Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange

Dernière rubrique modifiée : 2007-02-15

Les tâches suivantes sont accessibles via l'Assistant Dépannage de Microsoft® Exchange :

  • Utilitaire de résolution des problèmes de performances d'Exchange

  • Utilitaire de dépannage de base de données d'Exchange

  • Utilitaire de gestion de la récupération de bases de données d'Exchange

  • Utilitaire de résolution des problèmes de flux de messages d'Exchange

L'écran d'ouverture de l'Assistant Dépannage d'Exchange comporte deux sections :

  • un ensemble de sélections orientées sur les symptômes ;

  • un ensemble de sélections de fonctionnalités apparentées.

La section orientée sur les symptômes concerne la résolution des problèmes de performances, de flux de messages ou de base de données, comme les problèmes de montage de volumes de stockage. Les fonctions apparentées comprennent des éléments tels que le contrôle du suivi, la recherche dans le suivi des messages et la gestion de la récupération de bases de données.

Remarque :
Certaines options peuvent n'être disponibles que pour les serveurs Exchange 2007.
Remarque :
Vous devez installer l'Assistant Dépannage d'Exchange sur un poste ou un serveur exécutant une version anglaise des É.-U. du système d'exploitation Microsoft Windows®.


Installation de l'Assistant Résolution de problèmes de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

Pour installer l'Assistant Résolution de problèmes de Microsoft® Exchange, exécutez le fichier d'installation de Microsoft, ExTRA.msi, sur l'ordinateur sur lequel vous allez exécuter l'outil d'analyse. Par défaut, le fichier d'installation crée un répertoire appelé ExTRA dans <lecteur système>\Program Files\ et copie les fichiers requis dans ce nouveau répertoire.

Choix d'un ordinateur pour l'installation

Vous pouvez installer l'Assistant Résolution de problèmes d'Exchange sur le serveur qu'il analysera ou sur un autre serveur y ayant accès. Certaines fonctionnalités peuvent être désactivées lorsque l'Assistant est utilisé à distance.

Pour plus d'informations sur la procédure d'installation et l'utilisation d'un poste de gestion dédié, voir le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=21769).

Remarque :
Installez l'Assistant Résolution de problèmes d'Exchange sur un poste ou un serveur exécutant une version anglaise des États-Unis du système d'exploitation Microsoft Windows®.

Pour installer l'outil sur un ordinateur situé hors de l'organisation Exchange, vous devez définir de manière explicite les noms d'utilisateur et les mots de passe pour la connexion au service d'annuaire Active Directory® et aux serveurs Exchange.

Recherche de mises à jour

Lorsque vous lancez l'Assistant Résolution de problèmes d'Exchange, il peut chercher des mises à jour de l'outil ou des divers fichiers de configuration de l'analyseur, par exemple ExTRA.config.xml, ExPTA.config.xml ou ExDRA.config.xml. Toute combinaison de ces fichiers sera mise à jour et publiée en un seul module de mise à jour lors des cycles réguliers de publication via le Web ou sous forme d'une version ad hoc. S'il existe une nouvelle version, vous pouvez télécharger le nouveau fichier depuis la page référencée dans la procédure suivante. Vous devez être connecté à l'ordinateur en tant qu'administrateur pour télécharger les fichiers. Si vous choisissez de ne pas télécharger un nouveau fichier ou si l'outil ne peut pas accéder à Internet, il utilisera la copie du fichier qui réside sur l'ordinateur sur lequel vous l'exécutez.

Pour copier manuellement les nouvelles versions des fichiers de configuration

  1. Recherchez la page de mises à jour de Microsoft Exchange Troubleshooting Tool V1.0 sur http://go.microsoft.com/fwlink/?linkid=50424 dans votre navigateur Internet.

  2. Téléchargez le package autoextractible et extrayez les nouveaux fichiers dans un répertoire différent de celui où l'outil est installé (généralement C:\Program Files\ExTRA).

  3. Notez quels fichiers sont contenus dans le package de mise à jour.

  4. Renommez les fichiers existants concernés par la mise à jour.

  5. Copiez les fichiers extraits dans le répertoire d'installation de l'outil (généralement C:\Program Files\ExTRA).

Fonctions opérationnelles pendant l'analyse d'un ordinateur Exchange local uniquement

Ce tableau répertorie les fonctions opérationnelles uniquement dans le cadre de l'utilisation de l'Assistant Résolution de problèmes d'Exchange pour analyser l'ordinateur local sur lequel Exchange Server est installé.

Tâche | Symptôme ou fonction
Utilitaire de dépannage des performances Exchange | Symptôme : Le nombre d'opérations RPC par seconde est plus élevé que prévu.
Utilitaire de dépannage du flux des messages Exchange | Tous les symptômes observés lors de l'analyse d'un rôle de serveur de transport Edge Exchange Server 2007 qui n'est pas configuré pour utiliser le processus d'abonnement EdgeSync.
Utilitaire de gestion de la récupération de bases de données Exchange | Tâche de réparation de la base de données.


Procédure d'affichage d'un rapport précédent de l'Assistant Résolution de problèmes de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

Plutôt que de commencer une nouvelle analyse, vous souhaiterez peut-être utiliser l'Assistant Résolution des problèmes de Microsoft® Exchange pour afficher un rapport d'une analyse précédente.

Procédure

Pour afficher un rapport précédent de l'Assistant Résolution de problèmes d'Exchange

  1. Lancez l'Assistant Résolution de problèmes d'Exchange en exécutant ExTrA.exe ou en cliquant sur le lien approprié dans le menu Démarrer.

  2. Décidez si vous voulez télécharger les dernières mises à jour éventuellement disponibles.

  3. Sur la page Bienvenue, choisissez Sélectionner un fichier de résultats à afficher.

  4. Sélectionnez le rapport à afficher dans la liste de rapports stockés localement. L'outil crée la liste à partir des fichiers stockés dans <lecteur système>\Documents and Settings\<utilisateur>\Application Data\Microsoft\ExTRA. Lorsque vous cliquez sur un rapport, l'outil affiche des informations complémentaires sur sa taille et son nom, sur l'étiquette et sur la version de l'outil utilisé pour collecter les données. Vous pouvez également importer un rapport à partir d'un autre emplacement en cliquant sur Importer un fichier de résultats dans l'angle supérieur droit de la page.

  5. Cliquez sur Afficher un rapport pour afficher le rapport.


Fonctionnement de l'Assistant Dépannage d'Exchange Server
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

Généralement, les articles de l'Aide pour l'Assistant Dépannage de Microsoft® Exchange Server, dans la section Microsoft Exchange Server Analyzer - Articles, contiennent les informations détaillées sur la manière dont un outil particulier résout les problèmes liés à Exchange Server. Les articles sont regroupés en fonction des principaux domaines suivants de l'environnement Exchange :

  • Active Directory

  • Cluster Exchange

  • Serveur Exchange

  • Matériel

  • Réseau

  • Protocoles

  • Stockage

  • Logiciel tiers

  • Transport

  • Préparation d'Exchange Server 2007

Exemples d'articles et de leur contenu

Le deux exemples suivants présentent des articles sur l'analyseur ainsi qu'une brève description de leur approche pour décrire en détail la manière dont la résolution d'un problème particulier est effectuée.

Exemple 1 : Moteur de routage : paramètre de configuration défini par défaut

Dans la catégorie Transport, pour l'article « Moteur de routage : paramètre de configuration non défini par défaut », les informations de résolution de problème commencent par la lecture par l'outil Microsoft Exchange Server Analyzer d'une entrée de registre afin de déterminer si la valeur par défaut d'un paramètre a été modifiée. L'article contient une explication des causes possibles du message généré, puis fournit des instructions pour corriger le problème. Cela inclut une recommandation concernant l'utilisation de l'outil WinRoute pour afficher des informations sur l'état du lien.

Les articles sur l'analyseur incluent également des pointeurs vers des liens où vous pouvez obtenir des informations supplémentaires d'ordre général ou autre concernant ce problème.

Exemple 2 : Identification de l'utilisateur comme destination commune

L'article « Identification de l'utilisateur comme destination commune » figure dans la catégorie Transport et est l'un des articles relatifs à la résolution de problèmes de flux de messages. L'article montre que l'Assistant Dépannage d'Exchange utilise des requêtes WMI spécifiques pour obtenir des informations sur une file d'attente, puis applique certains seuils pour afficher un message d'erreur ou d'avertissement.

De même, d'autres articles fournissent des détails sur la logique sous-jacente pour chaque erreur et avertissement indiquant que l'Assistant Dépannage d'Exchange s'affiche lorsqu'il exécute la procédure de dépannage.


Présentation de l'outil Microsoft Exchange Performance Troubleshooting Analyzer Tool
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de résolution des problèmes de performances de Microsoft® Exchange localise et identifie les problèmes de performances pouvant affecter les serveurs qui exécutent Exchange Server. Pour trouver ces problèmes, il examine différents paramètres, journaux et saisies de données actives. Les rubriques suivantes fournissent davantage d'informations sur l'utilitaire de résolution des problèmes de performances d'Exchange :

  • Installation de l'Assistant Résolution de problèmes de Microsoft Exchange

  • Conditions préalables à l'exécution de l'utilitaire de résolution des problèmes de performances de Microsoft Exchange

  • Autorisations pour l'utilitaire de résolution des problèmes de performances de Microsoft Exchange

  • Lancement d'une analyse avec l'utilitaire de résolution des problèmes de performances de Microsoft Exchange

  • Présentation des résultats de l'utilitaire de résolution des problèmes de performances de Microsoft Exchange

Vos commentaires et suggestions concernant l'utilitaire de résolution des problèmes de performances d'Exchange sont les bienvenus.


Conditions préalables à l'exécution de l'utilitaire de résolution des problèmes de performances de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'outil Microsoft Exchange Performance Troubleshooting Analyzer Tool >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de résolution des problèmes de performances de Microsoft® Exchange est exécuté en mode client ou en mode serveur.

Conditions préalables

Pour que l'utilitaire de résolution des problèmes de performances d'Exchange fonctionne correctement, Microsoft .NET Framework 1.1 doit être installé sur l'ordinateur où il sera utilisé.

Environnements pris en charge

L'utilitaire de résolution des problèmes de performances d'Exchange peut être utilisé dans les environnements suivants :

  • Exchange Server 2003 (tous les Service Packs) sur Microsoft Windows Server 2003

  • Exchange Server 2003 (tous les Service Packs) sur Windows 2000 Service Pack (SP) 3 et versions ultérieures

  • Exchange 2000 Server SP3 et versions ultérieures sur Windows 2000 SP3 et versions ultérieures

Pour plus d'informations

Pour plus d'informations sur la procédure d'installation de l'utilitaire de résolution des problèmes de performances d'Exchange, voir la rubrique sur l'Installation de l'Assistant Résolution de problèmes de Microsoft Exchange.


Autorisations pour l'utilitaire de résolution des problèmes de performances de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'outil Microsoft Exchange Performance Troubleshooting Analyzer Tool >

Dernière rubrique modifiée : 2007-02-15

L'utilitaire de résolution des problèmes de performances de Microsoft® Exchange ne peut accéder au service d'annuaire Active Directory® et au serveur exécutant Exchange que si vous l'utilisez avec des informations d'identification qui disposent des autorisations requises.

Pour pouvoir utiliser l'utilitaire de résolution des problèmes de performances d'Exchange, vous devez disposer des autorisations suivantes :

  • autorisations Utilisateur de domaine ou supérieures sur le serveur de catalogue global spécifié à l'étape des connexions ;

  • membre du groupe Administrateur local sur chaque serveur à analyser exécutant Exchange. Ces autorisations sont requises pour accéder à Microsoft Windows® Management Instrumentation (WMI), au registre et aux données de performances.

Si les informations d'identification de l'utilisateur actuellement connecté ne disposent pas de toutes les autorisations nécessaires pour accéder à la fois à Active Directory et au serveur exécutant Exchange, le nom d'utilisateur, le domaine et le mot de passe peuvent être remplacés depuis l'outil.

Pour plus d'informations

Pour plus d'informations sur la procédure d'installation de l'utilitaire de résolution des problèmes de performances d'Exchange, voir la rubrique sur l'installation de l'utilitaire de résolution des problèmes de performances de Microsoft Exchange.

Pour plus d'informations sur les conditions préalables à l'exécution de cet outil, voir la rubrique sur les Conditions préalables à l'exécution de l'utilitaire de résolution des problèmes de performances de Microsoft Exchange.


Lancement d'une analyse avec l'utilitaire de résolution des problèmes de performances de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'outil Microsoft Exchange Performance Troubleshooting Analyzer Tool >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de résolution des problèmes de performances de Microsoft® Exchange collecte des données provenant de différentes sources pour fournir un conseil de remédiation. Les données sont collectées en plusieurs étapes, puis analysées. Selon les résultats de chaque étape, une collecte de données supplémentaires peut s'avérer nécessaire. Certaines des données, telles que le symptôme, exigent une saisie de la part de l'utilisateur. Les autres données sont collectées automatiquement sur le serveur qui pose problème.

Sélection du symptôme

Comme première étape de l'analyse, l'utilitaire de résolution des problèmes de performances d'Exchange demande le symptôme. En fonction du symptôme, la résolution du problème peut s'effectuer en plusieurs étapes.

Symptômes

  • Le nombre d'opérations RPC par seconde est supérieur au nombre attendu.

    Sélectionnez ce symptôme si le serveur exécutant Exchange semble plus occupé qu"il ne devrait. Dans le cadre de la procédure de résolution, l'outil Microsoft Exchange User Monitor (ExMon) suit les appels de procédure distante (RPC) de Microsoft Office® Outlook et d'autres clients MAPI. Si l'l'utilitaire de résolution des problèmes de performances d'Exchange détecte une charge des utilisateurs anormalement élevée, il isole la source du problème, par exemple un utilisateur individuel, qui est à l'origine du problème de performances du serveur.

  • Plusieurs utilisateurs se plaignent de retards lorsqu'ils utilisent Outlook ou voient fréquemment la boîte de dialogue annulable des RPC Outlook.

    Sélectionnez ce symptôme si des utilisateurs observent des retards inacceptables lors d'opérations dans le client Outlook. Par exemple, si des retards importants sont observés lorsque les utilisateurs passent d'un dossier à un autre, comme de la Boîte de réception vers le Calendrier. Certaines versions du client Outlook affichent une fenêtre Demande des données si le serveur ne répond pas rapidement à une demande client. Ces problèmes sont généralement dus à la charge du serveur ou à un goulet d'étranglement sur le serveur même. L'utilitaire de résolution des problèmes de performances d'Exchange isole la source du goulot d'étranglement.

Une liste de recommandations s'affiche sur la page de résultats lorsque l'utilitaire de résolution des problèmes de performances d'Exchange a terminé son analyse.

Collecte des données

Les référentiels de données suivants sont utilisés pour obtenir des paramètres de configuration :

  • service d'annuaire Active Directory® ;

  • Microsoft Windows® Management Instrumentation (WMI) ;

  • registre.

L'outil saisit en outre des données actives pour isoler la cause première des problèmes de performances. Les référentiels de données suivants sont utilisés pour obtenir des données en temps réel :

  • Bibliothèque de l'Assistant Performance des données

  • Données de suivi provenant de l'outil Microsoft Exchange Server User Monitor (ExMon) Tool

Pour les données en temps réel, des échantillons proviennent des compteurs et des fichiers journaux sur une période donnée. Ce type de collecte peut prendre plusieurs minutes.

Pour plus d'informations

Pour plus d'informations sur l'utilitaire de résolution des problèmes de performances d'Exchange, voir la rubrique sur la Présentation de l'outil Microsoft Exchange Performance Troubleshooting Analyzer Tool.

Pour plus d'informations sur le résultat de cet outil, voir la rubrique sur la Présentation des résultats de l'utilitaire de résolution des problèmes de performances de Microsoft Exchange.


Présentation des résultats de l'utilitaire de résolution des problèmes de performances de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'outil Microsoft Exchange Performance Troubleshooting Analyzer Tool >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de résolution des problèmes de performances de Microsoft® Exchange produit un rapport qui présente les résultats des données collectées au cours d'une analyse du serveur. Vous pouvez choisir parmi cinq types d'affichages :

  • Liste de problèmes critiques Présente les problèmes constituant des causes premières et d'autres facteurs pouvant affecter les performances

  • Affichage détaillé Présente une structure arborescente contenant toutes les données collectées pendant l'analyse

  • Liste complète des problèmes Présente les causes premières et d'autres suggestions pour résoudre les problèmes de performances

  • Journal Runtime Affiche le statut de traitement interne de l'outil

  • Affichage résumé Présente une structure arborescente contenant toutes les recommandations

Dans la Liste de problèmes critiques et la Liste complète des problèmes, vous pouvez cliquer sur n'importe quelle erreur ou avertissement pour afficher une explication. Vous pouvez ensuite cliquer sur En savoir plus sur ce problème et sa résolution pour obtenir des informations plus détaillées.

Dans la fenêtre de rapport, vous pouvez choisir d'imprimer ou d'exporter les données collectées. Les formats d'exportation pris en charge comprennent le XML, le HTML et le CSV.

Remarque :
Toutes les données collectées sont conservées dans un fichier de sortie XML situé dans <lecteur système>\Documents and Settings\<utilisateur>\Application Data\Microsoft\ExPTA.

Dans certains cas, vous souhaiterez peut-être afficher le rapport d'une analyse antérieure plutôt que de lancer une nouvelle analyse. Pour apprendre la procédure d'affichage d'un rapport antérieur, voir la rubrique sur la Procédure d'affichage d'un rapport précédent de l'Assistant Résolution de problèmes de Microsoft Exchange.


Présentation de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de résolution des problèmes de flux de messages de Microsoft® Exchange est un outil de diagnostic qui aide les clients dans les fonctions suivantes :

  • En partant des symptômes liés au flux de messages, orientez les clients vers la procédure de résolution correcte.

  • Fournissez un accès aisé à diverses sources de données requises pour résoudre les problèmes de flux de messages.

  • Diagnostiquez automatiquement les données récupérées et présentez une analyse des causes premières possibles.

  • Suggérez des actions de résolution du problème.

  • Par des conseils, aidez les utilisateurs à diagnostiquer manuellement les données lorsqu'un diagnostic automatique n'est pas possible.

Vos commentaires et suggestions concernant l'utilitaire de résolution des problèmes de flux de messages d'Exchange sont les bienvenus. Vous pouvez les envoyer comme suit :

  • Groupes de discussion publics de Microsoft Des membres de l'équipe de développement de l'utilitaire de résolution des problèmes de flux de messages d'Exchange contrôlent régulièrement les groupes de discussion sur le site d'Exchange Server et d'Outlook à l'adresse http://go.microsoft.com/fwlink/?linkid=14926.

  • Pour plus d'informations sur la procédure de participation à ce groupe ou à tout autre groupe de discussion Microsoft, voir le site Web de Microsoft Exchange Analyzers (http://go.microsoft.com/fwlink/?linkid=33938) et le site Web des groupes de discussion du Support Technique de Microsoft (http://go.microsoft.com/fwlink/?LinkId=50219).


Conditions préalables à l'emploi de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

Conditions préalables à l'emploi de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange |
 | Voir aussi
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange >

Dernière rubrique modifiée : 2006-08-11

L'utilitaire de résolution des problèmes de flux de messages de Microsoft® Exchange fonctionne soit en mode client, soit en mode serveur.

Les ordinateurs de l'organisation Exchange doivent satisfaire à plusieurs conditions préalables pour que vous puissiez employer l'utilitaire de résolution des problèmes de flux de messages d'Exchange. Si ces exigences ne sont pas satisfaites, l'outil devrait malgré tout fonctionner dans bien des cas, mais sans offrir toutes ses fonctionnalités ou avec des performances dégradées.

Cette rubrique contient des informations sur les conditions préalables et sur les environnements pris en charge pour exécuter l'utilitaire de résolution des problèmes de flux de messages d'Exchange.

Conditions préalables

Pour que l'utilitaire de résolution des problèmes de flux de messages d'Exchange fonctionne correctement, Microsoft .NET Framework 1.1 doit être installé sur l'ordinateur où il sera utilisé.

Environnements pris en charge

Important :
Si votre topologie Exchange Server inclut Exchange Server 2007 (y compris les versions pré-commerciales), l'utilitaire de résolution des problèmes de flux de messages d'Exchange peut ne pas fonctionner correctement ou certaines fonctions pourraient ne pas être disponibles.

L'utilitaire de résolution des problèmes de flux de messages d'Exchange peut être utilisé dans les environnements suivants :

  • Exchange Server 2003 (tous les Service Packs) sur Microsoft Windows Server 2003

  • Exchange Server 2003 (tous les Service Packs) sur Windows 2000 Server Service Pack SP3 et versions ultérieures

  • Exchange 2000 Server SP3 et versions ultérieures sur Windows 2000 Server SP3 et versions ultérieures

Remarque :
Certaines fonctions de l'utilitaire de résolution des problèmes de flux de messages d'Exchange peuvent n'être disponibles qu'avec Exchange Server 2003. En effet, Exchange 2000 Server et Windows Server 2000 offrent moins d'interfaces permettant de récupérer des données qu'Exchange Server 2003 et Windows Server 2003.

Voir aussi

Concepts

Autorisations pour l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

© 2007 Microsoft Corporation. Tous droits réservés.


Autorisations pour l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

Autorisations pour l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange |
 | Voir aussi
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-15

L'utilitaire de résolution des problèmes de flux de messages de Microsoft® Exchange ne peut accéder au service d'annuaire Active Directory® et aux serveurs Exchange que si vous l'utilisez avec des informations d'identification qui disposent des autorisations requises.

Autorisations

Pour pouvoir employer l'utilitaire de résolution des problèmes de flux de messages d'Exchange, vous devez disposer des autorisations suivantes :

  • Administrateur de domaine ou membre du groupe Builtin\Administrateurs sur le serveur Active Directory pour énumérer les informations Active Directory et appeler les fournisseurs WMI (Windows® Management Instrumentation) Microsoft sur le contrôleur de domaine et les serveurs de catalogue global ;

  • membre du groupe Administrateur local sur chaque serveur Exchange pour appeler les fournisseurs WMI et accéder au Registre et à la métabase ;

  • autorisations déléguées au moins Exchange - Affichage seul sur l'organisation Exchange.

Si vous vous connectez à l'ordinateur où vous allez exécuter l'utilitaire de résolution des problèmes de flux de messages d'Exchange avec un compte qui ne dispose pas des autorisations suffisantes, vous devez définir les informations d'identification des comptes que vous allez utiliser dans la page Entrer des informations relatives au serveur et à l'utilisateur dans l'outil. Cliquez sur Afficher les options de connexion avancées pour développer les options. Vous ne pouvez entrer qu'un seul compte. Par conséquent, assurez-vous que le compte dispose de toutes les autorisations requises.

Voir aussi

Concepts

Conditions préalables à l'emploi de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

© 2007 Microsoft Corporation. Tous droits réservés.


Lancement d'une analyse avec l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

Lancement d'une analyse avec l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange |
 | Voir aussi
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange >

Dernière rubrique modifiée : 2006-08-10

L'utilitaire de résolution des problèmes de flux de messages de Microsoft® Exchange collecte des données provenant de différentes sources pour fournir un conseil de remédiation. Les données sont collectées en plusieurs étapes, puis analysées. Selon les résultats de chaque étape, une collecte de données supplémentaires peut s'avérer nécessaire. Certaines des données, telles que le symptôme, exigent une saisie de la part de l'utilisateur. Les autres données sont collectées automatiquement sur le serveur qui pose problème.

Sélection du symptôme

Comme première étape de l'analyse, l'utilitaire de résolution des problèmes de flux de messages d'Exchange demande le symptôme observé. En fonction du symptôme, la résolution du problème peut s'effectuer en plusieurs étapes.

Symptômes

  • Les utilisateurs se plaignent de recevoir des rapports de non remise lorsqu'ils envoient des messages.

    Sélectionnez ce symptôme si des messages sont renvoyés et que des rapports de non remise (NDR) sont retournés aux expéditeurs. Des rapports de non-remise peuvent être retournés de l'extérieur de l'organisation Exchange d'entreprise ou de l'intérieur de celle-ci. L'utilitaire de résolution des problèmes de flux de messages d'Exchange tentera d'aider les utilisateurs à déterminer la procédure de résolution appropriée pour ce symptôme. Attention : les causes premières pouvant être extérieures à Exchange Server, l'aide à la résolution de problèmes est très importante.

  • Les messages provenant d'expéditeurs externes via l'Internet sont retardés ou ne sont pas reçus par certains destinataires.

    Ce symptôme et le suivant sont similaires. Sélectionnez ce symptôme si les messages ne parviennent pas à l'organisation Exchange Server de l'entreprise ou s'ils ne passent pas les serveurs Gatyeway non-Exchange en périphérie. L'utilitaire de résolution des problèmes de flux de messages d'Exchange examine à la fois l'intérieur de l'organisation Exchange Server et la passerelle.

  • Les messages envoyés à des destinataires externes sur l'Internet sont retardés ou ne sont pas envoyés à certains destinataires.

    Sélectionnez ce symptôme si les messages à remettre à l'extérieur de l'organisation Exchange Server de l'entreprise restent dans cette organisation ou s'ils ne passent pas les serveurs Gateway non-Exchange en périphérie. L'utilitaire de résolution des problèmes de flux de messages d'Exchange examine à la fois l'intérieur de l'organisation Exchange Server et la passerelle (comme pour le symptôme précédent).

  • Les messages s'accumulent dans une ou plusieurs files d'attente du serveur.

    Sélectionnez ce sympôme si les messages restent dans les files d'attente d'Exchange Server, notamment la file d'attente de remise distante, la file des messages en attente d'une recherche dans l'annuaire et la file d'attente de remise locale. L'accumulation affecte aussi bien les messages routés au sein de la même organisation Exchange Server que les messages provenant d'Internet et envoyés vers Internet, selon le chemin de routage des messages. La résolution de ce symptôme peut donc couvrir les second et troisième problèmes mentionnés dans cette liste de symptômes.

  • Les utilisateurs rapportent que les messages s'accumulent dans leur Boîte d'envoi (pour Exchange Server 2007 uniquement).

    Sélectionnez ce symptôme si les messages restent sur le serveur de boîtes aux lettres de l'utilisateur et ne sont pas transférés vers d'autres serveurs. L'utilitaire de résolution des problèmes de flux de messages d'Exchange tentera d'examiner tant le rôle de boîte aux lettres que le rôle de transport Hub.

Lorsque vous choisissez ce symptôme, l'analyseur demande d'identifier le serveur et l'utilisateur, puis commence l'analyse. Une liste de recommandations s'affiche sur la page de résultats lorsque l'utilitaire de résolution des problèmes de flux de messages d'Exchange a terminé son analyse.

Collecte des données

L'utilitaire de résolution des problèmes de flux de messages d'Exchange collecte des données auprès de différentes sources. Les référentiels de données suivants sont utilisés pour obtenir des paramètres de configuration :

  • service d'annuaire Active Directory® ;

  • Microsoft Windows® Management Instrumentation (WMI) ;

  • registre.

L'outil saisit en outre des données actives pour isoler la cause première des problèmes de flux de messages. Le référentiel de données Assistant Performance des données est utilisé pour obtenir des données en temps réel :

Pour les données en temps réel, des échantillons proviennent des compteurs et des fichiers journaux sur une période donnée. Ce type de collecte peut prendre plusieurs minutes.

Voir aussi

Concepts

Présentation de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange
Présentation des résultats de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

© 2007 Microsoft Corporation. Tous droits réservés.


Présentation des résultats de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

Présentation des résultats de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange |
 | Voir aussi
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de résolution des problèmes de flux de messages de Microsoft® Exchange produit des rapports qui présentent les résultats des données collectées au cours d'une analyse du serveur. Vous avez le choix entre trois types de rapports :

  • Rapports de liste, comprenant :

    • Aperçu Affiche l'état global des serveurs analysés

    • Causes premières Affiche les causes premières possibles des problèmes identifiés

    • Problèmes de flux de messages Affiche les problèmes critiques susceptibles d'affecter le flux des messages

    • Autres erreurs Affiche les problèmes de flux autres que ceux liés aux messages

    • Avertissement Affiche les situations qui ne sont généralement pas recommandées

    • Recommandations Affiche les recommandations connues

    • Éléments d'information Affiche les éléments autres que les problèmes

  • Rapports d'arborescence, comprenant :

    • Affichage détaillé Présente une structure arborescente contenant toutes les données collectées pendant l'analyse

    • Affichage résumé Présente une structure arborescente contenant les causes premières, erreurs, avertissements, éléments intéressants et recommandations

  • Autres rapports, comprenant :

    • Journal Runtime Affiche le statut de traitement interne de l'outil

Dans les Rapports de liste, vous pouvez cliquer sur n'importe quelle erreur ou avertissement pour afficher une explication. Vous pouvez ensuite cliquer sur En savoir plus sur ce problème et sa résolution pour obtenir des informations plus détaillées.

Dans la fenêtre de rapport, vous pouvez choisir d'imprimer ou d'exporter les données collectées. Les formats d'exportation pris en charge comprennent le XML, le HTML et le CSV.

Remarque :
Toutes les données collectées sont conservées dans un fichier de sortie XML dans <lecteur système>\Documents and Settings\<utilisateur>\Application Data\Microsoft\ExMFA.

Voir aussi

Concepts

Lancement d'une analyse avec l'utilitaire de résolution des problèmes de flux de messages de Microsoft Exchange

© 2007 Microsoft Corporation. Tous droits réservés.


Présentation de l'utilitaire de gestion de la récupération de bases de données de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de gestion de la récupération de bases de données de Microsoft® Exchange analyse les bases de données d'Exchange Server et les fichiers journaux de transactions disponibles à la recherche de problèmes affectant la possibilité de récupération des bases de données. Il signale les fichiers journaux manquants ou endommagés et recommande des actions pour mettre la base de données dans un état propre, montable.

L'utilitaire de gestion de la récupération de bases de données d'Exchange comprend les fonctions suivantes :

  • un utilitaire de résolution des problèmes de montage des bases de données en raison de conditions qui empêchent de relire correctement le journal des transactions ;

  • un Assistant pour déplacer en toute sécurité les fichiers journaux de transactions afin de résoudre les situations où le lecteur contenant les journaux est saturé ;

  • un filtre de journal des événements et un afficheur permettant de consulter et trier facilement les événements liés aux bases de données Exchange ;

  • pour Exchange 2007 uniquement, un gestionnaire de groupes de stockage de récupération pour créer et supprimer des groupes de stockage de récupération. Le gestionnaire peut aussi fusionner le contenu de boîtes aux lettres dans les boîtes aux lettres d'origine ou d'archivage.

Vos commentaires, questions et suggestions concernant l'utilitaire de gestion de la récupération de bases de données d'Exchange sont les bienvenus. Vous pouvez les envoyer comme suit :

  • Groupes de discussion publics de Microsoft Des membres de l'équipe de développement de l'utilitaire de gestion de la récupération de bases de données d'Exchange contrôlent régulièrement le groupe de discussion microsoft.public.exchange.tools sur le site news.microsoft.com. Pour plus d'informations sur la participation à ce groupe ou à tout autre groupe de discussion Microsoft, voir le site Web des groupes de discussion du Support Technique de Microsoft (http://go.microsoft.com/fwlink/?LinkId=50219).

  • Commentaires sur la documentation de l'utilitaire de gestion de la récupération de bases de données d'Exchange Si vous avez des commentaires ou des questions sur la documentation et les articles relatifs à l'utilitaire de gestion de la récupération de bases de données d'Exchange, envoyez-les-nous à extoolfb@microsoft.com.


Conditions préalables à l'emploi de l'utilitaire de gestion de la récupération de bases de données de Microsoft Exchange
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'utilitaire de gestion de la récupération de bases de données de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de gestion de la récupération de bases de données de Microsoft® Exchange s'exécute en deux modes : Détection automatique ou Saisie manuelle. En mode Détection automatique, l'utilitaire de gestion de la récupération de bases de données d'Exchange peut accéder aux informations de configuration du service d'annuaire Microsoft Active Directory® d'un serveur Exchange et localiser automatiquement les fichiers de journaux de transactions et de bases de données aux emplacements configurés. En mode Saisie manuelle, vous pouvez spécifier des chemins de fichiers explicites pour les fichiers journaux de transactions et de bases de données.

Conditions préalables

  • En mode Détection automatique, vous devez posséder les autorisations requises dans Active Directory pour lire les informations de configuration d'Exchange et vous devez posséder des autorisations de lecture et écriture sur le serveur Exchange pour les dossiers où sont stockées les données d'Exchange.

  • Pour que l'utilitaire de gestion de la récupération de bases de données d'Exchange fonctionne correctement, .NET Framework 1.1 doit être installé sur l'ordinateur sur lequel cet outil sera utilisé.

  • Vous pouvez employer l'utilitaire de gestion de la récupération de bases de données d'Exchange sur des ordinateurs exécutant Microsoft Windows 2000 Server, Microsoft Windows Server 2003 et Microsoft Windows XP.

Environnements pris en charge

Vous pouvez exécuter l'utilitaire de gestion de la récupération de bases de données d'Exchange dans les environnements suivants :

  • Exchange 2000 Server SP3 et supérieur sur Windows 2000 Server SP3 et supérieur

  • Exchange Server 2003 (tous les Service Packs) sur Windows 2000 Server SP3 et versions ultérieures

  • Exchange Server 2003 (tous les Service Packs) sur Windows Server 2003


Effet sur les performances de l'outil Microsoft Exchange Disaster Recovery Analyzer Tool
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'utilitaire de gestion de la récupération de bases de données de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

L'utilitaire de gestion de la récupération de bases de données de Microsoft® Exchange exerce un effet minimal sur les performances du service d'annuaire Active Directory® ou sur les performances d'un serveur Exchange. L'utilitaire de gestion de la récupération de bases de données d'Exchange lit les informations d'en-tête au début des fichiers de base de données et fichiers journaux de transactions et analyse ces fichiers pour en vérifier l'intégrité. L'utilitaire de gestion de la récupération de bases de données d'Exchange opère entièrement en lecture seule et ne modifie pas les fichiers de base de données ni les fichiers journaux de transactions.


Le Centre de tâches
Aperçu de l'Assistant Résolution de problèmes de Microsoft Exchange > Présentation de l'utilitaire de gestion de la récupération de bases de données de Microsoft Exchange >

Dernière rubrique modifiée : 2007-02-16

La page Centre de tâches est le cœur de l'utilitaire de gestion de la récupération de bases de données de Microsoft® Exchange. C'est là que vous sélectionnez le symptôme ou la tâche à résoudre. Avant d'accéder à la page Centre de tâches, vous devez sélectionner un serveur de travail ou le mode manuel.

Les options qui apparaissent dans le Centre de tâches dépendent du serveur de travail choisi. Les options non pertinentes ne sont pas affichées. Par exemple, si vous décidez de travailler sur un serveur Exchange Server 2003, les fonctions qui ne marchent qu'avec un serveur Exchange Server 2007 seront masquées.

Les fonctions suivantes sont disponibles dans le Centre de tâches.

  • Résoudre un problème de montage de base de données

    Cet utilitaire de résolution de problèmes lit le fichier journal Applications du serveur Exchange pour établir un premier diagnostic des problèmes du serveur. S'il rencontre plusieurs problèmes, vous pouvez sélectionner le problème à résoudre en premier. Une analyse complémentaire est alors effectuée pour confirmer le problème et vous aider à le corriger.

  • Analyser l'espace disque des journaux

    Cet Assistant vérifie l'espace qu'occupent les fichiers journaux de transactions disponibles pour chaque groupe de stockage sur le serveur et vous aide à déplacer les journaux vers un emplacement de sauvegarde si vous manquez d'espace disque.

    Si un groupe de stockage Exchange Server ne possède plus assez d'espace disque pour ses fichiers journaux de transactions, les bases de données sont arrêtées. Vous ne pouvez pas redémarrer les bases de données avant d'avoir résolu le problème d'espace disque. Si vous supprimez les mauvais fichiers journaux, vous risquez de rendre vos bases de données définitivement impossibles à démarrer. L'utilitaire de gestion de la récupération de bases de données d'Exchange déterminera quels fichiers journaux peuvent être déplacés sans crainte et les déplacera vers un emplacement de sauvegarde sur un autre lecteur ou serveur. Ne supprimez pas de fichiers journaux déplacés avant d'avoir effectué une nouvelle sauvegarde complète et réussie de toutes les bases de données du groupe de stockage.

  • Afficher les journaux d'événements liés aux bases de données

    Divers événements d'erreur et d'avertissement enregistrés dans le fichier journal des applications peuvent être associés à un problème de base de données. Il peut être difficile d'observer « l'histoire » que décrivent ces événements apparentés. Cette fonction de l'analyseur filtre les événements liés à la base de données Exchange et les présente dans un format facile à analyser et à trier.

  • Gestionnaire de groupes de stockage de récupération pour Exchange 2007

    La console de gestion Exchange pour Exchange 2007 ne comporte pas de fonctions de gestion des groupes de stockage de récupération. À la place, vous pouvez lancer la gestion des groupes de stockage de récupération à partir de la ligne de commande Windows PowerShell ou du Gestionnaire de groupes de stockage de récupération de cet analyseur.

    Le Gestionnaire de groupes de stockage de récupération améliore l'interface d'Exchange 2003 pour la gestion des groupes de stockage de récupération en réunissant toutes les tâches de gestion en un seul endroit. Il prend également en charge la copie du contenu des boîtes aux lettres depuis le Groupe de stockage de récupération vers la boîte aux lettres d'origine ou vers une autre boîte aux lettres sans l'intermédiaire d'un fichier .pst. La fonction de fusion peut aussi servir à copier le contenu de plusieurs boîtes aux lettres en une seule boîte aux lettres d'archivage.

  • Réparation de la base de données

    Cet Assistant exécute automatiquement une réparation et une défragmentation de base de données. Il exécute aussi Isinteg sur une base de données endommagée, puis tente de lui rendre un état cohérent. Cette fonction n'est disponible que lorsque l'outil est exécuté sur l'ordinateur local.

  • Réinitialisation du numéro de génération de journal

    Cet Assistant déplace les fichiers journaux des transactions existants vers un emplacement de sauvegarde qui permet de monter les bases de données avec de nouveaux numéros de génération de journal. Cet Assistant exige que toutes les bases de données du groupe de stockage soient démontées et n'est disponible que pour Exchange 2000 Server et Exchange Server 2003.


Microsoft Exchange Server Analyzer - Articles

Dernière rubrique modifiée : 2006-10-06

Les articles de cette section correspondent aux règles et aux messages créés par les outils Microsoft® Exchange Server Analyzers suivants :

  • Exchange Best Practices Analyzer

  • Assistant Dépannage d'Exchange

L'Assistant Dépannage d'Exchange donne accès aux fonctionnalités suivantes :

  • Utilitaire de dépannage des performances Exchange

  • Utilitaire de dépannage de base de données Exchange

  • Utilitaire de gestion de la récupération de bases de données Exchange

  • Utilitaire de dépannage du flux des messages Exchange

Chaque article décrit une erreur, un avertissement ou un message indiquant une configuration autre que celle par défaut pouvant être détecté par Exchange Server Analyzer.

La page Web Microsoft Exchange Analyzers http://go.microsoft.com/fwlink/?linkid=34707 propose des téléchargements des versions actuelles d'Exchange Best Practice Analyzer et de l'Assistant Dépannage d'Exchange. En outre, la page contient des informations sur la configuration requise et le lien d'un groupe de discussion consacré aux analyseurs.

Si vous travaillez dans un environnement où vous ne pouvez pas utiliser la fonctionnalité de mise à jour automatique de l'outil Exchange Best Practices, vous pouvez accéder à la page Web du pack de mise à jour Web de Microsoft Exchange Best Practices Analyzer à l'adresse URL http://go.microsoft.com/fwlink/?linkid=34290. Vous pouvez télécharger ici les derniers fichiers de configuration et d'aide.

Remarque :
Si les mises à jour sont appliquées automatiquement, vous ne devez pas utiliser ce téléchargement.


Active Directory
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-17

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant le service d'annuaire Active Directory®. En outre, ils décrivent les actions possibles pour corriger les erreurs liées à Active Directory, les avertissements et les configurations autres que celles par défaut détectés par Exchange Server Analyzer.


Le serveur Active Directory Connector est arrêté ou inaccessible
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool utilise des appels de procédure distante (RPC) pour lire la valeur de chaîne CurrentVersion de la clé de Registre suivante sur le serveur Active Directory Connector (ADC) :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Sur un ordinateur Microsoft Windows® 2000 Server, la valeur de la chaîne CurrentVersion prévue est 5.0. Sur un ordinateur Microsoft Windows Server™ 2003, la valeur prévue est 5.2.

Si Exchange Server Analyzer ne peut pas lire cette valeur de Registre pour une raison ou pour une autre, une erreur s'affiche.

Pour corriger cette erreur

  1. Assurez-vous que le serveur ADC a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour déterminer si le serveur ADC est accessible.

  3. Si un pare-feu est installé, vérifiez que les ports RPC sont bloqués.

  4. Assurez-vous que le service Registre distant a été démarré sur le serveur ADC.

  5. Vérifiez les autorisations pour le compte qui utilise Exchange Server Analyzer pour vous assurer qu'elles sont suffisantes pour lire le Registre sur le serveur ADC.

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, voir les documents suivants :

  • Article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • Rubrique sur la résolution des problèmes de connectivité par l'outil Microsoft Exchange Server Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285)


Le serveur Active Directory Connector n'exécute pas tous les accords de connexion et est candidat pour la suppression
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchChildSyncAgreements qui représente les accords de connexion en cours d'exécution sur un serveur ADC. Cet attribut est une chaîne à valeurs multiples et est défini sur l'objet Active Directory suivant : CN=Active_Directory_Connector_(nom_serveur),CN=Paramètres_Exchange,CN=Nom_serveur,CN=Serveurs,CN=Nom_site,CN=Sites,CN=Configuration,DC=Domaine,DC=com

Exchange Server Analyzer extrait le nombre d'entrées de cet attribut. Le nombre 0 indique qu'aucun accord de connexion n'est exécuté. Un avertissement s'affiche.

S'il s'avère que tous les accords de connexion requis sont exécutés sur d'autres serveurs ADC, le service ADC sur ce serveur doit être supprimé ou désactivé. L'exécution du service ADC sans accord de connexion n'entraîne pas de problème. Toutefois, il est recommandé de ne pas exécuter les services s'ils ne sont pas requis. Par conséquent, vous devez désactiver le service ADC sur ce serveur ADC ou le désinstaller.

Pour supprimer cet avertissement

  1. Pour désactiver le service ADC sur le serveur exécutant ADC, cliquez avec le bouton droit sur Poste de travail sur le Bureau, puis cliquez sur Gérer.

  2. Développez le nœud Services et applications, puis cliquez sur le nœud Services.

  3. Dans le volet droit, cliquez avec le bouton droit sur Connecteur Microsoft Active Directory et cliquez sur Propriétés.

  4. Modifiez Type de démarrage en Désactivé. Au prochain démarrage de l'ordinateur, le service ADC ne sera pas lancé.

  5. Cliquez sur Appliquer, puis sur OK.

Pour désinstaller le service ADC, vous pouvez utiliser le CD-ROM de Microsoft Exchange 2000 Server ou d'Exchange Server 2003. Accédez au dossier \ADC\I386 et double-cliquez sur le programme Setup.exe. Suivez les invites pour désinstaller le service ADC.

Pour plus d'informations sur Active Directory Connector, voir la Webdiffusion suivante du Support Technique de Microsoft sur

  • la webdiffusion Support et l'introduction à Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300)

  • sur la webdiffusion Support et Microsoft Advanced Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221)

  • Pour plus d'informations sur l'installation et la configuration d'Active Directory Connector, voir l'article 312632 de la Base de connaissances Microsoft sur la procédure d'installation et de configuration d'Active Directory Connector dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


Le serveur Active Directory Connector n'exécute pas le dernier Service Pack pour Windows 2000 Server
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool examine la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé ServicePackMajorVersion sur le serveur Active Directory Connector (ADC). Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows qui s'exécute sur le serveur ADC :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si Exchange Server Analyzer détermine que le serveur ADC utilise un système d'exploitation Microsoft Windows 2000 Server sans exécuter le Service Pack 4 (SP4) pour Windows 2000 Server, un avertissement s'affiche.

Microsoft recommande d'utiliser les derniers Service Packs pour tous les logiciels de votre déploiement Exchange, notamment les serveurs ADC.

Pour corriger cette erreur

  1. Mettez à jour le serveur ADC et tous les autres serveurs qui utilisent un système d'exploitation Windows 2000 Server vers le SP4, ainsi que les derniers correctifs et mises à jour de Windows Update.

  2. Mettez à jour tous les autres ordinateurs Exchange Server utilisant un système d'exploitation Windows 2000 Server vers le Service Pack et les correctifs les plus récents.

Pour plus d'informations sur l'obtention et l'installation des Service Packs pour les systèmes d'exploitation Windows 2000 Server, voir le site http://go.microsoft.com/fwlink/?LinkId=18353.

Pour plus d'informations sur l'obtention et l'installation des Service Packs et correctifs d'Exchange Server, voir le site http://go.microsoft.com/fwlink/?LinkId=21573.


Le serveur Active Directory Connector est peut-être surchargé
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchChildSyncAgreements qui représente les accords de connexion actifs sur un serveur ADC. Cet attribut est une chaîne à valeurs multiples et est défini sur l'objet Active Directory suivant : CN=Active_Directory_Connector_(nom_serveur),CN=Paramètres_Exchange,CN=Nom_serveur,CN=Serveurs,CN=Nom_site,CN=Sites,CN=Configuration,DC=Domaine,DC=com

Exchange Server Analyzer extrait le nombre d'entrées de cet attribut. Si le nombre est supérieur à 80, un avertissement s'affiche.

Il est recommandé d'utiliser moins de 80 accords de connexion par serveur ADC. Si d'autres serveurs ADC n'hébergent pas le nombre maximal recommandé d'accords de connexion, déplacez certains accords de connexion de ce serveur vers l'autre serveur ADC. Si vous n'avez pas d'autres serveurs ADC, installez le programme ADC fourni avec Microsoft Exchange 2000 Server ou Exchange Server 2003 sur un autre ordinateur exécutant Microsoft Windows® 2000 Server ou Windows Server™ 2003.

Notez que lorsque vous déplacez un accord de connexion d'un serveur ADC vers un autre, les attributs principaux de l'accord de connexion en question ne changent pas. Par exemple, les conteneurs source et destination utilisés pour la réplication, ainsi que les données, qui ont été configurés restent inchangés. Lorsque vous déplacez un accord de connexion, seul le serveur ADC qui exécutait l'accord de connexion change.

Pour supprimer cet avertissement

  1. Cliquez sur Démarrer, puis sur Programmes, pointez sur Outils d'administration, puis cliquez sur Gestion du Connecteur Active Directory pour ouvrir la console Gestion ADC.

  2. Le volet gauche de la console MMC affiche une liste de serveurs qui exécutent le service ADC. Sélectionnez ADC pour le serveur sur lequel se trouve l'accord de connexion à déplacer.

  3. Le volet Détails de la console MMC affiche les accords de connexion hébergés sur le serveur ADC sélectionné.

  4. Cliquez avec le bouton droit sur l'accord de connexion à déplacer, puis cliquez sur Propriétés.

  5. Sous l'onglet Général, dans la liste déroulante Sélectionnez un serveur pour exécuter l'accord de connexion, sélectionnez le serveur sur lequel vous souhaitez exécuter cet accord de connexion, puis cliquez sur OK.

  6. Sous Se connecter en tant que (serveur Windows), entrez le nom du compte et le mot de passe du service ADC, puis cliquez sur OK.

  7. Sous Se connecter en tant que (serveur Exchange), entrez le compte et le mot de passe du service Exchange, puis cliquez sur OK.

Pour plus d'informations sur le déplacement d'accords de connexion, voir l'article 326060 de la Base de connaissances Microsoft sur la procédure de déplacement d'un accord de connexion vers un autre serveur (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=326060).

Pour plus d'informations sur l'installation du programme Exchange 2000 Server ADC sur un autre serveur, voir l'article 312632 de la Base de connaissances Microsoft sur la procédure d'installation et de configuration d'Active Directory Connector dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312632).

Pour plus d'informations sur l'installation du programme Exchange Server 2003 ADC sur un autre serveur, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).


Mise à jour du logiciel Active Directory Connector requise
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-10-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) CIM_Datafile pour déterminer la valeur de la clé Version d'Adc.exe, le fichier ADC (Active Directory Connector). La clé WMI Version indique le numéro de version de ce fichier.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msDS-Behavior-Version de l'objet de forêt dans Active Directory, Paramètres NTDS. Cette valeur indique le niveau fonctionnel de la forêt Active Directory. Les valeurs valides pour l'attribut msDS-Behavior-Version sont indiquées dans le tableau suivant.

Valeur | Niveau fonctionnel de la forêt
0 | Microsoft Windows 2000 Server mixte
1 | Windows Server™ 2003 intermédiaire
2 | Windows Server 2003 natif

Si Exchange Server Analyzer détecte que le numéro de version d'Adc.exe est inférieur à 6.0.6615.0 sur un ordinateur Exchange Server dans une forêt Active Directory en mode natif ou intermédiaire Windows Server 2003, une erreur s'affiche. Cette erreur indique qu'une version Exchange 2000 Server du programme ADC est exécutée dans un niveau de forêt Active Directory Windows Server 2003 incompatible. Une mise à jour vers Exchange Active Directory Connection (ADC) est requise pour résoudre ce problème.

L'exécution d'une ancienne version d'ADC dans un niveau de fonctionnalité de forêt mixte ou natif peut provoquer une mise à jour incomplète de l'annuaire et une perte de données. Il est recommandé d'effectuer une mise à niveau vers la version Exchange Server 2003 d'ADC sur tous les ordinateurs de votre organisation.

Vous pouvez télécharger la dernière version d'ADC, ainsi que le dernier Service Pack d'Exchange Server 2003 depuis la page Téléchargements Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097). Ou bien, vous pouvez installer la version finale Exchange Server 2003 d'ADC à partir du CD d'Exchange Server.

Pour effectuer la mise à niveau vers la dernière version d'ADC

  1. Sur votre serveur qui exécute l'ancienne version d'ADC, cliquez sur Démarrer et sur Exécuter, puis entrez E:\setup\adc\i386\setup.exe, où E correspond à l'emplacement où télécharger le Service Pack d'Exchange Server.

  2. Sur la page Assistant d'Installation du Connecteur Microsoft Active Directory, cliquez sur Suivant.

  3. Sur la page Une installation précédente a été détectée, cliquez sur Réinstaller pour effectuer la mise à niveau d'ADC.

  4. Sur la page Fin de l'Assistant Installation du Connecteur Microsoft Active Directory, cliquez sur Terminer.

Pour plus d'informations sur l'influence du niveau fonctionnel de la forêt sur ADC, voir l'article 825916 de la Base de connaissances Microsoft sur la non-réplication par Active Directory Connector Exchange 2000 des modifications dans l'appartenance au groupe dans Active Directory Windows Server 2003 aux niveaux fonctionnels 1 et 2 de la forêt (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916).

Pour plus d'informations sur les niveaux fonctionnels de la forêt et du domaine, voir l'article 322692 de la Base de connaissances sur la procédure d'augmentation du niveau fonctionnel du domaine dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692).


Cette forêt Active Directory a été configurée pour l'hébergement de Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Microsoft Active Directory® pour déterminer la valeur de l'attribut LinkID de l'objet schéma d'attribut Global-Address-List . L'objet Global-Address-List est utilisé sur un conteneur Exchange pour stocker le nom unique d'une liste d'adresses globales (LAG) récemment créée.

Si Exchange Server Analyzer détecte que la valeur de l'attribut LinkID de l'objet Global-Address-List est définie sur 4048, il affiche un message indiquant une configuration autre que celle par défaut. La valeur 4 048 indique que la forêt Active Directory est configurée pour un environnement hébergeant Exchange.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les environnements hébergeant Exchange, voir les articles suivants :

  • "sur les informations pour les hôtes (http://go.microsoft.com/fwlink/?LinkId=46307)

  • sur les environnements de service hébergé dans le kit de ressources Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=46326)


Le serveur Active Directory est arrêté ou inaccessible
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool utilise des appels de procédure distante (RPC) pour lire la valeur de chaîne CurrentVersion de la clé de Registre suivante sur le serveur d'annuaire Active Directory® :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Sur un ordinateur Microsoft Windows® 2000 Server, la valeur de la chaîne CurrentVersion prévue est 5.0. Sur un ordinateur Windows Server™ 2003, la valeur prévue est 5.2.

Si Exchange Server Analyzer ne peut pas lire cette valeur de Registre pour une raison ou pour une autre, une erreur s'affiche.

Pour corriger cette erreur

  1. Assurez-vous que le serveur d'annuaire a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour déterminer si le serveur d'annuaire est accessible.

  3. Si un pare-feu est installé, vérifiez que les ports RPC sont bloqués.

  4. Assurez-vous que le service Registre distant a été démarré sur le serveur d'annuaire.

  5. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté pour vous assurer qu'il dispose des autorisations suffisantes pour lire le Registre sur le serveur Active Directory.

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, voir les documents suivants :

  • Article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • Rubrique sur la résolution des problèmes de connectivité par l'outil Microsoft Exchange Server Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285)


Le serveur Active Directory a moins de 1 Go de mémoire mais a les commutateurs /3GB et /USERVA=3030 définis dans le fichier Boot.ini.
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge deux classes WMI (Windows® Management Instrumentation) Microsoft pour déterminer la quantité de mémoire physique sur le serveur Active Directory® ainsi que la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur. Le tableau décrit les classes et les clés évaluées par Exchange Server Analyzer.

Classe | Clé | Description
Win32_OperatingSystem | MaxProcessMemorySize | Nombre maximal de kilo-octets de mémoire pouvant être alloués à un processus.
Win32_OperatingSystem | OSProductSuite | Programmes supplémentaires du système d'exploitation installés et sous licence.
Win32_ComputerSystem | TotalPhysicalMemory | Quantité de mémoire vive (RAM) installée sur l'ordinateur.

Si Exchange Server Analyzer détermine que le serveur d'annuaire a moins de 950 Mo de RAM et que la valeur de MaxProcessMemorySize est comprise entre 2 097 024 et 3 104 640, un avertissement s'affiche.

Cet avertissement indique que le serveur d'annuaire n'est pas configuré correctement pour une utilisation optimale de la mémoire à deux points de vue :

  • Le commutateur de démarrage /USERVA=3030 a été défini. Ce commutateur n'est nécessaire que sur les ordinateurs Exchange Server dotés d'au moins 1 Go de mémoire fonctionnant avec un système d'exploitation Microsoft Windows Server™ 2003.

  • Le commutateur de démarrage /3GB a été défini. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 Go, fonctionnant avec les systèmes d'exploitation suivants :

    • Microsoft Windows Server 2003 Édition Standard

    • Microsoft Windows Server 2003 Édition Entreprise

    • Microsoft Windows Server 2003 Édition Datacenter

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation ci-dessus lorsque 1 Go minimum de mémoire physique est installé.

Si vous rencontrez cet avertissement sur un système dans lequel 1 Go de mémoire physique est installé, cela peut indiquer qu'une partie de cette mémoire physique a été allouée au niveau matériel à un autre composant, tel qu'une carte graphique, et qu'elle n'est par conséquent pas disponible pour le système d'exploitation. Dans ce cas, la quantité de mémoire physique installée selon Windows est inférieure à la quantité réelle installée sur l'ordinateur. Vous devez alors comparer les données du BIOS et celles de Windows concernant la quantité de mémoire installée.

Pour supprimer cet avertissement dans Windows Server 2003

  1. Cliquez avec le bouton droit sur Poste de travail et sélectionnez Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur Avancé.

  3. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  4. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  5. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes les lignes de démarrage : /3GB /USERVA=3030

  6. Enregistrez les modifications et fermez le Bloc-notes.

  7. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour supprimer cet avertissement dans Windows 2000 Server

  1. Dans l'Explorateur Windows, recherchez la partition système.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Le cas échéant, dans l'Explorateur, cliquez sur Outils, Options des dossiers, puis sur l'onglet Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur, cliquez avec le bouton droit sur le fichier, puis cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes lignes de démarrage : /3GB /USERVA=3030

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation des commutateurs de démarrage /3GB et /USERVA, voir les articles suivants de la Base de connaissances Microsoft :

  • 308356 sur l'utilisation de la mémoire par le processus Lsass.exe sur les contrôleurs de domaine qui exécutent Windows Server 2003 ou Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812 sur l'utilisation de la fonctionnalité de réglage de RAM 4GT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739 sur l'utilisation du commutateur /USERVA dans le fichier Boot.ini pour régler les configurations /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Le serveur Active Directory a moins de 1 Go de mémoire mais a le commutateur /3GB défini dans le fichier Boot.ini.
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge deux classes WMI (Windows® Management Instrumentation) Microsoft pour déterminer la quantité de mémoire physique sur le serveur Active Directory® ainsi que la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur. Le tableau suivant décrit les classes et les clés évaluées par Exchange Server Analyzer.

Classe | Clé | Description
Win32_OperatingSystem | MaxProcessMemorySize | Nombre maximal de kilo-octets de mémoire pouvant être alloués à un processus.
Win32_OperatingSystem | OSProductSuite | Programmes supplémentaires du système d'exploitation installés et sous licence.
Win32_ComputerSystem | TotalPhysicalMemory | Nombre d'octets de mémoire vive (RAM) installés sur l'ordinateur.

Si Exchange Server Analyzer détermine que le serveur d'annuaire dispose de moins de 950 Mo de RAM et que la valeur de MaxProcessMemorySize est comprise entre 2 097 024 et 3 104 640, un avertissement s'affiche.

Cet avertissement indique que le serveur d'annuaire n'est pas configuré correctement pour une utilisation optimale de la mémoire. Le commutateur de démarrage /3GB a été défini sur cet ordinateur et doit être supprimé. Ce commutateur ne doit être utilisé que sur les serveurs Active Directory dotés d'au moins 1 Go de mémoire fonctionnant avec les systèmes d'exploitation suivants :

  • Microsoft Windows Server™ 2003 Édition Standard

  • Microsoft Windows Server™ 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation ci-dessus lorsque 1 Go minimum de mémoire physique est installé.

Si vous rencontrez cet avertissement sur un système dans lequel 1 Go de mémoire physique est installé, cela peut indiquer qu'une partie de cette mémoire physique a été allouée au niveau matériel à un autre composant, tel qu'une carte graphique, et qu'elle n'est par conséquent pas disponible pour le système d'exploitation. Dans ce cas, la quantité de mémoire physique installée selon Windows est inférieure à la quantité réelle installée sur l'ordinateur. Vous devez alors comparer les données du BIOS et celles de Windows concernant la quantité de mémoire installée.

Pour supprimer cet avertissement dans Windows Server 2003

  1. Cliquez avec le bouton droit sur Poste de travail, puis sur Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur Avancé.

  3. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  4. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  5. Dans la section [Systèmes d'exploitation], supprimez le commutateur suivant de toutes les lignes de démarrage : /3GB

  6. Enregistrez les modifications et fermez le Bloc-notes.

  7. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour supprimer cet avertissement dans Windows 2000 Server

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans l'Explorateur, cliquez sur Outils, Options des dossiers, puis sur l'onglet Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur, cliquez avec le bouton droit sur le fichier, puis cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez le commutateur suivant de toutes les lignes de démarrage : /3GB

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus de détails sur l'utilisation du commutateur de démarrage /3GB, voir les articles suivants de la Base de connaissances Microsoft :

  • 308356 sur l'utilisation de la mémoire par le processus Lsass.exe sur les contrôleurs de domaine qui exécutent Windows Server 2003 ou Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812 sur l'utilisation de la fonctionnalité de réglage de RAM 4GT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739 sur l'utilisation du commutateur /USERVA dans le fichier Boot.ini pour régler les configurations /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Le serveur Active Directory utilise Windows 2000 Server et le commutateur /3GB est défini
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la quantité d'espace d'adresse virtuelle alloué aux processus en mode utilisateur (MaxProcessMemorySize) et la version de Windows (OSProductSuite) utilisée par le serveur Active Directory®. Le tableau suivant décrit les classes et les clés évaluées par Exchange Server Analyzer.

Si Exchange Server Analyzer détermine que la valeur de MaxProcessMemorySize est 3104640 et que la valeur de OSProductSuite correspond à Windows 2000 Server, une erreur s'affiche.

Cette erreur indique que le commutateur de démarrage /3GB est défini dans le fichier Boot.ini sur un serveur d'annuaire utilisant Microsoft Windows 2000 Server. Ce commutateur n'est pas pris en charge par Windows 2000 Server et ne doit être utilisé que sur des ordinateurs qui disposent d'au moins 1 Go et utilisent l'un des systèmes d'exploitation suivants :

  • Microsoft Windows Server™ 2003 Édition Standard

  • Microsoft Windows Server 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Pour supprimer le commutateur /3GB du fichier Boot.ini

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Le cas échéant, dans l'Explorateur, cliquez sur Outils, Options des dossiers, puis sur l'onglet Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur, cliquez avec le bouton droit sur le fichier, cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes les lignes de démarrage : /3GB /USERVA=3030

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez le serveur d'annuaire pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation du commutateur de démarrage /3GB, voir les articles suivants de la Base de connaissances Microsoft :

  • 297812 sur l'utilisation de la fonctionnalité de réglage de RAM 4GT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739 sur l'utilisation du commutateur /USERVA dans le fichier Boot.ini pour régler les configurations /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Impossible d'accéder au Registre du serveur Active Directory
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante dans chaque contrôleur de domaine :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

Si, pour quelque raison que ce soit, Exchange Server Analyzer ne peut pas lire cette valeur de Registre, il affiche un message d'erreur.

Pour corriger cette erreur

  1. Assurez-vous que le contrôleur de domaine a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour vérifier si le contrôleur de domaine est accessible.

  3. Si un pare-feu est installé, vérifiez que les ports RPC sont bloqués.

  4. Assurez-vous que le service Remote Registry du contrôleur de domaine a été démarré.

  5. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque contrôleur de domaine qu'il analyse.

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, voir les documents suivants :

  • Article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • Rubrique sur la résolution des problèmes de connectivité par l'outil Microsoft Exchange Server Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285)

Pour plus d'informations sur les exigences en matière de ports, voir l'article 832017 de la Base de connaissance sur la vue d'ensemble des services et exigences de ports réseau pour le système Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Mise à jour du logiciel serveur Active Directory
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-02-20

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Exchange_DSAccessDC dans l'espace de noms ROOT\MicrosoftExchangeV2 pour déterminer la valeur de la propriété Name. La propriété Name spécifie le nom d'ordinateur du contrôleur de domaine utilisé par le serveur Exchange pour les recherches dans le service d'annuaire Active Directory.

Exchange Analyzer interroge ensuite Active Directory pour les valeurs des attributs spécifiques de ce contrôleur de domaine afin de déterminer :

  • si le contrôleur de domaine Active Directory exécute le système d'exploitation Windows Server 2003.

  • si le contrôleur de domaine Active Directory exécute une version non anglaise du système d'exploitation Microsoft Windows Server 2003.

  • s'il y a un serveur Microsoft Exchange Server 2007 dans l'organisation Exchange.

  • si la valeur de la clé Version pour le fichier ntdsa.dll sur le serveur est inférieure à 2700.

Si Exchange Analyzer détermine que toutes ces conditions sont vraies, il affiche un avertissement.

Cet avertissement indique que les clients Exchange Outlook Web Access peuvent rencontrer des problèmes avec l'indexation de carnet d'adresses Exchange.

Outlook Web Access permet aux utilisateurs de sélectionner la langue qu'ils veulent pour leur interface utilisateur (IU). La langue sélectionnée par les utilisateurs détermine la configuration des paramètres régionaux. Outlook Web Access utilise également cette langue pour trier les résultats d'Active Directory, tels que le carnet d'adresses. Lorsqu'Exchange exécute une demande d'affichage de la liste virtuelle et spécifie une langue indisponible dans le contrôleur de domaine, une erreur survient. Ce problème survient car il n'y a actuellement aucun mécanisme d'indexation par défaut qui permet à Exchange d'utiliser une autre langue si la langue spécifiée par une demande d'affichage de la liste virtuelle ne correspond pas à la langue du contrôleur de domaine.

Pour supprimer cet avertissement, procurez-vous et installez la mise à jour de fichier mentionnée dans l'article 919166 de la Base de connaissances Microsoft sur le dysfonctionnement de la fonction de carnet d'adresses dans Exchange 2007 lorsque la configuration des paramètres régionaux d'un client Exchange OWA ne correspond pas à celle d'un contrôleur de domaine Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166).


Impossible d'accéder à la classe WMI du serveur Active Directory
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si une valeur est définie pour la clé Name du contrôleur de domaine. Si cette interrogation échoue, Exchange Server Analyzer affiche une erreur.

Cette erreur peut avoir deux causes :

  • Le compte qui utilise Exchange Server Analyzer ne possède pas d'autorisations suffisantes pour interroger les informations WMI

  • Un problème de réseau empêche Exchange Server Analyzer de contacter l'ordinateur.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour voir si l'ordinateur Exchange Server est accessible.

  3. Si un pare-feu est installé, vérifiez que les ports RPC sont bloqués.

  4. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque ordinateur Exchange Server qu'il analyse.

    Vous pouvez également accorder des autorisations WMI spécifiques au compte sous lequel Exchange Server Analyzer est exécuté.

    1. Sur l'ordinateur Exchange, ouvrez l'arborescence de la console MMC Gestion de l'ordinateur.

    2. Dans Services et applications, cliquez avec le bouton droit sur Contrôle WMI et cliquez sur Propriétés.

    3. Dans la page Propriété des contrôles WMI, cliquez sur l'onglet Sécurité, puis développez Racine.

    4. Sélectionnez le dossier CIMV2 et cliquez sur Sécurité.

    5. Dans la page Sécurité pour ROOT\CIMV2, ajoutez le compte sous lequel Exchange Server Analyzer est exécuté.

    6. Sélectionnez le compte que vous avez ajouté à l'étape e. Dans Autorisations pour compte_sélectionné, sous la colonne Autoriser, activez les cases à cocher Appel à distance autorisé et Sécurité de lecture, puis cliquez sur OK.

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, voir les documents suivants :

  • Article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487)

  • Rubrique sur la résolution des problèmes de connectivité par l'outil Microsoft Exchange Server Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285)

Pour plus d'informations sur les exigences en matière de ports, voir l'article 832017 de la Base de connaissance sur la vue d'ensemble des services et exigences de ports réseau pour le système Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


L'attribut ADCDisabledMail est détecté
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'organisation Exchange est en mode mixte ou natif. Si l'organisation Exchange est en mode natif, Exchange Server Analyzer interroge Active Directory pour déterminer si la valeur de l'attribut legacyExchangeDN des objets à extension messagerie des domaines de l'organisation est définie sur ADCDisabledMail. S'il trouve des objets à extension de messagerie dont la valeur de l'attribut legacyExchangeDN est définie sur ADCDisabledMail, un avertissement s'affiche répertoriant les objets et leur domaine.

Ce problème peut apparaître dans les environnements Exchange 2000 Server et Exchange Server 2003 lors de la suppression d'une boîte aux lettres. Lorsque la boîte aux lettres est supprimée, la valeur de l'attribut legacyExchangeDN du compte est datée à l'aide de ADCDisabledMail. Cette valeur est utilisée pour demander à l'ADC (Active Directory Connector) de supprimer des objets du service d'annuaire Exchange Server 5.5 si l'objet associé n'a plus d'extension messagerie dans Active Directory. Si plusieurs boîtes aux lettres d'un grand groupe de distribution ont été supprimées, le message est retardé alors qu'Active Directory recherche une valeur unique de l'attribut legacyExchangeDN de ADCDisabledMail. Étant donné que plusieurs boîtes aux lettres peuvent avoir la même legacyExchangeDN attribute value, la recherche prend du temps. Cela entraîne des retards de messagerie. Des retards de messagerie apparaissent également si le groupe de distribution est étendu dans les lignes « À :/Cc :/Cci : » du message d'un client Microsoft Office Outlook® 2003.

Pour résoudre ce problème, vous pouvez supprimer les objets ou utiliser l'outil ADSI Edit, l'outil ldp.exe ou un autre client LDAP (Lightweight Directory Access Protocol) version 3 pour supprimer le contenu de l'attribut legacyExchangeDn. Si la valeur de l'attribut legacyExchangeDN est définie sur NULL, la recherche d'Active Directory est définie sur « /O=NT5/ou=<objectGUID du domaine>/cn=<objectGUID de l'utilisateur> » et un rapport de non-remise est généré beaucoup plus rapidement.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour supprimer la valeur ADCDisabledMail de l'attribut legacyExchangeDN

  1. Lancez l'outil ADSI Edit à partir des outils de support de Windows 2000 ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur de domaine

    • DC=Nom_domaine

    • Conteneur d'utilisateurs

  3. Cliquez avec le bouton droit sur Nom_utilisateur, puis cliquez sur Propriétés.

  4. Cliquez sur legacyExchangeDN dans la liste Attributs, puis sur Modifier.

  5. Supprimez la valeur originale legacyExchangeDN qui contient ADCDisabledMail en la sélectionnant et en cliquant sur Effacer.

  6. Cliquez deux fois sur OK pour appliquer la modification.

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide en ligne de Windows Server.

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Selon les paramètres de filtrage de la liste d'adresses, il se peut que les nouveaux destinataires ne figurent pas dans les listes d'adresses
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut purportedSearch pour chaque objet Carnet d'adresses. Si Exchange Server Analyzer détecte que l'attribut purportedSearch contient la chaîne « proxyAddresses=* », une erreur s'affiche.

Après la création d'un nouvel objet utilisateur, le service de mise à jour de destinataire attribue à cet objet destinataire des attributs spécifiques, tels que des adresses proxy. Il se peut toutefois que le service de mise à jour de destinataire ne puisse pas affecter l'attribut ShowInAddressBook. L'attribut ShowInAddressBook d'un objet destinataire indique les listes d'adresses dont le destinataire fait partie. Les objets destinataire auxquels cet attribut n'est pas affecté n'apparaissent ni dans la liste d'adresses globale ni dans une autre liste d'adresses, même si l'objet répond aux critères du filtre de la liste d'adresses.

Cette situation peut se produire si un ou plusieurs filtres de liste d'adresses contiennent l'attribut proxyAddresses. Vous pouvez déterminer si tel est le cas en consultant les propriétés de chaque carnet d'adresses et en recherchant la chaîne suivante dans la zone Règles de filtrage : « proxyAddresses=* ».

Effectuez la procédure suivante pour permettre au service de mise à jour de destinataire d'affecter correctement des attributs aux objets destinataire pour qu'ils apparaissent dans la liste d'adresses globale ou dans une autre liste d'adresses.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataire et Toutes les listes d'adresses globales puis sélectionnez Stratégies de destinataire.

  3. Dans le volet droit, cliquez avec le bouton droit sur la liste d'adresses à modifier et sélectionnez Propriétés.

  4. Sur la page Propriétés, sous l'onglet Général, sous Règles de filtrage, cliquez sur Modifier.

  5. Dans le menu déroulant Find Exchange Recipients, sélectionnez Recherche personnalisée. Si la liste d'adresses a été créée par une recherche personnalisée, la page Find Custom Search s'affiche lorsque vous cliquez sur Modifier à l'étape 3.

  6. Sélectionnez l'entrée Proxy addresses is (exactly) * dans la liste de critères, puis cliquez sur Supprimer.

  7. Cliquez sur OK pour fermer les boîtes de dialogue.

  8. Cliquez avec le bouton droit sur la stratégie de destinataire et cliquez sur Appliquer la stratégie maintenant.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances Microsoft :

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328738)

  • 319065 sur l'utilisation du service de mise à jour de destinataire dans Exchange 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319065)


Le mode du groupe d'administration est inconnu
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour vérifier le mode du groupe d'administration en vérifiant l'attribut msExchAdminGroupMode de l'objet de groupe d'administration dans le conteneur des groupes d'administration dans Active Directory. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchAdminGroupMode n'est pas égale à 0, 1 ou 2, une erreur s'affiche.

Exchange utilise le mode du groupe d'administration pour indiquer si ce dernier peut inclure les serveurs Exchange Server 5.5 ou Exchange Server 2003 (ou les serveurs Exchange 2000 Server). Si une valeur différente de 0, 1 ou 2 est présente pour cet attribut, il est probable qu'elle ait été modifiée manuellement par un administrateur. Le programme d'installation d'Exchange ou le Gestionnaire système Exchange ne définiront pas cette valeur de manière incorrecte.

Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour modifier l'attribut MSExchAdminGroupMode

  1. Utilisez un éditeur Active Directory tel qu'ADSI Edit pour localiser l'objet de groupe d'administration dans Active Directory.

    L'attribut MSExchAdminGroupMode peut se trouver dans :

    CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Organisation, CN=Groupes_administration, CN=Groupe_administration

  2. Entrez l'une des valeurs entières suivantes :

    0=mode natif (le groupe d'administration a été créé à l'aide d'Exchange 2000 Server ou d'Exchange Server 2003)

    1=mode Exchange Server 5.5 (le groupe d'administration a été créé à l'aide d'Exchange Server 5.5 et n'inclut que les serveurs Exchange Server 5.5)

    2=mode mixte (le groupe d'administration peut inclure les serveurs Exchange Server 5.5 et les serveurs Exchange 2000 Server ou Exchange Server 2003)

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide en ligne de Windows Server.


Configuration Utilisateurs authentifiés incorrecte pour l'hébergement de Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'environnement Exchange Server est configuré comme un environnement hébergeant Exchange. Si l'environnement Exchange Server est un environnement hébergeant Exchange, Exchange Server Analyzer interroge Active Directory pour déterminer si le groupe Utilisateurs authentifiés fait partie du groupe Accès compatible pré-Windows® 2000 du domaine.

Si le groupe Utilisateurs authentifiés est membre du groupe Accès compatible pré-Windows 2000, Exchange Server Analyzer affiche un avertissement. Cette configuration n'est pas recommandée pour une solution hébergeant Exchange.

Pour corriger cet avertissement, supprimez le groupe Utilisateurs authentifiés du groupe de sécurité Accès compatible pré-Windows 2000

  1. Ouvrez le composant Utilisateurs et ordinateurs Active Directory.

  2. Développez le nœud du domaine, puis cliquez sur le conteneur Builtin.

  3. Cliquez avec le bouton droit sur le groupe de sécurité Accès compatible pré-Windows 2000 et sélectionnez Propriétés.

  4. Cliquez sur l'onglet Membres.

  5. Sélectionnez Utilisateurs authentifiés.

  6. Cliquez sur Supprimer.

  7. Cliquez sur OK.

Pour plus d'informations sur les environnements hébergeant Exchange, voir les articles suivants :

  • "sur les informations pour les hôtes (http://go.microsoft.com/fwlink/?LinkId=46307)

  • sur les environnements de service hébergé dans le kit de ressources Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=46326)


Non-correspondance du certificat Principal
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge l'objet Server Certificate dans le système du serveur Exchange pour récupérer plusieurs propriétés sur des certificats X509. Pour chaque certificat SSL (Secure Sockets Layer) détecté, Exchange Server Analyzer évalue l'attribut Principal pour identifier le nom de domaine complet qui était attribué au certificat, par exemple, www.microsoft.com.

Microsoft Exchange Server Analyzer émet un avertissement lorsque le nom de domaine complet Principal ne correspond pas à l'adresse ou à l'URL de l'hôte. L'avertissement de non-correspondance du certificat Principal signifie que des utilisateurs risquent de ne pas pouvoir se connecter à leur boîte aux lettres à l'aide de Microsoft Office Outlook® Web Access pour Exchange Server 2003, Outlook Anywhere pour Exchange Server 2007, Exchange Server ActiveSync et RPC sur HTTP.

Remarque :
Un serveur doit posséder un certificat de serveur lorsqu'il exécute un protocole SSL. Le serveur peut éventuellement demander le certificat du client. Le certificat de serveur contient le nom du site Web. Le navigateur vérifie que le site Web correspond au nom entré. Par exemple, pour un site Web dont l'adresse est https://www.exemple.com, le nom du certificat doit être www.exemple.com.

Une différence de correspondance peut survenir si l'une des conditions suivantes est vraie :

  • Le certificat est accidentellement appliqué au mauvais serveur

  • Le client accède à des données sur un serveur à l'aide d'une URL d'hôte erronée si des serveurs possèdent plusieurs noms d'hôte

Résolution de la non-correspondance des noms de certificat

  • Vérifiez que le certificat SSL a été octroyé et appliqué à l'hôte approprié.

Pour plus d'informations

  • Pour plus d'informations sur l'utilisation des certificats avec des serveurs virtuels dans Exchange Server 2003, consultez l'article 823024 de la Base de connaissances Microsoft sur l'utilisation des certificats avec les serveurs virtuels dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024).

  • Pour plus d'informations sur l'utilisation de SSL et sur l'obtention et l'installation de certificats de serveur, consultez la rubrique sur la configuration d'Exchange Server 2003 pour l'accès client du Guide sur l'accès client à Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47568).

  • Pour plus d'informations sur l'utilisation de SSL et sur l'obtention et l'installation de certificats de serveur pour Exchange Server 2007, consultez la rubrique sur la configuration de SSL pour Outlook Anywhere (http:// go.microsoft.com/fwlink/?LinkId=80875).


La planification d'activation de l'accord de connexion a été définie sur Jamais
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut activationStyle sur chaque objet d'accord de connexion. L'attribut activationStyle représente le paramètre de planification pour l'accord de connexion. Si la planification est définie sur Jamais, un avertissement s'affiche.

Si vous déterminez que cet accord de connexion n'est plus nécessaire, supprimez-le. Si cet accord de connexion est nécessaire, vous devez le configurer pour exécuter une planification appropriée.

Pour supprimer cet avertissement

  1. Cliquez sur Démarrer, Programmes, Outils d'administration, puis Connecteur Active Directory.

  2. Dans le volet gauche, cliquez sur le serveur Active Directory Connector (ADC) qui héberge l'accord de connexion à modifier.

  3. Dans le volet droit, cliquez avec le bouton droit sur l'accord de connexion à modifier, puis cliquez sur Propriétés.

  4. Cliquez sur l'onglet Planification.

  5. Définissez la planification sur Toujours ou Horaires sélectionnés. Si vous sélectionnez ce dernier, cliquez sur les zones appropriées dans la grille pour que l'accord de connexion soit exécuté selon ces horaires.

Pour plus d'informations sur la configuration d'un accord de connexion de destinataire bidirectionnel, voir l'article 296260 de la Base de connaissances Microsoft sur la procédure de configuration d'un accord de connexion de destinataire bidirectionnel pour les utilisateurs Exchange Server 5.5 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260).


Accord de connexion orphelin
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si chaque accord de connexion possède une valeur valide pour msExchHomeSyncService. Si Exchange Server Analyzer détecte un accord de connexion qui ne possède pas de valeur valide pour cet attribut, un avertissement s'affiche.

L'attribut msExchHomeSyncService contient le serveur Active Directory Connector (ADC) sur lequel se trouve l'accord de connexion.

Cet avertissement s'affiche si vous supprimez un serveur ADC sans avoir au préalable éliminé l'ADC ou les accords de connexion sur le serveur ADC. Lors de la suppression du serveur ADC, la connexion est rompue entre les accords de connexion et le serveur ADC. Par conséquent, les objets sous la responsabilité des accords de connexion ne se répliquent plus. Si vous utilisez le composant logiciel enfichable ADC Manager sur un autre serveur ADC, les accords de connexion qui se trouvaient sur le serveur ADC supprimé ne seront pas affichés. Ils continuent néanmoins à exister dans Active Directory.

Pour résoudre ce problème, associez de nouveau les anciens accords de connexion à un nouveau serveur ADC. Pour ce faire, il suffit notamment de créer un nouvel accord de connexion sur le nouveau serveur ADC et d'ensuite copier-coller l'attribut msExchHomeSyncService du nouvel accord de connexion vers l'ancien.

Pour associer de nouveau un accord de connexion à un serveur ADC

  1. Démarrez le composant logiciel enfichable ADC Manager.

  2. Créez un nouvel accord de connexion.

  3. Démarrez Active Directory Service Interfaces (ADSI) Edit.

  4. Développez Configuration, Services, Microsoft Exchange et cliquez sur Connexions Active Directory.

  5. Dans le volet droit, ouvrez les propriétés de l'accord de connexion récemment créé.

  6. Dans la liste déroulante Sélectionnez une propriété à afficher, cliquez sur msExchHomeSyncService.

  7. Copiez l'attribut complet de la zone Valeur(s) et cliquez sur OK.

  8. Ouvrez les propriétés de l'accord de connexion à associer de nouveau.

  9. Cliquez dans la liste déroulante Sélectionnez une propriété à afficher, puis sur l'attribut msExchHomeSyncService.

  10. Collez la valeur copiée dans la zone Modifier l'attribut.

  11. Cliquez sur Définir, Appliquer, puis sur OK.

Pour plus d'informations sur les accords de connexion orphelins, voir l'article 319486 de la Base de connaissances Microsoft sur la disparition des accords de connexion après la suppression d'Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486).


Nom affiché par défaut modifié
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut createDialog d'objets ayant une classe displaySpecifier. Les objets ayant une classe displaySpecifier décrivent les menus contextuels et les pages de propriétés à utiliser avec des objets dans Active Directory. Si Exchange Server Analyzer détermine que l'attribut createDialog a été défini, un message indiquant une configuration autre que celle par défaut s'affiche.

Lorsqu'un nouvel objet utilisateur ou contact est créé dans Active Directory, le champ Nom complet est toujours généré au format Prénom Nom. Ce champ définit ensuite le champ Nom affiché. À la création, vous obtenez donc une liste d'adresses globale au format Prénom Nom.

Si vous le souhaitez, vous pouvez utiliser un éditeur Active Directory tel qu'ADSI Edit pour modifier le mode de création du champ Nom affiché. ADSI Edit modifie non seulement le mode de création de ce champ, mais également le champ Nom complet ; les noms des utilisateurs apparaissent par conséquent au format choisi affiché dans Utilisateurs et ordinateurs Active Directory.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Avant d'effectuer ces modifications, sachez qu'elles peuvent avoir des effets secondaires. Pour plus d'informations sur les conséquences possibles de cette modification, voir l'article 276266 de la Base de connaissances Microsoft sur les modifications de groupe pour les utilisateurs à caractères limités dans LDAP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266).

Pour modifier le format d'affichage par défaut des objets utilisateur et contact

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Cliquez avec le bouton droit sur le nœud supérieur, puis cliquez sur Établir une connexion.

  3. Modifiez le contexte de nommage en « Conteneur Configuration », puis cliquez sur OK pour lier et authentifier.

  4. Développez les nœuds Conteneur Configuration et Configuration.

  5. Développez le nœud cn=Spécificateur_affichage, puis double-cliquez sur CN=409. Remarque : 409 est l'ID du paramètre régional pour l'anglais des États-Unis. Si vous vous trouvez dans un environnement multilingue, il se peut que vous deviez modifier les autres codes.

  6. Dans le volet droit, ouvrez les propriétés pour CN=Affichage_utilisateur.

  7. Faites défiler jusqu'à l'attribut createDialog (facultatif).

  8. Définissez l'attribut sur %<sn>.%<nom_spécifié>, puis cliquez sur Définir. Remarque : les seuls jetons pouvant être formatés sont %<sn>, %<nom_spécifié> et %<initiales>.

  9. Cliquez sur OK pour fermer la boîte de dialogue.

  10. Créez un nouvel utilisateur dans Active Directory pour vérifier que le Nom complet et le Nom affiché sont générés comme prévu. Remarque : dans un environnement multi-domaine, il se peut que vous deviez attendre la fin de la réplication avant que l'outil Utilisateurs et ordinateurs Active Directory ne tienne compte des modifications.

Après exécution de la procédure ci-dessus, le nom affiché apparaît sous la forme Nom.Prénom. En outre, la procédure ci-dessus concerne les objets utilisateur. Pour les objets contact, modifiez l'étape 6 en contact-Display.

Pour plus d'informations sur la manière d'utiliser un script ADSI pour accomplir cette tâche, voir l'article 277717 de la Base de connaissances Microsoft sur la procédure de modification des noms affichés des utilisateurs Active Directory avec un script Active Directory Services Interface (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277717).

L'International Telecommunication Union (ITU) et l'Organisation Internationale de Normalisation (ISO) définissent les page de codes. Pour plus d'informations, voir les pages Web suivantes de l'ITU et l'ISO :

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur la prise en charge des clients Exchange localisés, voir l'article 150977 de la Base de connaissances Microsoft sur la prise en charge des clients Exchange localisés (http://go.microsoft.com/fwlink/?linkid=3052&kbid=150977).


Rétention des éléments supprimés désactivée pour la banque de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut garbageCollPeriod de chaque banque de boîtes aux lettres. Si Exchange Server Analyzer détecte que l'attribut garbageCollPeriod de n'importe quelle banque de boîtes aux lettres est défini sur 0, un message de recommandation s'affiche.

Le nettoyage de la mémoire est un processus de maintenance interne d'Exchange qui libère de l'espace dans la base de données de banque de boîtes aux lettres. Par défaut, les éléments supprimés sont stockés dans la base de données de banque de boîtes aux lettres pendant un certain nombre de jours avant d'être définitivement supprimés par Exchange. Vous pouvez définir la longueur de la période de rétention des éléments supprimés en utilisant la banque de boîtes aux lettres par défaut ou en sélectionnant le nombre de jours de rétention d'un élément supprimé avant sa suppression définitive.

Vous pouvez sélectionner pour cet attribut un nombre entre 0 et 24 855. Il est recommandé de configurer ce paramètre sur 7 jours. Si la période de rétention des éléments supprimés est définie sur 0, les éléments supprimés sont immédiatement effacés de manière définitive du serveur. À moins que vous manquiez d'espace disque, il est recommandé de ne pas désactiver la fonction de rétention des éléments supprimés. Respectez la procédure suivante pour définir le nombre de jours de rétention des éléments supprimés avant leur suppression définitive.

Pour configurer la rétention des éléments supprimés dans le Gestionnaire système Exchange

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupe d'administration ou Organisation, cliquez sur Serveurs, puis sur Banque de boîtes aux lettres.

  3. Cliquez avec le bouton droit sur la banque de boîtes aux lettres, puis cliquez sur Propriétés.

  4. Sous l'onglet Limites, définissez la période de rétention des éléments supprimés comme suit :

    • Pour définir une période de rétention des éléments supprimés, cliquez sur Conserver les éléments supprimés pendant (jours) et entrez une valeur.

    • Pour conserver les éléments jusqu'à la sauvegarde, cliquez sur Ne pas supprimer définitivement les boîtes aux lettres et leurs éléments tant que la banque d'informations n'a pas été sauvegardée.

Pour configurer la rétention des éléments supprimés dans Utilisateurs et ordinateurs Active Directory

  1. Ouvrez le composant Utilisateurs et ordinateurs Active Directory.

  2. Dans l'arborescence de la console, développez le domaine.

  3. Double-cliquez sur Utilisateurs ou sur le nœud contenant les informations sur le destinataire à modifier.

  4. Dans le volet Détails, double-cliquez sur le destinataire à modifier.

  5. Sous l'onglet Général d'Exchange, cliquez sur Limites de stockage.

  6. Dans la boîte de dialogue Limites de stockage, sous Rétention des éléments supprimés, désactivez la case à cocher Paramètres par défaut de banque de boîtes aux lettres et entrez une valeur dans le champ Conserver les éléments supprimés pendant (jours).

    Pour empêcher la suppression définitive des éléments supprimés avant leur sauvegarde, activez la case à cocher Ne pas supprimer définitivement les éléments tant que la banque d'informations n'a pas été sauvegardée.

Pour plus d'informations sur la définition des limites de stockage de boîtes aux lettres, voir l'article 319583 de la Base de connaissances Microsoft sur la procédure de configuration de limites de stockage sur les boîtes aux lettres dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319583).


La rétention des éléments supprimés est désactivée pour la banque de dossiers publics
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut garbageCollPeriod de chaque banque de dossiers publics. Si Exchange Server Analyzer détecte que l'attribut garbageCollPeriod de n'importe quelle banque de dossiers publics est défini sur 0, un message de recommandation s'affiche.

Le nettoyage de la mémoire est un processus de maintenance interne d'Exchange qui libère de l'espace dans la base de données de banque de dossiers publics. Par défaut, les éléments supprimés sont stockés dans la base de données de banque de dossiers publics pendant un certain nombre de jours avant d'être définitivement supprimés par Exchange. Vous pouvez définir la longueur de la période de rétention des éléments supprimés en utilisant la banque de dossiers publics par défaut ou en sélectionnant le nombre de jours de rétention d'un élément supprimé avant sa suppression définitive.

Vous pouvez sélectionner pour cet attribut un nombre entre 0 et 24 855. Il est recommandé de configurer ce paramètre sur 7 jours. Si la période de rétention des éléments supprimés est définie sur 0, les éléments supprimés sont immédiatement effacés de manière définitive du serveur. À moins que vous manquiez d'espace disque, il est recommandé de ne pas désactiver la fonction de rétention des éléments supprimés.

Pour configurer la rétention des éléments supprimés dans le Gestionnaire système Exchange

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupe d'administration ou Serveurs et cliquez sur Serveurs, puis sur Banque de dossiers publics.

  3. Cliquez avec le bouton droit sur la banque de dossiers publics, puis cliquez sur Propriétés.

  4. Sous l'onglet Limites, définissez la période de rétention des éléments supprimés comme suit :

    • Pour définir une période de rétention des éléments supprimés, cliquez sur Conserver les éléments supprimés pendant (jours) et entrez une valeur.

    • Pour conserver les éléments jusqu'à la sauvegarde, cliquez sur Ne pas supprimer définitivement les éléments tant que la banque n'a pas été sauvegardée.

Pour plus d'informations sur la définition de limites de stockage sur des dossiers publics, voir l'article 319439 de la Base de connaissances Microsoft sur la procédure de configuration de limites de stockage sur les dossiers publics dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439).


Conservation des boîtes aux lettres supprimées désactivée
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchMailboxRetentionPeriod de chaque banque de boîtes aux lettres. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchMailboxRetentionPeriod de n'importe quelle banque de boîtes aux lettres est définie sur 0, un message de recommandation s'affiche.

L'attribut msExchMailboxRetentionPeriod indique le nombre de jours de conservation des boîtes aux lettres supprimées avant leur effacement. Vous pouvez sélectionner pour cette attribut un nombre compris entre 0 et 24 855. La valeur par défaut de ce paramètre est 30 jours. Si la période de conservation des boîtes aux lettres est définie sur 0, les boîtes aux lettres supprimées sont immédiatement effacées de manière permanente du serveur. À moins que vous manquiez d'espace disque, il est recommandé de ne pas désactiver la fonction de conservation des boîtes aux lettres supprimées.

Pour configurer la conservation des boîtes aux lettres supprimées

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, votre groupe d'administration, Serveurs, puis votre groupe de stockage. Si le nœud Groupes d'administration n'est pas affiché dans le Gestionnaire système Exchange, développez Serveurs, puis votre groupe de stockage.

  3. Cliquez avec le bouton droit sur la banque de boîtes aux lettres à configurer, puis sélectionnez Propriétés.

  4. Sous l'onglet Limites, entrez une période de conservation des boîtes aux lettres dans le champ Conserver boîtes aux lettres supprimées pdt (jours).

  5. Cliquez sur OK pour enregistrer les modifications.
Remarque :
Vous pouvez récupérer une boîte aux lettres si sa période de conservation n'a pas expiré et si l'objet utilisateur associé n'a pas été supprimé.

Pour plus d'informations sur la récupération d'une boîte aux lettres supprimée, voir les articles suivants de la Base de connaissances Microsoft :

  • 274343 sur la procédure de récupération d'une boîte aux lettres supprimée dans Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343)

  • 813337 sur la procédure de récupération ou de restauration d'une seule boîte aux lettres dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=813337)

  • 823176 sur la procédure de récupération ou de restauration d'une seule boîte aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823176)


Le domaine a une signature Exchange inconnue
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la dernière version de DomainPrep exécutée sur le domaine donné. Le numéro de version de DomainPrep correspond à la signature Exchange du domaine. Exchange Server Analyzer examine l'attribut objectVersion de l'objet Objets système Exchange du domaine donné. Deux entiers valides sont disponibles :

  • Pour Exchange 2000 Server, la valeur objectVersion est 4 406.

  • Pour Exchange Server 2003, la valeur objectVersion est 6 936.

  • Pour Exchange Server 2007, la valeur objectVersion est 10628

Si Exchange Server Analyzer ne détecte pas l'une des valeurs de l'attribut objectVersion, une erreur s'affiche.

Cette valeur est probablement incorrecte si vous avez installé une pré-version d'Exchange 2000 Server ou Exchange Server 2003 dans le domaine donné sans exécuter la version commerciale de DomainPrep.

Remarque :
Dans Microsoft Exchange 2000 Server et Exchange Server 2003, vous avez effectué les étapes de préparation d'Active Directory en exécutant les commandes setup /forestprep et setup /domainprep. Exchange 2007 ne dispose pas des options /forestprep et /domainprep. Pour Exchange Server 2007, vous exécutez le processus d'installation /PrepareDomain ou l'Assistant Installation avec un compte disposant des autorisations requises pour préparer Active Directory et le domaine.

Pour corriger cette erreur pour Exchange 2000 Server ou Exchange Server 2003, exécutez la dernière version commerciale d'Exchange 2000 Server DomainPrep, d'Exchange Server 2003 DomainPrep ou la dernière version commerciale du processus PrepareDomain ou de l'Assistant Installation pour Exchange Server 2007. Le compte que vous utilisez pour exécuter DomainPrep, PrepareDomain ou l'Assistant Installation doit être membre du groupe de sécurité Administrateur de domaine dans le domaine local et administrateur de l'ordinateur local.

  • le domaine racine ;

  • tous les domaines comportant des ordinateurs Exchange 2000 Server ou Exchange Server 2003 ;

  • tous les domaines comportant des objets à boîte aux lettres activée Exchange 2000 Server ou Exchange Server 2003 (tels que les utilisateurs et groupes), même si aucun serveur Exchange n'est installé sur ces domaines ;

  • tous les domaines comportant des serveurs de catalogue global pouvant être potentiellement utilisés par les composants d'accès à l'annuaire Exchange ;

  • tous les domaines comportant des utilisateurs et groupes Exchange 2000 Server ou Exchange Server 2003 permettant de gérer votre organisation Exchange.

Exécution de DomainPrep pour Exchange 2000 Server ou Exchange Server 2003

  1. Insérez le CD-ROM d'Exchange dans votre lecteur. Vous pouvez exécuter DomainPrep sur n'importe quel ordinateur du domaine.

  2. À l'invite de commandes, entrez <lecteur>:\setup\i386\setup /DomainPrep, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants assurez-vous que Action est défini sur DomainPrep. Dans le cas contraire, cliquez sur la flèche vers le bas, puis sur DomainPrep. Cliquez sur Suivant.

  7. Sur la page Fin de l'Assistant Installation de Microsoft Exchange, cliquez sur Terminer.

Exécution de PrepareDomain pour Exchange Server 2007

  1. Suivez les instructions détaillées de la page « Procédure de préparation d'Active Directory et de domaines » (http://go.microsoft.com/fwlink/?LinkId=78453)

Pour plus d'informations sur l'exécution d'Exchange Server 2003 DomainPrep, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur l'exécution d'Exchange 2000 Server DomainPrep, voir le livre blanc sur l'installation et le paramétrage de Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=5906).

Pour plus d'informations sur la préparation d'Active Directory et de domaines pour Exchange Server 2007, consultez la page « Procédure de préparation d'Active Directory et de domaines » (http://go.microsoft.com/fwlink/?LinkId=78453).


Le contrôleur de domaine utilise Virtual Server 2005 et Exchange Server est installé en tant qu'invité
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur Virtual Machine.

Exchange Server Analyzer recherche également la présence de la valeur de Registre suivante :

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

En outre, Exchange Server Analyzer lit la clé Domain Role de Win32_ComputerSystem sur l'ordinateur physique qui utilise Microsoft Virtual Server 2005. Une valeur supérieure à 3 indique que l'ordinateur physique est un contrôleur de domaine.

Si Exchange Server Analyzer détecte que la clé Model contient la chaîne Virtual Machine, que la branche de Registre ci-dessus existe et que Domain Role est supérieur à 3, une erreur s'affiche.

Une valeur Virtual Machine pour la clé Model indique que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée sur Virtual Server 2005 ou Microsoft Virtual PC 2004. La branche de Registre ci-dessus n'étant créée que par Virtual Server 2005, son existence signifie que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée dans Virtual Server 2005.

Microsoft ne prend pas en charge l'exécution des versions d'Exchange Server sur une machine virtuelle ou un émulateur. Cela s'applique à Exchange Server sur Virtual Server 2005, Virtual PC 2004 ou tout programme tiers de machine virtuelle. Les plates-formes Exchange Server sont conçues et testées pour n'être exécutées que sur un matériel physique, notamment les plates-formes matérielles répertoriées dans Windows Server Catalog à l'adresse http://go.microsoft.com/fwlink/?linkid=17219.

En outre, il n'est pas conseillé d'exécuter Exchange en tant qu'invité du serveur virtuel sur un contrôleur de domaine parce qu'il ne permet pas une redondance adéquate de service en service.

Pour corriger cette erreur

  1. Déplacez les boîtes aux lettres du serveur Exchange exécuté sous Virtual Server 2005 vers un ordinateur Exchange Server non virtuel.

  2. Associez tous les dossiers publics et transférez au besoin tous les rôles détenus par le serveur virtuel Exchange.

  3. Désinstallez Exchange de la machine virtuelle pour le désactiver et le supprimer de votre infrastructure Exchange et du service d'annuaire Active Directory®.

Pour plus d'informations sur le déplacement des boîtes aux lettres, voir les articles suivants de la Base de connaissances Microsoft :

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975 sur les différences entre les méthodes de transfert de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Pour plus d'informations sur la prise en charge des ordinateurs Exchange Server fonctionnant dans des environnements virtuels, voir l'article 320220 de la Base de connaissances Microsoft sur les limites de prise en charge pour Exchange Server sur une machine virtuelle ou d'émulation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Pour plus d'informations sur Microsoft Virtual Server 2005, voir le site Web http://go.microsoft.com/fwlink/?linkid=34938.

Pour plus d'informations sur Microsoft Virtual PC 2004, voir le site Web http://go.microsoft.com/fwlink/?linkid=34663.


Le rôle FSMO d'appellation du domaine n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut fSMORoleOwner du maître des opérations d'appellation de domaine dans le contexte de nommage de configuration. Par exemple, dans un domaine nommé contoso.com, fSMORoleOwner pour le maître des opérations d'appellation de domaine est un attribut de CN=Partitions,CN=Configuration,DC=contoso,DC=com. Exchange Server Analyzer tente ensuite d'ouvrir une connexion LDAP sur le port TCP 389 du contrôleur de domaine qui tient actuellement ce rôle. Si Exchange Server Analyzer ne peut pas se connecter à ce contrôleur de domaine, une erreur s'affiche.

Le maître des noms de domaine est un rôle de maître des opérations à l'échelle de la forêt, car il gère l'ajout et la suppression de toutes les partitions d'annuaire, indépendamment du domaine, dans la hiérarchie de la forêt. Le contrôleur de domaine qui tient le rôle de maître des noms de domaine est le seul contrôleur de domaine à pouvoir effectuer les opérations suivantes :

  • ajouter de nouveaux domaines à la forêt ;

  • supprimer des domaines existants de la forêt ;

  • ajouter ou supprimer des objets de référence croisée à des annuaires externes.

Il ne peut exister qu'un seul maître des noms de domaine dans l'ensemble de la forêt.

Pour corriger cette erreur

  1. Vérifiez que le serveur d'annuaire spécifié dans l'erreur est actif et accessible par les serveurs Exchange de votre organisation.

  2. Si ce serveur d'annuaire a été désactivé, vous devez attribuer le rôle de maître des noms de domaine à un autre contrôleur de domaine.

Pour plus d'informations sur le transfert du rôle de maître des opérations d'appellation de domaine d'un contrôleur de domaine à un autre, voir les articles suivants de la Base de connaissances Microsoft :

  • Pour Microsoft Windows Server™ 2003, voir l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Microsoft Windows® 2000 Server, voir l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Rôle FSMO d'appellation de domaine introuvable
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer l'attribut fSMORoleOwner du maître des opérations d'appellation de domaine dans le contexte de nommage de configuration. Par exemple, dans un domaine appelé contoso.com, fSMORoleOwner pour le maître des noms de domaine est un attribut de CN=Partitions, CN=Configuration, DC=contoso, DC=com. Exchange Server Analyzer tente ensuite d'établir une connexion LDAP (Lightweight Directory Access Protocol) avec le contrôleur de domaine. Si Exchange Server Analyzer détecte que le contrôleur de domaine spécifié dans l'attribut fSMORoleOwner ne répond pas, une erreur s'affiche.

Le contrôleur de domaine maître des noms de domaine contrôle l'ajout ou la suppression de domaines dans la forêt. Il ne peut exister qu'un seul maître des noms de domaine dans l'ensemble de la forêt.

Vous devez avoir défini un maître des noms de domaine pour votre forêt Active Directory. L'installation d'Exchange et du Service Pack d'Exchange échouera si un contrôleur de domaine maître des noms de domaine n'est pas en ligne pendant l'installation. Si le contrôleur de domaine répertorié comme contrôleur des noms de domaine est hors connexion, il doit être remis en ligne.

Pour corriger cette erreur

  1. Vérifiez que le serveur Active Directory désigné est physiquement présent.

  2. Si ce serveur d'annuaire a été désactivé, affectez le rôle de maître des noms de domaine à un autre contrôleur de domaine.

Pour plus d'informations sur la manière d'affecter le rôle de maître des noms de domaine à un autre contrôleur de domaine, voir les articles suivants de la Base de connaissances Microsoft :

  • Pour Microsoft Windows Server™ 2003, voir l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Microsoft Windows® 2000 Server, voir l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Échec de résolution de nom DNS pour le serveur d'annuaire
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool tente d'exécuter une requête DNS (Domain Name System) sur les serveurs DNS configurés pour chaque serveur de service d'annuaire Active Directory®. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une demande de résolution de nom et analyse les résultats. Si Exchange Server Analyzer ne reçoit pas une adresse IP dans les résultats de la requête, une erreur s'affiche.

Cette erreur indique qu'un serveur d'annuaire n'a pas été trouvé dans le DNS. Exchange Server et Active Directory nécessitent, pour fonctionner correctement, un DNS correctement configuré et sain. Des problèmes d'enregistrement et de résolution DNS peuvent avoir des répercussions importantes sur la capacité à envoyer, à recevoir et à remettre les messages.

Vous devez configurer correctement le DNS pour vous assurer qu'Active Directory et Exchange Server fonctionneront correctement. Pour plus d'informations sur la configuration DNS pour Active Directory, voir l'article 237675 de la Base de connaissances Microsoft sur la configuration du serveur DNS pour Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675).

Pour corriger cette erreur

  1. Vérifiez les éléments de configuration suivants pour vous assurer que le DNS est sain et que les entrées DNS d'Active Directory sont correctement enregistrées :

    • configuration IP DNS ;

    • mises à jour de zones dynamiques ;

    • redirecteurs DNS.

  2. Recherchez l'existence d'une entrée de zone racine. Affichez les zones de recherche directe dans la console de gestion DNS. Une entrée doit exister pour le domaine. D'autres entrées de zones peuvent exister. Il ne doit pas exister de zone point ("."). Si la zone point (".") existe, supprimez-la. La zone point (".") identifie le serveur DNS comme serveur racine. En général, un domaine Active Directory qui nécessite un accès (Internet) externe ne doit pas être configuré en tant que serveur DNS racine. Réenregistrez manuellement l'adresse IP du serveur d'annuaire à l'aide de Ipconfig /registerdns sur le serveur d'annuaire après avoir supprimé le point ("."). Il se peut qu'il soit nécessaire de redémarrer le service Netlogon.

  3. Rajoutez manuellement les entrées DNS d'Active Directory à l'aide de netdiag /fix sur le serveur d'annuaire.

Pour plus d'informations sur l'utilisation du DNS avec Active Directory, voir l'article 323418 de la Base de connaissances Microsoft sur la procédure d'intégration d'un DNS à une infrastructure DNS existante si Active Directory est activé dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418).

Pour plus d'informations sur le dépannage de problèmes liés au DNS et à Active Directory, voir l'article 260371 de la Base de connaissances Microsoft sur la résolution des problèmes courants d'installation d'Active Directory dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371).


L'attribut dSHeuristics n'est pas défini correctement pour l'hébergement de Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le déploiement héberge Exchange. Si le déploiement Exchange est exécuté dans un environnement hébergé, Exchange Server Analyzer interroge Active Directory pour déterminer si l'attribut dSHeuristics du conteneur du service d'annuaire est défini correctement pour un déploiement hébergeant Exchange.

Si la valeur de l'attribut dSHeuristics est différente de 1, Exchange Server Analyzer affiche un avertissement. Dans un environnement hébergeant Exchange, l'attribut dSHeuristics doit être défini sur 1.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour supprimer cet avertissement

  1. Utilisez un éditeur Active Directory tel qu'ADSI Edit pour localiser l'objet du service d'annuaire dans Active Directory.

    L'attribut dSHeuristics peut se trouver dans :

    CN=Configuration, CN=Services, CN=Windows NT, CN=Service_annuaire

  2. Entrez la valeur 1 pour dSHeuristics.

Pour plus d'informations sur les environnements hébergeant Exchange, voir les articles suivants :

  • "sur les informations pour les hôtes (http://go.microsoft.com/fwlink/?LinkId=46307)

  • sur les environnements de service hébergés dans le kit des ressources Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=46326)


Conteneur Objets système Microsoft Exchange dupliqué dans Active Directory
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le conteneur Objets système Microsoft Exchange existe dans le contexte de nommage de domaine.

Si Exchange Server Analyzer détecte un conteneur Objets système Microsoft Exchange dupliqué dans Active Directory, il affiche une erreur : « Le domaine Active Directory semble être préparé pour Exchange mais il existe plusieurs conteneurs "Objets système Microsoft Exchange". Un nettoyage peut être nécessaire. »

Cette erreur peut apparaître dans les environnements Exchange Server dans lesquels :

  • un accord de connexion de serveur ADC (Active Directory Connector) bidirectionnel d'Active Directory à Exchange Server 5.5 a été supprimé et remplacé ;

  • un nouvel accord de connexion de serveur ADC monodirectionnel d'Exchange Server 5.5 à Active Directory est en place ;

  • un environnement en mode mixte exécutant Exchange Server 5.5 a été migré vers un environnement Exchange Server 2003 ;

  • une migration vers Exchange Server 2003 a été effectuée depuis un serveur de messagerie étranger.

Lorsqu'Exchange Server Analyzer affiche cette erreur, vous devez supprimer l'unité organisationnelle (OU) ou le conteneur Objets système Microsoft Exchange dupliqué incorrect. S'il existe un conteneur Objets système Microsoft Exchange dupliqué, vous ne pouvez pas résoudre le problème en exécutant à nouveau DomainPrep. Vous devez identifier et supprimer le conteneur Objets système Microsoft Exchange dupliqué incorrect.

Pour supprimer le conteneur Objets système Microsoft Exchange dupliqué incorrect

  1. Connectez-vous au contrôleur de domaine avec des informations d'identification d'administration.

  2. Cliquez sur Démarrer, puis sur Programmes, Outils d'administration et Utilisateurs et ordinateurs Active Directory.

  3. Dans le volet de la console de gestion Utilisateurs et ordinateurs Active Directory, cliquez sur le menu Affichage et sélectionnez Fonctionnalités avancées.

  4. Dans le volet de la console de gestion Utilisateurs et ordinateurs Active Directory, recherchez l'unité organisationnelle (OU) ou le conteneur Objets système Microsoft Exchange dupliqué incorrect.

  5. Vérifiez que l'unité organisationnelle ou le conteneur Objets système Microsoft Exchange dupliqué incorrect ne contient pas d'objet Active Directory valide.

  6. Cliquez avec le bouton droit sur l'unité organisationnelle ou le conteneur Objets système Microsoft Exchange dupliqué incorrect, puis cliquez sur Supprimer.

  7. Confirmez la suppression en cliquant sur Oui dans la boîte de dialogue.

    Remarque :
    Si vous souhaitez que la modification soit immédiatement répliquées, vous devez lancer manuellement la réplication entre les contrôleurs de domaine.

Pour plus d'informations sur cette erreur avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 316280 sur une description de l'attribut ADC Global Names (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280)

  • 252228 sur la création d'objets dupliqués par ADC (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228)

  • 253800 sur la création possible d'objets dupliqués par ADC dans Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800)

  • 274480 sur la création d'objets dupliqués lors de la réplication d'objets d'Exchange Server 5.5 vers Windows 2000 Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480)

  • 288578 sur la création de comptes dupliqués par ADC dans Exchange Server 5.5 et Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578)


Erreur lors de l'accès à Active Directory
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé qu'un contrôleur de domaine du service d'annuaire Active Directory® peut ne pas être disponible. Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.

Pour corriger cette erreur

  • Si vous avez spécifié un contrôleur de domaine Active Directory dans Exchange Server Analyzer, essayez de vous connecter sans spécifier de contrôleur de domaine.

  • Si vous n'avez pas spécifié de contrôleur de domaine, indiquez-en un en cours d'exécution et qui est disponible pour vous.


Erreur lors de l'accès aux groupes d'administration d'Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé qu'une organisation Exchange a été installée dans la forêt du service d'annuaire Active Directory® et que vous êtes parvenu à accéder aux informations de configuration de l'organisation Exchange dans Active Directory. Toutefois, aucun groupe d'administration contenant des serveurs Exchange n'a été détecté.

Pour corriger cette erreur :

  • Vérifiez que vous disposez des autorisations appropriées dans Active Directory pour accéder au conteneur pour les groupes d'administration Exchange.

  • Si la station de travail sur laquelle vous exécutez Exchange Server Analyzer fait partie d'une autre forêt Active Directory ou si vous êtes connecté avec un compte de domaine, vous risquez de devoir vous connecter à un contrôleur de domaine Active Directory pour une forêt qui héberge des serveurs Exchange.


Erreur lors de l'accès au conteneur de configuration d'Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que le conteneur de configuration d'Exchange est inaccessible. Les informations sur l'organisation, les groupes d'administration et la configuration serveur Exchange sont stockées dans le contexte d'appellation de configuration du service d'annuaire Active Directory®. Pour accéder aux informations de configuration Exchange, vous devez pouvoir lire la branche Microsoft Exchange du conteneur de configuration Active Directory.

Pour corriger cette erreur :

  • Vérifiez que vous disposez des autorisations nécessaires pour lire le conteneur de configuration Active Directory.

  • Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.


Le groupe de sécurité Tout le monde a le droit de créer des dossiers publics de haut niveau
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'identificateur de sécurité (SID) du groupe de sécurité Tout le monde est répertorié dans l'attribut ntSecurityDescriptor de l'objet de l'organisation Exchange. Si Exchange Server Analyzer détecte que le SID du groupe Tout le monde est présent dans l'attribut ntSecurityDescriptor de l'objet de l'organisation, un avertissement s'affiche. Cet avertissement indique que le groupe Tout le monde ne s'est pas vu refuser le droit de créer des dossiers publics de haut niveau.

Dans Exchange 2000 Server, le droit de créer des dossiers publics de haut niveau est accordé par défaut. Cependant, si la version Exchange Server 2003 de ForestPrep ou la version Exchange Server 2007 de PrepareAD est exécutée, le groupe de sécurité Tout le monde se voit refuser le droit de créer des dossiers publics de haut niveau. La fonctionnalité de refus est exécutée comme une mesure de sécurité. En autorisant le groupe de sécurité Tout le monde à créer des dossiers publics de haut niveau, votre organisation peut devenir vulnérable aux attaques par déni de service.

Par conséquent, il est recommandé de refuser le droit de créer des dossiers publics de haut niveau au groupe de sécurité Tout le monde. Si vous disposez d'Exchange Server 2003 ou d'Exchange Server 2007, vous devez exécuter la version Exchange Server 2003 de ForestPrep ou la version Exchange Server 2007 de PrepareAD. Vous pouvez exécuter la version Exchange Server 2003 de ForestPrep dans un environnement Exchange 2000 Server. Toutefois, les installations ultérieures d'Exchange 2000 Server rétabliront les autorisations permettant au groupe de sécurité Tout le monde de créer des dossiers publics de haut niveau.

Si vous ne disposez ni d'Exchange Server 2003 ni d'Exchange Server 2007, vous pouvez définir cette autorisation manuellement. Rappelez-vous que les installations ultérieures d'Exchange 2000 Server rétabliront ces autorisations. Par conséquent, vous devez configurer manuellement cette autorisation après chaque installation d'Exchange 2000 Server. Avant de définir cette autorisation, vous devez activer l'onglet Sécurité pour qu'il s'affiche dans le Gestionnaire système Exchange en ajoutant l'entrée ShowSecurityPage au Registre sur l'ordinateur Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour ajouter l'entrée ShowSecurityPage au Registre

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

  3. Cliquez sur Modifier, sur Nouveau, puis sur Valeur DWORD.

  4. Entrez ShowSecurityPage comme nom de la nouvelle valeur et appuyez sur ENTRÉE.

  5. Double-cliquez sur ShowSecurityPage, entrez 1 dans le champ Données de la valeur, puis cliquez sur OK.

Pour refuser manuellement au groupe de sécurité Tout le monde le droit de créer des dossiers publics de haut niveau dans un environnement Exchange 2000 Server

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez avec le bouton droit sur Nom_Organisation, puis cliquez sur Propriétés.

  3. Sur la page Propriétés de Nom_Organisation, cliquez sur l'onglet Sécurité.

  4. Sous l'onglet Sécurité, sélectionnez Tout le monde dans Noms de groupes ou d'utilisateurs. Dans la zone Permissions for Everyone, faites défiler jusqu'à l'autorisation Create top-level public folder, désactivez la case à cocher dans la colonne Autoriser et cliquez sur Appliquer.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'exécution d'Exchange Server 2003 ForestPrep, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur l'exécution d'Exchange Server 2007 PrepareAD, consultez la page « Procédure de préparation d'Active Directory et de domaines » (http://go.microsoft.com/fwlink/?LinkId=78453).

Pour plus d'informations sur la manière de refuser au groupe de sécurité Tout le monde le droit de créer un dossier public de haut niveau dans Exchange 2000 Server, consultez l'article 328808 de la Base de connaissances Microsoft, « COMMENT FAIRE : Suppression de l'autorisation de création de dossiers publics de niveau supérieur sous Exchange 2000 Server » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328808).


Problème de conteneur de domaine Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le conteneur Objets système Microsoft Exchange existe dans le contexte de nommage de domaine. Si Exchange Server Analyzer détecte que le conteneur Objets système Microsoft Exchange n'existe pas, n'est pas valide ou est incorrect, une erreur s'affiche.

Le conteneur Objets système Microsoft Exchange est créé dans chaque domaine lors de l'exécution d'Exchange DomainPrep.

Vous devez exécuter DomainPrep dans le domaine où cette erreur est détectée. Le nom du domaine dont le conteneur Objets système Microsoft Exchange est manquant figure dans les résultats d'Exchange Server Analyzer.

Le compte utilisé pour exécuter DomainPrep doit être membre du groupe de sécurité Admins du domaine sur le domaine local et administrateur local.

Vous devez généralement exécuter DomainPrep sur les domaines suivants :

  • le domaine racine ;

  • tous les domaines comportant des ordinateurs Exchange 2000 Server ou Exchange Server 2003 ;

  • tous les domaines comportant des objets à boîte aux lettres activée Exchange 2000 Server ou Exchange Server 2003 (tels que les utilisateurs et groupes), même si aucun serveur Exchange n'est installé sur ces domaines ;

  • tous les domaines comportant des serveurs de catalogue global pouvant être potentiellement utilisés par les composants d'accès à l'annuaire Exchange ;

  • tous les domaines comportant des utilisateurs et groupes Exchange 2000 Server ou Exchange Server 2003 permettant de gérer votre organisation Exchange.

Pour exécuter DomainPrep

  1. Insérez le CD-ROM d'Exchange dans votre lecteur. Vous pouvez exécuter DomainPrep sur n'importe quel ordinateur du domaine.

  2. À l'invite de commandes, entrez <lecteur>:\setup\i386\setup /DomainPrep, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants assurez-vous que Action est défini sur DomainPrep. Dans le cas contraire, cliquez sur la flèche vers le bas, puis sur DomainPrep. Cliquez sur Suivant.

  7. Sur la page Fin de l'Assistant Installation de Microsoft Exchange, cliquez sur Terminer.

Pour plus d'informations sur l'exécution d'Exchange Server 2003 DomainPrep, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur l'exécution d'Exchange 2000 Server DomainPrep, voir le livre blanc sur l'installation et le paramétrage de Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=5906).


Groupe Serveurs de domaine Exchange introuvable
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut ntSecurityDescriptor de l'objet Objets système Microsoft Exchange pour déterminer quelle version de DomainPrep a été exécutée dans le domaine.

Deux entiers valides sont disponibles :

  • Pour Exchange 2000 Server, la valeur ntSecurityDescriptor est 4 406.

  • Pour Exchange Server 2003, la valeur ntSecurityDescriptor est 6 936.

S'il a été déterminé que les versions ci-dessus de DomainPrep ont été utilisées, Exchange Server Analyzer interroge Active Directory pour déterminer la valeur de l'attribut objectGuid de l'objet Objets système Microsoft Exchange pour déterminer si le groupe Serveurs de domaine Exchange existe. Si Exchange Server Analyzer détermine que ce groupe n'existe pas, une erreur s'affiche.

Pour corriger cette erreur, exécutez la dernière version commerciale d'Exchange 2000 Server DomainPrep ou Exchange Server 2003 DomainPrep. Le compte utilisé pour exécuter DomainPrep doit être membre du groupe de sécurité Admins du domaine sur le domaine local et administrateur local.

Vous devez exécuter DomainPrep sur les domaines suivants :

  • le domaine racine ;

  • tous les domaines comportant des ordinateurs Exchange 2000 Server ou Exchange Server 2003 ;

  • tous les domaines comportant des objets à boîte aux lettres activée Exchange 2000 Server ou Exchange Server 2003 (tels que les utilisateurs et groupes), même si aucun serveur Exchange n'est installé sur ces domaines ;

  • tous les domaines comportant des serveurs de catalogue global pouvant être potentiellement utilisés par les composants d'accès à l'annuaire Exchange ;

  • tous les domaines comportant des utilisateurs et groupes Exchange 2000 Server ou Exchange Server 2003 permettant de gérer votre organisation Exchange.

Pour exécuter DomainPrep

  1. Insérez le CD-ROM d'Exchange dans votre lecteur. Vous pouvez exécuter DomainPrep sur n'importe quel ordinateur du domaine.

  2. À l'invite de commandes, entrez <lecteur>:\setup\i386\setup /DomainPrep, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants assurez-vous que Action est défini sur DomainPrep. Dans le cas contraire, cliquez sur la flèche vers le bas, puis sur DomainPrep. Cliquez sur Suivant.

  7. Sur la page Fin de l'Assistant Installation de Microsoft Exchange, cliquez sur Terminer.

Pour plus d'informations sur l'exécution d'Exchange Server 2003 DomainPrep, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur l'exécution d'Exchange 2000 Server DomainPrep, voir le livre blanc sur l'installation et le paramétrage de Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=5906).


Groupe Serveurs Exchange Enterprise introuvable
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut ntSecurityDescriptor de l'objet Objets système Microsoft Exchange pour déterminer quelle version de DomainPrep a été exécutée dans le domaine.

Deux entiers valides sont disponibles :

  • Pour Exchange 2000 Server, la valeur ntSecurityDescriptor est 4 406.

  • Pour Exchange Server 2003, la valeur ntSecurityDescriptor est 6 936.

S'il a été déterminé que les versions ci-dessus de DomainPrep ont été utilisées, Exchange Server Analyzer interroge Active Directory pour déterminer la valeur de l'attribut objectGuid de l'objet Objets système Microsoft Exchange pour déterminer si le groupe Serveurs Exchange Enterprise existe. Si Exchange Server Analyzer détermine que ce groupe n'existe pas, une erreur s'affiche.

Pour corriger cette erreur, exécutez la dernière version commerciale d'Exchange 2000 Server DomainPrep ou Exchange Server 2003 DomainPrep. Le compte utilisé pour exécuter DomainPrep doit être membre du groupe de sécurité Admins du domaine sur le domaine local et administrateur local.

Vous devez exécuter DomainPrep sur les domaines suivants :

  • le domaine racine ;

  • tous les domaines comportant des ordinateurs Exchange 2000 Server ou Exchange Server 2003 ;

  • tous les domaines comportant des objets à boîte aux lettres activée Exchange 2000 Server ou Exchange Server 2003 (tels que les utilisateurs et groupes), même si aucun serveur Exchange n'est installé sur ces domaines ;

  • tous les domaines comportant des serveurs de catalogue global pouvant être potentiellement utilisés par les composants d'accès à l'annuaire Exchange ;

  • tous les domaines comportant des utilisateurs et groupes Exchange 2000 Server ou Exchange Server 2003 permettant de gérer votre organisation Exchange.

Pour exécuter DomainPrep

  1. Insérez le CD-ROM d'Exchange dans votre lecteur. Vous pouvez exécuter DomainPrep sur n'importe quel ordinateur du domaine.

  2. À l'invite de commandes, entrez <lecteur>:\setup\i386\setup /DomainPrep, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants assurez-vous que Action est défini sur DomainPrep. Dans le cas contraire, cliquez sur la flèche vers le bas, puis sur DomainPrep. Cliquez sur Suivant.

  7. Sur la page Fin de l'Assistant Installation de Microsoft Exchange, cliquez sur Terminer.

Pour plus d'informations sur l'exécution d'Exchange Server 2003 DomainPrep, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur l'exécution d'Exchange 2000 Server DomainPrep, voir le livre blanc sur l'installation et le paramétrage de Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=5906).


Objet Exchange dans le conteneur LostAndFound
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-01

L'outil Microsoft® Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer s'il existe des objets dans le conteneur LostAndFoundConfig sous le conteneur Configuration. Si Exchange Server Analyzer détecte que des objets existent dans le conteneur LostAndFoundConfig, une erreur s'affiche avec l'objet et la classe dont il dérive.

Le conteneur LostAndFoundConfig contient les objets qui ne peuvent pas être rapprochés par Active Directory. Assurez-vous de supprimer tous les objets qui figurent dans le conteneur LostAndFoundConfig car Exchange tentera de les utiliser. Par exemple, lorsqu'Exchange interroge Active Directory par classe d'objet (c'est-à-dire, les serveurs), tous les objets, qu'ils se trouvent ou non dans le conteneur LostAndFoundConfig, sont renvoyés comme des objets valides. Par conséquent, Exchange peut essayer de se connecter au serveur qui est sous le conteneur the LostAndFoundConfig plutôt qu'à l'objet réel. Cela pourrait entraîner un comportement imprévisible d'Exchange, voire une défaillance du serveur. La présence de ces objets pourrait également empêcher la création d'objets de la même classe.

Pour résoudre ce problème, vous devez supprimer les entrées dans le conteneur LostAndFoundConfig d'Active Directory en utilisant ADSI (Active Directory Service Interfaces) Edit.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Remarque :
ADSI Edit est un outil fourni avec les outils de support de Windows 2000 Server et Windows Server 2003.

Pour corriger cette erreur

  1. Ouvrez le composant logiciel enfichable MMC ADSI Edit.

  2. Dans le menu Action, cliquez sur Se connecter à.

  3. Dans la boîte de dialogue Paramètres de connexion, dans le champ Nom, entrez un nom pour la connexion ADSI. Sous Point de connexion, sélectionnez Sélectionner un contexte de nommage connu, puis Configuration dans le menu déroulant. Cliquez sur OK.

  4. Dans le volet gauche, double-cliquez sur l'objet Configuration, puis sur LostAndFoundConfig.

  5. Dans le volet droit, supprimez tous les objets et conteneurs. Cliquez avec le bouton droit sur l'objet ou le conteneur, cliquez sur Supprimer, puis cliquez sur Oui.

  6. Quittez ADSI Edit.


L'organisation Exchange n'a aucune stratégie de destinataire
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut Name dans l'objet Stratégie de destinataire pour chaque organisation Exchange. Si Exchange Server Analyzer détecte qu'il n'y a pas d'objet Stratégie de destinataire ou que l'objet Stratégie de destinataire ne contient aucune stratégie de destinataire, une erreur s'affiche.

L'installation Exchange Server créée une stratégie de destinataire par défaut qui applique les adresses SMTP (Simple Mail Transfer Protocol) et X.400 à tous les destinataires de votre organisation Exchange. Vous pouvez modifier la stratégie par défaut ou en créer de nouvelles. Toutefois, vous ne devez pas supprimer la stratégie par défaut. Tous les destinataires d'une organisation Exchange doivent avoir des adresses SMTP et X.400. Si l'organisation Exchange n'a pas de stratégies de destinataire, cela entraînera des problèmes de fiabilité.

Pour créer une stratégie de destinataire

  1. Cliquez sur Démarrer, Tous les programmes, Microsoft Exchange, puis Gestionnaire système.

  2. Dans le volet gauche du Gestionnaire système Exchange, développez l'organisation, puis Destinataires, cliquez avec le bouton droit sur Stratégies de destinataire, pointez sur Nouveau et cliquez sur Stratégie de destinataire.

  3. Dans la boîte de dialogue Nouvelle stratégie, choisissez le type de stratégie que vous souhaitez créer en activant la case à cocher Adresses de messagerie, Paramètres du gestionnaire de boîtes aux lettres ou les deux, et en cliquant sur OK.

  4. Dans la boîte de dialogue Propriétés, entrez un nom pour la nouvelle stratégie de destinataire, puis cliquez sur Modifier pour créer un filtre pour la stratégie de destinataire.

    Remarque :
    Si vous ne créez pas de filtre, la stratégie ne s'appliquera à aucun destinataire.

  5. Pour personnaliser la stratégie de destinataire, passez sous l'onglet E-Mail Addresses (Policy) ou sous l'onglet Paramètres du gestionnaire de boîtes aux lettres (Stratégie) dans la boîte de dialogue Propriétés. Utilisez les paramètres proposés sous ces onglets pour configurer la stratégie de destinataire, puis cliquez sur OK pour créer la stratégie.

  6. Cliquez avec le bouton droit sur la stratégie de destinataire dans le Gestionnaire système Exchange, puis cliquez sur Appliquer la stratégie maintenant.

Pour plus d'informations sur les destinataires et les stratégies de destinataire, voir la rubrique sur la gestion des destinataires et des stratégies de destinataire dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

Pour plus d'informations sur la création et la configuration des stratégies de destinataire, voir l'article 249299 de la Base de connaissances Microsoft sur la procédure de configuration des stratégies de destinataire dans Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299).


L'organisation Exchange n'a aucune stratégie système
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nom de chaque stratégie système dans l'objet Stratégies système pour chaque organisation Exchange. Si Exchange Server Analyzer détecte qu'il n'y a pas d'objet Stratégies système ou que l'objet Stratégies système ne contient aucune stratégie système, une erreur s'affiche.

Ces objets Stratégies système vous permettent de simplifier l'administration du système en configurant les paramètres pour plusieurs serveurs Exchange grâce à un seul objet de configuration, tel que la banque de boîtes aux lettres, la banque de dossiers publics ou les paramètres du serveur. Par défaut, les stratégies système suivantes sont créées lorsque vous exécutez ForestPrep dans votre organisation :

  • Hidden DL Membership

  • Mail-Enabled Recipient

  • Mailbox-Enabled User

Si ces stratégies système par défaut n'existent pas dans votre organisation Exchange, cela entraînera des problèmes de fiabilité. Pour recréer les stratégies systèmes par défaut, exécutez ForestPrep.

Pour exécuter Exchange Server 2003 ForestPrep

  1. Insérez le CD-ROM d'Exchange dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter et entrez lecteur:\setup\i386\setup /ForestPrep, oùlecteur correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants assurez-vous que Action est défini sur ForestPrep. Dans le cas contraire, cliquez sur la flèche vers le bas, puis sur ForestPrep. Cliquez sur Suivant.

    Important :
    Si ForestPrep n'apparaît pas sous Action, il est possible que vous ayez mal orthographié la commande ForestPrep à l'étape 2. Dans ce cas, retournez à cette étape et entrez de nouveau la commande.

  7. Sur la page Microsoft Exchange Server Administrator Account, dans la boîte de dialogue Compte, entrez le nom du compte ou du groupe responsable de l'installation d'Exchange.

    Remarque :
    Le compte que vous spécifiez obtient également l'autorisation d'utiliser l'Assistant Délégation d'administration Exchange pour créer d'autres comptes administrateur Exchange. Pour plus d'informations sur l'Assistant Délégation d'administration Exchange, voir le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617).

  8. Cliquez sur Suivant pour démarrer ForestPrep. Après le démarrage de ForestPrep, vous ne pouvez plus annuler la procédure.

    Remarque :
    Selon la topologie de votre réseau et la vitesse de votre contrôleur de domaine Microsoft Windows® 2000 Server ou Microsoft Windows Server™ 2003, la procédure peut prendre un certain temps.

  9. Sur la page Fin de l'Assistant Installation de Microsoft Exchange, cliquez sur Terminer.

Pour plus d'informations sur l'utilisation des stratégies système dans Exchange, voir l'article 253838 de la Base de connaissances Microsoft sur la manière dont le service de mise à jour de destinataire applique les stratégies système (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838)

Pour plus d'informations sur les stratégies système, voir la rubrique sur l'architecture du Gestionnaire système Exchange dans le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Pour plus d'informations sur la création de stratégies système non configurées par défaut dans Exchange, voir l'article 256141 de la Base de connaissances sur la procédure de création de stratégies système dans Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141).


Le port NSPI de catalogue global a été remplacé
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-01-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante sur les serveurs de catalogue global pour déterminer si la clé de Registre TCP/IP Port est définie :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

Si Exchange Server Analyzer détecte que la clé de Registre TCP/IP Port a été créée et est définie, un message indiquant une configuration autre que celle par défaut s'affiche.

La clé de Registre du port TCP/IP est requise si un serveur de catalogue global doit utiliser un port spécifique pour servir des clients MAPI. S'il n'y a pas de tel besoin dans votre environnement Exchange, vous pouvez supprimer cette clé.

.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Suppression du port TCP/IP sur le serveur de catalogue global

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

  3. Cliquez avec le bouton droit sur la clé TCP/IP Port, puis cliquez sur Supprimer.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la configuration de RPC sur HTTP, consultez les articles suivants de la Base de connaissances :

  • 833401 sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330 sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)

  • 298369 sur la procédure de configuration d'un serveur de catalogue global pour qu'il utilise un port spécifique lorsqu'il communique avec des clients MAPI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369)

  • 24823 sur les scénarios de déploiement de la fonctionnalité RPC sur HTTP sur Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=24823).


Le port 3268 de catalogue global ne répond pas
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut isGlobalCatalogReady de ce serveur. La valeur True indique que le serveur d'annuaire est également un serveur de catalogue global fonctionnel. La valeur False indique que le serveur d'annuaire n'est pas un serveur de catalogue global.

Ensuite, Exchange Server Analyzer se connecte au port 3268 sur le serveur Exchange pour vérifier que le port répond.

Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • Il s'agit d'un serveur de catalogue global.

  • Le port 3268 ne répond pas.

Remarque :
Ce message peut s'afficher à tort si un pare-feu est installé entre l'ordinateur exécutant Exchange Server Analyzer et le serveur de catalogue global.

Ce problème apparaît généralement lorsque la case à cocher du serveur de catalogue global a été activée mais que le serveur n'a pas été redémarré.

Pour corriger cette erreur

  • Redémarrez le serveur.

Pour plus d'informations sur la promotion des contrôleurs de domaine, voir l'article 304403 de la Base de connaissances Microsoft sur les considérations d'Exchange pour la promotion d'un contrôleur de domaine en serveur de catalogue global (http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)


Erreur de schéma de la classe de groupe
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-01

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la classe msExchBaseClass apparaît dans l'attribut auxiliaryClass des objets de groupe dans le schéma d'Active Directory.

Active Directory a prédéfini des classes qui spécifient tous les types d'objet différents que le répertoire doit posséder pour fonctionner correctement. Les définitions d'objet sont créées par l'imbrication de classes les unes dans les autres. L'imbrication de classes crée une relation parent/enfant entre les classes.

La classe msExchBaseClass est ajoutée à Active Directory lorsque vous installez Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007. La classe msExchBaseClass est la classe auxiliaire de base appliquée à toutes les classes étendues par CDO pour Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007 (CDOEX). CDOEX fournit les classes COM et les interfaces fondamentales permettant de gérer la plupart des types d'informations dans la banque d'informations Exchange.

Une modification incorrecte du schéma Active Directory peut rompre la relation entre la classe msExchBaseClass et l'attribut auxiliaryClass des objets de groupe. Cette cassure peut provoquer une instabilité du serveur Exchange, par exemple des erreurs de traitement du service de mise à jour de destinataire, ou empêcher l'installation de nouveaux serveurs Exchange Server 200x dans l'organisation.

Si Exchange Server Analyzer détecte que la classe msExchBaseClass n'apparaît pas dans l'attribut auxiliaryClass des objets de groupe dans le schéma Active Directory, cela indique que la relation est rompue. Si la classe msExchBaseClass n'apparaît pas dans l'attribut auxiliaryClass des objets de groupe dans le schéma Active Directory, Exchange Server Analyzer affiche une erreur.

Pour corriger cette erreur, contactez les services du support technique de Microsoft (http://go.microsoft.com/fwlink/?LinkId=41364).


L'hébergement de Exchange nécessite une organisation Exchange en mode natif
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'environnement Exchange Server est configuré comme un environnement hébergeant Exchange. Si l'environnement Exchange Server est un environnement hébergeant Exchange, Exchange Server Analyzer interroge Active Directory pour déterminer si l'organisation Exchange est exécutée en mode mixte.

Si l'organisation Exchange est exécutée en mode mixte, un avertissement s'affiche. Les solutions hébergeant Exchange nécessitent une organisation en mode natif.

Une fois que vous êtes passé en mode natif, vous ne pouvez pas revenir en mode mixte.

Pour passer en mode natif

  1. Démarrez le Gestionnaire système Exchange : Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans l'arborescence de la console, cliquez avec le bouton droit sur l'organisation pour laquelle vous souhaitez passer en mode natif, puis cliquez sur Propriétés.

  3. Dans Propriétés de <Nom_organisation>, sous Changement du mode d'opération, cliquez sur Changer le mode.

  4. Dans la boîte de dialogue d'avertissement, cliquez sur Oui si vous êtes sûr de vouloir passer en mode natif de façon permanente. Cliquez sur Appliquer pour accepter votre nouveau mode Exchange.

Pour profiter pleinement du mode natif Exchange, vous devez redémarrer le service de banque d'informations de Microsoft Exchange sur tous les serveurs Exchange de votre organisation. Vous ne devez pas redémarrer tous les services de banque d'informations de Microsoft Exchange simultanément, mais vous devez redémarrer le service sur chaque serveur pour que le serveur puisse profiter de toutes les fonctions du mode natif Exchange. Redémarrez le service sur vos serveurs après la réplication du changement en mode natif sur le contrôleur de domaine Microsoft Windows® local.

Pour redémarrer le service de banque d'informations de Microsoft Exchange

  1. Cliquez sur Démarrer et Exécuter, entrez services.msc, puis cliquez sur OK.

  2. Dans le volet Services (Local), recherchez le service Banque d'informations de Microsoft Exchange.

  3. Cliquez avec le bouton droit sur le service, puis cliquez sur Redémarrer.

Pour plus d'informations sur les environnements hébergeant Exchange, voir les articles suivants :

  • "sur les informations pour les hôtes (http://go.microsoft.com/fwlink/?LinkId=46307)

  • sur les environnements de service hébergé dans le kit de ressources Exchange Server 2000 (http://go.microsoft.com/fwlink/?LinkId=46326)

Pour plus d'informations sur la conversion du mode mixte en mode natif, voir l'article 32779 de la Base de connaissances Microsoft sur la procédure à suivre pour passer du mode mixte au mode natif sous Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).


Le serveur ayant le rôle FSMO d'infrastructure n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut fSMORoleOwner du maître d'infrastructure dans le contexte de nommage de domaine. Par exemple, dans un domaine nommé contoso.com, fSMORoleOwner pour le maître d'infrastructure est un attribut de CN=Infrastructure, DC=contoso, DC=com. Exchange Server Analyzer tente ensuite d'ouvrir une connexion LDAP sur le port TCP 389 du contrôleur de domaine qui tient actuellement ce rôle. Si Exchange Server Analyzer ne peut pas se connecter à ce contrôleur de domaine, une erreur s'affiche.

Le maître d'infrastructure met à jour les références groupe-utilisateur chaque fois que les membres des groupes sont renommés ou modifiés au sein d'un domaine. Le contrôleur de domaine qui tient le rôle de maître d'infrastructure pour le domaine du groupe met à jour la référence groupe-utilisateur inter-domaine pour refléter le nouveau nom de l'utilisateur. Le maître d'infrastructure analyse régulièrement les comptes de domaine et vérifie l'appartenance aux groupes. Si un compte d'utilisateur est déplacé vers un nouveau domaine, le maître d'infrastructure identifie le nouveau domaine du compte d'utilisateur et met à jour le groupe en conséquence. Après que le maître d'infrastructure met à jour ces références localement, il utilise la réplication pour mettre à jour tous les autres réplicas du domaine. Si le maître d'infrastructure n'est pas disponible, ces mises à jour sont retardées. Chaque domaine ne peut comporter à tout moment qu'un seul contrôleur de domaine agissant en tant que maître d'infrastructure.

Pour corriger cette erreur

  1. Vérifiez que le serveur d'annuaire spécifié dans l'erreur est actif et accessible par les serveurs Exchange de votre organisation.

  2. Si ce serveur d'annuaire a été désactivé, vous devez attribuer le rôle de maître d'infrastructure à un autre contrôleur de domaine.

Pour plus d'informations sur le transfert du rôle de maître d'infrastructure d'un contrôleur de domaine à un autre, voir les articles suivants de la Base de connaissances Microsoft :

  • Pour Microsoft Windows Server™ 2003, voir l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Microsoft Windows 2000 Server, voir l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Attribut de version non valide sur l'objet d'organisation Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-02-28

L'outil Microsoft Exchange Server Analyzer interroge le service d'annuaire Active Directory pour déterminer les informations de version de schéma d'Exchange. Plus spécifiquement, Exchange Server Analyzer examine l'objet Active Directory suivant pour déterminer la valeur actuelle de l'attribut rangeUpper :

CN=Pt_version_schéma_MS_Exchange,CN=Schéma,CN=Configuration,DC=<Nom_domaine_du_domaine_racine_forêt>

Une valeur rangeUpper de 4397 indique qu'Exchange 2000 Server est installé.

Une valeur rangeUpper de 6870 indique qu'Exchange Server 2003 est installé.

Une valeur rangeUpper de 10637 indique qu'Exchange Server 2007 est installé.

Si Exchange Server Analyzer détecte une valeur différente pour rangeUpper, une erreur s'affiche.

La valeur rangeUpper est entrée par Exchange 2000 Server ou Exchange Server 2003 au cours du processus ForestPrep. Une valeur autre que 4397, 6870 ou 10637 indique généralement qu'une version bêta ou une pré-version d'Exchange a été utilisée pour exécuter ForestPrep ou, en cas d'utilisation d'Exchange Server 2007, PrepareDomain.

Pour résoudre ce problème dans Exchange 2000 Server ou Exchange Server 2003, exécutez à nouveau le processus ForestPrep en utilisant la version officielle d'Exchange installée dans votre environnement. Dans Exchange Server 2007, exécutez à nouveau PrepareSchema en utilisant la version officielle d'Exchange installée dans votre environnement. Vous devez exécuter ForestPrep ou PrepareSchema en étant connecté avec un compte qui possède au minimum les droits suivants :

  • Administrateur d'entreprise

  • Administrateur de schéma

  • Administrateur de domaine

  • Administrateur de la machine locale (en cas d'exécution sur le serveur membre uniquement)

Correction de cette erreur dans Exchange 2000 Server ou Exchange Server 2003

  1. Exécutez setup.exe /forestprep.

  2. Vérifiez que le processus ForestPrep s'est exécuté avec succès.

Correction de cette erreur dans Exchange Server 2007

  1. Exécutez setup.exe /PrepareSchema.

  2. Vérifiez que le processus PrepareSchema a été exécuté avec succès.

Pour plus d'informations sur l'installation d'Exchange et l'exécution du processus PrepareSchema, consultez la documentation produit suivante :

  • « Procédure de préparation d'Active Directory et de domaines » http://go.microsoft.com/fwlink/?LinkId=78453

Pour plus d'informations sur l'installation d'Exchange et sur l'exécution du processus ForestPrep, voir les articles suivants de la Base de connaissances Microsoft :

  • 312371 sur la procédure de préparation de la forêt à l'aide de ForestPrep dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371). Cet article s'applique à Exchange 2000 Server et Exchange Server 2003.

  • 274737 sur la manière de vérifier que ForestPrep et DomainPrep ont été exécutés avec succès dans Exchange 2000 Server ou Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737).

  • 828765 sur les autorisations requises pour installer des composants dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765).


Informations sur les comptes existants présentes dans le groupe d'administration en mode natif
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchLegacyAccount sur chaque objet de groupe d'administration Exchange contient des données.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msExchAdminGroupMode de chaque groupe d'administration. Une valeur 0 pour l'attribut msExchAdminGroupMode indique que le groupe d'administration est en mode natif Exchange. Une valeur 1 indique un environnement Exchange Server 5.5 pur et une valeur 2 indique le mode mixte Exchange.

Si Exchange Server Analyzer détecte que l'attribut msExchLegacyAccount contient des données et que la valeur de l'attribut msExchAdminGroupMode est 0, une erreur s'affiche.

Lorsque vous passez en mode natif Exchange, l'attribut msExchLegacyAccount est supprimé. Cet attribut n'est utilisé que dans les organisations Exchange en mode mixte où Exchange Server 5.5 est encore présent. Les données d'attribut réelles correspondent au compte du service Exchange Server 5.5 et leur présence dans l'attribut msExchLegacyAccount dans une organisation Exchange en mode natif entraînera des défaillances au cours des mises à niveau et des installations de Service Packs. En fait, seule la présence de l'attribut, même sans données, entraînera des défaillances. Cela est dû au fait que le programme d'installation d'Exchange utilise cet attribut pour détecter si une organisation Exchange est en mode mixte ou natif. Si cet attribut existe, le programme d'installation d'Exchange s'exécute dans une configuration en mode mixte pour une installation qui est réellement en mode natif.

Il est probable que l'attribut msExchLegacyAccount existe toujours si vous avez supprimé manuellement des données d'Active Directory à l'aide du composant logiciel enfichable ADSI Edit.

Vous devez supprimer ces données de msExchLegacyAccount en modifiant manuellement l'attribut avec l'outil LDP (ldp.exe). Vous devez utiliser l'outil LDP ou un autre client LDAP version 3 qui supprimera complètement les données et l'attribut de l'annuaire. Le composant logiciel enfichable ADSI Edit n'est pas suffisant dans ce cas puisqu'il ne supprime que les données et pas l'attribut. LDP.exe est inclus dans les outils de support de Windows®.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, Exchange Server 2003 ou les deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour supprimer l'attribut msExchLegacyAccount

  1. Exécutez LDP.exe

  2. Dans le menu Connexion, cliquez sur Se connecter ; dans la boîte de dialogue Connexion, entrez le nom d'un contrôleur de domaine dans la même forêt Active Directory que votre organisation Exchange, puis cliquez sur OK.

  3. Dans le menu Connexion, cliquez sur Liaison ; dans la boîte de dialogue Liaison, entrez les informations d'identification qui disposent au moins des droits d'administrateur intégral Exchange au niveau du groupe d'administration, puis cliquez sur OK.

  4. Dans le menu Affichage, cliquez sur Arborescence ; dans la boîte de dialogue Arborescence, laissez le champ vierge si vous vous connectez à partir du domaine racine, sinon, entrez CN=Configuration,DC=Nom_domaine, DC=Suffixe_domaine où Nom_domaine correspond au domaine racine dans la forêt Active Directory et Suffixe_domaine au suffixe du domaine, par exemple, com, net et org. Cliquez sur OK.

  5. Développez la vue Hiérarchie dans le volet gauche de LDP jusqu'à l'ouverture de votre groupe d'administration. Pour ce faire, double-cliquez sur les nœuds dans l'ordre suivant (chaque nœud dans LDP est suivi par un nom unique (DN) complet ; seules les classes CN de gauche sont signalées ici pour précision) :

    1. DC=Nom_domaine

    2. CN=Configuration

    3. CN=Services

    4. CN=Microsoft_Exchange

    5. CN=Nom_organisation

    6. CN=Groupes_administration

    7. CN=Nom_groupe_administration

    Dans le volet Détails (droit) de LDP, faites défiler pour afficher les attributs de votre groupe d'administration. Si l'attribut msExchLegacyAccount s'affiche, vous devez le supprimer. Si l'attribut msExchLegacyAccount s'affiche, il est probable que les attributs msExchLegacyDomain et msExchEncryptedPassword s'affichent également. Si c'est le cas, vous devez également les supprimer.

  6. Dans le volet Hiérarchie (gauche) de LDP, cliquez avec le bouton droit sur Nom_groupe_administration, puis cliquez sur Modifier.

  7. Dans la boîte de dialogue Modifier, vérifiez que le nom unique complet répertorié dans le champ DN identifie correctement le groupe d'administration que vous devez modifier. Il doit apparaître comme suit : CN=Nom_groupe_administration, CN=Groupes_administration, CN=Nom_organisation, CN=Microsoft_Exchange, CN=Services, CN=Configuration, DC=Nom_domaine.

  8. Dans la boîte de dialogue Modifier, sous Opérations, sélectionnez Supprimer ; sous Modifier une entrée, entrez msExchLegacyAccount dans le champ Attribut, puis appuyez sur Entrée. Cette opération ajoute msExchLegacyAccount à la Liste des entrées. La Liste des entrées définit les attributs qui seront supprimés lorsque vous cliquerez sur Exécuter.

  9. Si les attributs msExchLegacyDomain et msExchEncryptedPassword figurent dans le groupe d'administration, ajoutez-les à la Liste des entrées, comme décrit à l'étape 8.

  10. Lorsque la Liste d'entrées contient les attributs qui vous devez supprimer, cliquez sur Exécuter. Un message d'état s'affichera dans le volet Détails de LDP.

  11. Dans le menu Connexion, cliquez sur Nouveau pour vider le volet Détails de LDP.

  12. Naviguez jusqu'à CN=Nom_groupe_administration et double-cliquez sur l'objet. Voir le contenu du volet droit pour vérifier que les attributs sont supprimés.

Pour plus d'informations sur la modification d'Active Directory à l'aide de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


L'attribut legacyExchangeDN de l'organisation Exchange n'est pas valide
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-02-01

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le format de l'attribut legacyExchangeDN sur l'objet d'organisation Exchange. Si Exchange Server Analyzer détecte que l'attribut legacyExchangeDN n'est pas valide ou est incorrect, une erreur s'affiche.

La valeur de cet attribut correspond à /o= Organisation, où Organisation est le nom de l'organisation Exchange. Si la valeur commence par autre chose que /o= ou /O=, elle est considérée comme incorrecte. Ce problème doit être corrigé dès que possible.

Correction de cette erreur dans Exchange 2000 Server ou Exchange Server 2003

  1. Exécutez le processus Exchange Server ForestPrep. Au cours de ce processus, si le programme d'installation détecte que le format de l'attribut legacyExchangeDN est incorrect, il corrigera automatiquement le problème.

Correction de cette erreur dans Exchange Server 2007

  1. Exécutez le processus Exchange Server PrepareAD. Au cours de ce processus, si le programme d'installation détecte que le format de l'attribut legacyExchangeDN est incorrect, il corrigera automatiquement le problème.

Pour plus d'informations sur le processus ForestPrep, voir l'article 312371 de la Base de connaissances Microsoft sur la procédure de préparation de la forêt à l'aide de ForestPrep dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371).

Pour plus d'informations sur le processus PrepareAD, consultez la page « Procédure de préparation d'Active Directory et de domaines » http://go.microsoft.com/fwlink/?LinkId=78453

Pour plus d'informations sur l'attribut legacyExchangeDN et la manière de le modifier, consultez les articles suivants de la Base de connaissances Microsoft :

  • 324606 sur l'utilisation de Legacydn.exe pour corriger l'organisation Exchange ou les noms des groupes d'administration (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606).

  • 286783 sur le message d'erreur lors de la mise à jour des données de disponibilité dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783).

  • 301585 sur les solutions de contournement des problèmes avec MBconn.exe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585).


Informations sur les domaines existants présentes dans le groupe d'administration en mode natif
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchLegacyDomain sur chaque objet de groupe d'administration Exchange contient des données.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msExchAdminGroupMode de chaque groupe d'administration. Une valeur 0 pour l'attribut msExchAdminGroupMode indique que le groupe d'administration est en mode natif Exchange. Une valeur 1 indique un environnement Exchange Server 5.5 pur et une valeur 2 indique le mode mixte Exchange.

Si Exchange Server Analyzer détecte que l'attribut msExchLegacyDomain contient des données et que la valeur de l'attribut msExchAdminGroupMode est 0, une erreur s'affiche.

Lorsque vous passez en mode natif Exchange, l'attribut msExchLegacyDomain est supprimé. Cet attribut n'est utilisé que dans les organisations Exchange en mode mixte où Exchange Server 5.5 est encore présent. Les données d'attribut réelles correspondent au domaine des comptes du service Exchange Server 5.5 et leur présence dans l'attribut msExchLegacyDomain dans une organisation Exchange en mode natif entraînera des défaillances au cours des mises à niveau et des installations de Service Packs. En fait, seule la présence de l'attribut, même sans données, entraînera des défaillances. Cela est dû au fait que le programme d'installation d'Exchange utilise cet attribut pour détecter si une organisation Exchange est en mode mixte ou natif. Si cet attribut existe, le programme d'installation d'Exchange s'exécute dans une configuration en mode mixte pour une installation qui est réellement en mode natif.

Il est probable que l'attribut msExchLegacyDomain existe toujours si vous avez supprimé manuellement des données d'Active Directory à l'aide du composant logiciel enfichable ADSI Edit.

Vous devez supprimer ces données de msExchLegacyDomain en modifiant manuellement l'attribut avec l'outil LDP (ldp.exe). Vous devez utiliser l'outil LDP ou un autre client LDAP version 3 qui supprimera complètement les données et l'attribut de l'annuaire. Le composant logiciel enfichable ADSI Edit n'est pas suffisant dans ce cas puisqu'il ne supprime que les données et pas l'attribut. LDP.exe est inclus dans les outils de support de Windows®.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour supprimer l'attribut msExchLegacyDomain

  1. Exécutez LDP.exe

  2. Dans le menu Connexion, cliquez sur Se connecter ; dans la boîte de dialogue Connexion, entrez le nom d'un contrôleur de domaine dans la même forêt Active Directory que votre organisation Exchange, puis cliquez sur OK.

  3. Dans le menu Connexion, cliquez sur Liaison ; dans la boîte de dialogue Liaison, entrez les informations d'identification qui disposent au moins des droits d'administrateur intégral Exchange au niveau du groupe d'administration, puis cliquez sur OK.

  4. Dans le menu Affichage, cliquez sur Arborescence ; dans la boîte de dialogue Arborescence, laissez le champ vierge si vous vous connectez à partir du domaine racine, sinon, entrez CN=Configuration,DC=Nom_domaine, DC=Suffixe_domaine où Nom_domaine correspond au domaine racine dans la forêt Active Directory et Suffixe_domaine au suffixe du domaine, par exemple, com, net ou org. Cliquez sur OK.

  5. Développez la vue Hiérarchie dans le volet gauche de LDP jusqu'à l'ouverture de votre groupe d'administration. Pour ce faire, double-cliquez sur les nœuds dans l'ordre suivant (chaque nœud dans LDP est suivi par un nom unique (DN) complet ; seules les classes CN de gauche sont signalées ici pour précision) :

    • DC=Nom_domaine

    • CN=Configuration

    • CN=Services

    • CN=Microsoft_Exchange

    • CN=Nom_organisation

    • CN=Groupes_administration

    • CN=Nom_groupe_administration

    Dans le volet Détails (droit) de LDP, faites défiler pour afficher les attributs de votre groupe d'administration. Si l'attribut msExchLegacyDomain s'affiche, vous devez le supprimer. Si l'attribut msExchLegacyDomain s'affiche, il est probable que les attributs msExchLegacyAccount et msExchEncryptedPassword s'affichent également. Si c'est le cas, vous devez également les supprimer.

  6. Dans le volet Hiérarchie (gauche) de LDP, cliquez avec le bouton droit sur Nom_groupe_administration, puis cliquez sur Modifier.

  7. Dans la boîte de dialogue Modifier, vérifiez que le nom unique complet répertorié dans le champ DN identifie correctement le groupe d'administration que vous devez modifier. Il doit apparaître comme suit : CN=Nom_groupe_administration, CN=Groupes_administration, CN=Nom_organisation, CN=Microsoft_Exchange, CN=Services, CN=Configuration, DC=Nom_domaine.

  8. Dans la boîte de dialogue Modifier, sous Opérations, sélectionnez Supprimer ; sous Modifier une entrée, entrez msExchLegacyAccount dans le champ Attribut, puis appuyez sur Entrée. Cette opération ajoute msExchLegacyAccount à la Liste des entrées. La Liste des entrées définit les attributs qui seront supprimés lorsque vous cliquerez sur Exécuter.

  9. Si les attributs msExchLegacyAccount et msExchEncryptedPassword figurent dans le groupe d'administration, ajoutez-les à la Liste des entrées, comme décrit à l'étape 8.

  10. Lorsque la Liste d'entrées contient les attributs qui vous devez supprimer, cliquez sur Exécuter. Un message d'état s'affichera dans le volet Détails de LDP.

  11. Dans le menu Connexion, cliquez sur Nouveau pour vider le volet Détails de LDP.

  12. Naviguez jusqu'à CN=Nom_groupe_administration et double-cliquez sur l'objet. Voir le contenu du volet droit pour vérifier que les attributs sont supprimés.

Pour plus d'informations sur la modification d'Active Directory à l'aide de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


L'attribut LegacyExchangeDN de ce groupe d'administration ne correspond pas à l'organisation parente
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-11-30

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le format de l'attribut legacyExchangeDN sur l'objet conteneur de groupe d'administration. Si Exchange Server Analyzer détecte que l'attribut legacyExchangeDN du groupe d'administration ne correspond pas à l'attribut legacyExchangeDN de l'organisation Exchange, une erreur s'affiche.

Exchange utilise la valeur legacyExchangeDN pour identifier les objets Exchange dans Active Directory. La valeur legacyExchangeDN est un nom unique qui indique l'emplacement de l'objet dans l'organisation Exchange, par exemple :

/o= organisation /ou= groupe d'administration

Des objets tels que des serveurs et des hiérarchies de dossiers héritent d'une partie de leurs valeurs legacyExchangeDN du groupe d'administration. Cela signifie qu'en cas de problème avec la valeur de groupe d'administration, de nombreux autres objets peuvent hériter du même problème.

Les problèmes relatifs à la valeur legacyExchangeDN se produisent généralement lorsqu'un administrateur a tenté de la modifier directement. Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Utilisez un éditeur Active Directory tel qu'ADSI Edit pour localiser l'objet de groupe d'administration dans Active Directory.

    L'attribut legacyExchangeDN peut se trouver dans :

    CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Organisation, CN=Groupes_administration, CN= Groupe d'administration

  2. Entrez une nouvelle valeur de chaîne du formulaire :

    /o= organisation /ou= groupe d'administration

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server.


La valeur legacyExchangeDN pour ce groupe d'administration n'est pas valide
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour vérifier la valeur legacyExchangeDN d'un groupe d'administration. Cette erreur est affichée si l'organisation ou le groupe d'administration nommé dans la valeur legacyExchangeDN ne correspond pas au nom réel de l'organisation ou du groupe d'administration, ou si une partie de la valeur est totalement manquante.

Exchange utilise la valeur legacyExchangeDN pour identifier les objets Exchange dans Active Directory. La valeur legacyExchangeDN est un nom unique qui indique l'emplacement de l'objet dans l'organisation Exchange, par exemple :

/o=organisation/ou=groupe d'administration

Des objets tels que des serveurs et des hiérarchies de dossiers héritent d'une partie de leurs valeurs legacyExchangeDN du groupe d'administration. Cela signifie qu'en cas de problème avec la valeur de groupe d'administration, de nombreux autres objets peuvent hériter du même problème.

Les problèmes relatifs à la valeur legacyExchangeDN se produisent généralement lorsqu'un administrateur a tenté de la modifier directement. Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez ces attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Utilisez un éditeur Active Directory tel qu'ADSI Edit pour localiser l'objet de groupe d'administration dans Active Directory.

    L'attribut legacyExchangeDN peut se trouver dans :

    CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Organisation, CN=Groupes_administration, CN=Groupe_administration

  2. Entrez une nouvelle valeur de chaîne du formulaire :

    /o=organisation/ou=groupe d'administration

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide en ligne de Windows Server.


Présence de groupes non universels à extension messagerie
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de domaines dans l'environnement. Si Exchange Server Analyzer détecte plusieurs domaines Active Directory discrets dans la forêt, il interroge chaque domaine pour déterminer s'il existe un ou plusieurs groupes non universels à extension messagerie dans ces domaines.

Si Exchange Server Analyzer détermine que des groupes non universels à extension messagerie existent dans la forêt à plusieurs domaines, il affiche un avertissement.

Si vous utilisez des groupes de distribution locaux ou globaux de domaines dans une forêt à plusieurs domaines, des problèmes de remise de courrier électronique peuvent apparaître pour la raison suivante :

  • Pour étendre les groupes de distribution aux destinataires individuels, Exchange contacte un serveur de catalogue global.

  • Bien que le serveur de catalogue global dispose d'une liste de groupes de tous les types de chaque domaine, il ne comporte pas de liste d'appartenance pour les groupes globaux et locaux de domaines créés dans des domaines distants.

  • Si un message est envoyé à une groupe de distribution global mais qu'il est étendu à un domaine non associé, Exchange ne peut pas transmettre correctement le message aux membres du groupe.

  • Étant donné que le catégoriseur ne peut pas étendre la liste de distribution, si un utilisateur envoie un message à un groupe de distribution global ou à un groupe de sécurité à extension messagerie dans une forêt à plusieurs domaines, les utilisateurs du groupe de distribution global ne recevront peut-être pas le message.

  • La dernière entrée dans les journaux de suivi est un dépôt de message au catégoriseur. L'expéditeur du message ne reçoit pas de rapport de non-remise.

Pour résoudre ce problème et s'assurer de la remise du courrier électronique, utilisez les groupes de distribution universels dans un environnement à plusieurs domaines. L'appartenance aux groupes de distribution universels est répliquée sur chaque serveur de catalogue global dans chaque domaine

Pour plus d'informations sur ce problème et sur les groupes de distribution universels, voir les rubriques suivantes sur :

  • l'utilisation des groupes à extension messagerie dans des environnements à plusieurs domaines dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  • la section sur la portée du groupe dans l'article sur la compréhension des groupes dans Active Directory (http://go.microsoft.com/fwlink/?LinkId=51276).

  • les indications de création de groupes de distribution basés sur la demande dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

De plus, voir aussi les articles suivants de la Base de connaissances Microsoft :

  • 231273 sur le non-fonctionnement de la remise de messages aux groupes globaux (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930).

  • 283051 sur la disparition possible des courriers électroniques envoyés aux groupes globaux à extension messagerie (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051).

  • 231273 sur le type de groupe et l'utilisation de la portée dans Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231273).


Modification requise de la stratégie système Utilisateur à boîte aux lettres activée
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-08-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut purportedSearch pour chaque objet Stratégie système Exchange. L'attribut purportedSearch indique l'argument de recherche utilisé lors de l'application de la stratégie.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msDS-Behavior-Version de l'objet de forêt dans Active Directory, Paramètres NTDS. Cette valeur indique le niveau fonctionnel de la forêt Active Directory. Les valeurs valides pour l'attribut msDS-Behavior-Version sont indiquées dans le tableau suivant.

Valeur | Niveau fonctionnel de la forêt
0 | Microsoft Windows® 2000 Server mixte
1 | Microsoft Windows Server™ 2003 intermédiaire
2 | Microsoft Windows Server 2003 natif

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut revision du conteneur Windows2003Update. La valeur de cet attribut indique si l'utilitaire de préparation (ADPrep.exe) d'Active Directory est exécuté.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de la clé OSProductSuite indique la version de Windows utilisée sur l'ordinateur.

Si Exchange Server Analyzer détecte que les critères suivants sont vrais, un avertissement s'affiche :

  • La valeur de l'attribut purportedSearch de la stratégie système Utilisateur à boîte aux lettres activée n'est pas égale à (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

  • Le niveau fonctionnel de la forêt Active Directory est Windows Server 2003 intermédiaire ou Windows Server 2003 natif.

  • L'ordinateur Exchange Server n'utilise pas Windows Small Business Server 2003.

Pour éviter des problèmes de déplacement de boîtes aux lettres, il est nécessaire de modifier les stratégies système. Cette mise à jour peut être effectuée à l'aide d'ADSI (Active Directory Service Interfaces) Edit (ADSIEdit.msc), de l'outil LDP (ldp.exe) ou d'un autre outil d'édition Active Directory.

Si Windows Server 2003 est utilisé comme contrôleur de domaine et si la stratégie Utilisateur à boîte aux lettres activée n'est pas mise à jour, la réplication de la valeur y afférente dans Windows Server 2003 entraîne l'écrasement de la valeur de l'attribut homeMDB des nouveaux utilisateurs et le déplacement de leurs boîtes aux lettres dans la première banque du serveur par le service de mise à jour de destinataire.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Windows Server 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour corriger cette erreur

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Sélectionnez CN=Stratégies_système.

  4. Dans le volet droit, cliquez avec le bouton droit sur CN=Utilisateur_à_boîte_aux_lettres_activée, puis sélectionnez Propriétés.

  5. Faites défiler pour sélectionner l'attribut purportedSearch, puis cliquez sur Modifier.

  6. Effacez l'attribut, puis configurez-le avec le filtre suivant :

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    Remarque :
    Le filtre présenté à l'étape 6 a été renvoyé à la ligne pour une meilleure lisibilité. Veillez à entrer le filtre sans espace ni retour à la ligne.

  7. Cliquez sur OK pour enregistrer la modification et fermez ADSI Edit.

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objet Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur ce problème et ses conséquences, voir l'article 903291 de la Base de connaissances Microsoft sur le service de mise à jour de destinataire qui risque de remplacer la valeur de l'attribut homeMDB pour des nouveaux utilisateurs Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291).


Interface MAPI désactivée dans le catalogue global
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la clé de Registre existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

Si Exchange Server Analyzer détecte que la clé Initialize MAPI interface est présente et configurée de sorte à avoir une valeur numérique, il affiche une erreur.

Si la clé de Registre Initialize MAPI interface est présente, les clients Microsoft Office Outlook® ne pourront pas contacter le carnet d'adresses sur ce serveur. Pour résoudre ce problème, vous devez supprimer la clé de Registre Initialize MAPI interface.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

  3. Cliquez avec le bouton droit sur la clé Initialize MAPI interface et sélectionnez Supprimer.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la clé de Registre Initialize MAPI interface, voir l'article 275127 de la Base de connaissances Microsoft sur la procédure de configuration d'Exchange Server 5.5 pour qu'il s'exécute sur un contrôleur de domaine qui est un catalogue global (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127)


La valeur MaxActiveQueries a été modifiée
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre maximal de requêtes LDAP pouvant être traitées simultanément. Cette valeur est obtenue grâce à l'examen des stratégies d'administration LDAP actuelles. Exchange Server Analyzer recherche en particulier la présence de MaxActiveQueries. Si Exchange Server Analyzer détermine que MaxActiveQueries existe et est configuré avec une valeur différente de 20, un message indiquant une configuration autre que celle par défaut s'affiche.

Les limites d'administration LDAP compensent les possibilités opérationnelles d'Active Directory et ses performances. Ces limites empêchent les opérations spécifiques d'affecter défavorablement les performances du serveur. L'augmentation de ce paramètre à une valeur supérieure à celle par défaut peut avoir un effet secondaire sur votre infrastructure Active Directory.

La valeur MaxActiveQueries de l'attribut LDAPAdminLimits contrôle le nombre maximal de requêtes LDAP simultanées pour la stratégie de requête par défaut. Par défaut, une limite de 20 requêtes actives est imposée. Si cette limite est atteinte, Active Directory renvoie « LDAP_ADMIN_LIMIT_EXCEEDED » et ne traite plus aucune requête LDAP.

Pour démarrer Ntdsutil.exe

  1. Cliquez sur Démarrer, puis sur Exécuter.

  2. Dans la zone de texte Ouvrir, entrez ntdsutil, puis appuyez sur Entrée. Pour afficher l'Aide à tout moment, entrez ? à l'invite de commandes.

Pour afficher les paramètres de stratégie

  1. À l'invite de commandes de Ntdsutil.exe, entrez LDAP policies, puis appuyez sur Entrée.

  2. À l'invite de commandes de stratégie LDAP, entrez connections, puis appuyez sur Entrée.

  3. À l'invite de commandes de connexion au serveur, entrez connect to server nom de serveur DNS, puis appuyez sur Entrée. Vous souhaitez vous connecter au serveur avec lequel vous travaillez actuellement.

  4. À l'invite de commandes de connexion au serveur, entrez q, puis appuyez sur Entrée pour revenir au menu précédent.

  5. À l'invite de commandes de stratégie LDAP, entrez Show Values, puis appuyez sur Entrée.

    Les stratégies existantes s'affichent.
Remarque :
Cette procédure n'indique que les paramètres Stratégie de domaine par défaut. Si vous appliquez votre propre paramètre de stratégie, il ne s'affichera pas.

Pour modifier les paramètres de stratégie

  1. À l'invite de commandes de Ntdsutil.exe, entrez LDAP policies, puis appuyez sur Entrée.

  2. À l'invite de commandes de stratégie LDAP, entrez Set MaxActiveQueries to 20, puis appuyez sur ENTRÉE.

    Vous pouvez utiliser la commande Show Values pour vérifier vos modifications.

  3. Pour enregistrer les modifications, utilisez Commit Changes.

  4. Lorsque vous avez terminé, entrez q, puis appuyez sur Entrée.

  5. Pour quitter Ntdsutil.exe, à l'invite de commandes, entrez q, puis appuyez sur Entrée.

Pour plus d'informations sur la configuration des stratégies LDAP, voir l'article 315071 de la Base de connaissances Microsoft sur la procédure d'affichage et de définition des stratégies LDAP à l'aide de Ntdsutil.exe dans Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


Le paramètre MaxPageSize n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool vérifie la configuration LDAP d'un contrôleur de domaine en vérifiant les attributs de l'objet de stratégie de requête par défaut dans le conteneur de stratégies de requête dans Active Directory®. Si Exchange Server Analyzer détermine que la valeur MaxPageSize de l'attribut LDAPAdminLimits a été modifiée et diffère de sa valeur par défaut de 1000, un message indiquant une configuration autre que celle par défaut s'affiche.

Les limites d'administration LDAP compensent les possibilités opérationnelles d'Active Directory et ses performances. Ces limites empêchent des opérations spécifiques d'affecter défavorablement les performances du serveur et permettent à ce dernier de résister aux attaques par déni de service. L'augmentation de ce paramètre à une valeur supérieure à celle par défaut peut avoir un effet secondaire sur votre infrastructure Active Directory.

Les stratégies LDAP sont mises en œuvre à l'aide d'objets de la classe queryPolicy. Des objets de stratégie de requête peuvent être créés dans le conteneur de stratégies de requête, qui est un enfant du conteneur du service d'annuaire dans le contexte de nommage de configuration.

La valeur MaxPageSize de l'attribut LDAPAdminLimits contrôle le nombre d'enregistrements qui peuvent être renvoyés pour une requête LDAP. La valeur par défaut est de 1 000 enregistrements. Si plus de 1 000 éléments sont renvoyés, Active Directory voit cette valeur maximale et ne renvoie rien.

Cette limite contrôle les nombres supportables de plusieurs types d'objets Active Directory. Par exemple, chaque organisation peut disposer, au maximum, de 1 000 serveurs, de 1 000 groupes d'administration et de 1 000 listes d'adresses ; chaque groupe d'administration peut comporter, au maximum, 1 000 groupes de routage, et chaque groupe de routage, 1 000 connecteurs.

À moins d'avoir été invité par les services du Support Technique de Microsoft à utiliser une autre valeur, vous devez redéfinir cette valeur sur 1 000.

Pour démarrer Ntdsutil.exe

  1. Cliquez sur Démarrer, puis sur Exécuter.

  2. Dans la zone de texte Ouvrir, entrez ntdsutil, puis appuyez sur ENTRÉE. Pour afficher l'Aide à tout moment, entrez ? à l'invite de commandes.

Pour afficher les paramètres de stratégie

  1. À l'invite de commandes de Ntdsutil.exe, entrez LDAP policies, puis appuyez sur ENTRÉE.

  2. À l'invite de commandes de stratégie LDAP, entrez connections, puis appuyez sur ENTRÉE.

  3. À l'invite de commandes de connexion au serveur, entrez connect to server nom de serveur DNS, puis appuyez sur ENTRÉE. Vous souhaitez vous connecter au serveur avec lequel vous travaillez actuellement.

  4. À l'invite de commandes de connexion au serveur, entrez q, puis appuyez sur ENTRÉE pour revenir au menu précédent.

  5. À l'invite de commandes de stratégie LDAP, entrez Show Values, puis appuyez sur ENTRÉE.

    Les stratégies existantes s'affichent.

    Remarque :
    Cette procédure n'indique que les paramètres Stratégie de domaine par défaut. Si vous appliquez votre propre paramètre de stratégie, il ne s'affichera pas.

Pour modifier les paramètres de stratégie

  1. À l'invite de commandes de Ntdsutil.exe, entrez LDAP policies, puis appuyez sur ENTRÉE.

  2. À l'invite de commandes de stratégie LDAP, entrez Set MaxActiveQueries to 1000, puis appuyez sur ENTRÉE.

    Vous pouvez utiliser la commande Show Values pour vérifier vos modifications.

  3. Pour enregistrer les modifications, utilisez Commit Changes.

  4. Lorsque vous avez terminé, entrez q, puis appuyez sur ENTRÉE.

  5. Pour quitter Ntdsutil.exe, à l'invite de commandes, entrez q, puis appuyez sur ENTRÉE.

Pour plus d'informations sur la configuration des stratégies LDAP, voir l'article 315071 de la Base de connaissances Microsoft sur la procédure d'affichage et de définition des stratégies LDAP à l'aide de Ntdsutil.exe dans Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


MaxPageSize défini sur une valeur trop élevée
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur MaxPageSize de l'attribut LDAPAdminLimits de l'objet de stratégie de requête par défaut du conteneur de stratégies de requête. Si Exchange Server Analyzer détermine que la valeur de MaxPageSize est supérieure à 2500, une erreur s'affiche.

Les limites d'administration LDAP (Lightweight Directory Access Protocol) compensent les performances et les possibilités opérationnelles d'Active Directory. Ces limites empêchent les opérations spécifiques d'affecter défavorablement les performances du serveur. Elles permettent également au serveur de résister aux attaques par déni de service. L'augmentation de ce paramètre à une valeur supérieure à celle par défaut peut avoir un effet secondaire sur votre infrastructure Active Directory.

Les stratégies LDAP sont mises en œuvre à l'aide d'objets de la classe queryPolicy. Des objets de stratégie de requête peuvent être créés dans le conteneur de stratégies de requête, qui est un enfant du conteneur du service d'annuaire dans le contexte de nommage de configuration.

La valeur MaxPageSize de l'attribut LDAPAdminLimits contrôle le nombre d'enregistrements qui peuvent être renvoyés pour une requête LDAP. La valeur par défaut est de 1 000 enregistrements. Si plus de 1 000 éléments sont renvoyés, Active Directory voit cette valeur maximale et ne renvoie rien.

Cette limite contrôle les nombres supportables de plusieurs types d'objets Active Directory. Par exemple, chaque organisation peut disposer, au maximum, de 1 000 serveurs, de 1 000 groupes d'administration et de 1 000 listes d'adresses. Chaque groupe d'administration peut comporter, au maximum, 1 000 groupes de routage, et chaque groupe de routage, 1 000 connecteurs.

À moins d'avoir été invité par les services du Support Technique de Microsoft à utiliser une autre valeur, vous devez redéfinir cette valeur sur 1 000.

Pour démarrer Ntdsutil.exe

  1. Cliquez sur Démarrer, puis sur Exécuter.

  2. Dans la zone de texte Ouvrir, entrez ntdsutil, puis appuyez sur ENTRÉE. Pour afficher l'Aide à tout moment, entrez ? à l'invite de commandes.
Pour afficher les paramètres de stratégie

  1. À l'invite de commandes de Ntdsutil.exe, entrez LDAP policies, puis appuyez sur ENTRÉE.

  2. À l'invite de commandes de stratégie LDAP, entrez connections, puis appuyez sur ENTRÉE.

  3. À l'invite de commandes de connexion au serveur, entrez connect to server <nom de serveur DNS>, puis appuyez sur ENTRÉE. Connectez-vous au serveur avec lequel vous travaillez actuellement.

  4. À l'invite de commandes de connexion au serveur, entrez q, puis appuyez sur ENTRÉE pour revenir au menu précédent.

  5. À l'invite de commandes de stratégie LDAP, entrez Show Values, puis appuyez sur ENTRÉE.

    Les stratégies existantes s'affichent.

    Remarque :
    Cette procédure n'indique que les paramètres Stratégie de domaine par défaut. Si vous appliquez votre propre paramètre de stratégie, il ne s'affichera pas.
Pour modifier les paramètres de stratégie

  1. À l'invite de commandes de Ntdsutil.exe, entrez LDAP policies, puis appuyez sur ENTRÉE.

  2. À l'invite de commandes de stratégie LDAP, entrez Set MaxActiveQueries to 1000, puis appuyez sur ENTRÉE.

    Vous pouvez utiliser la commande Show Values pour vérifier vos modifications.

  3. Pour enregistrer les modifications, utilisez Commit Changes.

  4. Lorsque vous avez terminé, entrez q, puis appuyez sur ENTRÉE.

  5. Pour quitter Ntdsutil.exe, à l'invite de commandes, entrez q, puis appuyez sur ENTRÉE.

Pour plus d'informations sur la configuration des stratégies LDAP, voir l'article 315071 de la Base de connaissances Microsoft sur la procédure d'affichage et de définition des stratégies LDAP dans Active Directory à l'aide de Ntdsutil.exe (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071).


Plus de 800 listes d'adresses sont présentes
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le nombre de listes d'adresses du groupe Toutes les listes d'adresses d'Active Directory est supérieur à 800. Si Exchange Server Analyzer détecte que votre organisation Exchange Server contient plus de 800 listes d'adresses, il affiche un avertissement.

Il est recommandé de réduire le nombre de listes d'adresses du groupe Toutes les listes d'adresses sur une valeur inférieure à 800 pour éviter de graves latences lors d'opérations du service de mise à jour de destinataire. Si votre organisation Exchange Server contient plus de 800 listes d'adresses, le service de mise à jour de destinataire subit de graves latences lorsqu'il date des objets à extension messagerie.

Vous pouvez également désactiver le service de mise à jour de destinataire et utiliser des scripts pour traiter les tâches effectuées par le service de mise à jour de destinataire.

Pour plus d'informations sur la désactivation du service de mise à jour de destinataire, voir l'article de la Base de connaissances Microsoft sur les conditions requises pour la désactivation du service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479).

Pour plus d'informations sur les listes d'adresses et le service de mise à jour de destinataire, voir la rubrique sur la gestion des destinataires et des stratégies de destinataire dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Plus de 800 listes d'adresses globales sont présentes
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le nombre de listes d'adresses du groupe Toutes les listes d'adresses globales d'Active Directory est supérieur à 800. Si Exchange Server Analyzer détecte que votre organisation Exchange Server contient plus de 800 listes d'adresses globales, il affiche un avertissement.

Il est recommandé de réduire le nombre de listes d'adresses du groupe Toutes les listes d'adresses globales sur une valeur inférieure à 800 pour éviter de graves latences lors d'opérations du service de mise à jour de destinataire. Si votre organisation Exchange Server contient plus de 800 listes d'adresses globales, le service de mise à jour de destinataire subit de graves latences lorsqu'il date des objets à extension messagerie.

Vous pouvez également désactiver le service de mise à jour de destinataire et utiliser des scripts pour traiter les tâches effectuées par le service de mise à jour de destinataire.

Pour plus d'informations sur la désactivation du service de mise à jour de destinataire, voir l'article de la Base de connaissances Microsoft sur les conditions requises pour la désactivation du service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479).

Pour plus d'informations sur les listes d'adresses et le service de mise à jour de destinataire, voir la rubrique sur la gestion des destinataires et des stratégies de destinataire dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


L'attribut msExchHomeMDB est indexé
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut Routing Group Back-Link a été configuré pour une indexation dans Active Directory. Exchange Server Analyzer interroge spécifiquement Active Directory pour déterminer la valeur d'indexation actuelle de l'attribut msExchHomeMDB, un attribut d'objets à boîte aux lettres activée dans Active Directory. Cet attribut n'est pas indexé par défaut. Si Exchange Server Analyzer détecte que cet attribut est configuré pour une indexation, un message indiquant une configuration autre que celle par défaut s'affiche.

Les conséquences de l'indexation de l'attribut msExchHomeMDB sont minimes. La quantité de mémoire utilisée sur des serveurs de catalogue global augmente légèrement en raison de la présence de l'index dans la mémoire.

Si l'un de ces éléments s'applique à votre organisation, vous pouvez tirer profit de l'indexation de cet attribut :

  • Vous disposez d'un grand nombre d'objets à extension messagerie. Dans des environnements très grands, disposant de minimum 100 000 objets à extension messagerie, l'indexation de cet attribut peut également augmenter les performances du Gestionnaire système Exchange ainsi que les tâches spécifiques à Exchange qui peuvent être effectuées avec Utilisateurs et ordinateurs Active Directory.

  • Si vous utilisez fréquemment le programme de fusion de boîtes aux lettres d'Exchange (ExMerge), l'indexation de l'attribut msExchHomeMDB est parfois nécessaire dans des environnements moyens et grands qui utilisent ExMerge. Il a été prouvé que l'indexation de l'attribut msExchHomeMDB permet d'augmenter la vitesse et les performances d'ExMerge.

Si aucune des ces situations ne s'applique, il est recommandé de rétablir le paramètre sur sa valeur par défaut non indexée.

Pour corriger cette erreur

  • Aucune action n'est requise étant donné que le message généré par Exchange Server Analyzer n'est fourni qu'à titre indicatif.


L'attribut msExchRoutingGroupMembersBL est indexé
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut Routing Group Back-Link a été configuré pour une indexation dans Active Directory. Plus spécifiquement, Exchange Server Analyzer examine l'objet Active Directory suivant pour déterminer la valeur actuelle de l'attribut msExchRoutingGroupMembersBL :

CN=Configuration,DC=domaine,DC=com, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Groupes_administration, CN=Nom_groupe_administration, CN=Groupes_routage, CN=Nom_groupe_routage

Cet attribut n'est pas indexé par défaut. Si Exchange Server Analyzer détecte que cet attribut est configuré pour une indexation, un message indiquant une configuration autre que celle par défaut s'affiche.

Dans un déploiement Exchange distribué ou local comportant un grand nombre de groupe de routage, la non-indexation de cet attribut peut altérer les performances. Par exemple, si votre organisation Exchange comporte des centaines de groupes de routage, vous pouvez remarquer une activité accrue sur un ou plusieurs serveurs de catalogue global toutes les 15 minutes. Cette augmentation de l'activité se produit si le composant DSAccess d'Exchange relit la configuration du groupe de routage. Dans certains cas, le catalogue global risque d'être utilisé avec cette activité.

Pour réduire cette charge sur le catalogue global, l'attribut Routing Group Back-Link peut être indexé, réduisant, d'une part, le temps nécessaire au composant DSAccess pour lire les informations du groupe de routage et, d'autre part, la charge exercée par cette activité sur le catalogue global.

Pour corriger cette erreur

  • Aucune action n'est requise étant donné que le message généré par Exchange Server Analyzer n'est fourni qu'à titre indicatif.

Pour plus d'informations sur le réglage d'Exchange pour des performances optimales, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47576).


Plusieurs hiérarchies de dossiers publics trouvées
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de hiérarchies de dossiers publics présentant la valeur 1 pour l'attribut msExchPFTreeType. La valeur 1 de l'attribut msExchPFTreeType indique que la hiérarchie de dossiers publics est celle désignée pour les clients MAPI. Si Exchange Server Analyzer détermine que plusieurs hiérarchies de dossiers publics de l'organisation Exchange présentent la valeur 1 pour l'attribut msExchPFTreeType, il affiche une erreur.

Cette erreur indique que plusieurs hiérarchies de dossiers publics des clients MAPI ont été trouvées dans l'organisation Exchange. La présence de plusieurs hiérarchies de dossiers publics de clients MAPI peut créer des problèmes.

Pour résoudre ce problème, vous pouvez utiliser l'outil de modification Active Directory pour définir la valeur de l'attribut msExchPFTreeType sur 0 pour toutes les hiérarchies de dossiers publics, à l'exception de la hiérarchie MAPI. Reconfigurez au besoin les banques de boîtes aux lettres de vos serveurs Exchange de sorte à désigner la hiérarchie de dossiers publics MAPI comme banque de dossiers publics par défaut pour les clients MAPI.

Les outils de modification Active Directory sont les suivants :

  • Active Directory Service Interfaces (ADSI) Edit (AdsiEdit.msc) ;

  • l'outil LDP (ldp.exe).

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour corriger cette erreur

  1. Utilisez un outil de modification Active Directory pour localiser les objets de dossiers publics dans Active Directory. Les objets de dossiers publics peuvent se trouver dans : CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Modifiez l'attribut msExchPFTreeType pour tous les objets de hiérarchie de dossiers publics à l'exception de la hiérarchie MAPI, en entrant 0 comme nouvelle valeur.

  3. Fermez l'éditeur Active Directory.

  4. Ouvrez le Gestionnaire système Exchange.

  5. Pour accéder aux propriétés de chaque banque de boîtes aux lettres, cliquez sur Groupes d'administration, développez votre groupe d'administration, Serveurs, votre serveur et votre groupe de stockage. Ensuite, cliquez avec le bouton droit sur la banque de boîtes aux lettres dont vous souhaitez modifier les propriétés et sélectionnez Propriétés.

  6. Sous l'onglet Général, pour le champ Banque d'informations publique par défaut, cliquez sur Parcourir.

  7. Sélectionnez la hiérarchie de dossiers publics MAPI, puis cliquez deux fois sur OK pour enregistrer les modifications.

  8. Répétez les étapes 5 à 7 pour chaque banque de boîtes aux lettres.

Pour plus d'informations sur la modification d'Active Directory à l'aide de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur les hiérarchies de dossiers publics pour MAPI et pour les applications, voir les ressources suivantes :

  • Article 258509 de la Base de connaissances Microsoft sur la description des types d'arborescences de dossiers publics dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • le billet de l'équipe Exchange sur le fonctionnement des dossiers publics à extension messagerie (http://go.microsoft.com/fwlink/?LinkId=41913)


Paramètre « NeverPing » recommandé
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre d'approbations établies pour chaque domaine. Si au moins un contrôleur de domaine de chaque domaine présente une valeur NeverPing définie, l'outil affiche un message de recommandation.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies pour chaque domaine de l'environnement Exchange Server 2003 :

  • Le domaine dispose de plus de 50 approbations établies.

  • Les contrôleurs de domaine du domaine présentent une valeur de sous-clé de Registre NeverPing nulle (définie sur 0).

Cet avertissement indique que le processus LSASS.exe ou le processus d'authentification des utilisateurs dans le domaine peut être retardé. Dans les systèmes d'exploitation Microsoft Windows, le processus Service LSASS (Local Security Authority Subsystem Service) vérifie la connexion des utilisateurs à un serveur ou un ordinateur Windows.

Pour résoudre le problème, définissez la valeur de la sous-clé de Registre NeverPing pour les contrôleurs de domaine sur 1 comme suit.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour définir le paramètre NeverPing pour les contrôleurs de domaine dans votre environnement Exchange 2003

  1. Cliquez sur Démarrer et Exécuter, entrez regedit, puis cliquez sur OK.

  2. Recherchez la sous-clé de Registre suivante : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters.

  3. Cliquez avec le bouton droit sur cette sous-clé, pointez sur Nouveau, cliquez sur Valeur DWORD, entrez NeverPing, puis appuyez sur ENTRÉE.

  4. Cliquez avec le bouton droit sur NeverPing, cliquez sur Modifier, entrez 1 dans la zone Données de la valeur, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur ce problème et sur la définition de la valeur du paramètre NeverPing pour votre contrôleur de domaine, voir l'article 825107 de la Base de connaissances Microsoft sur le processus Lsass.exe qui peut cesser de répondre si vous disposez de nombreuses approbations externes sur un contrôleur de domaine Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107).

Remarque :
Bien que cet article décrive Microsoft Windows 2000 Server, les informations s'appliquent également à Windows Server™ 2003. La mise à jour mentionnée dans l'article n'est pas nécessaire pour Windows Server 2003.


Une version plus récente de Active Directory Connector est disponible
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber sur chaque objet d'accord de connexion. L'attribut versionNumber représente la version d'Active Directory Connector (ADC) exécutée sur l'ordinateur.

L'outil Exchange Server Analyzer Tool interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version d'Adc.exe, le fichier ADC (Active Directory Connector). La clé WMI Version indique le numéro de version de ce fichier.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • L'attribut versionNumber sur l'objet d'accord de connexion est défini sur 16973842.

  • L'attribut versionNumber sur l'objet d'accord de connexion est défini sur 16973843 et la valeur de la clé Version d'Adc.exe est inférieure à 7250,0.

La valeur 16973842 indique que l'ordinateur exécute la version commerciale originale d'ADC à partir du CD-ROM d'Exchange Server 2003 et la valeur 16973843 avec une clé Version d'Adc.exe inférieure à 7250,0 indique que l'ordinateur exécute la version Exchange Server 2003 Service Pack 1 (SP1) d'ADC.

Une version plus récente d'ADC est disponible avec le Service Pack 2 pour Exchange Server 2003. Il est recommandé d'utiliser la dernière version d'ADC.

Pour supprimer cet avertissement

  1. Accédez au Service Pack 2 pour Exchange Server 2003 http://go.microsoft.com/fwlink/?LinkId=54751 pour télécharger la dernière version d'ADC.

  2. Désinstallez la version existante d'ADC et installez la version mise à jour d'ADC.

Pour plus d'informations sur les accords de connexion d'ADC, voir les articles suivants de la Base de connaissances Microsoft :

  • 823601 sur la configuration requise et les implications d'Active Directory Connector dans une organisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180 sur l'accord de connexion d'Active Directory Connector requis pour les groupes d'administration mixtes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721 sur les droits de propriétaire de boîte aux lettres Exchange Server 5.5, qui sont supprimés lorsque vous modifiez l'accord de connexion ADC monodirectionnel en accord bidirectionnel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Le serveur Exchange désigné pour cet accord de connexion n'existe pas dans l'organisation
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchServer2NetworkAddress sur chaque objet d'accord de connexion. L'attribut msExchServer2NetworkAddress représente l'adresse réseau du serveur participant à cet accord de connexion. Exchange Server Analyzer énumère les groupes d'administration dans Active Directory pour déterminer si ce nom de serveur est répertorié pour l'accord de connexion d'un groupe d'administration. Si ce nom de serveur n'est pas répertorié dans un groupe d'administration, une erreur s'affiche.

Cette erreur indique un accord de connexion orphelin. Cela peut se produire si un ordinateur Exchange Server a été désactivé. Si l'ordinateur Exchange Server a été supprimé de l'organisation, vous devez modifier le nom du serveur Exchange sous l'onglet Connexions des propriétés de l'accord de connexion dans les outils d'administration ADC (Active Directory Connector). Si le serveur Exchange en question est déconnecté pour la maintenance ou toute autre raison connue, vous pouvez ignorer cette erreur.

Pour corriger cette erreur

  1. Cliquez sur Démarrer, Programmes, Outils d'administration, puis Connecteur Active Directory.

  2. Dans le volet gauche, cliquez sur le serveur ADC qui héberge l'accord de connexion à modifier.

  3. Dans le volet droit, cliquez avec le bouton droit sur l'accord de connexion à modifier, puis cliquez sur Propriétés.

  4. Cliquez sur l'onglet Connexions.

  5. Modifiez le nom du serveur utilisé pour les connexions et choisissez un nom existant.

Pour plus d'informations sur les accords de connexion d'ADC, voir les articles suivants de la Base de connaissances Microsoft :

  • 823601 sur la configuration requise et les implications d'Active Directory Connector dans une organisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180 sur l'accord de connexion d'Active Directory Connector requis pour les groupes d'administration mixtes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)


Le serveur de Carnet d'adresses en mode hors connexion désigné n'existe pas dans l'organisation
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut offLineABServer de l'objet de configuration du Carnet d'adresses en mode hors connexion. L'attribut offLineABServer est un attribut de nom unique qui stocke le nom unique de l'ordinateur Exchange Server responsable de la génération d'un Carnet d'adresses hors connexion.

Exchange Server Analyzer examine également la valeur de l'attribut distinguishedName des objets Exchange Server dans Active Directory.

Si Exchange Server Analyzer détecte que le serveur répertorié dans l'attribut offLineABServer ne correspond pas aux attributs distinguishedName détectés pour les objets Exchange Server et que l'attribut offLineABServer ne contient pas la chaîne DEL:, une erreur s'affiche.

Pour chaque Carnet d'adresses en mode hors connexion, Exchange génère et stocke les fichiers correspondants dans un ensemble de dossiers publics sur un serveur spécifié. Si ce message s'affiche, cela signifie que le serveur spécifié dans l'objet de liste d'adresses en mode hors connexion n'existe pas. Cette situation peut survenir lorsque l'ancien serveur de Carnet d'adresses en mode hors connexion a été désactivé ou supprimé de manière incorrecte de la topologie. Exchange ne génère pas de Carnet d'adresses en mode hors connexion tant qu'aucun nouveau serveur n'a été spécifié.

Correction de cette erreur dans Exchange 2000 Server et Exchange Server 2003

  1. Dans le Gestionnaire système Exchange, sous Destinataires, cliquez sur Listes d'adresses en mode hors connexion. Dans le volet droit, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut (ou toute autre liste d'adresses en mode hors connexion générant ce message), puis cliquez sur Propriétés.

  2. Sous l'onglet Général, sous Serveur de liste d'adresses en mode hors connexion, cliquez sur Parcourir, puis cliquez sur le serveur que vous souhaitez utiliser.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez Exchange Management Console.

  2. Développez Microsoft Exchange et Configuration de l'organisation, puis sélectionnez Boîte aux lettres.

  3. Dans le volet des résultats, cliquez sur l'onglet Carnet d'adresses en mode hors connexion.

  4. Sous l'onglet Carnet d'adresses en mode hors connexion, sélectionnez « Carnet d'adresses en mode hors connexion par défaut ». Dans le volet Actions, cliquez sur Déplacer pour démarrer l'Assistant Déplacement du carnet d'adresses en mode hors connexion. Cet Assistant permet de déplacer la génération de l'OAB vers un autre serveur. Elle copie également les fichiers de l'OAB sur le serveur spécifié.

Utilisation d'Exchange Management Shell pour définir le serveur qui hébergera la génération du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB et <Server> spécifie le serveur Exchange sur lequel exécuter l'opération sélectionnée.

    Par exemple, pour déplacer la génération de l'OAB vers le serveur SERVER01, vous devez entrer :
Copier le code
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2003, consultez la section sur la configuration de carnets d'adresses en mode hors connexion dans Exchange Server 2003 dans le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation des carnets d'adresses en mode hors connexion dans Exchange Server 2007, consultez la page « Configuration de l'organisation > Boîte aux lettres > Carnets d'adresses en mode hors connexion » (http://go.microsoft.com/fwlink/?LinkId=79247).


Le serveur Exchange désigné pour le service de mise à jour de destinataire n'existe pas dans l'organisation
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-03-29

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut distinguishedName pour chaque objet Exchange Server de l'annuaire. Exchange Server Analyzer Tool interroge également Active Directory pour déterminer la valeur de l'attribut msExchAddressListServiceLink pour chaque objet Service de mise à jour de destinataire de l'annuaire. L'attribut msExchAddressListServiceLink est un lien du service de liste d'adresses vers l'ordinateur Exchange Server sur lequel il est utilisé. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchAddressListServiceLink ne contient pas la chaîne DEL: et que l'attribut ne correspond à aucun attribut distinguishedName d'un objet Exchange Server de l'annuaire, une erreur s'affiche.

Chaque instance du service de mise à jour de destinataire est associée à un ordinateur Exchange Server qui utilise le service de mise à jour de destinataire. Si vous recevez ce message, l'instance du service de mise à jour de destinataire est associée à un ordinateur Exchange Server qui n'existe pas dans l'organisation Exchange. Le serveur a pu être désactivé ou supprimé de la topologie.

Pour exécuter cette instance du service de mise à jour de destinataire, vous devez l'associer à un serveur Exchange existant.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Services de mise à jour de destinataire. Dans le volet droit, cliquez avec le bouton droit sur l'instance appropriée du service de mise à jour de destinataire, puis cliquez sur Propriétés.

  3. Sous Exchange Server, sous l'onglet Général, cliquez sur Parcourir et spécifiez un nouveau serveur exécutant cette instance.

  4. Cliquez sur OK, puis cliquez de nouveau sur OK pour que la modification soit prise en compte.

  5. Fermez le Gestionnaire système Exchange.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les rubriques et les articles suivants de la Base de connaissances Microsoft :

  • sur la gestion des destinataires et des stratégies de destinataire dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617).

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127 sur la procédure de vérification des progrès du service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Le serveur maître du groupe de routage désigné n'a pas été détecté dans ce groupe d'administration
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchRoutingMasterDN pour chaque conteneur de groupe de routage. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchRoutingMasterDN ne contient pas de nom de serveur valide et que l'attribut ne comporte pas la chaîne « DEL: », un avertissement s'affiche.

Ce problème peut se produire si le maître de groupe de routage précédent a été désactivé ou mal supprimé de la topologie. Sans le maître de groupe de routage, Exchange ne parviendra pas à gérer ou mettre à jour correctement la topologie de routage.

Lorsque vous créez un groupe de routage, le premier serveur du groupe se voit attribuer le rôle de maître de groupe de routage. Le maître de groupe de routage conserve les informations d'état des liens actuels pour son groupe de routage et les diffuse aux autres serveurs au sein du groupe. Le maître de groupe de routage contrôle la configuration de routage écrite pour son groupe de routage dans Active Directory. Les serveurs membres peuvent communiquer toute information de disponibilité du serveur ou d'état du connecteur au maître de groupe de routage. Par exemple, si un serveur membre tente de contacter un autre serveur d'un groupe de routage différent via un connecteur et si ce lien n'est pas disponible, le serveur membre avertit immédiatement le maître de groupe de routage. De même, lorsqu'un serveur non-maître reçoit de nouvelles informations d'état des liens, il transfère immédiatement les informations d'état du connecteur au maître de groupe de routage pour que d'autres serveurs puissent recevoir les informations sur la modification de routage.

Pour supprimer cet avertissement

  1. Dans le Gestionnaire système Exchange, sous Groupes d'administration, développez Groupes_administration, puis Groupes de routage.

  2. Développez le groupe de routage, puis cliquez sur Membres.

  3. Dans le volet droit, cliquez avec le bouton droit sur l'ordinateur Exchange que vous souhaitez configurer comme maître de groupe de routage et cliquez sur Définir un maître.

Pour plus d'informations sur les maîtres de groupe de routage, voir le chapitre sur la configuration d'une topologie de routage dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579).


Le nombre d'accords de connexion de dossier public est inférieur au nombre d'accords de connexion de configuration
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si vous avez un accord de connexion de dossier public entre Active Directory et chaque site Exchange Server 5.5. Pour ce faire, il demande le nombre d'accords de connexion de dossier public et le nombre d'accords de connexion de configuration. Si Exchange Server Analyzer détermine que le nombre d'accords de connexion de dossier public est inférieur au nombre d'accords de connexion de configuration, un avertissement s'affiche.

Cet avertissement indique qu'au moins un site Exchange Server 5.5 ne possède pas d'accord de connexion de dossier public avec Active Directory et ne peut pas répliquer d'objets Annuaire pour les dossiers publics sur Active Directory. Le courrier ne peut donc pas circuler des boîtes aux lettres Exchange 2000 Server ou Exchange Server 2003 vers les dossiers publics Exchange Server 5.5 ni circuler des boîtes aux lettres Exchange Server 5.5 vers les dossiers publics à extension messagerie Exchange 2000 Server ou Exchange Server 2003.

Des accords de connexion de configuration sont automatiquement générés lors de l'installation d'un ordinateur Exchange 2000 Server ou Exchange Server 2003 dans un site Exchange Server 5.5 pur. Les accords de connexion de dossier public sont définis par l'utilisateur. En présence d'un accord de connexion de dossier public entre chaque site Exchange Server 5.5 et Active Directory, le nombre d'accords de connexion de dossier public sera au moins égal à celui d'accords de connexion de configuration.

Pour créer un accord de connexion de dossier public

  1. Sur un serveur Active Directory Connector (ADC), démarrez le Gestionnaire du Connecteur Active Directory. (Dans le menu Démarrer, pointez sur Programmes ou Tous les programmes, pointez sur Microsoft Exchange, puis cliquez sur Connecteur Active Directory).

  2. Dans l'arborescence de la console, cliquez sur Connecteur Active Directory. La fenêtre de droite affiche les accords de connexion. Utilisez cette liste pour déterminer le ou les sites qui ne possèdent pas d'accords de connexion de dossier public.

  3. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Accord de connexion de dossier public pour afficher la boîte de dialogue Propriétés.

  4. Sous l'onglet Général, dans Nom, entrez un nom pour l'accord de connexion.

  5. Dans la zone Service Connecteur Active Directory, sélectionnez un serveur pour exécuter l'accord de connexion.

  6. Sous l'onglet Connexions, sélectionnez le serveur Active Directory et le serveur Exchange Server 5.5 dont vous souhaitez répliquer les objets Dossier public, en spécifiant les comptes et informations d'identification correspondants.

  7. Sous l'onglet Planification, sélectionnez la planification de réplication.

  8. Cliquez sur OK.

Pour plus d'informations sur les accords de connexion de dossier public et de configuration, voir les articles suivants de la Base de connaissances Microsoft :

  • 264889 sur les accords de connexion de dossier public (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889)

  • 281223 sur la compréhension des accords de connexion dans Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223).


Génération du Carnet d'adresses en mode hors connexion configurée pour une mise à jour continue
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut offLineABSchedule de la classe msExchOAB a été configurée pour une génération du Carnet d'adresses en mode hors connexion. L'attribut offLineABSchedule détermine la planification de la liste d'adresses en mode hors connexion. Si Exchange Server Analyzer détecte que la planification de la génération du Carnet d'adresses en mode hors connexion de la liste d'adresses en mode hors connexion est configurée pour une mise à jour continue, il affiche un message d'erreur.

Un Carnet d'adresses en mode hors connexion est un conteneur qui renferme une série de listes d'adresses hors connexion. Les administrateurs configurent les Carnets d'adresses en mode hors connexion disponibles. Les utilisateurs de Microsoft Office Outlook® 2003 et d'Outlook 2007 peuvent choisir les listes d'adresses en mode hors connexion qu'ils veulent télécharger. Les clients MAPI, tels qu'Outlook 2003 et Outlook 2007, peuvent télécharger des listes d'adresses en mode hors connexion. Par conséquent, les utilisateurs peuvent composer des messages électroniques même s'ils sont déconnectés du serveur Exchange.

Vous pouvez planifier la mise à jour des listes d'adresses en mode hors connexion. Veillez toutefois à configurer une mise à jour qui vous laisse assez de temps pour générer la liste d'adresses en mode hors connexion avant le début de la mise à jour suivante. Par exemple, chaque mise à jour doit être espacée de quatre heures au minimum si les conditions suivantes existent :

  • Vous spécifiez trois mises à jour en 24 heures.

  • La mise à jour des listes d'adresses en mode hors connexion dure quatre heures.

Il est conseillé de ne pas effectuer de mises à jour trop rapprochées car cela peut entraîner des problèmes au niveau des performances client et serveur comme suit :

  • Le serveur doit générer le Carnet d'adresses en mode hors connexion plus souvent. Cette génération peut durer plusieurs heures, selon la taille d'Active Directory.

  • Pour chaque mise à jour, Outlook crée une copie du Carnet d'adresses en mode hors connexion sur l'ordinateur local et applique les modifications incrémentielles récupérées sur le serveur. Si le Carnet d'adresses en mode hors connexion sur l'ordinateur local est de 150 Mo, Outlook doit créer une copie de ces données lors de chaque mise à jour.

  • Outlook possède un mécanisme de « limitation » qui ralentit la mise à jour du Carnet d'adresses hors connexion lorsqu'il détecte une activité utilisateur. Si celle-ci est continue, la taille du Carnet d'adresses hors connexion affecte la durée de la mise à jour, qui peut varier entre une et huit heures.

Si vous souhaitez augmenter la fréquence de vos mises à jour, assurez-vous que votre Carnet d'adresses en mode hors connexion est suffisamment petit. Une taille raisonnable non compressée est comprise entre 1 et 25 Mo.

Planification d'une heure de mise à jour des listes d'adresses en mode hors connexion dans Exchange 2000 Server et Exchange Server 2003

  1. Dans Gestionnaire système, double-cliquez sur Destinataires et cliquez sur Listes d'adresses en mode hors connexion.

  2. Dans le volet Détails, double-cliquez sur la liste d'adresses en mode hors connexion pour laquelle vous souhaitez planifier une mise à jour.

    1. Pour choisir un intervalle de mise à jour préconfiguré, sous l'onglet Général, sélectionnez l'un des intervalles dans la liste déroulante Intervalle de mise à jour.

      Important :
      Si vous sélectionnez Ne jamais exécuter dans la liste déroulante, la liste d'adresses en mode hors connexion ne sera pas mise à jour.
    2. Pour définir une planification de mise à jour spécifique, cliquez sur Personnaliser. Dans la boîte de dialogue Planification, réglez la planification de mise à jour à l'aide de la grille de jours et d'heures affichée, puis cliquez sur OK.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez Exchange Management Console.

  2. Développez Microsoft Exchange et Configuration de l'organisation, puis sélectionnez Boîte aux lettres.

  3. Dans le volet des résultats, cliquez sur l'onglet Carnet d'adresses en mode hors connexion.

  4. Sous l'onglet Carnet d'adresses en mode hors connexion, sélectionnez « Carnet d'adresses en mode hors connexion par défaut ». Dans le volet Actions, cliquez sur Propriétés.

  5. Sous l'onglet Général, sélectionnez le délai d'exécution dans la liste déroulante Planning de mise à jour ou cliquez sur Personnaliser pour définir une planification personnalisée.

  6. Cliquez sur OK pour enregistrer les modifications.
Utilisation d'Exchange Management Shell pour définir un planning de génération du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB et <Schedule> spécifie le heures planifiées pour le démarrage de la génération de l'OAB, le format étant JourDeDebut.Heure:Minute [AM/PM]. Vous pouvez utiliser les valeurs suivantes pour les jours :

    • Nom complet du jour

    • Nom abrégé du jour

    • Nombre entier compris entre 0 et 6, où 0 = Dimanche

    Si vous préférez utiliser une horloge basée sur 24 heures, omettez les indications AM/PM.

    Par exemple, pour définir le planning de génération du carnet d'adresses en mode hors connexion par défaut comme quotidien entre 1h00 et 3h00, vous devez entrer :
Copier le code
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Pour plus d'informations, voir le guide des recommandations du carnet d'adresses en mode hors connexion (http://go.microsoft.com/fwlink/?LinkId=47583).

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2003, consultez la section sur la configuration de carnets d'adresses en mode hors connexion dans Exchange Server 2003 dans le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation des carnets d'adresses en mode hors connexion dans Exchange Server 2007, consultez la page « Configuration de l'organisation > Boîte aux lettres > Carnets d'adresses en mode hors connexion » (http://go.microsoft.com/fwlink/?LinkId=79247).


La planification de génération du Carnet d'adresses en mode hors connexion a été définie sur Jamais
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut offLineABSchedule de l'objet de configuration du Carnet d'adresses en mode hors connexion. L'attribut offLineABSchedule représente la planification de génération du Carnet d'adresses en mode hors connexion pour l'objet Default Offline Address List du conteneur Listes d'adresses dans Active Directory. Si Exchange Server Analyzer détecte que l'attribut offLineABSchedule est défini sur Jamais, un avertissement s'affiche.

Par défaut, Exchange gère un seul Carnet d'adresses en mode hors connexion. Exchange met à jour ce Carnet d'adresses en mode hors connexion (ou en génère une nouvelle version) chaque nuit pendant son cycle de maintenance. Vous pouvez créer des Carnets d'adresses en mode hors connexion supplémentaires et utiliser la procédure suivante pour vérifier la planification de leur génération.

Cet avertissement indique que la planification a été modifiée en Jamais. Exchange ne mettra pas à jour le Carnet d'adresses en mode hors connexion existant jusqu'à ce que vous définissiez une nouvelle planification. Cela signifie que les utilisateurs pourront télécharger le Carnet d'adresses en mode hors connexion existant ,mais qu'ils ne recevront pas de mises à jour.

Correction de cet avertissement dans Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Listes d'adresses en mode hors connexion.

  3. Dans le volet droit, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis cliquez sur Propriétés. Si vous ne souhaitez pas utiliser un Carnet d'adresses en mode hors connexion, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis sur Supprimer. Sinon, utilisez le reste de cette procédure pour définir une planification.

  4. Sous l'onglet Général, sélectionnez le délai d'exécution dans la liste déroulante Intervalle de mise à jour ou cliquez sur Personnaliser pour définir une planification personnalisée.

  5. Cliquez sur OK pour enregistrer les modifications.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez Exchange Management Console.

  2. Développez Microsoft Exchange et Configuration de l'organisation, puis sélectionnez Boîte aux lettres.

  3. Dans le volet des résultats, cliquez sur l'onglet Carnet d'adresses en mode hors connexion.

  4. Sous l'onglet Carnet d'adresses en mode hors connexion, sélectionnez « Carnet d'adresses en mode hors connexion par défaut ». Dans le volet Actions, cliquez sur Propriétés.

  5. Sous l'onglet Général, sélectionnez le délai d'exécution dans la liste déroulante Planning de mise à jour ou cliquez sur Personnaliser pour définir une planification personnalisée.

  6. Cliquez sur OK pour enregistrer les modifications.

Utilisation d'Exchange Management Shell pour définir un planning de génération du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB et <Schedule> spécifie le heures planifiées pour le démarrage de la génération de l'OAB, le format étant JourDeDebut.Heure:Minute [AM/PM]. Vous pouvez utiliser les valeurs suivantes pour les jours :

    • Nom complet du jour

    • Nom abrégé du jour

    • Nombre entier compris entre 0 et 6, où 0 = Dimanche

    Si vous préférez utiliser une horloge basée sur 24 heures, omettez les indications AM/PM.

    Par exemple, pour définir le planning de génération du carnet d'adresses en mode hors connexion par défaut comme quotidien entre 1h00 et 3h00, vous devez entrer :
Copier le code
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2003, consultez la section sur la configuration de carnets d'adresses en mode hors connexion dans Exchange Server 2003 dans le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2007, consultez la page « Configuration de l'organisation > Boîte aux lettres > Carnets d'adresses en mode hors connexion » (http://go.microsoft.com/fwlink?LinkId=79247).


Ancienne version de l'accord de connexion détectée
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber de chaque accord de connexion ADC (Active Directory Connector).

Si Exchange Server Analyzer détecte que la valeur de l'attribut versionNumber de tout accord de connexion est inférieure à 16973842 dans une organisation Exchange contenant un ou plusieurs ordinateurs Exchange Server 2003, un avertissement s'affiche.

Une valeur inférieure à 16973842 indique que l'accord de connexion a été créé et qu'il est géré par un ADC d'Exchange 2000 Server. Si vous exécutez toutes les instances d'Exchange Server 2003 dans votre organisation où s'exécute Exchange 2000 Server ou Exchange Server 5.5, vous devez mettre à niveau toutes les instances d'ADC vers la version fournie avec Exchange Server 2003. Après avoir procédé à la mise à niveau vers Exchange Server 2003 ou vers la version Exchange Server 2003 Service Pack 1 (SP1) d'ADC, les accords de connexion détenus par cette version d'ADC seront également mis à jour. L'attribut versionNumber de chaque accord de connexion sera mis à jour avec la valeur la plus récente.

Pour supprimer cet avertissement

  1. Téléchargez Exchange Server 2003 SP1 à l'adresse http://go.microsoft.com/fwlink/?LinkId=29090.

  2. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  3. Sur votre serveur qui exécute le connecteur ADC Exchange 2000 Server, cliquez sur Démarrer, Exécuter, puis entrez <path>\\adc\\i386\\setup.exe, où <path> correspond à l'emplacement de téléchargement d'Exchange Server 2003 SP1.

  4. Sur la page Assistant d'Installation du Connecteur Microsoft Active Directory, cliquez sur Suivant.

  5. Sur la page Une installation précédente a été détectée, cliquez sur Réinstaller pour mettre à niveau le connecteur ADC Exchange 2000 Server vers celui d'Exchange Server 2003.

  6. Sur la page Fin de l'Assistant Installation du Connecteur Microsoft Active Directory, cliquez sur Terminer.

Pour plus d'informations sur l'installation et la mise à niveau d'ADC, voir les articles suivants de la Base de connaissances Microsoft :

  • 823601 sur la configuration requise et les implications d'Active Directory Connector dans une organisation (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823601)

  • 822942 sur les considérations relatives à la mise à niveau vers Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822942)


Le rôle FSMO d'émulateur de contrôleur de domaine principal n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut fSMORoleOwner de la racine de la partition d'annuaire du domaine dans le contexte de nommage de domaine. Par exemple, dans un domaine nommé contoso.com, fSMORoleOwner pour l'émulateur de contrôleur de domaine principal est un attribut de DC=contoso, DC=com. Exchange Server Analyzer tente ensuite d'ouvrir une connexion LDAP sur le port TCP 389 du contrôleur de domaine qui tient actuellement ce rôle. Si Exchange Server Analyzer ne peut pas se connecter à ce contrôleur de domaine, une erreur s'affiche.

Cet émulateur sert de contrôleur de domaine principal pour la compatibilité avec des systèmes d'exploitation Microsoft Windows® antérieurs. Microsoft Windows 2000 Server et Microsoft Windows Server™ 2003 interagissent avec les stations de travail, les serveurs membres et les contrôleurs secondaires de domaine Microsoft Windows NT®. Le contrôleur de domaine principal (PDC) d'un domaine Microsoft Windows NT 3.51 ou Microsoft Windows NT 4.0 est responsable des tâches suivantes :

  • le traitement des modifications de mot de passe des utilisateurs et des ordinateurs ;

  • la réplication des mises à jour vers les contrôleurs secondaires de domaine ;

  • l'exécution de l'Explorateur principal de domaine.

Le rôle de maître de l'émulateur de contrôleur de domaine principal ne peut être attribué qu'à un seul contrôleur de domaine par domaine.

Pour corriger cette erreur

  1. Vérifiez que le serveur d'annuaire spécifié dans l'erreur est actif et accessible par les serveurs Exchange de votre organisation.

  2. Si ce serveur d'annuaire a été désactivé, vous devez attribuer le rôle d'émulateur de contrôleur de domaine principal à un autre contrôleur de domaine.

Pour plus d'informations sur le transfert du rôle d'émulateur de contrôleur de domaine principal d'un contrôleur de domaine à un autre, voir les articles suivants de la Base de connaissances Microsoft :

  • Pour Windows Server 2003, voir l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Windows 2000 Server, voir l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Blocage de l'héritage des autorisations dans l'objet de configuration
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-04-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge chaque objet de configuration Exchange dans la base de données Active Directory® pour déterminer si les autorisations d'héritage d'un objet sont bloquées. Si l'héritage des autorisations est bloqué pour un objet de configuration d'Exchange, Exchange Server Analyzer affiche une erreur.

Exchange Server Analyzer identifie l'objet de configuration pour lequel l'héritage des autorisations est bloqué.

Exchange Server Analyzer récupère les listes de contrôle d'accès discrétionnaires dans Active Directory pour les objets de configuration d'Exchange. Par défaut, les objets de configuration comme les serveurs Exchange et les protocoles d'Exchange Server sont définis pour l'héritage des autorisations lorsqu'Exchange est installé. Si des autorisations sont accidentellement désactivées ou modifiées, l'héritage des autorisations d'un objet de configuration peut être bloqué. Dans ces conditions, des problèmes de flux de messages, tels que la formation de files d'attente, et de montage de banque d'informations peuvent ralentir le temps de réponse d'Exchange Server.

Remarque :
La liste de contrôle d'accès est une liste des protections de sécurité qui s'appliquent à l'ensemble d'un objet, à un ensemble des propriétés de l'objet ou à une propriété d'un objet. Il existe deux types de listes de contrôle d'accès : discrétionnaire et système.

Vous pouvez résoudre ce problème en réactivant l'héritage des autorisations pour l'objet.

Pour réactiver l'héritage des autorisations pour un objet de configuration Exchange

  1. Activez l'onglet Sécurité pour la zone des propriétés de l'objet du Gestionnaire système Exchange en définissant un paramètre de Registre Pour obtenir la procédure détaillée, voir l'article 264733 de la Base de connaissances Microsoft sur la procédure d'activation de l'onglet Sécurité pour l'objet d'organisation dans Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733).

    Remarque :
    Par défaut, l'onglet Sécurité n'est pas activé dans la zone des propriétés de l'objet de configuration.

  2. Ouvrez le Gestionnaire système Exchange, recherchez l'objet concerné et réactivez l'héritage des autorisations.

  3. Redémarrez Exchange Server.

Pour plus d'informations sur les listes de contrôle d'accès discrétionnaires dans Windows Server 2003 Active Directory, voir la rubrique sur le fonctionnement des descripteurs de sécurité et des listes de contrôle d'accès

(http://go.microsoft.com/fwlink/?LinkId=64193).

Pour plus d'informations sur l'héritage des autorisations, voir la rubrique sur le fonctionnement des autorisations (http://go.microsoft.com/fwlink/?LinkId=64195).


Blocage de l'héritage des autorisations dans l'objet de domaine
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-04-13

L'outil Microsoft® Exchange Server Analyzer Tool contrôle les objets de domaine Active Directory® tels que les conteneurs et les unités d'organisation. Si l'héritage des autorisations est bloqué dans les conteneurs ou les unités d'organisation, Exchange Server Analyzer affiche une erreur.

Exchange Server Analyzer identifie l'objet spécifique.

Si des modifications sont apportées à un objet de domaine Active Directory, celles apportées à la liste de contrôle d'accès sont remplacées. Même si l'option « Hériter du parent » est activée manuellement, l'héritage appliqué est désactivé lorsque des modifications sont apportées à la liste de contrôle d'accès. Ceci entraîne des problèmes du service de mise à jour de destinataire car ce service ne dispose pas des autorisations nécessaires pour une unité d'organisation Active Directory dans laquelle les comptes résident.

Ce comportement peut survenir si vous avez désactivé la case à cocher Permettre aux autorisations pouvant être héritées du parent d'être propagées à cet objet dans l'unité d'organisation Active Directory dans laquelle les comptes résident.

Pour résoudre le problème, le composant logiciel enfichable Utilisateurs et ordinateurs Active Directory ou l'outil ADSI (Active Directory Service Interfaces) Edit permettent de rétablir les autorisations d'héritage pour l'unité d'organisation. Suivez les étapes détaillées au scénario 2 de l'article 254030 de la Base de connaissances Microsoft sur les autorisations manquantes qui entraînent le non-traitement des comptes dans Exchange 2000 Server et Exchange Server 2003 par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030).

Pour plus d'informations sur les listes de contrôle d'accès dans Microsoft Windows Server 2003™ Active Directory, voir la rubrique sur le fonctionnement des descripteurs de sécurité et des listes de contrôle d'accès (http://go.microsoft.com/fwlink/?LinkId=64193).

Pour plus d'informations sur l'héritage des autorisations, voir la rubrique sur le fonctionnement des autorisations (http://go.microsoft.com/fwlink/?LinkId=64195).


Hiérarchie de dossiers publics introuvable
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de hiérarchies de dossiers publics présentant la valeur 1 pour l'attribut msExchPFTreeType. La valeur 1 de l'attribut msExchPFTreeType indique qu'une hiérarchie de dossiers publics spécifique est la hiérarchie de dossiers publics désignée des clients MAPI. Si Exchange Server Analyzer détermine qu'aucune hiérarchie de dossiers publics de l'organisation Exchange ne présente la valeur 1 pour l'attribut msExchPFTreeType, il affiche une erreur.

Celle-ci indique qu'il n'existe dans l'organisation aucune hiérarchie de dossiers publics pour les clients MAPI. L'absence de hiérarchie de dossiers publics pour les clients MAPI peut engendrer des problèmes. Par exemple, l'absence d'une hiérarchie de dossiers publics pour les clients MAPI peut entraîner l'échec de la mise à niveau d'un serveur virtuel Exchange dans un cluster de serveurs Microsoft Windows®.

Pour résoudre ce problème, vous pouvez utiliser l'outil de modification Active Directory pour définir la valeur de l'attribut msExchPFTreeType de la hiérarchie de dossiers publics pour les clients MAPI sur 1. Les outils de modification Active Directory sont les suivants :

  • Active Directory Service Interfaces (ADSI) Edit (AdsiEdit.msc) ;

  • l'outil LDP (ldp.exe).

Vous ne devez modifier que la hiérarchie de dossiers publics MAPI. Si votre organisation Exchange comprend des hiérarchies de dossiers publics pour les applications, veillez à ne modifier que l'attribut pour la hiérarchie de dossiers publics MAPI.

Après avoir défini la valeur de l'attribut msExchPFTreeType de la hiérarchie de dossiers publics MAPI sur 1, vous pouvez configurer les banques de boîtes aux lettres sur vos serveurs Exchange pour désigner la hiérarchie de dossiers publics MAPI comme banque de dossiers publics par défaut.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour corriger cette erreur

  1. Utilisez un outil de modification Active Directory pour rechercher les objets de la hiérarchie de dossiers publics dans Active Directory. Les objets de dossiers publics peuvent se trouver dans CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Modifiez l'attribut msExchPFTreeType en entrant la nouvelle valeur 1.

  3. Fermez l'éditeur Active Directory.

  4. Ouvrez le Gestionnaire système Exchange.

  5. Pour accéder aux propriétés de chaque banque de boîtes aux lettres, cliquez sur Groupes d'administration, développez votre groupe d'administration, Serveurs, votre serveur, puis votre groupe de stockage. Ensuite, cliquez avec le bouton droit sur la banque de boîtes aux lettres dont vous souhaitez modifier les propriétés et sélectionnez Propriétés.

  6. Sous l'onglet Général, pour le champ Banque d'informations publique par défaut, cliquez sur Parcourir.

  7. Sélectionnez la hiérarchie de dossiers publics MAPI, puis cliquez deux fois sur OK pour enregistrer les modifications.

  8. Répétez les étapes 5 à 7 pour chaque banque de boîtes aux lettres.

Pour plus d'informations sur la modification d'Active Directory à l'aide de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur les hiérarchies de dossiers publics pour MAPI et pour les applications, voir les ressources suivantes :

  • Article 258509 de la Base de connaissances Microsoft sur la description des types d'arborescences de dossiers publics dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509)

  • le billet de l'équipe Exchange sur le fonctionnement des dossiers publics à extension messagerie (http://go.microsoft.com/fwlink/?LinkId=41913)


La planification de réplication de l'accord de connexion de destinataire n'est pas définie sur « Toujours »
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer l'option sur laquelle l'attribut activationStyle de chaque accord de connexion ADC (Active Directory Connector) est défini. L'attribut activationStyle correspond à la fréquence d'exécution d'un accord de connexion ADC. Une valeur de 0 indique que la planification de réplication est définie sur Jamais. Une valeur de 1 indique que la planification est définie sur Horaires sélectionnés. Une valeur de 2 indique que la planification est définie sur Toujours.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msExchServer2SearchFilter de chaque objet d'accord de connexion ADC. L'attribut msExchServer2SearchFilter représente le filtre de recherche qui sera utilisé lors de vos recherches dans le répertoire.

Si Exchange Server Analyzer détecte que l'attribut activationStyle n'est pas défini sur Toujours et que l'attribut msExchServer2SearchFilter réplique des informations de destinataire, un avertissement s'affiche.

En général, il est conseillé de définir la planification de réplication de l'accord de connexion de destinataire de manière à ce qu'elle réplique toujours. Dans certains cas, la définition de l'accord de connexion sur toute autre planification peut engendrer des rapports de non-remise après le déplacement des boîtes aux lettres des sites Exchange Server 5.5 vers des organisations Exchange Server 2003.

Pour supprimer cet avertissement

  1. Ouvrez le composant logiciel enfichable MMC Services Active Directory Connector (ADC).

  2. Ouvrez l'accord de connexion.

  3. Sur la page Propriétés de l'accord de connexion, sélectionnez l'onglet Planification et Toujours, puis cliquez sur OK.

Pour plus d'informations sur le déploiement de l'ADC et la configuration d'accords de connexion, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569)


La stratégie de destinataire contient des variables
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut gatewayProxy pour chaque objet Stratégie de destinataire. Si Exchange Server Analyzer détecte un objet Stratégie de destinataire qui contient la chaîne SMTP:% dans son attribut gatewayProxy, un message indiquant une configuration autre que celle par défaut s'affiche.

Si vous avez modifié une stratégie de destinataire pour générer des adresses SMTP (Simple Mail Transfer Protocol) en utilisant des chaînes de remplacement, votre stratégie de destinataire inclura des variables. L'utilisation de variables dans la stratégie de destinataire par défaut peut entraîner des problèmes de réplication dans les versions d'Exchange 2000 Server antérieures au Service Pack 2. Il est par conséquent recommandé de ne pas utiliser de variables dans les stratégies de destinataire ou d'effectuer la mise à niveau d'Exchange 2000 Server vers le dernier Service Pack. Exchange 2000 Server SP2 et versions ultérieures prennent en charge les variables dans la stratégie de destinataire par défaut.

Pour modifier une stratégie de destinataire

  1. Démarrez le Gestionnaire système Exchange.

  2. Cliquez sur Organisation, sur Destinataires, puis sur Stratégies de destinataire.

  3. Double-cliquez sur la stratégie que vous souhaitez modifier.

  4. Cliquez sur l'onglet Adresses de messagerie, puis modifiez l'adresse SMTP ou la règle de génération appropriée.

Pour plus d'informations sur la configuration des stratégies de destinataire, voir l'article 249299 de la Base de connaissances Microsoft sur la procédure de configuration des stratégies de destinataire dans Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299).

Pour plus d'informations sur l'utilisation des règles de génération pour personnaliser les adresses SMTP, voir l'article 822447 de la Base de connaissances sur la procédure de modification d'une adresse de courrier électronique SMTP à l'aide des stratégies de destinataires (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447).

Pour plus d'informations sur les problèmes susceptibles de survenir dans Exchange 2000 Server si la stratégie de destinataire par défaut inclut des variables, voir l'article 271339 de la Base de connaissances sur l'impossibilité de monter une base de données et l'apparition de l'ID d'événement 9546 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339).

Pour obtenir les derniers Service Packs d'Exchange 2000 Server, voir le site sur les téléchargements pour Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le service de mise à jour de destinataire semble bloqué
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchServer1HighestUSN de chaque objet Service de mise à jour de destinataire d'Active Directory. Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut activationStyle pour chaque objet du service de mise à jour de destinataire d'Active Directory. L'attribut activationStyle indique l'intervalle de mise à jour pour le service de mise à jour de destinataire.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut highestCommittedUSN pour l'attribut RootDSE du contrôleur de domaine utilisé par le service de mise à jour de destinataire. L'attribut highestCommittedUSN est le numéro de séquence de mise à jour (numéro USN) le plus élevé pour tout objet du serveur qui a été assigné à la base de données de ce contrôleur de domaine.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msExchServer1LastUpdateTime pour chaque objet du service de mise à jour de destinataire. L'attribut msExchServer1LastUpdateTime indique la date et l'heure de la dernière mise à jour de la dernière synchronisation réussie à partir de ce répertoire.

Si Exchange Server Analyzer détecte que les trois conditions suivantes sont remplies, un avertissement s'affiche :

  • L'attribut activationStyle est défini sur 2, ce qui indique que la planification pour ce service de mise à jour de destinataire est défini sur Toujours.

  • Le numéro de séquence répertorié dans la valeur msExchServer1HighestUSN est 5000 ou plus derrière le numéro de séquence répertorié dans highestCommittedUSN.

  • Au moins six heures se sont écoulées depuis que l'horodatage a été enregistré dans l'attribut msExchServer1LastUpdateTime.

Cet avertissement indique que le service de mise à jour de destinataire spécifié n'a pas été utilisé pendant plusieurs heures et s'est peut-être bloqué.

Pour supprimer cet avertissement

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataires, puis sélectionnez Services de mise à jour de destinataire.

  3. Cliquez avec le bouton droit sur le service de mise à jour de destinataire spécifié, puis sélectionnez Mettre à jour.

  4. Patientez 30 minutes, puis réexécutez Exchange Server Analyzer pour voir si cet état d'avertissement existe toujours. Si tel est le cas, passez à l'étape 5. Sinon, aucune autre action n'est requise.

  5. Redémarrez le service Surveillance du système Microsoft Exchange.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances Microsoft :

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838 sur la manière dont le service de mise à jour de destinataire applique les stratégies système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Le service de mise à jour de destinataire n'a pas traité toutes les modifications
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si des valeurs existent pour l'attribut gatewayProxy de chaque objet Service de mise à jour de destinataire dans Active Directory. Si Exchange Server Analyzer détecte que des valeurs sont définies pour l'attribut gatewayProxy de chaque objet Service de mise à jour de destinataire, un avertissement s'affiche.

Cet avertissement indique que l'attribut gatewayProxy d'un objet Service de mise à jour de destinataire contient des anciennes données qui n'ont pas été totalement traitées. Celles-ci doivent être supprimées manuellement.

D'anciennes données de l'attribut gatewayProxy doivent être supprimées ; sinon, l'état de ces adresses sera « appliqué ». Si l'administrateur choisit de modifier une stratégie à l'aide des options « Reconstruire » ou « Mettre à jour », il est possible que des adresses d'utilisateur valides soient accidentellement remplacées, entraînant le changement d'adresses SMTP pour chaque utilisateur. Pour plus d'informations, voir l'article du blog Exchange sur les stratégies de destinataire et les sites Exchange 2000/2003 (en anglais).

Remarque :
Le lien vers ce blog est fourni à titre indicatif. Le contenu peut être modifié sans préavis.

L'attribut gatewayProxy d'un objet Service de mise à jour de destinataire peut contenir des anciennes données qui n'ont pas été totalement traitées si l'une des conditions suivantes existe :

  • Des problèmes avec la réplication d'Active Directory sont survenus. Si le Gestionnaire système Exchange utilise un contrôleur de domaine différent de celui utilisé par le serveur Exchange qui exécute le service de mise à jour de destinataire, des problèmes de latence ou d'autres problèmes avec la réplication d'Active Directory peuvent survenir.

  • Des problèmes de synchronisation non liés à des transactions entraînent la perte des modifications. Ce comportement peut survenir lorsque le Gestionnaire système Exchange et le service Surveillance du système accèdent à l'attribut gatewayProxy en même temps. Ils essaient tous deux de lire l'attribut, d'y apporter des modifications, puis de le réécrire.

Vous devez supprimer les anciennes données en utilisant un outil tel qu'ADSI (Active Directory Service Interfaces) Edit (AdsiEdit.msc), l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour supprimer cet avertissement

  1. Définissez l'intervalle de mise à jour du service de mise à jour de destinataire sur Jamais comme suit :

    1. Ouvrez le Gestionnaire système Exchange.

    2. Développez Destinataires, puis Services de mise à jour de destinataire.

    3. Cliquez avec le bouton droit sur le service de mise à jour de destinataire que vous souhaitez modifier, puis sélectionnez Propriétés.

    4. Sous l'onglet Général, à l'aide de la liste Intervalle de mise à jour, définissez la planification sur Ne jamais exécuter.

  2. Patientez une à deux minutes.

  3. Recherchez ensuite, à l'aide d'ADSI Edit ou de tout autre outil similaire, l'objet Service de mise à jour de destinataire dont l'attribut gatewayProxy contient d'anciennes données. Les objets Service de mise à jour de destinataire se trouvent à l'emplacement suivant :

    CN=Configuration,CN=Services,CN=Microsoft_Exchange,CN=Organisation,CN=Conteneur_listes_adresses,CN=Services_mise_à_jour_destinataire

    1. Cliquez avec le bouton droit sur l'objet Service de mise à jour de destinataire contenant les anciennes données, puis sélectionnez Propriétés.

    2. Sous l'onglet Éditeur d'attribut, faites défiler jusqu'à l'attribut gatewayProxy et sélectionnez-le.

    3. Cliquez sur Modifier pour modifier cet attribut.

    4. Dans la zone des valeurs, sélectionnez le type d'adresse existante qui doit rester supprimé, cliquez sur Supprimer, puis sur OK. Répétez cette étape jusqu'à ce que tous les types d'adresses aient été supprimés.

    5. Cliquez sur OK pour enregistrer les modifications et fermez ADSI Edit.

  4. Forcez une réplication d'annuaire après la suppression de l'attribut gatewayProxy. Veillez à ce que la réplication soit effectuée avant une nouvelle exécution du service de mise à jour de destinataire de domaine.

  5. Rétablissez la planification d'origine du service de mise à jour de destinataire.

  6. Si vous devez le faire, appliquez une nouvelle fois les stratégies de destinataire spécifiques. Utilisez le composant logiciel enfichable Sites et services Active Directory pour effectuer une réplication Active Directory manuelle.

Pour plus d'informations sur la résolution de ce problème, voir l'article 821743 de la Base de connaissances Microsoft sur la non-suppression de l'attribut gatewayProxy sur l'objet Service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743).

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'obligation de la réplication d'annuaire, voir l'article 232072 de la Base de connaissances Microsoft sur le lancement de la réplication entre des partenaires de réplication directe dans Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc et ADSI Edit dans l'aide de Windows Server 2003.


Service de mise à jour de destinataire totalement reconstruit
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msDS-ReplAttributeMetaData de l'objet Service de mise à jour de destinataire à partir du contrôleur de domaine de configuration utilisé par le serveur Exchange. L'attribut msDS-ReplAttributeMetaData contient, entre autres, la date et l'heure de la dernière modification apportée à cet attribut. Si Exchange Server Analyzer détecte que moins de cinq jours se sont écoulés depuis la date et l'heure reprises dans l'attribut msDS-ReplAttributeMetaData, un avertissement s'affiche.

Celui-ci indique qu'une reconstruction complète de ce service de mise à jour de destinataire a été récemment programmée. Si une reconstruction complète est configurée, la prochaine fois que le service de mise à jour de destinataire sera démarré par la planification ou par la commande Mettre à jour, ce service examinera tous les objets au lieu d'interroger uniquement les nouveaux. Ce processus peut prendre un certain temps et ralentir le système.

Si une reconstruction complète est prévue, vous pouvez ignorer cet avertissement en toute sécurité. Dans le cas contraire, vous pouvez résoudre ce problème en utilisant ADSI (Active Directory Service Interfaces) Edit (AdsiEdit.msc) et la procédure suivante pour modifier la valeur True de l'attribut msExchDoFullReplication en False dans Active Directory.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour supprimer cet avertissement

  1. Utilisez ADSI Edit ou un outil similaire pour rechercher l'attribut msExchDoFullReplication de l'objet Service de mise à jour de destinataire spécifié. Les objets Service de mise à jour de destinataire se trouvent à l'emplacement suivant : CN=Configuration,CN=Services,CN=Microsoft_Exchange,CN=Organisation,CN=Conteneur_listes_adresses,CN=Services_mise_à_jour_destinataire

  2. Cliquez avec le bouton droit sur le service de mise à jour de destinataire spécifié, puis sélectionnez Propriétés.

  3. Sous l'onglet Éditeur d'attribut, faites défiler jusqu'à l'attribut msExchDoFullReplication et sélectionnez-le.

  4. Cliquez sur Modifier pour modifier cet attribut.

  5. Dans la boîte de dialogue Éditeur d'attribut booléen, modifiez la sélection en la faisant passer de True à False et cliquez sur OK.

  6. Cliquez de nouveau sur OK pour enregistrer les modifications et fermez ADSI Edit.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances Microsoft :

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838 sur la manière dont le service de mise à jour de destinataire applique les stratégies système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Service de mise à jour de destinataire configuré pour la reconstruction complète
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchDoFullReplication de chaque objet Service de mise à jour de destinataire d'Active Directory. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchDoFullReplication de chaque objet Service de mise à jour de destinataire est définie sur True, un avertissement s'affiche.

Cet avertissement indique que ce service de mise à jour de destinataire est configuré pour exécuter une reconstruction complète lors du prochain cycle de traitement. Si l'attribut msExchDoFullReplication est défini sur True, la prochaine fois que le service de mise à jour de destinataire est démarré par la planification ou par la commande Mettre à jour, le service de mise à jour de destinataire examine chaque objet au lieu d'interroger uniquement les nouveaux objets. Ce processus peut prendre un certain temps et ralentir le système.

Si une reconstruction complète est prévue, vous pouvez ignorer cet avertissement en toute sécurité. Dans le cas contraire, vous pouvez résoudre ce problème en utilisant ADSI (Active Directory Service Interfaces) Edit (AdsiEdit.msc) et la procédure suivante pour modifier la valeur True de l'attribut msExchDoFullReplication en False dans Active Directory.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour supprimer cet avertissement

  1. Utilisez ADSI Edit ou un outil similaire pour rechercher l'attribut msExchDoFullReplication de l'objet Service de mise à jour de destinataire spécifié. Les objets Service de mise à jour de destinataire se trouvent à l'emplacement suivant : CN=Configuration,CN=Services,CN=Microsoft_Exchange,CN=Organisation,CN=Conteneur_listes_adresses,CN=Services_mise_à_jour_destinataire

  2. Cliquez avec le bouton droit sur le service de mise à jour de destinataire spécifié, puis sélectionnez Propriétés.

  3. Sous l'onglet Éditeur d'attribut, faites défiler jusqu'à l'attribut msExchDoFullReplication et sélectionnez-le.

  4. Cliquez sur Modifier pour modifier cet attribut.

  5. Dans la boîte de dialogue Éditeur d'attribut booléen, modifiez la sélection en la faisant passer de True à False et cliquez sur OK.

  6. Cliquez de nouveau sur OK pour enregistrer les modifications et fermez ADSI Edit.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances Microsoft :

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838 sur la manière dont le service de mise à jour de destinataire applique les stratégies système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Service de mise à jour de destinataire inactif
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut activationStyle de chaque objet Service de mise à jour de destinataire d'Active Directory. Si Exchange Server Analyzer détecte que la valeur de l'attribut activationStyle de chaque objet du service de mise à jour de destinataire est définie sur 0, un avertissement s'affiche.

Cet avertissement indique que la planification de cet objet du service de mise à jour de destinataire est définie sur Jamais. Si la planification d'un service de mise à jour de destinataire est définie sur Jamais, les nouveaux objets ne sont pas traités.

Si vous n'avez plus besoin de cet objet de service de mise à jour de destinataire, il est recommandé de le supprimer. Si vous n'avez plus besoin de cet objet de service de mise à jour de destinataire, il est recommandé d'en configurer la planification.

Pour corriger cet avertissement en configurant une planification

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataires, puis sélectionnez Services de mise à jour de destinataire.

  3. Cliquez avec le bouton droit sur le service de mise à jour de destinataire dont la planification est définie sur Jamais, puis sélectionnez Propriétés.

  4. Sélectionnez une planification prédéfinie à l'aide de la liste Intervalle de mise à jour ou cliquez sur Personnaliser pour créer une planification personnalisée.

  5. Cliquez sur OK pour enregistrer les modifications.

  6. Cliquez avec le bouton droit sur ce service de mise à jour de destinataire et sélectionnez Mettre à jour.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances Microsoft :

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 253838 sur la manière dont le service de mise à jour de destinataire applique les stratégies système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838)

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)


Mise à jour du logiciel du service de mise à jour de destinataire requise
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le Service Affichage et groupes dynamiques du Carnet d'adresses (abv_dg.dll), également appelé Service de mise à jour de destinataire. La clé WMI Version indique le numéro de version de ce fichier.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msDS-Behavior-Version de l'objet Paramètres NTDS. Cette valeur indique le niveau fonctionnel de la forêt Active Directory. Les valeurs valides pour l'attribut msDS-Behavior-Version sont indiquées dans le tableau suivant.

Valeur | Niveau fonctionnel de la forêt
0 | Microsoft Windows 2000 Server mixte
1 | Microsoft Windows Server™ 2003 intermédiaire
2 | Microsoft Windows Server 2003 natif

Si Exchange Server Analyzer détecte que le numéro de version de abv_dg.dll est inférieur à 6.0.6615.0 sur un serveur Exchange dans une forêt Active Directory en mode natif ou intermédiaire Windows Server 2003, une erreur s'affiche. Cette erreur indique qu'une version Exchange 2000 Server du service de mise à jour de destinataire est exécutée dans un niveau de forêt Active Directory Windows Server 2003 incompatible. Une mise à jour vers le service de mise à jour de destinataire est requise pour résoudre ce problème.

Si vous utilisez le service de mise à jour de destinataire dans Exchange 2000 Server pour mettre à jour des objets destinataire dans une forêt Windows Server 2003, le service de mise à jour de destinataire ne met pas à jour les objets correctement. Par exemple, le service de mise à jour de destinataire ne reconnaît pas les modifications apportées à l'appartenance au groupe. De plus, si vous utilisez Exchange 2000 Server Active Directory Connector (ADC), ADC peut ne pas répliquer les modifications de l'appartenance au groupe d'Active Directory dans le répertoire Exchange Server 5.5.

Pour effectuer la mise à niveau vers la dernière version du service de mise à jour de destinataire

  1. Pour obtenir la mise à jour requise, voir les instructions de l'article 873059 de la Base de connaissances Microsoft sur le service de mise à jour de destinataire qui n'effectue pas une mise à jour correcte des objets lorsqu'Exchange 2000 Server est exécuté dans une forêt Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059).

  2. Appliquez la mise à jour. Vous ne devez pas redémarrer votre ordinateur après avoir appliqué cette mise à jour. Toutefois, les services liés à Exchange sont automatiquement redémarrés lorsque vous appliquez cette mise à jour.


L'instance RUS n'existe pas pour le domaine
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour renvoyer une liste de domaines de la forêt. Exchange Server Analyzer interroge également l'attribut msExchangeDomainLink pour obtenir une liste des instances de service de mise à jour de destinataire (RUS) de domaine existantes. Exchange Server Analyzer compare ensuite la liste des domaines renvoyée avec celle des instances RUS et détermine s'il y a des correspondances. Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • Un domaine existe

  • Une instance RUS n'existe pas pour ce domaine

Exchange Server Analyzer affiche cette erreur si le domaine a été préparé à l'aide de DomainPrep mais pas de l'instance RUS pour que le domaine existe. Une différence de comparaison peut apparaître dans des scénarios où un administrateur ajoute un nouveau domaine Active Directory à la forêt, prépare le domaine pour Exchange à l'aide de DomainPrep, mais oublie ensuite d'ajouter une instance RUS pour le domaine. Le cas échéant, de nouveaux objets utilisateur créés dans le domaine ne reçoivent pas d'adresse de courrier électronique. Si vous recevez ce message d'erreur, créez un nouveau service de mise à jour de destinataire pour le domaine.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataires.

  3. Cliquez avec le bouton droit sur le nœud Services de mise à jour de destinataire , cliquez sur Nouveau, puis sur Service de mise à jour de destinataire.

  4. Dans la fenêtre Nouvel objet, cliquez sur Parcourir pour rechercher le nom du domaine.

  5. Sélectionnez le nom du domaine et cliquez sur OK.

  6. Dans la fenêtre Nouvel objet, cliquez sur Suivant, puis sur Terminer.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances Microsoft :

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127 sur la procédure de vérification des progrès du service de mise à jour de destinataire Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


Modification de l'époque de réplication
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut ms-DS-ReplicationEpoch de l'objet NTDS Settings des contrôleurs de domaine a été défini.

Une époque est la période pendant laquelle un domaine possède un nom spécifique. Une nouvelle époque commence lorsqu'un domaine est créé pour la première fois et lorsque le nom d'un domaine est modifié.

L'attribut ms-DS-ReplicationEpoch s'applique à la période pendant laquelle tous les contrôleurs de domaine sont répliqués. Si Exchange Server Analyzer détecte qu'une valeur a été définie pour cet attribut, un message indiquant une configuration autre que celle par défaut s'affiche.

La présence d'une valeur pour l'attribut ms-DS-ReplicationEpoch indique généralement que le domaine sur lequel le serveur affecté réside a été renommé. Microsoft Windows Server™ 2003 Édition Standard, Windows Server 2003 Édition Entreprise et Windows Server 2003 Édition Datacenter permettent aux administrateurs de renommer des domaines dans la forêt Active Directory après la mise en place de la structure de la forêt. Le système d'exploitation Windows® 2000 Server ne permet pas aux administrateurs de renommer des domaines dans une forêt Active Directory après la mise en place de la structure de la forêt.

La structure d'une forêt Active Directory est déterminée par l'ordre de création des domaines et les noms hiérarchiques de ces domaines. Commencez par le domaine racine de la forêt. Les noms uniques et les noms DNS par défaut de tous les domaines enfants proviennent du nom du domaine racine de la forêt. Continuez de la même manière pour toutes les arborescences supplémentaires de la forêt.

Modifiez la structure hiérarchique d'une arborescence de domaine existante en renommant les domaines. Par exemple, vous pouvez renommer un domaine enfant de sorte qu'il possède un parent différent ou qu'il devienne un nouveau domaine racine de l'arborescence. Dans ces deux exemples, vous repositionnez un domaine existant pour créer une arborescence des domaines différente.

Vous pouvez également renommer des domaines sans affecter l'arborescence. Par exemple, si vous renommez un domaine racine, vous modifiez le nom de tous les domaines enfants situés sous ce domaine racine. Vous n'avez toutefois pas créé une arborescence de domaines différente.

La modification du nom des domaines n'est pas prise en charge dans les forêts qui contiennent Exchange 2000 Server ou Exchange Server 5.5. Les outils de changement de nom de domaine Windows Server 2003 sont conçus pour modifier le nom des domaines des forêts Active Directory qui ne contiennent pas de serveurs Exchange 2000 Server ou Exchange Server 5.5. Les outils de changement de nom de domaine Windows Server 2003 sont ainsi limités en raison des conditions suivantes :

  • La modification du nom d'un domaine affecte plusieurs attributs Exchange.

  • Les outils de changement de nom de domaine Windows Server 2003 n'offrent aucune fonctionnalité de correction de ces attributs.

La modification du nom des domaines est prise en charge dans les forêts qui contiennent Exchange Server 2003. L'outil Exchange Domain Rename Fix-Up (XDR-fixup.exe) corrige les attributs Exchange Server après la modification du nom d'un domaine qui contient des serveurs Exchange 2003 Server. Vous pouvez utiliser l'outil Exchange Domain Rename Fix-Up avec l'outil de changement de nom de répertoire Windows Server 2003 (Rendom.exe).

Pour plus d'informations sur les outils de changement de nom de domaine Active Directory de Windows Server 2003 et pour les télécharger, voir l'article sur les outils de changement de nom de domaine Active Directory de Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=5585).

Pour renommer un domaine, vous devez exécuter l'outil XDR-fixup. Cet outil modifie les attributs Active Directory dans Exchange Server de sorte qu'ils reflètent le nouveau nom de domaine. Il ne remplace pas les outils de changement de nom de domaine Windows Server 2003. Il ne constitue pas non plus une extension de la fonctionnalité des outils de changement de nom de domaine Windows Server 2003. Vous devez exécuter l'outil XDR-fixup lors de chaque exécution de Rendom.exe.

Pour plus d'informations sur le processus de modification du nom des domaines et son influence sur Exchange Server, voir les outils et documents suivants :

  • sur les outils de changement de nom de domaine Active Directory dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=40992)

  • sur la compréhension du fonctionnement du changement de nom de domaine (http://go.microsoft.com/fwlink/?LinkId=41906)

  • sur le guide pas à pas de l'implémentation du changement de nom de domaine (http://go.microsoft.com/fwlink/?LinkId=41359)

  • sur la correction après changement de nom de domaine d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=34171)

  • sur Exchange et les opérations de changement de nom de domaine (http://go.microsoft.com/fwlink/?LinkId=41908)


Réplique du Carnet d'adresses en mode hors connexion version 2 introuvable
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-01-29

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Public_Folder pour déterminer la valeur actuelle de HasLocalReplica. Si Exchange Server Analyzer détecte que la valeur de HasLocalReplica est définie sur False pour l'instance du Carnet d'adresses en mode hors connexion version 2 d'une liste d'adresses en mode hors connexion, une erreur s'affiche.

Si HasLocalReplica est défini sur False pour le Carnet d'adresses en mode hors connexion version 2 d'une liste d'adresses en mode hors connexion, les listes d'adresses en mode hors connexion ne sont pas générées correctement. Par conséquent, les utilisateurs de Microsoft Outlook® 2002 et version antérieure ne peuvent télécharger aucune liste d'adresses en mode hors connexion.

Ce problème peut se produire si vous n'avez pas configuré les banques de dossiers publics pour qu'elles contiennent des répliques du Carnet d'adresses en mode hors connexion version 2. Par défaut, le Carnet d'adresses en mode hors connexion réplique son contenu dans la banque de dossiers publics du serveur sur lequel il est installé. Si la banque de dossiers publics est supprimée de la configuration de la réplication du Carnet d'adresses en mode hors connexion, le problème décrit dans le paragraphe précédent survient.

Correction de cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis cliquez sur Dossiers.

  3. Cliquez avec le bouton droit sur Dossiers publics, puis cliquez sur Afficher les dossiers système.

  4. Cliquez pour développer l'objet CARNET D'ADRESSES EN MODE HORS CONNEXION.

  5. Sous CARNET D'ADRESSES EN MODE HORS CONNEXION, cliquez avec le bouton droit sur o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut, puis cliquez sur Propriétés.

  6. Sous l'onglet Réplication, vérifiez qu'une banque de dossiers publics est entrée dans la zone Répliquer le contenu vers les banques d'informations publiques suivantes. Si aucune banque de dossiers publics n'est entrée, cliquez sur Ajouter, puis entrez la banque publique appropriée pour le carnet d'adresses en mode hors connexion.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Cliquez pour développer o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut.

  9. Sous o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut, cliquez avec le bouton droit sur offline Address Book Version 2, puis cliquez sur Propriétés.

  10. Sous l'onglet Réplication, vérifiez qu'une banque de dossiers publics est entrée dans la zone Répliquer le contenu vers les banques d'informations publiques suivantes. Si aucune banque de dossiers publics n'est entrée, cliquez sur Ajouter, puis entrez la banque de dossiers publics appropriée pour le carnet d'adresses en mode hors connexion.

  11. Cliquez sur Appliquer, puis sur OK.

Pour plus d'informations sur ce problème, consultez l'article 286328 de la Base de connaissances Microsoft sur l'absence de Carnet d'adresses en mode hors connexion et l'impossibilité de le générer dans Microsoft Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Pour plus d'informations sur la génération de liste de carnet d'adresses en mode hors connexion, consultez la page Web relative à la génération de listes d'adresses en mode hors connexion (http://go.microsoft.com/fwlink/?LinkId=82242).

Pour plus d'informations sur la méthode correcte de suppression du premier ordinateur qui exécute Exchange Server 2003 d'un groupe d'administration, consultez l'article 822931 de la Base de connaissances sur la procédure de suppression du premier ordinateur Exchange Server 2003 du groupe d'administration (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).


Réplique du Carnet d'adresses en mode hors connexion version 3a introuvable
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Public_Folder pour déterminer la valeur actuelle de HasLocalReplica. Si Exchange Server Analyzer détecte que la valeur de HasLocalReplica est définie sur False pour l'instance du Carnet d'adresses en mode hors connexion version 3a d'une liste d'adresses en mode hors connexion, une erreur s'affiche.

Si HasLocalReplica est défini sur False pour le Carnet d'adresses en mode hors connexion version 3a d'une liste d'adresses en mode hors connexion, les listes d'adresses en mode hors connexion ne sont pas générées correctement. Par conséquent, les utilisateurs Microsoft Office Outlook® 2003 ne peuvent télécharger aucune liste d'adresses en mode hors connexion.

Ce problème peut se produire si vous n'avez pas configuré les banques de dossiers publics de sorte qu'elles contiennent des répliques du Carnet d'adresses en mode hors connexion version 3a. Par défaut, le Carnet d'adresses en mode hors connexion réplique son contenu dans la banque de dossiers publics du serveur sur lequel il est installé. Si la banque de dossiers publics est supprimée de la configuration de la réplication du Carnet d'adresses en mode hors connexion, le problème décrit dans le paragraphe précédent survient.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis cliquez sur Dossiers.

  3. Cliquez avec le bouton droit sur Dossiers publics et cliquez sur Afficher les dossiers système.

  4. Cliquez pour développer l'objet CARNET D'ADRESSES EN MODE HORS CONNEXION.

  5. Sous CARNET D'ADRESSES EN MODE HORS CONNEXION, cliquez avec le bouton droit sur o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut, puis cliquez sur Propriétés.

  6. Sous l'onglet Réplication, vérifiez qu'une banque de dossiers publics est entrée dans la zone Répliquer le contenu vers les banques d'informations publiques suivantes. Si aucune banque de dossiers publics n'est entrée, cliquez sur Ajouter, puis entrez la banque de dossiers publics appropriée pour le carnet d'adresses en mode hors connexion.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Cliquez pour développer o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut.

  9. Sous o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut, cliquez avec le bouton droit sur offline Address Book Version 3a, puis cliquez sur Propriétés.

  10. Sous l'onglet Réplication, vérifiez qu'une banque de dossiers publics est entrée dans la zone Répliquer le contenu vers les banques d'informations publiques suivantes. Si aucune banque de dossiers publics n'est entrée, cliquez sur Ajouter, puis entrez la banque de dossiers publics appropriée pour le carnet d'adresses en mode hors connexion.

  11. Cliquez sur Appliquer, puis sur OK.

Pour plus d'informations sur ce problème, voir l'article 286328 de la Base de connaissances Microsoft sur l'absence de Carnet d'adresses en mode hors connexion et l'impossibilité de le générer dans Microsoft Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Pour plus d'informations sur la méthode correcte de suppression du premier ordinateur qui exécute Exchange Server 2003 d'un groupe d'administration, voir l'article 822931 de la Base de connaissances sur la procédure de suppression du premier ordinateur Exchange Server 2003 du groupe d'administration (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).


Planification du connecteur de réplication d'annuaire
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut activationSchedule de chaque objet d'accord de connexion ADC (Active Directory Connector). L'attribut activationSchedule correspond à la fréquence d'exécution d'un accord de connexion ADC. Une valeur de 0 indique que la planification de réplication est définie sur Jamais. Une valeur de 1 indique que la planification est définie sur Horaires sélectionnés. Une valeur de 2 indique que la planification est définie sur Toujours.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msExchServer2SearchFilter de chaque objet d'accord de connexion ADC. L'attribut msExchServer2SearchFilter représente le filtre de recherche qui sera utilisé lors de vos recherches dans le répertoire.

Si Exchange Server Analyzer détecte que l'attribut activationSchedule est défini sur Horaires sélectionnés avec un intervalle de réplication supérieur à 6 heures et que l'attribut msExchServer2SearchFilter réplique les informations sur le destinataire, un avertissement s'affiche.

En général, il est conseillé de définir la planification de réplication de l'accord de connexion de destinataire de manière à ce qu'elle réplique toujours (Toujours). Dans certains cas, la définition de l'accord de connexion sur toute autre planification peut provoquer des rapports de non-remise une fois que des boîtes aux lettres sont déplacées de sites Exchange Server 5.5 vers Exchange 2000 Server ou Exchange Server 2003.

Pour supprimer cet avertissement

  1. Ouvrez le composant logiciel enfichable MMC Services Active Directory Connector (ADC).

  2. Ouvrez l'accord de connexion.

  3. Sur la page Propriétés de l'accord de connexion, cliquez sur l'onglet Planification, sur Toujours et puis sur OK.

Pour plus d'informations sur le déploiement de l'ADC et la configuration d'accords de connexion, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569)


Le serveur ayant le rôle FSMO RID n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut fSMORoleOwner du maître d'opérations RID (relative ID) dans le contexte de nommage de domaine. Par exemple, dans un domaine appelé contoso.com, fSMORoleOwner pour le maître des opérations RID est un attribut de CN=Gestionnaire$_RID, CN=Système, DC=contoso, DC=com. Exchange Server Analyzer tente ensuite d'ouvrir une connexion LDAP sur le port TCP 389 du contrôleur de domaine qui tient actuellement ce rôle. Si Exchange Server Analyzer ne peut pas se connecter à ce contrôleur de domaine, une erreur s'affiche.

Le maître RID alloue des ID relatifs à tous les contrôleurs de domaine pour garantir que toutes les entités de sécurité ont un identificateur unique. Vous pouvez créer un nouvel objet d'entité de sécurité (utilisateur, groupe ou ordinateur) sur n'importe quel contrôleur de domaine. Lors de cette opération, le contrôleur de domaine attribue un identificateur de sécurité (SID) unique à l'objet. Un domaine SID comprend quatre éléments, dont un est le RID pour le domaine. Le maître des opérations RID est chargé de traiter les requêtes de pool RID provenant de tous les contrôleurs de domaine dans un domaine particulier. Le domaine ne peut comporter à tout moment qu'un seul contrôleur de domaine agissant en tant que maître RID.

Pour corriger cette erreur

  1. Vérifiez que le serveur d'annuaire spécifié dans l'erreur est actif et accessible par les serveurs Exchange de votre organisation.

  2. Si ce serveur d'annuaire a été désactivé, vous devez attribuer le rôle de maître RID à un autre contrôleur de domaine.

Pour plus d'informations sur le transfert du rôle de maître des opérations RID d'un contrôleur de domaine à un autre, voir les articles suivants de la Base de connaissances Microsoft :

  • Pour Microsoft Windows Server™ 2003, voir l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Microsoft Windows® 2000 Server, voir l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Rôle FSMO du schéma introuvable
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le contrôleur de domaine spécifié comme schéma FSMO (fSMORoleOwner dans le contexte de nommage de schéma). Si Exchange Server Analyzer détecte que le contrôleur de domaine spécifié dans l'attribut fSMORoleOwner n'existe pas dans la forêt, une erreur s'affiche.

L'attribut fSMORoleOwner du contexte de nommage de schéma (CN=Schéma,CN=Configuration,DC=domaine,DC=com) définit le contrôleur de domaine qui est le contrôleur de schéma pour la forêt. Le contrôleur de domaine maître du schéma contrôle toutes mises à jour et modifications apportées au schéma. Pour mettre à jour le schéma d'une forêt, vous devez avoir accès au contrôleur de schéma. Il ne peut exister qu'un seul contrôleur de schéma dans l'ensemble de la forêt.

Vous devez avoir défini un contrôleur de schéma pour votre forêt Active Directory. L'installation d'Exchange 2000 Server et du Service Pack d'Exchange 2000 Server échouera (même si vous ne mettez pas le schéma à jour) si un contrôleur de domaine maître du schéma n'est pas en ligne lors de l'installation. Si le contrôleur de domaine répertorié comme contrôleur de schéma est hors connexion, il doit être remis en ligne. Ceci ne s'applique pas à Exchange Server 2003. L'installation d'Exchange Server 2003 ne contacte le contrôleur de schéma que si elle détermine que le schéma n'a pas été étendu.

Pour corriger cette erreur

  1. Vérifiez que le serveur Active Directory désigné est physiquement présent.

  2. Si ce serveur d'annuaire a été désactivé, affectez le rôle de contrôleur de schéma à un autre contrôleur de domaine.

Pour plus d'informations sur la manière d'affecter le rôle de contrôleur de schéma à un autre contrôleur de domaine, voir les articles suivants de la Base de connaissances Microsoft :

  • 280178 sur la nécessité d'un accès au contrôleur de schéma pour installer Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178)

  • Pour Microsoft Windows Server™ 2003, voir l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Microsoft Windows® 2000 Server, voir l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Le rôle FSMO du schéma n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut fSMORoleOwner du maître des opérations de schéma dans le contexte de nommage de schéma. Par exemple, dans un domaine nommé contoso.com, fSMORoleOwner pour le maître des opérations de schéma est un attribut de CN=Schéma,CN=Système,DC=contoso,DC=com. Exchange Server Analyzer tente ensuite d'ouvrir une connexion LDAP sur le port TCP 389 du contrôleur de domaine qui tient actuellement ce rôle. Si Exchange Server Analyzer ne peut pas se connecter à ce contrôleur de domaine, une erreur s'affiche.

Le contrôleur de domaine qui tient le rôle de contrôleur de schéma est le seul contrôleur de domaine pouvant effectuer des opérations d'écriture vers le schéma d'annuaire. Ces mises à jour de schéma sont répliquées sur tous les autres contrôleurs de domaine de la forêt à partir du contrôleur de schéma. Le contrôleur de schéma est un rôle de maître des opérations par forêt ; en effet, quelque soit le nombre de domaines, la forêt ne contient qu'un seul schéma. Pour mettre à jour le schéma d'une forêt, vous devez avoir accès au contrôleur de schéma. Il ne peut exister qu'un seul contrôleur de schéma dans l'ensemble de la forêt.

Pour corriger cette erreur

  1. Vérifiez que le serveur d'annuaire spécifié dans l'erreur est actif et accessible par les serveurs Exchange de votre organisation.

  2. Si ce serveur d'annuaire a été désactivé, vous devez attribuer le rôle de contrôleur de schéma à un autre contrôleur de domaine.

Pour plus d'informations sur le transfert du rôle de maître des opérations de schéma d'un contrôleur de domaine à un autre, voir les articles suivants de la Base de connaissances Microsoft :

  • Pour Microsoft Windows Server™ 2003, voir l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Microsoft Windows® 2000 Server, voir l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Expiration imminente d'un certificat SSL
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge l'objet Server Certificate dans le système du serveur Exchange pour récupérer plusieurs propriétés sur des certificats X509. Pour chaque certificat SSL (Secure Sockets Layer) détecté, Exchange Server Analyzer évalue l'attribut ExpirationDate pour identifier la date d'expiration du certificat.

Remarque :
Un serveur doit posséder un certificat de serveur lorsqu'il exécute un protocole SSL. Le certificat de serveur contient le nom du site Web. Le navigateur vérifie que le site Web correspond au nom entré. Par exemple, pour un site Web dont l'adresse est https://www.exemple.com, le nom du certificat doit être www.exemple.com.

Exchange Server Analyzer affiche un avertissement s'il reste entre 3 et 20 jours avant la date correspondant à ExpirationDate. Exchange Server Analyzer affiche une erreur s'il reste moins de 3 jours avant la date correspondant à ExpirationDate.

Si le certificat a expiré, les connexions SSL à l'URL spécifiées dans ce message échouent. De même, les connexions RPC sur HTTP et Exchange Server ActiveSync qui utilisent cette URL échouent.

Pour résoudre cette erreur ou cet avertissement d'expiration du certificat, renouvelez le certificat spécifié dans ce message. La procédure à suivre pour renouveler un certificat dépend de l'autorité de certification utilisée.

Pour plus d'informations

Pour plus d'informations sur SSL et l'utilisation de certificats avec des serveur virtuels dans Exchange Server, consultez les ressources Exchange suivantes :

  • Pour plus d'informations sur l'utilisation des certificats avec des serveurs virtuels dans Exchange Server 2003, consultez l'article 823024 de la Base de connaissances Microsoft sur l'utilisation des certificats avec les serveurs virtuels dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024).

  • Pour plus d'informations sur l'utilisation de SSL et sur l'obtention et l'installation de certificats de serveur, consultez la rubrique sur la configuration d'Exchange Server 2003 pour l'accès client du Guide sur l'accès client à Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47568).

  • Pour plus d'informations sur l'utilisation de SSL et sur l'obtention et l'installation de certificats de serveur pour Exchange Server 2007, consultez la rubrique sur la configuration de SSL pour Outlook Anywhere (http:// go.microsoft.com/fwlink/?LinkId =80875).


Conteneur de serveurs manquant
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut distingushedName pour chaque objet Routing Group découvert dans le groupe d'administration actuel.

Exchange Server Analyzer interroge ensuite Active Directory pour déterminer si un conteneur Serveurs est présent dans le groupe d'administration actuel.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le groupe d'administration actuel contient au moins un groupe de routage.

  • Aucun conteneur Serveurs n'existe.

Cette erreur indique qu'aucun serveur n'est installé dans le groupe d'administration et que les informations de routage risquent de ne pas être diffusées dynamiquement parmi les serveurs d'une organisation Exchange.

Pour supprimer cette erreur, assurez-vous que l'organisation Exchange est en mode natif et suivez les étapes ci-après.

Étapes de résolution

  1. Créez un groupe d'administration.

  2. Créez un conteneur Groupes de routage dans le nouveau groupe d'administration.

  3. Faites glisser les groupes de routage existants de l'ancien conteneur Groupes de routage vers le nouveau.

  4. Redémarrez tous les services Exchange.

Pour plus d'informations sur cette erreur, voir l'article 318491 de la Base de connaissances Microsoft sur les informations de routage qui ne sont pas diffusées dans une organisation Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491).


Nom du service principal manquant du serveur de catalogue global
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-05-12

L'outil Microsoft® Exchange Server Analyzer Tool interroge le serveur de catalogue global du service d'annuaire Active Directory® afin de trouver les valeurs renvoyées pour le nom de domaine complet (FQDN) et le nom NetBIOS de l'attribut servicePrincipalName des ressources exchangeAB et HOST.

Exchange Server Analyzer affiche une erreur si l'une des conditions suivantes est vraie :

  • L' attribut servicePrincipalName pour la ressource exchangeAB ne possède pas l'une des valeurs FQDN ou Nom NetBIOS attendues.

  • L' attribut servicePrincipalName pour la ressource Exchange HOST ne possède pas l'une des valeurs FQDN ou Nom NetBIOS attendues.

Le nom du service principal (SPN) est un nom unique qui identifie une instance d'un service et est associé au compte de connexion sous lequel l'instance du service est exécutée. L'authentification Kerberos n'est pas possible pour les services Exchange dont le SPN n'est pas correctement défini.

  • Si des clients qui exécutent Microsoft Outlook® 2003 ou une version ultérieure rencontrent des problèmes d'authentification Active Directory, il se peut que la ressource exchangeAB ne possède pas de SPN valide.

  • Des échecs d'authentification entre serveurs peuvent indiquer l'absence de SPN valide pour la ressource HOST.

Pour corriger ce problème, procédez comme suit afin d'ajouter les valeurs manquantes à l'attribut servicePrincipalName.

Utilisez l'outil SETSPN.exe pour ajouter un SPN avec les valeurs manquantes.

  1. Installez l'outil Setspn.exe. Pour savoir comment obtenir l'outil Setspn.exe, consultez la rubrique "Windows 2000 Resource Kit Tool : Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103).

    La version pour Windows Server 2003 de l'outil de ligne de commande Setspn.exe se trouve parmi les outils de support de Windows Server 2003 disponibles sur le CD de Windows Server 2003. Pour installer les outils de support de Server 2003, double-cliquez sur le fichier Suptools.msi dans le dossier Support/Tools.

  2. Suivez les instructions figurant dans le fichier Setspn_d.txt de SETSPN.EXE pour ajouter la valeur manquante à l'objet Active Directory pour votre serveur Exchange. L'exemple suivant illustre l'ajout de la valeur FQDN au SPN d'un serveur SMTP virtuel :

    • Ouvrez une invite de commande puis accédez au répertoire où vous avez installé Setspn.exe.

    • À l'invite de commande, entrez la commande suivante :

      setspn.exe-a SMTPSVC/ mail.votredomaine.com NOMDEVOTRESERVEUR

      Remarque :
      Remplacez mail.votredomaine.com par le FQDN de votre serveur SMTP virtuel et NOMDEVOTRESERVEUR par le nom du serveur Exchange.
      Appuyez ensuite sur la touche Entrée.


La banque de dossiers publics du serveur de dossiers du site de ce groupe d'administration n'existe pas dans ce groupe d'administration
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de distinguishedName de chaque banque de dossiers publics. En outre, Exchange Server Analyzer interroge Active Directory pour déterminer les valeurs des attributs siteFolderServer et msExchAdminGroupMode de chaque groupe d'administration. L'attribut siteFolderServer représente le nom du serveur responsable de l'hébergement des dossiers de site (normalement, le premier serveur du site ou le groupe d'administration). L'attribut msExchAdminGroupMode représente le mode pour le groupe d'administration qui peut être :

  • Exchange Server 5.5 pur

  • Exchange Server 5.5, Exchange 2000 Server et Exchange Server 2003 mixte

  • Exchange 2000 Server ou Exchange Server 2003 natif

Si Exchange Server Analyzer détermine que le groupe d'administration n'est pas en mode natif, que la valeur de l'attribut siteFolderServer ne correspond pas à celle de l'attribut distinguishedName de n'importe quelle banque de dossiers publics et que la valeur de l'attribut siteFolderServer ne contient pas la chaîne DEL:, un avertissement s'affiche.

Par défaut, le serveur de dossiers du site est le premier serveur qui est installé dans le groupe d'administration. La banque de dossiers publics sur ce serveur est l'emplacement par défaut des dossiers de disponibilité et des dossiers du carnet d'adresses en mode hors connexion pour le groupe d'administration. Si vous supprimez ou désactivez le serveur de dossiers du site sans répliquer ces dossiers vers un autre serveur et sans désigner ce serveur en tant que Carnet d'adresses en mode hors connexion, les utilisateurs d'Outlook verront des problèmes avec le Carnet d'adresses en mode hors connexion et les données de disponibilité.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour supprimer cet avertissement

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Recherchez la banque d'informations de dossiers publics que vous voulez désigner comme le serveur de dossiers du site, en développant les éléments suivants : CN=<Nom_banque_dossiers_publics>, CN=<Nom_groupe_stockage>, CN=Banque_informations, CN=<Nom_serveur>, CN=Serveurs, CN=<Nom_groupe_administration> ,CN=Groupes_administration, CN=<Nom_organisation>, CN=Microsoft_Exchange, CN=Services, CN=Configuration,DC=<Nom_domaine>,DC=com.

  3. Dans le volet droit, cliquez avec le bouton droit sur CN=<Nom_banque_dossiers_publics> et sélectionnez Propriétés.

  4. Dans le champ Attributs, faites défiler et sélectionnez l'attribut distinguishedName.

  5. Cliquez sur le bouton Modifier, puis copiez l'attribut entier dans le Presse-papiers.

  6. Développez le conteneur Configuration, puis CN=Groupes_administration,CN=<Nom_organisation>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<Nom_domaine>,DC=com.

  7. Cliquez avec le bouton droit sur le groupe d'administration que vous souhaitez modifier et sélectionnez Propriétés.

  8. Dans le champ Attributs, faites défiler et sélectionnez l'attribut siteFolderServer.

  9. Cliquez sur le bouton Modifier et collez la valeur de l'attribut distinguishedName dans le champ Valeur.

  10. Vérifiez le contenu du champ Valeur pour vous assurer que l'opération Coller a été correctement effectuée, puis cliquez sur OK pour enregistrer la modification.

  11. Cliquez sur OK pour fermer la boîte de dialogue des propriétés du groupe d'administration.

  12. Quittez ADSI Edit et redémarrez le service de banque d'informations de Microsoft Exchange sur tous les ordinateurs Exchange Server du site pour que la modification soit prise en compte.

Pour plus d'informations sur la nouvelle création des dossiers système et sur la réinitialisation du serveur de dossiers du site, voir les articles suivants de la Base de connaissances Microsoft :

  • 275171 sur la procédure de réinitialisation des dossiers système dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200 sur l'absence du dossier système Schedule+ disponible/occupé (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server 2003.


La banque de dossiers publics du serveur de dossiers du site utilisée par le Carnet d'adresses en mode hors connexion n'a pas été détectée
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2007-02-01

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active® Directory pour déterminer la valeur de l'attribut siteFolderServer sur toutes les banques de dossiers publics Exchange (banques ayant un objectClass de objectClass=msExchPublicMDB). L'attribut siteFolderServer représente la banque de dossiers publics utilisée pour le serveur du Carnet d'adresses en mode hors connexion.

Si Exchange Server Analyzer détermine qu'un serveur n'est pas listé, que le serveur listé est arrêté ou n'existe pas, un avertissement s'affiche. Si l'attribut siteFolderServer contient la chaîne DEL:, Exchange Server Analyzer affiche un message d'erreur.

Par défaut, Exchange Server 2003 génère des fichiers de carnet d'adresses en mode hors connexion sur le serveur de dossiers du site (le premier serveur installé dans le groupe d'administration). Si vous avez désigné un serveur différent pour faire office de serveur de Carnet d'adresses en mode hors connexion, la banque de dossiers publics répertoriée dans cet attribut sera celle sur le nouveau serveur de Carnet d'adresses en mode hors connexion et non celle sur le serveur de dossiers du site réel du groupe d'administration.

Lorsqu'Exchange Server 2003 génère des fichiers de Carnet d'adresses en mode hors connexion, il les annexe à des messages électroniques qu'il place ensuite dans des dossiers publics spéciaux. Microsoft Office Outlook® 2003 récupère les messages du dossier et télécharge les fichiers joints.

Dans Exchange Server 2003, les messages du carnet d'adresses en mode hors connexion sont stockés dans des sous-dossiers du dossier CARNET D'ADRESSES EN MODE HORS CONNEXION, qui est l'un des dossiers système de l'arborescence par défaut Dossiers publics. Ce dossier contient un sous-dossier pour chaque groupe d'administration ou site de votre topologie. Par défaut, un réplica du contenu d'un dossier de groupe d'administration spécifique réside sur le premier serveur installé dans le groupe d'administration (appelé serveur de dossiers du site).

Si votre organisation Exchange est une organisation Exchange Server 2007, sans client de niveau inférieur (Outlook 2003 ou version précédente), vous pouvez ignorer ce message d'avertissement ou d'erreur en toute sécurité. Si votre organisation Exchange Server 2007 héberge des clients exécutant Outlook 2003 ou une version antérieure, suivez la procédure ci-dessous pour activer la distribution des dossiers publics des fichiers du carnet d'adresses en mode hors connexion. La distribution des dossiers publics est la méthode de distribution par laquelle les clients exécutant Outlook 2003 ou une version antérieure qui travaillent en mode hors connexion ou via une connexion d'accès à distance accèdent au carnet d'adresses en mode hors connexion.

Correction de cet avertissement dans Exchange Server 2003

  1. Si vous êtes certain de l'existence du serveur, dans le Gestionnaire système Exchange, sous Serveurs, développez le serveur et le groupe de stockage, puis cliquez sur Banque de dossiers publics. Dans le volet droit, vérifiez que la banque d'informations est en cours d'exécution.

  2. Pour désigner un nouveau serveur de Carnet d'adresses en mode hors connexion, sous Destinataires, cliquez sur Listes d'adresses en mode hors connexion. Ensuite, dans le volet droit, cliquez sur Liste d'adresses en mode hors connexion par défaut (ou sur toute autre liste d'adresses en mode hors connexion qui génère ce message).

    Si vous ne souhaitez pas utiliser un Carnet d'adresses en mode hors connexion, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis sur Supprimer. Sinon, utilisez le reste de cette procédure pour définir une planification.

  3. Cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis cliquez sur Propriétés.

  4. Sous l'onglet Général, sous Serveur du Carnet d'adresses en mode hors connexion, cliquez sur Parcourir pour sélectionner un serveur.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez Exchange Management Console.

  2. Développez Microsoft Exchange et Configuration de l'organisation, puis sélectionnez Boîte aux lettres.

  3. Dans le volet des résultats, cliquez sur l'onglet Carnet d'adresses en mode hors connexion.

  4. Sous l'onglet Carnet d'adresses en mode hors connexion, sélectionnez « Carnet d'adresses en mode hors connexion par défaut ».

    1. Pour activer la distribution des dossiers publics du carnet d'adresses en mode hors connexion, sous l'onglet Distribution, sélectionnez Activer la distribution de dossier publics.

    2. Cliquez sur OK pour enregistrer les modifications.

  5. Pour désigner un nouveau serveur de carnet d'adresses en mode hors connexion, dans le volet Actions, cliquez sur Déplacer pour lancer l'Assistant Déplacement du carnet d'adresses en mode hors connexion. Cet Assistant permet de déplacer la génération de l'OAB vers un autre serveur. Il copie également les fichiers de l'OAB sur le serveur spécifié.

Utilisation d'Exchange Management Shell pour activer la distribution des dossiers publics des fichiers du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB.

    Par exemple, pour activer la distribution de dossiers publics du carnet d'adresses en mode hors connexion par défaut, vous devez entrer :
Copier le code
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Utilisation d'Exchange Management Shell pour définir le serveur qui hébergera la génération du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB et <Server> spécifie le serveur Exchange sur lequel exécuter l'opération sélectionnée.

    Par exemple, pour déplacer la génération de l'OAB vers le serveur SERVER01, vous devez entrer :
Copier le code
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2003, consultez la section sur la configuration de carnets d'adresses en mode hors connexion dans Exchange Server 2003 dans le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2007, consultez la page « Configuration de l'organisation > Boîte aux lettres > Carnets d'adresses en mode hors connexion » (http:// go.microsoft.com/fwlink/?LinkId =79247).


La valeur SiteName est codée de manière irréversible
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre SiteName est présente sur le serveur Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

Si Exchange Server Analyzer détecte que la valeur de Registre SiteName est présente, un avertissement s'affiche.

Cet avertissement indique que le site du service d'annuaire Active Directory® a été codé de manière irréversible sur cet ordinateur exécutant le système d'exploitation Microsoft Windows®. Cette configuration n'est pas recommandée pour Exchange Server.

Si vous codez de manière irréversible un site Windows, vous risquez de provoquer des problèmes au niveau du service Surveillance du système Microsoft Exchange et d'Exchange Server en général. Vous devriez envisager de supprimer la valeur de Registre SiteName. Si vous supprimez la valeur de Registre SiteName, Windows se connecte automatiquement au site Active Directory concerné.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer la valeur de Registre SiteName

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\Netlogon\Parameters

  3. Dans le volet droit, recherchez la valeur de Registre SiteName et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre SiteName, voir l'article 322834 de la Base de connaissances sur l'événement 1005, le service Surveillance du système ne démarre pas (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834).


Votre organisation Exchange compte plus de 900 groupes d'administration
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de groupes d'administration présents dans l'organisation Exchange. Si Exchange Server Analyzer détecte plus de 900 groupes d'administration, un message d'avertissement s'affiche.

Il est recommandé d'utiliser un maximum de 900 instances pour tout type d'objet Exchange. Cela est dû à la valeur par défaut d'Active Directory qui définit la taille de page maximale renvoyée pour toute demande donnée sur 1 000. Cela signifie que si une demande LDAP (Lightweight Directory Access Protocol) est effectuée pour un objet et si plus de 1 000 instances de cet objet existent dans Active Directory, aucun résultat n'est renvoyé étant donné que la taille de page maximale est dépassée.

Dans le cas d'Exchange, différents processus nécessitent l'instanciation de types d'objet spécifique. Par exemple, le Gestionnaire système Exchange effectue une demande LDAP à Active Directory pour créer un affichage de liste de tous les groupes d'administration dans l'organisation Exchange. Si l'organisation compte plus de 1 000 groupes d'administration, Active Directory ne renvoie aucun résultat. Par conséquent, une erreur s'affiche dans le Gestionnaire système Exchange et aucun groupe d'administration n'apparaît.

Même si la valeur de la taille de page maximale pour Active Directory peut être augmentée, cela n'est pas recommandé ou pris en charge par Exchange. Un comportement anormal et des échecs ont été observés dans les environnements Exchange dans lesquels la valeur de la taille de page maximale a été augmentée.

Même s'il est recommandé de rester à ou en dessous de 900 pour tout type d'objet dans Echange, plus de 1 000 types d'objets sont pris en charge.

Pour résoudre ce problème, pensez à consolider vos groupes d'administration.

Pour plus d'informations sur la consolidation des sites Exchange et des groupes d'administration, voir les articles suivants sur :

  • le déploiement d'une solution mondiale de consolidation de site pour Exchange Server 2003 de Microsoft (http://go.microsoft.com/fwlink/?LinkId=33531).


Votre organisation Exchange compte plus de 900 serveurs Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-03-30

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour obtenir le nombre d'objets de l'annuaire ayant un objectCategory de msExchExchangeServer. Ce nombre représente le nombre d'ordinateurs Exchange Server trouvés dans Active Directory. Si Exchange Server Analyzer détecte plus de 900 ordinateurs Exchange Server, un avertissement s'affiche.

Il est recommandé d'utiliser un maximum de 900 instances pour tout type d'objet Exchange. Cela est dû à la valeur par défaut d'Active Directory qui définit la taille de page maximale renvoyée pour toute demande donnée sur 1 000. Cela signifie que si une demande LDAP (Lightweight Directory Access Protocol) est effectuée pour un objet et si plus de 1 000 instances de cet objet existent dans Active Directory, aucun résultat n'est renvoyé étant donné que la taille de page maximale est dépassée.

Dans le cas d'Exchange Server, différents processus nécessitent l'instanciation de types d'objet spécifique. Par exemple, le Gestionnaire système Exchange effectue une demande LDAP à Active Directory pour créer un affichage de liste de tous les serveurs Exchange dans l'organisation Exchange. Si l'organisation compte plus de 1 000 serveurs Exchange, Active Directory ne renvoie aucun résultat. Par conséquent, une erreur s'affiche dans le Gestionnaire système Exchange et aucun serveur Exchange n'apparaît.

Même si la valeur de la taille de page maximale pour Active Directory peut être augmentée, cela n'est pas recommandé ou pris en charge par Exchange. Un comportement anormal et des échecs ont été observés dans les environnements Exchange dans lesquels la valeur de la taille de page maximale a été augmentée.

Même s'il est recommandé de rester à ou en dessous de 900 pour tout type d'objet dans Echange Server, plus de 1 000 types d'objets sont pris en charge.

Pour supprimer cet avertissement

  1. Pensez à consolider les serveurs Exchange de votre organisation.

  2. Recherchez les ordinateurs Exchange Server orphelins dans Active Directory et supprimez-les.

Pour plus d'informations sur la consolidation des serveurs Exchange, voir la rubrique sur la consolidation de serveurs à l'aide d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47586).


Plus de dix administrateurs sont délégués au niveau de l'organisation
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre d'utilisateurs disposant d'autorisations de type administrateur Exchange ou administrateur intégral Exchange. Exchange Server Analyzer compte le nombre d'entrées répertoriées dans l'attribut msExchAdmins, qui constitue un lien avec tous les administrateurs Exchange de l'organisation, ainsi qu'avec les autorisations appropriées. Si Exchange Server Analyzer détecte plus de 10 utilisateurs disposant d'autorisations de type administrateur Exchange et/ou administrateur intégral Exchange, un avertissement s'affiche.

msExchAdmins est un attribut à valeurs multiples du conteneur racine de l'organisation Exchange. Il contient une liste d'identificateurs de sécurité (SID) qui représentent les comptes d'utilisateurs avec les autorisations Exchange déléguées.

Il est conseillé de limiter le nombre d'utilisateurs disposant d'un accès en écriture à l'organisation Exchange. Envisagez de réduire le nombre d'administrateurs Exchange et d'administrateurs intégraux Exchange au niveau de l'organisation. En comparant les rôles administratifs aux exigences de votre infrastructure de messagerie, vous trouverez peut-être que vous pouvez convertir un grand nombre de ces utilisateurs en administrateurs Exchange Affichage seul au niveau de l'organisation, tout en leur délégant le rôle d'administrateur Exchange au niveau du groupe d'administration.

Pour supprimer cet avertissement

  1. Envisagez de réduire le nombre d'utilisateurs disposant d'autorisations de type administrateur Exchange et/ou administrateur intégral Exchange.

  2. Envisagez d'effectuer un audit des autorisations Exchange Server dans votre organisation pour s'assurer qu'elles sont appropriées.

Pour plus d'informations sur la planification et la configuration d'autorisations dans Exchange, consultez les documents suivants :

  • Utilisation des autorisations Active Directory dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47592).

  • Microsoft Exchange Server 2007, Opérations « Configuration des autorisations » (http://go.microsoft.com/fwlink/?LinkId=78432).

  • Microsoft Exchange Server 2007, Planification et architecture, Planification d'Active Directory « Considérations relatives aux autorisations » (http://go.microsoft.com/fwlink/?LinkId=78433).

Pour plus d'informations sur les rôles administratifs dans Exchange Server 2003, voir l'article 823018 de la Base de connaissances Microsoft sur la présentation des autorisations de rôle administratif Exchange dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823018).

Pour plus d'informations sur les rôles administratifs dans Exchange 2000 Server, voir l'article 289811 de la Base de connaissances sur les autorisations de rôle dans Exchange 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=289811).


Cet accord de connexion n'est pas défini pour créer des comptes désactivés en cas de non-correspondance
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchServer1AlwaysCreateAs de chaque objet d'accord de connexion. Si Exchange Server Analyzer détermine que l'attribut msExchServer1AlwaysCreateAs n'est pas défini sur 1, un avertissement s'affiche.

L'attribut msExchServer1AlwaysCreateAs détermine le mode de synchronisation des objets X.500 avec Active Directory. Une valeur de 0 indique que l'accord de connexion a été configuré pour créer des contacts Microsoft Windows®. Une valeur de 1 pour cet attribut indique que l'accord de connexion a été configuré pour créer des comptes d'utilisateurs Windows désactivés dans Active Directory. Une valeur de 2 indique que l'accord de connexion a été configuré pour créer de nouveaux comptes d'utilisateurs Windows.

Exchange Server Analyzer émet un avertissement dans une situation où Exchange Server 5.5 doit coexister avec Active Directory et une migration complète vers Exchange Server 2003 est prévue car il est important qu'Active Directory Connector (ADC) crée des comptes d'utilisateurs Windows désactivés. Ces comptes d'utilisateurs Windows désactivés sont « à boîte aux lettres activée », ce qui signifie qu'ils sont logiquement attachés à une boîte aux lettres existant sur l'ordinateur Exchange Server 5.5. La création de comptes d'utilisateurs Windows désactivés est nécessaire pour l'objet utilisateur qui représente ce compte Windows désactivé avant d'accéder aux dossiers publics et autres objets sécurisés dans Active Directory.

Dans l'interface utilisateur ADC, trois options sont disponibles pour la création de nouveaux objets lorsqu'un objet correspondant n'est pas trouvé dans Active Directory pour une boîte aux lettres d'Exchange Server 5.5. Elles sont répertoriées sous l'onglet Avancé des propriétés de l'accord de connexion comme suit :

  • Créer un contact WindowsCette option n'est pas recommandée car un objet Contact ne possède aucun contexte de sécurité.

  • Créer un nouveau compte d'utilisateur Windows Cette option n'est pas recommandée car le nouveau compte dispose d'un nouveau SID et l'historique du SID du compte utilisateur Microsoft Windows NT® Server 4.0 n'est par conséquent pas transféré à ce nouveau compte lors de la migration (car les SID sont différents).

  • Créer un compte d'utilisateur Windows désactivé Cette option est recommandée car elle permet à l'utilisateur Windows NT Server 4.0 de coexister (et de disposer d'un accès correct aux ressources) jusqu'à ce que la migration complète soit terminée.

Pour supprimer cet avertissement

  1. Configurez l'accord de connexion de destinataire Active Directory pour qu'il crée des comptes d'utilisateurs Windows désactivés à boîte aux lettres activée.

  2. Utilisez l'outil de migration Active Directory, qui effectue la migration des comptes d'utilisateurs Windows NT Server 4.0 vers Active Directory et crée des comptes Windows activés. Ces comptes Windows activés auront le même SID que les comptes Windows désactivés créés par ADC.

  3. Utilisez l'Assistant Nettoyage Active Directory (ADClean), qui fusionne les informations du compte créé par l'outil de migration Active Directory dans le compte créé par ADC.

Pour plus d'informations sur les accords de connexion de destinataire Active Directory Connector, voir les articles suivants de la Base de connaissances Microsoft :

  • 823601 sur la configuration requise et les implications d'Active Directory Connector dans une organisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180 sur l'accord de connexion d'Active Directory Connector requis pour les groupes d'administration mixtes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 296260 sur la procédure de configuration d'un accord de connexion de destinataire bidirectionnel pour les utilisateurs Exchange Server 5.5 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260)

  • Pour plus d'informations sur l'Assistant Nettoyage Active Directory, voir l'article suivant de la Base de connaissances :

  • 270652 sur les utilisations possibles de l'Assistant Nettoyage de compte Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652)

  • Pour plus d'informations sur l'outil de migration Active Directory, voir l'article suivant de la Base de connaissances :

  • 260871 sur la procédure de configuration d'ADMT pour une migration de Windows NT 4.0 vers Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260871)


Ceci est un accord de connexion monodirectionnel de Exchange
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchSynchronizationDirection sur chaque objet d'accord de connexion. L'attribut msExchSynchronizationDirection représente la direction dans laquelle les annuaires seront synchronisés. Si cet attribut est défini sur 2, un avertissement s'affiche.

L'attribut msExchSynchronizationDirection peut avoir la valeur 0 ou 2. Si cet attribut est défini sur 0, il indique un accord de connexion bidirectionnel. Si cet attribut est défini sur 2, il s'agit d'un accord de connexion monodirectionnel de l'ordinateur Exchange Server.

Il est recommandé d'utiliser des accords de connexion bidirectionnels. Les environnements Exchange en mode mixte (coexistence d'Exchange Server 5.5 avec Exchange 2000 Server et/ou Exchange Server 2003 ) nécessitent un accord de connexion bidirectionnel.

Pour supprimer cet avertissement

  1. Supprimez l'accord de connexion monodirectionnel existant.

  2. Créez un accord de connexion bidirectionnel de remplacement.

Pour plus d'informations sur les accords de connexion Active Directory Connector (ADC), voir les articles suivants de la Base de connaissances Microsoft :

  • 823601 sur la configuration requise et les implications d'Active Directory Connector dans une organisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180 sur l'accord de connexion d'Active Directory Connector requis pour les groupes d'administration mixtes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721 sur les droits de propriétaire de boîte aux lettres Exchange Server 5.5, qui sont supprimés lorsque vous modifiez l'accord de connexion ADC monodirectionnel en accord bidirectionnel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


Ceci est un accord de connexion monodirectionnel de Windows
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchSynchronizationDirection sur chaque objet d'accord de connexion. L'attribut msExchSynchronizationDirection représente la direction dans laquelle les annuaires seront synchronisés. Si cet attribut est défini sur 1, un avertissement s'affiche.

L'attribut msExchSynchronizationDirection peut avoir la valeur 0, 1 ou 2. La valeur 0 indique un accord de connexion bidirectionnel, la valeur 1 un accord de connexion monodirectionnel d'Active Directory et la valeur 2 un accord de connexion monodirectionnel de l'ordinateur Exchange Server.

Il est recommandé d'utiliser des accords de connexion bidirectionnels. Les environnements Exchange en mode mixte (coexistence d'Exchange Server 5.5 avec Exchange 2000 Server et/ou Exchange Server 2003 ) nécessitent un accord de connexion bidirectionnel.

Pour supprimer cet avertissement

  1. Supprimez l'accord de connexion monodirectionnel existant.

  2. Créez un accord de connexion bidirectionnel de remplacement.

Pour plus d'informations sur les accords de connexion Active Directory Connector (ADC), voir les articles suivants de la Base de connaissances Microsoft :

  • 823601 sur la configuration requise et les implications d'Active Directory Connector dans une organisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601)

  • 303180 sur l'accord de connexion d'Active Directory Connector requis pour les groupes d'administration mixtes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180)

  • 317721 sur les droits de propriétaire de boîte aux lettres Exchange Server 5.5, qui sont supprimés lorsque vous modifiez l'accord de connexion ADC monodirectionnel en accord bidirectionnel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721)


La différence d'horodatage entre Exchange et Active Directory dépasse 5 minutes
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_UTCTime pour déterminer la date et l'heure de chaque serveur Exchange. Exchange Server Analyzer récupère également la date et l'heure actuelles du contrôleur de domaine par défaut. Si Exchange Server Analyzer détecte une différence d'au moins 5 minutes entre les deux serveurs, une erreur s'affiche.

Microsoft Windows 2000 Server et Windows Server™ 2003 utilisent le service de temps Windows pour synchroniser la date et l'heure des ordinateurs exécutés sur un réseau Windows. L'heure synchronisée est essentielle dans Windows 2000 Server et Windows Server 2003 car le protocole d'authentification par défaut utilise l'heure de la station de travail dans le cadre du processus de génération de tickets d'authentification. MIT Kerberos version 5 est le protocole d'authentification par défaut.

Pour tous les serveurs Windows d'un domaine de service d'annuaire Active Directory®, le service de temps Windows se configure automatiquement à l'aide du service de temps Windows disponible sur les contrôleurs de domaine. Le service de temps Windows configure un contrôleur de domaine de son domaine comme source de temps fiable et se synchronise périodiquement avec cette source.

Pour corriger cette erreur, synchronisez l'horloge du serveur Exchange avec le serveur d'annuaire.

Pour synchroniser l'horloge d'un serveur dans un domaine Active Directory

  1. Ouvrez une invite de commandes.

  2. Entrez w32tm /resync, puis appuyez sur ENTRÉE.

Si cette erreur persiste ou si de nombreux ordinateurs de votre organisation la génèrent, passez en revue le mode de déploiement et de configuration du service de temps Windows de votre forêt Active Directory. Pour plus d'informations sur le service de temps Windows, voir l'article sur les références techniques du service de temps Windows (http://go.microsoft.com/fwlink/?LinkId=40648).

Si les serveurs frontaux Exchange ne sont plus synchronisés avec l'heure d'Active Directory, les clients peuvent recevoir des erreurs « HTTP 500 Erreur interne au serveur » lorsqu'ils tentent de se connecter à Microsoft Office Outlook® Web Access. Pour plus d'informations sur cette situation, voir l'article 841546 de la Base de connaissances Microsoft sur les problèmes connus entraînant le message d'erreur « HTTP 500 Erreur interne au serveur » dans Exchange 2000 Outlook Web Access (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546).


La différence d'horodatage entre le serveur Active Directory Connector et Active Directory dépasse 5 minutes
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_UTCTime pour déterminer la date et l'heure de chaque serveur Active Directory Connector. Exchange Server Analyzer récupère également la date et l'heure actuelles du contrôleur de domaine par défaut. Si Exchange Server Analyzer détecte une différence d'au moins 5 minutes entre les deux serveurs, une erreur s'affiche.

Microsoft Windows 2000 Server et Windows Server™ 2003 utilisent le service de temps Windows pour synchroniser la date et l'heure des ordinateurs exécutés sur un réseau Windows. L'heure synchronisée est essentielle dans Windows 2000 Server et Windows Server 2003 car le protocole d'authentification par défaut utilise l'heure de la station de travail dans le cadre du processus de génération de tickets d'authentification. MIT Kerberos version 5 est le protocole d'authentification par défaut.

Pour tous les serveurs Windows d'un domaine de service d'annuaire Active Directory®, le service de temps Windows se configure automatiquement à l'aide du service de temps Windows disponible sur les contrôleurs de domaine. Le service de temps Windows configure un contrôleur de domaine de son domaine comme source de temps fiable et se synchronise périodiquement avec cette source.

Pour corriger cette erreur, synchronisez l'horloge du serveur ADC avec le serveur d'annuaire.

Pour synchroniser l'horloge d'un serveur dans un domaine Windows 2000 Server ou Windows Server 2003

  1. Ouvrez une invite de commandes.

  2. Entrez w32tm /resync, puis appuyez sur ENTRÉE.

Si cette erreur persiste ou si de nombreux ordinateurs de votre organisation la génèrent, passez en revue le mode de déploiement et de configuration du service de temps Windows de votre forêt Active Directory. Pour plus d'informations sur le service de temps Windows, voir l'article sur les références techniques du service de temps Windows (http://go.microsoft.com/fwlink/?LinkId=40648).


Windows Server 2003 n'exécute pas la version officielle finale
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé Version sur les serveurs Active Directory Connector (ADC) de votre organisation Exchange. Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows qui s'exécute sur les serveurs ADC :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si Exchange Server Analyzer détecte que la valeur de la seconde instance de CurrentVersion est 5.2 alors que la valeur de Version n'est pas 5.2.3790, une erreur s'affiche.

Une valeur CurrentVersion de 5.2 indique que l'ordinateur exécute un système d'exploitation Windows Server 2003. La valeur Version de la version commerciale de tous les systèmes d'exploitation Windows Server 2003 est 5.2.3790. Toute autre valeur de la clé Version indique qu'une pré-version de Windows Server 2003 est en cours d'utilisation.

À moins que vous ne participiez à un programme TAP (Technology Adoption Program) ou à un programme similaire parrainé par Microsoft, Microsoft ne prend pas en charge et ne recommande pas l'utilisation de logiciels préliminaires dans des environnements de production.

Pour corriger cette erreur

  1. Effectuez la mise à niveau de tous les serveurs d'infrastructure Exchange, y compris les contrôleurs de domaine, les serveurs de catalogue global, les serveurs ADC et les ordinateurs Exchange Server, vers la dernière version commerciale du logiciel.

  2. Si l'option de mise à niveau est disponible ou prise en charge, reconstruisez le système d'exploitation et restaurez les paramètres et les données d'Exchange Server.

Effectuez la mise à niveau de tous les serveurs d'infrastructure Exchange, y compris les contrôleurs de domaine, les serveurs de catalogue global, les serveurs ADC et les ordinateurs Exchange Server, vers la dernière version commerciale du logiciel.

Pour plus d'informations sur les mises à jour logicielles de Windows Server 2003, voir le site Web sur les mises à jour logicielles de Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=33760).


Windows Server 2003 exécute le logiciel préliminaire
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool examine la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé ServicePackMajorVersion. Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows exécutée sur l'ordinateur de destination :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si la valeur pour la seconde instance de CurrentVersion est 5.2 et que celle de ServicePackMajorVersion est supérieure à 1, Exchange Server Analyzer affiche un message d'avertissement.

Une valeur CurrentVersion de 5.2 indique que l'ordinateur exécute un système d'exploitation Microsoft Windows Server™ 2003. Une valeur ServicePackMajorVersion supérieure à 1 indique qu'un Service Pack d'une version ultérieure au Service Pack 1 a été installé. Étant donné que le Service Pack 1 est le seul Service Pack commercialisé pour Windows Server 2003, tous les Service Packs ultérieurs de Windows Server 2003 installés doivent être des logiciels préliminaires.

À moins que vous ne participiez à un programme TAP (Technology Adoption Program) ou à un programme similaire parrainé par Microsoft, il est recommandé de ne pas exécuter de logiciel préliminaire dans des environnements de production.

Pour supprimer cet avertissement

  1. Désinstallez tout logiciel préliminaire installé.

  2. Si l'option de désinstallation est disponible, reconstruisez le système d'exploitation et restaurez les paramètres et les données d'Exchange Server.

Pour plus d'informations sur les mises à jour logicielles de Windows Server 2003, voir le site Web sur les mises à jour logicielles de Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=33760).


Windows 2000 Server n'exécute pas le Service Pack 4
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool examine la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé ServicePackMajorVersion. Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows exécutée sur l'ordinateur cible :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si Exchange Server Analyzer détermine que le système cible utilise un système d'exploitation Windows 2000 Server sans exécuter le Service Pack 4 pour Windows 2000 Server, un avertissement s'affiche.

Il est recommandé d'installer les derniers Service Packs pour tous les logiciels de votre déploiement Exchange.

Pour supprimer cet avertissement

  1. Mettez à jour tous les contrôleurs de domaine et serveurs de catalogue global qui utilisent un système d'exploitation Windows 2000 Server vers le Service Pack 4, ainsi que les derniers correctifs et mises à jour de Windows Update.

  2. Mettez à jour tous les ordinateurs Exchange Server vers le dernier Service Pack et correctif cumulatif.

Pour plus d'informations sur l'obtention et l'installation des Service Packs des systèmes d'exploitation Windows 2000 Server, voir le site Web sur les Service Packs Windows 2000 (http://go.microsoft.com/fwlink/?linkid=18353).

Pour plus d'informations sur l'obtention et l'installation des Service Packs et correctifs d'Exchange Server, voir le site Web sur Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).


Windows 2000 Server n'exécute pas la version officielle finale
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2005-11-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé Version.

Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows exécutée sur l'ordinateur :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 5.0 indique que l'ordinateur exécute un système d'exploitation Microsoft Windows 2000 Server. La valeur Version de la version commerciale de tous les systèmes d'exploitation Windows 2000 Server est 5.0.2195. Toute autre valeur de la clé Version indique qu'une pré-version de Windows 2000 Server est en cours d'utilisation.

Si Exchange Server Analyzer détecte que la valeur de la seconde instance de CurrentVersion est 5.0 alors que la valeur de Version n'est pas 5.0.2195, une erreur s'affiche.

À moins que vous ne participiez à un programme TAP (Technology Adoption Program) ou à un programme similaire parrainé par Microsoft, Microsoft ne prend pas en charge et ne recommande pas l'utilisation de logiciels préliminaires dans des environnements de production.

Pour corriger cette erreur

  1. Effectuez la mise à niveau de tous les serveurs d'infrastructure Exchange, y compris les contrôleurs de domaine, les serveurs de catalogue global, les serveurs ADC (Active Directory Connector) et les ordinateurs Exchange Server, vers la dernière version commerciale du logiciel.

  2. Si l'option de mise à niveau est disponible ou prise en charge, reconstruisez le système d'exploitation et restaurez les paramètres et les données d'Exchange Server.

Pour plus d'informations sur l'obtention et l'installation de Windows 2000 Service Pack 4, voir le site Web sur Windows 2000 Service Pack 4 (http://go.microsoft.com/fwlink/?LinkId=33241).


L'adresse X.400 possède un caractère de fin non valide
Microsoft Exchange Server Analyzer - Articles > Active Directory >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de gatewayProxy dans vos stratégies de destinataire et vérifier que l'adresse X.400 termine par un point-virgule.

Une mise en forme correcte d'une adresse X.400 dans une stratégie de destinataire impose que l'adresse se termine par un point-virgule. Si le point-virgule n'est pas présent, le routage du message vers l'adresse X.400 est interrompu.

Pour résoudre ce problème, vous devez ajouter un point-virgule à la fin de l'adresse à l'aide d'Active Directory Service Interfaces (ADSI) Edit ou de l'outil LDP.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour corriger cette erreur

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Développez Configuration [Nom_domaine], CN=Configuration, DC=Nom_domaine, DC=Suffixe_domaine.

  3. Développez CN=Services, puis CN=Microsoft_Exchange.

  4. Développez CN=Nom_organisation, CN=Groupes_administration et CN=Stratégies_destinataire.

  5. Cliquez avec le bouton droit sur CN=Nom_stratégie et sélectionnez Propriétés.

  6. Faites défiler jusque gatewayProxy, sélectionnez-le et cliquez sur Modifier.

  7. Dans le champ Valeur, entrez l'attribut gatewayProxy correct.

  8. Fermez l'Éditeur Active Directory et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.


Récupération de base de données
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2007-01-22

Les articles de cette section fournissent des détails sur les erreurs de base de données et les événements d'avertissement détectés par l'outil de dépannage de base de données de Microsoft® Exchange dans le journal des événements d'application. L'utilitaire de dépannage de base de données utilise le même moteur que l'Assistant Dépannage de Microsoft Exchange pour exécuter de façon programmée un ensemble d'opérations de dépannage pour déterminer les causes principales des problèmes de montage de base de données. En outre, ces articles décrivent des procédures permettant de détecter des symptômes et de résoudre des problèmes de base de données.

Pour plus d'informations et pour télécharger l'outil, consultez la page Web relative à l'Assistant Dépannage de Microsoft Exchange v1.0.


ESE 428 (0xfffff8f0) : Espace disque libre insuffisant sur le lecteur du journal des transactions
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-04-02

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements ESE 428 dans le journal des applications. Cet événement indique que l'espace disponible sur le lecteur du journal des transactions est insuffisant. Si cette erreur est générée, Exchange Server ne peut pas créer de fichier du journal des transactions. Cela a pour effet de mettre hors ligne toutes les bases de données du groupe de stockage affecté parce que les mises à jour des bases de données doivent être enregistrées dans le journal des transactions.

Explication

Exchange Server intègre deux mécanismes permettant d'éviter le remplissage du lecteur du journal des transactions :

  • Enregistrement circulaire. Les journaux des transactions sont automatiquement supprimés une fois que le point de contrôle de base de données dépasse leur date de fin. L'espace disque utilisé pour les fichiers du journal des transactions reste généralement inférieur à 50 Mo. Pendant la sauvegarde, il est possible de suspendre la suppression des journaux des transactions jusqu'à ce que la sauvegarde soit terminée.

    Remarque :
    Par défaut, l'enregistrement circulaire n'est pas activé dans Microsoft Exchange 2000 Server et les versions ultérieures.
  • Sauvegarde du groupe de stockage. Exchange Server supprime les journaux superflus après exécution d'une sauvegarde en ligne complète ou incrémentielle de toutes les bases de données du groupe de stockage à l'aide d'une méthode de sauvegarde implémentant le service VSS (Volume Shadow Copy Service) ou des API de sauvegarde en ligne en continu pour Exchange Server.

Si l'enregistrement circulaire n'est pas activé et si l'une des conditions suivantes est vraie, le nombre de fichiers du journal des transactions augmente jusqu'à épuisement de l'espace disponible sur le disque dur :

  • Le programme de sauvegarde ne supprime pas les fichiers du journal des transactions.

  • Le programme de sauvegarde a cessé de s'exécuter.

  • Les fichiers du journal des transactions ne sont pas purgés à l'aide d'une autre méthode.

Il se peut que vous deviez supprimer manuellement des fichiers du journal des transactions si l'espace disque disponible devient insuffisant. Il se peut également que vous deviez supprimer manuellement des fichiers du journal des transactions si vous pensez manquer d'espace libre sur le disque dur avant d'exécuter une sauvegarde en ligne complète ou incrémentielle de toutes les bases de données d'un groupe de stockage particulier. Si vous supprimez des journaux dont la date de fin est postérieure à un point de contrôle de base de données et si la base de données est arrêtée de façon anormale, il n'est plus possible de remonter celle-ci tant que les journaux nécessaires ne sont pas restaurés. C'est pourquoi, vous devez déterminer les journaux que vous pouvez supprimer en toute sécurité avant de supprimer manuellement tout fichier du journal des transactions d'Exchange Server.

L'erreur peut également être signalée comme JET_errDiskFull ou à l'aide du code d'erreur 0xfffff8f0. Cette erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre l'erreur, sélectionnez l'une des solutions ci-dessous :

  • Exécutez l'outil de Gestion de la récupération de base de données. Dans Microsoft Exchange Server 2007, l'outil est répertorié parmi les outils de Récupération de base de données sous la Boîte à outils dans la console de gestion Exchange. L'outil Exchange Server Analyzer peut automatiquement déterminer les fichiers journaux que vous pouvez supprimer en toute sécurité et les copier dans un emplacement de sauvegarde pour vous. Il est fortement recommandé d'utiliser Exchange Server Analyzer pour déplacer les fichiers journaux.

    Remarque :
    Exchange Server Analyzer ne fonctionne pas dans Exchange 2007 si le groupe de stockage contenant la base de données est activé pour la réplication continue en cluster (CCR).
  • Consultez les valeurs État et Journal requis dans chaque en-tête de base de données pour identifier les fichiers du journal des transactions que vous pouvez supprimer en toute sécurité.

    Remarque :
    Dans cet article, la suppression d'un fichier du journal des transactions équivaut à déplacer un fichier du journal des transactions vers un autre emplacement où le fichier du journal des transactions peut être sauvegardé, stocké ou supprimé. L'action dépend de vos propres besoins. Dans cet article, la suppression d'un fichier du journal des transactions fait référence au type de suppression qui ne permet pas de sauvegarder ni de restaurer ce fichier du journal des transactions.

Suivez les étapes détaillées pour identifier les fichiers du journal des transactions que vous pouvez supprimer manuellement en toute sécurité.

Examen de l'en-tête de la base de données et suppression des fichiers journaux superflus

  1. Démontez la base de données dont vous voulez examiner l'en-tête.

  2. Cliquez sur Démarrer, sur Exécuter, puis tapez cmd pour ouvrir la fenêtre d'invite de commandes.

  3. À l'invite de commandes, accédez au chemin d'accès du répertoire dans lequel se trouve le fichier de base de données.

    Remarque :
    Dans Exchange 2000 Server et Exchange Server 2003, pour déterminer le chemin d'accès et le nom des fichiers .edb et .stm d'une base de données, utilisez le Gestionnaire système Exchange pour afficher l'onglet Base de données de la boîte de dialogue propriétés pour chaque objet de base de données. Dans Exchange Server 2007, pour déterminer le nom et le chemin d'accès du fichier de base de données, développez la console de gestion Exchange sous Configuration du serveur, cliquez sur Boîte aux lettres, puis sur l'onglet Gestion de la base de données.

  4. À l'invite de commandes, tapez la commande Eseutil suivante avec le commutateur /MH :

    Copier le code
    "eseutil /MH databasefilename.edb"
    Remarque :
    Dans la syntaxe, databasefilename est le nom de la base de données que vous voulez consulter.

  5. Consultez les valeurs État et Journal requis dans les informations d'en-tête qui s'affichent.

    La valeur État fournit les informations suivantes, qui indiquent si la base de données a été correctement détachée :

    • Si la base de données a été correctement détachée, la valeur État indique soit Arrêt correct, soit Cohérent. Cette valeur dépend de la version d'Exchange Server en cours d'exécution. Vous pouvez supprimer tous les fichiers du journal des transactions, à l'exception du fichier du journal des transactions actuel.

      Remarque :
      En supprimant le fichier journal actuel alors que toutes les bases de données sont en état Arrêt correct, vous réinitialisez la séquence des fichiers journaux. Cela n'empêche pas le démarrage des bases de données. Toutefois, une réinitialisation de la séquence des fichiers journaux affecte la possibilité de restaurer une base de données à partir d'une sauvegarde précédente si la situation de produit.
    • Si la base de données n'a pas été correctement détachée, la valeur État indique soit Arrêt incorrect, soit Incohérent. Identifiez les fichiers du journal des transactions qui peuvent être supprimés en consultant le champ Journal requis dans l'en-tête de base de données.

      Remarque :
      Si la base de données est dans un état Arrêt incorrect ou Incohérent, cela signifie que certains fichiers du journal des transactions existants contiennent des transactions en attente requises par la base de données. Si vous supprimez les fichiers du journal des transactions dans cette situation, il n'est pas possible de redémarrer la base de données à moins de la restaurer à partir d'une sauvegarde. De la même façon, vous pouvez réparer la base de données à l'aide de la commande Eseutil et de la commande Isinteg.
      Vous devez consulter les valeurs Journal requis pour chaque base de données du groupe de stockage avant de supprimer des journaux pour ce groupe de stockage.

      Le champ Journal requis indique la plage des fichiers journaux numérotés requis pour démarrer cette base de données. Si la plage est 0 - 0, aucun fichier journal n'est requis pour démarrer cette base de données. Cela indique que la base de données est dans l'état Arrêt correct ou Cohérent. Si certains fichiers journaux sont plus anciens que le journal de point de contrôle, vous pouvez les supprimer à l'exclusion du journal de point de contrôle.

      Si vous exécutez une version d'Exchange Server antérieure à Exchange Server 2003 Service Pack 1 (SP1), vous devez convertir la plage décimale figurant dans le champ Journal requis en valeurs hexadécimales. Par exemple, si la valeur Journal requis est 28217 - 28221, les fichiers journaux de 06E39 à 06E3D sont requis pour cette base de données. Dans Exchange 2003 SP1, le champ Journal requis a été étendu de façon à indiquer les valeurs décimales et hexadécimales.

      Remarque :
      Vous pouvez utiliser le mode scientifique de la Calculatrice de Windows pour opérer la conversion du format décimal au format hexadécimal. Démarrez la Calculatrice, puis, dans le menu Affichage, cliquez sur Scientifique. Entrez le nombre décimal, puis cliquez sur Hex.
      Comme vous pouvez avoir jusqu'à quatre groupes de stockage dans Exchange 2000 et Exchange 2003, chaque groupe ayant un ensemble particulier de fichiers journaux, le préfixe Edb ne figure pas dans les noms de fichier du journal des transactions. Dans Exchange 2000 et Exchange 2003, le préfixe Edb est remplacé par E00, E01, E02 ou E03. Pour un groupe de stockage de récupération, le préfixe Edb est remplacé par R00. Le préfixe du nom du fichier journal de groupe de stockage s'affiche dans le Gestionnaire système Exchange sous l'onglet Général de la boîte de dialogue des propriétés d'un objet groupe de stockage particulier. C'est pourquoi, si le préfixe du groupe de stockage est E01 et si l'entrée Journal requis indique 28217 - 28221 (0x06E39 - 0x06E3D), les fichiers réels requis vont de E0106E39.log à E0106E3D.log.

  6. Vous pouvez supprimer en toute sécurité tous les fichiers journaux numérotés dont la numérotation est inférieure à l'entrée dont la valeur est la plus basse dans un champ Journal requis pour toute base de données du groupe de stockage.

    Remarque :
    Songez à déplacer, non supprimer, les fichiers journaux.
    Remarque :
    Il est recommandé de ne pas supprimer le dernier fichier du journal des transactions. Il s'agit du fichier journal dont l'horodateur est le plus récent et dont le nom ne contient pas encore de numéro de séquence. Même si vous avez déterminé que vous pouvez supprimer ce fichier en toute sécurité, conservez-le pour éviter de remettre la séquence des fichiers journaux à 0. La remise à zéro de la séquence des fichiers journaux affecte les cycles de sauvegarde. Il se peut que vous ne puissiez pas restaurer la base de données à partir d'une sauvegarde effectuée avant la remise à zéro.


ESE 454 -515 : Fichier journal de transactions requis manquant
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil Microsoft® Exchange Server Analyzer Tool a trouvé un événement ESE 454 avec le code d'erreur -515. Cette erreur indique qu'il n'a pas été possible de monter la base de données Exchange parce qu'un fichier journal de transactions requis est manquant.

Explication

Un événement ESE 454 avec une erreur -515 peut se produire si l'ESE (Extensible Storage Engine) tente de mettre toutes les bases de données d'un groupe de stockage dans un état cohérent durant le processus de récupération. Si un fichier journal de transactions requis est manquant, le processus de récupération échoue, ainsi que le montage de la base de données, en générant l'erreur -515.

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • À l'aide des procédures décrites ici, déterminez les fichiers journaux de transactions qui manquent et leurs emplacements. Déplacez-les ensuite dans le répertoire du journal de transactions pour le groupe de stockage.

  • Restaurez la ou les bases de données affectées à partir de la sauvegarde.

Attention :
Il est déconseillé de tenter de restaurer la base de données à moins que la solution précédente de localisation et de restauration des fichiers journaux de transactions manquants spécifiques ait échoué. Une telle opération entraînerait la réécriture de toutes les données depuis la dernière sauvegarde.
Remarque :
Avant de restaurer la ou les bases de données, déplacez ou supprimez les fichiers journaux de transactions associés au groupe de stockage concerné du chemin de destination.
Identification de fichiers journaux de transactions manquants à l'aide de l'Assistant Dépannage de Microsoft Exchange dans Exchange Server 2003 et Exchange Server 2007

  1. Dans la fenêtre Afficher les résultats de l'examen du journal des événements de l'Assistant Dépannage de Microsoft Exchange, cliquez sur le lien Utilisez la tâche de gestion de la récupération de base de données associée pour vérifier et résoudre ce problème pour identifier les fichiers journaux de transactions obligatoires manquants.

  2. Enregistrez les noms de fichiers journaux indiqués à l'étape 1.

  3. Déterminez l'emplacement actuel des fichiers journaux et déplacez-les vers l'emplacement souhaité.
Remarque :
Veillez à effectuer une recherche dans la Corbeille et les dossiers de mise en quarantaine antivirus lorsque vous déterminez l'emplacement actuel des fichiers journaux de transactions manquants.
  1. Essayez de monter la base de données Exchange affectée.

 Identification et restauration manuelles des journaux de transactions manquants sur Exchange 2000 Server ou Exchange Server 2003

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, votre propre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre groupe de stockage, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Emplacement du journal des transactions, enregistrez le chemin d'accès de l'emplacement des fichiers journaux de transactions.

  4. À l'invite de commandes, ouvrez le répertoire dans lequel se trouve le fichier Eseutil.exe. Le chemin d'accès par défaut d'Eseutil.exe dans Exchange 2000 Server et Exchange Server 2003 est C:\program files\exchsrvr\bin.

  5. À l'invite de commandes, entrez la commande suivante :

    Copier le code
    eseutil /ml "logpath\logprefix"

    où logpath est le chemin d'accès des fichiers journaux de transactions enregistrés à l'étape 3 et logprefix le préfixe des fichiers journaux de transactions, généralement e00.

    Voici un exemple de cette commande utilisant les valeurs par défaut :

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. Les fichiers journaux de transactions manquants sont signalés dans l'un des deux formats suivants, selon le fichier journal manquant :

    • Fichier journal manquant : c:\program files\exchsrvr\mdbdata\E0002BE2.log

    • ERREUR : Fichiers journaux manquants. Le fichier journal est de la génération 11 235 (0x2BE3), alors que la génération prévue est 11 234 (0x2BE2).

    où 0x2BE2 est le fichier journal manquant, E0002BE2.log.

  7. Enregistrez les noms de fichiers journaux indiqués à l'étape 6.

  8. Déterminez l'emplacement actuel des fichiers journaux et déplacez-les vers l'emplacement souhaité de l'étape 3.
Remarque :
Veillez à effectuer une recherche dans la Corbeille et les dossiers de mise en quarantaine antivirus lorsque vous déterminez l'emplacement actuel des fichiers journaux de transactions manquants.
  1. Essayez de monter la base de données Exchange affectée.

 Identification et restauration manuelles des journaux de transactions manquants sur Exchange Server 2007

  1. Démarrez la console de gestion Exchange sur le serveur qui contient le groupe de stockage.

  2. Dans l'arborescence de la console, développez Configuration du serveur, puis cliquez sur Boîte aux lettres.

  3. Dans le volet Résultats, cliquez sur le serveur de boîtes aux lettres qui contient le groupe de stockage pour lequel vous voulez restaurer les fichiers journaux de transactions manquants.

  4. Cliquez avec le bouton droit sur votre groupe de stockage, puis cliquez sur Propriétés.

  5. . Sous l'onglet Général, sous Emplacement du journal, enregistrez le chemin d'accès de l'emplacement des fichiers journaux de transactions.

  6. À l'invite de commandes, ouvrez le répertoire dans lequel se trouve le fichier Eseutil.exe. Dans Exchange Server 2007, le fichier Eseutil se trouve dans le dossier d'installation par défaut d'Exchange. Il s'agit de <SystemDrive>:\Program Files\Microsoft\Exchange Server\Bin.

  7. À l'invite de commandes, entrez la commande suivante :

    Copier le code
    eseutil /ml "logpath\logprefix"

    où logpath est le chemin d'accès des fichiers journaux de transactions enregistrés à l'étape 5 et logprefix le préfixe des fichiers journaux de transactions, généralement e00.

    Voici un exemple de cette commande utilisant les valeurs par défaut :

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. Les fichiers journaux de transactions manquants sont signalés dans l'un des deux formats suivants, selon le fichier journal manquant :

    • Fichier journal manquant : c:\Program Files\Microsoft\Exchange Server\Bin\E000000049A.log

    • ERREUR : Fichiers journaux manquants. Le fichier journal est de la génération 11 235 (0x2BE3), alors que la génération prévue est 11 234 (0x2BE2).

    où 0x2BE2 est le fichier journal manquant, E0002BE2.log.

  9. Enregistrez les noms de fichiers journaux indiqués à l'étape 8.

  10. Déterminez l'emplacement actuel des fichiers journaux et déplacez-les vers l'emplacement souhaité de l'étape 5.
Remarque :
Veillez à effectuer une recherche dans la Corbeille et les dossiers de mise en quarantaine antivirus lorsque vous déterminez l'emplacement actuel des fichiers journaux de transactions manquants.
  1. Essayez de monter la base de données Exchange affectée.

Pour plus d'informations sur l'événement ESE 454, consultez la page du centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=81883).


ESE 455 -1811 (0xfffff8ed) : Fichier journal de transactions (Exx.log) actuel manquant
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-05-31

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements ESE 455 avec le code d'erreur -1811 (0xfffff8ed) dans le journal des applications. Cet événement indique que le journal des transactions actuel (exx.log) est manquant, inaccessible ou porte une signature incorrecte.

Explication

L'erreur peut être due à l'une des causes suivantes :

  • Erreur 1811 correspondant à JET_errFileNotFound. Ce problème peut se produire dans un fichier journal Exchange ayant une signature incorrecte et un numéro de génération de journal interne (LGeneration). Généralement, le fichier journal Exchange est le fichier E00.log. Si le fichier E00.log a une signature incorrecte, il se peut que le montage de la banque d'informations échoue même si la base de données est cohérente.

  • Un programme antivirus met en quarantaine ou supprime le fichier journal Exchange actuel.

  • La commande de réparation eseutil /p a été exécutée sur les bases de données affectées et les fichiers journaux ont été supprimés.

  • La commande de récupération eseutil /r a été exécutée avec un nom de base de fichier journal incorrect, comme dans l'exemple, eseutil /r Exx.log, où Exx.log est un nom de base de fichier journal de trois caractères.

Cette erreur peut également être représentée comme une erreur -1811, JET_errFileNotFound. Cette erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Si le fichier journal a une signature et un numéro de génération de journaux incorrects, contactez les services de support technique Microsoft. Pour plus d'informations, visitez la page de contact du site Web du centre de support Microsoft.

  • Si un antivirus met en quarantaine ou supprime le fichier journal Exchange actuel, procédez comme suit :

    • Vérifiez la configuration de l'antivirus.

    • Vérifiez que l'antivirus n'est pas configuré pour analyser les répertoires Exchange Server.

    • Par défaut, certains antivirus sont paramétrés pour analyser les lecteurs et répertoires sur une base hebdomadaire en mode manuel ou en mode automatique. Cette configuration peut facilement être ignorée. Assurez-vous d'ajouter les répertoires Exchange Server aux emplacements exclus pour l'antivirus. Pour plus d'informations sur la configuration des antivirus pour qu'ils fonctionnent avec Exchange, consultez l'article 823166 de la Base de connaissances Microsoft, Aperçu des logiciels antivirus utilisés avec Exchange Server 2003.

    • Consultez les fichiers journaux de l'antivirus pour vérifier que le fichier journal Exchange a été mis en quarantaine ou supprimé.

    Utilisez une des méthodes suivantes pour récupérer le fichier journal Exchange :

Méthode 1 : si le fichier journal Exchange a été mis en quarantaine

  1. Récupérez le journal Exchange dans le dossier contenant vos fichiers journaux de production.

  2. Démarrez le service de banque d'informations de Microsoft Exchange. S'il ne manque aucun autre fichier journal, la base de données est montée. S'il manque d'autres fichiers journaux, vérifiez si les fichiers manquants figurent dans le dossier de mise en quarantaine de l'antivirus. Si les fichiers journaux ne figurent pas dans le dossier de mise en quarantaine, voyez la méthode 2.

Si le fichier journal Exchange a été supprimé, vous devez restaurer la base de données du groupe de stockage à partir d'une sauvegarde. Vous devez ensuite procéder à la relecture des fichiers journaux. Pour restaurer une base de données disponible, procédez comme suit :

Méthode 2 : si le fichier journal Exchange a été supprimé

  1. Déplacez les bases de données incohérentes vers un dossier de sauvegarde.

  2. Si un fichier E00.log a été créé, déplacez-le vers le dossier de sauvegarde. Déplacez également le fichier E00.chk vers le dossier de sauvegarde.

  3. Copiez les fichiers journaux existants vers le dossier de sauvegarde.Remarque Vous devez copier les fichiers journaux. Vous ne devez pas les déplacer.

  4. Renommez le dernier fichier E00*.log en E00.log.

  5. Restaurez la base de données à partir d'une sauvegarde. Puis, relisez les fichiers journaux. Cela permet de rétablir la cohérence de la base de données. La base de données n'inclut pas toutefois le fichier E00.log copié vers le dossier de sauvegarde. Même si quelques données sont perdues, vous disposez désormais d'une base de données qu'il est possible de monter.

    Remarque :
    Si vous ne pouvez pas restaurer la base de données à partir d'une sauvegarde, exécutez les utilitaires de réparation sur la base de données pour en rétablir la cohérence.

  6. Démarrez le service de banque d'informations de Microsoft Exchange.

Si la commande de réparation eseutil /p a été exécutée sur les bases de données affectées et les fichiers journaux ont été supprimés, procédez comme suit :

Identification de l'exécution de la commande eseutil /p

  1. Cliquez sur Démarrer, puis sur Exécuter, tapez cmd, puis cliquez sur OK.

  2. Tapez la commande suivante à l'invite de commandes :

    Copier le code
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    La syntaxe ci-avant est basée sur les hypothèses suivantes :

    • Les fichiers du programme Exchange Server ont été installés dans le dossier c:\program files\exchsrvr.

    • Votre base de données se trouve dans le dossier c:\program files\exchsrvr\mdbdata.

  3. Lisez l'attribut de nombre de réparations. S'il est égal à 0 (zéro), la commande eseutil /p n'a pas été exécutée. Si l'attribut est un nombre autre que 0, la commande eseutil /p a été exécutée sur la base de données.

Si les bases de données privée et publique présentent un état cohérent ou d'arrêt correct, vous pouvez déplacer les fichiers journaux des transactions vers un autre dossier. Pour déterminer si les bases de données sont dans un état cohérent ou d'arrêt correct, procédez comme suit :

Identification de l'état cohérent ou d'arrêt correct des bases de données

  1. Cliquez sur Démarrer, puis sur Exécuter, tapez cmd, puis cliquez sur OK.

  2. Pour examiner la banque d'informations privée, tapez ce qui suit :

    Copier le code
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. Pour examiner la banque d'informations publique, tapez ce qui suit :

    Copier le code
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    La syntaxe décrite dans les étapes 2 et 3 est basée sur les hypothèses suivantes :

    • Les fichiers du programme Exchange Server ont été installés dans le dossier c:\program files\exchsrvr.

    • Votre base de données se trouve dans le dossier c:\program files\exchsrvr\mdbdata.

  4. Consultez les résultats de la vérification de cohérence. Si la base de données est cohérente (état = arrêt correct), tous les fichiers journaux ont été validés dans la banque d'informations. Si la base de données n'est pas cohérente (état = arrêt incorrect), il se peut que la base de données ne soit pas endommagée. Les fichiers journaux n'ont peut-être pas encore été validés dans la base de données.

  5. Si l'état indique un arrêt correct, déplacez les fichiers journaux des dossiers mdbdata vers un dossier de sauvegarde.

  6. Montez les bases de données.
  • Si la commande de récupération eseutil /r a été exécutée avec un nom de base de fichier journal incorrect, utilisez le commutateur approprié pour exécuter la commande. Les noms de base de fichier journal courants sont e00, e01, e02 et e03. Par exemple, la commande suivante contient un nom de base de fichier journal correct :

    Copier le code
    eseutil /r e00
  • Si le problème persiste, contactez les services de support technique Microsoft. Pour plus d'informations, visitez la page de contact du site Web du centre de support Microsoft.


ESE 474 -1018 : Erreur irrécupérable détectée dans la base de données
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-03-28

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements ESE 474 avec le code d'erreur -1018 dans le journal des applications. Cette erreur est générée si le composant de vérification d'intégrité de Microsoft Exchange détermine qu'Exchange Server ne peut pas stocker ou récupérer correctement des données de fichiers de base de données Exchange depuis le sous-système du disque dur.

Explication

Un événement ESE 474 avec une erreur -1018 se produit en raison d'un composant matériel du sous-système de disque dur défectueux ou de pilotes ou de microprogrammes obsolètes ou incompatibles dans le sous-système du disque dur.

Après avoir rencontré une erreur -1018, des tests matériels de diagnostic sont exécutés sur le serveur et peuvent ne rapporter aucun problème matériel de sous-système de disque dur et vous pouvez raisonnablement penser qu'Exchange Server est responsable de ce problème.

D'autres analyses réalisées par Microsoft et les fournisseurs de matériel ont déterminé que la plupart des erreurs -1018 étaient dues aux composants matériels du sous-système de disque dur, aux pilotes et aux microprogrammes.

Exchange fait état d'une erreur -1018 lorsqu'une page initialisée du fichier de base de données présente l'une des conditions suivantes :

  • Le total de contrôle stocké sur la page ne correspond pas au résultat du nouveau calcul du total de contrôle obtenu lors de la lecture de la page.

  • Le numéro de la page qui est stocké sur la page ne correspond pas à celui qui devrait y figurer étant donné l'emplacement physique de la page dans le fichier de base de données.

Exchange peut être responsable de la génération d'une erreur -1018 si l'un des scénarii suivants se produit :

  • Exchange construit une page dont le total de contrôle est erroné.

  • Exchange construit une page correctement mais indique au système d'exploitation un emplacement erroné pour l'écriture de la page.

Exchange génère un total de contrôle pour une page qui est sur le point d'être écrite sur disque, après que toutes les autres données sont écrites dans la page. Le numéro de la page en fait partie. Une fois le total de contrôle ajouté à la page par Exchange, Exchange demande au système d'exploitation Windows d'écrire la page sur disque à l'aide d'API Windows publiées, standard.

Des erreurs mémoire transitoire peuvent entrâiner l'écriture de la page au mauvais endroit sur le disque dur.

Même si le total de contrôle de la page est correct, Exchange fait état d'une erreur -1018 car le numéro logique de la page ne correspond pas au numéro physique de la page.

Une seule erreur -1018 rapportée dans une base de données Exchange ne provoque pas l'arrêt de la base de données Exchange ou ne produit pas d'autres symptômes que le signalement de l'erreur même. La page concernée peut se trouver dans un dossier auquel il est plus rarement fait accès, par exemple le dossier Éléments envoyés ou Éléments supprimés, ou bien encore dans une pièce jointe rarement ouverte, voire vide.

Bien qu'une seule erreur -1018 soit peu susceptible de provoquer des pertes de données importantes, ces erreurs n'en sont pas moins préoccupantes car elles sont la preuve que le système de stockage a échoué au moins une fois lors d'une opération de stockage ou de récupération de données. L'erreur -1018 est un signe avant-coureur d'un problème qui ira en s'aggravant. Même si la première erreur -1018 se situe sur une page vide de la base de données, vous n'avez aucun moyen de savoir quelle sera la prochaine page endommagée. Si une table globale critique est endommagée, la base de données Exchange peut ne pas démarrer et la réparation peut partiellement ou totalement échouer.

Une fois qu'une erreur -1018 a été enregistrée, vous pouvez vous attendre à une panne imminente ou à l'apparition de dégâts aléatoires supplémentaires sur la base de données et devez prendre des mesures préventives, jusqu'à ce que vous ayez identifié et supprimé l'origine du problème.

Action d'utilisateur

Avant que vous n'essayiez de corriger l'erreur ESE 474 -1018 enregistrée dans le journal des applications, assurez-vous que le sous-système de disque dur du serveur est stable.

Pour dépanner le sous-système de disque, procédez comme suit :

  1. Ouvrez le journal des applications et recherchez des événements ESE 474. Dans chaque événement, notez le chemin complet de la base de données touchée. Après avoir compilé une liste des bases de données touchées, notez les lettres de disque reprises dans les chemins de base de données. Ces informations vous permettent de cibler vos efforts de dépannage directement sur ces disques physiques.

  2. Consultez le journal système et assurez-vous qu'aucune erreur de lecture, d'écriture ou de délai d'attente n'est consignée.

  3. Employez les utilitaires de disgnostic du sous-système de disque fournis et contactez le fournisseur matériel du sous-système de disque pour obtenir de l'aide concernant la vérification de l'intégrité du sous-système de disque.

Si vous avez corrigé tous les problèmes du sous-système de disque ou vérifié sa stabilité, les méthodes suivantes vous permettent une récupération de l'erreur -1018. Ces méthodes sont répertoriées par ordre de préférence ou par utilité :

Première méthode Déplacez les boîtes aux lettres de la ou des bases de données répertoriées dans les évéments ESE 474 du journal des applications. Déplacez les boîtes aux lettres vers une ou plusieurs banques existantes et connues ou créez une ou plusieurs nouvelles banques de boîtes aux lettres à cet effet. Lorsque toutes les boîtes aux lettres ont été déplacées, supprimez la ou les banques de boîtes aux lettres endommagées.

Pour déplacer des boîtes aux lettres (Exchange 2000 Server ou Exchange Server 2003)

  1. Dans Utilisateurs et ordinateurs Active Directory, sélectionnez le ou les utilisateurs dont vous souhaitez déplacer la boîte aux lettres.

  2. Cliquez avec le bouton droit sur la liste d'utilisateurs sélectionnés à l'étape précédente, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, dans la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.
Pour déplacer des boîtes aux lettres (Exchange Server 2003 uniquement)

  1. Dans le Gestionnaire système Exchange, développez Serveurs, le serveur à partir duquel déplacer des boîtes aux lettres, le Groupe de stockage à partir duquel déplacer des boîtes aux lettres, la Banque de boîtes aux lettres contenant les boîtes aux lettres à déplacer, puis cliquez sur Boîtes aux lettres.

  2. Dans le volet d'informations, cliquez avec le bouton droit sur le ou les utilisateurs dont vous voulez déplacer les boîtes aux lettres, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, dans la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.
Pour déplacer des boîtes aux lettres à l'aide de la console de gestion d'Exchange pour Exchange Server 2007 uniquement

  1. Démarrez la console de gestion Exchange.

  2. Dans l'arborescence de la console, développez Configuration du destinataire, puis cliquez sur Boîte aux lettres.

  3. Dans le volet Résultats, cliquez sur les boîtes aux lettres que vous voulez déplacer.

  4. Dans le volet Actions, cliquez sur Déplacer une boîte aux lettres.

  5. Dans l'Assistant Déplacer une boîte aux lettres, dans la page Introduction, sélectionnez le serveur, le groupe de stockage et la base de données de boîtes aux lettres vers lesquels vous voulez déplacer la boîte aux lettres, puis cliquez sur Suivant.

  6. Dans la page Options de déplacement, sélectionnez une option pour la gestion des messages endommagés dans une boîte aux lettres, puis cliquez sur Suivant.

  7. Dans la page Déplacer un planning, spécifiez le moment où le déplacement doit se produire, puis cliquez sur Suivant.

  8. Dans la page Déplacer une boîte aux lettres, consultez la liste récapitulative pour confirmer les déplacements de boîtes aux lettres, puis cliquez sur Déplacer.

  9. Dans la page Achèvement, cliquez sur Terminer.

Pour plus d'informations sur les scénarii pris en charge pour l'utilisation de l'Assistant Déplacer une boîte aux lettres et de la cmdlet Move-Mailbox, voir la rubrique sur le déplacement des boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=85754) dans la documentation sur le produit Exchange Server 2007.

Deuxième méthode Restaurez la ou les bases de données à partir d'une sauvegarde connue. Pour plus d'informations sur la procédure de restauration de bases de données Exchange Server, voir les articles suivants :

  • rubrique sur la récupération d'urgence d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=85802) ;

  • Guide des opérations de récupération d'urgence d'Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=30250).

Troisième méthode Eseutil permet une réparation matérielle de la ou des bases de données affectées. Cette méthode ne doit être utilisée que si les deux méthodes précédentes ont échoué. Après une réparation matérielle, vous devez également réaliser une défragmentation hors ligne de la base de données réparée et exécuter l'outil Isinteg pour réparer la défaillance logique. Ces étapes peuvent être réalisées à l'aide de la tâche de réparation de l'outil de dépannage de base de données Exchange. Elle exécute automatiquement les régimes Eseutil /P, Eseutil /D et Isinteg.

Pour plus d'informations

Pour plus d'informations sur ce problème, voir les articles suivants de la Base de connaissances Microsoft et les ressources Exchange :

  • 314917 sur la compréhension et l'analyse des erreurs de base de données Exchange -1018, -1019 et -1022 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917) ;

  • 867626 sur un nouveau code de correction d'erreur fourni avec Exchange Server 2003 SP1 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626) ;

  • 259851 sur les ramifications de l'exécution de la commande eseutil /p ou edbutil /d /r dans Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851) ;

  • sur l'erreur -1018 dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=85807).


MSExchangeIS 1003 : Espace disque libre insuffisant restant sur le lecteur de la base de données Exchange
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-22

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 1003 dans le journal des applications. Cette erreur peut se produire en cas d'insuffisance du volume d'espace disque libre sur le lecteur contenant les bases de données que vous tentez de monter.

Explication

Lorsque l'espace disponible sur le disque contenant les bases de données Exchange est saturé, le service Banque d'informations Microsoft Exchange consigne un événement MSExchangeIS 1003 et les bases de données affectées sont démontées. Si cela se produit, il se peut que vous ne puissiez pas monter les bases de données pour le groupe de stockage concerné. Cette erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, libérez de l'espace disque sur le lecteur de base de données, puis réessayez de monter les bases de données. Pour ce faire, effectuez une ou plusieurs des opérations suivantes :

  • Si les fichiers de base de données Exchange sont les seuls fichiers se trouvant sur le disque dur, il se peut que vous deviez faire une défragmentation en mode hors connexion des bases de données afin de libérer de l'espace disque.

    Remarque :
    Selon la quantité d'espace libre disponible dans la base de données, il se peut que cette opération ne résolve pas le problème.
    Pour plus d'informations sur l'exécution de cette opération, consultez l'article 328804 de la Base de connaissances Microsoft sur la procédure de défragmentation de bases de données Exchange.

    Consultez également la rubrique sur l'exécution de la commande Eseutil /D (défragmentation).

  • Si les fichiers journaux de transactions d'Exchange ne se trouvent pas sur ce lecteur, vous pouvez peut-être libérer de l'espace disque en supprimant les fichiers journaux superflus.

    Pour plus d'informations sur l'exécution de cette opération, consultez l'article 240145 de la Base de connaissances Microsoft sur la procédure de suppression de fichiers journaux de transactions d'Exchange Server.


MSExchangeIS 1088 : Impossible de monter la base de données en raison d'un legacyExchangeDN incorrect
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un événement MSExchangeIS 1088. Cet événement indique qu'il n'a pas été possible de monter la base de données Exchange parce qu'elle a une valeur d'attribut legacyExchangeDN différente de ce qui est stocké dans Active Directory.

Explication

Un événement MSExchangeIS 1088 peut se produire si une base de données Exchange est restaurée sur un groupe d'administration dont l'attribut legacyExchangeDN a une valeur différente de celle du groupe d'administration original. Ce comportement est conforme à la conception de l'application. Pour pouvoir monter des banques d'informations sur un serveur Exchange, il faut que la valeur de l'attribut legacyExchangeDN de l'organisation et du groupe d'administration des bases de données Exchange corresponde à la valeur de l'attribut legacyExchangeDN de l'organisation et du groupe d'administration dans Active Directory.

Action d'utilisateur

Pour résoudre ce problème, procédez comme suit :

  • Restaurez la base de données Exchange dans son groupe d'administration original.

  • S'il n'est pas possible de restaurer la base de données Exchange dans son groupe d'administration original, renommez les objets Active Directory de la destination voulue de façon à ce que leur attribut legacyExchangeDN ait la même valeur que la base de données Exchange. Vous pouvez corriger la valeur à l'aide d'un outil, tel qu'ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez les attributs d'objets Active Directory de manière incorrecte lorsque vous utilisez ADSI Edit, l'outil LDP ou un autre client LDAP version 3, vous vous exposez à des problèmes graves. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Modifiez des attributs d'objets Active Directory à votre propre risque.
Correction de cette erreur

  1. Si vous utilisez ADSI Edit ou un outil similaire, recherchez l'objet de groupe d'administration dans Active Directory.

    L'attribut legacyExchangeDN peut se trouver dans :

    CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Organisation, CN=Groupes_administration, CN=Groupe_administration

  2. Tapez une nouvelle valeur de chaîne du formulaire :

    /o= organisation /ou= groupe d'administration

Pour plus d'informations sur l'utilisation de l'outil LDP, consultez l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objet Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation d'ADSI Edit, consultez la rubrique « Adsiedit.msc : ADSI Edit » dans l'aide de Windows Server 2003.

Pour plus d'informations sur l'événement MSExchangeIS 1088, consultez les ressources suivantes :

  • Centre des événements et des messages d'erreur

  • Article 280652 de la Base de connaissances Microsoft, « XADM : L'ID d'événement 1088 est journalisé et le montage de la banque d'informations échoue » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652)


MSExchangeIS 5000 (0x3f5) : Compte de service non valide configuré pour le service Banque d'informations
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-02-27

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 5000 avec le code d'erreur 0x3f5 dans le journal des applications. Cette erreur se produit si le service Banque d'informations Microsoft Exchange est configuré pour démarrer avec un compte autre que Système local.

Explication

Ce problème peut se produire si le service Banque d'informations Microsoft Exchange (Store.exe) utilise un compte autre que celui du système local ou si le contrôleur de domaine, le domaine ou la stratégie de sécurité de l'ordinateur local n'inclut pas le compte de service local dans la stratégie de génération des audits de sécurité. Lorsque ce problème se produit, l'initialisation du service Banque d'informations Exchange échoue. L'erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Par défaut, le service Banque d'informations Exchange utilise le compte Système local pour démarrer le service Banque d'informations (MACHINENAME$). Utilisez le composant logiciel enfichable Services.msc pour contrôler le compte utilisé pour démarrer le service Banque d'informations. Si le compte est le compte Système local, vous devez octroyer au compte Système local le droit Générer des audits de sécurité. Pour ce faire, utilisez l'une des méthodes suivantes :

    • Exécutez de nouveau la commande /domainprep du programme d'installation d'Exchange sur cet ordinateur.

    • Octroyez manuellement au compte Système local le droit Générer des audits de sécurité sur l'une des stratégies suivantes :

    1. Stratégie du contrôleur de domaine

    2. Stratégie de domaine

    3. Stratégie de sécurité de l'ordinateur local

      Pour ré-octroyer ce droit à la stratégie de sécurité de l'ordinateur local d'un serveur membre, procédez comme suit :

      Remarque :
      Cette solution est recommandée si ce problème ne se produit que sur un seul serveur.
      Nouvel octroi d'un droit d'audit à la stratégie de sécurité de l'ordinateur local d'un serveur membre

      1. Cliquez sur Démarrer, Outils d'administration, puis sur Stratégie de sécurité locale.

      2. Développez Paramètres de sécurité, cliquez sur Stratégies locales, puis cliquez sur Attribution des droits utilisateur.

      3. Dans le volet de droite, double-cliquez sur Générer des audits de sécurité, cliquez sur Ajouter, entrez MACHINENAME$, puis cliquez deux fois sur OK.

      4. Fermez le composant logiciel enfichable Stratégie de groupe.
  • Si vous démarrez le service Banque d'informations à l'aide d'un compte autre que le compte Système local, vous devez le remodifier en compte Système local (MACHINENAME$). Ensuite, tentez de démarrer le service Banque d'informations. Pour plus d'informations sur la raison pour laquelle Exchange 2000 Server et Exchange Server 2003 utilisent le compte Système local pour démarrer les services Exchange, consultez l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem.

Pour plus d'informations

Pour plus d'informations, consultez l'article 281850 de la Base de connaissances Microsoft sur le fait que la banque d'informations ne démarre pas avec les messages d'ID d'événement 9530 et 5000 dans Exchange 2000 Server et Exchange Server 2003.


MSExchangeIS 5000 (0x80004005) : Impossible de monter la base de données en raison d'un compte de service incorrect ou d'autorisations SeSecurityPrivilege manquantes ou d'appartenance au groupe incorrecte
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-02-19

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 5000 avec le code d'erreur 0x80004005 dans le journal des applications. L'événement indique qu'une ou plusieurs bases de données sur le serveur Exchange ne peuvent pas être montées en raison d'un compte de service incorrect, d'autorisations SeSecurityPrivilege manquantes ou d'une appartenance au groupe incorrecte.

Explication

L'événement peut se produire si l'une des conditions suivantes est vraie :

  • Le droit Gestion des journaux d'audit et de sécurité (SeSecurityPrivilege) est supprimé du groupe Serveurs d'entreprise Exchange sur un ou plusieurs contrôleurs de domaine. Le groupe Serveurs d'entreprise Exchange doit disposer du droit Gestion des journaux d'audit et de sécurité sur tous les contrôleurs de domaine dans le domaine. Si cette condition est vraie, un ou plusieurs services d'Exchange Server ne démarrent pas.

  • Le service Banque d'informations Microsoft Exchange démarre avec un compte autre que celui du système local ou bien, si le contrôleur de domaine, le domaine ou la stratégie de sécurité de l'ordinateur local n'inclut pas le compte de service local dans la stratégie de génération des audits de sécurité. Si cette condition est vraie, le service Banque d'informations Exchange ne démarre pas.

  • Le groupe Serveurs d'entreprise Exchange du domaine parent ne contient pas le groupe Serveurs de domaine Exchange du domaine enfant.

L'événement peut également être identifié comme MAPI_E_CALL_FAILED. L'événement s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Si l'autorisation Gestion des journaux d'audit et de sécurité (SeSecurityPrivilege) est supprimée du groupe Serveurs d'entreprise Exchange sur un ou plusieurs contrôleurs de domaine, procédez comme suit :

    Ajout d'autorisations à un ou plusieurs contrôleurs de domaine

    1. Utilisez l'utilitaire Policytest.exe pour résoudre les problèmes liés aux autorisations. Ce dernier se trouve dans le dossier Support\Utils\I386 sur le CD Exchange 2000 Server, ou dans le dossier Support\ExDeploy sur le CD Exchange Server 2003. L'utilitaire Policytest.exe permet de déterminer si l'autorisation « Gestion des journaux d'audit et de sécurité » pour le groupe Serveurs d'entreprise Exchange est manquante pour un contrôleur de domaine. En cas de résultat positif, des informations semblables à celles qui suivent sont retournées :

      Le domaine local est "<contoso.com>" (contoso) Le compte est "CONTOSO\Exchange Enterprise Servers" DC = "<nom_ordinateur>" Dans le site = "<nom_premier_site_par_défaut>" Droit trouvé : "SeSecurityPrivilege"

      Remarque Un résultat positif indique que l'autorisation « Gestion des journaux d'audit et de sécurité » existe. Vous devez disposer des droits d'administrateur de domaine pour exécuter l'utilitaire Policytest.exe. Pour plus d'informations sur l'utilitaire Policytest.exe, consultez l'article 281537 de la Base de connaissances Microsoft, XADM : description de l'utilitaire Policytest.exe.

    2. Réinitialisez les autorisations par défaut du groupe Serveurs d'entreprise Exchange au niveau du domaine. Pour ce faire, procédez comme suit :

      1. Exécutez la commande setup /domainprep depuis le CD Exchange Server ou un point d'installation réseau. La commande setup /domainprep ajoute le groupe Serveurs d'entreprise Exchange au domaine disposant des autorisations par défaut. Lorsque vous exécutez la commande setup /domainprep, les autorisations sont immédiatement ajoutées à un contrôleur de domaine. Puis la modification est appliquée aux autres contrôleurs de domaine.

      2. Restaurez l'héritage des autorisations sur les autres unités d'organisation. Puis, attendez que les contrôleurs de domaine procèdent à la réplication des modifications dans le domaine.

      3. Exécutez l'utilitaire Policytest.exe. Notez les contrôleurs de domaine qui renvoient le résultat positif suivant :

        Droit trouvé : "SeSecurityPrivilege"

        Si tous les contrôleurs de domaine ont les autorisations correctes, redémarrez les services Exchange Server. Si aucun contrôleur de domaine n'a les autorisations correctes, passez à l'étape 3.

    3. Vérifiez la stratégie des contrôleurs de domaine par défaut. Pour ce faire, procédez comme suit :

      1. Démarrez le composant logiciel enfichable Utilisateurs et ordinateurs Active Directory.

      2. Cliquez avec le bouton droit sur le conteneur Contrôleurs de domaine, puis cliquez sur Propriétés.

      3. Cliquez sur l'onglet Stratégie de groupe, puis vérifiez que la stratégie des contrôleurs de domaine par défaut est répertoriée dans la zone Liaisons d'objet de stratégie de groupe. Remarque Si la stratégie des contrôleurs de domaine par défaut n'est pas répertoriée, cliquez sur Ajouter, Stratégie des contrôleurs de domaine par défaut, puis sur OK. Puis attendez que la modification soit appliquée aux autres contrôleurs de domaine.

      4. Exécutez la commande setup /domainprep depuis le CD Exchange Server ou un point d'installation réseau. La commande setup /domainprep ajoute le groupe Serveurs d'entreprise Exchange au domaine disposant des autorisations par défaut.

      5. Exécutez l'utilitaire Policytest.exe. Notez les contrôleurs de domaine qui renvoient le résultat positif suivant :

      Droit trouvé : "SeSecurityPrivilege"

      Si tous les contrôleurs de domaine ont les autorisations correctes, redémarrez les services Exchange Server. Si aucun contrôleur de domaine n'a les autorisations correctes, passez à l'étape 4.

    4. Ajoutez manuellement les autorisations au contrôleur de domaine. Il se peut que le service de réplication de fichiers ne réplique pas la stratégie de sécurité mise à jour sur un ou plusieurs contrôleurs de domaine après l'exécution de la commande setup /domainprep. Si ce problème survient, vous devez affecter manuellement les autorisations correctes au groupe Serveurs d'entreprise Exchange. Si certains contrôleurs de domaine ou tous les contrôleurs de domaine n'ont pas les autorisations correctes, affectez l'autorisation « Gestion des journaux d'audit et de sécurité » au groupe Serveurs d'entreprise Exchange. Puis attendez que la configuration soit appliquée aux autres contrôleurs de domaine. Pour ce faire, procédez comme suit :

      1. Démarrez le composant logiciel enfichable Utilisateurs et ordinateurs Active Directory.

      2. Cliquez avec le bouton droit sur le conteneur Contrôleurs de domaine, puis cliquez sur Propriétés.

      3. Cliquez sur l'onglet Stratégie de groupe, cliquez sur Stratégie des contrôleurs de domaine par défaut dans la zone Liaisons d'objet de stratégie de groupe, puis sur Modifier.

      4. Développez Configuration ordinateur, Paramètres Windows, Paramètres de sécurité, Stratégies locales, puis cliquez sur Attribution des droits d'utilisateur.

      5. Dans le volet droit, double-cliquez sur Gestion des journaux d'audit et de sécurité, cliquez sur Ajouter, Parcourir, puis ajoutez le groupe Serveurs d'entreprise Exchange.

      6. Dans la boîte de dialogue Ajouter un groupe ou un utilisateur, cliquez sur OK. Cliquez à nouveau sur OK.

      7. Quittez le composant logiciel enfichable Stratégie de groupe, puis cliquez sur OK dans la boîte de dialogue des propriétés des contrôleurs de domaine. Remarque Il peut arriver que le groupe Serveurs d'entreprise Exchange ne soit pas visible lorsque vous cliquez sur Parcourir dans la boîte de dialogue Ajouter un groupe ou un utilisateur. Si c'est le cas, ajoutez le groupe Serveurs de domaine Exchange. Puis exécutez à nouveau la commande setup /domainprep. Ce processus permet d'ajouter le groupe Serveurs d'entreprise Exchange à tous les contrôleurs de domaine.
  • Si le service Banque d'informations Exchange démarre avec un compte autre que celui du système local ou bien, si le contrôleur de domaine, le domaine ou la stratégie de sécurité de l'ordinateur local n'inclut pas le compte de service local dans la stratégie de génération des audits de sécurité, suivez la résolution indiquée ci-après :

    Par défaut, le service Banque d'informations Exchange utilise le compte Système local pour démarrer le service Banque d'informations (MACHINENAME$). Utilisez le composant logiciel enfichable Services.msc pour contrôler le compte utilisé pour démarrer le service Banque d'informations. Si le compte est le compte Système local, vous devez octroyer à nouveau au compte Système local le droit Générer des audits de sécurité. Pour ce faire, utilisez l'une des méthodes suivantes :

    Nouvel octroi du droit Générer des audits de sécurité au compte Système local

    1. Exécutez de nouveau la commande Setup /domainprep d'Exchange sur cet ordinateur.

    2. Octroyez manuellement au compte Système local le droit Générer des audits de sécurité sur l'une des stratégies suivantes :

      • Stratégie du contrôleur de domaine

      • Stratégie de domaine

      • Stratégie de sécurité de l'ordinateur local

    Nouvel octroi du droit Générer des audits de sécurité à la stratégie de sécurité de l'ordinateur local d'un serveur membre

    1. Cliquez sur Démarrer, Outils d'administration, puis sur Stratégie de sécurité locale.

    2. Développez Paramètres de sécurité, cliquez sur Stratégies locales, puis sur Attribution des droits utilisateur.

    3. Dans le volet droit, double-cliquez sur Générer des audits de sécurité, cliquez sur Ajouter, entrez MACHINENAME$, puis cliquez deux fois sur OK.

    4. Quittez le composant logiciel enfichable Stratégie de groupe.
    Si vous démarrez le service Banque d'informations à l'aide d'un compte autre que le compte Système local, vous devez le remodifier en compte Système local (MACHINENAME$). Ensuite, tentez de démarrer le service Banque d'informations. Pour plus d'informations sur la raison pour laquelle Exchange 2000 Server et Exchange Server 2003 utilisent le compte Système local pour démarrer les services Exchange, consultez l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem.

  • Si le groupe Serveurs d'entreprise Exchange du domaine parent ne contient pas le groupe Serveurs de domaine Exchange du domaine enfant, ajoutez le groupe Serveurs de domaine Exchange du domaine enfant au groupe Serveurs d'entreprise Exchange dans le domaine parent. Vous pouvez également résoudre ce problème en créant le service de mise à jour de destinataire dans le domaine racine.

    Pour résoudre ce problème, exécutez le programme d'installation d'Exchange avec le commutateur /domainprep sur un serveur dans le domaine Windows distant. Puis, sur le serveur Exchange, utilisez le Gestionnaire système Exchange pour créer un service de mise à jour de destinataire pour le domaine distant. Pour ce faire, procédez comme suit :

    Création d'une instance du service de mise à jour de destinataire pour le domaine distant

    1. Cliquez sur Démarrer, Programmes, Microsoft Exchange, puis Gestionnaire système.

    2. Développez l'objet Organisation, puis le conteneur Destinataires.

    3. Cliquez sur Service de mise à jour de destinataire.

    4. Dans le volet droit, cliquez avec le bouton droit sur Nouveau, puis cliquez sur Service de mise à jour de destinataire.

    5. Cliquez sur le domaine sans instance du service de mise à jour de destinataire et disposant d'utilisateurs devant être mis à jour par Exchange.

    6. Cliquez sur Suivant.

    7. Sélectionnez le serveur sur lequel vous voulez exécuter le service de mise à jour de destinataire et traitez tous les utilisateurs requis avec les attributs Exchange.

    8. Cliquez sur Suivant.

    9. Cliquez sur Terminer.

    10. Pour lancer manuellement une mise à jour des destinataires dans ce domaine, cliquez avec le bouton droit sur Service de mise à jour de destinataire, puis cliquez sur Mettre à jour pour forcer la mise à jour.
    Pour plus d'informations, consultez l'article 253770 de la Base de connaissances Microsoft sur les tâches effectuées par le service de mise à jour de destinataire d'Exchange.


MSExchangeIS 5000 (0x80040154) : Extensions de service SMTP manquantes ou endommagées
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-02-19

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 5000 avec le code d'erreur 0x80040154 dans le journal des applications. Cette erreur peut se produire si des extensions du service SMTP (Simple Mail Transfer Protocol) d'Exchange Server sont manquantes ou endommagées.

Explication

Ce problème survient car les extensions du service SMTP d'Exchange sont manquantes ou endommagées. Ce comportement entraîne une perte de fonctionnalités entre Exchange et le service SMTP. Le service SMTP est un service nécessaire qui est installé comme sous-composant des Services Internet (IIS) de Microsoft.

L'erreur peut se produire pour l'une des raisons suivantes :

  • Les Services Internet (IIS) ont été supprimés.

  • Le sous-composant service SMTP a été supprimé des Services Internet (IIS).

  • Les Services Internet (IIS) on été supprimés, puis réinstallés comme composant Windows n'ayant pas le sous-composant service SMTP requis.

  • Les Services Internet (IIS) on été supprimés, puis réinstallés comme composant Windows ayant la liste appropriée de sous-composants. Toutefois, les extensions du service SMTP d'Exchange n'ont pas été réinstallées.

Cette erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre cette erreur, consultez l'article 326305 de la Base de connaissances Microsoft sur le non-démarrage de la banque d'informations et les messages d'ID d'événement 5000 et 9538 de MSExchangeIS dans Exchange 2000 Server and Exchange Server 2003.

Restauration des extensions du service SMTP

  1. Vérifiez que les extensions du service SMTP d'Exchange sont manquantes. Pour ce faire, procédez comme suit :

    1. Connectez-vous à l'ordinateur exécutant Microsoft Exchange à l'aide d'un compte qui dispose des informations d'administration.

    2. Cliquez sur Démarrer, sur Exécuter, tapez cmd, puis cliquez sur OK.

    3. Tapez telnet 127.0.0.1 25 à l'invite de commandes pour afficher l'entrée « 220 server.domain.com Microsoft ESMTP Mail Service ».

    4. Tapez EHLO, puis appuyez sur Entrée pour afficher une liste de 250 verbes de commande. S'il n'y a aucun verbe dont le nom commence par « X », les extensions du service SMTP sont manquantes.

  2. Effectuez une sauvegarde complète de la partition système. Incluez la date système et les fichiers de base de données Exchange. Pour plus d'informations sur la manière de procéder, consultez l'article 258243 de la base de connaissances Microsoft sur la sauvegarde et la restauration d'un ordinateur Exchange à l'aide de l'utilitaire de sauvegarde Windows.

  3. Vérifiez qu'IIS a été correctement réinstallé pour inclure les sous-composants dépendants d'Exchange requis.

    IIS 6.0

    1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur Ajout/Suppression de programmes.

    3. Dans le volet gauche, cliquez sur Ajouter ou supprimer des composants Windows.

    4. Dans l'Assistant Composants Windows, localisez Serveur d'applications dans la liste de composants, puis cliquez sur Détails.

    5. Si les composants suivants ne sont pas installés, procédez à leur installation :

      ASP.NET

      Activer l'accès COM+ réseau

      Services IIS (Internet Information Services)

    6. Cliquez sur Services Internet (IIS), puis sur Détails.

    7. Si les composants suivants ne sont pas installés, procédez à leur installation :

      Fichiers communs

      Gestionnaire des services Internet

      Service NNTP

      Service SMTP

      Service World Wide Web

    8. Cliquez deux fois sur OK. Dans la page principale des composants Windows, cliquez sur Suivant, puis sur Terminer.

    IIS 5.0

    1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur Ajout/Suppression de programmes.

    3. Dans le volet gauche, cliquez sur Ajouter ou supprimer des composants Windows.

    4. Dans la boîte de dialogue Composants Windows, localisez les services Internet (IIS) dans la liste des composants. Si la case à cocher Services Internet (IIS) est activée, les services Internet sont installés. Pour afficher les sous-composants IIS installés, cliquez sur Services Internet (IIS), puis sur Détails.

    5. Si les services Internet ne sont pas installés, cliquez pour activer la case à cocher Services Internet (IIS), puis cliquez sur Détails. Installez les sous-composants IIS 5.0, puis cliquez sur OK. Les composants IIS 5.0 minimum requis avant l'installation d'Exchange 2000 sont les suivants :

      Fichiers communs

      Composant logiciel enfichable Services Internet

      Service SMTP

      service NNTP (Network News Transfer Protocol Service) (pour les groupes de discussion)

      Service World Wide Web

    6. Cliquez sur Suivant, puis sur Terminer.

  4. Restaurez les extensions du service SMTP d'Exchange.

    Exchange Server 2003

    Si vous réinstallez Exchange 2003 sur une installation Exchange 2003 existante, les fichiers de base de données et les autorisations restent inchangés. Pour ce faire, procédez comme suit :

    1. Insérez le CD Exchange 2003.

    2. Dans le dossier \SETUP\I386, double-cliquez sur le fichier Setup.exe.

    3. Dans la page d'accueil, cliquez sur Suivant jusqu'à accéder à la page Sélection des composants.

    4. Dans la page Sélection des composants, cliquez sur Réinstaller dans la colonne Action, puis cliquez sur Suivant.

    5. Vérifiez la sélection dans la page Résumé de l'installation, puis cliquez sur Suivant pour poursuivre l'installation d'Exchange 2003.

    Exchange 2000 Server

    Les méthodes permettant de restaurer les extensions du service SMTP d'Exchange 2000 dépendent du nombre de sous-composants IIS supprimés. Si le service SMTP est le seul sous-composant IIS supprimé et qu'Exchange 2000 Server Service Pack 2 (SP2) ou une version ultérieure a été installée, utilisez l'utilitaire de ligne de commande Smtpreinstall.exe. Ce dernier est accessible dans le dossier Server\Support\Utils\I386.

    Utilisation de l'utilitaire Smtpreinstall.exe

    1. Copiez le fichier Smtpreinstall.exe dans le dossier \Exchsrvr\Bin.

    2. À l'invite de commandes, accédez au dossier Exchsrvr\Bin, puis tapez la commande suivante :

      smtpreinstall.exe

    3. Redémarrez l'ordinateur lorsque vous y êtes invité.

    Si IIS 5.0 a été supprimé comme composant ou si plusieurs sous-composants du service SMTP ont été supprimés d'IIS 5.0, réinstallez Exchange 2000 sur l'installation existante dans le cadre du programme d'installation intégré de Microsoft Small Business Server 2000.

    Réinstallation d'Exchange 2000 Server

    Remarque :
    Si vous réinstallez Exchange 2000 sur une installation Exchange 2000 existante, les fichiers de base de données et les autorisations restent inchangés.
    1. Insérez le CD Exchange 2000 Server.

    2. Dans le dossier \SETUP\I386, double-cliquez sur le fichier Setup.exe.

    3. Dans la page Bienvenue, cliquez sur Suivant.

    4. Entrez la clé de CD si vous y êtes invité, puis cliquez sur Suivant.

    5. Dans la page Sélection des composants, cliquez sur Réinstaller dans la colonne Action, puis cliquez sur Suivant.

    6. Vérifiez la sélection dans la page Résumé de l'installation, puis cliquez sur Suivant pour poursuivre l'installation d'Exchange 2000.

  5. Réinstallez les Service Packs et les correctifs d'Exchange.

    Pour plus d'informations, consultez les articles suivants de la Base de connaissances Microsoft :

    836993 Comment faire pour obtenir les dernières mises à jour et les derniers Service Packs de Microsoft Exchange Server 2003.

    301378 Comment obtenir le dernier Service Pack d'Exchange 2000 Server.


MSExchangeIS 5000 (0xc004038a) : Impossible de monter la base de données en raison d'autorisations incorrectes ou de la suppression d'un groupe de routage
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-05-31

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 5000 avec le code d'erreur 0xc004038a dans le journal des applications. Si cette erreur se produit, le service Banque d'informations Microsoft Exchange ne s'initialise pas et les bases de données ne sont pas montées.

Explication

L'événement MSExchangeIS 5000 avec le code d'erreur 0xc004038a peut se produire en raison d'autorisations incorrectes ou de la suppression d'un groupe de routage. Cet événement peut se produire pour une ou plusieurs des raisons suivantes :

  • Le serveur Exchange n'est plus membre d'un groupe de routage ou son groupe de routage a été supprimé d'Active Directory.

  • Le groupe Serveurs de domaine Exchange ne dispose pas des autorisations appropriées dans Active Directory.

Cet événement s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Si le groupe Serveurs de domaine Exchange ne dispose pas des autorisations appropriées, servez-vous de l'utilitaire ADSI (Active Directory Service Interfaces) Edit pour vérifier que le groupe Serveurs de domaine Exchange dispose des autorisations appropriées dans Active Directory. Assurez-vous que la case à cocher Permettre aux autorisations héritées du parent de se propager à cet objet est activée sous l'onglet Sécurité du groupe Administrateurs, du groupe Serveurs de domaine Exchange et de tout autre groupe concernant votre configuration.

    Remarque :
    S'il le faut, forcez la réplication parmi les contrôleurs de domaine pour être certain que les modifications seront répercutées dans tout le domaine.
    Remarque :
    L'outil ADSI Edit fait partie des outils de support de Microsoft Windows 2000 et de Microsoft Windows Server 2003 disponibles sur les CD d'installation de Windows 2000 et de Windows 2003.
  • Si le serveur Exchange n'est plus membre d'un groupe de routage ou si son groupe de routage a été supprimé d'Active Directory, ajoutez ou restaurez le groupe de routage. Utilisez les procédures de résolution suivantes pour le problème correspondant à votre scénario :

Résolution 1 : ajoutez le serveur au groupe de routage. Vérifiez que le serveur n'est plus membre du groupe de routage en procédant comme suit :

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Organisation, Groupes d'administration, nom_groupe_administration, puis Groupes de routage.

    Remarque :
    Dans cette étape, nom_groupe_administration correspond au nom du groupe d'administration.
  3. Passez en revue les groupes de routage disponibles et vérifiez que ce serveur n'est pas répertorié.

    Remarque :
    Si aucun groupe de routage n'est visible, consultez la résolution 2.
  4. Une fois que vous avez vérifié que le serveur n'est pas membre d'un groupe de routage, ajoutez le serveur à un groupe de routage existant. Pour ce faire, procédez comme suit :

    Important :
    Si vous utilisez le composant logiciel enfichable ADSI Edit, l'utilitaire LDAP ou tout autre client LDAP version 3 et ne modifiez pas correctement les attributs d'objet Active Directory, des problèmes graves peuvent survenir. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 ou encore de Windows et Exchange. Microsoft ne peut pas garantir la résolution des problèmes qui surviennent à la suite d'une modification incorrecte des attributs d'objet Active Directory. La modification de ces attributs relève de votre responsabilité.
Ajout du serveur au groupe de routage

  1. Cliquez sur Démarrer, puis Exécuter, tapez adsiedit.msc, puis cliquez sur OK.

    Remarque :
    L'outil ADSI Edit fait partie des outils de support de Microsoft Windows 2000 et de Microsoft Windows Server 2003. Pour installer ces outils de support, procédez comme suit :
    • Pour les ordinateurs Windows 2000 Server, double-cliquez sur Setup.exe dans le dossier Support\Tools sur le CD Windows 2000, puis effectuez les étapes de l'Assistant Installation des outils de support Windows pour procéder à l'installation des outils de support Windows 2000.

    • Pour les ordinateurs Windows Server 2003, cliquez avec le bouton droit sur Suptools.msi dans le dossier Support\Tools sur le CD-ROM Windows Server 2003, cliquez sur Installer, puis effectuez les étapes de l'Assistant Installation des outils de support Windows pour procéder à leur installation.

  2. Développez Configuration [nom_serveur.nom_domaine.com], développez CN=Configuration, DC=nom_domaine, DC= com, développez CN=Services, développez CN=Microsoft Exchange, développez CN=nom_organisation, développez CN=Groupes d'administration, développez CN=nom_groupe_administration, puis cliquez sur CN=Groupes de routage.

    Remarque :
    Dans cette étape, nom_serveur correspond au nom du serveur, nom_domaine.com au nom du domaine, nom_organisation au nom de l'organisation Exchange Server et nom_groupe_administration au nom du groupe d'administration.

  3. Cliquez avec le bouton droit sur le groupe de routage dont vous voulez que le serveur devienne membre, puis cliquez sur Propriétés.

  4. Cliquez sur l'attribut distinguishedName, puis sur Modifier.

  5. Copiez la valeur de l'attribut distinguishedName dans le Bloc-notes.

  6. Cliquez deux fois sur Annuler pour fermer les propriétés.

  7. Dans l'outil ADSI Edit, développez Configuration [nom_serveur.nom_domaine.com], développez CN=Configuration, DC=nom_domaine, DC= com, développez CN=Services, développez CN=Microsoft Exchange, développez CN=nom_organisation, développez CN=Groupes d'administration, développez CN=nom_groupe_administration, puis développez CN=Serveurs.

  8. Cliquez avec le bouton droit sur nom_serveur, puis cliquez sur Propriétés.

  9. Cliquez sur l'attribut msExchHomeRoutingGroup, puis sur Modifier.

  10. Collez la valeur copiée dans le Bloc-notes lors de l'étape 5, puis cliquez deux fois sur OK pour enregistrer la nouvelle valeur.

  11. Dans le Gestionnaire système Exchange, localisez le groupe de routage auquel vous avez ajouté ce serveur.

  12. Actualisez le Gestionnaire système Exchange pour afficher ce serveur.

    Remarque :
    Si le serveur Exchange n'apparaît pas immédiatement, attendez la fin de la réplication d'Active Directory.

  13. Si le type de serveur Maître n'est défini pour aucun autre serveur Exchange dans ce groupe de routage, cliquez avec le bouton droit sur le serveur Exchange, puis cliquez sur Définir comme maître.

  14. Démarrez le service Banque d'informations et le service Piles MTA.

Résolution 2 : restaurez le groupe de routage. Si vous avez supprimé un groupe de routage par inadvertance, restaurez-le à l'aide de la dernière sauvegarde des données sur l'état du système. Si vous ne disposez pas d'une sauvegarde récente des données sur l'état du système et avez plusieurs contrôleurs de domaine, effectuez une opération de restauration faisant autorité du groupe de routage supprimé.

Restauration du groupe de routage

  1. Démarrez le Gestionnaire système Exchange, puis créez un groupe de routage doté du même nom que le groupe de routage supprimé. Pour ce faire, procédez comme suit :

    1. Développez Groupes d'administration, nom_groupe_administration, puis Groupes de routage.

      Dans cette étape, nom_groupe_administration correspond au nom du groupe d'administration.

    2. Cliquez avec le bouton droit sur Groupes de routage, pointez sur Nouveau, puis cliquez sur Groupe de routage.

    3. Dans la zone Nom, tapez le nom du groupe de routage, puis cliquez sur OK.

      Utilisez le même nom que celui du groupe de routage supprimé par inadvertance.

    4. Quittez le Gestionnaire système Exchange.

  2. Lancez ADSI Edit. Pour ce faire, cliquez sur Démarrer, Exécuter, tapez adsiedit.msc dans la zone Ouvrir, puis cliquez sur OK.

    Remarque :
    L'outil ADSI Edit fait partie des outils de support de Microsoft Windows 2000 et de Microsoft Windows Server 2003. Pour installer ces outils de support :
    • Pour les ordinateurs Windows 2000 Server, double-cliquez sur Setup.exe dans le dossier Support\Tools sur le CD Windows 2000, puis effectuez les étapes de l'Assistant Installation des outils de support Windows pour procéder à l'installation des outils de support Windows 2000.

    • Pour les ordinateurs Windows Server 2003, cliquez avec le bouton droit sur Suptools.msi dans le dossier Support\Tools sur le CD-ROM Windows Server 2003, cliquez sur Installer, puis effectuez les étapes de l'Assistant Installation des outils de support Windows pour procéder à leur installation.

  3. Développez Configuration [nom_serveur.nom_domaine.com], développez CN=Configuration, DC=nom_domaine, DC= com, développez CN=Services, développez CN=Microsoft Exchange, développez CN=nom_organisation, développez CN=Groupes d'administration, développez CN=nom_groupe_administration, puis cliquez sur CN=Groupes de routage.

    Dans cette étape, nom_serveur correspond au nom du serveur, nom_domaine.com au nom du domaine, nom_organisation au nom de l'organisation Exchange Server et nom_groupe_administration au nom du groupe d'administration.

  4. Dans le volet droit, cliquez avec le bouton droit sur le groupe de routage que vous avez créé, puis cliquez sur Propriétés.

  5. Cliquez pour activer les cases à cocher Afficher les attributs obligatoires et Afficher les attributs facultatifs si elles sont désactivées.

  6. Dans la liste Attributs, cliquez sur msExchRoutingGroupMembersBL, puis sur Modifier.

    La liste Valeurs est vide.

  7. Cliquez sur Annuler.

  8. Dans la liste Attributs, double-cliquez sur distinguishedName.

  9. Cliquez avec le bouton droit sur le nom unique dans la zone Valeur, puis cliquez sur Copier.

  10. Démarrez un éditeur de texte tel que le Bloc-notes, puis cliquez sur Coller dans le menu Edition pour coller le nom unique.

  11. Dans la boîte de dialogue Éditeur d'attributs de chaîne, cliquez sur Annuler, puis sur Annuler pour fermer la boîte de dialogue CN=nom_groupe_routage.

    Dans cette étape, nom_groupe_routage correspond au nom du groupe de routage.

  12. Dans ADSI Edit, sous CN=nom_groupe_administration, cliquez sur CN=Serveurs.

  13. Dans le volet droit, cliquez avec le bouton droit sur CN=nom_serveur, puis cliquez sur Propriétés.

    Dans cette étape, nom_serveur correspond à l'un des ordinateurs Exchange dans ce groupe de routage.

  14. Dans la liste Attributs, cliquez sur msExchHomeRoutingGroup, puis sur Modifier.

  15. Dans la zone Valeur, collez le nom unique copié lors des étapes 9 et 10, puis cliquez sur OK.

  16. Cliquez sur Appliquer, puis sur OK.

  17. Répétez les étapes 13 à 15 pour chaque serveur membre du groupe de routage supprimé par inadvertance.

  18. Sous CN=nom_groupe_administration, cliquez sur CN=Groupes de routage.

  19. Dans le volet droit, cliquez avec le bouton droit sur le groupe de routage que vous avez créé, puis cliquez sur Propriétés.

  20. Dans la liste Attributs, cliquez sur msExchRoutingGroupMembersBL, puis sur Modifier.

    La liste Valeurs n'est plus vide.

  21. Cliquez fois deux sur Annuler.

  22. Quittez ADSI Edit.

  23. Définissez le maître de groupe de routage à l'aide du Gestionnaire système Exchange. Pour ce faire, procédez comme suit :

    1. Démarrez le Gestionnaire système Exchange.

    2. Développez Groupes d'administration, nom_groupe_administration, puis Groupes de routage.

    3. Développez le groupe de routage que vous avez créé, puis cliquez sur Membres.

    4. Dans le volet droit, cliquez avec le bouton droit sur l'ordinateur Exchange que vous souhaitez configurer comme maître de groupe de routage et cliquez sur Définir un maître.

    5. Quittez le Gestionnaire système Exchange.

  24. Attendez que les modifications soient appliquées dans tout le domaine.

  25. Démarrez les services Microsoft Exchange arrêtés.


MSExchangeIS 5000 (0x8004010f) : Impossible de monter la base de données en raison d'autorisations d'accès incorrectes ou de caractères non valides dans le nom d'organisation
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 5000 avec le code d'erreur 0x8004010f dans le journal des applications. L'événement indique qu'une ou plusieurs bases de données sur le serveur Exchange ne peuvent pas être montées en raison d'autorisations incorrectes ou de caractères non valides dans le nom d'organisation Exchange.

Explication

L'événement MSExchangeIS 5000 avec le code d'erreur 0x8004010f peut se produire si l'une des conditions suivantes est vraie :

  • Les utilisateurs authentifiés n'ont pas d'accès en lecture aux conteneurs Domaine ou Configuration dans Active Directory. Si cette condition est vraie, si vous tentez d'installer un second serveur Exchange dans un groupe d'administration contenant déjà un serveur Exchange, il se peut que vous ne puissiez pas effectuer l'installation du second serveur. En outre, le service Banque d'informations Microsoft Exchange risque de ne pas démarrer.

  • L'autorisation d'accès en lecture pour le compte Tout le monde est absente du conteneur Entités de sécurité reconnues sous le conteneur Configuration dans Active Directory. Si cette condition est vraie, le service Banque d'informations Exchange ne démarre pas sur un serveur membre.

  • Le nom d'organisation Exchange contient des caractères non pris en charge. Si cette condition est vraie, après que vous avez installé Exchange 2000 Server ou Exchange Server 2003, le service Banque d'informations Exchange risque de ne pas démarrer et il se peut que vous découvriez que des événements MSExchangeIS 5000 et MSExchangeIS 1121 sont consignés dans le journal des applications.

L'événement peut également être identifié comme MAPI_E_NOT_FOUND. L'événement s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

Important :
Si vous utilisez le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'utilitaire LDP ou tout autre client LDAP version 3 et ne modifiez pas correctement les attributs d'objets Active Directory, des problèmes graves peuvent survenir. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows® 2000 Server, Microsoft Windows Server™ 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 ou encore de Windows et Exchange. Microsoft ne peut pas garantir la résolution des problèmes qui surviennent à la suite d'une modification incorrecte des attributs d'objets Active Directory. La modification de ces attributs relève de votre responsabilité.
  • Si des utilisateurs authentifiés n'ont pas d'accès en lecture aux conteneurs Domaine ou Configuration dans Active Directory, utilisez l'outil ADSI Edit d'Exchange Server 2003 et d'Exchange 2000 Server pour donner aux utilisateurs authentifiés un accès en lecture au conteneur Domaine et au conteneur Configuration dans Active Directory. Procédez comme suit :

    Remarque :
    L'outil ADSI Edit fait partie des outils de support de Microsoft Windows 2000 et de Microsoft Windows Server 2003. Pour installer les outils de support de Windows, exécutez le programme d'installation figurant dans le dossier Support\Tools sur le CD de Windows. Pour plus d'informations sur les outils de support de Windows, lisez le fichier Sreadme.doc dans le dossier Support\Tools sur le CD de Windows.
Octroi aux utilisateurs authentifiés d'un accès en lecture aux conteneurs Domaine ou Configuration dans Active Directory

  1. Cliquez sur Démarrer, puis Exécuter, tapez adsiedit.msc, puis cliquez sur OK.

  2. Développez le conteneur Domaine NC, cliquez avec le bouton droit sur le dossier du domaine (DC=domain,DC=com), puis cliquez sur Propriétés pour ouvrir les propriétés du domaine.

  3. Cliquez sur l'onglet Sécurité, puis assurez-vous que l'accès Lecture est activé pour le groupe Utilisateurs authentifiés dans la colonne Autoriser. Si Lecture n'est pas activé, cliquez pour activer Lecture, puis cliquez sur OK.

  4. Développez le Conteneur de configuration, cliquez avec le bouton droit sur le dossier de configuration (CN=Configuration,DC=domain,DC=com), puis cliquez sur Propriétés pour ouvrir les propriétés du dossier.

  5. Cliquez sur l'onglet Sécurité, puis assurez-vous que l'accès Lecture est activé pour le groupe Utilisateurs authentifiés dans la colonne Autoriser. Si Lecture n'est pas activé, cliquez pour activer Lecture, puis cliquez sur OK.

  6. Quittez ADSI Edit.

  7. Attendez que le changement soit répercuté dans les contrôleurs de domaine.

  8. Démarrez le service Banque d'informations.
  • Si l'autorisation d'accès en lecture pour le compte Tout le monde est absente du conteneur Entités de sécurité reconnues sous le conteneur Configuration dans Active Directory, procédez comme suit pour résoudre le problème :

Octroi de l'autorisation d'accès en lecture au compte Tout le monde dans le conteneur Entités de sécurité reconnues dans Active Directory

  1. Ouvrez une session en tant qu'administrateur de domaine, puis démarrez ADSI Edit.

  2. Développez le conteneur Configuration, puis cliquez sur le conteneur CN=WellKnown Security Principals.

  3. Cliquez avec le bouton droit sur Propriétés, puis localisez l'onglet Sécurité.

  4. Cliquez sur Ajouter, tapez tout le monde, puis cliquez sur OK.

  5. Dans la colonne Autoriser, activez la case à cocher Lecture.
  • Si le nom d'organisation Exchange contient des caractères non valides, supprimez-les. Pour plus d'informations sur les caractères non valides, consultez l'article 329599 de la Base de connaissances Microsoft concernant le non-démarrage de la banque d'informations Exchange et la journalisation des événements 1121 et 5000.


MSExchangeIS 9518 (0xfffffddc) : Dépassement du nombre maximal de fichiers journaux de transactions disponibles pour ce groupe de stockage
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-22

L'outil de dépannage de base de données de Microsoft® Exchange Server a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffffddc dans le journal des applications. Cela indique que le nombre maximal des fichiers journaux de transactions disponibles pour ce groupe de stockage a été dépassé.

Explication

Un événement MSExchangeIS 9518 avec le code d'erreur 0xfffffddc est journalisé en cas de tentative de montage des bases de données d'un groupe de stockage et si les deux conditions suivantes sont vraies :

  • Le nombre maximal des fichiers journaux de transactions disponibles pour ce groupe de stockage a été dépassé.

  • Toutes les bases de données de ce groupe de stockage sont en état d'arrêt correct.

En outre, un événement MSExchangeIS 1159 avec le code d'erreur 0xfffffdf9 aurait dû être journalisé dans le journal des applications avant l'arrêt des bases de données affectées. Cet événement indique qu'Exchange Server a utilisé tous les fichiers journaux de transactions disponibles pour ce groupe de stockage. Une fois le dernier journal des transactions rempli, toutes les bases de données de ce groupe de stockage sont démontées et leur redémarrage est impossible.

Exchange utilise des fichiers journaux de transactions numérotés de manière séquentielle. Dans Exchange 2000 Server et Exchange Server 2003, la numérotation des fichiers journaux de transactions commence par Exx00001.log, avec une incrémentation séquentielle jusqu'à ExxFFFF0.log. Le nombre maximal de fichiers journaux de transactions qui peuvent être générés en une seule séquence est 1 048 560 (0xFFFF0). En règle générale, il faut plusieurs années de fonctionnement avant qu'autant de fichiers journaux soient générés.

Dans Exchange Server 2007, la taille des fichiers journaux de transactions est plus importante. Il ne peut pas y avoir plus de 2 147 483 647 fichiers journaux dans une séquence de journaux (0x7FFFFFFF en hexadécimal, parce que les noms des fichiers journaux sont hexadécimaux). Les fichiers journaux de transactions ont une taille de 1 Mo. Il est improbable que cette erreur se produise dans Exchange Server 2007.

Action d'utilisateur

Pour résoudre l'erreur, vous devez supprimer tous les fichiers journaux de transactions et réinitialiser la séquence des fichiers journaux de transactions à 1. Une fois la séquence des fichiers journaux réinitialisée, le nom de fichier journal est Exx00001.log dans Exchange Server 2003 ou les versions antérieures et Exx00000001.log dans Exchange Server 2007.

Pour exécuter cette opération, utilisez la tâche Réinitialiser le numéro de génération de journaux dans l'outil de gestion de la récupération de base de données intégré dans l'Assistant Dépannage de Microsoft Exchange. L'outil vérifie que toutes les bases de données ont été correctement arrêtées, puis déplace en toute sécurité les fichiers journaux de transactions vers un emplacement de sauvegarde.

Remarque :
Il est également possible de supprimer les fichiers journaux de transactions manuellement. Toutefois, une suppression manuelle peut avoir pour effet qu'une base de données du groupe de stockage ne s'arrête pas correctement et qu'il ne soit plus possible de la remonter. Pour éviter ce genre d'échec, il est recommandé d'utiliser l'outil de gestion de la récupération de base de données.

Pour plus d'informations et pour télécharger l'outil, consultez la page Web relative à l'Assistant Dépannage de Microsoft Exchange v1.0.


MSExchangeIS 9518 0xfffffbc4 : le chemin du fichier journal est déjà utilisé
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-05-14

L'utilitaire de dépannage de base de données Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffffbc4 dans le journal des applications. Ce code d'erreur indique qu'un ou que plusieurs groupes de stockage sont configurés de manière à utiliser le même chemin de fichier journal ou système.

Explication

Cette erreur peut survenir si plusieurs groupes de stockage ont été configurés pour utiliser le même chemin de fichiers journaux et système. Exchange nécessite que chaque groupe de stockage possède un chemin unique pour les fichiers journaux et système.

Action d'utilisateur

Pour résoudre ce problème, assurez-vous que chaque groupe de stockage est configuré à l'aide d'un chemin de fichiers journaux et système unique.

Remarque :
Un groupe de stockage discret peut partager le même chemin de fichiers journaux et système. Mais le même chemin ne peut pas être utilisé pour les fichiers journaux et système pour un autre groupe de stockage.
Pour vérifier ou définir le chemin des fichiers journaux et système dans Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, votre propre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre groupe de stockage, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Emplacement du journal des transactions, cliquez sur Parcourir.

  4. Vérifiez que le chemin des fichiers journaux et le chemin des fichiers système sont uniques pour le groupe de stockage.

  5. Si ce n'est pas le cas, entrez le chemin d'un nouvel emplacment pour les fichiers journaux et/ou système et cliquez sur OK.

  6. Cliquez sur OK.
Pour vérifier ou définir le chemin des fichiers journaux et système pour un groupe de stockage dans Exchange Server 2007

  1. Ouvrez la console de gestion Exchange.

  2. Développez Configuration du serveur, puis mettez en surbrillance Boîte aux lettres.

  3. Dans le volet Boîte aux lettres, sélectionnez le serveur avec lequel vous voulez travailler.

  4. Dans le volet Gestion de la base de données, cliquez avec le bouton droit sur le groupe de stockage à utiliser et sélectionnez Propriétés.

  5. Vérifiez que le chemin des fichiers journaux et le chemin des fichiers système sont uniques pour le groupe de stockage.

  6. Sinon, suivez les instructions de la documentation sur Exchange Server 2007 dans la rubrique sur la procédure de définition ou de modification de l'emplacement des fichiers journaux du groupe de stockage (http://go.microsoft.com/fwlink/?LinkId=80702) pour définir les chemins de fichiers sur un emplacement unique pour chaque groupe de stockage.

Pour plus d'informations sur la procédure de déplacement de fichiers journaux dans Exchange Server 2003, voir l'article 821915 de la Base de connaissances Microsoft sur la procédure de déplacement des fichiers journaux ou de bases de données Exchange dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Pour plus d'informations sur la procédure de déplacement de fichiers journaux dans Exchange 2000 Server, voir l'article 239944 de la Base de connaissances Microsoft sur la procédure de déplacement des fichiers journaux de transactions ou des fichiers journaux système dans un autre emplacement (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944).


MSExchangeIS 9518 (0xfffff745) : Impossible de créer des fichiers TMP ou d'y accéder
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffff745 dans le journal des applications. Cette erreur se produit si Exchange ne peut pas créer de fichiers ni accéder aux fichiers dans les dossiers spécifiés dans les variables d'environnement système TMP ou TEMP.

Explication

Ce problème peut se produire si l'une des conditions suivantes est vraie :

  • Le chemin d'accès des variables d'environnement TMP ou TEMP est indisponible ou en lecture seule. Par exemple, ce problème se produit si la variable d'environnement TMP est mappée sur un lecteur distant ou un réseau SAN qui n'est plus disponible.

  • Le paramètre de Registre de la variable d'environnement TMP ou TEMP est incorrect.

  • Exchange ne dispose pas des autorisations de contrôle complètes de la racine du lecteur jusqu'aux journaux des transactions et aux bases de données.

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

Remarque Comme il existe plusieurs versions de Microsoft Windows, il se peut que les étapes suivantes diffèrent sur votre ordinateur. Si c'est le cas, consultez la documentation produit pour savoir comment exécuter ces étapes.

  • Vérifiez que les variables d'environnement TMP et TEMP pointent sur un emplacement correct dans Windows. Pour ce faire, procédez comme suit :

    Définition d'un chemin d'accès correct pour les variables Temp et TMP

    1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur Système, cliquez sur l'onglet Avancé, puis sur Variables d'environnement.

    3. Sous Variables système, cliquez sur TEMP, puis sur Edition.

    4. Si aucun chemin d'accès correct ne figure dans la zone Valeur de la variable, tapez un chemin d'accès correct pour la variable TEMP, puis cliquez sur OK. Par exemple, tapez %systemroot%\Temp, puis cliquez sur OK.

    5. Sous Variables système, cliquez sur TMP, puis sur Edition.

    6. Si aucun chemin d'accès correct ne figure dans la zone Valeur de la variable, tapez un chemin d'accès correct pour la variable TMP, puis cliquez sur OK. Par exemple, tapez %systemroot%\Temp, puis cliquez sur OK.

    7. Cliquez deux fois sur OK pour fermer la boîte de dialogue Propriété système.

    8. Redémarrez l'ordinateur.
  • Vérifiez et affectez le groupe Administrateurs local ou les autorisations de contrôle total du compte SYSTEM au dossier Temp. Il ne suffit pas d'affecter des autorisations de contrôle total au groupe Administrateurs de domaine. Par défaut, le chemin d'accès suivant est spécifié pour les variables d'environnement système TMP et TEMP :

    %SYSTEMROOT%\Temp

    Exchange doit accéder à cet emplacement de dossier à l'aide du compte SYSTEM. Pour afficher ces autorisations, procédez comme suit :

    Vérification des autorisations d'accès au dossier Temp

    1. Cliquez avec le bouton droit sur Démarrer, puis cliquez sur Explorer.

    2. Cliquez avec le bouton droit sur le dossier Temp spécifié dans la variable d'environnement, puis cliquez sur Propriétés. La valeur par défaut est généralement %systemroot%\Temp.

    3. Cliquez sur l'onglet Sécurité.

    4. Dans la liste Nom, cliquez sur SYSTEM, puis affichez les autorisations affectées répertoriées dans la liste Autorisations.
    Si les autorisations d'accès au dossier TMP sont correctes, vérifiez les autorisations sur chaque lecteur contenant les fichiers de base de données ou les fichiers journaux d'Exchange. Le compte SYSTEM doit disposer des autorisations de contrôle total sur la racine du lecteur et sur chaque dossier contenant des fichiers de base de données Exchange ou les fichiers journaux de transactions d'Exchange. Par exemple, si des journaux de transactions se trouvent dans le dossier C:\Exchsrvr\Mdbdata, le compte SYSTEM doit avoir des autorisations de contrôle total sur le répertoire racine du lecteur C, le dossier Exchsrvr et le dossier Mdbdata.

  • Vérifiez si le problème est dû à des paramètres de Registre incorrects. Procédez comme suit :

    Vérification des paramètres de Registre

    1. Cliquez sur Démarrer, sur Exécuter, tapez Regedt32.exe, puis cliquez sur OK.

    2. Localisez la clé de Registre suivante :

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. Localisez le nom TMP (ou TEMP). Cette clé doit être du type REG_EXPAND_SZ.

    4. Si l'une des clés est incorrecte, sauvegardez la sous-clé Environment, puis supprimez la valeur TMP ou TEMP à droite.

    5. Cliquez sur Démarrer, Exécuter, tapez Sysdm.cpl, puis cliquez sur OK.

    6. Sous l'onglet Avancé, cliquez sur Variables d'environnement.

    7. Dans la liste Variables système, vérifiez que les valeurs que vous avez supprimées à l'étape 4 ne figurent pas dans la liste.

      Remarque :
      Il se peut que vous deviez faire défiler la liste pour afficher les variables TEMP ou TMP.

    8. Cliquez sur Nouveau. Dans la zone Nom de variable, tapez les noms que vous avez supprimés à l'étape 4. Par exemple, tapez C:\Winnt\TEMP.

    9. Cliquez trois fois sur OK, puis redémarrez l'ordinateur.


MSExchangeIS 9518 (0xfffffd9a) : Fichier de point de contrôle manquant avec plus de 1008 fichiers journaux de transactions existants
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffffd9a dans le journal des applications. Cette erreur indique que le fichier de point de contrôle (Exx.chk) pour ce groupe de stockage est manquant ou a été supprimé, et que plus de 1008 fichiers journaux de transactions doivent être lus dans la base de données.

Explication

Ce problème peut se produire si les conditions suivantes sont vraies :

  • Les fichiers journaux et les bases de données sont arrêtés correctement. Il n'y a donc pas d'incident nécessitant une récupération.

  • Vous renommez ou supprimez le fichier de point de contrôle Exx.chk.

  • Il y a plus de 1008 fichiers journaux entre les points de contrôle à relire sur le serveur.

  • Dans une récupération par progression, une ou plusieurs bases de données dans le groupe de stockage sont perdues mais les fichiers journaux restent intacts sur le serveur au moment de la récupération. L'opération de récupération par progression n'est pas exécutée avec succès.

Dans cette situation, le service Banque d'informations Microsoft Exchange effectue une récupération logicielle et relit tous les fichiers journaux au démarrage. Comme les fichiers journaux et les bases de données ont été arrêtés correctement, il n'y a aucune récupération à effectuer. Comme il n'y a pas de point de contrôle, Exchange traite tous les journaux jusqu'à atteindre un enregistrement d'arrêt correct. Comme il y a plus de 1008 fichiers journaux, Exchange atteint la limite de 1008 fichiers journaux avant de pouvoir localiser l'enregistrement d'un état d'arrêt correct.

Remarque :
Les symptômes décrits peuvent également se produire si les conditions répertoriées précédemment sont vraies, et vous relisez les fichiers journaux à l'aide de la commande eseutil /r. La commande eseutil /r effectue également une récupération logicielle de la banque de boîtes aux lettres.

Cette erreur peut également être représentée comme une erreur JET_errCheckpointDepthTooDeep, -614. Cette erreur s'applique uniquement à Microsoft Exchange Server 2003.

Action d'utilisateur

Pour résoudre ce problème dans Exchange Server 2003, appliquez le correctif prescrit dans l'article 836611 de la Base de connaissances Microsoft sur le fait que les bases de données de banque d'informations ne sont pas montées et un message d'erreur indique que l'opération s'est terminée avec l'erreur -614 lorsque vous démarrez un ordinateur exécutant Exchange Server 2003.


MSExchangeIS 9518 0xfffffb40 : fichier de base de données manquant
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-05-23

L'utilitaire de dépannage de base de données Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffffb40 dans le journal des applications. Ceci indique qu'un ou plusieurs fichiers de base de données du groupe de stockage sont manquants.

Explication

Cette erreur peut se produire lorsque le moteur de stockage extensible (ESE) tente de mettre toutes les bases de données d'un groupe de stockage dans un état cohérent lors de la récupération, mais détecte que des fichiers de base de données sont manquants ou ont été remplacés par différentes versions.

Si un fichier de base de données du groupe de stockage est manquant ou a été remplacé par différentes versions, le moteur ESE renvoie l'erreur -1216, abandonne la récupération et ne démarre pas le groupe de stockage.

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Première méthode : Si le fichier de base de données manquant a été déplacé ou renommé, recherchez les événements ESE 494 dans le journal des applications qui se sont produits après la tentative de montage de la base de données. Pour chaque événement, notez le fichier de base de données spécifique manquant, recherchez-en l'emplacement et déplacez-le au bon emplacement.

Remarque :
Si le logiciel antivirus au niveau du fichier est installé sur ce serveur et si les exclusions n'ont pas été configurées correctement, il est possible que la base de données ait été supprimée ou mise en quarantaine par le logiciel antivirus. Veillez à contrôler la quarantaine antivirus et le fichier journal de suppression pour voir si c'est le cas.
  • Deuxième méthode :

    • Deuxième méthode A : Si le fichier de base de données manquant a été supprimé ou perdu, restaurez le fichier à partir d'une sauvegarde du groupe de stockage de production. Vous pouvez utiliser la tâche Vérifier les fichiers de base de données et les fichiers du journal des transactions de l'outil Gestion de la récupération de bases de données Exchange pour vérifier que le fichier de base de données restauré est disponible pour la restauration.

      Alors que vous restaurez ce fichier de base de données, vous pouvez également monter et accéder aux autres bases de données intactes dans un groupe de stockage à l'aide de la procédure suivante :

Pour autoriser l'accès à des boîtes aux lettres d'utilisateur sur des bases de données intactes

  1. Exécutez eseutil /R /L <chemin des fichiers journaux> /S <Path to System Files> Log Base Name /I (où Nom de base de fichier journal correspond aux trois premiers caractères des fichiers journaux pour ce groupe de stockage, par exemple E00, E01, etc.). Cela permet au moteur ESE de mettre les fichiers de base de données présents dans un état cohérent tout en ignorant les fichiers de base de données manquants. Après l'exécution de cette commande, les fichiers de base de données manquants devront être restaurés à partir de la sauvegarde.
Remarque :
Les commutateurs /L et /S sont facultatifs et ne doivent pas être utilisés si eseutil est exécuté au même emplacement que les fichiers journaux et système.
  1. Montez les fichiers de base de données présents et cohérents dans le groupe de stockage.

  2. Les utilisateurs dont les boîtes aux lettres sont hébergées par la base de données montée ont désormais accès à leur courrier.
  • Deuxième méthode B : Restaurez le fichier de base de données à partir de la sauvegarde dans un groupe de stockage de récupération. Vous pouvez utiliser immédiatement la fonction d'envoi et de réception en lançant le plus vite possible une nouvelle base de données (récupération avec base de données temporaire). Les clients voient une boîte aux lettres vide mais peuvent envoyer et recevoir du courrier plus rapidement que s'ils devaient attendre la fin de la restauration ou de la réparation.

Remarque :
Cette option nécessite la fusion éventuelle des nouvelles données avec les données restaurées.

Pour plus d'informations sur la récupération avec base de données temporaire, voir la section sur la portabilité de tonalité dans la rubrique sur la récupération d'urgence dans la documentation sur le produit Exchange 2007.

Pour plus d'informations sur les groupes de stockage de récupération, voir la section sur la présentagtion des groupes de stockage de récupération dans la rubrique sur la récupération d'urgence de la documentation sur le produit Exchange 2007.
  • Troisième méthode : Si une réparation matérielle a été réalisée manuellement ou à partir de la tâche de Réparation de base de données de l'Assistant Résolution de problèmes d'Exchange pour une ou plusieurs bases de données dans le groupe de stockage et si la ou les bases de données sont dans un état cohérent, il se peut que les fichiers journaux du groupe de stockage n'aient pas été supprimés. Si toutes les bases de données du groupe de stockage se trouvent au bon emplacement, vérifiez que toutes les bases de données sont dans un état cohérent en exécutant la commande suivante.

Pour vérifier manuellement l'état cohérent du fichier de base de données :

  1. Exécutez eseutil /mh <path to database .edb file>

  2. Dans la sortie de cette commande, recherchez le champ État : et vérifiez qu'il est défini sur Arrêt correct.

  3. Si toutes les bases de données du groupe de stockage sont en état d'arrêt normal, déplacez tous les fichiers journaux des transactions et les système pour le groupe de stockage vers un emplacement de sauvegarde et essayez ensuite de monter la banque. Si vous pouvez monter correctement toutes les bases de données, nous vous recommandons de réaliser une sauvegarde immédiatement dans le groupe de stockage.

Pour plus d'informations

Pour plus d'informations sur l'événement MSExchangeIS 9518 avec le code d'erreur 0xfffffb40, voir le centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=91705).

Pour plus d'informations sur la récupération de cette erreur, voir l'article 296843 de la Base de connaissances Microsoft sur la procédure de récupération d'une base de données Exchange 2000 Server après l'erreur -1216 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843).

Pour plus d'informations sur la planification de la récupération d'urgence d'Exchange, voir le guide de planification de la récupération d'urgence d'Exchange (http://go.microsoft.com/fwlink/?LinkId=91706).

Pour plus d'informations sur les Assistants Gestion de la récupération de la base de données et Dépannage de base de données, voir l'outil de gestion de récupération et de dépannage de base de données (http://go.microsoft.com/fwlink/?LinkId=91707).

Pour plus d'informations sur la récupération avec base de données temporaire, voir la section sur la portabilité de tonalité (http://go.microsoft.com/fwlink/?LinkId=91703) dans la rubrique sur la récupération d'urgence dans la documentation sur le produit Exchange 2007.

Pour plus d'informations sur les groupes de stockage de récupération, voir la section sur la présentation des groupes de stockage de récupération (http://go.microsoft.com/fwlink/?LinkID=80784) dans la rubrique sur la récupération d'urgence dans la documentation sur le produit Exchange 2007.


MSExchangeIS 9518 (0xfffffea8) : Horodatage de base de données non concordant dans le fichier de base de données
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffffea8 dans le journal des applications. Cette erreur se produit si la valeur de dbtime dans la page actuelle de la base de données affectée est supérieure à la valeur de dbtime de base de données globale de la base de données.

Explication

Si cette erreur se produit, la boîte aux lettres ou les bases de données de dossiers publics affectées ne sont pas montées. L'erreur est également identifiée comme JET_errDbTimeCorrupted.

L'erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre la discordance d'horodatage de base de données, exécutez la commande eseutil /d pour défragmenter la base de données pour laquelle ce problème se pose, puis montez la base de données. Pour plus d'informations sur l'exécution d'eseutil /d, consultez la rubrique sur l'exécution de la commande Eseutil /D (défragmentation). En outre, consultez l'article 328804 de la Base de connaissances Microsoft sur la procédure de défragmentation de bases de données Exchange.


MSExchangeIS 9518 (0xfffff764) : Fichier de transmission en continu manquant ou inaccessible
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffff764 dans le journal des applications. Cette erreur peut se produire si Exchange ne peut pas accéder au fichier de transmission en continu (.stm) associé à une base de données.

Explication

Cette erreur peut se produire si le fichier de transmission en continu (.stm) associé à une base de données a été supprimé ou déplacé, ou si Exchange ne peut pas accéder au fichier de transmission en continu en raison d'une modification d'autorisations.

Remarque :
Dans certaines circonstances, des programmes antivirus peuvent supprimer ou modifier les autorisations de fichiers Exchange, y compris le fichier .stm, si vous n'avez pas exclu les répertoires Exchange de l'analyse en fonction des meilleures pratiques recommandées pour Microsoft Exchange. Pour plus d'informations sur ce point, consultez l'article 823166 de la Base de connaissances Microsoft Aperçu d'Exchange Server 2003 et du logiciel antivirus.

Cette erreur peut également être représentée comme une erreur -2204. Cette erreur s'applique aux versions suivantes d'Exchange server :

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Restaurez le fichier de transmission en continu à partir d'une copie de sauvegarde de la base de données.

  • Vérifiez si votre logiciel antivirus a déplacé le fichier de transmission en continu vers le dossier de mise en quarantaine. Si le fichier se trouve dans le dossier de mise en quarantaine, déplacez-le vers son emplacement original, puis configurez le programme antivirus afin qu'il n'analyse pas les dossiers d'Exchange Server 2003.

    Remarque :
    Certains programmes antivirus modifient les propriétés de fichier en Lecture seule lors du déplacement de fichiers vers le dossier de mise en quarantaine. Si vous trouvez le fichier de transmission en continu dans le dossier de mise en quarantaine, cliquez avec le bouton droit sur le fichier, puis cliquez sur Propriétés. Cliquez pour désactiver la case à cocher Lecture seule avant de tenter de monter la base de données.
  • Vous pouvez exécuter l'outil de gestion de la récupération de bases de données de Microsoft Exchange qui fait partie de l'Assistant Dépannage de Microsoft Exchange. L'outil de gestion de la récupération de bases de données peut analyser la base de données et les fichiers journaux de transactions pour ce groupe de stockage et fournit des détails supplémentaires sur le problème. Pour plus d'informations et pour télécharger l'outil, consultez la page Web relative à l'Assistant Dépannage de Microsoft Exchange v1.0.


MSExchangeIS 9518 (0xfffffbf8) : autorisations requises manquantes dans le dossier ou sur le disque de la base de données Exchange
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-03-15

L'utilitaire de dépannage de base de données Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffffbf8 dans le journal des applications. Ceci indique que le dossier ou le disque qui contient la ou les bases de données Exchange ne possède pas les autorisations nécessaires.

Explication

Cette erreur indique que le dossier ou le disque hébergeant les fichiers de base de données Exchange ne possède pas les autorisations nécessaires pour les fonctions minimales. Vous risquez de rencontrer des difficultés à accéder ou à monter les banques de boîtes aux lettres ou de dossiers publics.

Action d'utilisateur

Pour résoudre ce problème, octroyez les autorisations par défaut au dossier qui contient les bases de données Exchange et au disque sur lequel ce dossier se trouve.

Pour octroyer les autorisations par défaut au dossier qui contient les bases de données Exchange dans Exchange 2007

  1. Démarrez l'Explorateur Windows, puis naviguez jusqu'au dossier qui contient les bases de données Exchange. Par défaut, il s'agit de C:\Program Files\Microsoft\Exchange\Mailbox\Nom du groupe de stockage\

  2. Cliquez avec le bouton droit sur ce dossier, puis cliquez sur Propriétés.

  3. Cliquez sur l'onglet Sécurité, et octroyez les autorisations par défaut suivantes

Compte | Autorisations
Administrateurs | Contrôle total
Système | Contrôle total
 Pour octroyer les autorisations par défaut au disque qui contient les bases de données Exchange dans Exchange 2007

  1. Démarrez l'Explorateur Windows.

  2. Cliquez avec le bouton droit sur l'objet Local Disk qui contient le dossier de base de données Exchange, puis cliquez sur Propriétés.

  3. Sélectionnez l'onglet Sécurité, et octroyez les autorisations par défaut suivantes, en fonction du système d'exploitation utilisé :

Pour Windows 2000 Server :

Compte | Autorisations
Tout le monde | Contrôle total

Pour Windows Server 2003 :

Compte | Autorisations
Administrateurs | Contrôle total
Créateur propriétaire | Aucune
Tout le monde | Aucune
Système | Contrôle total
Utilisateurs | Lecture et exécution, Affichage du contenu, Lecture
 Pour octroyer les autorisations par défaut au dossier Mdbdata sur Exchange 2000 Server et Exchange Server 2003

  1. Démarrez l'Explorateur Windows, puis naviguez jusqu'au dossier Exchsvr et développez-le.

  2. Cliquez avec le bouton droit sur le dossier Mdbdata et cliquez sur Propriétés

  3. Cliquez sur l'onglet Sécurité, et octroyez les autorisations par défaut suivantes :

Compte | Autorisations
Administrateurs | Contrôle total
Utilisateurs authentifiés | Lecture et exécution, Affichage du contenu, Lecture
Créateur propriétaire | Aucune
Opérateurs de serveur | Modification, Lecture et exécution, Affichage du contenu, Lecture, Écriture
Système | Contrôle total
 Pour octroyer les autorisations par défaut au disque qui contient le dossier Mdbdata sur Exchange 2000 Server et Exchange Server 2003

  1. Démarrez l'Explorateur Windows.

  2. Cliquez avec le bouton droit sur l'objet Local Disk qui contient le dossier Mdbdata, puis cliquez sur Propriétés.

  3. Sélectionnez l'onglet Sécurité, et octroyez les autorisations par défaut suivantes, en fonction du système d'exploitation utilisé :

Pour Windows 2000 Server :

Compte | Autorisations
Tout le monde | Contrôle total

Pour Windows Server 2003 :

Compte | Autorisations
Administrateurs | Contrôle total
Créateur propriétaire | Aucune
Tout le monde | Aucune
Système | Contrôle total
Utilisateurs | Lecture et exécution, Affichage du contenu, Lecture

Pour plus d'informations

Pour plus d'informations sur ce problème, voir l'article 823022 de la Base de connaissances Microsoft sur l'ID d'événement 490 qui est enregistré et vous recevez le message d'erreur suivant lorsque vous essayez de monter la banque de boîte aux lettres ou de dossiers publics dans Exchange Server : « N° ID : c1041724 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022).


MSExchangeIS 9518 (0xfffff743) : trop de fichiers temporaires
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-03-14

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffff743 dans le journal des applications. Cela indique que l'espace de nom du fichier teporaire d'un serveur est expiré ou qu'il n'y a plus d'espace disponible pour l'écriture dans le dossier temporaire.

Explication

Exchange 2000 Server et Exchange Server 2003 créent des fichiers temporaires dans le dossier Temp lorsqu'un objet volumineux, comme un message ou un fichier, arrive dans la base de données et le fichier .stm est trop fragmenté pour que l'ensemble de l'objet y soit écrit.

Lors du fonctionnement normal, lorsque les services Exchange sont stoppés, ces fichiers sont supprimés du dossier Temp. Si le serveur ou les services Exchange s'arrêtent inopinément, ces fichiers ne sont pas supprimés. Ensuite, lorsque vous redémarrez les services Exchange, de nouveaux fichiers temporaires sont créés. Les performances sont réduites. Si l'espace de nom du fichier temporaire 64 000 expire, les services Exchange ne démarrent pas et les événements 9518 avec le code d'erreur 0xfffff743 sont enregistrés dans le journal Application de l'Observateur d'événements.

Action d'utilisateur

Pour résoudre le problème, procédez comme suit :

  • Recherchez des fichiers lb*.tmp dans le dossier Temp de Windows. S'ils existent, procédez comme suit pour les supprimer.

  • Recherchez de l'espace disque disponible sur le disque qui héberge le dossier Temp. S'il n'y a plus d'espace disque disponible, la procédure suivante permet de déplacer les dossiers Temp et Tmp vers un autre lecteur.

Pour supprimer les fichiers lb*.tmp du dossier Temp de Windows

  1. Cliquez sur Démarrer, sélectionnez Programmes, Outils d'administration, puis cliquez sur Services.

  2. Faites défiler jusqu'à la Banque d'informations de Microsoft Exchange.

  3. Si l'état du service est Started, cliquez avec le bouton droit sur le service et cliquez sur Arrêter
Remarque :
Tous les utilisateurs seront déconnectés de leur boîte aux lettres.
  1. Recherchez le dossier %windir%\temp, où %windir% est le dossier racine de votre système Windows, par défaut, il s'agit de C:\Windows\Temp.

  2. Supprimez tous les fichiers lb*.tmp.

  3. Dans la console de gestion Services, cliquez avec le bouton droit sur le service Banque d'informations de Microsoft Exchange, puis cliquez sur Démarrer.

 Pour déplacer les dossiers Temp et Tmp vers un autre lecteur

  1. Sur l'ordinateur Exchange Server, cliquez sur Démarrer, Panneau de configuration, et double-cliquez sur Système.

  2. Cliquez sur l'onglet Avancé, puis sur Variables d'environnement.

  3. Sous Variables système, cliquez sur la ligne qui contient la variable TEMP et le disque, cliquez sur Modifier, puis tapez le nouvel emplacement du disque.

  4. Sous Variables système, cliquez sur la ligne qui contient la variable TMP et le disque, cliquez sur Modifier, puis tapez le nouvel emplacement du disque.
Remarque :
Assurez-vous que ce changement s'applique aux Variables système et non aux Variables utilisateur.
Remarque :
Si les procédures expliquées ici ne résolvent pas le problème, se reporter aux informations dans l'article 307242 de la Base de connaissances Microsoft sur l'impossibilité de monter la banque d'informations avec les erreurs 0xfffff745 et -2235 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242).

Pour plus d'informations

Pour plus d'informations sur ce problème, voir les articles suivants de la Base de connaissances Microsoft :

  • article 294462 sur les fichiers lb*.tmp Exchange du dossier Temp de Windows qui provoquent l'erreur ESE -2237 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462) ;

  • article 307242 sur l'impossibilité de monter la banque d'informations avec les erreurs 0xfffff745 et -2235 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242).


MSExchangeIS 9519 (0xfffffb3a) : Plusieurs bases de données détectées utilisant la même signature
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9519 avec le code d'erreur 0xfffffb3a dans le journal des applications. Cette erreur indique qu'une autre copie de la même base de données est en cours d'exécution.

Explication

Chaque base de données Exchange a sa propre signature unique. Si le service Banque d'informations Microsoft Exchange détecte plusieurs bases de données avec la même signature, il empêche le montage d'une base de données en double.

L'événement peut également être identifié comme erreur -1222, JET_errDatabaseSignInUse.

Action d'utilisateur

Vous pouvez vérifier que deux copies de la même base de données sont présentes dans un même groupe de stockage en procédant comme suit :

  1. Démontez toutes les autres bases de données dans le groupe de stockage, puis tentez de monter la base de données à l'origine de ce message d'erreur.

  2. Si le montage de la base de données est possible, vous devez tenter de monter toutes les autres bases de données dans le groupe de stockage.

  3. Si une autre base de données figurant dans le groupe de stockage produit la même erreur dans le journal des applications, cela signifie que deux bases de données ont la même signature et qu'il s'agit donc de copies de la même base de données.

Pour résoudre ce problème, assurez-vous qu'une seule copie de la base de données est présente dans ce groupe de stockage particulier.


MSExchangeIS 9519 (0xfffffe07) : Impossible de monter la base de données en raison d'un processus de sauvegarde en cours
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-02-27

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 9519 avec le code d'erreur 0xfffffe07 dans le journal des applications. Cette erreur indique que le montage de la base de données spécifiée n'a pas pu se faire en raison d'un processus de sauvegarde en cours.

Explication

Cette erreur peut se produire si la base de données du groupe de stockage contient plusieurs bases de données (bases de données de boîtes aux lettres ou de dossiers publics) et si l'une de ces bases de données était en cours de sauvegarde lorsque vous avez tenté de la monter. Ce comportement est conforme à la conception de l'application. Vous ne pouvez pas monter une base de données dans un groupe de stockage pendant que vous en sauvegardez une autre du même groupe de stockage.

Cette erreur peut également être représentée comme une erreur -505, JET_errBackupInProgress.

Action d'utilisateur

Assurez-vous qu'aucune autre base de données du groupe de stockage n'est en cours de sauvegarde, puis tentez de monter la base de données. Vous pouvez attendre que la sauvegarde de l'autre base de données du groupe de stockage soit terminée avant de tenter de la monter.


MSExchangeIS 9519 (0x3f3) : Case à cocher « Cette base de données peut être écrasée par une restauration » désactivée après restauration
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9519 avec le code d'erreur 0x3f3 dans le journal des applications. Cette erreur indique qu'une restauration a été effectuée sur une base de données alors que la case à cocher « Cette base de données peut être écrasée par une restauration » n'était pas activée.

Explication

Cet événement se produit lorsqu'une opération de restauration de base de données a eu lieu et qu'Exchange détecte que la case à cocher « Cette base de données peut être écrasée par une restauration » n'était pas activée sur les propriétés de la banque.

Action d'utilisateur

Pour résoudre ce problème, assurez-vous que la base de données peut être écrasée par une restauration en procédant comme suit :

Activation de l'option sur Exchange Server 2003 et Exchange 2000 Server

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration (si applicable).

  3. Développez Serveurs, <Nom de serveur>, <Groupe de stockage>, puis cliquez sur la base de données restaurée.

  4. Cliquez avec le bouton droit sur la base de données, puis cliquez sur Propriétés.

  5. Cliquez sur l'onglet Base de données.

  6. Cliquez pour activer la case à cocher Cette base de données peut être écrasée par une restauration.

  7. Cliquez sur OK.

  8. Pour monter la base de données, cliquez dessus avec le bouton droit, puis cliquez sur Monter la banque d'informations.
Activation de l'option sur Exchange Server 2007

  1. Démarrez la console de gestion Exchange.

  2. Sous Configuration du serveur, sélectionnez Boîte aux lettres.

  3. Dans le volet Gestion de la base de données, cliquez avec le bouton droit sur la base de données restaurée.

  4. Cliquez sur Propriétés.

  5. Sélectionnez l'onglet Général.

  6. Cliquez pour activer la case à cocher Cette base de données peut être écrasée par une restauration.

  7. Cliquez sur OK.

  8. Pour monter la base de données, cliquez dessus avec le bouton droit, puis cliquez sur Monter la base de données.


MSExchangeIS 9518 (0xfffffc01) : Base de données incorrecte, Lecteur du journal des transactions ou Répertoire
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9518 avec le code d'erreur 0xfffffc01 dans le journal des applications. Cela indique qu'une lettre de lecteur ou un chemin incorrect a été défini pour la base de données ou les fichiers journaux d'Exchange.

Explication

Cette erreur indique que le chemin de la base de données ou du fichier journal dans le groupe de stockage concerné pointe sur une lettre de lecteur non valide ou que le chemin du fichier est incorrect. Si cette erreur se produit, aucune des bases de données dans le groupe de stockage concerné ne peut être montée.

Ce problème peut également se produire si un logiciel antivirus bloque l'accès en écriture aux lecteurs contenant la base de données ou les fichiers journaux de transactions d'Exchange.

L'événement peut également être identifié comme erreur -1023, JET_errInvalidPath.

Action d'utilisateur

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Pour déterminer si votre logiciel antivirus est la cause du problème, désactivez-le temporairement dans la console Services. Ensuite, essayez de monter les bases de données affectées. Si le montage des bases de données réussit, contactez l'éditeur du logiciel antivirus pour en obtenir la dernière version.

  • Vérifiez et définissez les chemins corrects du système, de la base de données et du fichier journal de transactions pour chaque groupe de stockage et base de données affecté par cette erreur. Procédez comme suit.

Vérification et définition de chemins de fichier corrects dans Exchange Server 2003 ou Exchange 2000 Server

  1. Démarrez le Gestionnaire système Exchange. Cliquez sur Démarrer, pointez sur Programmes, sur Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Si des groupes d'administration s'affichent dans le Gestionnaire système Exchange, développez Groupes d'administration, puis le groupe d'administration dans lequel vous rencontrez le problème.

  3. Développez Serveurs, puis développez le serveur sur lequel vous rencontrez le problème.

  4. Cliquez avec le bouton droit sur le groupe de stockage contenant la banque d'informations que vous ne pouvez pas monter, puis cliquez sur Propriétés.

  5. Sous l'onglet Général, examinez le chemin d'accès qui s'affiche dans la zone Emplacement du journal des transactions. Examinez le chemin d'accès dans la zone Emplacement du chemin d'accès système.

    Si ces chemins d'accès sont incorrects, contactez les services de support technique Microsoft pour obtenir de l'aide concernant la résolution de ce problème.

  6. Exécutez les étapes 3 à 5 pour chaque groupe de stockage présent afin de vérifier les chemins d'accès de la base de données et du fichier journal de transactions.

  7. Après avoir vérifié les chemins d'accès système et du fichier journal de transactions pour chaque groupe de stockage, vérifiez les chemins d'accès de base de données pour chaque banque d'informations dans chaque groupe de stockage. Pour ce faire, procédez comme suit :

    1. Développez un groupe de stockage. Par exemple, développez Premier groupe de stockage.

    2. Cliquez avec le bouton droit sur StoreName (ServerName), puis cliquez sur Propriétés.

    3. Cliquez sur l'onglet Base de données, puis vérifiez le chemin d'accès affiché dans la zone Base de données Exchange. Ensuite, vérifiez le chemin d'accès qui s'affiche dans la zone Base de données de transmission en continu Exchange.

      Si un chemin d'accès particulier est incorrect, contactez les services de support technique Microsoft pour obtenir de l'aide concernant la résolution de ce problème.

    4. Répétez les étapes 7b et 7c pour vérifier les chemins d'accès de chaque banque de boîtes aux lettres ou banque de dossiers publics présente dans chaque groupe de stockage.

  8. Montez la banque de boîtes aux lettres ou la banque de dossiers publics.

Vérification et définition de chemins de fichier corrects dans Exchange Server 2007

  1. Démarrez la Console de gestion Exchange. Cliquez sur Démarrer, pointez sur Programmes, sur Microsoft Exchange, puis cliquez sur Console de gestion Exchange.

  2. Développez Configuration du serveur, puis sélectionnez Boîte aux lettres.

  3. Dans le volet Gestion de la base de données, sélectionnez le groupe de stockage contenant les bases de données que vous ne pouvez pas monter.

  4. Cliquez avec le bouton droit sur le groupe de stockage, puis cliquez sur Propriétés.

  5. Sous l'onglet Général, examinez le chemin d'accès qui s'affiche dans les champs Chemin d'accès au journal et Chemin d'accès système.

    Si ces chemins sont incorrects, cliquez avec le bouton droit sur le groupe de stockage, puis sélectionnez Déplacer le chemin d'accès du groupe de stockage. Sous Chemin d'accès des fichiers journaux et Chemin d'accès des fichiers système cliquez sur Parcourir pour accéder au dossier contenant les fichiers journaux de transactions ou les fichiers de base de données. Par défaut, les fichiers journaux des transactions et les fichiers de base de données se trouvent dans le dossier suivant :

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<nom du groupe de stockage>

  6. Cliquez sur OK.

  7. Exécutez les étapes 3 à 5 pour chaque groupe de stockage présent afin de vérifier les chemins d'accès système et du fichier journal de transactions.

  8. Après avoir vérifié les chemins d'accès système et du fichier journal de transactions pour chaque groupe de stockage, vérifiez les chemins d'accès de base de données pour chaque base de données dans chaque groupe de stockage. Pour ce faire, procédez comme suit :

    1. Développez un groupe de stockage. Par exemple, développez Premier groupe de stockage.

    2. Vérifiez le chemin d'accès affiché dans le champ Chemin d'accès au fichier de la base de données dans le volet Gestion de la base de données.

    3. Si un chemin d'accès particulier est incorrect, cliquez avec le bouton droit sur la base de données, puis cliquez sur Déplacer le chemin d'accès de la base de données.

    4. Cliquez sur Parcourir pour accéder au dossier correct pour le fichier de base de données. Par défaut, le fichier de base de données Exchange (.edb) se trouve dans le dossier suivant :

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<nom du groupe de stockage>\<nom de base de données.edb>

    5. Cliquez sur OK.

    6. Exécutez les étapes 8b à 8e pour vérifier les chemins d'accès de chaque base de données de boîtes aux lettres ou de dossiers publics présente dans chaque groupe de stockage.

  9. Montez la base de données de boîtes aux lettres ou de dossiers publics.


MSExchangeIS 9519 (0xfffffbda) : Paramètres régionaux du jeu de caractères codés sur deux octets manquants comme paramètres régionaux par défaut du système
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-23

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9519 avec le code d'erreur 0xfffffbda dans le journal des applications. L'événement indique que des paramètres régionaux par défaut du système non anglais ont été installés. Après l'installation d'Exchange Server, les paramètres régionaux par défaut du système ont été désinstallés.

Explication

Si l'événement MSExchangeIS 9519 avec le code d'erreur 0xfffffbda est déclenché au redémarrage du serveur Exchange, les bases de données Exchange ne sont pas montées. En outre, les événements d'erreur ESE 604 et MSExchangeIS 9519 sont consignés dans le journal des événements d'application.

Ce comportement peut se produire si vous avez précédemment défini des paramètres régionaux non anglais comme paramètres régionaux par défaut du système. Si vous avez des paramètres régionaux autres que ceux par défaut, supprimé les paramètres régionaux non anglais, puis redémarré Exchange 2000 Server ou Exchange Server 2003, vous avez été confronté à cet événement.

L'événement peut également être identifié comme -1062, JET_errInvalidLanguageId. L'événement s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre le problème, réinstallez les paramètres régionaux non anglais ou créez des bases de données. Si vous réinstallez des paramètres régionaux non anglais, il n'est pas nécessaire de les définir comme paramètres régionaux par défaut du système.


MSExchangeIS 9519 (0xfffff05b) : Base de données ou journaux compressés sur un serveur exécutant Exchange Server 2000 SP3 ou une version supérieure
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-02-19

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 9519 avec le code d'erreur 0xfffff05b dans le journal des applications. Cela indique que la base de données Exchange ou les fichiers journaux des transactions se trouvent sur un lecteur pour lequel la compression du système de fichiers est activée.

Explication

Cet événement peut se produire lorsque vous appliquez Exchange 2000 Server Service Pack 3 (SP3) à un serveur Exchange 2000 contenant une base de données de banque d'informations qui est compressée à l'aide d'une compression de système de fichiers NTFS. Ce problème peut également se produire si vous procédez à une mise à niveau d'un ordinateur Exchange 2000 Server vers Exchange Server 2003. Exchange 2000 Server SP3, Exchange Server 2003 et Exchange Server 2007 empêchent le montage des bases de données de banque d'informations compressées.

Cette erreur peut également être représentée comme une erreur -4005, JET_errFileCompressed. Cette erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server SP3

Action d'utilisateur

Pour résoudre ce problème, vous devez décompresser les dossiers où résident les journaux et les bases de données de banque d'informations, défragmenter les bases de données, puis effectuer une sauvegarde Exchange en ligne des groupes de stockage de la banque d'informations où les bases de données et les journaux résident. Pour ce faire, consultez l'article 327772 de la Base de connaissances Microsoft, Le montage de la base de données est impossible et l'erreur 0xfffff05b s'affiche après l'application du SP3 à Exchange 2000.


MSExchangeIS 9519 (0xfffffa84) : Index de base de données manquants ou endommagés
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-01-22

L'outil de dépannage de base de données de Microsoft® Exchange a détecté un ou plusieurs événements MSExchangeIS 9519 avec le code d'erreur 0xfffffa84 dans le journal des applications. Cet événement indique que les index de cette base de données sont endommagés ou manquants.

Explication

Les causes suivantes pourraient produire un index de base de données endommagé ou manquant :

  • Cela peut se produire durant un nettoyage d'index d'une base de données Exchange suite à l'application d'un nouveau Service Pack Microsoft Windows. Une fois le Service Pack appliqué, vous ne pouvez pas monter la boîte aux lettres ou les bases de données de dossiers publics dans le serveur Exchange. En outre, les événements ESE 609 et ESE 611 sont consignés dans le journal des événements d'application.

  • Cela se produit après exécution d'une opération de réparation de base de données (eseutil /p). Cette opération peut supprimer un index généré lors de la création initiale de la base de données. L'exécution de la commande Eseutil repair supprime l'index.

Cette erreur peut également être représentée comme une erreur -1404, JET_errIndexNotFound. Cette erreur s'applique aux versions suivantes d'Exchange Server :

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Action d'utilisateur

Pour résoudre ce problème, suivez la résolution correspondant au scénario de problème décrit ci-avant :

  • Si un index est endommagé durant un nettoyage d'index d'une base de données Exchange suite à l'application d'un nouveau Service Pack Windows, procédez comme suit :

    1. Restaurez la base de données de boîtes aux lettres ou de dossiers publics affectée à partir d'une sauvegarde de bonne qualité.

    2. Effectuez une défragmentation en mode hors connexion de la base de données affectée en exécutant eseutil /d. Pour plus d'informations sur la défragmentation de la base de données affectée en mode hors connexion, consultez les rubriques suivantes :

      Bases de données Exchange 2000 Server et Exchange Server 2003 : Procédure d'exécution de la commande Eseutil /D (défragmentation)

      Bases de données Exchange Server 2007 : Procédure d'exécution de la commande Eseutil /D (défragmentation)

  • S'il manque un index après que vous avez effectué une opération de réparation de base de données (eseutil /p), appliquez le correctif prescrit dans l'article 924627 de la Base de connaissances Microsoft décrivant le fait que l'ID d'événement 9519 qui inclut l'erreur 0xfffffa84 est journalisé lorsque vous tentez de monter une base de données après avoir exécuté les utilitaires Eseutil et Isinteg pour récupérer la base de données dans Exchange 2003.


MSExchangeIS 9519 0x972 : conteneur de dossiers publics supprimé ou attributs obligatoires manquants
Microsoft Exchange Server Analyzer - Articles > Récupération de base de données >

Dernière rubrique modifiée : 2007-08-30

L'outil de dépannage de base de données de Microsoft Exchange a détecté un ou plusieurs événements MSExchangeIS 9519 avec le code d'erreur 0x972 dans le journal des applications, ce qui indique une défaillance des bases de données de dossiers publics à monter car le conteneur de dossiers publics a été supprimé ou ne contient pas les attributs nécessaires.

Explication

Cette erreur peut se produire lorsque le conteneur de dossiers publics a été supprimé d'Active Directory ou si la banque publique affectée n'est pas configurée pour utiliser le conteneur de dossiers publics, c.-à-d. si la valeur de l'attribut msExchOwningPFTreeBL des conteneurs de dossiers publics ne pointe pas vers la banque publique. La cause la plus probable de cette erreur est que le groupe d'administration qui contenait le conteneur de dossiers publics a été supprimé sans que ce conteneur ne soit préalablement déplacé dans un nouveau groupe d'administration.

Action d'utilisateur

Pour résoudre ce problème, utilisez ADSI Edit ou un outil similaire pour déterminer si le conteneur de dossiers publics existe et si l'attribut msExchOwningPFTreeBL est correctement configuré pour pointer vers la banque publique adéquate.

Attention :
Si vous modifiez les attributs d'objets Active Directory de manière incorrecte lorsque vous utilisez ADSI Edit, l'outil LDP ou un autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour déterminer la cause de l'erreur

  1. Si vous utilisez ADSI Edit ou un outil similaire, recherchez l'objet de groupe d'administration dans Active Directory.

    L'objet de groupe d'administration peut se trouver dans :

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Groupes d'administration,CN=Groupe d'administration

  2. Développez chaque groupe d'administration et vérifiez s'il existe un conteneur CN=Hiérarchies de dossiers. Si le conteneur CN=Hiérarchies de dossiers existe, mettez-le en surbrillance et vérifiez qu'un objet CN=Dossiers publics existe dans le volet droit. S'il n'existe aucun objet CN=Dossiers publics sous aucun groupe d'administration, passez à la solution 1, qui consiste à recréer des hiérarchies de dossiers et des conteneurs de dossiers publics. Si vous trouvez un conteneur CN=Dossiers publics, passez à l'étape 3.

  3. Cliquez avec le bouton droit sur le dossier CN=Dossiers publics et cliquez sur Propriétés

  4. Dans la liste d'attributs, sélectionnez l'attribut msExchOwningPFTreeBL, puis cliquez sur Modifier.

  5. Veillez à ce que la banque de dossiers publics affectée soit affichée dans la liste Valeurs. Dans le cas contraire, passez à la solution 2.
Solution 1 : Recréation de hiérarchies de dossiers et de conteneurs de dossiers publics

  1. Si vous utilisez ADSI Edit ou un outil similaire, recherchez et développez Groupe d'administration Exchange (FYDIBOHF23SPDLT).

    L'objet Groupe d'administration Exchange (FYDIBOHF23SPDLT) peut se trouver dans :

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Groupes d'administration

  2. Cliquez avec le bouton droit sur l'objet Groupe d'administration Exchange (FYDIBOHF23SPDLT) et cliquez sur Nouveau, puis sur Objet.

  3. Dans la liste Sélectionnez une classe, sélectionnez msExchPublicFolderTreeContainer, puis cliquez sur Suivant.

  4. Dans la zone Valeur, tapez Hiérarchies de dossiers et cliquez sur Suivant, puis sur Terminer.

  5. Cliquez avec le bouton droit sur l'objet Hiérarchies de dossiers que vous venez de créer, cliquez sur Nouveau, puis sur Objet.

  6. Dans la liste Sélectionnez une classe, sélectionnez msExchPFTree, puis cliquez sur Suivant.

  7. Dans la zone Valeur, tapez Dossiers publics, puis cliquez sur Suivant.

  8. Cliquez sur Autres attributs.

  9. Dans la liste déroulante Sélectionnez une propriété à afficher, sélectionnez msExchPFTree.

  10. Dans la zone Modifier l'attribut, tapez 1 et cliquez sur Définir, puis sur OK et Terminer.

  11. Pour affecter le conteneur Dossiers public à chaque banque publique, cliquez avec le bouton droit sur le conteneur Dossiers publics et sélectionnez Propriétés.

  12. Dans la liste Attributs, sélectionnez distinguishedName et cliquez sur Modifier.

  13. Copiez le contenu de la zone Valeur dans le presse-papiers, puis cliquez sur Annuler.

  14. Pour chaque serveur qui affiche l'événement MSExchangeIS 9519 avec le code d'erreur 0x972, accédez à l'objet Banque de dossiers publics. L'emplacement par défaut de cet objet est :

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Groupes d'administration, CN=Groupe d'administration Exchange (FYDIBOHF23SPDLT), CN=Serveurs, CN= NomServeur , CN= BanqueInformations , CN=Deuxième groupe de stockage.

  15. Cliquez avec le bouton droit sur l'objet Banque de dossiers publics, puis cliquez sur Propriétés.

  16. Dans la liste Attributs, sélectionnez msExchOwningPFTree et cliquez sur Modifier.

  17. Collez la valeur copiée dans le presse-papiers à l'étape 13 dans la zone Valeur, puis cliquez sur OK à deux reprises pour terminer.

  18. Répétez les étapes 15 à 17 pour chaque serveur affichant l'événement MSExchangeIS 9519 avec le code d'erreur 0x972.

  19. Redémarrez le service Banque d'informations de Microsoft Exchange sur les serveurs affectés.

Solution 2 : Recopie de la valeur de l'attribut msExchOwningPFTreeBL pour l'objet du conteneur Dossiers publics

  1. À l'aide d'ADSI Edit ou d'un outil similaire, localisez l'objet Dossiers publics dans Active Directory.

    Les objets Dossiers publics peuvent se trouver dans :

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Groupes d'administration,CN=Groupe d'administration,CN=Hiérarchies de dossiers,CN=Dossiers publics

  2. Cliquez avec le bouton droit sur le conteneur Dossiers publics et sélectionnez Propriétés.

  3. Dans la liste Attributs, sélectionnez distinguishedName et cliquez sur Modifier.

  4. Copiez le contenu de la zone Valeur dans le presse-papiers, puis cliquez sur Annuler.

  5. Pour chaque serveur qui affiche l'événement MSExchangeIS 9519 avec le code d'erreur 0x972, accédez à l'objet Banque de dossiers publics. L'emplacement par défaut de cet objet est :

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organisation,CN=Groupes d'administration, CN=Groupe d'administration Exchange (FYDIBOHF23SPDLT), CN=Serveurs, CN= NomServeur , CN= BanqueInformations , CN=Deuxième groupe de stockage.

  6. Cliquez avec le bouton droit sur l'objet Banque de dossiers publics, puis cliquez sur Propriétés.

  7. Dans la liste Attributs, sélectionnez msExchOwningPFTree et cliquez sur Modifier.

  8. Collez la valeur copiée dans le presse-papiers à l'étape 4 dans la zone Valeur, puis cliquez sur OK à deux reprises pour terminer.

  9. Répétez les étapes 6 à 8 pour chaque serveur affichant l'événement MSExchangeIS 9519 avec le code d'erreur 0x972.

  10. Redémarrez le service Banque d'informations de Microsoft Exchange sur les serveurs affectés.


Cluster Exchange
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant les clusters Exchange. En outre, ils décrivent les actions possibles pour corriger les erreurs liées aux clusters Exchange, les avertissements et les configurations autres que celles par défaut détectés par Exchange Server Analyzer.


Le débogage de cluster est activé
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le débogage de cluster est activé sur le serveur :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

Si Exchange Server Analyzer détecte que la valeur Debug est égale à 1, il affiche un avertissement.

Le débogage de cluster avec cette valeur de Registre empêche les ressources de cluster de basculer entre des nœuds. Vous devriez utiliser cette valeur de Registre uniquement lors du débogage d'un problème pour lequel il est nécessaire d'empêcher des ressources de basculer.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour désactiver la clé de Registre de débogage de cluster

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à HKLM\Software\Microsoft\Exchange\Cluster.

  3. Modifiez la valeur Debug en 0.

  4. Quittez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les clusters Exchange, voir la rubrique sur la gestion des clusters Exchange dans Exchange Server 2003 dans le Guide d'administration d'Exchange 2003 Server (http://go.microsoft.com/fwlink/?LinkId=47617).


La priorité réseau de pulsation dédiée du cluster n'a pas été définie correctement
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer l'ordre de priorité de chaque ressource réseau d'interface dans le cluster de serveurs Exchange :

HKEY_LOCAL_MACHINE\Cluster\Networks\<GUID d'interface réseau>\Priority

La valeur de Priority indique la priorité réseau configurée pour la ressource d'interface réseau. La ressource d'interface réseau avec la priorité la plus élevée a une valeur de 1, la prochaine priorité la plus élevée a une valeur de 2, etc.

Exchange Server Analyzer lit l'entrée de Registre suivante pour déterminer le rôle défini pour chaque ressource réseau d'interface dans le cluster de serveurs Exchange :

HKLM\Cluster\Networks\<GUID d'interface réseau>\Role

Une valeur 1 indique que la ressource réseau a été configurée comme un réseau privé dédié (pulsation). Une valeur 2 indique que la ressource réseau a été configurée comme un réseau public dédié (accès client). Une valeur de 3 indique que la ressource réseau a été configurée comme un réseau mixte autorisant les trafics de pulsation et d'accès client.

Si Exchange Server Analyzer détermine qu'une ressource d'interface réseau avec une valeur Role de 1 a une valeur Priority supérieure à 1, un avertissement s'affiche. Cet avertissement indique qu'un réseau de pulsation dédiée a été détecté, mais que sa priorité réseau n'est pas correctement définie.

La configuration d'un réseau privé dédié à utiliser pour la pulsation de cluster est une méthode recommandée pour tous les clusters Exchange Server. La communication entre nœuds est essentielle pour le bon déroulement des opérations de cluster. Respectez les instructions ci-dessous pour configurer correctement la priorité réseau de pulsation dédiée.

Pour supprimer cet avertissement

  1. Ouvrez Administrateur de cluster et connectez-vous au cluster de serveurs Exchange.

  2. Dans le volet gauche, cliquez avec le bouton droit sur l'objet Cluster au sommet de la hiérarchie, puis cliquez sur Propriétés.

  3. Cliquez sur Priorité réseau.

  4. Sélectionnez la ressource réseau de pulsation dédiée.

  5. Cliquez sur Monter jusqu'à ce que la ressource réseau de pulsation dédiée arrive en tête de la liste des ressources réseau.

  6. Cliquez sur OK.

Pour plus d'informations sur les réseaux de pulsation de cluster, voir les articles suivants de la Base de connaissances Microsoft :

  • 258750 sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962 sur la prise en charge de la multidiffusion activée pour la pulsation de cluster (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

Pour plus d'informations, voir le document sur la liste des vérifications de la configuration des clusters Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=36083).


Le numéro de la version de Windows installée sur le nœud de cluster ne correspond pas au premier nœud
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version principale du système d'exploitation Microsoft Windows® exécutée sur chaque nœud du cluster :

HKEY_LOCAL_MACHINE\Cluster\Nodes\<numéro de nœud>\BuildNumber

Si Exchange Server Analyzer détecte que la valeur de BuildNumber sur le deuxième nœud ou l'un des nœuds suivants du cluster Exchange est différente de la valeur de BuildNumber sur le premier nœud du cluster, une erreur s'affiche.

Si un cluster Exchange s'exécute sur différentes versions de Windows, il est possible que le basculement ne se produise pas comme prévu ou conformément à la configuration. Dans un environnement Windows mixte, le basculement ne se produira que d'un système d'exploitation antérieur vers une version ultérieure (par exemple, de Windows 2000 Advanced Server vers Windows Server™ 2003 Édition Entreprise). Il ne se produira pas dans le sens inverse (par exemple, de Windows Server 2003 à Windows 2000 Server).

Pour résoudre ce problème, vous devez mettre à niveau tous les nœuds vers le même système d'exploitation et le même Service Pack. Pour miniser le temps d'arrêt, vous pouvez effectuer une mise à niveau tournante de votre cluster.

Pour corriger cette erreur

  1. Voir les instructions d'exécution d'une mise à niveau tournante d'un cluster dans l'article 811272 de la Base de connaissances Microsoft sur la procédure d'exécution d'une mise à niveau tournante des clusters de serveurs Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272).

  2. Voir l'article sur les clusters Windows 2000 et l'exécution d'une mise à niveau tournante (http://go.microsoft.com/fwlink/?linkid=1718).

  3. Effectuez une mise à niveau tournante de chaque nœud dont la valeur BuildNumber n'est pas identique à celle du premier nœud du cluster.

Pour plus d'informations sur des procédures alternatives, voir le document sur les alternatives aux mises à niveau tournantes (http://go.microsoft.com/fwlink/?LinkId=41363).


La version du Service Pack Windows installée sur le nœud de cluster ne correspond pas au premier nœud
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version du Service Pack Microsoft Windows® installée sur chaque nœud du cluster :

HKEY_LOCAL_MACHINE\Cluster\Nodes\<numéro de nœud>\CSDVersion

Si Exchange Server Analyzer détecte que la valeur de CSDVersion sur le deuxième nœud ou l'un des nœuds suivants du cluster Exchange est différente de la valeur de CSDVersion sur le premier nœud du cluster, une erreur s'affiche.

Cette erreur indique que les nœuds de ce cluster Exchange n'exécutent pas le même niveau du Service Pack Windows. Il est recommandé que tous les nœuds d'un cluster Exchange exécutent le même niveau du système d'exploitation et du Service Pack.

Pour résoudre ce problème, vous devez mettre à niveau tous les nœuds vers le même système d'exploitation et le même Service Pack. Pour miniser le temps d'arrêt, vous pouvez effectuer une mise à niveau tournante de votre cluster.

Pour supprimer cet avertissement

  1. Voir les instructions d'exécution d'une mise à niveau tournante d'un cluster dans l'article 811272 de la Base de connaissances Microsoft sur la procédure d'exécution d'une mise à niveau tournante des clusters de serveurs Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272).

  2. Voir l'article sur les clusters Windows 2000 et l'exécution d'une mise à niveau tournante (http://go.microsoft.com/fwlink/?linkid=34288).

  3. Effectuez une mise à niveau tournante de chaque nœud dont la valeur CSDVersion est différente de celle du premier nœud du cluster.

Pour plus d'informations sur des procédures alternatives, voir le document sur les alternatives aux mises à niveau tournantes (http://go.microsoft.com/fwlink/?linkid=34289).


Le chemin d'accès à l'environnement TEMP/TMP du cluster se trouve sur le même lecteur que la partition système
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

Sur un ordinateur Exchange Server non membre d'un cluster, l'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer la valeur des variables des environnements TEMP et TMP :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Lorsqu'Exchange Server Analyzer est utilisé sur un serveur virtuel Exchange (EVS) dans un cluster de serveurs Microsoft Windows®, la ruche du Registre HKLM n'est pas lue. Par contre, les entrées de Registre suivantes sont lues :

HKEY_USERS\<SID de compte du service de cluster>\Environment\TEMP

HKEY_USERS\<SID de compte du service de cluster>\Environment\TMP

Si Exchange Server Analyzer détecte que la variable de l'environnement TEMP et/ou TMP commence par %SYSTEMROOT, un avertissement s'affiche.

Le service de banque d'informations de Microsoft Exchange utilise les dossiers TEMP et TMP pour le stockage temporaire au cours de diverses opérations, telles que la conversion des messages et le déplacement de boîtes aux lettres. Sur un serveur Exchange non membre d'un cluster, la banque d'informations de Microsoft Exchange utilise le SYSTÈME (par exemple, Système local) utilisant un paramètre de variable d'environnement par défaut %Systemroot%\Temp pour TEMP et TMP.

Les serveurs virtuels Exchange exécutés dans un cluster de serveurs Windows utilisent les paramètres de variable d'environnement du compte du service de cluster, qui opère dans le contexte d'un principe de sécurité utilisateur spécifique. Pour les comptes d'utilisateurs, la variable d'environnement par défaut de TEMP et TMP est définie sur %Userprofile%\temp.

Les variables d'environnement TEMP et TMP permettent de désigner les dossiers du système de fichiers (par exemple, le chemin d'accès) devant être utilisés par les applications qui nécessitent un espace de travail temporaire. TEMP est généralement utilisé par des applications, telles qu'Exchange, et TMP par des outils de développement, tels que Microsoft Visual C++®. Le chemin d'accès de chaque variable est généralement relatif au contexte de sécurité de l'application ou de l'outil.

Pour des performances optimales, il est recommandé de ne pas utiliser le disque contenant le système d'exploitation pour les dossiers TEMP et TMP utilisés par Exchange. En outre, vous devez veiller à ce que ces variables d'environnement soient définies sur des chemins d'accès d'un disque rapide ou d'un sous-système de disque, tel que l'ensemble de piles RAID 0+1. Il est également recommandé de ne pas utiliser le disque contenant le système d'exploitation pour les dossiers TEMP et TMP utilisés par les serveurs Exchange virtuels ou non.

Pour supprimer cet avertissement

  1. Connectez-vous à un nœud du cluster comme le compte du service de cluster.

  2. Cliquez avec le bouton droit sur Poste de travail et sélectionnez Propriétés.

  3. Sélectionnez Avancé.

  4. Cliquez sur Variables d'environnement.

  5. Dans la zone Variables utilisateur pour <nom du compte>, sélectionnez TEMP et cliquez sur Modifier.

  6. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TEMP et cliquez sur OK.

  7. Dans la zone Variables utilisateur pour <nom du compte>, sélectionnez TMP et cliquez sur Modifier.

  8. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TMP et cliquez sur OK.

  9. Cliquez sur OK pour fermer la boîte de dialogue Variables d'environnement, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés système.

  10. Redémarrez le nœud pour appliquer la modification.

  11. Répétez les étapes 1 à 10 pour chaque nœud du cluster.

Pour plus d'informations sur la modification des variables d'environnement TEMP/TMP sur un ordinateur Exchange Server non membre d'un cluster, voir l'article La variable TEMP/TMP semble pointer vers un dossier non valide ou inapproprié.


Pulsation dédiée de cluster introuvable
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le rôle défini pour chaque ressource réseau d'interface dans le cluster de serveurs Exchange :

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

Une valeur 1 indique que la ressource réseau a été configurée comme un réseau privé dédié (pulsation). Une valeur 2 indique que la ressource réseau a été configurée comme un réseau public dédié (accès client). Une valeur de 3 indique que la ressource réseau a été configurée comme un réseau mixte autorisant les trafics de pulsation et d'accès client.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster (Clussvc). Une valeur True indique que le service de cluster est démarré et une valeur False qu'il n'est pas en cours d'exécution.

Si Exchange Server Analyzer ne trouve pas de ressource réseau dans un cluster Exchange configuré comme un réseau privé dédié, un avertissement s'affiche.

La configuration d'un réseau privé dédié à utiliser pour la pulsation de cluster est une méthode recommandée pour tous les clusters Exchange Server. La communication entre nœuds est essentielle pour le bon déroulement des opérations de cluster. Vous devez configurer de manière optimale les réseaux utilisés pour les communications du cluster et respecter toutes les spécifications de la liste de compatibilité matérielle. Pour la configuration réseau, au moins deux réseaux indépendants doivent connecter les nœuds d'un cluster pour éviter un point faible unique. Deux réseaux locaux sont généralement utilisés. Les services du Support Technique de Microsoft ne prennent pas en charge la configuration d'un cluster dont les nœuds ne sont connectés que par un réseau.

Pour supprimer cet avertissement

  1. Au besoin, ajoutez des cartes d'interface réseau sur chaque nœud du cluster Exchange et configurez-les comme un réseau privé dans Administrateur de cluster.

  2. Si des cartes réseau supplémentaires sont utilisées pour des réseaux mixtes, vous devez reconfigurer les réseaux appropriés pour qu'ils se comportent comme des réseaux privés dédiés.

Pour plus d'informations sur les réseaux de pulsation de cluster, voir les articles suivants de la Base de connaissances Microsoft :

  • 258750 sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750)

  • 307962 sur la prise en charge de la multidiffusion activée pour la pulsation de cluster (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962)

Pour plus de détails, voir le document sur la liste des vérifications de la configuration des clusters Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=36083).


La taille de fichier par défaut pour un fichier cluster.log doit être augmentée jusqu'à 32
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le paramètre ClusterLogSize a été défini :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

Si Exchange Server Analyzer détecte que la valeur de ClusterLogSize n'est pas présente ou que la valeur de ClusterLogSize est inférieure ou égale à 8, un avertissement s'affiche. Sur un cluster occupé, le fichier cluster.log réagit très rapidement, pouvant entraîner la perte d'entrées lorsque vous résolvez des situations de basculement dans les conditions suivantes :

  • Un dépannage nécessite un examen détaillé du fichier cluster.log.

  • Le cluster gère de nombreuses ressources.

Par conséquent, lorsque le dépannage nécessite l'utilisation du fichier cluster.log, créez le paramètre ClusterLogSize (s'il n'est pas déjà présent) et augmentez sa taille par défaut jusqu'à au moins 32, 64 ou 96.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour créer le paramètre ClusterLogSize et définir sa valeur

  1. Ouvrez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Dans le volet gauche, cliquez sur Environnement.

  4. Dans le menu Édition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  5. Entrez ClusterLogSize, puis appuyez sur ENTRÉE pour nommer la nouvelle entrée de Registre.

  6. Cliquez avec le bouton droit sur ClusterLogSize, puis cliquez sur Modifier.

  7. Adaptez les ClusterLogSize Données de la valeur à la nouvelle taille du fichier .log. Par exemple, augmentez la valeur ClusterLogSize jusqu'à 32, 64 ou 96, puis appuyez sur ENTRÉE.

  8. Quittez l'Éditeur du Registre
Pour modifier la taille par défaut du fichier cluster.log

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Cliquez avec le bouton droit sur ClusterLogSize, puis cliquez sur Modifier.

  4. Adaptez les ClusterLogSize Données de la valeur à la nouvelle taille du fichier .log. Par exemple, augmentez la valeur ClusterLogSize jusqu'à 32, 64 ou 96, puis appuyez sur ENTRÉE.

  5. Quittez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'enregistrement des clusters sur Microsoft Cluster Server, voir l'article 168801 de la Base de connaissances Microsoft sur la procédure d'activation de l'enregistrement des clusters sur Microsoft Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801)


Activation de l'authentification Kerberos pour SMTP
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2006-05-12

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® afin de déterminer si un serveur Microsoft Exchange Server 2003 installé dans un service de cluster Windows™ Server 2003 emploie le nom de domaine complet (FQDN) du serveur comme valeur pour la ressource SMTPSVC de l'attribut servicePrincipalName.

Si Exchange Server Analyzer détermine que l'attribut servicePrincipalName de la ressource Exchange SMTPSVC du service de cluster ne contient par le FQDN du serveur comme valeur, il affiche un message de recommandation.

Il est recommandé d'activer l'authentification Kerberos pour les services SMTP (Simple Mail Transfer Protocol) sur les serveurs de cluster Windows Server 2003 qui exécutent Exchange Server 2003. Vous pouvez activer l'authentification Kerberos en définissant manuellement une nouvelle valeur SPN (nom du service principal) pour la ressource Exchange SMTPSVC.

Par défaut, Windows Server 2003 utilise l'authentification NTLM. Le protocole Kerberos est plus flexible, plus efficace et plus sûr que NTLM. L'authentification Kerberos offre les avantages suivants :

  • Connexions plus rapides. Avec l'authentification NTLM, un serveur d'applications doit se connecter à un contrôleur de domaine pour authentifier chaque client. En employant l'authentification Kerberos, le serveur n'a pas besoin de trouver un contrôleur de domaine. Le serveur peut authentifier le client en examinant les informations d'identification fournies par le client. Les clients peuvent obtenir, de manière ponctuelle, des informations d'identification pour un serveur précis, puis les réutiliser au cours d'une session de connexion au réseau.

  • Authentification mutuelle. NTLM permet aux serveurs de vérifier les identités de leurs clients. NTLM ne permet par contre pas aux clients de vérifier l'identité d'un serveur ni à un serveur de vérifier l'identité d'un autre serveur. L'authentification NTLM a été conçue pour des environnements de réseau dans lesquels les serveurs étaient censés être authentiques. Le protocole Kerberos ne fait pas une telle supposition. Les parties se trouvant de part et d'autre d'une connexion réseau peuvent savoir que leur interlocuteur est bien celui qu'il affirme être.

  • Authentification déléguée. Les services Windows assument l'identité des clients lorsqu'ils accèdent à des ressources au nom de ces derniers. Il arrive souvent qu'un service puisse effectuer une tâche pour le client en accédant à des ressources sur l'ordinateur local. NTLM et Kerberos fournissent tous deux les informations requises pour qu'un service puisse assumer localement l'identité de son client. Toutefois, certaines applications distribuées sont conçues de façon à ce qu'un service frontal doive assumer l'identité de clients lorsqu'il se connecte à des services principaux sur d'autres ordinateurs. Le protocole Kerberos comporte un mécanisme de proxy qui permet à un service d'assumer l'identité de son client lorsqu'il se connecte à d'autres services. NTLM ne possède pas de mécanisme équivalent.

Pour corriger ce problème, procédez comme suit afin d'ajouter les valeurs manquantes aux attributs concernés.

Utilisez l'outil SETSPN.exe pour ajouter un SPN avec les valeurs manquantes.

  1. Installez l'outil Setspn.exe. Pour savoir comment obtenir l'outil Setspn.exe, consultez la rubrique "Windows 2000 Resource Kit Tool : Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103).

    La version pour Windows Server 2003 de l'outil de ligne de commande Setspn.exe se trouve parmi les outils de support de Windows Server 2003 disponibles sur le CD de Windows Server 2003. Pour installer les outils de support de Server 2003, double-cliquez sur le fichier Suptools.msi dans le dossier Support/Tools.

  2. Suivez les instructions figurant dans le fichier Setspn_d.txt de SETSPN.EXE pour ajouter la valeur manquante à l'objet Active Directory pour votre serveur Exchange. L'exemple suivant illustre l'ajout de la valeur FQDN au SPN d'un serveur SMTP virtuel :

    • Ouvrez une invite de commande puis accédez au répertoire où vous avez installé Setspn.exe.

    • À l'invite de commande, entrez la commande suivante :

      setspn.exe-a SMTPSVC/ mail.votredomaine.com NOMDEVOTRESERVEUR

      Remarque :
      Remplacez mail.votredomaine.com par le FQDN de votre serveur SMTP virtuel et NOMDEVOTRESERVEUR par le nom du serveur Exchange.
    • Appuyez ensuite sur la touche Entrée.


Impossible de contacter le nœud de cluster Exchange
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster (ClusSvc). Une valeur True indique que le service de cluster est démarré et une valeur False qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer la version de Windows exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute Windows 2000 Server et une valeur de 5.2, qu'il exécute Windows Server™ 2003.

Si Exchange Server Analyzer ne peut pas déterminer la version de Windows exécutée dans le cluster ou s'il ne peut pas déterminer si le service de cluster s'exécute, une erreur s'affiche. Cette erreur indique qu'Exchange Server Analyzer n'a pas pu contacter un nœud dans un cluster Exchange Server.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Utilisez la commande ping pour voir si l'ordinateur Exchange Server est accessible.

  3. Si un pare-feu est installé, vérifiez que les ports d'appel de procédure distante (RPC) sont bloqués.

  4. Assurez-vous que le service Registre distant sur l'ordinateur Exchange Server a été démarré.

  5. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté pour s'assurer qu'il possède des autorisations suffisantes pour lire le Registre sur l'ordinateur Exchange Server.

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Le chemin d'accès des données Exchange dans Active Directory ne correspond pas au Registre de cluster
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2006-04-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge le Registre de cluster (HKEY_LOCAL_MACHINE\Cluster) et le service d'annuaire Active Directory® pour déterminer si les chemins d'accès aux fichiers de données Exchange (par exemple, les fichiers journaux de suivi des messages) sont identiques aux deux emplacements. Exchange Server configure ces valeurs dans le Registre et dans Active Directory lorsque le Programme d'installation d'Exchange est utilisé pour installer Exchange sur un nœud d'un cluster de serveurs Microsoft Windows®.

La valeur de Registre créée par le Programme d'installation d'Exchange et lue par Exchange Server Analyzer est :

HKLM\Cluster\Resources\<Ressource GUID de ressource de banque d'informations>\Parameters\DestPath

La valeur Active Directory créée par le Programme d'installation d'Exchange et lue par Exchange Server Analyzer est : msExchDataPath. Cette valeur est un attribut de l'objet d'ordinateur Exchange Server dans Active Directory, pouvant se trouver dans :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN= Nom_organisation =Groupes_administration, CN= Nom_groupe_administration , CN=Serveurs, CN= Nom_serveur

Si Exchange Server Analyzer détecte que les valeurs de DestPath et msExchDataPath ne correspondent pas, une erreur s'affiche.

Une cause courante de la différence entre ces valeurs réside dans le changement de l'emplacement de certains ou de tous les fichiers de données Exchange après la production d'Exchange. Par exemple, en cas de mise à niveau de matériel, les fichiers journaux de suivi des messages sont déplacés, une lettre de lecteur est modifiée et la modification est répercutée dans le Registre de cluster, mais pas dans Active Directory. Après ce type de modification, des erreurs de démarrage de service, des problèmes de montage de base de données et d'autres problèmes peuvent survenir, en particulier lors de l'application d'un Service Pack Exchange ou de l'installation d'un ensemble de mises à jour.

Remarque :
Vous devez corriger cette incohérence dès que possible. N'installez pas de Service Pack ou de mise à jour d'Exchange Server avant d'avoir remédié à ce problème.

Pour effectuer la procédure suivante, vous devez utiliser un éditeur Active Directory tel qu'ADSI Edit ou l'outil LDP (ldp.exe).

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Modifiez la valeur de msExchDataPath du serveur virtuel Exchange affecté pour qu'elle corresponde à la valeur de DestPath du Registre de cluster. L'attribut msExchDataPath peut se trouver dans : CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation=Groupes_administration, CN=Nom_groupe_administration, CN=Serveurs, CN=Nom_serveur

  2. Redémarrez la ressource Surveillance du système Exchange du serveur virtuel pour que la modification soit prise en compte.

Pour plus d'informations sur la modification d'Active Directory à l'aide de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation d'ADSI Edit pour modifier l'attribut msExchDataPath, voir l'article 288362 de la Base de connaissances sur le message « Le système ne trouve pas le chemin d'accès spécifié » (ID d'événement 5007) qui est consigné par le service Surveillance du système Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362).


La réplication des journaux d'événements est activée
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante sur chaque serveur étant un nœud de cluster :

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

Remarque :
X est le numéro du nœud et commence par 1.

Si Exchange Server Analyzer détecte que la valeur de EnableEventLogReplication est de 1, il affiche un message de recommandation.

Si l'entrée de Registre EnableEventLogReplication est définie sur 1, le nœud de cluster réplique les événements du journal d'événements dans tous les autres nœuds du cluster. Si la réplication des journaux d'événements est activée, les outils qui contrôlent plusieurs serveurs, tels que Microsoft Operations Manager (MOM), signalent plusieurs fois un seul événement, une fois pour chaque nœud. Si vous effectuez un contrôle automatisé, il est conseillé de désactiver la réplication des journaux d'événements dans les nœuds de cluster.

Pour désactiver la réplication des journaux d'événements sur tous les nœuds d'un cluster

  1. Connectez-vous à un nœud du cluster avec un compte d'utilisateur de domaine ou membre d'un groupe global.

  2. Cliquez sur Démarrer, puis sur Exécuter et entrez

    cluster /prop EnableEventLogReplication=0
Pour désactiver la réplication des journaux d'événements sur un seul nœud de cluster

  1. Connectez-vous à un nœud du cluster avec un compte d'utilisateur de domaine ou membre d'un groupe global.

  2. Cliquez sur Démarrer, puis sur Exécuter et entrez

    Cluster <nom_du_nœud_à_désactiver> /prop EnableEventLogReplication=0

Pour plus d'informations sur la configuration de la réplication des journaux d'événements, voir l'article 224969 de la Base de connaissances Microsoft sur la procédure de configuration de la réplication des journaux d'événements dans Windows 2000 Cluster Servers (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224969).

Pour plus d'informations sur l'administration des clusters de serveurs, voir le document sur l'administration de clusters de serveurs (http://go.microsoft.com/fwlink/?LinkId=45971).


Désactivation de Kerberos sur la ressource de nom de réseau
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécuté sur le serveur :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute un système d'exploitation Windows 2000 Server et une valeur de 5.2, qu'il exécute un système d'exploitation Windows Server™ 2003.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Exchange Server 2003.

Exchange Server Analyzer lit enfin la valeur de Registre suivante pour déterminer si Exchange Server s'exécute dans un cluster avec une ressource de nom de réseau Kerberos :

HKLM\Cluster\Resources\<GUID de ressource de nom de réseau>\Parameters\RequireKerberos

Une valeur RequireKerberos de 0 indique que la ressource de nom de réseau n'est pas activée pour Kerberos et une valeur de 1 indique que la ressource de nom de réseau est activée pour Kerberos.

Si Exchange Server Analyzer détecte que la valeur de RequireKerberos est définie sur 0 sur un serveur virtuel Exchange Server 2003 qui s'exécute dans un cluster Windows Server 2003, un avertissement s'affiche.

Cet avertissement indique qu'une ressource de cluster de nom de réseau Kerberos n'est pas utilisée pour un serveur virtuel Exchange Server 2003. Cette configuration n'est pas prise en charge et doit être corrigée dès que possible.

Pour supprimer cet avertissement

  1. Ouvrez le programme Administrateur de cluster.

  2. Mettez hors connexion la ressource de nom de réseau. Ceci comprend également toutes les ressources hors connexion qui dépendent de la ressource de nom de réseau, notamment la ressource du service Surveillance du système Microsoft Exchange.

  3. Cliquez avec le bouton droit sur la ressource de nom de réseau, puis cliquez sur Propriétés.

  4. Sous l'onglet Paramètres, cliquez sur l'option Activer l'authentification Kerberos, puis sur OK.

  5. Mettez en ligne la ressource de nom de réseau, puis les autres ressources hors connexion.

Pour plus d'informations sur l'utilisation de ressources de nom de réseau Kerberos dans un cluster Windows Server 2003, voir l'article 302389 de la Base de connaissances Microsoft sur la description des propriétés de la ressource de nom de réseau de clusters dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389).

Pour plus d'informations sur les clusters, voir les rubriques suivantes sur :

  • le déploiement d'Exchange 2003 dans un cluster du Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47569)

  • la rubrique sur la planification du clustering Exchange du Guide sur la disponibilité élevée Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47571)


Activation de Kerberos sur la ressource de nom de réseau
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécuté sur le serveur :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute un système d'exploitation Windows 2000 Server et une valeur de 5.2, qu'il exécute un système d'exploitation Windows Server™ 2003.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Exchange Server 2003.

Exchange Server Analyzer lit enfin la valeur de Registre suivante pour déterminer si Exchange s'exécute dans un cluster avec une ressource de nom de réseau Kerberos :

HKLM\Cluster\Resources\<GUID de ressource de nom de réseau>\RequireKerberos

Une valeur RequireKerberos de 0 indique que la ressource de nom de réseau n'est pas activée pour Kerberos et une valeur de 1 indique que la ressource de nom de réseau est activée pour Kerberos.

Si Exchange Server Analyzer détecte que la valeur RequireKerberos est définie sur 1 sur un serveur virtuel Exchange 2000 Server qui s'exécute dans un cluster Windows 2000 Server, un avertissement s'affiche.

Cet avertissement indique qu'une ressource de cluster de nom de réseau Kerberos est utilisée pour un serveur virtuel Exchange 2000 Server. Cette configuration n'est pas prise en charge et doit être corrigée dès que possible. Comme l'indique l'article 235529 de la Base de connaissances Microsoft sur la prise en charge de Kerberos sur des clusters de serveur Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529), l'authentification Kerberos d'une ressource de nom de réseau Exchange 2000 Server n'est pas prise en charge. Exchange 2000 Server n'a pas été testé pour garantir qu'un serveur virtuel en clusters Exchange 2000 Server prend en charge l'authentification Kerberos.

Pour supprimer cet avertissement

  1. Ouvrez une invite de commandes sur n'importe quel nœud du cluster.

  2. Exécutez la commande suivante : cluster res "Nom de la ressource de nom de réseau" /priv requirekerberos=0:dword

    Remarque :
    Le nom de la ressource doit être placé entre guillemets.

  3. Utilisez la ressource de nom de réseau hors connexion et supprimez-la.

  4. Ouvrez le composant Utilisateurs et ordinateurs Active Directory.

  5. Localisez l'objet de compte d'ordinateur pour la ressource de nom de réseau supprimée et supprimez-le d'Active Directory.

  6. Créez une nouvelle ressource de nom de réseau pour ce serveur virtuel Exchange et n'activez pas Kerberos. Vous pouvez utiliser le même nom et la même configuration que la ressource de nom de réseau supprimée à l'étape 3.

  7. Utilisez la nouvelle ressource de nom de réseau en ligne, puis placez les autres ressources sur le serveur virtuel Exchange en ligne.

Pour plus d'informations sur l'utilisation de ressources de nom de réseau Kerberos dans un cluster Windows 2000 Server, voir l'article 235529 de la Base de connaissances Microsoft sur la prise en charge de Kerberos sur des clusters de serveur Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529).


MSDTC semble être manquant dans un cluster
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la ressource MSDTC (Microsoft Distributed Transaction Coordinator) existe dans un cluster :

HKEY_LOCAL_MACHINE\Cluster\Resources\

Exchange Server Analyzer affiche un avertissement si la valeur de ClusterMSDTCInstance est 0.

La ressource MSDTC doit être présente dans un cluster Exchange Server pour prendre en charge l'installation initiale et les mises à niveau des Service Packs. Toutefois, elle n'est pas un composant essentiel, ni obligatoire lorsqu'Exchange est en cours d'exécution.

Vous ou un autre administrateur de votre organisation avez peut-être supprimé la ressource MSDTC, sachant qu'elle n'est pas obligatoire lorsqu'Exchange est en cours d'exécution.

Toutefois, il est recommandé de ne pas supprimer la ressource MSDTC après la configuration initiale d'Exchange Server 2003. Si vous gardez la ressource MSDTC dans le cluster, vous pourrez exécuter l'installation des Service Packs et autres mises à jour.

Pour résoudre cet avertissement, créez une nouvelle ressource MSDTC. Pour obtenir la procédure spécifique de création d'une ressource MSDTC, voir la rubrique sur la procédure d'installation de MSDTC dans un cluster de serveurs Windows Server 2003 dans la section sur le déploiement d'Exchange 2003 dans un cluster du Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations

Pour plus d'informations sur MSDTC et Exchange, voir la rubrique sur les groupes de clusters dans la section sur la présentation des clusters Exchange Server 2003 du Guide sur la disponibilité élevée Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571).

Pour plus d'informations sur la procédure d'ajout de la ressource MSDTC dans Microsoft Windows Server™ 2003, voir l'article 301600 de la Base de connaissances Microsoft sur la procédure de configuration de Microsoft Distributed Transaction Coordinator sur un cluster Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Remarque :
L'article 301600 de la Base de connaissances Microsoft fait référence à l'article 817064 sur la procédure d'activation de l'accès DTC réseau dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). Il est déconseillé pour la sécurité d'Exchange Server d'activer l'accès DTC réseau pour un cluster Exchange. Si vous configurez la ressource Distributed Transaction Coordinator pour un cluster Exchange, n'activez pas l'accès DTC réseau.


Les pannes MSDTC affectent le groupe de clusters
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si votre configuration est telle qu'une défaillance de la ressource MSDTC (Microsoft Distributed Transaction Coordinator) affecte le groupe :

HKEY_LOCAL_MACHINE\Cluster\Resources\

Si la valeur de ClusterMSDTCInstance est 2, Exchange Server Analyzer affiche un avertissement.

La ressource MSDTC doit être présente dans un cluster Exchange pour prendre en charge l'installation initiale et les mises à niveau des Service Packs. Toutefois, elle n'est pas obligatoire lorsqu'Exchange est en cours d'exécution.

Par défaut, une défaillance de la ressource MSDTC affecte le groupe. Voici deux exemple de défaillance de la ressource :

  • La taille du fichier journal dépasse la capacité du disque.

  • Le disque physique pour la ressource MSDTC échoue.

En particulier, une défaillance de la ressource MSDTC provoque un basculement de tous les services Exchange qui ne sont pas exécutés sur ce nœud de cluster vers un autre nœud du cluster. Toutefois, comme la ressource MSDTC n'est pas une ressource obligatoire, elle ne doit pas être configurée de sorte à affecter le groupe.

Pour résoudre cet avertissement, configurez le cluster Exchange de sorte qu'une défaillance de la ressource MSDTC n'affecte pas le groupe.

Pour configurer Exchange de sorte qu'une défaillance de la ressource MSDTC n'affecte pas le groupe

  1. Connectez-vous à n'importe quel nœud du cluster.

  2. Cliquez sur Démarrer, pointez sur Tous les programmes et sur Outils d'administration, puis cliquez sur Administrateur de cluster.

  3. Sous Groupes, cliquez avec le bouton droit sur le groupe de clusters qui contient la ressource MSDTC.

  4. Cliquez avec le bouton droit sur la ressource MSDTC, puis cliquez sur Propriétés.

  5. Sous l'onglet Avancé, désactivez la case à cocher Affecter le groupe, puis cliquez sur OK.

Pour plus d'informations

Pour obtenir la procédure spécifique de création d'une ressource MSDTC, voir la section sur la procédure d'installation de MSDTC dans un cluster de serveurs Windows Server 2003 dans la rubrique sur le déploiement d'Exchange 2003 dans un cluster du Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur MSDTC et Exchange, voir la section sur les groupes de clusters dans la rubrique sur la présentation des clusters Exchange Server 2003 du Guide sur la disponibilité élevée Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571).

Pour plus d'informations sur la procédure d'ajout de la ressource MSDTC dans Microsoft Windows Server™ 2003, voir l'article 301600 de la Base de connaissances Microsoft sur la procédure de configuration de Microsoft Distributed Transaction Coordinator sur un cluster Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600).

Remarque :
L'article 301600 de la Base de connaissances Microsoft fait référence à l'article 817064 sur la procédure d'activation de l'accès DTC réseau dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064). Il est déconseillé pour la sécurité d'Exchange Server d'activer l'accès DTC réseau pour un cluster Exchange. Si vous configurez la ressource Distributed Transaction Coordinator pour un cluster Exchange, n'activez pas l'accès DTC réseau.


Les pannes du MTA affectent le groupe de clusters
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool examine les paramètres du Registre Cluster\Resources du système du serveur Exchange.

HKEY_LOCAL_MACHINE\Cluster\Resources

Si Exchange Server Analyzer détecte que les ressources du service des piles de l'Agent de transfert des messages (MTA) sont exécutées sur le cluster Exchange Server 2003 dans une organisation en mode natif, il affiche un message de recommandation.

Il est recommandé que l'administrateur Exchange configure la ressource MTA de manière à ce que le MTA ne provoque pas un éventuel basculement du serveur virtuel Exchange en cas d'arrêt ou d'échec du MTA.

Remarque :
Le service des piles MTA de Microsoft Exchange 2000 Server et Microsoft Exchange Server 2003 est fréquemment utilisé pour fournir des services de transfert de messages à compatibilité descendante entre les serveurs Exchange 2000 Server ou Exchange Server 2003 et les serveurs Microsoft Exchange Server 5.5 dans un environnement en mode mixte. En cas de transition vers un environnement pur en mode natif Exchange 2000 Server ou Exchange Server 2003, le MTA n'est pas une ressource essentielle pour l'exécution des services Exchange.

En cas d'arrêt ou d'échec du service des piles MTA, un basculement du serveur virtuel Exchange peut éventuellement survenir. Pour éviter ce problème, il est recommandé de configurer le service des piles MTA pour éviter tout basculement en procédant comme suit.

Pour configurer le service des piles MTA dans un état qui n'est pas affecté dans un cluster de serveurs Exchange

  1. Ouvrez Cluster Administrator

  2. Désactivez l'option Affect this Group pour la ressource du service des piles MTA.

Pour plus d'informations

Pour plus d'informations sur les instructions de prise en charge du service des piles MTA pour Exchange Server 2003, voir l'article 810489 de la Base de connaissances Microsoft sur les instructions de prise en charge du service des piles MTA pour Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489).

Pour plus d'informations sur le MTA dans l'architecture Exchange Server 2003, voir la rubrique sur le MTA Exchange dans l'architecture Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=63496).

Pour plus d'informations sur la procédure de déploiement d'Exchange Server 2003 dans un cluster, voir la rubrique sur le déploiement d'Exchange Server 2003 dans un cluster (http://go.microsoft.com/fwlink/?LinkId=63495).

Pour plus d'informations sur l'utilisation de l'administrateur de cluster, voir la rubrique sur l'utilisation de l'administrateur de cluster pour la gestion de clusters Exchange (http://go.microsoft.com/fwlink/?LinkId=63493).


Il s'agit d'un cluster actif/actif à 2 nœuds
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2006-04-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started de ClusSvc, le service de cluster. La valeur True indique que le service de cluster est en cours d'exécution et la valeur False indique qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer le nombre de nœuds du cluster :

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <numéro du nœud> \NodeName

Le nombre d'instances de NodeName représente le nombre de nœuds du cluster. Exchange Server Analyzer lit en outre l'entrée de Registre suivante pour déterminer le nombre de ressources Exchange Server du cluster :

HKLM\Cluster\Resources\ <GUID de ressource de cluster> \Parameters\DestPath

Les ressources suivantes sur un cluster Exchange Server ont une valeur DestPath :

  • Agent de transfert des messages de Microsoft Exchange

  • Banque d'informations de Microsoft Exchange

Le nombre d'instances de DestPath indique le nombre de serveurs virtuels Exchange exécutés dans le cluster.

Si Exchange Server Analyzer détecte 3 instances de DestPath dans un cluster comportant 2 instances de NodeName, un avertissement s'affiche. Cet avertissement indique qu'il s'agit d'un cluster à deux nœuds avec deux serveurs virtuels Exchange, appelé cluster actif/actif.

  • Dans le modèle de cluster actif/actif, le nombre de serveurs virtuels Exchange dans le cluster est égal ou supérieur au nombre de nœuds physiques du cluster.

Remarque :
Les clusters Exchange actifs/actifs peuvent être créés uniquement dans des clusters constitués de deux nœuds. Si vous avez plus de deux nœuds dans votre cluster, vous devez utiliser le modèle actif/passif.
  • Dans le modèle de cluster actif/passif, le nombre de serveurs virtuels Exchange dans le cluster est inférieur au nombre de nœuds physiques du cluster.

Bien que Microsoft prenne en charge le service de cluster actif/actif pour le serveur Exchange, il est vivement recommandé d'utiliser des implémentations actives/passives pour les clusters Exchange. Microsoft prend en charge uniquement les clusters Exchange actifs/actifs qui satisfont aux limites d'échelle suivantes :

  • Le nombre de connexions utilisateur simultanées par serveur virtuel Exchange par nœud physique ne doit jamais dépasser 1 900. Si un nœud du cluster n'est pas disponible alors que tous les serveurs virtuels Exchange sont en ligne sur un nœud unique, les limites d'échelle restent à 3 800 connexions pour les deux serveurs virtuels Exchange. Chaque utilisateur pouvant effectuer plusieurs connexions, le nombre de boîtes aux lettres ne permet pas d'estimer correctement le nombre de connexions.

  • L'utilisation moyenne du processeur par processus store d'Exchange ne doit pas dépasser 40 pour cent. Si l'utilisation totale du processeur par le processus STORE.EXE sur un nœud est supérieure à 40 pour cent pendant au moins 10 minutes, vous devez déplacer les utilisateurs vers un autre serveur Exchange virtuel ou non. Notez que cette charge n'inclut pas l'utilisation du processeur par les tâches administratives.

La migration d'une configuration de cluster actif/actif vers une configuration active/passive implique de retirer des ressources du deuxième serveur virtuel Exchange pour ensuite le désactiver.

Pour migrer d'un cluster actif/actif vers un cluster actif/passif

  1. Déplacez les boîtes aux lettres hébergées sur le second serveur virtuel Exchange vers le premier serveur virtuel Exchange du cluster. Le premier serveur virtuel Exchange du cluster contient toujours la seule ressource MTA Microsoft Exchange du cluster.

  2. Après le déplacement de toutes les boîtes aux lettres vers le premier serveur virtuel Exchange, mettez le second serveur hors connexion.

  3. Supprimez le second serveur virtuel Exchange en effectuant l'une des opérations suivantes :

    • Dans un cluster Exchange Server 2003, cliquez avec le bouton droit sur la ressource du service Surveillance du système Microsoft Exchange et cliquez sur Supprimer le serveur virtuel Exchange.

    • Dans un cluster Exchange 2000 Server, cliquez avec le bouton droit sur la ressource du service Surveillance du système Microsoft Exchange et cliquez sur Supprimer.

  4. Vérifiez que l'objet Serveur virtuel Exchange a été supprimé du service d'annuaire Active Directory®. En raison de modifications des autorisations du compte de service de cluster dans Exchange Server 2003, votre compte doit avoir l'autorisation de supprimer des objets Active Directory.

  5. Mettez hors connexion les ressources restantes du second serveur virtuel Exchange (par exemple, le disque physique, le nom de réseau et l'adresse IP), puis supprimez-les.

  6. Supprimez le groupe de ressources qui contenait le deuxième serveur virtuel Exchange.

Pour plus d'informations sur la suppression d'un serveur virtuel Exchange, voir la rubrique sur la suppression d'un serveur virtuel Exchange d'un cluster dans le manuel en ligne sur le déploiement de clusters Exchange dans Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=9393).

Pour plus d'informations sur les meilleures pratiques et les recommandations pour les clusters Exchange, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur le déploiement d'Exchange sur un cluster de serveurs Windows, voir l'article 815180 de la Base de connaissances Microsoft sur les considérations lors du déploiement d'Exchange sur un cluster actif/actif (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815180).


Journal quorum trop petit
Microsoft Exchange Server Analyzer - Articles > Cluster Exchange >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la taille du journal quorum configuré pour le cluster :

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

Si Exchange Server Analyzer détecte que la valeur de MaxQuorumLogSize est inférieure à la décimale 4194304 (hexadécimale 0x400000), un avertissement s'affiche.

La valeur de Registre MaxQuorumLogSize représente la valeur actuellement configurée du paramètre de quorum de cluster Réinitialiser le journal quorum à. Cet avertissement apparaît si la valeur MaxQuorumLogSize est inférieure à 4 096 Ko.

Le cluster enregistre toutes les modifications dans la base de données de cluster dans le fichier journal quorum. Lorsque le journal quorum atteint la taille spécifiée, le cluster enregistre la base de données et réinitialise le fichier journal. La taille limite du journal quorum par défaut sur les clusters basés sur Microsoft Windows® 2000 Server est fixée à 64 Ko. La taille limite du journal quorum par défaut sur les clusters basés sur Windows Server™ 2003 est fixée à 4 096 Ko. Pour les clusters Exchange Server, il est recommandé de configurer la propriété Réinitialiser le journal quorum à sur 4 096 Ko. Cette opération permet de s'assurer que l'espace est suffisant pour contenir les informations de configuration de cluster, telles que les serveurs faisant partie du cluster, les ressources installées sur le cluster et leur état (par exemple, en ligne ou hors connexion).

Pour supprimer cet avertissement

  1. Ouvrez Administrateur de cluster.

  2. Dans le volet gauche, cliquez avec le bouton droit sur l'objet représentant le cluster, puis cliquez sur Propriétés.

  3. Sous l'onglet Quorum, configurez Réinitialiser le journal quorum à sur la valeur 4096.

  4. Cliquez sur OK pour enregistrer les modifications.

Pour plus d'informations sur la taille limite du journal quorum par défaut, voir l'article 225081 de la Base de connaissances Microsoft sur la définition sur 64 Ko de la taille par défaut du journal quorum des ressources de cluster (http://go.microsoft.com/fwlink/?linkid=3052&kbid=225081).


Exchange Server
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant les ordinateurs Exchange Server. En outre, ils décrivent les actions possibles pour corriger les erreurs liées à Exchange, les avertissements et les configurations autres que celles par défaut détectés par Exchange Server Analyzer.


Verrouillage de compte installé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-08-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer si un fichier nommé ALockout.dll existe dans le dossier System32 sur le serveur Exchange. ALockout.dll fait partie des outils de gestion et de verrouillage de compte Account Lockout and Management Tools (ALTools.exe). Ces outils aident les administrateurs à gérer les comptes et à résoudre les problèmes de verrouillage de compte.

Si Exchange Server Analyzer détecte qu'ALockout.dll est présent sur un serveur Exchange, il affiche une erreur.

Les outils de gestion et de verrouillage de compte Account Lockout and Management Tools ne doivent pas être utilisés sur des serveurs qui hébergent des applications ou des services, notamment des serveurs Exchange. S'ils sont installés sur un serveur Exchange, ils peuvent empêcher le démarrage des services Exchange. Par conséquent, il est vivement recommandé de les désinstaller de ce serveur Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour corriger cette erreur

  1. À l'invite de commandes, entrez regsvr32 /u alockout.dll.

  2. Supprimez la valeur ALockout.dll située sous la clé de Registre suivante : HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
Remarque :
Une fois la valeur ALockout.dll supprimée, l'entrée de Registre AppInit_DLLs est vide. Redémarrez l'ordinateur.
  1. Supprimez le fichier ALockout.dll du dossier System32.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les outils de gestion et de verrouillage de compte Account Lockout and Management Tools, voir la section sur les outils de verrouillage de compte du document sur les stratégies et mots de passe de compte (http://go.microsoft.com/fwlink/?LinkId=52465).


Non-correspondance du site Active Directory
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool met en œuvre la fonction DsGetSiteName Win32 API pour demander le nom du site du service d'annuaire Active Directory® du contrôleur de domaine et le nom du site Active Directory du serveur Exchange Server local.

Si Exchange Server Analyzer détermine que le nom du site Active Directory du contrôleur de domaine et le nom du site Active Directory du serveur Exchange Server local ne correspondent pas, il affiche un avertissement.

Cet avertissement indique que le processus DSAccess (Directory Service Access) sort du site local Active Directory pour ses requêtes LDAP (Lightweight Directory Access protocol), pouvant entraîner de graves problèmes de performances d'Exchange Server.

Cette situation peut être due à la configuration statique d'un contrôleur de domaine hors site ou d'un réseau ; à l'arrêt d'un ordinateur de contrôleur de domaine à cause duquel le contrôleur de domaine résidant sur le site ne peut pas être atteint ; ou à la conception incorrecte d'une topologie Active Directory qui ne comprend pas de contrôleur de domaine Active Directory dans le même site qu'Exchange Server.

DSAccess est un composant Exchange Server partagé qui a accès aux informations d'annuaire et les stocke dans un cache. DSAccess détecte de manière dynamique les serveurs d'annuaire que d'autres composants Exchange doivent contacter, sur la base de critères tels que la configuration du site Active Directory et la disponibilité du serveur Active Directory. Des serveurs frontaux Exchange utilisent DSAccess pour déterminer le serveur qui contient la boîte aux lettres d'un utilisateur particulier, les adresses SMTP (Simple Mail Transfer Protocol) qui existent pour un objet utilisateur et les serveurs qui contiennent des banques de dossiers publics.

Lors de l'initialisation, si DSAccess ne trouve pas un ensemble de contrôleurs de domaine ou de catalogues globaux configurés statiquement dans le Registre, DSAccess utilise un processus de découverte pour identifier la topologie réseau et évaluer la disponibilité et la configuration des serveurs d'annuaire. Pour déterminer la configuration d'un contrôleur de domaine, vérifiez si le contrôleur de domaine se trouve dans le même site Active Directory qu'Exchange Server.

Pour réduire la latence pouvant être introduite par des requêtes LDAP inter-site, les serveurs Exchange doivent se trouver dans un site Active Directory possédant un contrôleur de domaine résidant.

Pour résoudre ce problème :

  • Évaluez les définitions de site pour la topologie Active Directory pour vérifier que chaque serveur Exchange Server a accès à un contrôleur de domaine dans le même site Active Directory.

  • Vérifiez que tout contrôleur de domaine configuré statiquement réside dans le même site Active Directory qu'Exchange Server.

Pour plus d'informations

Pour plus d'informations sur la procédure de configuration et de dépannage de DSAccess, voir les ressources Exchange suivantes :

  • la rubrique sur l'intégration d'annuaire et Exchange Server (http://go.microsoft.com/fwlink/?LinkId=63447)

  • la rubrique sur la compréhension et la résolution des problèmes d'accès à l'annuaire (http://go.microsoft.com/fwlink/?LinkId=39012)

  • l'article 250570 de la Base de connaissances Microsoft sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570)


Partages de fichiers administratifs désactivés
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les partages administratifs par défaut ont été désactivés :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

Si Exchange Server Analyzer détecte que la valeur de AutoShareServer est définie sur 0, une erreur s'affiche.

Cette erreur indique que les partages administratifs par défaut créés par le serveur ont été désactivés sur ce même serveur. Une restauration ou sauvegarde en ligne d'Exchange Server peut ne pas être effectuée si les partages administratifs par défaut ont été désactivés. Selon l'utilitaire de sauvegarde, vous pouvez recevoir les messages d'erreur lorsque vous tentez de restaurer les données. Vous pouvez également les recevoir dans le journal de sauvegarde de la bande.

En outre, lorsque les partages administratifs ont été supprimés, vous pouvez recevoir le message suivant lors d'une sauvegarde en ligne d'Exchange Server : Erreur inattendue (0xc0040000) : L'ordinateur Microsoft Exchange Server n'est pas disponible. Pour résoudre ce problème, il est recommandé de réactiver les partages administratifs par défaut en modifiant le Registre et en redémarrant le service Serveur.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur AutoShareServer.

  4. Définissez la valeur sur 1.

  5. Fermez l'Éditeur du Registre et redémarrez le service Serveur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la restauration des partages administratifs par défaut dans Microsoft Windows Server™ 2003, voir l'article 816113 de la Base de connaissances sur l'utilisation de l'Éditeur du Registre pour restaurer les partages administratifs dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113).


Interopérabilité du pilote AFD.SYS et du connecteur X.400
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version de Microsoft Windows® exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur Exchange Server est exécuté sur Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que l'ordinateur Exchange Server exécute Windows 2000 Server et la valeur 5.2, qu'il exécute Windows Server™ 2003.

Exchange Server Analyzer interroge également la classe WMI (Windows Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur de la clé NumberOfProcessors. Cette valeur représente le nombre de processeurs installés sur l'ordinateur. Ces processeurs comprennent des processeurs physiques et logiques. Un processeur physique peut être divisé en deux processeurs logiques à l'aide de la technologie Hyper-Threading d'Intel.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si Exchange Server est un serveur tête de pont pour un connecteur X.400 :

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows Management Instrumentation) CIM_Datafile pour déterminer la valeur de la clé Version pour un fichier appelé Afd.sys.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • L'ordinateur Exchange Server est exécuté sur Windows Server 2000.

  • La valeur de NumberOfProcessors est supérieure à 1.

  • Exchange Server est un serveur tête de pont pour un connecteur X.400.

  • La valeur de la clé Version de WINDOWSPATH%\\system32\\drivers\\afd.sys est comprise entre 5.0.2195.7036 et 5.0.2195.7060.

Cet avertissement indique que la version d'Afd.sys installée sur le serveur peut provoquer des problèmes de flux de messagerie avec les connecteurs X.400 hébergés sur ce serveur.

Pour résoudre ce problème, utilisez la mise à jour décrite dans l'article 904712 de la Base de connaissances Microsoft sur la remise du courrier qui est plus lente que prévu ou sur les arrêts de remise de courrier sur un connecteur X.400 vers un site distant dans Exchange Server 5.5 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712).


L'intervalle Aging Keep Time de la base de données n'est pas configuré par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchAgingKeepTime a été défini. Cet attribut représente le délai utilisé pour déterminer le moment de la suppression des index, des vues et des catégorisations. Si Exchange Server Analyzer détecte que cet attribut est défini, un message indiquant une configuration autre que celle par défaut s'affiche.

Les index utilisés dans les vues qui sont créés par un client Exchange dans les tables de base de données Exchange et qui sont inutilisées depuis un certain temps seront nettoyés. L'attribut msExchAgingKeepTime spécifie l'âge minimal requis de l'index avant sa suppression. La valeur par défaut dans la version originale d'Exchange 2000 Server était de huit jours. Dans le Service Pack 1 (SP1) d'Exchange 2000 Server et dans toutes les versions ultérieures d'Exchange Server, notamment Exchange Server 2003 et Exchange Server 2007, la valeur par défaut est de 40 jours.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Affichage ou modification de la valeur Aging Keep Time

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Développez CN=<Nom_serveur>, CN=Banque_informations, puis sélectionnez CN=<Nom_groupe_stockage>.

  5. Dans le volet Détails, cliquez avec le bouton droit sur CN=<Nom_banque_boîtes_aux_lettres> puis cliquez sur Propriétés.

  6. Dans l'Éditeur d'attribut, cliquez sur l'attribut msExchAgingKeepTime, puis sur Modifier.

  7. Dans la boîte de dialogue Modifier l'attribut, cliquez sur Effacer pour effacer la valeur.

  8. Cliquez sur Appliquer, puis sur OK.

  9. Fermez ADSI Edit. Si une modification est effectuée, redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil LDP, consultez l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objet Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur les problèmes possibles lors de l'accès aux dossiers de la banque d'informations dans Exchange Server, consultez l'article 216076 de la Base de connaissances Microsoft sur l'accès aux dossiers de la banque d'informations, qui peut devenir lent dans Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=216076).


Mise à jour d'Antigen disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-06-20

L'outil Microsoft Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft® CIM_Datafile pour déterminer la valeur de la clé Version pour MimeNavigator.dll. Ce module est présent dans les versions 8 et 9 de Microsoft Antigen.

Si Exchange Analyzer trouve que la valeur de la clé Version pour MimeNavigator.dll est inférieure à 8.00.1517.0 pour la version 8 et à 9.00.1055.0 pour la version 9, il affiche un avertissement.

Cet avertissement indique que Microsoft Antigen version 8 ou 9 est installé sur le serveur Exchange et qu'une mise à jour logicielle est disponible. Cette mise à jour est vivement recommandée et permet d'améliorer les performances et la fiabilité générales du serveur.

Pour résoudre ce problème, consultez et appliquez les recommandations de l'article 928082 de la Base de connaissances Microsoft sur l'augmentation possible de la taille des messages SMTP lors de l'analyse d'Antigen.


Taille du journal des applications
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-11-09

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la taille maximale du fichier journal des applications :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

Si Exchange Server Analyzer détecte que la valeur de MaxSize est inférieure à 41 943 040 octets (40 mégaoctets), il affiche un message de recommandation.

Par défaut, la taille maximale du fichier journal des applications est de 16 777 216 octets (16 384 Ko) pour Windows Server 2003 et de 524 288 octets (512 Ko) pour Windows 2000 Server. Pour les ordinateurs exécutant Exchange Server, il est recommandé de définir la taille maximale du fichier journal des applications sur 40 Mo (40 960 Ko) ou plus. En augmentant la taille du fichier journal des applications, vous conservez davantage d'événements Applications. Les informations d'événement supplémentaires vous aident lors du dépannage.

Pour augmenter la taille maximale du journal des applications

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Observateur d'événements.

  2. Cliquez avec le bouton droit sur le journal Application, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Taille du journal, entrez 40960 ou plus dans la zone Taille maximale du journal puis cliquez sur OK.


ASP.NET Rootver endommagé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de la clé Rootver d'ASP.NET :

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes existent :

  • Exchange Server Analyzer détecte que la valeur Rootver est définie sur 0.0.0.0.

  • Le service de cluster est exécuté.

Parfois, l'installation d'ASP.NET échoue sans afficher de message d'échec. Dans de tels cas, la clé Rootver est définie sur 0.0.0.0. La définition de la valeur Rootver sur 0.0.0.0 empêche le démarrage du service Surveillance du système Microsoft Exchange ou d'autres services d'Exchange Server sur des clusters Exchange Server 2003 et Exchange Server 2007. Pour corriger cette erreur, définissez Rootver sur l'une des valeurs suivantes :

  • Clé Rootver d'Exchange Server 2003 = 1.1.4322.0.

  • Clé Rootver d'Exchange Server 2007 = 2.0.50727.0

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Définition de Rootver sur 1.1.4322.0

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\ASP.NET\

  3. Dans le volet Détails, double-cliquez sur la clé RootVer.

  4. Dans la boîte de dialogue Modification de la chaîne, définissez Données de la valeur sur la valeur appropriée de l'article ci-dessus, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le débogage automatique du système d'exploitation a été désactivé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le débogage du système d'exploitation a été désactivé :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

Si Exchange Server Analyzer détecte que la valeur de Auto est définie sur 0, un avertissement s'affiche.

Par défaut, un débogueur d'application appelé Dr. Watson est installé en même temps que les systèmes d'exploitation Microsoft Windows® 2000 Server et Windows Server™ 2003. Un débogueur est un programme permettant de détecter, localiser et corriger les erreurs d'un autre programme grâce à l'activation d'un programmeur, qui parcourt le programme, examine les données et contrôle les conditions, telles que les valeurs des variables.

Les options par défaut sont définies lors de la première exécution de Dr. Watson, c'est-à-dire lorsqu'une erreur de programme se produit ou lorsque vous démarrez Dr. Watson vous-même.

Lorsqu'une erreur d'application se produit, Windows recherche un gestionnaire d'erreurs de programme. Un gestionnaire d'erreurs de programme traite les erreurs au fur et à mesure qu'elles se produisent lors de l'exécution d'un programme. Si Windows ne trouve pas de gestionnaire d'erreurs de programme, il vérifie que le programme n'est pas en cours de débogage et considère que l'erreur n'est pas traitée. Windows traite ensuite ces erreurs en recherchant dans le Registre un débogueur d'erreurs de programme.

Le comportement de Windows dépend des paramètres de deux valeurs de Registre sous : HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug

Les entrées s'appellent Debugger et Auto. La valeur de l'entrée Debugger spécifie la commande pour le débogueur à utiliser pour analyser les erreurs de programme. Si la valeur de l'entrée Debugger est détectée, Windows vérifie si la valeur de l'entrée Auto est définie sur 0 ou 1 :

  • Si la valeur de l'entrée Auto est définie sur 0, Windows génère une boîte de message indiquant qu'une erreur de programme s'est produite. Si la valeur de l'entrée Debugger spécifie la commande pour un débogueur valide, la boîte de message affiche deux boutons : OK et Annuler. Si vous cliquez sur OK, le programme est arrêté. Si vous cliquez sur Annuler, le débogueur spécifié démarre. Si la valeur de l'entrée Debugger est vide, la boîte de message n'affiche que OK et aucun débogueur ne démarre.

  • Si la valeur de l'entrée Auto est définie sur 1 et si la valeur de l'entrée Debugger spécifie la commande pour un débogueur valide, le système démarre automatiquement le débogueur et ne génère aucune boîte de message.

Lorsque Windows est installé, la valeur de l'entrée Auto est définie par défaut sur 1 et la valeur de l'entrée Debugger spécifie la commande de démarrage de Dr. Watson (drwtsn32 -p %ld -e %ld -g). Cela signifie que lorsqu'une erreur de programme se produit, Dr. Watson diagnostique automatiquement l'erreur et enregistre les informations de diagnostic appropriées.

Il est recommandé d'utiliser un débogueur d'erreurs de programme sur les ordinateurs Exchange Server. Si vous utilisez un autre programme que Dr. Watson comme débogueur par défaut et souhaitez plutôt utiliser Dr. Watson, accédez à l'invite de commandes et entrez la commande drwtsn32 -i pour démarrer Dr. Watson. Si vous entrez -i, les modifications requises sont apportées au Registre.

Pour enregistrer Dr. Watson comme débogueur par défaut à partir de l'invite de commandes

  1. Ouvrez une fenêtre d'invite de commandes.

  2. Exécutez la commande suivante : drwtsn32 -i

  3. Un message indiquant « Dr Watson a été installé en tant que débogueur par défaut » s'affiche. Cliquez sur OK pour accepter ce message.

Pour enregistrer Dr. Watson comme débogueur par défaut à partir de l'interface utilisateur

  1. Cliquez sur Démarrer, puis sur Exécuter, entrez drwtsn32, puis appuyez sur ENTRÉE. L'interface utilisateur Dr. Watson pour Windows s'affiche.

  2. Activez la case à cocher Créer un fichier de vidage sur incident.

  3. Cliquez sur OK pour enregistrer les modifications et fermer l'interface utilisateur Dr. Watson pour Windows.

Pour plus d'informations sur Dr. Watson pour Windows, voir le fichier d'aide de Dr. Watson en appuyant sur F1 dans l'interface utilisateur Dr. Watson.

Si vous pensez utiliser un autre débogueur d'erreurs de programme que Dr. Watson, vous pouvez désactiver Dr. Watson en utilisant la procédure de l'article 188296 de la Base de connaissances Microsoft sur la procédure de désactivation de Dr. Watson pour Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296).


La latence moyenne de lecture LDAP a dépassé 50 millisecondes
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-14

L'outil Microsoft Exchange Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance LDAP Read Time de l'objet de performance MSExchangeDSAccess Process pour les analyser.

Le compteur de performance LDAP Read Time indique le temps en millisecondes pour réaliser une demande de recherche LDAP (Lightweight Directory Access Protocol). Exchange Analyzer récupère un exemple toutes les 5 secondes pour une période de 5 minutes. Il signale ensuite la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Si la valeur moyenne dépasse 50 millisecondes, Exchange Analyzer affiche un avertissement.

Les latences élevées de lecture LDAP peuvent être dues à des latences élevées d'appel de procédure distante et par l'augmentation des files d'attente. Des latences élevées de lecture LDAP indiquent généralement l'un des problèmes suivants :

  • un problème de performance avec la connexion réseau au contrôleur de domaine ;

  • des problèmes de performance avec le contrôleur de domaine lui-même.

Remarque :
Les latences LDAP sont généralement supérieures lorsque des utilisateurs se connectent aux contrôleurs de domaine situés sur différents sites physiques. Cependant, les latences maximales conseillées citées dans cet article doivent généralement être respectées.

Si le contrôleur de domaine qui a enregistré cet avertissement est situé sur un autre site physique, il est possible que vous puissiez ignorer cette erreur en toute sécurité si vous pouvez déterminer que le contrôleur de domaine qui fait état de cet avertissement n'est pas utilisé par le serveur Exchange. Une manière de déterminer si un contrôleur de domaine est utilisé par Exchange est de régler l'enregistrement des diagnostics pour le composant Topologie du service MSExchangeDSAccess sur Minimum. Si vous ne voyez pas l'ID d'événement 2080 dans MSExchangeDSAccess, vous pouvez ignorer cet avertissement en toute sécurité.

Pour résoudre ce problème, procédez comme suit :

  • Vérifiez que toutes les connexions réseau au contrôleur de domaine sont opérationnelles et prennent en charge le trafic ICMP (Internet Control Monitoring Protocol).

  • Reportez-vous aux meilleures pratiques décrites dans les articles suivants :

    • Pour plus d'informations sur le compteur de performance LDAP Read Time et d'autres compteurs à utiliser pour résoudre les problèmes liés à Active Directory, voir la section sur la résolution des problèmes liés à Active Directory dans la rubrique sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588). Cet article contient également des informations sur la procédure d'amélioration des performances d'Active Directory.

    • Pour plus d'informations sur la procédure d'optimisation des performances d'Active Directory, voir la rubrique sur le réglage de l'intégration d'Active Directory dans le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Pour plus d'informations sur la garantie de la disponibilité élevée de vos serveurs Active Directory, voir la section sur la garantie d'un accès fiable à Active Directory et au système DNS dans la rubrique sur les mesures de tolérance de pannes au niveau système du Guide sur la disponibilité élevée Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Pour plus d'informations sur les considérations relatives à la bande passante du réseau, voir la section sur les performances réseau dans la rubrique sur la présentation des performances d'Exchange du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


La latence maximale de lecture LDAP a dépassé 100 millisecondes
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-14

L'outil Microsoft Exchange Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance LDAP Read Time de l'objet de performance MSExchangeDSAccess Process pour les analyser.

Le compteur de performance LDAP Read Time indique le temps en millisecondes pour réaliser une demande de recherche LDAP (Lightweight Directory Access Protocol). Exchange Analyzer récupère un exemple toutes les 5 secondes pour une période de 5 minutes. Il signale ensuite la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Si la valeur maximale dépasse 100 millisecondes, Exchange Analyzer affiche une erreur.

Les latences élevées de lecture LDAP peuvent être dues à des latences élevées d'appel de procédure distante et par l'augmentation des files d'attente. Des latences élevées de lecture LDAP indiquent généralement l'un des problèmes suivants :

  • un problème de performance avec la connexion réseau au contrôleur de domaine ;

  • des problèmes de performance avec le contrôleur de domaine lui-même.

Remarque :
Les latences LDAP sont généralement supérieures lorsque des utilisateurs se connectent aux contrôleurs de domaine situés sur différents sites physiques. Cependant, les latences maximales conseillées citées dans cet article doivent généralement être respectées.

Les serveurs Exchange interrogent les serveurs de catalogue global situés en dehors du domaine toutes les 15 minutes afin de maintenir à jour la liste des serveurs de catalogue global et des contrôleurs de domaine. Comme certains de ces serveurs d'annuaire peuvent être distants, les latences de ces requêtes peuvent être élevées. Cela est acceptable tant que les requêtes sont rares, c'est-à-dire tant que le taux est inférieur à 0,5 requêtes par seconde.

Si le contrôleur de domaine qui a enregistré cette erreur est situé sur un autre site physique, il est possible que vous puissiez ignorer cette erreur en toute sécurité si vous pouvez déterminer que le contrôleur de domaine qui fait état de cette erreur n'est pas utilisé par le serveur Exchange. Une manière de déterminer si un contrôleur de domaine est utilisé par Exchange est de régler l'enregistrement des diagnostics pour le composant Topologie du service MSExchangeDSAccess sur Minimum. Si vous ne voyez pas l'ID d'événement 2080 dans MSExchangeDSAccess, vous pouvez ignorer cette erreur en toute sécurité.

Important :
Pour les environnements en mode mixte uniquement, ce comportement a été présenté à peu près en même temps qu'Exchange 2000 SP2 pour certains attributs utilisateur spécifiques liés à la sécurité (tels que tokenGroups et tokengroupsGlobalandUniversal), qui permettent de déterminer les groupes de sécurité dont un utilisateur est membre et, par conséquent, les autorisations dont il dispose pour sécuriser les ressources (telles que les dossiers publics), qui nécessitent que le serveur Exchange interroge un contrôleur de domaine faisant autorité pour le domaine associé de l'utilisateur. Le contrôleur de domaine faisant autorité peut se situer dans un site distant et les requêtes à partir d'un grand nombre d'utilisateurs de domaines associés distants qui accèdent aux dossiers publics locaux peuvent contribuer aux latences RPC élevées.

Pour plus d'informations sur ce comportement, voir la rubrique suivante du blog Exchange Server :

  • Article sur Exchange qui n'utilise pas toujours les catalogues globaux locaux (en anglais)

    Remarque :
    Les liens vers les blogs sont fournis pour vous aider à trouver les informations techniques dont vous avez besoin. Le contenu de chaque blog et leur URL sont susceptibles d'être modifiés sans préavis.

Pour résoudre cette erreur, procédez comme suit :

  • Vérifiez que toutes les connexions réseau au contrôleur de domaine sont opérationnelles et prennent en charge le trafic ICMP (Internet Control Monitoring Protocol).

  • Reportez-vous aux meilleures pratiques décrites dans les articles suivants :

    • Pour plus d'informations sur le compteur de performance LDAP Read Time et d'autres compteurs à utiliser pour résoudre les problèmes liés à Active Directory, voir la section sur la résolution des problèmes liés à Active Directory dans la rubrique sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588). Cet article contient également des informations sur la procédure d'amélioration des performances d'Active Directory.

    • Pour plus d'informations sur la procédure d'optimisation des performances d'Active Directory, voir la rubrique sur le réglage de l'intégration d'Active Directory dans le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Pour plus d'informations sur la garantie de la disponibilité élevée de vos serveurs Active Directory, voir la section sur la garantie d'un accès fiable à Active Directory et au système DNS dans la rubrique sur les mesures de tolérance de pannes au niveau système du Guide sur la disponibilité élevée Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Pour plus d'informations sur les considérations relatives à la bande passante du réseau, voir la section sur les performances réseau dans la rubrique sur la présentation des performances d'Exchange du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


La latence moyenne de recherche LDAP a dépassé 50 millisecondes
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-14

L'outil Microsoft Exchange Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance LDAP Search Time de l'objet de performance MSExchangeDSAccess Process pour les analyser.

Le compteur de performance LDAP Search Time indique le temps en millisecondes pour réaliser une demande de recherche LDAP (Lightweight Directory Access Protocol). Exchange Analyzer récupère un exemple toutes les 5 secondes pour une période de 5 minutes. Il signale ensuite la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Si la valeur moyenne dépasse 50 millisecondes, Exchange Analyzer affiche un avertissement.

Les latences élevées de recherche LDAP peuvent être dues à des latences élevées d'appel de procédure distante et par l'augmentation des files d'attente. Des latences élevées de recherche LDAP indiquent généralement l'un des problèmes suivants :

  • un problème de performance avec la connexion réseau au contrôleur de domaine ;

  • des problèmes de performance avec le contrôleur de domaine lui-même.

Remarque :
Les latences LDAP sont généralement supérieures lorsque des utilisateurs se connectent aux contrôleurs de domaine situés sur différents sites physiques. Cependant, les latences maximales conseillées citées dans cet article doivent généralement être respectées.

Si le contrôleur de domaine qui a enregistré cet avertissement est situé sur un autre site physique, il est possible que vous puissiez ignorer cette erreur en toute sécurité si vous pouvez déterminer si le contrôleur de domaine qui fait état de cet avertissement n'est pas utilisé par le serveur Exchange. Une manière de déterminer si un contrôleur de domaine est utilisé par Exchange est de régler l'enregistrement des diagnostics pour le composant Topologie du service MSExchangeDSAccess sur Minimum. Si vous ne voyez pas l'ID d'événement 2080 dans MSExchangeDSAccess, vous pouvez ignorer cet avertissement en toute sécurité.

Pour résoudre ce problème, procédez comme suit :

  • Vérifiez que toutes les connexions réseau au contrôleur de domaine sont opérationnelles et prennent en charge le trafic ICMP (Internet Control Monitoring Protocol).

  • Reportez-vous aux meilleures pratiques décrites dans les articles suivants :

    • Pour plus d'informations sur le compteur de performance LDAP Read Time et d'autres compteurs à utiliser pour résoudre les problèmes liés à Active Directory, voir la section sur la résolution des problèmes liés à Active Directory dans la rubrique sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588). Cet article contient également des informations sur la procédure d'amélioration des performances d'Active Directory.

    • Pour plus d'informations sur la procédure d'optimisation des performances d'Active Directory, voir la rubrique sur le réglage de l'intégration d'Active Directory dans le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Pour plus d'informations sur la garantie de la disponibilité élevée de vos serveurs Active Directory, voir la section sur la garantie d'un accès fiable à Active Directory et au système DNS dans la rubrique sur les mesures de tolérance de pannes au niveau système du Guide sur la disponibilité élevée Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Pour plus d'informations sur les considérations relatives à la bande passante du réseau, voir la section sur les performances réseau dans la rubrique sur la présentation des performances d'Exchange du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


La latence maximale de recherche LDAP a dépassé 100 millisecondes
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-14

L'outil Microsoft Exchange Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance LDAP Search Time de l'objet de performance MSExchangeDSAccess Process pour les analyser.

Le compteur de performance LDAP Search Time indique le temps en millisecondes pour réaliser une demande de recherche LDAP (Lightweight Directory Access Protocol). Exchange Analyzer récupère un exemple toutes les 5 secondes pour une période de 5 minutes. Il signale ensuite la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Si la valeur maximale dépasse 100 millisecondes, Exchange Analyzer affiche une erreur.

Les latences élevées de recherche LDAP peuvent être dues à des latences élevées d'appel de procédure distante et par l'augmentation des files d'attente. Des latences élevées de recherche LDAP indiquent généralement l'un des problèmes suivants :

  • un problème de performance avec la connexion réseau au contrôleur de domaine ;

  • des problèmes de performance avec le contrôleur de domaine lui-même.

Remarque :
Les latences LDAP sont généralement supérieures lorsque des utilisateurs se connectent aux contrôleurs de domaine situés sur différents sites physiques. Cependant, les latences maximales conseillées citées dans cet article doivent généralement être respectées.

Les serveurs Exchange interrogent les serveurs de catalogue global situés en dehors du domaine toutes les 15 minutes afin de maintenir à jour la liste des serveurs de catalogue global et des contrôleurs de domaine. Comme certains de ces serveurs d'annuaire peuvent être distants, les latences de ces requêtes peuvent être élevées. Cela est acceptable tant que les requêtes sont rares, c'est-à-dire tant que le taux est inférieur à 0,5 requêtes par seconde.

Si le contrôleur de domaine qui a enregistré cette erreur est situé sur un autre site physique, il est possible que vous puissiez ignorer cette erreur en toute sécurité si vous pouvez déterminer que le contrôleur de domaine qui fait état de cette erreur n'est pas utilisé par le serveur Exchange. Une manière de déterminer si un contrôleur de domaine est utilisé par Exchange est de régler l'enregistrement des diagnostics pour le composant Topologie du service MSExchangeDSAccess sur Minimum. Si vous ne voyez pas l'ID d'événement 2080 dans MSExchangeDSAccess, vous pouvez ignorer cette erreur en toute sécurité.

Important :
Pour les environnements en mode mixte uniquement, ce comportement a été présenté à peu près en même temps qu'Exchange 2000 SP2 pour certains attributs utilisateur spécifiques liés à la sécurité (tels que tokenGroups et tokengroupsGlobalandUniversal), qui permettent de déterminer les groupes de sécurité dont un utilisateur est membre et, par conséquent, les autorisations dont il dispose pour sécuriser les ressources (telles que les dossiers publics), qui nécessitent que le serveur Exchange interroge un contrôleur de domaine faisant autorité pour le domaine associé de l'utilisateur. Le contrôleur de domaine faisant autorité peut se situer dans un site distant et les requêtes à partir d'un grand nombre d'utilisateurs de domaines associés distants qui accèdent aux dossiers publics locaux peuvent contribuer aux latences RPC élevées.

Pour plus d'informations sur ce comportement, voir l'article suivant du blog Exchange Server :

  • Article sur Exchange qui n'utilise pas toujours les catalogues globaux locaux (en anglais)

    Remarque :
    Les liens vers les blogs sont fournis pour vous aider à trouver les informations techniques dont vous avez besoin. Le contenu de chaque blog et leur URL sont susceptibles d'être modifiés sans préavis.

Pour résoudre cette erreur, procédez comme suit :

  • Vérifiez que toutes les connexions réseau au contrôleur de domaine sont opérationnelles et prennent en charge le trafic ICMP (Internet Control Monitoring Protocol).

  • Reportez-vous aux meilleures pratiques décrites dans les articles suivants :

    • Pour plus d'informations sur le compteur de performance LDAP Read Time et d'autres compteurs à utiliser pour résoudre les problèmes liés à Active Directory, voir la section sur la résolution des problèmes liés à Active Directory dans la rubrique sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588). Cet article contient également des informations sur la procédure d'amélioration des performances d'Active Directory.

    • Pour plus d'informations sur la procédure d'optimisation des performances d'Active Directory, voir la rubrique sur le réglage de l'intégration d'Active Directory dans le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Pour plus d'informations sur la garantie de la disponibilité élevée de vos serveurs Active Directory, voir la section sur la garantie d'un accès fiable à Active Directory et au système DNS dans la rubrique sur les mesures de tolérance de pannes au niveau système du Guide sur la disponibilité élevée Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47571).

    • Pour plus d'informations sur les considérations relatives à la bande passante du réseau, voir la section sur les performances réseau dans la rubrique sur la présentation des performances d'Exchange du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).


Impossible d'identifier la passerelle Exchange spécifiée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-08-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour le nom (cn) de chaque objet d'annuaire de la classe d'objet msExchExchangeServer pour déterminer s'il existe une correspondance pour le serveur de passerelle Exchange spécifié par l'utilisateur.

La valeur cn est une chaîne qui contient le nom court de l'ordinateur Exchange Server.

Si Exchange Server Analyzer ne trouve pas de correspondance de la valeur cn pour le serveur de passerelle Exchange spécifié par l'utilisateur dans Active Directory, il affiche une erreur.

Cette erreur indique qu'une des conditions suivantes est vraie :

  • Le serveur de passerelle Exchange spécifié par l'utilisateur n'existe pas dans l'organisation Exchange Server locale.

  • Le serveur de passerelle Exchange spécifié par l'utilisateur a été entré de manière incorrecte.

Pour résoudre cette erreur, vérifiez si le serveur de passerelle Exchange spécifié a été entré correctement et réessayez l'opération.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour vérifier la valeur (cn) du nom du serveur

  1. À l'aide d'ADSI Edit ou d'un outil similaire, localisez l'objet serveur dans Active Directory.

    L'attribut CN peut se trouver dans :

    Copier le code
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


Longueur de la file d'attente du catégoriseur au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Categorizer Queue Length de l'objet de performance SMTP Server pour les analyser.

Si Exchange Server Analyzer détermine que le compteur Categorizer Queue Length a dépassé la valeur maximale de 10 pendant une période-exemple, il affiche une erreur.

Le compteur SMTP Server\Categorizer Queue Length indique le nombre de messages dans la file d'attente SMTP (Simple Mail Transfer Protocol) du catégoriseur en attente de recherches d'attribut de service d'annuaire à l'aide des serveurs de catalogue global.

Le catégoriseur effectue les opérations principales suivantes :

  • Il résout et valide tous les destinataires.

  • Il détermine les limites et restrictions pour tous les destinataires.

  • Il développe les listes de distribution si nécessaire.

  • Il détermine si le message est destiné à une remise locale ou à distance

Cette erreur indique qu'il peut y avoir des problèmes avec les performances du serveur ou du réseau, avec Directory Service Access (DSAccess), avec le service d'annuaire Active Directory® ou des pannes avec les serveurs principaux dans l'organisation Exchange Server. Une augmentation du compteur Categorizer Queue Length peut indiquer un ralentissement du temps de réponse ou l'absence de réponse lors de la consultation d'Active Directory ou lors de l'envoi de messages pour remise locale ou SMTP. Cela peut entraîner un retard de remise de messages.

Pour corriger cette erreur :

  • Vérifiez que des ressources Active Directory suffisantes sont disponibles sur le serveur Exchange. Cela comprend les contrôleurs de domaine et les serveurs de catalogue global. Il est recommandé de maintenir un rapport 4:1 entre les processeurs de serveur Exchange et les processeurs de serveur de catalogue global de vitesse égale.

  • Dans le Gestionnaire système Exchange, vérifiez que l'ensemble des contrôleurs de domaine répertoriés sous l'onglet DSAccess du serveur Exchange fonctionnent correctement. Cette liste comprend les serveurs répertoriés dans le contrôleur de domaine ConfigDC et les rôles de serveur de catalogue global.

  • Contrôlez les performances du réseau entre le serveur Exchange et ses contrôleurs de domaine et serveurs de catalogue global sélectionnés pour déterminer s'il y a un goulot d'étranglement de performances de réseau.

  • Contrôlez l'utilisation du processeur sur le serveur Exchange et du processus Inetinfo.exe. Cela comprend le composant de catégoriseur.

  • Vérifiez l'état des objets de groupe et utilisateur liés à Exchange à l'aide de l'objet de configuration e2kdsinteg de l'outil ConfigDSInteg dans les Outils de déploiement de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21231). Les objets dont l'adresse est incorrecte ou dont les informations sont incomplètes peuvent entraîner des retards de détermination de destinataire et de catégorisation de retards.

Pour plus d'informations

Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Le fichier CDO.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Mise à jour de CimWin32.dll disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-19

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version de Microsoft Windows® exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur Exchange Server est exécuté sur Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que l'ordinateur Exchange Server exécute Windows 2000 Server et la valeur 5.2, qu'il exécute Windows Server™ 2003.

Exchange Server Analyzer interroge également la classe WMI (Windows Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur définie pour la clé Version du fichier Cimwin32.dll.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • L'ordinateur Exchange Server est exécuté sur Windows 2000 Server.

  • La valeur de la clé Version correspond à une version spécifique du fichier Cimwin32.dll.

Il existe une mise à jour du fichier Cimwin32.dll qui permet à Exchange Server Analyzer de fonctionner de manière plus efficace.

Pour résoudre ce problème, passez en revue et appliquez les recommandations de l'article 820608 de la Base de connaissances Microsoft sur la classe CIM_DataFile qui retourne une valeur incorrecte ou nulle pour les fichiers de plus de 2 Go dans Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608).


Impact des applications clients sur les performances du serveur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que des types spécifiques d'ordinateurs clients ou d'applications côté client peuvent accroître la charge du serveur dans votre organisation Exchange.

De nombreuses applications peuvent augmenter la charge sur le serveur. En cas d'augmentation de la charge, demandez aux utilisateurs quelles applications ils emploient et décidez éventuellement d'empêcher les utilisateurs d'exécuter certaines applications. Certaines applications ayant accès au courrier électronique (applications tierces ou plug-ins Microsoft Office Outlook®) risquent d'accroître la charge sur le serveur. Si le serveur connaît une augmentation des latences d'appel de procédure distante (RPC) ou de la charge, il est recommandé d'en rechercher la cause.

Vous pouvez utiliser ExMon, l'outil de surveillance des utilisateurs d'Exchange, pour identifier les utilisateurs confrontés à des latences élevées ou qui augmentent la charge sur le serveur. Pour télécharger ExMon, voir le Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=54983).

Procédure

Pour supprimer cet avertissement

  • ExMon permet d'identifier les utilisateurs qui provoquent une augmentation de la charge du serveur. Une fois que vous les avez identifiés, contactez-les et déterminez si les applications suivantes provoquent la charge supplémentaire :

    • plug-ins d'ordinateurs clients tiers ;

    • périphériques de synchronisation de bureau, tels qu'Exchange ActiveSync® ou Blackberry ;

    • autres applications MAPI, telles que les moteurs de recherche de bureau.

    Si ces applications ne sont pas obligatoires pour vos activités ou si un correctif a été publié pour elles, désactivez-les ou mettez-les à jour pour réduire la charge à un niveau approprié.

  • Configurez les ordinateurs clients dont les coûts de fonctionnement sont les plus élevés (en particulier ceux qui présentent de longues latences sur les opérations Restrict, SetColumns ou FindRow) pour qu'ils utilisent le mode Exchange mis en cache. Celui-ci isole le serveur de la majeure partie du trafic RPC excédentaire.

    Encouragez également les utilisateurs ayant de nombreux éléments dans leurs dossiers à archiver les anciennes données dans un fichier .pst. Si ces utilisateurs veulent conserver leurs données sur le serveur, vous pouvez aussi les encourager à déplacer les anciens éléments dans des dossiers créés récemment.

    Enfin, il est recommandé de conserver moins de 5 000 éléments dans les dossiers Boîte de réception, Calendrier, Éléments envoyés, Contacts et Éléments supprimés.
Remarque :
Certaines application peuvent considérablement accroître la charge du serveur sans effectuer un grand nombre d'opérations MAPI. En effet, les frais de certaines opérations sont plus élevés que pour d'autres. Une toute petite augmentation du nombre d'opérations coûteuses risque d'avoir une influence considérable sur les performances du serveur. Dans ExMon, ces utilisateurs sont signalés comme ayant une influence relativement élevée sur le processeur sans nécessairement effectuer un grand nombre d'opérations MAPI.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la résolution des problèmes de performances des clients Outlook, voir l'article sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803).

  • Pour plus d'informations sur le logiciel de recherche de bureau, voir l'article 905184 de la Base de connaissances Microsoft sur les performances d'Exchange 2000 Server et d'Exchange Server 2003 qui risquent d'être affectées en cas d'exécution du logiciel de moteur de recherche de bureau sur Outlook ou d'autres ordinateurs clients MAPI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).


Le chemin d'accès à l'environnement TEMP du cluster n'est pas valide ou non défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Sur un ordinateur Exchange Server non membre d'un cluster, l'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de la variable d'environnement TEMP :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

Lorsqu'Exchange Server Analyzer est utilisé sur un serveur virtuel Exchange dans un cluster de serveurs Microsoft Windows®, la ruche du Registre HKLM n'est pas lue. Exchange Server Analyzer lit plutôt l'entrée de Registre suivante :

HKEY_USERS\<SID de compte du service de cluster>\Environment\TEMP

Si Exchange Server Analyzer détecte que la variable d'environnement TEMP n'est pas définie sur un chemin d'accès disponible sur le système actuel, il affiche une erreur. Si ce chemin d'accès n'est pas valide, votre organisation peut être confrontée à un échec de remise de courrier. Dans sa configuration par défaut, Exchange Server Analyzer va essayer de trouver ce chemin d'accès défini dans %USERPROFILE%\Local Settings\Temp. Bien que ce chemin d'accès puisse être modifié pour désigner d'autres emplacements, après l'application d'un correctif ou d'une mise à jour et le redémarrage du nœud de cluster, le système peut s'attendre à trouver le chemin d'accès défini par défaut.

La variable d'environnement TEMP sert à désigner le dossier dans le système de fichiers qui doit être utilisé par des applications qui nécessitent un espace de travail temporaire. TEMP est généralement utilisé par des applications, telles qu'Exchange Server. Le chemin d'accès de chaque variable est généralement relatif au contexte de l'application. Par exemple, les processus de banque d'informations de Microsoft Exchange utilisent le dossier TEMP pour le stockage temporaire au cours de diverses opérations, telles que la conversion des messages et le déplacement de boîtes aux lettres.

Pour supprimer cet avertissement

  1. Connectez-vous à un nœud du cluster comme le compte du service de cluster.

  2. Cliquez avec le bouton droit sur Poste de travail et sélectionnez Propriétés.

  3. Sélectionnez Avancé.

  4. Cliquez sur Variables d'environnement.

  5. Dans la zone Variables utilisateur pour <nom du compte>, sélectionnez TEMP et cliquez sur Modifier.

  6. Dans le champ Valeur de la variable, entrez le chemin d'accès par défaut de la variable d'environnement TEMP et cliquez sur OK.

  7. Cliquez sur OK pour fermer la boîte de dialogue Variables d'environnement, puis une nouvelle fois sur OK pour fermer la boîte de dialogue Propriétés système.

  8. Redémarrez le nœud pour appliquer la modification.

  9. Répétez les étapes 1 à 8 pour chaque nœud du cluster dont les paramètres diffèrent de ceux par défaut.


Envisager plusieurs réplicas d'un carnet d'adresses en mode hors connexion
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-08-14

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_PublicFolder dans l'espace de noms root\MicrosoftExchangeV2 pour déterminer le nombre d'entrées dans la clé ReplicaList. Le nombre d'entrées représente le nombre de réplicas du carnet d'adresses en mode hors connexion présents dans chaque groupe d'administration.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer le nombre d'objets de base de données de dossiers publics contenant la même définition de l'attribut legacyExchangeDN. Le nombre d'objets qui disposent de cette définition d'attribut représente le nombre de banques de dossiers publics qui existent dans l'organisation.

Si Exchange Server Analyzer détermine qu'un seul réplica d'un carnet d'adresses en mode hors connexion existe dans une organisation Exchange disposant de plusieurs banques de dossiers publics, il affiche un message de recommandation.

Pour des questions de disponibilité et de performances, nous vous recommandons d'envisager le déploiement de plusieurs réplicas de chaque carnet d'adresses en mode hors connexion. Dan certains cas, de nombreux réplicas de carnet d'adresses en mode hors connexion peuvent augmenter les performances et la résilience. Dans les grandes organisations Exchange, un seul réplica de carnet d'adresses en mode hors connexion peut être surchargé. Dans toutes les organisations Exchange, un seul réplica d'un carnet d'adresses en mode hors connexion représente un point de défaillance unique.

Bien que plusieurs réplicas signifient un trafic supplémentaire de la réplication sur le réseau, il est recommandé d'utiliser cette pratique. Il doit exister au moins deux réplicas de chaque carnet d'adresses en mode hors connexion.

Pour ajouter des réplicas d'un carnet d'adresses en mode hors connexion à une organisation Exchange

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Dossiers, cliquez avec le bouton droit sur Dossiers publics et sélectionnez Affichez les dossiers système. Remarque Si le noeud Dossiers n'est pas visible, développez Groupes d'administration, puis le groupe d'administration qui contient les dossiers système à afficher. Cliquez ensuite avec le bouton droit sur Dossiers publics et sélectionnez Afficher les dossiers système.

  3. Développez le conteneur CARNET D'ADRESSES EN MODE HORS CONNEXION, puis cliquez avec le bouton droit sur le carnet d'adresses en mode hors connexion auquel ajouter un réplica en sélectionnant Propriétés dans la liste déroulante.

  4. Sélectionnez l'onglet Réplication, puis cliquez sur Ajouter pour sélectionner la banque publique à laquelle vous souhaitez ajouter le réplica. Cliquez sur OK pour terminer.

  5. Répétez les étapes 3 et 4 pour tous les objets enfants du conteneur Carnet d'adresses en mode hors connexion auquel vous souhaitez ajouter un réplica. Cette répétition permet de vérifier que tous les formats pris en charge sont compris dans le réplica. En d'autres termes, Ajouter les objets enfants OAB Version 2, OAB Version 3a, etc.

Pour plus d'informations sur la procédure de gestion et de configuration des carnets d'adresses en mode hors connexion, voir les articles suivants de TechCenter sur Microsoft Exchange Server :

  • Article sur le carnet d'adresses en mode hors connexion et les éléments à prendre en compte (http://go.microsoft.com/fwlink/?LinkId=57581)

  • Article sur l'utilisation des banques d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

  • Guide des recommandations du carnet d'adresses en mode hors connexion (http://go.microsoft.com/fwlink/?LinkId=47583).

  • Article sur OAB version 4 dans Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=53097).

  • Article sur le fonctionnement simultané d'Outlook 2003 SP2 et d'Exchange Server 2003 SP2 OAB version 4 (http://go.microsoft.com/fwlink/?linkid=53099).


Connexion au contrôleur de domaine du service de mise à jour de destinataire
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-05-18

L'outil Microsoft® Exchange Server Analyzer Tool ouvre une connexion de socket TCP sur le port 389 sur chaque contrôleur de domaine. Cette connexion est établie à l'aide d'un processeur d'objet personnalisé qui renvoie une chaîne spécifique si la connexion est correctement établie.

Si Exchange Server Analyzer ne reçoit pas 389 Available dans la chaîne renvoyée, un avertissement s'affiche.

Cet avertissement indique que le contrôleur de domaine n'a pas répondu à une tentative de connexion sur le port TCP 389. Le port TCP 389 est le port par défaut pour les communications LDAP. Si vous recevez cet avertissement, l'une des conditions suivantes peut exister :

  • Il peut y avoir des problèmes de connectivité entre Exchange Server Analyzer et le contrôleur de domaine.

  • Le serveur peut être à l'arrêt.

  • Le serveur a peut-être été désactivé.

Plusieurs raisons peuvent expliquer qu'un contrôleur de domaine ne répond pas correctement aux requêtes LDAP lorsqu'Exchange Server Analyzer l'interroge.

Pour supprimer cet avertissement

  1. Vérifiez que le compte utilisant Exchange Server Analyzer est autorisé à interroger le contrôleur de domaine. Vous aurez besoin d'autorisations au niveau utilisateur dans le domaine où le contrôleur de domaine est exécuté. Vous trouverez davantage d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer dans le fichier d'Aide fourni avec Exchange Server Analyzer. Pour ouvrir le fichier d'Aide d'Exchange Server Analyzer, cliquez sur Aide dans Exchange Server Analyzer, puis sur Aide sur Microsoft Exchange Server Analyzer Tool.

  2. Vérifiez qu'aucun pare-feu ou restriction de port ne soit présent entre l'ordinateur utilisant Exchange Server Analyzer et le contrôleur de domaine qui n'a pas répondu.

  3. Vérifiez que le contrôleur de domaine est connecté au réseau et fonctionne correctement.

  4. Vérifiez que le serveur n'a pas été désactivé et fait toujours partie de la liste des contrôleurs de domaine disponibles sur Exchange Server.

Pour plus d'informations, voir les articles suivants de la Base de connaissances Microsoft :

  • 319065 sur l'utilisation du service de mise à jour de destinataire dans Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)

  • 816103 sur l'utilisation de Portqry pour résoudre des problèmes de connectivité d'Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103)


L'indexation de contenu est activée pour cette banque de dossiers publics, mais les mises à jour ne sont pas planifiées
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchCIAvailable de chaque banque de dossiers publics. La valeur de cet attribut indique si l'indexation de contenu a été activée pour la banque de dossiers publics. La valeur True indique qu'un index de contenu existe pour une banque de dossiers publics et que le paramètre du Gestionnaire système Exchange Cet index est actuellement accessible aux clients pour les recherches est sélectionné. La valeur False indique qu'un index de contenu existe pour une banque de dossiers publics, mais le paramètre du Gestionnaire système Exchange Cet index est actuellement accessible aux clients pour les recherches est désactivé. La valeur <Not Set> indique l'absence d'index de contenu pour la banque de dossiers publics.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msExchCIRebuildSchedule de chaque banque de dossiers publics. La valeur de cet attribut indique les paramètres de planification de reconstruction pour l'index de contenu. Cet attribut est stocké sous la forme d'une chaîne en octet comprenant 82 paires de valeurs hexadécimales.

Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchCIAvailable est définie sur True, mais que la valeur de la chaîne en octet de l'attribut msExchCIRebuildSchedule passe à Ne jamais exécuter, un avertissement s'affiche.

Pour régler l'intervalle de mise à jour, il est recommandé de planifier des mises à jour incrémentielles au moins une fois par jour. Vous souhaiterez peut-être planifier des mises à jour plus fréquentes, car la mise à jour de l'index date de son dernier remplissage. Les index qui ne sont pas régulièrement mis à jour peuvent générer des résultats imprécis et obsolètes.

Vous devez également tenir compte du temps nécessaire pour effectuer un remplissage incrémentiel. Par exemple, une planification standard définit des mises à jour incrémentielles au début de chaque heure. Toutefois, si la mise à jour dure plus d'une heure, le remplissage incrémentiel suivant commence au début de l'heure suivante.

Généralement, si la taille de la banque de dossiers publics est inférieure ou égale à 6 gigaoctets (Go), vous pouvez effectuer des mises à jour incrémentielles toutes les heures. Si la taille de la banque dépasse 6 Go ou si le serveur utilise intensivement la mémoire, vous souhaiterez peut-être mettre à jour l'index moins souvent.

Pour définir l'intervalle de mise à jour de l'indexation de texte intégral sur une banque de dossiers publics spécifique

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration, Serveurs, votre serveur, votre groupe de stockage, puis cliquez avec le bouton droit sur votre banque de dossiers publics, puis cliquez sur Propriétés. Si le nœud Groupes d'administration n'est pas affiché dans le Gestionnaire système Exchange, développez Serveurs, cliquez avec le bouton droit sur votre serveur, puis sur Propriétés.

  3. Sous l'onglet Indexation de texte intégral, sélectionnez une option autre que Ne jamais exécuter.

  4. Si vous sélectionnez Utiliser le planning personnalisé, cliquez sur Personnaliser, définissez votre planification personnalisée, puis cliquez sur OK.

  5. Cliquez sur Appliquer.

Pour plus d'informations sur l'indexation de texte intégral pour Exchange Server, voir le document sur les recommandations pour le déploiement de l'indexation de texte intégral (http://go.microsoft.com/fwlink/?linkid=5223).


L'indexation de contenu est activée pour cette banque de boîtes aux lettres, mais les mises à jour ne sont pas planifiées
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchCIAvailable de chaque banque de boîtes aux lettres. La valeur de cet attribut indique si l'indexation de contenu a été activée pour la banque de boîtes aux lettres. La valeur TRUE indique qu'un index de contenu existe pour une banque de boîtes aux lettres et que le paramètre du Gestionnaire système Exchange « Cet index est actuellement accessible aux clients pour les recherches » est activé. La valeur FALSE indique qu'un index de contenu existe pour une banque de boîtes aux lettres, mais que le paramètre du Gestionnaire système Exchange « Cet index est actuellement accessible aux clients pour les recherches » est désactivé. La valeur <Non défini> indique l'absence d'index de contenu pour la banque de boîtes aux lettres.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msExchCIRebuildSchedule de chaque banque de boîtes aux lettres. La valeur de cet attribut indique les paramètres de planification de reconstruction pour l'index de contenu. Cet attribut est stocké sous la forme d'une chaîne en octet comprenant 82 paires de valeurs hexadécimales.

Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchCIAvailable est définie sur TRUE, mais que la valeur de la chaîne en octet de l'attribut msExchCIRebuildSchedule devient « Ne jamais exécuter », un avertissement s'affiche.

Pour régler l'intervalle de mise à jour, il est recommandé de planifier des mises à jour incrémentielles au moins une fois par jour. Vous souhaiterez peut-être planifier des mises à jour plus fréquentes, car la mise à jour de l'index date de son dernier remplissage. Les index qui ne sont pas régulièrement mis à jour peuvent générer des résultats imprécis et obsolètes.

Vous devez également tenir compte du temps nécessaire pour effectuer un remplissage incrémentiel. Par exemple, une planification standard définit des mises à jour incrémentielles au début de chaque heure. Toutefois, si la mise à jour dure plus d'une heure, le remplissage incrémentiel suivant commence au début de l'heure suivante.

Généralement, si la taille de la banque de boîtes aux lettres est de maximum 6 gigaoctets (Go), vous pouvez effectuer des mises à jour incrémentielles toutes les heures. Si la taille de la banque dépasse 6 Go ou si le serveur utilise intensivement la mémoire, vous souhaiterez peut-être mettre à jour l'index moins souvent.

Pour définir l'intervalle de mise à jour de l'indexation de texte intégral sur une banque de boîtes aux lettres spécifique

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration, Serveurs, votre serveur, votre groupe de stockage, puis cliquez avec le bouton droit sur votre banque de boîtes aux lettres, puis cliquez sur Propriétés. Si le nœud Groupes d'administration n'est pas affiché dans le Gestionnaire système Exchange, développez Serveurs, cliquez avec le bouton droit sur votre serveur, puis sur Propriétés.

  3. Sous l'onglet Indexation de texte intégral, sélectionnez une option autre que Ne jamais exécuter.

  4. Si vous sélectionnez Utiliser le planning personnalisé, cliquez sur Personnaliser, définissez votre planification personnalisée, puis cliquez sur OK.

  5. Cliquez sur Appliquer.

Pour plus d'informations sur la configuration et le dépannage de l'indexation de texte intégral dans Exchange, voir l'article 822932 de la Base de connaissances Microsoft sur la procédure de configuration de l'indexation de texte intégral dans les banques de boîtes aux lettres d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932) et l'article 319436 sur la procédure de configuration de l'indexation de texte intégral dans les banques de boîtes aux lettres d'Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436).

Pour plus d'informations sur l'indexation de texte intégral pour Exchange Server, voir le document sur les recommandations pour le déploiement de l'indexation de texte intégral (http://go.microsoft.com/fwlink/?LinkId=5223).


Mise à jour de contenu disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-06-21

Pour plus d'informations, voir la page de téléchargement de la documentation d'Exchange Server 2007.


Mise à jour du pilote CQPCIDRV.SYS disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-08-14

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version de Microsoft Windows® exécutée sur le serveur qui utilise Exchange :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que le serveur Exchange exécute Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que le serveur Exchange exécute Windows 2000 Server. La valeur 5.2 indique que l'ordinateur Exchange Server exécute Windows Server™ 2003.

Exchange Server Analyzer examine également la classe WMI (Windows Management Instrumentation) Win32_Processor pour déterminer la valeur de la clé DataWidth.

Une valeur de la clé DataWidth de 32 indique que le serveur exécute une version 32 bits du système d'exploitation Windows, tandis qu'une valeur de la clé DataWidth de 64 indique que le serveur exécute une version 64 bits du système d'exploitation Windows.

Enfin, Exchange Server Analyzer interroge la classe WMI CIM_Datafile pour déterminer la valeur de la clé de la Version pour un fichier appelé CpqCiDrv.sys.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le serveur Exchange exécute Windows Server 2003.

  • Le serveur Exchange exécute une version 64 bits du système d'exploitation Windows.

  • La version du pilote d'interface de gestion iLO (Integrated Lights-Out) de HP, CPQCIDRV.sys, est inférieure à 1.8.

Cette erreur indique que la version de CpqCiDrv.sys installée sur le serveur peut provoquer des erreurs d'allocation de la mémoire noyau.

Pour résoudre ce problème, suivez les instructions du fournisseur figurant dans l'ID de document : c00688313 (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313).

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


CrashOnAuditFail activé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le paramètre CrashOnAuditFail a été défini :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

Si Exchange Server Analyzer détecte que la valeur de CrashOnAuditFail est égale à 2, une erreur s'affiche.

Le rôle de la clé de Registre CrashonAuditFail est de configurer un serveur pour que les utilisateurs finaux ne puissent pas accéder à l'ordinateur lorsque les journaux de sécurité atteignent la taille limite configurée. L'interdiction de l'accès à l'ordinateur permet d'éviter la perte des informations d'audit qui seraient normalement consignées.

Lorsqu'elle est activée, la clé de Registre CrashonAuditFail a une valeur de 1. Toutefois, lorsque la limite du journal de sécurité est atteinte, le serveur définit la clé de Registre sur une valeur de 2, qui à son tour, interrompt le traitement sur le serveur. Il se peut que ce processus engendre un échec complet ou STOP 0xC0000244, également appelé erreur d'arrêt. Au mieux, les utilisateurs ne pourront pas accéder aux ressources de serveur et les performances seront fortement diminuées. En outre, lorsque le serveur est dans cet état, seuls les utilisateurs disposant des autorisations Administrateur peuvent accéder à l'ordinateur.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\LSA.

  3. Supprimez la valeur appelée CrashOnAuditFail (vous devez la supprimer entièrement et pas uniquement la donnée de valeur).

  4. Copiez les journaux d'événements de sécurité à un emplacement distinct. Par défaut, les journaux d'événements de sécurité (SecEvent.Evt) se trouvent à l'emplacement %RacineSystème%\System32\Config, où %RacineSystème% est le chemin où le système d'exploitation Microsoft Windows® est installé.

  5. Ouvrez l'Observateur d'événements, cliquez avec le bouton droit sur Sécurité, puis cliquez sur Propriétés.

  6. Sur la page Propriétés de sécurité, cliquez sur Effacer le journal. À l'invite vous demandant d'enregistrer le journal, cliquez sur Oui, puis spécifiez un emplacement de stockage.

    Remarque Sur la page Propriétés de sécurité, vous pouvez également augmenter la taille du journal en modifiant le champ Taille maximale du journal, puis en cliquant sur Appliquer.

  7. Redémarrez le serveur.

  8. Vérifiez que les utilisateurs peuvent accéder aux ressources de serveur en vous connectant à une banque de boîtes aux lettres Exchange.

  9. Recréez la clé de Registre CrashonAuditFail et définissez la donnée de valeur sur 1.

  10. Redémarrez le serveur pour que les paramètres CrashonAuditFail soient appliqués.

  11. Effacez et enregistrez régulièrement les journaux de sécurité du serveur pour ne pas dépasser la taille maximale. Pour plus d'informations, voir l'article 312571 de la Base de connaissances Microsoft sur le journal d'événements qui cesse d'enregistrer des événements avant d'atteindre la taille maximale de journal (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la récupération à la suite d'échecs CrashOnAuditFail, voir les articles suivants de la Base de connaissances :

  • 232564 sur l'ARRÊT 0xC0000244 lorsque la taille maximale du journal de sécurité est atteinte (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564)

  • 829082 sur le message « Erreur d'arrêt 0xC0000244 {Échec d'audit} » que vous recevez lorsque la clé de Registre crashonauditfail est définie sur 1 sur un ordinateur Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082)


Liste de redirection du dossier public personnalisée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchFolderAffinityCustom contient des noms de serveurs Exchange. Si Exchange Server Analyzer détecte que l'attribut msExchFolderAffinityCustom répertorie les noms de serveur, il affiche un message indiquant une configuration autre que celle par défaut.

Par défaut, Exchange Server 2003 utilise des groupes de routage pour déterminer les redirections de dossiers publics.

Par défaut, Exchange Server 2007 utilise les coûts intersite du service d'annuaire Active Directory pour déterminer le routage des redirections de dossiers publics.

Si l'attribut msExchFolderAffinityCustom répertorie les noms de serveur, des redirections personnalisées ont été configurées sur le serveur Exchange. L'attribut msExchFolderAffinityCustom est un attribut par serveur.

Il est généralement recommandé d'utiliser le comportement par défaut pour les redirections de dossiers publics. Cependant, il se peut que vous deviez créer une liste de redirection personnalisée. Le message indiquant une configuration autre que celle par défaut n'est envoyé qu'à titre indicatif. Aucune action n'est requise.

Rétablissement de la configuration par défaut d'Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Recherchez l'objet serveur sur lequel les redirections personnalisées de dossiers publics sont configurées. Le nom de ce serveur Exchange est spécifié dans le message d'Exchange Server Analyzer.

  3. Cliquez avec le bouton droit sur Nom_serveur, puis cliquez sur Propriétés.

  4. Sous l'onglet Redirections de dossiers publics, sélectionnez Utiliser des groupes de routages dans le menu déroulant Options de redirection de dossiers publics.

  5. Cliquez sur Appliquer, puis sur OK.
Rétablissement de la configuration par défaut d'Exchange Server 2007

  1. Le code suivant est un exemple de la commande Set-PublicFolderDatabase de l'environnement de ligne de commande Exchange Management Shell qui désactive l'utilisation de PublicFolderRefferalServerList pour la base de données de dossiers publics « MyServer\First Storage Group\Public Folder Database ».
Copier le code
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

Le paramètre UseCustomReferralServerList spécifie si les coûts de serveur spécifiés par le paramètre PublicFolderReferralServerList doivent être utilisés. S'il est défini sur $true, le serveur utilise les coûts du paramètre PublicFolderReferralServerList pour effectuer une redirection de dossiers publics. S'il est défini sur $false, le serveur utilise les coûts intersite d'Active Directory pour effectuer les redirections de dossiers publics.

Remarque :
La définition de ce paramètre sur $false efface également le paramètre PublicFolderReferralServerList.

Pour plus d'informations sur la commande Set-PublicFolderDatabase de l'environnement de ligne de commande Exchange Management Shell, consultez la référence technique de la documentation sur le produit Exchange Server 2007 « Set-PublicFolderDatabase » (http://go.microsoft.com/fwlink/?LinkId=80813).

Pour plus d'informations sur la réplication des dossiers publics, consultez les recommandations pour les dossiers publics sur Exchange Server (http://go.microsoft.com/fwlink/?LinkId=46437).


Objet d'analyseur de performances de la base de données non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Log Record Stalls/sec de l'objet de performance Database pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance Database est désactivé.

  • L'objet d'analyseur de performances Database est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre.

La procédure suivante explique comment corriger les deux premières conditions. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance Database est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe ( (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300965 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller Exchange Server en mode Réparer et appliquer les derniers Service Packs d'Exchange Server.


Le fichier DAVEX.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le service client DHCP n'est pas en cours d'exécution
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Win32_Service pour déterminer la valeur de la clé Started du service client DHCP (Dynamic Host Configuration Protocol). Si Exchange Server Analyzer détecte que la valeur de la clé Started du service client DHCP d'un serveur Exchange est définie sur False, il affiche un avertissement.

Cet avertissement indique que le service client DHCP n'est pas en cours d'exécution. Le service client DHCP effectue des mises à jour dynamiques du DNS (Domain Name System). Si le service client DHCP n'est pas en cours d'exécution, des échecs de mise à jour dynamique se produiront. Si un serveur Exchange n'exécute pas ce service, les problèmes les plus courants résideront dans le flux de messagerie.

Pour résoudre ces problèmes, définissez le service client DHCP sur démarrage automatique et démarrez le service.

Remarque :
Le service client DHCP doit être en cours d'exécution même si le serveur est configuré pour utiliser des adresses IP statiques plutôt que le protocole DHCP.
Pour activer le service client DHCP

  1. Ouvrez le composant logiciel enfichable Services.

  2. Dans le volet Détails, cliquez avec le bouton droit sur Service client DHCP, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, cliquez sur Type de démarrage et sélectionnez Automatique.

  4. Cliquez sur Démarrer, puis sur OK.

Pour plus d'informations sur le service client DHCP, voir l'article 264539 de la Base de connaissances Microsoft sur les mises à jour dynamiques du DNS qui ne fonctionnent pas si le service client DHCP s'arrête (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539).

Pour plus d'informations sur le protocole de mise à jour dynamique du DNS, voir l'article 816592 de la Base de connaissances Microsoft sur la procédure de configuration de la mise à jour dynamique du DNS sous Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).


Dr. Watson non activé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de la clé de Registre suivante pour déterminer si Dr. Watson est configuré comme le débogueur d'application par défaut du système d'exploitation Microsoft Windows® :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

Si Exchange Server Analyzer détecte que la valeur définie pour Debugger ne commence pas par drwtsn32, un message indiquant une configuration autre que celle par défaut s'affiche.

Ce message indique que Dr. Watson n'est pas activé. Le démarrage avec Windows NT® implique qu'un débogueur en mode d'application comme Dr. Watson a été inclus dans Windows. Lorsqu'une application se bloque, l'erreur peut être interceptée par Dr. Watson qui enregistre un type d'informations, comme des informations de plate-forme, une liste des processus d'exécution, l'identification du processus défaillant, une image mémoire du processus défaillant, une ou plusieurs piles d'appels et un pointeur désignant l'erreur. La plupart des informations recueillies correspondent à des informations de débogage de niveau inférieur destinées au développeur du processus défaillant.

La méthode recommandée consiste à exécuter Windows avec un débogueur en mode d'application activé. Si Dr. Watson n'est pas activé et si vous n'utilisez pas le débogueur d'une autre application, il est recommandé d'activer Dr. Watson comme suit.

Pour activer Dr. Watson

  1. Ouvrez une fenêtre d'invite de commandes.

  2. À l'invite de commandes, entrez drwtsn32 -i.

Pour plus d'informations sur l'activation et la désactivation de Dr. Watson, voir l'article 188296 de la Base de connaissances Microsoft sur la procédure à suivre pour désactiver Dr. Watson pour Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296).


Incohérence de nom DSA Computer
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur DSA Computer :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut name pour chaque objet Exchange Server.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service de cluster (ClusSvc). Une valeur True indique que le service de cluster est démarré et une valeur False qu'il n'est pas en cours d'exécution.

Si Exchange Server Analyzer détecte que la valeur de la clé DSA Computer ne correspond pas à celle de l'attribut name de l'objet serveur dans Active Directory pour tout ordinateur Exchange Server qui n'est pas exécuté dans un cluster Windows Server, une erreur s'affiche.

Pour corriger cette erreur, vous devez modifier la clé de Registre DSA Computer pour qu'elle corresponde à la valeur de l'attribut name dans Active Directory.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, double-cliquez sur DSA Computer, entrez le nom correct pour cet ordinateur, puis cliquez sur OK.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le fichier DSACCESS.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le cache de configuration DSAccess est plein
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-05-24

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches pour déterminer la valeur actuelle de la clé TotalEntriesMemoryConfigurationData. Si Exchange Server Analyzer détecte que la valeur de TotalEntriesMemoryConfigurationData est égale à la taille totale du cache de configuration d'accès au service d'annuaire (DSAccess) (MaxMemoryConfig), un avertissement s'affiche.

DSAccess est un composant interne d'Exchange 2000 Server et Exchange Server 2003 qui contrôle la manière dont tous les composants Exchange accèdent au service d'annuaire Active Directory®. La fonction principale de DSAccess est de conserver les informations sur divers événements et opérations liés à l'annuaire. Par exemple, DSAccess découvre la topologie Active Directory et détecte si les contrôleurs de domaine et les serveurs de catalogue global sont disponibles et répondent aux demandes. En outre, toutes les requêtes d'annuaire effectuées par des composants Exchange internes, tels que la banque Microsoft Exchange, sont routées via DSAccess, comme la résolution de destinataire, les recherches de paramètre de configuration, etc. DSAccess gère également un cache interne des résultats de certaines de ces requêtes pour que, si les mêmes informations sont demandées deux fois, elles puissent être récupérées à partir du cache DSAccess plutôt que via une autre requête LDAP (Lightweight Directory Access Protocol) sur Active Directory.

Comme la taille maximale de paramètre par défaut du cache de configuration DSAccess a été réduite d'une valeur de 25 mégaoctets (Mo) dans Exchange 2000 Server à une valeur de 5 Mo dans Exchange Server 2003, ce message d'avertissement peut être généré sur une version d'Exchange. Quelle que soit la version d'Exchange qui génère ce message d'avertissement, le problème doit être résolu dès que possible.

La valeur MaxMemoryConfig a été souvent utilisée conjointement avec la valeur MaxMemoryUser qui contrôle la quantité maximale de mémoire pouvant être utilisée par des objets de données utilisateur dans le cache DSAccess. Si vous modifiez ou supprimez la valeur MaxMemoryConfig comme décrit dans la procédure ci-dessous, vous devez de même modifier ou supprimer la valeur MaxMemoryUser comme décrit dans l'article Le cache utilisateur DSAccess n'est pas défini par défaut

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Augmentez la valeur de MaxMemoryConfig. Si la clé Instance0 ou la valeur DWORD MaxMemoryConfig n'existe pas, vous pouvez la créer manuellement. Les données de valeur de l'entrée de Registre MaxMemoryConfig sont exprimées en kilo-octets (Ko) ; par conséquent, une entrée décimale de 15 000 est égale à 15 Mo. Si la valeur existe, augmentez-la de 10 pour cent. Si la valeur n'existe pas, un point de départ de 10 Mo est recommandé.

  4. Fermez l'Éditeur du Registre et redémarrez le service Surveillance du système Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le cache de configuration DSAccess n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si la taille du cache d'objets de configuration (DSAccess) d'accès au service d'annuaire a été modifiée par rapport à la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

Si Exchange Server Analyzer détecte que la valeur MaxMemoryConfig est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

MaxMemoryConfig est un paramètre de Registre d'Exchange 2000 Server généralement devenu inutile dans Exchange Server 2003. MaxMemoryConfig contrôle la quantité maximale de mémoire pouvant être utilisée par des objets de données de configuration dans le cache DSAccess. DSAccess est un composant interne d'Exchange 2000 Server et d'Exchange Server 2003 qui contrôle la manière dont tous les composants Exchange accèdent au service d'annuaire Active Directory®. La fonction principale de DSAccess est de conserver les informations sur divers événements et opérations liés à l'annuaire. Par exemple, DSAccess découvre la topologie Active Directory et détecte si les contrôleurs de domaine et les serveurs de catalogue global sont disponibles et répondent aux demandes. En outre, toutes les requêtes d'annuaire effectuées par des composants Exchange internes, tels que la banque Microsoft Exchange, sont routées via DSAccess, comme la résolution de destinataire, les recherches de paramètre de configuration, etc. DSAccess gère également un cache interne des résultats de certaines de ces requêtes pour que, si les mêmes informations sont demandées deux fois, elles puissent être récupérées à partir du cache DSAccess plutôt que via une autre requête LDAP (Lightweight Directory Access Protocol) sur Active Directory.

Dans Exchange 2000 Server, le cache de configuration a été initialement défini sur 25 Mo. Sur la plupart des serveurs Exchange, ce paramètre était beaucoup plus grand que nécessaire. Le paramètre MaxMemoryConfig était utilisé pour récupérer et réattribuer une partie de la mémoire utilisée par le cache de configuration DSAccess. Il a été généralement configuré pour 5 Mo. Sur la base d'un test interne et de commentaires de clients, Microsoft a pu déterminer que la taille optimale est 3 Mo qu'Exchange Server 2003 utilise en tant que paramètre prêt à l'emploi. Lors de la mise à niveau d'Exchange 2000 Server vers Exchange Server 2003, tous les paramètres manuels sont conservés. Si ce serveur Exchange a été mis à niveau d'Exchange 2000 Server vers Exchange Server 2003, vérifiez que la valeur de MaxMemoryConfig est de 5 Mo maximum.

La valeur MaxMemoryConfig a été souvent utilisée conjointement avec la valeur MaxMemoryUser qui contrôle la quantité maximale de mémoire pouvant être utilisée par des objets de données utilisateur dans le cache DSAccess. Si vous modifiez ou supprimez la valeur MaxMemoryConfig comme décrit dans la procédure suivante, vous devez également modifier ou supprimer la valeur MaxMemoryUser comme décrit dans l'article relatif à Le cache utilisateur DSAccess n'est pas défini par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Utilisation de la valeur de Registre MaxMemoryConfig

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Examinez ou modifiez la valeur de MaxMemoryConfig.
Remarque :
La valeur de cette entrée de Registre est exprimée en kilo-octets (Ko). Si la valeur est définie sur 3000 ou moins, vous devez supprimer MaxMemoryConfig et redémarrer le service Surveillance du système Microsoft Exchange pour rétablir le paramètre par défaut d'Exchange Server 2003.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur DSAccess, consultez l'article 250570 de la Base de connaissances sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Le paramètre de Registre DisableNetLogonCheck de DSAccess n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si DSAccess (Directory Service Access) a été configuré pour utiliser un protocole ping autre que celui par défaut :

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

Si Exchange Server Analyzer détecte que DisableNetLogonCheck est présent et configuré avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Une fois que DSAccess a découvert la topologie du service d'annuaire Active Directory®, il détermine si les serveurs de catalogue global et les contrôleurs de domaine découverts peuvent être utilisés. Pendant la découverte initiale et la redécouverte en cours, DSAccess détermine si le serveur convient en exécutant une série de tests. L'un des tests envoie un appel de procédure à distance (RPC) au serveur d'annuaire pour tester sa convenance générale. Dans un scénario de réseau de périmètre dans lequel le trafic RPC n'est généralement pas autorisé, la demande d'appel de procédure à distance DSAccess échoue. Toutefois, DSAccess continue d'émettre des appels de procédure à distance jusqu'à ce qu'ils échouent, ce qui peut prendre du temps. De telles vérifications répétées peuvent affecter défavorablement les performances des ordinateurs Exchange Server. Par conséquent, des administrateurs ajoutent fréquemment la clé de Registre DisableNetLogonCheck et la configurent à l'aide d'une valeur de 1 sur des serveurs Exchange situés sur un réseau de périmètre.

Si le serveur Exchange qui a généré le message indiquant une configuration autre que celle par défaut se trouve sur un réseau de périmètre sur lequel l'appel de procédure à distance RPC est désactivé ou si vous avez déterminé que vous ne souhaitez pas que DSAccess réalise ce test de convenance, définissez la clé DisableNetLogonCheck sur 1. Sinon, vous devez supprimer la clé DisableNetLogonCheck.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour utiliser la clé DisableNetLogonCheck

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Double-cliquez sur la clé DisableNetLogonCheck et définissez la valeur DWORD sur 1..

  4. Fermez l'Éditeur du Registre. Vous ne devez redémarrer aucun service pour que la modification soit prise en compte.

Pour supprimer la clé DisableNetLogonCheck

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Supprimez la valeur nommée DisableNetLogonCheck.

  4. Fermez l'Éditeur du Registre. Vous ne devez redémarrer aucun service pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la clé de Registre DisableNetLogonCheck, voir l'article 320228 de la Base de connaissances sur la valeur de Registre DisableNetLogonCheck et son utilisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228).


DSAccess a été codé de manière irréversible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange DSAccessDC dans l'espace de noms ROOT\MicrosoftExchangeV2 pour déterminer la valeur de la clé ConfigurationType. Si la valeur de cette clé est 0, un message indiquant une configuration autre que celle par défaut s'affiche.

La propriété ConfigurationType indique si l'instance décrit un contrôleur de domaine détecté automatiquement ou spécifié manuellement. Le composant d'accès au service d'annuaire (DSAccess) prêt à l'emploi d'Exchange Server détecte dynamiquement la topologie du service d'annuaire Active Directory® et recherche automatiquement les contrôleurs de domaine et les serveurs de catalogue global. Pour les ordinateurs qui exécutent Exchange Server 2000 Service Pack 2 ou versions ultérieures ou Exchange Server 2003, le gestionnaire système Exchange inclut la possibilité d'entrer une liste codée de manière irréversible de serveurs Active Directory pour une utilisation par DSAccess.

À moins que les serveurs d'annuaire pour DSAccess aient été codés de manière irréversible pour une raison spécifique, vous devez supprimer la liste des serveurs et revenir aux paramètres par défaut de détection automatique. Il est recommandé d'utiliser la détection automatique de topologie pour profiter du basculement de catalogue global.

Pour rétablir les paramètres par défaut

  1. Cliquez sur Démarrer, Programmes, Microsoft Exchange, puis Gestionnaire système.

  2. Développez Groupes d'administration, <Nom_groupe_administration>, Serveurs, <Nom_serveur> (où Nom_groupe_administration est le nom du groupe d'administration qui contient le serveur Exchange et Nom_serveur le nom du serveur Exchange à configurer).

  3. Cliquez avec le bouton droit sur le serveur Exchange, puis cliquez sur Propriétés.

  4. Cliquez sur l'onglet Accès à l'annuaire.

  5. Dans la zone de liste Afficher, sélectionnez Configuration du contrôleur de domaine.

  6. Activez la case à cocher Détection automatique des serveurs.

  7. Cliquez sur Oui à l'invite suivante du Gestionnaire système Exchange : « Le ou les serveurs manuellement sélectionnés qui ont été spécifiés seront effacés. Voulez-vous continuer ? »

  8. Dans la zone de liste Afficher, sélectionnez Contrôleurs de domaine.

  9. Activez la case à cocher Détection automatique des serveurs.

  10. Cliquez sur Oui à l'invite suivante du Gestionnaire système Exchange : « Le ou les serveurs manuellement sélectionnés qui ont été spécifiés seront effacés. Voulez-vous continuer ? »

  11. Dans la zone de liste Afficher, sélectionnez Serveurs de catalogue global.

  12. Activez la case à cocher Détection automatique des serveurs.

  13. Cliquez sur Oui à l'invite suivante du Gestionnaire système Exchange : « Le ou les serveurs manuellement sélectionnés qui ont été spécifiés seront effacés. Voulez-vous continuer ? »

  14. Cliquez sur OK pour enregistrer les modifications.

Pour plus d'informations sur DSAccess et la détection de services d'annuaire, voir l'article 250570 de la Base de connaissances Microsoft sur la détection de serveurs de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


DSAccess n'utilise pas de port 389 pendant les demandes LDAP de contrôleur de domaine
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange DSAccessDC dans l'espace de noms ROOT\MicrosoftExchangeV2 pour déterminer la valeur de la clé LDAPPort. Si la valeur de la clé LDAPPort n'est pas définie sur 389, un message indiquant une configuration autre que celle par défaut s'affiche.

La touche LDAPPort représente le numéro de port TCP sur lequel le contrôleur de domaine écoute les demandes LDAP. Les administrateurs peuvent utiliser le protocole LDAP sur SSL sur le port TCP 636 (contrôleur de domaine) ou le port TCP 3269 (catalogue global) en tant que mesure de sécurité.

Par défaut, un serveur de catalogue global écoute les communications LDAP sur le port 3268. Toutefois, si une autorité de certification d'entreprise est installée, tous les contrôleurs de domaine demandent automatiquement un certificat et peuvent prendre en charge les communications LDAP sur SSL sur le port TCP 636. Si le contrôleur de domaine est également configuré comme catalogue global, il peut également prendre en charge les communications LDAP sur SSL sur le port TCP 3269.

Pour corriger cette erreur

  • Aucune action n'est requise. Exchange Server Analyzer identifie une configuration non définie par défaut.

Pour plus d'informations sur les ports DSAccess et LDAP, voir les articles suivants de la Base de connaissances Microsoft :

  • 247078 sur la procédure d'activation de la communication SSL sur le protocole LDAP pour les contrôleurs de domaine Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228 sur les profils DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


DSAccess n'utilise pas de port 3268 pendant les demandes LDAP de catalogue global
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_DSAccessDC dans l'espace de noms ROOT\MicrosoftExchangeV2 pour déterminer la valeur de la clé LDAPPort. Si la valeur de la clé LDAPPort n'est pas définie sur 3268, un message indiquant une configuration autre que celle par défaut s'affiche.

La touche LDAPPort représente le numéro de port TCP sur lequel le contrôleur de domaine écoute les demandes LDAP. Les administrateurs peuvent utiliser le protocole LDAP sur SSL sur le port TCP 636 (contrôleur de domaine) ou le port TCP 3269 (catalogue global) en tant que mesure de sécurité.

Par défaut, un serveur de catalogue global écoute les communications LDAP sur le port 3268. Toutefois, si une autorité de certification d'entreprise est installée, tous les contrôleurs de domaine demandent automatiquement un certificat et peuvent prendre en charge les communications LDAP sur SSL sur le port TCP 636. Si le contrôleur de domaine est également configuré comme catalogue global, il peut également prendre en charge les communications LDAP sur SSL sur le port TCP 3269.

Pour plus d'informations sur les ports DSAccess et LDAP, voir les articles suivants de la Base de connaissances Microsoft :

  • 247078 sur la procédure d'activation de la communication SSL sur le protocole LDAP pour les contrôleurs de domaine Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078)

  • 246228 sur les profils DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228)


Le paramètre de Registre LdapKeepAliveSecs de DSAccess n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'accès au service d'annuaire (DSAccess) a été configuré pour utiliser le protocole wLDAP d'implémentation du système d'exploitation Microsoft Windows® LDAP (Lightweight Directory Access Protocol) :

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Si Exchange Server Analyzer détecte que LdapKeepAliveSecs est présent et configuré avec une valeur de 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Une fois que DSAccess a découvert la topologie du service d'annuaire Active Directory®, il détermine si la liste découverte des serveurs de catalogue global et des contrôleurs de domaine qui fonctionnent peut être utilisée. Pendant la découverte initiale et la redécouverte en cours, DSAccess détermine si le serveur convient en exécutant une série de tests. Par défaut, l'un des tests de convenance utilise le protocole ICMP (Internet Control Message Protocol) sur les contrôleurs de domaine ping pour vérifier que les serveurs sont disponibles.

Toutes les connexions de votre réseau risquent de ne pas prendre en charge le protocole ICMP. Pour illustrer cette situation, prenons l'exemple spécifique d'un réseau de périmètre où la connectivité ICMP entre le serveur Exchange et les contrôleurs de domaine n'est pas autorisée. Dans ces cas, définir le paramètre de Registre LdapKeepAliveSecs sur 0 oblige DSAccess à utiliser l'implémentation de Windows de LDAP (wLDAP) pour les tests de convenance.

Si le serveur Exchange qui a généré le message indiquant une configuration autre que celle par défaut se trouve dans un réseau de périmètre où l'appel de procédure distante (RPC) est désactivé ou dans un réseau où le protocole ICMP n'est pas autorisé, vous devez conserver la clé LdapKeepAliveSecs telle qu'elle est configurée. Sinon, vous devez la supprimer.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer la clé LdapKeepAliveSecs

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Supprimez la valeur nommée LdapKeepAliveSecs.

  4. Fermez l'Éditeur du Registre. Vous ne devez redémarrer aucun service pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la clé de Registre LdapKeepAliveSecs, voir l'article 320529 de la Base de connaissances sur l'utilisation de DSAccess dans un scénario de pare-feu de réseau de périmètre, qui nécessite un paramètre de clé de Registre (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529).


Le paramètre de Registre DSAccess LdapKeepAliveSecs est défini sur une valeur non prise en charge
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'accès au service d'annuaire (DSAccess) a été configuré pour utiliser le protocole wLDAP d'implémentation du système d'exploitation Microsoft Windows® LDAP (Lightweight Directory Access Protocol) :

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Si Exchange Server Analyzer détecte que LdapKeepAliveSecs est présent et configuré à l'aide d'une valeur autre que 0, un avertissement s'affiche.

Une fois que DSAccess a découvert la topologie du service d'annuaire Active Directory®, il détermine si la liste découverte des serveurs de catalogue global et des contrôleurs de domaine qui fonctionnent peut être utilisée. Pendant la découverte initiale et la redécouverte en cours, DSAccess détermine si le serveur convient en exécutant une série de tests. Par défaut, l'un des tests de convenance utilise le protocole ICMP (Internet Control Message Protocol) sur les contrôleurs de domaine ping pour vérifier que les serveurs sont disponibles.

Toutes les connexions de votre réseau risquent de ne pas prendre en charge le protocole ICMP. Pour illustrer cette situation, prenons l'exemple spécifique d'un réseau de périmètre où la connectivité ICMP entre le serveur Exchange et les contrôleurs de domaine n'est pas autorisée. Dans ces cas, définir le paramètre de Registre LdapKeepAliveSecs sur 0 oblige DSAccess à utiliser wLDAP pour les tests de convenance.

Si le serveur Exchange qui a généré cet avertissement est dans un réseau de périmètre dans lequel l'appel de procédure à distance RPC est désactivé ou dans un réseau dans lequel l'ICMP n'est pas autorisé, définissez la clé LdapKeepAliveSecs sur 0. Sinon, vous devez la supprimer. Les valeurs autres que zéro ne sont pas prises en charge pour la clé de Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour modifier la clé LdapKeepAliveSecs

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Double-cliquez sur la clé LdapKeepAliveSecs et définissez la valeur DWORD sur 0 (zéro).

  4. Fermez l'Éditeur du Registre. Vous ne devez redémarrer aucun service pour que la modification soit prise en compte.

Pour supprimer la clé LdapKeepAliveSecs

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Supprimez la valeur nommée LdapKeepAliveSecs.

  4. Fermez l'Éditeur du Registre. Vous ne devez redémarrer aucun service pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la clé de Registre LdapKeepAliveSecs, voir l'article 320529 de la Base de connaissances sur l'utilisation de DSAccess dans un scénario de pare-feu de réseau de périmètre, qui nécessite un paramètre de clé de Registre (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529).


Le paramètre de Registre PreloadBaseDNs de DSAccess n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la fonctionnalité de préchargement de la recherche d'accès au service d'annuaire (DSAccess) a été modifiée par rapport à sa configuration par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

Par défaut, les données de valeur pour PreloadBaseDNs sont :

'"'

'"'

'"'

'"'

'"'

Si Exchange Server Analyzer détecte que la valeur de PreloadBaseDNs a été modifiée par rapport à ces valeurs par défaut, un avertissement s'affiche. Exchange Server Analyzer signale cette configuration car ce paramètre ne doit être modifié que sur avis des services du Support Technique de Microsoft.

Le cache DSAccess réside sur le serveur Exchange et collecte les enregistrements de configuration et des utilisateurs, qui sont récupérés dans le service d'annuaire Active Directory®. Vous pouvez accéder aux enregistrements du cache DSAccess en utilisant le nom unique d'un objet, un GUID ou une clé créée sur la base de la portée, BaseDN, et le filtre de recherche utilisé pour trouver cet objet dans Active Directory. Les accès suivants qui utilisent le même nom unique, GUID ou la même clé trouvent les enregistrements dans le cache. Par conséquent, la charge inutile d'Active Directory est évitée dans le cas de recherches identiques. Toutefois, DSAccess n'empêche pas la charge d'Active Directory lorsque le filtre de recherche n'est pas le même que celui du cache, même si DSAccess nécessite le même attribut pour l'objet utilisateur.

Le préchargement de la recherche est un moyen d'éviter le problème des recherches multiples dans Active Directory, qui peuvent apparaître lorsque de nombreux filtres de recherche sont utilisés pour le même objet utilisateur. Le préchargement de la recherche fonctionne sur la base de la construction de clé mentionnée précédemment, dans laquelle la portée, BaseDN, et le filtre de recherche constituent une entrée de recherche.

Pour plus d'informations sur la configuration de préchargement de la recherche DSAccess, voir l'article 250572 de la Base de connaissances Microsoft sur le préchargement et le cache DSAccess (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


Le paramètre de Registre PreloadFilters de DSAccess n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la fonctionnalité de préchargement de la recherche d'accès au service d'annuaire (DSAccess) a été modifiée par rapport à sa configuration par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

Par défaut, les données de valeur pour PreloadFilters sont :

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

Si Exchange Server Analyzer détecte que la valeur de PreloadFilters a été modifiée par rapport à ces valeurs par défaut, un avertissement s'affiche. Exchange Server Analyzer signale cette configuration car le paramètre de Registre PreloadFilters ne doit être modifié que sur avis des services du Support Technique de Microsoft.

Le cache DSAccess réside sur le serveur Exchange et collecte les enregistrements de configuration et des utilisateurs, qui sont récupérés dans le service d'annuaire Active Directory®. Vous pouvez accéder aux enregistrements du cache en utilisant le nom unique d'un objet, un GUID ou une clé créée sur la base de la portée, BaseDN, et le filtre de recherche utilisé pour trouver cet objet dans Active Directory. Les accès suivants qui utilisent le même nom unique, GUID ou la même clé trouvent les enregistrements dans le cache. Par conséquent, la charge inutile d'Active Directory est évitée dans le cas de recherches identiques. Toutefois, DSAccess n'empêche pas la charge d'Active Directory lorsque le filtre de recherche n'est pas le même que celui du cache, même si DSAccess nécessite le même attribut pour l'objet utilisateur.

Le préchargement de la recherche est un moyen d'éviter les problèmes des recherches multiples dans Active Directory, qui peuvent apparaître lorsque de nombreux filtres de recherche sont utilisés pour le même objet utilisateur. Le préchargement de la recherche fonctionne sur la base de la construction de clé mentionnée précédemment, dans laquelle la portée, BaseDN, et le filtre de recherche constituent une entrée de recherche.

Pour plus d'informations sur la configuration de préchargement de la recherche DSAccess, voir l'article 250572 de la Base de connaissances Microsoft sur le préchargement et le cache DSAccess (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572).


DSAccess signale que ce serveur Active Directory n'est pas fonctionnel
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange DSAccessDC dans l'espace de noms ROOT\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsUp. Si la clé IsUp est définie sur False, une erreur s'affiche.

Si la clé IsUp est définie sur True, cela indique que le contrôleur de domaine a répondu la dernière fois que le serveur Exchange a tenté d'établir une connexion. Si la clé IsUp est définie sur False, cela indique que le contrôleur de domaine n'a pas répondu aux tentatives de connexion.

L'absence de réponse ne signifie pas toujours que le contrôleur de domaine ou le catalogue global est arrêté ou défectueux. Parfois, des problèmes de connectivité réseau entre le serveur Exchange et le contrôleur de domaine peuvent provoquer cet échec. Cette situation peut également être due à la présence d'un pare-feu entre le serveur Exchange et le contrôleur de domaine sur lequel les ports appropriés n'ont pas été ouverts.

Pour corriger cette erreur

  1. Vérifiez que le contrôleur de domaine fonctionne en tentant une commande PING.

  2. En présence d'un pare-feu, vérifiez que les ports appropriés sont ouverts. N'oubliez pas que les pare-feu peuvent également être configurés pour supprimer des paquets PING. Voir la documentation de votre pare-feu pour plus de détails sur l'ouverture ou la fermeture de ports spécifiques.

  3. Assurez-vous qu'il n'existe aucun autre problème réseau, tels que des commutateurs, routeurs ou câbles défectueux.

Pour plus d'informations sur DSAccess et la détection de services d'annuaire, voir l'article 250570 de la Base de connaissances Microsoft sur la détection de serveurs de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


DSAccess signale que ce serveur Active Directory n'est pas synchronisé avec le reste de la topologie
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange DSAccessDC dans l'espace de noms ROOT\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsInSync. Si la valeur de IsInSync est False, une erreur s'affiche.

La clé IsInSync indique si le contrôleur de domaine est synchronisé avec le serveur de catalogue global et le contrôleur de domaine de configuration. Une valeur True indique que le serveur est synchronisé et une valeur False que le contrôleur de domaine n'est pas synchronisé.

Pour corriger cette erreur

  1. Examinez l'heure sur le contrôleur de domaine ou le catalogue global. Assurez-vous que le Service de temps est démarré ou synchronisez manuellement l'heure du serveur Exchange et celle du serveur de catalogue global ou du contrôleur de domaine de configuration.

  2. Utilisez l'outil du moniteur de réplication (Replmon) pour contrôler, vérifier et, au besoin, résoudre des problèmes de réplication du contrôleur de domaine. Replmon fait partie des outils de support de Microsoft Windows 2000 Server et Microsoft Windows Server™ 2003, qui se trouvent sur le CD-ROM de Windows Server dans le dossier Support\Tools.

Pour plus d'informations sur DSAccess et la détection de services d'annuaire, voir les articles suivants de la Base de connaissances Microsoft :

  • 316300 sur l'ID d'événement 2080 et MSExchangeDSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300).

  • 250570 sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


DSAccess signale que ce serveur Active Directory nécessite plus de 2 secondes pour répondre aux demandes LDAP
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft Exchange_DSAccessDC de l'espace de noms ROOT\MicrosoftExchangeV2 pour déterminer les valeurs des clés IsFast et IsUp. Si la valeur de la clé IsUp est True, elle indique que le serveur d'annuaire utilisé par le composant d'accès au service d'annuaire (DSAccess) dans Exchange Server est connecté au réseau et répond. Une valeur False indique que le serveur d'annuaire ne répond pas. Si la valeur de IsFast est True, elle indique que le temps de réponse de ce serveur d'annuaire est inférieur à deux secondes. Une valeur False indique que le temps de réponse est supérieur à deux secondes. Si la valeur de IsUp est True mais si la valeur de IsFast est False, une erreur s'affiche.

Pour corriger cette erreur

  1. Examinez la charge sur le contrôleur de domaine et le catalogue global. Un catalogue global et un contrôleur de domaine surchargés peuvent être lents à répondre aux appels LDAP.

  2. Assurez-vous de la présence d'au moins catalogue global sur le site du service d'annuaire Active Directory® local pour des performances optimales.

Pour plus d'informations sur DSAccess et la détection de services d'annuaire, voir l'article 250570 de la Base de connaissances Microsoft sur la détection de serveurs de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Le paramètre de Registre TopoCreateTimeoutSecs de DSAccess n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le délai d'initialisation par défaut d'accès au service d'annuaire (DSAccess) a été modifié :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

Si Exchange Server Analyzer détecte que la clé TopoCreateTimeoutSecs existe et a une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Au démarrage, DSAccess utilise un processus de découverte pour identifier la topologie du service d'annuaire Active Directory® et évaluer la disponibilité des contrôleurs de domaine et des serveurs de catalogue global. Une fois le démarrage effectué, toutes les 15 minutes, DSAccess utilise quasiment le même processus pour redécouvrir la topologie et vérifier les changements de disponibilité du serveur. Par défaut, l'initialisation de DSAccess pendant le démarrage doit être terminée en une minute. Dans le cas contraire, DSAccess s'arrête. Une minute suffit généralement pour initialiser DSAccess.

Remarque :
Si vous codez de manière irréversible les serveurs d'annuaire utilisés par DSAccess, DSAccess ignore le processus de découverte et ne vérifie que la conformité du serveur.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Supprimez la valeur nommée TopoCreateTimeoutSecs.

  4. Fermez l'Éditeur du Registre.

Si cette clé de Registre est présente, vous devez penser à évaluer la topologie de votre réseau. Si une période d'initialisation de DSAccess supplémentaire est nécessaire à votre organisation, cela peut signifier un problème réseau ou de conception. Un accès rapide et fiable aux contrôleurs de domaine, notamment aux serveurs de catalogue global, est indispensable au bon fonctionnement d'Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'accès à l'annuaire, voir le document sur la compréhension et la résolution des problèmes de l'accès à l'annuaire (http://go.microsoft.com/fwlink/?LinkId=39012).


Le cache utilisateur DSAccess est plein
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches pour déterminer la valeur actuelle de la clé TotalEntriesMemoryUserData. Si l'outil Exchange Server Analyzer Tool détecte que la valeur de TotalEntriesMemoryUserData est égale à la taille totale du cache utilisateur d'accès au service d'annuaire (DSAccess) (MaxMemoryUser), un avertissement s'affiche.

DSAccess est un composant interne d'Exchange 2000 Server et Exchange Server 2003 qui contrôle la manière dont tous les composants Exchange accèdent au service d'annuaire Active Directory®. La fonction principale de DSAccess est de conserver les informations sur divers événements et opérations liés à l'annuaire. Par exemple, DSAccess découvre la topologie Active Directory et détecte si les contrôleurs de domaine et les serveurs de catalogue global sont disponibles et répondent aux demandes. En outre, toutes les requêtes d'annuaire effectuées par des composants Exchange internes, tels que la banque Exchange, sont routées via DSAccess, comme la résolution de destinataire, les recherches de paramètre de configuration, etc. DSAccess gère également un cache interne des résultats de certaines de ces requêtes pour que, si les mêmes informations sont demandées deux fois, elles puissent être récupérées à partir du cache DSAccess plutôt que via une autre requête LDAP (Lightweight Directory Access Protocol) sur Active Directory.

Dans Exchange 2000 Server, le cache utilisateur a été initialement défini sur 25 mégaoctets (Mo). Sur les ordinateurs Exchange 2000 Server qui desservent un grand nombre de clients Microsoft Office Outlook® 2003, la taille du cache utilisateur DSAccess par défaut n'était pas suffisante. Pour améliorer les performances, la valeur par défaut pour le cache utilisateur a été optimisée et définie sur 140 Mo dans Exchange Server 2003.

Comme la taille maximale de paramètre par défaut du cache utilisateur DSAccess a été augmentée d'une valeur de 25 Mo dans Exchange 2000 Server à une valeur de 140 Mo dans Exchange Server 2003, ce message d'avertissement sera probablement généré sur les ordinateurs Exchange 2000 Server. Quelle que soit la version d'Exchange qui génère ce message d'avertissement, le problème doit être résolu dès que possible. Sur les systèmes dont le cache DSAccess est sous dimensionné, la résolution de nom du Carnet d'adresses et de remise des messages locale peut être plus lente que souhaité.

La taille maximale du cache utilisateur peut être configurée manuellement avec une entrée de Registre sur le serveur Exchange. MaxMemoryUser est un paramètre de Registre d'Exchange 2000 Server qui permet à un administrateur Exchange de contrôler la quantité maximale de mémoire pouvant être utilisée par les objets de données utilisateur dans le cache DSAccess.

La valeur MaxMemoryUser est souvent utilisée avec la valeur MaxMemoryConfig, qui contrôle la quantité maximale de mémoire que les objets de données de configuration peuvent utiliser dans le cache DSAccess. Si vous modifiez ou supprimez la valeur MaxMemoryUser comme décrit dans la procédure suivante, vous devez de même modifier ou supprimer la valeur MaxMemoryConfig comme décrit dans l'article sur le Le cache de configuration DSAccess n'est pas défini par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour remédier à ce problème sur un ordinateur Exchange 2000 Server

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Augmentez la valeur de MaxMemoryUser. Si la valeur DWORD n'existe pas, vous pouvez la créer manuellement. Les données de valeur de cette entrée de Registre sont exprimées en kilo-octets (Ko) ; par conséquent, une entrée décimale de 140000 est égale à 140 Mo.

  4. Réduisez la valeur de MaxMemoryConfig. Si la valeur DWORD n'existe pas, vous pouvez la créer manuellement. Les données de valeur pour cette entrée de Registre sont également exprimées en kilo-octets. Une valeur décimale de 5000, qui est égale à 5 Mo, est recommandée.

  5. Quittez l'Éditeur du Registre et redémarrez le service Surveillance du système Microsoft Exchange pour que la modification soit prise en compte.

Pour remédier à ce problème sur un ordinateur Exchange Server 2003

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Si MaxMemoryUser existe et est configurée sur une valeur inférieure à 140 Mo, supprimez la valeur MaxMemoryUser. Si MaxMemoryUser existe et est supérieure à 140 Mo, augmentez sa valeur de 10 %.

  4. Si la valeur MaxMemoryConfig existe, supprimez-la.

  5. Quittez l'Éditeur du Registre et redémarrez le service Surveillance du système Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur DSAccess, voir l'article 250570 de la Base de connaissances sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Le cache utilisateur DSAccess n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées du Registre suivantes pour déterminer si la taille du cache d'objets utilisateur (DSAccess) d'accès au service d'annuaire a été modifiée par rapport à la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

Si Exchange Server Analyzer détecte que la valeur MaxMemoryUser est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

MaxMemoryUser est un paramètre de Registre du serveur Exchange qui permet à un administrateur Exchange de contrôler la quantité maximale de mémoire pouvant être utilisée par les objets de données utilisateur dans le cache DSAccess.

DSAccess est un composant interne d'Exchange 2000 Server et Exchange Server 2003 qui contrôle la manière dont tous les composants Exchange accèdent au service d'annuaire Active Directory®. La fonction principale de DSAccess est de conserver les informations sur divers événements et opérations liés à l'annuaire. Par exemple, DSAccess découvre la topologie Active Directory et détecte si les contrôleurs de domaine et les serveurs de catalogue global sont disponibles et répondent aux demandes. En outre, toutes les requêtes d'annuaire effectuées par des composants Exchange internes, tels que la banque Exchange, sont routées via DSAccess, comme la résolution de destinataire, les recherches de paramètre de configuration, etc. DSAccess gère également un cache interne des résultats de certaines de ces requêtes pour que, si les mêmes informations sont demandées deux fois, elles puissent être récupérées à partir du cache DSAccess plutôt que via une autre requête LDAP (Lightweight Directory Access Protocol) sur Active Directory.

Dans Exchange 2000 Server, le cache utilisateur a été initialement défini sur 25 mégaoctets (Mo). Sur les ordinateurs Exchange 2000 Server qui desservent un grand nombre de clients Microsoft Office Outlook® 2003, la taille du cache utilisateur DSAccess par défaut n'était pas suffisante. Sur les systèmes dont le cache DSAccess est sous dimensionné, la résolution de nom du carnet d'adresses et de remise des messages locale peut être plus lente que souhaitable.

Pour améliorer les performances, la valeur par défaut pour le cache utilisateur a été optimisée et définie sur 140 Mo dans Exchange Server 2003. Lorsque vous effectuez une mise à niveau d'Exchange 2000 Server vers Exchange Server 2003, tout paramètre défini manuellement sera conservé. Si ce serveur Exchange a été mis à niveau d'Exchange 2000 Server vers Exchange Server 2003, vous devez vérifier que la valeur de MaxMemoryUser est d'au moins 140 Mo.

La valeur MaxMemoryUser a souvent été utilisée conjointement avec la valeur MaxMemoryConfig, qui contrôle la quantité maximale de mémoire pouvant être utilisée par des objets de données de configuration dans le cache DSAccess. Si vous modifiez ou supprimez la valeur MaxMemoryUser comme décrit dans la procédure ci-dessous, vous devez de même modifier ou supprimer la valeur MaxMemoryConfig comme décrit dans l'article Le cache de configuration DSAccess n'est pas défini par défaut

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour utiliser la clé de Registre MaxMemoryUser

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Examinez ou modifiez la valeur de MaxMemoryUser.

    La valeur de cette entrée de Registre est exprimée en kilo-octets (Ko). Si la valeur est définie sur 140 000 ou moins, vous devez supprimer MaxMemoryUser et redémarrer le service Surveillance du système Microsoft Exchange pour rétablir le paramètre par défaut d'Exchange Server 2003.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur DSAccess, voir l'article 250570 de la Base de connaissances sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Le service DSProxy RFR a été désactivé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si le service de redirection Directory Services Proxy (DSProxy RFR) a été désactivé :

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

Si Exchange Server Analyzer détecte que No RFR Service est présent et défini sur 1, un message indiquant une configuration autre que celle par défaut s'affiche.

Le composant DSProxy d'Exchange 2000 Server et Exchange Server 2003 fournit un accès à l'annuaire à un contrôleur de domaine ou un catalogue global pour les clients Microsoft Outlook® 98 et Outlook 97. Outlook 2000 Service Release 2 (SR-2) et les versions ultérieures peuvent directement interroger un serveur de catalogue global.

La première fois qu'un client Outlook 2000 SR-2 ou version ultérieure se connecte à un serveur Exchange 2000 ou à un ordinateur d'une version ultérieure, il recherche le service d'annuaire sur le serveur Exchange associé. Outlook passe d'abord par le processus DSProxy pour la toute première session. Une fois que le client contacte le service DSProxy (il essaie tous les protocoles de transport disponibles), une redirection lui est transmise pour l'informer que toutes les futures requêtes d'annuaire doivent arriver au serveur de catalogue global. Outlook définit la redirection dans le profil MAPI du Registre. Le mécanisme de redirection DSProxy réduit la charge sur le serveur Exchange et la latence pour les recherches du carnet d'adresses. Si un nom de serveur explicite est entré dans le profil, Outlook doit être redémarré si ce serveur d'annuaire Active Directory® échoue. Le cas échéant, le serveur Exchange envoie une nouvelle redirection à Outlook.

Dans certains scénarios, vous pouvez forcer les clients Outlook, même pour les dernières versions, à toujours passer par le processus DSProxy sans redirection. Vous pouvez par exemple le faire si un pare-feu existe entre Outlook et le serveur Exchange.

Si vous ajoutez l'entrée de Registre No RFR Service et la définissez sur 1, le serveur Exchange se comporte comme un proxy pour les clients Outlook au lieu de renvoyer les clients vers le serveur de catalogue global approprié pour une communication directe. La définition du paramètre de Registre No RFR Service sur 1 réduit les performances du serveur Exchange car celui-ci agit comme un proxy pour tous clients Outlook, notamment les clients Outlook 2000 SR-2 et versions ultérieures qui peuvent communiquer directement avec Active Directory.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour activer le service DSProxy RFR

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Créez une nouvelle valeur DWORD appelée No RFR Service.

  4. Définissez la valeur No RFR Service sur 1.

Pour désactiver le service DSProxy RFR, supprimez la valeur de Registre No RFR Service ou définissez-la sur 0.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'interaction entre les clients Outlook 2000 SR-2 et versions ultérieures et le service d'annuaire Active Directory, voir l'article 256976 de la Base de connaissances sur l'accès d'Outlook 2000 à Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914).

Pour plus d'informations sur l'accès des clients MAPI à Active Directory, voir l'article 256976 de la Base de connaissances sur l'accès des clients MAPI à Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976).


Le fichier EMSMTA.EXE est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


La clé de Registre EnableAuthEpResolution est activée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé de Registre des restrictions de l'interface d'appel de procédure distante (RPC) est activée :

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Si Exchange Server Analyzer détecte que la valeur de Registre EnableAuthEpResolution existe, il affiche un message indiquant une configuration autre que celle par défaut.

Les restrictions de l'interface d'appel de procédure distante (RPC) offrent une protection réseau accrue qui diminuera la vulnérabilité des systèmes aux attaques sur le réseau.

Une interface RPC, disponible à distance et de manière anonyme et enregistrée par défaut sur Microsoft Windows® XP, présente des risques d'attaques importants. L'appel de procédure distante doit également s'enregistrer comme une interface pour fournir une résolution de point final pour les appels utilisant des points finaux dynamiques. La clé de Registre RestrictRemoteClients modifie le comportement de toutes les interfaces d'appel de procédure distante (RCP) du système. Par défaut, la clé de Registre RestrictRemoteClients empêche l'accès anonyme à distance aux interfaces d'appel de procédure distante (RCP) du système, avec quelques exceptions. Par conséquent, l'interface du programme de mappage de points finaux RPC n'est plus disponible de manière anonyme.

Un client RPC qui tente d'appeler à l'aide d'un point final dynamique va d'abord interroger le programme de mappage de points finaux RPC sur le serveur pour déterminer le point final dynamique auquel il doit se connecter. La demande est anonyme, même si l'appel du client RPC est effectué à l'aide de la sécurité RPC. Par défaut, les appels anonymes vers l'interface du programme de mappage de points finaux RPC échoueront avec Microsoft Windows XP Service Pack 2 car la fonctionnalité RestrictRemoteClients par défaut empêche l'accès distant anonyme aux interfaces RPC sur le système. Étant donné cette restriction de l'interface RPC, l'exécution du client RPC est modifiée pour réaliser une demande authentifiée auprès du programme de mappage de points finaux. Cette restriction de l'interface RPC est le comportement par défaut dans Windows XP Service Pack 2. L'exécution du client RPC utilise ensuite l'authentification intégrée Windows, appelée auparavant NTLM, pour authentifier le programme de mappage de points finaux. L'authentification intégrée Windows se produit si l'appel du client RPC utilise ce type d'authentification. Un message indiquant une configuration autre que celle par défaut apparaît si les conditions suivantes existent :

  • La clé de Registre RPC et la valeur EnableAuthEpResolution décrites ont été créées.

  • La valeur de Registre EnableAuthEpResolution a été définie sur 0.

Pour plus d'informations sur les modifications apportées au service RPC dans Windows XP Service Pack 2, voir l'article sur les limitations de l'interface RCP (http://go.microsoft.com/fwlink/?LinkId=47371).


Longueur de la file d'attente à partir du client Epoxy (IMAP) au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Client Out Queue Length (IMAP) de l'objet de performance Epoxy pour les analyser.

Le compteur de performance Client Out Queue Length (IMAP) indique le nombre de messages dans la file d'attente qui contiennent des messages IMAP4 envoyés par le processus Inetinfo.exe au processus Store.exe. La file d'attente devrait toujours être inférieure à 50. Si Exchange Server Analyzer détermine que le compteur Client Out Queue Length (IMAP) a dépassé la valeur maximale de 50 pendant une période-exemple, il affiche une erreur.

Epoxy (ExIPC) est un mécanisme de mémoire partagée qui permet aux processus des services IIS Microsoft (Inetinfo.exe) et de banque d'informations Microsoft Exchange (Store.exe) de transférer rapidement les données. Ce mécanisme permet une communication bidirectionnelle interprocessus entre les processus Inetinfo.exe et Store.exe.

Remarque :
Le processus Inetinfo.exe accepte les demandes de protocoles Internet tels que WebDAV, IMAP4, NNTP, POP3 et SMTP.

Cette mémoire est également utilisée par DSAccess, le composant d'Exchange qui met en cache les informations d'Active Directory®.

Cette erreur indique que des problèmes de performances dans le processus Store.exe ou dans des ressources desquelles dépend le processus Store.exe, provoquent l'accroissement de cette file d'attente. Par conséquent, le temps de réponse du serveur augmente.

Pour résoudre ce problème, utilisez les ressources auxquelles la section « Plus d'informations » fait référence pour identifier le goulot d'étranglement des performances à l'aide du processus Store.exe ou de ressources associées. Ce goulot d'étranglement peut être lié à des performances de disque réduites ou à une utilisation élevée du processeur.

Pour plus d'informations

  • Pour plus d'informations sur l'identification des files d'attente croissantes dans Epoxy, voir la section sur l'identification des files d'attente croissantes dans Epoxy dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur la résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Longueur de la file d'attente à partir du client Epoxy (POP) au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Client Out Queue Length (POP) de l'objet de performance Epoxy pour les analyser.

Le compteur de performance Client Out Queue Length (POP) indique le nombre de messages dans la file d'attente qui contiennent des messages POP3 envoyés par le processus Inetinfo.exe au processus Store.exe. La file d'attente devrait toujours être inférieure à 50. Exchange Server Analyzer récupère de ce compteur un exemple toutes les 5 secondes pour une période de 5 minutes. Si Exchange Server Analyzer détermine que le compteur Client Out Queue Length (POP) a dépassé la valeur maximale de 50 pendant une période-exemple, il affiche une erreur.

Epoxy (ExIPC) est un mécanisme de mémoire partagée qui permet aux processus des services IIS Microsoft (Inetinfo.exe) et de banque d'informations Microsoft Exchange (Store.exe) de transférer rapidement les données. Ce mécanisme permet une communication bidirectionnelle interprocessus entre les processus Inetinfo.exe et Store.exe.

Remarque :
Le processus Inetinfo.exe accepte les demandes de protocoles Internet tels que WebDAV, IMAP4, NNTP, POP3 et SMTP.

Cette mémoire est également utilisée par DSAccess, le composant d'Exchange qui met en cache les informations d'Active Directory®.

Cette erreur indique que des problèmes de performances dans le processus Store.exe ou dans des ressources desquelles dépend le processus Store.exe, provoquent l'accroissement de cette file d'attente. Par conséquent, le temps de réponse du serveur augmente.

Pour résoudre ce problème, utilisez les ressources auxquelles la section « Plus d'informations » fait référence pour identifier le goulot d'étranglement des performances à l'aide du processus Store.exe ou de ressources associées. Ce goulot d'étranglement peut être lié à des performances de disque réduites ou à une utilisation élevée du processeur.

Pour plus d'informations

  • Pour plus d'informations sur l'identification des files d'attente croissantes dans Epoxy, voir la section sur l'identification des files d'attente croissantes dans Epoxy dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur la résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Le fichier EPOXY.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Objet d'analyseur de performances epoxy non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Client Out Queue Length de l'objet de performance Epoxy pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet d'analyseur de performances Epoxy est désactivé.

  • L'objet d'analyseur de performances Epoxy est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. La procédure suivante explique comment corriger les deux premières conditions. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance Epoxy est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe (Extensible Performance Counter List) à l'adresse http://go.microsoft.com/fwlink/?LinkId=34436.

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller Exchange Server en mode Réparer et appliquer les derniers Service Packs d'Exchange Server.


Longueur de la file d'attente à partir de la banque Epoxy (IMAP) au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Store Out Queue Length (IMAP) de l'objet de performance Epoxy pour les analyser.

Le compteur de performance Store Out Queue Length (IMAP) indique le nombre de messages dans la file d'attente qui contiennent des messages IMAP4 envoyés par le processus Store.exe au processus Inetinfo.exe. La file d'attente devrait toujours être inférieure à 50. Exchange Server Analyzer récupère de ce compteur un exemple toutes les 5 secondes pour une période de 5 minutes. Si Exchange Server Analyzer détermine que le compteur Store Out Queue Length (IMAP) a dépassé la valeur maximale de 50 pendant une période-exemple, il affiche une erreur.

Epoxy (ExIPC) est un mécanisme de mémoire partagée qui permet aux processus des services IIS Microsoft (Inetinfo.exe) et de banque d'informations Microsoft Exchange (Store.exe) de transférer rapidement les données. Ce mécanisme permet une communication bidirectionnelle interprocessus entre les processus Inetinfo.exe et Store.exe.

Remarque :
Le processus Inetinfo.exe accepte les demandes de protocoles Internet tels que WebDAV, IMAP4, NNTP, POP3 et SMTP.

Cette mémoire est également utilisée par DSAccess, le composant d'Exchange qui met en cache les informations d'Active Directory®.

Cette erreur indique que des problèmes de performances dans le processus Inetinfo.exe ou dans des ressources desquelles dépend le processus Inetinfo.exe, provoquent l'accroissement de cette file d'attente. Par conséquent, le temps de réponse du serveur peut augmenter. Les utilisateurs seront donc confrontés à des retards de réponse du serveur.

Pour résoudre ce problème, utilisez les ressources auxquelles la section « Plus d'informations » fait référence pour identifier le goulot d'étranglement des performances à l'aide d'Inetinfo.exe ou de ressources associées. Ce goulot d'étranglement peut être lié à des performances de disque réduites ou à une utilisation élevée du processeur.

Pour plus d'informations

  • Pour plus d'informations sur l'identification des files d'attente croissantes dans Epoxy, voir la section sur l'identification des files d'attente croissantes dans Epoxy dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur la résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Longueur de la file d'attente à partir de la banque Epoxy (POP) au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Store Out Queue Length (POP) de l'objet de performance Epoxy pour les analyser.

Le compteur de performance Store Out Queue Length (POP) indique le nombre de messages dans la file d'attente qui contiennent des messages POP3 envoyés par le processus Store.exe au processus Inetinfo.exe. La file d'attente devrait toujours être inférieure à 50. Exchange Server Analyzer récupère de ce compteur un exemple toutes les 5 secondes pour une période de 5 minutes. Si Exchange Server Analyzer détermine que le compteur Store Out Queue Length (POP) a dépassé la valeur maximale de 50 pendant une période-exemple, il affiche une erreur.

Epoxy (ExIPC) est un mécanisme de mémoire partagée qui permet aux processus des services IIS Microsoft (Inetinfo.exe) et de banque d'informations Microsoft Exchange (Store.exe) de transférer rapidement les données. Ce mécanisme permet une communication bidirectionnelle interprocessus entre les processus Inetinfo.exe et Store.exe.

Remarque :
Le processus Inetinfo.exe accepte les demandes de protocoles Internet tels que WebDAV, IMAP4, NNTP, POP3 et SMTP.

Cette mémoire est également utilisée par DSAccess, le composant d'Exchange qui met en cache les informations d'Active Directory®.

Cette erreur indique que des problèmes de performances dans le processus Inetinfo.exe ou dans des ressources desquelles dépend le processus Inetinfo.exe, provoquent l'accroissement de cette file d'attente. Par conséquent, le temps de réponse du serveur peut augmenter. Les utilisateurs seront donc confrontés à des retards de réponse du serveur.

Pour résoudre ce problème, utilisez les ressources auxquelles la section « Plus d'informations » fait référence pour identifier le goulot d'étranglement des performances à l'aide d'Inetinfo.exe ou de ressources associées. Ce goulot d'étranglement peut être lié à des performances de disque réduites ou à une utilisation élevée du processeur.

Pour plus d'informations

  • Pour plus d'informations sur l'identification des files d'attente croissantes dans Epoxy, voir la section sur l'identification des files d'attente croissantes dans Epoxy dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur la résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Erreur lors de l'accès à Exchange Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool ne peut pas accéder à votre serveur Exchange. Cette erreur indique que les informations de configuration du serveur Exchange que vous avez spécifiées ne se trouvaient pas dans le service d'annuaire Active Directory®.

Pour corriger cette erreur

  • Assure-vous d'avoir entré le nom du serveur correctement.

  • Entrez uniquement le nom de l'hôte ou NetBIOS du serveur (par exemple, Serveur1) et non le nom de domaine complet (par exemple, Serveur1.exemple.com).

  • Vérifiez que vous disposez des autorisations nécessaires pour accéder aux informations de configuration d'Active Directory pour ce serveur.


Erreur lors de l'accès aux informations d'Exchange Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool rencontre des problèmes d'accès aux informations de configuration du service d'annuaire Active Directory® pour le serveur Exchange.

Pour corriger cette erreur :

  • Vérifiez que votre compte de connexion actuel dispose des autorisations appropriées à la lecture d'informations de configuration du serveur Exchange dans Active Directory.

  • Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.

  • Entrez des informations d'identification de compte explicites dans l'outil Exchange Server Analyzer Tool pour accéder à Active Directory.

  • Spécifiez un contrôleur de domaine Active Directory dans Exchange Server Analyzer.

  • Vérifiez que le serveur Exchange spécifié existe et que vous avez tapé son nom correctement.


Erreur lors de l'accès au journal de suivi des messages
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-06

L'outil Microsoft® Exchange Server Analyzer Tool interroge la propriété MessageID de chaque instance de la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry.

Si Exchange Server Analyzer n'obtient pas de résultat, il affiche une erreur.

La cause la plus probable de cette erreur est que le Centre de suivi des messages est désactivé.

Lorsqu'il est activé, le Centre de suivi des messages enregistre des informations concernant l'expéditeur, le message et ses destinataires. En particulier, vous pouvez consulter des statistiques telles que l'heure d'envoi ou de réception d'un message, la taille de ce dernier, sa priorité, ainsi que la liste de ses destinataires. Vous pouvez également enregistrer la ligne d'objet des messages électroniques. Le Centre de suivi des messages cherche des messages tels que les messages système, les messages des dossiers publics et les messages électroniques.

Vous devez activer le Centre de suivi des messages sur chaque serveur où vous souhaitez effectuer le suivi des messages. Une fois l'activation effectuée, tous les messages routés par un serveur sont ajoutés aux journaux de suivi de messages.

Exchange Server Analyzer exige que le suivi des messages soit activé pour commencer ses analyses.

Remarque :
L'exécution de cette procédure nécessite les autorisations suivantes : membre du groupe Administrateurs local et membre d'un groupe ayant le rôle d'administrateur Exchange appliqué au niveau du groupe d'administration
Pour activer le Centre de suivi des messages sur un serveur

  1. Dans le Gestionnaire système Exchange, développez Serveurs, cliquez avec le bouton droit sur le serveur sur lequel vous souhaitez activer le suivi des messages, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, activez la case à cocher Activer le suivi des messages.

  3. Pour enregistrer l'objet de tout message envoyé depuis, vers ou via le serveur, activez la case à cocher Activer l'enregistrement et l'affichage de l'objet des messages.

    Remarque :
    L'activation de l'enregistrement des messages peut entraîner une diminution des performances.

  4. Sous Maintenance des fichiers journaux, vous pouvez empêcher la suppression des fichiers journaux ou modifier leur délai de garde. Par défaut, les journaux de suivi sont conservés pendant sept jours.

    Remarque :
    Sur les serveurs qui traitent de grandes quantités de courrier, la taille des journaux de suivi augmente rapidement. Assurez-vous que vous disposez d'un espace disque suffisant pour les fichiers journaux et les autres services ou applications qui utilisent ce disque.

  5. Cliquez sur OK ou sur Appliquer. Vous ne devez redémarrer aucun service pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation du Centre de suivi des messages, voir l'article 262162 de la Base de connaissances Microsoft sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).

Pour plus d'informations sur la procédure de résolution des problèmes de transport d'Exchange Server, voir l'article 821910 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de transport d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910).


Erreur lors de la mise à niveau des ACL
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-15

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si une erreur Événement 9551 a été enregistrée pour MSExchangeIS au cours de la dernière heure.

Si Exchange Analyzer détecte qu'une erreur Événement 9551 a été enregistrée au cours de la dernière heure, il compte le nombre total d'erreurs Événement 9551 enregistrées pour cette heure.

Enfin, si Exchange Analyzer détecte qu'une erreur Événement 9551 a été enregistrée au cours des dernières 20 heures ou plusieurs fois au cours de la dernière heure, il affiche un avertissement.

Cette erreur indique que des comptes d'utilisateur peuvent apparaître dans la liste de contrôle d'accès (ACL) pour une ressource de boîte aux lettres ou un dossier public mais ne sont pas associés à des objets valides du service d'annuaire Active Directory.

Une boîte aux lettres qui se trouve sur un serveur exécutant Microsoft Exchange Server 2003 ou Exchange 2000 Server doit être représentée dans Active Directory par un compte d'utilisateur valide du service d'annuaire Active Directory pour être accessible.

Un compte sans représentation valide dans Active Directory peut être créé si la ressource de boîte aux lettres ou le dossier public Exchange 2000 Server ou Exchange Server 2003 n'est pas actualisé après la suppression d'une boîte aux lettres sur l'ordinateur Exchange Server 5.5.

Si le compte de la boîte aux lettres supprimée reste sur l'ACL d'une ressource de boîte aux lettres ou d'un dossier public, à chaque accès à la ressource de boîte aux lettres ou au dossier public et tentative de résolution des comptes répertoriés par Exchange, le compte sans représentation valide dans Active Directory ne peut être résolu. Ce processus peut se déclarer comme un problème de performances.

Pour résoudre ce problème :

  • Assurez-vous qu'Exchange 2000 Server Service Pack 3 (SP3) ou une version ultérieure est installée. Pour obtenir le dernier Service Pack pour Exchange 2000 Server, consultez l'article 301378 de la Base de connaissances Microsoft sur l'obtention du dernier Service Pack d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

  • Utilisez le Gestionnaire système Exchange pour supprimer manuellement les comptes de boîte aux lettres non valide de l'ACL.

  • Si l'environnement Exchange est en mode mixte Exchange, exécutez le Vérificateur de cohérence SA/BI dans la banque d'informations.

  • Si l'environnement Exchange est en mode natif Exchange, suivez les instructions de l'article 324323 de la Base de connaissances Microsoft sur la manière d'ignorer les comptes d'utilisateur qui ne sont pas représentés dans Active Directory pendant la conversion de la liste de contrôle d'accès (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323).

Utilisation du Gestionnaire système Exchange pour supprimer manuellement les comptes de boîte aux lettres non valide de l'ACL

  1. Démarrez le Gestionnaire système Exchange et localisez le dossier identifié par l'erreur 9551.

  2. Cliquez avec le bouton droit sur le dossier et sélectionnez Propriétés.

  3. Sélectionnez l'onglet Autorisations, puis cliquez sur Autorisations client.

  4. Dans le volet Nom, sélectionnez le compte d'utilisateur identifié par l'erreur 9551, puis cliquez sur le bouton Supprimer pour supprimer le compte de l'ACL.
Exécution du Vérificateur de cohérence SA/BI dans la banque d'informations en mode mixte Exchange

  1. Dans le programme Administrateur Exchange Server 5.5, cliquez sur l'ordinateur Exchange 5.5 Server qui contient la banque d'informations.

  2. Dans le menu Fichier, cliquez sur Propriétés, puis cliquez sur l'onglet Paramètres avancés.

  3. Cliquez sur Vérification de cohérence.

  4. Cliquez pour activer les cases à cocher Supprimer les comptes d'utilisateur inconnus des autorisations des dossiers publics et Supprimer les comptes d'utilisateur inconnus des autorisations des boîtes aux lettres, puis cliquez sur Toutes les incohérences.

  5. Cliquez pour désactiver toutes les autres cases à cocher, puis cliquez sur OK.

Pour plus d'informations

Pour plus d'informations sur ce problème, consultez les articles suivants de la Base de connaissances Microsoft et les ressources Exchange Server :

  • Centre des événements et des messages d'erreur : Détails sur l'événement : détails sur l'événement 9551 de la banque de boîtes aux lettres MSExchangeIS (http://go.microsoft.com/fwlink/?LinkId=83189).

  • article 301378 de la Base de connaissances Microsoft sur la procédure d'obtention du dernier Service Pack pour Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

  • Article 324323 de la Base de connaissances Microsoft sur la manière d'ignorer les comptes d'utilisateur qui ne sont pas représentés dans Active Directory pendant la conversion de la liste de contrôle d'accès (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323).


Le fichier ESE.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=33457).


Le fichier ESEUTIL.EXE est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXCDO.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXCHMEM.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXMIME.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXOLEDB.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXPOP3.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXPROX.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXRES.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier EXSMTP.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


La version du fichier EXSMTP.DLL est obsolète
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour EXSMTP.DLL. Si Exchange Server Analyzer détermine que la valeur de la clé Version pour EXSMTP.DLL n'est pas égale à 6556.0, un avertissement s'affiche.

Cet avertissement indique que la version d'EXSMTP.DLL sur cet ordinateur Exchange Server provient du correctif Exchange 2000 Server post-Service Pack 3 mai 2004 version 1. Un correctif plus récent est téléchargeable.

Pour supprimer cet avertissement

  1. Téléchargez la dernière mise à jour (août 2004) à partir du site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Pour plus d'informations sur la dernière mise à jour, voir l'article 870540 de la Base de connaissances Microsoft sur la disponibilité du correctif cumulatif post-Service Pack 3 Exchange 2000 Server et daté d'août 2004 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Appliquez la mise à jour août 2004.

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article de la Base de connaissances Microsoft sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Le suivi Exchange ActiveSync est actuellement activé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le suivi a été activé pour Exchange ActiveSync® :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

Si Exchange Server Analyzer détecte que la valeur d'Enabled est présente et configurée avec une valeur supérieure à 0, un avertissement s'affiche.

Exchange ActiveSync est exécuté comme une extension ISAPI dans les services IIS (Internet Information Services). IIS, Exchange ActiveSync et la plupart des périphériques clients qui utilisent Exchange ActiveSync comprennent des fonctions natives de suivi et, par conséquent, celles de Microsoft Windows Server™ 2003 leur sont inutiles.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync

  3. Supprimez la valeur Enabled.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le suivi et l'enregistrement des clients Exchange ActiveSync et Exchange ActiveSync, voir les articles suivants de la Base de connaissances :

  • 330463 sur la procédure de résolution des codes d'erreur HTTP d'Exchange Server ActiveSync (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330463).

  • 330461 sur la procédure de dépannage d'Exchange Server ActiveSync (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330461).

  • 822176 sur le dépannage de notification actualisée d'Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822176).


La version du fichier binaire Exchange est plus récente que la version installée de Exchange Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier est supérieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version ultérieur indique qu'un fichier est plus récent que prévu. Cela peut se produire si un correctif a été installé.

Pour supprimer cet avertissement

  1. Aucune action ne doit être entreprise. Cet avertissement indique uniquement la présence de fichiers plus récents, probablement en raison de l'installation d'un correctif ou d'une autre mise à jour.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le nœud de cluster Exchange est également un contrôleur de domaine
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge l'objet WMI (Windows® Management Instrumentation) Microsoft (classe Win32_ComputerSystem) pour déterminer la valeur DomainRole pour le serveur. La valeur DomainRole représente le rôle d'un ordinateur dans un domaine. Le tableau ci-dessous répertorie les valeurs valides pour DomainRole.

Valeur | Signification
0 | Station de travail autonome
1 | Station de travail membre
2 | Serveur autonome
3 | Serveur membre
4 | Contrôleur secondaire de domaine
5 | Contrôleur de domaine principal

En outre, Exchange Server Analyzer interroge l'objet WMI ClusSvc (objet du service de cluster Windows, classe Win32_Service) pour déterminer sa valeur Started. La valeur True indique que le service de cluster est démarré et la valeur False qu'il n'est pas en cours d'exécution.

Si Exchange Server Analyzer détermine que la valeur DomainRole est supérieure à 3 sur un ordinateur Exchange Server sur lequel le service de cluster est démarré, une erreur s'affiche. Cette erreur indique qu'un serveur Exchange s'exécute dans un cluster de serveurs Windows dont les nœuds sont des contrôleurs de domaine.

L'exécution d'un nœud de cluster de serveurs Exchange en tant que contrôleur de domaine n'est pas une configuration prise en charge.

Pour corriger cette erreur

  1. Sélectionnez un serveur non ordonné en clusters devant agir en tant que le contrôleur de domaine et exécutez l'Assistant Installation d'Active Directory (dcpromo) pour promouvoir ce serveur.

  2. Une fois le service d'annuaire Active Directory® configuré sur le nouveau contrôleur de domaine, attendez que le contenu Active Directory existant soit répliqué vers le nouveau serveur.

    Selon la taille d'Active Directory, cette opération peut prendre plusieurs heures.

  3. Exécutez l'Assistant Installation d'Active Directory (dcpromo) sur le serveur de cluster pour rétrograder le serveur et supprimer Active Directory.

Pour plus d'informations sur la promotion et la rétrogradation des contrôleurs de domaine, voir l'article 238369 de la Base de connaissances Microsoft sur la procédure à suivre pour promouvoir et rétrograder des contrôleurs de domaine dans Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=238369).


Le rapport d'erreurs Exchange est désactivé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le rapport d'erreurs Exchange est activé :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

Si Exchange Server Analyzer détecte que la valeur de DisableErrorReporting est égale à 1, un avertissement s'affiche. Une valeur de 1 indique que le rapport d'erreurs Exchange est désactivé.

La prise en charge du rapport d'erreurs Microsoft (également appelé rapport d'erreurs Windows, rapport d'événements Microsoft et rapport d'erreurs automatique) a d'abord été ajoutée avec Exchange 2000 Server Service Pack 2. Exchange Server 2003 intègre une version optimisée du rapport d'erreurs Microsoft appelée rapport d'erreurs Exchange, qui rationalise les rapports d'erreurs aux administrateurs, s'intègre au rapport d'erreurs de la société et offre une fonctionnalité de rapport optimisée pour le service de mise à jour de destinataire d'Exchange Server 2003.

Le rapport d'erreurs Exchange permet aux administrateurs Exchange Server de transmettre, via HTTPS sur Internet, des blocages ou d'autres erreurs irrécupérables à un serveur de rapport d'erreurs Microsoft. Il est recommandé d'envoyer des rapports d'erreurs à l'Analyse des incidents en ligne Microsoft®. La collecte des données sur les erreurs irrécupérables des serveurs Exchange aide l'équipe d'Exchange à repérer et à corriger les erreurs des logiciels que vous utilisez.

Si une erreur irrécupérable se produit lors de l'utilisation du Gestionnaire système Exchange ou de l'exécution d'une tâche relative à Exchange avec Utilisateurs et ordinateurs Active Directory sur un ordinateur où le Gestionnaire système Exchange est installé, le rapport d'erreurs Exchange signale l'erreur à l'administrateur et l'invite à signaler l'erreur à Microsoft. En outre, le rapport d'erreurs Exchange intercepte et signale également les erreurs rencontrées par les services Surveillance du système Microsoft Exchange, Banque d'informations de Microsoft Exchange, etc. En outre, comme les erreurs rencontrées par le service de mise à jour de destinataire peuvent laisser le composant du service Surveillance du système en mauvais état, le rapport d'erreurs Exchange signale également les violations d'accès et autres erreurs internes qui se produisent dans le service de mise à jour de destinataire.

Vous pouvez configurer chaque serveur Exchange pour qu'il envoie des informations sur les erreurs irrécupérables en activant la case à cocher adéquate dans la page de propriétés du serveur dans le Gestionnaire système Exchange.

Pour configurer Exchange 2000 Server ou Exchange Server 2003 pour qu'ils envoient des données sur les erreurs du serveur à Microsoft

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre serveur, puis cliquez sur Propriétés. Si le nœud Groupes d'administration n'est pas affiché dans le Gestionnaire système Exchange, développez Serveurs, cliquez avec le bouton droit sur votre serveur, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page Propriétés de <Nom_serveur>, activez la case à cocher Envoyer automatiquement les informations sur l'erreur irrécupérable du service à Microsoft, puis cliquez sur Appliquer.

  4. Cliquez sur Oui pour confirmer que vous souhaitez activer le rapport d'erreurs Exchange.

  5. Cliquez sur OK.

En cas d'erreur irrécupérable, un fichier de rapport d'erreurs compressé est créé (généralement 10 à 50 kilo-octets). Ce rapport contient, entre autres, un fichier de vidage. Un fichier de vidage contient des informations sur le processus qui a rencontré l'erreur. Bien que les erreurs puissent se produire à différents niveaux de programmation (par exemple au niveau des threads, de l'interface, de la méthode ou du fonctionnement), elles se produisent toutes dans le cadre d'un seul processus. Le fichier de vidage comprend généralement des informations sur les processus défaillants, telles que des détails sur les actions de chaque thread, les diverses zones de la mémoire utilisées par le processus, des informations système et d'autres informations pertinentes sur le débogage. Avec Exchange Server, les rapports d'erreurs comprennent également des informations sur l'état d'Exchange Server, la version du système d'exploitation, le matériel informatique, l'adresse IP de l'ordinateur et l'ID de produit numérique, qui est utilisé pour identifier la licence du produit.

Alors que Microsoft collecte involontairement des informations personnelles, il reconnaît que certaines informations collectées peuvent contenir des données qui pourraient être utilisées pour identifier votre système de manière unique. Cependant, Microsoft n'utilise pas les données collectées de cette manière et ne s'en sert que pour les rapports sur les incidents et les résolutions de bogue. Pour plus d'informations, voir la stratégie de rapport d'erreurs sur la stratégie de collecte des données (http://go.microsoft.com/fwlink/?LinkId=33818).


Ce serveur frontal Exchange comporte le commutateur de démarrage /3GB dans le fichier Boot.ini
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur (MaxProcessMemorySize) sur l'ordinateur Exchange Server. Exchange Server Analyzer examine également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique qu'il s'agit d'un serveur frontal.

Si Exchange Server Analyzer détermine que la valeur de la clé MaxProcessMemorySize n'est pas égale à 2097024 et que la clé IsFrontEndServer a la valeur True, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server n'est pas correctement configuré pour une utilisation optimale de la mémoire, étant donné que le commutateur de démarrage /3GB a été défini dans le fichier Boot.ini. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 gigaoctet (Go), fonctionnant avec les systèmes d'exploitation suivants :

  • Microsoft Windows Server™ 2003 Édition Standard

  • Microsoft Windows Server 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation susmentionnés lorsqu'au moins 1 Go de mémoire physique est installé.

Lorsque le paramètre /3GB est inclus dans le fichier Boot.ini d'un serveur exécutant Microsoft Windows 2000 Server ou Windows Server 2003, Windows alloue 3 Go, sur un maximum de 4 Go d'espace d'adresse virtuelle, au processus utilisateur et 1 Go au noyau. Normalement (lorsque le paramètre /3GB n'est pas utilisé), Windows attribue 2 Go au processus utilisateur et 2 Go au noyau. Par conséquent, grâce au commutateur /3GB, les applications gourmandes en mémoire possèdent un espace d'adressage mémoire virtuel plus important et les performances sont améliorées.

L'utilisation du commutateur /3GB aide principalement les applications gourmandes en mémoire comme le processus Store.exe sur un serveur Exchange hébergeant des boîtes aux lettres d'utilisateurs. Un serveur frontal n'hébergeant pas de boîtes aux lettres d'utilisateurs, l'utilisation du commutateur /3GB ne présente aucun avantage sur un serveur frontal.

Pour supprimer cet avertissement

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur l'onglet Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur, cliquez avec le bouton droit sur le fichier, cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes lignes de démarrage : /3GB

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation du commutateur de démarrage /3GB, voir les articles suivants de Base de connaissances Microsoft :

  • 297812 sur l'utilisation de la fonctionnalité de réglage de RAM 4GT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 31679 sur l'utilisation du commutateur /USERVA dans le fichier Boot.ini pour régler les configurations /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Le lecteur IFS Exchange n'a pas été explicitement exclu de l'utilitaire de sauvegarde Windows
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les fichiers et dossiers qui ont été exclus des sauvegardes à l'aide de l'utilitaire de sauvegarde :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer recherche spécifiquement une valeur de chaîne nommée Exchange IFS.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour obtenir la lettre de lecteur qui représente le lecteur Exchange Installable File System (IFS) :

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

La lettre de lecteur par défaut dans Exchange 2000 Server est M. Le lecteur IFS est désactivé par défaut dans Exchange Server 2003.

Si Exchange Server Analyzer détecte que la clé FilesNotToBackup ne contient pas une valeur de chaîne nommée Exchange IFS, ou s'il contient Exchange IFS mais les données de valeur pour Exchange IFS sont différentes de M:\* /s (où M correspond à la lettre du lecteur représentant IFS), un avertissement s'affiche.

Par défaut, lorsque le mappage IFS de lettre de lecteur est activé, Exchange IFS est ajouté à la clé de Registre FilesNotToBackup. Le lecteur M:\ est une vue logique de la banque Exchange, pas un lecteur réel, et sa sauvegarde peut entraîner des problèmes importants, tels que la perte des pièces jointes. En outre, le logiciel de sauvegarde peut ne pas tronquer les fichiers journaux comme il convient, le serveur manquera alors inopinément d'espace disque.

Si vous n'utilisez pas l'utilitaire de sauvegarde, vous pouvez ignorer cet avertissement en toute sécurité. Si vous utilisez l'utilitaire de sauvegarde, il est recommandé d'exclure le lecteur IFS de toutes les opérations de sauvegarde. Si vous sauvegardez le lecteur IFS à l'aide de l'utilitaire de sauvegarde ou de tout autre programme de sauvegarde, vous risquez d'endommager vos bases de données de banque d'informations, de perdre des données et de ne pas parvenir à restaurer les données à partir d'une sauvegarde du lecteur IFS.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Cliquez avec le bouton droit sur FilesNotToBackup et cliquez sur Nouveau | Valeur de chaînes multiples. Tapez le nom Exchange IFS et appuyez sur Entrée.

  4. Dans le volet droit, double-cliquez sur Exchange IFS et entrez une valeur de M:\* /s. Veillez à utiliser la lettre de lecteur correcte si votre système n'utilise pas la lettre de lecteur par défaut M.

  5. Fermez l'Éditeur du Registre.

Pour plus d'informations sur le Registre de Microsoft Windows®, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations sur la sauvegarde et la récupération dans Exchange, voir le Guide des opérations de récupération d'urgence de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47570). Pour plus d'informations, voir les articles suivants de la Base de connaissances :

  • 258243 sur la procédure de sauvegarde et de restauration d'un ordinateur Exchange à l'aide de l'utilitaire de sauvegarde Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258243)

  • 233427 sur les fichiers et les dossiers qui ne sont pas sauvegardés lorsque l'outil Ntbackup.exe est utilisé dans Windows Server 2003, Windows XP et Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427)

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS à l'aide d'un logiciel antivirus, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lorsque vous montez des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Le serveur de boîtes aux lettres Exchange a au moins 1 Go de mémoire mais /3GB n'est pas défini dans le fichier Boot.ini
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge deux classes WMI (Windows® Management Instrumentation) Microsoft pour déterminer la quantité de mémoire physique sur le serveur Exchange ainsi que la quantité d'espace d'adresse virtuelle allouée aux processus en mode utilisateur. Le tableau suivant décrit les classes et les clés évaluées par Exchange Server Analyzer.

Classe demandée | Clés demandées | Description
Win32_OperatingSystem | MaxProcessMemorySize | Nombre maximal de kilo-octets de mémoire pouvant être alloués à un processus.
Win32_OperatingSystem | OSProductSuite | Programmes supplémentaires du système d'exploitation installés et sous licence.
Win32_ComputerSystem | TotalPhysicalMemory | Nombre d'octets de mémoire vive (RAM) installés sur l'ordinateur.

Si Exchange Server Analyzer détecte que l'ordinateur Exchange Server n'utilise pas Windows 2000 Server et dispose d'au moins 1 Go de mémoire physique, et que la valeur de MaxProcessMemorySize est supérieure à 2097024 mais inférieure à 3104640, un avertissement s'affiche.

Cet avertissement indique que le serveur Exchange ne respecte pas les exigences mentionnées dans l'article 266096 de la Base de connaissances Microsoft sur Exchange 2000 qui requiert le commutateur /3GB avec plus de 1 gigaoctet de RAM physique (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096). Cette configuration n'est pas recommandée pour la production.

Microsoft Windows Server™ 2003 inclut la prise en charge de deux commutateurs de démarrage, /3GB et /USERVA, qui vous permettent de régler l'allocation de l'utilisation de la mémoire et de l'espace d'adressage mémoire. Quelle que soit la quantité de mémoire physique de votre système, Windows utilise un espace d'adresse virtuelle de 4 Go, dont 2 Go sont alloués aux processus en mode utilisateur (applications, par exemple) et 2 Go aux processus en mode noyau (système d'exploitation et pilotes en mode noyau, par exemple). Sur les systèmes disposant d'au moins 1 Go de mémoire physique, ces deux commutateurs de démarrage peuvent être utilisés pour allouer davantage de mémoire aux applications (3 Go) et moins au système d'exploitation (1 Go). Cet espace d'adresse virtuelle supplémentaire permet de réduire la fragmentation de mémoire dans l'espace d'adresse virtuel du processus de banque d'informations d'Exchange.

Le commutateur /3GB sert pour effectuer ce changement d'allocation. Le commutateur est entré dans le fichier Boot.ini du système et prend effet après un redémarrage. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 Go, fonctionnant avec les systèmes d'exploitation suivants :

  • Microsoft Windows Server 2003 Édition Standard

  • Microsoft Windows Server 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation susmentionnés lorsqu'au moins 1 Go de mémoire physique est installé.

Nouveau dans Windows Server 2003, le commutateur /USERVA est destiné à améliorer le contrôle de la division de l'espace d'adresse virtuelle entre les processus en mode utilisateur et ceux en mode noyau. Il ne doit être utilisé que pour des applications qui le prennent en charge, telles qu'Exchange 2000 Server et Exchange Server 2003, et avec les valeurs spécifiques que celles-ci prennent en charge.

Remarque :
Les services du Support Technique de Microsoft ne prennent pas en charge des paramètres /USERVA arbitraires. Les clients doivent ajouter ce paramètre au fichier Boot.ini sur instruction du fabricant.

En cas d'utilisation sur des systèmes Exchange Server 2003, la seule valeur prise en charge pour /USERVA est 3030 (par exemple, /USERVA=3030). Cette valeur octroie 40 Mo supplémentaires au système d'exploitation et permet d'ajouter davantage d'utilisateurs sans utiliser toutes les ressources système disponibles.

Pour supprimer cet avertissement

  1. Cliquez avec le bouton droit sur Poste de travail et sélectionnez Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur l'onglet Avancé.

  3. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  4. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  5. Dans la section [Systèmes d'exploitation], ajoutez les commutateurs suivants à la fin de la ligne de démarrage qui inclut le commutateur /fastdetect : /3GB /USERVA=3030

  6. Enregistrez les modifications et fermez le Bloc-notes.

  7. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur l'optimisation de l'utilisation de la mémoire et les performances d'Exchange Server, voir les articles suivants dans la Base de connaissances Microsoft :

  • 266096 sur Exchange 2000 qui requiert le commutateur /3GB avec plus de 1 Gigaoctet de RAM physique (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096).

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 810371 sur l'utilisation du commutateur /Userva sur des serveurs Exchange Windows 2003 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • 823440 sur l'obligation d'utiliser le commutateur /3GB lorsque vous installez Exchange Server 2003 sur un système Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

  • 822178 sur l'aperçu des dépendances et des exigences des fonctions Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822178).


Le service de Gestion de Exchange n'est pas exécuté comme LocalSystem
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la propriété StartName pour le service Gestion de Microsoft Exchange (MSExchangeMGMT). Si Exchange Server Analyzer détecte que le service Gestion d'Exchange est exécuté sous un compte autre que LocalSystem (SYSTEM), il affiche une erreur.

Cette erreur indique que le service Gestion d'Exchange n'est pas exécuté dans une configuration prise en charge. L'exécution du service Gestion d'Exchange sous tout autre compte engendrera des erreurs d'autorisation et d'accès.

Pour corriger cette erreur, vous devez configurer le service Gestion d'Exchange pour qu'il démarre sous le compte LocalSystem (SYSTEM).

Pour configurer le compte du service Gestion d'Exchange

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Recherchez et arrêtez le service Gestion de Microsoft Exchange.

  3. Double-cliquez sur le service Gestion de Microsoft Exchange.

  4. Sous l'onglet Ouvrir une session de la page Propriétés de Gestion de Microsoft Exchange, sélectionnez Compte LocalSystem dans Ouvrir une session en tant que, puis cliquez sur Appliquer.

  5. Sous Statut du service, cliquez sur Démarrer, puis sur OK.

  6. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur l'exécution de services Exchange sous le compte LocalSystem, voir l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Le service Gestion de Exchange est arrêté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Process pour déterminer la valeur de la clé Started pour l'instance MSExchangeMGMT, qui représente le service Gestion de Microsoft Exchange. Si Exchange Server Analyzer détecte que la valeur de la clé Started pour l'instance MSExchangeMGMT est différente de True, un avertissement s'affiche.

Le service Gestion d'Exchange a été introduit dans Exchange 2000 Server Service Pack 2. La fonction de Centre de suivi des messages dans Exchange Server et certaines fonctions du Gestionnaire système Exchange, notamment, dépendent de ce service.

Le service Gestion d'Exchange permet de spécifier, par le biais de l'interface utilisateur, le contrôleur de domaine ou le serveur de catalogue global Exchange Server 2003 ou Exchange 2000 Server à utiliser pour accéder au service d'annuaire Active Directory®. Ce service est également nécessaire pour le suivi des messages. Vous pouvez le désactiver sans affecter la fonctionnalité principale d'Exchange. Toutefois, lorsque vous effectuez un audit de la fonctionnalité Exchange Server, il se peut que vous ayez besoin de fonctions de suivi des messages sur tous les ordinateurs Exchange Server qui routent le courrier.

Remarque :
Les serveurs frontaux servant généralement pour l'accès au courrier plutôt que pour son routage, vous jugerez peut-être inutile d'exécuter le service Gestion d'Exchange sur ces serveurs.

Pour configurer le service Gestion d'Exchange de manière à ce qu'il démarre automatiquement

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Double-cliquez sur le service Gestion de Microsoft Exchange.

  3. Sous l'onglet Général de la page des propriétés de Gestion de Microsoft Exchange, sélectionnez Automatique dans la boîte de dialogue Type de démarrage, puis cliquez sur Appliquer.

  4. Sous État du serveur, cliquez sur Démarrer, puis sur OK.

Pour plus d'informations sur le service Gestion d'Exchange, voir l'article 307413 de la Base de connaissances Microsoft sur les informations générales sur le service Gestion de Microsoft Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307413).

Pour plus d'informations générales sur la gestion d'Exchange, voir le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Le suivi du fournisseur Exchange est activé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-06-20

L'outil Microsoft Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut serialNumber pour tous les objets ayant une classe d'objet msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Microsoft Exchange 2000 Server. Si la valeur de chaîne inclut « Version 6.5 », l'ordinateur exécute Microsoft Exchange Server 2003. Si la valeur de chaîne inclut « Version 8.0 », l'ordinateur exécute Microsoft Exchange Server 2007.

Exchange Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft® CIM_Datafile pour déterminer la valeur de la clé Version du fournisseur de transport Exchange, Emsmdb32.dll. La clé WMI Version indique le numéro de version de ce fichier.

Enfin, Exchange Analyzer interroge l'entrée de Registre suivante pour déterminer si le suivi du fournisseur Exchange a été configuré et activé.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

Exchange Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • Le serveur n'utilise pas Exchange Server 2007.

  • La clé Version d'Emsmdb32.dll est 6.5.7233.47 ou versions ultérieures

  • L'entrée HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing existe et est définie sur une autre valeur que 0

Cette erreur indique que le suivi du fournisseur de transport Exchange est activé sur l'ordinateur.

Des versions du fournisseur de transport Exchange à la version 6.5.7233.47 et ultérieures possèdent des fonctions de suivi. Un fichier .ttd active le suivi des programmes suivants :

  • tout programme utilisant MAPI sur le serveur exécutant Exchange Server 2003 ;

  • tout programme installé à l'aide des Outils de gestion du système Microsoft Exchange.

Le suivi du fournisseur de transport Exchange doit être activé uniquement pour le dépannage actif ; sinon, il pourrait affecter les performances normales du serveur.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre la procédure de restauration en cas de problème. Pour plus d'informations sur la procédure de restauration du Registre, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour désactiver le suivi du fournisseur Exchange sur Exchange Server 2003

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Parcourir : HKML\Software\Microsoft\Exchange\Exchange Provider\

  3. Dans le volet droit de navigation :

    1. Cliquez avec le bouton droit sur la sous-clé et supprimez-la, ou

    2. Double-cliquez sur Enable Tracing.

  4. Configurez la sous-clé Enable Tracing à l'aide de la valeur 0.

  5. Fermez l'Éditeur du Registre.

  6. Redémarrez le service Banque d'informations d'Exchange pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour obtenir des informations sur la modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la Description du Registre de Microsoft Windows.


Exchange 2000 Server n'exécute pas le dernier Service Pack
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus STORE.EXE. Si Exchange Server Analyzer détermine que la clé Version pour STORE.EXE est supérieure à 4416 et inférieure ou égale à 6249, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server n'exécute pas le dernier code disponible pour la version d'Exchange utilisée sur l'ordinateur.

Pour supprimer cet avertissement

  1. Téléchargez Exchange 2000 Server Service Pack 3 (http://go.microsoft.com/fwlink/?LinkId=17058).

  2. Voir le Guide de déploiement du Service Pack 3 d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=12337).

  3. Téléchargez la dernière mise à jour (août 2004) (http://go.microsoft.com/fwlink/?LinkId=33457).

  4. Pour plus d'informations sur la dernière mise à jour, voir l'article 870540 de la Base de connaissances Microsoft sur la disponibilité du correctif cumulatif post-Service Pack 3 Exchange 2000 Server et daté d'août 2004 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  5. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  6. Appliquez Exchange 2000 Server Service Pack 3.

  7. Appliquez la mise à jour août 2004.

Pour plus d'informations sur l'obtention du dernier Service Pack pour Exchange 2000 Server, voir l'article 301378 de la Base de connaissances Microsoft sur l'obtention du dernier Service Pack d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article 328839 de la Base de connaissances sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Exchange 2000 Server n'est pas pris en charge par Windows Server 2003
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute Windows 2000 Server et une valeur de 5.2, qu'il exécute Windows Server™ 2003.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient Version 5.5, l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient Version 6.0, l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient Version 6.5, l'ordinateur exécute Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de CurrentVersion est égale à 5.2 et que celle de serialNumber contient Version 6,0, une erreur s'affiche. Cette configuration n'est pas prise en charge et vous devez corriger cette erreur dès que possible.

Pour corriger cette erreur

  1. Effectuez l'une des opérations suivantes :

    • Installez Exchange 2000 Server sur un serveur qui exécute un système d'exploitation pris en charge et déplacez les boîtes aux lettres vers ce serveur.

    • Effectuez la mise à niveau d'Exchange 2000 Server vers Exchange Server 2003.

Pour plus d'informations sur les configurations prises en charge, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur Exchange Server et Windows Server 2003, voir l'article 810591 de la Base de connaissances Microsoft sur la compatibilité d'Exchange Server avec Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591).


Version préliminaire d'Exchange 2007 installée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-20

L'outil Microsoft Exchange Server Analyzer interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut serialNumber pour tous les objets Exchange Server de l'annuaire. L'attribut serialNumber est une valeur de chaîne incluant la version d'Exchange Server et, le cas échéant, celle du Service Pack installé. Par exemple, sur un ordinateur Exchange Server 2007 sans Service Pack installé, l'attribut serialNumber est égal à Version 8.0 (Build 0685).

Si Exchange Server Analyzer détecte que la valeur de l'attribut serialNumber contient 8.0 mais un numéro de build inférieur à 0685 dans sa chaîne, une erreur est affichée.

Cette erreur indique que l'ordinateur Exchange Server 2007 exécute une version préliminaire d'Exchange Server 2007.

Les installations de la version préliminaire d'Exchange Server 2007 ne sont pas prises en charge dans les environnements de production.

Pour supprimer cette erreur, installez une version de production d'Exchange Server 2007.


Objet de serveur Exchange 2007 déplacé vers un autre groupe d'administration
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-08-11

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets Exchange Server de l'annuaire.

Exchange Server Analyzer interroge également la valeur de l'attribut cn du groupe d'administration hébergeant le serveur qui exécute Exchange Server pour déterminer s'il s'agit du groupe d'administration Exchange 2007 dédié, Groupe d'administration Exchange (FYDIBOHF23SPDLT).

Si Exchange Server Analyzer détermine que le serveur exécute Microsoft Exchange Server 2007, mais est hébergé dans un autre groupe d'administration que Groupe d'administration Exchange (FYDIBOHF23SPDLT), il affiche une erreur.

Cette erreur indique que le serveur a peut-être été déplacé manuellement du groupe d'administration Exchange 2007 dédié et peut provoquer des problèmes de flux de messages.

L'attribut serialNumber est une valeur de chaîne qui comprend les versions d'Exchange Server et du Service Pack s'il est installé. La valeur de l'attribut serialNumber égale à Version 8.0 indique que le serveur exécute Exchange 2007.

Microsoft Exchange Server 2003 et Microsoft Exchange 2000 Server utilisent les groupes d'administration pour regrouper les objets Exchange à des fins de délégation des autorisations de gestion de ces objets. Exchange 2007 n'utilise pas les groupes d'administration comme unité de gestion logique. Pour prendre en charge la coexistence entre Exchange Server 2003 ou Exchange 2000 Server et Exchange 2007, tous les serveurs Exchange 2007 sont automatiquement ajoutés à un seul groupe d'administration lors de l'installation d'Exchange 2007. Ce groupe d'administration est reconnu dans le Gestionnaire système Exchange dans Exchange Server 2003 comme Groupe d'administration Exchange (FYDIBOHF23SPDLT).

Pour résoudre ce problème, supprimez et réinstallez le serveur.


Exchange réside sur un contrôleur de domaine qui n'est pas un serveur de catalogue global
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur de la clé DomainRole. Les valeurs valides pour cette clé sont indiquées dans le tableau suivant.

Valeur | Signification
0 | Station de travail autonome
1 | Station de travail membre
2 | Serveur autonome
3 | Serveur membre
4 | Contrôleur secondaire de domaine
5 | Contrôleur de domaine principal

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster ClusSvc. En outre, Exchange Server Analyzer interroge la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de la clé OSProductSuite indique la version de Windows utilisée sur l'ordinateur.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets Annuaire disposant d'une catégorie d'objet de msExchExchangeServer. La valeur de l'attribut serialNumber indique la version utilisée d'Exchange Server.

Enfin, Exchange Server Analyzer interroge Active Directory pour déterminer la valeur de l'attribut isGlobalCatalogReady de ce serveur. La valeur True indique que le serveur d'annuaire est également un serveur de catalogue global en fonctionnement. La valeur False indique que le serveur d'annuaire n'est pas un serveur de catalogue global.

Un message d'avertissement s'affiche si Exchange Server Analyzer détermine que : la valeur de la clé DomainRole est supérieure à 3 sur un ordinateur Exchange Server ; que cet ordinateur n'exécute pas Windows Small Business Server ou Exchange Server version 5.5, ou ne fonctionne pas dans un cluster Windows ; et que l'attribut isGlobalCatalogReady est défini sur False.

Ce message indique qu'Exchange Server est exécuté sur un serveur d'annuaire qui n'est pas un serveur de catalogue global en fonctionnement. Cette configuration n'est pas prise en charge et peut faire échouer les services Exchange.

Si vous utilisez Exchange Server sur un contrôleur de domaine sans Small Business Server, tenez compte des problèmes suivants :

  • Exchange Server et Active Directory sont deux applications qui consomment énormément de ressources. Il convient de tenir compte des implications sur les performances lorsque toutes deux fonctionnent sur le même ordinateur.

  • Si Exchange Server est utilisé sur un contrôleur de domaine, vous devez également faire de ce contrôleur de domaine un serveur de catalogue global.

  • Plusieurs composants d'annuaire Exchange Server, tels que l'accès au service d'annuaire (DSAccess), le proxy du service d'annuaire (DSProxy) et le catégoriseur de messages, ne basculent pas vers un autre contrôleur de domaine ou serveur de catalogue global.

  • Vous ne devez pas utiliser le commutateur de démarrage /3GB dans Windows car Exchange Server risque de consommer toute la mémoire et donc de réduire la mémoire disponible pour Active Directory.

  • L'arrêt du système prendra beaucoup plus de temps si les services Exchange Server ne sont pas stoppés avant l'arrêt ou le redémarrage du serveur.

  • Cette configuration est moins sécurisée car les administrateurs Exchange disposent d'un accès administratif local à Active Directory. Cela leur permet d'élever leurs propres privilèges. En outre, toute vulnérabilité de la sécurité dans Exchange Server ou Active Directory compromet la sécurité de l'autre application.

  • Si vous utilisez Exchange Server 2003 ou Exchange Server 2007 sur un contrôleur de domaine, l'utilisation de l'outil de promotion de contrôleur de domaine (DCPromo) pour modifier le rôle de l'ordinateur n'est pas prise en charge et interrompt des composants tels que Microsoft Outlook® Mobile Access.

  • L'exécution d'Exchange Server 2003 ou d'Exchange Server 2007 sur un noeud de cluster qui est également un contrôleur de domaine Active Directory n'est pas prise en charge et ne doit jamais être effectuée. En d'autres termes, si vous utilisez Exchange 2000 Server sur un noeud d'un cluster qui est également un contrôleur de domaine, vous devez rétrograder le serveur au rang de serveur membre avant d'effectuer la mise à niveau d'Exchange 2000 Server vers Exchange Server 2003.

Si l'ordinateur exécute Exchange 2000 Server, il est recommandé de rétrograder le serveur au rang de serveur membre à l'aide de DCPromo dès que l'occasion se présente. Si l'ordinateur exécute Exchange Server 2003 ou Exchange Server 2007, utilisez l'une des procédures suivantes pour supprimer cet avertissement.

Correction de cet avertissement en déplaçant Exchange sur un autre ordinateur

  1. Installez Exchange Server sur un autre ordinateur.

  2. Utilisez l'option Déplacer une boîte aux lettres de l'Assistant Tâches Exchange pour déplacer les boîtes aux lettres existantes du contrôleur de domaine vers le nouveau serveur Exchange.

  3. Associez tous les dossiers publics et les rôles détenus par l'ancien ordinateur Exchange Server au nouvel ordinateur Exchange Server.

  4. Désinstallez Exchange Server du contrôleur de domaine.
Correction de cet avertissement en faisant du serveur Exchange un serveur de catalogue global

  1. Ouvrez Sites et services Active Directory.

  2. Développez Sites, le site, puis Serveurs.

  3. Sélectionnez le contrôleur de domaine que vous souhaitez spécifier en tant que serveur de catalogue global.

  4. Dans le volet droit, cliquez avec le bouton droit sur Paramètres NTDS et sélectionnez Propriétés.

  5. Sous l'onglet Général, activez la case à cocher Catalogue global. Si le serveur d'annuaire est utilisé avec Windows 2000 Server Service Pack 2 ou antérieur, redémarrez le serveur pour que la modification soit prise en compte. Si le serveur d'annuaire est utilisé avec Windows 2000 Server Service Pack 3 ou supérieur ou Windows Server™ 2003, la modification prend effet de manière dynamique, sans redémarrer l'ordinateur.

Pour plus d'informations sur l'installation d'Exchange Server sur un contrôleur de domaine, consultez l'article 250989 de la Base de connaissances Microsoft sur l'installation d'ADC sur un contrôleur de domaine Windows 2000 qui utilise également Exchange Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989).


Exchange Server 5.5 détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet msExchExchangeServer. Si la valeur de chaîne contient Version 5.5, l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient Version 6.0, l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient Version 6.5, l'ordinateur exécute Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur serialNumber contient Version 5.5, une erreur s'affiche.

Cette erreur indique que la version d'Exchange Server détectée ne peut pas être analysée davantage par cette version d'Exchange Server Analyzer.

Exchange Server Analyzer dépend de diverses interfaces de programme spécifiques qui sont indisponibles dans la version détectée d'Exchange Server.

Pour remédier à cette erreur, spécifiez un serveur Exchange exécutant Exchange 2000 ou une version ultérieure.

Si vous pensez que cette règle a été déclenchée par erreur, vérifiez que la valeur de l'attribut serialNumber de l'objet serveur Exchange dans Active Directory est correctement définie.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI (Active Directory Service Interfaces) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez ces attributs d'objet Active Directory, vous devez en assumer les risques.
Affichage de la valeur de l'attribut serialNumber

  1. Démarrez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Cliquez avec le bouton droit sur l'objet serveur, puis cliquez sur Propriétés.

  5. Double-cliquez sur l'attribut serialNumber pour afficher sa valeur actuelle.

Pour plus d'informations sur le déploiement d'Exchange Server 2003, consultez le Guide de déploiement d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur la migration d'Exchange Server 5.5 vers Exchange Server 2003, consultez l'article 259912 de la Base de connaissances, « Conditions préalables pour effectuer la mise à niveau d'Exchange Server 5.5 vers Exchange 2000 Server ou Exchange Server 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912).

Pour plus d'informations sur la migration et la mise à niveau vers Exchange Server 2003, consultez la page sur la mise à niveau vers Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=34186).


Exchange Server 5.5 n'exécute pas le dernier Service Pack
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus STORE.EXE. Si Exchange Server Analyzer détermine que la valeur de la clé Version pour STORE.EXE est supérieure à 1959 et inférieure à 2653, un avertissement s'affiche. Cela indique que l'ordinateur exécute Exchange Server 5.5 pré-Service Pack 4.

Cet avertissement indique que l'ordinateur Exchange Server n'exécute pas le dernier code disponible pour la version d'Exchange utilisée sur l'ordinateur.

Pour supprimer cet avertissement

  1. Téléchargez Exchange Server 5.5 Service Pack 4 (http://go.microsoft.com/fwlink/?LinkId=33456).

  2. Téléchargez la dernière mise à jour (mai 2004) pour Exchange Server 5.5 à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=33456).

  3. Découvrez les informations relatives à cette mise à jour dans l'article 841765 de la Base de connaissances Microsoft sur le correctif cumulatif de novembre 2004 pour Exchange Server 5.5 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765).

  4. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  5. Appliquez Exchange Server 5.5 Service Pack 4.

  6. Appliquez la mise à jour de novembre 2004.

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article de la Base de connaissances Microsoft sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Exchange Server 5.5 n'est pas pris en charge par Windows 2003
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute Windows 2000 Server et une valeur de 5.2, qu'il exécute Windows Server™ 2003.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient Version 5.5, l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient Version 6.0, l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient Version 6.5, l'ordinateur exécute Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de CurrentVersion est égale à 5.2 et que celle de serialNumber contient Version 5.5, une erreur s'affiche. Cette configuration n'est pas prise en charge et vous devez corriger cette erreur dès que possible.

Pour corriger cette erreur

  • Effectuez l'une des opérations suivantes :

    • Installez Exchange Server 5.5 sur un serveur qui exécute un système d'exploitation pris en charge, puis déplacez les boîtes aux lettres vers ce serveur.

    • Effectuez la migration d'Exchange Server 5.5 vers Exchange Server 2003.

Pour plus d'informations sur le déploiement d'Exchange Server 2003, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur Exchange Server et Windows Server 2003, voir l'article 810591 de la Base de connaissances Microsoft sur la compatibilité d'Exchange Server avec Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591).

Pour plus d'informations sur la migration d'Exchange Server 5.5 vers Exchange Server 2003, voir l'article 259912 de la Base de connaissances sur les conditions préalables pour effectuer la mise à niveau d'Exchange Server 5.5 vers Exchange 2000 Server ou Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912).

Pour plus d'informations sur la migration et la mise à niveau vers Exchange Server 2003, voir la page sur la migration et la mise à niveau vers Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=34186).


Exchange Server 5.0 n'utilise pas le dernier Service Pack ou correctif cumulatif
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus STORE.EXE. Si Exchange Server Analyzer détermine que la valeur de la clé Version pour STORE.EXE est supérieure à 1456 et inférieure à 1460, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server n'exécute pas le dernier code disponible pour la version d'Exchange utilisée sur l'ordinateur.

Pour supprimer cet avertissement

  1. Téléchargez le Service Pack 2 pour Exchange Server 5.0 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858).

  2. Lisez le fichier README.TXT du Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735).

  3. Visitez le Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=41361) pour télécharger la dernière mise à jour (avril 2004) d'Exchange Server 5.0.

  4. Pour des informations relatives à cette mise à jour, voir l'article 834130 de la Base de connaissances Microsoft sur les correctifs de mise à jour Microsoft Exchange Server 5.0 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130).

  5. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  6. Appliquez le Service Pack 2 pour Exchange Server 5.0.

  7. Appliquez la mise à jour d'avril 2004.

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article de la Base de connaissances Microsoft sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Exchange Server 5.5 résident sur le contrôleur de domaine Active Directory
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur de la clé DomainRole. Les valeurs valides pour cette clé sont indiquées dans le tableau suivant.

Valeur | Signification
0 | Station de travail autonome
1 | Station de travail membre
2 | Serveur autonome
3 | Serveur membre
4 | Contrôleur secondaire de domaine
5 | Contrôleur de domaine principal

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster ClusSvc.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets d'annuaire disposant d'une catégorie d'objet de msExchExchangeServer. La valeur de l'attribut serialNumber indique la version utilisée d'Exchange Server.

Si Exchange Server Analyzer détermine que la valeur de la clé DomainRole est supérieure à 3 sur un ordinateur Exchange Server, que l'ordinateur Exchange Server ne fonctionne pas dans un cluster Windows et que la version 5.5 d'Exchange Server est utilisée, un avertissement s'affiche.

Cet avertissement indique qu'Exchange Server 5.5 s'exécute sur un serveur Active Directory . Cette situation peut engendrer des problèmes au niveau d'Active Directory Connector (ADC) en raison d'un éventuel conflit de port. Si ADC utilise ce serveur comme cible, vérifiez que le numéro de port LDAP (Exchange Lightweight Directory Access Protocol) correct est utilisé. Par défaut, le serveur d'annuaire écoute les requêtes LDAP sur le port 389. Sauf si le port d'Exchange est modifié et si ADC est configuré pour utiliser le port Exchange, ADC ne pourra pas communiquer avec Exchange.

Active Directory utilise le port LDAP standard 389 pour l'accès LDAP. Toutefois, l'utilisation du numéro de port standard remplace le serveur Exchange résidant sur le même serveur qui essaie également d'écouter le port LDAP 389. Vous devez réaffecter le port LDAP Exchange pour permettre l'accès LDAP du serveur Exchange à son annuaire.

Pour supprimer cet avertissement

  1. Ouvrez Administrateur Exchange.

  2. Développez Nom du site, Configuration, Protocoles, puis Paramètres par défaut de site LDAP (annuaire).

  3. Modifiez l'affectation de port de 389 en un port non utilisé.

  4. Cliquez sur OK pour enregistrer la modification.

  5. Redémarrez le service d'annuaire de Microsoft Exchange pour que la modification soit prise en compte.

  6. Au besoin, reconfigurez ADC qui utilise ce serveur comme cible pour qu'il en utilise un nouveau.

Pour plus d'informations sur la modification de l'affectation de port LDAP dans Exchange Server 5.5, voir l'article 224447 de la Base de connaissances Microsoft sur la procédure de modification des affectations de port LDAP dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=224447).


Échec de résolution de nom DNS pour Exchange Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool tente d'exécuter une requête DNS (Domain Name System) sur les serveurs DNS configurés pour chaque ordinateur Exchange Server. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une demande de résolution de nom et analyse les résultats. Si Exchange Server Analyzer ne reçoit pas d'adresse IP (Internet Protocol) dans les résultats de la requête, une erreur s'affiche.

Cette erreur indique qu'un ordinateur Exchange Server n'a pas été trouvé dans le DNS. Exchange Server et le service d'annuaire Active Directory® nécessitent, pour fonctionner correctement, un DNS correctement configuré et sain. Des problèmes d'enregistrement et de résolution DNS peuvent avoir des répercussions importantes sur la capacité à envoyer, à recevoir et à remettre les messages.

Vous devez configurer correctement le DNS pour vous assurer qu'Active Directory et Exchange Server fonctionneront correctement. Pour plus d'informations sur la configuration DNS pour Active Directory, voir l'article 237675 de la Base de connaissances Microsoft sur la configuration du serveur DNS pour Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675).

Pour corriger cette erreur

  1. Vérifiez les éléments de configuration suivants pour vous assurer que le DNS est sain et que les entrées DNS d'Exchange Server sont correctement enregistrées :

    • configuration IP DNS ;

    • mises à jour de zones dynamiques ;

    • redirecteurs DNS.

  2. Recherchez l'existence d'une entrée de zone racine. Affichez les zones de recherche directe dans la console de gestion DNS. Une entrée doit exister pour le domaine. D'autres entrées de zones peuvent exister. Il ne doit pas exister de zone point ("."). Si la zone point (".") existe, supprimez-la. La zone point (".") identifie le serveur DNS comme serveur racine. En général, un domaine Active Directory qui nécessite un accès (Internet) externe ne doit pas être configuré en tant que serveur DNS racine. Réenregistrez manuellement l'adresse IP d'Exchange Server à l'aide de Ipconfig /registerdns sur le serveur d'annuaire après avoir supprimé le point ("."). Il se peut qu'il soit nécessaire de redémarrer le service Netlogon.

  3. Rajoutez manuellement les entrées DNS d'Exchange Server à l'aide de netdiag /fix sur l'ordinateur Exchange Server.

Pour plus d'informations sur l'utilisation du DNS avec Active Directory, voir l'article 323418 de la Base de connaissances Microsoft sur la procédure d'intégration d'un DNS à une infrastructure DNS existante si Active Directory est activé dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418).

Pour plus d'informations sur le dépannage de problèmes liés au DNS et à Active Directory, voir l'article 260371 de la Base de connaissances sur la résolution des problèmes courants d'installation d'Active Directory dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371).


Le serveur Exchange a été désigné comme serveur frontal et semble héberger des boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge l'objet WMI (Windows® Management Instrumentation) Microsoft Exchange Server (classe Exchange_Server) pour déterminer la valeur IsFrontEndServer du serveur. Si la valeur est True, le serveur Exchange agit comme un serveur frontal. Si le serveur possède des banques de boîtes aux lettres, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre de boîtes aux lettres sur le serveur. Chaque objet de banque de boîtes aux lettres (classe msExchPrivateMDB) possède un attribut à valeurs multiples homeMDBBL qui répertorie toutes les boîtes aux lettres de la banque. En comptant ces valeurs, Exchange Server Analyzer obtient le nombre total de boîtes aux lettres sur le serveur.

Si le serveur Exchange est désigné comme serveur frontal et possède également plus de 20 boîtes aux lettres, un avertissement s'affiche.

Selon votre configuration, Exchange peut devoir placer des boîtes aux lettres de service sur le serveur frontal. Par exemple, si le serveur frontal accepte le courrier SMTP (Simple Mail Transfer Protocol) depuis Internet, le service SMTP Exchange peut avoir besoin d'une boîte aux lettres dédiée sur le serveur. Exchange Server Analyzer rend compte de ces boîtes aux lettres de service par un simple avertissement s'affichant lorsqu'il existe plus de 20 boîtes aux lettres configurées sur le serveur Exchange.

Il est déconseillé de placer des boîtes aux lettres d'utilisateurs sur le serveur frontal. Cette configuration n'est pas prise en charge.

Si des boîtes aux lettres d'utilisateurs se trouvent sur le serveur frontal, utilisez le Gestionnaire système Exchange (uniquement sur Exchange Server 2003) ou l'outil Utilisateurs et ordinateurs Active Directory pour les déplacer vers un serveur principal adéquat.

Pour déplacer des boîtes aux lettres (Exchange 2000 Server ou Exchange Server 2003)

  1. Dans Utilisateurs et ordinateurs Active Directory, sélectionnez le ou les utilisateurs dont vous souhaitez déplacer la boîte aux lettres.

  2. Cliquez avec le bouton droit sur la liste d'utilisateurs sélectionnés à l'étape précédente, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, sur la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.

Pour déplacer des boîtes aux lettres (Exchange Server 2003 uniquement)

  1. Dans le Gestionnaire système Exchange, développez Serveurs, le serveur à partir duquel déplacer des boîtes aux lettres, le Groupe de stockage à partir duquel déplacer des boîtes aux lettres, la Banque de boîtes aux lettres contenant les boîtes aux lettres à déplacer, puis cliquez sur Boîtes aux lettres.

  2. Dans le volet Détails, cliquez avec le bouton droit sur le ou les utilisateurs dont vous souhaitez déplacer la boîte aux lettres, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, sur la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.

Pour plus d'informations sur les configurations correctes de serveurs frontaux Exchange, voir l'article 822443 de la Base de connaissances Microsoft sur les considérations relatives au serveur frontal dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443).

Pour des recommandations générales sur le déploiement et la configuration de serveurs frontaux Exchange, voir le Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur les erreurs pouvant se produire lors de l'exécution de boîtes aux lettres d'utilisateurs sur un serveur frontal Exchange, voir l'article 273296 de la Base de connaissances sur les utilisateurs qui ne peuvent pas lire de courrier sur un serveur frontal (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir les articles suivants de la Base de connaissances :

  • 821829 sur le déplacement de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)


Ce serveur Exchange est également un contrôleur de domaine, mais cette configuration n'est pas recommandée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur de la clé DomainRole. Les valeurs valides pour cette clé sont indiquées dans le tableau suivant.

Valeur | Signification
0 | Station de travail autonome
1 | Station de travail membre
2 | Serveur autonome
3 | Serveur membre
4 | Contrôleur secondaire de domaine
5 | Contrôleur de domaine principal

En outre, Exchange Server Analyzer interroge la classe WMI Win32_Service pour déterminer la valeur de la clé Started du service de cluster ClusSvc.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets Annuaire disposant d'une catégorie d'objet de msExchExchangeServer. La valeur de l'attribut serialNumber indique la version utilisée d'Exchange Server.

Si Exchange Server Analyzer détermine que la valeur de la clé DomainRole est supérieure à 3 sur un ordinateur Exchange Server et que l'ordinateur Exchange Server n'utilise pas Exchange Server 5.5 ou fonctionne dans un cluster Windows, un avertissement s'affiche.

Si vous utilisez Exchange Server en tant que partie de Microsoft Small Business Server 2000 ou Windows Small Business Server 2003, vous pouvez installer Exchange Server sur un contrôleur de domaine. Toutefois, si vous n'utilisez pas Exchange Server en tant que partie de Small Business Server, il est recommandé d'éviter d'exécuter Exchange Server sur un contrôleur de domaine.

Si vous utilisez Exchange Server sur un contrôleur de domaine sans Small Business Server, tenez compte des problèmes suivants :

  • Exchange Server et Active Directory sont deux applications qui consomment énormément de ressources. Il convient de tenir compte des implications sur les performances lorsque toutes deux fonctionnent sur le même ordinateur.

  • Si Exchange Server est utilisé sur un contrôleur de domaine, vous devez également faire de ce contrôleur de domaine un serveur de catalogue global. Pour plus d'informations sur la création d'un serveur de catalogue global, voir l'article 313994 de la Base de connaissances Microsoft sur la procédure de création ou de déplacement d'un catalogue global dans Windows Server 2003, Windows 2000 ou Small Business Server 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid= 313994).

  • Plusieurs composants d'annuaire Exchange Server, tels que l'accès au service d'annuaire (DSAccess), le proxy du service d'annuaire (DSProxy) et le catégoriseur de messages, ne basculent pas vers un autre contrôleur de domaine ou serveur de catalogue global.

  • Vous ne devez pas utiliser le commutateur de démarrage /3GB dans Windows car Exchange Server risque alors de consommer toute la mémoire et donc de réduire la mémoire disponible pour Active Directory.

  • L'arrêt du système prendra beaucoup plus de temps si les services Exchange Server ne sont pas stoppés avant l'arrêt ou le redémarrage du serveur.

  • Cette configuration est moins sûre car les administrateurs d'Exchange disposent d'un accès d'administrateur local à Active Directory, ce qui leur permet d'augmenter leurs propres droits. En outre, toute vulnérabilité de la sécurité trouvée dans Exchange Server ou Active Directory expose l'autre application à une compromission.

  • Si vous utilisez Exchange Server 2003 ou Exchange Server 2007 sur un contrôleur de domaine, l'utilisation de l'outil de promotion de contrôleur de domaine (DCPromo) pour modifier le rôle de l'ordinateur n'est pas prise en charge et interrompt des composants tels que Microsoft Outlook® Mobile Access.

  • L'exécution d'Exchange Server 2003 ou d'Exchange Server 2007 sur un noeud de cluster qui est également un contrôleur de domaine Active Directory n'est pas prise en charge et ne doit jamais être effectuée. Cela signifie que si vous utilisez Exchange 2000 Server sur un noeud d'un cluster qui est également un contrôleur de domaine, vous devez rétrograder le serveur au rang de serveur membre avant d'effectuer la mise à niveau d'Exchange 2000 Server vers Exchange Server 2003.

Si l'ordinateur exécute Exchange 2000 Server, il est recommandé de rétrograder le serveur au rang de serveur membre à l'aide de DCPromo dès que l'occasion se présente. Si l'ordinateur exécute Exchange Server 2003, utilisez la procédure suivante pour supprimer cet avertissement.

Correction de cet avertissement

  1. Installez Exchange Server sur un autre ordinateur.

  2. Utilisez l'option Déplacer une boîte aux lettres de l'Assistant Tâches Exchange pour déplacer les boîtes aux lettres existantes du contrôleur de domaine vers le nouveau serveur Exchange.

  3. Associez tous les dossiers publics et les rôles détenus par l'ancien ordinateur Exchange Server au nouvel ordinateur Exchange Server.

  4. Désinstallez Exchange Server du contrôleur de domaine.

Pour plus d'informations sur l'installation d'Exchange Server sur un contrôleur de domaine, consultez l'article 250989 de la Base de connaissances Microsoft sur l'installation d'ADC sur un contrôleur de domaine Windows 2000 qui utilise également Exchange Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989).


Le serveur Exchange est arrêté ou inaccessible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool utilise des appels de procédure distante (RPC) pour lire la valeur de chaîne CurrentVersion de la clé de Registre suivante sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si Exchange Server Analyzer ne peut pas lire cette valeur de Registre pour une raison ou pour une autre, une erreur s'affiche.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Utilisez la commande Ping pour voir si l'ordinateur Exchange Server est accessible.

  3. Si un pare-feu est installé, vérifiez que les ports RPC sont bloqués.

  4. Assurez-vous que le service Registre distant sur l'ordinateur Exchange Server a été démarré.

  5. Vérifiez les autorisations pour le compte sous lequel l'outil Exchange Server Analyzer Tool est exécuté pour vous assurer qu'il possède des autorisations suffisantes pour lire le Registre sur l'ordinateur Exchange Server.

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur la résolution des problèmes de connectivité de l'outil Exchange Server Best Practices Analyzer Tool, voir la rubrique sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?linkid=56285).


Ce serveur Exchange est exécuté sur Windows NT4.0 ; des informations de diagnostic limitées sont disponibles
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute Windows 2000 Server et une valeur de 5.2, qu'il exécute Windows Server™ 2003.

Si Exchange Server Analyzer détecte que la valeur de CurrentVersion est égale à 4.0, un avertissement s'affiche.

Cet avertissement indique que cet ordinateur Exchange Server exécute Windows NT Server 4.0. Windows NT Server 4.0 ne fournit pas autant d'informations de diagnostic que les versions ultérieures de Windows Server. Par conséquent, Exchange Server Analyzer ne peut rassembler et analyser qu'une quantité limitée d'informations.

Pour supprimer cet avertissement

  1. Il n'existe aucune action immédiate à entreprendre. Cet avertissement est fourni à titre indicatif.

  2. Windows NT Server 4.0 et Exchange Server 5.5 atteignant la fin de leur cycle de vie, vous devez envisager une mise à niveau vers Windows Server 2003 et Exchange Server 2003.

Pour plus d'informations sur le cycle de vie des produits Windows NT Server 4.0 et Exchange Server 5.5, voir le site Web Politique de Support Microsoft (http://go.microsoft.com/fwlink/?LinkId=21759).

Pour plus d'informations sur Windows Server 2003, voir la page d'accueil sur les produits Microsoft Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=26095).

Pour plus d'informations sur Exchange Server 2003, voir la page d'accueil des produits Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21573).


Ce serveur Exchange Server 2003 n'utilise pas la version finale du Service Pack 2
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets Exchange Server de l'annuaire. L'attribut serialNumber est une valeur de chaîne qui comprend les versions d'Exchange Server et du Service Pack, s'il est installé. Par exemple, sur un ordinateur Exchange Server 2003 avec le Service Pack 1 installé, l'attribut serialNumber est égal à Version 6.5 (Build 7638: Service Pack 2).

Si Exchange Server Analyzer détecte que la valeur de l'attribut serialNumber contient 6.5 et Service Pack 2 dans sa chaîne, mais pas 7638, il affiche un avertissement.

Cet avertissement indique que l'ordinateur Exchange Server 2003 exécute une pré-version d'Exchange Server 2003 Service Pack 2.

Remarque :
Étant donné qu'il est impossible de désinstaller les Service Packs d'Exchange Server, il est vivement recommandé de procéder à une sauvegarde complète de l'ordinateur Exchange Server avant d'appliquer des Service Packs.
Pour supprimer cet avertissement

  1. Obtenez la version finale d'Exchange Server 2003 Service Pack 2 sur le site Web d'Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).

  2. Voir les notes de mise à jour d'Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52072).

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Appliquez le Service Pack 2 pour Exchange Server 2003.

  5. Effectuez une nouvelle sauvegarde complète de l'ordinateur Exchange Server.

Pour plus d'informations sur la procédure d'installation d'un Service Pack pour Exchange Server, voir l'article 328839 de la Base de connaissances Microsoft sur la procédure d'application des Service Packs et correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Exchange Server exécute SharePoint Portal Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour Microsoft Windows SharePoint® Portal Server (MSDMSERV). La valeur True indique que SharePoint Portal Server est en cours d'exécution sur ce serveur Exchange.

Si Exchange Server Analyzer détermine que SharePoint Portal Server s'exécute sur un ordinateur Exchange Server, un avertissement s'affiche.

SharePoint Portal Server n'est pas compatible avec Exchange Server et doit être supprimé. SharePoint Portal Server et Exchange Server sont conçus pour travailler ensemble et jouent un rôle dans l'environnement de travail de votre organisation. Toutefois, ils sont faits pour fonctionner en parallèle et pas pour coexister sur le même support physique.

Pour supprimer cet avertissement

  • Déplacez Exchange Server ou SharePoint Portal Server vers un autre ordinateur. Il est recommandé de supprimer totalement l'un de ces programmes de l'ordinateur.

Pour plus d'informations sur le déplacement des boîtes aux lettres Exchange Server, voir l'article 821829 de la Base de connaissances Microsoft sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Pour plus d'informations sur la compatibilité d'Exchange Server et de SharePoint Portal Server, voir l'article 277567 de la Base de connaissances sur l'impossibilité d'installer Sharepoint Portal Server sur un ordinateur exécutant Exchange Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567).


Exchange Server exécute Virtual Server 2005 avec un autre serveur Exchange installé en tant qu'invité
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit des valeurs dans la clé de Registre suivante pour déterminer si le serveur est un serveur virtuel :

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

Exchange Server Analyzer recherche également la valeur de Registre suivante :

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

En outre, Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si le service de banque d'informations de Microsoft Exchange (MSExchangeIS) s'exécute sur l'ordinateur physique qui utilise Microsoft Virtual Server 2005.

Si Exchange Server Analyzer détecte que le serveur est un serveur virtuel, que la branche de Registre ci-dessus existe et que MSExchangeIS s'exécute sur l'ordinateur physique, une erreur s'affiche.

La présence de la clé HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 indique que les Compléments pour ordinateurs virtuels sont installés sur l'ordinateur Exchange Server. En outre, l'existence de la clé HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters signifie que l'ordinateur Exchange Server est exécuté en tant qu'ordinateur virtuel invité dans Virtual Server 2005.

Microsoft ne prend pas en charge l'exécution des versions d'Exchange Server sur un ordinateur virtuel ou un émulateur. Cela s'applique à Exchange Server sur Virtual Server 2005, Microsoft Virtual PC 2004 ou tout programme tiers d'ordinateur virtuel. Les plates-formes Exchange Server sont conçues et testées pour n'être exécutées que sur un matériel physique, notamment les plates-formes matérielles répertoriées dans Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

En outre, il n'est pas conseillé d'exécuter Exchange en tant qu'invité du serveur virtuel sur un ordinateur utilisant Exchange Server parce qu'il ne permet pas une redondance adéquate de service en service.

Pour corriger cette erreur

  1. Déplacez les boîtes aux lettres du serveur Exchange sous Virtual Server 2005 vers un ordinateur Exchange Server non virtuel.

  2. Associez tous les dossiers publics et transférez tous les rôles tenus par le serveur virtuel Exchange.

  3. Désinstallez Exchange de l'ordinateur virtuel pour le désactiver et le supprimer de votre infrastructure Exchange et du service d'annuaire Active Directory®.

Pour plus d'informations sur le déplacement des boîtes aux lettres, voir les articles suivants de la Base de connaissances Microsoft :

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975 sur les différences entre les méthodes de transfert de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Pour plus d'informations sur la prise en charge des ordinateurs Exchange Server fonctionnant dans des environnements virtuels, voir l'article 320220 de la Base de connaissances sur les limites de prise en charge d'Exchange Server sur une machine virtuelle ou d'émulation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Pour plus d'informations sur Virtual Server 2005, voir le site de Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?linkid=34938).

Pour plus d'informations sur Virtual PC 2004, voir le site de Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


Le serveur Exchange exécute les services DNS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service DNS Server (DNS) La valeur True indique que le service DNS Server est en cours d'exécution sur ce serveur Exchange.

Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur renvoyée pour cette clé indique la version du système d'exploitation Windows exécutée sur l'ordinateur Exchange Server.

En outre, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détermine que le service DNS Server est démarré sur un ordinateur Exchange Server répondant à tous les critères suivants, un avertissement s'affiche :

  • L'ordinateur Exchange Server héberge plus de 100 boîtes aux lettres.

  • L'ordinateur Exchange Server ne fonctionne pas sur Windows Small Business Server 2003 ou Small Business Server 2000.

Il n'est pas recommandé d'exécuter le service DNS Server sur le même ordinateur qu'un serveur de boîtes aux lettres Exchange de production. L'hébergement du service DNS Server et d'Exchange Server sur le même ordinateur dans un environnement de production risque fortement de réduire les performances d'un ou des deux serveurs.

Pour supprimer cet avertissement

  1. Prenez en compte l'une des options suivantes pour supprimer cet avertissement :

    • Déplacez Exchange Server ou le serivice DNS Server de l'ordinateur. Il est conseillé de supprimer totalement l'une des applications serveur de l'ordinateur.

    • Déplacez les boîtes aux lettres Exchange du serveur. Il convient, au minimum, de supprimer les boîtes aux lettres et de convertir le serveur Exchange en serveur de protocole ou d'infrastructure. Cela réduira la charge considérablement pour les E/S disque et de manière marginale pour le processeur (ce dernier dépend du rôle d'infrastructure d'Exchange).

    • Envisagez d'installer plutôt Small Business Server. Si vous utilisez Exchange dans un petit environnement de moins de 75 utilisateurs, qui ne nécessite pas plusieurs serveurs Exchange, l'installation de Small Business Server peut vous être profitable. Small Business Server comprend Microsoft SQL Server™ et Exchange Server, ainsi que d'autres applications serveur clés de Microsoft et a été développé, testé et optimisé pour une installation sur un seul ordinateur.

Pour plus d'informations sur le déplacement des boîtes aux lettres et des serveurs Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975 sur les différences entre les méthodes de transfert de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289 sur la procédure de transfert de Microsoft Exchange 2000 sur un nouveau matériel en conservant le même nom de serveur (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Pour plus d'informations sur Small Business Server, voir le site sur Microsoft Windows Small Business Server 2003 (http://go.microsoft.com/fwlink/?linkid=23456),


Serveur Exchange exécutant SQL Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service Microsoft SQL Server™ (MSSQLSERVER) La valeur True indique que le service SQL Server est en cours d'exécution sur ce serveur Exchange.

Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur renvoyée pour cette clé indique la version du système d'exploitation Windows exécutée sur l'ordinateur Exchange Server.

En outre, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détermine que le service SQL Server est démarré sur un ordinateur Exchange Server répondant à tous les critères suivants, un avertissement s'affiche :

  • L'ordinateur Exchange Server héberge plus de 100 boîtes aux lettres.

  • L'ordinateur Exchange Server ne fonctionne pas sur Windows Small Business Server 2003 ou Small Business Server 2000.

Il n'est pas recommandé d'exécuter SQL Server sur le même ordinateur qu'un serveur de boîtes aux lettres Exchange de production. SQL Server et les serveurs de boîtes aux lettres Exchange utilisent beaucoup de ressources mémoire et disque pour fonctionner de manière optimale. L'hébergement de SQL Server et d'Exchange Server sur le même ordinateur dans un environnement de production risque fortement de réduire les performances d'un ou des deux serveurs. En outre, le dépannage et la sécurisation de telles installations ne sont pas faciles.

Enfin, il existe un certain nombre de problèmes d'interopérabilité connus que vous pouvez rencontrer lorsque vous exécutez SQL Server et Exchange Server sur le même ordinateur. La plupart de ces problèmes proviennent d'incohérences entre versions de fichiers ou de programmes communs aux deux serveurs, tels que Microsoft Distributed Transaction Coordinator (MS DTC), Microsoft ActiveX® Data Objects (ADO) et OLE Database (OLE DB).

Pour supprimer cet avertissement

  • Prenez en compte l'une des options suivantes pour supprimer cet avertissement :

    • Déplacez Exchange Server ou SQL Server de l'ordinateur. Il est conseillé de supprimer totalement l'un de ces programmes de l'ordinateur.

    • Déplacez les boîtes aux lettres Exchange du serveur. Il convient, au minimum, de supprimer les boîtes aux lettres et de convertir le serveur Exchange en serveur de protocole ou d'infrastructure. Cela réduira la charge considérablement pour les E/S disque et de manière marginale pour le processeur (ce dernier dépend du rôle d'infrastructure d'Exchange).

    • Envisagez d'installer plutôt Small Business Server. Si vous utilisez Exchange dans un petit environnement qui ne nécessite pas plusieurs serveurs Exchange, l'installation de Small Business Server peut vous être profitable. Small Business Server comprend SQL Server et Exchange Server, ainsi que d'autres applications serveur clés de Microsoft et a été développé, testé et optimisé pour une installation sur un seul ordinateur.

Pour plus d'informations sur le déplacement des boîtes aux lettres et des serveurs Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975 sur les différences entre les méthodes de transfert de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

  • 297289 sur la procédure de transfert de Microsoft Exchange 2000 sur un nouveau matériel en conservant le même nom de serveur (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289)

Pour plus d'informations sur Small Business Server, voir le site sur Microsoft Windows Small Business Server 2003 (http://go.microsoft.com/fwlink/?linkid=23456),


Serveur Exchange sous VMware
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-10-26

Pour plus d'informations sur la prise en charge des ordinateurs Exchange Server fonctionnant dans des environnements virtuels, voir l'article 897615 de la Base de connaissances sur la stratégie de prise en charge des logiciels Microsoft s'exécutant sur un logiciel de virtualisation de matériel autre que Microsoft (http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615).


Ce serveur Exchange a moins de 1 Go de mémoire mais a les commutateurs /3GB et /USERVA=3030 définis dans le fichier boot.ini
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge deux classes WMI (Windows Management Instrumentation) Microsoft pour déterminer la quantité de mémoire physique sur l'ordinateur Exchange Server ainsi que la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur. Le tableau suivant décrit les classes et les clés évaluées par Exchange Server Analyzer.

Classe | Clé | Description
Win32_OperatingSystem | MaxProcessMemorySize | Nombre maximal de kilo-octets de mémoire pouvant être alloués à un processus.
Win32_OperatingSystem | OSProductSuite | Programmes supplémentaires du système d'exploitation installés et sous licence.
Win32_ComputerSystem | TotalPhysicalMemory | Nombre d'octets de mémoire vive (RAM) installés sur l'ordinateur.

Si Exchange Server Analyzer détermine que l'ordinateur Exchange Server a moins de 950 Mo de RAM et que la valeur de MaxProcessMemorySize est comprise entre 2 097 024 et 3 104 640, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server n'est pas configuré correctement pour une utilisation optimale de la mémoire à deux points de vue :

  • Le commutateur de démarrage /USERVA=3030 a été défini. Ce commutateur n'est nécessaire que sur les ordinateurs Exchange Server dotés d'au moins 1 Go de mémoire exécutés sur un système d'exploitation Microsoft Windows Server™ 2003.

  • Le commutateur de démarrage /3GB a été défini. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 Go, fonctionnant avec les systèmes d'exploitation suivants :

    • Microsoft Windows Server 2003 Édition Standard

    • Microsoft Windows Server 2003 Édition Entreprise

    • Microsoft Windows Server 2003 Édition Datacenter

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation susmentionnés lorsqu'au moins 1 Go de mémoire physique est installé.

Si vous rencontrez cet avertissement sur un système dans lequel 1 Go de mémoire physique est installé, cela peut indiquer qu'une partie de cette mémoire physique a été allouée au niveau matériel à un autre composant, tel qu'une carte graphique, et qu'elle n'est par conséquent pas disponible pour le système d'exploitation. Dans ce cas, la quantité de mémoire physique installée selon Windows est inférieure à la quantité réelle installée sur l'ordinateur. Vous devez alors comparer les données du BIOS et celles de Windows concernant la quantité de mémoire installée.

Pour supprimer cet avertissement dans Windows Server 2003

  1. Cliquez avec le bouton droit sur Poste de travail, puis sur Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur Avancé.

  3. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  4. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  5. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes les lignes de démarrage : /3GB /USERVA=3030

  6. Enregistrez les modifications et fermez le Bloc-notes.

  7. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour supprimer cet avertissement dans Windows 2000 Server

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier, puis cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Supprimez le commutateur /3GB et le commutateur /USERVA=3030, le cas échéant.

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation des commutateurs de démarrage /3GB et /USERVA, voir les articles suivants de la Base de connaissances Microsoft :

  • 308356 sur l'utilisation de la mémoire par le processus Lsass.exe sur les contrôleurs de domaine qui exécutent Windows Server 2003 ou Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

  • 297812 sur l'utilisation de la fonctionnalité de réglage de RAM 4GT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739 sur l'utilisation du commutateur /USERVA dans le fichier Boot.ini pour régler les configurations /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Ce serveur Exchange a moins de 1 Go de mémoire mais a le commutateur /3GB défini dans le fichier Boot.ini
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge deux classes WMI (Windows® Management Instrumentation) Microsoft pour déterminer la quantité de mémoire physique sur l'ordinateur Exchange Server ainsi que la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur en cours d'exécution sur l'ordinateur Exchange Server. Le tableau suivant décrit les classes et les clés évaluées par Exchange Server Analyzer.

Classe demandée | Clés demandées | Description
Win32_OperatingSystem | MaxProcessMemorySize | Nombre maximal de kilo-octets de mémoire pouvant être alloués à un processus.
Win32_ComputerSystem | TotalPhysicalMemory | Nombre d'octets de mémoire vive (RAM) installés sur l'ordinateur.

Si Exchange Server Analyzer détermine que la valeur de TotalPhysicalMemory est inférieure à 1073741824 et que celle de MaxProcessMemorySize est égale à 3145600, un avertissement s'affiche.

Cet avertissement indique que le système possède moins de 950 mégaoctets (Mo) de mémoire physique, mais qu'il a été configuré avec le commutateur de démarrage /3GB dans le fichier Boot.ini. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 gigaoctet (Go), fonctionnant avec les systèmes d'exploitation suivants :

  • Microsoft Windows Server™ 2003 Édition Standard

  • Microsoft Windows Server 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation susmentionnés lorsqu'au moins 1 Go de mémoire physique est installé.

Si vous rencontrez cet avertissement sur un système dans lequel 1 Go de mémoire physique est installé, cela peut indiquer qu'une partie de cette mémoire physique a été allouée au niveau matériel à un autre composant, tel qu'une carte graphique, et qu'elle n'est par conséquent pas disponible pour le système d'exploitation. Dans ce cas, la quantité de mémoire physique installée selon Windows est inférieure à la quantité réelle installée sur l'ordinateur. Vous devez alors comparer les données du BIOS et celles de Windows concernant la quantité de mémoire installée.

Pour supprimer cet avertissement dans Windows Server 2003

  1. Cliquez avec le bouton droit sur Poste de travail, puis sur Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur Avancé.

  3. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  4. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  5. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes les lignes de démarrage : /3GB

  6. Enregistrez les modifications et fermez le Bloc-notes.

  7. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour supprimer cet avertissement dans Windows 2000 Server

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système. Cette partition contient les fichiers spécifiques de matériel, tels que Boot.ini et NTLDR.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Lorsque vous y êtes invité, cliquez sur Oui.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier, puis cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes les lignes de démarrage : /3GB

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus d'informations sur l'optimisation de l'utilisation de la mémoire d'Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Ce serveur Exchange comporte un commutateur de démarrage /3GB défini dans le fichier Boot.ini
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur (MaxProcessMemorySize) sur l'ordinateur Exchange Server.

Exchange Server Analyzer examine également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique qu'il s'agit d'un serveur frontal.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer si le service de cluster (ClusSvc) est présent et démarré.

Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'attributs homeMDBBL de l'objet de banque de boîte aux lettres (msExchPrivateMDB). Le résultat est le nombre de boîtes aux lettres identifiées sur l'ordinateur Exchange Server.

Si Exchange Server Analyzer détermine que la valeur de la clé MaxProcessMemorySize est différente de 2 097 024, que la clé IsFrontEndServer est définie sur False, que le service de cluster n'est pas exécuté, que la banque de boîtes aux lettres d'Exchange Server contient moins de 20 boîtes aux lettres et qu'Exchange n'est pas exécuté dans Microsoft Windows Small Business Server 2003, un avertissement s'affiche.

Cet avertissement indique que le serveur d'annuaire n'est pas correctement configuré pour une utilisation optimale de la mémoire, étant donné que le commutateur de démarrage /3GB a été défini dans le fichier Boot.ini. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 Go, fonctionnant avec les systèmes d'exploitation suivants :

  • Microsoft Windows Server™ 2003 Édition Standard

  • Microsoft Windows Server 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation susmentionnés lorsqu'au moins 1 Go de mémoire physique est installé.

Lorsque le paramètre /3GB est inclus dans le fichier Boot.ini d'un système d'exploitation pris en charge, Windows alloue 3 Go sur un maximum de 4 Go d'espace d'adresse virtuelle au processus utilisateur et 1 Go au noyau. Normalement (lorsque le paramètre /3GB n'est pas utilisé), Windows attribue 2 Go au processus utilisateur et 2 Go au noyau. Par conséquent, grâce au commutateur /3GB, les applications gourmandes en mémoire possèdent un espace d'adressage mémoire virtuel plus important et les performances sont accrues.

L'utilisation du commutateur /3GB aide principalement les applications gourmandes en mémoire comme le processus Store.exe sur un serveur Exchange hébergeant des boîtes aux lettres d'utilisateurs. Un serveur frontal n'hébergeant pas de boîtes aux lettres d'utilisateurs, l'utilisation du commutateur /3GB ne présente aucun avantage sur un serveur frontal.

Pour supprimer cet avertissement

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur l'onglet Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier, cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes lignes de démarrage : /3GB

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation du commutateur /3GB, voir les articles suivants de la Base de connaissances Microsoft :

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372 sur l'optimisation de l'utilisation de la mémoire dans Exchange Server 2003

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


Ce serveur Exchange 2003 n'utilise pas la version finale du Service Pack 1 (build 7226.6).
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour chaque objet Exchange Server de l'annuaire. L'attribut serialNumber est une valeur de chaîne incluant la version d'Exchange Server et, le cas échéant, celle du Service Pack installé. Par exemple, sur un ordinateur Exchange Server 2003 avec le Service Pack 1 installé, l'attribut serialNumber est égal à Version 6.5 (Build 7226.6: Service Pack 1).

Si Exchange Server Analyzer détecte que la valeur de l'attribut serialNumber contient 6.5 et Service Pack 1 dans sa chaîne, mais pas 7226.6, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server 2003 exécute une pré-version d'Exchange Server 2003 Service Pack 1.

Remarque :
Étant donné qu'il est impossible de désinstaller les Service Packs d'Exchange, il est vivement recommandé de procéder à une sauvegarde complète de l'ordinateur Exchange Server avant d'appliquer les Service Packs.

Pour supprimer cet avertissement

  1. Téléchargez la dernière version d'Exchange Server 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?LinkId=29090).

  2. Voir les notes de mise à jour d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=23235).

  3. Voir les mises à jour du Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=34272).

  4. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  5. Appliquez le Service Pack 1 pour Exchange Server 2003.

  6. Effectuez une nouvelle sauvegarde complète de l'ordinateur Exchange Server.

Pour plus d'informations sur l'installation d'un Service Pack d'Exchange Server, voir l'article 328839 de la Base de connaissances Microsoft sur la procédure d'application des Service Packs et correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Ce serveur Exchange utilise Windows 2000 Server mais le commutateur /3GB est défini dans le fichier boot.ini
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge deux classes WMI (Windows® Management Instrumentation) Microsoft pour déterminer la quantité de mémoire physique sur l'ordinateur Exchange Server ainsi que la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur. Le tableau suivant décrit les classes et les clés évaluées par Exchange Server Analyzer.

Classe | Clé | Description
Win32_OperatingSystem | MaxProcessMemorySize | Nombre maximal de kilo-octets de mémoire pouvant être alloués à un processus.
Win32_OperatingSystem | OSProductSuite | Programmes supplémentaires du système d'exploitation installés et sous licence.
Win32_ComputerSystem | TotalPhysicalMemory | Nombre d'octets de mémoire vive (RAM) installés sur l'ordinateur.

Si Exchange Server Analyzer détermine que la valeur de MaxProcessMemorySize n'est pas égale à 2097024 et que la valeur de OSProductSuite correspond à Windows 2000 Server, une erreur s'affiche.

Cet avertissement indique que le serveur d'annuaire n'est pas correctement configuré pour une utilisation optimale de la mémoire, étant donné que le commutateur de démarrage /3GB a été défini dans le fichier Boot.ini. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 Go, fonctionnant avec les systèmes d'exploitation suivants :

  • Microsoft Windows Server™ 2003 Édition Standard

  • Microsoft Windows Server 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation susmentionnés lorsqu'au moins 1 Go de mémoire physique est installé.

Pour corriger cette erreur dans Windows Server 2003

  1. Cliquez avec le bouton droit sur Poste de travail et sélectionnez Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur l'onglet Avancé.

  3. Dans la zone Démarrage et récupération, cliquez sur le bouton Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  4. Dans la zone Démarrage du système, cliquez sur le bouton Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  5. Dans la section [Systèmes d'exploitation], supprimez les commutateurs suivants de toutes les lignes de démarrage : /3GB.

  6. Enregistrez les modifications et fermez le Bloc-notes.

  7. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez le serveur d'annuaire pour que la modification soit prise en compte.

Pour corriger cette erreur dans Windows 2000 Server

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur l'onglet Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier, cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Supprimez /3GB et enregistrez le fichier.

  5. Redémarrez le serveur d'annuaire pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation des commutateurs de démarrage /3GB et /USERVA, voir les articles suivants de la Base de connaissances Microsoft :

  • 297812 sur l'utilisation de la fonctionnalité de réglage de RAM 4GT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 316739 sur l'utilisation du commutateur /USERVA dans le fichier Boot.ini pour régler les configurations /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739)

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)


Impossible d'accéder à la classe WMI de Exchange Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-08-24

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si une valeur est définie pour la clé Name. Si cette interrogation échoue et si Exchange Server n'utilise pas Microsoft Windows NT® Server°4.0, Exchange Server Analyzer affiche une erreur.

Cette erreur peut avoir deux causes :

  • le compte qui utilise Exchange Server Analyzer n'a pas d'autorisations suffisantes pour interroger des classes WMI ou

  • Un problème de réseau empêche Exchange Server Analyzer de contacter l'ordinateur.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour voir si l'ordinateur Exchange Server est accessible.

  3. En cas de pare-feu, vérifiez que les ports d'appel de procédure distante (RPC) sont bloqués.

  4. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque serveur Exchange qu'il analyse.

    Vous pouvez également accorder des autorisations WMI spécifiques au compte sous lequel Exchange Server Analyzer est exécuté :

    1. Sur l'ordinateur Exchange, ouvrez l'arborescence MMC (Microsoft Management Console) Gestion de l'ordinateur.

    2. Dans Services et applications, cliquez avec le bouton droit sur Contrôle WMI et cliquez sur Propriétés.

    3. Dans la page Propriété des contrôles WMI, cliquez sur l'onglet Sécurité, puis développez Racine.

    4. Sélectionnez le dossier CIMV2 et cliquez sur Sécurité.

    5. Dans la page Sécurité pour ROOT\CIMV2, ajoutez le compte sous lequel Exchange Server Analyzer est exécuté.

  5. Sélectionnez le compte ajouté à l'étape 5 ci-dessus. Dans Autorisations pour compte_sélectionné, sous la colonne Autoriser, activez les cases à cocher Appel à distance autorisé et Sécurité de lecture, puis cliquez sur OK.

Pour plus d'informations sur la résolution de problèmes de connectivité réseau, consultez l'article 325487 de la Base de connaissances Microsoft, « Résolution des problèmes de connectivité réseau » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur la résolution des problèmes de connectivité de l'outil Exchange Server Best Practices Analyzer Tool, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, consultez l'article 832017 de la Base de connaissance, « Vue d'ensemble des services et exigences de ports réseau pour le système Windows Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Le service Surveillance du système Exchange n'est pas en cours d'exécution sur ce serveur frontal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service Surveillance du système Microsoft Exchange. La valeur False indique que le service Surveillance du système Exchange n'est pas en cours d'exécution. La valeur True indique que le service Surveillance du système Exchange est en cours d'exécution.

Exchange Server Analyzer examine également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique qu'il s'agit d'un serveur frontal.

Si Exchange Server Analyzer détecte que la valeur de la clé Started sur un serveur frontal Exchange est définie sur False, un avertissement s'affiche.

Généralement, la plupart des serveurs Exchange utilisent constamment le service Surveillance du système. Or, l'exécution du service Surveillance du système n'est pas toujours requise. Par exemple, sur un serveur frontal, le service Surveillance du système n'est requis que pour l'apport de modifications à la configuration du serveur.

Exchange Server stocke toutes ses informations de configuration dans le service d'annuaire Active Directory®, notamment les informations concernant les stratégies de destinataire, la configuration du serveur virtuel SMTP (Simple Mail Transfer Protocol), les paramètres d'appel de procédure distante (RPC) sur HTTP (Hypertext Transfer Protocol) et les boîtes aux lettres d'utilisateurs. Toutefois, SMTP lit ses paramètres à partir de la métabase IIS (Internet Information Services). Pour intégrer dans la métabase IIS les informations nécessaires à Exchange pour SMTP et la fonctionnalité RPC sur HTTP, le composant Directory-service-to-Metabase (DS2MB) du service Surveillance du système réplique les informations de configuration d'Active Directory dans la métabase IIS. Si le service Surveillance du système n'est pas en cours d'exécution, les modifications apportées aux paramètres de configuration d'Exchange Server stockés dans Active Directory ne sont pas copiées vers la métabase IIS d'Exchange Server. Si aucune modification n'est apportée à la configuration et si les messages SMTP ne sont pas en cours de traitement, le service Surveillance du système peut rester dans un état arrêté.

Si vous devez modifier la configuration, lancez le service Surveillance du système, modifiez la configuration, puis attendez que ces modifications soient répliquées dans la métabase IIS. Pour déterminer si les modifications ont été répliquées d'Active Directory dans la métabase IIS, recherchez la présence de trois entrées dans le journal des événements Applications d'Exchange Server présentant une source d'événement MSExchangeMU et un ID d'événement 1005. Ces événements sont consignés après la réussite d'une réplication DS2MB. Dès que ces événements sont consignés, vous pouvez arrêter le service Surveillance du système.

Si SMTP n'est pas utilisé sur un serveur frontal, la configuration recommandée consiste à arrêter le service Surveillance du système et à le désactiver. Sur les serveurs frontaux qui utilisent SMTP et tous les autres ordinateurs Exchange Server, le service Surveillance du système Exchange doit être en cours d'exécution pour pouvoir remettre des messages, effectuer des transactions de banque de boîtes aux lettres et SMTP et réaliser la réplication DS2MB.

Le service Surveillance du système Exchange doit toujours être exécuté sur les serveurs principaux et tout autre serveur Exchange qui contient des boîtes aux lettres ou des dossiers publics.

Pour supprimer cet avertissement

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Dans le volet droit, faites défiler jusqu'au service Surveillance du système Microsoft Exchange et double-cliquez sur celui-ci. La boîte de dialogue Propriétés du service Surveillance du système s'affiche.

  3. Définissez la valeur de la liste déroulante Type de démarrage sur Automatique.

  4. Cliquez sur Démarrer pour démarrer le service Surveillance du système.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du service Surveillance du système.

  6. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur la désactivation du service Surveillance du système et la sécurisation de serveurs Exchange, voir les rubriques Exchange Server suivantes :

  • sur la sécurisation des serveurs Exchange 2000 sur la base du rôle (http://go.microsoft.com/fwlink/?LinkId=35585)

  • sur le Guide de renforcement de la sécurité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47578)


Le service Surveillance du système Exchange n'est pas en cours d'exécution
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service Surveillance du système Microsoft Exchange. La valeur False indique que le service Surveillance du système Exchange n'est pas en cours d'exécution. La valeur True indique que le service Surveillance du système Exchange est en cours d'exécution.

Exchange Server Analyzer examine également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique qu'il s'agit d'un serveur frontal.

Si Exchange Server Analyzer détecte que la valeur de la clé Started est définie sur False sur un ordinateur Exchange Server qui n'est pas un serveur frontal, un avertissement s'affiche.

Généralement, la plupart des serveurs Exchange utilisent constamment le service Surveillance du système. Or, l'exécution du service Surveillance du système n'est pas toujours requise. Par exemple, sur un serveur frontal Exchange 2000 Server ou Exchange Server 2003, le service Surveillance du système n'est requis que pour l'apport de modifications à la configuration du serveur.

Exchange Server stocke toutes ses informations de configuration dans le service d'annuaire Active Directory®, notamment les informations concernant les stratégies de destinataire, la configuration du serveur virtuel SMTP (Simple Mail Transfer Protocol), les paramètres d'appel de procédure distante (RPC) sur HTTP (Hypertext Transfer Protocol) et les boîtes aux lettres d'utilisateurs. Toutefois, SMTP lit ses paramètres à partir de la métabase IIS (Internet Information Services). Pour intégrer dans la métabase IIS les informations nécessaires à Exchange pour SMTP et la fonctionnalité RPC sur HTTP, le composant Directory-service-to-Metabase (DS2MB) du service Surveillance du système réplique les informations de configuration d'Active Directory dans la métabase IIS. Si le service Surveillance du système n'est pas en cours d'exécution, les modifications apportées aux paramètres de configuration d'Exchange Server stockés dans Active Directory ne sont pas copiées vers la métabase IIS d'Exchange Server. Si aucune modification n'est apportée à la configuration et si les messages SMTP ne sont pas en cours de traitement, le service Surveillance du système peut rester dans un état arrêté.

Si vous devez modifier la configuration, lancez le service Surveillance du système, modifiez la configuration, puis attendez que ces modifications soient répliquées dans la métabase IIS. Pour déterminer si les modifications ont été répliquées d'Active Directory dans la métabase IIS, recherchez la présence de trois entrées dans le journal des événements Applications d'Exchange Server présentant une source d'événement MSExchangeMU et un ID d'événement 1005. Ces événements sont consignés après la réussite d'une réplication DS2MB. Dès que ces événements sont consignés, vous pouvez arrêter le service Surveillance du système.

Si SMTP n'est pas utilisé sur un serveur frontal Exchange 2000 Server ou Exchange Server 2003, la configuration recommandée consiste à arrêter le service Surveillance du système et à le désactiver. Sur les serveurs frontaux Exchange 2000 Server ou Exchange Server 2003 qui utilisent SMTP et tous les autres ordinateurs Exchange Server, le service Surveillance du système Exchange doit être en cours d'exécution pour pouvoir remettre des messages, effectuer des transactions de banque de boîtes aux lettres et SMTP et réaliser la réplication DS2MB.

Le service Surveillance du système Exchange doit toujours être exécuté sur les serveurs principaux et tout autre serveur Exchange qui contient des boîtes aux lettres ou des dossiers publics.

Correction de cet avertissement

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Dans le volet droit, faites défiler jusqu'au service Surveillance du système Microsoft Exchange et double-cliquez sur celui-ci. La boîte de dialogue Propriétés du service Surveillance du système s'affiche.

  3. Définissez la valeur du menu déroulant Type de démarrage sur Automatique.

  4. Cliquez sur Démarrer pour démarrer le service Surveillance du système.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du service Surveillance du système.

  6. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur la désactivation du service Surveillance du système et la sécurisation de serveurs Exchange, consultez l'article relatif à la sécurisation de serveurs Exchange 2000 en fonction du rôle (http://go.microsoft.com/fwlink/?linkid=35585).


Les segments Exchmem indiquent des problèmes de performances
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a analysé les compteurs de performance Exchmem Heap dans l'objet de performance MSExchangeIS pour déterminer si les performances du serveur Exchange ont diminué. L'outil Exchange Server Analyzer Tool génère un rapport sur les compteurs Exchmem comme suit :

  • Si la valeur Exchmem: Number of heaps with memory errors est positive, Exchange Server Analyzer génère un avertissement. Si la valeur est supérieure à cinq, Exchange Server Analyzer génère une erreur.

  • Si la valeur Exchmem: Number of memory errors est supérieure à 500, Exchange Server Analyzer génère une erreur.

  • Si la valeur Exchmem: Number Additional Heaps est supérieure à 3, Exchange Server Analyzer génère une erreur.

Le processus Store.exe utilise ses propres mécanismes et structures d'allocation de segment. Ils sont appelés Exchmem. Au démarrage, le processus Store.exe crée plusieurs segments Exchmem. Store.exe n'augmente pas le nombre de segments sauf si le nombre existant est utilisé totalement ou fragmenté à un point où une allocation ne dispose pas de mémoire contiguë suffisante pour réussir.

En cas de problème d'utilisation de la mémoire ou de fragmentation interne (c'est-à-dire la fragmentation dans les segments Exchmem, qui résident dans l'espace de mémoire virtuelle de la banque d'informations Exchange), le processus Store.exe crée de nouveaux segments Exchmem.

En règle générale, si le processus Store.exe doit créer à plusieurs reprises des segments supplémentaires, la mémoire virtuelle de la banque d'informations Exchange est fragmentée ou épuisée. En opérant le suivi des compteurs répertoriés ci-dessus, vous pouvez déterminer si les segments Exchmem constituent une source de problème ou s'ils diminuent les performances à mesure que les segments sont fragmentés.

Pour supprimer l'avertissement ou l'erreur

  • Téléchargez et installez les dernières mises à jour de la banque d'informations Exchange.

    • Pour obtenir les derniers téléchargements d'Exchange Server 2003, voir le site Web des téléchargements pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

    • Pour obtenir les derniers téléchargements d'Exchange 2000 Server, voir le site Web des téléchargements pour Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).

  • Téléchargez et installez les dernières mises à jour pour toutes les applications exécutées dans le processus Store.exe. Parfois, des applications tierces qui s'exécutent dans le processus Store.exe peuvent provoquer une fragmentation de segments.

  • Envisagez le déplacement des boîtes aux lettres utilisateur du serveur touché vers un autre serveur pour limiter la charge du serveur. Pour plus d'informations, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

  • Jusqu'à ce que vous ayez identifié la cause du problème, vous pouvez redémarrer au besoin pour réinitialiser la mémoire.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


EXCHMEM.DLL est présent dans le dossier System32 de Windows
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer s'il peut lire la valeur de la clé Version pour \Windows\System32\Exchmem.dll. Si Exchange Server Analyzer peut lire la clé Version, Exchmem.dll est présent dans le dossier System32.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 6 », l'ordinateur exécute Exchange 2000 Server ou Exchange Server 2003.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • Exchmem.dll est présent dans le dossier System32.

  • L'ordinateur exécute Exchange 2000 Server ou Exchange Server 2003.

En principe, deux copies d'Exchmem.dll ne peuvent pas exister sur un serveur Exchange. Toutefois, un second fichier Exchmem.dll est parfois ajouté à l'aide d'une mise à niveau en place des versions précédentes du produit. La présence de deux versions du fichier peut provoquer l'échec du paramétrage lors de l'installation des Service Packs. Pour éviter tout problème, il est recommandé de renommer ou supprimer le fichier Exchmem.dll du dossier \Windows\System32.

Pour supprimer ou renommer une seconde version d'Exchmem.dll

  1. Arrêtez tous les services Exchange.

  2. Renommez ou supprimez le fichier Exchmem.dll dans le dossier \Windows\System32.

  3. Redémarrez tous les services Exchange.


Erreur irrécupérable détectée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer tente d'accéder à diverses ressources spécifiques pour exécuter son analyse :

  • Service d'annuaire Microsoft Active Directory®

  • Centre de suivi des messages Exchange Server

  • Registre de Microsoft Windows®

  • Microsoft Windows® Management Instrumentation (WMI)

  • Métabase des Services Internet (IIS)

Si Exchange Server Analyzer ne peut pas accéder à une ou plusieurs ressources requises, Exchange Server Analyzer affiche un message d'erreur.

Cette erreur indique que, parce qu'une ou plusieurs de ces ressources de base sont inaccessibles, une analyse supplémentaire est impossible.

Pour corriger cette erreur, consultez les instructions et les liens spécifiques à l'erreur fournis par Exchange Server Analyzer.


L'enregistrement FCL n'est pas activé pour le serveur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets ayant une classe d'objet msExchExchangeServer. Si la valeur de chaîne contient Version 5.5, l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient Version 6.0, l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient Version 6.5, l'ordinateur exécute Exchange Server 2003.

Exchange Server Analyzer interroge également la présence de la sous-clé Disable Call Tracing dans l'entrée de Registre suivante pour déterminer si la fonction Microsoft Exchange Function Call Logging (FCL) est activée pour le serveur Exchange :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server peut suivre les performances des appels internes effectués par le service de la banque d'informations de Microsoft Exchange (Store.exe). Vous pouvez utiliser la fonction FCL pour isoler le composant et l'appel de fonction susceptibles d'être la cause première du problème de performances.

La fonction FCL du service de la banque d'informations de Microsoft Exchange suit les appels pertinents aux composants suivants :

  • Local Security Authentication Server (Lsass.exe)

  • DSAccess

  • Extensible Storage Engine (ESE)

  • IMAIL

  • Virusscan

FCL est une fonction d'enregistrement à faible charge système qui collecte des données relatives à des scénarios de problèmes tels que des problèmes d'arrêt d'Exchange Server ou des situations où le service de banque d'informations Exchange (Store.exe) présente une perte de performances ou ne répond pas.

Dès qu'elle est activée, la fonction FCL consigne automatiquement les données des appels de fonction. Elle n'exige aucune configuration spécifique ni aucune intervention de l'utilisateur telle que l'acquisition d'un fichier de vidage utilisateur du serveur de production ou l'utilisation d'un débogueur.

Par défaut, la fonction FCL est activée sur Exchange Server 2003, mais elle doit être expressément activée sur Exchange 2000 Server.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • Le serveur exécute Exchange 2000 Server et la sous-clé Disable Call Tracing n'est pas présente ou, si elle l'est, elle contient une valeur autre que 0.

  • Le serveur exécute Exchange Server 2003 et la sous-clé Disable Call Tracing est présente et contient une valeur autre que 0.

Ce message, qui réfère à une pratique recommandée, indique que la fonction FCL est désactivée.

Il est en effet recommandé d'activer FCL sur tous les serveurs Exchange.

Important :
Cet article contient des informations sur la procédure de modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour activer la fonction Function Call Logging sur un ordinateur Exchange 2000 Server

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing

  3. Dans le volet droit, double-cliquez sur Disable Call Tracing. Si la sous-clé Disable Call Tracing n'est pas présente, créez-la comme une nouvelle valeur DWORD.

  4. Configurez la sous-clé Disable Call Tracing à l'aide de la valeur 0.
Remarque :
Par défaut, la fonction FCL est désactivée dans Exchange 2000 Server et la sous-clé reçoit la valeur 1.
  1. Fermez l'Éditeur du Registre.

  2. Redémarrez le service de banque d'informations d'Exchange pour que les modifications soient prises en compte.

 Pour activer la fonction Function Call Logging sur un ordinateur Exchange Server 2003

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Disable Call Tracing.

  3. Dans le volet droit, double-cliquez sur Disable Call Tracing.

  4. Configurez la sous-clé Disable Call Tracing à l'aide de la valeur 0.
Remarque :
Par défaut, la fonction FCL est activée sur Exchange Server 2003, la sous-clé Disable Call Tracing a été créée et elle a été définie sur une valeur autre que 0 pour la désactiver.
  1. Fermez l'Éditeur du Registre.

  2. Redémarrez le service de banque d'informations d'Exchange pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Les entrées libres dans la table des pages ont atteint le seuil critique
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_PerfOS_Memory pour déterminer la valeur actuelle de l'objet FreeSystemPageTableEntries. Si la valeur de FreeSystemPageTableEntries est inférieure ou égale à 5000, une erreur s'affiche.

Microsoft Windows Server™ 2003 et Windows 2000 Server peuvent directement traiter 4 gigaoctets (Go) d'espace d'adressage mémoire maximum, quelle que soit la taille de RAM physique installée. Du point de vue du processus, chaque élément d'adresse virtuelle fait théoriquement référence à un octet de mémoire physique. Le gestionnaire de mémoire virtuelle (VMM) est chargé, en association avec l'unité de gestion de la mémoire (MMU) du processeur, de traduire ou mapper chaque adresse virtuelle en une adresse physique correspondante. Le gestionnaire de mémoire virtuelle effectue le mappage en divisant la RAM en cadres de page de taille fixe, créant ainsi des entrées dans la table des pages (PTE) pour stocker des informations relatives à ces cadres et les mapper. Les PTE système sont de petits tampons de mémoire en mode noyau utilisés pour communiquer avec le sous-système d'E/S et le réseau. Chaque PTE représente un cadre de page et contient des informations nécessaires, permettant au gestionnaire de mémoire virtuelle de localiser une page.

Sur un système X86 utilisant une taille de page de 4 Ko, le nombre maximal de PTE requis pour mapper 2 Go d'espace d'adressage s'élève à 524 288 (2 Go/4 Ko). Sur un système similaire utilisant le commutateur /3GB, le nombre de PTE requis pour mapper 3 Go d'espace d'adressage s'élève à 786 432 (3 Go/4 Ko). Sur un système standard, cet espace est utilisé comme suit :

  • Un maximum de 50 000 PTE (environ 195 Mo d'espace d'adressage) est réservé à un usage général.

  • Le reste est utilisé pour mapper le cache système, l'hyperespace, la réserve paginée, la réserve non paginée, la zone de vidage sur incident, etc.

La taille de la réserve de PTE est automatiquement déterminée au démarrage du système en fonction de la quantité de mémoire physique du système. Cette réserve est insérée entre la réserve paginée et la réserve non paginée, qui augmente également avec la quantité de mémoire physique du système.

La réserve de PTE système peut être fréquemment utilisée et fragmentée. Cela peut conduire à des situations où un pilote risque de ne pas se charger. De même, si la réserve de PTE système est entièrement épuisée, d'autres parties du système se dégradent, pouvant annuler la création de threads, bloquer le système ou provoquer des incidents potentiels.

Un ordinateur Exchange Server sain doit disposer d'au moins 8 000 PTE système disponibles à tout moment. Si le nombre de PTE système libres est inférieur à 8 000 mais supérieur à 5 000, l'avertissement décrit dans l'article Les entrées libres dans la table des pages ont atteint le seuil d'avertissement s'affiche. Lorsque le nombre de PTE système libres est inférieur à 5 000, cette erreur s'affiche.

Pour résoudre ce problème, vous pouvez utiliser la procédure suivante pour configurer correctement la valeur de Registre SystemPages pour le système d'exploitation de votre ordinateur Exchange Server. Lorsque vous exécutez Exchange Server 2003 Service Pack 1 (SP1) sur Windows Server 2003 avec 1 Go minimum de RAM, il est recommandé de définir la clé de Registre SystemPages sur zéro. Cette recommandation diffère de celle pour Windows 2000 Server, qui propose de définir SystemPages sur la valeur 31 000 décimal.

Après avoir exécuté la procédure décrite ci-dessous, vous devez contrôler le nombre de PTE système libres. Pour ce faire, vous pouvez contrôler le compteur de performance des PTE système libres avec le Moniteur système de Windows (également connu comme l'Analyseur de performances). Si le nombre de PTE système libres reste faible après avoir modifié le Registre, vous devez vérifier les éléments suivants pour vous assurer que votre ordinateur Exchange Server est configuré de manière optimale :

  • Pilotes Un pilote défectueux est l'une des causes les plus courantes d'un faible nombre de PTE système. Contactez votre fabricant de matériel pour vous assurer que vous utilisez les pilotes les plus récents pour tout votre matériel. Il est également possible de passer à un pilote plus simple. Par exemple, les ordinateurs qui exécutent des applications serveur telles qu'Exchange Server n'ont généralement pas besoin des pilotes vidéo les plus avancés équipés de toutes les fonctionnalités. Au contraire, un pilote plus simple est souvent suffisant. Passer d'un pilote vidéo avancé à un pilote vidéo de base doit augmenter le nombre de PTE système libres.

  • Configuration système Si votre système Windows Server 2003 est équipé de 1 Go minimum de mémoire physique, vous devez vous assurer que son fichier Boot.ini est correctement configuré avec les commutateurs /3GB et /USERVA=3030 comme décrit dans l'article 823440 de la Base de connaissances Microsoft sur la nécessité de l'utilisation du commutateur /3GB lors de l'installation d'Exchange Server 2003 sur un système Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) et dans l'article 810371 de la Base de connaissances sur l'utilisation du commutateur /Userva sur des serveurs Exchange Windows 2003 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Journaux d'événements Vérifiez la présence d'erreurs et d'avertissements dans le journal des événements Applications d'Exchange Server, notamment des événements MSExchangeIS 9582 (erreurs et avertissements), 9665 (avertissement) et 12880 (erreur). La présence de l'événement 9665 peut également indiquer que SystemPages n'est pas configuré pour des performances optimales. Pour plus d'informations sur ces événements, voir l'article 325044 de la Base de connaissances sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange 2003 et Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cette erreur sur un ordinateur exécutant Windows 2000 Server

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez la valeur 31 000 Décimal (31 000 est la représentation décimale de 7 918 hex ; Regedit.exe utilise par défaut des valeurs hexadécimales), puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour supprimer cette erreur sur un ordinateur exécutant la version originale de Windows Server 2003

  • Voir les informations de l'article 894067 de la Base de connaissances Microsoft sur l'outil de performance qui n'affiche pas précisément les PTE système libres disponibles dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067) pour déterminer les PTE système libres réelles.

Pour supprimer cette erreur sur un ordinateur exécutant Windows Server 2003 SP1

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre.

  6. Cliquez avec le bouton droit sur Poste de travail, puis sur Propriétés. La boîte de dialogue Propriétés système s'affiche.

  7. Cliquez sur Avancé.

  8. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  9. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  10. Consultez la section sur les systèmes d'exploitation.

    1. Si le commutateur /3GB existe, mais pas le commutateur /USERVA=3030, ajoutez le commutateur /USERVA=3030 à la ligne de démarrage pour qu'elle soit configurée comme suit : /3GB /USERVA=3030.

    2. Si les commutateurs /3GB /USERVA=3030 sont déjà configurés, modifiez la valeur du commutateur /USERVA en /USERVA=2970.

  11. Enregistrez les modifications et fermez le Bloc-notes.

  12. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'optimisation de la mémoire d'Exchange Server, voir les articles suivants de la Base de connaissances :

  • 894067 sur l'outil de performance qui n'affiche pas précisément les PTE système libres disponibles dans Windows Server 2003 http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 823150 sur la procédure de collecte de données pour résoudre des problèmes de mémoire virtuelle dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Les entrées libres dans la table des pages ont atteint le seuil d'avertissement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_PerfOS_Memory pour déterminer la valeur actuelle de l'objet FreeSystemPageTableEntries. Si la valeur de FreeSystemPageTableEntries est supérieure à 5 000 mais inférieure ou égale à 8 000, un avertissement s'affiche.

Microsoft Windows Server™ 2003 et Windows 2000 Server peuvent directement traiter 4 gigaoctets (Go) d'espace d'adressage mémoire maximum, quelle que soit la taille de RAM physique installée. Du point de vue du processus, chaque élément d'adresse virtuelle fait théoriquement référence à un octet de mémoire physique. Le gestionnaire de mémoire virtuelle (VMM) est chargé, en association avec l'unité de gestion de la mémoire (MMU) du processeur, de traduire ou mapper chaque adresse virtuelle en une adresse physique correspondante. Le gestionnaire de mémoire virtuelle effectue le mappage en divisant la RAM en cadres de page de taille fixe, créant ainsi des entrées dans la table des pages (PTE) pour stocker des informations relatives à ces cadres et les mapper. Les PTE système sont de petits tampons de mémoire en mode noyau utilisés pour communiquer avec le sous-système d'E/S et le réseau. Chaque PTE représente un cadre de page et contient des informations nécessaires, permettant au gestionnaire de mémoire virtuelle de localiser une page.

Sur un système X86 utilisant une taille de page de 4 Ko, le nombre maximal de PTE requis pour mapper 2 Go d'espace d'adressage s'élève à 524 288 (2 Go/4 Ko). Sur un système similaire utilisant le commutateur /3GB, le nombre de PTE requis pour mapper 3 Go d'espace d'adressage s'élève à 786 432 (3 Go/4 Ko). Sur un système standard, cet espace est utilisé comme suit :

  • Un maximum de 50 000 PTE (environ 195 Mo d'espace d'adressage) est réservé à un usage général.

  • Le reste est utilisé pour mapper le cache système, l'hyperespace, la réserve paginée, la réserve non paginée, la zone de vidage sur incident, etc.

La taille de la réserve de PTE est automatiquement déterminée au démarrage du système en fonction de la quantité de mémoire physique du système. Cette réserve est insérée entre la réserve paginée et la réserve non paginée, qui augmente également avec la quantité de mémoire physique du système.

La réserve de PTE système peut être fréquemment utilisée et fragmentée. Cela peut conduire à des situations où un pilote risque de ne pas se charger. De même, si la réserve de PTE système est entièrement épuisée, d'autres parties du système se dégradent, pouvant annuler la création de threads, bloquer le système ou provoquer des incidents potentiels.

Un ordinateur Exchange Server sain doit disposer d'au moins 8 000 PTE système disponibles à tout moment. Si le nombre de PTE système libres est inférieur à 5 000, l'erreur décrite dans l'article Les entrées libres dans la table des pages ont atteint le seuil critique s'affiche. Lorsque le nombre de PTE système libres est inférieur à 8 000 mais reste supérieur à 5 000, cet avertissement s'affiche.

Pour résoudre ce problème, vous pouvez utiliser la procédure suivante pour configurer correctement la valeur de Registre SystemPages pour le système d'exploitation de votre ordinateur Exchange Server. Lorsque vous exécutez Exchange Server 2003 Service Pack 1 (SP1) sur Windows Server 2003 avec 1 Go minimum de RAM, il est recommandé de définir la clé de Registre SystemPages sur zéro. Cette recommandation diffère de celle pour Windows 2000 Server, qui propose de définir SystemPages sur la valeur 31 000 décimal.

Après avoir exécuté la procédure suivante, contrôlez le nombre de PTE système libres. Pour ce faire, vous pouvez contrôler le compteur de performance des PTE système libres avec le Moniteur système de Windows (également connu comme l'Analyseur de performances). Si le nombre de PTE système libres reste faible après avoir modifié le Registre comme décrit dans cet article, vérifiez les éléments suivants pour vous assurer que votre ordinateur Exchange Server est configuré de manière optimale :

  • Pilotes Un pilote défectueux est l'une des causes les plus courantes d'un faible nombre de PTE système. Contactez votre fabricant de matériel pour vous assurer que vous utilisez les pilotes les plus récents pour tout votre matériel. Il est également possible de passer à un pilote plus simple. Par exemple, les ordinateurs qui exécutent des applications serveur telles qu'Exchange Server n'ont généralement pas besoin des pilotes vidéo les plus avancés équipés de toutes les fonctionnalités. Au contraire, un pilote plus simple est souvent suffisant. Passer d'un pilote vidéo avancé à un pilote vidéo de base doit augmenter le nombre de PTE système libres.

  • Configuration système Si votre système Windows Server 2003 est équipé de 1 Go minimum de mémoire physique, vous devez vous assurer que son fichier Boot.ini est correctement configuré avec les commutateurs /3GB et /USERVA=3030 comme décrit dans l'article 823440 de la Base de connaissances Microsoft sur la nécessité de l'utilisation du commutateur /3GB lors de l'installation d'Exchange Server 2003 sur un système Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440) et dans l'article 810371 de la Base de connaissances sur l'utilisation du commutateur /Userva sur des serveurs Exchange Windows 2003 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Journaux d'événements Vérifiez la présence d'erreurs et d'avertissements dans le journal des événements Applications d'Exchange Server, notamment des événements MSExchangeIS 9582 (erreurs et avertissements), 9665 (avertissement) et 12880 (erreur). La présence de l'événement 9665 peut également indiquer que SystemPages n'est pas configuré pour des performances optimales. Pour plus d'informations sur ces événements, voir l'article 324044 de la Base de connaissances sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange 2003 et Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement sur un ordinateur exécutant Windows 2000 Server

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez la valeur 31 000 Décimal (31 000 est la représentation décimale de 7 918 hex ; Regedit.exe utilise par défaut des valeurs hexadécimales), puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour supprimer cet avertissement sur un ordinateur exécutant la version originale de Windows Server 2003

  • Voir les informations de l'article 894067 de la Base de connaissances Microsoft sur l'outil de performance qui n'affiche pas précisément les PTE système libres disponibles dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067) pour déterminer les PTE système libres réelles.

Pour supprimer cet avertissement sur un ordinateur exécutant Windows Server 2003 SP1

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre.

  6. Cliquez avec le bouton droit sur Poste de travail, puis sur Propriétés. La boîte de dialogue Propriétés système s'affiche.

  7. Cliquez sur Avancé.

  8. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  9. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  10. Consultez la section sur les systèmes d'exploitation.

    1. Si le commutateur /3GB existe, mais pas le commutateur /USERVA=3030, ajoutez le commutateur /USERVA=3030 à la ligne de démarrage pour qu'elle soit configurée comme suit : /3GB /USERVA=3030.

    2. Si les commutateurs /3GB /USERVA=3030 sont déjà configurés, modifiez la valeur du commutateur /USERVA en /USERVA=2970.

  11. Enregistrez les modifications et fermez le Bloc-notes.

  12. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'optimisation de la mémoire d'Exchange Server, voir les articles suivants de la Base de connaissances :

  • 894067 sur l'outil de performance qui n'affiche pas précisément les PTE système libres disponibles dans Windows Server 2003 http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 823150 sur la procédure de collecte de données pour résoudre des problèmes de mémoire virtuelle dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Le serveur frontal exécute le service de réplication de sites
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge l'objet WMI (Windows® Management Instrumentation) Microsoft Exchange Server (classe Exchange_Server) pour déterminer la valeur IsFrontEndServer du serveur. Si la valeur est True, le serveur Exchange agit comme un serveur frontal. Exchange Server Analyzer interroge également l'objet WMI MSExchangeSRS (classe Win32_Service) pour déterminer la valeur de la propriété Started pour l'objet. Si la valeur est True, le service de réplication de sites est en cours d'exécution sur ce serveur.

Si le serveur Exchange est désigné comme serveur frontal et possède également une instance en cours d'exécution du service de réplication de sites, un avertissement s'affiche.

Exchange utilise le service de réplication de sites si votre topologie inclut les serveurs Exchange Server 5.5, Exchange 2000 Server ou Exchange Server 2003. Grâce à ce service, des versions ultérieures d'Exchange peuvent répliquer les informations de configuration de serveur sur des serveurs Exchange Server 5.5 sous une forme compatible avec l'annuaire Exchange Server 5.5 et traiter correctement les informations de configuration répliquées à partir de l'annuaire Exchange Server 5.5 pour pouvoir l'enregistrer dans le service d'annuaire Active Directory®. Si votre topologie est configurée pour utiliser des serveurs frontaux et principaux, le service de réplication de sites ne doit fonctionner que sur des serveurs principaux. À partir d'Exchange 2000 Server Service Pack 2 (SP2), le service de réplication de sites ne fonctionne pas correctement sur les serveurs frontaux et peut provoquer des problèmes.

Pour résoudre ce problème, convertissez le serveur frontal en serveur principal et configurez un nouveau serveur frontal. Il n'est pas recommandé de tenter de supprimer le service de réplication de sites du serveur.

Pour corriger cette erreur

  1. Configurez un nouveau serveur frontal.

  2. Sur le serveur frontal problématique, dans le Gestionnaire système Exchange, sous Serveurs, cliquez avec le bouton droit sur le serveur problématique, puis cliquez sur Propriétés.

  3. Désactivez la case à cocher Serveur frontal.

Pour plus d'informations sur le serveur frontal et le service de réplication de sites, voir l'article 313646 de la Base de connaissances Microsoft sur la désactivation des services sur des serveurs frontaux après une mise à niveau Exchange 2000 Server SP2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646).


Le fichier GAPI32.DLL du dossier bin est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier GAPI32.DLL est manquant dans le dossier system32
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


La valeur GlobalFlag a été définie
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Analyzer Tool lit les entrées de Registre suivantes pour déterminer la valeur de l'entrée GlobalFlag :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Si Exchange Server Analyzer détecte que la valeur de GlobalFlag est présente et configurée avec toute valeur autre que 0 ou null, un avertissement s'affiche.

La valeur de Registre GlobalFlag est un masque de bits qui détermine les options de débogage activées pour un processus particulier. Dans ce cas, Exchange Server Analyzer vérifie spécifiquement si une option de débogage a été activée pour divers composants Exchange :

  • STORE.EXE (le processus store)

  • MAD.EXE (le processus du service Surveillance du système)

  • INETINFO.EXE (le processus parent et d'administration IIS)

  • EMSMTA.EXE (le processus du service Agent de transfert des messages)

Sauf si vous êtes activement impliqué dans le débogage ou le suivi d'un problème avec l'aide des services du Support Technique de Microsoft, il est recommandé de toujours définir la valeur GlobalFlag sur 0 ou de la supprimer complètement, ce qui a le même effet.

La valeur de Registre GlobalFlag n'est pas présente par défaut et doit être ajoutée manuellement si le débogage du processus STORE.EXE (ou tout autre processus) est nécessaire. Vous pouvez utiliser l'outil Gflags fourni avec les outils de support de Microsoft Windows Server™ 2003, qui se trouvent sur le CD-ROM Windows dans le dossier \Support. Vous pouvez également définir manuellement la valeur sur 0 ou supprimer la valeur GlobalFlag à l'aide d'un Éditeur du Registre. Les deux procédures sont décrites dans cet article.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur à l'aide de Gflags

  1. Cliquez sur Démarrer, puis sur Exécuter et dans le champ Ouvrir, entrez GFlags. L'interface utilisateur Global Flags s'affiche.

  2. Dans le champ Image File Name (Nom du fichier d'image), entrez STORE.EXE.

  3. Sélectionnez Image File Options (Options du fichier d'image).

  4. Désactivez toutes les cases à cocher, puis cliquez sur Apply (Appliquer).

  5. Répétez les étapes 2 à 4 pour chaque processus Exchange mentionné dans cet article.

  6. Cliquez sur OK pour quitter l'outil GFlags et redémarrer les services concernés pour que la modification soit prise en compte.

Pour corriger cette erreur à l'aide d'un Éditeur du Registre

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Supprimez la valeur nommée GlobalFlag.

  4. Répétez les étapes 2 et 3 pour chaque processus Exchange mentionné dans cet article.

  5. Quittez l'Éditeur du Registre et redémarrez les services concernés pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Survenue de nombreuses erreurs de mise à niveau de la liste de contrôle d'accès
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeIS_MSExchangeIS pour déterminer la valeur actuelle de la clé ACLUpgradefailures. La clé ACLUpgradefailures représente le compteur de performance ACL Upgrade: failures sous l'objet de performance MSExchangeIS.

Si Exchange Server Analyzer détecte que la valeur de la clé ACLUpgradefailures est supérieure à 500, il affiche un avertissement.

Cet avertissement indique que le serveur Exchange a rapporté de nombreuses erreurs de mise à niveau de la liste de contrôle d'accès. Le nombre excessif d'erreurs de mise à niveau de la liste de contrôle d'accès peut entraîner de graves problèmes de performance, notamment l'arrêt aléatoire du processus de banque d'informations (store.exe).

Ces erreurs peuvent avoir de multiples raisons et apparaissent lorsque les conditions suivantes sont remplies :

  • Dans une organisation Exchange en mode mixte, l'ajusteur de cohérence Exchange Server version 5.5 n'était pas exécuté avant la mise en œuvre du serveur ADC (Active Directory Connector). L'ajusteur de cohérence Exchange Server 5.5 supprime les listes de contrôle d'accès orphelines.

  • La réplication d'Active Directory ne fonctionne pas correctement.

  • La réplication d'Active Directory Connector ne réplique pas correctement des comptes d'Exchange Server 5.5 vers Active Directory.

  • Une migration incorrecte des comptes utilisateur est survenue.

Pour supprimer cet avertissement

  1. Voir l'article 812963 de la Base de connaissances Microsoft sur l'utilisation de la clé de Registre Ignore Zombie Users (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963).

  2. Après avoir compris les implications de l'utilisation de la clé de Registre Ignore Zombie Users, ajoutez la clé comme bon vous semblera.

  3. Exécutez Exchange Server Analyzer ou contrôlez le compteur de performance ACL Upgrade: failures pour rechercher les erreurs excessives de mise à niveau de la liste de contrôle d'accès.


Utilisateur très actif de l'outil Exmon
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool utilise ExMon, l'outil de surveillance des utilisateurs d'Exchange Server, pour déterminer si un utilisateur ou un processus (ou un groupe d'utilisateurs ou de processus) provoque le pourcentage considérablement élevé de la charge actuelle du serveur.

ExMon évalue plusieurs scénarios :

  • restrictions du client ;

  • nombre élevé d'opérations d'appel de procédure distante (RPC) ;

  • nombre élevé d'opérations de synchronisation RPC ;

  • nombre élevé d'opérations en ligne du client ;

  • opérations sur les vues effectuées par les utilisateurs.

Les sections suivantes détaillent chaque scénario et recommandent les actions appropriées.

Restrictions du client

Dans ce scénario, les données RPC d'ExMon indiquent que les restrictions de l'ordinateur client provoquent une charge élevée sur ce serveur. Dans le contexte MAPI, une restriction fait référence à une opération MAPI appelée Restrict. Cette opération permet de sélectionner des éléments correspondant à des critères particuliers. L'opération Restrict fait partie du processus permettant de demander à Exchange de créer une vue sur un dossier ou un ensemble de dossiers (en réalité, une table de base de données avec des critères associés). Si la vue sur le dossier ou l'ensemble de dossiers présente déjà une restriction correspondante, le serveur utilise la vue existante pour répondre à la demande de l'utilisateur. Si une vue ne présente pas de restriction correspondante, Exchange crée une nouvelle vue. La création d'une vue revient plus cher que l'utilisation d'une vue existante.

Après le déplacement de nombreuses boîtes aux lettres, les restrictions du client engendrent temporairement plus de frais. L'opération move-mailbox provoque la recréation d'index sur les dossiers par un serveur. Par conséquent, lorsque des clients consultent des dossiers pour la première fois sur un nouveau serveur, toutes les restrictions doivent être créées de toutes pièces et les performances risquent donc d'être altérées. Si vous n'avez pas déplacé de boîtes aux lettres récemment, étudiez les points suivants :

  • Aucune autre application MAPI n'est installée sur les ordinateurs clients. Souvent, les compléments Microsoft Office Outlook® ou d'autres applications MAPI peuvent provoquer la création de trop nombreuses restrictions.

  • Les boîtes aux lettres sont dimensionnées et des limites sont définies de manière appropriée dans l'ensemble de votre organisation.

Pour plus d'informations sur la taille des boîtes aux lettres et les numéros des éléments, voir le billet de l'équipe Microsoft Exchange sur les limites de taille des boîtes aux lettres recommandées (http://go.microsoft.com/fwlink/?linkid=55097).

Nombre élevé d'opérations RPC

Citons en guise d'exemples de ces opérations le déplacement, la suppression ou la définition des propriétés (c.-à-d. read flag) pour des centaines ou des milliers d'éléments en une seule opération. Ces types d'opérations peuvent altérer temporairement les performances du serveur. Si vous effectuez souvent un nombre élevé d'opérations RPC et si le serveur devient un goulot d'étranglement au niveau du disque ou du processeur, les performances d'Outlook pour les autres utilisateurs sur le même serveurs seront altérées.

Pour corriger cette erreur

  1. Vérifiez que des limites sont définies pour les boîtes aux lettres.

  2. Recommandez à vos utilisateurs d'archiver des éléments en fichiers .pst.

    Remarque :
    Il est généralement recommandé que les dossiers fréquemment utilisés contiennent moins de 5 000 éléments.

Nombre élevé d'opérations de synchronisation RPC

Un nombre élevé d'opération de synchronisation RPC indique que plusieurs utilisateurs synchronisent actuellement des éléments. La charge du serveur augmente donc.

Pour corriger cette erreur

  • Vérifiez que vous avez mis à l'échelle vos serveurs Exchange conformément au nombre d'ordinateurs clients qui utilisent Outlook en mode Exchange mis en cache. Pour plus d'informations, voir le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  • Ralentir les demandes des clients en mode Exchange mis en cache peut contribuer à empêcher les opérations de synchronisation RPC de devenir un problème de performances. Pour plus d'informations, vois l'article 818484 de la Base de connaissances Microsoft sur les valeurs de Registre et les compteurs disponibles pour configurer et surveiller la synchronisation client Outlook (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=818484).

Nombre élevé d'opérations en ligne du client

Parfois, Exchange peut rencontrer un pic inhabituel dans les problèmes de performances provoqué par une charge élevée répartie entre les utilisateurs. Il peut s'agir du résultat d'une mauvaise planification à mesure de la croissance d'une organisation. Si vous avez respecté les recommandations de Microsoft lors de la mise à l'échelle de votre organisation et si, malgré cela, vous êtes encore confronté à de faibles performances dues à de nombreuses opérations en ligne du client, il se peut que vos utilisateurs utilisent des applications MAPI tierces ou des plug-ins Outlook.

Opérations sur les vues effectuées par les utilisateurs

Les données RPC d'ExMon indiquent qu'un utilisateur crée de nouvelles vues, ce qui provoque une charge élevée sur le serveur. Dans ce scénario, un seul utilisateur compte pour un pourcentage important de l'utilisation du processeur RPC.

Pour étudier ce processus, considérez les scénarios suivants :

  • L'utilisateur peut être occupé à effectuer des opérations sur un dossier qui contient de nombreux éléments. Pour remédier à ce problème, encouragez les utilisateurs à réduire le nombre d'éléments dans un seul dossier. Il est généralement recommandé que les dossiers contiennent moins de 2 000 éléments.

  • L'utilisateur exécute peut-être une application mal écrite qui provoque l'excès de charge. Pour résoudre ce problème, supprimez l'application.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la taille des boîtes aux lettres et les numéros des éléments, voir le billet de l'équipe Microsoft Exchange sur les limites de taille des boîtes aux lettres recommandées (http://go.microsoft.com/fwlink/?linkid=55097).

  • Pour plus d'informations sur les restrictions des boîtes aux lettres, voir le billet de l'équipe Microsoft Exchange sur l'application de restrictions à des restrictions (http://go.microsoft.com/fwlink/?LinkId=55098).

  • Pour plus d'informations sur ExMon, voir le site Web de téléchargement d'ExMon (http://go.microsoft.com/fwlink/?LinkId=54983).


IIS crée des processus 32 bits sur une machine 64 bits
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-05-03

L'outil Microsoft Exchange Server Analyzer Tool interroge la métabase IIS (Internet Information Services) pour connaître la valeur de la propriété de métabase w3svc/AppPools/Enable32BitAppOnWin64 sur tous les serveurs Windows Server 2003 Service Pack 1 (SP1) 64 bits qui exécutent Exchange Server 2007 pour déterminer si la métabase IIS est configurée de manière à créer des processus de travail 32 bits.

Une valeur de 1 (true) indique que la métabase IIS est configurée de manière à créer des processus de travail 32 bits. Une valeur de 0 (false) indique que la métabase IIS est configurée de manière à créer des processus de travail 64 bits.

Si Exchange Analyzer détermine que la valeur de la propriété de métabase w3svc/AppPools/Enable32BitAppOnWin64 est définie sur 1 (true), il affiche une erreur. Cette erreur indique que la métabase IIS est configurée de manière à créer des processus de travail 32 bits sur un serveur Windows 64 bits qui exécute Exchange 2007. Cette configuration entraîne le dysfonctionnement des répertoires virtuels d'Exchange 2007.

Pour résoudre cette erreur, configureez la métabase IIS de manière à créer des processus de travail 64 bits sur le serveur Windows Server 2003 (SP1) 64 bits qui exécute Exchange 2007.

Pour faire basculer IIS en mode 64 bits

  1. Ouvrez une invite de commandes.

  2. Tapez ensuite :

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Appuyez sur Entrée.

Pour plus d'informations sur l'exécution de processus de travail IIS 6.0 32 bits sur un serveur Windows Server 2003 SP1 64 bits, voir l'article 895976 de la Base de connaissances Microsoft sur Windows Server 2003 SP1 qui permet la compatibilité WOW64 pour des applications Web 32 bits dans IIS 6.0 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976).


Amélioration de la mémoire du noyau
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool teste les niveaux de mémoire système pour vérifier qu'ils se situent dans une plage acceptable. Si Exchange Server Analyzer détecte qu'un compteur de mémoire du noyau de l'analyseur de performances (Perfmon) se trouve en dessous du niveau approprié, il affiche un message de dépannage.

La mémoire du noyau de Microsoft Windows® consiste en différentes structures de mémoire, notamment la mémoire de réserve paginée ou non et les entrées dans la table des pages système. Ces structures de mémoire, appelées également mémoire du noyau, sont utilisées par le système d'exploitation pour fournir un environnement aux applications telles qu'Exchange. Pour conserver un déploiement Exchange sain, assurez-vous d'analyser la mémoire du noyau.

L'optimisation de la mémoire du noyau peut s'avérer complexe. Pour des informations détaillées sur l'utilisation de la mémoire du noyau, notamment des informations en matière de résolution de problèmes, voir la rubrique sur le dépannage des problèmes de performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588). Pour libérer des ressources serveur, il est essentiel de prendre en compte la charge de la boîte aux lettres utilisateur sur le serveur. Envisagez le déplacement des boîtes aux lettres utilisateur vers un autre serveur pour réduire la charge du serveur et vérifier si le problème disparaît. Pour plus d'informations, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

Pour plus d'informations

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur le déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur


Amélioration de la mémoire utilisateur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-28

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que les compteurs de performance de la mémoire utilisateur sont supérieurs au seuil considéré comme sain pour le serveur Exchange. Exchange Server Analyzer interroge le compteur de performance Mégaoctets disponibles et le compteur Pages de mémoire/s sous l'objet de performance Memory. Si le serveur ne dispose plus de beaucoup de mémoire ou présente une pagination élevée, cela indique un goulot d'étranglement de mémoire.

Le compteur de performance Mégaoctets disponibles indique la quantité de mémoire physique en mégaoctets (Mo) immédiatement disponible pour une allocation à un processus ou pour une utilisation du système. Il s'agit de la quantité de mémoire assignée à l'attente (cache), libre et sans listes de pages.

Le compteur de performance Pages de mémoire/s indique la vitesse à laquelle les pages sont lues ou écrites sur le disque pour la résolution des anomalies de pages difficiles. À mesure que le serveur utilise de la mémoire et que la mémoire disponible se réduit, le système d'exploitation commence à limiter la plage de travail du processus et à utiliser le fichier d'échange de manière plus dynamique. L'utilisation du fichier d'échange affecte l'ensemble des performances car les opérations de disque prennent plus de temps que les opérations de mémoire. Ce compteur est un indicateur essentiel des types d'anomalies qui entraînent des retards au niveau de l'ensemble du système. Il inclut des pages récupérées pour satisfaire les anomalies de page dans le cache système de fichiers. Ces pages sont généralement demandées par les applications. Le compteur devrait toujours être inférieur à 1 000.

Si Exchange Server Analyzer détecte que le compteur de performance Mégaoctets disponibles indique que moins de 50 Mo de mémoire sont disponibles ou que le taux d'écriture ou de lecture des pages de mémoire à partir du disque est supérieur à 1 000 pages par seconde, il affiche une erreur.

La liste suivante décrit la procédure d'amélioration des performances de la mémoire utilisateur.

Pour résoudre ce problème

  1. Utilisez l'outil Microsoft Exchange Server Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=34705) pour vérifier que les paramètres de la mémoire du serveur soient configurés correctement.

  2. Supprimez le logiciel superflu. Pour rendre davantage de ressources mémoire disponibles pour Exchange, supprimez les outils logiciels tiers qui exécutent des fonctions de surveillance ou tout type de services qui ne sont pas essentiels. Le composant logiciel enfichable Performance (Perfmon.msc) peut vous aider à comprendre la quantité de mémoire que les applications consomment.

  3. Exécutez les tâches de maintenance du serveur pendant les heures creuses. L'exécution d'outils (comme Eseutil) ou de tâches (comme la gestion de boîtes aux lettres) de maintenance pendant les heures de pointe peut utiliser de la mémoire qui, sinon, serait utilisée par Exchange. Il est recommandé d'exécuter ces outils et tâches pendant les heures creuses ou des périodes d'utilisation réduite.

  4. Envisagez le déplacement des boîtes aux lettres utilisateur du serveur touché vers un autre serveur pour limiter la charge du serveur. Pour plus d'informations, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

Pour plus d'informations

Pour plus d'informations, voir les ressources Microsoft suivantes :

  • Déplacement de boîtes aux lettres utilisateur vers un autre serveur

  • Rubrique sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Section sur l'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=34705)

  • Article 815372 de la Base de connaissances Microsoft sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372)

  • Document sur la modification de la configuration de la mémoire d'Exchange 2003 pour Windows 2003 (Prise en charge PAE) (http://go.microsoft.com/fwlink/?LinkId=54979)

    Remarque :
    Le contenu de chaque blog et leur URL sont susceptibles d'être modifiés sans préavis.


Optimisation de la mémoire virtuelle
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre serveur rencontre des problèmes de fragmentation de la mémoire virtuelle.

Dans les systèmes Microsoft Windows® 32 bits, il existe deux types de mémoire :

  • Mémoire physique Quantité de mémoire réelle installée sur le système

  • Espace d'adressage mémoire virtuel Espace de mémoire de 4 Go virtualisé

Quelle que soit la quantité de mémoire physique installée sur le système, la taille totale de l'espace d'adresse virtuelle est toujours identique : 4 Go. Bien que ce ne soit pas le cas pour toutes les applications 32 bits, pour Exchange Server, l'espace d'adresse virtuelle équivaut à la mémoire virtuelle ; l'un et l'autre sont interchangeables.

Lors du déroulement normal de ses opérations, la banque d'informations Exchange alloue, utilise et désalloue la mémoire virtuelle à plusieurs reprises. Si la mémoire virtuelle est fréquemment allouée, utilisée et désallouée, une fragmentation de mémoire virtuelle peut se produire. La fragmentation de mémoire virtuelle est similaire à la fragmentation de système de fichiers, qui peut se produire de temps à autre. Après un moment, les segments alloués de mémoire virtuelle ne sont plus contigus et les performances s'en ressentent. Dans le cas du système de fichiers, vous pouvez exécuter une application qui procède à la défragmentation du système de fichiers, généralement même lorsque le système est en ligne et qu'un utilisateur y accède. Il n'existe aucun outil de défragmentation pour fragmenter la mémoire virtuelle ; pour remédier à ce problème, arrêtez et redémarrez le service de banque d'informations de Microsoft Exchange ou redémarrez le système.

La fragmentation de la mémoire virtuelle peut être causée par un logiciel tiers qui s'exécute dans des processus store/inetinfo. Assurez-vous d'avoir les derniers pilotes des applications tierces. Si le problème se reproduit après le redémarrage, envisagez la désactivation du logiciel tiers ou le déplacement des boîtes aux lettres utilisateur vers un autre serveur pour réduire la charge du serveur et vérifiez si le problème disparaît. Pour plus d'informations, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur le dépannage de la fragmentation de mémoire virtuelle dans Microsoft Exchange Server 2003 et Exchange 2000 Server, voir l'article 325044 de la Base de connaissances Microsoft sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • Pour plus d'informations sur la procédure d'optimisation de l'utilisation de la mémoire virtuelle, voir l'article 815372 de la Base de connaissances sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Pour plus d'informations sur le déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur


Le filtre de messages intelligent n'est pas installé sur un ou plusieurs serveurs utilisant Exchange Server 2003
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchExchangeServer pour chaque objet Exchange Server de l'organisation. Exchange Server Analyzer utilise les résultats de cette requête pour déterminer le nombre total de serveurs dans l'organisation qui utilisent Exchange Server 2003. Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer si le filtre de messages intelligent Exchange est installé sur tous les serveurs Exchange Server 2003 de l'organisation. Si Exchange Server Analyzer détecte que le filtre de messages intelligent n'est pas installé sur un ou plusieurs serveurs utilisant Exchange Server 2003, il affiche un message de recommandation.

Le filtre de messages intelligent identifie les messages susceptibles d'être des messages commerciaux indésirables. Dans une topologie standard d'Exchange Server 2003, le filtre de messages intelligent est installé sur des serveurs de passerelle pour filtrer les messages électroniques Internet entrants. Si vous utilisez un système de messagerie autre que Microsoft comme serveur de passerelle Internet, vous devez installer le filtre de messages intelligent sur le serveur tête de pont Exchange qui accepte les messages électroniques Internet entrants à partir de vos serveurs de passerelle.

Pour ce faire, utilisez un compte possédant des droits administratifs locaux et un membre d'un groupe ayant reçu le rôle d'administrateur Exchange.

Pour plus d'informations, voir le document sur le filtre de messages intelligent Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


La mise à jour de ISA Server 2000 est disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la version du fichier smtpfltr.dll utilisée par la fonction Filtreur de messages SMTP de Microsoft ISA (Internet Security and Acceleration) Server 2000. Si Exchange Server Analyzer détecte que la valeur du numéro de version est plus ancienne que 2004, un avertissement s'affiche.

Cet avertissement indique qu'une version plus récente d'ISA Server 2000 est disponible. Il est recommandé d'installer ISA Server 2000 Service Pack 2. La mise à niveau vers le Service Pack 2 est particulièrement importante si vous utilisez la fonction Filtreur de messages SMTP. Les anciennes versions du Filtreur de messages SMTP provoquent un goulot d'étranglement et réduisent ensuite les performances globales de débit des messages.

Pour supprimer cet avertissement

  1. Téléchargez ISA Server 2000 Service Pack 2 à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?linkid=37592).

  2. Voir les notes de mise à jour du Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=37584).

  3. Installez le Service Pack 2 en respectant les instructions des notes de mise à jour.

Pour plus d'informations sur les téléchargements de ISA Server, notamment ISA Server 2000 Service Pack 2, voir le site Web des téléchargements d'ISA Server (http://go.microsoft.com/fwlink/?LinkId=18919).


Destinataire de la journalisation non valide
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-27

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut mailNickname de l'objet destinataire de la journalisation est valide. Le surnom doit être défini de manière à ce que l'attribut mailNickname soit valide. Si l'attribut mailNickname de l'objet destinataire de la journalisation désigné n'est pas valide, les messages de journalisation s'insèrent dans une file d'attente. En outre, le mailNickname non valide peut indiquer que la journalisation a été configurée pour copier les messages de journalisation vers un objet destinataire sans extension messagerie. Si Exchange Server Analyzer détecte que la valeur de l'attribut mailNickname de l'objet destinataire de la journalisation n'est pas valide, il affiche une erreur.

Pour résoudre cette erreur dans Exchange Server 2003, utilisez Utilisateurs et ordinateurs Active Directory et le Gestionnaire système Exchange pour procéder comme suit :

  • Activez l'extension messagerie à l'objet destinataire de la journalisation.

  • Désignez une nouvelle boîte aux lettres utilisateur comme destinataire de la journalisation.

Pour résoudre cette erreur dans Exchange Server 2003, utilisez Utilisateurs et ordinateurs Active Directory et le Gestionnaire système Exchange pour procéder comme suit :

Activation de l'extension messagerie pour l'objet destinataire de la journalisation pour Exchange Server 2003

  1. Ouvrez le composant Utilisateurs et ordinateurs Active Directory.

  2. Dans l'arborescence de la console, développez le domaine.

  3. Naviguez jusqu'au conteneur parent du destinataire à modifier.

  4. Dans le volet d'informations, cliquez avec le bouton droit sur le destinataire à modifier, puis sélectionnez Tâches Exchange.

  5. Dans l'Assistant Tâches Exchange, dans la boîte de dialogue Tâches disponibles, sélectionnez Créer une boîte aux lettres et cliquez sur Suivant.

  6. Dans la boîte de dialogue Créer une boîte aux lettres, vérifiez les informations dans les champs Alias, Banque d'informations et Serveur de boîtes aux lettres, puis cliquez sur Suivant.

  7. Cliquez sur Terminer pour fermer l'Assistant Tâches Exchange.
Création d'une boîte aux lettres utilisateur comme destinataire de la journalisation dans Exchange Server 2003

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Serveurs, <votre_serveur_Exchange>, <groupe_stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres et sélectionnez Propriétés.

  3. Cliquez sur Parcourir à droite du texte Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque pour spécifier une boîte aux lettres comme boîte aux lettres de journalisation.

    Remarque :
    Tous les messages journalisés pour les expéditeurs de cette banque de boîtes aux lettres sont envoyés à la boîte aux lettres spécifiée.

Pour résoudre cette erreur dans Exchange Server 2007, utilisez la console de gestion Exchange ou l'environnement de ligne de commande Exchange Management Shell pour procéder comme suit :

  • Créez une boîte aux lettres pour l'objet destinataire de journal.

  • Désignez une nouvelle boîte aux lettres utilisateur comme destinataire de la journalisation.

Activation de l'extension messagerie pour l'objet destinataire de la journalisation pour Exchange Server 2007 à l'aide de la console de gestion Exchange

  1. Dans la console de gestion Exchange, développez Configuration du destinataire, cliquez avec le bouton droit sur l'objet Boîte aux lettres, puis sélectionnez Nouvelle boîte aux lettres pour lancer l'Assistant Nouvelle boîte aux lettres.

  2. Dans la fenêtre Introduction, sélectionnez Boîte aux lettres d'utilisateur, puis cliquez sur Suivante.

  3. Dans la fenêtre Type d'utilisateur, sélectionnez Utilisateur existant, puis utilisez le bouton Parcourir pour sélectionner l'objet destinataire du journal pour lequel créer la boîte aux lettres.

  4. Dans la fenêtre Paramètres de la boîte aux lettres, vérifiez les informations des champs Alias, Serveur, Groupe de stockage et Base de données de boîtes aux lettres, puis cliquez sur Suivant.

  5. Dans la fenêtre Nouvelle boîte aux lettres, cliquez sur Nouvelle pour créer la boîte aux lettres pour l'objet destinataire du journal.

  6. Cliquez sur Terminer pour fermer l'Assistant Nouvelle boîte aux lettres.
Activation de l'extension messagerie pour l'objet destinataire de la journalisation pour Exchange Server 2007 à l'aide de l'environnement de ligne de commande Exchange Management Shell

  1. Suivez les instructions de la documentation produit d'Exchange Server 2007, « Enable-Mailbox » (http://go.microsoft.com/fwlink/?LinkID=80827).

Création d'une boîte aux lettres utilisateur comme destinataire de la journalisation dans Exchange Server 2007

  1. Dans la console de gestion Exchange, développez Configuration du serveur, <votre serveur Exchange>, <groupe de stockage>, puis cliquez avec le bouton droit sur la base de données de boîtes aux lettres et sélectionnez Propriétés.

  2. Sous l'onglet Général, sous Destinataire du journal, cliquez sur Parcourir pour spécifier une boîte aux lettres comme boîte aux lettres de journalisation.

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation avec Exchange Server 2003, consultez la rubrique sur la journalisation à l'aide d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581).

Pour plus d'informations sur le déploiement d'une solution de journalisation avec Exchange Server 2007, consultez la rubrique Vue d'ensemble de la journalisation (http://go.microsoft.com/fwlink/?LinkId=80820).


Le destinataire de la journalisation pointe vers un objet supprimé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-01

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut msExchMessageJournalRecipient contient la chaîne DEL:. Cet attribut indique que la journalisation a été configurée pour copier des messages vers une boîte aux lettres qui a été supprimée. Pour que la journalisation fonctionne correctement, une boîte aux lettres de destinataire de journalisation valide est nécessaire pour y envoyer les messages copiés. L'attribut msExchMessageJournalRecipient est défini lorsque la journalisation est activée dans une base de données de boîtes aux lettres. Cet attribut est un attribut de base de données de boîtes aux lettres et comprend le nom unique de la boîte aux lettres de journalisation.

Si la boîte aux lettres du destinataire de la journalisation a été supprimée, les messages de journalisation vont commencer à s'insérer dans une file d'attente. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchMessageJournalRecipient comprend la chaîne DEL:, il affiche une erreur.

Pour corriger cette erreur, le Gestionnaire système Exchange ou la console de gestion Exchange permettent de désigner une nouvelle boîte aux lettres comme destinataire de la journalisation.

Création d'une boîte aux lettres utilisateur comme destinataire de la journalisation dans Exchange Server 2003

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Serveurs, <votre_serveur_Exchange>, <groupe_stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres et sélectionnez Propriétés.

  3. Cliquez sur Parcourir à droite du texte Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque pour spécifier une boîte aux lettres comme boîte aux lettres de journalisation.

    Remarque :
    Tous les messages journalisés pour les expéditeurs de cette banque de boîtes aux lettres sont envoyés à la boîte aux lettres spécifiée.
Création d'une boîte aux lettres utilisateur comme destinataire de la journalisation dans Exchange Server 2007

  1. Dans la console de gestion Exchange, développez Configuration du serveur, <votre serveur Exchange>, <groupe de stockage>, puis cliquez avec le bouton droit sur la base de données de boîtes aux lettres et sélectionnez Propriétés.

  2. Sous l'onglet Général, sous Destinataire du journal, cliquez sur Parcourir pour spécifier une boîte aux lettres comme boîte aux lettres de journalisation.

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation pour Exchange Server 2003, consultez la rubrique sur la journalisation à l'aide d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581).

Pour plus d'informations sur le déploiement d'une solution de journalisation avec Exchange Server 2007, consultez la rubrique Vue d'ensemble de la journalisation (http://go.microsoft.com/fwlink/?LinkId=80820).


Le destinataire de la journalisation pointe vers un compte désactivé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut msExchUserAccountControl de l'objet destinataire de la journalisation est défini de manière à indiquer un compte d'utilisateur désactivé. Si la valeur de l'attribut msExchUserAccountControl de l'objet destinataire de la journalisation est définie sur 2, cette journalisation a été configurée pour copier les messages de journalisation dans un compte d'utilisateur désactivé. Cette configuration peut entraîner l'insertion des messages de journalisation dans une file d'attente ou leur envoi dans le dossier Badmail. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchUserAccountControl du destinataire de la journalisation est définie pour indiquer un compte d'utilisateur de destinataire de la journalisation désactivé, il affiche une erreur.

Pour résoudre cette erreur dans Exchange Server 2003, utilisez Utilisateurs et ordinateurs Active Directory et le Gestionnaire système Exchange pour procéder comme suit :

  • Activez le compte d'utilisateur du destinataire de la journalisation actuel.

  • Désignez une nouvelle boîte aux lettres utilisateur comme destinataire de la journalisation.

Activation du compte du destinataire du journal pour Exchange Server 2003

  1. Ouvrez le composant Utilisateurs et ordinateurs Active Directory.

  2. Dans l'arborescence de la console, développez le domaine.

  3. Naviguez jusqu'au conteneur parent du destinataire de la journalisation à modifier.

  4. Dans le volet d'informations, cliquez avec le bouton droit sur le destinataire à modifier, puis sélectionnez Activer le compte.
Création d'une boîte aux lettres utilisateur comme destinataire de la journalisation dans Exchange Server 2003

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Serveurs, <votre_serveur_Exchange>, <groupe_stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres et sélectionnez Propriétés.

  3. Cliquez sur Parcourir à droite du texte Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque pour spécifier une boîte aux lettres comme boîte aux lettres de journalisation.

    Remarque :
    Tous les messages journalisés pour les expéditeurs de cette banque de boîtes aux lettres sont envoyés à la boîte aux lettres spécifiée.

Pour résoudre cette erreur dans Exchange Server 2007, utilisez la console de gestion Exchange ou l'environnement de ligne de commande Exchange Management Shell pour procéder comme suit :

  • Créez une boîte aux lettres pour l'objet destinataire de journal.

  • Désignez une nouvelle boîte aux lettres utilisateur comme destinataire de la journalisation.

Activation de l'extension messagerie pour l'objet destinataire de la journalisation pour Exchange Server 2007 à l'aide de la console de gestion Exchange

  1. Dans la console de gestion Exchange, développez Configuration du destinataire, cliquez avec le bouton droit sur l'objet Boîte aux lettres, puis sélectionnez Nouvelle boîte aux lettres pour lancer l'Assistant Nouvelle boîte aux lettres.

  2. Dans la fenêtre Introduction, sélectionnez Boîte aux lettres d'utilisateur, puis cliquez sur Suivante.

  3. Dans la fenêtre Type d'utilisateur, sélectionnez Utilisateur existant, puis utilisez le bouton Parcourir pour sélectionner l'objet destinataire du journal pour lequel créer la boîte aux lettres.

  4. Dans la fenêtre Paramètres de la boîte aux lettres, vérifiez les informations des champs Alias, Serveur, Groupe de stockage et Base de données de boîtes aux lettres, puis cliquez sur Suivant.

  5. Dans la fenêtre Nouvelle boîte aux lettres, cliquez sur Nouvelle pour créer la boîte aux lettres pour l'objet destinataire du journal.

  6. Cliquez sur Terminer pour fermer l'Assistant Nouvelle boîte aux lettres.
Activation de l'extension messagerie pour l'objet destinataire de la journalisation pour Exchange Server 2007 à l'aide de l'environnement de ligne de commande Exchange Management Shell

  1. Suivez les instructions de la documentation produit d'Exchange Server 2007, « Enable-Mailbox » (http://go.microsoft.com/fwlink/?LinkId=80827).

Création d'une boîte aux lettres utilisateur comme destinataire de la journalisation dans Exchange Server 2007

  1. Dans la console de gestion Exchange, développez Configuration du serveur, <votre serveur Exchange>, <groupe de stockage>, puis cliquez avec le bouton droit sur la base de données de boîtes aux lettres et sélectionnez Propriétés.

  2. Sous l'onglet Général, sous Destinataire du journal, cliquez sur Parcourir pour spécifier une boîte aux lettres comme boîte aux lettres de journalisation.

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation avec Exchange Server 2003, consultez la rubrique sur la journalisation à l'aide d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581).

Pour plus d'informations sur le déploiement d'une solution de journalisation avec Exchange Server 2007, consultez la rubrique Vue d'ensemble de la journalisation (http://go.microsoft.com/fwlink/?LinkId=80820).


Le destinataire de la journalisation pointe vers un serveur local
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut msExchHomeServerName de l'objet destinataire de la journalisation pour une banque de boîtes aux lettres correspond à la valeur de l'attribut legacyExchangeDN pour le serveur local. Une correspondance entre les valeurs de ces attributs indique que les messages de journalisation sont copiés dans une boîte aux lettres sur le serveur sur lequel une journalisation active s'exécute. Un grand volume de trafic de journalisation pouvant être généré, il est recommandé que la boîte aux lettres du destinataire de la journalisation réside sur un serveur de journalisation dédié.

Si Exchange Server Analyzer détecte que les valeurs de l'attribut msExchHomeServerName pour l'objet destinataire de la journalisation correspond à la valeur de legacyExchangeDN sur le serveur local, Exchange Server Analyzer affiche un message de recommandation.

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation avec Exchange Server 2003, consultez la rubrique sur la journalisation à l'aide d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581).

Pour plus d'informations sur le déploiement d'une solution de journalisation avec Exchange Server 2007, consultez la rubrique Vue d'ensemble de la journalisation (http://go.microsoft.com/fwlink/?LinkId=80820).


Le destinataire de la journalisation doit être masqué
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut msExchHideFromAddressLists de l'objet destinataire de la journalisation est définie sur True. Une autre valeur que True pour cet attribut indique que le destinataire de la journalisation pour la banque de boîtes aux lettres n'est pas masqué dans les listes d'adresses Exchange Server et peut devenir le destinataire de messages non liés à la journalisation. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchHideFromAddressLists de l'objet destinataire de la journalisation n'est pas défini sur True, il affiche un message de recommandation.

Pour résoudre ce problème dans Exchange Server 2003, servez-vous de l'outil Utilisateurs et ordinateurs Active Directory pour masquer la boîte aux lettres du destinataire de la journalisation dans les listes d'adresses Exchange Server.

Pour résoudre ce problème dans Exchange Server 2007, servez-vous de la console de gestion Exchange pour masquer la boîte aux lettres du destinataire de la journalisation dans les listes d'adresses Exchange Server.

Masquage de la boîte aux lettres du destinataire de la journalisation désigné dans les listes d'adresses Exchange Server avec Exchange Server 2003

  1. Ouvrez le composant Utilisateurs et ordinateurs Active Directory.

  2. Dans l'arborescence de la console, développez le domaine.

  3. Naviguez jusqu'au conteneur parent du destinataire à modifier.

  4. Dans le volet d'informations, double-cliquez sur le destinataire à modifier.

  5. Sous l'onglet Paramètres avancés d'Exchange, activez la case à cocher Masquer dans la liste d'adresses Exchange.

  6. Cliquez sur OK.
Masquage de la boîte aux lettres du destinataire de la journalisation désigné dans les listes d'adresses Exchange Server avec Exchange Server 2007

  1. Ouvrez la console de gestion Exchange.

  2. Dans l'arborescence de la console, naviguez jusqu'au conteneur parent du destinataire à modifier.

  3. Dans le volet d'informations, double-cliquez sur l'objet boîte aux lettres correspondant au destinataire de la journalisation indiqué pour afficher ses propriétés.

  4. Sous l'onglet Général, activez la case à cocher Masquer dans la liste d'adresses Exchange.

  5. Cliquez sur OK.

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation avec Exchange Server 2003, consultez la rubrique sur la journalisation à l'aide d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581).

Pour plus d'informations sur le déploiement d'une solution de journalisation avec Exchange Server 2007, consultez la rubrique Vue d'ensemble de la journalisation (http://go.microsoft.com/fwlink/?LinkId=80820).


Junk store threshold not configured
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-07-30

L'outil Microsoft Exchange Analyzer Tool interroge l'environnement Exchange pour déterminer la présence des rôles serveur de boîtes aux lettres et de transport Hub Exchange Server 2007.

Si l'un des rôles serveur de boîtes aux lettres ou de transport Hub Exchange Server 2007 est détecté, Exchange Analyzer exécute la cmdlet Exchange Management Shell suivant pour interroger la valeur du paramètre SCLJunkThreshold pour l'organisation Exchange :

Get-OrganizationConfig

Le paramètre SCLJunkThreshold d'une organisation spécifie le seuil SCL auquel un message est déplacé dans le répertoire Courrier indésirable.

Si Exchange Analyzer détermine que le paramètre SCLJunkThreshold d'une organisation est défini sur la valeur par défaut 8, il affiche un avertissement.

Cet avertissement indique que le seuil SCL pour le déplacement des messages dans le répertoire Courrier indésirable est défini de manière à filtrer les utilisateurs légitimes et les déplacer dans le répertoire Courrier indésirable. La valeur recommandée du paramètre SCLJunkThreshold est 4.

Pour supprimer cet avertissement, utilisez la cmdlet Set-OrganizationConfig d'Exchange Management Shell pour définir la valeur du paramètre SCLJunkThreshold sur 4.

Pour définir la valeur du paramètre SCLJunkThreshold sur 4 à l'aide de la cmdlet Set-OrganizationConfig

  1. Le code suivant est un exemple de la commande Set-OrganizationConfig qui définit la valeur du paramètre SCLJunkThreshold sur 4.

  2. Set-OrganizationConfig -SCLJunkThreshold 4


Épuisement de la mémoire du noyau
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-15

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si une erreur Événement 2000, Événement 2019 ou Événement 2020 a été enregistrée pour la source SRV (serveur) ou Serveur NCP au cours des dernières 24 heures.

  • Un ID d'événement 2000 pour la source SRV (serveur) indique qu'un appel du serveur à un service système a échoué de façon inattendue en raison de l'épuisement de la mémoire du noyau du système général.

  • Un ID d'événement 2019 pour la source SRV indique l'épuisement de la mémoire de réserve non paginée du système.

  • Un ID d'événement 2020 pour la source SRV indique l'épuisement de la mémoire de réserve paginée du système.

Si Exchange Analyzer détecte qu'un ou plusieurs de ces événements ont été enregistrés au cours des dernières 24 heures, il affiche une erreur.

Cet avertissement indique que la mémoire du noyau du serveur est épuisée et que le serveur peut rencontrer des problèmes de performances.

La mémoire du noyau de Microsoft Windows consiste en différentes structures de mémoire, notamment la mémoire de réserve paginée ou non et les entrées dans la table des pages système. Ces structures de mémoire, appelées également mémoire du noyau, sont utilisées par le système d'exploitation pour fournir un environnement aux applications telles qu'Exchange.

Pour résoudre ce problème, suivez les instructions des articles sur Exchange Analyzer, relatifs à des problèmes spécifiques, répertoriés ci-après :

  • Amélioration de la mémoire du noyau

  • La réserve paginée dépasse le seuil d'avertissement

  • La réserve non paginée dépasse le seuil d'avertissement

  • La réserve paginée dépasse le seuil d'erreur

En général, pour conserver un déploiement Exchange sain, assurez-vous de contrôler régulièrement la mémoire du noyau du serveur Exchange.

Pour plus d'informations

Pour plus d'informations sur les événements 2000, 2019 et 2020 pour la source SRV, consultez les pages du centre des événements et messages d'erreur :

  • ID d'événement 2000 pour la source SRV http://go.microsoft.com/fwlink/?LinkId=83250

  • ID d'événement 2019 pour la source SRV http://go.microsoft.com/fwlink/?LinkId=83251

  • ID d'événement 2020 pour la source SRV http://go.microsoft.com/fwlink/?LinkId=83252

Pour plus d'informations sur l'optimisation de la mémoire d'Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 912376 sur l'analyse et le dépannage de l'utilisation de la mémoire de réserve paginée dans Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 894067 sur l'outil de performance qui n'affiche pas précisément les PTE système libres disponibles dans Windows Server 2003 http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)

  • 912376 sur l'analyse et le dépannage de l'utilisation de la mémoire de réserve paginée dans Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376)


Épuisement des ressources du noyau : mise à jour du service de cliché instantané de volumes
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft CIM_Datafile pour vérifier que le fichier Vssvc.exe existe.

Exchange Server Analyzer interroge également le Registre pour déterminer si le service de cliché instantané de volumes ou le service de disque virtuel sont exécutés sur Windows Server :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

En outre, Exchange Server Analyzer lit la valeur de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur le serveur Exchange :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si la valeur CurrentVersion est égale à 5.0, le serveur Exchange est exécuté sur Microsoft Windows 2000 Server. Si la valeur CurrentVersion est de 5.2, le serveur Exchange est exécuté sur Microsoft Windows Server™ 2003.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé ServicePackMajorVersion. La valeur de la clé ServicePackMajorVersion indique la version du Service Pack Windows installé sur l'ordinateur.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Exchange Server est installé sur Windows Server 2003 Service Pack 1 (SP1).

  • Le service de cliché instantané ou de disque virtuel est exécuté sur Windows Server 2003 SP1.

  • La mise à jour du service de cliché instantané de volumes n'est pas installée sur cette configuration Exchange Server.

Si vous appliquez la mise à jour du service de cliché instantané de volumes, des problèmes tels que l'épuisement des ressources de noyau seront résolus.

Pour corriger cette erreur

  • Appliquez la mise à jour du service de cliché instantané de volumes qui peut être téléchargée dans l'article 891957 de la Base de connaissances Microsoft sur la disponibilité d'une mise à jour qui résout différents problèmes du service de cliché instantané de volumes dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957).

Pour plus d'informations sur les recommandations pour l'utilisation du service de cliché instantané de volumes avec Exchange Server 2003, voir le document Recommandations pour l'utilisation du service de cliché instantané de volumes avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=56571).


LeakDiag installé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si LeakDiag.exe est installé sur l'ordinateur :

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

Si Exchange Server Analyzer détecte que cette branche de Registre est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

LeakDiag est un ensemble d'outils permettant aux développeurs, aux techniciens du support technique et au personnel informatique de diagnostiquer les pertes de mémoire, la fragmentation et d'autres problèmes de mémoire dans des applications ou services qui s'exécutent sur des ordinateurs Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP et Windows Server™ 2003.

Les outils LeakDiag peuvent être utilisés pour localiser des pertes de mémoire jusqu'à la ligne de code. En utilisant la technologie Detours de Microsoft, LeakDiag intercepte des appels à des allocations de mémoire spécifiées et effectue le suivi des différentes piles d'appels. Il génère un rapport sur la mémoire qui a été allouée mais pas encore libérée. Ces informations vous permettent de résoudre des problèmes de perte de mémoire pour déterminer avec précision les composants qui ont effectué les allocations. Même la ligne de code qui a demandé les allocations peut s'afficher avec des symboles de débogage corrects.

Il est recommandé de ne pas exécuter LeakDiag sur des serveurs Exchange présents dans un environnement de production. Une fois activé, LeakDiag effectue le suivi de toutes les allocations de mémoire pour tous les processus chaque fois que le serveur Exchange démarre. Une quantité importante de processeur et de ressources mémoire est utilisée, ce qui n'est pas recommandé à moins de résoudre activement un problème lié à la mémoire. Si vous ne résolvez pas activement un problème lié à la mémoire, vous devez désactiver LeakDiag. L'utilisation de LeakDiag dans un environnement de production Exchange Server peut conduire à la fragmentation et à l'épuisement de la mémoire et finalement à la défaillance d'Exchange.

Remarque :
Vous devez toujours résoudre les problèmes de LeakDiag pendant les heures creuses. L'utilisation de LeakDiag pendant des périodes d'utilisation excessive ou maximale peut considérablement nuire aux performances de votre ordinateur Exchange Server.

Informations sur ce message

  1. Ce message est fourni à titre indicatif uniquement. Si LeakDiag n'est ni activé ni en cours d'exécution, son installation n'affecte pas les performances d'Exchange Server. LeakDiag requiert environ 4 Mo d'espace disque (journaux exclus).

  2. Pour libérer cet espace disque, vous pouvez supprimer LeakDiag.exe en sélectionnant Panneau de configuration, en cliquant sur Ajout/Suppression de programmes, sur LeakDiag, puis sur Supprimer.

Pour la dernière version de LeakDiag, voir le site FTP public de Microsoft (http://go.microsoft.com/fwlink/?LinkId=41401).


LeakDiag est activé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si LeakDiag.exe est activé sur l'ordinateur :

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

Si Exchange Server Analyzer détecte que la valeur d'EnableAutoStart est définie sur 1, un avertissement s'affiche. EnableAutoStart est configuré à l'aide de l'interface utilisateur LeakDiag. La valeur par défaut est 0. Une valeur de 1 indique que LeakDiag est activé et actif.

LeakDiag est un ensemble d'outils permettant aux développeurs, aux techniciens du support technique et au personnel informatique de diagnostiquer les pertes de mémoire, la fragmentation et d'autres problèmes de mémoire dans des applications ou services qui s'exécutent sur des ordinateurs Microsoft Windows NT® Server 4.0, Windows® 2000 Server, Windows XP et Windows Server™ 2003.

Les outils LeakDiag peuvent être utilisés pour localiser des pertes de mémoire jusqu'à la ligne de code. En utilisant la technologie Detours de Microsoft, LeakDiag intercepte des appels à des allocations de mémoire spécifiées et effectue le suivi des différentes piles d'appels. Il génère un rapport sur la mémoire qui a été allouée mais pas encore libérée. Ces informations permettent à une personne qui résout un problème de perte de mémoire de voir exactement les composants qui ont effectué les allocations. Même la ligne de code qui a demandé les allocations peut s'afficher avec des symboles de débogage corrects.

Il est recommandé de ne pas exécuter LeakDiag sur des serveurs Exchange présents dans un environnement de production. Une fois activé, LeakDiag effectue le suivi de toutes les allocations de mémoire pour tous les processus chaque fois que le serveur Exchange démarre. Une quantité importante de processeur et de ressources mémoire est utilisée, ce qui n'est pas recommandé à moins de résoudre activement un problème lié à la mémoire. Si vous ne résolvez pas activement un problème lié à la mémoire, vous devez désactiver LeakDiag. L'utilisation de LeakDiag dans un environnement de production Exchange Server peut conduire à la fragmentation et à l'épuisement de la mémoire et finalement à la défaillance d'Exchange.

Remarque :
Vous devez toujours résoudre les problèmes de LeakDiag pendant les heures creuses. L'utilisation de LeakDiag pendant des périodes d'utilisation excessive ou maximale peut considérablement nuire aux performances de votre ordinateur Exchange Server.

Pour désactiver le démarrage automatique dans LeakDiag.exe

  1. Cliquez sur Démarrer, puis sur LeakDiag.

  2. Dans le menu Outils, cliquez sur Options.

  3. Dans la page Options, désactivez la case à cocher Autoriser le démarrage automatique, puis cliquez sur OK.

Pour la dernière version de LeakDiag, voir le site FTP public de Microsoft (http://go.microsoft.com/fwlink/?LinkId=41401).


Espace restant pour le journal inférieur à sept jours
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-13

L'outil Microsoft Exchange Server Analyzer Tool estime la durée restante avant que l'espace disque pour le journal des transactions d'un groupe de stockage Exchange Server ne soit saturé. Exchange Server Analyzer estime la durée restant au lecteur du journal pour atteindre sa capacité maximale en vérifiant les horodatages des fichiers journaux des transactions situés sur le lecteur. Lorsqu'Exchange Server Analyzer détecte qu'il reste moins de sept jours avant que le lecteur du journal ne soit saturé, il affiche une erreur.

Le lecteur hébergeant les fichiers journaux pour les bases de données Exchange Server manque d'espace disque.

Si le lecteur du journal manque d'espace disque, les problèmes suivants peuvent se produire :

  • La base de données de démarre pas ou se ferme.

  • La base de données se met en état d'arrêt brutal et devient incohérente.

  • Les utilisateurs ne peuvent plus accéder à leur courrier et/ou aux dossiers publics.

L'espace du lecteur du journal peut être saturé car l'enregistrement circulaire est désactivé. Par conséquent, les fichiers journaux des transactions restent sur le lecteur jusqu'à l'exécution d'une sauvegarde en ligne complète ou incrémentielle qui utilise un logiciel de sauvegarde compatible avec Exchange Server.

Dans les versions d'Exchange Server antérieures à Exchange 2003, il est possible que les bases de données ne puissent pas récupérer d'état de fermeture sain avant d'être arrêtées. Deux fichiers journaux des transactions de réserve, Res1.log et Res2.log, sont convertis en journaux des transactions ordinaires en cas d'urgence au niveau de l'espace disque.

Les améliorations apportées à Exchange Server 2003 permettent la fermeture saine des bases de données jusqu'à ce que les fichiers journaux de réserve soient épuisés. Si une base de données n'a pas été fermée sainement, il est très important que les derniers journaux des transactions associés à la base de données ne soient pas supprimés. Ces journaux des transactions contiennent des informations devant être appliquées à la base de données pour en restaurer la cohérence. Si vous les supprimez, la base de données ne peut pas être relancée avant d'avoir été réparée ou restaurée.

Si toutes les bases de données d'un groupe de stockage se trouvent dans un état de fermeture sain, la suppression de tous les journaux des transactions n'empêchera pas le lancement des bases de données. Toutefois, la suppression des journaux des transactions invaliderait les sauvegardes précédentes. Cette suppression ne signifie pas qu'il sera impossible de restaurer les sauvegardes précédentes. Seulement, vous ne pourrez pas récupérer une base de données restaurée dans l'état qu'elle avait avant la suppression des fichiers journaux.

L'Assistant d'espace pour le journal d'Exchange Server Analyzer analysera les fichiers journaux des transactions existants et vous aidera à déplacer ceux devenus inutiles pour la base de données. L'Assistant d'espace pour le journal garantit également que le fichier journal actuel n'est pas supprimé, même si toutes les bases de données se trouvent dans un état de fermeture sain. Si le fichier journal actuel n'est pas supprimé, les sauvegardes précédentes restent valides.

Pour récupérer de l'espace pour le lecteur du journal, vous devez supprimer les fichiers journaux inutiles. Les actions suivantes sont recommandées.

Pour récupérer de l'espace pour le lecteur du journal si celui-ci est saturé ou approche de sa capacité maximale

  • Effectuez une sauvegarde en ligne de transmission en continu compatible avec Exchange ou une sauvegarde VSS (service de cliché instantané de volumes) de la base de données. Pour plus d'informations sur les sauvegardes VSS, voir les recommandations pour l'utilisation du service de cliché instantané de volumes avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=56571).

    Remarque :
    La méthode recommandée pour la suppression des fichiers journaux inutiles consiste à effectuer une sauvegarde en ligne de transmission en continu ou une sauvegarde VSS.

  • Si la base de données se ferme car elle est sur le point de manquer d'espace pour le lecteur du journal, vous pouvez utiliser l'Assistant de gestion d'espace pour le journal d'Exchange Server Analyzer. Cet Assistant permet de supprimer les fichiers journaux accessoires. Vous pouvez également supprimer manuellement les fichiers journaux accessoires avant de remonter la base de données.

    Pour supprimer les fichiers journaux manuellement, suivez les procédures et recommandations fournies dans l'article 240145 de la Base de connaissances Microsoft sur la procédure de suppression des fichiers journaux des transactions d'Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145).


L'attribut LegacyExchangeDN de ce serveur Exchange ne correspond pas au groupe d'administration parent
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour vérifier la valeur legacyExchangeDN d'un serveur en vérifiant les attributs de l'objet serveur dans le conteneur de serveurs dans Active Directory, en la comparant au nom réel du groupe d'administration et d'organisation dans lequel le serveur réside. Si la valeur legacyExchangeDN du serveur diffère du groupe d'organisation ou d'administration, une erreur s'affiche.

Exchange utilise la valeur legacyExchangeDN pour identifier les objets Exchange dans Active Directory. La valeur legacyExchangeDN est un nom unique qui indique l'emplacement de l'objet dans l'organisation Exchange, par exemple :

/o= organisation /ou= groupe d'administration /ou= serveur

Des objets tels que des banques de boîtes aux lettres et des banques de dossiers publics héritent d'une partie de leurs valeurs legacyExchangeDN du serveur. Cela signifie qu'en cas de problème avec la valeur du serveur, d'autres objets peuvent hériter du même problème.

Les problèmes relatifs à la valeur legacyExchangeDN se produisent généralement lorsqu'un administrateur a tenté de la modifier directement. Vous devez corriger la valeur à l'aide d'un outil, tel qu'ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Correction de cette erreur

  1. Si vous utilisez ADSI Edit ou un outil similaire, recherchez l'objet de groupe d'administration dans Active Directory.

    L'attribut legacyExchangeDN peut se trouver dans :

    CN=Configuration,CN=Services,CN=Microsoft_Exchange,CN=Organisation,CN=Groupes_administration,CN=Groupe_administration,CN=Serveurs,CN=serveur

  2. Entrez une nouvelle valeur de chaîne du formulaire :

    /o= organisation /ou= groupe d'administration /ou= serveur

Pour plus d'informations sur l'utilisation de l'outil LDP, consultez l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, consultez la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server 2003.


La valeur LegacyExchangeDN de ce serveur Exchange n'est pas valide
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour vérifier la valeur legacyExchangeDN du serveur Exchange. Cette erreur est affichée si l'organisation ou le groupe d'administration nommé dans la valeur legacyExchangeDN ne correspond pas au nom réel de l'organisation ou du groupe d'administration, ou si une partie de la valeur est totalement manquante.

Exchange utilise la valeur legacyExchangeDN pour identifier les objets Exchange dans Active Directory. La valeur legacyExchangeDN est un nom unique qui indique l'emplacement de l'objet dans l'organisation Exchange, par exemple :

/o= organisation /ou= groupe d'administration

Des objets tels que des serveurs et des hiérarchies de dossiers héritent d'une partie de leurs valeurs legacyExchangeDN du groupe d'administration. Cela signifie qu'en cas de problème avec la valeur de groupe d'administration, de nombreux autres objets peuvent hériter du même problème.

En général, les problèmes avec le legacyExchangeDN apparaissent lorsqu'un administrateur a tenté de modifier directement la valeur. Vous devez corriger la valeur à l'aide d'un outil, tel qu'ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Correction de cette erreur

  1. Si vous utilisez ADSI Edit ou un outil similaire, recherchez l'objet de groupe d'administration dans Active Directory.

    L'attribut legacyExchangeDN peut se trouver dans :

    CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Organisation, CN=Groupes_administration, CN=Groupe_administration

  2. Entrez une nouvelle valeur de chaîne du formulaire :

    /o= organisation /ou= groupe d'administration

Pour plus d'informations sur l'utilisation de l'outil LDP, consultez l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, consultez la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server 2003.


Le service d'enregistrement de licence est défini sur Automatique
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service d'enregistrement de licence (LicenseService) La valeur False indique que ce service n'est pas en cours d'exécution sur le serveur Exchange. La valeur True indique qu'il est en cours d'exécution.

Exchange Server Analyzer interroge également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique qu'il s'agit d'un serveur frontal.

Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur renvoyée pour cette clé indique la version du système d'exploitation Windows exécutée sur l'ordinateur Exchange Server.

En outre, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détermine que le service d'enregistrement de licence est démarré sur un ordinateur Exchange Server répondant à tous les critères suivants, un avertissement s'affiche :

  • L'ordinateur Exchange Server n'est pas un serveur frontal.

  • L'ordinateur Exchange Server héberge plus de 20 boîtes aux lettres.

  • L'ordinateur Exchange Server ne fonctionne pas sur Microsoft Windows Small Business Server 2003 ou Small Business Server 2000.

Le service d'enregistrement de licence est un outil conçu à l'origine pour aider les clients à gérer les licences des produits serveurs Microsoft sous licence selon le modèle de licence d'accès client (CAL) du serveur.

Par défaut, ce service est désactivé dans Microsoft Windows Server™ 2003. En raison des contraintes en matière de conception d'origine et des termes et conditions de licence en évolution, le service d'enregistrement de licence ne peut pas fournir un aperçu précis du nombre total de licences d'accès client achetées par rapport au nombre total de licences utilisées sur un seul serveur ou dans toute l'entreprise. Les licences d'accès client signalées par le service peuvent entrer en conflit avec l'interprétation du contrat de licence utilisateur final (CLUF) et les droits d'utilisation des logiciels (PUR). Le service ne sera plus inclus dans les futures versions du système d'exploitation Windows.

Microsoft donne des recommandations spécifiques pour l'utilisation du service d'enregistrement de licence sur les ordinateurs Exchange Server :

  • Sur les serveurs frontaux Exchange utilisant SSL (Secure Sockets Layer), vous devez activer et démarrer le service d'enregistrement de licence. Si ce service n'est pas en cours d'exécution, les services IIS (Internet Information Services) limiteront le nombre de connexions SSL authentifiées simultanées à 10.

  • Sur les serveurs principaux Exchange, il est recommandé d'arrêter et de désactiver le service d'enregistrement de licence.

  • Sur les serveurs en clusters Exchange, il est recommandé d'arrêter et de désactiver le service d'enregistrement de licence.

  • Sur les serveurs Exchange fonctionnant sous Microsoft Windows Small Business Server 2003 ou Small Business Server 2000, le service d'enregistrement de licence n'est nécessaire que lorsque plus de 10 connexions SSL authentifiées sont requises.

Pour définir l'état du service d'enregistrement de licence

  1. Démarrez le composant logiciel enfichable Services dans le menu Outils d'administration.

  2. Recherchez et double-cliquez sur le service d'enregistrement de licence.

  3. Dans la liste déroulante Type de démarrage, sélectionnez l'option appropriée :

    • Définissez le service sur Automatique sur les serveurs frontaux Exchange utilisant SSL.

    • Définissez le service sur Désactivé sur les serveurs principaux et en clusters Exchange.

  4. Si vous désactivez le service d'enregistrement de licence, cliquez également sur Arrêter pour arrêter le service.

  5. Cliquez sur OK pour enregistrer les modifications et fermer le composant logiciel enfichable Services.

Pour plus d'informations sur le service d'enregistrement de licence, voir les articles suivants de la Base de connaissances Microsoft :

  • 824196 sur la description du service d'enregistrement de licence dans les systèmes d'exploitation Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=824196)

  • 316631 sur la procédure de désactivation du service d'enregistrement de licence (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316631)


Le nom de fichier du journal ne correspond pas au numéro de génération de journal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool compare la valeur du numéro de génération lGeneration interne contenu dans l'en-tête du fichier journal de transactions au nom de fichier de ce journal de transactions afin de vérifier s'ils correspondent.

Si le numéro de génération interne du fichier journal de transactions ne correspond pas au numéro de génération interne contenu dans le nom de ce fichier, Exchange Server Analyzer affiche une erreur.

À moins qu'un fichier journal soit le journal actuel, le fichier journal disponible le plus récent doit avoir un nom de fichier correspondant à son numéro de génération. Si un fichier journal est le journal actuel, son nom de fichier ne devrait pas contenir son numéro de génération, mais uniquement le préfixe du groupe de stockage. Par exemple, d'anciens journaux de transactions dans une série peuvent être appelés E0154321.LOG, E0154322.LOG, E0154323.LOG, etc., le journal actuel étant E01.LOG.

Vous pouvez utiliser la commande Eseutil /ML LOGFILE pour afficher la valeur lGeneration interne d'un fichier journal.

Pour plus d'informations sur l'enregistrement des transactions Exchange Server, voir la section relative à ce sujet dans la rubrique sur l'utilisation de groupes de stockage de récupération dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Non-correspondance de la signature de la séquence de fichier journal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool compare la Signature d'un fichier journal à la Signature du fichier de journal suivant afin de vérifier s'ils correspondent.

Si ces deux valeurs ne correspondent pas, Exchange Server Analyzer affiche une erreur.

Exchange utilise une série de fichiers journaux, de 5 méga-octets exactement chacun, au lieu d'enregistrer toutes les informations en un seul gros fichier. Lorsqu'un fichier journal est plein, Exchange le ferme et le renomme en lui donnant un numéro d'ordre.

Lorsqu'une nouvelle séquence de fichiers journaux de transactions est initialisée pour un groupe de stockage Exchange, une Signature est enregistrée dans le premier fichier journal ; elle est ensuite copiée dans chaque fichier journal successif de la séquence. La Signature identifie de manière unique un fichier journal particulier comme membre d'une séquence de journaux particulière.

En aucun cas, des fichiers journaux ayant des signatures différentes ne devraient se trouver dans un même dossier. Si cette situation se produit, cela indique que des fichiers journaux étrangers a été copié dans le groupe de stockage ou que les fichiers journaux ont été réinitialisés sans que les anciens fichiers journaux aient été supprimés.

Vous pouvez utiliser la commande Eseutil /ML LOGFILE pour afficher la Signature d'un fichier journal.

Pour plus d'informations sur l'enregistrement des transactions Exchange Server, voir la section relative à ce sujet dans la rubrique sur l'utilisation de groupes de stockage de récupération dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Problème de signature de journal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool compare la signature contenue dans l'en-tête du fichier de transactions Exchange actuel sur un serveur à la signature de journal contenu dans le fichier de base de données du groupe de stockage.

Si la signature du fichier journal de transactions ne correspond à la signature de journal d'aucun des fichiers de base de données, Exchange Server Analyzer affiche une erreur.

Cette erreur indique qu'une des conditions suivantes se vérifie :

  • Le fichier journal de transactions actuel n'existe pas.

  • Le fichier journal de transactions actuel ne correspond à aucune des bases de données comprises dans le groupe de stockage.

Cette situation peut se produire pour l'une des raisons suivantes :

  • Les journaux de transactions du groupe de stockage ont été supprimés manuellement.

  • Une base de données d'un autre groupe de stockage a été restaurée ou copiée dans ce groupe.

  • Des fichiers journaux de transactions provenant d'une autre séquence ou d'un autre groupe de stockage ont été copiés dans ce groupe.

Cette situation peut ou non empêcher le montage d'une base de données, selon que le fichier de base de données est à l'état d'arrêt correct ou d'arrêt brutal.

Remarque :
Une base de données peut être à l'état d'arrêt correct mais rester impossible à monter parce que d'autres bases de données du même groupe de stockage ne sont pas montables. Exchange Server Disaster Recovery Analyzer permet de diagnostiquer et d'obtenir des conseils sur la façon de monter les bases de données dans ces situations.

Lorsqu'une base de données Exchange est arrêtée correctement, toutes les données en attente sont enregistrées dans les fichiers de base de données. Après un arrêt ordinaire, l'ensemble de fichiers de base de données (extensions .edb et .stm) est considéré cohérent. Exchange détache alors l'ensemble de fichiers de base de données de son flux de journaux. Cela signifie que le contenu des fichiers de base de données est maintenant complètement à jour. Les journaux de transactions antérieurs ne sont pas requis pour démarrer les fichiers de base de données.

Les bases de données à l'état d'arrêt correct ont été détachées de leurs fichiers journaux et peuvent être attachées à un autre flux de journaux. Par conséquent, la discordance entre les fichiers journaux et la base de données n'est pas nécessairement un problème.

Les bases de données à l'état d'arrêt brutal ont été incorrectement détachées de leurs fichiers journaux. Ces bases doivent être récupérées avec leurs fichiers journaux attachés. Si les fichiers journaux attachés sont introuvables, la base de données ne peut pas être montée. Vous devez alors restaurer une sauvegarde ou réparer la base de données pour qu'elle soit montable.

Vous pouvez savoir si une base de données a été fermée correctement en entrant la commande Eseutil /mh et en examinant les en-têtes de fichier. Dans Microsoft Exchange 2000 Service Pack 1 et versions ultérieures, une ligne de l'en-tête indique soit « État : arrêt correct », soit « État : arrêt brutal ». Dans les versions antérieures d'Exchange, ce même état est rapporté comme « État : cohérent » ou « État : incohérent ».

Pour plus d'informations sur l'enregistrement des transactions Exchange Server, voir la section relative à ce sujet dans la rubrique sur l'utilisation de groupes de stockage de récupération dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Nombre d'octets d'enregistrement journal/s supérieur au seuil d'erreur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-23

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si le temps d'exécution des opérations MAPI de l'utilisateur est celui raisonnablement prévisible pour un serveur Exchange sain.

Dans le cadre de cette analyse, l'outil Exchange Server Analyzer examine l'utilisation du fichier journal de transactions pour déterminer si des opérations MAPI d'un utilisateur entraînent l'écriture de données de plus de 5 Mo par minute dans les journaux de transactions d'Exchange.

Une croissance excessive du fichier journal de transactions due à des opérations MAPI peut entraîner des goulots d'étranglement des ressources du serveur et des erreurs telles qu'un dépassement de la profondeur de point de contrôle, des goulots d'étranglement d'E/S sur disque et un manque d'espace disque.

Si Exchange Server Analyzer détermine qu'une ou plusieurs opérations MAPI de l'utilisateur entraînent l'écriture de plus de 5 Mo de données par minute dans les fichiers journaux de transactions d'Exchange, Exchange Server Analyzer affiche un message d'erreur.

L'écriture par les opérations MAPI de plus de 5 Mo de données par minute dans les fichiers journaux de transactions d'Exchange ne constitue pas toujours un problème. Une fréquence d'écriture élevée est prévue pour certaines actions, telles que des déplacements de boîtes aux lettres ou d'autres opérations en bloc sur un grand nombre de messages, qui génèrent des volumes importants de données de journal de transactions. Dans ce cas, des fréquences d'écriture élevées ne doivent pas être maintenues plus de quelques minutes.

Si le serveur est confronté à d'autres problèmes, tels qu'une latence RPC élevée, coopérez avec l'utilisateur générant les données de journal de transactions afin de déterminer quelle activité de l'utilisateur est à l'origine de la fréquence élevée d'écriture d'enregistrements de journal.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Résolution des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Performances d'Exchange Server 2003 : 10 choses à savoir (http://go.microsoft.com/fwlink/?LinkID=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Objet d'analyseur de performances LogicalDisk non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Avg. Disk sec/Read de l'objet de performance LogicalDisk pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance LogicalDisk est désactivé. Par défaut, dans Microsoft Windows Server™ 2003, l'objet de performance LogicalDisk est activé. Toutefois, dans Microsoft Windows® 2000 Server, LogicalDisk n'est pas activé par défaut.

  • L'objet d'analyseur de performances LogicalDisk est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows Management Instrumentation) Microsoft modifient le Registre.

La procédure suivante explique comment corriger les deux premières conditions. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance LogicalDisk est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe (Extensible Performance Counter List) à l'adresse http://go.microsoft.com/fwlink/?LinkId=34436.

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller le système d'exploitation Windows en mode Réparer et appliquer ensuite les derniers Service Packs de Windows.


Opérations MAPI à latence élevée détectées
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-11-22

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour collecter des données, en cinq minutes, afin de déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Si Exchange Server Analyzer détermine que, durant la période pendant laquelle les données ont été collectées, une ou plusieurs opérations MAPI d'un utilisateur ont duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur et effectue une analyse supplémentaire des actions des utilisateurs ayant déclenché l'erreur.

Les opérations MAPI qui durent plus de 30 secondes ne constituent pas nécessairement un problème. La sauvegarde de volumes importants de données de messagerie ou de pièces jointes peut entraîner un allongement du temps de traitement des opérations MAPI.

Si les utilisateurs sont confrontés à des retards fréquents ou à des retards qui affectent leur expérience de la messagerie, il convient d'étudier ces retards des opérations MAPI pour s'assurer qu'ils ne sont pas symptomatiques de problèmes de latence plus inquiétants, tels que des goulots d'étranglement des ressources ou des dépendances imbriquées.

Pour corriger cette erreur :

  • Songez à utiliser l'outil ExMon pour capturer un échantillon de données de plus grande taille à soumettre à Exchange Server Analyzer. En raison du volume important des données générées par ExMon, il est recommandé de limiter la collecte de données à 30 minutes.

  • Passez en revue les erreurs de latence et les articles associés décrivant l'opération particulière et les actions permettant de les résoudre. À défaut d'erreurs de latence signalées par l'outil d'analyse d'Exchange Server, une analyse supplémentaire des actions de l'utilisateur n'a révélé aucun problème.


Opération en bloc MAPI longue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-23

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Dans le cadre de son analyse, Exchange Server Analyzer examine les données ExMon pour les opérations en bloc MAPI lancées par l'utilisateur dont l'exécution a pris plus de 30 secondes.

Les opérations en bloc MAPI sont des opérations qui agissent sur plusieurs objets et sont généralement coûteuses (nécessitant un grand nombre d'E/S).

Si Exchange Server Analyzer détermine qu'une ou plusieurs des opérations en bloc MAPI d'un utilisateur ont duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur.

Les opérations en bloc MAPI qui durent plus de 30 secondes ne constituent pas nécessairement un problème. Si l'utilisateur agit (copie, supprime, définit des indicateurs d'attribut, etc.) sur au moins un millier de messages à la fois, les opérations en bloc MAPI risquent de prendre un temps supérieur à la normale.

Si les utilisateurs sont confrontés à des retards fréquents ou à des retards qui affectent leur expérience de la messagerie, il convient d'étudier ces retards des opérations en bloc MAPI pour s'assurer qu'ils ne sont pas symptomatiques de problèmes de latence plus inquiétants, tels que des goulots d'étranglement des ressources ou des dépendances imbriquées.

Pour corriger cette erreur :

  • Songez à utiliser l'outil ExMon pour capturer un échantillon de données de plus grande taille à soumettre à Exchange Server Analyzer. En raison du volume important des données générées par Exchange, il est recommandé de limiter la collecte de données à 30 minutes.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Résolution des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • « Performances d'Exchange Server 2003 : 10 choses à savoir » (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Opération MAPI « FindRow » longue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-11-22

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Dans le cadre de son analyse, Exchange Server Analyzer examine les données ExMon pour des opérations MAPI FindRow lancées par l'utilisateur, dont l'exécution a pris plus de 30 secondes.

L'augmentation du nombre de vues pour chaque dossier peut allonger le temps de traitement de nombreuses opérations MAPI. Les applications clientes utilisent les opérations MAPI SeekRow ou FindRow pour déplacer le pointeur entre les lignes d'une vue. L'opération SeekRow spécifie le nombre de lignes sur lesquelles déplacer le pointeur et est très peu coûteuse en termes de temps processeur. L'opération FindRow est très coûteuse car elle déplace le pointeur vers le premier élément d'une vue non matérialisée (non mise en cache) qui correspond aux critères de restriction, puis ignore la vue une fois que l'application cliente a terminé l'action. Le coût processeur final de l'opération FindRow dépend de la complexité de la restriction et du nombre de lignes que la banque d'informations doit passer en revue avant de trouver le premier élément qui correspond aux critères et est vaguement en corrélation avec le nombre d'éléments dans le dossier.

Les coûts élevés que peut générer une opération FindRow en font une bonne candidate pour une exécution en mode mis en cache qui déchargerait le serveur de ce coût. Sachez que, parfois, le pourcentage de processeur élevé consommé par ces opérations peut simplement être provoqué par des calendriers partagés, auquel cas le mode mis en cache n'aiderait pas. Une consommation élevée du pourcentage de temps processeur par les opérations FindRow peut indiquer un grand nombre de créations de vues, de vues chères ou d'éléments de dossiers volumineux.

Si Exchange Server Analyzer détermine qu'une opération MAPI FindRow lancée par un utilisateur a duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur.

Les opérations MAPI FindRow qui durent plus de 30 secondes ne constituent pas nécessairement un problème. Si le ou les utilisateurs identifiés sont confrontés à des retards fréquents ou qui affectent l'utilisation de la messagerie, vous devez comprendre pourquoi. Coopérez avec l'utilisateur confronté à la latence élevée afin de déterminer :

  • si le nombre d'éléments dans les dossiers est important ;

  • les applications que l'utilisateur exécute.

Pour résoudre ce problème :

  • Encouragez les utilisateurs ayant de nombreux éléments dans leurs dossiers à réduire le nombre d'éléments par dossier. Il est recommandé de conserver moins de 5000 éléments dans les dossiers Boîte de réception, Calendrier, Éléments envoyés, Contacts et Éléments supprimés.

  • Configurez les ordinateurs clients dont les coûts de fonctionnement sont les plus élevés (en particulier ceux qui présentent de longues latences sur les opérations Restrict, SetColumns ou FindRow) pour qu'ils utilisent le mode Exchange mis en cache. Celui-ci isole le serveur de la majeure partie du trafic RPC excédentaire.

  • Essayez de désactiver toutes les applications, puis de les réactiver une à une afin d'identifier celle qui pourrait être la cause du problème. Si ces applications ne sont pas obligatoires pour vos activités ou si un correctif a été publié pour elles, désactivez-les définitivement ou mettez-les à jour pour réduire la charge à un niveau approprié.

Remarque :
Certaines applications peuvent considérablement accroître la charge du serveur sans effectuer un grand nombre d'opérations MAPI. En effet, les frais de certaines opérations sont plus élevés que pour d'autres. Une toute petite augmentation du nombre d'opérations coûteuses risque d'affecter sensiblement les performances du serveur. Dans ExMon, ces utilisateurs sont signalés comme ayant une influence élevée sur le processeur, sans nécessairement effectuer un grand nombre d'opérations MAPI.

Notez également que, dès qu'il existe un goulot d'étranglement des ressources (généralement au niveau du disque ou du processeur), les latences des opérations FindRow augmentent.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Performances d'Exchange Server 2003 : 10 choses à savoir (http://go.microsoft.com/fwlink/?LinkID=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Opération MAPI en ligne longue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-23

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI en ligne de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Un exemple d'opération MAPI en ligne est l'opération QueryRows.

L'opération QueryRows est utilisée pour renvoyer les lignes de l'affichage actuel. QueryRows utilise les données de la table pour répondre à la demande de l'utilisateur. L'opération SetColumns détermine les données disponibles pour QueryRows. Le coût de QueryRows augmente avec la taille des propriétés demandées, le nombre de propriétés demandées et le nombre de lignes de données demandées. QueryRows peut également être coûteux si un grand nombre de colonnes et de lignes sont requises.

Comme le nombre d'éléments dans les dossiers principaux d'Exchange Server 2003 augmente, le coût du disque physique pour effectuer certaines opérations augmente également pour les utilisateurs d'Outlook. Le premier tri de la Boîte de réception par taille est une opération très coûteuse (qui requiert un grand nombre d'E/S sur le disque). À l'avenir, les tris de votre Boîte de réception par taille sera très abordable.

Si Exchange Server Analyzer détermine que, durant la période pendant laquelle les données ont été collectées, une ou plusieurs des opérations MAPI en ligne d'un utilisateur ont duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur.

Une latence longue des opérations MAPI en ligne peut indiquer un goulot d'étranglement des ressources du serveur. Pour l'opération QueryRows, cela peut également indiquer un nombre d'éléments élevé dans un dossier ou le fait que de nombreuses propriétés sont définies sur les tables internes.

Si l'opération en ligne à latence élevée opère sur un grand nombre de données en même temps, il se peut que la latence élevée n'indique pas un problème lié aux performances du serveur. Un exemple de cela est quand un utilisateur sélectionne tous les éléments d'un dossier et les marque comme lus en une seule opération. Coopérez avec l'utilisateur confronté à la latence élevée afin de déterminer :

  • si le nombre d'éléments dans les dossiers est important ;

  • les applications que l'utilisateur exécute.

Pour résoudre ce problème :

  • Encouragez les utilisateurs ayant de nombreux éléments dans leurs dossiers à réduire le nombre d'éléments par dossier. Il est recommandé de conserver moins de 5000 éléments dans les dossiers Boîte de réception, Calendrier, Éléments envoyés, Contacts et Éléments supprimés.

  • Essayez de désactiver toutes les applications, puis de les réactiver une à une afin d'identifier celle qui pourrait être la cause du problème. Si ces applications ne sont pas obligatoires pour vos activités ou si un correctif a été publié pour elles, désactivez-les définitivement ou mettez-les à jour pour réduire la charge à un niveau approprié.

Remarque :
Certaines applications peuvent considérablement accroître la charge du serveur sans effectuer un grand nombre d'opérations MAPI en ligne. En effet, les frais de certaines opérations sont plus élevés que pour d'autres. Une toute petite augmentation du nombre d'opérations coûteuses risque d'affecter sensiblement les performances du serveur. Dans ExMon, ces utilisateurs sont signalés comme ayant une influence relativement élevée sur le processeur, sans nécessairement effectuer un grand nombre d'opérations MAPI.

Notez également que, dès qu'il existe un goulot d'étranglement des ressources (généralement au niveau du disque ou du processeur), les latences des opérations MAPI en ligne augmentent. Identifiez les goulots d'étranglement des ressources du serveur, puis augmentez la capacité de ressources du serveur ou déplacez des utilisateurs vers un serveur moins chargé.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Résolution des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Performances d'Exchange Server 2003 : 10 choses à savoir (http://go.microsoft.com/fwlink/?LinkID=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Opération MAPI longue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-11-22

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Si Exchange Server Analyzer détermine qu'une ou plusieurs des opérations MAPI d'un utilisateur ont duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur.

L'augmentation du nombre de vues pour chaque dossier peut allonger le temps de traitement de nombreuses opérations MAPI. Les deux opérations les plus courantes, SeekRow et FindRow, sont décrites dans cette rubrique. D'autres opérations MAPI identifiées par Exchange Server Analyzer comme « longues » peuvent généralement être résolues par les même actions que les opérations MAPI SeekRow et FindRow.

Les applications clientes utilisent les opérations MAPI SeekRow ou FindRow pour déplacer le pointeur entre les lignes d'une vue. L'opération SeekRow spécifie le nombre de lignes sur lesquelles déplacer le pointeur et est très peu coûteuse en termes de temps processeur. L'opération FindRow est très coûteuse car elle déplace le pointeur vers le premier élément d'une vue non matérialisée (non mise en cache) qui correspond aux critères de restriction, puis ignore la vue une fois que l'application cliente a terminé l'action. Le coût processeur final de l'opération FindRow dépend de la complexité de la restriction, du nombre de propriétés de message faisant l'objet d'un accès pour chaque message et du nombre de lignes que la banque d'informations doit passer en revue pour trouver le premier élément correspondant aux critères ; il est donc étroitement lié au nombre d'éléments figurant dans le dossier.

Les opérations MAPI qui durent plus de 30 secondes ne constituent pas nécessairement un problème. Si le ou les utilisateurs identifiés sont confrontés à des retards fréquents ou qui affectent l'utilisation de la messagerie, vous devez comprendre pourquoi. Coopérez avec l'utilisateur confronté à la latence élevée afin de déterminer :

  • si le nombre d'éléments dans les dossiers est important ;

  • les applications que l'utilisateur exécute.

Pour résoudre ce problème :

  • Encouragez les utilisateurs ayant de nombreux éléments dans leurs dossiers à réduire le nombre d'éléments par dossier. Il est recommandé de conserver moins de 5000 éléments dans les dossiers Boîte de réception, Calendrier, Éléments envoyés, Contacts et Éléments supprimés.

  • Configurez les ordinateurs clients dont les coûts de fonctionnement sont les plus élevés (en particulier ceux qui présentent de longues latences sur les opérations Restrict, SetColumns ou FindRow) pour qu'ils utilisent le mode Exchange mis en cache. Celui-ci isole le serveur de la majeure partie du trafic RPC excédentaire.

  • Essayez de désactiver toutes les applications, puis de les réactiver une à une afin d'identifier celle qui pourrait être la cause du problème. Si ces applications ne sont pas obligatoires pour vos activités ou si un correctif a été publié pour elles, désactivez-les définitivement ou mettez-les à jour pour réduire la charge à un niveau approprié.

Remarque :
Certaines applications peuvent considérablement accroître la charge du serveur sans effectuer un grand nombre d'opérations MAPI. En effet, les frais de certaines opérations sont plus élevés que pour d'autres. Une toute petite augmentation du nombre d'opérations coûteuses risque d'affecter sensiblement les performances du serveur. Dans ExMon, ces utilisateurs sont signalés comme ayant une influence élevée sur le processeur, sans nécessairement effectuer un grand nombre d'opérations MAPI.

Notez également que, dès qu'il existe un goulot d'étranglement des ressources (généralement au niveau du disque ou du processeur), les latences des opérations MAPI augmentent. Identifiez les goulots d'étranglement des ressources du serveur, puis augmentez la capacité de ressources du serveur ou déplacez des utilisateurs vers un serveur moins chargé.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Performances d'Exchange Server 2003 : 10 choses à savoir (http://go.microsoft.com/fwlink/?LinkID=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Opération MAPI « SaveChangesMessage » longue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-11-22

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Dans le cadre de son analyse, Exchange Server Analyzer examine les données ExMon pour des opérations MAPI SaveChangesMessage lancées par l'utilisateur, dont l'exécution a pris plus de 30 secondes.

L'opération MAPI SaveChangesMessage est appelée quand une application enregistre le contenu et/ou les propriétés d'un message sur le serveur. Le temps requis pour exécuter l'opération dépend des données écrites, de la vitesse de la base de données et des disques de journal de transactions sur lesquels l'écriture a lieu, ainsi que de la présence éventuelle d'un goulot d'étranglement de ressources.

Si Exchange Server Analyzer détermine qu'une opération MAPI SaveChangesMessage lancée par un utilisateur a duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur.

Les opérations MAPI SaveChangesMessage qui durent plus de 30 secondes ne constituent pas nécessairement un problème. La sauvegarde de volumes importants de données de messagerie ou de pièces jointes peut entraîner un allongement du temps de traitement de l'opération MAPI SaveChangesMessage. Si le ou les utilisateurs identifiés sont confrontés à des retards fréquents ou qui affectent l'utilisation de la messagerie, la cause la plus probable est la présence d'un goulot d'étranglement au niveau du disque.

Pour plus d'informations

  • Pour plus d'informations sur les goulots d'étranglement de disque, consultez la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur les performances d'Exchange Server, consultez le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, consultez la rubrique sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les meilleures pratiques de conception d'architectures de stockage, consultez la rubrique sur les meilleures pratiques communes à diverses architectures (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Pour plus d'informations sur la procédure de déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, consultez la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

  • Pour plus d'informations sur les vitesses d'E/S, la latence et le dimensionnement de disques, consultez les billets suivants sur le site Web du blog de l'équipe Microsoft Exchange :

    • « A few basic concepts in disk sizing » (Quelques concepts de base du dimensionnement de disques) (http://go.microsoft.com/fwlink/?linkid=39538)

    • Billet sur des réflexions concernant les calculs et E/S disque (en anglais) (http://go.microsoft.com/fwlink/?linkid=39539)

    • Rubrique sur la procédure de calcul des besoins en E/S disque(http://go.microsoft.com/fwlink/?linkid=69747)


Opération MAPI « SetColumns » longue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-23

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que raisonnablement prévu sur un serveur sain exécutant Exchange Server.

Dans le cadre de son analyse, Exchange Server Analyzer examine les données ExMon pour des opérations MAPI SetColumns lancées par l'utilisateur, dont l'exécution a pris plus de 30 secondes.

Une vue de base est créée à l'aide de l'appel MAPI à SetColumns. L'appel à SetColumns définit les propriétés qui constitueront les colonnes du nouveau tableau d'affichage.

La première fois qu'une propriété est demandée dans un affichage, le serveur doit effectuer un travail supplémentaire pour générer l'affichage. Une fois que cette propriété a été demandée dans un affichage, elle est présente dans tous les affichages ultérieurs. Cela signifie que la première fois que de nouvelles propriétés sont demandées, l'appel à SetColumns peut prendre plus de temps. Le temps requis est proportionnel au nombre de nouvelles propriétés et au nombre d'éléments dans le dossier. Par exemple, la première fois qu'un utilisateur affiche sa boîte de réception après un déplacement de boîte aux lettres, le serveur met plus de temps pour générer l'affichage. Cela est dû au fait que les affichages ne sont pas déplacés avec la boîte aux lettres. Les affichages sont donc recréés.

Il est généralement très coûteux d'ajouter des propriétés à l'affichage. Le coût de l'ajout de propriétés est proportionnel au nombre d'éléments dans le dossier et au nombre de propriétés ajoutées. Une utilisation classique de Microsoft Office® Outlook® n'entraîne pas l'ajout d'un grand nombre de propriétés à la table de dossiers de messages, mais il est possible d'en ajouter manuellement. Cela ne pose généralement pas de problème. Toutefois, il risque d'y avoir des retards si une application ajoute régulièrement des colonnes, ajoute de nombreuses colonnes ou si un client ajoute plusieurs colonnes sur de nombreux éléments. Plus la table de dossiers de messages contient de colonnes, plus le traitement est important pour l'exécution de toutes les autres actions sur les éléments de ce dossier. Après qu'une colonne a été ajoutée, il n'est plus possible de la supprimer. Chaque propriété de la table de dossiers des messages augmente le traitement nécessaire pour l'insertion d'éléments dans ce dossier.

Si Exchange Server Analyzer détermine qu'une opération MAPI SetColumns lancée par un utilisateur a duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur.

La première fois qu'un utilisateur accède à sa boîte aux lettres après le déplacement de celle-ci vers une nouvelle base de données ou un nouveau serveur, le serveur doit créer des éléments. Dans ce cas, il faut s'attendre à ce que les appels SetColumns et Restrict soient longs. Vous pouvez spécifier d'ignorer ces erreurs pendant quelques jours après le déplacement d'une boîte aux lettres.

Certaines applications créent des affichages et entraînent la promotion de propriétés vers des structure de données de la banque d'informations interne. Cela peut affecter durablement les performances du serveur lorsqu'il accède aux données de cet utilisateur. Si le ou les utilisateurs identifiés sont confrontés à des retards fréquents ou qui affectent l'utilisation de la messagerie, vous devez comprendre pourquoi. Coopérez avec l'utilisateur confronté à la latence élevée afin de déterminer :

  • si le nombre d'éléments dans les dossiers est important ;

  • les applications que l'utilisateur exécute.

Pour résoudre ce problème, procédez comme suit :

  • Encouragez les utilisateurs ayant de nombreux éléments dans leurs dossiers à réduire le nombre d'éléments par dossier. Il est recommandé de conserver moins de 5000 éléments dans les dossiers Boîte de réception, Calendrier, Éléments envoyés, Contacts et Éléments supprimés.

  • Configurez les ordinateurs clients dont les opérations sont les plus coûteuses afin qu'ils utilisent le mode Exchange mis en cache. Soyez particulièrement attentif aux ordinateurs clients qui présentent des latences élevés sur les opérations Restrict, SetColumns ou FindRow. Celui-ci isole le serveur de la majeure partie du trafic RPC excédentaire.

  • Tentez de désactiver toutes les applications. Ensuite, activez-les une par une afin d'identifier celle qui pourrait être à l'origine du problème. Désactivez définitivement toute application problématique ou mettez-la à jour pour réduire la charge à un niveau approprié si l'une des conditions suivantes est vraie :

    • L'application n'est pas requise pour l'activité.

    • L'application a une mise à jour publiée.

Remarque :
Certaines applications peuvent considérablement accroître la charge du serveur sans effectuer un grand nombre d'opérations MAPI. Cela est dû au fait que certaines opérations sont plus coûteuses que pour d'autres. Une toute petite augmentation du nombre d'opérations coûteuses risque d'affecter sensiblement les performances du serveur. Dans ExMon, ces utilisateurs sont signalés comme ayant une influence élevée sur le processeur, sans nécessairement effectuer un grand nombre d'opérations MAPI.

Notez également que, dès qu'il existe un goulot d'étranglement des ressources (généralement au niveau du disque ou du processeur), les latences des opérations SetColumns augmentent.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • « Guide des performances et de l'évolutivité d'Exchange Server 2003 » (http://go.microsoft.com/fwlink/?LinkId=47576)

  • « Résolution des problèmes de performances de Microsoft Exchange Server » (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Performances d'Exchange Server 2003 : 10 choses à savoir (http://go.microsoft.com/fwlink/?LinkID=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Opération de synchronisation MAPI longue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-23

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Dans le cadre de son analyse, Exchange Server Analyzer examine les données ExMon pour les opérations de synchronisation MAPI lancées par l'utilisateur dont l'exécution a pris plus de 30 secondes.

Des opérations de synchronisation MAPI sont exécutées pour maintenir la synchronisation entre le fichier de dossiers en mode hors connexion de Microsoft Office® Outlook® (.ost) ou la copie locale de la boîte aux lettres de l'utilisateur et les données de boîte aux lettres de l'utilisateur sur le serveur.

Les opérations de synchronisation MAPI qui durent plus de 30 secondes ne constituent pas nécessairement un problème. Par défaut, tous les messages électroniques stockés sur le serveur Exchange et qui sont des copies complètes de la liste d'adresses globale sont téléchargés sur l'ordinateur de l'utilisateur lors de la première activation du mode Exchange mis en cache dans Outlook 2003.

Lors d'une synchronisation initiale avec Exchange Server, les utilisateurs d'Outlook 2003 peuvent être confrontés à des retards de réponse.

Si les utilisateurs sont confrontés à des retards fréquents ou à des retards qui affectent leur expérience de la messagerie, suite à l'initiation de la synchronisation en mode mis en cache, il convient d'étudier de plus près ces retards des opérations de synchronisation MAPI pour s'assurer qu'ils ne sont pas symptomatiques de problèmes de latence plus inquiétants, tels que des goulots d'étranglement des ressources.

Dès qu'il existe un goulot d'étranglement des ressources (généralement au niveau du disque ou du processeur), les latences des opérations de synchronisation MAPI augmentent. Identifiez les goulots d'étranglement des ressources du serveur, puis augmentez la capacité de ressources du serveur ou déplacez des utilisateurs vers un serveur moins chargé.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Résolution des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • « Performances d'Exchange Server 2003 : 10 choses à savoir » (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Opération MAPI « TaskQ » de longue durée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-20

L'outil Microsoft Exchange Analyzer utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que prévu sur un serveur Exchange sain.

Dans le cadre de son analyse, Exchange Analyzer examine les données ExMon pour les opérations MAPI TaskQ lancées par l'utilisateur dont l'exécution a pris plus de 30 secondes.

Les opérations TaskQ sont des tâches asynchrones exécutées en dehors du contexte d'un appel RPC. Les opérations TaskQ et TaskQ Utilisateur inconnu sont des tâches exécutées à la demande d'Exchange et incluent la maintenance de la banque. Les opérations TaskQ Utilisateur connu sont des tâches asynchrones lancées par une demande d'utilisateur directe et incluent le renseignement, le tri et les opérations en bloc sur les dossiers de recherche, telles que le déplacement, la copie, la suppression et le marquage de messages comme lus sur plusieurs messages.

Si Exchange Analyzer détecte des opérations MAPI TaskQ lancées par l'utilisateur dont l'exécution a pris plus de 30 secondes, il affiche un avertissement.

Cela n'indique pas toujours un problème au niveau des performances dans la mesure où les opérations TaskQ sont généralement de longue durée.

Pour résoudre ce problème, procédez comme suit :

  • Songez à utiliser l'outil ExMon pour capturer un échantillon de données de plus grande taille à soumettre à Exchange Server Analyzer. En raison du volume important des données générées par Exchange, il est recommandé de limiter la collecte de données à 30 minutes.

Pour plus d'informations

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Résolution des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Performances d'Exchange Server 2003 : 10 choses à savoir (http://go.microsoft.com/fwlink/?LinkID=56460).


Opération longue en raison d'une opération « Restrict » MAPI
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-23

L'outil Microsoft® Exchange Server Analyzer Tool utilise l'outil Exchange Server User Monitor (ExMon) pour déterminer si les opérations MAPI de l'utilisateur prennent plus de temps que raisonnablement prévu sur un serveur sain exécutant Exchange Server.

Dans le cadre de son analyse, Exchange Server Analyzer examine les données ExMon pour des opérations MAPI Restrict lancées par l'utilisateur, dont l'exécution a pris plus de 30 secondes.

L'opération MAPI Restrict permet à des applications clientes de sélectionner des éléments correspondant à des critères particuliers. Le serveur crée une vue qui est effectivement une table avec des critères associés appelés restrictions. Si la vue qui a une restriction correspondante existe déjà, le serveur utilise la vue existante pour répondre à la demande de l'utilisateur. Lorsque le serveur utilise cette vue, l'opération est moins coûteuse que lorsqu'il en crée une nouvelle. Par défaut, la banque d'informations ne met en cache que 11 vues pour chaque dossier. S'il est demandé au serveur de créer une douzième vue, celui-ci supprime la vue mise en cache la plus ancienne et crée une vue. Les vues ajoutent du temps de traitement à toutes les actions effectuées sur des éléments.

Si Exchange Server Analyzer détermine qu'une opération MAPI Restrict lancée par un utilisateur a duré plus de 30 secondes, Exchange Server Analyzer affiche un message d'erreur.

Les opérations MAPI Restrict qui durent plus de 30 secondes ne constituent pas nécessairement un problème. Toutefois, si le ou les utilisateurs sont confrontés à des retards fréquents ou qui affectent négativement leur utilisation de la messagerie, ces retards peuvent indiquer qu'une application utilisateur entraîne la création de vues.

Pour résoudre cette erreur, coopérez avec l'utilisateur confronté à la latence élevée pour déterminer ce qui suit :

  • si le nombre d'éléments dans les dossiers est important ;

  • les applications que l'utilisateur exécute.

Pour résoudre ce problème, procédez comme suit :

  • Encouragez les utilisateurs ayant de nombreux éléments dans leurs dossiers à réduire le nombre d'éléments par dossier. Il est recommandé de conserver moins de 5000 éléments dans les dossiers Boîte de réception, Calendrier, Éléments envoyés, Contacts et Éléments supprimés.

  • Configurez les ordinateurs clients dont les opérations sont les plus coûteuses afin qu'ils utilisent le mode Exchange mis en cache. Soyez particulièrement attentif aux ordinateurs clients qui présentent des latences élevés sur les opérations Restrict, SetColumns ou FindRow. Celui-ci isole le serveur de la majeure partie du trafic RPC excédentaire.

  • Suivez les instructions du blog de l'équipe Exchange référencé dans la section suivante pour activer le suivi de la restriction du journal des événements. Activez ensuite les applications utilisateur une par une pour déterminer quelle application peut être à l'origine de la restriction la plus longue.

  • Tentez de désactiver toutes les applications. Ensuite, activez-les une par une afin d'identifier celle qui pourrait être à l'origine du problème. Désactivez définitivement toute application problématique ou mettez-la à jour pour réduire la charge à un niveau approprié si l'une des conditions suivantes est vraie :

    • L'application n'est pas requise pour l'activité.

    • L'application a une mise à jour publiée.

Remarque :
Certaines applications peuvent considérablement accroître la charge du serveur sans effectuer un grand nombre d'opérations MAPI. Cela est dû au fait que certaines opérations sont plus coûteuses que pour d'autres. Une toute petite augmentation du nombre d'opérations coûteuses risque d'affecter sensiblement les performances du serveur. Dans ExMon, ces utilisateurs sont signalés comme ayant une influence élevée sur le processeur, sans nécessairement effectuer un grand nombre d'opérations MAPI.

Notez également que, dès qu'il existe un goulot d'étranglement des ressources (généralement au niveau du disque ou du processeur), les latences des opérations Restrict augmentent.

Pour plus d'informations

Pour plus d'informations sur l'opération MAPI Restrict, consultez le blog de l'équipe Microsoft Exchange sur l'application de restrictions à des restrictions (http://go.microsoft.com/fwlink/?linkid=55098).

Remarque :
Le contenu et l'URL de chaque blog sont susceptibles d'être modifiés sans préavis.

Pour plus d'informations, consultez les ressources Exchange Server suivantes :

  • « Guide des performances et de l'évolutivité d'Exchange Server 2003 » (http://go.microsoft.com/fwlink/?LinkId=47576)

  • « Résolution des problèmes de performances de Microsoft Exchange Server » (http://go.microsoft.com/fwlink/?LinkId=47588)

  • « Performances d'Exchange Server 2003 : 10 choses à savoir » (http://go.microsoft.com/fwlink/?LinkId=56460)

  • Article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803)


Le fichier MAD.EXE est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le port NSPI MAD est inférieur à 5000
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre TCP/IP NSPI Port pour le service Surveillance du système Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Si Exchange Server Analyzer détecte que la valeur de TCP/IP NSPI Port est définie sur une valeur inférieure à 5000 (décimal), un avertissement s'affiche.

Si vous devez définir TCP/IP NSPI Port sur une valeur statique, il est recommandé de le définir sur une valeur à peine supérieure à 5000. L'affectation de numéros de port statiques inférieurs à 5000 risque de provoquer un conflit de port avec un autre processus et un échec du processus du service Surveillance du système Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour définir la clé de Registre TCP/IP NSPI Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé TCP/IP NSPI Port et définissez le champ Données de la valeur sur un entier à peine supérieur à 5000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service Surveillance du système Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les limitations des ports, voir l'article 194952 de la Base de connaissances sur les limitations des ports mappés de manière statique pour Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


Le port RFR MAD a été remplacé manuellement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur du port de redirection d'annuaire du service Surveillance du système Microsoft Exchange a été remplacée manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Si Exchange Server Analyzer détecte que TCP/IP Port est présent et configuré, un message indiquant une configuration autre que celle par défaut s'affiche.

Cette valeur est généralement configurée pour permettre aux clients MAPI de se connecter à un serveur Exchange situé de l'autre côté d'un pare-feu. Ce scénario implique l'ouverture de plusieurs ports sur un pare-feu pour permettre aux clients Microsoft Office Outlook® 2003 de se connecter via l'interface MAPI à un serveur Exchange, généralement sur Internet. Cette configuration est prise en charge. Pour plus d'informations sur la configuration de clients MAPI pour qu'ils se connectent à Exchange via un pare-feu, voir l'article 270836 de la Base de connaissances Microsoft sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836). Si vous n'utilisez pas ce scénario, vous devez supprimer la clé de Registre.

Le déploiement recommandé pour l'utilisation d'Outlook en mode MAPI pour se connecter à un serveur Exchange via Internet consiste à utiliser les fonctionnalités d'appel de procédure distante (RPC) sur HTTP (Hypertext Transfer Protocol) disponibles dans Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 et Windows® XP Professionnel. Le mode MAPI était auparavant appelé mode « société » ou « groupe de travail ».

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer la valeur de Registre TCP/IP Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Supprimez la valeur de Registre nommée TCP/IP Port.

  4. Fermez l'Éditeur du Registre et redémarrez le service Surveillance du système Microsoft Exchange.

Pour déployer RPC sur HTTPS

  1. Voir le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Voir l'article 833401 de la Base de connaissances sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Voir l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Voir la Webdiffusion du Support Technique de Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le port RFR MAD est inférieur à 5000
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre TCP/IP Port pour le service Surveillance du système Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Si Exchange Server Analyzer détecte que la valeur de TCP/IP Port est définie sur une valeur inférieure à 5000 (décimal), un avertissement s'affiche.

Si vous devez définir TCP/IP Port sur une valeur statique, il est recommandé de le définir sur une valeur à peine supérieure à 5000. L'affectation de numéros de port statiques inférieurs à 5000 risque de provoquer un conflit de port avec un autre processus et un échec du processus du service Surveillance du système Microsoft Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour définir la clé de Registre TCP/IP NSPI Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé TCP/IP Port et définissez le champ Données de la valeur sur un entier à peine supérieur à 5000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service Surveillance du système Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres des ports, voir l'article 194952 de la Base de connaissances sur les limitations des ports mappés de manière statique pour Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


Le fichier MAPI32.DLL est manquant dans le dossier bin
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier MAPI32.DLL est manquant dans le dossier system32
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier MAPISTUB.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier MAPISP32.EXE est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


La taille maximale du cache ESE est supérieure à 1,2 Go
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance DataBase Cache Size (DBCacheSize) de l'objet de performance DataBase pour les analyser.

Le compteur de performance DataBase Cache Size (DBCacheSize) représente la taille actuelle du cache utilisé par la banque d'informations. Si Exchange Server Analyzer détecte que la valeur du compteur de performance DataBase Cache Size (DBCacheSize) est supérieure à 307200 (1,2 Go), il affiche une erreur.

Cette erreur indique que la valeur de l'attribut msExchESEParamCacheSizeMax pour l'objet de la banque d'informations Microsoft Exchange (MSExchangeIS) a été augmentée et est supérieure à la valeur maximale recommandée de 307200 (1,2 Go).

Le cache de la base de données de la banque d'informations porte également le nom de tampon ESE. Il stocke les transactions de base de données avant leur validation dans la base de données.

Dans Exchange 2000 Server, une grande zone de la mémoire virtuelle utilisée par Store.exe est allouée au tampon ESE. Exchange 2000 Server utilise une valeur par défaut codée de manière irréversible de 858 mégaoctets (Mo) pour ce tampon. Dans Exchange Server 2003, l'allocation de tampon ESE se base sur la présence du commutateur /3GB dans le fichier Boot.ini. Si le commutateur /3GB est présent, le tampon ESE est réglé sur 896 Mo. Si le commutateur /3GB n'est pas présent, le tampon ESE est réglé sur 576 Mo. Bien qu'un réglage automatique soit systématiquement correct, vous pouvez souhaiter remplacer ce réglage et définir manuellement une valeur plus appropriée à votre environnement.

Alors que vous pouvez régler cette valeur afin que la mémoire réelle allouée soit tout multiple de 8 192 octets, il est recommandé d'utiliser uniquement une valeur du tableau suivant :

Valeur recommandée | Mémoire allouée | Commentaires
147456 | 576 Mo | Il s'agit du minimum recommandé. Ne définissez pas la valeur sur un nombre inférieur. Cette valeur est utile sur des serveurs limités par la mémoire virtuelle et sur des ordinateurs Exchange Server 2003 exécutés sur Microsoft Windows® 2000 Server, qui ne prend pas en charge le commutateur /3GB. Cette valeur est également celle par défaut sur les systèmes qui n'utilisent pas le commutateur /3GB.
196608 | 768 Mo | Cette valeur est recommandée sur des serveurs disposant d'une grande mémoire virtuelle, qui enregistre fréquemment l'événement 9582.
219726 | 858 Mo | Il s'agit de la valeur par défaut dans Exchange 2000 Server. Elle convient sur des systèmes dont vous effectuez la mise à niveau en place et qui disposent d'une grande mémoire virtuelle.
229376 | 896 Mo | Cette valeur est celle par défaut dans Exchange Server 2003 et convient sur de nouveaux systèmes, sauf si votre journal des événements Applications indique autre chose avec la présence de 9 582 événements.
307200 | 1,2 Go | Il s'agit de la valeur maximale que vous pouvez définir. Cette valeur ne doit être utilisée que sur des systèmes disposant d'au moins 2 Go de mémoire physique.

Avant de reconfigurer cette valeur, vous devez analyser la taille de la mémoire virtuelle utilisée par le processus Store.exe. À cet effet, vous pouvez analyser l'objet de performance Processus dans Microsoft Windows. Sur des systèmes disposant du commutateur /3GB, le compteur Virtual Bytes de l'instance Store.exe de l'objet Process doit être inférieur à 2,8 Go. Sur des systèmes ne disposant pas du commutateur /3GB, le compteur Virtual Bytes de l'instance Store.exe de l'objet Process doit être inférieur à 1,8 Go. Si les valeurs sont supérieures à ces nombres, vous risquez de devoir réduire la valeur de msExchESEParamCacheSizeMax. Si les valeurs sont inférieures à ces nombres, vous souhaitez peut-être augmenter la valeur de msExchESEParamCacheSizeMax.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory® lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour régler l'attribut msExchESEParamCacheSizeMax

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration.

  3. Développez CN=Services.

  4. Développez CN=Microsoft_Exchange.

  5. Développez CN=<Nom_organisation_Exchange>.

  6. Développez CN=Groupes_administration.

  7. Développez CN=<Nom_groupe_administration>.

  8. Développez CN=Serveurs.

  9. Développez CN=<Nom_serveur_Exchange>.

  10. Cliquez avec le bouton droit sur CN=Banque_informations, puis cliquez sur Propriétés.

  11. Dans le champ d'attributs, faites défiler et double-cliquez sur msExchESEParamCacheSizeMax.

  12. Dans le champ Valeur, entrez la valeur à définir. Utilisez le tableau pour déterminer la valeur optimale pour votre système.

  13. Cliquez sur OK, puis de nouveau sur OK.

  14. Fermez l'Éditeur Active Directory et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'optimisation de l'utilisation de la mémoire, voir la section sur l'optimisation de l'utilisation de la mémoire pour Exchange Server 2003 dans la rubrique sur la planification d'un système de messagerie Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47584).

Pour plus d'informations sur l'attribut msExchESEParamCacheSizeMax, voir l'article 266768 de la Base de connaissances Microsoft sur la procédure de modification de la taille maximale du cache de la base de données de la banque d'informations dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Le nombre maximal de destinataires a été modifié
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchRecipLimit a été modifié par rapport à sa valeur par défaut. L'attribut msExchRecipLimit stocke la valeur du nombre maximal global de destinataires pour chaque message électronique. Par défaut, la valeur de l'attribut msExchRecipLimit est définie sur 5000. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchRecipLimit n'est pas égale à 5000, il affiche un message indiquant une configuration autre que celle par défaut.

Le nombre maximal global de destinataires s'applique à l'ensemble de l'organisation Exchange. La valeur de l'attribut msExchRecipLimit limite le nombre de destinataires pour un seul message électronique. Le nombre maximal global affecte les messages système et non-système. Les messages système incluent les messages de réplication des dossiers publics.

Remarque :
Vous pouvez également définir des nombres maximaux de destinataires par utilisateur à l'aide de l'outil Utilisateurs et ordinateurs Active Directory. Le paramètre par utilisateur est prioritaire sur le paramètre global et le remplace. Par défaut, le nombre maximal de destinataires par utilisateur est défini de sorte à utiliser le nombre maximal global de destinataires.
Remarque :
Sur un serveur virtuel SMTP (Simple Mail Transfer Protocol), vous pouvez définir un nombre maximal de destinataires par message pour les messages provenant d'utilisateurs Internet. Cette limite diffère du nombre maximal global de destinataires et du nombre maximal de destinataires par utilisateur. Ces deux nombres limitent le nombre de destinataires auxquels un utilisateur Exchange peut envoyer un message.
Pour redéfinir le nombre maximal global de destinataires sur sa valeur par défaut

  1. Démarrez le Gestionnaire système Exchange.

  2. Dans le volet gauche, développez Paramètres globaux.

  3. Cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  4. Sous l'onglet Valeurs par défaut, sous Nombre maximal de destinataires, cliquez sur Nombre maximal de destinataires et entrez 5000.

  5. Redémarrez le service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la définition de nombres maximaux de destinataires et la configuration des clients Outlook Web Access, voir le chapitre sur les paramètres relatifs au contrôle S/MIME d'Outlook Web Access du Guide de sécurité des messages Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47574).

Pour plus d'informations sur l'historique du nombre maximal de destinataires, voir l'article du journal Web Exchange « Me Too ! » (http://go.microsoft.com/fwlink/?LinkId=41848).


Nombre maximal de destinataires élevé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer si la valeur msExchRecipLimit des messages dépasse 7 500. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchRecipLimit est supérieure à 7 500, il affiche un avertissement.

L'attribut msExchRecipLimit stocke la valeur du nombre maximal global de destinataires pour chaque message électronique. La valeur limite le nombre de destinataires pour un seul message électronique. Elle affecte également les messages système et non-système. Les messages système incluent les messages de réplication des dossiers publics. Par défaut, la valeur de l'attribut msExchRecipLimit est définie sur 5000.

Si la valeur de l'attribut msExchRecipLimit dépasse 7 500, les risques de problèmes causés par les messages avec de nombreux destinataires augmentent.

Remarque :
Vous pouvez également définir des nombres maximaux de destinataires par utilisateur à l'aide de l'outil Utilisateurs et ordinateurs Active Directory. Le paramètre par utilisateur est prioritaire sur le paramètre global et le remplace. Par défaut, le nombre maximal de destinataires par utilisateur est défini de sorte à utiliser le nombre maximal global de destinataires.
Remarque :
Sur un serveur virtuel SMTP (Simple Mail Transfer Protocol), vous pouvez définir un nombre maximal de destinataires par message pour les messages provenant d'utilisateurs Internet. Cette limite diffère du nombre maximal global de destinataires et du nombre maximal de destinataires par utilisateur. Ces deux nombres limitent le nombre de destinataires auxquels un utilisateur Exchange peut envoyer un message.
Pour redéfinir le nombre maximal global de destinataires sur sa valeur par défaut

  1. Démarrez le Gestionnaire système Exchange.

  2. Dans le volet gauche, développez Paramètres globaux.

  3. Cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  4. Sous l'onglet Valeurs par défaut, sous Nombre maximal de destinataires, cliquez sur Nombre maximal de destinataires et entrez 5000.

  5. Redémarrez le service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la définition de nombres maximaux de destinataires et la configuration des clients Outlook Web Access, voir le chapitre sur les paramètres relatifs au contrôle S/MIME d'Outlook Web Access du Guide de sécurité des messages Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47574).

Pour plus d'informations sur l'historique du nombre maximal global de destinataires, voir l'article du journal Web Exchange « Me Too ! » (http://go.microsoft.com/fwlink/?LinkId=41848).


Nombre maximal de destinataires trop faible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur msExchRecipLimit pour les messages est inférieure au nombre de banques de dossiers publics dans l'organisation Exchange. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchRecipLimit est inférieure au nombre de banques de dossiers publics, il affiche une erreur.

L'attribut msExchRecipLimit stocke la valeur du nombre maximal global de destinataires pour chaque message électronique. La valeur limite le nombre de destinataires pour un seul message électronique. Elle affecte également les messages système et non-système. Les messages système incluent les messages de réplication des dossiers publics. Par défaut, la valeur de l'attribut msExchRecipLimit est définie sur 5000. Si la valeur de l'attribut msExchRecipLimit est inférieure au nombre de banques de dossiers publics dans l'organisation Exchange, vous rencontrerez des problèmes de réplication de la hiérarchie des dossiers publics.

Remarque :
Vous pouvez également définir des nombres maximaux de destinataires par utilisateur à l'aide de l'outil Utilisateurs et ordinateurs Active Directory. Le paramètre par utilisateur est prioritaire sur le paramètre global et le remplace. Par défaut, le nombre maximal de destinataires par utilisateur est défini de sorte à utiliser le nombre maximal global de destinataires.
Remarque :
Sur un serveur virtuel SMTP (Simple Mail Transfer Protocol), vous pouvez définir un nombre maximal de destinataires par message pour les messages provenant d'utilisateurs Internet. Cette limite diffère du nombre maximal global de destinataires et du nombre maximal de destinataires par utilisateur. Ces deux nombres limitent le nombre de destinataires auxquels un utilisateur Exchange peut envoyer un message.
Pour redéfinir le nombre maximal global de destinataires sur sa valeur par défaut

  1. Démarrez le Gestionnaire système Exchange.

  2. Dans le volet gauche, développez Paramètres globaux.

  3. Cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  4. Sous l'onglet Valeurs par défaut, sous Nombre maximal de destinataires, cliquez sur Nombre maximal de destinataires et vérifiez que la valeur n'est pas inférieure au nombre de banques de dossiers publics de l'organisation Exchange.

  5. Redémarrez le service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la définition de nombres maximaux de destinataires et la configuration des clients Outlook Web Access, voir le chapitre sur les paramètres relatifs au contrôle S/MIME d'Outlook Web Access du Guide de sécurité des messages Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47574).

Pour plus d'informations sur l'historique du nombre maximal global de destinataires, voir l'article du journal Web Exchange « Me Too ! » (http://go.microsoft.com/fwlink/?LinkId=41848).


La clé MaxUserPort est manquante ou n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-23

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut serialNumber pour tous les objets ayant une classe d'objet msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne inclut « Version 6.5 », l'ordinateur exécute Exchange Server 2003. Si la valeur de chaîne inclut « Version 8.0 », l'ordinateur exécute Exchange Server 2007.

L'outil Exchange Analyzer Tool lit ensuite la branche de registre suivante pour chaque serveur Exchange Server 2007 détecté pour déterminer si la valeur de la clé MaxUserPort est définie sur la valeur par défaut 60000.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

La clé MaxUserPort spécifie le numéro de port le plus élevé que TCP peut attribuer lorsqu'une application nécessite un port utilisateur disponible du système.

Par défaut, Microsoft Windows Server 2003 définit la valeur MaxUserPort sur 5000. Microsoft Windows 2000 n'ajoute pas la valeur MaxUserPort au Registre. Toutefois, elle peut être ajoutée manuellement. Cependant, sous Windows Server 2003 et Windows 2000 Server, Exchange Server 2003 et Exchange Server 2007définissent la valeur par défaut sur 60000. Exchange 2000 Server ne définit aucune valeur.

Nous conseillons de définir la valeur MaxUserPort sur 60000. Si vous définissez MaxUserPort sur une valeur inférieure à 60000, vous risquez d'obtenir des avertissements du proxy NSPI (Name Service Provider Interface), tels que l'événement 9040, qui est documenté dans le tableau suivant :

ID d'événement | 9040
Catégorie de l'événement | Proxy NSPI
Source de l'événement | MSExchangeSA
Type d'événement | Avertissement
Description de l'événement | Le proxy NSPI a rencontré une erreur lors de la réception d'un paquet. Il se peut que le contrôleur de domaine cible, le réseau ou un client soit arrêté. Le sous-système Winsock a renvoyé l'erreur : [0x2746]. Le circuit qui a reçu cette erreur est en cours de fermeture.
Important :
Cette rubrique contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la procédure de restauration du Registre, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Correction de cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Double-cliquez sur MaxUserPort, définissez le champ Données de la valeur sur 60000 (décimal), puis cliquez sur OK.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que le paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Ce problème est lié au problème de l'Analyzer La clé TcpTimedWaitDelay est manquante ou n'est pas définie par défaut.

Pour plus d'informations sur l'effet des clés de Registre MaxUserPort et TcpTimedWaitDelay, voir la rubrique sur le protocole TCP du Kit de ressources Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=85654).


La valeur MaxUserPort est trop faible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur maximale du port éphémère TCP :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

Un port éphémère est un port de courte utilisation.

Si Exchange Server Analyzer détecte que la valeur de la clé de Registre MaxUserPort est inférieure à 50000, il affiche un avertissement.

La valeur MaxUserPort spécifie le numéro de port le plus élevé que TCP peut attribuer lorsqu'une application nécessite un port utilisateur disponible du système. En général, les ports éphémères se voient alloués les numéros de port 1024 à 5000.

Par défaut, Microsoft Windows Server™ 2003 définit la valeur MaxUserPort sur 5000. Microsoft Windows® 2000 n'ajoute pas la valeur MaxUserPort au Registre. Vous pouvez ajouter manuellement la valeur MaxUserPort au Registre. Toutefois, sous Windows Server 2003 et Windows 2000 Server, Exchange Server 2003 définit la valeur par défaut sur 60000. Exchange 2000 Server ne définit aucune valeur.

Il est conseillé de définir la valeur MaxUserPort sur 60000. Si vous définissez MaxUserPort sur une valeur inférieure à 60000, vous risquez d'obtenir des avertissements du proxy NSPI (Name Service Provider Interface), tels que l'événement 9040, qui est documenté dans le tableau suivant.

ID d'événement | 9040
Catégorie de l'événement | Proxy NSPI
Source de l'événement | MSExchangeSA
Type d'événement | Avertissement
Description de l'événement | Le proxy NSPI a rencontré une erreur lors de la réception d'un paquet. Il se peut que le contrôleur de domaine cible, le réseau ou un client soit arrêté. Le sous-système Winsock a renvoyé l'erreur : [0x2746]. Le circuit ayant reçu cette erreur est fermé.

Pour supprimer cet avertissement, définissez la valeur de la clé de Registre MaxUserPort sur 60000.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Double-cliquez sur MaxUserPort, définissez le champ Données de la valeur sur ea60 (hexadécimal), puis cliquez sur OK.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que le paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le fichier MDBSZ.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Objet d'analyseur de performances Memory non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Available Mbytes de l'objet de performance Memory pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance Memory est désactivé.

  • L'objet d'analyseur de performances Memory est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre.

Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance Memory est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe ( (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller le système d'exploitation Windows en mode Réparer et appliquer ensuite les derniers Service Packs de Windows.


Objet d'analyseur de performances du processeur MSExchangeDSAccess non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance LDAP Read Time de l'objet de performance MSExchangeDSAccess pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance MSExchangeDSAccess est désactivé.

  • L'objet d'analyseur de performances MSExchangeDSAccess est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. La procédure suivante explique comment corriger les deux premières conditions. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées.

Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance MSExchangeDSAccess est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe ( (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller Exchange Server en mode Réparer et appliquer les derniers Service Packs d'Exchange Server.


Objet d'analyseur de performances de boîte aux lettres MSExchangeIS non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Send Queue Size de l'objet de performance MSExchangeIS Mailbox pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance MSExchangeIS Mailbox est désactivé.

  • L'objet d'analyseur de performances MSExchangeIS Mailbox est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre.

Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance MSExchangeIS Mailbox est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe ( (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller Exchange Server en mode Réparer et appliquer les derniers Service Packs d'Exchange Server.


Objet d'analyseur de performances MSExchangeIS non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-03

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance RPC Operations/sec de l'objet de performance MSExchangeIS pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance MSExchangeIS est désactivé.

  • L'objet d'analyseur de performances MSExchangeIS est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance MSExchangeIS est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe ( (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller Exchange Server en mode Réparer et appliquer les derniers Service Packs d'Exchange Server.

Pour plus d'informations sur la résolution des problèmes de connectivité de l'outil Exchange Server Best Practices Analyzer Tool, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).


Objet d'analyseur de performances MSExchangeIS Public non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Send Queue Size de l'objet de performance MSExchangeIS Public pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance MSExchangeIS Public est désactivé.

  • L'objet d'analyseur de performances MSExchangeIS Public est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance MSExchangeIS Public est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe (Extensible Performance Counter List) à l'adresse http://go.microsoft.com/fwlink/?LinkId=34436.

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller Exchange Server en mode Réparer et appliquer les derniers Service Packs d'Exchange Server.


Mise à jour du pilote MSGINA.DLL disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version de Microsoft Windows® exécutée sur le serveur qui utilise Exchange :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que le serveur Exchange exécute Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que le serveur Exchange exécute Windows 2000 Server. La valeur 5.2 indique que le serveur Exchange exécute Windows Server™ 2003.

Exchange Server Analyzer examine également la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé ServicePackMajorVersion.

La valeur 1 pour la clé ServicePackMajorVersion indique que le Service Pack 1 (SP1) est installé sur le serveur.

Enfin, Exchange Server Analyzer interroge la classe WMI CIM_Datafile pour déterminer la valeur de la clé de la Version pour le fichier Msgina.dll.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le serveur exécute Windows Server™ 2003 SP1.

  • Le numéro de version du fichier Msgina.dll est inférieur à 5.2.3790.2525.

Cette erreur indique que la version de Msgina.dll installée sur le serveur peut provoquer une activité excessive du fichier d'échange et altérer les performances.

Pour résoudre ce problème, installez la mise à jour mentionnée dans l'article 905865 de la Base de connaissances Microsoft sur les tailles des plages de travail de tous les processus dans la session d'une console qui peuvent être tronquées lorsque vous utilisez les services Terminal Server pour vous connecter ou vous déconnecter d'un ordinateur qui exécute Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865).


Le paramètre de journalisation APDU requis du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

Si Exchange Server Analyzer détecte que la valeur de APDU logging required est présente et définie sur une autre valeur que 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Les journaux de type texte au format APDU (Unité de données de protocole d'application) sont des représentations binaires de communication entre les Agents de transfert des messages (MTA) de différents sites et entre le MTA et des applications client d'un même site. Les journaux au format APDU peuvent vous aider à diagnostiquer les problèmes du MTA. Toutefois, ils ne sont intéressants que pour les personnes familières aux traductions ASCII du protocole X.400.

Lorsque le paramètre de Registre APDU logging required est présent et configuré avec une valeur 0, tous les APDU envoyés ou reçus par le MTA sont consignées en tant que données binaires dans MTADATA\BF*.LOG.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration de journalisation APDU par défaut du MTA

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur APDU logging required.

  4. Dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les journaux au format APDU, voir l'article 163324 de la Base de connaissances sur les journaux au format APDU (Unité de données de protocole d'application) (BF0.LOG) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324).


Le paramètre des diagnostics des piles d'appels requis du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

Si Exchange Server Analyzer détecte que la valeur de Call-stack diagnostics required est présente et définie sur un nombre autre que 1, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre des diagnostics des piles d'appels requis est utilisée uniquement pour des opérations avancées de débogage et ne peut être lue que par une version de débogage de l'Agent de transfert de messages (MTA). Ses données de valeur doivent toujours être définies sur 1. Lorsqu'une version de débogage du MTA est utilisée, cette valeur fournit une pile d'appels pour chaque thread MTA en fin d'exécution.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Call-stack diagnostics required.

  4. Dans le champ Données de la valeur, entrez 1, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Incohérence de nom MTA Computer
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur MTA Computer (Agent de transfert des messages) : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut name pour chaque objet Exchange Server.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster (ClusSvc). Une valeur True indique que le service de cluster est démarré et une valeur False qu'il n'est pas en cours d'exécution.

Si Exchange Server Analyzer détecte que la valeur de la clé MTA Computer ne correspond pas à celle de l'attribut name de l'objet serveur dans Active Directory pour tout ordinateur Exchange Server qui n'est pas exécuté dans un cluster de serveurs Windows, une erreur s'affiche.

Pour corriger cette erreur, vous devez modifier la clé de Registre MTA Computer pour qu'elle corresponde à la valeur de l'attribut name dans Active Directory.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, double-cliquez sur MTA Computer, entrez le nom correct pour cet ordinateur, puis cliquez sur OK.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre Concurrent connections to XLAN-MTAs du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

Si Exchange Server Analyzer détecte que la valeur de Concurrent connections to LAN-MTAs est présente et définie sur une autre valeur que 0x28 (hexa) ou40 (décimal) un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre Concurrent connections to LAN-MTAs détermine le nombre maximal de connexions simultanées aux agents de transfert des messages (MTA) sur le réseau local (LAN). Les MTA qui communiquent par le biais d'un réseau local sont qualifiés de LAN-MTA. Le MTA local peut avoir plusieurs connexions à un MTA distant en fonction de sa configuration et de sa charge système. Le nombre maximal de connexions MTA simultanées sur le réseau local est de 240.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut des connexions MTA simultanées

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Concurrent connections to LAN-MTAs.

  4. Vérifiez qu'hexadécimal est défini pour Base et dans le champ Données de la valeur, entrez 28, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le nombre maximal de connexions MTA simultanées sur le réseau local, voir l'article de la Base de connaissances sur l'ID d'événement 9280 MTA Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402).


Le paramètre Concurrent connections to X.400 gateways du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to X.400 gateways

Si Exchange Server Analyzer détecte que la valeur de Concurrent connections to X.400 gateways est présente et définie sur un nombre autre que 6, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre Concurrent connections to X.400 gateways représente le nombre maximal de connexions simultanées à des MTA X.400 distants. La valeur par défaut de 6 est suffisante pour la plupart des organisations. Il existe un problème connu lors de l'utilisation de plus de 4 connecteurs EDK sur un serveur utilisant Exchange Server 5.5 qui requiert l'augmentation de la valeur de Concurrent connections to X.400 gateways à 0x12 (hexadécimal) ou 18 (décimal). Pour plus d'informations sur ce problème, voir l'article 282115 de la Base de connaissances Microsoft sur le flux de messages qui s'arrête si plus de 4 connecteurs EDK Exchange sont installés (http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115). À moins de rencontrer le problème décrit dans cet article, laissez la valeur de Registre Concurrent connections to X.400 gateways définie sur 6.

Pour résoudre ce problème, rétablissez la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Concurrent connections to X.400 gateways.

  4. Dans le champ Données de la valeur, entrez 6, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre Concurrent MDB/delivery queue clients du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

Si Exchange Server Analyzer détecte que la valeur de Concurrent MDB/delivery queue clients est présente et définie sur un nombre autre que 3, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Concurrent MDB/delivery queue clients correspond au nombre maximal de clients de file d'attente de remise d'accès aux messages des bases de données de messages (MDB) et de l'API Exchange que l'Agent de transfert des messages (MTA) peut prendre en charge. Chaque client peut avoir plusieurs sessions. Cette valeur devrait être définie sur au moins deux pour prendre en charge les entités MDB privées et publiques.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Concurrent MDB/delivery queue clients.

  4. Dans le champ Données de la valeur, entrez 3, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Les fichiers de données du MTA sont écrits dans un dossier compressé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Compressed pour le chemin des données de l'Agent de transfert des messages (MTA). Si Exchange Server Analyzer détermine que la valeur de la clé Compressed est True, une erreur s'affiche.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume compressé de système de fichiers NTFS. Lorsque vous stockez vos fichiers de données Exchange sur un volume compressé, la surcharge supplémentaire affecte considérablement les performances d'Exchange. En outre, lorsqu'une base de données de banque Exchange atteint une certaine taille (environ 4 Go), elle risque de ne plus pouvoir être montée ou d'être endommagée.

Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Les fichiers gérés par ESE (Extensible Storage Engine) ne sont pas conçus pour être stockés sur un lecteur compressé. ESE dépend de l'indépendance de secteur pour la récupération basée sur le journal et la compression des fichiers invalide l'indépendance de secteur. La compression ne doit pas être activée pour les volumes hébergeant les bases de données ESE ou pour toute base de données qui utilise l'enregistrement à écriture anticipée.

Avant Exchange 2000 Server Service Pack 3, le montage des bases de données de banque Exchange compressées était possible. La corruption peut toutefois affecter toutes les bases de données de banque Exchange 2000 ou les journaux compressés à l'aide de la compression NTFS.

Avec Exchange 2000 Server Service Pack 3, les fichiers de base de données de banques d'informations compressés d'au plus 128 Mo sont automatiquement décompressés. Lorsque les fichiers de base de données sont supérieurs à 128 Mo, le montage de la base de données est impossible et les messages d'erreur sont générés dans le journal des applications. Exchange 2000 Server Service Pack 3 empêche le montage des bases de données compressées supérieures à 128 Mo.

Pour désactiver la compression de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dont vous souhaitez désactiver la compression de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

Pour déplacer les fichiers de base de données MTA

  1. Dans Exchange Server 5.5, vous pouvez déplacer les fichiers de base de données MTA à l'aide de l'utilitaire Assistant Performance. Pour plus d'informations sur la façon de procéder dans Exchange 2000 Server ou Exchange Server 2003, voir l'article 259896 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du répertoire d'exécution et de la base de données du MTA (http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896).

Pour plus d'informations sur les fichiers de données Exchange et la compression NTFS, voir les articles suivants de la Base de connaissances Microsoft :

  • 170009 sur une erreur de banque provoquée par un volume compressé NTFS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009).

  • 327772 sur le montage impossible de la base de données et l'erreur 0xfffff05b qui s'affiche après l'application du SP3 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772).


Les fichier de données MTA sont écrits dans un dossier crypté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-17

Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Encrypted pour le chemin des données de l'Agent de transfert des messages (MTA). Si Exchange Server Analyzer détecte que la valeur de cette clé est True, une erreur s'affiche.

Sur un ordinateur Exchange 2000 Server ou Exchange Server 2003, les fichiers MTA sont écrits à l'emplacement par défaut suivant :

<lecteur> :\Program Files\Exchsrvr\MTAdata

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume chiffré du système de fichiers de chiffrage (EFS). Lorsque vous stockez vos fichiers de données Exchange sur un volume chiffré, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour sécuriser vos fichiers de données Exchange, il est recommandé d'empêcher l'accès non autorisé à l'ordinateur Exchange et d'utiliser le format de message S/MIME pour chiffrer des données de message.

Désactivation du chiffrage de fichiers sur un dossier spécifié

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver la compression de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Chiffrer le contenu pour sécuriser les données, puis cliquez sur OK.

Pour plus d'informations sur les fichiers de données Exchange Server et EFS, consultez l'article 834638 de la Base de connaissances Microsoft, qui contient des informations sur le stockage de fichiers de données sur un volume chiffré dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Pour plus d'informations sur la sécurisation des messages dans Microsoft Exchange Server 2003, consultez le Guide de sécurité des messages Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47574).


Les fichiers de données du MTA sont écrits sur une partition non NTFS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé FSName pour le dossier de données de l'Agent de transfert des messages Exchange (MTA). Si Exchange Server Analyzer détermine que la valeur de la clé FSName n'est pas égale à NTFS, une erreur s'affiche.

Microsoft ne prend pas en charge le stockage de fichiers de données Exchange sur des volumes non NTFS. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Si vous rencontrez cette erreur, vous devez déplacer le dossier de données du MTA vers un lecteur NTFS. Si le lecteur sur lequel le dossier de données du MTA est enregistré est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS.

Déplacement du dossier Exchange mtadata

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, votre propre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre groupe de stockage, puis cliquez sur Propriétés.

  3. Dans la page de propriétés du groupe de stockage, en regard du champ Emplacement du chemin d'accès système, cliquez sur Parcourir.

  4. Entrez le nouveau chemin d'accès au dossier mtadata, puis cliquez sur OK.

  5. Cliquez sur OK.

Si le lecteur sur lequel les fichiers sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS. Pour plus d'informations sur l'utilisation de l'outil de ligne de commande convert.exe pour convertir une partition FAT en partition NTFS, consultez l'article 214579 de la Base de connaissances Microsoft sur l'utilisation de Convert.exe pour convertir une partition en système de fichiers NTFS (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Le paramètre des tampons de données de base de données par objet du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

Si Exchange Server Analyzer détecte que la valeur de DB data buffers per object est présente et supérieure à zéro mais que celle-ci est définie sur un chiffre autre que 3 ou 6, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur DB data buffers per object value correspond au nombre de tampons de serveur de base de données de 4 kilo-octets (Ko) configurés pour chaque objet de base de données. Plusieurs tampons requièrent davantage de mémoire, mais réduisent la probabilité qu'un objet de base de données soit déplacé sur le disque en raison d'un manque d'espace de tampon. Il est recommandé de modifier cette valeur lorsqu'un Agent de transfert des messages (MTA) communique avec plusieurs ordinateurs Exchange Server version 5.5 dans un site ou entre des sites. Il est ensuite recommandé de définir la valeur sur 6. Si ce MTA ne répond pas à ce critère, vous devez rétablir la valeur par défaut (3).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur DB data buffers per object.

  4. Dans le champ Données de la valeur, entrez 3, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre des descripteurs de fichiers de base de données du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

Si Exchange Server Analyzer détecte que la valeur de DB file handles est présente et définie sur un nombre différent de 192, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur DB file handles correspond au nombre de descripteurs de fichiers de serveur de base de données configurés. Cela détermine le nombre maximal de fichiers de base de données pouvant être ouverts simultanément. Si d'autres fichiers ouverts sont nécessaires par rapport à la valeur configurée, des objets de base de données sont copiés sur le disque.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur DB file handles.

  4. Dans le champ Données de la valeur, entrez 192, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le niveau d'enregistrement des diagnostics MTA est supérieur à 5 (le MTA est en mode de débogage)
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit une série d'entrées de clés de Registre pour déterminer le niveau d'enregistrement des diagnostics de l'Agent de transfert des messages (MTA) défini sur le serveur Exchange. Les clés de Registre se trouvent à l'emplacement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

La valeur par défaut de ces clés est 0. Si Exchange Server Analyzer détecte que la valeur de l'une de ces clés est supérieure à 5, une erreur s'affiche.

Ces clés de Registre sont définies par le Gestionnaire système Exchange lorsque vous réglez les niveaux d'enregistrement sous l'onglet Enregistrement des diagnostics de la page de propriétés d'un serveur particulier. Le Gestionnaire système Exchange permet à un administrateur de définir des niveaux d'enregistrement donnés sur Aucun, Minimum, Moyen et Maximum. Les valeurs correspondantes des clés de Registre sont respectivement 0, 1, 3 ou 5.

Une valeur supérieure à 5 ne peut par conséquent être définie qu'à l'aide d'une modification manuelle du Registre et un tel niveau ne doit être utilisé que pendant des heures creuses pour un débogage ou un dépannage très rapide. La définition de ces clés sur des entiers supérieurs à 5 fait passer l'enregistrement à des niveaux de débogage, ce qui consomme énormément de ressources. Outre l'enregistrement à des niveaux de débogage, la configuration de ces clés sur des valeurs supérieures à 5 génère la création de fichiers « call.out » de suivi de débogage à quelques secondes d'intervalle d'une taille d'environ 40 mégaoctets (Mo). Cela peut remplir le journal des événements de l'ordinateur en moins d'une minute.

Le tableau suivant présente les catégories d'enregistrement MTA telles qu'elles apparaissent sous l'onglet Enregistrement des diagnostics du Gestionnaire système Exchange, ainsi que les noms de clé correspondants dans le Registre.

Catégorie telle qu'affichée dans le Gestionnaire système Exchange | Nom correspondant de clé de Registre
Service X.400 | Service 1 X.400
Ressource | Ressource 2
Sécurité | Sécurité 3
Interface | Interface 4
Ingénierie de maintenance | Ingénierie de maintenance 5
Administration du MTA | Administration du MTA 6
Configuration | Configuration 7
Accès à l'annuaire | Accès à l'annuaire 8
Système d'exploitation | Système d'exploitation 9
Traitement interne | Traitement interne 10
Interopérabilité | Interopérabilité 11
APDU (Application Protocol Data Unit) | APDU 12

Les liens à la fin de cet article fournissent plus d'informations sur ce que chaque catégorie MTA enregistre.

Il est recommandé de définir l'enregistrement pour chaque catégorie sur Aucun (0), sauf si vous êtes en train de résoudre activement un problème. Cette recommandation a pour but de maintenir un nombre gérable d'enregistrements d'événements. Même un niveau Minimum (1) risque fortement de produire des centaines de journaux d'événements en quelques jours, en fonction de la catégorie dans laquelle le niveau est défini.

Si aucun dépannage n'est en cours, il est probable que ces valeurs aient été modifiées lors d'un précédent dépannage et qu'elles aient été laissées ainsi par inadvertance. Vous devez définir ces valeurs au moins sur Maximum (5), mais également envisager de définir les niveaux d'enregistrement sur Aucun (0) pour chaque catégorie d'enregistrement des diagnostics MTA, sauf si vous êtes en train de résoudre activement un problème.

Pour définir les catégories d'enregistrement des diagnostics MTA sur Aucun

  1. Démarrez le Gestionnaire système Exchange : Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans l'arborescence de la console, développez Serveurs, puis le serveur souhaité et cliquez sur Propriétés.

  3. Dans Propriétés de <serveur>, cliquez sur Enregistrement des diagnostics.

  4. Dans Services, cliquez sur MSExchangeMTA.

  5. Pour chaque entrée sous Catégories, définissez le niveau d'enregistrement sur Aucun en sélectionnant la catégorie, puis en sélectionnant Aucun dans Niveau d'enregistrement.

  6. Une fois toutes les catégories définies sur Aucun, cliquez sur Appliquer, puis sur OK.

Pour plus d'informations sur l'enregistrement des diagnostics MTA dans Exchange 2000 Server et Exchange Server 2003, voir l'article 163033 de la Base de connaissances Microsoft sur la description des catégories de diagnostics du MTA (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033).

Pour plus d'informations sur l'enregistrement des diagnostics MTA dans Exchange Server 5.5, voir l'article 163032 de la Base de connaissances sur la description de l'enregistrement des diagnostics MTA (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032).


Le niveau d'enregistrement des diagnostics MTA est différent de zéro
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit une série d'entrées de clés de Registre pour déterminer le niveau d'enregistrement des diagnostics de l'Agent de transfert des messages (MTA) défini sur le serveur Exchange. Les clés de Registre se trouvent à l'emplacement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

La valeur par défaut de ces clés est 0. Si Exchange Server Analyzer détecte que la valeur de l'une de ces clés est supérieure à 1 mais inférieure à 6, un message indiquant une configuration autre que celle par défaut s'affiche.

Ces clés de Registre sont définies par le Gestionnaire système Exchange lorsque vous réglez les niveaux d'enregistrement sous l'onglet Enregistrement des diagnostics de la page de propriétés d'un serveur particulier. Le Gestionnaire système Exchange permet à un administrateur de définir des niveaux d'enregistrement donnés sur Aucun, Minimum, Moyen et Maximum. Les valeurs correspondantes des clés de Registre sont respectivement 0, 1, 3 ou 5.

Le tableau suivant présente les catégories d'enregistrement MTA telles qu'elles apparaissent sous l'onglet Enregistrement des diagnostics du Gestionnaire système Exchange, ainsi que les noms de clé correspondants dans le Registre.

Catégorie telle qu'affichée dans le Gestionnaire système Exchange | Nom correspondant de clé de Registre
Service X.400 | Service 1 X.400
Ressource | Ressource 2
Sécurité | Sécurité 3
Interface | Interface 4
Ingénierie de maintenance | Ingénierie de maintenance 5
Administration du MTA | Administration du MTA 6
Configuration | Configuration 7
Accès à l'annuaire | Accès à l'annuaire 8
Système d'exploitation | Système d'exploitation 9
Traitement interne | Traitement interne 10
Interopérabilité | Interopérabilité 11
APDU (Application Protocol Data Unit) | APDU 12

Les liens à la fin de cet article fournissent plus d'informations sur ce que chaque catégorie MTA enregistre.

En ce qui concerne l'enregistrement des diagnostics, il est généralement recommandé de définir l'enregistrement de chaque catégorie MTA sur Aucun (0), sauf si vous êtes en train de résoudre activement un problème. Cette recommandation a pour but de maintenir un nombre gérable d'enregistrements d'événements. Même un niveau Minimum (1) risque fortement de produire des centaines de journaux d'événements en quelques jours, en fonction de la catégorie dans laquelle le niveau est défini.

Si aucun dépannage n'est en cours, il est probable que ces valeurs aient été modifiées lors d'un précédent dépannage et qu'elles aient été laissées ainsi par inadvertance. Envisagez de définir le niveau d'enregistrement sur Aucun (0) pour chaque catégorie d'enregistrement de diagnostic MTA.

Pour corriger cette erreur dans Exchange Server 2003 ou Exchange 2000 Server

  1. Ouvrez le Gestionnaire système Exchange.

  2. Dans l'arborescence de la console, développez Serveurs, puis le serveur souhaité et cliquez sur Propriétés.

  3. Dans Propriétés de <serveur>, cliquez sur l'onglet Enregistrement des diagnostics.

  4. Dans Services, sélectionnez MSExchangeMTA.

  5. Pour chaque entrée sous Catégories, définissez le niveau d'enregistrement sur Aucun en sélectionnant la catégorie, puis en sélectionnant Aucun dans Niveau d'enregistrement.

  6. Une fois toutes les catégories définies sur Aucun, cliquez sur Appliquer, puis sur OK.

Pour corriger cette erreur dans Exchange Server 5.5

  1. Démarrez le programme Administrateur de Microsoft Exchange Server.

  2. Ouvrez l'objet représentant le serveur qui a des difficultés avec le MTA.

  3. Double-cliquez sur l'objet Agent de transfert des messages dans le volet droit.

  4. Sous l'onglet Enregistrement des diagnostics, sélectionnez le service X.400, puis cliquez sur Maximum.

  5. Sélectionnez Ressource.

  6. Maintenez la touche CTRL enfoncée, puis cliquez sur chaque ressource à déboguer.

  7. Cliquez sur Option pour définir le niveau d'enregistrement Aucun.

  8. Cliquez sur OK.

Pour plus d'informations sur l'enregistrement des diagnostics MTA dans Exchange 2000 Server, voir l'article 163033 de la Base de connaissances Microsoft sur la description des catégories de diagnostics du MTA (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033).

Pour plus d'informations sur l'annulation de l'enregistrement avancé dans Exchange Server 5.5, voir l'article 168906 de la Base de connaissances sur la configuration des fonctions d'enregistrement avancées dans les MTA Exchange 5.0 et 5.5 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168906).

Pour plus d'informations sur l'enregistrement des diagnostics MTA dans Exchange Server 5.5, voir l'article 163032 de la Base de connaissances sur la description des catégories de diagnostics du MTA (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033).


Le paramètre Dispatcher threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

Si Exchange Server Analyzer détecte que la valeur de Dispatcher threads est présente et supérieure à zéro, mais définie sur une autre valeur que 1 ou 2, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Dispatcher threads est le nombre de threads du Répartiteur de l'Agent de transfert de messages (MTA). Cette valeur est multipliée par trois pour les trois sous-types (Router, Fanout, Result) de threads du Répartiteur. Il est recommandé de modifier cette valeur lorsqu'un MTA communique avec plus de cinq ordinateurs Exchange Server version 5.5 sur un même site ou entre des sites, ou encore si des listes de distribution sont très utilisées. Dans ce cas, il est recommandé de définir la valeur sur 3. Si ce MTA ne répond pas à ce critère, vous devez rétablir la valeur par défaut (1).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Dispatcher threads.

  4. Dans le champ Données de la valeur, entrez 1, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le service MTA ne s'exécute pas sous le compte LocalSystem
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur définie pour la clé StartName du service des piles MTA Microsoft Exchange. Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber sur l'objet Exchange Server de l'annuaire. L'attribut serialNumber sur l'objet Exchange Server identifie la version d'Exchange Server en cours d'exécution sur l'ordinateur représenté par l'objet. Si la valeur de la clé StartName n'est pas égale au compte LocalSystem sur un serveur Exchange exécutant Exchange 2000 Server ou Exchange Server 2003, une erreur s'affiche.

L'exécution du service des piles MTA Exchange sous tout autre compte engendrera des erreurs d'autorisation et d'accès et cette configuration n'est pas prise en charge.

Pour corriger cette erreur, vous devez configurer le service des piles MTA Exchange pour qu'il démarre sous le compte LocalSystem (aks SYSTEM).

Remarque :
Cette erreur ne s'applique pas à Exchange Server version 5.5. Seuls Exchange 2000 Server et Exchange Server 2003 nécessitent le service des piles MTA Exchange pour être exécutés sous le compte LocalSystem.

Pour configurer le compte du service des piles MTA Exchange

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Recherchez et arrêtez le service des piles MTA Microsoft Exchange.

  3. Double-cliquez sur le service des piles MTA Microsoft Exchange.

  4. Sous l'onglet Ouvrir une session de la page Propriétés des piles MTA Microsoft Exchange, sélectionnez le compte LocalSytem sous Ouvrir une session en tant que, puis cliquez sur Appliquer.

  5. Sous Statut du service, cliquez sur Démarrer, puis sur OK.

  6. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur l'exécution de services Exchange sous le compte LocalSystem, voir l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Le paramètre Kernel threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

Si Exchange Server Analyzer détecte que la valeur de Kernel threads est présente et supérieure à 0, mais est définie sur une autre valeur que 1 ou 3, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Kernel threads est le nombre de threads de plate-forme qui gèrent le niveau Présentation et Session de la pile OSI (Open Systems Interconnection). Ces threads sont au cœur du traitement de messages de l'Agent de transfert des messages (MTA). Si ce MTA communique avec de nombreux autres serveurs Exchange Server version 5.5 à l'aide de l'appel de procédure distante (RPC) via des connexions réseau lentes ou hautement latentes, il est recommandé d'utiliser une valeur répertoriée dans le tableau suivant.

Valeur | Description
0x3 (hexa) | Recommandation standard. Utilisez cette valeur pour tout MTA communiquant avec d'autres serveurs Exchange Server 5.5 utilisant RPC via des connexions réseau lentes ou hautement latentes.
0x8 (hexa) | Utilisez cette valeur pour les MTA Exchange 2000 Server ou Exchange Server 2003 qui appartiennent à un site contenant plus de 15 ordinateurs Exchange Server 5.5.
0xC (hexa) | Utilisez cette valeur pour les MTA Exchange 2000 Server ou Exchange Server 2003 qui appartiennent à un site contenant plus de 30 ordinateurs Exchange Server 5.5.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la valeur Kernel threads

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Kernel threads.

  4. Dans le champ Données de la valeur, entrez la valeur appropriée pour votre organisation et cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre LAN-MTAs du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

Si Exchange Server Analyzer détecte que la valeur de LAN-MTAs est présente et définie sur une valeur autre que 20, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur LAN-MTAs est le nombre d'Agents de transfert des messages sur le réseau (MTA) pris en charge par le MTA. Il est recommandé d'utiliser 20 comme valeur de Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur LAN-MTAs.

  4. Dans le champ Données de la valeur, entrez 20, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre MDB users du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

Si Exchange Server Analyzer détecte que la valeur de MDB users est présente et définie sur un nombre autre que 500, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur MDB users représente le nombre maximal d'utilisateurs MDB pris en charge par le MTA. Tous les utilisateurs d'Exchange Server sont des utilisateurs MDB par défaut sauf configuration contraire explicite.

La valeur de Registre MDB users définit le nombre de noms uniques à mettre en cache à partir de l'annuaire. Si votre organisation compte plus de 1 500 utilisateurs, vous devez changer la valeur à un tiers de la taille de la liste d'adresses globale, mais en la limitant à un maximum de 5 000.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur MDB users.

  4. Dans le champ Données de la valeur, entrez 500, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre Max RPC Calls Outstanding du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

Si Exchange Server Analyzer détecte que la valeur de Max RPC Calls Outstanding est présente et définie sur un nombre autre que 50, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Max RPC Calls Outstanding est le nombre maximal de threads d'appel de procédure distante (RPC). Cela limite le nombre maximal de RPC dont le traitement simultané est garanti. Cette valeur est utilisée par RpcServerUseAllProtSeqs() et RpcServerListen().

Dans les scénarios mixtes dans lesquels Exchange 2000 Server et/ou Exchange Server 2003 coexistent avec des ordinateurs Exchange Server 5.5 et si vous avez augmenté le nombre de threads d'entrée/sortie de passerelle dans le processus Store.exe, il est recommandé d'augmenter les données de valeur à 0x80 (hexa) ou 128 (décimal).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Max RPC Calls Outstanding.

  4. Dans le champ Données de la valeur, entrez 50, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre Min RPC threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

Si Exchange Server Analyzer détecte que la valeur de Min RPC Threads est présente et définie sur un nombre autre que 4, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Min RPC Threads est le nombre minimal de threads RPC. Elle identifie le nombre minimal de threads d'appel. Cette valeur est utilisée par RpcServerListen(). En règle générale, vous ne devez pas modifier le paramètre par défaut de la valeur de Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Min RPC Threads.

  4. Dans le champ Données de la valeur, entrez 4, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre RTS threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

Si Exchange Server Analyzer détecte que la valeur de RTS threads est présente et supérieure à 0, mais est définie sur une autre valeur que 1 ou 3, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur RTS threads est le nombre de threads de plate-forme qui gèrent le niveau RTSE (Reliable Transfer Service Element) de la pile OSI (Open Systems Interconnection). Les threads RTS sont chargés de placer des données dans les files d'attente. Vous devez régler la valeur de Registre RTS threads sur 1 (valeur par défaut) ou sur 3 si cet Agent de transfert des messages (MTA) communique avec plusieurs ordinateurs Exchange Server version 5.5 au sein d'un site ou entre des sites.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour optimiser la valeur de Registre RTS threads

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur RTS threads.

  4. Dans le champ Données de la valeur, entrez la valeur appropriée (1 ou 3) et cliquez sur OK.

  5. Quittez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le service MTA n'est pas exécuté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-19

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si la valeur des clés Started du service suivant est définie sur True ou False :

  • service des piles MTA Microsoft Exchange ;

  • service de cluster.

La valeur False indique que le service n'est pas en cours d'exécution sur cet ordinateur Exchange Server. La valeur True indique que le service est en cours d'exécution.

Exchange Server Analyzer examine également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique qu'il s'agit d'un serveur frontal.

Si la valeur des trois clés évaluées est False, un avertissement s'affiche.

Il est recommandé de démarrer le service des piles MTA Microsoft Exchange sur tous les ordinateurs Exchange Server qui routent le courrier. Cette opération est particulièrement importante dans un environnement en mode mixte où les messages sont transférés entre Exchange Server 5.5 et Exchange Server 2003 et/ou Exchange 2000 Server. En outre, tous les connecteurs X.400 nécessitent le service des piles MTA Exchange. Sa désactivation entraînera des erreurs et la fonctionnalité pourrait échouer. Les déplacements de boîtes aux lettres nécessitent également le démarrage du service des piles MTA Exchange.

Pour supprimer cet avertissement, démarrez le service des piles MTA Exchange.

Pour démarrer le service des piles MTA Microsoft Exchange

  1. Dans le menu Démarrer, sélectionnez Programmes, Outils d'administration, puis le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Cliquez avec le bouton droit sur le service des piles MTA Microsoft Exchange, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés des piles MTA Microsoft Exchange, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service des piles MTA Microsoft Exchange, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur l'exécution du service des piles MTA Exchange dans un environnement Exchange en mode mixte, voir l'article 810489 de la Base de connaissances Microsoft sur le service des piles MTA qui doit rester activé dans Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489).


Le service MTA est défini sur Disabled
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur définie pour la clé StartMode du service des piles MTA Microsoft Exchange. La valeur Disabled indique que le service des piles MTA Exchange a été désactivé et ne peut pas être démarré tant que la valeur StartMode n'est pas modifiée sur Manual ou Automatic.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour le service SMTP. La valeur False indique que le service n'est pas en cours d'exécution. La valeur True indique que le service est en cours d'exécution.

Exchange Server Analyzer interroge la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de cette clé correspond à une version spécifique du système d'exploitation Microsoft Windows Server™ 2003.

Si Exchange Server Analyzer détecte que la valeur de la clé StartMode est définie sur Disabled sur un ordinateur Exchange Server sur lequel le service SMTP est démarré et que ce même ordinateur ne fait pas partie d'une installation Microsoft Windows Small Business Server 2003, un avertissement s'affiche.

À moins que le serveur ne fasse partie d'une installation Microsoft Windows Small Business Server 2003 ou fonctionne dans un environnement Exchange Server 2003 en mode natif pur, le service des piles MTA Exchange de tous les ordinateurs Exchange Server qui routent le courrier doit être défini sur Automatic. Le routage du courrier sur un serveur sur lequel le service des piles MTA Exchange est désactivé peut produire des messages d'erreur différents. Dans certains cas, les erreurs seront enregistrées si vous exécutez un environnement Exchange 2000 Server ou Exchange Server 2003 dans lequel Exchange Server 5.5 est encore en cours d'exécution. En outre, tous les connecteurs X.400 nécessitent le service des piles MTA Exchange. Sa désactivation entraînera des erreurs et la fonctionnalité pourrait échouer.

Remarque :
Sauf en cas de connectivité directe avec des systèmes de messagerie X.400 ou d'exécution de connecteurs EDK (Exchange Development Kit) tels que Novell GroupWise Connector, Lotus Notes Connector ou un connecteur de fax tiers, les dépendances par rapport au service des piles MTA ont été supprimées dans Exchange Server 2003. Par conséquent, Microsoft prend à présent en charge des déploiements Exchange Server 2003 en mode natif purs dans lesquels le service des piles MTA est désactivé.

Pour corriger cette erreur, vous devez configurer le service des piles MTA Exchange pour qu'il démarre automatiquement sur les serveurs qui routent le courrier.

Pour configurer le service des piles MTA Exchange pour un démarrage automatique

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Double-cliquez sur le service des piles MTA Microsoft Exchange.

  3. Sous l'onglet Général de la page Propriétés des piles MTA Microsoft Exchange, sélectionnez Automatique dans la liste déroulante de la boîte de dialogue Type de démarrage, puis cliquez sur Appliquer.

  4. Sous État du serveur, cliquez sur Démarrer, puis sur OK.

  5. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur l'exécution du service des piles MTA Exchange dans un environnement Exchange, voir l'article 810489 de la Base de connaissances Microsoft sur les instructions de prise en charge du service des piles MTA pour Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489).


Le paramètre Submit/deliver threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

Si Exchange Server Analyzer détecte que la valeur de Submit/deliver threads est présente et définie sur un nombre autre que 2, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Submit/deliver threads est le nombre de threads de soumission/remise de l'Agent de transfert de messages (MTA). Le MTA utilise ces threads pour envoyer des messages à la banque d'informations. Sur certains ordinateurs Exchange Server version 5.5, il est possible que la valeur par défaut 2 ait été automatiquement modifiée par l'Assistant Performance d'Exchange pour être définie sur une valeur plus appropriée au serveur Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Submit/deliver threads.

  4. Dans le champ Données de la valeur, vérifiez que la valeur 2 est entrée, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Sur les ordinateurs Exchange 2000 Server et Exchange Server 2003, la valeur de cette entrée doit être inférieure à 3. Pour les ordinateurs Exchange Server 5.5, vous pouvez également exécuter l'Assistant Performance d'Exchange en mode d'affichage des informations (perfwiz.exe -v) et définir la valeur à l'aide de cet outil.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les situations pour lesquelles la valeur par défaut de Registre Submit/deliver threads de MTA a dû être modifiée, voir les articles suivants de la Base de connaissances :

  • 234280 sur la procédure d'augmentation des capacités de MTA pour envoyer le courrier via des connexions réseau lentes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186 sur le ralentissement du processus Fanout de MTA sur des serveurs multiprocesseurs et la sauvegarde des messages dans la banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 234702 sur la lente progression de la file d'attente MTA à la banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702)

  • 327260 sur le ralentissement ou le blocage du MTA dans Exchange Server 5.5 et la sauvegarde des messages dans la banque d'informations privée (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)

  • Pour plus d'informations sur l'utilisation de l'Assistant Performance d'Exchange en mode d'affichage des informations, voir l'article 246125 de la Base de connaissances sur l'Assistant Performance d'Exchange Server 5.5 en mode d'affichage des informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125).


Le paramètre TCP/IP Control Blocks du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

Si Exchange Server Analyzer détecte que la valeur de TCP/IP control blocks est présente et définie sur un nombre autre que 20, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur TCP/IP control blocks est le nombre maximal de connexions RFC1006 (TCP/IP) simultanées qui sont prises en charge. Ce paramètre contrôle le nombre de tampons disponibles pour les connexions X.400. Si cet Agent de transfert des messages (MTA) héberge plusieurs connecteurs X.400, la valeur TCP/IP control blocks doit être ajustée. Dix blocs de contrôle sont nécessaires pour chaque connecteur X.400 hébergé et un bloc de contrôle pour les connexions entrantes. Par conséquent, dans le cas d'un système avec trois connexions X.400, la valeur appropriée est 33.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la valeur TCP/IP control blocks

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur TCP/IP control blocks.

  4. Dans le champ Données de la valeur, entrez la valeur appropriée pour ce MTA, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre TCP/IP threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

Si Exchange Server Analyzer détecte que la valeur de TCP/IP threads est présente et définie sur un nombre autre que 2, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur TCP/IP threads correspond au nombre maximal de threads du module d'adresse dynamique (DMOD) de l'Agent de transfert des messages (MTA) qui gèrent les connexions RFC1006. Ce nombre est doublé pour les deux sous-types (Driver et Async Notify) de threads RFC1006. Sur les serveurs têtes de pont de réplication d'annuaire et les serveurs de dossiers publics dédiés X.400 qui gèrent un grand nombre de connexions, il est recommandé de remplacer la valeur par défaut (2) par 10.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la valeur TCP/IP threads

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur TCP/IP threads.

  4. Dans le champ Données de la valeur, entrez la valeur appropriée et cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre Transfer threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

Si Exchange Server Analyzer détecte que la valeur de Transfer threads est présente et supérieure à 0, mais est définie sur une autre valeur que 1 ou 2, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Transfer threads est le nombre de threads de transfert de l'Agent de transfert de messages (MTA). Cette valeur est doublée pour les deux sous-types (Transfer In et Transfer Out) de chaque thread de transfert. Il s'agit de l'équivalent de la valeur Submit/deliver threads (qui est liée à MTA et au transfert de messages de la banque d'informations) pour les passerelles et pour MTA. Pour plus d'informations sur la valeur Submit/deliver threads, voir l'article Le paramètre Submit/deliver threads du MTA n'est pas défini par défaut

S'il s'agit d'un MTA Exchange 2000 Server ou Exchange Server 2003 qui communique avec plusieurs ordinateurs Exchange Server 5.5 d'un même site ou entre sites, il est recommandé de régler la valeur de Transfer threads sur 3.

Sur certains ordinateurs Exchange Server 5.5, il est possible que la valeur par défaut 2 ait été automatiquement modifiée par l'Assistant Performance d'Exchange pour être définie sur une valeur plus appropriée à l'ordinateur Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la valeur Transfer threads

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Transfer threads.

  4. Dans le champ Données de la valeur, entrez la valeur appropriée et cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Sur les ordinateurs Exchange 2000 Server et Exchange Server 2003, la valeur de cette entrée doit être inférieure à 3. Vous pouvez également exécuter l'Assistant Performance d'Exchange en mode d'affichage des informations (perfwiz.exe -v) et définir la valeur à l'aide de cet utilitaire.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les situations pour lesquelles la valeur par défaut de Registre Transfer threads du MTA a dû être modifiée, voir les articles suivants de la Base de connaissances :

  • 234280 sur la procédure d'augmentation des capacités de MTA pour envoyer le courrier via des connexions réseau lentes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280)

  • 265186 sur le ralentissement du processus Fanout de MTA sur des serveurs multiprocesseurs et la sauvegarde des messages dans la banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186)

  • 327260 sur le ralentissement ou le blocage du MTA dans Exchange Server 5.5 et la sauvegarde des messages dans la banque d'informations privée (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260)


Le paramètre Transport threads du MTA n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer sa valeur actuelle :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

Si Exchange Server Analyzer détecte que la valeur de Transport threads est présente et définie sur un nombre autre que 1, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Transport threads est le nombre de threads de transfert de l'Agent de transport de messages (MTA). La valeur par défaut de 1 est suffisante pour la plupart des organisations. Vous ne devez pas modifier cette valeur par défaut à moins que des techniciens des services du Support Technique de Microsoft ne vous y invitent.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la valeur Transport threads

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Dans le volet droit, recherchez et double-cliquez sur la valeur Transport threads.

  4. Dans le champ Données de la valeur, entrez 1, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service des piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Suivi des messages désactivé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-06

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la propriété messageTrackingEnabled de l'objet de serveur est définie sur TRUE (activée) ou FALSE (désactivée).

Si Exchange Server Analyzer détermine que la propriété messageTrackingEnabled de l'objet de serveur est définie sur False, il affiche une erreur.

La propriété messageTrackingEnabled de l'objet de serveur détermine l'état du Centre de suivi des messages pour le serveur.

Lorsqu'il est activé, le Centre de suivi des messages enregistre des informations concernant l'expéditeur, le message et ses destinataires. En particulier, vous pouvez consulter des statistiques telles que l'heure d'envoi ou de réception d'un message, la taille de ce dernier, sa priorité, ainsi que la liste de ses destinataires. Vous pouvez également enregistrer la ligne d'objet des messages électroniques. Le Centre de suivi des messages cherche des messages tels que les messages système, les messages des dossiers publics et les messages électroniques.

Vous devez activer le Centre de suivi des messages sur chaque serveur où vous souhaitez effectuer le suivi des messages. Une fois l'activation effectuée, tous les messages routés par un serveur sont ajoutés aux journaux de suivi de messages.

Exchange Server Analyzer exige que le suivi des messages soit activé pour commencer ses analyses.

Remarque :
L'exécution de cette procédure nécessite les autorisations suivantes : membre du groupe Administrateurs local et membre d'un groupe ayant le rôle d'administrateur Exchange appliqué au niveau du groupe d'administration
Pour activer le Centre de suivi des messages sur un serveur

  1. Dans le Gestionnaire système Exchange, développez Serveurs, cliquez avec le bouton droit sur le serveur sur lequel vous souhaitez activer le suivi des messages, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, activez la case à cocher Activer le suivi des messages.

  3. Pour enregistrer l'objet de tout message envoyé depuis, vers ou via le serveur, activez la case à cocher Activer l'enregistrement et l'affichage de l'objet des messages.

    Remarque :
    L'activation de l'enregistrement des messages peut entraîner une diminution des performances.

  4. Sous Maintenance des fichiers journaux, vous pouvez empêcher la suppression des fichiers journaux ou modifier leur délai de garde. Par défaut, les journaux de suivi sont conservés pendant sept jours.

    Remarque :
    Sur les serveurs qui traitent de grandes quantités de courrier, la taille des journaux de suivi augmente rapidement. Assurez-vous que vous disposez d'un espace disque suffisant pour les fichiers journaux et les autres services ou applications qui utilisent ce disque.

  5. Cliquez sur OK ou sur Appliquer. Vous ne devez redémarrer aucun service pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation du Centre de suivi des messages, voir l'article 262162 de la Base de connaissances Microsoft sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).

Pour plus d'informations sur la procédure de résolution des problèmes de transport d'Exchange Server, voir l'article 821910 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de transport d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910).


Les fichiers journaux de suivi des messages sont écrits dans un dossier compressé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Compressed pour l'emplacement du fichier journal de suivi des messages. Si Exchange Server Analyzer détermine que la valeur de la clé Compressed est True, une erreur s'affiche.

Lorsque le suivi des messages est activé sur un serveur Exchange 2000 ou 2003, les journaux de suivi sont écrits à l'emplacement par défaut suivant :

<lecteur> :\Program Files\Exchsrvr\ ServerName .log

où <lecteur> représente le lecteur contenant le chemin d'accès \Program Files\Exchsrvr et Nom_serveur représente le nom d'hôte de l'ordinateur Exchange Server.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume compressé NTFS. Lorsque vous stockez vos fichiers de données Exchange sur un volume compressé, la surcharge supplémentaire affecte considérablement les performances d'Exchange. En outre, lorsqu'une base de données de banque d'informations atteint une certaine taille (4 Go environ), elle peut ne pas être montée ou être endommagée.

Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Les fichiers gérés par ESE (Extensible Storage Engine) ne sont pas conçus pour être stockés sur un lecteur compressé. ESE dépend de l'indépendance de secteur pour la récupération basée sur le journal et la compression des fichiers invalide l'indépendance de secteur. La compression ne doit pas être activée pour les volumes hébergeant les bases de données ESE ou pour toute base de données qui utilise l'enregistrement à écriture anticipée.

Avant Exchange 2000 Server Service Pack 3, le montage des bases de données des banques d'informations compressées était autorisé. L'altération peut toutefois affecter toutes les bases de données des banques d'informations d'Exchange 2000 Server ou les journaux des banques d'informations compressés à l'aide de la compression NTFS.

Avec Exchange 2000 Server Service Pack 3, les fichiers de base de données de banques d'informations compressés d'au plus 128 Mo sont automatiquement décompressés. Lorsque les fichiers de base de données sont supérieurs à 128 Mo, le montage de la base de données est impossible et les messages d'erreur sont générés dans le journal des applications. Exchange 2000 Server Service Pack 3 empêche le montage des bases de données compressées supérieures à 128 Mo.

Désactivation de la compression de fichiers pour un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dont vous souhaitez désactiver la compression de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

Vous pouvez également déplacer les fichiers journaux de suivi des messages vers un dossier différent, non compressé. Pour plus d'informations sur le déplacement des fichiers journaux de suivi des messages, consultez les articles suivants de la Base de connaissances Microsoft :

  • 84103 sur la procédure de modification de l'emplacement des journaux de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700 sur la procédure de modification de l'emplacement des journaux de suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)

Pour plus d'informations sur les fichiers de données Exchange et la compression NTFS, consultez les articles suivants de la Base de connaissances :

  • 170009 sur une erreur de banque provoquée par un volume compressé NTFS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009).

  • 327772 sur le montage impossible de la base de données et l'erreur 0xfffff05b qui s'affiche après l'application du SP3 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772).


Les fichiers journaux de suivi des messages sont écrits sur une partition non NTFS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé FSName pour l'emplacement des fichiers journaux de suivi des messages. Si Exchange Server Analyzer détermine que la valeur de la clé FSName n'est pas égale à NTFS, une erreur s'affiche.

Microsoft ne prend pas en charge le stockage de fichiers de données Exchange sur des volumes non NTFS. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Si vous rencontrez cette erreur, vous devez déplacer les fichiers journaux de suivi des messages dans un dossier sur un lecteur NTFS. Si le lecteur sur lequel les fichiers journaux de suivi des messages sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS.

Déplacement des fichiers journaux de suivi des messages dans Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre serveur, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, cliquez sur Modifier.

  4. Entrez le nouvel emplacement des fichiers journaux de suivi des messages, puis cliquez sur OK.

  5. Cliquez sur OK.
Remarque :
Par défaut, la modification de l'emplacement du fichier journal de suivi est prise en compte à minuit UTC (temps universel coordonné). Une fois cette modification prise en compte, le composant de suivi des messages Exchange crée de nouveaux fichiers journaux à l'emplacement spécifié. Toutefois, les fichiers journaux précédents ne sont pas déplacés vers le nouvel emplacement. C'est pourquoi vous devez attendre que la modification de l'emplacement du fichier journal soit prise en compte, puis déplacer manuellement les fichiers journaux de l'ancien vers le nouvel emplacement. Si le service Surveillance du système Microsoft Exchange est redémarré, l'emplacement du fichier journal est immédiatement modifié. Dans ce scénario, le suivi des messages Exchange crée un nouveau fichier journal dans le nouvel emplacement lorsqu'un utilisateur envoie un message. Dans ce scénario, deux fichiers journaux peuvent porter le même nom : une fichier journal dans l'emplacement d'origine et un dans le nouvel emplacement spécifié. Le cas échéant, renommez le fichier journal stocké à l'emplacement du fichier journal d'origine avant de le déplacer vers le nouvel emplacement de fichier journal. Utilisez la même convention d'appellation que celle utilisée par le suivi des messages Exchange (aaaammjj). Toutefois, dans ce cas, utilisez une date antérieure à celles des fichiers journaux existants pour que ce fichier journal renommé n'interfère pas avec des fichiers journaux futurs.

Pour plus d'informations sur le déplacement de fichiers journaux de suivi des messages sur un ordinateur utilisant Exchange 2000 Server, consultez l'article 317700 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement des fichiers journaux de suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700).

Si le lecteur sur lequel les fichiers sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS. Pour plus d'informations sur l'utilisation de l'outil de ligne de commande convert.exe pour convertir une partition FAT en partition NTFS, consultez l'article 214579 de la Base de connaissances Microsoft sur l'utilisation de Convert.exe pour convertir une partition en système de fichiers NTFS (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Les fichiers journaux de suivi des messages sont écrits dans un dossier crypté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Encrypted pour les fichiers journaux de suivi des messages. Si la valeur de cette clé est True, une erreur s'affiche.

Lorsque le suivi des messages est activé sur un serveur Exchange 2000 ou 2003, les journaux de suivi sont écrits à l'emplacement par défaut suivant :

<lecteur>:\Program Files\Exchsrvr\ ServerName .log

où <lecteur> représente le lecteur contenant le chemin d'accès \Program Files\Exchsrvr et Nom_serveur représente le nom d'hôte de l'ordinateur Exchange Server.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume chiffré du système de fichiers de chiffrage (EFS). Lorsque vous stockez vos fichiers de données Exchange sur un volume chiffré, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour sécuriser vos fichiers de données Exchange, il est recommandé d'empêcher l'accès non autorisé à l'ordinateur Exchange et d'utiliser le format de message S/MIME pour chiffrer des données de message.

Désactivation du chiffrage de fichiers pour un dossier spécifié

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver le chiffrage de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Chiffrer le contenu pour sécuriser les données, puis cliquez sur OK.

Vous pouvez également déplacer les fichiers journaux de suivi des messages vers un dossier différent, non chiffré. Pour plus d'informations sur le déplacement des fichiers journaux de suivi des messages, consultez les articles suivants de la Base de connaissances Microsoft :

  • 841089 sur la procédure de modification de l'emplacement des journaux de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089)

  • 317700 sur la procédure de modification de l'emplacement des journaux de suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700)


Métabase inaccessible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-13

L'outil Microsoft® Exchange Server Analyzer tente de lire diverses propriétés de l'instance de serveur virtuel SMTP (Simple Mail Transfer Protocol) à partir du chemin de métabase des Services Internet (IIS) :

/LM/SmtpSvc/<instance de serveur virtuel SMTP>

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • L'interrogation de la métabase échoue.

  • Exchange Server ne s'exécute pas sur Microsoft Windows NT® Server 4.0.

Cette erreur indique qu'Exchange Server Analyzer ne peut pas se connecter à la métabase IIS.

La métabase IIS comprend des informations qui affectent Exchange Server, par exemple des paramètres de protocole pour HTTP, des répertoires virtuels pour l'accès à la boîte aux lettres et au périphérique mobile et des paramètres de sécurité HTTP.

Pour résoudre ce problème, vérifiez l'intégrité de la métabase et que les services Internet (IIS) sont correctement installés.

Pour vérifier que la métabase n'est pas endommagée et que les services Internet (IIS) sont correctement installés, consultez les ressources suivantes :

  • Article 240225 de la Base de connaissances Microsoft, « Description des utilitaires Adsutil et MetaEdit utilisés pour modifier la métabase » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225).

  • Article 317678 de la Base de connaissances Microsoft sur la procédure de redémarrage des services Internet (IIS) sur Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678).

Si les instructions fournies dans ces ressources ne permettent pas de résoudre le problème, il se peut que vous deviez désinstaller puis réinstaller IIS.

Désinstallation d'IIS à l'aide de l'option Ajouter ou supprimer des composants Windows du Panneau de configuration

  1. Cliquez sur Démarrer, puis sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter/Supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications.

  5. Cliquez sur Détails.

  6. Cliquez sur le Gestionnaire des services Internet (IIS).

  7. Cliquez sur Suivant.

  8. Cliquez sur Terminer lorsque les services Internet (IIS) sont désinstallés.
Installation d'IIS à l'aide du Panneau de configuration

  1. Cliquez sur Démarrer, puis sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter/Supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications.

  5. Cliquez sur Détails.

  6. Activez la case à cocher Gestionnaire des services Internet (IIS).

  7. Cliquez sur OK jusqu'à ce que vous soyez revenu dans l'Assistant Composants Windows.

  8. Cliquez sur Suivant, puis exécutez l'Assistant Composants Windows.


La valeur MinUserDC n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-08

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si le contrôleur de domaine du service d'annuaire Active Directory® agissant en tant qu'émulateur PDC a été manuellement exclu de la liste de contrôleurs de domaine disponibles pour une utilisation par Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

Si Exchange Server Analyzer détecte que la valeur MinUserDC est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Un émulateur PDC est un ordinateur qui tient le rôle de maître des opérations d'Active Directory et traite les demandes de réplication des contrôleurs secondaires de domaine Microsoft Windows NT® Server 4.0 et toutes les mises à jour de mot de passe pour les clients qui n'utilisent pas le logiciel client Active Directory. Les émulateurs PDC sont également des contrôleurs de domaine et par conséquent disponibles pour une utilisation par des applications telles qu'Exchange.

Directory Service Access (DSAccess) est un composant interne d'Exchange 2000 Server et Exchange Server 2003 qui contrôle la manière dont tous les composants Exchange accèdent à Active Directory. La fonction principale de DSAccess est de conserver les informations sur divers événements et opérations liés à l'annuaire. Par exemple, DSAccess découvre la topologie Active Directory et détecte si les contrôleurs de domaine et les serveurs de catalogue global sont disponibles et répondent aux demandes.

Par défaut, DSAccess inclut l'ordinateur de l'émulateur PDC dans sa liste de contrôleurs de domaine disponibles et utilisables. Si des programmes non-Exchange utilisent intensivement l'émulateur PDC, l'utilisation de l'émulateur PDC par DSAccess peut provoquer des problèmes de performances sur l'ordinateur, le serveur Exchange et l'ordinateur de programme non-Exchange.

Pour éviter de tels problèmes de performances, la valeur MinUserDC peut être ajoutée au Registre sur un serveur Exchange pour inciter DSAccess à interroger tous les contrôleurs de domaine disponibles avant d'interroger le contrôleur de domaine qui tient le rôle de maître des opérations de l'émulateur PDC.

Remarque :
Un serveur Exchange configuré avec la valeur de Registre MiniUserDC tentera d'abord d'utiliser d'autres serveurs dans le même domaine. Par conséquent, il est recommandé d'établir cette configuration uniquement si le site comprend au moins deux contrôleurs de domaine contenant les serveurs Exchange.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour examiner et modifier la valeur de Registre MinUserDC

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Recherchez la valeur MinUserDC et apportez les modifications requises. Si la valeur DWORD n'existe pas, vous pouvez la créer manuellement.

  4. Les données de valeur configurées pour l'entrée de Registre MinUserDC correspondent au nombre maximal de contrôleurs de domaine à contacter avant de contacter l'émulateur PDC. Par exemple, si vous définissez MinUserDC sur 4, DSAccess est configuré pour n'exclure l'émulateur PDC que lorsqu'un total de 4 contrôleurs de domaine est disponible. Lorsque cette condition est remplie, l'émulateur PDC ne peut pas être utilisé et DSAccess ne communique qu'avec les 3 autres contrôleurs de domaine.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de l'entrée de Registre MinUserDC, voir l'article 298879 de la Base de connaissances sur les problèmes de performances que peut rencontrer Exchange 2000 en cas d'utilisation de l'émulateur PDC par DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879).


Plus de 1 000 banques de boîtes aux lettres sont présentes
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® et conserve le décompte des objets de banque d'informations de Microsoft Exchange avec la classe d'objet de msExchPrivateMDB. Si Exchange Server Analyzer constate qu'une organisation compte plus de 1 000 banques de boîtes aux lettres, un avertissement s'affiche.

Un avertissement s'affiche car un problème connu existe, selon lequel les utilisateurs accédant aux boîtes aux lettres à partir de Microsoft Office Outlook® Web Access 2003 via des serveurs frontaux dans des organisations comptant plus de 1 000 banques de boîtes aux lettres ne peuvent accéder à leurs boîtes aux lettres. Ce problème résulte de la façon dont le serveur Exchange frontal traite la demande d'authentification vers le serveur Exchange principal.

Si des utilisateurs accèdent à leurs banques de boîtes aux lettres à partir de serveurs Exchange frontaux et si vous obtenez cet avertissement, vous devez effectuer l'une des opérations suivantes :

  • Procurez-vous et installez le correctif Exchange Server décrit dans l'article 899902 de la Base de connaissances Microsoft sur l'obtention d'un message d'erreur 401 lorsque les utilisateurs essaient d'accéder à l'aide d'Outlook Web Access à une boîte aux lettres qui se situe sur un serveur frontal Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=899902).

  • Consolidez si possible les boîtes aux lettres sur moins de banques.

  • définissez les serveurs frontaux de manière à ce qu'ils s'authentifient auprès des serveurs principaux avec une authentification de base. Le reste de cet article décrit cette option.

Par défaut, les serveurs frontaux Exchange Server 2003 utilisent l'authentification Kerberos pour aider à protéger les informations d'identification de l'utilisateur entre les serveurs frontaux et principaux. Si l'authentification Kerberos échoue, un événement d'avertissement sera consigné et le serveur frontal tentera plutôt l'authentification NTLM. Si NTLM échoue, une erreur sera consignée. Une nouvelle tentative d'authentification Kerberos sera effectuée dans 30 minutes. Lorsque les ordinateurs frontaux Exchange 2000 Server ou Exchange Server 2003 s'authentifient auprès des ordinateurs principaux Exchange 2000 Server, NTLM est utilisé. Ni IIS (Internet Information Services) ni le Gestionnaire système Exchange ne disposent d'une interface utilisateur permettant de sélectionner des mécanismes d'authentification.

Configurer le serveur frontal Exchange pour qu'il utilise l'authentification de base implique que vous définissiez une clé de Registre sur tous les serveurs frontaux de votre organisation. La procédure suivante explique comment définir cette clé manuellement.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer les serveurs frontaux Exchange pour qu'ils utilisent l'authentification de base auprès des serveurs principaux Exchange

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    Naviguez jusqu'à : = HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb

  2. Cliquez avec le bouton droit sur MSExchangeWeb, pointez sur Nouveau, puis cliquez sur Clé. Nommez la nouvelle clé Dav.

  3. Cliquez avec le bouton droit sur la nouvelle clé Dav, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Nommez la nouvelle valeur UseBasicAuthToBE et définissez-la sur 1.

  5. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services, cliquez avec le bouton droit sur Service d'administration IIS, puis cliquez sur Redémarrer.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La majorité des appels store.exe permanents attendent une réponse du moteur ESE
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant des appels permanents entre composants adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au moteur Exchange Extensible Storage Engine (ESE).

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Le service de banque d'informations Microsoft Exchange opère par-dessus une base de données ESE. ESE est un moteur de base de données sophistiqué à base de transactions. Une transaction est une série d'opérations traitées comme une unité atomique (indivisible). Soit toutes les opérations d'une transaction sont achevées et enregistrées de manière permanente, soit aucune opération n'est effectuée.

Exchange Server utilise ESE comme un moteur de base de données incorporé qui détermine la structure des bases de données et gère la mémoire. Ce moteur de base de données met en cache les bases de données en transférant des blocs de données (pages) de quatre kilo-octets (Ko) vers et depuis la mémoire. Il met à jour les pages en mémoire et écrit sur le disque les pages nouvelles ou mises à jour. Lorsque des demandes parviennent au système, le moteur de base de données peut fournir les données se trouvant en mémoire. Il ne doit donc pas constamment accéder au disque.

Bien que la mise en cache mémoire de données soit le mode de traitement des données le plus rapide et le plus efficace, elle signifie aussi, lorsqu'Exchange est exécuté, que les informations sur le disque ne sont jamais entièrement à jour. La version la plus récente de la base de données se trouve en mémoire. Cependant, puisque de nombreuses modifications effectuées en mémoire ne sont pas encore transcrites sur le disque, la base de données et la mémoire ne sont pas synchronisées. Le disque contenant le journal des transactions est toujours tenu à jour avec les informations relatives à chaque transaction.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant une prédominance d'appels du service de banque d'informations d'Exchange (Store.exe) à la base de données ESE, il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange au moteur ESE peuvent être dus aux conditions suivantes :

  • Défragmentation en ligne d'Exchange.

  • Sauvegardes de données.

    Remarque :
    Si une sauvegarde de données ou une défragmentation en ligne était en cours pendant la collecte des données de journal Exchange Call Trace, vous pouvez ignorer sans crainte ce message d'erreur censé indiquer un problème de performances d'Exchange Server.
  • Des goulets d'étranglement sur les lecteurs de base de données, par exemple une capacité insuffisante pour le nombre d'utilisateurs du serveur.

  • Des goulets d'étranglement sur les lecteurs TEMP et TMP.

Pour résoudre cette erreur, procédez comme suit :

  • Nous recommandons de ne pas faire chevaucher les fenêtres de sauvegarde ou la maintenance en ligne et des moments d'intenses demandes des utilisateurs.

  • Assurez-vous que les lecteurs de disque de la base de données sont en bon état et offrent un débit suffisant pour la charge d'E/S.

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire du serveur. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur la procédure de configuration des fenêtres de défragmentation en ligne, voir l'article 244524 de la Base de connaissances Microsoft sur la procédure de configuration de la fenêtre de défragmentation en ligne d'Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Pour plus d'informations sur les problèmes de goulet d'étranglement de disque d'Echange Server, voir la rubrique sur le Goulot d'étranglement de disque détecté.

Pour plus d'informations sur la procédure de dimensionnement et d'optimisation de disques pour Exchange Server, voir les sections sur la procédure de calcul des besoins d'E/S de disque et sur les pratiques recommandées communes à diverses architectures dans la rubrique sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Pour plus d'informations sur ESE, voir la rubrique sur l'architecture Extensible Storage Engine (http://go.microsoft.com/fwlink/?linkid=67009).


La majorité des appels store.exe permanents attendent une réponse d'IMAIL
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant une prédominance d'appels permanents entre composants adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au composant IMAIL du client MAPI.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Le composant IMAIL d'Exchange Server est un service de conversion flexible utilisé par le service de banque d'informations de Microsoft Exchange entre Internet et les messages MAPI. Il assure ainsi l'interopérabilité entre les clients utilisant RFC-822 ou un format Internet et les clients qui utilisent le format de stockage interne d'Exchange Server, tels que les clients MAPI ou les tâches de stockage internes.

Exchange utilise le mécanisme IMAIL pour appliquer des formats de message au contenu, selon les paramètres définis pour les domaines Internet dans le Gestionnaire système Exchange ou selon les spécifications de l'utilisateur pour chaque destinataire dans Microsoft Office Outlook®. Si aucun paramètre de format n'est transmis à IMAIL, IMAIL formate les messages MAPI au format Summary TNEF (S/TNEF) pour les transferts entre serveurs.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant une prédominance d'appels permanents du service de banque d'informations de Microsoft Exchange (Store.exe) au composant IMAIL du client MAPI, il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange au composant IMAIL du client MAPI peuvent se produire lorsqu'une ou plusieurs des conditions suivantes sont remplies :

  • IMAIL essaie de traiter des données volumineuses dans un message ou une pièce jointe.

  • De nombreux clients demandent une conversion de données.

  • Les demandes DSAccess obtiennent des réponses lentes.

  • Des goulets d'étranglement affectent les lecteurs TEMP et TMP.

  • Il existe des déplacements permanents de boîtes aux lettres.

Pour résoudre cette erreur, procédez comme suit :

  • Planifiez les déplacements de boîtes aux lettres à des heures creuses.

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur tels que les limites de taille des messages et des pièces jointes. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les problèmes de goulets d'étranglement de disque avec Exchange Server, voir la rubrique sur le Goulot d'étranglement de disque détecté.

Pour plus d'informations sur la procédure de dimensionnement et d'optimisation de disques pour Exchange Server, voir les sections sur la procédure de calcul des besoins d'E/S de disque et sur les pratiques recommandées communes à diverses architectures dans la rubrique sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Pour plus d'informations sur les pratiques recommandées en termes de limite de taille des messages sur Exchange Server, voir la rubrique sur La taille maximale des messages sortants n'a pas été définie.

Pour plus d'informations sur DSAccess et les performances d'Exchange Server, voir la rubrique sur la procédure de configuration du cache utilisateur DSAccess dans le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


La majorité des appels store.exe permanents attendent une réponse de LSASS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-11

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant une prédominance d'appels permanents entre composants adressés par le service de banque d'informations Exchange (Store.exe) au processus Lsass.exe (Local Security Authentication Server).

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Le processus Lsass.exe est un sous-système de sécurité invoqué par d'autres processus pour vérifier les informations de compte et la validation de la connexion.

Toute connexion de client Exchange provoque l'envoi, par le serveur qui exécute Exchange Server, d'une demande visant à consulter l'identificateur de sécurité du compte (SID) du client et crée un appel à l'intérieur du processus Lsass.exe.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant une prédominance d'appels permanents du service de banque d'informations Microsoft Exchange (Store.exe) au processus Lsass.exe, il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange au processus LSASS peuvent être dus aux conditions suivantes :

  • problèmes de ressources serveur liés au nombre d'utilisateurs qui s'authentifient en même temps ;

  • latence du réseau entre le serveur Exchange et le contrôleur de domaine ou le serveur de catalogue global ;

  • problèmes de goulet d'étranglement au niveau des ressources du serveur.

Pour résoudre cette erreur, procédez comme suit :

  • Envisagez d'implémenter le paramètre NeverPing de la manière décrite dans le document Paramètre « NeverPing » recommandé.

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur le processus Lsass.exe et l'utilisation de la mémoire, voir l'article 308356 de la Base de connaissances Microsoft sur l'utilisation de la mémoire par le processus Lsass.exe sur les contrôleurs de domaine qui exécutent Windows Server 2003 ou Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

Pour plus d'informations sur les connexions client Exchange et les problèmes de LSASS, voir l'article 161938 de la Base de connaissances Microsoft sur la lenteur des connexions client Exchange en raison d'un blocage des ressources (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Pour plus d'informations sur la latence du réseau entre le serveur Exchange et le contrôleur de domaine ou le serveur de catalogue global, voir l'article sur le site des billets de l'équipe Microsoft Exchange relatif au fait qu'Exchange n'utilise pas toujours des serveurs de catalogue locaux (http://go.microsoft.com/fwlink/?LinkId=69166).

Remarque :
Le contenu de chaque blog et leur URL sont susceptibles d'être modifiés sans préavis.

Pour plus d'informations sur les problèmes de goulet d'étranglement au niveau des ressources du serveur, voir la rubrique sur les Goulot d'étranglement de processeur.

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


La majorité des appels store.exe permanents attendent une réponse de l'annuaire
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-14

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant une prédominance d'appels permanents entre composants adressés par le service de banque d'informations Exchange (Store.exe) au service d'annuaire Active Directory®.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Active Directory fournit toutes les informations de boîtes aux lettres, les services de listes d'adresses et d'autres informations liées aux destinataires. La plupart des informations de configuration d'Exchange Server 2003 sont également stockées dans Active Directory.

Les services d'Exchange Server accèdent aux informations contenues dans Active Directory et y écrivent des informations.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant une prédominance d'appels du service de banque d'informations de Microsoft Exchange (Store.exe) à Active Directory, il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange à Active Directory peuvent être dus aux conditions suivantes :

  • Latence du réseau entre le serveur Exchange et le contrôleur de domaine.

  • Configuration statique ou généralement incorrecte de DSAccess.

  • Surcharge du contrôleur de domaine et du catalogue global.

  • Conception incorrecte de la topologie Active Directory.

Pour résoudre cette erreur, procédez comme suit :

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur tels que les limites de taille des messages et des pièces jointes. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Vérifiez les performances des serveurs contrôleurs de domaine Active Directory.

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les performances d'Exchange et sur DSAccess, voir l'article 250570 de la Base de connaissances Microsoft sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Pour plus d'informations sur les performances des contrôleurs de domaine, voir les ressources Windows Server suivantes :

  • document sur la planification de la capacité des contrôleurs de domaine (http://go.microsoft.com/fwlink/?LinkId=70191).

  • rubrique sur la surveillance des contrôleurs de domaine dans Active Directory, dans les Guides de planification et de déploiement d'Active Directory dans Windows 2000 Server (http://go.microsoft.com/fwlink/?LinkId=70193).


La majorité des appels store.exe permanents attendent une réponse de l'analyse antivirus
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant une prédominance d'appels entrants entre composants adressés par le service de banque d'informations Exchange (Store.exe) au composant Virus API (VAPI) de Virusscan.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant une prédominance d'appels permanents du service de banque d'informations Microsoft Exchange (Store.exe) au composant VAPI de Virusscan, il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange au composant VAPI de Virusscan peuvent être dus aux conditions suivantes :

  • Mises à jour d'un analyseur antivirus générant une nouvelle analyse des éléments contenus dans la banque d'informations.

  • Mauvaise configuration de l'analyseur antivirus

  • Traitement d'un message ou d'une pièce jointe volumineuse par l'analyseur antivirus

Pour résoudre cette erreur, procédez comme suit :

  • Planifiez les mises à jour de votre moteur antivirus à des moments où la consommation de ressources est faible (heures creuses au niveau de la demande).

  • Envisagez de réinstaller l'analyseur antivirus, mais faites-le à des moments de faible demande.

  • Examinez la configuration de votre moteur d'analyse antivirus pour vérifiez que vous disposez d'une configuration correcte des threads, d'exclusions au niveau des fichiers, etc. Voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


La majorité des appels store.exe permanents attendent une réponse de l'instantané du service Cliché instantané de volume
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant une prédominance d'appels permanents entre composants adressés par le service de banque d'informations Exchange (Store.exe) au composant d'instantané du service Cliché instantané de volume.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Le service Cliché instantané de volume est un ensemble d'API COM mettant en place un cadre permettant d'effectuer des sauvegardes de volumes alors que des applications du système continuent d'écrire sur ces volumes.

Microsoft Exchange Server 2003 utilise le service Cliché instantané de volume inclus dans le système d'exploitation Microsoft Windows Server™ 2003 pour effectuer des clichés instantanés de volumes des bases de données Exchange Server 2003 et des fichiers journaux de transactions.

Un instantané du service Cliché instantané de volume n'est pas entièrement indépendant des données d'origine. En général, des instantanés sont créés lorsque vous définissez un point dans le temps et veillez à ce qu'une annulation d'enregistrement des données puisse se faire jusqu'à ce point.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant des appels permanents du service de banque d'informations de Microsoft Exchange (Store.exe) au composant d'instantané du service Cliché instantané de volume, il affiche un message de recommandation.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Remarque :
Si un instantané du service Cliché instantané de volume a été lancé intentionnellement dans les 20 secondes qui suivent une collecte de données Exchange Call Trace, vous pouvez ignorer sans crainte ce message censé indiquer un problème de performances d'Exchange Server.

Nous recommandons de ne pas faire chevaucher les fenêtres de sauvegarde avec la maintenance en ligne ou des moments d'intenses demandes des utilisateurs.

Pour plus d'informations

Pour plus d'informations sur les sauvegardes du service Cliché instantané de volume, voir les recommandations pour l'utilisation du du service Cliché instantané de volume avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=56571).


La version du fichier MOUNTMGR.SYS est incorrecte
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si Microsoft Windows® Server 2003 est installé : HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

Exchange Server Analyzer exécute également les interrogations suivantes :

  • la classe WMI (Windows Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer si Windows Server 2003 Service Pack 1 est installé ;

  • la classe WMI Win32_Service pour déterminer si le service de cluster est exécuté ;

  • la classe WMI Win32_Volume pour déterminer si des points de montage de volume sont présents ;

  • la classe WMI CIM_Datafile pour déterminer si la valeur de la clé Version pour Mountmgr.sys est inférieure à 2443.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • La clé Version de Mountmgr.sys est inférieure à 2443.

  • Le serveur est un nœud d'un cluster exécutant Windows Server 2003 Service Pack 1.

  • Le serveur possède des points de montage de volume.

La version de Mountmgr.sys installée sur le nœud de cluster peut provoquer des échecs de point de montage de volume. Ce problème survient à cause d'une erreur sur le pilote Mountmgr.sys. Il s'agit d'un problème de synchronisation temporaire qui peut survenir lorsqu'un volume arrive pour être monté à un point de montage.

Remarque :
Ce problème ne se pose généralement pas dans un environnement sans cluster. Dans ce type d'environnement, la synchronisation du processus de montage de volume est différente.

Pour plus d'informations sur ce problème, voir l'article 898790 de la Base de connaissances Microsoft sur les points de montage de volume sur des disques dans un cluster de serveur qui peuvent devenir indisponibles par intermittence après l'installation de Windows Server 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


Déplacement des répertoires Temp et TMP
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-01

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que les dossiers TEMP et TMP du serveur peuvent ne pas être situés de manière à optimiser les performances du disque. Il est recommandé de stocker les dossiers TEMP et TMP sur un sous-système de disque qui n'est pas partagé par votre dossier système ou par les fichiers de données Exchange.

Le service de banque d'informations de Microsoft Exchange utilise les dossiers TEMP et TMP pour le stockage temporaire lors de diverses opérations, telles que la conversion des messages, l'utilisation de pièces jointes volumineuses et le déplacement de boîtes aux lettres. Les variables d'environnement TEMP et TMP permettent de désigner les dossiers du système de fichiers (par exemple, le chemin d'accès) devant être utilisés par les applications qui nécessitent un espace de travail temporaire. TEMP est généralement utilisé par des applications, telles que Microsoft Exchange, et TMP par des outils de développement, tels que Microsoft Visual C++®. Le chemin d'accès de chaque variable est généralement relatif au contexte de sécurité de l'application ou de l'outil.

Sur un serveur Exchange non membre d'un cluster, la banque d'informations d'Exchange utilise le dossier SYSTEM (par exemple, Système local) utilisant un paramètre de variable d'environnement par défaut %Systemroot%\Temp pour TEMP et TMP. Les serveurs virtuels Exchange exécutés dans un cluster de serveurs Microsoft Windows® utilisent les paramètres de variable d'environnement du compte du service de cluster, qui opère dans le contexte d'un principe de sécurité utilisateur spécifique. Pour les comptes d'utilisateurs, la variable d'environnement par défaut de TEMP et TMP est définie sur %Userprofile%\Temp.

Cet article explique la procédure de déplacement des répertoires TEMP et TMP dans des environnements en clusters ou sans clusters. Avant d'effectuer les procédures décrites dans cet article, prenez en compte les recommandations suivantes :

  • Pour des performances optimales, il est recommandé de ne pas utiliser le disque contenant le système d'exploitation pour les dossiers TEMP et TMP utilisés par Exchange. En outre, vous devez veiller à ce que ces variables d'environnement soient définies sur des chemins d'accès d'un disque rapide ou d'un sous-système de disque, tel que l'ensemble de piles RAID-0+1.

  • Il est recommandé de ne pas utiliser les journaux de transactions Exchange du disque pour les dossiers TEMP et TMP utilisés.

Pour déplacer les dossiers TEMP ou TMP dans un environnement sans clusters

  1. Connectez-vous à l'ordinateur exécutant Exchange Server à l'aide d'un compte qui dispose des droits d'administration.

  2. Cliquez avec le bouton droit sur Poste de travail, puis sélectionnez Propriétés.

  3. Cliquez sur l'onglet Avancé.

  4. Cliquez sur Variables d'environnement.

  5. Dans la zone Variables système, sélectionnez TEMP, puis cliquez sur Modifier.

  6. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TEMP et cliquez sur OK.

  7. Dans la zone Variables système, sélectionnez TMP, puis cliquez sur le bouton Modifier.

  8. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TMP et cliquez sur OK.

  9. Cliquez sur OK pour fermer la boîte de dialogue Variables d'environnement, puis sur OK pour fermer la boîte de dialogue Propriétés système.

  10. Redémarrez le serveur pour appliquer toutes les modifications.
Pour déplacer les dossiers TEMP ou TMP dans un environnement en clusters

  1. Connectez-vous à un nœud du cluster comme le compte du service de cluster.

  2. Cliquez avec le bouton droit sur Poste de travail, puis sélectionnez Propriétés.

  3. Sélectionnez Avancé.

  4. Cliquez sur Variables d'environnement.

  5. Dans la zone Variables utilisateur pour <nom du compte>, sélectionnez TEMP et cliquez sur Modifier.

  6. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TEMP et cliquez sur OK.

  7. Dans la zone Variables utilisateur pour <nom du compte>, sélectionnez TMP et cliquez sur Modifier.

  8. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TMP et cliquez sur OK.

  9. Cliquez sur OK pour fermer la boîte de dialogue Variables d'environnement, puis sur OK pour fermer la boîte de dialogue Propriétés système.

  10. Redémarrez le nœud pour appliquer la modification.

  11. Répétez les étapes 1 à 10 pour chaque nœud du cluster.
Important :
Vous devez octroyer au compte Utilisateurs authentifiés les autorisations appropriées au nouveau chemin d'accès aux dossiers TMP et TEMP.
Pour octroyer au groupe Utilisateurs authentifiés les autorisations des dossiers TMP et TEMP

  1. Démarrez l'Explorateur Windows, localisez, puis cliquez avec le bouton droit sur le dossier vers lequel la variable TEMP ou TMP pointe, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Temp, cliquez sur l'onglet Sécurité, puis sur Ajouter.

  3. Dans la boîte de dialogue Sélectionnez les utilisateurs, les ordinateurs ou les groupes, ajoutez le groupe Utilisateurs authentifiés à la liste des noms d'objet, puis cliquez sur OK.

  4. Cliquez sur Avancé pour accéder aux paramètres de sécurité avancés.

  5. Sélectionnez Utilisateurs authentifiés dans la liste Nom, puis cliquez sur Modifier pour afficher la boîte de dialogue Entrée d'autorisation.

  6. Les champs de la zone Autorisations permettent d'octroyer les autorisations spéciales suivantes :

    Parcourir le dossier / Exécuter le fichier

    Création de fichiers / Écriture de données

    Création de dossiers / Ajout de données

  7. Cliquez sur OK à trois reprises pour appliquer les autorisations et quitter.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Déplacement de boîtes aux lettres utilisateur vers un autre serveur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre serveur présente actuellement une charge des utilisateurs supérieure et la prend en charge de manière efficace. La charge actuelle des utilisateurs provoque des problèmes de performances. Il est recommandé de déplacer les utilisateurs vers un autre emplacement en procédant par petit nombre (généralement cinq pour cent du nombre total d'utilisateurs) chaque nuit jusqu'à résolution des problèmes de performances.

Cette approche est recommandée car l'un des problèmes suivants s'est produit :

  • Certains fichiers de base de données Exchange se situent sur des disques à ou sous la limite de leur capacité de débit.

  • D'autres ressources serveur (telles que la mémoire ou le processeur) sont saturées.

  • Un disque est saturé lorsque le sous-système du disque qui assure la prise en charge d'au moins l'une de vos banques d'informations Exchange présente une latence d'E/S disque moyenne qui dépasse les niveaux recommandés. Déplacez cinq pour cent de vos utilisateurs vers une base de données d'un autre sous-système du disque jusqu'à résolution du problème. Si les lecteurs de base de données représentent un goulot d'étranglement, déplacez les utilisateurs vers une base de données située sur un autre lecteur. Si un lecteur de groupe de stockage constitue le goulot d'étranglement, déplacez les utilisateurs vers une base de données d'un autre groupe de stockage situé sur une autre base de données. Si les lecteurs sont partagés par une autre ressource, une autre solution possible consiste à réduire la charge d'autres applications sur ces lecteurs.

  • Votre serveur physique est saturé. Vous ne disposez actuellement pas de suffisamment de processeurs ou de mémoire pour assurer la prise en charge de la charge du serveur générée par vos utilisateurs. Vous devez déplacer cinq pour cent de vos utilisateurs vers un autre serveur jusqu'à résolution des problèmes de performances.

Remarque :
Alors qu'il n'est pas nécessaire de déconnecter les clients Exchange de leurs boîtes aux lettres pendant une opération de déplacement de boîtes au lettres, il est recommandé d'effectuer cette opération lorsque l'activité du client Exchange est faible, par exemple en dehors des heures de pointe, pour éviter toute interruption possible des services.
Pour déplacer des boîtes aux lettres dans Exchange Server 2003

  1. Lancez le Gestionnaire système Exchange sur l'ordinateur Exchange Server 2003 sur lequel vous souhaitez exécuter le processus.

  2. Double-cliquez sur Serveurs, puis déplacez le conteneur du serveur au même emplacement que les boîtes aux lettres des utilisateurs.

    Par exemple, si vous souhaitez déplacer des boîtes aux lettres du groupe de stockage et de la banque de boîtes aux lettres par défaut, double-cliquez sur Premier groupe de stockage et sur Banque de boîtes aux lettres, puis cliquez sur Boîtes aux lettres.

  3. Dans le volet d'informations, cliquez sur les boîtes aux lettres à déplacer.

  4. Cliquez avec le bouton droit sur les utilisateurs sélectionnés, puis cliquez sur Tâches Exchange.

  5. Dans l'Assistant Tâches Exchange, cliquez sur Suivant.

  6. Sur la page Tâches disponibles, sous Sélectionnez une tâche à accomplir, cliquez sur Déplacer la boîte aux lettres, puis sur Suivant.

  7. Sur la page Déplacer la boîte aux lettres, dans la liste Serveurs, cliquez sur le serveur souhaité, puis, dans la liste Banque de boîtes aux lettres, cliquez sur la banque de boîtes aux lettres souhaitée.

  8. Cliquez sur Suivant.

  9. Configurez la manière dont vous souhaitez traiter les messages endommagés détectés lors du déplacement, puis cliquez sur Suivant.

  10. Cliquez sur Suivant.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir l'article 821829 de la Base de connaissances Microsoft sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • Pour plus d'informations sur le déplacement des boîtes aux lettres entre Exchange 2000 Server et Exchange Server 5.5, voir l'article 328810 de la Base de connaissances Microsoft sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).


Problème de configuration NAS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamLogFilePath de chaque objet de groupe de stockage. Cet attribut spécifie l'emplacement des fichiers du journal des transactions utilisés par les bases de données du groupe de stockage.

En outre, Exchange Server Analyzer interroge Active Directory pour déterminer le nombre des entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

En outre, Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service Microsoft Windows Storage Server 2003 Feature Pack (wssexchmap). Une valeur False indique que le service Windows Storage Server 2003 Feature Pack n'est pas en cours d'exécution sur ce serveur Exchange. Une valeur True indique que le service Windows Storage Server 2003 Feature Pack est en cours d'exécution.

Si Exchange Server Analyzer détermine que la valeur de tout attribut msExchESEParamLogFilePath commence par S:\{ et que le service Windows Storage Server 2003 Feature Pack est actif sur un ordinateur Exchange Server contenant plus de 1 500 boîtes aux lettres, un avertissement s'affiche.

Windows Storage Server 2003 est la plate-forme Microsoft pour périphériques NAS. La configuration de stockage Windows Storage Server 2003 recommandée pour une utilisation avec Exchange Server 2003 est légèrement différente de la configuration standard d'Exchange Server. La configuration recommandée consiste à placer les bases de données Exchange Server sur Windows Storage Server 2003 et les fichiers du journal des transactions sur un disque local de l'ordinateur Exchange Server.

Microsoft a développé le Windows Storage Server 2003 Feature Pack pour trois types de charge de travail spécifiques :

  • Petites charges de travail, pour un maximum de 250 boîtes aux lettres hébergées par un serveur Exchange connecté à un ordinateur Windows Storage Server. Dans ce cas, la configuration Windows Storage Server recommandée est la suivante : un processeur de 1 GHz ou plus rapide, 512 Mo de RAM, quatre disques SCSI ou IDE/SATA configurés comme volume RAID-5 et deux cartes d'interface réseau : une pour la connexion au réseau local et une carte Gigabit Ethernet privée pour une connexion directe au serveur Exchange. Les bases de données Exchange sont stockées sur le volume RAID-5 ; les journaux des transactions restent sur le RAID-1 local du serveur Exchange.

  • Charges de travail moyennes, avec un maximum de 750 boîtes aux lettres dans un groupe de stockage, hébergées par un serveur Exchange et un seul ordinateur Windows Storage Server. Dans cette configuration, l'ordinateur Windows Storage Server doit disposer de deux processeurs de 1 GHz ou plus rapide, de 1 Go de RAM, de six disques SCSI et de deux cartes d'interface réseau. Les disques doivent être configurés comme baie RAID-5 de 4 disques pour les bases de données et comme jeux de miroirs à deux disques distinct pour les journaux des transactions.

  • Charges de travail importantes, avec un ou deux serveurs Exchange Server 2003 hébergeant jusqu'à 1 500 boîtes aux lettres dans deux groupes de stockage. Dans cette configuration, Windows Storage Server doit disposer de deux processeurs de 1 GHz ou plus rapide, de 2 Go de RAM et de 14 disques au total : 10 pour une baie RAID 0+1 pour les bases de données et deux jeux de disques en miroir pour les journaux des transactions.

Cet avertissement indique que l'ordinateur Exchange Server a été configuré pour utiliser Windows Storage Server 2003 pour le stockage. Lors de l'utilisation de Windows Storage Server pour le stockage de données, il est recommandé que moins de 1 500 utilisateurs accèdent en même temps au serveur Exchange.

Pour supprimer cet avertissement

  • Effectuez l'une des opérations suivantes :

    • Déplacez les journaux des transactions sur un disque local de l'ordinateur Exchange Server.

    • Déplacez certaines boîtes aux lettres de cet ordinateur Exchange Server vers un autre ordinateur Exchange Server pour que le nombre de boîtes aux lettres sur l'ordinateur Exchange Server utilisant Windows Storage Server soit égal ou inférieur à 1 500.

Pour plus d'informations sur l'utilisation du Windows Storage Server 2003 Feature Pack avec Exchange Server 2003, voir le document sur la gestion du stockage Exchange avec le Windows Storage Server 2003 Feature Pack (http://go.microsoft.com/fwlink/?linkid=34942).

Pour plus d'informations, voir les ressources supplémentaires suivantes :

  • le document sur l'introduction à l'architecture et au déploiement de Windows Storage Server 2003 (http://go.microsoft.com/fwlink/?linkid=34943)

  • le document sur la création de stockage à protection accrue à l'aide de Windows Storage Server 2003 (http://go.microsoft.com/fwlink/?linkid=34944)

  • le document sur la consolidation de serveurs à l'aide d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47586)


L'attribut networkAddress n'est pas défini correctement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut networkAddress contient la chaîne ncacn_ip_tcp. Exchange Server Analyzer affiche une erreur si l'une des conditions suivantes existe :

  • La chaîne ncacn_ip_tcp n'existe pas.

  • La chaîne ncacn_ip_tcp est endommagée.

Dans Microsoft Office Outlook® Web Access pour Exchange Server 2003, le serveur frontal examine la valeur de l'attribut networkaddress lors de toute tentative de connexion à un serveur Exchange principal.

Remarque :
Exchange 2000 Server ne fait pas ceci avec Outlook Web Access.

Le serveur frontal nécessite une valeur de nom de domaine complet. Le serveur frontal recherche une période dans la valeur renvoyée pour networkaddress ncacn_ip_tcp. La demande de connexion pour la boîte aux lettres du serveur principal spécifique échoue et le serveur frontal renvoie un message d'erreur « HTTP 500 Erreur interne au serveur » à l'utilisateur si les conditions suivantes existent :

  • La valeur networkaddress ncacn_ip_tcp n'est qu'un nom d'hôte ou un nom système d'entrée/sortie de base (NetBIOS).

  • La valeur networkaddress ncacn_ip_tcp n'est pas un nom de domaine complet.

Vous devez mettre à jour la valeur networkaddress ncacn_ip_tcp sur l'objet serveur dans Active Directory pour garantir les fonctionnalités appropriées d'Outlook Web Access 2003. Le nom du serveur affecté est indiqué dans le message d'erreur Exchange Server Analyzer.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Remarque :
Avant de mettre à jour la valeur ncacn_ip_tcp, lisez le reste de cet article. Pour minimiser le temps d'arrêt provoqué par le redémarrage des services Exchange Server, vous devez effectuer une procédure supplémentaire avant le redémarrage.
Pour mettre à jour la valeur ncacn_ip_tcp de l'attribut networkAddress

  1. Lancez l'outil ADSI Edit à partir des outils de support de Windows 2000 Server ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Groupes_administration

    • Nom_groupe_administration

    • Serveurs

  3. Cliquez avec le bouton droit sur Nom_serveur_Exchange, puis cliquez sur Propriétés.

  4. Cliquez sur adresse_réseau dans la liste Attributs, puis sur Modifier.

  5. Ajoutez une nouvelle valeur pour ncacn_ip_tcp. Utilisez le nom de domaine complet du serveur au lieu du nom NetBIOS ou du nom d'hôte du serveur.

    La syntaxe de cette valeur est ncacn_ip_tcp:FQDN. Par exemple, si votre serveur principal Exchange porte le nom d'hôte EXCHANGE1 et le nom de domaine complet EXCHANGE1.contoso.com, utilisez la valeur suivante pour ncacn_ip_tcp : ncacn_ip_tcp:EXCHANGE1.contoso.com

  6. Cliquez deux fois sur OK pour appliquer la modification.

  7. Redémarrez tous les services Exchange Server sur le serveur.

  8. S'il existe plusieurs contrôleurs de domaine, attendez l'exécution de la réplication avant de tenter de vous connecter à partir du serveur frontal. Si le problème n'est pas résolu après l'exécution de la réplication, redémarrez le service d'administration IIS sur le serveur frontal.

Si vous mettez à jour des fichiers d'hôte sur des serveurs principaux pour mettre en corrélation une adresse IP serveur portant un nom d'hôte court, vous devez également mettre à jour la valeur de Registre UpdateProtocols registry. En cas d'utilisation d'un fichier d'hôte, Exchange Server peut rétablir la valeur ncacn_ip_tcp lors du redémarrage du service Surveillance du système Microsoft. Si le serveur principal est en clusters, Exchange Server peut rétablir la valeur ncacn_ip_tcp après le basculement.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour modifier la valeur de Registre UpdateProtocols pour les serveurs principaux qui utilisent des fichiers d'hôte

  1. Utilisez un Éditeur du Registre pour configurer la valeur de Registre suivante sur les serveurs frontaux : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Remarque :
    Si la valeur UpdateProtocols n'est pas présente, vous devez la créer. Pour ce faire, effectuez la procédure suivante :

  2. Ouvrez un Éditeur du Registre et recherchez la sous-clé de Registre suivante : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    1. Cliquez avec le bouton droit sur Paramètres, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

    2. Entrez UpdateProtocols, puis appuyez sur ENTRÉE.

  3. Cliquez avec le bouton droit sur UpdateProtocols, cliquez sur Modifier, entrez 0 dans le champ Données de la valeur, puis cliquez sur OK.

  4. Si votre réseau utilise un fichier Hosts sur le nœud de cluster principal, modifiez l'ordre de saisie de UpdateProtocolscomme suit :

    IPAddress to FQDN

    IPAddress to NetBIOS

    au lieu de :

    IPAddress to NetBIOS

    IPAddress to FQDN

  5. Redémarrez tous les services Exchange Server sur le serveur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Objet d'analyseur de performances de l'interface réseau non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Bytes Total/sec de l'objet de performance Network Interface pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance Network Interface est désactivé.

  • L'objet d'analyseur de performances Network Interface est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance Network Interface est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe ( (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller le système d'exploitation Windows Server en mode Réparer.


Version de MSGTRACK.dll plus récente disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-10-05

L'outil Microsoft® Exchange Server Analyzer contient un moteur de collecte des données de performances permettant d'interroger des objets compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données de plusieurs compteurs de performance de l'objet de performance du processeur pour les analyser.

Exchange Server Analyzer interroge également la classe WMI (Microsoft Windows® Management Instrumentation) CIM_Datafile pour déterminer la valeur définie pour la clé Version du fichier Msgtrak.dll.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Le serveur est confronté à un usage intensif de l'UC.

  • La valeur de la clé Version pour le fichier Msgtrak.dll est antérieure à 6.0.6373.0.

Cet avertissement indique que la version du fichier Msgtrack.dll trouvé peut entraîner un usage intensif de l'UC. Cet avertissement indique également que la version du fichier Msgtrack.dll trouvé peut amener le processus Inetinfo.exe à faire une usage intensif de la mémoire.

Pour résoudre ce problème, procurez-vous la mise à jour référencée dans l'article 811409 de la Base de données Microsoft relatif au suivi des messages qui peut amener le processus Inetinfo.exe à faire un usage intensif de la mémoire (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409).


Fichier WLDAP32.DLL plus récent disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer contient un moteur de collecte des données de performances permettant d'interroger des objets compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données de plusieurs compteurs de performance de l'objet de performance du processeur pour les analyser.

Exchange Server Analyzer lit également l'entrée de registre suivante pour identifier la version de Microsoft Windows® exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

La valeur CurrentVersion 4.0 indique que l'ordinateur Exchange Server exécute Microsoft Windows NT® 4.0. La valeur 5.0 indique que l'ordinateur Exchange Server exécute Windows 2000 Server et la valeur 5.2 qu'il exécute Windows Server™ 2003.

Finalement, Exchange Server Analyzer interroge également la classe WMI (Microsoft Windows® Management Instrumentation) CIM_Datafile pour déterminer la valeur définie pour la clé Version du fichier Wldap32.dll.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Exchange Server Analyzer a détecté un usage intensif de l'UC sur le serveur en cours d'analyse.

  • L'ordinateur Exchange Server exécute Windows 2000 Server.

  • La valeur de la clé de version du fichier Wldap32.dll indique une version antérieure à la version 5.0.2195.7044.

Cet avertissement indique que la version du fichier Wldap32.dll trouvé risque d'amener le processus Inetinfo.exe à consommer 100 % des ressources de l'UC sur des systèmes Windows 2000 Server.

Pour résoudre ce problème, procurez-vous la mise à jour référencée par l'article 899019 de la Base de données Microsoft sur la possibilité que le processus Inetinfo.exe utilise 100 % des ressources de l'UC sur un ordinateur Windows 2000 Server exécutant Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019).


Service NNTP activé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service NNTP (NntpSvc) La valeur True indique que le service NNTP (Network News Transfer Protocol) est en cours d'exécution sur ce serveur Exchange.

Exchange Server Analyzer lit également la propriété suivante dans la métabase IIS (Internet Information Services) pour déterminer si une alimentation NNTP est configurée pour le serveur Exchange :

/LM/NNTPSVC/1/Feeds

Si Exchange Server Analyzer détecte que le service NNTP est démarré, mais qu'aucune alimentation n'a été configurée pour le serveur, un avertissement s'affiche.

Pour économiser des ressources, et pour des raisons de sécurité générales, vous ne devez pas exécuter les services des composants qui ne sont pas utilisés. Chaque service exécuté expose des fonctionnalités pouvant être exploitées par des utilisateurs malveillants. Il est recommandé de désactiver tous les services n'étant pas utilisés.

Pour désactiver le service NNTP

  1. Cliquez sur Démarrer, Programmes, Outils d'administration, puis Services.

  2. Cliquez avec le bouton droit sur le service NNTP (Network News Transfer Protocol), puis cliquez sur Propriétés.

  3. Sous l'onglet Général, cliquez sur Arrêter.

  4. Sous Type de démarrage, sélectionnez Désactivé, puis cliquez sur OK.

Pour plus d'informations sur la sécurisation d'Exchange Server 2003, voir le Guide sur le renforcement de la sécurité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47578).


Aucun serveur DNS disponible pour les tests
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-12-05

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Microsoft Windows® Management Instrumentation) Win32_NetworkAdapterConfiguration pour obtenir l'attribut DNSServerSearchOrder pour les serveurs distants auxquels le serveur exécutant Exchange Server tente d'envoyer des messages. Cet attribut est un groupe d'adresses IP de serveur utilisées dans l'interrogation de serveurs DNS (Domain Name System).

Exchange Server Analyzer interroge également le serveur d'annuaire Microsoft Active Directory® pour déterminer la valeur de l'attribut msExchSMTPExternalDNSServers dans la classe protocolCfgSMTPServer pour les objets serveurs Exchange 2000 Server et Exchange Server 2003. La classe protocolCfgSMTPServer contient les paramètres d'un serveur virtuel SMTP (Simple Mail Transfer Protocol). Si l'attribut msExchSMTPExternalDNSServers est défini, le serveur virtuel SMTP utilise un serveur DNS externe.

Enfin, Exchange Server Analyzer utilise la cmdlet Exchange Management Shell suivante pour interroger les valeurs des propriétés ExternalDNSServers et InternalDNSServers des rôles de serveur de transport Exchange 2007 cibles. La propriété ExternalDNSServers spécifie la liste de serveurs DNS externes que le serveur interroge pour résoudre un domaine distant. La propriété InternalDNSServers spécifie la liste de serveurs DNS à utiliser pour résoudre un nom de domaine local pour le serveur cible.

Copier le code
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Exchange Server Analyzer ne peut pas extraire avec succès la valeur de l'attribut DNSServerSearchOrder. De la même façon, l'attribut ne contient pas de données.

  • L'attribut msExchSMTPExternalDNSServers pour les objets serveur Exchange 2000 Server et Exchange Server 2003 n'est pas défini.

  • Les valeurs des propriétés ExternalDNSServers et InternalDNSServers pour les rôles de serveur de transport Exchange 2007 cibles ne contiennent pas de données.

Cette erreur indique qu'Exchange Server Analyzer ne peut pas identifier de serveur DNS utilisé par le serveur Exchange cible. En outre, cette situation peut affecter le flux de messages.

Cette situation peut être due aux causes suivantes :

  • Le DNS n'est pas configuré sur le serveur cible.

  • Le service WMI est en échec ou inaccessible.

Pour résoudre ce problème :

  • Examinez la configuration DNS sur le serveur cible.

  • Vérifiez que le service WMI Exchange est accessible.

Vérification de l'accessibilité du service WMI Exchange

  1. Assurez-vous que le serveur Exchange a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour voir si le serveur Exchange est accessible.

  3. En cas de présence d'un pare-feu, vérifiez si les ports d'appel de procédure distante (RPC) sont bloqués.

  4. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque serveur Exchange qu'il analyse.

    Vous pouvez également accorder des autorisations WMI spécifiques au compte sous lequel Exchange Server Analyzer est exécuté :

    1. Sur le serveur Exchange, ouvrez l'arborescence MMC (Microsoft Management Console) Gestion de l'ordinateur.

    2. Dans Services et applications, cliquez avec le bouton droit sur Contrôle WMI et cliquez sur Propriétés.

    3. Dans la page Propriété des contrôles WMI, cliquez sur l'onglet Sécurité, puis développez Racine.

    4. Sélectionnez le dossier CIMV2, puis cliquez sur Sécurité.

    5. Dans la page Sécurité pour ROOT\CIMV2, ajoutez le compte sous lequel Exchange Server Analyzer est exécuté.

  5. Sélectionnez le compte que vous avez ajouté à l'étape 4. Dans Autorisations pour compte_sélectionné, sous la colonne Autoriser, activez les cases à cocher Appel à distance autorisé et Sécurité de lecture, puis cliquez sur OK.

Pour plus d'informations sur la procédure de configuration du DNS pour une utilisation avec Exchange Server, consultez l'article 322856 de la Base de connaissances Microsoft, « COMMENT FAIRE : Configuration de DNS pour une utilisation avec Exchange Server » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856).

Pour plus d'informations sur les problèmes de connectivité réseau, consultez l'article 325487 de la Base de connaissances Microsoft, « Résolution des problèmes de connectivité réseau » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur les problèmes de connectivité de l'outil Exchange Server Analyzer, consultez le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, consultez l'article 832017 de la Base de connaissance, « Vue d'ensemble des services et exigences de ports réseau pour le système Windows Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Aucun SID de compte principal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-14

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si un avertissement Événement 9548 a été enregistré pour MSExchangeIS au cours de la dernière heure.

Si Exchange Analyzer détecte qu'un avertissement Événement 9548 a été enregistré au cours de la dernière heure, il compte le nombre total d'avertissements Événement 9548 enregistrés pour cette heure.

Enfin, si Exchange Analyzer détecte qu'un avertissement Événement 9548 a été enregistré au cours des dernières 20 heures ou plusieurs fois au cours de la dernière heure, il affiche un avertissement.

Cet avertissement indique que des comptes d'utilisateur du service d'annuaire Active Directory associés à des boîtes aux lettres Exchange Server et dotés d'attributs msExchMasterAccountSID non valides peuvent être désactivés.

Une boîte aux lettres qui se trouve sur un serveur exécutant Microsoft Exchange Server 2003 ou Exchange 2000 Server doit être liée à un compte d'utilisateur du service d'annuaire Active Directory pour être accessible. Pour créer ce lien en partie, définissez l'attribut Active Directory msExchMasterAccountSid dans la boîte aux lettres. Le compte Active Directory auquel la boîte aux lettres Exchange est liée peut être activé ou désactivé. Seuls les comptes désactivés doivent avoir un utilisateur doté de l'attribut msExchMasterAccountSid.

Si la valeur de l'attribut msExchMasterAccountSid sur un compte d'utilisateur désactivé est vide ou endommagée, et qu'une liste de contrôle d'accès (ACL) créée inclut ce compte d'utilisateur, des problèmes de performances peuvent survenir lorsque cette ACL est utilisée pour accéder aux ressources de boîte aux lettres ou de dossier public.

Pour supprimer cet avertissement :

  • Vérifiez qu'Exchange Server 2003 Service Pack 2 (SP2) est installé avec le correctif mentionné dans l'article 916783 de la Base de connaissances Microsoft sur le correctif disponible pour modifier le mode de traitement par Exchange Server 2003 SP2 du compte d'utilisateur Active Directory associé à une boîte aux lettres Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783).

  • Examinez l'ACL et le compte d'utilisateur référencé par l'avertissement Événement 9548 pour déterminer si la valeur de l'attribut msExchMasterAccountSid est vide ou endommagée et, au besoin, générez une valeur d'attribut msExchMasterAccountSID valide pour le compte en suivant les instructions de l'article 328880 de la Base de connaissances Microsoft, « Comment faire pour résoudre les problèmes de performances des dossiers publics liés à la conversion des listes de contrôle d'accès dans Exchange 2000 et Exchange 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880).

  • Supprimez le compte d'utilisateur désactivé de l'ACL en suivant les instructions de l'article 278966 de la Base de connaissances Microsoft, « Impossible de déplacer la boîte aux lettres de ressources Exchange ou de s'y connecter » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966).

Pour plus d'informations

Pour plus d'informations sur ce problème, consultez les articles suivants de la Base de connaissances Microsoft et les ressources Exchange Server :

  • Centre des événements et des messages d'erreur : Détails sur l'événement : détails sur l'événement 9548 de la banque de boîtes aux lettres MSExchangeIS (http://go.microsoft.com/fwlink/?LinkId=83135)

  • Article 916783 de la Base de connaissances Microsoft sur le correctif disponible pour modifier le mode de traitement par Exchange Server 2003 SP2 du compte d'utilisateur Active Directory associé à une boîte aux lettres Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783)

  • Article 328880 de la Base de connaissances Microsoft, « Comment faire pour résoudre les problèmes de performances des dossiers publics liés à la conversion des listes de contrôle d'accès dans Exchange 2000 et Exchange 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880)

  • Article 278966 de la Base de connaissances Microsoft, « Impossible de déplacer la boîte aux lettres de ressources Exchange ou de s'y connecter » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966).


Aucune instance SMTP trouvée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-08-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge l'attribut distingushedName du service d'annuaire Active Directory® de la classe d'objet protocolCfgSMTPServer pour déterminer si une instance de serveur virtuel SMTP (Simple Mail Transfer Protocol) est en cours d'exécution pour le nom de serveur de passerelle Exchange spécifié par l'utilisateur.

Si Exchange Server Analyzer ne trouve pas d'instance de service virtuel SMTP pour le serveur de passerelle Exchange spécifié par l'utilisateur, il affiche une erreur.

Cette erreur peut être provoquée par des problèmes réseau temporaires, mais peut également indiquer des informations incorrectes dans Active Directory.

Pour résoudre ce problème, passez en revue la configuration du serveur virtuel SMTP pour le serveur de passerelle Exchange spécifié par l'utilisateur.

Pour afficher la configuration de l'instance de serveur virtuel SMTP

  1. Démarrez le Gestionnaire système Exchange :

    Cliquez sur Démarrer, pointez sur Programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Accédez au conteneur suivant :

    \Groupes d'administration\Nom_groupe\Serveurs\Nom_serveur\Protocoles\SMTP\Instance de serveur virtuel SMTP \

  3. Cliquez avec le bouton droit sur l'instance de serveur virtuel SMTP souhaitée, puis sélectionnez Propriétés.

  4. Vérifiez que la configuration de l'instance de serveur virtuel SMTP est correcte.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Pour plus d'informations sur la conception du service SMTP, voir la rubrique correspondante dans le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876).

Pour plus d'informations sur les problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Le serveur cible NSPI a été remplacé manuellement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si le service du serveur cible NSPI (serveur cible Name Service Provider Interface) a été remplacé manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

Si Exchange Server Analyzer détecte que NSPI Target Server est présent et configuré, un message indiquant une configuration autre que celle par défaut s'affiche.

Les divers types de clients utilisent les contrôleurs de domaine et les serveurs de catalogue global de manière différente pour obtenir l'accès à la liste d'adresses globale. Les clients d'Exchange antérieurs à Microsoft Outlook® 2000 Service Release 2 (SR-2) s'attendent à trouver un service d'annuaire sur le serveur Exchange. Exchange 2000 Server et Exchange Server 2003 utilisent le mécanisme DSProxy (Directory Service Proxy) pour établir une connexion vers le serveur de catalogue global le plus proche pour le compte du client et des communications proxy entre Outlook et le serveur de catalogue global. Selon la configuration requise de votre déploiement, vous pouvez explicitement spécifier un serveur de catalogue global particulier à utiliser pour traiter les requêtes DSProxy. Vous pouvez le faire en codant de manière irréversible l'entrée NSPI Target Server du Registre sur le serveur Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour spécifier manuellement un serveur NSPI

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Créez une nouvelle valeur REG_MULTISZ nommée NSPI Target Server.

  4. Configurez la valeur NSPI Target Server avec le nom de domaine complet des serveurs à spécifier.

Pour désactiver un paramètre statique pour le serveur NSPI, supprimez l'entrée de nom de domaine complet du serveur à supprimer. Si un seul serveur cible NSPI est indiqué, supprimez la valeur de Registre NSPI Target Server.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'interaction entre les clients Outlook 2000 SR-2 et versions ultérieures et le service d'annuaire Active Directory®, voir les articles suivants de la Base de connaissances :

  • 302914 sur l'accès d'Outlook 2000 à Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976 sur l'accès des clients MAPI à Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


Un sous-système MAPI non Exchange est installé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la version du fichier MAPI32.dll présent dans les deux dossiers suivants :

<lecteur>:\Program Files\Exchsrvr\Bin

%Systemroot%\System32

Si la version et la copie du fichier MAPI32.dll ne sont pas identiques dans les deux dossiers, une erreur s'affiche.

Pour garantir l'utilisation d'une seule et même version de l'interface MAPI, le programme d'installation d'Exchange Server copie le fichier MAPI32.dll dans les répertoires <lecteur>:\Program Files\Exchsrvr\Bin et %Systemroot%\system32. Si une autre application MAPI, telle que Microsoft Office Outlook® 2003 ou un programme tiers, est installée sur l'ordinateur Exchange Server, il se peut qu'elle copie une version différente du fichier MAPI32.dll dans le dossier System32 et qu'elle nuise ainsi au fonctionnement d'Exchange. Cela s'explique par le fait que les différentes versions de ces deux produits entraînent un conflit du sous-système MAPI qui ne peut probablement être pleinement résolu qu'en interrompant Exchange Server ou l'autre application MAPI.

Il est vivement recommandé de ne pas installer Outlook 2000 ou version ultérieure et Exchange Server 2003, Exchange 2000 Server ou Exchange Server 5.5 sur le même ordinateur.

Une raison fréquente pour installer Outlook et Exchange Server sur un même ordinateur est de pouvoir profiter de certains composants Outlook dans des programmes côté serveur. Pour la plupart des besoins en développement de programmes, il n'est pas nécessaire d'avoir Outlook sur un ordinateur Exchange. Exchange Server inclut en effet une bibliothèque CDO (Collaboration Data Objects), qui offre des fonctions similaires à celles du modèle d'objet Outlook. La bibliothèque CDO est conçue pour une utilisation côté serveur et évite également les implications inhérentes aux versions ultérieures d'Outlook. Pour plus d'informations, voir l'article 290500 de la Base de connaissances Microsoft sur OL2002 et les informations destinées aux développeurs concernant les fonctionnalités de sécurité du courrier électronique (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290500).

Une autre raison fréquente est la création de profils MAPI. Exchange Server inclut toutefois toutes les fonctions nécessaires à cette fin et ne nécessite en aucun cas Outlook. Pour plus d'informations sur la création de profils MAPI sans installer Outlook, voir l'article 306962 de la Base de connaissances sur la procédure de création de profils MAPI sans installer Outlook (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306962).

Si vous devez installer Outlook et Exchange Server sur le même ordinateur à des fins de démonstration, il est conseillé d'utiliser l'une des configurations suivantes, testées spécialement à cet effet :

  • Exchange 2000 Server utilisé avec Outlook 2000

  • Exchange 2000 Server utilisé avec Outlook 2002

Pour corriger cette erreur

  1. Désinstallez Microsoft Outlook ou l'application MAPI tierce du serveur Exchange.

  2. Réexécutez le programme d'installation d'Exchange Server et cliquez sur Réinstaller.

Pour plus d'informations sur l'utilisation de Microsoft Office Outlook 2003 et de Microsoft Exchange Server sur le même ordinateur, voir l'article 266418 de la Base de connaissances Microsoft sur la recommandation de Microsoft de ne pas installer Exchange 2000 Server et Outlook 2000 ou version ultérieure sur le même ordinateur (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418).

Pour plus d'informations sur la résolution des conflits MAPI, voir l'article 229700 de la Base de connaissances sur la procédure de recherche du chemin d'accès correct au fichier MAPISVC.INF sous Outlook 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700).

Pour plus d'informations sur la bibliothèque stub MAPI32, voir MAPI (Messaging API) (http://go.microsoft.com/fwlink/?linkid=34395).


Moteur ESE non Microsoft détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour Ese.dll, le moteur de stockage de base de données Exchange (ESE).

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Microsoft Exchange 2000 Server. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Microsoft Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de Version ne contient pas de sous-chaîne 6 comme partie de ses informations de version, mais que la valeur de serialNumber indique qu'Exchange 2000 Server ou Exchange Server 2003 est installé, un avertissement s'affiche. Cet avertissement indique qu'une version d'Ese.dll non Microsoft est installée et utilisée sur cet ordinateur Exchange Server. Vous devez corriger ce problème dès que possible.

Une cause possible est l'utilisation du logiciel antivirus ESE. Certains programmes antivirus ESE utilisent une interface non prise en charge entre la banque d'informations Exchange et l'ESE. Lorsque vous utilisez ce type de logiciel, vous risquez d'endommager la base de données et de perdre des données si des erreurs se produisent lors de l'implémentation du logiciel.

Pendant l'installation, l'analyseur ESE modifie le service de banque d'informations de Microsoft Exchange pour qu'il dépende du service de programme antivirus ESE. Cela permet de s'assurer que le service de programme antivirus ESE démarre avant le service de banque d'informations de Microsoft Exchange. Lorsque le programme antivirus ESE démarre, la version d'Ese.dll fournie avec Exchange Server est provisoirement renommée Xese.dll et la version d'Ese.dll du programme antivirus ESE remplace le fichier d'origine. Une fois la version d'Ese.dll du programme antivirus ESE chargée, la version fournie avec Exchange Server est renommée Ese.dll et le service de banque d'informations de Microsoft Exchange termine le processus de démarrage.

Il est vivement recommandé de ne pas utiliser des implémentations non Microsoft d'ESE sur les ordinateurs Exchange Server. Les clients qui contactent les services du Support Technique de Microsoft peuvent être invités à désactiver le programme antivirus ESE pour permettre d'identifier les problèmes, mais ils sont libres de réactiver le logiciel après le diagnostic correct de la cause profonde du problème.

Antigen pour Microsoft Exchange de Sybari Software est le programme antivirus ESE le plus largement utilisé. Microsoft et Sybari admettent que la désactivation de Sybari Antigen est une procédure de dépannage valide pour déterminer la cause de problèmes. Pour contacter Sybari Software, voir le site Web Sybari Software (http://www.sybari.com).

Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

Il est également recommandé d'utiliser les programmes antivirus qui prennent en charge l'interface VSAPI (interface de programmation d'applications d'analyse antivirus), également appelée Antivirus API (AVAPI).

Pour supprimer cet avertissement

  1. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  2. Désinstallez Exchange Server de l'ordinateur.

  3. Réinstallez Exchange Server sur l'ordinateur.

  4. Appliquez le dernier Service Pack et les dernières mises à jour d'Exchange Server.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 823166 sur l'aperçu d'Exchange Server 2003 et de logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).


Moteur de stockage non Microsoft détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour Ese.dll, le moteur de stockage de base de données Exchange (ESE).

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Microsoft Exchange 2000 Server. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Microsoft Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de Version ne contient pas de sous-chaîne 5.5 comme partie de ses informations de version, mais que la valeur de serialNumber indique qu'Exchange Server 5.5 est installé, un avertissement s'affiche. Cet avertissement indique qu'une version d'Ese.dll non Microsoft est installée et utilisée sur cet ordinateur Exchange Server. Vous devez corriger ce problème dès que possible.

Une cause possible est l'utilisation d'un logiciel antivirus ESE. Certains programmes antivirus ESE utilisent une interface non prise en charge entre la banque d'informations Exchange et l'ESE. Lorsque vous utilisez ce type de logiciel, vous risquez d'endommager la base de données et de perdre des données si des erreurs se produisent lors de l'implémentation du logiciel.

Pendant l'installation, l'analyseur ESE modifie le service de banque d'informations de Microsoft Exchange pour qu'il dépende du service de programme antivirus ESE. Cela permet de s'assurer que le service de programme antivirus ESE démarre avant le service de banque d'informations de Microsoft Exchange. Lorsque le programme antivirus ESE démarre, la version d'Ese.dll fournie avec Exchange Server est provisoirement renommée Xese.dll et la version d'Ese.dll du programme antivirus ESE remplace le fichier d'origine. Une fois la version d'Ese.dll du programme antivirus ESE chargée, la version fournie avec Exchange Server est renommée Ese.dll et le service de banque d'informations de Microsoft Exchange termine le processus de démarrage.

Il est vivement recommandé de ne pas utiliser des implémentations non Microsoft d'ESE sur les ordinateurs Exchange Server. Les clients qui contactent les services du Support Technique de Microsoft peuvent être invités à désactiver le programme antivirus ESE pour permettre d'identifier les problèmes, mais ils sont libres de réactiver le logiciel après le diagnostic correct de la cause profonde du problème.

Pour supprimer cet avertissement

  1. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  2. Réinstallez Exchange Server sur l'ordinateur.

  3. Appliquez le dernier Service Pack et les mises à jour pour Exchange que vous pouvez obtenir à partir du site Web de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).
  • Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir l'article 328841 de la Base de connaissances Microsoft sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Pour plus d'informations sur la reconstruction d'un ordinateur Exchange Server 5.5 utilisant le même nom, voir l'article 155216 de la Base de connaissances sur la procédure de déplacement d'Exchange Server vers un autre ordinateur ayant le même nom (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216).


La réserve non paginée dépasse le seuil d'avertissement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_PerfOS_Memory pour déterminer la valeur actuelle de la clé PoolNonpagedBytes. Les actions prises par Exchange Server Analyzer dépendent du système d'exploitation sous-jacent, de la présence ou non du commutateur /3GB dans le fichier Windows Boot.ini et de la valeur détectée de cette clé.

Le tableau suivant présente la matrice d'évaluations utilisée par Exchange Server Analyzer pour déterminer si cette valeur est hors limites pour un serveur Exchange spécifié. Si les conditions dans le tableau suivant sont remplies, un avertissement s'affiche.

Système d'exploitation | Paramètre Boot.ini | Réserve non paginée actuelle
Microsoft Windows 2000 Server ou Advanced Server | /3GB | 100 Mo ou plus
Microsoft Windows 2000 Server ou Advanced Server | Aucun | 200 Mo ou plus
Microsoft Windows Server™ 2003 | /3GB | 100 Mo ou plus
Microsoft Windows Server 2003 | Aucun | 200 Mo ou plus

La valeur de la clé PoolNonpagedBytes correspond à la taille, en octets, de la réserve non paginée de la mémoire du noyau. Il s'agit d'une zone de mémoire système physique pour des objets ne pouvant pas être écrits sur le disque même lorsqu'ils ne sont pas utilisés. La valeur de cette clé est la dernière valeur observée. Sur un serveur Exchange sain, à moins qu'une sauvegarde ou une restauration ne soit en cours, la taille de la mémoire de réserve non paginée utilisée ne peut dépasser 85 Mo.

Avec Windows 2000 Server et Windows 2000 Advanced Server, la valeur maximale pour la mémoire de réserve non paginée est de 256 Mo. Étant donné que vous ne pouvez pas augmenter la limite de la mémoire de réserve non paginée au-delà des valeurs répertoriées ci-dessus, cette situation doit être corrigée dès que possible. Quel que soit le système d'exploitation utilisé ou la présence ou non du commutateur /3GB, Windows ne peut accéder qu'à la quantité de mémoire de réserve non paginée disponible. Si la mémoire du noyau de Windows est insuffisante, celui-ci peut afficher des messages d'erreur ainsi que les incidents. La mémoire du noyau est essentielle au bon fonctionnement du système et vous devez par conséquent analyser attentivement la mémoire du noyau.

Si, après le redémarrage du serveur Exchange, cette condition se reproduit, la prochaine étape consistera à s'assurer que votre système est correctement réglé et que le logiciel et le matériel de ce système sont à jour. Cela inclut l'installation des derniers éléments suivants :

  • Service Pack du système d'exploitation Windows ;

  • Service Pack d'Exchange Server ;

  • microprogramme matériel et pilotes ;

  • mises à jour du BIOS système ;

  • mises à jour pour toute application tierce installée et en cours d'exécution.

Si les mises à jour logicielles et matérielles ne résolvent pas ce problème, vous devez désactiver tout logiciel tiers, redémarrer l'ordinateur Exchange Server et analyser la mémoire du noyau.

Pour corriger cette erreur

  1. Redémarrez l'ordinateur Exchange Server dès que possible.

  2. Contrôlez le compteur de performance Mémoire | Octets de réserve non paginée pour veiller à ce qu'il n'excède pas le seuil ci-dessus de votre système.

Pour plus d'informations sur le réglage approprié d'Exchange Server, voir les articles et les livres blancs suivants de la Base de connaissances Microsoft :

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096 sur Exchange 2000 nécessitant le commutateur /3GB avec plus de 1 Gigaoctet de RAM physique (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096).

  • le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • le guide des performances d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=18177).

  • le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

Pour plus d'informations sur la mémoire de réserve non paginée et les rubriques connexes, voir les articles suivants de la Base de connaissances :

  • 294418 sur la comparaison de l'architecture des mémoires 32 bits et 64 bits (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294418)

  • 177415 sur l'utilisation de l'analyseur de mémoire en pool (Poolmon.exe) pour résoudre les problèmes de fuites de mémoire en mode Kernel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=177415)

  • 268343 sur Umdhtools.exe et l'utilisation d'Umdh.exe pour rechercher des pertes de mémoire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343)


Le nombre d'entrées libres dans la table des pages est faible, ce qui peut entraîner une instabilité système
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur SystemPages :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Si Exchange Server Analyzer détecte que la valeur de SystemPages est définie sur 0 et que le nombre d'entrées libres dans la table des pages (PTE) système est inférieur à 3 001, un avertissement s'affiche.

Microsoft Windows Server™ 2003 et Windows® 2000 Server peuvent directement traiter jusqu'à 4 gigaoctets (Go) d'espace d'adressage mémoire, quelle que soit la taille de RAM physique installée. Du point de vue du processus, chaque élément d'adresse virtuelle fait théoriquement référence à un octet de mémoire physique. Le gestionnaire de mémoire virtuelle (VMM) est chargé, en association avec l'unité de gestion de la mémoire (MMU) du processeur, de traduire ou mapper chaque adresse virtuelle en une adresse physique correspondante. Le gestionnaire de mémoire virtuelle effectue le mappage en divisant la RAM en cadres de page de taille fixe, créant ainsi des PTE système pour stocker des informations relatives à ces cadres et les mapper. Les PTE système sont de petits tampons de mémoire en mode noyau utilisés pour communiquer avec le sous-système d'E/S et le réseau. Chaque PTE représente un cadre de page et contient des informations nécessaires, permettant au gestionnaire de mémoire virtuelle de localiser une page.

Sur un système X86 utilisant une taille de page de 4 Ko, le nombre maximal de PTE requis pour mapper 2 Go d'espace d'adressage s'élève à 524 288 (2 Go/4 Ko). Sur un système similaire utilisant le commutateur /3GB, le nombre de PTE requis pour mapper 3 Go d'espace d'adressage s'élève à 786 432 (3 Go/4 Ko). Sur un système standard, cet espace est utilisé comme suit :

  • Un maximum de 50 000 PTE (environ 195 Mo d'espace d'adressage) est réservé à un usage général.

  • Le reste est utilisé pour mapper le cache système, l'hyperespace, la réserve paginée, la réserve non paginée, la zone de vidage sur incident, etc.

La taille de la réserve de PTE est automatiquement déterminée au démarrage du système en fonction de la quantité de mémoire physique du système. Cette réserve est insérée entre la réserve paginée et la réserve non paginée, qui augmente également avec la quantité de mémoire physique du système.

La réserve de PTE système peut être fréquemment utilisée et fragmentée. Cela peut conduire à des situations où un pilote risque de ne pas se charger. De même, si la réserve de PTE système est entièrement épuisée, d'autres parties du système se dégradent, pouvant annuler la création de threads, bloquer le système ou provoquer des incidents potentiels.

Un ordinateur Exchange Server sain doit disposer d'au moins 5 000 PTE système disponibles à tout moment. Si le nombre de PTE système libres est inférieur à 5 000 mais supérieur à 3 001, l'avertissement décrit dans l'article Les entrées libres dans la table des pages ont atteint le seuil d'avertissement s'affiche. Lorsque le nombre de PTE système libres est inférieur à 3 001, cette erreur s'affiche. Pour résoudre ce problème, vous pouvez utiliser la procédure suivante pour configurer correctement la valeur de Registre SystemPages pour le système d'exploitation de votre ordinateur Exchange Server. Lorsque vous exécutez Exchange Server 2003 Service Pack 1 (SP1) sur Windows Server 2003 avec au moins 1 Go de RAM, il est recommandé de définir la clé de Registre SystemPages sur 0. Cette recommandation s'oppose à celle pour Windows 2000 Server, qui suggère de définir SystemPages sur une valeur comprise entre 24 000 et 31 000.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Après avoir exécuté la procédure décrite ci-dessous, vous devez contrôler le nombre de PTE système libres. Pour ce faire, vous pouvez contrôler le compteur de performance des PTE système libres avec le Moniteur système de Windows (également connu comme l'Analyseur de performances). Si le nombre de PTE système libres reste faible après avoir modifié le Registre comme décrit ci-dessous, vous devez vérifier les éléments suivants pour vous assurer que votre ordinateur Exchange Server est configuré de manière optimale :

  • Pilotes Un pilote défectueux est l'une des causes les plus courantes d'un faible nombre de PTE système. Contactez votre fabricant de matériel pour vous assurer que vous utilisez les pilotes les plus récents pour tout votre matériel. Il est également possible de passer à un pilote plus simple. Par exemple, les ordinateurs qui exécutent des applications serveur telles qu'Exchange Server n'ont généralement pas besoin des pilotes vidéo les plus avancés équipés de toutes les fonctionnalités. Au contraire, un pilote plus simple est souvent suffisant. Passer d'un pilote vidéo avancé à un pilote vidéo de base doit augmenter le nombre de PTE système libres.

  • Configuration système Si votre système est équipé d'au moins 1 Go de mémoire physique, vous devez vous assurer que son fichier Boot.ini est correctement configuré avec les commutateurs /3GB et /USERVA=3030 comme décrit dans les articles suivants de la Base de connaissances Microsoft :

    • 823440 sur l'obligation d'utiliser le commutateur /3GB lorsque vous installez Exchange Server 2003 sur un système Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371 sur l'utilisation du commutateur /Userva sur des serveurs Exchange Windows 2003 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Journaux d'événements Vérifiez la présence d'erreurs et d'avertissements dans le journal des événements Applications d'Exchange Server, notamment les événements MSExchangeIS 9582 (erreurs et avertissements), 9665 (avertissement) et 12880 (erreur). La présence de l'événement 9665 peut également indiquer que SystemPages n'est pas configuré pour des performances optimales. Pour plus d'informations sur ces événements, voir l'article 325044 de la Base de connaissances sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange 2003 et Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Pour supprimer cet avertissement dans Windows 2000 Server

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez une valeur comprise entre 24 000 et 31 000 (décimal), puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour supprimer cet avertissement dans Windows Server 2003

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'optimisation de la mémoire d'Exchange Server, voir les articles suivants de la Base de connaissances :

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Le nombre d'appels permanents en attente d'une analyse antivirus est proche de la limite.
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, pour déterminer le nombre d'appels permanents entre composants adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au composant Virus API (VAPI).

Exchange Server Analyzer interroge également la clé ScanningThreads de l'entrée de Registre suivante pour déterminer le nombre maximum de threads autorisés pour les appels de composant VAPI :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, que le nombre d'appels permanents du service de banque d'informations de Microsoft Exchange (Store.exe) au composant VAPI est proche du nombre maximum de threads autorisé, il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange au composant VAPI peuvent être dus aux conditions suivantes :

  • Mises à jour d'un analyseur antivirus générant une nouvelle analyse des éléments contenus dans la banque d'informations.

  • Mauvaise configuration de l'analyseur antivirus

  • Traitement d'un message ou d'une pièce jointe volumineuse par l'analyseur antivirus

Pour résoudre cette erreur, procédez comme suit :

  • Planifiez les mises à jour de votre moteur antivirus à des moments où la consommation de ressources est faible (heures creuses au niveau de la demande).

  • Envisagez de réinstaller l'analyseur antivirus, mais faites-le à des moments de faible demande.

  • Examinez la configuration de votre moteur d'analyse antivirus pour vérifiez que vous disposez d'une configuration correcte des threads, d'exclusions au niveau des fichiers, etc. Voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Augmentez le nombre de threads pour l'API d'analyse antivirus :

    La valeur optimale de ScanningThreads est (2 * NombreDeProcesseurs) + 1. Par exemple, si le serveur exécutant Exchange Server est équipé de deux processeurs, la valeur optimale de ScanningThreads est 5.

    Remarque :
    S'il est équipé de la technologie Hyper-Threading, la valeur de NumberOfProcessors double le nombre de processeurs physiques. Il est recommandé de contacter le fabricant de votre logiciel antivirus pour déterminer si des processeurs physiques ou logiques peuvent être utilisés par la formule ci-dessus.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour augmenter le nombre de threads

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Dans le volet droit, double-cliquez sur ScanningThreads.

  4. Entrez la valeur renvoyée par la formule précédente.

  5. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Pour plus d'informations sur la technologie Hyper-Threading, voir le site Web d'Intel (http://www.intel.com/technology/hyperthread).

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Le fichier OABGEN.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs des fichiers ci-dessus sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Obtention du dernier correctif cumulatif/Service Pack de Exchange Server 5.0
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus STORE.EXE. Si Exchange Server Analyzer détermine que la valeur de la clé Version pour STORE.EXE est supérieure ou égale à 1460 et inférieure à 1462, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server n'exécute pas le dernier code disponible pour la version d'Exchange utilisée sur l'ordinateur.

Pour supprimer cet avertissement

  1. Visitez le Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=41361) pour télécharger la dernière mise à jour (avril 2004) d'Exchange Server 5.0.

  2. Pour des informations relatives à cette mise à jour, voir l'article 834130 de la Base de connaissances Microsoft sur les correctifs de mise à jour Microsoft Exchange Server 5.0 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130).

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Appliquez la mise à jour d'avril 2004.

Pour obtenir le dernier correctif cumulatif pour Exchange Server 5.0 Service Pack 2, voir l'article 168858 de la Base de connaissances sur la procédure pour obtenir la version d'Exchange Server 5.0 Service Pack 2 pour les États-Unis (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858).

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article 328839 de la Base de connaissances sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Obtenir le dernier correctif cumulatif/Service Pack de Exchange Server 5.5
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus STORE.EXE. Si Exchange Server Analyzer détermine que la clé Version pour STORE.EXE possède une valeur supérieure ou égale à 2653 et inférieure à 2658, un avertissement s'affiche. Ceci indique que l'ordinateur exécute Exchange Server 5.5 Service Pack 4 ou Exchange Server 5.5 Service Pack 4 avec correctifs.

Cet avertissement indique que l'ordinateur Exchange Server n'exécute pas le dernier code disponible pour la version d'Exchange utilisée sur l'ordinateur.

Pour supprimer cet avertissement

  1. Visitez le Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=33456) pour télécharger la dernière mise à jour (novembre 2004) d'Exchange Server 5.5.

  2. Découvrez les informations relatives à cette mise à jour dans l'article 841765 de la Base de connaissances Microsoft sur le correctif cumulatif de novembre 2004 pour Exchange Server 5.5 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765).

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Appliquez la mise à jour de novembre 2004.

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article de la Base de connaissances Microsoft sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Obtention du dernier correctif cumulatif/Service Pack de Exchange Server 2003
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus STORE.EXE.

  • La valeur 7638 pou la clé Version indique Exchange Server 2003 Service Pack 2.

  • La valeur 7226 pou la clé Version indique Exchange Server 2003 Service Pack 1.

  • La valeur 6944 pour la clé Version indique la version originale d'Exchange Server 2003.

  • Une valeur comprise entre les versions ci-dessus indique que le serveur exécute une version de mise à jour du correctif du processus Store.exe.

Si Exchange Server Analyzer détermine que la valeur de la clé Version pour Store.exe est inférieure à 7638, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server n'exécute pas le dernier code disponible pour la version d'Exchange Server utilisée sur l'ordinateur.

Pour supprimer cet avertissement

  1. Téléchargez ou commandez le Service Pack 2 pour Exchange Server 2003 sur le site Web « Exchange Server 2003 Service Pack 2 » (http://go.microsoft.com/fwlink/?LinkId=54751).

  2. Voir les notes de mise à jour du Service Pack 2 sur le site Web Exchange Server 2003 Service Pack 2 (SP2) (http://go.microsoft.com/fwlink/?LinkId=52072).

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Appliquez le Service Pack 2 pour Exchange Server 2003.

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article de la Base de connaissances Microsoft sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Obtention du dernier correctif cumulatif/Service Pack de Exchange 2000 Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus STORE.EXE. Si Exchange Server Analyzer détermine que la valeur de la clé Version pour STORE.EXE n'est pas comprise dans les plages suivantes, un avertissement s'affiche :

  • supérieure à 6249 et inférieure ou égale à 6396 ;

  • supérieure à 6396 et inférieure ou égale à 6487 ;

  • supérieure à 6487 et inférieure ou égale à 6556 ;

  • supérieure à 6556 et inférieure ou égale à 6603 ;

  • supérieure à 6603 et inférieure à 6700.

Cet avertissement indique que l'ordinateur Exchange Server n'exécute pas le dernier code disponible pour la version d'Exchange utilisée sur l'ordinateur.

Pour supprimer cet avertissement

  1. Téléchargez la dernière mise à jour (août 2004) sur le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).

  2. Pour plus d'informations sur la dernière mise à jour, voir l'article 870540 de la Base de connaissances Microsoft sur la disponibilité du correctif cumulatif post-Service Pack 3 Exchange 2000 Server et daté d'août 2004 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Appliquez la mise à jour août 2004.

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article 328839 de la Base de connaissances sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Le serveur de Carnet d'adresses en mode hors connexion a été supprimé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut offLineABServer de l'objet de configuration du Carnet d'adresses en mode hors connexion. Si Exchange Server Analyzer détecte que la valeur de l'attribut offLineABServer contient la chaîne DEL:, une erreur s'affiche.

L'attribut offLineABServer est un attribut de nom unique qui stocke le nom unique de l'ordinateur Exchange Server responsable de la génération d'un Carnet d'adresses hors connexion. Pour chaque Carnet d'adresses en mode hors connexion, Exchange génère et stocke les fichiers correspondants dans un ensemble de dossiers publics sur un serveur spécifié. Cette erreur indique que le serveur spécifié dans l'attribut offLineABServer de l'objet de configuration du Carnet d'adresses en mode hors connexion n'existe pas. Cette situation peut survenir lorsque l'ancien serveur de Carnet d'adresses en mode hors connexion a été désactivé ou supprimé de manière incorrecte de la topologie. Exchange ne génère pas de Carnet d'adresses en mode hors connexion tant qu'aucun nouveau serveur n'a été spécifié.

Correction de cette erreur dans Exchange 2000 Server et Exchange Server 2003

  1. Dans le Gestionnaire système Exchange, sous Destinataires, cliquez sur Listes d'adresses en mode hors connexion. Dans le volet droit, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut (ou toute autre liste d'adresses en mode hors connexion générant ce message), puis cliquez sur Propriétés.

  2. Sous l'onglet Général, sous Serveur de liste d'adresses en mode hors connexion, cliquez sur Parcourir, puis cliquez sur le serveur que vous voulez utiliser.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez Exchange Management Console.

  2. Développez Microsoft Exchange et Configuration de l'organisation, puis sélectionnez Boîte aux lettres.

  3. Dans le volet des résultats, cliquez sur l'onglet Carnet d'adresses en mode hors connexion.

  4. Sous l'onglet Carnet d'adresses en mode hors connexion, sélectionnez « Carnet d'adresses en mode hors connexion par défaut ». Dans le volet Actions, cliquez sur Déplacer pour démarrer l'Assistant Déplacement du carnet d'adresses en mode hors connexion. Cet Assistant permet de déplacer la génération de l'OAB vers un autre serveur. Elle copie également les fichiers de l'OAB sur le serveur spécifié.

Utilisation d'Exchange Management Shell pour définir le serveur qui hébergera la génération du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB et <Server> spécifie le serveur Exchange sur lequel exécuter l'opération sélectionnée.

    Par exemple, pour déplacer la génération de l'OAB vers le serveur SERVER01, vous devez entrer :
Copier le code
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2003, consultez la section sur la configuration de carnets d'adresses en mode hors connexion dans Exchange Server 2003 dans le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation des carnets d'adresses en mode hors connexion dans Exchange Server 2007, consultez la page « Configuration de l'organisation > Boîte aux lettres > Carnets d'adresses en mode hors connexion » (http://go.microsoft.com/fwlink/?LinkId=79247).


Serveur du Carnet d'adresses en mode hors connexion en cours d'exécution sur un serveur frontal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut offLineABServer de l'objet de configuration du Carnet d'adresses en mode hors connexion. L'attribut offLineABServer est un attribut de nom unique qui stocke le nom unique de l'ordinateur Exchange Server responsable de la génération d'un Carnet d'adresses hors connexion.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Exchange_Server Microsoft pour déterminer la valeur de la clé IsFrontEndServer pour le serveur Exchange. Si la valeur de la clé IsFrontEndServer est True, le serveur Exchange agit comme un serveur frontal.

Si Exchange Server Analyzer détecte qu'un Carnet d'adresses en mode hors connexion désigné est également un serveur frontal, il affiche un message d'erreur.

Cette erreur indique que le serveur Exchange désigné pour la génération du Carnet d'adresses en mode hors connexion est un serveur frontal. Si le serveur de Carnet d'adresses en mode hors connexion désigné est également un serveur frontal, la génération du Carnet d'adresses en mode hors connexion échoue. Un nouveau serveur doit être désigné pour cette tâche. Si un serveur exécutant Microsoft Exchange 2000 Server avec Service Pack 2 ou version ultérieure est désigné comme un serveur frontal, les services suivants ne fonctionnent plus :

  • DSProxy ;

  • génération de listes d'adresses en mode hors connexion ;

  • service de mise à jour de destinataire ;

  • tâches disponibles/occupées ;

  • Mailbox Cleanup Agent (agent de nettoyage de boîtes aux lettres) ;

  • service Événements Exchange ;

  • service de réplication de sites (SRS).

Les serveurs frontaux sont désignés pour gérer des demandes entrantes des clients Microsoft Office Outlook® Web Access, POP3, IMAP4, Exchange ActiveSync, Outlook Mobile Access et Outlook configurés pour utiliser RPC sur HTTP. Les serveurs frontaux permettent parfois également de relayer des messages SMTP vers des serveurs Exchange internes.

Pour résoudre ce problème, il est recommandé de désigner un serveur Exchange principal comme serveur de Carnet d'adresses en mode hors connexion.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Listes d'adresses en mode hors connexion.

  3. Dans le volet droit, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis cliquez sur Propriétés.

    Remarque :
    Effectuez la même procédure pour tout autre liste d'adresses en mode hors connexion qui génère ce message.

  4. Sous l'onglet Général, sous Serveur de liste d'adresses en mode hors connexion, cliquez sur Parcourir, puis cliquez sur le serveur Exchange principal que vous souhaitez utiliser.

Pour plus d'informations sur l'utilisation de Carnets d'adresses en mode hors connexion, voir la section sur la configuration de carnets d'adresses en mode hors connexion dans Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Dossier public du site Carnet d'adresses en mode hors connexion supprimé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut siteFolderServer de chaque objet de banque de dossiers publics. Si Exchange Server Analyzer détecte que la valeur de l'attribut siteFolderServer contient la chaîne DEL:, une erreur s'affiche.

L'attribut siteFolderServer représente la banque de dossiers publics utilisée pour le serveur du Carnet d'adresses en mode hors connexion. Par défaut, Exchange Server génère des fichiers de Carnet d'adresses en mode hors connexion sur le serveur de dossiers du site (le premier serveur installé dans le groupe d'administration). Si vous avez désigné un serveur différent pour faire office de serveur de Carnet d'adresses en mode hors connexion, la banque de dossiers publics répertoriée dans cet attribut sera celle sur le nouveau serveur de Carnet d'adresses en mode hors connexion et non celle sur le serveur de dossiers du site réel du groupe d'administration.

Lorsqu'Exchange Server 2003 génère des fichiers de Carnet d'adresses en mode hors connexion, il les annexe à des messages électroniques qu'il place ensuite dans des dossiers publics spéciaux. Microsoft Office Outlook® 2003 récupère les messages du dossier et télécharge les fichiers joints.

Les messages du Carnet d'adresses en mode hors connexion sont stockés dans des sous-dossiers du dossier Carnet d'adresses en mode hors connexion, qui est l'un des dossiers système de l'arborescence par défaut Dossiers publics. Ce dossier contient un sous-dossier pour chaque groupe d'administration ou site de votre topologie. Par défaut, un réplica du contenu d'un dossier de groupe d'administration spécifique réside sur le premier serveur installé dans le groupe d'administration (appelé serveur de dossiers du site).

Si votre organisation Exchange est une organisation Exchange Server 2007, sans client de niveau inférieur (Outlook 2003 ou version précédente), vous pouvez ignorer ce message d'avertissement ou d'erreur en toute sécurité. Si votre organisation Exchange Server 2007 héberge des clients exécutant Outlook 2003 ou une version antérieure, suivez la procédure ci-dessous pour activer la distribution des dossiers publics des fichiers du carnet d'adresses en mode hors connexion. La distribution des dossiers publics est la méthode de distribution par laquelle les clients exécutant Outlook 2003 ou une version antérieure qui travaillent en mode hors connexion ou via une connexion d'accès à distance accèdent au carnet d'adresses en mode hors connexion.

Pour corriger cette erreur

  1. Si vous êtes certain de l'existence du serveur, dans le Gestionnaire système Exchange, sous Serveurs, développez le serveur et le groupe de stockage, puis cliquez sur Banque de dossiers publics. Dans le volet droit, vérifiez que la banque d'informations Exchange est en cours d'exécution.

  2. Pour désigner un nouveau serveur de Carnet d'adresses en mode hors connexion, sous Destinataires, cliquez sur Listes d'adresses en mode hors connexion. Ensuite, dans le volet droit, cliquez sur Liste d'adresses en mode hors connexion par défaut (ou sur toute autre liste d'adresses en mode hors connexion qui génère ce message).

    Si vous ne souhaitez pas utiliser un Carnet d'adresses en mode hors connexion, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis sur Supprimer. Sinon, utilisez le reste de cette procédure pour définir une planification.

  3. Cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis cliquez sur Propriétés.

  4. Sous l'onglet Général, sous Serveur du Carnet d'adresses en mode hors connexion, cliquez sur Parcourir pour sélectionner un serveur.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez Exchange Management Console.

  2. Développez Microsoft Exchange et Configuration de l'organisation, puis sélectionnez Boîte aux lettres.

  3. Dans le volet des résultats, cliquez sur l'onglet Carnet d'adresses en mode hors connexion.

  4. Sous l'onglet Carnet d'adresses en mode hors connexion, sélectionnez « Carnet d'adresses en mode hors connexion par défaut ».

    1. Pour activer la distribution des dossiers publics du carnet d'adresses en mode hors connexion, sous l'onglet Distribution, sélectionnez Activer la distribution de dossier publics.

    2. Cliquez sur OK pour enregistrer les modifications.

  5. Pour désigner un nouveau serveur de carnet d'adresses en mode hors connexion, dans le volet Actions, cliquez sur Déplacer pour lancer l'Assistant Déplacement du carnet d'adresses en mode hors connexion. Cet Assistant permet de déplacer la génération de l'OAB vers un autre serveur. Il copie également les fichiers de l'OAB sur le serveur spécifié.

Utilisation d'Exchange Management Shell pour activer la distribution des dossiers publics des fichiers du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB.

    Par exemple, pour activer la distribution de dossiers publics du carnet d'adresses en mode hors connexion par défaut, vous devez entrer :
Copier le code
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Utilisation d'Exchange Management Shell pour définir le serveur qui hébergera la génération du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Où : <OAB> spécifie le nom unique (DN), le nom de domaine\compte ou le GUID de l'OAB et <Server> spécifie le serveur Exchange sur lequel exécuter l'opération sélectionnée.

    Par exemple, pour déplacer la génération de l'OAB vers le serveur SERVER01, vous devez entrer :
Copier le code
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Pour plus d'informations sur l'utilisation de carnets d'adresses en mode hors connexion dans Exchange Server 2003, consultez la section sur la configuration de carnets d'adresses en mode hors connexion dans Exchange Server 2003 dans le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation des carnets d'adresses en mode hors connexion dans Exchange Server 2007, consultez la page « Configuration de l'organisation > Boîte aux lettres > Carnets d'adresses en mode hors connexion » (http://go.microsoft.com/fwlink/?LinkId=79247).


Ancien fichier CDO.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier DAVEX.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Fichier DRVIIS.DLL plus ancien détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • DrvIis.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe lequel de ces fichiers est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique l'utilisation possible de fichiers obsolètes.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou d'Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que des fichiers binaires. Le mode Réinstallation ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou mises à jour d'Exchange qui ont été installés.

Réinstallation d'Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous voulez réinstaller Exchange. Insérez le CD Exchange 2000 Server ou Exchange Server 2003 dans le lecteur.

  2. Cliquez sur Démarrer, sur Exécuter, puis tapez <lecteur>:\setup\i386\setup, où <lecteur> désigne le lecteur de CD.

  3. Dans la page d'accueil de l'Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Dans la page Contrat de licence, lisez le contrat. Si vous acceptez les termes du contrat, cliquez sur J'accepte, puis sur Suivant.

  5. Dans la page Identification du produit, tapez votre clé du produit à 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, les correctifs cumulatifs et les compléments, consultez le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, les correctifs cumulatifs et les compléments, consultez le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier DSACCESS.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EMSMTA.EXE détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EPOXY.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier ESE.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-06-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier ESEUTIL.EXE détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXCDO.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXCHMEM.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXCHMEM.DLL présent
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange Server. Ces fichiers comprennent le fichier Exchmem.dll. Si Exchange Server Analyzer détermine que le fichier Exchmem.dll du dossier \%systemroot%\system32 est antérieur au fichier Exchmem.dll du dossier \%exchangeroot%\bin, il affiche un avertissement.

En principe, deux copies d'Exchmem.dll ne peuvent pas exister sur un serveur. Toutefois, un second fichier Exchmem.dll est parfois ajouté avec une mise à niveau en place des versions précédentes du produit. La présence de deux versions du fichier peut provoquer l'échec du paramétrage lors de l'installation des versions de service. Pour éviter tout problème, il est recommandé de renommer le fichier Exchmem.dll du dossier \%systemroot%\system32.

Pour supprimer cet avertissement

  1. Arrêtez tous les services Exchange.

  2. Renommez le fichier Exchmem.dll du dossier \%systemroot%\system32 en Exchmem.dll.old.

  3. Redémarrez tous les services Exchange.


Ancien fichier EXMIME.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXOLEDB.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXPOP3.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXPROX.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXRES.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier EXSMTP.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier MAD.EXE détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier MAPI32.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier MAPI32.DLL détecté dans le dossier system32
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier MDBSZ.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier OABGEN.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier PHATCAT.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier PHATQ.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier REAPI.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Ancien fichier RESVC.DLL détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe quel fichier ci-dessus est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être en cours d'utilisation.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Fichier STORE.EXE plus ancien détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) CIM_Datafile pour déterminer la valeur de la clé Version pour plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte que la valeur Version de n'importe lequel de ces fichiers est inférieure à la valeur Version d'Exchange Server, un avertissement s'affiche. Un numéro de version antérieure indique que des fichiers obsolètes sont peut-être utilisés.

Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou d'Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que des fichiers binaires. Le mode Réinstallation ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou mises à jour d'Exchange qui ont été installés.

Réinstallation d'Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous voulez réinstaller Exchange. Insérez le CD Exchange 2000 Server ou Exchange Server 2003 dans le lecteur.

  2. Cliquez sur Démarrer, sur Exécuter, puis tapez <lecteur>:\setup\i386\setup, où <lecteur> est le lecteur de CD.

  3. Dans la page d'accueil de l'Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Dans la page Contrat de licence, lisez le contrat. Si vous acceptez les termes du contrat, cliquez sur J'accepte, puis sur Suivant.

  5. Dans la page Identification du produit, tapez votre clé du produit à 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, les correctifs cumulatifs et les compléments, consultez le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, les correctifs cumulatifs et les compléments, consultez le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Détection d'appels permanents adressés à Active Directory
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-14

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant des appels permanents entre composants adressés par le service de banque d'informations Exchange (Store.exe) au service d'annuaire Active Directory®.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Active Directory fournit toutes les informations de boîtes aux lettres, les services de listes d'adresses et d'autres informations liées aux destinataires. La plupart des informations de configuration d'Exchange Server 2003 sont également stockées dans Active Directory.

Les services d'Exchange Server accèdent aux informations contenues dans Active Directory et y écrivent des informations.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant des appels permanents du service de banque d'informations de Microsoft Exchange (Store.exe) à Active Directory, il affiche un avertissement.

Cet avertissement indique que des problèmes de performances peuvent survenir sur ce serveur. Des appels permanents occasionnels ne sont pas nécessairement le signe d'un problème, mais des appels permanents répétés à la même zone peuvent l'être.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange à Active Directory peuvent être dus aux conditions suivantes :

  • Latence du réseau entre le serveur Exchange et le contrôleur de domaine.

  • Configuration statique ou généralement incorrecte de DSAccess.

  • Surcharge du contrôleur de domaine et du catalogue global.

  • Conception incorrecte de la topologie Active Directory.

Pour résoudre cet avertissement, procédez comme suit :

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Vérifiez les performances des serveurs contrôleurs de domaine Active Directory.

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les performances d'Exchange et sur DSAccess, voir l'article 250570 de la Base de connaissances Microsoft sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Pour plus d'informations sur les performances des contrôleurs de domaine, voir les ressources Windows Server suivantes :

  • document sur la planification de la capacité des contrôleurs de domaine (http://go.microsoft.com/fwlink/?LinkId=70191).

  • rubrique sur la surveillance des contrôleurs de domaine dans Active Directory, dans les Guides de planification et de déploiement d'Active Directory dans Windows 2000 Server (http://go.microsoft.com/fwlink/?LinkId=70193).


Détection d'appels permanents au moteur ESE
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant des appels permanents entre composants adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au moteur Exchange Extensible Storage Engine (ESE).

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Le service de banque d'informations de Microsoft Exchange opère par-dessus une base de données ESE. ESE est un moteur de base de données sophistiqué à base de transactions. Une transaction est une série d'opérations traitées comme une unité atomique (indivisible). Soit toutes les opérations d'une transaction sont achevées et enregistrées de manière permanente, soit aucune opération n'est effectuée.

Exchange Server utilise ESE comme un moteur de base de données incorporé qui détermine la structure des bases de données et gère la mémoire. Ce moteur de base de données met en cache les bases de données en transférant des blocs de données (pages) vers et depuis la mémoire. Il met à jour les pages en mémoire et écrit sur le disque les pages nouvelles ou mises à jour. Lorsque des demandes parviennent au système, le moteur de base de données peut fournir les données se trouvant en mémoire. Il ne doit donc pas constamment accéder au disque.

Bien que la mise en cache mémoire de données soit le mode de traitement des données le plus rapide et le plus efficace, elle signifie aussi, lorsqu'Exchange est exécuté, que les informations sur le disque ne sont jamais entièrement à jour. La version la plus récente de la base de données se trouve en mémoire. Cependant, puisque de nombreuses modifications effectuées en mémoire ne sont pas encore transcrites sur le disque, la base de données et la mémoire ne sont pas synchronisées. Le disque contenant le journal des transactions est toujours tenu à jour avec les informations relatives à chaque transaction.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant des appels permanents du service de banque d'informations de Microsoft Exchange (Store.exe) à la base de données Extensible Storage Engine (ESE), il affiche un avertissement.

Cet avertissement indique que des problèmes de performances peuvent survenir sur ce serveur. Des appels permanents occasionnels ne sont pas nécessairement le signe d'un problème, mais des appels permanents répétés à la même zone peuvent l'être.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations de Microsoft Exchange au composant ESE peuvent être dus aux conditions suivantes :

  • Défragmentation en ligne d'Exchange.

  • Sauvegardes de données.

    Remarque :
    Si une sauvegarde de données ou une défragmentation en ligne était en cours pendant la collecte des données de journal Exchange Call Trace, vous pouvez ignorer sans crainte cet avertissement censé indiquer un problème de performances d'Exchange Server
  • Des goulets d'étranglement sur les lecteurs de base de données, par exemple une capacité insuffisante pour le nombre d'utilisateurs du serveur.

  • Des goulets d'étranglement sur les lecteurs TEMP et TMP.

Pour résoudre cette erreur, procédez comme suit :

  • Nous recommandons de ne pas faire chevaucher les fenêtres de sauvegarde ou la maintenance en ligne et des moments d'intenses demandes des utilisateurs.

  • Assurez-vous que les lecteurs de disque de la base de données sont en bon état et offrent un débit suffisant pour la charge d'E/S.

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur tels que les limites de taille des messages et des pièces jointes. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur la procédure de configuration des fenêtres de défragmentation en ligne, voir l'article 244524 de la Base de connaissances Microsoft sur la procédure de configuration de la fenêtre de défragmentation en ligne d'Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Pour plus d'informations sur les problèmes de goulet d'étranglement de disque d'Echange Server, voir la rubrique sur le Goulot d'étranglement de disque détecté.

Pour plus d'informations sur la procédure de dimensionnement et d'optimisation de disques pour Exchange Server, voir les sections sur la procédure de calcul des besoins d'E/S de disque et sur les pratiques recommandées communes à diverses architectures dans la rubrique sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Pour plus d'informations sur ESE, voir la rubrique sur l'architecture Extensible Storage Engine (http://go.microsoft.com/fwlink/?linkid=67009).


Détection d'appels permanents à IMail
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant des appels permanents entre composants adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au composant IMAIL du client MAPI.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Le composant IMAIL d'Exchange Server est un service de conversion flexible utilisé par le service de banque d'informations de Microsoft Exchange entre Internet et les messages MAPI. Il assure ainsi l'interopérabilité entre les clients utilisant RFC-822 ou un format Internet et les clients qui utilisent le format de stockage interne d'Exchange Server, tels que les clients MAPI ou les tâches de stockage internes.

Exchange utilise le mécanisme IMAIL pour appliquer des formats de message au contenu, selon les paramètres définis pour les domaines Internet dans le Gestionnaire système Exchange ou selon les spécifications de l'utilisateur pour chaque destinataire dans Microsoft Office Outlook®. Si aucun paramètre de format n'est transmis à IMAIL, IMAIL formate les messages MAPI au format Summary TNEF (S/TNEF) pour les transferts entre serveurs.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant des appels permanents du service de banque d'informations de Microsoft Exchange (Store.exe) au composant MAPI, il affiche un avertissement.

Cet avertissement indique que des problèmes de performances peuvent survenir sur ce serveur. Des appels permanents occasionnels ne sont pas nécessairement le signe d'un problème, mais des appels permanents répétés à la même zone peuvent l'être.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations d'Exchange au composant IMAIL du client MAPI peuvent se produire lorsqu'une ou plusieurs des conditions suivantes sont remplies :

  • IMAIL essaie de traiter des données volumineuses dans un message ou une pièce jointe.

  • De nombreux clients demandent une conversion de données.

  • Les demandes DSAccess obtiennent des réponses lentes.

  • Des goulets d'étranglement affectent les lecteurs TEMP et TMP.

  • Il existe des déplacements permanents de boîtes aux lettres.

Pour résoudre cet avertissement, procédez comme suit :

  • Planifiez les déplacements de boîtes aux lettres à des moments de faible demande.

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur tels que les limites de taille des messages et des pièces jointes. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les problèmes de goulets d'étranglement de disque avec Exchange Server, voir la rubrique sur le Goulot d'étranglement de disque détecté.

Pour plus d'informations sur la procédure de dimensionnement et d'optimisation de disques pour Exchange Server, voir les sections sur la procédure de calcul des besoins d'E/S de disque et sur les pratiques recommandées communes à diverses architectures dans la rubrique sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Pour plus d'informations sur les pratiques recommandées en termes de limite de taille des messages sur Exchange Server, voir la rubrique sur La taille maximale des messages sortants n'a pas été définie.

Pour plus d'informations sur DSAccess et les performances d'Exchange Server, voir la rubrique sur la procédure de configuration du cache utilisateur DSAccess dans le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Détection d'appels permanents adressés à LSASS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant une prédominance d'appels permanents entre composants adressés par le service de banque d'informations Exchange (Store.exe) au processus Lsass.exe.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Le processus Lsass.exe est un sous-système de sécurité invoqué par d'autres processus pour vérifier les informations de compte et la validation de la connexion.

Toute connexion de client Exchange provoque l'envoi, par le serveur qui exécute Exchange Server, d'une demande visant à consulter l'identificateur de sécurité du compte (SID) du client et crée un appel à l'intérieur du processus Lsass.exe.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant une prédominance d'appels permanents du service de banque d'informations Microsoft Exchange (Store.exe) au processus Lsass.exe, il affiche un avertissement.

Cet avertissement indique que des problèmes de performances peuvent survenir sur ce serveur. Des appels permanents occasionnels ne sont pas nécessairement le signe d'un problème, mais des appels permanents répétés à la même zone peuvent l'être.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations d'Exchange au processus LSASS peuvent être dus aux conditions suivantes :

  • problèmes de ressources serveur liés au nombre d'utilisateurs qui s'authentifient en même temps ;

  • latence du réseau entre le serveur Exchange et le contrôleur de domaine ou le serveur de catalogue global ;

  • problèmes de goulet d'étranglement au niveau des ressources du serveur.

Pour résoudre cet avertissement, procédez comme suit :

  • Envisagez d'implémenter le paramètre NeverPing de la manière décrite dans le document Paramètre « NeverPing » recommandé.

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur le processus Lsass.exe et l'utilisation de la mémoire, voir l'article 308356 de la Base de connaissances Microsoft sur l'utilisation de la mémoire par le processus Lsass.exe sur les contrôleurs de domaine qui exécutent Windows Server 2003 ou Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

Pour plus d'informations sur les connexions client Exchange et les problèmes de LSASS, voir l'article 161938 de la Base de connaissances Microsoft sur la lenteur des connexions client Exchange en raison d'un blocage des ressources (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Pour plus d'informations sur la latence du réseau entre le serveur Exchange et le contrôleur de domaine ou le serveur de catalogue global, voir l'article sur le site des billets de l'équipe Microsoft Exchange relatif au fait qu'Exchange n'utilise pas toujours des serveurs de catalogue locaux (http://go.microsoft.com/fwlink/?LinkId=69166).

Remarque :
Le contenu de chaque blog et leur URL sont susceptibles d'être modifiés sans préavis.

Pour plus d'informations sur les problèmes de goulet d'étranglement au niveau des ressources du serveur, voir la rubrique sur les Goulot d'étranglement de processeur.

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Appels permanents vers l'analyse antivirus détectés
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements indiquant des appels permanents entre composants adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au composant Virus API (VAPI) de Virusscan.

Des appels permanents sont des demandes adressées par le service de banque d'informations de Microsoft Exchange (Store.exe) à d'autres composants et restant sans réponse au moment où les données FCL d'Exchange sont écrites dans le fichier Store.fcl.

Si Exchange Server Analyzer détecte, dans le fichier Store.fcl, des événements reflétant des appels permanents du service de banque d'informations de Microsoft Exchange (Store.exe) au composant VAPI, il affiche un avertissement.

Cet avertissement indique que des problèmes de performances peuvent survenir sur ce serveur. Des appels permanents occasionnels ne sont pas nécessairement le signe d'un problème, mais des appels permanents répétés à la même zone peuvent l'être.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis le service de banque d'informations d'Exchange au composant VAPI peuvent être dus aux conditions suivantes :

  • Mises à jour d'un analyseur antivirus générant une nouvelle analyse des éléments contenus dans la banque d'informations.

  • Mauvaise configuration de l'analyseur antivirus

  • Traitement d'un message ou d'une pièce jointe volumineuse par l'analyseur antivirus

Pour résoudre cet avertissement, procédez comme suit :

  • Planifiez les mises à jour de votre moteur antivirus à des moments où la consommation de ressources est faible (heures creuses au niveau de la demande).

  • Envisagez de réinstaller l'analyseur antivirus, mais faites-le à des moments de faible demande.

  • Examinez la configuration de votre moteur d'analyse antivirus pour vérifiez que vous disposez d'une configuration correcte des threads, d'exclusions au niveau des fichiers, etc. Voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


La valeur GlobalFlag du système d'exploitation a été définie
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de l'entrée GlobalFlag :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

Si Exchange Server Analyzer détecte que la valeur de GlobalFlag est présente et configurée avec toute valeur autre que 0 ou null, un avertissement s'affiche.

  • La valeur de Registre GlobalFlag est un masque de bits qui détermine les options de débogage activées pour le système d'exploitation. Sauf si vous êtes activement impliqué dans le débogage ou le suivi d'un problème avec l'aide des services du Support Technique de Microsoft, il est recommandé de toujours définir la valeur GlobalFlag sur 0.

La valeur de Registre GlobalFlag est définie sur 0 par défaut. Si cette valeur a été modifiée et diffère de sa valeur par défaut de 0, vous pouvez utiliser l'outil Gflags fourni avec les outils de support de Microsoft Windows Server™ 2003, qui se trouvent sur le CD-ROM Windows dans le dossier \Support. Vous pouvez également définir manuellement cette valeur sur 0 à l'aide d'un Éditeur du Registre. Les deux procédures sont décrites ci-dessous.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur à l'aide de GFlags

  1. Cliquez sur Démarrer, puis sur Exécuter et dans le champ Ouvrir, entrez GFlags. L'interface utilisateur Global Flags s'affiche.

  2. Désactivez toutes les cases à cocher, puis cliquez sur Apply (Appliquer).

  3. Cliquez sur OK pour quitter l'outil GFlags et redémarrer l'ordinateur pour que la modification soit prise en compte.

Pour corriger cette erreur à l'aide d'un Éditeur du Registre

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\ System\CurrentControlSet\Control\Session Manager

  3. Double-cliquez sur la valeur appelée GlobalFlag et définissez-la sur 0.

  4. Quittez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).


Le système d'exploitation est en mode débogage
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer si une valeur est définie pour la propriété Debug. Si la valeur de cette clé sur un ordinateur Exchange Server est définie sur True, une erreur s'affiche.

Le mode de débogage Windows est activé en ajoutant le paramètre /debug dans le fichier Boot.ini. Lorsque /debug est spécifié dans le fichier Boot.ini d'un ordinateur Windows Server, le débogueur de noyau est chargé pendant le démarrage et mémorisé toutes les fois. Cela permet à un technicien du support technique d'appeler le système en cours de débogage et de s'arrêter dans le débogueur lorsque le système n'est pas interrompu au niveau de l'écran ARRÊT du noyau. À la différence du commutateur /crashdebug, le commutateur /debug utilise le port COM selon le débogage ou non. Ce commutateur est utilisé lors de la résolution de problèmes qui se reproduisent régulièrement. Il est probable que le paramètre /debug ait été défini comme un moyen de résoudre un problème et laissé involontairement ainsi.

En raison des processus supplémentaires en cours d'exécution, les performances sont considérablement affectées. Par conséquent, il n'est pas recommandé d'utiliser Exchange Server sur un ordinateur où Windows s'exécute en mode débogage.

Pour corriger cette erreur, modifiez le fichier Boot.ini et supprimez le paramètre /debug.

Pour corriger cette erreur

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système. Cette partition contient les fichiers spécifiques de matériel, tels que Boot.ini et NTLDR.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Lorsque vous y êtes invité, cliquez sur Oui.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier, cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez le paramètre /debug.

  5. Enregistrez le fichier et fermez-le, puis redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur les paramètres pouvant être utilisés dans le fichier Boot.ini, voir l'article 833721 de la Base de connaissances Microsoft sur les options de commutateurs disponibles pour les fichiers Boot.ini Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833721).


Outlook Web Access nécessite le correctif Windows Server 2003 SP1
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-08-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge différentes classes WMI (Windows® Management Instrumentation) Microsoft pour collecter les informations suivantes :

  • Sur quelle version du système d'exploitation Microsoft Windows Server Exchange Server est-il installé ?

  • Le serveur Exchange est-il exécuté sur un cluster ?

Si Exchange Server Analyzer détermine que toutes les conditions suivantes sont vraies, un avertissement s'affiche :

  • Le Service Pack 1 (SP1) d'Exchange Server 2003 est installé.

  • Microsoft Windows Server™ 2003 SP1 n'est pas installé.

  • Le service de cluster est exécuté.

  • La valeur Version de Davex.dll est inférieure à 6.5.7232.

Si vous disposez d'une telle configuration, vous devez télécharger et installer un correctif Exchange Server avant d'installer Windows Server 2003 SP1. Si vous n'installez pas le correctif Exchange Server, les utilisateurs Microsoft Office Outlook® Web Access pour Exchange Server 2003 ne pourront pas se connecter à leurs boîtes aux lettres. Le message d'erreur suivant s'affichera pour les utilisateurs ayant des boîtes aux lettres hébergées sur les clusters lorsqu'ils essayeront de se connecter à l'aide d'Outlook Web Access :

  • « 500 - Erreur interne au serveur »

Cette erreur provient de certaines des améliorations en matière de sécurité comprises dans Windows Server 2003 SP1.

Lorsqu'un utilisateur tente de se connecter à une boîte aux lettres à l'aide d'Outlook Web Access, le protocole HTTP envoie des requêtes aux clusters API en se faisant passer pour l'utilisateur connecté. Toutefois, des modifications de sécurité ont été apportées dans Windows Server 2003 SP1. Les restrictions de sécurité pour les API exécutant l'accès au Registre distant ont été modifiées. C'est pourquoi la tentative de connexion échoue.

Pour corriger cette erreur, vous devez télécharger et installer le correctif Exchange Server décrit dans l'article 841561 de la Base de connaissances Microsoft sur l'apparition du « Message d'erreur 500 - Erreur interne au serveur » lorsqu'un utilisateur tente d'accéder à un serveur principal Exchange Server 2003 en clusters à l'aide d'Outlook Web Access (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561).


Problème de correspondance du fichier de modèle Outlook Web Access
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer le numéro de version du fichier Wmtemplates.dll. Exchange Server Analyzer compare ensuite le numéro de version de Wmtemplates.dll sur tous les serveurs du groupe d'administration. Si Exchange Server Analyzer détecte que le numéro de version de Wmtemplates.dll ne correspond pas entre les serveurs Exchange principaux et frontaux, il affiche un message de recommandation.

Le fichier Wmtemplates.dll est utilisé par les commandes Microsoft Office Outlook® Web Access. Des versions de Wmtemplates.dll présentant des problèmes de correspondance sur les serveurs Exchange frontaux et principaux peuvent entraîner des erreurs de niveau 400 si les utilisateurs essaient de se connecter à Outlook Web Access en accédant au serveur Exchange frontal.

Microsoft a récemment sorti deux mises à jour de Wmtemplates.dll :

  • l'article sur le service de banque d'informations Microsoft Exchange qui bloque périodiquement après l'installation d'Exchange Server 2003 SP1 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963)

  • l'article sur le contrôle S/MIME qui ne charge pas dans OWA lors de l'exécution d'un client OWA Exchange Server 2003 sur un ordinateur Windows XP Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=883543)

Si vous avez récemment installé l'une de ces mises à jour, les conditions suivantes peuvent être vraies :

  • Les mises à jour n'étaient pas installées dans l'ordre correct.

  • La mise à jour n'était pas installée sur les serveurs frontaux et principaux.

Lorsque vous installez des mises à jour d'Outlook Web Access, vous devez les installer sur le serveur frontal, redémarrer le serveur, puis les installer sur le serveur principal.

Si vous n'avez pas installé ces mises à jour, veillez à ce que tous les serveurs exécutent au moins les Service Packs et mises à jour Exchange Server les plus récents.

Pour plus d'informations sur les derniers Service Packs et mises à jour d'Exchange Server, voir les sites Web suivants :

  • le site des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21236).

  • le site des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Les demandes RPC en attente ont atteint le seuil maximal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance RPC Requests de l'objet de performance MSExchangeIS pour les analyser.

Si Exchange Server Analyzer détermine que le nombre de demandes RPC a atteint la valeur maximale de 100 pendant une période-exemple, il affiche une erreur.

Le compteur de performance RPC Requests indique le nombre de demandes d'appel de procédure à distance (RPC) MAPI ou client en cours de traitement par le service de banque d'informations de Microsoft Exchange. La valeur moyenne du compteur de performance RPC Requests doit être inférieure à 30 par seconde. Par défaut, la valeur maximale pour les demandes RPC est 100. Dès lors, sauf configuration différente, le service de banque d'informations de Microsoft Exchange ne peut traiter que 100 demandes RPC à la fois avant que toutes les nouvelles opérations RPC ne soient rejetées et que les utilisateurs ne puissent plus se connecter au serveur jusqu'à ce que les demandes RPC redeviennent inférieures à 100. Le serveur ne répond plus et le flux de messages peut être bloqué. La boîte de dialogue Requête d'annulation RCP peut s'afficher pour les utilisateurs Outlook.

Cette erreur indique que le serveur rencontre un goulot d'étranglement de performances ou qu'une procédure ne répond plus.

Un goulot d'étranglement de performances peut être lié au processeur, au disque, au réseau ou à la mémoire et dû à un accroissement de la charge sur le serveur ou à des ressources serveur insuffisantes. L'analyseur de performances (Perfmon.msc) permet de déterminer si le goulot d'étranglement est dû à une charge accrue sur le serveur ou si le serveur est sous-dimensionné. En cas d'augmentation de la charge du serveur, identifiez la source de la charge et réduisez-la. Si le serveur dispose de ressources suffisantes, augmentez les ressources nécessaires ou déplacez des utilisateurs du serveur.

Une procédure peut ne plus répondre car la banque d'informations attend une ressource qui ne retourne rien. Par exemple, un cluster perd le lecteur qui héberge le suivi des messages ou un problème d'analyse antivirus. Lorsqu'une procédure ne répond plus, les demandes RPC ne seront jamais retournées et la banque d'informations doit être redémarrée.

Pour plus d'informations

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la procédure de prévision des performances d'Exchange Server, voir le Document sur les 10 choses à savoir sur les performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=56460).

  • Pour plus d'informations sur la procédure de déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


Le fichier PHATCAT.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs des fichiers ci-dessus sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange Server 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le fichier PHATQ.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Windows CIM_Datafile pour rechercher plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs fichiers sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode Réinstallation n'installe que les fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Problème de performances du fichier d'échange
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets du compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte des données à partir des compteurs Avg Disk sec/Read et Avg Disk sec/Write pour l'instance PAGEDISK de l'objet de performance LogicalDisk pour les analyser.

Si Exchange Server Analyzer détermine que les compteurs Avg Disk sec/Read et Avg Disk sec/Write dépassent 10 millisecondes pendant une période-exemple, il affiche une erreur.

L'objet de performance LogicalDisk est constitué de compteurs tels que Avg Disk sec/Read et Avg Disk sec/Write qui surveillent les partitions logiques des disques durs. Le compteur de performance Avg Disk sec/Read indique le temps moyen, en secondes, de lecture de données du disque. Le compteur de performance Avg Disk sec/Write indique le temps moyen, en secondes, de l'écriture de données sur le disque. La valeur moyenne des compteurs de performance Avg Disk sec/Read et Avg Disk sec/Write doit être inférieure à 10 millisecondes.

L'instance PAGEDISK de l'objet de performance LogicalDisk sur un serveur représente le fichier d'échange (Pagefile.sys). Pagefile.sys est un fichier d'échange masqué sur le disque dur utilisé par Microsoft Windows® pour stocker des données temporaires lorsque votre système fonctionne avec une mémoire RAM faible. Le fichier d'échange est également appelé fichier de pagination.

Cette erreur indique qu'il existe un problème de latence avec le disque hébergeant le fichier d'échange.

Pour résoudre cette erreur, procédez comme suit :

  • Identifiez la cause de la latence. Si ce problème est dû à une pagination excessive, il peut être provoqué par des problèmes de mémoire du serveur.

  • Pensez à placer le fichier d'échange sur une partition dédiée ou sur un disque rapide.

  • Pensez à créer un fichier d'échange secondaire sur un autre lecteur comme décrit dans l'article 197379 de la Base de connaissances Microsoft sur la configuration du fichier d'échange pour optimisation et récupération dans Windows Server 2003, Windows 2000 et Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Exécutez les tâches de maintenance du serveur pendant les heures creuses. Si vous exécutez des outils, tels que les Utilitaires de base de données Exchange Server (comme Eseutil), ou des tâches de maintenance, comme la gestion de boîtes aux lettres, pendant les heures de pointe, vous pouvez utiliser de la mémoire qui, sinon, serait utilisée par Exchange. Il est recommandé d'exécuter ces outils et tâches pendant les heures creuses ou des périodes d'utilisation réduite.

Pour plus d'informations

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur l'optimisation du fichier d'échange, voir l'article 197379 de la Base de connaissances Microsoft sur la configuration des fichiers d'échange à des fins d'optimisation et de récupération dans Windows Server 2003, Windows 2000 et Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les meilleures pratiques de conception d'architectures de stockage, voir la rubrique sur les meilleures pratiques communes à diverses architectures (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Pour plus d'informations sur les taux d'E/S, la latence et le dimensionnement de disques, voir les billets suivants sur le site Web des billets de l'équipe Microsoft Exchange :

    • Billet sur les quelques concepts de base du dimensionnement de disques (en anglais) (http://go.microsoft.com/fwlink/?linkid=39538)

    • Billet sur des réflexions concernant les calculs et E/S disque (en anglais) (http://go.microsoft.com/fwlink/?linkid=39539)

    • Rubrique sur la procédure de calcul des besoins en E/S disque(http://go.microsoft.com/fwlink/?linkid=69747)


Le compteur Utilisation du fichier d'échange est supérieur à 50 %
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance % Usage de l'objet de performance Paging File pour les analyser.

Si Exchange Server Analyzer détermine que le compteur % Usage dépasse 50% pendant la période-exemple, il affiche une erreur.

Le fichier d'échange (Pagefile.sys) est un fichier système caché sur le disque dur utilisé par Windows pour stocker des données temporaires lorsque le système dispose de peu de RAM. Le fichier d'échange est également appelé fichier de pagination. L'utilisation du fichier d'échange affecte l'ensemble des performances car les opérations de disque prennent plus de temps que les opérations de mémoire. En outre, lorsque la pagination devient trop élevée, un goulot d'étranglement de disque peut survenir et les performances sont affectées. Dans ce cas, le réel problème est la mémoire et le goulot d'étranglement de disque n'est qu'un symptôme.

La contention de mémoire est tolérée jusqu'à ce que le système atteigne un point où il passe un temps considérable à gérer la mémoire limitée liée au temps nécessaire pour effectuer la tâche. Si vous créez un graphique représentant la contention de la mémoire par rapport aux temps de réponse moyens, une ligne régulière apparaît entre zéro et le point auquel les temps de réponse augmentent fortement. Ce point est appelé point d'effondrement. Alors que la contention de la mémoire augmente une fois ce point dépassé, les temps de réponses s'accroissent de manière exponentielle. L'effondrement temporaire peut être toléré dans certains environnements mais il est préférable de tout faire pour l'éviter.

Cette erreur indique qu'il existe un problème de performances avec le disque hébergeant le fichier d'échange. Finalement, ce problème peut être lié à une erreur de mémoire sur le serveur.

Pour résoudre cette erreur, procédez comme suit :

  • Pensez à créer un fichier d'échange secondaire sur un autre lecteur comme décrit dans l'article 197379 de la Base de connaissances Microsoft sur la configuration du fichier d'échange pour optimisation et récupération dans Windows Server 2003, Windows 2000 et Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Pensez à placer le fichier d'échange sur une partition dédiée ou sur un disque rapide.

  • Supprimez le logiciel superflu. Pour rendre davantage de ressources mémoire disponibles pour Exchange, supprimez les outils logiciels tiers qui exécutent des fonctions de surveillance ou tout type de services superflus. Le composant logiciel enfichable Performance (http://go.microsoft.com/fwlink/?LinkId=56118) peut vous aider à comprendre la quantité de mémoire que les applications consomment.

  • Exécutez les tâches de maintenance du serveur pendant les heures creuses. Si vous exécutez des outils, tels que les Utilitaires de base de données Exchange Server (comme Eseutil), ou des tâches de maintenance, comme la gestion de boîtes aux lettres, pendant les heures de pointe, vous pouvez utiliser de la mémoire qui, sinon, serait utilisée par Exchange. Il est recommandé d'exécuter ces outils et tâches pendant les heures creuses ou des périodes d'utilisation réduite.

  • Envisagez le déplacement des boîtes aux lettres utilisateur du serveur touché vers un autre serveur pour limiter la charge du serveur. Pour plus d'informations, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

Pour plus d'informations

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur l'optimisation du fichier d'échange, voir l'article 197379 de la Base de connaissances Microsoft sur la configuration des fichiers d'échange à des fins d'optimisation et de récupération dans Windows Server 2003, Windows 2000 et Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379).

  • Pour plus d'informations sur l'amélioration des performances de la mémoire, voir la rubrique Amélioration de la mémoire utilisateur.

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les meilleures pratiques de conception d'architectures de stockage, voir la rubrique sur les meilleures pratiques communes à diverses architectures (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Pour plus d'informations sur les taux d'E/S, la latence et le dimensionnement de disques, voir les billets suivants sur le site Web des billets de l'équipe Microsoft Exchange :

    • Billet sur les quelques concepts de base du dimensionnement de disques (en anglais) (http://go.microsoft.com/fwlink/?linkid=39538)

    • Billet sur des réflexions concernant les calculs et E/S disque (en anglais) (http://go.microsoft.com/fwlink/?linkid=39539)

    • Rubrique sur la procédure de calcul des besoins en E/S disque(http://go.microsoft.com/fwlink/?linkid=69747)


La valeur PageHeapFlags a été définie
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer la valeur de l'entrée PageHeapFlags :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Si Exchange Server Analyzer détecte que la valeur de PageHeapFlags est présente et configurée avec toute valeur autre que 0 ou null, un avertissement s'affiche.

L'option PageHeapFlags est utilisée en même temps que la valeur de Registre GlobalFlag décrite dans l'article La valeur GlobalFlag a été définie. L'option PageHeapFlags permet de sélectionner la vérification de segment de mémoire standard, qui écrit des schémas de remplissage à la fin de chaque allocation de segment de mémoire et les examine une fois les allocations libérées, ou la vérification de segment de mémoire pleine page. Cette opération place une page inaccessible à la fin de chaque allocation, de sorte que le programme s'arrête immédiatement s'il accède à la mémoire au-delà de l'allocation. Étant donné que la vérification de segment de mémoire pleine page utilise une page entière de mémoire pour chaque allocation, son utilisation étendue peut provoquer des insuffisances de mémoire système.

Dans ce cas, Exchange Server Analyzer vérifie spécifiquement si une valeur PageHeapFlags a été activée pour divers composants Exchange :

  • STORE.EXE - le processus store

  • MAD.EXE - le processus du service Surveillance du système

  • INETINFO.EXE - le processus parent et d'administration IIS

  • EMSMTA.EXE - le processus du service Agent de transfert des messages

Sauf si vous êtes activement impliqué dans le débogage ou le suivi d'un problème avec l'aide des services du Support Technique de Microsoft, il est recommandé de toujours définir la valeur PageHeapFlags sur 0 ou de la supprimer complètement, ce qui a le même effet.

La valeur de Registre PageHeapFlags n'est pas présente par défaut et doit être ajoutée manuellement si le débogage du processus STORE.EXE (ou tout autre processus) est nécessaire. Vous pouvez utiliser l'outil Gflags fourni avec les outils de support de Microsoft Windows Server™ 2003, qui se trouvent sur le CD-ROM Windows Server 2003 dans le dossier \Support. Vous pouvez également définir manuellement la valeur sur 0 ou supprimer complètement la valeur PageHeapFlags à l'aide d'un Éditeur du Registre. Les deux procédures sont décrites dans cet article.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur à l'aide de GFlags

  1. Cliquez sur Démarrer | Exécuter. Dans le champ Ouvrir, exécutez GFlags. L'interface utilisateur Global Flags s'affiche.

  2. Dans le champ Image File Name (Nom du fichier d'image), entrez STORE.EXE.

  3. Cliquez sur Image File Options (Options du fichier d'image).

  4. Désactivez toutes les cases à cocher, puis cliquez sur Apply (Appliquer).

  5. Répétez les étapes 2 à 4 pour chaque processus Exchange mentionné ci-dessus.

  6. Cliquez sur OK pour quitter l'outil GFlags et redémarrer les services concernés pour que la modification soit prise en compte.

  7. L'utilisation de l'outil GFlags pour effacer cette valeur ne supprime pas ou ne modifie pas la valeur de PageHeapFlags. Elle définit plutôt la valeur GlobalFlag sur 0, ce qui annule et désactive le comportement configuré avec l'entrée PageHeapFlags.

Pour corriger cette erreur à l'aide d'un Éditeur du Registre

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Supprimez la valeur nommée PageHeapFlags.

  4. Répétez les étapes 2 et 3 pour chaque processus Exchange mentionné.

  5. Quittez l'Éditeur du Registre et redémarrez les services concernés pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La réserve paginée dépasse le seuil d'erreur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_PerfOS_Memory pour déterminer la valeur actuelle de la clé PoolNonpagedBytes. Les actions prises par Exchange Server Analyzer dépendent du système d'exploitation sous-jacent, de la présence ou non du commutateur /3GB dans le fichier Windows Boot.ini et de la valeur détectée de cette clé.

Le tableau suivant présente la matrice d'évaluations utilisée par Exchange Server Analyzer pour déterminer si cette valeur est hors limites pour un serveur Exchange donné. Si les conditions de la matrice sont remplies, une erreur s'affiche.

Système d'exploitation | Paramètre Boot.ini | Réserve non paginée actuelle
Windows 2000 Server ou Advanced Server | /3GB | 110 Mo ou plus
Windows 2000 Server ou Advanced Server | Aucun | 220 Mo ou plus
Windows Server™ 2003 | /3GB | 110 Mo ou plus
Windows Server 2003 | Aucun | 220 Mo ou plus

La valeur de la clé PoolNonpagedBytes correspond à la taille, en octets, de la réserve non paginée de la mémoire du noyau. La réserve non paginée est une zone de mémoire système physique pour des objets ne pouvant pas être écrits sur le disque, mais restant dans la mémoire physique tant qu'ils sont alloués. La valeur de cette clé est la dernière valeur observée. Sur un serveur Exchange sain, cette valeur doit rester de niveau. Si la valeur de ce compteur augmente considérablement, elle peut indiquer une insuffisance de mémoire.

Comme il n'existe aucun moyen d'augmenter la limite de la mémoire de réserve non paginée au-delà des valeurs répertoriées ci-dessus, cette condition doit être corrigée dès que possible. Quel que soit le système d'exploitation utilisé ou la présence ou non du commutateur /3GB, le système d'exploitation Windows ne peut accéder qu'à la quantité de mémoire de réserve non paginée disponible. Si la mémoire du noyau de Windows est insuffisante, celui-ci peut afficher des messages d'erreur ainsi que les incidents. La mémoire du noyau est nécessaire au bon fonctionnement du système et vous devez par conséquent l'analyser attentivement.

Si, après le redémarrage du serveur Exchange, cette condition se reproduit, la prochaine étape consiste à s'assurer que votre système est correctement réglé et que le logiciel et le matériel de ce système sont à jour. Cela inclut l'installation des derniers éléments suivants :

  • Service Pack du système d'exploitation Windows ;

  • Service Pack d'Exchange Server ;

  • microprogramme matériel et pilotes ;

  • mises à jour du BIOS système ;

  • mises à jour pour toute application tierce installée et en cours d'exécution.

Si les mises à jour logicielles et matérielles ne résolvent pas ce problème, désactivez tout logiciel tiers, redémarrez l'ordinateur Exchange Server et analysez la mémoire du noyau.

Pour corriger cette erreur

  1. Redémarrez l'ordinateur Exchange Server dès que possible.

  2. Contrôlez le compteur de performance Mémoire | Octets de réserve non paginée pour veiller à ce qu'il n'excède pas le seuil ci-dessus de votre système.

Pour plus d'informations sur le réglage correct d'Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096 sur Exchange 2000 nécessitant le commutateur /3GB avec plus de 1 Gigaoctet de RAM physique (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096).

  • le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • le guide des performances d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=18177).

  • le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)


La réserve paginée dépasse le seuil d'avertissement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_PerfOS_Memory pour déterminer la valeur actuelle de la clé PoolPagedBytes. Les actions prises par Exchange Server Analyzer dépendent du système d'exploitation sous-jacent, de la présence ou non du commutateur /3GB dans le fichier Windows Boot.ini et de la valeur détectée de cette clé.

Le tableau présente la matrice d'évaluations utilisée par Exchange Server Analyzer pour déterminer si cette valeur est hors limites pour un serveur Exchange donné. Si les conditions du tableau sont remplies, un avertissement s'affiche.

Système d'exploitation | Paramètre Boot.ini | Réserve paginée actuelle
Windows 2000 Server ou Advanced Server | /3GB | 180 Mo ou plus
Windows 2000 Server ou Advanced Server | Aucun | 180 Mo ou plus
Windows Server™ 2003 | /3GB | 200 Mo ou plus
Windows Server 2003 | Aucun | 300 Mo ou plus

La valeur de la clé PoolPagedBytes correspond à la taille, en octets, de la réserve paginée de la mémoire du noyau. La réserve paginée est une zone de mémoire système physique pour des objets pouvant être écrits sur le disque même lorsqu'ils ne sont pas utilisés. La valeur de cette clé est la dernière valeur observée. Sur un serveur Exchange sain, à moins qu'une sauvegarde ou restauration ne se produise, 180 Mo maximum de mémoire de réserve paginée doivent être utilisés.

Avec Windows 2000 Server et Windows 2000 Advanced Server, la valeur maximale pour la mémoire de réserve paginée est de 470 Mo. Lorsque le commutateur /3GB est ajouté à un ordinateur Windows 2000 Advanced Server, la valeur maximale pour la mémoire de réserve paginée est de 192 Mo. Sur un ordinateur Windows Server 2003 sans le commutateur /3GB, la valeur maximale pour la mémoire de réserve paginée est de 491 Mo. Sur un ordinateur Windows Server 2003 avec le commutateur /3GB, la valeur maximale pour la mémoire de réserve paginée est de 256 Mo.

Comme il n'existe aucun moyen d'augmenter la limite de la mémoire de réserve paginée au-delà des valeurs répertoriées ci-dessus, cette condition doit être corrigée dès que possible. Quel que soit le système d'exploitation utilisé ou la présence ou non du commutateur /3GB, Windows ne peut accéder qu'à la quantité de mémoire de réserve paginée disponible. Si la mémoire du noyau de Windows est insuffisante, celui-ci peut afficher des messages d'erreur ainsi que les incidents. La mémoire du noyau est essentielle au bon fonctionnement du système et vous devez par conséquent analyser attentivement la mémoire du noyau.

Si, après le redémarrage du serveur Exchange, cette condition se reproduit, la prochaine étape consistera à s'assurer que votre système est correctement réglé et que le logiciel et le matériel de ce système sont à jour. Cela inclut l'installation des derniers éléments suivants :

  • Service Pack du système d'exploitation Windows ;

  • Service Pack d'Exchange Server ;

  • microprogramme matériel et pilotes ;

  • mises à jour du BIOS système ;

  • mises à jour pour toute application tierce installée et en cours d'exécution.

Si les mises à jour logicielles et matérielles ne résolvent pas ce problème, vous devez désactiver tout logiciel tiers, redémarrer l'ordinateur Exchange Server et analyser la mémoire du noyau.

Pour supprimer cet avertissement

  1. Redémarrez l'ordinateur Exchange Server dès que possible.

  2. Contrôlez le compteur de performance Mémoire | Octets de réserve paginée pour veiller à ce qu'il n'excède pas le seuil ci-dessus de votre système.

Pour plus d'informations sur le réglage approprié d'Exchange Server, voir les articles de la Base de connaissances Microsoft et les rubriques Exchange suivants :

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 266096 sur Exchange 2000 nécessitant le commutateur /3GB avec plus de 1 Gigaoctet de RAM physique (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096).

  • le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

  • le guide des performances d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=18177).

  • le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

Pour plus d'informations, voir les articles suivants du blog Exchange :

  • l'article sur la gestion de la mémoire du noyau de Microsoft Windows et sur Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=63477) (en anglais)

  • l'article sur la configuration de l'ajout de mémoire à chaud et de grande mémoire pour Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=63478) (en anglais)

  • l'article sur les grands jetons de sécurité et sur l'épuisement de la mémoire du noyau (http://go.microsoft.com/fwlink/?LinkId=63479) (en anglais)

    Remarque :
    Les liens vers ces blogs sont fournis à titre indicatif. Le contenu peut être modifié sans préavis.


Chemin d'extension du serveur proxy RPC incorrect
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété suivante dans la métabase IIS (Internet Information Services) pour déterminer si sa valeur est correctement configurée :

LM/W3SVC/Filters/RpcProxy

Cette propriété de métabase est la propriété d'extension du serveur proxy de l'appel de procédure distante (RPC) dans les extensions Services Web d'IIS. La valeur correcte de cette propriété est la suivante :

<Répertoire Windows>\system32\rpcproxy\rpcproxy.dll

Si Exchange Server Analyzer détecte que la propriété ne possède pas la valeur correcte, un avertissement s'affiche.

La propriété d'extension du serveur proxy RPC est définie lors de l'installation du sous-composant proxy RPC sur HTTP du composant Microsoft Windows® des services de mise en réseau. Si elle est définie de manière incorrecte ou si vous modifiez manuellement sa valeur, effectuez l'opération suivante :

  1. Supprimez la propriété d'extension du serveur proxy RPC incorrecte.

  2. Supprimez le sous-composant proxy RPC sur HTTP.

  3. Réinstallez le sous-composant proxy RPC sur HTTP.

Pour supprimer la propriété d'extension du serveur proxy RPC incorrecte

  1. Ouvrez le Gestionnaire des services Internet (IIS).

  2. Dans le volet gauche de la fenêtre Gestionnaire des services Internet (IIS), développez le nom du serveur, puis cliquez sur Extensions Web.

  3. Dans le volet droit de la fenêtre Gestionnaire des services Internet (IIS), cliquez avec le bouton droit sur Extension du serveur Proxy RPC, puis cliquez sur Propriétés.

  4. Sous l'onglet Fichiers requis, sélectionnez le fichier incorrect dans la liste, cliquez sur Supprimer, puis sur OK.

    Remarque :
    Pour afficher le chemin d'accès complet, réglez la largeur de la colonne Nom de fichier de la liste de fichiers.
Pour supprimer le sous-composant proxy RPC sur HTTP

  1. Cliquez sur Démarrer, Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Dans le volet gauche, cliquez sur Ajouter ou supprimer des composants Windows.

  3. Sélectionnez Services de mise en réseau, puis cliquez sur Détails.

  4. Désactivez la case à cocher Proxy RPC sur HTTP, cliquez sur OK, puis sur Suivant.

  5. Une fois que l'Assistant Composants Windows a terminé, cliquez sur Terminer pour le fermer.
Pour réinstaller le sous-composant proxy RPC sur HTTP

  1. Cliquez sur Démarrer, Panneau de configuration, puis sur Ajout/Suppression de programmes.

  2. Dans le volet gauche, cliquez sur Ajouter ou supprimer des composants Windows.

  3. Sélectionnez Services de mise en réseau, puis cliquez sur Détails.

  4. Activez la case à cocher Proxy RPC sur HTTP, cliquez sur OK, puis sur Suivant.

  5. Une fois que l'Assistant Composants Windows a terminé, cliquez sur Terminer pour le fermer.

Pour plus d'informations sur les problèmes de chargement de l'extension du serveur proxy RPC, voir la section de dépannage de l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de l'appel de procédure distante (RPC) sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833401).

Pour plus d'informations sur le déploiement de RPC sur HTTP sous Exchange Server 2003, voir le guide sur les scénarios de déploiement RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=24823).


L'émulateur PDC n'est pas exclu de la topologie DSAccess
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si le contrôleur de domaine Active Directory® agissant en tant qu'émulateur de contrôleur de domaine principal (PDC) a été manuellement exclu de la liste des contrôleurs de domaine disponibles pour une utilisation par Exchange Server :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

Si Exchange Server Analyzer détecte que le contrôleur de domaine agissant en tant qu'émulateur PDC n'a pas été exclu manuellement de la liste des contrôleurs de domaine disponibles pour une utilisation par Exchange Server, il affiche un message de recommandation.

Un émulateur PDC est un ordinateur qui tient le rôle de maître des opérations d'Active Directory et traite les demandes de réplication des contrôleurs secondaires de domaine Microsoft Windows NT® Server 4.0 et toutes les mises à jour de mot de passe pour les clients qui n'utilisent pas le logiciel client Active Directory. Les émulateurs PDC sont également des contrôleurs de domaine et par conséquent disponibles pour une utilisation par des applications telles qu'Exchange Server.

DSAccess (Directory Service Access) est un composant interne d'Exchange 2000 Server et Exchange Server 2003 qui contrôle la manière dont tous les composants Exchange Server accèdent à Active Directory. La fonction principale de DSAccess est de conserver les informations sur divers événements et opérations liés à l'annuaire. Par exemple, DSAccess découvre la topologie Active Directory et détecte si les contrôleurs de domaine et les serveurs de catalogue global sont disponibles et répondent aux demandes.

Par défaut, DSAccess inclut l'ordinateur de l'émulateur PDC dans sa liste de contrôleurs de domaine disponibles et utilisables. Si des programmes non-Exchange Server utilisent intensivement l'émulateur PDC, l'utilisation de l'émulateur PDC par DSAccess peut provoquer des problèmes de performances sur l'ordinateur, le serveur Exchange et l'ordinateur non-Exchange Server.

Pour éviter de tels problèmes de performances, la valeur de Registre MinUserDC peut être ajoutée au Registre sur un serveur Exchange pour inciter DSAccess à interroger tous les contrôleurs de domaine disponibles avant d'interroger le contrôleur de domaine qui tient le rôle de maître des opérations de l'émulateur PDC.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour examiner et modifier la valeur de Registre MinUserDC

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Recherchez la valeur MinUserDC et apportez toutes les modifications requises. Si la valeur DWORD n'existe pas, vous pouvez la créer manuellement.

    Remarque :
    La valeur configurée pour l'entrée de Registre MinUserDC correspond au nombre maximal de contrôleurs de domaine à contacter avant l'émulateur PDC. Par exemple, si vous définissez MinUserDC sur 4, DSAccess est configuré pour n'exclure l'émulateur PDC que lorsqu'un total de 4 contrôleurs de domaine est disponible.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de l'entrée de Registre MinUserDC, voir l'article 298879 de la Base de connaissances sur la possibilité qu'Exchange 2000 rencontre des problèmes de performances lorsqu'un émulateur PDC est utilisé pour DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879).


Données de performances du compteur Mégaoctets disponibles
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Available MBytes de l'objet de performance Memory pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Available MBytes, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Available MBytes indique la quantité de mémoire physique en mégaoctets (Mo) immédiatement disponible pour une allocation à un processus ou pour une utilisation du système. Il s'agit de la quantité de mémoire assignée à l'attente (cache), libre et sans listes de pages.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Disque moyen s/Lecture de l'objet de performance LogicalDisk
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Avg. Disk sec/Read de l'objet de performance LogicalDisk pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Avg. Disk sec/Read, il affiche des informations sur les données collectées en guise d'informations de comparaison.

L'objet de performance Logical Disk est constitué des compteurs tels que Avg. Disk sec/Read qui surveillent les partitions logiques des disques durs. Le compteur de performance Avg. Disk sec/Read indique le temps moyen, en secondes, de lecture de données du disque. La valeur moyenne du compteur de performance Avg. Disk sec/Read doit être inférieure à 10 millisecondes. La valeur maximale du compteur de performance Avg. Disk sec/Read ne doit pas excéder 50 millisecondes.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur la procédure d'optimisation du système de stockage pour Exchange Server 2003, voir le document sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49324).

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Disque moyen s/Lecture de l'objet de performance PhysicalDisk
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Avg. Disk sec/Read de l'objet de performance PhysicalDisk pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Avg. Disk sec/Read, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Avg. Disk sec/Read indique le temps moyen, en secondes, de lecture de données du disque. La valeur moyenne du compteur de performance Avg. Disk sec/Read doit être inférieure à 10 millisecondes. La valeur maximale du compteur de performance Avg. Disk sec/Read ne doit pas excéder 50 millisecondes.

Si vous rassemblez des résultats des compteurs Disk Reads/sec et Disk Writes/sec, vous pouvez déterminer si l'E/S générée par Exchange Server augmente ou diminue avec le temps. Si vous rassemblez des résultats des compteurs Avg. Disk sec/Read et Avg. Disk sec/Write, vous pouvez déterminer si la latence de stockage a changé avec le temps. Par exemple, la procédure suivante vous aide à prévoir si le débit de stockage est ou deviendra un goulet d'étranglement :

  1. Effectuez des mesures tous les mois, de préférence le même jour et aux mêmes heures.

  2. Analysez les données rassemblées.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances du compteur Disque moyen s/Écriture de l'objet de performance LogicalDisk
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Avg. Disk sec/Write de l'objet de performance LogicalDisk pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Avg. Disk sec/Write, il affiche des informations sur les données collectées en guise d'informations de comparaison.

L'objet de performance Logical Disk est constitué des compteurs tels que Avg. Disk sec/Write qui surveillent les partitions logiques des disques durs. Le compteur de performance Avg. Disk sec/Write indique le temps moyen en secondes utilisé pour écrire des données sur le disque. La valeur moyenne du compteur de performance Avg. Disk sec/Write doit être inférieure à 10 millisecondes. La valeur maximale du compteur de performance Avg. Disk sec/Write ne doit pas excéder 50 millisecondes.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur la procédure d'optimisation du système de stockage pour Exchange Server 2003, voir le document du site Web Microsoft TechNet sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49324).

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Disque moyen s/Écriture
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Avg. Disk sec/Write de l'objet de performance Physical Disk pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Avg. Disk sec/Write, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Avg. Disk sec/Write indique le temps moyen en secondes utilisé pour écrire des données sur le disque. La valeur moyenne du compteur de performance Avg. Disk sec/Write doit être inférieure à 10 millisecondes. La valeur maximale du compteur de performance Avg. Disk sec/Write ne doit pas excéder 50 millisecondes.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur epoxy Longueur de la file à partir du client (DSAccess)
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Client Out Queue Length (DSAccess) de l'objet de performance Epoxy pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Client Out Queue Length (DSAccess) , il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Client Out Queue Length (DSAccess) indique le nombre de messages dans la file d'attente qui contient des messages DSAccess (Directory Service Access) envoyés par le processus Inetinfo.exe. La file d'attente devrait toujours être inférieure à 10.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur epoxy Longueur de la file à partir du client (SMTP)
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Client Out Queue Length (SMTP) de l'objet de performance Epoxy pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Client Out Queue Length (SMTP), il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Client Out Queue Length (SMTP) indique le nombre de messages dans la file d'attente qui contient des messages SMTP (Simple Mail Transfer Protocol) envoyés par le processus Inetinfo.exe. La file d'attente devrait toujours être inférieure à 50 sauf s'il s'agit d'une file d'attente de messagerie.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur epoxy Longueur de la file à partir de la banque (DSAccess)
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Store Out Queue Length (DSAccess) de l'objet de performance Epoxy pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Store Out Queue Length (DSAccess), il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Store Out Queue Length (DSAccess) indique le nombre de messages dans la file d'attente qui contient des messages DSAccess (Directory Service Access) envoyés par le processus Store.exe. La file d'attente devrait toujours être inférieure à 10.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur epoxy Longueur de la file à partir de la banque (SMTP)
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Store Out Queue Length (SMTP) de l'objet de performance Epoxy pour analyser les données de performances. Si Exchange Server Analyzer collecte les données du compteur de performance Store Out Queue Length (SMTP), il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Store Out Queue Length (SMTP) indique le nombre de messages dans la file d'attente qui contient des messages SMTP (Simple Mail Transfer Protocol) envoyés par le processus Inetinfo.exe. La file d'attente devrait toujours être inférieure à 50 sauf s'il s'agit d'une file d'attente de messagerie.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Latence RPC moyenne
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance RPC Averaged Latency de l'objet de performance MSExchangeIS pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance RPC Averaged Latency, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance RPC Averaged Latency indique la latence des appels de procédure distante (RPC), en millisecondes, moyenne pour les derniers 1 024 paquets. La valeur maximale du compteur de performance RPC Averaged Latency doit être constamment inférieure à 50 millisecondes.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Opérations RPC/s
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance RPC Operations/sec de l'objet de performance MSExchangeIS pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance RPC Operations/sec, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance RPC Operations/sec indique la fréquence des opérations d'appel de procédure distante (RPC). Le compteur de performance RPC Operations/sec est un bon compteur de fréquence permettant de mesurer la charge de travail d'Exchange Server car toutes les actions MAPI utilisent le protocole RPC.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Demandes RPC
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance RPC Requests de l'objet de performance MSExchangeIS pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance RPC Requests, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance RPC Requests indique le nombre de demandes d'appel de procédure à distance (RPC) MAPI ou client en cours de traitement par le service de banque d'informations de Microsoft Exchange. La valeur moyenne du compteur de performance RPC Requests doit être inférieure à 30 par seconde. Par défaut, la valeur maximale pour les demandes RPC est 100. Dès lors, sauf configuration différente, le service de banque d'informations de Microsoft Exchange ne peut traiter que 100 demandes RPC à la fois avant de rejeter des demandes client.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Longueur de la file d'attente du catégoriseur SMTP
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Categorizer Queue Length de l'objet de performance SMTP Server pour les analyser. Exchange Server Analyzer signale le nombre total de messages détectés dans Categorizer queue.

Le compteur SMTP Server\Categorizer Queue Length indique le nombre de messages dans la file d'attente SMTP (Simple Mail Transfer Protocol) Categorizer en attente de recherches d'attribut de service d'annuaire à l'aide des serveurs de catalogue global. Il est généralement recommandé que la valeur maximale soit inférieure à 10.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Le compteur Categorizer Queue Length indique le nombre de messages dans la file d'attente du catégoriseur de messages. Le catégoriseur effectue les opérations principales suivantes :

  • Il résout et valide tous les destinataires.

  • Il détermine les limites et restrictions pour tous les destinataires.

  • Il étend les listes de distribution au besoin.

  • Il détermine si le message est destiné à une remise locale ou à distance

Une augmentation du compteur Categorizer Queue Length indique l'existence de problèmes potentiels avec les performances du serveur, Directory Service Access (DSAccess), le service d'annuaire Active Directory® ou les serveurs clés dans l'organisation Exchange Server. Une augmentation du compteur Categorizer Queue Length indique un ralentissement du temps de réponse ou l'absence de réponse lors de la consultation d'Active Directory ou lors de l'envoi de messages pour remise locale ou SMTP.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Longueur de la file d'attente locale SMTP
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Local Queue Length de l'objet de performance SMTP Server pour les analyser. Exchange Server Analyzer signale le nombre total de messages détectés dans la file d'attente locale SMTP (Simple Mail Transfer Protocol).

Le compteur SMTP Server\Local Queue Length indique le nombre de messages de la file d'attente SMTP pour une remise locale. Il est généralement recommandé que la valeur maximale soit inférieure à 1 000. La file d'attente doit rester proche de sa moyenne avec une faible variation.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Une accumulation de messages dans la file d'attente de remise locale indique un problème de performances ou des pannes du serveur car il ne parvient plus à remettre en temps voulu le courrier entrant. Ce retard peut être dû aux raisons suivantes :

  • Le service d'annuaire Active Directory® n'est pas consulté immédiatement.

  • Les messages ne sont pas envoyés assez vite pour une remise locale ou SMTP.

  • Les bases de données ont été démontées.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Longueur de la file d'attente distante SMTP
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Remote Queue Length de l'objet de performance SMTP Server pour les analyser. Exchange Server Analyzer signale le nombre total de messages détectés dans la file d'attente distante SMTP (Simple Mail Transfer Protocol).

Le compteur SMTP Server\Remote Queue Length indique le nombre de messages de la file d'attente SMTP pour une remise à distance. Il est généralement recommandé que la valeur maximale soit inférieure à 1 000. La file d'attente doit rester stable aux environs de sa moyenne avec une légère variation.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Une augmentation de la longueur de la file d'attente distante signifie que le courrier n'est pas envoyé à d'autres serveurs. Cet échec d'envoi du courrier peut s'expliquer par des pannes ou des problèmes de performances au niveau du réseau ou des serveurs distants. Ces pannes ou problèmes de performances empêchent le réseau ou les serveurs distants de recevoir le courrier correctement.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Longueur de la file d'attente Virus Scan
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Virus Scan Queue Length de l'objet de performance MSExchangeIS pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Virus Scan Queue Length, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Virus Scan Queue Length indique le nombre actuel de demandes en attente pour l'analyse antivirus. La valeur recommandée de ce compteur est spécifique à votre organisation.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Enregistrements journal inachevés/s
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Log Record Stalls/sec de l'objet de performance Database pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Log Record Stalls/sec, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Log Record Stalls/sec représente le nombre d'enregistrements de journal qui ne peuvent pas être ajoutés aux tampons de journal par seconde car ils sont pleins. La valeur moyenne du compteur de performance Log Record Stalls/sec doit être inférieure à 10 par seconde. La valeur maximale ne doit pas dépasser 100 par seconde.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Threads de journal en attente
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Log Threads Waiting de l'objet de performance Database pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Log Threads Waiting, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Log Threads Waiting indique le nombre de threads en attente de terminer une mise à jour de la base de données en écrivant leurs données dans le journal. Si la valeur du compteur de performance Log Threads Waiting est trop élevée, le journal peut être un goulot d'étranglement pour les autres transactions.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Pages/s
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Pages/sec de l'objet de performance Memory pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Pages/sec, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Pages/sec indique la vitesse à laquelle les pages sont lues ou écrites sur le disque pour la résolution des anomalies de pages difficiles. Ce compteur est un indicateur essentiel des types d'anomalies qui entraînent des retards au niveau de l'ensemble du système. Le comptage inclut des pages récupérées pour satisfaire les anomalies de page dans le cache système de fichiers. Ces pages sont généralement demandées par les applications. Le compteur devrait toujours être inférieur à 1 000.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances pour le compteur % Temps processeur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance % Processor Time de l'objet de performance Processor pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance % Processor Time, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance % Processor Time affiche le pourcentage de temps pendant lequel le processeur exécute des threads inactives. Vous pouvez utiliser ce compteur pour analyser l'utilisation globale des processeurs, mais vous pouvez également contrôler l'utilisation par processeur. L'utilisation moyenne du processeur doit toujours être inférieure à 90 %.

Remarque :
Le % Processor Time affiché par Exchange Server Analyzer est une valeur d'agrégation basée sur le nombre total de processeurs détectés, tant physiques que logiques, et divisée par la somme du nombre de processeurs.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Total octets/s
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Bytes Total/sec de l'objet de performance Network Interface pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance Bytes Total/sec, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance Bytes Total/sec indique la fréquence à laquelle l'adaptateur réseau traite des types de données. Ce compteur inclut toutes les données des fichiers et des applications, outre les informations sur les protocoles, telles que les en-têtes des paquets. Pour un adaptateur réseau de 100 mégabits par seconde (Mbps), la valeur du compteur de performance Bytes Total/sec doit être inférieure à 7 mégaoctets/seconde. Pour un adaptateur réseau de 1 000 Mbps, la valeur du compteur de performance Total octets/s doit être inférieure à 70 mégaoctets/seconde.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances du compteur Durée de lecture LDAP
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-06

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance LDAP Read Time de l'objet de performance MSExchangeDSAccess Process pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance LDAP Read Time, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance LDAP Read Time indique le temps en millisecondes pour réaliser une demande de recherche LDAP (Lightweight Directory Access Protocol). La valeur moyenne doit être inférieure à 50 millisecondes. Les valeurs maximales doivent être inférieures à 100 millisecondes.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Données de performances provenant du compteur Durée de recherche LDAP
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance LDAP Search Time de l'objet de performance MSExchangeDSAccess Processes pour les analyser. Si Exchange Server Analyzer collecte les données du compteur de performance LDAP Search Time, il affiche des informations sur les données collectées en guise d'informations de comparaison.

Le compteur de performance LDAP Search Time indique le temps en millisecondes pour réaliser une demande de recherche LDAP (Lightweight Directory Access Protocol). La valeur moyenne doit être inférieure à 50 millisecondes. Les valeurs maximales doivent être inférieures à 100 millisecondes.

Par défaut, Exchange Server Analyzer récupère un exemple toutes les 30 secondes pendant une période de deux heures. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Exchange Server Analyzer signale également la valeur équivalente au quatre-vingt-dixième centile de toutes les valeurs collectées.

Remarque :
Si vous répertoriez dans l'ordre croissant toutes les valeurs collectées par Exchange Server Analyzer, le quatre-vingt-dixième centile correspond à la valeur à la quatre-vingt-dixième position dans la liste. La valeur du quatre-vingt-dixième centile indique les valeurs élevées de ce compteur pendant l'intervalle entre deux collectes.

Dans certaines instances, la valeur maximale correspond à celle du sommet de l'intervalle. Par conséquent, la valeur maximale n'est pas représentative de l'ensemble de l'intervalle. La valeur intermédiaire n'indique pas toujours précisément la charge car elle comprend le délai d'inactivité pendant l'intervalle entre deux collectes. Donc, Exchange Server Analyzer signale la valeur maximale et la valeur du quatre-vingt-dixième centile.

Les informations de ce message de comparaison ne sont fournies qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les seuils suggérés pour les compteurs de performance, voir le guide des performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Objet d'analyseur de performances PhysicalDisk non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Avg. Disk sec/Read de l'objet de performance PhysicalDisk pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance PhysicalDisk est désactivé.

  • L'objet d'analyseur de performances PhysicalDisk est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. La procédure suivante explique comment corriger les deux premières conditions. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance PhysicalDisk est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe (Extensible Performance Counter List) sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller le système d'exploitation Windows en mode Réparer et appliquer ensuite les derniers Service Packs de Windows.


Conflit de port : Service de réplication de sites
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si un conflit de port existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Si Exchange Server Analyzer détecte que la valeur de HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP correspond à l'une des valeurs spécifiées dans les six autres valeurs de Registre de ports reprises ci-dessus dans l'article, une erreur s'affiche. Exchange Server Analyzer affiche également une erreur pour le port qui est en conflit avec HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP.

Pour corriger cette erreur, vous devez modifier la valeur de cette clé ou de la clé en conflit comme spécifié par la sortie d'Exchange Server Analyzer sous la forme d'une valeur unique.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour définir le paramètre de Registre TCP/IP

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Double-cliquez sur la clé TCP/IP et définissez le champ Données de la valeur sur une valeur unique à peine supérieure à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Pour déployer RPC sur HTTP

  1. Voir le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Voir l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Voir l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Voir la Webdiffusion du Support Technique de Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les ports mappés statiquement utilisés par Exchange, voir les articles suivants de la Base de connaissances :

  • 194952 sur les limitations de port mappés statiquement pour Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)

  • 270836 sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Conflit de port : HTTP de la banque
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si un conflit de port existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

La clé de Registre Rpc/HTTP Port permet la prise en charge par Exchange des fonctionnalités de Microsoft Office Outlook® 2003 RPC/HTTP et d'Exchange Server 2007 Outlook Anywhere. Si Exchange Server Analyzer détecte que la valeur de HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port correspond à l'une des valeurs spécifiées dans les six autres valeurs de Registre de ports reprises ci-dessus dans l'article, une erreur s'affiche. Exchange Server Analyzer affiche également une erreur pour le port qui est en conflit avec HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port.

Pour corriger cette erreur, vous devez modifier la valeur de cette clé ou de la clé en conflit comme spécifié par la sortie d'Exchange Server Analyzer sous la forme d'une valeur unique.

Si votre système prend en charge les clients RPC/HTTP Outlook 2003 ou Outlook 2007, vous devez définir la clé Rpc/HTTP Port sur la valeur décimale 6001. En outre, vous devez vérifier les configurations RPC/HTTP de votre environnement.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la valeur de Registre Rpc/HTTP Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters

  3. Double-cliquez sur la clé Rpc/HTTP Port et définissez le champ Données de la valeur sur une valeur unique à peine supérieure à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Vérification des configurations RPC sur HTTP

  1. Consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez la page Web « Déploiement d'Outlook Anywhere » (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consultez l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consultez la Webdiffusion des services du support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Conflit de port : TCP de la banque
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-30

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si un conflit de port existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Si Exchange Server Analyzer détecte que la valeur de HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port correspond à l'une des valeurs spécifiées dans les six autres valeurs de Registre de ports reprises ci-dessus dans l'article, une erreur s'affiche. Exchange Server Analyzer affiche également une erreur pour le port qui est en conflit avec HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port.

Cette valeur est généralement configurée pour permettre aux clients MAPI de se connecter à un serveur Exchange situé de l'autre côté d'un pare-feu. Ce scénario implique l'ouverture de plusieurs ports sur un pare-feu pour permettre aux clients Microsoft Office Outlook® 2003 ou Outlook 2007 de se connecter via l'interface MAPI à un serveur Exchange, généralement sur Internet.

Le déploiement recommandé pour l'utilisation d'Outlook en mode MAPI pour se connecter à un serveur Exchange via Internet consiste à utiliser les fonctionnalités RPC sur HTTP disponibles dans Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 et Microsoft Windows® XP Professionnel. Le mode MAPI était auparavant appelé mode « société » ou « groupe de travail ».

Pour corriger cette erreur, vous devez modifier la valeur de cette clé ou de la clé en conflit comme spécifié par la sortie d'Exchange Server Analyzer sous la forme d'une valeur unique.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la valeur de Registre TCP/IP Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Double-cliquez sur la clé TCP/IP Port et définissez le champ Données de la valeur sur une valeur unique à peine supérieure à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Déploiement de RPC sur HTTP

  1. Consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez la page Web « Déploiement d'Outlook Anywhere » (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consultez l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consultez la Webdiffusion des services du support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les ports mappés statistiquement utilisés par Exchange, consultez l'article 270836 de la Base de connaissances Microsoft sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


Conflit de port : port HTTP du service Surveillance du système
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si un conflit de port existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

La clé HTTP Port permet la prise en charge par Exchange des fonctionnalités de Microsoft Office Outlook® 2003 RPC/HTTP et d'Exchange Server 2007 Outlook Anywhere. Si Exchange Server Analyzer détecte que la valeur de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port correspond à l'une des valeurs spécifiées dans les six autres valeurs de Registre de ports reprises ci-dessus dans l'article, une erreur s'affiche. Exchange Server Analyzer affiche également une erreur pour le port qui est en conflit avec HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port.

Pour corriger cette erreur, vous devez modifier la valeur de cette clé ou de la clé en conflit comme spécifié par la sortie d'Exchange Server Analyzer sous la forme d'une valeur unique.

Si votre système prend en charge les clients RPC/HTTP Outlook 2003 ou Outlook 2007, vous devez définir la clé HTTP Port sur la valeur décimale 6002. En outre, vous devez vérifier les configurations RPC/HTTP de votre environnement.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la valeur de Registre HTTP Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé HTTP Port et définissez le champ Données de la valeur sur une valeur unique à peine supérieure à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Vérification des configurations RPC sur HTTP

  1. Consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez la rubrique « Déploiement d'Outlook Anywhere » (http://www.microsoft.com/technet/prodtechnol/exchange/e2k7help/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx).

  3. Consultez l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consultez la Webdiffusion des services du support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Conflit de port : Port HTTP NSPI du service Surveillance du système
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-30

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si un conflit de port existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

La clé de Registre Rpc/HTTP NSPI Port permet la prise en charge par Exchange des fonctionnalités de Microsoft Office Outlook® 2003 RPC/HTTP et d'Exchange Server 2007 Outlook Anywhere. Si Exchange Server Analyzer détecte que la valeur de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port correspond à l'une des valeurs spécifiées dans les six autres valeurs de Registre de ports reprises ci-dessus dans l'article, une erreur s'affiche. Exchange Server Analyzer affiche également une erreur pour le port qui est en conflit avec HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port.

Pour corriger cette erreur, vous devez modifier la valeur de cette clé ou de la clé en conflit comme spécifié par la sortie d'Exchange Server Analyzer sous la forme d'une valeur unique.

Si votre système prend en charge les clients RPC/HTTP Outlook 2003 ou Outlook 2007, vous devez définir la clé Rpc/HTTP NSPI Port sur la valeur décimale 6004. En outre, vous devez vérifier les configurations RPC/HTTP de votre environnement.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la valeur de Registre Rpc/HTTP NSPI Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé Rpc/HTTP NSPI Port et définissez le champ Données de la valeur sur une valeur unique à peine supérieure à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Vérification des configurations RPC sur HTTP

  1. Consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez la page Web « Déploiement d'Outlook Anywhere » (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consultez l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consultez la Webdiffusion des services du support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Conflit de port : Port NSPI du service Surveillance du système
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si un conflit de port existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Si Exchange Server Analyzer détecte que la valeur de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port correspond à l'une des valeurs spécifiées dans les six autres valeurs de Registre de ports reprises ci-dessus dans l'article, une erreur s'affiche. Exchange Server Analyzer affiche également une erreur pour le port qui est en conflit avec HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port.

Cette valeur est généralement configurée pour permettre aux clients MAPI de se connecter à un serveur Exchange situé de l'autre côté d'un pare-feu. Ce scénario implique l'ouverture de plusieurs ports sur un pare-feu pour permettre aux clients Microsoft Office Outlook® 2003 et Outlook 2007 de se connecter via l'interface MAPI à un serveur Exchange, généralement sur Internet.

Le déploiement recommandé pour l'utilisation d'Outlook en mode MAPI pour se connecter à un serveur Exchange via Internet consiste à utiliser les fonctionnalités RPC sur HTTP disponibles dans Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 et Microsoft Windows® XP Professionnel. Le mode MAPI était auparavant appelé mode « société » ou « groupe de travail ».

Pour corriger cette erreur, vous devez modifier la valeur de cette clé ou de la clé en conflit comme spécifié par la sortie d'Exchange Server Analyzer sous la forme d'une valeur unique.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la valeur de Registre TCP/IP NSPI Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé TCP/IP NSPI Port et définissez le champ Données de la valeur sur une valeur unique à peine supérieure à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Déploiement de RPC sur HTTP

  1. Consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez la page Web « Déploiement d'Outlook Anywhere » (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consultez l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consultez la Webdiffusion des services du support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les ports mappés statiquement utilisés par Exchange, voir l'article suivant de la Base de connaissances :

  • 270836 sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Conflit de port : service Surveillance du système RFR
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-30

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si un conflit de port existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Si Exchange Server Analyzer détecte que la valeur de HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port correspond à l'une des valeurs spécifiées dans les six autres valeurs de Registre de ports reprises ci-dessus dans l'article, une erreur s'affiche. Exchange Server Analyzer affiche également une erreur pour le port qui est en conflit avec HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port.

Cette valeur est généralement configurée pour permettre aux clients MAPI de se connecter à un serveur Exchange situé de l'autre côté d'un pare-feu. Ce scénario implique l'ouverture de plusieurs ports sur un pare-feu pour permettre aux clients Microsoft Office Outlook® 2003 ou Outlook 2007 de se connecter via l'interface MAPI à un serveur Exchange, généralement sur Internet.

Le déploiement recommandé pour l'utilisation d'Outlook en mode MAPI pour se connecter à un serveur Exchange via Internet consiste à utiliser les fonctionnalités RPC sur HTTP disponibles dans Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 et Microsoft Windows® XP Professionnel. Le mode MAPI était auparavant appelé mode « société » ou « groupe de travail ».

Pour corriger cette erreur, vous devez modifier la valeur de cette clé ou de la clé en conflit comme spécifié par la sortie d'Exchange Server Analyzer sous la forme d'une valeur unique.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la valeur de Registre TCP/IP Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé TCP/IP Port et définissez le champ Données de la valeur sur une valeur unique à peine supérieure à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Déploiement de RPC sur HTTP

  1. Consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez la page Web « Déploiement d'Outlook Anywhere » (http://go.microsoft.com/fwlink/?LinkId=80831).

  3. Consultez l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  4. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  5. Consultez la Webdiffusion des services du support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les ports mappés statistiquement utilisés par Exchange, consultez l'article 270836 de la Base de connaissances Microsoft sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836)


Pré-version de correctif cumulatif de Service Pack détectée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le fichier bibliothèque ExCDO (Exchange Collaboration Data Object) ExCDO.dll. Si Exchange Server Analyzer détermine que la clé Version pour ExCDO.dll possède une valeur égale à 6603.0, un avertissement s'affiche.

Un ordinateur Exchange 2000 Server qui exécute la version 6603.0 d'ExCDO.dll indique que le serveur utilise le correctif cumulatif version 1 post-Service Pack 3 Exchange 2000 Server et daté d'août 2004. La version 2 de ce correctif cumulatif est désormais disponible. Il est recommandé d'installer le correctif cumulatif d'août 2004.

Pour supprimer cet avertissement

  1. Pour plus d'informations sur la dernière mise à jour, voir l'article 870540 de la Base de connaissances Microsoft sur la disponibilité du correctif cumulatif post-Service Pack 3 Exchange 2000 Server daté d'août 2004 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540).

  2. Téléchargez la dernière mise à jour (août 2004) à partir du site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).

  3. Sauvegardez l'ordinateur Exchange Server.

  4. Appliquez le correctif cumulatif d'août 2004.

Pour plus d'informations sur l'obtention du dernier Service Pack pour Exchange 2000 Server, voir l'article 301378 de la Base de connaissances Microsoft sur l'obtention du dernier Service Pack d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Pour plus d'informations sur cette installation et d'autres mises à jour d'Exchange Server, voir l'article 328839 de la Base de connaissances sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Problème avec l'emplacement du fichier d'échange
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer a déterminé que votre fichier d'échange se situe à un emplacement pouvant avoir une influence négative sur les performances du serveur. Le fichier d'échange peut ne pas se trouver sur le même disque que les bases de données ou les fichiers journaux Exchange. Il est également recommandé d'isoler le fichier d'échange des fichiers système.

Il est recommandé de situer votre fichier d'échange sur une partition dédiée ou un disque rapide.

Pour supprimer cet avertissement

  • Déplacez le fichier d'échange vers un emplacement qui ne contient pas de base de données ni de fichiers journaux Exchange et, si possible, pas de partition système.

Pour plus d'informations

  • Pour plus d'informations sur la configuration du fichier d'échange, voir l'article 197379 de la Base de connaissances Microsoft sur la configuration des fichiers d'échange à des fins d'optimisation et de récupération dans Windows Server 2003, Windows 2000 et Windows NT (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=197379).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Goulot d'étranglement de processeur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-24

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre serveur rencontre un goulot d'étranglement de processeur. Votre serveur a dépassé le seuil recommandé d'utilisation du processeur. Les compteurs utilisés pour l'identification des goulots d'étranglement de processeur ou des problèmes d'utilisation du processeur comprennent :

  • le compteur de performance Changements de contexte/s sous l'objet de performance System ;

  • le compteur de performance % Temps processeur (_Total) sous l'objet de performance Processor ;

  • le compteur de performance Longueur de la file du processeur sous l'objet de performance System.

Détection d'un goulot d'étranglement de processeur

Si l'une des conditions suivantes est remplie, Exchange Server Analyzer détecte un goulot d'étranglement :

  • La moyenne du compteur de performance % Temps processeur (_Total) sous l'objet de performance Process est supérieure à 70 %.

  • La valeur maximale du compteur de performance % Temps processeur (_Total) sous l'objet de performance Process est supérieure à 90 %.

  • La moyenne du compteur de performance Changements de contexte/s sous l'objet de performance System est supérieure à 20 000.

  • Le compteur de performance Longueur de la file du processeur sous l'objet de performance System est supérieur à deux.

  • Ce compteur de performance % Temps processeur (_Total) sous l'objet de performance Process fournit l'utilisation globale des processeurs. L'utilisation moyenne du processeur doit toujours être inférieure à 80 %. Une moyenne plus élevée indique un goulot d'étranglement de processeur. Si l'utilisation moyenne du processeur est supérieure à 70 %, un avertissement s'affiche. Les pointes fréquentes de temps processeur supérieures à 90 % indiquent également un goulot d'étranglement de processeur.

  • La compteur de performance Longueur de la file du processeur sous l'objet de performance System indique le nombre de threads dans la file d'attente du processeur. Il existe une seule file d'attente pour le temps processeur, même sur des ordinateurs à plusieurs processeurs. Un nombre supérieur à deux indique que les threads attendent le temps processeur ainsi que la présence d'un goulot d'étranglement de processeur.

Identification des sources de la charge processeur

Si un goulot d'étranglement de processeur est détecté, vous devez déterminer l'origine de la majeure partie de l'utilisation du processeur. Sur un serveur principal Exchange, la majorité de l'utilisation du processeur doit provenir d'un processus Store.exe. Si plus de 20 % de l'utilisation du processeur provient d'un processus autre que Store.exe, il est important de retrouver les processus qui augmentent l'utilisation du processeur.

Si l'utilisation du processeur pour les processus répertoriés dans la table ci-dessous est supérieure au seuil, Exchange Server Analyzer affiche une erreur.

Processus | Seuil pour le compteur de performance %Temps processeur sous l'objet de performance Process
Store | 90%
Inetinfo | 20%
Emsmts | 40%
Lsass | 40%
System | 40%
Mad | 40%
ExMGMT | 20%
W3WP | 40%

Exchange Server Analyzer mesure également la différence entre le temps processeur actif mesuré par les compteurs de performance %Temps processeur (instance Actif) et %Temps processeur (instance _Total) sous l'objet de performance Process. Sur un serveur principal Exchange sain, au moins 70 % du temps processeur utilisé doit l'être dans le cadre du processus Store.exe.

Exchange Server Analyzer affiche une erreur si les conditions suivantes existent :

  • Si le temps processeur qui n'est pas utilisé dans le cadre de processus liés au serveur Exchange (processus Store.exe, inetinfo.exe, emsmta.exe, lsass.exe, w3wp.exe, exmgmt.exe ou mad.exe) est supérieur à 35 %.

  • Si le temps processeur non lié à Exchange est supérieur à 20 %.

  • En cas de goulot d'étranglement et si moins de 70 % du temps processeur sont utilisés dans le cadre du processus Store.exe.

Dans tous ces cas, il est recommandé de découvrir la raison de l'augmentation du temps processeur de votre serveur.

Causes habituelles des goulots d'étranglement de processeur sur les serveurs principaux

Il existe de nombreuses causes possibles aux goulots d'étranglement des performances, notamment :

  • d'autres applications sur le serveur qui augmentent l'utilisation du processeur ;

  • les taux élevés d'appels de procédure distante ;

  • l'extension de la liste de distribution ;

  • l'exécution de la sauvegarde et de la maintenance pendant les heures de pointe d'utilisation ;

  • la conversion du contenu des messages en messages provoquée par :

    • l'exécution de nombreux protocoles (par exemple HTTP, POP3, IMAP4, Microsoft Office Outlook®) ;

    • l'utilisation par Outlook 2000 ou versions antérieures de dossiers en mode hors connexion (fichiers .ost).

Suppression des goulots d'étranglement de processeur

La suppression de goulots d'étranglement de processeur de votre serveur Exchange peut se faire de différentes manières.

Pour supprimer les goulots d'étranglement de processeur

  • Si possible, ajoutez davantage de processeurs ou des processeurs plus rapides au serveur. Activez également la technologie Hyper-Threading si elle est prise en charge par les processeurs. Vous pouvez activer la technologie Hyper-Threading en configurant le BIOS système. Pour plus d'informations, voir la documentation d'aide du fabricant de votre ordinateur.

  • Si l'augmentation de la puissance de traitement s'avère impossible, vous devez diminuer la charge des processeurs. Pour réduire l'impact global sur le serveur, il est important de s'assurer que les tâches qui nécessitent de nombreuses E/S et une grande partie du processeur ou utilisent beaucoup de mémoire soient effectuées en dehors des heures de fonctionnement habituelles.

    Identifiez tout d'abord les applications ou tâches qui provoquent une charge sur le serveur. Si une application non-Exchange n'est pas importante pour ce serveur, exécutez-la sur un autre serveur. Si possible, déplacez également les rôles de serveur vers d'autres ordinateurs. Par exemple, si le processus Inetinfo utilise une grande partie du processeur, envisagez l'ajout de serveurs frontaux pour prendre la responsabilité du fonctionnement du protocole assuré par Inetinfo. Vous pouvez également déplacer l'accès aux dossiers publics vers un serveur de dossiers publics dédié. Enfin, si un serveur effectue de nombreuses extensions de liste de distribution, vous pouvez réduire l'utilisation du processeur en déplaçant l'extension de la liste de distribution vers un serveur d'extension de liste de distribution dédié.

  • Assurez-vous que les tâches qui nécessitent une grande partie du processeur (comme les tâches de sauvegarde et de maintenance) sont effectuées pendant les heures creuses. Assurez-vous également que ces tâches soient effectuées par étapes. Effectuer une tâche par étapes signifie le paramétrage de différentes heures de début et de fin pour chaque tâche. Effectuer par étapes la maintenance et la sauvegarde des bases de données ou des groupes de stockage diminue également l'effet de ces tâches nécessitant beaucoup de ressources.

  • Si vous avez supprimé toutes les sources facultatives de charge et si l'utilisation du processeur reste trop élevée, vous devez déplacer des utilisateurs vers un autre serveur pour réduire la charge. Pour plus d'informations, voir la rubrique sur le Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur le déplacement de boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique sur le Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


Objet d'analyseur de performances du processeur non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance % Processor Time de l'objet de performance Processor pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance Processor est désactivé.

  • L'objet d'analyseur de performances Processor est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. La procédure suivante explique comment corriger les deux premières conditions. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance Processor est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger l'outil Exctrlst.exe ( (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller le système d'exploitation Windows en mode Réparer et appliquer ensuite les derniers Service Packs de Windows.


La réplication du contenu des dossiers publics est suspendue
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut heuristics a été défini dans l'organisation Exchange Server. Si Exchange Server Analyzer détecte que ce bit 1024 est défini dans heuristics, un avertissement s'affiche.

Exchange Server 2003 SP2 a introduit la capacité pour un administrateur d'arrêter la réplication de tout contenu de dossier public dans l'organisation. Vous pouvez arrêter la réplication de tous les dossiers publics en cliquant avec le bouton droit sur le nom de l'organisation dans la Gestion de système Exchange et en cliquant sur Arrêter la réplication du contenu des dossiers publics. Lorsque vous cliquez sur Arrêter la réplication du contenu des dossiers publics, le bit 1024 est défini dans l'attribut heuristics. Vous devez uniquement arrêter la réplication des dossiers publics dans des cas extrêmes, tels que la résolution d'un problème de dossier public au niveau de l'organisation ou de flux de messagerie.

Vous devez reprendre la réplication du contenu des dossiers publics si les conditions suivantes sont réunies :

  • Vous n'êtes pas en train de résoudre un problème.

  • Vous n'avez pas besoin que la réplication du contenu des dossiers publics soit arrêtée.

Pour reprendre la réplication du contenu des dossiers publics au niveau de l'organisation

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez avec le bouton droit sur Nom_Organisation, puis cliquez sur Reprendre la réplication du contenu des dossiers publics.

Pour plus d'informations sur la réplication des dossiers publics, voir les recommandations pour les dossiers publics sur Exchange Server (http://go.microsoft.com/fwlink/?LinkId=46437).


Banque de dossiers publics présente sur le serveur frontal
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-07

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si une banque de dossiers publics est présente sur chaque serveur Exchange. Si Exchange Server Analyzer détecte que l'objet InformationStore appartient à la classe d'objet de msExchPublicMDB, le serveur héberge une banque de dossiers publics.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft MicrosoftExchangeV2 pour déterminer si une valeur est définie pour la clé IsFrontEndServer. Une valeur True indique que le serveur Exchange est configuré en tant que serveur frontal et une valeur False indique que le serveur Exchange n'est pas configuré en tant que serveur frontal. Si Exchange Server Analyzer détecte qu'un serveur Exchange configuré en tant que serveur frontal héberge une banque d'informations publique, un avertissement s'affiche.

Il est recommandé de ne pas utiliser de banque de dossiers publics sur des serveurs frontaux. Les banques de dossiers publics ne sont pas requises sur des serveurs frontaux, car ces serveurs n'hébergent pas de boîtes aux lettres. Il existe en outre des problèmes connus de réplication et de redirection de dossiers publics, ainsi que de pertes de mémoire lorsque les banques de dossiers publics sont situées sur des serveurs frontaux exécutant Exchange 2000 Server. Vous devez, par conséquent, démonter toutes les banques de dossiers publics sur tous les serveurs frontaux.

Après avoir démonté les banques de dossiers publics, vous pouvez désactiver le service de banque d'informations de Microsoft Exchange parce qu'il n'exécute plus toutes les fonctions sur les serveurs frontaux. En supprimant les services superflus, vous réduisez la charge et améliorez la sécurité et les performances.

Remarque :
Si le serveur frontal reçoit également des messages SMTP (Simple Mail Transfer Protocol) à partir d'Internet, le service de banque d'informations de Microsoft Exchange doit être en cours d'exécution et une banque de boîtes aux lettres doit rester montée. Cependant, vous ne devez jamais avoir de banque de dossiers publics sur un serveur frontal.

Pour arrêter et désactiver les bases de données de boîtes aux lettres et de dossiers publics

  1. Dans le Gestionnaire système Exchange, développez Serveurs, votre serveur, puis Premier groupe de stockage.

    Cliquez avec le bouton droit sur Banque de boîtes aux lettres (Nom_serveur), puis cliquez sur Démonter la banque d'informations et sur Oui pour démonter la banque d'informations.

    Important :
    Si vous utilisez le serveur frontal en tant que serveur tête de pont SMTP, vous devez disposer d'une banque de boîtes aux lettres installée sur le serveur. Dans ce cas, ne démontez ni ne supprimez cette banque, mais veillez à ne pas stocker de boîtes aux lettres sur ce serveur.

  2. Cliquez avec le bouton droit sur Banque de boîtes aux lettres (Nom_serveur), puis cliquez sur Propriétés.

  3. Cliquez sur l'onglet Base de données, activez la case à cocher Ne pas monter cette banque d'informations au démarrage, puis cliquez sur OK.

    Cliquez avec le bouton droit sur Banque de dossiers publics (Nom_serveur), puis cliquez sur Démonter la banque d'informations.

    Attention :
    Avant de démonter la banque de dossiers publics, vérifiez que les dossiers publics sont répliqués dans une autre banque de dossiers publics. Sinon, vous risquez perdre des informations.

  4. Cliquez sur Oui pour démonter la banque de dossiers publics.

Pour désactiver le service de banque d'informations de Microsoft Exchange

  1. Dans le composant logiciel enfichable MMC (Microsoft Management Console) Services, cliquez avec le bouton droit sur Banque d'informations de Microsoft Exchange dans la liste Nom, puis cliquez sur Propriétés.

  2. Dans la liste Type de démarrage, sélectionnez Désactivé, puis cliquez sur Arrêter.

Pour supprimer définitivement les bases de données de boîtes aux lettres et de dossiers publics

  • Suivez les instructions de la section sur la procédure de démontage et de suppression des banques de dossiers publics et de boîtes aux lettres du Guide sur le renforcement de la sécurité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25210).

Pour plus d'informations sur les problèmes liés à l'exécution des services de banque d'informations sur des serveurs frontaux, voir les articles suivants de la Base de connaissances Microsoft :

  • 286822 sur l'établissement par les serveurs frontaux d'un grand nombre de connexions (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822)

  • 320298 sur le grand nombre de connexions établies sur des serveurs frontaux exécutant Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298)

Pour plus d'informations sur les serveurs frontaux et principaux, voir le guide sur la topologie principale et frontale d'Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=34216).


Le fichier REAPI.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs des fichiers ci-dessus sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Mises à jour recommandées pour Windows 2000 Server SP 4 sur un cluster
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécuté sur le serveur Exchange :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

Remarque :
Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute Microsoft Windows 2000 Server. Une valeur de 5.2 indique que l'ordinateur exécute Microsoft Windows Server™ 2003.

Exchange Server Analyzer interroge également la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé ServicePackMajorVersion.

Enfin, Exchange Server Analyzer interroge la classe WMI Win32_Service pour déterminer si le service ClusSvc a été démarré.

Exchange Server Analyzer affiche un message de configuration recommandée si les conditions suivantes existent :

  • Le serveur Exchange se trouve sur un ordinateur qui exécute Windows 2000 Server, qui a été mis à niveau avec le Service Pack 4.

  • Le service ClusSvc a été démarré.

Il est recommandé d'évaluer les mises à jours et les correctifs disponibles et de déterminer s'ils peuvent résoudre les problèmes de votre environnement.

Pour plus d'informations et pour obtenir la liste des mises à jour disponibles pour les serveurs exécutant Windows 2000 Server, voir l'article 895090 de la Base de connaissances Microsoft sur les correctifs recommandés pour les clusters de serveur Windows 2000 Service Pack 4 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090).


Longueur de la file d'attente distante au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-04-09

L'outil Microsoft Exchange Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Remote Queue Length de l'objet de performance SMTP Server pour les analyser.

Si Exchange Analyzer détermine que le compteur Remote Queue Length a dépassé la valeur maximale de 1000 pendant une période-exemple, il affiche une erreur.

Le compteur SMTP Server\Remote Queue Length indique le nombre de messages de la file d'attente SMTP (Simple Mail Transfer Protocol) pour une remise à distance. Une augmentation de Remote Queue Length signifie que le courrier n'est pas envoyé à d'autres serveurs.

Cet échec d'envoi du courrier peut s'expliquer par des pannes ou des problèmes de performances au niveau du réseau ou des serveurs distants. Ces pannes ou problèmes de performances empêchent le réseau ou les serveurs distants de recevoir le courrier correctement.

Pour résoudre cette erreur, les ressources des liens suivants permettent d'identifier le serveur ou composant réseau posant problème et de résoudre les problèmes de performances.

Pour plus d'informations

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir la partie consacrée à l'identification des files d'attente de messagerie croissantes dans la section sur l'identification des symptômes des problèmes de performances dans la rubrique sur la résolution des problèmes de performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Document sur les 10 choses à savoir sur les performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=56460).


Longueur de file d'attente de nouvelle tentative distante au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Remote Retry Queue Length de l'objet de performance SMTP Server pour les analyser.

Le compteur SMTP Server\Remote Retry Queue Length indique le nombre de messages dans la file d'attente de nouvelle tentative distante du protocole SMTP (Simple Mail Transfer Protocol) qui ne peuvent pas être envoyés vers un serveur de destination. Si Exchange Server Analyzer détermine que le compteur Remote Retry Queue Length a dépassé la valeur maximale de 1000 pendant une période-exemple, il affiche une erreur.

Cet échec d'envoi du courrier peut s'expliquer par des pannes ou des problèmes de performances au niveau du réseau ou des serveurs distants. Ces pannes ou problèmes de performances empêchent le réseau ou les serveurs distants de recevoir le courrier correctement.

Pour résoudre cette erreur, les ressources des liens suivants permettent d'identifier le serveur ou composant réseau posant problème et de résoudre les problèmes de performances.

Pour plus d'informations

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir la partie consacrée à l'identification des files d'attente de messagerie croissantes dans la section sur l'identification des symptômes des problèmes de performances dans la rubrique sur la résolution des problèmes de performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Document sur les 10 choses à savoir sur les d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=56460).


Réplica du Carnet d'adresses en mode hors connexion version 4 introuvable
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Public_Folder pour déterminer la valeur actuelle de HasLocalReplica. Si Exchange Server Analyzer détecte que la valeur de HasLocalReplica est définie sur False pour l'instance du Carnet d'adresses en mode hors connexion version 4 d'une liste d'adresses en mode hors connexion, il affiche une erreur.

Si HasLocalReplica est défini sur False pour le Carnet d'adresses en mode hors connexion version 4 d'une liste d'adresses en mode hors connexion, les listes d'adresses en mode hors connexion ne sont pas générées correctement. Par conséquent, les utilisateurs Microsoft Office Outlook® 2003 ne peuvent télécharger aucune liste d'adresses en mode hors connexion.

Ce problème peut se produire si vous n'avez pas configuré les banques de dossiers publics pour qu'elles contiennent des répliques du Carnet d'adresses en mode hors connexion version 4. Par défaut, le Carnet d'adresses en mode hors connexion réplique son contenu dans la banque de dossiers publics du serveur sur lequel il est installé. Si la banque de dossiers publics est supprimée de la configuration de la réplication du Carnet d'adresses en mode hors connexion, le problème décrit dans le paragraphe précédent survient.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis cliquez sur Dossiers.

  3. Cliquez avec le bouton droit sur Dossiers publics et cliquez sur Afficher les dossiers système.

  4. Cliquez pour développer l'objet CARNET D'ADRESSES EN MODE HORS CONNEXION.

  5. Sous CARNET D'ADRESSES EN MODE HORS CONNEXION, cliquez avec le bouton droit sur o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut, puis cliquez sur Propriétés.

  6. Sous l'onglet Réplication, vérifiez qu'une banque de dossiers publics est entrée dans la zone Répliquer le contenu vers les banques d'informations publiques suivantes. Si aucune banque de dossiers publics n'est entrée, cliquez sur Ajouter, puis entrez la banque de dossiers publics appropriée pour le carnet d'adresses en mode hors connexion.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Cliquez pour développer o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut.

  9. Sous o=org/cn=addrlists/cn=oabs/cn=Liste_adresses_en_mode_hors_connexion_par_défaut, cliquez avec le bouton droit sur offline Address Book Version 4, puis cliquez sur Propriétés.

  10. Sous l'onglet Réplication, vérifiez qu'une banque de dossiers publics est entrée dans la zone Répliquer le contenu vers les banques d'informations publiques suivantes. Si aucune banque de dossiers publics n'est entrée, cliquez sur Ajouter, puis entrez la banque de dossiers publics appropriée pour le carnet d'adresses en mode hors connexion.

  11. Cliquez sur Appliquer, puis sur OK.

Pour plus d'informations sur ce problème, voir l'article 286328 de la Base de connaissances Microsoft sur l'absence de Carnet d'adresses en mode hors connexion et l'impossibilité de le générer dans Microsoft Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328).

Pour plus d'informations sur la méthode correcte de suppression du premier ordinateur qui exécute Exchange Server 2003 d'un groupe d'administration, voir l'article 822931 de la Base de connaissances sur la procédure de suppression du premier ordinateur Exchange Server 2003 du groupe d'administration (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931).

Pour plus d'informations sur les problèmes liés au Carnet d'adresses en mode hors connexion, voir les ressources Exchange Server suivantes :

  • Article sur le carnet d'adresses en mode hors connexion et les éléments à prendre en compte (http://go.microsoft.com/fwlink/?LinkId=57581)

  • Article sur le fonctionnement simultané d'Outlook 2003 SP2 et d'Exchange Server 2003 SP2 OAB version 4 (http://go.microsoft.com/fwlink/?linkid=53099).

  • Article sur OAB version 4 dans Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=53097).


Longueur de la file d'attente File d'attente de réception de réplication au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Replication Receive Queue Size de l'objet de performance MSExchangeIS Public pour les analyser.

Si Exchange Server Analyzer détermine que le compteur Replication Receive Queue Size a dépassé la valeur maximale de 1000 pendant une période-exemple, il affiche une erreur.

Les messages de réplication de dossiers publics sont reçus par SMTP, catégorisés et transmis à la file d'attente SMTP locale. Les messages sont ensuite soumis à la banque de dossiers publics. Lorsqu'ils ont été soumis à la banque de dossiers publics, les messages sont placés dans la file d'attente de réception de réplication. Ces messages sont ensuite traités et les modifications sont réalisées dans le dossier public approprié. Le compteur de performance Replication Receive Queue Size indique le nombre de messages de réplication de dossier public en attente de traitement.

Plus la file d'attente de réplication grandit, plus le contenu des dossiers perd de sa synchronisation. À mesure que les files d'attente de réplication grandissent, la charge sur les ressources augmente, alors que les messages dans la file d'attente de réplication sont traités. La croissance des files d'attente de réplication indique également que le contenu de dossier public sur le serveur est obsolète.

Aucune action n'est requise dans les deux instances dans lesquelles la croissance de la file d'attente de réception de réplication est prévue et peut être planifiée :

  • Sur un nouveau serveur de dossiers publics, la croissance de la file d'attente de réception de réplication peut être due à la réplication de renvoi initiale prévue.

  • En cas de consolidation de site ou d'autres changements dans la topologie Exchange, il est prévu que de nombreuses réplications auront lieu lors du déplacement du contenu.

Dans le cadre de serveurs stables existants dans lesquels les réplicas de dossiers publics ne sont pas modifiés en vrac, cette erreur peut indiquer :

  • Des goulots d'étranglement des performances de ressources de serveur tels que le disque, le processeur, le réseau ou la mémoire. S'il existe un goulot d'étranglement de ressource sur le serveur, le processus Store.exe ne peut pas traiter les messages de réplication assez rapidement et une file d'attente grandit.

  • L'intervalle de réplication de dossier public est trop court pour terminer la réplication avant le début du cycle de réplication suivant.

Pour résoudre cette erreur, procédez comme suit :

  • Augmentez cet intervalle et surveillez le compteur MSExchangeIS Public\Replication Receive Queue Size jusqu'à ce qu'il indique que la réplication est terminée avant le début du cycle de réplication suivant.

  • Les ressources disponibles dans les liens suivants permettent de déterminer si un goulot d'étranglement des performances entraîne la croissance de la longueur de la file d'attente et de le résoudre.

  • Pensez à réduire le nombre total de réplicas dans l'organisation Exchange pour diminuer le trafic de réplication requis.

Pour plus d'informations

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir la section sur le traitement de rôles spéciaux et des performances d'Exchange dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la réplication de dossiers publics Exchange Server, voir la section sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 dans la rubrique sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

  • Pour plus d'informations sur les meilleures pratiques de dossiers publics Exchange, voir la rubrique Meilleures pratiques de dossiers publics Exchange : mise en œuvre de la réplication (http://go.microsoft.com/fwlink/?LinkId=46440).

  • Pour plus d'informations sur les améliorations apportées à la gestion de dossiers publics dans Exchange Server 2003 Service Pack 2, voir les Notes de mise à jour de Microsoft Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=52072).


Le fichier RESVC.DLL est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs des fichiers ci-dessus sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


La clé de Registre RestrictRemoteClients est activée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les restrictions de l'interface d'appel de procédure distante (RPC) sont activées :

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Si Exchange Server Analyzer détecte que la clé de Registre RestrictRemoteClients est configurée, il affiche un message indiquant une configuration autre que celle par défaut.

Les restrictions de l'interface d'appel de procédure distante (RPC) offrent une protection réseau accrue qui diminuera la vulnérabilité des systèmes aux attaques sur le réseau. La valeur de Registre RestrictRemoteClients modifie le comportement de toutes les interfaces d'appel de procédure distante (RPC) du système. Par défaut, la valeur de Registre RestrictRemoteClients empêche l'accès anonyme à distance aux interfaces d'appel de procédure distante (RPC) du système, à quelques exceptions près.

Lorsqu'une interface est enregistrée à l'aide de RpcServerRegisterIf, l'appel de procédure distante (RPC) autorise l'application serveur à limiter l'accès à l'interface, généralement à l'aide d'un rappel de sécurité. La valeur de Registre RestrictRemoteClients permet à l'appel de procédure distante (RPC) d'effectuer des vérifications de sécurité supplémentaires pour toutes les interfaces, même si l'interface n'a pas de rappel de sécurité enregistré.

Remarque :
Les clients RPC qui utilisent la séquence de protocole canaux nommés sont exemptés de toutes les limitations. La séquence de protocole canaux ne peut pas être limitée étant donné les problèmes importants de compatibilité avec les versions précédentes.
Remarque :
Vous pouvez également configurer la clé de Registre the RestrictRemoteClients à l'aide de l'Éditeur d'objet Stratégie de groupe.

La clé de Registre RestrictRemoteClients est configurée à l'aide de valeurs DWORD. Si la valeur de Registre est absente, la valeur manquante équivaut à RPC_Restrict_Remote_Client_Default.

Le tableau suivant fournit des informations sur les paramètres de configuration RestrictRemoteClients.

Valeur de la clé de Registre (DWORD) Description

0 (par défaut)

RPC_RESTRICT_REMOTE_CLIENT_NONE (0) représente la valeur par défaut dans Microsoft Windows Server™ 2003 Service Pack 1. Si elle est sélectionnée, le système ignore la limitation de l'interface d'appel de procédure distante (RPC).

Le paramètre par défaut correspond à la valeur de RPC_RESTRICT_REMOTE_CLIENT_NONE. C'est l'application serveur qui est responsable de l'imposition des limitations RPC appropriées. Le paramètre par défaut équivaut à celui de RestrictRemoteClients dans les versions antérieures de Windows.

1

La valeur par défaut de la clé de Registre RestrictRemoteClients est 1 dans Microsoft Windows® XP Service Pack 2. Cette valeur limite l'accès à toutes les interfaces RPC. Tous les appels anonymes à distance sont rejetés par l'exécution RPC.

Ce paramètre correspond à la valeur de RPC_RESTRICT_REMOTE_CLIENT_DEFAULT. Si une interface enregistre un rappel de sécurité et émet l'indicateur RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH, cette limitation ne s'applique pas à cette interface.

2

La valeur 2 de la clé de Registre RestrictRemoteClients indique que tous les appels anonymes à distance sont rejetés par l'exécution RPC sans exceptions.

Ce paramètre correspond à la valeur de RPC_RESTRICT_REMOTE_CLIENT_HIGH. Si la valeur RestrictRemoteClients est configurée sur 2, un système ne peut pas recevoir d'appels anonymes à distance à l'aide de RPC.

Pour plus d'informations sur les modifications apportées au service RPC dans Windows XP Service Pack 2, voir l'article de MSDN® sur les limitations de l'interface RCP (http://go.microsoft.com/fwlink/?LinkId=47371).


Le serveur cible de redirection (RFR) a été remplacé manuellement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante sur le serveur Exchange pour déterminer si le service de redirection Directory Services Proxy (DSProxy referral) a été remplacé manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

Si Exchange Server Analyzer détecte que RFR Target Server est présent et configuré, un message indiquant une configuration autre que celle par défaut s'affiche.

La première fois qu'un client Microsoft Outlook® 2000 Service Release 2 (SR-2) ou version ultérieure se connecte à un ordinateur Exchange 2000 Server ou Exchange Server 2003, il recherche le service d'annuaire sur le serveur Exchange associé. Outlook passe d'abord par le processus DSProxy pour la toute première session. Une fois que le client a contacté le service DSProxy, une redirection DSProxy lui est renvoyée pour l'informer que toutes les futures requêtes d'annuaire doivent arriver au serveur de catalogue global. Outlook définit les informations de redirection DSProxy dans le profil MAPI du Registre.

Le mécanisme de redirection DSProxy réduit la charge sur le serveur Exchange et la latence pour les recherches du carnet d'adresses. Si un nom de serveur explicite est entré dans le profil et que ce serveur de catalogue global échoue, Outlook doit redémarrer. Le cas échéant, le serveur Exchange envoie une nouvelle redirection à Outlook.

Dans certaines situations, il est préférable de coder de manière irréversible l'entrée RFR Target Server pour spécifier les serveurs à utiliser pour le service de redirection de client MAPI. Par exemple, une semaine avant de rétrograder un serveur de catalogue global au rang de serveur membre, vous devriez coder de manière irréversible l'entrée RFR Target Server pour un groupe défini de serveurs de catalogue global. Vous êtes ainsi sûr que le serveur de catalogue global à rétrograder n'est plus référencé dans les profils MAPI des clients Outlook. Pour plus d'informations sur cette utilisation spécifique de l'entrée de Registre RFR Target Server, voir l'article 305065 de la Base de connaissance Microsoft sur les considérations relatives au serveur Exchange pour rétrograder un serveur de catalogue global au rang de contrôleur de domaine (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour utiliser la valeur de Registre RFR Target Server

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Créez une nouvelle valeur REG_MULTISZ nommée RFR Target Server.

  4. Configurez la valeur RFR Target Server avec le nom de domaine complet du ou des serveurs à spécifier.

  5. Fermez l'Éditeur du Registre et redémarrez le service Surveillance du système Microsoft Exchange pour que la modification soit prise en compte.

Pour désactiver un paramètre statique pour le serveur RFR, supprimez l'entrée de nom de domaine complet du serveur à supprimer. Si un seul serveur cible RFR est indiqué, supprimez la valeur de Registre RFR Target Server.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'interaction entre les clients Outlook 2000 SR-2 et versions ultérieures et le service d'annuaire Active Directory®, voir les articles suivants de la Base de connaissances Microsoft :

  • 302914 sur l'accès d'Outlook 2000 à Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914)

  • 256976 sur l'accès des clients MAPI à Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976)


RegTrace est actuellement activé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le suivi de diagnostic avancé a été activé sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

Si Exchange Server Analyzer détecte que l'entrée de Registre EnabledTraces est présente et configurée avec une valeur autre que 0, une erreur s'affiche.

Le suivi de diagnostic avancé des composants de transport et de routage d'Exchange Server peut être effectué à l'aide de l'utilitaire Regtrace (Regtrace.exe). Regtrace est un outil particulièrement utile pour le diagnostic et la résolution de problèmes liés aux rapports de non-remise. L'utilitaire Regtrace se trouve sur le CD-ROM d'Exchange Server dans le dossier \Support\Utils\I386.

Le fichier de suivi est disponible à l'emplacement spécifié sous l'onglet Output (Sortie) de l'utilitaire Regtrace. C:\Trace.atf est l'emplacement par défaut du fichier. Le fichier de suivi est un fichier codé binaire qui contient des informations de niveau de débogage sur les composants de transport et de routage faisant l'objet d'un suivi. C'est pour cela que les services du Support Technique de Microsoft requièrent des clients l'envoi des fichiers de suivi pour analyse interne.

Si vous ne résolvez pas de problème, Microsoft vous avertit que l'activation de Regtrace entraîne de graves problèmes de performances au niveau du serveur et ne devrait être utilisée que pour de courtes périodes sur les recommandations des services du Support Technique de Microsoft. De plus, l'espace disque nécessaire au fichier de suivi peut être utilisé à hauteur de 10 mégaoctets (Mo) par minute au moins. Pour supprimer cette erreur si vous n'êtes pas en train de résoudre un problème, vous pouvez utiliser Regtrace pour désactiver le suivi.

Pour désactiver le suivi de diagnostic avancé avec Regtrace

  1. Copiez Regtrace.exe figurant sur le CD-ROM d'Exchange Server sur l'ordinateur Exchange Server.

  2. Exécutez Regtrace.exe sur l'ordinateur Exchange Server. L'interface utilisateur Regtrace s'affiche.

  3. Sous l'onglet Traces (Suivis), désactivez toutes les cases à cocher.

  4. Sélectionnez l'onglet Output (Sortie), puis No Tracing (Aucun suivi).

  5. Cliquez sur OK pour enregistrer vos modifications et fermer l'utilitaire Regtrace.
  • Pour plus d'informations sur l'outil Regtrace, voir l'article 238614 de la Base de connaissances Microsoft sur la procédure de configuration de Regtrace pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614).

  • Pour plus d'informations sur le dépannage de messages, voir l'article 281800 de la Base de connaissances sur le dépannage des problèmes de message dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800).


Rejection threshold not configured
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-07-30

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur des attributs suivants sur tous les objets avec une classe ContentFilterConfig :

msExchAgentsFlags La valeur de l'attribut msExchAgentsFlag indique le statut de l'action de rejet du seuil SCL et de l'agent de filtrage du contenu de Microsoft Exchange Server 2007. Lorsque l'agent de filtrage du contenu est activé sur un ordinateur, il filtre tous les messages en provenance de tous les connecteurs de réception sur cet ordinateur. Si elle est activée, l'action de rejet SCL envoie une réponse de rejet pendant la transaction SMTP pour tous les messages qui dépassent le seuil de rejet SCL.

msExchMessageHygieneSCLRejectThreshold La valeur de l'attribut msExchMessageHygieneSCLRejectThreshold indique le niveau défini pour l'action de rejet SCL. Cette valeur représente la valeur du seuil SCL qu'un message particulier doit dépasser pour que l'agent de filtrage du contenu le supprime et envoie un rapport de non-remise à l'expéditeur.

Exchange Analyzer exécute également la cmdlet Exchange Management Shell suivante pour interroger tous les rôles serveur de transport Hub sur lesquels les agents de blocage du courrier indésirable sont installés :

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

Si Exchange Analyzer détecte que toutes les conditions suivantes existent pour un serveur, il affiche un avertissement :

  • Filtrage du contenu activé

  • Action de rejet SCL activée

  • Seuil de rejet SCL défini sur 9

  • Les agents de blocage du courrier indésirable sont activés sur le serveur.

Cet avertissement indique que, malgré l'activation du filtrage du contenu et de l'action de rejet SCL, le seuil de l'action de rejet SCL est défini sur la valeur par défaut (9), ce qui peut provoquer le rejet de messages provenant d'utilisateurs légitimes. Le paramètre recommandé pour la valeur du seuil de l'action de rejet SCL est 7.

Pour supprimer cet avertissement, définissez la valeur du seuil de l'action de rejet SCL sur 7 à l'aide de l'onglet Anti-spam de la console de gestion Exchange ou de la cmdlet Set-ContentFilterConfig d'Exchange Management Shell.

Pour configurer le seuil de l'action de rejet SCL, suivez les instructions de la rubrique sur la procédure d'activation et de configuration des seuils SCL (http://go.microsoft.com/fwlink/?LinkId=96099) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations

Pour plus d'informations sur la gestion des fonctions antispam et antivirus d'Exchange Server 2007, voir la rubrique correspondante (http://go.microsoft.com/fwlink/?LinkId=96103) dans la documentation sur le produit Exchange Server 2007.


Service de mise à jour de destinataire supprimé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchAddressListServiceLink pour chaque objet du service de mise à jour de destinataire de l'annuaire. L'attribut msExchAddressListServiceLink est un lien du service de liste d'adresses vers l'ordinateur Exchange Server sur lequel il devrait être exécuté. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchAddressListServiceLink est définie sur DEL:, une erreur s'affiche.

Chaque instance du service de mise à jour de destinataire est associée à un ordinateur Exchange Server qui utilise le service de mise à jour de destinataire. Si vous recevez ce message, l'instance du service de mise à jour de destinataire est associée à un ordinateur Exchange Server qui n'existe pas dans l'organisation Exchange. Le serveur a pu être désactivé ou supprimé de la topologie.

Pour exécuter cette instance du service de mise à jour de destinataire, vous devez l'associer à un serveur Exchange existant.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Services de mise à jour de destinataire. Dans le volet droit, cliquez avec le bouton droit sur l'instance appropriée du service de mise à jour de destinataire, puis cliquez sur Propriétés.

  3. Sous Exchange Server, sous l'onglet Général, cliquez sur Parcourir et spécifiez un nouveau serveur exécutant cette instance.

  4. Cliquez sur OK, puis cliquez de nouveau sur OK pour que la modification soit prise en compte.

  5. Fermez le Gestionnaire système Exchange.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les rubriques Exchange et les articles suivants de la Base de connaissances Microsoft :

  • sur la gestion des destinataires et des stratégies de destinataire dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617).

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127 sur la procédure de vérification des progrès du service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Recipient Update Service is missing or is not configured
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-07-11

L'outil Microsoft Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut msExchAddressListServiceLink pour chaque objet Recipient Update Service de l'annuaire. L'attribut msExchAddressListServiceLink est un lien du service de liste d'adresses vers l'ordinateur Exchange Server sur lequel il est utilisé. Si Exchange Analyzer détecte qu'il n'existe aucun attribut msExchAddressListServiceLink pour l'objet Recipient Update Service ou que la valeur de l'attribut msExchAddressListServiceLink pour l'objet n'est pas renseignée, une erreur s'affiche.

Chaque instance du service de mise à jour de destinataire est généralement associée à un ordinateur Exchange Server qui utilise le service de mise à jour de destinataire. Si vous recevez ce message, l'instance du service de mise à jour de destinataire n'est associée à aucun ordinateur Exchange Server. Les destinataires et listes d'adresses Exchange risquent de ne pas être mis à jour.

Pour exécuter cette instance du service de mise à jour de destinataire, vous devez l'associer à un serveur Exchange existant.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Services de mise à jour de destinataire. Dans le volet droit, cliquez avec le bouton droit sur l'instance appropriée du service de mise à jour de destinataire, puis cliquez sur Propriétés.

  3. Sous Exchange Server, sous l'onglet Général, cliquez sur Parcourir et spécifiez un serveur exécutant cette instance.

  4. Cliquez sur OK, puis cliquez de nouveau sur OK pour que la modification soit prise en compte.

  5. Fermez le Gestionnaire système Exchange.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les rubriques et les articles suivants de la Base de connaissances Microsoft :

  • Article sur la gestion des destinataires et des stratégies de destinataire dans Exchange Server 2003 dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617)

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828 sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127 sur la procédure de vérification des progrès du service de mise à jour de destinataire Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127)

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770)


La liaison RPC ne contient pas de nom de domaine complet
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur ncacn_ip_tcp de l'attribut networkAddress contient un nom de domaine complet (FQDN). Si Exchange Server Analyzer détecte que la valeur ncacn_ip_tcp ne contient pas de point (.), il affiche une erreur.

Dans Microsoft Office Outlook® Web Access pour Exchange Server 2003, le serveur frontal examine la valeur de l'attribut networkaddress lors de toute tentative de connexion à un serveur Exchange principal.

Remarque :
Outlook Web Access pour Exchange 2000 Server n'effectue pas cette tâche. Le serveur frontal nécessite une valeur de nom de domaine complet.

Le serveur frontal recherche un point dans la valeur renvoyée pour networkaddress ncacn_ip_tcp. La demande de connexion pour la boîte aux lettres du serveur principal spécifique échoue et le serveur frontal renvoie un message d'erreur « HTTP 500 Erreur interne au serveur » à l'utilisateur si les conditions suivantes existent :

  • La valeur ncacn_ip_tcp n'est qu'un nom d'hôte ou un nom système d'entrée/sortie de base (NetBIOS).

  • La valeur ncacn_ip_tcp n'est pas un nom de domaine complet.

Vous devez mettre à jour la valeur ncacn_ip_tcp sur l'objet de serveur dans Active Directory pour vous assurer qu'Outlook Web Access pour Exchange Server 2003 fonctionne correctement. Les résultats d'Exchange Server Analyzer fournissent le nom du serveur affecté.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Remarque :
Avant de mettre à jour la valeur ncacn_ip_tcp, lisez le reste de cet article. Vous devez effectuer une procédure supplémentaire avant de redémarrer les services Exchange Server.
Pour mettre à jour la valeur ncacn_ip_tcp de l'attribut networkAddress

  1. Lancez l'outil ADSI Edit à partir des outils de support de Windows 2000 Server ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Groupes_administration

    • Nom_groupe_administration

    • Serveurs

  3. Cliquez avec le bouton droit sur Nom_serveur_Exchange, puis cliquez sur Propriétés.

  4. Cliquez sur networkaddress dans la liste Attributs, puis sur Modifier.

  5. Ajoutez une nouvelle valeur pour ncacn_ip_tcp. Utilisez le nom de domaine complet du serveur au lieu du nom NetBIOS ou du nom d'hôte du serveur.

    La syntaxe de cette valeur est ncacn_ip_tcp:nom_domaine_complet. Par exemple, si votre serveur principal Exchange porte le nom d'hôte EXCHANGE1 et le nom de domaine complet EXCHANGE1.contoso.com, utilisez la valeur suivante pour ncacn_ip_tcp : ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Supprimez la valeur originale ncacn_ip_tcp qui contient le nom NetBIOS ou le nom d'hôte du serveur principal en la sélectionnant et en cliquant sur Supprimer. Cliquez deux fois sur OK pour appliquer la modification.

  7. Redémarrez tous les services Exchange Server sur le serveur.

  8. S'il existe plusieurs contrôleurs de domaine, attendez l'exécution de la réplication avant de tenter de vous connecter à partir du serveur frontal. Si le problème n'est pas résolu après l'exécution de la réplication, redémarrez le service d'administration IIS sur le serveur frontal.

Si vous mettez à jour des fichiers d'hôte sur des serveurs principaux pour mettre en corrélation une adresse IP serveur portant un nom d'hôte court, vous devez également mettre à jour la valeur de Registre UpdateProtocols. En cas d'utilisation d'un fichier d'hôte, Exchange Server peut rétablir la valeur ncacn_ip_tcp lors du redémarrage du service Surveillance du système Microsoft. Si le serveur principal est en clusters, Exchange Server peut rétablir la valeur ncacn_ip_tcp après le basculement.

Pour réduire le temps d'arrêt dû au redémarrage des services Exchange Server, effectuez la procédure suivante avant le redémarrage en mettant à jour la valeur ncacn_ip_tcp de l'attribut networkaddress comme décrit dans la procédure précédente.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour modifier la valeur de Registre UpdateProtocols pour les serveurs principaux qui utilisent des fichiers d'hôte

  1. Utilisez un Éditeur du Registre pour configurer la valeur de Registre suivante sur les serveurs principaux : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Remarque :
    Si la valeur UpdateProtocols n'est pas présente, vous devez la créer. Pour ce faire, effectuez la procédure suivante :
    1. Ouvrez un Éditeur du Registre et recherchez la sous-clé de Registre suivante : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    2. Cliquez avec le bouton droit sur Paramètres, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

    3. Entrez UpdateProtocols, puis appuyez sur ENTRÉE.

  2. Cliquez avec le bouton droit sur UpdateProtocols, cliquez sur Modifier, entrez 0 dans le champ Données de la valeur, puis cliquez sur OK.

  3. Si votre réseau utilise un fichier Hosts sur le nœud de cluster principal, modifiez l'ordre de saisie de UpdateProtocols comme suit :

    IPAddress to FQDN

    IPAddress to NetBIOS

    au lieu de :

    IPAddress to NetBIOS

    IPAddress to FQDN

  4. Redémarrez tous les services Exchange Server sur le serveur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La liaison RPC ne correspond pas au nom résolu DNS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool tente d'exécuter une requête DNS (Domain Name System) sur les serveurs DNS configurés pour chaque ordinateur Exchange Server. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une demande de résolution de nom et analyse les résultats. Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer si la valeur ncacn_ip_tcp de serveur de l'attribut networkAddress et le nom de domaine complet renvoyés après la résolution DNS sont différents. L'attribut networkAddress est un attribut de chaque objet Exchange Server dans Active Directory. Si Exchange Server Analyzer détecte que la valeur ncacn_ip_tcp de serveur dans Active Directory ne correspond pas au nom de domaine complet après la résolution DNS, il affiche un avertissement.

Cette situation survient si le nom de domaine complet du serveur est modifié après l'installation d'Exchange. Exchange Server et Active Directory nécessitent, pour fonctionner correctement, un DNS correctement configuré et sain. Les problèmes de résolution et d'enregistrement DNS peuvent affecter de manière significative la capacité de l'ordinateur Exchange Server à envoyer, recevoir et remettre des messages. Vous pouvez éviter ces problèmes si vous faites correspondre les deux adresses en modifiant manuellement l'attribut networkAddress sur l'objet Exchange Server dans Active Directory.

Vous devez mettre à jour la valeur ncacn_ip_tcp sur l'objet serveur dans Active Directory pour s'assurer que la valeur ncacn_ip_tcp correspond au nom de domaine complet DNS du serveur. Les résultats d'Exchange Server Analyzer fournissent le nom du serveur affecté.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Mise à jour de la valeur ncacn_ip_tcp de l'attribut networkAddress

  1. Lancez l'outil ADSI Edit à partir des outils de support de Windows® 2000 ou Windows Server 2003.

  2. Développez les noeuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Groupes_administration

    • Nom_groupe_administration

    • Serveurs

  3. Cliquez avec le bouton droit sur Nom_serveur_Exchange, puis cliquez sur Propriétés.

  4. Cliquez sur adresse_réseau dans la liste Attributs, puis sur Modifier.

  5. Ajoutez une nouvelle valeur pour ncacn_ip_tcp. Utilisez le nom de domaine complet du serveur au lieu de la valeur actuelle.

    La syntaxe de cette valeur est ncacn_ip_tcp:nom_domaine_complet. Par exemple, si votre serveur Exchange porte le nom d'hôte EXCHANGE1 et le nom de domaine complet EXCHANGE1.contoso.com, utilisez la valeur suivante pour ncacn_ip_tcp : ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Supprimez la valeur originale ncacn_ip_tcp qui contient le nom incorrect ou le nom d'hôte du serveur principal en la sélectionnant et en cliquant sur Supprimer. Cliquez deux fois sur OK pour appliquer la modification.

  7. Redémarrez tous les services Exchange Server sur le serveur.

Pour plus d'informations sur l'utilisation du DNS avec Active Directory, consultez l'article 323418 de la Base de connaissances Microsoft sur la procédure d'intégration d'un DNS à une infrastructure DNS existante si Active Directory est activé dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418).


L'ordre de liaison RPC est incorrect
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer l'ordre de liaison des appels de procédure distante (RPC) utilisé par l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Si Exchange Server Analyzer détecte que la valeur de Rpc_Svr_Binding_Order ne commence pas par ncacn_ip_tcp, une erreur s'affiche.

L'entrée de Registre Rpc_Svr_Binding_Order est créée lorsque vous installez Exchange Server sur un ordinateur. Cette entrée détermine la séquence de protocole utilisée pendant la communication RPC de serveur à serveur.

Par défaut, l'entrée Rpc_Svr_Binding_Order contient les données de valeur suivantes :

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Remarque :
Des valeurs supplémentaires peuvent se trouver dans cette chaîne si d'autres protocoles sont également installés sur l'ordinateur Exchange Server.

Cette entrée spécifie l'ordre dans lequel Exchange Server essaye les protocoles de communication réseau pour la communication RPC avec d'autres serveurs. Par exemple, le protocole TCP/IP étant spécifié en premier, Exchange Server tente d'abord de communiquer avec d'autres serveurs à l'aide de l'appel de procédure à distance (RPC) sur TCP/IP avant d'essayer sur d'autres protocoles.

Il est recommandé de ne pas modifier la valeur par défaut de l'ordre de liaison RPC. Si la valeur par défaut est modifiée, vous pouvez rencontrer des problèmes de communication de serveur à serveur ou au démarrage du serveur ou du service.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Dans le volet droit, double-cliquez sur Rpc_Svr_Binding_Order.

  4. Dans la boîte de dialogue Données de la valeur, entrez ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Cliquez sur OK, puis fermez l'Éditeur du Registre.

  6. Redémarrez tous les services Exchange Server ou l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'ordre de liaison RPC, voir l'article 325930 de la Base de connaissances sur la procédure de résolution des problèmes de connexion provoqués par des entrées de Registre du protocole client RPC (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930).


L'entrée de Registre Rpc_Binding_Order est présente
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour vérifier la présence d'une entrée de Registre d'ordre de liaison des appels de procédure distante (RPC) orienté client sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

Si Exchange Server Analyzer détecte que la valeur Rpc_Binding_Order est présente, un avertissement s'affiche.

Si la valeur Rpc_Binding_Order est présente, cela indique qu'un ou plusieurs éléments suivants sont installés sur l'ordinateur :

  • Exchange Server version 5.5 ;

  • Microsoft Office Outlook® 2003 ;

  • Windows Clustering.

  • L'entrée RPC_Binding_Order détermine la séquence de protocole utilisée lors du lancement de la communication RPC d'Outlook. Cette entrée n'est pas créée dans Exchange Server 2003 ni dans Exchange 2000 Server. Cette entrée n'est créée que dans Exchange Server 5.5 et les versions précédentes d'Exchange. Si Exchange Server 5.5 ou Microsoft Outlook ont été précédemment installés sur cet ordinateur, puis supprimés, vous pouvez effacer manuellement cette entrée de Registre. En outre, vous devez supprimer Outlook de tous les ordinateurs utilisant Exchange Server car cette configuration n'est pas prise en charge. Pour plus d'informations sur l'exécution d'Exchange et Outlook sur le même ordinateur, voir l'article 266418 de la Base de connaissances Microsoft sur Microsoft qui recommande de ne pas installer Exchange Server et Outlook sur le même ordinateur (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer l'entrée de Registre Rpc_Binding_Order

  1. Ouvrez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Supprimez la valeur Rpc_Binding_Order.

  4. Fermez l'Éditeur du Registre et redémarrez tous les services Exchange Server ou l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'entrée de Registre RPC_Binding_Order, voir les articles suivants de la Base de connaissances :

  • 325930 sur la procédure de résolution des problèmes de connexion provoqués par des entrées de Registre du protocole client RPC (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930)

  • 326036 sur l'impossibilité d'ouvrir une session sur l'ordinateur Exchange 2000 Server à l'aide des informations d'identification correctes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036)


La valeur par défaut de Registre Rpc_Svr_Binding_Order a été modifiée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer l'ordre de liaison des appels de procédure distante (RPC) utilisé par l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Si Exchange Server Analyzer détecte que la valeur de Rpc_Svr_Binding_Order n'est pas définie sur ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp, un avertissement s'affiche.

L'entrée de Registre Rpc_Svr_Binding_Order est créée lorsque vous installez Exchange Server sur un ordinateur. Cette entrée détermine la séquence de protocole utilisée pendant la communication RPC de serveur à serveur.

Par défaut, l'entrée Rpc_Svr_Binding_Order contient les données de valeur suivantes :

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Remarque :
Des valeurs supplémentaires peuvent se trouver dans la chaîne ci-dessus si d'autres protocoles sont également installés sur l'ordinateur Exchange Server.

Cette entrée spécifie l'ordre dans lequel Exchange Server essaye les protocoles de communication réseau pour la communication RPC avec d'autres serveurs. Par exemple, le protocole TCP/IP étant spécifié en premier, Exchange Server tente d'abord de communiquer avec d'autres serveurs à l'aide de l'appel de procédure à distance (RPC) sur TCP/IP avant d'essayer sur d'autres protocoles.

Microsoft recommande de ne pas modifier la valeur par défaut de l'ordre de liaison RPC. Si la valeur par défaut est modifiée, vous pouvez rencontrer des problèmes de communication de serveur à serveur ou au démarrage du serveur ou du service.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Dans le volet droit, double-cliquez sur Rpc_Svr_Binding_Order.

  4. Dans la boîte de dialogue Données de la valeur, entrez ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Cliquez sur OK, puis fermez l'Éditeur du Registre.

  6. Redémarrez tous les services Exchange Server ou l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'ordre de liaison RPC, voir l'article 325930 de la Base de connaissances sur la procédure de résolution des problèmes de connexion provoqués par des entrées de Registre du protocole client RPC (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930).


La durée des boucles avec le serveur de Active Directory est supérieure à 100 ms
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft WIN32_PingStatus de l'espace de noms root\cimv2 pour déterminer la valeur de la clé ResponseTime. Si Exchange Server Analyzer détecte que la valeur de la clé ResponseTime est supérieure à 100 millisecondes (ms), une erreur s'affiche.

La clé ResponseTime représente le temps écoulé (en millisecondes) pour répondre à la demande d'écho ICMP (Internet Control Message Protocol) (ping). Les contrôleurs de domaine utilisés par un ordinateur Exchange Server doivent toujours avoir un temps de réponse égal ou inférieur à 10 ms. Si le temps de réponse dépasse 100 ms, cela peut indiquer des problèmes de performances ou de connectivité.

Pour corriger cette erreur

  1. Vérifiez que le contrôleur de domaine en question n'est pas surchargé. Utilisez l'outil ADTest.exe pour exécuter des tests sur le contrôleur de domaine et ainsi déterminer si le matériel peut gérer la charge prévue.

  2. Vérifiez les journaux d'événements sur le serveur Exchange et le contrôleur de domaine pour voir si les événements liés au réseau qui indiquent un ou plusieurs problèmes ont été consignés.

  3. Utilisez les commandes DCDiag.exe et NetDiag.exe sur le contrôleur de domaine pour vérifier la configuration correcte et le bon fonctionnement.

  4. Enfin, recherchez la conception de site du service d'annuaire Active Directory®. Un site Active Directory est considéré comme une section réseau disposant d'une bande passante élevée et d'une latence faible. Si le réseau n'est pas partitionné selon cette spécification, envisagez de le partitionner en plusieurs sites Active Directory.
Remarque :
Si l'outil Analyzer exécute la requête WMI pour le test ping, la taille de paquet par défaut et les valeurs de délai sont remplacées. Analyzer utilise plutôt une taille de paquet ICMP de 4 096 (au lieu de la valeur par défaut de 32 octets) et une valeur de délai de 2 000 ms (au lieu de la valeur par défaut de 1 000 ms).

Procédez comme suit pour émuler manuellement le comportement de ping d'Analyzer.

Pour effectuer un test ping manuellement

  • Exécutez la commande suivante dans la fenêtre de ligne de commande du serveur Exchange : ping -L 4096 -N 6 <Active Server server name>Remarque La commande lance six requêtes ping de 4 096 octets chacune.

Pour plus d'informations sur l'outil ADTest.Exe, voir la page Web sur l'outil Active Directory Performance Testing Tool (ADTest.exe) (http://go.microsoft.com/fwlink/?LinkId=33758).

Pour plus d'informations sur la classe WMI Win32 PingStatus, voir l'article de MSDN® sur Win32_PingStatus (http://go.microsoft.com/fwlink/?LinkId=33549).

Pour plus d'informations sur la conception du site d'Active Directory, voir le document sur la conception de la topologie de site (http://go.microsoft.com/fwlink/?linkid=33551).


La durée des boucles avec le serveur de Active Directory est supérieure à 10 ms
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft WIN32_PingStatus de l'espace de noms root\cimv2 pour déterminer la valeur de la clé ResponseTime. Si Exchange Server Analyzer détecte que la valeur de la clé ResponseTime est supérieure à 10 millisecondes (ms) mais inférieure à 100 ms, un avertissement s'affiche.

La clé ResponseTime représente le temps écoulé (en millisecondes) de la réponse aux paquets de demandes d'écho ICMP (Internet Control Message Protocol) (ping) envoyés du serveur Exchange vers le contrôleur de domaine. Les contrôleurs de domaine utilisés par un ordinateur Exchange Server doivent toujours avoir un temps de réponse égal ou inférieur à 10 ms. Si le temps de réponse dépasse 10 ms, cela peut indiquer des problèmes de performances ou de connectivité.

Pour supprimer cet avertissement

  1. Vérifiez que le contrôleur de domaine en question n'est pas surchargé. Utilisez l'outil ADTest.exe pour exécuter des tests sur le contrôleur de domaine et ainsi déterminer si le matériel peut gérer la charge prévue.

  2. Vérifiez les journaux d'événements sur le serveur Exchange et le contrôleur de domaine pour voir si les événements liés au réseau qui indiquent un ou plusieurs problèmes ont été consignés.

  3. Utilisez les commandes DCDiag.exe et NetDiag.exe sur le contrôleur de domaine pour vérifier la configuration correcte et le bon fonctionnement.

  4. Enfin, recherchez la conception de site du service d'annuaire Active Directory®. Un site Active Directory est considéré comme une section réseau disposant d'une bande passante élevée et d'une latence faible. Si le réseau n'est pas partitionné selon cette spécification, envisagez de le partitionner en plusieurs sites Active Directory.
Remarque :
Si l'outil Analyzer exécute la requête WMI pour le test ping, la taille de paquet par défaut et les valeurs de délai sont remplacées. Analyzer utilise plutôt une taille de paquet ICMP de 4 096 (au lieu de la valeur par défaut de 32 octets) et une valeur de délai de 2 000 ms (au lieu de la valeur par défaut de 1 000 ms).

Procédez comme suit pour émuler manuellement le comportement de ping d'Analyzer.

Pour effectuer un test ping manuellement

  • Exécutez la commande suivante dans la fenêtre de ligne de commande du serveur Exchange : ping -L 4096 -N 6 <Active Server server name>Remarque La commande lance six requêtes ping de 4 096 octets chacune.

Pour plus d'informations sur l'outil ADTest.Exe, voir la page Web sur l'outil Active Directory Performance Testing Tool (ADTest.exe) (http://go.microsoft.com/fwlink/?LinkId=33758).

Pour plus d'informations sur la classe WMI Win32 PingStatus, voir l'article de MSDN® sur Win32_PingStatus (http://go.microsoft.com/fwlink/?LinkId=33549).

Pour plus d'informations sur la conception du site d'Active Directory, voir le document sur la conception de la topologie de site (http://go.microsoft.com/fwlink/?linkid=33551).


La durée des boucles avec le serveur de catalogue global supérieure à 100 ms
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft WIN32_PingStatus de l'espace de noms root\cimv2 pour déterminer la valeur de la clé ResponseTime. Si Exchange Server Analyzer détecte que la valeur de la clé ResponseTime est supérieure à 100 millisecondes (ms), une erreur s'affiche.

La clé ResponseTime représente le temps écoulé (en millisecondes) de la réponse aux paquets de demandes d'écho ICMP (Internet Control Message Protocol) (ping) envoyés d'Exchange Server vers le serveur de catalogue global. Le temps de réponse des serveurs de catalogue global utilisés par un ordinateur Exchange Server doit toujours être inférieur ou égal à 10 ms. Si celui-ci est supérieur à 10 ms, des problèmes de performances ou de connectivité peuvent survenir.

Pour corriger cette erreur

  1. Assurez-vous que le serveur de catalogue global en question n'est pas surchargé. Utilisez l'outil ADTest.exe pour exécuter des tests sur le serveur de catalogue global et ainsi déterminer si le matériel peut gérer la charge prévue.

  2. Examinez les journaux d'événements sur le serveur Exchange et le serveur de catalogue global pour voir si les événements liés au réseau qui indiquent un ou plusieurs problèmes ont été consignés.

  3. Utilisez les commandes DCDiag.exe et NetDiag.exe sur le serveur de catalogue global pour vérifier la configuration correcte et le bon fonctionnement.

  4. Enfin, recherchez la conception de site du service d'annuaire Active Directory®. Un site Active Directory est considéré comme une section réseau disposant d'une bande passante élevée et d'une latence faible. Si le réseau n'est pas partitionné selon cette spécification, envisagez de le partitionner en plusieurs sites Active Directory.
Remarque :
Si l'outil Analyzer exécute la requête WMI pour le test ping, la taille de paquet par défaut et les valeurs de délai sont remplacées. Analyzer utilise plutôt une taille de paquet ICMP de 4 096 (au lieu de la valeur par défaut de 32 octets) et une valeur de délai de 2 000 ms (au lieu de la valeur par défaut de 1 000 ms).

Procédez comme suit pour émuler manuellement le comportement de ping d'Analyzer.

Pour effectuer un test ping manuellement

  • Exécutez la commande suivante dans la fenêtre de ligne de commande du serveur Exchange : ping -L 4096 -N 6 <Active Server server name>Remarque La commande lance six requêtes ping de 4 096 octets chacune.

Pour plus d'informations sur l'outil ADTest.exe, voir la page Web sur l'outil Active Directory Performance Testing Tool (ADTest.exe) (http://go.microsoft.com/fwlink/?LinkId=33758).

Pour plus d'informations sur la classe WMI Win32 PingStatus, voir l'article de MSDN® sur Win32_PingStatus (http://go.microsoft.com/fwlink/?LinkId=33549).

Pour plus d'informations sur la conception du site d'Active Directory, voir le document sur la conception de la topologie de site (http://go.microsoft.com/fwlink/?linkid=33551).

Pour plus d'informations sur l'installation des outils de support de Windows 2000 Server, voir l'article 301423 de la Base de connaissances Microsoft sur la procédure d'installation des outils de support de Windows 2000 sur un ordinateur Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301423).

Pour plus d'informations sur l'installation des outils de support de Windows Server 2003, voir l'article sur l'installation des outils de support de Windows (http://go.microsoft.com/fwlink/?LinkId=41362).


La durée des boucles avec le serveur de catalogue global supérieure à 10 ms
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft WIN32_PingStatus de l'espace de noms root\cimv2 pour déterminer la valeur de la clé ResponseTime. Si Exchange Server Analyzer détecte que la valeur de la clé ResponseTime est supérieure à 10 millisecondes (ms) mais inférieure à 100 ms, un avertissement s'affiche.

La clé ResponseTime représente le temps écoulé (en millisecondes) de la réponse aux paquets de demandes d'écho ICMP (Internet Control Message Protocol) (ping) envoyés d'Exchange Server vers le serveur de catalogue global. Le temps de réponse des serveurs de catalogue global utilisés par un ordinateur Exchange Server doit toujours être inférieur ou égal à 10 millisecondes. Si le temps de réponse dépasse 10 millisecondes, des problèmes de performances ou de connectivité peuvent se produire.

Pour supprimer cet avertissement

  1. Assurez-vous que le serveur de catalogue global en question n'est pas surchargé. Utilisez l'outil ADTest.exe pour exécuter des tests sur le serveur de catalogue global et ainsi déterminer si le matériel peut gérer la charge prévue.

  2. Vérifiez dans les journaux d'événements sur le serveur Exchange et le serveur de catalogue global si les événements liés au réseau qui indiquent un ou plusieurs problèmes ont été consignés.

  3. Utilisez les commandes DCDiag.exe et NetDiag.exe sur le serveur de catalogue global pour vérifier la configuration correcte et le bon fonctionnement.

  4. Enfin, recherchez la conception de site du service d'annuaire Active Directory®. Un site Active Directory est considéré comme une section réseau disposant d'une bande passante élevée et d'une latence faible. Si le réseau n'est pas partitionné selon cette spécification, envisagez de le partitionner en plusieurs sites Active Directory.
Remarque :
Si l'outil Analyzer exécute la requête WMI pour le test ping, la taille de paquet par défaut et les valeurs de délai sont remplacées. Analyzer utilise plutôt une taille de paquet ICMP de 4 096 (au lieu de la valeur par défaut de 32 octets) et une valeur de délai de 2 000 ms (au lieu de la valeur par défaut de 1 000 ms).

Procédez comme suit pour émuler manuellement le comportement de ping d'Analyzer.

Pour effectuer un test ping manuellement

  • Exécutez la commande suivante dans la fenêtre de ligne de commande du serveur Exchange :

    ping -L 4096 -N 6 <Active Server server name>

    Remarque :
    La commande lance six requêtes ping de 4 096 octets chacune.

Pour plus d'informations sur l'outil ADTest.exe, voir la page Web sur l'outil Active Directory Performance Testing Tool (ADTest.exe) (http://go.microsoft.com/fwlink/?LinkId=33758).

Pour plus d'informations sur la classe WMI Win32 PingStatus, voir l'article de MSDN® sur Win32_PingStatus (http://go.microsoft.com/fwlink/?LinkId=33549).

Pour plus d'informations sur la conception du site d'Active Directory, voir le document sur la conception de la topologie de site (http://go.microsoft.com/fwlink/?linkid=33551).


Changement du filtre de recherche nécessaire pour la stratégie de destinataire
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut purportedSearch pour chaque objet Stratégie de destinataire Exchange. L'attribut purportedSearch indique l'argument de recherche utilisé lors de l'application de la stratégie.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msDS-Behavior-Version de l'objet de forêt dans Active Directory, Paramètres NTDS. Cette valeur indique le niveau fonctionnel de la forêt Active Directory. Les valeurs valides pour l'attribut msDS-Behavior-Version sont indiquées dans le tableau suivant.

Valeur | Niveau fonctionnel de la forêt
0 | Microsoft Windows® 2000 Server mixte
1 | Microsoft Windows Server™ 2003 intermédiaire
2 | Windows Server 2003 natif

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut revision du conteneur Windows2003Update. La valeur de cet attribut indique si l'outil de préparation d'Active Directory (ADPrep.exe) a été exécuté.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de la clé OSProductSuite indique la version de Windows utilisée sur l'ordinateur.

Si Exchange Server Analyzer détermine que les critères suivants sont vrais, un avertissement s'affiche :

  • La valeur de l'attribut purportedSearch de la stratégie de destinataire contient homeMdb.

  • Le niveau fonctionnel de la forêt Active Directory est Windows Server 2003 intermédiaire ou Windows Server 2003 natif.

  • L'ordinateur Exchange Server n'utilise pas Microsoft Windows Small Business Server 2003.

Cet avertissement indique que la forêt Active Directory a été préparée pour Windows Server 2003. Pour éviter des problèmes de tampon d'adresse de courrier électronique lors de la mise à niveau de la forêt vers le niveau complet de fonctionnalité Windows Server 2003, il est nécessaire de modifier les stratégies de destinataire. La stratégie de destinataire concernée est spécifiée dans les résultats d'Exchange Server Analyzer.

Si Windows Server 2003 est utilisé comme contrôleur de domaine et si la stratégie de destinataire n'est pas mise à jour, la réplication de la valeur y afférente dans Windows Server 2003 entraîne une écriture incorrecte des adresses électroniques des nouveaux utilisateurs par le service de mise à jour de destinataire. La première rencontre entre le service de mise à jour de destinataire et l'utilisateur peut avoir lieu entre le moment de la réplication mailnickname et homeMDB en raison de la réplication de la valeur y afférente. Par conséquent, à ce moment, l'utilisateur sera soumis à la stratégie par défaut et non à la stratégie basée sur homeMDB. Quelques minutes plus tard, lors de la réplication homeMDB, l'utilisateur sera couvert par leur stratégie homeMDB. Toutefois, l'utilisateur aura déjà des adresses qui correspondent à la stratégie par défaut.

Pour supprimer cet avertissement

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataires, sélectionnez Stratégies de destinataire, cliquez avec le bouton droit sur Nom_stratégie_destinataire, puis cliquez sur Propriétés.

  3. Sur la page Propriétés de Nom_stratégie_destinataire, sous l'onglet Général, sous Règles de filtrage, cliquez sur Modifier.

  4. Dans le menu Find Exchange Recipients, sélectionnez Recherche personnalisée. Si la stratégie de destinataire a été créée par une recherche personnalisée, la page Find Custom Search s'affiche lorsque vous cliquez sur Modifier à l'étape 3.

  5. Modifiez la requête LDAP (Lightweight Directory Access Protocol) pour que l'attribut homeMdb ne soit pas utilisé comme une partie de condition de filtre. Des attributs tels que extensionAttribute, msExchHomeServerName ou UPN sont des arguments valides qui peuvent aider à atteindre le même résultat de recherche.

  6. Cliquez sur OK pour enregistrer la modification, puis fermez le Gestionnaire système Exchange.


Changement du filtre de recherche nécessaire pour la stratégie de destinataire
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut purportedSearch pour chaque objet Stratégie de destinataire Exchange. L'attribut purportedSearch indique l'argument de recherche utilisé lors de l'application de la stratégie.

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut msDS-Behavior-Version de l'objet de forêt dans Active Directory, Paramètres NTDS. Cette valeur indique le niveau fonctionnel de la forêt Active Directory. Les valeurs valides pour l'attribut msDS-Behavior-Version sont indiquées dans le tableau suivant.

Valeur | Niveau fonctionnel de la forêt
0 | Windows® 2000 Server mixte
1 | Windows Server™ 2003 intermédiaire
2 | Windows Server 2003 natif

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut revision du conteneur Windows2003Update. La valeur de cet attribut indique si l'outil de préparation d'Active Directory (ADPrep.exe) a été exécuté.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de la clé OSProductSuite indique la version de Windows utilisée sur l'ordinateur.

Si Exchange Server Analyzer détecte que les critères suivants sont vrais, un avertissement s'affiche :

  • La valeur de l'attribut purportedSearch de la stratégie de destinataire contient (homeMdb=).

  • Le niveau fonctionnel de la forêt Active Directory est Windows 2000 Server mixte.

  • La forêt Active Directory a été préparée pour les contrôleurs de domaine Windows Server 2003.

  • L'ordinateur Exchange Server n'utilise pas Microsoft Windows Small Business Server 2003.

Cet avertissement indique que la forêt Active Directory a été préparée pour Windows Server 2003. Pour éviter des problèmes de tampon d'adresse de courrier électronique lors de la mise à niveau de la forêt Active Directory vers le niveau complet de fonctionnalité Windows Server 2003, il est nécessaire de modifier les stratégies de destinataire. La stratégie de destinataire concernée est spécifiée dans les résultats d'Exchange Server Analyzer.

Si Windows Server 2003 est utilisé comme contrôleur de domaine et si la stratégie de destinataire n'est pas mise à jour, la réplication de la valeur y afférente dans Windows Server 2003 entraîne une écriture incorrecte des adresses de courrier électronique des nouveaux utilisateurs par le service de mise à jour de destinataire.

Étant donné la réplication de la valeur y afférente, le service de mise à jour de destinataire peut détecter un nouvel utilisateur pour la première fois entre le moment de la réplication du surnom de courrier et celui de la réplication de homeMdb. Par conséquent, l'utilisateur sera dans la stratégie par défaut à ce moment, au lieu de la stratégie basée sur homeMdb. Quelques minutes plus tard, lorsque homeMdb réplique, l'utilisateur sera sous leur stratégie homeMdb. Toutefois, l'utilisateur aura déjà des adresses qui correspondent à la stratégie par défaut.

Pour supprimer cet avertissement

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataires, sélectionnez Stratégies de destinataire, cliquez avec le bouton droit sur Nom_stratégie_destinataire, puis cliquez sur Propriétés.

  3. Sur la page Propriétés de Nom_stratégie_destinataire, sous l'onglet Général, sous Règles de filtrage, cliquez sur Modifier.

  4. Dans le menu Find Exchange Recipients, sélectionnez Recherche personnalisée. Si la stratégie de destinataire a été créée par une recherche personnalisée, la page Find Custom Search s'affiche lorsque vous cliquez sur Modifier à l'étape 3.

  5. Modifiez la requête LDAP (Lightweight Directory Access Protocol) pour que l'attribut homeMdb ne soit pas utilisé comme une partie de condition de filtre. Des attributs tels que extensionAttribute, msExchHomeServerName ou UPN sont des arguments valides qui peuvent aider à atteindre le même résultat de recherche.

  6. Cliquez deux fois sur OK pour enregistrer la modification, puis quittez le Gestionnaire système Exchange.


L'ID de l'expéditeur n'est pas configuré
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-05-10

L'outil Microsoft Exchange Best Practices Analyzer Tool utilise la cmdlet Exchange Management Shell suivante pour rechercher les valeurs des propriétés Enabled et ExternalMailEnabled de l'objet SenderIdConfig pour les rôles de serveurs cibles transport Edge ou Hub ExchangeServer 2007.

Copier le code
- get-SenderIdConfig

La valeur de la propriété Enabled spécifie si l'ID de l'expéditeur est activé. Une entrée valide pour le paramètre Enabled est $true ou $false. Le réglage par défaut est $true. Lorsque le paramètre Enabled est défini sur $true, l'agent d'ID de l'expéditeur est activé.

La valeur de la propriété ExternalMailEnabled spécifie si tous les messages provenant de connexions non authentifiées sont transmis via l'agent d'ID expéditeur pour traitement. Une entrée valide pour le paramètre ExternalMailEnabled est $true ou $false. Le réglage par défaut est $true. Lorsque le paramètre ExternalMailEnabled a la valeur $true, tous les messages provenant de connexions non authentifiées sont transmis via l'agent d'ID expéditeur pour traitement.

Si Exchange Best Practices Analyzer détermine que les valeurs des propriétés Enabled ou ExternalMailEnabled de l'objet SenderIdConfig ne sont pas définies sur $true, il affiche un message de recommandation.

Ce message indique que l'ID de l'expéditeur n'est pas activé sur les rôles de serveurs cibles transport Edge ou Hub Exchange 2007.

L'ID de l'expéditeur essaie de vérifier que chaque message électronique provient du domaine Internet à partir duquel il prétend avoir été envoyé.

Lorsque l'ID de l'expéditeur est activé sur un ordinateur, il filtre tous les messages transmis via tous les connecteurs de réception présents sur cet ordinateur. Seuls les messages provenant de sources externes sont filtrés. Les sources externes sont définies comme sources non authentifiées. Celles-ci sont considérées comme des sources Internet anonymes.

Pour résoudre ce problème, activez l'ID de l'expéditeur sur les rôles de serveurs cibles transport Edge ou Hub Exchange 2007.

Utilisation de la cmdlet Exchange Management Shell pour activer la fonctionnalité de l'ID de l'expéditeur

  • Pour activer le filtrage des expéditeurs, exécutez la commande suivante :

    Copier le code
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

Pour plus d'informations sur l'ID de l'expéditeur, voir les rubriques suivantes :

  • Page d'accueil de l'ID de l'expéditeur (http://go.microsoft.com/fwlink/?linkid=50977)

  • ID de l'expéditeur d'Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=89719)

  • Configuration de l'ID de l'expéditeur (http://go.microsoft.com/fwlink/?LinkId=89720)


Incohérence de casse du nom de serveur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur stockée dans Active Directory pour le nom du serveur Exchange (CN=<ExchangeServerName>). Après avoir récupéré ce nom, Exchange Server Analyzer en compte le nombre de caractères.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer la valeur stockée dans le Registre de l'ordinateur Exchange Server pour le nom d'hôte du serveur Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour ClusSvc, le service de cluster Windows®.

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • La valeur de CN=<ExchangeServerName> ne correspond pas à la casse de la valeur de Hostname. Par exemple, CN=Nom_ordinateur et Nom_hôte est défini sur NOM_ORDINATEUR.

    Remarque :
    Il n'est pas recommandé de modifier la casse du nom de serveur dans le Registre même si cette fonctionnalité est prise en charge.
  • Le nom du serveur Exchange comprend au plus 15 caractères.

  • Le serveur Exchange n'est pas utilisé dans un cluster Windows.

La cause la plus courante de cette erreur est la modification manuelle du nom du serveur Exchange dans le Registre.


Incohérence de nom de serveur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur This Server :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut name pour chaque objet Exchange Server.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster (Clussvc). Une valeur TRUE indique que le service de cluster est démarré et une valeur FALSE qu'il n'est pas en cours d'exécution.

Si Exchange Server Analyzer détecte que la valeur de la clé This Server ne correspond pas à celle de l'attribut name de l'objet serveur dans Active Directory pour tout ordinateur Exchange Server qui n'est pas exécuté dans un cluster de serveurs, une erreur s'affiche.

Pour corriger cette erreur, vous devez modifier la clé de Registre This Server pour qu'elle corresponde à la valeur de l'attribut name dans Active Directory.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. Dans le volet droit, double-cliquez sur This Server, entrez le nom correct pour cet ordinateur, puis cliquez sur OK.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Nom de serveur trop long
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-22

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nom (cn) de chaque objet d'annuaire avec une classe d'objet de msExchExchangeServer. La valeur cn est une chaîne qui contient le nom court de l'ordinateur Exchange Server. Exchange Server Analyzer extrait le cn, puis détermine la longueur de la chaîne. Celle-ci correspond au nombre de caractères du nom du serveur Exchange. Si Exchange Server Analyzer détermine que le nom du serveur Exchange dépasse 15 caractères, une erreur s'affiche.

Exchange Server 2007, Exchange Server 2003 et Exchange 2000 Server possèdent plusieurs dépendances NetBIOS pour lesquelles il peut être nécessaire d'utiliser une résolution de nom NetBIOS sur les différents sous-réseaux pour le bon fonctionnement de tous les composants Exchange, suivant la topologie réseau. La convention d'appellation NetBIOS autorise 16 caractères dans un nom NetBIOS. Microsoft limite toutefois les noms NetBIOS à 15 caractères et utilise le 16e comme suffixe NetBIOS.

En raison des dépendances NetBIOS d'Exchange Server et de la limitation des noms NetBIOS à 15 caractères, les noms de serveur dépassant 15 caractères ne sont pas pris en charge dans une organisation Exchange. En outre, étant donné les effets importants que peut avoir le changement de nom d'un ordinateur Exchange Server dans Active Directory et l'organisation Exchange, le changement de nom d'un ordinateur Exchange Server n'est pas pris en charge.

Pour corriger cette erreur

  1. Supprimez l'ordinateur Exchange Server incorrectement nommé à l'aide de l'option Supprimer.

  2. Attribuez à l'ordinateur un nom de maximum 15 caractères.

  3. Réinstallez Exchange Server sur l'ordinateur.

Pour plus d'informations sur la suppression d'Exchange Server 2007, consultez la page « Procédure de suppression totale d'Exchange 2007 d'un serveur » (http://go.microsoft.com/fwlink/?LinkId=79246) dans la documentation sur le déploiement de Microsoft Exchange Server 2007.

Pour plus d'informations sur la suppression d'Exchange Server 2003, voir la section relative à la désinstallation d'Exchange Server 2003 du Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations, consultez les articles suivants de la Base de connaissances Microsoft :

  • 833396 sur la procédure de suppression manuelle d'Exchange 2003 de votre ordinateur (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396)

  • 260378 sur la procédure de suppression manuelle d'une installation Exchange 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260378)

  • 328810 sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)

  • 821829 sur le déplacement de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).


L'adresse réseau du serveur RPC ne correspond pas au nom du serveur Exchange
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut networkAddress pour chaque objet Exchange Server de l'annuaire. Plusieurs entrées sont généralement répertoriées pour cet attribut de chaîne multiple, comme illustré dans les exemples suivants :

ncacn_ip_tcp :<nom de domaine complet d'Exchange Server>

ncacn_np :<nom d'hôte d'Exchange Server>

ncacn_spx :<nom d'hôte d'Exchange Server>

ncacn_vns_spp :<nom d'hôte d'Exchange Server>

ncalrpc :<nom d'hôte d'Exchange Server>

netbios :<nom d'hôte d'Exchange Server>

Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur de l'attribut name pour chaque objet Exchange Server.

Si Exchange Server Analyzer détecte que la valeur de l'attribut name ne correspond pas à la partie de nom des chaînes trouvées dans l'attribut networkAddress, une erreur s'affiche.

Cette erreur peut survenir si un administrateur a modifié manuellement la valeur cn de l'objet serveur. L'attribut networkAddress est créé et géré par Exchange Server. Il contient des valeurs de chaîne multiple pour la prise en charge des différents protocoles de communication réseau d'Exchange Server. Chaque valeur associe un protocole au formulaire approprié du nom de serveur comme requis par le protocole particulier.

Pour corriger cette erreur, vérifiez si le nom de serveur a été modifié ou si la valeur n'est pas valide, puis effectuez l'opération appropriée :

  • Si le nom de serveur a été modifié, utilisez la procédure figurant dans la suite de cet article pour corriger les valeurs de manière appropriée.

  • Si les valeurs ne sont pas valides pour une autre raison, réexécutez le programme d'installation d'Exchange sur le serveur.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Si vous utilisez ADSI Edit ou un outil similaire, recherchez l'objet de groupe d'administration dans Active Directory.

    L'attribut networkAddress peut se trouver dans :

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Nom_organisation, CN=Groupes_administration, CN=Nom_groupe_administration, CN=Serveurs, CN=Nom_serveur

  2. Notez le format de chaque valeur de la liste. Au besoin, mettez à jour les valeurs en ne modifiant que la partie du nom de serveur de chaque valeur.

    Remarque :
    Vérifiez que, pour la valeur ncacn_ip_tcp, le nom du serveur a la forme d'un nom de domaine complet et pas d'un nom NetBIOS ou d'une adresse IP.

  3. Fermez l'éditeur Active Directory, puis redémarrez le service de moteur de routage d'Exchange.

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur les problèmes de routage d'Exchange, voir la section sur la résolution des problèmes de routage du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Nom du service principal manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-08-14

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour trouver les valeurs renvoyées pour l'attribut servicePrincipalName des comptes d'ordinateur du serveur Exchange pour les ressources Exchange figurant dans le tableau ci-dessous.

Valeur servicePrincipalName de ressource Exchange | Valeur attendue renvoyée
exchangeMDB | Nom de domaine complet (FQDN)
exchangeMDB | Nom NetBIOS
exchangeRFR | Nom de domaine complet (FQDN)
exchangeRFR | Nom NetBIOS
SMTP | Nom de domaine complet (FQDN)
SMTP | nom NetBIOS
SMTPSVC | Nom de domaine complet (FQDN)
SMTPSVC | Nom NetBIOS
HOST | Nom de domaine complet (FQDN)
HOST | Nom NetBIOS

Si Exchange Server Analyzer trouve que l'attribut servicePrincipalName pour le compte d'ordinateur d'une ressource Exchange ne dispose pas d'une des valeurs attendues indiquées dans ce tableau, il affiche un message d'erreur.

Le nom du service principal (SPN) est un nom unique qui identifie une instance d'un service et est associé au compte de connexion sous lequel l'instance du service est exécutée. L'authentification Kerberos n'est pas possible pour les services Exchange dont le SPN n'est pas correctement défini.

  • L'existence de problèmes d'authentification entre des clients qui exécutent Microsoft Office Outlook® 2003 ou une version ultérieure et la banque d'informations Exchange (données de boîte aux lettres) peut attester de l'absence de SPN valide pour la ressource exchangeMDB.

  • Si des clients Outlook 2003 ou version ultérieure rencontrent des problèmes d'authentification Active Directory, il se peut que la ressource exchangeRFR ne possède pas de SPN valide.

  • Des échecs d'authentification entre des serveurs virtuels SMTP (Simple Mail Transport Protocol) peuvent indiquer l'absence de SPN valide pour la ressource SMTPSVC ou HOST.

Pour corriger ce problème, procédez comme suit afin d'ajouter les valeurs manquantes aux attributs concernés.

Utilisez l'outil SETSPN.exe pour ajouter un SPN avec les valeurs manquantes.

  1. Installez l'outil Setspn.exe. Pour savoir comment obtenir l'outil Setspn.exe, consultez la rubrique "Windows 2000 Resource Kit Tool : Setspn.exe" (http://go.microsoft.com/fwlink/?LinkId=28103).

    La version pour Windows Server 2003 de l'outil de ligne de commande Setspn.exe se trouve parmi les outils de support de Windows Server 2003 disponibles sur le CD de Windows Server 2003. Pour installer les outils de support de Server 2003, double-cliquez sur le fichier Suptools.msi dans le dossier Support/Tools.

  2. Suivez les instructions figurant dans le fichier Setspn_d.txt de SETSPN.EXE pour ajouter la valeur manquante à l'objet Active Directory pour votre serveur Exchange. L'exemple suivant illustre l'ajout de la valeur FQDN au SPN d'un serveur SMTP virtuel :

    • Ouvrez une invite de commande puis accédez au répertoire où vous avez installé Setspn.exe.

    • À l'invite de commande, entrez la commande suivante :

      setspn.exe -a SMTPSVC/ mail.votredomaine.com NOMDEVOTRESERVEUR

      Remarque :
      Remplacez mail.votredomaine.com par le FQDN de votre serveur SMTP virtuel et NOMDEVOTRESERVEUR par le nom du serveur Exchange.
      Appuyez ensuite sur la touche Entrée.


Interruption inattendue d'un service au cours des dernières 24 heures
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-14

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si un avertissement Événement 7031 a été enregistré pour la source Gestionnaire de contrôle des services au cours des dernières 24 heures.

Un avertissement Événement 7031 indique que le service spécifié n'a pas pu continuer. Le service est configuré pour comptabiliser le nombre d'échecs ; une fois qu'un nombre spécifique d'échecs a été comptabilisé, le Gestionnaire de contrôle des services effectue l'action de récupération configurée pour le service spécifié.

Si Exchange Analyzer détecte qu'un ou plusieurs de ces événements ont été enregistrés au cours des dernières 24 heures, il affiche un message d'information.

Plusieurs causes peuvent être à l'origine de ce problème. Parmi celles-ci, les plus courantes sont les suivantes :

  • message endommagé en cours de traitement ;

  • problèmes de configurations de l'application antivirus.

Pour résoudre ce problème :

  • Suivez les instructions de l'article 286350 de la Base de connaissances Microsoft, « Comment utiliser ADPlus pour dépanner "blocages" et "incidents" » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350) pour identifier la cause de l'absence de réponse (blocage) ou de l'arrêt inattendu (incident) d'un processus.

  • Procurez-vous le dernier Service Pack pour Microsoft Windows 2000.

  • Procurez-vous le dernier Service Pack pour Microsoft Exchange Server.

  • Contactez le fournisseur de l'application antivirus pour obtenir les dernières mises à jour et informations de configuration.

Pour plus d'informations

Pour plus d'informations sur l'avertissement Événement 7031, consultez la page du centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=83114).

Pour plus d'informations sur l'obtention du dernier Service Pack pour Windows 2000 Server, consultez l'article 260910 de la Base de connaissances Microsoft, « Comment faire pour obtenir le dernier Service Pack Windows 2000 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910).

Pour plus d'informations sur l'obtention du dernier Service Pack pour Exchange 2000 Server, consultez l'article 301378 de la Base de connaissances Microsoft, « Comment obtenir le dernier Service Pack d'Exchange 2000 Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378).

Pour plus d'informations sur l'obtention du dernier Service Pack pour Exchange Server 2003, consultez la page sur les avantages du Service Pack 2 pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073)

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, consultez le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Services Value is Missing or Inaccessible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-07-24

L'outil Microsoft Exchange Analyzer Tool lit l'entrée de Registre suivante pour vérifier l'existence de la valeur de type de chaîne Services :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

Si Exchange Analyzer détecte que la valeur de type de chaîne Services est manquante ou inaccessible, il affiche une erreur.

Cette erreur indique que la valeur de type de chaîne Services, qui permet de bloquer le chemin d'accès à la racine d'installation d'Exchange, est manquante ou inaccessible. L'absence de chemin d'accès à la racine d'installation d'Exchange risque de provoquer un échec d'initialisation des protocoles et pilotes critiques qui entraîneront à leur tour l'échec au démarrage de la banque d'informations Exchange et des services dépendants.

Pour résoudre cette erreur, voir les instructions de l'article 285116 de la Base de connaissances Microsoft sur l'impossibilité de démarrer la banque Exchange : erreurs 7024, 1026, 9542 et 5000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116).


Un seul réplica de disponibilité trouvé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_PublicFolder sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer le nombre de réplicas de disponibilité présents dans chaque groupe d'administration.

Si Exchange Server Analyzer ne détecte qu'un seul réplica de disponibilité dans un groupe d'administration, il affiche un message de recommandation.

Il est généralement recommandé qu'il existe plusieurs réplicas du dossier disponible/occupé dans chaque groupe d'administration. Parfois, plusieurs réplicas disponible/occupé peuvent accroître les performances et la résilience. Dans les grandes organisations Exchange, un seul réplica des données de disponibilité peut être surchargé. Dans toutes les organisations Exchange, un seul réplica des données de disponibilité est un point de défaillance unique.

Il est recommandé d'utiliser plusieurs réplicas malgré les considérations suivantes :

  • Plusieurs réplicas provoquent un trafic de réplication supplémentaire sur le réseau.

  • Le risque de conflits de planification augmente en cas de réplicas multiples.

Il doit exister au moins un réplica pour 10 000 boîtes aux lettres.

Pour plus d'informations sur les dossiers disponible/occupé et la publication d'informations de disponibilité, voir le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Un seul réplica de disponibilité détecté pour un grand nombre de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_PublicFolder dans l'espace de noms root\MicrosoftExchangeV2 pour déterminer le nombre d'entrées dans la clé ReplicaList. Le nombre d'entrées représente le nombre de réplicas de disponibilité présents dans chaque groupe d'administration.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer ne détecte qu'un seul réplica de disponibilité dans un groupe d'administration qui contient plus de 10 000 boîtes aux lettres, il affiche une erreur.

Il est généralement recommandé qu'il existe plusieurs réplicas du dossier disponible/occupé dans chaque groupe d'administration. Parfois, plusieurs réplicas disponible/occupé peuvent accroître les performances et la résilience. Dans les grandes organisations Exchange, un seul réplica des données de disponibilité peut être surchargé. Dans toutes les organisations Exchange, un seul réplica des données de disponibilité est un point de défaillance unique.

Il est recommandé d'utiliser plusieurs réplicas malgré les considérations suivantes :

  • Plusieurs réplicas provoquent un trafic de réplication supplémentaire sur le réseau.

  • Le risque de conflits de planification augmente en cas de réplicas multiples.

Il doit exister au moins un réplica pour 10 000 boîtes aux lettres.

Pour plus d'informations sur les dossiers disponible/occupé et la publication d'informations de disponibilité, voir le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Un seul catalogue global est présent dans la topologie
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_DSAccess dans l'espace de noms root\MicrosoftExchangeV2 pour déterminer le nombre de serveurs de catalogue global présents dans la topologie. Pour déterminer le nombre de serveurs de catalogue global, il suffit de compter le nombre d'entrées de la clé WMI DSAccessNameGC. Si Exchange Server Analyzer détecte un seul serveur de catalogue global dans la topologie, il affiche un message de recommandation.

Pour permettre une tolérance de pannes, il est recommandé de mettre au moins deux serveurs de catalogue global à la disposition des serveurs Exchange et des utilisateurs. Un seul serveur de catalogue global constitue un point de défaillance unique. Toute une série de fonctions d'Exchange 2000 Server, d'Exchange Server 2003 et d'Exchange Server 2007 dépendent des serveurs de catalogue global. Si aucun serveur de catalogue global n'est disponible, la remise des messages peut être ralentie ou totalement interrompue. De plus, si aucun serveur de catalogue global n'est disponible, les services Exchange Server peuvent ne pas démarrer. Dans ce cas, les utilisateurs ne peuvent pas accéder à leur boîte aux lettres.

Pour permettre une évolutivité et une tolérance de pannes, il est recommandé de configurer au moins deux serveurs de catalogue global dans chaque site du service d'annuaire Active Directory®. Si un site s'étend sur plusieurs domaines, il est recommandé de configurer un catalogue global pour chaque domaine sur lequel des clients et des ordinateurs Exchange 2000 Server, Exchange Server 2003 ou Exchange Server 2007 résident. Il est également recommandé de déployer un serveur de catalogue global pour quatre processeurs d'ordinateur Exchange Server.

Pour obtenir des détails sur la création de serveurs de catalogue global supplémentaires, consultez l'article 313994 de la Base de connaissances Microsoft sur la procédure de création ou de déplacement d'un catalogue global dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994).

Pour plus d'informations sur l'emplacement et la disponibilité du serveur de catalogue global liés à Exchange Server, consultez les articles suivants de la Base de connaissances :

  • 875427 sur l'emplacement et les ratios du serveur de catalogue global dans une organisation Exchange 2000 Server ou Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427)

  • 322801 sur le non-démarrage du service Surveillance du système Exchange et le message d'erreur « Les serveurs de catalogue global ne répondent pas » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801)

  • 829361 sur la lenteur de l'ordinateur Exchange Server 2003 à s'éteindre (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361)

  • 304403 sur les considérations d'Exchange pour la promotion d'un contrôleur de domaine en serveur de catalogue global (http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403)

  • 305065 sur les considérations relatives au serveur Exchange pour rétrograder un serveur de catalogue global au rang de contrôleur de domaine (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065)


Serveur de dossiers du site supprimé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-01

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut siteFolderServer pour chaque objet de groupe d'administration. Si Exchange Server Analyzer détermine que la valeur de l'attribut siteFolderServer contient la chaîne DEL:, une erreur s'affiche.

L'attribut siteFolderServer représente le nom unique (DN) de la banque de dossiers publics responsable de l'hébergement des dossiers de site (normalement, le premier serveur du site ou le groupe d'administration).

Par défaut, le serveur de dossiers du site est le premier serveur qui est installé dans le groupe d'administration. La banque de dossiers publics sur ce serveur est l'emplacement par défaut des dossiers de disponibilité et des dossiers du carnet d'adresses en mode hors connexion pour le groupe d'administration. Si vous supprimez ou désactivez ce serveur sans répliquer ces dossiers vers un autre serveur et sans désigner ce serveur en tant que serveur de carnet d'adresses en mode hors connexion, les utilisateurs de Microsoft Office Outlook® 2003 verront des problèmes avec le carnet d'adresses en mode hors connexion et les données de disponibilité.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Recherchez la banque d'informations de dossiers publics que vous voulez désigner comme serveur de dossiers du site en développant les nœuds suivants dans le conteneur de configuration :

    CN=Configuration, DC=<Nom_domaine>, DC=com, CN=Services, CN=Microsoft Exchange, CN=<Nom_organisation>, CN=Groupes_administration, CN=<Nom_groupe_administration>, CN=Serveurs, CN=<Nom_serveur>, CN=Banque_informations, CN=<Nom_groupe_stockage>

  3. Dans le volet droit, cliquez avec le bouton droit sur CN=<Nom_banque_dossiers_publics>,, puis cliquez sur Propriétés.

  4. Dans le champ Attributs, faites défiler et sélectionnez l'attribut distinguishedName.

  5. Cliquez sur Modifier, puis copiez l'attribut entier dans le Presse-papiers.

  6. Développez le conteneur Configuration, puis développez CN=Configuration, CN=<Nom_domaine>, CN=com, CN=Services, CN=Microsoft_Exchange, CN=<Nom_organisation>, CN=Groupes_administration

  7. Cliquez avec le bouton droit sur le groupe d'administration que vous souhaitez modifier, puis cliquez sur Propriétés.

  8. Dans le champ Attributs, faites défiler et sélectionnez l'attribut siteFolderServer.

  9. Cliquez sur Modifier, puis collez la valeur de l'attribut distinguishedName dans le champ Valeur.

  10. Vérifiez le contenu du champ Valeur pour vous assurer que l'opération Coller a été correctement effectuée, puis cliquez sur OK pour enregistrer la modification.

  11. Cliquez sur OK pour fermer les propriétés du groupe d'administration.

  12. Quittez l'éditeur Active Directory et redémarrez le service de banque d'informations de Microsoft Exchange Server sur tous les ordinateurs Exchange Server du site pour que la modification soit prise en compte.

Pour plus d'informations sur la nouvelle création des dossiers système et sur la réinitialisation du serveur de dossiers du site, voir les articles suivants de la Base de connaissances Microsoft :

  • 822444 sur la procédure de réinitialisation d'un dossier site dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822444)

  • 275171 sur la procédure de réinitialisation des dossiers système dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171)

  • 284200 sur l'absence du dossier système Schedule+ disponible/occupé (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200)

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server.


Appels lents au service d'annuaire Active Directory
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-14

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements de composant du service d'annuaire Active Directory® dont le temps de réponse dépasse 2,5 secondes.

Les événements de composant FCL Active Directory représentent des appels de fonction du service de banque d'informations de Microsoft Exchange (Store.exe) adressés au composant Active Directory.

Active Directory fournit toutes les informations de boîtes aux lettres, les services de listes d'adresses et d'autres informations liées aux destinataires. La plupart des informations de configuration d'Exchange Server 2003 sont également stockées dans Active Directory.

Les services d'Exchange Server accèdent aux informations contenues dans Active Directory et y écrivent des informations.

Si Exchange Server Analyzer trouve, dans le fichier Store.fcl, des événements dont le temps de réponse dépasse 2,5 secondes pour les appels de fonction à Active Directory provenant du service de banque d'informations de Microsoft Exchange (Store.exe), il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels de plus de 2,5 secondes à Active Directory depuis le service de banque d'informations de Microsoft Exchange peuvent être dus aux conditions suivantes :

  • Latence du réseau entre le serveur Exchange et le contrôleur de domaine.

  • Configuration statique ou généralement incorrecte de DSAccess.

  • Surcharge du contrôleur de domaine et du catalogue global.

  • Conception incorrecte de la topologie Active Directory.

Pour résoudre cette erreur, procédez comme suit :

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Vérifiez les performances des serveurs contrôleurs de domaine Active Directory.

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les performances d'Exchange et sur DSAccess, voir l'article 250570 de la Base de connaissances Microsoft sur la détection de serveur de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).

Pour plus d'informations sur les performances des contrôleurs de domaine, voir les ressources Windows Server suivantes :

  • document sur la planification de la capacité des contrôleurs de domaine (http://go.microsoft.com/fwlink/?LinkId=70191).

  • rubrique sur la surveillance des contrôleurs de domaine dans Active Directory, dans les Guides de planification et de déploiement d'Active Directory dans Windows 2000 Server (http://go.microsoft.com/fwlink/?LinkId=70193).


Lenteur des appels ESE
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements de composant ESE (Extensible Storage Engine ) Exchange dont le temps de réponse dépasse 2,5 secondes.

Les événements de composant Exchange FCL ESE sont des représentations des appels de fonction du service de banque d'informations Microsoft Exchange (Store.exe) adressés au composant ESE.

Le service de banque d'informations Exchange opère par-dessus une base de données ESE. ESE est un moteur de base de données sophistiqué à base de transactions. Une transaction est une série d'opérations traitées comme une unité atomique (indivisible). Soit toutes les opérations d'une transaction sont achevées et enregistrées de manière permanente, soit aucune opération n'est effectuée.

Exchange Server utilise ESE comme un moteur de base de données incorporé qui détermine la structure des bases de données et gère la mémoire. Ce moteur de base de données met en cache les bases de données en transférant des blocs de données (pages) de quatre kilo-octets (Ko) vers et depuis la mémoire. Il met à jour les pages en mémoire et écrit sur le disque les pages nouvelles ou mises à jour. Lorsque des demandes parviennent au système, le moteur de base de données peut fournir les données se trouvant en mémoire. Il ne doit donc pas constamment accéder au disque.

Bien que la mise en cache mémoire de données soit le mode de traitement des données le plus rapide et le plus efficace, elle signifie aussi, lorsqu'Exchange tourne, que les informations sur le disque ne sont jamais entièrement à jour, même si le disque contenant le journal des transactions est toujours mis à jour avec les informations relatives à chaque transaction. Cependant, puisque de nombreuses modifications effectuées en mémoire ne sont pas encore transcrites sur le disque, la base de données et la mémoire ne sont pas synchronisées.

Si Exchange Server Analyzer trouve, dans le fichier Store.fcl, des événements dont le temps de réponse dépasse 2,5 secondes pour les appels de fonction au composant ESE provenant du service de banque d'informations de Microsoft Exchange (Store.exe), il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des appels permanents depuis l'ESE peuvent être dus aux conditions suivantes :

  • Défragmentation en ligne d'Exchange.

  • Sauvegardes de données.

    Remarque :
    Si une sauvegarde de données ou une défragmentation en ligne était intentionnellement en cours pendant la collecte des données de journal Exchange Call Trace, vous pouvez ignorer sans crainte ce message indiquant un problème de performances d'Exchange Server
  • Goulets d'étranglement sur un lecteur de base de données.

Pour résoudre cette erreur, procédez comme suit :

  • Nous recommandons de ne pas faire chevaucher les fenêtres de sauvegarde ou la maintenance en ligne et des moments d'intenses demandes des utilisateurs.

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire du serveur. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur la procédure de configuration des fenêtres de défragmentation en ligne, voir l'article 244524 de la Base de connaissances Microsoft sur la procédure de configuration de la fenêtre de défragmentation en ligne d'Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524).

Pour plus d'informations sur les problèmes de goulet d'étranglement de disque d'Echange Server, voir la rubrique sur le Goulot d'étranglement de disque détecté.

Pour plus d'informations sur la procédure de dimensionnement et d'optimisation de disques pour Exchange Server, voir les sections sur la procédure de calcul des besoins d'E/S de disque et sur les pratiques recommandées communes à diverses architectures dans la rubrique sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Pour plus d'informations sur ESE, voir la rubrique sur l'architecture Extensible Storage Engine (http://go.microsoft.com/fwlink/?linkid=67009).


Appels lents à IMAIL
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-12

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements dont le temps de réponse dépasse 2,5 secondes pour le composant IMAIL du client MAPI.

Les événements de composant IMAIL MAPI dans le journal FCL d'Exchange représentent des appels de fonction du service de banque d'informations de Microsoft Exchange (Store.exe) pour convertir les messages au format Internet et du format Internet au format MAPI.

Le composant IMAIL d'Exchange Server est un service de conversion flexible utilisé par le service de banque d'informations de Microsoft Exchange entre Internet et les messages MAPI. Il assure ainsi l'interopérabilité entre les clients utilisant RFC-822 ou un format Internet et les clients qui utilisent le format de stockage interne d'Exchange Server, tels que les clients MAPI ou les tâches de stockage internes.

Exchange utilise le mécanisme IMAIL pour appliquer des formats de message au contenu, selon les paramètres définis pour les domaines Internet dans le Gestionnaire système Exchange ou selon les spécifications de l'utilisateur pour chaque destinataire dans Microsoft Office Outlook®. Si aucun paramètre de format n'est transmis à IMAIL, IMAIL formate les messages MAPI au format Summary TNEF (S/TNEF) pour les transferts entre serveurs.

Si Exchange Server Analyzer trouve, dans le fichier Store.fcl, des événements dont le temps de réponse dépasse 2,5 secondes pour les appels de fonction au composant client MAPI provenant du service Microsoft Exchange Information Store (Store.exe), il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des temps de réponse lents pour les appels de fonction externes adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au composant IMAIL peuvent être dus aux conditions suivantes :

  • IMAIL essaie de traiter des données volumineuses dans un message ou une pièce jointe.

  • De nombreux clients demandent une conversion de données.

  • Les demandes DSAccess obtiennent des réponses lentes.

  • Des goulets d'étranglement affectent les lecteurs TEMP et TMP.

  • Il existe des déplacements permanents de boîtes aux lettres.

  • Pour résoudre cette erreur, procédez comme suit :

  • Planifiez les déplacements de boîtes aux lettres à des moments de faible demande.

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur tels que les limites de taille des messages et des pièces jointes. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les problèmes de goulet d'étranglement de disque d'Echange Server, voir la rubrique sur le Goulot d'étranglement de disque détecté.

Pour plus d'informations sur la procédure de dimensionnement et d'optimisation de disques pour Exchange Server, voir les sections sur la procédure de calcul des besoins d'E/S de disque et sur les pratiques recommandées communes à diverses architectures dans la rubrique sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).

Pour plus d'informations sur les pratiques recommandées en termes de limite de taille des messages sur Exchange Server, voir la rubrique sur La taille maximale des messages sortants n'a pas été définie.


Appels lents à LSASS
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements de composant du processus Lsass.exe dont le temps de réponse dépasse 25 millisecondes.

Les événements de composant du processus LSASS dans FCL représentent des appels de fonction du service de banque d'informations de Microsoft Exchange (Store.exe) adressés au composant du processus Lsass.exe.

Le processus Lsass.exe est un sous-système de sécurité invoqué par d'autres processus pour vérifier les informations de compte et la validation de la connexion.

Toute connexion de client Exchange provoque l'envoi, par le serveur qui exécute Exchange Server, d'une demande visant à consulter l'identificateur de sécurité du compte (SID) du client et crée un appel à l'intérieur du processus Lsass.exe.

Si Exchange Server Analyzer trouve, dans le fichier Store.fcl, des événements dont le temps de réponse dépasse 25 millisecondes pour les appels de fonction au composant Lsass.exe provenant du service de banque d'informations de Microsoft Exchange (Store.exe), il affiche un message d'erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des temps de réponse lents pour les appels de fonction externes adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) à LSASS peuvent être dus aux conditions suivantes :

  • problèmes de ressources serveur liés au nombre d'utilisateurs qui s'authentifient en même temps ;

  • latence du réseau entre le serveur Exchange et le contrôleur de domaine ou le serveur de catalogue global ;

  • problèmes de goulet d'étranglement au niveau des ressources du serveur.

Pour résoudre cette erreur, procédez comme suit :

  • Envisagez d'implémenter le paramètre NeverPing de la manière décrite dans le document Paramètre « NeverPing » recommandé.

  • Exécutez Exchange Server Analyzer pour procéder à une analyse supplémentaire des problèmes de serveur tels que les limites de taille des messages et des pièces jointes. Vous pouvez télécharger Exchange Server Analyzer sur le site sur l'outil Microsoft Exchange Server Best Practices Analyzer Tool v2.7 (http://go.microsoft.com/fwlink/?LinkId=34705).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur le processus Lsass.exe et l'utilisation de la mémoire, voir l'article 308356 de la Base de connaissances Microsoft sur l'utilisation de la mémoire par le processus Lsass.exe sur les contrôleurs de domaine qui exécutent Windows Server 2003 ou Windows 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356)

Pour plus d'informations sur les connexions client Exchange et les problèmes de LSASS, voir l'article 161938 de la Base de connaissances Microsoft sur la lenteur des connexions client Exchange en raison d'un blocage des ressources (http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938).

Pour plus d'informations sur la latence du réseau entre le serveur Exchange et le contrôleur de domaine ou le serveur de catalogue global, consultez l'article du blog de l'équipe Microsoft Exchange relatif au fait qu'Exchange n'utilise pas toujours des serveurs de catalogue global locaux (http://go.microsoft.com/fwlink/?LinkId=69166).

Remarque :
Le contenu de chaque blog et leur URL sont susceptibles d'être modifiés sans préavis.

Pour plus d'informations sur les problèmes de goulet d'étranglement au niveau des ressources du serveur, voir la rubrique sur les Goulot d'étranglement de processeur.

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Lenteur des appels à l'analyseur antivirus
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-11

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements de composant Virus API (VAPI) de Virusscan dont le temps de réponse dépasse 2,5 secondes.

Les événements de composant VAPI de Virusscan représentent des appels de fonction du service de banque d'informations de Microsoft Exchange (Store.exe) adressés à un logiciel antivirus externe.

Pour améliorer la résolution de problèmes du composant VAPI, Exchange Server applique un enregistrement d'événements qui peut être utilisé pour suivre les performances de l'API d'analyse antivirus.

Les événements consignés comprennent :

  • le chargement et le déchargement de DLL fournisseur ;

  • l'analyse réussie d'éléments ;

  • les virus localisés dans la banque d'informations ;

  • le comportement inattendus dans VAPI.

Si Exchange Server Analyzer trouve, dans le fichier Store.fcl, des événements dont le temps de réponse dépasse 2,5 secondes pour les appels de fonction au logiciel d'analyse antivirus provenant du service de banque d'informations de Microsoft Exchange (Store.exe), il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Des temps de réponse lents pour les appels de fonction externes adressés par le service de banque d'informations de Microsoft Exchange (Store.exe) au logiciel d'analyse antivirus peuvent être dus aux conditions suivantes :

  • Mises à jour d'un analyseur antivirus générant une nouvelle analyse des éléments contenus dans la banque d'informations.

  • Mauvaise configuration de l'analyseur antivirus

  • Traitement d'un message ou d'une pièce jointe volumineuse par l'analyseur antivirus

Pour résoudre cette erreur, procédez comme suit :

  • Planifiez les mises à jour de votre moteur antivirus à des moments où la consommation de ressources est faible (heures creuses au niveau de la demande).

  • Envisagez de réinstaller l'analyseur antivirus, mais faites-le à des moments de faible demande.

  • Examinez la configuration de votre moteur d'analyse antivirus pour vérifiez que vous disposez d'une configuration correcte des threads, d'exclusions au niveau des fichiers, etc. Voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Lisez les articles de la section « Pour plus d'Informations » de ce document.

Pour plus d'informations

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

Pour plus d'informations sur la procédure de résolution des problèmes de performances des banques d'informations, voir l'article 257725 de la Base de connaissances Microsoft sur la procédure de collecte des données de diagnostic afin de résoudre les problèmes liés à la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725).


Appels lents à l'instantané du service Cliché instantané de volume
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-13

L'outil Microsoft® Exchange Server Analyzer Tool examine le journal de la fonction FCL (Function Call Logging) d'Exchange, le fichier Store.fcl, à la recherche d'événements de composant d'instantané du service Cliché instantané de volume dont le temps de réponse dépasse 20 secondes.

Les événements de composant du service Cliché instantané de volume dans le journal FCL d'Exchange représentent des appels de fonction du service de banque d'informations de Microsoft Exchange (Store.exe) adressés au composant d'instantané du service Cliché instantané de volume.

Le service Cliché instantané de volume est un ensemble d'API COM mettant en place un cadre permettant d'effectuer des sauvegardes de volumes alors que des applications du système continuent d'écrire sur ces volumes.

Microsoft Exchange Server 2003 utilise le service Cliché instantané de volume inclus dans le système d'exploitation Microsoft Windows Server™ 2003 pour effectuer des clichés instantanés de volumes des bases de données Exchange Server 2003 et des fichiers journaux de transactions.

Un instantané du service Cliché instantané de volume n'est pas entièrement indépendant des données d'origine. En général, des instantanés sont créés lorsque vous définissez un point dans le temps et veillez à ce qu'une annulation d'enregistrement des données puisse se faire jusqu'à ce point.

Si Exchange Server Analyzer trouve, dans le fichier Store.fcl, des événements dont le temps de réponse dépasse 20 secondes pour les appels de fonction au composant d'instantané du service Cliché instantané de volume provenant du service de banque d'informations de Microsoft Exchange (Store.exe), il affiche une erreur.

Lorsque des appels entre composants provenant du service de banque d'informations Microsoft Exchange (Store.exe) sont en attente d'une réponse, des threads d'appel de procédure distante (RPC) peuvent s'accumuler derrière ces demandes et entraîner des problèmes de performances d'Exchange Server tels que des retards dans les réponses du serveur aux clients.

Remarque :
Si un instantané du service Cliché instantané de volume a été lancé intentionnellement dans les 20 secondes qui suivent une collecte de données Exchange Call Trace, vous pouvez ignorer sans crainte ce message d'erreur censé indiquer un problème de performances d'Exchange Server.

Nous recommandons de ne pas faire chevaucher les fenêtres de sauvegarde avec la maintenance en ligne ou des moments d'intenses demandes des utilisateurs.

Pour plus d'informations

Pour plus d'informations sur les sauvegardes du service Cliché instantané de volume, voir les recommandations pour l'utilisation du du service Cliché instantané de volume avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=56571).


Un événement d'erreur SMTPSVC (ID : 429) a été enregistré au cours des dernières 24 heures
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-16

L'outil Microsoft Exchange Analyzer Tool interroge la métabase IIS pour déterminer la valeur de la propriété LM/SmtpSvc/%SMTPInstance%/ServerState pour chaque instance d'un serveur virtuel SMTP (Simple Mail Transfer Protocol).

La propriété ServerState présente l'état actuel de l'instance de serveur. Les états et codes correspondants sont les suivants : 1 (démarrage), 2 (démarré), 3 (arrêt), 4 (arrêté), 5 (suspension), 6 (suspendu) ou 7 (reprise).

Si Exchange Analyzer détermine que la valeur de la propriété ServerState pour une instance de serveur virtuel SMTP n'est pas égale à 2 (démarré), il interroge ensuite la classe WMI (Windows Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si une erreur Événement 429 a été enregistrée pour le service SMTP (SMTPSVC) au cours de ces dernières 24 heures.

Si Exchange Analyzer détecte que l'instance de serveur virtuel SMTP n'est pas démarrée et qu'il y a au moins une erreur Évenement 429 enregistrée pour le service SMTP ces dernières 24 heures, Exchange Analyzer affiche un avertissement.

Cet avertissement indique qu'il peut y avoir des problèmes avec les répertoires désignés pour l'instance de serveur virtuel SMTP.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Lorsque des messages arrivent sur l'ordinateur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange.

Ce problème peut avoir l'une des causes suivantes :

  • Le chemin du répertoire <lecteur>:\Program Files\Exchsrvr\Mailroot ou les dossiers contenus dans ce répertoire ont été déplacés, sont manquants ou endommagés

  • Les autorisations du répertoire <lecteur>:\Program Files\Exchsrvr\Mailroot ou des dossiers de ce répertoire ne sont pas définies correctement.

  • Analyse par l'application antivirus du chemin du répertoire <lecteur>:\Program Files\Exchsrvr\Mailroot ou des dossiers de ce répertoire.

Pour résoudre cet avertissement, effectuez une ou plusieurs des opérations suivantes :

  • Vérifiez l'emplacement et l'intégrité du chemin du répertoire <lecteur>:\Program Files\Exchsrvr\Mailroot et des dossiers de ce répertoire.

  • Vérifiez les autorisations du chemin du répertoire <lecteur>:\Program Files\Exchsrvr\Mailroot et des dossiers de ce répertoire.

  • Assurez-vous que les applications antivirus n'analysent pas les dossiers dans le chemin du répertoire <lecteur>:\Program Files\Exchsrvr\Mailroot.

Pour vérifier le chemin du répertoire Mailroot dans Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut), puis cliquez sur Arrêter.

  4. Cliquez de nouveau avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Cliquez sur l'onglet Messages.

  6. Dans le champ Répertoire de file d'attente, vérifiez le chemin d'accès complet du dossier Mailroot approprié. Vous pouvez cliquer sur Parcourir pour rechercher le chemin d'accès sur l'ordinateur local.

  7. Cliquez sur OK pour enregistrer les modifications.

  8. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer.
Pour vérifier le chemin du répertoire Mailroot dans Exchange 2000 Server

  1. Arrêtez tous les services Exchange Server et IIS sur l'ordinateur Exchange 2000 Server dont vous souhaitez vérifier le dossier Mailroot sur le serveur virtuel SMTP.

  2. Vérifiez que la valeur msExchSmtpQueueDirectory du serveur virtuel SMTP soit configurée pour le chemin d'accès approprié.

  3. Attendez qu'Active Directory réplique ce changement sur les serveurs de catalogue global utilisés par ce serveur Exchange.

  4. Démarrez le service Surveillance du système Microsoft Exchange.

  5. Sur l'ordinateur Exchange Server, vérifiez la présence de trois instances de l'ID d'événement 1005 dans le journal des événements Applications disposant d'une source d'événement MSExchangeMU et d'une catégorie Général.

  6. Redémarrez l'ordinateur Exchange Server pour que les modifications soient prises en compte.
Pour vérifier les autorisations par défaut du chemin du répertoire Mailroot sur Exchange 2000 Server et Exchange Server 2003

  1. Démarrez l'Explorateur Windows, puis naviguez jusqu'au dossier Exchsvr et développez-le.

  2. Cliquez avec le bouton droit sur le répertoire Mailroot, puis cliquez sur Propriétés

  3. Cliquez sur l'onglet Sécurité, et vérifiez les autorisations par défaut suivantes :

Compte | Autorisations
Administrateurs | Contrôle total
Utilisateurs authentifiés | Lecture et exécution, Affichage du contenu, Lecture
Créateur propriétaire | Aucune
Opérateurs de serveur | Modification, Lecture et exécution, Affichage du contenu, Lecture, Écriture
Système | Contrôle total
  1. Vérifiez que ces autorisations par défaut existent pour tous les dossiers de chaque instance de serveur virtuel.

Pour plus d'informations sur les procédures décrites, voir les articles suivants de la Base de connaissances Microsoft :

  • 822933 sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230 sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Pour plus d'informations sur la configuration des applications d'analyse antivirus pour une utilisation avec Exchange, voir la rubrique sur la Les exclusions du dossier Antivirus n'ont pas été configurées.

Pour des informations détaillées sur la procédure de configuration des exclusions sur l'analyse en temps réel dans Symantec AntiVirus Corporate Edition, voir le site Web de Symantec Antivirus (http://www.symantec.com).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur la protection renforcée d'un environnement Exchange Server contre des vers et des virus transmis par courrier électronique, voir l'article relatif au ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus et les anti-spam (http://go.microsoft.com/fwlink/?linkid=16226).


Le nom de domaine complet de l'instance SMTP ne correspond pas au nom du serveur
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de la chaînencacn_ip_tcp: de l'attribut networkAddress pour l'objet de serveur correspond au nom de domaine complet (FQDN) contenu dans l'attribut msExchSmtpFullyQualifiedDomainName de l'objet de serveur virtuel SMTP (Simple Mail Transfer Protocol).

Si Exchange Server Analyzer détermine que les attributs ont des valeurs différentes, il affiche un avertissement :

Cet avertissement indique que les valeurs de ces attributs peuvent avoir été modifiées manuellement et pourraient contribuer à des problèmes de flux de messages sur ce serveur.

L'attribut msExchSmtpFullyQualifiedDomainName spécifie le nom de domaine complet du serveur virtuel SMTP ; ce nom doit pouvoir être résolu par le protocole de réseau DNS (Domain Name System).

Un enregistrement DNS HOST (A) valide doit exister pour la valeur de cet attribut afin que les serveurs de messagerie qui tentent de résoudre le nom complet de domaine du serveur virtuel SMTP puissent récupérer l'adresse IP correcte et acheminer correctement les messages.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, voir la rubrique sur l'ajout d'un enregistrement de ressource à une zone DNS (http://go.microsoft.com/fwlink/?LinkId=63002).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Pour plus d'informations sur la conception du service SMTP, voir la rubrique correspondante dans le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876).


Longueur de la file d'attente locale SMTP au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Local Queue Length de l'objet de performance SMTP Server pour les analyser.

Si Exchange Server Analyzer détermine que le compteur Local Queue Length a dépassé la valeur maximale de 1000 pendant une période-exemple, il affiche une erreur.

Le compteur SMTP Server\Local Queue Length indique le nombre de messages de la file d'attente SMTP (Simple Mail Transfer Protocol) pour une remise locale au service de Banque d'informations Microsoft Exchange. Les données de la file d'attente locale SMTP (répertoire Mailroot) sont temporairement stockées dans le périphérique de stockage lors de leur traitement par Exchange Server. Ceci permet d'éviter la perte de données en cas d'échec du serveur. Par exemple, lorsqu'un serveur de destination est inaccessible, les messages qui devraient être routés vers ce serveur sont stockés dans le répertoire de la file d'attente du serveur local jusqu'à leur remise.

Cette erreur indique des problèmes de performances ou des pannes sur le serveur car celui-ci ne peut plus remettre le courrier entrant à temps. Ce retard peut être dû aux raisons suivantes :

  • Le service d'annuaire Active Directory® n'est pas consulté immédiatement.

  • Les messages ne sont pas envoyés assez vite pour une remise locale ou SMTP.

  • Les bases de données (banques de boîtes aux lettres et de dossiers publics) ont été démontées.

  • Pour résoudre ce problème, procédez comme suit :

  • Assurez-vous que toutes les bases de données (banques de boîtes aux lettres et de dossiers publics) sont montées.

  • Identifiez la source des goulots d'étranglement des performances. Un goulot d'étranglement de performances peut être lié au processeur, au disque, au réseau ou à la mémoire et dû à un accroissement de la charge sur le serveur ou à des ressources serveur insuffisantes. L'analyseur de performances (Perfmon.msc) permet de déterminer si le goulot d'étranglement est dû à une charge accrue sur le serveur ou si le serveur est sous-dimensionné. En cas d'augmentation de la charge du serveur, identifiez la source de la charge et réduisez-la. Si le serveur dispose de ressources suffisantes, augmentez les ressources nécessaires ou déplacez des utilisateurs du serveur.

  • Surveillez les dépendances externes, par exemple le service d'annuaire Active Directory, pour détecter les problèmes de performances et les résoudre si nécessaire.

Pour plus d'informations

  • Pour plus d'informations sur le réglage du transport SMTP, voir la rubrique sur le réglage du transport SMTP dans le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution de problèmes de flux de messages, voir l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489).

  • Pour plus d'informations sur la résolution des problèmes de transport, voir l'article 257265 de la Base de connaissances Microsoft sur le dépannage dans Transport Microsoft Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les goulots d'étranglement de disque, voir la rubrique Goulot d'étranglement de disque détecté.

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la procédure de déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


Objet d'analyseur de performances SMTP Server non disponible
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Local Queue Length de l'objet de performance SMTP Server pour les analyser. Si le compteur ne renvoie aucune donnée valide, Exchange Server Analyzer affiche un message de comparaison.

Si le moteur de collecte des données de performances ne renvoie aucune donnée valide, toute combinaison des conditions suivantes est vraie :

  • L'objet de performance SMTP Server est désactivé.

  • L'objet d'analyseur de performances SMTP Server est manquant ou endommagé.

  • Exchange Server Analyzer ne dispose pas des autorisations appropriées pour accéder aux objets de performance.

Les deux premières conditions peuvent être remplies si certains compteurs extensibles endommagent le Registre ou si des programmes WMI (Windows® Management Instrumentation) Microsoft modifient le Registre. La procédure suivante explique comment corriger les deux premières conditions. Avant de l'effectuer, vérifiez qu'Exchange Server Analyzer dispose des autorisations appropriées. Pour plus d'informations sur les autorisations requises pour l'exécution d'Exchange Server Analyzer, voir la documentation de l'Aide fournie avec Exchange Server Analyzer. Pour obtenir de l'aide, ouvrez Exchange Server Analyzer et appuyez sur la touche F1.

Pour corriger cette erreur

  1. Vérifiez que l'objet de performance SMTP Server est activé.

    1. Téléchargez et installez l'outil Extensible Performance Counter List (Exctrlst.exe). Vous pouvez télécharger le fichier Exctrlst.exe à partir du site Web de l'outil Exctrlst.exe (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?LinkId=34436).

    2. Ouvrez Exctrlst.exe, cliquez sur Sort Order (Ordre de tri), puis sur Service.

    3. Recherchez le service pour lequel l'objet de performance doit créer un rapport et vérifiez que la case à cocher Performance Counters Enabled (Compteurs de performance activés) est activée.

      Si elle ne l'est pas, activez-la, puis redémarrez le service associé aux compteurs de performance pour vérifier que ceux-ci sont opérationnels. S'ils ne le sont pas ou si la case à cocher Performance Counters Enabled (Compteurs de performance activés) était déjà activée, passez à l'étape 2.

  2. Recréez les compteurs de performance manquants ou endommagés comme décrit dans l'article 300956 de la Base de connaissances Microsoft sur la procédure de recréation manuelle des valeurs de la bibliothèque du compteur de performance (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956).

  3. Si la procédure de l'article de la Base de connaissances ne permet pas de résoudre le problème, vous devez réinstaller le système d'exploitation Windows en mode Réparer et appliquer ensuite les derniers Service Packs de Windows.


SQL Server exécute Virtual Server 2005 avec Exchange Server installé en tant qu'invité
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur Virtual Machine.

Exchange Server Analyzer recherche également la présence de la valeur de Registre suivante :

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

En outre, Exchange Server Analyzer interroge la classe WMI Win32_Services pour déterminer si le service Microsoft SQL Server™ (MSSQLSERVER) est en cours d'exécution sur l'ordinateur physique qui utilise Microsoft Virtual Server 2005.

Si Exchange Server Analyzer détecte que la clé Model contient la chaîne Virtual Machine, que la branche de Registre ci-dessus existe et que MSSQLSERVER est en cours d'exécution, une erreur s'affiche.

Une valeur Virtual Machine pour la clé Model indique que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée sur Virtual Server 2005 ou Microsoft Virtual PC 2004. La branche de Registre ci-dessus n'étant créée que par Virtual Server 2005, son existence signifie que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée dans Virtual Server 2005.

Microsoft ne prend pas en charge l'exécution des versions de Microsoft Exchange sur une machine virtuelle ou un émulateur. Cela s'applique à Exchange Server sur Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 ou tout programme tiers de machine virtuelle. Les plates-formes Microsoft Exchange Server sont conçues et testées pour n'être exécutées que sur un matériel physique, notamment les plates-formes matérielles répertoriées dans Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

En outre, il n'est pas conseillé d'exécuter Exchange en tant qu'invité du serveur virtuel sur un ordinateur utilisant SQL Server parce qu'il ne permet pas une redondance adéquate de service en service.

Pour corriger cette erreur

  1. Déplacez les boîtes aux lettres du serveur Exchange sous Virtual Server 2005 vers un ordinateur Exchange Server non virtuel.

  2. Associez tous les dossiers publics et transférez au besoin tous les rôles détenus par le serveur virtuel Exchange.

  3. Désinstallez Exchange de la machine virtuelle pour le désactiver et le supprimer de votre infrastructure Exchange et du service d'annuaire Active Directory®.

Pour plus d'informations sur le déplacement des boîtes aux lettres, voir les articles suivants de la Base de connaissances Microsoft :

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975 sur les différences entre les méthodes de transfert de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Pour plus d'informations sur la prise en charge des ordinateurs Exchange Server fonctionnant dans des environnements virtuels, voir l'article 320220 de la Base de connaissances sur les limites de prise en charge pour Exchange Server sur une machine virtuelle ou d'émulation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Pour plus d'informations sur Microsoft Virtual Server 2005, voir le site Web de Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?linkid=34938).

Pour plus d'informations sur Microsoft Virtual PC 2004, voir le site Web de Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


SRS port is below 5000
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre TCP/IP pour le service de réplication de sites Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Si Exchange Server Analyzer détecte que la valeur de TCP/IP est définie sur une valeur inférieure à 5 000 (décimal), un avertissement s'affiche.

Si vous devez définir TCP/IP sur une valeur statique, il est recommandé de le définir sur une valeur à peine supérieure à 5 000. L'affectation de numéros de port statiques inférieurs à 5 000 risque de provoquer un conflit de port avec un autre processus et un échec du processus du service de réplication de sites Microsoft Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour définir la clé de Registre TCP/IP

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Double-cliquez sur la clé TCP/IP et définissez le champ Données de la valeur sur un entier à peine supérieur à 5000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service de réplication de sites Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les limitations des ports, voir l'article 194952 de la Base de connaissances sur les limitations des ports mappés de manière statique pour Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952).


Le port SRS a été remplacé manuellement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur du port SRS Microsoft Exchange a été remplacée manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Si Exchange Server Analyzer détecte que TCP/IP est présent et configuré, un message indiquant une configuration autre que celle par défaut s'affiche.

Cette valeur est généralement configurée pour permettre aux clients MAPI de se connecter à un serveur Exchange situé de l'autre côté d'un pare-feu. Ce scénario implique l'ouverture de plusieurs ports sur un pare-feu pour permettre aux clients Microsoft Office Outlook® 2003 de se connecter via l'interface MAPI à un serveur Exchange, généralement sur Internet. Il s'agit d'une configuration prise en charge. Pour plus d'informations sur la configuration de clients MAPI pour qu'ils se connectent à Exchange via un pare-feu, voir l'article 270836 de la Base de connaissances Microsoft sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836). Si vous n'utilisez pas ce scénario, vous devez supprimer la clé de Registre.

Le déploiement recommandé pour l'utilisation d'Outlook en mode MAPI pour se connecter à un serveur Exchange via Internet consiste à utiliser les fonctionnalités RPC sur HTTP disponibles dans Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 et Microsoft Windows® XP Professionnel. Le mode MAPI était auparavant appelé mode « société » ou « groupe de travail ».

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer l'entrée de Registre TCP/IP

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Supprimez la valeur de Registre nommée TCP/IP.

  4. Fermez l'Éditeur du Registre et redémarrez le service de réplication de sites Microsoft Exchange.

Pour déployer RPC sur HTTP

  1. Voir le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Voir l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Voir l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Voir la Webdiffusion du Support Technique de Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le compte de démarrage configuré pour le service Surveillance du système n'est pas pris en charge
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Services pour déterminer si le compte de démarrage spécifié dans la propriété StartName du service Surveillance du système Microsoft Exchange (MSExchangeSA) utilise le compte LocalSystem. Si Exchange Server Analyzer détecte que la valeur de la propriété StartName sur un ordinateur Exchange 2000 Server ou Exchange Server 2003 n'est pas le compte LocalSystem, il affiche une erreur. Le compte LocalSystem est également appelé compte SYSTEM.

Vous devez démarrer MSExchangeSA dans Exchange 2000 Server et Exchange Server 2003 dans le contexte de sécurité LocalSystem. Vous ne pouvez pas démarrer MSExchangeSA en l'associant à un compte d'utilisateur spécifique. Lorsqu'un service Exchange qui s'exécute en tant que LocalSystem accède à un serveur distant, il est authentifié à l'aide des informations d'identification du compte d'ordinateur.

Le mécanisme standard de modification de mot de passe change le mot de passe du compte d'ordinateur tous les sept jours. En modifiant le mot de passe tous les sept jours, vous améliorez la sécurité du compte d'ordinateur. Ce dernier est plus sécurisé qu'un compte d'utilisateur normal pour les raisons suivantes :

  • Le mot de passe d'un compte d'utilisateur normal est modifié moins souvent.

  • Le mot de passe d'un compte d'utilisateur normal est moins aléatoire que celui d'un compte d'ordinateur généré de manière aléatoire.

Dans Exchange Server 5.5, les comptes d'utilisateur sont utilisés pour les services. Certains administrateurs familiarisés avec Exchange Server 5.5 changent le compte de démarrage sur les services Exchange 2000 Server et Exchange Server 2003 en passant du compte LocalSystem par défaut à un compte d'utilisateur.

Dans Exchange 2000 Server et Exchange Server 2003, Microsoft ne prend en charge l'exécution de MSExchangeSA sur aucun compte, excepté le compte LocalSystem par défaut.

Pour corriger cette erreur

  1. Cliquez sur Démarrer, pointez sur Programmes, Outils d'administration, puis cliquez sur Services.

  2. Dans la liste des services, cliquez avec le bouton droit sur Surveillance du système Microsoft Exchange, puis cliquez sur Propriétés.

  3. Sous l'onglet Ouvrir une session, sous Ouvrir une session en tant que, cliquez sur Compte LocalSystem, puis sur OK.

  4. Cliquez avec le bouton droit sur Surveillance du système Microsoft Exchange, puis cliquez sur Redémarrer.

Pour plus d'informations sur les services Exchange, voir l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem ( http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Le fichier STORE.EXE est manquant
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour vérifier la présence de plusieurs fichiers binaires principaux Exchange :

  • Exres.dll ;

  • Gapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapi32.dll (vérifié dans le dossier System32 et le dossier \Exchsrvr\bin) ;

  • Mapisp32.dll ;

  • Mapistub.dll ;

  • Cdo.dll ;

  • DavEx.dll ;

  • DSAccess.dll ;

  • EmsMta.exe ;

  • Epoxy.dll ;

  • Ese.dll ;

  • Eseutil.exe ;

  • ExCdo.dll ;

  • ExchMem.dll ;

  • ExMime.dll ;

  • ExOleDb.dll ;

  • ExPop3.dll ;

  • ExSmtp.dll ;

  • Mad.exe ;

  • Mbdsz.dll ;

  • OabGen.dll ;

  • PhatCat.dll ;

  • Phatq.dll ;

  • Reapi.dll ;

  • ReSvc.dll ;

  • Store.exe.

Si Exchange Server Analyzer détecte qu'un ou plusieurs des fichiers ci-dessus sont manquants, une erreur s'affiche. Pour corriger cette erreur, installez le dernier Service Pack ou le correctif cumulatif pour votre version d'Exchange. Si cette erreur persiste, procédez à l'installation d'Exchange 2000 Server ou Exchange Server 2003 et sélectionnez Réinstaller. L'exécution du programme d'installation en mode de réinstallation n'installe que des fichiers binaires. Il ne supprime ni ne réinitialise les données utilisateur ou les données de configuration. Si vous réinstallez Exchange Server, vous devez également réinstaller les Service Packs ou correctifs d'Exchange qui ont été installés.

Pour réinstaller Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller Exchange. Insérez le CD-ROM d'Exchange 2000 Server ou Exchange Server 2003 dans votre lecteur.

  2. Dans le menu Démarrer, cliquez sur Exécuter, puis entrez <lecteur>:\setup\i386\setup, où <lecteur> correspond à votre lecteur de CD-ROM.

  3. Sur la page Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  4. Sur la page Contrat de licence, lisez le contrat. Si vous en acceptez les termes, cliquez sur J'accepte, puis sur Suivant.

  5. Sur la page Identification du produit, entrez votre clé de produit (Product Key) de 25 caractères, puis cliquez sur Suivant.

  6. Sur la page Sélection des composants, dans la colonne Action, cliquez sur la flèche vers le bas en regard du nœud Microsoft Exchange, sélectionnez Réinstaller, puis cliquez sur Suivant.

Pour plus d'informations sur les derniers Service Packs d'Exchange 2003, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les derniers Service Packs d'Exchange 2000 Server, sur les correctifs cumulatifs et les compléments, voir le site Web des téléchargements d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=33457).


Le port HTTP de la banque est inférieur à 5000
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre Rpc/HTTP Port pour le service Banque d'informations Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Si Exchange Server Analyzer détecte que la valeur de Rpc/HTTP Port est définie sur une valeur inférieure à 5000 (décimal), un avertissement s'affiche.

La clé de Registre Rpc/HTTP Port est définie sur 6001 par le programme d'installation d'Exchange Server 2003 et d'Exchange Server 2007. La clé de Registre Rpc/HTTP Port permet la prise en charge de la fonctionnalité RPC sur HTTP pour Microsoft Office Outlook® 2003 et Microsoft Office Outlook 2007.

À moins que vous ayez personnalisé votre déploiement RPC sur HTTP à l'aide de MCS (Microsoft Consulting Services) ou sur recommandation des services de support technique Microsoft, il est recommandé de déployer RPC sur HTTP avec les valeurs de port par défaut.

Si vous devez définir Rpc/HTTP Port sur une valeur autre que 6001, il est recommandé de définir une valeur juste supérieure à 5000. L'affectation de numéros de port statiques inférieurs à 5000 risque de provoquer un conflit de port avec un autre processus et un échec du processus du service Banque d'informations Microsoft Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition du Registre Rpc/HTTP Port sur sa valeur par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

  3. Double-cliquez sur la clé Rpc/HTTP Port et définissez le champ Données de la valeur sur 6 001 (décimal) ou un entier à peine supérieur à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la configuration de RPC sur HTTP, consultez les articles suivants de la Base de connaissances :

  • 833401 sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330 sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Banque : Le port HTTP n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer HTTP Port est défini sur la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Si Exchange Server Analyzer détecte que la valeur définie pour Rpc/HTTP Port n'est pas 6001 (décimal), un message indiquant une configuration autre que celle par défaut s'affiche.

La clé de Registre Rpc/HTTP Port est définie sur 6001 par le programme d'installation d'Exchange Server 2003 et d'Exchange Server 2007. La clé de Registre Rpc/HTTP Port permet la prise en charge de la fonctionnalité RPC sur HTTP pour Microsoft Office Outlook® 2003 et Microsoft Office Outlook 2007.

À moins que vous ayez personnalisé votre déploiement RPC sur HTTP à l'aide de MCS (Microsoft Consulting Services) ou sur recommandation des services de support technique Microsoft, il est recommandé de déployer RPC sur HTTP avec les valeurs de port par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la clé de Registre Rpc/HTTP Port sur sa valeur par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Double-cliquez sur la clé Rpc/HTTP Port et définissez le champ Données de la valeur sur 6001 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la configuration de RPC sur HTTP, consultez les articles suivants de la Base de connaissances :

  • 833401 sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330 sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Configuration sous-optimale de la mémoire
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-15

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si une erreur Événement 9665 a été enregistrée pour MSExchangeIS au cours des dernières 24 heures.

Microsoft Exchange Server 2003 vérifie si la configuration de la mémoire est optimale lors du démarrage du processus de la banque d'informations. Si la configuration de la mémoire a besoin d'être optimisée, l'événement 9665 apparaît dans l'Observateur d'événements.

Si Exchange Analyzer détecte qu'un événement 9665 a été enregistré au cours des dernières 24 heures, il lit le champ de données de l'événement pour identifier les indicateurs du tableau ci-après présents dans l'événement.

Indicateur du champ de données de l'événement | Avertissement d'Exchange Server Analyzer affiché | Problème d'Exchange Server 2003
0x00000001 | Le commutateur /3GB n'est pas défini. | Le serveur exécute Microsoft Windows 2000 Advanced Server ou Microsoft Windows 2000 Datacenter Server et est doté d'une mémoire physique égale ou supérieure à 1 Go mais le commutateur /3GB n'est pas défini dans le fichier boot.ini.
0x00000002 | Le commutateur /Userva n'est pas correctement défini. | Le serveur exécute Microsoft Windows Server 2003 Standard Edition, Microsoft Windows Server 2003 Enterprise Edition ou Microsoft Windows Server 2003 Datacenter Edition, est doté d'une mémoire physique égale ou supérieure à 1 Go et le commutateur /3GB est défini, mais le commutateur /USERVA n'est pas configuré dans le fichier boot.ini.
0x00000004 | Le paramètre « SystemPages » doit être défini. | Le serveur exécute une édition de Microsoft Windows 2000 Server et la valeur SystemPages du Registre est définie en dehors de la plage allant de 24000 à 31000.
0x00000008 | Le paramètre « SystemPages » doit être redéfini. | Le serveur exécute Microsoft Windows Server 2003 Standard, Microsoft Windows Server 2003 Enterprise ou Microsoft Windows Server 2003 Datacenter Edition, et le paramètre SystemPages du Registre est défini sur une valeur autre que 0.
0x00000010 | Le paramètre HeapDecommitFreeBlockThreshold n'est pas correctement défini. | Le serveur exécute une édition de Microsoft Windows 2000 Server ou Microsoft Windows Server 2003, et le paramètre HeapDeCommitFreeBlockThreshold du Registre est défini sur une valeur autre que 0x00040000.

En fonction de l'indicateur figurant dans le champ de données de l'événement 9665, Exchange Analyzer affiche l'avertissement correspondant indiqué dans le tableau ci-avant.

Ces avertissements indiquent que la configuration de la mémoire d'Exchange Server n'est pas optimale.

Pour supprimer ces avertissements, suivez les instructions des articles sur Exchange Analyzer, relatifs à des problèmes spécifiques, répertoriés ci-après :

  • Le serveur de boîtes aux lettres Exchange a au moins 1 Go de mémoire mais /3GB n'est pas défini dans le fichier Boot.ini

  • Le commutateur USERVA n'est pas défini correctement

  • SystemPages défini sur une valeur trop élevée

  • Ce serveur exécute Windows Server 2003 et la valeur SystemPages n'est pas égale à 0.

  • Ce serveur possède 1 Go ou plus de mémoire physique et HeapDeCommitFreeBlockThreshold n'a pas été défini sur 262144

Pour plus d'informations

Pour plus d'informations sur ces problèmes, consultez l'article 325044 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de fragmentation de la mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Pour plus d'informations sur l'événement 9665 de MSExchangeIS, consultez les pages du centre des événements et messages d'erreur.

  • Événement 9665 de la banque de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=83210)

  • Événement 9665 de la banque publique (http://go.microsoft.com/fwlink/?LinkId=83213)


Moteurs de recherche de bureau suspects installés sur les clients
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-05

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que nombre de vos utilisateurs emploient un moteur de recherche de bureau. Ces moteurs risquent de créer des appels de procédure distante (RPC) sur les boîtes aux lettres montées d'un utilisateur, ainsi qu'un trafic important sur les dossiers publics car ces moteurs de recherche analysent la structure des fichiers de la banque de dossiers publics. De nombreux moteurs de recherche n'analysent les dossiers publics que s'ils se trouvent dans la liste de favoris de dossiers publics de l'utilisateur. Par conséquent, il se peut qu'aucune charge n'apparaisse sur les serveurs de dossiers publics dans la recherche de bureau.

Parmi les mesures à prendre pour atténuer ce problème, citons les suivantes :

  • Demandez à vos utilisateurs de désactiver les fonctionnalités Microsoft Office Outlook® de l'analyseur ou limitez l'analyse à leur seule boîte aux lettres personnelle.

  • Exécutez Outlook en mode Exchange mis en cache pour que les analyses ne s'effectuent que sur la station de travail locale et non sur le serveur.

  • Suivez les instructions de l'article 889086 de la Base de connaissances Microsoft sur la possibilité de rencontrer un comportement inattendu sur un ordinateur Windows XP lorsque vous essayez d'accéder à des dossiers publics sur Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086) pour obtenir le correctif et définir la clé de Registre MaxObjsPerMapiSession sur des ordinateurs exécutant Exchange Server accessibles par des utilisateurs d'une recherche de bureau.

Pour vérifier si l'application de recherche de bureau est la cause d'une charge élevée pour un utilisateur particulier, utilisez ExMon, l'outil de surveillance des utilisateurs de Microsoft Exchange Server, pour contrôler les opérations RPC, les actions du moteur de recherche et vous assurer de la collecte de données pour une période adéquate (au moins cinq minutes). Supprimez ensuite le moteur de recherche et réexécutez l'outil ExMon. Si le taux de RPC a considérablement diminué, vous pouvez être sûr que le moteur de recherche de bureau provoque l'augmentation de la charge. Si vous observez des diminutions de latence RPC moyennes, vous savez qu'une charge élevée se traduit par des latences RPC supérieures.

Remarque :
Les taux de latence RPC varient considérablement au cours d'une journée. Par conséquent, un essai de cinq minutes n'est pas adapté. Mieux vaut effectuer une mesure sur une plus longue période.

Pour télécharger ExMon, voir le Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?linkid=54983).

Pour plus d'informations

  • Pour plus d'informations sur le logiciel de recherche de bureau, voir les documents suivants :

    • Article 905184 de la Base de connaissances Microsoft sur les performances d'Exchange 2000 Server et d'Exchange Server 2003 qui risquent d'être affectées en cas d'exécution du logiciel de moteur de recherche de bureau sur Outlook ou d'autres ordinateurs clients MAPI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184)

    • Blog de l'équipe Microsoft Exchange sur l'utilisation par vos clients de moteurs de recherche de bureau qui indexent des dossiers publics ou des boîtes aux lettres Exchange (http://go.microsoft.com/fwlink/?LinkId=54475).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


SystemPages défini sur une valeur trop élevée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-03-13

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de SystemPages :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Si Exchange Server Analyzer détecte que la valeur de SystemPages est supérieure à 50000, il affiche un avertissement.

Microsoft Windows Server™ 2003 et Microsoft Windows® 2000 Server peuvent directement traiter 4 gigaoctets (Go) d'espace d'adressage mémoire maximum, quelle que soit la taille de RAM physique installée. Du point de vue du processus, chaque élément d'adresse virtuelle fait théoriquement référence à un octet de mémoire physique. Le gestionnaire de mémoire virtuelle (VMM) est chargé, en association avec l'unité de gestion de la mémoire (MMU) du processeur, de traduire ou mapper chaque adresse virtuelle en une adresse physique correspondante. Le gestionnaire de mémoire virtuelle effectue le mappage en divisant la RAM en cadres de page de taille fixe, créant ainsi des entrées dans la table des pages (PTE) pour stocker des informations relatives à ces cadres et les mapper. Les PTE système sont de petits tampons de mémoire en mode noyau utilisés pour communiquer avec le sous-système d'E/S et le réseau. Chaque PTE représente un cadre de page et contient des informations nécessaires, permettant au gestionnaire de mémoire virtuelle de localiser une page.

Sur un système X86 utilisant une taille de page de 4 Ko, le nombre maximal de PTE requis pour mapper 2 Go d'espace d'adressage s'élève à 524 288 (2 Go/4 Ko). Sur un système similaire utilisant le commutateur /3GB, le nombre de PTE requis pour mapper 3 Go d'espace d'adressage s'élève à 786 432 (3 Go/4 Ko). Sur un système standard, cet espace est utilisé comme suit :

  • Un maximum de 50 000 PTE (environ 195 Mo d'espace d'adressage) est réservé à un usage général.

  • Le reste est utilisé pour mapper le cache système, l'hyperespace, la réserve paginée, la réserve non paginée, la zone de vidage sur incident, etc.

La taille de la réserve de PTE est automatiquement déterminée au démarrage du système en fonction de la quantité de mémoire physique du système. Cette réserve est insérée entre la réserve paginée et la réserve non paginée, qui augmente également avec la quantité de mémoire physique du système.

La réserve de PTE système peut être fréquemment utilisée et fragmentée. Cela pourrait conduire à des situations où un pilote peut ne pas se charger, etc. De même, si la réserve de PTE système est entièrement épuisée, d'autres parties du système se dégradent, pouvant annuler la création de threads, bloquer le système ou provoquer des incidents potentiels.

Pour éviter une fragmentation excessive de la réserve de PTE système, il est recommandé de toujours configurer la valeur de Registre SystemPages en fonction du système d'exploitation de votre ordinateur Exchange Server. Lorsque vous exécutez Exchange Server sur Windows Server 2003, il est recommandé de définir la clé de Registre SystemPages sur 0. Cette recommandation diffère de celle pour Windows 2000 Server, qui propose de définir SystemPages sur une valeur comprise entre 24000 et 31000.

Après avoir exécuté la procédure décrite ci-dessous, vous devez contrôler le nombre de PTE système libres. Pour ce faire, vous pouvez contrôler le compteur de performance des PTE système libres avec le Moniteur système de Windows (également connu comme le Moniteur système). Si le nombre de PTE système libres reste faible après avoir modifié le Registre comme décrit ci-dessous, vous devez vérifier les éléments suivants pour vous assurer que votre ordinateur Exchange Server est configuré de manière optimale :

  • Pilotes Un pilote défectueux est l'une des causes les plus courantes d'un faible nombre de PTE système. En outre, certaines versions des pilotes de carte graphique S3 Savage 4 définissent SystemPages sur 208 896. Ce pilote se trouve généralement sur des serveurs IBM E-Series. Contactez votre fabricant de matériel pour vous assurer que vous utilisez les pilotes les plus récents pour tout votre matériel. Il est également possible de passer à un pilote plus simple. Par exemple, les ordinateurs qui exécutent des applications serveur telles qu'Exchange Server n'ont généralement pas besoin des pilotes vidéo les plus avancés équipés de toutes les fonctionnalités. Au contraire, un pilote plus simple est souvent suffisant. Passer d'un pilote vidéo avancé à un pilote vidéo de base doit augmenter le nombre de PTE système libres.

  • Configuration système Si votre système Windows Server 2003 est équipé d'au moins 1 Go de mémoire physique, vous devez vous assurer que son fichier Boot.ini est correctement configuré avec les commutateurs /3GB et /USERVA=3030 comme décrit dans les articles suivants de la Base de connaissances Microsoft :

    • 823440 sur l'obligation d'utiliser le commutateur /3GB lorsque vous installez Exchange Server 2003 sur un système Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440)

    • 810371 sur l'utilisation du commutateur /Userva sur des serveurs Exchange Windows 2003 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371).

  • Journaux d'événements Vérifiez la présence d'erreurs et d'avertissements dans le journal des événements Applications d'Exchange Server, notamment les événements MSExchangeIS 9582 (erreurs et avertissements), 9665 (avertissement) et 12880 (erreur). La présence de l'événement 9665 peut également indiquer que SystemPages n'est pas configuré pour des performances optimales. Pour plus d'informations sur ces événements, voir l'article 325044 de la Base de connaissances sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange 2003 et Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cet avertissement sur Windows 2000 Server en modifiant la valeur de SystemPages

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez une valeur comprise entre 24 000 et 31 000 (décimal), puis cliquez sur OK. Si vous n'êtes pas sûr de la valeur à utiliser, nous vous recommandons la valeur 31000 (décimal).

  5. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour corriger cet avertissement sur Windows 2003 Server en modifiant la valeur de SystemPages

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour corriger cet avertissement en mettant à jour le pilote graphique ou en le mettant à niveau vers une version antérieure

  • Effectuez l'une des opérations suivantes :

    • Contactez votre fabricant de matériel pour obtenir un pilote graphique mis à jour ne configurant pas le paramètre SystemPages.

    • Mettez à niveau le pilote graphique vers une version de pilote VGA standard et corrigez la valeur SystemPages comme décrit ci-dessus.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'optimisation de la mémoire d'Exchange Server, voir les articles suivants de la Base de connaissances :

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Le port HTTP du service Surveillance du système est inférieur à 5000
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre HTTP Port pour le service Surveillance du système Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Si Exchange Server Analyzer détecte que la valeur de HTTP Port est définie sur une valeur inférieure à 5000 (décimal), un avertissement s'affiche.

La clé de Registre HTTP Port est définie sur 6002 par le programme d'installation d'Exchange Server 2003 et d'Exchange Server 2007. La clé de Registre HTTP Port permet la prise en charge de la fonctionnalité RPC sur HTTP pour Microsoft Office Outlook® 2003 et Microsoft Office Outlook 2007.

À moins que vous ayez personnalisé votre déploiement RPC sur HTTP à l'aide de MCS (Microsoft Consulting Services) ou sur recommandation des services de support technique Microsoft, il est recommandé de déployer RPC sur HTTP avec les valeurs de port par défaut.

Si vous devez définir HTTP Port sur une valeur autre que 6002, il est recommandé de le définir sur une valeur à peine supérieure à 5000. L'affectation de numéros de port statiques inférieurs à 5000 risque de provoquer un conflit de port avec un autre processus et un échec du processus du service Surveillance du système Microsoft Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la clé de Registre HTTP Port sur sa valeur par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé HTTP Port et définissez le champ Données de la valeur sur 6002 (décimal) ou un entier à peine supérieur à 5 000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la configuration de RPC sur HTTP, consultez les articles suivants de la Base de connaissances :

  • 833401 sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330 sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Le port NSPI HTTP du service Surveillance du système est inférieur à 5000
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre Rpc/HTTP NSPI Port pour le service Surveillance du système Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Si Exchange Server Analyzer détecte que la valeur de Rpc/HTTP NSPI Port est définie sur une valeur inférieure à 5000 (décimal), un avertissement s'affiche.

La clé de Registre Rpc/HTTP NSPI Port est définie sur 6004 par le programme d'installation d'Exchange Server 2003 et d'Exchange Server 2007. La clé de Registre Rpc/HTTP NSPI Port permet la prise en charge de la fonctionnalité RPC sur HTTP pour Microsoft Office Outlook® 2003 et Microsoft Office Outlook 2007.

À moins que vous n'ayez personnalisé votre déploiement RPC sur HTTP à l'aide de MCS (Microsoft Consulting Services) ou sur recommandation des services de support technique Microsoft, il est recommandé de déployer RPC sur HTTP avec les valeurs de port par défaut.

Si vous devez définir Rpc/HTTP NSPI Port sur une valeur autre que 6004, il est recommandé de définir une valeur juste supérieure à 5000. L'affectation de numéros de port statiques inférieurs à 5000 risque de provoquer un conflit de port avec un autre processus et un échec du processus du service Surveillance du système Microsoft Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la clé de Registre Rpc/HTTP NSPI Port sur sa valeur par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé Rpc/HTTP NSPI Port et définissez le champ Données de la valeur sur 6004 (décimal) ou un entier à peine supérieur à 5000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la configuration de RPC sur HTTP, consultez les articles suivants de la Base de connaissances :

  • 833401 sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330 sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Service Surveillance du système : Le port HTTP NSPI n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer HTTP Port est défini sur la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Si Exchange Server Analyzer détecte que la valeur définie pour Rpc/HTTP NSPI Port n'est pas 6004 (décimal), un message indiquant une configuration autre que celle par défaut s'affiche.

La clé de Registre Rpc/HTTP NSPI Port est définie sur 6004 par le programme d'installation d'Exchange Server 2003. La clé de Registre Rpc/HTTP NSPI Port permet la prise en charge de la fonctionnalité RPC sur HTTP pour Microsoft Office Outlook® 2003.

À moins que vous ayez personnalisé votre déploiement RPC sur HTTP à l'aide de MCS (Microsoft Consulting Services) ou sur recommandation des services du Support Technique de Microsoft, il est recommandé de déployer RPC sur HTTP avec les valeurs de port par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour définir la valeur de Registre Rpc/HTTP NSPI Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé Rpc/HTTP NSPI Port et définissez le champ Données de la valeur sur 6004 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la configuration de RPC sur HTTP, voir les articles suivants de la Base de connaissances :

  • 833401 sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330 sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Surveillance du système : la valeur du port HTTP n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer HTTP Port est défini sur la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Si Exchange Server Analyzer détecte que la valeur définie pour HTTP Port n'est pas 6002 (décimal), un message indiquant une configuration autre que celle par défaut s'affiche.

La clé de Registre HTTP Port est définie sur 6002 par le programme d'installation d'Exchange Server 2003 et d'Exchange Server 2007. La clé de Registre HTTP Port permet la prise en charge de la fonctionnalité RPC sur HTTP pour Microsoft Office Outlook® 2003 et Microsoft Office Outlook 2007.

À moins que vous ayez personnalisé votre déploiement RPC sur HTTP à l'aide de MCS (Microsoft Consulting Services) ou sur recommandation des services de support technique Microsoft, il est recommandé de déployer RPC sur HTTP avec les valeurs de port par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition de la clé de Registre HTTP Port sur sa valeur par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Double-cliquez sur la clé HTTP Port et définissez le champ Données de la valeur sur 6002 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez l'ordinateur pour que ce paramètre soit pris en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la configuration de RPC sur HTTP, consultez les articles suivants de la Base de connaissances :

  • 833401 sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330 sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


La valeur legacyExchangeDN du service Surveillance du système est manquante
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut legacyExchangeDN pour l'objet Surveillance du système de chaque ordinateur Exchange Server. Si Exchange Server Analyzer ne détecte pas de valeur pour l'attribut legacyExchangeDN d'un objet Surveillance du système, il affiche un message d'erreur.

Une valeur legacyExchangeDN peut être manquante lorsqu'un administrateur modifie Active Directory pour récupérer une base de données dans une situation de récupération d'urgence. Pour corriger cette erreur, vous devez modifier l'attribut legacyExchangeDN à l'aide d'un éditeur Active Directory, tel que l'outil LDP (ldp.exe) ou ADSI Edit.

Pour vous assurer que l'attribut legacyExchangeDN est correct, vous devez également vérifier d'autres objets Surveillance du système pour ce serveur ou un autre serveur Exchange qui ne génèrent pas cette erreur, car ils doivent avoir une valeur similaire pour l'attribut legacyExchangeDN.

Si l'attribut legacyExchangeDN est manquant sur une base de données, il est probable qu'il le soit également sur plusieurs autres objets système. Si vous utilisez LDP ou ADSI Edit pour ajouter une nouvelle valeur legacyExchangeDN, vous devez par conséquent ajouter une nouvelle valeur legacyExchangeDN pour tous les autres objets système également.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Correction de cette erreur

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Développez Configuration [Nom_domaine], CN=Configuration, DC=Nom_domaine, DC=Suffixe_domaine.

  3. Développez CN=Services, puis CN=Microsoft_Exchange.

  4. Développez CN=Nom_organisation, CN=Groupes_administration, puis CN=Nom_groupe_administration.

  5. Développez CN=Serveurs, puis CN=Nom_serveur.

  6. Cliquez avec le bouton droit sur CN=Surveillance_système_Microsoft et sélectionnez Propriétés.

  7. Faites défiler jusque legacyExchangeDN, sélectionnez-le et cliquez sur Modifier.

  8. Dans le champ Valeur, entrez l'attribut legacyExchangeDN correct.

  9. Fermez l'Éditeur Active Directory et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit pour créer un attribut legacyExchangeDN, consultez l'article 273863 de la Base de connaissances Microsoft sur la procédure de modification de l'attribut LegacyExchangeDN en mode natif avec ADSI Edit (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863).


Le port System Attendant NSPI a été remplacé manuellement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si le service du serveur cible NSPI (serveur cible Name Service Provider Interface) a été remplacé manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Si Exchange Server Analyzer détecte que la valeur TCP/IP NSPI Port est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Cette valeur est généralement configurée pour permettre aux clients MAPI de se connecter à un serveur Exchange situé de l'autre côté d'un pare-feu. Ce scénario implique l'ouverture de plusieurs ports sur un pare-feu pour permettre aux clients Microsoft Office Outlook® 2003 de se connecter via l'interface MAPI à un serveur Exchange, généralement sur Internet.

Le déploiement recommandé pour l'utilisation d'Outlook en mode société ou groupe de travail pour se connecter à un serveur Exchange via Internet consiste à utiliser les fonctionnalités RPC sur HTTP disponibles dans Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 et Windows® XP Professionnel.

RPC sur HTTP élimine le besoin d'utiliser une connexion de réseau privé virtuel (VPN) ou d'ouvrir plusieurs ports sur votre pare-feu pour permettre à Outlook 2003 d'accéder à Exchange Server 2003 via l'interface MAPI. Un utilisateur qui exécute Outlook 2003 peut se connecter à un serveur Exchange via Internet. Le client RPC établit la connexion Internet par le tunneling du trafic RPC via le protocole HTTP. Si le client RPC peut établir une connexion HTTP/HTTPS avec un ordinateur distant qui exécute les services IIS (Internet Information Services), le client RPC peut se connecter à tout serveur sur le réseau distant. Le serveur sur le réseau distant doit être configuré pour être accessible via Internet en utilisant RPC sur HTTP. Le client RPC et les programmes serveur RPC peuvent également se connecter via Internet, même si les deux programmes se trouvent derrière des pare-feu situés sur des réseaux différents.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Suppression de l'entrée de Registre TCP/IP NSPI Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Supprimez la valeur de Registre nommée TCP/IP NSPI Port.

  4. Quittez l'Éditeur du Registre et redémarrez le service Surveillance du système Exchange.

Déploiement de RPC sur HTTP

  1. Consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez l'article 833401 de la Base de connaissances Microsoft sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Consultez la Webdiffusion des services de support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre TCP/IP NSPI Port dans un environnement de pare-feu, consultez l'article de la Base de connaissances sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Le service Surveillance du système est configuré de manière à interagir avec le Bureau
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la propriété DesktopInteract pour le service Surveillance du système Microsoft Exchange (MSExchangeSA). Si Exchange Server Analyzer détecte que le service Surveillance du système Exchange est configuré de manière à interagir avec le Bureau, il affiche une erreur.

Cette configuration ne doit être utilisée que sur recommandation des services du Support Technique de Microsoft. À moins que les services du Support Technique de Microsoft vous ait demandé d'exécuter le service Surveillance du système dans cette configuration, il est recommandé de reconfigurer les propriétés de ce service de manière telle qu'il n'interagisse pas avec le Bureau.

Pour configurer le compte du service Surveillance du système Exchange

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Recherchez et arrêtez le service Surveillance du système Microsoft Exchange. Notez qu'arrêter le service Surveillance du système arrête également tous les services qui en dépendent, notamment le service de banque d'informations de Microsoft Exchange.

  3. Double-cliquez sur le service Surveillance du système Microsoft Exchange.

  4. Sous l'onglet Ouvrir une session de la page Propriétés du service Surveillance du système Microsoft Exchange, sélectionnez Compte LocalSystem dans Ouvrir une session en tant que.

  5. Désactivez la case à cocher Autoriser le service à interagir avec le Bureau, puis cliquez sur Appliquer.

  6. Sous Statut du service, cliquez sur Démarrer, puis sur OK.

  7. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur la configuration correcte du service Exchange, voir l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Le service de Surveillance du système n'est pas exécuté comme LocalSystem
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-01-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la propriété StartName pour le service Surveillance du système Microsoft Exchange (MSExchangeSA). Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber sur l'objet Exchange Server de l'annuaire. L'attribut serialNumber sur l'objet Exchange Server identifie la version d'Exchange Server en cours d'exécution sur l'ordinateur représenté par l'objet. Si Exchange Server Analyzer détecte que le service Surveillance du système Exchange est exécuté sous un compte autre que LocalSystem (SYSTEM) sur un serveur Exchange utilisant Exchange 2000 Server, Exchange Server 2003 ou Exchange Server 2007, il affiche une erreur.

Cette erreur indique que le service Surveillance du système n'est pas exécuté dans une configuration prise en charge. L'exécution du service Surveillance du système sous un autre compte, quel qu'il soit, engendrera des erreurs d'autorisation et d'accès.

Pour corriger cette erreur, vous devez configurer le service Surveillance du système Exchange pour qu'il démarre sous le compte LocalSystem (SYSTEM).

Remarque :
Cette erreur ne s'applique pas à Exchange Server version 5.5. Seuls Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007 exigent que le service Surveillance du système Exchange soit exécuté sous le compte LocalSystem.
Configuration du compte du service Surveillance du système Exchange

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Recherchez et arrêtez le service Surveillance du système Microsoft Exchange. Notez qu'arrêter le service Surveillance du système arrête également tous les services qui en dépendent, notamment le service Banque d'informations Microsoft Exchange.

  3. Double-cliquez sur le service Surveillance du système Microsoft Exchange.

  4. Sous l'onglet Ouvrir une session de la page Propriétés du service Surveillance du système Microsoft Exchange, sélectionnez Compte LocalSystem dans Ouvrir une session en tant que, puis cliquez sur Appliquer.

  5. Sous Statut du service, cliquez sur Démarrer, puis sur OK.

  6. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur l'exécution de services Exchange sous le compte LocalSystem, consultez l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


La clé TcpTimedWaitDelay est manquante ou n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-03-13

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut serialNumber pour tous les objets ayant une classe d'objet msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne inclut « Version 6.5 », l'ordinateur exécute Exchange Server 2003. Si la valeur de chaîne inclut « Version 8.0 », l'ordinateur exécute Exchange Server 2007.

Exchange Analyzer lit ensuite la branche de registre suivante pour chaque serveur Exchange Server 2007 détecté pour déterminer si la valeur de la clé TcpTimedWaitDelay est définie sur la valeur par défaut 60.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

La clé TcpTimedWaitDelay détermine le temps qui doit s'écouler avant que TCP puisse publier une connexion fermée et réutiliser ses ressources. Cet intervalle entre la clôture et la publication s'appelle état TIME_WAIT ou état 2MSL. Pendant cet intervalle, la connexion peut être réouverte à un coût moindre pour le client et le serveur que s'ils avaient établi une nouvelle connexion.

En réduisant la valeur de cette entrée, TCP peut libérer de nouvelles connexions fermées plus rapidement, et offrir davantage de ressources pour de nouvelles connexions. Toutefois, si la valeur est trop faible, TCP peut libérer des ressources de connexion avant que la connexion soit complète, nécessitant ainsi que le serveur utilise des ressources supplémentaires pour réétablir la connexion.

Si Exchange Analyzer détermine que la valeur de la clé TcpTimedWaitDelay est manquante ou n'est pas égale à la valeur par défaut de 60, il affiche un avertissement.

Pour des performances optimales, nous vous recommandons de définir la clé TcpTimedWaitDelay sur cette valeur par défaut de 60 sur les serveurs Exchange Server 2007.

Important :
Cette rubrique contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la procédure de restauration du Registre, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Définition de la clé de Registre TcpTimedWaitDelay sur sa valeur par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Double-cliquez sur TcpTimedWaitDelay, et définissez le champ Données de la valeur sur 60 (décimal).

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Ce problème est lié au problème de l'Analyzer La clé MaxUserPort est manquante ou n'est pas définie par défaut.

Pour plus d'informations sur l'effet des clés de Registre MaxUserPort et TcpTimedWaitDelay, voir la rubrique sur le protocole TCP du Kit de ressources Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=85654).


La variable TEMP/TMP semble pointer vers un dossier non valide ou inapproprié
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

Sur un ordinateur Exchange Server non membre d'un cluster, l'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer la valeur des variables des environnements TEMP et TMP :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Le service de banque d'informations de Microsoft Exchange utilise les dossiers TEMP et TMP pour le stockage temporaire lors de diverses opérations, telles que la conversion des messages et le déplacement de boîtes aux lettres. Sur un serveur Exchange non membre d'un cluster, la banque d'informations de Microsoft Exchange utilise le SYSTÈME (par exemple, Système local) utilisant un paramètre de variable d'environnement par défaut %Systemroot%\Temp pour TEMP et TMP. Si au moins une des deux variables d'environnement TEMP ou TMP du serveur Exchange commence par %SYSTEMROOT, un avertissement s'affiche.

Les variables d'environnement TEMP et TMP permettent de désigner les dossiers du système de fichiers (par exemple, le chemin d'accès) devant être utilisés par les applications qui nécessitent un espace de travail temporaire. TEMP est généralement utilisé par des applications, telles que Microsoft Exchange, et TMP par des outils de développement, tels que Microsoft Visual C++®. Le chemin d'accès de chaque variable est généralement relatif au contexte de sécurité de l'application ou de l'outil.

Lorsqu'Exchange Server Analyzer est utilisé sur un serveur virtuel Exchange dans un cluster Windows Server™ 2003, l'arborescence du Registre HKLM n'est pas lue. Par contre, les entrées de Registre suivantes sont lues :

HKEY_USERS\<SID de compte du service de cluster>\Environment\TEMP

HKEY_USERS\<SID de compte du service de cluster>\Environment\TMP

Les serveurs virtuels Exchange exécutés dans un cluster Windows Server 2003 utilisent les paramètres de variable d'environnement du compte du service de cluster, qui opère dans le contexte d'un principe de sécurité utilisateur spécifique. Pour les comptes d'utilisateurs, la variable d'environnement par défaut de TEMP et TMP est définie sur %Userprofile%\temp. Si au moins une des deux variables d'environnement TEMP ou TMP du serveur virtuel Exchange commence par %SYSTEMROOT, un avertissement s'affiche.

Pour des performances optimales, il est recommandé de ne pas utiliser le disque contenant le système d'exploitation pour les dossiers TEMP et TMP utilisés par Exchange. En outre, vous devez veiller à ce que ces variables d'environnement soient définies sur des chemins d'accès d'un disque rapide ou d'un sous-système de disque, tel que l'ensemble de piles RAID 0+1. Il est également recommandé de ne pas utiliser le disque contenant le système d'exploitation pour les dossiers TEMP et TMP utilisés par les serveurs Exchange virtuels ou non.

Pour supprimer cet avertissement

  1. Connectez-vous à l'ordinateur Exchange Server avec un compte disposant de droits d'administration.

  2. Cliquez avec le bouton droit sur Poste de travail et sélectionnez Propriétés.

  3. Cliquez sur l'onglet Avancé.

  4. Cliquez sur Variables d'environnement.

  5. Dans la zone Variables système, sélectionnez TEMP, puis cliquez sur le bouton Modifier.

  6. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TEMP et cliquez sur OK.

  7. Dans la zone Variables système, sélectionnez TMP, puis cliquez sur le bouton Modifier.

  8. Dans le champ Valeur de la variable, entrez le nouveau chemin d'accès de la variable d'environnement TMP et cliquez sur OK.

  9. Cliquez sur OK pour fermer la boîte de dialogue Variables d'environnement, puis une nouvelle fois sur OK pour fermer la boîte de dialogue Propriétés système.

  10. Redémarrez le nœud pour appliquer la modification.

Pour plus d'informations sur la modification des variables d'environnement TEMP/TMP sur un serveur Exchange membre d'un cluster, voir l'article Le chemin d'accès à l'environnement TEMP/TMP du cluster se trouve sur le même lecteur que la partition système.


Ce serveur possède 1 Go ou plus de mémoire physique et HeapDeCommitFreeBlockThreshold n'a pas été défini sur 262144
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-08-14

Message d'erreur

Introduction

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si Exchange a été configuré de manière optimale en fonction de la quantité de mémoire physique dans le système :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

Si Exchange Server Analyzer détecte que la valeur de HeapDeCommitFreeBlockThreshold n'a pas été définie sur un ordinateur Exchange Server possédant un 1 gigaoctet (Go) ou plus de mémoire physique, un avertissement s'affiche.

Lorsque de la mémoire est libérée sur une adresse donnée, le gestionnaire de segments du système d'exploitation vérifie le nombre d'octets contigus libres autour de cette adresse. Une fois cette vérification terminée, le gestionnaire de segments peut faire l'une des deux opérations suivantes :

  • Garder le bloc de mémoire contiguë alloué.

  • Désallouer le bloc de mémoire contiguë et le marquer comme étant réservé uniquement.

La clé de Registre HeapDeCommitFreeBlockThreshold spécifie le nombre d'octets contigus au-delà duquel la mémoire est désallouée. Par défaut, le gestionnaire de segments n'associe pas nécessairement tous les blocs libres ou n'effectue pas de nouvelles allocations ; les blocs peuvent donc être désalloués et devenir des trous inutiles dans l'espace d'adresse virtuelle. Cela peut entraîner une fragmentation de la mémoire virtuelle, des performances médiocres et finalement une instabilité du système.

Sur les systèmes possédant 1 Go ou plus de mémoire physique, les performances sont optimisées en contrôlant la taille des blocs de mémoire désallouée. La clé de Registre HeapDeCommitFreeBlockThreshold permet de contrôler la gestion de la mémoire lors de sa libération. Lorsque vous ajoutez cette valeur au Registre, vous devez la configurer avec une valeur hexadécimale de 0x00040000 (262144 en décimal).

Microsoft ne prend en charge que la valeur hexadécimale de 0x00040000 (262144 en décimal) pour la clé de Registre HeapDeCommitFreeBlockThreshold.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Correction de cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Control\Session Manager

  3. Créez une valeur DWORD appelée HeapDeCommitFreeBlockThreshold.

  4. Double-cliquez sur la valeur HeapDeCommitFreeBlockThreshold et entrez une valeur hexadécimale de 0x00040000 (262144 en décimal).

  5. Fermez l'Éditeur du Registre et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre HeapDeCommitFreeBlockThreshold, voir les articles suivants de la Base de connaissances :

  • 315407 sur la clé de Registre HeapDeCommitFreeBlockThreshold (http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)


Ce serveur exécute Windows Server 2003 et la valeur SystemPages n'est pas égale à 0.
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur SystemPages :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de cette clé correspond à une version spécifique d'un système d'exploitation Microsoft Windows.

Si Exchange Server Analyzer détecte que la valeur de SystemPages n'est pas définie sur 0 sur un ordinateur Exchange Server qui exécute Microsoft Windows Server™ 2003 ne faisant pas partie d'une installation Microsoft Windows Small Business Server 2003, un avertissement s'affiche.

Lorsque vous exécutez Exchange Server 2003 Service Pack 1 (SP1) sur Microsoft Windows Server 2003 avec au moins 1 Go de RAM, il est recommandé de définir la clé de Registre SystemPages sur 0. Cette recommandation s'oppose à celle pour Microsoft Windows 2000 Server, qui suggère de définir SystemPages sur une valeur comprise entre 24 000 et 31 000.

Sur un ordinateur Windows Server 2003 ne faisant pas partie d'une installation Microsoft Windows Small Business Server 2003, vous ne devez jamais définir la valeur de Registre SystemPages sur une valeur autre que 0. Si vous modifiez cette valeur, le système ne peut pas calculer une valeur optimale pour votre système ni régler la valeur lorsque votre système est modifié.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Attention :
La définition de la valeur de Registre SystemPages sur les ordinateurs exécutant Windows Server 2003 se traduit par une réduction de la taille maximale de la réserve paginée et peut entraîner l'épuisement de la réserve paginée et une instabilité du serveur.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Dans le volet droit, double-cliquez sur SystemPages.

  4. Dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  5. Quittez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'optimisation de la mémoire d'Exchange Server, voir les articles suivants de la Base de connaissances :

  • 325044 sur la procédurede dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901)


Ce serveur Exchange comporte un commutateur de démarrage /PAE défini dans le fichier Boot.ini
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Win32_ComputerSystem pour déterminer les options définies dans la propriété SystemStartupOptions. Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer le nombre d'attributs homeMDBBL de l'objet de banque de boîtes aux lettres (msExchPrivateMDB). Le résultat est le nombre de boîtes aux lettres identifiées sur l'ordinateur Exchange Server.

Si Exchange Server Analyzer détecte que le commutateur de démarrage /PAE a été défini dans le fichier boot.ini sur un serveur Exchange disposant de moins de 500 boîtes aux lettres et exécutant Windows 2000 Server, un avertissement s'affiche.

Les PAE (Physical Addressing Extensions) permettent à un ordinateur d'accéder à plus de 4 Go de mémoire physique (RAM). Exchange Server ne prend pas en charge les PAE. Les PAE permettent à Windows d'accéder à plus de 4 gigaoctets (Go) de mémoire physique. Exchange Server ne peut pas utiliser plus de 4 Go de mémoire physique et il n'est pas intéressant d'installer plus de 4 Go de RAM sur un ordinateur dédié à l'exécution d'Exchange Server. Les PAE sont activées lorsque le commutateur de démarrage /PAE est présent dans le fichier Boot.ini au démarrage.

Pour corriger cet avertissement dans Windows 2000 uniquement, il est recommandé de supprimer le commutateur /PAE du fichier Boot.ini.

Pour supprimer cet avertissement

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système. Cette partition contient les fichiers spécifiques de matériel, tels que Boot.ini et NTLDR.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur, cliquez sur Outils, Options des dossiers, puis sur Affichage. Cliquez sur Afficher les fichiers et dossiers cachés. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Lorsque vous y êtes invité, cliquez sur Oui.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier, puis cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez le commutateur /PAE.

  5. Enregistrez le fichier et fermez-le, puis redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur le commutateur /PAE dans le fichier Boot.ini, voir les articles suivants de la Base de connaissances Microsoft :

  • 268363 sur les extensions d'adresse physique dans Windows 2000

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882 sur l'utilisation de la mémoire Exchange et le commutateur /3GB

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Ce serveur Exchange fonctionne avec des extensions d'adresse physique (PAE) activées
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-05-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer les valeurs des clés suivantes :

  • PAEEnabled La valeur de cette clé indique si les extensions d'adresse physique (PAE) sont activées. Une valeur True indique que les PAE sont activées et une valeur False que les PAE ne sont pas activées.

  • Version La valeur de cette clé indique la version du système d'exploitation Microsoft Windows utilisée sur l'ordinateur. Une valeur de 5.0.2195 indique qu'un système d'exploitation Microsoft Windows 2000 Server est en cours d'exécution et une valeur de 5.2.3790 indique qu'un système d'exploitation Microsoft Windows Server™ 2003 est en cours d'exécution.

  • ServicePackMajorVersion La valeur de cette clé indique le numéro de version majeur du Service Pack de Windows installé.

Exchange Server Analyzer interroge également la classe WMI (Windows Management Instrumentation) CIM_Datafile pour connaître la version mineure de ntoskrnl.exe exécutée sur le système pour déterminer si la mise à jour de sécurité MS04-032 est installée sur l'ordinateur. Si la version mineure de ntoskrnl.exe est égale ou inférieure à 174, cela indique que la mise à jour MS04-032 n'est pas installée. Si la version mineure de ntoskrnl.exe est supérieure à 174, la mise à jour MS04-032 est installée.

Si Exchange Server Analyzer détecte que la valeur PAEEnabled est définie sur True pour un serveur Exchange sous Windows Server 2003 sans que la mise à jour de sécurité MS04-032 ne soit installée, une erreur s'affiche. Cette erreur indique que l'ordinateur est sensible à un problème connu pouvant engendrer le blocage du service de banque d'informations de Microsoft Exchange (Store.exe).

Exchange Server n'utilise pas de PAE. Les PAE permettent à Windows d'accéder à plus de 4 gigaoctets (Go) de mémoire physique. Exchange Server ne peut pas utiliser plus de 4 Go de mémoire physique et il n'est pas intéressant d'installer plus de 4 Go de RAM sur un ordinateur dédié à l'exécution d'Exchange Server. Les PAE sont activées lorsque le commutateur de démarrage /PAE est présent dans le fichier Boot.ini au démarrage ou lorsque le système d'exploitation Windows Server 2003 détecte des périphériques d'ajout de mémoire à chaud. Windows Server 2003 Édition Entreprise et Windows Server 2003 Édition Datacenter n'activent automatiquement les PAE que si le serveur utilise des périphériques d'ajout de mémoire à chaud.

Pour corriger cette erreur en installant la mise à jour MS04-032

  1. Pour obtenir la mise à jour MS04-032, voir l'article 840987 de la Base de connaissances Microsoft sur la mise à jour de sécurité MS04-032 pour Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=840987).

  2. Effectuez une sauvegarde complète du système.

  3. Appliquez la mise à jour, puis redémarrez l'ordinateur pour que la mise à jour soit prise en compte.

Pour plus d'informations sur les PAE, voir les articles suivants de la Base de connaissances :

  • 268363: sur les extensions d'adresse physique dans Windows 2000

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: sur l'utilisation de la mémoire Exchange et le commutateur /3GB

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)

Pour plus d'informations sur le commutateur /NOPAE dans le fichier Boot.ini, voir l'article de MSDN sur /nopae (http://go.microsoft.com/fwlink/?LinkId=51490).


Ce serveur Exchange fonctionne avec des extensions d'adresse physique (PAE) activées et le commutateur de démarrage /3GB
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé PAEEnabled. La valeur de cette clé indique si les extensions d'adresse physique (PAE) sont activées. La valeur True indique que les PAE sont activées et la valeur False que les PAE ne sont pas activées. Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé MaxProcessMemorySize.

Si Exchange Server Analyzer détecte que la valeur de PAEEnabled est égale à True et que celle de MaxProcessMemorySize est supérieure à 2 097 024, un avertissement s'affiche. Cet avertissement indique que ces valeurs ne sont pas celles par défaut. Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les PAE, voir les articles suivants de la Base de connaissances Microsoft :

  • 268363: sur les extensions d'adresse physique dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882: sur l'utilisation de la mémoire Exchange et le commutateur /3GB (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Ce serveur Exchange exécute les commutateurs de démarrage /PAE et /3GB
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer les options définies dans la clé SystemStartupOptions. Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé MaxProcessMemorySize.

Si Exchange Server Analyzer détecte que la valeur de la clé SystemStartupOptions comprend /PAE, que la valeur Win32_OperatingSystem indique Microsoft Windows 2000 Server et que la valeur de MaxProcessMemorySize est supérieure à 2 097 024, une erreur s'affiche.

Cette erreur indique que les commutateurs de démarrage /PAE et /3GB ont tous deux été définis dans le fichier Boot.ini. Les PAE (extensions d'adresse physique) permettent à un ordinateur d'accéder à plus de 4 Go de mémoire physique (RAM). Exchange Server ne prend pas en charge les PAE. Exchange Server ne peut pas utiliser plus de 4 Go de mémoire physique et il n'est pas intéressant d'installer plus de 4 Go de RAM sur un ordinateur dédié à l'exécution d'Exchange Server. Les PAE sont activées lorsque le commutateur de démarrage /PAE est présent dans le fichier Boot.ini au démarrage.

Pour corriger cette erreur dans Windows 2000 Server uniquement, il est recommandé de supprimer le commutateur /PAE du fichier Boot.ini.

Pour corriger cette erreur

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système. Cette partition contient les fichiers spécifiques de matériel, tels que Boot.ini et NTLDR.

  2. Si le fichier Boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Si tel est le cas, dans la fenêtre de l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur Affichage. Cliquez sur Afficher les fichiers et dossiers cachés. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Lorsque vous y êtes invité, cliquez sur Oui.

  3. Lorsque le fichier Boot.ini est visible dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier, puis cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], supprimez le commutateur /PAE.

  5. Enregistrez le fichier et fermez-le, puis redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur le commutateur /PAE dans le fichier Boot.ini, voir les articles suivants de la Base de connaissances Microsoft :

  • 268363 sur les extensions d'adresse physique dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363)

  • 328882 sur l'utilisation de la mémoire Exchange et le commutateur /3GB(http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882)


Ce serveur frontal est configuré à l'aide du service de mise à jour de destinataire
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchAddressListServiceLink pour chaque objet Recipient Update Service du répertoire. L'attribut msExchAddressListServiceLink est un lien du service de listes d'adresses vers un ordinateur Exchange Server qui exécute le Service de mise à jour de destinataire. Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • L'ordinateur Exchange Server est configuré en tant que serveur frontal.

  • L'ordinateur Exchange Server exécute le Service de mise à jour de destinataire.

Le Service de mise à jour de destinataire est un composant du service Surveillance du système Exchange. Le Service de mise à jour de destinataire crée et gère les valeurs des attributs spécifiques à Exchange dans Active Directory. Si vous créez une boîte aux lettres pour un utilisateur, le Service de mise à jour de destinataire se charge de la génération automatique de l'adresse SMTP (Simple Mail Transfer Protocol) et de toutes les autres adresses proxy que vous avez définies dans vos stratégies de destinataire.

Si un ordinateur Exchange configuré pour une utilisation avec le Service de mise à jour de destinataire est également configuré comme un serveur frontal, les objets utilisateur récemment créés ne sont pas traités par le Service de mise à jour de destinataire. Par conséquent, les objets utilisateur peuvent ne pas recevoir d'adresse de courrier électronique et les destinataires ne sont pas affichés dans la liste des adresses). Les mises à jour du carnet d'adresses en mode hors connexion ne sont également pas traitées.

Si vous recevez ce message, le Service de mise à jour de destinataire est exécuté sur un ordinateur Exchange Server configuré comme un serveur frontal.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Services de mise à jour de destinataire. Dans le volet droit, cliquez avec le bouton droit sur l'instance appropriée du service de mise à jour de destinataire, puis cliquez sur Propriétés.

  3. Sous Exchange Server, sous l'onglet Général, cliquez sur Parcourir et spécifiez un nouveau serveur exécutant cette instance du Service de mise à jour de destinataire.

  4. Cliquez sur OK, puis cliquez de nouveau sur OK pour que la modification soit prise en compte.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les rubriques et les articles suivants de la Base de connaissances Microsoft :

  • 328738 sur la manière dont le Service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253828 sur la manière dont le Service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828)

  • 246127 sur la procédure de vérification des progrès du Service de mise à jour de destinataire Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

  • 253770 sur les tâches effectuées par le Service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Il existe une incohérence avec le nom du serveur Exchange entre le Registre et Active Directory
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur stockée dans Active Directory pour le nom du serveur Exchange (CN=<Nom_serveur_Exchange>). Après avoir récupéré ce nom, Exchange Server Analyzer en compte le nombre de caractères.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer la valeur stockée dans le Registre de l'ordinateur Exchange Server pour le nom d'hôte du serveur Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

En outre, Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service de cluster ClusSvc.

Si Exchange Server Analyzer détermine que les critères suivants sont tous vrais, une erreur s'affiche :

  • La valeur de CN=<Nom_serveur_Exchange> ne correspond pas à la valeur de Hostname.

  • Le nom du serveur Exchange comprend au plus 15 caractères.

  • Le serveur Exchange n'est pas utilisé dans un cluster Windows.

La cause la plus courante de cette erreur est la modification du nom du serveur Exchange. Une telle modification du nom modifie le nom dans le Registre de l'ordinateur ainsi que celui du compte d'ordinateur dans Active Directory, mais pas les nombreuses références au nom du serveur Exchange trouvées dans les attributs Exchange et les objets Active Directory.

Remarque :
Certains logiciels tiers modifient également le nom d'ordinateur pour offrir une fonctionnalité de cluster. Si vous utilisez ce type de logiciel, vous pouvez ignorer ce problème.

La modification du nom d'un ordinateur Exchange Server n'est pas prise en charge et est réputée pour créer des problèmes, tels que l'échec du démarrage du service Surveillance du système Microsoft Exchange après la modification du nom d'ordinateur. Si l'ordinateur Exchange Server renommé ne semble pas fonctionner correctement à tous points de vue, vous pouvez supprimer manuellement Exchange Server de l'ordinateur à l'aide du processus de suppression manuelle décrit dans cet article. Si l'ordinateur Exchange Server renommé ne semble pas fonctionner correctement à tous points de vue, vous devez reconstruire le serveur Exchange à l'aide de la procédure de reconstruction ci-dessous car cette configuration n'est pas prise en charge et risque de créer des problèmes à l'avenir.

Pour corriger cette erreur en supprimant manuellement Exchange Server

  1. Arrêtez tous les services Exchange Server et effectuez une sauvegarde complète de l'ordinateur.

  2. Selon la version d'Exchange Server que vous exécutez, voir les articles suivants de la Base de connaissances Microsoft :

    • Si vous exécutez Exchange Server 2007, suivez la procédure décrite dans la documentation sur Exchange Server 2007, intitulée « Procédure de suppression totale d'Exchange 2007 d'un serveur » (http://go.microsoft.com/fwlink/?LinkId=79246).

    • Si vous utilisez Exchange Server 2003, suivez la procédure décrite dans l'article 833396 de la Base de connaissances sur la procédure de suppression d'Exchange Server 2003 de votre ordinateur (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396).

    • Si vous utilisez Exchange 2000 Server, suivez la procédure décrite dans l'article 260378 de la Base de connaissances sur la procédure de suppression manuelle d'une installation Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378).

  3. Si vous exécutez Exchange 2000 Server ou Exchange Server 2003 et qu'il s'agit du seul serveur Exchange de votre organisation, suivez la procédure décrite dans l'article 273478 de la Base de connaissances Microsoft, « Comment faire pour supprimer complètement Exchange 2000 ou Exchange 2003 dans Active Directory » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273478).

Pour corriger cette erreur en reconstruisant l'ordinateur Exchange Server

  1. Déplacez les boîtes aux lettres, les dossiers publics, les connecteurs et les rôles vers un autre ordinateur Exchange Server de l'organisation.

  2. Désinstallez Exchange Server de l'ordinateur.

  3. Pour nettoyer le registre d'un ordinateur exécutant Exchange Server 2003 ou Exchange Server 2000, suivez les instructions des sections de nettoyage du registre des procédures décrites dans les articles suivants de la Base de connaissances Microsoft :

    • 833396 sur la procédure de suppression d'Exchange Server 2003 de votre ordinateur (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396)

    • 260378 sur la procédure de suppression manuelle d'une installation Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378)

    Vous pouvez également reconstruire le système d'exploitation.

  4. Installez Exchange Server sur l'ordinateur.

  5. Déplacez les boîtes aux lettres, les dossiers publics, les connecteurs et les rôles vers l'ordinateur Exchange Server que vous venez de reconstruire.

Pour plus d'informations sur la procédure de déploiement d'Exchange Server 2003 sur des clusters, voir l'article 810986 de la Base de connaissances Microsoft sur la stratégie de prise en charge de Microsoft pour des installations Exchange Server exécutant un service de cluster tiers (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986).


Il existe une incohérence avec le nom du serveur Exchange dans Active Directory
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut Name correspond avec l'attribut cn d'un serveur (objet de classe msExchExchangeServer). Si Exchange Server Analyzer détecte que ces attributs diffèrent, un message d'erreur s'affiche.

Exchange utilise la valeur cn de l'objet serveur pour identifier le serveur en interne. Il utilise la valeur Name pour identifier le serveur dans l'interface utilisateur du Gestionnaire système Microsoft Exchange.

Cette erreur peut survenir si un administrateur a modifié la valeur Name à l'aide d'un outil tel qu'ADSI Edit ou LDP (ldp.exe). Tandis que cette action modifie le nom du serveur dans l'interface utilisateur, elle crée une incohérence qui génère des événements de banque et du service Surveillance du système. Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI Edit, l'outil LDP ou tout autre client LDAP version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. À l'aide d'ADSI Edit ou d'un outil similaire, localisez l'objet serveur dans Active Directory.

    Les attributs CN et Name peuvent être trouvés à l'emplacement suivant :

    Copier le code
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. Pour l'attribut Name, tapez une nouvelle valeur de chaîne qui correspond à la valeur de l'attribut CN.

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server.


Il existe plusieurs réseaux entre le serveur Active Directory et ce serveur Exchange
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft WIN32_PingStatus de l'espace de noms root\cimv2 pour déterminer la valeur de la clé RouteRecord. La clé RouteRecord contient un enregistrement de sauts intermédiaires (par exemple le nombre de routeurs) entre le serveur Exchange et les contrôleurs de domaine. Exchange Server Analyzer compte le nombre de routeurs répertoriés dans la clé RouteRecord. Si Exchange Server Analyzer détecte que plusieurs routeurs sont répertoriés, une erreur s'affiche.

Un service d'annuaire optimal Active Directory ® est conçu pour garantir que l'ordinateur Exchange Server peut communiquer sur son sous-réseau avec un contrôleur de domaine ou un serveur de catalogue global. Cette erreur indique que l'ordinateur Exchange Server communique avec des contrôleurs de domaine sur des réseaux éloignés de plus d'un saut.

Pour corriger cette erreur

  1. Vérifiez votre topologie de réseau et réévaluez l'emplacement des serveurs Active Directory.

  2. Contrôlez les journaux d'événements sur le serveur Exchange et le contrôleur de domaine pour voir si les événements liés au réseau qui indiquent les éventuels problèmes ont été consignés.

  3. Examinez la conception du site Active Directory. Si votre réseau n'est pas partitionné selon cette spécification, envisagez de le partitionner en plusieurs sites Active Directory.

Pour plus de détails sur la classe WMI Win32_PingStatus, voir l'article sur la classe Win32_PingStatus (http://go.microsoft.com/fwlink/?linkid=33549).

Pour plus d'informations sur la conception du site d'Active Directory, voir le document sur la conception de la topologie de site (http://go.microsoft.com/fwlink/?linkid=33551).


Trop de sauts
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-07-06

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété MessageID pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour chaque serveur vers lequel se dirige le message.

Un message peut être routé via de nombreux serveurs SMTP différents avant que le message n'atteigne sa destination finale. Chaque serveur se trouvant sur cette route consitute un saut.

Si le nombre d'instances de Exchange_MessageTrackingEntry pour le MessageID spécifique monte à 30, Exchange Server Analyzer affiche une erreur.

Cette erreur indique que le message de test est peut-être entré dans une boucle. Par conséquent, Exchange Server Analyzer a arrêté d'interroger d'autres instances de Exchange_MessageTrackingEntry par mesure de précaution pour se prémunir contre une éventuelle boucle sans fin.

Une analyse supplémentaire de la section Journal de suivi des messages de la sortie d'Exchange Server Analyzer peut vous aider à déterminer si une boucle s'est produite.


Configuration de la machine virtuelle non prise en charge - Serveur Exchange en clusters détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur « Virtual Machine ».

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster Windows (ClusSvc). Une valeur True pour la clé Started indique que le service de cluster est démarré et une valeur False qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • La valeur de la clé Model est définie sur « Virtual Machine ».

  • La valeur de la clé Started du service de cluster est définie sur True.

Cette erreur indique que le serveur Exchange est un serveur Exchange en clusters exécuté dans un environnement de machine virtuelle. Cette configuration n'est pas prise en charge.

Pour corriger cette erreur

  1. Créez un cluster physique et déplacez les boîtes aux lettres vers ce cluster physique à partir du serveur Exchange en clusters exécuté dans l'environnement virtuel.

  2. Si vous ne pouvez pas créer de cluster physique, vous pouvez corriger cette erreur comme suit :

    1. Déplacez les boîtes aux lettres du serveur Exchange Server exécuté dans l'environnement virtuel vers un ordinateur Exchange Server non virtuel et autonome.

    2. Réassociez tous les dossiers publics et transférez tous les rôles effectués par le serveur Exchange en clusters.

    3. Désinstallez Exchange Server de la machine virtuelle pour le désactiver et le supprimer de l'infrastructure Exchange Server et d'Active Directory.

Pour plus d'informations sur la stratégie de prise en charge de Microsoft pour l'exécution d'Exchange Server 2003 dans des environnements virtuels, voir l'article 320220 de la Base de connaissances Microsoft sur la stratégie de prise en charge pour Exchange Server 2003 exécuté sur un logiciel de virtualisation de matériel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Configuration de la machine virtuelle non prise en charge - Exchange Server 2003 Service Pack 2 ou ultérieur non détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur « Virtual Machine ».

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5,5 », l'ordinateur exécute Exchange Server 5,5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Exchange Server 2003. Si la valeur de chaîne contient « Version 6.5 » et « Service Pack 2 », l'ordinateur exécute Exchange Server 2003 avec Service Pack 2 (SP2).

Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • La clé Model est définie sur « Virtual Machine ».

  • L'ordinateur n'exécute pas Exchange Server 2003 avec SP2 ou version ultérieure.

Cette erreur indique que le serveur Exchange est une machine virtuelle mais qu'Exchange Server 2003 SP2 ou version ultérieure n'est pas installé. Cette configuration n'est pas prise en charge.

Pour corriger cette erreur

  1. Installez le Service Pack 2 ou version ultérieure pour Exchange Server 2003.

  2. Voir l'article 320220 de la Base de connaissances Microsoft sur la stratégie de prise en charge pour Exchange Server 2003 exécuté sur un logiciel de virtualisation de matériel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

  3. Si vous ne parvenez pas à appliquer le Service Pack 2 ou version ultérieure, vous pouvez corriger cette erreur comme suit :

    1. Déplacez les boîtes aux lettres du serveur Exchange sous Virtual Server 2005 vers un ordinateur Exchange Server non virtuel.

    2. Réassociez tous les dossiers publics et transférez tous les rôles effectués par le serveur Exchange virtuel.

    3. Désinstallez Exchange Server de la machine virtuelle pour le désactiver et le supprimer de l'infrastructure Exchange Server et d'Active Directory.


Configuration de la machine virtuelle non prise en charge - Ajouts de machines virtuelles non détectés
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur « Virtual Machine ».

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si des ajouts de machines virtuelles ont été installés :

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

La présence de ce chemin d'accès au répertoire indique que des ajouts de machines virtuelles ont été installés. Si le chemin d'accès au répertoire n'est pas présent, cela indique que les ajouts de machines virtuelles n'ont pas été installés.

Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • La valeur de la clé Model est définie sur « Virtual Machine ».

  • Le chemin d'accès au répertoire n'est pas présent.

Cette erreur indique que le serveur Exchange est une machine virtuelle mais que les ajouts de machines virtuelles ne sont pas installés. Cette configuration n'est pas prise en charge.

Pour installer des ajouts de machines virtuelles

  1. Sauvegardez le serveur Exchange Server exécuté dans l'environnement virtuel.

  2. Installez les ajouts de machines virtuelles à l'aide de la console d'administration ou du site Web Virtual Server 2005.

Pour plus d'informations sur la procédure d'exécution d'Exchange Server 2003 dans un environnement virtuel, voir l'article 320220 de la Base de connaissances Microsoft sur la stratégie de prise en charge pour Exchange Server 2003 exécuté sur un logiciel de virtualisation de matériel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Mise à jour disponible pour l'heure d'été
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-07-30

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut versionNumber pour chaque objet Exchange Server. L'attribut versionNumber représente la version d'Exchange Server exécutée sur l'ordinateur.

Exchange Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le processus Store.exe.

  • La valeur 7638 pou la clé Version indique Exchange Server 2003 Service Pack 2.

  • La valeur 7226 pou la clé Version indique Exchange Server 2003 Service Pack 1.

  • La valeur 6944 pour la clé Version indique la version originale d'Exchange Server 2003.

  • Une valeur comprise entre les versions ci-dessus indique que le serveur exécute une version de mise à jour du correctif du processus Store.exe.

Si Exchange Analyzer détermine que la clé Version pour Store.exe sur un serveur exécutant Exchange Server 2003 SP2 possède une valeur inférieure à 7561 ou un serveur exécutant Exchange Server 2003 SP1 possède une valeur inférieure à 7234, un avertissement s'affiche.

Cet avertissement indique que l'ordinateur Exchange Server exécute Exchange Server 2003 Service Pack 1 ou Exchange Server 2003 SP2 sans la mise à jour des changements d'heure d'été en 2007.

Sans cette mise à jour, les éléments de calendrier des programmes CDO et d'Outlook Web Access fonctionnent comme si l'heure standard était appliquée pendant les semaines supplémentaires de l'heure d'été.

Pour corriger cet avertissement dans Exchange Server 2003 SP2

  1. Suivez les instructions de l'article 926666 de la Base de connaissances Microsoft sur la mise à jour des changements de l'heure d'été en 2007 dans Exchange 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666).
Pour corriger cet avertissement dans Exchange Server 2003 SP1

  1. Suivez les instructions de l'article 931978 de la Base de connaissances Microsoft sur la mise à jour des changements de l'heure d'été en 2007 dans Exchange 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978).


Correctif cumulatif pour Windows 2000 SP4 non installé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft pour déterminer la valeur de la clé ServicePackMajorVersion. Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows exécutée sur l'ordinateur de destination :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si Exchange Server Analyzer détermine que le système cible utilise un système d'exploitation Windows 2000 Server sans exécuter le correctif cumulatif pour Windows 2000 Server Service Pack 4, un avertissement s'affiche.

Il est recommandé d'installer les derniers Service Packs et correctifs pour tous les logiciels de votre déploiement Exchange.

Pour supprimer cet avertissement

  1. Mettez à jour tous les contrôleurs de domaine et serveurs de catalogue global qui utilisent Windows 2000 Server vers le correctif cumultatif du Service Pack 4, ainsi que les derniers correctifs et mises à jour de Windows Update.

  2. Mettez à jour tous les ordinateurs Exchange Server vers le dernier correctif et correctif cumulatif.

Pour plus d'informations sur le correctif cumulatif pour Windows 2000 SP4, voir l'article 891861 de la Base de connaissances Microsoft sur le correctif cumulatif 1 pour Windows 2000 SP4 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=891861).

Pour plus d'informations sur l'obtention et l'installation des Service Packs et correctifs d'Exchange Server, voir le site Web d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).


URLScan installé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer si le fichier ci-dessous existe à l'emplacement suivant sur le serveur Exchange :

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

La présence de Urlscan.dll indique que l'outil URLScan est installé sur le serveur Exchange. Si Exchange Server Analyzer détecte que l'outil URLScan est installé sur un serveur Exchange, un message de recommandation s'affiche.

URLScan est un filtre ISAPI (Internet Server Application Programming Interface) qui permet aux administrateurs de sites Web de limiter le type de demandes HTTP traitées par le serveur. En bloquant certaines demandes HTTP, le filtre URLScan empêche les demandes potentiellement dangereuses d'atteindre le serveur et de nuire.

Lorsque vous exécutez URLScan sur un serveur Exchange, assurez-vous que Urlscan.ini est réglé pour un rôle de serveur Exchange. Pour aider à améliorer la sécurité du serveur Exchange, modifiez le fichier de configuration Urlscan.ini pour supprimer toute fonctionnalité superflue. Pour personnaliser le fichier Urlscan.ini en fonction du rôle particulier de votre ordinateur Exchange Server 2003, supprimez des verbes dans la section [AllowVerbs] du fichier Urlscan.ini. Vérifiez toutefois que les verbes recommandés pour le rôle de votre ordinateur sont inclus pour garantir la fonctionnalité appropriée. Si plusieurs fonctionnalités Web sont requises sur un même ordinateur, vous devez fusionner les exigences appropriées de la section [AllowVerbs].

Vous pouvez modifier le fichier Urlscan.ini sur la base du rôle de l'ordinateur Exchange Server 2003 en utilisant les informations du modèle Exchange Server 2003 Urlscan inclus dans l'article 823175 de la Base de connaissances Microsoft sur l'optimisation et les problèmes connus lors de l'utilisation de l'utilitaire Urlscan dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175).

Pour plus d'informations sur URLScan, voir l'outil de sécurité UrlScan (http://go.microsoft.com/fwlink/?LinkId=24490).

Pour plus d'informations sur l'utilisation d'URLScan dans un environnement Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 309677 sur les problèmes connus et la mise au point lors de l'utilisation de l'Assistant IIS Lockdown dans un environnement Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677)

  • 309508 sur les configurations des outils IIS Lockdown et URLscan dans un environnement Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508)

  • 325965 sur les problèmes dans Outlook Web Access pouvant provenir de l'outil URLScan (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965)

  • 326444 sur la procédure de configuration de l'outil URLScan (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444)


Le commutateur USERVA n'est pas défini correctement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-09-19

L'outil Microsoft® Exchange Server Analyzer Tool interroge trois classes WMI (Windows® Management Instrumentation) Microsoft pour déterminer la quantité de mémoire physique sur l'ordinateur Exchange Server ainsi que la quantité d'espace d'adresse virtuelle allouée à des processus en mode utilisateur en cours d'exécution sur l'ordinateur Exchange Server. Le tableau ci-dessous décrit les classes et les clés évaluées par Exchange Server Analyzer.

Classe demandée | Clés demandées | Description
Win32_OperatingSystem | MaxProcessMemorySize | Nombre maximal de kilo-octets de mémoire pouvant être alloués à un processus.
Win32_ComputerSystem | TotalPhysicalMemory | Nombre d'octets de mémoire vive (RAM) installés sur l'ordinateur.
Win32_Service | Started | État du service. La valeur True indique que le service est en cours d'exécution et la valeur False indique qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer Tool lit également l'entrée de Registre suivante pour déterminer la version de Microsoft Windows exécutée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur Exchange Server est exécuté sur Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que l'ordinateur Exchange Server exécute Windows 2000 Server et la valeur 5.2, qu'il exécute Windows Server™ 2003.

Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'attributs homeMDBBL de l'objet de banque de boîte aux lettres (msExchPrivateMDB). Le résultat est le nombre de boîtes aux lettres identifiées sur l'ordinateur Exchange Server.

Si Exchange Server Analyzer détermine que tous les critères suivants sont vrais, un avertissement s'affiche :

  • L'ordinateur Exchange Server est exécuté sur Windows Server 2003.

  • La valeur de TotalPhysicalMemory est supérieure à 1073741824.

  • La valeur de MaxProcessMemorySize est égale à 3145600.

  • Le service de cluster (ClusSvc) dispose d'une valeur Win32_Service\Started de True ou l'ordinateur Exchange Server contient plus de 20 boîtes aux lettres.

Cet avertissement indique que l'ordinateur Exchange Server n'est pas configuré de manière optimale pour une utilisation de la mémoire virtuelle. Plus spécifiquement, le commutateur de démarrage /USERVA=3030 ne figure pas dans le fichier Boot.ini de l'ordinateur Exchange Server. L'ajout de ce commutateur peut fournir une évolutivité supérieure et des performances optimales.

Windows Server 2003 inclut la prise en charge de deux commutateurs de démarrage du fichier boot.ini, /3GB et /USERVA, qui permettent de régler l'allocation et l'utilisation de la mémoire et de l'espace d'adressage mémoire. Quelle que soit la quantité de mémoire physique de votre système, Windows utilise un espace d'adresse virtuelle de 4 gigaoctets (Go), dont 2 Go sont alloués aux processus en mode utilisateur (applications, par exemple) et 2 Go aux processus en mode noyau (système d'exploitation et pilotes en mode noyau, par exemple). Sur les systèmes disposant d'au moins 1 Go de mémoire physique, ces deux commutateurs de démarrage peuvent être utilisés pour allouer davantage de mémoire aux applications (3 Go) et moins au système d'exploitation (1 Go). Sur un ordinateur Exchange Server, cet espace d'adresse virtuelle supplémentaire permet de réduire la fragmentation de mémoire dans l'espace d'adresse virtuelle du processus de banque d'informations. Le commutateur /3GB est utilisé pour effectuer ce changement d'allocation. Le commutateur est entré dans le fichier Boot.ini du système et prend effet après un redémarrage. Ce commutateur ne doit être utilisé que sur les serveurs Exchange dotés d'une mémoire d'au moins 1 Go, fonctionnant avec les systèmes d'exploitation suivants :

  • Microsoft Windows Server 2003 Édition Standard

  • Microsoft Windows Server 2003 Édition Entreprise

  • Microsoft Windows Server 2003 Édition Datacenter

Important :
Le commutateur /3GB ne doit pas être utilisé sous Windows 2000 Server car il n'est pas pris en charge et peut entraîner une panne de l'application ou du système d'exploitation. De plus, le commutateur /3GB n'est pris en charge que par les systèmes d'exploitation ci-dessus lorsque 1 Go minimum de mémoire physique est installé. De plus, le commutateur /3GB ne doit pas être utilisé sur des serveurs Active Directory (contrôleurs de domaine et serveurs de catalogue global) exécutés sur Windows Server 2003 Édition Standard.

Nouveau dans Windows Server 2003, le commutateur /USERVA est destiné à améliorer le contrôle de la division de l'espace d'adresse virtuelle entre les processus en mode utilisateur et ceux en mode noyau. Il ne doit être utilisé que pour des applications qui le prennent en charge, telles qu'Exchange Server 2003, et avec les valeurs spécifiques que celles-ci prennent en charge. Utilisé sur le système Exchange Server 2003, /USERVA doit toujours être égal à 3030 (c.-à-d., /USERVA=3030). Cette valeur octroie 40 Mo supplémentaires au système d'exploitation et permet d'ajouter davantage d'utilisateurs sans utiliser toutes les ressources système disponibles.

Pour supprimer cet avertissement dans Windows Server 2003

  1. Cliquez avec le bouton droit sur Poste de travail et sélectionnez Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur l'onglet Avancé.

  3. Dans la zone Démarrage et récupération, cliquez sur Paramètres. La boîte de dialogue Démarrage et récupération s'affiche.

  4. Dans la zone Démarrage du système, cliquez sur Modifier. Cela permet d'ouvrir le fichier Windows Boot.ini dans le Bloc-notes.

  5. Dans la section [Systèmes d'exploitation], ajoutez les commutateurs suivants à la ligne de démarrage : /3GB /USERVA=3030

  6. Enregistrez les modifications et fermez le Bloc-notes.

  7. Cliquez deux fois sur OK pour fermer les boîtes de dialogue ouvertes, puis redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation des commutateurs de démarrage /3GB et /USERVA, voir les articles suivants de la Base de connaissances Microsoft :

  • 297812 sur l'utilisation de la fonctionnalité de réglage de RAM 4GT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812).

  • 311901 sur les effets du réglage 4GT sur les PTE système (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901).

  • 316739 sur l'utilisation du commutateur /userva et /3GB pour le réglage de l'espace en mode utilisateur sur une valeur comprise entre 2 et 3 Go (http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739).

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372).


La version du fichier Tcpip.sys installée sur cet ordinateur peut nécessiter l'utilisation d'un correctif
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version du fichier Tcpip.sys. Si Exchange Server Analyzer détecte que la valeur de la clé Version correspond à une version spécifique du fichier Tcpip.sys, il affiche un avertissement.

Pour plus d'informations sur cet avertissement, suivez les recommandations de l'article 898060 de la Base de connaissances Microsoft sur l'installation de la mise à niveau de sécurité MS05-019 ou Windows Server 2003 Service Pack 1 qui peut entraîner l'échec de la connectivité réseau entre des clients et des serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060).


Configuration de machine virtuelle détectée
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur « Virtual Machine ».

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour ClusSvc, le service de cluster Windows. La valeur True de la clé Started indique que le service de cluster est démarré. La valeur False indique que le service de cluster n'est pas démarré.

Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 6.5 » et « Service Pack 2 », l'ordinateur exécute Exchange Server 2003 avec Service Pack 2 (SP2).

Enfin, Exchange Server Analyzer lit l'entrée de Registre suivante pour déterminer si les ajouts de machines virtuelles ont été installés :

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

La présence de ce chemin d'accès au répertoire indique que des ajouts de machines virtuelles ont été installés. L'absence de ce chemin d'accès au répertoire indique qu'aucun ajout de machines virtuelles n'a été installé.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • Le serveur Exchange est exécuté en tant qu'un invité dans Microsoft Virtual Server 2005.

  • Le serveur Exchange exécute Exchange Server 2003 avec Service Pack 2 ou version ultérieure.

  • Le serveur Exchange n'est pas en clusters.

  • Les ajouts de machines virtuelles pour Virtual Server 2005 ont été installés sur le serveur Exchange.

Il existe certaines exigences pour l'exécution dans cette configuration qu'Exchange Server Analyzer ne peut pas détecter. Par conséquent, nous recommandons de revoir l'article suivant pour obtenir les dernières informations sur la possibilité de prise en charge et le réglage des performances pour cette configuration avant d'exécuter Exchange Server 2003 dans un environnement Virtual Server 2005 :

Article 320220 de la Base de connaissances Microsoft sur la stratégie de prise en charge pour Exchange Server 2003 exécuté sur un logiciel de virtualisation de matériel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Fragmentation de la mémoire virtuelle
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2007-02-15

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si une erreur Événement 9852 a été enregistrée pour MSExchangeIS au cours des dernières 24 heures.

Si Exchange Analyzer détecte qu'un événement 9852 a été enregistré au cours des dernières 24 heures, il affiche une erreur.

Cette erreur indique que la mémoire virtuelle requise pour l'exécution du serveur Exchange est fragmentée.

Dans les systèmes Microsoft Windows 32 bits, il existe deux types de mémoire :

  • Mémoire physique Quantité de mémoire réelle installée sur le système

  • Espace d'adressage mémoire virtuel Espace de mémoire de 4 Go virtualisé

Quelle que soit la quantité de mémoire physique installée sur le système, la taille totale de l'espace d'adressage virtuel est toujours identique : 4 Go. Bien que ce ne soit pas le cas pour toutes les applications 32 bits, pour Exchange Server, l'espace d'adressage virtuel équivaut à la mémoire virtuelle. Ces deux termes sont interchangeables.

Lors du déroulement normal de ses opérations, la banque d'informations d'Exchange alloue, utilise et désalloue la mémoire virtuelle à plusieurs reprises. Si la mémoire virtuelle est fréquemment allouée, utilisée et désallouée, une fragmentation de mémoire virtuelle peut se produire. La fragmentation de mémoire virtuelle est similaire à la fragmentation de système de fichiers, qui peut se produire de temps à autre. Après un moment, les segments alloués de mémoire virtuelle ne sont plus contigus et les performances s'en ressentent. Pour le système de fichiers, vous pouvez exécuter une application qui procède à la défragmentation du fichier. Généralement, il est possible de procéder à la défragmentation du système de fichiers lorsque le système est en ligne et qu'un utilisateur y accède. Il n'existe aucun outil de défragmentation pour fragmenter la mémoire virtuelle. Pour remédier à ce problème, vous devez arrêter et redémarrer le service Banque d'informations de Microsoft Exchange ou redémarrer le système.

Pour résoudre ce problème :

  • La fragmentation de la mémoire virtuelle peut être causée par un logiciel tiers qui s'exécute dans des processus store/inetinfo. Assurez-vous d'avoir les derniers pilotes des applications tierces.

  • Utilisez l'outil Journaux et alertes de performance pour analyser le compteur Total en octets de blocs de mémoire virtuelle de grande taille disponibles pour l'objet de performance MSExchangeIS. Utilisez les données collectées à partir de ce compteur pour identifier la meilleure fenêtre, au cours des prochaines 36 à 72 heures, pour arrêter puis redémarrer le serveur.

Remarque :
S'il s'agit d'un serveur en cluster, arrêtez et redémarrez le noeud passif avant de déplacer les ressources de cluster vers ce noeud afin de vérifier que l'espace d'adressage mémoire virtuel cible est correct.
  • Si le problème se reproduit après le redémarrage, envisagez la désactivation du logiciel tiers.

  • Envisagez le déplacement des boîtes aux lettres utilisateur vers un autre serveur pour réduire la charge du serveur et vérifier si le problème disparaît. Pour plus d'informations, consultez la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

Pour plus d'informations

  • Pour plus d'informations sur l'événement 9852 de MSExchangeIS, consultez la page du centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=83209).

  • Pour plus d'informations sur les performances d'Exchange Server, consultez le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, consultez la rubrique sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur le dépannage de la fragmentation de mémoire virtuelle dans Microsoft Exchange Server 2003 et Exchange 2000 Server, consultez l'article 325044 de la Base de connaissances Microsoft « Quelle procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).

  • Pour plus d'informations sur la procédure d'optimisation de l'utilisation de la mémoire virtuelle, consultez l'article 815372 de la Base de connaissances Microsoft sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

  • Pour plus d'informations sur la procédure de déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, consultez la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


Virtual Server 2005 R2 ou ultérieur non détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version du processus Vssrvc.exe, représenté par le service Virtual Server fourni avec Microsoft Virtual Server 2005. Si Exchange Server Analyzer détecte que la valeur de la clé Version de Vssrvc.exe est égale à 1.1.465.0, il affiche une erreur.

Cette erreur indique que ce serveur Exchange est exécuté en tant qu'invité dans un environnement Microsoft Virtual Server 2005 qui n'exécute pas Virtual Server 2005 R2 ou ultérieur. Cette configuration n'est pas prise en charge. Exchange Server 2003 avec Service Pack 2 ou ultérieur est uniquement pris en charge en tant qu'invité dans un environnement virtuel lorsqu'il est exécuté dans Microsoft Virtual Server 2005 R2 ou ultérieur.

Pour corriger cette erreur

  1. Voir l'article 320220 de la Base de connaissances Microsoft sur la stratégie de prise en charge pour Exchange Server 2003 exécuté sur un logiciel de virtualisation de matériel (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

  2. Installez Microsoft Virtual Server 2005 R2 ou ultérieur. Pour plus d'informations sur Microsoft Virtual Server 2005 R2, voir le site Web de Microsoft Virtual Server 2005 R2 (http://go.microsoft.com/fwlink/?LinkId=34938).

  3. Si vous ne parvenez pas à installer Virtual Server 2005 R2 ou ultérieur, vous pouvez corriger cette erreur comme suit :

    1. Déplacez les boîtes aux lettres du serveur Exchange Server exécuté sous Virtual Server 2005 vers un ordinateur Exchange Server non virtuel ou vers un ordinateur Exchange Server virtuel exécuté sous Virtual Server 2005 R2.

    2. Réassociez tous les dossiers publics et transférez tous les rôles tenus par le serveur virtuel Exchange non pris en charge.

    3. Désinstallez Exchange Server de la machine virtuelle non prise en charge pour le désactiver et le supprimer de l'infrastructure Exchange Server et d'Active Directory.


Longueur de la file d'attente Virus Scan au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-27

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Virus Scan Queue Length de l'objet de performance MSExchangeIS pour les analyser.

Si Exchange Server Analyzer détermine que la valeur du quatre-vingt-dixième centile pour le compteur Virus Scan Queue Length est supérieure à 10 pendant la période-exemple, il affiche une erreur.

Le compteur de performance Virus Scan Queue Length indique le nombre actuel de demandes en attente pour l'analyse antivirus.

Cette erreur peut indiquer des problèmes de performances liées à ce qui suit :

  • une diminution des performances du serveur, généralement provoquée par un goulot d'étranglement de processeur ;

  • une charge de serveur supérieure à la normale ;

  • un moteur d'analyse antivirus obsolète ;

  • une configuration incorrecte du moteur d'analyse antivirus.

Pour résoudre cette erreur, procédez comme suit :

  • recherchez les mises à jour de votre moteur d'analyse antivirus ;

  • envisagez de réinstaller le logiciel d'analyse antivirus.

  • Examinez la configuration de votre moteur d'analyse antivirus pour vérifiez que vous disposez d'une configuration correcte des threads, d'exclusions au niveau des fichiers, etc. Voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&k).

  • L'analyseur de performances (Perfmon.msc) permet de déterminer si le goulot d'étranglement est dû à une charge accrue sur le serveur ou si le serveur est sous-dimensionné. En cas d'augmentation de la charge du serveur, identifiez la source de la charge et réduisez-la. Si le serveur dispose de ressources suffisantes, augmentez les ressources nécessaires ou déplacez des utilisateurs du serveur.

Suppression des goulots d'étranglement de processeur

Il existe de nombreuses façons de supprimer les goulots d'étranglement de processeur de votre serveur Exchange.

  • Identifiez tout d'abord les applications ou tâches qui provoquent une charge sur le serveur. Déterminez si l'application doit utiliser le temps processeur réel ou s'il existe un problème avec ce processus.

  • Si une application non-Exchange n'est pas importante sur ce serveur, exécutez-la sur un autre serveur. Si vous pouvez l'exécuter sur un autre serveur, déplacez également les rôles de serveur vers d'autres ordinateurs. Par exemple, si le processus Inetinfo utilise une grande partie du processeur, envisagez l'ajout de serveurs frontaux pour prendre la responsabilité du fonctionnement du protocole assuré par Inetinfo. Vous pouvez également déplacer l'accès aux dossiers publics vers un serveur de dossiers publics dédié. Enfin, si un serveur effectue de nombreuses extensions de liste de distribution, vous pouvez réduire l'utilisation du processeur en déplaçant l'extension de la liste de distribution vers un serveur d'extension de liste de distribution dédié.

  • Si possible, ajoutez davantage de processeurs ou des processeurs plus rapides au serveur. Activez également la technologie Hyper-Threading si elle est prise en charge par les processeurs. Vous pouvez activer la technologie Hyper-Threading en configurant le BIOS système. Pour plus d'informations, voir la documentation d'aide du fabricant de l'ordinateur.

  • Si l'augmentation de la puissance de traitement s'avère impossible, vous devez diminuer la charge des processeurs. Pour réduire l'impact global sur le serveur, assurez-vous que les tâches qui nécessitent de nombreuses E/S et une grande partie du processeur ou utilisent beaucoup de mémoire soient effectuées en dehors des heures de fonctionnement habituelles.

  • Assurez-vous que les tâches qui nécessitent une grande partie du processeur (comme les tâches de sauvegarde et de maintenance) sont effectuées pendant les heures creuses. Assurez-vous également que ces tâches soient effectuées par étapes. Effectuer une tâche par étapes signifie le paramétrage de différentes heures de début et de fin pour chaque tâche. Effectuer par étapes la maintenance et la sauvegarde des bases de données ou des groupes de stockage diminue également l'effet de ces tâches nécessitant beaucoup de ressources.

Pour plus d'informations

  • Pour obtenir un aperçu d'Exchange Server et de l'analyse antivirus, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et du logiciel antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Pour plus d'informations sur l'analyse antivirus et sur Exchange Server, voir l'article 285667 de la Base de connaissances Microsoft sur la présentation de Virus Scanning API 2.0 dans Exchange 2000 Server SP1 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la procédure de déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


Longueur de la file d'attente Virus Scan au-delà du seuil d'avertissement
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Virus Scan Queue Length de l'objet de performance MSExchangeIS pour les analyser.

Si Exchange Server Analyzer détermine que la valeur du quatre-vingt-dixième centile pour le compteur Virus Scan Queue Length est supérieure à 5 pendant la période-exemple, il affiche un avertissement.

Le compteur de performance Virus Scan Queue Length indique le nombre actuel de demandes en attente pour l'analyse antivirus.

Cet avertissement indique que des problèmes de performances peuvent survenir sur ce serveur. Ces problèmes peuvent être liés à :

  • une diminution des performances du serveur, généralement provoquée par un goulot d'étranglement de processeur émergeant ;

  • une charge de serveur supérieure à la normale ;

  • un moteur d'analyse antivirus obsolète ;

  • une configuration incorrecte du moteur d'analyse antivirus.

Pour résoudre cet avertissement, procédez comme suit :

  • recherchez les mises à jour de votre moteur d'analyse antivirus ;

  • envisagez de réinstaller le logiciel d'analyse antivirus.

  • Examinez la configuration de votre moteur d'analyse antivirus pour vérifiez que vous disposez d'une configuration correcte des threads, d'exclusions au niveau des fichiers, etc. Voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • L'analyseur de performances (Perfmon.msc) permet d'identifier si le goulot d'étranglement émergeant est dû à une charge accrue sur le serveur ou si le serveur est sous-dimensionné. En cas d'augmentation de la charge du serveur, identifiez la source de la charge et réduisez-la. Si le serveur dispose de ressources suffisantes, augmentez les ressources nécessaires ou déplacez des utilisateurs du serveur.

Suppression des goulots d'étranglement de processeur

Il existe de nombreuses façons de réagir face aux goulots d'étranglement sur votre serveur Exchange :

  • Identifiez tout d'abord les applications ou tâches qui provoquent une charge sur le serveur. Déterminez si l'application doit utiliser le temps processeur réel ou s'il existe un problème avec ce processus.

  • Si une application non-Exchange n'est pas importante sur ce serveur, exécutez-la sur un autre serveur. Si vous pouvez l'exécuter sur un autre serveur, déplacez également les rôles de serveur vers d'autres ordinateurs. Par exemple, si le processus Inetinfo utilise une grande partie du processeur, envisagez l'ajout de serveurs frontaux pour prendre la responsabilité du fonctionnement du protocole assuré par Inetinfo. Vous pouvez également déplacer l'accès aux dossiers publics vers un serveur de dossiers publics dédié. Enfin, si un serveur effectue de nombreuses extensions de liste de distribution, vous pouvez réduire l'utilisation du processeur en déplaçant l'extension de la liste de distribution vers un serveur d'extension de liste de distribution dédié.

  • Si possible, ajoutez davantage de processeurs ou des processeurs plus rapides au serveur. Activez également la technologie Hyper-Threading si elle est prise en charge par les processeurs. Vous pouvez activer la technologie Hyper-Threading en configurant le BIOS système. Pour plus d'informations, voir la documentation d'aide du fabricant de l'ordinateur.

  • Si l'augmentation de la puissance de traitement s'avère impossible, vous devez diminuer la charge des processeurs. Pour réduire l'impact global sur le serveur, assurez-vous que les tâches qui nécessitent de nombreuses E/S et une grande partie du processeur ou utilisent beaucoup de mémoire soient effectuées en dehors des heures de fonctionnement habituelles.

  • Assurez-vous que les tâches qui nécessitent une grande partie du processeur (comme les tâches de sauvegarde et de maintenance) sont effectuées pendant les heures creuses. Assurez-vous également que ces tâches soient effectuées par étapes. Effectuer une tâche par étapes signifie le paramétrage de différentes heures de début et de fin pour chaque tâche. Effectuer par étapes la maintenance et la sauvegarde des bases de données ou des groupes de stockage diminue également l'effet de ces tâches nécessitant beaucoup de ressources.

Pour plus d'informations

  • Pour obtenir un aperçu d'Exchange Server et de l'analyse antivirus, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et du logiciel antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Pour plus d'informations sur l'analyse antivirus et sur Exchange Server, voir l'article 285667 de la Base de connaissances Microsoft sur la présentation de Virus Scanning API 2.0 dans Exchange 2000 Server SP1 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667).

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la procédure de déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


Échec du point de montage de volume : Windows Server 2003 SP1 n'est pas installé
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) CIM_Datafile pour vérifier que le pilote Mountmgr.sys existe.

Exchange Server Analyzer lit ensuite la valeur de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur le serveur Exchange : HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si la valeur CurrentVersion est égale à 5.0, le serveur Exchange est exécuté sur Microsoft Windows 2000 Server. Si la valeur CurrentVersion est 5.2, le serveur Exchange est exécuté sur Microsoft Windows Server™ 2003.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service de cluster (ClusSvc). Une valeur TRUE indique que le service de cluster est démarré et une valeur FALSE qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • L'ordinateur Exchange Server est exécuté sur Windows Server 2003.

  • Windows Server 2003 SP1 n'est pas installé.

  • Exchange Server est exécuté dans un environnement en clusters.

  • Les points de montage de volume existent.

L'avertissement indique que si l'environnement de nœud de cluster Exchange est mis à niveau vers Windows Server 2003 SP1, vous aurez besoin de la mise à jour décrite dans la section suivante. Sans cette mise à jour, des échecs de montage de volume peuvent survenir après la mise à niveau.

Pour supprimer cet avertissement

  • Appliquez la mise à jour décrite dans l'article 898790 de la Base de connaissances Microsoft sur les points de montage de volume sur des disques dans un cluster de serveur qui peuvent devenir indisponibles par intermittence après l'installation de Windows Server 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


Le service de pare-feu Windows est activé sur Exchange Server
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service Pare-feu Windows (SharedAccess). La valeur True indique que le service Pare-feu Windows est activé sur ce serveur Exchange.

Si Exchange Server Analyzer détermine que le service Pare-feu Windows est activé sur un ordinateur Exchange Server, un avertissement s'affiche. Lorsque le service Pare-feu Windows est activé, les problèmes suivants peuvent survenir :

  • Certains composants d'Exchange Server, tels que le service de suivi des messages ou la communication d'appel de procédure distante (RPC), peuvent cesser de répondre.

  • Vous pouvez recevoir un message d'erreur indiquant que la mémoire disponible est insuffisante.

Par défaut, le service Pare-feu Windows s'arrête lorsque Microsoft Windows Server™ 2003 Service Pack 1 (SP1) est appliqué. Toutefois, il fonctionne automatiquement si l'une des conditions suivantes est vraie :

  • Un administrateur active manuellement le service Pare-feu Windows.

  • Vous activez le service Pare-feu Windows après avoir exécuté l'Assistant de configuration de sécurité.

Pour supprimer cet avertissement

  • Vérifiez les exclusions de programmes.

  • Vérifiez les exclusions de ports.

  • Vérifiez les exceptions de pare-feu si les clients ne parviennent pas à se connecter au serveur Exchange.

  • Ouvrez manuellement les ports du pare-feu pour pouvoir utiliser le Gestionnaire système Exchange et l'Administrateur Microsoft Exchange. En ouvrant les ports du service Pare-feu Windows, vous permettez peut-être à d'autres programmes d'accéder à votre ordinateur via ces ports. Examinez consciencieusement le paramétrage de la sécurité réseau avant d'ouvrir les ports du service Pare-feu Windows.

  • Arrêtez le service Pare-feu Windows.


Le service Windows Management Instrumentation n'est pas exécuté comme LocalSystem
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les données de la valeur ObjectName :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

La valeur ObjectName de cette branche de Registre indique les paramètres de comptes du service Microsoft Windows® Management Instrumentation (WMI), également appelé service Winmgmt. Si Exchange Server Analyzer détecte que les données de la valeur ObjectName ne sont pas égales à LocalSystem, il affiche une erreur.

Cette erreur indique que le service WMI n'est pas exécuté dans une configuration prise en charge. L'exécution du service WMI sous tout autre compte que LocalSystem engendrera des erreurs d'autorisation et d'accès.

Pour corriger cette erreur, vous devez configurer le service WMI pour qu'il démarre sous le compte LocalSystem (SYSTEM).

Pour configurer le compte du service WMI

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Recherchez et arrêtez le service de Windows Management Instrumentation.

  3. Double-cliquez sur le service Windows Management Instrumentation.

  4. Sous l'onglet Ouvrir une session de la page Propriétés de Windows Management Instrumentation, sélectionnez Compte LocalSystem dans Ouvrir une session en tant que, puis cliquez sur Appliquer.

  5. Sous Statut du service, cliquez sur Démarrer, puis sur OK.

  6. Fermez le composant logiciel enfichable Services.


Windows Server 2003 SP1 : le correctif Outlook Web Access est requis
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge différentes classes WMI (Windows® Management Instrumentation) Microsoft pour collecter les informations suivantes :

  • Sur quelle version du système d'exploitation Microsoft Windows Server Exchange Server est-il installé ?

  • Exchange Server est-il exécuté sur un cluster ?

Si Exchange Server Analyzer détermine que toutes les conditions suivantes sont vraies, une erreur s'affiche :

  • Le Service Pack 1 (SP1) d'Exchange Server 2003 est installé.

  • Le Service Pack 1 (SP1) de Microsoft Windows Server™ 2003 est installé.

  • Le service de cluster est exécuté.

  • La valeur Version de Davex.dll est inférieure à 6.5.7232.

Si vous disposez d'une telle configuration, vous devez télécharger et installer un correctif Exchange Server avant d'installer Windows Server 2003 SP1. Si vous n'installez pas le correctif Exchange Server, les utilisateurs Microsoft Office Outlook® Web Access pour Exchange Server 2003 ne pourront pas se connecter à leurs boîtes aux lettres. Le message d'erreur suivant s'affichera pour les utilisateurs ayant des boîtes aux lettres hébergées sur les clusters lorsqu'ils essayeront de se connecter à l'aide d'Outlook Web Access :

  • « 500 - Erreur interne au serveur »

Cette erreur provient de certaines des améliorations en matière de sécurité comprises dans Windows Server 2003 SP1.

Lorsqu'un utilisateur tente de se connecter à une boîte aux lettres à l'aide d'Outlook Web Access, le protocole HTTP envoie des requêtes aux clusters API en se faisant passer pour l'utilisateur connecté. Toutefois, des modifications de sécurité ont été apportées dans Windows Server 2003 SP1. Les restrictions de sécurité pour les API exécutant l'accès au Registre distant ont été modifiées. C'est pourquoi la tentative de connexion échoue.

Pour corriger cette erreur, vous devez télécharger et installer le correctif Exchange Server décrit dans l'article 841561 de la Base de connaissances Microsoft sur l'apparition du « Message d'erreur 500 - Erreur interne au serveur » lorsqu'un utilisateur tente d'accéder à un serveur principal Exchange Server 2003 en clusters à l'aide d'Outlook Web Access (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561).


L'Assistant de configuration de sécurité de Windows Server 2003 SP1 a été détecté
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur le serveur Exchange :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Si la valeur CurrentVersion est égale à 5.0, le serveur Exchange est exécuté sur Microsoft Windows 2000 Server. Si la valeur CurrentVersion est 5.2, le serveur Exchange est exécuté sur Microsoft Windows Server™ 2003.

En outre, Exchange Server Analyzer lit la valeur de Registre suivante pour déterminer le chemin d'accès du répertoire Program Files de Windows :

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

Exchange Server Analyzer examine ensuite le répertoire Program Files de Windows pour déterminer si ce dernier contient le dossier \Exchsrvr pour Exchange Server.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé ServicePackMajorVersion. La valeur de la clé ServicePackMajorVersion indique la version du Service Pack Windows installé sur l'ordinateur.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Exchange Server Analyzer indique que l'ordinateur Exchange Server est exécuté sur le Service Pack 1 de Windows Server 2003.

  • Exchange Server Analyzer indique qu'Exchange Server 2003 ne se trouve pas dans le chemin d'accès par défaut \Program Files\Exchsrvr.

Cet avertissement indique qu'Exchange Server 2003 ne se trouve pas dans le dossier Program Files par défaut du serveur et que l'Assistant de configuration de sécurité est installé sur le serveur Exchange. L'Assistant de configuration de sécurité est un outil fourni comme composant facultatif du Service Pack 1 de Windows Server 2003. S'il est installé sur un serveur Exchange, la configuration manuelle de la section Sécurité réseau est nécessaire.

Remarque :
Pour installer cet Assistant, vous devez d'abord installer le Service Pack 1 de Windows Server 2003. Ensuite, ouvrez l'applet Ajout/Suppression de programmes dans le Panneau de configuration pour installer l'Assistant de configuration de sécurité.

L'Assistant de configuration de sécurité contribue à réduire les risques d'attaques sur les serveurs Windows en posant à l'utilisateur une série de questions qui permet de déterminer les besoins fonctionnels d'un serveur. L'Assistant de configuration de sécurité contribue, en particulier, à effectuer les tâches suivantes :

  • Il désactive automatiquement les services inutiles.

  • Il bloque automatiquement les ports non utilisés.

  • Il contribue à appliquer des restrictions d'adresses ou de sécurité supplémentaires aux ports laissés ouverts.

  • Il empêche les extensions Web IIS (Internet Information Services) inutiles, au besoin.

  • Il réduit la surface de vulnérabilité des protocoles SMB (Server Message Block), LanMan et LDAP (Lightweight Directory Access Protocol).

  • Il définit une stratégie d'audit signal/bruit importante.

L'Assistant de configuration de sécurité vous guide à travers le processus de création, de modification, d'application ou de restauration d'une stratégie de sécurité basée sur les rôles sélectionnés du serveur. Les stratégies de sécurité créées à l'aide de l'Assistant de configuration de sécurité correspondent à des fichiers XML qui, une fois appliqués, configurent des services, la sécurité réseau, des valeurs de Registre spécifiques et la stratégie d'audit. Vous pouvez aussi configurer les services IIS (Internet Information Services), au besoin.

Cet Assistant comprend une fonction de sécurité réseau qui configure et ajoute des exceptions au Pare-feu Windows, en plus d'effectuer d'autres opérations. Le Pare-feu Windows est la nouvelle version du filtre de paquets du Service Pack 1 de Windows Server 2003. Il a d'abord été intégré au Service Pack 2 de Windows XP et s'appelle Pare-feu de connexion Internet.

Il existe un problème connu qui survient lorsque la fonction de sécurité réseau dans l'Assistant de configuration de sécurité est exécutée sur un serveur Exchange sur lequel Exchange Server ne se trouve pas dans le chemin d'accès par défaut. Dans cette configuration, l'application de la stratégie appropriée peut rendre Exchange Server inaccessible aux clients. Si la fonction de sécurité réseau est utilisée sur un serveur Exchange sur lequel Exchange Server ne se trouve pas dans le chemin d'accès par défaut, l'Assistant de configuration de sécurité peut configurer le Pare-feu Windows pour bloquer l'accès du port TCP/IP à l'aide de processus Exchange Server, tels que le service Surveillance du système (Mad.exe), la Banque d'informations Microsoft Exchange (Store.exe) ou l'Agent de transfert des messages (Emsmta.exe). Dans cette configuration, l'Assistant de configuration de sécurité affiche Introuvable ! en regard de chaque processus. Si cet Assistant est exécuté jusqu'à la fin avec un processus portant l'inscription Introuvable !, il applique la stratégie de sécurité au Pare-feu Windows qui bloque l'accès au réseau via ce processus.

Si les processus bloqués comprennent un ou plusieurs processus Exchange Server, des clients ou d'autres serveurs risquent de ne plus pouvoir accéder à Exchange Server. Dans ce cas-ci, vous devez effectuer l'une des procédures suivantes pour résoudre le problème.

Pour résoudre le problème

  • Effectuez l'une des procédures suivantes pour résoudre le problème :

    • Utilisez la fonction de restauration de l'Assistant pour restaurer une stratégie de sécurité après son application. Pour plus d'informations sur la manière de procéder, voir le fichier d'aide de l'Assistant de configuration de sécurité fourni avec le Service Pack 1 de Windows Server 2003. Pour plus d'informations sur le Service Pack 1 de Windows Server 2003 et sur l'Assistant de configuration de sécurité, voir le Centre technique Windows Server 2003(http://go.microsoft.com/fwlink/?LinkId=45315).

    • Dans L'Assistant de configuration de sécurité, remplissez manuellement le champ Chemin de l'application pour spécifier l'emplacement des fichiers de traitement Exchange Server exécutables. Pour ce faire, sélectionnez le traitement portant l'inscription Introuvable ! et cliquez sur Modifier. Il est conseillé d'exécuter l'Assistant sur le serveur Exchange pour s'assurer que le chemin de chaque exécutable Exchange Server est correct. Ensuite, la stratégie de sécurité de l'Assistant peut être appliquée et Exchange Server doit avoir l'accès au réseau pour pouvoir fonctionner.

Pour plus d'informations sur Windows Server 2003 Service Pack 1 et l'Assistant de configuration de sécurité, voir le Centre technique Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=45315).


Le fichier XESE.DLL est présent
Microsoft Exchange Server Analyzer - Articles > Exchange Server >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour un fichier appelé Xese.dll.

Si Exchange Server Analyzer parvient à obtenir une valeur Version pour ce fichier, il indique que le fichier existe et une erreur s'affiche.

Certains programmes antivirus ESE utilisent une interface non prise en charge entre la banque d'informations d'Exchange et ESE (Extensible Storage Engine). Lorsque vous utilisez ce type de logiciel, vous risquez d'endommager la base de données et de perdre des données si des erreurs se produisent lors de l'implémentation du logiciel.

Pendant l'installation, l'analyseur ESE modifie le service de banque d'informations de Microsoft Exchange de manière à ce qu'il dépende du service de programme antivirus ESE. Cela permet de s'assurer que le service de programme antivirus ESE démarre avant le service de banque d'informations de Microsoft Exchange. Lorsque le programme antivirus ESE démarre, la version d'Ese.dll fournie avec Exchange Server est provisoirement renommée Xese.dll et la version d'Ese.dll du programme antivirus ESE remplace le fichier d'origine. Une fois la version d'Ese.dll du programme antivirus ESE chargée, la version fournie avec Exchange Server est renommée Ese.dll et le service de banque d'informations de Microsoft Exchange termine le processus de démarrage.

Pour supprimer cet avertissement

  1. Il est vivement recommandé de ne pas utiliser des implémentations non Microsoft d'ESE sur les ordinateurs Exchange Server. Les clients qui contactent les services du Support Technique de Microsoft peuvent être invités à désactiver le programme antivirus ESE pour permettre d'identifier les problèmes, mais ils sont libres de réactiver le logiciel après le diagnostic correct de la cause profonde du problème.

  2. Antigen pour Microsoft Exchange de Sybari Software est le programme antivirus ESE le plus largement utilisé. Microsoft et Sybari admettent que la désactivation de Sybari Antigen est une procédure de dépannage valide pour déterminer la cause de problèmes. Pour contacter Sybari Software, voir le site Web Sybari Software (http://www.sybari.com).

    Remarque :
    Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

  3. Il est recommandé d'utiliser les programmes antivirus qui prennent en charge l'interface VSAPI (interface de programmation d'applications d'analyse antivirus), également appelée AntiVirus API (AVAPI).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=).

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=).


Matériel
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant le matériel. En outre, ils décrivent les actions possibles pour corriger les erreurs liées au matériel, les avertissements et les configurations autres que celles par défaut détectés par Exchange Server Analyzer.


Le BIOS est obsolète
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_BIOS pour déterminer la valeur des clés SMBIOSBIOSVersion et ReleaseDate. La valeur renvoyée représente respectivement le numéro de version et la date de publication du BIOS installé sur l'ordinateur. Exchange Server Analyzer examine également la classe WMI Win32_ComputerSystem pour déterminer la valeur de la clé Model.

Si Exchange Server Analyzer détecte que la valeur de la clé ReleaseDate est obsolète de plus d'un an et que la clé Model contient l'une des chaînes suivantes, un avertissement s'affiche :

  • ProLiant DL320 ;

  • ProLiant DL320 G2 ;

  • ProLiant DL320 G3 ;

  • ProLiant DL360 ;

  • ProLiant DL360 G2 ;

  • ProLiant DL360 G3 ;

  • ProLiant DL360 G4 ;

  • ProLiant DL380 ;

  • ProLiant DL380 G2 ;

  • ProLiant DL380 G3 ;

  • ProLiant DL380 G4 ;

  • ProLiant DL560 ;

  • ProLiant DL570 G3 ;

  • ProLiant DL580 ;

  • ProLiant DL580 G2 ;

  • ProLiant DL580 G3 ;

  • ProLiant DL585 G1 ;

  • ProLiant ML350 ;

  • ProLiant ML350 G2 ;

  • ProLiant ML350 G3 ;

  • ProLiant ML350 G4 ;

  • ProLiant ML370 ;

  • ProLiant ML370 G2 ;

  • ProLiant ML370 G3 ;

  • ProLiant ML370 G4 ;

  • ProLiant ML530 ;

  • ProLiant ML530 G2 ;

  • ProLiant ML570 ;

  • ProLiant ML570 G2 ;

  • ProLiant ML750.

Pour corriger cet avertissement et pour plus d'informations sur l'obtention et la mise à jour d'une nouvelle version de BIOS, voir la rubrique sur les mises à jour ROM-BIOS/logiciel sur le site Web d'Hewlett-Packard (http://h18023.www1.hp.com/support/files/server/us/romtabl.html).

Pour plus d'informations sur les serveurs Hewlett-Packard ProLiant, voir le site Web d'Hewlett-Packard (http://www.hp.com).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Le BIOS est obsolète sur le serveur Dell PowerEdge
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_BIOS pour déterminer la valeur de la clé SMBIOSBIOSVersion. La valeur renvoyée représente le numéro de version du BIOS installé sur l'ordinateur. Exchange Server Analyzer examine également la classe WMI Win32_ComputerSystem pour déterminer la valeur de la clé Model.

Si Exchange Server Analyzer détecte que la clé Model contient l'une des chaînes suivantes et que SMBIOSBIOSVersion n'est pas la dernière version du modèle, un avertissement s'affiche :

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

Pour supprimer cet avertissement et pour plus d'informations sur l'obtention et la mise à jour d'une version plus récente du BIOS, voir la rubrique Téléchargements sur le site Web de Dell (http://support.dell.com/support/downloads).

Pour plus d'informations sur les serveurs Dell PowerEdge, voir le site Web de Dell (http://www.dell.com).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Mise à jour du BIOS disponible
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_BIOS pour déterminer la valeur de la clé SMBIOSBIOSVersion. La valeur renvoyée représente le numéro de version et la date de publication du BIOS installé sur l'ordinateur. Exchange Server Analyzer examine également la classe WMI Win32_ComputerSystem pour déterminer la valeur de la clé Model. Si Exchange Server Analyzer détermine que l'ordinateur est un système IBM X445 dont la version de BIOS est antérieure à REJT48A, il affiche une erreur.

Pour corriger cette erreur et pour plus d'informations sur l'obtention et la mise à jour d'une version plus récente du BIOS, voir l'article du site Web IBM sur la mise à jour du BIOS flash (package de mise à jour DOS) avec la prise en charge EXA RSA I et RSA II - IBM eServer xSeries 445 (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


La carte d'interface réseau de cluster est activée pour le DHCP
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour déterminer la valeur de la clé DHCPEnabled pour toutes les interfaces réseau du cluster. Si Exchange Server Analyzer détecte que la valeur de DHCPEnabled est définie sur True pour toute interface de réseau privé du cluster, une erreur s'affiche.

Une valeur True pour la clé WMI DHCPEnabled indique qu'une interface réseau est configurée pour utiliser le protocole DHCP (Dynamic Host Configuration Protocol). Microsoft ne prend pas en charge l'utilisation de DHCP pour des nœuds sur le réseau privé dans un cluster de serveurs Windows. En outre, il est recommandé d'utiliser des adresses IP statiques pour les nœuds de réseau public dans un cluster de serveurs Windows. L'utilisation d'une configuration dynamique de réseaux publics via DHCP n'est pas recommandée, l'échec du renouvellement d'un bail DHCP a pu en effet entraîner l'interruption des opérations de cluster. En outre, une configuration dynamique de réseaux privés via DHCP n'est pas prise en charge et ne doit jamais être utilisée.

Pour résoudre ce problème, vous devez reconfigurer les interfaces réseau pour les réseaux privés pour utiliser une adresse IP statique. Il est recommandé de sélectionner les adresses dans les étendues suivantes :

  • 10.0.0.0 - 10.255.255.255 (réseau de classe A)

  • 172.16.0.0 - 172.31.255.255 (réseau de classe B)

  • 192.168.0.0 - 192.168.255.255 (réseau de classe C)

Pour corriger cette erreur

  1. Dans Connexions réseau, cliquez avec le bouton droit sur la connexion réseau de votre carte réseau privé, puis cliquez sur Propriétés.

  2. Cliquez sur Protocole Internet (TCP/IP), puis sur Propriétés.

  3. Sous l'onglet Général, entrez une adresse IP statique ne se trouvant pas sur le même réseau ou sous-réseau que l'une des cartes réseau public. 10.10.10.10 est un bon exemple d'adresse IP à utiliser pour les cartes réseau privé sur le nœud 1 et 10.10.10.11 sur le nœud 2 avec un masque de sous-réseau de 255.0.0.0. Si votre réseau public utilise le réseau 10.x.x.x et le masque de sous-réseau 255.0.0.0, utilisez un autre masque de sous-réseau et une autre adresse IP de réseau privé.

  4. Veillez à ce qu'aucune valeur ne soit définie dans la zone Passerelle par défaut.

  5. Vérifiez qu'aucune valeur n'est définie dans la zone Utiliser l'adresse de serveur DNS suivante.

  6. Cliquez sur Paramètres avancés.

  7. Sous l'onglet DNS, vérifiez qu'aucune valeur n'est définie. Veillez à ce que les cases à cocher Enregistrer les adresses de cette connexion dans le système DNS et Utiliser le suffixe DNS de cette connexion pour l'enregistrement DNS soient désactivées.

  8. Sous l'onglet WINS, vérifiez qu'aucune valeur n'est définie. Cliquez sur Désactiver NetBIOS avec TCP/IP.

  9. À la fermeture de la boîte de dialogue, l'invite suivante peut apparaître. Dans ce cas, cliquez sur Oui : Cette connexion possède une adresse de serveur WINS principale vide. Voulez-vous continuer ?

  10. Cliquez sur OK pour enregistrer vos modifications.

  11. Répétez cette procédure pour tous les autres nœuds du cluster.

Pour plus d'informations sur la configuration réseau optimale des clusters de serveurs Windows, voir le livre blanc sur les clusters de serveurs et la configuration réseau recommandée pour Windows 2000 et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=34304).

Pour plus d'informations sur la configuration correcte du réseau de pulsation de cluster, voir l'article 258750 de la Base de connaissances Microsoft sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Le suffixe DNS principal de l'ordinateur ne correspond pas au nom de domaine complet du domaine sur lequel il réside
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2006-05-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer le suffixe DNS (Domain Name System) principal pour ce serveur Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

Si Exchange Server Analyzer détecte que les valeurs NV Domain et Domain ne correspondent pas, un avertissement s'affiche.

La valeur de Registre NV Domain contient le suffixe DNS principal de l'ordinateur. La valeur de Registre Domain contient le domaine DNS principal de l'ordinateur. Par défaut, la partie du suffixe DNS principal du nom de domaine complet d'un ordinateur doit être identique au nom de domaine du service d'annuaire Active Directory® sur lequel se trouve l'ordinateur. Des noms qui ne correspondent pas peuvent empêcher le bon déroulement de l'enregistrement DNS. Si le nom de domaine DNS de l'ordinateur ne correspond pas au nom de domaine Active Directory, des erreurs s'afficheront dans le journal des événements système de l'ordinateur toutes les 22 minutes. Une telle condition est appelée espace de noms disjoint. Pour autoriser différents suffixes DNS principaux, vous pouvez créer une liste restreinte de suffixes autorisés en créant un attribut Active Directory appelé msDS-AllowedDNSSuffixes dans le conteneur d'objets de domaine.

La procédure permettant de s'assurer que vous avez correctement configuré l'espace de noms disjoint dépend du système d'exploitation utilisé pour vos contrôleurs de domaine Active Directory.

  • Si vous utilisez un système d'exploitation Microsoft Windows® 2000 Server sur vos contrôleurs de domaine Active Directory, vous pouvez utiliser la procédure décrite dans l'article 258503 de la Base de connaissances Microsoft sur les erreurs d'enregistrement DNS 5788 et 5789 lorsque les noms des domaines DNS et Active Directory diffèrent (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258503) pour configurer correctement votre espace de noms. Cet article décrit également les procédures permettant de corriger un espace de noms disjoint involontaire et, au besoin, de configurer correctement un espace de noms disjoint.

  • Si vous utilisez Microsoft Windows Server™ 2003 sur vos contrôleurs de domaine Active Directory et si l'espace de noms disjoint est involontaire, vous pouvez utiliser la première procédure décrite ci-dessous pour corriger l'espace de noms disjoint involontaire et supprimer cet avertissement. Si vous utilisez Windows Server 2003 sur vos contrôleurs de domaine Active Directory et si l'espace de noms disjoint est voulu, vous pouvez utiliser la deuxième procédure décrite ci-dessous pour le configurer correctement.

Pour effectuer la seconde procédure ci-dessous, vous devez utiliser un éditeur Active Directory tel qu'ADSI (Active Directory Service Interfaces) Edit ou l'outil LDP (ldp.exe). Pour plus d'informations sur la modification d'Active Directory à l'aide de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Windows Server 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Si l'espace de noms disjoint est involontaire

  1. Cliquez avec le bouton droit de la souris sur Poste de travail, puis sélectionnez Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur l'onglet Nom de l'ordinateur.

  3. Cliquez sur Modifier. La boîte de dialogue Modification du nom d'ordinateur s'affiche.

  4. Cliquez sur Plus. La boîte de dialogue Nom d'ordinateur NetBIOS et suffixe DNS s'affiche.

  5. Activez la case à cocher Modifier le suffixe DNS principal lorsque les adhésions au domaine sont modifiées.

  6. Cliquez sur OK pour enregistrer les modifications, puis de nouveau sur OK pour quitter la boîte de dialogue Modification du nom d'ordinateur.

  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés système, puis redémarrez l'ordinateur pour que la modification soit prise en compte.

Si l'espace de noms disjoint est voulu

  1. Utilisez la procédure ci-dessus pour vous assurer que la case à cocher Modifier le suffixe DNS principal lorsque les adhésions au domaine sont modifiées est désactivée.

  2. Modifiez l'attribut Active Directory msDS-AllowedDNSSuffixes sur le conteneur d'objets de domaine. À cet effet, vous pouvez utiliser ADSI Edit en respectant la procédure suivante :

    1. Double-cliquez sur la partition d'annuaire du domaine à modifier.

    2. Cliquez avec le bouton droit de la souris sur l'objet de conteneur de domaine, puis sélectionnez Propriétés.

    3. Dans l'onglet Éditeur d'attribut, dans la zone Attributs, double-cliquez sur l'attribut msDS-AllowedDNSSuffixes.

    4. Dans la ???boîte de dialogue Éditeur de chaînes à valeurs multiples, dans la zone Valeur à ajouter, entrez un suffixe DNS puis cliquez sur Ajouter.

    5. Lorsque vous avez ajouté tous les suffixes DNS au domaine, cliquez sur OK.

    6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du domaine.

    7. Répétez l'opération si vous voulez configurer d'autres domaines de la même manière.

Pour plus d'informations sur l'attribut msDS-AllowedDNSSuffixes, voir le Centre d'Aide et de Support de Windows Server 2003. Pour plus d'informations sur la procédure utilisée pour modifier cet attribut, voir le livre blanc « Step-by-Step Guide to Implementing Domain Rename » (en anglais) à l'adresse http://go.microsoft.com/fwlink/?LinkId=41359.


La mise à jour critique du BIOS est disponible
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_BIOS pour déterminer la valeur de la clé SMBIOSBIOSVersion. La valeur de la clé SMBIOSBIOSVersion représente la version du BIOS installé sur le serveur. Exchange Server Analyzer interroge également la classe WMI Win32_ComputerSystem pour déterminer la valeur de la clé Model. La valeur de la clé Model représente les informations sur le modèle telles qu'elles sont fournies par le fabricant du matériel.

Si Exchange Server Analyzer détecte que la valeur de la clé Version est 42B sur un serveur dont la clé Model commence par eserver xSeries 445, une erreur s'affiche. Cette erreur indique que le BIOS du serveur IBM xSeries 445 doit être mis à jour.

Il existe un problème connu avec la version 42B du microprogramme BIOS qui peut provoquer une altération des données. Le problème est limité aux systèmes X445, sur lesquels BIOS 42B (version 1.15) est installé. Le problème est résolu avec BIOS 45A. Vous devez effectuer la mise à jour du BIOS sur ce serveur vers la version 45A ou ultérieure dès que possible.

Pour corriger cette erreur

  1. Pour plus d'informations sur ce problème, voir le site Web d'IBM sur la mise à jour du BIOS flash (package de mise à jour DOS) - IBM eServer xSeries 445 (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion).

  2. Pour plus d'informations, voir le fichier LisezMoi pour la mise à jour du BIOS (ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt).

  3. Téléchargez la mise à jour du BIOS à partir du site Web d'IBM (http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe).

  4. Mettez à jour le BIOS sur le serveur.

Pour plus d'informations sur l'application de cette mise à jour critique du BIOS, voir le site Web d'IBM (http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


La vitesse de processeur actuelle est inférieure à la vitesse maximale possible
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Processor pour déterminer les valeurs actuelles des clés MaxClockSpeed et CurrentClockSpeed. Si Exchange Server Analyzer détecte que la valeur de CurrentClockSpeed est inférieure à la valeur de MaxClockSpeed, un avertissement s'affiche.

La valeur CurrentClockSpeed est la vitesse actuelle de chaque processeur en mégahertz (MHz). La valeur MaxClockSpeed est la vitesse maximale de chaque processeur en mégahertz. Si ce message d'avertissement s'affiche, cela indique qu'un ou plusieurs processeurs sur votre serveur Exchange ne fonctionnent pas à plein rendement. Il existe plusieurs causes connues pour cela :

  1. Exchange Server est installé sur un ordinateur Microsoft® Windows® 2000 Server ou Windows 2000 Advanced Server sur lequel le Service Pack 3 ou ultérieur de Windows 2000 Server n'est pas installé. Le Service Pack 3 de Windows 2000 Server corrige un problème provoquant le renvoi de valeurs incorrectes pour MaxClockSpeed ou CurrentClockSpeed par l'infrastructure WMI.

  2. Un paramètre d'économie d'énergie incorrect dans le BIOS du serveur Exchange peut ralentir la vitesse d'exécution du processeur.

Pour supprimer cet avertissement

  1. Si Exchange Server est installé sur un ordinateur Windows 2000 Server ou Windows 2000 Advanced Server sur lequel le Service Pack 3 ou ultérieur de Windows 2000 Server n'est pas installé, vous devez installer le dernier Service Pack. Pour plus d'informations sur les derniers Service Packs de Windows 2000, voir le site Web de Microsoft Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=18353).

  2. Si Exchange Server est installé sur un ordinateur Windows 2000 Server ou Windows 2000 Advanced Server sur lequel le Service Pack 3 ou ultérieur de Windows 2000 Server est installé, vérifiez les paramètres de BIOS de votre serveur Exchange. Vous devez également vérifier les paramètres de gestion de l'alimentation dans le BIOS et le Panneau de configuration ou le Gestionnaire de périphériques.

Contactez votre fabricant de matériel pour plus d'informations sur la procédure d'affichage et de configuration du BIOS système, du processeur et des paramètres de gestion de l'alimentation.

Pour plus d'informations sur les fonctionnalités de gestion de l'alimentation de Windows 2000 Server, voir l'article 244806 de la Base de connaissances Microsoft sur la présentation de la Gestion de l'alimentation dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=244806).

Pour plus d'informations sur les fonctionnalités de gestion de l'alimentation dans Microsoft Windows Server™ 2003, effectuez une recherche sur « Gestion de l'alimentation » et « Options d'alimentation » dans le Centre d'Aide et de Support de Windows Server 2003. Cette recherche peut être exécutée à partir du menu Démarrer sur un ordinateur Windows Server 2003.

Pour plus d'informations sur les fonctionnalités de gestion de l'alimentation dans Windows 2000 Server, voir les rubriques « Gestion de l'alimentation » et « Options d'alimentation » dans l'aide de Windows 2000 Server. Cette recherche peut être exécutée à partir du menu Démarrer sur un ordinateur Windows 2000 Server.


La valeur DisableDHCPMediaSense n'est pas définie correctement dans Windows Server 2003
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2006-10-02

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la fonction de détection de support est correctement configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows exécutée sur l'ordinateur de destination :

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. Une valeur de 5.0 indique que l'ordinateur exécute un système d'exploitation Windows® 2000 Server et une valeur de 5.2, qu'il exécute un système d'exploitation Windows Server™ 2003.

En outre, l'outil Exchange Server Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started de ClusSvc, le service de cluster Microsoft Windows. La valeur True indique que le service de cluster Windows est en cours d'exécution et la valeur False, qu'il ne l'est pas.

Si Exchange Server Analyzer détecte que le service de cluster Windows est en cours d'exécution sur Windows Server 2003 Édition Entreprise ou Windows Server 2003 Édition Datacenter et que la valeur de la clé de Registre DisableDHCPMediaSense est définie sur 1, un avertissement s'affiche.

Lorsque vous utilisez le service de cluster Windows Server 2003, si la connectivité réseau est rejetée, la pile TCP/IP n'est pas déchargée par défaut, comme elle l'était dans Windows 2000 Server. Par conséquent, il n'est plus nécessaire de définir la clé de Registre DisableDHCPMediaSense. Dans Windows 2000 Server, si la connectivité réseau est rejetée, la pile TCP/IP est déchargée, ce qui signifie que toutes les ressources de cluster, y compris les ressources d'un serveur virtuel Exchange, qui dépendaient des adresses IP ont été déconnectées. Une fois les réseaux reconnectés, leur rôle par défaut est rétabli (client et privé). En désactivant la fonction de détection de support par défaut, le rôle réseau est conservé ainsi que toutes les ressources en ligne qui dépendent des adresses IP.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Dans le volet droit, cliquez avec le bouton droit pour modifier (définissez sur 0 pour désactiver) ou supprimer la valeur de registre DisableDHCPMediaSense.

  4. Fermez l'Éditeur du Registre.

  5. Déplacez toutes les ressources de cluster vers un autre nœud ou déconnectez-les. Puis, redémarrez le nœud de cluster pour que la modification soit prise en compte.

  6. Répétez ce processus sur tous les autres nœuds de cluster qui ont généré cet avertissement.

Pour plus d'informations sur le Registre de Microsoft Windows, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations sur la fonction de détection de support et sur les clusters Windows, voir les articles suivants de la Base de connaissances :

  • 254651 sur la modification automatique du rôle réseau de cluster (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924 sur la procédure de désactivation de la fonction de détection de support pour le protocole TCP/IP dans Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430 sur la non-disponibilité de la carte réseau lors de la configuration de cluster avec un câble inverseur (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007 sur les fonctions disponibles dans les clusters Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


DisableDHCPMediaSense n'est pas défini correctement dans Windows 2000 Server
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la fonction de détection de support est correctement configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version de Windows exécutée sur l'ordinateur cible :

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que l'ordinateur exécute un système d'exploitation Microsoft Windows® 2000 Server et la valeur 5.2, qu'il exécute un système d'exploitation Microsoft Windows Server™ 2003.

En outre, l'outil Exchange Server Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started de ClusSvc, le service de cluster Microsoft Windows. La valeur True indique que le service de cluster Windows est en cours d'exécution et la valeur False, qu'il ne l'est pas.

Si Exchange Server Analyzer détecte que le service de cluster Windows est exécuté sur Windows 2000 Advanced Server ou Windows 2000 Datacenter Server, si la clé de Registre DisableDHCPMediaSense est présente et si la valeur n'est pas définie sur 1, un avertissement s'affiche.

Lors de l'utilisation du service de cluster Windows 2000 Server, si la connectivité réseau est rejetée, la pile TCP/IP est déchargée. Cela signifie que toutes les ressources de cluster, y compris les ressources d'un serveur virtuel Exchange, qui dépendaient des adresses IP ont été déconnectées. Une fois les réseaux reconnectés, leur rôle par défaut est rétabli (client et privé). Pour éviter cette situation, il est recommandé de désactiver la fonction de détection de support sur tous les clusters Windows 2000 Server. La fonction de détection de support est automatiquement désactivée sur les clusters Windows Server 2003.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Cliquez avec le bouton droit sur Paramètres, puis cliquez sur Nouveau | Valeur DWORD. Entrez DisableDHCPMediaSense pour le nom et appuyez sur Entrée.

  4. Dans le volet droit, double-cliquez sur DisableDHCPMediaSense et entrez 1 pour les Données de la valeur.

  5. Fermez l'Éditeur du Registre.

  6. Déplacez toutes les ressources de cluster vers un autre nœud ou déconnectez-les. Puis, redémarrez le nœud de cluster pour que la modification soit prise en compte.

  7. Répétez ce processus sur tous les nœuds de cluster qui ont généré cet avertissement.

Pour plus d'informations sur le Registre de Microsoft Windows, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations sur la fonction de détection de support et sur les clusters Windows, voir les articles suivants de la Base de connaissances :

  • 254651 sur la modification automatique du rôle réseau de cluster (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651)

  • 239924 sur la procédure de désactivation de la fonction de détection de support pour le protocole TCP/IP dans Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924)

  • 242430 sur la non-disponibilité de la carte réseau lors de la configuration de cluster avec un câble inverseur (http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430)

  • 278007 sur les fonctions disponibles dans les clusters Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007)


Le délai d'attente du disque n'est pas défini sur la valeur par défaut
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur du délai d'attente du disque a été modifiée et diffère de sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

Si Exchange Server Analyzer détecte que l'attribut TimeOutValue est présent et configuré sur une valeur différente de 10 et que le serveur n'est pas membre d'un cluster, un message indiquant une configuration autre que celle par défaut s'affiche. Si Exchange Server Analyzer détecte que l'attribut TimeOutValue est présent et configuré sur une valeur différente de 20 et que le serveur est membre d'un cluster, un message indiquant une configuration autre que celle par défaut s'affiche.

Le délai d'attente du disque est un paramètre de Registre qui définit le temps pendant lequel Microsoft Windows® attend qu'un disque dur réponde à une commande. Sur un système non membre d'un cluster, cette clé n'est pas présente et une valeur par défaut de 10 secondes est utilisée pour tous les disques. Sur un cluster Windows, cette clé est présente et utilise la valeur par défaut de 20 secondes. Si le délai d'attente est supérieur à la valeur de ce paramètre de Registre, Windows affiche une erreur et empêche l'accès au disque. Cet attribut peut parfois être défini sur une valeur plus importante si vous exécutez un logiciel à chemins d'accès multiples au disque. Le logiciel à chemins d'accès multiples permet de connecter plusieurs chemins physiques (tel que de la fibre) à un seul pilote de disque pour la redondance. Le logiciel à chemins d'accès multiples gère les différentes connexions physiques pour que Windows n'ait plus qu'un seul accès au disque à gérer.

L'installation de contrôleurs de stockage HBA (Host Bus Adapter) ou autres peut entraîner la création et la configuration de cette clé. Lorsque vous installez ou réinstallez ces pilotes, la valeur de Registre TimeOutValue est remplacée par la valeur requise par ces pilotes. Vous devrez peut-être contacter votre fournisseur de matériel pour déterminer la valeur de Registre TimeOutValue correcte pour votre configuration.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. Dans le volet droit, supprimez l'entrée TimeOutValue. Vous pouvez également double-cliquer sur l'entrée TimeOutValue et la définir sur l'une des valeurs suivantes :

    • Sur un serveur non membre d'un cluster, définissez la valeur sur 10.

    • Sur un serveur membre d'un cluster, définissez la valeur sur 20.

    • Si votre fabricant de matériel recommande une valeur différente pour un système membre ou non membre d'un cluster, utilisez plutôt cette valeur.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'entrée TimeOutValue sur des systèmes membres d'un cluster, voir l'article 818877 de la Base de connaissances sur les serveurs de cluster qui peuvent connaître des délais d'attente pour la connexion aux pilotes après l'installation ou la mise à niveau de fonctionnalités de gestion de clusters Windows dans Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877).


L'ordre de recherche DNS est vide
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour déterminer si une valeur est définie pour la propriété DNSServerSearchOrder. Si la valeur de cette clé sur un serveur Exchange est vide, un avertissement s'affiche.

Cet avertissement indique qu'une ou plusieurs cartes réseau sur cet ordinateur n'ont aucune adresse IP DNS qui leur est associée. Par conséquent, lorsque cet ordinateur essaie de se connecter à un autre ordinateur, il diffuse sur le réseau local à la recherche d'adresses IP. La résolution de nom est donc lente, ce qui peut ralentir Exchange.

Il est recommandé d'entrer une adresse IP ou au moins un serveur DNS valide. Si vous disposez de plus d'une carte sur l'ordinateur, vérifiez que toutes possèdent au moins une adresse IP de serveur DNS valide.

Pour définir l'adresse IP DNS sur une carte réseau

  1. Dans Connexions réseau, cliquez avec le bouton droit sur la carte réseau local appropriée, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, double-cliquez sur Protocole Internet (TCP/IP).

  3. Sous l'onglet Général de la page des propriétés de Protocole Internet (TCP/IP), entrez au moins une adresse IP ou un serveur DNS valide, puis cliquez sur OK.

Pour plus d'informations sur la configuration de DNS pour travailler avec Exchange, voir l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856).


La connexion de pulsation dispose d'une passerelle par défaut
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapter pour déterminer la valeur de la clé NetConnectionID. Si la valeur de la clé NetConnectionID contient la chaîne Internal ou HEART, cela indique que l'interface est le réseau privé de cluster (pulsation).

Exchange Server Analyzer interroge également la classe WMI Win32_NetworkAdapterConfiguration pour déterminer si une valeur est définie pour la clé DefaultIPGateway. Si une valeur est définie, cela indique qu'une passerelle par défaut a été configurée pour cette interface réseau.

Si Exchange Server Analyzer détecte une valeur définie pour la clé DefaultIPGateway sur l'interface réseau utilisée pour le réseau de pulsation de cluster, un avertissement s'affiche.

Les réseaux privés de cluster étant utilisés pour les communications internes du cluster, il n'est pas nécessaire de configurer une passerelle par défaut. Pour éliminer d'éventuels problèmes de communication, il est conseillé de supprimer tout trafic réseau inutile de la carte réseau utilisée comme carte réseau privé de cluster.

Pour supprimer cet avertissement

  1. Ouvrez la fenêtre Connexions réseau. Cliquez avec le bouton droit sur Favoris réseau, puis cliquez sur Propriétés ou, si Favoris réseau n'est pas affiché sur le Bureau, cliquez sur Démarrer, Programmes, Accessoires, Communications et enfin sur Connexions réseau.

  2. Dans la fenêtre Connexions réseau, cliquez avec le bouton droit sur la carte réseau utilisée pour le réseau privé, puis cliquez sur Propriétés.

  3. Sélectionnez Protocole Internet (TCP/IP), puis cliquez sur Propriétés.

  4. Dans la zone Utiliser l'adresse IP suivante, supprimez l'adresse IP de la passerelle par défaut.

  5. Cliquez deux fois sur OK pour enregistrer les modifications.

  6. Répétez les étapes 1 à 5 pour chaque nœud du cluster.

Pour plus d'informations sur les paramètres recommandés pour le réseau privé dans un cluster de serveurs Windows, voir l'article 258750 de la Base de connaissances Microsoft sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


La connexion de pulsation dispose d'une adresse de recherche DNS
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapter pour déterminer la valeur de la clé NetConnectionID. Si la valeur de la clé NetConnectionID contient la chaîne Internal ou HEART, cela indique que l'interface est le réseau privé de cluster (pulsation).

Exchange Server Analyzer interroge également la classe WMI Win32_NetworkAdapterConfiguration pour déterminer si une valeur est définie pour la clé DNSServerSearchOrder. Si une valeur est définie, cela indique qu'une adresse de recherche DNS (Domain Name System) a été configurée pour cette interface réseau.

Si Exchange Server Analyzer détecte une valeur définie pour la clé DNSServerSearchOrder sur l'interface réseau utilisée pour le réseau de pulsation de cluster, un avertissement s'affiche.

Les réseaux privés de cluster étant utilisés pour les communications internes du cluster, il n'est pas nécessaire de configurer un serveur DNS. Pour éliminer d'éventuels problèmes de communication, il est conseillé de supprimer tout trafic réseau inutile de la carte réseau utilisée comme carte réseau privé de cluster.

Pour supprimer cet avertissement

  1. Ouvrez la fenêtre Connexions réseau. Cliquez avec le bouton droit sur Favoris réseau, puis cliquez sur Propriétés ou, si Favoris réseau n'est pas affiché sur le Bureau, cliquez sur Démarrer, Programmes, Accessoires, Communications et enfin sur Connexions réseau.

  2. Dans la fenêtre Connexions réseau, cliquez avec le bouton droit sur la carte réseau utilisée pour le réseau privé, puis cliquez sur Propriétés.

  3. Sélectionnez Protocole Internet (TCP/IP), puis cliquez sur Propriétés.

  4. Cliquez sur Paramètres avancés.

  5. Sous l'onglet DNS, sélectionnez une adresse de serveur DNS, puis cliquez sur Supprimer. Répétez cette étape pour chaque adresse de serveur DNS répertoriée.

  6. Désactivez les cases à cocher Enregistrer les adresses de cette connexion dans le système DNS et Utiliser le suffixe DNS de cette connexion pour l'enregistrement DNS.

  7. Cliquez trois fois sur OK pour enregistrer les modifications.

  8. Répétez les étapes 1 à 7 pour chaque nœud du cluster.

Pour plus d'informations sur les paramètres recommandés pour le réseau privé dans un cluster de serveurs Windows, voir l'article 258750 de la Base de connaissances Microsoft sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


La connexion de pulsation dispose d'une adresse WINS
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapter pour déterminer la valeur de la clé NetConnectionID. Si la valeur de la clé NetConnectionID contient la chaîne Internal ou HEART, cela indique que l'interface est le réseau privé de cluster (pulsation).

Exchange Server Analyzer interroge également la classe WMI Win32_NetworkAdapterConfiguration pour déterminer si une valeur est définie pour la clé WINSPrimaryServer. Si une valeur est définie, cela indique qu'une adresse WINS (Windows Internet Name Service) principale a été configurée pour cette interface réseau.

Si Exchange Server Analyzer détecte une valeur définie pour la clé WINSPrimaryServer sur l'interface réseau utilisée pour le réseau de pulsation de cluster, un avertissement s'affiche.

Comme les réseaux de cluster privés sont utilisés pour les communications internes du cluster, vous ne devez pas configurer de serveur WINS, ni utiliser NetBIOS. Pour éliminer d'éventuels problèmes de communication, il est conseillé de supprimer tout trafic réseau inutile de la carte réseau utilisée comme carte réseau privé de cluster.

Pour supprimer cet avertissement

  1. Ouvrez la fenêtre Connexions réseau. Cliquez avec le bouton droit sur Favoris réseau, puis cliquez sur Propriétés ou, si Favoris réseau n'est pas affiché sur le Bureau, cliquez sur Démarrer, Programmes, Accessoires, Communications et enfin sur Connexions réseau.

  2. Dans la fenêtre Connexions réseau, cliquez avec le bouton droit sur la carte réseau utilisée pour le réseau privé, puis cliquez sur Propriétés.

  3. Sélectionnez Protocole Internet (TCP/IP), puis cliquez sur Propriétés.

  4. Cliquez sur Paramètres avancés.

  5. Sous l'onglet WINS, sélectionnez une adresse WINS, puis cliquez sur Supprimer. Répétez cette étape pour chaque adresse WINS répertoriée.

  6. Dans la zone de paramètre NetBIOS, sélectionnez Désactiver NetBIOS avec TCP/IP.

  7. Cliquez trois fois sur OK pour enregistrer les modifications. Lorsque vous avez cliqué une première fois sur OK, l'invite suivante peut s'afficher. Dans ce cas, cliquez sur Oui : "Cette connexion possède une adresse de serveur WINS principale vide. Voulez-vous continuer ? »

  8. Répétez les étapes 1 à 7 pour chaque nœud du cluster.

Pour plus d'informations sur les paramètres recommandés pour le réseau privé dans un cluster de serveurs Windows, voir l'article 258750 de la Base de connaissances Microsoft sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


La connexion de pulsation occupe la première place dans l'ordre de liaison TCP/IP contrairement à la connexion publique
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft pour effectuer les opérations suivantes :

  • La classe WMI Win32_NetworkConfiguration est interrogée pour déterminer la valeur de la clé SettingID pour toutes les interfaces réseau du cluster. La valeur de la clé SettingsID est un GUID qui représente une carte réseau unique.

  • La classe WMI Win32_NetworkAdapter est interrogée pour déterminer les cartes réseau utilisées pour les communications du réseau privé dans un cluster Exchange. Le réseau privé est utilisé pour les communications internes du cluster, notamment la pulsation de cluster.

  • Exchange Server Analyzer examine également la valeur de Registre suivante pour déterminer l'ordre de liaison des cartes réseau :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

La valeur de Registre Bind est une valeur de chaînes multiples qui contient une liste de cartes réseau dans l'ordre de liaison. La première entrée de la liste est la première carte réseau liée, la deuxième entrée est la deuxième carte réseau dans l'ordre de liaison, etc.

Si Exchange Server Analyzer détermine que la carte réseau de pulsation de cluster est la première dans l'ordre de liaison, un avertissement s'affiche.

Pour résoudre ce problème, veillez à ce que la carte réseau public soit la première liaison en tête de la liste de liaison. Si vous disposez de plusieurs cartes réseau public, veillez à ce que la carte réseau de pulsation privé soit la dernière de la liste. Si la carte réseau de pulsation est en tête de la liste, elle peut empêcher l'installation correcte des Service Packs et mises à niveau.

Pour supprimer cet avertissement

  1. Dans la fenêtre Connexions réseau, cliquez sur Avancé, puis sur Paramètres avancés.

  2. Cliquez sur l'onglet Cartes et liaisons.

  3. Dans le champ Connexions, sélectionnez la carte réseau privé et utilisez la flèche vers le bas pour déplacer la carte réseau privé vers le bas de la liste.

  4. Répétez ces étapes pour chaque nœud du cluster.

Pour plus d'informations sur la configuration réseau optimale des clusters de serveurs Windows, voir le livre blanc sur les clusters de serveurs et la configuration réseau recommandée pour Windows 2000 et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=34304).

Pour plus d'informations sur la configuration correcte du réseau de pulsation de cluster, voir l'article 258750 de la Base de connaissances Microsoft sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


La vitesse du réseau de pulsation est définie sur « Détection automatique »
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapter pour déterminer la valeur de la clé NetConnectionID. Si la valeur de la clé NetConnectionID contient la chaîne Internal ou HEART, cela indique que l'interface est le réseau privé de cluster (pulsation).

Exchange Server Analyzer lit également la valeur de Registre suivante pour déterminer la vitesse de liaison et les paramètres duplex pour la carte d'interface réseau utilisée pour le réseau de pulsation de cluster :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<NetworkCardDeviceID>\SpeedDuplex

En outre, Exchange Server Analyzer lit également la valeur de Registre suivante pour déterminer si la détection automatique de la vitesse du réseau est activée :

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

Si la valeur de la clé 0 contient la chaîne AUTO, cela signifie que la détection automatique de la vitesse du réseau est activée.

Si Exchange Server Analyzer détermine que SpeedDuplex est défini sur 0 et que la détection automatique de la vitesse du réseau est activée pour le réseau de pulsation de cluster, un avertissement s'affiche.

La communication entre nœuds de cluster de serveurs est essentielle pour le bon déroulement des opérations de cluster. Si vous utilisez une carte réseau Ethernet à plusieurs vitesses pour des communications de cluster et configurez la carte pour qu'elle détecte automatiquement la vitesse du réseau, elle peut provoquer des problèmes au sein du cluster. Pendant le processus de détection, les paquets ne peuvent pas être traités par la carte et doivent être placés dans la file d'attente. Certaines cartes peuvent involontairement déclencher le processus de détection automatique à tout moment. Par conséquent, les communications sont placées dans la file d'attente et la communication est retardée. Les retards de ce type peuvent empêcher les nœuds de cluster de recevoir rapidement les paquets critiques et provoquer un basculement des ressources de cluster. Il est recommandé de définir manuellement le réseau de pulsation d'un cluster sur 10 mégabits et semi-duplex. Cette configuration offre suffisamment de bande passante et une communication fiable.

Pour supprimer cet avertissement

  • Configurez la carte d'interface réseau de pulsation pour une vitesse de liaison de 10 mégabits et le paramètre duplex sur semi-duplex. Étant donné que les étapes de configuration sont différentes pour chaque carte réseau, respectez les instructions de votre fournisseur de matériel pour configurer correctement le réseau de pulsation. La configuration de ces options peut nécessiter la mise à jour du pilote.

Pour plus d'informations sur les paramètres recommandés pour le réseau privé dans un cluster de serveurs Windows, voir l'article 258750 de la Base de connaissances Microsoft sur la configuration de carte réseau privé recommandée sur Cluster Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


La profondeur de file d'attente HBA (Host Bus Adapter) est définie sur 32
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2006-10-11

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la profondeur de file d'attente HBA (Host Bus Adapter) installée sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

Si Exchange Server Analyzer détecte que la valeur de DriverParameter est définie sur 32, un avertissement s'affiche.

Un HBA est un contrôleur de disque pour les réseaux SAN (Storage Area Network). La profondeur de file d'attente HBA définit le nombre maximal de demandes de file d'attente en suspens. Généralement, la valeur recommandée pour DriverParameter est 128. Toutefois, il ne s'agit peut-être pas de la valeur optimale de profondeur de file d'attente HBA pour chaque HBA dans chaque ordinateur Exchange Server. Par conséquent, vous devez consulter le fabricant du HBA pour obtenir la valeur optimale pour votre matériel spécifique.

Pour supprimer cet avertissement

  1. Contactez votre fabricant de matériel pour déterminer le paramètre optimal pour vos HBA.

  2. Surveillez les performances du disque à l'aide de l'utilitaire Moniteur système de Microsoft Windows®.

  3. Effectuez la mise à jour de votre matériel HBA vers les microprogrammes et pilotes les plus récents.

Pour plus d'informations sur l'optimisation et la conception du stockage d'Exchange Server, voir le document sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=49324).


Configuration d'ajout de mémoire à chaud
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2006-02-22

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Computer System pour déterminer si le serveur offre des possibilités d'ajout de mémoire à chaud. Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer :

  • si l'option /3GB est activée dans le fichier Boot.ini ;

  • si le noyau des extensions d'adresse physique (PAE) est chargé ;

  • la version du système d'exploitation du serveur.

Enfin, Exchange Server Analyzer interroge l'entrée de Registre suivante pour déterminer si le paramètre de configuration DynamicMemory existe et est correctement défini :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Si Exchange Server Analyzer détermine que tous les critères suivants sont vrais, un message d'erreur s'affiche :

  • L'ordinateur prend en charge l'ajout de mémoire à chaud et, par défaut, la fonctionnalité est activée.

  • L'ordinateur utilise Microsoft Windows Server™ 2003 Édition Entreprise ou Windows Server 2003 Édition Datacenter.

  • Le noyau PAE est chargé.

  • L'option /3GB est activée dans Boot.ini.

  • Le paramètre de configuration du Registre DynamicMemory n'est pas défini, est défini sur une valeur de 0 ou supérieure à 3.

Remarque :
Si l'ordinateur prend en charge l'ajout de mémoire à chaud, mais que le fabricant de matériel désactive la fonctionnalité par défaut, Exchange Server Analyzer affiche un message d'avertissement plutôt qu'un message d'erreur.

La fonctionnalité d'ajout de mémoire à chaud a été introduite dans Windows Server 2003 Édition Entreprise et Windows Server 2003 Édition Datacenter pour permettre aux administrateurs système d'ajouter de la mémoire physique à un ordinateur sans le redémarrer. Cette fonctionnalité s'avère utile sur les serveurs qui prennent en charge des applications de base de données à forte intensité de mémoire, comme Microsoft SQL Server. Toutefois, Exchange Server ne pouvant pas utiliser plus de 4 Go de mémoire physique, cette fonctionnalité ne lui est d'aucune utilité.

Tous les ordinateurs ne prennent pas en charge l'ajout de mémoire à chaud. Dans le cas des ordinateurs offrant cette fonctionnalité, certains fabricants l'activent par défaut, tandis que d'autres offrent des contrôles au sein du BIOS (Basic Input Output System). Si, pendant le processus d'amorçage, l'ajout de mémoire à chaud est activé, le noyau du système d'exploitation doit pré-allouer de l'espace afin de tenir compte de la mémoire future susceptible d'être ajoutée à l'ordinateur. Les ressources du noyau sont donc allouées en fonction des capacités de l'ordinateur plutôt que du matériel effectivement installé. La mémoire du noyau est une ressource précieuse sur les ordinateurs qui exécutent Microsoft Exchange Server. Étant donné que le noyau peut allouer d'importantes quantités de ressources à de la mémoire qui peut ne jamais être installée et compte tenu de la nature de la mémoire physique utilisée par Exchange Server, il est possible de bénéficier de performances et d'une évolutivité accrues en désactivant la fonctionnalité d'ajout de mémoire à chaud. Laisser la fonctionnalité activée risque de limiter la taille maximale de la mémoire de réserve paginée à une valeur nettement inférieure à celle attendue. Cela peut entraîner une importante altération des performances, des blocages du système et, finalement, un arrêt du service.

Exemples de tailles maximales de mémoire de réserve paginée attendues (plus la taille est importante, mieux c'est) :

  • 240 Mo Ordinateur qui dispose de 4 Go de mémoire physique sans prise en charge de l'ajout de mémoire à chaud ou avec cette fonctionnalité désactivée

  • 210 Mo Ordinateur qui dispose de 4 Go de mémoire physique, mais peut prendre en charge jusqu'à 32 Go de mémoire ajoutée à chaud

  • 160 Mo Ordinateur qui dispose de 4 Go de mémoire physique, mais peut prendre en charge jusqu'à 64 Go de mémoire ajoutée à chaud

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour résoudre ce problème sur des ordinateurs qui exécutent Windows Server 2003 Service Pack 1 (SP1) ou version ultérieure

  1. Définissez le paramètre de Registre suivant pour désactiver la fonctionnalité d'ajout de mémoire à chaud :

    Chemin d'accès

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Valeur

    DynamicMemory

    Type

    REG_DWORD

    Données

    0x1
    Remarque :
    La valeur de ce paramètre de configuration est exprimée sous la forme du nombre de giga-octets de mémoire physique maximale disponible, notamment la mémoire à chaud, si la mémoire physique installée au moment du démarrage n'est pas supérieure. Si vous définissez la valeur sur 1, le noyau réserve de l'espace pour un total de 1 Go de mémoire système ou pour la quantité totale de mémoire physique installée au moment de l'amorçage, selon celle de ces deux valeurs qui est la plus élevée.

  2. Redémarrez l'ordinateur
Pour résoudre ce problème sur des ordinateurs qui exécutent Windows Server 2003 sans SP1 installé

  • Contactez le fournisseur de votre matériel pour déterminer s'il est possible de désactiver la fonctionnalité d'ajout de mémoire à chaud dans le BIOS.

  • Si l'ajout de mémoire à chaud ne peut pas être contrôlé par le biais du matériel, l'approche recommandée consiste à effectuer une mise à niveau vers Windows Server 2003 SP1 et à suivre les étapes de résolution présentées ici pour définir le paramètre DynamicMemory. Si vous ne pouvez pas effectuer de mise à niveau vers le SP1, l'autre solution consiste à définir l'option /NOPAE dans le fichier Boot.ini. L'activation de cette option forcera l'ordinateur à ne pas reconnaître la mémoire située au-delà de la limite de 4 Go. Optez pour cette solution sur les ordinateurs qui exécutent Windows Server 2003 pré-SP1. Toutefois, il convient de ne pas l'utiliser sur les ordinateurs SP1 car elle est susceptible de désactiver involontairement de nouvelles fonctionnalités, telles que la prise en charge DEP (Data Execution Prevention).

Pour plus d'informations

Pour plus d'informations sur la prise en charge de l'ajout de mémoire à chaud dans Windows Server 2003, voir le document correspondant (http://go.microsoft.com/fwlink/?linkid=57183).


Le logiciel Internet SCSI Initiator est obsolète
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2006-04-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_SCSIController pour déterminer la valeur de la clé DriverName pour le pilote iScsciPrt. Exchange Server Analyzer interroge également la classe WMI CIM_Datafile pour déterminer la valeur de la clé Version répertoriée dans le fichier du pilote iScsciPrt. Si Exchange Server Analyzer trouve une valeur de sous-chaîne inférieure à 1748 dans la clé Version du pilote iScsciPrt, un message d'avertissement s'affiche.

Le protocole iSCSI est une méthode basée sur le protocole Internet (IP) conçue pour transférer des commandes SCSI encapsulées dans des paquets IP sur les réseaux TCP/IP. Étant donné que le protocole iSCSI se base sur le protocole IP, des données peuvent être transmises à des emplacements de stockage éloignés via des réseaux locaux (LAN), étendus (WAN) et via Internet. Dans le cadre de programmes comme Exchange Server 2003 ou Exchange 2000 Server, les systèmes d'exploitation Microsoft Windows font apparaître des disques durs iSCSI comme les disques durs connectés directement à l'ordinateur Exchange Server.

Microsoft vous recommande de faire preuve de prudence en déployant Exchange Server 2003 avec iSCSI ou Exchange 2000 Server avec iSCSI. Étant donné que le système iSCSI utilise le protocole de transport SCSI pour transmettre des blocs de données par le biais de réseaux TCP/IP, la participation d'un réseau peut entraîner la présence de composants n'étant pas généralement considérés comme des chemins d'accès d'entrée/de sortie rapides. Pour maximiser le débit, configurez Exchange Server pour optimiser les activités de mise en cache et procédez à un test pour vérifier que la latence liée au trafic iSCSI est limitée. Sauf indication contraire de votre fournisseur de solutions de stockage, il est également vivement conseillé d'utiliser la dernière version disponible de Microsoft iSCSI Software Initiator.

Pour supprimer cet avertissement

  1. Téléchargez la dernière version de Microsoft iSCSI Software Initiator à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=33817).

  2. Voir les notes de mise à jour sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=40951).

  3. Voir le Guide de l'utilisateur sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=40963).

  4. Effectuez une sauvegarde complète de l'ordinateur.

  5. Appliquez la dernière mise à jour de la version.

Pour plus d'informations sur la prise en charge iSCSI dans Exchange 2000 Server et Exchange Server 2003, voir l'article 839686 de la Base de connaissances Microsoft sur la prise en charge de composants technologiques iSCSI dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686).

Pour plus d'informations sur la technologie iSCSI et sa prise en charge par Microsoft, voir la rubrique sur les technologies de stockage iSCSI sur le site Web de Microsoft (http://go.microsoft.com/fwlink/?LinkId=27514).


Les compteurs de performances des disques logiques et physiques sont désactivés
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les compteurs de performance des disques logiques et physiques sont désactivés :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

Si Exchange Server Analyzer détecte que la valeur de Disable Performance Counters est présente et configurée avec une valeur de 1, un avertissement s'affiche.

Il existe deux types de compteurs de performance relatifs aux disques publiés sur un ordinateur serveur utilisant le système d'exploitation Microsoft Windows® :

  • Ceux utilisés par le sous-système de performances Microsoft Win32® et WMI (Windows Management Instrumentation).

  • Ceux utilisés par des applications existantes qui exécutent l'API IOCTL_DISK_PERFORMANCE pour récupérer des informations de compteurs bruts.

  • Les compteurs de performance utilisés par Win32 et WMI sont activés par défaut sur Microsoft Windows Server™ 2003 et Windows 2000 Server. Les compteurs bruts sont désactivés par défaut sur les deux systèmes d'exploitation. Si la valeur de Registre Disable Performance Counters, qui n'est présente par défaut sur aucun système d'exploitation, est ajoutée et configurée avec une valeur de 1, les compteurs de performance Win32/WMI sont désactivés et la collecte des données de performances de ces compteurs ne peut pas être accomplie.

La manière la plus courante de désactiver les compteurs Win32/WMI consiste à utiliser l'outil Extensible Counter List (ExCtrLst.exe). Cet outil graphique, disponible avec les kits de ressources Windows 2000 Server et Windows Server 2003, permet à un administrateur d'activer et de désactiver sélectivement la publication d'objets de performance. Lorsqu'ExCtrLst.exe est utilisé pour désactiver un objet de performance, il ajoute l'entrée Disable Performance Counters au Registre et la configure avec une valeur de 1. S'il est ensuite utilisé pour réactiver un compteur désactivé, il remplace la valeur de Disable Performance Counters par 0 (remarquez qu'il ne supprime pas l'entrée Disable Performance Counters).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance

  3. Dans le volet droit, double-cliquez sur Disable Performance Counters et définissez-la sur la valeur 0. Vous pouvez également supprimer l'entrée Disable Performance Counters pour réactiver les compteurs.

  4. Quittez l'Éditeur du Registre et redémarrez n'importe quelle application qui collecte des données de performances pour que la modification soit prise en compte.

Pour plus d'informations sur lExCtrLst.exe, voir l'article sur l'outil Exctrlst.exe (Extensible Performance Counter List) (http://go.microsoft.com/fwlink/?linkid=34436).


Passerelles multiples par défaut détectées
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour déterminer le nombre d'instances de la clé DefaultIPGateway. Chaque carte réseau publie sur WMI son adresse de passerelle configurée par défaut via cette clé. Si Exchange Server Analyzer détermine qu'il existe plusieurs instances configurées de la clé DefaultIPGateway, un avertissement s'affiche.

Cet avertissement indique que plusieurs cartes réseau ont été trouvées et que plusieurs de ces cartes présentent une passerelle configurée par défaut. Lorsque plusieurs cartes sont utilisées et configurées avec des passerelles par défaut distinctes, la connectivité des ordinateurs sur des réseaux distants risque d'être perdue. En outre, l'utilisation de passerelles multiples par défaut qui lient différents sous-réseaux de réseaux est connue pour créer des problèmes de résolution DNS (Domain Name System), de remise des messages SMTP (Simple Message Transfer Protocol), de requêtes LDAP (Lightweight Directory Access Protocol) et de nouvelles notifications de messagerie aux clients Microsoft Office Outlook® 2003. La plupart de ces problèmes peuvent empêcher Exchange Server de démarrer ou d'envoyer et de recevoir des messages.

Il est recommandé de supprimer toutes les passerelles par défaut et d'en laisser une sur l'une des cartes d'interface réseau de l'ordinateur Exchange Server. Les ordinateurs Exchange Server sont souvent multirésidents lorsque Microsoft ISA (Internet Security and Acceleration) Server a été installé sur le même ordinateur. Même lorsque vous exécutez Exchange Server et ISA Server sur le même ordinateur, l'utilisation de passerelles multiples par défaut n'est pas recommandée. Si Exchange Server et ISA Server ne sont pas installés sur le même ordinateur, il est recommandé de ne pas héberger un ordinateur Exchange Server de manière multiple.

Pour supprimer cet avertissement

  1. Ouvrez la fenêtre Connexions réseau. Cliquez avec le bouton droit sur Favoris réseau, puis cliquez sur Propriétés ou, si Favoris réseau n'est pas affiché sur le Bureau, cliquez sur Démarrer, Programmes, Accessoires, Communications et enfin sur Connexions réseau.

  2. Dans la fenêtre Connexions réseau, cliquez avec le bouton droit sur la connexion réseau contenant l'entrée de passerelle par défaut à supprimer, puis cliquez sur Propriétés.

  3. Sélectionnez Protocole Internet (TCP/IP), puis cliquez sur Propriétés.

  4. Supprimez l'adresse IP du champ Passerelle par défaut.

  5. Cliquez deux fois sur OK pour enregistrer les modifications.

  6. Répétez cette procédure pour toutes les autres connexions réseau qui contiennent l'entrée de passerelle par défaut, sauf pour l'entrée à conserver.

Pour plus d'informations sur les problèmes rencontrés sur des ordinateurs utilisant des passerelles multiples par défaut, voir l'article 159168 de la Base de connaissances Microsoft sur les passerelles multiples par défaut qui peuvent être à l'origine de problèmes de connectivité (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159168).

Pour plus d'informations sur la configuration des passerelles par défaut sur des ordinateurs multirésidents, voir l'article 157025 de la Base de connaissances sur la configuration de passerelles par défaut pour les ordinateurs multirésidents (http://go.microsoft.com/fwlink/?linkid=3052&kbid=157025).


Taille de fichier d'échange supérieure à la mémoire physique totale
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2007-07-30

L'outil Microsoft Exchange Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Win32_PageFile pour déterminer la valeur de la clé MaximumSize. Cette clé représente la taille maximale actuelle du fichier d'échange configuré.

Exchange Analyzer interroge également la classe WMI Win32_ComputerSystem pour déterminer la valeur définie pour la clé TotalPhysicalMemory. Cette valeur représente la quantité de RAM installée sur l'ordinateur.

Si Exchange Analyzer détermine que la valeur de la clé MaximumSize Win32_PageFile est supérieure à 1,5 fois la valeur de la clé Win32_ComputerSystem TotalPhysicalMemory, une erreur s'affiche.

Le fichier d'échange (pagefile.sys) est un fichier caché sur le disque dur utilisé par Windows pour conserver des données temporaires lorsque le système dispose de peu de RAM. Le fichier d'échange est également appelé fichier de pagination. La mémoire virtuelle est constituée de fichiers d'échange et de RAM.

La taille recommandée de fichier d'échange équivaut à 1,05 fois la quantité de RAM et peut atteindre un maximum de 4 095 Mo. Cela signifie que la taille la plus importante du fichier de pagination par volume que vous pouvez définir est de 4 095 Mo.

Remarque :
Pour éviter une fragmentation du fichier d'échange, il est conseillé de définir les mêmes valeurs maximales et initiales pour la taille du fichier de pagination. Si vous réduisez la taille des paramètres initiaux ou maximaux du fichier d'échange, vous devez redémarrer votre ordinateur pour voir les effets de ces modifications. En général, si vous augmentez la taille, vous ne devez pas redémarrer l'ordinateur.
Pour modifier les paramètres de fichier d'échange

  1. Cliquez sur Démarrer, Panneau de configuration, puis sur Système.

  2. Sous l'onglet Avancé, cliquez sur Paramètres dans Performances.

  3. Dans la boîte de dialogue Options de performance, sous l'onglet Avancé, sous Mémoire virtuelle, cliquez sur Modifier.

  4. Sous Lecteur [Nom de volume], cliquez sur le lecteur qui contient le fichier de pagination que vous souhaitez modifier.

  5. Sous Taille du fichier d'échange pour le lecteur sélectionné, cliquez sur Taille personnalisée et entrez la taille du fichier d'échange recommandée en mégaoctets dans les champs Taille initiale (Mo) et Taille maximale (Mo) et cliquez sur Définir.

Pour plus d'informations sur les fichiers d'échange, voir les articles suivants de la Base de connaissances Microsoft :

  • 197379 sur la configuration des fichiers de pagination à des fins d'optimisation et de récupération dans Windows Server 2003, Windows 2000 et Windows NT (http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379)

  • 307973 sur la procédure de configuration des options de défaillance du système et de récupération dans Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973)

  • 254649 sur la présentation des options de fichier d'image mémoire de Windows Server 2003, Windows XP et Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649)

  • 241046 sur l'impossibilité de créer un fichier Memory.dmp sur des ordinateurs de plus de 4 Go de RAM (http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046)


L'adresse du serveur secondaire WINS est vide
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour déterminer si une valeur est définie pour la clé WINSSecondaryServer. Si la valeur de cette clé sur un serveur Exchange est vide, un avertissement s'affiche.

Exchange Server 2003 et Exchange 2000 Server possèdent plusieurs dépendances NetBIOS. En outre, les clients utilisant les versions Microsoft Outlook® antérieures à Microsoft Office Outlook 2003 nécessitent également une résolution de nom NetBIOS. Par exemple, la fonctionnalité Exchange suivante dépend de la résolution de nom NetBIOS :

  • Les programmes d'installation d'Exchange Server 2003 et Exchange 2000 Server, notamment sur les serveurs en clusters.

  • L'utilitaire ExMerge (Exchange Mailbox Merge Wizard) sur un ordinateur Exchange Server 2003 ou Exchange 2000 Server.

  • La modification d'un mot de passe pour une boîte aux lettres Exchange Server 2003 ou Exchange 2000 Server via Outlook Web Access.

  • Le Gestionnaire système Exchange sur un ordinateur Exchange Server 2003 ou Exchange 2000 Server.

Selon la topologie du réseau de votre organisation, vous pourrez peut-être ignorer cet avertissement en toute sécurité. Sur les réseaux constitués d'un sous-réseau NetBIOS unique, les diffusions peuvent généralement gérer les exigences de résolution de nom NetBIOS dans un déploiement Exchange.

Dans les grandes organisations, la résolution de nom NetBIOS via des diffusions risque de ne pas fonctionner correctement. Étant donné que les diffusions NetBIOS ne traversent généralement pas les sous-réseaux, les réseaux routés nécessitent une autre méthode de résolution des noms NetBIOS. La méthode privilégiée est WINS (Windows Internet Name Service). WINS fournit une base de données distribuée pour l'inscription et la requête de mappages dynamiques des noms NetBIOS pour les ordinateurs et les groupes utilisés sur votre réseau. WINS mappe les noms NetBIOS sur des adresses IP et a été conçu pour résoudre les problèmes inhérents à la résolution de nom NetBIOS dans les environnements routés. WINS constitue le choix le plus approprié pour la résolution de nom NetBIOS dans les réseaux routés utilisant NetBIOS sur TCP/IP.

Les opérations et fonctions d'Exchange Server 2003 et Exchange 2000 Server n'ont pas été entièrement testées dans des organisations de grande taille ou utilisant des sous-réseaux sans WINS. Microsoft invite les sociétés utilisant Exchange sur des réseaux routés ou segmentés à utiliser WINS pour la résolution de nom NetBIOS. L'exécution d'Exchange dans un environnement routé ou segmenté sans WINS n'est pas prise en charge.

Il est recommandé de déployer un environnement WINS tolérant aux pannes incluant au moins deux serveurs WINS. Les serveurs WINS peuvent faire office de serveur principal ou secondaire pour un client. La différence entre les serveurs WINS principaux et secondaires est la priorité avec laquelle les clients les contactent. Un serveur WINS principal est le premier serveur qu'un client contacte pour effectuer ses opérations de service de nom NetBIOS. Un client contacte un serveur WINS secondaire uniquement lorsqu'un serveur WINS principal ne peut pas répondre à la requête, par exemple s'il n'est pas disponible au moment de la requête ou s'il ne peut pas résoudre un nom pour le client.

Si un serveur WINS principal ne répond pas à une requête, le client effectue la même requête auprès du serveur WINS secondaire. Si plusieurs serveurs WINS sont configurés pour le client, celui-ci essaie les serveurs WINS secondaires supplémentaires jusqu'à l'épuisement de la liste ou jusqu'à ce que l'un des serveurs WINS réponde favorablement à la requête. Après l'utilisation d'un serveur WINS secondaire, le client tente périodiquement de revenir au serveur WINS principal pour les futures requêtes de service de nom.

Il est recommandé de configurer au moins un serveur WINS secondaire sur les ordinateurs Exchange sur un réseau routé ou segmenté.

Pour supprimer cet avertissement

  1. Ouvrez les connexions réseau.

  2. Cliquez avec le bouton droit sur la connexion réseau à configurer, puis cliquez sur Propriétés.

  3. Sous l'onglet Général (pour une connexion au réseau local) ou Réseau (pour toutes les autres connexions), cliquez sur Protocole Internet (TCP/IP), puis sur Propriétés.

  4. Cliquez sur Avancé, sous l'onglet WINS, puis sur Ajouter.

  5. Dans Serveur WINS TCP/IP, entrez l'adresse IP d'un serveur WINS secondaire, puis cliquez sur Ajouter.

  6. Répétez les étapes 4 et 5 pour chaque adresse IP de serveur WINS supplémentaire à ajouter, puis cliquez sur OK. Vous pouvez modifier l'ordre de préférence des serveurs WINS à l'aide des flèches.

  7. Vérifiez que la case d'option Activer NetBIOS avec TCP/IP est activée.

  8. Cliquez sur OK pour enregistrer vos modifications.

Pour plus d'informations sur les exigences de résolution de nom NetBIOS pour Exchange, voir l'article 837391 de la Base de connaissances Microsoft sur la nécessité de résolution de nom NetBIOS pour une fonctionnalité totale sur Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391).


Le serveur est un PC virtuel
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2007-03-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur de la clé Model pour l'ordinateur Exchange Server. Si la valeur de cette clé contient la chaîne « Virtual Machine », une erreur s'affiche.

La présence de la chaîne « Virtual Machine » indique que l'ordinateur Exchange Server fonctionne sur un ordinateur virtuel Microsoft Virtual PC 200x. Virtual PC 200x est une solution d'ordinateur virtuel permettant d'exécuter plusieurs systèmes d'exploitation PC en même temps sur une seule station de travail. Microsoft ne prend pas en charge l'exécution des versions de Microsoft Exchange Server sur une machine virtuelle ou un émulateur. Cela s'applique à Exchange Server sur Microsoft Virtual Server 200x, Microsoft Virtual PC 200x ou tout programme tiers de machine virtuelle. Les plates-formes Microsoft Exchange Server sont conçues et testées pour n'être exécutées que sur un matériel physique, notamment les plates-formes matérielles répertoriées dans Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

Correction de cette erreur

  1. Déplacez les boîtes aux lettres du serveur Exchange Server sous Virtual PC 200x vers un ordinateur Exchange Server non virtuel.

  2. Associez tous les dossiers publics et transférez au besoin tous les rôles détenus par le serveur virtuel Exchange.

  3. Désinstallez Exchange de la machine virtuelle pour le désactiver et le supprimer de votre infrastructure Exchange et du service d'annuaire Active Directory®.

Pour plus d'informations sur l'assistance destinées aux ordinateurs Exchange Server fonctionnant dans des environnements virtuels, voir l'article 320220 de la Base de connaissances Microsoft sur la stratégie d'assistance d'Exchange Server 2003 s'exécutant sur un logiciel de virtualisation matérielle (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320220).

Pour plus d'informations sur Microsoft Virtual PC, voir la page d'accueil du site Web de Microsoft Virtual PC (http://go.microsoft.com/fwlink/?linkid=34663).


Ce disque signale une erreur
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_DiskDrive pour déterminer la valeur de la clé Status pour chaque disque. Si Exchange Server Analyzer détermine que la valeur de la clé Status pour tout disque est différente de OK, une erreur s'affiche.

La clé Status fournit l'état actuel de l'objet de disque. Plusieurs états opérationnels ou non peuvent être définis. Les états opérationnels sont les suivants :

  • OK

  • Détérioré

  • Échec prévu (un élément, comme un disque dur activé pour SMART, fonctionne correctement, mais une défaillance est prévue dans un futur proche)

  • Les états non opérationnels sont les suivants :

  • Erreur

  • Démarrage

  • Arrêt

  • Service (peut s'appliquer lors de la recréation d'un disque en miroir, le rechargement d'une liste d'autorisations d'utilisateur ou d'autres tâches administratives)

La clé Status est héritée de la classe WMI CIM_ManagedSystemElement, qui comprend les valeurs suivantes :

  • OK

  • Erreur

  • Détérioré

  • Inconnu

  • Échec prévu

  • Démarrage

  • Arrêt

  • Service

  • Dommages

  • Non récupération

  • Aucun contact

  • Communication perdue

Microsoft ne propose généralement pas de documentation sur le dépannage des problèmes de disque pour des fournisseurs de matériel spécifiques.

Pour corriger cette erreur

  1. Contrôlez toutes les connexions de disque et de câbles, patientez 10 minutes et vérifiez la valeur de Status.

  2. Si la valeur renvoyée n'est pas une valeur du mode de maintenance (par exemple, elle n'est pas égale à « Service », vous devez respecter la procédure de dépannage de disque recommandée par votre fabricant de disque dur. Dans certains cas, votre fabricant de disque dur peut vous proposer un logiciel de dépannage à installer pour analyser le problème.

Pour plus d'informations génériques de stockage lié à Exchange, voir l'article sur les solutions de stockage pour Microsoft Exchange 2000 Server dans le Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=1715)

Pour plus d'informations génériques de stockage liées à Microsoft Windows Server™ 2003, voir la page sur les services de stockage pour Windows Server 2003 dans le Centre technique de Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=33811).

Pour plus d'informations génériques de stockage liées à Windows 2000 Server, voir la page sur les services de stockage pour Windows 2000 dans le Centre technique de Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=33811).


Ce serveur Exchange dispose de plus de 8 processeurs
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur actuelle de NumberOfProcessors. Si Exchange Server Analyzer détecte que la valeur de NumberOfProcessors est supérieure à 8, un avertissement s'affiche. Toutefois, si ce serveur est configuré pour utiliser la technologie Hyper-Threading d'Intel, cet avertissement peut être ignoré en toute sécurité. La technologie Hyper-Threading active les applications logicielles multithread pour exécuter des threads en parallèle. Elle nécessite un système informatique comprenant un processeur Intel Pentium 4 qui prend en charge la technologie Hyper-Threading et une puce compatible à cette même technologie, BIOS et le système d'exploitation.

Exchange 2000 Server et Exchange Server 2003 ne peuvent utiliser de manière efficace que huit processeurs sur un ordinateur. Le service de banque d'informations de Microsoft Exchange est spécifiquement adapté pour un maximum de huit processeurs.

Sur les ordinateurs disposant de plus de huit processeurs, il est recommandé d'utiliser le partitionnement matériel pour partitionner l'ordinateur en plusieurs ordinateurs à huit processeurs ou à quatre processeurs. Vous pouvez également ne configurer l'affinité du processeur pour le processus de banque d'informations de Microsoft Exchange (Store.exe) que sur huit processeurs.

Dès que le processus de banque d'informations de Microsoft Exchange a été limité à huit processeurs via l'affinité du processeur ou via le partitionnement matériel, il est recommandé d'effectuer une mise à niveau vers le dernier Service Pack et correctifs cumulatifs d'Exchange. Cette opération est particulièrement importante si vous utilisez Exchange Server 2003.

Précédemment, les performances du serveur Exchange ont montré des améliorations marginales lorsque le nombre de processeurs sur les serveurs principaux augmente de plus de quatre. Avec plus de huit processeurs, l'augmentation des performances est marginale et ces dernières peuvent parfois diminuer. La décroissance dans le gain de performances avec les processeurs supplémentaires est plus prononcée avec les types de processeurs utilisés sur des ordinateurs plus récents. Avec Exchange Server 2003 Service Pack 1, l'évolutivité avec les processeurs supplémentaires est améliorée. Lorsque la technologie Hyper-Threading est activée, les serveurs à huit processeurs proposent une augmentation de 50 pour cent au niveau des performances par rapport aux serveurs à quatre processeurs. L'utilisation d'ordinateurs à huit processeurs pour des serveurs principaux est désormais appropriée dans de nombreux scénarios. Des serveurs biprocesseur sont recommandés pour les serveurs frontaux.

Comme susmentionné, si cet ordinateur Exchange Server utilise la technologie Hyper-Threading, cet avertissement peut être ignoré en toute sécurité.

Pour supprimer cet avertissement sur les systèmes qui n'utilisent pas la technologie Hyper-Threading

  1. Appliquez le dernier Service Pack et les correctifs cumulatifs pour Exchange Server que vous pouvez télécharger sur le site Web des téléchargements d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=25097).

  2. Définissez l'affinité du processeur pour le service de banque d'informations de Microsoft Exchange (Store.exe) sur huit processeurs ou utilisez le partitionnement matériel pour créer un serveur Exchange à huit processeurs. Contactez votre fabricant de matériel pour plus d'informations sur la manière de procéder.

Pour plus d'informations sur l'évolutivité des ressources d'Exchange Server, voir l'article de la Base de connaissances Microsoft sur l'évolutivité de la mémoire et du processeur pour Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281).

Pour plus d'informations, voir également l'article 271088 de la Base de connaissances sur l'optimisation des serveurs Windows 2000 Active Directory à six ou huit processeurs à utiliser avec Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088).

Pour plus d'informations sur la technologie Hyper-Threading, voir le site Web d'Intel (http://www.intel.com/info/hyperthreading).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Ce serveur Exchange dispose de plus de 4 Go de mémoire
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2006-06-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur de la clé TotalPhysicalMemory pour chaque ordinateur Exchange Server.

Si Exchange Server Analyzer détecte que la valeur de TotalPhysicalMemory est comprise entre 4294967296 et 6442450944, un avertissement s'affiche.

Si Exchange Server Analyzer détecte que la valeur de TotalPhysicalMemory est supérieure à 6442450944, une erreur s'affiche.

Une valeur de TotalPhysicalMemory supérieure à 4294967296 indique que l'ordinateur Exchange Server possède une mémoire de plus de 4 gigaoctets (Go) installée, alors qu'une valeur de TotalPhysicalMemory supérieure à 6442450944 indique que l'ordinateur Exchange Server possède une mémoire de plus de 6 Go installée. Sur un ordinateur dont la mémoire physique est égale ou supérieure à 4 Go, Exchange Server n'utilise pas plus de 3 Go. Par conséquent, s'il est uniquement destiné à l'exécution d'Exchange Server, il n'est pas utile d'y installer plus de 4 Go de mémoire.

De plus, plus la mémoire RAM physique est grande, plus il faut d'entrées d'adresse de noyau du système d'exploitation pour effectuer le mappage nécessaire de la mémoire virtuelle à la mémoire physique. Cette opération réduit les entrées dans la table des pages (PTE) système disponibles et la mémoire de réserve paginée disponible sur le système, ce qui peut entraîner une instabilité.

Par exemple, un ordinateur avec 8 Go de mémoire RAM physique aura 3 000 entrées dans la table des pages (PTE) système disponibles et 30 Mo de moins que la taille maximale de mémoire de réserve paginée qu'un ordinateur qui ne dispose que d'une mémoire RAM physique de 4 Go.

Il est recommandé de choisir l'une des solutions suivantes :

  • Réduire à 4 Go la quantité de mémoire disponible sur le système

  • Définir le paramètre BurnMemory dans le fichier Boot.ini pour réduire la mémoire physique à 4 Go, comme décrit plus loin dans cet article.

En outre, si vous exécutez plusieurs applications qui nécessitent la mémoire supplémentaire, vous pouvez exécuter un correctif Windows qui permettra d'empêcher les défaillances de la banque d'informations Exchange qui pourraient survenir lorsque la RAM disponible est supérieure à 4 Go. Notez qu'il est recommandé de consacrer un ordinateur exclusivement à l'exécution d'Exchange Server. Pour plus de détails sur le correctif, voir l'article 834628 de la Base de connaissances Microsoft sur l'endommagement des données si les extensions d'adresse physique sont activées sur un ordinateur Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052).

Pour supprimer cet avertissement

  1. Dans l'Explorateur Windows, naviguez jusqu'à la partition système.

  2. Si le fichier boot.ini n'est pas visible, cela peut signifier que les Options des dossiers sont définies sur Masquer les fichiers protégés du système d'exploitation (recommandé). Le cas échéant, dans l'Explorateur Windows, cliquez sur Outils, Options des dossiers, puis sur l'onglet Affichage. Désactivez la case à cocher Masquer les fichiers protégés du système d'exploitation (recommandé). Cliquez sur Oui dans la boîte d'avertissement qui s'affiche.

  3. Dès que le fichier boot.ini est visible dans l'Explorateur, cliquez avec le bouton droit sur le fichier, cliquez sur Ouvrir avec et choisissez Bloc-notes pour ouvrir le fichier.

  4. Dans la section [Systèmes d'exploitation], ajoutez le commutateur suivant à la ligne de démarrage : /BURNMEMORY=<Valeur en Mo>

    Par exemple :

    Si une mémoire physique de 6 Go est installée, /BURNMEMORY=2048 permet de réduire la mémoire disponible à 4 Go. Si une mémoire physique de 8 Go est installée, utilisez plutôt /BURNMEMORY=4096.

  5. Enregistrez les modifications et fermez le Bloc-notes.

  6. Redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur les paramètres utilisables dans le fichier Boot.ini, voir les articles suivants de la Base de connaissances Microsoft :

  • 833721 sur les options de commutateur disponibles pour les fichiers Boot.ini de Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052)

  • 102873 sur les conventions d'affectation de noms et l'utilisation des chemins BOOT.INI et ARC (http://go.microsoft.com/fwlink/?linkid=3052)


Ce disque logique a moins de 3 Go d'espace disponible
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2007-03-14

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32 LogicalDisk pour déterminer la valeur de la clé FreeSpace pour les disques dont la clé Win32 LogicalDisk DriveType est définie sur 3 (ce qui indique un disque local). Si la valeur de la clé FreeSpace pour un disque local sur un ordinateur Exchange Server est inférieure à 3 Go, un avertissement s'affiche. Il est recommandé que tous les disques des ordinateurs Exchange Server qui contiennent des boîtes aux lettres disposent en permanence d'une capacité de mémoire disponible d'au moins 50 %.

Disposer de capacités de disque suffisantes est essentiel. Lorsqu'un disque de base de données n'a plus d'espace disque, la base de données est hors connexion. Lorsqu'un disque de journal des transactions n'a plus d'espace disque, toutes les bases de données de ce groupe de stockage sont hors connexion. L'octroi d'espace supplémentaire n'est pas une tâche rapide à exécuter et la réalisation d'un compactage en mode hors connexion pour récupérer de l'espace peut être long. Dans la plupart des cas, le manque d'espace disque provoque une interruption de la disponibilité d'une ou plusieurs bases de données pour une durée qui dépasse généralement la plupart des objectifs de temps de récupération (RTO).

Pour supprimer cet avertissement

  1. Supprimez les fichiers inutiles de ce disque pour libérer de l'espace.

  2. Si le disque disposant de moins de 50 % d'espace disponible contient des données pouvant être déplacées sans risque vers un autre disque, telles que des boîtes aux lettres ou le fichier d'échange Windows, respectez la procédure de déplacement des données.

  3. Ajoutez de la capacité au disque de l'ordinateur Exchange Server.

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir l'article 821829 de la Base de connaissances Microsoft sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Pour plus d'informations sur le déplacement des boîtes aux lettres entre Exchange 2000 Server et Exchange Server 5.5, voir l'article 328810 de la Base de connaissances sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810)

Pour plus d'informations sur la définition des limites de boîtes aux lettres avec stratégie système sur Exchange Server 2003, voir l'article 822938 de la Base de connaissances sur l'utilisation de stratégies système pour configurer des limites de stockage de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938)

Pour plus d'informations sur la définition des limites de boîtes aux lettres avec stratégie système sur Exchange 2000 Server, voir l'article 319130 de la Base de connaissances sur l'utilisation de stratégies système pour configurer des limites de stockage de boîtes aux lettres dans Exchange 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130)

Pour plus d'informations sur :


Ce point de montage a moins de 3 Go d'espace disponible
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Volume pour déterminer la valeur de la clé FreeSpace pour les points de montage de volume utilisés par l'ordinateur Exchange Server. Si la valeur de FreeSpace est inférieure à 4 lorsqu'elle est divisée par 1 000 000 000 et arrondie au nombre entier le plus proche, un avertissement s'affiche.

Cet avertissement indique que l'espace disponible est inférieur à 3 gigaoctets (Go) pour un point de montage de volume. Dans Exchange Server 2003, les points de montage de volume (également appelés points de jonction du système de fichiers NTFS) sont pris en charge comme emplacement de stockage de données dans une configuration en clusters lorsqu'Exchange Server 2003 est installé sur un ordinateur Microsoft Windows Server™ 2003, Édition Entreprise ou Windows Server 2003, Édition Datacenter. La fonctionnalité de points de montage de volume NTFS permet de dépasser la limitation de 26 caractères pour les lecteurs. Les points de montage de volume permettent d'ajouter ou de monter une partition cible dans un dossier sur un autre disque physique. Les points de montage de volume sont transparents pour les programmes tels qu'Exchange Server 2003.

Les points de montage ne sont pas pris en charge dans les cas suivants :

  • Utilisation comme emplacement de stockage des fichiers binaires Exchange Server 2003.

  • Utilisation avec des clusters Exchange exécutant Microsoft Exchange 2000 Server ou une version antérieure.

  • Utilisation avec des clusters Windows exécutant Microsoft Windows 2000 Server ou une version antérieure.

Qu'un volume utilisé par Exchange Server soit un disque physique local, un volume logique ou un point de montage de volume, les meilleures pratiques spécifient que les implémentations d'Exchange Server doivent avoir au moins 50 pour cent d'espace disque disponible sur tous les lecteurs. En règle générale, Microsoft recommande un minimum de 25 à 30 pour cent d'espace disque disponible pour la maintenance d'Exchange, comme les tâches effectuées à l'aide d'utilitaires de base de données tels qu'Eseutil et Isinteg. En outre, pour certaines opérations de maintenance, telles que la défragmentation hors ligne, Microsoft recommande d'avoir un d'espace disponible équivalent à celui que vous défragmentez. Par exemple, si vous défragmentez une base de données de 1 Go, vous devez disposer d'un espace disque disponible d'au moins 1 Go.

Avoir un espace disque disponible important est également intéressant tant sur le plan de la sécurité que sur celui de la disponibilité. Une attaque par déni de service, une boucle de message ou la survenue d'un virus répandu peuvent provoquer une consommation excessive d'espace disque en raison de l'accroissement du trafic de messages, de l'activité du journal des transactions, etc.

Pour supprimer cet avertissement

  1. Examinez où vous pouvez récupérer de l'espace disque et augmenter l'espace disponible.

  2. Si l'espace disque est extrêmement réduit, vous devez envisager le déplacement des données sur un autre ordinateur Exchange Server ou un serveur virtuel Exchange dont l'espace n'est pas limité. Si ce n'est déjà fait, la définition de limites de boîtes aux lettres peut également s'avérer utile dans la gestion de l'utilisation du disque.

Pour plus d'informations sur l'utilisation de points de montage de volume dans un cluster Exchange Server 2003, voir l'article 318458 de la Base de connaissances Microsoft sur la prise en charge de point de montage de volume pour un cluster Exchange Server 2003 sur un système Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458).

Pour plus d'informations sur l'utilisation de points de montage de volume dans un Windows Server 2003, voir l'article de la Base de connaissances sur la procédure de configuration d'un point de montage de volume sur un serveur en clusters (http://go.microsoft.com/fwlink/?linkid=3052&kbid=280297).


Cette carte réseau est activée pour le DHCP
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour déterminer si une valeur est définie pour la propriété DHCPEnabled. Si cette propriété a une valeur de un (1) sur un serveur Exchange, une erreur s'affiche.

Il est possible d'exécuter Exchange sur une carte réseau activée pour le DHCP. Cette configuration n'est toutefois pas recommandée. L'exécution d'Exchange sur des ordinateurs activés pour le DHCP n'est pas conseillé car, en cas de défaillance ou d'interruption du service DHCP, Exchange peut arrêter de transmettre le courrier ou présenter un autre type de défaillance.

Il est recommandé de configurer tous les ordinateurs exécutant Exchange pour utiliser des adresses IP statiques.

Pour plus d'informations sur l'établissement de réseaux TCP/IP Windows, voir le site Web Microsoft TechNet relatif aux réseaux (http://go.microsoft.com/fwlink/?LinkId=33819).


L'adresse du serveur principal WINS est vide
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour déterminer si une valeur est définie pour la clé WINSPrimaryServer. Si Exchange Server Analyzer détecte que la valeur de cette clé sur un serveur Exchange est vide, un avertissement s'affiche.

Exchange Server 2003 et Exchange 2000 Server possèdent plusieurs dépendances NetBIOS. En outre, les clients utilisant des versions de Microsoft Outlook® antérieures à Microsoft Office Outlook 2003 nécessitent également une résolution de nom NetBIOS. Par exemple, la fonctionnalité Exchange suivante dépend de la résolution de nom NetBIOS :

  • Les programmes d'installation d'Exchange Server 2003 et Exchange 2000 Server, notamment sur les serveurs en clusters.

  • L'utilitaire ExMerge (Exchange Mailbox Merge Wizard) sur un ordinateur Exchange Server 2003 ou Exchange 2000 Server.

  • La modification d'un mot de passe pour une boîte aux lettres Exchange Server 2003 ou Exchange 2000 Server via Outlook Web Access.

  • Le Gestionnaire système Exchange sur un ordinateur Exchange Server 2003 ou Exchange 2000 Server.

Selon la topologie du réseau de votre organisation, vous pourrez peut-être ignorer cet avertissement en toute sécurité. Sur les réseaux constitués d'un sous-réseau unique, les diffusions NetBIOS peuvent généralement gérer les exigences de résolution de nom NetBIOS dans un déploiement Exchange.

Dans les grandes organisations, la résolution de nom NetBIOS via des diffusions risque de ne pas fonctionner correctement. Étant donné que les diffusions NetBIOS ne traversent généralement pas les sous-réseaux, les réseaux routés nécessitent une autre méthode de résolution des noms NetBIOS. La méthode privilégiée est WINS (Windows Internet Name Service). WINS fournit une base de données distribuée pour l'inscription et la requête de mappages dynamiques des noms NetBIOS pour les ordinateurs et les groupes utilisés sur votre réseau. WINS mappe les noms NetBIOS sur des adresses IP et a été conçu pour résoudre les problèmes dus à la résolution de nom NetBIOS dans des environnements routés. WINS constitue le choix le plus approprié pour la résolution de nom NetBIOS dans les réseaux routés utilisant NetBIOS sur TCP/IP.

Les opérations et fonctions d'Exchange Server 2003 et Exchange 2000 Server n'ont pas été entièrement testées dans des organisations de grande taille ou utilisant des sous-réseaux sans WINS. Microsoft invite les sociétés utilisant Exchange sur des réseaux routés ou segmentés à utiliser WINS pour la résolution de nom NetBIOS. L'exécution d'Exchange dans un environnement routé ou segmenté sans WINS n'est pas prise en charge.

Il est recommandé de déployer un environnement WINS tolérant aux pannes incluant au moins deux serveurs WINS. Les serveurs WINS peuvent faire office de serveur principal ou secondaire pour un client. La seule différence entre les serveurs WINS principaux et secondaires est la priorité avec laquelle les clients les contactent. Un serveur WINS principal est le premier serveur qu'un client contacte pour effectuer ses opérations de service de nom NetBIOS. Un client contacte un serveur WINS secondaire uniquement lorsqu'un serveur WINS principal ne peut pas répondre à la requête, par exemple s'il n'est pas disponible au moment de la requête ou s'il ne peut pas résoudre un nom pour le client.

Si un serveur WINS principal ne répond pas à une requête, le client effectue la même requête auprès du serveur WINS secondaire. Si plusieurs serveurs WINS sont configurés pour le client, celui-ci essaie les serveurs WINS secondaires supplémentaires jusqu'à l'épuisement de la liste ou jusqu'à ce que l'un des serveurs WINS réponde favorablement à la requête. Après l'utilisation d'un serveur WINS secondaire, le client tente périodiquement de revenir au serveur WINS principal pour les futures requêtes de service de nom.

Il est recommandé de configurer au moins un serveur WINS secondaire sur les ordinateurs Exchange sur un réseau routé ou segmenté.

Pour supprimer cet avertissement

  1. Ouvrez les connexions réseau.

  2. Cliquez avec le bouton droit sur la connexion réseau à configurer, puis cliquez sur Propriétés.

  3. Sous l'onglet Général (pour une connexion au réseau local) ou Réseau (pour toutes les autres connexions), cliquez sur Protocole Internet (TCP/IP), puis sur Propriétés.

  4. Cliquez sur Avancé, sous l'onglet WINS, puis sur Ajouter.

  5. Dans Serveur WINS TCP/IP, entrez l'adresse IP du serveur WINS, puis cliquez sur Ajouter.

  6. Répétez les étapes 4 et 5 pour chaque adresse IP de serveur WINS supplémentaire à ajouter, puis cliquez sur OK. Vous pouvez modifier l'ordre de préférence des serveurs WINS à l'aide des flèches.

  7. Vérifiez que la case d'option Activer NetBIOS avec TCP/IP est activée.

  8. Cliquez sur OK pour enregistrer vos modifications.

Pour plus d'informations sur les exigences de résolution de nom NetBIOS pour Exchange, voir l'article de la Base de connaissances sur la nécessité de résolution de nom NetBIOS pour une fonctionnalité totale sur Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391).


Serveur virtuel détecté
Microsoft Exchange Server Analyzer - Articles > Matériel >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur Virtual Machine.

Exchange Server Analyzer recherche également la présence de la valeur de Registre suivante :

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Si Exchange Server Analyzer détecte que la clé Model contient la chaîne Virtual Machine et que la branche de Registre ci-dessus existe, une erreur s'affiche.

Une valeur Virtual Machine pour la clé Model indique que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée sur Microsoft Virtual Server 2005 ou Microsoft Virtual PC 2004. La branche de Registre ci-dessus n'étant créée que par Virtual Server 2005, son existence signifie que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée dans Virtual Server 2005.

Microsoft ne prend pas en charge l'exécution des versions de Microsoft Exchange Server sur une machine virtuelle ou un émulateur. Cela s'applique à Exchange Server sur Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 ou tout programme tiers de machine virtuelle. Les plates-formes Microsoft Exchange Server sont conçues et testées pour n'être exécutées que sur un matériel physique, notamment les plates-formes matérielles répertoriées dans Microsoft Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

Pour corriger cette erreur

  1. Déplacez les boîtes aux lettres du serveur Exchange sous Virtual Server 2005 vers un ordinateur Exchange Server non virtuel.

  2. Associez tous les dossiers publics et transférez au besoin tous les rôles détenus par le serveur virtuel Exchange.

  3. Désinstallez Exchange de la machine virtuelle pour le désactiver et le supprimer de votre infrastructure Exchange et du service d'annuaire Active Directory®.

Pour plus d'informations sur le déplacement des boîtes aux lettres, voir les articles suivants de la Base de connaissances Microsoft :

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975 sur les différences entre les méthodes de transfert de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Pour plus d'informations sur Microsoft Virtual Server 2005, voir le site Web de Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?LinkId=34938).

Pour plus d'informations sur Microsoft Virtual PC 2004, voir le site Web de Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


Réseau
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails relatifs aux éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool en termes de réseau. Ils décrivent, en outre, les actions possibles pour corriger les erreurs liées au réseau, les avertissements et configurations autres que celles par défaut détectés par Exchange Server Analyzer.


L'enregistrement d'hôte DNS semble manquer
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2006-04-13

L'outil Microsoft® Exchange Server Analyzer Tool effectue une recherche DNS (Domain Name System) sur le serveur DNS pour récupérer l'enregistrement d'hôte (A) du serveur Exchange. Si l'opération de recherche DNS ne renvoie pas d'adresse IP, Exchange Server Analyzer affiche un avertissement indiquant que l'enregistrement d'hôte (A) semble manquer.

La recherche DNS de l'enregistrement d'hôte (A) de l'ordinateur Exchange Server 2003 peut échouer pour les raisons suivantes :

  • Le serveur DNS peut être arrêté ou ne pas répondre en raison d'une défaillance du réseau ou pour d'autres motifs.

  • L'enregistrement d'hôte (A) pour Exchange Server 2003 peut être manquant sur le serveur DNS car il n'est peut-être pas disponible ou correct ou parce que le serveur DNS n'est peut-être pas configuré pour autoriser les mises à jour dynamiques de l'enregistrement d'hôte.

Si le serveur DNS est arrêté, des retards de routage du courrier et d'autres échecs des services peuvent se produire.

Remarque :
Exchange Server 2003 utilise la résolution du nom d'hôte pour les systèmes de messagerie SMTP local et externe du réseau. La résolution du nom d'hôte se base principalement sur DNS et DNS est un service réseau essentiel. La défaillance d'un serveur DNS peut empêcher les utilisateurs de détecter votre système de messagerie. Active Directory et l'organisation Exchange Server 2003 ne peuvent pas fonctionner sans DNS. Les clients de messagerie interrogent DSN pour détecter les ressources internes, telles que les contrôleurs de domaine et les serveurs de boîtes aux lettres. D'autre part, Exchange Server 2003 utilise DNS pour récupérer les adresses IP (Internet Protocol) des contrôleurs de domaine pour les recherches d'annuaire et les hôtes SMTP (Simple Mail Transfer Protocol) externes lorsqu'Exchange Server 2003 envoie des messages à Internet.

Pour résoudre le problème, vérifiez que le serveur DNS est en cours d'exécution et que l'enregistrement d'hôte (A) est enregistré.

Pour vérifier que le serveur DNS est en ligne et que l'enregistrement d'hôte est présent

  1. Pour vérifier que le serveur DNS est en cours d'exécution, effectuez au moins l'une des étapes suivantes :

    • Examinez l'état du serveur DNS à l'aide du programme d'administration DNS sur le serveur DNS.

    • Redémarrez le serveur DNS. Pour plus d'informations, voir la rubrique sur le démarrage, l'arrêt, la mise en pause ou le redémarrage d'un serveur DNS (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Vérifiez le temps de réponse du serveur DNS à l'aide de nslookup. Pour plus d'informations, voir la rubrique sur la vérification du temps de réponse du serveur DNS à l'aide de la commande nslookup (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. nslookup permet de vérifier que l'enregistrement d'hôte (A) existe sur le serveur DNS. Pour plus d'informations, voir la rubrique sur la procédure de vérification de l'existence d'une ressource A dans DNS (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Si l'enregistrement de ressource d'hôte (A) n'existe pas, ajoutez ou modifiez manuellement l'enregistrement de la ressource A ou configurez le serveur DNS pour autoriser les mises à jour dynamiques de l'enregistrement.

    • Ajoutez manuellement un enregistrement de ressource A. Pour plus d'informations, voir la rubrique sur l'ajout d'un enregistrement de ressource à une zone DNS (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifiez manuellement un enregistrement de ressource A. Pour plus d'informations, voir la rubrique sur la modification d'un enregistrement de ressource existant (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Configurez le serveur DNS de sorte qu'il autorise les mises à jour dynamiques de l'enregistrement d'hôte. Pour plus d'informations, voir l'article 816592 de la Base de connaissances Microsoft sur la procédure de configuration de la mise à jour dynamique du DNS sous Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Pour plus d'informations sur l'utilisation de DNS par Exchange Server 2003 pour résoudre les adresses IP externes, voir la rubrique sur les dépendances de transport pour Exchange Server 2003 du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Pour plus d'informations sur la résolution de nom DNS, voir l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Pour plus d'informations sur la procédure de résolution des problèmes de DNS, voir la rubrique sur la résolution des problèmes de DNS (http://go.microsoft.com/fwlink/?LinkId=63003).

Pour plus d'informations sur la surveillance du système d'Exchange Server 2003, voir la rubrique sur la surveillance du système avec le pack de gestion d'Exchange Server 2003 du guide du pack de gestion d'Exchange Server 2003 pour MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573) (en anglais).

  • Pour plus d'informations sur les enregistrements de ressource d'hôte (A), voir la rubrique sur la gestion des enregistrements de ressource (http://go.microsoft.com/fwlink/?LinkId=63004).


Les réponses DNS sont différentes entre UDP et TCP
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2007-03-16

L'outil Microsoft Exchange Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour obtenir l'attribut DNSServerSearchOrder. Cet attribut est un groupe d'adresses IP de serveur utilisées dans l'interrogation de serveurs DNS (Domain Name System).

Après la récupération de l'adresse du serveur DNS principal, Exchange Analyzer tente d'exécuter une requête DNS sur des serveurs DNS configurés pour chaque serveur de service d'annuaire Active Directory. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une requête de résolution de nom TCP (Transmission Control Protocol) et UDP (User Datagram Protocol).

Si les requêtes de résolution de nom TCP et UDP sont réussies, Exchange Analyzer compare les réponses des reqûetes réussies. Si les réponses renvoyées des requêtes TCP et UDP ne sont pas les mêmes, Exchange Analyzer affiche un avertissement.

Cet avertissement indique qu'il peut y avoir des problèmes de configuration du serveur DNS qui affectent les performances du flux de messagerie.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Pour qu'Exchange Server remette un message Internet sortant via le service SMTP, le serveur DNS est utilisé comme suit :

  1. Un utilisateur interne envoie un message à un destinataire dans un domaine distant.

  2. Pour déterminer si le destinataire est local ou distant, le serveur virtuel SMTP sur le serveur Exchange de l'expéditeur utilise des fonctions de transport interne pour interroger le serveur de catalogue global afin d'obtenir l'adresse du destinataire. Si l'adresse du destinataire sur le message ne figure pas dans une stratégie de destinataire, celle-ci n'est pas stockée dans Active Directory ; par conséquent, Exchange détermine que le message est destiné à un domaine distant.

  3. Si nécessaire, le serveur Exchange remet le message au serveur virtuel SMTP approprié.

  4. Le serveur virtuel SMTP utilise ses informations de métabase IIS pour déterminer la méthode de remise d'un message à un domaine distant.

  5. Le serveur virtuel SMTP sur le serveur Exchange effectue ensuite l'une des deux actions suivantes :

    • Il utilise le serveur DNS pour vérifier l'adresse IP du domaine cible, puis tente de livrer le message.

    • Il transmet le message à un hôte actif chargé de la résolution DNS et de la remise du message.

Pour supprimer cet avertissement, suivez les instructions de l'article 820284 de la Base de connaissances Microsoft sur l'impossibilité de remettre le courrier à certains domaines si le système d'exploitation du serveur est Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284).

Pour plus d'informations sur DNS et Exchange Server, voir les articles suivants de la Base de connaissances Microsoft et la Webdiffusion :

  • 322856 sur la procédure de configuration du serveur DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237 sur l'utilisation des requêtes DNS TCP par Windows 2000 et Exchange 2000 SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759 sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server Dépannage DNS dans les transports (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Le serveur DNS utilise Virtual Server 2005 et Exchange Server est installé en tant qu'invité
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer si la valeur de la clé Model est définie sur Virtual Machine.

Exchange Server Analyzer recherche également la présence de la valeur de Registre suivante :

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

En outre, Exchange Server Analyzer interroge la classe WMI Win32_Services pour déterminer si le service DNS (Domain Name Services) est en cours d'exécution sur l'ordinateur physique qui utilise Microsoft Virtual Server 2005.

Si Exchange Server Analyzer détecte que la clé Model contient la chaîne Virtual Machine, que la branche de Registre ci-dessus existe et que DNS est en cours d'exécution, une erreur s'affiche.

Une valeur Virtual Machine pour la clé Model indique que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée sur Virtual Server 2005 ou Microsoft Virtual PC 2004. La branche de Registre ci-dessus n'étant créée que par Virtual Server 2005, son existence signifie que l'ordinateur Exchange Server fonctionne comme une machine virtuelle invitée dans Virtual Server 2005.

Microsoft ne prend pas en charge l'exécution des versions de Microsoft Exchange Server sur une machine virtuelle ou un émulateur. Cela s'applique à Exchange Server sur Virtual Server 2005, Virtual PC 2004 ou tout programme tiers de machine virtuelle. Les plates-formes Microsoft Exchange Server sont conçues et testées pour n'être exécutées que sur un matériel physique, notamment les plates-formes matérielles répertoriées dans Windows Server Catalog (http://go.microsoft.com/fwlink/?linkid=17219).

En outre, il est déconseillé d'exécuter Exchange en tant qu'invité de Virtual Server 2005 sur un ordinateur utilisant DNS car cela ne permet pas une redondance adéquate de service en service.

Pour corriger cette erreur

  1. Déplacez les boîtes aux lettres du serveur Exchange sous Virtual Server 2005 vers un ordinateur Exchange Server non virtuel.

  2. Associez tous les dossiers publics et transférez au besoin tous les rôles détenus par le serveur virtuel Exchange.

  3. Désinstallez Exchange de la machine virtuelle pour le désactiver et le supprimer de votre infrastructure Exchange et du service d'annuaire Active Directory®.

Pour plus d'informations sur le déplacement des boîtes aux lettres, voir les articles suivants de la Base de connaissances Microsoft :

  • 822892 sur les améliorations du déplacement de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892)

  • 224975 sur les différences entre les méthodes de transfert de boîtes aux lettres (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975)

Pour plus d'informations sur la prise en charge des ordinateurs Exchange Server fonctionnant dans des environnements virtuels, voir l'article 320220 de la Base de connaissances sur les limites de prise en charge pour Exchange Server sur une machine virtuelle ou d'émulation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).

Pour plus d'informations sur Microsoft Virtual Server 2005, voir le site Web de Microsoft Virtual Server 2005 (http://go.microsoft.com/fwlink/?linkid=34938).

Pour plus d'informations sur Microsoft Virtual PC 2004, voir le site Web de Microsoft Virtual PC 2004 (http://go.microsoft.com/fwlink/?linkid=34663).


Les réponses du serveur DNS externes sont différentes pour UDP et TCP
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2007-03-16

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut msExchSmtpExternalDNSServers de la classe protocolCfgSMTPServer pour chaque objet Exchange Server. Si elle est définie, la valeur de l'attribut msExchSmtpExternalDNSServers spécifie l'adresse du serveur DNS externe que l'instance de serveur virtuel SMTP utilise.

Après la récupération de l'adresse du serveur DNS externe principal, Exchange Analyzer tente d'exécuter une requête DNS sur des serveurs DNS configurés pour chaque serveur de service d'annuaire Active Directory. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une requête de résolution de nom TCP (Transmission Control Protocol) et UDP (User Datagram Protocol).

Si les requêtes de résolution de nom TCP et UDP sont réussies, Exchange Analyzer compare les réponses des reqûetes réussies. Si les réponses renvoyées des requêtes TCP et UDP ne sont pas les mêmes, Exchange Analyzer affiche un avertissement.

Cet avertissement indique qu'il peut y avoir des problèmes de configuration du serveur DNS externe qui affectent les performances du flux de messagerie.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Pour qu'Exchange Server remette un message Internet sortant via le service SMTP, le serveur DNS est utilisé comme suit :

  1. Un utilisateur interne envoie un message à un destinataire dans un domaine distant.

  2. Pour déterminer si le destinataire est local ou distant, le serveur virtuel SMTP sur le serveur Exchange de l'expéditeur utilise des fonctions de transport interne pour interroger le serveur de catalogue global afin d'obtenir l'adresse du destinataire. Si l'adresse du destinataire sur le message ne figure pas dans une stratégie de destinataire, celle-ci n'est pas stockée dans Active Directory ; par conséquent, Exchange détermine que le message est destiné à un domaine distant.

  3. Si nécessaire, le serveur Exchange remet le message au serveur virtuel SMTP approprié.

  4. Le serveur virtuel SMTP utilise ses informations de métabase IIS pour déterminer la méthode de remise d'un message à un domaine distant.

  5. Le serveur virtuel SMTP sur le serveur Exchange effectue ensuite l'une des deux actions suivantes :

    • Il utilise le serveur DNS pour vérifier l'adresse IP du domaine cible, puis tente de livrer le message.

    • Il transmet le message à un hôte actif chargé de la résolution DNS et de la remise du message.

Pour supprimer cet avertissement, voir l'article 820284 de la Base de connaissances Microsoft sur l'impossibilité de remettre le courrier à certains domaines si le système d'exploitation du serveur est Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284).

Pour plus d'informations sur DNS et Exchange Server, voir les articles suivants de la Base de connaissances Microsoft et la Webdiffusion :

  • 322856 sur la procédure de configuration du serveur DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237 sur l'utilisation des requêtes DNS TCP par Windows 2000 et Exchange 2000 SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759 sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server Dépannage DNS dans les transports (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Total octets par seconde de réseau au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Bytes Total/sec de l'objet de performance Network Interface pour les analyser.

Le compteur de performance Bytes Total/sec indique la fréquence à laquelle l'adaptateur réseau traite des types de données. Ce compteur inclut toutes les données des fichiers et des applications, outre les informations sur les protocoles, telles que les en-têtes des paquets. Le compteur de performance Bytes Total/sec est la somme de Network Interface\Bytes Received/sec et Network Interface/Bytes Sent/sec.

Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Pour un adaptateur réseau de 100 mégabits par seconde (Mbps), la valeur du compteur de performance Bytes Total/sec doit être inférieure à 7 mégaoctets/seconde. Pour un adaptateur réseau de 1 000 Mbps, la valeur du compteur de performance Bytes Total/sec doit être inférieure à 70 mégaoctets/seconde. Si le compteur Bytes Total/sec dépasse 7 pour cent de la bande passante du réseau, Exchange Server Analyzer affiche une erreur.

Cette erreur indique généralement que le serveur passe par des périodes pendant lesquelles il ne répond plus, provoquant le ralentissement ou l'arrêt du flux de messages. En outre, la boîte de dialogue Requête d'annulation RPC peut s'afficher pour les clients Microsoft Outlook® qui se connectent à ce serveur.

Voici quelques exemples de causes possibles pour cette erreur :

  • une carte réseau sur l'ordinateur ne peut pas prendre en charge la bande passante maximale prise en charge par votre infrastructure réseau ;

  • la charge sur le serveur est trop importante ;

  • des virus et du courrier indésirable provoquent une augmentation soudaine de l'utilisation réseau.

Pour résoudre cette erreur

  • Si une carte réseau ne prend pas en charge la bande passante maximale de votre réseau, mettez-la à niveau afin de prendre en charge une bande passante plus rapide.

  • Diminuez la charge sur le serveur. Pour ce faire, déplacez des boîtes aux lettres vers un serveur qui en contient moins. Si nécessaire, ajoutez un serveur Exchange supplémentaire à votre environnement.

  • Si vous pensez que la charge anormalement élevée n'est pas due à un nombre excessif de boîtes aux lettres sur un serveur, essayez d'identifier et de bloquer la source de cet excès anormal de charge.

  • Reportez-vous aux meilleures pratiques décrites dans les articles suivants :

    • Pour plus d'informations sur les considérations relatives à la bande passante du réseau, voir la section sur les performances réseau dans la rubrique sur la présentation des performances d'Exchange du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

    • Pour plus d'informations sur la résolution des problèmes de réseau, voir la section sur le dépannage des problèmes liés au réseau dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Regroupement des cartes d'interface réseau (NIC) activé
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2006-10-16

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapter pour identifier toutes les cartes d'interface réseau (NIC) liés au protocole TCP/IP.

Exchange Server Analyzer interroge ensuite la branche de registre suivante pour déterminer si la clé TeamAdapters existe pour ces cartes :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

Si Exchange Server Analyzer détermine que la clé TeamAdapters existe pour une ou plusieurs NIC sur le serveur en cours d'analyse, Exchange Server Analyzer affiche un message d'avertissement.

Cet avertissement indique que le regroupement des NIC est activé sur le serveur Exchange en cours d'analyse. Bien que le regroupement des NIC ne représente généralement pas un problème de flux de messages, il convient de s'assurer qu'il est configuré correctement avec les derniers pilotes NIC disponibles.

Pour résoudre ce problème :

  • Si des problèmes de flux de messages se produisent sur le serveur sur lequel le regroupement des NIC est activé, désactivez temporairement le regroupement pour voir si cela résout le problème de flux de messages.

  • Mettez à jour les pilotes NIC à l'aide des derniers pilotes disponibles auprès du fabricant de NIC.

  • Suivez rigoureusement les recommandations de configuration relatives au regroupement du fabricant de NIC.

Pour plus d'informations sur le regroupement des NIC, consultez les articles suivants de la Base de connaissances Microsoft :

  • 278431, « L'utilisation de cartes réseau NIC avec l'équilibrage de charge réseau peut provoquer des problèmes réseau » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431).

  • 814607 sur la prise en charge par Microsoft de clusters de serveurs avec des composants système tiers (http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607).


Paquets de sortie réseau au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance. Le moteur de collecte des données de performances collecte les données du compteur de performance Packet Outbound errors de l'objet de performance Network Interface pour analyser les données de performances.

Le compteur de performance Packet Outbound errors indique le nombre de paquets sortants qui n'ont pas pu être transmis en raison d'une erreur. La valeur du compteur de performance Packet Outbound errors doit être nulle. Si Exchange Server Analyzer détermine que la valeur du compteur de performance Packet Outbound errors est supérieure à zéro, il affiche une erreur.

Cette erreur indique généralement que le serveur passe par des périodes pendant lesquelles il ne répond plus, provoquant le ralentissement ou l'arrêt du flux de messages. En outre, la boîte de dialogue Requête d'annulation RPC peut s'afficher pour les clients Microsoft Outlook® qui se connectent à ce serveur.

Cette erreur est probablement due à une carte réseau défaillante ou endommagée.

Pour résoudre cette erreur, vous devez déterminer la cause des erreurs de paquets sortants et corriger le problème. Si les erreurs des paquets sortants sont dues à une carte réseau défaillante, remplacez-la immédiatement.

Reportez-vous aux meilleures pratiques décrites dans les articles suivants :

  • Pour plus d'informations sur les considérations relatives à la bande passante du réseau, voir la section sur les performances réseau dans la rubrique sur la présentation des performances d'Exchange du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de réseau, voir la section sur le dépannage des problèmes liés au réseau dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Longueur de la file d'attente de sortie réseau au-delà du seuil
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2007-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance Output Queue Length de l'objet de performance Network Interface pour les analyser.

Le compteur de performance Output Queue Length indique la longueur de la file d'attente de paquets sortants sous la forme de paquets. Il signale la valeur maximale du compteur de performance pendant l'intervalle entre deux collectes. Si la valeur moyenne dépasse 10, Exchange Server Analyzer affiche une erreur.

Cette erreur indique généralement que le serveur passe par des périodes pendant lesquelles il ne répond plus, provoquant le ralentissement ou l'arrêt du flux de messagerie. En outre, la boîte de dialogue Requête d'annulation RPC peut s'afficher pour les clients Outlook qui se connectent à ce serveur.

Voici quelques exemples de causes possibles pour cette erreur :

Remarque :
Dans certains cas, sur une machine exécutant le système d'exploitation Microsoft Windows 2000 Server, le compteur de performance Output Queue Length risque d'afficher en permanence une valeur aléatoire supérieure à zéro. Pour plus d'informations sur les cas dans lesquels le compteur de performance Output Queue Length risque d'afficher la valeur aléatoire et sur la procédure de correction, consultez l'article 834940 de la Base de connaissances Microsoft sur le Moniteur système qui risque d'afficher des valeurs élevées pour le compteur de performance Longueur de la file d'attente de sortie dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940)..
  • une carte réseau sur l'ordinateur ne peut pas prendre en charge la bande passante maximale prise en charge par votre infrastructure réseau ;

  • la charge sur le serveur est trop importante ;

  • des virus et du courrier indésirable provoquent une augmentation soudaine de l'utilisation réseau.

Procédez comme suit pour résoudre cette erreur :

  • Si une carte réseau ne prend pas en charge la bande passante maximale de votre réseau, mettez-la à niveau afin de prendre en charge une bande passante plus rapide.

  • Diminuez la charge sur le serveur. Pour ce faire, déplacez des boîtes aux lettres vers un serveur qui en contient moins. Si nécessaire, ajoutez un serveur Exchange supplémentaire à votre environnement.

  • Si vous pensez que la charge anormalement élevée n'est pas due à un nombre excessif de boîtes aux lettres sur un serveur, essayez d'identifier et de bloquer la source de cet excès anormal de charge.

Reportez-vous aux meilleures pratiques décrites dans les articles suivants :

  • Pour plus d'informations sur les considérations relatives à la bande passante du réseau, voir la section sur les performances réseau dans la rubrique sur la présentation des performances d'Exchange du Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de réseau, voir la section sur le dépannage des problèmes liés au réseau dans la rubrique Dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Le serveur DNS principal n'est pas parvenu à répondre à une connexion UDP
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2007-03-16

L'outil Microsoft Exchange Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour obtenir l'attribut DNSServerSearchOrder. Cet attribut est un groupe d'adresses IP de serveur à utiliser dans l'interrogation de serveurs DNS.

Après la récupération de l'adresse du serveur DNS, Exchange Analyzer tente d'exécuter une requête DNS sur des serveurs DNS configurés pour chaque serveur de service d'annuaire Active Directory. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une requête de résolution de nom UDP et analyse les résultats.

Si la requête de résolution de nom UDP échoue, Exchange Analyzer affiche un avertissement.

Cet avertissement indique que le serveur DNS principal est peut-être configuré pour accepter uniquement les requêtes TCP.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Pour qu'Exchange Server remette un message Internet sortant via le service SMTP, le serveur DNS est utilisé comme suit :

  1. Un utilisateur interne envoie un message à un destinataire dans un domaine distant.

  2. Pour déterminer si le destinataire est local ou distant, le serveur virtuel SMTP sur le serveur Exchange de l'expéditeur utilise des fonctions de transport interne pour interroger le serveur de catalogue global afin d'obtenir l'adresse du destinataire. Si l'adresse du destinataire sur le message ne figure pas dans une stratégie de destinataire, celle-ci n'est pas stockée dans Active Directory ; par conséquent, Exchange détermine que le message est destiné à un domaine distant.

  3. Si nécessaire, le serveur Exchange remet le message au serveur virtuel SMTP approprié.

  4. Le serveur virtuel SMTP utilise ses informations de métabase IIS pour déterminer la méthode de remise d'un message à un domaine distant.

  5. Le serveur virtuel SMTP sur le serveur Exchange effectue ensuite l'une des deux actions suivantes :

    • Il utilise le serveur DNS pour vérifier l'adresse IP du domaine cible, puis tente de livrer le message.

    • Il transmet le message à un hôte actif chargé de la résolution DNS et de la remise du message.

Par défaut, les serveurs DNS écoutent sur le socket UDP 53 dans le cadre de communications telles que les requêtes de résolution de nom.

Si les services SMTP sur Exchange Server sont configurés de manière à uniquement envoyer des requêtes UDP et si le serveur DNS principal est configuré de manière à uniquement accepter les requêtes TCP, des échecs de routage du courrier peuvent apparaître et affecter négativement les performances du flux de messagerie.

Pour palier cet avertissement, procédez comme suit :

  1. Assurez-vous que le serveur DNS a été démarré et qu'il est connecté au réseau.

  2. Vérifiez qu'aucun pare-feu réseau ou filtre de paquet ne bloque les ports DNS bien connus comme le port UDP 53.

  3. Vérifiez que le serveur DNS principal soit configuré pour prendre en charge les requêtes de résolution de nom UDP.

Pour plus d'informations sur DNS et Exchange Server, voir les articles suivants de la Base de connaissances Microsoft et la Webdiffusion :

  • 322856 sur la procédure de configuration du serveur DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237 sur l'utilisation des requêtes DNS TCP par Windows 2000 et Exchange 2000 SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759 sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server Dépannage DNS dans les transports (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Le serveur DNS principal est inaccessible
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour obtenir l'attribut DNSServerSearchOrder. Cet attribut est un groupe d'adresses IP de serveur à utiliser dans l'interrogation de serveurs DNS. Après avoir récupéré l'adresse du serveur DNS principal, Exchange Server Analyzer ouvre une connexion de socket TCP sur le port 53 du serveur. Cette connexion est établie à l'aide d'un processeur d'objet personnalisé qui renvoie une chaîne spécifique si la connexion est correctement établie. Si Exchange Server Analyzer ne reçoit pas 53 Available dans la chaîne renvoyée, un avertissement s'affiche.

Cet avertissement indique que le serveur n'a pas répondu à une tentative de connexion sur le port 53 TCP. Par défaut, les serveurs DNS écoutent sur le socket TCP 53 dans le cadre de communications telles que les requêtes de résolution de nom.

Si le serveur DNS principal est inaccessible et si vous utilisez Exchange 2000 Server, la remise des messages est lente. Microsoft met à disposition un correctif pris en charge pour résoudre le problème de la remise des messages à des destinataires externes, qui s'avère plus lente lorsque le serveur DNS principal n'est pas disponible. Contactez les services du Support Technique de Microsoft pour obtenir ce correctif.

En outre, vous souhaitez résoudre le problème d'indisponibilité du serveur DNS principal ou modifier les paramètres DNS sur le serveur Exchange pour utiliser un serveur DNS différent pour la résolution de nom.

Pour supprimer cet avertissement

  1. Assurez-vous que le serveur DNS a été démarré et qu'il est connecté au réseau.

  2. Utilisez la commande PING pour déterminer si le serveur DNS est accessible.

Pour plus d'informations sur la lenteur de la remise des messages en cas d'indisponibilité du serveur DNS principal et sur la manière d'obtenir un correctif, voir l'article 829722 de la Base de connaissances Microsoft sur la lenteur de la remise des messages dans Exchange 2000 en cas d'indisponibilité du serveur DNS principal (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722).

Pour plus d'informations sur DNS et Exchange Server, voir les articles suivants de la Base de connaissances et la Webdiffusion :

  • 322856 sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237 sur l'utilisation des requêtes DNS TCP par Windows 2000 et Exchange 2000 SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759 sur la Webdiffusion du Support Technique : Microsoft Exchange 2000 Server : Dépannage DNS dans les transports (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Le serveur DNS principal externe n'est pas parvenu à répondre à une connexion TCP
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2007-03-16

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut msExchSmtpExternalDNSServers de la classe protocolCfgSMTPServer pour chaque objet Exchange Server. Si elle est définie, la valeur de l'attribut msExchSmtpExternalDNSServers spécifie l'adresse du serveur DNS externe que l'instance de serveur virtuel SMTP utilise.

Après avoir récupéré l'adresse du serveur DNS externe principal, Exchange Server Analyzer ouvre une connexion de socket TCP sur le port 53 du serveur. Cette connexion est établie à l'aide d'un processeur d'objet personnalisé qui renvoie une chaîne spécifique si la connexion est correctement établie. Si Exchange Server Analyzer ne reçoit pas 53 Available dans la chaîne renvoyée, un avertissement s'affiche.

Cet avertissement indique que le serveur n'a pas répondu à une tentative de connexion sur le port 53 TCP. Par défaut, les serveurs DNS écoutent sur le socket TCP 53 dans le cadre de communications telles que les requêtes de résolution de nom.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Pour qu'Exchange Server remette un message Internet sortant via le service SMTP, le serveur DNS est utilisé comme suit :

  1. Un utilisateur interne envoie un message à un destinataire dans un domaine distant.

  2. Pour déterminer si le destinataire est local ou distant, le serveur virtuel SMTP sur le serveur Exchange de l'expéditeur utilise des fonctions de transport interne pour interroger le serveur de catalogue global afin d'obtenir l'adresse du destinataire. Si l'adresse du destinataire sur le message ne figure pas dans une stratégie de destinataire, celle-ci n'est pas stockée dans Active Directory ; par conséquent, Exchange détermine que le message est destiné à un domaine distant.

  3. Si nécessaire, le serveur Exchange remet le message au serveur virtuel SMTP approprié.

  4. Le serveur virtuel SMTP utilise ses informations de métabase IIS pour déterminer la méthode de remise d'un message à un domaine distant.

  5. Le serveur virtuel SMTP sur le serveur Exchange effectue ensuite l'une des deux actions suivantes :

    • Il utilise le serveur DNS pour vérifier l'adresse IP du domaine cible, puis tente de livrer le message.

    • Il transmet le message à un hôte actif chargé de la résolution DNS et de la remise du message.

Si le serveur DNS externe principal est inaccessible et si vous utilisez Exchange 2000 Server, la remise des messages est lente. Microsoft met à disposition un correctif pris en charge pour résoudre le problème de la remise des messages à des destinataires externes, qui s'avère plus lente lorsque le serveur DNS externe principal n'est pas disponible. Contactez les services de support technique Microsoft pour obtenir ce correctif.

En outre, vous souhaitez résoudre le problème d'indisponibilité du serveur DNS externe principal ou modifier les paramètres DNS sur le serveur Exchange pour utiliser un serveur DNS différent pour la résolution de nom.

Pour résoudre ce problème, procédez comme suit :

  1. Assurez-vous que le serveur DNS externe a été lancé et qu'il existe une connectivité entre ce serveur et le réseau Exchange.

  2. Utilisez la commande PING pour déterminer si le serveur DNS externe est accessible.

Pour plus d'informations sur la lenteur de la remise des messages en cas d'indisponibilité du serveur DNS principal et sur la manière d'obtenir un correctif, voir l'article 829722 de la Base de connaissances Microsoft sur la lenteur de la remise des messages dans Exchange 2000 en cas d'indisponibilité du serveur DNS principal (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722).

Pour plus d'informations sur DNS et Exchange Server, voir les articles suivants de la Base de connaissances et la Webdiffusion :

  • 322856 sur la procédure de configuration du serveur DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237 sur l'utilisation des requêtes DNS TCP par Windows 2000 et Exchange 2000 SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759 sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server Dépannage DNS dans les transports (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Le serveur DNS principal externe n'est pas parvenu à répondre à une connexion UDP
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2007-03-16

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut msExchSmtpExternalDNSServers de la classe protocolCfgSMTPServer pour chaque objet Exchange Server. Si elle est définie, la valeur de l'attribut msExchSmtpExternalDNSServers spécifie l'adresse du serveur DNS externe que l'instance de serveur virtuel SMTP utilise.

Après la récupération de l'adresse du serveur DNS externe principal, Exchange Analyzer tente d'exécuter une requête DNS sur des serveurs DNS configurés pour chaque serveur de service d'annuaire Active Directory. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une requête de résolution de nom UDP et analyse les résultats.

Si la requête de résolution de nom UDP échoue, Exchange Analyzer affiche un avertissement.

Cet avertissement indique que le serveur DNS externe principal est peut-être configuré pour accepter uniquement les requêtes TCP.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Pour qu'Exchange Server remette un message Internet sortant via le service SMTP, le serveur DNS est utilisé comme suit :

  1. Un utilisateur interne envoie un message à un destinataire dans un domaine distant.

  2. Pour déterminer si le destinataire est local ou distant, le serveur virtuel SMTP sur le serveur Exchange de l'expéditeur utilise des fonctions de transport interne pour interroger le serveur de catalogue global afin d'obtenir l'adresse du destinataire. Si l'adresse du destinataire sur le message ne figure pas dans une stratégie de destinataire, celle-ci n'est pas stockée dans Active Directory ; par conséquent, Exchange détermine que le message est destiné à un domaine distant.

  3. Si nécessaire, le serveur Exchange remet le message au serveur virtuel SMTP approprié.

  4. Le serveur virtuel SMTP utilise ses informations de métabase IIS pour déterminer la méthode de remise d'un message à un domaine distant.

  5. Le serveur virtuel SMTP sur le serveur Exchange effectue ensuite l'une des deux actions suivantes :

    • Il utilise le serveur DNS pour vérifier l'adresse IP du domaine cible, puis tente de livrer le message.

    • Il transmet le message à un hôte actif chargé de la résolution DNS et de la remise du message.

Par défaut, les serveurs DNS écoutent sur le socket UDP 53 dans le cadre de communications telles que les requêtes de résolution de nom.

Si les services SMTP sur le serveur Exchange sont configurés de manière à uniquement envoyer des requêtes UDP et si le serveur DNS externe principal est configuré de manière à uniquement accepter les requêtes TCP, des échecs de routage du courrier peuvent apparaître et affecter négativement les performances du flux de messagerie.

Pour palier cet avertissement, procédez comme suit :

  1. Assurez-vous que le serveur DNS externe a été lancé et qu'il existe une connectivité entre ce serveur et le réseau.

  2. Vérifiez qu'aucun pare-feu réseau ou filtre de paquet ne bloque les ports DNS bien connus comme le port UDP 53.

  3. Vérifiez que le serveur DNS externe principal soit configuré pour prendre en charge les requêtes de résolution de nom UDP.

Pour plus d'informations sur DNS et Exchange Server, voir les articles suivants de la Base de connaissances Microsoft et la Webdiffusion :

  • 322856 sur la procédure de configuration du serveur DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856)

  • 263237 sur l'utilisation des requêtes DNS TCP par Windows 2000 et Exchange 2000 SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759 sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server Dépannage DNS dans les transports (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759)


Le serveur WINS principal ne répond pas
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NetworkAdapterConfiguration pour obtenir l'attribut WINSPrimaryServer. Cet attribut est l'adresse IP du serveur WINS (Windows Internet Name Service) principal pour l'ordinateur Exchange Server. Après qu'Exchange Server Analyzer récupère l'adresse du serveur WINS principal, il ouvre une connexion de socket TCP au port 137 sur le serveur. Cette connexion est établie à l'aide d'un processeur d'objet personnalisé qui renvoie une chaîne spécifique si la connexion est correctement établie. Si Exchange Server Analyzer ne reçoit pas 137 Available dans la chaîne renvoyée, il affiche un avertissement.

Cet avertissement indique que le serveur n'a pas répondu à une tentative de connexion sur le port 137 TCP. Par défaut, les serveurs WINS écoutent sur le socket TCP 137 dans le cadre de communications telles que les requêtes de résolution de nom.

Si le serveur WINS principal est inaccessible et si vous utilisez Exchange Server, la remise des messages est lente, surtout dans les grandes organisations. Vous devez résoudre le problème d'indisponibilité du serveur WINS principal ou modifier les paramètres WINS sur le serveur Exchange pour utiliser un serveur WINS différent pour la résolution de nom.

Pour supprimer cet avertissement

  1. Assurez-vous que le serveur WINS a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour déterminer si le serveur WINS est accessible.

Pour plus d'informations sur la nécessité de WINS pour Exchange 2000 Server et Exchange Server 2003, voir l'article 837391 de la Base de connaissances Microsoft sur Exchange Server 2003 et Exchange 2000 Server qui nécessitent la résolution de nom NetBIOS pour une fonctionnalité totale (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=837391).


Le port 389 n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut dNSHostName de tous les contrôleurs de domaine dans Active Directory. Après avoir récupéré les noms des contrôleurs de domaine, Exchange Server Analyzer ouvre une connexion de socket TCP au port 389 sur chaque contrôleur de domaine. Cette connexion est établie à l'aide d'un processeur d'objet personnalisé qui renvoie une chaîne spécifique si la connexion est correctement établie. Si Exchange Server Analyzer ne reçoit pas 389 Available dans la chaîne renvoyée, un avertissement s'affiche.

Cet avertissement indique que le contrôleur de domaine n'a pas répondu à une tentative de connexion sur le port TCP 389. Le port TCP 389 est le port par défaut pour les communications LDAP.

Cet avertissement peut s'afficher en raison de problèmes de connectivité entre Exchange Server Analyzer et le contrôleur de domaine. Plusieurs raisons peuvent expliquer qu'un contrôleur de domaine ne répond pas correctement aux requêtes LDAP lorsqu'Exchange Server Analyzer l'interroge.

Pour supprimer cet avertissement

  1. Vérifiez que le compte utilisant l'outil est autorisé à interroger le contrôleur de domaine. Vous aurez besoin d'autorisations au niveau utilisateur dans le domaine où le contrôleur de domaine est exécuté. Pour plus d'informations sur les autorisations requises pour utiliser Exchange Server Analyzer, voir le fichier d'aide accompagnant l'outil. Pour ouvrir le fichier d'aide, lancez Exchange Server Analyzer, cliquez sur ?, puis sur Aide sur Microsoft Exchange Analyzer Tool.

  2. Vérifiez qu'aucun pare-feu ou restriction de port ne soit présent entre l'ordinateur utilisant Exchange Server Analyzer et le contrôleur de domaine qui n'a pas répondu.

  3. Vérifiez que le contrôleur de domaine est connecté au réseau et fonctionne correctement.

Pour plus d'informations sur la résolution de problèmes de connectivité d'Active Directory, voir l'article 816103 de la Base de connaissances Microsoft sur l'utilisation de Portqry pour résoudre des problèmes de connectivité d'Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103).

Pour plus d'informations sur la configuration de l'heure de Microsoft Windows® sur les contrôleurs de domaine, voir l'article 816042 de la Base de connaissances sur la procédure de configuration d'un serveur de temps faisant autorité dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042).


Le port 636 n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut dNSHostName de tous les contrôleurs de domaine dans Active Directory. Après avoir récupéré les noms des contrôleurs de domaine, Exchange Server Analyzer ouvre une connexion de socket TCP au port 636 sur chaque contrôleur de domaine. Cette connexion est établie à l'aide d'un processeur d'objet personnalisé qui renvoie une chaîne spécifique si la connexion est correctement établie. Si Exchange Server Analyzer ne reçoit pas 636 Available dans la chaîne renvoyée, un avertissement s'affiche.

Cet avertissement indique que le contrôleur de domaine n'a pas répondu à une tentative de connexion sur le port TCP 636. Le port TCP 636 est le port par défaut pour les communications LDAP sur SSL (Secure Lightweight Directory Access Protocol).

Grâce à l'introduction d'Exchange 2000 Server Service Pack 3, Exchange Server établira une connexion avec LDAP sur SSL si un certificat valide existe dans la banque locale d'informations de certificats de l'ordinateur Exchange Server. Si ce certificat n'existe pas ou si une erreur liée au certificat est renvoyée (par exemple, le contrôleur de domaine ne fait pas confiance au certificat Exchange ou le certificat utilisé nécessite la protection élevée par clé), Exchange Server repassera automatiquement à LDAP sans SSL. Cet avertissement peut s'afficher en raison de problèmes de connectivité entre Exchange Server Analyzer et le contrôleur de domaine. L'infrastructure à clé publique (PKI) ou d'autres problèmes de certificat ne sont pas soumis à cet avertissement.

Plusieurs raisons peuvent expliquer qu'un contrôleur de domaine ne répond pas correctement aux requêtes LDAP sur SSL lorsqu'Exchange Server Analyzer l'interroge.

Pour supprimer cet avertissement

  1. Vérifiez que le compte utilisant l'outil est autorisé à interroger le contrôleur de domaine. Vous aurez besoin d'autorisations au niveau utilisateur dans le domaine où le contrôleur de domaine est exécuté. Pour plus d'informations sur les autorisations requises pour utiliser Exchange Server Analyzer, voir le fichier d'aide accompagnant l'outil. Pour ouvrir le fichier d'aide, lancez Exchange Server Analyzer, cliquez sur ?, puis sur Aide sur Microsoft Exchange Analyzer Tool.

  2. Vérifiez qu'aucun pare-feu ou restriction de port ne soit présent entre l'ordinateur utilisant Exchange Server Analyzer et le contrôleur de domaine qui n'a pas répondu.

  3. Vérifiez que le contrôleur de domaine est connecté au réseau et fonctionne correctement.

  4. Vérifiez que l'heure de l'ordinateur utilisant Exchange Server Analyzer et le contrôleur de domaine qui n'a pas répondu est synchronisée. Si le service de temps Microsoft Windows® du contrôleur de domaine est arrêté ou désactivé, son heure locale ne sera peut-être plus synchronisée. Dans ce cas, le contrôleur de domaine ne répond pas aux requêtes LDAP sur SSL tant que son horloge n'est pas synchronisée.

Pour plus d'informations sur l'utilisation de LDAP sur SSL, voir l'article 321051 de la Base de connaissances Microsoft sur la procédure d'activation de LDAP sur SSL avec une autorité de certification tierce (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321051).

Pour plus d'informations sur la résolution de problèmes de connectivité d'Active Directory, voir l'article 816103 de la Base de connaissances sur l'utilisation de Portqry pour résoudre des problèmes de connectivité d'Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103).

Pour plus d'informations sur le service de temps Windows, voir l'article 816042 de la Base de connaissances sur la procédure de configuration d'un serveur de temps faisant autorité dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042).


Le serveur SMTP ne prend pas en charge le verbe X-LINK2STATE
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lance une session SMTP avec le serveur Exchange pour confirmer que les verbes Exchange SMTP corrects sont répertoriés. Si le verbe X-LINK2STATE n'est pas répertorié, un avertissement s'affiche.

Le verbe X-LINK2STATE est utilisé par Exchange pour mettre à jour les tables d'état des liens sur les maîtres de routage. Les tables d'état des liens enregistrent des informations actualisées sur l'état des liens SMTP via l'organisation Exchange. Exchange utilise ces informations pour récupérer le coût le plus faible et les itinéraires les plus fiables lors du routage de messages. Cette fonctionnalité est également appelée « Routage intelligent ».

Le verbe X-LINK2STATE est requis par Exchange pour le routage efficace et n'est pas utilisé par d'autres fournisseurs SMTP. Cette fonctionnalité est disponible dans un fichier (xlsasink.dll) installé et enregistré par le programme d'installation d'Exchange.

Deux raisons connues expliquent pourquoi cet avertissement peut être renvoyé. Tout d'abord, certains administrateurs peuvent avoir désactivé le fichier xlsasink.dll comme un moyen de contourner la fonctionnalité de routage intelligent qu'il fournit. Cette méthode n'est pas recommandée et peut engendrer des problèmes de performances et de fiabilité. Dans ce cas, il est recommandé de réinstaller Exchange sur l'ordinateur concerné pour installer et enregistrer le fichier xlsasink.dll.

Cet avertissement peut également être renvoyé si vous utilisez un produit antivirus qui installe et utilise sa propre pile de protocoles SMTP pour analyser les messages. Dans ce cas, le logiciel antivirus peut utiliser sa propre pile SMTP qui intercepte et analyse les messages avant qu'ils n'atteignent la pile SMTP d'Exchange. Dans ce cas, la pile SMTP antivirus n'utilise pas le verbe X-LINK2STATE. Il est recommandé d'exécuter le logiciel antivirus dans un mode qui ne requiert pas l'installation de sa propre pile SMTP sur le serveur Exchange.

Pour plus d'informations sur le verbe X-LINK2STATE et d'autres verbes propriétaires utilisés par Exchange, voir l'article 812455 de la Base de connaissances Microsoft sur les définitions des verbes utilisés entre 2 serveurs Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455.

Pour plus d'informations sur l'affichage des verbes de commande Exchange et la réinstallation d'Exchange 2000 Server, voir l'article 319885 de la Base de connaissances sur la non-remise des messages envoyés dans l'organisation Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885).

Pour plus d'informations sur l'affichage des verbes de commande Exchange et sur la réinstallation d'Exchange Server 2003, voir l'article 822939 de la Base de connaissances sur la non-remise des messages envoyés dans l'organisation Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


Échec du test d'acceptation des messages sur le serveur SMTP
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool tente d'envoyer un message vers le compte administrateur pour le domaine SMTP (Simple Mail Transfer Protocol) en effectuant les tâches suivantes :

  • Ouverture d'une connexion de socket sur le serveur SMTP. Si Exchange Server Analyzer reçoit le code de réponse 220, cette étape est considérée comme réussie.

  • Transmission du verbe de commande SMTP EHLO. Si Exchange Server Analyzer reçoit une série de codes de réponse 250, dont une réponse incluant 250-X-LINK2STATE et 250-XEXCH50, cette étape est considérée comme réussie.

  • Transmission du verbe de commande SMTP MAIL FROM: ExBPA-MailAcceptTest@Fabrikam.com. Si Exchange Server Analyzer reçoit le code de réponse 250, cette étape est considérée comme réussie.

  • Transmission du verbe de commande SMTP RCPT TO: Postmaster@<nom_domaine>.com. Si Exchange Server Analyzer reçoit le code de réponse 250, cette étape est considérée comme réussie.

Si Exchange Server Analyzer ne parvient pas à effectuer toutes les étapes avec succès, une erreur s'affiche. Cette erreur indique l'existence probable d'un problème général de flux de messages. Les liens suivants sont indiqués dans l'ordre dans lequel vous devez procéder au dépannage, en commençant par le niveau serveur pour terminer par le niveau réseau.

Pour corriger cette erreur

  1. Voir la section sur la résolution des problèmes de routage du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579).

  2. Voir l'article 324867 de la Base de connaissances Microsoft sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server concernant le dépannage des problèmes de flux de messages (révision) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867).

  3. Voir l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour dépanner des problèmes de flux de messages http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489).

  4. Voir l'article 324759 de la Base de connaissances Microsoft sur la Webdiffusion du Support Technique et le dépannage DNS dans les transports dans Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759).

Pour plus d'informations sur le compte administrateur dans Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 223860 sur la configuration manuelle de la boîte aux lettres administrateur SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860)

  • 313832 sur la procédure de définition d'un compte SMTP d'administrateur dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832)


Le test de relais ouvert a échoué pour le serveur SMTP
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2007-03-14

L'outil Microsoft® Exchange Server Analyzer Tool tente de relayer un message via un serveur SMTP (Simple Mail Transfer Protocol) en effectuant les tâches suivantes :

  • Ouverture d'une connexion de socket sur le serveur SMTP. Si Exchange Server Analyzer reçoit le code de réponse 220, cette étape est considérée comme réussie.

  • Transmission du verbe de commande SMTP EHLO. Si Exchange Server Analyzer reçoit une série de codes de réponse 250, dont une réponse incluant 250-X-LINK2STATE et 250-XEXCH50, cette étape est considérée comme réussie.

  • Transmission du verbe de commande SMTP MAIL FROM: ExBPA-OpenRelayTest@Fabrikam.com. Si Exchange Server Analyzer reçoit le code de réponse 250, cette étape est considérée comme réussie.

  • Transmission du verbe de commande SMTP RCPT TO: ExBPA-OpenRelayTest@Fabrikam.com. Si Exchange Server Analyzer reçoit le code de réponse 250, cette étape est considérée comme réussie.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de cette clé correspond à une version spécifique d'un système d'exploitation Windows Server.

Si Exchange Server Analyzer parvient à effectuer toutes les étapes avec succès sur un ordinateur Exchange Server faisant partie d'une installation Microsoft Small Business Server 2000 ou Microsoft Windows Small Business Server 2003, une erreur s'affiche.

L'erreur indique que ce serveur est configuré en tant que relais ouvert.

Il n'est pas recommandé d'autoriser des relais ouverts.

Un relais ouvert existe lorsqu'un serveur de messagerie autorise le relais des messages électroniques via le système sans exercer de restriction ni aucun contrôle sur le message relayé.

Remarque :
Si, pour une raison ou une autre, votre organisation Exchange utilise un domaine SMTP nommé Fabrikam.com, vous pouvez rencontrer cette erreur. Dans ce cas, vous pouvez ignorer cette erreur en toute sécurité. Le domaine Fabrikam.com est détenu par Microsoft Corporation et est utilisé pour les formations, la documentation et à des fins similaires.

Le relais n'est pas négatif en soi ; le protocole SMTP a en effet été conçu à cette fin (pour plus d'informations, voir le document RFC 2821, sections 2.1 et 3.7 (http://ietf.org)). Toutefois, si le relais n'est pas contrôlé (un hôte non contrôlé est appelé hôte de relais ouvert), un utilisateur malveillant pourrait potentiellement utiliser le relais pour envoyer des messages commerciaux indésirables en bloc. En faisant transiter ces messages électroniques indésirables par un hôte intermédiaire, l'utilisateur malveillant tente de masquer son identité. Ceci bloque également les ressources sur l'hôte relais et peut empêcher celui-ci d'envoyer des messages électroniques valides. La plupart des utilisateurs qui envoient ce type de messages indésirables peuvent notamment envoyer un message unique à un nombre très important de destinataires sans utiliser leur propre bande passante.

Veillez à ne pas autoriser le relais anonyme sur vos serveurs virtuels SMTP Internet. Par défaut, Exchange ne permet qu'aux utilisateurs authentifiés de relayer le courrier. Seuls les utilisateurs authentifiés peuvent utiliser Exchange pour envoyer du courrier à un domaine externe. Si vous modifiez les paramètres de relais par défaut pour autoriser le relais aux utilisateurs non authentifiés, ou si vous autorisez le relais ouvert à un domaine via un connecteur, des utilisateurs non autorisés ou des vers malveillants peuvent utiliser votre serveur Exchange pour envoyer du courrier indésirable. Votre serveur peut figurer dans une liste d'interdiction et ne plus pouvoir envoyer de courrier pour légitimer les serveurs distants. Pour éviter que des utilisateurs non autorisés ne se servent de votre serveur Exchange pour relayer le courrier, utilisez, au minimum, les restrictions de relais par défaut.

Si vous avez des raisons légitimes d'utiliser le relais, suivez les indications pour vérifier que la sécurité est préservée dans votre implémentation. Pour ce faire, laissez inchangés les paramètres par défaut refusant tout relais et ajoutez uniquement les adresses IP desquelles vous accepterez le courrier relayé et désactivez l'accès pour les utilisateurs authentifiés.

Examinez de quelle façon les comptes intégrés (administrateur local) et les autres utilisateurs sont utilisés sur vos serveurs de passerelle. Il est peu probable que vous utilisiez les comptes intégrés pour tout type de relais. Si vous utilisez le relais, celui-ci s'effectue probablement par un ensemble connu d'utilisateurs ou d'ordinateurs. Il est recommandé de restreindre les droits de relais à des utilisateurs et ordinateurs explicites ou à une adresse IP.

Configurer une autorisation explicite de relais permettra en outre de renforcer la protection de votre serveur. Des utilisateurs malveillants peuvent utiliser une attaque de décryptage pour tenter d'obtenir les mots de passe des comptes intégrés ou des comptes d'utilisateurs trouvés sur Internet pour pouvoir utiliser votre serveur comme proxy de courrier indésirable. Par conséquent, le paramètre par défaut qui permet à tout ordinateur authentifié d'effectuer le relais n'est pas recommandé pour les ordinateurs accessibles d'Internet. Il est recommandé de désactiver ce paramètre.

Les procédures suivantes expliquent comment désactiver le relais anonyme s'il s'agit d'un serveur virtuel SMTP Internet. Comme déjà mentionné dans cet article, vous ne devez activer toute forme de relais anonyme que lorsque votre organisation est consciente du risque de sécurité et que celui-ci est acceptable. Les références à la fin de cet article fournissent plus d'informations sur l'utilisation du relais.

Si un serveur virtuel SMTP n'est pas accessible depuis Internet, il est recommandé de rétablir les configurations de relais par défaut. En conséquence, les serveurs virtuels SMTP n'autorisent que le relais interne à partir d'ordinateurs authentifiés.

Pour les serveurs virtuels SMTP accessibles depuis Internet, il est recommandé de renforcer la sécurité des configurations de relais par défaut, pour que seuls les utilisateurs et les ordinateurs détenteurs d'autorisations explicites soient autorisés à effectuer le relais.

Si vous avez vérifié qu'Exchange est configuré pour bloquer le relais et si vous recevez toujours cette erreur dans l'outil Exchange Server Analyzer, vous devez contrôler que tous les serveurs ou processus proxy, tels que les pare-feu, antivirus ou antispam, n'autorisent pas le relais anonyme.

Pour rétablir les configurations par défaut de relais anonyme sur les serveurs virtuels SMTP internes

  1. Ouvrez le Gestionnaire système Exchange.

  2. Dans l'arborescence de la console, développez Serveurs, le serveur souhaité, puis Protocoles et enfin SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP auquel vous souhaitez appliquer des restrictions de relais, puis cliquez sur Propriétés.

  4. Dans Propriétés de <serveur virtuel SMTP>, cliquez sur l'onglet Accès, puis sur Relais.

  5. Dans Restrictions de relais, sous Sélectionnez l'ordinateur autorisé à relayer via ce serveur virtuel, sélectionnez Uniquement la liste ci-dessous, activez la case à cocher Autoriser tous les ordinateurs authentifiés à relayer, sans tenir compte de la liste ci-dessous, puis cliquez sur OK.

Pour configurer l'autorisation de relais explicite sur les serveurs virtuels SMTP Internet dans Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Dans l'arborescence de la console, développez Serveurs, le serveur souhaité, puis Protocoles et enfin SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP auquel vous souhaitez appliquer des restrictions de relais, puis cliquez sur Propriétés.

  4. Dans Propriétés de <serveur virtuel SMTP>, cliquez sur l'onglet Accès, puis sur Relais.

  5. Dans Restrictions de relais, désactivez la case à cocher Autoriser tous les ordinateurs authentifiés à relayer, sans tenir compte de la liste ci-dessous, puis cliquez sur Utilisateurs pour spécifier un sous-ensemble d'utilisateurs pour lesquels vous souhaitez accorder des autorisations de relais sur ce serveur virtuel SMTP.

  6. Dans Permissions for Submit and Relay (Autorisations de dépôt et de relais), pour supprimer un utilisateur ou un groupe, sélectionnez le groupe ou l'utilisateur, puis cliquez sur Supprimer.

  7. Pour ajouter un groupe ou un utilisateur, cliquez sur Ajouter, puis sélectionnez les utilisateurs ou le groupe pour lequel vous souhaitez spécifier des autorisations. Sélectionnez l'une des options suivantes :

    • Sous Microsoft Windows Server 2003, dans Sélectionnez les utilisateurs, les ordinateurs ou les groupes, sous Entrez le nom de l'objet à sélectionner, entrez le nom de l'utilisateur ou du groupe. Pour rechercher l'utilisateur ou le groupe, cliquez sur Avancé, recherchez son nom, puis cliquez sur Vérifier les noms pour valider votre entrée.

      Conseil :
      Cliquez sur exemples pour afficher les formats acceptables pour vos entrées.
    • Sous Windows 2000 Server, dans Sélectionnez les utilisateurs, les ordinateurs ou les groupessélectionnez le groupe ou l'utilisateur pour lequel vous souhaitez accorder des autorisations de dépôt, puis cliquez sur Ajouter.

  8. Cliquez sur OK pour revenir à la boîte de dialogue Permissions for Submit and Relay (Autorisations de dépôt et de relais).

  9. Sous Group or user names list (liste de noms de groupes ou d'utilisateurs), sélectionnez le groupe que vous venez d'ajouter.

  10. Sous Autorisations pour <groupe sélectionné>, en regard de Autorisation de dépôt, activez, au besoin, la case à cocher sous Autoriser pour autoriser l'utilisateur ou le groupe sélectionné à envoyer du courrier via ce serveur virtuel SMTP.

  11. En regard de Autorisations de relais, activez la case à cocher sous Autoriser pour permettre à l'objet sélectionné d'effectuer le relais via ce serveur virtuel SMTP, ou activez la case à cocher sous Refuser pour lui interdire de le faire.

    Remarque :
    Vous devez permettre les autorisations de dépôt si vous souhaitez accepter les autorisations de relais.

  12. Cliquez sur OK.

Pour configurer les autorisations de relais sur les serveurs virtuels SMTP Internet dans Exchange Server 2000

  1. Ouvrez le Gestionnaire système Exchange.

  2. Dans l'arborescence de la console, développez Serveurs, le serveur que vous souhaitez configurer, puis Protocoles et enfin SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP auquel vous souhaitez appliquer des restrictions de relais, puis cliquez sur Propriétés.

  4. Dans Propriétés de <serveur virtuel SMTP>, cliquez sur l'onglet Accès, puis sur Relais.

  5. Dans Restrictions de relais, sous Sélectionnez l'ordinateur autorisé à relayer via ce serveur virtuel, sélectionnez Uniquement la liste ci-dessous.

  6. Cliquez sur Ajouter pour ajouter un seul ordinateur, groupe d'ordinateurs ou un nom de domaine SMTP, puis cliquez sur OK. Répétez cette étape pour chaque entrée supplémentaire à ajouter.

  7. Activez la case à cocher Autoriser tous les ordinateurs authentifiés à relayer, sans tenir compte de la liste ci-dessus, puis cliquez à deux reprises sur OK.

Pour plus d'informations sur la sécurité et le relais de messages, voir les guides suivants de la bibliothèque technique d'Exchange Server 2003 :

  • le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579).

  • le Ralentissement et arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=47587)

Pour plus d'informations sur le test et la sécurisation du comportement de relais ouvert dans votre environnement Exchange et Microsoft Windows, voir l'article 304897 de la Base de connaissances Microsoft sur les serveurs Microsoft SMTP qui peuvent sembler accepter et relayer les messages électroniques dans les tests tiers (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=304897).


La version de SMTP utilisée ne prend pas en charge le verbe XEXCH50
Microsoft Exchange Server Analyzer - Articles > Réseau >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lance une session SMTP avec le serveur Exchange pour confirmer que les verbes Exchange SMTP corrects sont répertoriés. Si le verbe XEXCH50 n'est pas répertorié, un avertissement s'affiche.

Le verbe XEXCH50 est notamment utilisé par Exchange pour la réplication de dossiers publics. Exécuter une version de SMTP sur un serveur Exchange qui ne prend pas en charge le verbe XEXCH50 interrompra la réplication de dossiers publics.

Le verbe XEXCH50 n'est pas utilisé par d'autres fournisseurs SMTP, par conséquent, cette fonctionnalité est disponible dans un fichier (peexch50.dll) installé et enregistré par le programme d'installation d'Exchange.

Exchange Server Analyzer peut renvoyer cet avertissement si vous utilisez un produit antivirus qui installe et utilise sa propre pile de protocoles SMTP pour analyser les messages. Dans ce cas, le logiciel antivirus utilise sa propre pile SMTP pour intercepter et analyser les messages avant qu'ils n'atteignent la pile SMTP d'Exchange. Dans ce cas, la pile SMTP dans le logiciel antivirus n'utilise pas le verbe XEXCH50.

Il est recommandé d'exécuter le logiciel antivirus dans un mode qui ne requiert pas l'installation de sa propre pile SMTP sur le serveur Exchange ou de lancer ce logiciel au périmètre entrant de votre réseau SMTP. Si vous avez désactivé la pile SMTP pour le logiciel antivirus et si vous obtenez toujours cet avertissement, réinstallez Exchange pour installer et enregistrer correctement le fichier peexch50.dll.

Pour plus d'informations sur le verbe XEXCH50 et d'autres verbes propriétaires utilisés par Exchange, voir l'article 812455 de la Base de connaissances Microsoft sur les définitions des verbes utilisés entre 2 serveurs Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455).

Pour plus d'informations sur l'affichage des verbes de commande Exchange et la réinstallation d'Exchange 2000 Server, voir l'article 319885 de la Base de connaissances sur la non-remise des messages envoyés dans l'organisation Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885).

Pour plus d'informations sur l'affichage des verbes de commande Exchange et sur la réinstallation d'Exchange Server 2003, voir l'article 822939 de la Base de connaissances sur la non-remise des messages envoyés dans l'organisation Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939).


Protocoles
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant les protocoles Internet. En outre, ils décrivent les actions possibles pour corriger les erreurs liées aux protocoles Internet, les avertissements et les configurations autres que celles par défaut détectés par Exchange Server Analyzer.


Erreur de réponse de la boucle Active Directory
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PingStatus pour déterminer la valeur (clé StatusCode) renvoyée par le serveur du service d'annuaire Active Directory®. Win32_PingStatus renvoie un objet avec 24 propriétés qui fournit davantage de détails sur les paquets ping envoyés par la classe.

Si Exchange Server Analyzer détecte que la valeur de cette clé correspond à l'une des valeurs du tableau suivant, une erreur s'affiche.

Exchange Server Analyzer affiche le nom du serveur Active Directory et la valeur StatusCode correspondante renvoyée avec l'erreur.

Valeur StatusCode Signification Description

11001

Tampon trop petit

Il est peu probable que cette erreur soit renvoyée car Exchange Server Analyzer génère une requête standard.

11002

Réseau de destination inaccessible

La requête a échoué car le réseau contenant l'ordinateur de destination n'est pas accessible ; aucun itinéraire valide vers l'ordinateur de destination n'existe.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Hôte de destination inaccessible

La requête a échoué car l'ordinateur de destination n'est pas accessible.

Pour plus d'informations, voir Le serveur Active Directory est arrêté ou inaccessible.

Cette erreur peut également être provoquée par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible, voire par une erreur DNS.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocole de destination inaccessible

La requête a échoué car l'ordinateur de destination ne répond pas au protocole du paquet.

Cette erreur peut également être provoquée par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11005

Port de destination inaccessible

La requête a échoué car le port de l'ordinateur de destination n'est pas disponible.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Aucune ressource

La requête a échoué car les ressources réseau sont insuffisantes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Option non valide

La requête a échoué car elle contient une option non valide.

Il est peu probable que cette erreur soit renvoyée car Exchange Server Analyzer génère une requête standard.

11008

Erreur matérielle

La requête a échoué en raison d'une erreur matérielle.

Vérifiez que le contrôleur de domaine fonctionne correctement en exécutant l'outil de vérification matérielle du fabricant de votre ordinateur.

11009

Paquet trop volumineux

La requête a échoué car le paquet qui la contient est plus grand que l'unité de transmission maximale (MTU) d'un nœud (routeur ou passerelle) située entre la source et la destination. L'unité de transmission maximale définit la taille maximale du paquet transmissible.

La requête envoyée par Exchange Server Analyzer n'est pas supérieure à 10 Ko. Vérifiez que les routeurs et passerelles de votre organisation sont correctement configurés.

Pour plus d'informations, voir l'article 159211 de la Base de connaissances sur la détection des routeurs trou noir et les solutions s'y rapportant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Délai de la requête écoulé

Aucune réponse n'a été reçue dans le délai imparti. Le délai de réponse par défaut est de 5 secondes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Requête incorrecte

La requête a échoué car elle n'a pas été encodée correctement.

Il est peu probable que cette erreur soit renvoyée car Exchange Server Analyzer génère une requête standard.

11012

Itinéraire incorrect

La requête a échoué car il n'existe pas d'itinéraire valide entre les ordinateurs source et de destination.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Transit de la propriété TimeToLive expiré

La requête a échoué car la valeur de la durée de vie a atteint zéro. Par conséquent, le nœud de transfert (routeur ou passerelle) ignore le paquet.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Réassemblage de la propriété TimeToLive expiré

La requête a échoué car le paquet a été divisé en fragments pour la transmission et tous les fragments n'ont pas été reçus dans le délai imparti pour le réassemblage. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) définit sur 60 secondes le délai maximal pendant lequel tous les fragments du paquet doivent être reçus.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problème de paramètre

La requête a échoué car un nœud (routeur ou passerelle) a rencontré des problèmes lors du traitement de l'en-tête du paquet. Cet état survient si, par exemple, l'en-tête contient des données de champ non valides ou une option non reconnue.

Il est peu probable que cette erreur soit renvoyée car Exchange Server Analyzer génère une requête standard.

11016

Extinction de source

La requête a échoué car le paquet a été ignoré. Cela se produit lorsque la file d'attente de sortie de l'ordinateur source ne dispose pas d'un espace de stockage suffisant ou lorsque les paquets arrivent à destination trop rapidement pour être traités.

Il est peu probable que cette erreur soit renvoyée car Exchange Server Analyzer génère une requête standard.

11017

Option trop volumineuse

La requête a échoué car elle contient une option non valide.

Il est peu probable que cette erreur soit renvoyée car Exchange Server Analyzer génère une requête standard.

11018

Destination non valide

La requête a échoué car l'adresse IP de destination ne peut pas recevoir de requêtes PING ou ne s'affiche jamais dans le champ d'adresse de destination d'un datagramme IP.

Cela peut également être provoqué par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11032

Négociation de IPSEC

La requête a échoué car une connexion IPsec n'a pas pu être négociée.

11050

Échec général

La requête a échoué pour une raison inconnue.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Erreur de réponse de la boucle Active Directory-Exchange Server
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PingStatus pour déterminer la valeur de la clé StatusCode renvoyée par le serveur du service d'annuaire Active Directory®. Win32_PingStatus renvoie un objet avec 24 propriétés qui fournit davantage de détails sur les paquets ping envoyés par la classe.

Si Exchange Server Analyzer détecte que la valeur de cette clé correspond à l'une des valeurs du tableau suivant, il affiche une erreur.

Exchange Server Analyzer affiche le nom du serveur Active Directory, le nom du serveur Exchange et la valeur StatusCode correspondante renvoyée avec cette erreur.

Valeur StatusCode Signification Description

11001

Tampon trop petit

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11002

Réseau de destination inaccessible

La requête a échoué car le réseau qui contient l'ordinateur de destination n'est pas accessible. Aucun itinéraire valide n'existe vers l'ordinateur de destination.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Hôte de destination inaccessible

La requête a échoué car l'ordinateur de destination n'est pas accessible.

Pour plus d'informations, voir la rubrique sur le Le serveur Active Directory est arrêté ou inaccessible.

Cette erreur peut également être provoquée par l'une des conditions suivantes :

  • un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible ;

  • une erreur DNS.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocole de destination inaccessible

La requête a échoué car l'ordinateur de destination ne répond pas au protocole du paquet.

Cette erreur peut également être provoquée par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11005

Port de destination inaccessible

La requête a échoué car le port de l'ordinateur de destination n'est pas disponible.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Aucune ressource

La requête a échoué car les ressources réseau sont insuffisantes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Option non valide

La requête a échoué car elle contient une option non valide.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11008

Erreur matérielle

La requête a échoué en raison d'une erreur matérielle.

Vérifiez que le contrôleur de domaine fonctionne correctement en exécutant l'outil de vérification matérielle fourni par le fabricant de votre ordinateur.

11009

Paquet trop volumineux

La requête a échoué car le paquet qui la contient est plus grand que l'unité de transmission maximale (MTU) d'un nœud (routeur ou passerelle) située entre la source et la destination. L'unité de transmission maximale définit la taille maximale du paquet transmissible.

La requête envoyée par Exchange Server Analyzer n'est pas supérieure à 10 Ko. Vérifiez que les routeurs et passerelles de votre organisation sont correctement configurés.

Pour plus d'informations, voir l'article 159211 de la Base de connaissances Microsoft sur la détection des routeurs trou noir et les solutions s'y rapportant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Délai de la requête écoulé

Aucune réponse n'a été reçue dans le délai imparti. Le délai de réponse par défaut est de 5 secondes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Requête incorrecte

La requête a échoué car elle n'a pas été encodée correctement.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11012

Itinéraire incorrect

La requête a échoué car il n'existe pas d'itinéraire valide entre les ordinateurs source et de destination.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Transit de la propriété TimeToLive expiré

La requête a échoué car la valeur de Time to Live (TTL) a atteint zéro. Le nœud de transfert (routeur ou passerelle) va donc ignorer le paquet.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Réassemblage de la propriété TimeToLive expiré

La requête a échoué car le paquet a été divisé en fragments pour la transmission et tous les fragments n'ont pas été reçus dans le délai imparti pour le réassemblage. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) définit sur 60 secondes le délai maximal pendant lequel tous les fragments du paquet doivent être reçus.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problème de paramètre

La requête a échoué car un nœud (routeur ou passerelle) a rencontré des problèmes lors du traitement de l'en-tête du paquet. Cela peut se produire si l'en-tête contient des données de champ non valides ou une option non reconnue.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11016

Extinction de source

La requête a échoué car le paquet a été ignoré. Cela se produit lorsque la file d'attente de sortie de l'ordinateur source ne dispose pas d'un espace de stockage suffisant ou lorsque les paquets arrivent à destination trop rapidement pour être traités.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11017

Option trop volumineuse

La requête a échoué car elle contient une option non valide.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11018

Destination non valide

La requête a échoué pour l'une des raisons suivantes :

  • L'adresse IP de destination ne peut pas recevoir de requêtes PING.

  • L'adresse IP de destination ne s'affiche jamais dans le champ d'adresse de destination d'un datagramme IP.

Cela peut également être provoqué par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11032

Négociation de IPSEC

La requête a échoué car une connexion IPsec n'a pas pu être négociée.

11050

Échec général

La requête a échoué pour une raison inconnue.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Accès anonyme autorisé sur des serveurs virtuels SMTP internes et dédiés pour les clients POP et IMAP
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchAuthenticationFlags dans la classe protocolCfgSMTPServer de l'objet Exchange Server. La classe protocolCfgSMTPServer contient les paramètres d'un serveur virtuel SMTP. L'attribut msExchAuthenticationFlags représente le type d'authentification autorisé sur le serveur SMTP. Exchange Server Analyzer affiche un message d'avertissement si les conditions suivantes existent :

  • L'authentification sur l'attribut msExchAuthenticationFlags a été configurée de sorte à autoriser l'accès au serveur SMTP.

  • Le serveur n'est pas un serveur Microsoft Small Business Server 2000 ou Microsoft Windows® Small Business Server 2003.

  • Exchange Server héberge plus de 20 boîtes aux lettres.

Pour accroître la sécurité, désactivez l'accès anonyme sur vos serveurs virtuels SMTP internes qui n'acceptent pas le courrier Internet entrant. Vous pouvez également désactiver l'accès anonyme sur les serveurs virtuels SMTP dédiés pour les utilisateurs POP et IMAP distants.

Important :
Ne désactivez pas l'accès anonyme sur vos serveurs virtuels SMTP têtes de pont Internet. Les serveurs virtuels SMTP qui acceptent le courrier provenant d'Internet doivent autoriser l'accès anonyme.

Lors de l'envoi de courrier interne, les serveurs Exchange de votre organisation s'authentifient mutuellement pour l'envoi de courrier. C'est pourquoi vous ne devez pas activer l'accès anonyme sur vos serveurs virtuels SMTP internes. Le refus de l'accès anonyme sur vos serveurs internes ne perturbe pas le flux de messages et offre une couche de sécurité supplémentaire sur votre serveur virtuel SMTP interne.

De même, les clients POP et IMAP s'authentifient sur vos serveurs virtuels SMTP avant d'envoyer du courrier à des serveurs virtuels SMTP. Par conséquent, si vous utilisez des serveurs virtuels SMTP dédiés pour vos clients POP et IMAP, vous pouvez les configurer de sorte à n'autoriser que l'accès authentifié. Si vous désactivez l'accès anonyme sur ces serveurs, vous pouvez contribuer à empêcher les utilisateurs non autorisés d'y accéder.

Si vous ne pouvez pas désactiver l'accès authentifié sur votre serveur virtuel SMTP pour des raisons professionnelles, telles que l'authentification par une société partenaire, effectuez la procédure suivante pour améliorer la sécurité sur votre serveur de passerelle :

  • Mettez en œuvre une stratégie des mots de passe forts, en particulier pour le compte administrateur.

  • Désactivez le compte invité. Pour plus d'informations sur la désactivation du compte invité, voir l'article 320053 de la Base de connaissances Microsoft sur la procédure de changement de nom des comptes administrateur et invité dans Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053). Bien que cet article s'applique à Windows 2000 Server, les mêmes principes s'appliquent à Windows Server 2003.

Pour désactiver l'authentification des accès anonymes pour un serveur virtuel SMTP

  1. Dans le Gestionnaire système Exchange, développez Serveurs, <your inbound Exchange server>, Protocoles et SMTP.

  2. Cliquez avec le bouton droit sur le serveur virtuel SMTP entrant, puis cliquez sur Propriétés.

  3. Cliquez sur l'onglet Accès, puis sur Authentification.

  4. Dans Authentification, désactivez la case à cocher Accès anonyme.

Pour plus d'informations sur la configuration de votre organisation Exchange Server 2003 de sorte à envoyer et recevoir du courrier Internet de manière plus sécurisée, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


L'analyse antivirus en arrière-plan a été activée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'analyse antivirus en arrière-plan est activée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Si Exchange Server Analyzer détecte que la valeur de l'entrée BackgroundScanning est définie sur 1, un avertissement s'affiche.

Lorsque l'entrée de Registre BackgroundScanning est présente et définie sur 1, tous les messages sont analysés une nouvelle fois en arrière-plan à chaque mise à jour du fichier de signature du programme antivirus. Ce comportement affecte considérablement les performances à chaque fois qu'un fichier de signature antivirus est mis à jour et n'est, par conséquent, pas recommandé par Microsoft.

Lorsque vous utilisez un programme antivirus VSAPI 2.0 (interface de programmation d'applications d'analyse antivirus) et qu'un client tente d'ouvrir un message, une comparaison est effectuée pour s'assurer que le corps du message et la pièce jointe ont été analysés par le fichier de signature antivirus actuel. Si le fichier de motif de signature actuel n'a pas été utilisé pour analyser le contenu, le message correspondant est envoyé au programme antivirus avant que le message ne soit disponible pour le client.

Si le programme antivirus installé n'est pas doté d'une interface utilisateur vous permettant de désactiver l'analyse en arrière-plan, vous pouvez utiliser la procédure ci-dessous pour contrôler ce comportement en modifiant le Registre sur l'ordinateur Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Dans le volet droit, double-cliquez sur la valeur BackgroundScanning.

  4. Dans le champ Données de la valeur, définissez la valeur sur 0.

  5. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange, ainsi que les services du logiciel antivirus, pour que la modification soit prise en compte.
  • Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

  • Pour plus d'informations sur les différents types de programmes d'analyse antivirus utilisés par Exchange, voir l'article 328841 de la Base de connaissances sur Exchange et le logiciel antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).


La valeur CheckPop3Tail a été modifiée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

Si Exchange Server Analyzer détecte que la valeur CheckPop3Tail est présente et configurée avec une valeur 1, un message indiquant une configuration autre que celle par défaut s'affiche.

Le document RFC (Request for Comments) 1939 du groupe de travail IETF (Internet Engineering Task Force) (http://www.ietf.org/rfc/rfc1939.txt) spécifie une séquence de fin CRLF pour les messages POP3. En langage Exchange, la séquence CRLF est désignée en tant que POP3Tail. Si un client POP3, tel que Microsoft Office Outlook® 2003, Microsoft Outlook Express, traite un message incorrect avec un POP3Tail incorrect (par exemple, une CRLF manquante), il peut interrompre la réponse et ne pas télécharger tous les messages se trouvant dans la boîte de réception. La valeur de Registre CheckPop3Tail représente une opportunité de configuration pour les administrateurs qui demandent au service Microsoft Exchange POP3 de vérifier le POP3Tail de chaque message POP3 et d'ajouter la séquence de fin correcte si elle est manquante.

Remarque :
Ce paramètre corrigera les messages incorrects et permettra au client POP3 de télécharger tous les messages de la boîte de réception de l'utilisateur ; toutefois, il entraînera également une légère dégradation des performances car chaque message sera vérifié pour déterminer si le POP3Tail est correct.

Si vous le souhaitez, vous pouvez utiliser la procédure ci-dessous pour supprimer la valeur de Registre CheckPop3Tail.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer la valeur de Registre CheckPop3Tail

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Supprimez la valeur nommée CheckPop3Tail.

  4. Fermez l'Éditeur du Registre et redémarrez le service Microsoft Exchange POP3 pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre CheckPop3Tail, voir l'article 816896 de la Base de connaissances sur le client POP3 qui cesse de répondre (blocage) ou qui se déconnecte lorsque vous tentez de télécharger des messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816896).


Le système de message de défense est activé
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut heuristics a été configuré de manière à activer le système de message de défense. Par défaut, l'attribut heuristics n'est pas configuré. Si Exchange Server Analyzer détecte que l'attribut heuristics est défini sur 256, il affiche un message indiquant une configuration autre que celle par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Le programme du système de message de défense a été conçu par le sous-secrétariat de la Défense (Acquisition) pour faciliter et coordonner le développement d'un système de message à utilisation commune intégré qui réponde aux exigences writer-à-lecteur, limite les coûts et le personnel et améliore la fonctionnalité, la sécurité, la survie et la disponibilité.

Pour plus d'informations sur le système de message de défense, voir le site Web Lockheed Martin (http://www.lockheedmartin.com).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Désactivation de l'avertissement des clients MAPI
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-05-01

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le blocage du client MAPI a été défini :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

Si Exchange Server Analyzer détecte que la valeur de Disabled MAPI Clients est définie sur une valeur qui commence par -10, -11 ou -12, il affiche un avertissement.

Par défaut, la clé Disable MAPI Clients n'est pas activée. Par conséquent, un administrateur peut empêcher des versions spécifiques de Microsoft Office Outlook® de se connecter à un ordinateur Exchange 2000 Server, Exchange Server 2003 ou Exchange Server 2007.

Si la clé Disabled MAPI Clients est définie de manière à ce que la valeur commence par -10, -11 ou -12, l'ensemble des plages de versions MAPI sont bloquées. Ces plages correspondent aux versions d'Outlook 2000, d'Outlook 2003 et d'Outlook 2007 et au service Surveillance du système Exchange dans Exchange Server 2003. Le blocage de ce service entraînera probablement des dysfonctionnements d'Exchange Server.

Pour corriger cet avertissement, suivez les recommandations et procédures décrites dans la rubrique Toutes les versions de Outlook sont autorisées à accéder au serveur.

Pour plus d'informations sur le blocage de certains clients MAPI pour la connexion à un ordinateur exécutant Exchange 2000 Server ou Exchange Server 2003, consultez les articles suivants de la Base de connaissances Microsoft :

  • 328240 sur la procédure de définition des restrictions côté serveur pour les clients utilisés pour accéder aux boîtes aux lettres Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894 sur la procédure de désactivation de l'accès des clients MAPI à un ordinateur Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894).

Pour plus d'informations sur le blocage de clients MAPI spécifiques se connectant à un ordinateur exécutant Exchange Server 2007, consultez la rubrique sur la cmdlet Set-CasMailbox de l'environnement de ligne de commande Exchange Management Shell dans la documentation sur le produit Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=80698).

Pour plus d'informations sur le téléchargement de mises à jour de sécurité pour les versions plus anciennes d'Outlook et le blocage d'autres versions d'Outlook, consultez l'article relatif au ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=30732).


La valeur DisableSMTPMailboxAddressing est définie
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-08-11

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur est définie de manière à désactiver l'adressage des boîtes aux lettres SMTP (Simple Mail Transfer Protocol) :

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

La valeur 1 pour la clé DisableSMTPMailboxAddressing indique que l'adressage des boîtes aux lettres SMTP est désactivé (true) ; la valeur 0 qu'il ne l'est pas (false).

Si Exchange Server Analyzer détermine que la valeur de la clé DisableSMTPMailboxAddressing est définie sur la valeur 1 de manière à désactiver l'adressage des boîtes aux lettres SMTP, il affiche un avertissement.

Cette erreur indique que l'adressage des boîtes aux lettres SMTP est désactivé. Cela peut provoquer des erreurs de synchronisation pour les clients ActiveSync Microsoft Exchange qui se connectent à ce serveur.

Pour supprimer cet avertissement, définissez la valeur de la clé DisableSMTPMailboxAddressing sur 0.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour modifier la valeur de la clé DisableSMTPMailboxAddressing

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Accédez à :

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. Dans le volet droit, recherchez et double-cliquez sur DisableSMTPMailboxAddressing.

  2. Modifiez la valeur 1 en 0.

  3. Fermez l'Éditeur du Registre et redémarrez le service Serveur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'erreur de synchronisation associée à cet avertissement, voir l'article 886346 de la Base de connaissances Microsoft sur le message d'erreur HTTP_500 qui s'affiche lors de la synchronisation de votre appareil mobile avec Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346).


Répartition de la charge des utilisateurs
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre serveur présente un nombre élevé d'opérations RPC par seconde.

Dans ce cas, ExMon, l'outil de surveillance des utilisateurs d'Exchange Server, permet d'identifier la répartition de la charge. Il est important de déterminer si la charge est due à l'une des circonstances suivantes :

  • Le nombre d'utilisateurs actifs est relativement restreint.

  • La charge est répartie sur de nombreux utilisateurs.

Si un seul utilisateur est identifié comme la cause d'un pourcentage élevé de la charge, Exchange Server Analyzer affiche un avertissement indiquant qu'une utilisation élevée peut être due à un seul utilisateur. Si ce n'est pas le cas, Exchange Server Analyzer affiche un message indiquant que la charge est répartie sur un grand nombre d'utilisateurs.

Remarque :
Le trafic RPC varie au fil du temps. Par conséquent, pour collecter des données statistiques intéressantes sur l'utilisation d'Exchange, vous devez le faire à plusieurs reprises.

En outre, certaines opérations d'utilisateur commun vont fortement accroître l'utilisation du processeur sur une courte période. Ces opérations ne sont pas inquiétantes sauf si un même utilisateur accroît l'utilisation du processeur fréquemment ou pendant de longues périodes.

Remarque :
Vous pouvez ignorer cet avertissement en toute sécurité si la source de la charge élevée est un processus ou service connu conçu pour supporter des charges élevées et qui traite les demandes de nombreux utilisateurs et génère une charge supérieure aux utilisateurs individuels. Il s'agit notamment de certains services qui synchronisent les périphériques mobiles, de processus serveurs qui gèrent des données de disponibilité, de services liés à la messagerie vocale ou unifiée et de processus serveur qui déplacent des utilisateurs.
Pour résoudre ce problème

  • Si le taux de RPC est élevé (pour un seul utilisateur ou pour tous), essayez de savoir si les utilisateurs possèdent des moteurs de recherche de bureau, des plug-ins clients tiers ou des périphériques mobiles qui synchronisent le courrier électronique avec la boîte aux lettres de l'utilisateur. Pour plus d'informations sur la résolution des problèmes des applications tierces, voir la rubrique sur la Désactivation des compléments tiers sur le client.

  • Les utilisateurs doivent avoir moins de 5 000 éléments dans les dossiers par défaut et ceux utilisés fréquemment.

  • Il est recommandé d'avoir des boîtes aux lettres d'une taille maximale de 1 Go. Pour les utilisateurs qui provoquent une charge élevée, il est recommandé d'archiver leurs éléments de boîtes aux lettres dans un fichier .pst. Vous pouvez ensuite réexécuter l'outil Performance d'Exchange (Perfmon) pour voir si la charge de l'utilisateur reste élevée.

  • Contactez l'utilisateur pour identifier les applications clientes qui peuvent accéder au programme de messagerie électronique du client. Supprimez-les et réinstallez-les une à une pour observer leur impact sur le serveur.

  • Les faux positifs sont monnaie courante lors de la résolution de problèmes de charge des utilisateurs. Par conséquent, il est recommandé de réexécuter ExMon en cas de charge élevée pour vérifier si l'analyse est cohérente.

Pour plus d'informations

  • Pour télécharger ExMon, l'outil de surveillance des utilisateurs d'Exchange Server, voir le Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=54983).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la résolution des problèmes de performances des clients Outlook, voir l'article 905803 de la Base de connaissances Microsoft sur les utilisateurs d'Outlook confrontés à de faibles performances lorsqu'ils utilisent un dossier contenant de nombreux éléments sur un serveur qui exécute Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803).

  • Pour plus d'informations sur le logiciel de recherche de bureau, voir l'article 905184 de la Base de connaissances Microsoft sur les performances d'Exchange 2000 Server et d'Exchange Server 2003 qui risquent d'être affectées en cas d'exécution du logiciel de moteur de recherche de bureau sur Outlook ou d'autres ordinateurs clients MAPI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184).


Le répertoire virtuel Exchange pour OMA et EAS a été remplacé
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'adresse proxy SMTP pour Exchange ActiveSync® a été remplacée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

Si Exchange Server Analyzer détecte que l'entrée de Registre ExchangeVDir est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

L'entrée de Registre ExchangeVDir est utilisée par Microsoft Outlook® Mobile Access et Exchange ActiveSync. Elle spécifie le répertoire virtuel utilisé par Outlook Mobile Access et Exchange ActiveSync pour accéder aux modèles Microsoft Office Outlook Web Access pour Exchange Server 2003 et à World Wide Web Distributed Authoring and Versioning (WebDAV) sur les serveurs principaux Exchange Server 2003 où résident les boîtes aux lettres d'utilisateurs.

Si l'entrée ExchangeVDir n'existe pas ou si aucune valeur n'est définie pour elle, la valeur par défaut de /Exchange est utilisée. Dans le cas contraire, elle contient le nom du répertoire virtuel (barre oblique « / » incluse). Vous pouvez configurer cette valeur lorsque vous souhaitez spécifier un répertoire virtuel pour Outlook Mobile Access ou Exchange ActiveSync.

Il existe un problème connu dans Exchange Server 2003 : les services mobiles Exchange ne fonctionnent pas lors de l'authentification basée sur des formulaires sur une seule topologie Exchange Server 2003. Lorsque le répertoire virtuel /Exchange sur un serveur principal Exchange Server 2003 est configuré pour nécessiter SSL (Secure Sockets Layer) ou lorsque l'authentification basée sur des formulaires est activée, Outlook Mobile Access ne peut pas accéder à ce répertoire virtuel. Ce problème ne survient pas lorsque vous activez ces paramètres dans le répertoire virtuel /Exchange sur un serveur frontal.

Il est possible de le résoudre à l'aide de la configuration en créant la valeur de Registre ExchangeVDir.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Examinez et, au besoin, modifiez la valeur ExchangeVDir.

  4. Fermez l'Éditeur du Registre. Si une modification est effectuée, redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la résolution de ce problème, voir l'article 817317 de la Base de connaissances sur la non-prise en charge du mappage de plusieurs adresses proxy vers des répertoires racines virtuels principaux sur un même serveur (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817317).


Un produit compatible API d'analyse antivirus Exchange a été détecté, mais n'est pas actuellement activé
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le logiciel compatible VSAPI (interface de programmation d'applications d'analyse antivirus) est activé sur l'ordinateur Exchange Server :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

L'outil Exchange Server Analyzer Tool interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour Ese.dll, le moteur de stockage de base de données Exchange (ESE).

En outre, Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Microsoft Exchange 2000 Server. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Microsoft Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de Version ne contient pas une sous-chaîne de 6 dans ses informations de version, mais que la valeur de serialNumber indique qu'Exchange 2000 Server ou Exchange Server 2003 est installé, une version autre qu'Exchange d'ESE s'exécute sur le serveur Exchange.

Si Exchange Server Analyzer détermine qu'une version autre qu'Exchange d'ESE n'est pas utilisée et que la valeur de la clé de Registre VirusScan \Enabled est égale à 0, un avertissement s'affiche. Si Exchange Server Analyzer détermine qu'une version autre qu'Exchange d'ESE est utilisée sur le serveur Exchange, un avertissement distinct s'affiche.

En général, il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP ou sur les ordinateurs Exchange Server qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur l'ordinateur Exchange Server qui utilise VSAPI 2.0 (Exchange 2000 Server) ou VSAPI 2.5 (Exchange Server 2003).

Vous devez en outre exécuter le logiciel antivirus sur les ordinateurs clients. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (c.-à-d. qu'il peut analyser des messages MIME) sur la passerelle ou sur le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur les ordinateurs clients est suffisante.

Pour supprimer cet avertissement

  1. Dans l'interface utilisateur du programme de logiciel antivirus, activez l'analyse VSAPI.

  2. Si le problème persiste après avoir activé l'analyse VSAPI, contactez votre fournisseur de logiciels antivirus.

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).


Le produit compatible API d'analyse antivirus Exchange a été détecté, mais n'est pas installé correctement
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le logiciel compatible VSAPI (interface de programmation d'applications d'analyse antivirus) qui s'exécute sur l'ordinateur dispose d'une bibliothèque valide référencée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Si Exchange Server Analyzer détecte que la valeur de Library ne contient pas un chemin d'accès valide pour un fichier bibliothèque antivirus VSAPI (DLL), un avertissement s'affiche.

En général, il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP ou sur les ordinateurs Exchange Server qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur l'ordinateur Exchange Server qui utilise VSAPI 2.0 (Exchange 2000 Server) ou VSAPI 2.5 (Exchange Server 2003).

Vous devez en outre exécuter le logiciel antivirus sur les ordinateurs clients. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (c.-à-d. qu'il peut analyser des messages MIME) sur la passerelle ou sur le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur les ordinateurs clients est suffisante.

Pour supprimer cet avertissement

  1. Désinstallez, puis réinstallez le logiciel antivirus.

  2. Si le problème persiste après la réinstallation du logiciel, contactez votre fournisseur de logiciels antivirus.

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Pour plus d'informations sur les programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).


Faible nombre de threads API d'analyse antivirus Exchange
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de ScanningThreads :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

La valeur de Registre ScanningThreads représente le nombre maximal de threads API d'analyse antivirus (VSAPI) allouée à l'analyse.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si l'analyse de message VSAPI est activée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

La valeur 1 pour Enabled indique que l'analyse VSAPI est activée. La valeur 0 indique que l'analyse VSAPI n'est pas activée.

L'outil Microsoft® Exchange Server Analyzer Tool interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur définie pour la clé NumberOfProcessors. Cette valeur représente le nombre de processeurs installés sur l'ordinateur, y compris les processeurs physiques et logiques. La technologie Hyper-Threading de Intel permet de diviser un processeur physique en deux processeurs logiques.

Si Exchange Server Analyzer détecte que la valeur de ScanningThreads est inférieure à (2 × NumberOfProcessors) + 1 sur un ordinateur Exchange Server sur lequel l'analyse VSAPI est activée, un avertissement s'affiche. La valeur optimale de ScanningThreads est égale à (2 × NumberOfProcessors) + 1. Par exemple, sur un ordinateur Exchange Server à deux processeurs, la valeur optimale de ScanningThreads est 5.

Remarque :
S'il est équipé de la technologie Hyper-Threading, la valeur de NumberOfProcessors double le nombre de processeurs physiques. Il est recommandé de contacter le fabricant de votre logiciel antivirus pour déterminer si des processeurs physiques ou logiques peuvent être utilisés par la formule ci-dessus.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Dans le volet droit, double-cliquez sur ScanningThreads.

  4. Entrez la valeur renvoyée par la formule ci-dessus.

  5. Fermez l'Éditeur du Registre, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la technologie Hyper-Threading, voir le site Web d'Intel (http://www.intel.com/technology/hyperthread).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Serveur DNS externe utilisé pour le protocole SMTP
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchSMTPExternalDNSServers dans la classe protocolCfgSMTPServer de l'objet Exchange Server. La classe protocolCfgSMTPServer contient les paramètres d'un serveur virtuel SMTP. Si l'attribut msExchSMTPExternalDNSServers est défini, le serveur virtuel SMTP utilise un serveur DNS externe. Si Exchange Server Analyzer détermine que l'attribut msExchSMTPExternalDNSServers est défini, un avertissement s'affiche.

Si vous configurez votre serveur virtuel SMTP pour qu'il utilise un serveur DNS externe, vous pouvez rencontrer des problèmes de performances. Cette configuration n'est dès lors pas recommandée.

Pour modifier le paramètre DNS externe sur un serveur virtuel SMTP

  1. Dans le Gestionnaire système Exchange, développez Serveurs, <votre serveur Exchange entrant>, Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  3. Sélectionnez l'onglet Remise, puis cliquez sur Avancé.

  4. Cliquez sur Configurer pour configurer des serveurs DNS externes.

  5. Pour ajouter un serveur DNS externe, cliquez sur Ajouter, entrez l'adresse IP du serveur DNS externe dans la boîte de dialogue Ajouter, puis cliquez sur OK.

  6. Pour supprimer un serveur DNS externe, sélectionnez une adresse IP, puis cliquez sur Supprimer.

  7. Cliquez sur OK.

Pour plus d'informations sur la configuration du service DNS dans votre organisation Exchange Server 2003, voir la section sur la configuration du service DNS dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la configuration des connecteurs SMTP pour qu'ils se lient aux domaines Internet dans Exchange, voir l'article 319426 de la Base de connaissances Microsoft sur la procédure de configuration du connecteur SMTP pour qu'il se lie aux domaines Internet dans Exchange (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426).


Le serveur frontal utilise une authentification de base
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'authentification de base est configurée entre un serveur frontal et un serveur principal :

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

Si Exchange Server Analyzer détecte que la clé UseBasicAuthToBE a été définie, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, les serveurs frontaux Exchange Server 2003 utilisent l'authentification Kerberos pour aider à protéger les informations d'identification de l'utilisateur entre les serveurs frontaux et principaux. Si l'authentification Kerberos échoue, un événement d'avertissement sera consigné et le serveur frontal tentera plutôt l'authentification NTLM. Si NTLM échoue, une erreur sera consignée. Une nouvelle tentative d'authentification Kerberos sera effectuée dans 30 minutes. Lorsque les ordinateurs frontaux Exchange 2000 Server ou Exchange Server 2003 s'authentifient auprès des ordinateurs principaux Exchange 2000 Server, NTLM est utilisé.

Définir la clé de Registre UseBasicAuthToBE remplace cette logique par défaut et contraint les serveurs frontaux Exchange à utiliser l'authentification de base pour toutes les communications avec les serveurs principaux. Si votre organisation Exchange compte plus de 1 000 banques de boîtes aux lettres, vous devez définir cette clé de Registre. Un problème connu existe lorsque les utilisateurs accédant aux boîtes aux lettres à partir de Microsoft Office Outlook® Web Access pour Exchange Server 2003 via des serveurs frontaux dans des organisations comptant plus de 1 000 banques de boîtes aux lettres ne peuvent accéder à leurs boîtes aux lettres.

Si vous ne disposez pas de plus de 1 000 banques de boîtes aux lettres et n'avez aucune raison de forcer l'authentification de base, pensez à supprimer la clé de Registre UseBasicAuthToBE.

L'authentification de base envoie des informations d'identification en texte clair. Si la clé de Registre UseBasicAuthToBE est définie sur votre serveur frontal Exchange, il est vivement recommandé d'utiliser le cryptage IPSec.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer la clé de Registre UseBasicAuthToBE

  1. Sur le serveur frontal Exchange, ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE.

  3. Cliquez avec le bouton droit sur UseBasicAuthToBE, cliquez sur Supprimer, puis sur Oui.

  4. Ouvrez le composant logiciel enfichable MMC Services, cliquez avec le bouton droit sur Service d'administration IIS, puis cliquez sur Redémarrer.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Échec du serveur de passerelle PING
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PingStatus pour déterminer la valeur de la clé StatusCode renvoyée par un serveur de passerelle non-Exchange. Win32_PingStatus renvoie un objet avec 24 propriétés qui fournit davantage de détails sur les paquets ping envoyés par la classe.

Si Exchange Server Analyzer détecte que la valeur de cette clé correspond à l'une des valeurs du tableau suivant, il affiche une erreur.

Exchange Server Analyzer affiche le nom du serveur de passerelle, le nom du serveur Exchange et la valeur StatusCode correspondante renvoyée avec cette erreur.

Valeur StatusCode Signification Description

11001

Tampon trop petit

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11002

Réseau de destination inaccessible

La requête a échoué car le réseau qui contient l'ordinateur de destination n'est pas accessible. Aucun itinéraire valide n'existe vers l'ordinateur de destination.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Hôte de destination inaccessible

La requête a échoué car l'ordinateur de destination n'est pas accessible.

Pour plus d'informations, voir la rubrique sur le Le serveur Active Directory est arrêté ou inaccessible.

Cette erreur peut également être provoquée par l'une des conditions suivantes :

  • un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible ;

  • une erreur DNS.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocole de destination inaccessible

La requête a échoué car l'ordinateur de destination ne répond pas au protocole du paquet.

Cette erreur peut également être provoquée par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11005

Port de destination inaccessible

La requête a échoué car le port de l'ordinateur de destination n'est pas disponible.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Aucune ressource

La requête a échoué car les ressources réseau sont insuffisantes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Option non valide

La requête a échoué car elle contient une option non valide.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11008

Erreur matérielle

La requête a échoué en raison d'une erreur matérielle.

Vérifiez que le contrôleur de domaine fonctionne correctement en exécutant l'outil de vérification matérielle fourni par le fabricant de votre ordinateur.

11009

Paquet trop volumineux

La requête a échoué car le paquet qui la contient est plus grand que l'unité de transmission maximale (MTU) d'un nœud (routeur ou passerelle) située entre la source et la destination. L'unité de transmission maximale définit la taille maximale du paquet transmissible.

La requête envoyée par Exchange Server Analyzer n'est pas supérieure à 10 Ko. Vérifiez que les routeurs et passerelles de votre organisation sont correctement configurés.

Pour plus d'informations, voir l'article 159211 de la Base de connaissances sur la détection des routeurs trou noir et les solutions s'y rapportant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Délai de la requête écoulé

Aucune réponse n'a été reçue dans le délai imparti. Le délai de réponse par défaut est de 5 secondes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Requête incorrecte

La requête a échoué car elle n'a pas été encodée correctement.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11012

Itinéraire incorrect

La requête a échoué car il n'existe pas d'itinéraire valide entre les ordinateurs source et de destination.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Transit de la propriété TimeToLive expiré

La requête a échoué car la valeur de Time to Live (TTL) a atteint zéro. Le nœud de transfert (routeur ou passerelle) va donc ignorer le paquet.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Réassemblage de la propriété TimeToLive expiré

La requête a échoué car le paquet a été divisé en fragments pour la transmission et tous les fragments n'ont pas été reçus dans le délai imparti pour le réassemblage. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) définit sur 60 secondes le délai maximal pendant lequel tous les fragments du paquet doivent être reçus.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problème de paramètre

La requête a échoué car un nœud (routeur ou passerelle) a rencontré des problèmes lors du traitement de l'en-tête du paquet. Cela peut se produire si l'en-tête contient des données de champ non valides ou une option non reconnue.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11016

Extinction de source

La requête a échoué car le paquet a été ignoré. Cela se produit lorsque la file d'attente de sortie de l'ordinateur source ne dispose pas d'un espace de stockage suffisant ou lorsque les paquets arrivent à destination trop rapidement pour être traités.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11017

Option trop volumineuse

La requête a échoué car elle contient une option non valide.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11018

Destination non valide

La requête a échoué pour l'une des raisons suivantes :

  • L'adresse IP de destination ne peut pas recevoir de requêtes PING.

  • L'adresse IP de destination ne s'affiche jamais dans le champ d'adresse de destination d'un datagramme IP.

Cela peut également être provoqué par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11032

Négociation de IPSEC

La requête a échoué car une connexion IPsec n'a pas pu être négociée.

11050

Échec général

La requête a échoué pour une raison inconnue.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).


Le paramètre MaxFieldLength des services IIS 6.0 n'est pas défini correctement
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la longueur de champ maximale pour les requêtes HTTP a été codée de manière irréversible dans le Registre.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur l'ordinateur de destination.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que l'ordinateur exécute un système d'exploitation Microsoft Windows 2000 Server et la valeur 5.2, qu'il exécute un système d'exploitation Microsoft Windows Server™ 2003.

Enfin, Exchange Server Analyzer examine la classe WMI (Windows Management Instrumentation) Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique que l'ordinateur Exchange Server est un serveur frontal.

Exchange Server Analyzer affiche un avertissement s'il détecte que la valeur de MaxFieldLength n'est pas définie sur 32768 sur un serveur Exchange principal sur lequel les conditions suivantes sont vraies :

  • Le serveur Exchange principal est exécuté sur Windows Server 2003.

  • Le serveur Exchange principal n'est pas configuré en tant que serveur frontal.

  • Le serveur Exchange principal présente plus de 500 boîtes aux lettres.

Le paramètre de Registre des services MaxFieldLength, absent par défaut, spécifie la taille maximale de toute demande client HTTP. Cette valeur est généralement définie en même temps que la valeur MaxRequestBytes. Dans des environnements plus grands, si ces valeurs ne sont pas définies sur 32768, les utilisateurs de Microsoft Office Outlook® Web Access pour Exchange Server peuvent rencontrer des échecs d'ouverture de session. En particulier, l'absence de ces valeurs peut provoquer des erreurs HTTP 400 - Demande incorrecte. Lors de la configuration de la valeur de Registre MaxFieldLength, vous devez également définir le paramètre MaxRequestBytes sur 32768 pour permettre aux utilisateurs membres de plus de 75 groupes d'ouvrir une session Outlook Web Access. La valeur de Registre MaxRequestBytes détermine la limite supérieure de la taille totale de la ligne Request et des en-têtes. Si sa valeur est inférieure à MaxFieldLength, la valeur MaxFieldLength est ajustée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition des paramètres MaxRequestBytes et MaxFieldLength

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Cliquez avec le bouton droit sur Paramètres, cliquez sur Nouveau | valeur DWORD, puis nommez la valeur MaxFieldLength.

  4. Cliquez avec le bouton droit sur Paramètres, cliquez sur Nouveau | valeur DWORD, puis nommez la valeur MaxRequestBytes.

  5. Dans le volet droit, double-cliquez sur MaxFieldLength et définissez sa valeur sur 32768 (décimal).

  6. Dans le volet droit, double-cliquez sur MaxRequestBytes et définissez sa valeur sur 32768 (décimal).

  7. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres de Registre HTTP pour IIS (Internet Information Service), consultez l'article 820129 de la Base de connaissances sur les paramètres de Registre Http.sys pour IIS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129).


Le paramètre MaxRequestBytes des services IIS 6.0 n'est pas défini correctement
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la taille maximale pour les requêtes HTTP a été codée de manière irréversible dans le Registre :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

Exchange Server Analyzer examine également l'entrée de Registre suivante pour déterminer la version du système d'exploitation Microsoft Windows® exécutée sur l'ordinateur de destination :

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Une valeur CurrentVersion de 4.0 indique que l'ordinateur exécute Microsoft Windows NT® Server 4.0. La valeur 5.0 indique que l'ordinateur exécute un système d'exploitation Microsoft Windows 2000 Server et la valeur 5.2, qu'il exécute un système d'exploitation Microsoft Windows Server™ 2003.

Enfin, Exchange Server Analyzer examine la classe WMI (Windows Management Instrumentation) Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique que l'ordinateur Exchange Server est un serveur frontal.

Exchange Server Analyzer affiche un avertissement s'il détecte que la valeur de MaxRequestBytes est définie sur 32768 sur un serveur Exchange principal sur lequel les conditions suivantes sont vraies :

  • Le serveur Exchange principal est exécuté sur Windows Server 2003.

  • Le serveur Exchange principal n'est pas configuré en tant que serveur frontal.

  • Le serveur Exchange principal présente plus de 500 boîtes aux lettres.

La valeur de Registre MaxRequestBytes, qui n'est pas présente par défaut, détermine la limite supérieure de la taille totale de la ligne Request et des en-têtes. Cette valeur est généralement définie en même temps que la valeur MaxFieldLength. Le paramètre de Registre des services IIS MaxFieldLength spécifie la taille maximale de toute demande client HTTP individuelle. Dans des environnements plus grands, si ces valeurs ne sont pas définies sur 32768, les utilisateurs de Microsoft Office Outlook® Web Access pour Exchange Server peuvent rencontrer des échecs d'ouverture de session. En particulier, l'absence de ces valeurs peut provoquer des erreurs HTTP 400 - Demande incorrecte. Lors de la configuration de la valeur de Registre MaxFieldLength, vous devez également définir le paramètre MaxRequestBytes sur 32768 pour permettre aux utilisateurs membres de plus de 75 groupes d'ouvrir une session Outlook Web Access. Si sa valeur est inférieure à MaxFieldLength, la valeur MaxFieldLength est ajustée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Définition des paramètres MaxRequestBytes et MaxFieldLength

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Cliquez avec le bouton droit sur Paramètres, sélectionnez Nouveau | valeur DWORD, puis nommez la valeur MaxFieldLength.

  4. Cliquez avec le bouton droit sur Paramètres, sélectionnez Nouveau | valeur DWORD, puis nommez la valeur MaxRequestBytes.

  5. Dans le volet droit, double-cliquez sur MaxFieldLength et définissez sa valeur sur 32768 (décimal).

  6. Dans le volet droit, double-cliquez sur MaxRequestBytes et définissez sa valeur sur 32768 (décimal).

  7. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres de Registre HTTP pour les services IIS (Internet Information Services), consultez l'article 820129 de la Base de connaissances sur les paramètres de Registre Http.sys pour IIS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129).


L'indicateur IMAP4 Compatibility a été défini dans le Registre
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

Si Exchange Server Analyzer détecte que la valeur Compatibility est présente et configurée sur 0xfffffffe (en hexadécimal), un message indiquant une configuration autre que celle par défaut s'affiche.

Les ordinateurs clients IP Exchange Server se servant des protocoles IMAP4 et POP3 (Post Office Protocol 3) utilisent le fichier de banque d'informations en continu (.stm) pour la lecture et l'écriture de données. Lorsqu'un client IP demande le téléchargement de messages à l'aide du protocole POP3 ou IMAP4, la banque d'informations d'Exchange contenant la boîte aux lettres de l'utilisateur calcule la taille exacte des messages dans la boîte de réception à envoyer au client avant de transmettre les messages. Dans les grands environnements, en particulier les environnements hébergeant Exchange, ce calcul peut prendre beaucoup de temps. La valeur Compatibility représente une opportunité de configuration pour les administrateurs qui demandent à la banque Exchange d'utiliser une taille de message approximative plutôt que de calculer leur taille exacte.

La valeur de Registre Compatibility est disponible pour le service Exchange IMAP4, tel que décrit dans cet article, et pour le service Exchange POP3, tel que décrit dans l'article L'indicateur POP3 Compatibility a été défini dans le Registre.

La valeur de Registre Compatibility peut également être utilisée lors du déplacement de nombreuses boîtes aux lettres ou de boîtes aux lettres contenant plusieurs messages MIME. Lors d'un déplacement de données, celles-ci sont promues de la banque d'informations en continu à l'emplacement de stockage MAPI (fichier .edb). Les clients utilisant les protocoles POP3 et IMAP4 pour accéder à leurs boîtes aux lettres peuvent rencontrer des problèmes de performances après un déplacement de celles-ci entre des bases de données ou des serveurs. Après la connexion de l'utilisateur, la taille des messages doit être calculée et la conversion MAPI-MIME s'effectue dans la mémoire et sur le disque du serveur. Dans des cas extrêmes, de très gros fichiers temporaires peuvent être créés sur l'ordinateur Exchange Server lorsque ce comportement se produit.

Tous les clients de messagerie POP3 et IMAP4 ne fonctionnent pas correctement une fois la valeur de Registre Compatibility définie. La modification de ce paramètre provoque une panne chez certains clients de messagerie plus anciens tels que Fetchmail. La définition de cette clé de Registre rompt également la conformité RFC pour le protocole IMAP4. Si vous rencontrez des problèmes lors du téléchargement des messages à l'aide des protocoles POP3 et IMAP4 et si vous utilisez la valeur de Registre Compatibility, vous pouvez la supprimer en suivant la procédure de dépannage ci-dessous.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer la valeur de Registre Compatibility

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Supprimez la valeur nommée Compatibility.

  4. Quittez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange et le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre Compatibility, voir les articles suivants de la Base de connaissances :

  • 317722 sur les latences client qui se produisent lors de la conversion de courrier du format MAPI au format MIME par Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067 sur la fonctionnalité de déplacement de boîte aux lettres qui utilise le contenu de fichiers .stm (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


La valeur IMAP4 MaxBufferSize a été modifiée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-08-07

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Si Exchange Server Analyzer détecte que la valeur MaxBufferSize est présente et configurée avec une valeur numérique supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre MaxBufferSize est utilisée dans une topologie Exchange frontale/principale. Elle définit la taille du tampon TCP/IP entre les serveurs frontaux et principaux. La taille de tampon par défaut est 1 kilo-octet (Ko). Sur des réseaux ayant une latence élevée, le réglage de la valeur MaxBufferSize peut améliorer les performances des clients IMAP4.

Lors de la définition de la taille du tampon TCP/IP avec la valeur de Registre MaxBufferSize, vous devez toujours définir la taille de tampon avec une valeur multiple de 1024. Il est recommandé de tester les performances de configuration de votre serveur frontal/principal avec les tailles de tampon suivantes pour déterminer la valeur optimale pour votre organisation :

  • 8 192 octets

  • 16 384 octets

  • 32 768 octets

Il est recommandé de ne pas définir l'entrée de Registre MaxBufferSize sur une valeur supérieure à 32 768. Toutefois, vous remarquerez peut-être une amélioration des performances avec une valeur de 65 536 pour la taille de tampon selon les conditions de votre réseau. Une taille de tampon plus importante utilise plus de mémoire sur l'ordinateur Exchange Server et risque de réduire le nombre d'utilisateurs pouvant accéder au serveur frontal. Alors qu'il n'existe aucune limite à la valeur maximale utilisable pour la valeur de Registre MaxBufferSize, vous pouvez vous heurter à des performances instables et des problèmes de mémoire si vous affectez une valeur trop grande à cette entrée de Registre.

Remarque :
Pour utiliser la valeur de Registre MaxBufferSize, vous devez exécuter Exchange 2000 Server Service Pack 2 ou ultérieur.

Si la valeur de Registre MaxBufferSize est trop faible, les performances ne s'amélioreront pas et Exchange Server Analyzer affichera un message d'erreur, comme décrit dans la rubrique La valeur IMAP4 MaxBufferSize est trop faible Si la valeur de Registre MaxBufferSize est trop élevée, le système peut devenir instable et Exchange Server Analyzer affichera un message d'erreur, comme décrit dans la rubrique La valeur IMAP4 MaxBufferSize est trop élevée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la valeur MaxBufferSize

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Créez une nouvelle valeur DWORD appelée MaxBufferSize.

  4. Double-cliquez sur la valeur MaxBufferSize et définissez-la sur la nouvelle taille du tampon (en octets). Vous pouvez par exemple entrer 8192 pour la définir sur 8 192 octets.

  5. Fermez l'Éditeur du Registre et redémarrez le service Microsoft Exchange IMAP4 pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre MaxBufferSize, voir l'article 823857 de la Base de connaissances sur la lenteur des performances d'IMAP4 et POP3 entre les serveurs frontaux et principaux (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


La valeur IMAP4 MaxBufferSize est trop élevée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-08-07

L'outil Microsoft® Exchange Server Analyzer Tool lit le Registre sur l'ordinateur Exchange Server pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Si Exchange Server Analyzer détecte que la valeur MaxBufferSize est présente et configurée avec n'importe quelle valeur numérique supérieure à 32768, un avertissement s'affiche.

La valeur de Registre MaxBufferSize est utilisée dans une topologie Exchange frontale/principale. Elle définit la taille du tampon TCP/IP entre les serveurs frontaux et principaux. La taille de tampon par défaut est 1 kilo-octet (Ko). Sur des réseaux ayant une latence élevée, le réglage de la valeur MaxBufferSize peut améliorer les performances des clients IMAP4.

Lorsque vous définissez la taille de tampon TCP/IP avec la valeur de Registre MaxBufferSize, vous devez toujours définir la taille de tampon par multiples de 1 024. Il est recommandé de tester vos performances de configuration de serveurs frontaux/principaux avec les tailles de tampon suivantes :

  • 8 192 octets

  • 16 384 octets

  • 32 768 octets

Lorsque vous utilisez cette entrée de Registre, elle doit être définie sur 1 024 au moins. Il est recommandé de ne pas définir l'entrée de Registre MaxBufferSize sur une valeur supérieure à 32 768. Vous pouvez toutefois remarquer l'accroissement des performances avec une valeur de taille de tampon de 65 536, en fonction de vos conditions réseau. Une taille de tampon plus importante utilise plus de mémoire sur l'ordinateur Exchange Server et risque de réduire le nombre d'utilisateurs pouvant accéder au serveur frontal. Alors qu'il n'existe aucune limite à la valeur maximale utilisable pour la valeur de Registre MaxBufferSize, vous pouvez vous heurter à des performances instables et des problèmes de mémoire si vous affectez une valeur trop grande à cette entrée de Registre.

Remarque :
Pour utiliser la valeur de Registre MaxBufferSize, vous devez exécuter Exchange 2000 Server Service Pack 2 ou ultérieur.

Si la valeur de Registre MaxBufferSize est trop faible, les performances ne s'amélioreront pas et Exchange Server Analyzer affichera un message d'erreur, comme décrit dans la rubrique La valeur IMAP4 MaxBufferSize est trop faible. Si la valeur de Registre MaxBufferSize est trop élevée, le système peut devenir instable et Exchange Server Analyzer affichera un message tel que celui décrit dans cet article.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Créez une nouvelle valeur DWORD appelée MaxBufferSize.

  4. Double-cliquez sur la valeur MaxBufferSize et définissez-la sur la nouvelle taille du tampon (en octets). Vous pouvez par exemple entrer 8192 pour la définir sur 8 192 octets.

  5. Fermez l'Éditeur du Registre et redémarrez le service Microsoft Exchange IMAP4 pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre MaxBufferSize, voir l'article 823857 de la Base de connaissances sur la lenteur des performances d'IMAP4 et POP3 entre les serveurs frontaux et principaux (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


La valeur IMAP4 MaxBufferSize est trop faible
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-08-07

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Si Exchange Server Analyzer détecte que la valeur MaxBufferSize est présente et configurée avec une valeur numérique supérieure à 0 et inférieure à 1024, une erreur s'affiche.

La valeur de Registre MaxBufferSize est utilisée dans une topologie Exchange frontale/principale. Elle définit la taille du tampon TCP/IP entre les serveurs frontaux et principaux. La taille de tampon par défaut est 1 kilo-octet (Ko). Sur des réseaux ayant une latence élevée, le réglage de la valeur MaxBufferSize peut améliorer les performances des clients IMAP4.

Lors de la définition de la taille du tampon TCP/IP avec la valeur de Registre MaxBufferSize, vous devez toujours définir la taille de tampon avec une valeur multiple de 1024. Il est recommandé de tester les performances de configuration de votre serveur frontal/principal avec les tailles de tampon suivantes pour déterminer la valeur optimale pour votre organisation :

  • 8 192 octets

  • 16 384 octets

  • 32 768 octets

Lorsque vous utilisez cette entrée de Registre, elle doit être définie sur 1 024 au moins. Il est recommandé de ne pas définir l'entrée de Registre MaxBufferSize sur une valeur supérieure à 32 768. Vous pouvez toutefois remarquer l'accroissement des performances avec une valeur de taille de tampon de 65 536, en fonction de vos conditions réseau. Une taille de tampon plus importante utilise plus de mémoire sur l'ordinateur Exchange Server et risque de réduire le nombre d'utilisateurs pouvant accéder au serveur frontal. Alors qu'il n'existe aucune limite à la valeur maximale utilisable pour la valeur de Registre MaxBufferSize, vous pouvez vous heurter à des performances instables et des problèmes de mémoire si vous affectez une valeur trop grande à cette entrée de Registre.

Remarque :
Pour utiliser la valeur de Registre MaxBufferSize, vous devez exécuter Exchange 2000 Server Service Pack 2 ou ultérieur.

Si la valeur de Registre MaxBufferSize est trop faible, les performances ne s'amélioreront pas et Exchange Server Analyzer affichera un message d'erreur tel que celui décrit dans cet article. Si la valeur de Registre MaxBufferSize est trop élevée, le système peut devenir instable et Exchange Server Analyzer affichera un message, comme décrit dans la rubrique dans La valeur IMAP4 MaxBufferSize est trop élevée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Créez une nouvelle valeur DWORD appelée MaxBufferSize.

  4. Double-cliquez sur la valeur MaxBufferSize et définissez-la sur la nouvelle taille du tampon (en octets). Vous pouvez par exemple entrer 8192 pour la définir sur 8 192 octets.

  5. Fermez l'Éditeur du Registre et redémarrez le service Microsoft Exchange IMAP4 pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre MaxBufferSize, voir l'article 823857 de la Base de connaissances sur la lenteur des performances d'IMAP4 et POP3 entre les serveurs frontaux et principaux (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Échecs d'opérations MAPI
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que le serveur contient de nombreux échecs MAPI signalés. Certaines opérations MAPI sont censées renvoyer des erreurs occasionnellement. Toutefois, une application cliente risque parfois de ne pas répondre correctement à l'erreur. Par conséquent, l'application risque d'émettre à nouveau la demande RPC qui a provoqué l'erreur, augmentant ainsi la charge sur le serveur.

Par exemple, une erreur cliente se produit fréquemment lorsqu'un client MAPI demande une liste d'éléments dans des lots et continue à demander les articles une fois la demande renvoyée par Exchange. Par exemple, un ordinateur client peut demander tous les articles dans un dossier donné qui contient une pièce jointe. Le client risque de redemander que les éléments soient renvoyés par lots de 30 éléments chacun. Dans certains cas, une fois que le serveur Exchange a renvoyé le dernier élément de la demande, le client continue à demander un nouveau lot de 30 éléments. Dans ces cas, Exchange renvoie une erreur « Introuvable ». Si l'ordinateur client continue à demander des éléments, même après le renvoi de l'erreur « Introuvable », il ne répond plus à l'erreur correctement. Dans ce scénario, ExMon, l'outil de surveillance des utilisateurs d'Exchange Server, signalerait plusieurs échecs MAPI. Dans ce cas, bien que le taux d'échec par rapport au nombre d'opérations soit élevé, un taux d'échec élevé est attendu. Les opérations MAPI avec des taux d'échec élevés attendus incluent notamment GetPerUserGuid, ImportMsgMove et Logon.

Pour corriger cette erreur

  1. Utilisez ExMon pour déterminer les utilisateurs ou groupes d'utilisateurs qui provoquent le nombre élevé d'échecs MAPI.

  2. Identifiez l'application de l'ordinateur client qui cause ce problème.

  3. Corrigez ou supprimez l'application qui cause le problème.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


La clé MaxClientRequestBuffer est définie sur une valeur autre que celle par défaut
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la clé est présente :

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

Si Exchange Server Analyzer détecte que la clé MaxClientRequestBuffer a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Par défaut, cette valeur de Registre n'existe pas.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur la clé de Registre MaxClientRequestBuffer, voir l'article 260694 de la Base de connaissances Microsoft sur la description de la valeur de Registre MaxClientRequestBuffer (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694).


MaxClientRequestBuffer est défini sur une valeur trop faible
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer la valeur de MaxClientRequestBuffer :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

Si Exchange Server Analyzer détecte que les données de la valeur MaxClientRequestBuffer sont inférieures à 16 384, il affiche un avertissement.

Une valeur de MaxClientRequestBuffer trop faible peut entraîner des erreurs pour les utilisateurs de Microsoft Office Outlook® Web Access. Par exemple, HTTP 400 - Bad Request peut être renvoyé au navigateur. Pour corriger cet avertissement, il est recommandé d'augmenter la valeur à un nombre supérieur à 16 384 ou de supprimer la valeur de Registre pour rétablir les paramètres par défaut. La valeur MaxClientRequestBuffers n'est pas présente par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour corriger cet avertissement en augmentant les données de la valeur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Double-cliquez sur la valeur MaxClientRequestBuffer et modifiez-en les données. Définissez les données de la valeur sur un nombre décimal supérieur ou égal à 16 384.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange.
Pour corriger cet avertissement en supprimant la valeur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Cliquez avec le bouton droit sur la valeur MaxClientRequestBuffer, puis cliquez sur Supprimer.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre MaxClientRequestBuffer, voir l'article 260694 de la Base de connaissances Microsoft sur la description de la valeur de Registre MaxClientRequestBuffer (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260694).


Plusieurs liaisons de port SMTP configurées
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchServerBindings présente plusieurs liaisons de port. Par défaut, l'attribut msExchServerBindings est configuré pour le port TCP 25. Si Exchange Server Analyzer détecte que l'attribut msExchServerBindings a été configuré avec plusieurs liaisons de port, un message indiquant une configuration autre que celle par défaut s'affiche.

L'attribut msExchServerBindings représente le port TCP sur lequel ce serveur SMTP (Simple Mail Transfer Protocol) écoute les connexions entrantes. Les serveurs virtuels SMTP peuvent être configurés pour écouter sur un ou plusieurs ports TCP. Par défaut, tous les serveurs virtuels SMTP sont configurés pour écouter sur le port TCP 25. Vous pouvez modifier le port d'écoute SMTP tant que vous modifiez en conséquence l'ensemble de l'infrastructure de messagerie interne. Toutefois, il est généralement recommandé d'utiliser le port 25 pour des serveurs virtuels SMTP qui acceptent des messages directement depuis Internet, car les serveurs SMTP sur Internet envoient les messages par le biais du port 25.

Notez qu'Exchange Server Analyzer examine la valeur pour le serveur virtuel de protocole SMTP Exchange. Ce serveur n'est pas forcément le serveur SMTP qui reçoit les messages directement depuis Internet. Certains produits antivirus et antispam sont conçus pour recevoir des messages SMTP depuis Internet sur le port 25 et les rediriger vers un serveur virtuel SMTP Exchange sur un autre port.

Pour afficher ou modifier le port d'écoute du serveur virtuel SMTP

  1. Dans le Gestionnaire système Exchange, développez Serveurs, développez un serveur Exchange, développez Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut), puis cliquez sur Propriétés.

  3. Sélectionnez l'onglet Général, puis cliquez sur Avancé.

  4. Une liste de ports et d'adresses IP s'affiche.

    • Pour modifier le port existant, sélectionnez l'adresse IP, puis cliquez sur Modifier.

    • Pour supprimer un port existant, sélectionnez l'adresse IP, puis cliquez sur Supprimer.

  5. Cliquez sur OK pour enregistrer vos modifications, puis de nouveau sur OK pour quitter la boîte de dialogue Avancé.

  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La taille de la réponse PING est différente
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PingStatus à l'aide de valeurs de paramètres BufferSize spécifiques, qu'il compare aux valeurs BufferSize renvoyées afin de déterminer si elles sont identiques.

Si la valeur BufferSize renvoyée diffère de celle qui a été envoyée, Exchange Server Analyzer affiche un avertissement.

Cet avertissement indique que le paquet a été tronqué quelque part lors de son transit. Cette situation peut signaler une défaillance réseau générale ou la présence d'un routeur trou noir dans l'environnement.

Dans un réseau étendu (WAN) basé sur TCP/IP, les communications sur certaines routes peuvent échouer si la taille de paquet d'un segment de réseau intermédiaire est inférieure celle des hôtes de la communication, et si les routeurs n'envoient pas de réponses ICMP appropriées à cette situation. Le pare-feu sur le chemin d'accès peut également retourner ce type de réponse. Un routeur qui provoque cette condition est parfois appelé routeur trou noir.

La présence d'un routeur trou noir peut provoquer de nombreuses erreurs qui ne se produisent pas si un programme se connecte à un ordinateur sur un sous-réseau local. Le comportement peut sembler intermittent mais, si vous examinez ses circonstances de plus près, il se peut que vous constatiez que ce comportement peut se reproduire, par exemple, si un client lit un fichier volumineux envoyé à partir d'un hôte distant.

Pour plus d'informations, voir les instructions de l'article 314825 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes rencontrés avec des routeurs trou noir (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).

Pour plus d'informations

Pour plus d'informations sur la détection et le traitement d'éventuels routeurs trou noir, voir les ressources suivantes :

  • Article 159211 de la Base de connaissances Microsoft sur la détection des routeurs trou noir et solutions s'y rapportant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

  • « Path Maximum Transmission Unit (PMTU) Black Hole Routers » (http://go.microsoft.com/fwlink/?LinkId=66963) (en anglais).


Échec du test ping
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-08-09

Microsoft® Exchange Server Analyzer Tool tente d'interroger la classe Win32_PingStatus WMI (Windows® Management Instrumentation) Microsoft pour analyser l'objet de réponse pour différents paramètres de configuration spécifiques au flux de messages.

Win32_PingStatus renvoie par défaut un objet avec 24 propriétés qui fournit davantage de détails sur les paquets ping envoyés par la classe.

Si Exchange Server Analyzer ne reçoit pas l'objet prévu en réponse à sa requête après six tentatives consécutives, il affiche un avertissement.

Cet avertissement indique que Win32_PingStatus n'a pas pu avoir lieu.

La cause la plus probable de cet échec est que l'ordinateur qui essaie d'exécuter la commande Win32_PingStatus utilise le système d'exploitation Microsoft Windows® 2000 Server. Windows® 2000 Server ne prend pas en charge la classe WMI Win32_PingStatus.

Si l'ordinateur qui tente d'exécuter la commande Win32_PingStatus n'utilise pas le système d'exploitation Windows 2000 Server, il peut s'agir de problèmes généraux de réseau ou d'autorisations.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Utilisez la commande PING sur l'ordinateur qui exécute Exchange Server Analyzer pour vérifier si l'ordinateur Exchange Server cible est accessible.

  3. Utilisez la commande PING sur un serveur situé sur le même sous-réseau que le serveur Exchange cible pour vérifier si l'ordinateur Exchange Server cible est accessible.

  4. En cas de pare-feu, vérifiez si les ports d'appel de procédure distante (RPC) sont bloqués.

  5. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque serveur Exchange qu'il analyse.

Pour plus d'informations sur les problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur les problèmes de connectivité d'Exchange Server Best Practices Analyzer, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur la classe WMI Win32_PingStatus, voir l'article de MSDN® sur Win32_PingStatus (http://go.microsoft.com/fwlink/?linkid=33549).


L'analyse antivirus de texte brut a été désactivée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur pour l'analyse antivirus de messages au format RTF (Rich Text Format) :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Si Exchange Server Analyzer détecte que la valeur de ScanPlainText est définie sur 0, un avertissement s'affiche.

La clé de Registre ScanPlainText est définie par les fournisseurs d'antivirus tiers qui utilisent l'interface VSAPI (Exchange Virus Scanning API). Il est recommandé d'analyser tous les types de messages à la recherche de virus, notamment les messages en texte brut. Vous devez activer l'analyse antivirus de tous les messages circulant via un ordinateur Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  • Dans votre application antivirus compatible avec Exchange, activez l'analyse de tous les messages

    -ou-

  • modifiez manuellement l'entrée dans le Registre en respectant la procédure suivante :

    1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    2. Naviguez jusqu'à :

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. Double-cliquez sur la valeur de Registre ScanPlainText et définissez-la sur 1.

    4. Quittez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange, ainsi que les services représentant votre logiciel antivirus compatible avec Exchange, pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la lutte contre les virus, voir le site Web sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).


L'indicateur POP3 Compatibility a été défini dans le Registre
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

Si Exchange Server Analyzer détecte que la valeur Compatibility est présente et configurée sur 0xfffffffe (en hexadécimal), un message indiquant une configuration autre que celle par défaut s'affiche.

Les ordinateurs clients IP Exchange Server se servant des protocoles IMAP4 et POP3 (Post Office Protocol 3) utilisent le fichier de banque d'informations en continu (.stm) pour la lecture et l'écriture de données. Lorsqu'un client IP demande le téléchargement de messages à l'aide du protocole POP3 ou IMAP4, la banque Exchange contenant la boîte aux lettres de l'utilisateur calcule la taille exacte des messages dans la boîte de réception à envoyer au client avant de transmettre les messages. Dans les grands environnements, en particulier les environnements hébergeant Exchange, ce calcul peut prendre un certain temps. La valeur Compatibility représente une opportunité de configuration pour les administrateurs qui demandent à la banque Exchange d'utiliser une taille de message approximative plutôt que de calculer leur taille exacte.

La valeur de Registre Compatibility est disponible pour le service Exchange POP3, tel que décrit dans cet article, et pour le service Exchange IMAP4, tel que décrit dans l'article L'indicateur IMAP4 Compatibility a été défini dans le Registre.

La valeur de Registre Compatibility est également utile lors du déplacement d'un grand nombre de boîtes aux lettres ou de boîtes aux lettres contenant de nombreux messages MIME (Multipurpose Internet Mail Extensions). Lors d'un déplacement de données, celles-ci sont promues de la banque d'informations en continu à l'emplacement de stockage MAPI (fichier .edb). Les clients utilisant les protocoles POP3 et IMAP4 pour accéder à leurs boîtes aux lettres peuvent rencontrer des problèmes de performances après un déplacement de celles-ci entre des bases de données ou des serveurs. Après la connexion de l'utilisateur, la taille des messages doit être calculée et la conversion MAPI-MIME s'effectue dans la mémoire et sur le disque du serveur. Dans des cas extrêmes, de très gros fichiers temporaires peuvent être créés sur l'ordinateur Exchange Server lorsque ce comportement se produit.

Tous les clients de messagerie POP3 et IMAP4 ne fonctionnent pas correctement une fois la valeur de Registre Compatibility définie. La modification de ce paramètre provoque une panne chez certains clients de messagerie plus anciens (tels que Fetchmail). La définition de cette clé de Registre rompt également la conformité RFC pour le protocole POP3. Si vous rencontrez des problèmes lors du téléchargement des messages à l'aide des protocoles POP3 et IMAP4 et que vous utilisez la valeur de Registre Compatibility, vous pouvez la supprimer en suivant la procédure de dépannage ci-dessous.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer la valeur de Registre Compatibility

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Supprimez la valeur nommée Compatibility.

  4. Quittez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange et le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre Compatibility, voir les articles suivants de la Base de connaissances :

  • 317722 sur les latences client qui se produisent lors de la conversion de courrier du format MAPI au format MIME par Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722)

  • 329067 sur la fonctionnalité de déplacement de boîte aux lettres qui utilise le contenu de fichiers .stm (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067)


La valeur POP3 MaxBufferSize a été modifiée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Si Exchange Server Analyzer détecte que la valeur MaxBufferSize est présente et configurée avec une valeur numérique supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre MaxBufferSize est utilisée dans une topologie Exchange frontale/principale. Elle définit la taille du tampon TCP/IP entre les serveurs frontaux et principaux. La taille de tampon par défaut est 1 kilo-octet (Ko). Sur des réseaux ayant une latence élevée, le réglage de la valeur MaxBufferSize peut améliorer les performances pour les clients POP3.

Lorsque vous définissez la taille de tampon TCP/IP avec la valeur de Registre MaxBufferSize, vous devez toujours définir la taille de tampon par multiples de 1 024. Il est recommandé de tester vos performances de configuration de serveurs frontaux/principaux avec les tailles de tampon suivantes :

  • 8 192 octets

  • 16 384 octets

  • 32 768 octets

Lorsque vous utilisez cette entrée de Registre, elle doit être définie sur 1 024 au moins. Il est recommandé de ne pas définir l'entrée de Registre MaxBufferSize sur une valeur supérieure à 32 768. Vous pouvez toutefois remarquer l'accroissement des performances avec une valeur de taille de tampon de 65 536, en fonction de vos conditions réseau. Une taille de tampon plus importante utilise plus de mémoire sur l'ordinateur Exchange Server et risque de réduire le nombre d'utilisateurs pouvant accéder au serveur frontal. Alors qu'il n'existe aucune limite à la valeur maximale utilisable pour la valeur de Registre MaxBufferSize, vous pouvez vous heurter à des performances instables et des problèmes de mémoire si vous affectez une valeur trop grande à cette entrée de Registre.

Remarque :
Pour utiliser la valeur de Registre MaxBufferSize, vous devez exécuter Exchange 2000 Server Service Pack 2 ou une version ultérieure.

Si la valeur de Registre MaxBufferSize est trop faible, les performances ne s'amélioreront pas et Exchange Server Analyzer affichera un message d'erreur tel que celui décrit dans l'article Valeur POP3 MaxBufferSize trop faible. Si la valeur de Registre MaxBufferSize est trop élevée, le système peut devenir instable et Exchange Server Analyzer affiche un message d'erreur tel que celui décrit dans l'article La valeur POP3 MaxBufferSize est trop élevée

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Créez une nouvelle valeur DWORD appelée MaxBufferSize.

  4. Double-cliquez sur la valeur MaxBufferSize et définissez-la sur la nouvelle taille du tampon (en octets). Vous pouvez par exemple entrer 8192 pour la définir sur 8 192 octets.

  5. Quittez l'Éditeur du Registre et redémarrez le service Microsoft Exchange POP3 pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre MaxBufferSize, voir l'article 823857 de la Base de connaissances sur la lenteur des performances d'IMAP4 et POP3 entre les serveurs frontaux et principaux (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


La valeur POP3 MaxBufferSize est trop élevée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Si Exchange Server Analyzer détecte que la valeur MaxBufferSize est présente et configurée avec n'importe quelle valeur numérique supérieure à 32 768, un avertissement s'affiche.

La valeur de Registre MaxBufferSize est utilisée dans une topologie Exchange frontale/principale. Elle définit la taille du tampon TCP/IP entre les serveurs frontaux et principaux. La taille de tampon par défaut est 1 kilo-octet (Ko). Sur des réseaux ayant une latence élevée, le réglage de la valeur MaxBufferSize peut améliorer les performances pour les clients POP3.

Lorsque vous définissez la taille de tampon TCP/IP avec la valeur de Registre MaxBufferSize, vous devez toujours définir la taille de tampon par multiples de 1 024. Il est recommandé de tester vos performances de configuration de serveurs frontaux/principaux avec les tailles de tampon suivantes :

  • 8 192 octets

  • 16 384 octets

  • 32 768 octets

Lorsque vous utilisez cette entrée de Registre, elle doit être définie sur 1 024 au moins. Il est recommandé de ne pas définir l'entrée de Registre MaxBufferSize sur une valeur supérieure à 32 768. Vous pouvez toutefois remarquer l'accroissement des performances avec une valeur de taille de tampon de 65 535, en fonction de vos conditions réseau. Une taille de tampon plus importante utilise plus de mémoire sur l'ordinateur Exchange Server et risque de réduire le nombre d'utilisateurs pouvant accéder au serveur frontal. Alors qu'il n'existe aucune limite à la valeur maximale utilisable pour la valeur de Registre MaxBufferSize, vous pouvez vous heurter à des performances instables et des problèmes de mémoire si vous affectez une valeur trop grande à cette entrée de Registre.

Remarque :
Pour utiliser la valeur de Registre MaxBufferSize, vous devez exécuter Exchange 2000 Server Service Pack 2 ou ultérieur.

Si la valeur de Registre MaxBufferSize est trop faible, les performances ne s'amélioreront pas et Exchange Server Analyzer affichera un message d'erreur tel que celui décrit dans l'article Valeur POP3 MaxBufferSize trop faible. Si la valeur de Registre MaxBufferSize est trop élevée, le système peut devenir instable et Exchange Server Analyzer affichera un message tel que celui décrit dans cet article.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Créez une nouvelle valeur DWORD appelée MaxBufferSize.

  4. Double-cliquez sur la valeur MaxBufferSize et définissez-la sur la nouvelle taille du tampon (en octets). Vous pouvez par exemple entrer 8192 pour la définir sur 8 192 octets.

  5. Quittez l'Éditeur du Registre et redémarrez le service Microsoft Exchange POP3 pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre MaxBufferSize, voir l'article 823857 de la Base de connaissances sur la lenteur des performances d'IMAP4 et POP3 entre les serveurs frontaux et principaux (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Valeur POP3 MaxBufferSize trop faible
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre suivante existe :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Si Exchange Server Analyzer détecte que la valeur MaxBufferSize est présente et configurée avec une valeur numérique supérieure à 0 et inférieure à 1024, une erreur s'affiche.

La valeur de Registre MaxBufferSize est utilisée dans une topologie Exchange frontale/principale. Elle définit la taille du tampon TCP/IP entre les serveurs frontaux et principaux. La taille de tampon par défaut est 1 kilo-octet (Ko). Sur des réseaux ayant une latence élevée, le réglage de la valeur MaxBufferSize peut améliorer les performances pour les clients POP3.

Lors de la définition de la taille du tampon TCP/IP avec la valeur de Registre MaxBufferSize, vous devez toujours définir la taille de tampon avec une valeur multiple de 1024. Il est recommandé de tester les performances de configuration de votre serveur frontal/principal avec les tailles de tampon suivantes pour déterminer la valeur optimale pour votre organisation :

  • 8 192 octets

  • 16 384 octets

  • 32 768 octets

Lorsque vous utilisez cette entrée de Registre, elle doit être définie sur 1 024 au moins. Il est recommandé de ne pas définir l'entrée de Registre MaxBufferSize sur une valeur supérieure à 32 768. Vous pouvez toutefois remarquer l'accroissement des performances avec une valeur de taille de tampon de 65 535, en fonction de vos conditions réseau. Une taille de tampon plus importante utilise plus de mémoire sur l'ordinateur Exchange Server et risque de réduire le nombre d'utilisateurs pouvant accéder au serveur frontal. Alors qu'il n'existe aucune limite à la valeur maximale utilisable pour la valeur de Registre MaxBufferSize, vous pouvez vous heurter à des performances instables et des problèmes de mémoire si vous affectez une valeur trop grande à cette entrée de Registre.

Remarque :
Pour utiliser la valeur de Registre MaxBufferSize, vous devez exécuter Exchange 2000 Server Service Pack 2 ou ultérieur.

Si la valeur de Registre MaxBufferSize est trop faible, les performances ne s'amélioreront pas et Exchange Server Analyzer affichera un message d'erreur tel que celui décrit dans cet article. Si la valeur de Registre MaxBufferSize est trop élevée, le système peut devenir instable et Exchange Server Analyzer affichera un message tel que celui décrit dans La valeur POP3 MaxBufferSize est trop élevée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Créez une nouvelle valeur DWORD appelée MaxBufferSize.

  4. Double-cliquez sur la valeur MaxBufferSize et définissez-la sur la nouvelle taille du tampon (en octets). Vous pouvez par exemple entrer 8192 pour la définir sur 8 192 octets.

  5. Fermez l'Éditeur du Registre et redémarrez le service Microsoft Exchange POP3 pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre MaxBufferSize, voir l'article 823857 de la Base de connaissances sur la lenteur des performances d'IMAP4 et POP3 entre les serveurs frontaux et principaux (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857).


Le port n'a pas répondu
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge le serveur défini par l'utilisateur et tente d'ouvrir une connexion de socket avec le serveur indiqué sur le port TCP 25 (configuration par défaut) ou un port défini par l'utilisateur. Si Exchange Server Analyzer ne reçoit pas une réponse personnalisée attendue, à savoir xx Available où xx correspond au port par défaut (25) ou au numéro de port défini par l'utilisateur, il affiche une erreur.

Cette erreur indique que le serveur n'est pas accessible sur le port TCP désiré et que des défaillances peuvent se produire. Pour corriger cette erreur, vous pouvez tenter de résoudre le problème de connectivité avec le serveur.

Pour résoudre le problème de connectivité avec le serveur

  1. Pouvez-vous accéder, par Telnet, au port désiré du serveur indiqué ? Si ce n'est pas le cas, le problème ne se situe pas au niveau du réseau.

  2. Tous les éléments sont-ils connectés ? Votre matériel fonctionne-t-il correctement ?

  3. Le DNS fonctionne-t-il et est-il configuré correctement ?

  4. Votre routeur fonctionne-t-il correctement ?

  5. Des pare-feu vous empêchent-ils de vous connecter ?

Pour plus d'informations sur le dépannage des problèmes de connectivité des serveurs, voir la section sur la résolution des problèmes de connectivité par l'outil Microsoft Exchange Server Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).


Routeurs trou noir potentiels
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PingStatus en utilisant les différentes valeurs spécifiques des paramètres BufferSize et NoFragmentation pour déterminer si des routeurs trou noir risquent d'être présents dans l'environnement étendu (WAN).

Paramètre BufferSize | Paramètre NoFragmentation
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • PING avec valeur BufferSize inférieure et NoFragmentation = True réussit

  • PING avec valeur BufferSize supérieure et NoFragmentation = True est dépassé

  • PING avec valeur BufferSize supérieure et NoFragmentation = False réussit, mais la taille de la valeur BufferSize de la réponse diffère de la valeur BufferSize envoyée.

Cette erreur indique la présence possible d'au moins un routeur trou noir sur le réseau étendu (WAN).

Sur un réseau étendu TCP/IP, la communication sur certains itinéraires risque d'échouer si les conditions suivantes sont vraies :

  • Les tailles des paquets des segments des réseaux intermédiaires sont inférieures aux hôtes communicants.

  • Les routeurs n'envoient pas de réponse ICMP appropriée dans cette condition.

Le pare-feu sur le chemin d'accès peut également retourner ce type de réponse. Un routeur qui provoque cette condition est parfois appelé routeur trou noir.

La présence d'un routeur trou noir peut provoquer de nombreuses erreurs qui ne se produisent pas si un programme se connecte à un ordinateur sur un sous-réseau local. Le comportement peut sembler intermittent, mais vous constaterez qu'il peut se reproduire, par exemple, si un client lit un fichier volumineux envoyé à partir d'un hôte distant.

Pour plus d'informations, voir les instructions de l'article 314825 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes rencontrés avec des routeurs trou noir (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).

Pour plus d'informations

Pour plus d'informations sur la détection et le traitement d'éventuels routeurs trou noir, voir les ressources suivantes :

  • Article 159211 de la Base de connaissances Microsoft sur la détection des routeurs trou noir et solutions s'y rapportant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

  • « Path Maximum Transmission Unit (PMTU) Black Hole Routers » dans la colonne The Cable Guy - July 2004 (en anglais) (http://go.microsoft.com/fwlink/?LinkId=66963).


Échec de l'hôte distant PING
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PingStatus en utilisant les différents paramètres BufferSize et NoFragmentation pour déterminer la taille de l'unité de transmission maximale (MTU) pour le réseau et rechercher les éventuels routeurs trou noir. Exchange Server Analyzer détermine la taille en examinant la valeur de la clé StatusCode renvoyée par un hôte distant pour chaque combinaison de paramètres.

Paramètre BufferSize | Paramètre NoFragmentation
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Win32_PingStatus renvoie un objet avec 24 propriétés qui fournit davantage de détails sur les paquets ping envoyés par la classe.

Si Exchange Server Analyzer détecte que la valeur de cette clé correspond à l'une des valeurs du tableau suivant, il affiche une erreur.

Exchange Server Analyzer affiche le nom du serveur de l'hôte distant, le nom du serveur Exchange et la valeur StatusCode correspondante renvoyée avec cette erreur.

Valeur StatusCode Signification Description

11001

Tampon trop petit

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11002

Réseau de destination inaccessible

La requête a échoué car le réseau qui contient l'ordinateur de destination n'est pas accessible. Aucun itinéraire valide n'existe vers l'ordinateur de destination.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances Microsoft sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11003

Hôte de destination inaccessible

La requête a échoué car l'ordinateur de destination n'est pas accessible.

Pour plus d'informations, voir la rubrique sur le Le serveur Active Directory est arrêté ou inaccessible.

Cette erreur peut également être provoquée par l'une des conditions suivantes :

  • un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible ;

  • une erreur DNS.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11004

Protocole de destination inaccessible

La requête a échoué car l'ordinateur de destination ne répond pas au protocole du paquet.

Cette erreur peut également être provoquée par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11005

Port de destination inaccessible

La requête a échoué car le port de l'ordinateur de destination n'est pas disponible.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11006

Aucune ressource

La requête a échoué car les ressources réseau sont insuffisantes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11007

Option non valide

La requête a échoué car elle contient une option non valide.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11008

Erreur matérielle

La requête a échoué en raison d'une erreur matérielle.

Vérifiez que le contrôleur de domaine fonctionne correctement en exécutant l'outil de vérification matérielle fourni par le fabricant de votre ordinateur.

11009

Paquet trop volumineux

La requête a échoué car le paquet qui la contient est plus grand que l'unité de transmission maximale (MTU) d'un nœud (routeur ou passerelle) située entre la source et la destination. L'unité de transmission maximale définit la taille maximale du paquet transmissible.

La requête envoyée par Exchange Server Analyzer n'est pas supérieure à 10 Ko. Vérifiez que les routeurs et passerelles de votre organisation sont correctement configurés.

Pour plus d'informations, voir l'article 159211 de la Base de connaissances sur la détection des routeurs trou noir et les solutions s'y rapportant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211).

11010

Délai de la requête écoulé

Aucune réponse n'a été reçue dans le délai imparti. Le délai de réponse par défaut est de 5 secondes.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11011

Requête incorrecte

La requête a échoué car elle n'a pas été encodée correctement.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11012

Itinéraire incorrect

La requête a échoué car il n'existe pas d'itinéraire valide entre les ordinateurs source et de destination.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11013

Transit de la propriété TimeToLive expiré

La requête a échoué car la valeur de Time to Live (TTL) a atteint zéro. Le nœud de transfert (routeur ou passerelle) va donc ignorer le paquet.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11014

Réassemblage de la propriété TimeToLive expiré

La requête a échoué car le paquet a été divisé en fragments pour la transmission et tous les fragments n'ont pas été reçus dans le délai imparti pour le réassemblage. RFC 2460 (http://www.ietf.org/rfc/rfc2460.txt) définit sur 60 secondes le délai maximal pendant lequel tous les fragments du paquet doivent être reçus.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

11015

Problème de paramètre

La requête a échoué car un nœud (routeur ou passerelle) a rencontré des problèmes lors du traitement de l'en-tête du paquet. Cela peut se produire si l'en-tête contient des données de champ non valides ou une option non reconnue.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11016

Extinction de source

La requête a échoué car le paquet a été ignoré. Cela se produit lorsque la file d'attente de sortie de l'ordinateur source ne dispose pas d'un espace de stockage suffisant ou lorsque les paquets arrivent à destination trop rapidement pour être traités.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11017

Option trop volumineuse

La requête a échoué car elle contient une option non valide.

Cette erreur est peu probable car Exchange Server Analyzer génère une requête standard.

11018

Destination non valide

La requête a échoué pour l'une des raisons suivantes :

  • L'adresse IP de destination ne peut pas recevoir de requêtes PING.

  • L'adresse IP de destination ne s'affiche jamais dans le champ d'adresse de destination d'un datagramme IP.

Cela peut également être provoqué par un pare-feu entre le point d'utilisation d'Exchange Server Analyzer et le contrôleur de domaine cible.

11032

Négociation de IPSEC

La requête a échoué car une connexion IPsec n'a pas pu être négociée.

11050

Échec général

La requête a échoué pour une raison inconnue.

Pour plus d'informations, voir l'article 325487 de la Base de connaissances sur la résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur ces tests, voir l'article 314825 de la Base de connaissances Microsoft sur la procédure pour résoudre les problèmes rencontrés avec des routeurs trou noir (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825).


Moteur de routage arrêté
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si le service moteur de routage (RESvc) de Microsoft Exchange et le service SMTP (Simple Mail Transfer Protocol - SMTPSVC) sont exécutés. Exchange Server Analyzer affiche une erreur s'il détecte que l'une des conditions suivantes est vraie :

  • SMTPSVC est en cours d'exécution.

  • RESvc n'est pas en cours d'exécution.

Si RESvc n'est pas en cours d'exécution sur tous les serveurs Exchange qui relaient des messages, des problèmes de routage peuvent survenir. Une configuration Exchange Server qui relaie des messages sans que RESvc soit exécuté n'est pas prise en charge.

Comme Exchange 2000 Server, Exchange Server 2003 utilise un algorithme de routage d'état des liens, ainsi qu'un protocole de routage pour diffuser des informations d'état des liens sous la forme d'un tableau d'état des liens. Ce tableau est mémorisé sur tous les serveurs Exchange 2000 Server et Exchange Server 2003 de l'organisation.

Un algorithme d'état des liens offre les avantages suivants :

  • Chaque serveur Exchange peut sélectionner à la source l'itinéraire optimal des messages plutôt que d'envoyer ces derniers par un itinéraire sur lequel une liaison est indisponible.

  • Les messages ne sont plus renvoyés d'un serveur à l'autre. En effet, chaque serveur Exchange est constamment informé de la disponibilité d'itinéraires alternatifs ou redondants.

  • Les boucles de messages n'existent plus. Celles-ci posaient parfois problème dans les versions précédentes d'Exchange Server.

Exchange Server collecte les informations suivantes à partir du tableau d'état des liens :

  • Ce tableau documente la topologie de routage de l'ensemble de l'organisation Exchange.

  • Il renseigne la disponibilité de chaque connecteur de la topologie. Une topologie disponible est « En service ». Une topologie non disponible est « Hors service ».

  • Ce tableau indique également les espaces d'adressage et les coûts associés à chaque connecteur disponible.

Exchange Server utilise ces informations pour déterminer l'itinéraire dont le coût est le plus faible pour l'adresse de destination. Si un connecteur se trouvant le long de l'itinéraire dont le coût est le plus faible n'est pas disponible, Exchange Server détermine le meilleur itinéraire alternatif sur la base des coûts et de la disponibilité du connecteur. RESvc est requis pour le routage d'état des liens.

Pour corriger cette erreur, vous devez configurer RESvc pour qu'il démarre automatiquement. Vous devez également vous assurer que RESvc est exécuté pendant les heures de production.

Pour corriger cette erreur

  1. Cliquez sur Démarrer, pointez sur Programmes, Outils d'administration, puis cliquez sur Services.

  2. Dans la liste des services, cliquez avec le bouton droit sur Moteur de routage Microsoft Exchange, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, dans le menu Type de démarrage, sélectionnez Automatique, puis cliquez sur OK.

  4. Cliquez avec le bouton droit sur Moteur de routage Microsoft Exchange, puis cliquez sur Démarrer.

Pour plus d'informations sur le routage des messages dans Exchange Server 2003, voir le Guide de transport et de routage Exchange Server 2003 à l'adresse http://go.microsoft.com/fwlink/?LinkId=47579.


RPC Performance Counters Indicate Poor Server Performance
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-08-24

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre serveur n'offre pas ses performances optimales. Exchange Server Analyzer évalue de nombreux compteurs de performance d'appels de procédure distante (RPC). Si les données collectées dans les compteurs de performance RPC n'offrent pas de comparaison favorable aux niveaux dans la table ci-dessous, un avertissement s'affiche.

Nombre d'utilisateurs d'Exchange Server | Seuil de Latence moyenne RPC
Inférieur à 500 | Moyenne supérieure à 15
Supérieur ou égal à 500 mais inférieur à 3000 | Moyenne supérieure à 30
Supérieur à 3 000 | Moyenne supérieure à 50

Les compteurs de performance suivants sont décrits dans cet article et gérés par l'objet de performance MSExchangeIS :

  • Latence moyenne RPC

  • Demandes RPC

Latence moyenne RPC

Le compteur de performance Latence moyenne RPC enregistre la durée moyenne, en millisecondes (ms), nécessaire au traitement des 1 024 derniers paquets. La latence représente la durée nécessaire entre la réception du paquet par le processus Store.exe et le moment où il le renvoie. Le compteur de performance Latence moyenne RPC ne prend pas en compte la latence du réseau ou toute autre latence introduite par un autre élément que le processus Store.exe. Bien que les données du compteur de performance Latence moyenne RPC n'incluent pas la durée de transit du réseau, elles fournissent des données sur la plus courte période pendant laquelle les ordinateurs clients ont dû attendre une réponse de la part du serveur. Si les données du compteur de performance Latence moyenne RPC sont inférieures à 50 ms, le serveur peut traiter les demandes en une période raisonnable. Si le compteur reste supérieur à 50 ms pendant plusieurs secondes, cela signifie qu'il éprouve des difficultés à supporter la charge. Il se peut donc que les utilisateurs doivent patienter lors de l'accès à leurs messages électroniques. Si la latence moyenne est supérieure à 100 ms, les utilisateurs verront s'afficher la fenêtre indépendante suivante sur leur ordinateur client Microsoft Office Outlook® : « Retrieving data from Exchange Server » (Récupération des données à partir d'Exchange Server).

Interprétation du compteur de performance Latence moyenne RPC

Le compteur Latence moyenne RPC peut être trompeur dans le deux cas suivants :

  • Tout d'abord, certaines opérations MAPI sont supposées durer longtemps. Par exemple, si l'ordinateur client effectue une recherche dans un dossier qui contient des centaines d'éléments en tentant de localiser les éléments qui répondent à des critères complexes, il est normal qu'une telle opération nécessite plusieurs secondes. Si quelques utilisateurs emploient le serveur, le déroulement de cette opération peut provoquer un pic dans Latence RPC moyenne. Si la charge RPC sur le serveur est faible, observez la moyenne pour cette valeur sur une période plus longue (au moins plusieurs minutes) au lieu d'agir à court terme, comportement plus versatile.

  • Le deuxième cas survient lorsque la charge RPC sur le serveur est très faible. Parfois, selon les activités de l'utilisateur le plus actif, la latence peut varier considérablement. Étant donné que la charge du serveur est particulièrement forte, le résultat d'opérations lourdes par un seul utilisateur peut influencer involontairement les données de latence RPC moyenne.

Demandes RPC

Le compteur de performance Demandes RPC enregistre le nombre de demandes d'ordinateurs clients actuellement en cours de traitement par Exchange. Le compteur a une valeur maximale de 100. Une fois que la banque d'informations Exchange a lancé le traitement de 100 opérations RPC, elle refuse régulièrement de nouvelles connexions. Sur un serveur sain, le nombre de demandes en attente doit être inférieur à 50. Si le nombre est supérieur à 50 pendant une longue période, les RPC sont sauvegardés et attendent d'être traités. Les ordinateurs rencontrent dès lors probablement des retards.

Interprétation des demandes RPC

Le seuil de 50 demandes n'est pas un seuil strict. Un serveur légèrement chargé peut rencontrer ses premiers problèmes de performances avant que le compteur atteigne 30. Toutefois, un serveur fortement chargé peut fonctionner correctement avec 50 demandes. Idéalement, pour chaque serveur, une valeur de base pour ce compteur doit être mesurée. L'outil Exchange Server Performance Troubleshooting Analyzer utilise le seuil de 50, qui est approprié à la plupart des grands serveurs.

Par rapport à un serveur fortement chargé, un serveur faiblement chargé présente une valeur réduite pour les demandes RPC. En effet, un serveur faiblement chargé nécessite moins de threads pour suivre le rythme de la charge. Pour éviter de prendre du retard et obtenir une valeur de demande RPC supérieure, un serveur plus occupé doit fournir un travail davantage simultané. Par conséquent, sur un serveur fortement chargé, une valeur de demande RPC supérieure n'implique pas, en soi, un problème de performances. Pour évaluer la « lenteur » du serveur, vous devez également prendre en considération le compteur de performance Latence RPC moyenne.

Causes de la latence

La hausse de la latence peut être due à :

  • une augmentation de la charge RPC ;

  • un goulot d'étranglement d'au moins une ressource du serveur.

En outre, un goulot d'étranglement peut être dû à :

  • une charge RPC élevée (ou toute autre charge sur le serveur) ;

  • une défaillance matérielle ou une erreur de configuration.

Pour corriger cette erreur

  • Suivez les recommandation fournies dans les guides d'Exchange Server 2003 suivants :

    • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

    • Guide sur la résolution des problèmes de performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)


Plage du port RPC définie sur un serveur non membre d'un cluster
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer la valeur des ports :

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Si Exchange Server Analyzer détecte que toutes les conditions suivantes sont vraies, une erreur s'affiche :

  • La clé HKLM\Software\Microsoft\Rpc\Internet\Ports est présente.

  • Le serveur est un serveur Exchange non membre d'un cluster.

  • Le serveur rencontre d'autres erreurs.

Lorsque la clé de Registre est présente, Exchange Server est limité à une plage spécifique de ports pour les appels RPC. Si le serveur Exchange est chargé et nécessite davantage de ports que ceux disponibles, des erreurs peuvent survenir.

Pour remédier à ce problème, vous devez ajouter 100 ports supplémentaires à la clé HKLM\Software\Microsoft\Rpc\Internet\Ports jusqu'à la résolution des problèmes.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez l'Éditeur du Registre Regedt32.exe.

    Remarque :
    Pour modifier une valeur REG_MULTI_SZ, utilisez Regedt32.exe au lieu de Regedit.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Rpc\Internet.

  3. Dans le volet droit, double-cliquez sur la clé Ports. Dans la zone des valeurs, augmentez la plage du port.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les clés de Registre HKLM\Software\Microsoft\Rpc\Internet, voir l'article 154596 de la Base de connaissances Microsoft sur la procédure de configuration de l'allocation du port dynamique RPC avec un pare-feu (http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596).


Plage du port RPC définie sur un serveur en clusters
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer la valeur des ports : HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Si Exchange Server Analyzer détecte que toutes les conditions suivantes sont vraies, une erreur s'affiche :

  • La clé HKLM\Software\Microsoft\Rpc\Internet\Ports est présente.

  • Le serveur est un serveur Exchange en clusters.

  • Le serveur rencontre d'autres erreurs.

Lorsque la clé de Registre est présente, Exchange Server est limité à une plage spécifique de ports pour les appels RPC. Si le serveur Exchange est chargé et nécessite davantage de ports que ceux disponibles, des erreurs peuvent survenir.

Pour remédier à ce problème, vous devez ajouter 100 ports supplémentaires à la clé HKLM\Software\Microsoft\Rpc\Internet\Ports jusqu'à la résolution des problèmes.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez l'Éditeur du Registre Regedt32.exe.

    Remarque :
    Pour modifier une valeur REG_MULTI_SZ, utilisez Regedt32.exe au lieu de Regedit.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Rpc\Internet.

  3. Dans le volet droit, double-cliquez sur la clé Ports. Dans la zone des valeurs, augmentez la plage du port.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les clés de Registre HKLM\Software\Microsoft\Rpc\Internet, voir l'article 154596 de la Base de connaissances Microsoft sur la procédure de configuration de l'allocation du port dynamique RPC avec un pare-feu (http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596).


Activité des utilisateurs RPC à partir des compteurs de performance
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-02-14

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre serveur supporte actuellement une charge élevée d'appel de procédure distante (RPC).

Le taux d'opérations RPC par seconde indique l'importance de la charge RPC présente sur le serveur. Dans certains cas, une augmentation inattendue de la charge opérationnelle RPC peut se traduire par une altération des performances du serveur. Si votre serveur rencontre des problèmes de performances, vous devez tout d'abord identifier si la charge sur le serveur est supérieure à celle attendue. Plusieurs compteurs de performance fournissent des informations sur l'activité RPC présente sur le serveur. Les compteurs de performance décrits dans cet article se trouvent sous les objet de performance MSExchangeIS, MSExchangeIS Public ou MSExchangeIS Mailbox :

  • Opérations RPC/s

  • Nombre d'utilisateurs actifs

  • Ouvertures de session client actives (MSExchangeIS Public)

  • Ouvertures de session client actives (MSExchangeIS Mailbox)

Identification de la charge RPC cliente

Deux compteurs permettent d'identifier le taux d'activité actuel des ordinateurs clients.

  • Opérations RPC/s Ce compteur fournit le nombre d'opérations RPC par seconde que les ordinateurs clients demandent au serveur. Vous pouvez compter les utilisateurs en procédant comme suit :

    • Vous pouvez compter le nombre total des boîtes aux lettres sur le serveur.

    • Vous pouvez compter le nombre total d'ouvertures de session (à partir de la somme Ouvertures de session client actives pour MSExchangeIS Public et Ouvertures de session client actives pour MSExchangeIS Mailbox).

    • Vous pouvez compter le nombre total d'ouvertures de session à partir du Nombre d'utilisateurs actifs.

    Exchange Server Analyzer utilise la dernière méthode. Pour calculer la taux par utilisateur actif, divisez la moyenne des Opérations RPC/s par le Nombre d'utilisateurs actifs.

  • Opérations RPC/s par utilisateur Ce compteur fournit une indication sur les utilisateurs actifs présents sur le serveur. Généralement, les travailleurs du savoir qui utilisent Microsoft Office Outlook® ont un taux d'environ 0,1 opération par seconde et par utilisateur sur un serveur de boîtes aux lettres. Si les utilisateurs sur le serveur exécutent des applications supplémentaires, le nombre peut augmenter.

Si Exchange Server Analyzer détermine que le nombre d'opérations RPC par seconde par utilisateur est compris entre 0,15 et 0,25, les utilisateurs sont considérés comme modérément actifs et Exchange Server Analyzer affiche un avertissement.

Si Exchange Server Analyzer détermine que le nombre d'opérations RPC par seconde par utilisateur est supérieur à 0,25, l'activité des utilisateurs est considérée comme inhabituelle et Exchange Server Analyzer affiche une erreur.

Mesures à prendre si la charge RPC est élevée

Si le nombre d'opérations par seconde est supérieur à celui attendu, essayez d'abord d'identifier la cause de cette charge élevée et réduisez celle-ci. Vous pouvez utiliser EXMon, l'outil de surveillance des utilisateurs d'Exchange Server, pour identifier si un utilisateur particulier effectue un taux élevé d'opérations RPC.

Si vous ne parvenez pas à réduire la charge sur le serveur, vous devez identifier les goulots d'étranglement des performances et augmenter la capacité du serveur.

Identification d'un grand nombre d'ouvertures de session

Il est nécessaire que le serveur conserve en mémoire (mémoire utilisateur et mémoire du noyau) certaines informations sur les ouvertures de session. Une quantité de mémoire limitée est mise de côté. Si cette mémoire est utilisée, le serveur peut rencontrer un goulot d'étranglement de mémoire. Pour cette raison, si vous rencontrez des problèmes de performances sur un serveur Exchange, vous devez vous assurer que le nombre total d'ouvertures de session par utilisateur n'est pas excessif.

En général, un travailleur du savoir dispose de deux ou trois ouvertures de session. Si des utilisateurs exécutent d'autres applications, le nombre d'ouvertures de session peut augmenter. Exchange Server Analyzer calcule le nombre d'ouvertures de session par utilisateur en divisant le nombre total d'ouvertures de session sur le serveur par le nombre de boîtes aux lettres sur le serveur. Vous pouvez déterminer le nombre total d'ouvertures de session sur le serveur en ajoutant les compteurs de performance Ouvertures de session clientes actives dans les objets de performance MSExchangeIS Mailbox et MSExchangeIS Public. Pour les serveurs de boîtes aux lettres ou mixtes de boîtes aux lettres et de dossiers publics, Exchange Server Analyzer tient uniquement compte de ce rapport.

Remarque :
Si un grand nombre d'utilisateurs affichent les dossiers partagés d'autres utilisateurs (tels que les calendriers partagés), le nombre d'ouvertures de session peut également être supérieur.

Si le nombre moyen d'ouvertures de session par utilisateur est supérieur à cinq et si le serveur rencontre un goulot d'étranglement de mémoire, cela peut indiquer que des utilisateurs exécutent des applications créant de nombreuses ouvertures de session. Si des utilisateurs exécutent des applications qui ne sont pas professionnelles, demandez-leur de ne pas exécuter des applications provoquant des ouvertures de session excessives sur le serveur Exchange.

Si vous ne parvenez pas à réduire le nombre d'applications exécutées par les utilisateurs, vous devez réduire le nombre d'utilisateurs par serveur en déplaçant des utilisateurs vers un autre serveur. Pour déterminer si les ouvertures de session sont provoquées par plusieurs utilisateurs ou si un seul utilisateur possède un trop grand nombre d'ouvertures de session, vous pouvez utiliser le Gestionnaire système Exchange pour afficher les ouvertures de session actives de chaque utilisateur.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


L'analyse antivirus RTF a été désactivée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur pour l'analyse antivirus de messages au format RTF (Rich Text Format) :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Si Exchange Server Analyzer détecte que la valeur de ScanRTF est définie sur 0, un avertissement s'affiche.

La clé de Registre ScanRTF est définie par les fournisseurs d'antivirus tiers qui utilisent l'interface VSAPI (Exchange Virus Scanning API). Les messages RTF permettent d'utiliser les couleurs, les polices et la mise en forme, mais ne peuvent être lus que par Microsoft Office Outlook® 2003. Le format RTF d'Exchange Server est différent de celui d'un fichier RTF qui peut être lu dans un traitement de texte tel que Microsoft Office Word 2003.

Il est recommandé d'analyser tous les types de messages à la recherche de virus, y compris les messages RTF. Vous devez activer l'analyse antivirus de tous les messages circulant via un ordinateur Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Dans votre application antivirus compatible avec Exchange, activez l'analyse de tous les messages

    ou

  2. modifiez manuellement l'entrée dans le Registre en respectant la procédure suivante :

    • Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    • Naviguez jusqu'à :

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • Double-cliquez sur la valeur de Registre ScanRTF et définissez-la sur 1.

    • Quittez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange, ainsi que les services représentant votre logiciel antivirus compatible avec Exchange, pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la lutte contre les virus, voir le site Web sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=30732).


La bannière SMTP a été personnalisée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool tente d'envoyer un message vers le compte administrateur ou un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol). Exchange Server Analyzer affiche un avertissement s'il reçoit une réponse de ce compte qui diffère de la réponse par défaut, c'est-à-dire la suivante :

« 220 Computer Name . Domain Name .com Microsoft ESMTP MAIL Service, Version: Version Number ready at Date Time +0000 »

Cet avertissement indique que la réponse par défaut qui s'affiche lorsque le programme se connecte à un serveur virtuel SMTP Exchange a été personnalisée.

Une bannière SMTP personnalisée peut ne pas poser de problème si l'administrateur Exchange Server l'a modifiée intentionnellement comme décrit dans l'article 281224 de la Base de connaissances Microsoft sur la procédure de modification de la bannière SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224).

Si la bannière SMTP par défaut n'a pas été intentionnellement personnalisée par l'administrateur Exchange Server, cet avertissement peut indiquer qu'Exchange Server se trouve derrière un pare-feu ou un proxy SMTP qui filtre les commandes ESMTP (Extended SMTP) d'Exchange Server.

Un filtrage des commandes ESMTP d'Exchange Server peut avoir un impact significatif sur les performances d'Exchange et risque de produire le comportement décrit dans l'article 320027 de la Base de connaissances Microsoft sur l'impossibilité d'envoyer ou de recevoir des messages électronique derrière un pare-feu Cisco PIX (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).

Pour plus d'informations sur les bannières SMTP personnalisées, voir les articles suivants de la Base de connaissances Microsoft :

  • Article sur la procédure de modification de la bannière SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224).

  • Article sur l'impossibilité d'envoyer ou de recevoir des messages électroniques derrière un pare-feu Cisco PIX (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).


Instance SMTP suspendue
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la métabase IIS pour déterminer la valeur de la propriété ServerState pour chaque instance d'un serveur virtuel SMTP (Simple Mail Transfer Protocol).

La propriété ServerState présente l'état actuel de l'instance de serveur. Les états et codes correspondants sont les suivants : 1 (démarrage), 2 (démarré), 3 (arrêt), 4 (arrêté), 5 (suspension), 6 (suspendu) ou 7 (reprise).

Si Exchange Server Analyzer détermine que la valeur de la propriété ServerState pour une instance de serveur virtuel SMTP est égale à 6 (suspendu), il affiche une erreur.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Les serveurs virtuels s'exécutent sous un processus serveur que vous pouvez démarrer, arrêter et suspendre (de la même manière que d'autres processus serveur). Par exemple, si vous modifiez la configuration d'un serveur virtuel ou effectuez d'autres tâches de mise à jour, il se peut que vous deviez arrêter le serveur virtuel, apporter les modifications, puis le redémarrer. Lorsque vous arrêtez un serveur virtuel, il n'accepte pas les connexions des utilisateurs et vous ne pouvez pas l'utiliser pour remettre ou recevoir des messages électroniques.

La suspension constitue une alternative à l'arrêt d'un serveur virtuel. La suspension d'un serveur virtuel empêche les nouvelles connexions des clients mais ne déconnecte pas les connexions en cours. Lorsque vous suspendez un serveur virtuel SMTP, les clients actifs peuvent continuer à envoyer des messages et le serveur virtuel peut remettre les messages existants en attente de remise. Toutefois, aucune nouvelle connexion n'est acceptée.

Pour les opérations de messagerie ordinaires, les instances de serveur virtuel SMTP d'Exchange Server doivent être démarrées.

Pour résoudre cette erreur, effectuez la procédure suivante pour démarrer l'instance de serveur virtuel SMTP.

Pour démarrer l'instance de serveur virtuel SMTP

  1. Dans le Gestionnaire système Exchange, cliquez avec le bouton droit sur l'instance de serveur virtuel à démarrer.

  2. Dans le menu Action, cliquez sur Démarrer.

Pour plus d'informations sur la procédure de démarrage, d'arrêt ou de suspension de serveurs virtuels SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • Article sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • Article sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

  • Article sur la procédure de vidage de la file d'attente de messagerie SMTP dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087).

  • Article sur la désactivation des protocoles dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330).


L'instance SMTP s'est arrêtée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la métabase IIS pour déterminer la valeur de la propriété ServerState pour chaque instance d'un serveur virtuel SMTP (Simple Mail Transfer Protocol).

La propriété ServerState présente l'état actuel de l'instance de serveur. Les états et codes correspondants sont les suivants : 1 (démarrage), 2 (démarré), 3 (arrêt), 4 (arrêté), 5 (suspension), 6 (suspendu) ou 7 (reprise).

Si l'outil Exchange Server Analyzer Tool détermine que la valeur de la propriété ServerState pour une instance de serveur virtuel SMTP est égale à 4 (arrêté), il affiche une erreur.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Les serveurs virtuels s'exécutent sous un processus serveur que vous pouvez démarrer, arrêter et suspendre (de la même manière que d'autres processus serveur). Par exemple, si vous modifiez la configuration d'un serveur virtuel ou effectuez d'autres tâches de mise à jour, il se peut que vous deviez arrêter le serveur virtuel, apporter les modifications, puis le redémarrer. Lorsque vous arrêtez un serveur virtuel, il n'accepte pas les connexions des utilisateurs et vous ne pouvez pas l'utiliser pour remettre ou recevoir des messages électroniques.

Pour les opérations de messagerie ordinaires, les instances de serveur virtuel SMTP d'Exchange Server doivent être démarrées.

Pour résoudre cette erreur, effectuez la procédure suivante pour démarrer l'instance de serveur virtuel SMTP.

Pour démarrer l'instance de serveur virtuel SMTP

  1. Dans le Gestionnaire système Exchange, cliquez avec le bouton droit sur l'instance de serveur virtuel à démarrer.

  2. Dans le menu Action, cliquez sur Démarrer.

Pour plus d'informations sur la procédure de démarrage, d'arrêt ou de suspension de serveurs virtuels SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • Article sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • Article sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

  • Article sur la procédure de vidage de la file d'attente de messagerie SMTP dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087).

  • Article sur la désactivation des protocoles dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330).


Le nombre maximal de destinataires SMTP est peut-être défini sur une valeur trop faible
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée pour l'attribut msExchSmtpMaxRecipients est inférieure à 250. Par défaut, l'attribut msExchSmtpMaxRecipients est configuré sur 64 000 destinataires. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchSmtpMaxRecipients est inférieure à 250, il affiche un avertissement.

Pour des raisons de sécurité, il est préférable de limiter le nombre maximal de destinataires pour chaque message. Il est recommandé de laisser l'attribut msExchSmtpMaxRecipients sur sa valeur par défaut, à savoir 64000.

Chaque organisation doit déterminer son nombre maximal acceptable de destinataires en fonction de ses besoins. Il est toutefois déconseillé de définir ce nombre sur une valeur inférieure à 250, car les messages envoyés à plusieurs listes de distribution sont susceptibles de compter plus de 250 destinataires. Si le maximum est défini sur une valeur inférieure à 250, Exchange doit utiliser des copies supplémentaires du message pour traiter les destinataires restants, ce qui augmente le trafic réseau.

Pour afficher et configurer le nombre maximal de destinataires

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut), puis sélectionnez Propriétés.

  4. Sélectionnez l'onglet Messages.

  5. Pour rétablir le paramètre par défaut de 64000, veillez à activer la case à cocher Limiter le nombre de destinataires par message à et entrez une valeur de 64000. Vous pouvez également configurer ce champ avec la valeur de votre choix ou désactiver la case à cocher pour autoriser un nombre illimité de destinataires.

  6. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


L'adresse proxy SMTP pour EAS a été remplacée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

Message d'erreur

Intro

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'adresse proxy SMTP pour Exchange ActiveSync® a été remplacée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

Si Exchange Server Analyzer détecte que l'entrée de Registre SMTPProxy est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Les adresses SMTP sont utilisées pour identifier le chemin d'accès à une boîte aux lettres dans Exchange Server et elles doivent être uniques. Chaque adresse est constituée d'une partie gauche et d'une partie droite séparées par un symbole @. Par exemple, le format pour une adresse SMTP est le suivant :

NomUtilisateur@domaine.com = partie gauche@partie droite (ou LHS@RHS)

Exchange ActiveSync utilise une demande WebDAV pour accéder aux informations de boîte aux lettres à partir du serveur Exchange Exchange ActiveSync sélectionne une valeur RHS associée, LHS@RHS représentant une adresse proxy SMTP, pour l'utiliser dans la demande WebDAV. Dans les environnements qui présentent une adresse RHS par défaut différente de l'adresse SMTP principale d'un utilisateur, la valeur de Registre SMTPProxy fournit une opportunité de configuration pour permettre à Exchange ActiveSync d'utiliser une autre adresse proxy SMTP.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour afficher ou modifier la valeur de Registre SMTPProxy

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Examinez et, au besoin, modifiez la valeur SMTPProxy.

  4. Si une modification est effectuée, fermez l'Éditeur du Registre puis redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur Exchange ActiveSync, voir le document sur l'architecture d'Exchange Server 2003 ActiveSync (http://go.microsoft.com/fwlink/?linkid=34203).

Pour plus d'informations sur l'accès mobile et Exchange Server 2003, voir le document sur l'accès mobile à l'aide d'Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=20098).


Le serveur SMTP accepte l'authentification de base
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchAuthenticationFlags dans la classe protocolCfgSMTPServer de l'objet Exchange Server. La classe protocolCfgSMTPServer contient les paramètres d'un serveur virtuel SMTP. L'attribut msExchAuthenticationFlags représente le type d'authentification autorisé sur le serveur SMTP. Si Exchange Server Analyzer détermine que l'authentification de base a été configurée sur le serveur SMTP et que le serveur n'est pas un serveur Microsoft Small Business Server 2000 ou Microsoft Windows® Small Business Server 2003, Exchange Server Analyzer affiche un message d'avertissement.

Si l'authentification de base est configurée sur le serveur SMTP, le risque de violation de la sécurité augmente. L'authentification de base permet d'envoyer des noms d'utilisateur et des mots de passe sur le réseau en texte clair. Sans cryptage, les noms d'utilisateur et les mots de passe peuvent être facilement interceptés sur Internet.

Si vous utilisez l'authentification de base, il est vivement recommandé d'utiliser également le cryptage TLS (Transport Layer Security) pour accroître la sécurité. Celui-ci crypte les noms d'utilisateur, les mots de passe et les données des messages. Vous pouvez demander que les clients qui se connectent au serveur virtuel SMTP utilisent le cryptage TLS. TLS est conçu pour contribuer à protéger les messages sortants, mais ne protège pas le trafic des clients vers le serveur.

TLS est pris en charge par Microsoft Outlook Express. Pour utiliser le cryptage TLS pour le serveur virtuel SMTP, vous devez créer des paires de clés et configurer des certificats de clé. Les clients peuvent ensuite utiliser TLS pour crypter la session avec le service SMTP. Par conséquent, tous les messages sont envoyés. Le service SMTP peut également utiliser TLS pour crypter les sessions avec des serveurs distants.

Remarque :
Les clients qui ne prennent pas TLS en charge ne peuvent pas relayer les messages électroniques par le biais du serveur virtuel.

Si vous ne pouvez pas désactiver l'accès authentifié sur votre serveur virtuel SMTP pour des raisons professionnelles, telles que l'authentification par une société partenaire, effectuez la procédure suivante pour améliorer la sécurité sur votre serveur de passerelle :

  • Mettez en œuvre une stratégie des mots de passe forts, en particulier pour le compte administrateur.

  • Désactivez le compte invité. Pour plus d'informations sur la désactivation du compte invité, voir l'article 320053 de la Base de connaissances Microsoft sur la procédure de changement de nom des comptes administrateur et invité dans Windows 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053). Bien que cet article s'applique à Microsoft Windows 2000 Server, les mêmes principes sont également valables pour Windows Server™ 2003.

Pour désactiver l'authentification de base

  1. Dans le Gestionnaire système Exchange, développez Serveurs, <votre serveur Exchange entrant>, Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur le serveur virtuel SMTP entrant, puis cliquez sur Propriétés.

  3. Cliquez sur l'onglet Accès, puis sur Authentification.

    Boîte de dialogue Authentification

  4. Dans Authentification, désactivez la case à cocher Authentification de base.

    Important :
    Si vous utilisez l'authentification de base, envisagez la mise en œuvre de TLS pour accroître la sécurité. Activez la case à cocher Requiert le cryptage TLS si vous possédez un certificat numérique. Les certificats numériques sont courants dans un environnement de haute sécurité. Si vous activez cette case à cocher, dans la zone Domaine par défaut correspondante, vous devez entrer le nom de domaine Windows 2000 Server ou Windows Server 2003 par lequel l'utilisateur doit s'authentifier s'il ne spécifie pas de domaine. Pour plus d'informations sur le cryptage TLS, voir la documentation Exchange en ligne.

Pour plus d'informations sur la manière de configurer votre organisation Exchange Server 2003 pour envoyer et recevoir du courrier Internet de manière plus sécurisée, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=26041).


Service SMTP désactivé
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur définie pour la clé StartMode du service SMTP (Simple Mail Transfer Protocol). La valeur Disabled indique que le service SMTP (Simple Mail Transfer Protocol) a été désactivé et ne peut pas être redémarré avant que la valeur StartMode soit modifiée en Manual ou Automatic.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour le service SMTP. La valeur False indique que le service n'est pas en cours d'exécution. La valeur True indique que le service est en cours d'exécution.

Si Exchange Server Analyzer détecte que la valeur de la clé StartMode est définie sur Disabled sur un ordinateur Exchange Server sur lequel le service SMTP est démarré, il affiche une erreur.

Le service SMTP de Windows est un composant des services Internet (IIS) et s'exécute en même temps que Inetinfo.exe. Exchange Server utilise le service SMTP comme protocole de transport natif. Par conséquent, Exchange utilise SMTP pour router tous les messages internes et externes.

Le service SMTP de tous les ordinateurs Exchange Serveur doit être défini sur Automatic.

Pour corriger cette erreur, vous devez configurer le service SMTP pour qu'il démarre automatiquement sur les serveurs qui routent le courrier.

Pour configurer le service SMTP en vue d'un lancement automatique

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Double-cliquez sur le service SMTP (Simple Mail Transfer Protocol).

  3. Sous l'onglet Général de la page Propriétés SMTP (Simple Mail Transfer Protocol), sélectionnez Automatique dans la liste déroulante de la boîte de dialogue Type de démarrage, puis cliquez sur Appliquer.

  4. Sous État du serveur, cliquez sur Démarrer, puis sur OK.

  5. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur le service SMTP et les serveurs Exchange, voir la rubrique sur l'architecture de transport SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de configuration du service SMTP pour Exchange, voir la rubrique sur la configuration de SMTP dans Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=24866).


Service SMTP non démarré
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2007-03-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service SMTP (Simple Mail Transfer Protocol). La valeur False indique que le service SMTP n'est pas en cours d'exécution. La valeur True indique que le service SMTP est en cours d'exécution.

Si Exchange Server Analyzer détecte que la valeur de la clé Started est définie sur False, il affiche une erreur.

Le service SMTP de Windows est un composant des services Internet (IIS) et s'exécute en même temps que Inetinfo.exe. Exchange Server utilise le service SMTP comme protocole de transport natif. Par conséquent, Exchange utilise SMTP pour router tous les messages internes et externes.

Le service SMTP doit toujours être en cours d'exécution sur les serveurs Exchange.

Pour corriger cette erreur

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Dans le volet droit, faites défiler jusqu'au service Simple Mail Transfer Protocol (SMTP) et double-cliquez sur celui-ci. La boîte de dialogue Propriétés SMTP (Simple Mail Transfer Protocol) s'affiche.

  3. Définissez la valeur du menu déroulant Type de démarrage sur Automatique.

  4. Cliquez sur Démarrer pour démarrer le service Surveillance du système.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés SMTP (Simple Mail Transfer Protocol).

  6. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur le service SMTP et les serveurs Exchange, voir la rubrique sur l'architecture de transport SMTP dans le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Pour plus d'informations sur la procédure de configuration du service SMTP pour Exchange, voir la rubrique sur la configuration de SMTP dans Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=24866).


Service SMTP défini sur Manuel
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-05-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur définie pour la clé StartMode du service SMTP (Simple Mail Transfer Protocol). La valeur Manual indique que le service SMTP a été défini de sorte à exiger un lancement manuel et à ne pas démarrer automatiquement.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour le service SMTP. La valeur False indique que le service n'est pas en cours d'exécution. La valeur True indique que le service est en cours d'exécution.

Si Exchange Server Analyzer détecte que la valeur de la clé StartMode est définie sur Manual sur un ordinateur Exchange Server sur lequel le service SMTP est démarré, il affiche un avertissement.

Le service SMTP de Windows est un composant des services Internet (IIS) et s'exécute en même temps qu'Inetinfo.exe. Exchange Server utilise le service SMTP comme protocole de transport natif. Par conséquent, Exchange utilise SMTP pour router tous les messages internes et externes.

Si le service SMTP ne se lance pas automatiquement au démarrage, il a peut-être été oublié. Cela peut provoquer de graves problèmes de flux de messages.

Le service SMTP de tous les ordinateurs Exchange Serveur doit être défini sur Automatic.

Pour corriger cette erreur, vous devez configurer le service SMTP pour qu'il démarre automatiquement sur les serveurs qui routent le courrier.

Pour configurer le service SMTP en vue d'un lancement automatique

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Double-cliquez sur le service SMTP (Simple Mail Transfer Protocol).

  3. Sous l'onglet Général de la page Propriétés SMTP (Simple Mail Transfer Protocol), sélectionnez Automatique dans la liste déroulante de la boîte de dialogue Type de démarrage, puis cliquez sur Appliquer.

  4. Sous État du serveur, cliquez sur Démarrer, puis sur OK.

  5. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur le service SMTP et les serveurs Exchange, voir la rubrique sur l'architecture de transport SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de configuration du service SMTP pour Exchange, voir la rubrique sur la configuration de SMTP dans Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=24866).


État du service SMTP inconnu
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service SMTP (Simple Mail Transfer Protocol). La valeur False indique que le service SMTP n'est pas en cours d'exécution. La valeur True indique que le service SMTP est en cours d'exécution.

Si Exchange Server Analyzer ne peut pas déterminer la valeur de la clé Started, il affiche un message d'erreur.

Cette erreur indique que la requête WMI n'a pas pu extraire les données requises.

Les causes probables de cette erreur sont les suivantes :

  • Le compte qui utilise Exchange Server Analyzer n'a pas d'autorisations suffisantes pour interroger des classes WMI.

  • Un problème de réseau empêche Exchange Server Analyzer de contacter l'ordinateur.

  • Une condition temporaire d'origine inconnue a entraîné un délai d'attente pour la requête.

Correction de cette erreur

  1. Assurez-vous que le serveur exécutant Exchange Server a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour voir si le serveur Exchange est accessible.

  3. En cas de présence d'un pare-feu, vérifiez si les ports d'appel de procédure distante (RPC) sont bloqués.

  4. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque serveur Exchange qu'il analyse.

    Vous pouvez également accorder des autorisations WMI spécifiques au compte sous lequel Exchange Server Analyzer est exécuté :

    1. Sur le serveur Exchange, ouvrez l'arborescence MMC (Microsoft Management Console) Gestion de l'ordinateur.

    2. Dans Services et applications, cliquez avec le bouton droit sur Contrôle WMI, puis sur Propriétés.

    3. Dans la boîte de dialogue Propriété des contrôles WMI, cliquez sur l'onglet Sécurité, puis développez Racine.

    4. Sélectionnez le dossier CIMV2, puis cliquez sur Sécurité.

    5. Dans la page Sécurité pour ROOT\CIMV2, ajoutez le compte sous lequel Exchange Server Analyzer est exécuté.

  5. Sélectionnez le compte que vous avez ajouté à l'étape 5. Dans Autorisations pour compte_sélectionné, sous la colonne Autoriser, activez les cases à cocher Appel à distance autorisé et Sécurité de lecture, puis cliquez sur OK.

Pour plus d'informations sur le service SMTP et les serveurs Exchange, consultez la rubrique sur l'architecture de transport SMTP dans le Guide de référence technique d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Pour plus d'informations sur la procédure de configuration du service SMTP pour Exchange, consultez la rubrique sur la configuration de SMTP dans Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=24866).

Pour plus d'informations sur le dépannage des problèmes de connectivité réseau, consultez l'article 325487 de la Base de connaissances Microsoft, « Résolution des problèmes de connectivité réseau » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur le dépannage des problèmes de connectivité de l'outil Exchange Server Analyzer, consultez le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer (http://go.microsoft.com/fwlink/?LinkId=56285).


Valeurs de Registre UseAltRegionalCharset et UseRegionalCharset toutes deux activées
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer les paramètres de langue utilisés par les clients Microsoft Outlook® Web Access :

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    Le paramètre 1 permet aux corps de messages UTF-8 de persister dans la banque d'informations dans le jeu de caractères régionaux ou dans la page de codes et non au format UTF-8. Il s'agit du paramètre par défaut pour la valeur de Registre UseRegionalCharset dans Exchange Server 2003.

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Le niveau du navigateur détermine le codage du message si les conditions suivantes sont vraies :

  • La clé UseAltRegionalCharset n'est pas définie ou est définie sur 0.

  • La clé UseRegionalCharset associée n'est pas définie ou est définie sur 0.

Un navigateur d'un niveau supérieur, tel qu'Internet Explorer 5 ou qu'une version ultérieure, envoie des messages au format UTF-8. Un navigateur antérieur ou différent d'Internet Explorer 5, envoie des messages codés de manière appropriée pour la langue acceptée par ce navigateur.

La clé UseAltRegionalCharset modifie uniquement le comportement des navigateurs configurés pour les langues répertoriées dans la liste suivante :

  • Coréen : KS_C_5601-1987

  • Japonais : shift_jis

  • Europe occidentale : windows-1252

  • Russe : windows-1251

  • Europe centrale : windows-1250

Si la clé UseAltRegionalCharset est définie sur 1, les navigateurs d'un niveau supérieur et antérieurs envoient des messages codés de la manière suivante :

  • Coréen : euc_kr

  • Japonais : iso-2022-jp (JIS)

  • Europe occidentale : iso-8859-1

  • Russe : koi8-r

  • Europe centrale : iso-8859-2

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer.

  • Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server.

  • Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Exchange Server 2003.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Les valeurs UseAltRegionalCharset et UseRegionalCharset sont toutes deux présentes

  • Les valeurs UseAltRegionalCharset et UseRegionalCharset sont toutes deux configurées pour utiliser la valeur 1 sur un serveur Exchange 2000 ou Exchange 2003.

Pour Exchange 2000 Server et Exchange Server 2003, les autres jeux de caractères ont la priorité lorsque les conditions suivantes sont vraies :

  • L'utilisation des caractères régionaux est activée : la valeur REG_DWORD de la clé de Registre UseRegionalCharset est définie sur -1.

  • L'utilisation d'autres jeux de caractères est activée : la valeur REG_DWORD de la clé de Registre UseAltRegionalCharset est définie sur 0x1.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour corriger cette erreur

  1. Sur l'ordinateur Exchange, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Déterminez les paramètres de langue Outlook Web Access appropriés pour l'environnement Exchange Server et supprimez la clé inappropriée.

    1. Naviguez jusqu'à : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

    2. Sélectionnez la clé à supprimer, cliquez dessus avec le bouton droit, puis sélectionnez Supprimer dans la liste déroulante.

  3. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres de langue Outlook Web Access, voir les ressources Exchange Server suivantes :

Guide sur l'accès client à Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47568).

Article 311342 de la Base de connaissances Microsoft sur les clés de Registre OWA côté serveur Exchange 2000 Server SP2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342).


La valeur de Registre UseAltRegionalCharset est activée dans Exchange 2000 Server
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur UseAltRegionalCharset est utilisée pour le paramètre de langue du client pour Microsoft Outlook® Web Access :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Le niveau du navigateur détermine le codage du message si les conditions suivantes sont vraies :

  • La clé UseAltRegionalCharset n'est pas définie ou est définie sur 0.

  • La clé UseRegionalCharset associée n'est pas définie ou est définie sur 0.

La clé UseAltRegionalCharset modifie uniquement le comportement des navigateurs configurés pour les langues répertoriées dans la liste suivante :

  • Coréen : KS_C_5601-1987

  • Japonais : shift_jis

  • Europe occidentale : windows-1252

  • Russe : windows-1251

  • Europe centrale : windows-1250

Si la clé UseAltRegionalCharset est définie sur 1, les navigateurs d'un niveau supérieur et antérieurs envoient des messages codés de la manière suivante :

  • Coréen : euc_kr

  • Japonais : iso-2022-jp (JIS)

  • Europe occidentale : iso-8859-1

  • Russe : koi8-r

  • Europe centrale : iso-8859-2

Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server.

Si Exchange Server Analyzer détecte que la clé UseAltRegionalCharset est configurée de manière à utiliser une valeur supérieure à 0 sur un ordinateur Exchange 2000 Server, il affiche un message indiquant une configuration autre que celle par défaut.

Ce message indique que le paramètre de Registre UseAltRegionalCharset sur ce serveur Exchange 2000 est activé. Si vous pensez que les utilisateurs Outlook Web Access de votre organisation envoient souvent du courrier à des destinataires qui utilisent une série de jeux de caractères, vous pouvez modifier les paramètres du Registre pour que les utilisateurs qui exécutent Internet Explorer 5 ou versions ultérieures puissent utiliser les caractères UNICODE codés par UTF-8 pour envoyer le courrier. Si vous n'avez pas besoin de plusieurs jeux de caractères, utilisez la procédure suivante pour restaurer la configuration par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour restaurer le paramètre de langue par défaut pour Outlook Web Access

  1. Sur l'ordinateur Exchange, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Dans le volet droit, supprimez la valeur de Registre UseAltRegionalCharSet.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres de langue d'Outlook Web Access, voir l'article 311342 de la Base de connaissances Microsoft sur les clés de Registre OWA côté serveur Exchange 2000 Server SP2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342).


La valeur de Registre UseAltRegionalCharset est activée dans Exchange Server 2003
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour rechercher la présence de la valeur de Registre UseAltRegionalCharset :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

La valeur de Registre UseAltRegionalCharset permet aux utilisateurs Microsoft Outlook® Web Access de coder les messages électroniques à l'aide d'un autre jeu de caractères.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de Registre UseAltRegionalCharset est définie sur une valeur supérieure à 0 sur un serveur Exchange 2003, il affiche un message indiquant une configuration autre que celle par défaut.

Ce message indique que la valeur UseAltRegionalCharset a été configurée sur ce serveur Exchange 2003. Ce paramètre peut entraîner un codage du jeu de caractères involontaire pour les messages Outlook Web Access, certains messages pouvant être illisibles pour certains clients. Nous vous recommandons de vérifier que les paramètres de langue du client sont corrects.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour restaurer le paramètre de langue par défaut pour Outlook Web Access sur Exchange Server 2003

  1. Sur l'ordinateur Exchange, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Dans le volet droit, supprimez la valeur de Registre UseAltRegionalCharSet.

  4. Si la valeur de Registre UseRegionalCharset n'existe pas, procédez comme suit pour la créer :

    1. Dans le menu Edition, cliquez sur Nouveau, puis sur Valeur DWORD.

    2. Entrez UseRegionalCharset comme nom de la valeur DWORD, puis appuyez sur Entrée.

  5. Si la valeur UseRegionalCharset existe, double-cliquez sur cette dernière pour la modifier.

  6. Dans la zone Données de la valeur, entrez 1, puis cliquez sur OK.

  7. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les valeurs de Registre UseAltRegionalCharSet et UseRegionalCharset, voir l'article 283214 de la Base de connaissances Microsoft sur Outlook Web Access qui peut envoyer un message en japonais dans SJIS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214).


La valeur de Registre UseRegionalCharset est activée dans Exchange 2000 Server
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les paramètres de langue utilisés par les clients Microsoft Outlook® Web Access :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

La valeur de Registre UseRegionalCharset permet aux corps de messages UTF-8 de persister dans la banque d'informations dans le jeu de caractères régionaux ou dans la page de codes et non au format UTF-8.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Exchange 2000 Server.

Si Exchange Server Analyzer détecte que la valeur UseRegionalCharset est configurée pour une utilisation avec une valeur de 1 ou plus sur un ordinateur qui exécute Exchange 2000 Server, il affiche un message indiquant une configuration autre que celle par défaut.

Ce message indique que le paramètre de Registre UseRegionalCharset sur ce serveur Exchange 2000 est activé. Si vous pensez que les utilisateurs Outlook Web Access de votre organisation envoient souvent du courrier à des destinataires qui utilisent une série de jeux de caractères, vous pouvez modifier les paramètres du Registre pour que les utilisateurs qui exécutent Internet Explorer 5 ou versions ultérieures puissent utiliser les caractères UNICODE codés par UTF-8 pour envoyer le courrier. Si vous n'avez pas besoin de plusieurs jeux de caractères, utilisez la procédure suivante pour restaurer la configuration par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour restaurer le paramètre de langue par défaut pour Outlook Web Access

  1. Sur l'ordinateur Exchange, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Dans le volet droit, supprimez la valeur de Registre UseRegionalCharSet.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La valeur de Registre UseRegionalCharset est désactivée
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les paramètres de langue utilisés par les clients Microsoft Outlook® Web Access :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

La valeur de Registre UseRegionalCharset permet aux corps de messages UTF-8 de persister dans la banque d'informations dans le jeu de caractères régionaux ou dans la page de codes et non au format UTF-8.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur UseRegionalCharset est configurée pour une utilisation avec une valeur de 0 sur un ordinateur Exchange Server 2003, il affiche un message indiquant une configuration autre que celle par défaut.

Ce message indique que le paramètre de Registre UseRegionalCharset sur ce serveur Exchange 2003 est désactivé. Ce paramètre peut entraîner un codage du jeu de caractères involontaire pour les messages Outlook Web Access, certains messages pouvant être illisibles pour certains clients.

Lorsque vous utilisez Microsoft Internet Explorer 5 ou versions ultérieures pour accéder à Outlook Web Access, Exchange Server 2003 utilise les paramètres de langue du navigateur pour déterminer le jeu de caractères à utiliser pour coder les informations comme les messages électroniques et les demandes de réunion.

Si vous pensez que les utilisateurs Outlook Web Access de votre organisation envoient souvent du courrier à des destinataires qui utilisent une série de jeux de caractères, vous pouvez modifier les paramètres du Registre pour que les utilisateurs qui exécutent Internet Explorer 5 ou versions ultérieures puissent utiliser les caractères UNICODE codés par UTF-8 pour envoyer le courrier.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour restaurer le paramètre de langue par défaut pour Outlook Web Access

  1. Sur l'ordinateur Exchange, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Si la valeur UseRegionalCharset n'existe pas, procédez comme suit pour la créer :

    1. Dans le menu Edition, cliquez sur Nouveau, puis sur Valeur DWORD.

    2. Entrez UseRegionalCharset comme nom de la valeur DWORD, puis appuyez sur Entrée.

  4. Si la valeur UseRegionalCharset existe, double-cliquez sur cette dernière pour la modifier.

  5. Dans la zone Données de la valeur, entrez 1, puis cliquez sur OK.

  6. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres de langue Outlook Web Access, voir le guide sur l'accès client à Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47568).


La valeur de Registre UseRegionalCharset est désactivée ou manquante sur Exchange Server 2003
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les paramètres de langue utilisés par les clients Microsoft Outlook® Web Access :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

La valeur de Registre UseRegionalCharset permet aux corps de messages UTF-8 de persister dans la banque d'informations dans le jeu de caractères régionaux ou dans la page de codes et non au format UTF-8.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Exchange Server 2003.

Exchange Server Analyzer affiche un message d'avertissement si l'une des conditions suivantes est vraie :

  • L'entrée UseRegionalCharset d'un serveur Exchange 2003 n'est pas présente.

  • L'entrée UseRegionalCharset possède une valeur autre que 1.

Ce message indique que le paramètre de Registre UseRegionalCharset sur ce serveur Exchange 2003 est désactivé ou manquant. Ce paramètre peut entraîner un codage du jeu de caractères involontaire pour les messages Outlook Web Access, certains messages pouvant être illisibles pour certains clients.

Lorsque vous utilisez Microsoft Internet Explorer 5 ou versions ultérieures pour accéder à Outlook Web Access, Exchange Server 2003 utilise les paramètres de langue du navigateur pour déterminer le jeu de caractères à utiliser pour coder les informations comme les messages électroniques et les demandes de réunion.

Si vous pensez que les utilisateurs Outlook Web Access de votre organisation envoient souvent du courrier à des destinataires qui utilisent une série de jeux de caractères, vous pouvez modifier les paramètres du Registre pour que les utilisateurs qui exécutent Internet Explorer 5 ou versions ultérieures puissent utiliser les caractères UNICODE codés par UTF-8 pour envoyer le courrier.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour restaurer le paramètre de langue par défaut pour Outlook Web Access

  1. Sur l'ordinateur Exchange, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Si la valeur UseRegionalCharset n'existe pas, procédez comme suit pour la créer :

    1. Dans le menu Edition, cliquez sur Nouveau, puis sur Valeur DWORD.

    2. Entrez UseRegionalCharset comme nom de la valeur DWORD, puis appuyez sur Entrée.

  4. Si la valeur UseRegionalCharset existe, double-cliquez sur cette dernière pour la modifier.

  5. Dans la zone Données de la valeur, entrez 1, puis cliquez sur OK.

  6. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres de langue Outlook Web Access, voir le guide sur l'accès client à Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47568).


Charge des utilisateurs et opérations MAPI
Microsoft Exchange Server Analyzer - Articles > Protocoles >

Dernière rubrique modifiée : 2006-10-17

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que quelques opérations MAPI sur le serveur contribuent à un pourcentage considérable de la charge des utilisateurs du serveur. Pour en arriver à cette conclusion, il recherche les opérations qui consomment plus de 4 % du temps processeur par rapport au temps processeur consacré au traitement de toutes les demandes RPC.

Causes courantes des opérations MAPI à pourcentage de temps processeur élevé

Un administrateur qui recherche la cause de faibles performances d'Exchange Server doit vérifier si la taille moyenne des boîtes aux lettres est élevée sur les serveurs qui offrent de faibles performances. Il doit déterminer si des dossiers individuels sont excessivement volumineux (plus de 5 000 éléments dans les dossiers Boîte de réception, Éléments envoyés, Éléments supprimés ou Calendrier). Les dossiers volumineux et l'augmentation de taille des boîtes aux lettres peuvent provoquer une hausse de la charge d'E/S et du processeur. L'augmentation du nombre de vues pour chaque dossier peut également allonger le temps de traitement de nombreuses opérations MAPI.

Vues

De nombreuses opérations MAPI courantes qui nécessitent beaucoup de temps sont liées aux vues. Parmi les plus évidentes, citons Restrict et FindRow. Ces opérations ne nécessitent pas toujours beaucoup de temps et si leur exécution pose problème, vous devez comprendre pourquoi. Notez également qu'en plus des raisons suivantes, dès qu'il existe un goulot d'étranglement pour les ressources (généralement au niveau du disque ou du processeur), les latences des opérations augmentent.

Remarque :
Parfois, le coût de TaskQ User Known peut être élevé avec les opérations Restrict ou FindRow. En effet, une partie du travail pour ces opérations est effectué dans un TaskQ et le coût est attribué à TaskQ User Known.

Restrictions

L'opération MAPI Restrict permet de sélectionner des éléments correspondant à des critères particuliers. Le serveur crée une vue qui est effectivement une table avec des critères associés appelés restrictions. Si la vue qui a une restriction correspondante existe déjà, le serveur utilise la vue existante pour répondre à la demande de l'utilisateur. L'utilisation de cette vue engendre relativement peu de frais, contrairement à la création d'une nouvelle vue, qui est relativement chère. Par défaut, la banque d'informations ne met en cache que 11 vues pour chaque dossier. S'il est demandé au serveur de créer une onzième vue, celui-ci supprime la vue mise en cache la plus ancienne et crée une nouvelle vue. Les vues ajoutent du temps de traitement à toutes les actions effectuées sur les éléments qui correspondent aux restrictions des vues.

Findrow

Les applications clientes utilisent les opérations MAPI SeekRow ou FindRow pour déplacer le curseur entre les lignes d'une vue. L'opération SeekRow spécifie le nombre de lignes sur lesquelles déplacer le curseur et engendre très peu de frais en termes de temps processeur. L'opération FindRow est assez chère car elle déplace le curseur vers le premier élément d'une vue non matérialisée (non mise en cache) qui correspond aux critères de restriction, puis ignore la vue une fois que l'application cliente a terminé l'action. Le coût processeur final de l'opération FindRow dépend de la complexité de la restriction et du nombre de lignes que la banque d'informations doit passer en revue avant de trouver le premier élément qui correspond aux critères et est vaguement en corrélation avec le nombre d'éléments dans le dossier.

Le coût élevé pouvant se produire avec les opérations Restrict and FindRow en fait des candidats adéquats pour l'exécution du mode mis en cache, qui supprimerait le coût du serveur. Sachez que, parfois, le pourcentage de processeur élevé consommé par ces opérations peut simplement être provoqué par des calendriers partagés, auquel cas le mode mis en cache n'aiderait pas. Une consommation élevée du pourcentage de temps processeur par ces opérations peut indiquer un grand nombre de créations de vues, de vues chères ou d'éléments de dossiers volumineux.

Pour plus d'informations

Pour plus d'informations, voir les ressources Exchange Server suivantes :

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Performances d'Exchange Server 2003 : 10 choses à savoir (http://go.microsoft.com/fwlink/?LinkID=56460).


Stockage
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails relatifs aux éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool en termes de stockage. Ils décrivent, en outre, les actions que vous pouvez prendre pour corriger les erreurs liées au stockage, les avertissements et les configurations autres que celle par défaut détectés par Exchange Server Analyzer.


La clé Aging Clean Interval d'une banque de boîtes aux lettres n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'intervalle de suppression des index de base de données inutilisés a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

Si Exchange Server Analyzer détecte que la clé Aging Clean Interval est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

L'une des fonctions du moteur ESE (Extensible Storage Engine) consiste à créer de manière dynamique des index lorsque des informations sont retriées ou demandées dans un ordre de tri différent. De ce fait, la base de données de la banque Exchange pourrait contenir des milliers d'index sur une table. La banque Exchange gère cette situation en attribuant un délai d'expiration aux index. Les informations relatives à l'index sont ajoutées à une table interne, dite table de détermination de l'âge de l'index. Pendant la maintenance en ligne, la table de détermination de l'âge des index est analysée et le délai de suppression de chaque entrée est comparé à l'heure actuelle. Si l'index a expiré, il est supprimé. Par défaut, ce processus s'exécute toutes les 24 heures pendant le cycle de maintenance des banques Exchange et supprime les entrées qui remontent à plus de 8 jours pour Exchange Server 5.5 et à plus de 40 jours pour Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007. La clé Aging Clean Interval est l'intervalle en millisecondes pendant lequel la banque Exchange tente de supprimer les index inutilisés. La clé de Registre peut être utilisée pour modifier cette valeur par défaut pour exécuter cette fonction à un intervalle personnalisé.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Supprimez la clé Aging Clean Interval.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la clé Aging Clean Interval, consultez les articles suivants de la Base de connaissances :

  • 159197 sur le contrôle de la détermination de l'âge des index des dossiers (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076 sur l'accès aux dossiers de la banque d'informations, qui peut devenir lent dans Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


La clé Aging Clean Interval d'une banque de dossiers publics n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'intervalle de suppression des index de base de données inutilisés a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

Si Exchange Server Analyzer détecte que la clé Aging Clean Interval est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

L'une des fonctions du moteur ESE (Extensible Storage Engine) consiste à créer de manière dynamique des index lorsque des informations sont retriées ou demandées dans un ordre de tri différent. De ce fait, la base de données de la banque Exchange pourrait contenir des milliers d'index sur une table. La banque Exchange gère cette situation en attribuant un délai d'expiration aux index. Les informations relatives à l'index sont ajoutées à une table interne, dite table de détermination de l'âge de l'index. Pendant la maintenance en ligne, la table de détermination de l'âge des index est analysée et le délai de suppression de chaque entrée est comparé à l'heure actuelle. Si l'index a expiré, il est supprimé. Par défaut, ce processus s'exécute toutes les 24 heures pendant le cycle de maintenance des banques Exchange et supprime les entrées qui remontent à plus de 8 jours pour Exchange Server 5.5 et à plus de 40 jours pour Exchange 2000 Server et Exchange Server 2003. La clé Aging Clean Interval est l'intervalle en millisecondes pendant lequel la banque Exchange tente de supprimer les index. La clé de Registre peut être utilisée pour modifier cette valeur par défaut pour exécuter cette fonction à un intervalle personnalisé.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Supprimez la clé Aging Clean Interval.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la clé Aging Clean Interval, voir les articles suivants de la Base de connaissances :

  • 159197 sur le contrôle de la détermination de l'âge des index des dossiers (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197)

  • 216076 sur l'accès aux dossiers de la banque d'informations, qui peut devenir lent dans Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076)


Toutes les versions de Outlook sont autorisées à accéder au serveur
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si des versions de Microsoft Office Outlook® sont bloquées pour la connexion à Exchange Server :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la clé Disable MAPI Clients n'existe pas, un avertissement s'affiche.

La clé Désactiver les clients MAPI, non activée par défaut, permet à un administrateur d'empêcher des versions spécifiques d'Outlook de se connecter à un ordinateur exécutant Exchange 2000 Server, Exchange Server 2003 ou Exchange Server 2007.

Les versions et les Service Packs récents d'Outlook proposent de nombreuses améliorations en matière de sécurité et de lutte contre les virus. Dans Outlook 2002, le blocage des pièces jointes et l'option Object Model Guard sont disponibles et activés par défaut. Ces fonctionnalités sont des composants essentiels dans la lutte contre les virus. La version la plus ancienne d'Outlook prise en charge par les services de support technique Microsoft est Outlook 2000 Service Pack 3 (SP3). Si vous utilisez des versions plus récentes d'Outlook dans votre organisation, effectuez une mise à niveau vers Outlook 2003 ou, au minimum, mettez à jour le client Outlook avec les dernières versions de sécurité.

Une fois Outlook mis à jour, vous pouvez verrouiller l'accès à Exchange de versions précédentes d'Outlook qui n'ont pas été mises à jour. Le verrouillage de versions précédentes d'Outlook ne prenant pas en charge le blocage des pièces jointes et l'option Object Model Guard permet d'assurer un niveau connu de sécurité client pour les connexions MAPI client.

Pour se protéger contre toutes les versions précédentes d'Outlook (Outlook 97, Outlook 98, Outlook 2000 avant SP3, et les versions précédentes), il est fortement recommandé d'empêcher toutes les versions d'Outlook dont les numéros de version correspondent ou sont antérieurs à 5.3164.0.0 de se connecter à Exchange Server.

Le client lui-même dicte la chaîne de version du client. Cette chaîne est similaire au numéro de version indiqué dans la boîte dialogue À propos du client. Ne vous fiez toutefois à ce numéro de version. Utilisez plutôt le Gestionnaire système Exchange pour afficher la propriété Version du client dans la page Mailbox Store Logons (Ouvertures de session de la banque de boîtes aux lettres).

Important :
Avant d'effectuer toute modification, notez que les correctifs et les versions de Service Packs peuvent affecter la chaîne de version du client. Faites très attention lorsque vous limitez l'accès client car les composants Exchange côté serveur doivent également utiliser l'interface MAPI pour ouvrir une session. Certains composants signalent leur version du client comme le nom du composant, tel que SMTP ou OLEDB, alors que d'autres indiquent le numéro de version d'Exchange, par exemple 6.0.4712.0. Par conséquent, évitez de limiter les clients dont les numéros de version commencent par 6.<x.x>. Par exemple, pour empêcher totalement l'accès MAPI, spécifiez deux plages au lieu de « 0.0.0-65535.65535.65535 », pour que les composants de serveur puissent ouvrir une session, comme suit : 0.0.0-5.9.9; 7.0.0-65535.65535.65535.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Correction de cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Créez une nouvelle entrée Valeur de chaîne appelée Disable MAPI Clients.

  4. Double-cliquez sur l'entrée de Registre Disable MAPI Clients et définissez les données de valeur sur le niveau souhaité. La liste des valeurs de la chaîne Données de la valeur représente les différentes façons de désactiver les plages des versions MAPI client. Les versions (vX) sont généralement disponibles aux formats suivants :

    • Pour Microsoft Outlook 2003 et Outlook 2007 : Maj.Min.Build

    • Pour Microsoft Outlook 2000 : Maj.Build.Dot

    • Pour les versions précédentes de Microsoft Outlook : Maj.Min.Build

    Vous pouvez indiquez toutes les versions spécifiques ou des plages de versions à désactiver dans cette chaîne. Le Gestionnaire système Exchange permet de déterminer la version des clients MAPI qui se connectent à la banque de boîtes aux lettres pour Exchange Server 2003. Dans le Gestionnaire système Exchange, localisez le conteneur Ouvertures de session de la banque de boîtes aux lettres. La colonne Version du client affiche la version des clients MAPI connectés à la banque de boîtes aux lettres.

    Dans Exchange Server 2007, utilisez la cmdlet Get-LogonStatistics de l'environnement de ligne de commande Exchange Management Shell pour extraire la version des clients MAPI connectés à la base de données de boîtes aux lettres.
Important :
La version du client MAPI est répertoriée dans le Gestionnaire système Exchange et l'environnement de ligne de commande Exchange Management Shell au format X.0.Y.Z. Cette version doit être entrée au format X.Y.Z dans la valeur de Registre. Par exemple, si le Gestionnaire système Exchange répertorie la version du client MAPI comme 5.0.2819.0, entrez 5.2819.0 dans la valeur de Registre Disable MAPI Clients.
  1. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft, « Description du Registre de Microsoft Windows » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations sur le blocage de certains clients MAPI pour la connexion à un ordinateur Exchange 2000 Server ou Exchange Server 2003, consultez les articles suivants de la Base de connaissances Microsoft :

  • 328240 sur la procédure de définition des restrictions côté serveur pour les clients utilisés pour accéder aux boîtes aux lettres Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240)

  • 288894 sur la fonctionnalité permettant de désactiver l'accès au client MAPI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894)

Pour plus d'informations sur le téléchargement de mises à jour de sécurité pour les versions plus anciennes d'Outlook et le blocage d'autres versions d'Outlook, consultez l'article relatif au ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur la cmdlet Get-LogonStatistics, consultez la page Web la concernant (http://go.microsoft.com/fwlink/?LinkId=80699) dans la documentation du produit Exchange Server 2007.


AssertOnEvent défini
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le débogage a été activé sur la banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

Si Exchange Server Analyzer détecte qu'une valeur a été définie pour AssertOnEvent, un avertissement s'affiche.

La valeur de Registre AssertOnEvent contient des valeurs décimales spécifiant les événements de banque déclenchant le mode débogage de la banque d'informations de Microsoft Exchange. Le Registre AssertOnEvent ne fonctionne que lorsque la version de débogage de store.exe est exécutée. La banque d'informations de Microsoft Exchange utilise beaucoup de ressources lorsqu'elle est exécutée en mode débogage. Il ne s'agit pas de la méthode recommandée pour déboguer la banque dans un environnement de production.

Sauf en cas de résolution active d'un problème de la banque d'informations Exchange avec l'aide des services du Support Technique de Microsoft, vous devez supprimer la valeur de Registre AssertOnEvent.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer la clé de Registre AssertOnEvent

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, recherchez la valeur AssertOnEvent et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Au moins un message endommagé a été identifié
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le nombre d'entrées de la valeur PoisonIDs :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<Nom_serveur_Exchange> \Private- <GUID_banque_informations_privée>

Si Exchange Server Analyzer détermine que le nombre d'entrées de la valeur PoisonIDs est supérieur à 0, un avertissement s'affiche.

Les versions d'Exchange Server postérieure à Exchange Server 2003 Service Pack 1 introduisent un comportement qui contribue à éviter que des messages endommagés ou incorrects provoquent l'arrêt inopiné du service Banque d'informations Exchange ou la réussite de son démarrage.

Dans Exchange Server 2003 Service Pack 1 ou les versions ultérieures, les messages qui provoquent l'arrêt inattendu du service Banque d'informations Exchange pendant la conversion du format MAPI au format MIME sont suivis. L'ID du message endommagé est stocké dans le Registre lorsque l'incident se produit. Si un message endommagé provoque trois fois l'arrêt inopiné de la banque d'informations, ces informations sont exploitées pour éviter que le message soit à nouveau traité au quatrième redémarrage du service Banque d'informations Exchange.

Lorsque le service Banque d'informations Exchange s'arrête inopinément à cause d'un message endommagé, la valeur de Registre PoisonIDs est créée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<Nom_serveur_Exchange> \Private- <GUID_banque_informations_privée>

Un administrateur peut également créer l'entrée de Registre PoisonThreshold. La clé PoisonThreshold contrôle le nombre maximal de fois qu'un message est autorisé à passer par la banque d'informations Exchange avant d'être ajouté à la clé de Registre PoisonIDs. Cette valeur seuil est 2 par défaut. Pour déclencher le comportement, le seuil doit être dépassé. Le service Banque d'informations Exchange peut donc s'arrêter 3 fois à cause d'un message endommagé avant que celui-ci soit bloqué. Par exemple, si un message entraîne 3 incidents, il est bloqué parce que trois est supérieur à la valeur seuil 2.

Lorsqu'un événement de message endommagé est écrit dans le Registre, des messages d'événement d'erreur (ID d'événement 9680 et 9681) apparaissent dans le journal des événements Applications. Après le démarrage correct du service Banque d'informations Exchange, Exchange bloque le message et tente d'envoyer une notification d'échec de remise pour celui-ci. Dans certains cas, Exchange risque de ne pas parvenir à envoyer une notification d'échec de remise. Le message bloqué peut alors rester dans la file d'attente jusqu'à ce qu'il expire. La clé de Registre PoisonIDs peut contenir un maximum de dix valeurs ID de message. En cas de dépassement de la limite de dix, un nouvel événement de message endommagé est ajouté. L'événement de message endommagé le plus ancien est supprimé.

Correction de cet avertissement

  1. Si vous avez une banque de boîtes aux lettres présentant des problèmes en raison d'un message endommagé, vous devez examiner le problème plus en profondeur. Pour plus d'informations sur la manière dont Microsoft IT effectue une récupération à partir de bases de données Exchange endommagées, consultez la rubrique http://go.microsoft.com/fwlink/?LinkId=56372.

  2. Si vous rencontrez des problèmes d'arrêt d'Exchange Server 2003 à cause de messages endommagés, il peut s'avérer utile d'activer le rapport d'erreurs automatique sur l'ordinateur Exchange Server. Les données des rapports d'erreurs sont exploitées pour corriger les problèmes dans les logiciels que vous utilisez. Pour plus d'informations sur l'activation du rapport d'erreurs Exchange, consultez la rubrique sur la Le rapport d'erreurs Exchange est désactivé.

Pour plus d'informations sur Exchange Server 2003 Service Pack 1 (SP1), consultez la page des téléchargements d'Exchange 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=29090).


La valeur Background Cleanup d'une banque de boîtes aux lettres n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les données actuelles de la valeur de Registre Background Cleanup :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Si Exchange Server Analyzer détecte que les données de valeur de Background Cleanup sont définies sur une valeur différente de 60 000 (décimal) ou 0xEA60 (hexadécimal), un message indiquant une configuration autre que celle par défaut s'affiche. Il est recommandé de définir Background Cleanup sur la valeur par défaut.

Si la valeur Background Cleanup est trop élevée, le processus de nettoyage en arrière-plan risque de ne pas s'exécuter assez souvent et de nombreux problèmes peuvent survenir. Cela inclut les opérations suivantes :

  • Des échecs de déplacement de boîtes aux lettres et un événement 1205 avec le code d'erreur 0x4e3 peuvent survenir.

  • Les tailles des dossiers et les comptages d'éléments affichés dans le Gestionnaire système Exchange ou la console de gestion Exchange peuvent différer considérablement de ceux affichés dans Microsoft Outlook®. En outre, l'espace de base de données occupé par ces éléments risque de ne pas être récupéré.

  • Les confirmations de lecture négatives pour les éléments supprimés sans avoir été lus peuvent ne pas être générées dans certaines circonstances.

  • Le nettoyage des anciennes entrées de la table DeliveredTo ne sera pas effectué. La table DeliveredTo est utilisée par la banque Exchange pour empêcher la remise de messages en double.

Si la valeur Background Cleanup est trop faible, le processus de nettoyage en arrière-plan risque de provoquer une charge inutile sur le serveur.

Attention :
La procédure décrite ci-après dans cette rubrique, qui permet de rétablir la configuration par défaut d'une valeur trop élevée, peut provoquer une charge accrue sur le serveur jusqu'à la fin du nettoyage en arrière-plan pour tous les articles qui auraient normalement dû être nettoyés lors de l'intervalle par défaut. C'est pourquoi il est recommandé d'apporter ces changements à une heure où l'incidence sur les utilisateurs est minimale. Par ailleurs, si des messages, pour lesquels des confirmations de lecture ont été demandées, ont été supprimés sans avoir été lus et qu'ils n'ont pas été nettoyés à cause de ce problème, des confirmations de lecture négatives sont générées pour chacun de ces messages une fois l'avertissement corrigé.
Important :
Cet article contient des informations sur la procédure de modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Modifiez la valeur Background Cleanup en 60 000 (décimal) ou 0xEA60 (hexadécimal).

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


L'intervalle de nettoyage en arrière-plan pour une banque de boîtes aux lettres est manquant
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre Background Cleanup est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Si Exchange Server Analyzer détecte que la valeur Background Cleanup est manquante, un avertissement s'affiche.

Si la valeur Background Cleanup est manquante, le processus de nettoyage en arrière-plan ne s'exécute pas et de nombreux problèmes peuvent être rencontrés, notamment les suivants :

  • Des échecs de déplacement de boîtes aux lettres et un événement 1205 avec le code d'erreur 0x4e3 peuvent survenir.

  • Les tailles des boîtes aux lettres et les comptages d'éléments affichés dans le Gestionnaire système Exchange ou la console de gestion Exchange peuvent différer considérablement de ceux affichés dans Microsoft Outlook®. En outre, l'espace de base de données occupé par ces éléments risque de ne pas être récupéré.

  • Les confirmations de lecture négatives pour les éléments supprimés sans avoir été lus peuvent ne pas être générées dans certaines circonstances.

  • Le nettoyage de la table DeliveredTo ne sera pas effectué. La table DeliveredTo est utilisée par la banque Exchange pour empêcher la remise de messages en double. La valeur Track Duplicates contrôle la période pendant laquelle les entrées de la table DeliveredTo sont conservées. Si la valeur Background Cleanup est présente alors que la valeur Track Duplicates est manquante, les entrées de plus de 24 heures seront supprimées par le nettoyage en arrière-plan. La valeur suggérée pour Track Duplicates est 1 (décimale ou hexadécimale).

Il est recommandé de définir Background Cleanup sur sa valeur par défaut de 60 000 (décimale) ou 0xEA60 (hexadécimale).

Attention :
L'exécution de la procédure de suppression de l'avertissement décrite ci-dessous peut augmenter la charge de votre serveur jusqu'à la fin du nettoyage en arrière-plan de tous les éléments qui auraient été normalement nettoyés de manière régulière. C'est pourquoi il est recommandé d'effectuer ces changements à une heure où l'incidence sur les utilisateurs sera minimale. Par ailleurs, si des messages, pour lesquels des confirmations de lecture ont été demandées, ont été supprimés sans avoir été lus et qu'ils n'ont pas été nettoyés à cause de ce problème, des confirmations de lecture négatives seront générées pour chacun de ces messages une fois l'avertissement corrigé.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Correction de cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Créez une valeur DWORD nommée Background Cleanup avec la valeur 60000 (décimale) ou 0xEA60 (hexadécimale).

  4. Fermez l'Éditeur du Registre. Pour que les modifications soient prises en compte, effectuez l'une des opérations suivantes :

    • Démontez et remontez les banques d'informations affectées ou

    • Redémarrez le service Banque d'informations Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


L'intervalle de nettoyage en arrière-plan pour une banque de dossiers publics n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les données actuelles de la valeur de Registre Background Cleanup :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

Si Exchange Server Analyzer détecte que les données de valeur de Background Cleanup sont définies sur une valeur différente de 60 000 (décimal) ou 0xEA60 (hexadécimal), un message indiquant une configuration autre que celle par défaut s'affiche. Il est recommandé de définir Background Cleanup sur la valeur par défaut.

Si la valeur Background Cleanup est trop élevée, le processus de nettoyage en arrière-plan risque de ne pas s'exécuter assez souvent et de nombreux problèmes peuvent survenir, notamment :

  • Les tailles des dossiers et les comptages d'éléments affichés dans le Gestionnaire système Exchange peuvent différer considérablement de ceux affichés dans Microsoft Outlook®. En outre, l'espace de base de données occupé par ces éléments risque de ne pas être récupéré.

  • Les confirmations de lecture négatives pour les éléments supprimés sans avoir été lus peuvent ne pas être générées dans certaines circonstances.

  • Le nettoyage des anciennes entrées de la table DeliveredTo ne sera pas effectué. La table DeliveredTo est utilisée par la banque Exchange pour empêcher la remise de messages en double.

Si la valeur Background Cleanup est trop faible, le processus de nettoyage en arrière-plan risque de provoquer une charge inutile sur le serveur.

Attention :
La procédure suivante, qui permet de rétablir la configuration par défaut d'une valeur trop élevée, peut provoquer une charge accrue sur votre serveur jusqu'à la fin du nettoyage en arrière-plan pour tous les articles qui auraient en principe dû être nettoyés lors de l'intervalle par défaut. C'est pourquoi il est recommandé d'effectuer ces changements à une heure où l'incidence sur les utilisateurs sera minimale. Par ailleurs, si des messages, pour lesquels des confirmations de lecture ont été demandées, ont été supprimés sans avoir été lus et qu'ils n'ont pas été nettoyés à cause de ce problème, des confirmations de lecture négatives seront générées pour chacun de ces messages une fois l'avertissement corrigé.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>

  3. Modifiez la valeur Background Cleanup en 60 000 (décimal) ou 0xEA60 (hexadécimal).

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


L'intervalle de nettoyage en arrière-plan pour une banque de dossiers publics est manquant
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre Background Cleanup est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

Si Exchange Server Analyzer détecte que la valeur Background Cleanup est manquante, un avertissement s'affiche.

Si la valeur Background Cleanup est manquante, le processus de nettoyage en arrière-plan ne s'exécute pas et de nombreux problèmes peuvent être rencontrés, notamment les suivants :

  • Les tailles des dossiers et les comptages d'éléments affichés dans le Gestionnaire système Exchange ou la console de gestion Exchange peuvent différer considérablement de ceux affichés dans Microsoft Outlook®. En outre, l'espace de base de données occupé par ces éléments risque de ne pas être récupéré.

  • Les confirmations de lecture négatives pour les éléments supprimés sans avoir été lus peuvent ne pas être générées dans certaines circonstances.

  • Le nettoyage de la table DeliveredTo ne sera pas effectué. La table DeliveredTo est utilisée par la banque Exchange pour empêcher la remise de messages en double. La valeur Track Duplicates contrôle la période pendant laquelle les entrées de la table DeliveredTo sont conservées. Si la valeur Background Cleanup est présente alors que la valeur Track Duplicates est manquante, les entrées de plus de 24 heures seront supprimées par le nettoyage en arrière-plan. La valeur suggérée pour Track Duplicates est 1 (décimale ou hexadécimale).

Il est recommandé de définir Background Cleanup sur sa valeur par défaut de 60000 (décimale) ou 0xEA60 (hexadécimale).

Attention :
L'exécution de la procédure de suppression de l'avertissement décrite ci-dessous peut augmenter la charge de votre serveur jusqu'à la fin du nettoyage en arrière-plan de tous les éléments qui auraient été normalement nettoyés de manière régulière. C'est pourquoi il est recommandé d'effectuer ces changements à une heure où l'incidence sur les utilisateurs sera minimale. Par ailleurs, si des messages, pour lesquels des confirmations de lecture ont été demandées, ont été supprimés sans avoir été lus et qu'ils n'ont pas été nettoyés à cause de ce problème, des confirmations de lecture négatives seront générées pour chacun de ces messages une fois l'avertissement corrigé.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Correction de cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. Créez une valeur DWORD nommée Background Cleanup avec la valeur 60000 (décimale) ou 0xEA60 (hexadécimale).

  4. Fermez l'Éditeur du Registre. Pour que les modifications soient prises en compte, effectuez l'une des opérations suivantes :

    • Démontez et remontez les banques d'informations affectées ou

    • Redémarrez le service Banque d'informations Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La valeur BreakOnEvent est définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le débogage a été activé sur la banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

Si Exchange Server Analyzer détecte qu'une valeur a été définie pour la valeur de RegistreBreakOnEvent, il affiche un avertissement.

La valeur de Registre BreakOnEvent contient des valeurs décimales spécifiant les événements de banque déclenchant le mode débogage de la banque d'informations de Microsoft Exchange. La banque d'informations de Microsoft Exchange utilise beaucoup de ressources lorsqu'elle est exécutée en mode débogage. Il ne s'agit pas de la méthode recommandée pour déboguer la banque dans un environnement de production.

Sauf en cas de résolution active d'un problème de la banque d'informations Exchange avec l'aide des services du Support Technique de Microsoft, vous devez supprimer la valeur de Registre BreakOnEvent.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer la clé de Registre BreakOnEvent

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, recherchez la valeur BreakOnEvent et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Call tracing désactivé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si Call Trace logging est activé :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Si Exchange Server Analyzer détecte que la valeur de Registre de Disable Call Tracing est présente et configurée pour une utilisation avec une valeur de 1 et que l'ordinateur est Exchange Server 2003, il affiche un message indiquant une configuration autre que celle par défaut.

Lorsque Call Trace logging est activé, les données d'appel de fonction des processus Store.exe sont enregistrées. Par défaut, le suivi des appels est activé sur les ordinateurs Exchange Server 2003. Il convient de noter que cette fonction est désactivée par défaut sur Exchange 2000 Server. Toutefois, si vous exécutez Exchange Server 2003, vous devez activer le suivi des appels sauf indication contraire des services du Support Technique de Microsoft. Si le suivi des appels est activé, il collecte des informations importantes que vous pouvez utiliser pour la résolution de problèmes qui apparaissent lors du processus de stockage.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez l'Éditeur du Registre (Regedit.exe ou Regedt32.exe).

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Définissez la valeur de Registre Disable Call Tracing sur 0.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Call tracing activé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si Call Trace logging est activé :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Si Exchange Server Analyzer détecte que la valeur de Registre de Disable Call Tracing est présente et configurée à l'aide d'une valeur de 0, il affiche un message indiquant une configuration autre que celle par défaut.

Lorsque Call Trace logging est activé, les données d'appel de fonction des processus Store.exe sont enregistrées. Call Trace logging peut provoquer une réduction des performances allant jusqu'à 4 pour cent. Ne l'activez que lorsque vous en avez besoin pour résoudre des problèmes de lenteur ou d'absence de réponse des processus Store.exe.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Définissez la valeur de Registre Disable Call Tracing sur 1. Les clés Flush Call Traces , RPC Requests Threshold et Call Tracing Logging Interval ne sont pas utilisées lorsque Call Tracing est désactivé.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La profondeur du point de contrôle n'est pas définie correctement sur ce cluster
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamCheckpointDepthMax sur chaque groupe de stockage. Si Exchange Server Analyzer détecte que l'attribut msExchESEParamCheckpointDepthMax n'est pas égal à 5242880 sur un cluster Exchange 2000 Server, un avertissement s'affiche.

L'attribut msExchESEParamCheckpointDepthMax est défini en octets et régit la profondeur maximale du point de contrôle. La profondeur du point de contrôle est la quantité de données en attente d'assignation à la banque Exchange. La profondeur du point de contrôle maximale est la quantité maximale de données qui peuvent être en attente à tout moment. Si la profondeur du point de contrôle maximale est définie à 20 Mo, il s'agit donc de la quantité maximale de données qui peuvent être en attente (non assignées à la banque Exchange) à tout moment. Dans un environnement en clusters, une valeur inférieure pour ce paramètre provoque des temps de basculement plus rapides. Les tests dans Exchange Server 2003 ont démontré qu'une valeur de 5 Mo (5242880 octets) pour ce paramètre (au lieu de 20 Mo, la valeur par défaut dans Exchange 2000 Server) entraîne des temps de basculement beaucoup plus rapides sans affecter considérablement les performances d'E/S sur le serveur.

Dans les clusters Exchange 2000 Server, cette valeur devrait toujours être définie sur 5242880.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets du service d'annuaire Active Directory® lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour définir l'attribut msExchESEParamCheckpointDepthMax en utilisant ADSI Edit

  1. Exécutez Active Directory Service Interfaces (ADSI) Edit. ADSI Edit est fourni avec les outils de support de Microsoft Windows® 2000 Server et Microsoft Windows Server™ 2003 Server.

  2. Dans l'arborescence de la console, cliquez avec le bouton droit sur ADSIEdit, cliquez sur Connect to et connectez-vous à Configuration Naming Context.

  3. Développez le conteneur Configuration, CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=<Nom_organisation>, CN=Groupes_administration, CN=<Nom_groupe_administration>, CN=Serveurs, CN=<Nom_serveur>, CN=Banque_informations.

  4. Cliquez avec le bouton droit sur CN=<Nom_groupe_stockage>, puis sur Propriétés.

  5. Dans la liste des propriétés, sélectionnez msExchESEParamCheckpointDepthMax.

  6. Cliquez sur Edit et entrez la taille que vous souhaitez définir par incréments de 5 Mo. La valeur doit être entrée en octets. Par exemple, une profondeur de point de contrôle de 5 Mo correspond à 5242880 octets et une profondeur de 10 Mo à 10485760 octets. La taille minimale est de 5 Mo. Si vous entrez une valeur supérieure à 20 Mo, les temps de basculement des ressources du service de banque d'informations de Microsoft Exchange seront augmentés.

  7. Fermez ADSIEdit, puis redémarrez le service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur le déploiement de clusters Exchange 2000 Server, voir le document sur le déploiement de clusters Microsoft Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkID=14578).


Emplacement du fichier de point de contrôle
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le chemin d'accès du fichier de point de contrôle (msExchESEParamSystemPath) pour chaque groupe de stockage d'un serveur Exchange correspond à celui du journal des transactions (msExchESEParamLogFilePath) pour ce groupe. Si Exchange Server Analyzer détecte que le chemin d'accès du fichier de point de contrôle ne correspond pas à celui du journal des transactions pour le groupe de stockage, il affiche un message de recommandation.

Si l'emplacement du fichier de point de contrôle ne correspond pas à celui du journal des transactions, vous pouvez rencontrer des temps d'arrêt prolongés en cas de défaillance du disque.

Modification de l'emplacement du fichier de point de contrôle d'un groupe de stockage Exchange pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Ie Gestionnaire système Exchange, cliquez avec le bouton droit sur le groupe de stockage et cliquez sur Propriétés.

  2. Sous l'onglet Général de Emplacement du chemin d'accès système, cliquez sur Parcourir et sélectionnez un emplacement pour le fichier de point de contrôle.
Modification de l'emplacement des fichiers journaux de transactions d'un groupe de stockage Exchange pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Ie Gestionnaire système Exchange, cliquez avec le bouton droit sur le groupe de stockage et cliquez sur Propriétés.

  2. Sous l'onglet Général de Emplacement du journal des transactions, cliquez sur Parcourir et sélectionnez un emplacement pour les fichiers du journal des transactions.
Modification de l'emplacement des fichiers journaux de transactions d'un groupe de stockage Exchange pour Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de définition ou de modification de l'emplacement des fichiers journaux d'un groupe de stockage » (http://go.microsoft.com/fwlink/?LinkId=80702).

Pour plus d'informations sur l'emplacement des fichiers du journal des transactions, consultez la rubrique sur la gestion des banques de boîtes aux lettres et de dossiers publics dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

Pour plus d'informations sur le fichier de point de contrôle, consultez la section sur la relecture du fichier journal de transactions, la récupération logicielle et matérielle dans Exchange Server 2003 dans la rubrique sur l'utilisation de groupes de stockage de récupération Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (en anglais).


L'enregistrement circulaire est désactivé sur ce serveur frontal
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-03-27

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur configurée pour l'attribut msExchESEParamCircularLog de l'enregistrement circulaire. Si Exchange Server Analyzer détecte que la valeur configurée pour cet attribut est 0, un avertissement s'affiche.

Une valeur de 1 pour l'attribut msExchESEParamCircularLog indique que l'enregistrement circulaire est activé. Une valeur de 0 pour l'attribut msExchESEParamCircularLog indique que l'enregistrement circulaire est désactivé.

Dans l'enregistrement standard des transactions utilisé par Exchange Server, chaque transaction de base de données d'un groupe de stockage est inscrite dans un fichier journal, puis dans la base de données. Lorsqu'un fichier journal atteint une certaine taille, il est renommé et un nouveau fichier journal est créé. Au fil du temps, cela donne lieu à un ensemble de fichiers journaux. En cas d'incident, vous pouvez récupérer les transactions en relisant les données de ces fichiers journaux dans la base de données.

L'enregistrement circulaire écrase et réutilise le premier fichier journal une fois ses données inscrites dans la base de données. Dans Exchange Server, l'enregistrement circulaire est désactivé par défaut. Si vous l'activez, vous réduisez l'espace de stockage requis, mais sans fichiers journaux complets des transactions, vous ne pouvez récupérer aucune donnée ultérieure à la dernière sauvegarde complète. Dès lors, l'enregistrement circulaire est déconseillé sur les serveurs de production qui contiennent des données de boîtes aux lettres ou de dossiers publics. Par contre, sur les serveurs Exchange frontaux qui ne contiennent pas de boîtes aux lettres ni de dossiers publics, les seuls messages assignés sont des rapports de non-remise (NDR). Pour ces serveurs, il n'est donc pas nécessaire de conserver les fichiers de transactions ni d'effectuer des sauvegardes. L'activation de l'enregistrement circulaire sur les serveurs frontaux permet d'écraser les fichiers journaux des transactions pour qu'ils n'excèdent jamais les 20 Mo de données.

Pour activer l'enregistrement circulaire

  1. Dans le Gestionnaire système Exchange, développez Serveurs, puis développez un serveur Exchange.

  2. Cliquez avec le bouton droit sur le groupe de stockage pour lequel activer l'enregistrement circulaire, puis sélectionnez Propriétés. La boîte de dialogue des propriétés du groupe de stockage s'affiche.

  3. Sélectionnez la case à cocher Activer l'enregistrement circulaire dans le fichier journal, puis cliquez sur OK pour enregistrer les modifications.

  4. Quittez le Gestionnaire système Exchange et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'enregistrement circulaire, voir les articles suivants de la Base de connaissances Microsoft :

  • 258470 sur la procédure de modification du paramètre d'enregistrement circulaire (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524 sur l'influence de l'enregistrement circulaire sur l'utilisation des journaux des transactions (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788 sur les procédures de sauvegarde et de restauration en mode hors connexion pour Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605 sur la procédure d'activation/de désactivation de l'enregistrement circulaire dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


L'enregistrement circulaire est activé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamCircularLog de chaque groupe de stockage sur le serveur Exchange. La valeur 1 indique que l'enregistrement circulaire est activé pour le groupe de stockage. La valeur 2 indique que l'enregistrement circulaire n'est pas activé pour le groupe de stockage. Exchange Server Analyzer interroge Active Directory pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

L'outil Exchange Server Analyzer Tool interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Server dans l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur True indique que l'ordinateur Exchange Server est un serveur frontal. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal.

Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchESEParamCircularLog est définie sur 1, celle de la clé IsFrontEndServer sur False et celle de l'attribut homeMDBBL est supérieure à 20, un avertissement s'affiche.

Cette combinaison de valeurs indique que l'enregistrement circulaire est activé sur un serveur de boîtes aux lettres contenant plus de 20 boîtes aux lettres. Dans l'enregistrement standard des transactions utilisé par Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007, chaque transaction de base de données d'un groupe de stockage est inscrite dans un fichier journal, puis dans la base de données. Lorsqu'un fichier journal atteint une certaine taille, il est renommé et un nouveau fichier journal est créé. Au fil du temps, cela donne lieu à un ensemble de fichiers journaux. En cas d'incident, vous pouvez récupérer les transactions en relisant les données de ces fichiers journaux dans la base de données.

L'enregistrement circulaire écrase et réutilise le premier fichier journal une fois ses données inscrites dans la base de données. Dans Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007, l'enregistrement circulaire est désactivé par défaut. Si vous l'activez, vous réduisez l'espace de stockage requis, mais sans fichiers journaux complets des transactions, vous ne pouvez récupérer aucune donnée ultérieure à la dernière sauvegarde complète. L'enregistrement circulaire n'est dès lors pas recommandé dans un environnement de production normal.

Correction de cet avertissement dans Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis celui que vous souhaitez modifier.

  3. Cliquez avec le bouton droit sur le groupe de stockage que vous souhaitez modifier, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés, désactivez la case à cocher Activer l'enregistrement circulaire dans le fichier journal.

  5. Cliquez sur OK pour enregistrer le paramètre.

  6. Fermez le Gestionnaire système Exchange et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Correction de cet avertissement dans Exchange Server 2007 à l'aide de la console de gestion Exchange

  1. Ouvrez la console de gestion Exchange.

  2. Développez Configuration du serveur, puis développez le serveur que vous voulez modifier.

  3. Cliquez avec le bouton droit sur le groupe de stockage que vous voulez modifier, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés, activez la case à cocher Activer l'enregistrement circulaire.

  5. Cliquez sur OK pour enregistrer le paramètre.

  6. Fermez la console de gestion Exchange et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Correction de cet avertissement dans Exchange Server 2007 à l'aide de l'environnement de ligne de commande Exchange Management Shell

  1. Le code suivant est un exemple de la commande Set-StorageGroup qui désactive l'enregistrement circulaire pour le groupe de stockage « MyStorageGroup ».
Copier le code
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • Pour plus d'informations sur l'enregistrement circulaire, consultez les articles suivants de la Base de connaissances Microsoft :

  • 147524 sur l'influence de l'enregistrement circulaire sur l'utilisation des journaux des transactions (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 240145 sur la procédure de désignation des fichiers journaux des transactions pouvant être supprimés en toute sécurité (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145)


Enregistrement circulaire désactivé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-03-23

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur configurée de l'attribut msExchESEParamCircularLog.

Une valeur de 1 pour l'attribut msExchESEParamCircularLog indique que l'enregistrement circulaire est activé. Une valeur de 0 pour l'attribut msExchESEParamCircularLog indique que l'enregistrement circulaire est désactivé.

Exchange Analyzer détermine si les conditions suivantes sont présentes :

  • L'ordinateur Exchange Server est configuré en tant que serveur frontal.

  • Le service SMTP s'exécute et détermine combien de boîtes aux lettres sont configurées.

Si Exchange Analyzer détecte que toutes les conditions suivantes sont présentes, un avertissement s'affiche :

  • L'attribut msExchESEParamCircularLog est configuré avec la valeur 0.

  • Le serveur n'est pas configuré en tant que serveur frontal.

  • Moins de 20 boîtes aux lettres sont configurées.

Dans l'enregistrement standard des transactions utilisé par Exchange Server, chaque transaction de base de données d'un groupe de stockage est inscrite dans un fichier journal, puis dans la base de données. Lorsqu'un fichier journal atteint une certaine taille, il est renommé et un nouveau fichier journal est créé. Au fil du temps, cet enregistrement standard des transactions crée un ensemble de fichiers journaux. En cas d'échec du système, vous pouvez récupérer les transactions en relisant les données de ces fichiers journaux dans la base de données.

L'enregistrement circulaire écrase et réutilise le premier fichier journal une fois ses données inscrites dans la base de données. Dans Exchange Server, l'enregistrement circulaire est désactivé par défaut.

Important :
Si vous l'activez, vous réduisez l'espace de stockage requis. Toutefois, sans fichiers journaux complets des transactions, vous ne pouvez récupérer aucune donnée postérieure à la dernière sauvegarde complète. Dès lors, l'enregistrement circulaire est déconseillé sur les serveurs de production qui contiennent des données de boîtes aux lettres ou de dossiers publics.

Sur les serveurs Exchange frontaux, les serveurs de routage de messages (également appelés serveurs d'infrastructure) et les serveurs têtes de pont qui ne contiennent pas de boîtes aux lettres ni de dossiers publics, les seuls messages assignés sont des notifications de non-remise (NDR). Il n'est donc pas nécessaire de conserver les fichiers de transactions pour ces serveurs, ni d'effectuer des sauvegardes. Si vous activez l'enregistrement circulaire sur des serveurs n'hébergeant pas de boîtes aux lettres d'utilisateurs, vous pouvez écraser les fichiers des journaux des transactions pour que ceux-ci ne dépassent jamais 20 Mo de données.

Activation de l'enregistrement circulaire pour Exchange 2000 Server et Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis un serveur Exchange.

  3. Cliquez avec le bouton droit sur le groupe de stockage pour lequel activer l'enregistrement circulaire, puis sélectionnez Propriétés. La boîte de dialogue des propriétés du groupe de stockage s'affiche.

  4. Sélectionnez la case à cocher Activer l'enregistrement circulaire dans le fichier journal, puis cliquez sur OK pour enregistrer les modifications.

  5. Fermez le Gestionnaire système Exchange et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.
Activation de l'enregistrement circulaire pour Exchange Server 2007 à l'aide de la console de gestion Exchange

  1. Ouvrez la console de gestion Exchange.

  2. Développez Configuration du serveur, puis développez le serveur que vous voulez modifier.

  3. Cliquez avec le bouton droit sur le groupe de stockage que vous voulez modifier, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés, activez la case à cocher Activer l'enregistrement circulaire.

  5. Cliquez sur OK pour enregistrer le paramètre.

  6. Fermez la console de gestion Exchange et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.
Activation de l'enregistrement circulaire pour Exchange Server 2007 à l'aide de l'environnement de ligne de commande Exchange Management Shell

  1. Le code suivant est un exemple de la commande Set-StorageGroup qui active l'enregistrement circulaire pour le groupe de stockage MyStorageGroup.
Copier le code
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

Pour plus d'informations sur l'enregistrement circulaire, consultez les articles suivants de la Base de connaissances Microsoft :

  • 258470 sur la procédure de modification du paramètre d'enregistrement circulaire (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470)

  • 147524 sur l'influence de l'enregistrement circulaire sur l'utilisation des journaux des transactions (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524)

  • 296788 sur les procédures de sauvegarde et de restauration en mode hors connexion pour Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788)

  • 314605 sur la procédure d'activation/de désactivation de l'enregistrement circulaire dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605)


Compression RPC client/serveur désactivée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la compression RPC est activée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

Si Exchange Server Analyzer détecte que la valeur de Rpc Compression Minimum Size est présente et configurée sur 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, toutes les données RPC qui se déplacent entre Microsoft Office Outlook® 2003 ou Outlook 2007 et Exchange Server 2003 ou Exchange Server 2007 sont compressées, quelle que soit la taille. Dans certains scénarios, vous souhaitez peut-être contrôler la compression RPC. Par exemple, si vous essayez de résoudre des problèmes de connexion en affichant les paquets envoyés sur le réseau, la compression RPC peut rendre l'analyse difficile car vous affichez uniquement les données compressées dans le suivi.

Pour configurer les paramètres de compression RPC, vous pouvez ajouter trois valeurs de clé de Registre aux paramètres système :

  • Taille minimale de compression Rpc

  • Compression Rpc activée

  • Ensemble Rpc activé

La valeur de Registre Rpc Compression Enabled détermine si les algorithmes de compression RPC sont utilisés. Si la clé n'est pas présente, la compression RPC est activée et utilisée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la clé Rpc Compression Enabled. Si les clés Rpc Compression Minimum Size et Rpc Packing Enabled sont présentes, supprimez-les également.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le contrôle de la compression RPC, consultez l'article 825371 de la Base de connaissances sur la modification de la compression RPC dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


Le paramètre ClientMonitoringReportLevel n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer comment Exchange Server 2003 analyse les données des performances réseau pour Microsoft Office Outlook® 2003 :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la valeur de la clé de Registre ClientMonitoringReportLevel est différente de 1, il affiche un message indiquant une configuration autre que celle par défaut.

Exchange Server utilise la valeur de la clé de Registre ClientMonitoringReportLevel pour identifier les erreurs réseau et les problèmes de latence avec les clients Outlook 2003. La valeur de la clé de Registre ClientMonitoringReportLevel peut présenter trois valeurs différentes.

Valeur | Fonction
0 | Ne collecter aucune donnée de performances des clients Outlook 2003.
1 | Collecter les données de performances uniquement des clients Outlook 2003 dotés d'une connectivité réseau rapide.
2 | Collecter les données de performances de tous les clients Outlook 2003.

Lorsque vous activez la clé de Registre ClientMonitoringReportLevel avec une valeur de 1 ou 2, les clients Outlook 2003 envoient des données au serveur. Les données envoyées au serveur indiquent l'état de la connexion réseau. Elles incluent des informations sur les requêtes d'appel de procédure distante (RPC) échouées et les conditions d'erreur. Le serveur regroupe les informations et les expose dans des entrées du journal des événements.

Le programme d'installation d'Exchange ne crée pas la clé de Registre ClientMonitoringReportLevel. Toutefois, le comportement par défaut dans Exchange Server 2003 prévoit la collecte des données de performances uniquement des clients Outlook 2003 dotés d'une connectivité réseau rapide. Ce comportement par défaut d'Exchange Server 2003 est fonctionnellement identique à celui appliqué lorsque la valeur de la clé de Registre ClientMonitoringReportLevel est définie sur 1.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise. Vous pouvez toutefois modifier la valeur de la clé de Registre ClientMonitoringReportLevel si vous souhaitez rétablir la valeur par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Double-cliquez sur ClientMonitoringReportLevel.

  4. Dans le champ Données de la valeur, entrez 1 puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre.

Le service de banque d'informations de Microsoft Exchange détecte les modifications en quelques minutes. Il n'est pas nécessaire de redémarrer l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Prévision d'implémentation de quotas de stockage
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si les quotas de boîtes aux lettres ont été définis sur chaque objet private de base de données de messages (MDB). Si Exchange Server Analyzer détecte qu'une base de données de messages privée particulière contient plus de 200 boîtes aux lettres et que des quotas ne sont pas définis dans la base de données de messages, il affiche un message de configuration recommandée.

Il est recommandé d'appliquer des quotas à toutes les bases de données des ordinateurs Exchange Server qui hébergent des boîtes aux lettres d'utilisateurs. Vous devez définir trois limites au niveau de la base de données. Les limites sont définies sous l'onglet Limites de la page des propriétés de la banque de boîtes aux lettres. Chaque limite est exprimée en kilo-octets (Ko).

  • Avertissement La limite Issue warning définit la taille de boîte aux lettres qui déclenche l'envoi d'un courrier électronique à l'utilisateur. Ce courrier d'avertissement informe l'utilisateur que la taille de boîte aux lettres approche de la limite Prohibit send.

  • Interdire l'envoi La limite Prohibit send définit la taille de boîte aux lettres qui empêche un utilisateur d'envoyer des messages électroniques. L'utilisateur reçoit un message électronique du serveur Exchange expliquant que la taille limite de boîte aux lettres a été dépassée.

  • Interdire l'envoi et la réception La limite Prohibit send and receive définit la taille de boîte aux lettres qui empêche un utilisateur d'envoyer et de recevoir des messages électroniques. Tous les messages envoyés à l'utilisateur sont renvoyés à l'expéditeur avec une notification d'échec de remise.

Lorsque vous définissez ces règles, assurez-vous de fournir un écart suffisamment grand entre les limites d'interdiction d'envoi et d'interdiction d'envoi et de réception. Si l'écart entre les deux limites est trop petit, la boîte aux lettres risque de rejeter les messages avant que l'utilisateur n'ait l'occasion de nettoyer sa boîte. Par conséquent, il est recommandé de fournir un tampon d'au moins 20 % entre les limites d'interdiction d'envoi et d'interdiction d'envoi et de réception. Par exemple, si les utilisateurs ne peuvent pas envoyer de nouveaux messages lorsque leur boîte aux lettres atteint 100 Mo, la limite d'envoi et de réception doit être d'au moins 120 Mo.

Définition de limites de boîtes aux lettres dans Exchange 2000 Server et Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Recherchez la banque de boîtes aux lettres affichée dans Exchange Server Analyzer concernant ce problème.

  3. Cliquez avec le bouton droit sur Nom_banque_boîte_aux_lettres, puis sélectionnez Propriétés.

  4. Cliquez sur l'onglet Limites.

  5. Modifiez les limites Émettre un avertissement à (Ko), Interdire l'envoi à (Ko) et Interdire l'envoi et la réception à (Ko).

  6. Cliquez sur Appliquer, puis sur OK.
Définition de limites de boîte aux lettres pour Exchange Server 2007 à l'aide de la console de gestion Exchange

  1. Ouvrez la console de gestion Exchange.

  2. Recherchez la banque de boîtes aux lettres affichée dans Exchange Server Analyzer concernant ce problème.

  3. Cliquez avec le bouton droit sur Nom_banque_boîte_aux_lettres, puis sélectionnez Propriétés.

  4. Cliquez sur l'onglet Limites.

  5. Modifiez les limites Émettre un avertissement à (Ko), Interdire l'envoi à (Ko) et Interdire l'envoi et la réception à (Ko).

  6. Cliquez sur Appliquer, puis sur OK.
Définition de limites de boîte aux lettres pour Exchange Server 2007 à l'aide de l'environnement de ligne de commande Exchange Management Shell

  1. L'exemple suivant montre comment définir la taille de boîte aux lettres à partir de laquelle un message d'avertissement est envoyé à l'utilisateur. Cet attribut s'applique à toutes les boîtes aux lettres de la base de données de boîtes aux lettres n'ayant pas leur propre attribut de quota d'avertissement défini. Vous devez spécifier un nombre entier ou « unlimited ». La valeur par défaut est 1,9 gigaoctets (Go).

    Copier le code
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. L'exemple suivant montre comment définir la taille de boîte aux lettres à partir de laquelle les utilisateurs associés à des boîtes aux lettres dans cette base de données ne peuvent plus envoyer de messages. Cet attribut s'applique à toutes les boîtes aux lettres de la base de données de boîtes aux lettres qui n'ont pas leurs propres attributs de quota d'interdiction d'envoi définis. La valeur limite définie doit être soit un nombre entier, soit « illimitée ».

    Copier le code
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. L'exemple suivant montre comment définir la taille de boîte aux lettres à partir de laquelle l'utilisateur associé à la boîte aux lettres ne peut plus envoyer ou recevoir de messages. Cet attribut s'applique à toutes les boîtes aux lettres de la base de données de boîtes aux lettres qui n'ont pas leurs propres attributs de quota d'interdiction d'envoi et de réception définis. Vous devez spécifier un nombre entier ou « unlimited ».

    Copier le code
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Pour plus d'informations sur la gestion des boîtes aux lettres Exchange dans Exchange Server 2003, consultez la page Web Utilisation des banques d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur la gestion des limites de boîte aux lettres Exchange dans Exchange Server 2007, consultez la page Web « Procédure de configuration de limites et de propriétés de base de données » (http://go.microsoft.com/fwlink/?LinkId=80746)


L'indexation de contenu a été activée dans cette banque de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut Content Indexing Rebuild Schedule (msExchCIRebuildSchedule) a été défini sur une valeur non nulle et si l'attribut Content Indexing Rebuild Style (msExchCIRebuildStyle) a été défini. Il s'agit des attributs de chaque base de données de boîtes aux lettres privée. Si Exchange Server Analyzer détecte que ces deux attributs sont configurés pour une indexation, un avertissement s'affiche.

Il n'est pas recommandé d'exécuter l'indexation de contenu, également appelée « indexation de texte intégral » sur une banque de boîtes aux lettres, car l'indexation de texte intégral consomme beaucoup de ressources et les données de boîte aux lettres changent fréquemment. Par conséquent, le maintien d'un index actualisé pour une base de données spécifique est un processus très exigeant en termes de ressources. L'indexation de texte intégral est mieux adaptée aux dossiers publics.

Pour exécuter l'indexation de texte intégral sur une banque de boîtes aux lettres, il est recommandé de définir la planification d'indexation pour mettre à jour et contrôler les performances de l'ordinateur pour s'assurer que l'ordinateur n'est pas dépassé et reste capable de remettre le message et de répondre à des demandes client tout en indexant le contenu.

Sinon il est recommandé de désactiver l'indexation de texte intégral en supprimant l'index de texte intégral sur la banque de boîtes aux lettres.

Pour désactiver l'indexation de texte intégral sur une banque de boîtes aux lettres spécifique

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration, Serveurs, votre serveur, votre groupe de stockage, puis cliquez avec le bouton droit sur Banque de boîtes aux lettres et cliquez sur Supprime l'index de texte intégral.

Pour plus d'informations sur la configuration et le dépannage de l'indexation de texte intégral dans Exchange, voir l'article de la Base de connaissances Microsoft sur la procédure de configuration de l'indexation de texte intégral sur des banques de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932).


L'indexation de contenu a été activée dans cette banque de dossiers publics
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si les attributs Content Indexing Rebuild Schedule (msExchCIRebuildSchedule) et Content Indexing Rebuild Style (msExchCIRebuildStyle) sont présents et définis sur une valeur différente de 0. Il s'agit des attributs de chaque base de données de banque d'informations publique.

Si Exchange Server Analyzer détecte que la valeur de ces deux attributs est présente et définie sur une valeur autre que 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Lorsque ces deux attributs sont définis sur 1, cela indique que l'indexation de texte intégral a été activée pour la base de données de banque d'informations. L'indexation de texte intégral permet d'effectuer des recherches puissantes et rapides en indexant chaque mot dans une base de données spécifiée. Lorsque vous déployez l'indexation de texte intégral, vous sélectionnez une banque de boîtes aux lettres ou de dossiers publics individuelle à indexer. Les utilisateurs peuvent ensuite effectuer des recherches de texte intégral sur les messages et pièces jointes contenus dans la banque de dossiers publics ou de boîtes aux lettres.

Par défaut, l'index contient l'objet et le corps d'un message, le nom de l'expéditeur et du destinataire, ainsi que tout nom susceptible d'apparaître dans les champs Cc et Cci. L'index comprend également du texte des types suivants de pièces jointes : Fichiers .doc, .xls, .ppt, .html, .htm, .asp, .txt et .eml (messages MIME (Multipurpose Internet Mail Extensions) incorporés). Les pièces jointes binaires, telles que des images et des sons, ne sont pas indexées.

Les résultats de recherche sont aussi précis que lors de la dernière mise à jour de l'index. Étant donné que le contenu de la banque de dossiers publics ou de boîtes aux lettres change, l'index doit être mis à jour de manière à refléter le nouveau contenu. Les mises à jour de l'index peuvent être effectuées manuellement ou automatiquement via une planification.

Il existe quatre catégories principales de fichiers d'indexation de texte intégral. Vous pouvez optimiser les performances de l'indexation de texte intégral en organisant l'emplacement de disque de ces fichiers comme suit :

  • Catalogues Les catalogues sont les index principaux. À chaque banque Exchange peut correspondre un catalogue. Placez votre catalogue sur une baie RAID-0+1. Vous pouvez spécifier l'emplacement du catalogue dans le Gestionnaire système Exchange lors de sa création.

  • Banque de propriétés Il s'agit de la base de données contenant plusieurs propriétés des éléments indexés dans le catalogue. Chaque serveur ne dispose que d'une seule banque de propriétés. Placez la banque de propriétés de texte intégral sur la baie RAID. Par défaut, ces fichiers sont installés sur le même lecteur qu'Exchange Server.

  • Fichiers temporaires Ces fichiers contiennent des informations temporaires utilisées par le service Microsoft Search. Placez le répertoire temporaire d'index de texte intégral sur la baie RAID. Par défaut, ces fichiers sont installés sur le lecteur système, qui ne dispose généralement pas du débit d'E/S de la baie RAID.

  • Journaux du Rassembleur Ces fichiers contiennent des informations du journal pour le service d'indexation. Un ensemble de journaux existe pour chaque catalogue. Les journaux du Rassembleur peuvent rester à leur emplacement par défaut ou vous pouvez également les déplacer.

Pour activer ou désactiver l'indexation de texte intégral

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis développez un serveur Exchange, et enfin le groupe de stockage contenant la banque de dossiers publics utilisée.

  3. Cliquez avec le bouton droit sur la banque de dossiers publics et sélectionnez Propriétés.

  4. Sélectionnez l'onglet Indexation de texte intégral.

  5. Modifiez le champ Intervalle de mise à jour à votre convenance.

  6. Cliquez sur OK pour enregistrer les modifications et quitter les propriétés de la banque de dossiers publics.

Pour plus d'informations sur les dossiers publics d'indexation de texte intégral, voir l'article 319433 de la Base de connaissances Microsoft sur la procédure de configuration de l'indexation de texte intégral sur des dossiers publics (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433).

Pour plus d'informations sur la configuration et le dépannage de l'indexation de texte intégral sur les banques de boîtes aux lettres, voir les articles suivants de la Base de connaissances :

  • 822932 sur la procédure de configuration de l'indexation de texte intégral sur des banques de boîtes aux lettres dans Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932).

  • 319436 sur la procédure de configuration de l'indexation de texte intégral sur des banques de boîtes aux lettres dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436).

Pour plus d'informations sur l'indexation de texte intégral dans un environnement multilingue, voir l'article 325624 de la Base de connaissances sur l'indexation de texte intégral avec plusieurs langues (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624).

Pour plus d'informations sur l'utilisation optimale de l'indexation de texte intégral, voir l'article 326186 de la Base de connaissances sur le livre blanc relatif à l'utilisation optimale du déploiement de l'indexation de texte intégral (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186).


Des notifications d'état de remise sont actuellement restituées sous la forme de messages
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si des notifications d'état de remise sur l'ordinateur Exchange Server sont restituées sous la forme de messages standard :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

Si Exchange Server Analyzer détecte que l'entrée de Registre RenderDSNsAsMessages est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Comme son nom l'indique, l'entrée de Registre RenderDSNsAsMessages représente une opportunité de configuration qui permet aux administrateurs de contrôler le mode de restitution des notifications d'état de remise sur des ordinateurs Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007 :

  • Si les données de valeur de RenderDSNsAsMessages sont définies sur 0, les notifications d'état de remise (qui contiennent des notification de remise et d'échec de remise) sont restituées sous la forme de messages MAPI standard.

  • Si les données de valeur de RenderDSNsAsMessages sont définies sur une valeur supérieure à 0, les notifications d'état de remise sont restituées sous la forme de messages MIME multiples/mixtes.

Cette valeur de Registre n'est pas présente par défaut et doit être ajoutée manuellement pour être utilisée. En outre, pour que l'entrée ait l'effet approprié sur Exchange 2000 Server, l'ordinateur doit au moins utiliser le correctif Exchange 2000 Server post-Service Pack 3 septembre 2003.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Supprimez l'entrée de Registre RenderDSNsAsMessages.

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.
  • Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

  • Pour plus d'informations sur les problèmes de format de la notification d'état de remise, voir l'article 812806 de la Base de connaissances sur la réception inopinée par un utilisateur Exchange d'un rapport de non-remise standard au lieu d'un rapport de non-remise personnalisé (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812806).

  • Pour plus d'informations sur le correctif Exchange 2000 Server post-Service Pack 3, voir l'article 824282 de la Base de connaissances sur le correctif Exchange 2000 Server post-Service Pack 3 de septembre 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282).


L'intervalle par défaut Aging Keep Time de la base de données a été modifié
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur par défaut pour l'âge des index de la base de données de la vue du client Exchange a été remplacée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Private-<GUID de banque d'informations privée>\Aging Keep Time

Si Exchange Server Analyzer détecte que l'entrée de Registre Aging Keep Time est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Les index utilisés dans les vues créées par un client Exchange dans les tables de base de données Exchange qui n'ont pas été utilisées pendant un certain temps seront nettoyés. Les entrées de Registre suivantes sont utilisées pour contrôler l'âge des index :

  • Aging Keep Time Âge minimal requis pour supprimer l'index. La valeur par défaut est de 8 jours pour Exchange Server 5.5 et de 40 jours pour Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007.

  • Aging Clean Interval Intervalle minimal (en millisecondes) avant l'exécution d'une tâche de détermination de l'âge de l'index. La valeur par défaut est 24 heures.

  • Reset Views Si ce paramètre existe et est différent de zéro, tous les index mis en cache seront supprimés lors de la prochaine exécution d'une tâche de détermination de l'âge de l'index. Une fois l'âge des index déterminé, la valeur Reset Views est définie sur 0.

Il est recommandé de ne pas ajouter de valeur de Registre Aging Keep Time à moins d'y avoir été invité par les services de support technique Microsoft.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Affichage ou modification de la valeur de Registre Aging Keep Time

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Private-<GUID de banque d'informations privée>

  3. Examinez et, au besoin, modifiez la valeur Aging Keep Time.

  4. Fermez l'Éditeur du Registre. Si une modification est effectuée, redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Fichiers journaux et de base de données stockés sur le même volume de disque
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si les fichiers de base de données pour cette banque de boîtes aux lettres sont situés sur le même disque physique que les fichiers du journal des transactions de ce groupe de stockage. Plus spécifiquement, Exchange Server Analyzer interroge Active Directory pour effectuer les tâches suivantes :

  • Déterminer si la banque de boîtes aux lettres dispose de plus de 100 boîtes aux lettres en calculant les valeurs de l'attribut homeMDBBL de l'objet de banque de boîtes aux lettres (classe msExchPrivateMDB). Si la banque dispose de moins de 100 boîtes aux lettres, l'impact de l'emplacement du fichier sur les performances est limité.

  • Définir le chemin d'accès des fichiers de base de données pour la banque de boîtes aux lettres en fonction de la lecture de la valeur de msExchEDBFile de l'objet de banque de boîtes aux lettres.

  • Définir le chemin d'accès des fichiers du journal des transactions pour le groupe de stockage en fonction de la lecture de la valeur de msExchESEParamLogFilePath de l'objet de groupe de stockage (classe msExchStorageGroup).

  • Déterminer si le chemin d'accès de msExchESEParamLogFilePath est sur le même disque que celui de msExchEDBFile.

Exchange Server Analyzer permet également d'effectuer les tâches suivantes :

  • Déterminer si les extensions d'Exchange Server pour le NAS de Windows sont en cours d'exécution sur le serveur en interrogeant la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service de la valeur de l'attribut Started pour les extensions NAS d'Exchange Server (wssexchmap). Si les extensions d'Exchange Server pour le NAS de Windows sont en cours d'exécution, cela signifie que les fichiers concernés peuvent ne pas se trouver sur un lecteur local et les performances peuvent ne pas être prises en compte.

  • Déterminer si les fichiers se trouvent sur un volume de disque dont le nom est supérieur à trois caractères en interrogeant la classe WMI Win32_Volume. Cela signifie également que les fichiers peuvent ne pas se trouver sur un lecteur local et les performances peuvent ne pas être prises en compte.

Pour fournir une tolérance de pannes en cas de défaillance du disque dur, enregistrez les fichiers du journal des transactions Exchange et les fichiers de base de données sur des disques durs différents. Cette opération vous permettra d'augmenter de manière significative les performances d'E/S du disque dur.

Remarque :
Pour fournir une tolérance de pannes en cas de restauration d'une base de données, chaque groupe de stockage dispose de son propre ensemble de fichiers du journal des transactions. Les fichiers du journal des transactions conservent un enregistrement de chaque modification apportée à chaque base de données de ce groupe de stockage. Les fichiers du journal des transactions ne sont pas supprimés jusqu'à ce que toutes les bases de données du groupe de stockage soient complètement sauvegardées.

Les exemples suivants illustrent la façon de rétablir des données même dans ces circonstances extrêmes (telles que la perte d'un disque dur contenant vos fichiers de base de données ou vos fichiers du journal des transactions) si votre sauvegarde et vos fichiers du journal des transactions se trouvent sur un disque différent.

  • En cas de défaillance du disque contenant vos fichiers de base de données, vous pouvez remplacer le disque dur défaillant, rétablir la dernière sauvegarde de ces fichiers et utiliser les fichiers journaux actuels stockés sur un autre disque dur pour rétablir les données sur votre serveur Exchange et le mettre à jour au moment où le disque dur a échoué.

  • En cas de défaillance du disque dur contenant vos fichiers du journal des transactions, si le disque dur contenant vos fichiers de base de données fonctionne et si le fichier de banque de bases de données est fermé normalement, vous pouvez rétablir le disque du journal des transactions et remontez la banque de bases de données. Si le fichier de banque de bases de données n'est pas fermé normalement, il reste dans un état incohérent et ne peut être monté qu'après une réparation matérielle avec le fichier eseutil.exe, ce qui peut entraîner une perte de données. L'autre option consiste à rétablir le fichier de banque de bases de données à partir de la sauvegarde, qui ne comprend pas les nouvelles données de boîtes aux lettres créées après la sauvegarde.

Important :
Si vous conservez les fichiers de base de données et du journal des transactions Exchange sur le même disque dur physique et si ce disque dur connaît une défaillance, vous risquez de perdre les données créées après la dernière sauvegarde.

En outre, l'enregistrement des fichiers de base de données et des fichiers du journal des transactions sur des disques différents augmente les performances générales. Exchange écrit d'abord chaque transaction dans le journal des transactions, puis dans le fichier de base de données. Les fichiers du journal des transactions sont également partagés par toutes les banques de boîtes aux lettres dans le groupe de stockage. Lorsque ces fichiers sont sur le même disque physique, la tête de lecture doit avancer et reculer entre l'emplacement du fichier du journal des transactions actuels et les emplacements des fichiers de base de données pour effectuer les opérations d'écriture. Lorsque les fichiers se trouvent sur des disques séparés, une tête de lecture reste en position pour écrire dans le fichier du journal des transactions. Les transactions peuvent donc être effectuées plus rapidement que lorsque les fichiers sont sur le même disque. La différence de performances pour une seule transaction est petite, mais elle devient perceptible lorsque la charge du système est élevée.

Pour corriger votre configuration, vous pouvez déplacer les fichiers du journal des transactions ou les fichiers de base de données.

Déplacement de fichiers journaux des transactions vers un nouveau lecteur dans Exchange 2000 Server ou Exchange Server 2003

  1. Dans le Gestionnaire système Exchange, développez l'objet serveur Exchange approprié, cliquez avec le bouton droit sur le groupe de stockage souhaité et cliquez sur Propriétés.

  2. Sous l'onglet Général, spécifiez un nouvel emplacement pour les fichiers.

    Par exemple, si le lecteur E:\ ne doit contenir que les fichiers journaux pour ce groupe de stockage, dans Emplacement du journal des transactions, cliquez sur Parcourir et sélectionnez le lecteur E:\.

Modification de l'emplacement des fichiers journaux de transactions d'un groupe de stockage Exchange pour Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de définition ou de modification de l'emplacement des fichiers journaux d'un groupe de stockage » (http://go.microsoft.com/fwlink/?LinkId=80702).

Déplacement de fichiers de base de données vers un nouveau lecteur dans Exchange 2000 Server ou Exchange Server 2003

  1. Dans le Gestionnaire système Exchange, développez l'objet serveur Exchange sur lequel la banque réside, développez le conteneur de groupe de stockage approprié, cliquez avec le bouton droit sur l'objet de banque de boîtes aux lettres désiré, puis cliquez sur Propriétés.

  2. Spécifiez les nouveaux emplacements de fichiers sous l'onglet Base de données de la boîte de dialogue Propriétés.
Attention :
Pour déplacer un fichier de base de données, la base de données doit temporairement être démontée puis remontée. L'Assistant effectue cela automatiquement, mais la base de données est inaccessible aux utilisateurs lors du processus.

Déplacement de fichiers de base de données vers un nouveau lecteur dans Exchange Server 2007 à l'aide de l'Assistant Déplacer le chemin d'accès de la base de données

  1. Démarrez la console de gestion Exchange sur le serveur qui contient le groupe de stockage.

  2. Dans l'arborescence de la console, développez Configuration du serveur, puis cliquez sur Boîte aux lettres.

  3. Dans le volet Résultats, développez le conteneur de groupe de stockage approprié, cliquez avec le bouton droit sur l'objet base de données de boîtes aux lettres de votre choix, puis cliquez sur Déplacer le chemin d'accès de la base de données. L'Assistant Déplacer le chemin d'accès de la base de données s'affiche.

  4. Dans la page Introduction, la zone Chemin d'accès des fichiers de base de données affiche l'emplacement dans lequel sont actuellement stockés vos fichiers de base de données. Cliquez sur Parcourir pour spécifier un emplacement vers lequel déplacer ces fichiers.

  5. Cliquez sur Déplacer.

  6. Dans la page Achèvement, vérifiez si le chemin de fichier de base de données a été modifié avec succès. L'état Achevé indique que l'Assistant a achevé la tâche avec succès. L'état Échec indique que la tâche n'a pas été achevée avec succès. En cas d'échec de la tâche, consultez le résumé pour obtenir une explication, puis cliquez sur Précédent pour modifier la configuration. Cliquez sur Terminer pour fermer l'Assistant Déplacer le chemin d'accès de la base de données.
Remarque :
L'environnement de ligne de commande Exchange Management Shell permet également de déplacer des fichiers de bases de données dans Exchange Server 2007. Pour plus d'informations, consultez la rubrique Move- DatabasePath.

Pour plus d'informations sur les fichiers de base de données Exchange Server, consultez les rubriques suivantes :

  • sur la gestion des banques de boîtes aux lettres et des banques de dossiers publics dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617)

  • sur la présentation de la banque d'informations Exchange dans la rubrique sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur la gestion des fichiers de base de données Exchange Server, consultez l'article 328794 de la Base de connaissances Microsoft sur la procédure de protection des données Exchange contre une défaillance du disque dur (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794).

Pour plus d'informations sur la réparation matérielle des banques de bases de données Exchange, consultez l'article 296788 de la Base de connaissances sur les procédures de sauvegarde et de restauration en mode hors connexion pour Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788).

Pour plus d'informations sur la réalisation d'une réparation matérielle sur un fichier de banque de bases de données Exchange, consultez l'article 810190 de la Base de connaissances sur le message d'erreur « La banque d'informations s'est arrêtée anormalement » et l'ID d'événement 447 enregistré (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810190).


Tous les fichiers journaux sont présents dans la base de données
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que tous les fichiers journaux nécessaires à la récupération de cette base de données existent et se trouvent au bon emplacement pour la récupération. Par conséquent, l'échec de la récupération n'est pas provoqué par un fichier journal des transactions manquant ou non concordant.

Il est possible que les bases de données ou les fichiers journaux des transactions soient endommagés ou que d'autres fichiers interfèrent avec le processus de récupération.

Pour corriger cette erreur

  • Le Gestionnaire système Exchange permet de monter l'une des bases de données du groupe de stockage, puis de consulter dans le journal Applications les erreurs susceptibles d'indiquer la cause de l'échec.

  • Récupérez la base de données isolée. Une fois la base de données analysée, Exchange Server Analyzer affiche les instructions pour la récupération de la base de données isolée.

  • Exécutez Eseutil.exe /ML pour vérifier l'intégrité des fichiers journaux requis. Pour plus d'informations sur l'utilisation d'Eseutil, voir l'article 248122 de la Base de connaissances Microsoft sur l'utilisation d'Eseutil pour vérifier si les fichiers journaux des transactions sont endommagés dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=248122).


Base de données dans un état de fermeture sain
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre base de données Exchange est dans un état de fermeture sain.

Une base de données dans un état de fermeture sain a été arrêtée correctement et détachée du flux de fichiers journaux. Donc, pour remonter la base de données, vous pouvez effectuer toute opération de récupération.

Si vous ne pouvez pas monter une base de données qui se trouve dans un état de fermeture sain, ce n'est pas parce que cette base de données nécessite une relecture supplémentaire du fichier journal des transactions. Toutefois, il est possible que la relecture du journal des transactions nécessaire à d'autres bases de données du même groupe de stockage puisse empêcher le montage d'une base de données dans un état de fermeture sain. Avant de pouvoir monter une base de données d'un groupe de stockage Exchange, toutes les bases de données de ce groupe de stockage doivent être récupérées et mises dans un état montable.

Une base de données dans un état de fermeture sain peut être montée avec ses journaux de transactions précédents ou avec un nouvel ensemble de journaux de transactions. Si vous montez une base de données dans un état de fermeture sain et si aucun journal des transactions n'existe, un nouvel ensemble de journaux de transactions sera généré.

Remarque :
En règle générale, vous ne devez pas supprimer de fichiers journaux de transactions, même si toutes les bases de données d'un groupe de stockage se trouvent dans un état de fermeture sain. Si vous supprimez des fichiers journaux de transactions, vous ne pourrez pas effectuer de récupération à partir de sauvegardes précédentes. Toutefois, la suppression de fichiers journaux de transactions lorsque toutes les bases de données d'un groupe de stockage se trouvent dans un état de fermeture sain n'affecte pas les bases de données actuelles. Il est recommandé, en cas de suppression de tous les fichiers journaux de transactions d'un groupe de stockage, de créer immédiatement une copie de sauvegarde de toutes les bases de données du groupe de stockage.


Base de données dans un état d'arrêt intempestif et aucun journal requis
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-08-10

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre base de données est dans un état d'arrêt intempestif.

Par définition, une base de données dans un état d'arrêt intempestif nécessite la relecture d'au moins un fichier journal des transactions. L'arrêt intempestif n'est pas un état montable pour la base de données et ne doit pas survenir pendant des opérations générales.

Pour corriger cette erreur

  • Pour une analyse avancée de la base de données et des fichiers journaux, contactez le Centre d'Aide et de Support de Microsoft (http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845).


La base de données est dans un état inconnu
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a détecté que votre base de données est dans un état inconnu. Généralement, vos bases de données sont dans un état de fermeture sain ou d'arrêt brutal. (Dans Exchange 2000 Server et antérieur, ces états sont appelés respectivement Cohérent ou Incohérent.)

Pour corriger cette erreur

  • Pour une analyse avancée de l'état de la base de données, contactez le Centre d'Aide et de Support de Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845).


Des fichiers journaux facultatifs et obligatoires sont manquants de la base de données
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que des fichiers journaux nécessaires pour récupérer cette base de données ne se trouvent pas dans le dossier de fichiers journaux. Tant qu'un fichier journal nécessaire est manquant, il est impossible de récupérer une base de données.

Si une base de données Exchange n'a pas été fermée correctement, il est toujours nécessaire de relire des fichiers journaux dans la base de données avant de pouvoir la remonter. Il est nécessaire de relire au moins un fichier journal. Toutefois, en règle générale, plusieurs fichiers journaux doivent être relus.

En plus des fichiers journaux nécessaires, des fichiers journaux supplémentaires peuvent être lus dans la base de données. Bien qu'il ne soit pas nécessaire de relire ces fichiers journaux facultatifs avant le montage de la base de données, vous pouvez les utiliser pour récupérer des données supplémentaires. Si vous ne les relisez pas, toutes les données qu'ils contenaient seront perdues.

Pour corriger cette erreur

  • Recherchez les fichiers journaux de transactions manquants et ajoutez-les au dossier approprié.

  • Si vous ne trouvez pas tous les fichiers journaux facultatifs, vous pouvez récupérer la base de données isolée uniquement à l'aide des fichiers journaux nécessaires. Pour récupérer la base de données sans les fichiers journaux facultatifs, suivez les instructions d'Exchange Server Analyzer. Rappelez-vous que si vous récupérez la base de données sans les fichiers journaux facultatifs, vous perdrez toutes les données qu'ils contiennent.

    Toutefois, en fonction du fichier journal manquant, il se peut que vous puissiez relire certains fichiers journaux facultatifs dans la base de données. Considérez, par exemple, le scénario suivant. Vous disposez de fichiers journaux numérotés de un à dix. Le dixième fichier journal est obligatoire (les autres sont facultatifs) et le sixième est manquant. Dans ce cas, vous pouvez relire les fichiers journaux numérotés de sept à dix car l'ordre séquentiel jusqu'au fichier obligatoire est constant.

  • Réparez la base de données actuelle.

    Remarque :
    La réparation de la base de données va probablement être réussie, mais cela n'est pas garanti. Même une réparation réussie peut engendrer une perte majeure ou mineure de données. Pour plus d'informations sur la réparation d'une base de données Exchange, voir l'article 812357 de la Base de connaissances Microsoft sur la procédure de conservation de votre base de données Exchange après une réparation à l'aide de l'outil Eseutil /p dans Exchange Server 5.5, Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).

  • Mettez en œuvre une stratégie hybride qui comprend la réparation et la restauration de la base de données. Dans certains cas, vous pouvez restaurer une base de données même si elle ne peut plus être reprise avec d'autres fichiers journaux. Dans ce cas, vous pouvez restaurer une copie précédente de la base de données et réparer simultanément la copie actuelle qui ne peut pas être montée. Vous pouvez ensuite fusionner les contenus des bases de données pour maximiser la récupération des données. Il s'agit d'une stratégie avancée et vous pouvez contacter le Centre d'Aide et de Support de Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845) avant sa mise en œuvre. Pour plus d'informations sur cette stratégie, voir la rubrique sur l'utilisation de groupes de stockage de récupération dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Des fichiers journaux facultatifs mais pas de fichiers journaux obligatoires sont manquants de la base de données
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que l'une de vos bases de données n'a pas été fermée correctement.

Si une base de données Exchange n'a pas été fermée correctement, il est toujours nécessaire de relire des fichiers journaux dans la base de données avant de pouvoir la remonter. Il est nécessaire de relire au moins un fichier journal. Toutefois, en règle générale, plusieurs fichiers journaux doivent être relus.

En plus des fichiers journaux nécessaires, des fichiers journaux supplémentaires peuvent être lus dans la base de données. Bien qu'il ne soit pas nécessaire de relire ces fichiers journaux facultatifs avant le montage de la base de données, vous pouvez les utiliser pour récupérer des données supplémentaires. Si vous ne les relisez pas, toutes les données qu'ils contenaient seront perdues.

Pour corriger cette erreur

  • Recherchez les fichiers journaux facultatifs manquants et ajoutez-les au dossier de journaux de transactions.

  • Si vous ne trouvez pas tous les fichiers journaux facultatifs, vous pouvez récupérer la base de données isolée uniquement à l'aide des fichiers journaux nécessaires. Pour récupérer la base de données sans les fichiers journaux facultatifs, suivez les instructions d'Exchange Server Analyzer. Rappelez-vous que si vous récupérez la base de données sans les fichiers journaux facultatifs, vous perdrez toutes les données qu'ils contiennent.

    Toutefois, en fonction du fichier journal manquant, il se peut que vous puissiez relire certains fichiers journaux facultatifs dans la base de données. Considérez, par exemple, le scénario suivant. Vous disposez de fichiers journaux numérotés de un à dix. Le dixième fichier journal est obligatoire (les autres sont facultatifs) et le sixième est manquant. Dans ce cas, vous pouvez relire les fichiers journaux numérotés de sept à dix car l'ordre séquentiel jusqu'au fichier obligatoire est constant.


Des fichiers journaux obligatoires sont manquants de la base de données
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que des fichiers journaux nécessaires pour la récupération de cette base de données ne se trouvent pas dans le dossier de fichiers journaux. Tant qu'un fichier journal nécessaire est manquant, il est impossible de récupérer une base de données.

Pour corriger cette erreur

  • Recherchez les fichiers journaux de transactions manquants et ajoutez-les au dossier approprié.

  • Restaurez la base de données à partir de la sauvegarde. Reprenez ensuite la base de données en lisant les fichiers journaux des transactions restants dans la base de données.

    Important :
    Les données du fichier journal manquant et des fichiers journaux suivants seront perdues. Avant de restaurer une base de données à partir d'une sauvegarde, enregistrez une copie de la base de données actuelle. Si la restauration échoue, vous pourrez peut-être réparer la base de données actuelle.

  • Réparez la base de données actuelle.

    Remarque :
    La réparation de la base de données va probablement être réussie, mais cela n'est pas garanti. Même une réparation réussie peut engendrer une perte majeure ou mineure de données. Pour plus d'informations sur la procédure de réparation d'une base de données Exchange, voir l'article 812357 de la Base de connaissances Microsoft sur la procédure de conservation de votre base de données Exchange après une réparation à l'aide de l'outil Eseutil /p dans Exchange Server 5.5, Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).

  • Mettez en œuvre une stratégie hybride qui comprend la réparation et la restauration de la base de données. Dans certains cas, vous pouvez restaurer une base de données même si elle ne peut plus être reprise avec d'autres fichiers journaux. Dans ce cas, vous pouvez restaurer une copie précédente de la base de données et réparer simultanément la copie actuelle qui ne peut pas être montée. Vous pouvez ensuite fusionner les contenus des bases de données pour maximiser la récupération des données. Il s'agit d'une stratégie avancée et vous pouvez contacter le Centre d'Aide et de Support de Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845) avant sa mise en œuvre. Pour plus d'informations sur cette stratégie, voir la rubrique sur l'utilisation de groupes de stockage de récupération dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589).


Les bases de données de ce groupe de stockage sont définies pour réinitialiser les pages pendant la sauvegarde
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamZeroDatabaseDuringBackup de chaque groupe de stockage sur le serveur. Si Exchange Server Analyzer détecte que l'attribut msExchESEParamZeroDatabaseDuringBackup est défini sur 1, il affiche un message indiquant une configuration autre que celle par défaut.

L'attribut msExchESEParamZeroDatabaseDuringBackup représente un paramètre de configuration qui permet de réinitialiser des enregistrements supprimés/valeurs longues pendant la sauvegarde. Ce processus est qualifié de réinitialisation. Vous pouvez contrôler la réinitialisation des pages des bases de données au niveau du groupe de stockage. Chaque groupe de stockage peut disposer d'une stratégie différente de réinitialisation des pages des bases de données supprimées.

La réinitialisation est désactivée par défaut et la valeur de l'attribut msExchESEParamZeroDatabaseDuringBackup est définie sur 0. Lorsque l'attribut est défini sur 1, les pages des bases de données supprimées sont remplacées par d'autres caractères à la fin des sauvegardes en ligne des bases de données de ce groupe de stockage.

La réinitialisation d'Exchange 2000 Server et d'Exchange Server 2003 peut être activée et désactivée à l'aide du Gestionnaire système Exchange, comme décrit dans cet article. L'activation et la désactivation de la réinitialisation d'Exchange Server 2007 peuvent être effectuées à l'aide de l'environnement de ligne de commande Exchange Management Shell, comme décrit dans cet article. Alors que cette option offre la meilleure sécurité, elle affecte toutefois les performances du serveur.

Remarque Si vous activez la réinitialisation sur un ordinateur Exchange 2000 Server, il est recommandé d'installer Exchange 2000 Server Service Pack 3 ou une version ultérieure. Le Service Pack 3 corrige un problème connu qui peut causer l'arrêt des réponses de la part de la banque d'informations Exchange. Pour plus d'informations sur ce problème, consultez l'article 320883 de la Base de connaissances Microsoft sur la banque d'informations qui cesse de répondre pendant une sauvegarde en ligne si la réinitialisation des bases de données est activée (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883).

Activation ou désactivation de la réinitialisation d'Exchange 2000 Server et d'Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis celui que vous souhaitez modifier.

  3. Cliquez avec le bouton droit sur le groupe de stockage que vous souhaitez modifier, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés, activez ou désactivez au besoin la case à cocher Réinitialiser les pages des bases de données supprimées. La sélection de la case à cocher active la réinitialisation et sa désélection la désactive.

  5. Cliquez sur OK pour enregistrer le paramètre.

  6. Fermez le Gestionnaire système Exchange et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Activation ou désactivation de la réinitialisation de pages supprimées pour Exchange Server 2007

  1. Le code suivant est un exemple de la commande Set-StorageGroup qui active ou désactive la réinitialisation des bases de données dans le groupe de stockage « MyStorageGroup ».
Copier le code
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

Pour plus d'informations sur l'effet sur les performances du remplacement des pages des bases de données supprimées, consultez l'article 815068 de la Base de connaissances sur la diminution dans le temps des performances de sauvegarde en ligne (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068).


La valeur Debug Break At Startup est définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le débogage a été activé sur la banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

Si Exchange Server Analyzer détecte qu'une valeur a été définie pour Debug Break At Startup, un avertissement s'affiche.

La valeur de Registre Debug Break At Startup active le mode débogage au prochain démarrage du service de banque d'informations de Microsoft Exchange. La banque d'informations de Microsoft Exchange utilise beaucoup de ressources lorsqu'elle est exécutée en mode débogage. Il ne s'agit pas de la méthode recommandée pour déboguer la banque dans un environnement de production.

Sauf si vous êtes en train de résoudre activement un problème de la banque avec l'aide des services du Support Technique de Microsoft (PSS), supprimez la valeur de Registre Debug Break At Startup.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer la clé de Registre Debug Break At Startup

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, recherchez la valeur Debug Break At Startup et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Les tampons du journal ESE par défaut ont été modifiés
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool recherche dans le service d'annuaire Active Directory® la valeur de l'attribut msExchESEParamLogBuffers de chaque groupe de stockage sur l'ordinateur Exchange Server. Si Exchange Server Analyzer détecte que la valeur msExchESEParamLogBuffers est égale à 512, un message indiquant une configuration autre que celle par défaut s'affiche.

L'attribut de groupe de stockage msExchESEParamLogBuffers régit le nombre de tampons du journal ESE (Extensible Storage Engine) utilisés par la banque d'informations Exchange. ESE utilise un ensemble de tampons de journal pour conserver les informations en mémoire vive avant de les écrire dans les journaux de transactions. L'utilisation de ces tampons améliore les performances d'enregistrement des transactions. Pour les gros serveurs, la valeur par défaut de 84 est trop faible. Elle peut provoquer des opérations d'E/S disque excessives sur le lecteur du journal des transactions et donc une altération considérable des performances si le serveur est chargé ou si les utilisateurs envoient des messages volumineux. L'augmentation du nombre de tampons du journal ESE améliore les performances, mais suscite également davantage de mémoire virtuelle.

Les informations suivantes permettent de définir correctement cette valeur :

  • Pour Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), définissez cette valeur sur 9 000.

  • Pour Exchange 2000 Server Service Pack 3 (SP3), définissez cette valeur sur 512.

  • Pour Exchange Server 2003, une valeur par défaut de 500 est utilisée et vous devez modifier la valeur de l'attribut msExchESEParamLogBuffers sur 9000.

Remarque :
Si vous avez précédemment réglé les tampons de journal sur 9 000, assurez-vous de réduire ce paramètre manuellement après l'application d'Exchange 2000 Server SP3. Cette modification n'est pas apportée automatiquement lorsque vous installez Exchange 2000 Server SP3.

Les blocages de journal peuvent être provoqués par un tampon trop faible et vous pouvez augmenter cette valeur jusqu'à 9 000. L'analyse du compteur de performance Base de données\Enregistrements journal inachevés/s permet de déterminer si des blocages de journal se produisent. N'utilisez pas de valeur supérieure à 9 000 car cela peut endommager les fichiers des journaux de transactions.

Remarque :
Enregistrements journal inachevés/s représente le nombre d'enregistrements de journal qui ne peuvent pas être ajoutés aux tampons de journal par seconde car ils sont pleins. Si ce compteur est différent de zéro la plupart du temps, la taille du tampon de journal peut être un goulot d'étranglement.

Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour rétablir la configuration par défaut

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Développez CN=<Nom_serveur>, CN=Banque_informations, cliquez avec le bouton droit sur CN=<Nom_groupe_stockage>, puis cliquez sur Propriétés.

  5. Dans l'Éditeur d'attribut, cliquez sur l'attribut msExchESEParamLogBuffers, puis sur Modifier.

  6. Dans la boîte de dialogue Modifier l'attribut, définissez la valeur sur 512 pour Exchange 2000 Server ou sur 9000 pour Exchange Server 2003.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Fermez ADSI Edit, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur les tampons du journal ESE, voir l'article 328466 de la Base de connaissances Microsoft sur les tampons du journal ESE définis sur une valeur trop faible pouvant entraîner l'arrêt des réponses de la part de la banque (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server.


Banque de dossiers publics par défaut distante
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchHomePublicMDB de chaque banque de boîtes aux lettres contient le serveur Exchange local. Par défaut, la banque de dossiers publics d'une banque de boîtes aux lettres se situe sur le serveur Exchange local. Si l'attribut msExchHomePublicMDB ne contient pas le serveur Exchange local, la banque de boîtes aux lettres possède une banque de dossiers publics distante par défaut. Si Exchange Server Analyzer détecte que la banque de boîtes aux lettres possède une banque de dossiers publics distante par défaut, il affiche un message de configuration autre que celle par défaut.

Modification de la banque de dossiers publics par défaut

  1. Dans le Gestionnaire système Exchange, développez Serveurs, <votre serveur Exchange>, <groupe de stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres et sélectionnez Propriétés.

  2. Sous l'onglet Général, sous Banque d'informations publique par défaut, cliquez sur Parcourir pour sélectionner une banque de dossiers publics.

Pour plus d'informations sur les banques de boîtes aux lettres et de dossiers publics, consultez la rubrique sur la gestion des banques de boîtes aux lettres et de dossiers publics dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


La période de suppression de thread d'une banque de boîtes aux lettres n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'intervalle de suppression des éléments supprimés a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

Si Exchange Server Analyzer détecte que la clé Deletion Thread Period est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Si vous supprimez un message, Exchange le marque pour le supprimer. Exchange le marque également comme caché jusqu'à ce qu'il soit supprimé de manière permanente de la banque d'Exchange. Si la banque d'Exchange reçoit une demande de suppression d'un message dans un dossier particulier auquel fait référence l'ID message, celle-ci détermine si le message doit subir une suppression logicielle ou matérielle. Le message est supprimé définitivement à la fin de sa période de rétention des éléments supprimés. La suppression logicielle est également appelée suppression logique, et la suppression matérielle, suppression physique.

Par défaut, un processus de nettoyage des messages supprimés s'exécute toutes les 24 heures et détermine s'il faut procéder à une suppression matérielle d'un élément. Ce processus fait partie du processus de maintenance en ligne de la banque d'Exchange. Si la période de rétention des éléments supprimés a expiré, l'élément subira une suppression matérielle. La valeur de Registre Deletion Thread Period permet de remplacer l'intervalle par défaut de 24 heures et de spécifier un intervalle personnalisé pour le processus de nettoyage des messages supprimés.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Supprimez la clé Deletion Thread Period.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la rétention et la récupération d'éléments supprimés, consultez les articles suivants de la Base de connaissances :

  • 249680 sur la compréhension du processus de rétention des éléments supprimés et de suppression des messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=249680)

  • 287544 sur la croissance importante de la banque d'informations publique lorsque la fonctionnalité de rétention des éléments supprimés est activée (http://go.microsoft.com/fwlink/?linkid=3052&kbid=287544)

  • 822938 sur l'utilisation de stratégies système pour configurer des limites de stockage de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)


La période de suppression de thread d'une banque de dossiers publics n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'intervalle de suppression des éléments supprimés a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

Si Exchange Server Analyzer détecte que la clé Deletion Thread Period est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Si vous supprimez un message, Exchange le marque pour le supprimer. Exchange le marque également comme caché jusqu'à ce qu'il soit supprimé de manière permanente de la banque d'Exchange. Si la banque d'informations reçoit une demande de suppression d'un message dans un dossier particulier auquel fait référence l'ID message, la banque d'Exchange détermine si le message doit subir une suppression logicielle ou matérielle. La suppression logicielle est également appelée suppression logique, et la suppression matérielle, suppression physique. Le message est supprimé définitivement à la fin de sa période de rétention des éléments supprimés.

Par défaut, un processus de nettoyage des messages supprimés s'exécute toutes les 24 heures et détermine s'il convient de les supprimer du matériel. Ce processus fait partie du processus de maintenance en ligne de la banque d'Exchange. Si la période de rétention des éléments supprimés a expiré, l'élément subira une suppression matérielle. La valeur de Registre Deletion Thread Period permet de remplacer l'intervalle par défaut de 24 heures et de spécifier un intervalle personnalisé pour le processus de nettoyage des messages supprimés.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Supprimez la clé Deletion Thread Period.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la rétention et la récupération d'éléments supprimés, voir les articles suivants de la Base de connaissances :

  • 249680 sur la compréhension du processus de rétention des éléments supprimés et de suppression des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680)

  • 287544 sur la croissance importante de la banque d'informations publique lorsque la fonctionnalité de rétention des éléments supprimés est activée (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544)

  • 319098 sur l'utilisation de stratégies système pour configurer des limites de stockage de dossiers publics dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098)


Goulot d'étranglement de disque détecté
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-11-14

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre système disque fonctionne actuellement avec 20 pour cent du débit disponible maximal prévu. Cette constatation est effectuée par l'un des calculs suivants :

  • Mesure des latences de disque. Les compteurs de performance indiquant une latence sont Disque logique\Disque moyen s/Lecture et Disque logique\Disque moyen s/Écriture.

  • Comparaison du nombre maximal d'E/S disque possibles par seconde (Ops ES) de votre configuration de disque actuelle et du nombre de piles par rapport à la valeur actuelle d'opérations d'entrées/de sorties enregistrée par l'analyseur de performances (Perfmon).

Latences acceptables

Selon le type de données auquel l'utilisateur tente d'accéder, le serveur Exchange tolère les retards de différentes manières. Pour cette raison, le seuil maximal de latence moyenne acceptable dépend du type de ressources situées sur le disque. Dans tous les cas, sauf ceux indiqués dans la liste suivante, la valeur acceptable maximale pour les latences de lecture ou d'écriture est de 50 millisecondes (ms).

  • Lecteurs de journaux des transactions Le lecteur qui héberge le journal des transactions doit offrir des latences d'écriture moyennes inférieures à 10 ms. Les pointes de latence d'écriture doivent être inférieures à 50 ms. Les écritures dans les journaux de transactions sont synchrones. Donc, avant qu'un thread du processus Store.exe puisse effectuer une autre tâche, il doit attendre la fin de l'écriture. De faibles valeurs de latence d'écriture pour les journaux de transactions sont importantes pour les performances du serveur. La latence de lecture moyenne sur les lecteurs de journaux de transactions doit être inférieure à 20 ms. Les pointes de latence de lecture doivent être inférieures à 50 ms. Le nombre de blocages d'enregistrement de journal de base données par seconde doit être inférieur à 10. Le nombre de threads de journal de base de données en attente doit être inférieur à 10.

    En règle générale, les serveurs Exchange ne lisent pas à partir de journaux de transactions. Par conséquent, les latences de lecture sur ce lecteur n'ont pas d'importance. Toutefois, comme les latences d'écriture pour les journaux de transactions sont si importantes pour les performances d'Exchange, il est recommandé de ne pas utiliser sur les grands serveurs de lecteurs qui hébergent des journaux de transactions à d'autres fins. Dans ce cas, le taux de lectures (mesuré par le compteur Disque logique\Lectures disque/s) doit être minimal par rapport à celui d'écritures (Disque logique\Écritures disque/s). Exchange Server Analyzer détecte si le taux de lectures par rapport aux écritures sur le lecteur du journal des transactions est supérieur à 0,10 (plus d'une lecture pour dix écritures).

    En cas de dépassement de ce nombre, vous devez identifier l'application qui lit à partir du lecteur du journal des transactions et l'en empêcher.

  • Lecteurs de bases de données La latence acceptable pour les lecteurs qui contiennent des fichiers de bases de données Exchange (fichiers *edb et *stm) respecte les conditions suivantes (des valeurs supérieures indiquent un goulot d'étranglement de disque) :

    • La valeur maximale de Disque logique\Disque moyen s/Lecture sur un lecteur de base de données doit être inférieure à 50 ms (0,050 secondes).

    • La valeur moyenne de Disque logique\Disque moyen s/Lecture sur un lecteur de base de données doit être inférieure à 20 ms (0,020 secondes).

  • Lecteurs TEMP et TMP La latence pour les lecteurs qui contiennent les répertoires TEMP et TMP doit être inférieure à 10 ms pour les écritures et les lectures. La valeur maximale pour la latence de lecture ou d'écriture doit être inférieure à 50 ms.

  • Lecteur système et de page La latence pour les lecteurs qui contiennent les fichiers d'échange et les fichiers système Windows doit être inférieure à 10 ms pour les écritures et les lectures.

  • Lecteur SMTP La latence pour les lecteurs qui contiennent les fichiers de serveur SMTP doit être inférieure à 10 ms pour les écritures et les lectures.

Causes de la latence

L'une des causes les plus courantes de latence de disque est que l'accès aux disques s'effectue à un taux supérieur à celui que le sous-système de disque peut prendre en charge. Dans ce cas, le disque est dit représenter un goulot d'étranglement. Cela signifie également que le sous-système de disque se situe à ou sous sa capacité de débit.

Si le taux d'Ops ES disque (Disque logique\Transferts disque/s) est proche de ou supérieur à celui de la capacité estimée, le disque est dit « sous sa capacité de débit » ou « sous sa capacité ». Dans ces cas, pour améliorer les performances du serveur, vous devez réduire la charge sur le sous-système de disque (déplacer des utilisateurs vers un autre serveur) ou augmenter la capacité du lecteur (en ajoutant davantage de piles ou des piles plus rapides).

Dans les cas où votre matériel ne fonctionne pas comme prévu, vous pouvez constater des latences, même si le taux d'E/S est considérablement inférieur à la capacité estimée.

Réduction de la latence de disque

Pour réduire la charge sur le sous-système de disque, vous pouvez réduire certaines des tâches effectuées par le serveur. En particulier, vous devez supprimer les applications facultatives qui contribuent à la charge du disque. Le processus Store.exe est la seule application qui doit accéder aux lecteurs de bases de données et des journaux de transactions.

Selon votre configuration système de disque actuelle, vous pouvez effectuer plusieurs actions pour réduire l'effet de ce problème.

Pour réduire la latence de disque

  • Si un lecteur de base de données ou de journal des transactions constitue un goulot d'étranglement, vous pouvez réduire la charge sur ce lecteur en déplaçant des utilisateurs vers une base de données ou un groupe de stockage hébergé sur un lecteur qui n'approche pas la capacité maximale. Si tous les lecteurs de bases de données ou de journaux des transactions approchent de leur capacité maximale, déplacez des utilisateurs vers un autre serveur. Pour plus d'informations, voir la rubrique sur le Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

  • Parfois, la durée d'un taux d'E/S élevé est brève car elle résulte d'une opération MAPI chère. Dans ce cas, pour identifier l'utilisateur ou l'action qui cause les taux d'E/S élevés, vous pouvez utiliser ExMon, l'outil de surveillance des utilisateurs d'Exchange Server, conjointement avec les compteurs de performance des disques logiques. Si vous parvenez à isoler l'utilisateur, vous pourrez peut-être identifier l'application cliente qui génère l'excès de charge. Vous pouvez télécharger ExMon à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?LinkId=54983).

  • Si vous utilisez une baie de disques RAID-5, il se peut que vous souhaitiez passer à une baie de disques RAID-10 pour améliorer les Ops ES disponibles prises en charge du sous-système de disque.

  • Pour améliorer les Ops ES disponibles prises en charge, envisagez d'ajouter d'autres disques à votre système de disque.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les meilleures pratiques de conception d'architectures de stockage, voir la rubrique sur les meilleures pratiques communes à diverses architectures (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Pour plus d'informations sur le déplacement de boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique sur le Déplacement de boîtes aux lettres utilisateur vers un autre serveur.

  • Pour plus d'informations sur les taux d'E/S, la latence et le dimensionnement de disques, voir les billets suivants sur le site Web des billets de l'équipe Microsoft Exchange :

    • Billet sur les quelques concepts de base du dimensionnement de disques (en anglais) (http://go.microsoft.com/fwlink/?linkid=39538)

    • Billet sur des réflexions concernant les calculs et E/S disque (en anglais) (http://go.microsoft.com/fwlink/?linkid=39539)

    • Rubrique sur la procédure de calcul des besoins en E/S disque(http://go.microsoft.com/fwlink/?linkid=69747)


Goulot d'étranglement de disque détecté sur le disque contenant les fichiers journaux de transactions
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que le système de disque qui contient les fichiers journaux d'Exchange Server est saturé et cause un goulot d'étranglement des performances. Cette constatation est effectuée grâce à la vérification d'un ou plusieurs compteurs de performance parmi les suivants :

  • La valeur moyenne de Base de données\Enregistrements journal inachevés/s est supérieure 10.

  • La valeur maximale de Base de données\Enregistrements journal inachevés/s est supérieure à 100.

  • La valeur moyenne de Base de données\Threads de journal en attente est supérieure à 10.

  • La valeur maximale de Base de données\Threads de journal en attente est supérieure à 20.

Si un de ces seuils est dépassé, une erreur s'affiche, indiquant que votre lecteur de journal représente un goulot d'étranglement de disque. Les fichiers journaux nécessitent une latence d'écriture faible. Les sauvegardes ou blocages d'écritures d'un fichier journal peuvent entraîner des problèmes de performances du serveur. Les blocages de journal peuvent être dus à un paramètre du tampon de journal faible, à msExchESEParamLogBuffers ou à un nombre trop élevé de connexions au serveur.

Pour réduire la latence du disque de journal

  • Vous pouvez augmenter le paramètre de tampons ESE, msExchESEParamLogBuffers, à 9 000. N'utilisez pas une valeur supérieure à 9 000 car les fichiers journaux de transactions peuvent être endommagés. Pour plus d'informations, voir la rubrique Les tampons du journal ESE par défaut ont été modifiés.

  • Si un lecteur de base de données ou de journal des transactions constitue un goulot d'étranglement, vous pouvez réduire la charge sur ce lecteur en déplaçant des utilisateurs vers une base de données ou un groupe de stockage hébergé sur un lecteur qui n'approche pas la capacité maximale. Si tous les lecteurs de bases de données ou de journaux des transactions approchent de leur capacité maximale, déplacez des utilisateurs vers un autre serveur. Pour plus d'informations, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


La valeur EnableChangeNotification n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si la notification de changement de fichier du système ExIFS (Exchange Installable File System) Exchange a été activée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

Si Exchange Server Analyzer détecte que la clé EnableChangeNotification est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, la notification de changement de fichier est désactivée pour le système ExIFS Exchange. Lorsque le système ExIFS envoie des notifications de changement pour un fichier ou un répertoire, il ne supprime pas la version en cache du fichier ou du répertoire. Par conséquent, lorsqu'une application telle qu'Exchange Server ou Microsoft SharePoint® Portal Server reçoit une notification de changement et recharge le fichier ou le répertoire, elle obtient la version en cache et non le fichier ou répertoire récemment modifié.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Supprimez la clé EnableChangeNotification.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le système ExIFS, voir la documentation suivante :

  • le chapitre 26 sur l'architecture d'Exchange 2000 du kit de ressources Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=51224)

  • le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47891)


Erreur lors de l'accès au répertoire du journal
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que le chemin d'accès défini pour les journaux de transactions de ce groupe de stockage sur le serveur Exchange est inaccessible.

Pour corriger cette erreur

  • Vérifiez que le chemin d'accès existe sur le serveur.

  • Vérifiez que vous disposez des autorisations nécessaires pour lire des fichiers stockés dans le chemin d'accès du journal des transactions.


Erreur lors de l'accès au fichier de base de données de transmission en continu
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que le fichier de base de données de transmission en continu Exchange (.stm) est inaccessible.

Chaque base de données dans Exchange 2000 Server et Exchange Server 2003 comprend deux fichiers : le fichier de base de données Exchange .edb et le fichier de base de données de transmission en continu .stm. Il est nécessaire d'accéder à ces fichiers et de les traiter en même temps.

Pour corriger cette erreur :

  • Recherchez le chemin d'accès au fichier .stm. Dans le Gestionnaire système Exchange, ce chemin d'accès est défini dans la page des propriétés de la base de données pour chaque objet de base de données.

  • Vérifiez que le fichier .stm existe pour cette base de données.

  • Vérifiez que vous disposez des autorisations permettant d'accéder au dossier dans lequel se situe le fichier .stm.

  • Vérifiez que le fichier n'a pas été verrouillé en mode exclusif par un autre processus. Pour ce faire, essayez de renommer le fichier. Si vous y parvenez, cela indique que le fichier n'est pas verrouillé en mode exclusif. (N'oubliez pas de réaffecter au fichier son nom d'origine.)


Erreur lors de la vérification des fichiers journaux
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool n'a pas pus lire les fichiers journaux des transactions.

Pour corriger cette erreur

  • Vérifiez que vous disposez des autorisations nécessaires pour accéder au dossier des fichiers journaux de transactions.

  • Vérifiez que le fichier n'a pas été verrouillé en mode exclusif par un autre processus. Pour ce faire, essayez de renommer le fichier. Si vous y parvenez, cela indique que le fichier n'est pas verrouillé en mode exclusif. (N'oubliez pas de réaffecter au fichier son nom d'origine.)


Les tampons du journal ESE sont au maximum dans ce groupe de stockage
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamLogBuffers de chaque groupe de stockage. Si Exchange Server Analyzer détecte que la valeur msExchESEParamLogBuffers est égale à 9 000, un message indiquant une configuration autre que celle par défaut s'affiche.

ESE (Extensible Storage Engine) utilise un ensemble de tampons de journal pour conserver les informations en mémoire vive avant de les écrire dans les journaux de transactions. L'utilisation de ces tampons améliore les performances d'enregistrement des transactions. Pour les gros serveurs, la valeur par défaut de 84 est trop faible. Elle peut provoquer des opérations d'E/S disque excessives sur le lecteur du journal des transactions et donc une altération considérable des performances si le serveur est chargé ou si les utilisateurs envoient des messages volumineux. L'augmentation du nombre de tampons du journal ESE améliore les performances, mais suscite également davantage de mémoire virtuelle.

Les informations suivantes permettent de définir correctement cette valeur :

  • Pour Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), définissez cette valeur sur 9 000.

  • Pour Exchange 2000 Server Service Pack 3 (SP3), définissez cette valeur sur 512.

  • Pour Exchange Server 2003, une valeur par défaut de 500 est utilisée et vous devez modifier la valeur de l'attribut msExchESEParamLogBuffers sur 9000.

Remarque :
Si vous avez précédemment réglé les tampons de journal sur 9 000, assurez-vous de réduire ce paramètre manuellement après l'application d'Exchange 2000 Server SP3. Cette modification n'est pas apportée automatiquement lorsque vous installez Exchange 2000 Server SP3.

Les blocages de journal peuvent être provoqués par un tampon trop faible et vous pouvez augmenter cette valeur jusqu'à 9 000. L'analyse du compteur de performance Base de données\Enregistrements journal inachevés/s permet de déterminer si des blocages de journal se produisent. N'utilisez pas de valeur supérieure à 9 000 car cela peut endommager les fichiers des journaux de transactions.

Remarque :
Enregistrements journal inachevés/s représente le nombre d'enregistrements de journal qui ne peuvent pas être ajoutés aux tampons de journal par seconde car ils sont pleins. Si ce compteur est différent de zéro la plupart du temps, la taille du tampon de journal peut être un goulot d'étranglement.

Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour rétablir la configuration par défaut

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Développez CN=<Nom_serveur>, CN=Banque_informations, cliquez avec le bouton droit sur CN=<Nom_groupe_stockage>, puis cliquez sur Propriétés.

  5. Dans l'Éditeur d'attribut, cliquez sur l'attribut msExchESEParamLogBuffers, puis sur Modifier.

  6. Dans la boîte de dialogue Modifier l'attribut, définissez la valeur sur 512 pour Exchange 2000 Server ou sur 9000 pour Exchange Server 2003.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Fermez ADSI Edit, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur la définition des tampons du journal ESE, voir l'article 328466 de la Base de connaissances Microsoft sur les tampons du journal ESE définis sur une valeur trop faible pouvant entraîner l'arrêt des réponses de la part de la banque (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466).


Les tampons du journal ESE sont définis sur une valeur trop faible sur ce groupe de stockage
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur msExchESEParamLogBuffers de chaque objet du groupe de stockage (classe msExchStorageGroup) dans le conteneur InformationStore. Si Exchange Server Analyzer détecte que la valeur de cet attribut est inférieure à 500, un avertissement s'affiche.

ESE (Extensible Storage Engine) utilise un ensemble de tampons de journal pour conserver les informations en mémoire vive avant de les écrire dans les journaux de transactions. L'utilisation de ces tampons améliore les performances d'enregistrement des transactions. Pour les gros serveurs, la valeur par défaut de 84 est trop faible. Elle peut provoquer des opérations d'E/S disque excessives sur le lecteur du journal des transactions et donc une altération considérable des performances si le serveur est chargé ou si les utilisateurs envoient des messages volumineux. L'augmentation du nombre de tampons du journal ESE améliore les performances, mais suscite également davantage de mémoire virtuelle.

Les informations suivantes permettent de définir correctement cette valeur :

  • Pour Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), définissez cette valeur sur 9 000.

  • Pour Exchange 2000 Server Service Pack 3 (SP3), définissez cette valeur sur 512.

  • Pour Exchange Server 2003, une valeur par défaut de 500 est utilisée et vous devez modifier la valeur de l'attribut msExchESEParamLogBuffers sur 9000.

Remarque :
Si vous avez précédemment réglé les tampons de journal sur 9 000, assurez-vous de réduire ce paramètre manuellement après l'application d'Exchange 2000 Server SP3. Cette modification n'est pas apportée automatiquement lorsque vous installez Exchange 2000 Server SP3.

Les blocages de journal peuvent être provoqués par un tampon trop faible et vous pouvez augmenter cette valeur jusqu'à 9 000. L'analyse du compteur de performance Base de données\Enregistrements journal inachevés/s permet de déterminer si des blocages de journal se produisent. N'utilisez pas de valeur supérieure à 9 000 car cela peut endommager les fichiers des journaux de transactions.

Remarque :
Enregistrements journal inachevés/s représente le nombre d'enregistrements de journal qui ne peuvent pas être ajoutés aux tampons de journal par seconde car ils sont pleins. Si ce compteur est différent de zéro la plupart du temps, la taille du tampon de journal peut être un goulot d'étranglement.

Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour supprimer cet avertissement

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Développez CN=<Nom_serveur>, CN=Banque_informations, cliquez avec le bouton droit sur CN=<Nom_groupe_stockage>, puis cliquez sur Propriétés.

  5. Dans l'Éditeur d'attribut, cliquez sur l'attribut msExchESEParamLogBuffers, puis sur Modifier.

  6. Dans la boîte de dialogue Modifier l'attribut, définissez la valeur sur 512 pour Exchange 2000 Server ou sur 9000 pour Exchange Server 2003.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Fermez ADSI Edit, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur les tampons du journal ESE, voir l'article 328466 de la Base de connaissances Microsoft sur les tampons du journal ESE définis sur une valeur trop faible pouvant entraîner l'arrêt des réponses de la part de la banque (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur la définition des tampons du journal ESE, voir l'article 328466 de la Base de connaissances sur les tampons du journal ESE définis sur une valeur trop faible pouvant entraîner l'arrêt des réponses de la part de la banque (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server.


Les tampons du journal ESE sont définis sur une valeur trop élevée sur ce groupe de stockage
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamLogBuffers de chaque groupe de stockage. Si Exchange Server Analyzer détermine que la valeur de l'attribut msExchESEParamLogBuffers pour tous les groupes de stockage est supérieure à 9 000, une erreur s'affiche.

ESE (Extensible Storage Engine) utilise un ensemble de tampons de journal pour conserver les informations en mémoire vive avant de les écrire dans les journaux de transactions. L'utilisation de ces tampons améliore les performances d'enregistrement des transactions. Pour les gros serveurs, la valeur par défaut de 84 est trop faible. Elle peut provoquer des opérations d'E/S disque excessives sur le lecteur du journal des transactions et donc une altération considérable des performances si le serveur est chargé ou si les utilisateurs envoient des messages volumineux. L'augmentation du nombre de tampons du journal ESE améliore les performances, mais suscite également davantage de mémoire virtuelle.

Les informations suivantes permettent de définir correctement cette valeur :

  • Pour Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1) ou Exchange 2000 Server Service Pack 2 (SP2), définissez cette valeur sur 9 000.

  • Pour Exchange 2000 Server Service Pack 3 (SP3), définissez cette valeur sur 512.

  • Pour Exchange Server 2003, une valeur par défaut de 500 est utilisée et vous devez modifier la valeur de l'attribut msExchESEParamLogBuffers sur 9000.

Remarque :
Si vous avez précédemment réglé les tampons de journal sur 9 000, assurez-vous de réduire ce paramètre manuellement après l'application d'Exchange 2000 Server SP3. Cette modification n'est pas apportée automatiquement lorsque vous installez Exchange 2000 Server SP3.

Les blocages de journal peuvent être provoqués par un tampon trop faible et vous pouvez augmenter cette valeur jusqu'à 9 000. L'analyse du compteur de performance Base de données\Enregistrements journal inachevés/s permet de déterminer si des blocages de journal se produisent. N'utilisez pas de valeur supérieure à 9 000 car cela peut endommager les fichiers des journaux de transactions.

Remarque :
Enregistrements journal inachevés/s représente le nombre d'enregistrements de journal qui ne peuvent pas être ajoutés aux tampons de journal par seconde car ils sont pleins. Si ce compteur est différent de zéro la plupart du temps, la taille du tampon de journal peut être un goulot d'étranglement.

Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Développez CN=<Nom_serveur>, CN=Banque_informations, cliquez avec le bouton droit sur CN=<Nom_groupe_stockage>, puis cliquez sur Propriétés.

  5. Dans l'Éditeur d'attribut, cliquez sur l'attribut msExchESEParamLogBuffers, puis sur Modifier.

  6. Dans la boîte de dialogue Modifier l'attribut, définissez la valeur sur 512 pour Exchange 2000 Server ou sur 9000 pour Exchange Server 2003.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Fermez ADSI Edit, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur la définition des tampons du journal ESE, voir l'article 328466 de la Base de connaissances sur les tampons du journal ESE définis sur une valeur trop faible pouvant entraîner l'arrêt des réponses de la part de la banque (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466).


La taille du fichier journal ESE a été modifiée manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamLogFileSize du conteneur InformationStore. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchESEParamLogFileSize n'est pas égale à 5 120, une erreur s'affiche.

Cette valeur s'applique à tous les groupes de stockage sur le serveur. Cette erreur particulière se produit si la valeur par défaut de cet attribut a été modifiée (5 120 Ko ou 5 Mo). Il s'agit de la seule valeur prise en charge. Elle ne doit jamais être modifiée.

Vous devez corriger la valeur à l'aide d'un utilitaire, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit et localisez l'objet InformationStore pour cet ordinateur Exchange Server dans Active Directory.

    L'attribut msExchESEParamLogFileSize peut se trouver dans :

    CN=Configuration, DC=Domaine, CN=Services, CN=Microsoft Exchange, CN=Nom_organisation, CN=Groupes_administration, CN=Nom_groupe_administration, CN=Serveurs, CN=Nom_serveur, CN=Banque_informations

  2. Double-cliquez sur l'attribut msExchESEParamLogFileSize et définissez sa valeur sur 5 120.

  3. Fermez l'éditeur Active Directory et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de LDP.exe pour modifier des attributs d'Active Directory, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server.


Le nombre maximal de tables ouvertes ESE a été codé de manière irréversible
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchESEParamMaxOpenTables est présent pour tous les objets du groupe de stockage sous l'objet InformationStore de l'objet Exchange Server. Si Exchange Server Analyzer détecte que l'attribut msExchESEParamMaxOpenTables est présent et configuré, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, pour Exchange 2000 Server et Exchange Server 2003, cet attribut est présent, mais n'est défini sur aucune valeur. Exchange Server met en cache des données sur les dossiers auxquels personne n'accède actuellement. Cela peut dans certains cas contribuer à la fragmentation de mémoire virtuelle. Pour atténuer ce phénomène, vous pouvez réduire le nombre maximal de tables de base de données pouvant être ouvertes simultanément. La valeur réelle suggérée varie en fonction de la version d'Exchange Server et du Service Pack d'Exchange installés. Pour Exchange 2000 Server Service Pack 2, le paramètre par défaut pour les serveurs 8 processeurs est 85 000 tables par groupe de stockage. Cette valeur est réduite à 27 600 pour les serveurs 8 processeurs Exchange 2000 Server Service Pack 3. Pour les serveurs 4 processeurs, la valeur est 13 800 ; elle peut être diminuée pour limiter les problèmes de fragmentation de mémoire virtuelle. Toutefois, diminuer cette valeur peut également provoquer des situations pour lesquelles les opérations peuvent échouer en raison du nombre trop élevé de tables ouvertes. Cette erreur se produit parce que le nombre maximal de tables pouvant être simultanément ouvertes est diminué, ce qui signifie que le maximum est plus vite atteint.

Exchange Server 2003 utilise une méthode différente pour la mise en cache de données sur les dossiers auxquels personne n'accède actuellement. Par conséquent, il n'est ni nécessaire ni efficace de réduire le nombre maximal de tables ouvertes pour limiter le nombre de problèmes de fragmentation de mémoire virtuelle. Cet attribut ne doit pas être défini sur un serveur Exchange Server 2003.

À moins qu'il ne vous ait été demandé par les services de support technique Microsoft d'entrer une valeur ici, utilisez l'outil ADSI (Active Directory Service Interfaces) Edit pour effacer la valeur définie pour cet attribut.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Effacement de la valeur de l'attribut msExchESEParamMaxOpenTables

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=Nom_organisation_Exchange.

  3. Développez CN=Groupes_administration, CN=Nom_groupe_administration, puis CN=Serveurs.

  4. Développez CN=Nom_serveur_Exchange, CN=Banque_informations, cliquez avec le bouton droit sur CN=Nom_groupe_stockage, puis cliquez sur Propriétés.

  5. Dans la zone Sélectionnez une propriété à afficher, cliquez sur msExchESEParamMaxOpenTables.

  6. Dans la zone Modifier l'attribut, cliquez sur Effacer pour modifier la valeur et la définir sur <non défini>.

  7. Cliquez sur OK, puis de nouveau sur OK.

  8. Fermez l'éditeur Active Directory et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur cet attribut, consultez l'article 325044 de la Base de connaissances Microsoft sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange 2003 et Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044).

Pour plus d'informations sur l'utilisation de l'outil LDP, consultez l'article 260745 de la Base de connaissances sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


La base de données Exchange dépasse 100 Go
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_DataFile pour déterminer la valeur de la clé FileSize pour chaque base de données des banques d'informations Exchange. Si la taille combinée des fichiers .edb et .stm d'une banque d'informations dépasse 100 gigaoctets (Go), un avertissement s'affiche.

Microsoft recommande que la taille des bases de données des banques d'informations ne dépasse pas 50 Go. En cas de maintenance correcte, l'exécution de banques de boîtes aux lettres dépassant 50 Go ne pose aucun problème opérationnel ; toutefois, les temps de sauvegarde et de restauration pour les banques de boîtes aux lettres plus importantes peuvent être inadaptés pour certains accords sur les niveaux de service.

Si vous exécutez des banques de boîtes aux lettres dépassant 50 Go, vérifiez que votre matériel est adapté à vos accords sur les niveaux de service, notamment que ceux-ci incluent la restauration de bases de données volumineuses. Dans le cas contraire, il est recommandé de partager les boîtes aux lettres sur plusieurs banques pour qu'aucune ne dépasse 50 Go.

Correction de cet avertissement

  1. Envisagez de déplacer certaines boîtes aux lettres de la grande banque d'informations vers une nouvelle banque d'informations sur cet ordinateur Exchange Server ou sur un autre.

  2. Si vous avez récemment déplacé des boîtes aux lettres de cette banque d'informations vers une autre banque ou supprimé des boîtes aux lettres de cette banque d'informations, une défragmentation hors ligne risque de réduire la taille des fichiers.

  3. Envisagez de définir des tailles limites de boîte aux lettres ou de messages pour éviter la croissance illimitée de la base de données de banque d'informations.

Pour plus d'informations sur les fichiers .stm et .edb, consultez l'article 232323 de la Base de connaissances Microsoft sur le stockage du contenu natif dans Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, consultez l'article 821829 de la Base de connaissances sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange 2000 Server, consultez l'article 328810 de la Base de connaissances sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Pour plus d'informations sur l'exécution d'une défragmentation hors ligne d'une base de données Exchange Server, consultez l'article 328804 de la Base de connaissances sur la procédure de défragmentation des bases de données Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Pour plus d'informations sur la définition de tailles limites des messages, consultez l'article 322679 de la Base de connaissances sur la définition de tailles limites pour les messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).


Des fichiers de base de données Exchange sont écrits dans un dossier compressé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Compressed pour le dossier contenant les fichiers de base de données des banques d'informations Exchange. Si la valeur Compressed est définie sur True pour ce dossier, une erreur s'affiche.

Sur un ordinateur Exchange 2000 Server ou Exchange Server 2003, les bases de données des banques d'informations sont écrites à l'emplacement par défaut suivant :

<lecteur> :\Program Files\Exchsrvr\mdbdata

Sur un ordinateur Exchange Server 2007, les fichiers de base de données sont écrits dans l'emplacement par défaut suivant :

<lecteur> :\Program Files\Microsoft\Exchange Server\Mailbox\<Nom de groupe de stockage>

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume compressé NTFS. Lorsque vous stockez vos fichiers de données Exchange sur un volume compressé, la surcharge supplémentaire affecte considérablement les performances d'Exchange. En outre, lorsqu'une base de données de banque d'informations atteint une certaine taille (4 Go environ), elle peut ne pas être montée ou être endommagée.

Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Les fichiers gérés par ESE (Extensible Storage Engine) ne sont pas conçus pour être stockés sur un lecteur compressé. ESE dépend de l'indépendance de secteur pour la récupération basée sur le journal et la compression des fichiers invalide l'indépendance de secteur. La compression ne doit pas être activée pour les volumes hébergeant les bases de données ESE ou pour toute base de données qui utilise l'enregistrement à écriture anticipée.

Avant Exchange 2000 Server Service Pack 3, le montage des bases de données des banques d'informations compressées était autorisé. L'altération peut toutefois affecter toutes les bases de données des banques d'informations d'Exchange 2000 Server ou les journaux des banques d'informations compressés à l'aide de la compression NTFS.

Avec Exchange 2000 Server Service Pack 3, les fichiers de base de données des banques d'informations compressées de 128 Mo maximum sont automatiquement décompressés. Lorsque les fichiers de base de données sont supérieurs à 128 Mo, le montage de la base de données est impossible et les messages d'erreur sont générés dans le journal des applications. Exchange 2000 Server Service Pack 3 empêche le montage des bases de données compressées supérieures à 128 Mo.

Désactivation de la compression de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dont vous souhaitez désactiver la compression de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

Déplacement des fichiers de base de données sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration, Serveurs, votre serveur, votre groupe de stockage, puis cliquez avec le bouton droit sur Banque de boîtes aux lettres et cliquez sur Propriétés.

  3. Sous l'onglet Base de données, sous Base de données Exchange ou Base de données de transmission en continu Exchange, cliquez sur Parcourir, tapez l'emplacement de chemin d'accès dans un dossier dans lequel la compression n'est pas activée, puis cliquez sur OK.

  4. Cliquez sur OK ou sur Appliquer pour appliquer vos modifications, puis sur Oui dans le message d'avertissement.

    Après avoir cliqué sur Oui, les banques (bases de données) sont démontées, déplacées et remontées. Une fois ces procédures terminées correctement, vous recevez le message d'information suivant :

    Les fichiers de base de données ont été correctement déplacés

Modification de l'emplacement des fichiers de base de données d'un groupe de stockage Exchange dans Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de déplacement d'un chemin de groupe de stockage » (http://go.microsoft.com/fwlink/?LinkID=80747).

Pour plus d'informations sur les fichiers .stm et .edb, consultez l'article 232323 de la Base de connaissances Microsoft sur le stockage du contenu natif dans Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).


Les fichiers de base de données Exchange sont écrits sur une partition non NTFS
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows Management® Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé FSName pour l'emplacement des fichiers de base de données Exchange. Si Exchange Server Analyzer détermine que la valeur de la clé FSName n'est pas égale à NTFS File System, une erreur s'affiche.

Microsoft ne prend pas en charge le stockage de fichiers de données Exchange sur des volumes non NTFS. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .chk ;

  • fichiers .eml.

Si vous rencontrez cette erreur, vous devez déplacer les fichiers de base de données dans un dossier sur un lecteur NTFS. Si le lecteur sur lequel les fichiers de base de données sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS.

Déplacement de fichiers de base de données d'Exchange sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration, Serveurs, votre serveur, votre groupe de stockage, puis cliquez avec le bouton droit sur Banque de boîtes aux lettres et cliquez sur Propriétés.

  3. Sous l'onglet Base de données, sous Base de données Exchange ou Base de données de transmission en continu Exchange, cliquez sur Parcourir, tapez l'emplacement de chemin d'accès dans un dossier sur un volume NTFS, puis cliquez sur OK.

  4. Cliquez sur OK ou Appliquer pour appliquer vos modifications ou cliquez sur Annuler si vous ne souhaitez pas les appliquer.

  5. Si vous avez cliqué sur OK ou Appliquer, le message d'avertissement suivant s'affiche :

    Remarque Vous êtes sur le point d'effectuer les opérations suivantes

    • modifier l'emplacement de la base de données Exchange ;

    • modifier l'emplacement de la base de données de transmission en continu Exchange.

    Pour effectuer les opérations demandées, il est nécessaire de démonter temporairement la banque d'informations. Elle ne sera alors accessible à aucun utilisateur.

    Voulez-vous continuer ?

    Remarque :
    Seules les opérations que vous avez sélectionnées sont affichées dans le message d'avertissement. Il contient un bouton Oui et un bouton Non.

  6. Cliquez sur Oui si vous êtes prêt à continuer, cliquez sur Non dans le cas contraire.

  7. Si vous avez cliqué sur Oui, les banques (bases de données) sont démontées, déplacées et remontées. Une fois ces procédures terminées correctement, vous recevez le message d'information suivant :

    Les fichiers de base de données ont été correctement déplacés

Modification de l'emplacement des fichiers de base de données d'un groupe de stockage Exchange dans Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de déplacement d'un chemin de groupe de stockage » (http://go.microsoft.com/fwlink/?LinkID=80747)

Si le lecteur sur lequel les fichiers sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS. Pour plus d'informations sur l'utilisation de l'outil de ligne de commande convert.exe pour convertir une partition FAT en partition NTFS, consultez l'article 214579 de la Base de connaissances Microsoft sur l'utilisation de Convert.exe pour convertir une partition en système de fichiers NTFS (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Des fichiers de base de données Exchange sont écrits dans un dossier crypté
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Encrypted pour le dossier contenant les fichiers de base de données des banques d'informations de Microsoft Exchange. Si Exchange Server Analyzer détecte que la valeur de Encrypted est définie sur True, une erreur s'affiche.

Sur un ordinateur Exchange 2000 Server ou Exchange Server 2003, les fichiers de base de données sont écrits à l'emplacement par défaut suivant :

<lecteur> :\Program Files\Exchsrvr\mdbdata

Sur un ordinateur Exchange Server 2007, les fichiers de base de données sont écrits dans l'emplacement par défaut suivant :

<lecteur> :\Program Files\Microsoft\Exchange Server\Mailbox\<Nom de groupe de stockage>

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume chiffré du système de fichiers de chiffrage (EFS). Lorsque vous stockez vos fichiers de données Exchange sur un volume chiffré, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour sécuriser vos fichiers de données Exchange, il est recommandé d'empêcher l'accès non autorisé à l'ordinateur Exchange et d'utiliser le format de message S/MIME pour chiffrer des données de message.

Pour corriger cette erreur, vous devez désactiver le chiffrage de fichiers dans le dossier où sont écrits les fichiers de base de données ou déplacer les fichiers de base de données vers un dossier où le chiffrage n'est pas activé.

Désactivation du chiffrage de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver le chiffrage de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Chiffrer le contenu pour sécuriser les données, puis cliquez sur OK.

Déplacement des fichiers de base de données sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, puis votre groupe d'administration, Serveurs, votre serveur, votre groupe de stockage, puis cliquez avec le bouton droit sur Banque de boîtes aux lettres et cliquez sur Propriétés.

  3. Sous l'onglet Base de données, sous Base de données Exchange ou Base de données de transmission en continu Exchange, cliquez sur Parcourir, tapez l'emplacement de chemin d'accès dans un dossier dans lequel le chiffrage n'est pas activé, puis cliquez sur OK.

  4. Cliquez sur OK ou sur Appliquer pour appliquer vos modifications, puis sur Oui dans le message d'avertissement.

  5. Après avoir cliqué sur Oui, les banques (bases de données) sont démontées, déplacées et remontées. Une fois ces procédures terminées correctement, vous recevez le message d'information suivant :

    Les fichiers de base de données ont été correctement déplacés

Modification de l'emplacement des fichiers de base de données d'un groupe de stockage Exchange dans Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de déplacement d'un chemin de groupe de stockage » (http://go.microsoft.com/fwlink/?LinkId=80747)

Pour plus d'informations sur le déplacement de fichiers de bases de données, consultez l'article 821915 de la Base de connaissances Microsoft sur la procédure de déplacement des fichiers journaux et de bases de données Exchange dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Pour plus d'informations sur les fichiers de données Exchange Server et EFS, consultez l'article 834638 de la Base de connaissances, qui contient des informations sur le stockage de fichiers de données sur un volume chiffré dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Pour plus d'informations sur la sécurisation des messages dans Exchange Server 2003, consultez le Guide de sécurité des messages Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47574).


Base de données Exchange dans un état d'arrêt brutal
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-10-30

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que l'une de vos bases de données n'a pas été fermée correctement. Par conséquent, les fichiers de base de données sont encore joints aux fichiers journaux.

Un état d'arrêt brutal n'indique pas que la base de données est corrompue ou endommagée. Un état d'arrêt brutal indique seulement que les fichiers de la base de données n'ont pas été détachés du flux de journaux correctement. Par conséquent, avant de pouvoir redémarrer la base de données, vous devez récupérer les fichiers de base de données.

Lors du prochain montage de la base de données, cette récupération sera exécutée automatiquement. En cas d'échec de la récupération automatique, vous pouvez utiliser l'outil Microsoft Exchange Server Disaster Recovery Analyzer Tool pour analyser les raisons de l'échec. Après l'analyse, cet outil fournit des recommandations pour la récupération manuelle des fichiers de base de données.

Pour corriger cette erreur

  • Amenez la base de données dans un état de fermeture sain en relisant les fichiers journaux des transactions requis dans la base de données. Pour relire les fichiers journaux, montez la base de données. En cas d'échec, utilisez l'outil Exchange Server Disaster Recovery Analyzer Tool pour identifier la raison de l'échec.

Pour plus d'informations sur l'outil Analyseur de récupération d'urgence Exchange Server, consultez l'article 922247 de la Base de connaissances Microsoft sur l'outil Analyseur de récupération d'urgence Microsoft Exchange Server pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247).


La planification de la maintenance en ligne des bases de données Exchange est définie sur Jamais
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut activationSchedule sur les banques de boîtes aux lettres et les banques publiques. S'il détecte que la valeur de activationSchedule correspond à Jamais, un avertissement s'affiche.

L'attribut activationSchedule représente le paramètre de planification de la maintenance en ligne des bases de données. La maintenance en ligne des bases de données dans Exchange Server est très importante. C'est pendant cet intervalle que s'effectuent des tâches telles que le nettoyage des messages périmés (les messages périmés sont supprimés), l'expiration des dossiers publics (les messages contenus dans des dossiers publics, qui sont antérieurs à une certaine date, expirent), le nettoyage des boîtes aux lettres supprimées et la défragmentation en ligne (les objets de base de données qui ne sont plus utilisés sont détectés et supprimés, ce qui libère de l'espace dans la base de données). Grâce à ces processus, l'ordinateur Exchange Server reste sain et ses performances sont stables. La maintenance en ligne devrait être définie de manière à fonctionner au moins quatre heures par jour, faute de quoi les performances se dégraderont au fil du temps.

Il est donc recommandé de configurer la maintenance en ligne des bases de données pour qu'elle s'exécute sur chaque base de données (banque de boîtes aux lettres ou banque de dossiers publics) pendant quatre heures chaque jour. Échelonnez les intervalles de maintenance en ligne avec les planifications de sauvegarde. Par exemple, si la sauvegarde s'effectue de minuit à 2 h 00, exécutez la maintenance en ligne de 3 h 00 à 7 h 00.

Cela est important car la maintenance en ligne ne démarrera que lorsque la session de sauvegarde sera terminée. En cas de chevauchement, la sauvegarde prévaut sur la maintenance. Exchange vérifie alors toutes les 15 minutes si la sauvegarde est terminée. Une fois la sauvegarde finie, la maintenance commencera.

Pour effectuer la maintenance, la banque exécute 18 tâches. Lorsqu'une tâche est démarrée, la banque la termine indépendamment de la fenêtre de temps de la maintenance. Toutefois, une nouvelle tâche ne sera pas entamée si cette fenêtre est expirée. Ainsi, dans certains cas, toutes les tâches ne sont pas réalisées dans un intervalle de maintenance donné. Si la maintenance n'a pas été effectuée complètement, elle reprendra, lors de son prochain cycle, là où elle a été interrompue.

Activation de la maintenance de base de données en ligne pour Exchange 2000 Server et Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis celui que vous souhaitez utiliser.

  3. Développez le groupe de stockage que vous souhaitez utiliser.

  4. Dans la liste des banques de données disponibles dans le volet Détails, cliquez avec le bouton droit sur la banque avec laquelle vous souhaitez travailler, puis cliquez sur Propriétés.

  5. Dans la boîte de dialogue Propriétés de la banque de boîtes aux lettres, cliquez sur l'onglet Base de données.

  6. Effectuez l'une des opérations suivantes :

    • Dans la liste d'intervalles Maintenance, sélectionnez un intervalle.

    • Cliquez sur Personnaliser pour accéder à la boîte de dialogue Schedule (Planification), puis créez un intervalle personnalisé.

  7. Cliquez sur OK.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez la console de gestion Exchange.

  2. Développez Configuration du serveur, puis sélectionnez le serveur que vous voulez utiliser.

  3. Développez le groupe de stockage souhaité.

  4. Cliquez avec le bouton droit sur la banque que vous voulez utiliser, puis sélectionnez Propriétés.

  5. Sous l'onglet Général, cliquez sur la liste déroulante Planification de la maintenance, puis sélectionnez un intervalle, ou cliquez sur Personnaliser pour créer une planification personnalisée.

Pour plus d'informations sur les tâches de maintenance en ligne des bases de données, consultez l'article 159196 de la Base de connaissances Microsoft sur « XADM : les tâches contrôlées par la planification de la maintenance de la banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196).


Le service de banque d'informations Exchange n'est pas configuré pour s'exécuter en tant que LocalSystem
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-02-27

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Services pour déterminer si le compte de démarrage spécifié dans la propriété StartName du service Banque d'informations Microsoft Exchange (MSExchangeIS) utilise le compte LocalSystem. Si Exchange Server Analyzer détecte que la valeur de cette propriété sur un ordinateur Exchange 2000 Server, Exchange Server 2003 ou Exchange Server 2007 est un compte autre que LocalSystem (également appelé compte SYSTEM), un avertissement s'affiche. Cet avertissement n'apparaît pas sur les ordinateurs Exchange Server 5.5, sur lesquels le service Banque d'informations Microsoft Exchange doit s'exécuter sous un compte d'utilisateur.

Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007 doivent être démarrés dans le contexte de sécurité LocalSystem au lieu d'associer un compte d'utilisateur spécifique (et un mot de passe) pour démarrer ces services. De cette manière, aucune modification de mot de passe ou suppression de compte d'utilisateur n'entrave le bon fonctionnement d'Exchange. Lorsqu'un service Exchange qui s'exécute en tant que LocalSystem accède à un serveur distant, Microsoft Windows 2000 Server ou Windows Server™ 2003 l'authentifie en utilisant les informations d'authentification du compte d'ordinateur.

Le mot de passe sur le compte d'ordinateur change tous les sept jours en utilisant le mécanisme standard de modification de mot de passe. Le compte d'ordinateur est ainsi plus sûr qu'un compte d'utilisateur normal, où le mot de passe est non seulement modifié moins souvent, mais où il est aussi généré de manière moins aléatoire qu'un mot de passe créé par un ordinateur.

Certains administrateurs familiarisés avec Exchange Server 5.5, où un compte d'utilisateur est employé pour les services, changent le compte de démarrage sur les services Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007 en passant de l'utilisation du compte LocalSystem par défaut à un compte d'utilisateur.

Sur Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007, Microsoft ne prend pas en charge l'exécution du service Banque d'informations Microsoft Exchange sous un compte autre que LocalSystem.

Correction de cette erreur

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Outils d'administration, puis cliquez sur Services.

  2. Dans la liste des services, cliquez avec le bouton droit sur Microsoft Exchange - Banque d'informations, puis cliquez sur Propriétés.

  3. Sous l'onglet Ouvrir une session, sous Ouvrir une session en tant que, cliquez sur Compte LocalSystem, puis sur OK.

  4. Cliquez avec le bouton droit sur Microsoft Exchange - Banque d'informations, puis cliquez sur Redémarrer.

Pour plus d'informations sur les services Exchange, consultez l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Le service de banque d'informations de Exchange n'est pas en cours d'exécution
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si la valeur de la clé Started dans le service Banque d'informations Microsoft Exchange est définie sur True ou False.

La valeur False indique que le service Banque d'informations Microsoft Exchange n'est pas en cours d'exécution sur cet ordinateur Exchange Server. La valeur True indique que le service Banque d'informations Microsoft Exchange est en cours d'exécution.

Exchange Server Analyzer examine également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique que l'ordinateur Exchange Server est un serveur frontal Exchange Server 2003 ou Exchange 2000 Server.

Si les valeurs des deux clés évaluées sont False sur les systèmes Exchange 2000 Server et Exchange Server 2003, un avertissement s'affiche.

Si la valeur False est renvoyée pour la clé Win32_Service Started et que l'ordinateur Exchange Server exécute Exchange Server 2007, un avertissement s'affiche.

Si les tentatives de démarrage du service Banque d'informations Microsoft Exchange échouent, cela pourrait indiquer un problème plus grave sur cet ordinateur Exchange Server. Dans ce cas, vous devez examiner les journaux d'événements pour plus de détails sur l'échec. Vous devez également vous assurer que vous utilisez le dernier Service Pack pour votre version d'Exchange Server.

Vous pouvez obtenir le dernier Service Pack pour Exchange Server 2003 sur le site des téléchargements pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=25097).

Pour plus d'informations sur les causes connues d'échec du service Banque d'informations Microsoft Exchange, consultez les articles suivants de la Base de connaissances Microsoft :

  • 827915 sur le service Banque d'informations qui peut s'arrêter inopinément lors de la conversion d'un message ne contenant pas la propriété PR_MESSAGE_CLASS dans Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602 sur l'absence de réaction du service Banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115 sur le service Banque d'informations qui ne démarre pas après la mise à niveau vers Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197 sur le service Banque d'informations qui s'arrête inopinément lorsqu'un message avec un ID de message Internet nul est remis localement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130 sur le volet Dossiers qui ne s'affiche pas ou le service Banque d'informations qui se ferme inopinément lors de l'utilisation d'OWA pour accéder à votre boîte aux lettres sur l'ordinateur Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163 sur l'affichage du message d'erreur « Le programme d'installation n'est pas parvenu à trouver un serveur de catalogue global pour se connecter » lorsque vous essayez de démarrer le service Banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579 sur l'ID d'événement 7024 après l'installation d'Exchange Server 2003 et l'impossibilité de démarrer le service Banque d'informations Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841 sur le service Banque d'informations Microsoft Exchange qui cesse inopinément de répondre (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Pour plus d'informations sur l'utilisation de serveurs frontaux Exchange Server 2003 et Exchange 2000 Server, consultez les sites Web suivants :

  • sur l'utilisation des serveurs frontaux Microsoft Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=12055).

  • sur la topologie des serveurs frontaux et principaux Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=47567)


Le service de banque d'informations de Exchange ne fonctionne pas sur ce serveur frontal
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer les valeurs définies pour la clé Started de la banque d'informations de Microsoft Exchange et les services SMTP (Simple Message Transfer Protocol). La valeur False indique que le service n'est pas en cours d'exécution. La valeur True indique que le service est en cours d'exécution.

Exchange Server Analyzer examine également la classe WMI Exchange_Server de l'espace de noms root\MicrosoftExchangeV2 pour déterminer la valeur de la clé IsFrontEndServer. La valeur False indique que l'ordinateur Exchange Server n'est pas un serveur frontal. La valeur True indique qu'il s'agit d'un serveur frontal.

Si Exchange Server Analyzer détecte que la valeur de Started pour le service SMTP est « true », la valeur de Started pour le service de banque d'informations de Microsoft Exchange est False et la valeur de IsFrontEndServer est True, un avertissement s'affiche.

Exchange 2000 Server et Exchange Server 2003 utilisent des serveurs frontaux pour traiter les demandes de clients proxy POP3, IMAP4 et Microsoft Office Outlook® Web Access. En outre, ils peuvent être utilisés comme serveurs SMTP Internet. Si ce serveur frontal accepte et route les messages SMTP, prend en charge les clients IMAP (qui utilisent SMTP pour l'envoi de messages) ou s'il utilise un logiciel compatible VSAPI (API d'analyse antivirus), le service de banque d'informations de Microsoft Exchange doit être actif. Sinon, le serveur frontal ne pourra pas traiter les messages SMTP ni analyser les messages utilisant l'interface VSAPI.

À moins qu'un logiciel antivirus compatible SMTP ou VSAPI ne soit utilisé sur un serveur frontal, la configuration recommandée consiste à déconnecter et à supprimer toutes les banques de dossiers publics sur le serveur frontal, à interrompre le service de banque d'informations de Microsoft Exchange et à le désactiver. Le service SMTP doit en outre être interrompu s'il n'est pas utilisé. Sur les ordinateurs Exchange Server qui utilisent un logiciel compatible SMTP ou VSAPI, le service de banque d'informations de Microsoft Exchange doit être en cours d'exécution pour pouvoir remettre des messages et répondre aux clients de messagerie.

Pour supprimer cet avertissement

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur Microsoft Exchange - Banque d'informations, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de Banque d'informations de Microsoft Exchange, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, définissez-le sur Automatique, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service de banque d'informations de Microsoft Exchange, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

Si les tentatives de démarrage du service de banque d'informations de Microsoft Exchange échouent, cela pourrait indiquer un problème plus grave sur cet ordinateur Exchange Server. Dans ce cas, vous devez examiner les journaux d'événements pour plus de détails sur l'échec. Vous devez également vous assurer que vous utilisez le dernier Service Pack pour votre version d'Exchange Server. Vous pouvez vous procurer le dernier Service Pack pour Exchange Server sur la page d'accueil du site Web de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).

Pour plus d'informations sur les causes connues d'échec du service de banque d'informations de Microsoft Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 827915 sur le service de banque d'informations qui peut s'arrêter inopinément lors de la conversion d'un message ne contenant pas la propriété PR_MESSAGE_CLASS dans Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915)

  • 830602 sur l'absence de réaction du service de banque d'informations d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602)

  • 839115 sur le service de banque d'informations qui ne démarre pas après la mise à niveau vers Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115)

  • 330197 sur le service de banque d'informations qui s'arrête inopinément lorsqu'un message avec un ID de message Internet nul est remis localement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197)

  • 831130 sur le volet Dossiers qui ne s'affiche pas ou le service de banque d'informations qui se ferme inopinément lors de l'utilisation d'OWA pour accéder à votre boîte aux lettres sur l'ordinateur Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130)

  • 823163 sur l'affichage du message d'erreur « Le programme d'installation n'est pas parvenu à trouver un serveur de catalogue global pour se connecter » lorsque vous essayez de démarrer le service de banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163)

  • 822579 sur l'ID d'événement 7024 après l'installation d'Exchange Server 2003 et l'impossibilité de démarrer le service de banque d'informations d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579)

  • 833841 sur le service de banque d'informations de Microsoft Exchange qui cesse inopinément de répondre (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841)

Pour plus d'informations sur les serveurs frontaux, voir le guide sur la topologie principale et frontale d'Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=47567).


Le lecteur Exchange Installable File System est activé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-02-28

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le mappage de lettre de lecteur Exchange Installable File System (ExIFS ou IFS) est activé :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Si Exchange Server Analyzer détecte que la valeur de Registre DriveLetter est configurée avec une lettre de lecteur (telle que M), une erreur s'affiche.

Exchange 2000 Server a introduit une fonction nommée IFS. IFS est un lecteur au niveau noyau qui rend certaines des données des banques d'informations d'Exchange accessibles au système de fichiers Microsoft Windows®. Dans les nouvelles installations d'Exchange 2000 Server et les mises à niveau d'Exchange Server 5.5 vers Exchange 2000 Server, IFS est automatiquement installé et une lettre de lecteur (par défaut, le lecteur M) est attribuée et mappée à la banque d'informations. Cette opération a été effectuée à l'aide de l'espace de noms \\.\BackOfficeStorage\.

Exchange Server 2003 prend en charge IFS, mais le mappage de lettre de lecteur y est désactivé par défaut. La valeur de Registre DriveLetter n'est pas présente dans les nouvelles installations d'Exchange Server 2003 et, dans une mise à niveau d'Exchange 2000 Server vers Exchange Server 2003, les données de la valeur de Registre et donc le mappage de lettre de lecteur sont supprimés.

Il est recommandé de ne pas activer le mappage de lettre de lecteur IFS dans Exchange Server 2003 et de le supprimer dans Exchange 2000 Server. Des problèmes connus peuvent survenir si un antivirus ou des applications basées sur un système de fichiers accèdent ou analysent la lettre de lecteur mappée vers IFS. Par conséquent, il est recommandé que le mappage de lettre de lecteur soit supprimé si la fonctionnalité IFS n'est pas utilisée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Dans le volet droit, double-cliquez sur la valeur DriveLetter.

  4. Dans le champ Données de la valeur, supprimez la lettre affichée pour que le champ soit vide.

  5. Fermez l'Éditeur du Registre et redémarrez le service Surveillance du système Microsoft Exchange et le service de publication World Wide Web pour que la modification soit prise en compte. Lorsque vous redémarrez le service Surveillance du système, tous les services qui en dépendent, notamment les services des piles MTA Microsoft Exchange et de banque d'informations de Microsoft Exchange, seront également redémarrés.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la suppression du mappage du lecteur M dans Exchange 2000 Server, voir l'article 305145 de la Base de connaissances sur la procédure de suppression du mappage IFS pour le lecteur M dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=305145).

Pour plus d'informations sur l'ajout du mappage du lecteur M dans Exchange Server 2003, voir l'article 821836 de la Base de connaissances sur l'absence de mappage par défaut du lecteur M vers IFS dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821836).


Configuration et performances d'Exchange Server
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre serveur Exchange n'est pas configuré pour des performances optimales.

Pendant leur fonctionnement normal, les serveurs Exchange accèdent à différents fichiers. L'emplacement des fichiers peut contribuer à un goulot d'étranglement des performances. Les groupes de fichiers interdépendants, tels que les lecteurs de journaux des transactions, sont également appelés ressources.

Si la distribution de ces ressources contribue à un goulot d'étranglement de disque, Exchange Server Analyzer risque d'afficher un avertissement ou une erreur sur l'emplacement des ressources sur le serveur Exchange. Pour vérifier que les ressources spécifiques sont isolées des autres demandes de charge, placez-les sur un périphérique de stockage dédié. La liste suivante décrit l'utilisation de chaque ressource, notamment les recommandations relatives à la procédure de configuration de la ressource.

  • Lecteurs de journaux des transactions Les fichiers journaux des transactions conservent l'état et l'intégrité de vos fichiers .edb et .stm. Ceci signifie que les fichiers journaux représentent en fait les données. Il existe un ensemble de fichiers journaux de transactions pour chaque groupe de stockage. Étant donné que les journaux des transactions constituent un composant de sauvegarde essentiel pour les données des fichiers de base de données du serveur Exchange, ce dernier doit valider toutes les données dans le fichier journal avant de pouvoir terminer la plupart de ses transactions sur les données. Tout retard d'écriture sur le lecteur du journal des transactions peut affecter sérieusement les performances du serveur. Par conséquent, il est important d'isoler les lecteurs de journaux de transactions pour qu'ils disposent de leur propre sous-système de disque, qui n'est pas partagé par un autre serveur, une autre application ou une autre ressource. Pour des performances optimales, veillez à ce que chaque journal des transactions dispose d'un lecteur dédié.

  • Emplacement du lecteur TEMP Lorsqu'il est installé pour la première fois, le système d'exploitation définit l'emplacement du fichier temporaire sur le même lecteur que celui utilisé par le système d'exploitation. Ceci signifie que toute E/S pour le lecteur TEMP rivalise avec les E/S des programmes et des opérations du fichier d'échange exécutées à partir de ce lecteur. Cette rivalité entre les E/S affecte les performances. Le lecteur TEMP est utilisé pour la remise de courrier et la conversion de contenu des messages volumineux. Si le lecteur TEMP devient un goulot d'étranglement, il affecte le flux du courrier et certaines applications clientes. Pour éviter toute rivalité entre les E/S du système d'exploitation et du lecteur TEMP et pour réduire le risque de problèmes de performances sur le serveur Exchange, il est recommandé de :

    • modifier le paramètre d'environnement global de TEMP pour pointer vers un autre disque ;

    • déplacer le lecteur TEMP vers son propre disque.

  • Emplacement des fichiers .edb et .stm Une base de données Exchange se compose de deux fichiers :

    • Un fichier .edb (contenu MAPI) Ce fichier stocke tous les messages et tables MAPI utilisés par le processus Store.exe pour rechercher tous les messages et totaux de contrôle des fichiers .edb et .stm et des messages MAPI.

    • Un fichier .stm (contenu non-MAPI) Ce fichier contient les messages transmis avec leur contenu Internet natif.

    Étant donné que l'accès à l'un ou l'autre type de ces fichiers est généralement aléatoire, ces deux types peuvent être inclus sur le même volume de disque. Toutefois, il est important de ne pas placer les fichiers .edb et .stm sur le même lecteur que les journaux des transactions. Comme il est important d'éviter un goulot d'étranglement des performances sur les lecteurs qui contiennent les fichiers de base de données, il est également recommandé de placer ces fichiers sur des lecteurs dédiés conformément à chaque groupe de stockage.

  • Emplacement du répertoire SMTP La file d'attente SMTP stocke les messages SMTP jusqu'à ce qu'Exchange les écrive dans une base de données (la banque de boîtes aux lettres ou la banque de dossiers publics) ou envoie les messages vers un autre serveur ou connecteur. En règle générale, les files d'attente SMTP connaissent des petites E/S aléatoires. Exchange Server Analyzer affiche un avertissement si le répertoire SMTP se situe sur un lecteur partagé par l'un des éléments suivants :

    • tout autre fichier de données Exchange ;

    • les répertoires TEMP ou TMP ;

    • le fichier d'échange ;

    • le lecteur système.

    S'il n'existe aucun goulot d'étranglement de disque au niveau du répertoire SMTP, vous pouvez ignorer cet avertissement en toute sécurité. Toutefois, si le trafic vers ce lecteur est intense et si le lecteur présente un goulot d'étranglement des performances, envisagez de déplacer le répertoire SMTP vers son propre lecteur ou augmentez la capacité du lecteur qui héberge le répertoire SMTP.

  • Emplacement du fichier d'échange Le fichier d'échange sert d'extension à la mémoire physique. En particulier, le fichier d'échange est l'endroit où le système stocke les pages inutilisées ou les pages dont le système aura besoin ultérieurement. Le fichier d'échange est toujours utilisé, même par les serveurs qui dispose d'une quantité adéquate de mémoire libre. Cette utilisation est constante car le système d'exploitation tente de ne stocker que les pages nécessaires et suffisamment d'espace libre pour les opérations. Par exemple, un outil d'impression utilisé uniquement au démarrage risque de voir une partie de sa mémoire paginée pour le disque et de ne jamais la récupérer si elle n'est jamais utilisée.

    Sur des serveurs où la mémoire physique est très utilisée, veillez à ce que tout accès au fichier d'échange soit aussi rapide que possible. Il est recommandé de créer un deuxième fichier d'échange sur un lecteur qui est dédié au fichier d'échange.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les meilleures pratiques de conception d'architectures de stockage, voir la rubrique sur les meilleures pratiques communes à diverses architectures (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Pour plus d'informations sur le dimensionnement de disque, la latence et les taux d'E/S, voir la rubrique sur la procédure de calcul des besoins en E/S disque (http://go.microsoft.com/fwlink/?linkid=69747).


Le port TCP/IP de la banque Exchange a été remplacé manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-03-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur du port pour l'interface de la banque Exchange a été remplacée manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Si Exchange Server Analyzer détecte que TCP/IP Port est présent et configuré, un message indiquant une configuration autre que celle par défaut s'affiche.

Cette valeur est généralement configurée pour permettre aux clients MAPI de se connecter à un serveur Exchange situé de l'autre côté d'un pare-feu. Ce scénario implique l'ouverture de plusieurs ports sur un pare-feu pour permettre aux clients Microsoft Office Outlook® 2003 ou Outlook 2007 de se connecter via l'interface MAPI à un serveur Exchange, généralement sur Internet. Il s'agit d'une configuration prise en charge. Pour plus d'informations sur la configuration de clients MAPI pour qu'ils se connectent à Exchange via un pare-feu, consultez l'article 270836 de la Base de connaissances Microsoft sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836). Toutefois, si vous n'utilisez pas ce scénario, vous devez supprimer la clé de Registre.

Le déploiement recommandé pour l'utilisation d'Outlook en mode MAPI pour se connecter à un serveur Exchange via Internet consiste à utiliser les fonctionnalités RPC sur HTTP disponibles dans Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 et Microsoft Windows® XP Professionnel. Le mode MAPI était auparavant appelé mode « société » ou « groupe de travail ».

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Suppression de la clé de Registre TCP/IP Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la valeur de Registre nommée TCP/IP Port.

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Déploiement de RPC sur HTTPS

  1. Voir le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47577).

  2. Consultez l'article 833401 de la Base de connaissances sur la procédure de configuration de RPC sur HTTP sur un seul serveur dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401).

  3. Consultez l'article 827330 de la Base de connaissances sur la procédure de dépannage des problèmes de connexion client RPC sur HTTP dans Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330).

  4. Consultez la Webdiffusion des services du support technique Microsoft sur l'utilisation de Microsoft Exchange sur Internet (RPC/HTTP) avec Microsoft Office Outlook 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134).


Port TCP/IP de la banque Exchange inférieur à 5000
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-01-11

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre TCP/IP Port de la banque Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Si Exchange Server Analyzer détecte que la valeur de TCP/IP Port est définie sur une valeur inférieure à 5000 (décimal), un avertissement s'affiche.

Si vous devez définir le paramètre TCP/IP Port sur une valeur statique, il est recommandé de le définir sur une valeur supérieure ou égale à 5000. S'il est défini sur une valeur inférieure à 5000, le serveur Exchange risque d'arrêter d'écouter sur ce port. Le serveur Exchange reste dans cet état jusqu'au redémarrage d'un service (le service à redémarrer dépend du composant d'Exchange qui est codé de manière irréversible).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour définir la clé de Registre TCP/IP NSPI Port

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Double-cliquez sur la clé TCP/IP Port et définissez le champ Données de la valeur sur un entier à peine supérieur à 5000 (décimal).

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service de banque d'informations de Microsoft Exchange pour que cette modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les paramètres des ports, voir l'article 270836 de la Base de connaissances sur les mappages de ports statiques Exchange 2000 et Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836).


Des journaux de transactions Exchange sont écrits sur une partition non NTFS
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-02-27

Message d'erreur

Introduction

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé FSName de l'emplacement des fichiers journaux des transactions Exchange. Si Exchange Server Analyzer détermine que la valeur de la clé FSName n'est pas égale à NTFS, une erreur s'affiche.

Microsoft ne prend pas en charge le stockage de fichiers de données Exchange sur des volumes non NTFS. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml.

Si vous rencontrez cette erreur, vous devez déplacer les journaux de transactions dans un dossier sur un lecteur NTFS. Si le lecteur sur lequel le répertoire de journal de transaction est enregistré est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS.

Déplacement des journaux des transactions sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, votre propre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre groupe de stockage, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Emplacement du journal des transactions, cliquez sur Parcourir.

  4. Entrez le chemin du nouvel emplacement des fichiers journaux, puis cliquez sur OK.

  5. Cliquez sur OK.

Modification de l'emplacement des fichiers journaux des transactions d'un groupe de stockage Exchange pour Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de définition ou de modification de l'emplacement des fichiers journaux d'un groupe de stockage » (http://go.microsoft.com/fwlink/?LinkID=80702).

Si le lecteur sur lequel les fichiers sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS. Pour plus d'informations sur l'utilisation de l'outil de ligne de commande convert.exe pour convertir une partition FAT en partition NTFS, voir l'article 214579 de la Base de connaissances Microsoft sur l'utilisation de Convert.exe pour convertir une partition en système de fichiers NTFS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579).


Des journaux de transactions Exchange sont écrits dans un dossier compressé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Compressed pour le dossier contenant les journaux de transactions des banques d'informations Exchange. Si la valeur Compressed est définie sur True pour ce dossier, une erreur s'affiche.

Lorsqu'un message est remis à Exchange, il est d'abord écrit dans les journaux de transactions avant d'être assigné à la banque d'informations et remis. Sur un ordinateur Exchange 2000 Server ou Exchange Server 2003, les journaux de transactions sont écrits à l'emplacement par défaut suivant :

<lecteur> :\Program Files\Exchsrvr\mdbdata

Sur un ordinateur Exchange Server 2007, les fichiers journaux de transactions sont écrits dans l'emplacement par défaut suivant :

<lecteur> :\Program Files\Microsoft\Exchange Server\Mailbox\<Nom de groupe de stockage>

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume compressé NTFS. Lorsque vous stockez vos fichiers de données Exchange sur un volume compressé, la surcharge supplémentaire affecte considérablement les performances d'Exchange. En outre, lorsqu'une base de données de banque d'informations atteint une certaine taille (4 Go environ), elle peut ne pas être montée ou être endommagée.

Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Les fichiers gérés par ESE (Extensible Storage Engine) ne sont pas conçus pour être stockés sur un lecteur compressé. ESE dépend de l'indépendance de secteur pour la récupération basée sur le journal et la compression des fichiers invalide l'indépendance de secteur. La compression ne doit pas être activée pour les volumes hébergeant les bases de données ESE ou pour toute base de données qui utilise l'enregistrement à écriture anticipée.

Avant Exchange 2000 Server Service Pack 3, le montage des bases de données des banques d'informations compressées était autorisé. L'altération peut toutefois affecter toutes les bases de données des banques d'informations d'Exchange 2000 Server ou les journaux des banques d'informations compressés à l'aide de la compression NTFS.

Avec Exchange 2000 Server Service Pack 3, les fichiers de base de données des banques d'informations compressées de 128 Mo maximum sont automatiquement décompressés. Lorsque les fichiers de base de données sont supérieurs à 128 Mo, le montage de la base de données est impossible et les messages d'erreur sont générés dans le journal des applications. Exchange 2000 Server Service Pack 3 empêche le montage des bases de données compressées supérieures à 128 Mo.

Désactivation de la compression pour un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver la compression de fichiers et cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

Déplacement des fichiers de transactions sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, votre propre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre groupe de stockage, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Emplacement du journal des transactions, cliquez sur Parcourir.

  4. Entrez le chemin du nouvel emplacement des fichiers journaux, puis cliquez sur OK.

  5. Cliquez sur OK.

Modification de l'emplacement des fichiers journaux de transactions d'un groupe de stockage Exchange pour Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de définition ou de modification de l'emplacement des fichiers journaux d'un groupe de stockage » (http://go.microsoft.com/fwlink/?LinkId=80702).

Pour plus d'informations sur le déplacement de fichiers journaux dans Exchange Server 2003, consultez l'article 821915 de la Base de connaissances Microsoft sur la procédure de déplacement des fichiers journaux ou des bases de données Exchange dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Pour plus d'informations sur le déplacement de fichiers journaux dans Exchange 2000 Server, consultez l'article 239944 de la Base de connaissances sur la procédure de déplacement des fichiers journaux de transactions ou des fichiers journaux système (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944).


Des journaux de transactions Exchange sont écrits dans un dossier crypté
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-02-27

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Encrypted pour le dossier contenant les journaux des transactions de la banque d'informations. Si Exchange Analyzer détecte que la valeur de Encrypted est définie sur True, une erreur s'affiche.

Lorsqu'un message est remis à Exchange, il est d'abord écrit dans les journaux de transactions avant d'être assigné à la banque d'informations et remis. Sur un ordinateur Exchange 2000 Server ou Exchange Server 2003, les journaux de transactions sont écrits à l'emplacement par défaut suivant :

<lecteur> :\Program Files\Exchsrvr\mdbdata

Sur un ordinateur Exchange Server 2007, les fichiers journaux des transactions sont écrits dans l'emplacement par défaut suivant :

<lecteur> :\Program Files\Microsoft\Exchange Server\Mailbox\<Nom de groupe de stockage>

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume chiffré du système de fichiers de chiffrage (EFS). Lorsque vous stockez vos fichiers de données Exchange sur un volume chiffré, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour sécuriser vos fichiers de données Exchange, il est recommandé d'empêcher l'accès non autorisé à l'ordinateur Exchange et d'utiliser le format de message S/MIME pour chiffrer des données de message.

Pour corriger cette erreur, vous devez désactiver le chiffrement de fichiers dans le dossier où sont écrits les journaux de transactions ou déplacer ces derniers vers un dossier où le chiffrement n'est pas activé.

Désactivation du chiffrage de fichiers sur un dossier spécifié

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver le chiffrage de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Chiffrer le contenu pour sécuriser les données, puis cliquez sur OK.

Pour déplacer les fichiers de transactions sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, votre propre groupe d'administration et Serveurs, cliquez avec le bouton droit sur votre groupe de stockage, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Emplacement du journal des transactions, cliquez sur Parcourir.

  4. Entrez le chemin du nouvel emplacement des fichiers journaux, puis cliquez sur OK.

  5. Cliquez sur OK.

Modification de l'emplacement des fichiers journaux des transactions d'un groupe de stockage Exchange pour Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de définition ou de modification de l'emplacement des fichiers journaux d'un groupe de stockage » (http://go.microsoft.com/fwlink/?LinkID=80702).

Pour plus d'informations sur le déplacement de fichiers journaux, voir l'article 821915 de la Base de connaissances Microsoft sur la procédure de déplacement des fichiers journaux ou des bases de données Exchange dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915).

Pour plus d'informations sur les fichiers de données Exchange Server et EFS, consultez l'article 834638 de la Base de connaissances, qui contient des informations sur le stockage de fichiers de données sur un volume chiffré dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Pour plus d'informations sur la sécurisation des messages dans Microsoft Exchange Server 2003, voir le Guide de sécurité des messages Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47574).


Les compteurs de performances ESE étendus sont activés
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si le serveur Exchange comprend les compteurs étendus ESE (Extensible Storage Engine) dans sa bibliothèque de compteurs de performance :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

Si Exchange Server Analyzer détecte que la valeur de la clé de Registre Show Advanced Counters est 1, il affiche un message indiquant une configuration autre que celle par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour désactiver les compteurs de performance ESE étendus

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Supprimez la valeur Show Advanced Counters sous la clé HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance dans le Registre.

  3. Fermez l'Éditeur du Registre.

  4. Redémarrez l'Analyseur de performances pour appliquer la modification.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Les compteurs de performances de stockage étendus sont activés
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si le fichier Mdbperfx.dll existe dans la bibliothèque du serveur Exchange des compteurs de performance :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

Si Exchange Server Analyzer détecte que la valeur de la Bibliothèque comprend la chaîne « mdbperfx.dll », un message indiquant une configuration autre que celle par défaut s'affiche.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

La DLL Mdbperf.dll contient l'ensemble de compteurs de performance de stockage par défaut. La DLL Mdbperfx.dll contient le même ensemble de compteurs de performance de stockage par défaut, ainsi que l'ensemble étendu de compteurs de performance de stockage.

Par défaut, les données de valeur de la Bibliothèque incluent la DLL Mdbperf.dll, mais pas la DLL Mdbperfx.dll. Le tableau suivant énumère les compteurs de performance de stockage étendus que contient la DLL Mdbperfx.dll.

Compteur | Cible
FXGetBufferRopsCalled | Nombre total d'opérations d'appel de procédure distante (RPC) FXGetBuffer
FXGetBufferRopsCalledPerSec | Nombre d'opérations RPC FXGetBuffer par seconde
FXGetBufferRopsAcceptedPerSec | Nombre d'opérations RPC FXGetBuffer acceptées par seconde
FXGetBufferRopsDenied | Nombre total d'opérations RPC FXGetBuffer refusées
FXGetBufferRopsDeniedPerSec | Nombre d'opérations RPC FXGetBuffer refusées par seconde
FXGetBufferCurrentCallerCount | Nombre d'opérations RPC FXGetBuffer simultanées
FXGetBufferCurrentUsersExecuting | Nombre d'opérations RPC FXGetBuffer simultanées en cours d'exécution
Messages analysés comme messages MIME | Nombre total de messages de haut niveau traités comme des messages MIME par l'analyseur antivirus
Messages analysés comme messages MIME/s | Taux de messages de haut niveau traités comme des messages MIME par l'analyseur antivirus
Messages analysés comme messages MAPI | Nombre total de messages de haut niveau traités comme des messages MAPI par l'analyseur antivirus
Messages analysés comme messages MAPI/s | Taux de messages de haut niveau traités comme des messages MAPI par l'analyseur antivirus
Octets lus | Nombre total d'octets lus par l'analyseur antivirus
Octets écrits | Nombre total d'octets écrits par l'analyseur antivirus
Longueur de la file d'attente (priorité basse) | Nombre actuel de requêtes de priorité basse mises en file d'attente pour l'analyse antivirus
Threads | Nombre actuel de threads dans un pool de threads utilisées pour l'analyse antivirus. Ce chiffre n'inclut pas le nombre de threads utilisées pour l'analyse en arrière-plan.
Vérifications antivirus approuvées par un tampon MFT | Nombre de fois que des vérifications antivirus ont été approuvées par un tampon dans MFT (Message Folder Table)
Vérifications antivirus approuvées par un tampon MFT/s | Taux auquel les vérifications antivirus sont approuvées par un tampon dans MFT (Message Folder Table)
Vérifications antivirus approuvées par un tampon d'instance | Nombre de fois que des vérifications antivirus ont été approuvées par un tampon d'instance
Vérifications antivirus approuvées par un tampon d'instance/s | Nombre de fois que des vérifications antivirus ont été approuvées par un tampon d'instance principale
Vérifications antivirus approuvées par un tampon d'instance principale/s | Taux auquel les vérifications antivirus sont approuvées par un tampon d'instance principale
Vérifications non approuvées | Nombre de fois que des vérifications antivirus n'ont pas été approuvées par un tampon
Vérifications non approuvées/s | Taux auquel les vérifications antivirus ne sont pas approuvées par un tampon
Vérifications bloquées | Nombre de fois que le traitement a été bloqué en attendant la fin de l'analyse antivirus
Vérifications bloquées/s | Taux auquel le traitement est bloqué en attendant la fin de l'analyse antivirus
Dépassement de délai des vérifications | Nombre de fois que le délai imparti aux opérations en attente de la fin de l'analyse antivirus a été dépassé
Dépassement de délai des vérifications/s | Taux auquel le délai imparti aux opérations en attente de la fin de l'analyse antivirus est dépassé
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour n'activer que les compteurs de performance de stockage par défaut

  1. Lancez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Recherchez la valeur de la Bibliothèque sous la clé de Registre suivante :

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. Dans le menu Édition, cliquez sur Modifier.

  4. Dans la zone Données de la valeur, modifiez la valeur c:\Program Files\Exchsrvr\bin\mdbperfx.dll en c:\Program Files\exchsrvr\bin\mdbperf.dll.

  5. Cliquez sur OK, puis fermez l'Éditeur du Registre.

  6. Redémarrez l'Analyseur de performances pour appliquer la modification.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la collecte de données de performances de la banque Exchange, voir l'article 821912 de la Base de connaissances sur la procédure de collecte des données de diagnostic pour résoudre les problèmes de la banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912).


Le paramètre FXGetBuffer Backoff Constant n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la valeur FXGetBuffer Backoff Constant a été créée :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la valeur FXGetBuffer Backoff Constant a été créée sous la clé de Registre ParametersSystem, il affiche un message indiquant une configuration autre que celle par défaut.

La valeur FXGetBuffer Backoff Constant permet de contrôler le nombre de clients Microsoft Office Outlook® 2003 qui se synchronisent simultanément avec un serveur Exchange Server 2003. Définissez la valeur FXGetBuffer Backoff Constant pour configurer le délai d'attente d'un client Outlook avant que ce dernier ne puisse tenter de se reconnecter. La valeur par défaut pour FXGetBuffer Backoff Constant est de 500 millisecondes.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise. Toutefois, vous pouvez supprimer la clé de Registre FXGetBuffer Backoff Constant si vous souhaitez rétablir la configuration par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la valeur FXGetBuffer Backoff Constant.

  4. Fermez l'Éditeur du Registre.

Le service de banque d'informations de Microsoft Exchange détecte les modifications en quelques minutes. Il n'est pas nécessaire de redémarrer l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la définition des clés de Registre pour contrôler le nombre de clients Outlook qui peuvent se synchroniser avec Exchange Server 2003, voir l'article 818484 de la Base de connaissances sur les valeurs de Registre et les compteurs disponibles pour configurer et surveiller la synchronisation client Outlook (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


Le paramètre FXGetBuffer Retry Count n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la valeur FXGetBuffer Retry Count a été créée :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la valeur FXGetBuffer Retry Count a été créée sous la clé de Registre ParametersSystem, il affiche un message indiquant une configuration autre que celle par défaut.

La valeur FXGetBuffer Retry Count permet de contrôler le nombre de clients Microsoft Office Outlook® 2003 qui se synchronisent simultanément avec un serveur Exchange Server 2003. Définissez la valeur FXGetBuffer Retry Count pour configurer le nombre de fois qu'un client Outlook peut essayer de se synchroniser avant de se voir autoriser l'accès. La valeur par défaut est 10.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise. Toutefois, vous pouvez supprimer la clé de Registre FXGetBuffer Retry Count si vous souhaitez rétablir la configuration par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la valeur FXGetBuffer Retry Count.

  4. Fermez l'Éditeur du Registre.

Le service de banque d'informations de Microsoft Exchange détecte les modifications en quelques minutes. Il n'est pas nécessaire de redémarrer l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la définition des clés de Registre pour contrôler le nombre de clients Outlook qui peuvent se synchroniser avec Exchange Server 2003, voir l'article 818484 de la Base de connaissances sur les valeurs de Registre et les compteurs disponibles pour configurer et surveiller la synchronisation client Outlook (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


Le paramètre de Registre Ignore Bad Oof Rule a été défini
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit le Registre de l'ordinateur Exchange Server pour vérifier la présence de l'entrée de Registre Ignore Bad Oof Rule. Cette valeur de Registre se trouve dans :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

Si Exchange Server Analyzer détecte que l'entrée de Registre Ignore Bad Oof Rule est présente et configurée avec une valeur 1 ou supérieure, un message indiquant une configuration autre que celle par défaut s'affiche.

L'entrée de Registre Ignore Bad Oof Rule est un paramètre de configuration pour Exchange 2000 Server, Exchange Server 2003 et Exchange Server 2007, conçu spécialement pour utiliser le correctif décrit dans l'article 828875 de la Base de connaissances Microsoft sur l'impossibilité de déplacer une boîte aux lettres Exchange après avoir utilisé l'utilitaire Exmerge.exe (http://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875).

Lorsque le programme de fusion de boîtes aux lettres Exchange (Exmerge.exe) est utilisé pour déplacer des messages et d'autres éléments d'une boîte aux lettres d'une banque vers une boîte aux lettres d'une autre banque, la prochaine tentative de déplacement de la seconde boîte aux lettres risque d'échouer. Cela peut être dû à la définition incorrecte d'une règle de notification d'absence du bureau pour cette boîte aux lettres. Si vous le voulez, vous pouvez rétablir la configuration par défaut en suivant la procédure décrite ci-après.

Important :
Cet article contient des informations sur la procédure de modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Dans le volet droit, recherchez la valeur Ignore Bad Oof Rule et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre de Registre Ignore Zombie Users a été défini
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool recherche dans le Registre de l'ordinateur Exchange Server la présence de l'entrée de Registre Ignore Zombie users. Cette valeur de Registre se trouve dans :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que l'entrée de Registre Ignore Zombie users est présente et configurée avec une valeur de 1 ou supérieure, un message indiquant une configuration autre que celle par défaut s'affiche.

Dans une organisation Exchange Server en mode mixte contenant Exchange Server 5.5 et Exchange 2000 Server ou dans un environnement auparavant mixte, des problèmes peuvent survenir dans les cas suivants :

  • Vous mettez à niveau la liste de contrôle d'accès (ACL) des boîtes aux lettres et des dossiers publics d'Exchange Server 5.5 vers Exchange 2000 Server.

  • La liste de contrôle d'accès contient les comptes d'utilisateurs qui ne sont pas représentés dans le service d'annuaire Active Directory®.

Ces entrées de contrôle d'accès (ACE) inutilisées sont également connues sous le nom d'utilisateurs zombie. Depuis le correctif post-Service Pack 3 de mars 2003 d'Exchange 2000 Server, le comportement par défaut pour le traitement des utilisateurs zombie est modifié. Vous pouvez contrôler ce comportement en utilisant la clé de Registre Ignore Zombie users.

La valeur de Registre Ignore Zombie users peut être utilisée sur des serveurs sur lesquels Exchange 2000 Server Service Pack 3 ou version ultérieure est installé. Vous devez utiliser attentivement cette entrée de Registre et seulement si vous êtes sûr que les utilisateurs zombie ne sont pas le résultat de problèmes de réplication ADC (Active Directory Connector), tels que la latence. Cette valeur de Registre permet à Exchange Server d'ignorer les utilisateurs zombie et de les supprimer de la liste de contrôle d'accès des boîtes aux lettres ou des dossiers publics. Si l'utilisateur est valide mais s'il ne se trouve pas dans Active Directory au moment de la mise à niveau de la liste de contrôle d'accès, celui-ci est supprimé et vous devez l'ajouter à chaque liste de contrôle d'accès manuellement et ultérieurement.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, recherchez la valeur Ignore Zombie users et supprimez-la.

  4. Fermez l'Éditeur du Registre, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la clé de Registre Ignore Zombie Users, voir les articles suivants de la Base de connaissances :

  • 812963 sur l'utilisation de la clé de Registre Ignore Zombie Users (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963)

  • 324323 sur la manière d'ignorer les comptes d'utilisateurs qui ne sont pas représentés dans Active Directory pendant la conversion de la liste de contrôle d'accès (http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323)


Le traitement des exceptions IMAIL a été désactivé manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur de Registre ExceptionHandling :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Si Exchange Server Analyzer détecte que la valeur de Registre ExceptionHandling est configurée avec une valeur 0, un avertissement s'affiche.

Dans Exchange Server, le traitement des exceptions IMAIL est activé par défaut et ne peut pas être désactivé via l'interface utilisateur. Le traitement des exceptions IMAIL peut toutefois être désactivé à l'aide du Registre.

Microsoft recommande que la gestion des exceptions IMAIL reste activée sauf si vous êtes en train de résoudre activement un problème. Par exemple, vous pourriez désactiver le traitement des exceptions IMAIL en présence d'applications personnalisées qui déclenchent des événements basés sur un contenu MIME (Multipurpose Internet Mail Extensions) ou MAPI incorrect. Microsoft recommande que la gestion des exceptions IMAIL ne soit désactivée que sur les conseils et les instructions des techniciens des services de support technique Microsoft.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Correction de cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent.

  3. Double-cliquez sur ExceptionHandling :

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre ExceptionHandling, consultez l'article 832174 de la Base de connaissances sur l'impossibilité de désactiver le traitement des exceptions IMAIL dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174).


Le service de banque d'informations est configuré de manière à interagir avec le Bureau
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la propriété DesktopInteract pour le service de banque d'informations de Microsoft Exchange (MSExchangeIS). Si Exchange Server Analyzer détecte que le service de banque d'informations de Microsoft Exchange est configuré de manière à interagir avec le Bureau, il affiche une erreur.

Cette configuration ne doit être utilisée que sur recommandation des services du Support Technique de Microsoft. À moins que les services du Support Technique de Microsoft vous aient demandé d'exécuter le service de banque d'informations de Microsoft Exchange dans cette configuration, il est conseillé de reconfigurer les propriétés de ce service de manière à ce qu'il n'interagisse pas avec le Bureau.

Pour configurer le compte du service de banque d'informations d'Exchange

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Recherchez et arrêtez le service Banque d'informations de Microsoft Exchange.

  3. Double-cliquez sur le service Banque d'informations de Microsoft Exchange.

  4. Sous l'onglet Ouvrir une session de la page Propriétés de Banque d'informations de Microsoft Exchange, sélectionnez Compte LocalSystem dans Ouvrir une session en tant que.

  5. Désactivez la case à cocher Autoriser le service à interagir avec le Bureau, puis cliquez sur Appliquer.

  6. Sous Statut du service, cliquez sur Démarrer, puis sur OK.

  7. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur la configuration correcte du service Exchange, voir l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Augmentation de la taille maximale de base de données pour une banque de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_DataFile pour déterminer les informations suivantes :

  • le chemin d'accès complet aux fichiers de base de données Exchange ;

  • la taille actuelle de la banque de boîtes aux lettres.

Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer :

  • la version du système d'exploitation Windows exécutée sur le serveur Exchange ;

  • la version d'Exchange Server installée ;

  • l'édition d'Exchange Server installée ;

  • la version du Service Pack pour Exchange Server.

Enfin, Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si la valeur Database Size in Gb a été définie :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Private-<GUID de banque de boîtes aux lettres>

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le serveur exécute Exchange Server 2003.

  • Le Service Pack 2 pour Exchange Server 2003 est installé.

  • La taille de la base de données Exchange Server est supérieure à 16 gigaoctets (Go).

  • La valeur de Registre Database Size in Gb n'a pas été définie.

Cette erreur indique que la taille de la base de données Exchange identifiée approche de la limite. Le Service Pack 2 pour Exchange Server 2003 augmente la limite de stockage de la base de données de 16 à 75 Go. Toutefois, pour utiliser les nouvelles limites, vous devez ajouter manuellement la valeur de Registre Database Size in Gb sur Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour corriger cette erreur en ajoutant la valeur de Registre Database Size in Gb

  1. Sur l'ordinateur Exchange Server, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Private-<GUID de banque de boîtes aux lettres>

  3. Cliquez avec le bouton droit sur GUID de banque de boîtes aux lettres, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Pour le nom de la nouvelle valeur, entrez Database Size Limit in Gb.

  5. Double-cliquez sur Database Size Limit in Gb. Dans Données de la valeur, entrez une valeur appropriée pour la taille de base de données maximale en Go. Cliquez sur OK.

  6. Cliquez avec le bouton droit sur GUID de banque de boîtes aux lettres, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  7. Pour le nom de la nouvelle valeur, entrez Database Size Buffer in Percentage.

  8. Double-cliquez sur Database Size Buffer in Percentage. Dans Données de la valeur, entrez une valeur comprise entre 1 et 100 pour spécifier le moment d'enregistrement des événements pour vous avertir que vous approchez de la taille maximale pour une base de données. Cliquez sur OK.

    Remarque :
    La valeur par défaut 10 permet d'enregistrer des événements d'avertissement lorsqu'il vous reste une capacité de 10 pour cent avant d'atteindre la taille maximale de cette base de données.

  9. Cliquez avec le bouton droit sur GUID de banque de boîtes aux lettres, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  10. Pour le nouveau nom, entrez Database Size Check Start Time in Hours From Midnight.

  11. Double-cliquez sur Database Size Check Start Time in Hours From Midnight. Dans Données de la valeur, entrez une valeur comprise entre 0 et 23 pour spécifier le moment auquel Exchange doit vérifier la taille de la base de données. Cliquez sur OK.

    Remarque :
    Avec la valeur par défaut 5, Exchange Server vérifie la taille de la base de données 5 heures après minuit (05:00).

  12. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la procédure de configuration et de gestion des limites de taille de base de données Exchange Server, voir la rubrique sur la configuration et la gestion de la limite de taille de base de données (http://go.microsoft.com/fwlink/?LinkId=57029).

Pour plus d'informations sur la taille de base de données maximale pour Exchange Server 2003 Édition Standard et Exchange 2000 Server Édition Standard, voir l'article 828070 de la Base de connaissances sur la banque de boîtes aux lettres Exchange Server qui n'est pas montée si sa base de données atteint la limite de 16 Go (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir sur le site Web sur Exchange Server 2003 Service Pack 2 l'article sur les raisons d'essayer le Service Pack 2 pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Augmentation de la taille maximale de base de données pour une banque de dossiers publics
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_DataFile pour déterminer les informations suivantes :

  • le chemin d'accès complet aux fichiers de base de données Exchange Sever ;

  • la taille actuelle de la banque de dossiers publics.

Exchange Server Analyzer interroge également la classe WMI Win32_OperatingSystem pour déterminer :

  • la version du système d'exploitation Windows exécutée sur le serveur Exchange ;

  • la version d'Exchange Server installée ;

  • l'édition d'Exchange Server installée ;

  • la version du Service Pack pour Exchange Server.

Enfin, Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si la valeur Database Size in Gb a été définie :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de banque publique>

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le serveur exécute Exchange Server 2003.

  • Le Service Pack 2 pour Exchange Server 2003 est installé.

  • La taille de la base de données Exchange est supérieure à 16 gigaoctets (Go).

  • La valeur de Registre Database Size in Gb n'a pas été définie.

Cette erreur indique que la taille de la base de données Exchange Server identifiée approche de la limite. Le Service Pack 2 pour Exchange Server 2003 augmente la limite de stockage de la base de données de 16 à 75 Go. Toutefois, pour utiliser les nouvelles limites, vous devez ajouter manuellement la valeur de Registre Database Size in Gb sur Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour corriger cette erreur en ajoutant la valeur de Registre Database Size in Gb

  1. Sur l'ordinateur Exchange Server, ouvrez un Éditeur du Registre, comme Regedit.exe ou RegEdt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de banque publique>

  3. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Pour le nom de la nouvelle valeur, entrez Database Size Limit in Gb.

  5. Double-cliquez sur Database Size Limit in Gb. Dans Données de la valeur, entrez une valeur appropriée pour la taille de base de données maximale en Go. Cliquez sur OK.

  6. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  7. Pour le nom de la nouvelle valeur, entrez Database Size Buffer in Percentage.

  8. Double-cliquez sur Database Size Buffer in Percentage. Dans Données de la valeur, entrez une valeur comprise entre 1 et 100 pour spécifier le moment d'enregistrement des événements pour vous avertir que vous approchez de la taille maximale pour une base de données. Cliquez sur OK.

    Remarque :
    La valeur par défaut 10 permet d'enregistrer des événements d'avertissement lorsqu'il vous reste une capacité de 10 pour cent avant d'atteindre la taille maximale de cette base de données.

  9. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  10. Pour le nouveau nom, entrez Database Size Check Start Time in Hours From Midnight.

  11. Double-cliquez sur Database Size Check Start Time in Hours From Midnight. Dans Données de la valeur, entrez une valeur comprise entre 0 et 23 pour spécifier le moment auquel Exchange doit vérifier la taille de la base de données. Cliquez sur OK.

    Remarque :
    Avec la valeur par défaut 5, Exchange Server vérifie la taille de la base de données 5 heures après minuit (05:00).

  12. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la procédure de configuration et de gestion des limites de taille de base de données Exchange, voir la rubrique sur la configuration et la gestion de la limite de taille de base de données (http://go.microsoft.com/fwlink/?LinkId=57029).

Pour plus d'informations sur la taille de base de données maximale pour Exchange Server 2003 Édition Standard et Exchange 2000 Server Édition Standard, voir l'article 828070 de la Base de connaissances sur la banque de boîtes aux lettres Exchange Server qui n'est pas montée si sa base de données atteint la limite de 16 Go (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir sur le site Web sur Exchange Server 2003 Service Pack 2 l'article sur les raisons d'essayer le Service Pack 2 pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=52073).


Augmentation du paramètre relatif aux tampons de journal des journaux des transactions
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que le nombre de tampons de journal sur votre serveur est trop peu élevé. L'outil a détecté que la valeur Base de données (Instance de banque d'informations)\Enregistrements journal inachevés/s pour votre serveur est supérieure à 10 blocages par seconde. Une valeur supérieure à 10 indique qu'une écriture de sauvegarde est en cours dans le journal des transactions. Cette situation peut se produire lorsque le lecteur du journal des transactions est sous sa capacité de débit ou lorsque les tampons du journal sont définis sur une valeur trop faible.

Les E/S d'écriture de journal sont séquentielles et mono-thread. La latence sur les E/S de journal représente donc souvent un goulot d'étranglement dans le système. Les E/S de journal sont écrites en premier lieu dans les tampons du journal, puis le tampon est effacé par une allocation de capacité ou une allocation non paresseuse. Une allocation non paresseuse signifie que le tampon de journal est écrit immédiatement sur le disque. Une allocation de capacité signifie que le tampon de journal est écrit sur le disque lorsque le tampon est complet.

L'augmentation de la taille du tampon de journal réduit la fréquence des vidages, accroît la taille d'écriture du journal et réduit en conséquence la latence d'écriture de journal globale. La réduction de la latence d'écriture d'E/S constitue une importante méthode d'amélioration des performances et de l'évolutivité du déploiement Exchange.

La recommandation générale consiste à augmenter la taille du tampon à la valeur maximale de 9 000 pour Exchange Server 2003 et à 512 pour Exchange 2000 Server.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour supprimer cet avertissement

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=Nom_organisation_Exchange.

  3. Développez CN=Groupes_administration, CN=Nom_groupe_administration, puis CN=Serveurs.

  4. Développez CN=Nom_serveur et CN=Banque_informations, cliquez avec le bouton droit sur CN=Nom_groupe_stockage, puis cliquez sur Propriétés.

  5. Dans la zone Sélectionnez une propriété à afficher, cliquez sur msExchESEParamLogBuffers.

  6. Dans la zone Modifier l'attribut, entrez la valeur appropriée à votre version d'Exchange pour msExchESEParamLogBuffers, puis cliquez sur Définir.

    Remarque :
    Pour les ordinateurs exécutant Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1), Exchange 2000 Server SP2 ou Exchange 2000 SP3, définissez cette valeur sur 512. Pour les ordinateurs exécutant la version originale d'Exchange Server 2003 ou d'Exchange Server 2003 SP1, définissez la valeur sur 9 000.

  7. Cliquez sur Appliquer, puis sur OK.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur l'utilisation de la mise en mémoire tampon de journal, voir l'article de la Base de connaissances Microsoft sur les tampons du journal ESE qui sont définis sur une valeur trop faible et peuvent entraîner l'arrêt des réponses de la part du service de banque d'informations de Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466).


La valeur Initial Memory Percentage a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur Initial Memory Percentage a été définie :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la valeur de Initial Memory Percentage est présente et configurée avec toute valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Le paramètre de Registre Initial Memory Percentage a été introduit comme mécanisme de réglage fin de la quantité initiale de mémoire allouée à la banque d'informations Exchange sur 10 pour cent de la mémoire physique totale du serveur Exchange. En commençant par cette allocation initiale, puis en l'augmentant, la fragmentation de mémoire virtuelle ne se produit pas aussi fréquemment. Cette valeur de Registre ne doit pas être définie arbitrairement et ne peut être utilisée que sur les conseils et les instructions des services de support technique Microsoft.

Exchange Server 2003 et les versions ultérieures incluent la prise en charge de commutateurs de démarrage spéciaux dans Microsoft Windows® 2000 Advanced Server et Windows Server™ 2003, qui permettent de réduire la fragmentation de mémoire virtuelle. Des modifications supplémentaires ont été apportées pour empêcher la fragmentation de mémoire virtuelle dans les clusters d'Exchange Server. Par conséquent, la valeur de Registre Initial Memory Percentage n'est plus nécessaire sur Exchange Server 2003 ou les versions ultérieures.

La valeur de Registre Initial Memory Percentage ne fonctionne que sur les ordinateurs exécutant Exchange 2000 Server. Exchange Server 2003 et Exchange Server 2007 ignorent cette valeur si elle est présente et celle-ci n'a aucun effet. Par conséquent, vous devriez supprimer cette entrée de Registre avant d'effectuer la mise à niveau de ce serveur Exchange à partir d'Exchange 2000 Server vers Exchange Server 2003.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Suppression du paramètre de Registre Initial Memory Percentage

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, supprimez la valeur Initial Memory Percentage.

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.
  • Pour plus d'informations sur un problème connu lors de l'utilisation de cette valeur de Registre, consultez l'article 810883 de la Base de connaissances Microsoft sur l'absence d'effet de la valeur de Registre Initial Memory Percentage (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883).

  • Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).


L'entrée de Registre Initial Reserve Size KB a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-04-27

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'entrée de Registre Initial Reserve Size KB est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la valeur de Registre Initial Reserve Size KB est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre Initial Reserve Size KB est utilisée pour mettre de côté la mémoire supplémentaire pour l'espace de tas. La valeur spécifiée est exprimée en kilo-octets. La valeur par défaut sur la plupart des serveurs Exchange est 655360 kilo-octets (Ko), ce qui équivaut à 640 mégaoctets (Mo). Vous pouvez réduire cette valeur pour augmenter la quantité de mémoire libre disponible et diminuer la fragmentation de mémoire virtuelle. Cette valeur ne doit être définie que sur les conseils et les instructions des techniciens des services du Support Technique de Microsoft. Ce message est fourni à titre indicatif et aucune action corrective ne doit être prise si l'entrée de Registre a été ajoutée sur les conseils des techniciens des services du Support Technique de Microsoft.

Si vous pensez que cette entrée n'a pas été définie correctement, vous pouvez la supprimer et rétablir la configuration par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir les paramètres de configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

  3. Supprimez la valeur appelée Initial Reserve Size KB.

  4. Fermez l'Éditeur du Registre, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le dépannage de fragmentation de mémoire virtuelle, voir l'article de la Base de connaissances sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


L'attribut legacyExchangeDN pour cette base de données Exchange ne correspond pas au serveur Exchange
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut legacyExchangeDN pour toutes les bases de données de banques de boîtes aux lettres sur un ordinateur Exchange Server. Si Exchange Server Analyzer détecte que la valeur de l'attribut legacyExchangeDN de toutes les banques de boîtes aux lettres ne correspond pas à l'ordinateur Exchange Server contenant la banque de boîtes aux lettres, une erreur s'affiche.

Un legacyExchangeDN non concordant peut résulter de la modification d'Active Directory par un administrateur pour récupérer une base de données dans une situation de récupération d'urgence. Pour corriger cette erreur, vous devez modifier l'attribut legacyExchangeDN à l'aide d'un éditeur Active Directory, tel que l'outil LDP (ldp.exe) ou ADSI Edit.

Pour vous assurer que l'attribut legacyExchangeDN est correct, examinez l'attribut legacyExchangeDN du serveur sur lequel cette base de données réside car, cette base de données étant un objet enfant de ce serveur, elle aura le même attribut legacyExchangeDN.

Vous devez également examiner les autres bases de données du serveur Exchange qui n'ont pas généré cette erreur puisqu'elles doivent avoir le même attribut legacyExchangeDN. Sachez que plusieurs autres objets système ont également cet attribut. Si l'attribut legacyExchangeDN ne concorde pas avec une base de données, il est probable que l'attribut ne concorde pas non plus avec plusieurs autres objets système. Si vous utilisez LDP ou ADSI Edit pour corriger une valeur legacyExchangeDN, vous devez par conséquent le faire pour tous les autres objets système également.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Correction de cette erreur

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Développez Configuration [Nom_domaine], puis CN=Configuration,DC=Nom_domaine,DC=Suffixe_domaine.

  3. Développez CN=Services, puis CN=Microsoft_Exchange.

  4. Développez CN=Nom_organisation, CN=Groupes_administration, puis CN=Nom_groupe_administration.

  5. Développez CN=Serveurs, CN=Nom_serveur, puis CN=Banque_informations.

  6. Sélectionnez CN=Nom_groupe_stockage, puis, dans le volet droit, cliquez avec le bouton droit sur la banque de boîtes aux lettres dont l'attribut legacyExchangeDN ne concorde pas et cliquez sur Propriétés.

  7. Faites défiler jusque legacyExchangeDN, sélectionnez-le et cliquez sur Modifier.

  8. Dans le champ Valeur, entrez l'attribut legacyExchangeDN correct.

  9. Fermez l'Éditeur Active Directory et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit pour créer un nouvel attribut legacyExchangeDN, consultez l'article 273863 de la Base de connaissances Microsoft sur la procédure de modification de l'attribut LegacyExchangeDN en mode natif avec ADSI Edit (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863).


La valeur legacyExchangeDN de cette base de données Exchange est manquante
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut legacyExchangeDN pour toutes les bases de données de banques de boîtes aux lettres sur un ordinateur Exchange Server. Si Exchange Server Analyzer ne détecte aucune valeur pour l'attribut legacyExchangeDN sur les banques de boîtes aux lettres, une erreur s'affiche.

Une valeur legacyExchangeDN manquante peut résulter de la modification d'Active Directory par un administrateur pour récupérer une base de données dans une situation de récupération d'urgence. Pour corriger cette erreur, vous devez modifier l'attribut legacyExchangeDN à l'aide d'un éditeur Active Directory, tel que l'outil LDP (ldp.exe) ou ADSI Edit.

Pour vous assurer que l'attribut legacyExchangeDN est correct, examinez l'attribut legacyExchangeDN du serveur sur lequel cette base de données réside car, cette base de données étant un objet enfant de ce serveur, elle aura le même attribut legacyExchangeDN.

Vous devez également examiner les autres bases de données du serveur Exchange qui n'ont pas généré cette erreur puisqu'elles doivent avoir le même attribut legacyExchangeDN. Sachez que plusieurs autres objets système ont également cet attribut. Si l'attribut legacyExchangeDN est manquant sur une base de données, il est probable qu'il le soit également sur plusieurs autres objets système. Si vous utilisez LDP ou ADSI Edit pour ajouter une nouvelle valeur legacyExchangeDN, vous devez par conséquent le faire pour tous les autres objets système également.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Correction de cette erreur

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Développez Configuration [Nom_domaine], CN=Configuration,DC=Nom_domaine,DC=Suffixe_domaine.

  3. Développez CN=Services, puis CN=Microsoft_Exchange.

  4. Développez CN=Nom_organisation, CN=Groupes_administration, puis CN=Nom_groupe_administration.

  5. Développez CN=Serveurs, CN=Nom_serveur, puis CN=Banque_informations.

  6. Sélectionnez CN=Nom_groupe_stockage, puis, dans le volet droit, cliquez avec le bouton droit sur la banque de boîtes aux lettres dont l'attribut legacyExchangeDN est manquant et cliquez sur Propriétés.

  7. Faites défiler jusque legacyExchangeDN, sélectionnez-le et cliquez sur Modifier.

  8. Dans le champ Valeur, entrez l'attribut legacyExchangeDN correct.

  9. Fermez l'Éditeur Active Directory et redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit pour créer un nouvel attribut legacyExchangeDN, consultez l'article 273863 de la Base de connaissances Microsoft sur la procédure de modification de l'attribut LegacyExchangeDN en mode natif avec ADSI Edit (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863).


Le paramètre LimitBodyParts a été défini manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la limite par défaut pour les pièces jointes dans un message a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

Si Exchange Server Analyzer détecte que l'entrée de Registre LimitBodyParts est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

De conception et pour des raisons de sécurité, Exchange Server limite le nombre de pièces jointes à 250 (désignées en tant que parties de corps). Si un message contient plus de 250 pièces jointes, une erreur MAPI_E_TOO_BIG s'affiche. En outre, le service de banque d'informations Microsoft Exchange risque d'utiliser une part excessive de mémoire et de ressources de processeur lors du traitement de messages comportant de nombreuses pièces jointes.

Il existe une opportunité de configuration qui permet aux administrateurs d'ajouter la valeur de Registre LimitBodyParts et de la configurer pour pouvoir utiliser une valeur supérieure à 250. À défaut, la valeur par défaut de 250 est utilisée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour afficher ou modifier la valeur de Registre LimitBodyParts

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Examinez et, au besoin, modifiez la valeur LimitBodyParts. Une valeur acceptable pour cette valeur de Registre est tout nombre entier entre 250 et 4294967295.

  4. Si une modification est effectuée, redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le paramètre LimitEmbeddingDepth a été défini manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-30

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les limites d'en-tête MIME par défaut dans Exchange ont été modifiées :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Si Exchange Server Analyzer détecte qu'une valeur a été définie pour LimitEmbeddingDepth, un message indiquant une configuration autre que celle par défaut s'affiche.

Exchange 2000 Server Service Pack 3, Exchange Server 2003 et Exchange Server 2007 incluent la fonctionnalité mise à jour dans le processus store (store.exe) qui définit la gestion des messages MIME volumineux ou incorrectement formulés. Cette fonctionnalité a été ajoutée pour protéger Exchange Server contre les attaques par déni de service par des messages MIME nuisibles et involontairement grands et complexes. Voici quelques exemples des limites imposées aux messages MIME soumis à la banque : limitation du nombre de destinataires, limitation du nombre de messages incorporés et limitation de la taille des en-têtes MIME individuels.

Les valeurs par défaut de ces limites d'en-tête MIME sont définies dans le processus store. Toutefois, si une clé de Registre a été définie pour fixer l'une de ces limites, la clé de Registre remplacera la valeur store.exe par défaut. Lorsque l'une des limites est dépassée dans un message MIME, une notification d'échec de remise est envoyée à l'expéditeur.

Limiter la profondeur d'incorporation des messages MIME fait référence au nombre de messages MIME qui peuvent être incorporés les uns dans les autres. Supposons, par exemple, que vous recevez un message (m1) avec un message joint (m2). Lorsque vous ouvrez le message joint (m2), vous trouvez qu'un autre message (m3) est également joint à ce message (m2). Par conséquent, le message d'origine (m1) présente 3 niveaux de messages incorporés. Par défaut, Exchange autorise des messages avec un niveau de profondeur d'incorporation de 100. Les messages avec des messages incorporés sur plus de 100 niveaux peuvent utiliser la totalité de la mémoire sur un serveur Exchange pendant le temps nécessaire à ce dernier pour ouvrir le message, l'analyser et le convertir au format MAPI. Il est hautement improbable qu'un serveur ou client de messagerie génère un message avec une telle profondeur de messages incorporés. Ce type de message provient plus probablement d'utilisateurs malveillants tentant une attaque par déni de service sur votre système de messagerie.

Rétablissement de la configuration par défaut

  • Aucune action ne doit être entreprise. Cette entrée de Registre ne sera présente qu'après l'installation du correctif de l'article 833607 de la Base de connaissances Microsoft sur l'utilisation à 100 % des ressources processeur du service Banque d'informations Microsoft Exchange sur Exchange 2000 Server ou Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607). Ce correctif crée l'entrée de Registre LimitEmbeddingDepth et lui attribue une valeur de 10.

Pour plus d'informations sur les Service Packs et correctifs d'Exchange Server, consultez l'article 328839 de la Base de connaissances sur la procédure d'application des Service Packs et des correctifs d'Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839).


Le paramètre LimitNestingLevels a été défini manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les limites d'en-tête MIME (Multipurpose Internet Mail Extensions) par défaut dans Exchange ont été modifiées :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Si Exchange Server Analyzer détecte qu'une valeur a été définie pour LimitNestingLevels, un message indiquant une configuration autre que celle par défaut s'affiche.

Les parties de corps de message MIME d'un élément de message peuvent être imbriquées. Si le niveau d'imbrication est élevé, le processus de conversion nécessite de plus en plus de ressources pour décoder l'ensemble du message. Un seul message avec un corps MIME imbriqué dans 700 niveaux peut prendre 10 minutes pour être traité. Lorsque vous recevez des messages à partir d'Internet avec des parties de corps de message MIME imbriquées, le processus de conversion de ces parties peut entraîner un ralentissement de la remise de ces messages. Au fur et à mesure de la remise des messages, le serveur requiert une grande quantité de ressources système, de mémoire en particulier. Si ces messages sont reçus simultanément en grande quantité, le système peut signaler qu'il manque de mémoire virtuelle.

La limitation des niveaux d'imbrication de MIME renvoie au nombre de types de contenus MIME (tel que multiple/mixte ou multiple/alternatif) qui peuvent être imbriqués l'un dans d'autre. Les messages générés par la plupart des clients de messagerie électronique (notamment Microsoft Outlook® et Outlook Express) et serveurs de messagerie électronique contiennent très peu de types de contenus MIME imbriqués. Par exemple, un message standard (même avec plusieurs réponses) ne sera représenté dans un message MIME que sous un seul type de contenu. Plusieurs niveaux d'imbrication résultent généralement d'un processus automatisé qui crée des messages MIME pour des utilisations spécifiques (telles qu'une application de workflow) ou un message malveillant construit avec l'intention spécifique d'utiliser des ressources sur le serveur de messagerie.

En plus d'appliquer des niveaux d'imbrication liés au type de contenu, Exchange Server utilisera la valeur LimitNestingLevels pour appliquer une limite aux messages incorporés (qu'elle soit définie comme une valeur de Registre ou une valeur par défaut dans le processus store). Si la valeur de Registre LimitNestingLevels n'est pas définie, la valeur par défaut de 30 niveaux d'imbrication est appliquée. La limite des messages incorporés est définie par la multiplication de la valeur LimitNestingLevels par 16. Par conséquent, la valeur par défaut du nombre de messages incorporés est 480. Par exemple, si LimitNestingLevels est configuré avec une valeur de 5, un nombre maximal de 80 pièces jointes est accepté.

Pour rétablir la configuration par défaut

  • Aucune action ne doit être entreprise. Exchange Server Analyzer affiche une configuration autre que celle par défaut pour vos informations.

Pour plus d'informations sur un correctif Exchange 2000 Server lié à la valeur de Registre LimitNestingLevels, voir l'article 289775 de la Base de connaissances Microsoft sur les pertes de mémoires d'Exchange 2000 Server lorsqu'un grand nombre de messages sont imbriqués (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775).


Le paramètre LimitRecipients a été défini manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les limites d'en-tête MIME par défaut dans Exchange ont été modifiées :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Si Exchange Server Analyzer détecte qu'une valeur a été définie pour LimitRecipients, un message indiquant une configuration autre que celle par défaut s'affiche.

Exchange 2000 Server Service Pack 2 (SP2) et les versions ultérieures d'Exchange Server incluent la fonctionnalité mise à jour dans le processus store (store.exe) qui définit la gestion des messages MIME volumineux ou incorrectement formulés. Cette fonctionnalité a été ajoutée pour mieux protéger Exchange Server contre les attaques par déni de service de messages MIME nuisibles et involontairement volumineux et complexes. Voici quelques exemples des limites imposées aux messages MIME soumis à la banque : limitation du nombre de destinataires, limitation du nombre de messages incorporés et limitation de la taille des en-têtes MIME individuels. Dans les versions précédentes d'Exchange, où des en-têtes MIME illimités peuvent entrer dans la banque Exchange pour y être traités, des messages MIME très volumineux ou complexes peuvent consommer la quasi-totalité des ressources (essentiellement le processeur) à la suite des opérations d'analyse, d'indexation et de traitement des messages MIME.

Les valeurs par défaut de ces limites d'en-tête MIME sont définies dans le processus store. Toutefois, si une clé de Registre a été définie pour fixer l'une de ces limites, la clé de Registre remplacera la valeur store.exe par défaut. Lorsque l'une des limites est dépassée dans un message MIME, une notification d'échec de remise est envoyée à l'expéditeur.

Si la clé de Registre LimitRecipients a été définie, il s'agit probablement du résultat des conseils des services de support technique Microsoft, étant donné que cette clé n'a pas été publiée. À ce titre, Microsoft recommande de ne pas modifier ce paramètre.

La valeur par défaut de LimitRecipients (en l'absence de clé de Registre) dans le processus store est de 65 535 destinataires par message MIME.


Les tampons de journal ne sont pas optimisés pour les serveurs avec capacité de disque répliquée qui exécutent Exchange Server 2003
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si les conditions suivantes sont vraies :

  • L'ordinateur exécute Exchange Server 2003.

  • La valeur de msExchESEParamLogBuffers est comprise entre 0 et 8 960.

Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeIS_MSExchangeIS pour déterminer si la condition suivante est vraie :

  • La valeur de VMLargestBlockSize est supérieure à 150 000 000.

Exchange Server Analyzer détermine si les services suivants sont exécutés :

  • GeoSpanService ;

  • SRDFService.

Si toutes les conditions ci-dessus sont remplies, une erreur s'affiche.

ESE (Extensible Storage Engine) utilise des tampons de journal pour conserver les transactions en mémoire avant de les enregistrer dans les journaux de transactions. Si les tampons de journal ne sont pas suffisamment nombreux, un nombre excessif d'E/S disque risque d'apparaître dans le lecteur du journal des transactions, ce qui ralentirait les performances.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour corriger cette erreur

  1. Dans ADSI (Active Directory Service Interfaces) Edit, double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=Nom_organisation_Exchange.

  2. Développez CN=Groupes_administration, CN=Nom_groupe_administration, puis CN=Serveurs.

  3. Développez CN=Nom_serveur et CN=Banque_informations, cliquez avec le bouton droit sur CN=Nom_groupe_stockage, puis cliquez sur Propriétés.

  4. Dans la zone Sélectionnez une propriété à afficher, cliquez sur msExchESEParamLogBuffers.

  5. Dans la zone Modifier l'attribut, entrez 9 000 pour msExchESEParamLogBuffers, puis cliquez sur Définir.

  6. Cliquez sur Appliquer, puis sur OK.

  7. Pour que la modification soit prise en compte, vous devez redémarrer le service de banque d'informations de Microsoft Exchange.

Pour plus d'informations, voir l'article 328466 de la Base de connaissances Microsoft sur les tampons du journal ESE qui sont définis sur une valeur trop faible et peuvent entraîner l'arrêt des réponses de la part du service de la banque d'informations de Microsoft Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Les tampons du journal risquent de ne pas suffire pour les serveurs présentant de très nombreuses boîtes aux lettres et exécutant Exchange Server 2003
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-03-27

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si les conditions suivantes sont vraies :

  • L'ordinateur exécute Exchange Server 2003.

  • La valeur de msExchESEParamLogBuffers est comprise entre 0 et 8 960.

  • Le nombre de boîtes aux lettres dans le groupe de stockage est supérieur à 500.

Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeIS_MSExchangeIS pour déterminer si la condition suivante est vraie :

  • La valeur de VMLargestBlockSize est supérieure à 150 millions.

Si toutes ces conditions sont vraies, un avertissement s'affiche.

ESE (Extensible Storage Engine) utilise des tampons de journal pour conserver les transactions en mémoire avant de les enregistrer dans les journaux de transactions. Si les tampons de journal ne sont pas suffisamment nombreux, un nombre excessif d'E/S disque risque d'apparaître dans le lecteur du journal des transactions, ce qui ralentirait les performances.

Correction de cet avertissement

  1. Dans ADSI (Active Directory Service Interfaces) Edit, double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=Nom_organisation_Exchange.

  2. Développez CN=Groupes_administration, CN=Nom_groupe_administration, puis CN=Serveurs.

  3. Développez CN=Nom_serveur et CN=Banque_informations, cliquez avec le bouton droit sur CN=Nom_groupe_stockage, puis cliquez sur Propriétés.

  4. Dans la zone Sélectionnez une propriété à afficher, cliquez sur msExchESEParamLogBuffers.

  5. Dans la zone Modifier l'attribut, entrez 9 000 pour msExchESEParamLogBuffers, puis cliquez sur Définir.

  6. Cliquez sur Appliquer, puis sur OK.

  7. Pour que la modification soit prise en compte, vous devez redémarrer le service Banque d'informations Microsoft Exchange.
Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour plus d'informations, voir l'article 328466 de la Base de connaissances Microsoft sur les tampons du journal ESE qui sont définis sur une valeur trop faible et peuvent entraîner l'arrêt des réponses de la part du service de la banque d'informations de Microsoft Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466).


Fichiers journaux stockés sur le lecteur réseau
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamLogFilePath de chaque objet de groupe de stockage. Cet attribut spécifie l'emplacement des fichiers du journal des transactions utilisés par les bases de données du groupe de stockage.

En outre, Exchange Server Analyzer interroge Active Directory pour déterminer le nombre des entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détecte que l'attribut msExchESEParamLogFilePath commence par \\ sur un Exchange Server comprenant plus de 50 boîtes aux lettres, une erreur s'affiche.

Cette erreur indique que les fichiers du journal des transactions d'un groupe de stockage sont stockés sur un partage réseau. Si l'attribut msExchESEParamLogFilePath commence par \\, cela indique que le chemin d'accès au fichier journal utilise un chemin d'accès UNC (Universal Naming Convention). Cette manière de procéder n'est pas recommandée étant donné que les interruptions de la connectivité réseau pourraient engendrer des erreurs de base de données et du journal des transactions, se traduisant par une perte de données ou des bases de données endommagées. Il est recommandé de résoudre ce problème au plus vite.

Pour corriger cette erreur

  • Déplacez les journaux des transactions du partage réseau vers un disque local. Pour une optimisation des performances, placez tous les journaux des transactions sur des lecteurs distincts.

Pour plus d'informations sur la procédure de déplacement des journaux des transactions, voir l'article 239944 de la Base de connaissances Microsoft sur la procédure de déplacement des fichiers journaux de transactions ou des fichiers journaux système dans un autre emplacement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944).


Incohérence de génération de journaux
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé une incohérence de génération de fichiers journaux. Cette erreur indique qu'un fichier journal de transactions a été renommé à l'aide d'un numéro de séquence inapproprié.

Les fichiers journaux de transactions Exchange sont nommés en fonction du format suivant : EnnXXXXX.log

  • XXXXX = numéro de séquence hexadécimal à cinq chiffres. Lorsqu'un nouvel ensemble de fichiers journaux de transactions est généré, le premier journal de la séquence s'appelle 000001, le suivant 00002, etc. Étant donné que chaque enregistrement de journal des transactions possède son propre numéro de séquence dans l'en-tête, vous pouvez déterminer si le nom du fichier journal a été modifié.

  • Enn = Préfixe du journal constitué d'une séquence de trois caractères partagée par chaque journal des transactions pour ce groupe de stockage. Généralement, le préfixe est E00, E01, E02, E03 ou R00 (pour un groupe de stockage de récupération).

Le journal en cours d'écriture est nommé uniquement à l'aide du préfixe du journal. Ce journal ne possède pas de numéro de séquence avant d'être fermé et qu'un nouveau journal ne soit généré. Par conséquent, le fichier journal actuel peut s'appeler E00.log. Lorsque ce fichier journal est complet, il peut être renommé E0012345.log. Un nouveau journal E00.log peut être généré avec un numéro de séquence interne de 12346.

Pour corriger cette erreur

  • Renommez le fichier journal à l'aide du numéro de séquence approprié.
Pour afficher le numéro de séquence interne

  • Exécutez la commande suivante :

    C:\Program Files\Exchsrvr\Bin\Eseutil.exe /ML [nom du fichier journal]

    La valeur lGeneration du résultat de cette commande répertorie le numéro de séquence actuel du fichier journal.


Paires de journaux incohérentes
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que certains de vos fichiers journaux obligatoires sont incohérents. Cette erreur indique que les fichiers journaux ont peut-être été falsifiés, déplacés, copiés, renommés ou supprimés manuellement.

Pour corriger cette erreur

  • Pour une analyse avancée des fichiers journaux, contactez le Centre d'Aide et de Support de Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845).


Incohérence de signature de journal
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que la signature de journal dans un ou plusieurs fichiers journaux ne correspond pas à celle des autres fichiers journaux du même dossier.

Ce problème ne se pose que si les fichiers journaux ont été déplacés, supprimés ou désorganisés manuellement.

Remarque :
Il s'agit d'un scénario de récupération avancés et vous pouvez contacter le Centre d'Aide et de Support de Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845) avant sa mise en œuvre.

Chaque fichier journal de transactions Exchange est daté à l'aide d'une signature appelée Signature de journal. Cette signature identifie les différents fichiers journaux qui appartiennent à la même série de journaux. Chaque base de données Exchange enregistre la Signature de journal de la série de journaux de transactions à laquelle la base de données a été liée pour la dernière fois.

Les bases de données Exchange ont également une signature appelée Signature de base de données. Cette signature est générée lors de la création initiale d'une base de données. Si vous utilisez Eseutil pour défragmenter ou réparer une base de données, cette signature va changer car les processus de réparation et de défragmentation procèdent à des modifications dans les fichiers de base de données sans les enregistrer dans les journaux de transactions. Pour des questions d'enregistrement, la base de données résultant d'une opération de réparation ou de défragmentation est nouvelle ou différente.

Contrairement aux signatures de base de données, les signatures de journal ne se modifient jamais lors de la durée de vie d'une série de fichiers journaux.

Les fichiers journaux enregistrent les signatures de base de données de toutes les bases de données liées lors de la création du journal. Les bases de données enregistrent la signature de journal des séries de journaux les plus récentes auxquelles la base de données a été liée. Par conséquent, les signatures de base de données et de journal sont utiles pour mettre en correspondance les bases de données avec des fichiers journaux de transactions.

Vous pouvez détacher une base de données Exchange d'un ensemble de journaux et l'attacher à un autre. Pour ce faire, déplacez la base de données vers un autre groupe de stockage ou supprimez tous les journaux de transactions pour un groupe de stockage et commencez une nouvelle série de journaux.

Si une base de données est dans un état d'arrêt brutal, seuls les fichiers journaux de transactions dont les signatures correspondent aux signatures de journal dans l'en-tête de la base de données peuvent être relus avec succès dans la base de données. Dans un état d'arrêt brutal, une base de données est toujours attachée à un flux de journaux particulier et peut uniquement effectuer une récupération à l'aide de ce flux de journaux.

Si une base de données est dans un état de fermeture sain, vous pouvez lire les fichiers journaux de transactions dont les signatures ne correspondent pas à la signature de journal actuelle de l'en-tête de la base de données. Ce processus ne fonctionne que dans les circonstances suivantes :

  1. La base de données a été fermée correctement à la fin d'une séquence précédente de fichiers journaux.

  2. La base de données a ensuite été attachée à une nouvelle séquence de fichiers journaux de transactions et vous avez accès au journal des transactions dans lequel la base de données a d'abord été attachée au nouvel ensemble de journaux.

Pour corriger cette erreur

  • Vous devez connaître l'historique de la base de données et les circonstances dans lesquelles les journaux des transactions ont été générés par rapport à la base de données.

  • Dans ce cas, avant d'essayer la récupération, copiez toujours les fichiers journaux de transactions ou de base de données. Une tentative de récupération erronée peut modifier les fichiers journaux de transactions ou de base de données de manière à ce qu'une autre tentative de récupération soit impossible.

  • Ne relisez qu'un ensemble de journaux de transactions à la fois à l'aide de la base de données. Déplacez les autres journaux des transactions du dossier de récupération.

  • Si la base de données est en état d'arrêt brutal, vous devez tout d'abord relire avec succès les journaux de transactions auxquels la base de données est attachée et la mettre dans un état de fermeture sain. Vous devez ensuite pouvoir lire le second ensemble de fichiers journaux à l'aide de la base de données.

  • Si la base de données est dans un état de fermeture sain, vous ne pouvez pas examiner les journaux ou la base de données pour vérifier quel ensemble de journaux de transactions doit être relu.


L'ouverture de session a été restreinte à certains utilisateurs
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante sur l'ordinateur Exchange Server pour déterminer si la liste d'utilisateurs autorisés à se connecter à la banque d'informations Exchange a été limitée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

Si Exchange Server Analyzer détecte que la valeur de Registre Logon Only As est présente, un avertissement s'affiche.

La valeur de Registre Logon Only As est une valeur de chaînes multiples (REG_MULTI_SZ) contenant la liste des attributs legacyExchangeDN pour les comptes autorisés à ouvrir une session dans la banque d'informations Exchange. Cette valeur de Registre, qui n'est pas présente par défaut, est généralement ajoutée lors d'opérations de dépannage, de maintenance et de déplacement de boîtes aux lettres.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, supprimez la valeur de Registre Logon Only As.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Logon Only As, voir l'article 146764 de la Base de connaissances sur la limitation des ouvertures de session dans la banque d'informations (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764).

Pour plus d'informations sur la procédure de limitation des ouvertures de session durant les opérations de déplacement de boîtes aux lettres, voir l'article 218920 de la Base de connaissances sur la procédure à suivre pour empêcher les ouvertures de session durant les opérations de déplacement de boîtes aux lettres (http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920).


Valeur de Registre Lookup SID Cache Expire définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si l'entrée de Registre Lookup Sid Cache Expire est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • L'entrée de Registre Lookup Sid Cache Expire est présente.

  • L'entrée de Registre Lookup Sid Cache Expire possède une valeur autre que 3 600.

Sur les serveurs Exchange utilisant Exchange 2000 Server Service Pack 3 ou version ultérieure, la banque d'informations crée un cache contenant des identificateurs de sécurité (SID) et indique si le SID est un objet utilisateur ou de groupe. Ce cache est créé et rempli lors du premier accès à un dossier public. Une fois le cache rempli, tous les appels de recherche de SID de compte sont d'abord dirigés vers le cache de la banque d'informations. Si le SID ne s'y trouve pas, l'appel est transmis au contrôleur de domaine, puis les informations sur ce SID sont ajoutées au cache.

Par défaut, le cache est conservé une heure. S'il dépasse la valeur par défaut de 8 kilo-octets (Ko) d'entrées, les entrées plus anciennes du cache sont supprimées pour permettre d'enregistrer les nouvelles. Vous pouvez utiliser deux clés de Registre pour régler la durée (Lookup Sid Cache Expire) et la taille par défaut du cache (Lookup Sid Cache Size). Il est recommandé de ne pas modifier ces paramètres par défaut à moins d'être sûr que cela permettrait d'accroître les performances.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Dans le volet droit, recherchez la valeur Lookup Sid Cache Expire et supprimez-la. Si la valeur Lookup SID Cache Size est également définie, supprimez-la aussi.

  4. Quittez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Lookup Sid Cache Expire, voir l'article 328907 de la Base de connaissances Microsoft sur les mises à niveau de la liste de contrôle d'accès qui ralentissent les performances des dossiers publics et le correctif qui nécessite Exchange 2000 SP2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907).


Valeur de Registre Lookup SID Cache Size définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si l'entrée de Registre Lookup Sid Cache Size est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • L'entrée de Registre Lookup Sid Cache Size est présente.

  • L'entrée de Registre Lookup Sid Cache Size possède une valeur autre que 1 024.

Sur les serveurs Exchange utilisant Exchange 2000 Server Service Pack 3 ou version ultérieure, la banque d'informations crée un cache contenant des identificateurs de sécurité (SID) et indique si le SID est un objet utilisateur ou de groupe. Ce cache est créé et rempli lors du premier accès à un dossier public. Une fois le cache rempli, tous les appels de recherche de SID de compte sont d'abord dirigés vers le cache de la banque d'informations. Si le SID ne s'y trouve pas, l'appel est transmis au contrôleur de domaine, puis les informations sur ce SID sont ajoutées au cache.

Par défaut, le cache est conservé une heure. S'il dépasse la valeur par défaut de 8 kilo-octets (Ko) d'entrées, les entrées plus anciennes du cache sont supprimées pour permettre d'enregistrer les nouvelles. Vous pouvez utiliser deux clés de Registre pour régler la durée (Lookup Sid Cache Expire) et la taille par défaut du cache (Lookup Sid Cache Size). Il est recommandé de ne pas modifier ces paramètres par défaut à moins d'être sûr que cela permettrait d'accroître les performances.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Dans le volet droit, recherchez la valeur Lookup Sid Cache Size et supprimez-la. Si la valeur Lookup SID Cache Expire est également définie, supprimez-la aussi.

  4. Quittez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Lookup Sid Cache Size, voir l'article 328907 de la Base de connaissances Microsoft sur les mises à niveau de la liste de contrôle d'accès qui ralentissent les performances des dossiers publics et le correctif qui nécessite Exchange 2000 SP2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907).


L'événement d'erreur de mémoire virtuelle faible a été remplacé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le seuil d'enregistrement d'un événement concernant la fragmentation de mémoire virtuelle a été remplacé manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

Si Exchange Server Analyzer détecte que la valeur de Registre VM Error Level est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Dans les systèmes Microsoft Windows® 32 bits, il existe deux types de mémoire : la mémoire physique (quantité réelle de mémoire installée dans le système) et l'espace d'adressage mémoire virtuel (espace mémoire virtualisé de 4 Go). Quelle que soit la quantité de mémoire physique installée sur le système, la taille totale de l'espace d'adresse virtuelle est toujours identique : 4 Go. Bien que ce ne soit pas le cas pour toutes les applications 32 bits, pour Exchange Server, l'espace d'adresse virtuelle équivaut à la mémoire virtuelle ; en d'autres termes, l'un et l'autre sont interchangeables.

Lors du déroulement normal de ses opérations, la banque d'informations Exchange alloue, utilise et désalloue la mémoire virtuelle à plusieurs reprises. Si la mémoire virtuelle est fréquemment allouée, utilisée et désallouée, une fragmentation de mémoire virtuelle peut se produire. La fragmentation de mémoire virtuelle est similaire à la fragmentation de système de fichiers, qui peut se produire de temps à autre. Après un moment, les segments alloués de mémoire virtuelle ne sont plus contigus et les performances s'en ressentent. Dans le cas du système de fichiers, vous pouvez exécuter une application qui procède à la défragmentation du système de fichiers, généralement même lorsque le système est en ligne et qu'un utilisateur y accède. Il n'existe aucun outil de défragmentation pour fragmenter la mémoire virtuelle ; pour remédier à ce problème, arrêtez et redémarrez le service de banque d'informations de Microsoft Exchange ou redémarrez le système.

Lorsqu'un ordinateur Exchange Server dispose de moins de 16 Mo d'espace d'adresse virtuelle contigu libre, le message d'erreur suivant est consigné dans le journal des événements Applications :

Source : | MSExchangeIS
Catégorie : | Performances
ID : | 9582
Type : | Erreur
Description : | La mémoire virtuelle nécessaire à l'exécution de votre serveur Exchange est fragmentée au point de pouvoir en affecter le fonctionnement normal. Il est vivement recommandé de redémarrer tous les services Exchange pour remédier à ce problème.

La valeur de Registre VM Error Level représente une opportunité de configuration qui permet à un administrateur de remplacer l'avertissement par défaut au niveau des 16 Mo et de définir une autre valeur.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, supprimez la valeur de VM Error Level.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur le dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server, voir l'article 325044 de la Base de connaissances Microsoft sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


L'événement d'avertissement de mémoire virtuelle faible a été remplacé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le seuil d'enregistrement d'un événement concernant la fragmentation de mémoire virtuelle a été remplacé manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

Si Exchange Server Analyzer détecte que la valeur de Registre VM Warning Level est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Dans les systèmes Microsoft Windows® 32 bits, il existe deux types de mémoire : la mémoire physique (quantité réelle de mémoire installée dans le système) et l'espace d'adressage mémoire virtuel (espace mémoire virtualisé de 4 Go). Quelle que soit la quantité de mémoire physique installée sur le système, la taille totale de l'espace d'adresse virtuelle est toujours identique : 4 Go. Bien que ce ne soit pas le cas pour toutes les applications 32 bits, pour Exchange Server, l'espace d'adresse virtuelle équivaut à la mémoire virtuelle ; en d'autres termes, l'un et l'autre sont interchangeables.

Lors du déroulement normal de ses opérations, la banque d'informations Exchange alloue, utilise et désalloue la mémoire virtuelle à plusieurs reprises. Si la mémoire virtuelle est fréquemment allouée, utilisée et désallouée, une fragmentation de mémoire virtuelle peut se produire. La fragmentation de mémoire virtuelle est similaire à la fragmentation de système de fichiers, qui peut se produire de temps à autre. Après un moment, les segments alloués de mémoire virtuelle ne sont plus contigus et les performances s'en ressentent. Pour le système de fichiers, vous pouvez exécuter une application qui procède à la défragmentation du fichier. En règle générale, vous pouvez le faire lorsque le système est en ligne et qu'un utilisateur y accède. Il n'existe aucun outil de défragmentation pour fragmenter la mémoire virtuelle ; pour remédier à ce problème, arrêtez et redémarrez plutôt le service de banque d'informations de Microsoft Exchange ou redémarrez le système.

Par défaut, lorsqu'un ordinateur Exchange Server dispose de moins de 32 Mo d'espace d'adresse virtuelle contigu libre, le message d'avertissement suivant est consigné dans le journal des événements Applications :

Source : | MSExchangeIS
Catégorie : | Performances
ID : | 9582
Type : | Avertissement
Description : | La mémoire virtuelle nécessaire à l'exécution de votre serveur Exchange est fragmentée au point de pouvoir affecter les performances. Il est vivement recommandé de redémarrer tous les services Exchange pour remédier à ce problème.

La valeur de Registre VM Warning Level représente une opportunité de configuration qui permet à un administrateur de remplacer l'avertissement par défaut au niveau des 32 Mo et de définir une autre valeur.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, supprimez la valeur de VM Warning Level.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur le dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server, voir l'article 325044 de la Base de connaissances Microsoft sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


La valeur Mailbox Cache Age Limit a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-15

L'outil Microsoft® Exchange Server Analyzer Tool recherche dans le Registre de l'ordinateur Exchange Server la présence de l'entrée de Registre Mailbox Cache Age Limit. Cette valeur de Registre se trouve dans :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que l'entrée de Registre Mailbox Cache Age Limit est présente et configurée avec une valeur égale ou supérieure à 1, un message indiquant une configuration autre que celle par défaut s'affiche.

Exchange Server permet de définir des tailles limites (quotas) pour les boîtes aux lettres. Des paramètres de quota sont stockés dans le service d'annuaire Active Directory® et Exchange Server lit régulièrement les informations d'Active Directory pour déterminer si des modifications ont été apportées à ces limites. Par défaut, Exchange Server met en cache ces informations pendant une période de deux heures (120 minutes) après lesquelles il relit les informations d'Active Directory.

La valeur de Registre Mailbox Cache Age Limit, représentée en minutes, permet de remplacer la période par défaut. Elle s'avère particulièrement utile lorsqu'un utilisateur ne peut pas accéder à sa boîte aux lettres car la taille limite a été atteinte. Si la limite d'âge de cache par défaut est appliquée, l'utilisateur ne pourra pas accéder à sa boîte aux lettres pendant deux heures maximum. La valeur recommandée est 20 minutes. Ne la définissez pas sur une valeur trop faible car cela peut entraîner des problèmes de performances.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Dans le volet droit, recherchez la valeur Limite d'âge du cache de la boîte aux lettres et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service Bnque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Mailbox Cache Age Limit, consultez l'article 327378 de la Base de connaissances sur les tailles limites de boîte aux lettres Exchange 2000 et Exchange Server 2003, qui ne sont pas appliquées dans une période de temps raisonnable et le correctif, qui nécessite Exchange 2000 SP3 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


La valeur Mailbox Cache Idle Limit a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur Mailbox Cache Idle Limit est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que l'entrée de Registre Mailbox Cache Idle Limit est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Exchange Server permet de définir des tailles limites (quotas) pour les boîtes aux lettres. Les paramètres de quota sont stockés dans le service d'annuaire Active Directory® et Exchange Server lit régulièrement les informations d'Active Directory pour déterminer si des modifications ont été apportées à ces limites. Exchange Server met en cache ces informations pendant un période après laquelle il relit les informations d'Active Directory.

Les paramètres Mailbox Cache Age Limit et Mailbox Cache Idle Limit contrôlent la durée de survie des entrées dans le cache d'informations de boîte aux lettres. Un élément est supprimé du cache s'il s'y trouve depuis plus longtemps que la période (en secondes) définie dans le paramètre Mailbox Cache Age Limit. Un élément est supprimé du cache s'il n'est pas utilisé pendant la période (en secondes) définie dans le paramètre Mailbox Cache Idle Limit. Les valeurs par défaut de ces paramètres sont de 7 200 secondes (120 minutes) pour le paramètre Mailbox Cache Age Limit et de 900 secondes (15 minutes) pour le paramètre Mailbox Cache Idle Limit. La valeur du paramètre Mailbox Cache Idle Limit ne doit pas excéder celle du paramètre Mailbox Cache Age Limit.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. Dans le volet droit, recherchez la valeur Mailbox Cache Idle Limit et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Mailbox Cache Age Limit, voir l'article 327378 de la Base de connaissances sur les tailles limites de boîte aux lettres Exchange 2000, qui ne sont pas appliquées dans une période de temps raisonnable et le correctif, qui nécessite Exchange 2000 SP3 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


La valeur Mailbox Cache Size a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur Mailbox Cache Size est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que l'entrée de Registre Mailbox Cache Size est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur Mailbox Cache Size contrôle la taille du cache de boîte aux lettres. 256 Mo est la valeur par défaut. Exchange Server permet de définir des tailles limites (quotas) pour les boîtes aux lettres. Des paramètres de quota sont stockés dans le service d'annuaire Active Directory® et Exchange Server lit régulièrement les informations d'Active Directory pour déterminer si des modifications ont été apportées à ces limites. Par défaut, Exchange Server met en cache ces informations pendant une période de deux heures (7 200 secondes) après lesquelles il relit les informations d'Active Directory.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, recherchez la valeur Mailbox Cache Size et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Mailbox Cache Age Limit, voir l'article 327378 de la Base de connaissances sur les tailles limites de boîte aux lettres Exchange 2000, qui ne sont pas appliquées dans une période de temps raisonnable et le correctif, qui nécessite Exchange 2000 SP3 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


La valeur Mailbox Cache Size est définie sur zéro
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur Mailbox Cache Size :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la valeur de Registre Mailbox Cache Size est définie sur 0, une erreur s'affiche.

Exchange Server permet de définir des tailles limites (quotas) pour les boîtes aux lettres. Des paramètres de quota sont stockés dans le service d'annuaire Active Directory® et Exchange Server lit régulièrement les informations d'Active Directory pour déterminer si des modifications ont été apportées à ces limites. La valeur Mailbox Cache Size contrôle la taille du cache de boîte aux lettres. 256 Mo est la valeur par défaut. Lorsqu'elle est définie sur 0, le cache de boîte aux lettres est désactivé. Il n'est pas recommandé de définir cette valeur sur 0, étant donné que cela entraîne une augmentation du nombre de recherches dans Active Directory par le composant d'accès au service d'annuaire (DSAccess). En outre, définir cette valeur sur 0 peut entraîner une défaillance de la banque Exchange et des problèmes lors du déplacement de boîtes aux lettres.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, recherchez la valeur Mailbox Cache Size et supprimez-la.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Mailbox Cache Age Limit, voir l'article 327378 de la Base de connaissances sur les tailles limites de boîte aux lettres Exchange 2000, qui ne sont pas appliquées dans une période de temps raisonnable et le correctif, qui nécessite Exchange 2000 SP3 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378).


Banque de boîtes aux lettres contrôlée par une stratégie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-06-06

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchPolicyList de chaque objet de banque de boîtes aux lettres. L'attribut msExchPolicyList détermine si une stratégie de boîte aux lettres Exchange Server a été créée et attribuée à une banque de boîtes aux lettres. Si Exchange Server Analyzer détecte que l'attribut msExchPolicyList est défini, il affiche un message indiquant une configuration autre que celle par défaut.

Par défaut, lors de leur création, les banques de boîtes aux lettres n'ont pas de stratégie attribuée. Toutefois, la majorité du temps, des administrateurs créent des stratégies de boîtes aux lettres et les attribuent à plusieurs banques de boîtes aux lettres. Ces stratégies appliquent des paramètres d'administration comme les limites de stockage, les mises à jour de l'index, les intervalles de maintenance, les mappages aux banques d'informations publiques et les listes d'adresses en mode hors connexion. Si une stratégie de banque de boîtes aux lettres a été créée et attribuée à une banque de boîtes aux lettres, Exchange Server Analyzer affiche un message indiquant que la banque de boîtes aux lettres est actuellement contrôlée par une stratégie. Aucune autre action n'est nécessaire.

Pour supprimer une stratégie de boîte aux lettres d'une banque de boîtes aux lettres

  1. Ouvrez le Gestionnaire système Exchange et développez Groupes d'administration dans l'arborescence de la console.

  2. Développez le Premier groupe d'administration et sélectionnez Stratégies système.

  3. Dans le volet des résultats, cliquez avec le bouton droit sur la banque de boîtes aux lettres et sélectionnez Supprimer de la stratégie.

  4. Dans la fenêtre Gestionnaire système Exchange, cliquez sur Oui pour confirmer la suppression de la banque de boîtes aux lettres.
Remarque :
Si le nœud Stratégies système n'est pas visible dans l'arborescence de la console dans Gestionnaire système Exchange, configurez ce dernier de manière à afficher les groupes d'administration.

Pour plus d'informations sur les stratégies de banques de boîtes aux lettres, voir les articles suivants de la Base de connaissances Microsoft :

  • 822938 sur l'utilisation de stratégies système pour configurer des limites de stockage de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938)

  • 256141 sur la procédure de création de stratégies système dans Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141).

Pour plus d'informations sur les fichiers de base de données Exchange Server, voir les rubriques Exchange Server 2003 suivantes :

  • rubrique sur la gestion des banques de boîtes aux lettres et de dossiers publics dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  • rubrique sur la présentation de la banque d'informations Exchange dans Utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Fichier de base de données de banque de boîtes aux lettres stocké sur le lecteur réseau
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchEDBFile de chaque objet de banque de boîtes aux lettres. Cet attribut spécifie l'emplacement des fichiers de base de données utilisés par cette banque de boîtes aux lettres.

Exchange Server Analyzer interroge également Active Directory pour déterminer le nombre de valeurs répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres sur ce serveur. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres. Exchange Server Analyzer peut ensuite calculer le nombre total de boîtes aux lettres gérées par le serveur.

Si Exchange Server Analyzer détecte que l'attribut msExchEDBFile commence par \\ sur un serveur Exchange comprenant plus de 50 boîtes aux lettres, une erreur s'affiche.

Cette erreur indique que les fichiers de base de données d'une banque de boîtes aux lettres sont stockés sur un partage réseau. Si l'attribut msExchEDBFile commence par \\, cela indique que le chemin d'accès au fichier journal utilise un chemin d'accès UNC (Universal Naming Convention). Cette manière de procéder n'est pas recommandée étant donné que les interruptions de la connectivité réseau pourraient engendrer des erreurs de base de données, se traduisant par une perte de données ou des bases de données endommagées. Il est recommandé de résoudre ce problème au plus vite.

Pour déplacer les fichiers de base de données vers un nouveau lecteur

  1. Dans le Gestionnaire système Exchange, développez l'objet de serveur Exchange sur lequel la banque réside, développez le conteneur de groupe de stockage approprié, cliquez avec le bouton droit sur l'objet de banque de boîtes aux lettres désiré, puis cliquez sur Propriétés.

  2. Spécifiez les nouveaux emplacements de fichiers sous l'onglet Base de données de la boîte de dialogue Propriétés.

Pour plus d'informations sur les fichiers de base de données Exchange Server, voir les rubriques suivantes :

  • sur la gestion des banques de boîtes aux lettres et des banques de dossiers publics dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617)

  • sur la présentation de la banque d'informations Exchange dans la rubrique sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation d'Exchange Server avec les lecteurs réseau, voir les articles suivants de la Base de connaissances Microsoft :

  • 328879 sur l'utilisation d'Exchange Server avec un réseau SAN (Storage Attached Network) et des périphériques NAS (Network Attached Storage) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687 sur la stratégie de prise en charge de Microsoft sur l'utilisation des périphériques NAS (Network Attached Storage) avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173 sur Exchange Server et le système NAS (Network Attached Storage) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172 sur Exchange Server 5.5 et le système NAS (Network Attached Storage) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


Une taille limite de base de données a été définie pour une banque de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre Database Size Limit in Gb est présente et configurée pour les bases de données de banques de boîtes aux lettres :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Si Exchange Server Analyzer détecte que la valeur Database Size Limit in Gb est présente et configurée, il affiche un message indiquant une configuration autre que celle par défaut.

Si Exchange Server 2003 Service Pack 2 (SP2) est appliqué à Exchange Server 2003 Édition Standard, la taille limite de base de données sous licence codée de manière irréversible passe de 16 à 75 gigaoctets (Go). Vous pouvez définir une taille limite de base de données de protection pour éviter toute augmentation accidentelle de la taille de base de données. La valeur de taille limite par défaut du SP2 est de 18 Go. Vous pouvez la remplacer en créant la valeur de Registre Database Size Limit in Gb.

Il est également possible d'augmenter la limite de taille de base de données de 50 Go programmée d'Exchange Server 2007 Standard Edition en créant la valeur de Registre Database Size Limit in Gb.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Supprimez la valeur Database Size Limit in Gb.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, consultez le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


La banque de boîtes aux lettres n'est pas associée à une banque de dossiers publics par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchPrivateMDB présente une banque de dossiers publics par défaut affectée à la banque de boîtes aux lettres.

L'attribut msExchPrivateMDB est une configuration de base de données privée pour un objet de banque de boîtes aux lettres. Par défaut, l'attribut msExchHomePublicMDB est associé à une banque de boîtes aux lettres. L'attribut msExchPrivateMDB est la base de données de messages publics associée (MDB).

Si Exchange Server Analyzer détecte que l'attribut msExchHomePublicMDB est supprimé ou que sa configuration est incorrecte, il affiche une erreur.

Chaque banque de boîtes aux lettres doit être associée à une banque de dossiers publics par défaut, sur le serveur local ou un autre serveur. Pour chaque utilisateur à boîte aux lettres activée pris en charge par une banque de boîtes aux lettres spécifique, la banque de dossiers publics associée est la banque de dossiers publics associée de l'utilisateur. Utilisez si possible la banque de dossiers publics par défaut sur le même serveur que la banque de boîtes aux lettres.

Remarque :
En utilisant la banque de dossiers publics par défaut sur le même serveur que la banque de boîtes aux lettres, vous pouvez améliorer les performances lorsque des utilisateurs accèdent à des dossiers publics et simplifier la résolution des problèmes d'accès aux dossiers publics.
Pour attribuer une banque de dossiers publics par défaut à une banque de boîtes aux lettres

  1. Dans le Gestionnaire système Exchange, cliquez avec le bouton droit sur le groupe de stockage où la Banque de boîtes aux lettres réside.

  2. Cliquez avec le bouton droit sur la banque de boîtes aux lettres, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, dans la Banque de dossiers publics par défaut, cliquez sur Parcourir et sélectionnez la banque de dossiers publics que vous souhaitez associer à cette banque de boîtes aux lettres.

    Remarque :
    Si vous créez une nouvelle banque de boîtes aux lettres, Exchange Server sélectionne automatiquement la banque publique par défaut, qui est associée à l'arborescence Dossiers publics, et un Carnet d'adresses en mode hors connexion que les utilisateurs téléchargeront pour une utilisation en mode hors connexion.

Pour plus d'informations sur la gestion de banques de boîtes aux lettres et de dossiers publics, voir le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=21769).


La banque de boîtes aux lettres dépasse 12 Go
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-02-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_DataFile pour déterminer la valeur de la clé FileSize pour chaque fichier de base de données de la banque de boîtes aux lettres Exchange (fichier .edb) et chaque fichier de transmission en continu (fichier .stm). Exchange Server Analyzer lit également la branche de Registre suivante pour déterminer la version d'Exchange Server installée :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Si Exchange Server Analyzer détecte que la taille combinée d'une base de données de banque de boîtes aux lettres et de fichiers de transmission en continu dépasse 12 Go sur un ordinateur qui utilise Microsoft Exchange Server 2003 Édition Standard ou Microsoft Exchange 2000 Server Édition Standard, un avertissement s'affiche.

Les bases de données de banque Exchange sur les Éditions Standard d'Exchange Server 2003 et d'Exchange 2000 Server ne peuvent pas dépasser 16 Go. Lorsque la limite est atteinte, la banque de boîtes aux lettres n'augmente pas non plus et Exchange est inaccessible. Les bases de données de banque Exchange des Éditions Entreprise d'Exchange Server 2003 et Exchange 2000 Server ne sont pas limitées à 16 Go ; elles ne sont limitées que par le matériel disponible, d'une taille maximale théorique de 16 téraoctets.

Pour supprimer cet avertissement

  1. Envisagez de déplacer certaines boîtes aux lettres de la grande banque de boîtes aux lettres vers une nouvelle banque de boîtes aux lettres sur cet ordinateur Exchange Server ou sur un autre.

  2. Si vous avez récemment déplacé des boîtes aux lettres de cette banque d'informations vers une autre banque ou supprimé des boîtes aux lettres de cette banque d'informations, une défragmentation hors ligne risque de réduire la taille des fichiers.

  3. Envisagez de définir des tailles limites de boîtes aux lettres et de messages pour éviter la croissance illimitée de la banque de boîtes aux lettres.
Remarque :
La publication d'Exchange Server 2003 Service Pack 2 (SP2) pour Exchange Server 2003 Édition Standard a permis d'augmenter la taille limite de base de données sous licence codée de manière irréversible de 16 à 75 Go. L'administrateur peut définir une taille limite de base de données de protection (pour éviter toute augmentation accidentelle de taille de base de données). La valeur par défaut est de 18 Go dans le SP2 pour l'Édition Standard. Vous pouvez la remplacer en modifiant la clé de Registre Database Size Limit in Gb.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la taille limite d'une base de données avec Exchange Server 2003 SP2

  1. Sur l'ordinateur Exchange Server, démarrez Regedit.exe.

  2. Ouvrez la clé de Registre suivante : HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nom_serveur\Private-GUID de banque de boîtes aux lettres

  3. Cliquez avec le bouton droit sur GUID de banque privée, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Pour le nom de la nouvelle valeur, entrez Database Size Limit in Gb.

  5. Double-cliquez sur Database Size Limit in Gb. Dans Données de la valeur, entrez une valeur appropriée pour la taille de base de données maximale en Go. Pour Exchange Server 2003 Édition Standard, entrez une valeur décimale comprise entre 1 et 75 (la valeur par défaut est 18 Go). Pour Exchange Server 2003 Édition Entreprise, entrez une valeur décimale comprise entre 1 et 8 000 (la valeur par défaut est 8 000 Go). Cliquez sur OK.

  6. Cliquez avec le bouton droit sur GUID de banque privée, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  7. Pour le nom de la nouvelle valeur, entrez Database Size Buffer in Percentage.

  8. Double-cliquez sur Database Size Buffer in Percentage. Dans Données de la valeur, entrez une valeur décimale comprise entre 1 et 100 pour spécifier le moment d'enregistrement des événements pour vous avertir que vous approchez de la taille maximale pour une base de données. La valeur par défaut 10 permet d'enregistrer des événements d'avertissement lorsqu'il vous reste une capacité de 10 pour cent avant d'atteindre la taille maximale de cette base de données. Cliquez sur OK.

  9. Cliquez avec le bouton droit sur GUID de banque privée, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  10. Pour le nouveau nom, entrez Database Size Check Start Time in Hours From Midnight.

  11. Double-cliquez sur Database Size Check Start Time in Hours From Midnight. Dans Données de la valeur, entrez une valeur comprise entre 0 et 23 pour spécifier le moment auquel Exchange doit vérifier la taille de la base de données. La valeur par défaut de 5 permet à Exchange Server de vérifier la taille de la base de données 5 heures après minuit (5 heures du matin). Cliquez sur OK.

  12. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les fichiers .stm et .edb, voir l'article 232323 de la Base de connaissances Microsoft sur le stockage du contenu natif dans Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir l'article 821829 de la Base de connaissances sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange 2000 Server, voir l'article 328810 de la Base de connaissances sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Pour plus d'informations sur l'exécution d'une défragmentation hors ligne d'une base de données Exchange Server, voir l'article 328804 de la Base de connaissances sur la procédure de défragmentation des bases de données Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Pour plus d'informations sur la définition de tailles limites des messages, voir l'article 322679 de la Base de connaissances sur la définition de tailles limites pour les messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Pour plus d'informations sur les Éditions Standard d'Exchange Server 2003 ou Microsoft Exchange 2000 Server ayant atteint la taille maximale de base de données, voir l'article 828070 de la Base de connaissances sur la banque de boîtes aux lettres Exchange Server qui n'est pas montée si sa base de données atteint la limite de 16 Go (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


La banque de boîtes aux lettres dépasse 15 Go
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-02-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_DataFile pour déterminer la valeur de la clé FileSize pour chaque fichier de base de données de la banque de boîtes aux lettres Exchange (fichier .edb) et chaque fichier de transmission en continu (fichier .stm). Exchange Server Analyzer lit également la branche de Registre suivante pour déterminer la version d'Exchange Server installée :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID de produit Exchange>

Si Exchange Server Analyzer détecte que la taille combinée d'une base de données de banque de boîtes aux lettres et de fichiers de transmission en continu dépasse 15 Go sur un ordinateur qui utilise Microsoft Exchange Server 2003 Édition Standard ou Microsoft Exchange 2000 Server Édition Standard, une erreur s'affiche.

Les bases de données de banque Exchange sur les Éditions Standard d'Exchange Server 2003 et d'Exchange 2000 Server ne peuvent pas dépasser 16 Go. Lorsque la limite est atteinte, la banque de boîtes aux lettres n'augmente pas non plus et Exchange est inaccessible. Les bases de données de banque Exchange des Éditions Entreprise d'Exchange Server 2003 et Exchange 2000 Server ne sont pas limitées à 16 Go ; elles ne sont limitées que par le matériel disponible, d'une taille maximale théorique de 16 téraoctets.

Pour corriger cette erreur

  1. Envisagez de déplacer certaines boîtes aux lettres de la grande banque de boîtes aux lettres vers une nouvelle banque de boîtes aux lettres sur cet ordinateur Exchange Server ou sur un autre.

  2. Si vous avez récemment déplacé des boîtes aux lettres de cette banque d'informations vers une autre banque ou supprimé des boîtes aux lettres de cette banque d'informations, une défragmentation hors ligne risque de réduire la taille des fichiers.

  3. Envisagez de définir des tailles limites de boîtes aux lettres et de messages pour éviter la croissance illimitée de la banque de boîtes aux lettres.
Remarque :
La publication d'Exchange Server 2003 Service Pack 2 (SP2) pour Exchange Server 2003 Édition Standard a permis d'augmenter la taille limite de base de données sous licence codée de manière irréversible de 16 à 75 Go. L'administrateur peut définir une taille limite de base de données de protection (pour éviter toute augmentation accidentelle de taille de base de données). La valeur par défaut est de 18 Go dans le SP2 pour l'Édition Standard. Vous pouvez la remplacer en modifiant la clé de Registre Database Size Limit in GB.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la taille limite d'une base de données avec Exchange Server 2003 SP2

  1. Sur l'ordinateur Exchange Server, démarrez Regedit.exe.

  2. Ouvrez la clé de Registre suivante : HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nom_serveur\Private-GUID de banque de boîtes aux lettres

  3. Cliquez avec le bouton droit sur GUID de banque privée, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Pour le nom de la nouvelle valeur, entrez Database Size Limit in Gb.

  5. Double-cliquez sur Database Size Limit in Gb. Dans Données de la valeur, entrez une valeur appropriée pour la taille de base de données maximale en Go. Pour Exchange Server 2003 Édition Standard, entrez une valeur décimale comprise entre 1 et 75 (la valeur par défaut est 18 Go). Pour Exchange Server 2003 Édition Entreprise, entrez une valeur décimale comprise entre 1 et 8 000 (la valeur par défaut est 8 000 Go). Cliquez sur OK.

  6. Cliquez avec le bouton droit sur GUID de banque privée, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  7. Pour le nom de la nouvelle valeur, entrez Database Size Buffer in Percentage.

  8. Double-cliquez sur Database Size Buffer in Percentage. Dans Données de la valeur, entrez une valeur décimale comprise entre 1 et 100 pour spécifier le moment d'enregistrement des événements pour vous avertir que vous approchez de la taille maximale pour une base de données. La valeur par défaut 10 permet d'enregistrer des événements d'avertissement lorsqu'il vous reste une capacité de 10 pour cent avant d'atteindre la taille maximale de cette base de données. Cliquez sur OK.

  9. Cliquez avec le bouton droit sur GUID de banque privée, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  10. Pour le nouveau nom, entrez Database Size Check Start Time in Hours From Midnight.

  11. Double-cliquez sur Database Size Check Start Time in Hours From Midnight. Dans Données de la valeur, entrez une valeur comprise entre 0 et 23 pour spécifier le moment auquel Exchange doit vérifier la taille de la base de données. La valeur par défaut de 5 permet à Exchange Server de vérifier la taille de la base de données 5 heures après minuit (5 heures du matin). Cliquez sur OK.

  12. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les fichiers .stm et .edb, voir l'article 232323 de la Base de connaissances Microsoft sur le stockage du contenu natif dans Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir l'article 821829 de la Base de connaissances sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange 2000 Server, voir l'article 328810 de la Base de connaissances sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Pour plus d'informations sur l'exécution d'une défragmentation hors ligne d'une base de données Exchange Server, voir l'article 328804 de la Base de connaissances sur la procédure de défragmentation des bases de données Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Pour plus d'informations sur la définition de tailles limites des messages, voir l'article 322679 de la Base de connaissances sur la définition de tailles limites pour les messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Pour plus d'informations sur les Éditions Standard d'Exchange Server 2003 et Exchange 2000 Server ayant atteint la taille maximale de base de données, voir l'article 828070 de la Base de connaissances sur la banque de boîtes aux lettres Exchange Server qui n'est pas montée si sa base de données atteint la limite de 16 Go (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Aucune sauvegarde complète de la banque de boîtes aux lettres n'a été effectuée depuis plus de 8 jours
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge chaque banque de boîtes aux lettres pour déterminer la date et l'heure de la dernière sauvegarde complète. Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer le nombre d'utilisateurs avec des boîtes aux lettres dans chaque banque de boîtes aux lettres. Exchange Server Analyzer affiche un avertissement si les deux conditions suivantes existent :

  • Le nombre de jours depuis la dernière sauvegarde complète d'une banque de boîtes aux lettres est supérieur à huit.

  • Plus de dix boîtes aux lettres existent dans la banque de boîtes aux lettres.

La banque de boîtes aux lettres est une base de données permettant de stocker des boîtes aux lettres dans Microsoft Exchange Server 2003 et Exchange Server 2007. Une banque de boîtes aux lettres se compose d'un fichier de texte enrichi (.edb) et d'un fichier de contenu Internet natif de transmission en continu (.stm). Ces deux fichiers représentent les deux moitiés d'une même base de données et non deux bases de données distinctes.

Les données des banques de boîtes aux lettres et de dossiers publics de vos bases de données Exchange Server et les fichiers des journaux de transactions constituent les données les plus importantes à sauvegarder dans votre organisation Exchange Server. Vous pouvez utiliser une sauvegarde de base de données Exchange Server pour restaurer une boîte aux lettres endommagée sur un serveur fonctionnel qui exécute Exchange Server. Vous pouvez également utiliser des sauvegardes de base de données Exchange Server pour restaurer vos bases de données Exchange Server sur un autre serveur.

Il est recommandé d'effectuer une sauvegarde complète de vos fichiers de base de données et de vos journaux des transactions tous les jours. Après l'exécution d'une sauvegarde complète d'un groupe de stockage, les fichiers des journaux de transactions assignés des bases de données Exchange Server sont supprimés du serveur. L'avantage d'une sauvegarde complète réside dans la vitesse dans un scénario de récupération, car vous ne devez définir qu'une bande pour restaurer toutes les données.

Remarque :
Il est recommandé de conserver les fichiers des journaux de transactions sur un disque dédié distinct de celui des fichiers de base de données. Vous disposez d'une tolérance de pannes en cas de destruction du disque de la base de données, et dans certains cas, vous améliorez les performances de la base de données.
Important :
Vous devez posséder les autorisations requises ou les droits affectés au compte d'utilisateur auquel vous êtes connecté lorsque vous tentez de sauvegarder ou restaurer des fichiers et des dossiers. Pour créer des sauvegardes Exchange Server, vous devez posséder les droits d'opérateur de sauvegarde au niveau du domaine. Pour créer des sauvegardes de votre système d'exploitation Microsoft Windows Server™ 2003, vous devez au moins posséder des droits d'opérateur de sauvegarde locale.

La stratégie de sauvegarde que vous choisissez pour vos données Exchange Server dépend de la taille des banques, de la vitesse du matériel et du logiciel de sauvegarde, de la capacité matérielle et des délais.

Pour plus d'informations sur les stratégies de sauvegarde et les opérations de récupération d'urgence, consultez :

  • Guide des opérations de récupération d'urgence d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47570)

  • Sauvegarde et restauration des bases de données (http://go.microsoft.com/fwlink/?LinkId=80766)


Aucune sauvegarde complète de la banque de boîtes aux lettres n'a été effectuée depuis plus de 60 jours
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge chaque banque de boîtes aux lettres pour déterminer la date et l'heure de la dernière sauvegarde complète. Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer le nombre d'utilisateurs avec des boîtes aux lettres dans chaque banque de boîtes aux lettres. Exchange Server Analyzer affiche une erreur si les deux conditions suivantes existent :

  • Le nombre de jours depuis la dernière sauvegarde complète d'une banque de boîtes aux lettres est supérieur à soixante.

  • Plus de dix boîtes aux lettres existent dans la banque de boîtes aux lettres.

La banque de boîtes aux lettres est une base de données permettant de stocker des boîtes aux lettres dans Microsoft Exchange Server 2003 et Microsoft Exchange Server 2007. Une banque de boîtes aux lettres se compose d'un fichier de texte enrichi (.edb) et d'un fichier de contenu Internet natif de transmission en continu (.stm). Ces deux fichiers représentent les deux moitiés d'une même base de données et non deux bases de données distinctes.

Les données des banques de boîtes aux lettres et de dossiers publics de vos bases de données Exchange Server et les fichiers des journaux de transactions constituent les données les plus importantes à sauvegarder dans votre organisation Exchange Server. Vous pouvez utiliser une sauvegarde de base de données Exchange Server pour restaurer une boîte aux lettres endommagée sur un serveur fonctionnel qui exécute Exchange Server. Vous pouvez également utiliser des sauvegardes de base de données Exchange Server pour restaurer vos bases de données Exchange Server sur un autre serveur.

Il est recommandé d'effectuer une sauvegarde complète de vos fichiers de base de données et de vos journaux des transactions tous les jours. Après l'exécution d'une sauvegarde complète d'un groupe de stockage, les fichiers des journaux de transactions assignés des bases de données Exchange Server sont supprimés du serveur. L'avantage d'une sauvegarde complète réside dans la vitesse dans un scénario de récupération, car vous ne devez définir qu'une bande pour restaurer toutes les données.

Remarque :
Il est recommandé de conserver les fichiers des journaux de transactions sur un disque dédié distinct de celui des fichiers de base de données. Vous disposez d'une tolérance de pannes en cas de destruction du disque de la base de données, et dans certains cas, vous améliorez les performances de la base de données.
Important :
Vous devez posséder les autorisations requises ou les droits affectés au compte d'utilisateur auquel vous êtes connecté lorsque vous tentez de sauvegarder ou restaurer des fichiers et des dossiers. Pour créer des sauvegardes Exchange Server, vous devez posséder les droits d'opérateur de sauvegarde au niveau du domaine. Pour créer des sauvegardes de votre système d'exploitation Microsoft Windows Server™ 2003, vous devez au moins posséder des droits d'opérateur de sauvegarde locale.

La stratégie de sauvegarde que vous choisissez pour vos données Exchange Server dépend de la taille des banques, de la vitesse du matériel et du logiciel de sauvegarde, de la capacité matérielle et des délais.

Pour plus d'informations sur les stratégies de sauvegarde et les opérations de récupération d'urgence, consultez :

  • Guide des opérations de récupération d'urgence d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47570)

  • Sauvegarde et restauration des bases de données (http://go.microsoft.com/fwlink/?LinkID=80766).


Les planifications de maintenance en ligne des banques de boîtes aux lettres se chevauchent
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si toutes les banques de boîtes aux lettres du groupe de stockage disposent de la même planification de maintenance. Si le conteneur de groupe de stockage (classe msExchStorageGroup) possède plusieurs objets de banques de boîtes aux lettres (classe msExchPrivMDB), Exchange Server Analyzer vérifie l'attribut activationSchedule de chaque objet de banque de boîtes aux lettres. Si Exchange Server Analyzer détecte que ces valeurs (stockées sous la forme de chaînes en octet) sont identiques pour chaque banque de boîtes aux lettres ou si elles se chevauchent, un avertissement s'affiche.

Par défaut, les processus de maintenance des banques de boîtes aux lettres sont exécutés entre 1 et 5 heures du matin. En raison des ressources de serveur requises pour les processus de maintenance, il est recommandé de modifier les planifications de maintenance de sorte que les banques de boîtes aux lettres disposent de planifications différant d'au moins 15 minutes.

Correction de cet avertissement dans Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis celui que vous souhaitez utiliser.

  3. Développez le groupe de stockage que vous souhaitez utiliser.

  4. Cliquez avec le bouton droit sur la banque que vous souhaitez utiliser, puis sélectionnez Propriétés.

  5. Sous l'onglet Base de données, cliquez sur Fréquence d'exécution de la maintenance et sur une nouvelle fréquence ou cliquez sur Personnaliser pour créer une planification personnalisée.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez la console de gestion Exchange.

  2. Développez Configuration du serveur, puis sélectionnez le serveur que vous voulez utiliser.

  3. Développez le groupe de stockage souhaité.

  4. Cliquez avec le bouton droit sur la banque que vous voulez utiliser, puis sélectionnez Propriétés.

  5. Sous l'onglet Général, cliquez sur la liste déroulante Planification de la maintenance, puis sélectionnez un intervalle, ou cliquez sur Personnaliser pour créer une planification personnalisée.

Pour plus d'informations sur la maintenance des banques d'informations d'Exchange Server 2003, consultez la section sur la configuration des options de maintenance et de sauvegarde des banques du Guide d'administration de Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Les limites d'interdiction d'envoi et de réception de la banque de boîtes aux lettres sont trop similaires
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer les limites de taille de la boîte aux lettres. Si Exchange Server Analyzer détecte que la différence entre les limites Prohibit send et Prohibit send and receive de la boîte aux lettres est inférieure à 20 %, il affiche un message de configuration recommandée.

Il est conseillé de séparer les limites Prohibit send et Prohibit send and receive d'au moins 20 %. Si la différence entre les limites est inférieure à 20 %, l'utilisateur de la boîte aux lettres risque de ne pas avoir assez de temps pour nettoyer sa boîte avant qu'elle ne commence à rejeter des messages. Par exemple, si les utilisateurs ne peuvent pas envoyer de nouveaux messages lorsque leur boîte aux lettres atteint 100 Mo, la limite Prohibit send and receive doit être d'au moins 120 Mo.

Remarque :
Il est également important de définir une limite d'avertissement au niveau des boîtes aux lettres. Si la boîte aux lettres atteint cette limite, un message électronique est envoyé à l'utilisateur, l'avertissant que sa boîte aux lettres approche la limite fixée par Prohibit send.

Pour résoudre ce problème, vous devez augmenter la différence entre les limites Prohibit send et Prohibit send and receive de boîtes aux lettres à plus de 20 %.

Définition des limites de boîte aux lettres

  1. Ouvrez le Gestionnaire système Exchange.

  2. Recherchez la banque de boîtes aux lettres affichée dans le message Exchange Server Analyzer.

  3. Cliquez avec le bouton droit sur Nom_banque_boîte_aux_lettres, puis sélectionnez Propriétés.

  4. Cliquez sur l'onglet Limites.

  5. Modifiez la limite Interdire l'envoi à (Ko) ou Interdire l'envoi et la réception à (Ko) ou les deux.

  6. Cliquez sur Appliquer, puis sur OK.
Définition de limites de boîte aux lettres pour Exchange Server 2007 à l'aide de la console de gestion Exchange

  1. Ouvrez la console de gestion Exchange.

  2. Recherchez la banque de boîtes aux lettres affichée dans Exchange Server Analyzer concernant ce problème.

  3. Cliquez avec le bouton droit sur Nom_banque_boîte_aux_lettres, puis sélectionnez Propriétés.

  4. Cliquez sur l'onglet Limites.

  5. Modifiez les limites Émettre un avertissement à (Ko), Interdire l'envoi à (Ko) et Interdire l'envoi et la réception à (Ko).

  6. Cliquez sur Appliquer, puis sur OK.
Définition de limites de boîte aux lettres pour Exchange Server 2007 à l'aide de l'environnement de ligne de commande Exchange Management Shell

  1. L'exemple suivant montre comment définir la taille de boîte aux lettres à partir de laquelle un message d'avertissement est envoyé à l'utilisateur. Cet attribut s'applique à toutes les boîtes aux lettres de la base de données de boîtes aux lettres n'ayant pas leur propre attribut de quota d'avertissement défini. Vous devez spécifier un nombre entier ou « unlimited ». La valeur par défaut est 1,9 gigaoctets (Go).
Copier le code
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. L'exemple suivant montre comment définir la taille de boîte aux lettres à partir de laquelle les utilisateurs associés à des boîtes aux lettres dans cette base de données ne peuvent plus envoyer de messages. Cet attribut s'applique à toutes les boîtes aux lettres de la base de données de boîtes aux lettres qui n'ont pas leurs propres attributs de quota d'interdiction d'envoi définis. La valeur limite définie doit être soit un nombre entier, soit « illimitée ».

Copier le code
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. L'exemple suivant montre comment définir la taille de boîte aux lettres à partir de laquelle l'utilisateur associé à la boîte aux lettres ne peut plus envoyer ou recevoir de messages. Cet attribut s'applique à toutes les boîtes aux lettres de la base de données de boîtes aux lettres qui n'ont pas leurs propres attributs de quota d'interdiction d'envoi et de réception définis. Vous devez spécifier un nombre entier ou « unlimited ».

Copier le code
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Pour plus d'informations sur la gestion des boîtes aux lettres Exchange, consultez le document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur la gestion des limites de boîte aux lettres Exchange dans Exchange Server 2007, consultez la page Web « Procédure de configuration de limites et de propriétés de base de données » (http://go.microsoft.com/fwlink/?LinkID=80746)


La banque de boîtes aux lettres ne sera pas montée au démarrage
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchEDBOffline de tous les objets avec une classe msExchPrivateMDB. Les objets présentant cette classe sont des banques de boîtes aux lettres.

Une valeur True de l'attribut msExchEDBOffline indique que la banque de boîtes aux lettres ne sera pas montée automatiquement au démarrage du service Banque d'informations Microsoft Exchange. Une valeur False indique que la banque de boîtes aux lettres sera montée au démarrage. Si Exchange Server Analyzer détecte la valeur True pour cet attribut, un avertissement s'affiche.

Celui-ci indique que la case à cocher Ne pas monter cette banque d'informations au démarrage est activée. Cette case à cocher se trouve sous l'onglet Base de données de la boîte de dialogue Propriétés de la banque de boîtes aux lettres. Si elle est activée, la banque de boîtes aux lettres n'est pas montée automatiquement au démarrage du service Banque d'informations Microsoft Exchange. Au prochain démarrage de ce service, par exemple après un redémarrage du serveur, les banques de boîtes aux lettres dont cet attribut est défini sur True ne seront pas montées. Il est conseillé de monter automatiquement les banques de boîtes aux lettres au démarrage du service Banque d'informations Microsoft Exchange.

Correction de cet avertissement dans Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis le serveur qui comprend la banque de boîtes aux lettres que vous souhaitez modifier.

  3. Développez le groupe de stockage qui comprend la banque de boîtes aux lettres que vous souhaitez modifier.

  4. Cliquez avec le bouton droit sur la banque de boîtes aux lettres, puis cliquez sur Propriétés.

  5. Sous l'onglet Base de données, désactivez la case à cocher Ne pas monter cette banque d'informations au démarrage.

  6. Cliquez sur OK pour enregistrer le paramètre.

  7. Fermez le Gestionnaire système Exchange.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez la console de gestion Exchange.

  2. Développez Configuration du serveur, puis sélectionnez le serveur que vous voulez utiliser.

  3. Développez le groupe de stockage souhaité.

  4. Cliquez avec le bouton droit sur la base de données que vous voulez utiliser, puis cliquez sur Propriétés.

  5. Sous l'onglet Général, désactivez la case à cocher Ne pas monter cette base de données au démarrage.

  6. Cliquez sur OK pour enregistrer le paramètre.

  7. Fermez la console de gestion Exchange.

Pour plus d'informations sur cette option, consultez les articles suivants de la Base de connaissances Microsoft

  • 314218 sur la procédure d'activation et de désactivation du montage automatique des bases de données lors du démarrage d'Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314218)

  • 285169 sur les banques d'informations qui ne sont pas montées après que vous avez utilisé le commutateur « /disasterrecovery » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Paramètre Max FXGetBuffer Users non défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé de Registre Max FXGetBuffer Users a été créée :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la clé de Registre Max FXGetBuffer Users a été créée sous ParametersSystem, il affiche un message indiquant une configuration autre que celle par défaut.

La clé de Registre Max FXGetBuffer Users permet de contrôler le nombre de clients Microsoft Office Outlook® 2003 qui se synchronisent simultanément avec un serveur Exchange Server 2003. Vous définissez la valeur de la clé de Registre Max FXGetBuffer Users pour remplacer la limite définie par les clients Outlook sur les connexions d'appel de procédure distante (RPC) simultanées. Ces connexions sont parfois également appelées ropFXSrcGetBuffers. Pour calculer la valeur par défaut de la clé de Registre Max FXGetBuffer Users, prenez le nombre de processeurs sur le serveur, multipliez ce nombre par 2, puis ajoutez-y 3. Par exemple, sur un serveur Exchange Server 2003 ayant deux processeurs, la valeur par défaut est 7 ([2 * 2] + 3 = 7).

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Effacez la valeur Max FXGetBuffer Users.

  4. Fermez l'Éditeur du Registre.

Le service de banque d'informations de Microsoft Exchange détecte les modifications en quelques minutes. Il n'est pas nécessaire de redémarrer l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la définition des clés de Registre pour contrôler le nombre de clients Outlook qui peuvent se synchroniser avec Exchange Server 2003, voir l'article 818484 de la Base de connaissances sur les valeurs de Registre et les compteurs disponibles pour configurer et surveiller la synchronisation client Outlook (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484).


Le nombre maximal de pièces jointes par dépôt de message a été modifié
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le nombre maximal par défaut de pièces jointes par dépôt de message a été modifié :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

Si Exchange Server Analyzer détecte que la valeur de Registre objtAttachment est présente et configurée avec une valeur différente de celle affichée dans le tableau ci-après, un message indiquant une configuration autre que celle par défaut s'affiche.

Entrée | Valeur par défaut d'Exchange Server 2003 RTM | Valeur par défaut d'Exchange Server 2003 SP1 et des versions ultérieures | Valeur par défaut d'Exchange Server 2007
objtAttachment | 100 | 500 | 500

Ajoutée et configurée manuellement, la valeur de Registre objtAttachment détermine le nombre maximal de pièces jointes par dépôt de message par client MAPI. Lorsqu'un client MAPI tente d'envoyer un message avec un nombre de pièces jointes supérieur au nombre autorisé, l'événement suivant est enregistré dans le journal des événements d'applications de l'ordinateur Exchange Server qui contient la boîte aux lettres du client :

Type d'événement : | Erreur
ID d'événement : | 9646
Source de l'événement : | MSExchangeIS
Catégorie de l'événement : | Général
Description : | Fermeture de la session Mapi « /o=Nom_organisation/ou=Nom_groupe_administration/cn=Destinataires/cn=Nom_utilisateur » en raison du dépassement du nombre maximal de xxx objets de type « objtAttachment ».

La valeur de Registre objtAttachment représente une opportunité de configuration offrant à l'administrateur un niveau supérieur de contrôle des ressources Exchange Server utilisées par les clients MAPI.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Supprimez la valeur de Registre objtAttachment.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Si vous souhaitez utiliser la valeur de Registre objtAttachment, au lieu de la supprimer, vous pouvez également la conserver avec la même définition de valeur ou l'ajuster au besoin.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations, consultez l'article 830829 de la Base de connaissances sur l'ordinateur Exchange Server 2003 qui peut cesser de répondre lorsqu'un client MAPI ouvre plus d'objets serveur qu'autorisé par la valeur par défaut (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Nombre maximal de vues mises en cache modifié
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le nombre maximal de vues mises en cache par base de données a été modifié. Si Exchange Server Analyzer détecte que l'attribut msExchMaxCachedViews a été modifié par rapport à sa valeur par défaut de 11, Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut. Le nombre de vues mises en cache configuré par base de données est inclus dans les résultats d'Exchange Server Analyzer. Il est recommandé de le définir sur une valeur comprise entre 5 et 20.

L'attribut msExchMaxCachedViews fait partie de la classe d'objet msExchangePrivateMDB. Par conséquent, chaque objet de banque de boîtes aux lettres d'Active Directory possède une valeur d'attribut msExchMaxCachedViews. La valeur de l'attribut msExchMaxCachedViews spécifie le nombre maximal de vues mises en cache pour un dossier spécifique d'une boîte aux lettres. Dans ce contexte, le terme « vue » désigne les dossiers affichés lorsqu'un utilisateur accède à la boîte aux lettres Microsoft Office Outlook® 2003 d'un autre utilisateur. Lorsque des utilisateurs partagent l'accès à un dossier Outlook avec d'autres utilisateurs, Exchange Server génère une vue qui masque les éléments privés.

Lorsqu'un utilisateur Outlook affiche en premier le calendrier, le dossier de contacts ou toute autre donnée d'un autre utilisateur, des retards peuvent survenir. Une fois qu'il a consulté le dossier, il est possible que les vues soient plus rapides lors des tentatives suivantes, mais après un certain délai, il se peut qu'il doive patienter s'il réessaie d'accéder au dossier. Cette attente est généralement plus longue si le dossier contient un grand nombre d'éléments. Par grand nombre, l'on entend au moins 5 000 éléments.

L'application d'une vue à un dossier crée des dossiers de recherche dans la banque Exchange pour chaque utilisateur unique qui accède au dossier Outlook. Lors de sa création, le dossier de recherche est mis en cache pour une utilisation ultérieure. Avant de créer un nouveau dossier de recherche, Exchange Server détermine si ce dossier de recherche existe déjà. Le cas échéant, Exchange Server utilise le dossier de recherche mis en cache pour accélérer les affichages suivants.

L'attribut msExchMaxCachedViews définit le mode de mise en cache de nombreux dossiers de recherche dans un dossier spécifique. Par exemple, l'attribut msExchMaxCachedViews peut définir le nombre de dossiers de recherche mis en cache dans le dossier Calendrier.

Si plusieurs utilisateurs partagent des dossiers Outlook, vous devez décider de la manière d'équilibrer les ressources du serveur et les performances acceptables du client. Lors de sa mise en cache, un dossier de recherche est actualisé au fur et à mesure que ses données sont modifiées. Cette actualisation occupe les ressources disque et processeur. En cas de mise à jour de plusieurs caches du dossier de recherche, les performances du processeur et du disque sont davantage affectées.

Par ailleurs, lorsqu'Exchange Server crée un dossier de recherche pour la première fois, il se peut que l'utilisateur qui accède au dossier Outlook doive patienter pendant la création.

Imaginez par exemple qu'un serveur Exchange est configuré avec 11 dossiers de recherche. Ce chiffre constitue le nombre de dossiers de recherche par défaut. L'utilisateur A partage son dossier Calendrier avec 15 autres utilisateurs. L'utilisateur B accède au dossier et doit patienter lors de la création de son dossier de recherche. Une fois le dossier de recherche de l'utilisateur B créé, l'accès au dossier Calendrier de l'utilisateur A est rapide. Supposons que l'utilisateur B n'accède pas au dossier pendant le restant de la journée. Dans le même temps, si 11 autres utilisateurs accèdent au dossier, des dossiers de recherche uniques sont créés pour eux. Étant donné que seulement 11 dossiers de recherche sont mis en cache, la prochaine fois que l'utilisateur B accèdera au Calendrier de l'utilisateur A, il devra de nouveau patienter pendant la création d'un nouveau dossier de recherche pour lui.

Il est recommandé de limiter le nombre maximal de mises en cache de dossiers de recherche à 20. Si vous dépassez cette limite, en particulier pour les dossiers contenant plus de 5 000 éléments, vous risquez de surcharger le serveur alors qu'il tente de mettre à jour les dossiers mis en cache.

Il est également recommandé de ne pas dépasser cinq caches. Si des utilisateurs partagent des dossiers Outlook avec plusieurs utilisateurs, la mise en cache de seulement quatre dossiers de recherche a une incidence négative sur l'utilisation du client et oblige le serveur à utiliser davantage de ressources plus fréquemment lors de la création de nouveaux caches.

L'attribut msExchMaxCachedViews peut également être défini dans des bases de données de dossiers publics. Des dossiers de recherche sont également créés pour des dossiers publics. Par défaut, les dossiers publics sont des ressources partagées auxquelles de nombreux utilisateurs peuvent accéder. Si des dossiers publics reçoivent de nombreuses publications, vous devez diminuer le nombre de dossiers de recherche car le serveur Exchange peut considérablement occuper le processeur et le disque lors de l'actualisation des dossiers de recherche. En outre, il n'est pas recommandé de tenter d'optimiser l'utilisation du client en fournissant de nombreux caches de dossiers de recherche si beaucoup d'utilisateurs accèdent à un dossier public. Ces caches risquent d'être ignorés lors de la création de nouveaux dossiers de recherche pour les nouveaux utilisateurs.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour modifier l'attribut msExchMaxCachedViews

  1. Lancez l'outil ADSI Edit à partir des outils de support de Microsoft Windows® 2000 ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Groupes_administration

    • Nom_groupe_administration

    • Serveurs

    • InformationStore

    • Nom_groupe_stockage

  3. Dans le volet Détails, cliquez avec le bouton droit sur Nom_base_données, puis cliquez sur Propriétés.

  4. Dans la zone Attributs, double-cliquez sur msExchMaxCachedViews.

  5. Dans la boîte de dialogue Éditeur d'attribut de nombre entier, entrez un nombre entier compris entre 5 et 20 dans le champ Valeur, puis cliquez sur OK.

  6. Cliquez sur Appliquer, puis fermez ADSI Edit.

  7. Attendez au moins 15 minutes pour la réplication, puis redémarrez le service de banque d'informations de Microsoft Exchange du serveur Exchange auquel vous avez apporté la modification.


Nombre maximal de vues mises en cache défini sur une valeur trop élevé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le nombre maximal de vues mises en cache par base de données a été modifié. Si Exchange Server Analyzer détecte que l'attribut msExchMaxCachedViews est défini sur une valeur inférieure à 20, il affiche un avertissement. Le nombre de vues mises en cache configuré par base de données est inclus dans les résultats d'Exchange Server Analyzer. Il est recommandé de le définir sur une valeur comprise entre 5 et 20.

L'attribut msExchMaxCachedViews fait partie de la classe d'objet msExchangePrivateMDB. Par conséquent, chaque objet de banque de boîtes aux lettres d'Active Directory possède une valeur d'attribut msExchMaxCachedViews. La valeur de l'attribut msExchMaxCachedViews spécifie le nombre maximal de vues mises en cache pour un dossier spécifique d'une boîte aux lettres. Dans ce contexte, le terme « vue » désigne les dossiers affichés lorsqu'un utilisateur accède à la boîte aux lettres Microsoft Office Outlook® 2003 d'un autre utilisateur. Lorsque des utilisateurs partagent l'accès à un dossier Outlook avec d'autres utilisateurs, Exchange Server génère une vue qui masque les éléments privés.

Lorsqu'un utilisateur Outlook affiche en premier le calendrier, le dossier de contacts ou toute autre donnée d'un autre utilisateur, des retards peuvent survenir. Une fois qu'il a consulté le dossier, il est possible que les vues soient plus rapides lors des tentatives suivantes, mais après un certain délai, il se peut qu'il doive patienter s'il réessaie d'accéder au dossier. Cette attente est généralement plus longue si le dossier contient un grand nombre d'éléments. Par grand nombre, l'on entend au moins 5 000 éléments.

L'application d'une vue à un dossier crée des dossiers de recherche dans la banque Exchange pour chaque utilisateur unique qui accède au dossier Outlook. Lors de sa création, le dossier de recherche est mis en cache pour une utilisation ultérieure. Avant de créer un nouveau dossier de recherche, Exchange Server détermine si ce dossier de recherche existe déjà. Le cas échéant, Exchange Server utilise le dossier de recherche mis en cache pour accélérer les affichages suivants.

L'attribut msExchMaxCachedViews définit le mode de mise en cache de nombreux dossiers de recherche dans un dossier spécifique. Par exemple, l'attribut msExchMaxCachedViews peut définir le nombre de dossiers de recherche mis en cache dans le dossier Calendrier.

Si plusieurs utilisateurs partagent des dossiers Outlook, vous devez décider de la manière d'équilibrer les ressources du serveur et les performances acceptables du client. Lors de sa mise en cache, un dossier de recherche est actualisé au fur et à mesure que ses données sont modifiées. Cette actualisation occupe les ressources disque et processeur. En cas de mise à jour de plusieurs caches du dossier de recherche, les performances du processeur et du disque sont davantage affectées.

Par ailleurs, lorsqu'Exchange Server crée un dossier de recherche pour la première fois, il se peut que l'utilisateur qui accède au dossier Outlook doive patienter pendant la création.

Imaginez par exemple qu'un serveur Exchange est configuré avec 11 dossiers de recherche. Ce chiffre constitue le nombre de dossiers de recherche par défaut. L'utilisateur A partage son dossier Calendrier avec 15 autres utilisateurs. L'utilisateur B accède au dossier et doit patienter lors de la création de son dossier de recherche. Une fois le dossier de recherche de l'utilisateur B créé, l'accès au dossier Calendrier de l'utilisateur A est rapide. Supposons que l'utilisateur B n'accède pas au dossier pendant le restant de la journée. Dans le même temps, si 11 autres utilisateurs accèdent au dossier, des dossiers de recherche uniques sont créés pour eux. Étant donné que seulement 11 dossiers de recherche sont mis en cache, la prochaine fois que l'utilisateur B accèdera au Calendrier de l'utilisateur A, il devra de nouveau patienter pendant la création d'un nouveau dossier de recherche pour lui.

Il est recommandé de limiter le nombre maximal de mises en cache de dossiers de recherche à 20. Si vous dépassez cette limite, en particulier pour les dossiers contenant plus de 5 000 éléments, vous risquez de surcharger le serveur alors qu'il tente de mettre à jour les dossiers mis en cache.

Il est également recommandé de ne pas dépasser cinq caches. Si des utilisateurs partagent des dossiers Outlook avec plusieurs utilisateurs, la mise en cache de seulement quatre dossiers de recherche a une incidence négative sur l'utilisation du client et oblige le serveur à utiliser davantage de ressources plus fréquemment lors de la création de nouveaux caches.

L'attribut msExchMaxCachedViews peut également être défini dans des bases de données de dossiers publics. Des dossiers de recherche sont également créés pour des dossiers publics. Par défaut, les dossiers publics sont des ressources partagées auxquelles de nombreux utilisateurs peuvent accéder. Si des dossiers publics reçoivent de nombreuses publications, vous devez diminuer le nombre de dossiers de recherche car le serveur Exchange peut considérablement occuper le processeur et le disque lors de l'actualisation des dossiers de recherche. En outre, il n'est pas recommandé de tenter d'optimiser l'utilisation du client en fournissant de nombreux caches de dossiers de recherche si beaucoup d'utilisateurs accèdent à un dossier public. Ces caches risquent d'être ignorés lors de la création de nouveaux dossiers de recherche pour les nouveaux utilisateurs.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour modifier l'attribut msExchMaxCachedViews

  1. Lancez l'outil ADSI Edit à partir des outils de support de Microsoft Windows® 2000 ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Groupes_administration

    • Nom_groupe_administration

    • Serveurs

    • InformationStore

    • Nom_groupe_stockage

  3. Dans le volet Détails, cliquez avec le bouton droit sur Nom_base_données, puis cliquez sur Propriétés.

  4. Dans la zone Attributs, double-cliquez sur msExchMaxCachedViews.

  5. Dans la boîte de dialogue Éditeur d'attribut de nombre entier, entrez un nombre entier compris entre 5 et 20 dans le champ Valeur, puis cliquez sur OK.

  6. Cliquez sur Appliquer, puis fermez ADSI Edit.

  7. Attendez au moins 15 minutes pour la réplication, puis redémarrez le service de banque d'informations de Microsoft Exchange du serveur Exchange auquel vous avez apporté la modification.


Nombre maximal de vues mises en cache défini sur une valeur trop faible
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le nombre maximal de vues mises en cache par base de données a été modifié. Si Exchange Server Analyzer détecte que l'attribut msExchMaxCachedViews est défini sur une valeur inférieure à 5, il affiche un avertissement. Le nombre de vues mises en cache configuré par base de données est inclus dans les résultats d'Exchange Server Analyzer. Il est recommandé de le définir sur une valeur comprise entre 5 et 20.

L'attribut msExchMaxCachedViews fait partie de la classe d'objet msExchangePrivateMDB. Par conséquent, chaque objet de banque de boîtes aux lettres d'Active Directory possède une valeur d'attribut msExchMaxCachedViews. La valeur de l'attribut msExchMaxCachedViews spécifie le nombre maximal de vues mises en cache pour un dossier spécifique d'une boîte aux lettres.

Dans ce contexte, le terme « vue » désigne les dossiers affichés lorsqu'un utilisateur accède à la boîte aux lettres Microsoft Office Outlook® 2003 d'un autre utilisateur. Lorsque des utilisateurs partagent l'accès à un dossier Outlook avec d'autres utilisateurs, Exchange Server génère une vue qui masque les éléments privés.

Lorsqu'un utilisateur Outlook affiche en premier le calendrier, le dossier de contacts ou toute autre donnée d'un autre utilisateur, des retards peuvent survenir. Une fois qu'il a consulté le dossier, il est possible que les vues soient plus rapides lors des tentatives suivantes, mais après un certain délai, il se peut qu'il doive patienter s'il réessaie d'accéder au dossier. Cette attente est généralement plus longue si le dossier contient un grand nombre d'éléments. Par grand nombre, l'on entend au moins 5 000 éléments.

L'application d'une vue à un dossier crée des dossiers de recherche dans la banque Exchange pour chaque utilisateur unique qui accède au dossier Outlook. Lors de sa création, le dossier de recherche est mis en cache pour une utilisation ultérieure. Avant de créer un nouveau dossier de recherche, Exchange Server détermine si ce dossier de recherche existe déjà. Le cas échéant, Exchange Server utilise le dossier de recherche mis en cache pour accélérer les affichages suivants.

L'attribut msExchMaxCachedViews définit le mode de mise en cache de nombreux dossiers de recherche dans un dossier spécifique. Par exemple, l'attribut msExchMaxCachedViews peut définir le nombre de dossiers de recherche mis en cache dans le dossier Calendrier.

Si plusieurs utilisateurs partagent des dossiers Outlook, vous devez décider de la manière d'équilibrer les ressources du serveur et les performances acceptables du client. Lors de sa mise en cache, un dossier de recherche est actualisé au fur et à mesure que ses données sont modifiées. Cette actualisation occupe les ressources disque et processeur. En cas de mise à jour de plusieurs caches du dossier de recherche, les performances du processeur et du disque sont davantage affectées.

Par ailleurs, lorsqu'Exchange Server crée un dossier de recherche pour la première fois, il se peut que l'utilisateur qui accède au dossier Outlook doive patienter pendant la création.

Imaginez par exemple qu'un serveur Exchange est configuré avec 11 dossiers de recherche. Ce chiffre constitue le nombre de dossiers de recherche par défaut. L'utilisateur A partage son dossier Calendrier avec 15 autres utilisateurs. L'utilisateur B accède au dossier et doit patienter lors de la création de son dossier de recherche. Une fois le dossier de recherche de l'utilisateur B créé, l'accès au dossier Calendrier de l'utilisateur A est rapide. Supposons que l'utilisateur B n'accède pas au dossier pendant le restant de la journée. Dans le même temps, si 11 autres utilisateurs accèdent au dossier, des dossiers de recherche uniques sont créés pour eux. Étant donné que seulement 11 dossiers de recherche sont mis en cache, la prochaine fois que l'utilisateur B accèdera au Calendrier de l'utilisateur A, il devra de nouveau patienter pendant la création d'un nouveau dossier de recherche pour lui.

Il est recommandé de limiter le nombre maximal de mises en cache de dossiers de recherche à 20. Si vous dépassez cette limite, en particulier pour les dossiers contenant plus de 5 000 éléments, vous risquez de surcharger le serveur alors qu'il tente de mettre à jour les dossiers mis en cache.

Il est également recommandé de ne pas dépasser cinq caches. Si des utilisateurs partagent des dossiers Outlook avec plusieurs utilisateurs, la mise en cache de seulement quatre dossiers de recherche a une incidence négative sur l'utilisation du client et oblige le serveur à utiliser davantage de ressources plus fréquemment lors de la création de nouveaux caches.

L'attribut msExchMaxCachedViews peut également être défini dans des bases de données de dossiers publics. Des dossiers de recherche sont également créés pour des dossiers publics. Par défaut, les dossiers publics sont des ressources partagées auxquelles de nombreux utilisateurs peuvent accéder. Si des dossiers publics reçoivent de nombreuses publications, vous devez diminuer le nombre de dossiers de recherche car le serveur Exchange peut considérablement occuper le processeur et le disque lors de l'actualisation des dossiers de recherche. En outre, il n'est pas recommandé de tenter d'optimiser l'utilisation du client en fournissant de nombreux caches de dossiers de recherche si beaucoup d'utilisateurs accèdent à un dossier public. Ces caches risquent d'être ignorés lors de la création de nouveaux dossiers de recherche pour les nouveaux utilisateurs.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, Exchange Server 2003 ou les deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour modifier l'attribut msExchMaxCachedViews

  1. Lancez l'outil ADSI Edit à partir des outils de support de Microsoft Windows® 2000 ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Groupes_administration

    • Nom_groupe_administration

    • Serveurs

    • InformationStore

    • Nom_groupe_stockage

  3. Dans le volet Détails, cliquez avec le bouton droit sur Nom_base_données, puis cliquez sur Propriétés.

  4. Dans la zone Attributs, double-cliquez sur msExchMaxCachedViews.

  5. Dans la boîte de dialogue Éditeur d'attribut de nombre entier, entrez un nombre entier compris entre 5 et 20 dans le champ Valeur, puis cliquez sur OK.

  6. Cliquez sur Appliquer, puis fermez ADSI Edit.

  7. Attendez au moins 15 minutes pour la réplication, puis redémarrez le service de banque d'informations de Microsoft Exchange du serveur Exchange auquel vous avez apporté la modification.


Cache ESE maximal modifié manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-02-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamCacheSizeMax pour tous les objets de banque de boîtes aux lettres. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchESEParamCacheSizeMax pour toutes les banques de boîtes aux lettres doit être supérieure à 0 et inférieure à 219727, un message indiquant une configuration autre que celle par défaut s'affiche.

Dans Exchange 2000 Server, une grande zone de la mémoire virtuelle utilisée par STORE.EXE est allouée au tampon ESE. Exchange 2000 Server utilise une valeur par défaut codée de manière irréversible de 858 mégaoctets (Mo) pour ce tampon. Dans Exchange Server 2003, l'allocation de tampon ESE se base sur la présence du commutateur /3GB dans le fichier Boot.ini. Si le commutateur /3GB est présent, le tampon ESE est réglé sur 896 Mo. Si le commutateur /3GB n'est pas présent, le tampon ESE est réglé sur 576 Mo. Alors qu'un réglage automatique s'avère utile dans chaque cas, vous pouvez remplacer le réglage automatique et définir manuellement une valeur plus appropriée à votre environnement. Alors que vous pouvez régler cette valeur sur tout multiple de 8192, il est recommandé de n'utiliser qu'une valeur du tableau suivant :

Valeur recommandée | Mémoire allouée | Commentaires
147456 | 576 Mo | Il s'agit du minimum recommandé. Ne définissez pas la valeur sur un nombre inférieur. Cette valeur est utile sur des serveurs limités par la mémoire virtuelle et sur des ordinateurs Exchange Server 2003 exécutés sur Microsoft Windows® 2000 Server, qui ne prend pas en charge le commutateur /3GB. Cette valeur est également celle par défaut sur les systèmes qui n'utilisent pas le commutateur /3GB.
196608 | 768 Mo | Cette valeur est recommandée sur des serveurs disposant d'une grande mémoire virtuelle, qui enregistre fréquemment l'événement 9582.
219726 | 858 Mo | Cette valeur est celle par défaut dans Exchange 2000 Server et convient sur des systèmes dont vous effectuez la mise à niveau en place et qui disposent d'une grande mémoire virtuelle.
229376 | 896 Mo | Cette valeur est celle par défaut dans Exchange Server 2003 et convient sur de nouveaux systèmes, sauf si votre journal des événements Applications indique autre chose avec la présence de 9 582 événements.
311296 | 1,2 Go | Il s'agit de la valeur maximale que vous pouvez définir. Cette valeur ne doit être utilisée que sur des systèmes disposant d'au moins 2 Go de mémoire physique.

Avant de reconfigurer cette valeur, vous devez analyser la taille de la mémoire virtuelle utilisée par le processus STORE.EXE. À cet effet, vous pouvez analyser l'objet de performance Processus dans Windows. Sur les systèmes disposant du commutateur /3GB, le compteur Virtual Bytes pour l'instance STORE.EXE de l'objet Process doit être inférieur à 2,8 Go. Sur les systèmes ne disposant pas du commutateur /3GB, il doit être inférieur à 1,8 Go. Si les valeurs sont supérieures à ces nombres, vous risquez de devoir réduire la valeur de msExchESEParamCacheSizeMax. Si les valeurs sont inférieures à ces nombres, vous risquez de devoir augmenter la valeur de msExchESEParamCacheSizeMax.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour régler l'attribut msExchESEParamCacheSizeMax

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration.

  3. Développez CN=Services.

  4. Développez CN=Microsoft_Exchange.

  5. Développez CN=<Nom_organisation_Exchange>.

  6. Développez CN=Groupes_administration.

  7. Développez CN=<Nom_groupe_administration >.

  8. Développez CN=Serveurs.

  9. Développez CN=<Nom_serveur_Exchange>.

  10. Cliquez avec le bouton droit sur CN=Banque_informations, puis sur Propriétés.

  11. Dans le champ d'attributs, faites défiler et double-cliquez sur msExchESEParamCacheSizeMax.

  12. Dans le champ Valeur, entrez la valeur à définir. Utilisez le tableau de cet article pour déterminer la valeur optimale pour votre système. Notez que la valeur utilisée doit être un multiple de 8 192.

  13. Cliquez sur OK, puis de nouveau sur OK.

  14. Fermez l'Éditeur Active Directory et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'optimisation de l'utilisation de la mémoire, voir l'article 815372 de la Base de connaissances Microsoft sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Pour plus d'informations sur l'attribut msExchESEParamCacheSizeMax, voir l'article 266768 de la Base de connaissances sur la procédure de modification de la taille maximale du cache de la base de données des banques (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


La taille maximale du cache ESE est définie sur une valeur trop élevée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-02-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamCacheSizeMax pour tous les objets de banque de boîtes aux lettres. Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeIS_MSExchangeIS pour déterminer la valeur de la clé VMLargestBlockSize. La clé VMLargestBlockSize représente la taille (en octets) du plus grand bloc de mémoire virtuelle disponible.

En outre, Exchange Server Analyzer interroge Active Directory pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détecte que la valeur de msExchESEParamCacheSizeMax est supérieure à 219726 et que la valeur de VMLargestBlockSize est supérieure à 50000000 mais inférieure à 150000000 sur un ordinateur Exchange Server comportant plus de 20 boîtes aux lettres, une erreur s'affiche. Cette erreur indique que l'attribut msExchESEParamCacheSizeMax est défini sur une valeur trop élevée pour cet ordinateur Exchange Server.

Dans Exchange 2000 Server, une grande zone de la mémoire virtuelle utilisée par STORE.EXE est allouée au tampon ESE. Exchange 2000 Server utilise une valeur par défaut codée de manière irréversible de 858 mégaoctets (Mo) pour ce tampon. Dans Exchange Server 2003, l'allocation de tampon ESE se base sur la présence du commutateur /3GB dans le fichier Boot.ini. Si le commutateur /3GB est présent, le tampon ESE est réglé sur 896 Mo. Si le commutateur /3GB n'est pas présent, le tampon ESE est réglé sur 576 Mo. Bien qu'un réglage automatique soit systématiquement correct, vous pouvez souhaiter remplacer ce réglage et définir manuellement une valeur plus appropriée à votre environnement. Alors que vous pouvez régler cette valeur sur tout multiple de 8 192, il est recommandé d'utiliser uniquement une valeur du tableau suivant :

Valeur recommandée | Mémoire allouée | Commentaires
147456 | 576 Mo | Il s'agit du minimum recommandé. Ne définissez pas la valeur sur un nombre inférieur. Cette valeur est utile sur des serveurs limités par la mémoire virtuelle et sur des ordinateurs Exchange Server 2003 exécutés sur Microsoft Windows 2000 Server, qui ne prend pas en charge le commutateur /3GB. Cette valeur est également celle par défaut sur les systèmes qui n'utilisent pas le commutateur /3GB.
196608 | 768 Mo | Cette valeur est recommandée sur des serveurs disposant d'une grande mémoire virtuelle, qui enregistre fréquemment l'événement 9582.
219726 | 858 Mo | Cette valeur est celle par défaut dans Exchange 2000 Server et convient sur des systèmes dont vous effectuez la mise à niveau en place et qui disposent d'une grande mémoire virtuelle.
229376 | 896 Mo | Cette valeur est celle par défaut dans Exchange Server 2003 et convient sur de nouveaux systèmes, sauf si votre journal des événements Applications indique autre chose avec la présence de 9 582 événements.
311296 | 1,2 Go | Il s'agit de la valeur maximale que vous pouvez définir. Cette valeur ne doit être utilisée que sur des systèmes disposant d'au moins 2 Go de mémoire physique.

Avant de reconfigurer cette valeur, vous devez analyser la taille de la mémoire virtuelle utilisée par le processus STORE.EXE. À cet effet, vous pouvez analyser l'objet de performance Processus dans Windows. Sur les systèmes disposant du commutateur /3GB, le compteur Virtual Bytes pour l'instance STORE.EXE de l'objet Process doit être inférieur à 2,8 Go. Sur les systèmes ne disposant pas du commutateur /3GB, il doit être inférieur à 1,8 Go. Si les valeurs sont supérieures à ces nombres, vous risquez de devoir réduire la valeur de msExchESEParamCacheSizeMax. Si les valeurs sont inférieures à ces nombres, vous souhaitez peut-être augmenter la valeur de msExchESEParamCacheSizeMax.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour régler l'attribut msExchESEParamCacheSizeMax

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration.

  3. Développez CN=Services.

  4. Développez CN=Microsoft_Exchange.

  5. Développez CN=<Nom_organisation_Exchange>.

  6. Développez CN=Groupes_administration.

  7. Développez CN=<Nom_groupe_administration >.

  8. Développez CN=Serveurs.

  9. Développez CN=<Nom_serveur_Exchange>.

  10. Cliquez avec le bouton droit sur CN=Banque_informations, puis sur Propriétés.

  11. Dans le champ d'attributs, faites défiler et double-cliquez sur msExchESEParamCacheSizeMax.

  12. Dans le champ Valeur, entrez la valeur à définir. Utilisez le tableau pour déterminer la valeur optimale pour votre système. Notez que la valeur utilisée doit être un multiple de 8 192.

  13. Cliquez sur OK, puis de nouveau sur OK.

  14. Fermez l'Éditeur Active Directory et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'optimisation de l'utilisation de la mémoire, voir l'article 815372 de la Base de connaissances Microsoft sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Pour plus d'informations sur l'attribut msExchESEParamCacheSizeMax, voir l'article 266768 de la Base de connaissances sur la procédure de modification de la taille maximale du cache de la base de données des banques (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


Taille maximale du cache ESE augmentée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-02-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamCacheSizeMax pour tous les objets de banque de boîtes aux lettres.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeIS_MSExchangeIS pour déterminer la valeur de la clé VMLargestBlockSize. La clé VMLargestBlockSize représente la taille (en octets) du plus grand bloc de mémoire virtuelle disponible.

En outre, Exchange Server Analyzer interroge Active Directory pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détecte que la valeur msExchESEParamCacheSizeMax est supérieure à 219726 et que la valeur de VMLargestBlockSize n'est pas comprise entre les valeurs suivantes sur l'ordinateur Exchange Server comprenant plus de 20 boîtes aux lettres, un avertissement s'affiche :

  • supérieure à 50000000 et inférieure à 150000000.

  • supérieure à 0 et inférieure à 50000001.

Cet avertissement indique que l'attribut msExchESEParamCacheSizeMax a été augmenté sur cet ordinateur Exchange Server et peut engendrer une insuffisance de mémoire virtuelle.

Dans Exchange 2000 Server, une grande zone de la mémoire virtuelle utilisée par STORE.EXE est allouée au tampon ESE. Exchange 2000 Server utilise une valeur par défaut codée de manière irréversible de 858 mégaoctets (Mo) pour ce tampon. Dans Exchange Server 2003, l'allocation de tampon ESE se base sur la présence du commutateur /3GB dans le fichier Boot.ini. Si le commutateur /3GB est présent, le tampon ESE est réglé sur 896 Mo. Si le commutateur /3GB n'est pas présent, le tampon ESE est réglé sur 576 Mo. Alors qu'un réglage automatique s'avère utile dans chaque cas, vous pouvez remplacer le réglage automatique et définir manuellement une valeur plus appropriée à votre environnement. Alors que vous pouvez régler cette valeur sur tout multiple de 8 192, il est recommandé de n'utiliser qu'une valeur du tableau suivant :

Valeur recommandée | Mémoire allouée | Commentaires
147456 | 576 Mo | Il s'agit du minimum recommandé. Ne définissez pas la valeur sur un nombre inférieur. Cette valeur est utile sur des serveurs limités par la mémoire virtuelle et sur des ordinateurs Exchange Server 2003 exécutés sur Microsoft Windows 2000 Server, qui ne prend pas en charge le commutateur /3GB. Cette valeur est également celle par défaut sur les systèmes qui n'utilisent pas le commutateur /3GB.
196608 | 768 Mo | Cette valeur est recommandée sur des serveurs disposant d'une grande mémoire virtuelle, qui enregistre fréquemment l'événement 9582.
219726 | 858 Mo | Cette valeur est celle par défaut dans Exchange 2000 Server et convient sur des systèmes dont vous effectuez la mise à niveau en place et qui disposent d'une grande mémoire virtuelle.
229376 | 896 Mo | Cette valeur est celle par défaut dans Exchange Server 2003 et convient sur de nouveaux systèmes, sauf si votre journal des événements Applications indique autre chose avec la présence de 9 582 événements.
311296 | 1,2 Go | Il s'agit de la valeur maximale que vous pouvez définir. Cette valeur ne doit être utilisée que sur des systèmes disposant d'au moins 2 Go de mémoire physique.

Avant de reconfigurer cette valeur, vous devez analyser la taille de la mémoire virtuelle utilisée par le processus STORE.EXE. À cet effet, vous pouvez analyser l'objet de performance Processus dans Windows. Sur les systèmes disposant du commutateur /3GB, le compteur Virtual Bytes pour l'instance STORE.EXE de l'objet Process doit être inférieur à 2,8 Go. Sur les systèmes ne disposant pas du commutateur /3GB, il doit être inférieur à 1,8 Go. Si les valeurs sont supérieures à ces nombres, vous risquez de devoir réduire la valeur de msExchESEParamCacheSizeMax. Si les valeurs sont inférieures à ces nombres, vous risquez de devoir augmenter la valeur de msExchESEParamCacheSizeMax.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour régler l'attribut msExchESEParamCacheSizeMax

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration.

  3. Développez CN=Services.

  4. Développez CN=Microsoft_Exchange.

  5. Développez CN=<Nom_organisation_Exchange>.

  6. Développez CN=Groupes_administration.

  7. Développez CN=<Nom_groupe_administration >.

  8. Développez CN=Serveurs.

  9. Développez CN=<Nom_serveur_Exchange>.

  10. Cliquez avec le bouton droit sur CN=Banque_informations, puis sur Propriétés.

  11. Dans le champ d'attributs, faites défiler et double-cliquez sur msExchESEParamCacheSizeMax.

  12. Dans le champ Valeur, entrez la valeur à définir. Utilisez le tableau de cet article pour déterminer la valeur optimale pour votre système. Notez que la valeur utilisée doit être un multiple de 8 192.

  13. Cliquez sur OK, puis de nouveau sur OK.

  14. Fermez l'Éditeur Active Directory et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'optimisation de l'utilisation de la mémoire, voir l'article 815372 de la Base de connaissances Microsoft sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372).

Pour plus d'informations sur l'attribut msExchESEParamCacheSizeMax, voir l'article 266768 de la Base de connaissances sur la procédure de modification de la taille maximale du cache de la base de données des banques (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768).


La valeur MaxOpenMessagesPerLogon a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-05-14

L'outil Microsoft Exchange Analyzer lit l'entrée de Registre suivante pour déterminer si la valeur de Registre MaxOpenMessagesPerLogon est présente et configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Analyzer détecte que la valeur de Registre MaxOpenMessagesPerLogon est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Chaque fois qu'une application ou un client MAPI ouvre un message sur un ordinateur Exchange Server, le service Banque d'informations de Microsoft Exchange (store.exe) consomme une petite quantité de mémoire physique. Lorsque le message est fermé par les clients Microsoft Office Outlook 2003 ou Outlook 2007, la mémoire est libérée. Pour éviter qu'un ou plusieurs clients MAPI n'entraînent une allocation continue de mémoire par les services de banque d'informations d'Exchange, une nouvelle fonctionnalité de configuration a été introduite dans Exchange 2000 Server Service Pack 1 (SP1). Elle permet à un administrateur de limiter le nombre de messages que chaque ouverture de session de client MAPI peut ouvrir simultanément. La définition d'une telle limite peut s'avérer utile dans votre environnement si certaines applications clientes ouvrent involontairement de nombreux messages, affectant ainsi les performances générales du serveur.

Cette fonctionnalité est mise en oeuvre à l'aide de la valeur de Registre MaxOpenMessagesPerLogon sur l'ordinateur Exchange Server. Il est recommandé de définir une limite inférieure à 1 000. Une valeur de 1 000 permet à chaque client d'utiliser environ 4 à 6 mégaoctets (Mo) de mémoire. Pour certains environnements, une valeur inférieure de 500 peut être plus appropriée.

Important :
Cet article contient des informations sur la procédure de modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer un nombre maximal de messages ouverts simultanément

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Ouvrez :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Cliquez avec le bouton droit sur ParametersSystem, sélectionnez Nouveau | Valeur DWORD et nommez la nouvelle valeur MaxOpenMessagesPerLogon.

  4. Dans le volet droit, double-cliquez sur la valeur MaxOpenMessagesPerLogon, puis entrez le nombre maximal de messages ouverts simultanément (nombre décimal).

  5. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre MaxOpenMessagesPerLogon, voir l'article 289109 de la Base de connaissances Microsoft sur la procédure pour limiter le nombre de messages ouverts pour chaque ouverture de session MAPI (http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109).


Le nombre maximal de bases de données par groupe de stockage a été modifié manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchMaxStoresPerGroup de chaque groupe de stockage. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchMaxStoresPerGroup pour tous les groupes de stockage n'est pas égale à 5, une erreur s'affiche.

Cette valeur s'applique à tous les groupes de stockage sur le serveur. Cette erreur particulière se produit si la valeur de cet attribut a été modifiée de sa valeur par défaut de 5. Il s'agit de la seule valeur prise en charge. Elle ne doit jamais être modifiée. Exchange Server ne fonctionne pas correctement si cette valeur est augmentée.

Vous devez corriger la valeur à l'aide d'un outil, tel que le composant logiciel enfichable ADSI (Active Directory Service Interfaces) Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Développez CN=<Nom_serveur>, cliquez avec le bouton droit sur CN=Banque_informations, puis cliquez sur Propriétés.

  5. Dans l'Éditeur d'attribut, cliquez sur l'attribut msExchMaxStoresPerGroup, puis sur Modifier.

  6. Dans la boîte de dialogue Modifier l'attribut, définissez la valeur sur 5.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Fermez ADSI Edit, puis redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur le nombre maximal autorisé de groupes de stockage, voir l'article de la Base de connaissances sur le nombre maximal de groupes de stockage pour la planification de la capacité de base de données dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123).

Pour plus d'informations sur l'utilisation de l'outil ADSI Edit, voir la rubrique sur Adsiedit.msc : ADSI Edit dans l'aide de Windows Server.


Le nombre maximal de groupes de stockage a été modifié manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchMaxStorageGroups de chaque conteneur InformationStore. Si Exchange Server Analyzer établit que la valeur de l'un des attributs msExchMaxStorageGroups n'est pas égale à 4, une erreur s'affiche.

La seule valeur prise en charge pour l'attribut msExchMaxStorageGroups est 4 et cette valeur ne doit jamais être changée. Exchange ne fonctionne pas correctement si cette valeur est modifiée.

Vous devez corriger la valeur à l'aide d'un éditeur Active Directory, tel que le composant logiciel enfichable ADSI Edit, l'outil LDP (ldp.exe) ou tout autre client LDAP (Lightweight Directory Access Protocol) version 3.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur

  1. À l'aide d'ADSI Edit ou d'un outil similaire, recherchez l'objet InformationStore pour ce serveur dans Active Directory.

    L'attribut msExchMaxStorageGroups peut se trouver dans :

    CN=Configuration,DC=Domaine,CN=com, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Groupes_administration, CN=Nom_groupe_administration, CN=Serveurs, CN=Nom_serveur, CN=Banque_informations

  2. Modifiez l'attribut msExchMaxStorageGroups en entrant la nouvelle valeur 4.

  3. Fermez l'Éditeur Active Directory puis redémarrez l'ordinateur Exchange Server pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil LDP, voir l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Le nombre maximal d'objets dossier ouvert par ouverture de session a été modifié
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le nombre maximal par défaut de dossiers qu'il est possible d'ouvrir par session MAPI a été modifié :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

Si Exchange Server Analyzer détecte que la valeur de Registre objtFolder est présente et configurée avec une valeur différente de 500, un message indiquant une configuration autre que celle par défaut s'affiche.

Ajoutée et configurée manuellement, la valeur de Registre objtFolder détermine le nombre maximal de dossiers qu'il est possible d'ouvrir par client MAPI. Par défaut, Exchange Server 2003 et Exchange Server 2007 limitent le nombre de dossiers ouverts à 500. Lorsqu'un client MAPI tente d'ouvrir plus de 500 dossiers, l'événement suivant est enregistré dans le journal des événements Applications sur l'ordinateur Exchange Server qui contient la boîte aux lettres du client :

Type d'événement : | Erreur
ID d'événement : | 9646
Source de l'événement : | MSExchangeIS
Catégorie de l'événement : | Général
Description : | Fermeture de la session Mapi « /o=Nom_organisation/ou=Nom_groupe_administration/cn=Destinataires/cn=Nom_utilisateur » en raison du dépassement du nombre maximal de 500 objets de type « objtFolder ».

La valeur de Registre objtFolder représente une opportunité de configuration offrant à l'administrateur un niveau supérieur de contrôle des ressources Exchange Server utilisées par les clients MAPI.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Supprimez la valeur de Registre objtFolder.

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

  5. Si vous souhaitez utiliser la valeur de Registre objtFolder, au lieu de la supprimer, vous pouvez également la conserver avec la même définition de valeur ou l'ajuster au besoin.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations, consultez l'article 830829 de la Base de connaissances sur l'ordinateur Exchange Server 2003 qui peut cesser de répondre lorsqu'un client MAPI ouvre plus d'objets serveur qu'autorisé par la valeur par défaut (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Le nombre maximal de vues de dossiers ouvertes par ouverture de session a été modifié
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le nombre maximal par défaut de vues de dossiers qu'il est possible d'ouvrir par session MAPI a été modifié :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

Si Exchange Server Analyzer détecte que la valeur de Registre objtFolderView est présente et configurée avec une valeur différente de 500, un message indiquant une configuration autre que celle par défaut s'affiche.

Ajoutée et configurée manuellement, la valeur de Registre objtFolderView détermine le nombre maximal de vues de dossiers qu'il est possible d'ouvrir par client MAPI. Par défaut, Exchange Server 2003 et Exchange Server 2007 limitent le nombre de vues de dossiers ouvertes à 500. Lorsqu'un client MAPI tente d'ouvrir plus de 500 vues de dossiers, l'événement suivant est enregistré dans le journal des événements Applications sur l'ordinateur Exchange Server qui contient la boîte aux lettres du client :

Type d'événement : Erreur

Source de l'événement : MSExchangeIS

Catégorie de l'événement : Général

Description : Fermeture de la session Mapi « /o= Nom_organisation /ou= Nom_groupe_administration /cn=Destinataires/cn= UserName » en raison du dépassement du nombre maximal de 500 objets de type « objtFolderView ».

La valeur de Registre objtFolderView représente une opportunité de configuration offrant à l'administrateur un niveau supérieur de contrôle des ressources Exchange Server utilisées par les clients MAPI.

Important :
Cet article contient des informations sur la procédure de modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Supprimez la valeur de Registre objtFolderView .

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

  5. Si vous souhaitez utiliser la valeur de Registre objtFolderView, au lieu de la supprimer, vous pouvez également la conserver avec la même définition de valeur ou l'ajuster au besoin.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations, consultez l'article 830829 de la Base de connaissances Microsoft « Votre ordinateur Exchange Server 2003 peut cesser de répondre lorsqu'un client MAPI ouvre plus d'objets serveur qu'autorisé par la valeur par défaut » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


Le nombre maximal d'objets message ouverts par ouverture de session a été modifié
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le nombre maximal par défaut de messages ouverts par session MAPI a été modifié :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

Si Exchange Server Analyzer détecte que la valeur de Registre objtMessage est présente et configurée avec une valeur différente de 250, un message indiquant une configuration autre que celle par défaut s'affiche.

Ajoutée et configurée manuellement, la valeur de Registre objtMessage détermine le nombre maximal de messages ouverts par client MAPI. Par défaut, Exchange Server 2003 et Exchange Server 2007 limitent le nombre de messages ouverts à 250. Lorsqu'un client MAPI tente d'ouvrir plus de 250 messages, l'événement suivant est enregistré dans le journal des événements d'applications sur l'ordinateur Exchange Server qui contient la boîte aux lettres du client :

Type d'événement : Erreur

ID d'événement : 9646

Source de l'événement : MSExchangeIS

Catégorie de l'événement : Général

Description : Fermeture de la session Mapi « /o= Nom_organisation /ou= Nom_groupe_administration /cn=Destinataires/cn= UserName » parce qu'il a dépassé le nombre maximal de 250 objets de type « objtMessage ».

La valeur de Registre objtMessage représente une opportunité de configuration offrant à l'administrateur un niveau supérieur de contrôle des ressources Exchange Server utilisées par les clients MAPI.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à :

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Supprimez la valeur de Registre objtMessage.

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

  5. Si vous souhaitez utiliser la valeur de Registre objtMessage, au lieu de la supprimer, vous pouvez également la conserver avec la même définition de valeur ou l'ajuster au besoin.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations, consultez l'article 830829 de la Base de connaissances sur l'ordinateur Exchange Server 2003 qui peut cesser de répondre lorsqu'un client MAPI ouvre plus d'objets serveur qu'autorisé par la valeur par défaut (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829).


La fréquence d'interrogation maximale n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si la fréquence d'interrogation des clients Microsoft Office Outlook® 2003 et Outlook 2007 qui accèdent à Exchange Server 2003 ou à Exchange Server 2007 à l'aide de la fonctionnalité RPC sur HTTP a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

Si Exchange Server Analyzer détecte que la clé Maximum Polling Frequency est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Lors de sa première connexion à un serveur Exchange, Outlook s'enregistre pour les notifications de nouveaux messages. Dès la réception d'un nouveau message dans la boîte aux lettres d'un utilisateur Outlook, Exchange envoie une notification à Outlook à l'aide du protocole UDP (User Datagram Protocol). À la réception de cette notification, Outlook récupère le message du serveur Exchange et l'affiche dans le dossier approprié. Si Outlook ne reçoit pas de notification de nouveaux messages, il réinterroge le serveur Exchange. Bien que cette interrogation soit effectuée par Outlook, la fréquence en est imposée par le serveur Exchange.

Par défaut, Outlook 2003 effectue une interrogation toutes les 60 secondes. Vous pouvez modifier la fréquence en ajoutant l'entrée de Registre Maximum Polling Frequency au serveur Exchange qui contient la boîte aux lettres de l'utilisateur. La valeur entrée correspond au nombre minimal de millisecondes entre chaque interrogation. Si l'entrée Maximum Polling Frequency n'est pas présente, une valeur par défaut de 60 secondes (60 000 millisecondes) est utilisée. Cette valeur par défaut ne signifie pas que l'interrogation est effectuée toutes les 60 secondes, mais plutôt à tout moment entre les intervalles d'interrogation et deux fois pendant cet intervalle. Supposons par exemple que l'entrée Maximum Polling Frequency est définie sur 90 secondes. Dans cet exemple, l'interrogation est effectuée entre 90 et 180 secondes après la dernière interrogation.

Ne réduisez pas la valeur à une valeur inférieure à celle par défaut de 60 secondes car cela altérerait les performances pour Exchange, Outlook et le réseau. Vous ne devez pas nécessairement ajuster cette valeur car de nombreuses actions de l'utilisateur provoquent la vérification des nouveaux messages dans le cadre d'opérations internes. Par exemple, si un utilisateur bascule entre des dossiers ou ouvre un message, de nouveaux éléments sont affichés sur le serveur. En effet, lorsqu'Outlook envoie les requêtes RPC nécessaires à Exchange pour appliquer les actions de l'utilisateur, l'indicateur de nouveau message est vérifié et, le cas échéant, la notification de nouveau message est incluse dans la réponse RPC renvoyée à Outlook.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la valeur de Registre Maximum Polling Frequency.

  4. Redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la fonctionnalité RPC sur HTTP, consultez le guide sur les scénarios de déploiement de RPC sur HTTP dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47577).


Le cache ESE minimal a été modifié manuellement
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-01-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamCacheSizeMin pour tous les objets de banque de boîtes aux lettres. Si Exchange Server Analyzer découvre que la valeur de l'attribut msExchESEParamCacheSizeMin de chaque banque de boîtes aux lettres est supérieur à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Le service de banque d'informations de Microsoft Exchange utilise le cache ESE (Extensible Storage Engine) comme tampon lors de l'écriture de données de la banque d'informations sur le disque. Exchange 2000 Server utilise une taille maximale de cache de 858 Mo. Exchange Server 2003 détermine dynamiquement la valeur par défaut de la propriété msExchESEParamCacheSizeMin en fonction de la quantité physique de mémoire vive (RAM) installée sur le serveur.

Par exemple, la taille de cache maximale d'un ordinateur Exchange Server 2003 ayant le commutateur /3GB défini dans son fichier boot.ini est de 896 Mo. Si le commutateur /3GB n'est pas défini, la taille maximale du cache est de 576 Mo.

Les informations suivantes vous permettent de restaurer la valeur d'origine de la propriété msExchESEParamCacheSizeMin :

  • Si Exchange Server 2003 est exécuté sous Microsoft Windows Server™ 2003 et que le serveur dispose de 2 Go ou plus de RAM, la valeur de msExchESEParamCacheSizeMin est de 131072 (512 Mo).

  • Si Exchange Server 2003 est exécuté sous Windows Server 2003 et que la mémoire RAM du serveur est égale ou supérieure à 768 Mo mais inférieure à 2 Go, msExchESEParamCacheSizeMin est égal à « RAM/4*(4*1024) ».

  • Si Exchange Server 2003 est exécuté sous Windows Server 2003 et que la mémoire RAM du serveur est inférieure à 768 Mo, msExchESEParamCacheSizeMin est égal à « RAM/8*(4*1024) ».

Par exemple :

  • Windows Server 2003 avec 512 Mo de RAM aura une valeur par défaut pour msExchESEParamCacheSizeMin de 16 384 (pages de 4 Ko).

  • Windows Server 2003 avec 1 Go de RAM aura une valeur par défaut pour msExchESEParamCacheSizeMin de 65536 (pages de 4 Ko).

  • Windows Server 2003 avec 4 Go de RAM aura une valeur par défaut pour msExchESEParamCacheSizeMin de 131072 (pages de 4 Ko).

  • Si Exchange Server 2003 est exécuté sous Microsoft Windows® 2000 Server, aucune valeur par défaut n'est définie pour msExchESEParamCacheSizeMin.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Windows Server 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour supprimer cet avertissement

  1. Ouvrez un éditeur Active Directory, tel qu'ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration.

  3. Développez CN=Services.

  4. Développez CN=Microsoft_Exchange.

  5. Développez CN=<Nom_organisation_Exchange>.

  6. Développez CN=Groupes_administration.

  7. Développez CN=<Nom_groupe_administration >.

  8. Développez CN=Serveurs.

  9. Développez CN=<Nom_serveur_Exchange>.

  10. Cliquez avec le bouton droit sur CN=Banque_informations, puis sur Propriétés.

  11. Dans le champ Attributs, faites défiler et double-cliquez sur msExchESEParamCacheSizeMin.

  12. Dans le champ Valeur, entrez la valeur à définir. Vous pouvez utiliser la formule par défaut et l'adapter à votre situation. La valeur utilisée doit être un multiple de 32 Mo.

  13. Cliquez sur OK, puis de nouveau sur OK.

  14. Fermez l'Éditeur Active Directory et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur le réglage de l'attribut msExchESEParamCacheSizeMin, voir l'article 822894 de la Base de connaissances Microsoft sur le fonctionnement incorrect de la base de données Jet pendant une sauvegarde ou une opération d'indexation de contenu (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894).


Le nombre de threads du processus store est élevé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Process pour déterminer la valeur de ThreadCount pour le processus de banque d'informations d'Exchange. Cette valeur représente le nombre de threads de banque d'informations actifs sur le serveur. S'il y a plus de 400 threads de banque d'informations actifs, un message d'avertissement s'affiche.

Ce problème est généralement dû à un logiciel antivirus incompatible exécuté sur le même ordinateur.

Pour supprimer cet avertissement

  1. Contactez votre fournisseur pour vous assurer que vous exécutez un logiciel antivirus récent et compatible avec Exchange.

  2. Mettez à jour votre logiciel antivirus.

Pour plus d'informations sur le logiciel antivirus et Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et de logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).


Le paramètre de Registre OAB Bandwidth Threshold (KBps) n'est pas configuré par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la clé de Registre OAB Bandwidth Threshold (KBps) a été créée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la clé de Registre OAB Bandwidth Threshold (KBps) a été créée sous ParametersSystem, il affiche un message indiquant une configuration autre que celle par défaut.

Dans Microsoft Exchange Server 2003 Service Pack 1 (SP1), l'administrateur peut définir et configurer la clé de Registre OAB Bandwidth Threshold (KBps) pour remplacer la fonctionnalité par défaut et limiter la bande passante utilisée pour les téléchargements complets d'un carnet d'adresses en mode hors connexion à partir d'une banque publique spécifique.

Par défaut, chaque demande client pour un téléchargement complet d'un carnet d'adresses en mode hors connexion est exécutée immédiatement. En outre, la banque publique ne limite pas le nombre de téléchargements complets simultanés de carnets d'adresses en mode hors connexion. Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise. Toutefois, vous pouvez supprimer la clé de Registre OAB Bandwidth Threshold (KBps) si vous souhaitez rétablir la configuration par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la valeur OAB Bandwidth Threshold (KBps).

  4. Fermez l'Éditeur du Registre.

Le service de banque d'informations de Microsoft Exchange détecte les modifications en quelques minutes. Il n'est pas nécessaire de redémarrer l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la limitation de la bande passante utilisée durant les téléchargements de carnets d'adresses en mode hors connexion, voir l'article 867623 de la Base de connaissances sur la limitation des téléchargements complets de carnets d'adresses en mode hors connexion pour réduire les effets sur un réseau LAN dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623).


Le Carnet d'adresses en mode hors connexion n'est pas associé à une banque de boîtes aux lettres spécifique
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchUseOAB de la classe msExchPrivateMDB a été configuré pour utiliser un Carnet d'adresses en mode hors connexion spécifique pour une banque de boîtes aux lettres particulière d'une base de données. La classe msExchPrivateMDB définit la configuration pour une base de données privée. L'attribut msExchUseOAB détermine le Carnet d'adresses en mode hors connexion spécifique qu'une banque de boîtes aux lettres particulière utilise. Si Exchange Server Analyzer détecte que le Carnet d'adresses en mode hors connexion pour la banque de boîtes aux lettres est manquant, il affiche un message d'erreur.

Dans Exchange 2000 Server et les versions ultérieures, une liste d'adresses en mode hors connexion est associée à tous les utilisateurs contenus dans une banque d'informations. Vous ne pouvez pas associer automatiquement une liste d'adresses en mode hors connexion à une boîte aux lettres spécifique ni ignorer les paramètres généraux de liste d'adresses en mode hors connexion pour la banque d'informations ou le groupe de stockage.

Pour associer une liste d'adresses en mode hors connexion à une boîte aux lettres spécifique, vous devez d'abord créer une liste d'adresses en mode hors connexion qui contient une copie filtrée de la liste d'adresses globale. Vous devez ensuite associer la liste d'adresses en mode hors connexion à une boîte aux lettres spécifique à l'aide d'Active Directory Service Interfaces (ADSI) Edit ou d'un autre client LDAP version 3 pour définir l'attribut msExchUseOAB sur le nom unique complet de la liste d'adresses en mode hors connexion.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour des instructions détaillées sur l'association d'un Carnet d'adresses en mode hors connexion à une boîte aux lettres particulière, consultez l'article 275203 de la Base de connaissances Microsoft sur l'impossibilité d'associer le Carnet d'adresses en mode hors connexion à une boîte aux lettres particulière (http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203).

Pour en savoir plus sur les Carnets d'adresses en mode hors connexion, consultez le guide des recommandations du carnet d'adresses en mode hors connexion (http://go.microsoft.com/fwlink/?LinkId=47583).


Le délai d'exécution de la défragmentation en ligne d'une banque de dossiers publics n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le délai de démarrage de la défragmentation en ligne a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

Si Exchange Server Analyzer détecte que la clé OLD Completion Time est présente, un message indiquant une configuration autre que celle par défaut s'affiche. La clé OLD Completion Time spécifie la période (en secondes) d'exécution de la défragmentation en ligne après la fenêtre de maintenance de la banque d'informations. La valeur par défaut est d'1 heure (3 600 secondes).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Supprimez la clé OLD Completion Time.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Délai minimum de l'exécution de la défragmentation en ligne d'une banque de dossiers publics non défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le délai minimum de la défragmentation en ligne a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

Si Exchange Server Analyzer détecte que la clé OLD Minimum RunTime est présente , un message indiquant une configuration autre que celle par défaut s'affiche. La clé OLD Minimum RunTime spécifie la période minimale en secondes de l'exécution de la défragmentation en ligne.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Supprimez la clé OLD Minimum RunTime.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La défragmentation en ligne a été désactivée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamEnableOnlineDefrag sur chaque objet de groupe de stockage. Une valeur True indique que la maintenance en ligne des bases de données aura lieu en fonction de la planification. Une valeur False indique que la maintenance en ligne ne se fera pas. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchESEParamEnableOnlineDefrag est False, une erreur s'affiche.

La maintenance en ligne des bases de données, notamment la défragmentation, est très importante dans Exchange Server. C'est pendant cet intervalle que s'effectuent des tâches telles que le nettoyage des messages périmés (les messages périmés sont supprimés), l'expiration des dossiers publics (les messages contenus dans des dossiers publics, antérieurs à une certaine date, expirent), le nettoyage des boîtes aux lettes supprimées et la défragmentation en ligne (les objets de base de données qui ne sont plus utilisés sont détectés et supprimés, libérant de l'espace dans la base de données). Grâce à ces processus, le serveur Exchange est sain et ses performances sont stables. La maintenance en ligne des bases de données ne doit pas être réglée sur « Ne jamais exécuter » sous peine d'une altération des performances à long terme.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Correction de cette erreur

  1. Cliquez sur Démarrer, Exécuter, entrez MMC, puis cliquez sur OK.

  2. Dans le Microsoft Management Console (MMC), cliquez sur Fichier, puis sur Ajouter/Supprimer un composant logiciel enfichable.

  3. Dans la liste des Composants logiciels enfichables disponibles, sélectionnez ADSI Edit, cliquez sur Ajouter, puis sur Fermer. Cliquez sur OK dans la fenêtre Ajouter/Supprimer un composant logiciel enfichable.

  4. Cliquez avec le bouton droit sur ADSI Edit, puis sur Connecter. Dans la boîte de dialogue Sélectionner un contexte de nommage connu, sélectionnez Configuration et cliquez sur OK.

  5. Développez le conteneur Configuration, CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=<Nom_organisation>, CN=Groupes_administration, CN=<Nom_groupe_administration>, CN=Serveurs, CN=<Nom_serveur>, CN=Banque_informations.

  6. Cliquez avec le bouton droit sur CN=<Nom_groupe_stockage>, puis sur Propriétés.

  7. Dans la boîte de dialogue Propriétés du groupe de stockage, sélectionnez msExchESEParamEnableOnlineDefrag dans la liste d'attributs, cliquez sur Modifier et définissez la valeur True.

  8. Fermez ADSI Edit et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur la maintenance de base de données en ligne, consultez les ressources d'Exchange suivantes :

  • article 314214 de la Base de connaissances Microsoft sur la procédure des intervalles de maintenance des banques de données dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214).

  • Exchange Server 2007 Insider Article relatif à la maintenance de la banque d'informations Exchange (http://go.microsoft.com/fwlink/?LinkId=80787).


Source de renvoi préférée activée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Preferred Backfill Source a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de banque publique>\Preferred Backfill Source

Par défaut, Preferred Backfill Source n'existe pas. Si Exchange Server Analyzer détecte que la clé Preferred Backfill Source est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Le renvoi se produit lorsqu'une banque de dossiers publics détermine qu'elle n'a pas reçu toutes les mises à jour pour un dossier répliqué, ou la hiérarchie, et doit récupérer les mises à jour manquantes d'une autre banque.

Pour optimiser le processus de renvoi, Exchange Server stocke les informations sur les mises à jour manquantes dans le tableau de renvoi.

Le tableau de renvoi stocke ces informations pendant une période spécifiée (appelée délai de renvoi). Si les mises à jour manquantes arrivent dans des messages de réplication ultérieurs pendant ce laps de temps, elles sont supprimées du tableau de renvoi. Le tableau répertorie les valeurs de délai de renvoi par défaut qui dépendent de l'emplacement des mises à jour manquantes et si elles ont déjà été demandées.

Type de demande | Contenu existant dans une banque du site local | Contenu existant dans une banque d'un site distant
Renvoi initial | 6 heures | 12 heures
Première tentative de renvoi | 12 heures | 24 heures
Tentatives de renvoi suivantes | 24 heures | 48 heures

Si le délai de renvoi expire et si les mises à jour sont toujours manquantes, Exchange Server 2003 crée une ou plusieurs demandes de renvoi et décide quels serveurs utiliser comme sources de renvoi.

Pour sélectionner le serveur ou les serveurs à utiliser comme source de renvoi, Exchange Server 2003 crée d'abord une liste de tous les serveurs qui contiennent des réplicas du dossier et trie ensuite la liste d'après la séquence de critères suivante :

  • Tri d'après l'état du serveur. Les serveurs qui sont arrêtés ou indisponibles sont placés à la fin de la liste.

  • Tri d'après le serveur de renvoi préféré. (le cas échéant, cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures). Exchange Server 2003 recherche un serveur de renvoi préféré dans l'objet de banque de dossiers publics du service d'annuaire Active Directory®. Ce paramètre est rarement utilisé. Dans la plupart des cas, le processus de renvoi est plus efficace si Exchange Server 2003 sélectionne automatiquement un serveur de renvoi. La plupart des déploiements d'Exchange Server 2003 n'ont pas besoin d'un serveur de renvoi préféré. Les services du Support Technique de Microsoft peuvent fournir un script qui définit un serveur de renvoi préféré si votre déploiement le nécessite.

  • Tri d'après le coût de transport (plus faible à élevé). Les serveurs se trouvant sur le même site sont prioritaires par rapport aux serveurs de sites distants. Le coût de transport d'un serveur est calculé par le moteur de routage Exchange Server 2003 et normalement utilisé pour calculer la manière la plus efficace de remettre un message. Notez que dans les versions d'Exchange antérieures à Exchange Server 2003, le coût de transport a une priorité plus faible et n'est pris en considération qu'après la version d'Exchange et le nombre de modifications disponibles.

  • Tri d'après la version d'Exchange (de la plus récente à la plus ancienne).

  • Tri d'après le nombre de modifications nécessaires qui sont disponibles sur le serveur (du plus grand au plus petit). Les serveurs qui n'ont aucune des modifications manquantes sont supprimés de la liste.

Si un serveur n'a pas toutes les modifications nécessaires, Exchange Server 2003 sélectionne le serveur suivant dans la liste triée et envoie également une demande de renvoi à ce serveur. Ce processus est répété jusqu'à ce que toutes les modifications aient été demandées. Cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures ; les versions d'Exchange envoient des demandes de renvoi à un serveur à la fois si aucun serveur unique ne contient toutes les mises à jour manquantes pour un dossier spécifique. Après chaque demande, les versions précédentes d'Exchange attendent que le délai de tentative (de 24 à 48 heures) soit écoulé avant d'envoyer la demande suivante.

Si le serveur sélectionné ne répond pas à la demande de renvoi, la banque marque ce serveur comme arrêté et répète le processus de sélection. Les serveurs marqués comme arrêtés sont placés à la fin de la liste.

La plupart du temps, votre topologie fonctionne de manière efficace si vous autorisez Exchange Server à sélectionner automatiquement les serveurs de renvoi. À des fins de dépannage, les services du Support Technique de Microsoft peuvent recommander de définir Preferred Backfill Source. Toutefois, vous ne devez l'utiliser qu'en cas de nécessité pour résoudre un problème spécifique.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Preferred Backfill Source

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Preferred Backfill Source.

    La valeur de cette entrée de Registre est exprimée en kilo-octets (Ko). Pour rétablir la valeur par défaut, vous devez supprimer Preferred Backfill Source et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


La source préférée de renvoi de dossiers publics a été activée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si Exchange a été configuré avec une source de renvoi préférée pour la hiérarchie de dossiers publics :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de banque d'informations publique>\Preferred Backfill Source

Si Exchange Server Analyzer détecte que l'entrée de Registre Preferred Backfill Source est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Exchange Server 2003 introduit un nouvel attribut de service d'annuaire Active Directory® nommé msexchPreferredBackfillSource pouvant être utilisé pour désigner le serveur Exchange qui doit recevoir les messages de demande de renvoi.

Lorsqu'un dossier public doit répliquer le contenu, il envoie une requête à l'organisation Exchange pour une demande de renvoi. Le premier serveur de dossiers publics qui répond est utilisé pour renvoyer les données. Cette logique suppose que le premier serveur de dossiers publics qui répond est le plus proche. Mais ce n'est pas toujours le cas. Une opportunité de configuration a été introduite dans Exchange Server 2003, qui permet à un administrateur de spécifier un serveur préféré pour le renvoi.

Dans Exchange Server 2003, vous pouvez définir le serveur préféré à utiliser pour renvoyer la hiérarchie de dossiers publics et le contenu à l'aide d'un attribut Active Directory ou de l'entrée de Registre Preferred Backfill Source sur le serveur de dossiers publics. Le paramètre Active Directory est vérifié en premier. S'il n'existe pas, le paramètre de Registre est vérifié. Si ce dernier n'existe pas non plus, l'algorithme par défaut pour le renvoi de dossiers publics est utilisé.

Pour utiliser l'attribut Active Directory, définissez le nom unique (DN) de la banque de dossiers publics de renvoi requise dans l'attribut msExchPreferredBackfillSource sur les objets de banque de dossiers publics.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Si vous choisissez de modifier l'attribut msExchPreferredBackfillSource dans Active Directory, vous devrez utiliser un éditeur Active Directory tel qu'ADSI Edit ou l'outil LDP (Ldp.exe).

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour spécifier une source préférée de renvoi de dossiers publics dans le Registre

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de banque d'informations publique>

  3. Examinez et, au besoin, modifiez la valeur Preferred Backfill Source. La valeur à entrer est le nom unique (DN) de la banque de dossiers publics Exchange que vous préférez utiliser comme source.

  4. Si une modification est apportée, démontez et remontez la banque d'informations publique pour que la modification soit prise en compte.

Pour spécifier une source préférée de renvoi de dossiers publics dans Active Directory

  1. Modifiez la valeur de l'objet Banque de dossiers publics affecté pour msExchPreferredBackfillSource pour pointer sur la source de renvoi souhaitée. L'attribut msExchPreferredBackfillSource peut se trouver dans : CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Groupes_administration, CN=Nom_groupe_administration, CN=Serveurs, CN=Nom_serveur, CN=Banque_informations, CN=Nom_groupe_stockage, CN=Banque_dossiers_publics

  2. La valeur à entrer est le nom unique (DN) de la banque de dossiers publics Exchange que vous préférez utiliser comme source.

  3. Si une modification est apportée, démontez et remontez la banque d'informations publique pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la modification d'Active Directory à l'aide de l'outil LDP, voir l'article 260745 de la Base de connaissances sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).


Obtention de davantage d'espace disque
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que l'espace disque sur l'ordinateur qui exécute Exchange Server est inférieur aux niveaux acceptables. Exchange Server Analyzer mesure l'espace disque disponible pour vérifier qu'il se situe dans une plage acceptable. Si l'outil détecte que l'espace disque est inférieur aux niveaux acceptables, il affiche un message d'erreur. Il est recommandé que tous les disques des ordinateurs exécutant Exchange Server qui contiennent des boîtes aux lettres disposent en permanence d'une capacité de mémoire disponible d'au moins 10 %.

Exchange Server Analyzer teste les lecteurs suivants :

  • lecteur de la base de données ;

  • lecteur Temp ;

  • lecteur MailRoot ;

  • lecteur STM ;

  • lecteur système ;

  • lecteur du journal ;

    Remarque :
    Le tableau d'état effectue un appel pour augmenter la taille du lecteur du journal et archiver les journaux.
  • lecteur de la page.

Pour corriger cette erreur

  1. Pour libérer de l'espace disque, supprimez les fichiers inutiles du disque.

  2. Si le disque disposant de moins de 10 % d'espace disponible contient des données pouvant être déplacées sans risque vers un autre disque, telles que des boîtes aux lettres ou le fichier d'échange Microsoft Windows®, respectez la procédure de déplacement des données.

  3. Ajoutez de la capacité au disque de l'ordinateur qui exécute Exchange Server.

  4. Réduisez la taille de la boîte aux lettres ou déplacez les utilisateurs vers un autre serveur.

Pour plus d'informations

  • Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir l'article 821829 de la Base de connaissances Microsoft sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

  • Pour plus d'informations sur le déplacement des boîtes aux lettres entre Exchange 2000 Server et Exchange 5.5 Server, voir l'article 328810 de la Base de connaissances Microsoft sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

  • Pour plus d'informations sur la définition des limites de boîtes aux lettres avec des stratégies système sur Exchange Server 2003, voir l'article 822938 de la Base de connaissances Microsoft sur l'utilisation de stratégies système pour configurer des limites de stockage de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938).

  • Pour plus d'informations sur la définition des limites de boîtes aux lettres avec des stratégies système sur Exchange 2000 Server, voir l'article 319130 de la Base de connaissances Microsoft sur l'utilisation de stratégies système pour configurer des limites de stockage de boîtes aux lettres dans Exchange 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130).

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur les meilleures pratiques de conception d'architectures de stockage, voir la rubrique sur les meilleures pratiques communes à diverses architectures (http://go.microsoft.com/fwlink/?LinkId=72988).

  • Pour plus d'informations sur le dimensionnement de disque, la latence et les taux d'E/S, voir la rubrique sur la procédure de calcul des besoins en E/S disque (http://go.microsoft.com/fwlink/?linkid=69747).


Fichier de base de données de banque de dossiers publics stocké sur le lecteur réseau
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchEDBFile de chaque objet de banque de dossiers publics. Cet attribut spécifie l'emplacement des fichiers de base de données utilisés par cette banque de dossiers publics.

Exchange Server Analyzer interroge également Active Directory pour déterminer le nombre de valeurs répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres sur ce serveur. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres. Exchange Server Analyzer peut ensuite calculer le nombre total de boîtes aux lettres gérées par le serveur.

Si Exchange Server Analyzer détecte que l'attribut msExchEDBFile commence par \\ sur un serveur Exchange comprenant plus de 50 boîtes aux lettres, une erreur s'affiche.

Cette erreur indique que les fichiers de base de données pour la banque de dossiers publics sont stockés sur un partage réseau. Si l'attribut msExchEDBFile commence par \\, cela indique que le chemin d'accès au fichier journal utilise un chemin d'accès UNC (Universal Naming Convention). Cette manière de procéder n'est pas recommandée étant donné que les interruptions de la connectivité réseau pourraient engendrer des erreurs de base de données, se traduisant par une perte de données ou des bases de données endommagées. Il est recommandé de résoudre ce problème au plus vite.

Pour déplacer les fichiers de base de données vers un nouveau lecteur

  1. Dans le Gestionnaire système Exchange, développez l'objet de serveur Exchange sur lequel la banque réside, développez le conteneur de groupe de stockage approprié, cliquez avec le bouton droit sur l'objet de banque de dossiers publics souhaité, puis cliquez sur Propriétés.

  2. Spécifiez les nouveaux emplacements de fichiers sous l'onglet Base de données de la boîte de dialogue Propriétés.

Pour plus d'informations sur les fichiers de base de données Exchange Server, voir les rubriques suivantes :

  • sur la gestion des banques de boîtes aux lettres et des banques de dossiers publics dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617)

  • sur la présentation de la banque d'informations Exchange dans la rubrique sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).

Pour plus d'informations sur l'utilisation d'Exchange Server avec les lecteurs réseau, voir les articles suivants de la Base de connaissances Microsoft :

  • 328879 sur l'utilisation d'Exchange Server avec un réseau SAN (Storage Attached Network) et des périphériques NAS (Network Attached Storage) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879)

  • 839687 sur la stratégie de prise en charge de Microsoft sur l'utilisation des périphériques NAS (Network Attached Storage) avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687)

  • 317173 sur Exchange Server et le système NAS (Network Attached Storage) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173)

  • 317172 sur Exchange Server 5.5 et le système NAS (Network Attached Storage) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172)


Une taille limite de base de données a été définie pour une banque de dossiers publics
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre Database Size Limit in Gb est présente et configurée pour la banque de dossiers publics :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

Si Exchange Server Analyzer détecte que la valeur Database Size Limit in Gb est présente et configurée, il affiche un message indiquant une configuration autre que celle par défaut.

Si Exchange Server 2003 Service Pack 2 (SP2) est appliqué à Exchange Server 2003 Édition Standard, la taille limite de base de données sous licence codée de manière irréversible passe de 16 à 75 gigaoctets (Go). Vous pouvez définir une taille limite de base de données de protection pour éviter toute augmentation accidentelle de la taille de base de données. La valeur de taille limite par défaut du SP2 est de 18 Go. Vous pouvez la remplacer en créant la valeur de Registre Database Size Limit in Gb.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>

  3. Supprimez la valeur Database Size Limit in Gb.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Aucune sauvegarde complète de la banque de dossiers publics n'a été effectuée depuis plus de 8 jours
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge la banque de dossiers publics pour déterminer la date et l'heure de la dernière sauvegarde complète. Si Exchange Server Analyzer détecte que le nombre de jours écoulé depuis la dernière sauvegarde complète d'une banque de dossiers publics est supérieur à huit, il affiche un message d'avertissement.

La banque de dossiers publics contient des informations associées à une arborescence de dossiers publics particulière, telles que son type de structure et les dossiers qu'elle comprend. Elle comporte également le contenu des dossiers publics. Une banque de dossiers publics se compose d'un fichier .edb de texte enrichi et d'un fichier .stm de contenu Internet natif de transmission en continu.

Les données des banques de boîtes aux lettres et de dossiers publics de vos bases de données Exchange Server et les fichiers des journaux de transactions constituent les données les plus importantes à sauvegarder dans votre organisation Exchange Server. Vous pouvez utiliser une sauvegarde de base de données Exchange Server pour restaurer une banque de dossiers publics endommagée sur un serveur fonctionnel qui exécute Exchange Server. Vous pouvez également utiliser des sauvegardes de base de données Exchange Server pour restaurer vos bases de données Exchange Server sur un autre serveur.

Il est recommandé d'effectuer une sauvegarde complète de vos fichiers de base de données et de vos journaux des transactions tous les jours. Après l'exécution d'une sauvegarde complète d'un groupe de stockage, les fichiers des journaux de transactions assignés des bases de données Exchange Server sont supprimés du serveur. L'avantage d'une sauvegarde complète réside dans la vitesse dans un scénario de récupération, car vous ne devez définir qu'une bande pour restaurer toutes les données.

Remarque :
Il est recommandé de conserver les fichiers des journaux de transactions sur un disque dédié distinct de celui des fichiers de base de données. Vous disposez d'une tolérance de pannes en cas de destruction du disque de la base de données, et dans certains cas, vous améliorez les performances de la base de données.
Important :
Vous devez posséder les autorisations requises ou les droits affectés au compte d'utilisateur auquel vous êtes connecté lorsque vous tentez de sauvegarder ou restaurer des fichiers et des dossiers. Pour créer des sauvegardes Exchange Server, vous devez posséder les droits d'opérateur de sauvegarde au niveau du domaine. Pour créer des sauvegardes de votre système d'exploitation Microsoft Windows Server™ 2003, vous devez au moins posséder des droits d'opérateur de sauvegarde locale.

La stratégie de sauvegarde que vous choisissez pour vos données Exchange Server dépend de la taille des banques, de la vitesse du matériel et du logiciel de sauvegarde, de la capacité matérielle et des délais.

Pour plus d'informations sur les stratégies de sauvegarde et les opérations de récupération d'urgence, consultez :

  • Guide des opérations de récupération d'urgence d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47570).

  • Sauvegarde et restauration des bases de données (http://go.microsoft.com/fwlink/?LinkID=80766).


Aucune sauvegarde complète de la banque de dossiers publics n'a été effectuée depuis plus de 60 jours
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge la banque de dossiers publics pour déterminer la date et l'heure de la dernière sauvegarde complète. Si Exchange Server Analyzer détecte que le nombre de jours écoulés depuis la dernière sauvegarde complète d'une banque de dossiers publics est supérieur à 60, il affiche une erreur.

La banque de dossiers publics contient des informations associées à une arborescence de dossiers publics particulière, telles que son type de structure et les dossiers qu'elle comprend. Elle comporte également le contenu des dossiers publics. Une banque de dossiers publics se compose d'un fichier .edb de texte enrichi et d'un fichier .stm de contenu Internet natif de transmission en continu.

Les données des banques de boîtes aux lettres et de dossiers publics de vos bases de données Exchange Server et de vos fichiers des journaux de transactions constituent les données les plus importantes à sauvegarder dans votre organisation Exchange Server. Vous pouvez utiliser une sauvegarde de base de données Exchange Server pour restaurer une banque de dossiers publics endommagée sur un serveur fonctionnel qui exécute Exchange Server. Vous pouvez également utiliser des sauvegardes de base de données Exchange Server pour restaurer vos bases de données Exchange Server sur un autre serveur.

Il est recommandé d'effectuer une sauvegarde complète de vos fichiers de base de données et de vos journaux des transactions tous les jours. Après l'exécution d'une sauvegarde complète d'un groupe de stockage, les fichiers des journaux de transactions assignés des bases de données Exchange Server sont supprimés du serveur. L'avantage d'une sauvegarde complète réside dans la vitesse dans un scénario de récupération, car vous ne devez définir qu'une bande pour restaurer toutes les données.

Remarque :
Il est recommandé de conserver les fichiers des journaux de transactions sur un disque dédié distinct de celui des fichiers de base de données. Ainsi, non seulement vous améliorez les performances de la base de données, mais vous disposez également d'une tolérance de pannes en cas de destruction du disque de la base de données.
Important :
Vous devez posséder les autorisations requises ou les droits affectés au compte d'utilisateur auquel vous êtes connecté lorsque vous tentez de sauvegarder ou restaurer des fichiers et des dossiers. Pour créer des sauvegardes Exchange Server, vous devez posséder les droits d'opérateur de sauvegarde au niveau du domaine. Pour créer des sauvegardes de votre système d'exploitation Microsoft Windows Server™ 2003, vous devez au moins posséder des droits d'opérateur de sauvegarde locale.

La stratégie de sauvegarde que vous choisissez pour vos données Exchange Server dépend de la taille des banques, de la vitesse du matériel et du logiciel de sauvegarde, de la capacité matérielle et des délais.

Pour plus d'informations sur les stratégies de sauvegarde et les opérations de récupération d'urgence, consultez :

  • Guide des opérations de récupération d'urgence d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47570).

  • Sauvegarde et restauration des bases de données (http://go.microsoft.com/fwlink/?LinkId=80766)


La banque de dossiers publics dépasse 12 Go
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_DataFile pour déterminer la valeur de la clé FileSize pour chaque fichier de base de données de banque de dossiers publics Exchange (fichier .edb) et chaque fichier de transmission en continu (fichier .stm). Exchange Server Analyzer lit également la branche de Registre suivante pour déterminer la version d'Exchange Server installée :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID de produit Exchange>

Si Exchange Server Analyzer détecte que la taille combinée d'une base de données de banque de dossiers publics et de fichiers de transmission en continu dépasse 12 Go sur un ordinateur qui utilise Microsoft Exchange Server 2003 Édition Standard ou Microsoft Exchange 2000 Server Édition Standard, un avertissement s'affiche.

Les bases de données de banque Exchange sur les Éditions Standard d'Exchange Server 2003 et d'Exchange 2000 Server ne peuvent pas dépasser 16 Go. Lorsque la limite est atteinte, la banque de boîtes aux lettres n'augmente pas non plus et Exchange est inaccessible. Les bases de données de banque Exchange des Éditions Entreprise d'Exchange Server 2003 et Exchange 2000 Server ne sont pas limitées à 16 Go ; elles ne sont limitées que par le matériel disponible, d'une taille maximale théorique de 16 téraoctets.

Pour supprimer cet avertissement

  1. Pensez à définir des stratégies d'expiration sur les dossiers publics pour supprimer les messages plus anciens.

  2. Pensez à définir des limites de stockage sur les banques de dossiers publics et des dossiers publics individuels pour éviter une croissance illimitée de la banque de dossiers publics.

  3. Si vous avez récemment supprimé des messages en bloc ou des répliques de dossiers publics de cette banque de dossiers publics, effectuer une défragmentation hors ligne peut diminuer la taille des fichiers.
Remarque :
La publication d'Exchange Server 2003 Service Pack 2 (SP2) pour Exchange Server 2003 Édition Standard a permis d'augmenter la taille limite de base de données sous licence codée de manière irréversible de 16 à 75 Go. L'administrateur peut définir une taille limite de base de données de protection (pour éviter toute augmentation accidentelle de taille de base de données). La valeur par défaut est de 18 Go dans le SP2 pour l'Édition Standard. Vous pouvez la remplacer en modifiant la clé de Registre Database Size Limit in Gb.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la taille limite d'une base de données avec Exchange Server 2003 SP2

  1. Sur l'ordinateur Exchange Server, démarrez Regedit.exe.

  2. Ouvrez la clé de Registre suivante : HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nom_serveur\Public-GUID de banque publique

  3. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Pour le nom de la nouvelle valeur, entrez Database Size Limit in Gb.

  5. Double-cliquez sur Database Size Limit in Gb. Dans Données de la valeur, entrez une valeur appropriée pour la taille de base de données maximale en Go. Pour Exchange Server 2003 Édition Standard, entrez une valeur comprise entre 1 et 75 (la valeur par défaut est 18 Go). Pour Exchange Server 2003 Édition Entreprise, entrez une valeur comprise entre 1 et 8 000 (la valeur par défaut est 8 000 Go). Cliquez sur OK.

  6. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  7. Pour le nom de la nouvelle valeur, entrez Database Size Buffer in Percentage.

  8. Double-cliquez sur Database Size Buffer in Percentage. Dans Données de la valeur, entrez une valeur comprise entre 1 et 100 pour spécifier le moment d'enregistrement des événements pour vous avertir que vous approchez de la taille maximale pour une base de données. La valeur par défaut 10 permet d'enregistrer des événements d'avertissement lorsqu'il vous reste une capacité de 10 pour cent avant d'atteindre la taille maximale de cette base de données. Cliquez sur OK.

  9. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  10. Pour le nouveau nom, entrez Database Size Check Start Time in Hours From Midnight.

  11. Double-cliquez sur Database Size Check Start Time in Hours From Midnight. Dans Données de la valeur, entrez une valeur comprise entre 0 et 23 pour spécifier le moment auquel Exchange doit vérifier la taille de la base de données. La valeur par défaut de 5 permet à Exchange Server de vérifier la taille de la base de données 5 heures après minuit (5 heures du matin). Cliquez sur OK.

  12. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les fichiers .stm et .edb, voir l'article 232323 de la Base de connaissances Microsoft sur le stockage du contenu natif dans Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir l'article 821829 de la Base de connaissances sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange 2000 Server, voir l'article 328810 de la Base de connaissances sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Pour plus d'informations sur l'exécution d'une défragmentation hors ligne d'une base de données Exchange Server, voir l'article 328804 de la Base de connaissances sur la procédure de défragmentation des bases de données Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Pour plus d'informations sur la définition de limites de stockage sur des dossiers publics, voir l'article 823144 de la Base de connaissances sur la procédure de configuration de limites de stockage sur les dossiers publics dans Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144).

Pour plus d'informations sur les Éditions Standard d'Exchange Server 2003 et Exchange 2000 Server ayant atteint la taille maximale de base de données, voir l'article 828070 de la Base de connaissances Microsoft sur la banque de boîtes aux lettres Exchange Server qui n'est pas montée si sa base de données atteint la limite de 16 Go (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


La banque de dossiers publics dépasse 15 Go
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_DataFile pour déterminer la valeur de la clé FileSize pour chaque fichier de base de données de banque de dossiers publics Exchange (fichier .edb) et chaque fichier de transmission en continu (fichier .stm). Exchange Server Analyzer lit également la branche de Registre suivante pour déterminer la version d'Exchange Server installée :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID de produit Exchange>

Si Exchange Server Analyzer détecte que la taille combinée d'une base de données de banque de dossiers publics et de fichiers de transmission en continu dépasse 15 Go sur un ordinateur qui utilise Microsoft Exchange Server 2003 Édition Standard ou Exchange 2000 Server Édition Standard, une erreur s'affiche.

Les bases de données de banque Exchange sur les Éditions Standard d'Exchange Server 2003 et d'Exchange 2000 Server ne peuvent pas dépasser 16 Go. Lorsque la limite est atteinte, la banque de boîtes aux lettres n'augmente pas non plus et Exchange est inaccessible. Les bases de données de banque Exchange des Éditions Entreprise d'Exchange Server 2003 et Exchange 2000 Server ne sont pas limitées à 16 Go ; elles ne sont limitées que par le matériel disponible, d'une taille maximale théorique de 16 téraoctets.

Pour corriger cette erreur

  1. Pensez à définir des stratégies d'expiration sur les dossiers publics pour supprimer les messages plus anciens.

  2. Pensez à définir des limites de stockage sur les banques de dossiers publics et des dossiers publics individuels pour éviter une croissance illimitée de la banque de dossiers publics.

  3. Si vous avez récemment supprimé des messages en bloc ou des répliques de dossiers publics de cette banque de dossiers publics, effectuer une défragmentation hors ligne peut diminuer la taille des fichiers.
Remarque :
La publication d'Exchange Server 2003 Service Pack 2 (SP2) pour Exchange Server 2003 Édition Standard a permis d'augmenter la taille limite de base de données sous licence codée de manière irréversible de 16 à 75 Go. L'administrateur peut définir une taille limite de base de données de protection (pour éviter toute augmentation accidentelle de taille de base de données). La valeur par défaut est de 18 Go dans le SP2 pour l'Édition Standard. Vous pouvez la remplacer en modifiant la clé de Registre Database Size Limit in Gb.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour configurer la taille limite d'une base de données avec Exchange Server 2003 SP2

  1. Sur l'ordinateur Exchange Server, démarrez Regedit.exe.

  2. Ouvrez la clé de Registre suivante : HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nom_serveur\Public-GUID de banque publique

  3. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Pour le nom de la nouvelle valeur, entrez Database Size Limit in Gb.

  5. Double-cliquez sur Database Size Limit in Gb. Dans Données de la valeur, entrez une valeur appropriée pour la taille de base de données maximale en Go. Pour Exchange Server 2003 Édition Standard, entrez une valeur comprise entre 1 et 75 (la valeur par défaut est 18 Go). Pour Exchange Server 2003 Édition Entreprise, entrez une valeur comprise entre 1 et 8 000 (la valeur par défaut est 8 000 Go). Cliquez sur OK.

  6. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  7. Pour le nom de la nouvelle valeur, entrez Database Size Buffer in Percentage.

  8. Double-cliquez sur Database Size Buffer in Percentage. Dans Données de la valeur, entrez une valeur comprise entre 1 et 100 pour spécifier le moment d'enregistrement des événements pour vous avertir que vous approchez de la taille maximale pour une base de données. La valeur par défaut 10 permet d'enregistrer des événements d'avertissement lorsqu'il vous reste une capacité de 10 pour cent avant d'atteindre la taille maximale de cette base de données. Cliquez sur OK.

  9. Cliquez avec le bouton droit sur GUID de banque publique, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  10. Pour le nouveau nom, entrez Database Size Check Start Time in Hours From Midnight.

  11. Double-cliquez sur Database Size Check Start Time in Hours From Midnight. Dans Données de la valeur, entrez une valeur comprise entre 0 et 23 pour spécifier le moment auquel Exchange doit vérifier la taille de la base de données. La valeur par défaut de 5 permet à Exchange Server de vérifier la taille de la base de données 5 heures après minuit (5 heures du matin). Cliquez sur OK.

  12. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les fichiers .stm et .edb, voir l'article 232323 de la Base de connaissances Microsoft sur le stockage du contenu natif dans Microsoft Exchange (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange Server 2003, voir l'article 821829 de la Base de connaissances sur le déplacement des boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829).

Pour plus d'informations sur le déplacement des boîtes aux lettres dans Exchange 2000 Server, voir l'article 328810 de la Base de connaissances sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810).

Pour plus d'informations sur l'exécution d'une défragmentation hors ligne d'une base de données Exchange Server, voir l'article 328804 de la Base de connaissances sur la procédure de défragmentation des bases de données Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804).

Pour plus d'informations sur la définition de limites de stockage sur des dossiers publics, voir l'article 823144 de la Base de connaissances sur la procédure de configuration de limites de stockage sur les dossiers publics dans Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144).

Pour plus d'informations sur les Éditions Standard d'Exchange Server 2003 et Exchange 2000 Server ayant atteint la taille maximale de base de données, voir l'article 828070 de la Base de connaissances sur la banque de boîtes aux lettres Exchange Server qui n'est pas montée si sa base de données atteint la limite de 16 Go (http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


La banque de dossiers publics n'a pas d'adresse de messagerie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-03-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut mail de chaque banque de dossiers publics. Si Exchange Server Analyzer détecte que l'attribut mail n'est configuré pour aucune banque de dossiers publics, un message d'erreur s'affiche.

Si une banque de dossiers publics n'est pas configurée avec une adresse SMTP (Simple Mail Transfer Protocol), la réplication de la hiérarchie de dossiers publics ne fonctionne pas correctement pour cette banque.

D'un point de vue technique, une banque de dossiers publics est un type spécifique de boîte aux lettres Exchange. Comme pour tous les objets à boîte aux lettres activée, les attributs suivants d'une banque de dossiers publics doivent être correctement configurés pour pouvoir envoyer et recevoir du courrier :

  • legacyExchangeDNIl s'agit du nom unique de type Exchange de l'objet.

  • proxyAddressesCet attribut contient toutes les adresses de messagerie pouvant être utilisées pour envoyer du courrier à ce destinataire.

  • textEncodedORAddressCet attribut contient l'adresse X.400 principale.

  • MailCet attribut contient l'adresse SMTP principale de l'objet sans préfixe d'adresse.

  • mailNicknameCet attribut est utilisé pour générer l'URL d'accès à la boîte aux lettres.

  • displayNameCet attribut contient le nom complet de l'objet tel qu'il apparaît dans la Liste d'adresses globale ainsi que dans toute autre liste d'adresses dont cet objet est membre.

Si l'attribut de messagerie n'est pas défini pour une banque de dossiers publics, cela signifie généralement que le service de mise à jour de destinataire n'est pas configuré ou ne fonctionne pas correctement. Il existe deux types de service de mise à jour de destinataire. L'un est responsable du traitement des objets système Exchange dans le conteneur Configuration (le service de mise à jour de destinataire d'entreprise) et l'autre du traitement des destinataires dans chaque domaine (un service de mise à jour de destinataire de domaine).

Un seul service de mise à jour de destinataire d'entreprise est disponible dans la forêt Active Directory car il n'existe qu'un conteneur Configuration. C'est ce service de mise à jour de destinataire qui est responsable de la configuration, entre autres, de l'attribut mail des banques de dossiers publics. Si ce service de mise à jour de destinataire est désactivé, s'il est configuré de manière incorrecte ou s'il rencontre un problème, les attributs risquent de ne pas être configurés correctement et la réplication de dossiers publics ne fonctionne pas. Vous devez résoudre ce problème en vérifiant la configuration du service de mise à jour de destinataire d'entreprise.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataires, puis sélectionnez le nœud Services de mise à jour de destinataire.

  3. Dans le volet droit, cliquez avec le bouton droit sur le service de mise à jour de destinataire comprenant (Enterprise Configuration) dans son nom et cliquez sur Propriétés.

  4. Vérifiez que le champ Domaine comporte un nom de domaine correct.

  5. Vérifiez que les ordinateurs répertoriés dans les champs Serveur Exchange et Contrôleur de domaine Windows fonctionnent normalement et sont disponibles sur le réseau. Si ces systèmes sont arrêtés, non disponibles ou s'il ne s'agit pas des systèmes requis pour l'exécution des tâches du service de mise à jour de destinataire, vous pouvez utiliser le bouton Parcourir de ces champs pour spécifier un autre ordinateur.

  6. Vérifiez que l'option Intervalle de mise à jour est définie sur Toujours exécuter.

  7. Cliquez sur OK pour enregistrer les modifications.

  8. Dans le volet droit, cliquez avec le bouton droit sur le service de mise à jour de destinataire comprenant (Enterprise Configuration) dans son nom et sélectionnez Reconstruire. Le message suivant s'affiche :

    « Cette opération permet de recalculer l'appartenance à une liste d'adresses et les paramètres de stratégie de destinataire de tous les destinataires dans contoso.com d'après le prochain intervalle de mise à jour planifié. Selon le nombre de destinataires dans le domaine, l'opération peut prendre plusieurs heures. Voulez-vous continuer ? »

  9. Cliquez sur Oui pour reconstruire le service de mise à jour de destinataire.

  10. Après 15 minutes, commencez à contrôler l'avancement du service de mise à jour de destinataire en effectuant les procédures décrites dans l'article 246127 de la Base de connaissances Microsoft sur la procédure de vérification des progrès du service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances :

  • 296479 sur les conditions requises pour la désactivation du service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479).

  • 328738 sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738)

  • 253770 sur les tâches effectuées par le service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).

  • 288807 sur le dépannage du service de mise à jour de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288807).

  • 319065 sur l'utilisation du service de mise à jour de destinataire d'Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065)


La banque de dossiers publics ne sera pas montée au démarrage
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchEDBOffline de tous les objets avec une classe msExchPublicMDB. Les objets présentant cette classe sont des banques de dossiers publics.

Une valeur True pour l'attribut msExchEDBOffline indique que la banque de dossiers publics ne sera pas montée automatiquement lors du démarrage du service Banque d'informations Microsoft Exchange. Une valeur False indique que la banque de dossiers publics sera montée lors du démarrage. Si Exchange Server Analyzer détecte que la valeur de cet attribut est définie sur True, un avertissement s'affiche.

Celui-ci indique que la case à cocher Ne pas monter cette banque d'informations au démarrage est activée. Cette case à cocher se trouve sous l'onglet Base de données de la boîte de dialogue Propriétés de la banque de dossiers publics. Si elle est activée, la banque de dossiers publics n'est pas montée automatiquement lors du démarrage du service Banque d'informations Microsoft Exchange. Au prochain démarrage de ce service, par exemple après un redémarrage du serveur, les banques de dossiers publics dont cet attribut est défini sur True ne seront pas montées. Il est conseillé de monter automatiquement les banques de dossiers publics lors du démarrage du service Banque d'informations Microsoft Exchange.

Correction de cet avertissement dans Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis le serveur qui comprend la banque de dossiers publics que vous souhaitez modifier.

  3. Développez le groupe de stockage qui comprend la banque de dossiers publics que vous souhaitez modifier.

  4. Cliquez avec le bouton droit sur la banque de dossiers publics, puis cliquez sur Propriétés.

  5. Sous l'onglet Base de données, désactivez la case à cocher Ne pas monter cette banque d'informations au démarrage.

  6. Cliquez sur OK pour enregistrer le paramètre.

  7. Fermez le Gestionnaire système Exchange.

Correction de cet avertissement dans Exchange Server 2007

  1. Ouvrez la console de gestion Exchange.

  2. Développez Configuration du serveur, puis sélectionnez le serveur que vous voulez utiliser.

  3. Développez le groupe de stockage souhaité.

  4. Cliquez avec le bouton droit sur la base de données de dossiers publics que vous voulez utiliser, puis cliquez sur Propriétés.

  5. Sous l'onglet Général, désactivez la case à cocher Ne pas monter cette base de données au démarrage.

  6. Cliquez sur OK pour enregistrer le paramètre.

  7. Fermez la console de gestion Exchange.

Pour plus d'informations sur cette option, consultez les articles suivants de la Base de connaissances Microsoft

  • 314218 sur la procédure d'activation et de désactivation du montage automatique des banques de données lors du démarrage dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218)

  • 285169 sur les banques d'informations qui ne sont pas montées après l'utilisation du commutateur « /disasterrecovery » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=285169)


Affectation de la base de données à l'arborescence de dossiers publics
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchOwningPFTreeBL pour chaque classe d'objet msExchPFTree . L'attribut msExchOwningPFTreeBL stocke une liste de noms uniques de banques de dossiers publics qui contiennent une réplique de l'arborescence de dossiers publics. Si Exchange Server Analyzer détecte que l'attribut msExchOwningPFTreeBL sur un objet d'arborescence de dossiers publics est vide, un avertissement s'affiche. Cet avertissement indique qu'une arborescence de dossiers publics n'est détenue par aucune banque de dossiers publics.

Chaque arborescence de dossiers publics (également appelée « hiérarchie de dossiers publics ») est reliée à une banque de dossiers publics. Vous devez d'abord créer l'arborescence, puis la banque. Si vous n'avez pas encore lié l'arborescence à une base de données, l'avertissement s'affiche. Chaque arborescence de dossiers publics ne dispose que d'une seule banque sur un serveur particulier. Une arborescence peut avoir plusieurs banques lorsque chaque banque existe sur un serveur distinct. Dans ce type de configuration, Exchange réplique les informations parmi les banques pour maintenir la cohérence de la hiérarchie.

Si des clients Microsoft Office Outlook® Web Access tentent de se connecter à un dossier public d'une arborescence à laquelle aucune banque de dossiers publics n'est associée, une erreur « service non disponible (HTTP 503) » se produit.

Pour corriger cet avertissement, vous devez effectuer l'une des opérations suivantes :

  • Liaison de l'arborescence de dossiers publics à une base de données de dossiers publics. Pour lier l'arborescence de dossiers publics à une base de données de dossiers publics, vous devez d'abord créer une nouvelle base de données de dossiers publics, puis localiser l'arborescence de dossiers publics et les lier.

  • Suppression de l'arborescence de dossiers publics. Si vous n'avez pas encore lié l'arborescence de dossiers publics à une base de données de dossiers publics, aucune donnée utilisateur ne sera perdue lorsque vous supprimerez l'arborescence.

Pour lier l'arborescence de dossiers publics à une base de données de dossiers publics

  1. Dans le Gestionnaire système Exchange, développez le serveur auquel vous souhaitez ajouter une banque de dossiers publics.

  2. Cliquez avec le bouton droit sur un groupe de stockage spécifique, pointez sur Nouveau, puis cliquez sur Banque publique.

  3. Dans Nom, entrez un nom pour la nouvelle base de données.

  4. Pour associer l'arborescence de dossiers publics à la base de données, cliquez sur Parcourir, puis sélectionnez l'arborescence de dossiers publics affichée dans l'avertissement d'Exchange Server Analyzer.

  5. Pour enregistrer vos paramètres, cliquez sur OK.

  6. Pour monter la nouvelle banque, cliquez sur Oui.

Pour supprimer l'arborescence de dossiers publics

  1. Dans le Gestionnaire système Exchange, développez le nœud Dossiers où existe l'arborescence de dossiers publics.

  2. Cliquez avec le bouton droit sur l'arborescence de dossiers publics que vous souhaitez supprimer, cliquez sur Supprimer, puis sur Oui.

Pour plus d'informations sur l'administration des dossiers publics, voir la rubrique sur la gestion des banques de boîtes aux lettres et de dossiers publics dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47617).

Pour plus d'informations, voir l'Aide en ligne d'Exchange Server 2003 Service Pack 1 (SP1) (http://go.microsoft.com/fwlink/?LinkId=29847).


Groupe de stockage de récupération activé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchESEParamBaseName de tous les objets avec une classe msExchStorageGroup. Les objets de cette classe sont des objets de groupe de stockage. La valeur R00 de l'attribut msExchESEParamBaseName indique que l'objet de groupe de stockage est un groupe de stockage de récupération. Si Exchange Server Analyzer détecte que la valeur de cet attribut est R00, un avertissement s'affiche.

Cet avertissement indique qu'un groupe de stockage de récupération existe. Il est recommandé de supprimer le groupe de stockage de récupération après avoir exécuté le processus de récupération. Si vous ne supprimez pas le groupe de stockage de récupération, un administrateur qui n'est pas habitué aux groupes de stockage de récupération risque d'être perturbé lors d'une future récupération standard.

Correction de cet avertissement dans Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, puis le serveur qui contient le groupe de stockage de récupération que vous souhaitez supprimer.

  3. Cliquez avec le bouton droit sur le groupe de stockage de récupération, puis cliquez sur Supprimer.

  4. Fermez le Gestionnaire système Exchange.

Correction de cet avertissement dans Exchange Server 2007

  1. Suivez les instructions de la documentation principale sur Exchange Server 2007, « Procédure de suppression d'un groupe de stockage de récupération » (http://go.microsoft.com/fwlink/?LinkId=80783).

Pour plus d'informations sur les groupes de stockage de récupération et Exchange Server 2003, consultez la rubrique sur l'utilisation des groupes de stockage de récupération d'Exchange Server 2003 (en anglais) (http://go.microsoft.com/fwlink/?LinkId=23233) et l'article 824126 de la Base de connaissances Microsoft sur la procédure d'utilisation des groupes de stockage de récupération dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824126).

Pour plus d'informations sur les groupes de stockage de récupération et Exchange Server 2007, consultez la page Web Présentation des groupes de stockage de récupération (http://go.microsoft.com/fwlink/?LinkId=80784).


Groupe de stockage de récupération désactivé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchMaxRestoreStorageGroups a été modifié. Si Exchange Server Analyzer détecte que l'attribut msExchMaxRestoreStorageGroups a été défini sur 0, il affiche une erreur.

L'attribut msExchMaxRestoreStorageGroups est un attribut binaire de l'objet de banque d'informations pour chaque ordinateur Exchange. Si l'attribut msExchMaxRestoreStorageGroups est défini sur 0, les groupes de stockage de récupération ne peuvent pas être créés pour l'ordinateur Exchange donné.

Cette erreur peut se produire si vous avez effectué une mise à niveau en place d'Exchange 2000 Server SP3 à Exchange Server 2003 SP1 sur un cluster Windows où le serveur virtuel Exchange n'a pas été mis à niveau avec Exchange Server 2003. Ce scénario de mise à niveau en place peut également entraîner l'échec d'Outlook® Mobile Access.

Vous devez corriger l'erreur du groupe de stockage de récupération en définissant l'attribut msExchMaxRestoreStorageGroups sur 1 pour chaque objet de banque d'informations de l'ordinateur Exchange. Les objets de banque d'informations affectés s'affichent dans les résultats d'Exchange Server Analyzer. Pour obtenir de l'aide sur Outlook Mobile Access, contactez les services de support technique Microsoft.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Correction de l'erreur du groupe de stockage de récupération

  1. Lancez ADSI Edit.

  2. Double-cliquez sur le conteneur Configuration, développez CN=Services, CN=Microsoft_Exchange, puis CN=<Nom_organisation_Exchange>.

  3. Développez CN=Groupes_administration, CN=<Nom_groupe_administration>, puis CN=Serveurs.

  4. Dans le volet Détails, cliquez avec le bouton droit sur CN=InformationStore, puis cliquez sur Propriétés.

  5. Dans l'Éditeur d'attribut, cliquez sur l'attribut msExchMaxRestoreStorageGroups, puis sur Modifier.

  6. Dans le champ Modifier l'attribut, entrez 1.

  7. Cliquez sur Appliquer, puis sur OK.

  8. Fermez ADSI Edit. Redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur l'utilisation de l'outil LDP, consultez l'article 260745 de la Base de connaissances Microsoft sur l'utilisation de l'utilitaire LDP pour modifier des attributs d'objets Active Directory (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745).

Pour plus d'informations sur les groupes de stockage de récupération Exchange, consultez les ressources sur Exchange suivantes :

  • Utilisation de groupes de stockage de récupération Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=23233) (en anglais).

  • Présentation des groupes de stockage de récupération (http://go.microsoft.com/fwlink/?LinkID=80784)


La clé Replication Expiry d'une banque de dossiers publics n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-05-25

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'intervalle selon lequel la banque Exchange supprime les éléments dont la période de rétention est écoulée a été modifiée et diffère de sa valeur par défaut :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de dossiers publics>\Replication Expiry

Si Exchange Server Analyzer détecte que la valeur de Registre Replication Expiry est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

L'expiration des messages est le processus qui consiste à faire expirer les messages des dossiers publics qui dépassent un intervalle de temps spécifié. L'intervalle par défaut d'expiration des messages est de 24 heures.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Supprimez la valeur de Registre Replication Expiry.

  4. Redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le document sur l'utilisation de la banque d'informations d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595) et l'article 273479 de la Base de connaissances sur la description de la fonctionnalité de redirection de dossiers publics dans Exchange 2000 Server et dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479).


La limite d'âge de conflit de dossier Réplication des dossiers publics n'est pas celle par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si l'âge de conflit de dossier par défaut a été modifié :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

Si Exchange Server Analyzer détecte que la valeur de Registre Replication Folder Conflict Age Limit est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Si deux utilisateurs ont modifié le même message dans un dossier public, les messages sauvegardés sont définis comme étant en conflit. Cette situation peut se présenter lors d'un enregistrement simultané sur le même serveur de dossiers publics ou si le message est modifié sur deux serveurs qui contiennent des répliques du dossier. Si les propriétaires du dossier public n'entreprennent aucune action dans la période établie par la limite d'âge de conflit, le conflit est résolu par la banque de dossiers publics à l'expiration de la limite d'âge. Cette limite d'âge est déterminée par la valeur de Registre Replication Folder Conflict Age Limit. Cette dernière représente le nombre de jours pendant lesquels les éléments en conflit peuvent exister.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Supprimez la valeur de Registre Replication Folder Conflict Age Limit.

  4. Redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication de dossiers publics, voir l'article 273479 de la Base de connaissances sur la compréhension de la réplication et des redirections de dossiers publics (http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479).


La valeur Replication Folder Count Limit a été modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Folder Count Limit a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Folder Count Limit

Si Exchange Server Analyzer détecte que la clé Replication Folder Count Limit est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, Replication Folder Count Limit n'existe pas. La valeur Replication Folder Count Limit représente le nombre maximal de dossiers à compresser dans un message de réplication de hiérarchie (utilisé pour répliquer la hiérarchie de l'arborescence des dossiers publics et les propriétés des dossiers publics). Cette valeur doit être comprise entre 1 et 1000 ; la valeur par défaut est 20. Cette clé de Registre n'est pas valide dans Exchange Server 2003 et les versions ultérieures ; elle n'est utilisée que dans les versions précédentes d'Exchange Server.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Replication Folder Count Limit

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Folder Count Limit.

    La valeur de cette entrée de Registre est exprimée en kilo-octets (Ko). Pour retourner la valeur par défaut, vous devez supprimer Replication Folder Count Limit et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


La valeur de la clé Replication Folder Tree RMQ Timeout a été modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Folder Tree RMQ Timeout a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Folder Tree RMQ Timeout

Si Exchange Server Analyzer détecte que la clé Replication Folder Tree RMQ Timeout est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, la clé Replication Folder Tree RMQ Timeout n'existe pas. Exchange utilise des messages d'état de hiérarchie pour répliquer la hiérarchie de l'arborescence des dossiers publics et les propriétés de ces dossiers publics. Lorsqu'une banque de dossiers publics reçoit des modifications répliquées, elle les charge en mémoire (files d'attente de messages de réplication) pour les traiter. La valeur Replication Folder Tree RMQ Timeout représente la durée maximale pendant laquelle les modifications de hiérarchie répliquées restent en mémoire. La valeur, exprimée en secondes, doit être comprise entre 3600 (une heure) et 2592000 (30 jours) ; la valeur par défaut est 604800 (7 jours). Les modifications qui sont traitées avec succès sont rapidement supprimées de la mémoire ; les autres sont conservées en mémoire jusqu'à ce qu'elles puissent être traitées ou sont supprimées lorsque le délai est écoulé.

Par exemple, une modification peut être répliquée pour un dossier et une autre pour un de ses sous-dossiers. Selon la topologie et le délai entre les modifications, celles-ci peuvent arriver à la banque de dossiers publics de destination dans n'importe quel ordre. Si la modification du sous-dossier arrive en premier mais ne peut pas être traitée de manière correcte tant que celle du dossier parent n'a pas été appliquée, la banque de dossiers publics conservera en mémoire la modification du sous-dossier jusqu'à ce que celle de son parent soit arrivée et ait été traitée. Si le délai s'écoule avant que la modification du dossier parent ait été traitée, la modification du sous-dossier est supprimée de la mémoire. Ensuite, lorsque la modification du dossier parent a été traitée, la banque de dossiers publics peut recevoir une autre copie de la modification du sous-dossier qui peut alors être traitée avec succès. Si la banque de dossiers publics ne reçoit pas d'autre copie de la modification du sous-dossier, elle compare son état à celui des autres banques de dossiers publics de la topologie, détecte l'absence de la modification du sous-dossier dans sa copie de l'arborescence de dossiers publics et entame le processus de renvoi de cette modification.

Dans la plupart des cas, il est déconseillé de modifier la valeur par défaut de Replication Folder Tree RMQ Timeout. Si cette valeur a été modifiée, il se peut qu'elle ait été augmentée temporairement pendant une période d'intense trafic de réplication (par exemple, après l'ajout d'une nouvelle banque de dossiers publics).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour restaurer la clé de Registre Replication Folder Tree RMQ Timeout

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Folder Tree RMQ Timeout.

    La valeur de cette entrée de Registre est exprimée en secondes. Pour renvoyer la valeur par défaut, vous devez supprimer Replication Folder Tree RMQ Timeout et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


La limite d'âge « Tombstone » du dossier Réplication des dossiers publics n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'intervalle de suppression des entrées de l'indicateur de suppression de dossier public a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

Si Exchange Server Analyzer détecte que Replication Folder Tombstone Age Limit est présent dans le Registre, un message indiquant une configuration autre que celle par défaut s'affiche.

Les informations d'un indicateur de suppression de dossier sont utilisées par la réplication de dossiers publics. L'âge permet d'empêcher la liste de l'indicateur de suppression de dossier public de s'accroître à l'infini. La valeur par défaut de 180 jours peut être remplacée par la valeur de Registre Replication Folder Tombstone Age Limit.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>

  3. Supprimez la valeur de Registre Replication Folder Tombstone Age Limit.

  4. Redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Replication Folder Tombstone Age Limit, voir l'article 159196 de la Base de connaissances sur les tâches contrôlées par la planification de la maintenance de la banque d'informations (http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196).


Valeur Replication Long Backfill Request Delay modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Long Backfill Request Delay a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Long Backfill Request Delay

Si Exchange Server Analyzer détecte que la clé Replication Long Backfill Request Delay est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, la clé Replication Long Backfill Request Delay n'existe pas. Le renvoi se produit lorsqu'une banque de dossiers publics détermine qu'elle n'a pas reçu toutes les mises à jour pour un dossier répliqué, ou la hiérarchie, et doit récupérer les mises à jour manquantes d'une autre banque.

Pour optimiser le processus de renvoi, Exchange Server stocke les informations sur les mises à jour manquantes dans le tableau de renvoi. Le tableau de renvoi stocke ces informations pendant une période spécifiée (appelée délai de renvoi). Si les mises à jour manquantes arrivent dans des messages de réplication ultérieurs pendant ce laps de temps, elles sont supprimées du tableau de renvoi. Le tableau ci-dessous répertorie les valeurs de délai de renvoi par défaut qui dépendent de l'emplacement des mises à jour manquantes et si elles ont déjà été demandées.

Type de demande | Contenu existant dans une banque du site local | Contenu existant dans une banque d'un site distant
Renvoi initial | 6 heures | 12 heures
Première tentative de renvoi | 12 heures | 24 heures
Tentatives de renvoi suivantes | 24 heures | 48 heures

Si le délai de renvoi expire et si les mises à jour sont toujours manquantes, Exchange Server 2003 crée une ou plusieurs demandes de renvoi et décide quels serveurs utiliser comme sources de renvoi.

Pour sélectionner le serveur ou les serveurs à utiliser comme source de renvoi, Exchange Server 2003 crée d'abord une liste de tous les serveurs qui contiennent des réplicas du dossier et trie ensuite la liste d'après la séquence de critères suivante :

  • Tri d'après l'état du serveur. Les serveurs qui sont arrêtés ou indisponibles sont placés à la fin de la liste.

  • Tri d'après le serveur de renvoi préféré. Le cas échéant, cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures. Exchange Server 2003 recherche un serveur de renvoi préféré dans l'objet de banque de dossiers publics du service d'annuaire Active Directory®. Ce paramètre est rarement utilisé. Dans la plupart des cas, le processus de renvoi est plus efficace si Exchange Server 2003 sélectionne automatiquement un serveur de renvoi. La plupart des déploiements d'Exchange Server 2003 n'ont pas besoin d'un serveur de renvoi préféré. Les services du Support Technique de Microsoft peuvent fournir un script qui définit un serveur de renvoi préféré si votre déploiement le nécessite.

  • Tri d'après le coût de transport (du plus faible au plus élevé). Les serveurs se trouvant sur le même site sont prioritaires par rapport aux serveurs de sites distants. Le coût de transport d'un serveur est calculé par le moteur de routage Exchange Server 2003 et normalement utilisé pour calculer la manière la plus efficace de remettre un message. Notez que dans les versions d'Exchange antérieures à Exchange Server 2003, le coût de transport a une priorité plus faible et n'est pris en considération qu'après la version d'Exchange et le nombre de modifications disponibles.

  • Tri d'après la version d'Exchange (de la plus récente à la plus ancienne).

  • Tri d'après le nombre de modifications nécessaires qui sont disponibles sur le serveur (du plus grand au plus petit). Les serveurs qui n'ont aucune des modifications manquantes sont supprimés de la liste.

Si un serveur n'a pas toutes les modifications nécessaires, Exchange Server 2003 sélectionne le serveur suivant dans la liste triée et envoie également une demande de renvoi à ce serveur. Ce processus est répété jusqu'à ce que toutes les modifications aient été demandées. Cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures ; les versions précédentes d'Exchange envoient des demandes de renvoi à un serveur à la fois si aucun serveur unique ne contient toutes les mises à jour manquantes pour un dossier spécifique. Après chaque demande, les versions précédentes d'Exchange attendent que le délai de tentative (de 24 à 48 heures) soit écoulé avant d'envoyer la demande suivante.

Si le serveur sélectionné ne répond pas à la demande de renvoi, la banque marque ce serveur comme arrêté et répète le processus de sélection. Les serveurs marqués comme arrêtés sont placés à la fin de la liste.

La valeur Replication Long Backfill Request Delay représente le temps d'attente utilisé par une banque avant d'envoyer une demande de renvoi pour les données non disponibles sur le même site Exchange. La valeur, en secondes, doit être comprise entre 900 et 2 592 000 secondes (30 jours) ; la valeur par défaut est 43200 secondes (12 heures).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Replication Long Backfill Request Delay

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Long Backfill Request Delay.

    La valeur de cette entrée de Registre est exprimée en secondes. Pour renvoyer la valeur par défaut, vous devez supprimer Replication Long Backfill Request Delay et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Valeur Replication Short Backfill Request Delay modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Long Backfill Request Timeout a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Long Backfill Request Timeout

Si Exchange Server Analyzer détecte que la clé Replication Long Backfill Request Timeout est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, la clé Replication Long Backfill Request Timeout n'existe pas. Le renvoi se produit lorsqu'une banque de dossiers publics détermine qu'elle n'a pas reçu toutes les mises à jour pour un dossier répliqué, ou la hiérarchie, et doit récupérer les mises à jour manquantes d'une autre banque.

Pour optimiser le processus de renvoi, Exchange Server stocke les informations sur les mises à jour manquantes dans le tableau de renvoi. Le tableau de renvoi stocke ces informations pendant une période spécifiée (appelée délai de renvoi). Si les mises à jour manquantes arrivent dans des messages de réplication ultérieurs pendant ce laps de temps, elles sont supprimées du tableau de renvoi. Le tableau ci-dessous répertorie les valeurs de délai de renvoi par défaut qui dépendent de l'emplacement des mises à jour manquantes et si elles ont déjà été demandées.

Type de demande | Contenu existant dans une banque du site local | Contenu existant dans une banque d'un site distant
Renvoi initial | 6 heures | 12 heures
Première tentative de renvoi | 12 heures | 24 heures
Tentatives de renvoi suivantes | 24 heures | 48 heures

Si le délai de renvoi expire et si les mises à jour sont toujours manquantes, Exchange Server 2003 crée une ou plusieurs demandes de renvoi et décide quels serveurs utiliser comme sources de renvoi.

Pour sélectionner le serveur ou les serveurs à utiliser comme source de renvoi, Exchange Server 2003 crée d'abord une liste de tous les serveurs qui contiennent des réplicas du dossier et trie ensuite la liste d'après la séquence de critères suivante :

  • Tri d'après l'état du serveur. Les serveurs qui sont arrêtés ou indisponibles sont placés à la fin de la liste.

  • Tri d'après le serveur de renvoi préféré. Le cas échéant, cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures. Exchange Server 2003 recherche un serveur de renvoi préféré dans l'objet de banque de dossiers publics du service d'annuaire Active Directory®. Ce paramètre est rarement utilisé. Dans la plupart des cas, le processus de renvoi est plus efficace si Exchange Server 2003 sélectionne automatiquement un serveur de renvoi. La plupart des déploiements d'Exchange Server 2003 n'ont pas besoin d'un serveur de renvoi préféré. Les services du Support Technique de Microsoft peuvent fournir un script qui définit un serveur de renvoi préféré si votre déploiement le nécessite.

  • Tri d'après le coût de transport (du plus faible au plus élevé). Les serveurs se trouvant sur le même site sont prioritaires par rapport aux serveurs de sites distants. Le coût de transport d'un serveur est calculé par le moteur de routage Exchange Server 2003 et normalement utilisé pour calculer la manière la plus efficace de remettre un message. Notez que dans les versions d'Exchange antérieures à Exchange Server 2003, le coût de transport a une priorité plus faible et n'est pris en considération qu'après la version d'Exchange et le nombre de modifications disponibles.

  • Tri d'après la version d'Exchange (de la plus récente à la plus ancienne).

  • Tri d'après le nombre de modifications nécessaires qui sont disponibles sur le serveur (du plus grand au plus petit). Les serveurs qui n'ont aucune des modifications manquantes sont supprimés de la liste.

Si un serveur n'a pas toutes les modifications nécessaires, Exchange Server 2003 sélectionne le serveur suivant dans la liste triée et envoie également une demande de renvoi à ce serveur. Ce processus est répété jusqu'à ce que toutes les modifications aient été demandées. Cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures ; les versions précédentes d'Exchange envoient des demandes de renvoi à un serveur à la fois si aucun serveur unique ne contient toutes les mises à jour manquantes pour un dossier spécifique. Après chaque demande, les versions précédentes d'Exchange attendent que le délai de tentative (de 24 à 48 heures) soit écoulé avant d'envoyer la demande suivante.

Si le serveur sélectionné ne répond pas à la demande de renvoi, la banque marque ce serveur comme arrêté et répète le processus de sélection. Les serveurs marqués comme arrêtés sont placés à la fin de la liste.

La valeur Replication Long Backfill Request Timeout représente la valeur de délai que la banque de dossiers publics utilise lorsqu'elle tente d'envoyer une demande de renvoi pour les données non disponibles sur le même site Exchange. La valeur, en secondes, doit être comprise entre 900 et 2 592 000 secondes (30 jours) ; la valeur par défaut est 86400 secondes (24 heures).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Replication Long Backfill Request Timeout

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Long Backfill Request Timeout.

    La valeur de cette entrée de Registre est exprimée en secondes. Pour rétablir la valeur par défaut, vous devez supprimer Replication Long Backfill Request Timeout et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Valeur Replication Long Backfill Request Timeout Retry modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Long Backfill Request Timeout Retry a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Long Backfill Request Timeout Retry

Si Exchange Server Analyzer détecte que la clé Replication Long Backfill Request Timeout Retry est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, la clé Replication Long Backfill Request Timeout Retry n'existe pas. Le renvoi se produit lorsqu'une banque de dossiers publics détermine qu'elle n'a pas reçu toutes les mises à jour pour un dossier répliqué, ou la hiérarchie, et doit récupérer les mises à jour manquantes d'une autre banque.

Pour optimiser le processus de renvoi, Exchange Server stocke les informations sur les mises à jour manquantes dans le tableau de renvoi. Le tableau de renvoi stocke ces informations pendant une période spécifiée (appelée délai de renvoi). Si les mises à jour manquantes arrivent dans des messages de réplication ultérieurs pendant ce laps de temps, elles sont supprimées du tableau de renvoi. Le tableau répertorie les valeurs de délai de renvoi par défaut qui dépendent de l'emplacement des mises à jour manquantes et si elles ont déjà été demandées.

Type de demande | Contenu existant dans une banque du site local | Contenu existant dans une banque d'un site distant
Renvoi initial | 6 heures | 12 heures
Première tentative de renvoi | 12 heures | 24 heures
Tentatives de renvoi suivantes | 24 heures | 48 heures

Si le délai de renvoi expire et si les mises à jour sont toujours manquantes, Exchange Server 2003 crée une ou plusieurs demandes de renvoi et décide quels serveurs utiliser comme sources de renvoi.

Pour sélectionner le serveur ou les serveurs à utiliser comme source de renvoi, Exchange Server 2003 crée d'abord une liste de tous les serveurs qui contiennent des réplicas du dossier et trie ensuite la liste d'après la séquence de critères suivante :

  • Tri d'après l'état du serveur. Les serveurs qui sont arrêtés ou indisponibles sont placés à la fin de la liste.

  • Tri d'après le serveur de renvoi préféré. Le cas échéant, cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures. Exchange Server 2003 recherche un serveur de renvoi préféré dans l'objet de banque de dossiers publics du service d'annuaire Active Directory®. Ce paramètre est rarement utilisé. Dans la plupart des cas, le processus de renvoi est plus efficace si Exchange Server 2003 sélectionne automatiquement un serveur de renvoi. La plupart des déploiements d'Exchange Server 2003 n'ont pas besoin d'un serveur de renvoi préféré. Les services du Support Technique de Microsoft peuvent fournir un script qui définit un serveur de renvoi préféré si votre déploiement le nécessite.

  • Tri d'après le coût de transport (du plus faible au plus élevé). Les serveurs se trouvant sur le même site sont prioritaires par rapport aux serveurs de sites distants. Le coût de transport d'un serveur est calculé par le moteur de routage Exchange Server 2003 et normalement utilisé pour calculer la manière la plus efficace de remettre un message. Notez que dans les versions d'Exchange antérieures à Exchange Server 2003, le coût de transport a une priorité plus faible et n'est pris en considération qu'après la version d'Exchange et le nombre de modifications disponibles.

  • Tri d'après la version d'Exchange (de la plus récente à la plus ancienne).

  • Tri d'après le nombre de modifications nécessaires qui sont disponibles sur le serveur (du plus grand au plus petit). Les serveurs qui n'ont aucune des modifications manquantes sont supprimés de la liste.

Si un serveur n'a pas toutes les modifications nécessaires, Exchange Server 2003 sélectionne le serveur suivant dans la liste triée et envoie également une demande de renvoi à ce serveur. Ce processus est répété jusqu'à ce que toutes les modifications aient été demandées. Cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures ; les versions précédentes d'Exchange envoient des demandes de renvoi à un serveur à la fois si aucun serveur unique ne contient toutes les mises à jour manquantes pour un dossier spécifique. Après chaque demande, les versions précédentes d'Exchange attendent que le délai de tentative (de 24 à 48 heures) soit écoulé avant d'envoyer la demande suivante.

Si le serveur sélectionné ne répond pas à la demande de renvoi, la banque marque ce serveur comme arrêté et répète le processus de sélection. Les serveurs marqués comme arrêtés sont placés à la fin de la liste.

La valeur Replication Long Backfill Request Timeout Retry représente la valeur de délai utilisée par la banque de dossiers publics lors de l'envoi d'une demande de renvoi pour les données qui ne sont pas disponibles sur le même site Exchange et lorsque cette demande est une tentative d'une précédente demande de renvoi. La valeur, en secondes, doit être comprise entre 900 et 2 592 000 secondes (30 jours) ; la valeur par défaut est 172800 secondes (48 heures).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Replication Long Backfill Request Timeout Retry

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Long Backfill Request Timeout Retry.

    La valeur de cette entrée de Registre est exprimée en secondes. Pour renvoyer la valeur par défaut, vous devez supprimer Replication Long Backfill Request Timeout Retry et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Les messages de réplication au démarrage ont été activés
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si Exchange a été configuré pour générer des messages de demande d'état pour la hiérarchie de dossiers publics :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de banque d'informations publique>\Enable Replication Messages At Startup

Si Exchange Server Analyzer détecte que l'entrée de Registre Enable Replication Messages At Startup est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Dans Exchange Server 5.5, chaque ordinateur disposant d'une banque de dossiers publics envoie un message de demande d'état pendant la nuit pour déterminer l'état de la hiérarchie de dossiers publics. Exchange 2000 Server et Exchange Server 2003 ne le permettent pas. En règle générale, dans Exchange 2000 Server et Exchange Server 2003, le message de demande d'état n'est envoyé qu'une fois pendant la durée de vie de la banque de dossiers publics ; il est envoyé lors de la création de la banque.

Toutefois, dans certaines circonstances, il se peut que vous deviez générer un message de demande d'état. Par exemple, si la hiérarchie de dossiers publics de l'ordinateur Exchange 2000 Server ou Exchange Server 2003 ne semble pas être répliqué ou si la hiérarchie de dossiers publics est répliquée très lentement, la génération d'un message de demande d'état peut autoriser la poursuite de la réplication de la hiérarchie de dossiers publics. Des problèmes de réplication de la hiérarchie de dossiers publics peuvent se produire si le message original de demande d'état envoyé lors de la création de la banque de dossiers publics a été supprimé et n'a jamais été reconnu ou si le message a été envoyé à un serveur présentant une hiérarchie fort incomplète.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour afficher ou modifier la valeur de Registre Aging Keep Time

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur>\Public-<GUID de banque d'informations publique>

  3. Examinez ou, si vous le souhaitez, modifiez la valeur Enable Replication Messages At Startup. Cette valeur REG_DWORD doit être définie sur 1 pour être prise en compte. Si vous définissez la valeur sur 0 (paramètre par défaut), aucun message de demande d'état n'est envoyé lors du démarrage de la banque d'informations publique.

  4. Si une modification est apportée, fermez l'Éditeur du Registre, puis démontez et remontez la banque d'informations publique pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les messages d'état de réplication des dossiers publics et la valeur de Registre Enable Replication Messages At Startup, voir les articles suivants de la Base de connaissances :

  • 321082 sur la procédure d'envoi des messages de demande d'état de réplication dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082).

  • 842273 sur la procédure de résolution des problèmes de réplication des dossiers publics dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273).


Valeur Replication Short Backfill Request Delay modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Short Backfill Request Delay a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Short Backfill Request Delay

Si Exchange Server Analyzer détecte que la clé Replication Short Backfill Request Delay est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut Replication Short Backfill Request Delay n'existe pas. Le renvoi se produit lorsqu'une banque de dossiers publics détermine qu'elle n'a pas reçu toutes les mises à jour pour un dossier répliqué, ou la hiérarchie, et doit récupérer les mises à jour manquantes d'une autre banque.

Pour optimiser le processus de renvoi, Exchange Server stocke les informations sur les mises à jour manquantes dans le tableau de renvoi. Le tableau de renvoi stocke ces informations pendant une période spécifiée (appelée délai de renvoi). Si les mises à jour manquantes arrivent dans des messages de réplication ultérieurs pendant ce laps de temps, elles sont supprimées du tableau de renvoi. Le tableau répertorie les valeurs de délai de renvoi par défaut qui dépendent de l'emplacement des mises à jour manquantes et si elles ont déjà été demandées.

Type de demande | Contenu existant dans une banque du site local | Contenu existant dans une banque d'un site distant
Renvoi initial | 6 heures | 12 heures
Première tentative de renvoi | 12 heures | 24 heures
Tentatives de renvoi suivantes | 24 heures | 48 heures

Si le délai de renvoi expire et si les mises à jour sont toujours manquantes, Exchange Server 2003 crée une ou plusieurs demandes de renvoi et décide quels serveurs utiliser comme sources de renvoi.

Pour sélectionner le ou les serveurs à utiliser comme source de renvoi, Exchange Server 2003 crée d'abord une liste de tous les serveurs qui contiennent des réplicas du dossier et trie ensuite la liste d'après la séquence de critères suivante :

  • Tri d'après l'état du serveur. Les serveurs qui sont arrêtés ou indisponibles sont placés à la fin de la liste.

  • Tri d'après le serveur de renvoi préféré. Le cas échéant, cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures. Exchange Server 2003 recherche un serveur de renvoi préféré dans l'objet de banque de dossiers publics du service d'annuaire Active Directory®. Ce paramètre est rarement utilisé. Dans la plupart des cas, le processus de renvoi est plus efficace si Exchange Server 2003 sélectionne automatiquement un serveur de renvoi. La plupart des déploiements d'Exchange Server 2003 n'ont pas besoin d'un serveur de renvoi préféré. Les services du Support Technique de Microsoft peuvent fournir un script qui définit un serveur de renvoi préféré si votre déploiement le nécessite.

  • Tri d'après le coût de transport (du plus faible au plus élevé). Les serveurs se trouvant sur le même site sont prioritaires par rapport aux serveurs de sites distants. Le coût de transport d'un serveur est calculé par le moteur de routage Exchange Server 2003 et normalement utilisé pour calculer la manière la plus efficace de remettre un message. Notez que dans les versions d'Exchange antérieures à Exchange Server 2003, le coût de transport a une priorité plus faible et n'est pris en considération qu'après la version d'Exchange et le nombre de modifications disponibles.

  • Tri d'après la version d'Exchange (de la plus récente à la plus ancienne).

  • Tri d'après le nombre de modifications nécessaires qui sont disponibles sur le serveur (du plus grand au plus petit). Les serveurs qui n'ont aucune des modifications manquantes sont supprimés de la liste.

Si un serveur n'a pas toutes les modifications nécessaires, Exchange Server 2003 sélectionne le serveur suivant dans la liste triée et envoie également une demande de renvoi à ce serveur. Ce processus est répété jusqu'à ce que toutes les modifications aient été demandées. Cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures ; les versions précédentes d'Exchange envoient des demandes de renvoi à un serveur à la fois si aucun serveur unique ne contient toutes les mises à jour manquantes pour un dossier spécifique. Après chaque demande, les versions précédentes d'Exchange attendent que le délai de tentative (de 24 à 48 heures) soit écoulé avant d'envoyer la demande suivante.

Si le serveur sélectionné ne répond pas à la demande de renvoi, la banque marque ce serveur comme arrêté et répète le processus de sélection. Les serveurs marqués comme arrêtés sont placés à la fin de la liste.

La valeur Replication Short Backfill Request Delay représente le temps d'attente utilisé par la banque de dossiers publics avant d'envoyer une demande de renvoi pour les données disponibles sur le même site Exchange. La valeur, en secondes, doit être comprise entre 900 et 2 592 000 secondes (30 jours) ; la valeur par défaut est 21600 secondes (6 heures).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Replication Short Backfill Request Delay

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Short Backfill Request Delay.

    La valeur de cette entrée de Registre est exprimée en secondes. Pour renvoyer la valeur par défaut, vous devez supprimer Replication Short Backfill Request Delay et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


Valeur Replication Short Backfill Request Timeout modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Short Backfill Request Timeout a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Short Backfill Request Timeout

Si Exchange Server Analyzer détecte que la clé Replication Short Backfill Request Timeout est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, la clé Replication Short Backfill Request Timeout n'existe pas. Le renvoi se produit lorsqu'une banque de dossiers publics détermine qu'elle n'a pas reçu toutes les mises à jour pour un dossier répliqué, ou la hiérarchie, et doit récupérer les mises à jour manquantes d'une autre banque.

Pour optimiser le processus de renvoi, Exchange Server stocke les informations sur les mises à jour manquantes dans le tableau de renvoi. Le tableau de renvoi stocke ces informations pendant une période spécifiée (appelée délai de renvoi). Si les mises à jour manquantes arrivent dans des messages de réplication ultérieurs pendant ce laps de temps, elles sont supprimées du tableau de renvoi. Le tableau ci-dessous répertorie les valeurs de délai de renvoi par défaut qui dépendent de l'emplacement des mises à jour manquantes et si elles ont déjà été demandées.

Type de demande | Contenu existant dans une banque du site local | Contenu existant dans une banque d'un site distant
Renvoi initial | 6 heures | 12 heures
Première tentative de renvoi | 12 heures | 24 heures
Tentatives de renvoi suivantes | 24 heures | 48 heures

Si le délai de renvoi expire et si les mises à jour sont toujours manquantes, Exchange Server 2003 crée une ou plusieurs demandes de renvoi et décide quels serveurs utiliser comme sources de renvoi.

Pour sélectionner le serveur ou les serveurs à utiliser comme source de renvoi, Exchange Server 2003 crée d'abord une liste de tous les serveurs qui contiennent des réplicas du dossier et trie ensuite la liste d'après la séquence de critères suivante :

  • Tri d'après l'état du serveur. Les serveurs qui sont arrêtés ou indisponibles sont placés à la fin de la liste.

  • Tri d'après le serveur de renvoi préféré. Le cas échéant, cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures. Exchange Server 2003 recherche un serveur de renvoi préféré dans l'objet de banque de dossiers publics dans le service d'annuaire Active Directory®. Ce paramètre est rarement utilisé. Dans la plupart des cas, le processus de renvoi est plus efficace si Exchange Server 2003 sélectionne automatiquement un serveur de renvoi. La plupart des déploiements d'Exchange Server 2003 n'ont pas besoin d'un serveur de renvoi préféré. Les services du Support Technique de Microsoft peuvent fournir un script qui définit un serveur de renvoi préféré si votre déploiement le nécessite.

  • Tri d'après le coût de transport (plus faible à élevé). Les serveurs se trouvant sur le même site sont prioritaires par rapport aux serveurs de sites distants. Le coût de transport d'un serveur est calculé par le moteur de routage Exchange Server 2003 et est normalement utilisé pour calculer la manière la plus efficace de remettre un message. Notez que dans les versions d'Exchange antérieures à Exchange Server 2003, le coût de transport a une priorité plus faible et n'est pris en considération qu'après la version d'Exchange et le nombre de modifications disponibles.

  • Tri d'après la version d'Exchange (de la plus récente à la plus ancienne).

  • Tri d'après le nombre de modifications nécessaires qui sont disponibles sur le serveur (du plus grand au plus petit). Les serveurs qui n'ont aucune des modifications manquantes sont supprimés de la liste.

Si un serveur n'a pas toutes les modifications nécessaires, Exchange Server 2003 sélectionne le serveur suivant dans la liste triée et envoie également une demande de renvoi à ce serveur. Ce processus est répété jusqu'à ce que toutes les modifications aient été demandées. Cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures ; les versions précédentes d'Exchange envoient des demandes de renvoi à un serveur à la fois si aucun serveur unique ne contient toutes les mises à jour manquantes pour un dossier spécifique. Après chaque demande, les versions précédentes d'Exchange attendent que le délai de tentative (de 24 à 48 heures) soit écoulé avant d'envoyer la demande suivante.

Si le serveur sélectionné ne répond pas à la demande de renvoi, la banque marque ce serveur comme arrêté et répète le processus de sélection. Les serveurs marqués comme arrêtés sont placés à la fin de la liste.

La valeur Replication Short Backfill Request Timeout représente la valeur de délai que la banque de dossiers publics utilise lorsqu'elle tente d'envoyer une demande de renvoi pour les données non disponibles sur le même site Exchange. La valeur, en secondes, doit être comprise entre 900 et 2 592 000 secondes (30 jours) ; la valeur par défaut est 43200 secondes (12 heures).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Replication Short Backfill Request Timeout

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Short Backfill Request Timeout.

    La valeur de cette entrée de Registre est exprimée en secondes. Pour rétablir la valeur par défaut, vous devez supprimer Replication Short Backfill Request Timeout et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


La valeur Replication Short Backfill Request Timeout Retry a été modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la clé Replication Short Backfill Request Timeout Retry a été modifiée et ne contient plus la valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>\Replication Short Backfill Request Timeout Retry

Si Exchange Server Analyzer détecte que la clé Replication Short Backfill Request Timeout Retry est présente, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, la clé Replication Short Backfill Request Timeout Retry n'existe pas. Le renvoi se produit lorsqu'une banque de dossiers publics détermine qu'elle n'a pas reçu toutes les mises à jour pour un dossier répliqué, ou la hiérarchie, et doit récupérer les mises à jour manquantes d'une autre banque.

Pour optimiser le processus de renvoi, Exchange Server stocke les informations sur les mises à jour manquantes dans le tableau de renvoi. Le tableau de renvoi stocke ces informations pendant une période spécifiée (appelée délai de renvoi). Si les mises à jour manquantes arrivent dans des messages de réplication ultérieurs pendant ce laps de temps, elles sont supprimées du tableau de renvoi. Le tableau ci-dessous répertorie les valeurs de délai de renvoi par défaut qui dépendent de l'emplacement des mises à jour manquantes et si elles ont déjà été demandées.

Type de demande | Contenu existant dans une banque du site local | Contenu existant dans une banque d'un site distant
Renvoi initial | 6 heures | 12 heures
Première tentative de renvoi | 12 heures | 24 heures
Tentatives de renvoi suivantes | 24 heures | 48 heures

Si le délai de renvoi expire et si les mises à jour sont toujours manquantes, Exchange Server 2003 crée une ou plusieurs demandes de renvoi et décide quels serveurs utiliser comme sources de renvoi.

Pour sélectionner le serveur ou les serveurs à utiliser comme source de renvoi, Exchange Server 2003 crée d'abord une liste de tous les serveurs qui contiennent des réplicas du dossier et trie ensuite la liste d'après la séquence de critères suivante :

  • Tri d'après l'état du serveur. Les serveurs qui sont arrêtés ou indisponibles sont placés à la fin de la liste.

  • Tri d'après le serveur de renvoi préféré. Le cas échéant, cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures. Exchange Server 2003 recherche un serveur de renvoi préféré dans l'objet de banque de dossiers publics du service d'annuaire Active Directory®. Ce paramètre est rarement utilisé. Dans la plupart des cas, le processus de renvoi est plus efficace si Exchange Server 2003 sélectionne automatiquement un serveur de renvoi. La plupart des déploiements d'Exchange Server 2003 n'ont pas besoin d'un serveur de renvoi préféré. Les services du Support Technique de Microsoft peuvent fournir un script qui définit un serveur de renvoi préféré si votre déploiement le nécessite.

  • Tri d'après le coût de transport (du plus faible au plus élevé). Les serveurs se trouvant sur le même site sont prioritaires par rapport aux serveurs de sites distants. Le coût de transport d'un serveur est calculé par le moteur de routage Exchange Server 2003 et normalement utilisé pour calculer la manière la plus efficace de remettre un message. Notez que dans les versions d'Exchange antérieures à Exchange Server 2003, le coût de transport a une priorité plus faible et n'est pris en considération qu'après la version d'Exchange et le nombre de modifications disponibles.

  • Tri d'après la version d'Exchange (de la plus récente à la plus ancienne).

  • Tri d'après le nombre de modifications nécessaires qui sont disponibles sur le serveur (du plus grand au plus petit). Les serveurs qui n'ont aucune des modifications manquantes sont supprimés de la liste.

Si un serveur n'a pas toutes les modifications nécessaires, Exchange Server 2003 sélectionne le serveur suivant dans la liste triée et envoie également une demande de renvoi à ce serveur. Ce processus est répété jusqu'à ce que toutes les modifications aient été demandées. Cette fonction n'est disponible que dans Exchange Server 2003 et versions ultérieures ; les versions précédentes d'Exchange envoient des demandes de renvoi à un serveur à la fois si aucun serveur unique ne contient toutes les mises à jour manquantes pour un dossier spécifique. Après chaque demande, les versions précédentes d'Exchange attendent que le délai de tentative (de 24 à 48 heures) soit écoulé avant d'envoyer la demande suivante.

Si le serveur sélectionné ne répond pas à la demande de renvoi, la banque marque ce serveur comme arrêté et répète le processus de sélection. Les serveurs marqués comme arrêtés sont placés à la fin de la liste.

La valeur Replication Short Backfill Request Timeout Retry représente la valeur de délai utilisée par la banque de dossiers publics lors de l'envoi d'une demande de renvoi pour les données disponibles sur le même site Exchange et lorsque cette demande est une tentative d'une précédente demande de renvoi. La valeur, en secondes, doit être comprise entre 900 et 2 592 000 secondes (30 jours) ; la valeur par défaut est 86 400 secondes (24 heures).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour réinitialiser la clé de Registre Replication Short Backfill Request Timeout Retry

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nom_serveur>\Public-<GUID de banque publique>

  3. Examinez ou modifiez la valeur de Replication Short Backfill Request Timeout Retry.

    La valeur de cette entrée de Registre est exprimée en secondes. Pour revenir à la valeur par défaut, vous devez supprimer Replication Short Backfill Request Timeout Retry et redémarrer le service de banque d'informations de Microsoft Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la réplication des dossiers publics, voir le chapitre sur le contrôle de la réplication des dossiers publics d'Exchange Server 2003 du document sur l'utilisation de la banque d'informations Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47595).


La taille d'incrément de réserve a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-30

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si une valeur de Reserve Increment KB a été définie : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Microsoft Exchange 2000 Server. Si la valeur de chaîne inclut « Version 6.5 », l'ordinateur exécute Microsoft Exchange Server 2003. Si la valeur de chaîne inclut « Version 8.0 », l'ordinateur exécute Microsoft Exchange Server 2007.

Si Exchange Server Analyzer détecte que la valeur de Registre Reserve Increment KB existe sur un ordinateur qui utilise Exchange Server 2003, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre Reserve Increment KB remplace la valeur du segment de mémoire natif dans Microsoft Windows®. Windows inclut un gestionnaire de segments des processus qui traite les opérations de mémoire pour tous les processus. Chaque fois qu'un processus instancie, un segment par défaut (appelé segment de mémoire du processus) est créé pour ce processus. Les programmes ou modules chargés dans le processus peuvent également créer des segments supplémentaires, au besoin. Le service Banque d'informations Microsoft Exchange, Store.exe, est un exemple de processus qui crée, au besoin, des segments supplémentaires. Par défaut, Store.exe définit la mémoire initiale qui est réservée pour l'espace de tas sur 20 % de RAM physique. La valeur Reserve Increment KB modifie la réservation de mémoire initiale pour le tas en 10 % de mémoire physique.

La valeur de Registre Reserve Increment KB n'est utile que dans des cas limités. En outre, cette valeur ne doit être définie que sur les conseils et les instructions des services de support technique Microsoft. Une utilisation ou un paramétrage incorrect de cette valeur peut réduire les performances et accélérer la fragmentation de mémoire virtuelle. Si cette valeur a été définie sans consultation des services de support technique Microsoft, envisagez de la supprimer à l'aide de la procédure suivante.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, supprimez la valeur Reserve Increment KB.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur le réglage d'Exchange Server 2003, consultez les articles suivants de la Base de connaissances Microsoft :

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372 sur la procédure d'optimisation de l'utilisation de la mémoire dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


Compression de tampon RPC désactivée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la compression de tampon RPC (Remote Procedure Call) a été désactivée :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

Si Exchange Server Analyzer détecte que la valeur de la clé de Registre Rpc Packing Enabled est définie sur 0, il affiche un message indiquant une configuration autre que celle par défaut. La clé de Registre Rpc Packing Enabled est désactivée si sa valeur est définie sur 0.

Les données de valeur de la clé de Registre Rpc Packing Enabled correspondent à l'une des trois entrées de Registre que les administrateurs peuvent ajouter pour configurer la compression RPC entre Microsoft Office Outlook® 2003 et Exchange Server 2003.

Outlook 2003 peut nécessiter un tampon de données de 96 Ko. Toutefois, après la compression des données par Exchange Server 2003, le tampon de données peut s'avérer considérablement inférieur à la taille requise par Outlook.

Exchange Server 2003 prend en charge la compression de tampon pour accepter des taux de compression variables et garder l'intégralité des tampons pour une efficacité optimale.

Lorsque la clé de Registre Rpc Packing Enabled est activée, Exchange Server 2003 continue d'ajouter des données compressées au tampon jusqu'à ce qu'il soit saturé. Pour chaque demande de données, Outlook 2003 peut télécharger beaucoup plus de données que les versions précédentes d'Outlook pour les raisons suivantes :

  • Outlook 2003 nécessite des tailles de tampon plus importantes.

  • Exchange Server 2003 prend en charge la compression de tampon.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise. Toutefois, vous pouvez supprimer la clé de Registre Rpc Packing Enabled si vous souhaitez rétablir la configuration par défaut. Vous pouvez également définir la valeur des données de la clé de Registre Rpc Packing Enabled sur 1 pour activer la compression de tampon RPC.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    • Pour supprimer l'entrée, effacez la valeur Rpc Packing Enabled.

    • Pour conserver l'entrée et activer la compression de tampon RPC, double-cliquez sur Rpc Packing Enabled, définissez la valeur sur 1, puis cliquez sur OK.

  3. Fermez l'Éditeur du Registre.

Le service de banque d'informations de Microsoft Exchange détecte les modifications en quelques minutes. Il n'est pas nécessaire de redémarrer l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la définition des clés de Registre pour configurer la compression RPC entre des clients Outlook et Exchange Server 2003, voir l'article de la Base de connaissances sur la modification de la compression d'appel de procédure distante dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


La taille minimale de compression RPC n'est pas celle par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la taille minimale du paquet de compression RPC :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

Si Exchange Server Analyzer détecte que la valeur définie pour Rpc Compression Minimum Size est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Par défaut, toutes les données RPC qui se déplacent entre Microsoft Office Outlook® 2003 ou Outlook 2007 et Exchange Server 2003 ou Exchange Server 2007 sont compressées, quelle que soit la taille. Dans certains scénarios, vous souhaitez peut-être contrôler la compression RPC. Par exemple, si vous essayez de résoudre des problèmes de connexion en affichant les paquets envoyés sur le réseau, la compression RPC peut rendre l'analyse difficile car vous affichez uniquement les données compressées dans le suivi.

Pour configurer les paramètres de compression RPC, vous pouvez ajouter trois valeurs de clé de Registre aux paramètres système :

  • Taille minimale de compression Rpc

  • Compression Rpc activée

  • Ensemble Rpc activé

La valeur de Registre Rpc Compression Minimum Size détermine le nombre minimal d'octets nécessaires dans le paquet RPC avant l'activation de la compression. Si cette clé n'est pas présente, une valeur par défaut de 1 024 octets est utilisée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la clé Rpc Compression Minimum Size. Si les clés Rpc Compression Enabled et Rpc Packing Enabled sont présentes, supprimez-les également.

  4. Fermez l'Éditeur du Registre et redémarrez le serveur Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le contrôle de la compression RPC, consultez l'article 825371 de la Base de connaissances sur la modification de la compression RPC dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371).


Le paramètre RpcEtwTracing n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour en déterminer la valeur :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

Si Exchange Server Analyzer détecte que la valeur de la clé de Registre RpcEtwTracing est définie sur 1, il affiche un message indiquant une configuration autre que celle par défaut.

Utilisez la valeur de la clé de Registre RpcEtwTracing uniquement pour résoudre des problèmes réseau entre Microsoft Office Outlook® 2003 et Exchange Server. Il est conseillé de désactiver la clé de Registre RpcEtwTracing si vous n'êtes pas occupé à résoudre un problème.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise. Toutefois, vous pouvez supprimer la clé de Registre RpcEtwTracing si vous souhaitez rétablir la configuration par défaut.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la valeur RpcEtwTracing.

  4. Fermez l'Éditeur du Registre.

Le service de banque d'informations de Microsoft Exchange détecte les modifications en quelques minutes. Il n'est pas nécessaire de redémarrer l'ordinateur.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le serveur a moins de quatre groupes de stockage mais plus de quatre banques de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour compter le nombre d'objets StorageGroup et MailboxGroup sur un serveur qui exécute Exchange Server 2003. Si Exchange Server Analyzer détermine que le nombre total d'objets StorageGroup est inférieur à quatre et que le nombre total d'objets MailboxStore est supérieur à quatre, une erreur s'affiche.

Si vous utilisez Exchange Server 2003 Édition Standard, chaque ordinateur Exchange Server peut avoir un groupe de stockage qui prend en charge une banque de boîtes aux lettres et une banque de dossiers publics. Si vous utilisez Exchange Server 2003 Édition Entreprise, chaque serveur peut avoir jusqu'à quatre groupes de stockage, chacun d'entre eux prenant en charge jusqu'à cinq bases de données (soit des banques de boîtes aux lettres ou des banques de dossiers publics).

Pour configurer les groupes de stockage pour des ordinateurs exécutant Exchange Server 2003 Édition Entreprise, il est recommandé d'ajouter un groupe de stockage supplémentaire pour chaque nouvelle base de données jusqu'à ce que le nombre maximal de groupes de stockage ait été créé. Vous pouvez répartir la charge des boîtes aux lettres de votre topologie de stockage Exchange Server sur autant de groupes de stockage que possible. Une telle topologie offre les avantages suivants :

  • accroissement de la fiabilité de la topologie de stockage ;

  • accroissement de la possibilité de récupération de la topologie de stockage ;

  • gestion optimale du lecteur E/S.

Si vous avez moins de quatre groupes de stockage et plus de quatre banques de boîtes aux lettres sur un serveur exécutant Exchange Server 2003 Édition Entreprise, respectez la procédure suivante pour répartir vos boîtes aux lettres sur le plus de groupes de stockage possibles.

Pour corriger cette erreur

  1. Dans le Gestionnaire système Exchange, sélectionnez le serveur qui a rapporté cette erreur. Notez le nombre de groupes de stockage et de banques de boîtes aux lettres présents sur ce serveur. Notez les groupes de stockage qui contiennent plus d'une banque de boîtes aux lettres.

  2. Créez des groupes de stockage supplémentaires jusqu'à avoir quatre groupes de stockage sur l'ordinateur exécutant Exchange Server 2003 Édition Entreprise. Pour plus d'informations sur la création d'un nouveau groupe de stockage, voir la rubrique sur l'ajout d'un groupe de stockage dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  3. Créez une nouvelle banque de boîtes aux lettres dans chaque nouveau groupe de stockage que vous avez créé. Pour plus d'informations sur la création d'une nouvelle banque de boîtes aux lettres, voir la rubrique sur l'ajout d'une banque de boîtes aux lettres dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).

  4. Déplacez les boîtes aux lettres d'une banque de boîtes aux lettres d'un groupe de stockage qui contient plusieurs banques de boîtes aux lettres vers une banque de boîtes aux lettres située dans un groupe de stockage nouvellement créé. Utilisez l'Assistant Déplacer une boîte aux lettres pour déplacer des boîtes aux lettres. Pour plus de détails sur l'utilisation de l'Assistant Déplacer une boîte aux lettres, voir la section sur l'utilisation de l'Assistant Tâches Exchange pour déplacer des boîtes aux lettres dans le chapitre sur la migration d'Exchange Server 5.5 vers Exchange Server 2003 du Guide de déploiement de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47569).

Pour plus d'informations sur la configuration des groupes de stockage dans Exchange Server 2003, voir l'article 890699 de la Base de connaissances Microsoft sur la procédure de configuration des groupes de stockage dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699).

Pour plus d'informations sur la configuration des groupes de stockage, voir la section sur la configuration des groupes de stockage du chapitre sur la planification d'une solution de stockage principale fiable du Guide sur la disponibilité élevée Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47571).

Pour des recommandations générales pour vous aider à optimiser la disponibilité, la tolérance des pannes et les performances, voir le document sur l'optimisation du stockage pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49324).


Incohérence de signature entre la base de données et le fichier de transmission en continu
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé une incohérence de signature entre votre fichier de base de données Exchange (.edb) et son fichier de base de données de transmission en continu Exchange correspondant (.stm).

Chaque base de données dans Exchange 2000 Server et Exchange Server 2003 comprend deux fichiers : le fichier MAPI de base de données .edb et le fichier de base de données de transmission en continu .stm. Les paires de fichiers correspondantes partagent une signature de base de données commune. Si la signature de base de données ne correspond pas, les fichiers ne correspondent pas.

Vous devez considérer les fichiers .edb et .stm comme un seul et même fichier. Il faut toujours les déplacer ou les copier ensemble.

Pour corriger cette erreur

  • Examinez l'historique des fichiers de base de données. Il est probable que des fichiers aient été copiés, déplacés ou supprimés manuellement. Vous devez résoudre ce problème avant de pouvoir récupérer la base de données.

  • Si vous ne parvenez pas à trouver les fichiers .edb et .stm correspondants, vous pouvez utiliser Eseutil.exe pour réparer uniquement le fichier.edb et utiliser Eseutil avec le commutateur /createstm pour ignorer le fichier .stm. Cette méthode entraîne la perte de toutes les informations comprises dans la base de données de transmission en continu.

    Remarque :
    Si tous les utilisateurs de la base de données se connectent à celle-ci à l'aide d'un client MAPI tel que Microsoft Office Outlook®, les informations stockées dans la base de données de transmission en continu sont minimes. Si des utilisateurs se connectent à la base de données à l'aide des clients POP3, IMAP ou Outlook Web Access, la base de données de transmission en continu contient une partie ou l'ensemble du contenu de la boîte aux lettres de l'utilisateur.

Pour plus d'informations sur la procédure de réparation d'une base de données Exchange, voir l'article 812357 de la Base de connaissances Microsoft sur la procédure de conservation de votre base de données Exchange après une réparation à l'aide de l'outil Eseutil /p dans Exchange Server 5.5, Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357).


L'adresse SMTP n'est pas définie dans la stratégie de destinataire par défaut
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-12-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'adresse SMTP est spécifiée dans l'attribut gatewayProxy de la stratégie de destinataire par défaut de votre organisation Exchange Server. Si Exchange Server Analyzer détecte que l'attribut gatewayProxy ne contient pas d'adresse SMTP, il affiche un message d'erreur.

Il s'agit d'une erreur critique. Vous devez ajouter l'adresse SMTP, telle que SMTP:@contoso.com, à l'attribut gatewayProxy de la stratégie de destinataire par défaut dans votre organisation Exchange Server. La stratégie de destinataire par défaut doit contenir une adresse SMTP. Si ce n'est pas le cas, le service de banque d'informations de Microsoft Exchange ne s'initialisera pas après le redémarrage. Ce problème se produira sur tous les serveurs Exchange de votre organisation Exchange Server la prochaine fois que le service de banque d'informations de Microsoft Exchange est redémarré.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou d'Exchange Server 2007, ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour ajouter l'adresse SMTP à l'attribut gatewayProxy de la stratégie de destinataire par défaut

  1. Lancez l'outil ADSI Edit à partir des outils de support de Microsoft Windows® 2000 ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Stratégies de destinataire

  3. Dans le volet Détails, cliquez avec le bouton droit sur CN=Stratégie_par_défaut, puis cliquez sur Propriétés.

  4. Dans la zone Attributs, double-cliquez sur gatewayProxy.

  5. Dans la boîte de dialogue Éditeur de chaînes à valeurs multiples, entrez SMTP:@nom_domaine.com dans le champ Valeur à ajouter et cliquez sur Ajouter.

    Remarque :
    La syntaxe de ce que vous entrez est importante. Vous devez commencer par SMTP:@ avant d'entrer le nom de domaine de l'organisation Exchange Server. Cette chaîne ne contient aucun espace.

  6. Cliquez sur OK, puis sur Appliquer et fermez ADSI Edit.

  7. Attendez au moins 15 minutes pour la réplication.


Les valeurs des paramètres du Registre Prorate RPC de la banque ne sont pas correctement définies
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit trois clés de Registre pour déterminer si elles ont été modifiées par rapport à leurs valeurs par défaut. Les trois clés sont des valeurs DWORD qui se trouvent à l'emplacement suivant :

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

Les noms et les valeurs par défaut des clés sont les suivants :

Valeur DWORD Valeur décimale par défaut
  • ProrateStart
  • 40
  • ProrateMax
  • 10,000
  • ProrateFactor
  • 100

Si Exchange Server Analyzer détecte qu'une des valeurs par défaut ci-dessus a été modifiée, un message indiquant une configuration autre que celle par défaut s'affiche.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir les valeurs par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

  3. Dans le volet droit, double-cliquez sur l'entrée dont la valeur a été modifiée et configurez-la pour sa valeur par défaut.

  4. Répétez l'étape 3 si plusieurs valeurs ont été modifiées.

  5. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les threads des processus store, voir l'article 267255 de la Base de connaissances sur les threads Store.exe qui utilisent la mémoire disponible (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255).


Répertoire de travail de la banque manquant ou incorrect
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-30

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour vérifier le répertoire de travail du service Banque d'informations Microsoft Exchange.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

Exchange Server Analyzer affiche un avertissement si les conditions suivantes existent :

  • Le répertoire spécifié comme répertoire de travail n'existe pas.

  • Vous exécutez Exchange 2000 Server, Exchange Server 2003 ou Exchange Server 2007.

Exchange Server utilise le répertoire de travail pour le stockage temporaire. Exchange Server utilise par exemple le répertoire de travail lors du processus de conversion des messages. Exchange Server utilise également le répertoire de travail pour stocker une base de données temporaire lors de la défragmentation. Si le répertoire de travail n'est pas correctement spécifié, les problèmes suivants peuvent survenir :

  • Les messages avec des pièces jointes peuvent constituer une file d'attente de remise locale dans SMTP.

  • Les messages peuvent être reçus sans pièce jointe.

  • Il se peut que les messages ne soient pas remis correctement.

Par défaut, Exchange 2000 Server et Exchange Server 2003 définissent le répertoire mdbdata comme répertoire de travail sous le répertoire d'installation d'Exchange Server. Par exemple, si vous installez Exchange Server dans le répertoire C:\Program Files\Exchsrvr, Exchange Server définit C:\Program Files\Exchsrvr\mdbdata comme répertoire de travail.

Par défaut, Exchange Server 2007 définit le répertoire de base de données de boîtes aux lettres comme répertoire de travail sous le répertoire d'installation d'Exchange Server. Par exemple, si vous installez Exchange Server dans le répertoire C:\Program Files\Exchange Server, Exchange Server 2007 définit C:\ Program Files\Exchange Server\Mailbox\MDBTemp comme répertoire de travail.

Pour supprimer cet avertissement, définissez comme répertoire de travail un répertoire existant sur votre serveur Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Spécification du répertoire de travail à l'aide de regedit

  1. Lancez un Éditeur du Registre (regedit).

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Mettez à jour la valeur de Registre Working Directory à l'aide du répertoire de travail adéquat pour le service Banque d'informations Microsoft Exchange, par exemple C:\Program Files\Exchsrvr\mdbdata.

    Remarque :
    Cette modification ne nécessite pas de redémarrage du service Banque d'informations Microsoft Exchange.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre Working Directory, consultez l'article 298415 de la Base de connaissances sur les messages avec pièces jointes qui ne sont pas remis comme prévu et les messages d'ID d'événement 12003 et 327 qui sont consignés dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?Linkid=3052&kbid=298415).


La suppression des messages Absent du bureau des listes de distribution a été définie
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-02-27

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si des messages de notification d'absence du bureau sont en cours de suppression des listes de distribution :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

Si Exchange Server Analyzer détecte que la valeur de SuppressOOFsToDistributionLists est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Lorsqu'un message est envoyé à une boîte aux lettres dont le Gestionnaire d'absence du bureau est activé, l'expéditeur reçoit un message sans adresse indiquée dans le champ À ou Cc, mais avec une liste de distribution dans le champ Cci et un message de notification d'absence du bureau est envoyé à la liste de distribution figurant dans le champ Cci.

Si un message est envoyé à un destinataire, si l'adresse du destinataire n'est indiquée que dans le champ Cci et pas dans une liste de distribution et si le destinataire a activé le Gestionnaire d'absence du bureau, la banque de boîtes aux lettres du destinataire enverra un message de notification d'absence du bureau même si la valeur de Registre SuppressOOFsToDistributionLists est définie. Cette limitation ne s'applique que si l'adresse du destinataire est indiquée dans le champ Cci et que les champs À et Cc sont vierges. Si au moins un utilisateur est indiqué dans le champ À ou Cc, le paramètre de Registre sur l'ordinateur Exchange Server empêche les destinataires répertoriés dans le champ Cci de générer une notification d'absence du bureau.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Modification du comportement de génération de message de notification d'absence du bureau

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Cliquez avec le bouton droit sur ParametersSystem, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Nommez la nouvelle valeur SuppressOOFsToDistributionLists.

  5. Cliquez avec le bouton droit sur SuppressOOFsToDistributionLists, puis cliquez sur Modifier.

  6. Dans la zone Données de la valeur, entrez 1, puis cliquez sur OK.

  7. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre SuppressOOFsToDistributionLists, consultez l'article 825370 de la Base de connaissances sur l'envoi des notifications d'absence du bureau aux listes de distribution figurant dans le champ Cci (http://go.microsoft.com/fwlink/?lin k id=3052 & kbid=825370).


La valeur seuil qui contrôle le nombre de fois qu'un message endommagé est autorisé à passer par la banque d'informations a été modifiée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-08

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de PoisonThreshold :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<Nom_serveur_Exchange> \Private- <GUID_banque_informations_privée>

Si Exchange Server Analyzer détermine que la valeur de PoisonThreshold n'est pas égale à 2, un message indiquant une configuration autre que celle par défaut s'affiche.

Les versions d'Exchange Server postérieure à Exchange Server 2003 Service Pack 1 introduisent un comportement qui contribue à éviter que des messages endommagés ou incorrects provoquent l'arrêt inopiné du service Banque d'informations Microsoft Exchange ou la réussite de son démarrage.

Dans Exchange Server 2003 Service Pack 1 ou des versions ultérieures, les messages qui provoquent l'arrêt inattendu du service Banque d'informations Microsoft Exchange pendant la conversion du format MAPI au format MIME sont suivis. L'ID du message endommagé est stocké dans le Registre lorsque l'incident se produit. Si un message endommagé provoque trois fois l'arrêt inopiné de la banque d'informations, ces informations sont exploitées pour éviter que le message soit à nouveau traité au quatrième redémarrage du service Banque d'informations Microsoft Exchange.

Lorsque le service Banque d'informations Microsoft Exchange s'arrête inopinément à cause d'un message endommagé, la valeur de Registre PoisonIDs est créée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<Nom_serveur_Exchange> \Private- <GUID_banque_informations_privée>

Un administrateur peut également créer l'entrée de Registre PoisonThreshold. La clé PoisonThreshold contrôle le nombre maximal de fois qu'un message est autorisé à passer par la banque d'informations Exchange avant d'être ajouté à la clé de Registre PoisonIDs. Cette valeur seuil est 2 par défaut. Pour déclencher le comportement, le seuil doit être dépassé. Le service Banque d'informations Microsoft Exchange peut donc s'arrêter 3 fois à cause d'un message endommagé avant que celui-ci soit bloqué. Par exemple, si un message entraîne 3 incidents, il est bloqué parce que trois est supérieur à la valeur seuil 2.

Lorsqu'un événement de message endommagé est écrit dans le Registre, des messages d'événement d'erreur (ID d'événement 9680 et 9681) apparaissent dans le journal des événements Applications. Après le démarrage correct du service Banque d'informations Microsoft Exchange, Exchange bloque le message et tente d'envoyer une notification d'échec de remise pour celui-ci. Dans certains cas, Exchange peut ne pas parvenir à envoyer de notification d'échec de remise. Le message bloqué peut alors rester dans la file d'attente jusqu'à ce qu'il expire. La clé de Registre PoisonIDs stocke un maximum de dix valeurs ID de message. En cas de dépassement de la limite de dix, un nouvel événement de message endommagé est ajouté. L'événement de message endommagé le plus ancien est supprimé.

Remarque :
Les procédures de dépannage liées aux différents messages endommagés sortent du cadre d'Exchange Server Analyzer. Dans certains cas, les services de support technique Microsoft peuvent être en mesure de vous aider à résoudre les problèmes liés à des messages endommagés spécifiques. Si vous rencontrez des problèmes d'arrêt d'Exchange Server 2003 ou des arrêts ultérieurs à cause de messages endommagés, il peut s'avérer utile d'activer le rapport d'erreurs automatique sur l'ordinateur Exchange Server. Les données des rapports d'erreurs sont exploitées pour corriger les problèmes dans les logiciels que vous utilisez. Pour plus d'informations sur l'activation du rapport d'erreurs Exchange, consultez l'article Le rapport d'erreurs Exchange est désactivé

Il est recommandé de rétablir la valeur par défaut de 2 de PoisonThreshold.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Correction de cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nom_serveur_Exchange>\Private-<GUID_banque_informations_privée>

  3. Dans le volet droit, double-cliquez sur PoisonThreshold.

  4. Dans la zone Données de la valeur, entrez 2 (décimal) et cliquez sur OK.

  5. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le suivi a été activé sur le processus store
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool vérifie dans le Registre si l'entrée Enable Tracing existe avec la valeur de Registre Trace User LegacyDN. Ces deux valeurs de Registre sont présentes sous la clé de Registre suivante :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que les deux entrées de Registre sont présentes et configurées, un avertissement s'affiche.

La valeur de Registre DWORD Enable Tracing active le suivi de la banque d'informations de Microsoft Exchange. Le suivi permet de dépanner les problèmes de démarrage de la banque d'informations d'Exchange et peut affecter sérieusement les performances. Si vous ne résolvez pas de problème, n'utilisez pas ce paramètre de Registre. Le suivi peut être activé pour des utilisateurs spécifiques (suivi filtré) en cas d'ajout de la valeur de chaîne de Registre Trace User LegacyDN. Si la valeur Trace User LegacyDN n'est pas présente, le suivi est activé pour tous les utilisateurs. Si la valeur Trace User LegacyDN est présente, le suivi est assuré pour les utilisateurs spécifiques répertoriés sous cette clé.

Si le dépannage n'est pas effectué sur l'ordinateur Exchange Server, ces valeurs de Registre ne doivent pas être présentes.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez les valeurs de Registre Enable Tracing et Trace User LegacyDN.

  4. Fermez l'Éditeur du Registre et redémarrez l'ordinateur pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le suivi par utilisateur sur un serveur Exchange, voir l'article de la Base de connaissances sur la fonctionnalité de suivi par utilisateur ajoutée à Exchange 2000 Server Service Pack 2 (SP2) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


Le suivi a été désactivé pour tous les utilisateurs du service de banque d'informations de Microsoft Exchange
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit le Registre pour déterminer si l'entrée Enable Tracing est présente sous

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Si Exchange Server Analyzer détecte que la valeur de Registre Enable Tracing est présente et configurée, un avertissement s'affiche.

La valeur de Registre DWORD Enable Tracing active le suivi du service Banque d'informations Microsoft Exchange. Le suivi permet de dépanner les problèmes de démarrage de la banque d'informations et peut affecter sérieusement les performances. Ce paramètre de Registre ne doit pas être utilisé sauf si vous résolvez un problème. Le suivi peut être activé pour des utilisateurs spécifiques en cas d'ajout de la valeur de chaîne de Registre Trace User LegacyDN. Si cette valeur n'est pas présente, cela signifie que le traçage est activé pour tous les utilisateurs.

Si le dépannage n'est pas effectué sur l'ordinateur Exchange Server, cette valeur ne doit pas être présente.

Remarque :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Correction de cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Supprimez la valeur de Registre Enable Tracing.

  4. Fermez l'Éditeur du Registre et redémarrez le service Banque d'informations Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le suivi par utilisateur sur un serveur Exchange, consultez l'article de la Base de connaissances sur la fonctionnalité de suivi par utilisateur ajoutée à Exchange 2000 Server Service Pack 2 (SP2) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624).


Noms de fichier des journaux de transactions manquants
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool vérifie l'état des fichiers des journaux de transactions pour chaque groupe de stockage en consultant les fichiers journaux sur le disque du serveur. Pour trouver l'emplacement des fichiers journaux, Exchange Server Analyzer interroge le service d'annuaire Active Directory®. Pour chaque objet du groupe de stockage (classe msExchStorageGroup), le chemin d'accès aux fichiers journaux est enregistré dans l'attribut msExchESEParamLogFilePath.

Les noms de fichier des journaux de transactions incluent des nombres hexadécimaux séquentiels qui identifient la séquence des fichiers journaux. Par exemple, le premier fichier journal du Premier groupe de stockage par défaut s'appelle E0000001.log, le deuxième E0000002.log, etc. La valeur de la séquence peut être aussi élevée qu'E00FFFFF.log. Exchange peut créer jusqu'à 1 030 000 fichiers journaux uniques. Toutefois, lorsqu'Exchange atteint la fin de la séquence, les banques du groupe de stockage affecté ne se montent plus si elles sont démontées une fois la limite atteinte. Si elles sont laissées montées, les banques ne démonteront pas les bases de données même si aucune opération Jet ne peut avoir lieu. En principe, Exchange peut être exécuté pendant plusieurs années avant d'atteindre cette limite.

Ce message s'affichera comme un avertissement si le serveur spécifié a utilisé plus de 950 000 fichiers des journaux de transactions.

Ce message s'affichera comme une erreur si le serveur spécifié a utilisé plus de 1 020 000 fichiers des journaux de transactions.

Pour que les banques puissent démonter correctement les bases de données en cas d'atteinte de cette limite, un correctif a été inclus dans Exchange Server 2003 Service Pack 1. Un correctif post-Service Pack 3 est disponible pour Exchange 2000 Server, comme décrit dans l'article 830408 de la Base de connaissances Microsoft sur les banques de bases de données Exchange qui restent montées bien que tous les journaux de transactions qui sont disponibles pour un groupe de stockage aient été utilisés (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408).

Si Exchange n'a pas encore atteint la limite de 1 030 000 journaux de transactions, effectuez une sauvegarde en ligne complète du serveur dès que possible. Pour plus d'informations sur la réalisation d'une sauvegarde en ligne complète des banques Exchange, voir le Guide des opérations de récupération d'urgence de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47570).

Si Exchange a atteint cette limite, vous devez déplacer tous les journaux de transactions existants. Après cette opération, une nouvelle séquence de fichiers journaux commençant par 0x00001 sera générée. Pour être sûr que la banque Exchange démontera les bases de données correctement, vous devez également appliquer le correctif approprié pour votre version d'Exchange.

Remarque :
Avant de déplacer les journaux des transactions, vous devez vérifier que l'état de toutes les bases de données du groupe de stockage correspond à celui qui résulte d'un arrêt correct.
Important :
Une fois la procédure ci-dessous effectuée, toutes les sauvegardes précédentes devront être invalidées. Cela ne signifie pas pour autant que ces dernières ne peuvent pas être restaurées. Elles ne peuvent toutefois plus être transmises avec d'autres journaux des transactions. Si vous devez restaurer une sauvegarde après la suppression des journaux des transactions, vous ne pourrez restaurer que les données postérieures à la génération des nouveaux journaux.

Pour résoudre ce problème

  1. Pour Exchange Server 2003, installez le Service Pack 1, disponible sur le site Web des téléchargements d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=29090).

    -ou-

    Pour Exchange 2000 Server, procurez-vous et installez le correctif mentionné dans l'article 830408 de la Base de connaissances Microsoft sur les banques de bases de données Exchange qui restent montées bien que tous les journaux de transactions qui sont disponibles pour un groupe de stockage aient été utilisés (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408).

  2. Dans le groupe de stockage qui n'a plus de fichiers de journaux de transactions, démontez toutes les bases de données. Pour ce faire, effectuez la procédure suivante :

    1. Ouvrez le Gestionnaire système Exchange.

    2. Développez Groupes d'administration, <Nom_groupe_administration>, Serveurs, <Nom_serveur>, puis <Nom_groupe_stockage>.

    3. Cliquez avec le bouton droit sur la première banque de ce groupe de stockage et cliquez sur Démonter la banque d'informations. Répétez cette étape pour chaque banque de ce groupe.

  3. Vérifiez que l'état de chaque base de données du groupe de stockage correspond à celui qui résulte d'un arrêt correct. Pour ce faire, effectuez la procédure suivante :

    1. Dans le Gestionnaire système Exchange, cliquez avec le bouton droit sur la première banque du groupe de stockage qui n'a plus de fichiers de journaux de transactions et cliquez sur Propriétés.

    2. Cliquez sur l'onglet Base de données, puis notez les chemins d'accès et les noms des fichiers de la base de données dans la zone de la base de données Exchange et dans celle de la base de données de transmission en continu Exchange. Chaque base de données Exchange comprend un lot croisé de fichiers dont les extensions de nom de fichier sont .edb et .stm. Répétez cette étape pour chaque banque du groupe de stockage.

    3. À l'invite de commandes, modifiez le répertoire en dossier bin d'Exchange Server. Par exemple, modifiez le répertoire en C:\Program Files\Exchsrvr\bin.

    4. Entrez Eseutil /mh DatabaseFileName, puis appuyez sur ENTRÉE. Répétez cette étape pour chaque base de données du groupe de stockage. Cette commande affiche l'en-tête des fichiers de la base de données. L'en-tête contient l'une des deux lignes suivantes : État : Arrêt correct ou État : Arrêt intempestif.

  4. Si l'en-tête contient la ligne État : Arrêt intempestif, vous devez récupérer manuellement la base de données avant de supprimer les fichiers journaux. Pour ce faire, effectuez la procédure suivante :

    1. Dans le Gestionnaire système Exchange, cliquez avec le bouton droit sur le groupe de stockage qui n'a plus de fichiers de journaux de transactions et cliquez sur Propriétés.

    2. Cliquez sur l'onglet Général, puis notez les chemins d'accès des journaux des transactions dans la zone d'emplacement correspondante.

    3. Notez le chemin d'accès du fichier de point de contrôle dans la zone d'emplacement du chemin d'accès système.

    4. À l'invite de commandes, modifiez le répertoire en dossier bin d'Exchange Server.

    5. Entrez la commande suivante et appuyez sur Entrée : Eseutil /r 3-CharacterLogfileBaseName /lDirectory:\LogfilePath /sDirectory:\CheckpointFilePath.

      Remarque :
      N'entrez pas d'espace entre le commutateur d'option et les chemins d'accès des répertoires. En cas d'erreur typographique dans les chemins d'accès de la commande, la récupération peut échouer. Pour éviter cela, vous pouvez copier le fichier de point de contrôle dans le dossier des fichiers des journaux des transactions. À l'invite de commandes par défaut du répertoire des fichiers journaux, exécutez la commande Eseutil /r 3-CharacterLogfileBaseName. Les commutateurs /l et /s étant définis par défaut dans le répertoire en cours, il est inutile de fournir les chemins d'accès des fichiers journaux ou ceux des fichiers de point de contrôle.
    6. Une fois la récupération terminée, vérifiez tous les fichiers de base de données présentent bien un état d'arrêt correct avant de déplacer les fichiers des journaux des transactions et des fichiers de point de contrôle. Si vous déplacez les fichiers journaux alors qu'une base de données présente un état d'arrêt intempestif, vous ne pourrez pas redémarrer la base de données. Si vous ne parvenez pas à rétablir toutes les bases de données dans un état d'arrêt correct, contactez les services du Support Technique de Microsoft pour plus d'informations.

  5. Dans le Gestionnaire système Exchange, cliquez avec le bouton droit sur le groupe de stockage qui n'a plus de fichiers de journaux de transactions et cliquez sur Propriétés.

  6. Cliquez sur l'onglet Général, puis notez les chemins d'accès des journaux des transactions dans la zone Emplacement du journal des transactions.

  7. Notez le chemin d'accès du fichier de point de contrôle dans la zone Emplacement du chemin d'accès système.

  8. Déplacez les fichiers des journaux des transactions et le fichier de point de contrôle. L'extension du nom des fichiers journaux est .log et celle des fichiers de point de contrôle est .chk.

  9. Dans le Gestionnaire système Exchange, cliquez avec le bouton droit sur la première banque démontée du groupe de stockage et cliquez sur Monter la banque d'informations.

  10. Répétez cette étape pour chaque banque du groupe de stockage. La séquence des fichiers journaux est désormais réinitialisée dans le groupe de stockage.

  11. Procédez à une sauvegarde complète de toutes les bases de données du groupe de stockage.

Pour plus d'informations sur les Service Packs d'Exchange Server, voir le site Web sur Exchange Server (http://go.microsoft.com/fwlink/?LinkId=21573).


La taille du plus grand bloc de mémoire virtuelle est peu élevée
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeIS_MSExchangeIS pour déterminer la valeur de la clé VMLargestBlockSize. La clé VMLargestBlockSize représente la taille (en octets) du plus grand bloc de mémoire virtuelle disponible.

En outre, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détecte que la valeur de VMLargestBlockSize est supérieure à 50000000 mais inférieure à 150000000 sur un ordinateur Exchange Server avec plus de 20 boîtes aux lettres, un avertissement s'affiche.

Entre autres, Exchange Server utilise la mémoire virtuelle pour stocker les messages lorsque vous les convertissez aux formats MIME et MAPI et en tant que tampon pour l'assignation de messages à partir du journal de transactions et vers la banque. Ces opérations exigent régulièrement de larges blocs contigus de mémoire virtuelle pour s'effectuer rapidement et efficacement. Si cet avertissement s'affiche, la mémoire virtuelle de l'ordinateur Exchange est épuisée et inférieure à 150 Mo d'espace contigu. Ce processus est qualifié de fragmentation de la mémoire virtuelle.

Si la mémoire virtuelle est épuisée, vous pouvez voir apparaître des messages d'erreur dans le journal des événements (ID d'événement 9582), indiquant des erreurs de la mémoire virtuelle. Si la mémoire virtuelle est suffisamment faible, l'ID d'événement 12800 s'affiche, indiquant que les messages ne sont pas remis en raison d'une quantité de mémoire insuffisante pour traiter les messages.

Pour supprimer cet avertissement, suivez ces recommandations dans l'ordre dans lequel elles sont présentées.

Recherchez l'erreur « Taille maximale du cache ESE augmentée » dans les résultats d'Exchange Server Analyzer.

Si l'erreur Taille maximale du cache ESE augmentée est renvoyée sur l'ordinateur Exchange sur lequel l'avertissement de fragmentation de la mémoire virtuelle s'est affiché, suivez les recommandations de l'article La taille maximale du cache ESE est définie sur une valeur trop élevée

Le couplage de ces deux messages indique probablement que les problèmes de fragmentation de la mémoire virtuelle résultent de l'augmentation manuelle du cache ESE

Redémarrez le service de banque d'informations de Microsoft Exchange

Dans la description de ce message d'erreur, Exchange Server Analyzer spécifie le nombre de jours d'utilisation du service de banque d'informations de Microsoft Exchange. Si le nombre de jours spécifié est supérieur à 30, redémarrez le service.

Pour redémarrer le service de banque d'informations de Microsoft Exchange

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur Microsoft Exchange - Banque d'informations, puis cliquez sur Redémarrer.

Évaluez les tailles limites des messages

Si un grand nombre d'utilisateurs envoient des messages volumineux (plus de 30 Mo), la mémoire virtuelle risque d'être fragmentée plus tôt que si ces utilisateurs n'envoient pas de messages volumineux. Comme mentionné, la mémoire virtuelle est utilisée comme tampon lorsque le processus store déplace des données des fichiers journaux et les assigne à la banque. Si les données déplacées sont volumineuses, de larges blocs contigus de mémoire virtuelle sont rapidement utilisés.

Si des données volumineuses sont régulièrement envoyées par courrier électronique et si des données sont envoyées en interne, configurez des répertoires partagés sur les serveurs de fichiers où les utilisateurs peuvent publier des données volumineuses.

Il est recommandé de définir la taille limite des messages sur une valeur inférieure à 30 Mo. Toutefois, si vous avez besoin d'une taille limite plus élevée pour les messages contenant des pièces jointes à envoyer dans votre organisation Exchange, vous souhaiterez peut-être augmenter la taille limite des messages sortants à plus de 30 Mo. Outre la fragmentation de la mémoire virtuelle, l'augmentation de la taille limite des messages à plus de 30 Mo peut rendre votre système plus vulnérable aux attaques nuisibles. Il est recommandé de ne pas définir la taille limite des messages sur plus de 30 Mo.

Pour définir des tailles limites des messages

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Sending message size limit (Taille limite des messages sortants) et entrez la taille limite souhaitée.

Vérifiez que le logiciel antivirus est actualisé

L'utilisation d'un logiciel antivirus obsolète en mode API d'analyse antivirus Exchange (VSAPI) peut parfois provoquer la fragmentation de la mémoire virtuelle. Si vous exécutez un logiciel antivirus en mode VSAPI, contactez votre fournisseur d'antivirus et vérifiez que vous utilisez la dernière version du logiciel et des pilotes.

Déplacez les boîtes aux lettres vers un autre serveur Exchange

Si vous avez effectué toute la procédure et si Exchange Server Analyzer affiche toujours cet avertissement, vous devez déplacer les boîtes aux lettres du serveur concerné pour réduire sa charge. Ce serveur compte trop de boîtes aux lettres.

Pour déplacer des boîtes aux lettres dans Exchange 2000 Server et Exchange Server 2003

  1. Dans Utilisateurs et ordinateurs Active Directory, sélectionnez le ou les utilisateurs dont vous souhaitez déplacer la boîte aux lettres.

  2. Cliquez avec le bouton droit sur la liste d'utilisateurs sélectionnés à l'étape précédente, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, sur la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.

Pour déplacer des boîtes aux lettres dans Exchange Server 2003

  1. Dans le Gestionnaire système Exchange, développez Serveurs, le serveur à partir duquel déplacer des boîtes aux lettres, le Groupe de stockage à partir duquel déplacer des boîtes aux lettres, la Banque de boîtes aux lettres contenant les boîtes aux lettres à déplacer, puis cliquez sur Boîtes aux lettres.

  2. Dans le volet Détails, cliquez avec le bouton droit sur le ou les utilisateurs dont vous souhaitez déplacer la boîte aux lettres, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, sur la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.

Pour plus d'informations sur la résolution des problèmes de fragmentation de la mémoire virtuelle, voir les articles suivants de la Base de connaissances Microsoft :

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 838233 sur le ralentissement, l'arrêt de votre ordinateur ou l'enregistrement à plusieurs reprises d'ID d'événement 9582 et 1160 dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233).

Pour plus de détails sur la définition des tailles limites des messages, voir l'article 322679 de la Base de connaissances sur la définition des tailles limites des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Pour plus d'informations sur le déplacement des boîtes aux lettres, voir les articles suivants de la Base de connaissances :

  • 328810 sur le déplacement de boîtes aux lettres entre serveurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810)

  • 821829 sur le déplacement de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829).


La taille du plus grand bloc de mémoire virtuelle a atteint la valeur maximale
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_MSExchangeIS_MSExchangeIS pour déterminer la valeur de la clé VMLargestBlockSize. La clé VMLargestBlockSize représente la taille (en octets) du plus grand bloc de mémoire virtuelle disponible.

En outre, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détecte que la valeur de VMLargestBlockSize est supérieure à 0 mais inférieure à 50000001 sur un ordinateur Exchange Server avec plus de 20 boîtes aux lettres, une erreur s'affiche.

Entre autres, le serveur Exchange utilise la mémoire virtuelle pour stocker les messages lors de leur conversion aux formats MIME et MAPI et en tant que tampon pour l'assignation de messages à partir du journal de transactions et vers la banque. Ces opérations exigent souvent de larges blocs contigus de mémoire virtuelle pour s'effectuer rapidement et efficacement. Si cette erreur s'affiche, la mémoire virtuelle de l'ordinateur Exchange est épuisée et inférieure à 50 Mo d'espace contigu. Ce processus est qualifié de fragmentation de la mémoire virtuelle. Un serveur de boîtes aux lettres Exchange exécuté avec moins de 50 Mo d'espace mémoire virtuelle contigu est une erreur critique.

Si la mémoire virtuelle est épuisée, vous pouvez voir apparaître des alertes dans le journal des événements (ID d'événement 9582), indiquant des erreurs de la mémoire virtuelle. Si la mémoire virtuelle est suffisamment faible, l'ID d'événement 12800 s'affiche, indiquant que les messages ne sont pas remis en raison d'une quantité de mémoire insuffisante pour traiter les messages.

Pour corriger cette erreur, suivez les recommandations ci-dessous dans l'ordre dans lequel elles sont présentées.

Recherchez l'erreur « Taille maximale du cache ESE augmentée » dans les résultats d'Exchange Server Analyzer.

Si l'erreur Taille maximale du cache ESE augmentée est renvoyée sur l'ordinateur Exchange sur lequel l'avertissement de fragmentation de la mémoire virtuelle s'est affiché, suivez les recommandations de l'article La taille maximale du cache ESE est définie sur une valeur trop élevée

Le couplage de ces deux alertes indique probablement que les problèmes de fragmentation de la mémoire virtuelle résultent de l'augmentation manuelle du cache ESE

Redémarrez le service de banque d'informations de Microsoft Exchange

Dans la description de cette alerte, Exchange Server Analyzer spécifie le nombre de jours d'utilisation du service de banque d'informations de Microsoft Exchange. Si le nombre de jours spécifié est supérieur à 30, redémarrez le service.

Pour redémarrer le service de banque d'informations d'Exchange

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur Microsoft Exchange - Banque d'informations, puis cliquez sur Redémarrer.

Évaluez les tailles limites des messages

Si un grand nombre d'utilisateurs envoient des messages volumineux (supérieurs à 30 Mo), la mémoire virtuelle risque d'être fragmentée plus tôt que si ces utilisateurs n'envoient pas de messages volumineux. Comme susmentionné, la mémoire virtuelle est utilisée comme tampon lorsque le processus store déplace des données des fichiers journaux et les assigne à la banque. Si les données déplacées sont volumineuses, de larges blocs contigus de mémoire virtuelle sont rapidement utilisés.

Si des données volumineuses sont régulièrement envoyées par courrier électronique et si des données sont envoyées en interne, configurez des répertoires partagés sur les serveurs de fichiers où les utilisateurs peuvent publier des données volumineuses.

Il est recommandé de définir la taille limite des messages sur une valeur inférieure à 30 Mo. Toutefois, si vous avez besoin d'une taille limite plus élevée pour les messages contenant des pièces jointes à envoyer dans votre organisation Exchange, vous souhaiterez peut-être augmenter la taille limite des messages sortants à plus de 30 Mo. Outre la fragmentation de la mémoire virtuelle, l'augmentation de la taille limite des messages à plus de 30 Mo peut rendre votre système plus vulnérable aux attaques nuisibles. Une taille limite des messages à plus de 30 Mo n'est donc pas recommandée.

Pour définir des tailles limites des messages

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Sending message size limit (Taille limite des messages sortants) et entrez la taille limite souhaitée.

Vérifiez que le logiciel antivirus est actualisé

Dans certains cas, l'utilisation d'un logiciel antivirus obsolète en mode API d'analyse antivirus Exchange (VSAPI) peut provoquer la fragmentation de la mémoire virtuelle. Si vous exécutez un logiciel antivirus en mode VSAPI, contactez votre fournisseur d'antivirus et vérifiez que vous utilisez la dernière version du logiciel et des pilotes.

Déplacez les boîtes aux lettres vers un autre serveur Exchange

Si vous avez effectué toutes les procédures ci-dessus et si Exchange Server Analyzer affiche toujours cette erreur ou la version de cette alerte (150 Mo maximum d'espace mémoire virtuelle contigu), vous devez déplacer les boîtes aux lettres du serveur concerné pour réduire sa charge. Ce serveur compte trop de boîtes aux lettres.

Pour déplacer des boîtes aux lettres dans Exchange 2000 Server et Exchange Server 2003

  1. Dans Utilisateurs et ordinateurs Active Directory, sélectionnez le ou les utilisateurs dont vous souhaitez déplacer la boîte aux lettres.

  2. Cliquez avec le bouton droit sur la liste d'utilisateurs sélectionnés à l'étape précédente, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, sur la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.

Pour déplacer des boîtes aux lettres dans Exchange Server 2003

  1. Dans le Gestionnaire système Exchange, développez Serveurs, le serveur à partir duquel déplacer des boîtes aux lettres, le Groupe de stockage à partir duquel déplacer des boîtes aux lettres, la Banque de boîtes aux lettres contenant les boîtes aux lettres à déplacer, puis cliquez sur Boîtes aux lettres.

  2. Dans le volet Détails, cliquez avec le bouton droit sur le ou les utilisateurs dont vous souhaitez déplacer la boîte aux lettres, puis cliquez sur Tâches Exchange.

  3. Dans l'Assistant Tâches Exchange, sur la page Tâches disponibles, cliquez sur Déplacer une boîte aux lettres, puis sur Suivant.

  4. Lisez et suivez attentivement les instructions de l'Assistant.

Pour plus d'informations sur la résolution des problèmes de fragmentation de la mémoire virtuelle, voir les articles suivants de la Base de connaissances Microsoft :

  • 325044 sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 838233 sur le ralentissement, l'arrêt de votre ordinateur ou l'enregistrement à plusieurs reprises d'ID d'événement 9582 et 1160 dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233).

Pour plus d'informations sur la définition des tailles limites des messages, voir l'article 322679 de la Base de connaissances sur la définition des tailles limites des messages dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Pour plus d'informations sur le déplacement des boîtes aux lettres, voir les articles suivants de la Base de connaissances :

  • 328810 sur le déplacement de boîtes aux lettres entre les serveurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810).

  • 821829 sur le déplacement de boîtes aux lettres dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829).


VirtualReserveSize is non-default
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si l'allocation de mémoire initiale du composant ExIPC (Exchange Interprocess Communication) a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

Si Exchange Server Analyzer détecte que la clé VirtualReserveSize est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Le composant de file d'attente ExIPC permet à Inetinfo.exe (services IIS) et à Store.exe (service de banque d'informations de Microsoft Exchange) de déplacer et replacer des données rapidement. En règle générale, l'allocation de mémoire initiale par défaut pour ExIPC suffit. Par défaut, la clé VirtualReserveSize n'est pas présente. Elle ne doit être ajoutée et configurée que sur recommandation de MCS (Microsoft Consulting Services) ou des services du Support Technique de Microsoft.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\EXIPC\Parameters

  3. Supprimez la clé VirtualReserveSize.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange et le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur ExIPC, voir les articles suivants de la Base de connaissances :

  • 821879 sur les définitions de composants de transport clés dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879)

  • 260995 sur les définitions de composants de transport clés dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995)


L'intervalle d'événement de mémoire virtuelle a été remplacé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le seuil d'enregistrement d'un événement concernant la fragmentation de mémoire virtuelle a été remplacé manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ VM Info Update Interval

Si Exchange Server Analyzer détecte que la valeur de Registre VM Info Update Interval est présente, mais différente de 3600, un message indiquant une configuration autre que celle par défaut s'affiche.

Dans les systèmes Microsoft Windows® 32 bits, il existe deux types de mémoire : la mémoire physique (quantité réelle de mémoire installée dans le système) et l'espace d'adressage mémoire virtuel (espace mémoire virtualisé de 4 Go). Quelle que soit la quantité de mémoire physique installée sur le système, la taille totale de l'espace d'adresse virtuelle est toujours identique : 4 Go. Bien que ce ne soit pas le cas pour toutes les applications 32 bits, pour Exchange Server, l'espace d'adresse virtuelle équivaut à la mémoire virtuelle ; en d'autres termes, l'un et l'autre sont interchangeables.

Lors du déroulement normal de ses opérations, le service de banque d'informations de Microsoft Exchange alloue, utilise et désalloue la mémoire virtuelle à plusieurs reprises. Si la mémoire virtuelle est fréquemment allouée, utilisée et désallouée, une fragmentation de mémoire virtuelle peut se produire. La fragmentation de mémoire virtuelle est similaire à la fragmentation de système de fichiers, qui peut se produire de temps à autre. Après un moment, les segments alloués de mémoire virtuelle ne sont plus contigus et les performances s'en ressentent. Pour le système de fichiers, vous pouvez exécuter une application qui procède à la défragmentation du système de fichiers, généralement même lorsque le système est en ligne et qu'un utilisateur y accède. Il n'existe aucun outil de défragmentation pour fragmenter la mémoire virtuelle ; pour remédier à ce problème, arrêtez et redémarrez plutôt le service de banque d'informations de Microsoft Exchange ou redémarrez le système.

Par défaut, le service de banque d'informations de Microsoft Exchange vérifie la mémoire virtuelle libre une fois par heure (par exemple, toutes les 3 600 secondes). La valeur de Registre VM Info Update Interval représente une opportunité de configuration permettant à un administrateur de remplacer l'intervalle par défaut de 3 600 secondes. Si vous remplacez le niveau par défaut, il est recommandé de ne pas définir de valeur inférieure à 5 minutes (300 secondes).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Dans le volet droit, supprimez la valeur de VM Info Update Interval.

  4. Fermez l'Éditeur du Registre et redémarrez le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Pour plus d'informations sur le dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server, voir l'article 325044 de la Base de connaissances Microsoft sur la procédure de dépannage de fragmentation de mémoire virtuelle dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044).


Cache en écriture différée non activé
Microsoft Exchange Server Analyzer - Articles > Stockage >

Dernière rubrique modifiée : 2006-08-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que votre contrôleur de baie de disques n'a pas de cache en écriture différée définie correctement pour les lecteurs qui hébergent les journaux de transactions.

Il est recommandé d'activer le cache en réécriture différée à 100 pour cent sur votre contrôleur de baie pour tous les lecteurs qui hébergent des journaux de transactions. Les lectures dans les journaux de transactions sont rares. Plus la vitesse d'écriture disponible pour le lecteur du journal de transactions est élevée, mieux un serveur exécutant Exchange Server fonctionne.

Correction de cet avertissement

  • Activez le cache en écriture différée.

Pour plus d'informations sur la procédure de configuration de disques durs de serveur Exchange, consultez l'article 188589 de la Base de connaissances Microsoft sur la base de données Exchange et les disques durs et contrôleurs de mise en cache (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589).


Logiciel tiers
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant le logiciel tiers. Ils décrivent, en outre, les actions possibles pour corriger les erreurs liées au logiciel tiers, les avertissements et configurations autres que celles par défaut détectés par Exchange Server Analyzer.


Les exclusions du dossier Antivirus n'ont pas été configurées
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si Symantec AntiVirus Corporate Edition (Symantec AV) est installé sur Exchange Server et si la fonction RTP (protection en temps réel) est activée :

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

Si Exchange Server Analyzer détecte que la valeur de Registre HaveExceptionDirs est définie sur 0, il affiche une erreur. Une valeur de Registre HaveExceptionDirs égale à 0 indique que les exclusions de dossiers sont désactivées.

Celles-ci empêchent l'analyse de dossiers spécifiques lors de l'analyse antivirus en temps réel. Si vous n'avez pas activé les exclusions de dossiers sur votre serveur Exchange, les problèmes suivants peuvent se produire :

  • La fonction de protection en temps réel de Symantec AV peut fournir des rapports positifs erronés sur certains fichiers nettoyés auxquels l'utilisateur a eu accès lors d'une activité de programme normale.

  • La fonction de protection en temps réel de Symantec AV peut signaler de manière inexacte des fichiers infectés dans le logiciel dont l'exécution sur votre serveur Exchange a déjà été autorisée par la stratégie de sécurité de votre société.

  • La fonction de protection en temps réel de Symantec AV peut analyser la structure d'annuaire d'Exchange Server et engendrer des détections de virus inappropriées, un comportement inattendu d'Exchange Server ou endommager les bases de données d'Exchange Server.

Important :
Vous ne devez jamais exécuter le logiciel d'analyse de fichiers sur des bases de données, des journaux, des fichiers temporaires Exchange Server, sur des fichiers système des services IIS (Internet Information Services) ni sur le lecteur IFS (Installable File System) (lecteur M). Configurez le logiciel antivirus de sorte que les dossiers contenant ces fichiers ne soient pas analysés.

Vous pouvez exécuter le logiciel antivirus de fichiers sur le système d'exploitation de l'ordinateur Exchange Server et sur les fichiers de programmes Exchange Server (dossier Exchsrvr\Bin). Toutefois, ne l'exécutez pas sur les dossiers et fichiers suivants :

  • Bases de données Exchange Server (fichiers .mdb et .stm) et fichiers du journal des transactions (.log) (emplacement par défaut : \Exchsrvr\MDBData)

  • Fichiers .mta Exchange Server (emplacement par défaut : \Exchsrvr\Mtadata)

  • Fichiers journaux de suivi des messages Exchange Server (emplacement par défaut : \Exchsrvr\Server_Name.log)

  • Dossiers du serveur virtuel (emplacement par défaut : \Exchsrvr\Mailroot)

  • Fichiers SRS (service de réplication de sites) (emplacement par défaut : \Exchsrvr\Srsdata)

  • Fichiers système des services IIS (Internet Information Service) (emplacement par défaut : \%SystemRoot%\System32\Inetsrv)

  • Fichiers du connecteur de courrier Internet (emplacement par défaut : \Exchsrvr\IMCData)

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier de travail se trouve à l'emplacement \Exchsrvr\MDBData.

  • Un dossier temporaire utilisé avec des utilitaires de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut des fichiers .exe, mais il peut être modifié lorsque vous exécutez l'utilitaire.

Vous pouvez exécuter l'analyse de fichiers sur les dossiers suivants :

  • Exchsrvr\Address

  • Exchsrvr\Bin

  • Exchsrvr\Exchweb

  • Exchsrvr\Res

  • Exchsrvr\Schema

Pour des informations détaillées sur la configuration des exclusions sur l'analyse en temps réel dans Symantec AntiVirus Corporate Edition, voir le site Web de Symantec Antivirus (http://www.symantec.com).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur la protection renforcée d'un environnement Exchange Server contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Antigen analyse les messages de réplication des dossiers publics
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-03-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si une banque de dossiers publics est présente sur chaque serveur Exchange. Si Exchange Server Analyzer détecte que l'objet Informations appartient à la classe d'objet mise, le serveur héberge une banque de dossiers publics.

Microsoft® Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour À.DLL. Une valeur de clé Version de 1517 ou supérieure pour À.DLL indique que S À pour Microsoft Exchange version 8.0 SR3 ou ultérieure est installé sur le serveur Exchange Server.

Enfin, Exchange Server Analyzer interroge la branche de Registre suivante pour déterminer si la clé DoNotScanIPMReplicationMessages est présente et si sa valeur n'est pas supérieure à 0 :

HKEY_LOCAL_MACHINE\Software\S Software\À for Exchange\DoNotScanIPMReplicationMessages

La valeur de la clé DoNotScanIPMReplicationMessages détermine si la version installée de S À analyse et supprime éventuellement les messages de réplication des dossiers publics d'Exchange Server. Une valeur inférieure à 1 pour la clé DoNotScanIPMReplicationMessages signifie qu'À analyse les fichiers winmail.dat et recherche les éventuels virus. Exchange Server utilise les fichiers Winmail.dat à différentes fins, notamment pour faciliter la réplication de dossiers publics entre des serveurs. Si À modifie un de ces fichiers Winmail.dat, le processus de réplication de dossiers publics échoue.

Si Exchange Server Analyzer détermine que toutes les conditions suivantes sont remplies, il affiche une erreur :

  • Exchange Server héberge une ou plusieurs banques de dossiers publics

  • La version 1517 de S À ou ultérieure est installée sur le serveur

  • La clé DoNotScanIPMReplicationMessages n'est pas présente ou est présente mais sa valeur n'est pas supérieure à 0.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\S Software\À for Exchange

  3. Si la sous-clé DoNotScanIPMReplicationMessages existe déjà dans le volet droit, double-cliquez sur celle-ci et définissez la valeur sur 1.

  4. Si la sous-clé DoNotScanIPMReplicationMessages n'existe pas encore, cliquez avec le bouton droit dans le volet droit pour la créer comme une nouvelle valeur DWORD.

  5. Configurez la valeur DoNotScanIPMReplicationMessages en la définissant sur 1.

    Remarque :
    Si un virus est répliqué par le biais de la réplication de dossiers publics, même si vous activez cette nouvelle clé de Registre, À détectera encore le virus lors de l'analyse en temps réel.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)


CA eTrust : Les fichiers EML/LOG/EDB/STM/DAT ne figurent pas dans la liste d'exclusion de fichiers en temps réel
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des extensions de fichier exclues de l'analyse antivirus en temps réel au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

Si Exchange Server Analyzer détecte que la valeur de szExcludeExtList n'inclut pas d'extension de fichier correspondant à un type de fichier de données Exchange (.eml, .log, .edb, .stm ou .dat), un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server, effectuez l'opération suivante :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • Plusieurs problèmes peuvent se produire si vous analysez le lecteur représenté par le système IFS Exchange, généralement le lecteur M, avec le logiciel de détection au niveau fichier

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lors du montage des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : Le lecteur de données Exchange n'a pas été exclu de l'analyse manuelle
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des répertoires qui ont été exclus de l'analyse antivirus manuelle au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer lit également la valeur de l'attribut MsExchESEParamSystemPath dans le service d'annuaire Active Directory® qui est un attribut du groupe de stockage correspondant à l'emplacement du fichier de données du système Exchange.

Si Exchange Server Analyzer détecte que la valeur de szExcludeDirs n'inclut pas le chemin correspondant à l'emplacement du fichier de données du système Exchange, un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • Plusieurs problèmes peuvent se produire si vous analysez le lecteur représenté par le système IFS Exchange, généralement le lecteur M, avec le logiciel de détection au niveau fichier

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lors du montage des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : le lecteur de données Exchange n'a pas été exclu de l'analyse en temps réel
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des répertoires exclus de l'analyse antivirus en temps réel au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut MsExchESEParamSystemPath de chaque groupe de stockage. Cet attribut représente le chemin d'accès des fichiers de données Exchange.

Si Exchange Server Analyzer détecte que la valeur de szExcludeDirs n'inclut pas le chemin correspondant à l'emplacement du fichier de données du système Exchange, un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • Plusieurs problèmes peuvent se produire si vous analysez le lecteur représenté par le système IFS Exchange, généralement le lecteur M, avec le logiciel de détection au niveau fichier

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lorsque vous montez des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : Le chemin d'accès Exchange IFS n'a pas été exclu de l'analyse manuelle
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des répertoires qui ont été exclus de l'analyse antivirus manuelle au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer lit également l'entrée de Registre suivante pour obtenir la lettre de lecteur qui représente le lecteur Exchange Installable File System (IFS) :

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

La lettre de lecteur par défaut sur Exchange 2000 Server est M. Le lecteur IFS est désactivé par défaut dans Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de szExcludeDirs n'inclut pas le chemin correspondant au lecteur IFS, un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server, effectuez l'opération suivante :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • D'autres problèmes peuvent se produire si vous analysez le lecteur représenté par l'IFS, généralement le lecteur M, avec le logiciel de détection au niveau fichier.

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lors du montage des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : le chemin IFS Exchange n'a pas été exclu de l'analyse en temps réel
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des répertoires qui ont été exclus de l'analyse antivirus en temps réel au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer lit également l'entrée de Registre suivante pour obtenir la lettre de lecteur qui représente le lecteur Exchange Installable File System (IFS) :

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

La lettre de lecteur par défaut sur Exchange 2000 Server est M. Par défaut, le lecteur IFS est désactivé dans Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de szExcludeDirs n'inclut pas le chemin correspondant au lecteur IFS, un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server, effectuez l'opération suivante :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • D'autres problèmes peuvent se produire si vous analysez le lecteur représenté par l'IFS, généralement le lecteur M, avec le logiciel de détection au niveau fichier.

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lors du montage des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : L'analyse en temps réel est configurée pour analyser tous les fichiers quelle que soit leur extension
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des extensions de nom de fichier exclues de l'analyse antivirus en temps réel au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

Si Exchange Server Analyzer détermine que la valeur de dwFileFilterType est configurée pour analyser tous les fichiers indépendamment de l'extension de nom de fichier, un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server, effectuez l'opération suivante :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants risquent de se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • Plusieurs problèmes peuvent se produire si vous analysez le lecteur représenté par le système IFS Exchange, généralement le lecteur M, avec le logiciel de détection au niveau fichier

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M .

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers indiqués de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lorsque vous montez des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : Le lecteur du groupe de stockage n'a pas été exclu de l'analyse manuelle
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des répertoires qui ont été exclus de l'analyse antivirus manuelle au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer lit également la valeur de l'attribut MsExchESEParamSystemPath dans le service d'annuaire Active Directory® qui est un attribut du groupe de stockage correspondant à l'emplacement du fichier journal du système Exchange.

Si Exchange Server Analyzer détecte que la valeur de szExcludeDirs n'inclut pas le chemin correspondant à l'emplacement du fichier journal du système Exchange, un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server, effectuez l'opération suivante :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • Plusieurs problèmes peuvent se produire si vous analysez le lecteur représenté par le système IFS Exchange, généralement le lecteur M, avec le logiciel de détection au niveau fichier

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

  • Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lors du montage des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : Le lecteur du groupe de stockage n'a pas été exclu de l'analyse en temps réel
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des répertoires exclus de l'analyse antivirus en temps réel au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer interroge également la valeur de l'attribut MsExchESEParamSystemPath dans le service d'annuaire Active Directory® qui est un attribut du groupe de stockage correspondant à l'emplacement du fichier de données du système Exchange.

Si Exchange Server Analyzer détecte que la valeur de szExcludeDirs n'inclut pas le chemin correspondant à l'emplacement du fichier de données du système Exchange, un avertissement s'affiche.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • Plusieurs problèmes peuvent se produire si vous analysez le lecteur représenté par le système IFS Exchange, généralement le lecteur M, avec le logiciel de détection au niveau fichier

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lors du montage des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


CA eTrust : le processus Exchange n'a pas été exclu de l'analyse en temps réel
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour obtenir la liste des processus qui ont été exclus de l'analyse antivirus en temps réel au niveau fichier dans eTrust Antivirus de Computer Associates :

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

Si Exchange Server Analyzer détecte que la valeur de szExcludeProcessNames n'inclut pas STORE.EXE, EMSMTA.EXE et MAD.EXE, un avertissement s'affiche.

Il est recommandé de ne pas analyser le processus de banque d'informations de Microsoft Exchange (Store.exe), le processus MTA Exchange (Emsmta.exe) ou le processus du service Surveillance du système (Mad.exe) à l'aide d'un analyseur antivirus au niveau fichier pendant que ces processus sont en cours d'exécution.

eTrust Antivirus est un programme d'analyse antivirus au niveau fichier. Pour déterminer la version d'eTrust Antivirus installée sur votre ordinateur Exchange Server, effectuez l'opération suivante :

  1. Naviguez jusqu'à Démarrer | Programmes | eTrust Antivirus, puis cliquez sur eTrust Antivirus pour démarrer l'application.

  2. Dans le menu d'application eTrust Antivirus, cliquez sur Help (Aide), puis sur About eTrust Antivirus (À propos d'eTrust Antivirus).

  3. Examinez le champ Product Version (Version du produit) pour déterminer la version d'eTrust Antivirus.

Les problèmes suivants peuvent se produire lorsque vous utilisez des analyseurs au niveau fichier sur un ordinateur Exchange Server :

  • Les analyseurs au niveau fichier analysent un fichier lorsqu'il est utilisé ou à un intervalle planifié et peuvent verrouiller ou mettre en quarantaine un fichier journal ou de base de données Exchange lorsqu'Exchange tente d'utiliser le fichier. Cela peut provoquer une erreur grave dans Exchange Server ou générer des erreurs de base de données.

  • D'autres problèmes peuvent se produire si vous analysez le lecteur représenté par l'IFS, généralement le lecteur M, avec le logiciel de détection au niveau fichier.

Quel que soit le programme antivirus au niveau fichier utilisé, vous devez toujours exclure les fichiers et dossiers suivants des analyseurs au niveau fichier :

  • Les fichiers .eml, .edb, .stm, .log, .dat et .chk.

  • Le lecteur Exchange Server représenté par l'IFS. Par défaut, le lecteur M.

  • Les bases de données et les fichiers journaux Exchange. Par défaut, ceux-ci se trouvent dans le dossier Exchsrvr\Mdbdata.

  • Les fichiers MTA Exchange du dossier Exchsrvr\Mtadata.

  • Les fichiers journaux supplémentaires tels que le fichier Exchsrvr\nom_serveur.log.

  • Le dossier de serveur virtuel Exchsrvr\Mailroot.

  • Le dossier de travail destiné à stocker les fichiers temporaires de transmission utilisés pendant la conversion des messages. Par défaut, ce dossier se trouve à l'emplacement \Exchsrvr\MDBData, mais vous pouvez modifier celui-ci.

  • Le dossier temporaire utilisé avec des outils de maintenance hors connexion tels qu'Eseutil.exe. Ce dossier est l'emplacement d'exécution par défaut du fichier .exe, mais il peut être modifié lorsque vous exécutez l'outil.

  • Les fichiers du service de réplication de sites (SRS) du dossier Exchsrvr\Srsdata.

  • Les fichiers système des services IIS (Microsoft Internet Information Service) du dossier %SystemRoot%\System32\Inetsrv.

  • Les fichiers de travail des services IIS du dossier %SystemRoot%\IIS Temporary Compressed Files.

Pour supprimer cet avertissement

  1. Utilisez l'interface utilisateur eTrust Antivirus pour exclure les dossiers et fichiers répertoriés ci-dessus de l'analyse antivirus au niveau fichier.

  2. Visitez le site Web eTrust Antivirus de Computer Associates (http://www3.ca.com/Solutions/Product.asp?ID=156) pour les informations les plus récentes sur l'utilisation d'eTrust Antivirus sur un ordinateur Exchange Server.

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).

Pour plus d'informations sur les problèmes qui peuvent se produire si vous analysez le lecteur IFS, voir les articles suivants de la Base de connaissances :

  • 298924 sur les problèmes provoqués par une sauvegarde ou par une analyse du lecteur M Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924)

  • 300608 sur l'affichage du message d'erreur C1041737 lors du montage des bases de données (http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608)

  • 299046 sur la disparition d'éléments du calendrier des dossiers des utilisateurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046)


Mise à jour Client Service Messaging Security for SMB 2.0 disponible
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante :

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Une valeur Version de 6,2100 indique que Trend Micro ScanMail Client Service Messaging Security for SMB 2.0 est installé.

Microsoft® Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la version de Client Service Messaging Security for SMB 2.0 qui est installée. Si le numéro de version principal est inférieur à 1145, Exchange Server Analyzer affiche un avertissement.

Cet avertissement indique que Client Server Messaging Security for SMB 2.0 est installé sur le serveur Exchange et qu'une mise à jour logicielle recommandée est disponible. La mise à jour recommandée est Client Server Messaging Security for SMB 2.0 Patch 2 for Messaging Component. Cette mise à jour est vivement recommandée et permet d'améliorer les performances et la fiabilité générales du serveur.

Pour supprimer cet avertissement

  1. Visitez le site Web Update Center for Client Server Messaging Security for SMB de Trend Micro (http://www.trendmicro.com/download/product.asp?productid=39).

  2. Téléchargez et installez le correctif 2.
Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

Pour plus d'informations sur d'autres mises à jour de produits Trend Micro, voir le site Web Update Center de Trend Micro (http://www.trendmicro.com/download/).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Envisager l'installation de HP Command View EVAPerf
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_SCSIController pour déterminer la valeur de la clé Name. Si la valeur de la clé Name équivaut à Compaq HSV110CCL, cela signifie qu'au moins un volume de disque du serveur est présenté par un réseau SAN (Storage Area Network) HP EVA.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer la valeur de la clé Started pour le service HP StorageWorks Command View EVAPerf (EVSPDCS). La valeur False indique que le service n'est pas en cours d'exécution. La valeur True indique que le service n'est pas en cours d'exécution.

Exchange Server Analyzer affiche une recommandation si les deux conditions suivantes existent :

  • Au moins un volume de disque est présenté par un réseau SAN HP EVA.

  • Le service HP StorageWorks Command View EVAPerf (EVSPDCS) n'est pas présent ou en cours d'exécution.

HP fournit une application de gestion logicielle gratuite qui publie des compteurs de performance supplémentaires pour les réseaux SAN HP StorageWorks. Les administrateurs peuvent utiliser cette application pour contrôler les performances de chaque contrôleur et disque physique du réseau SAN.

Pour suivre la recommandation

  1. Voir le site Web du logiciel HP StorageWorks Command View EVAPerf pour télécharger l'application HP Command View EVAPerf (http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005).

    Remarque :
    Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

  2. Exécutez le fichier exécutable autoextractible que vous avez téléchargé et suivez les instructions pour installer l'application.


Le service EMC PowerPath est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service EMC PowerPath. Une valeur True indique que le service EMC PowerPath s'exécute et une valeur False, que le service EMC PowerPath ne s'exécute pas. Si Exchange Server Analyzer détecte que la valeur de la clé Started est False, un avertissement s'affiche.

EMC PowerPath est un logiciel MPIO (multipath I/O). L'utilisation de chemins d'accès multiples (multipathing) assure un accès aux données haute disponibilité en permettant à un hôte d'avoir jusqu'à 32 chemins d'accès à un périphérique de stockage externe, ce qui facilite le basculement et l'équilibrage de charge. Ce n'est pas une fonctionnalité du système d'exploitation, mais elle est prise en charge par le biais du DDK (Driver Development Kit) MPIO, qui permet aux fournisseurs de stockage de créer des solutions multipathing interopérables.

Lorsque le logiciel MPIO est exécuté, Microsoft Windows® détecte un seul lecteur alors que le logiciel MPIO gère plusieurs connexions à divers périphériques de stockage. Si le logiciel MPIO est arrêté, Windows identifiera ensuite tous les lecteurs de stockage connectés comme des lecteurs indépendants. Cela entraînera probablement des erreurs de stockage et une défaillance.

Pour démarrer le service EMC PowerPath

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service EMC PowerPath, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés du service EMC PowerPath, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service EMC PowerPath, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

Pour des informations générales sur le déploiement de différentes technologies de stockage avec Windows, voir le document sur la planification de l'utilisation des fonctions de stockage de Windows avec des réseaux de zone de stockage (http://go.microsoft.com/fwlink/?LinkId=33626).


EMC PowerPath Version Mismatch Between Cluster Nodes
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2007-07-25

L'outil Microsoft Exchange Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version d'EMC PowerPath installée sur chaque nœud du cluster :

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

Si Exchange Analyzer détecte que la valeur du deuxième nœud ou de l'un des nœuds suivants du cluster Exchange est différente de la valeur de Version, sur le premier nœud du cluster Exchange, une erreur s'affiche.

Cette erreur indique que les nœuds de ce cluster Exchange n'exécutent pas le même niveau du pilote EMC PowerPath. Il est recommandé que tous les nœuds d'un cluster Exchange exécutent le même niveau de pilote EMC PowerPath.

EMC PowerPath est un logiciel MPIO (multipath I/O). L'utilisation de chemins d'accès multiples (multipathing) assure un accès aux données haute disponibilité en permettant à un hôte d'avoir jusqu'à 32 chemins d'accès à un périphérique de stockage externe, ce qui facilite le basculement et l'équilibrage de charge. Ce n'est pas une fonctionnalité du système d'exploitation, mais elle est prise en charge par le biais du DDK (Driver Development Kit) MPIO, qui permet aux fournisseurs de stockage de créer des solutions multipathing interopérables.

Lorsque le logiciel MPIO est exécuté, Microsoft Windows détecte un seul lecteur alors que le logiciel MPIO gère plusieurs connexions à divers périphériques de stockage. Si le pilote MPIO n'est pas compatible pour les différents nœuds du cluster, des problèmes de basculement de cluster peuvent survenir.

Pour résoudre ce problème, vous devez mettre à niveau tous les nœuds vers la même version du pilote EMC PowerPath.

Pour plus d'informations

Pour plus d'informations sur le déploiement de différentes technologies de stockage avec Windows, voir le document sur la planification de l'utilisation des fonctions de stockage de Windows avec des réseaux de zone de stockage (http://go.microsoft.com/fwlink/?LinkId=33626).


Le pilote d'Emulex FC Port n'a pas été mis à jour depuis plus de deux ans
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-04-19

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft® Win32_SCSIController pour déterminer si une valeur est définie pour la clé DriverName. L'outil Exchange Server Analyzer Tool détermine si les conditions suivantes sont présentes :

  • Le pilote d'Emulex FC Port est installé sur le serveur Exchange.

  • La version actuelle du pilote d'Emulex FC Port est installée sur le serveur Exchange.

  • Le pilote d'Emulex FC Port a été mis à jour au cours de ces deux dernières années.

Si Exchange Server Analyzer détecte que la valeur de la clé DriverName n'a pas été mise à jour depuis plus de deux ans, il affiche un avertissement.

Le pilote d'Emulex FC Port fournit des fonctionnalités SCSI uniquement ou SCSI et IP simultanément en un seul ou plusieurs HBA (host bus adapter). Le pilote FC Port prend en charge les topologies FC-AL (Fibre Channel arbitrated loop), point-à-point et Fabric. Le pilote FC Port est conçu pour des applications spécialisées qui nécessitent un mappage LUN (logical unit number) basé sur l'hôte ou une liaison continue.

Pour mettre à jour le pilote d'Emulex FC Port, voir la page sur les téléchargements et manuels pour Windows (http://www.emulex.com/ts/docfc/winframe.htm). Si vous avez besoin de pilotes OEM spécifiques, voir le site Web sur le logiciel Emulex et sur la documentation (http://www.emulex.com/ts/index.html).

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Emulex SCSIport Miniport driver has not been updated in more than two years
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-06-14

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_SCSIController pour déterminer si une valeur est définie pour la clé DriverName. L'outil Exchange Server Analyzer Tool détermine si les conditions suivantes sont présentes :

  • Le pilote miniport d'Emulex SCSIport est installé sur le serveur Exchange.

  • La version actuelle du pilote miniport d'Emulex SCSIport est installée sur le serveur Exchange.

  • Le pilote miniport d'Emulex SCSIport a été mis à jour au cours de ces deux dernières années.

Si Exchange Server Analyzer détecte que la valeur de la clé DriverName n'a pas été mise à jour depuis plus de deux ans, il affiche un avertissement.

Le pilote miniport SCSIport offre une fonctionnalité SCSI sur les topologies FC-AL (Fibre Channel arbitrated loop), point-à-point et Fabric.

Pour mettre à jour le pilote miniport d'Emulex SCSIport, voir la page sur les téléchargements et manuels pour Windows (http://www.emulex.com/ts/docfc/winframe.htm). Si vous avez besoin de pilotes OEM spécifiques, voir la page sur les logiciels et la documentation OEM (http://www.emulex.com/ts/index.html).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Le pilote miniport d'Emulex Storport n'a pas été mis à jour depuis plus de deux ans
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-06-14

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft® Win32_SCSIController pour déterminer si une valeur est définie pour la clé DriverName. L'outil Exchange Server Analyzer Tool détermine si les conditions suivantes sont présentes :

  • Le pilote miniport d'Emulex Storport est installé sur le serveur Exchange.

  • La version actuelle du pilote miniport d'Emulex Storport est installée sur le serveur Exchange.

  • Le pilote miniport d'Emulex Storport a été mis à jour au cours de ces deux dernières années.

Si Exchange Server Analyzer détecte que la valeur de la clé DriverName n'a pas été mise à jour depuis plus de deux ans, il affiche un avertissement.

Le pilote miniport d'Emulex Storport optimise les performances et la gestion des réseaux SAN (Storage Area Network) et des matrices de disques matérielles. Le pilote miniport d'Emulex Storport prend en charge les topologies FC-AL (Fibre Channel arbitrated loop), point-à-point et Fabric.

Pour mettre à jour le pilote miniport d'Emulex Storport, voir la page sur les téléchargements et manuels pour Windows (http://www.emulex.com/ts/docfc/winframe.htm). Si vous avez besoin de pilotes OEM spécifiques, voir la page sur les logiciels et la documentation OEM (http://www.emulex.com/ts/index.html).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Utilisation élevée du processeur dans un processus non-Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

  • L'outil Microsoft® Exchange Server Analyzer Tool a détecté un processus non-Exchange Server qui utilise plus de 20 pour cent du processeur disponible sur le serveur. Si un processus non-Exchange Server utilise plus de 20 pour cent du processeur disponible, une erreur s'affiche.

  • Il est recommandé que vos serveurs qui exécutent Exchange Server soient dédiés à Exchange Server si possible et exécutent le moins d'applications ou de services possible à l'exception d'Exchange.

Pour corriger cette erreur

  • Si un autre processus est responsable d'une grande partie de l'utilisation du processeur, essayez l'une des options suivantes :

    • Désactivez le processus et voyez si le problème disparaît.

    • Déplacez ce processus vers un autre serveur si vous le pouvez.

    • Assurez-vous que le processus est configuré correctement et recherchez des mises à jour Microsoft ainsi que le fournisseur du processus à la base du problème.

    • Désinstallez le processus si vous n'en avez pas besoin.

  • Si vous ne parvenez pas à déplacer ou corriger le processus, le serveur doit être ré-échelonné pour autoriser la charge ajoutée du processus non-Exchange Server. Vous devez envisager de déplacer des utilisateurs vers un autre serveur Exchange lors de ce ré-échelonnage.


Le service HP/Compaq Secure Path est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si le service HP/Compaq Secure Path est en cours d'exécution. Si Exchange Server Analyzer détermine que le service HP/Compaq Secure Path n'est pas en cours d'exécution, un avertissement s'affiche.

Le service HP/Compaq Secure Path est un logiciel MPIO (Multipath I/O). L'utilisation de chemins d'accès multiples (multipathing) assure un accès aux données haute disponibilité en permettant à un hôte d'avoir jusqu'à 32 chemins d'accès à un périphérique de stockage externe, ce qui facilite le basculement et l'équilibrage de charge. Ce n'est pas une fonctionnalité du système d'exploitation, mais elle est prise en charge par le biais du DDK (Driver Development Kit) MPIO, qui permet aux fournisseurs de stockage de créer des solutions multipathing interopérables.

Lorsque le logiciel MPIO est exécuté, le système d'exploitation Windows détecte un seul lecteur alors que le logiciel MPIO gère plusieurs connexions à divers périphériques de stockage. Si le logiciel MPIO est arrêté, Windows identifiera ensuite tous les lecteurs de stockage connectés comme des lecteurs indépendants. Cela entraînera probablement des erreurs de stockage et une défaillance.

Pour supprimer cet avertissement

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service HP/Compaq Secure Path, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés du service HP/Compaq Secure Path, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service HP/Compaq Secure Path, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

Pour des informations générales sur le déploiement de différentes technologies de stockage avec Windows, voir le document sur la planification de l'utilisation des fonctions de stockage de Windows avec des réseaux de zone de stockage (http://go.microsoft.com/fwlink/?linkid=33626).


Impact du logiciel tiers
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que vous exécutez un logiciel tiers sur votre serveur Exchange. Ce logiciel tiers peut provoquer des problèmes de performances sur votre serveur. Le logiciel tiers peut comprendre, entre autres, ce qui suit :

  • des produits antivirus au niveau fichier ;

  • des produits antivirus de courrier électronique compatibles avec Exchange ;

  • des solutions de blocage du courrier indésirable ;

  • un logiciel de serveur de télécopie ;

  • un connecteur de collaboration ou de messagerie étrangère ;

  • des services de fichier et d'impression ;

  • des connecteurs de périphériques mobiles.

Pour corriger cette erreur

  • Si vous pensez que le logiciel tiers altère les performances d'Exchange Server, désinstallez-le ou désactivez-le et analysez les performances d'Exchange Server.

  • Si vous déterminez que le logiciel tiers provoque une diminution des performances et que ce logiciel est important pour les fonctionnalités du serveur, envisagez de dédier un autre serveur pour répartir la charge sur deux serveurs.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Mise à jour de version INO_FLPY.SYS disponible
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la version du pilote du filtre antivirus Computer Associates Ino_flpy.sys.

Exchange Server Analyzer interroge la classe WMI CIM_Datafile pour déterminer la valeur de la clé Version pour Ino_flpy.sys, et en fonction du numéro de version, une mise à jour du logiciel peut être requise. Si la valeur de la clé Version indique que le numéro de version est inférieur à 5.00.6100.109 pour le fichier Ino_flpy.sys, un avertissement s'affiche.

Un numéro de version inférieur à 5.00.6100.109 indique que la version la plus récente du fichier Ino_flpy.sys n'est pas installée sur l'ordinateur Exchange Server et qu'une version plus récente du pilote doit être installée. Une mise à jour logicielle antivirus pour le fichier Ino_flpy.sys peut être trouvée sur le site Web de Computer Associates. Cette mise à jour logicielle antivirus est vivement recommandée et peut améliorer la fiabilité et les performances globales de l'ordinateur Exchange Server.

Lorsque les programmes eTrust Antivirus Inoculan version 6.x ou 7.x et InoculateIT version 6.x de Computer Associates sont installés sur un ordinateur Exchange 2000 Server ou Exchange Server 2003, le programme d'installation copie les fichiers du pilote du filtre antivirus Ino_flpy.sys et Ino_fltr.sys dans le dossier %systemroot%\system32\drivers. Les fichiers du pilote du filtre antivirus sont des pilotes en mode noyau Windows NT® utilisés pour démarrer les services antivirus requis. Les anciennes versions des pilotes de filtre peuvent provoquer des résultats inappropriés avec l'ordinateur Exchange Server.

Pour supprimer cet avertissement

  1. Pour obtenir les mises à jour logicielles antivirus les plus récentes pour le fichier ino_flpy.sys, voir le site Web de Computer Associates (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp).

  2. Téléchargez la version mise à jour appropriée d'eTrust ou InoculateIT.

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server, y compris une sauvegarde du fichier Ino_flpy.sys.

  4. Installez la dernière mise à jour d'eTrust ou InoculateIT.
Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 240309 sur la procédure de désactivation complète des filtres de fichiers d'un logiciel antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Mise à jour de version INO_FLTR.SYS disponible
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la version du pilote du filtre antivirus Computer Associates no_fltr.sys.

Exchange Server Analyzer interroge la classe WMI CIM_Datafile pour déterminer la valeur de la clé Version pour Ino_fltr.sys, et en fonction du numéro de version, une mise à jour du logiciel peut être requise. Si la valeur de la clé Version indique que le numéro de version est inférieur à 5.00.6100.142 pour le fichier Ino_fltr.sys, un avertissement s'affiche.

Un numéro de version inférieur à 5.00.6100.142 indique que la version la plus récente du fichier Ino_fltr.sys n'est pas installée sur l'ordinateur Exchange Server et qu'une version plus récente du pilote doit être installée. Une mise à jour logicielle antivirus pour le fichier Ino_fltr.sys peut être trouvée sur le site Web de Computer Associates. Cette mise à jour logicielle antivirus est vivement recommandée et peut améliorer la fiabilité et les performances globales de l'ordinateur Exchange Server.

Lorsque les programmes eTrust Antivirus Inoculan version 6.x ou 7.x et InoculateIT version 6.x de Computer Associates sont installés sur un ordinateur Exchange 2000 Server ou Exchange Server 2003, le programme d'installation copie les fichiers du pilote du filtre antivirus Ino_flpy.sys et Ino_fltr.sys dans le dossier %systemroot%\system32\drivers. Les fichiers du pilote du filtre antivirus sont des pilotes en mode noyau Windows NT® utilisés pour démarrer les services antivirus requis. Les anciennes versions des pilotes de filtre peuvent provoquer des résultats inappropriés avec l'ordinateur Exchange Server.

Pour supprimer cet avertissement

  1. Pour obtenir les mises à jour logicielles antivirus les plus récentes pour le fichier Ino_fltr.sys, voir le site Web de Computer Associates (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp).

  2. Téléchargez la version mise à jour appropriée d'eTrust ou InoculateIT.

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server, y compris une sauvegarde du fichier Ino_fltr.sys.

  4. Installez la dernière mise à jour d'eTrust ou InoculateIT.
Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 240309 sur la procédure de désactivation complète des filtres de fichiers d'un logiciel antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309)

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Mise à jour de McAfee GroupShield 5,2 pour Microsoft Exchange disponible pour Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-04-19

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si un fichier bibliothèque VSAPI (Virus Scanning Application Programming Interface) est enregistré avec le service de banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Lorsque McAfee GroupShield 5.2 pour Microsoft Exchange est installé sur Exchange 2000 Server ou Exchange Server 2003, l'entrée de Registre Bibliothèque présente la valeur GSEVS2.DLL. Ce fichier bibliothèque exécute plusieurs fonctions relatives à VSAPI dans GroupShield 5.2 pour Microsoft Exchange.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour GSEVS2.DLL. Si la valeur de la clé Version indique que le numéro de version est inférieur à 682 pour ce fichier, un avertissement s'affiche.

Un numéro de version inférieur à 682 pour GSEVS2.DLL indique que la dernière version de GroupShield 5.2 pour Microsoft Exchange n'est pas installée. Une mise à jour du logiciel est disponible pour GroupShield 5.2 pour Microsoft Exchange sur le site Web de McAfee. Cette mise à jour est vivement recommandée et peut améliorer la fiabilité et les performances globales. En outre, la mise à niveau vers GroupShield pour Microsoft Exchange 5.2.682 garantit l'utilisation des dernières versions des importantes DLL. La dernière version de gsevs2.dll améliore considérablement les performances et la fiabilité des déploiements de messagerie dans Exchange Server.

Pour supprimer cet avertissement

  1. Découvrez la dernière version de GroupShield 5.2 pour Microsoft Exchange Server en visitant la page de recherche guidée du site Web de McAfee (http://knowledgemap.nai.com/). Utilisez les articles suivants ou d'autres articles de la base de connaissances des solutions McAfee de ce site pour déterminer la dernière version :

    • ID de solution KB40567 concernant l'obtention de la dernière version de GroupShield et/ou SpamKiller

    • ID de solution KB nai18117 concernant les informations sur la version du produit pour GroupShield pour Exchange 2000

  2. Visitez le site Web de McAfee (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Téléchargez la dernière mise à jour pour votre version de GroupShield 5.2 pour Microsoft Exchange Server.

  4. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  5. Installez la dernière mise à jour de GroupShield 5.2 pour Microsoft Exchange Server.
Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226)


Mise à jour de McAfee GroupShield 6.0 pour Microsoft Exchange disponible pour Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si un fichier bibliothèque VSAPI (Virus Scanning Application Programming Interface) est enregistré avec le service de banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Lorsque McAfee GroupShield 6.0 pour Microsoft Exchange est installé sur Exchange 2000 Server ou Exchange Server 2003, l'entrée de Registre Bibliothèque présente la valeur VSAPISCANSOURCE.DLL. Ce fichier bibliothèque exécute plusieurs fonctions relatives à VSAPI dans GroupShield 6.0 pour Microsoft Exchange.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour VSAPISCANSOURCE.DLL. Si la valeur de la clé Version indique que le numéro de version est inférieur à 6.0.1148.0 pour ce fichier, un avertissement s'affiche.

Un numéro de version inférieur à 6.0.1148.0 pour VSAPISCANSOURCE.DLL indique que la dernière version de GroupShield 6.0 pour Microsoft Exchange n'est pas installée. Une mise à jour du logiciel est disponible pour GroupShield 6.0 pour Microsoft Exchange sur le site Web de McAfee. Cette mise à jour est vivement recommandée et peut améliorer la fiabilité et les performances globales.

Pour supprimer cet avertissement

  1. Découvrez la dernière version de GroupShield 6.0 pour Microsoft Exchange en visitant la page de recherche guidée du site Web de McAfee (http://knowledgemap.nai.com/). Utilisez les articles suivants ou d'autres articles des solutions McAfee de ce site pour déterminer la dernière version :

    • ID de solution nai18117 concernant les informations sur la version du produit pour GroupShield pour Exchange 2000

    • ID de solution KB37636 concernant les numéros de version de McAfee GroupShield 6.x pour Microsoft Exchange

    • ID de solution KB40567 concernant l'obtention de la dernière version de GroupShield et/ou SpamKiller

  2. Voir la page de téléchargement des produits du site Web de McAfee (https://secure.nai.com/us/forms/downloads/upgrades/login.asp).

  3. Téléchargez la dernière mise à jour pour votre version de GroupShield 6.0 pour Microsoft Exchange.

  4. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  5. Installez la dernière mise à jour de GroupShield 6,0 pour Microsoft Exchange.
Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


McAfee GroupShield est installé sur ce serveur Exchange, mais le service est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si McAfee GroupShield pour Microsoft Exchange est installé et si le service McAfee GroupShield est en cours d'exécution sur l'ordinateur Exchange.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer si la valeur de la clé Started dans le service de banque d'informations de Microsoft Exchange est définie sur True ou False.

La valeur False indique que le service de banque d'informations n'est pas en cours d'exécution sur cet ordinateur Exchange Server. La valeur True indique que le service de banque d'informations de Microsoft Exchange est en cours d'exécution.

Si Exchange Server Analyzer détecte que le service de banque d'informations de Microsoft Exchange est en cours d'exécution et que McAfee GroupShield est installé mais que le service McAfee GroupShield n'est pas démarré, un avertissement s'affiche.

McAfee GroupShield assure la protection antivirus pour Exchange. Les raisons de l'arrêt du service McAfee GroupShield ainsi que les solutions sont répertoriées ci-dessous.

  • Le logiciel en cours d'exécution sur votre serveur Exchange peut être une version d'évaluation qui a expiré. Dans ce cas, il se peut que vous deviez réinstaller McAfee GroupShield. Pour continuer à utiliser le logiciel, vous devez au moins l'activer.

  • Un administrateur a peut-être involontairement arrêté le service McAfee GroupShield. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le.

  • Un ver malveillant, un virus ou un autre programme peut avoir arrêté le service. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le. Si le service continue à s'arrêter inopinément sans événements d'erreur pertinente, vérifiez que l'ordinateur n'est pas infecté par un ver malveillant et désinfectez le système, au besoin.

Microsoft recommande généralement le déploiement d'un logiciel antivirus conçu pour les systèmes de messagerie sur la passerelle SMTP ou sur les serveurs Exchange qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur l'ordinateur Exchange Server qui utilise VSAPI 2.5.

Pour démarrer le service McAfee GroupShield

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service McAfee GroupShield, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de McAfee GroupShield, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service McAfee GroupShield, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

En outre, vous devez exécuter le logiciel antivirus client sur le Bureau de l'utilisateur. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (il peut analyser des messages MIME) sur la passerelle ou le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur le Bureau est suffisante.

  • Pour plus d'informations sur les différents types de programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Pour plus d'informations sur les différents types de programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir le livre blanc Microsoft sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=30732).


Messageware Plus Pack installé
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si Messageware Plus Pack est installé sur un serveur Exchange :

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

Si Exchange Server Analyzer détecte que la valeur de Load est égale à 1, il affiche un message indiquant une configuration autre que celle par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Messageware Plus Pack est un complément de Microsoft Office Outlook® Web Access pour Exchange Server 2003, fabriqué par Messageware Incorporated. Messageware Plus Pack étend et améliore Outlook Web Access pour les utilisateurs d'Outlook Web Access Basic et Outlook Web Access Premium.

Pour plus d'informations sur Messageware Plus Pack, voir le site Web sur la suite Messageware OWA (http://www.messageware.com).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Compatibilité de la prévention de l'exécution des données de Microsoft Antigen
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2007-02-19

L'outil Microsoft Exchange Analyzer interroge la classe WMI (Windows Management Instrumentation) Win32_Service pour déterminer la valeur de la clé Started pour le service Microsoft Antigen. La valeur False indique que le service n'est pas en cours d'exécution. La valeur True indique que le service est en cours d'exécution.

Exchange Analyzer lit également l'entée de Registre suivante pour déterminer si le moteur d'analyse Kaspersky pour Microsoft Antigen est installé sur le serveur Exchange. Cette entrée de Registre n'est présente que si le moteur d'analyse Kaspersky est installé sur le serveur Exchange.

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

Si le serveur Exchange est exécuté sur Microsoft Windows Server 2003 Service Pack 1 (SP1) ou une version ultérieure, Exchange Analyzer interroge la classe WMI Win32_ComputerSystem pour déterminer si la valeur de la clé SystemStartupOptions contient les chaînes « /NOEXECUTE=OPTOUT » ou « /NOEXECUTE=ALWAYSON ». Cela indique que la prévention de l'exécution des données est activée sur le serveur. La prévention de l'exécution des données est un ensemble de technologies matérielles et logicielles qui effectuent des vérifications supplémentaires sur la mémoire pour empêcher l'exécution de codes malveillants sur un système.

Si Exchange Analyzer détermine que les conditions suivantes sont vraies, il affiche un avertissement :

  • Le service Microsoft Antigen est activé sur le serveur.

  • Le moteur d'analyse Kaspersky pour Antigen est installé.

  • Le serveur Exchange est exécuté sur Microsoft Windows Server 2003 Service Pack 1 (SP1) ou une version ultérieure.

  • La prévention de l'exécution des données est activée sur le serveur.

Cet avertissement indique que la configuration actuelle du serveur peut provoquer des problèmes de performances de la messagerie et de l'analyse des virus.

Pour supprimer cet avertissement, suivez les instructions de l'article 905952 de la Base de connaissances Microsoft, « Les performances de messagerie sont plus lentes que prévu dans Antigen et le client Antigen ne répond plus » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952) pour désactiver la prévention de l'exécution des données de façon sélective pour des programmes individuels.

Pour plus d'informations

Pour plus d'informations sur la prévention de l'exécution des données, consultez l'article 875352 de la Base de connaissances Microsoft, « Description détaillée de la fonctionnalité Prévention de l'exécution des données dans Windows XP Service Pack 2, Windows XP Édition Tablet PC 2005 et Windows Server 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352).


Le service Double-Take de NSI Software est installé
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service Double-Take. Une valeur True indique que le service Double-Take fonctionne sur ce serveur Exchange Server. Si ce service est détecté sur un serveur Exchange Server, Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Le service Double-Take de NSI Software, Inc., copie les fichiers sélectionnés par l'utilisateur ou des volumes complets d'un ou plusieurs serveurs sources vers un ou plusieurs serveurs cibles par le biais des connexions réseau standard. Ces copies permettent aux entreprises de récupérer rapidement après un sinistre ou une panne système, que ce soit avec ou sans intervention de l'utilisateur.

Pour plus d'informations sur le service Double-Take, voir le site Web sur le Double-Take (http://www.nsisoftware.com/pro/doubletake).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Double-Take est un logiciel de réplication des données. Pour plus de détails sur la réplication des données multi-sites pour Exchange 2000 Server et Exchange Server 2003, voir l'article 895847 de la Base de connaissances Microsoft sur la prise en charge de la réplication des données multi-sites pour Exchange 2003 et Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847).


Processus non-Exchange utilisant un temps processeur supérieur à 20 %
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance %Processor Time (_Total) de l'objet de performance Processor pour les analyser.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Il y a un goulot d'étranglement de processeur.

  • Un ou plusieurs processus non-Exchange utilisent plus de 20 pour cent du temps processeur total moyen du serveur.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Il y a un goulot d'étranglement de processeur.

  • Un ou plusieurs processus non-Exchange utilisent plus de 10 pour cent du temps processeur total moyen du serveur.

Le compteur de performance % Processor Time (_Total) dans l'objet de performance Process fournit l'utilisation globale des processeurs. L'utilisation moyenne du processeur doit toujours être inférieure à 80 %. Une moyenne plus élevée indique un goulot d'étranglement de processeur. Les pointes fréquentes de temps processeur supérieures à 90 % indiquent également un goulot d'étranglement de processeur.

Suppression des goulots d'étranglement de processeur

Il existe de nombreuses façons de supprimer les goulots d'étranglement de processeur de votre serveur Exchange.

  • Identifiez tout d'abord les applications ou tâches qui provoquent une charge sur le serveur. Déterminez si l'application doit utiliser le temps processeur réel ou s'il existe un problème avec ce processus.

  • Si une application non-Exchange n'est pas importante sur ce serveur, exécutez-la sur un autre serveur. Si vous pouvez l'exécuter sur un autre serveur, déplacez également les rôles de serveur vers d'autres ordinateurs. Par exemple, si le processus Inetinfo utilise une grande partie du processeur, envisagez l'ajout de serveurs frontaux pour prendre la responsabilité du fonctionnement du protocole assuré par Inetinfo. Vous pouvez également déplacer l'accès aux dossiers publics vers un serveur de dossiers publics dédié. Enfin, si un serveur effectue de nombreuses extensions de liste de distribution, vous pouvez réduire l'utilisation du processeur en déplaçant l'extension de la liste de distribution vers un serveur d'extension de liste de distribution dédié.

  • Si possible, ajoutez davantage de processeurs ou des processeurs plus rapides au serveur. Activez également la technologie Hyper-Threading si elle est prise en charge par les processeurs. Vous pouvez activer la technologie Hyper-Threading en configurant le BIOS système. Pour plus d'informations, voir la documentation d'aide du fabricant de l'ordinateur.

  • Si l'augmentation de la puissance de traitement s'avère impossible, vous devez diminuer la charge des processeurs. Pour réduire l'impact global sur le serveur, assurez-vous que les tâches qui nécessitent de nombreuses E/S et une grande partie du processeur ou utilisent beaucoup de mémoire soient effectuées en dehors des heures de fonctionnement habituelles.

  • Assurez-vous que les tâches qui nécessitent une grande partie du processeur (comme les tâches de sauvegarde et de maintenance) sont effectuées pendant les heures creuses. Assurez-vous également que ces tâches soient effectuées par étapes. Effectuer une tâche par étapes signifie le paramétrage de différentes heures de début et de fin pour chaque tâche. Effectuer par étapes la maintenance et la sauvegarde des bases de données ou des groupes de stockage diminue également l'effet de ces tâches nécessitant beaucoup de ressources.

Pour plus d'informations

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

  • Pour plus d'informations sur la procédure de déplacement des boîtes aux lettres utilisateur pour réduire la charge du serveur, voir la rubrique Déplacement de boîtes aux lettres utilisateur vers un autre serveur.


Processus non-Exchange utilisant un temps processeur supérieur à 50 %
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Le moteur de collecte des données de performances collecte les données du compteur de performance %Processor Time (_Total) de l'objet de performance Processor pour les analyser.

Ce compteur de performance % Processor Time (_Total) dans l'objet de performance Process fournit l'utilisation globale des processeurs. L'utilisation moyenne du processeur doit toujours être inférieure à 80 %. Une moyenne plus élevée indique un goulot d'étranglement de processeur. Les pointes fréquentes de temps processeur supérieures à 90 % indiquent également un goulot d'étranglement de processeur.

Si Exchange Server Analyzer détermine qu'un processus non-Exchange utilise plus de 50 % du temps processeur total moyen du serveur, même si aucun goulot d'étranglement de processeur n'est détecté, il affiche un avertissement.

Suppression des goulots d'étranglement de processeur potentiels

Il existe de nombreuses façons de supprimer les goulots d'étranglement de processeur potentiels de votre serveur Exchange.

  • Identifiez tout d'abord les applications ou tâches qui provoquent une charge sur le serveur. Déterminez si l'application doit utiliser le temps processeur réel ou s'il existe un problème avec ce processus.

  • Si une application non-Exchange n'est pas importante sur ce serveur, exécutez-la sur un autre serveur. Si vous pouvez l'exécuter sur un autre serveur, déplacez également les rôles de serveur vers d'autres ordinateurs. Par exemple, si le processus Inetinfo utilise une grande partie du processeur, envisagez l'ajout de serveurs frontaux pour prendre la responsabilité du fonctionnement du protocole assuré par Inetinfo. Vous pouvez également déplacer l'accès aux dossiers publics vers un serveur de dossiers publics dédié. Enfin, si un serveur effectue de nombreuses extensions de liste de distribution, vous pouvez réduire l'utilisation du processeur en déplaçant l'extension de la liste de distribution vers un serveur d'extension de liste de distribution dédié.

  • Si possible, ajoutez davantage de processeurs ou des processeurs plus rapides au serveur. Activez également la technologie Hyper-Threading si elle est prise en charge par les processeurs. Vous pouvez activer la technologie Hyper-Threading en configurant le BIOS système. Pour plus d'informations, voir la documentation d'aide du fabricant de l'ordinateur.

  • Si l'augmentation de la puissance de traitement s'avère impossible, vous devez diminuer la charge des processeurs. Pour réduire l'impact global sur le serveur, assurez-vous que les tâches qui nécessitent de nombreuses E/S et une grande partie du processeur ou utilisent beaucoup de mémoire soient effectuées en dehors des heures de fonctionnement habituelles.

  • Assurez-vous que les tâches qui nécessitent une grande partie du processeur (comme les tâches de sauvegarde et de maintenance) sont effectuées pendant les heures creuses. Assurez-vous également que ces tâches soient effectuées par étapes. Effectuer une tâche par étapes signifie le paramétrage de différentes heures de début et de fin pour chaque tâche. Effectuer par étapes la maintenance et la sauvegarde des bases de données ou des groupes de stockage diminue également l'effet de ces tâches nécessitant beaucoup de ressources.

Pour plus d'informations

  • Pour plus d'informations sur les goulots d'étranglement de processeur, voir la rubrique Goulot d'étranglement de processeur.

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Une ancienne version de HP/Compaq Secure Path est installée
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la version logicielle d'HP/Compaq Secure Path installée sur le serveur Exchange. Si la version de Secure Path n'est pas 3.7.2.540, un avertissement s'affiche.

Pour supprimer cet avertissement, mettez le logiciel Secure Path à jour. Contactez votre revendeur HP/Compaq pour le mettre à jour.

Pour plus d'informations sur les mises à jour logicielles d'HP/Compaq Secure Path, voir le site Web HP sur HP StorageWorks Secure Path (http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html).

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Port 25 bloqué
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer lit l'entrée de registre suivante pour déterminer la version de McAfee VirusScan pour Microsoft Exchange installée sur le serveur exécutant Exchange Server :

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

Exchange Server Analyzer interroge également la branche de registre suivante pour déterminer la configuration du produit VirusScan pour le blocage des ports :

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

Les clés de cette branche permettent de configurer les processus et les ports bloqués ou autorisés avec la fonction On Access du produit VirusScan.

Enfin, Exchange Server Analyzer interroge également la classe Win32_Service WMI (Microsoft Windows® Management Instrumentation) pour déterminer la valeur de la clé Started afin de permettre au service McAfee VirusScan de déterminer s'il est en cours d'exécution sur Exchange Server.

La valeur False indique que le service McAfee VirusScan n'est pas en cours d'exécution sur ce serveur Exchange. La valeur True indique que le service McAfee VirusScan est en cours d'exécution.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • McAfee VirusScan est installé et en cours d'exécution sur le serveur Exchange.

  • La règle de blocage de l'envoi de messages par des vers de publipostage est activée pour le port 25.

  • Le service SMTP (Simple Mail Transfer Protocol) n'est pas exclu de la règle de blocage.

Cet avertissement indique que l'application McAfee VirusScan est configurée pour bloquer toute communication Exchange Server légitime via le port 25. Des problèmes de flux de messages peuvent se produire.

Pour résoudre ce problème :

  • Considérez l'opportunité de désactiver la règle de blocage de l'envoi de messages par des vers de publipostage.

  • Ajoutez le service SMTP Exchange Server à la liste d'exclusion de la règle de blocage de l'envoi de messages par des vers de publipostage.

Pour plus d'informations

  • Pour plus d'informations sur la procédure de configuration de McAfee VirusScan pour Microsoft Exchange, visitez le portail du service McAfee (http://knowledge.mcafee.com/).

    Remarque :
    Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL peuvent faire l'objet de modifications sans préavis.
  • Pour plus d'informations sur les différents types de programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, consultez l'article 823166 de la Base de connaissances Microsoft, « Aperçu des logiciels antivirus utilisés avec Exchange Server 2003 » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • Pour plus d'informations sur les différents types de programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, consultez l'article 328841 de la Base de connaissances, « Exchange et les logiciels antivirus » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, consultez le livre blanc Microsoft « Ralentissement et arrêt des virus transmis par courrier électronique dans un environnement Exchange » (http://go.microsoft.com/fwlink/?LinkId=30732).


Red Earth Software Policy Patrol for Exchange Server Needs Update
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2007-07-24

L'outil Microsoft Exchange Analyzer Tool lit le Registre pour déterminer si l'une des deux sous-clés suivantes est présente :

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

La présence de l'une de ces branches indique que Policy Patrol 3.0 pour Exchange Server de Red Earth Software est installé sur l'ordinateur local.

Si Exchange Analyzer détecte que Policy Patrol 3 pour Exchange Server est installé sur l'ordinateur local, il affiche un avertissement.

Cet avertissement indique qu'une mise à jour recommandée de Policy Patrol pour Exchange Server est disponible.

Pour corriger cet avertissement

  1. Visitez le site de téléchargement de Policy Patrol pour Exchange Server de Red Earth Software à l'adresse http://www.policypatrol.com/download.htm

  2. Téléchargez et installez les mises à jours obligatoires ou recommandées pour Policy Patrol pour Exchange Server.
Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


ScanMail pour Microsoft Exchange et CA eTrust sont exécutés simultanément
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version de Trend Micro ScanMail pour Microsoft Exchange installée sur le serveur Exchange :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Si les données de la valeur Version commencent par 7, cela indique que ScanMail pour Microsoft Exchange Version 7 est installé.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si eTrust de Computer Associates est également installé sur le serveur Exchange :

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

Si la valeur de Registre CurrentVersion existe, cela indique qu'eTrust Antivirus version 7 de Computer Associates est installé sur le serveur Exchange.

Enfin, Exchange Server Analyzer interroge la classe Windows® Management Instrumentation Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service InoRT, également appelé service eTrust Antivirus Realtime Server dans eTrust Antivirus.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • ScanMail pour Microsoft Exchange et eTrust Antivirus sont installés sur le serveur Exchange.

  • Le service eTrust Antivirus Realtime Server est démarré.

Trend Micro recommande que tous les logiciels antivirus basés sur le système de fichiers, comme eTrust Antivirus, n'analysent pas les dossiers ScanMail pour Microsoft Exchange. ScanMail pour Microsoft Exchange utilise des dossiers temporaires dans son chemin d'accès pour sa propre activité d'analyse. Si un analyseur antivirus basé sur le système de fichiers analyse ces dossiers temporaires, l'analyse peut interférer avec les opérations habituelles de ScanMail pour Microsoft Exchange.

Il est recommandé d'exclure les dossiers ScanMail pour Microsoft Exchange de l'analyse en temps réel effectuée par le logiciel antivirus basé sur le système de fichiers, comme eTrust Antivirus de Computer Associates. Pour plus d'informations sur l'utilisation de ScanMail pour Microsoft Exchange sur un ordinateur sur lequel un logiciel antivirus basé sur le système de fichier est installé, voir l'article de la base de connaissances de Trend Micro sur l'installation d'une autre application antivirus lorsque ScanMail pour Exchange est également installé sur le même serveur (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540).

Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Le répertoire d'archivage de ScanMail pour Microsoft Exchange contient trop de fichiers
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la version 7.0 de Trend Micro ScanMail pour Microsoft Exchange est installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer compte ensuite le nombre de fichiers présents dans le répertoire d'archivage utilisé par ScanMail pour Microsoft Exchange. Par défaut, le chemin d'accès au répertoire d'archivage est le suivant :

C:\Program Files\Trend Micro\Smex\Storage\Archive

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • La version 7.0 de ScanMail pour Microsoft Exchange est installée.

  • Plus de 1 000 fichiers se situent dans le répertoire d'archivage utilisé par ScanMail pour Microsoft Exchange.

Cet avertissement indique la présence de plusieurs fichiers dans le répertoire d'archivage utilisé par ScanMail pour Microsoft Exchange. Trend Micro recommande de consulter et de vider régulièrement le dossier d'archivage utilisé par ScanMail pour Microsoft Exchange.


Le répertoire de sauvegarde de ScanMail pour Microsoft Exchange contient trop de fichiers
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la version 7.0 de Trend Micro ScanMail pour Microsoft Exchange est installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer compte ensuite le nombre de fichiers présents dans le répertoire de sauvegarde utilisé par ScanMail pour Microsoft Exchange. Par défaut, le chemin d'accès au répertoire de sauvegarde est le suivant :

C:\Program Files\Trend Micro\Smex\Storage\Backup

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • La version 7.0 de ScanMail pour Microsoft Exchange est installée.

  • Plus de 1 000 fichiers se situent dans le répertoire de sauvegarde utilisé par ScanMail pour Microsoft Exchange.

Cet avertissement indique la présence de plusieurs fichiers dans le répertoire de sauvegarde utilisé par ScanMail pour Microsoft Exchange. Trend Micro recommande de consulter et de vider régulièrement le dossier de sauvegarde utilisé par ScanMail pour Microsoft Exchange.


ScanMail pour l'exclusion de sauvegarde de Microsoft Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer les fichiers et dossiers qui ont été exclus des sauvegardes à l'aide de l'utilitaire de sauvegarde Windows :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer recherche spécifiquement une chaîne qui contient « SMEX\DATA ».

Si Exchange Server Analyzer détecte que la clé FilesNotToBackup contient un valeur qui comprend la chaîne « SMEX\DATA », il affiche un avertissement.

Si vous n'utilisez pas l'utilitaire de sauvegarde Windows, vous pouvez ignorer cet avertissement en toute sécurité. Si vous utilisez l'utilitaire de sauvegarde Windows, il est recommandé de supprimer l'exclusion pour le répertoire SMEX\DATA. Trend Micro recommande que les utilisateurs sauvegardent dans ce dossier tous les fichiers avec une extension de nom de fichier .mdb. Les fichiers de sauvegarde peuvent être utilisés si les fichiers de production .mdb du dossier SMEX\DATA sont manquants ou endommagés.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Sélectionnez FilesNotToBackup dans le volet gauche.

  4. Dans le volet droit, cliquez avec le bouton droit sur la valeur qui contient la chaîne « SMEX\DATA » et sélectionnez Supprimer.

  5. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Le mode débogage de ScanMail pour Microsoft Exchange est activé
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le mode débogage est activé dans ScanMail pour Microsoft Exchange par Trend Micro :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\DebugModule

Si les données de la valeur DebugModule contiennent une ou plusieurs chaînes suivantes, Exchange Server Analyzer affiche un avertissement :

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

Cet avertissement indique que le mode débogage est actuellement activé pour un ou plusieurs modules ScanMail pour Microsoft Exchange. Trend Micro recommande d'activer le mode débogage uniquement si nécessaire, par exemple, lors de la résolution de problèmes. Dans les autres cas, Trend Micro recommande de désactiver le mode débogage pour les opérations ordinaires.

Pour supprimer cet avertissement

  1. Voir l'article de la base de connaissances de Trend Micro sur l'activation du débogage dans ScanMail pour Exchange (SMEX) 7.0 à l'aide de l'Éditeur du Registre (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532).

  2. Désactivez le débogage pour tous les modules en suivant les instructions fournies dans l'article de la base de connaissances de Trend Micro.
Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Le répertoire de quarantaine de ScanMail pour Microsoft Exchange contient trop de fichiers
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la version 7.0 de Trend Micro ScanMail pour Microsoft Exchange est installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer compte ensuite le nombre de fichiers dans le répertoire de quarantaine utilisé par ScanMail pour Microsoft Exchange. Par défaut, le chemin d'accès au répertoire de quarantaine est le suivant :

C:\Program Files\Trend Micro\Smex\Storage\Quarantine

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • La version 7.0 de ScanMail pour Microsoft Exchange est installée.

  • Plus de 1 000 fichiers se situent dans le répertoire de quarantaine utilisé par ScanMail pour Microsoft Exchange.

Cet avertissement indique la présence de plusieurs fichiers dans le répertoire de quarantaine utilisé par ScanMail pour Microsoft Exchange. Trend Micro recommande de consulter et de vider régulièrement le dossier de quarantaine utilisé par ScanMail pour Microsoft Exchange.


Répertoire SharedResPool de ScanMail pour Microsoft Exchange dans le chemin d'accès par défaut
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2007-06-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la version de Trend Micro ScanMail pour Microsoft Exchange installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer l'emplacement du dossier SharedResPool :

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

Enfin, Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer l'emplacement d'installation de ScanMail pour Microsoft Exchange :

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • ScanMail pour Microsoft Exchange Version 7 est installé.

  • Le dossier SharedResPool se situe dans le chemin d'accès du répertoire racine de ScanMail.

Il est recommandé de déplacer le répertoire SharedResPool sur un lecteur plus rapide que celui du répertoire racine utilisé par ScanMail pour Microsoft Exchange. Trend Micro recommande aux clients de déplacer le dossier SharedResPool sur un lecteur plus rapide pour de meilleures performances. Le répertoire SharedResPool contient des fichiers de mappage dans la mémoire pour les ressources partagées entre les processus fournis avec ScanMail pour Microsoft Exchange version 7.0. Ne supprimez pas le contenu de ce répertoire.

Pour plus d'informations sur le répertoire SharedResPool, consultez la page sur la définition des répertoires SharedResPool et Engine de ScanMail pour Exchange (SMEX) 7.0 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898).

Pour plus d'informations sur le déplacement du répertoire SharedResPool, consultez la page sur le déplacement du répertoire SharedResPool de ScanMail pour Exchange (SMEX) 7.0 vers un autre emplacement (http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549).

Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


L'analyse SMTP ScanMail pour Microsoft Exchange est activée sur un serveur de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété suivante dans la métabase IIS (Internet Information Services) Microsoft pour déterminer les paramètres de configuration actuels pour Trend Micro ScanMail pour Microsoft Exchange :

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serverRole pour l'objet du serveur Exchange. Une valeur de 1 pour l'attribut serverRole indique que le serveur Exchange a été configuré comme un serveur frontal. Une valeur de 0 indique que le serveur Exchange n'est pas configuré comme un serveur frontal.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite pour le serveur Exchange. Cette requête permet d'identifier le système d'exploitation exécuté sur le serveur Exchange.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer la version de ScanMail pour Exchange exécutée sur le serveur Exchange :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Si les données de la valeur Version commencent par 7, cela indique que ScanMail pour Microsoft Exchange Version 7 est installé.

Enfin, Exchange Server Analyzer interroge Active Directory pour déterminer le nombre d'objets dont l'attribut homeMDBBL est configuré. Les objets dont l'attribut homeMDBBL est configuré possèdent une extension messagerie. Par conséquent, le nombre d'objets dont l'attribut homeMDBBL est configuré correspond au nombre de boîtes aux lettres existantes.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • ScanMail pour Microsoft Exchange version 7 est installé.

  • ScanMail pour Microsoft Exchange est configuré pour effectuer une analyse SMTP sur un serveur Exchange qui n'est pas configuré comme un serveur frontal.

  • Le serveur Exchange contient plus de 20 boîtes aux lettres.

  • Le serveur Exchange n'exécute pas Microsoft Windows Small Business Server 2003 ou Microsoft Small Business Server 2000.

Trend Micro recommande aux utilisateurs de ScanMail pour Microsoft Exchange version 7 de désactiver l'analyse SMTP qui utilise la console de gestion ScanMail sur les serveurs de boîtes aux lettres s'il existe des serveurs de passerelle ou têtes de pont séparés et dédiés. Pour accroître les performances et la sécurité, Trend Micro recommande d'activer l'analyse SMTP sur les serveurs têtes de pont de passerelle plutôt que sur les serveurs de boîtes aux lettres.


Le répertoire TEMP de ScanMail pour Microsoft Exchange contient de nombreux fichiers
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la version 7.0 de Trend Micro ScanMail pour Microsoft Exchange est installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

L'outil Exchange Server Analyzer Tool compte ensuite le nombre de fichiers dans le répertoire TEMP utilisé par ScanMail pour Microsoft Exchange. Par défaut, le chemin d'accès du répertoire TEMP utilisé par ScanMail pour Microsoft Exchange se présente comme suit :

C:\Program Files\Trend Micro\Smex\Temp

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • La version 7.0 de ScanMail pour Microsoft Exchange est installée.

  • Plus de 100 fichiers se situent dans le répertoire TEMP utilisé par ScanMail pour Microsoft Exchange.

Cet avertissement indique la présence de plusieurs fichiers dans le répertoire TEMP utilisé par ScanMail pour Microsoft Exchange. Les fichiers de ce dossier sont des fichiers temporaires utilisés par ScanMail pour Microsoft Exchange. ScanMail pour Microsoft Exchange est supposé supprimer ces fichiers automatiquement.

Si de nombreux fichiers portent une date antérieure à la date actuelle, Trend Micro recommande de supprimer les anciens fichiers.


Le répertoire TEMP de ScanMail pour Microsoft Exchange contient trop de fichiers
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la version 7.0 de Trend Micro ScanMail pour Microsoft Exchange est installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Si ScanMail pour Microsoft Exchange version 7 est installé, Exchange Server Analyzer lit l'entrée de Registre suivante pour déterminer l'emplacement du répertoire TEMP utilisé par ScanMail pour Microsoft Exchange :

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Exchange Server Analyzer compte ensuite le nombre de fichiers dans le répertoire TEMP utilisé par ScanMail pour Microsoft Exchange.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • La version 7.0 de ScanMail pour Microsoft Exchange est installée.

  • Plus de 100 fichiers se situent dans le répertoire TEMP utilisé par ScanMail pour Microsoft Exchange.

Cet avertissement indique la présence de plusieurs fichiers dans le répertoire TEMP utilisé par ScanMail pour Microsoft Exchange. Les fichiers de ce dossier sont des fichiers temporaires utilisés par ScanMail pour Microsoft Exchange. ScanMail pour Microsoft Exchange est supposé supprimer ces fichiers automatiquement.

Si de nombreux fichiers portent une date antérieure à la date actuelle, Trend Micro recommande de supprimer les anciens fichiers.


Modification du chemin d'accès au dossier temporaire de ScanMail pour Microsoft Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la version 7.0 de Trend Micro ScanMail pour Microsoft Exchange est installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer l'emplacement du dossier temporaire utilisé par ScanMail pour Microsoft Exchange :

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Si la valeur TempFolderPath est présente et configurée dans le Registre, elle indique que le dossier temporaire utilisé par ScanMail pour Microsoft Exchange a été déplacé de son emplacement par défaut.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version d'AdapterSMTP.dll. Ce module est fourni avec ScanMail pour Microsoft Exchange par Trend Micro. Une clé Version pour AdapterSMTP.dll d'une valeur inférieure à 7.0.1366 indique qu'un version mise à jour de ScanMail pour Microsoft Exchange est nécessaire.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • ScanMail pour Microsoft Exchange version 7 est installé.

  • Le dossier temporaire utilisé par ScanMail pour Microsoft Exchange a été déplacé de son emplacement d'origine.

  • La version du fichier adapterSMTP.dll est 7.0.1366 ou antérieure.

Trend Micro a introduit la possibilité de déplacer le dossier temporaire dans les versions récentes de ScanMail pour Microsoft Exchange. Cette fonction n'existe que dans les versions postérieures à la version 7.0.1366. Cet avertissement indique que le dossier temporaire a été déplacé mais que ce déplacement ne prendra pas effet car ce serveur exécute une version antérieure de ScanMail pour Microsoft Exchange qui ne prend pas en charge le déplacement du dossier temporaire.

Pour supprimer cet avertissement

  1. Visitez le site Web Update Center de Trend Micro (en anglais) (http://www.trendmicro.com/download).

  2. Téléchargez et installez les mises à jours obligatoires ou recommandées pour ScanMail pour Microsoft Exchange.
Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


ScanMail pour l'optimisation du chemin d'accès au dossier temporaire de Microsoft Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la version 7.0 de Trend Micro ScanMail pour Microsoft Exchange est installée :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer l'emplacement du dossier temporaire utilisé par ScanMail pour Microsoft Exchange :

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Si la valeur TempFolderPath est présente et configurée dans le Registre, elle indique que le dossier temporaire utilisé par ScanMail pour Microsoft Exchange a été déplacé de son emplacement par défaut.

Enfin, Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour AdapterSMTP.dll. Ce module est fourni avec ScanMail pour Microsoft Exchange par Trend Micro.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • ScanMail pour Microsoft Exchange version 7 est installé.

  • Le dossier temporaire utilisé par ScanMail pour Microsoft Exchange reste à son emplacement par défaut d'origine.

  • La version du fichier AdapterSMTP.dll prend en charge la redirection du dossier temporaire utilisé par ScanMail pour Microsoft Exchange.

Trend Micro a introduit la possibilité de déplacer le dossier temporaire dans les versions récentes de ScanMail pour Microsoft Exchange. Cette fonction n'existe que dans les versions postérieures à la version 7.0.1366. Si vous utilisez une version de ScanMail pour Microsoft Exchange postérieure à la version 7.0.1366, Trend Micro recommande de déplacer le dossier temporaire sur un lecteur plus rapide.

Pour déplacer le dossier temporaire

  1. Relisez l'article de la Base de connaissances de Trend Micro sur la possibilité qu'ont les utilisateurs de modifier l'emplacement du dossier temporaire de ScanMail for Exchange (SMEX) 7.0 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343).

  2. Effectuez les procédures présentées dans cet article pour déplacer le dossier temporaire sur un lecteur plus rapide.
Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Mise à jour disponible pour ScanMail pour Microsoft Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-12-15

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour adapterSMTP.dll. Ce module est fourni avec ScanMail pour Microsoft Exchange par Trend Micro.

Si Exchange Server Analyzer détecte que la valeur de la clé Version pour adapterSMTP.dll est inférieure à 7.0.1366, il affiche un avertissement.

Cet avertissement indique que ScanMail pour Microsoft Exchange version 7 est installé sur le serveur Exchange et qu'une mise à jour logicielle recommandée est disponible. Cette mise à jour est vivement recommandée et peut améliorer la fiabilité et les performances globales du serveur.

Pour supprimer cet avertissement

  1. Visitez le site Web Update Center de Trend Micro (en anglais) (http://www.trendmicro.com/download/).

  2. Téléchargez et installez les mises à jours obligatoires ou recommandées pour ScanMail pour Microsoft Exchange.
Remarque :
Les informations du site Web tiers sont fournies pour vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


L'analyse antivirus au niveau transport SMTP n'est pas activée
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si une valeur est définie pour la clé Started du service SMSMSE (Symantec Mail Security pour Microsoft Exchange). La classe Win32_Service détermine si SMSMSE est installé sur l'ordinateur Exchange Server 2003. La valeur True indique que le service SMSMSE n'est pas en cours d'exécution. La valeur False indique que le service SMSMSE n'est pas en cours d'exécution. Exchange Server Analyzer affiche un avertissement si les conditions suivantes existent :

  • SMSMSE est installé sur l'ordinateur Exchange Server 2003.

  • L'analyse antivirus au niveau transport SMTP n'est pas activée.

Dans Exchange Server 2003, Exchange Transport AntiVirus API est l'un des six récepteurs d'événements de transport utilisés par le moteur avancé de files d'attente pour remettre des messages à leurs destinataires. Mis en œuvre dans OnSubmit.dll, le récepteur d'événements Exchange Transport AntiVirus API permet à des fournisseurs tiers, tels que Symantec, d'exécuter des analyseurs antivirus qui, pour chaque message, recherchent les éventuelles structures de données et pièces jointes malveillantes avant qu'il ne soit remis à son ou ses destinataires. Cet événement est enregistré pour l'événement OnSubmission.

Par défaut, l'analyse antivirus au niveau transport n'est pas activée car elle implique une double analyse des messages, une première fois au niveau de la couche SMTP et une deuxième fois dans la banque Exchange. Si vous utilisez toutefois des serveurs frontaux pour connecter une organisation Exchange à Internet, vous pouvez activer l'analyse antivirus au niveau transport sur ces serveurs.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour activer l'analyse antivirus au niveau transport

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI.

  3. Créez une nouvelle valeur DWORD et nommez-la Enabled. Définissez les données de cette valeur Enabled sur 1.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Remarque :
La fonctionnalité d'analyse au niveau transport n'est disponible qu'avec les analyseurs antivirus Exchange basés sur VSAPI 2.5 (interface de programmation d'applications d'analyse antivirus).

Pour plus d'informations sur l'architecture de transport SMTP, voir le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47891).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


La mise à jour de Simpler-Webb Exchange Resource Manager est disponible
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-04-14

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur définie pour la clé Version pour ERME2KAsyncSink.dll. Si Exchange Server Analyzer détecte que la valeur de Version pour ERME2KAsyncSink.dll est inférieure à 1015, un avertissement s'affiche.

Le fichier ERME2KAsyncSink.dll est un noyau binaire pour Simpler-Webb Exchange Resource Manager (ERM). Une version d'ERME2KAsyncSink.dll inférieure à 1015 signifie qu'ERM 1.2 ou version antérieure est installé sur le serveur. Un problème connu d'ERM 1.2 provoque l'arrêt de la remise de messages par la file d'attente de remise locale d'Exchange lorsqu'Exchange OLE DB attend un appel de retour du récepteur d'événements ERM. Microsoft Exchange OLEDB attend que le récepteur d'événements ERME2KAsyncSink.dll soit retourné de l'appel OnSyncSave, pendant que l'arrêt de la banque d'informations Exchange est en cours.

L'échec de retour de cet appel peut empêcher l'arrêt de la banque d'informations Exchange. Ce problème est résolu dans ERM version 1.35.

Pour supprimer cet avertissement

  1. Ajout/Suppression de programmes permet de supprimer manuellement ERM version 1.2.

  2. Installez ERM version 1.35, disponible sur le site Web Simpler-Webb (http://www.swinc.com/products/ERM/upgrade/).

    Remarque :
    Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Mise à jour de Sybari Antigen 7.5 pour Microsoft Exchange disponible pour Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si un fichier bibliothèque VSAPI (Virus Scanning Application Programming Interface) est enregistré avec le service de banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 7.5 pour Microsoft Exchange est un produit Sybari. Lorsqu'Antigen 7.5 pour Microsoft Exchange est installé sur Exchange 2000 Server ou Exchange Server 2003, l'entrée de Registre Bibliothèque présente la valeur ANTIGENVSAPI.DLL. Ce fichier bibliothèque exécute plusieurs fonctions relatives à VSAPI dans Antigen 7.5 pour Microsoft Exchange.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour ANTIGENVSAPI.DLL. Si la valeur de la clé Version indique que le numéro de version est inférieur à 1316 pour ce fichier, un avertissement s'affiche.

Un numéro de version inférieur à 1316 pour ANTIGENVSAPI.DLL indique que la dernière version d'Antigen 7.5 pour Microsoft Exchange n'est pas installée. Une mise à jour du logiciel est disponible pour Antigen 7.5 pour Microsoft Exchange sur le site Web de Sybari. Cette mise à jour est vivement recommandée et peut améliorer la fiabilité et les performances globales.

Pour supprimer cet avertissement

  1. Visitez le site Web de Sybari concernant le Centre de téléchargement sous licence (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter au site Web susmentionné.

  2. Téléchargez la dernière mise à jour pour votre version d'Antigen 7.5 pour Microsoft Exchange.

  3. Créez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Installez la dernière mise à jour d'Antigen 7.5 pour Microsoft Exchange.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Mise à jour de Sybari Antigen 8,0 pour Microsoft Exchange disponible pour Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-01-09

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si un fichier bibliothèque VSAPI (Virus Scanning Application Programming Interface) est enregistré avec le service de banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 8.0 pour Microsoft Exchange est un produit Sybari. Lorsqu'Antigen 8.0 pour Microsoft Exchange est installé sur Exchange 2000 Server ou Exchange Server 2003, l'entrée de Registre Bibliothèque présente la valeur ANTIGENVSAPIEx.DLL. Ce fichier bibliothèque exécute plusieurs fonctions relatives à VSAPI dans Antigen 8.0 pour Microsoft Exchange.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour ANTIGENVSAPI.DLL. Si la valeur de la clé Version indique que le numéro de version est inférieur à 1517 pour ce fichier, un avertissement s'affiche.

Un numéro de version inférieur à 1517 pour ANTIGENVSAPI.DLL indique que la dernière version d'Antigen 8.0 pour Microsoft Exchange n'est pas installée. Une mise à jour du logiciel est disponible pour Antigen 8.0 pour Microsoft Exchange sur le site Web de Sybari. Cette mise à jour est vivement recommandée et peut améliorer la fiabilité et les performances globales.

Pour supprimer cet avertissement

  1. Visitez le site Web de Sybari concernant le Centre de téléchargement sous licence (http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx).

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter au site Web susmentionné.

  2. Téléchargez la dernière mise à jour pour votre version d'Antigen 8.0 pour Microsoft Exchange.

  3. Créez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Installez la dernière mise à jour d'Antigen 8.0 pour Microsoft Exchange.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Sybari Antigen est installé sur ce serveur Exchange, mais le service AntigenStore n'est pas en cours d'exécution
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si Sybari Antigen est installé et si le service AntigenStore est en cours d'exécution sur l'ordinateur Exchange.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer si la valeur de la clé Started dans le service de banque d'informations de Microsoft Exchange est définie sur True ou False.

La valeur False indique que le service de banque d'informations de Microsoft Exchange n'est pas en cours d'exécution sur cet ordinateur Exchange Server. La valeur True indique que le service de banque d'informations de Microsoft Exchange est en cours d'exécution.

Si Exchange Server Analyzer détecte que le service de banque d'informations de Microsoft Exchange est en cours d'exécution et que Sybari Antigen est installé mais que le service AntigenStore n'est pas démarré, un avertissement s'affiche.

Sybari Antigen assure une protection antivirus pour Exchange Server. Les raisons de l'arrêt du service Sybari AntigenStore ainsi que les solutions sont répertoriées ci-dessous.

  • Le logiciel en cours d'exécution sur votre serveur Exchange peut être une version d'évaluation qui a expiré. Dans ce cas, il se peut que vous deviez réinstaller Sybari Antigen. Pour continuer à utiliser le logiciel, vous devez au moins l'activer.

  • Un administrateur peut avoir arrêté involontairement le service Sybari Antigen. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le.

  • Un ver malveillant, un virus ou un autre programme peut avoir arrêté le service. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le. Si le service continue à s'arrêter inopinément sans événements d'erreur pertinente, vérifiez que l'ordinateur n'est pas infecté par un ver malveillant et désinfectez le système, au besoin.

En général, il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP ou sur les serveurs Exchange qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur l'ordinateur Exchange Server qui utilise VSAPI 2.5. En outre, vous devez exécuter le logiciel antivirus client sur le Bureau de l'utilisateur. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (il peut analyser des messages MIME) sur la passerelle ou le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur le Bureau est suffisante.

Pour démarrer le service AntigenStore

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service AntigenStore, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de AntigenStore, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, sélectionnez Automatique, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service AntigenStore, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841).

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Sybari Antigen est installé sur ce serveur Exchange, mais le service est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si Sybari Antigen est installé et si le service AntigenService est en cours d'exécution sur l'ordinateur Exchange Server.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer si la valeur de la clé Started dans le service de banque d'informations de Microsoft Exchange est définie sur True ou False.

La valeur False indique que le service de banque d'informations de Microsoft Exchange n'est pas en cours d'exécution sur cet ordinateur Exchange Server. La valeur True indique que le service de banque d'informations de Microsoft Exchange est en cours d'exécution.

Si Exchange Server Analyzer détecte que le service de banque d'informations de Microsoft Exchange est en cours d'exécution et que Sybari Antigen est installé mais que le service AntigenService n'est pas démarré, un avertissement s'affiche.

Sybari Antigen assure une protection antivirus pour Exchange Server. Les raisons de l'arrêt du service Sybari Antigen ainsi que les solutions sont répertoriées ci-dessous :

  • Le logiciel en cours d'exécution sur votre serveur Exchange peut être une version d'évaluation qui a expiré. Dans ce cas, il se peut que vous deviez réinstaller Sybari Antigen. Pour continuer à utiliser le logiciel, vous devez au moins l'activer.

  • Un administrateur peut avoir arrêté involontairement le service Sybari Antigen. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le.

  • Un ver malveillant, un virus ou un autre programme peut avoir arrêté le service. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le. Si le service continue à s'arrêter inopinément sans événements d'erreur pertinente, vérifiez que l'ordinateur n'est pas infecté par un ver malveillant et désinfectez le système, au besoin.

En général, il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP ou sur les serveurs Exchange qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur le serveur Exchange qui utilise VSAPI 2.5. Vous devez en outre exécuter le logiciel antivirus sur les ordinateurs clients. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (il peut analyser des messages MIME) sur la passerelle ou le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur le Bureau est suffisante.

Pour démarrer le service AntigenService

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service AntigenService, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de AntigenService, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, sélectionnez Automatique, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service AntigenService, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.
  • Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Les définitions de Symantec Antivirus n'ont pas été mises à jours depuis plus de 30 jours
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les conditions suivantes sont vraies :

  • Symantec Antivirus est installé sur le serveur.

  • Les fichiers de définition antivirus suivants sont mis à jour :

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

Si Exchange Server Analyzer détecte que les données de valeur de la clé de Registre BinHubStamp n'ont pas été mises à jour depuis plus de 30 jours, il affiche un avertissement.

Symantec Antivirus pour Microsoft Exchange Server fournit une protection antivirus pour Exchange Server. Il est recommandé de télécharger la dernière définition de Symantec Antivirus dès sa commercialisation. Veillez à déployer la mise à jour de la définition de l'antivirus dans les couches suivantes de votre organisation :

  • Serveurs de passerelle de messagerie

  • Serveurs Exchange

  • Stations de travail client

Pour télécharger les dernières définitions de virus, voir la page d'accueil du site Web Symantec Antivirus (http://www.symantec.com).

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Symantec Antivirus est installé sur ce serveur Exchange, mais le service est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si une valeur est définie pour la clé Started. La classe Win32_Service détermine si Symantec Antivirus pour Exchange Server est installé. La valeur True de la clé Started indique que le service Symantec Antivirus est en cours d'exécution sur cet ordinateur Exchange Server. La valeur False de la clé Started indique que le service Symantec Antivirus n'est pas exécuté sur cet ordinateur Exchange Server.

Si Exchange Server Analyzer détecte que Symantec Antivirus est installé sur cet ordinateur Exchange Server, mais que le service Symantec Antivirus n'est pas démarré, il affiche un avertissement.

Symantec Antivirus assure une protection antivirus pour Exchange Server. Les raisons de l'arrêt du service Symantec Antivirus ainsi que les solutions sont répertoriées ci-dessous.

  • Le logiciel en cours d'exécution sur votre serveur Exchange peut être une version d'évaluation qui a expiré. Dans ce cas, il se peut que vous deviez réinstaller Symantec Antivirus. Pour continuer à utiliser le logiciel, vous devez au moins l'activer.

  • Un administrateur peut avoir arrêté involontairement le service Symantec Antivirus. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le.

  • Un ver malveillant, un virus ou un autre programme peut avoir arrêté le service. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le. Si le service continue à s'arrêter inopinément sans événements d'erreur pertinente, vérifiez que l'ordinateur n'est pas infecté par un ver malveillant et, le cas échéant, désinfectez le système.

Il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP (Simple Mail Transfer Protocol) ou sur les serveurs Exchange qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur l'ordinateur Exchange Server qui utilise VSAPI 2.5.

Pour démarrer le service Symantec Antivirus

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service Symantec Antivirus, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de Symantec Antivirus, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service Symantec Antivirus, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

En outre, vous devez exécuter le logiciel antivirus client sur le Bureau de l'utilisateur. Un analyseur au niveau fichier sur le Bureau fournit une protection suffisante si l'une des conditions suivantes est vraie :

  • Vous exécutez un logiciel antivirus conçu pour les systèmes de messagerie qui peut analyser des messages MIME sur la passerelle.

  • Vous exécutez un logiciel antivirus conçu pour les systèmes de messagerie qui peut analyser des messages MIME sur le serveur Exchange.

Pour plus d'informations sur les différents types de programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange Server 2003, voir l'article 823166 de la Base de connaissances Microsoft sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

Pour plus d'informations sur les différents types de programmes d'analyse antivirus généralement utilisés avec Microsoft Exchange 2000 Server, voir l'article 328841 de la Base de connaissances sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

Pour plus d'informations sur la protection renforcée d'un environnement Exchange Server contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).


Alertes de configuration d'analyse antivirus de Symantec Mail Security pour Microsoft Exchange
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started du service SMSMSE (Symantec Mail Security pour Microsoft Exchange).

Une valeur True indique que Symantec Mail Security pour Microsoft Exchange est installé sur cet ordinateur Exchange Server et que le service SMSMSE est en cours d'exécution. Une valeur False indique que le service SMSMSE n'est pas en cours d'exécution.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer si la valeur de la clé Started dans le service de banque d'informations de Microsoft Exchange est définie sur True ou False.

La valeur False indique que le service de banque d'informations de Microsoft Exchange n'est pas en cours d'exécution sur cet ordinateur Exchange Server. La valeur True indique que le service de banque d'informations de Microsoft Exchange est en cours d'exécution.

Si Exchange Server Analyzer détecte que le service de banque d'informations de Microsoft Exchange est en cours d'exécution et que Symantec Mail Security pour Microsoft Exchange est installé mais que le service SMSMSE n'est pas en cours d'exécution, un avertissement s'affiche.

L'une des principales menaces pour votre environnement réside dans les virus transmis par les messages électroniques. Les virus par courrier électronique peuvent attaquer les systèmes informatiques proprement dits ou l'environnement de messagerie en submergeant le système de messages jusqu'à la surcharge. Vous devez veiller à être suffisamment protégé contre les virus dans votre environnement. Vous devez envisager une protection antivirus au niveau du pare-feu, à la passerelle SMTP ou hors de cette dernière, à chaque serveur Exchange et sur chaque client.

Pour supprimer cet avertissement

  1. Démarrez le composant logiciel enfichable Services de Windows sur l'ordinateur Exchange Server.

  2. Dans le volet droit, faites défiler jusqu'au service Symantec Mail Security pour Microsoft Exchange et double-cliquez sur celui-ci.

  3. Vérifiez que la valeur dans la liste déroulante Type de démarrage est définie sur Automatique.

  4. Cliquez sur Démarrer pour démarrer le service Symantec Mail Security pour Microsoft Exchange.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés, puis quittez le composant logiciel enfichable.

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


La mise à jour de Symantec Mail Security pour Microsoft Exchange 4.5 est disponible
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-02-14

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour Savfmsevsapi.dll. Si la valeur de la clé Version indique que le numéro de version est 4.5 pour ce fichier, un avertissement s'affiche.

Un numéro de version de 4.5 pour Savfmsevsapi.dll indique que vous n'exécutez pas la dernière version de Symantec Mail Security pour Microsoft Exchange 4.6x. Une mise à jour logicielle est disponible pour Symantec Mail Security pour Microsoft Exchange 4.6x sur le site Web de Symantec. La mise à niveau vers la version 4.63 ou ultérieure est vivement recommandée et peut améliorer la fiabilité et les performances globales.

Voici quelques problèmes connus rencontrés lors de l'exécution de la version 4.5 de Savfmsevsapi.dll.

  • Les processus de flux de messages du serveur Exchange peuvent rencontrer une diminution des performances lors d'opérations courantes.

  • Les files d'attente SMTP telles que la file d'attente de recherche d'annuaire et de remise locale sont sauvegardées.

  • Le service de banque d'informations Microsoft Exchange ne peut pas être arrêté.

  • Les clients Microsoft Outlook® ne peuvent pas se connecter au serveur Exchange.

  • Les messages envoyés par des clients Outlook prennent beaucoup plus de temps que prévu pour remettre un message au serveur Exchange. Les clients Outlook peuvent ne pas répondre pendant 30 secondes.

Pour supprimer cet avertissement

  1. Visitez la page Support du site Web de Symantec (http://www.symantec.com/techsupp/enterprise/).

  2. Effectuez une mise à niveau vers la version 4.63 ou ultérieure.
Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend Micro ScanMail pour la mise à jour de Microsoft Exchange est disponible
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-01-09

L'outil Microsoft® Exchange Server Analyzer Tool lit la valeur de Registre suivante pour déterminer si un fichier bibliothèque VSAPI (Virus Scanning Application Programming Interface) est enregistré avec la banque d'informations de Microsoft Exchange :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Lorsque ScanMail pour Microsoft Exchange, un produit Trend Micro, est installé sur Exchange 2000 Server ou Exchange Server 2003, l'entrée de Registre Bibliothèque présente une valeur de SMXS3DLL.DLL. Ce fichier bibliothèque exécute plusieurs fonctions relatives à VSAPI dans ScanMail pour Microsoft Exchange.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour SMXS3DLL.DLL. Si la valeur de la clé Version indique que le numéro de version est inférieur à 1174 pour ce fichier, un avertissement s'affiche.

Un numéro de version inférieur à 1174 pour SMXS3DLL.DLL indique que la dernière version de ScanMail pour Microsoft Exchange n'est pas installée. Une mise à jour du logiciel est disponible pour ScanMail pour Microsoft Exchange sur le site Web de Trend Micro. Cette mise à jour est vivement recommandée et peut améliorer la fiabilité et les performances globales.

Pour supprimer cet avertissement

  1. Visitez le site Web de Trend Micro sur le centre des mises à jour de ScanMail pour Microsoft Exchange (http://www.trendmicro.com/download/product.asp?productid=8).

  2. Téléchargez la dernière mise à jour pour votre version de ScanMail pour Microsoft Exchange.

  3. Effectuez une sauvegarde complète de l'ordinateur Exchange Server.

  4. Installez la dernière mise à jour de ScanMail pour Microsoft Exchange.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Trend Micro ServerProtect pour Microsoft Windows est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service SpntSvc. Le service SpntSvc est installé par ServerProtect pour Microsoft Windows, qui est un produit Trend Micro. La valeur True pour la clé Started indique que le service est en cours d'exécution et la valeur False indique qu'il n'est pas en cours d'exécution. Si Exchange Server Analyzer détecte que le service SpntSvc n'est pas démarré, un avertissement s'affiche.

ServerProtect pour Microsoft Windows fournit une analyse antivirus système pour les serveurs, incluant la détection et la suppression de virus en temps réel.

Pour démarrer le service SpntSvc

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service Serveur ServerProtect, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de Serveur ServerProtect, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, sélectionnez Automatique, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service Serveur ServerProtect, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Configuration de Trend ScanMail : les performances peuvent être améliorées
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-09-05

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de TempFileThreshold :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

La valeur de Registre TempFileThreshold est applicable pour l'analyse des pièces jointes et du corps des messages. Si la taille de la pièce jointe ou du corps du message est supérieure à la valeur spécifiée dans la clé TempFileThreshold, le fichier temporaire sera créé sur le disque. Dans le cas contraire, il sera créé dans la mémoire. La valeur par défaut pour TempFileThreshold est de 3 072 kilo-octets (3 Mo).

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur définie pour la clé TotalPhysicalMemory. Cette valeur représente la quantité de mémoire vive (RAM) installée sur l'ordinateur.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut delivContLength des paramètres globaux se trouvant à l'emplacement :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN= Nom_organisation , CN=Paramètres_globaux, CN=Remise_messages

Cet attribut représente la taille maximale des messages SMTP entrants.

Si Exchange Server Analyzer détecte que la valeur de TempFileThreshold est inférieure à 70 % de la taille maximale des messages entrants sur un ordinateur Exchange Server disposant de 1 Go de RAM ou davantage, un avertissement s'affiche.

Cet avertissement indique que la valeur de Registre TempFileThreshold n'est peut-être pas optimisée pour votre environnement. Cette valeur doit être définie de manière à être au moins égale à la taille limite des pièces jointes fixée sur vos serveurs Exchange.

Remarque :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. Dans le volet droit, double-cliquez sur TempFileThreshold.

  4. Entrez une valeur, en kilo-octets, égale à la taille moyenne des messages dans votre organisation. Par exemple, si la taille moyenne des messages est de 10 Mo, vous devez entrer 10240.
Remarque :
De la mémoire système supplémentaire peut être nécessaire si vous augmentez cette valeur. Par exemple, si la valeur « ScanningThreads » est définie sur 8 et la valeur « TempFileThreshold » sur 10240, la mémoire minimale requise pour l'analyse antivirus est de 80 Mo (ScanningThreads * TempFileThreshold).
  1. Fermez l'Éditeur du Registre, puis redémarrez le service ScanMail_RealTimeScan et le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Configuration de Trend ScanMail : la valeur de Registre QuerySender est activée
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-04-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service ScanMail_Action de Trend Micro ScanMail pour Microsoft Exchange. La valeur True indique que le service ScanMail_Action est en cours d'exécution et la valeur False indique qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si ScanMail pour Microsoft Exchange est configuré pour les recherches par caractères génériques dans le service d'annuaire Active Directory® :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\QuerySender

Une valeur de 0 pour l'entrée de Registre QuerySender indique que les recherches par caractères génériques sont désactivées. Une valeur de 1 pour l'entrée de Registre QuerySender indique que les recherches par caractères génériques sont activées.

En outre, Exchange Server Analyzer interroge Active Directory pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détermine que le service ScanMail_Action est en cours d'exécution, que le serveur Exchange compte plus de 100 boîtes aux lettres et que l'entrée de Registre QuerySender n'est pas définie sur 0, un avertissement s'affiche.

Trend Micro ScanMail pour Microsoft Exchange assure la protection antivirus pour Exchange Server. Lorsque ScanMail pour Exchange analyse un message envoyé à une liste de distribution, son comportement par défaut consiste à interroger le catalogue global Active Directory pour tous les destinataires des messages. Si la liste de distribution comporte un grand nombre de destinataires, ce comportement peut créer des problèmes de performances. En outre, les compteurs de performance suivants seront élevés si les recommandations de cet article ne sont pas respectées :

  • Longueur de la file d'attente MSExchangeIS/Virus Scan

  • Demandes MSExchangeIS/RPC

  • Latence moyenne MSExchangeIS/RPC

La définition de la valeur QuerySender sur 0 empêche ScanMail pour Microsoft Exchange d'interroger le catalogue global pour tous les destinataires lors de l'analyse des messages envoyés aux listes de distribution.

Pour supprimer cet avertissement

  1. Contactez Trend Micro pour plus d'informations sur l'utilisation de la valeur de Registre QuerySender (http://www.trendmicro.com/en/about/overview.htm).

  2. Pour plus d'informations sur la valeur de Registre QuerySender, voir la solution Trend Micro n° 120393 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393).

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).


Configuration de Trend ScanMail : le service ScanMail_Monitor ne dépend pas du service de cluster
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante sur chaque serveur étant un nœud de cluster :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Une valeur Version de 6.2.000 indique que la version 6.2 de ScanMail pour Microsoft Exchange est installée.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour ClusSvc, le service de cluster. La valeur True indique que le service de cluster est en cours d'exécution et la valeur False indique qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer lit également l'entrée de Registre suivante sur chaque serveur étant un nœud de cluster :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

Si Exchange Server Analyzer détecte que la clé ScanMail_Monitor ne comprend pas l'entrée de Registre à valeurs multiples DependOnService avec une valeur de ClusSvc, le service ScanMail_Monitor ne dépend pas du service de cluster.

Exchange Server Analyzer affiche un message d'avertissement si les conditions suivantes sont vraies :

  • Le serveur exécute TrendMicro ScanMail pour Microsoft Exchange 6.2.

  • Le serveur exécute le service de cluster (ClusSvc).

  • Le service ScanMail_Monitor n'est pas configuré de manière à dépendre du service de cluster.

Après avoir installé des versions de ScanMail pour Microsoft Exchange 6.2, vous devez configurer le service ScanMail_Monitor pour qu'il dépende du service de cluster. Si vous ne configurez pas cette dépendance, le service de cluster ne répondra plus à chaque redémarrage du nœud.

Pour supprimer cet avertissement

  1. Voir le document sur le service de cluster Microsoft Exchange qui s'arrête inopinément après l'application de ScanMail pour Exchange (SMEX) 6.2 correctif 1 [ID solution : 21441] sur le site Web de Trend Micro (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441).

    Remarque :
    Bien que l'article de l'ID solution 21441 se rapporte spécifiquement à l'exigence de configuration de cette dépendance après l'installation du correctif 1, il s'applique aux serveurs qui exécutent n'importe quelle version de ScanMail pour Microsoft Exchange 6.2.

  2. Ajoutez la valeur de chaînes multiples DependOnService au Registre comme indiqué dans la section « Solutions » de l'article d'ID solution 21441.
Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.

Pour plus d'informations sur d'autres mises à jour de produits Trend Micro, voir le site Web Update Center de Trend Micro (http://www.trendmicro.com/download/).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Configuration de Trend ScanMail : SkipWildcardSearchInGC est définie sur 0
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service ScanMail_Action de Trend Micro ScanMail pour Microsoft Exchange. La valeur True indique que le service ScanMail_Action est en cours d'exécution et la valeur False indique qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si ScanMail pour Microsoft Exchange est configuré pour les recherches par caractères génériques dans le service d'annuaire Active Directory® :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

Une valeur de 1 pour l'entrée de Registre SkipWildcardSearchInGC indique que les recherches par caractères génériques sont désactivées. Une valeur de 0 pour l'entrée de Registre SkipWildcardSearchInGC indique que les recherches par caractères génériques sont activées.

Exchange Server Analyzer interroge Active Directory pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détermine que le service ScanMail_Action est en cours d'exécution, que le serveur Exchange compte plus de 100 boîtes aux lettres et que l'entrée de Registre SkipWildcardSearchInGC est définie sur 0, un avertissement s'affiche.

Trend Micro ScanMail pour Microsoft Exchange assure la protection antivirus pour Exchange Server. Définir la valeur SkipWildcardSearchInGC sur 1 empêche ScanMail pour Microsoft Exchange de corriger un nom contenant un caractère générique (*). Interroger un nom contenant un caractère générique peut considérablement ralentir les performances de l'ordinateur Exchange Server, étant donné que ScanMail pour Exchange vérifie l'ensemble de l'annuaire. En outre, les compteurs de performance suivants seront élevés si les recommandations de cet article ne sont pas respectées :

  • Longueur de la file d'attente MSExchangeIS/Virus Scan

  • Demandes MSExchangeIS/RPC

  • Latence moyenne MSExchangeIS/RPC

Pour supprimer cet avertissement

  1. Contactez Trend Micro pour plus d'informations sur l'utilisation de la valeur de Registre SkipWildcardSearchInGC (http://www.trendmicro.com/en/about/overview.htm).

  2. Pour plus d'informations sur la valeur de Registre SkipWildcardSearchInGC, voir la solution Trend Micro n° 20393 (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=20393).

    Remarque :
    Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).


Configuration de Trend ScanMail : de la valeur de Registre MaxMessageCount est inférieure à 500
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de MaxMessageCount :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

En outre, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer le nombre d'entrées répertoriées dans l'attribut homeMDBBL de chaque banque de boîtes aux lettres. Ce nombre représente le nombre de boîtes aux lettres dans la banque de boîtes aux lettres.

Si Exchange Server Analyzer détermine que le serveur Exchange contient plus de 100 boîtes aux lettres et que la valeur de MaxMessageCount est inférieure à 500, un avertissement s'affiche.

Trend Micro ScanMail pour Microsoft Exchange assure la protection antivirus pour Exchange Server. Dès que la thread d'analyse de ScanMail pour Exchange finit une tâche, elle écrit les résultats de l'analyse dans une file d'attente. Si cette file d'attente contient trop d'éléments, la thread d'analyse doit attendre avant de pouvoir écrire dans cette file d'attente et de relâcher la thread. Le seuil de la taille de la file d'attente des résultats d'analyse est contrôlé par MaxMessageCount. Définir la valeur MaxMessageCount sur 500 optimise les performances de ScanMail pour Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

  3. Dans le volet droit, double-cliquez sur MaxMessageCount.

  4. Entrez la valeur 500 (décimal).

  5. Fermez l'Éditeur du Registre, puis redémarrez le service ScanMail_RealTimeScan et le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre, et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'utilisation de la valeur de Registre MaxMessageCount, voir le site Web de Trend Micro (http://www.trendmicro.com/en/about/overview.htm).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).


Trend ScanMail est configuré pour supprimer tous les fichiers joints
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit plusieurs entrées de Registre pour déterminer si ScanMail pour Microsoft Exchange est configuré pour supprimer toutes les pièces jointes. Les valeurs lues se trouvent dans le Registre à l'emplacement :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Valeur | Description
ActionType | Indique les pièces jointes devant être bloquées lorsque le blocage des pièces jointes est activé. La valeur 0 indique que toutes les pièces jointes sont bloquées. La valeur 3 indique qu'une liste de noms de fichier, d'extensions de nom de fichier ou de types de fichier spécifiques a été spécifiée par l'administrateur. Ce paramètre peut être configuré en sélectionnant l'option appropriée dans la boîte de dialogue Attachment Blocking Settings (Paramètres de blocage des pièces jointes) de la console de gestion ScanMail.
EnableAlert | Indique si le blocage des pièces jointes est activé. La valeur 1 indique que le blocage des pièces jointes est activé. La valeur 0 indique qu'il est désactivé. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable attachment blocking (Activer le blocage des pièces jointes) sur la page Virus Scan (Analyse antivirus) | Options de la console de gestion ScanMail.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Valeur | Description
EnableEManager | Indique si ScanMail eManager est activé. La valeur 1 indique qu'eManager est activé. La valeur 0 indique qu'il est désactivé. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable eManager (Activer eManager) de la console de gestion ScanMail. Ce paramètre est uniquement disponible lorsque ScanMail eManager, un produit associé distinct, est installé.
EnableWebStoreDelMail | Indique si le filtre actif de messages ScanMail est activé pour les messages entrants. La valeur 1 indique que le filtre actif de messages ScanMail est activé pour les messages entrants. La valeur 0 indique qu'il n'est pas activé pour les messages entrants. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Inbound Messages (Messages entrants) dans la boîte de dialogue Active Message Filter (Filtre actif de messages) de la console de gestion ScanMail.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si l'analyse des messages VSAPI (Virus Scanning API) est activée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

La valeur 1 pour Enabled indique que l'analyse VSAPI est activée. La valeur 0 indique que l'analyse VSAPI n'est pas activée. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable VS API virus scanning (Activer l'analyse antivirus VS API) sur la page Virus Scan (Analyse antivirus) | Options de la console de gestion ScanMail.

Si Exchange Server Analyzer détecte que tous les critères suivants sont vrais, un avertissement s'affiche :

  • L'analyse VSAPI est Enabled (activée) dans ScanMail pour Exchange

  • EnableAlert possède la valeur 1

  • ActionType possède la valeur 0

  • EnableEManager possède la valeur 1

  • EnableWebStoreDelMail possède la valeur 1

Cet avertissement indique que ScanMail est configuré pour supprimer toutes les pièces jointes au cours de la prochaine analyse programmée ou manuelle.

Pour supprimer cet avertissement

  1. Vérifiez que vous voulez que les pièces jointes soient supprimées.

  2. Si tel est le cas, désactivez le blocage des pièces jointes ou modifiez l'action de Delete (Supprimer) en Quarantine (Quarantaine). Cela permet à un administrateur d'examiner les fichiers mis en quarantaine pour récupérer ceux devant éventuellement être conservés.

Pour plus d'informations sur ScanMail pour Microsoft Exchange et ScanMail eManager, voir le site Web de Trend Micro (http://www.trend.com/).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Trend ScanMail est configuré pour supprimer les pièces jointes avec des noms de fichier spécifiques
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit plusieurs entrées de Registre pour déterminer si ScanMail pour Microsoft Exchange est configuré pour supprimer les pièces jointes. Les valeurs lues se trouvent dans le Registre à l'emplacement :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Valeur | Description
ActionType | Indique les pièces jointes devant être bloquées lorsque le blocage des pièces jointes est activé. La valeur 0 indique que toutes les pièces jointes sont bloquées. La valeur 3 indique qu'une liste de noms de fichier, d'extensions de nom de fichier ou de types de fichier spécifiques a été spécifiée par l'administrateur. Vous pouvez configurer ce paramètre en sélectionnant l'option souhaitée dans la boîte de dialogue Attachment Blocking Settings (Paramètres de blocage des pièces jointes) de la console de gestion ScanMail.
EnableAlert | Indique si le blocage des pièces jointes est activé. La valeur 1 indique que le blocage des pièces jointes est activé. La valeur 0 indique qu'il est désactivé. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable attachment blocking (Activer le blocage des pièces jointes) sur la page Virus Scan (Analyse antivirus) | Options de la console de gestion ScanMail.
FileName | Une valeur de chaîne délimitée par un point-virgule contient une liste de fichiers à supprimer. Si les fichiers spécifiés doivent être bloqués, vous pouvez configurer ce paramètre en entrant les noms de fichier souhaités dans la boîte de dialogue Attachment Blocking Settings (Paramètres de blocage des pièces jointes) de la console de gestion ScanMail.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Valeur | Description
EnableEManager | Indique si ScanMail eManager est activé. La valeur 1 indique qu'eManager est activé. La valeur 0 indique qu'il est désactivé. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable eManager (Activer eManager) de la console de gestion ScanMail. Ce paramètre est uniquement disponible lorsque ScanMail eManager, un produit associé distinct, est installé.
EnableWebStoreDelMail | Indique si le filtre actif de messages ScanMail est activé pour les messages entrants. La valeur 1 indique que le filtre actif de messages ScanMail est activé pour les messages entrants. La valeur 0 indique qu'il n'est pas activé pour les messages entrants. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Inbound Messages (Messages entrants) dans la boîte de dialogue Active Message Filter (Filtre actif de messages) de la console de gestion ScanMail.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si une analyse de message VSAPI (Virus Scanning API) est activée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

La valeur 1 pour Enabled indique que l'analyse VSAPI est activée. La valeur 0 indique que l'analyse VSAPI n'est pas activée. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable VS API virus scanning (Activer l'analyse antivirus VS API) sur la page Virus Scan (Analyse antivirus) | Options de la console de gestion ScanMail.

Si Exchange Server Analyzer détecte que tous les critères suivants sont vrais, un avertissement s'affiche :

  • L'analyse VSAPI est activée dans ScanMail pour Exchange

  • EnableAlert possède la valeur 1

  • ActionType possède la valeur 3

  • EnableEManager possède la valeur 1

  • EnableWebStoreDelMail possède la valeur 1

  • FileName n'est pas nul ou vide

Cet avertissement indique que ScanMail est configuré pour supprimer toutes les pièces jointes dont le nom est répertorié dans la clé FileName lors de l'analyse manuelle ou planifiée suivante.

Pour supprimer cet avertissement

  1. Vérifiez que vous souhaitez supprimer les pièces jointes dont les noms sont répertoriés dans la clé FileName.

  2. Dans le cas contraire, désactivez le blocage des pièces jointes ou modifiez l'action de Delete (Supprimer) en Quarantine (Quarantaine). Cela permet à un administrateur d'examiner les fichiers mis en quarantaine pour récupérer ceux devant éventuellement être conservés.

Pour plus d'informations sur ScanMail pour Microsoft Exchange et ScanMail eManager, voir le site Web de Trend Micro (http://www.trend.com/).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Trend ScanMail est configuré pour supprimer les pièces jointes avec des extensions de fichier spécifiques
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit plusieurs entrées de Registre pour déterminer si ScanMail pour Microsoft Exchange Server est configuré pour supprimer les pièces jointes. Les valeurs lues se trouvent dans le Registre à l'emplacement :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Valeur | Description
ActionType | Indique les pièces jointes devant être bloquées lorsque le blocage des pièces jointes est activé. La valeur 0 indique que toutes les pièces jointes sont bloquées. La valeur 3 indique qu'une liste de noms de fichier, d'extensions de fichier ou de types de fichier spécifiques a été spécifiée par l'administrateur. Vous pouvez configurer ce paramètre en sélectionnant l'option souhaitée dans la boîte de dialogue Attachment Blocking Settings (Paramètres de blocage des pièces jointes) de la console de gestion ScanMail.
EnableAlert | Indique si le blocage des pièces jointes est activé. La valeur 1 indique que le blocage des pièces jointes est activé. La valeur 0 indique qu'il est désactivé. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable attachment blocking (Activer le blocage des pièces jointes) sur la page Virus Scan (Analyse antivirus) | Options de la console de gestion ScanMail.
Extension | Une valeur de chaîne délimitée par un point-virgule contient une liste d'extensions de fichier des pièces jointes à supprimer. Si les pièces jointes spécifiées doivent être bloquées, vous pouvez configurer ce paramètre en entrant les extensions souhaitées dans la boîte de dialogue Attachment Blocking Settings (Paramètres de blocage des pièces jointes) de la console de gestion ScanMail.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Valeur | Description
EnableEManager | Indique si ScanMail eManager est activé. La valeur 1 indique qu'eManager est activé. La valeur 0 indique qu'il est désactivé. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable eManager (Activer eManager) de la console de gestion ScanMail. Ce paramètre est uniquement disponible lorsque ScanMail eManager, un produit associé distinct, est installé.
EnableWebStoreDelMail | Indique si le filtre actif de messages ScanMail est activé pour les messages entrants. La valeur 1 indique que le filtre actif de messages ScanMail est activé pour les messages entrants. La valeur 0 indique qu'il n'est pas activé pour les messages entrants. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Inbound Messages (Messages entrants) dans la boîte de dialogue Active Message Filter (Filtre actif de messages) de la console de gestion ScanMail.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si une analyse de message VSAPI (Virus Scanning API) est activée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

La valeur 1 pour Enabled indique que l'analyse VSAPI est activée. La valeur 0 indique que l'analyse VSAPI n'est pas activée. Vous pouvez configurer ce paramètre en activant ou en désactivant la case à cocher Enable VS API virus scanning (Activer l'analyse antivirus VS API) sur la page Virus Scan (Analyse antivirus) | Options de la console de gestion ScanMail.

Si Exchange Server Analyzer détecte que tous les critères suivants sont vrais, un avertissement s'affiche :

  • L'analyse VSAPI est Enabled (activée) dans ScanMail pour Exchange

  • EnableAlert possède la valeur 1

  • ActionType possède la valeur 3

  • EnableEManager possède la valeur 1

  • EnableWebStoreDelMail possède la valeur 1

  • Extension n'est pas nul ou vide

Cet avertissement indique que ScanMail est configuré pour supprimer toutes les pièces jointes dont les extensions sont répertoriées dans la clé Extension lors de l'analyse manuelle ou planifiée suivante.

Pour supprimer cet avertissement

  1. Vérifiez que vous souhaitez supprimer les pièces jointes dont les extensions sont répertoriées dans la clé Extension.

  2. Si tel est le cas, désactivez le blocage des pièces jointes ou modifiez l'action de Delete (Supprimer) en Quarantine (Quarantaine). Cela permet à un administrateur d'examiner les fichiers mis en quarantaine pour récupérer ceux devant éventuellement être conservés.

Pour plus d'informations sur ScanMail pour Microsoft Exchange et ScanMail eManager, voir le site Web de Trend Micro (http://www.trend.com/).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Trend ScanMail est configuré pour traiter deux fois les messages
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service ScanMail_RealTimeScan. Une valeur True indique que le service ScanMail_RealTimeScan est démarré et une valeur False, que le service ScanMail_RealTimeScan n'est pas démarré. Le service ScanMail_RealTimeScan est un composant de ScanMail de Trend Micro pour l'application Microsoft Exchange. Trend Micro ScanMail pour Microsoft Exchange assure la protection antivirus pour Exchange.

En outre, Exchange Server Analyzer lit l'entrée de Registre suivante pour déterminer le paramètre pour la valeur Enabled :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Une valeur de 1 pour Enabled indique que l'analyse antivirus au niveau transport (parfois appelée « analyse SMTP » pour Simple Mail Transfer Protocol) est activée et une valeur de 0, que l'analyse SMTP n'est pas activée.

Si Exchange Server Analyzer détecte que Enabled est défini sur la valeur 1 et que la valeur de la clé Started pour le service ScanMail_RealTimeScan est définie sur True, un avertissement s'affiche.

Cet avertissement indique que les messages circulant via cet ordinateur Exchange Server sont analysés deux fois par la même application et le moteur d'analyse antivirus. L'analyse du même message à deux reprises lorsqu'il circule via les composants de transport et de stockage d'Exchange Server consomme inutilement des ressources et n'apporte aucun avantage ni protection supplémentaire. Il est recommandé de laisser l'analyse antivirus VSAPI (Virus Scanning API) activée et de désactiver l'analyse des messages SMTP à l'aide de la console de gestion ScanMail.

En général, il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP ou sur les serveurs Exchange qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur l'ordinateur Exchange Server qui utilise VSAPI 2.5. En outre, vous devez exécuter le logiciel antivirus client sur le Bureau de l'utilisateur. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (il peut analyser des messages MIME) sur la passerelle ou le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur le Bureau est suffisante.

Pour supprimer cet avertissement

  1. Ouvrez la console de gestion ScanMail et entrez vos informations d'identification d'ouverture de session.

  2. Sur la page Virus Scan (Analyse antivirus) | Options, vérifiez que la case à cocher Enable VS API virus scanning (Activer l'analyse antivirus VS API) est activée.

  3. Sur la même page, désactivez la case à cocher Enable SMTP mail scanning (Activer l'analyse des messages SMTP).

  4. Cliquez sur Apply (Appliquer) pour enregistrer vos modifications.

  5. Fermez la console de gestion ScanMail.

Pour plus d'informations sur Trend Micro ScanMail pour Microsoft Exchange, voir le site Web de Trend (http://kb.trendmicro.com/solutions/search).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841).

  • 823166 sur l'aperçu d'Exchange Server 2003 et de logiciels antivirus (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166).

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105).

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822).


Faible nombre de threads Trend ScanMail
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de MaxScanningThreadCount :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

La valeur de Registre MaxScanningThreadCount représente le nombre maximal de threads que ScanMail pour Exchange peut créer pour l'analyse. La valeur par défaut est 12.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si une analyse de message VSAPI (Virus Scanning API) est activée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

La valeur 1 pour Enabled indique que l'analyse VSAPI est activée. La valeur 0 indique que l'analyse VSAPI n'est pas activée.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur définie pour la clé NumberOfProcessors. Cette valeur représente le nombre de processeurs installés sur l'ordinateur, y compris les processeurs physiques et logiques. La technologie Hyper-Threading de Intel permet de diviser un processeur physique en deux processeurs logiques.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer le nombre d'objets avec une classe d'objet de msExchPrivateMDB. Ce nombre représente le nombre de banques de boîtes aux lettres de l'ordinateur Exchange Server.

Si Exchange Server Analyzer détecte que la valeur de MaxScanningThreadCount est inférieure à (2 × NumberOfProcessors + 1) + 3 + le nombre de banques de boîtes aux lettres) sur un ordinateur Exchange Server sur lequel l'analyse VSAPI est activée, un avertissement s'affiche.

Remarque :
S'il est équipé de la technologie Hyper-Threading, la valeur de NumberOfProcessors double le nombre de processeurs physiques. Il est recommandé d'utiliser la formule précédente pour les systèmes équipés de processeurs physiques, de même que pour les systèmes qui disposent de processeurs physiques et logiques.

Cet avertissement indique que la valeur de Registre MaxScanningThreadCount n'est peut-être pas optimisée pour votre environnement. Cette valeur doit être définie de manière à être au moins égale à la taille limite des pièces jointes fixée sur vos serveurs Exchange. Pour plus d'informations sur une valeur de Registre associée, voir l'article Faible nombre de pools de threads Trend ScanMail.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. Dans le volet droit, double-cliquez sur MaxScanningThreadCount.

  4. Entrez une valeur recommandée par Exchange Server Analyzer.

  5. Fermez l'Éditeur du Registre et redémarrez le service ScanMail_RealTimeScan et le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre MaxScanningThreadCount , voir la solution Trend Micro n° 13176 (http://fr.trendmicro-europe.com/enterprise/support/knowledge_base_detail.php).

Pour plus d'informations sur la technologie Hyper-Threading, voir le site Web d'Intel (http://www.intel.com/technology/hyperthread).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Faible nombre de pools de threads Trend ScanMail
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de ScanningThreadPoolCount :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

La valeur de Registre ScanningThreadPoolCount représente le nombre de threads d'analyse qui seront initialisées et préparées pour l'utilisation au démarrage des services ScanMail pour Exchange. La valeur par défaut est 12. Lorsque toutes les threads créées au démarrage sont utilisées, ScanMail pour Exchange crée des threads supplémentaires à utiliser jusqu'à obtention du nombre de threads contrôlées par la valeur de Registre MaxScanningThreadCount décrite dans le document Faible nombre de threads Trend ScanMail.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si l'analyse des messages VSAPI (Virus Scanning API) est activée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

La valeur 1 pour Enabled indique que l'analyse VSAPI est activée. La valeur 0 indique que l'analyse VSAPI n'est pas activée.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_ComputerSystem pour déterminer la valeur définie pour la clé NumberOfProcessors. Cette valeur représente le nombre de processeurs installés sur l'ordinateur, y compris les processeurs physiques et logiques. La technologie Hyper-Threading de Intel permet de diviser un processeur physique en deux processeurs logiques.

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer le nombre d'objets avec une classe d'objet de msExchPrivateMDB. Ce nombre représente le nombre de banques de boîtes aux lettres de l'ordinateur Exchange Server.

Si Exchange Server Analyzer détecte que la valeur de ScanningThreadPoolCount est inférieure à (2 × NumberOfProcessors + 1) + 3 + le nombre de banques de boîtes aux lettres) sur un ordinateur Exchange Server sur lequel l'analyse VSAPI est activée, un avertissement s'affiche.

Remarque :
S'il est équipé de la technologie Hyper-Threading, la valeur de NumberOfProcessors double le nombre de processeurs physiques. Il est recommandé d'utiliser la formule précédente pour les systèmes équipés de processeurs physiques, de même que pour les systèmes qui disposent de processeurs physiques et logiques.

Cet avertissement indique que la valeur de Registre ScanningThreadPoolCount n'est peut-être pas optimisée pour votre environnement. Cette valeur doit être définie de manière à être au moins égale à la taille limite des pièces jointes fixée sur vos serveurs Exchange.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption.

  3. Dans le volet droit, double-cliquez sur ScanningThreadPoolCount.

  4. Entrez une valeur recommandée par Exchange Server Analyzer.

  5. Fermez l'Éditeur du Registre, puis redémarrez le service ScanMail_RealTimeScan et le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la technologie Hyper-Threading, voir le site Web d'Intel (http://www.intel.com/technology/hyperthread).

Remarque :
Les adresses Web pouvant être modifiées, vous risquez de ne pas pouvoir vous connecter aux sites Web susmentionnés.


Trend ScanMail est en mode débogage
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-06-22

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer la valeur de ModuleName :

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

La valeur de Registre ModuleName représente le nom du fichier de module de débogage en cours d'utilisation.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si une analyse de message VSAPI (Virus Scanning API) est activée :

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

La valeur 1 pour Enabled indique que l'analyse VSAPI est activée. La valeur 0 indique que l'analyse VSAPI n'est pas activée.

Si Exchange Server Analyzer détecte que l'analyse VSAPI est activée et que la valeur de Registre ModuleName n'est pas vide ou nulle, un avertissement s'affiche.

L'exécution en mode débogage entraîne une sérieuse dégradation des performances à cause du suivi de diagnostic en arrière-plan. Sauf si vous êtes en train de résoudre activement un problème qui implique d'exécuter ScanMail pour Exchange en mode débogage, vous devez désactiver le mode débogage.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug.

  3. Dans le volet droit, double-cliquez sur ModuleName.

  4. Supprimez les données de valeur pour cette entrée, en laissant la chaîne vide. Ne supprimez pas la clé ModuleName.

  5. Fermez l'Éditeur du Registre et redémarrez le service ScanMail_RealTimeScan et le service de banque d'informations de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052).

Pour plus d'informations sur la vérification de la désactivation du mode débogage, voir la solution Trend Micro n°119149 (http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149).

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Le service d'opération de courrier Trend ScanMail est installé sur ce serveur Exchange, mais le service est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si Trend Micro ScanMail pour Exchange est installé et si le service ScanMail_MailAction est en cours d'exécution sur l'ordinateur Exchange.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer si la valeur de la clé Started dans le service de banque d'informations de Microsoft Exchange est définie sur True ou False.

La valeur False indique que le service de banque d'informations de Microsoft Exchange n'est pas en cours d'exécution sur cet ordinateur Exchange Server. La valeur True indique que le service de banque d'informations de Microsoft Exchange est en cours d'exécution.

Si Exchange Server Analyzer détecte que le service de banque d'informations de Microsoft Exchange est en cours d'exécution et que Trend Micro ScanMail pour Exchange est installé mais que le service ScanMail_MailAction n'est pas démarré, un avertissement s'affiche.

Trend Micro ScanMail pour Exchange assure la protection antivirus pour Exchange Server. Les raisons de l'arrêt du service Trend ScanMail ainsi que les solutions sont répertoriées ci-dessous.

  • Le logiciel en cours d'exécution sur votre serveur Exchange peut être une version d'évaluation qui a expiré. Dans ce cas, il se peut que vous deviez réinstaller Trend ScanMail. Pour continuer à utiliser le logiciel, vous devez au moins l'activer.

  • Un administrateur peut avoir arrêté involontairement le service ScanMail_MailAction. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le.

  • Un ver malveillant, un virus ou un autre programme peut avoir arrêté le service. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le. Si le service continue à s'arrêter inopinément sans événements d'erreur pertinente, vérifiez que l'ordinateur n'est pas infecté par un ver malveillant et désinfectez le système, au besoin.

En général, il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP ou sur les serveurs Exchange qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur le serveur Exchange qui utilise VSAPI 2.5. En outre, vous devez exécuter le logiciel antivirus client sur le Bureau de l'utilisateur. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (il peut analyser des messages MIME) sur la passerelle ou le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur le Bureau est suffisante.

Pour démarrer le service ScanMail_MailAction

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service ScanMail_MailAction, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de ScanMail_MailAction, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, définissez-le sur Automatique, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service ScanMail_RealTimeScan, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.
  • Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?linkid=16226).


Le service en temps réel Trend ScanMail est installé sur ce serveur Exchange, mais le service est arrêté
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si Trend Micro ScanMail pour Microsoft Exchange est installé et si le service ScanMail_RealTimeScan est en cours d'exécution sur l'ordinateur Exchange Server. Si Exchange Server Analyzer détecte que Trend Micro ScanMail pour Microsoft Exchange est installé, mais que le service ScanMail_RealTimeScan n'est pas démarré, un avertissement s'affiche.

Trend Micro ScanMail pour Microsoft Exchange assure la protection antivirus pour Exchange. Vous trouverez ci-dessous certaines raisons pour lesquelles le service ScanMail_RealTimeScan a peut-être été arrêté, ainsi que leurs solutions.

  • Le logiciel en cours d'exécution sur votre serveur Exchange peut être une version d'évaluation qui a expiré. Dans ce cas, vous devez peut-être réinstaller Trend Micro ScanMail pour Microsoft Exchange. Pour continuer à utiliser le logiciel, vous devez au moins l'activer.

  • Un administrateur peut avoir arrêté involontairement le service ScanMail_RealTimeScan. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le.

  • Un ver malveillant, un virus ou un autre programme peut avoir arrêté le service. Vérifiez que le service est configuré pour démarrer automatiquement, puis lancez-le. Si le service continue à s'arrêter inopinément sans événements d'erreur pertinente, vérifiez que l'ordinateur n'est pas infecté par un ver malveillant et désinfectez le système, au besoin.

En général, il est recommandé de déployer le logiciel antivirus conçu pour des systèmes de messagerie sur la passerelle SMTP ou sur les serveurs Exchange qui hébergent des boîtes aux lettres. Pour une protection optimale, exécutez le logiciel antivirus sur la passerelle qui analyse les messages MIME entrants et un analyseur sur l'ordinateur Exchange Server qui utilise VSAPI 2.5. En outre, vous devez exécuter le logiciel antivirus client sur le Bureau de l'utilisateur. Si vous exécutez le logiciel antivirus conçu pour des systèmes de messagerie (il peut analyser des messages MIME) sur la passerelle ou le serveur Exchange, l'exécution d'un analyseur au niveau fichier sur le Bureau est suffisante.

Pour démarrer le service ScanMail_RealTimeScan

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Cliquez avec le bouton droit sur le service ScanMail_RealTimeScan, puis cliquez sur Propriétés.

  3. Sous l'onglet Général de la page de propriétés de ScanMail_RealTimeScan, assurez-vous que Type de démarrage est défini sur Automatique. Dans le cas contraire, définissez-le sur Automatique, cliquez sur Appliquer, puis sur OK.

  4. Cliquez avec le bouton droit sur le service ScanMail_RealTimeScan, puis cliquez sur Démarrer.

  5. Fermez le composant logiciel enfichable Services.
  • Pour plus d'informations sur la protection renforcée d'un environnement Exchange contre des vers et des virus transmis par courrier électronique, voir l'article sur le ralentissement et l'arrêt des virus de messagerie dans un environnement Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=47587).

Pour plus d'informations sur l'utilisation d'un logiciel antivirus avec Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 328841 sur Exchange et les logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841)

  • 823166 sur l'aperçu d'Exchange Server 2003 et des logiciels antivirus (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166)

  • 306105 sur la position de Microsoft concernant les solutions antivirus pour Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105)

  • 245822 sur les recommandations pour dépanner un ordinateur Exchange avec un logiciel antivirus installé (http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822)

Pour une liste de logiciels tiers antivirus disponibles pour Exchange Server, voir le site Web Exchange Server Partners sur les antivirus (http://go.microsoft.com/fwlink/?LinkId=16226).


Désactivation des compléments tiers sur le client
Microsoft Exchange Server Analyzer - Articles > Logiciel tiers >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool a déterminé que vous exécutez l'un des types de logiciel tiers suivants :

  • un complément tiers Microsoft Office Outlook®, comme un logiciel antivirus ou de télécopie ;

  • une application tierce qui accède à votre serveur Exchange ;

  • un logiciel de synchronisation tiers pour périphériques mobiles.

Il est recommandé de rechercher les types d'applications tierces exécutées par vos utilisateurs, puis de décider si vous voulez imposer des limites à ces applications ou les supprimer complètement. Rappelez-vous que l'exécution de logiciels tiers peut fréquemment provoquer des charges excessives sur vos serveurs.

Pour désactiver des compléments tiers dans Outlook

  1. Dans Outlook, dans le menu Outils , cliquez sur Options.

  2. Dans Options, cliquez sur l'onglet Autre, puis cliquez sur Options avancées.

  3. Dans Options avancées, cliquez sur Gestionnaire de compléments.

  4. Désactivez les cases à cocher pour chaque complément tiers.

  5. Cliquez sur OK.

  6. Redémarrez Outlook.

Pour plus d'informations

  • Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Pour plus d'informations sur la résolution des problèmes de performances d'Exchange Server, voir le document sur le dépannage des problèmes de performances de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).


Transport
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2005-11-18

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant les composants de transport Exchange. En outre, ils décrivent les actions possibles pour corriger les erreurs liées au transport, les avertissements et les configurations autres que celles par défaut détectés par Exchange Server Analyzer.


8BITMIME non enregistré
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-18

L'outil Microsoft® Exchange Server Analyzer Tool transmet le verbe de commande ESMTP (EHLO Extended Simple Mail Transfer Protocol) au port 25 d'un serveur distant et analyse la réponse pour déterminer si le serveur distant prend en charge le verbe ESMTP 8BITMIME.

Si la réponse reçue du serveur distant ne comprend pas la chaîne « 250-8BITMIME », Exchange Server Analyzer affiche un avertissement.

Exchange Server 2003 utilise des verbes SMTP étendus spécifiques à Exchange pour communiquer avec d'autres serveurs utilisant Exchange Server dans l'organisation. Il est plus efficace de communiquer avec des verbes SMTP étendus spécifiques à Exchange que d'utiliser le protocole SMTP standard. Si la prise en charge de l'ensemble de commandes ESMTP est désactivée, les performances d'Exchange Server risquent d'être altérées.

Cette erreur indique que le serveur distant ne prend pas en charge le verbe de commande ESMTP 8BITMIME. Elle ne signifie pas que le serveur distant est ou n'est pas un serveur Exchange. Dans les deux cas, les messages qui nécessitent l'extension 8BITMIME ne sont pas routés.

Pour résoudre ce problème, vérifiez le contenu des files d'attente SMTP à la recherche de messages qui nécessitent l'extension 8BITMIME.

Pour plus d'informations sur la procédure de suppression ou de restauration de la prise en charge par défaut de ces verbes, voir l'article 257569 de la Base de connaissances Microsoft sur la procédure de désactivation des verbes ESMTP dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Pour plus d'informations sur la manière dont Exchange Server utilise les verbes de commande ESMTP, voir la section sur la procédure de chargement correct de SMTP Exchange du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=71800)


ADAM LDAP Port Identified
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-07-23

L'outil Microsoft Exchange Analyzer Tool lit les entrées de Registre suivantes pour déterminer les ports utilisés par le service d'annuaire Active Directory Application Mode (ADAM) sur le serveur de transport Edge :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM est un service d'annuaire LDAP (Lightweight Directory Access Protocol) conçu spécifiquement en vue d'une utilisation avec des applications compatibles avec l'annuaire. ADAM ne stocke et réplique que les informations spécifiques aux applications ; il ne nécessite pas de déploiement sur un contrôleur de domaine et ne dépend pas du service d'annuaire Active Directory. ADAM ne fournit pas d'authentification ni d'autorisation de système d'exploitation de réseau.

Dans Microsoft Exchange Server 2007, le rôle serveur de transport Edge utilise ADAM pour stocker des informations de configuration et des données sur le destinataire pour le filtrage du contenu. Lorsque ADAM est synchronisé avec Active Directory, il peut également permettre d'effectuer une recherche de destinataires pour la sécurité des messages.

Si des données sont envoyées d'Active Directory vers ADAM, elles sont envoyées à l'aide d'une connexion LDAP via les ports suivants qui ne sont pas définis par défaut :

  • LDAP : Port 50389/TCP

  • LDAP sécurisé : Port 50636/UDP

Lorsqu'Exchange Analyzer identifie les ports utilisés par ADAM, il affiche un message de recommandation.

Nous recommandons de bloquer l'accès de l'extérieur à tous les ports qui ne sont pas essentiels.

Pour résoudre ce problème, vérifiez que les ports identifiés par Exchange Analyzer comme étant utilisés pour ADAM n'autorisent pas l'accès de l'extérieur.

Attention :
Le port 50636/UDP est utilisé pour le service Exchange EdgeSync et doit rester ouvert si la fonctionnalité EdgeSync est souhaitée.
Pour bloquer l'accès de l'extérieur aux ports ADAM identifiés à l'aide du Pare-feu Windows

  1. Cliquez sur Démarrer, Exécuter, tapez firewall.cpl, puis cliquez sur OK.

  2. Cliquez sur l'onglet Exceptions.

  3. Sélectionnez chaque programme ou service répertorié dans la zone Nom, puis cliquez sur Modifier pour savoir quels ports sont ouverts.

  4. Vérifiez que les ports rapportés par Exchange Analyzer comme étant utilisés pour ADAM ne sont pas répertoriés.

  5. Si les ports identifiés sont répertoriés, veillez à ce qu'ils ne soient pas utilisés pour d'autres communications nécessaires et fermez-les en les désélectionnant dans la fenêtre Modifier un service.

  6. Cliquez sur OK à deux reprises pour quitter la configuration du Pare-feu Windows.

Pour plus d'informations

Pour plus d'informations sur les ports, l'authentification et le chiffrement de tous les chemins de données utilisés par Exchange 2007, voir le document sur la référence de sécurité du chemin de données (http://go.microsoft.com/fwlink/?LinkId=95630).


Plug-in antivirus installé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-18

L'outil Microsoft® Exchange Server Analyzer Tool recherche l'entrée de Registre suivante pour déterminer si le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est installé :

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

La présence de cette branche de Registre indique que le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est installé sur le serveur qui exécute Exchange Server.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est activé :

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

La valeur 1 pour OnOff indique que le plug-in Auto Protect est activé. La valeur 0 indique qu'il ne l'est pas.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est installé.

  • Le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est activé.

Cet avertissement indique que l'installation et la configuration du plug-in doivent être revues par rapport aux recommandations du fournisseur actuel.

Pour plus d'informations sur les recommandations du fournisseur concernant ce plug-in, voir le site Web sur les recommandations relatives à Symantec AntiVirus Corporate Edition 9.x Auto-Protect sur un serveur Microsoft Exchange (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Plug-in antivirus activé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-18

L'outil Microsoft® Exchange Server Analyzer Tool recherche l'entrée de Registre suivante pour déterminer si le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est installé.

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

La présence de cette entrée de Registre indique que le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est installé sur le serveur qui exécute Exchange Server.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est activé.

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

La valeur 1 pour OnOff indique que le plug-in Auto Protect est activé. La valeur 0 indique qu'il ne l'est pas.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est installé.

  • Le plug-in Symantec Antivirus Corporate Edition 9.x Internet E-Mail Auto Protect est activé.

Cette erreur indique que l'installation et la configuration du plug-in doivent être revues par rapport aux recommandations du fournisseur actuel.

Pour plus d'informations sur les recommandations du fournisseur concernant ce plug-in, voir le site Web sur les recommandations relatives à Symantec AntiVirus Corporate Edition 9.x Auto-Protect sur un serveur Microsoft Exchange (http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam).

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


La journalisation Cci est activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la journalisation Cci (copie conforme invisible) est activée :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

Si Exchange Server Analyzer détecte que la valeur de JournalBCC est définie sur 1, il affiche un message indiquant une configuration autre que celle par défaut.

La journalisation Cci est une journalisation des messages uniquement avec possibilité de capturer les destinataires Cci. Lorsque la journalisation Cci est activée, Exchange Server capture tous les destinataires, y compris ceux en copie conforme invisible, connus sur le serveur d'origine. Si cette liste de destinataires contient des listes de distribution masquées, des listes de distribution fondées sur une requête ou des listes de distribution développées sur un autre serveur, les destinataires de ces listes ne figurent pas dans la messagerie journalisée.

Pour activer la fonctionnalité de journalisation Cci, vous devez définir une clé de Registre. Pour plus d'informations sur la définition de cette clé de Registre, voir l'article 810999 de la Base de connaissances Microsoft sur la perte d'informations Cci pour les messages journalisés dans Exchange 2000 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999).

Avant de pouvoir activer la journalisation Cci sur un serveur spécifique, vous devez configurer la journalisation des messages uniquement. Le paramètre JournalBCC n'est pas actif lorsque les conditions suivantes existent :

  • Le Registre JournalBCC est défini sur 1.

  • La journalisation des messages uniquement n'est activée sur aucune base de données d'un même serveur.

Les messages de journalisation peuvent utiliser beaucoup de ressources disque, réseau et processeur. Par conséquent, la journalisation nécessite une planification approfondie du déploiement. La journalisation doit être activée uniquement dans le cadre d'une structure de solution de journalisation globale.

Ignorez ce message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • Vos activités nécessitent une journalisation.

  • Vous avez déployé une structure de solution de journalisation.

Dans le cas contraire, vous devez désactiver la fonctionnalité de journalisation. En désactivant la journalisation au niveau de la base de données, vous désactivez globalement la journalisation.

Pour désactiver la journalisation des messages uniquement dans une base de données

  1. Dans le Gestionnaire système Exchange, développez Serveurs, <votre serveur Exchange>, <groupe de stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres.

  2. Sous l'onglet Général, désactivez la case à cocher Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque.

  3. Attendez 15 minutes pour que la banque Exchange applique les modifications. Vous ne devez pas redémarrer le service de banque d'informations de Microsoft Exchange.

Si vous souhaitez qu'Exchange Server Analyzer n'affiche plus ce message, vous devez désactiver la clé de Registre JournalBCC. Il n'est pas nécessaire de supprimer la clé de Registre JournalBCC pour désactiver la fonctionnalité de journalisation.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer la clé de Registre JournalBCC

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. Dans le volet droit, recherchez la valeur JournalBCC et supprimez-la.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le déploiement d'une solution de journalisation, voir le document sur la journalisation à l'aide d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


BDAT non enregistré
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-18

L'outil Microsoft® Exchange Server Analyzer Tool transmet le verbe de commande ESMTP (EHLO Extended Simple Mail Transfer Protocol) au port 25 d'un serveur distant et analyse la réponse pour déterminer si le serveur distant prend en charge le verbe ESMTP BDAT.

Si Exchange Server Analyzer reçoit une réponse contenant un chaîne qui indique une erreur irrécupérable de la part du serveur distant, il affiche une erreur.

Exchange Server 2003 utilise des verbes SMTP étendus spécifiques à Exchange pour communiquer avec d'autres serveurs utilisant Exchange Server dans l'organisation. Il est plus efficace de communiquer avec des verbes SMTP étendus spécifiques à Exchange que d'utiliser le protocole SMTP standard. Si la prise en charge de l'ensemble de commandes ESMTP est désactivée, les performances d'Exchange Server risquent d'être altérées.

Cette erreur indique que le serveur distant ne prend pas en charge le verbe de commande ESMTP BDAT. Elle ne signifie pas que le serveur distant est ou n'est pas un serveur Exchange. Dans les deux cas, les messages qui nécessitent l'extension BDAT ne sont pas routés.

Pour résoudre ce problème, vérifiez le contenu des files d'attente SMTP à la recherche de messages qui nécessitent l'extension BDAT.

Pour plus d'informations sur la procédure de suppression ou de restauration de la prise en charge par défaut de ces verbes, voir l'article 257569 de la Base de connaissances Microsoft sur la procédure de désactivation des verbes ESMTP dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Pour plus d'informations sur la manière dont Exchange Server utilise les verbes de commande ESMTP, voir la section sur la procédure de chargement correct de SMTP Exchange du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=71800).


Le serveur tête de pont doit vérifier les restrictions de remise des groupes de distribution pour les connecteurs de groupe de routage
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet de connecteur de groupe de routage msExchRoutingGroupConnector détecté dans le service d'annuaire Active Directory® pour déterminer si des restrictions de remise sont définies sur la base de l'appartenance au groupe de distribution.

dLMemRejectPerms | Contient les noms de domaine d'une liste de distribution dont les membres ne peuvent pas effectuer d'envois via ce connecteur de groupe de routage.
dLMemSubmitPerms | Contient les noms de domaine d'une liste de distribution dont les membres peuvent effectuer des envois via ce connecteur de groupe de routage.

Si Exchange Server Analyzer détecte des connecteurs de groupe de routage ayant des restrictions de remise sur la base de l'appartenance au groupe de distribution, il interroge l'attribut msExchSourceBridgeheadServersDN des connecteurs du groupe de routage détectés pour déterminer si le serveur en cours d'analyse est défini comme serveur tête de pont pour l'un de ces connecteurs.

Enfin, Exchange Server Analyzer lit la clé de Registre suivante pour déterminer si la valeur de Registre CheckConnectorRestrictions est présente et configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Un connecteur de groupe de routage permet de définir des restrictions de remise sur la base de l'appartenance au groupe de distribution.

  • Le serveur Exchange en cours d'analyse est désigné comme serveur tête de pont pour ce connecteur de groupe de routage et a pour tâche de développer le groupe de distribution.

  • La clé CheckConnectorRestrictions est présente, définie sur 1 et donc activée.

Les comportements par défaut du catégoriseur consistent à développer de manière récurrente les groupes de distribution et à vérifier les restrictions pour chaque message qui passe par le système.

Lorsque vous créez un groupe de routage, vous désignez un groupe de serveurs pouvant communiquer directement entre eux. Pour que les serveurs de différents groupes de routage puissent communiquer entre eux, vous devez connecter les groupes de routage.

La méthode de connexion préférée est un connecteur de groupe de routage car ce connecteur est désigné et prévu spécifiquement pour la connexion de groupes de routage.

Les serveur qui peuvent envoyer du courrier via un connecteur de groupe de routage sont les serveurs têtes de pont. Un serveur tête de pont est une combinaison d'un serveur virtuel SMTP (Simple Mail Transfer Protocol) et d'un serveur Exchange responsable de la remise de tous les messages via un connecteur.

Lorsque vous créez un connecteur de groupe de routage, vous pouvez choisir de garder tous les serveurs comme serveurs têtes de pont pour ce connecteur ou spécifier que seuls quelques serveurs sélectionnés servent de serveurs têtes de pont pour ce connecteur. Les têtes de pont désignées sont les serveurs qui ont pour tâche de développer l'appartenance au groupe de distribution.

Lorsque vous envoyez du courrier à l'aide de connecteurs de groupe de routage pour lesquels des restrictions de remise sont définies sur la base de l'appartenance au groupe de distribution, le catégoriseur de messages doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas de correspondance d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

Cet avertissement indique que les restrictions de remise sur la base de l'appartenance au groupe de distribution peuvent provoquer des messages destinés à la mise en file d'attente par la tête de pont pendant que le catégoriseur vérifie les restrictions.

Pour supprimer cet avertissement :

  • Configurez le connecteur de groupe de routage en groupe de routage local comme décrit dans l'article 329171 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Utilisez un serveur de catalogue global dédié et plus robuste comme serveur tête de pont désigné pour le connecteur.

  • Configurez les boîtes aux lettres individuelles et pas les groupes de distribution pour les restrictions de remise comme décrit dans l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Envisagez la mise en œuvre du filtrage des expéditeurs SMTP.

  • Pour les serveurs qui exécutent Microsoft Exchange Server 2003 Service Pack 2 (SP2) ou version ultérieure, envisagez la mise en œuvre de la vérification des restrictions non hiérarchiques. Pour les serveurs qui exécutent des versions d'Exchange antérieures à Exchange 2003 SP2, envisagez la mise à niveau vers Exchange 2003 SP2.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur le filtrage des expéditeurs SMTP, voir la section sur la procédure d'activation du filtrage des expéditeurs dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=71832).

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 329171 sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Le serveur tête de pont doit vérifier les restrictions de remise des groupes de distribution pour les connecteurs SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet de connecteur SMTP (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector) détecté dans le service d'annuaire Active Directory® pour déterminer si des restrictions de remise sont définies sur la base de l'appartenance au groupe de distribution.

dLMemRejectPerms | Contient les noms de domaine d'une liste de distribution dont les membres ne peuvent pas effectuer d'envois via ce connecteur SMTP.
dLMemSubmitPerms | Contient les noms de domaine d'une liste de distribution dont les membres peuvent effectuer des envois via ce connecteur SMTP.

Si Exchange Server Analyzer détecte des connecteurs SMTP ayant des restrictions de remise sur la base de l'appartenance au groupe de distribution, il interroge l'attribut msExchSourceBridgeheadServersDN des connecteurs SMTP détectés pour déterminer si le serveur en cours d'analyse est défini comme serveur tête de pont pour l'un de ces connecteurs.

Enfin, Exchange Server Analyzer lit la clé de Registre suivante pour déterminer si la valeur de Registre CheckConnectorRestrictions est présente et configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Un connecteur SMTP permet de définir des restrictions de remise sur la base de l'appartenance au groupe de distribution.

  • Le serveur Exchange en cours d'analyse est désigné comme serveur tête de pont pour ce connecteur SMTP et a pour tâche de développer le groupe de distribution.

  • La clé CheckConnectorRestrictions est présente, définie sur 1 et donc activée.

Les comportements par défaut du catégoriseur consistent à développer de manière récurrente les groupes de distribution et à vérifier les restrictions pour chaque message qui passe par le système.

Lorsque vous envoyez du courrier à l'aide d'un connecteur qui accepte ou refuse des messages d'un groupe de distribution, le catégoriseur de messages doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas de correspondance d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

La tête de pont désignée est le serveur qui a pour tâche de développer l'appartenance au groupe de distribution.

La vérification des restrictions est contrôlée par la valeur de Registre CheckConnectorRestrictions qui doit être définie sur le serveur tête de pont Exchange qui est la source du connecteur en cours de vérification. Si vous spécifiez une restriction mais ne créez pas la valeur de Registre CheckConnectorRestrictions, la restriction n'est pas vérifiée.

Par défaut, la vérification des restrictions du connecteur est désactivée. Les performances du système sont considérablement affectées si les groupes de distribution sont développés et les restrictions vérifiées pour chaque message passant par le système.

Cet avertissement indique que les restrictions de remise sur la base de l'appartenance au groupe de distribution peuvent provoquer des messages destinés à la mise en file d'attente par la tête de pont pendant que le catégoriseur vérifie les restrictions.

Pour supprimer cet avertissement :

  • Désignez un groupe de routage dédié pour les restrictions de connecteur et configurez-le dans un groupe de routage local comme indiqué dans l'article 329171 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Utilisez un serveur de catalogue global dédié et plus robuste comme serveur tête de pont désigné pour le connecteur.

  • Configurez les boîtes aux lettres individuelles et pas les groupes de distribution pour les restrictions de remise comme décrit dans l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Envisagez la mise en œuvre du filtrage des expéditeurs SMTP.

  • Pour les serveurs qui exécutent Microsoft Exchange Server 2003 Service Pack 2 (SP2) ou version ultérieure, envisagez la mise en œuvre de la vérification des restrictions non hiérarchiques. Pour les serveurs qui exécutent des versions d'Exchange antérieures à Exchange 2003 SP2, envisagez la mise à niveau vers Exchange 2003 SP2.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur le filtrage des expéditeurs SMTP, voir la section sur la procédure d'activation du filtrage des expéditeurs dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=71832).

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 329171 sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Connexion impossible au maître de routage du port 25
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-24

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchRoutingMasterDN de chaque groupe de routage du groupe d'administration actuel. Exchange Server Analyzer tente ensuite d'ouvrir une connexion de socket sur le maître de routage du port TCP 25. Si Exchange Server Analyzer ne reçoit pas une réponse personnalisée prévue de 25 Available, une erreur s'affiche.

Cette erreur indique que le maître de routage n'est pas accessible sur le port TCP 25 et que, par conséquent, le routage peut échouer. Pour corriger cette erreur, vous pouvez résoudre le problème de connectivité à l'aide du maître de routage ou attribuer un nouveau maître de routage.

Pour résoudre le problème de connectivité à l'aide du maître de routage

  1. Pouvez-vous utiliser Telnet sur le port 25 à partir du maître de routage ? Si ce n'est pas le cas, le problème ne se situe pas au niveau du réseau.

  2. Tous les éléments sont-ils connectés ? Votre matériel fonctionne-t-il correctement ?

  3. Le DNS fonctionne-t-il et est-il configuré correctement ?

  4. Votre routeur fonctionne-t-il correctement ?

  5. Des pare-feu ou applications des vous empêchent-ils de vous connecter ?
Pour attribuer un nouveau maître de routage

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez avec le bouton droit sur l'icône Organisation (Exchange) dans le haut de l'arborescence du volet gauche (où Organisation correspond au nom sélectionné pour votre organisation Exchange 2000), puis cliquez sur Propriétés.

  3. Cliquez sur Afficher les groupes d'administration, sur Afficher les groupes de routage, puis sur OK.

  4. Développez Groupes d'administration, <Groupe_administration>, puis Groupes de routage.

  5. Développez le groupe de routage, puis cliquez sur Membres.

  6. Dans le volet droit, cliquez avec le bouton droit sur l'ordinateur Exchange que vous souhaitez configurer comme maître de groupe de routage et cliquez sur Définir un maître.

Pour plus d'informations sur la résolution des problèmes de routage, sur la configuration des topologies de routage et sur les concepts de routage avancés, voir la section sur la résolution des problèmes de routage du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Connexion impossible au maître de routage du port 691
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-24

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchRoutingMasterDN de chaque groupe de routage du groupe d'administration actuel. Exchange Server Analyzer tente ensuite d'ouvrir une connexion de socket sur le maître de routage du port TCP 691. Si Exchange Server Analyzer ne reçoit pas une réponse personnalisée prévue de 691 Available, une erreur s'affiche.

Cette erreur indique que le maître de routage n'est pas accessible sur le port TCP 691 et que, par conséquent, le routage peut échouer. Pour corriger cette erreur, vous pouvez résoudre le problème de connectivité à l'aide du maître de routage ou attribuer un nouveau maître de routage.

Pour résoudre le problème de connectivité à l'aide du maître de routage

  1. Pouvez-vous utiliser Telnet sur le port 691 à partir du maître de routage ? Si ce n'est pas le cas, le problème ne se situe pas au niveau du réseau.

  2. Tous les éléments sont-ils connectés ? Votre matériel fonctionne-t-il correctement ?

  3. Le DNS fonctionne-t-il et est-il configuré correctement ?

  4. Votre routeur fonctionne-t-il correctement ?

  5. Des pare-feu vous empêchent-ils de vous connecter ?
Pour attribuer un nouveau maître de routage

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez avec le bouton droit sur l'icône Organisation (Exchange) dans le haut de l'arborescence du volet gauche (où Organisation correspond au nom sélectionné pour votre organisation Exchange 2000), puis cliquez sur Propriétés.

  3. Cliquez sur Afficher les groupes d'administration, sur Afficher les groupes de routage, puis sur OK.

  4. Développez Groupes d'administration, <Groupe_administration>, puis Groupes de routage.

  5. Développez le groupe de routage, puis cliquez sur Membres.

  6. Dans le volet droit, cliquez avec le bouton droit sur l'ordinateur Exchange que vous souhaitez configurer comme maître de groupe de routage et cliquez sur Définir un maître.

Pour plus d'informations sur la résolution des problèmes de routage, sur la configuration des topologies de routage et sur les concepts de routage avancés, voir la section sur la résolution des problèmes de routage du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Enregistrements d'hôte ou MX introuvables
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-05-10

L'outil Microsoft Exchange Analyzer effectue une recherche DNS (Domain Name System) pour récupérer les enregistrements de serveur de messagerie (MX) pour un domaine. Si Exchange Analyzer ne peut pas récupérer d'enregistrements MX pour un domaine à partir du serveur DNS, il tente d'effectuer une recherche DNS pour récupérer les enregistrements d'hôte (A) des domaines auxquels le serveur Exchange tente d'envoyer des messages.

Exchange Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Exchange Analyzer ne peut pas récupérer d'enregistrements MX pour un domaine.

  • L'opération de recherche DNS échoue lors du renvoi d'une adresse IP pour l'un des enregistrements d'hôte (A).

Cette erreur indique que les enregistrements d'hôte (A) et de serveur de messagerie (MX) DNS semblent être manquants pour le domaine et les serveurs. Cette erreur risque d'entraîner la sauvegarde des messages destinés aux domaines distants dans les files d'attente Remise distante du serveur Exchange, ajoutant ainsi aux autres retards de routage et de service.

Pour identifier les hôtes de messagerie, le serveur Exchange expéditeur recherche un enregistrement MX. Ensuite, il le résout en une adresse IP en recherchant un enregistrement d'adresse (enregistrement A).

La recherche DNS des enregistrements d'hôte (A) et de serveur de messagerie (MX) peut échouer pour les raisons suivantes :

  • Le serveur DNS est arrêté ou inaccessible en raison d'une défaillance du réseau ou pour d'autres motifs.

  • L'enregistrement d'hôte (A) pour le serveur distant est manquant du serveur DNS car il n'est pas disponible ou correct.

  • Le serveur DNS n'est pas configuré pour autoriser les mises à jour dynamiques de l'enregistrement d'hôte.

  • Le système tente d'envoyer des notifications d'échec de remise en réponse aux messages indésirables qui peuvent masquer leurs domaines d'origine. Si c'est le cas, vous devez supprimer ces messages. Consultez le lien relatif à l'outil de suppression et d'archivage des messages incorrects dans Exchange Server dans la section Pour plus d'informations de cet article.

Pour vérifier que le serveur DNS est en ligne et que les enregistrements d'hôte et MX sont présents

  1. Pour vérifier que le serveur DNS est en cours d'exécution, effectuez au moins l'une des vérifications suivantes :

    • Examinez l'état du serveur DNS à partir du programme d'administration DNS sur le serveur DNS.

    • Redémarrez le serveur DNS. Pour plus d'informations, voir la rubrique sur le démarrage, l'arrêt, la mise en pause ou le redémarrage d'un serveur DNS (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Vérifiez le temps de réponse du serveur DNS à l'aide de la commande nslookup. Pour plus d'informations, voir les instructions de la rubrique sur la vérification du temps de réponse du serveur DNS à l'aide de la commande nslookup (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. La commande nslookup permet de vérifier que les enregistrements de serveur de messagerie (MX) sont correctement configurés. Pour plus d'informations, voir la rubrique sur l'utilisation de Nslookup pour vérifier la configuration de l'enregistrement MX dans la section sur la vérification de la conception et de la configuration DNS du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  3. nslookup permet de vérifier que l'enregistrement d'hôte (A) existe sur le serveur DNS. Pour plus d'informations, voir la rubrique sur la procédure de vérification de l'existence d'une ressource A dans DNS (http://go.microsoft.com/fwlink/?LinkId=63001).

  4. Si l'enregistrement de ressource d'hôte (A) n'existe pas, ajoutez ou modifiez manuellement l'enregistrement de la ressource A ou configurez le serveur DNS pour activer les mises à jour dynamiques de l'enregistrement.

    • Ajoutez manuellement un enregistrement de ressource A. Pour plus d'informations, voir la rubrique sur l'ajout d'un enregistrement de ressource à une zone DNS (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifiez manuellement un enregistrement de ressource A. Voir les instructions de la rubrique sur la modification d'un enregistrement de ressource existant (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Configurez le serveur DNS de sorte qu'il active les mises à jour dynamiques de l'enregistrement d'hôte. Pour plus d'informations, voir l'article 816592 de la Base de connaissances Microsoft sur la procédure de configuration de la mise à jour dynamique du DNS sous Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Pour plus d'informations

  • Pour plus d'informations sur l'utilisation de DNS par Exchange Server 2003 pour résoudre les adresses IP externes, voir la rubrique sur les dépendances de transport pour Exchange Server 2003 du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Pour plus d'informations sur la résolution de nom DNS, voir l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Pour plus d'informations sur la procédure de résolution des problèmes de DNS, voir la rubrique sur la résolution des problèmes de DNS (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Pour plus d'informations sur la surveillance du système d'Exchange Server 2003, voir la rubrique sur la surveillance du système avec le pack de gestion d'Exchange du pack de gestion d'Exchange Server 2003 pour MOM 2005 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Pour plus d'informations sur les enregistrements de ressource d'hôte (A), voir la rubrique sur la gestion des enregistrements de ressource (http://go.microsoft.com/fwlink/?LinkId=63004).

  • Pour plus d'informations sur l'outil de suppression et d'archivage des messages incorrects dans Exchange Server, consultez la page sur la suppression et l'archivage des messages incorrects dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=84239).


Impossible d'identifier l'expéditeur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-08

L'outil Microsoft® Exchange Server Analyzer Tool interroge la valeur de l'attribut proxyAddress du service d'annuaire Active Directory® pour tous les objets utilisateur afin de déterminer si une correspondance existe pour l'adresse SMTP (Simple Mail Transfer Protocol) de l'expéditeur local spécifié par l'utilisateur.

Si Exchange Server Analyzer ne trouve pas de correspondance proxyAddress pour l'adresse SMTP de l'expéditeur local spécifié par l'utilisateur, il affiche une erreur.

Cette erreur indique qu'une des conditions suivantes est vraie :

  • L'expéditeur local n'existe pas l'organisation Exchange Server locale.

  • L'adresse SMTP de l'expéditeur local spécifié par l'utilisateur a été entrée de manière incorrecte.

Pour résoudre cette erreur, vérifiez l'adresse SMTP de l'expéditeur local spécifié et réessayez l'opération.

Pour vérifier l'adresse de l'expéditeur local

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Destinataires, puis Toutes les listes d'adresses globales.

  3. Cliquez avec le bouton droit sur Liste d'adresses globale par défaut et sélectionnez Propriétés.

  4. Cliquez sur Aperçu pour afficher les adresses SMTP des destinataires figurant dans la Liste d'adresses globale par défaut.

  5. Vérifiez que l'expéditeur local spécifié est affiché et notez l'adresse SMTP.


Récepteur d'événements CatDbgSink installé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les données trouvées dans la propriété LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes de la métabase IIS (Internet Information Services) pour déterminer si l'application de diagnostic de flux de messagerie CatDbgSink est installée sur un ordinateur Exchange 2000 Server ou Exchange Server 2003.

L'application CatDbgSink est un récepteur d'événements pouvant être utilisé pour la résolution de problèmes de flux de messagerie sur des ordinateurs Exchange 2000 Server ou Exchange Server 2003. Si l'application CatDbgSink est installée sur le serveur Exchange, Exchange Server Analyzer affiche un message d'avertissement indiquant que l'application CatDbgSink est installée et doit être utilisée uniquement pour la résolution de problèmes de flux de messagerie.

L'application CatDbgSink est généralement envoyée aux clients pour la résolution de problèmes de flux de messagerie sur des ordinateurs Exchange 2000 Server et Exchange Server 2003. L'application CatDbgSink est généralement installée sur les conseils des services du Support Technique de Microsoft. Après l'installation et l'inscription de l'application CatDbgSink, les clients peuvent utiliser l'application CatDbgSink pour créer des fichiers journaux et collecter des informations de dépannage pour les problèmes de flux de messagerie sur un serveur Exchange.

Parfois, l'application CatDbgSink ne peut pas être supprimée du serveur de production Exchange après son isolation et la résolution des problèmes. Si l'application CatDbgSink n'est pas supprimée de l'ordinateur Exchange, elle crée une charge importante qui entraîne des problèmes de performance indésirables sur le serveur Exchange. Après le diagnostic des problèmes de flux de messagerie sur un serveur de production Exchange, vous devez supprimer l'application CatDbgSink.

Pour supprimer cet avertissement

  1. Recherchez le dossier d'installation local CatDbgSink. Ce dossier contient les fichiers d'installation suivants : Setup.vbs, CatDbgSink.dll, CatDbgSink.pdb et MustReadMe.txt.

  2. À partir de la fenêtre d'invite de commandes, déplacez le répertoire vers l'emplacement des fichiers d'installation sur le disque local, par exemple : C:\CatDbgSink.

  3. À l'invite de commandes, entrez cscript setup.vbs uninstall 1 .
Remarque :
Le numéro 1 de la ligne de commande désigne l'instance de serveur virtuel SMTP, commençant par 1.

Pour plus d'informations sur l'application CatDbgSink, contactez les services du Support Technique de Microsoft (http://support.microsoft.com/default.aspx?pr=cntactms).


Le catégoriseur est désactivé pour l'instance SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les données trouvées dans la propriété LM/SmtpSvc/%SMTPInstance%/RoutingSources de la métabase IIS (Internet Information Services) pour déterminer l'état du catégoriseur de messages de chaque instance de serveur virtuel SMTP sur les ordinateurs Exchange 2000 Server ou Exchange Server 2003.

Exchange Server Analyzer détermine si la clé SMTPDSUseCat existe dans la métabase IIS, puis produit des rapports présentant les résultats. Si Exchange Server Analyzer détecte que SMTPDSUseCat existe et est définie sur désactivé, 0X000000, il affiche une erreur. Si le catégoriseur de messages est désactivé, le serveur Exchange est confronté à de graves problèmes de flux de messagerie.

Par défaut, si le service SMTP est installé sur un ordinateur Microsoft Windows®°2000 Server ou Microsoft Windows Server™ 2003, la clé SMTPDSUseCat est créée dans la métabase IIS. Par défaut, la clé SMTPDSUseCat est désactivée (0). Si Exchange Server est installé, la clé de la métabase IIS SMTPDSUseCat est supprimée. Le catégoriseur de messages est activé. Si le service SMTP ou Exchange Server est installé sur un ordinateur Windows 2000 Server ou Windows Server 2003, une instance de serveur virtuel STMP (1) par défaut est créée. Le catégoriseur de messages peut être désactivé dans des cas où Exchange Server est installé et où le service SMTP est désinstallé, puis réinstallé sur l'ordinateur. Le catégoriseur de messages peut également être désactivé si un logiciel tiers est installé ou si une erreur de configuration administrative se produit.

Remarque :
Chaque instance de serveur virtuel SMTP du serveur Exchange dispose d'un contrôle indépendant de l'état du catégoriseur de messages.

Le catégoriseur de messages examine chaque message entrant dans chaque instance du serveur virtuel SMTP et détermine les options. Les messages peuvent être destinés à la banque locale, à un hôte distant grâce à l'Agent de transfert des messages (MTA) ou à un hôte distant grâce au serveur SMTP. Le catégoriseur de messages gère également l'extension de la liste de distribution. Le catégoriseur de messages examine les messages arrivant sur un serveur SMTP et détermine les opérations à effectuer. Le catégoriseur de messages est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur de messages est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui passe par le moteur avancé de files d'attente.

Remarque :
L'outil de réinstallation de SMTP (Smtpreinstall.exe) se trouve sur le CD-ROM d'Exchange 2000 Server SP2, dans le dossier \SUPPORT\UTILS\I386.
Pour activer le catégoriseur de messages à l'aide de l'outil de réinstallation SMTP

  1. Copiez Smtpreinstall.exe dans le dossier \Exchsrvr\Bin.

  2. Double-cliquez sur Smtpreinstall.exe dans le dossier \Exchsrvr\Bin.

  3. Cliquez sur OK dans la boîte de dialogue Réinstaller Microsoft Exchange SMTP pour redémarrer le serveur Exchange.

Si vous devez afficher les propriétés dans la métabase IIS, vous pouvez le faire en installant l'utilitaire Metaedit 2.2 pour IIS 4.0/5.0 ou IIS Metabase Explorer de IIS 6.0.

Attention :
Il est recommandé de ne pas modifier directement la métabase.

Pour plus d'informations sur le catégoriseur de messages ou les utilitaires de métabase IIS disponibles, voir les articles suivants de la Base de connaissances Microsoft :

  • 290290 sur l'impossibilité d'envoyer des messages après la réinstallation du service IIS SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=290290)

  • 319885 sur la non-remise des messages envoyés dans l'organisation Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319885).

  • 231729 sur la clé DSUseCat et le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231729)

  • 232068 sur le téléchargement, l'installation et la suppression de l'utilitaire IIS MetaEdit 2.2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068)

Pour télécharger les outils du kit de ressources IIS 6.0, voir les outils du kit de ressources Internet Information Services (IIS) 6.0 (http://go.microsoft.com/fwlink/?LinkId=33134)


Un événement d'avertissement du catégoriseur (ID : 6004) a été enregistré au cours des dernières 24 heures
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-05

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si un avertissement Événement 6004 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures.

Si Exchange Server Analyzer détecte qu'un avertissement Événement 6004 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures, il affiche un message d'avertissement.

Cela indique qu'une erreur s'est produite pendant que le catégoriseur tentait de traiter un message.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP (Simple Mail Transfer Protocol) et détermine les opérations à effectuer sur les messages. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui transite par le moteur avancé de files d'attente. Le catégoriseur exécute la résolution d'adresse et le transfert de messages, définit des indicateurs de conversion de contenu, développe des listes de distribution, applique des paramètres globaux et génère des notifications d'état de remise. Le catégoriseur détecte également des itinéraires de destinataire alternatifs et exécute des fonctions de bifurcation, de journalisation parmi de nombreuses autres fonctions.

Dès qu'un message entre dans le catégoriseur, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Possible causes of MSExchangeTransport L'événement d'avertissement 6004 inclut les éléments suivants :

  • problèmes DSAccess (Directory Service Access) ;

  • latence ou échecs de réplication d'annuaire ;

  • serveurs de catalogue global surchargés ;

  • problèmes DNS.

Pour supprimer cet avertissement :

  • Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  • Examinez les messages de notification d'état de remise (DSN) en cours de génération. Les DSN peuvent inclure des rapports de non remise (NDR). Les DSN décrivent des messages en échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  • Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  • L'outil Archive Sink permet d'archiver et d'analyser les messages entrants et sortants d'Exchange Server.

  • Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

Pour plus d'informations sur les événements et les erreurs d'Exchange Server 2003, consultez la page du centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).

Pour obtenir la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, consultez l'article 284204 de la Base de connaissances Microsoft, « Notifications d'état de remise dans Exchange Server ou dans Small Business Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 262162, l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, « Comment faire pour activer le suivi des messages dans Exchange 2000 Server et dans Exchange Server 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, « ID d'événements du suivi des messages dans Exchange Server 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864; sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, consultez le WebCast Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, consultez l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour des informations générales sur le dépannage de problèmes liés au transport, consultez les articles et ressources suivants de la Base de connaissances Microsoft :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, sur le dépannage des problèmes de transport dans Microsoft Exchange 2000 et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • 895853, « Comment faire pour résoudre les problèmes de relais de messagerie dans Exchange Server 2003 et Exchange 2000 Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour obtenir la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, consultez l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Un événement d'avertissement du catégoriseur (ID : 6006) a été enregistré au cours des dernières 24 heures
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si un avertissement Événement 6006 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures.

Si Exchange Server Analyzer détecte qu'un avertissement Événement 6006 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures, il affiche un message d'avertissement.

Cet avertissement indique que des messages sont en cours de blocage dans le catégoriseur de messages.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP (Simple Mail Transfer Protocol) et détermine les opérations à effectuer sur les messages. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui transite par le moteur avancé de files d'attente. Le catégoriseur exécute la résolution d'adresse et le transfert de messages, définit des indicateurs de conversion de contenu, développe des listes de distribution, applique des paramètres globaux et génère des notifications d'état de remise. Le catégoriseur détecte également des itinéraires de destinataire alternatifs et exécute des fonctions de bifurcation, de journalisation parmi de nombreuses autres fonctions.

Dès qu'un message entre dans le catégoriseur, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Possible causes of MSExchangeTransport L'événement d'avertissement 6006 inclut les éléments suivants :

  • logiciel antivirus obsolète ou mal configuré ;

  • extension de groupe de distribution importante ;

  • destinataires de journaux mal configurés ;

  • autorisations mal configurées pour des objets Exchange dans Active Directory.

Pour supprimer cet avertissement :

  • Veillez à configurer correctement votre application antivirus au niveau fichier afin d'exclure des répertoires Exchange Server spécifiques. Pour une description des dossiers à ne pas inclure lorsque vous analysez des serveurs exécutant Microsoft Exchange Server, consultez l'article 823166 de la Base de données Microsoft, « Aperçu des logiciels antivirus utilisés avec Exchange Server 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166).

  • Assurez-vous que vous exécutez la dernière version de votre logiciel d'application antivirus.

  • Examinez les paramètres de restrictions de remise du groupe de distribution et supprimez les restrictions inutiles.

  • Examinez les paramètres de journalisation afin de déterminer si leur configuration est correcte.

  • Examinez les objets Exchange dans Active Directory afin de déterminer si la configuration des autorisations est correcte.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, consultez la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation, consultez la page sur la journalisation à l'aide d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581).

Pour plus d'informations sur la cause possible de l'événement Avertissement du catégoriseur ID 6006, consultez l'article 922256 de la Base de connaissances Microsoft sur les messages électroniques bloqués dans la file d'attente « Messages en attente d'une recherche dans l'annuaire » au sein d'une organisation Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=922256).

Pour plus d'informations sur les événements et les erreurs d'Exchange Server 2003, consultez la page du centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).

Pour obtenir la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, consultez l'article 284204 de la Base de connaissances Microsoft, « Notifications d'état de remise dans Exchange Server ou dans Small Business Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, consultez le WebCast Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour des informations générales sur le dépannage de problèmes liés au transport, consultez les articles et ressources suivants de la Base de connaissances Microsoft :

  • 821910, sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, sur le dépannage des problèmes de transport dans Microsoft Exchange 2000 et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • 895853, « Comment faire pour résoudre les problèmes de relais de messagerie dans Exchange Server 2003 et Exchange 2000 Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour obtenir la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, consultez l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Un événement d'avertissement du catégoriseur (ID : 6008) a été enregistré au cours des dernières 24 heures
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si un avertissement Événement 6008 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures.

Si Exchange Server Analyzer détecte qu'un avertissement Événement 6008 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures, il affiche un message d'avertissement.

Cela indique qu'une erreur s'est produite pendant que le catégoriseur tentait de traiter un message.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP (Simple Mail Transfer Protocol) et détermine les opérations à effectuer sur les messages. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui transite par le moteur avancé de files d'attente. Le catégoriseur exécute la résolution d'adresse et le transfert de messages, définit des indicateurs de conversion de contenu, développe des listes de distribution, applique des paramètres globaux et génère des notifications d'état de remise. Le catégoriseur détecte également des itinéraires de destinataire alternatifs et exécute des fonctions de bifurcation, de journalisation parmi de nombreuses autres fonctions.

Dès qu'un message entre dans le catégoriseur, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Possible causes of MSExchangeTransport L'événement d'avertissement 6008 inclut les éléments suivants :

  • problèmes DSAccess (Directory Service Access) ;

  • latence ou échecs de réplication d'annuaire ;

  • serveurs de catalogue global surchargés ;

  • problèmes DNS ;

  • extension de groupe de distribution excessive.

Pour supprimer cet avertissement :

  • Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  • Examinez les messages de notification d'état de remise (DSN) en cours de génération. Les DSN peuvent inclure des rapports de non remise (NDR). Les DSN décrivent des messages en échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  • Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  • L'outil Archive Sink permet d'archiver et d'analyser les messages entrants et sortants d'Exchange Server.

  • Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

  • Examinez les paramètres de restrictions de remise du groupe de distribution et supprimez les restrictions inutiles.

Pour plus d'informations sur les événements et les erreurs d'Exchange Server 2003, consultez la page du centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).

Pour obtenir la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, consultez l'article 284204 de la Base de connaissances Microsoft, « Notifications d'état de remise dans Exchange Server ou dans Small Business Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 262162 sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856, « Comment faire pour activer le suivi des messages dans Exchange 2000 Server et dans Exchange Server 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905, « ID d'événements du suivi des messages dans Exchange Server 2003 » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864; sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, consultez le WebCast Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, consultez l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, consultez la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Pour des informations générales sur le dépannage de problèmes liés au transport, consultez les articles et ressources suivants de la Base de connaissances Microsoft :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265, sur le dépannage des problèmes de transport dans Microsoft Exchange 2000 et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

  • 895853, « Comment faire pour résoudre les problèmes de relais de messagerie dans Exchange Server 2003 et Exchange 2000 Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour obtenir la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, consultez l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Filtrage des connexions activé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la propriété msExchServerBindingsFiltering d'un objet de serveur virtuel SMTP (Simple Mail Transfer Protocol) indique que le filtrage des connexions est activé pour une instance de serveur virtuel SMTP.

Exchange Server Analyzer interroge également Active Directory pour déterminer si les propriétés msExchSmtpConnectionRulesPriority, msExchSMTPGlobalIPAcceptList ou msExchSMTPGlobalIPDenyList indiquent que le filtrage des connexions est également activé au niveau des paramètres globaux.

Exchange Server Analyzer affiche un message d'avertissement si les conditions suivantes existent :

  • Le filtrage des connexions est activé sur l'instance de serveur virtuel SMTP.

  • Le filtrage des connexions est activé au niveau des paramètres globaux.

Cet avertissement indique que le filtrage des connexions est effectivement activé. Le filtrage des connexions n'est généralement pas un problème. Toutefois, si vous résolvez des problèmes de flux de messages concernant ce serveur spécifique, vous pouvez vérifier la configuration du filtre ou désactiver temporairement le filtrage des connexions pour déterminer s'il bloque de manière incorrecte le courrier de destinataires valides.

Pour désactiver un filtre des connexions sur un serveur virtuel SMTP

  1. Démarrez le Gestionnaire système Exchange : Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans l'arborescence de la console, développez Serveurs, le serveur souhaité, puis Protocoles et enfin SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP sur lequel vous souhaitez désactiver le filtre, puis cliquez sur Propriétés.

  4. Dans les <Propriétés du> Serveur virtuel SMTP, sous l'onglet Général, cliquez sur Options avancées.

  5. Dans Options avancées, sélectionnez l'adresse IP pour laquelle vous souhaitez désactiver le filtre, puis cliquez sur Modifier.

  6. Dans Identification, désactivez la case à cocher Appliquer le filtre de connexion pour désactiver le filtre.

  7. Si vous possédez plusieurs serveurs virtuels, répétez les étapes 3 à 6 pour chaque serveur sur lequel le filtre doit être désactivé.

Pour plus d'informations sur la procédure de configuration des filtres des connexions, voir l'article 823866 de la Base de connaissances Microsoft sur la procédure de configuration du filtrage des connexions à l'aide de listes noires en temps réel (RBL, Realtime Block List) et du filtrage des destinataires dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866).

Pour plus d'informations sur le filtrage de messages intelligent, voir le site Web sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Des restrictions d'acceptation sont définies pour le connecteur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut dLMemDefault pour chaque connecteur SMTP du groupe de routage. Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur des attributs authOrig et unauthOrig de chaque connecteur. Les attributs unauthOrig et authOrig contiennent des listes de noms uniques (DN) de comptes.

Par défaut, un connecteur SMTP permet à tous les utilisateurs d'envoyer des messages par son intermédiaire. Lorsque dLMemDefault est défini sur 1 (valeur par défaut), les messages provenant de n'importe quel expéditeur sont acceptés, sauf ceux provenant des comptes figurant dans l'attribut unauthOrig. Lorsque dLMemDefault est défini sur 0, les messages provenant de n'importe quel expéditeur sont rejetés, sauf ceux provenant des comptes figurant dans l'attribut authOrig.

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • La valeur de l'attribut dLMemDefault est définie sur 0.

  • L'attribut authOrig contient des valeurs.

Le connecteur spécifié par Exchange Server Analyzer est configuré pour n'accepter que certains messages. Seuls les comptes dont les autorisations ont été explicitement accordées sous l'onglet Restrictions de remise du connecteur sont autorisés à envoyer des messages par le biais du connecteur.

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut à titre indicatif uniquement.

Pour plus d'informations sur les connecteurs, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Des restrictions de rejet sont définies pour le connecteur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut dLMemDefault pour chaque connecteur SMTP du groupe de routage. Exchange Server Analyzer interroge également Active Directory pour déterminer la valeur des attributs authOrig et unauthOrig de chaque connecteur. Les attributs unauthOrig et authOrig contiennent des listes de noms uniques (DN) de comptes.

Par défaut, un connecteur SMTP permet à tous les utilisateurs d'envoyer des messages par son intermédiaire. Lorsque dLMemDefault est défini sur 1 (valeur par défaut), les messages provenant de n'importe quel expéditeur sont acceptés, sauf ceux provenant des comptes figurant dans l'attribut unauthOrig. Lorsque dLMemDefault est défini sur 0, les messages provenant de n'importe quel expéditeur sont rejetés, sauf ceux provenant des comptes figurant dans l'attribut authOrig.

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • La valeur de l'attribut dLMemDefault est définie sur 1.

  • L'attribut unauthOrig contient des valeurs.

Le connecteur spécifié par Exchange Server Analyzer est configuré pour rejeter certains messages. Les comptes dont les autorisations ont été explicitement refusées sous l'onglet Restrictions de remise du connecteur ne seront pas autorisés à envoyer des messages par le biais du connecteur.

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut à titre indicatif uniquement.

Pour plus d'informations sur les connecteurs, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Le connecteur rejette tous les messages par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut dLMemDefault de chaque connecteur. L'attribut dLMemDefault vérifie si les messages sont acceptés ou rejetés par défaut.

La valeur 0 de l'attribut dLMemDefault indique que les messages sont rejetés par défaut. La valeur 1 de l'attribut dLMemDefault indique que les messages sont acceptés par défaut. Si Exchange Server Analyzer détecte que la valeur de l'attribut dLMemDefault est égale à 0, il affiche un message indiquant une configuration autre que celle par défaut.

Le connecteur spécifié par Exchange Server Analyzer est configuré pour rejeter tous les messages par défaut. Seuls les comptes dont les autorisations ont été explicitement accordées sous l'onglet Restrictions de remise du connecteur sont autorisés à envoyer des messages par le biais du connecteur.

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut à titre indicatif uniquement.

Pour plus d'informations sur les connecteurs, voir le Guide de transport et de routage Exchange Server 2003 à l'adresse http://go.microsoft.com/fwlink/?LinkId=47579.


La vérification des restrictions de connecteur est activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la branche de Registre suivante pour déterminer si la valeur de Registre CheckConnectorRestrictions est présente et configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Si Exchange Server Analyzer détecte que la valeur de CheckConnectorRestrictions est présente et définie sur 1, un avertissement s'affiche.

Si vous devez appliquer une restriction de liste de distribution à un connecteur, vous devez activer manuellement le processus pour ces restrictions. La vérification des restrictions est contrôlée par la valeur de Registre CheckConnectorRestrictions qui doit être définie sur le serveur tête de pont Exchange qui est la source du connecteur en cours de vérification. Si vous spécifiez une restriction, mais ne créez pas la valeur de Registre CheckConnectorRestrictions, la restriction n'est pas vérifiée.

La vérification des restrictions de connecteur est désactivée par défaut car l'extension des groupes de distribution et la vérification des restrictions pour chaque message qui transite par le système peuvent affecter considérablement les performances. N'activez si possible ce paramètre que lorsque cela s'avère nécessaire (par exemple, sur le serveur tête de pont pour le connecteur restreint).

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour désactiver la vérification des restrictions de connecteur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\Resvc\Parameters

  3. Dans le volet droit, recherchez CheckConnectorRestrictions et supprimez-le.

  4. Fermez l'Éditeur du Registre et redémarrez les services Microsoft Exchange Routing Engine et SMTP (Simple Mail Transfer Protocol) pour que la modification soit prise en compte.

Pour plus d'informations sur la modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre de vérification des restrictions de connecteur, voir l'article 277872 de la Base de connaissances Microsoft sur les restrictions de remise de connecteur, qui risquent de ne pas fonctionner correctement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Le connecteur a une étendue pour le routage
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-04-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchRoutingSMTPConnector de chaque connecteur SMTP. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchRoutingSMTPConnector comprend la chaîne « Local: », il affiche un message indiquant une configuration autre que celle par défaut. La présence de la chaîne « Local: » indique que le connecteur SMTP a une étendue pour le routage.

Un connecteur SMTP désigne un routage isolé pour le courrier. Vous pouvez utiliser des connecteurs SMTP pour établir une passerelle pour le courrier Internet ou pour vous connecter à un domaine spécifique ou un système de messagerie. Les connecteurs permettent de définir des options spécifiques pour le routage de courrier désigné.

Bien que vous puissiez envoyer et recevoir du courrier Internet à l'aide d'un serveur virtuel SMTP, de nombreuses organisations configurent un connecteur SMTP dédié de sorte à router le courrier Internet. L'utilisation d'un connecteur SMTP est recommandée car celui-ci fournit un routage isolé pour le courrier destiné à Internet. En outre, un connecteur SMTP propose plus d'options de configuration que le serveur virtuel SMTP.

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut à titre indicatif uniquement.

Pour plus d'informations sur les connecteurs SMTP, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Envisager la vérification des restrictions non hiérarchiques
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour chaque objet Exchange Server de l'annuaire. SI Exchange Server Analyzer détecte que la valeur de l'attribut serialNumber d'un objet de serveur Exchange Server 2003 contient Service Pack 2 dans sa valeur de chaîne, il lit ensuite la clé de Registre suivante pour déterminer si la valeur de Registre CheckConnectorRestrictions est présente et configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Cette condition indique que le serveur vérifie les restrictions d'envoi et de réception avant de permettre le traitement d'un message.

Si Exchange Server Analyzer détecte que la valeur de CheckConnectorRestrictions est présente, définie sur 1, et donc activée, il lit également la clé de Registre HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod pour déterminer si la valeur de Registre RestrictionMethod est présente et comment elle est configurée.

Si Exchange Server Analyzer détecte que la valeur de Registre RestrictionMethod est manquante ou définie sur une valeur autre que 2, il affiche un message de recommandation.

En bref, Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • Le SP2 du serveur Exchange Server 2003 est installé.

  • La valeur de Registre CheckConnectorRestrictions de HKLM\System\CurrentControlSet\Services\Resvc\Parameters est configurée de manière à utiliser une restriction basée sur la liste de distribution sur un connecteur de l'ordinateur local.

  • La valeur de Registre RestrictionMethod de HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod est manquante ou définie sur une valeur autre que 2.

La valeur RestrictionMethod détermine la manière dont le catégoriseur va appliquer les restrictions. Le comportement par défaut du catégoriseur consiste à développer de manière récurrente les groupes de distribution et à vérifier les restrictions pour chaque message qui passe par le système. Ce comportement par défaut du catégoriseur peut considérablement affecter les performances et n'est pas recommandé.

Si vous définissez la valeur de RestrictionMethod sur 2, les composants de transport de ce serveur Exchange ne développeront pas les groupes de distribution lorsque le serveur vérifie les restrictions. Cette configuration fournit les meilleures performances au niveau du contrôle des restrictions. En outre, pour que l'entrée de Registre RestrictionMethod soit appliquée, tous les groupes de distribution qui incluent des utilisateurs soumis à des restrictions de remise de messages doivent être bidimensionnels. Cela signifie que les groupes de distribution restreints ne doivent présenter aucun groupe de distribution imbriqué. La logique d'expansion ne fonctionne pas si des groupes de distribution restreints sont imbriqués.

Pour les groupes de distribution utilisés dans des restrictions de connecteur, il est recommandé de définir la valeur de l'entrée de Registre RestrictionMethod sur un serveur tête de pont de connecteur qui ne possède aucune boîte aux lettres. Pour les restrictions utilisateur d'Active Directory, si les groupes de distribution restreints possèdent des serveurs d'expansion, nous recommandons de créer l'entrée de Registre RestrictionMethod sur les serveurs d'expansion.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour créer l'entrée de Registre RestrictionMethod et en définir la valeur sur 2

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Dans le volet gauche, cliquez sur Paramètres.

  4. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  5. Entrez RestrictionMethod, puis appuyez sur ENTRÉE pour nommer la nouvelle entrée de Registre.

  6. Cliquez avec le bouton droit sur RestrictionMethod, puis cliquez sur Modifier.

  7. Entrez 2, puis appuyez sur ENTRÉE.

  8. Quittez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre RestrictionMethod, voir l'article 895407 de la Base de connaissances Microsoft sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de message sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Pour plus d'informations sur la valeur de Registre, voir l'article 277872 de la Base de connaissances Microsoft sur les restrictions de remise de connecteur, qui risquent de ne pas fonctionner correctement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


La clé de Registre ConvertDSNInternetContent est configurée pour effectuer la conversion de contenu de tous les messages
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur de Registre ConvertDSNInternetContent a été configurée pour effectuer la conversion de contenu pour tous les messages reçus par la banque d'informations Exchange d'un ordinateur Exchange Server 2003 :

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes sont vraies :

  • La valeur de Registre ConvertDSNInternetContent a été créée manuellement.

  • La valeur de Registre ConvertDSNInternetContent est définie sur 1.

Une valeur nulle ou inexistante pour la clé de Registre ConvertDSNInternetContent désactive la conversion de contenu des messages SMTP par la banque d'informations Exchange. Une valeur de 1 active la conversion de contenu de tous les messages SMTP sur toutes les instances de serveur virtuel (VSI) SMTP ou sur chaque VSI.

Par défaut, la valeur de Registre ConvertDSNInternetContent n'est pas créée pendant l'installation d'Exchange Server 2003. La valeur de Registre ConvertDSNInternetContent peut être créée manuellement après l'installation d'Exchange Server pour modifier le comportement de la conversion de contenu sur l'ordinateur Exchange Server 2003. Le contenu des messages SMTP envoyés ne doit généralement pas être converti. Si vous activez la conversion de contenu pour tous les messages, notamment les messages SMTP, vous ajoutez une surcharge de traitement sur le serveur Exchange. Cette surcharge supplémentaire peut provoquer des problèmes de performances et de stockage du fichier journal.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Vous devez modifier le Registre pour rétablir le comportement de la conversion de contenu sur l'ordinateur Exchange Server 2003 sur la méthode de conversion la plus efficace.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à la clé de Registre suivante : HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre ConvertDSNInternetContent, cliquez sur Modifier, puis modifiez le champ Données de la valeur sur 80. Cliquez sur OK.

    Remarque :
    Pour supprimer la valeur de Registre ConvertDSNInternetContent, cliquez avec le bouton droit sur la valeur de Registre ConvertDSNInternetContent dans le volet Détails, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Identification de groupe de distribution comme destination commune
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-04

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Queue pour déterminer les valeurs des attributs suivants pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur le serveur virtuel SMTP.

LinkId | Indique l'identificateur du lien contenant la file d'attente.
QueueId | Indique l'identificateur de la file d'attente.
QueueName | Indique le nom de la file d'attente.
VirtualMachine | Indique le nom de la machine virtuelle contenant la file d'attente.
VirtualServerName | Indique le nom du serveur virtuel contenant la file d'attente.
MessageCount | Indique le nombre de messages dans la file d'attente.

Exchange Server Analyzer utilise les informations obtenues ci-avant pour interroger la classe WMI Exchange_QueuedSMTPMessage afin d'obtenir les valeurs des attributs suivants des messages figurant dans la file d'attente :

Recipients | Indique les destinataires du message.
Received | Indique l'horodatage reçu pour le message.
MessageId | Indique l'identificateur du message en file d'attente.
StateRetry | Indique qu'une nouvelle tentative de transmission a lieu pour un message qui n'a pas été remis avec succès.

Enfin, Exchange Server Analyzer utilise les données obtenues ici pour interroger le service d'annuaire Active Directory® pour déterminer la valeur distinguishedName de chaque objet Recipient. Exchange Server Analyzer détermine ensuite si le destinataire est un utilisateur, un groupe de distribution, un dossier public ou une banque de dossiers publics.

Si Exchange Server Analyzer détermine qu'au moins 25 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à un groupe de distribution spécifique, Exchange Server Analyzer affiche un message d'avertissement.

Si Exchange Server Analyzer détermine qu'au moins 50 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à un groupe de distribution spécifique, Exchange Server Analyzer affiche un message d'erreur.

Ce message d'avertissement ou d'erreur signifie que le groupe de distribution identifié est une destination commune des messages bloqués dans une file d'attente SMTP.

Pour résoudre ce problème, il convient de vérifier s'il y a des problèmes de configuration ou d'autres anomalies en relation avec le groupe de distribution, qui pourraient être à l'origine de la mise en file d'attente des messages :

  • Assurez-vous que les attributs de l'objet groupe de distribution sont correctement définis et contiennent les valeurs correctes dans Active Directory.

  • Vérifiez que les autorisations Active Directory de l'objet groupe de distribution sont correctement paramétrées.

  • Si le groupe de distribution contient un objet utilisateur destiné à usage particulier, à savoir un destinataire de la journalisation désigné, examinez les configurations du service ou des composants auxquels l'objet utilisateur est associé pour vérifier si la configuration est correcte.

  • Recherchez la présence éventuelle de publicités commerciales non sollicitées (UCE) ou de courrier indésirable, ou d'attaques de virus dirigées contre le groupe de distribution.

  • Déterminez si les restrictions de remise du groupe de distribution sont correctement définies.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 329171 sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Échec des catégorisations précédentes avec une erreur renouvelable
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Ce moteur collecte des données à partir des compteurs de performance Cat. : catégorisations en cours et Longueur de la file d'attente du catégoriseur de l'objet de performance SMTP Server pour analyser les données de performances.

Le compteur de performance catégorisations en cours indique le nombre de catégorisations en cours tandis que le compteur Longueur de la file d'attente du catégoriseur indique le nombre de messages dans la file d'attente du catégoriseur.

Pour cette requête, Exchange Server Analyzer récupère un exemple toutes les 6 secondes pendant une période de deux minutes. Il signale la valeur moyenne du compteur de performance pendant l'intervalle entre deux collectes.

Exchange Server Analyzer examine le nombre moyen de catégorisations en cours et compare ce nombre à celui de catégorisations toujours dans la file d'attente.

Exchange Server Analyzer affiche une erreur si, pour la période d'exemple, les conditions suivantes sont vraies :

  • Le nombre moyen de catégorisations en cours est zéro.

  • La longueur moyenne de la file d'attente du catégoriseur est supérieure à zéro.

Le catégoriseur effectue les opérations principales suivantes :

  • Il résout et valide tous les destinataires.

  • Il détermine les limites et restrictions pour tous les destinataires.

  • Il développe les listes de distribution si nécessaire.

  • Il détermine si le message est destiné à une remise locale ou à distance.

Cette erreur indique que des messages bloqués dans la file d'attente du catégoriseur ont échoué dans la catégorisation avec une erreur renouvelable.

En règle générale, les messages s'accumulent dans les files d'attente car le moteur avancé de files d'attente n'est pas en mesure de catégoriser le message. Le moteur avancé de files d'attente risque de ne pas pouvoir accéder aux serveurs de catalogue global ni aux informations de destinataire. Les serveurs de catalogue global peuvent également être inaccessibles ou lents. En outre, les messages peuvent s'accumuler pour les raisons suivantes :

  • Le service d'annuaire Active Directory® n'est pas disponible.

    Remarque :
    Le catégoriseur utilise Active Directory pour catégoriser des messages.
  • Active Directory subit peut-être une charge trop importante si de nombreux messages se trouvaient dans la file d'attente avant catégorisation.

  • Un échec de conversion s'est produit. Le catégoriseur traite également les conversions de contenu.

  • Le catégoriseur de messages ne peut pas trouver les banques de boîtes aux lettres.

  • En cas de réinstallation ou de suppression de SMTP (Simple Mail Transfer Protocol), les clés de la métabase IIS suivantes risquent d'être invalidées : /smtpsvc/DsUseCat and /smtpsvc/vsi#/DsUseCat.

    Remarque :
    Déterminez si SMTP a été réinstallé ou supprimé.

Vous pouvez examiner les propriétés de la file d'attente pour déterminer la cause de l'échec. Par exemple, si les propriétés de la file d'attente affichent un message du type « Une erreur SMTP s'est produite », consultez les journaux des événements de votre serveur afin d'identifier les erreurs SMTP éventuelles. Si le journal ne contient pas d'événements, augmentez le niveau d'enregistrement SMTP.

Pour plus d'informations sur la procédure de dépannage d'Exchange et des files d'attente SMTP, voir les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)

  • Rubrique sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588)

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Activation de la mise à jour automatique du filtre de messages intelligent
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-02-13

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets Exchange Server de l'annuaire. L'attribut serialNumber est une valeur de chaîne qui comprend les versions d'Exchange Server et du Service Pack, s'il est installé. Une valeur de l'attribut serialNumber égale à Version 6.5 (Build 7638: Service Pack 2) indique que le serveur exécute Exchange Sever 2003 Service Pack 2.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour ClusSvc, le service de cluster. La valeur True indique que le service de cluster est en cours d'exécution et la valeur False indique qu'il n'est pas en cours d'exécution.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si le filtre de messages intelligent de Microsoft Exchange est installé et activé sur le serveur :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Si Exchange Server Analyzer détecte que l'entrée ContentFilterBindings dans la clé de Registre ContentFilter est présente, mais que la valeur ContentFilterBindings n'est pas configurée, il indique que le filtre de messages intelligent n'est pas activé sur le serveur.

Enfin, Exchange Server Analyzer interroge l'entrée de Registre suivante pour déterminer si la sous-clé ContentFilterState est présente et si la mise à jour automatique du filtre de messages intelligent est activée sur le serveur :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

Une valeur autre que 1 pour la sous-clé ContentFilterState indique que la mise à jour automatique du filtre de messages intelligent n'est pas activée.

Exchange Server Analyzer affiche un message de recommandation si les conditions suivantes sont vraies :

  • le serveur exécute Exchange Server 2003 Service Pack 2 ;

  • le serveur Exchange n'est pas en clusters ;

  • le filtre de messages intelligent est activé ;

  • les mises à jour automatiques du filtre de messages intelligent ne sont pas activées.

Par défaut, la fonction du filtre de messages intelligent est installée avec Exchange Server 2003 SP2. Vous devez activer manuellement le filtre de messages intelligent pour bénéficier de cette nouvelle technologie de filtrage de messages. Après avoir activé cette fonction, les fichiers .dat et .dll doivent être régulièrement mis à niveau pour garder le filtre à jour et efficace. L'article auquel la section suivante fait référence décrit le processus de mise à jour permettant la mise à jour du filtre de messages intelligent.

Pour plus d'informations sur la procédure d'activation de la mise à jour automatique du filtre de messages intelligent, voir l'article 907747 de la Base de connaissances Microsoft sur la procédure de mise à jour de la deuxième version du filtre de messages intelligent dans Exchange Server 2003 SP2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747).


La journalisation des enveloppes est activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-03-30

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut heuristics a été configuré de manière à activer la journalisation des enveloppes. Par défaut, l'attribut heuristics n'est pas configuré. Si Exchange Server Analyzer détecte que l'attribut heuristics est défini sur 512, il affiche un message indiquant une configuration autre que celle par défaut.

La journalisation des enveloppes permet d'archiver les en-têtes des messages P1. L'en-tête de message P1 est constitué des informations sur les adresses utilisées par les Agents de transfert de messages (MTA) pour router le courrier. Ces informations sur les adresses comprennent des données sur les destinataires qui reçoivent réellement le message, notamment les destinataires en copie conforme invisible (Cci) et ceux des groupes de distribution. La journalisation des enveloppes remet les messages marqués pour l'archivage à l'aide d'un message d'enveloppe qui contient un rapport journal et le message d'origine. Le message d'origine est remis en tant que pièce jointe. Le corps du rapport journal contient les données de l'enveloppe de transport du message archivé.

Avant de pouvoir activer la journalisation Cci sur un serveur donné, vous devez configurer la journalisation des messages uniquement au niveau de la base de données. L'attribut heuristics n'est pas actif lorsque les conditions suivantes existent :

  • L'attribut heuristics est défini sur 512.

  • La journalisation des messages uniquement n'est activée sur aucune des banques de bases de données.

Les messages de journalisation peuvent utiliser beaucoup de ressources disque, réseau et processeur. Par conséquent, la journalisation nécessite une planification approfondie du déploiement. La journalisation doit être activée uniquement dans le cadre d'une structure de solution de journalisation globale.

Ignorez ce message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • Vos activités nécessitent une journalisation.

  • Vous avez déployé une structure de solution de journalisation.

Dans le cas contraire, vous devez désactiver la fonctionnalité de journalisation.

Pour désactiver la journalisation des messages uniquement dans une base de données

  1. Dans le Gestionnaire système Exchange, développez Serveurs, <votre serveur Exchange>, <groupe de stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres.

  2. Sous l'onglet Général, désactivez la case à cocher Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque.

  3. Attendez 15 minutes pour que la banque Exchange applique les modifications. Vous ne devez pas redémarrer le service de banque d'informations de Microsoft Exchange.

Si vous souhaitez qu'Exchange Analyzer n'affiche plus ce message, vous devez désactiver l'attribut heuristics. Il n'est pas nécessaire de désactiver l'attribut heuristics pour désactiver la fonctionnalité de journalisation.

Vous pouvez désactiver la journalisation des enveloppes à l'aide de l'outil E-Mail Journaling Advanced Configuration (Exejcfg.exe). Vous pouvez exécuter cet outil à partir de tous les serveurs ayant accès à Active Directory, mais il est recommandé de l'exécuter à partir d'un contrôleur de domaine.

Pour obtenir l'outil E-Mail Journaling Advanced Configuration et la documentation, téléchargez le package des outils à l'adresse http://go.microsoft.com/fwlink/?LinkId=33122. L'outil E-Mail Journaling Advanced Configuration peut être utilisé dans les environnements Exchange 2000 Server et Exchange Server 2003.

Pour désactiver l'attribut heuristics

  1. Téléchargez et décompressez l'outil E-Mail Journaling Advanced Configuration dans le répertoire souhaité.

  2. Ouvrez une invite de commandes.

  3. Accédez au répertoire dans lequel vous avez installé l'outil E-Mail Journaling Advanced Configuration.

  4. Entrez la commande suivante pour désactiver la journalisation des enveloppes :

    Copier le code
    exejcfg -d

Pour plus d'informations sur le déploiement d'une solution de journalisation, voir le document sur la journalisation à l'aide d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Verbe ESMTP non pris en charge
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut msExchSmtpInboundCommandSupportOptions pour chaque instance d'un serveur virtuel SMTP (Simple Mail Transfer Protocol) est configurée pour prendre en charge les verbes SMTP étendus par défaut pour les connexions entrantes.

Ces verbes SMTP étendus sont répertoriés dans le tableau ci-dessous. Si Exchange Server Analyzer détecte qu'un des verbes SMTP étendus par défaut répertoriés pour les connexions entrantes n'est pas pris en charge, il affiche un avertissement.

Exchange Server 2003 utilise ces verbes SMTP étendus spécifiques à Exchange pour communiquer avec d'autres serveurs Exchange de l'organisation plus efficacement que sur le protocole SMTP standard. Ces verbes sont contrôlés dans la métabase et dans les récepteurs d'événements Exchange Server. Dans Exchange Server 2003, le processus DS2MB est chargé de mettre à jour les valeurs dans la métabase en les copiant à partir d'Active Directory. Si vous désactivez les récepteurs d'événements, vous risquez d'altérer les performances d'Exchange Server.

Verbe SMTP étendu Commentaires

8BITMIME

Indique que le serveur virtuel SMTP local prend en charge les messages MIME à huit bits.

BDAT, CHUNKING

Alternative à la commande DATA. Utilise deux arguments. Lorsqu'un serveur virtuel SMTP répond au mot-clé EHLO avec CHUNKING, le serveur SMTP indique qu'il prend en charge la commande BDAT et accepte les messages en blocs.

  • Le premier argument indique la longueur du paquet de données binaires. Par conséquent, l'hôte SMTP ne doit pas rechercher en permanence la fin des données. Le serveur récepteur compte les octets du messages. Si la taille du message est égale à la valeur envoyée par la commande BDAT, le serveur suppose qu'il a reçu toutes les données du message.

  • Le deuxième argument indique si le paquet de données est le dernier de la transmission actuelle. Il est facultatif.

BINARYMIME

Indique que le serveur virtuel SMTP accepte les messages contenant du matériel binaire sans codage de transport à l'aide d'un paramètre BODY avec une valeur de BINARYMIME avec la commande MAIL. Si le serveur SMTP accepte une commande MAIL dont le paramètre BODY est défini sur BINARYMIME, le serveur accepte de préserver tous les bits de chaque octet transmis à l'aide de la commande BDAT. L'extension SMTP BINARYMIME ne peut être utilisée qu'avec CHUNKING.

DSN

Commande ESMTP permettant d'activer les notifications d'état de remise comme défini dans le document RFC (Request for Comments) 1891.

ENHANCEDSTATUSCODES

Indique que le serveur SMTP fournit des codes d'état d'erreur améliorés. La partie texte de toutes les réponses d'état SMTP, autre que les salutations initiales et toute réponse à HELO ou EHLO, est précédée d'un code d'état comme défini dans le document RFC (Request for Comments) 1891.

ETRN

Envoyé par un serveur SMTP pour demander que le serveur virtuel local envoie tout message électronique situé dans la file d'attente pour les domaines indiqués dans la commande ETRN.

TURN

Permet à un hôte distant et à l'hôte local d'échanger les rôles et d'envoyer du courrier dans l'autre direction sans établir de nouvelle connexion.

Pour plus d'information sur la procédure de restauration de la prise en charge par défaut de ces verbes, voir l'article 257569 de la Base de connaissances sur la procédure de désactivation des verbes ESMTP dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).


Des verbes étendus ne sont pas signalés par le serveur Exchange
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété SmtpInboundCommandSupportOptions dans la métabase IIS (Internet Information Services) pour déterminer si Exchange Server a été configuré pour prendre en charge les verbes étendus. Si Exchange Server Analyzer détecte que l'attribut SmtpInboundCommandSupportOptions n'est pas défini sur 7697601, un avertissement s'affiche.

Des verbes SMTP étendus sont requis par Exchange 2000 Server et Exchange Server 2003. La valeur de la métabase IIS doit correspondre à la valeur définie dans le service d'annuaire Active Directory®. Si vous exécutez Exchange Server dans un environnement en mode mixte, cette valeur doit être définie sur 7697601.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'Active Directory Service Interfaces (ADSI) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour restaurer la valeur par défaut de SmtpInboundCommandSupportOptions

  1. Ouvrez ADSI Edit et connectez-vous à un contrôleur de domaine.

  2. Ouvrez le Conteneur Configuration.

  3. Rendez-vous à l'emplacement suivant :

    Configuration/Services/Microsoft Exchange/<votre organisation>/Groupes d'administration/<votre groupe d'administration>/Serveurs/<votre ordinateur Exchange Server>/Protocoles/SMTP/<votre serveur virtuel>.

  4. Cliquez avec le bouton droit sur l'objet de serveur virtuel, puis cliquez sur Propriétés.

  5. Pour Sélectionnez une propriété à afficher, sélectionnez msExchSmtpInboundCommandsSupportOptions.

  6. Dans le champ Modifier l'attribut, entrez 7697601.

  7. Cliquez sur Définir, Appliquer, puis sur OK.

  8. Fermez ADSI Edit.


Détection de files d'attente figées
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour déterminer la valeur de la clé StateFrozen pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur un serveur.

Si Exchange Server Analyzer détecte que la valeur de la clé StateFrozen pour l'une des files d'attente SMTP sur un serveur Exchange est définie sur True, il affiche une erreur.

Une file d'attente figée signifie l'arrêt des sessions de transport pour cette file d'attente. Une file d'attente figée empêche les messages de sortir, bien que de nouveaux messages puissent être ajoutés. Vous pouvez modifier manuellement l'état d'une connexion à l'aide du menu contextuel dans chaque file d'attente de liens. Si vous utilisez la commande Forcer la connexion pour modifier l'état d'une file d'attente en Actif, vous activez immédiatement une connexion qui envoie les messages de cette file d'attente.

Pour plus d'informations sur les files d'attente SMTP concernées et la cause possible, voir les articles suivants sur l'outil Exchange Server Analyzer Tool :

  • La file d'attente « Messages en attente d'une recherche dans l'annuaire » est figée

  • La file d'attente « Messages en attente de routage » est figée

  • La file d'attente « Envoi de messages suspendu » est figée

  • La file d'attente « Remise locale » est figée

  • La file d'attente « Remise distante » est figée

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La mise à jour du filtre de messages intelligent est disponible
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer si MSExchange.UceContentFilter.dll existe dans le chemin suivant sur le serveur Exchange :

<chemin_fichiers_binaires_du_serveur_Exchange>\MSCFv2\MSExchange.UceContentFilter.dll

Remarque :
Dans ce chemin, <chemin_fichiers_binaires_du_serveur_Exchange> désigne l'emplacement du dossier bin.

Si MSExchange.UceContentFilter.dll n'existe pas à cet emplacement, Exchange Server Analyzer affiche un message de recommandation.

Il est conseillé d'installer la mise à jour du filtre de messages intelligent Microsoft Exchange sur tous les serveurs Exchange équipés de ce filtre. La mise à jour du filtre de messages intelligent fournit la dernière mise à jour du filtre de messages intelligent SmartScreen™ pour le filtre de messages intelligent. La mise à jour du filtre SmartScreen contient des fonctionnalités antispam améliorées qui augmentent la capacité du filtre de messages intelligent à bloquer les messages électroniques commerciaux indésirables, aussi appelés spam.

Remarque :
Avant d'installer la mise à jour, vous devez installer le filtre de messages intelligent. Pour ce faire, utilisez un compte disposant de droits administratifs locaux et un membre d'un groupe ayant reçu le rôle d'administrateur Exchange.

Après l'installation du filtre de messages intelligent, procédez comme suit pour installer les mises à jour.

Pour obtenir et installer la mise à jour du filtre de messages intelligent

  1. Rendez-vous à l'adresse http://go.microsoft.com/fwlink/?LinkId=41026 pour obtenir une mise à jour du filtre de messages intelligent.

  2. Voir les notes de mise à jour du filtre de messages intelligent à l'adresse http://go.microsoft.com/fwlink/?LinkId=41027.

  3. Exécutez le package de mise à jour et suivez les instructions de l'Assistant de configuration de ce package.

Pour plus d'informations, voir le document sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


La vérification des restrictions bidimensionnelles est activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour chaque objet Exchange Server de l'annuaire. Si la valeur de chaîne de l'attribut serialNumber d'un objet serveur Exchange Server 2003 contient Service Pack 2, cela signifie que le serveur Exchange exécute une pré-version d'Exchange Server 2003 Service Pack 2.

Exchange Server Analyzer lit également l'entrée de Registre suivante pour déterminer si la valeur de Registre RestrictionMethod est présente :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si toutes les conditions suivantes existent :

  • Le Service Pack 2 d'Exchange Server 2003 est installé.

  • La valeur de Registre RestrictionMethod est présente et configurée pour avoir une valeur de 2.

Cette configuration indique que les composants de transport sur ce serveur Exchange ne développeront pas les groupes de distribution lorsque le serveur vérifie les restrictions. Cette configuration fournit les meilleures performances au niveau du contrôle des restrictions.

Si vous pensez que la présence et la configuration de la valeur de Registre RestrictionMethod sont erronées, la procédure suivante permet de rétablir la configuration par défaut. Toutefois, étant donné que la présence de cette clé combinée à Exchange Server 2003 Service Pack 2 offre de meilleures performances au niveau de la vérification des restrictions, il est recommandé de laisser la configuration actuelle de la valeur de Registre RestrictionMethod.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. Dans le volet droit, cliquez avec le bouton droit sur RestrictionMethod et sélectionnez Supprimer.

  4. Fermez l'Éditeur du Registre, puis redémarrez le service d'administration IIS et le service de moteur de routage (RESvc) de Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre RestrictionMethod, voir l'article 895407 de la Base de connaissances Microsoft sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de message sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).


Enregistrements d'hôte trouvés mais pas d'enregistrements MX
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge les serveurs DNS qu'il utilise pour les enregistrements de serveur de messagerie (MX) des domaines distants vers lesquels Exchange effectue des envois. Exchange Server Analyzer effectue ensuite une recherche DNS pour récupérer les enregistrements d'hôte (A) des domaines distants.

Si l'opération de recherche DNS d'Exchange Server Analyzer ne renvoie aucun enregistrement MX pour les domaines distants, mais peut ensuite récupérer des enregistrements d'hôte (A) pour les mêmes domaines distants, Exchange Server Analyzer affiche un avertissement.

Dans ce cas, après l'échec de la récupération des enregistrements MX, Exchange Server peut tenter d'envoyer des messages électroniques aux serveurs vers lesquels les enregistrements d'hôte (A) pointent. Il est très important que les enregistrements d'hôte (A) pointent vers les bons serveurs de messagerie.

Certains domaines peuvent configurer leurs enregistrements d'hôte (A) pour pointer vers un fournisseur de services Internet (ISP), qui risque de ne pas être un serveur de messagerie faisant autorité pour le destinataire prévu, bien qu'il dispose peut-être de serveurs de messagerie valides. Dans ce cas, le message est rejeté.

La recherche DNS d'enregistrements MX peut échouer si le serveur DNS est arrêté ou inaccessible en raison d'une défaillance du réseau ou pour d'autres motifs.

Pour vérifier que le serveur DNS est en ligne et que les enregistrements MX sont présents

  1. Pour vérifier que le serveur DNS est en cours d'exécution, effectuez au moins l'une des vérifications suivantes :

    • Examinez l'état du serveur DNS à partir du programme d'administration DNS sur le serveur DNS.

    • Redémarrez le serveur DNS. Pour plus d'informations, voir la rubrique sur le démarrage, l'arrêt, la mise en pause ou le redémarrage d'un serveur DNS (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Vérifiez le temps de réponse du serveur DNS à l'aide de la commande nslookup. Pour plus d'informations, voir les instructions de la rubrique sur la vérification du temps de réponse du serveur DNS à l'aide de la commande nslookup (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. La commande nslookup permet de vérifier que les enregistrements MX sont correctement configurés. Pour plus d'informations, voir la rubrique sur l'utilisation de Nslookup pour vérifier la configuration de l'enregistrement MX dans la section sur la vérification de la conception et de la configuration DNS du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations

  • Pour plus d'informations sur l'utilisation de DNS par Exchange Server 2003 pour résoudre les adresses IP externes, voir la rubrique sur les dépendances de transport pour Exchange Server 2003 du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Pour plus d'informations sur la résolution de nom DNS, voir l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Pour plus d'informations sur la procédure de résolution des problèmes de DNS, voir la rubrique sur la résolution des problèmes de DNS (http://go.microsoft.com/fwlink/?LinkId=63003).


La valeur de Registre PoolThreadLimit des services IIS a été ajoutée et configurée manuellement
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit les entrées de Registre suivantes pour déterminer si le nombre maximal de threads de pool de services IIS a été modifié par rapport à la valeur par défaut :

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

Si Exchange Server Analyzer détecte que la valeur PoolThreadLimit est présente et configurée sur une autre valeur, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre PoolThreadLimit indique le nombre maximal de threads de travail d'entrée/sortie (E/S) pouvant être créées dans le processus Inetinfo.exe, qui, à son tour, contrôle le nombre maximal de connexions simultanées pouvant être établies avec les services IIS. Chaque thread de pool surveille une demande réseau et la traite en renvoyant un fichier statique ou en transmettant la demande à une DLL d'extension ISAPI (comme ASP.DLL) ou à une application CGI (interface de passerelle commune). Si l'extension ISAPI traite une demande simultanément et que le traitement des demandes nécessite un certain temps, la thread de travail sera bloquée et les services IIS disposeront alors de moins de threads de travail pour traiter d'autres demandes. Pour cette raison, les extensions ISAPI bien écrites comme ASP exécutent leurs propres pools de threads, placent les demandes dans une file d'attente et les traitent de manière asynchrone avec leurs propres threads de façon à ne pas bloquer les threads de travail des services IIS.

Par défaut, les services IIS définissent la valeur PoolThreadLimit sur :

2* nombre de mégaoctets de RAM présents sur l'ordinateur

Si cette valeur est supérieure à 256, elle sera bloquée sur 256. Par défaut, cette valeur de Registre n'existe pas. Si cette valeur est présente dans le Registre, elle remplace le calcul par défaut des services IIS.

En général, si vous constatez que la limite par défaut de 256 threads est inappropriée, l'extension ISAPI est probablement mal écrite et bloque les threads de travail des services IIS. La présence de 256 threads actives simultanément est considérable, ce qui provoque une surcharge système significative au niveau de la synchronisation et du changement de contextes.

La valeur de Registre PoolThreadLimit représente une limite stricte qui inclut toutes les threads de travail des services IIS, notamment les services HTTP, FTP, NNTP et SMTP.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Examinez, supprimez ou modifiez la valeur PoolThreadLimit.

  4. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).


Restriction de la taille des messages entrants et sortants
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-12-01

L'outil Microsoft® Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer si l'attribut submissionContLength de taille limite des messages sortants diffère de l'attribut delivContLength de taille limite des messages entrants. Si Exchange Server Analyzer détecte que la taille limite des messages sortants est différente de celle des messages entrants, il affiche un message de recommandation.

Il est recommandé de définir la taille limite des messages sortants et celle des messages entrants sur une valeur identique pour rester cohérent au niveau des restrictions des messages.

Modification de la limite de taille des messages sortants pour Exchange 2000 Server et Exchange Server 2003

  1. Démarrez le Gestionnaire système Exchange.

  2. Dans le volet gauche, développez Paramètres globaux.

  3. Cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  4. Sous l'onglet Valeurs par défaut, sous Envoi de la taille des messages, cliquez sur Maximale (Ko), puis entrez un nombre.
Définition des limites de taille des messages sortants pour Exchange Server 2007

  1. Dans Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxSendSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize 10MB

Pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize unlimited
 Pour modifier la taille limite des messages entrants

  1. Démarrez le Gestionnaire système Exchange.

  2. Dans le volet gauche, développez Paramètres globaux.

  3. Cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  4. Sous l'onglet Valeurs par défaut, sous Réception de la taille des messages, cliquez sur Maximale (Ko), puis entrez un nombre.
Définition des limites de taille des messages entrants pour Exchange Server 2007

  1. Dans Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxReceiveSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize 10MB

Pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize unlimited

Pour plus d'informations sur la définition de tailles limites pour les messages dans Exchange 2000 Server et Exchange Server 2003, voir l'article 322679 de la Base de connaissances Microsoft sur la procédure de définition des tailles limites pour les messages dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679).

Pour plus d'informations sur la cmdlet TransportConfig pour Exchange Server 2007, consultez la page « Set-TransportConfig » dans la référence technique d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=79237).


Réponse personnalisée du filtre de messages intelligent présente
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la valeur de Registre CustomRejectResponse est présente :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si les conditions suivantes existent :

  • La valeur CustomRejectResponse est présente.

  • Cette valeur est une chaîne valide.

    Remarque :
    La valeur de la chaîne de réponse doit commercer par 550 5.7.1 pour être reconnue comme valide.

Aucune mesure de correction n'est requise.

Dans Exchange Server 2003 Service Pack 2 (SP2), le filtrage de messages intelligent est installé et prêt à l'emploi lorsque vous installez le SP2. Exchange Server 2003 SP2 permet une personnalisation des chaînes de réponse du serveur générées et jointes au rapport de non-remise renvoyé à l'expéditeur. La réponse par défaut 550 5.7.1 Requested action not taken: message refused (550 5.7.1 Action demandée non effectuée : message refusé) peut être modifiée pour fournir aux utilisateurs légitimes bloqués une explication claire sur la raison du blocage de leur message. Cette explication permet de réduire les examens de faux positifs et les coûts associés au traitement antispam.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour modifier la chaîne de réponse personnalisée

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Exchange\ContentFilter

  3. Dans le volet Office droit, cliquez avec le bouton droit sur la valeur CustomRejectResponse et sélectionnez Modifier.

  4. Entrez la valeur de chaîne à utiliser comme réponse personnalisée, en commençant par 550 5.7.1. Par exemple, vous pouvez entrer 550 5.7.1 Domain not an allowed sender (550 5.7.1 Domaine n'est pas un expéditeur autorisé) pour définir la chaîne sur une chaîne valide qui sera jointe au rapport de non-remise.

  5. Enregistrez les modifications, quittez l'Éditeur du Registre et redémarrez le service SMTP pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le filtrage de messages intelligent, voir le site Web sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).

Pour obtenir des informations détaillées sur la procédure d'exécution de tâches de filtrage de messages intelligent, voir l'article sur la configuration du filtrage de messages intelligent dans l'aide en ligne d'Exchange Server 2003 SP2.

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Liste de mots personnalisés du filtre de messages intelligent présente
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) CIM_Datafile pour déterminer la présence d'un fichier MSExchange.UCEContentFilter.xml sur le serveur Exchange. Si Exchange Server Analyzer détecte un fichier MSExchange.UCEContentFilter.xml sur le serveur Exchange, il affiche un message indiquant une configuration autre que celle par défaut. Aucune mesure de correction n'est requise.

Le fichier MSExchange.UCEContentFilter.xml est un composant de la fonctionnalité de pondération personnalisée du filtre de messages intelligent d'Exchange Server 2003 Service Pack 2 (SP2).

La fonctionnalité de pondération personnalisée du filtre de messages intelligent du SP2 permet aux administrateurs de personnaliser le comportement du filtre de messages intelligent sur la base de phrases contenues dans le corps d'un message électronique, dans la ligne d'objet ou les deux. Aucune interface utilisateur n'est associée à la fonctionnalité de pondération personnalisée. La pondération personnalisée est disponible sous forme d'un fichier de configuration XML, MSExchange.UCEContentFilter.xml, lu par le filtre de messages intelligent lors de l'initialisation, puis rechargé à chaque modification du fichier. Si le fichier MSExchange.UCEContentFilter.xml n'est pas présent lors du démarrage du filtre de messages intelligent, vous devez redémarrer le service SMTP. Le fichier de pondération personnalisée MSExchange.UceContentFilter.xml doit être situé dans le même répertoire que les fichiers MSExchange.UceContentFilter.dll et .dat.

Pour plus d'informations sur le fichier de pondération personnalisée, voir les notes de mise à jour d'Exchange Server 2003 Service Pack 2. Les notes de mise à jour d'Exchange Server 2003 Service Pack 2 sont disponibles sur le CD-ROM du SP2 et sur le site Web des notes de mise à jour d'Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52072).

Pour plus d'informations sur le SP2 pour Exchange Server 2003, voir le site Web sur Exchange Server 2003 Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=52073).


Réponse personnalisée du filtre de messages intelligent non valide
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la clé de Registre suivante pour déterminer si la valeur de Registre CustomRejectResponse est présente :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer affiche un avertissement si les conditions suivantes existent :

  • La valeur CustomRejectResponse est présente.

  • Cette chaîne de valeur ne commence pas par 550 5.7.1.

    Remarque :
    La valeur de la chaîne de réponse doit commercer par 550 5.7.1 pour être reconnue comme valide.

Exchange Server 2003 Service Pack 2 (SP2) permet une personnalisation des chaînes de réponse du serveur générées et jointes au rapport de non-remise renvoyé à l'expéditeur. La réponse par défaut 550 5.7.1 Requested action not taken: message refused (550 5.7.1 Action demandée non effectuée : message refusé) peut être modifiée pour fournir aux utilisateurs légitimes bloqués une explication claire sur la raison du blocage de leur message. Cette explication permet de réduire les examens de faux positifs et les coûts associés au traitement antispam.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Exchange\ContentFilter

  3. Dans le volet Office droit, cliquez avec le bouton droit sur la valeur CustomRejectResponse et sélectionnez Modifier.

  4. Entrez la valeur de chaîne à utiliser comme réponse personnalisée, en commençant par 550 5.7.1. Par exemple, vous pouvez entrer 550 5.7.1 Domain not an allowed sender (550 5.7.1 Domaine n'est pas un expéditeur autorisé) pour définir la chaîne sur une chaîne valide qui sera jointe au rapport de non-remise.

  5. Enregistrez les modifications, quittez l'Éditeur du Registre et redémarrez le service SMTP pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le filtrage de messages intelligent, voir le site Web sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).

Pour obtenir des informations détaillées sur la procédure d'exécution de tâches de filtrage de messages intelligent, voir l'article sur la configuration du filtrage de messages intelligent dans l'aide en ligne d'Exchange Server 2003 SP2.


Le filtre de messages intelligent est activé sur le serveur de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le filtre de messages intelligent de Microsoft® Exchange est installé et activé sur le serveur :

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer lit la valeur ContentFilterBindings dans la clé de Registre ContentFilter pour déterminer si le filtre de messages intelligent est installé et activé sur le serveur.

Exchange Server Analyzer interroge alors le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchAuthenticationFlags pour chaque objet Exchange Server. L'attribut msExchAuthenticationFlags représente le type d'authentification autorisé sur le serveur. Exchange Server Analyzer affiche un message d'avertissement si les conditions suivantes existent :

  • L'authentification sur l'attribut msExchAuthenticationFlags a été configurée de manière à autoriser l'accès anonyme au serveur.

  • Le serveur héberge également des boîtes aux lettres.

Le filtre de messages intelligent identifie les messages susceptibles d'être des messages commerciaux indésirables. Pour filtrer efficacement les spams, vous devez développer un filtre de messages intelligent sur vos serveurs de passerelle ou vos serveurs têtes de pont Exchange si vous utilisez à la passerelle un système de messagerie qui n'appartient pas à Microsoft. Ces serveurs de passerelle acceptent les messages électroniques Internet entrants et les acheminent jusqu'au serveur de boîtes aux lettres approprié. Les serveurs de passerelle n'hébergent généralement pas de boîte aux lettres.

En outre, vous devez activer un filtre de messages intelligent sur chaque serveur virtuel SMTP qui accepte les messages électroniques Internet sur vos serveurs de passerelle Exchange.

Important :
Ne désactivez pas l'accès anonyme sur vos serveurs virtuels SMTP de passerelle Internet. Ces serveurs virtuels SMTP qui acceptent le courrier provenant d'Internet doivent autoriser l'accès anonyme.

Pour filtrer les spams, vous pouvez configurer un filtre de messages intelligent en définissant des seuils pour les contrôles d'accès SLC qui sont affectés aux messages entrants à la fois sur les banques de boîtes aux lettres de passerelle et les banques de boîtes aux lettres Exchange. Le filtre de messages intelligent évalue chaque message entrant et lui affecte un contrôle d'accès SCL qui est basé sur la plausibilité que le message est un spam. Les serveurs de boîtes aux lettres Exchange utilisent un seuil et des paramètres SCL qui sont définis pour que la banque de boîtes aux lettres détermine si le message doit être envoyé à la boîte de réception ou vers le dossier de courrier indésirable de l'utilisateur.

Important :
Le filtre de messages intelligent n'a pas besoin d'être installé sur les serveurs de boîtes aux lettres Exchange. Si le filtre de messages intelligent est installé et activé sur les serveurs virtuels SMTP de passerelle, les serveurs de boîtes aux lettres Exchange reçoivent le contrôle d'accès SCL avec chaque message entrant et effectuent l'opération appropriée.

Pour plus d'informations, voir le document sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607). Pour plus d'informations sur la configuration de votre organisation Exchange Server 2003 pour envoyer et recevoir du courrier électronique de manière plus sécurisée, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Le filtre de messages intelligent n'est pas activé sur le serveur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le filtre de messages intelligent de Microsoft® Exchange est installé et activé sur le serveur :

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Si Exchange Server Analyzer détecte que l'entrée de la valeur ContentFilterBindings de la clé de Registre ContentFilter est présente, mais que la valeur ContentFilterBindings n'est pas configurée, il affiche un message d'avertissement.

Remarque :
La présence de l'entrée de la valeur ContentFilterBindings dans la clé de Registre ContentFilter alors que la valeur ContentFilterBindings n'est pas configurée indique que le filtre de messages intelligent n'est pas activé sur le serveur.
Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Le filtre de messages intelligent Microsoft Exchange identifie les messages susceptibles d'être des messages commerciaux indésirables. Après avoir déployé le filtre de messages intelligent sur vos serveurs de passerelle Exchange ou vos serveurs têtes de pont Exchange qui acceptent les messages électroniques entrants, vous devez activer le filtre de messages intelligent sur chaque serveur virtuel SMTP qui accepte les messages électroniques entrants provenant d'Internet.

Pour afficher la clé de Registre ContentFilter

  1. Dans l'Éditeur du Registre (regedit), dans le volet Détails, cliquez avec le bouton droit sur ContentFilter pour afficher ContentFilterBindings.

    Remarque :
    Si vous n'avez pas configuré le filtre de messages intelligent sur votre serveur virtuel SMTP, la valeur ContentFilterBindings est nulle.

    Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Il est recommandé d'activer le filtre de messages intelligent Exchange sur tous les serveurs Exchange sur lesquels le filtre est installé. Pour activer le filtre de messages intelligent sur votre serveur virtuel SMTP, procédez comme suit. Après avoir activé le filtre de messages intelligent, vous pouvez vérifier la valeur de la clé de Registre ContentFilter dans le Registre.

Pour activer le filtre de messages intelligent

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans le Gestionnaire système Exchange, développez Serveurs, le nom du serveur, Protocoles, SMTP, cliquez avec le bouton droit sur Filtre de messages intelligent, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Appliquer le filtrage de messages intelligent aux adresses IP des serveurs virtuels ci-dessous, activez la case à cocher en regard de chaque serveur virtuel SMTP sur lequel activer le filtre de messages intelligent.

    Boîte de dialogue Propriétés de filtre de messages intelligent

Pour plus d'informations, voir le document sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Désignation d'un serveur de service de mise à jour de destinataire non valide
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-07-30

L'outil Microsoft Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory pour déterminer la valeur de l'attribut msExchAddressListServiceLink pour chaque objet du service de mise à jour de destinataire de l'annuaire. L'attribut msExchAddressListServiceLink est un lien du service de listes d'adresses vers un ordinateur Exchange Server qui exécute le Service de mise à jour de destinataire.

Exchange Analyzer interroge ensuite la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer la valeur de la clé Version pour le Service Affichage et groupes dynamiques du Carnet d'adresses (abv_dg.dll) sur les ordinateurs Exchange Server identifiés. La clé WMI Version indique le numéro de version de ce fichier.

Si Exchange Analyzer détecte que le numéro de version du fichier abv_dg.dll de l'un des ordinateurs identifiés commence par 08, une erreur s'affiche.

Cette erreur indique que l'ordinateur désigné comme serveur de mise à jour de destinataire exécute Microsoft Exchange Server 2007.

Le Service de mise à jour de destinataire est un composant du service Surveillance du système Exchange disponible dans Exchange 2000 Server et Exchange Server 2003. Le Service de mise à jour de destinataire pour Exchange 2000 et Exchange 2003 crée et gère les valeurs des attributs spécifiques à Exchange dans Active Directory. Cette fonctionnalité est gérée par le processus de création de destinataires dans Exchange 2007 et le Service de mise à jour de destinataire hérité ne traite pas les mises à jour s'il est exécuté sur un serveur Exchange 2007.

Pour résoudre cette erreur, désignez un serveur Exchange 2000 Server ou Exchange Server 2003 pour héberger le Service de mise à jour de destinataire.

Pour corriger cette erreur

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Services de mise à jour de destinataire. Dans le volet de navigation droit, cliquez avec le bouton droit sur l'instance appropriée du Service de mise à jour de destinataire, puis cliquez sur Propriétés.

  3. Sous Exchange Server, sous l'onglet Général, cliquez sur Parcourir et spécifiez un nouveau serveur Exchange 2000 Server ou Exchange Server 2003 pour exécuter cette instance du Service de mise à jour de destinataire.

  4. Cliquez sur OK, puis cliquez de nouveau sur OK pour que la modification soit prise en compte.


Nombre important de catégorisations en cours
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Ce moteur collecte des données à partir du compteur de performance Cat. : catégorisations en cours de l'objet de performance SMTP Server pour analyser les données de performances.

Le compteur de performance Cat. : catégorisations en cours indique le nombre de catégorisations en cours.

Pour cette requête, Exchange Server Analyzer récupère un exemple toutes les 6 secondes pendant une période de deux minutes. Il signale la valeur moyenne du compteur de performance pendant l'intervalle entre deux collectes.

Si Exchange Server Analyzer détermine que le nombre moyen de catégorisations en cours pendant la période d'exemple dépasse 800, il affiche une erreur.

Le catégoriseur effectue les opérations principales suivantes :

  • Il résout et valide tous les destinataires.

  • Il détermine les limites et restrictions pour tous les destinataires.

  • Il développe les listes de distribution si nécessaire.

  • Il détermine si le message est destiné à une remise locale ou à distance.

Cette erreur peut indiquer que le serveur subit une charge extraordinaire ou rencontre des problèmes liés aux performances.

Pour corriger cette erreur :

  • Déterminez si les contraintes du catégoriseur sont prévues ou générées par une charge habituelle. Si elles sont générées par une charge prévue, passez en revue les instructions relatives aux performances d'Exchange figurant dans les articles Microsoft TechNet suivants.

    • Rubrique sur la résolution des problèmes de performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

    • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Si les contraintes du catégoriseur ne proviennent pas d'une charge prévue, recherchez d'éventuels virus ou courriers indésirables susceptibles de générer la charge.

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP (Simple Mail Transfer Protocol). Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).


Grand nombre de boîtes aux lettres avec définition de restrictions de remise pour les groupes de distribution
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet utilisateur de tous les domaines trouvés dans le service d'annuaire Active Directory® pour déterminer si des boîtes aux lettres de ces domaines possèdent des définitions de restrictions de remise basées sur l'appartenance au groupe de distribution :

dLMemDefault | Contrôle si les messages sont acceptés ou rejetés par défaut. Lorsque cet attribut est défini sur le paramètre par défaut 1, les messages provenant de tous les expéditeurs sont acceptés.
dLMemRejectPerms | Contient les noms de domaine des listes de distribution dont les membres ne peuvent rien envoyer à ce destinataire.
dLMemSubmitPerms | Contient les noms de domaine des listes de distribution dont les membres peuvent effectuer des envois vers ce destinataire.

Si Exchange Server Analyzer détermine que des restrictions de remise sont définies pour plus de 500 boîtes aux lettres du domaine sur la base de l'appartenance au groupe de distribution, il affiche un avertissement.

Cette erreur indique que des restrictions de remise sur la base de l'appartenance au groupe de distribution pour plusieurs boîtes aux lettres peuvent affecter les performances de flux de messages d'Exchange.

Par défaut, le catégoriseur développe de manière récurrente les groupes de distribution et vérifie les restrictions pour chaque message qui passe par le système.

Lorsque le catégoriseur de messages envoie du courrier à un utilisateur qui accepte ou refuse des messages d'un groupe de distribution, il doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas d'affichage d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

Pour corriger cette erreur :

  • Identifiez les utilisateurs pour lesquels des restrictions de remise pour le groupe de distribution sont définies et supprimez les restrictions inutiles.

  • Configurez les boîtes aux lettres individuelles et pas les groupes de distribution pour les restrictions de remise comme décrit dans l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Pour les serveurs qui exécutent Exchange Server 2003 Service Pack 2 (SP2) ou version ultérieure, envisagez la mise en œuvre de la vérification des restrictions non hiérarchiques. Pour les serveurs qui exécutent des versions d'Exchange antérieures à Exchange Server 2003 SP2, envisagez la mise à niveau vers Exchange Server 2003 SP2.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Le routage de moindre coût est activé dans une organisation en mode mixte
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le routage de moindre coût est activé sur le serveur qui exécute la version 5.5 d'Exchange Server dans un environnement en mode mixte. Exchange Server Analyzer affiche un avertissement si les conditions suivantes existent :

  • Le routage de moindre coût est activé.

  • Votre organisation exécute Exchange Server 2003 dans un environnement en mode mixte avec Exchange Server 5.5.

Lorsque le routage de moindre coût est activé dans un environnement en mode mixte, des boucles de message peuvent être créées. Exchange Server 2003 utilise le routage d'état des liens. Par conséquent, Exchange Server 2003 redirige les messages vers un autre serveur lorsqu'il détecte qu'un lien est arrêté. Si un serveur Exchange Server 5.5 utilise l'option Only use least cost routes dans la page de propriétés Message Transfer Agent, le meilleur itinéraire est souvent le retour au serveur Exchange Server 2003 qui vient d'envoyer le message. Lorsque le message est renvoyé au serveur Exchange Server 2003, l'itinéraire devient une boucle.

Dans le cas d'une organisation en mode mixte exécutant Exchange Server 5.5 et Exchange Server 2003, il est conseillé de désactiver l'option de routage de moindre coût sur tous les serveurs exécutant Exchange Server 5.5.

Pour désactiver le routage de moindre coût dans Exchange Server 5.5

  1. Dans le programme Microsoft Exchange Server Administrator, développez les conteneurs Organisation, Site, Configuration, Serveurs et cliquez sur l'objet serveur.

  2. Dans le volet droit, cliquez sur l'objet Agent de transfert des messages.

  3. Cliquez sur le menu Fichier, puis sur Propriétés.

  4. Dans la boîte de dialogue Propriétés de l'Agent de transfert des messages, sous l'onglet Général, désactivez l'option Only use least cost routing.

  5. Cliquez sur OK.


Le port d'écoute pour SMTP semble avoir été modifié et différer de sa valeur par défaut de 25
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchServerBindings a été modifiée et diffère de sa valeur par défaut de 25. Si Exchange Server Analyzer détecte que la valeur de cet attribut diffère de 25, un message indiquant une configuration autre que celle par défaut s'affiche.

L'attribut msExchServerBindings représente le port TCP sur lequel ce serveur SMTP (Simple Mail Transfer Protocol) écoute les connexions entrantes. Les serveurs virtuels SMTP peuvent être configurés pour écouter sur un ou plusieurs ports TCP. Par défaut, tous les serveurs virtuels SMTP sont configurés pour écouter sur le port TCP 25, le port SMTP par défaut. Si le port d'écoute SMTP a été modifié par rapport à sa valeur par défaut et n'inclut plus le port TCP 25 dans sa liste de ports d'écoute, il peut perturber le flux de messages.

Vous pouvez modifier le port d'écoute SMTP, pour autant que vous modifiez en conséquence l'ensemble de l'infrastructure de messagerie interne. Toutefois, il n'est généralement pas possible d'utiliser d'autres ports pour des serveurs virtuels SMTP qui acceptent des messages directement depuis Internet, dans la mesure où les serveurs SMTP sur Internet envoient les messages par le biais du port 25.

Notez qu'Exchange Server Analyzer recherche la valeur pour le serveur virtuel de protocole SMTP Exchange. Ce serveur n'est pas forcément le serveur SMTP qui reçoit les messages directement depuis Internet. Certains produits antivirus et antispam sont conçus pour recevoir des messages SMTP depuis Internet sur le port 25 et les rediriger vers un serveur virtuel SMTP Exchange sur un autre port. Dans ce scénario, un serveur virtuel SMTP Exchange qui écoute sur un port autre que le 25 est une configuration acceptable.

Pour afficher ou modifier le port d'écoute du serveur virtuel SMTP

  1. Dans le Gestionnaire système Exchange, développez Serveurs, développez un serveur Exchange, développez Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut), puis cliquez sur Propriétés.

  3. Sélectionnez l'onglet Général, puis cliquez sur Avancé.

  4. Une liste de ports et d'adresses IP s'affiche.

    • Pour modifier le port existant, sélectionnez l'adresse IP, puis cliquez sur Modifier. Modifiez le champ du port TCP en 25.

    • Pour ajouter le port 25 comme port d'écoute supplémentaire, cliquez sur Ajouter et ajoutez la nouvelle combinaison adresse IP/port. Si vous utilisez le filtre connexion, expéditeur ou destinataire, assurez-vous d'activer les cases à cocher appropriées.

  5. Cliquez sur OK pour enregistrer vos modifications, puis de nouveau sur OK pour quitter la boîte de dialogue Avancé. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La file d'attente « Remise locale » est figée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateFrozen pour la file d'attente SMTP (Simple Mail Transfer Protocol) Remise locale.

Si Exchange Server Analyzer détecte que la valeur de la clé StateFrozen pour la file d'attente Remise locale d'un serveur Exchange est définie sur True, il affiche une erreur.

Une file d'attente figée signifie l'arrêt des sessions de transport pour cette file d'attente. Une file d'attente figée empêche les messages de sortir, bien que de nouveaux messages puissent être ajoutés. Vous pouvez modifier manuellement l'état d'une connexion à l'aide du menu contextuel dans chaque file d'attente de liens. Si vous utilisez la commande Forcer la connexion pour modifier l'état d'une file d'attente en Actif, vous activez immédiatement une connexion qui envoie les messages de cette file d'attente.

La file d'attente Remise locale contient les messages qui sont mis en file d'attente sur le serveur Exchange, à des fins de remise locale vers une boîte aux lettres ou une banque de dossiers publics Exchange Server.

Les messages peuvent s'accumuler dans cette file d'attente si le serveur Exchange n'accepte pas les messages pour la remise locale. Une remise ralentie ou intermittente des messages peut indiquer une boucle de message ou un problème de performances.

Pour résoudre cette erreur, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport afin de collecter des informations sur les composants du catégoriseur.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La file d'attente « Remise locale » présente l'état Réessayer
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateRetry pour la file d'attente SMTP (Simple Mail Transfer Protocol) Remise locale.

Si Exchange Server Analyzer détecte que la valeur de la clé StateRetry pour la file d'attente Remise locale d'un serveur Exchange est définie sur True, il affiche une erreur.

Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente. Vous pouvez modifier les files d'attente présentant l'état Réessayer ou Planifiée en Actif à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner. N'oubliez pas que les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

La file d'attente Remise locale contient les messages qui sont mis en file d'attente sur le serveur Exchange, à des fins de remise locale vers une boîte aux lettres ou une banque de dossiers publics Exchange Server.

Les messages peuvent s'accumuler dans cette file d'attente si le serveur Exchange n'accepte pas les messages pour la remise locale. Une remise ralentie ou intermittente des messages peut indiquer une boucle de message ou un problème de performances.

Pour résoudre cette erreur, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport afin de collecter des informations sur les composants du catégoriseur.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Échec d'acceptation des messages
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool tente d'envoyer un message vers le compte administrateur ou un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol) comme suit :

  • Exchange Server Analyzer ouvre une connexion de socket sur le serveur SMTP. Si Exchange Server Analyzer reçoit le code de réponse 220, cette étape est considérée comme réussie.

  • Exchange Server Analyzer transmet le verbe de commande SMTP EHLO. Si les conditions suivantes sont vraies, cette étape est considérés comme réussie :

    • Exchange Server Analyzer reçoit une série de codes de réponse 250.

    • L'une de ces réponses comprend 250-X-LINK2STATE et 250-XEXCH50.

  • Exchange Server Analyzer transmet le verbe de commande SMTP MAIL FROM: ExMFA-MailAcceptTest@Fabrikam.com. Si Exchange Server Analyzer reçoit le code de réponse 250, cette étape est considérée comme réussie.

  • Exchange Server Analyzer transmet le verbe de commande SMTP RCPT TO: administrateur (ou un compte défini par l'utilisateur)@<nom_domaine>.com. Si Exchange Server Analyzer reçoit le code de réponse 250, cette étape est considérée comme réussie.

  • Exchange Server Analyzer transmet le verbe de commande SMTP DATA avec un corps de message en guise d'exemple se terminant par un point. Si Exchange Server Analyzer reçoit le code de réponse 250, cette étape est considérée comme réussie.

Si Exchange Server Analyzer ne peut pas effectuer toute cette procédure, il affiche une erreur : Cette erreur indique l'existence probable d'un problème général de flux de messages. Les liens suivants sont indiqués dans l'ordre dans lequel vous devez procéder au dépannage, en commençant par le niveau serveur pour terminer par le niveau réseau.

Pour corriger cette erreur

  1. Voir la section sur la résolution des problèmes de routage du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579).

  2. Voir l'article 324867 de la Base de connaissances Microsoft sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server concernant le dépannage des problèmes de flux de messages (révision) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867).

  3. Voir l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489).

  4. Voir l'article 324759 de la Base de connaissances Microsoft sur la Webdiffusion du Support Technique pour Microsoft Exchange 2000 Server concernant le dépannage DNS dans les transports (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759).

Pour plus d'informations sur le compte administrateur dans Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 223860 sur la configuration manuelle de la boîte aux lettres administrateur SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860).

  • 313832 sur la procédure de définition d'un compte SMTP d'administrateur dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832).


Échec d'acceptation du courrier, commande BDAT
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool transmet le verbe de commande ESMTP (EHLO Extended Simple Mail Transfer Protocol) au port 25 d'un serveur distant et analyse la réponse pour déterminer si le serveur distant prend en charge le verbe ESMTP BDAT.

Si la réponse reçue du serveur distant au verbe de commande BDAT n'indique aucune erreur irrécupérable, Exchange Server Analyzer transmet ensuite un message de test au serveur distant et analyse la réponse pour déterminer si le transfert du message a réussi.

Si Exchange Server Analyzer n'obtient pas la chaîne de réponse prévue (250), il affiche une erreur.

Exchange Server 2003 utilise des verbes SMTP étendus spécifiques à Exchange pour communiquer avec d'autres serveurs utilisant Exchange Server dans l'organisation. Il est plus efficace de communiquer avec des verbes SMTP étendus spécifiques à Exchange que d'utiliser le protocole SMTP standard. Si la prise en charge de l'ensemble de commandes ESMTP est désactivée, les performances d'Exchange Server risquent d'être altérées.

Le verbe de commande ESMTP BDAT constitue une alternative à la commande DATA. Lorsqu'un serveur virtuel SMTP répond au mot-clé EHLO avec CHUNKING, le serveur SMTP indique qu'il prend en charge la commande BDAT et accepte les messages en blocs. Deux arguments sont utilisés.

  • Le premier argument indique la longueur du paquet de données binaires. Par conséquent, l'hôte SMTP ne doit pas rechercher en permanence la fin des données. Le serveur récepteur compte les octets du messages. Si la taille du message est égale à la valeur envoyée par la commande BDAT, le serveur suppose qu'il a reçu toutes les données du message.

  • Le deuxième argument indique si le paquet de données est le dernier de la transmission actuelle. Il est facultatif.

Cette erreur indique que bien que le verbe de commande ESMTP BDAT soit pris en charge par le serveur distant, le test d'acceptation du courrier BDAT qui suit échoue.

Pour résoudre cette erreur, recherchez dans l'environnement de messagerie les problèmes ou configurations pouvant bloquer le verbe de commande BDAT, notamment :

  • des pannes de réseau temporaires ;

  • des proxys SMTP ;

  • des pare-feu ;

  • des applications.

Pour plus d'informations sur la procédure de suppression ou de restauration de la prise en charge par défaut de ces verbes, voir l'article 257569 de la Base de connaissances Microsoft sur la procédure de désactivation des verbes ESMTP dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569).

Pour plus d'informations sur la manière dont Exchange Server utilise les verbes de commande ESMTP, voir la section sur la procédure de chargement correct de SMTP Exchange du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=71800).


Identification de la banque de boîtes aux lettres comme destination commune
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-04

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Queue pour déterminer les valeurs des attributs suivants pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur le serveur virtuel SMTP.

LinkId | Indique l'identificateur du lien contenant la file d'attente.
QueueId | Indique l'identificateur de la file d'attente.
QueueName | Indique le nom de la file d'attente.
VirtualMachine | Indique le nom de la machine virtuelle contenant la file d'attente.
VirtualServerName | Indique le nom du serveur virtuel contenant la file d'attente.
MessageCount | Indique le nombre de messages dans la file d'attente.

Exchange Server Analyzer utilise les informations obtenues ci-avant pour interroger la classe WMI Exchange_QueuedSMTPMessage afin d'obtenir les valeurs des attributs suivants des messages figurant dans la file d'attente :

Recipients | Indique les destinataires du message.
Received | Indique l'horodatage reçu pour le message.
MessageId | Indique l'identificateur du message en file d'attente.
StateRetry | Indique qu'une nouvelle tentative de transmission a lieu pour un message qui n'a pas été remis avec succès.

Enfin, Exchange Server Analyzer utilise les données obtenues ici pour interroger le service d'annuaire Active Directory® pour déterminer les valeurs suivantes de chaque objet Recipient. Exchange Server Analyzer détermine ensuite si le destinataire est un utilisateur, un groupe de distribution, un dossier public ou une banque de dossiers publics :

distinguishedName | Indique le nom unique de l'objet.
msExchHomeServerName | Indique le serveur sur lequel le destinataire est hébergé.
homeMDB | Indique la banque de boîtes aux lettes du destinataire.

Si Exchange Server Analyzer détermine qu'au moins 25 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à des destinataires dont les boîtes aux lettres sont hébergées dans la même banque de boîtes aux lettres, Exchange Server Analyzer affiche un message d'avertissement.

Si Exchange Server Analyzer détermine qu'au moins 50 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à des destinataires dont les boîtes aux lettres sont hébergées dans la même banque de boîtes aux lettres, Exchange Server Analyzer affiche un message d'erreur.

Ce message d'avertissement ou d'erreur signifie que la banque de boîtes aux lettres identifiée est une destination commune des messages bloqués dans une file d'attente SMTP.

Pour résoudre ce problème, il convient de vérifier s'il y a des problèmes de configuration ou d'autres anomalies en relation avec la banque de boîtes aux lettres, qui pourraient être à l'origine de la mise en file d'attente des messages :

  • Assurez-vous que les attributs de l'objet banque sont correctement définis et contiennent les valeurs correctes dans Active Directory.

  • Vérifiez que les autorisations Active Directory de l'objet banque sont correctement paramétrées.

  • Si la banque de boîtes aux lettres est pour un objet utilisateur destiné à usage particulier, à savoir un destinataire de la journalisation désigné, examinez les configurations du service ou des composants auxquels l'objet utilisateur est associé pour vérifier si la configuration est correcte.

  • Recherchez la présence éventuelle de publicités commerciales non sollicitées (UCE) ou de courrier indésirable, ou d'attaques de virus dirigées contre les destinataires de la banque.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


La file d'attente « Messages à destination inaccessible » contient des messages
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-04

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour déterminer la valeur des propriétés TypeCurrentlyUnreachable, LinkName et NumberofMessages pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur un serveur.

La propriété TypeCurrentlyUnreachable, si sa valeur est True, spécifie que le lien (file d'attente Exchange) contient des messages concernant des destinations actuellement inaccessibles.

La propriété LinkName spécifie le nom du lien.

La propriété NumberOfMessages spécifie le nombre de messages en attente de transmission sur le lien.

Si Exchange Server Analyzer détermine que la file d'attente SMTP Messages à destination inaccessible contient des messages, Exchange Server Analyzer affiche un message d'erreur.

Cette erreur indique que la file d'attente contient des messages qui ne peuvent pas atteindre le serveur de destination voulu. Par exemple, Exchange ne parvient pas à identifier un itinéraire ou un connecteur vers la destination finale. De la même façon, l'ensemble des itinéraires et des connecteurs disponibles sont marqués comme arrêtés.

Pour résoudre cette erreur, procédez comme suit :

  • Déterminez si les messages figurant dans la file d'attente Messages à destination inaccessible sont légitimes.

  • Consultez les recommandations et les liens relatifs à l'erreur fournis par Exchange Server Analyzer.

  • Suivez les instructions de la section « Pour plus d'informations » ci-après dans cette rubrique.

Pour plus d'informations

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


File d'attente « Messages à destination inaccessible » figée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateFrozen pour la file d'attente SMTP (Simple Mail Transfer Protocol) Messages à destination inaccessible.

Si Exchange Server Analyzer détecte que la valeur de la clé StateFrozen pour la file d'attente Messages à destination inaccessible d'un serveur Exchange est définie sur True, il affiche un message d'erreur.

Une file d'attente figée signifie l'arrêt des sessions de transport pour cette file d'attente. Une file d'attente figée empêche les messages de sortir, bien que de nouveaux messages puissent être ajoutés.

La file d'attente Messages à destination inaccessible contient les messages qui n'ont pas pu atteindre le serveur de destination voulu. Par exemple, Exchange ne parvient pas à identifier un itinéraire ou un connecteur vers la destination finale. De la même façon, l'ensemble des itinéraires et des connecteurs disponibles sont marqués comme arrêtés. Des messages peuvent s'accumuler dans cette file d'attente si l'une des conditions suivantes est vraie :

  • Il n'existe pas d'itinéraire pour la remise des messages.

  • Un connecteur Exchange ou une file d'attente de remise distante est inaccessible.

  • Les nouveaux messages sont déplacés vers cette file d'attente quand un connecteur Exchange ou une file d'attente de remise distante est en attente de nouvelle tentative et aucun autre itinéraire disponible n'existe vers le connecteur ou la destination distante.

Pour remédier à cette erreur, modifiez manuellement l'état de la connexion à l'aide du menu contextuel dans chaque file d'attente de liaison. Si vous utilisez la commande Forcer la connexion pour modifier l'état d'une file d'attente en Active, vous activez immédiatement une connexion qui envoie les messages de cette file d'attente. Si l'erreur persiste, élevez le niveau d'enregistrement des diagnostics du moteur de files d'attente en procédant de la manière décrite dans la section « Pour plus d'informations » ci-après dans cette rubrique.

Pour plus d'informations

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, consultez la section sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la rubrique sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


File d'attente « Messages à destination inaccessible » en attente de nouvelle tentative
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateRetry pour la file d'attente SMTP (Simple Mail Transfer Protocol) Messages à destination inaccessible.

Si Exchange Server Analyzer détecte que la valeur de la clé StateRetry pour la file d'attente Messages à destination inaccessible d'un serveur Exchange est définie sur True, il affiche un message d'erreur.

Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

La file d'attente Messages à destination inaccessible contient les messages qui n'ont pas pu atteindre le serveur de destination voulu. Par exemple, Exchange ne parvient pas à identifier un itinéraire ou un connecteur vers la destination finale. De la même façon, l'ensemble des itinéraires et des connecteurs disponibles sont marqués comme arrêtés. Des messages peuvent s'accumuler dans cette file d'attente si l'une des conditions suivantes est vraie :

  • Il n'existe pas d'itinéraire pour la remise des messages.

  • Un connecteur Exchange ou une file d'attente de remise distante est inaccessible.

  • Les nouveaux messages sont déplacés vers cette file d'attente quand un connecteur Exchange ou une file d'attente de remise distante est en attente de nouvelle tentative et aucun autre itinéraire disponible n'existe vers le connecteur ou la destination distante.

Pour corriger cette erreur, modifiez l'état Réessayer en Active à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé. Toutefois, cette méthode risque de ne pas toujours fonctionner. Si l'erreur persiste, élevez le niveau d'enregistrement des diagnostics du moteur de files d'attente en procédant de la manière décrite dans la section « Pour plus d'informations » ci-après dans cette rubrique.

Pour plus d'informations

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, consultez la section sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la rubrique sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Boîtes aux lettres avec définition de restrictions de remise de messages pour le groupe de distribution
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet utilisateur de tous les domaines trouvés dans le service d'annuaire Active Directory® pour déterminer si des boîtes aux lettres de ces domaines possèdent des définitions de restrictions de remise basées sur l'appartenance au groupe de distribution :

dLMemDefault | Contrôle si les messages sont acceptés ou rejetés par défaut. Lorsque cet attribut est défini sur le paramètre par défaut 1, les messages provenant de tous les expéditeurs sont acceptés.
dLMemRejectPerms | Contient les noms de domaine des listes de distribution dont les membres ne peuvent rien envoyer à ce destinataire.
dLMemSubmitPerms | Contient les noms de domaine des listes de distribution dont les membres peuvent effectuer des envois vers ce destinataire.

Si Exchange Server Analyzer détermine que des restrictions de remise sont définies pour des boîtes aux lettres du domaine sur la base de l'appartenance au groupe de distribution, il affiche un avertissement.

Cet avertissement indique que des restrictions de remise sur la base de l'appartenance au groupe de distribution peuvent affecter les performances de flux de messages d'Exchange Server.

Par défaut, le catégoriseur développe de manière récurrente les groupes de distribution et vérifie les restrictions pour chaque message qui passe par le système.

Lorsque le catégoriseur de messages envoie du courrier à un utilisateur qui accepte ou refuse des messages d'un groupe de distribution, il doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas d'affichage d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

Pour supprimer cet avertissement :

  • Identifiez les utilisateurs pour lesquels des restrictions de remise pour le groupe de distribution sont définies et supprimez les restrictions inutiles.

  • Configurez les boîtes aux lettres individuelles et pas les groupes de distribution pour les restrictions de remise comme décrit dans l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Pour les serveurs qui exécutent Exchange Server 2003 Service Pack 2 (SP2) ou version ultérieure, envisagez la mise en œuvre de la vérification des restrictions non hiérarchiques. Pour les serveurs qui exécutent des versions d'Exchange antérieures à Exchange Server 2003 SP2, envisagez la mise à niveau vers Exchange Server 2003 SP2.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


La taille maximale des messages entrants n'a pas été définie
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut delivContLength des paramètres globaux se trouvant à l'emplacement :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Paramètres_globaux, CN=Remise_messages

Si Exchange Server Analyzer détecte que la valeur de l'attribut delivContLength est inférieure à 1, une erreur s'affiche.

Cette erreur indique que la taille limite des messages entrants n'a pas été définie. Selon la bande passante du réseau et la configuration requise pour les utilisateurs de votre organisation, vous souhaiterez peut-être limiter la taille des messages. Dans Exchange 2000 Server et Exchange Server 2007, il n'existe aucune taille limite des messages par défaut. Dans Exchange Server 2003, la taille limite par défaut pour l'envoi et la réception de messages est de 10 240 Ko. Cette limite de taille par défaut pour Exchange Server 2003 s'applique à de nouvelles installations et à des mises à niveau d'Exchange 2000 Server, dans lesquelles aucune limite de taille des messages n'est définie.

Vous pouvez économiser des ressources système en définissant des tailles limites des messages, qui empêchent les utilisateurs d'envoyer et de recevoir des messages électroniques volumineux. Cela aidera à limiter le trafic réseau, à économiser de l'espace disque et à améliorer les performances réseau globales. Pour Exchange 2000 Server et Exchange Server 2003, vous pouvez utiliser l'onglet Valeurs par défaut dans les Propriétés de remise des messages de vos Paramètres globaux pour spécifier des restrictions de remise pour les messages entrants et sortants. Pour définir la taille maximale des messages individuels, sélectionnez Maximale (Ko), puis, dans la zone de texte, tapez une taille maximale en kilo-octets (Ko). Si vous ne souhaitez pas limiter la taille des messages, sélectionnez Aucune limite. Les expéditeurs de votre organisation reçoivent une notification d'échec de remise s'ils tentent d'envoyer un message à un utilisateur qui dépasse la taille limite spécifiée. Selon les paramètres de la notification d'échec de remise que vous avez définis dans l'option Formats des messages Internet, il se peut que les expéditeurs externes ne puissent pas recevoir cette notification.

Pour Exchange Server 2007, vous pouvez utiliser l'environnement de ligne de commande Exchange Management Shell pour définir le paramètre TransportConfig MaxReceiveSize pour l'organisation Exchange.

Il est recommandé de ne pas définir la taille limite des messages sur une valeur supérieure à 10 Mo. Toutefois, si vous avez besoin d'une taille limite plus élevée pour les messages contenant des pièces jointes volumineuses à envoyer dans l'organisation Exchange, vous souhaiterez peut-être augmenter la taille limite maximale des messages entrants à 30 Mo. L'augmentation de la taille limite des messages à plus de 30 Mo risque de ralentir les performances de votre réseau, voire d'accroître la vulnérabilité de votre système aux attaques de sécurité.

Définition de limite de taille des messages pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Receiving message size limit (Taille limite des messages entrants) et entrez la taille limite souhaitée.

Définition des limites de taille des messages pour Exchange Server 2007

  1. Dans l'environnement de ligne de commande Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxReceiveSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize 10MB

Pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize unlimited
  • Pour plus de détails sur la définition des limites de taille des messages pour Exchange 2000 Server et Exchange Server 2003, consultez l'article 322679 de la Base de connaissances Microsoft sur la définition des limites de taille des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Pour plus d'informations sur la cmdlet TransportConfig pour Exchange Server 2007, consultez la page « Set-TransportConfig » dans la référence technique d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Pour plus d'informations sur les formats de messages Internet, consultez la rubrique sur la configuration des stratégies SMTP pour contrôler la mise en forme des messages sortants et les réponses automatiques dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


La taille maximale des messages entrants est définie sur une valeur trop élevée (>30 Mo)
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-02-27

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut delivContLength des paramètres globaux se trouvant à l'emplacement :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Paramètres_globaux, CN=Remise_messages

Si Exchange Server Analyzer détecte que la valeur de l'attribut delivContLength est supérieure à 30 720, une erreur s'affiche.

Cette erreur indique que la taille limite maximale des messages entrants est définie sur une valeur supérieure à 30 mégaoctets (Mo). Dans Exchange 2000 Server et Exchange Server 2007, il n'existe aucune taille limite des messages par défaut. Dans Exchange Server 2003, la taille limite par défaut pour l'envoi et la réception de messages est de 10 240 Ko. La taille limite par défaut s'applique à des nouvelles installations et à des mises à niveau d'Exchange 2000 Server, dans lesquelles aucune taille limite des messages n'est définie.

Vous pouvez économiser des ressources système en définissant des tailles limites de messages, qui empêchent les utilisateurs d'envoyer et de recevoir des messages électroniques volumineux. Cela aidera à limiter le trafic réseau, à économiser de l'espace disque et à améliorer les performances réseau globales. Pour Exchange 2000 Server et Exchange Server 2003, vous pouvez utiliser l'onglet Valeurs par défaut dans les Propriétés de remise des messages de vos Paramètres globaux pour spécifier des restrictions de remise pour les messages entrants et sortants. Pour définir la taille maximale des messages individuels, sélectionnez Maximale (Ko), puis, dans la zone de texte, entrez une taille maximale en kilo-octets (Ko). Si vous ne souhaitez pas limiter la taille des messages, sélectionnez Aucune limite. Les expéditeurs de votre organisation reçoivent une notification d'échec de remise s'ils tentent d'envoyer un message supérieur à la taille limite spécifiée à un utilisateur. Selon les paramètres de la notification d'échec de remise que vous avez définis dans l'option Formats des messages Internet, il se peut que les expéditeurs externes ne puissent pas recevoir cette notification.

Pour Exchange Server 2007, vous pouvez utiliser l'environnement de ligne de commande Exchange Management Shell pour définir le paramètre TransportConfig MaxSendSize pour l'organisation Exchange.

Il est recommandé de ne pas définir la taille limite des messages sur une valeur supérieure à 30 Mo. Toutefois, si vous avez besoin d'une taille limite plus élevée pour les messages contenant des pièces jointes volumineuses à envoyer dans l'organisation Exchange, vous souhaiterez peut-être augmenter la taille limite maximale des messages entrants à 30 Mo. L'augmentation de la taille limite des messages à plus de 30 Mo risque de ralentir les performances de votre réseau, voire d'accroître la vulnérabilité de votre système aux attaques de sécurité.

Important :
Même s'ils peuvent sembler similaires, les résultats des configurations suivantes diffèrent de façon considérable pour les environnements Exchange 2000 Server/Exchange Server 2003 et les environnements Exchange Server 2007 purs.

Définir les restrictions de taille de message envoyés et reçus sur une valeur de 0 dans les paramètres globaux pour un utilisateur doté d'une boîte aux lettres dans un environnement Exchange 2000 Server/Exchange Server 2003 pur entraîne la suppression totale des restrictions de taille de message.

Définir les paramètres TransportConfig -MaxSendSize et TransportConfig -MaxreceiveSize sur la valeur 0 dans un environnement Exchange 2007 pur entraîne la restriction de l'envoi des messages de toute taille.

Définition de limite de taille des messages pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Receiving message size limit (Taille limite des messages entrants) et entrez la taille limite souhaitée.

Définition des limites de taille des messages pour Exchange Server 2007

  1. Dans l'environnement de ligne de commande Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxReceiveSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize 10MB

Pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize unlimited
  • Pour plus de détails sur la définition des limites de taille des messages pour Exchange 2000 Server et Exchange Server 2003, consultez l'article 322679 de la Base de connaissances Microsoft sur la définition des limites de taille des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Pour plus d'informations sur la cmdlet TransportConfig pour Exchange Server 2007, consultez la page « Set-TransportConfig » dans la référence technique d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Pour plus d'informations sur les formats de messages Internet, consultez la rubrique sur la configuration des stratégies SMTP pour contrôler la mise en forme des messages sortants et les réponses automatiques dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


La taille maximale des messages entrants est peut-être définie sur une valeur trop faible (<1 Mo)
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut delivContLength des paramètres globaux se trouvant à l'emplacement :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Paramètres_globaux, CN=Remise_messages

Si Exchange Server Analyzer détecte que la valeur de l'attribut delivContLength est inférieure à 1 024, mais supérieure à 0, une erreur s'affiche.

Cette erreur indique que la taille limite maximale des messages entrants est définie sur une valeur inférieure à 1 mégaoctet (Mo). Une valeur aussi faible risque d'empêcher Exchange Server d'accepter certains des messages envoyés à votre organisation. Dans Exchange 2000 Server et Exchange Server 2007, il n'existe aucune taille limite des messages par défaut. Dans Exchange Server 2003, la taille limite par défaut pour l'envoi et la réception de messages est de 10 240 Ko. La taille limite par défaut s'applique à des nouvelles installations et à des mises à niveau d'Exchange 2000 Server, dans lesquelles aucune taille limite des messages n'est définie.

Vous pouvez économiser des ressources système en définissant des tailles limites de messages, qui empêchent les utilisateurs d'envoyer et de recevoir des messages électroniques volumineux. Cela aidera à limiter le trafic réseau, à économiser de l'espace disque et à améliorer les performances réseau globales. Pour Exchange 2000 Server et Exchange Server 2003, vous pouvez utiliser l'onglet Valeurs par défaut dans les Propriétés de remise des messages de vos Paramètres globaux pour spécifier des restrictions de remise pour les messages entrants et sortants. Pour définir la taille maximale des messages individuels, sélectionnez Maximale (Ko), puis, dans la zone de texte, entrez une taille maximale en kilo-octets (Ko). Si vous ne souhaitez pas limiter la taille des messages, sélectionnez Aucune limite. Les expéditeurs de votre organisation reçoivent une notification d'échec de remise s'ils tentent d'envoyer un message à un utilisateur qui dépasse la taille limite spécifiée. Selon les paramètres de la notification d'échec de remise que vous avez définis dans l'option Formats des messages Internet, il se peut que les expéditeurs externes ne puissent pas recevoir cette notification.

Pour Exchange Server 2007, vous pouvez utiliser l'environnement de ligne de commande Exchange Management Shell pour définir le paramètre TransportConfig MaxSendSize pour l'organisation Exchange.

Il est recommandé de ne pas définir la taille limite des messages sur une valeur supérieure à 10 Mo. Toutefois, si vous avez besoin d'une taille limite plus élevée pour les messages contenant des pièces jointes volumineuses à envoyer dans l'organisation Exchange, vous souhaiterez peut-être augmenter la taille limite maximale des messages entrants à 30 Mo. L'augmentation de la taille limite des messages à plus de 30 Mo risque de ralentir les performances de votre réseau, voire d'accroître la vulnérabilité de votre système aux attaques de sécurité.

Définition de limite de taille des messages pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Receiving message size limit (Taille limite des messages entrants) et entrez la taille limite souhaitée.

Définition des limites de taille des messages pour Exchange Server 2007

  1. Dans l'environnement de ligne de commande Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxReceiveSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize 10MB

Pour définir la taille maximale des messages que peuvent recevoir des destinataires au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxReceiveSize unlimited
  • Pour plus de détails sur la définition des limites de taille des messages pour Exchange 2000 Server et Exchange Server 2003, consultez l'article 322679 de la Base de connaissances Microsoft sur la définition des limites de taille des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Pour plus d'informations sur la cmdlet TransportConfig pour Exchange Server 2007, consultez la page « Set-TransportConfig » dans la référence technique d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Pour plus d'informations sur les formats de messages Internet, consultez la rubrique sur la configuration des stratégies SMTP pour contrôler la mise en forme des messages sortants et les réponses automatiques dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


MaxDSNSize non définie
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la taille maximale des messages de notification d'état de remise (DSN) a été définie :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut serialNumber pour tous les objets disposant d'une classe d'objet de msExchExchangeServer. Si la valeur de chaîne contient « Version 5.5 », l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient « Version 6.0 », l'ordinateur exécute Microsoft Exchange 2000 Server. Si la valeur de chaîne contient « Version 6.5 », l'ordinateur exécute Microsoft Exchange Server 2003.

Si Exchange Server Analyzer détecte que la valeur de Registre MaxDSNSize n'existe pas sur un ordinateur qui utilise Exchange 2000 Server ou Exchange Server 2003, un avertissement s'affiche.

La valeur de Registre MaxDSNSize est une valeur facultative dans Exchange Server qui limite la taille des notifications d'état de remise. Cette option configure Exchange pour qu'il supprime les pièces jointes si un message ne peut pas être remis. Si vous ajoutez cette valeur de Registre, il est recommandé d'utiliser une valeur de 10 240 000 octets (10 mégaoctets).

Remarque :
La valeur de Registre MaxDSNSize a été introduite dans le Service Pack 2 (SP2) pour Exchange 2000 Server et nécessite par conséquent l'utilisation d'Exchange 2000 Server SP2 ou versions ultérieures. En outre, dans le Service Pack 1 pour Exchange Server 2003 et les versions ultérieures, une valeur de 10 mégaoctets est utilisée en l'absence de la valeur de Registre MaxDSNSize. Si vous le souhaitez, vous pouvez ajouter la valeur de Registre MaxDSNSize pour remplacer ce comportement par défaut.

Si vous activez cette option, vous pouvez enregistrer les ressources du serveur et les ressources réseau. Toutefois, cette implémentation de la suppression de pièce jointe SMTP (Simple Mail Transfer Protocol) présente des inconvénients. Si vous activez cette option pour supprimer les pièces jointes du rapport de non-remise, les détails nécessaires pour afficher la notification dans le volet de visualisation sont également supprimés et l'expéditeur du message ne peut pas utiliser l'option Renvoyer. Si l'expéditeur du message tente d'utiliser l'option Renvoyer depuis le rapport de non-remise, il reçoit le message d'erreur suivant : Impossible de renvoyer le message. Le rapport de non-remise ne contient pas suffisamment d'informations sur le message d'origine. Pour renvoyer le message, ouvrez-le dans votre dossier Éléments envoyés, cliquez sur le menu Actions et cliquez sur « Renvoyer ce message ».

Toutefois, l'expéditeur du message ne peut pas renvoyer le message même en utilisant la méthode décrite dans le message d'erreur.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc

  3. Cliquez avec le bouton droit sur SMTPSvc et sélectionnez Nouveau | Clé. Nommez la nouvelle clé Queuing et laissez la classe vide.

  4. Cliquez avec le bouton droit sur Queuing et sélectionnez Nouveau | Valeur DWORD. Nommez la nouvelle valeur MaxDSNSize.

  5. Dans le volet droit, double-cliquez sur la valeur de Registre MaxDSNSize et entrez la taille limite (en octets) souhaitée dans le champ Données de la valeur. Les messages de taille supérieure à cette valeur qui génèrent un rapport de non-remise ne renvoient pas de pièces jointes ni de propriétés de message complet.

  6. Quittez l'Éditeur du Registre, puis redémarrez le service SMTP pour que la modification soit prise en compte.

Pour plus d'informations sur le paramètre de Registre MaxDSNSize, voir les articles suivants de la Base de connaissances Microsoft :

  • 308303 sur l'option de suppression des pièces jointes des messages qui génèrent un rapport de non-remise (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303).

  • 323484 sur la description du format de message Internet Multipart/Report dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484).


La taille maximale des messages sortants n'a pas été définie
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut submissionContLength des paramètres globaux se trouvant à l'emplacement :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Paramètres_globaux, CN=Remise_messages

Si Exchange Server Analyzer détecte que la valeur de l'attribut submissionContLength est inférieure à 1, une erreur s'affiche.

Cette erreur indique que la taille limite des messages sortants n'a pas été définie. Selon la bande passante du réseau et la configuration requise pour les utilisateurs de votre organisation, vous souhaiterez peut-être limiter la taille des messages. Dans Exchange 2000 Server et Exchange Server 2007, il n'existe aucune taille limite des messages par défaut. Dans Exchange Server 2003, la taille limite par défaut pour l'envoi et la réception de messages est de 10 240 Ko. La taille limite par défaut s'applique à des nouvelles installations et à des mises à niveau d'Exchange 2000 Server, dans lesquelles aucune taille limite des messages n'est définie.

Vous pouvez économiser des ressources système en définissant des tailles limites de messages, qui empêchent les utilisateurs d'envoyer et de recevoir des messages électroniques volumineux. Cela aidera à limiter le trafic réseau, à économiser de l'espace disque et à améliorer les performances réseau globales. Pour Exchange 2000 Server et Exchange Server 2003, vous pouvez utiliser l'onglet Valeurs par défaut dans les Propriétés de remise des messages de vos Paramètres globaux pour spécifier des restrictions de remise pour les messages entrants et sortants. Pour définir la taille maximale des messages individuels, sélectionnez Maximale (Ko), puis, dans la zone de texte, entrez une taille maximale en kilo-octets (Ko). Si vous ne souhaitez pas limiter la taille des messages, sélectionnez Aucune limite. Les expéditeurs de votre organisation reçoivent un rapport de non-remise s'ils tentent d'envoyer un message à un utilisateur qui dépasse la taille limite spécifiée. Selon les paramètres des rapports de non-remise configurés dans Formats des messages Internet, les expéditeurs externes peuvent recevoir ou ne pas recevoir de rapport de non-remise.

Pour Exchange Server 2007, vous pouvez utiliser Exchange Management Shell pour définir le paramètre TransportConfig MaxSendSize pour votre organisation Exchange.

Il est recommandé de définir la taille limite des messages sur une valeur inférieure à 10 Mo. Toutefois, si vous avez besoin d'une taille limite plus élevée pour les messages contenant des pièces jointes à envoyer dans votre organisation Exchange, vous souhaiterez peut-être augmenter la taille limite des messages sortants à 30 Mo. L'augmentation de la taille limite des messages à plus de 30 Mo risque de ralentir les performances de votre réseau, voire d'accroître la vulnérabilité de votre système aux attaques de sécurité.

Définition de limite de taille des messages pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Sending message size limit (Taille limite des messages sortants) et entrez la taille limite souhaitée.

Définition des limites de taille des messages pour Exchange Server 2007

  1. Dans Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxSendSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize 10MB

Pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize unlimited
  • Pour plus d'informations sur la définition des limites de taille des messages pour Exchange 2000 Server et Exchange Server 2003, consultez l'article 322679 de la Base de connaissances Microsoft sur la définition des limites de taille des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

  • Pour plus d'informations sur la cmdlet TransportConfig pour Exchange Server 2007, consultez la page « Set-TransportConfig » dans la référence technique d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Pour plus d'informations sur les formats de messages Internet, voir la rubrique sur la configuration des stratégies SMTP pour contrôler la mise en forme des messages sortants et les réponses automatiques dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


La taille maximale des messages sortants est définie sur une valeur trop élevée (>30 Mo)
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut submissionContLength des paramètres globaux se trouvant à l'emplacement :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN=Nom_organisation, CN=Paramètres_globaux, CN=Remise_messages

Si Exchange Server Analyzer détecte que la valeur de l'attribut submissionContLength est supérieure à 30 720, une erreur s'affiche.

Cette erreur indique que la taille limite des messages sortants est définie sur une valeur supérieure à 30 mégaoctets (Mo). Selon la bande passante du réseau et la configuration requise pour les utilisateurs de votre organisation, vous souhaiterez peut-être limiter la taille des messages à des messages plus petits. Dans Exchange 2000 Server et Exchange Server 2007, il n'existe aucune taille limite des messages par défaut. Dans Exchange Server 2003, la taille limite par défaut pour l'envoi et la réception de messages est de 10 240 Ko. La taille limite par défaut s'applique à des nouvelles installations et à des mises à niveau d'Exchange 2000 Server, dans lesquelles aucune taille limite des messages n'est définie.

Vous pouvez économiser des ressources système en définissant des tailles limites de messages, qui empêchent les utilisateurs d'envoyer et de recevoir des messages électroniques volumineux. Vous pourrez ainsi limiter le trafic réseau, économiser de l'espace disque et améliorer les performance globales du réseau. Pour Exchange 2000 Server et Exchange Server 2003, vous pouvez utiliser l'onglet Valeurs par défaut dans les Propriétés de remise des messages de vos Paramètres globaux pour spécifier des restrictions de remise pour les messages entrants et sortants. Pour définir la taille maximale des messages individuels, sélectionnez Maximale (Ko), puis, dans la zone de texte, entrez une taille maximale en kilo-octets (Ko). Si vous ne souhaitez pas limiter la taille des messages, sélectionnez Aucune limite. Les expéditeurs de votre organisation reçoivent un rapport de non-remise s'ils tentent d'envoyer un message à un utilisateur qui dépasse la taille limite spécifiée. Selon les paramètres des rapports de non-remise configurés dans Formats des messages Internet, les expéditeurs externes peuvent recevoir ou ne pas recevoir de rapport de non-remise.

Pour Exchange Server 2007, vous pouvez utiliser Exchange Management Shell pour définir le paramètre TransportConfig MaxSendSize pour votre organisation Exchange.

Il est recommandé de définir la taille limite des messages sur une valeur inférieure à 10 Mo. Toutefois, si vous avez besoin d'une taille limite plus élevée pour les messages contenant des pièces jointes à envoyer dans votre organisation Exchange, vous souhaiterez peut-être augmenter la taille limite des messages sortants à 30 Mo. L'augmentation de la taille limite des messages à plus de 30 Mo risque de ralentir les performances de votre réseau, voire d'accroître la vulnérabilité de votre système aux attaques de sécurité.

Définition de limite de taille des messages pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Sending message size limit (Taille limite des messages sortants) et entrez la taille limite souhaitée.

Définition des limites de taille des messages pour Exchange Server 2007

  1. Dans Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxSendSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize 10MB

Pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize unlimited
  • Pour plus d'informations sur la définition des limites de taille des messages pour Exchange 2000 Server et Exchange Server 2003, consultez l'article 322679 de la Base de connaissances Microsoft sur la définition des limites de taille des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Pour plus d'informations sur la cmdlet TransportConfig pour Exchange Server 2007, consultez la page « Set-TransportConfig » dans la référence technique d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Pour plus d'informations sur les formats de messages Internet, voir la rubrique sur la configuration des stratégies SMTP pour contrôler la mise en forme des messages sortants et les réponses automatiques dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21769).


La taille maximale des messages sortants est peut-être définie sur une valeur trop faible
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-12-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut submissionContLength des paramètres globaux se trouvant à l'emplacement :

CN=Configuration, CN=Services, CN=Microsoft_Exchange, CN= Nom_organisation , CN=Paramètres_globaux, CN=Remise_messages

Si Exchange Server Analyzer détecte que la valeur de l'attribut submissionContLength est inférieure à 1024, mais supérieure à 0, un avertissement s'affiche.

Cet avertissement indique que la taille maximale des messages sortants a été définie sur une valeur inférieure à 1 mégaoctet (Mo). Selon la bande passante du réseau et la configuration requise pour les utilisateurs de votre organisation, vous souhaiterez peut-être augmenter la taille maximale des messages pour permettre la réception de messages plus volumineux. Dans Exchange 2000 Server et Exchange Server 2007, il n'existe aucune taille limite des messages par défaut. Dans Exchange Server 2003, la taille limite par défaut pour l'envoi et la réception de messages est de 10 240 Ko. La taille limite par défaut s'applique à des nouvelles installations et à des mises à niveau d'Exchange 2000 Server, dans lesquelles aucune taille limite des messages n'est définie.

Vous pouvez économiser des ressources système en définissant des tailles limites de messages, qui empêchent les utilisateurs d'envoyer et de recevoir des messages électroniques volumineux. Cela aidera à limiter le trafic réseau, à économiser de l'espace disque et à améliorer les performances réseau globales. Pour Exchange 2000 Server et Exchange Server 2003, vous pouvez utiliser l'onglet Valeurs par défaut dans les Propriétés de remise des messages de vos Paramètres globaux pour spécifier des restrictions de remise pour les messages entrants et sortants. Pour définir la taille maximale des messages individuels, sélectionnez Maximale (Ko), puis, dans la zone de texte, entrez une taille maximale en kilo-octets (Ko). Si vous ne souhaitez pas limiter la taille des messages, sélectionnez Aucune limite. Les expéditeurs de votre organisation reçoivent un rapport de non-remise s'ils tentent d'envoyer un message supérieur à la taille limite spécifiée à un utilisateur. Selon les paramètres des rapports de non-remise configurés dans Formats des messages Internet, les expéditeurs externes peuvent recevoir ou ne pas recevoir de rapport de non-remise.

Pour Exchange Server 2007, vous pouvez utiliser Exchange Management Shell pour définir le paramètre TransportConfig MaxSendSize pour votre organisation Exchange.

Il est recommandé de définir la taille limite des messages sur une valeur inférieure à 30 Mo. Toutefois, si vous avez besoin d'une taille limite des messages plus élevée pour l'envoi de messages avec des pièces jointes volumineuses par le biais de votre organisation Exchange, vous souhaitez peut-être définir une taille maximale des messages sortants supérieure à 30 Mo. L'augmentation de la taille limite des messages à plus de 30 Mo risque de ralentir les performances de votre réseau, voire d'accroître la vulnérabilité de votre système aux attaques de sécurité.

Définition de limite de taille des messages pour Exchange 2000 Server et Exchange Server 2003

  1. Dans Gestionnaire système Exchange, développez Paramètres globaux, cliquez avec le bouton droit sur Remise des messages, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés de Remise des messages, sous l'onglet Valeurs par défaut, sélectionnez l'option Sending message size limit (Taille limite des messages sortants) et entrez la taille limite souhaitée.

Définition des limites de taille des messages pour Exchange Server 2007

  1. Dans Exchange Management Shell, exécutez la commande suivante où <size> est la taille « illimitée » par défaut ou une taille exprimée en o (octets), Ko (Kilo-octets) ou Mo (Méga-octets) dans une plage de 0 à 2147483647 octets :
Copier le code
Set-TransportConfig -MaxSendSize <size>

Par exemple, pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur 10 Mo, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize 10MB

Pour définir la taille maximale des messages que peuvent envoyer des utilisateurs au sein de l'organisation Exchange sur la valeur illimitée par défaut, vous devez entrer :

Copier le code
Set-TransportConfig -MaxSendSize unlimited
  • Pour plus d'informations sur la définition des limites de taille des messages pour Exchange 2000 Server et Exchange Server 2003, consultez l'article 322679 de la Base de connaissances Microsoft sur la définition des limites de taille des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679).

Pour plus d'informations sur la cmdlet TransportConfig pour Exchange Server 2007, consultez la page « Set-TransportConfig » dans la référence technique d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkID=79237).

  • Pour plus d'informations sur les formats de messages Internet, voir la rubrique sur la configuration des stratégies SMTP pour contrôler la mise en forme des messages sortants et les réponses automatiques dans le Guide d'administration d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


La journalisation des messages uniquement est activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchMessageJournalRecipient a été configuré pour copier le message dans la boîte aux lettres d'un destinataire. L'attribut msExchMessageJournalRecipient est un attribut des objets de banque de boîtes aux lettres dans Active Directory. Par défaut, l'attribut msExchMessageJournalRecipient n'est pas configuré. Si Exchange Server Analyzer détecte que l'attribut msExchMessageJournalRecipient est configuré, il affiche un message indiquant une configuration autre que celle par défaut. Exchange Server Analyzer affiche également le nom de la base de données et du serveur dans lesquels la journalisation des messages uniquement est activée.

La journalisation des messages uniquement d'Exchange Server 2003 ou la journalisation standard d'Exchange Server 2007 crée une copie de tous les messages et des données d'en-tête de message P2 correspondantes échangés avec des utilisateurs sur une base de données de boîtes aux lettres et envoie la copie de message à une boîte aux lettres spécifiée. L'en-tête du message P2 contient uniquement les données du destinataire du message que l'expéditeur a déclaré aux destinataires. Si vous recevez un message externe d'Internet, Exchange Server journalise les en-têtes de messages P1. L'en-tête de message P1 est constitué des informations sur les adresses utilisées par les Agents de transfert de messages (MTA) pour router le courrier. Par défaut, lorsque la journalisation des messages uniquement est activée, Exchange Server ne prend pas en compte les destinataires en copie conforme invisible (Cci), les destinataires des règles de transfert automatique ou les destinataires des extensions de groupe de distribution. Exchange Server n'archive pas non plus les messages de rapport MAPI, tels que les confirmations de lecture et les notifications d'absence du bureau.

Les messages de journalisation peuvent utiliser beaucoup de ressources disque, réseau et processeur. Par conséquent, la journalisation nécessite une planification approfondie du déploiement. La journalisation doit être activée uniquement dans le cadre d'une structure de solution de journalisation globale.

Ignorez ce message indiquant une configuration autre que celle par défaut dans les conditions suivantes :

  • Vos activités nécessitent une journalisation.

  • Vous avez déployé une structure de solution de journalisation.

Dans le cas contraire, vous devez désactiver la fonctionnalité de journalisation.

Désactivation de la journalisation des messages uniquement pour une base de données dans Exchange 2000 Server et Exchange Server 2003

  1. Dans le Gestionnaire système Exchange, développez Serveurs, <votre serveur Exchange>, <groupe de stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres.

  2. Sous l'onglet Général, désactivez la case à cocher Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque.

  3. Attendez 15 minutes pour que la banque Exchange applique les modifications. Vous ne devez pas redémarrer le service Banque d'informations Microsoft Exchange.
Désactivation de la journalisation standard pour une base de données Exchange Server 2007

  1. Suivez les instructions de la documentation produit d'Exchange Server 2007, Procédure de désactivation de la journalisation de base de données par boîte aux lettres (http://go.microsoft.com/fwlink/?LinkId=80889).

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation avec Exchange Server 2003, consultez la rubrique sur la journalisation à l'aide d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).

Pour plus d'informations sur le déploiement d'une solution de journalisation avec Exchange Server 2007, consultez la rubrique Vue d'ensemble de la journalisation (http://go.microsoft.com/fwlink/?LinkId=80820).


Boucle de routage de message possible
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchAlternateServer de chaque serveur virtuel SMTP (Simple Mail Transfer Protocol). Exchange Server Analyzer détermine également si l'attribut msExchNonAuthoritativeDomains a été configuré dans l'une des stratégies de destinataire de l'organisation. Exchange Server Analyzer affiche un avertissement si les conditions suivantes existent :

  • Une instance de l'attribut msExchAlternateServer a été définie.

  • L'attribut msExchNonAuthoritativeDomains a été défini dans une stratégie de destinataire.

Exchange Server Analyzer affiche un avertissement car les configurations susmentionnées peuvent créer des boucles de message. Celles-ci peuvent survenir lorsque différents systèmes de messagerie sont configurés pour travailler ensemble dans une seule organisation. Dans ce scénario, les configurations SMTP et les stratégies de destinataire Exchange Server sont utilisées pour le routage et la remise des messages pour les groupes d'utilisateurs existant dans différents systèmes de messagerie.

L'attribut msExchAlternateServer est défini lorsque vous spécifiez une adresse dans le champ Transférer tous les messages dont les destinataires n'ont pas été résolus vers l'hôte sur une page de propriétés de serveur virtuel SMTP.

L'attribut msExchNonAuthoritativeDomains est défini lorsque vous désactivez la case à cocher L'organisation Exchange est responsable de la remise de tous les messages à cette adresse sur la page de propriétés de l'adresse SMTP d'une stratégie de destinataire donnée.

Dès lors, si vous définissez un domaine SMTP comme ne faisant pas autorité en désactivant la case à cocher L'organisation Exchange est responsable de la remise de tous les messages à cette adresse et si vous avez spécifié une adresse pour les destinataires non résolus sur un serveur virtuel SMTP, Exchange Server Analyzer affiche un avertissement. Toutefois, il est important de noter que l'apparition de cet avertissement n'indique pas forcément l'existence d'une boucle de message dans votre organisation.

S'il existe un domaine ne faisant pas autorité et si au moins un serveur de l'organisation a l'attribut msExchAlternateServer défini, des boucles de routage de message sont possibles. Vous devez vérifier que les conditions suivantes existent :

  • Il existe des domaines faisant autorité pour tous les domaines de votre organisation.

  • Vos serveurs virtuels SMTP sont configurés pour que les domaines faisant autorité traitent tous les messages non résolus.

Plus particulièrement, si vous partagez un nom de domaine avec une autre organisation, il est recommandé de ne laisser qu'un seul chemin d'entrée vers cet espace de nom de domaine. Un serveur ou un système de messagerie doit faire autorité pour le domaine pour éviter les boucles. Le serveur faisant autorité doit être le dernier système du chemin d'entrée.

Le système de destination initiale n'a pas d'importance, tout comme l'existence de plusieurs systèmes de destination initiale. Il est par contre essentiel qu'un seul système soit la destination finale.

Pour modifier l'attribut msExchAlternateServer

  1. Dans le Gestionnaire système Exchange, développez Serveurs, le <nom du serveur>, Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  3. Dans les propriétés du serveur virtuel SMTP, cliquez sur l'onglet Messages.

  4. Dans la zone Transférer tous les messages dont les destinataires n'ont pas été résolus vers l'hôte, entrez le nom de domaine complet du serveur devant recevoir le courrier non résolu. Vous pouvez aussi entrer l'adresse IP du serveur entre crochets droits ([ ]).

  5. Cliquez sur OK.
Pour modifier l'attribut msExchNonAuthoritativeDomains

  1. Dans le Gestionnaire système Exchange, développez Destinataires, puis double-cliquez sur le <nom de la stratégie de destinataire>.

  2. Sous l'onglet E-Mail Addresses (Policy), double-cliquez sur une adresse SMTP.

  3. Sur la page de propriétés de l'adresse SMTP, l'activation de la case à cocher L'organisation Exchange est responsable de la remise de tous les messages à cette adresse efface l'attribut msExchNonAuthoritativeDomains. En désactivant cette case à cocher, vous définissez l'attribut msExchNonAuthoritativeDomains à l'aide de l'adresse SMTP spécifiée dans le champAdresse.

Pour plus d'informations sur le partage d'espaces d'adressage SMTP, voir l'article 321721 de la Base de connaissances Microsoft sur le partage d'espaces d'adressage SMTP dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721).

Pour plus d'informations sur les scénarios de déploiement pour la connectivité Internet, voir le chapitre sur les scénarios de déploiement pour la connectivité Internet du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


La file d'attente « Messages en attente d'une recherche dans l'annuaire » est figée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour déterminer la valeur de la clé StateFrozen pour la file d'attente SMTP (Simple Mail Transfer Protocol) Messages en attente d'une recherche dans l'annuaire.

Si Exchange Server Analyzer détecte que la valeur de la clé StateFrozen pour la file d'attente Messages en attente d'une recherche dans l'annuaire sur un serveur Exchange est définie sur True, il affiche une erreur.

Une file d'attente figée signifie l'arrêt des sessions de transport pour cette file d'attente. Une file d'attente figée empêche les messages de sortir, bien que de nouveaux messages puissent être ajoutés. Vous pouvez modifier manuellement l'état d'une connexion à l'aide du menu contextuel dans chaque file d'attente de liens. Si vous utilisez la commande Forcer la connexion pour modifier l'état d'une file d'attente en Actif, vous activez immédiatement une connexion qui envoie les messages de cette file d'attente.

La file d'attente Messages en attente d'une recherche dans l'annuaire contient des messages pour des destinataires qui n'ont pas encore été résolus par rapport au service d'annuaire Active Directory®. Les messages sont également maintenus dans la file d'attente lors du développement des listes de distribution.

En règle générale, les messages s'accumulent dans cette file d'attente car le moteur avancé de files d'attente n'est pas en mesure de catégoriser le message. Le moteur avancé de files d'attente risque de ne pas pouvoir accéder aux serveurs de catalogue global ni aux informations sur le destinataire ou les serveurs de catalogue global ne sont pas accessibles ou fonctionnent lentement. En outre, les messages peuvent s'accumuler pour les raisons suivantes :

  • Active Directory n'est pas disponible.

    Remarque :
    Le catégoriseur utilise Active Directory pour catégoriser des messages.
  • Active Directory subit peut-être une charge trop importante si de nombreux messages se trouvent dans la file d'attente avant catégorisation.

  • Un échec de conversion s'est produit. Le catégoriseur traite également les conversions de contenu.

  • Le catégoriseur de messages ne peut pas trouver les banques de boîtes aux lettres.

  • En cas de réinstallation ou de suppression de SMTP, les clés de la métabase IIS suivantes risquent d'être invalidées : /smtpsvc/DsUseCat and /smtpsvc/vsi#/DsUseCat.

    Remarque :
    Déterminez si SMTP a été réinstallé ou supprimé.

Pour résoudre cette erreur, augmentez l'enregistrement des diagnostics pour les services MSExchangeDSAccess et MSExchangeTransport afin de collecter des informations sur les composants du catégoriseur.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La file d'attente « Messages en attente d'une recherche dans l'annuaire » présente l'état Réessayer
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour déterminer la valeur de la clé StateRetry pour la file d'attente SMTP (Simple Mail Transfer Protocol) Messages en attente d'une recherche dans l'annuaire.

Si Exchange Server Analyzer détecte que la valeur de la clé StateRetry pour la file d'attente Messages en attente d'une recherche dans l'annuaire sur un serveur Exchange est définie sur True, il affiche une erreur.

Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente. Vous pouvez modifier les files d'attente présentant l'état Réessayer ou Planifiée en Actif à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

La file d'attente Messages en attente d'une recherche dans l'annuaire contient des messages pour des destinataires qui n'ont pas encore été résolus par rapport au service d'annuaire Active Directory®. Les messages sont également maintenus dans la file d'attente lors du développement des listes de distribution.

En règle générale, les messages s'accumulent dans cette file d'attente car le moteur avancé de files d'attente n'est pas en mesure de catégoriser le message. Le moteur avancé de files d'attente risque de ne pas pouvoir accéder aux serveurs de catalogue global ni aux informations sur le destinataire ou les serveurs de catalogue global ne sont pas accessibles ou fonctionnent lentement. En outre, les messages peuvent s'accumuler pour les raisons suivantes :

  • Active Directory n'est pas disponible.

    Remarque :
    Le catégoriseur utilise Active Directory pour catégoriser des messages.
  • Active Directory subit peut-être une charge trop importante si de nombreux messages se trouvent dans la file d'attente avant catégorisation.

  • Un échec de conversion s'est produit. Le catégoriseur traite également les conversions de contenu.

  • Le catégoriseur de messages ne peut pas trouver les banques de boîtes aux lettres.

  • En cas de réinstallation ou de suppression de SMTP, les clés de la métabase IIS suivantes risquent d'être invalidées : /smtpsvc/DsUseCat and /smtpsvc/vsi#/DsUseCat.

    Remarque :
    Déterminez si SMTP a été réinstallé ou supprimé.

Pour résoudre cette erreur, examinez les propriétés de la file d'attente pour déterminer la raison pour laquelle la file d'attente présente l'état Réessayer. Par exemple, si les propriétés de la file d'attente affichent un message du type « Une erreur SMTP s'est produite », consultez les journaux des événements de votre serveur afin d'identifier les erreurs SMTP éventuelles. Si le journal ne contient pas d'événements, augmentez le niveau d'enregistrement du protocole SMTP.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La file d'attente « Envoi de messages suspendu » est figée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-16

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateFrozen pour la file d'attente SMTP (Simple Mail Transfer Protocol) Envoi de messages suspendu.

Si Exchange Server Analyzer détecte que la valeur de la clé StateFrozen pour la file d'attente Envoi de messages suspendu d'un serveur Exchange est définie sur True, il affiche une erreur.

Une file d'attente figée signifie l'arrêt des sessions de transport pour cette file d'attente. Une file d'attente figée empêche les messages de sortir, bien que de nouveaux messages puissent être ajoutés. Vous pouvez modifier manuellement l'état d'une connexion à l'aide du menu contextuel dans chaque file d'attente de liens. Si vous utilisez la commande Forcer la connexion pour modifier l'état d'une file d'attente en Actif, vous activez immédiatement une connexion qui envoie les messages de cette file d'attente.

La file d'attente Envoi de messages suspendu contient les messages reconnus et acceptés par le service SMTP.

Les messages qui sont dans cette file d'attente n'ont pas encore été traités. Si les messages s'accumulent de manière constante, il se peut que vous ayez un problème de performances. Des pics occasionnels dans les performances du processeur peuvent entraîner l'apparition intermittente de messages dans cette file d'attente. Fréquemment, l'accumulation de messages dans cette file d'attente provient de problèmes au niveau des récépteurs d'événements, par exemple du code de traitement SMTP personnalisé pour l'analyse antivirus et pour les avis de non-responsabilité.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La file d'attente « Envoi de messages suspendu » présente l'état Réessayer
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateRetry pour la file d'attente SMTP (Simple Mail Transfer Protocol) Envoi de messages suspendu.

Si Exchange Server Analyzer détecte que la valeur de la clé StateRetry pour la file d'attente Envoi de messages suspendu d'un serveur Exchange est définie sur True, il affiche une erreur.

Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente. Vous pouvez modifier les files d'attente présentant l'état Réessayer ou Planifiée en Actif à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

La file d'attente Envoi de messages suspendu contient les messages reconnus et acceptés par le service SMTP.

Les messages qui sont dans cette file d'attente n'ont pas encore été traités. Si les messages s'accumulent de manière constante, il se peut que vous ayez un problème de performances. Des pics occasionnels dans les performances du processeur peuvent entraîner l'apparition intermittente de messages dans cette file d'attente. Fréquemment, l'accumulation de messages dans cette file d'attente provient de problèmes au niveau des récépteurs d'événements, par exemple du code de traitement SMTP personnalisé pour l'analyse antivirus et pour les avis de non-responsabilité.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La file d'attente « Messages en attente de routage » est figée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateFrozen pour la file d'attente SMTP (Simple Mail Transfer Protocol) Messages en attente de routage.

Si Exchange Server Analyzer détecte que la valeur de la clé StateFrozen pour la file d'attente Messages en attente d'une recherche dans l'annuaire sur un serveur Exchange est définie sur True, il affiche une erreur.

Une file d'attente figée signifie l'arrêt des sessions de transport pour cette file d'attente. Une file d'attente figée empêche les messages de sortir, bien que de nouveaux messages puissent être ajoutés. Vous pouvez modifier manuellement l'état d'une connexion à l'aide du menu contextuel dans chaque file d'attente de liens. Si vous utilisez la commande Forcer la connexion pour modifier l'état d'une file d'attente en Actif, vous activez immédiatement une connexion qui envoie les messages de cette file d'attente.

La file d'attente Messages en attente de routage regroupe les messages jusqu'à ce que leur prochain serveur de destination ait été défini ; les messages sont ensuite acheminés vers leurs files d'attente de liaison respectives.

Les messages s'accumulent dans la file d'attente en cas de problèmes de routage Exchange Server. Le routage des messages peut être sauvegardé.

Pour résoudre cette erreur, augmentez l'enregistrement des diagnostics pour les services MSExchangeDSAccess et MSExchangeTransport afin de collecter des informations sur les composants du catégoriseur.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La file d'attente « Messages en attente de routage » présente l'état Réessayer
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateRetry pour la file d'attente SMTP (Simple Mail Transfer Protocol) Messages en attente de routage.

Si Exchange Server Analyzer détecte que la valeur de la clé StateRetry pour la file d'attente Messages en attente d'une recherche dans l'annuaire sur un serveur Exchange est définie sur True, il affiche une erreur.

Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente. Vous pouvez modifier les files d'attente présentant l'état Réessayer ou Planifiée en Actif à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

La file d'attente Messages en attente de routage regroupe les messages jusqu'à ce que leur prochain serveur de destination ait été défini ; les messages sont ensuite acheminés vers leurs files d'attente de liaison respectives.

Les messages s'accumulent dans la file d'attente en cas de problèmes de routage Exchange Server. Le routage des messages peut être sauvegardé.

Pour résoudre cette erreur, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport afin de collecter des informations sur les composants du catégoriseur. Désactivez toute restriction de connecteur inutile car les restrictions peuvent considérablement altérer les performances du serveur. Il se peut que vous deviez activer la clé de Registre CheckConnectorRestrictions pour certaines restrictions.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Liaison de récepteur d'événements de transport manquante
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-01-11

L'outil Microsoft® Exchange Server Analyzer Tool interroge la métabase IIS (Internet Information Server) Microsoft pour énumérer la liste des liaisons des récepteurs d'événements de transport SMTP (Simple Mail Transport Protocol). Exchange Server Analyzer tente de rechercher un nombre de liaisons d'événements standard sur la base d'une liste préremplie dans Exchange Server Analyzer :

  • Récepteur de notifications d'état de remise Exchange personnalisé

  • Récepteur du gestionnaire de commandes entrantes EHLO pour XLSA

  • Récepteur du gestionnaire de réponses EHLO pour X-LSA

  • Récepteur du gestionnaire de commandes entrantes EOD

  • Catégoriseur Exchange

  • Exchange LoadBalancer

  • Pilote de banque d'informations Exchange NTFS

  • Routeur Exchange

  • Récepteur d'enregistrements dans le journal de protocole SMTP Exchange

  • Récepteur EHLO de sécurité du protocole SMTP Exchange

  • Récepteur EXPS de sécurité du protocole SMTP Exchange

  • Récepteur EXPS-Aux de sécurité du protocole SMTP Exchange

  • Récepteur EXPS-EOD de sécurité du protocole SMTP Exchange

  • Récepteur de courrier de sécurité du protocole SMTP Exchange

  • Protocole SMTP Exchange XEXCH50 avant récepteur de données

  • Récepteur de réponses EHLO XEXCH50 du protocole SMTP Exchange

  • Récepteur EOD XEXCH50 du protocole SMTP Exchange

  • Récepteur EHLO entrant XEXCH50 du protocole SMTP Exchange

  • Récepteur MAIL entrant XEXCH50 du protocole SMTP Exchange

  • Récepteur RCPT entrant XEXCH50 du protocole SMTP Exchange

  • Récepteur XEXCH50 entrant XEXCH50 du protocole SMTP Exchange

  • XEXCH50 du protocole SMTP Exchange par récepteur d'événements du destinataire

  • Récepteur de réponses RCPT XEXCH50 du protocole SMTP Exchange

  • Récepteur de réponses XEXCH50 du protocole SMTP Exchange

  • Pilote de banque d'informations Exchange

  • API antivirus de transport Exchange

  • Récepteur de dépôt XEXCH50 de transport Exchange

  • Récepteur du gestionnaire de commandes entrantes MAIL pour TURF

  • Catégoriseur mobile

  • Récepteur EOD de filtre de contenu MSExchange

  • Récepteur MsgTrackLog

  • Récepteur du gestionnaire de commandes entrantes RCPT

  • Récepteur Eventlog SMTP

  • UmConvSink

  • Récepteur du gestionnaire de commandes entrantes X-LSA

  • Récepteur du gestionnaire de réponses X-LSA

  • Récepteur X-LSA

Si Exchange Server Analyzer détermine qu'une ou plusieurs liaisons d'événements standard sont manquantes, il génère un avertissement.

Un événement de transport SMTP survient lorsque des données de messages sont transportées vers l'intérieur ou l'extérieur d'un service SMTP. Tous les messages passent par des événements, notamment les messages X.400 et RPC entrants ou sortants. Un exemple commun d'un événement de transport entrant est l'arrivée d'un message dans le service SMTP via le réseau ou dans le répertoire de collecte SMTP. Lorsque cet événement de transport survient, une source de cet événement notifie les récepteurs d'événements de transport, dont chacun peut réaliser un type d'action sur la base du contenu des données du message. Le système n'effectue aucune autre action avec les données du message après les avoir transmises au récepteur jusqu'à ce que ce dernier termine l'action et renvoie le message. Le récepteur détient le contrôle exclusif des données du message et de son état lorsqu'il effectue cette action.

Les liaisons de récepteur d'événements de transport manquantes peuvent provoquer des problèmes de flux de messages. Si Exchange Server présente des symptômes de problèmes de flux de messages, tels que des files d'attente de messages, réenregistrez les récepteurs d'événements de transport.

Pour réenregistrer les récepteurs d'événements de transport

  1. À partir de Microsoft Exchange Server, ouvrez une fenêtre d'invite de commandes et accédez au dossier \Program Files\Exchsrvr\Bin.

  2. Tapez les commandes suivantes pour réenregistrer les récepteurs d'événements de transport :

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Réexécutez Exchange Server Analyzer pour vérifier que les avertissements n'existent plus. Si des avertissements de récepteur d'événements continuent de s'afficher et si vous rencontrez des problèmes de flux de messages, contactez les services du Support Technique de Microsoft.

Pour plus d'informations sur les liaisons de récepteurs d'événements de transport, voir les ressources Exchange suivantes :

  • Article 258224 de la Base de connaissances Microsoft sur l'énumération des récepteurs d'événements de transport enregistrés (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • Rubrique sur la conception du service SMTP du Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876)


L'attribut msExchAlternateServer a été défini
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchAlternateServer de chaque serveur virtuel SMTP (Simple Mail Transfer Protocol). Par défaut, la valeur de l'attribut msExchAlternateServer n'est pas définie. Si Exchange Server Analyzer détecte que l'attribut msExchAlternateServer est défini, il affiche un message indiquant une configuration autre que celle par défaut.

Vous pouvez définir l'attribut msExchAlternateServer dans l'exemple suivant. Vous partagez un espace d'adressage SMTP, tel qu'un domaine SMTP, entre Exchange Server 2003 et un autre système de messagerie. Dans ce scénario, Exchange Server 2003 accepte le courrier entrant provenant d'Internet. Exchange Server 2003 recherche un destinataire correspondant dans l'organisation Exchange Server. Si aucune correspondance n'est établie, Exchange Server transfère le courrier au système de messagerie étranger. Ce dernier cherche également à établir une correspondance. Si aucune correspondance n'est établie, il est possible qu'il transfère le courrier à un troisième système de messagerie. Le dernier système de la chaîne doit faire autorité dans le domaine. Il doit rechercher un destinataire correspondant. S'il n'en trouve aucun, il génère un rapport de non-remise pour le message. Si un système de réception de messages cherche à établir une correspondance et s'il retransfère ensuite le message au système d'origine alors qu'aucune correspondance n'a été établie, des boucles de message sont créées.

Pour modifier l'attribut msExchAlternateServer

  1. Dans le Gestionnaire système Exchange, développez Serveurs, le <nom du serveur>, Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  3. Dans les Propriétés du serveur virtuel SMTP, cliquez sur l'onglet Messages.

  4. Dans la zone Transférer tous les messages dont les destinataires n'ont pas été résolus vers l'hôte, entrez le nom de domaine complet du serveur devant recevoir le courrier non résolu. Vous pouvez aussi entrer l'adresse IP du serveur entre crochets droits ([ ]).

  5. Cliquez sur OK.

Pour plus d'informations sur le partage d'espaces d'adressage SMTP, voir l'article 321721 de la Base de connaissances Microsoft sur le partage d'espaces d'adressage SMTP dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721).

Pour plus d'informations sur les scénarios de déploiement pour la connectivité Internet, voir le chapitre sur les scénarios de déploiement pour la connectivité Internet du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


La valeur msExchMaxIncomingConnections a été modifiée et diffère de sa valeur par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur configurée de l'attribut msExchSmtpMaxIncomingConnections de chaque serveur virtuel SMTP.

Par défaut, sur un ordinateur Exchange Server ne faisant pas partie d'une installation Microsoft Windows® Small Business Server 2003, l'attribut msExchSmtpMaxIncomingConnections est configuré pour un nombre illimité de connexions, comme représenté par une valeur par défaut de 2000000000. Sur un ordinateur Exchange Server faisant partie d'une installation Microsoft Windows Small Business Server 2003, le nombre maximum par défaut de connexions entrantes est de 500.

Exchange Server Analyzer interroge également la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de cette clé correspond à une version spécifique d'un système d'exploitation Windows Server.

Si Exchange Server Analyzer détecte que l'attribut msExchSmtpMaxIncomingConnections sur un ordinateur Exchange Server qui ne fait pas partie d'une installation Microsoft Windows Small Business Server 2003 ne possède pas une valeur de 2000000000, un message indiquant une configuration autre que celle par défaut s'affiche. La valeur de 2000000000 utilisée pour cet attribut est à la fois une limite théorique et la limite imposée sur les éléments d'interface utilisateur qui vous permettent de configurer cette valeur.

Si Exchange Server Analyzer détecte que l'attribut msExchSmtpMaxIncomingConnections sur un ordinateur Exchange Server qui fait partie d'une installation Microsoft Windows Small Business Server 2003 n'a pas une valeur de 500, un message indiquant une configuration autre que celle par défaut s'affiche.

D'un point de vue de la sécurité, il est logique de limiter le nombre de connexions entrantes. La possibilité d'accepter un nombre essentiellement illimité de connexions SMTP entrantes pourrait prêter à un refus de situation de service. Un nombre trop important de connexions simultanées au serveur virtuel peut surcharger votre réseau et entraîner des performances médiocres. Chaque organisation doit décider d'une valeur appropriée pour cet attribut.

Pour afficher et configurer le nombre maximum de connexions entrantes

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut) puis cliquez sur Propriétés.

  4. Cliquez sur Général :

    • Pour limiter le nombre de connexions entrantes, activez la case à cocher Limiter le nombre de connexions à et entrez la valeur souhaitée.

    • Pour rétablir la valeur par défaut de connexions entrantes illimitées, désactivez la case à cocher Limiter le nombre de connexions à.

  5. Cliquez sur OK pour enregistrer les modifications.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpMaxHopCount a été modifiée et diffère de sa valeur par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée pour l'attribut msExchSmtpMaxHopCount a été modifiée et diffère de sa valeur par défaut.

Dans Exchange 2000 Server, l'attribut msExchSmtpMaxHopCount est configuré avec une valeur par défaut de 15. Dans Exchange Server 2003, cet attribut a une valeur par défaut de 30. Si Exchange Server Analyzer détecte que cet attribut n'est plus défini sur le paramètre par défaut, un message indiquant une configuration autre que celle par défaut s'affiche.

Un message peut être routé via de nombreux serveurs SMTP différents (chacun est désigné en tant que saut) avant que le message n'atteigne sa destination finale. Pour empêcher un message d'être mal routé à plusieurs reprises (condition appelée boucle de message), un administrateur peut contrôler le nombre maximal de sauts autorisés. L'attribut mxExchSmtpMaxHopCount spécifie le nombre de serveurs SMTP qui peuvent router un message avant qu'il ne soit renvoyé à l'expéditeur en tant que message non remis.

Une valeur de 30 pour les serveurs virtuels SMTP Exchange 2000 Server et Exchange Server 2003 SMTP est recommandée.

Pour corriger cette erreur

  1. Dans le Gestionnaire système Exchange, développez Serveurs, puis développez un serveur Exchange, développez Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, serveur virtuel SMTP par défaut) et sélectionnez Propriétés.

  3. Sélectionnez l'onglet Remise, puis cliquez sur Avancé.

  4. Entrez la valeur souhaitée dans le champ Nombre maximal de sauts et cliquez sur OK pour enregistrer la modification.

  5. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpMaxMessageSize a été modifiée et diffère de sa valeur par défaut de 0
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée pour l'attribut msExchSmtpMaxMessageSize a été modifiée et diffère de sa valeur par défaut de 0. Par défaut, l'attribut msExchSmtpMaxMessageSize est configuré pour une taille de message illimitée. Si Exchange Server Analyzer détecte que la valeur de cet attribut est différente de 0 et qu'Exchange ne fonctionne pas sur Microsoft Windows® Small Business Server 2003, un avertissement s'affiche.

L'attribut msExchSmtpMaxMessageSize représente la taille maximale de chaque message SMTP pouvant être envoyé ou reçu. Pour des raisons de sécurité, il est conseillé de limiter la taille maximale des messages SMTP pouvant être envoyés et reçus depuis Internet. Néanmoins, pour les messages SMTP internes tels que ceux échangés entre des serveurs Exchange de la même organisation, il est recommandé de laisser l'attribut msExchSmtpMaxMessageSize défini sur 0.

Exchange utilise les messages SMTP en interne pour gérer des tâches telles que la réplication de dossiers publics. Si l'attribut msExchSmtpMaxMessageSize est configuré avec une limite trop faible, il pourrait provoquer des problèmes de réplication de dossiers publics et d'autres échecs de remise de messages inter-organisationnels.

Si ce serveur Exchange est un serveur tête de pont qui transfère les messages SMTP vers et depuis Internet, vous pouvez ignorer cet avertissement en toute sécurité. Si ce serveur Exchange gère les messages SMTP internes, vous devez rétablir la valeur par défaut de l'attribut msExchSmtpMaxMessageSize, qui est de 0.

Remarque :
Si vous fixez une taille limite de messages trop basse, cela pourrait empêcher toute réplication de Carnet d'adresses en mode hors connexion entre les ordinateurs Exchange Server. Pour plus d'informations sur ce problème, voir l'article 326154 de la Base de connaissances Microsoft sur la non-réplication d'OAB si vous définissez une restriction de la taille des messages au niveau transport (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).

Pour afficher et configurer la taille maximale des messages SMTP

  1. Dans le Gestionnaire système Exchange, développez Serveurs, puis développez un serveur Exchange, développez Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, serveur virtuel SMTP par défaut) et sélectionnez Propriétés.

  3. Sélectionnez l'onglet Messages.

  4. Pour rétablir le paramètre par défaut de 0, désactivez la case à cocher Limiter la taille des messages à (Ko). Vous pouvez également laisser cette case activée et configurer une valeur de votre choix.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpMaxOutboundMsgPerDomain a été modifiée et diffère de sa valeur par défaut de 20
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchSmtpMaxOutboundMsgPerDomain a été modifiée par rapport à la valeur par défaut de 20. Par défaut, l'attribut msExchSmtpMaxOutboundMsgPerDomain est configuré pour un nombre maximal de 20 messages SMTP sortants par connexion. Si Exchange Server Analyzer détecte que cet attribut ne possède pas une valeur de 20, un message indiquant une configuration autre que celle par défaut s'affiche.

L'attribut msExchSmtpMaxOutboundMsgPerDomain représente le nombre maximal de messages par connexion qui peuvent être envoyés par un serveur virtuel SMTP sur le serveur Exchange. Par exemple, si un serveur SMTP doit envoyer 35 messages à microsoft.com et si l'attribut msExchSmtpMaxOutboundMsgPerDomain est défini sur 20, deux connexions vers les serveurs de messagerie responsables des messages pour microsoft.com sont établies. La première connexion envoie le nombre maximal de 20 messages et une deuxième connexion est établie pour envoyer les 15 messages restants.

Généralement, il n'existe aucune recommandation des meilleures pratiques pour déterminer la valeur correcte de cet attribut. Chaque organisation doit déterminer personnellement la valeur appropriée à définir.

Pour définir un nombre maximal de messages par connexion

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut), puis cliquez sur Propriétés.

  4. Cliquez sur Messages.

  5. La valeur actuelle de l'attribut msExchSmtpMaxOutboundMsgPerDomain est répertoriée dans le champ Limiter le nombre de connexions à. Modifiez ce champ en fonction de vos besoins et cliquez sur OK pour enregistrer vos modifications. Les valeurs acceptées pour ce champ incluent tout nombre entier entre 1 et 1 999 999 999.

  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpMaxOutgoingConnections a été modifiée et diffère de sa valeur par défaut de 1000
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée pour l'attribut msExchSmtpMaxOutgoingConnections a été modifiée par rapport à la valeur par défaut de 1000. Par défaut, l'attribut msExchSmtpMaxOutgoingConnections est configuré pour un nombre maximal de 1 000 connexions SMTP sortantes. Si Exchange Server Analyzer détecte que cet attribut ne possède pas une valeur de 1000, un message indiquant une configuration autre que celle par défaut s'affiche.

L'attribut msExchSmtpMaxOutgoingConnections représente le nombre maximal de connexions sortantes par domaine qui peuvent être établies par un serveur virtuel SMTP sur le serveur Exchange.

Généralement, il n'existe aucune recommandation des meilleures pratiques pour déterminer la valeur correcte de cet attribut. Chaque organisation doit déterminer personnellement la valeur appropriée à définir. Ceci dit, la valeur par défaut peut être trop élevée pour certaines organisations. Vous pouvez surveiller et déterminer le nombre réel de connexions SMTP sortantes établies par un serveur virtuel Exchange SMTP en collectant les compteurs de performance suivants sur votre serveur Exchange :

Objet | compteur | Explication
Serveur SMTP | connexions en cours sortantes | Nombre de connexions actuellement sortantes.
Serveur SMTP | connexions totales sortantes | Nombre total de connexions sortantes tentées.

Si votre organisation n'utilise pas fréquemment de connexions SMTP sortantes sur ce serveur Exchange, envisagez de réduire la valeur de cet attribut. Diminuer le nombre maximal de connexions SMTP sortantes simultanées pouvant être établies à tout moment pourrait ralentir les pointes de l'activité du serveur SMTP qui peuvent être provoquées par une configuration incorrecte, une erreur innocente, une activité malveillante, une boucle de message, une autre défaillance, la survenue d'un virus ou une violation de la sécurité.

Pour afficher et configurer la limite des connexions sortantes

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut), puis cliquez sur Propriétés.

  4. Cliquez sur Remise, puis sur Connexions sortantes.

  5. La valeur actuelle de l'attribut msExchSmtpMaxOutgoingConnections est répertoriée dans le champ Limiter le nombre de connexions à. Modifiez ce champ en fonction de vos besoins et cliquez sur OK pour enregistrer vos modifications. Les valeurs acceptées pour ce champ incluent tout nombre entier entre 1 et 1 999 999 999.

  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpMaxOutgoingConnectionsPerDomain a été modifiée et diffère de sa valeur par défaut de 100
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchSmtpMaxOutgoingConnectionsPerDomain a été modifiée et diffère de sa valeur par défaut. L'attribut msExchSmtpMaxOutgoingConnectionsPerDomain représente le nombre maximal de connexions sortantes par domaine qui peuvent être établies par un serveur virtuel SMTP sur le serveur Microsoft Exchange. Par défaut, sur un ordinateur Exchange Server ne faisant pas partie d'une installation Microsoft Windows® Small Business Server 2003, l'attribut msExchSmtpMaxOutgoingConnectionsPerDomain est configuré avec une valeur par défaut de 100. Sur un ordinateur Exchange Server faisant partie d'une installation Windows Small Business Server 2003, le nombre maximum par défaut de connexions sortantes par domaine est de 10.

Exchange Server Analyzer interroge également la classe WMI (Windows Management Instrumentation) Win32_OperatingSystem pour déterminer la valeur de la clé OSProductSuite. La valeur de cette clé correspond à une version spécifique d'un système d'exploitation Windows Server.

Si Exchange Server Analyzer détecte que l'attribut msExchSmtpMaxOutgoingConnectionsPerDomain sur un ordinateur Exchange Server qui ne fait pas partie d'une installation Windows Small Business Server 2003 ne possède pas une valeur de 500, un message indiquant une configuration autre que celle par défaut s'affiche.

Si Exchange Server Analyzer détecte que l'attribut msExchSmtpMaxOutgoingConnectionsPerDomain sur un ordinateur Exchange Server qui fait partie d'une installation Microsoft Windows Small Business Server 2003 n'a pas une valeur de 10, un message indiquant une configuration autre que celle par défaut s'affiche.

Généralement, il n'existe aucune recommandation des meilleures pratiques pour déterminer la valeur correcte de cet attribut. Chaque organisation doit déterminer la valeur appropriée à définir. Ceci dit, la valeur par défaut peut être trop élevée pour certaines organisations. Vous pouvez surveiller et déterminer le nombre réel de connexions SMTP sortantes établies par un serveur virtuel Exchange SMTP en collectant les compteurs de performance suivants sur votre serveur Exchange :

Objet | compteur | Explication
Serveur SMTP | connexions en cours sortantes | Nombre de connexions actuellement sortantes.
Serveur SMTP | connexions totales sortantes | Nombre total de connexions sortantes tentées.

Si votre organisation n'utilise pas fréquemment de connexions SMTP sortantes sur ce serveur Exchange, envisagez de réduire la valeur de cet attribut. Diminuer le nombre maximal de connexions SMTP sortantes simultanées pouvant être établies à tout moment pourrait ralentir les pointes de l'activité du serveur SMTP qui peuvent être provoquées par une configuration incorrecte, une erreur innocente, une activité malveillante, une boucle de message, une autre défaillance, la survenue d'un virus ou une violation de la sécurité.

Pour afficher et configurer la limite des connexions sortantes par domaine

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut) puis cliquez sur Propriétés.

  4. Cliquez sur Remise, puis sur Connexions sortantes.

  5. La valeur actuelle de l'attribut msExchSmtpMaxOutgoingConnectionsPerDomain est répertoriée dans le champ Limiter le nombre de connexions par domaine à. Modifiez ce champ selon vos besoins et cliquez sur OK pour enregistrer vos modifications. Les valeurs acceptées pour ce champ incluent tout nombre entier entre 1 et 1 999 999 999.

  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpMaxRecipients a été modifiée et diffère de sa valeur par défaut de 64000
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée pour l'attribut msExchSmtpMaxRecipients a été modifiée et diffère de sa valeur par défaut de 64000. Par défaut, l'attribut msExchSmtpMaxRecipients est configuré sur 64 000 destinataires. Si Exchange Server Analyzer détecte que cet attribut ne possède pas une valeur de 64000, un message indiquant une configuration autre que celle par défaut s'affiche.

Pour des raisons de sécurité, il est conseillé de limiter le nombre maximal de destinataires pour chaque message. Chaque organisation doit déterminer une valeur acceptable pour elle-même. À moins d'avoir une raison particulière de configurer cette valeur autrement, il est recommandé de conserver la valeur par défaut de 64000 pour l'attribut msExchSmtpMaxRecipients.

Pour afficher et configurer le nombre maximal de destinataires

  1. Dans le Gestionnaire système Exchange, développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, serveur virtuel SMTP par défaut), puis sélectionnez Propriétés.

  3. Sélectionnez l'onglet Messages.

  4. Pour rétablir le paramètre par défaut de 64000, veillez à activer la case à cocher Limiter le nombre de destinataires par message à et entrez une valeur de 64000. Vous pouvez également configurer ce champ avec la valeur de votre choix ou désactiver la case à cocher pour autoriser un nombre illimité de destinataires.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpMaxSessionSize a été modifiée et diffère de sa valeur par défaut de 0
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée pour l'attribut msExchSmtpMaxSessionSize a été modifiée par rapport à la valeur par défaut de 0. Par défaut, l'attribut msExchSmtpMaxSessionSize est configuré pour une taille de message illimitée. Si Exchange Server Analyzer détecte que cet attribut ne possède pas une valeur de 0, un message d'avertissement s'affiche.

L'attribut msExchSmtpMaxSessionSize représente la quantité maximale de données en kilo-octets (Ko) acceptée pour chaque session SMTP. Pour des raisons de sécurité, il est conseillé de limiter la taille des sessions SMTP pour les messages envoyés et reçus depuis Internet. Néanmoins, pour les session SMTP internes telles que celles entre des serveurs Exchange de la même organisation, il est recommandé de laisser l'attribut msExchSmtpMaxSessionSize défini sur 0.

Exchange utilise les messages SMTP en interne pour gérer des tâches telles que la réplication de dossiers publics. Si l'attribut msExchSmtpMaxSessionSize est configuré avec une limite trop faible, il pourrait provoquer des problèmes de réplication de dossiers publics et d'autres échecs de remise de messages inter-organisationnels.

Si ce serveur Exchange est un serveur tête de pont qui transfère les messages SMTP vers et depuis Internet, vous pouvez ignorer cet avertissement en toute sécurité. Si ce serveur Exchange gère les messages SMTP internes, vous devez rétablir la valeur par défaut de l'attribut msExchSmtpMaxSessionSize, qui est de 0.

Pour afficher et configurer la taille maximale de session SMTP

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, développez un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut) puis cliquez sur Propriétés.

  4. Cliquez sur Messages.

  5. Pour rétablir le paramètre par défaut de 0, désactivez la case à cocher Limiter la taille d'une session à (Ko). Vous pouvez également laisser cette case activée et configurer une valeur de votre choix.

  6. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpOutgoingPort a été modifiée et diffère de sa valeur par défaut de 25
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer que la valeur configurée pour l'attribut msExchSmtpOutgoingPort a été modifiée par rapport à la valeur par défaut de 25. Par défaut, l'attribut msExchSmtpOutgoingPort est configuré pour le port TCP 25. Si Exchange Server Analyzer détecte que cet attribut est configuré pour un port autre que le 25, un avertissement s'affiche.

Par défaut, les serveurs SMTP sont configurés pour accepter les connexions entrantes sur le port TCP 25. Le paramètre msExchSmtpOutgoingPort représente le port TCP auquel ce serveur Exchange tentera de se connecter sur tous les serveurs SMTP distants. Si les serveurs SMTP distants n'ont pas été configurés pour écouter sur ce port, la connexion ne peut pas être établie.

À moins que votre infrastructure de messagerie interne ait été modifiée, entièrement ou en partie, pour utiliser des ports non standard, il est recommandé d'utiliser le port TCP 25 pour toutes les communications SMTP.

Pour afficher ou modifier le port SMTP sortant par défaut

  1. Dans le Gestionnaire système Exchange, développez Serveurs, développez un serveur Exchange, développez Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut) et cliquez sur Propriétés.

  3. Cliquez sur Remise, puis sur Connexions sortantes.

  4. Dans le champ du port TCP, entrez le port que vous souhaitez utiliser pour les connexions sortantes. Chaque serveur SMTP distant avec lequel vous souhaitez communiquer doit être configuré pour accepter des connexions sur le port spécifié. En règle générale, il est préférable de ne pas modifier cette valeur.

  5. Modifiez ce champ en fonction de vos besoins et cliquez sur OK pour enregistrer vos modifications.

  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur msExchSmtpRelayForAuth a été modifiée et diffère de sa valeur par défaut True
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchSmtpRelayForAuth a été modifiée et diffère de sa valeur par défaut, à savoir True. Si Exchange Server Analyzer détecte que l'attribut msExchSmtpRelayForAuth ne possède pas la valeur True, un message indiquant une configuration autre que celle par défaut s'affiche.

Lorsque cette valeur est définie sur True, seules les connexions SMTP authentifiées peuvent relayer des messages SMTP par ce serveur virtuel SMTP. Si ce paramètre a été modifié en False, cela indique que la case à cocher « Autoriser tous les ordinateurs authentifiés à relayer, sans tenir compte de la liste ci-dessus » dans les paramètres de relais de la boîte de dialogue Propriétés du serveur virtuel SMTP est désactivée.

Le relais est l'utilisation d'une connexion entrante vers votre serveur SMTP pour l'envoi de messages électroniques à des domaines externes. Ce processus est utilisé pour les messages commerciaux indésirables par l'envoi d'un seul message électronique vers votre serveur SMTP avec plusieurs destinataires dans des domaines externes à votre entreprise. Le paramètre par défaut des serveurs SMTP étant l'utilisation de l'authentification anonyme, le système utilisé pour la diffusion des messages commerciaux indésirables accepte le message entrant comme message standard.

Une fois le message accepté, le serveur SMTP identifie que les destinataires appartiennent à des domaines externes et le transmet. Les utilisateurs non autorisés qui envoient des messages commerciaux indésirables n'ont dès lors qu'à envoyer un message entrant à votre serveur SMTP pour qu'il puisse ensuite être transmis à des milliers de destinataires, ce qui ralentit le temps de réponse de votre ordinateur Exchange Server, crée des files d'attente et provoque le mécontentement des destinataires lorsque ces messages arrivent dans leur boîte de réception.

Le moyen principal de contrôle du relais est de ne pas accorder d'autorisation de relais aux hôtes extérieurs. Cependant, le relais est parfois nécessaire. Par exemple, si vous disposez de clients POP3 (Post Office Protocol) et IMAP4 (Internet Message Access Protocol) utilisant SMTP pour la transmission des messages et ayant des raisons légitimes d'envoyer des messages électroniques à des domaines externes. Vous pouvez contourner ce problème en créant un deuxième serveur virtuel SMTP destiné à la réception des messages électroniques des clients POP3 et IMAP4. Ce serveur virtuel SMTP supplémentaire peut utiliser l'authentification associée au cryptage SSL (Secure Sockets Layer) et être configuré de manière à autoriser le relais par des clients authentifiés. Pour plus d'informations sur l'application de cette configuration, voir l'article 319267 de la Base de connaissances Microsoft sur la procédure de sécurisation de la remise de messages client à l'aide d'un protocole SMTP dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267).

Pour afficher ou modifier la valeur msExchSmtpRelayForAuth dans le Gestionnaire système

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut) et cliquez sur Propriétés.

  4. Sélectionnez l'onglet Accès, puis cliquez sur Relais.

  5. Désactiver ou activer la case à cocher Autoriser tous les ordinateurs authentifiés à relayer, sans tenir compte de la liste ci-dessus.

  6. Cliquez sur OK pour enregistrer les modifications.

Si la case est activée, l'attribut msExchSmtpRelayForAuth doit être défini sur True. Si la case est désactivée, l'attribut msExchSmtpRelayForAuth doit être défini sur False.

Pour plus d'informations sur le contrôle des comptes pouvant relayer des messages, voir les articles suivants de la Base de connaissances Microsoft :

  • 818778 sur les utilisateurs non autorisés à relayer des messages mais qui peuvent envoyer des messages via le serveur virtuel SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778).

  • 310380 sur la procédure pour empêcher l'utilisation d'Exchange 2000 comme un relais de messagerie dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)


La valeur msExchSmtpSmartHostType a été modifiée et diffère de sa valeur par défaut de 0
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchSmtpSmartHostType a été modifiée et diffère de sa valeur par défaut de 0. Si Exchange Server Analyzer détecte que la valeur de cet attribut n'est pas 0, un message indiquant une configuration autre que celle par défaut s'affiche.

L'attribut msExchSmtpSmartHostType indique si un serveur virtuel SMTP est configuré pour utiliser un hôte actif pour la remise des messages. Vous pouvez router tous les messages sortants pour des domaines distants vers un hôte actif, au lieu d'envoyer ces messages directement vers les domaines des destinataires. Lorsqu'Exchange est configuré pour utiliser un hôte actif, la valeur de l'attribut msExchSmtpSmartHostType est modifiée comme indiqué dans le tableau ci-dessous.

Paramètre d'hôte actif | msExchSmtpSmartHostType (valeur d'attribut)
Pas d'hôte actif | 0
Hôte actif | 2
Hôte actif avec tentative préalable de remise directe | 1

Sur des ordinateurs Exchange Server 2003, cette valeur est de 0 ou 2. Sur des ordinateurs Exchange 2000 Server, elle peut être de 0, 1 ou 2. La valeur 1 est définie lorsque la case à cocher Essayer la remise directe avant l'envoi à l'hôte actif est activée. Cette case à cocher n'est disponible que sur les ordinateurs Exchange 2000 Server. Exchange Server 2003 ne dispose pas de cette case à cocher.

À moins d'avoir une raison particulière, il est recommandé de conserver la valeur par défaut de 0 de l'attribut msExchSmtpSmartHostType.

Si votre environnement requiert un hôte actif et que vous avez (ou projetez d'avoir) plus d'un ordinateur Exchange Server dans votre environnement, il est recommandé d'utiliser un connecteur SMTP pour toutes les entrées d'hôte actif. De cette façon, tout votre courrier interne est routé par Exchange Server et seul votre courrier externe est routé par l'hôte actif.

Pour afficher et configurer les paramètres d'hôte actif

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, serveur virtuel SMTP par défaut) et sélectionnez Propriétés.

  4. Sélectionnez l'onglet Remise, puis cliquez sur Avancé.

  5. Entrez l'hôte actif à utiliser. Vous pouvez identifier l'hôte actif par le nom de domaine complet ou une adresse IP. Si vous utilisez une adresse IP, vous devez la placer entre crochets ([ ]). Exchange recherche d'abord un nom de serveur, puis une adresse IP. Les crochets identifient la valeur comme une adresse IP ; la recherche DNS est dès lors ignorée.

  6. Si vous utilisez un ordinateur Exchange 2000 Server, activez le cas échéant la case à cocher Essayer la remise directe avant l'envoi à l'hôte actif.

  7. Cliquez sur OK pour enregistrer les modifications, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=268163)


Le service des piles MTA est configuré de manière à interagir avec le Bureau
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la propriété DesktopInteract pour le service des piles MTA Microsoft Exchange (MSExchangeMTA). Si Exchange Server Analyzer détecte que le service MTA est configuré de manière à interagir avec le Bureau, il affiche une erreur.

Cette configuration ne doit être utilisée que sur recommandation des services du Support Technique de Microsoft (PSS). À moins que PSS vous ait demandé d'exécuter le service MTA dans cette configuration, il est recommandé de reconfigurer les propriétés de ce service de sorte qu'il n'interagisse pas avec le Bureau.

Pour configurer le compte du service des piles MTA Exchange

  1. Ouvrez le composant logiciel enfichable MMC Services.

  2. Recherchez et arrêtez le service des piles MTA Microsoft Exchange.

  3. Double-cliquez sur le service des piles MTA Microsoft Exchange.

  4. Sous l'onglet Ouvrir une session de la page Propriétés des piles MTA Microsoft Exchange, sélectionnez Compte LocalSystem sous Ouvrir une session en tant que.

  5. Désactivez la case à cocher Autoriser le service à interagir avec le Bureau, puis cliquez sur Appliquer.

  6. Sous Statut du service, cliquez sur Démarrer, puis sur OK.

  7. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur la configuration correcte du service Exchange, voir l'article 239762 de la Base de connaissances Microsoft sur les services Exchange exécutés sous LocalSystem (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762).


Aucun enregistrement d'hôte trouvé pour les enregistrements MX
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-03

L'outil Microsoft® Exchange Server Analyzer Tool effectue une recherche DNS pour récupérer les enregistrements de serveur de messagerie (MX) pour un domaine. Si les enregistrements MX sont correctement récupérés, Exchange Server Analyzer effectue ensuite une recherche DNS pour récupérer les enregistrements d'hôte (A) des serveurs vers lesquels les enregistrements MX pointent. Si l'opération de recherche DNS ne retourne aucune adresse IP pour l'un des enregistrements d'hôte (A), Exchange Server Analyzer affiche une erreur.

Cette erreur indique que l'enregistrement d'hôte (A) DNS semble être manquant pour le serveur. Cette erreur risque d'entraîner la sauvegarde des messages destinés aux domaines distants dans les files d'attente Remise distante du serveur Exchange. Cette erreur est également susceptible de provoquer d'autres retards de routage et de service.

La recherche DNS de l'enregistrement d'hôte (A) pour un enregistrement MX peut échouer pour les raisons suivantes :

  • Le serveur DNS est arrêté ou ne répond pas en raison d'une défaillance du réseau ou pour d'autres motifs.

  • L'enregistrement d'hôte (A) pour le serveur distant est manquant du serveur DNS car il n'est pas disponible ou correct.

  • Le serveur DNS n'est pas configuré pour activer les mises à jour dynamiques de l'enregistrement d'hôte.

Pour vérifier que le serveur DNS est en ligne et que l'enregistrement d'hôte est présent

  1. Pour vérifier que le serveur DNS est en cours d'exécution, effectuez au moins l'une des vérifications suivantes :

    • Examinez l'état du serveur DNS à partir du programme d'administration DNS sur le serveur DNS.

    • Redémarrez le serveur DNS. Pour plus d'informations, voir la rubrique sur le démarrage, l'arrêt, la mise en pause ou le redémarrage d'un serveur DNS (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Vérifiez le temps de réponse du serveur DNS à l'aide de la commande nslookup. Pour plus d'informations, voir la rubrique sur la vérification du temps de réponse du serveur DNS à l'aide de la commande nslookup (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. nslookup permet de vérifier que l'enregistrement d'hôte (A) existe sur le serveur DNS. Pour plus d'informations, voir la rubrique sur la procédure de vérification de l'existence d'une ressource A dans DNS (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Si l'enregistrement de ressource d'hôte (A) n'existe pas, ajoutez ou modifiez manuellement l'enregistrement de la ressource A ou configurez le serveur DNS pour activer les mises à jour dynamiques de l'enregistrement.

    • Ajoutez manuellement un enregistrement de ressource A. Pour plus d'informations, voir la rubrique sur l'ajout d'un enregistrement de ressource à une zone DNS (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifiez manuellement un enregistrement de ressource A. Pour plus d'informations, voir la rubrique sur la modification d'un enregistrement de ressource existant (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Configurez le serveur DNS de sorte qu'il active les mises à jour dynamiques de l'enregistrement d'hôte. Pour plus d'informations, voir l'article 816592 de la Base de connaissances Microsoft sur la procédure de configuration de la mise à jour dynamique du DNS sous Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).

Pour plus d'informations

  • Pour plus d'informations sur l'utilisation de DNS par Exchange Server 2003 pour résoudre les adresses IP externes, voir la rubrique sur les dépendances de transport pour Exchange Server 2003 du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Pour plus d'informations sur la résolution de nom DNS, voir l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Pour plus d'informations sur la procédure de résolution des problèmes de DNS, voir la rubrique sur la résolution des problèmes de DNS (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Pour plus d'informations sur la surveillance du système d'Exchange Server 2003, voir le chapitre 3 sur la surveillance du système avec le pack de gestion d'Exchange Server 2003 du Guide du pack de gestion d'Exchange Server 2003 pour MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Pour plus d'informations sur les enregistrements de ressource d'hôte (A), voir la rubrique sur la gestion des enregistrements de ressource (http://go.microsoft.com/fwlink/?LinkId=63004).


Aucun enregistrement d'hôte trouvé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-04

L'outil Microsoft® Exchange Server Analyzer Tool effectue une recherche DNS (Domain Name System) pour récupérer les enregistrements d'hôte (A) des serveurs distants auxquels le serveur Exchange essaie d'envoyer des messages. Si l'opération de recherche DNS ne retourne aucune adresse IP, Exchange Server Analyzer affiche une erreur.

Cette erreur indique que l'enregistrement d'hôte (A) DNS semble être manquant pour le serveur distant. Cette erreur risque d'entraîner la sauvegarde des messages dans les files d'attente Remise distante du serveur Exchange.

La recherche DNS de l'enregistrement d'hôte (A) du serveur distant peut échouer pour les raisons suivantes :

  • Le serveur DNS est arrêté ou ne répond pas en raison d'une défaillance du réseau ou pour d'autres motifs.

  • L'enregistrement d'hôte (A) pour le serveur distant est manquant du serveur DNS car il n'est pas disponible ou correct.

  • Le serveur DNS n'est pas configuré pour activer les mises à jour dynamiques de l'enregistrement d'hôte.

Pour vérifier que le serveur DNS est en ligne et que l'enregistrement d'hôte est présent

  1. Pour vérifier que le serveur DNS est en cours d'exécution, effectuez au moins l'une des vérifications suivantes :

    • Examinez l'état du serveur DNS à partir du programme d'administration DNS sur le serveur DNS.

    • Redémarrez le serveur DNS. Pour plus d'informations, voir la rubrique sur le démarrage, l'arrêt, la mise en pause ou le redémarrage d'un serveur DNS (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Vérifiez le temps de réponse du serveur DNS à l'aide de la commande nslookup. Pour plus d'informations, voir la rubrique sur la vérification du temps de réponse du serveur DNS à l'aide de la commande nslookup (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. nslookup permet de vérifier que l'enregistrement d'hôte (A) existe sur le serveur DNS. Pour plus d'informations, voir la rubrique sur la procédure de vérification de l'existence d'une ressource A dans DNS (http://go.microsoft.com/fwlink/?LinkId=63001).

  3. Si l'enregistrement de ressource d'hôte (A) n'existe pas, ajoutez ou modifiez manuellement l'enregistrement de la ressource A ou configurez le serveur DNS pour activer les mises à jour dynamiques de l'enregistrement.

    • Ajoutez manuellement un enregistrement de ressource A. Pour plus d'informations, voir la rubrique sur l'ajout d'un enregistrement de ressource à une zone DNS (http://go.microsoft.com/fwlink/?LinkId=63002).

    • Modifiez manuellement un enregistrement de ressource A. Pour plus d'informations, voir la rubrique sur la modification d'un enregistrement de ressource existant (http://go.microsoft.com/fwlink/?LinkId=63014).

    • Configurez le serveur DNS de sorte qu'il active les mises à jour dynamiques de l'enregistrement d'hôte. Pour plus d'informations, voir l'article 816592 de la Base de connaissances Microsoft sur la procédure de configuration de la mise à jour dynamique du DNS sous Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592).
  • Pour plus d'informations sur l'utilisation de DNS par Exchange Server 2003 pour résoudre les adresses IP externes, voir la rubrique sur les dépendances de transport pour Exchange Server 2003 du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Pour plus d'informations sur la résolution de nom DNS, voir l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Pour plus d'informations sur la procédure de résolution des problèmes de DNS, voir la rubrique sur la résolution des problèmes de DNS (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Pour plus d'informations sur la surveillance du système d'Exchange Server 2003, voir le chapitre 3 sur la surveillance du système avec le pack de gestion d'Exchange Server 2003 du Guide du pack de gestion d'Exchange Server 2003 pour MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).

  • Pour plus d'informations sur les enregistrements de ressource d'hôte (A), voir la rubrique sur la gestion des enregistrements de ressource (http://go.microsoft.com/fwlink/?LinkId=63004).


Aucun enregistrement MX trouvé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge les serveurs DNS qu'il utilise pour les enregistrements de serveur de messagerie (MX) des domaines distants vers lesquels Exchange effectue des envois.

Si Exchange Server Analyzer ne peut pas récupérer d'enregistrements MX pour un domaine distant sur les serveurs DNS qu'il utilise, il affiche un avertissement.

Ce avertissement indique que les enregistrements MX du DNS semblent être manquants pour le domaine distant.

Pour identifier les hôtes de messagerie, le serveur Exchange expéditeur recherche un enregistrement MX. Ensuite, il le résout en une adresse IP en recherchant un enregistrement d'adresse (A).

Si des enregistrements MX sont manquants pour des domaines distants, les messages destinés aux domaines distants risquent d'être sauvegardés dans les files d'attente Remise distante du serveur Exchange, ajoutant ainsi aux autres retards de routage et de service.

La recherche DNS d'enregistrements MX peut échouer si le serveur DNS est arrêté ou inaccessible en raison d'une défaillance du réseau ou pour d'autres motifs.

Pour vérifier que le serveur DNS est en ligne et que les enregistrements MX sont présents

  1. Pour vérifier que le serveur DNS est en cours d'exécution, effectuez au moins l'une des vérifications suivantes :

    • Examinez l'état du serveur DNS à partir du programme d'administration DNS sur le serveur DNS.

    • Redémarrez le serveur DNS. Pour plus d'informations, voir la rubrique sur le démarrage, l'arrêt, la mise en pause ou le redémarrage d'un serveur DNS (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Vérifiez le temps de réponse du serveur DNS à l'aide de la commande nslookup. Pour plus d'informations, voir les instructions de la rubrique sur la vérification du temps de réponse du serveur DNS à l'aide de la commande nslookup (http://go.microsoft.com/fwlink/?LinkId=63000).

  2. La commande nslookup permet de vérifier que les enregistrements MX sont correctement configurés. Pour plus d'informations, voir la rubrique sur l'utilisation de Nslookup pour vérifier la configuration de l'enregistrement MX dans la section sur la vérification de la conception et de la configuration DNS du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations

  • Pour plus d'informations sur l'utilisation de DNS par Exchange Server 2003 pour résoudre les adresses IP externes, voir la rubrique sur les dépendances de transport pour Exchange Server 2003 du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

  • Pour plus d'informations sur la résolution de nom DNS, voir l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • Pour plus d'informations sur la procédure de résolution des problèmes de DNS, voir la rubrique sur la résolution des problèmes de DNS (http://go.microsoft.com/fwlink/?LinkId=63003).

  • Pour plus d'informations sur la surveillance du système d'Exchange Server 2003, voir le chapitre 3 sur la surveillance du système avec le pack de gestion d'Exchange Server 2003 du Guide du pack de gestion d'Exchange Server 2003 pour MOM 2000 SP1 (http://go.microsoft.com/fwlink/?LinkId=47573).


Groupe de distribution imbriqué trouvé dans les restrictions de remise
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet de groupe de distribution de tous les domaines trouvés dans le service d'annuaire Active Directory® pour déterminer si l'un des groupes permet de définir des restrictions de remise basées sur l'appartenance au groupe :

dLMemRejectPermsBL | Contient les noms de domaine des destinataires ou connecteurs qui n'acceptent pas les messages de ce groupe.
dLMemSubmitPermsBL | Contient les noms de domaine des destinataires ou connecteurs qui acceptent les messages de ce groupe.

Si Exchange Server Analyzer détecte que des objets de groupe permettent de définir des restrictions de remise, il examine ces groupes pour déterminer s'ils contiennent des groupes imbriqués.

Exchange Server Analyzer lit également la clé de Registre suivante pour déterminer si la valeur de Registre RestrictionMethod est présente et comment elle est configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • L'appartenance au groupe de distribution permet de définir des restrictions de remise.

  • Des groupes de distribution sont imbriqués dans les groupes de distributions pour lesquels des restrictions de remise sont définies.

  • La valeur de Registre RestrictionMethod est présente mais pas définie de manière à forcer la vérification des restrictions bidimensionnelles.

Cette erreur indique que des restrictions de remise sur la base de l'appartenance au groupe de distribution peuvent affecter considérablement les performances de flux de messages d'Exchange.

Les comportements par défaut du catégoriseur consistent à développer de manière récurrente les groupes de distribution et à vérifier les restrictions pour chaque message qui passe par le système.

Lorsque vous envoyez du courrier à un utilisateur qui accepte ou refuse des messages d'un groupe de distribution ou lorsque vous envoyez du courrier qui passe par un connecteur qui accepte ou refuse des messages d'un groupe de distribution, le catégoriseur de messages doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas de correspondance d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

La valeur RestrictionMethod détermine la manière dont le catégoriseur traite les restrictions. Si vous définissez la valeur de RestrictionMethod sur 2, les composants de transport de ce serveur qui exécute Exchange Server ne développent pas l'appartenance des groupes de distribution lorsque le serveur vérifie les restrictions. Cette configuration fournit les meilleures performances au niveau de la vérification des restrictions. En outre, pour que l'entrée de Registre RestrictionMethod soit appliquée, tous les groupes de distribution qui incluent des utilisateurs soumis à des restrictions de remise de messages doivent être bidimensionnels. Cela signifie que les groupes de distribution restreints ne doivent présenter aucun groupe de distribution imbriqué. La logique d'expansion ne fonctionne pas si des groupes de distribution restreints sont imbriqués.

Pour les groupes de distribution utilisés dans des restrictions de connecteur, il est recommandé de définir la valeur de l'entrée de Registre RestrictionMethod sur un serveur tête de pont de connecteur qui ne possède aucune boîte aux lettres. Pour les restrictions utilisateur d'Active Directory, si les groupes de distribution restreints possèdent des serveurs d'expansion, nous recommandons de créer l'entrée de Registre RestrictionMethod sur les serveurs d'expansion.

Pour corriger cette erreur :

  • Identifiez les utilisateurs pour lesquels des restrictions de remise pour le groupe de distribution sont définies et supprimez les restrictions inutiles.

  • Configurez les boîtes aux lettres individuelles et pas les groupes de distribution pour les restrictions de remise comme décrit dans l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Pour les serveurs qui exécutent Microsoft Exchange Server 2003 Service Pack 2 (SP2) ou version ultérieure, envisagez la mise en œuvre de la vérification des restrictions non hiérarchiques. Pour les serveurs qui exécutent des versions d'Exchange antérieures à Exchange 2003 SP2, envisagez la mise à niveau vers Exchange 2003 SP2.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour créer l'entrée de Registre RestrictionMethod et en définir la valeur sur 2

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Accédez à : HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Dans le volet gauche, cliquez sur Paramètres.

  4. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  5. Entrez RestrictionMethod, puis appuyez sur ENTRÉE pour nommer la nouvelle entrée de Registre.

  6. Cliquez avec le bouton droit sur RestrictionMethod, puis cliquez sur Modifier.

  7. Entrez 2, puis appuyez sur ENTRÉE.

  8. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Pour plus d'informations sur la valeur de Registre RestrictionMethod, voir l'article 895407 de la Base de connaissances Microsoft sur la remise des messages aux boîtes aux lettres locales et externes qui est plus lente que prévu dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Pour plus d'informations sur la valeur de Registre, voir l'article 277872 de la Base de connaissances Microsoft sur les restrictions de remise de connecteur, qui risquent de ne pas fonctionner correctement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Groupe de distribution imbriqué trouvé mais la vérification des restrictions bidimensionnelles est activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet de groupe de distribution de tous les domaines trouvés dans le service d'annuaire Active Directory® pour déterminer si l'un des groupes permet de définir des restrictions de remise basées sur l'appartenance au groupe :

dLMemRejectPermsBL | Contient les noms de domaine des destinataires ou connecteurs qui n'acceptent pas les messages de ce groupe.
dLMemSubmitPermsBL | Contient les noms de domaine des destinataires ou connecteurs qui acceptent les messages de ce groupe.

Si Exchange Server Analyzer détecte que des objets de groupe permettent de définir des restrictions de remise, il examine ensuite ces groupes pour déterminer s'ils contiennent des groupes imbriqués.

Exchange Server Analyzer lit également la clé de Registre suivante pour déterminer si la valeur de Registre RestrictionMethod est présente et comment elle est configurée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • L'appartenance au groupe de distribution permet de définir des restrictions de remise.

  • Des groupes de distribution sont imbriqués dans les groupes de distributions pour lesquels des restrictions de remise sont définies.

  • La valeur de Registre RestrictionMethod est présente et définie de manière à forcer la vérification des restrictions bidimensionnelles.

Cet avertissement indique que, bien que la valeur de Registre RestrictionMethod soit définie de manière à forcer la vérification des restrictions (non hiérarchiques) bidimensionnelles, les groupes de distribution présentent des restrictions de remise définies de manière à ce que d'autres groupes de distribution y soient incorporés (imbriqués). La vérification des restrictions bidimensionnelles n'identifie pas correctement les expéditeurs autorisés ou refusés si les groupes de distribution contiennent des groupes de distribution imbriqués. Avec la vérification des restrictions bidimensionnelles, les groupes de distribution imbriqués ne sont pas développés.

Les comportements par défaut du catégoriseur consistent à développer de manière récurrente les groupes de distribution et à vérifier les restrictions pour chaque message qui passe par le système.

Lorsque vous envoyez du courrier à un utilisateur qui accepte ou refuse des messages d'un groupe de distribution ou lorsque vous envoyez du courrier qui passe par un connecteur qui accepte ou refuse des messages d'un groupe de distribution, le catégoriseur de messages doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas de correspondance d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

La valeur RestrictionMethod détermine la manière dont le catégoriseur traite les restrictions. Si vous définissez la valeur de RestrictionMethod sur 2, les composants de transport de ce serveur qui exécute Exchange Server ne développent pas l'appartenance des groupes de distribution lorsque le serveur vérifie les restrictions. Cette configuration fournit les meilleures performances au niveau de la vérification des restrictions. En outre, pour que l'entrée de Registre RestrictionMethod soit appliquée, tous les groupes de distribution qui incluent des utilisateurs soumis à des restrictions de remise de messages doivent être bidimensionnels. Cela signifie que les groupes de distribution restreints ne doivent présenter aucun groupe de distribution imbriqué.

Pour supprimer cet avertissement, n'imbriquez pas de groupes de distribution dans d'autres groupes de distribution utilisés pour les restrictions de remise lorsque la vérification des restrictions bidimensionnelles est activée.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Pour plus d'informations sur la valeur de Registre RestrictionMethod, voir l'article 895407 de la Base de connaissances Microsoft sur la remise des messages aux boîtes aux lettres locales et externes qui est plus lente que prévu dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Pour plus d'informations sur la valeur de Registre, voir l'article 277872 de la Base de connaissances Microsoft sur les restrictions de remise de connecteur, qui risquent de ne pas fonctionner correctement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Pas de message provenant de l'expéditeur spécifié
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-03-07

L'outil Microsoft Exchange Server Analyzer Tool interroge la valeur de l'attribut proxyAddress du service d'annuaire Active Directory pour tous les objets utilisateur afin de déterminer si une correspondance existe pour l'adresse SMTP (Simple Mail Transfer Protocol) de l'expéditeur local spécifié par l'utilisateur.

Si une correspondance proxyAddress d'objet utilisateur est trouvée, Exchange Server Analyzer interroge ensuite la valeur de l'attribut msExchHomeServerName Active Directory pour déterminer si cette valeur correspond au nom Exchange Server spécifié par l'utilisateur.

Enfin, Exchange Server Analyzer interroge la propriété SenderAddress pour la classe WMI (Windows Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour identifier les messages faisant l'objet d'un suivi par les journaux de suivi des messages pour vérifier s'ils proviennent de l'expéditeur spécifié par l'utilisateur.

Si Exchange Server Analyzer ne trouve pas d'entrée de journal de suivi des messages dont la valeur de la propriété senderAddress correspond à legacyDN ou à l'adresse SMTP de l'expéditeur spécifié par l'utilisateur, il affiche une erreur.

  • Cette erreur indique qu'au moins l'une des conditions suivantes est vraie :

  • L'expéditeur spécifié par l'utilisateur n'a envoyé aucun message.

  • La période de rétention du journal de suivi des messages s'est écoulée et les entrées appropriées du journal ont été supprimées.

  • Le suivi des messages n'est pas activé pour le serveur.

Pour résoudre ce problème :

  • Demandez à l'expéditeur spécifié d'envoyer un autre message au destinataire concerné.

  • Activez le Centre de suivi des messages.

  • Prolongez la période de rétention du journal de suivi des messages ou assurez le suivi d'un message plus actuel.

Pour plus d'informations sur la procédure d'activation du Centre de suivi des messages, voir la section sur la procédure d'activation du Centre de suivi des messages sur un serveur (http://go.microsoft.com/fwlink/?LinkId=71257) dans la rubrique sur la résolution des problèmes de flux de messagerie et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875).

Pour plus d'informations sur l'utilisation du suivi des messages, voir l'article 262162 de la Base de connaissances Microsoft sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).


Pas de message pour le destinataire spécifié
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-12-07

L'outil Microsoft® Exchange Server Analyzer Tool interroge la valeur de l'attribut proxyAddress du service d'annuaire Active Directory® pour tous les objets utilisateur afin de déterminer si une correspondance existe pour l'adresse SMTP (Simple Mail Transfer Protocol) de l'expéditeur local spécifié par l'utilisateur.

Si une correspondance proxyAddress d'objet utilisateur est trouvée, Exchange Server Analyzer interroge ensuite la valeur de l'attribut msExchHomeServerName Active Directory pour déterminer si cette valeur correspond au nom Exchange Server spécifié par l'utilisateur.

Puis, Exchange Server Analyzer interroge la propriété SenderAddress pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour identifier les messages faisant l'objet d'un suivi par les journaux de suivi des messages pour vérifier s'ils proviennent de l'expéditeur spécifié par l'utilisateur.

Enfin, Exchange Server Analyzer interroge la propriété RecipientAddress pour la classe WMI Exchange_MessageTrackingEntry afin d'identifier d'éventuels messages faisant l'objet d'un suivi par les journaux de suivi des messages à l'attention du destinataire spécifié par l'utilisateur.

Si Exchange Server Analyzer ne trouve pas d'entrée de journal de suivi des messages dont la valeur de la propriété RecipientAddress correspond à l'adresse SMTP du destinataire spécifié par l'utilisateur, il affiche une erreur.

Cette erreur indique qu'au moins l'une des conditions suivantes est vraie :

  • L'expéditeur spécifié par l'utilisateur n'a pas envoyé de messages au destinataire spécifié par l'utilisateur.

  • La période de rétention du journal de suivi des messages s'est écoulée et les entrées appropriées du journal ont été supprimées.

Pour résoudre ce problème :

  • Vérifiez que l'adresse du destinataire spécifié est correcte.

  • Demandez à l'expéditeur spécifié d'envoyer un autre message au destinataire concerné.

  • Prolongez la période de rétention du journal de suivi des messages ou assurez le suivi d'un message plus actuel.

Pour plus d'informations sur la procédure de prolongement de la période de rétention du journal du Centre de suivi des messages, consultez la page « Procédure d'activation du Centre de suivi des messages sur un serveur » (http://go.microsoft.com/fwlink/?LinkID=71257).

Pour plus d'informations sur l'utilisation du suivi des messages, voir l'article 262162 de la Base de connaissances Microsoft sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162).


Aucun état de file d'attente disponible. Abandon de l'analyse de la file d'attente SMTP.
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-03-15

L'outil Microsoft Exchange Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft ExchangeLink pour contrôler l'état des files d'attente SMTP (Simple Mail Transfer Protocol) pour un serveur Exchange.

SMTP est le protocole de messagerie natif pour l'envoi et le transport de messages électroniques pour Exchange Server. Cela signifie que les clients utilisent SMTP pour envoyer des messages et que les serveurs Exchange utilisent SMTP pour remettre les messages et les données des messages.

Les propriétés de la classe WMI ExchangeLink renvoient des informations sur les liens de gestion des messages (files d'attente) entre les serveurs de messagerie. Un lien peut contenir zéro ou plus d'objets ExchangeQueue. Ce nombre dépend du trafic actuel des messages sur le lien.

Le protocole SMTP utilise les files d'attente SMTP pour remettre du courrier de manière interne et externe. Lors de la catégorisation et de la remise des messages, le moteur de files d'attente avancé envoie tous les messages via les files d'attente SMTP d'un serveur virtuel SMTP. Si un problème survient lors de la remise du message à n'importe quel stade du processus, le message reste dans la file d'attente concernée.

Description des files d'attente SMTP

File d'attente SMTP Description

[nom de domaine local] (Remise locale)

Contient les messages placés en file d'attente sur le serveur Exchange en vue de leur remise locale dans une boîte aux lettres Exchange ou une banque de dossiers publics.

Messages en attente d'une recherche dans l'annuaire

Contient les messages adressés aux destinataires dont les noms ne sont pas encore résolus au niveau du service d'annuaire Microsoft Active Directory. Les messages figurent également ici lors de l'extension des listes de distribution.

Messages en attente de routage

Conserve les messages tant que le serveur de destination suivant n'est pas déterminé, puis déplace les messages vers leurs files d'attente de liens respectives.

Remise distante

[Nom de connecteur|

Nom de serveur| Domaine distant]

Contient les messages destinés à une remise distante. Le nom de la file d'attente correspond à celui de la destination de remise distante qui peut être un connecteur, un serveur ou un domaine.

Destination finale actuellement inaccessible

Le serveur de destination finale des messages n'est pas accessible. Par exemple, Exchange ne peut pas déterminer le chemin d'accès réseau à la destination finale.

Dépôt préalable

Contient les messages qui ont été reçus et acceptés par le service SMTP. Le traitement de ces messages n'a pas commencé.

Envoi de messages DSN suspendu

Contient les notifications d'état de remise, connues également sous le nom de rapports de non-remise, qui sont prêtes à être remises par Exchange.

Remarque Les opérations suivantes ne sont pas disponibles pour cette file d'attente :

  • Supprimer tous les messages (pas de rapport de non-remise)

  • Supprimer tous les messages (rapport de non-remise)

File de nouvel essai des messages qui ont échoué

Contient les messages qui n'ont pas pu être placés en file d'attente de dépôt avant tout autre traitement. Par défaut, les messages de cette file d'attente sont retraités dans les 60 minutes.

Messages en file d'attente pour une remise différée

Contient les messages qui sont mis en file d'attente pour être remis ultérieurement, y compris les messages qui ont été envoyés par des versions antérieures d'Outlook. (Vous pouvez définir cette option sur les ordinateurs clients Outlook).

Les versions antérieures d'Outlook dépendent de l'Agent de transfert des messages (MTA) pour la remise des messages. Désormais, cependant, le protocole SMTP gère la remise des messages à la place de l'Agent de transfert des messages. Ainsi, les messages envoyés par des versions antérieures d'Outlook traitent différemment la remise différée.

Ces messages restent dans cette file d'attente jusqu'au moment prévu pour leur remise.

Si Exchange Analyzer ne peut pas interroger avec succès la classe WMI ExchangeLink pour un serveur, il affiche une erreur.

Cette erreur indique que la requête WMI n'a pas pu extraire les données requises.

Les causes probables de cette erreur sont les suivantes :

  • le compte qui utilise Exchange Analyzer n'a pas d'autorisations suffisantes pour interroger des classes WMI ou

  • Un problème de réseau empêche Exchange Analyzer de contacter l'ordinateur.

  • Une condition temporaire d'origine inconnue a entraîné un délai d'attente pour la requête.

Pour résoudre cette erreur, procédez comme suit :

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Utilisez la commande PING pour voir si l'ordinateur Exchange Server est accessible.

  3. En cas de pare-feu, vérifiez que les ports d'appel de procédure distante (RPC) sont bloqués.

  4. Vérifiez les autorisations pour le compte sous lequel Exchange Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque serveur Exchange qu'il analyse.

    Vous pouvez également accorder des autorisations WMI spécifiques au compte sous lequel Exchange Analyzer est exécuté :

    1. Sur l'ordinateur Exchange, ouvrez l'arborescence de la console MMC (Microsoft Management Console) Gestion de l'ordinateur.

    2. Dans Services et applications, cliquez avec le bouton droit sur Contrôle WMI et cliquez sur Propriétés.

    3. Dans la page Propriété des contrôles WMI, cliquez sur l'onglet Sécurité, puis développez Racine.

    4. Sélectionnez le dossier CIMV2 et cliquez sur Sécurité.

    5. Dans la page Sécurité pour ROOT\CIMV2, ajoutez le compte sous lequel Exchange Analyzer est exécuté.

  5. Sélectionnez le compte ajouté à l'étape 5 ci-dessus. Dans Autorisations pour compte_sélectionné, sous la colonne Autoriser, activez les cases à cocher Appel à distance autorisé et Sécurité de lecture, puis cliquez sur OK.

Pour plus d'informations sur la résolution des problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur la résolution des problèmes de connectivité de l'outil Exchange Best Practices Analyzer Tool, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, voir l'article 832017 de la Base de connaissances Microsoft sur la vue d'ensemble des services et les exigences de ports réseau pour le système Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Aucun serveur distant ou domaine disponible pour les tests d'enregistrement DNS
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-06

L'outil Microsoft® Exchange Server Analyzer Tool essaye d'identifier et de dresser une liste des noms de domaine complets (FQDN), adresses IP et noms de domaines des serveurs distants auxquels sont destinés les messages se trouvant dans une file d'attente de remise distante.

La liste des noms de domaine complets, adresses IP et noms de domaines des serveurs distants est constituée comme suit :

  • L'outil interroge la propriété msExchSmtpFullyQualifiedDomainName de l'objet de service d'annuaire Active Directory® du serveur virtuel SMTP (Simple Mail Transfer Protocol).

    Remarque :
    Il lit ensuite la propriété msExchSmtpFullyQualifiedDomainName à partir de la propriété msExchTargetBridgeheadServersDN d'un objet d'annuaire de connecteur de groupe de routage lorsque celui-ci est interrogé pour les serveurs Bridgehead cibles désignés.
  • Il interroge la propriété msExchSmtpSmartHost de l'objet Active Directory du connecteur SMTP pour l'hôte actif désigné d'un connecteur SMTP.

  • Il interroge la propriété LinkName de la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour les éventuelles connexions directes aux serveurs distants.

Si Exchange Server Analyzer détermine que la tentative de dresser cette liste donne une liste vide, il affiche une erreur.

Cette erreur indique que :

  • Il peut y avoir des problèmes intermittents de connexion au réseau ou à Active Directory, qui provoquent des problèmes de flux de messages.

  • Le compte qui exécute Exchange Server Analyzer ne possède peut-être pas d'autorisations suffisantes pour demander les informations.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.

  3. Spécifiez un contrôleur de domaine Active Directory dans Exchange Server Analyzer.

  4. Utilisez la commande PING pour voir si l'ordinateur Exchange Server est accessible.

  5. Si un pare-feu est installé, vérifiez si les ports RPC sont bloqués.

  6. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque ordinateur Exchange Server qu'il analyse.

Pour plus d'informations sur les problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur les problèmes de connectivité de l'outil Exchange Server Analyzer, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, voir l'article 832017 de la Base de connaissance sur la vue d'ensemble des services et exigences de ports réseau pour le système Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Aucun serveur disponible pour les tests des commandes SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-16

L'outil Microsoft® Exchange Server Analyzer essaie d'identifier et de dresser la liste des noms de domaine complets (FQDN), adresses IP et noms de domaines des serveurs distants auxquels sont destinés les messages se trouvant dans une file d'attente de remise distante.

La liste des noms de domaine complets, adresses IP et noms de domaines des serveurs distants est constituée comme suit :

  • L'outil interroge la propriété msExchSmtpFullyQualifiedDomainName de l'objet de service d'annuaire Active Directory® du serveur virtuel SMTP (Simple Mail Transfer Protocol).

    Remarque :
    Il lit ensuite la propriété msExchSmtpFullyQualifiedDomainName à partir de la propriété msExchTargetBridgeheadServersDN d'un objet d'annuaire de connecteur de groupe de routage lorsque celui-ci est interrogé pour les serveurs têtes de pont cibles désignés.
  • Il interroge la propriété msExchSmtpSmartHost de l'objet Active Directory du connecteur SMTP pour l'hôte actif désigné d'un connecteur SMTP.

  • Il interroge la propriété LinkName de la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour les éventuelles connexions directes aux serveurs distants.

Si Exchange Server Analyzer détermine que la tentative de dresser cette liste donne une liste vide, il affiche une erreur.

Cette erreur indique ce qui suit :

  • Il peut y avoir des problèmes temporaires de connexion au réseau ou à Active Directory, qui provoquent des problèmes de flux de messages.

  • Le compte qui exécute Exchange Server Analyzer ne possède peut-être pas d'autorisations suffisantes pour demander les informations.

Correction de cette erreur

  1. Assurez-vous que le serveur exécutant Exchange Server a été démarré et est connecté au réseau.

  2. Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.

  3. Spécifiez un contrôleur de domaine Active Directory dans Exchange Server Analyzer.

  4. Utilisez la commande PING pour voir si le serveur Exchange est accessible.

  5. En cas de présence d'un pare-feu, vérifiez si les ports d'appel de procédure distante (RPC) sont bloqués.

  6. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque ordinateur Exchange Server qu'il analyse.

Pour plus d'informations sur les problèmes de connectivité réseau, consultez l'article 325487 de la Base de connaissances Microsoft, « Résolution des problèmes de connectivité réseau » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur les problèmes de connectivité de l'outil Exchange Server Analyzer, consultez le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, consultez l'article 832017 de la Base de connaissance, « Vue d'ensemble des services et exigences de ports réseau pour le système Windows Server » (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Aucun serveur disponible pour les tests de connectivité
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool essaye d'identifier et de dresser une liste des noms de domaine complets (FQDN), adresses IP et noms de domaines des serveurs distants auxquels sont destinés les messages se trouvant dans une file d'attente de remise distante.

  • La liste des noms de domaine complets, adresses IP et noms de domaines des serveurs distants est constituée comme suit :

  • L'outil interroge la propriété msExchSmtpFullyQualifiedDomainName de l'objet de service d'annuaire Active Directory® du serveur virtuel SMTP (Simple Mail Transfer Protocol).

    Remarque :
    Il lit ensuite la propriété msExchSmtpFullyQualifiedDomainName à partir de la propriété msExchTargetBridgeheadServersDN d'un objet d'annuaire de connecteur de groupe de routage lorsque celui-ci est interrogé pour les serveurs Bridgehead cibles désignés.
  • Il interroge la propriété msExchSmtpSmartHost de l'objet Active Directory du connecteur SMTP pour l'hôte actif désigné d'un connecteur SMTP.

  • Il interroge la propriété LinkName de la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour les éventuelles connexions directes aux serveurs distants.

Si Exchange Server Analyzer détermine que la tentative de dresser cette liste donne une liste vide, il affiche une erreur.

Cette erreur indique que :

  • Il peut y avoir des problèmes intermittents de connexion au réseau ou à Active Directory, qui provoquent des problèmes de flux de messages.

  • Le compte qui exécute Exchange Server Analyzer ne possède peut-être pas d'autorisations suffisantes pour demander les informations.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.

  3. Spécifiez un contrôleur de domaine Active Directory dans Exchange Server Analyzer.

  4. Utilisez la commande PING pour voir si l'ordinateur Exchange Server est accessible.

  5. Si un pare-feu est installé, vérifiez si les ports RPC sont bloqués.

  6. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque ordinateur Exchange Server qu'il analyse.

Pour plus d'informations sur les problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur les problèmes de connectivité de l'outil Exchange Server Analyzer, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, voir l'article 832017 de la Base de connaissance sur la vue d'ensemble des services et exigences de ports réseau pour le système Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Aucun serveur disponible pour les contrôles de noms d'instances SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool essaye d'identifier et de dresser une liste des noms de domaine complets (FQDN), adresses IP et noms de domaines des serveurs distants auxquels sont destinés les messages se trouvant dans une file d'attente de remise distante.

La liste des noms de domaine complets, adresses IP et noms de domaines des serveurs distants est constituée comme suit :

  • L'outil interroge la propriété msExchSmtpFullyQualifiedDomainName de l'objet de service d'annuaire Active Directory® du serveur virtuel SMTP (Simple Mail Transfer Protocol).

    Remarque :
    Il lit ensuite la propriété msExchSmtpFullyQualifiedDomainName à partir de la propriété msExchTargetBridgeheadServersDN d'un objet d'annuaire de connecteur de groupe de routage lorsque celui-ci est interrogé pour les serveurs Bridgehead cibles désignés.
  • Il interroge la propriété msExchSmtpSmartHost de l'objet Active Directory du connecteur SMTP pour l'hôte actif désigné d'un connecteur SMTP.

  • Il interroge la propriété LinkName de la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour les éventuelles connexions directes aux serveurs distants.

Si Exchange Server Analyzer détermine que la tentative de dresser cette liste donne une liste vide, il affiche une erreur.

Cette erreur indique que :

  • Il peut y avoir des problèmes intermittents de connexion au réseau ou à Active Directory, qui provoquent des problèmes de flux de messages.

  • Le compte qui exécute Exchange Server Analyzer ne possède peut-être pas d'autorisations suffisantes pour demander les informations.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.

  3. Spécifiez un contrôleur de domaine Active Directory dans Exchange Server Analyzer.

  4. Utilisez la commande PING pour voir si l'ordinateur Exchange Server est accessible.

  5. Si un pare-feu est installé, vérifiez si les ports RPC sont bloqués.

  6. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque ordinateur Exchange Server qu'il analyse.

Pour plus d'informations sur les problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur les problèmes de connectivité de l'outil Exchange Server Analyzer, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, voir l'article 832017 de la Base de connaissance sur la vue d'ensemble des services et exigences de ports réseau pour le système Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Paramètre de cache du service de routage autre que celui par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le paramètre par défaut de la mise en cache du service de routage a été modifié :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

Si Exchange Server Analyzer détecte que la valeur de Registre ServerCacheRefreshInterval a été créée manuellement pour remplacer le paramètre binaire par défaut d'Exchange Server de 900, il affiche un avertissement. Par défaut, la valeur de Registre ServerCacheRefreshInterval n'est pas créée par une installation d'Exchange Server. Toutefois, la valeur de Registre ServerCacheRefreshInterval peut être créée manuellement après l'installation d'Exchange Server pour modifier le paramètre de mise en cache du service de routage par défaut. Si la valeur de Registre est créée manuellement et si le paramètre de cette valeur est configuré de manière incorrecte, le serveur Exchange peut rencontrer des problèmes de flux de messagerie.

Il est recommandé de ne créer ou modifier la valeur de Registre ServerCacheRefreshInterval qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour Exchange Server ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements d'Exchange Server. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange Server en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre ServerCacheRefreshInterval existe, vous souhaiterez peut-être la supprimer pour reconfigurer le serveur Exchange sur le paramètre binaire par défaut de la mise en cache du service de routage. Toutefois, votre décision dépend des paramètres de configuration personnalisés d'Exchange Server ou de l'environnement Exchange.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Cliquez sur Démarrer et Exécuter, entrez Regedit, puis cliquez sur OK.

  2. Dans l'arborescence de la console, recherchez, puis cliquez sur la clé de Registre suivante : HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre ServerCacheRefreshInterval. Modifiez les données de la valeur en 900.

  4. Dans le volet Détails, cliquez éventuellement avec le bouton droit sur la valeur de Registre ServerCacheRefreshInterval, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756).


Valeur de Registre SMTP LdapRequestTimeLimit non définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur LdapRequestTimeLimit par défaut a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Si Exchange Server Analyzer détecte que la valeur de Registre LdapRequestTimeLimit a été créée manuellement pour remplacer le paramètre binaire par défaut du serveur Exchange de 600 secondes, il affiche un message d'avertissement indiquant une configuration autre que celle par défaut. Par défaut, la valeur de Registre LdapRequestTimeLimit n'est pas créée par une installation d'Exchange Server. Toutefois, la valeur de Registre LdapRequestTimeLimit peut être créée manuellement après l'installation d'Exchange Server pour modifier la période maximale (en secondes) pendant laquelle une requête LDAP unique attend dans la file d'attente. Si la valeur de Registre est créée manuellement et si le paramètre de cette valeur est configuré de manière incorrecte, le serveur Exchange peut rencontrer des problèmes de transport des messages.

Il est recommandé de ne créer ou modifier la valeur de Registre LdapRequestTimeLimit qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour le serveur Exchange ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements de serveur Exchange. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange Server en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre LdapRequestTimeLimit existe, vous souhaiterez peut-être la supprimer pour reconfigurer le serveur Exchange sur le paramètre binaire par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Cliquez sur Démarrer et Exécuter, entrez Regedit, puis cliquez sur OK.

  2. Dans l'arborescence de la console, recherchez, puis cliquez sur la clé de Registre suivante : HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre LdapRequestTimeLimit. Modifiez les données de la valeur en 600.

  4. Dans le volet Détails, cliquez éventuellement avec le bouton droit sur la valeur de Registre LdapRequestTimeLimit, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valeur de Registre SMTP LdapResultTimeout non définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur LdapResultTimeout par défaut a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Si Exchange Server Analyzer détecte que la clé de Registre LdapResultTimeout a été créée manuellement pour remplacer le paramètre binaire par défaut du serveur Exchange de 121 secondes, il affiche un message d'avertissement indiquant une configuration autre que celle par défaut. Par défaut, la clé de Registre LdapResultTimeout n'est pas créée par une installation d'Exchange Server. Toutefois, la clé de Registre LdapResultTimeout peut être créée manuellement après l'installation d'Exchange Server pour modifier la valeur de délai. LdapResultTimeout est le délai maximum en secondes pendant lequel les threads d'exécution LDAP, pour les connexions LDAP du catégoriseur, attendent d'être traitées. Si le délai expire et qu'aucun nouveau résultat ne provient d'un serveur de catalogue global, les recherches en cours échouent en rapport avec LDAP_SERVER_DOWN. Ce processus permet ensuite aux recherches en cours d'être de nouveaux appliquées sur les nouvelles connexions. Si la valeur de Registre est créée manuellement et si le paramètre de cette valeur est configuré de manière incorrecte, le serveur Exchange peut rencontrer des problèmes de transport des messages.

Il est recommandé de ne créer ou modifier la valeur de Registre LdapResultTimeout qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour Exchange Server ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements d'Exchange Server. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre LdapResultTimeout existe, vous souhaiterez peut-être la supprimer pour reconfigurer le serveur Exchange sur le paramètre binaire par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Cliquez sur Démarrer et Exécuter, entrez Regedit, puis cliquez sur OK.

  2. Dans l'arborescence de la console, recherchez, puis cliquez sur la clé de Registre suivante : HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre LdapResultTimeout. Modifiez les données de la valeur en 121.

  4. Dans le volet Détails, cliquez éventuellement avec le bouton droit sur la valeur de Registre LdapResultTimeout, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valeur de Registre SMTP MaxConnectionRetries non définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur MaxConnectionRetries par défaut a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Si Exchange Server Analyzer détecte que la valeur de Registre MaxConnectionRetries a été créée manuellement pour remplacer le paramètre binaire par défaut du serveur Exchange de 20, il affiche un message d'avertissement indiquant une configuration autre que celle par défaut. Par défaut, la valeur de Registre MaxConnectionRetries n'est pas créée par une installation d'Exchange Server. Toutefois, la valeur de Registre MaxConnectionRetries peut être créée manuellement après l'installation d'Exchange Server pour modifier la valeur. La valeur MaxConnectionRetries définit le nombre maximal de fois qu'une catégorisation unique peut voir sa connexion LDAP échouer et devoir établir une nouvelle connexion. Après l'échec de la catégorisation de connexion MaxConnectionRetries, elle est mise dans la file d'attente pour recommencer. Si la valeur de Registre est créée manuellement et si le paramètre de cette valeur est configuré de manière incorrecte, Exchange Server peut rencontrer des problèmes de transport des messages.

Il est recommandé de ne créer ou modifier la valeur de Registre MaxConnectionRetries qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour Exchange Server ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements d'Exchange Server. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange Server en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre MaxConnectionRetries existe, vous souhaiterez peut-être la supprimer pour reconfigurer Exchange Server sur le paramètre binaire par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Cliquez sur Démarrer et Exécuter, entrez Regedit, puis cliquez sur OK.

  2. Dans l'arborescence de la console, recherchez, puis cliquez sur la clé de Registre suivante : HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre MaxConnectionRetries. Remplacez la valeur par 20.

  4. Dans le volet Détails, cliquez éventuellement avec le bouton droit sur la valeur de Registre MaxConnectionRetries, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  5. Redémarrez Exchange Server.

Avant de modifier le Registre et pour obtenir des informations sur la modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows. (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valeur de Registre SMTP MaxLdapConnections non définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur MaxLdapConnections par défaut a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Si Exchange Server Analyzer détecte que la valeur de Registre MaxLdapConnections a été créée manuellement pour remplacer le paramètre binaire par défaut du serveur Exchange de 8, il affiche un message d'avertissement indiquant une configuration autre que celle par défaut. Par défaut, la valeur de Registre MaxLdapConnections n'est pas créée par une installation d'Exchange. Toutefois, la valeur de Registre MaxLdapConnections peut être créée manuellement après l'installation d'Exchange pour modifier la valeur. La valeur MaxLdapConnections définit le nombre maximal de connexions LDAP que le catégoriseur ouvre sur un seul serveur de catalogue global. Si la valeur de Registre est créée manuellement et si le paramètre de cette valeur est configuré de manière incorrecte, le serveur Exchange peut rencontrer des problèmes de transport des messages.

Attention :
La valeur de Registre MaxLdapConnections doit toujours correspondre à la valeur de Registre HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads.

Il est recommandé de ne créer ou modifier la valeur de Registre MaxLdapConnections qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour le serveur Exchange ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements de serveur Exchange. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange Server en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre MaxLdapConnections existe, vous souhaiterez peut-être la supprimer pour reconfigurer le serveur Exchange sur le paramètre binaire par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Cliquez sur Démarrer et Exécuter, entrez Regedit, puis cliquez sur OK.

  2. Dans l'arborescence de la console, recherchez, puis cliquez sur la clé de Registre suivante : HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre MaxLdapConnections. Modifiez les données de la valeur en 8.

  4. Dans le volet Détails, cliquez éventuellement avec le bouton droit sur la valeur de Registre MaxLdapConnections, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour obtenir des informations sur la modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows. (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valeur de Registre SMTP MaxPendingSearches non définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur MaxPendingSearches par défaut a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Si Exchange Server Analyzer détecte que la valeur de Registre MaxPendingSearches a été créée manuellement pour remplacer le paramètre binaire par défaut du serveur Exchange de 60, il affiche un message d'avertissement indiquant une configuration autre que celle par défaut. Par défaut, la valeur de Registre MaxPendingSearches n'est pas créée par une installation d'Exchange Server. Toutefois, la valeur de Registre MaxPendingSearches peut être créée manuellement après l'installation d'Exchange Server pour modifier la valeur. La valeur MaxPendingSearches définit le nombre de recherches LDAP mises en attente par le catégoriseur par rapport à un serveur de catalogue global particulier. Le nombre maximal de recherche en attente par connexion était de 1 024 dans Exchange 2000 Server avant SP3. Dans Exchange 2000 Server SP3 et Exchange Server 2003, la valeur par défaut est 60. Par exemple, modifier cette valeur par rapport à la valeur par défaut en la définissant sur 30 réduit le nombre total de recherches LDAP mises en attente par le catégoriseur par rapport au serveur de catalogue global.

Si la valeur de Registre est créée manuellement et si le paramètre de cette valeur est configuré de manière incorrecte, le serveur Exchange peut rencontrer des problèmes de transport des messages.

Il est recommandé de ne créer ou modifier la valeur de Registre MaxPendingSearches qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour le serveur Exchange ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements de serveur Exchange. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre MaxPendingSearches existe, vous souhaiterez peut-être la supprimer pour reconfigurer le serveur Exchange sur le paramètre binaire par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Cliquez sur Démarrer et Exécuter, entrez Regedit, puis cliquez sur OK.

  2. Dans l'arborescence de la console, recherchez, puis cliquez sur la clé de Registre suivante : HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre MaxPendingSearches. Modifiez les données de la valeur en 60.

  4. Dans le volet Détails, cliquez éventuellement avec le bouton droit sur la valeur de Registre MaxPendingSearches, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

•322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

•322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valeur de Registre SMTP MaxSearchBlockSize non définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur MaxSearchBlockSize par défaut a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Si Exchange Server Analyzer détecte que la valeur de Registre MaxSearchBlockSize a été créée manuellement pour remplacer le paramètre binaire par défaut du serveur Exchange de 20, il affiche un message d'avertissement indiquant une configuration autre que celle par défaut. Par défaut, la valeur de Registre MaxSearchBlockSize n'est pas créée par une installation d'Exchange Server. Toutefois, la valeur de Registre MaxSearchBlockSize peut être créée manuellement après l'installation d'Exchange Server pour modifier la valeur. La valeur MhelpsBlockSize définit le nombre maximal de recherches du catégoriseur pouvant être soumises ensemble comme une recherche LDAP unique. En définissant le nombre maximal de recherches du catégoriseur, vous pouvez contribuer à simplifier les filtres de recherche pour le catégoriseur.

Ce processus permet aux recherches en cours d'être de nouveaux appliquées sur les nouvelles connexions. Si la valeur de Registre est créée manuellement et si le paramètre de cette valeur est configuré de manière incorrecte, le serveur Exchange peut rencontrer des problèmes de transport des messages.

Il est recommandé de ne créer ou modifier la valeur de Registre MaxSearchBlockSize qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour Exchange Server ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements de serveur Exchange. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange Server en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre MaxSearchBlockSize existe, vous souhaiterez peut-être la supprimer pour reconfigurer le serveur Exchange sur le paramètre binaire par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Cliquez sur Démarrer et Exécuter, entrez Regedit, puis cliquez sur OK.

  2. Dans l'arborescence de la console, recherchez, puis cliquez sur la clé de Registre suivante : HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre MaxSearchBlockSize. Modifiez les données de la valeur en 20.

  4. Dans le volet Détails, cliquez éventuellement avec le bouton droit sur la valeur de Registre MaxSearchBlockSize, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Valeur de Registre SMTP TopoRecheckSecs non définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la valeur par défaut a été modifiée :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

Si Exchange Server Analyzer détecte que la valeur de TopoRecheckSecs n'est pas égale à la valeur par défaut de 900 secondes, un message indiquant une configuration autre que celle par défaut s'affiche. Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise. Étant donné que DSAccess utilise la valeur de la valeur de Registre TopoRecheckSecs pour définir l'intervalle dans lequel la liste de catalogue global est reconstruite, un paramètre incorrect peut entraîner une diminution des performances. Il est recommandé d'utiliser les paramètres de configuration par défaut pour Exchange Server lorsque c'est possible. Toutefois, si la valeur de Registre est présente, elle peut avoir été ajoutée et configurée sur les conseils des services du Support Technique de Microsoft pour résoudre un problème qui est survenu auparavant. Vous devriez envisager de supprimer cette valeur de Registre sauf si elle a été ajoutée et configurée sur les conseils des services de Support Technique de Microsoft ou d'autres experts.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer la clé de Registre TopoRecheckSecs

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Dans le volet droit, recherchez la valeur TopoRecheckSecs et supprimez-la.

  4. Fermez l'Éditeur du Registre.

  5. Pour appliquer cette modification, redémarrez le service Surveillance du système.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur l'optimisation de l'emplacement du catalogue global pour Exchange Server, voir le document sur la compréhension et le dépannage de l'accès à l'annuaire (http://go.microsoft.com/fwlink/?LinkId=39012).


Serveur de passerelle non-Exchange défini comme hôte actif
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-09

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour la valeur de l'attribut distingushedName de la classe d'objet protocolCfgSMTPServer pour répertorier toutes les instances de serveur virtuel SMTP (Simple Mail Transfer Protocol) sur la passerelle Exchange spécifiée par l'utilisateur.

Exchange Server Analyzer interroge ensuite Active Directory pour la valeur des attributs msExchSourceBridgeheadServersDN et routingList pour chaque objet msExchRoutingSMTPConnector trouvé afin de déterminer si un connecteur SMTP dispose effectivement de l'une des instances de serveur virtuel SMTP détectée définie comme tête de pont locale pour un espace d'adressage SMTP externe.

Enfin, Exchange Server Analyzer interroge Active Directory pour la valeur de l'attribut msExchSmtpSmartHost sur tous les connecteurs SMTP détectés (objet msExchRoutingSMTPConnector) afin de déterminer si l'un d'eux a été désigné comme hôte actif pour le serveur de passerelle non-Exchange spécifié par l'utilisateur.

Si Exchange Server Analyzer détermine que le serveur de passerelle non-Exchange spécifié par l'utilisateur n'est pas configuré comme un hôte actif pour l'un des connecteurs SMTP, il affiche un avertissement.

Cet avertissement indique qu'aucun itinéraire explicite n'est configuré du serveur de passerelle Exchange spécifié par l'utilisateur vers le serveur de passerelle non-Exchange spécifié par l'utilisateur et que les autres serveurs que les passerelles non-Exchange risquent de router involontairement des messages en-dehors de l'organisation.

Pour résoudre ce problème, désignez le serveur de passerelle non-Exchange comme hôte actif pour un connecteur SMTP.

Pour afficher et configurer les paramètres d'hôte actif

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP, par exemple, Serveur virtuel SMTP par défaut et sélectionnez Propriétés.

  4. Sélectionnez l'onglet Remise, puis cliquez sur Avancé.

  5. Entrez l'hôte actif à utiliser. Vous pouvez identifier l'hôte actif par le nom de domaine complet ou une adresse IP. Si vous utilisez une adresse IP, vous devez la placer entre crochets ([ ]). Exchange recherche d'abord un nom de serveur, puis une adresse IP. Les crochets identifient la valeur comme une adresse IP. Par conséquent, la recherche DNS est ignorée.

  6. Si vous utilisez un serveur qui exécute Exchange 2000 Server, activez éventuellement la case à cocher Essayer la remise directe avant l'envoi à l'hôte actif.

  7. Cliquez sur OK pour enregistrer les modifications, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur la procédure de configuration des connecteurs d'hôte actif, voir l'article 821911 de la Base de connaissances Microsoft sur la procédure de configuration d'Exchange Server 2003 pour utiliser une adresse IP d'hôte actif (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911).

Pour plus d'informations sur l'utilisation des connecteurs SMTP, voir l'article 294736 de la Base de connaissances Microsoft sur le moment auquel créer des connecteurs SMTP dans Exchange 2000 et versions ultérieures (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Pour plus d'informations sur les connecteurs SMTP, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Surcharge possible du catégoriseur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Ce moteur collecte des données à partir des compteurs de performance Cat. : messages soumis/s et Cat. : catégorisations terminées/s de l'objet de performance SMTP Server pour analyser les données de performances.

Le compteur de performance Cat. : messages soumis/s indique le nombre de messages soumis par seconde au catégoriseur tandis que Cat. : catégorisations terminées/s indique le nombre de catégorisations terminées par seconde.

Exchange Server Analyzer compare le nombre total moyen des deux compteurs pour déterminer si davantage de messages que ceux traités sont soumis en permanence.

Si Exchange Server Analyzer détermine que le nombre total moyen de messages soumis par seconde au catégoriseur augmente constamment de deux messages par rapport au nombre total moyen de messages terminés par seconde, il affiche un avertissement.

Le catégoriseur effectue les opérations principales suivantes :

  • Il résout et valide tous les destinataires.

  • Il détermine les limites et restrictions pour tous les destinataires.

  • Il développe les listes de distribution si nécessaire.

  • Il détermine si le message est destiné à une remise locale ou à distance.

Cet avertissement indique que le catégoriseur est peut-être soumis à des contraintes. Il convient d'étudier les causes possibles et d'y remédier, le cas échéant.

Les contraintes du catégoriseur peuvent résulter d'une demande de traitement de nombreux messages en raison de :

  • courrier publicitaire non sollicité ou de courrier indésirable ;

  • prolifération de virus ;

  • problèmes de performances du serveur.

Pour supprimer cet avertissement :

  • Déterminez si les contraintes du catégoriseur sont prévues ou générées par une charge habituelle. Si elles sont générées par une charge prévue, passez en revue les instructions relatives aux performances d'Exchange figurant dans les rubriques Microsoft TechNet suivantes.

    • Rubrique sur la résolution des problèmes de performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588).

    • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

  • Si les contraintes du catégoriseur ne proviennent pas d'une charge prévue, recherchez d'éventuels virus ou courriers indésirables susceptibles de générer la charge.


Problème de passerelle possible
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-09

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test à un compte externe défini par l'utilisateur à partir du serveur qui exécute Exchange Server. Exchange Server Analyzer analyse ensuite le journaux de suivi des messages du serveur pour déterminer si des problèmes de remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause de la création d'au moins une entrée dans le journal de suivi des messages.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le journal de suivi des messages a pu être analysé avec succès.

  • Le message de test n'a pas pu être transféré de la file d'attente.

  • Aucun rapport de non-remise n'a été généré.

  • La valeur 1034 existe pour la propriété EntryType.

  • Le message a atteint le serveur de passerelle sortant Exchange local spécifié.

Cette erreur peut indiquer un problème de connexion entre le serveur de passerelle sortant Exchange local spécifié par l'utilisateur et le serveur distant.

Pour résoudre cette erreur, l'utilitaire NSlookup permet de revoir les éventuels problèmes de résolution DNS (Domain Name System). Pour les problèmes de connexion et de protocole tels que les erreurs Hôte inaccessible, Telnet.exe permet d'essayer de vous connecter à l'ordinateur de destination. Pour résoudre des erreurs de protocole, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport pour le composant SMTP (Simple Mail Transfer Protocol) et passez en revue les journaux d'erreurs. Vous pouvez également utiliser l'outil Moniteur réseau (Netmon.exe) pour obtenir des informations sur les erreurs de connexion au réseau.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Problème Inetinfo possible
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool contient un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003. Ce moteur collecte des données à partir du compteur de performance Cat. : catégorisations en cours de l'objet de performance SMTP Server pour analyser les données de performances.

Le compteur de performance Cat. : catégorisations en cours indique le nombre de catégorisations en cours.

Pour cette requête, Exchange Server Analyzer récupère un exemple toutes les 6 secondes pendant une période de deux minutes. Il signale la valeur moyenne du compteur de performance pendant l'intervalle entre deux collectes.

Si Exchange Server Analyzer détermine que le nombre minimal de catégorisations en cours pendant la période d'exemple n'est jamais égal à zéro, il affiche un avertissement.

Le catégoriseur effectue les opérations principales suivantes :

  • Il résout et valide tous les destinataires.

  • Il détermine les limites et restrictions pour tous les destinataires.

  • Il développe les listes de distribution si nécessaire.

  • Il détermine si le message est destiné à une remise locale ou à distance.

Si le serveur n'est pas soumis à une charge importante, cet avertissement peut indiquer que le processus Inetinfo.exe ou les ressources dont il dépend sont bloquées.

Le service SMTP (Simple Mail Transfer Protocol) s'exécute dans le processus Inetinfo.exe et, lorsque des messages passent par le sous-système de transport, SMTP utilise intensivement les ressources IIS (services Internet).

Un blocage se produit lorsque au moins deux processus (ou threads) attendent que l'autre ait terminé avant de pouvoir poursuivre. Le résultat est que tous les processus (ou threads) arrêtent de répondre (se bloquent). Dans un blocage, les processus n'arrêtent jamais leur exécution et les ressources système sont occupées. Cela empêche les autres tâches de démarrer.

Pour supprimer cet avertissement :

  • Déterminez si les contraintes du catégoriseur sont prévues ou générées par une charge habituelle. Si le catégoriseur n'est pas soumis à une charge importante, utilisez les ressources mentionnées dans la section « Pour plus d'informations » pour identifier les éventuels problèmes de performances avec le processus Inetinfo.exe ou les ressources liées.

  • Vérifiez si le processus Inetinfo.exe est en cours d'exécution.

  • Recherchez une situation de blocage du processus Inetinfo.exe en suivant les instructions de débogage de l'article 919791 de la Base de connaissances Microsoft sur l'utilisation de l'outil Debug Diagnostics Tool pour résoudre les problèmes d'utilisation intensive du processeur par un processus dans IIS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Pour plus d'informations

Pour plus d'informations sur Inetinfo.exe, voir la rubrique sur les services Internet dans le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=72966).

Pour plus d'informations sur la procédure de résolution du blocage d'un processus, voir l'article 919791 de la Base de connaissances Microsoft sur l'utilisation de l'outil Debug Diagnostics Tool pour résoudre les problèmes d'utilisation intensive du processeur par un processus dans IIS (http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791).

Pour plus d'informations sur les performances d'Exchange Server, voir le Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576).

Pour plus d'informations sur la procédure de résolution des problèmes de performances d'Exchange Server, voir le document sur la résolution des problèmes de performances de Microsoft Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47588).


Problème possible non lié à la passerelle
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-09

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test à une adresse SMTP de destinataire externe définie par l'utilisateur à partir du serveur qui exécute Exchange Server. Exchange Server Analyzer analyse ensuite le journaux de suivi des messages du serveur pour déterminer si des problèmes de remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause de la création d'au moins une entrée dans le journal de suivi des messages.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le journal de suivi des messages a pu être analysé avec succès.

  • Le message de test n'a pas pu être transféré de la file d'attente.

  • Aucun rapport de non-remise n'a été généré.

  • La valeur 1034 existe pour la propriété EntryType.

  • Le message n'a pas atteint le serveur de passerelle sortant Exchange local spécifié.

Cette erreur peut indiquer que le message de test se trouve toujours dans l'une des files d'attente SMTP (Simple Mail Transfer Protocol) Remise distante du serveur d'envoi et qu'il existe un problème avec la file d'attente.

Une file d'attente Remise distante contient des messages destinés à une remise distante. Le nom de la file d'attente correspond à la destination de remise distante. Cette destination peut être un connecteur, un serveur ou un domaine.

Pour résoudre des erreurs de protocole, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport pour le composant SMTP et passez en revue les journaux d'erreurs. Vous pouvez également utiliser l'outil Moniteur réseau (Netmon.exe) pour obtenir des informations sur les erreurs de connexion au réseau. Pour reproduire le problème, vous devez obliger la file d'attente à réessayer. Vérifiez si le journal d'événements contient des erreurs possibles associées au service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Proxy SMTP possible détecté
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-12-06

L'outil Microsoft® Exchange Server Analyzer Tool tente d'envoyer un message vers le compte administrateur ou un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol).

La réponse par défaut suivante est normale si Exchange Server Analyzer ouvre une connexion de socket sur le serveur SMTP.

« 220 Computer Name . Domain Name .com Microsoft ESMTP MAIL Service, Version: Version Number ready at Date Time +0000 »

Si Exchange Server Analyzer reçoit une réponse autre que celle par défaut contenant une chaîne tierce spécifique, il affiche une erreur.

Cette erreur indique qu'un serveur proxy SMTP tiers est peut-être en cours d'exécution derrière le serveur distant.

Si la bannière SMTP par défaut n'a pas été intentionnellement personnalisée par l'administrateur Exchange Server, cet avertissement peut indiquer qu'Exchange Server se trouve derrière un proxy SMTP qui filtre les commandes ESMTP (Extended Simple Mail Transfer Protocol) d'Exchange Server.

Un filtrage des commandes ESMTP d'Exchange Server peut avoir un impact significatif sur les performances d'Exchange et risque de produire le comportement décrit dans l'article 320027 de la Base de connaissances Microsoft sur l'impossibilité d'envoyer ou de recevoir des messages électroniques derrière un pare-feu Cisco PIX (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027).

Pour plus d'informations sur les bannières SMTP personnalisées, consultez l'article suivant de la Base de connaissances Microsoft :

  • 281224: XCON : procédure de modification de la bannière SMTP (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224)


Problème potentiel de performances du catégoriseur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour la valeur de l'attribut TypePendingCategorization de l'instance ProtocolName du protocole SMTP (Simple Mail Transfer Protocol) pour déterminer le nombre de messages dans la file d'attente SMTP Messages en attente d'une recherche dans l'annuaire.

Les propriétés de la classe WMI ExchangeLink renvoient des informations sur les liens de gestion des messages (files d'attente) entre les serveurs de messagerie. Un lien peut contenir zéro ou plus d'objets ExchangeQueue. Ce nombre dépend du trafic actuel des messages sur le lien.

Exchange Server Analyzer contient également un moteur de collecte des données de performances permettant d'interroger des objets de compteur de performance des ordinateurs qui exécutent Exchange 2000 Server ou Exchange Server 2003.

Si Exchange Server Analyzer détermine que plus de cinquante messages se trouvent actuellement dans la file d'attente Messages en attente d'une recherche dans l'annuaire, il demande au moteur de collecte de rassembler les données des compteurs de performance Cat. : messages catégorisés et Cat. : catégorisations terminées de l'objet de performance SMTP Server pour analyser les données de performances.

Le compteur de performance Cat. : messages catégorisés indique le nombre de messages que le catégoriseur a envoyés pour mise en file d'attente tandis que le compteur de performance Cat. : catégorisations terminées indique le nombre total de messages envoyés au catégoriseur qui ont été terminés.

Le catégoriseur effectue les opérations principales suivantes :

  • Il résout et valide tous les destinataires.

  • Il détermine les limites et restrictions pour tous les destinataires.

  • Il développe les listes de distribution si nécessaire.

  • Il détermine si le message est destiné à une remise locale ou à distance.

Exchange Server Analyzer examine le nombre total moyen des deux compteurs pour déterminer si les chiffres augmentent pendant la période d'exemple.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies.

  • Au moins cinquante messages se trouvent dans la file d'attente Messages en attente d'une recherche dans l'annuaire.

  • Le compteur de performance Cat. : messages catégorisés montre une augmentation pendant la période d'exemple qui indique l'avancement du passage des messages envoyés au processus suivant.

  • Le compteur de performance Cat. : catégorisations terminées montre une augmentation pendant la période d'exemple qui indique l'avancement du succès de la catégorisation des messages envoyés.

Cette erreur indique que, malgré le succès du traitement des messages par le catégoriseur, la longueur de sa file d'attente reste élevée et que les performances risquent d'être altérées.

Les performances du catégoriseur peuvent être affectées par une demande de traitement de nombreux messages en raison de :

  • courrier publicitaire non sollicité ou de courrier indésirable ;

  • prolifération de virus ;

  • problèmes de performances du serveur.

Pour supprimer cet avertissement :

  • Déterminez si les contraintes du catégoriseur sont prévues ou générées par une charge habituelle. Si elles sont générées par une charge prévue, passez en revue les instructions relatives aux performances d'Exchange figurant dans les ressources Exchange suivantes :

    • Rubrique sur la résolution des problèmes de performances d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47588)

    • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)

  • Si les contraintes du catégoriseur ne proviennent pas d'une charge prévue, recherchez d'éventuels virus ou courriers indésirables susceptibles de générer la charge.


Problèmes d'extension de groupe de distribution potentiels détectés
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le serveur Exchange exécute Exchange Server 2003 Service Pack 2 (SP2) et est configuré pour développer les groupes de distribution lorsqu'il vérifie les restrictions de remise de messages :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • La valeur 1 pour cette entrée signifie que le serveur est configuré pour développer les groupes de distribution lorsqu'il vérifie les restrictions de remise de messages.

  • La valeur 2 pour cette entrée indique que le serveur est configuré pour ne pas développer les groupes de distribution lorsqu'il vérifie les restrictions de remise de messages.

Si Exchange Server Analyzer détecte que le serveur est paramétré pour développer les groupes de distribution lorsqu'il vérifie les restrictions de remise de messages, il vérifie ensuite les journaux d'événements du serveur pour voir si les événements d'erreur 6004, 6006 et 6008 se sont produits au cours des dernières 24 heures.

Ces événements indiquent que des messages sont en cours de blocage dans le catégoriseur de messages. Le catégoriseur de messages est un composant du moteur avancé de files d'attente qui envoie des requêtes LDAP (Lightweight Directory Access Protocol) au serveur de catalogue global pour effectuer directement des recherches.

Enfin, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer :

  • Si plus de 500 boîtes aux lettres existent dans la forêt, pour lesquelles des restrictions de remise de messages sont définies de manière à ce qu'au moins un groupe de distribution permette d'autoriser ou de bloquer les expéditeurs.

  • Si un connecteur de groupe de routage possède des restrictions de remise de messages sur la base de l'appartenance au groupe de distribution et si la vérification des restrictions de connecteur du serveur Bridgehead est activée.

  • Si la restriction de remise de messages d'un connecteur SMTP est définie sur la base de l'appartenance à des groupes de distribution et si la vérification des restrictions de connecteur du serveur Bridgehead est activée.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le serveur Exchange Server 2003 SP2 est configuré pour développer les groupes de distribution lorsqu'il vérifie les restrictions de remise de messages.

  • Le serveur Exchange a enregistré les événements 6004, 6006 et 6008 au cours des dernières 24 heures.

  • Plus de 500 boîtes aux lettres de la forêt présentent des restrictions de remise de messages définies de manière à ce qu'au moins un groupe de distribution permette d'autoriser ou de bloquer des expéditeurs ; ou un connecteur de groupe de routage possède des restrictions de remise de messages sur la base de l'appartenance au groupe de distribution et la vérification des restrictions de connecteur du serveur Bridgehead est activée ; ou la restriction de remise de messages d'un connecteur SMTP est définie sur la base de l'appartenance à des groupes de distribution et la vérification des restrictions de connecteur du serveur Bridgehead est activée.

La valeur RestrictionMethod détermine la manière dont le catégoriseur va appliquer les restrictions. Le comportement par défaut du catégoriseur consiste à développer de manière récurrente les groupes de distribution et à vérifier les restrictions pour chaque message qui passe par le système. Lorsqu'un message électronique est envoyé à un destinataire configuré pour permettre une restriction qui rejette les messages des membres d'un groupe de distribution spécifique ou d'un groupe de sécurité, Exchange Server doit développer ce groupe pour s'assurer que l'expéditeur n'est pas un membre d'un groupe restreint. Les résultats de ce développement ne sont pas mis en cache par Exchange Server et doivent être effectués à chaque fois. Par conséquent, les messages doivent être maintenus dans les files d'attente de catégoriseur et peuvent ralentir le traitement des messages.

Si vous définissez la valeur de RestrictionMethod sur 2, les composants de transport de ce serveur Exchange ne développeront pas les groupes de distribution lorsque le serveur vérifie les restrictions. Cette configuration fournit les meilleures performances au niveau du contrôle des restrictions. En outre, pour que l'entrée de Registre RestrictionMethod soit appliquée, tous les groupes de distribution qui incluent des utilisateurs soumis à des restrictions de remise de messages doivent être bidimensionnels. Cela signifie que les groupes de distribution restreints ne doivent présenter aucun groupe de distribution imbriqué. La logique d'expansion ne fonctionne pas si des groupes de distribution restreints sont imbriqués.

Pour les groupes de distribution utilisés dans des restrictions de connecteur, il est recommandé de définir la valeur de l'entrée de Registre RestrictionMethod sur un serveur Bridgehead de connecteur qui ne possède aucune boîte aux lettres. Pour les restrictions utilisateur Active Directory, si les groupes de distribution restreints possèdent des serveurs d'expansion, nous recommandons de créer l'entrée de Registre RestrictionMethod sur les serveurs d'expansion.

Pour plus d'informations sur ce qu'il se passe lorsque les restrictions de remise de messages sont configurées, voir l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

Pour plus d'informations sur la valeur de Registre RestrictionMethod, voir l'article 895407 de la Base de connaissances Microsoft sur la remise des messages aux boîtes aux lettres locales et externes qui est plus lente que prévu dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

Pour plus d'informations sur les événements et les erreurs d'Exchange Server 2003, voir le centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).

Pour plus d'informations sur les restrictions de connecteur, voir l'article 277872 de la Base de connaissances Microsoft sur les restrictions de remise de connecteur, qui risquent de ne pas fonctionner correctement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).

Pour plus d'informations sur les files d'attente SMTP, voir l'article 884996 de la Base de connaissances Microsoft sur les messages qui restent dans la file d'attente SMTP « Messages en attente d'une recherche dans l'annuaire » dans Exchange Server 2003 ou Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996).


Problèmes potentiels de destinataire de journalisation du message détectés
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si l'une des combinaisons Avertissement du catégoriseur/Événement d'erreur s'est produite pour le catégoriseur au cours des dernières 24 heures :

  • Événement 9004 et Événement 9003

  • Événement 9035 et Événement 6004

Ces événements indiquent que des messages sont en cours de blocage dans le catégoriseur de messages. Le catégoriseur de messages est un composant du moteur avancé de files d'attente qui envoie des requêtes LDAP (Lightweight Directory Access Protocol) au serveur de catalogue global pour effectuer directement des recherches.

  • Exchange Server Analyzer interroge également le service d'annuaire Active Directory® pour déterminer si une ou plusieurs des conditions suivantes sont également vraies :

  • Le destinataire de journalisation spécifié pour une banque pointe vers un objet supprimé.

  • Le destinataire de journalisation spécifié pour une banque pointe vers un objet ne possédant un attribut mailNickname valide.

  • Le destinataire de journalisation spécifié pour une banque pointe vers un compte désactivé.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • L'une des combinaisons Avertissement du catégoriseur/Événement d'erreur indiquées précédemment s'est produite.

  • L'une des conditions de destinataire de journalisation spécifiée est également vraie.

Cette erreur indique qu'il existe un problème de journalisation potentiel dans l'environnement Exchange, qui peut entraîner une mise en file d'attente des messages.

Pour plus d'informations sur la procédure de résolution de ce problème, voir l'article sur Exchange Server Analyzer relatif à votre problème :

  • Le destinataire de la journalisation pointe vers un objet supprimé

  • Destinataire de la journalisation non valide

  • Le destinataire de la journalisation pointe vers un compte désactivé

  • Pour plus d'informations sur les événements et les erreurs d'Exchange Server 2003, voir le centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).


Problèmes potentiels de journalisation des messages ou du service de banque d'informations détectés
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si l'événement d'avertissement du catégoriseur 9004 s'est produit au cours des dernières 24 heures.

Exchange Server Analyzer interroge également la classe WMI Win32_Service pour déterminer si le service de banque d'informations de Microsoft Exchange (MSExchangeIS) a été démarré ou arrêté. Toute autre valeur que Started pour l'instance MSExchangeIS signifie que le service MSExchangeIS est arrêté.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le serveur a enregistré un événement d'avertissement du catégoriseur 9003 au cours des dernières 24 heures.

  • Le service MSExchangeIS est arrêté.

Cette erreur indique qu'un problème de journalisation des messages ou du service de banque d'informations de Microsoft Exchange (Store.exe) s'est produit et risque de provoquer le placement de messages dans la file d'attente.

Ce problème peut se produire si l'une des conditions suivantes est vraie :

  • L'objet destinataire de la journalisation a été supprimé du service d'annuaire Active Directory®.

  • Le service de banque d'informations n'est pas en cours d'exécution ou a été désactivé sur l'ordinateur Exchange Server qui est le serveur Bridgehead SMTP.

  • Au moins une banque de boîtes aux lettres du serveur Bridgehead SMTP a été démontée.

Pour résoudre ce problème :

  • Assurez-vous que le service de banque d'informations du serveur Bridgehead SMTP est activé et en cours d'exécution. Assurez-vous que les banques de boîtes aux lettres du serveur Bridgehead SMTP sont montées.

  • Assurez-vous que l'objet destinataire de la journalisation pour les banques de boîtes aux lettres a été supprimé d'Active Directory.

Pour déterminer le destinataire de la journalisation pour une banque de boîtes aux lettres

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Serveurs, <votre_serveur_Exchange>, <groupe_stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres et sélectionnez Propriétés.

  3. Sous l'onglet Général, identifiez le compte qui s'affiche immédiatement sous la case à cocher Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque. Il s'agit du compte utilisé comme destinataire de la journalisation.

    Remarque :
    Assurez-vous de vérifiez le destinataire de la journalisation pour chaque objet de banque de boîtes aux lettres.
Pour désigner une nouvelle boîte aux lettres d'utilisateur comme destinataire de la journalisation

  1. Démarrez le Gestionnaire système Exchange.

  2. Développez Serveurs, <votre_serveur_Exchange>, <groupe_stockage>, puis cliquez avec le bouton droit sur la banque de boîtes aux lettres et sélectionnez Propriétés.

  3. Sous l'onglet Général, cliquez sur Parcourir à droite du texte Archiver tous les messages envoyés ou reçus par les boîtes aux lettres de cette banque pour spécifier une boîte aux lettres comme boîte aux lettres de journalisation.

    Remarque :
    Tous les messages journalisés pour les expéditeurs de cette banque de boîtes aux lettres sont envoyés à la boîte aux lettres spécifiée.

Pour plus d'informations sur ce problème voir la rubrique Le destinataire de la journalisation pointe vers un objet supprimé.

Pour plus d'informations sur les événements et les erreurs d'Exchange Server 2003, voir le centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).

Pour plus d'informations sur la procédure de déploiement d'une solution de journalisation, voir la rubrique sur la journalisation à l'aide d'Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47581).


Problèmes potentiels d'autorisations détectés
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si les événements d'erreur d'Exchange Server suivants se sont produits au cours des dernières 24 heures :

  • Événement 929.

  • Événement 9035.

  • Une combinaison des événements 9003, 9004 et 6004.

L'événement d'erreur d'Exchange Server 929 peut se produire en raison d'autorisations d'accès incorrectes sur les objets Exchange Server dans le service d'annuaire Active Directory®.

Les événements d'erreur d'Exchange Server 9003, 9004 et 6004 indiquent que les messages sont en cours de blocage dans le catégoriseur de messages. Le catégoriseur de messages est un composant du moteur avancé de files d'attente qui envoie des requêtes LDAP (Lightweight Directory Access Protocol) au serveur de catalogue global pour effectuer directement des recherches.

Exchange Server Analyzer interroge également Active Directory pour déterminer si les attributs des objets liés à Exchange indiquent des problèmes d'héritage des autorisations pour ces objets.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • L'un des événements ou l'une des combinaisons d'événements suivante a été enregistrée au cours des dernières 24 heures sur un serveur ayant des messages dans la file d'attente Messages en attente d'une recherche dans l'annuaire.

    • Événement 929.

    • Événement 9035.

    • La combinaison des événements 9003, 9004 et 6004.

  • Des objets liés à Exchange présentent des autorisations d'accès manquantes ou incorrectes.

Cette erreur signifie que des problèmes d'héritage des autorisations existent dans l'environnement Exchange, pouvant provoquer le placement de messages dans la file d'attente.

Pour résoudre ce problème, effectuez la procédure décrite dans l'article 907969 de la Base de connaissances Microsoft sur l'enregistrement de l'ID événement 929 et la non-remise des messages d'un serveur de messagerie vers un autre serveur d'une organisation Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969).

Pour plus d'informations sur les événements et les erreurs d'Exchange Server 2003, voir le centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).


Dossier public identifié comme destination commune
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-04

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Queue pour déterminer les valeurs des attributs suivants pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur le serveur virtuel SMTP.

LinkId | Indique l'identificateur du lien contenant la file d'attente.
QueueId | Indique l'identificateur de la file d'attente.
QueueName | Indique le nom de la file d'attente.
VirtualMachine | Indique le nom de la machine virtuelle contenant la file d'attente.
VirtualServerName | Indique le nom du serveur virtuel contenant la file d'attente.
MessageCount | Indique le nombre de messages dans la file d'attente.

Exchange Server Analyzer utilise les informations obtenues ci-avant pour interroger la classe WMI Exchange_QueuedSMTPMessage afin d'obtenir les valeurs des attributs suivants des messages figurant dans la file d'attente :

Recipients | Indique les destinataires du message.
Received | Indique l'horodatage reçu pour le message.
MessageId | Indique l'identificateur du message en file d'attente.
StateRetry | Indique qu'une nouvelle tentative de transmission a lieu pour un message qui n'a pas été remis avec succès.

Enfin, Exchange Server Analyzer utilise les données obtenues ici pour interroger le service d'annuaire Active Directory® pour déterminer la valeur distinguishedName de chaque objet Recipient. Exchange Server Analyzer détermine ensuite si le destinataire est un utilisateur, un groupe de distribution, un dossier public ou une banque de dossiers publics.

Si Exchange Server Analyzer détermine qu'au moins 25 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à un dossier public spécifique, Exchange Server Analyzer affiche un message d'avertissement.

Si Exchange Server Analyzer détermine qu'au moins 50 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à un dossier public spécifique, Exchange Server Analyzer affiche un message d'erreur.

Ce message d'avertissement ou d'erreur signifie que le dossier public identifié est une destination commune des messages bloqués dans une file d'attente SMTP.

Pour résoudre ce problème, il convient de vérifier s'il y a des problèmes de configuration ou d'autres anomalies en relation avec le dossier public, qui pourraient être à l'origine de la mise en file d'attente des messages :

  • Assurez-vous que les attributs de l'objet dossier public sont correctement définis et contiennent les valeurs correctes dans Active Directory.

  • Vérifiez que les autorisations Active Directory de l'objet dossier public sont correctement paramétrées.

  • Recherchez la présence éventuelle de publicités commerciales non sollicitées (UCE) ou de courrier indésirable, ou d'attaques de virus dirigées contre le dossier public.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


Identification de la banque de dossiers publics comme destination commune
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-04

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Queue pour déterminer les valeurs des attributs suivants pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur le serveur virtuel SMTP.

LinkId | Indique l'identificateur du lien contenant la file d'attente.
QueueId | Indique l'identificateur de la file d'attente.
QueueName | Indique le nom de la file d'attente.
VirtualMachine | Indique le nom de la machine virtuelle contenant la file d'attente.
VirtualServerName | Indique le nom du serveur virtuel contenant la file d'attente.
MessageCount | Indique le nombre de messages dans la file d'attente.

Exchange Server Analyzer utilise les informations obtenues ci-avant pour interroger la classe WMI Exchange_QueuedSMTPMessage afin d'obtenir les valeurs des attributs suivants des messages figurant dans la file d'attente :

Recipients | Indique les destinataires du message.
Received | Indique l'horodatage reçu pour le message.
MessageId | Indique l'identificateur du message en file d'attente.
StateRetry | Indique qu'une nouvelle tentative de transmission a lieu pour un message qui n'a pas été remis avec succès.

Enfin, Exchange Server Analyzer utilise les données obtenues ici pour interroger le service d'annuaire Active Directory® pour déterminer la valeur distinguishedName de chaque objet Recipient. Exchange Server Analyzer détermine ensuite si le destinataire est un utilisateur, un groupe de distribution, un dossier public ou une banque de dossiers publics.

Si Exchange Server Analyzer détermine qu'au moins 25 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à des destinataires dont les boîtes aux lettres sont hébergées dans la même banque de dossiers publics, Exchange Server Analyzer affiche un message d'avertissement.

Si Exchange Server Analyzer détermine qu'au moins 50 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à des destinataires dont les boîtes aux lettres sont hébergées dans la même banque de dossiers publics, Exchange Server Analyzer affiche un message d'erreur.

Ce message d'avertissement ou d'erreur signifie que la banque de dossiers publics identifiée est une destination commune des messages bloqués dans une file d'attente SMTP.

Pour résoudre ce problème, il convient de vérifier s'il y a des problèmes de configuration, des bourrasques de réplication ou d'autres anomalies en relation avec la banque de dossiers publics, qui pourraient être à l'origine de la mise en file d'attente des messages :

  • Assurez-vous que les attributs de l'objet banque sont correctement définis et contiennent les valeurs correctes dans Active Directory.

  • Vérifiez que les autorisations Active Directory de l'objet banque sont correctement paramétrées.

  • Recherchez la présence éventuelle de publicités commerciales non sollicitées (UCE) ou de courrier indésirable, ou d'attaques de virus dirigées contre le dossier public.

  • Vérifiez s'il y a des modifications dans la hiérarchie de dossiers publics ou le contenu susceptibles de générer de nombreuses réplications entre les banques de dossiers publics.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Article 842273 de la Base de connaissances Microsoft, sur la procédure de résolution des problèmes de réplication des dossiers publics dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273).


Filtrage des destinataires activé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la propriété msExchServerBindingsFiltering d'un objet de serveur virtuel SMTP (Simple Mail Transfer Protocol) indique que le filtrage des destinataires est activé pour une instance de serveur virtuel SMTP.

L'outil Exchange Server Analyzer Tool interroge également Active Directory pour déterminer si les propriétés msExchRecipTurfListNames ou msExchRecipTurfListOptions indiquent que le filtrage des destinataires est également activé au niveau des paramètres globaux.

Si l'outil Exchange Server Analyzer Tool détecte que le filtrage des destinataires est activé au niveau de l'instance de serveur virtuel SMTP et des paramètres globaux, Exchange Server Analyzer affiche un avertissement.

Cet avertissement indique que le filtrage des destinataires est effectivement activé. Le filtrage des destinataires n'est généralement pas un problème. Toutefois, si vous résolvez des problèmes de flux de messages concernant ce serveur spécifique, vous pouvez vérifier la configuration du filtre ou désactiver temporairement le filtrage des destinataires pour déterminer s'il bloque de manière incorrecte le courrier de destinataires valides.

Pour désactiver un filtre des destinataires sur un serveur virtuel SMTP

  1. Démarrez le Gestionnaire système Exchange : Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans l'arborescence de la console, développez Serveurs, le serveur souhaité, puis Protocoles et enfin SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP sur lequel vous souhaitez désactiver le filtre, puis cliquez sur Propriétés.

  4. Dans Propriétés de <SMTP Virtual Server>, sous l'onglet Général, cliquez sur Options avancées.

  5. Dans Options avancées, sélectionnez l'adresse IP pour laquelle vous souhaitez désactiver le filtre, puis cliquez sur Modifier.

Dans Identification, désactivez la case à cocher Appliquer le filtre destinataire pour désactiver le filtre.

  1. Si vous possédez plusieurs serveurs virtuels, répétez les étapes 3 à 6 pour chaque serveur sur lequel le filtre doit être désactivé.

Pour plus d'informations sur la procédure de configuration des filtres des destinataires, voir l'article 823866 de la Base de connaissances Microsoft sur la procédure de configuration du filtrage des connexions à l'aide de listes noires en temps réel (RBL, Realtime Block List) et du filtrage des destinataires dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866).

Pour plus d'informations sur le filtrage de messages intelligent, voir le site Web sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


La file d'attente « Remise distante » est figée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateFrozen pour la file d'attente SMTP (Simple Mail Transfer Protocol) Remise distante.

Si Exchange Server Analyzer détecte que la valeur de la clé StateFrozen pour la file d'attente Remise distante d'un serveur Exchange est définie sur True, il affiche une erreur.

Une file d'attente figée signifie l'arrêt des sessions de transport pour cette file d'attente. Une file d'attente figée empêche les messages de sortir, bien que de nouveaux messages puissent être ajoutés. Vous pouvez modifier manuellement l'état d'une connexion à l'aide du menu contextuel dans chaque file d'attente de liens. Si vous utilisez la commande Forcer la connexion pour modifier l'état d'une file d'attente en Actif, vous activez immédiatement une connexion qui envoie les messages de cette file d'attente.

La file d'attente Remise distante contient des messages destinés à une remise distante. Le nom de la file d'attente correspond à la destination de remise distante. Cette destination peut être un connecteur, un serveur ou un domaine.

Pour résoudre cette erreur, l'utilitaire NSlookup permet de revoir les éventuels problèmes de résolution DNS (Domain Name System). Pour les problèmes de connexion et de protocole tels que les erreurs Hôte inaccessible, Telnet.exe permet d'essayer de vous connecter à l'ordinateur de destination. Pour résoudre des erreurs de protocole, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport pour le composant de protocole SMTP et passez en revue les journaux d'erreurs. Vous pouvez également utiliser l'outil Moniteur réseau (Netmon.exe) pour obtenir des informations sur les erreurs de connexion au réseau. Pour reproduire le problème, vous devez obliger la file d'attente à réessayer. Vérifiez si le journal d'événements contient des erreurs possibles associées au service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


La file d'attente « Remise distante » présente l'état Réessayer
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink afin de déterminer la valeur de la clé StateRetry pour la file d'attente SMTP (Simple Mail Transfer Protocol) Remise distante.

Si Exchange Server Analyzer détecte que la valeur de la clé StateRetry pour la file d'attente Remise distante d'un serveur Exchange est définie sur True, il affiche une erreur.

Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente. Vous pouvez modifier les files d'attente présentant l'état Réessayer ou Planifiée en Actif à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

La file d'attente Remise distante contient des messages destinés à une remise distante. Le nom de la file d'attente correspond à la destination de remise distante. Cette destination peut être un connecteur, un serveur ou un domaine.

Pour résoudre cette erreur, l'utilitaire NSlookup permet de revoir les éventuels problèmes de résolution DNS (Domain Name System). Pour les problèmes de connexion et de protocole tels que les erreurs Hôte inaccessible, Telnet.exe permet d'essayer de vous connecter à l'ordinateur de destination. Pour résoudre des erreurs de protocole, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport pour le composant de protocole SMTP et passez en revue les journaux d'erreurs. Vous pouvez également utiliser l'outil Moniteur réseau (Netmon.exe) pour obtenir des informations sur les erreurs de connexion au réseau. Pour reproduire le problème, vous devez obliger la file d'attente à réessayer. Vérifiez si le journal d'événements contient des erreurs possibles associées au service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Problème de la file d'attente « Remise distante »
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause des entrées dans le journal de suivi des messages à créer.

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le journal de suivi des messages a pu être analysé avec succès.

  • Le message de test n'a pas pu être transféré de la file d'attente.

  • Aucun rapport de non-remise n'a été généré.

  • La valeur 1034 existe pour la propriété EntryType.

Cette erreur indique que le message de test se trouve toujours dans l'une des files d'attente SMTP Remise distante du serveur d'envoi et qu'il existe un problème avec la file d'attente.

Une file d'attente Remise distante contient des messages destinés à une remise distante. Le nom de la file d'attente correspond à la destination de remise distante. Cette destination peut être un connecteur, un serveur ou un domaine.

Pour résoudre cette erreur, l'utilitaire NSlookup permet de revoir les éventuels problèmes de résolution DNS (Domain Name System). Pour les problèmes de connexion et de protocole tels que les erreurs Hôte inaccessible, Telnet.exe permet d'essayer de vous connecter à l'ordinateur de destination. Pour résoudre des erreurs de protocole, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport pour le composant de protocole SMTP et passez en revue les journaux d'erreurs. Vous pouvez également utiliser l'outil Moniteur réseau (Netmon.exe) pour obtenir des informations sur les erreurs de connexion au réseau. Pour reproduire le problème, vous devez obliger la file d'attente à réessayer. Vérifiez si le journal d'événements contient des erreurs possibles associées au service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Nouvelle tentative de catégorisation
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause de l'entrée dans le journal de suivi des messages.

Si Exchange Server Analyzer détecte la valeur 1 032 pour la propriété EntryType, il affiche un avertissement.

Cet avertissement indique que le message de test se trouve dans une file d'attente prévue pour une nouvelle tentative de catégorisation. Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente. Vous pouvez modifier les files d'attente présentant l'état Réessayer ou Planifiée en Actif à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

En règle générale, les messages s'accumulent dans les files d'attente en attendant une nouvelle tentative car le moteur avancé de files d'attente n'est pas en mesure de catégoriser le message. Le moteur avancé de files d'attente risque de ne pas pouvoir accéder aux serveurs de catalogue global ni aux informations sur le destinataire ou les serveurs de catalogue global ne sont pas accessibles ou fonctionnent lentement. En outre, les messages peuvent s'accumuler pour les raisons suivantes :

  • Active Directory n'est pas disponible.

    Remarque :
    Le catégoriseur utilise Active Directory pour catégoriser des messages.
  • Active Directory subit peut-être une charge trop importante si de nombreux messages se trouvent dans la file d'attente avant catégorisation.

  • Un échec de conversion s'est produit. Le catégoriseur traite également les conversions de contenu.

  • Le catégoriseur de messages ne peut pas trouver les banques de boîtes aux lettres.

  • En cas de réinstallation ou de suppression de SMTP, les clés de la métabase IIS suivantes risquent d'être invalidées : /smtpsvc/DsUseCat and /smtpsvc/vsi#/DsUseCat.

    Remarque :
    Déterminez si SMTP a été réinstallé ou supprimé.

Si une file d'attente comporte l'état « Réessayer », vérifiez ses propriétés afin de déterminer l'origine du problème. Par exemple, si les propriétés de la file d'attente affichent un message du type « Une erreur SMTP s'est produite », consultez les journaux des événements de votre serveur afin d'identifier les erreurs SMTP éventuelles. Si le journal ne contient pas d'événements, augmentez le niveau d'enregistrement du protocole SMTP.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft surla présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Nouvelle tentative de remise locale
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-04

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause de l'entrée dans le journal de suivi des messages.

Si Exchange Server Analyzer détecte la valeur 1037 pour la propriété EntryType, il affiche un avertissement.

Cet avertissement indique qu'au moins une erreur s'est produite lors des précédentes tentatives de traitement du message dans la file d'attente Remise locale.

La file d'attente Remise locale contient les messages qui sont mis en file d'attente sur le serveur Exchange, à des fins de remise locale vers une boîte aux lettres ou une banque de dossiers publics Exchange Server.

Les messages peuvent s'accumuler dans cette file d'attente si le serveur Exchange n'accepte pas les messages pour la remise locale. Une remise ralentie ou intermittente des messages peut indiquer une boucle de message ou un problème de performances.

Vous pouvez modifier les files d'attente dont l'état est Réessayer ou Planifiée, afin de les passer à l'état Actif, grâce à la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

Pour résoudre ce problème, augmentez le niveau d'enregistrement des diagnostics pour les composants du pilote de banque SMTP des services MSExchangeIS et MSExchangeTransport.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft surla présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Nouvelle tentative de routage
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, l'outil Exchange Server Analyzer Tool interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause de l'entrée dans le journal de suivi des messages.

Si Exchange Server Analyzer détecte la valeur 1035 pour la propriété EntryType, il affiche un avertissement.

Cet avertissement indique que le message de test se trouve dans une file d'attente prévue pour une nouvelle tentative de routage. Si une file d'attente présente l'état Réessayer, cela indique qu'au moins une erreur s'est produite dans les tentatives précédentes de traitement des messages de la file d'attente. Vous pouvez modifier les files d'attente présentant l'état Réessayer ou Planifiée en Actif à l'aide de la commande Forcer la connexion. Celle-ci entraîne le fonctionnement de la file d'attente comme si l'intervalle entre deux tentatives s'était écoulé ou le temps prévu était atteint. Toutefois, cette méthode risque de ne pas toujours fonctionner.

Remarque :
Les propriétés d'une file d'attente peuvent indiquer une raison spécifique à l'état Réessayer d'une file d'attente.

Les messages s'accumulent dans les files dans l'attente d'une nouvelle tentative en cas de problème de routage Exchange Server. Les messages n'ont pas été routés en raison d'une erreur temporaire, c'est-à-dire de l'échec d'initialisation du moteur de routage. Les messages se trouvent dans la file de pré-routage dans l'attente d'une nouvelle tentative ou sont en cours de reroutage.

Pour résoudre cette erreur, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport afin de collecter des informations sur le composant de la catégorie de routage. Désactivez toute restriction de connecteur inutile car les restrictions peuvent considérablement altérer les performances du serveur. Il se peut que vous deviez activer la clé de Registre CheckConnectorRestrictions pour certaines restrictions.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Les recherches DNS inversées ont été activées dans la métabase, mais pas sur le serveur SMTP associé dans Active Directory
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété suivante dans la métabase IIS (Internet Information Services) pour déterminer si sa valeur correspond à la valeur configurée de l'attribut msExchSmtpPerformReverseDnsLookup dans le service d'annuaire Active Directory® :

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

Si Exchange Server Analyzer détecte que les valeurs ne correspondent pas, un message d'avertissement s'affiche.

Si la valeur dans la métabase IIS ne correspond pas à la valeur dans Active Directory, il peut s'agir d'un problème de réplication d'Active Directory ou du composant de réplication Directory-service-to-Metabase (DS2MB) dans Exchange.

Le processus DS2MB permet de transférer les informations de configuration d'Active Directory vers la métabase locale. Cette configuration est stockée dans la métabase locale au lieu du Registre pour des raisons de performance et d'évolutivité. Tous les protocoles Internet (SMTP, NNTP, POP3, IMAP4 et HTTP) s'exécutent en tant que composants IIS dans Exchange 2000 Server et Exchange Server 2003.

Toutes les 15 minutes, le processus DS2MB copie des sous-arborescences entières d'Active Directory sans changer leur forme. Il s'agit d'une écriture monodirectionnelle d'Active Directory vers la métabase ; la métabase n'écrit jamais dans Active Directory.

La propriété EnableReverseDnsLookup et l'attribut msExchSmtpPerformReverseDnsLookup peuvent tous les deux avoir une valeur TRUE ou FALSE. Une valeur TRUE signifie que le serveur virtuel SMTP effectuera des recherches DNS inversées sur tous les messages entrants. Une valeur FALSE signifie qu'il n'effectuera pas de recherches DNS inversées. À cause d'éventuelles dégradations des performances en raison d'enregistrements DNS mal configurés ou de connexions à Internet intermittentes, la propriété EnableReverseDnsLookup et l'attribut msExchSmtpPerformReverseDnsLookup sont définis par défaut sur FALSE.

Si la propriété EnableReverseDnsLookup est définie sur TRUE et que l'attribut msExchSmtpPerformReverseDnsLookup est défini sur FALSE, cela signifie qu'Active Directory et la métabase IIS ne sont pas synchronisés. Si le problème est dû à un échec du processus DS2MB, vous pouvez le corriger en suivant la procédure ci-dessous pour la version d'Exchange Server que vous exécutez. Si le problème est dû à un échec de réplication partiel ou complet d'Active Directory, vous pouvez utiliser l'utilitaire du moniteur de réplication d'Active Directory (ReplMon.exe) pour vérifier le bon fonctionnement et l'état de réplication d'Active Directory. Vous pouvez trouver Replmon.exe dans les outils de support de Windows® sur le CD-ROM de Windows Server.

Correction de cette erreur dans Exchange Server 2003

  1. Recherchez la présence d'entrées de journal des événements Applications avec une source de MSExchangeMU. Si le processus DS2MB échoue, il consignera un événement dans Exchange Server 2003.

  2. Si tous les échecs du processus DS2MB n'apparaissent pas, utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  3. Redémarrez le service Surveillance du système Exchange si vous constatez des échecs du processus DS2MB ou après avoir corrigé tous les problèmes de réplication d'Active Directory.

Correction de cette erreur dans Exchange 2000 Server

  1. Utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  2. Redémarrez le service Surveillance du système Exchange après avoir supprimé ou résolu tous les problèmes de réplication d'Active Directory.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, consultez l'article 297412 de la Base de connaissances Microsoft sur l'option Exécuter une recherche DNS inversée sur les messages entrants qui correspond à une résolution de nom d'hôte (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, consultez les articles 266686 et 268163 de la Base de connaissances Microsoft sur la procédure de configuration d'un serveur virtuel SMTP, première (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) et deuxième partie (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Pour plus d'informations sur la réplication d'Active Directory, consultez l'article 232072 de la Base de connaissances Microsoft sur le lancement de la réplication entre des partenaires de réplication directe dans Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Pour plus d'informations sur le processus DS2MB, consultez l'article 240105 de la Base de connaissances Microsoft sur les informations générales sur le processus DS2MB (Directory Service/Metabase Synchronization) dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Moteur de routage : Le paramètre AttachedTimeout n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la logique de routage du connecteur SMTP (Simple Mail Transfer Protocol) a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

Si Exchange Server Analyzer détecte que la clé de Registre AttachedTimeout est présente et configurée avec une valeur supérieure à 300, un message indiquant une configuration autre que celle par défaut s'affiche.

L'entrée de Registre AttachedTimeout est un paramètre de configuration personnalisée pour Exchange Server qui détermine la fréquence à laquelle le paquet ORG_INFO est envoyé. Chaque fois que le client de routage ne se connecte pas à un serveur de routage, la version utilisateur de la topologie est incrémentée et entraîne la diffusion du paquet ORG_INFO dans l'ensemble de l'organisation.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Supprimez la clé de Registre AttachedTimeout.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre AttachedTimeout, voir l'article 832281 de la Base de connaissances sur les problèmes de l'état des liens et de routage dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281).


Moteur de routage : Le paramètre BestAddressMatchOnly n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la logique de routage du connecteur SMTP (Simple Mail Transfer Protocol) a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

Si Exchange Server Analyzer détecte que la clé de Registre BestAddressMatchOnly est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

L'entrée de Registre BestAddressMatchOnly est un paramètre de configuration personnalisé pour Exchange Server qui oblige le courrier envoyé à un domaine en particulier à passer par un connecteur spécifique, quelles que soient les restrictions existantes.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Supprimez la clé de Registre BestAddressMatchOnly.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Moteur de routage : le paramètre CheckConnectorRestrictions n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la logique de routage du connecteur SMTP (Simple Mail Transfer Protocol) a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

Si Exchange Server Analyzer détecte que la clé de Registre CheckConnectorRestrictions est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

L'entrée de Registre CheckConnectorRestrictions est un paramètre de configuration personnalisée pour Exchange Server qui active la vérification des restrictions sur le serveur tête de pont Exchange, source du connecteur contrôlé. Par défaut, la vérification des restrictions du connecteur est désactivée car elle peut affecter considérablement les performances, notamment dans les configurations qui utilisent plusieurs groupes de distribution. Les restrictions sont vérifiées pour chaque message envoyé à chaque membre de chaque groupe de distribution qui transite par le système. Si les restrictions sont spécifiées mais que cette entrée de Registre n'existe pas, la vérification des restrictions n'est pas effectuée.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Supprimez la clé de Registre CheckConnectorRestrictions.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service d'administration IIS.

  6. Sous l'onglet Restrictions de remise, réactivez l'option de restriction.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre CheckConnectorRestrictions, voir l'article 277872 de la Base de connaissances sur les restrictions de remise de connecteur, qui risquent de ne pas fonctionner correctement (http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872).


Moteur de routage : paramètre de configuration non défini par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si l'intervalle de lecture du service d'annuaire Active Directory® pour le paramétrage du moteur de routage Exchange a été modifié par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

Si Exchange Server Analyzer détecte que les données de valeur de ReloadOsInterval sont définies sur une valeur différente de 3600, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur ReloadOsInterval permet de spécifier l'intervalle de mise à jour des informations d'état des liens de routage entre des serveurs qui exécutent Exchange. Exchange utilise les informations d'état des liens de routage pour que chaque serveur puisse déterminer l'itinéraire le moins onéreux pour remettre un message. Il détermine également si les connecteurs qui constituent l'itinéraire fonctionnent. Par défaut, les serveurs Exchange lisent les informations d'état des liens à partir d'Active Directory toutes les 3 600 secondes, c'est-à-dire toutes les heures.

Dans certains cas, les informations d'état de routage peuvent ne pas être diffusées correctement et dynamiquement parmi les serveurs d'une organisation Exchange. Certains serveurs de l'organisation continuent de fonctionner avec d'anciennes informations d'état de routage susceptibles d'être incorrectes. Par conséquent, cette situation peut inclure de nouveaux connecteurs qui n'apparaissent pas lorsque vous affichez un groupe de routage distant à l'aide de l'outil WinRoute (Winroute.exe). Cet outil WinRoute permet de vérifier que les informations d'état des liens sont diffusées. Pour vérifier cette diffusion, utilisez l'outil WinRoute pour afficher les informations d'état des liens à partir d'emplacements différents de l'organisation Exchange, puis comparez les numéros de version de chaque groupe de routage. L'outil WinRoute se connecte au port d'état des liens d'un ordinateur Exchange Server et extrait les informations d'état des liens pour l'organisation Exchange. Bien que les informations d'état des liens constituent une série de GUID, WinRoute fait correspondre les GUID de connecteurs et de serveurs têtes de pont aux objets d'Active Directory et présente les informations dans un format lisible.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters

  3. Dans le volet droit, double-cliquez sur ReloadOsInterval.

  4. Dans la zone Données de la valeur, entrez 3 600, puis cliquez sur OK.

  5. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le routage et les informations d'état des liens, voir les articles suivants de la Base de connaissances :

  • 842026 sur les informations d'état de routage qui ne sont pas diffusées correctement sur tous les serveurs Exchange 2000 Server ou Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026)

  • 285130 sur les informations d'état des liens (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130)

Pour télécharger WinRoute, un outil qui vous aide à déterminer les informations d'état des liens connues par le maître de routage, voir l'article sur Exchange Server WinRoute (http://go.microsoft.com/fwlink/?LinkId=25049).


Moteur de routage : Le paramètre PollingInterval n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la logique de routage du connecteur SMTP (Simple Mail Transfer Protocol) a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

Si Exchange Server Analyzer détecte que la clé de Registre PollingInterval est présente et configurée avec une valeur supérieure à 300, un message indiquant une configuration autre que celle par défaut s'affiche.

L'entrée de Registre PollingInterval est un paramètre de configuration personnalisé pour Exchange Server qui contribue au contrôle de la fréquence du trafic d'état des liens parmi les groupes de routage, en particulier vers et à partir du maître de groupe de routage au sein d'un groupe de routage. L'augmentation de la valeur de ce paramètre empêche l'échec des connexions, mais peut également vous empêcher de résoudre le problème plus important de lenteur des liens entre les membres d'un groupe de routage.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Supprimez la clé de Registre PollingInterval.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Moteur de routage : Le paramètre StateChangeDelay n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la logique de routage du connecteur SMTP (Simple Mail Transfer Protocol) a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

Si Exchange Server Analyzer détecte que la clé de Registre StateChangeDelay est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

L'entrée de Registre StateChangeDelay est un paramètre de configuration par défaut pour Exchange Server qui aide à contrôler l'intervalle pendant lequel les connecteurs sont indisponibles et les notifications qui apparaissent à cause du changement d'état du connecteur et du serveur. Si StateChangeDelay est défini sur une valeur supérieure à 0, un serveur peut uniquement apparaître comme disponible ou indisponible à chaque période définie par cette valeur.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Supprimez la clé de Registre StateChangeDelay.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Moteur de routage : le paramètre SuppressStateChanges n'est pas défini par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la logique de routage du connecteur SMTP (Simple Mail Transfer Protocol) a été modifiée par rapport à sa valeur par défaut :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

Si Exchange Server Analyzer détecte que la clé de Registre SuppressStateChanges est présente et configurée avec une valeur supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Exchange Server 2003 comprend la fonctionnalité de détection automatique des modifications apportées à l'état d'un lien. Ces informations permettent de signaler à d'autres serveurs exécutant Exchange Server 2003 qu'un itinéraire alternatif doit être utilisé à la place de l'itinéraire principal dont le coût est le plus faible. Les informations d'état des liens sont divisées en modifications majeures et mineures. Une modification est majeure lorsque l'administrateur modifie la topologie de routage, par exemple lorsqu'il ajoute un nouveau connecteur ou modifie un coût. Des mises à jour mineures sont effectuées lorsque le système détecte automatiquement la défaillance ou la restauration d'un lien.

Cette fonction est utilisée dans les petites et moyennes organisations. Toutefois, dans des environnements multi-sites importants, la fluctuation du réseau de masse peut provoquer des flux de mises à jour des liens pour la version mineure. Pour être vraiment efficaces, les données d'état des liens doivent être diffusées sur tous les serveurs de l'organisation. En outre, lorsque l'état change, la totalité du tableau d'état des liens est rediffusée, ce qui peut engendrer un nombre considérable de données à transmettre sur le réseau. Dans ce cas, il peut être utile de supprimer les modifications mineures d'état des liens. L'entrée de Registre SuppressStateChanges est un paramètre de configuration personnalisée qui permet de supprimer les modifications mineures d'état des liens. Lorsque SuppressStateChanges est défini sur une valeur supérieure à 0, toutes les modifications d'état des liens apportées à cet ordinateur Exchange Server sont supprimées.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Supprimez la clé de Registre SuppressStateChanges.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le service SMTP (Simple Mail Transfer Protocol), le moteur de routage Microsoft Exchange et les piles MTA Microsoft Exchange pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la clé de Registre SuppressStateChanges, voir les guides Microsoft suivants :

  • Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Guide des performances et de l'évolutivité d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47576)


Connecteur de groupe de routage avec définition de restrictions de remise de messages pour le groupe de distribution
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet de connecteur de groupe de routage (msExchRoutingGroupConnector) détecté dans le service d'annuaire Active Directory® pour déterminer si des restrictions de remise sont définies pour eux sur la base de l'appartenance au groupe de distribution.

dLMemRejectPerms | Contient les noms de domaine des listes de distribution dont les membres ne peuvent pas effectuer d'envois via ce connecteur de groupe de routage.
dLMemSubmitPerms | Contient les noms de domaine des listes de distribution dont les membres peuvent effectuer des envois via ce connecteur de groupe de routage.

Si Exchange Server Analyzer détermine que des restrictions de remise sont définies pour des connecteurs de groupe de routage sur la base de l'appartenance au groupe de distribution, il affiche un avertissement.

Cet avertissement indique que des restrictions de remise sur la base de l'appartenance au groupe de distribution peuvent affecter les performances de flux de messages d'Exchange.

Lorsque vous envoyez du courrier à l'aide de connecteurs de groupe de routage pour lesquels des restrictions de remise sont définies sur la base de l'appartenance au groupe de distribution, le catégoriseur de messages doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas de correspondance d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

Pour supprimer cet avertissement :

  • Désignez un groupe de routage dédié pour les restrictions de connecteur et configurez-le dans un groupe de routage local comme indiqué dans l'article 329171 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Utilisez un serveur de catalogue global dédié et plus robuste comme serveur tête de pont désigné pour le connecteur.

  • Configurez les boîtes aux lettres individuelles et pas les groupes de distribution pour les restrictions de remise comme décrit dans l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Envisagez la mise en œuvre du filtrage des expéditeurs SMTP (Simple Mail Transfer Protocol).

  • Pour les serveurs qui exécutent Exchange Server 2003 Service Pack 2 (SP2) ou version ultérieure, envisagez la mise en œuvre de la vérification des restrictions non hiérarchiques. Pour les serveurs qui exécutent des versions d'Exchange antérieures à Exchange 2003 SP2, envisagez la mise à niveau vers Exchange 2003 SP2.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur le filtrage des expéditeurs SMTP, voir la section sur la procédure d'activation du filtrage des expéditeurs dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=72967).

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 329171 sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Le maître de groupe de routage a été supprimé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchRoutingMasterDN pour chaque conteneur de groupe de routage. Si Exchange Server Analyzer détecte que la valeur de l'attribut msExchRoutingMasterDN contient la chaîne « DEL: », une erreur s'affiche.

L'attribut msExchRoutingMasterDN est un attribut de nom unique qui stocke le nom unique de l'ordinateur Exchange Server servant de maître de groupe de routage pour chaque groupe de routage. La présence de la chaîne « DEL: » pourrait indiquer que le maître de groupe de routage précédent a été supprimé à l'aide de l'outil Utilisateurs et ordinateurs Active Directory. Sans le maître de groupe de routage, Exchange ne parviendra pas à gérer ou mettre à jour correctement la topologie de routage.

Lorsque vous créez un groupe de routage, le premier serveur du groupe se voit attribuer le rôle de maître de groupe de routage. Le maître de groupe de routage conserve les informations d'état des liens actuels pour son groupe de routage et les diffuse aux autres serveurs au sein du groupe. Le maître de groupe de routage contrôle la configuration de routage écrite pour son groupe de routage dans Active Directory. Les serveurs membres peuvent communiquer toute information de disponibilité du serveur ou d'état du connecteur au maître de groupe de routage. Par exemple, si un serveur membre tente de contacter un autre serveur d'un groupe de routage différent via un connecteur et si ce lien n'est pas disponible, le serveur membre avertit immédiatement le maître de groupe de routage. De même, lorsqu'un serveur non-maître reçoit de nouvelles informations d'état des liens, il transfère immédiatement les informations d'état du connecteur au maître de groupe de routage pour que d'autres serveurs puissent recevoir les informations sur la modification de routage.

Pour corriger cette erreur

  1. Dans le Gestionnaire système Exchange, sous Groupes d'administration, développez Groupe_administration, puis Groupes de routage.

  2. Développez le groupe de routage, puis cliquez sur Membres.

  3. Dans le volet droit, cliquez avec le bouton droit sur l'ordinateur Exchange que vous souhaitez configurer comme maître de groupe de routage et cliquez sur Définir un maître.

Pour plus d'informations sur les maîtres de groupe de routage, voir le chapitre sur la configuration d'une topologie de routage dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47579).


Erreur d'appartenance au groupe de routage
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour chaque valeur de l'attribut msExchRoutingGroupMembersBL des objets Routing Group pour déterminer si le serveur avec lien ascendant appartient au groupe d'administration dédié de Microsoft Exchange Server 2007, Groupe d'administration Exchange (FYDIBOHF23SPDLT).

Exchange Server Analyzer interroge également la valeur de l'attribut CN pour l'objet Routing Group afin de déterminer si la valeur est égale au groupe de routage Exchange 2007 par défaut, Groupe de routage Exchange (DWBGZMFD01QNBJR).

Exchange Server Analyzer affiche une erreur si les conditions suivantes sont vraies :

  • Le serveur avec lien ascendant appartient au groupe d'administration dédié d'Exchange 2007, Groupe d'administration Exchange (FYDIBOHF23SPDLT).

  • Le groupe de routage n'est pas le groupe de routage Exchange 2007 par défaut, Groupe de routage Exchange (DWBGZMFD01QNBJR).

Cette erreur indique que le serveur a peut-être été déplacé manuellement à partir du groupe de routage Exchange 2007 par défaut. Cela peut provoquer des problèmes de routage.

Microsoft Exchange Server 2003 et Microsoft Exchange 2000 Server utilisent des groupes de routage pour définir une topologie de routage spécifique à Exchange. Exchange 2007 utilise les sites Active Directory pour définir sa topologie de routage. Exchange 2003 et Exchange 2000 utilisent une topologie de routage basée sur les groupes de routage et les connecteurs. Une configuration de routage spécifique à Exchange n'est plus nécessaire dans une organisation Exchange 2007 pure. Une organisation Exchange 2007 pure utilise la topologie de sites Active Directory pour déterminer sa topologie de routage.

Pour prendre en charge la coexistence de ces deux topologies de routage, tous les serveurs Exchange 2007 sont automatiquement ajoutés à un seul groupe de routage lors de l'installation d'Exchange 2007. Le groupe de routage Exchange 2007 est reconnu dans le Gestionnaire système Exchange dans Exchange 2003 ou Exchange 2000 sous forme d'un Groupe de routage Exchange (DWBGZMFD01QNBJR) dans un Groupe d'administration Exchange (FYDIBOHF23SPDLT).

Pour résoudre ce problème, déplacez les serveurs Exchange 2007 vers le groupe de routage Exchange 2007 dédié ou supprimez, puis réinstallez le serveur.


Connecteur d'envoi désactivé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-07-30

L'outil Microsoft Exchange Analyzer Tool utilise la cmdlet Exchange Management Shell suivante pour interroger tous les connecteurs d'envoi de l'environnement Exchange dont l'attribut Enabled est défini sur False. La valeur False pour l'attribut Enabled du connecteur d'envoi indique que celui-ci est désactivé.

Get-SendConnector | where { $_.Enabled -eq $False}

Exchange Analyzer interroge ensuite le service d'annuaire Active Directory pour déterminer la valeur de l'attribut serialNumber pour tous les objets ayant une classe d'objet msExchExchangeServer.

Si la valeur de chaîne contient Version 5.5, l'ordinateur exécute Microsoft Exchange Server 5.5. Si la valeur de chaîne contient Version 6.0, l'ordinateur exécute Exchange 2000 Server. Si la valeur de chaîne contient Version 6.5, l'ordinateur exécute Exchange Server 2003. Si la valeur de chaîne contient Version 8, l'ordinateur exécute Exchange Server 2007.

Si Exchange Analyzer détermine qu'un connecteur d'envoi est désactivé dans un environnement Exchange qui comprend également des serveurs Exchange 2000 ou Exchange 2003, il affiche une erreur.

Cette erreur indique que le routage Exchange 2007 ignore les connecteurs d'envoi désactivés, mais qu'Exchange 2000 et Exchange 2003 ne reconnaissent pas l'indicateur de désactivation du connecteur et risquent quand même de tenter de router les messages par le connecteur, ce qui provoquerait des boucles de routage.

Pour résoudre cette erreur, supprimez tous les connecteurs désactivés des environnements Exchange qui utilisent Exchange 2000 ou Exchange 2003.

Pour supprimer un connecteur d'envoi désactivé, suivez les instructions d'utilisation de la cmdlet Remove-SendConnector d'Exchange Management Shell figurant dans la rubrique correspondante (http://go.microsoft.com/fwlink/?LinkId=96007) dans la documentation sur le produit Exchange Server 2007.


Filtrage des expéditeurs activé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la propriété msExchServerBindingsTurflist d'un objet de serveur virtuel SMTP (Simple Mail Transfer Protocol) indique que le filtrage des expéditeurs est activé pour une instance de serveur virtuel SMTP.

Exchange Server Analyzer interroge également Active Directory pour déterminer si les propriétés msExchTurfListNames ou msExchTurfListOptions indiquent que le filtrage des expéditeurs est également activé au niveau des paramètres globaux.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Le filtrage des expéditeurs est activé sur l'instance de serveur virtuel SMTP.

  • Le filtrage des expéditeurs est activé au niveau des paramètres globaux.

Cet avertissement indique que le filtrage des expéditeurs est effectivement activé. Le filtrage des expéditeurs n'est généralement pas un problème excepté si vous résolvez des problèmes de flux de messages concernant ce serveur particulier. Dans ce cas, vous pouvez vérifier la configuration du filtre ou désactiver temporairement le filtrage des expéditeurs pour déterminer s'il bloque de manière incorrecte le courrier d'expéditeurs valides.

Pour désactiver un filtre des expéditeurs sur un serveur virtuel SMTP

  1. Démarrez le Gestionnaire système Exchange : Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans l'arborescence de la console, développez Serveurs, le serveur souhaité, puis Protocoles et enfin SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP sur lequel vous souhaitez désactiver le filtre, puis cliquez sur Propriétés.

  4. Dans les Propriétés du <Serveur virtuel SMTP>, sous l'onglet Général, cliquez sur Options avancées.

  5. Dans Options avancées, sélectionnez l'adresse IP pour laquelle vous souhaitez désactiver le filtre, puis cliquez sur Modifier.

  6. Dans Identification, désactivez la case à cocher Appliquer le filtre expéditeur pour désactiver le filtre.

  7. Si vous possédez plusieurs serveurs virtuels, répétez les étapes 3 à 6 pour chaque serveur sur lequel le filtre doit être désactivé.

Pour plus d'informations sur le filtrage de messages intelligent, voir le site Web sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).

Pour plus d'informations sur la procédure de configuration du filtrage et le contrôle du courrier indésirable, voir la section sur la configuration du filtrage et le contrôle du courrier indésirable dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Filtrage des ID expéditeur activé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la propriété msExchServerBindingsFiltering d'un objet de serveur virtuel SMTP (Simple Mail Transfer Protocol) indique que le filtrage des ID expéditeur est activé pour une instance de serveur virtuel SMTP.

Exchange Server Analyzer interroge également Active Directory pour déterminer si l'attribut wWWHomePage de l'objet Filtre de contenu publicitaire contient des entrées pour le filtrage des ID expéditeur et des connexions.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Le filtrage des expéditeurs est activé sur l'instance de serveur virtuel SMTP.

  • Le filtrage des expéditeurs est activé au niveau de l'objet Filtre de contenu publicitaire.

Cet avertissement indique que le filtrage des ID expéditeur est effectivement activé. Le filtrage des ID expéditeur n'est généralement pas un problème excepté si vous résolvez des problèmes de flux de messages impliquant ce serveur particulier. Dans ce cas, vous pouvez vérifier la configuration du filtre ou désactiver temporairement le filtrage des ID expéditeur pour déterminer s'il bloque de manière incorrecte le courrier d'expéditeurs valides.

Pour désactiver un filtre des ID expéditeur sur un serveur virtuel SMTP

  1. Démarrez le Gestionnaire système Exchange : Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans l'arborescence de la console, développez Serveurs, le serveur souhaité, puis Protocoles et enfin SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP sur lequel vous souhaitez désactiver le filtre, puis cliquez sur Propriétés.

  4. Dans les Propriétés du <Serveur virtuel SMTP>, sous l'onglet Général, cliquez sur Options avancées.

  5. Dans Options avancées, sélectionnez l'adresse IP pour laquelle vous souhaitez désactiver le filtre, puis cliquez sur Modifier.

  6. Dans Identification, désactivez la case à cocher Appliquer le filtre expéditeur pour désactiver le filtre.

  7. Si vous possédez plusieurs serveurs virtuels, répétez les étapes 3 à 6 pour chaque serveur sur lequel le filtre doit être désactivé.

Pour plus d'informations sur le filtrage de messages intelligent, voir le site Web sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Identification du serveur comme destination commune
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-04

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Queue pour déterminer les valeurs des attributs suivants pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur le serveur virtuel SMTP.

LinkId | Indique l'identificateur du lien contenant la file d'attente.
QueueId | Indique l'identificateur de la file d'attente.
QueueName | Indique le nom de la file d'attente.
VirtualMachine | Indique le nom de la machine virtuelle contenant la file d'attente.
VirtualServerName | Indique le nom du serveur virtuel contenant la file d'attente.
MessageCount | Indique le nombre de messages dans la file d'attente.

Exchange Server Analyzer utilise les informations obtenues ci-avant pour interroger la classe WMI Exchange_QueuedSMTPMessage afin d'obtenir les valeurs des attributs suivants des messages figurant dans la file d'attente :

Recipients | Indique les destinataires du message.
Received | Indique l'horodatage reçu pour le message.
MessageId | Indique l'identificateur du message en file d'attente.
StateRetry | Indique qu'une nouvelle tentative de transmission a lieu pour un message qui n'a pas été remis avec succès.

Enfin, Exchange Server Analyzer utilise les données obtenues ici pour interroger le service d'annuaire Active Directory® pour déterminer les valeurs suivantes de chaque objet Destinataire. Exchange Server Analyzer détermine ensuite si le destinataire est un utilisateur, un groupe de distribution, un dossier public ou une banque de dossiers publics :

distinguishedName | Indique le nom unique de l'objet.
msExchHomeServerName | Indique le serveur sur lequel le destinataire est hébergé.
homeMDB | Indique la banque de boîtes aux lettes du destinataire.

Si Exchange Server Analyzer détermine qu'au moins 25 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à des destinataires hébergés sur un serveur particulier, Exchange Server Analyzer affiche un message d'avertissement.

Si Exchange Server Analyzer détermine qu'au moins 50 % des messages bloqués dans la file d'attente sont adressés, dans le champ To: ou Cc:, à des destinataires hébergés sur un serveur particulier, Exchange Server Analyzer affiche un message d'erreur.

Ce message d'avertissement ou d'erreur signifie que le serveur identifié est une destination commune des messages bloqués dans une file d'attente SMTP.

Pour résoudre ce problème, il convient de vérifier s'il y a des problèmes de configuration ou d'autres anomalies en relation avec le serveur, qui pourraient être à l'origine de la mise en file d'attente des messages :

  • Assurez-vous que les attributs de l'objet serveur sont correctement définis et contiennent les valeurs correctes dans Active Directory.

  • Vérifiez que les autorisations Active Directory de l'objet serveur sont correctement paramétrées.

  • Si le serveur est le serveur associé pour un objet utilisateur destiné à usage particulier, à savoir un destinataire de la journalisation désigné, examinez les configurations du service ou des composants auxquels l'objet utilisateur est associé pour vérifier si la configuration est correcte.

  • Recherchez la présence éventuelle de publicités commerciales non sollicitées (UCE) ou de courrier indésirable, ou d'attaques de virus dirigées contre le dossier public.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 329171 sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Inscription de récepteur introuvable
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-01-11

L'outil Microsoft® Exchange Server Analyzer Tool interroge la métabase IIS (Internet Information Server) Microsoft pour énumérer la liste des liaisons des récepteurs d'événements de transport SMTP (Simple Mail Transport Protocol). Exchange Server Analyzer essaie de rechercher un nombre de liaisons d'événements standard sur la base d'une liste préremplie dans Exchange Server Analyzer. Pour chaque liaison, Exchange Server Analyzer vérifie les détails d'enregistrement COM (Component Object Model) dans le Registre sous la branche suivante :

HKEY_CLASSES_ROOT\CLSID\

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Une liaison de récepteur d'événements de transport est détectée dans la métabase.

  • L'enregistrement COM correspondant est manquant dans le registre.

Un événement de transport SMTP survient lorsque des données de messages sont transportées vers l'intérieur ou l'extérieur d'un service SMTP. Tous les messages passent par des événements, notamment les messages X.400 et RPC entrants ou sortants. Un exemple commun d'un événement de transport entrant est l'arrivée d'un message dans le service SMTP via le réseau ou dans le répertoire de collecte SMTP. Lorsque cet événement de transport survient, une source de cet événement notifie les récepteurs d'événements de transport, dont chacun peut réaliser un type d'action sur la base du contenu des données du message. Le système n'effectue aucune autre action avec les données du message après les avoir transmises au récepteur jusqu'à ce que ce dernier termine l'action et renvoie le message. Le récepteur détient le contrôle exclusif des données du message et de son état lorsqu'il effectue cette action.

Les enregistrements COM manquants pour les liaisons de récepteur d'événements de transport peuvent provoquer des problèmes de flux de messages. Si Exchange Server présente des symptômes de problèmes de flux de messages, tels que des files d'attente de messages, réenregistrez les récepteurs d'événements de transport.

Pour réenregistrer les récepteurs d'événements de transport

  1. À partir de Microsoft Exchange Server, ouvrez une fenêtre d'invite de commandes et accédez au dossier \Program Files\Exchsrvr\Bin.

  2. Tapez les commandes suivantes pour réenregistrer les récepteurs d'événements de transport :

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Réexécutez Exchange Server Analyzer pour vérifier que les avertissements ne s'affichent plus. Si des avertissements d'enregistrement de récepteur d'événements continuent de s'afficher et si vous rencontrez des problèmes de flux de messages, contactez les services du Support Technique de Microsoft.

Pour plus d'informations sur les liaisons de récepteurs d'événements de transport, voir les ressources Exchange suivantes :

  • Article 258224 de la Base de connaissances Microsoft sur l'énumération des récepteurs d'événements de transport enregistrés (http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224)

  • Rubrique sur la conception du service SMTP du Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876)


L'hôte actif est défini sur un serveur virtuel SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut msExchSmtpSmartHost a été configuré sur un serveur virtuel SMTP spécifique. Si Exchange Server Analyzer détecte que l'attribut msExchSmtpSmartHost est configuré, il affiche un avertissement.

Il n'est pas recommandé de configurer un hôte actif sur un serveur virtuel SMTP. Vous devez plutôt créer un connecteur SMTP et y configurer les paramètres de l'hôte actif.

Dans Exchange Server 2003, utilisez l'Assistant Messagerie Internet pour configurer la remise de courrier via Internet. Pour plus d'informations, dans le Guide de transport et de routage Exchange Server 2003, voir la rubrique sur l'utilisation de l'Assistant Messagerie Internet (http://go.microsoft.com/fwlink/?LinkId=50099).

Pour plus d'informations sur la création de connecteurs SMTP, dans le Guide de transport et de routage Exchange Server 2003, voir la rubrique sur la création d'un connecteur SMTP (http://go.microsoft.com/fwlink/?LinkId=50100).


La valeur de Registre SMTP AdditionalPoolThreadsPerProc a été définie manuellement
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si des threads de pool supplémentaires ont été configurées manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

Si Exchange Server Analyzer détecte que la valeur AdditionalPoolThreadsPerProc est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Cinq files d'attente de travail dans SMTP utilisent un pool de threads appelé thread ATQ. Par défaut, deux de ces files d'attente sont conçues pour utiliser au maximum 90 pour cent des threads disponibles. Ce pool de threads est partagé par le processus qui accepte les requêtes POP et IMAP. Par conséquent, dans un scénario de chargement modéré à élevé, la situation, dans laquelle SMTP peut conserver des ressources des services POP et IMAP, peut se présenter.

Vous pouvez réserver des threads adéquates pour POP et IMAP en limitant le pourcentage de threads que SMTP peut utiliser. Pour effectuer cette modification, augmentez le nombre global de threads à la disposition des services IIS. Dans ce cas, le seul compromis consiste à utiliser la mémoire augmentée pour les threads supplémentaires.

Deux valeurs de Registre permettent de contrôler le pourcentage SMTP de threads et les threads supplémentaires par processeur :

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Valeur : AdditionalPoolThreadsPerProc

Type : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Valeur : MaxPercentPoolThreads

Type : REG_DWORD

Ces deux valeurs de Registre doivent être ajustées sur les ordinateurs Exchange Server en clusters si une importante activité SMTP entraîne l'échec de POP3, IMAP4 ou des deux ressources. Les formules suivantes permettent de calculer la valeur optimale pour votre cluster :

Valeur de Registre | Formule
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * nombre de serveurs virtuels de protocole)

Par exemple, dans un cluster Exchange Server avec deux serveurs virtuels de protocole, la formule pour MaxPercentPoolThreads est 90 / (2*2) = 22 : Lors du calcul de la valeur MaxPercentPoolThreads, si vous obtenez une valeur comprenant une virgule, vous devez arrondir le résultat au nombre entier inférieur. Lors du calcul de la valeur AdditionalPoolThreadsPerProc, si vous obtenez une valeur supérieure à 200, vous devez également affecter la valeur résultante à une valeur de Registre supplémentaire :

Emplacement : HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Valeur : PoolThreadLimit

Type : REG_DWORD

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Configuration du paramètre optimal sur votre cluster Exchange

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Créez une valeur de Registre DWORD appelée AdditionalPoolThreadsPerProc et définissez ses données de valeur sur le nombre approprié en fonction des formules ci-dessus.

  4. Créez une valeur de Registre DWORD appelée MaxPercentPoolThreads et définissez ses données de valeur sur le nombre approprié en fonction des formules ci-dessus.

  5. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le problème spécifique de ressource de cluster décrit dans cet article, consultez l'article 281868 de la Base de connaissances Microsoft sur les serveurs virtuels POP\IMAP4 qui basculent à plusieurs reprises en cas de charge élevée (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868).


Récepteur d'archivage SMTP : Archivage des ensembles d'en-têtes P1
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le récepteur d'archivage SMTP a été installé et activé :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

Si Exchange Server Analyzer détecte que la valeur définie pour Dump P1 est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Une valeur de 0 indique que l'archivage des en-têtes P1 est désactivé. Une valeur de 1 indique que l'archivage des en-têtes P1 est activé. Des valeurs autres que 0 ou 1 ne sont pas prises en charge.

L'outil Archive Sink SMTP est un script personnalisé qui permet l'archivage de tous les messages entrant et sortant d'un dossier spécifique sur un serveur Exchange. Par défaut, si le récepteur d'archivage SMTP est activé, tous les messages et leurs destinataires sont archivés dans un fichier .eml, sauf les destinataires en copie conforme invisible.

Les en-têtes P1 sont également appelés « données de l'enveloppe ». Les données de l'enveloppe correspondent à la liste de destinataires réels qu'Exchange génère lorsqu'un message est en transit et permet de toucher tous les destinataires. Contrairement aux en-têtes P2, qui représentent les destinataires tels que déclarés par l'expéditeur dans un courrier reçu, les données de l'enveloppe varient car elles ont plusieurs destinations. Ces changements apparaissent avec l'extension de la liste de distribution et le comportement des listes de distribution masquées.

Par défaut, les en-têtes P1 ne sont pas archivées lorsque vous installez et activez le récepteur d'archivage SMTP. Généralement, l'archivage des en-têtes P1 n'est activé qu'à des fins de dépannage.

Si vous ne souhaitez pas archiver les en-têtes P1 sur cet ordinateur Exchange, vous pouvez définir la clé de Registre Dump P1 sur 0 ou désinstaller le récepteur d'archivage SMTP. Si vous désinstallez le récepteur d'archivage SMTP, toutes les clés de Registre utilisées par le récepteur d'archivage SMTP sont supprimées.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour désactiver l'archivage des en-têtes P1

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Double-cliquez sur la clé de Registre Dump P1, dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  4. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que les modifications soient prises en compte.

Pour désinstaller le récepteur d'archivage SMTP

  1. Cliquez sur Démarrer, sur Exécuter, entrez cmd, puis cliquez sur OK.

  2. Dans le dossier C:\Program Files\Exchsrvr\bin, entrez cscript archivesink_setup.vbs, puis appuyez sur Entrée.

  3. Entrez cscript archivesink_setup.vbs uninstall Virtual Server ID, là où Virtual Server ID est le numéro de serveur virtuel sur lequel le récepteur d'archivage SMTP est installé.

  4. Fermez la fenêtre d'invite de commandes et redémarrez le service d'administration IIS pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange Server 2003, voir l'article 871110 de la Base de connaissances sur la procédure d'installation et l'utilisation de l'outil Archive Sink dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange 2000 Server, voir l'article 307798 de la Base de connaissances sur la disponibilité de l'outil Archive Sink dans Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Pour plus d'informations sur le déploiement d'une solution de journalisation complète à des fins de conformité, voir le document sur la journalisation avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Récepteur d'archivage SMTP activé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le récepteur d'archivage SMTP a été installé et activé :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

Si Exchange Server Analyzer détecte que la valeur définie pour Enable Smtp Messages est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Une valeur de 0 indique que le récepteur d'archivage SMTP est désactivé. Une valeur de 1 indique que le récepteur d'archivage SMTP est activé. Des valeurs autres que 0 ou 1 ne sont pas prises en charge.

L'outil Archive Sink SMTP est un script personnalisé qui permet l'archivage de tous les messages entrant et sortant d'un dossier spécifique sur un serveur Exchange. Par défaut, si le récepteur d'archivage SMTP est activé, tous les messages et leurs destinataires sont archivés dans un fichier .eml, sauf les destinataires en copie conforme.

Par défaut, lorsque vous activez l'archivage SMTP à l'aide du récepteur d'archivage SMTP, tous les messages devant être transportés par SMTP (Simple Mail Transfer Protocol), par la banque Exchange ou par tout autre récepteur déclenchent cet événement. Théoriquement, cet événement peut survenir une fois par message et peut être archivé une seule fois. L'événement OnMessageSubmission se produit avant le routage ou le catégoriseur. Par conséquent, ces messages sont également appelés messages PreCat. Par défaut, les messages sont archivés pour cet événement si l'outil SMTP Archive Sink est installé. Les messages qui sont archivés pour cet événement contiennent le nom de fichier du préfixe : ARCH_numéro aléatoire.xml.

Si vous ne souhaitez pas archiver les messages sur cet ordinateur Exchange, vous pouvez définir la clé de Registre Enable Smtp Messages sur 0 ou désinstaller le récepteur d'archivage SMTP. Si vous désinstallez le récepteur d'archivage SMTP, toutes les clés de Registre utilisées par le récepteur d'archivage SMTP sont supprimées.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour désactiver le récepteur d'archivage SMTP

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Double-cliquez sur la clé de Registre Enable Smtp Messages, dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  4. Quittez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Pour désinstaller le récepteur d'archivage SMTP

  1. Cliquez sur Démarrer, sur Exécuter, entrez cmd, puis cliquez sur OK.

  2. Dans le dossier C:\Program Files\Exchsrvr\bin, entrez cscript archivesink_setup.vbs, puis appuyez sur Entrée.

  3. Entrez cscript archivesink_setup.vbs uninstall Virtual Server ID, là où Virtual Server ID est le numéro de serveur virtuel sur lequel le récepteur d'archivage SMTP est installé.

  4. Quittez la fenêtre d'invite de commandes et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange Server 2003, voir l'article 871110 de la Base de connaissances sur la procédure d'installation et l'utilisation de l'outil Archive Sink dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange 2000 Server, voir l'article 307798 de la Base de connaissances sur la disponibilité de l'outil Archive Sink dans Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Pour plus d'informations sur le déploiement d'une solution de journalisation complète à des fins de conformité, voir le document sur la journalisation avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Récepteur d'archivage SMTP : définition après catégorisation
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le récepteur d'archivage SMTP a été installé et activé :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

Si Exchange Server Analyzer détecte que la valeur définie pour Enable PostCat est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Une valeur de 0 indique que l'archivage des messages après catégorisation est désactivé. Une valeur de 1 indique que l'archivage des messages après catégorisation est activé. Des valeurs autres que 0 ou 1 ne sont pas prises en charge.

L'outil Archive Sink SMTP est un script personnalisé qui permet l'archivage de tous les messages entrant et sortant d'un dossier spécifique sur un serveur Exchange. Par défaut, si le récepteur d'archivage SMTP est activé, tous les messages et leurs destinataires sont archivés dans un fichier .eml, sauf les destinataires en copie conforme.

Lorsque Enable PostCat est défini sur 1, les messages sont archivés après la catégorisation d'un message. Les messages peuvent déclencher cet événement plusieurs fois, mais il ne se produit que si un message a été catégorisé, mis en file d'attente et de nouveau énuméré. Les messages archivés pour cet événement contiennent le nom de fichier du préfixe ARCH_POSTCAT_random number.xml.

Si vous ne souhaitez pas archiver des messages après catégorisation sur cet ordinateur Exchange, vous pouvez définir la clé de Registre Enable PostCat sur 0. Si vous ne souhaitez pas archiver sur cet ordinateur, vous pouvez désinstaller le récepteur d'archivage SMTP. Si vous désinstallez le récepteur d'archivage SMTP, toutes les clés de Registre utilisées par le récepteur d'archivage SMTP sont supprimées.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour désactiver l'archivage des messages après catégorisation

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Double-cliquez sur la clé de Registre Enable PostCat, dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  4. Quittez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Pour désinstaller le récepteur d'archivage SMTP

  1. Cliquez sur Démarrer, sur Exécuter, entrez cmd, puis cliquez sur OK.

  2. Dans le dossier C:\Program Files\Exchsrvr\bin, entrez cscript archivesink_setup.vbs, puis appuyez sur Entrée.

  3. Entrez cscript archivesink_setup.vbs uninstall Virtual Server ID, là où Virtual Server ID est le numéro de serveur virtuel sur lequel le récepteur d'archivage SMTP est installé.

  4. Quittez la fenêtre d'invite de commandes et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange Server 2003, voir l'article 871110 de la Base de connaissances sur la procédure d'installation et l'utilisation de l'outil Archive Sink dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange 2000 Server, voir l'article 307798 de la Base de connaissances sur la disponibilité de l'outil Archive Sink dans Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Pour plus d'informations sur le déploiement d'une solution de journalisation complète à des fins de conformité, voir le document sur la journalisation avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Récepteur d'archivage SMTP : définition avant catégorisation
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le récepteur d'archivage SMTP a été installé et activé :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

Si Exchange Server Analyzer détecte que la valeur définie pour Enable PreCat est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Une valeur de 0 indique que l'archivage des messages avant catégorisation est désactivé. Une valeur de 1 indique que l'archivage des messages avant catégorisation est activé. Des valeurs autres que 0 ou 1 ne sont pas prises en charge.

L'outil Archive Sink SMTP est un script personnalisé qui permet l'archivage de tous les messages entrant et sortant d'un dossier spécifique sur un serveur Exchange. Par défaut, si le récepteur d'archivage SMTP est activé, tous les messages et leurs destinataires sont archivés dans un fichier .eml, sauf les destinataires en copie conforme.

Tous les messages devant être transportés par SMTP (Simple Mail Transfer Protocol), par la banque d'Exchange ou par d'autres récepteurs déclenchent cet événement. Théoriquement, cet événement peut survenir une fois par message et peut être archivé une seule fois. L'événement OnMessageSubmission se produit avant le routage ou le catégoriseur. Par conséquent, ces messages sont également appelés messages PreCat. Par défaut, les messages sont archivés pour cet événement si l'utilitaire SMTP Active Sink est installé. Les messages qui sont archivés pour cet événement contiennent le nom de fichier du préfixe ARCH_random number.xml.

Si vous ne souhaitez pas archiver des messages avant catégorisation sur cet ordinateur Exchange, vous pouvez définir la clé de Registre Enable PreCat sur 0. Si vous ne souhaitez pas archiver sur cet ordinateur, vous pouvez désinstaller le récepteur d'archivage SMTP. Si vous désinstallez le récepteur d'archivage SMTP, toutes les clés de Registre utilisées par le récepteur d'archivage SMTP sont supprimées.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour désactiver l'archivage des messages avant catégorisation

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Double-cliquez sur la clé de Registre Enable PreCat, dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  4. Quittez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Pour désinstaller le récepteur d'archivage SMTP

  1. Cliquez sur Démarrer, sur Exécuter, entrez cmd, puis cliquez sur OK.

  2. Dans le dossier C:\Program Files\Exchsrvr\bin, entrez cscript archivesink_setup.vbs, puis appuyez sur Entrée.

  3. Entrez cscript archivesink_setup.vbs uninstall Virtual Server ID, là où Virtual Server ID est le numéro de serveur virtuel sur lequel le récepteur d'archivage SMTP est installé.

  4. Quittez la fenêtre d'invite de commandes et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange Server 2003, voir l'article 871110 de la Base de connaissances sur la procédure d'installation et l'utilisation de l'outil Archive Sink dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange 2000 Server, voir l'article 307798 de la Base de connaissances sur la mise à disposition de l'utilitaire Archive Sink dans le Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Pour plus d'informations sur le déploiement d'une solution de journalisation complète à des fins de conformité, voir le document sur la journalisation avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Récepteur d'archivage SMTP : messages système archivés
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le récepteur d'archivage SMTP a été installé et activé :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

Si Exchange Server Analyzer détecte que la valeur définie pour Archive System Messages est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Une valeur de 0 indique que les messages système ne sont pas archivés. Une valeur de 1 indique que les messages système sont archivés. Des valeurs autres que 0 ou 1 ne sont pas prises en charge.

L'outil Archive Sink SMTP est un script personnalisé qui permet l'archivage de tous les messages entrant et sortant d'un dossier spécifique sur un serveur Exchange. Par défaut, si le récepteur d'archivage SMTP est activé, tous les messages et leurs destinataires sont archivés dans un fichier .eml, sauf les destinataires en copie conforme.

Si vous ne souhaitez pas archiver des messages système sur cet ordinateur Exchange, vous pouvez définir la clé de Registre Archive System Messages sur 0. Si vous ne souhaitez pas archiver sur cet ordinateur, vous pouvez désinstaller le récepteur d'archivage SMTP. Si vous désinstallez le récepteur d'archivage SMTP, toutes les clés de Registre utilisées par le récepteur d'archivage SMTP sont supprimées.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour désactiver l'archivage des messages système

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Double-cliquez sur la clé de Registre Archive System Messages, dans le champ Données de la valeur, entrez 0, puis cliquez sur OK.

  4. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que les modifications soient prises en compte.

Pour désinstaller le récepteur d'archivage SMTP

  1. Cliquez sur Démarrer, sur Exécuter, entrez cmd, puis cliquez sur OK.

  2. Dans le dossier C:\Program Files\Exchsrvr\bin, entrez cscript archivesink_setup.vbs, puis appuyez sur Entrée.

  3. Entrez cscript archivesink_setup.vbs uninstall Virtual Server ID, là où Virtual Server ID est le numéro de serveur virtuel sur lequel le récepteur d'archivage SMTP est installé.

  4. Fermez la fenêtre d'invite de commandes et redémarrez le service d'administration IIS pour que les modifications soient prises en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange Server 2003, voir l'article 871110 de la Base de connaissances sur la procédure d'installation et l'utilisation de l'outil Archive Sink dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110).

Pour plus d'informations sur le paramétrage et la configuration du récepteur d'archivage SMTP dans Exchange 2000 Server, voir l'article 307798 de la Base de connaissances sur la disponibilité de l'outil Archive Sink dans Service Pack 2 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798).

Pour plus d'informations sur le déploiement d'une solution de journalisation complète à des fins de conformité, voir le document sur la journalisation avec Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47581).


Les données SMTP BadMail sont écrites dans un dossier compressé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Compressed pour le dossier SMTP (Simple Mail Transfer Protocol) BadMail. Si Exchange Server Analyzer détecte que la valeur de Compressed est définie sur True, un avertissement s'affiche.

Lorsque des messages arrivent sur l'ordinateur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange. Si le dossier dans lequel sont enregistrées les données SMTP BadMail est compressé, les performances d'Exchange peuvent être considérablement altérées. Par conséquent, la compression du dossier dans lequel les données SMTP BadMail sont stockées n'est pas prise en charge.

Si cet avertissement s'affiche, vous devez désactiver la compression sur le dossier dans lequel les données SMTP BadMail sont stockées ou déplacer les données SMTP BadMail vers un dossier qui n'est pas compressé.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume compressé. Lorsque vous stockez vos fichiers de données Exchange sur un volume compressé, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour désactiver la compression de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver la compression de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

Pour déplacer le dossier BadMail sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez sur Groupes d'administration, développez votre groupe d'administration, développez Serveurs et votre serveur, puis Protocoles et SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Arrêter.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Sous l'onglet Messages, en regard de la zone Répertoire BadMail, cliquez sur Parcourir et entrez le chemin d'accès du nouvel emplacement du dossier de file d'attente.

  6. Cliquez sur OK.

  7. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer.

Pour plus d'informations sur le déplacement du dossier Mailroot, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


Les données SMTP BadMail sont écrites sur une partition non NTFS
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé FSName pour le répertoire SMTP BadMail d'Exchange. Si Exchange Server Analyzer détermine que la valeur de la clé FSName n'est pas égale à NTFS, un avertissement s'affiche.

Microsoft ne prend pas en charge le stockage de fichiers de données Exchange sur des volumes non NTFS. Les fichiers de données Exchange comprennent les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml.

Si vous voyez cet avertissement, vous devez déplacer le répertoire SMTP BadMail dans un dossier d'un lecteur utilisant le système de fichiers NTFS. Si le lecteur sur lequel le répertoire BadMail est enregistré est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS.

Pour déplacer le répertoire SMTP BadMail vers un autre dossier

  1. Démarrez le Gestionnaire système Exchange.

  2. Cliquez sur Groupes d'administration, développez votre groupe d'administration, développez Serveurs et votre serveur, puis Protocoles et SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Arrêter.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Sous l'onglet Messages, en regard de la zone Répertoire BadMail, cliquez sur Parcourir et entrez le chemin d'accès du nouvel emplacement du dossier BadMail.

  6. Cliquez sur OK.

  7. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer.

Pour plus d'informations sur le déplacement du dossier Mailroot, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Si le lecteur sur lequel les fichiers sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS. Pour plus d'informations sur l'utilisation de l'outil de ligne de commande convert.exe pour convertir une partition FAT en partition NTFS, voir l'article 214579 de la Base de connaissances Microsoft sur l'utilisation de Convert.exe pour convertir une partition en système de fichiers NTFS (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Les données SMTP BadMail sont écrites dans un dossier crypté
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Encrypted pour le dossier SMTP BadMail. Si Exchange Server Analyzer détecte que la valeur de la clé Encrypted est définie sur True, un avertissement s'affiche.

Lorsque des messages arrivent sur l'ordinateur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange. Si le dossier dans lequel sont enregistrées les données SMTP BadMail est crypté, les performances d'Exchange peuvent être considérablement altérées. Par conséquent, le cryptage du dossier dans lequel les données SMTP BadMail sont stockées n'est pas pris en charge.

Si cet avertissement s'affiche, vous devez désactiver le cryptage sur le dossier dans lequel les données SMTP BadMail sont stockées ou déplacer les données SMTP BadMail vers un dossier non crypté.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume crypté du système de fichiers de cryptage (EFS). Lorsque vous stockez vos fichiers de données Exchange sur un volume crypté, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour sécuriser vos fichiers de données Exchange, il est recommandé d'empêcher l'accès non autorisé à l'ordinateur Exchange et d'utiliser le format de message S/MIME pour crypter des données de message.

Pour corriger cette erreur, vous devez désactiver le cryptage de fichiers dans le dossier BadMail ou déplacer ce dossier vers un emplacement où le cryptage n'est pas activé.

Pour désactiver le cryptage de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver le cryptage de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Crypter le contenu pour sécuriser les données, puis cliquez sur OK.

Pour déplacer le dossier BadMail sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez sur Groupes d'administration, développez votre groupe d'administration, développez Serveurs et votre serveur, puis Protocoles et SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Arrêter.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Sous l'onglet Messages, en regard de la zone Répertoire BadMail, cliquez sur Parcourir et entrez le chemin d'accès du nouvel emplacement du dossier de file d'attente.

  6. Cliquez sur OK.

  7. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer.

Pour plus d'informations sur le déplacement du dossier Mailroot, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Pour plus d'informations sur les fichiers de données Exchange Server et EFS, voir l'article 834638 de la Base de connaissances Microsoft, qui contient des informations sur le stockage de fichiers de données sur un volume crypté dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Pour plus d'informations sur la sécurisation des messages dans Exchange Server 2003, voir le Guide de sécurité des messages Exchange Server 2003 à l'adresse http://go.microsoft.com/fwlink/?linkid=47574.


La valeur de Registre SMTP CatRetryMinutes n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé CatRetryMinutes a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Il est recommandé de ne modifier les valeurs des files d'attente par défaut qu'après mûre réflexion. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur Exchange Server.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


Avertissement de configuration SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-03

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur de l'attribut msExchSmtpMaxMessageSize a été modifiée et diffère de sa valeur par défaut de 0. Par défaut, l'attribut msExchSmtpMaxMessageSize est configuré pour une taille de message illimitée.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes existent :

  • L'attribut msExchSmtpMaxMessageSize ne présente pas la valeur 0.

  • Exchange n'est pas exécuté sous Microsoft Windows® Small Business Server 2003.

L'attribut msExchSmtpMaxMessageSize représente la taille maximale de chaque message SMTP pouvant être envoyé ou reçu. Pour des raisons de sécurité, il est recommandé de limiter la taille maximale des messages SMTP pouvant être envoyés et reçus depuis Internet. Toutefois, pour les messages SMTP internes tels que ceux échangés entre des serveurs Exchange de la même organisation, il est recommandé de laisser l'attribut msExchSmtpMaxMessageSize défini sur 0.

Exchange utilise les messages SMTP en interne pour gérer des tâches telles que la réplication de dossiers publics. Si l'attribut msExchSmtpMaxMessageSize est configuré avec une limite trop faible, cette limite pourrait provoquer des problèmes de réplication de dossiers publics et d'autres échecs de remise de messages inter-organisationnels.

Si ce serveur Exchange est un serveur Bridgehead qui transfère les messages SMTP vers et depuis Internet, vous pouvez ignorer cet avertissement en toute sécurité. Si ce serveur Exchange gère les messages SMTP internes, vous devez rétablir la valeur par défaut de l'attribut msExchSmtpMaxMessageSize, qui est de 0.

Remarque :
Si vous fixez une taille limite de messages trop basse, cela pourrait empêcher toute réplication de Carnet d'adresses en mode hors connexion entre les ordinateurs Exchange Server. Pour plus d'informations, voir l'article 326154 de la Base de connaissances Microsoft sur l'impossibilité de télécharger le Carnet d'adresses en mode hors connexion dans Microsoft Outlook dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).
Pour afficher et configurer la taille maximale des messages SMTP

  1. Dans le Gestionnaire système Exchange, développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP, par exemple, serveur virtuel SMTP par défaut, puis sélectionnez Propriétés.

  3. Sélectionnez l'onglet Messages.

  4. Pour rétablir le paramètre par défaut de 0, désactivez la case à cocher Limiter la taille des messages à (Ko). Vous pouvez également laisser cette case activée et configurer une valeur de votre choix.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 surla procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Connecteur SMTP avec définition de restrictions de remise de messages pour le groupe de distribution
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool interroge les attributs suivants pour chaque objet de connecteur SMTP (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector) trouvé dans le service d'annuaire Active Directory® afin de déterminer si des restrictions de remise sont définies pour eux sur la base de l'appartenance au groupe de distribution.

dLMemRejectPerms | Contient les noms de domaine des listes de distribution dont les membres ne peuvent pas effectuer d'envois via ce connecteur SMTP.
dLMemSubmitPerms | Contient les noms de domaine des listes de distribution dont les membres peuvent effectuer des envois via ce connecteur SMTP.

Si Exchange Server Analyzer détermine que des restrictions de remise sont définies pour des connecteurs SMTP sur la base de l'appartenance au groupe de distribution, il affiche un avertissement.

Cet avertissement indique que des restrictions de remise sur la base de l'appartenance au groupe de distribution peuvent affecter les performances de flux de messages d'Exchange.

Lorsque vous envoyez du courrier à l'aide de connecteurs SMTP pour lesquels des restrictions de remise sont définies sur la base de l'appartenance au groupe de distribution, le catégoriseur de messages doit développer l'appartenance du groupe de distribution, obtenir la liste complète des noms de domaine des membres, puis comparer cette liste aux noms de domaine de l'expéditeur de la liste. Une opération d'accès ou de refus est effectuée en cas de correspondance d'un nom de domaine dans les deux listes. Si un groupe de distribution est imbriqué dans un autre groupe de distribution, la distribution imbriquée est également développée.

Pour supprimer cet avertissement :

  • Désignez un groupe de routage dédié pour les restrictions de connecteur et configurez-le dans un groupe de routage local comme indiqué dans l'article 329171 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • Utilisez un serveur de catalogue global dédié et plus robuste comme serveur tête de pont désigné pour le connecteur.

  • Configurez les boîtes aux lettres individuelles et pas les groupes de distribution pour les restrictions de remise comme décrit dans l'article 812298 de la Base de connaissances Microsoft sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).

  • Envisagez la mise en œuvre du filtrage des expéditeurs SMTP.

  • Pour les serveurs qui exécutent Exchange Server 2003 Service Pack 2 (SP2) ou version ultérieure, envisagez la mise en œuvre de la vérification des restrictions non hiérarchiques. Pour les serveurs qui exécutent des versions d'Exchange antérieures à Exchange 2003 SP2, envisagez la mise à niveau vers Exchange 2003 SP2.

Pour plus d'informations

Pour plus d'informations sur la vérification des restrictions non hiérarchiques, voir la rubrique Envisager la vérification des restrictions non hiérarchiques.

Pour plus d'informations sur le filtrage des expéditeurs SMTP, voir la section sur la procédure d'activation du filtrage des expéditeurs dans le Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=72967).

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 329171 sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).


Réécriture de domaine SMTP activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut heuristics sur l'objet Serveur virtuel SMTP pour ce serveur Exchange. Si Exchange Server Analyzer détecte que la valeur de l'attribut heuristics est différente de la valeur par défaut 131072, une erreur s'affiche.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur l'outil de réécriture d'adresse Exchange Server Address Rewrite, voir l'article sur Exchange Server Address Rewrite (http://go.microsoft.com/fwlink/?LinkId=25932).


La valeur de Registre SMTP FailedMsgQRetryMinutes n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé FailedMsgQRetryMinutes a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Il est recommandé de ne modifier les valeurs des files d'attente par défaut qu'après mûre réflexion. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur Exchange Server.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


La valeur de Registre SMTP LocalDeliveryMaxBatch n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le paramètre par défaut de la valeur de Registre LocalDeliveryMaxBatch a été modifié :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

Si Exchange Server Analyzer détecte que le paramètre de la valeur de Registre LocalDeliveryMaxBatch a été créé manuellement pour remplacer le paramètre binaire par défaut du serveur Exchange de 80, il affiche un message d'avertissement indiquant une configuration autre que celle par défaut.

Par défaut, la valeur de Registre LocalDeliveryMaxBatch n'est pas créée pendant l'installation d'Exchange Server. La valeur de Registre LocalDeliveryMaxBatch peut être créée manuellement après l'installation d'Exchange Server pour modifier la façon dont la banque d'informations Exchange traite et envoie les messages en interne. Le serveur Exchange peut rencontrer des problèmes de transport des messages et de performances de stockage si les conditions suivantes sont vraies :

  • La valeur de Registre LocalDeliveryMaxBatch a été créée manuellement.

  • Le paramètre de la valeur de Registre LocalDeliveryMaxBatch n'est pas configuré correctement.

Il est recommandé de ne créer ou modifier la valeur de Registre LocalDeliveryMaxBatch qu'après mûre réflexion. Les valeurs par défaut des fichiers binaires pour le serveur Exchange ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements de serveur Exchange. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement par défaut d'Exchange Server en configurant le Registre manuellement. Pour respecter ces recommandations, si la valeur de Registre LocalDeliveryMaxBatch existe déjà, vous souhaiterez peut-être la supprimer pour reconfigurer le serveur Exchange sur le paramètre binaire par défaut.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Toutefois, vous souhaiterez peut-être réinitialiser la valeur de Registre au paramètre par défaut en modifiant le Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer cet avertissement

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à la clé de Registre suivante : HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%

  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur de Registre LocalDeliveryMaxBatch, cliquez sur Modifier, puis modifiez le champ Données de la valeur sur 80. Cliquez sur OK.

    Remarque :
    Pour supprimer la valeur de Registre LocalDeliveryMaxBatch, cliquez avec le bouton droit sur la valeur de Registre LocalDeliveryMaxBatch dans le volet Détails, puis cliquez sur Supprimer. Confirmez la suppression de la valeur de Registre en cliquant sur Oui dans la boîte de dialogue.

  4. Fermez l'Éditeur du Registre.

  5. Redémarrez le serveur Exchange.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la manière de modifier le Registre de Microsoft Windows, voir les articles suivants de la Base de connaissances Microsoft :

  • 322755 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755)

  • 322756 sur la procédure de sauvegarde, de modification et de restauration du Registre dans Windows XP et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756)


Le FQDN de l'instance SMTP ne correspond pas au nom de serveur DNS résolu
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-04

L'outil Microsoft® Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour déterminer la valeur de l'attribut msExchSmtpFullyQualifiedDomainName de l'objet serveur virtuel SMTP (Simple Mail Transfer Protocol) par défaut.

L'outil Exchange Server Analyzer tente également d'exécuter une requête DNS (Domain Name System) sur les serveurs DNS configurés pour le nom de domaine complet (FQDN) du serveur exécutant Exchange Server. Cette connexion est établie en utilisant un processeur d'objet personnalisé qui exécute une demande de résolution de nom et analyse les résultats.

Exchange Server Analyzer compare les résultats des deux requêtes : Si la valeur de l'attribut msExchSmtpFullyQualifiedDomainName de l'objet serveur virtuel SMTP (Simple Mail Transfer Protocol) par défaut ne correspond pas au FQDN du DNS du serveur Exchange, Exchange Server Analyzer affiche un message d'avertissement.

Cet avertissement indique que les valeurs de ces attributs ont peut-être été modifiées manuellement . C'est pourquoi, ces valeurs modifiées peuvent contribuer à générer des problèmes de flux de messages sur ce serveur.

L'attribut msExchSmtpFullyQualifiedDomainName spécifie le nom de domaine complet du serveur virtuel SMTP ; ce nom doit pouvoir être résolu par le protocole de réseau DNS (Domain Name System).

Un enregistrement DNS HOST (A) valide doit exister pour la valeur de cet attribut afin que les serveurs de messagerie qui tentent de résoudre le nom de domaine complet du serveur virtuel SMTP puissent récupérer l'adresse IP correcte et acheminer correctement les messages.

Pour supprimer cet avertissement, déterminez si les valeurs ont été modifiées volontairement dans un but valide. Si les valeurs ont été modifiées dans un but valide, procédez comme suit :

  • Modifiez la valeur de l'attribut msExchSmtpFullyQualifiedDomainName pour qu'elle corresponde au FQDN du DNS.

  • Configurez le FQDN du DNS d'Exchange Server pour qu'il corresponde à la valeur de l'attribut msExchSmtpFullyQualifiedDomainName.

Attention :
Si vous modifiez de manière incorrecte les attributs des objets Active Directory lors de l'utilisation d'ADSI (Active Directory Service Interfaces) Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter une réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez ces attributs d'objet Active Directory, vous devez en assumer les risques.
Mise à jour de la valeur de l'attribut msExchSMTPFullyQualifiedDomainName

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Groupes d'administration, Serveurs, le serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP par défaut, puis sélectionnez Propriétés.

  4. Sélectionnez l'onglet Remise, puis cliquez sur Paramètres avancés.

  5. Sous le nom de domaine complet, entrez la valeur de l'attribut msExchSmtpFullyQualifiedDomainName.

  6. Cliquez sur OK pour enregistrer les modifications, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.
Configuration du FQDN du DNS d'Exchange Server

  1. Suivez les instructions de la Procédure de configuration des paramètres sur le serveur DNS.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, consultez la rubrique sur l'ajout d'un enregistrement de ressource à une zone DNS (http://go.microsoft.com/fwlink/?LinkId=63002).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, consultez les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Pour plus d'informations sur la conception du service SMTP, consultez la rubrique « Conception du service SMTP » dans le Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=58876).


Instance SMTP sans définition de connecteur SMTP sortant
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-22

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour la valeur de l'attribut distingushedName de la classe d'objet protocolCfgSMTPServer pour répertorier toutes les instances de serveur virtuel SMTP (Simple Mail Transfer Protocol) sur la passerelle Exchange spécifiée par l'utilisateur.

Exchange Server Analyzer interroge ensuite Active Directory pour la valeur des attributs msExchSourceBridgeheadServersDN et routingList pour chaque objet msExchRoutingSMTPConnector trouvé afin de déterminer si un connecteur SMTP dispose de l'une des instances de serveur virtuel SMTP détectée définie comme tête de pont locale pour un espace d'adressage SMTP externe.

Un connecteur SMTP désigne un routage isolé pour le courrier. Vous pouvez utiliser des connecteurs SMTP pour établir une passerelle pour le courrier Internet ou pour vous connecter à un domaine spécifique ou un système de messagerie. Les connecteurs permettent de définir des options spécifiques pour le routage de courrier désigné.

Si Exchange Server Analyzer détermine qu'aucun connecteur SMTP ne dispose d'une instance de serveur virtuel SMTP du serveur de passerelle Exchange spécifié défini comme serveur tête de pont local, il affiche un avertissement.

Cet avertissement indique que les serveurs autres que le serveur de passerelle Exchange spécifié par l'utilisateur peuvent involontairement router les messages en dehors de l'organisation.

Il se peut que vous souhaitiez créer un connecteur SMTP qui désigne une instance de serveur virtuel SMTP sur le serveur de passerelle Exchange spécifié comme tête de pont pour éviter que des serveurs autres que le serveur de passerelle Exchange spécifié par l'utilisateur puisse involontairement router les messages en dehors de l'organisation.

Bien que vous puissiez envoyer et recevoir du courrier Internet à l'aide d'un seul serveur virtuel SMTP, il est recommandé de configurer un connecteur SMTP dédié pour router le courrier Internet. L'utilisation d'un connecteur SMTP est recommandée car celui-ci fournit un routage isolé pour le courrier destiné à Internet. En outre, un connecteur SMTP propose davantage d'options de configuration que le serveur virtuel SMTP.

Pour plus d'informations sur l'utilisation des connecteurs SMTP, voir l'article 294736 de la Base de connaissances Microsoft sur le moment auquel créer des connecteurs SMTP dans Exchange 2000 et versions ultérieures (http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736).

Pour plus d'informations sur les connecteurs SMTP, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


La valeur de Registre SMTP LocalRetryMinutes n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé LocalRetryMinutes a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Il est recommandé de ne modifier les valeurs des files d'attente par défaut qu'après mûre réflexion. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur Exchange.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


La valeur de Registre SMTP FileCacheLifeTimeSeconds a été ajoutée manuellement, mais risque de ne plus être nécessaire
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le délai de vie par défaut de chaque descripteur de fichier des services IIS (Internet Information Services ) mis en cache a été modifié de la valeur par défaut de 1 880 secondes (30 minutes) :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

Si Exchange Server Analyzer détecte que la valeur FileCacheLifeTimeSeconds est présente et configurée sur une autre valeur, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur FileCacheLifeTimeSeconds spécifie le délai de vie des descripteurs de fichiers des services IIS mis en cache. Les descripteurs de fichiers sont mis en cache pour améliorer les performances car une fois mis en cache, ils empêchent le serveur d'effectuer des entrées/sorties (E/S) redondantes et des cycles de processeur. Chaque fois que la pile de transport SMTP d'un ordinateur Exchange Server reçoit un message, celui-ci est transféré au système de fichiers, où il attend d'être acheminé vers sa destination. Pour écrire au système de fichiers, la pile de transport SMTP obtient un descripteur de fichier et lui transfère le message. Chaque descripteur de fichier utilise environ 2 kilo-octets (Ko) de mémoire de réserve paginée. Le nombre par défaut de descripteurs de fichiers de cache des services IIS est de 800 par tranche de 32 Mo.

Cette valeur de Registre n'est pas présente par défaut car Exchange 2000 Server Service Pack 2 (SP2) et ultérieur et Exchange Server 2003 sont configurés pour mettre en cache un nombre optimal de descripteurs de fichiers. Exchange Server 2003 calcule dynamiquement les paramètres appropriés pour les descripteurs de fichiers SMTP pour que ces paramètres ne soient plus nécessaires. Par conséquent, avant la mise à niveau de tout ordinateur Exchange 2000 Server avec ces paramètres vers Exchange Server 2003, vous devez supprimer ces entrées du Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour rétablir la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Dans le volet droit, supprimez la valeur FileCacheLifeTimeSeconds.

  4. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La valeur SMTP FileCacheMaxHandles de Registre a été ajoutée manuellement, mais risque de ne plus être nécessaire
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le nombre maximal de descripteurs de caches de fichiers des services IIS a été modifié par rapport à la valeur par défaut de 800 :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

Si Exchange Server Analyzer détecte que FileCacheMaxHandles est présent et configuré avec une valeur différente de 800, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur FileCacheMaxHandles spécifie le nombre maximal de descripteurs de fichiers des services IIS utilisés par Exchange pour chaque tranche de 32 mégaoctets (Mo) de mémoire physique. Les descripteurs de fichiers sont mis en cache pour améliorer les performances car une fois mis en cache, ils empêchent le serveur d'effectuer des entrées/sorties (E/S) redondantes et des cycles de processeur. Chaque fois que la pile de transport SMTP d'un ordinateur Exchange Server reçoit un message, celui-ci est transféré au système de fichiers, où il attend d'être acheminé vers sa destination. Pour écrire au système de fichiers, la pile de transport SMTP obtient un descripteur de fichier et lui transfère le message. Chaque descripteur de fichier utilise environ 2 kilo-octets (Ko) de mémoire de réserve paginée. Le nombre par défaut de descripteurs de fichiers de cache des services IIS est de 800 par tranche de 32 Mo.

Avant le Service Pack 2 (SP2) pour Exchange 2000 Server, les serveurs Exchange qui maintenaient de grandes files de messages SMTP (en moyenne, au moins 1 000 messages) se sont heurtés à des contraintes de performance historique en raison d'un paramètre par défaut du service SMTP, qui consiste en un maximum de 1 000 descripteurs de fichiers. Comme Exchange 2000 Server a par défaut utilisé un nombre maximal de 1 000 descripteurs de fichiers, le service SMTP n'a pu écrire que 1 000 messages simultanés dans le système de fichiers.

Pour améliorer les performances de ces grands systèmes, trois entrées de Registre ont fréquemment été ajustées simultanément de manière à augmenter le nombre maximal de descripteurs de fichiers pouvant être ouverts par le service SMTP (pour pouvoir traiter davantage de messages) et à réduire le nombre de descripteurs de fichiers ouverts pour le système de fichiers à installer, un autre composant Exchange (pour éviter de manquer de mémoire lorsque la file d'attente est grande). Ces valeurs de Registre, qui n'existaient pas par défaut et ont donc dû être ajoutées manuellement, sont répertoriées ci-dessous :

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Valeur : MsgHandleThreshold

Entrez : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Valeur : MsgHandleAsyncThreshold

Entrez : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valeur : FileCacheMaxHandles

Entrez : REG_DWORD

Les entrées MsgHandleThreshold et MsgHandleAsyncThreshold sont généralement définies sur la même valeur (souvent une valeur supérieure à 1 000) et la valeur FileCacheMaxHandles est généralement réduite de 800 à 600.

Cette valeur de Registre n'est pas présente par défaut car Exchange 2000 Server Service Pack 2 (SP2) et ultérieur détermine dynamiquement les valeurs optimales à utiliser. Si ce serveur Exchange exécute Exchange 2000 Server avec Service Pack 1 ou antérieur, il est recommandé d'effectuer une mise à niveau vers le Service Pack et l'ensemble de mises à jour les plus récents. Dès que vous avez effectué la mise à niveau vers le dernier code, vous pouvez supprimer ces entrées de Registre.

Exchange Server 2003 calcule dynamiquement les paramètres appropriés pour les descripteurs de fichiers SMTP pour que ces paramètres ne soient plus nécessaires. Par conséquent, avant la mise à niveau de tout ordinateur Exchange 2000 Server avec ces paramètres vers Exchange Server 2003, vous devez supprimer ces entrées du Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Supprimez la valeur FileCacheMaxHandles.

  4. Fermez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La valeur de Registre SMTP GlitchRetrySeconds a été définie manuellement
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le temps d'attente par défaut pour une nouvelle tentative après un problème a été remplacé manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

Si Exchange Server Analyzer détecte que la valeur GlitchRetrySeconds est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Si Exchange 2000 Server ou Exchange Server 2003 tente de router un message vers un système SMTP externe très chargé, il peut recevoir une erreur Serveur occupé. Lorsque cela se produit, Exchange passe à un état appelé « nouvelle tentative après un problème ». Dans cet état, Exchange attend 60 secondes avant de tenter de renvoyer le message et répète fois trois ce processus avant de recourir à d'autres actions. Si des serveurs SMTP externes sont régulièrement occupés, il est recommandé de réduire le temps d'attente pour une nouvelle tentative après un problème pour éviter la mise en file d'attente de messages en masse.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Dans le volet droit, supprimez la valeur GlitchRetrySeconds. Vous pouvez également réduire la valeur de GlitchRetrySeconds en cas de mise en file d'attente en masse.

  4. Quittez l'Éditeur du Registre et redémarrez le service SMTP pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La valeur de Registre SMTP IgnorePFTimeLimit a été définie manuellement
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le nombre de jours pendant lesquels le moteur de routage du service SMTP ignore la nouvelle banque de dossiers publics a été défini manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

Si Exchange Server Analyzer détecte que la valeur IgnorePFTimeLimit est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Lorsqu'une nouvelle banque de dossiers publics est mise en ligne, vous remarquerez que la file d'attente de remise locale s'allonge dans l'Afficheur des files d'attente. Si la hiérarchie de dossiers publics est volumineuse, le nombre de messages dans la file d'attente locale continue d'augmenter et leur remise peut prendre plus de temps que prévu. Dans certains cas, les messages peuvent ne pas être remis.

Lors de l'introduction du nouveau serveur, son nom unique est ajouté à l'attribut msExchOwningPFTreeBL de l'objet Folder Hierarchies Public Folder du groupe d'administration dans le service d'annuaire Active Directory®. Lorsque le catégoriseur du serveur qui reçoit des messages liés aux dossiers publics lit l'attribut msExchOwningPFTreeBL, il doit d'abord sélectionner la banque de dossiers publics locale si elle existe. Pour l'équilibrage de charge, il sélectionne ensuite les banques de dossiers publics dans l'ordre dans lequel elles sont répertoriées. Les messages sont routés vers le nouveau serveur car il figure en haut de la liste. Ils sont alors ajoutés à la file d'attente de remise locale du nouveau serveur. Si une banque de dossiers publics n'a pas reçu de copie de la hiérarchie, le serveur ne peut pas router les messages vers une banque qui possède une copie du dossier de destination.

Vous pouvez éviter ce problème en ajoutant la valeur IgnorePFTimeLimit au Registre du nouveau serveur de dossiers publics. Vous indiquerez ainsi le nombre de jours pendant lesquels le moteur de routage ignore la nouvelle banque de dossiers publics.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Dans le volet droit, supprimez IgnorePFTimeLimit.

  4. Fermez l'Éditeur du Registre, puis redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Pour plus d'informations sur le problème et la valeur de Registre IgnorePFTimeLimit décrits dans cet article, consultez l'article 328870 de la Base de connaissances Microsoft sur l'activation du routage de dossiers publics avant la réplication de la hiérarchie (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870).

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


L'instance SMTP présente plusieurs liaisons de port configurées
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchServerBindings a été modifiée et diffère de sa valeur par défaut de 25 ou si plusieurs valeurs ont été définies. Par défaut, l'attribut msExchServerBindings est configuré pour le port TCP 25. Si Exchange Server Analyzer détecte que cet attribut présente plusieurs valeurs définies, un message indiquant une configuration autre que celle par défaut s'affiche et indique le nom du serveur virtuel SMTP (Simple Mail Transfer Protocol) présentant plusieurs valeurs définies.

L'attribut msExchServerBindings représente le port TCP sur lequel ce serveur SMTP écoute les connexions entrantes. Les serveurs virtuels SMTP peuvent être configurés pour écouter sur un ou plusieurs ports TCP. Par défaut, tous les serveurs virtuels SMTP sont configurés pour écouter sur le port TCP 25, le port SMTP par défaut. Si le port d'écoute SMTP a été modifié par rapport à sa valeur par défaut et comprend plusieurs liaisons de port, il peut perturber le flux de messages.

Vous pouvez modifier le port d'écoute SMTP tant que vous modifiez en conséquence l'ensemble de l'infrastructure de messagerie interne. Toutefois, il n'est généralement pas possible d'utiliser d'autres ports pour des serveurs virtuels SMTP qui acceptent des messages directement depuis Internet, car les serveurs SMTP sur Internet envoient les messages par le biais du port 25.

Exchange Server Analyzer recherche la valeur pour le serveur virtuel de protocole SMTP Exchange. Ce serveur n'est pas forcément le serveur SMTP qui reçoit les messages directement depuis Internet. Certains produits antivirus et antispam sont conçus pour recevoir des messages SMTP depuis Internet sur le port 25 et les rediriger vers un serveur virtuel SMTP Exchange sur un autre port. Dans ce scénario, un serveur virtuel SMTP Exchange qui écoute sur plusieurs ports est une configuration acceptable.

Pour afficher ou modifier le port d'écoute du serveur virtuel SMTP

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut) puis cliquez sur Propriétés.

  4. Sélectionnez l'onglet Général, puis cliquez sur Avancé.

  5. Une liste de ports et d'adresses IP s'affiche.

    • Pour modifier le port existant, sélectionnez l'adresse IP, puis cliquez sur Modifier. Modifiez le champ du port TCP en 25.

    • Pour ajouter le port 25 comme port d'écoute supplémentaire, cliquez sur Ajouter et ajoutez la nouvelle combinaison adresse IP/port. Si vous utilisez le filtre connexion, expéditeur ou destinataire, assurez-vous d'activer les cases à cocher appropriées.

  6. Cliquez sur OK pour enregistrer vos modifications, puis de nouveau sur OK pour quitter la boîte de dialogue Avancé.

  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Avertissement d'échec de message SMTP - Échec général des messages BadMail
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé BadmailedMessagesGeneralFailure. La valeur de cette clé représente le nombre de messages envoyés au répertoire Badmail pour des raisons non liées à un compteur spécifique. Le répertoire Badmail est utilisé pour stocker les messages non remis. Pour plus d'informations sur d'autres compteurs WMI Badmail, voir les articles suivants d'Exchange Server Analyzer :

  • Avertissement d'échec de message SMTP - Seuil de nombre de sauts des messages BadMail

  • Avertissement d'échec de message SMTP - Rapports de non-remise sur notifications d'état de remise des messages BadMail

Certains compteurs s'incrémentent lorsqu'un message est envoyé au répertoire Badmail pour d'autres raisons, notamment un fichier de collecte incorrect, l'absence de destinataires, et déclenché via un événement.

Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de BadmailedMessagesGeneralFailure par celle de SystemUpTime est supérieur à 1000, un avertissement s'affiche.

Cet avertissement indique que 1 000 messages ou plus par jour en moyenne sont identifiés comme non remis et stockés dans le répertoire Badmail. Les messages du répertoire Badmail doivent être supprimés manuellement. Il est recommandé que l'examen et la suppression des messages du répertoire Badmail fassent partie intégrante de la maintenance régulière d'Exchange Server. Permettre l'accroissement du répertoire Badmail sans restriction risque de consommer tout l'espace disque disponible et de provoquer ensuite le démontage des bases de données Exchange.

Pour supprimer cet avertissement

  1. Examinez les messages du répertoire Badmail pour déterminer si la source du message est interne ou externe. Les messages du répertoire Badmail sont stockés au format ASCII et peuvent être ouverts et affichés dans le Bloc-notes ou tout autre éditeur de texte.

    • Si les messages semblent être générés en interne, vous pouvez examiner les en-têtes pour déterminer leur origine.

    • Si les messages semblent être générés en externe, cela peut signifier qu'Exchange Server est utilisé pour relayer le courrier.

Pour plus d'informations sur le contrôle et la configuration d'options de relais, voir les articles suivants de la Base de connaissances Microsoft :

  • 310380 sur la procédure pour empêcher l'utilisation d'Exchange 2000 comme un relais de messagerie dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)

  • 313395 sur la procédure d'examen des restrictions de relais pour les connexions SMTP anonymes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395)

Pour plus d'informations sur les démontages de bases de données en raison d'un espace disque disponible insuffisant, voir l'article 321825 de la Base de connaissances Microsoft sur le démontage des bases de données en raison d'un espace disque insuffisant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825).


Avertissement d'échec de message SMTP - Seuil de nombre de sauts des messages BadMail
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé BadmailedMessagesHopCountExceeded. La valeur de cette clé représente le nombre de messages envoyés au répertoire Badmail en raison d'un dépassement du nombre maximal de sauts. Le répertoire Badmail est utilisé pour stocker les messages non remis. Pour plus d'informations sur d'autres compteurs WMI Badmail, voir les articles sur l'outil Exchange Server Analyzer Tool, Avertissement d'échec de message SMTP - Échec général des messages BadMail et Avertissement d'échec de message SMTP - Rapports de non-remise sur notifications d'état de remise des messages BadMail.

Certains compteurs s'incrémentent lorsqu'un message est envoyé au répertoire Badmail pour d'autres raisons, notamment un fichier de collecte incorrect, l'absence de destinataires, et déclenché via un événement.

Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de BadmailedMessagesHopCountExceeded par celle de SystemUpTime est supérieur à 100, un avertissement s'affiche.

Cet avertissement indique que 100 messages ou plus par jour en moyenne sont identifiés comme non remis et stockés dans le répertoire Badmail en raison d'un dépassement du nombre maximal de sauts. Le nombre maximal de sauts correspond au nombre maximal de serveurs SMTP par lesquels un message peut transiter entre l'expéditeur et le destinataire. Chaque fois qu'un message transite par un serveur SMTP, une ligne de texte représentant le saut est ajoutée à l'en-tête de message.

Le nombre optimal de sauts de messages varie selon la topologie de votre réseau et de vos besoins de messagerie. Pour empêcher un message d'être mal routé à plusieurs reprises (condition appelée boucle de message), un administrateur peut contrôler le nombre maximal de sauts autorisés. Pour ce faire, vous pouvez définir un nombre maximal de sauts pour le serveur virtuel SMTP. Dans Exchange 2000 Server, le nombre de sauts par défaut est 15. Dans Exchange Server 2003, il est de 30. Une valeur de 30 pour les serveurs virtuels SMTP Exchange 2000 Server et Exchange Server 2003 est recommandée.

Les messages du répertoire Badmail doivent être supprimés manuellement. Il est recommandé que l'examen et la suppression à intervalles réguliers des messages du répertoire Badmail fassent partie intégrante de la maintenance régulière d'Exchange Server. Permettre l'accroissement du répertoire Badmail sans restriction risque de consommer tout l'espace disque disponible et de provoquer ensuite le démontage des bases de données Exchange.

Pour supprimer cet avertissement

  1. Examinez les messages du répertoire Badmail pour déterminer si la source du message est interne ou externe. Les messages du répertoire Badmail sont stockés au format ASCII et peuvent être ouverts et affichés dans le Bloc-notes ou tout autre éditeur de texte.

    • Si les messages semblent être générés en interne, vous pouvez examiner les en-têtes pour déterminer leur origine.

    • Si les messages semblent être générés en externe, cela peut signifier qu'Exchange Server est utilisé pour relayer le courrier.

  2. Définissez le nombre de sauts maximal sur 30.

    1. Ouvrez le Gestionnaire système Exchange.

    2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

    3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, serveur virtuel SMTP par défaut) et sélectionnez Propriétés.

    4. Sélectionnez l'onglet Remise, puis cliquez sur Avancé.

    5. Entrez la valeur souhaitée dans le champ Nombre maximal de sauts et cliquez sur OK pour enregistrer la modification.

    6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur le contrôle et la configuration d'options de relais, voir les articles suivants de la Base de connaissances Microsoft :

  • 310380 sur la procédure pour empêcher l'utilisation d'Exchange 2000 comme un relais de messagerie dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380)

  • 313395 sur la procédure d'examen des restrictions de relais pour les connexions SMTP anonymes (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395)

Pour plus d'informations sur les démontages de bases de données en raison d'un espace disque disponible insuffisant, voir l'article 321825 de la Base de connaissances Microsoft sur le démontage des bases de données en raison d'un espace disque insuffisant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825).


Avertissement d'échec de message SMTP - Rapports de non-remise sur notifications d'état de remise des messages BadMail
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-23

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé BadmailedMessagesNDRofDSN. La valeur de cette clé représente le nombre de messages de notification d'état de remise envoyés au répertoire Badmail car ils ne peuvent pas être remis. Le répertoire Badmail est utilisé pour stocker les messages non remis. Pour plus d'informations sur d'autres compteurs WMI Badmail, voir les articles d'Exchange Server Analyzer, Avertissement d'échec de message SMTP - Échec général des messages BadMail et Avertissement d'échec de message SMTP - Seuil de nombre de sauts des messages BadMail.

Certains compteurs s'incrémentent lorsqu'un message est envoyé au répertoire Badmail pour d'autres raisons, notamment un fichier de collecte incorrect, l'absence de destinataires, et déclenché via un événement.

Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0et que le résultat de la division de la valeur de BadmailedMessagesNDRofDSN par celle de SystemUpTime est supérieure à 1000, un avertissement est affiché.

Cet avertissement indique qu'une moyenne d'au moins 1 000 notifications d'état de remise par jour sont stockées dans le répertoire Badmail faute d'avoir pu être remises. Les messages du répertoire Badmail doivent être supprimés manuellement. Il est recommandé que l'examen et la suppression à intervalles réguliers des messages du répertoire Badmail fassent partie intégrante de la maintenance régulière d'Exchange Server. Permettre l'accroissement du répertoire Badmail sans restriction risque de consommer tout l'espace disque disponible et de provoquer ensuite le démontage des bases de données Exchange.

Pour supprimer cet avertissement

  • Examinez les messages du répertoire Badmail pour déterminer si les notifications d'état de remise sont prévues pour des destinataires internes ou externes. Les messages du répertoire Badmail sont stockés au format ASCII et peuvent être ouverts et affichés dans le Bloc-notes ou tout autre éditeur de texte.

    • Si les notifications d'état de remise sont prévues pour des destinataires internes, cela indique un problème de flux de messages. La résolution de ce problème dépend du code numérique spécifique renvoyé avec la notification d'état de remise.

    • Si les notifications d'état de remise sont prévues pour des destinataires externes, cela indique qu'Exchange Server est utilisé pour relayer le courrier. La résolution de ce problème dépend également du code numérique renvoyé.

Pour plus d'informations sur les codes numériques de retour des notifications d'état de remise, voir l'article 284204 de la Base de connaissances Microsoft sur les notifications d'état de remise dans Exchange Server et dans Small Business Server.

Pour plus d'informations sur le contrôle et la configuration d'options de relais, voir l'article 313395 de la Base de connaissances Microsoft sur la façon d'examiner les restrictions de relais pour les connexions SMTP anonymes et le filtrage de messages électroniques non sollicités dans Exchange 2000 Server.

Pour plus d'informations sur les démontages de bases de données en raison d'un espace disque disponible insuffisant, voir l'article 321825 de la Base de connaissances Microsoft sur le démontage des bases de données en raison d'un espace disque insuffisant.


Avertissement d'échec de message SMTP - Échec des recherches d'adresse du catégoriseur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-03-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé CatAddresslookupsnotfound. La valeur de cette clé représente le nombre de recherches d'adresse effectuées par le catégoriseur de messages qui n'a pas trouvé d'objet du service d'annuaire. Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de CatAddresslookupsnotfound par celle de SystemUpTime est supérieur à 5 000, un avertissement s'affiche.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP et détermine les opérations à effectuer. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou encore à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui passe par le moteur avancé de files d'attente. Il assure la résolution d'adresse et le transfert de messages, définit les indicateurs de conversion de contenu, étend les listes de distribution, applique des paramètres globaux, génère des notifications d'état de remise et exécute la détection d'itinéraire de destinataire suppléant, la bifurcation, la journalisation et de nombreuses autres fonctions.

Lorsqu'un message entre dans le catégoriseur de messages, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Cet avertissement indique qu'une moyenne d'au moins 5 000 recherches d'adresse du catégoriseur échoue chaque jour. Plusieurs causes sont possibles, notamment des problèmes d'accès au service d'annuaire (DSAccess), la latence ou des échecs de réplication d'annuaire, des attaques de dictionnaire sur des annuaires, des problèmes avec DNS ou l'utilisation d'adresses incorrectes.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Vérifiez si les journaux d'événements de l'ordinateur Exchange Server contiennent des erreurs.

  2. Si vous ne trouvez pas d'événements permettant de résoudre le problème, envisagez d'augmenter l'enregistrement des diagnostics du catégoriseur MSExchangeTransport au niveau maximal. Lorsque l'enregistrement des diagnostics est activé, revérifiez si le journal des événements contient des erreurs. Si la configuration de l'enregistrement des diagnostics sur le niveau maximal ne produit aucune entrée du journal des événements, configurez-le sur le niveau 7 en utilisant le Registre. À ce niveau, l'ID d'événement 9000 généré par le catégoriseur de messages sera enregistré. Il détaille la fonction, la raison de l'échec, le nom du destinataire qui a échoué et le type de destinataire. Pour définir l'enregistrement des diagnostics sur le niveau 7 :

    1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    2. Naviguez jusqu'à :

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Dans le volet droit, double-cliquez sur 2 Categorizer (Catégoriseur 2), définissez les données de valeur sur 7, puis cliquez sur OK.

    4. Fermez l'Éditeur du Registre.

      Remarque :
      Lorsque vous avez terminé le dépannage, redéfinissez les données de la valeur pour 2 Categorizer sur 0.

  3. Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  4. Examinez les messages de notification d'état de remise en cours de génération. Ces messages, qui peuvent comprendre des rapports de non-remise, décrivent des messages d'échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  5. Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  6. Utilisez l'outil Archive Sink pour archiver et analyser les messages entrants et sortants d'Exchange Server.

  7. Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

Pour la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, voir l'article 284204 de la Base de connaissances Microsoft sur les notifications d'état de remise dans Exchange 2000 Server et dans Small Business Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 262162 sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856 sur la procédure d'activation du suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905 sur les ID d'événements du suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864 sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, voir la Webdiffusion du Support Technique de Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, voir l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour des informations générales sur le dépannage de problèmes liés au transport, voir les articles suivants de la Base de connaissances Microsoft :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265 sur le dépannage dans Transport Microsoft Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Pour plus d'informations sur d'autres compteurs WMI Categorizer, voir les articles suivants d'Exchange Server Analyzer :

  • Avertissement d'échec de message SMTP - Échec du service d'annuaire du catégoriseur

  • Avertissement d'échec de message SMTP - Échec d'ouverture de session du catégoriseur

  • Avertissement d'échec de message SMTP - Erreur non renouvelable du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du catégoriseur dû à une mémoire insuffisante

  • Avertissement d'échec de message SMTP - Erreur renouvelable du catégoriseur


Avertissement d'échec de message SMTP - Échec d'ouverture de session du catégoriseur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé CatCategorizationsfailedDSlogonfailure. Cette valeur représente le nombre de catégorisations qui ont échoué en raison d'un échec d'ouverture de session du service d'annuaire. Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de CatCategorizationsfailedDSlogonfailure par celle de SystemUpTime est supérieur à 50, un avertissement s'affiche.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP et détermine les opérations à effectuer. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou encore à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui passe par le moteur avancé de files d'attente. Il assure la résolution d'adresse et le transfert de messages, définit les indicateurs de conversion de contenu, étend les listes de distribution, applique des paramètres globaux, génère des notifications d'état de remise et exécute la détection d'itinéraire de destinataire suppléant, la bifurcation, la journalisation et de nombreuses autres fonctions.

Dès qu'un message entre dans le catégoriseur, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Cet avertissement indique qu'en moyenne, au moins 50 tentatives de connexion du service d'annuaire effectuées par le catégoriseur de messages échouent chaque jour en raison d'échecs d'ouverture de session. Plusieurs causes sont possibles, notamment des problèmes d'accès au service d'annuaire (DSAccess), la latence ou des échecs de réplication d'annuaire, des serveurs de catalogue global surchargés et des problèmes avec DNS.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Vérifiez si les journaux d'événements de l'ordinateur Exchange Server contiennent des erreurs.

  2. Si vous ne trouvez pas d'événements permettant de résoudre le problème, envisagez d'augmenter l'enregistrement des diagnostics du catégoriseur MSExchangeTransport au niveau maximal. Dès que l'enregistrement des diagnostics est activé, revérifiez si le journal des événements contient des erreurs. Si la configuration de l'enregistrement des diagnostics sur le niveau maximal ne produit aucune entrée du journal des événements, configurez-le sur le niveau 7 en utilisant le Registre. À ce niveau, l'ID d'événement 9000 généré par le catégoriseur de messages sera enregistré. Il détaille la fonction, la raison de l'échec, le nom du destinataire qui a échoué et le type de destinataire. Pour définir l'enregistrement des diagnostics sur le niveau 7 :

    1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    2. Naviguez jusqu'à :

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Dans le volet droit, double-cliquez sur 2 Categorizer, définissez les données de la valeur sur 7, puis cliquez sur OK.

    4. Fermez l'Éditeur du Registre.

      Remarque :
      Lorsque vous avez terminé le dépannage, redéfinissez les données de la valeur pour 2 Categorizer sur 0.

  3. Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  4. Examinez les messages de notification d'état de remise en cours de génération. Ces messages, qui peuvent comprendre des rapports de non-remise, décrivent des messages d'échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  5. Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  6. Utilisez l'outil Archive Sink pour archiver et analyser les messages entrants et sortants d'Exchange Server.

  7. Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

Pour la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, voir l'article 284204 de la Base de connaissances Microsoft sur les notifications d'état de remise dans Exchange Server et Small Business Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, voir les articles suivants de la Base de connaissances :

  • 262162 sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856 sur la procédure d'activation du suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905 sur les ID d'événements du suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864 sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, voir l'article de la Webdiffusion du Support Technique de Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, voir l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour des informations générales sur le dépannage de problèmes liés au transport, voir les articles suivants de la Base de connaissances :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265 sur le dépannage dans Transport Microsoft Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Pour plus d'informations sur d'autres compteurs WMI Categorizer, voir les articles suivants d'Exchange Server Analyzer

  • Avertissement d'échec de message SMTP - Échec du service d'annuaire du catégoriseur

  • Avertissement d'échec de message SMTP - Échec des recherches d'adresse du catégoriseur

  • Avertissement d'échec de message SMTP - Erreur non renouvelable du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du catégoriseur dû à une mémoire insuffisante

  • Avertissement d'échec de message SMTP - Erreur renouvelable du catégoriseur


Avertissement d'échec de message SMTP - Échec du service d'annuaire du catégoriseur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-03-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé CatCategorizationsfailedDSconnectionfailure. La valeur de cette clé représente le nombre de catégorisations qui ont échoué à cause d'un échec du service de connexion du service d'annuaire. Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de CatCategorizationsfailedDSconnectionfailure par celle de SystemUpTime est supérieur à 50, un avertissement s'affiche.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP et détermine les opérations à effectuer. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou encore à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui passe par le moteur avancé de files d'attente. Il assure la résolution d'adresse et le transfert de messages, définit les indicateurs de conversion de contenu, étend les listes de distribution, applique des paramètres globaux, génère des notifications d'état de remise et exécute la détection d'itinéraire de destinataire suppléant, la bifurcation, la journalisation et de nombreuses autres fonctions.

Lorsqu'un message entre dans le catégoriseur de messages, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Cet avertissement indique qu'en moyenne, au moins 50 tentatives de connexion du service d'annuaire effectuées par le catégoriseur de messages échouent chaque jour. Plusieurs causes sont possibles, notamment des problèmes d'accès au service d'annuaire (DSAccess), la latence ou des échecs de réplication d'annuaire, des serveurs de catalogue global surchargés et des problèmes avec DNS.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Vérifiez si les journaux d'événements de l'ordinateur Exchange Server contiennent des erreurs.

  2. Si vous ne trouvez pas d'événements permettant de résoudre le problème, envisagez d'augmenter l'enregistrement des diagnostics du catégoriseur MSExchangeTransport au niveau maximal. Dès que l'enregistrement des diagnostics est activé, revérifiez si le journal des événements contient des erreurs. Si la configuration de l'enregistrement des diagnostics sur le niveau maximal ne produit aucune entrée du journal des événements, configurez-le sur le niveau 7 en utilisant le Registre. À ce niveau, l'ID d'événement 9000 généré par le catégoriseur de messages sera enregistré. Il détaille la fonction, la raison de l'échec, le nom du destinataire qui a échoué et le type de destinataire. Pour définir l'enregistrement des diagnostics sur le niveau 7 :

    1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    2. Naviguez jusqu'à :

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Dans le volet droit, double-cliquez sur 2 Categorizer (Catégoriseur 2), définissez les données de valeur sur 7, puis cliquez sur OK.

    4. Fermez l'Éditeur du Registre.

      Remarque :
      Lorsque vous avez terminé le dépannage, redéfinissez les données de la valeur pour 2 Categorizer sur 0.

  3. Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  4. Examinez les messages de notification d'état de remise en cours de génération. Ces messages, qui peuvent comprendre des rapports de non-remise, décrivent des messages d'échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  5. Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  6. Utilisez l'outil Archive Sink pour archiver et analyser les messages entrants et sortants d'Exchange Server.

  7. Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

Pour la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, voir l'article 284204 de la Base de connaissances Microsoft sur les notifications d'état de remise dans Exchange 2000 Server et dans Small Business Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 262162 sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856 sur la procédure d'activation du suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905 sur les ID d'événements du suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864 sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, voir l'article de la Webdiffusion du Support Technique de Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, voir l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour des informations générales sur le dépannage de problèmes liés au transport, voir les articles suivants de la Base de connaissances Microsoft :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265 sur le dépannage dans Transport Microsoft Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Pour plus d'informations sur d'autres compteurs WMI Categorizer, voir les articles suivants d'Exchange Server Analyzer :

  • Avertissement d'échec de message SMTP - Échec des recherches d'adresse du catégoriseur

  • Avertissement d'échec de message SMTP - Échec d'ouverture de session du catégoriseur

  • Avertissement d'échec de message SMTP - Erreur non renouvelable du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du catégoriseur dû à une mémoire insuffisante

  • Avertissement d'échec de message SMTP - Erreur renouvelable du catégoriseur


Avertissement d'échec de message SMTP - Erreur non renouvelable du catégoriseur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé CatCategorizationsfailednonretryableerror. La valeur de cette clé représente le nombre de catégorisations qui ont échoué en raison d'une erreur matérielle (non renouvelable). Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de CatCategorizationsfailednonretryableerror par celle de SystemUpTime est supérieur à 50, un avertissement s'affiche.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP et détermine les opérations à effectuer. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou encore à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui passe par le moteur avancé de files d'attente. Il assure la résolution d'adresse et le transfert de messages, définit les indicateurs de conversion de contenu, étend les listes de distribution, applique des paramètres globaux, génère des notifications d'état de remise et exécute la détection d'itinéraire de destinataire suppléant, la bifurcation, la journalisation et de nombreuses autres fonctions.

Dès qu'un message entre dans le catégoriseur, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Cet avertissement indique que 50 erreurs matérielles ou davantage se produisent chaque jour en moyenne. Plusieurs causes sont possibles, notamment des problèmes d'accès au service d'annuaire (DSAccess), la latence ou des échecs de réplication d'annuaire, des serveurs de catalogue global surchargés et des problèmes avec DNS.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Vérifiez si les journaux d'événements de l'ordinateur Exchange Server contiennent des erreurs.

  2. Si vous ne trouvez pas d'événements permettant de résoudre le problème, envisagez d'augmenter l'enregistrement des diagnostics du catégoriseur MSExchangeTransport au niveau maximal. Lorsque l'enregistrement des diagnostics est activé, revérifiez le journal des événements d'erreurs. Si la configuration de l'enregistrement des diagnostics sur le niveau maximal ne produit aucune entrée du journal des événements, configurez-le sur le niveau 7 en utilisant le Registre. À ce niveau, l'ID d'événement 9000 généré par le catégoriseur de messages sera enregistré. Il détaille la fonction, la raison de l'échec, le nom du destinataire qui a échoué et le type de destinataire. Pour définir l'enregistrement des diagnostics sur le niveau 7 :

    1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    2. Naviguez jusqu'à :

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Dans le volet droit, double-cliquez sur 2 Categorizer (Catégoriseur 2), définissez les données de valeur sur 7, puis cliquez sur OK.

    4. Fermez l'Éditeur du Registre.

      Remarque :
      Lorsque vous avez terminé le dépannage, redéfinissez les données de la valeur pour 2 Categorizer sur 0.

  3. Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  4. Examinez les messages de notification d'état de remise en cours de génération. Ces messages, qui peuvent comprendre des rapports de non-remise, décrivent des messages d'échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  5. Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  6. Utilisez l'outil Archive Sink pour archiver et analyser les messages entrants et sortants d'Exchange Server.

  7. Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

Pour la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, voir l'article 284204 de la Base de connaissances Microsoft sur les notifications d'état de remise dans Exchange 2000 Server et dans Small Business Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 262162 sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856 sur la procédure d'activation du suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905 sur les ID d'événements du suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864 sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, voir l'article de la Webdiffusion du Support Technique de Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, voir l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour des informations générales sur le dépannage de problèmes liés au transport, voir les articles suivants de la Base de connaissances Microsoft :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265 sur le dépannage dans Transport Microsoft Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Pour plus d'informations sur d'autres compteurs WMI Categorizer, voir les articles suivants d'Exchange Server Analyzer :

  • Avertissement d'échec de message SMTP - Échec des recherches d'adresse du catégoriseur

  • Avertissement d'échec de message SMTP - Échec d'ouverture de session du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du service d'annuaire du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du catégoriseur dû à une mémoire insuffisante

  • Avertissement d'échec de message SMTP - Erreur renouvelable du catégoriseur


Avertissement d'échec de message SMTP - Échec du catégoriseur dû à une mémoire insuffisante
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-03-28

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé CatCategorizationsfailedOutOfMemory. La valeur de cette clé représente le nombre de catégorisations qui ont échoué en raison d'une mémoire disponible insuffisante. Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de CatCategorizationsfailedOutOfMemory par celle de SystemUpTime est supérieur à 50, un avertissement s'affiche.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP et détermine les opérations à effectuer. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou encore à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui passe par le moteur avancé de files d'attente. Il assure la résolution d'adresse et le transfert de messages, définit les indicateurs de conversion de contenu, étend les listes de distribution, applique des paramètres globaux, génère des notifications d'état de remise et exécute la détection d'itinéraire de destinataire suppléant, la bifurcation, la journalisation et de nombreuses autres fonctions.

Dès qu'un message entre dans le catégoriseur, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Cet avertissement indique qu'une moyenne de 50 catégorisations ou plus échoue chaque jour en raison d'une mémoire disponible insuffisante. Plusieurs causes sont possibles, notamment des problèmes d'accès au service d'annuaire (DSAccess), la latence ou des échecs de réplication d'annuaire, des serveurs de catalogue global surchargés et des problèmes avec DNS.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Vérifiez si les journaux d'événements de l'ordinateur Exchange Server contiennent des erreurs.

  2. Si vous ne trouvez pas d'événements permettant de résoudre le problème, envisagez d'augmenter l'enregistrement des diagnostics du catégoriseur MSExchangeTransport au niveau maximal. Lorsque l'enregistrement des diagnostics est activé, revérifiez le journal des événements d'erreurs. Si la configuration de l'enregistrement des diagnostics sur le niveau maximal ne produit aucune entrée du journal des événements, configurez-le sur le niveau 7 en utilisant le Registre. À ce niveau, l'ID d'événement 9000 généré par le catégoriseur de messages sera enregistré. Il détaille la fonction, la raison de l'échec, le nom du destinataire qui a échoué et le type de destinataire. Pour définir l'enregistrement des diagnostics sur le niveau 7 :

    1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    2. Naviguez jusqu'à :

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Dans le volet droit, double-cliquez sur 2 Categorizer (Catégoriseur 2), définissez les données de valeur sur 7, puis cliquez sur OK.

    4. Fermez l'Éditeur du Registre.

      Remarque :
      Lorsque vous avez terminé le dépannage, redéfinissez les données de la valeur pour 2 Categorizer sur 0.

  3. Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  4. Examinez les messages de notification d'état de remise en cours de génération. Ces messages, qui peuvent comprendre des rapports de non-remise, décrivent des messages d'échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  5. Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  6. Utilisez l'outil Archive Sink pour archiver et analyser les messages entrants et sortants d'Exchange Server.

  7. Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

Pour la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, voir l'article 284204 de la Base de connaissances Microsoft sur les notifications d'état de remise dans Exchange 2000 Server et dans Small Business Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 262162 sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856 sur Procédure d'activation du suivi des messages dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905 sur les ID d'événements du suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864 sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, voir l'article de la Webdiffusion du Support Technique de Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, voir l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour des informations générales sur le dépannage de problèmes liés au transport, voir les articles suivants de la Base de connaissances Microsoft :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265 sur le dépannage des problèmes de transport dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=305 2 &kbid=257265).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Pour plus d'informations sur d'autres compteurs WMI Categorizer, voir les articles suivants d'Exchange Server Analyzer :

  • Avertissement d'échec de message SMTP - Échec des recherches d'adresse du catégoriseur

  • Avertissement d'échec de message SMTP - Échec d'ouverture de session du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du service d'annuaire du catégoriseur

  • Avertissement d'échec de message SMTP - Erreur non renouvelable du catégoriseur

  • Avertissement d'échec de message SMTP - Erreur renouvelable du catégoriseur


Avertissement d'échec de message SMTP - Erreur renouvelable du catégoriseur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-03-20

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_PerfRawData_SMTPSVC_SMTPServer pour déterminer la valeur de la clé CatCategorizationsfailedretryableerror. La valeur de cette clé représente le nombre de classifications qui ont échoué avec une erreur renouvelable. Exchange Server Analyzer interroge également la clé WMI Win32_PerfRawData_PerfOS_System pour déterminer la valeur de SystemUpTime.

Si Exchange Server Analyzer détermine que la valeur de la clé SystemUpTime est supérieure à 0 et que le résultat de la division de la valeur de CatCategorizationsfailedretryableerror par celle de SystemUpTime est supérieur à 500, un avertissement s'affiche.

Le catégoriseur de messages examine les messages arrivant à un serveur SMTP et détermine les opérations à effectuer. Les messages peuvent être destinés à la banque d'informations locale ou à un hôte distant en utilisant l'Agent de transfert de messages (MTA), ou encore à un hôte distant en utilisant SMTP. Le catégoriseur gère également l'extension de la liste de distribution. Le catégoriseur est un plug-in du moteur avancé de files d'attente qui exécute des requêtes LDAP sur des serveurs de catalogue global sur le port TCP 3268. Le catégoriseur est essentiellement un ensemble de récepteurs d'événements qui effectue une résolution d'adresse avancée sur chaque message qui passe par le moteur avancé de files d'attente. Il assure la résolution d'adresse et le transfert de messages, définit les indicateurs de conversion de contenu, étend les listes de distribution, applique des paramètres globaux, génère des notifications d'état de remise et exécute la détection d'itinéraire de destinataire suppléant, la bifurcation, la journalisation et de nombreuses autres fonctions.

Dès qu'un message entre dans le catégoriseur, ce dernier résout l'expéditeur de l'enveloppe en recherchant l'adresse dans les attributs d'adresse proxy dans le service d'annuaire Active Directory®. Le catégoriseur résout également le destinataire de l'enveloppe en recherchant chaque adresse dans l'attribut des adresses proxy dans Active Directory. Par exemple, si la liste comprend une liste de distribution, il l'étend pour inclure ces membres si l'extension de la liste de distribution est autorisée sur le serveur.

Cet avertissement indique qu'une moyenne de 500 catégorisations ou plus échoue chaque jour avec une erreur renouvelable. Plusieurs causes sont possibles, notamment des problèmes d'accès au service d'annuaire (DSAccess), la latence ou des échecs de réplication d'annuaire, des serveurs de catalogue global surchargés et des problèmes avec DNS.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour supprimer cet avertissement

  1. Vérifiez si les journaux d'événements de l'ordinateur Exchange Server contiennent des erreurs.

  2. Si vous ne trouvez pas d'événements permettant de résoudre le problème, envisagez d'augmenter l'enregistrement des diagnostics du catégoriseur MSExchangeTransport au niveau maximal. Lorsque l'enregistrement des diagnostics est activé, revérifiez le journal des événements d'erreurs. Si la configuration de l'enregistrement des diagnostics sur le niveau maximal ne produit aucune entrée du journal des événements, configurez-le sur le niveau 7 en utilisant le Registre. À ce niveau, l'ID d'événement 9000 généré par le catégoriseur de messages sera enregistré. Il détaille la fonction, la raison de l'échec, le nom du destinataire qui a échoué et le type de destinataire. Pour définir l'enregistrement des diagnostics sur le niveau 7 :

    1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

    2. Naviguez jusqu'à :

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Dans le volet droit, double-cliquez sur 2 Categorizer (Catégoriseur 2), définissez les données de valeur sur 7, puis cliquez sur OK.

    4. Fermez l'Éditeur du Registre.

      Remarque :
      Lorsque vous avez terminé le dépannage, redéfinissez les données de la valeur pour 2 Categorizer sur 0.

  3. Vérifiez qu'Exchange Server dispose d'une connectivité vers au moins un serveur de catalogue global. L'outil Moniteur réseau de Windows s'avère très utile pour cela.

  4. Examinez les messages de notification d'état de remise en cours de génération. Ces messages, qui peuvent comprendre des rapports de non-remise, décrivent des messages d'échec permanent et temporaire qui aboutissent souvent à des erreurs de remise permanentes.

  5. Utilisez le suivi des messages pour libérer les messages bloqués dans le catégoriseur.

  6. Utilisez l'outil Archive Sink pour archiver et analyser les messages entrants et sortants d'Exchange Server.

  7. Contrôlez les compteurs de performance du catégoriseur à l'aide du Moniteur système.

Pour la liste des notifications d'état de remise et des rapports de non-remise générés par Exchange Server et Microsoft Windows Small Business Server, voir l'article 284204 de la Base de connaissances Microsoft sur les notifications d'état de remise dans Exchange 2000 Server et dans Small Business Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204).

Pour plus d'informations sur l'utilisation du Centre de suivi des messages dans Exchange Server, voir les articles suivants de la Base de connaissances Microsoft :

  • 262162 sur l'utilisation du Centre de suivi des messages pour effectuer le suivi d'un message (http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162).

  • 246856 sur la procédure d'activation du suivi des messages dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856).

  • 821905 sur les ID d'événements du suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905).

  • 823864 sur les fonctionnalités améliorées de suivi des messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864).

Pour plus d'informations sur le dépannage de problèmes du catégoriseur de messages, voir l'article de la Webdiffusion du Support Technique de Microsoft sur le dépannage de problèmes du catégoriseur de messages et des rapports de non-remise dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137).

Pour plus d'informations sur l'outil Archive Sink, voir l'article 307798 de la Base de connaissances Microsoft sur l'utilitaire Archive Sink disponible dans le Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798).

Pour des informations générales sur le dépannage de problèmes liés au transport, voir les articles suivants de la Base de connaissances Microsoft :

  • 821910 sur la procédure de dépannage des problèmes de transport pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910).

  • 257265 sur le dépannage dans Transport Microsoft Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265).

Les compteurs de performance du catégoriseur de messages sont publiés séparément pour chaque instance de serveur virtuel SMTP. Pour la liste des compteurs de performance disponibles relatifs au catégoriseur de messages, voir l'article 231734 de la Base de connaissances Microsoft sur les compteurs de l'Analyseur de performances pour le catégoriseur de messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734).

Pour plus d'informations sur d'autres compteurs WMI Categorizer, voir les articles suivants de l'outil Exchange Server Analyzer Tool :

  • Avertissement d'échec de message SMTP - Échec des recherches d'adresse du catégoriseur

  • Avertissement d'échec de message SMTP - Échec d'ouverture de session du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du service d'annuaire du catégoriseur

  • Avertissement d'échec de message SMTP - Erreur non renouvelable du catégoriseur

  • Avertissement d'échec de message SMTP - Échec du catégoriseur dû à une mémoire insuffisante


Les données de file d'attente de messagerie SMTP sont écrites dans un dossier compressé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Compressed pour le dossier de file d'attente de messagerie SMTP. Si Exchange Server Analyzer détecte que la valeur de Compressed est définie sur True, un avertissement s'affiche.

Lorsque des messages arrivent sur l'ordinateur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange. Si le dossier dans lequel est enregistrée la file d'attente de messagerie SMTP est compressé, les performances d'Exchange peuvent être considérablement altérées. Par conséquent, la compression du dossier dans lequel la file d'attente de messagerie SMTP est stockée n'est pas prise en charge.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume compressé. Lorsque vous stockez vos fichiers de données Exchange sur un volume compressé, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour désactiver la compression de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver la compression de fichiers et cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

Pour déplacer le dossier Mailroot sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez sur Groupes d'administration, développez votre groupe d'administration, développez Serveurs et votre serveur, puis Protocoles et SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Arrêter.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Sous l'onglet Messages, en regard de la zone Répertoire de file d'attente, cliquez sur Parcourir et entrez le chemin d'accès du nouvel emplacement du dossier de file d'attente.

  6. Cliquez sur OK.

  7. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer.

Pour plus d'informations sur le déplacement du dossier Mailroot, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


Les données de file d'attente de messagerie SMTP sont écrites dans un dossier crypté
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32 Directory pour déterminer la valeur de la clé Encrypted pour le dossier de file d'attente de messagerie SMTP (Simple Mail Transfer Protocol). Si Exchange Server Analyzer détecte que la valeur de la clé Encrypted est définie sur True, un avertissement s'affiche.

Lorsque des messages arrivent sur l'ordinateur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange. Si le dossier dans lequel est enregistrée la file d'attente de messagerie SMTP est crypté, les performances d'Exchange peuvent être sérieusement altérées. Par conséquent, le cryptage du dossier dans lequel la file d'attente de messagerie SMTP est stockée n'est pas pris en charge.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume crypté du système de fichiers de cryptage (EFS). Lorsque vous stockez vos fichiers de données Exchange sur un volume crypté, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour sécuriser vos fichiers de données Exchange, il est recommandé d'empêcher l'accès non autorisé à l'ordinateur Exchange et d'utiliser le format de message S/MIME pour crypter des données de message.

Pour corriger cette erreur, vous devez désactiver le cryptage de fichiers dans le dossier de file d'attente de messagerie SMTP ou déplacer ce dossier vers un emplacement où le cryptage n'est pas activé.

Pour désactiver le cryptage de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver le cryptage de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Crypter le contenu pour sécuriser les données, puis cliquez sur OK.

Pour déplacer le dossier de file d'attente de messagerie SMTP sur Exchange 2000 Server ou Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez sur Groupes d'administration, développez votre groupe d'administration, développez Serveurs et votre serveur, puis Protocoles et SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Arrêter.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Sous l'onglet Messages, en regard de la zone Répertoire BadMail, cliquez sur Parcourir et entrez le chemin d'accès du nouvel emplacement du dossier de file d'attente.

  6. Cliquez sur OK.

  7. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer.

Pour plus d'informations sur le déplacement du dossier Mailroot, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Pour plus d'informations sur les fichiers de données Exchange Server et EFS, voir l'article 834638 de la Base de connaissances Microsoft, qui contient des informations sur le stockage de fichiers de données sur un volume crypté dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Pour plus d'informations sur la sécurisation des messages dans Exchange Server 2003, voir le Guide de sécurité des messages Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47574).


Les données de file d'attente de messagerie SMTP sont écrites sur une partition non NTFS
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé FSName pour le répertoire de file d'attente SMTP d'Exchange. Si Exchange Server Analyzer détermine que la valeur de la clé FSName n'est pas égale à NTFS File System, une erreur s'affiche.

Microsoft ne prend pas en charge le stockage de fichiers de données Exchange sur des volumes non NTFS. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml.

Si vous rencontrez cette erreur, vous devez déplacer le répertoire de file d'attente SMTP dans un dossier sur un lecteur NTFS. Si le lecteur sur lequel le répertoire de file d'attente est enregistré est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS.

Pour déplacer la file d'attente SMTP vers un autre dossier

  1. Ouvrez le Gestionnaire système Exchange.

  2. Cliquez sur Groupes d'administration, développez votre groupe d'administration, développez Serveurs et votre serveur, puis Protocoles et SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Arrêter.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Sous l'onglet Messages, en regard de la zone Répertoire BadMail, cliquez sur Parcourir et entrez le chemin d'accès du nouvel emplacement du dossier de file d'attente.

  6. Cliquez sur OK.

  7. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer.

Pour plus d'informations sur le déplacement du dossier Mailroot, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Si le lecteur sur lequel les fichiers sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS. Pour plus d'informations sur l'utilisation de l'outil de ligne de commande convert.exe pour convertir une partition FAT en partition NTFS, voir l'article 214579 de la Base de connaissances Microsoft sur l'utilisation de Convert.exe pour convertir une partition en système de fichiers NTFS (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


La valeur SMTP MaxDSNSize a été définie manuellement
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit la sous-clé de Registre suivante pour déterminer si la taille maximale des messages de notification d'état de remise (DSN) a été remplacée manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Si Exchange Server Analyzer détecte que la valeur MaxDSNSize est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur de Registre MaxDSNSize permet à un ordinateur exécutant Exchange 2000 Server Service Pack 2 (SP2) ou version ultérieure de supprimer les pièces jointes s'il est impossible d'envoyer un message. Si vous activez cette option, vous pouvez enregistrer les ressources du serveur et les ressources réseau. Toutefois, cette implémentation de la suppression de pièce jointe SMTP présente des inconvénients.

Si vous activez cette option pour supprimer les pièces jointes de la notification d'échec de remise, les détails nécessaires pour afficher la notification dans le volet de visualisation sont également supprimés et l'expéditeur du message ne peut pas utiliser l'option Renvoyer. Si l'expéditeur du message tente d'utiliser l'option Renvoyer depuis la notification d'échec de remise, il reçoit le message d'erreur suivant :

« Impossible de renvoyer le message. La notification d'échec de remise ne contient pas suffisamment d'informations sur le message d'origine. Pour renvoyer le message, ouvrez-le dans votre dossier Éléments envoyés, cliquez sur le menu Actions et cliquez sur Renvoyer ce message ».

Toutefois, l'expéditeur du message ne peut pas renvoyer le message même en utilisant la méthode décrite dans le message d'erreur. Par conséquent, il est recommandé d'utiliser cette option avec prudence.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Modification de la valeur de Registre MaxDSNSize

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Créez une valeur de Registre DWORD appelée MaxDSNSize et définissez les données de valeur (en octets) sur la quantité souhaitée.

  4. Quittez l'Éditeur du Registre et redémarrez le service SMTP pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la valeur de Registre MaxDSNSize, consultez les articles suivants de la Base de connaissances :

  • 308303 sur l'option de suppression des pièces jointes des messages qui génèrent une notification d'échec de remise (http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303).

  • 323484 sur la description du format de message Internet Multipart/Report dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484).


La valeur de Registre SMTP MaxPendingCat n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé MaxPendingCat a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Il est recommandé de ne modifier les valeurs des files d'attente par défaut qu'après mûre réflexion. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur Exchange.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


La valeur SMTP MaxMessageObjects a été définie sur une valeur trop faible
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le nombre maximal de messages électroniques que le système peut allouer :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Si Exchange Server Analyzer détecte que la valeur de MaxMessageObjects est inférieure à 30 001, un avertissement s'affiche.

Lorsque la file d'attente contient le nombre maximal de messages, aucun message entrant supplémentaire n'est accepté par SMTP (Simple Mail Transfer Protocol). Chaque message électronique qui réside dans la file d'attente SMTP utilise au moins 4 kilo-octets (Ko) de mémoire ; par conséquent, une très grande file d'attente peut engendrer des problèmes d'insuffisance de mémoire.

La valeur de MaxMessageObjects n'est pas présente par défaut et le nombre maximal de messages est défini sur 100 000. Une valeur inférieure de MaxMessageObjects réduit le nombre maximal de messages pouvant résider dans la file d'attente et donc l'encombrement maximal de mémoire pour SMTP. Lorsque cette limite est atteinte, chaque connexion SMTP établie avec le serveur renvoie une erreur de mémoire insuffisante.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour limiter le nombre de messages SMTP pouvant résider dans la file d'attente

  1. Lancez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Exchange

  3. Cliquez avec le bouton droit sur la clé Exchange, puis cliquez sur Nouvelle clé. Nommez la nouvelle clé MailMsg.

  4. Cliquez avec le bouton droit sur la clé MailMsg, puis cliquez sur Nouvelle valeur DWORD.

  5. Cliquez avec le bouton droit sur la nouvelle valeur, cliquez sur Renommer, puis entrez MaxMessageObjects.

  6. Double-cliquez sur la valeur MaxMessageObjects et définissez-la sur le nombre maximal souhaité de messages pouvant résider simultanément dans les files d'attente. Si vous ne devez pas traiter davantage de messages, une valeur maximale de 100 000 est recommandée.

  7. Quittez l'Éditeur du Registre et redémarrez le service SMTP pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur la définition des limites des messages en attente, voir l'article 258748 de la Base de connaissances Microsoft sur la procédure de définition d'une limite du nombre de messages SMTP en attente (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748).


Le paramètre de Registre SMTP MaxMessageObjects a été modifié et diffère de sa valeur par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le nombre maximal de messages électroniques que le système peut allouer :

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Si Exchange Server Analyzer détecte que la valeur de MaxMessageObjects est supérieure à 0, un message indiquant une configuration autre que celle par défaut s'affiche.

Lorsque la file d'attente contient le nombre maximal de messages, aucun message entrant supplémentaire n'est accepté par SMTP. Chaque message électronique qui réside dans la file d'attente SMTP utilise au moins 4 kilo-octets (Ko) de mémoire ; par conséquent, une très grande file d'attente peut engendrer des problèmes d'insuffisance de mémoire.

La valeur de MaxMessageObjects n'est pas présente par défaut et le nombre maximal de messages est défini sur 100 000. Une valeur inférieure de MaxMessageObjects réduit le nombre maximal de messages pouvant résider dans la file d'attente et donc l'encombrement maximal de mémoire pour SMTP. Lorsque cette limite est atteinte, chaque connexion SMTP établie avec le serveur renvoie une erreur de mémoire insuffisante.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour limiter le nombre de messages SMTP pouvant résider dans la file d'attente

  1. Lancez un Éditeur du Registre tel que Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\Software\Microsoft\Exchange

  3. Cliquez avec le bouton droit sur la clé Exchange, puis cliquez sur Nouvelle clé. Nommez la nouvelle clé MailMsg.

  4. Cliquez avec le bouton droit sur la clé MailMsg, puis cliquez sur Nouvelle valeur DWORD.

  5. Cliquez avec le bouton droit sur la nouvelle valeur, cliquez sur Renommer, puis entrez MaxMessageObjects.

  6. Double-cliquez sur la valeur MaxMessageObjects et définissez-la sur le nombre maximal souhaité de messages pouvant résider simultanément dans les files d'attente. À moins de devoir traiter plusieurs messages, il est recommandé d'utiliser une valeur maximale de 100 000.

  7. Quittez l'Éditeur du Registre et redémarrez le service SMTP pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986).

Pour plus d'informations sur la définition des limites des messages en attente, voir l'article 258748 de la Base de connaissances sur la procédure de définition d'une limite du nombre de messages SMTP en attente (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748).


La valeur de Registre SMTP MaxPercentPoolThreads a été définie manuellement
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si des threads de pool supplémentaires ont été configurées manuellement :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

Si Exchange Server Analyzer détecte que la valeur MaxPercentPoolThreads est présente et configurée, un message indiquant une configuration autre que celle par défaut s'affiche.

Cinq files d'attente de travail dans SMTP utilisent un pool de threads appelé thread ATQ. Par défaut, deux de ces files d'attente sont conçues pour utiliser au maximum 90 pour cent des threads disponibles. Ce pool de threads est partagé par le processus qui accepte les requêtes POP et IMAP. Par conséquent, dans un scénario de chargement modéré à élevé, la situation, dans laquelle SMTP peut conserver des ressources des services POP et IMAP, peut se présenter.

Vous pouvez réserver des threads adéquates pour POP et IMAP en limitant le pourcentage de threads que SMTP peut utiliser. Pour effectuer cette modification, vous devez augmenter le nombre global de threads à la disposition des services IIS. Dans ce cas, le seul compromis consiste à utiliser la mémoire augmentée pour les threads supplémentaires.

Deux valeurs de Registre permettent de contrôler le pourcentage SMTP de threads et les threads supplémentaires par processeur :

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Valeur : AdditionalPoolThreadsPerProc

Type : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Valeur : MaxPercentPoolThreads

Type : REG_DWORD

Ces deux valeurs de Registre doivent être ajustées sur les ordinateurs Exchange Server en clusters si une importante activité SMTP entraîne l'échec de POP3, IMAP4 ou des deux ressources. Les formules suivantes permettent de calculer la valeur optimale pour votre cluster :

Valeur de Registre | Formule
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * nombre de serveurs virtuels de protocole)

Par exemple, dans un cluster Exchange Server avec deux serveurs virtuels de protocole, la formule pour MaxPercentPoolThreads est : 90 / (2*2) = 22. Lors du calcul de la valeur MaxPercentPoolThreads, si vous obtenez une valeur comprenant une virgule, vous devez arrondir le résultat au nombre entier inférieur. Lors du calcul de la valeur AdditionalPoolThreadsPerProc, si vous obtenez une valeur supérieure à 200, vous devez également affecter la valeur résultante à une valeur de Registre supplémentaire :

Emplacement : HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Valeur : PoolThreadLimit

Type : REG_DWORD

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Configuration du paramètre optimal sur votre cluster Exchange

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Créez une valeur de Registre DWORD appelée AdditionalPoolThreadsPerProc et définissez ses données de valeur sur le nombre approprié en fonction des formules ci-dessus.

  4. Créez une valeur de Registre DWORD appelée MaxPercentPoolThreads et définissez ses données de valeur sur le nombre approprié en fonction des formules ci-dessus.

  5. Quittez l'Éditeur du Registre et redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur le problème spécifique de ressource de cluster décrit dans cet article, consultez l'article 281868 de la Base de connaissances sur les serveurs virtuels POP\IMAP4 qui basculent à plusieurs reprises en cas de charge élevée (http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868).


La valeur de Registre SMTP MsgHandleAsyncThreshold a été ajoutée manuellement, mais risque de ne plus être nécessaire
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivantes pour déterminer si le nombre maximal de descripteurs de fichiers asynchrones des services IIS a été modifié par rapport à la valeur par défaut de 1 000 :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

Si Exchange Server Analyzer détecte que MsgHandleAsyncThreshold est présent et configuré avec une autre valeur, un avertissement s'affiche.

La valeur MsgHandleAsyncThreshold spécifie le nombre maximal de descripteurs de fichiers asynchrones que les services IIS peuvent utiliser. Les descripteurs de fichiers sont mis en cache pour améliorer les performances car une fois mis en cache, ils empêchent le serveur d'effectuer des entrées/sorties (E/S) redondantes et des cycles de processeur. Chaque fois que la pile de transport SMTP d'un ordinateur Exchange Server reçoit un message, celui-ci est transféré au système de fichiers, où il attend d'être acheminé vers sa destination. Pour écrire au système de fichiers, la pile de transport SMTP obtient un descripteur de fichier et lui transfère le message. Chaque descripteur de fichier utilise environ 2 kilo-octets (Ko) de mémoire de réserve paginée. Le nombre par défaut de descripteurs de fichiers de cache des services IIS est de 800 par tranche de 32 Mo.

Avant Exchange 2000 Server avec Service Pack 2 (SP2), les serveurs Exchange qui maintenaient de grandes files de messages SMTP (au moins 1 000 messages, en moyenne) se sont heurtés à des contraintes de performances en raison d'un paramètre par défaut du service SMTP, qui consiste en un maximum de 1 000 descripteurs de fichiers. Comme Exchange 2000 Server a par défaut utilisé un nombre maximal de 1 000 descripteurs de fichiers, le service SMTP n'a pu écrire que 1 000 messages simultanés dans le système de fichiers.

Pour améliorer les performances de ces grands systèmes, trois entrées de Registre ont souvent été ajustées simultanément de manière à augmenter le nombre maximal de descripteurs de fichiers pouvant être ouverts par le service SMTP (pour pouvoir traiter davantage de messages) et à réduire le nombre de descripteurs de fichiers ouverts pour le système de fichiers à installer, un autre composant Exchange (pour éviter de manquer de mémoire lorsque la file d'attente est grande). Ces valeurs de Registre, qui n'existaient pas par défaut et ont donc dû être ajoutées manuellement, sont répertoriées ci-dessous :

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valeur : MsgHandleThreshold

Type : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valeur : MsgHandleAsyncThreshold

Type : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valeur : FileCacheMaxHandles

Type : REG_DWORD

Les entrées MsgHandleThreshold et MsgHandleAsyncThreshold sont généralement définies sur la même valeur (souvent une valeur supérieure à 1 000) et la valeur FileCacheMaxHandles passe généralement de 800 à 600.

Cette valeur de Registre n'est pas présente par défaut car Exchange 2000 Server SP2 et ultérieur détermine dynamiquement les valeurs optimales à utiliser. Si ce serveur Exchange exécute Exchange 2000 Server avec Service Pack 1 ou antérieur, il est recommandé d'effectuer une mise à niveau vers le Service Pack et l'ensemble de mises à jour les plus récents. Après la mise à niveau vers le dernier code, vous pouvez supprimer ces entrées de Registre.

Exchange Server 2003 calcule dynamiquement les paramètres appropriés pour les descripteurs de fichiers SMTP pour que ces paramètres ne soient plus nécessaires. Sauf instruction contraire des services de support technique Microsoft, avant la mise à niveau de tout ordinateur Exchange 2000 Server avec ces paramètres vers Exchange Server 2003, vous devez donc supprimer ces entrées du Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, consultez la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Rétablissement de la configuration par défaut

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Dans le volet droit, supprimez la valeur MsgHandleAsyncThreshold.

  4. Fermez l'Éditeur du Registre, puis redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, consultez l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


La valeur de Registre SMTP MsgHandleThreshold a été ajoutée manuellement, mais risque de ne plus être nécessaire
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le nombre maximal de descripteurs de fichiers des services IIS (Internet Information Services) a été modifié par rapport à la valeur par défaut de 1 000 :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

Si Exchange Server Analyzer détecte que la valeur MsgHandleThreshold est présente et configurée sur une autre valeur, un message indiquant une configuration autre que celle par défaut s'affiche.

La valeur MsgHandleThreshold spécifie le nombre maximal de descripteurs de fichiers que les services IIS peuvent utiliser. Les descripteurs de fichiers sont mis en cache pour améliorer les performances car une fois mis en cache, ils empêchent le serveur d'effectuer des entrées/sorties (E/S) redondantes et des cycles de processeur. Chaque fois que la pile de transport SMTP d'un ordinateur Exchange Server reçoit un message, celui-ci est transféré au système de fichiers, où il attend d'être acheminé vers sa destination. Pour écrire au système de fichiers, la pile de transport SMTP obtient un descripteur de fichier et lui transfère le message. Chaque descripteur de fichier utilise environ 2 kilo-octets (Ko) de mémoire de réserve paginée. Le nombre par défaut de descripteurs de fichiers de cache des services IIS est de 800 par tranche de 32 Mo.

Avant l'Exchange 2000 Server Service Pack 2 (SP2), les serveurs Exchange qui maintenaient de grandes files de messages SMTP (en moyenne, au moins 1 000 messages) se sont heurtés à des contraintes de performance historique en raison d'un paramètre par défaut du service SMTP, qui consiste en un maximum de 1 000 descripteurs de fichiers. Comme Exchange 2000 Server a par défaut utilisé un nombre maximal de 1 000 descripteurs de fichiers, le service SMTP n'a pu écrire que 1 000 messages simultanés dans le système de fichiers.

Pour améliorer les performances de ces grands systèmes, trois entrées de Registre ont souvent été ajustées simultanément de manière à augmenter le nombre maximal de descripteurs de fichiers pouvant être ouverts par le service SMTP (pour pouvoir traiter davantage de messages) et à réduire le nombre de descripteurs de fichiers ouverts pour le système de fichiers à installer, un autre composant Exchange (pour éviter de manquer de mémoire lorsque la file d'attente est grande). Ces valeurs de Registre, qui n'existaient pas par défaut et ont donc dû être ajoutées manuellement, sont répertoriées ci-dessous :

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valeur : MsgHandleThreshold

Entrez : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valeur : MsgHandleAsyncThreshold

Entrez : REG_DWORD

Emplacement : HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valeur : FileCacheMaxHandles

Entrez : REG_DWORD

Les entrées MsgHandleThreshold et MsgHandleAsyncThreshold sont généralement définies sur la même valeur (souvent une valeur supérieure à 1 000) et la valeur FileCacheMaxHandles est généralement réduite de 800 à 600.

Si ce serveur Exchange exécute Exchange 2000 Server, il est recommandé d'effectuer une mise à niveau vers le dernier niveau de Service Pack et l'ensemble de mises à jour. Une fois la mise à niveau effectuée vers le dernier code, il est recommandé de définir la valeur MsgHandleThreshold sur le paramètre par défaut 1 000.

La valeur MsgHandleThreshold pour Exchange Server 2003 est 1 000, donc ces paramètres de remplacement du Registre ne sont plus nécessaires. Sauf instruction contraire des services du Support Technique de Microsoft, avant la mise à niveau de tout ordinateur Exchange 2000 Server avec ces paramètres vers Exchange Server 2003, vous devez donc supprimer ces entrées du Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.

Pour corriger cette erreur

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Supprimez la valeur MsgHandleThreshold.

  4. Fermez l'Éditeur du Registre, puis redémarrez le service d'administration IIS pour que la modification soit prise en compte.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).


Les fichiers de collecte SMTP sont écrits dans un dossier compressé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Compressed pour le dossier de collecte SMTP (Simple Mail Transfer Protocol). Si Exchange Server Analyzer détecte que la valeur de Compressed est définie sur True, un avertissement s'affiche.

Lorsque des messages arrivent sur l'ordinateur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange. Si le dossier dans lequel les données de collecte SMTP sont enregistrées est compressé, les performances d'Exchange peuvent être considérablement altérées. Par conséquent, la compression du dossier dans lequel les données de collecte SMTP sont stockées n'est pas prise en charge.

Si cet avertissement s'affiche, vous devez désactiver la compression sur le dossier dans lequel les données de collecte SMTP sont stockées ou déplacer les données de collecte SMTP vers un dossier qui n'est pas compressé.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume compressé. Lorsque vous stockez vos fichiers de données Exchange sur un volume compressé, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent tous les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour désactiver la compression de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver la compression de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

Pour plus d'informations sur le déplacement du dossier de collecte, voir l'article de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).


Les fichier de collecte SMTP sont écrits dans un dossier crypté
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé Encrypted pour le dossier de collecte SMTP (Simple Mail Transfer Protocol). Si Exchange Server Analyzer détecte que la valeur de la clé Encrypted est définie sur True, un avertissement s'affiche.

Lorsque des messages arrivent sur l'ordinateur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange. Si le dossier dans lequel sont enregistrées les données de collecte SMTP est crypté, les performances d'Exchange peuvent être considérablement altérées. Par conséquent, le cryptage du dossier dans lequel les données de collecte SMTP sont stockées n'est pas pris en charge.

Si cet avertissement s'affiche, vous devez désactiver le cryptage sur le dossier dans lequel les données de collecte SMTP sont stockées ou déplacer les données de collecte SMTP vers un dossier non crypté.

Microsoft ne prend pas en charge le stockage des fichiers de données Exchange sur un volume crypté du système de fichiers de cryptage (EFS). Lorsque vous stockez vos fichiers de données Exchange sur un volume crypté, la surcharge supplémentaire affecte considérablement les performances d'Exchange. Les fichiers de données Exchange comprennent les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml ;

  • fichiers .chk.

Pour sécuriser vos fichiers de données Exchange, il est recommandé d'empêcher l'accès non autorisé à l'ordinateur Exchange et d'utiliser le format de message S/MIME pour crypter des données de message.

Pour corriger cette erreur, vous devez désactiver le cryptage de fichiers dans le dossier de collecte ou déplacer ce dossier vers un emplacement où le cryptage n'est pas activé.

Pour désactiver le cryptage de fichiers sur un dossier donné

  1. Cliquez avec le bouton droit sur le dossier dans lequel vous souhaitez désactiver le cryptage de fichiers, puis cliquez sur Propriétés.

  2. Sous l'onglet Général, cliquez sur Paramètres avancés.

  3. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Crypter le contenu pour sécuriser les données, puis cliquez sur OK.

Pour plus d'informations sur le déplacement du dossier de collecte, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Pour plus d'informations sur les fichiers de données Exchange Server et EFS, voir l'article 834638 de la Base de connaissances, qui contient des informations sur le stockage de fichiers de données sur un volume crypté dans Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638).

Pour plus d'informations sur la sécurisation des messages dans Exchange Server 2003, voir le Guide de sécurité des messages Exchange Server 2003 à l'adresse http://go.microsoft.com/fwlink/?linkid=47574.


Les fichiers de collecte SMTP sont écrits dans une partition non NTFS
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows Management Instrumentation) Microsoft Win32_Directory pour déterminer la valeur de la clé FSName pour le répertoire de collecte SMTP d'Exchange. Si Exchange Server Analyzer détermine que la valeur de la clé FSName n'est pas égale à NTFS, un avertissement s'affiche.

Microsoft ne prend pas en charge le stockage de fichiers de données Exchange sur des volumes non NTFS. Les fichiers de données Exchange comprennent les fichiers suivants :

  • fichiers .edb ;

  • fichiers .stm ;

  • fichiers .log ;

  • fichiers .dat ;

  • fichiers .eml.

Si vous voyez cet avertissement, vous devez déplacer le répertoire de collecte SMTP dans un dossier d'un lecteur utilisant le système de fichiers NTFS. Si le lecteur sur lequel le répertoire de collecte est enregistré est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS.

Pour plus d'informations sur le déplacement du dossier de collecte, voir l'article 822933 de la Base de connaissances Microsoft sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933).

Si le lecteur sur lequel les fichiers sont enregistrés est formaté en tant que lecteur FAT, vous pouvez également utiliser l'outil de ligne de commande convert.exe pour convertir le lecteur en NTFS. Pour plus d'informations sur l'utilisation de l'outil de ligne de commande convert.exe pour convertir une partition FAT en partition NTFS, voir l'article 214579 de la Base de connaissances sur l'utilisation de Convert.exe pour convertir une partition en système de fichiers NTFS (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579).


Modification du port SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-11

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété suivante dans la métabase IIS (Internet Information Services) pour déterminer si sa valeur correspond à la valeur par défaut de 25 :

LM/SmtpSvc/<instance de serveur virtuel SMTP>/SMTPPORT

Si Exchange Server Analyzer détecte que la valeur de la propriété SMTPPORT n'est pas 25, il affiche un avertissement.

La propriété SMTPPORT représente le port TCP sur lequel ce serveur SMTP (Simple Mail Transfer Protocol) écoute les connexions entrantes. Les serveurs virtuels SMTP peuvent être configurés pour écouter sur un ou plusieurs ports TCP. Par défaut, tous les serveurs virtuels SMTP sont configurés pour écouter sur le port TCP 25, le port SMTP par défaut. Si le port d'écoute SMTP a été modifié par rapport à sa valeur par défaut et n'inclut plus le port TCP 25 dans sa liste de ports d'écoute, il peut perturber le flux de messages.

Vous pouvez modifier le port d'écoute SMTP, pour autant que vous modifiez en conséquence l'ensemble de l'infrastructure de messagerie interne. Toutefois, il n'est généralement pas possible d'utiliser d'autres ports pour des serveurs virtuels SMTP qui acceptent des messages directement depuis Internet, dans la mesure où les serveurs SMTP sur Internet envoient les messages par le biais du port 25.

Remarque :
Exchange Server Analyzer recherche la valeur pour le serveur virtuel de protocole SMTP Exchange. Ce serveur n'est pas forcément le serveur SMTP qui reçoit les messages directement depuis Internet. Certains produits antivirus et antispam sont conçus pour recevoir des messages SMTP depuis Internet sur le port 25 et les rediriger vers un serveur virtuel SMTP Exchange sur un autre port. Dans ce scénario, un serveur virtuel SMTP Exchange qui écoute sur un port autre que le 25 est une configuration acceptable.
Pour afficher ou modifier le port d'écoute du serveur virtuel SMTP

  1. Dans le Gestionnaire système Exchange, développez Serveurs, développez un serveur Exchange, développez Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP, par exemple, serveur virtuel SMTP par défaut, puis cliquez sur Propriétés.

  3. Sélectionnez l'onglet Général, puis cliquez sur Avancé.

  4. Une liste de ports et d'adresses IP s'affiche.

    • Pour modifier le port existant, sélectionnez l'adresse IP, puis cliquez sur Modifier. Modifiez le champ du port TCP en 25.

    • Pour ajouter le port 25 comme port d'écoute supplémentaire, cliquez sur Ajouter et ajoutez la nouvelle combinaison adresse IP/port. Si vous utilisez le filtre connexion, expéditeur ou destinataire, assurez-vous d'activer les cases à cocher appropriées.

  5. Cliquez sur OK pour enregistrer vos modifications, puis de nouveau sur OK pour quitter la boîte de dialogue Avancé. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances Microsoft :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686).

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).


Le dossier de file d'attente SMTP contient un grand nombre de fichiers
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la métabase des Services Internet (IIS) pour déterminer la valeur de l'attribut QueueDirectory de chaque instance de serveur virtuel SMTP (Simple Mail Transfer Protocol).

Exchange Server Analyzer compte ensuite le nombre de fichiers dans le dossier de file d'attente spécifié pour chaque serveur virtuel SMTP.

Si Exchange Server Analyzer détecte qu'il y a au moins 50 000 fichiers dans le dossier de file d'attente pour un serveur virtuel SMTP, il affiche un message d'avertissement.

Si Exchange Server Analyzer détecte qu'il y a au moins 90 000 fichiers dans le dossier de file d'attente pour un serveur virtuel SMTP, il affiche un message d'erreur.

Ce message d'avertissement ou d'erreur signifie qu'il y a une accumulation de messages que l'instance de serveur virtuel SMTP doit traiter. Le message d'avertissement ou d'erreur indique un problème de performance ou une panne grave sur le serveur car celui-ci ne peut plus remettre le courrier entrant à temps. Ce retard peut être dû aux raisons suivantes :

  • Le service d'annuaire Active Directory® n'est pas consulté rapidement.

  • Les messages ne sont pas traités assez vite pour une remise locale ou SMTP.

Pour résoudre ce problème :

  • Examinez la légitimité des messages dans le dossier de file d'attente afin de vérifier que le serveur ne subit pas une charge anormale en raison de messages publicitaires non sollicités (UCE), de courrier indésirable ou d'une attaque de virus.

  • Vérifiez que le service SMTP est activé et en cours d'exécution.

Vérification du démarrage du service SMTP

  1. Ouvrez le composant logiciel enfichable MMC (Microsoft Management Console) Services.

  2. Dans le volet droit, faites défiler jusqu'au service Simple Mail Transfer Protocol (SMTP) et double-cliquez sur celui-ci. La boîte de dialogue Propriétés SMTP (Simple Mail Transfer Protocol) s'affiche.

  3. Vérifiez que la valeur sélectionnée dans le menu déroulant Type de démarrage est définie sur Automatique.

  4. Cliquez sur Démarrer pour démarrer le service Surveillance du système.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés SMTP (Simple Mail Transfer Protocol).

  6. Fermez le composant logiciel enfichable Services.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47579)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • Article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • Article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Le dossier de la file d'attente SMTP et le dossier de collecte sont identiques
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour vérifier que l'annuaire à partir duquel les messages sont collectés n'est pas identique à celui dans lequel ils sont mis en file d'attente pour un serveur virtuel SMTP spécifique. Si Exchange Server Analyzer détecte que l'attribut du dossier de la file d'attente, msExchSmtpQueueDirectory, et l'attribut du dossier de collecte, msExchSmtpPickupDirectory, sont identiques, il affiche une erreur.

Il s'agit d'une erreur critique. Si les attributs msExchSmtpQueueDirectory et msExchSmtpPickupDirectory sont définis dans le même répertoire, les messages sont remis en double. Vous pouvez mettre à jour ces attributs à l'aide d'ADSI (Active Directory Service Interfaces) Edit.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.
Pour mettre à jour l'attribut de msExchSmtpPickupDirectory ou msExchSmtpQueueDirectory à l'aide d'ADSI Edit

  1. Lancez l'outil ADSI Edit à partir des outils de support de Windows® 2000 ou Windows Server 2003.

  2. Développez les nœuds suivants :

    • Conteneur Configuration

    • Configuration

    • Services

    • Microsoft Exchange

    • Nom_organisation

    • Stratégies de destinataire

    • Nom_groupe_administration

    • Serveurs

    • Nom_serveur

    • Protocoles

    • SMTP

  3. Dans le volet Détails, cliquez avec le bouton droit sur CN=1 (où 1 est le serveur virtuel SMTP par défaut), puis cliquez sur Propriétés.

  4. Dans la liste Sélectionnez les propriétés à afficher, cliquez sur Les deux.

  5. Mettez à jour l'attribut de msExchSmtpPickupDirectory pour annuler le conflit avec msExchSmtpQueueDirectory, puis cliquez sur Définir lorsque vous avez terminé.

  6. Cliquez sur OK, puis sur Appliquer et fermez ADSI Edit.

  7. Attendez au moins 15 minutes pour la réplication.


La file d'attente SMTP se trouve sur le même lecteur que la partition système
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer la valeur configurée de l'attribut msExchSmtpQueueDirectory.

Exchange Server Analyzer interroge également la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service SMTP (Simple Message Transfer Protocol). La valeur False indique que le service n'est pas en cours d'exécution. La valeur True indique que le service est en cours d'exécution. Exchange Server Analyzer interroge la classe WMI Win32_OperatingSystem pour déterminer la valeur de la clé WindowsDirectory. La valeur de cette clé indique l'emplacement du lecteur système Windows.

Si Exchange Server Analyzer détecte que l'attribut msExchSmtpQueueDirectory est configuré avec un chemin d'accès comprenant le même lecteur que le système, que le service SMTP est en cours d'exécution et qu'Exchange n'est pas utilisé avec Microsoft Windows Small Business Server, un avertissement s'affiche.

L'attribut msExchSmtpQueueDirectory représente le chemin d'accès du dossier de la file d'attente SMTP, également appelé dossier Mailroot. Lorsque des messages arrivent sur le serveur Exchange via le service SMTP, les données sont écrites sur le disque dur en tant que fichier .eml. Par défaut, ces fichiers sont stockés dans le dossier <lecteur>:\Program Files\Exchsrvr\Mailroot sur la même partition qu'Exchange.

Dans certains cas, lorsque vous configurez un serveur tête de pont, vous pouvez accroître les performances du serveur Exchange si vous déplacez le répertoire SMTP Mailroot vers un autre disque dur ou une autre partition. Il est recommandé de ne pas placer le dossier SMTP Mailroot sur le même lecteur que le lecteur système Windows. Il doit se trouver sur un disque rapide ou un sous-système de disque rapide pour des performances optimales.

Alors que le dossier Mailroot peut être déplacé dans le Gestionnaire système Exchange sur le serveur virtuel SMTP Exchange Server 2003, son déplacement sur un serveur virtuel SMTP Exchange 2000 Server nécessite l'utilisation d'un éditeur de bas niveau Active Directory, tel qu'ADSI (Active Directory Service Interfaces) Edit.

Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour corriger cette erreur dans Exchange Server 2003

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut), puis cliquez sur Arrêter.

  4. Cliquez de nouveau avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Propriétés.

  5. Cliquez sur l'onglet Messages.

  6. Dans le champ Répertoire de file d'attente, spécifiez le chemin d'accès complet du dossier Mailroot approprié. Vous pouvez cliquer sur Parcourir pour rechercher le chemin d'accès sur l'ordinateur local.

  7. Cliquez sur OK pour enregistrer les modifications.

  8. Cliquez avec le bouton droit sur le serveur virtuel SMTP, puis cliquez sur Démarrer. Le nouvel emplacement est utilisé immédiatement.

Pour corriger cette erreur dans Exchange 2000 Server

  1. Arrêtez tous les services Exchange Server et IIS sur l'ordinateur Exchange 2000 Server dont vous souhaitez modifier le dossier Mailroot sur le serveur virtuel SMTP.

  2. Modifiez la valeur msExchSmtpQueueDirectory affectée du serveur virtuel SMTP concerné de manière à le configurer avec le chemin d'accès approprié.

  3. Attendez qu'Active Directory réplique ce changement sur les serveurs de catalogue global utilisés par ce serveur Exchange.

  4. Démarrez le service Surveillance du système Microsoft Exchange.

  5. Sur l'ordinateur Exchange Server, vérifiez la présence de trois instances de l'ID d'événement 1005 dans le journal des événements Applications disposant d'une source d'événement MSExchangeMU et d'une catégorie Général.

  6. Redémarrez l'ordinateur Exchange Server pour que les modifications soient prises en compte.

Pour plus d'informations sur les deux procédures décrites, voir les articles suivants de la Base de connaissances Microsoft :

  • 822933 sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933)

  • 318230 sur la procédure de modification de l'emplacement du dossier SMTP Mailroot d'Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230)

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


La valeur de Registre SMTP ResetMessageStatus n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

Exchange Server Analyzer affiche un message d'erreur si les conditions suivantes existent :

  • La clé ResetMessageStatus n'est pas définie sur 0 (zéro).

  • Le service de cluster n'est pas exécuté sur le serveur Exchange Server.

Si la clé de Registre ResetMessageStatus est définie sur 1, tous les messages de la file d'attente passent de nouveau par toutes les files d'attente de traitement interne lors du redémarrage d'Exchange Server. Par exemple, tous les messages de la file d'attente passent de nouveau par le catégoriseur lors du redémarrage d'Exchange Server. Par conséquent, la clé ResetMessageStatus devrait être définie sur 1 uniquement pour la résolution de problèmes d'installation SMTP, comme illustré dans l'article 279616 de la Base de connaissances Microsoft sur l'ajout d'une clé de Registre pour une nouvelle catégorisation des messages (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616). Si vous ne résolvez pas les problèmes d'installation SMTP, supprimez cette clé de Registre.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour supprimer la clé de Registre ResetMessageStatus

  1. Ouvrez un Éditeur du Registre, comme Regedit.exe ou Regedt32.exe.

  2. Naviguez jusqu'à : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Dans le volet droit, recherchez la valeur ResetMessageStatus et supprimez-la.

  4. Fermez l'Éditeur du Registre.

Avant de modifier le Registre et pour plus d'informations sur la procédure de modification du Registre, voir l'article 256986 de la Base de connaissances Microsoft sur la description du Registre de Microsoft Windows (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986).

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


The SMTP ResetRoutesRetryMinutes registry value is non-default
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé ResetRoutesRetryMinutes a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Il est recommandé de ne modifier les valeurs des files d'attente par défaut qu'après mûre réflexion. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur Exchange Server.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


La valeur de Registre SMTP RoutingRetryMinutes n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé RoutingRetryMinutes a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Il est recommandé de ne modifier les valeurs des files d'attente par défaut qu'après mûre réflexion. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur Exchange Server.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


La valeur de Registre SMTP SecondsPerDSNPass n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer le paramètre de la valeur de Registre SecondsPerDSNPass :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé SecondsPerDSNPass est présente, mais pas définie sur 10, il affiche un message indiquant une configuration autre que celle par défaut.

Ce paramètre permet d'optimiser les notifications d'état de remise (DSN) et spécifie le nombre de secondes avant le traitement de chaque DSN. Dès que le seuil a été surpassé, la génération de DSN est interrompue et reprise ultérieurement. Il est recommandé de ne modifier les valeurs par défaut qu'après mûre réflexion. Ce paramètre spécifique ne doit être modifié qu'après avoir consulté les services de Support de Microsoft. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur le serveur Exchange.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.


L'authentification NTLM est désactivée sur le serveur SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-11-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si le bit du protocole d'authentification NTLM (également appelé Authentification intégrée Windows) de l'attribut msExchAuthenticationFlags est défini. Si Exchange Server Analyzer détermine que le bit n'est pas défini et qu'Exchange n'est pas en cours d'exécution sur Microsoft Windows® Small Business Server, un avertissement s'affiche.

L'attribut msExchAuthenticationFlags indique le type de protocole d'authentification accepté par un serveur virtuel. Cet attribut utilise un masque de trois bits.

Bit | Méthode d'authentification
0 | Anonyme
1 | De base
2 | NTLM (Authentification intégrée Windows)

Si le bit contrôlant l'authentification NTLM n'est pas défini, le serveur virtuel SMTP n'autorisera pas l'authentification NTLM. Cela peut entraîner des problèmes d'authentification entre des ordinateurs Exchange.

Pour supprimer cet avertissement

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, le nom du serveur, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur le serveur virtuel SMTP Exchange, puis cliquez sur Propriétés.

  4. Cliquez sur l'onglet Accès, sur Authentification, puis activez la case à cocher Authentification intégrée Windows.

  5. Cliquez sur OK, puis de nouveau sur OK.

  6. Fermez le Gestionnaire système Exchange.

Pour plus d'informations sur les méthodes d'authentification de SMTP, voir le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579) et l'article 319267 de la Base de connaissances Microsoft sur la procédure de sécurisation de la remise de messages client à l'aide d'un protocole SMTP dans Exchange 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267).


La valeur de Registre SMTP SubmissionRetryMinutes n'est pas définie par défaut
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si les configurations des files d'attente SMTP par défaut ont été modifiées :

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Si Exchange Server Analyzer détecte que la clé SubmissionRetryMinutes a été définie, il affiche un message indiquant une configuration autre que celle par défaut.

Il est recommandé de ne modifier les valeurs des files d'attente par défaut qu'après mûre réflexion. Les valeurs par défaut ont été soigneusement sélectionnées pour des performances optimales dans la plupart des environnements. Il est généralement recommandé de s'attaquer à la cause première du problème au lieu de modifier le comportement de la file d'attente sur Exchange.

Exchange Server Analyzer ne signale cette configuration qu'à titre indicatif. Aucune action n'est requise.

Pour plus d'informations sur les files d'attente SMTP d'Exchange, voir le billet de l'équipe Microsoft Exchange sur l'explication du mystérieux moteur avancé de files d'attente (http://go.microsoft.com/fwlink/?LinkId=48585).


Le serveur virtuel SMTP a une taille limite de messages plus élevée que la taille limite de messages globale
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour comparer les tailles limites des messages entrants du serveur virtuel SMTP aux tailles limites globales des messages entrants.

L'attribut Active Directory qui représente la taille limite des messages du serveur virtuel SMTP pour les messages entrants et sortants est msExchSmtpMaxMessageSize. Cette valeur est un attribut de l'objet de serveur virtuel SMTP dans Active Directory, pouvant se trouver dans :

CN=<Numéro_serveur_virtuel>, CN=SMTP, CN=Protocoles, CN=<Nom_serveur>, CN=Serveurs, CN=<Nom_groupe_administration>, CN=Groupes_administration, CN=<Nom_organisation>, CN=Microsoft_Exchange, CN=Services, CN=Configuration, DC=<Nom_domaine>, DC=com

L'attribut Active Directory qui représente la taille limite globale des messages entrants est delivContLength. Cette valeur est un attribut de l'objet de remise des messages de paramètres globaux de l'organisation dans Active Directory, pouvant se trouver dans :

CN=Remise_messages, CN=Paramètres_globaux, CN=<Nom_organisation>, CN=Microsoft_Exchange, CN=Services, CN=Configuration, DC=<Nom_domaine>, DC=com

Si Exchange Server Analyzer détecte que la valeur de msExchSmtpMaxMessageSize est supérieure à la valeur de delivContLength, un avertissement s'affiche.

Si l'un des serveurs virtuels SMTP a une taille limite de messages plus élevée que la taille limite de messages globale, cela pourrait entraîner l'acceptation des messages entrants supérieurs à la taille limite qui ne seraient par conséquent pas remis. Pour éviter ce problème, configurez le serveur virtuel SMTP sur une taille maximale des messages égale ou inférieure à la taille limite globale des messages entrants.

Remarque :
Si vous fixez une taille limite de messages trop basse, cela pourrait empêcher toute réplication de Carnet d'adresses en mode hors connexion entre les ordinateurs Exchange Server. Pour plus d'informations sur ce problème, voir l'article 326154 de la Base de connaissances Microsoft sur la non-réplication d'OAB si vous définissez une restriction de la taille des messages au niveau transport (http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154).

Pour supprimer cet avertissement

  1. Dans le Gestionnaire système Exchange, développez Serveurs, puis développez un serveur Exchange, développez Protocoles, puis SMTP.

  2. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, serveur virtuel SMTP par défaut) et sélectionnez Propriétés.

  3. Sélectionnez l'onglet Messages.

  4. Modifiez la valeur pour le champ Limiter la taille des messages à (Ko) de sorte qu'elle soit égale ou inférieure à la taille limite de messages globale.

  5. Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Pour plus d'informations sur l'affichage et la modification de paramètres à l'échelle de l'organisation, voir l'article 821881 de la Base de connaissances sur la procédure de modification des paramètres globaux dans le Gestionnaire système Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821881).

Pour plus d'informations sur les tailles limites de messages globales, voir les articles suivants de la Base de connaissances :

  • 298572 sur les messages électroniques dont la taille est supérieure à la taille limite des messages entrants ou sortants qui ne sont pas remis (http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572)

  • 322679 sur la définition de tailles limites pour les messages (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679)

  • 824111 sur les modifications et mises à jour des paramètres de sécurité présentées dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=824111)


Ce serveur virtuel SMTP est configuré pour effectuer des recherches DNS inversées pour les messages entrants
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-24

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si la valeur configurée de l'attribut msExchSmtpPerformReverseDnsLookup a été modifiée par rapport à la valeur par défaut False. Par défaut, l'attribut msExchSmtpPerformReverseDnsLookup est configuré pour ne pas effectuer de recherche DNS inversée pour les messages entrants. Si Exchange Server Analyzer détecte que cet attribut est défini sur True, un avertissement s'affiche.

L'option Exécuter une recherche DNS inversée sur les messages entrants n'offre pas la fonctionnalité d'éviter la réception de messages électroniques indésirables. Lorsque cette option est utilisée, Exchange Server effectue une requête DNS pour résoudre l'adresse IP d'origine des messages entrants vers un nom d'hôte. Ensuite, le nom d'hôte est joint aux en-têtes des messages électroniques.

Lorsque cette fonction est activée, vous pouvez rencontrer une dégradation des performances en raison d'enregistrements DNS mal configurés ou de connexions à Internet intermittentes. Par conséquent, vous souhaiterez peut-être désactiver cette option lorsque la remise de courrier via Internet est ralentie.

Pour activer ou désactiver les recherches DNS inversées pour les messages SMTP entrants

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, le serveur virtuel SMTP par défaut) puis cliquez sur Propriétés.

  4. Sélectionnez l'onglet Remise, puis cliquez sur Avancé.

    • Pour activer les recherches DNS inversées, activez la case à cocher Exécuter une recherche DNS inversée sur les messages entrants.

    • Pour désactiver les recherches DNS inversées, désactivez la case à cocher Exécuter une recherche DNS inversée sur les messages entrants.

  5. Cliquez sur OK pour enregistrer la modification, puis de nouveau sur OK pour quitter la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, voir l'article 297412 de la Base de connaissances Microsoft sur l'option Exécuter une recherche DNS inversée sur les messages entrants qui correspond à une résolution de nom d'hôte (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)


Version SP1 du filtre de messages intelligent activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si le filtre de messages intelligent de Microsoft® Exchange est installé et activé sur le serveur :

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer lit la valeur ContentFilterBindings dans la clé de Registre ContentFilter pour déterminer si le filtre de messages intelligent est installé et activé sur le serveur.

Exchange Server Analyzer interroge ensuite la classe WMI (Windows® Management Instrumentation) Microsoft CIM_Datafile pour déterminer si le chemin du filtre de messages intelligent MSExchange.UceContentFilter.dll pour Exchange Server 2003 Service Pack 1 (SP1) est le suivant sur le serveur Exchange :

<chemin_fichiers_binaires_du_serveur_Exchange>\MSCFv1\MSExchange.UceContentFilter.dll

Remarque :
Dans ce chemin, <chemin_fichiers_binaires_du_serveur_Exchange> désigne l'emplacement du dossier bin.

Si le filtre de messages intelligent pour Exchange Server 2003 Service Pack 1 (SP1) est installé et activé sur le serveur, Exchange Server Analyzer affiche un avertissement.

Cet avertissement indique qu'une version plus récente du filtre de messages intelligent est disponible. Il est recommandé d'installer la version la plus récente du filtre de messages intelligent. Si vous résolvez des problèmes de flux de messages impliquant ce serveur spécifique, vous pouvez désactiver temporairement le filtre de messages intelligent afin de déterminer s'il bloque à tort des messages légitimes.

Pour désactiver le filtre de messages intelligent

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans le Gestionnaire système Exchange, développez Serveurs, le nom du serveur, Protocoles, SMTP, cliquez avec le bouton droit sur Filtre de messages intelligent, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, sous Appliquer le filtrage de messages intelligent aux adresses IP des serveurs virtuels ci-dessous, désactivez la case à cocher en regard de chaque serveur virtuel SMTP sur lequel désactiver le filtre de messages intelligent.

    Boîte de dialogue Propriétés de filtre de messages intelligent

Pour plus d'informations, voir le document sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Version SP2 du filtre de messages intelligent activée
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-04

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® afin de déterminer si la propriété msExchServerBindingsFiltering d'un objet de serveur virtuel SMTP (Simple Mail Transfer Protocol) indique que le filtre de messages intelligent est activé pour une instance de serveur virtuel SMTP.

Exchange Server Analyzer interroge également Active Directory afin de déterminer si msExchUceEnabled est activé au niveau des paramètres globaux.

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Le filtre de messages intelligent est activé pour une instance de serveur virtuel SMTP.

  • Le filtre de messages intelligent est activé au niveau des paramètres globaux.

Cet avertissement indique que la version du filtre de messages intelligent pour Exchange Server 2003 Service Pack 2 (SP2) est effectivement activée. Le fait que la version SP2 du filtre de messages intelligent soit activée n'est généralement pas un problème, à moins que vous ayez à résoudre des problèmes de flux de messagerie impliquant le serveur concerné. Dans ce cas, vous pouvez vérifier la configuration du filtre ou désactiver temporairement le filtre de messages intelligent pour déterminer s'il bloque de manière incorrecte le courrier d'expéditeurs valides.

Pour désactiver le filtre de messages intelligent

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans le Gestionnaire système Exchange, développez Serveurs, le nom du serveur, Protocoles, puis SMTP.

  3. Dans les Propriétés du Serveur virtuel SMTP, sous l'onglet Général, cliquez sur Options avancées.

  4. Sélectionnez l'adresse IP pour laquelle vous souhaitez désactiver le filtre de messages intelligent, puis cliquez sur Modifier.

  5. Sous Identification, désactivez la case à cocher Appliquer le filtre de messages intelligent.

  6. Si vous possédez plusieurs serveurs virtuels, répétez les étapes 3 à 6 pour chaque serveur sur lequel le filtre doit être désactivé.

Pour plus d'informations, voir le document sur le filtre de messages intelligent Exchange (http://go.microsoft.com/fwlink/?LinkId=21607).


Serveur de passerelle spécifié inutilisé
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-09

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte externe défini par l'utilisateur, puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer vérifie si le serveur de passerelle Exchange permettant de router le message vers le destinataire externe est celui spécifié par l'utilisateur sur la page Entrer des informations relatives au serveur et à l'utilisateur, à l'étape du nom du serveur et des informations d'identification.

Si Exchange Server Analyzer détermine que le message a été routé à l'extérieur de l'organisation Exchange, mais que le serveur de passerelle utilisé n'était pas celui spécifié, il affiche un avertissement.

Cet avertissement indique qu'un problème peut se produire avec la topologie de routage Exchange et que des serveurs de passerelle sortants sont présents.

Des problèmes de routage peuvent survenir si des entrées d'hôte actif sont définies au niveau du serveur virtuel au lieu du niveau du connecteur. Il est recommandé de définir des entrées d'hôte actif sur le connecteur SMTP et non sur le serveur virtuel SMTP.

Pour résoudre cet avertissement, procédez comme suit :

  • Passez en revue la configuration du serveur virtuel SMTP (Simple Mail Transfer Protocol) pour vous assurer qu'aucune entrée d'hôte actif n'est définie.

  • Passez en revue la configuration du serveur tête de pont pour vérifier que les espaces d'adressage et les coûts des connecteurs sont corrects.

Pour afficher et configurer les paramètres d'hôte actif

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Serveurs, un serveur Exchange, Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur un serveur virtuel SMTP (par exemple, serveur virtuel SMTP par défaut) et sélectionnez Propriétés.

  4. Sélectionnez l'onglet Remise, puis cliquez sur Avancé.

  5. Effacez les éventuelles entrées figurant sous Hôte actif.

  6. Cliquez sur OK pour enregistrer les modifications, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés du serveur virtuel SMTP.

Pour plus d'informations sur la procédure de configuration des connecteurs SMTP, voir l'article 822941 de la Base de connaissances Microsoft sur l'utilisation des connecteurs SMTP pour relier les groupes de routage dans Exchange 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875)

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)


Expéditeur spécifié sur un autre serveur
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-08-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge la valeur de l'attribut proxyAddress du service d'annuaire Active Directory® pour tous les objets utilisateur afin de déterminer si une correspondance existe pour l'adresse SMTP (Simple Mail Transfer Protocol) de l'expéditeur local spécifié par l'utilisateur.

Si une correspondance proxyAddress d'objet utilisateur est trouvée, Exchange Server Analyzer interroge ensuite Active Directory pour la valeur de l'attribut msExchHomeServerName pour l'objet utilisateur afin de déterminer si cette valeur correspond au nom Exchange Server spécifié par l'utilisateur.

Si Exchange Server Analyzer détermine que la valeur de l'attribut msExchHomeServerName pour l'expéditeur spécifié par l'utilisateur ne correspond pas au nom Exchange Server spécifié par l'utilisateur, Exchange Server Analyzer affiche un avertissement.

Cet avertissement indique qu'un nom Exchange Server incorrect a été fourni ou que le problème de flux de messages affecte un autre serveur que celui spécifié par l'utilisateur.

Pour résoudre ce problème, vérifiez que le nom Exchange Server correct est entré.

Pour afficher les boîtes aux lettres utilisateur sur le serveur spécifié

  1. Démarrez le Gestionnaire système Exchange :

    Cliquez sur Démarrer, pointez sur Programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans le Gestionnaire système Exchange, accédez au conteneur suivant, puis cliquez dessus :

    \Groupes d'administration\ Nom_groupe \Serveurs\ Nom_serveur \ Nom_groupe_stockage \Banque de boîtes aux lettres\Boîtes aux lettres

  3. Vérifiez que la boîte aux lettres utilisateur spécifiée est affichée sur le serveur Exchange déterminé.


Impossible d'identifier les serveurs de destination cibles
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-06

L'outil Microsoft® Exchange Server Analyzer Tool essaye d'identifier et de dresser une liste des noms de domaine complets (FQDN), adresses IP et noms de domaines des serveurs distants auxquels sont destinés les messages se trouvant dans une file d'attente de remise distante.

La liste des noms de domaine complets, adresses IP et noms de domaines des serveurs distants est constituée comme suit :

  • L'outil interroge la propriété msExchSmtpFullyQualifiedDomainName de l'objet de service d'annuaire Active Directory® du serveur virtuel SMTP (Simple Mail Transfer Protocol).

    Remarque :
    Il lit ensuite la propriété msExchSmtpFullyQualifiedDomainName à partir de la propriété msExchTargetBridgeheadServersDN d'un objet d'annuaire de connecteur de groupe de routage lorsque celui-ci est interrogé pour les serveurs Bridgehead cibles désignés.
  • Il interroge la propriété msExchSmtpSmartHost de l'objet Active Directory du connecteur SMTP pour l'hôte actif désigné d'un connecteur SMTP.

  • Il interroge la propriété LinkName de la classe WMI (Windows® Management Instrumentation) Microsoft ExchangeLink pour les éventuelles connexions directes aux serveurs distants.

Si Exchange Server Analyzer détermine que la tentative de dresser cette liste donne une liste vide, il affiche une erreur.

Cette erreur indique que :

  • Il peut y avoir des problèmes intermittents de connexion au réseau ou à Active Directory, qui provoquent des problèmes de flux de messages.

  • Le compte qui exécute Exchange Server Analyzer ne possède peut-être pas d'autorisations suffisantes pour demander les informations.

Pour corriger cette erreur

  1. Assurez-vous que l'ordinateur Exchange Server a été démarré et est connecté au réseau.

  2. Vérifiez que vous disposez de la connectivité réseau à un contrôleur de domaine Active Directory.

  3. Spécifiez un contrôleur de domaine Active Directory dans Exchange Server Analyzer.

  4. Utilisez la commande PING pour voir si l'ordinateur Exchange Server est accessible.

  5. Si un pare-feu est installé, vérifiez si les ports RPC sont bloqués.

  6. Vérifiez les autorisations pour le compte sous lequel Exchange Server Analyzer est exécuté. Ce compte doit posséder des autorisations de type administrateur local sur chaque ordinateur Exchange Server qu'il analyse.

Pour plus d'informations sur les problèmes de connectivité réseau, voir l'article 325487 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de connectivité réseau (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487).

Pour plus d'informations sur les problèmes de connectivité de l'outil Exchange Server Analyzer, voir le document sur la résolution des problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=56285).

Pour plus d'informations sur les exigences en matière de ports, voir l'article 832017 de la Base de connaissance sur la vue d'ensemble des services et exigences de ports réseau pour le système Windows Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017).


Mise en œuvre de TarpitTime
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-02-21

L'outil Microsoft® Exchange Server Analyzer Tool lit l'entrée de Registre suivante pour déterminer si la fonctionnalité Tar Pit du filtrage des destinataires a été définie :

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

Si Exchange Server Analyzer détecte que la valeur de TarpitTime est supérieure à 0 (zéro), il affiche un message indiquant une configuration autre que celle par défaut.

Le tar pitting consiste à ralentir ou retarder délibérément des connexions non légitimes pour réduire la vitesse d'envoi du courrier électronique indésirable automatisé ou des attaques de dictionnaire.

La fonctionnalité Tar Pit disponible dans Microsoft Windows Server™ 2003 Service Pack 1 (SP1) peut être ajoutée pour une utilisation avec le filtrage des destinataires comme décrit dans l'article 842851 de la Base de connaissances Microsoft sur la fonctionnalité Tar Pit SMTP pour Microsoft Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851). De plus, la fonctionnalité Tar Pit étend l'utilité du filtrage des destinataires si la case à cocher Filtrer les destinataires qui ne sont pas dans le répertoire est activée sous l'onglet Filtrage des destinataires dans Paramètres globaux.

La fonctionnalité Tar Pit est mise en œuvre en définissant la sous-clé de Registre TarpitTime. La sous-clé de Registre TarpitTime demande une valeur décimale. La valeur décimale traduit le nombre de secondes que la session SMTP attend pour répondre à un expéditeur lorsqu'un destinataire n'existe pas dans l'organisation Exchange Server cible.

Grâce à la fonctionnalité Tar Pit, les éditeurs de courrier indésirable éprouvent davantage de difficultés à automatiser une attaque d'annuaire. Une attaque d'annuaire est une tentative de récupération d'une liste de bonnes adresses électroniques d'une organisation spécifique.

Le protocole SMTP reconnaît les destinataires autorisés lors d'une session SMTP en retournant « Destinataire 2.1.5 OK. » Dans le cas où du courrier est envoyé à un destinataire inconnu, le protocole SMTP retourne une erreur « 5.x.x ». Par conséquent, un éditeur de courrier indésirable peut écrire un programme automatisé qui utilise des noms communs ou des termes du dictionnaire pour créer des adresses électroniques pour un domaine spécifique. Le programme peut ensuite rassembler toutes les adresses électroniques qui retournent « Destinataire 2.1.5 OK » et ignorer celles qui entraînent des erreurs « 5.x.x ». L'éditeur de courrier indésirable peut ensuite vendre les « bonnes » adresses électroniques ou les utiliser comme destinataires de courrier non sollicité.

Si la case à cocher Filtrer les destinataires qui ne sont pas dans le répertoire est activée, mais que la sous-clé de Registre TarpitTime n'est pas définie, Exchange Server retourne immédiatement une erreur « 5.x.x » à l'expéditeur lors de la session SMTP si un destinataire n'existe pas dans le service d'annuaire Active Directory® cible.

Par contre, si la sous-clé de Registre TarpitTime est définie et si la case à cocher Filtrer les destinataires qui ne sont pas dans le répertoire est activée, SMTP patiente avant de retourner l'erreur « 5.x.x ». La valeur décimale entrée dans la sous-clé de Registre TarpitTime correspond au nombre de secondes que SMTP attend avant de retourner l'erreur. Cette pause au cours de la session SMTP rend d'autant plus difficile l'automatisation d'une attaque d'annuaire.

Comme mentionné précédemment, Exchange Server Analyzer affiche un message indiquant une configuration autre que celle par défaut si la sous-clé de Registre TarpitTime est définie. Ce message est fourni à titre indicatif uniquement.

Important :
Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous de comprendre comment le restaurer en cas de problème. Pour plus d'informations sur la façon de procéder, voir la rubrique d'aide sur la restauration du Registre dans Regedit.exe ou Regedt32.exe.
Pour afficher ou modifier la sous-clé de Registre TarpitTime

  1. Cliquez sur Démarrer, puis Exécuter, entrez regedit dans la zone Ouvrir et cliquez sur OK.

  2. Recherchez et cliquez sur la sous-clé de Registre suivante :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. La zone Données de la valeur contient un nombre décimal. Cette valeur représente le nombre de secondes de décalage des réponses de la vérification des adresses SMTP pour chaque adresse qui n'existe pas dans Active Directory.

  4. Si vous modifiez la valeur ou supprimez la sous-clé de Registre TarpitTime, vous devez redémarrer le service SMTP (Simple Mail Transport Protocol).

Pour plus d'informations, voir l'article 842851 de la Base de connaissances Microsoft sur la fonctionnalité Tar Pit de SMTP pour Microsoft Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851).


Le message de test a généré un rapport de non-remise
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause des entrées dans le journal de suivi des messages à créer.

Si l'outil Exchange Server Analyzer Tool détecte la valeur 1030 pour la propriété EntryType, il affiche un avertissement.

Cet avertissement indique que le message de test a généré un rapport de non-remise et qu'il se peut qu'un problème ait été rencontré dans la configuration SMTP (Simple Mail Transfer Protocol) du serveur. Le rapport de non-remise est prévisible si le destinataire désiré n'existe pas, mais il indique un problème si le message de test a été envoyé à un destinataire valide.

À des fins de dépannage, il peut s'avérer utile d'essayer d'envoyer d'autres messages au même destinataire et de consulter les rapports de non-remise pour déterminer la cause du problème.

Pour plus d'informations sur le dépannage des rapports de non-remise, voir la section sur le dépannage des rapports de non-remise dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Message de test envoyé dans le répertoire Badmail
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-05-17

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI ( Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer la cause de l'entrée dans le journal de suivi des messages.

Si Exchange Server Analyzer détecte la valeur 1021 pour la propriété EntryType, il affiche un avertissement.

Cet avertissement indique que le message de test a été envoyé au répertoire Badmail pour le serveur Exchange et qu'un problème a été rencontré dans la configuration SMTP (Simple Mail Transfer Protocol) du serveur.

Un message peut être placé dans le répertoire Badmail pour l'une des raisons suivantes :

  • Sa remise est impossible.

  • Le nombre maximal de tentatives a été dépassé.

  • Il ne peut pas être renvoyé à l'expéditeur en tant que message impossible à remettre.

Pour plus d'informations sur la procédure de test du flux de messages sortants, voir l'article 297700 de la Base de connaissances Microsoft sur la procédure de test du flux de messages sortants à l'aide d'un fichier du dossier Pickup (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700).

Pour plus d'informations sur le dépannage du flux de messages et de SMTP, voir la section appropriée du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).


Message de test bloqué dans une file d'attente SMTP
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-06

L'outil Microsoft® Exchange Server Analyzer Tool envoie un message de test du serveur Exchange au compte administrateur ou à un compte défini par l'utilisateur pour le domaine SMTP (Simple Mail Transfer Protocol), puis analyse les journaux de suivi des messages du serveur pour déterminer si des problèmes concernant la remise du message de test ont été détectés.

Dans le cadre de cette analyse, Exchange Server Analyzer interroge la propriété EntryType pour la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_MessageTrackingEntry sous l'espace de noms root\MicrosoftExchangeV2 pour déterminer pourquoi des entrées ont été créées dans le journal de suivi des messages.

Le tableau ci-dessous répertorie les valeurs qui peuvent être retournées pour EntryType.

Nom de la valeur | Valeur
Message reçu via X400 | 0
Rapport reçu | 2
Message envoyé | 4
Message transféré (sortie) | 7
Rapport transféré (sortie) | 8
Message remis | 9
Rapport remis | 10
Liste de distribution étendue | 26
Message redirigé | 28
Message rerouté | 29
Serveur mis à niveau vers le bas par MTA | 31
Rapport absorbé | 33
Rapport généré | 34
Rapport non routable ignoré | 43
Message supprimé par l'administrateur | 50
Sonde supprimée par l'administrateur | 51
Rapport supprimé par l'administrateur | 52
Message remis localement | 1000
Message transféré sur la structure fondamentale (entrée) | 1001
Message transféré sur la structure fondamentale (entrée) | 1002
Message transféré sur la passerelle (sortie) | 1003
Message transféré sur la passerelle (entrée) | 1004
Rapport transféré sur la passerelle (entrée) | 1005
Rapport transféré sur la passerelle (sortie) | 1006
Rapport généré | 1007
SMTP : message mis en attente en sortie | 1010
SMTP : Message transféré (sortie) | 1011
SMTP : message entrant reçu | 1012
SMTP : message entrant transféré | 1013
SMTP : Message rerouté | 1014
SMTP : rapport transféré (entrée) | 1015
SMTP : Rapport transféré (sortie) | 1016
SMTP : Rapport généré | 1017
SMTP : Rapport absorbé | 1018
SMTP : message soumis au moteur avancé de files d'attente | 1019
SMTP : transfert en sortie du message commencé | 1020
SMTP : message envoyé au répertoire Badmail | 1021
SMTP : échec de la file d'attente avancée | 1022
SMTP : Message remis localement | 1023
SMTP : message soumis au catégoriseur | 1024
SMTP : soumission du message au moteur avancé de files d'attente commencée | 1025
SMTP : échec de la remise du message par la file d'attente avancée | 1026
Pilote de banque d'informations SMTP : message soumis depuis la banque d'informations | 1027
Pilote de banque d'informations SMTP : message remis localement à la banque d'informations | 1028
Pilote de banque d'informations SMTP : message soumis à l'agent MTA | 1029
SMTP : rapport de non-remise (NDR) généré | 1030
SMTP : Message transféré (sortie) | 1031

Exchange Server Analyzer affiche une erreur si les valeurs de EntryType retournées indiquent que les conditions suivantes sont vérifiées :

  • Le journal de suivi des messages test a pu être analysé avec succès.

  • Le message de test n'a pas pu être transféré de la file d'attente.

  • Aucun rapport de non-remise n'a été généré pour le message de test.

  • Le message de test n'a pas été transféré vers le répertoire Badmail.

  • Le message de test n'est pas mis en file d'attente pour une remise distante.

  • Le message de test n'a pas été correctement remis à la banque d'informations locale.

  • Le message de test n'est pas planifié pour un nouvel essai de catégorisation.

  • Le message de test n'est pas planifié pour un nouvel essai de routage.

  • Le message de test n'est pas planifié pour un nouvel essai de remise locale.

Cette erreur signifie que le message de test reste bloqué dans une des files d'attente SMTP et qu'une analyse complémentaire est nécessaire pour déterminer pourquoi il est bloqué là.

Pour résoudre cette erreur, l'utilitaire NSlookup permet de revoir les éventuels problèmes de résolution DNS (Domain Name System). Pour les problèmes de connexion et de protocole tels que les erreurs Hôte inaccessible, Telnet.exe permet d'essayer de vous connecter à l'ordinateur de destination. Pour résoudre des erreurs de protocole, augmentez l'enregistrement des diagnostics pour le service MSExchangeTransport pour le composant SMTP et passez en revue les journaux d'erreurs. Vous pouvez également utiliser l'outil Moniteur réseau (Netmon.exe) pour obtenir des informations sur les erreurs de connexion au réseau. Pour reproduire le problème, vous devez obliger la file d'attente à réessayer. Vérifiez si le journal d'événements contient des erreurs possibles associées au service de banque d'informations de Microsoft Exchange.

Pour plus d'informations sur la procédure de modification des paramètres d'enregistrement, voir la rubrique sur la procédure de modification des paramètres d'enregistrement pour MSExchangeTransport dans la section sur la résolution des problèmes de flux de messages et SMTP du Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, voir les ressources Exchange suivantes :

  • la rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579)

  • l'article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

  • l'article 821877 de la Base de connaissances Microsoft sur la description des champs des onglets Propriétés SMTP et de file d'attente X.400 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877)

  • l'article 264054 de la Base de connaissances Microsoft sur la présentation des états des files d'attente dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054)


Un groupe de routage compte plus de 900 connecteurs
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de connecteurs présents dans un groupe de routage donné, notamment les connecteur SMTP, les connecteurs de groupe de routage, les connecteurs X.400 et les connecteurs EDK. Si Exchange Server Analyzer détecte plus de 900 connecteurs dans un seul groupe de routage, un avertissement s'affiche.

Il est recommandé d'utiliser un maximum de 900 instances pour tout type d'objet Exchange. Cela est dû à la valeur par défaut d'Active Directory qui définit la taille de page maximale renvoyée pour toute demande donnée sur 1 000. Cela signifie que si une demande LDAP (Lightweight Directory Access Protocol) est effectuée pour un objet et si plus de 1 000 instances de cet objet existent dans Active Directory, aucun résultat n'est renvoyé étant donné que la taille de page maximale est dépassée.

Dans le cas d'Exchange Server, différents processus nécessitent l'instanciation de types d'objet spécifique. Par exemple, le Gestionnaire système Exchange effectue une demande LDAP à Active Directory pour créer un affichage de liste de tous les connecteurs dans un groupe de routage. Si un seul groupe de routage comporte plus de 1 000 connecteurs, Active Directory ne renvoie aucun résultat de requête. Dans ce cas, une erreur s'affiche dans le Gestionnaire système Exchange.

Même si la valeur de la taille de page maximale pour Active Directory peut être augmentée, cela n'est pas recommandé ou pris en charge par Exchange Server. Un comportement anormal et des échecs ont été observés dans les environnements Exchange dans lesquels la valeur de la taille de page maximale a été augmentée.

Même s'il est recommandé de rester à ou en dessous de 900 pour tout type d'objet dans Echange Server, plus de 1 000 types d'objets sont pris en charge.

Correction de cet avertissement

  1. Pensez à consolider les connecteurs ou à créer plus de groupe de routage et à équilibrer la charge des connecteurs existants.

  2. Recherchez les connecteurs orphelins dans Active Directory et supprimez-les.

  3. Pensez à consolider les serveurs Exchange de votre organisation.

Pour plus d'informations sur la conception des groupes de routage et les connecteurs, consultez le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47579).

Pour plus d'informations sur la consolidation des serveurs Exchange, consultez le document sur la consolidation de serveurs à l'aide d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=47586).


Il existe une incohérence dans le paramètre de nom de domaine complet entre Active Directory et la métabase
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2007-01-17

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété suivante dans la métabase IIS (Internet Information Services) pour déterminer si sa valeur correspond à la valeur configurée de l'attribut msExchSmtpFullyQualifiedDomainName dans le service d'annuaire Active Directory® :

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

Si Exchange Server Analyzer détecte que les valeurs des deux attributs ne correspondent pas, un message d'avertissement s'affiche.

Si la valeur dans la métabase IIS ne correspond pas à la valeur dans Active Directory, il peut s'agir d'un problème de réplication d'Active Directory ou du composant de réplication Directory-service-to-Metabase (DS2MB) dans Exchange.

Le processus DS2MB permet de transférer les informations de configuration d'Active Directory vers la métabase locale. Cette configuration est stockée dans la métabase locale au lieu du Registre pour des raisons de performance et d'évolutivité. Tous les protocoles Internet (SMTP, NNTP, POP3, IMAP4 et HTTP) s'exécutent en tant que composants IIS dans Exchange 2000 Server et Exchange Server 2003.

Toutes les 15 minutes, le processus DS2MB copie des sous-arborescences entières d'Active Directory sans changer leur forme. Il s'agit d'une écriture monodirectionnelle d'Active Directory vers la métabase ; la métabase n'écrit jamais dans Active Directory.

La propriété FullyQualifiedDomainName et l'attribut msExchSmtpFullyQualifiedDomainName utilisent un nom de serveur par défaut qui correspond au nom de domaine complet du serveur Exchange (par exemple, serveur.domaine.com). Si la propriété FullyQualifiedDomainName et l'attribut msExchSmtpFullyQualifiedDomainName n'ont pas la même valeur de nom de domaine complet, cela signifie qu'Active Directory et la métabase IIS ne sont pas synchronisés. Si le problème est dû à un échec du processus DS2MB, vous pouvez le corriger en suivant la procédure ci-dessous pour la version d'Exchange Server que vous exécutez. Si le problème est dû à un échec de réplication partiel ou complet d'Active Directory, vous pouvez utiliser l'utilitaire du moniteur de réplication d'Active Directory (ReplMon.exe) pour vérifier le bon fonctionnement et l'état de réplication d'Active Directory. Vous pouvez trouver Replmon.exe dans les outils de support de Microsoft Windows® sur le CD-ROM de Windows Server™ 2003.

Correction de cet avertissement dans Exchange Server 2003

  1. Recherchez la présence d'entrées de journal des événements Applications avec une source de MSExchangeMU. Si le processus DS2MB échoue, il consignera un événement dans Exchange Server 2003.

  2. Si tous les échecs du processus DS2MB n'apparaissent pas, utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  3. Redémarrez le service Surveillance du système Exchange si vous constatez des échecs du processus DS2MB ou après avoir corrigé tous les problèmes de réplication d'Active Directory.

Correction de cet avertissement dans Exchange 2000 Server

  1. Utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  2. Redémarrez le service Surveillance du système Exchange après avoir supprimé ou résolu tous les problèmes de réplication d'Active Directory.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, consultez l'article 297412 de la Base de connaissances Microsoft sur l'option Exécuter une recherche DNS inversée sur les messages entrants qui correspond à une résolution de nom d'hôte (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, consultez les articles 266686 et 268163 de la Base de connaissances sur la procédure de configuration d'un serveur virtuel SMTP, première (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686) et deuxième partie (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163).

Pour plus d'informations sur la réplication d'Active Directory, consultez l'article 232072 de la Base de connaissances sur le lancement de la réplication entre des partenaires de réplication directe dans Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Pour plus d'informations sur le processus DS2MB, consultez l'article 240105 de la Base de connaissances sur les informations générales sur le processus DS2MB (Directory Service/Metabase Synchronization) dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Il existe une incohérence dans le paramètre du nombre maximal de sauts entre Active Directory et la métabase
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété suivante dans la métabase IIS (Internet Information Services) pour déterminer si sa valeur correspond à la valeur configurée de l'attribut msExchSmtpMaxHopCount dans le service d'annuaire Active Directory® :

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

Si Exchange Server Analyzer détecte que les valeurs ne correspondent pas, un avertissement s'affiche.

Si la valeur dans la métabase IIS ne correspond pas à la valeur dans Active Directory, il peut s'agir d'un problème de réplication d'Active Directory ou du composant de réplication Directory-service-to-Metabase (DS2MB) dans Exchange.

Le processus DS2MB permet de transférer les informations de configuration d'Active Directory vers la métabase locale. Cette configuration est stockée dans la métabase locale au lieu du Registre pour des raisons de performance et d'évolutivité. Tous les protocoles Internet (SMTP, NNTP, POP3, IMAP4 et HTTP) s'exécutent en tant que composants IIS dans Exchange 2000 Server et Exchange Server 2003.

Toutes les 15 minutes, le processus DS2MB copie des sous-arborescences entières d'Active Directory sans changer leur forme. Il s'agit d'une écriture monodirectionnelle d'Active Directory vers la métabase ; la métabase n'écrit jamais dans Active Directory.

Sur un serveur virtuel SMTP Exchange 2000 Server, le nombre de sauts par défaut est 15. Sur un serveur virtuel SMTP Exchange Server 2003, le nombre de sauts par défaut est 30. Quelle que soit la valeur configurée, si la propriété HopCount et l'attribut msExchSmtpMaxHopCount ne correspondent pas, cela signifie qu'Active Directory et la métabase IIS ne sont pas synchronisés. Si le problème est dû à un échec du processus DS2MB, vous pouvez le corriger en suivant la procédure ci-dessous pour la version d'Exchange Server que vous exécutez. Si le problème est dû à un échec de réplication partiel ou complet d'Active Directory, vous pouvez utiliser l'utilitaire du moniteur de réplication d'Active Directory (ReplMon.exe) pour vérifier le bon fonctionnement et l'état de réplication d'Active Directory. Vous pouvez trouver Replmon.exe dans les outils de support de Microsoft Windows® sur le CD-ROM de Windows Server™ 2003.

Pour corriger cette erreur dans Exchange Server 2003

  1. Recherchez la présence d'entrées de journal des événements Applications avec une source de MSExchangeMU. Si le processus DS2MB échoue, il consignera un événement dans Exchange Server 2003.

  2. Si tous les échecs du processus DS2MB n'apparaissent pas, utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  3. Redémarrez le service Surveillance du système Exchange si vous constatez des échecs du processus DS2MB ou après avoir supprimé ou résolu tous les problèmes de réplication d'Active Directory.

Pour corriger cette erreur dans Exchange 2000 Server

  1. Utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  2. Redémarrez le service Surveillance du système Exchange après avoir supprimé ou résolu tous les problèmes de réplication d'Active Directory.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, voir l'article 297412 de la Base de connaissances Microsoft sur l'option Exécuter une recherche DNS inversée sur les messages entrants qui correspond à une résolution de nom d'hôte (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Pour plus d'informations sur la réplication d'Active Directory, voir l'article 232072 de la Base de connaissances sur le lancement de la réplication entre des partenaires de réplication directe dans Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Pour plus d'informations sur le processus DS2MB, voir l'article 240105 de la Base de connaissances sur les informations générales sur le processus DS2MB (Directory Service/Metabase Synchronization) dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Il existe une incohérence dans le paramètre de taille de message maximale entre Active Directory et la métabase
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété suivante dans la métabase IIS (Internet Information Services) pour déterminer si sa valeur correspond à la valeur configurée de l'attribut msExchSmtpMaxMessageSize dans le service d'annuaire Active Directory® :

/LM/SmtpSvc/<instance de serveur virtuel SMTP>/MaxMessageSize

Si Exchange Server Analyzer détecte que les valeurs ne correspondent pas, un avertissement s'affiche.

Si la valeur dans la métabase IIS ne correspond pas à la valeur dans Active Directory, il peut s'agir d'un problème de réplication d'Active Directory ou du composant de réplication Directory-service-to-Metabase (DS2MB) dans Exchange.

Le processus DS2MB permet de transférer les informations de configuration d'Active Directory vers la métabase locale. Cette configuration est stockée dans la métabase locale au lieu du Registre pour des raisons de performance et d'évolutivité. Tous les protocoles Internet (SMTP, NNTP, POP3, IMAP4 et HTTP) s'exécutent en tant que composants IIS dans Exchange 2000 Server et Exchange Server 2003.

Toutes les 15 minutes, le processus DS2MB copie des sous-arborescences entières d'Active Directory sans changer leur forme. Il s'agit d'une écriture monodirectionnelle d'Active Directory vers la métabase ; la métabase n'écrit jamais dans Active Directory.

La propriété MaxMessageSize et l'attribut msExchSmtpMaxMessageSize utilisent un paramètre par défaut de 0, ce qui signifie qu'il n'existe aucune taille limite de message imposée. Si la propriété MaxMessageSize et l'attribut msExchSmtpMaxMessageSize n'ont pas la même valeur, cela signifie qu'Active Directory et la métabase IIS ne sont pas synchronisés. Si le problème est dû à un échec du processus DS2MB, vous pouvez le corriger en suivant la procédure ci-dessous pour la version d'Exchange Server que vous exécutez. Si le problème est dû à un échec de réplication partiel ou complet d'Active Directory, vous pouvez utiliser l'utilitaire du moniteur de réplication d'Active Directory (ReplMon.exe) pour vérifier le bon fonctionnement et l'état de réplication d'Active Directory. Vous pouvez trouver Replmon.exe dans les outils de support de Microsoft Windows® sur le CD-ROM de Windows Server™ 2003.

Pour corriger cette erreur dans Exchange Server 2003

  1. Recherchez la présence d'entrées de journal des événements Applications avec une source de MSExchangeMU. Si le processus DS2MB échoue, il consignera un événement dans Exchange Server 2003.

  2. Si tous les échecs du processus DS2MB n'apparaissent pas, utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  3. Redémarrez le service Surveillance du système Exchange si vous constatez des échecs du processus DS2MB ou après avoir supprimé ou résolu tous les problèmes de réplication d'Active Directory.

Pour corriger cette erreur dans Exchange 2000 Server

  1. Utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  2. Redémarrez le service Surveillance du système Exchange après avoir supprimé ou résolu tous les problèmes de réplication d'Active Directory.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, voir l'article 297412 de la Base de connaissances Microsoft sur l'option Exécuter une recherche DNS inversée sur les messages entrants qui correspond à une résolution de nom d'hôte (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Pour plus d'informations sur la réplication d'Active Directory, voir l'article 232072 de la Base de connaissances sur le lancement de la réplication entre des partenaires de réplication directe dans Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Pour plus d'informations sur le processus DS2MB, voir l'article 240105 de la Base de connaissances sur les informations générales sur le processus DS2MB (Directory Service/Metabase Synchronization) dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


Différence du paramètre de taille de session entre Active Directory et la métabase
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool lit la propriété /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize dans la métabase IIS (Internet Information Services) pour déterminer si sa valeur correspond à la valeur configurée de l'attribut msExchSmtpMaxSessionSize dans le service d'annuaire Active Directory®.

Si Exchange Server Analyzer détecte que les valeurs ne correspondent pas, un message d'avertissement s'affiche.

Si la valeur dans la métabase IIS ne correspond pas à la valeur dans Active Directory, il peut s'agir d'un problème de réplication d'Active Directory ou du composant de réplication Directory-service-to-Metabase (DS2MB) dans Exchange.

Le processus DS2MB permet de transférer les informations de configuration d'Active Directory vers la métabase locale. Cette configuration est stockée dans la métabase locale au lieu du Registre pour des raisons de performance et d'évolutivité. Tous les protocoles Internet (SMTP, NNTP, POP3, IMAP4 et HTTP) s'exécutent en tant que composants IIS dans Exchange 2000 Server et Exchange Server 2003.

Toutes les 15 minutes, le processus DS2MB copie des sous-arborescences entières d'Active Directory sans changer leur forme. Il s'agit d'une écriture monodirectionnelle d'Active Directory vers la métabase ; la métabase n'écrit jamais dans Active Directory.

La propriété MaxSessionSize et l'attribut msExchSmtpMaxSessionSize utilisent un paramètre par défaut de 0 signifiant qu'il n'existe aucune taille limite de session imposée. Si la propriété MaxSessionSize et l'attribut msExchSmtpMaxSessionSize n'ont pas la même valeur, cela signifie qu'Active Directory et la métabase IIS ne sont pas synchronisés. Si le problème est dû à un échec du processus DS2MB, vous pouvez le corriger en suivant la procédure ci-dessous pour la version d'Exchange Server que vous exécutez. Si le problème est dû à un échec de réplication partiel ou complet d'Active Directory, vous pouvez utiliser l'utilitaire du moniteur de réplication d'Active Directory (ReplMon.exe) pour vérifier le bon fonctionnement et l'état de réplication d'Active Directory. ReplMon se trouve dans les outils de support de Microsoft Windows® sur le CD-ROM de Windows Server™ 2003.

Pour corriger cette erreur dans Exchange Server 2003

  1. Recherchez la présence d'entrées de journal des événements Applications avec une source de MSExchangeMU. Si le processus DS2MB échoue, il consignera un événement dans Exchange Server 2003.

  2. Si tous les échecs du processus DS2MB n'apparaissent pas, utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  3. Redémarrez le service Surveillance du système Exchange si vous constatez des échecs du processus DS2MB ou après avoir corrigé tous les problèmes de réplication d'Active Directory.

Pour corriger cette erreur dans Exchange 2000 Server

  1. Utilisez ReplMon pour diagnostiquer la réplication d'Active Directory. Prêtez une attention particulière aux serveurs de catalogue global utilisés par votre serveur virtuel SMTP.

  2. Redémarrez le service Surveillance du système Exchange après avoir supprimé ou résolu tous les problèmes de réplication d'Active Directory.

Pour plus d'informations sur la fonction de recherche DNS inversée d'Exchange, voir l'article 297412 de la Base de connaissances Microsoft sur l'option Exécuter une recherche DNS inversée sur les messages entrants qui correspond à une résolution de nom d'hôte (http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412).

Pour plus d'informations sur les paramètres du serveur virtuel SMTP, voir les articles suivants de la Base de connaissances :

  • 266686 sur la procédure de configuration d'un serveur virtuel SMTP (première partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686)

  • 268163 sur la procédure de configuration d'un serveur virtuel SMTP (deuxième partie) (http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163)

Pour plus d'informations sur la réplication d'Active Directory, voir l'article 232072 de la Base de connaissances sur le lancement de la réplication entre des partenaires de réplication directe dans Active Directory (http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072).

Pour plus d'informations sur le processus DS2MB, voir l'article 240105 de la Base de connaissances sur les informations générales sur le processus DS2MB (Directory Service/Metabase Synchronization) dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105).


L'événement Avertissement du gestionnaire de connexion de transport a été enregistré lors des dernières 24 heures
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si un avertissement Événement 4006 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures.

Si Exchange Server Analyzer détecte qu'un avertissement Événement 4006 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures, il affiche un avertissement.

Ce dernier indique généralement qu'une tentative d'envoi de messages électroniques à un serveur distant a échoué.

Un Événement 4006 MSExchangeTransport peut se produire pour l'une des raisons suivantes :

  • La connexion a été abandonnée par l'hôte distant.

  • Le service SMTP (Simple Mail Transfer Protocol) a rejeté la négociation AUTH.

  • Le serveur qui tente de transmettre le message ne peut pas accéder aux informations de remise contenues dans le message.

  • Une erreur SMTP s'est produite.

  • Le serveur qui essaie de transmettre le message ne peut pas se connecter au serveur distant.

  • Un hôte actif spécifié dans les propriétés du serveur virtuel SMTP n'est pas joignable pour une raison quelconque.

Pour plus d'informations sur un avertissement Événement 4006 MSExchangeTransport, vous pouvez trouver les détails de l'événement dans le centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).

Pour plus d'informations sur les problèmes de relais de messages dans Exchange Server 2000, voir l'article 895853 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de relais de messagerie dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

Pour plus d'informations sur les problèmes de flux de messages et de SMTP, voir la rubrique appropriée du Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).


Un événement Avertissement du gestionnaire de connexion de transport a été enregistré lors des dernières 24 heures
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-07-07

L'outil Microsoft® Exchange Server Analyzer Tool interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_NTLogEvent pour déterminer si un avertissement Événement 4001 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures.

Si Exchange Server Analyzer détecte qu'un avertissement Événement 4001 a été enregistré pour MSExchangeTransport au cours des dernières 24 heures, il affiche un avertissement.

Ce dernier indique généralement qu'une tentative d'envoi de messages électroniques à un serveur distant a échoué.

Un Événement 4001 MSExchangeTransport peut se produire lorsque le service SMTP (Simple Mail Transfer Protocol) sur Exchange 2000 Server ou Exchange Server 2003 rencontre un ou plusieurs problèmes de remise de messages. Les causes possibles de ces problèmes de remise peuvent être notamment des problèmes de DNS (Domain Name System), de configuration IP ou d'installation de fichiers DLL incorrects.

Pour plus d'informations sur un avertissement Événement 4001, vous pouvez trouver les détails de l'événement dans le centre des événements et messages d'erreur (http://go.microsoft.com/fwlink/?LinkId=34258).

Pour plus d'informations sur les problèmes de relais de messages dans Exchange Server 2000, voir l'article 895853 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes de relais de messagerie dans Exchange Server 2003 et Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853).

Pour plus d'informations sur les problèmes de flux de messages et de SMTP, voir la rubrique appropriée du Guide de transport et de routage Exchange Server (http://go.microsoft.com/fwlink/?LinkID=67875).


Fichier du récepteur d'événements de transport introuvable
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-01-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge la métabase IIS (Internet Information Server) Microsoft pour énumérer la liste des liaisons des récepteurs d'événements de transport SMTP (Simple Mail Transport Protocol). Exchange Server Analyzer essaie de rechercher plusieurs liaisons d'événements standard sur la base d'une liste préremplie dans Exchange Server Analyzer. Pour chaque liaison, Exchange Server Analyzer vérifie les détails d'enregistrement COM (Component Object Model) dans le Registre sous la branche suivante :

HKEY_CLASSES_ROOT\CLSID\

Les détails d'enregistrement COM comprennent le chemin d'accès complet du fichier .dll associé. Exchange Server Analyzer utilise Microsoft Windows® Management Instrumentation (WMI) pour retrouver le fichier .dll et afficher son numéro de version. Si Exchange Server Analyzer ne retrouve pas le fichier .dll, il affiche un avertissement avec le nom et le chemin d'accès du fichier .dll manquant

Si Exchange Server Analyzer détermine qu'une ou plusieurs liaisons d'événements standard sont manquantes, il génère un avertissement.

Un événement de transport SMTP survient lorsque des données de messages sont transportées vers l'intérieur ou l'extérieur d'un service SMTP. Tous les messages passent par des événements, notamment les messages X.400 et RPC entrants ou sortants. Un exemple commun d'un événement de transport entrant est l'arrivée d'un message dans le service SMTP via le réseau ou dans le répertoire de collecte SMTP. Lorsque cet événement de transport survient, une source de cet événement notifie les récepteurs d'événements de transport, dont chacun peut réaliser un type d'action sur la base du contenu des données du message. Le système n'effectue aucune autre action avec les données du message après les avoir transmises au récepteur jusqu'à ce que ce dernier termine l'action et renvoie le message. Le récepteur détient le contrôle exclusif des données du message et de son état lorsqu'il effectue cette action.

Les fichiers .dll manquants pour les enregistrements COM de récepteur d'événements de transport peuvent provoquer des problèmes de flux de messages. Si Exchange Server présente des symptômes de problèmes de flux de messages, tels que des files d'attente de messages, vérifiez que les fichiers .dll identifiés sont présents et réinstallez-les au besoin.

Pour résoudre ce problème

  1. Utilisez l'Explorateur pour rechercher manuellement le fichier .dll identifié. Généralement, ce fichier se situe dans le dossier \Program Files\Exchsrvr\Bin.

  2. Vous pouvez ignorer en toute sécurité l'avertissement généré par Exchange Server Analyzer si les conditions suivantes sont vraies :

    • Le fichier .dll est présent dans le dossier répertorié.

    • Le serveur ne semble pas avoir de problèmes de flux de messages.

  3. Copiez le fichier .dll manquant à partir du support d'installation original d'Exchange Server si les conditions suivantes sont vraies :

    • Le fichier .dll n'est pas présent dans le dossier répertorié par Exchange Server Analyzer.

    • Le serveur semble rencontrer des problèmes de flux de messages.

    Vous pouvez également réappliquer le dernier Service Pack Exchange.

  4. Réexécutez Exchange Server Analyzer pour vérifier que l'avertissement ne s'affiche plus.


Les modifications de version utilisateur des informations d'état des liens sont supprimées
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2005-11-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer si l'attribut heuristics a été configuré pour supprimer les modifications de version utilisateur des informations d'état des liens. Par défaut, l'attribut heuristics n'est pas configuré. Si Exchange Server Analyzer détecte que l'attribut heuristics est défini sur 2048, il affiche un message indiquant une configuration autre que celle par défaut.

Les tables d'état des liens sont utilisées pour garantir un routage des messages efficace et fiable. La table d'état des liens contient des informations de version pour chaque groupe de routage sous la forme de numéros de version majeure, mineure et utilisateur. Les modifications de versions majeures ont la priorité la plus élevée, suivies par les modifications mineures et enfin par les modifications de version utilisateur.

Les modifications de version utilisateur ont lieu lors d'une mise à jour du service d'annuaire au niveau de base. Ces petites modifications comprennent des modifications de maître de groupe de routage, lorsque des services sont démarrés ou arrêtés sur un serveur Exchange, lorsqu'un autre serveur est ajouté au groupe de routage, ou lorsqu'un serveur membre est déconnecté du maître de groupe de routage.

Une mise à jour du service d'annuaire au niveau de base peut se produire lorsqu'un administrateur Exchange Server modifie un élément au niveau du groupe de routage. Par exemple, une modification de version utilisateur survient lorsqu'un administrateur modifie un nom de groupe de routage, ajoute un serveur ou en supprime un. Toutefois, la principale cause des modifications de version utilisateur sont les données WMI (Windows® Management Instrumentation) Microsoft de chaque serveur. Ces données indiquent les services en cours d'exécution. Si vous arrêtez et redémarrez un service, les modifications de version utilisateur dans le tableau d'état des liens sont répliquées sur tous les ordinateurs Exchange Server de l'organisation.

Les mises à jour fréquentes de version utilisateur peuvent provoquer une quantité indésirable de trafic réseau et peuvent être supprimées à l'aide d'un correctif obtenu auprès des services du Support Technique de Microsoft, puis en définissant l'attribut heuristics sur 2048 (0x800 en hexadécimal).

Si les mises à jour de version utilisateur ne génère pas de trafic réseau excessif, il est recommandé de ne pas les supprimer.

Pour rétablir la configuration par défaut

  1. Ouvrez ADSI (Active Directory Service Interfaces) Edit.

  2. Dans ADSI Edit, développez Conteneur Configuration, CN=Configuration, DC=Nom_domaine, DC=com, CN=Services, puis CN=Microsoft Exchange.

  3. Cliquez avec le bouton droit sur CN=Nom_Organisation, puis cliquez sur Propriétés.

  4. Dans la zone Sélectionnez une propriété à afficher, cliquez sur Heuristics.

  5. Dans la boîte de dialogue Modifier l'attribut, effacez la valeur 0x800.

  6. Cliquez sur Définir, puis sur OK.

  7. Fermez ADSI Edit.
Attention :
Si vous ne modifiez pas correctement les attributs des objets Active Directory lors de l'utilisation d'ADSI Edit, de l'outil LDP (ldp.exe) ou de tout autre client LDAP (Lightweight Directory Access Protocol) version 3, vous vous exposez à de graves problèmes. Ces problèmes peuvent nécessiter la réinstallation de Microsoft Windows Server™ 2003, d'Exchange Server 2003 ou des deux. Si vous modifiez les attributs d'objet Active Directory, vous devez en assumer les risques.

Pour plus d'informations sur l'état des liens et les numéros de version utilisateur, voir le chapitre sur la propagation de l'état des liens du Guide de référence technique de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=49367).


Identification de l'utilisateur comme destination commune
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-09-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Exchange_Queue pour déterminer les valeurs des attributs suivants pour les files d'attente SMTP (Simple Mail Transfer Protocol) sur le serveur virtuel SMTP.

LinkId | Indique l'identificateur du lien contenant la file d'attente.
QueueId | Indique l'identificateur de la file d'attente.
QueueName | Indique le nom de la file d'attente.
VirtualMachine | Indique le nom de la machine virtuelle contenant la file d'attente.
VirtualServerName | Indique le nom du serveur virtuel contenant la file d'attente.
MessageCount | Indique le nombre de messages dans la file d'attente.

Exchange Server Analyzer utilise les informations obtenues ci-avant pour interroger la classe WMI Exchange_QueuedSMTPMessage afin d'obtenir les valeurs des attributs suivants des messages figurant dans la file d'attente :

Recipients | Indique les destinataires du message.
Received | Indique l'horodatage reçu pour le message.
MessageId | Indique l'identificateur du message en file d'attente.
StateRetry | Indique qu'une nouvelle tentative de transmission a lieu pour un message qui n'a pas été remis avec succès.

Enfin, en utilisant les données recueillies suite à la requête précédente, Exchange Server Analyzer interroge le service d'annuaire Active Directory® pour obtenir les valeurs suivantes de chaque objet Destinataire afin de déterminer si le destinataire est un utilisateur, un groupe de distribution, un dossier public ou une banque de dossiers publics :

distinguishedName | Indique le nom unique de l'objet.
msExchHomeServerName | Indique le serveur sur lequel le destinataire est hébergé.
homeMDB | Indique la banque de boîtes aux lettes du destinataire.

Si Exchange Server Analyzer détermine qu'au moins 25 % des messages bloqués dans la file d'attente sont adressés, dans le champ À : ou Cc :, à un utilisateur particulier, Exchange Server Analyzer affiche un message d'avertissement.

Si Exchange Server Analyzer détermine qu'au moins 50 % des messages bloqués dans la file d'attente sont adressés, dans le champ À : ou Cc :, à un utilisateur particulier, Exchange Server Analyzer affiche un message d'erreur.

Ce message d'avertissement ou d'erreur signifie que l'utilisateur identifié est une destination commune des messages bloqués dans une file d'attente SMTP.

Pour résoudre ce problème, il convient de vérifier s'il y a des problèmes de configuration ou d'autres anomalies en relation avec l'utilisateur, qui pourraient être à l'origine de la mise en file d'attente des messages.

Les domaines d'investigation sont les suivants :

  • Assurez-vous que les attributs de l'objet utilisateur sont correctement définis et contiennent les valeurs correctes dans Active Directory.

  • Vérifiez que les autorisations Active Directory de l'objet utilisateur sont correctement paramétrées.

  • Recherchez la présence éventuelle de publicités commerciales non sollicitées (UCE ou SPAM) ou d'attaques de virus dirigées contre l'utilisateur.

  • Déterminez si l'utilisateur appartient à un groupe de distribution dont les restrictions de remise définies sont incorrectes.

  • Si un objet utilisateur est un usage particulier, à savoir un destinataire de la journalisation désigné, examinez les configurations du service ou des composants auxquels l'objet utilisateur est associé pour vérifier si la configuration est correcte.

Pour plus d'informations sur la procédure de dépannage des files d'attente SMTP, consultez les ressources Exchange suivantes :

  • Rubrique sur la résolution des problèmes de flux de messages et SMTP dans le Guide de transport et de routage Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkID=67875).

  • Article 823489 de la Base de connaissances Microsoft sur l'utilisation de l'Afficheur des files d'attente pour résoudre les problèmes de flux de messages dans Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489)

Pour plus d'informations sur l'effet des restrictions des groupes de distribution sur le flux de messages Exchange Server, consultez les articles suivants de la Base de connaissances Microsoft :

  • 895407 sur la lenteur de la remise de messages dans les boîtes aux lettres locales et externes dans Exchange Server 2003 après la configuration des restrictions de remise de messages sur la base de groupes de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407).

  • 329171 sur la lenteur de la remise du courrier si les destinataires sont configurés avec des restrictions de remise sur la base de l'appartenance au groupe (http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171).

  • 839949 sur la résolution des problèmes de transport du courrier et des groupes de distribution dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949).

  • 812298 sur la lenteur de la remise du courrier après configuration des restrictions de remise sur la base d'une liste de distribution (http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298).


Problème SMTP inconnu
Microsoft Exchange Server Analyzer - Articles > Transport >

Dernière rubrique modifiée : 2006-10-06

L'outil Microsoft® Exchange Server Analyzer interroge la classe WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer la valeur de la clé Started pour le service SMTP (Simple Mail Transfer Protocol). La valeur False indique que le service SMTP n'est pas en cours d'exécution. La valeur True indique que le service SMTP est en cours d'exécution.

Exchange Server Analyzer interroge également la métabase des services internet (IIS) pour déterminer la valeur de la propriété ServerState pour l'instance de serveur virtuel SMTP.

La propriété ServerState présente l'état actuel de l'instance de serveur. Les codes d'état et les états correspondants sont les suivants :

Code d'état | État
1 | Démarrage
2 | Démarré
3 | Arrêt
4 | Arrêté
5 | Pause
6 | Suspendu
7 | Reprise

Exchange Server Analyzer affiche un avertissement si les conditions suivantes sont vraies :

  • Le service SMTP est en cours d'exécution.

  • Toutes les instances de serveur virtuel SMTP sur le serveur ont démarré.

Ce message d'avertissement indique que, bien que le service SMTP et les instances de serveur virtuel SMTP semblent fonctionner, un problème nécessitant une investigation supplémentaire empêche les ports SMTP de répondre correctement.

Les raisons suivantes peuvent expliquer ce problème :

  • Le service SMTP est bloqué.

  • Un pare-feu ou une application antivirus bloque la communication vers les ports SMTP.

Pour résoudre ce problème :

  • Redémarrez le service SMTP.

  • Examinez la configuration de l'ensemble des pare-feu et applications antivirus en relation avec les ports SMTP.

  • Consultez les recommandations et les liens relatifs à l'erreur fournis par Exchange Server Analyzer.

Démarrage, arrêt ou suspension du service SMTP

  1. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Services de composants.

  2. Dans l'arborescence de la console, cliquez sur Services (Local).

  3. Dans le volet Résultats, cliquez avec le bouton droit sur SMTP (Simple Mail Transfer Protocol), puis cliquez sur Démarrer, Arrêter ou Suspendre.


État de préparation d'Exchange Server 2007
Microsoft Exchange Server Analyzer - Articles >

Dernière rubrique modifiée : 2006-07-18

Les articles de cette section fournissent des détails sur les éléments évalués par l'outil Microsoft® Exchange Server Analyzer Tool concernant l'état de préparation d'Exchange Server 2007. En outre, ils décrivent les actions possibles pour corriger les erreurs liées aux conditions préalables, les avertissements et les configurations autres que celles par défaut détectés par Exchange Server Analyzer.


L'héritage de la liste de contrôle d'accès est bloqué
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-06-19

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car les autorisations requises ne peuvent pas se propager.

Le programme d'installation d'Exchange nécessite que l'héritage des autorisations soit activé sur les objets d'arborescence de dossier public.

Pour résoudre ce problème, assurez-vous que le réglage « Permettre aux autorisations de se propager à cet objet et ces objets enfants » est activé, puis réexécutez le programme d'installation d'Exchange Server 2007.

Pour réactiver l'héritage d'arborescence de dossiers publics

  1. Ouvrez le Gestionnaire système Exchange Server 2003.

  2. Cliquez avec le bouton droit sur la banque de dossiers publics, puis cliquez sur Propriétés.

  3. Cliquez sur l'onglet Sécurité, puis cliquez pour activer la case à cocher Permettre aux autorisations héritées de se propager à cet objet.


L'extension de schéma Active Directory nécessite que Ldifde.exe soit installé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-06-19

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car l'ordinateur local ne peut pas mettre à jour le schéma d'Active Directory.

Le programme d'installation de Microsoft Exchange nécessite que Ldifde.exe soit installé sur l'ordinateur local pour créer les extensions nécessaires au schéma d'Active Directory.

Pour résoudre ce problème, installez Ldifde.exe sur l'ordinateur local et réexécutez le programme d'installation d'Exchange Server 2007 ou démarrez le programme d'installation d'Exchange Server 2007 à partir d'un contrôleur de domaine.

Remarque :
Lorsque le schéma d'Active Directory a été étendu, des rôles serveurs Exchange 2007 peuvent être installés sur l'ordinateur local sans devoir installer ldifde.exe.
Pour installer Ldifde.exe sur l'ordinateur local

  1. Cliquez sur Démarrer, Exécuter et, dans le champ Ouvrir, exécutez 'ServerManagerCmd -i RSAT-ADDS'


Le chemin d'installation ADAM existe
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-26

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installation d'Active Directory en mode application (ADAM) a échoué.

Une installation antérieure d'ADAM existe dans l'emplacement par défaut. Le programme d'installation d'Exchange ne peut pas réaliser une nouvelle installation d'ADAM dans une structure d'annuaire ADAM existante.

Pour résoudre ce problème, supprimez le dossier ADAM existant et réexécutre le programme d'installation d'Exchange.


ADAM n'est pas installé sur l'ordinateur local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-22

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car ADAM (Active Directory Application Mode) n'est pas installé sur cet ordinateur.

ADAM est un service d'annuaire LDAP (Lightweight Directory Access Protocol) conçu spécifiquement en vue d'une utilisation avec des applications compatibles avec l'annuaire. ADAM ne stocke et réplique que les informations spécifiques aux applications ; il ne nécessite pas de déploiement sur un contrôleur de domaine et ne dépend pas du service d'annuaire Active Directory. ADAM ne fournit pas d'authentification ni d'autorisation de système d'exploitation de réseau.

Dans Exchange 2007, le rôle serveur de transport Exchange utilise ADAM pour stocker les informations de configuration. Lorsque ADAM est synchronisé avec Active Directory, il peut également permettre d'effectuer une recherche de destinataires pour la sécurité des messages.

Le programme d'installation de Microsoft Exchange nécessite que le service ADAM soit installé sur l'ordinateur local pour pouvoir poursuivre.

Pour résoudre ce problème, installez ADAM Service Pack 1 (SP1) à partir de la rubrique sur Active Directory Application Mode (ADAM) (http://go.microsoft.com/fwlink/?linkid=71063) et recommencez le programme d'installation.


ADAM n'est pas installé sur l'ordinateur local (Longhorn)
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-08-13

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car ADAM (Active Directory Application Mode) n'est pas installé sur cet ordinateur Windows Server 2008.

ADAM est un service d'annuaire LDAP (Lightweight Directory Access Protocol) conçu spécifiquement en vue d'une utilisation avec des applications compatibles avec l'annuaire. ADAM ne stocke et réplique que les informations spécifiques aux applications ; il ne nécessite pas de déploiement sur un contrôleur de domaine et ne dépend pas du service d'annuaire Active Directory. ADAM ne fournit pas d'authentification ni d'autorisation de système d'exploitation de réseau.

Dans Exchange 2007, le rôle serveur de transport Exchange utilise ADAM pour stocker les informations de configuration. Lorsque ADAM est synchronisé avec Active Directory, il peut également permettre d'effectuer une recherche de destinataires pour la sécurité des messages.

Le programme d'installation de Microsoft Exchange nécessite que le service ADAM soit installé sur l'ordinateur local pour pouvoir poursuivre.

Pour résoudre ce problème, installez ADAM sur l'ordinateur local qui exécute le système d'exploitation Windows Server 2008, puis réexécutez le programme d'installation.

Pour installer ADAM sur le système d'exploitation Windows Server 2008

  1. Cliquez sur Démarrer, sélectionnez Exécuter, puis entrez la commande suivante :

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. Exécutez une nouvelle fois le programme d'installation d'Exchange 2007.


Avertissement de recherche d'analyseur
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-08-09

Cette rubrique est destinée à résoudre un problème spécifique signalé par l'outil Exchange Server Analyzer Tool. Ne l'appliquez qu'à des systèmes sur lesquels l'outil Exchange Server Analyzer Tool a été exécuté et qui ont rencontré ce problème spécifique.

L'outil Exchange Server Analyzer Tool, disponible sous forme de téléchargement gratuit, collecte à distance des données de configuration de chaque serveur de la topologie et les analyse automatiquement. Il génère un rapport qui détaille les problèmes de configuration importants, les problèmes potentiels et les paramètres du produit qui ne sont pas définis par défaut. En suivant ces recommandations, vous pouvez accroître les performances, l'évolutivité, la fiabilité et la disponibilité.

Pour plus d'informations sur l'outil ou pour télécharger les versions les plus récentes, voir la rubrique sur les analyseurs Microsoft Exchange à l'adresse http://go.microsoft.com/fwlink/?linkid=34707.


Avertissement de compatibilité 32 bits
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-08-13

Le programme d'installation de Microsoft Exchange Server 2007 affiche cet avertissement parce que vous installez la version 32 bits de Microsoft Exchange.

Exchange 2007 est disponible en deux versions de plateforme : une version de plateforme (64 bits) est destinée aux environnements de production actifs et l'autre (version 32 bits) aux environnements autres que de production (laboratoires, formation, démonstration et évaluation). Vous ne pouvez acheter que la version 64 bits car vous ne pouvez pas utiliser de serveurs Exchange 2007 32 bits en environnement de production.

Il y a deux exceptions à l'utilisation en environnement de production et de non-production de la plateforme 32 bits parce que Microsoft permet une utilisation minimale de la version 32 bits en environnement de production, à savoir :

  • Vous pouvez utiliser la version 32 bits des outils de gestion Exchange en production pour administrer des serveurs Exchange 2007 à partir de Windows Server 2003 ou Windows XP. Actuellement, vous n'avez pas le choix entre l'utilisation de la version 32 bits ou de la version 64 bits sur Windows Vista ou sur Windows Server 2008. La prise en charge de Windows Vista et Windows Server 2008 devrait être intégrée dans le Service Pack 1 pour Exchange 2007.

  • Vous pouvez utiliser la version 32 bits du programme d'installation en environnement de production pour étendre votre schéma du service d'annuaire Active Directory. Pour obtenir la procédure détaillée de la préparation d'Active Directory pour Exchange 2007, voir la rubrique sur la procédure de préparation d'Active Directory et des domaines.

Aucune autre utilisation de la version 32 bits d'Exchange 2007 en environnement de production n'est prise en charge.

Pour télécharger la version 32 bits des outils de gestion d'Exchange, voir la rubrique que les outils de gestion de Microsoft Exchange Server 2007 (32 bits) (http://go.microsoft.com/fwlink/?LinkId=82335). Pour plus d'informations sur les versions de la plateforme Exchange 2007, voir la rubrique sur les plateformes, les éditions et les versions d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=88051) dans la documentation sur le produit Exchange 2007.


Installation requise de la mise à jour du fuseau horaire de 2007 pour les systèmes d'exploitation Microsoft Windows
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-02-20

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas se poursuivre car une mise à jour permettant de corriger la configuration des informations de fuseau horaire est requise pour cet ordinateur.

Le programme d'installation d'Exchange 2007 requiert l'installation de la mise à jour du fuseau horaire pour les systèmes d'exploitation Windows mentionnée dans l'article 931836 de la Base de connaissances Microsoft.

Pour résoudre ce problème, installez la mise à jour mentionnée dans l'article 931836 de la Base de connaissances Microsoft, « Mise à jour du fuseau horaire cumulative de février 2007 pour les systèmes d'exploitation Microsoft Windows » (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836), puis recommencez l'installation d'Exchange 2007.


Active Directory n'existe pas ou ne peut pas être contacté
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-04-18

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car il est incapable de contacter un site de service d'annuaire Active Directory valide.

Le programme d'installation d'Exchange 2007 nécessite que le serveur utilisé pour l'installation de Microsoft Exchange soit capable de trouver le contexte d'appellation de configuration dans Active Directory.

Pour résoudre ce problème, assurez-vous que le compte d'utilisateur qui exécute le programme d'installation de Microsoft Exchange est bien connecté à Active Directory, puis exécutez de nouveau le programme d'installation. Si le problème persiste, follow the guidancesuivez les instructions du fournisseur en utilisant les outils NETDIAG.Exe et DCDIAG.Exe dans les rubriques suivantes pour établir un nouveau diagnostic du problème.

Pour plus d'informations sur le dépannage d'Active Directory et sa configuration pour Microsoft Exchange, voir les documents suivants :

  • section sur le dépannage des opérations d'Active Directory du guide des opérations de Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=68099).

  • section sur les outils de dépannage d'Active Directory dans le guide des opérations d'Active Directory (http://go.microsoft.com/fwlink/?LinkId=68100).

  • section sur le contexte d'appellation de configuration dans la rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).

  • rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).

  • Vue d'ensemble de Netdiag (http://go.microsoft.com/fwlink/?LinkID=69481).

  • Vue d'ensemble de Dcdiag (http://go.microsoft.com/fwlink/?LinkID=68936).


Domaine Active Directory en mode mixte
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-10

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le domaine Active Directory n'est pas défini sur le mode Microsoft Windows®°2000 Server natif ou mieux.

Le programme d'installation d'Exchange 2007 va créer des groupes de sécurité universel qui ne peuvent exister que dans les domaines Windows 2000 Server en mode natif ou mieux.

Pour résoudre ce problème, suivez les étapes ci-après pour augmenter le niveau fonctionnel du domaine jusqu'au moins le niveau Windows 2000 Server natif, puis réexécutez le programme d'installation d'Exchange 2007.

Pour augmenter le niveau fonctionnel du domaine

  1. Ouvrez le composant Domaines et approbations Active Directory.

  2. Dans l'arborescence de la console, cliquez avec le bouton droit sur le domaine dont vous souhaitez augmenter les fonctionnalités, puis cliquez sur Augmenter le niveau fonctionnel du domaine.

  3. Dans Sélectionner un niveau fonctionnel du domaine disponible, utilisez l'une des procédures suivantes :

    • Pour augmenter le niveau fonctionnel du domaine jusqu'à Windows 2000 Server natif, cliquez sur Windows 2000 natif, puis sur Augmenter.

    • Pour augmenter le niveau fonctionnel du domaine jusqu'à Windows Server® 2003, cliquez sur Windows Server 2003, puis sur Augmenter.
Attention :

Si vous disposez ou allez disposer de contrôleurs de domaine exécutant Windows NT® 4.0 et antérieur, n'augmentez pas le niveau fonctionnel du domaine jusqu'à Windows 2000 Server natif. Une fois le niveau fonctionnel du domaine défini sur Windows 2000 Server natif, il ne peut plus être ramené à Windows 2000 Server mixte.

Si vous disposez ou allez disposer de contrôleurs de domaine exécutant Windows NT® 4.0 et antérieur, n'augmentez pas le niveau fonctionnel du domaine jusqu'à Windows Server 2003. Une fois le niveau fonctionnel du domaine défini sur Windows Server 2003, il ne peut plus être ramené à Windows 2000 Server mixte ou Windows 2000 Server natif.


Préparation d'Active Directory requise
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-26

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative de préparation de domaine a échoué.

Le programme d'installation d'Exchange nécessite que le service d'annuaire Active Directory soit modifié pour Exchange Server 2007 avant de pouvoir préparer des domaines dans Active Directory.

Pour résoudre ce problème, préparez Active Directory à l'aide de la commande Setup /PrepareAD, ainsi que les domaines.

Pour plus d'informations sur la réalisation du processus PrepareAD, voir la rubrique sur la procédure de préparation d'Active Directory et de domaines (http://go.microsoft.com/fwlink/?LinkId=78453).


Le port ADAM est déjà utilisé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il a détecté, lors de sa tentative d'installer le rôle Gateway Server, que les ports attribués à la synchronisation ADAM (Active Directory® Application Mode) sont déjà utilisés.

ADAM est un service d'annuaire LDAP (Lightweight Directory Access Protocol) conçu spécifiquement en vue d'une utilisation avec des applications compatibles avec l'annuaire. ADAM ne stocke et réplique que les informations spécifiques aux applications ; il ne nécessite pas de déploiement sur un contrôleur de domaine et ne dépend pas du service Active Directory. ADAM ne fournit pas d'authentification ni d'autorisation de système d'exploitation de réseau.

Dans Exchange 2007, le serveur de passerelle utilise ADAM pour stocker les informations de configuration. Lorsque ADAM est synchronisé avec le service d'annuaire Active Directory, il peut également permettre d'effectuer une recherche de destinataires pour la sécurité des messages.

Le programme d'installation de Microsoft Exchange nécessite que des ports spécifiques soient disponibles (inutilisés) de manière à pouvoir être attribués au processus de synchronisation ADAM lorsque le rôle Gateway Server est installé.

Pour corriger ce problème, identifiez et arrêtez le processus qui utilise déjà les ports requis pour ADAM ou exécutez le programme d'installation d'Exchange 2007 à l'aide de commutateurs de ligne de commande pour remplacer les attributions de port ADAM par défaut.

Pour exécuter le programme d'installation en remplaçant les attributions de port ADAM par défaut

  1. À l'invite de commandes, entrez la commande suivante :

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport :<numéro de port à attribuer à ADAM>

    • /adamsslport :<numéro de port à attribuer à ADAM>


Hiérarchie de dossiers publics de l'application présente
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

L'outil Microsoft® Exchange Server Analyzer Tool cherche la hiérarchie de dossiers publics dans le domaine du service d'annuaire Active Directory®. Si Exchange Server Analyzer trouve des arborescences de dossiers publics non-MAPI, il affiche un avertissement. Celui-ci indique que des arborescences de dossiers publics non MAPI sont présentes dans l'organisation Exchange. Ces arborescences d'applications personnalisées ne sont pas prises en charge dans Exchange Server 2007.

Les arborescences de dossiers publics non-MAPI sont utilisées pour le développement d'applications personnalisées. Ces arborecences se trouvent dans Microsoft Exchange 2000 Server et Microsoft Exchange Server 2003 mais ne sont pas prises en charge dans Exchange 2007. Avant de déployer Exchange 2007, il est recommandé, au choix, de :

  • déplacer les arborescences de dossiers publics non-MAPI vers un serveur SharePoint Portal Server ;

  • conserver les données sur le serveur Exchange 2003.

Pour plus d'informations sur les différentes hiérarchies de dossiers publics, voir la rubrique sur la sélection du client approprié pour l'accès aux dossiers publics d'Exchange (http:// go.microsoft.com/fwlink/?LinkId =46439).


Impossible de déterminer le nom du site Active Directory
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car ce serveur ne semble pas appartenir à un site de service d'annuaire Active Directory® valide.

Le programme d'installation de Microsoft Exchange nécessite que le serveur utilisé pour l'installation d'Exchange 2007 appartienne à un site Active Directory valide.

Pour résoudre ce problème, vérifiez que le serveur local est membre d'un site Active Directory valide, puis recommencez l'installation d'Exchange Server 2007.

Vous pouvez utiliser l'option /DsGetSite de l'outil de ligne de commande Nltest.exe afin de vérifier et d'afficher l'appartenance à un site. Pour plus d'informations, voir la section sur la présentation de NLTest (Nltest.exe) dans la bibliothèque d'outils et de paramètres du Guide de référence technique de Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=27734).

Pour plus d'informations sur le dépannage d'Active Directory, voir la section sur le dépannage des opérations d'Active Directory du guide des opérations de Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=68099).


Service de mise à jour de destinataire introuvable
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-05-16

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le service de mise à jour de destinataire (RUS) responsable d'un domaine de l'organisation Exchange existante est introuvable.

Le programme d'installation de Microsoft Exchange nécessite que chaque domaine de l'organisation Exchange existante dispose d'une instance du service de mise à jour de destinataire.

Si une instance du service de mise à jour de destinataire est manquante pour un domaine, de nouveaux objets utilisateur créés dans le domaine ne reçoivent pas d'adresse de courrier électronique.

Pour résoudre ce problème, vérifiez qu'une instance du service de mise à jour de destinataire existe pour chaque domaine et créez une instance du service de mise à jour de destinataire pour les domaines qui n'en ont pas, puis recommencez l'installation de Microsoft Exchange.

Pour créer une instance du service de mise à jour de destinataire pour un domaine

  1. Ouvrez le Gestionnaire système Exchange.

  2. Développez Destinataires.

  3. Cliquez avec le bouton droit sur le nœud Services de mise à jour de destinataire, cliquez sur Nouveau, puis sur Service de mise à jour de destinataire.

  4. Dans la fenêtre Nouvel objet, cliquez sur Parcourir pour rechercher le nom du domaine.

  5. Sélectionnez le nom du domaine et cliquez sur OK.

  6. Dans la fenêtre Nouvel objet, cliquez sur Suivant, puis sur Terminer.

Pour plus d'informations sur le service de mise à jour de destinataire, voir les articles suivants de la Base de connaissances Microsoft :

  • Article sur la manière dont le service de mise à jour de destinataire applique les stratégies de destinataire (http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738).

  • Article sur la manière dont le service de mise à jour de destinataire complète les listes d'adresses (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828).

  • Article sur la procédure de vérification des progrès du service de mise à jour de destinataire Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127).

  • Article sur les tâches effectuées par le service de mise à jour de destinataire Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770).


Impossible de supprimer la base de données de boîtes aux lettres
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-06-20

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le processus du rôle Uninstall Mailbox Server ne peut pas supprimer une base de données de boîtes aux lettres (banque) du serveur local sans risquer de provoquer une perte de données.

Le programme d'installation d'Exchange 2007 vérifie si toutes les banques de boîtes aux lettres sont supprimées du serveur avant la suppression du rôle serveur de boîte aux lettres. Il se peut toutefois que des boîtes aux lettres utilisateur restent sur le serveur.

Pour résoudre ce problème, déplacez ou désactivez toutes les boîtes aux lettres utilisateur du serveur, puis recommencez l'installation d'Exchange 2007.

Pour plus d'informations sur l'identification des boîtes aux lettres dans la base de données, voir la cmdlet « Get-Mailbox » (http://go.microsoft.com/fwlink/?LinkId=93470) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations sur la désactivation d'une boîte aux lettres, voir la rubrique sur la procédure de désactivation d'une boîte aux lettres (http://go.microsoft.com/fwlink/?LinkId=93471) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations sur la procédure de suppression de bases de données de boîte aux lettres dans Exchange Server 2007, voir la rubrique sur la procédure de suppression d'une base de données de boîte aux lettres (http://go.microsoft.com/fwlink/?LinkId=93473) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations sur la procédure de gestion des banques ou des réplicas de bases de données de boîtes aux lettres utilisateur, voir la section sur la gestion des banques de boîtes aux lettres et de dossiers publics du Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Impossible de supprimer la base de données de dossiers publics
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-01-23

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le processus du rôle Uninstall Mailbox Server ne peut pas supprimer la base de données de dossiers publics du serveur local sans risquer de provoquer une perte de données.

Le programme d'installation d'Exchange 2007 nécessite que la base de données de dossiers publics soit supprimée du serveur avant la suppression du rôle Mailbox Server.

Il se peut que des réplicas de dossiers publics restent sur le serveur ou que la base de données de dossiers publics soit la dernière de l'organisation Exchange.

Pour résoudre ce problème, déplacez ou supprimez la base de données de dossiers publics du serveur, puis recommencez l'installation d'Exchange Server 2007.

Pour plus d'informations sur la suppression de bases de données de dossiers publics dans Exchange Server 2007, consultez la rubrique « Procédure de suppression d'une base de données de dossiers publics » (http://go.microsoft.com/fwlink/?LinkId=81409) dans la documentation produit d'Exchange Server 2007.

Pour plus d'informations sur la procédure de gestion des banques ou des réplicas de bases de données de dossiers publics, consultez la section sur la gestion des banques de boîtes aux lettres et de dossiers publics du Guide d'administration de Microsoft Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47617).


Impossible de supprimer le rôle serveur de messagerie unifiée
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-26

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative de désinstaller le rôle serveur de messagerie unifiée a échoué.

Le programme d'installation d'Exchange 2007 vérifie si le rôle serveur de messagerie unifiée à désinstaller héberge le point de publication des messages d'assistance vocale pour un plan de commutation et si ce plan est lié à d'autres serveurs.

Si le rôle serveur de messagerie unifiée héberge le point de publication des messages d'assistance vocale pour un plan de commutation, la procédure de désinstallation échoue.

Pour résoudre ce problème, déplacez le point de publication des messages d'assistance vocale vers un autre serveur et réexécutez le programme d'installation d'Exchange 2007.

Pour plus d'informations sur le déplacement du point de publication des messages d'assistance vocale pour un plan de commutation, voir la rubrique sur la procédure de modification du point de publication des messages d'assistance vocale (http://go.microsoft.com/fwlink/?LinkId=82356).


Impossible d'écrire sur le chemin d'accès aux données CMS
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-26

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installation du rôle serveur de boîtes aux lettres en clusters sur un disque de cluster partagé a échoué.

Le programme d'installation d'Exchange n'est pas parvenu à écrire sur le chemin d'installation cible soumis au paramètre /CMSDataPath. Le programme d'installation d'Exchange nécessite que le chemin cible pour les données du serveur de boîtes aux lettres en cluster soient un volume accessible en écriture.

Pour résoudre ce problème, spécifiez un chemin cible pour le /CMSDataPath situé sur le média de stockage disponible en écriture.

Pour plus d'informations sur l'installation du serveur de boîtes aux lettres en cluster, voir la rubrique que la procédure d'installation du rôle serveur de boîtes aux lettres dans le nœud actif (http://go.microsoft.com/fwlink/?LinkId=86624) dans la documentation sur le produit Exchange Server 2007.


Impossible d'écrire dans le conteneur de l'organisation Exchange
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-05-04

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car l'utilisateur connecté ne dispose pas des autorisations de compte requises pour écrire dans le conteneur de l'organisation du service d'annuaire Active Directory.

Le programme d'installation de Microsoft Exchange nécessite que l'utilisateur connecté lors de l'installation d'Exchange 2007 possède des informations d'identification d'administration de niveau Administrateur d'entreprise ou Organisation Exchange.

Dans le cadre du processus d'installation, il se peut que le programme d'installation d'Exchange 2007 doive créer des objets dans le conteneur de l'organisation Microsoft Exchange.

Pour résoudre ce problème, accordez à l'utilisateur connecté des autorisations de niveau Administrateur d'entreprise ou Organisation Exchange ou ouvrez une session à l'aide d'un compte disposant de ces autorisations, puis recommencez l'installation d'Exchange 2007.

Important :
L'installation inter-forêts d'Exchange 2007 n'est pas prise en charge. Utilisez un compte membre de la forêt Active Directory dans laquelle est installé Exchange 2007.

Pour plus d'informations sur les autorisations Active Directory nécessaires avec Microsoft Exchange, voir la rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).


Rôle Client Access non détecté dans le site local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 affiche cet avertissement parce qu'aucun rôle Client Access existant n'a été détecté dans le site local du service d'annuaire Active Directory®.

Vous avez décidé d'installer le rôle Mailbox Server avant qu'une instance du rôle Client Access ne soit installée dans le site Active Directory.

Le rôle de serveur Client Access accepte les connexions à votre serveur Exchange 2007 depuis divers clients. Les clients logiciels tels que Microsoft Outlook Express et Eudora utilisent des connexions POP3 ou IMAP4 pour communiquer avec le serveur Exchange. Les clients matériels, tels que les appareils mobiles, utilisent ActiveSync, POP3 ou IMAP4 pour communiquer avec le serveur Exchange.

Si les utilisateurs accèdent à leur boîte de réception à l'aide d'un client autre que Microsoft Office Outlook®, vous devez installer le rôle de serveur Client Access dans votre organisation Exchange.

Les utilisateurs pourront se connecter à leurs boîtes aux lettres à l'aide d'Outlook, mais ils ne pourront employer Outlook Web Access ou des appareils mobiles vis-à-vis de la même boîte aux lettres que si le rôle Client Access est présent dans le site Active Directory local.


Les ressources gérées par des clusters doivent être déplacées ou déconnectées
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-04-09

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installation d'un rôle serveur de boîtes aux lettres en cluster actif a échoué.

Exchange Server 2007 nécessite que les ressources gérées par des clusters soient inactives dans le nœud du cluster sur lequel le programme d'installation est exécuté.

Pour résoudre ce problème, déplacez toutes les ressources gérées par des clusters détenues par ce nœud, notamment les ressources de cluster non-Exchange Server, vers un autre nœud du cluster. Sinon, déconnectez-les et réexécutez le programme d'installation.

Pour plus d'informations sur la procédure de déplacement des services Exchange gérés par des clusters, voir la rubrique de la cmdlet « Move-ClusteredMailboxServer » (http://go.microsoft.com/fwlink/?LinkId=86627) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations sur la procédure de déconnexion des services Exchange gérés par des clusters, voir la rubrique de la cmdlet « Stop-ClusteredMailboxServer » (http://go.microsoft.com/fwlink/?LinkId=86635) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations sur la gestion de ressources de cluster non-Exchange, voir la rubrique sur la gestion des ressources (http://go.microsoft.com/fwlink/?LinkId=86637) dans l'aide sur le produit Windows Server 2003.


Le service de cluster n'est pas lancé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-26

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le service de cluster Microsoft Windows Server n'est pas lancé.

L'installation d'Exchange 2007 nécessite que le service de cluster soit lancé lorsqu'il est installé sur l'ordinateur local.

Pour résoudre ce problème, lancez le service de cluster sur l'ordinateur local puis réexécutez le programma d'installation d'Exchange.

Pour lancer le service de cluster, voir le document sur le lancement du service de cluster (http://go.microsoft.com/fwlink/?LinkId=86638) dans la Bibliothèque de documentation technique de Windows Server 2003.


Mise à jour de cluster requise (KB921181)
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-11

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car une mise à jour du nœud de cluster est nécessaire.

Le programme d'installation d'Exchange 2007 nécessite que la mise à jour mentionnée dans l'article 921181 de la Base de connaissances Microsoft soit installée sur le nœud de cluster.

Pour résoudre ce problème, installez la mise à jour mentionnée dans l'article 921181 de la Base de connaissances Microsoft sur une mise à jour disponible qui ajoute une fonction témoin de partage de fichiers et une fonction de pulsation de cluster configurable aux clusters de serveurs Windows Server 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?LinkId=69785), puis réexécutez le programme d'installation d'Exchange 2007.


Le chemin d'accès aux données CMS doit être un volume NTFS
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-26

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installation du rôle serveur de boîte aux lettres en clusters sur un disque de cluster partagé a échoué.

Le chemin d'installation cible soumis au paramètre /CMSDataPath est un volume non NTFS. Le programme d'installation d'Exchange nécessite que le chemin cible pour les données du serveur de boîtes aux lettres en cluster soient un volume NTFS.

Pour résoudre ce problème, sélectionnez un autre chemin cible pour /CMSDataPath ou convertissez le volume cible en NTFS et réexécutez le programme d'installation d'Exchange 2007.

Pour plus d'informations sur la conversion d'un volume en NTFS, voir la rubrique sur la conversion (http://go.microsoft.com/fwlink/?LinkId=86642) dans la documentation sur le produit Windows XP Professionnel.


Le nœud de cluster actuel détient des services de gestion de cluster
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-04-09

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative de désinstaller le nœud de cluster passif a échoué.

Les services de gestion de cluster Exchange sont détenus par ce nœud de cluster. L'installation d'Exchange 2007 nécessite que les services de gestion de cluster Exchange soient déplacés de ce nœud avant de pouvoir supprimer des fichiers Exchange.

Pour résoudre ce problème, déplacez toutes les ressources gérées par des clusters détenues par ce nœud, notamment les ressources de cluster non-Exchange Server, vers un autre nœud du cluster, ou déconnectez-les et recommencez l'installation.

Pour plus d'informations sur la procédure de déplacement des services Exchange gérés par des clusters, voir la rubrique de la cmdlet « Move-ClusteredMailboxServer » (http://go.microsoft.com/fwlink/?LinkId=86627) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations sur la procédure de déconnexion des services Exchange gérés par des clusters, voir la rubrique de la cmdlet « Stop-ClusteredMailboxServer » (http://go.microsoft.com/fwlink/?LinkId=86635) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations sur la gestion de ressources de cluster non-Exchange, voir la rubrique sur la gestion des ressources (http://go.microsoft.com/fwlink/?LinkId=86637) dans l'aide sur le produit Windows Server 2003.


Le système d'événement COM+ doit être démarré avant de pouvoir poursuivre l'installation
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-16

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative d'installer les rôles serveur d'accès au client ou de transport Edge a échoué parce que le système d'événement COM+ n'est pas démarré sur l'ordinateur cible.

L'installation d'Exchange 2007 nécessite que le statut du système d'événement COM+ soit défini sur Démarré sur l'ordinateur sur lequel vous installez Microsoft Exchange.

Le système d'événement COM+ prend en charge la notification d'événement de système pour les composants COM+ qui fournissent une distribution automatique d'événements aux composants COM d'abonnement.

Les deux rôles serveurs ont des dépendances sur les composants COM+ qui s'abonnent au système d'événement COM+.

Pour résoudre ce problème, vérifiez que le statut du système d'événement COM+ est défini sur Démarré sur l'ordinateur local, puis réexécutez le programme d'installation de Microsoft Exchange.

Pour définir le statut du système d'événement COM+ sur « Démarré »

  1. Cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Gérer.

  2. Développez le nœud Services et applications, puis cliquez sur le nœud Services.

  3. Dans le volet droit, recherchez Système d'événement Com+.

  4. Cliquez avec le bouton droit sur Système d'événement Com+, puis cliquez sur Propriétés.

  5. Définissez le Type de démarrage sur Automatique et le Statut du service sur Démarré.

  6. Cliquez sur Appliquer, puis sur OK.


Modèle d'organisation Exchange complexe détecté
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de groupes de routage dans l'organisation Exchange Server. Exchange Server Analyzer interroge également Active Directory pour déterminer le nombre de sites Active Directory qui disposent de serveurs Exchange exécutant Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003.

Exchange Server Analyzer identifie l'organisation Exchange comme une organisation Exchange complexe si les conditions suivantes sont vraies :

  • Il existe plusieurs forêts Active Directory.

  • Microsoft Identity Integration Server (MIIS) est installé dans au moins une forêt.

Parmi les quatre modèles d'organisation définis pour Microsoft Exchange Server 2007, l'organisation Exchange complexe est le seul modèle qui inclut plusieurs forêts Active Directory ou l'utilisation de la technologie de synchronisation.

Pour passer d'une organisation Exchange complexe à Exchange 2007

  1. Voir la documentation en ligne du produit Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Passez en revue la rubrique sur la planification d'une organisation Exchange complexe (http://go.microsoft.com/fwlink/?LinkId=70505).


Site Web par défaut introuvable sur l'ordinateur local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il ne peut pas accéder aux site Web par défaut sur ce serveur.

L'installation d'Exchange 2007 nécessite que l'installation du rôle Client Access ait accès au site Web par défaut créé par les services Internet (IIS) Microsoft.

Le rôle de serveur Client Access offre des fonctionnalités d'accès client, telles que Microsoft Office Outlook® (en cas de connexion sur HTTP), Outlook Web Access, Exchange ActiveSync® et les clients qui utilisent les protocoles POP3 ou IMAP4.

IIS sert de moteur de protocole pour les protocoles HTTP, POP3, IMAP4, SMTP (Simple Mail Transfer Protocol) et NNTP (Network News Transfer Protocol).

Il peut arriver que le site Web par défaut IIS n'existe plus. Il a peut-être été supprimé ou renommé avec un autre nom que Site Web par défaut.

Pour résoudre ce problème, commencez par supprimer, puis réinstaller IIS sur ce serveur. Recommencez ensuite l'installation d'Exchange 2007.

Important :
Vous devez désinstaller, puis réinstaller IIS pour résoudre ce problème. Il ne suffit pas de recréer ou de renommer le répertoire.
Pour désinstaller IIS à l'aide de l'option Ajouter ou supprimer des composants Windows du Panneau de configuration

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications.

  5. Cliquez sur Détails.

  6. Cliquez sur le Gestionnaire des services Internet (IIS).

  7. Cliquez sur Suivant.

  8. Cliquez sur Terminer lorsque la désinstallation d'IIS est terminée.
Pour installer IIS à l'aide du Panneau de configuration

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications.

  5. Cliquez sur Détails.

  6. Activez la case à cocher Gestionnaire des services Internet (IIS).

  7. Cliquez sur OK jusqu'à ce que vous soyez revenu dans l'Assistant Composants Windows.

  8. Cliquez sur Suivant et terminez l'Assistant Composants Windows.


Le service Distributed Transaction Coordinator doit être démarré avant de pouvoir poursuivre l'installation
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-16

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative d'installer les rôles serveur d'accès au client ou de messagerie unifiée a échoué parce que le service Distributed Transaction Coordinator n'est pas démarré sur l'ordinateur cible.

L'installation d'Exchange 2007 nécessite que le statut du service Distributed Transaction Coordinator soit défini sur Démarré sur l'ordinateur sur lequel vous installez Microsoft Exchange.

Le service Distributed Transaction Coordinator propose des services conçus pour assurer des transactions complètes et réussies, même en cas de défaillances système, d'échecs de processus et de communication.

Chaque ordinateur participant à une transaction distribuée gère ses propres ressources et données et agit de concert avec les autres ordinateurs de la transaction. De plus, une transaction distribuée doit valider ou abandonner son travail sur tous les ordinateurs participants. Le service Distributed Transaction Coordinator joue le rôle de coordination de transaction pour les composants concernés et de gestionnaire de transaction pour chaque ordinateur qui gère des transactions.

Les rôles serveurs d'accès client et de messagerie unifiée possèdent des dépendances dans le service Distributed Transaction Coordinator.

Pour résoudre ce problème, vérifiez que le statut du service Distributed Transaction Coordinator est défini sur Démarré sur l'ordinateur local, puis réexécutez le programme d'installation de Microsoft Exchange.

Pour définir le statut du service Distributed Transaction Coordinator sur « Démarré »

  1. Cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Gérer.

  2. Développez le nœud Services et applications, puis cliquez sur le nœud Services.

  3. Dans le volet droit, recherchez le service Distributed Transaction Coordinator.

  4. Cliquez avec le bouton droit sur Distributed Transaction Coordinator, puis cliquez sur Propriétés.

  5. Définissez le Type de démarrage sur Automatique et le Statut du service sur Démarré.

  6. Cliquez sur Appliquer, puis sur OK.


Le suffixe DNS n'est pas défini sur l'ordinateur local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le nom de domaine complet de l'ordinateur local n'a pas été défini.

Pour que l'installation d'Exchange 2007 réussisse, l'ordinateur local doit posséder un suffixe de nom de domaine complet valide.

Pour résoudre ce problème, définissez le suffixe DNS pour l'ordinateur local, redémarrez l'ordinateur, puis recommencez l'installation d'Exchange 2007.

Pour définir le suffixe DNS principal de l'ordinateur local

  1. Cliquez avec le bouton droit de la souris sur Poste de travail, puis sélectionnez Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur l'onglet Nom de l'ordinateur.

  3. Cliquez sur Modifier. La boîte de dialogue Modification du nom d'ordinateur s'affiche.

  4. Cliquez sur Plus. La boîte de dialogue Nom d'ordinateur NetBIOS et suffixe DNS s'affiche.

  5. Entrez le suffixe DNS approprié pour le domaine.

  6. Activez la case à cocher Modifier le suffixe DNS principal lorsque les adhésions au domaine sont modifiées.

  7. Cliquez sur OK pour enregistrer les modifications, puis de nouveau sur OK pour quitter la boîte de dialogue Modification du nom d'ordinateur.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés système, puis redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus d'informations sur les noms DNS, voir l'article 909264 de la Base de connaissances Microsoft sur les conventions d'affectation de noms dans Active Directory pour les ordinateurs, les domaines, les sites et les unités d'organisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264).


Le remplacement du contrôleur de domaine est défini dans le Registre
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative d'utiliser le contrôleur de domaine spécifié a échoué. Un contrôleur de domaine a été statiquement mappé dans le Registre.

L'installation d'Exchange 2007 nécessite que le contrôleur de domaine spécifié dans la commande d'installation corresponde au contrôleur de domaine mappé statiquement à l'aide d'un écrasement du Registre.

Pour résoudre ce problème, réexécutez le programme d'installation en spécifiant le contrôleur de domaine mappé statiquement pour le paramètre /DomainController: <Nom de domaine complet du contrôleur de domaine mappé statiquement>.

Pour plus d'informations sur DSAccess et la détection de services d'annuaire, voir l'article 250570 de la Base de connaissances Microsoft sur la détection de serveurs de service d'annuaire et l'utilisation de DSAccess (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570).


Préparation de domaine requise
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installer le rôle serveur a échoué.

Le programme d'installation de Microsoft Exchange nécessite que le domaine local soit préparé pour Exchange Server 2007 avant de pouvoir installer certains rôles serveurs.

La préparation du domaine pour Exchange Server 2007 est la procédure suivante :

  • définition d'autorisations sur le conteneur de domaine pour les serveurs Exchange, les administrateurs d'organisation Exchange, les utilisateurs authentifiés et les administrateurs de boîtes aux lettres Exchange ;

  • création du conteneur Objets système Microsoft Exchange s'il n'existe pas et définition des autorisations sur ce conteneur pour les serveurs Exchange, les administrateurs d'organisation Exchange et les utilisateurs authentifiés ;

  • création d'un groupe global de domaines dans le domaine actuel, nommé Serveurs de domaine Exchange.

  • Ajout du groupe Serveurs de domaine Exchange au groupe de sécurité universel Serveurs Exchange dans le domaine racine.

Pour résoudre ce problème, exécutez setup /PrepareDomain pour préparer le domaine local et réessayez l'installation du rôle serveur.

Pour plus d'informations sur la réalisation du processus PrepareDomain, voir la rubrique sur la procédure de préparation d'Active Directory et de domaines (http://go.microsoft.com/fwlink/?LinkId=78453).


Le rôle Edge Transport ne peut pas être installé sur l'ordinateur local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-01-03

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il a détecté, lors de sa tentative d'installer le rôle serveur de transport Edge, d'autres rôles Microsoft Exchange déjà installés sur ce serveur.

Le programme d'installation d'Exchange 2007 ne peut pas installer le rôle serveur de transport Edge sur un serveur où d'autres rôles Microsoft Exchange sont installés.

Le rôle serveur de transport Edge de Microsoft Exchange est déployé dans le réseau de périmètre de votre organisation, où il traite tout le flux de courrier Internet. Il assure le chiffrement et le déchiffrement des messages envoyés entre les organisations Microsoft Exchange approuvées, ainsi que la protection contre le courrier non sollicité.

Pour résoudre ce problème, installez le rôle serveur de transport Edge sur un ordinateur où aucun autre rôle Microsoft Exchange n'est installé.


Connecteur EDK trouvé dans la topologie
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-04

L'outil Microsoft® Exchange Server Analyzer Tool recherche des connecteurs EDK (Exchange Development Kit) dans le service d'annuaire Active Directory® dans l'organisation Exchange. S'il trouve des connecteurs EDK dans Active Directory, il affiche un avertissement. Cet avertissement indique que les connecteurs EDK ne sont pas pris en charge dans Microsoft Exchange Server 2007.

Il est recommandé de contacter le fournisseur tiers pour obtenir un connecteur de remplacement pour Exchange 2007. Vous pouvez aussi conserver un serveur Exchange 2003 ou Microsoft Exchange 2000 Server pour prendre en charge le connecteur EDK.

Remarque :
Les connecteurs EDK sont des applications tierces conçues pour permettre la connexion à des systèmes de communication tels que des télécopieurs, des SMS ou des télex, ou à d'autres systèmes de messagerie tels que Lotus Notes utilisant un connecteur de passerelle. Les fournisseurs non-Microsoft utilisent EDK pour développer des connecteurs propriétaires.


Esm.dll est utilisé par un ou plusieurs processus
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-28

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative de mise à niveau du serveur a rencontré un problème d'accès à un module.

L'installation d'Exchange 2007 nécessite que certains modules ne soient pas en cours d'exécution afin que la mise à niveau puisse modifier les fichiers binaires. Le fichier Esm.dll est l'un de ces modules.

Pour résoudre ce problème, déchargez les processus pour lesquels le fichier Esm.dll est ouvert, puis recommencez l'installation d'Exchange 2007.

Pour arrêter le processus pour lequel le fichier Esm.dll est ouvert

  1. Démarrez Exchange Management Shell

  2. La cmdlet Get-Process permet de trouver l'ID de processus pour les processus identifiés par Exchange Analyzer.

  3. Get-Process < nom de processus >

  4. La cmdlet Stop-Process permet d'arrêter le processus.

  5. Stop-Process < ID du processus >

  6. Où <process ID> est la valeur de l'ID du processus retournée de la cmdlet Get-Process à l'étape 2.

Pour plus d'informations sur la cmdlet Get-Process, voir la section sur l'utilisation de la cmdlet Get-Process dans la rubrique sur l'utilisation de Windows PowerShell.


ExchHelp.chm est ouvert
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-16

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative de mise à niveau du serveur a rencontré un problème d'accès à un fichier.

L'installation d'Exchange 2007 nécessite que certains fichiers soient fermés afin que le processus de mise à niveau puisse modifier les fichiers ou les processus d'accès. Le fichier d'aide d'Exchange local (ExchHelp.chm) en fait partie.

Pour résoudre ce problème, fermez le fichier ExchHelp.chm, puis recommencez l'installation d'Exchange 2007.


Les ordinateurs Exchange 2000 Server nécessitent une mise à niveau vers SP3
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car un ou plusieurs serveurs de l'organisation existante exécutent Exchange 2000 Server sans Service Pack 3 ou une version ultérieure.

Le programme d'installation d'Exchange 2007 nécessite que tous les ordinateurs Exchange 2000 Server existants dans l'organisation exécutent Exchange 2000 Server Service Pack 3 (SP3).

Pour résoudre ce problème, mettez à niveau tous les ordinateurs Exchange 2000 Server existants de l'organisation vers Exchange 2000 Server SP3 ou une version ultérieure, puis réexécutez le programme d'installation d'Exchange 2007.

Pour plus d'informations sur la mise à niveau d'ordinateurs Exchange 2000 Server vers Exchange 2000 Server SP3 ou une version ultérieure, voir la rubrique sur les téléchargements pour Exchange 2000 Server (http://go.microsoft.com/fwlink/?LinkId=86647).


L'organisation Exchange est en mode mixte
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le conteneur de l'organisation Exchange pour déterminer le mode de l'organisation Exchange. Exchange Server Analyzer vérifie la valeur de l'attribut msExchangeMixedMode. Si la valeur de cet attribut est True, Exchange Server Analyzer affiche une erreur. Le message d'erreur indique que l'organisation Exchange est exécutée en mode mixte. Microsoft Exchange Server 2007 ne peut être installé que dans une organisation en mode natif. Si l'organisation est en mode mixte, vous devez donc la basculer en mode natif pour la préparer à un déploiement d'Exchange 2007.

Remarque :
Une organisation qui tourne en mode natif ne peut contenir que des serveurs Exchange 2000 ou supérieurs.

Pour préparer une organisation Exchange au déploiement d'Exchange 2007, vous devez la convertir au mode natif comme suit :

  1. Supprimez ou désactivez tout serveur Exchange 5.5 restant.

  2. Dans le Gestionnaire système Exchange, ouvrez les propriétés de l'objet d'organisation Exchange, puis basculez en mode natif.

Pour plus d'informations sur la procédure de conversion d'une organisation Exchange en mode natif, voir la rubrique sur la procédure de conversion du mode mixte au mode natif dans Exchange (http://go.microsoft.com/fwlink/?LinkId=56642) dans le Guide de déploiement de Microsoft Exchange Server 2003.

Pour plus d'informations sur le mode mixte et le mode natif pour Microsoft Exchange, voir les articles suivants de la Base de connaissances Microsoft :

  • 270143 sur la description du mode mixte et du mode natif dans Exchange 2000 Server et Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143) ;

  • 327779 sur la procédure de conversion du mode mixte en mode natif dans Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779) ;

  • 272314 sur la préparation d'une organisation en mode mixte en vue de sa conversion au mode natif (http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314).


Les ordinateurs Exchange Server 2003 nécessitent une mise à niveau vers SP2
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car un ou plusieurs serveurs de l'organisation existante exécutent Exchange Server 2003 sans Service Pack 2 ou une version ultérieure.

Le programme d'installation d'Exchange 2007 nécessite que tous les ordinateurs Exchange Server 2003 existants dans l'organisation exécutent Exchange Server 2003 Service Pack 2 (SP2) ou une version ultérieure.

Pour résoudre ce problème, mettez à niveau tous les ordinateurs Exchange Server 2003 existants de l'organisation vers Exchange Server 2003 SP2 ou une version ultérieure, puis réexécutez le programme d'installation d'Exchange 2007.

Pour plus d'informations sur la mise à niveau d'ordinateurs Exchange Server 2003 vers Exchange Server 2003 SP2 ou une version ultérieure, voir la rubrique sur les téléchargements pour Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=21030).


Exchange Server 2007 ne peut pas être utilisé avec cette version de Windows
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car l'ordinateur local n'exécute pas une version du système d'exploitation Microsoft Windows Server prise en charge avec Exchange Server 2007.

Le programme d'installation d'Exchange 2007 nécessite que la version de Windows Server sur l'ordinateur local soit prise en charge pour exécuter Exchange Server 2007 de la manière spécifiée dans la configuration requise pour Exchange Server 2007.

Pour résoudre ce problème, installez une version du système d'exploitation Windows Server prise en charge par Exchange Server 2007 sur l'ordinateur local ou installez Exchange Server 2007 sur un ordinateur exécutant une version de Windows Server prise en charge.

Pour plus d'informations sur la configuration requise pour Exchange Server 2007, voir la rubrique correspondante (http://go.microsoft.com/fwlink/?LinkId=86651).


Le témoin de partage de fichiers n'est pas configuré
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-23

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car un témoin de partage de fichiers n'a pas été configuré pour le cluster de réplication continue en cluster.

Pour maintenir l'échec des différents nœuds dans un quorum de cluster de jeu de nœuds majoritaire (MNS), vous devez avoir au moins trois périphériques disponibles. La fonction de témoin de partage de fichiers vous permet d'utiliser un partage de fichiers externe comme témoin. Ce témoin fait office du troisième périphérique disponible dans un quorum de cluster MNS à deux nœuds.

L'installation d'Exchange 2007 nécessite que la fonction de témoin de partage de fichiers soit configurée pour l'installation du rôle serveur de boîtes aux lettres en cluster dans un environnement de CCR.

Pour résoudre ce problème, suivez la procédure de création et de sécurisation du partage de fichiers pour le témoin de partage de fichiers, comme dans la rubrique sur la procédure de configuration d'un témoin de partage de fichiers (http://go.microsoft.com/fwlink/?LinkId=78278). Définissez ensuite la valeur MNSFileShare, déplacez deux fois le groupe de clusters et essayez une nouvelle fois d'installer Microsoft Exchange.


L'installation du premier rôle ne peut pas être déléguée
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le compte de l'utilisateur connecté ne possède pas les autorisations requises pour installer le premier rôle de serveur de la topologie.

Bien que le programme d'installation de Microsoft Exchange permette la délégation pour l'installation des rôles de serveur suivants, il exige que l'installation du premier rôle de serveur Exchange 2007 de la topologie soit effectuée par un utilisateur connecté qui dispose d'informations d'identification d'administration de niveau Organisation Exchange.

Dans le cadre de l'installation du premier rôle de serveur, il se peut que le programme d'installation d'Exchange 2007 doive créer des objets dans le conteneur de l'organisation Exchange.

Pour résoudre ce problème, accordez à l'utilisateur connecté des autorisations de niveau Administrateur de l'organisation Exchange ou ouvrez une session à l'aide d'un compte possédant ces autorisations, puis exécutez de nouveau le programme d'installation d'Exchange 2007.


Les services Forefront Security pour Exchange Server doivent être désactivés
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-06-20

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre la mise à niveau d'Exchange Server 2007 car Microsoft Forefront Security pour les services Exchange Server est en cours d'exécution sur cet ordinateur.

Le programme d'installation d'Exchange nécessite la désactivation de Forefront Security pour les services Exchange Server avant de poursuivre la mise à niveau d'Exchange Server 2007.

Pour résoudre ce problème, désactivez Forefront Security pour les services Exchange Server, puis réexécutez la mise à niveau d'Exchange Server.

Pour plus d'informations sur l'installation d'un Service Pack ou d'une mise à jour logicielle sur un serveur Exchange Server qui exécute Forefront Security, voir l'article 929080 de la Base de connaissances Microsoft correspondant .


Mise à niveau requise de Forefront Security pour Exchange Server
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

S'applique à : Exchange Server 2007, Exchange Server 2007 SP1
Dernière rubrique modifiée : 2007-08-08

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre la mise à niveau d'Exchange 2007 car l'ordinateur local exécute une version de Microsoft Forefront Security pour Exchange Server qui n'est pas prise en charge par Exchange Server 2007 Service Pack 1 (SP1).

Le programme d'installation d'Exchange nécessite la mise à niveau de la version de Microsoft Forefront Security pour Exchange Server et la désactivation de ses services avant de poursuivre la mise à niveau d'Exchange Server 2007.

Pour résoudre ce problème, effectuez la mise à niveau de Microsoft Forefront Security version 10.0 pour Exchange Server vers Microsoft Forefront Security pour Exchange Server SP1, puis désactivez les services de Microsoft Forefront Security pour Exchange Server avant de reprendre la mise à niveau d'Exchange Server.

Pour plus d'informations

Pour plus d'informations sur l'installation d'un Service Pack ou d'une mise à jour logicielle sur un serveur Exchange Server qui exécute Forefront Security, voir l'article 929080 de la Base de connaissances Microsoft correspondant (http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080).


Le nom de domaine complet de l'ordinateur correspond à une stratégie de destinataire
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-05-16

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le nom de domaine complet de l'ordinateur local correspond à l'adresse SMTP (Simple Mail Transfer Protocol) d'une stratégie de destinataire.

Le programme d'installation de Microsoft Exchange nécessite que les noms de domaine complets des serveurs d'une organisation Exchange ne correspondent à aucune adresse SMTP des stratégies de destinataire dans la même organisation Exchange.

Si le nom de domaine complet d'un ordinateur correspond à l'adresse SMTP d'une stratégie de destinataire, le courrier ne bascule pas en SMTP et est bloqué dans les files d'attente MTA.

Pour résoudre ce problème, renommez l'ordinateur local. Vous pouvez également supprimer ou renommer la stratégie de destinataire, puis recommencer l'installation de Microsoft Exchange

Pour renommer l'ordinateur local

  1. Ouvrez Système dans Panneau de configuration.

  2. Sous l'onglet Nom de l'ordinateur, cliquez sur Modifier....

  3. Sous Nom de l'ordinateur, entrez un nouveau nom pour l'ordinateur, puis cliquez sur OK. Vous êtes invité à fournir un nom d'utilisateur et un mot de passe pour renommer l'ordinateur dans le domaine.

  4. Cliquez sur OK pour fermer la boîte de dialogue Propriété système. Vous êtes invité à redémarrer votre ordinateur pour appliquer les modifications.
Important :
Si l'ordinateur que vous souhaitez renommer est un contrôleur de domaine, voir la rubrique sur la modification du nom d'un contrôleur de domaine (http://go.microsoft.com/fwlink/?LinkId=66828).
Pour modifier l'adresse SMTP d'une stratégie de destinataire

  1. Démarrez le Gestionnaire système Exchange.

  2. Cliquez sur Organisation, sur Destinataires, puis sur Stratégies de destinataire.

  3. Double-cliquez sur la stratégie que vous souhaitez modifier.

  4. Cliquez sur l'onglet Adresses de messagerie, puis modifiez l'adresse SMTP appropriée

Pour plus d'informations sur les problèmes de nom de stratégie de destinataire, voir l'article 288175 de la Base de connaissances Microsoft sur la stratégie de destinataire qui ne peut pas correspondre au nom de domaine complet d'un serveur de l'organisation, 5.4.8 rapport de non-remise (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175).


Aucun serveur de catalogue global n'existe sur le site local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il n'y a aucun serveur de catalogue global sur le site où vous essayez d'installer Microsoft Exchange.

Le programme d'installation de Microsoft Exchange nécessite que le site du service d'annuaire Active Directory® de l'ordinateur sur lequel le programme d'installation est en cours d'exécution possède un serveur jouant le rôle de catalogue global.

Pour résoudre ce problème, procédez comme suit :

  • Utilisez comme serveur de catalogue global un contrôleur de domaine existant sur le site.

  • Installez un nouveau serveur dans le rôle de serveur de catalogue global.

Pour utiliser un contrôleur de domaine existant comme serveur de catalogue global

  1. Ouvrez Sites et services Active Directory.

  2. Développez Sites, le site, puis Serveurs.

  3. Sélectionnez le contrôleur de domaine que vous souhaitez spécifier en tant que serveur de catalogue global.

  4. Dans le volet droit, cliquez avec le bouton droit sur Paramètres NTDS et sélectionnez Propriétés.

  5. Sous l'onglet Général, activez la case à cocher Catalogue global. La modification prend effet de manière dynamique, sans redémarrer l'ordinateur.
  • Pour plus d'informations sur la procédure de création de serveurs de catalogue global supplémentaires, voir l'article 313994 de la Base de connaissances Microsoft sur la procédure de création ou de déplacement d'un catalogue global dans Windows 2000 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994).

  • Pour plus d'informations sur l'emplacement et la disponibilité du serveur de catalogue global lié à Exchange Server, voir l'article 875427 de la Base de connaissances Microsoft sur l'emplacement et les ratios du serveur de catalogue global dans une organisation Exchange 2000 Server ou Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427).


Mises à jours globales requises
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-09-19

L'installation de Microsoft® Exchange Server 2007 ne peut pas continuer car le compte de l'utilisateur connecté ne possède pas les autorisations requises pour effectuer les mises à jour globales du service d'annuaire Active Directory®.

Le programme d'installation de Microsoft Exchange nécessite que l'utilisateur connecté lors de l'installation d'Exchange 2007 possède des informations d'identification d'administration de niveau Administrateur d'entreprise.

Dans le processus d'installation, le programme d'installation d'Exchange 2007 doit procéder comme suit :

  • créer ou modifier les objets de l'organisation Exchange dans le service d'annuaire Active Directory ;

  • préparer tous les domaines dans la forêt Active Directory pour Exchange 2007 ;

  • préparer les domaines Exchange 2000 Server et Exchange Server 2003 existants pour Exchange 2007.

Pour résoudre ce problème, accordez à l'utilisateur connecté des autorisations de niveau Administrateur d'entreprise ou ouvrez une session à l'aide d'un compte possédant ces autorisations, puis recommencez l'installation d'Exchange 2007.

Pour plus d'informations sur les autorisations Active Directory nécessaires avec Exchange, voir la rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).


L'enregistrement d'hôte pour l'ordinateur local est introuvable dans la base de données DNS
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car l'enregistrement d'hôte (A) pour cet ordinateur est introuvable dans la base de données DNS (Domain Name System).

L'installation d'Exchange 2007 nécessite que l'ordinateur local ait un enregistrement d'hôte (A) valide inscrit auprès de la base de données d'autorité DNS pour le domaine.

Microsoft Exchange dépend des enregistrements d'hôte (A) DNS pour connaître l'adresse IP du serveur de destination suivant, interne ou externe.

Pour résoudre ce problème :

  • Vérifiez que la configuration TCP/IP locale pointe vers le serveur DNS correct.

    Pour vérifier la configuration TCP/IP locale

    1. Passez en revue la configuration TCP/IP locale. Pour plus d'informations, voir la rubrique sur la configuration TCP/IP pour utiliser DNS (http://go.microsoft.com/fwlink/?LinkId=68094).
  • Nslookup.exe permet de vérifier que l'enregistrement d'hôte (A) existe sur le serveur DNS. Pour plus d'informations, voir la rubrique sur la procédure de vérification de l'existence d'une ressource A dans DNS (http://go.microsoft.com/fwlink/?LinkId=63001).

Pour plus d'informations sur la résolution des noms DNS, le dépannage et les enregistrements d'hôte (A), voir les documents suivants :

  • l'article 322856 de la Base de connaissances Microsoft sur la procédure de configuration de DNS pour une utilisation avec Exchange Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856).

  • la rubrique sur la résolution des problèmes DNS (http://go.microsoft.com/fwlink/?LinkId=63003).

  • la rubrique sur la gestion des enregistrements de ressource (http://go.microsoft.com/fwlink/?LinkId=63004).


Rôle Hub Transport non détecté dans le site local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 affiche cet avertissement car aucun rôle de serveur Hub Transport existant n'a pu être détecté dans le site local du service d'annuaire Active Directory®.

Vous avez décidé d'installer le rôle Mailbox Server avant qu'une instance du rôle Hub Transport ne soit installée dans le site Active Directory.

Les services Hub Transport d'Exchange 2007 sont déployés dans l'annuaire Active Directory de votre organisation. Les services Hub Transport traitent tout le flux des messages à l'intérieur de l'organisation, appliquent les règles de routage du flux de messages dans l'organisation et sont responsables de la remise des messages dans la boîte aux lettres d'un destinataire.

Les utilisateurs peuvent se connecter à leurs boîtes aux lettres, mais ce serveur de boîtes aux lettres ne peut ni envoyer ni recevoir de courrier tant qu'un rôle Hub Transport n'est pas installé.


Hub Transport Server Not Present in Active Directory Site
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-07-25

L'outil Microsoft Exchange Analyzer Tool interroge le service d'annuaire Active Directory pour la valeur des objets de la classe msExchAdminGroupContainer dans l'organisation Exchange contenant l'identificateur de groupe d'administration spécifique à Exchange Server 2007, FYDIBOHF23SPDLT.

Si Exchange Analyzer détecte un groupe d'administration Exchange Server 2007 dans l'organisation Exchange, il interroge tous les sites Active Directory dans l'organisation pour la valeur de l'attribut msExchCurrentServerRoles pour chaque objet msExchExchangeServer afin de déterminer si un rôle serveur de boîtes aux lettres est installé dans un des sites trouvés.

Si Exchange Analyzer détecte un rôle serveur de boîtes aux lettres installé dans un site, il interroge l'attribut msExchCurrentServerRoles de chaque objet msExchExchangeServer dans ce site afin de déterminer si un rôle serveur de transport Hub est également installé dans ce même site.

Si Exchange Analyzer détecte un rôle serveur de boîtes aux lettres installé dans un site Active Directory dans lequel aucun rôle serveur de transport Hub n'est installé, il affiche une erreur.

Cette erreur indique que, même si un rôle serveur de boîtes aux lettres est installé dans le site Active Directory, le courrier ne sera pas transféré d'une boîte aux lettres à l'autre, même si elles se trouvent sur le même serveur, jusqu'à ce qu'un rôle serveur de transport Hub soir installé dans le site.

Le rôle serveur de transport Hub est déployé dans le service d'annuaire Active Directory de votre organisation. Il traite tout le flux des messages à l'intérieur de l'organisation, applique une stratégie de message dans l'organisation et est responsable de la remise des messages dans la boîte aux lettres d'un destinataire. Les serveurs de transport Hub proposent la fonctionnalité suivante :

Flux de messages Le rôle serveur de transport Hub traite tous les messages envoyés dans l'organisation Exchange 2007 avant de les remettre à la boîte de réception d'un destinataire dans l'organisation ou de les router vers des utilisateurs à l'extérieur de l'organisation. Il n'existe pas d'exception à ce comportement.

Catégorisation Le catégoriseur effectue une résolution de destinataire, une résolution de routage et une conversion de contenu pour tous les messages déplacés à l'aide du pipeline de transport Exchange 2007.

Routage Le rôle serveur de transport Hub détermine l'itinéraire de routage pour tous les messages envoyés à l'organisation et reçus par elle.

Remise Des messages sont remis à la boîte aux lettres d'un destinataire par le pilote de banque. Des messages envoyés par des utilisateurs dans votre organisation sont repris de la boîte d'envoi de l'expéditeur par le pilote de banque et placés dans la file d'attente de soumission sur un serveur de transport Hub.

Pour corriger cette erreur, installez le rôle serveur de transport Hub dans les sites dans lesquels le rôle serveur de boîtes aux lettres est installé.

Pour plus d'informations

Pour plus d'informations sur le déploiement du rôle serveur de transport Hub dans un site, voir la rubrique sur le déploiement de rôles serveur (http://go.microsoft.com/fwlink/?LinkId=83282) dans la documentation sur le produit Exchange Server 2007.


Composant de compatibilité IIS 6 non installé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-08-13

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre sa tentative d'installation du rôle serveur d'accès au client ou de boîtes aux lettres ou des outils d'administration d'Exchange 2007 sur l'ordinateur de destination Windows Server 2008 car la compatibilité de la métabase du service IIS 6 et la console de gestion du service IIS 6 ne sont pas installés.

L'installation d'Exchange 2007 nécessite que l'ordinateur Windows Server 2008 sur lequel vous installez le rôle serveur d'accès au client ou de boîtes aux lettres Exchange 2007 ou les outils d'administration d'Exchange 2007 possède la compatibilité de la métabase du service IIS 6 et la console de gestion du service IIS 6.

Pour résoudre ce problème, installez le composant de compatibilité métabase IIS 6 sur l'ordinateur de destination, puis réexécutez le programme d'installation de Microsoft Exchange.

Pour installer les composants de compatibilité avec la gestion IIS 6.0 à l'aide du Gestionnaire de serveur Windows Server 2008

  1. Cliquez sur Démarrer, Outils d'administration puis Gestionnaire de serveur.

  2. Dans le volet de navigation de gauche, développez Rôles, puis cliquez avec le bouton droit sur Serveur Web (IIS) et sélectionnez Ajouter des services de rôle.

  3. Dans le volet Sélectionner les services de rôle, faites défiler jusqu'à Compatibilité avec la gestion IIS 6.

  4. Activez les cases à cocher Compatibilité métabase IIS 6 et Console de gestion IIS 6.

  5. Cliquez sur Suivant dans le volet Sélectionner les services de rôle, puis sur Installer dans le volet Sélections relatives à la confirmation d'installation.

  6. Cliquez sur Fermer pour quitter l'Assistant Ajout de services de rôle.


Composant IIS 7 non installé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-08-09

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre l'installation du rôle serveur d'accès au client sur le système Microsoft Windows Server 2008, car les composants IIS 7 requis ne sont pas installés.

Le programme d'installation d'Exchange 2007 nécessite que l'ordinateur Windows Server 2008 sur lequel vous installez le rôle serveur d'accès au client possède les composants IIS 7 suivants avant d'installer le rôle serveur d'accès au client.

Composants IIS 7 requis

Compression du contenu dynamique

Compression du contenu statique

Authentification de base

Authentification Windows

Pour résoudre ce problème, installez le ou les composants IIS 7 requis sur l'ordinateur de destination, puis réexécutez le programme d'installation de Microsoft Exchange.

Pour installer les composants IIS 7 à l'aide du Gestionnaire de serveur Windows Server 2008

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Gestionnaire de serveur.

  2. Dans le volet de navigation de gauche, développez Rôles, puis cliquez avec le bouton droit sur Serveur Web (IIS) et sélectionnez Ajouter des services de rôle.

  3. Dans le volet Sélectionner les services de rôle, faites défiler jusqu'à IIS.

  4. Activez les cases à cocher sous Sécurité pour Authentification de base et Authentification Windows.

  5. Activez les cases à cocher sous Performance pour Compression statique et Compression dynamique.

  6. Cliquez sur Suivant dans le volet Sélectionner les services de rôle, puis sur Installer dans le volet Sélections relatives à la confirmation d'installation.

  7. Cliquez sur Fermer pour quitter l'Assistant Ajout de services de rôle.


Fichiers communs IIS requis
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-14

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car les fichiers communs des services Internet (IIS) Microsoft ne sont pas installés sur ce serveur.

Microsoft Exchange Management Shell peut nécessiter un accès distant à la métabase IIS. La métabase est un référentiel pour la plupart des valeurs de configuration IIS. L'accès distant à la métabase nécessite l'installation des DLL COM+ appropriées sur l'ordinateur local.

Pour résoudre ce problème, installez les fichiers communs IIS sur ce serveur, puis réexécutez le programme d'installation d'Exchange 2007.

Pour installer les fichiers communs IIS à l'aide du Panneau de configuration sous Windows Server™ 2003

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications.

  5. Cliquez sur Détails.

  6. Dans la liste Sous-composants du serveur d'applications, activez la case à cocher Services IIS.

  7. Cliquez sur Détails.

  8. Activez la case à cocher Fichiers communs.

  9. Cliquez sur OK jusqu'à ce que vous soyez revenu dans l'Assistant Composants Windows.

  10. Cliquez sur Suivant et terminez l'Assistant Composants Windows.
Pour installer les fichiers communs IIS à l'aide du Panneau de configuration sous Windows® XP

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Services IIS.

  5. Cliquez sur Détails.

  6. Activez la case à cocher Fichiers communs.

  7. Cliquez sur OK jusqu'à ce que vous soyez revenu dans l'Assistant Composants Windows.

  8. Cliquez sur Suivant et terminez l'Assistant Composants Windows.


IIS est en mode de compatibilité 32 bits
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-11

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car les services Internet (IIS) de Microsoft s'exécutent en mode 32 bits sur cet ordinateur 64 bits.

Exchange 2007 nécessite qu'IIS soit en mode 64 bits complet lorsqu'il s'exécute sur un ordinateur 64 bits.

Pour résoudre ce problème, faites basculer IIS en mode 64 bits, puis réexécutez le programme d'installation de Microsoft Exchange.

Pour faire basculer IIS en mode 64 bits

  1. Ouvrez une invite de commandes.

  2. Tapez la commande suivante :

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Appuyez sur Entrée.


Autorisations insuffisantes pour préparer Active Directory
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-21

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative de préparation de domaine a échoué.

Le programme d'installation d'Exchange nécessite que le service d'annuaire Active Directory soit modifié pour Exchange Server 2007 avant de pouvoir préparer des domaines dans Active Directory.

Le compte utilisé pour exécuter la commande setup /PrepareAD ne possède pas les autorisations suffisantes pour exécuter cette commande même s'il semble appartenir au groupe Administrateurs de l'entreprise. Le compte peut avoir expiré.

Pour résoudre ce problème, vérifiez que le compte de l'utilisateur connecté est valide et appartienne au groupe Administrateurs de l'entreprise, ou connectez-vous à l'aide d'un compte qui possède ces autorisations et réexécutez setup /PrepareAD.

Pour plus d'informations sur la réalisation du processus PrepareAD, voir la rubrique sur la procédure de préparation d'Active Directory et de domaines (http://go.microsoft.com/fwlink/?LinkId=78453).

Pour plus d'informations sur les autorisations Active Directory nécessaires avec Microsoft Exchange, voir la rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).


Autorisations insuffisantes pour supprimer tous les rôles de serveur
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative de désinstaller tous les rôles serveurs a échoué.

Le programme d'installation d'Exchange 2007 nécessite que l'utilisateur connecté lors de la désinstallation de tous les rôles serveurs soit membre des groupes Administrateurs d'organisation Exchange ou du groupe Administrateurs de l'entreprise.

Pour résoudre ce problème, accordez à l'utilisateur connecté des autorisations de niveau Organisation Exchange ou inscrivez-le dans le groupe Administrateurs de l'entreprise ou ouvrez une session à l'aide d'un compte disposant des autorisations, puis recommencez l'installation d'Exchange 2007.

Pour plus d'informations sur les autorisations Active Directory nécessaires avec Microsoft Exchange, voir la rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).


Autorisations insuffisantes pour exécuter /PrepareDomain
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'exécution du processus /PrepareDomain a échoué. L'utilisateur connecté ne possède pas les autorisations suffisantes pour réaliser le processus /PrepareDomain.

Le programme d'installation d'Exchange 2007 nécessite que l'utilisateur connecté lors de l'exécution du processus /PrepareDomain soit membre du groupe Admins du domaine pour le domaine préparé et du groupe Administrateurs d'organisation Exchange ou Administrateurs de l'entreprise.

Pour résoudre ce problème, accordez à l'utilisateur connecté des autorisations de niveau Admins du domaine pour le domaine préparé et inscrivez-le dans le groupe Administrateurs d'organisation Exchange ou Administrateurs de l'entreprise ou ouvrez une session à l'aide d'un compte disposant des autorisations, puis recommencez l'installation d'Exchange 2007.

Pour plus d'informations sur les autorisations Active Directory nécessaires avec Microsoft Exchange, voir la rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).


Nom de domaine DNS non valide
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-04-13

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le nom de domaine DNS défini sur l'ordinateur local n'est pas valide.

L'installation d'Exchange 2007 nécessite que le nom de domaine DNS ne contienne pas d'autres caractères que « A-Z », « a-z », « 0-9 », « . » et « - ».

Pour résoudre ce problème, déterminez si les caractères non valides se trouvent dans le nom de l'ordinateur local ou dans le nom de domaine DNS.

  • Si les caractères non valides se trouvent dans le nom de l'ordinateur local, redéfinissez le nom de domaine DNS pour le domaine de l'ordinateur local à l'aide de caractères valides compris entre « A-Z », « a-z », « 0-9 », « . » et « - ». Redémarrez l'ordinateur et réexécutez le programme d'installation d'Exchange 2007.

  • Si les caractères non valides se trouvent dans le nom de domaine DNS de l'organisation, renommez le domaine DNS ou installez Exchange 2007 dans une nouvelle arborescence de domaine.

Attention :
La modification du nom de domaine DNS peut affecter fortement votre réseau. Avant de procéder à toute modification, concertez-vous avec votre administrateur réseau.
Pour vérifier le nom de domaine DNS de l'ordinateur local

  1. Cliquez avec le bouton droit de la souris sur Poste de travail, puis sélectionnez Propriétés. La boîte de dialogue Propriétés système s'affiche.

  2. Cliquez sur l'onglet Nom de l'ordinateur.

  3. Cliquez sur Modifier. La boîte de dialogue Modification du nom d'ordinateur s'affiche.

  4. Cliquez sur Autres. La boîte de dialogue Nom d'ordinateur NetBIOS et suffixe DNS s'affiche.

  5. Vérifiez que seuls les caractères « A-Z », « a-z », « 0-9 », « . » et « - » sont utilisés.

  6. Activez la case à cocher Modifier le suffixe DNS principal lorsque les adhésions au domaine sont modifiées.

  7. Cliquez sur OK pour enregistrer les modifications, puis de nouveau sur OK pour quitter la boîte de dialogue Modification du nom d'ordinateur.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés système, puis redémarrez l'ordinateur pour que la modification soit prise en compte.

Pour plus d'informations sur les noms DNS, voir l'article 909264 de la Base de connaissances Microsoft sur les conventions d'affectation de noms dans Active Directory pour les ordinateurs, les domaines, les sites et les unités d'organisation (http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264).


Chemin d'installation non valide
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installation du rôle serveur de boîtes aux lettres ou de boîtes aux lettres en cluster sur un disque de cluster partagé a échoué.

L'installation d'Exchange nécessite que des rôles serveur Exchange soient installés sur un disque qui ne soit pas une ressource de cluster partagée.

Pour résoudre ce problème, installez le rôle serveur de boîtes aux lettres ou de boîtes aux lettres en cluster dans un chemin d'accès qui n'est pas désigné comme un lecteur de cluster partagé.

Pour plus d'informations sur les configurations de clustering, voir la rubrique sur la disponibilité élevée (http://go.microsoft.com/fwlink/?linkid=68190) dans la documentation sur le produit Exchange Server 2007.


Format du chemin d'accès cible CMS non valide
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installation du rôle serveur de boîtes aux lettres en clusters sur un disque de cluster partagé a échoué.

Le paramètre /CMSDataPath: <PathToTheDatabase> soumis était dans un format UNC (Universal Naming Convention) non valide. L'installation d'Exchange nécessite que le paramètre /CMSDataPath: <PathToTheDatabase> spécifié utilise une affectation de lettre de lecteur valide, comme /CMSDataPath: s:\<PathToTheDatabase>, et non le format UNC.

Pour résoudre ce problème, utilisez une affectation de lettre de lecteur valide pour le paramètre /CMSDataPath: <PathToTheDatabase>.

Pour plus d'informations sur l'installation du serveur de boîtes aux lettres en cluster, voir la rubrique que la procédure d'installation du rôle serveur de boîtes aux lettres dans le nœud actif (http://go.microsoft.com/fwlink/?LinkId=86624) dans la documentation sur le produit Exchange Server 2007.


La version installée de MOUNTMGR.SYS est incompatible avec Exchange Server
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car la version installée de Mountmgr.sys est incompatible avec Microsoft Exchange.

Le programme d'installation d'Exchange 2007 nécessite que la mise à jour visée par l'article 898790 de la Base de connaissances Microsoft soit installée sur le nœud de cluster.

La version de Mountmgr.sys actuellement installée sur le nœud de cluster peut provoquer des échecs de point de montage de volume. Ce problème survient à cause d'une erreur sur le pilote Mountmgr.sys. Il s'agit d'un problème de synchronisation temporaire qui peut survenir lorsqu'un volume arrive pour être monté à un point de montage.

Pour résoudre ce problème, installez la mise à jour visée par l'article 898790 de la Base de connaissances Microsoft (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790), puis recommencez l'installation d'Exchange 2007.

Pour plus d'informations sur ce problème, voir l'article 898790 de la Base de connaissances Microsoft sur les points de montage de volume sur des disques dans un cluster de serveur qui peuvent devenir indisponibles par intermittence après l'installation de Windows Server 2003 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790).


La version installée de TCPIP.SYS est incompatible avec Exchange Server
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car la version installée de Tcpip.sys est incompatible avec Microsoft Exchange.

Le programme d'installation d'Exchange 2007 nécessite que la mise à jour visée par l'article 898060 de la Base de connaissances Microsoft soit installée sur l'ordinateur local.

Cet ordinateur exécute actuellement le pilote Tcpip.sys de Windows Server™ 2003 Service Pack 1. Ce pilote peut provoquer des problèmes de connectivité dans les réseaux étendus.

Pour résoudre ce problème, installez la mise à jour visée par l'article 898060 de la Base de connaissances Microsoft à partir de la page sur la mise à jour pour Windows Server version x64 (KB898060) (http://go.microsoft.com/fwlink/?linkid=59272), puis recommencez l'installation d'Exchange 2007.

Pour plus d'informations sur cet avertissement, voir l'article 898060 de la Base de connaissances Microsoft sur l'installation de la mise à jour de sécurité MS05-019 ou Windows Server 2003 Service Pack 1 qui peut provoquer une panne de connectivité réseau entre clients et serveurs (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060).


Modèle d'organisation Exchange volumineuse détecté
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de groupes de routage dans l'organisation Exchange Server. Exchange Server Analyzer interroge également Active Directory pour déterminer le nombre de sites Active Directory qui disposent de serveurs Exchange exécutant Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003.

Exchange Server Analyzer identifie l'organisation Exchange comme une organisation Exchange volumineuse si les conditions suivantes sont vraies :

  • L'organisation Exchange compte plus de 5 groupes de routage.

  • Les serveurs qui exécutent Exchange 2000 ou Exchange 2003 sont installés dans plus de 5 sites Active Directory.

Pour passer d'une organisation Exchange volumineuse à Exchange 2007

  1. Consultez la documentation en ligne du produit Microsoft Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Passez en revue la rubrique sur la planification d'une organisation Exchange volumineuse (http://go.microsoft.com/fwlink/?LinkId=70504).


L'ordinateur local est un contrôleur de domaine d'un domaine enfant
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-12-29

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car l'ordinateur local est un contrôleur de domaine pour un domaine enfant.

Le programme d'installation d'Exchange 2007 ne peut pas effectuer d'installation sur un contrôleur de domaine pour un domaine enfant, sauf si ce contrôleur de domaine est un serveur de catalogue global.

Pour résoudre ce problème, élevez le contrôleur de domaine au rang de serveur de catalogue global ou installez Exchange 2007 sur un ordinateur qui n'est pas contrôleur de domaine, un serveur membre, dans le domaine enfant, puis recommencez l'installation de Microsoft Exchange.

Correction de cet avertissement en faisant du serveur Exchange un serveur de catalogue global

  1. Sur le contrôleur de domaine, cliquez sur Démarrer, pointez sur Programmes, cliquez sur Outils d'administration, puis cliquez sur Sites et services Active Directory.

  2. Dans l'arborescence de la console, double-cliquez sur Sites, sur le nom du site, puis sur Serveurs.

  3. Double-cliquez sur le contrôleur de domaine cible.

  4. Dans le volet des résultats, cliquez avec le bouton droit sur Paramètres NTDS, puis cliquez sur Propriétés.

  5. Sous l'onglet Général, activez la case à cocher Catalogue global.

  6. Redémarrez le contrôleur de domaine.


L'ordinateur local exécute déjà Exchange Server
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-01-15

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car des composants antérieurs de Microsoft Exchange sont installés sur l'ordinateur local.

Le programme d'installation d'Exchange 2007 nécessite qu'aucun composant existant de Microsoft Exchange ne soit installé sur l'ordinateur local.

Pour résoudre ce problème, supprimez tous les composants de Microsoft Exchange 2000 Server ou de Microsoft Exchange Server 2003, puis recommencez l'installation de Microsoft Exchange.

Suppression des composants de Microsoft Exchange

  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Dans la liste Programmes actuellement installés, cliquez sur Microsoft Exchange, puis sur Modifier/Supprimer.

  4. Dans l'Assistant Installation de Microsoft Exchange, cliquez sur Suivant.

  5. Dans la liste Action de la page Sélection des composants, cliquez sur la flèche vers le bas en regard de chaque composant installé, puis cliquez sur Supprimer.

    Remarque :
    Les composants installés sont marqués par une coche dans la liste Action. Si vous cliquez sur Supprimer, cette coche est remplacée par le mot Supprimer.

  6. Cliquez sur Suivant à deux reprises.

  7. Cliquez sur Terminer.


L'ordinateur local n'exécute pas Windows Server 2003 Service Pack 1 ou une version ultérieure
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car l'ordinateur local n'exécute pas sous Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou une version ultérieure.

Le programme d'installation d'Exchange 2007 nécessite que l'ordinateur utilisé pour Microsoft Exchange exécute Windows Server 2003 SP1 ou une version ultérieure.

Pour résoudre ce problème :

  • Exécutez le programme d'installation d'Exchange 2007 depuis un ordinateur utilisant Windows Server 2003 SP1 ou une version ultérieure.

  • Mettez à niveau l'ordinateur à partir duquel vous voulez exécuter le programme d'installation d'Exchange 2007 vers Windows Server 2003 SP1 ou une version ultérieure.

Pour plus d'informations sur la procédure de mise à niveau vers Windows Server 2003, voir l'article 810613 de la Base de connaissances Microsoft sur les chemins d'accès pris en charge pour la mise à niveau vers Windows Server 2003 ou Windows Small Business Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Pour obtenir le dernier Service Pack de Windows Server 2003, visitez le site TechCenter de Windows Server (http://go.microsoft.com/fwlink/?LinkId=45315).


L'ordinateur local est responsable de l'extension de l'appartenance au groupe
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative de désinstallation d'un rôle Hub Transport responsable du développement de l'appartenance au groupe a échoué.

L'installation d'Exchange 2007 nécessite la suppression de l'extension de la liste de distribution du serveur Bridgehead actuel avant de pouvoir désinstaller le rôle Hub Transport.

L'extension des listes de distribution active l'identification des différents destinataires qui font partie de la liste de distribution à identifier ou l'identification des listes de distributions supplémentaires pour l'extension. Une liste de distribution étendue peut renvoyer le chemin d'accès de toute notification d'état de remise (DSN) demandée. Les notifications d'état de remise (DSN) avertissement l'administrateur Microsoft Exchange ou l'expéditeur d'un message électronique particulier. En outre, l'extension de la liste de distribution indique si les messages Absent du bureau ou les réponses générées automatiquement doivent être envoyées à l'expéditeur du message original.

Pour résoudre ce problème, déplacez l'extension du groupe de distribution sur un autre serveur et recommencez l'installation de Microsoft Exchange.

Pour modifier le serveur d'extension pour un groupe de distribution ou un groupe de distribution dynamique.

  1. Ouvrez la console de gestion Exchange.

  2. Dans l'arborescence de la console, développez Configuration des destinataires.

  3. Dans l'arborescence de la console, cliquez sur Groupe de distribution.

  4. Créez un filtre pour afficher tous les groupes de distribution et les groupes de distribution dynamique qui utilisent le serveur Bridgehead actuel comme serveur d'extension.

    1. Dans le volet Action, cliquez sur Créer un filtre.

    2. Dans la liste déroulante des propriétés, cliquez sur Serveur d'expansion.

    3. Dans la liste déroulante des opérateurs, cliquez sur Equals.

    4. Dans la zone de valeur, cliquez sur le bouton Parcourir pour sélectionner le serveur Bridgehead servant actuellement de serveur d'expansion.
Remarque :
L'étape suivante est facultative.
  1. Cliquez sur Ajouter une expression pour spécifier des critères de filtrage supplémentaires. Seuls les messages correspondant à tous les critères de filtrage sont affichés.

  2. Cliquez sur Appliquer le filtre. Les résultats correspondant aux critères de filtrage s'affichent.

  1. Dans le volet des résultats, cliquez sur le groupe de distribution pour lequel vous souhaitez modifier le serveur d'expansion, puis cliquez sur Propriétés dans le volet Action.

  2. Sous Propriétés, cliquez sur l'onglet Paramètres avancés.

  3. Dans la liste déroulante du serveur d'expansion, sélectionnez un serveur spécifique dans la liste ou sélectionnez Tout serveur de l'organisation.

  4. Répétez les étapes 5 à 7 pour tous les groupes de distribution ou les groupes de distribution dynamique qui utilisent le serveur Bridgehead comme serveur d'expansion.


L'ordinateur local est responsable de la génération du carnet d'adresses en mode hors connexion
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative de désinstallation d'un rôle Mailbox responsable de la génération du carnet d'adresses en mode hors connexion a échoué.

L'installation d'Exchange 2007 nécessite qu'à moins que le rôle Mailbox soit le dernier de l'organisation Exchange, la génération du carnet d'adresses en mode hors connexion soit supprimée du serveur Mailbox actuel avant que le rôle Mailbox puisse être installé.

Pour résoudre ce problème, déplacez la génération du carnet d'adresses en mode hors connexion sur un autre serveur et recommencez l'installation de Microsoft Exchange.

Pour déplacer la génération du carnet d'adresses en mode hors connexion à l'aide du Gestionnaire système Exchange

  1. Ouvrez le Gestionnaire système Exchange.

  2. Sous Destinataires, cliquez sur Listes d'adresses en mode hors connexion.

  3. Dans le volet droit, cliquez avec le bouton droit sur Liste d'adresses en mode hors connexion par défaut, puis cliquez sur Propriétés.

    Remarque :
    Effectuez la même procédure pour toute autre liste d'adresses en mode hors connexion qui génère ce message.

  4. Sous l'onglet Général, sous Serveur de liste d'adresses en mode hors connexion, cliquez sur Parcourir, puis cliquez sur le serveur Exchange que vous souhaitez utiliser.
Pour déplacer la génération du carnet d'adresses en mode hors connexion à l'aide de la console de gestion Exchange

  1. Ouvrez la console de gestion Exchange.

  2. Développez Microsoft Exchange et Configuration de l'organisation, puis sélectionnez Boîte aux lettres.

  3. Dans le volet des résultats, cliquez sur l'onglet Carnet d'adresses en mode hors connexion.

  4. Sous l'onglet Carnet d'adresses en mode hors connexion, sélectionnez le carnet à déplacer. Dans le volet Action, cliquez sur Déplacer.

  5. Lorsque l'Assistant Déplacer le carnet d'adresses en mode hors connexion s'affiche, sélectionnez le nouveau serveur devant héberger la génération du carnet d'adresses en mode hors connexion à l'aide du bouton Parcourir, puis cliquez sur Déplacer.

  6. Pour fermer l'Assistant, cliquez sur Terminer.
Pour utiliser Exchange Management Shell en vue du déplacement de la génération du carnet d'adresses en mode hors connexion

  • Exécutez la commande suivante :

    Copier le code
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


L'ordinateur local exécute le rôle Edge Transport
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il a détecté, lors de sa tentative d'installer un rôle Exchange 2007, le rôle Gateway Server déjà installé sur ce serveur.

Le programme d'installation d'Exchange 2007 ne peut pas installer d'autres rôles de serveur sur un serveur où le rôle Gateway Server de Microsoft Exchange est installé.

Le rôle Gateway Server de Microsoft Exchange est déployé dans le réseau de périmètre de votre organisation, où il traite tout le flux de courrier Internet. Il assure le chiffrement et le déchiffrement des messages envoyés entre les organisations Microsoft Exchange approuvées, ainsi que la protection contre les courriers non sollicités.

Pour résoudre ce problème, installez l'autre rôle Microsoft Exchange 2007 sur un ordinateur où le rôle Gateway Server n'est pas installé.


L'ordinateur local utilise Windows Server 2003 Web Edition
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car l'ordinateur local utilise Microsoft Windows Server™ 2003, Web Edition.

Le programme d'installation d'Exchange 2007 nécessite que Microsoft Exchange soit installé sur un ordinateur qui exécute un système d'exploitation pris en charge.

Pour résoudre ce problème, installez Microsoft Exchange sur un ordinateur utilisant Windows Server 2003 Service Pack 1 (SP1) ou une version ultérieure autre que la Web Edition.


Le domaine local doit être mis à jour
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car l'utilisateur connecté ne possède pas les autorisations nécessaires pour la préparation de domaine.

Le programme d'installation d'Exchange nécessite que l'utilisateur connecté lors de l'exécution de Setup /PrepareDomain soit un membre des groupes Administrateurs de domaine et Administrateurs d'organisation Exchange ou du groupe Administrateurs de l'entreprise.

Pour résoudre ce problème, accordez à l'utilisateur connecté des autorisations de niveau Admins du domaine et Administrateurs d'organisation Exchange ou inscrivez-le dans le groupe Administrateurs de l'entreprise ou ouvrez une session à l'aide d'un compte disposant des autorisations, puis recommencez l'installation d'Exchange 2007.

Pour plus d'informations sur les autorisations Active Directory nécessaires avec Microsoft Exchange, voir la rubrique sur l'utilisation des autorisations Active Directory dans Exchange Server (http://go.microsoft.com/fwlink/?LinkId=47592).


Impossible d'accéder à la métabase locale
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il n'a pas pu lire des données dans la métabase locale.

L'installation d'Exchange 2007 nécessite que l'installation des rôles Mailbox Server ou Client Access puisse lire dans la métabase des services Internet (IIS) Microsoft.

La métabase IIS comprend des informations qui affectent Microsoft Exchange, par exemple les paramètres de protocole pour HTTP, les répertoires virtuels pour l'accès à la boîte aux lettres et aux périphériques mobiles et les paramètres de sécurité HTTP.

Pour résoudre ce problème, vérifiez que les services Internet soient correctement installés, puis recommencez l'installation de Microsoft Exchange.

Pour vérifier que les services Internet sont correctement installés, voir les ressources suivantes :

  • Article 843093 de la Base de connaissances Microsoft sur la procédure de résolution des problèmes d'endommagement de la métabase IIS sur un ordinateur Windows 2000 qui utilise Exchange 2000 Server ou Exchange Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093).

  • Article 240225 de la Base de connaissances Microsoft sur la description des utilitaires Adsutil et MetaEdit utilisés pour modifier la métabase (http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225).

  • Article 317678 de la Base de connaissances Microsoft sur la procédure de redémarrage des services Internet (IIS) sur Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678).

Si les instructions fournies dans ces ressources ne permettent pas de résoudre le problème, il se peut que vous deviez désinstaller, puis réinstaller IIS.

Pour désinstaller IIS à l'aide de l'option Ajouter ou supprimer des composants Windows du Panneau de configuration

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications.

  5. Cliquez sur Détails.

  6. Cliquez sur le Gestionnaire des services Internet (IIS).

  7. Cliquez sur Suivant.

  8. Cliquez sur Terminer lorsque les services Internet (IIS) sont désinstallés.
Pour installer IIS à l'aide du Panneau de configuration

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications.

  5. Cliquez sur Détails.

  6. Activez la case à cocher Gestionnaire des services Internet (IIS).

  7. Cliquez sur OK jusqu'à ce que vous soyez revenu dans l'Assistant Composants Windows.

  8. Cliquez sur Suivant et terminez l'Assistant Composants Windows.


L'utilisateur connecté n'est pas membre du groupe Administrateurs local
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car l'utilisateur connecté n'est pas membre du groupe Administrateurs de l'ordinateur local.

Le programme d'installation d'Exchange 2007 nécessite que l'utilisateur connecté qui installe Microsoft Exchange dispose d'un accès total à l'ordinateur local.

Pour résoudre ce problème, ouvrez une session sur l'ordinateur à l'aide d'un compte disposant d'un accès d'administrateur local, puis recommencez l'installation de Microsoft Exchange.


L'utilisateur connecté n'est pas membre du groupe Administrateurs du schéma
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-09-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le processus de mise à jour du schéma ne possède pas d'informations d'identification d'administration du schéma du service d'annuaire Active Directory® ni d'administration d'entreprise.

Le programme d'installation d'Exchange 2007 nécessite que l'utilisateur connecté qui installe Microsoft Exchange dispose d'informations d'identification d'administration du schéma et d'administration d'entreprise pour la forêt Active Directory.

Dans le cadre du processus d'installation, le programme d'installation de Microsoft Exchange développe le schéma Active Directory afin d'ajouter des classes et des attributs spécifiques à Exchange 2007.

Si l'utilisateur connecté ne possède pas de droits de niveau Administrateur du schéma ou d'administration d'entreprise, le processus de mise à jour du schéma échoue.

Pour résoudre ce problème, ajoutez l'utilisateur connecté aux groupes Administrateurs du schéma et Administrateurs de l'entreprise, puis déconnectez-vous et reconnectez-vous ou déconnectez-vous et reconnectez-vous avec un compte qui possède déjà les informations d'identification d'administration du schéma et d'entreprise pour la forêt Active Directory.


Trop de nœuds actifs
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-23

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative de création d'un rôle serveur de boîte aux lettres en cluster actif a échoué.

Exchange Server 2007 nécessite qu'au moins un nœud du cluster soit passif pour prendre en charge la récupération en cas d'échec.

Pour résoudre ce problème, installez un autre rôle serveur de boîte aux lettres en cluster dans l'environnement, puis réexécutez le programme d'installation.

Pour plus d'informations sur l'installation de nœuds actifs et passifs, voir la rubrique sur la disponibilité élevée (http://go.microsoft.com/fwlink/?LinkId=68190) dans la documentation sur le produit Exchange Server 2007.


La définition de lecteur de la base de données de boîtes aux lettres est manquante
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-05-15

Le programme d'installation de Microsoft® Exchange Server 2007 Disaster Recovery ne peut pas poursuivre son exécution car il ne peut pas accéder à la définition de lecteur de la base de données de boîtes aux lettres utilisée lors de l'installation précédente sur ce serveur.

Le programme d'installation de Microsoft Exchange Disaster Recovery nécessite que les mêmes définitions de lecteur de la base de données de boîtes aux lettres que celles utilisées précédemment pour ce serveur soient disponibles pendant la restauration.

Pour résoudre ce problème, configurez les lecteurs de manière à correspondre à la configuration de lecteurs logiques d'origine, puis recommencez l'installation de Microsoft Exchange Disaster Recovery.

Attribution ou modification d'une lettre de lecteur

  1. Ouvrez Gestion de l'ordinateur (Local).

  2. Dans l'arborescence de la console, cliquez sur Gestion de l'ordinateur (Local), sur Stockage, puis sur Gestion des disques.

  3. Cliquez avec le bouton droit sur une partition, un lecteur logique ou un volume, puis cliquez sur Modifier la lettre de lecteur et les chemins d'accès.

  4. Utilisez l'une des procédures suivantes :

    • Pour attribuer une lettre de lecteur, cliquez sur Ajouter, sur la lettre à utiliser, puis sur OK.

    • Pour modifier une lettre de lecteur, cliquez sur celle-ci, sur Modifier, sur la lettre à utiliser, puis sur OK.

Pour plus d'informations sur la procédure d'attribution de lettres de lecteur, voir la rubrique sur l'attribution, la modification ou la suppression d'une lettre de lecteur (http://go.microsoft.com/fwlink/?LinkId=66764).


Une ou plusieurs files d'attente contiennent des messages
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

Le programme d'installation de Microsoft® Exchange Server 2007 affiche cet avertissement car la tentative de désinstallation d'un rôle Transport pourrait entraîner une perte de données dans une file d'attente de transport.

Il lance une vérification pour s'assurer que les files d'attente de transport sont vides avant de supprimer les rôles qui assurent leur gestion.

Si vous supprimez les rôles Transport avant la remise des messages que les files d'attente correspondantes contiennent, ces messages seront bloqués indéfiniment.

Pour résoudre ce problème, examinez les files d'attente référencées afin de vous assurer qu'elles sont vides, pour pouvoir continuer l'installation.

Pour afficher le contenu d'une file d'attente

  1. Ouvrez la console de gestion Exchange.

  2. Dans l'arborescence de la console, cliquez sur Boîte à outils.

  3. Dans le volet des résultats, cliquez sur Afficheur des files d'attente Exchange.

  4. Dans le volet Action, cliquez sur Ouvrir l'outil.

  5. Dans l'Afficheur de files d'attente, cliquez sur l'onglet Files d'attente. Une liste de toutes les files d'attente du serveur auquel vous êtes connecté s'affiche.

  6. Cliquez avec le bouton droit sur la file d'attente souhaitée, puis sélectionnez Propriétés pour afficher les propriétés de la file d'attente.
Pour afficher les messages d'une file d'attente

  1. Observez les étapes 1 à 4.

  2. Dans l'Afficheur de files d'attente, cliquez sur l'onglet Messages. Une liste de tous les messages du serveur auquel vous êtes connecté s'affiche. Pour configurer l'affichage d'une file d'attente spécifique, cliquez sur l'onglet Files d'attente, double-cliquez sur le nom de la file d'attente souhaitée, puis cliquez sur l'onglet Serveur\File d'attente qui s'affiche.

  3. Pour afficher des informations détaillées sur un message, sélectionnez-le, puis cliquez sur Propriétés dans le volet Action.


Mise à jour Microsoft .NET Framework requise
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-02-26

L'exécution du programme d'installation de Microsoft Exchange Server 2007 ne peut pas se poursuivre car l'ordinateur local nécessite une mise à jour logicielle.

Le programme d'installation d'Exchange 2007 nécessite l'installation sur l'ordinateur local de la mise à jour de Microsoft .NET Framework appropriée référencée ci-après.

Pour résoudre ce problème, quittez le programme d'installation d'Exchange 2007 et installez la mise à jour appropriée (32 bits ou 64 bits) à partir des URL suivantes, puis réexécutez le programme d'installation d'Exchange 2007.

Remarque :
Un clic sur les liens ci-après vous invite à télécharger les fichiers directement.
  • Téléchargement 64 bits, http://go.microsoft.com/fwlink/?linkid=74465

  • Téléchargement 32 bits, http://go.microsoft.com/fwlink/?linkid=74469


Microsoft Core XML Services (MSXML) 6.0 requis
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-21

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car Microsoft Core XML Services (MSXML) 6.0 n'est pas installé sur ce serveur.

Pour toute installation de rôle de serveur de messagerie unifiée, le programme d'installation d'Exchange Server 2007 nécessite l'installation de MSXML 6.0 sur l'ordinateur pour prendre en charge les services vocaux de Microsoft.

Pour résoudre ce problème, installez le logiciel MSXML 6.0 depuis http://go.microsoft.com/fwlink/?LinkId=70796, puis réexécutez le programme d'installation d'Exchange 2007.


Le chemin d'accès de MNSFileShare n'est pas valide
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le chemin d'accès de MNSFileShare n'est pas valide.

La valeur MNSFileShare doit être définie sur une valeur de chaîne qui contient le chemin UNC d'un partage de fichier externe au cluster, comme \\server\sharename.

Pour résoudre ce problème, entrez une valeur pour la propriété dont le chemin UNC est valide.

Pour plus d'informations sur la procédure de configuration de la propriété MNSFileShare, voir la rubrique sur la procédure de configuration du témoin de partage de fichiers (http://go.microsoft.com/fwlink/?LinkId=78278).


Mise à jour de MSDAPS.DLL requise
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-12-05

L'exécution du programme d'installation de Microsoft® Exchange Server 2007 ne peut pas se poursuivre car l'ordinateur local nécessite une mise à jour logicielle.

Le programme d'installation d'Exchange 2007 nécessite l'installation sur l'ordinateur local de la mise à jour de MSDAPS.DLL référencée ci-dessous.

Pour résoudre ce problème, téléchargez et installez la mise à jour dont le lien figure ci-dessous, puis exécutez de nouveau le programme d'installation d'Exchange 2007.

  • http://go.microsoft.com/fwlink/?linkid=74467


Le service NNTP est actuellement installé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-01-22

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le service NNTP (Network News Transport Protocol) de Microsoft Windows® Server™ 2003 est installé sur cet ordinateur.

Le programme d'installation de Microsoft Exchange nécessite que le service NNTP ne soit pas installé sur les serveurs utilisés pour Exchange 2007.

Pour résoudre ce problème, désinstallez le service NNTP, puis exécutez de nouveau le programme d'installation de Microsoft Exchange.

Désinstallation du service NNTP à l'aide de la fonction Ajouter ou supprimer des composants Windows du Panneau de configuration :

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications, puis cliquez sur Détails.

  5. Sélectionnez Gestionnaire des services IIS, puis cliquez sur Détails.

  6. Sélectionnez Service NNTP, puis cliquez pour désactiver la case à cocher.

  7. Cliquez sur OK à deux reprises pour revenir à la liste Composants, puis cliquez sur Suivant.

  8. Cliquez sur Terminé lorsque le service NNTP est désinstallé.


Aucun rôle serveur d'accès au client détecté
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-02-16

L'outil Microsoft Exchange Analyzer interroge le service d'annuaire Active Directory pour la valeur des objets de la classe msExchAdminGroupContainer dans l'organisation Exchange contenant l'identificateur de groupe d'administration spécifique à Exchange Server 2007, FYDIBOHF23SPDLT.

Si Exchange Analyzer détecte un groupe d'administration Exchange Server 2007 dans l'organisation Exchange, il interroge tous les sites Active Directory dans l'organisation pour la valeur de l'attribut msExchCurrentServerRoles pour chaque objet msExchExchangeServer afin de déterminer si un rôle serveur de boîtes aux lettres est installé dans un des sites trouvés.

Si Exchange Analyzer détecte un rôle serveur de boîtes aux lettres installé dans un site, il interroge l'attribut msExchCurrentServerRoles de chaque objet msExchExchangeServer dans ce site afin de déterminer si un rôle serveur d'accès au client est également installé dans ce même site.

Si Exchange Analyzer détecte un rôle serveur de boîtes aux lettres installé dans un site Active Directory dans lequel aucun rôle serveur d'accès au client n'est installé, il affiche un avertissement.

Cet avertissement indique que, même si un rôle serveur de boîtes aux lettres est installé dans le site Active Directory, les clients Microsoft Office Outlook Web Access et les clients d'accès aux périphériques mobiles Exchange ActiveSync ne pourront pas accéder à leur messagerie sur ce serveur de boîtes aux lettres tant que le rôle serveur d'accès au client n'est pas installé dans ce site.

Le rôle serveur d'accès au client accepte les connexions au serveur Exchange 2007 depuis divers clients. Les clients logiciels tels que Microsoft Outlook Express et Eudora utilisent des connexions POP3 ou IMAP4 pour communiquer avec le serveur Exchange. Les clients matériels, tels que les périphériques mobiles, utilisent ActiveSync, POP3 ou IMAP4 pour communiquer avec le serveur Exchange.

Si les utilisateurs accèdent à leur boîte de réception à l'aide d'un client autre que Microsoft Outlook, vous devez installer le rôle serveur d'accès au client dans l'organisation Exchange.

Pour supprimer cet avertissement, si vous avez des clients autres que ceux utilisant Microsoft Outlook qui doivent accéder à des boîtes aux lettres, installez le rôle serveur d'accès au client dans les sites dans lesquels le rôle serveur de boîtes aux lettres est installé.

Pour plus d'informations

Pour plus d'informations sur la procédure d'installation du rôle serveur d'accès au client dans un site, consultez la rubrique relative au déploiement de rôles serveur (http://go.microsoft.com/fwlink/?LinkId=83282) dans la documentation produit d'Exchange Server 2007.


Espace d'adressage non standard trouvé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-21

L'outil Microsoft® Exchange Server Analyzer Tool affiche cet avertissement s'il détermine qu'il existe un espace d'adressage non standard dans au moins une stratégie de destinataire.

Un espace d'adressage non standard, ou proxy, est l'adresse par laquelle un objet destinataire Exchange Server est reconnu dans un système de messagerie étranger.

Dans les versions antérieures d'Exchange Server, la prise en charge des espaces d'adressage non standard incombait au service de mise à jour de destinataire.

Dans Microsoft Exchange Server 2007, le service de mise à jour destinataire n'est pas mis en œuvre. Il appartient à la console d'administration d'Exchange 2007 de générer des adresses proxy.

Les consoles d'administration doivent disposer d'une DLL de génération proxy chargée pour chaque espace d'adressage non standard détecté.

Important :
Si la console d'administration est exécutée sur un ordinateur 64 bits, une version 64 bits de la DLL de génération proxy est nécessaire.

Pour supprimer cet avertissement, contactez le fournisseur qui prend en charge l'espace d'adressage étranger afin d'obtenir la DLL de génération proxy compatible avec Exchange 2007.


Absent du site/domaine du contrôleur de schéma
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-10

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car l'ordinateur qui l'exécute ne se trouve pas dans le même site ou domaine du service d'annuaire Active Directory® que le serveur auquel le rôle de contrôleur de schéma du domaine également appelé FSMO (flexible single master operations, opérations à maître unique flottant).

Le programme d'installation d'Exchange 2007 nécessite que le contrôleur de domaine qui sert de contrôleur de schéma du domaine se trouve dans le même site et domaine que l'ordinateur local qui exécute programme d'installation d'Exchange.

Le contrôleur de schéma du domaine contrôle toutes les mises à jour et les modifications du schéma Active Directory.

Pour résoudre ce problème, exécutez le programme d'installation d'Exchange Server 2007 à partir du même site et domaine que le contrôleur de schéma du domaine.

L'outil Contrôleur de schéma permet d'identifier le rôle. Toutefois, la DLL Schmmgmt.dll doit être enregistrée pour que l'outil Schéma soit disponible comme un logiciel enfichable MMC.

Pour afficher le contrôleur de schéma actuel

  1. À l'invite de commandes, tapez regsvr32 schmmgmt.dll.

    Remarque :
    RegSvr32 est enregistré lorsque la boîte de dialogue suivante s'affiche :

    DllRegisterServer in schmmgmt.dll succeeded.

  2. Pour ouvrir une nouvelle console de gestion, cliquez sur Démarrer et sur Exécuter, puis tapez mmc.

  3. Dans le menu de la console, cliquez sur Ajouter/Supprimer un composant logiciel enfichable.

  4. Cliquez sur Ajouter pour ouvrir la boîte de dialogue Ajout d'un composant logiciel enfichable autonome.

  5. Sélectionnez Schéma Active Directory, puis cliquez sur Ajouter.

  6. « Schéma Active Directory » s'affiche dans Ajouter/Supprimer un composant logiciel enfichable. Cliquez sur Fermer, puis sur OK pour revenir à la console.

  7. Sélectionnez Schéma Active Directory pour que les sections Classes et Attributs s'affichent à droite.

  8. Cliquez avec le bouton droit sur Schéma Active Directory, puis cliquez sur Maître d'opérations.

  9. Le contrôleur de schéma actuel s'affiche.


Le domaine ne contient pas de contrôleur de domaine Windows Server 2003 SP1
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la commande Setup /PrepareLegacyExchangePermissions n'a pas trouvé de contrôleur de domaine exécutant Microsoft Windows Server 2003 Service Pack 1 (SP1) ou version ultérieure dans le domaine préparé.

Dans chaque domaine où vous exécutez la commande Setup /PrepareLegacyExchangePermissions, le programme d'installation doit contacter un contrôleur de domaine Windows Server 2003 SP1. La commande Setup /PrepareLegacyExchangePermissions ne sera pas appliquée avec succés si elle ne peut pas trouver au moins un contrôleur de domaine Windows Server 2003 SP1.

L'exécution de la commande setup /PrepareLegacyExchangePermissions permet au service de mise à jour de destinataire de fonctionner correctement. Avant l'importation du nouveau schéma Exchange 2007, Exchange 2007 doit attribuer de nouvelles autorisations dans chaque domaine dans lequel vous avez exécuté l'outil DomainPrep d'Exchange Server 2003 ou Exchange 2000 Server. La commande setup /PrepareLegacyExchangePermissions octroie ces nouvelles autorisations.

Pour résoudre ce problème, mettez à niveau au moins un contrôleur de domaine dans chaque domaine où vous exécuterez la commande setup /PrepareLegacyExchangePermissions pour Windows Server 2003 SP1 ou une version ultérieure, puis exécutez une nouvelle fois le programme d'installation.

Pour plus d'informations sur la procédure de préparation d'autorisations héritées d'Exchange, voir la rubrique sur la préparation d'autorisations héritées d'Exchange (http://go.microsoft.com/fwlink/?linkid=81776) dans la documentation sur le produit Exchange Server 2007.


Serveur OAB supprimé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-21

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative d'installer le rôle serveur d'accès au client a échoué. Le serveur de boîtes aux lettres Exchange désigné pour héberger le Carnet d'adresses en mode hors connexion a été supprimé.

L'installation d'Exchange 2007 nécessite un serveur de boîtes aux lettres Exchange valide hébergeant la génération du carnet d'adresses en mode hors connexion pour pouvoir poursuivre l'installation du rôle serveur d'accès au client.

Pour résoudre ce problème, désignez un serveur de boîtes aux lettres Exchange valide pour héberger la génération du Carnet d'adresses en mode hors connexion, puis exécutez à nouveau le programme d'installation d'Exchange 2007.

Pour plus d'informations sur la procédure de désignation d'un serveur Exchange comme hôte pour la génération du Carnet d'adresses en mode hors connexion, voir la rubrique sur la procédure de création d'un Carnet d'adresses en mode hors connexion (http://go.microsoft.com/fwlink/?LinkId=86314) dans la documentation sur le produit Exchange 2007.


Présence d'anciens fichiers de base de données
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il a détecté des fichiers de base de données Microsoft Exchange existants dans le chemin d'accès de l'installation cible.

Le programme d'installation d'Exchange 2007 nécessite que le chemin d'accès de l'installation cible ne contienne pas de fichiers de base de données Microsoft Exchange.

Pour résoudre ce problème, supprimez tous les fichiers existants des chemins d'accès de l'installation cible, puis recommencez l'installation.

Pour supprimer des fichiers de base de données Exchange Server existants du chemin d'accès de l'installation cible

  1. Dans le Poste de travail ou l'Explorateur Windows, trouvez le chemin d'accès de l'installation cible.

    Remarque :
    Par défaut, les fichiers de base de données se trouvent à l'emplacement suivant :

    <lecteur_système>:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group.

  2. Cliquez avec le bouton droit sur les fichiers à supprimer, puis sélectionnez Supprimer.

  3. Dans la ???boîte de dialogue Confirmation de la suppression du fichier, cliquez sur Oui.

  4. Répétez les étapes 2 et 3 pour tous les fichiers des chemins d'accès de l'installation cible.


Ancienne version d'ADAM détectée
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 affiche cet avertissement car, lors de sa tentative d'installer le rôle Gateway Server, il a détecté une ancienne version d'ADAM (Active Directory® Application Mode) sur le serveur actuel.

ADAM est un service d'annuaire LDAP (Lightweight Directory Access Protocol) conçu spécifiquement en vue d'une utilisation avec des applications compatibles avec l'annuaire. ADAM ne stocke et réplique que les informations spécifiques aux applications ; il ne nécessite pas de déploiement sur un contrôleur de domaine et ne dépend pas du service Active Directory. ADAM ne fournit pas d'authentification ni d'autorisation de système d'exploitation de réseau.

Dans Exchange 2007, le serveur de passerelle utilise ADAM pour stocker les informations de configuration. Lorsque ADAM est synchronisé avec Active Directory, il peut également permettre d'effectuer une recherche de destinataires pour la sécurité des messages.

Le programme d'installation d'Exchange 2007 met automatiquement l'installation ADAM à niveau vers la version Service Pack 1 (SP1).

Aucune intervention n'est requise de votre part, sauf si vous ne voulez pas mettre ADAM à niveau. Dans ce cas, n'installez pas le rôle Gateway Server sur l'ordinateur local.


Au moins un serveur Active Directory Connector trouvé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car au moins un connecteur Active Directory a été trouvé dans l'environnement Microsoft Exchange actuel.

Le connecteur ADC réplique les objets d'Exchange Server version 5.5 vers le service d'annuaire Active Directory® dans un environnement Microsoft Exchange en mode mixte et n'est pas pris en charge par Exchange 2007.

L'installation d'Exchange 2007 nécessite la suppression de tous les composants ADC.

Pour résoudre ce problème, supprimez tous les composants ADC, puis recommencez l'installation d'Exchange 2007.

Pour supprimer les composants Active Directory Connector

  1. Pour désactiver le service ADC sur le serveur exécutant ADC, cliquez avec le bouton droit sur Poste de travail sur le Bureau, puis cliquez sur Gérer.

  2. Développez le nœud Services et applications, puis cliquez sur le nœud Services.

  3. Dans le volet droit, cliquez avec le bouton droit sur Microsoft Active Directory Connector et cliquez sur Propriétés.

  4. Modifiez le Type de démarrage en Désactivé. Au prochain démarrage de l'ordinateur, le service ADC ne sera pas lancé.

  5. Cliquez sur Appliquer, puis sur OK.

  6. L'Assistant Installation d'Active Directory fourni sur le CD-ROM Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003 permet de désinstaller le service ADC. Ouvrez le dossier \ADC\I386 et double-cliquez sur le programme Setup.exe. Suivez les invites pour Supprimer tous les composants du service ADC.

    Important :
    Vous devez effectuez l'étape 6 et Supprimer tous les composants ADC pour résoudre ce problème. Il ne suffit pas de désactiver le service ADC.

Pour plus d'informations sur le connecteur ADC, voir les articles suivants de la Base de connaissances Microsoft :

  • 325300 sur la Webdiffusion du Support Technique et l'introduction à Active Directory Connector (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300).

  • 325221 sur la Webdiffusion du Support Technique et Microsoft Advanced Active Directory Connector" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221).

  • 312632 sur la procédure d'installation et de configuration d'Active Directory Connector dans Exchange 2000 Server (http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632).


Un seul serveur de réplication continue en cluster (CCR) autorisé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la tentative de création d'un serveur de boîtes aux lettres en cluster a échoué.

Exchange Server 2007 nécessite que seul un serveur de boîtes aux lettres en cluster CCR existe dans la cluster CCR. Un serveur de boîtes aux lettres en cluster existe déjà dans ce cluster CCR.

Pour résoudre ce problème, n'essayez pas d'installer un autre serveur de boîtes aux lettres en cluster CCR dans ce cluster.

Pour plus d'informations sur l'installation du serveur de boîtes aux lettres en cluster dans un environnement CCR, voir la procédure d'installation du rôle serveur de boîtes aux lettres dans le nœud actif (http://go.microsoft.com/fwlink/?LinkId=86624) dans la documentation sur le produit Exchange Server 2007.


Seul le rôle Mailbox peut être installé sur un serveur de cluster
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-07

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative d'installer un rôle autre que le rôle Mailbox Server sur ce serveur en clusters a échoué.

Microsoft Exchange ne prend pas en charge les rôles Exchange 2007 autres que le rôle Mailbox Server sur les serveurs où le service de cluster est installé.

Pour résoudre ce problème, voir la section sur la disponibilité élevée pour Exchange 2007 du Guide des opérations d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=68190).


L'organisation est en mode mixte
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-05-15

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car l'organisation Microsoft Exchange existante n'est pas en mode natif.

L'installation d'Exchange 2007 nécessite que l'organisation Exchange existante soit en mode natif.

Pour résoudre ce problème, effectuez la procédure suivante après la dernière mise à niveau d'Exchange Server version 5.5 dans l'organisation existante ou avant la désactivation du dernier serveur Exchange 5.5. Recommencez ensuite l'installation d'Exchange 2007.

Remarque :
Une fois que vous êtes passé en mode natif, vous ne pouvez pas revenir en mode mixte.
Pour passer en mode natif

  1. Démarrez le Gestionnaire système Exchange : Cliquez sur Démarrer, pointez sur Tous les programmes, Microsoft Exchange, puis cliquez sur Gestionnaire système.

  2. Dans l'arborescence de la console, cliquez avec le bouton droit sur l'organisation pour laquelle vous souhaitez passer en mode natif, puis cliquez sur Propriétés.

  3. Dans Propriétés de <Nom_organisation>, sous Changement du mode d'opération, cliquez sur Changer le mode.

  4. Dans la boîte de dialogue d'avertissement, cliquez sur Oui si vous êtes sûr de vouloir passer en mode natif de façon permanente. Cliquez sur Appliquer pour accepter votre nouveau mode Exchange.

Vous devez redémarrer le service de banque d'informations de Microsoft Exchange sur tous les serveurs Exchange de votre organisation pour profiter pleinement du mode natif Exchange. Vous ne devez pas redémarrer tous les services de banque d'informations de Microsoft Exchange simultanément, mais vous devez redémarrer le service sur chaque serveur pour que le serveur puisse profiter de toutes les fonctions du mode natif Exchange. Redémarrez le service sur vos serveurs après la réplication du changement en mode natif sur le contrôleur de domaine Microsoft Windows® local.

Pour redémarrer le service de banque d'informations de Microsoft Exchange

  1. Cliquez sur Démarrer et Exécuter, entrez services.msc, puis cliquez sur OK.

  2. Dans le volet Services (Local), recherchez le service Banque d'informations de Microsoft Exchange.

  3. Cliquez avec le bouton droit sur le service, puis cliquez sur Redémarrer.

Pour plus d'informations sur la procédure de conversion du mode mixte en mode natif, voir l'article 32779 de la Base de connaissances Microsoft sur la procédure à suivre pour passer du mode mixte au mode natif sous Exchange (http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779).


Impossible de contacter le serveur DNS principal
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car il est impossible d'établir la communication avec le serveur DNS principal (Domain Name System).

L'installation d'Exchange 2007 nécessite une communication entre l'ordinateur local et la base de données DNS faisant autorité pour le domaine.

Microsoft Exchange dépend de DNS pour résoudre l'adresse IP de son serveur de destination interne ou externe suivant.

La communication avec le serveur DNS principal peut échouer pour les raisons suivantes :

  • La configuration TCP/IP locale ne pointe pas vers le serveur DNS correct.

  • Le serveur DNS est arrêté ou inaccessible en raison d'une défaillance du réseau ou pour d'autres motifs.

Pour résoudre ce problème :

  • Vérifiez que la configuration TCP/IP locale pointe vers le serveur DNS correct.

Pour vérifier la configuration TCP/IP locale

  1. Passez en revue la configuration TCP/IP locale :

    Pour plus d'informations, voir la rubrique sur la configuration TCP/IP pour utiliser DNS (http://go.microsoft.com/fwlink/?LinkId=68094).
  • Vérifiez que le serveur DNS est en cours d'exécution et peut être contacté.

Pour vérifier que le serveur DNS est en cours d'exécution et peut être contacté

  1. Pour vérifier que le serveur DNS est en cours d'exécution, effectuez au moins l'une des vérifications suivantes :

    • Examinez l'état du serveur DNS à partir du programme d'administration DNS sur le serveur DNS.

    • Redémarrez le serveur DNS.

      Pour plus d'informations, voir la rubrique sur le démarrage, l'arrêt, la mise en pause ou le redémarrage d'un serveur DNS (http://go.microsoft.com/fwlink/?LinkId=62999).

    • Vérifiez le temps de réponse du serveur DNS à l'aide de la commande nslookup.

      Pour plus d'informations, voir les instructions de la rubrique sur la vérification du temps de réponse du serveur DNS à l'aide de la commande nslookup (http://go.microsoft.com/fwlink/?LinkId=63000).


La définition de lecteur de la base de données de dossiers publics est manquante
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-05-15

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le programme d'installation de l'outil Disaster Recovery ne peut pas accéder à la définition de lecteur de la base de données de dossiers publics qui a été utilisée lors de l'installation précédente sur ce serveur.

Le programme d'installation de Microsoft Exchange Disaster Recovery nécessite que les mêmes définitions de lecteur de la base de données de dossiers publics que celles utilisées précédemment pour ce serveur soient disponibles pendant la restauration.

Pour résoudre ce problème, configurez les lecteurs de manière à correspondre à la configuration de lecteurs logiques d'origine, puis recommencez l'installation de Microsoft Exchange Disaster Recovery.

Attribution ou modification d'une lettre de lecteur

  1. Ouvrez Gestion de l'ordinateur (Local).

  2. Dans l'arborescence de la console, cliquez sur Gestion de l'ordinateur (Local), sur Stockage, puis sur Gestion des disques.

  3. Cliquez avec le bouton droit sur une partition, un lecteur logique ou un volume, puis cliquez sur Modifier la lettre de lecteur et les chemins d'accès.

  4. Utilisez l'une des procédures suivantes :

    • Pour attribuer une lettre de lecteur, cliquez sur Ajouter, sur la lettre à utiliser, puis sur OK.

    • Pour modifier une lettre de lecteur, cliquez sur celle-ci, sur Modifier, sur la lettre à utiliser, puis sur OK.

Pour plus d'informations sur la procédure d'attribution de lettres de lecteur, voir la rubrique sur l'attribution, la modification ou la suppression d'une lettre de lecteur (http://go.microsoft.com/fwlink/?LinkId=66764).


Impossible d'accéder à distance au Registre sur un nœud en cluster
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-04-13

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas se poursuivre son exécution car le Registre sur le nœud en cluster est inaccessible.

L'installation d'Exchange 2007 nécessite un accès au Registre de tous les nœuds du cluster pour extraire divers paramètres.

Pour résoudre ce problème, procédez comme suit :

  • Vérifiez que le service Registre distant est exécuté sur tous les nœuds du cluster.

  • Vérifiez que la fonction Partage de fichiers et d'imprimantes pour les réseaux Microsoft soit activée pour l'adaptateur réseau répertorié en première place dans l'ordre des liens.

  • Vérifiez que les valeurs des clés de Registre suivantes soient les mêmes dans chaque nœud du cluster et sont valides pour la stratégie de groupe appropriée :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

Pour plus d'informations sur la résolution des problèmes de connectivité du Registre, voir la section sur la résolution des problèmes de connectivité du Registre dans la rubrique sur les problèmes de connectivité de l'outil Microsoft Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?linkid=56285).


Suppression de l'abonnement Edge avant la désinstallation du rôle serveur
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-21

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le processus de désinstallation du rôle serveur de transport Edge ou Hub a échoué parce que le rôle serveur possède un abonnement Edge.

L'abonnement d'un serveur de transport Edge à un site Active Directory associe le serveur de transport Edge à l'organisation Exchange. Un serveur de transport Edge abonné est marqué à l'aide d'un attribut de site Active Directory. Entre autres choses, cette association vous permet de configurer l'abonnement Edge comme serveur source pour les connecteurs d'envoi créés dans l'organisation Exchange. Les serveurs de transport Hub dans l'organisation Exchange utilisent un connecteur d'envoi intra-organisationnel spécifique pour router les messages électroniques vers Internet via le serveur de transport Edge abonné. L'association au site Active Directory permet aux serveurs de transport Hub de localiser le serveur de transport Edge à des fins de routage.

Le programme d'installation d'Exchange 2007 nécessite que tous les abonnements Edge pour le rôle serveur cible de transport Edge ou le dernier rôle serveur de transport Hub sur un site, soient supprimés avant de désinstaller le rôle serveur de transport Edge ou Hub.

Pour résoudre cette erreur, la cmdlet Get-EdgeSubscription permet de récupérer des informations sur les abonnements Edge et la cmdlet Remove-EdgeSubscription permet de supprimer l'abonnement Edge du serveur cible, puis réexécutez le programme d'installation d'Exchange 2007.

Pour identifier et supprimer l'abonnement Edge

  1. Suivez les instructions de la rubrique sur la cmdlet Get-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86320) pour identifier des abonnements Edge pour le serveur cible.

  2. Suivez les instructions de la rubrique sur la cmdlet Remove-EdgeSubscription (http://go.microsoft.com/fwlink/?LinkId=86321) pour supprimer l'abonnement Edge du serveur cible.


Le schéma FSMO est différent de Windows Server 2003 Service Pack 1 (SP1) ou supérieur
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge la forêt du service d'annuaire Active Directory® pour savoir quelle version du système d'exploitation est exécutée sur le contrôleur de schéma du contrôleur de domaine Active Directory. Si Exchange Server Analyzer détecte que le contrôleur de domaine Active Directory ayant le rôle de contrôleur des opérations, également appelé FSMO (flexible single master operations, opérations à maître unique flottant), n'utilise pas Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou une version ultérieure, il affiche une erreur.

Cette erreur indique que Windows Server 2003 SP1 ou supérieur est nécessaire pour installer Microsoft Exchange Server 2007. Windows Server 2003 SP1 ou une version supérieure est nécessaire pour prendre en charge les nouvelles structures d'autorisations d'Exchange 2007.

Si le contrôleur de domaine FSMO de schéma d'Active Directory n'utilise pas Windows Server 2003 SP1 ou supérieur, l'installation d'Exchange 2007 échouera.

Ce message résulte d'un contrôle des conditions préalables au déploiement d'Exchange 2007. Il est recommandé d'exécuter Windows Server 2003 SP1 ou supérieur sur le contrôleur de domaine ayant le rôle de maître des opérations Active Directory à l'échelle de la forêt si vous prévoyez d'installer Exchange 2007.


Le contrôleur de schéma utilise Windows 2000 Server
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-01-08

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le contrôleur de domaine attribué au rôle de contrôleur de schéma du service d'annuaire Active Directory®, également baptisé FSMO (flexible single master operations, opérations à maître unique flottant), utilise Microsoft Windows® 2000 Server.

Le programme d'installation d'Exchange 2007 nécessite que le contrôleur de domaine qui fait office de FSMO du schéma tourne utilise Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou une version ultérieure.

Le FSMO contrôle toutes les mises à jour et les modifications du schéma Active Directory.

Pour résoudre ce problème, mettez à niveau ou déplacez le contrôleur de domaine FSMO vers Windows Server 2003 SP1 ou une version de serveur ultérieure, puis recommencez l'installation de Microsoft Exchange.

Pour plus d'informations, consultez l'article 325379 de la Base de connaissances Microsoft sur la procédure de mise à niveau des contrôleurs de domaine Windows 2000 vers Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379).

Pour plus d'informations sur le transfert du rôle de maître d'infrastructure d'un contrôleur de domaine à un autre, consultez les articles suivants de la Base de connaissances Microsoft :

  • Pour Microsoft Windows Server™ 2003, consultez l'article 324801 sur la procédure d'affichage et de transfert des rôles FSMO dans Windows Server 2003 (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801)

  • Pour Microsoft Windows 2000 Server, consultez l'article 255690 sur la procédure d'affichage et de transfert des rôles FSMO dans l'interface utilisateur graphique (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690).


Le contrôleur de schéma n'utilise pas Windows Server 2003 Service Pack 1 ou une version ultérieure
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le contrôleur de domaine attribué au rôle de contrôleur de schéma du service d'annuaire Active Directory, également baptisé FSMO (flexible single master operations, opérations à maître unique flottant), n'utilise pas Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou une version ultérieure.

Le programme d'installation d'Exchange 2007 nécessite que le contrôleur de domaine qui fait office de FSMO du schéma utilise Windows Server 2003 SP1 ou une version ultérieure.

Le FSMO contrôle toutes les mises à jour et les modifications du schéma Active Directory.

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Mettez à niveau le contrôleur de domaine FSMO vers Windows Server 2003 SP1 ou une version ultérieure, puis recommencez l'installation de Microsoft Exchange.

  • Si un contrôleur de domaine FSMO exécute Microsoft Windows Server 2003 Service Pack 1 (SP1) ou version ultérieure dans l'organisation Exchange, exécutez le programme d'installation d'Exchange 2007 avec le paramètre /domaincontroller pointant sur ce contrôleur de domaine FSMO :

    [/DomainController, ou /dc <Nom de domaine complet du contrôleur de domaine>]

    Le paramètre /DomainController permet de spécifier le contrôleur de domaine à utiliser pour lire ou écrire dans Active Directory en cours d'installation. Vous pouvez utiliser NetBIOS ou le format de nom de domaine complet (FQDN).

Pour obtenir le dernier Service Pack de Windows Server 2003, visitez le site TechCenter de Windows Server (http://go.microsoft.com/fwlink/?LinkId=45315).

Pour plus d'informations sur les paramètres du programme d'installation d'Exchange Server 2007, voir la rubrique sur la procédure d'installation d'Exchange 2007 en mode sans assistance (http://go.microsoft.com/fwlink/?LinkId=86476) dans la documentation sur le produit Exchange Server 2007.


Setup Cannot Install Exchange to a Read-Only Domain Controller
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-07-23

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre l'installation car l'ordinateur cible est un contrôleur de domaine en lecture seule (RODC).

Les contrôleurs de domaine en lecture seule sont une fonctionnalité de Windows Server 2008 Active Directory. Il s'agit d'un type d'option d'installation de contrôleur de domaine qui peut être installée sur des sites distants dont les niveaux de sécurité physiques peuvent être plus faibles.

Le programme d'installation Exchange nécessite un accès en écriture à l'ordinateur d'installation cible.

Pour résoudre ce problème, sélectionnez un ordinateur d'installation cible qui n'est pas désigné comme contrôleur de domaine en lecture seule, puis réexécutez le programme d'installation.


Échec du programme d'installation lors de l'installation d'un rôle serveur
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-04-12

Le programme d'installation Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le programme d'installation a échoué lors de l'installation d'un rôle serveur.

L'installation d'Exchange 2007 nécessite qu'un rôle serveur soit correctement réinstallé ou supprimé du processus d'installation avant de pouvoir continuer une autre tâche d'installation.

Pour résoudre ce problème, réinstallez le rôle serveur échoué ou supprimez-le.

Pour réinstaller le rôle serveur en échec pour la ligne de commande

  1. Ouvrez une fenêtre d'invite de commandes et naviguez jusqu'à l'emplacement des fichiers d'installation.

  2. Exécutez la commande suivante :

    Copier le code
    Setup /roles:<Failed Server Role>

    Sélectionnez un ou plusieurs des rôles suivants dans une liste séparée par des virgules :

    ClientAccess (ou CA, ou C)

    EdgeTransport (ou ET, ou E)

    Remarque :
    Le rôle serveur de transport Edge ne peut pas coexister sur le même ordinateur qu'un autre rôle serveur.
    Remarque :
    Vous devez déployer le rôle serveur de transport Edge dans le réseau de périmètre et à l'extérieur de la forêt Active Directory.

    HubTransport (ou HT, ou H)

    Mailbox (ou MB, ou M)

    UnifiedMessaging (ou MU, ou U)

    ManagementTools (ou MT, ou T)

    Remarque :
    En choisissant Outils de gestion, vous installez la console de gestion Exchange, les cmdlets Exchange pour l'environnement de ligne de commandeExchange Management Shell, le fichier d'aide Exchange, l'outil Exchange Best Practices Analyzer Tool et l'Assistant Dépannage Exchange. Si vous installez un autre rôle serveur, les outils de gestion sont installés automatiquement.

    Par exemple, pour ajouter le rôle serveur de transport Hub à un serveur de boîtes aux lettres existant, tapez ce qui suit : %LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install

Remarque :
Si un rôle serveur Exchange Server 2007 avait été installé, l'Assistant Installation est exécuté en mode maintenance. Si aucun rôle serveur Exchange 2007 n'avait été installé, l'Assistant Installation commence à l'endroit où il s'est arrêté.
Pour utiliser l'Assistant Installation d'Exchange Server 2007 en mode maintenance pour réinstaller le rôle serveur en échec

  1. Ouvrez une session sur le serveur sur lequel vous souhaitez réinstaller un rôle serveur.

  2. Ouvrez Panneau de Configuration, puis double-cliquez sur Ajout/Suppression de programmes.

  3. Dans la page Modifier ou Supprimer des programmes, sélectionnez Microsoft Exchange Server, puis cliquez sur Modifier.

  4. Dans l'Assistant Installation Exchange Server 2007, sur la page Mode de maintenance d'Exchange, cliquez sur Suivant.

  5. Dans la page Sélection des rôles serveur, activez les cases à cocher des rôles serveur que vous voulez installer, puis cliquez sur Suivant.

    Remarque :
    Le rôle serveur de transport Edge ne peut pas coexister sur le même ordinateur qu'un autre rôle serveur.
    Remarque :
    Vous devez déployer le rôle serveur de transport Edge dans le réseau de périmètre et à l'extérieur de la forêt Active Directory.
    Remarque :
    En sélectionnant Outils de gestion, vous installez la console de gestion Exchange, les cmdlets Exchange pour l'environnement de ligne de commande Exchange Management Shell et le fichier d'aide d'Exchange. Les outils de gestion sont installés automatiquement si vous installez un autre rôle serveur.

  6. Si vous avez sélectionné Rôle de transport Hub et si vous installez Exchange 2007 dans une forêt disposant d'une organisation Exchange Server 2003 ou Exchange 2000 Server existante, dans la page Paramètres du flux de messagerie, sélectionnez un serveur de tête de pont dans l'organisation existante membre du groupe de routage Exchange 2003 ou Exchange 2000 dans lequel vous voulez créer un connecteur de groupe de routage.

  7. Dans la page Tests de préparation, affichez l'état pour déterminer si les contrôles préalables de l'organisation et du rôle serveur ont été accomplis avec succès. Si c'est le cas, cliquez sur Installer pour installer Exchange 2007.

  8. Dans la page Achèvement, cliquez sur Terminer.
Pour utiliser l'Assistant Installation d'Exchange Server 2007 pour réinstaller le rôle serveur en échec si aucun rôle serveur n'avait été installé

  1. Suivez les étapes de la rubrique sur l'installation personnalisée à l'aide du programme d'installation d'Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=86648) dans la documentation sur le produit Exchange Server 2007.
Pour supprimer le rôle serveur qui a échoué

  1. Suivez les étapes de la rubrique sur la procédure de suppression des rôles serveur Exchange 2007 Server (http://go.microsoft.com/fwlink/?LinkId=86649) dans la documentation sur le produit Exchange Server 2007.

Pour plus d'informations

Pour plus d'informations sur la procédure d'installation d'Exchange 2007 en mode sans assistance, voir la rubrique sur la procédure d'installation d'Exchange 2007 en mode sans assistance (http://go.microsoft.com/fwlink/?LinkId=86476).


Ce serveur est la source pour un connecteur de groupe de routage
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative de supprimer le rôle serveur de transport Hub a échoué. L'ordinateur local est la source pour un ou plusieurs connecteurs de groupe de routage dans l'organisation Exchange.

Un connecteur de groupe de routage est utilisé pour échanger des messages entre des serveurs de transport Hub Exchange et des serveurs têtes de pont Exchange Server 2003 ou Exchange 2000 Server. Lorsqu'Exchange Server 2007 est installé dans une organisation Exchange Server 2003 et Exchange 2000 Server existante, le connecteur de groupe de routage requis est créé pendant l'installation.

Le programme d'installation d'Exchange 2007 nécessite que tous les connecteurs de groupe de routage pour une organisation Exchange soient déplacés ou supprimés du serveur de transport Hub avant de pouvoir supprimer le rôle serveur.

Pour résoudre ce problème, déplacez ou supprimez tous les connecteurs de groupe de routage de l'ordinateur local puis réexécutez le programme d'installation.

Pour déplacer le connecteur de groupe de routage à l'aide d'Exchange Management Shell

  1. La cmdlet Set-RoutingGroupConnector permet de modifier les propriétés d'un connecteur de groupe de routage existant entre un groupe de routage Microsoft Exchange Server 2007 et un groupe de routage Exchange Server 2003 ou Exchange 2000 Server.

  2. Cet exemple utilise la cmdlet Set-RoutingGroupConnector pour modifier la source d'un connecteur de groupe de routage.
Copier le code
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 Pour supprimer le connecteur de groupe de routage à l'aide d'Exchange Management Shell

  1. La cmdlet Remove-RoutingGroupConnector permet de supprimer un connecteur de groupe de routage entre un groupe de routage Microsoft Exchange Server 2007 et un groupe de routage Exchange Server 2003 ou Exchange 2000 Server.

  2. L'exemple suivant montre l'utilisation de la cmdlet Remove-RoutingGroupConnector pour supprimer le connecteur de groupe de routage spécifié.
Copier le code
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

Pour plus d'informations sur la modification ou la suppression de connecteurs de groupe de routage, voir les rubriques suivantes dans la documentation sur le produit Exchange Server 2007 :

  • cmdlet Set-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86659).

  • cmdlet Remove-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86660).


Ce serveur est la source pour un connecteur d'envoi
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative de supprimer le rôle serveur de transport Hub a échoué. L'ordinateur local est la source pour un ou plusieurs connecteurs d'envoi dans l'organisation Exchange.

Un connecteur d'envoi constitue une passerelle logique via laquelle les messages sortants sont envoyés.

Le programme d'installation d'Exchange 2007 nécessite que tous les connecteurs d'envoi pour une organisation Exchange soient déplacés ou supprimés du serveur de transport Hub avant de pouvoir supprimer le rôle serveur.

Pour résoudre ce problème, déplacez ou supprimez tous les connecteurs d'envoi de l'ordinateur local puis réexécutez le programme d'installation.

Pour plus d'informations sur la modification ou la suppression de connecteurs d'envoi, voir les rubriques suivantes dans la documentation sur le produit Exchange Server 2007 :

  • Procédure de suppression d'un connecteur d'envoi (http://go.microsoft.com/fwlink/?LinkId=86655).

  • Procédure de modification de la configuration d'un connecteur d'envoi (http://go.microsoft.com/fwlink/?LinkId=86656).


Modèle d'organisation Exchange simple trouvé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-18

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer le nombre de boîtes aux lettres sur le serveur. Chaque objet de banque de boîtes aux lettres (classe msExchPrivateMDB) possède un attribut à valeurs multiples homeMDBBL qui répertorie toutes les boîtes aux lettres de la banque. Exchange Server Analyzer compte ces valeurs pour obtenir le nombre total de boîtes aux lettres sur le serveur.

Exchange Server Analyzer interroge également Active Directory pour déterminer le nombre de sites Active Directory qui contiennent des serveurs Exchange. En outre, Exchange Server Analyzer interroge Active Directory pour déterminer le nombre de serveurs qui exécutent Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003. Enfin, Exchange Server Analyzer interroge l'objet WMI (Windows® Management Instrumentation) Microsoft Win32_Service pour déterminer si le service de cluster Windows est présent et en cours d'exécution.

Exchange Server Analyzer identifie l'organisation Exchange comme un organisation Exchange simple si les conditions suivantes sont vraies :

  • Le nombre total de boîtes aux lettres de l'organisation est inférieur à 1 000.

  • Les serveurs Exchange ne sont installés que sur un site Active Directory.

  • Moins de 3 ordinateurs exécutent Exchange 2000 ou Exchange 2003.

  • Aucun serveur Exchange en cluster n'est déployé.

Parmi les quatre modèles d'organisation définis pour Microsoft Exchange Server 2007, l'organisation Exchange simple représente la topologie la plus basique dans laquelle Exchange 2007 peut être déployé. Elle contient :

  • un serveur Exchange unique qui offre tous les services Exchange et stocke toutes les données Exchange de l'ensemble de l'organisation ou

  • plusieurs serveurs Exchange dans une topologie qui comprend des serveurs d'annuaire redondants et un serveur de transport Edge dans un réseau de périmètre.

Pour passer d'une organisation Exchange simple à Exchange 2007

  1. Voir la documentation en ligne du produit Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Développez les sections sur la planification et l'architecture, la planification de votre déploiement, puis la planification d'une organisation Exchange simple.


Le protocole SMTP est actuellement installé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-01-22

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le service SMTP (Simple Mail Transfer Protocol) de Microsoft Windows Server™ 2003 est installé sur cet ordinateur.

Le programme d'installation de Microsoft Exchange nécessite que le service SMTP ne soit pas installé sur les serveurs utilisés pour Exchange 2007.

Pour résoudre ce problème, désinstallez le service SMTP, puis exécutez de nouveau le programme d'installation de Microsoft Exchange.

Désinstallation du service SMTP à l'aide de la fonction Ajouter ou supprimer des composants Windows du Panneau de configuration :

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

  3. Cliquez sur Ajouter ou supprimer des composants Windows.

  4. Dans la liste Composants, activez la case à cocher Serveur d'applications, puis cliquez sur Détails.

  5. Sélectionnez Gestionnaire des services IIS, puis cliquez sur Détails.

  6. Sélectionnez Service SMPT, puis cliquez pour désactiver la case à cocher.

  7. Cliquez sur OK à deux reprises pour revenir à la liste Composants, puis cliquez sur Suivant.

  8. Cliquez sur Terminer lorsque le service SMTP est désinstallé.


Le site ne peut pas prendre en charge les serveurs Exchange 2007
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-11

L'outil Microsoft® Exchange Server Analyzer Tool affichait cet avertissement car certains sites de la forêt du service d'annuaire Active Directory ne disposent pas d'au moins un serveur de catalogue global exécuté sous Microsoft Windows Server™ 2003 Service Pack 1 (SP1) ou une version ultérieure.

Le programme d'installation de Microsoft Exchange Server 2007 nécessite que chaque site Active Directory héberge un serveur exécutant Exchange 2007 pour disposer d'au moins un serveur de catalogue global exécuté sous Windows Server 2003 SP1 ou une version ultérieure.

Pour résoudre ce problème, mettez à niveau au moins un serveur de catalogue global dans chaque site Active Directory vers Windows Server 2003 SP1 ou une version ultérieure.

Pour plus d'informations sur la procédure de mise à niveau vers Windows Server 2003, voir l'article 810613 de la Base de connaissances Microsoft sur les chemins d'accès pris en charge pour la mise à niveau vers Windows Server 2003 ou Windows Small Business Server 2003 (http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613).

Pour obtenir le dernier Service Pack de Windows Server 2003, visitez le site TechCenter de Windows Server (http://go.microsoft.com/fwlink/?LinkId=45315).


Modèle d'organisation Exchange standard trouvé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-08-10

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour déterminer :

  • le nombre de boîtes aux lettres dans l'organisation ;

  • le nombre de groupes de routage dans l'organisation ;

  • le nombre de sites Active Directory dans l'organisation ;

  • le nombre de forêts Active Directory dans l'organisation ;

  • si Microsoft Identity Integration Server (MIIS) est installé.

La quantité retournée pour chaque élément détermine si le modèle d'organisation Exchange est simple, standard, volumineux ou complexe. Toute organisation qui n'est pas identifiée comme simple, volumineuse ou complexe est automatique classée comme organisation Exchange standard.

Parmi les quatre modèles d'organisation définis pour Microsoft Exchange Server 2007, l'organisation Exchange standard représente la topologie la plus courante dans laquelle Exchange 2007 est déployé. Comme le service de messagerie doit évoluer au-delà des limites des ressources d'un seul ordinateur, la répartition des services Exchange 2007 sur plusieurs ordinateurs constitue la division topologique suivante : l'organisation Exchange standard. Celle-ci repose sur l'organisation Exchange simple et le déploiement de plusieurs ordinateurs exécutant Exchange.

Pour passer d'une organisation Exchange standard à Exchange 2007

  1. Voir la documentation en ligne du produit Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=69434).

  2. Développez les sections sur la planification et l'architecture, la planification de votre déploiement, puis la planification d'une organisation Exchange standard.


Les adresses IP statiques sont recommandées dans un cluster
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

Le programme d'installation de Microsoft® Exchange Server 2007 affiche cet avertissement car au moins une interface réseau est configurée de manière à utiliser le protocole DHCP (Dynamic Host Configuration Protocol).

Il est recommandé d'employer des adresses IP statiques pour les interfaces réseau qui gèrent les connexions des clients et les liens de pulsation dans un cluster de serveurs Microsoft Windows. L'utilisation d'une configuration dynamique via DHCP n'est pas recommandée, l'échec du renouvellement d'un bail DHCP a pu en effet entraîner l'interruption des opérations de cluster.

Pour résoudre cet avertissement, configurez chaque interface réseau qui gère des connexions des clients ou des liens de pulsation de manière à ce qu'elle utilise une adresse IP statique.

Pour configurer une adresse IP statique pour une connexion réseau

  1. Dans le menu Démarrer, cliquez sur Paramètres, puis sur Paramètres réseau.

  2. Cliquez avec le bouton droit sur la connexion à configurer, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, dans Cette connexion utilise les éléments suivants, cliquez sur Protocole Internet (TCP/IP), puis sur Propriétés.

  4. Cliquez sur Utiliser l'adresse IP suivante puis, dans Adresse IP, tapez l'adresse IP.

  5. Cliquez sur OK à deux reprises pour terminer.

Pour plus d'informations sur la configuration réseau optimale des clusters Windows Server, voir le livre blanc sur les clusters de serveurs et la configuration réseau recommandée pour Windows 2000 et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=34304).

Pour plus d'informations sur la configuration correcte du réseau de pulsation de cluster, voir l'article 258750 de la Base de connaissances Microsoft sur la configuration de carte réseau privé recommandée sur un cluster de serveurs (http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750).


Le chemin d'accès du stockage pour un cluster à copie unique doit être un disque en cluster
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le chemin de stockage d'un cluster à copie unique doit être un disque en cluster.

Dans Exchange Server 2007, un cluster à copie unique est une solution de cluster qui utilise une copie unique d'un groupe de stockage pour le stockage qui est partagé entre les nœuds du cluster.

Pour résoudre ce problème, spécifiez un disque en cluster pour le chemin de données, puis réexécutez le programme d'installation d'Exchange 2007.

Pour plus d'informations sur les clusters en copie unique, voir la rubrique sur l'installation d'un cluster en copie unique (http://go.microsoft.com/fwlink/?LinkId=76162) dans la documentation sur le produit Exchange Server 2007.


Le format d'adressage SMTP n'est pas pris en charge
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la stratégie de destinataire spécifiée utilise un format d'adresse SMTP (Simple Mail Transfer Protocol) non pris en charge.

L'installation d'Exchange 2007 nécessite que toutes les adresses SMTP utilisées pour les stratégies d'adresses électroniques ne contiennent pas de litéraux d'adresse IP, par exemple : utilisateur@[10.10.1.1].

Pour résoudre ce problème, modifiez la valeur de l'adresse SMTP dans la stratégie de destinataire afin qu'elle ne contienne pas de litéral d'adresse IP. Remplacez les crochets ([]) et les chiffres (10.10.1.1) du litéral de l'adresse IP par le format DNS, par exemple : user@contoso.com, puis exécutez à nouveau le programme d'installation d'Exchange.

Pour plus d'informations sur la gestion des stratégies de destinataire dans Exchange Server 2007, voir la rubrique sur la gestion des stratégies d'adresse électronique (http://go.microsoft.com/fwlink/?LinkId=86653).


Lien de sites SMTP trouvé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-12-07

L'outil Microsoft® Exchange Server Analyzer Tool affiche cet avertissement s'il trouve des liens de sites SMTP (Simple Mail Transfer Protocol) dans le service d'annuaire Active Directory®.

Le routage de Microsoft Exchange Server 2007 ignore les sites Active Directory référencés par des liens de sites SMTP. Si Exchange 2007 est installé sur des sites qui ne sont référencés que par un lien de sites SMTP, des erreurs de routage se produisent.

Pour résoudre ce problème, remplacez les liens de sites SMTP par des liens de sites IP.

Pour plus d'informations sur les liens de site IP Active Directory, consultez la page « Planification de l'utilisation de sites Active Directory pour le routage de messages » (http://go.microsoft.com/fwlink/?LinkId=71803).


La définition du lecteur du groupe de stockage est manquante
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-05-15

Le programme d'installation de Microsoft® Exchange Server 2007 Disaster Recovery ne peut pas poursuivre son exécution car il ne peut pas accéder à la définition de lecteur de la base de données du groupe de stockage utilisée lors de l'installation précédente sur ce serveur.

Le programme d'installation de Microsoft Exchange Disaster Recovery nécessite que les mêmes définitions de lecteur de la base de données du groupe de stockage que celles utilisées précédemment pour ce serveur soient disponibles pendant la restauration.

Pour résoudre ce problème, configurez les lecteurs de manière à correspondre à la configuration de lecteurs logiques d'origine, puis recommencez l'installation de Microsoft Exchange Disaster Recovery.

Attribution ou modification d'une lettre de lecteur

  1. Ouvrez Gestion de l'ordinateur (Local).

  2. Dans l'arborescence de la console, cliquez sur Gestion de l'ordinateur (Local), sur Stockage, puis sur Gestion des disques.

  3. Cliquez avec le bouton droit sur une partition, un lecteur logique ou un volume, puis cliquez sur Modifier la lettre de lecteur et les chemins d'accès.

  4. Utilisez l'une des procédures suivantes :

    • Pour attribuer une lettre de lecteur, cliquez sur Ajouter, sur la lettre à utiliser, puis sur OK.

    • Pour modifier une lettre de lecteur, cliquez sur celle-ci, sur Modifier, sur la lettre à utiliser, puis sur OK.

Pour plus d'informations sur la procédure d'attribution de lettres de lecteur, voir la rubrique sur l'attribution, la modification ou la suppression d'une lettre de lecteur (http://go.microsoft.com/fwlink/?LinkId=66764).


Non-concordance du chemin d'installation cible
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car le chemin cible des fichiers binaires d'Exchange ne correspond pas au chemin d'installation existant d'Exchange dans d'autres nœuds de cluster.

Exchange Server 2007 nécessite que des nœuds du même cluster aient des chemins d'installation cibles cohérents pour les fichiers binaires d'Exchange.

Pour résoudre ce problème, utilisez un chemin d'installation cible pour les fichiers binaires d'Exchange qui soit cohérent pour tous les nœuds du cluster.

Pour plus d'informations sur les installations de disponibilité élevée pour Exchange Server 2007, voir la rubrique sur la disponibilité élevée (http://go.microsoft.com/fwlink/?linkid=68190) dans la documentation sur le produit Exchange Server 2007.


Le chemin d'accès de destination est compressé
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-06

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car le chemin d'accès du dossier de destination de l'installation de Microsoft Exchange est compressé.

Le programme d'installation de Microsoft Exchange nécessite que le premier dossier du chemin d'accès de destination de l'installation ne soit pas compressé. Par défaut, le premier dossier du chemin d'accès de destination de l'installation est C:\Program Files.

Pour résoudre ce problème, désactivez la compression du premier dossier du chemin d'accès de destination, puis exécutez de nouveau le programme d'installation d'Exchange 2007.

Pour désactiver la compression du chemin d'accès de destination :

  1. Dans le Poste de travail ou l'Explorateur Windows, cliquez avec le bouton droit sur le dossier à décompresser.

  2. Cliquez sur Propriétés pour afficher la ???boîte de dialogue Propriétés.

  3. Sous l'onglet Général, cliquez sur Avancé.

  4. Dans la boîte de dialogue Attributs avancés, désactivez la case à cocher Compresser le contenu pour minimiser l'espace disque nécessaire, puis cliquez sur OK.

  5. Dans la ???boîte de dialogue Propriétés, cliquez sur OK.

  6. Lorsque l'état de compression du dossier est modifié, activez l'option Appliquer les modifications à ce dossier et à tous les sous-dossiers et fichiers de la ???boîte de dialogue Confirmation des modifications d'attributs.

  7. Cliquez sur OK quand vous avez terminé.


Plusieurs interfaces sont recommandées dans un cluster
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

Le programme d'installation de Microsoft® Exchange Server 2007 affiche cet avertissement car l'environnement de cluster actuel de Microsoft Windows ne comporte qu'une seule interface réseau définie.

Il est recommandé de mettre en œuvre au moins une interface réseau pour le réseau public (connexion des clients) et une autre pour le réseau privé (administration/pulsation) pour éviter la présence d'un point de défaillance unique.

Pour résoudre cet avertissement, mettez en œuvre au moins une interface réseau supplémentaire pour le cluster Microsoft Windows.

Pour plus d'informations sur la configuration réseau optimale des clusters de serveurs Windows, voir le livre blanc sur les clusters de serveurs et la configuration réseau recommandée pour Windows 2000 et Windows Server 2003 (http://go.microsoft.com/fwlink/?linkid=34304).


Impossible de se connecter au service Registre distant
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-01-23

L'exécution du programme d'installation de Microsoft® Exchange Server 2007 ne peut pas se poursuivre car le Registre de l'ordinateur local est inaccessible.

L'installation d'Exchange 2007 nécessite un accès au Registre local pour extraire divers paramètres.

L'installation d'Exchange tente d'utiliser le DNS (Domain Name System) pour obtenir le nom de domaine complet (FQDN) de l'ordinateur local pour accéder au Registre.

Soit l'installation n'a pas pu extraire le FQDN du DNS en raison d'une erreur réseau, soit il n'a pas pu accéder au Registre.

Pour résoudre ce problème, vérifiez que le service Registre distant est en cours d'exécution sur l'ordinateur local et que le partage de fichiers et d'imprimantes est activé sur la première carte réseau dans l'ordre de liaison, puis exécutez de nouveau l'installation d'Exchange.

Vérification de l'exécution du service Registre distant

  1. Cliquez sur Démarrer, pointez sur Paramètres, sur Panneau de configuration, sur Outils d'administration, puis double-cliquez sur Services.

  2. Vérifiez que l'état du service Registre distant est Démarré.
Activation du partage de fichiers et d'imprimantes sur la carte réseau principale

  1. Cliquez sur Démarrer, pointez sur Paramètres, sur Panneau de configuration, sur Connexion réseau, puis sur Connexion au réseau local.

  2. Vérifiez que l'option Partage de fichiers et d'imprimantes pour les réseaux Microsoft est activée.
Remarque :
S'il s'agit d'un serveur en cluster, vous devez vérifier que le service Registre distant s'exécute sur tous les noeuds du cluster et que l'option Partage de fichiers et d'imprimantes pour réseaux Microsoft est activée pour la carte réseau figurant en première position dans l'ordre de liaison.


Mise à jour requise du codec voix Windows Media Audio
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-07-13

L'installation de Microsoft® Exchange Server 2007 ne peut pas continuer parce que le codec voix Microsoft Windows Media Audio n'est pas installé ou qu'une version plus récente du codec voix Windows Media Audio est disponible.

L'installation d'Exchange 2007 exige d'installer la version la plus récente du codec voix Windows Media Audio sur le serveur. Le codec voix Windows Media Audio est nécessaire pour prendre en charge le rôle Unified Messaging d'Exchange Server 2007.

Pour résoudre ce problème, installez la version la plus récente du codec voix Windows Media Audio depuis http://go.microsoft.com/fwlink/?LinkId=67407, puis recommencez l'installation d'Exchange 2007.


Mise à jour requise de Windows Media Encoder
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-07-13

L'installation de Microsoft® Exchange Server 2007 ne peut pas continuer parce que Microsoft Windows Media Encoder n'est pas installé ou qu'une version plus récente de Windows Media Encoder est disponible.

L'installation d'Exchange 2007 exige d'installer la version la plus récente de Windows Media Encoder sur le serveur. Windows Media Encoder est nécessaire pour prendre en charge le rôle Unified Messaging Server d'Exchange Server 2007.

Pour résoudre ce problème, installez la version la plus récente dee Windows Media Encoder depuis http://go.microsoft.com/fwlink/?LinkId=67406, puis recommencez l'installation d'Exchange 2007.


Le service de publication sur le World Wide Web est désactivé ou manquant
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-02-14

Le programme d'installation de Microsoft® Exchange Server 2007 ne peut pas poursuivre son exécution car sa tentative d'installation du rôle Mailbox Server ou Client Access a détecté que le service de publication sur le World Wide Web est désactivé ou n'est pas installé sur cet ordinateur.

L'installation d'Exchange 2007 nécessite que le service de publication sur le World Wide Web soit installé sur l'ordinateur sur lequel vous installez Microsoft Exchange et défini sur une autre valeur que désactivé.

Pour résoudre ce problème, vérifiez que le service de publication sur le World Wide Web est installé et n'est pas désactivé sur l'ordinateur local, puis recommencez l'installation de Microsoft Exchange.

Pour vérifier que le service de publication sur le World Wide Web est installé et n'est pas désactivé

  1. Cliquez avec le bouton droit sur Poste de travail sur le Bureau, puis cliquez sur Gérer.

  2. Développez le nœud Services et applications, puis cliquez sur le nœud Services.

  3. Dans le volet droit, recherchez le Service de publication sur le World Wide Web.

    Si le Service de publication sur le World Wide Web n'est pas affiché dans la liste des services installés, exécutez la procédure suivante pour l'installer.

  4. Si le Service de publication sur le World Wide Web est affiché mais que son état n'est pas Démarré, exécutez la procédure suivante pour le démarrer.

  5. Cliquez avec le bouton droit sur Service de publication sur le World Wide Web, puis cliquez sur Propriétés.

  6. Vérifiez que le type de démarrage est Automatique et que l'état du service est défini sur Démarré.

  7. Cliquez sur Appliquer, puis sur OK.
Pour installer le service de publication sur le World Wide Web

  1. Cliquez sur le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter ou supprimer des composants Windows.

  3. Dans la liste Composants, activez la case à cocher Serveur d'applications, puis cliquez sur Détails.

  4. Sélectionnez Gestionnaire des services IIS, puis cliquez sur Détails.

  5. Sélectionnez Service World Wide Web, puis activez la case à cocher.

  6. Cliquez sur OK à deux reprises pour revenir à la liste Composants, puis cliquez sur Suivant.

  7. Cliquez sur Terminer lorsque le service IIS est installé.


Désinstallation de modules linguistiques de messagerie unifiée
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-16

Le programme d'installation de Microsoft Exchange Server 2007 ne peut pas poursuivre son exécution car la mise à niveau du rôle serveur de messagerie unifiée a échoué.

L'installation d'Exchange nécessite que tous les modules linguistiques du rôle serveur de messagerie unifiée, excepté le module linguistique Anglais des États-Unis, soient désinstallés avant de pouvoir poursuivre la mise à niveau du rôle serveur de messagerie unifiée.

Les modules linguistiques de messagerie unifiée inclus dans Exchange 2007 contiennent des messages d'assistance vocaux préenregistrés et une aide de conversion de texte par synthèse vocale pour une langue donnée.

Les modules linguistiques de messagerie unifiée d'Exchange 2007 permettent aux appelants et aux utilisateurs d'Outlook Voice Access d'interagir avec le système de messagerie unifiée dans plusieurs langues.

Les modules linguistiques existants autres que celui pour l'Anglais des États-Unis doivent être désinstallés afin de pouvoir installer de nouveaux modules linguistiques.

Pour résoudre ce problème, désinstallez tous les modules linguistiques du rôle serveur de messagerie unifiée, excepté le module linguistique Anglais des États-Unis, et réexécutez le programme d'installation d'Exchange 2007.

Pour plus d'informations sur la désinstallation des modules linguistiques du rôle serveur de messagerie unifiée, voir la rubrique sur la procédure de suppression d'un module linguistique de messagerie unifiée d'un serveur de messagerie unifiée dans la documentation sur le produit Exchange 2007.


Mise à jour nécessaire pour la récupération d'urgence
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2007-03-27

La récupération d'urgence de Microsoft Exchange Server 2007 ne peut pas poursuivre car une version ultérieure d'Exchange Server 2007 avait été utilisée pour l'installation d'Exchange Server sur cet ordinateur.

La récupération d'urgence de Microsoft Exchange nécessite que la version d'Exchange Server 2007 utilisée pour la récupération d'Exchange Server soit égale ou supérieure à celle utilisée pour l'installation d'Exchange Server.

Pour résoudre ce problème, démarrez la récupération d'urgence d'Exchange Server 2007 à partir d'une version d'Exchange Server 2007 égale ou supérieure à celle utilisée pour l'installation d'Exchange Server.


Connecteur X400 trouvé dans la topologie
Microsoft Exchange Server Analyzer - Articles > État de préparation d'Exchange Server 2007 >

Dernière rubrique modifiée : 2006-06-05

L'outil Microsoft® Exchange Server Analyzer Tool interroge le service d'annuaire Active Directory® pour les connecteurs X.400. Si Exchange Server Analyzer trouve des connecteurs X.400 dans l'orgnisation Microsoft Exchange, il affiche un avertissement. Cet avertissement indique que le connecteur X.400, un protocole utilisé; pour transporter des messages entre d'anciens systèmes de messagerie, n'est pas pris en charge dans Microsoft Exchange Server 2007.

Dans Microsoft Exchange 2000 Server et Microsoft Exchange Server 2003, le protocole par dérfaut était SMTP (Simple Mail Transfer Protocol). Bien que les connecteurs X.400 soient pris en charge dans Exchange 2000 et Exchange 2003, ils ne le sont pas dans Exchange 2007 car l'utilisation de connecteurs X.400 a d cliné au fil des ans. Si vous avez besoin d'une prise en charge du protocole X.400, il est recommandé de conserver un serveur Exchange 2000 ou Exchange 2003. Sinon, le connecteur X.400 peut être remplacé par SMTP.

Pour plus d'informations sur l'architecture de transport X.400 dans Exchange 2003, voir la rubrique sur le routage d'Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=65578).

Pour plus d'informations sur la procédure d'implémentation du connecteur X.400 dans Exchange 2003, voir la rubrique sur l'implémentation du connecteur X.400 et la nécessité de l'utiliser avec Exchange Server 2003 (http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html)

Remarque :
Les informations du site Web tiers fournies dans cette rubrique permettent de vous aider à trouver les informations techniques dont vous avez besoin. Les URL sont susceptibles d'être modifiées sans préavis.


Informations juridiques

Dernière rubrique modifiée : 2007-04-06

Les informations de ce document, y compris les URL et autres références de sites Web Internet, sont susceptibles d'être modifiées sans préavis. Sauf mention contraire, les noms de sociétés, d'organisations, de produits, de domaines, de personnes, les adresses de messagerie, les logos, les emplacements et les événements mentionnés dans les exemples sont fictifs. Toute ressemblance avec des noms ou des événements réels est purement fortuite et involontaire. Le respect des lois en matière de droits d'auteur est de la responsabilité de l'utilisateur. Sans limitation des droits d'auteur, aucune partie de ce document ne peut être reproduite, stockée ou introduite dans un système de récupération d'informations, ni transmise à quelque fin, sous quelque forme ou par quelque moyen que ce soit (électronique, mécanique, photocopie, enregistrement ou autre) sans l'autorisation exprès écrite de Microsoft Corporation.

Microsoft peut détenir des brevets, avoir déposé des demandes d'enregistrement de brevets ou être titulaire de marques, droits d'auteur ou autres droits de propriété intellectuelle portant sur l'objet de ce document. Sauf stipulation expresse contraire dans un contrat de licence écrit de Microsoft, la fourniture de ce document n'a pas pour effet de vous concéder une licence sur ces brevets, marques, droits d'auteur ou autres droits de propriété intellectuelle.

© 2004-2006 Microsoft Corporation. Tous droits réservés.

Microsoft, Active Directory, ActiveSync, ActiveX, MSDN, Outlook, SharePoint, Visual C++, Win32, Windows, Windows NT, Windows Server et Windows Server System sont soit des marques de Microsoft Corporation, soit des marques déposées de Microsoft Corporation, aux États-Unis d'Amérique et/ou dans d'autres pays.

Les noms de sociétés et de produits réels mentionnés ici peuvent être des marques de leurs propriétaires respectifs.