Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool

Ultima modifica: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer Tool è uno strumento di diagnostica in grado di eseguire le seguenti funzioni:

  • Raccogliere informazioni da un'organizzazione di Microsoft Exchange Server.

  • Eseguire test specifici sull'organizzazione di Exchange Server.

  • Compilare rapporti sui risultati dei test.

È possibile utilizzare Exchange Server Best Practices Analyzer per eseguire le seguenti attività:

  • Eseguire controlli fattivi per verificare che la configurazione sia impostata in base ai valori consigliati.

  • Segnalare tutte le impostazioni diverse dalle impostazioni predefinite.

  • Compilare rapporti sulle modifiche recenti apportate nell'organizzazione di Exchange Server. Questa funzionalità consente di diagnosticare i problemi provocati dalle modifiche nell'organizzazione di Exchange Server.

  • Identificare l'origine dei problemi in organizzazioni di Exchange Server danneggiate.

  • Confrontare un set di server con una configurazione di base e segnalare tutte le differenze riscontrate.

Nota:
Le modifiche recenti possono essere segnalate solo per gli oggetti di configurazione che includono la proprietà ultima modifica.

Per determinare le informazioni da raccogliere dall'organizzazione di Exchange Server viene utilizzato un file di configurazione. Viene eseguito un confronto tra i dati raccolti e un set di regole predefinite per le impostazioni e le configurazioni di Exchange Server. Quindi vengono segnalati eventuali problemi.

Per ciascun problema vengono forniti tre tipi di informazioni:

  • Viene segnalato ciò che è stato rilevato durante l'analisi dell'organizzazione di Exchange Server.

  • Viene fornita una configurazione consigliata.

  • Vengono forniti i collegamenti a ulteriori informazioni sui problemi e sugli argomenti correlati.

Gli eventuali commenti e suggerimenti su Exchange Server Best Practices Analyzer possono essere inviati in diversi modi:

  • Newsgroup pubblico di Microsoft I membri del team di sviluppo di Exchange Server Best Practices Analyzer Tool controllano frequentemente il newsgroup microsoft.public.exchange.tools all'indirizzo news.microsoft.com. Per ulteriori informazioni su come partecipare a questo e ad altri newsgroup di Microsoft, consultare il sito Web di Microsoft® Exchange Server Best Practices Analyzer Tool (http://go.microsoft.com/fwlink/?LinkId=33938) e il sito Web dei newsgroup del Supporto Tecnico Clienti Microsoft (http://go.microsoft.com/fwlink/?LinkId=50219).

  • Feedback della documentazione di Exchange Server Best Practices Analyzer. Se si desidera inviare commenti, domande o suggerimenti su qualsiasi documentazione o articolo incluso in Exchange Server Best Practices Analyzer, scrivere all'indirizzo exbpadoc@microsoft.com.


Installazione di Microsoft Exchange Server Best Practices Analyzer Tool

Installazione di Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2006-02-08

Per installare Microsoft® Exchange Server Analyzer Tool, eseguire il file del programma di installazione Microsoft, ExBPA.msi, sul computer sul quale verrà eseguito lo strumento. Il programma di installazione creerà una directory denominata ExBPA, posizionata per impostazione predefinita in <unità di sistema>\Programmi\ e copierà i file necessari in questa nuova directory.

Selezionare un computer per l'installazione

Il computer consigliato per l'installazione di Exchange Server Analyzer è una stazione di gestione dedicata. Per ulteriori informazioni sull'installazione e l'utilizzo di una stazione di gestione dedicata, consultare il Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=21769.

Per installare lo strumento in un computer esterno all'organizzazione di Exchange è necessario impostare esplicitamente i nomi utente e le password per l'accesso al servizio directory di Active Directory® e ai server di Exchange. Per ulteriori informazioni sull'impostazione delle credenziali dell'account utente nel quale verrà eseguita l'analisi, consultare Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool.

È inoltre possibile installare lo strumento in un server di Exchange. Lo strumento può essere eseguito su un server di Exchange, tuttavia, utilizzerà una grande quantità di risorse di sistema, in particolare CPU e RAM. Si consiglia, pertanto, di installare lo strumento in un computer separato. Se si installa lo strumento in un server di Exchange, si consiglia di eseguire l'analisi esclusivamente di quel server di Exchange.

Ricerca di aggiornamenti

All'avvio, Exchange Server Analyzer verificherà la disponibilità di un nuovo file di regole consigliate sul sito www.microsoft.com. Se disponibile, sarà possibile scaricare la nuova versione del file. È necessario avere effettuato l'accesso sul computer come amministratore per scaricare il file. Se si sceglie di non scaricare il file o se non riuscisse ad accedere a Internet, lo strumento tenterà di utilizzare la copia del file presente sul computer sul quale è in esecuzione.

Nota:
Se viene richiesta l'autenticazione proxy per l'accesso a Internet, lo strumento non sarà in grado di accedere alla nuova versione del file di configurazione da scaricare. Tuttavia è possibile copiare il file manualmente dal sito Web www.microsoft.com sul computer locale.
Per copiare manualmente la nuova versione del file di configurazione

  1. Nella directory nella quale è installato lo strumento, rinominare il file ExBPA.Config.xml esistente.

  2. Passare a http://go.microsoft.com/fwlink/?LinkId=34290 nel browser Web.

  3. Scaricare il pacchetto eseguibile ed estrarre i nuovi file nella directory in cui è installato lo strumento (generalmente C:\Programi\ExBPA).

Vedere anche

Concetti

Effetto sulle prestazioni di Microsoft Exchange Server Best Practices Analyzer Tool
Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool

Altre risorse

Configurazione dell'analisi in Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Prerequisiti per l'esecuzione di Microsoft Exchange Server Best Practices Analyzer Tool
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

I computer nell'organizzazione Exchange devono soddisfare numerosi prerequisiti prima di poter eseguire correttamente Microsoft® Exchange Server Best Practices Analyzer Tool. Se questi requisiti non sono soddisfatti, sarà probabilmente possibile eseguire ugualmente lo strumento, ma potrebbero non essere attive le funzioni complete oppure si potrebbero verificare dei problemi.

Gli argomenti trattati in questa sezione includono le informazioni sulle autorizzazioni richieste per l'esecuzione di Exchange Server Best Practices Analyzer e tutti gli altri prerequisiti che devono essere soddisfatti dalle organizzazioni Exchange e dal computer sul quel viene eseguito lo strumento. L'argomento Altri prerequisiti comprende inoltre un elenco degli ambienti supportati per l'esecuzione dello strumento.

In questa sezione

Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool

Altri prerequisiti di Microsoft Exchange Server Best Practices Analyzer Tool


Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool

Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Prerequisiti per l'esecuzione di Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer Tool può accedere al servizio directory di Active Directory® e ai server di Exchange solo se lo strumento viene eseguito utilizzando credenziali che dispongono di tutte le autorizzazioni necessarie.

Autorizzazioni

Per eseguire correttamente Exchange Server Best Practices Analyzer, è necessario disporre delle seguenti autorizzazioni:

  • Amministratore del dominio o membro del gruppo Builtin\Administrators sul server Active Directory, per elencare le informazioni Active Directory e chiamare i provider Microsoft WMI (Strumentazione gestione Windows®) sul controller del dominio e sui server di catalogo globale.

  • Membro del gruppo Administrators locale sul server di Exchange per chiamare i provider WMI (Strumentazione gestione Windows) e accedere al registro di sistema e al metabase.

  • Delegato almeno ai diritti di sola visualizzazione di Exchange nell'organizzazione Exchange.

Se si accede al computer sul quale verrà eseguito Exchange Server Best Practices Analyzer tramite un account che non dispone di autorizzazioni sufficienti, esistono due possibilità:

  1. Utilizzare il comando runas per aprire una finestra del prompt dei comandi che verrà eseguita tramite un account che dispone di autorizzazioni sufficienti e che avvierà lo strumento da questa finestra. La sintassi per questa operazione è la seguente:

    runas /netonly /user:<dominio>\<nomeutente> exbpa.exe

  2. Impostare le credenziali per gli account che verranno utilizzati nella pagina Connessione a Active Directory dello strumento. Fare clic su Mostra opzioni di accesso avanzate per espandere le opzioni. È possibile immettere due account, uno per la connessione a Active Directory e uno per la connessione ai server di Exchange. Se non si specifica uno di questi account, verrà utilizzato l'account nel quale lo strumento è in esecuzione.

Vedere anche

Concetti

Altri prerequisiti di Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Altri prerequisiti di Microsoft Exchange Server Best Practices Analyzer Tool

Altri prerequisiti di Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Prerequisiti per l'esecuzione di Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2007-05-16

Oltre a eseguire Microsoft® Exchange Server Analyzer Tool con un account che dispone delle autorizzazioni necessarie nel servizio directory di Active Directory® e con un account che dispone delle autorizzazioni necessarie nei server di Exchange, è necessario verificare ulteriori prerequisiti per l'esecuzione corretta dello strumento.

Prerequisiti

Per una corretta esecuzione di Exchange Server Analyzer, devono verificarsi le seguenti condizioni:

  • .NET Framework 1.1 deve essere installato nel computer sul quale verrà eseguito Exchange Server Analyzer.

  • I file comuni di Internet Information Services (IIS) devono essere installati nel computer sul quale verrà eseguito Exchange Server Analyzer, per consentire l'accesso remoto alla metabase.

    Nota:
    Se sono installati Internet Information Services, Amministrazione di Internet Information Services o Gestore di sistema di Exchange, i file comuni di Internet Information Services verranno installati automaticamente.
  • Il computer sul quale verrà eseguito Exchange Server Analyzer deve disporre di almeno 256 megabyte (MB) di memoria RAM (Random Access Memory). Questa quantità di memoria è sufficiente per l'analisi di fino a 50 server di Exchange. Per ogni 50 server aggiuntivi nell'organizzazione di Exchange, saranno necessari ulteriori 256 MB di RAM sul computer utilizzato per l'esecuzione dello strumento. Ad esempio, se nell'organizzazione si trovano tra 50 e 100 server di Exchange, è necessario disporre di 512 MB di RAM sul computer utilizzato per l'esecuzione dello strumento. Se nell'organizzazione si trovano tra 100 e 150 server di Exchange, è necessario disporre di almeno 768 MB di RAM sul computer utilizzato per l'esecuzione dello strumento.

  • Per ciascun server di Exchange nell'organizzazione che si desidera analizzare, è necessario disporre di almeno 2 MB di spazio su disco sul computer che verrà utilizzato per l'esecuzione di Exchange Server Analyzer.

  • È necessario installare Active Directory nella topologia su Microsoft Windows® 2000 Server o Windows Server™ 2003.

  • Almeno un server di Exchange 2003 o Exchange 2000 deve essere installato in Active Directory.

  • Il servizio Registro di sistema remoto (RemoteRegistry) deve essere in esecuzione sul server Active Directory e sui server di Exchange.

  • Il servizio WMI (Strumentazione gestione Windows) (winmgmt) deve essere in esecuzione sul server Active Directory e sui server di Exchange.

  • Il servizio di gestione di Exchange (MSExchangeMGMT) deve essere in esecuzione su tutti i server di Exchange, a partire dalla versione Exchange 2000 Server e successive.

  • È necessario che l'utente che effettua l'accesso ed esegue Exchange Server Analyzer disponga dei diritti di scrittura/lettura per la cartella sulla quale lo strumento viene eseguito.

  • Per raccogliere informazioni sull'adattatore bus host (HBA, Host Bus Adapter), deve essere installato un driver o un servizio remoto compatibile con l'API HBA (come il servizio HBAnywhere Emulex) su tutti di server dai quali si desidera raccogliere informazioni sull'HBA. Inoltre il programma di installazione del Managed Object Format (MOF) dell'API HBA deve essere eseguito sia sul computer su quale verrà eseguito Exchange Server Analyzer sia sul server di destinazione sul quale è installato l'HBA. Se non è installato un driver o un servizio remoto compatibile con l'API HBA, Exchange Server Analyzer verrà eseguito, ma non raccoglierà informazioni sull'HBA.

Ambienti supportati

Exchange Server Analyzer può essere eseguito nei seguenti ambienti:

  • Exchange Server 5.5 su Windows 2000 Server SP3 e versioni successive

Nota:
Il server di Exchange Server 5.5 deve far parte di un'organizzazione di Exchange a modalità mista, rappresentata in Active Directory.
  • Exchange 2000 Server (tutti i Service Pack) su Windows 2000 Server SP3 e versioni successive

Nota:
Né Windows 2000 Server né Exchange 2000 Server supportano provider WMI (Strumentazione gestione Windows) di notevoli dimensioni. L'analisi e la raccolta dei dati potrebbero essere limitate.
  • Exchange 2003 Server (tutti i Service Pack) su Windows 2000 Server SP3 e versioni successive

Nota:
Windows 2000 Server non supporta provider WMI (Strumentazione gestione Windows) di notevoli dimensioni. L'analisi e la raccolta dei dati potrebbero essere limitate.
  • Exchange Server 2003 (tutti i Service Pack) su Windows Server 2003

  • Exchange Server 2007 su Windows Server 2003

Vedere anche

Concetti

Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer Tool effettua l'analisi dei computer presenti nell'organizzazione di Exchange che rientrano nell'ambito selezionato. Questo strumento confronta le impostazioni con quelle consigliate e compila un rapporto con i risultati.

Durante l'analisi, l'indicatore di stato viene aggiornato dinamicamente, visualizzando la percentuale completata dell'analisi completa. La percentuale è basata sulla quantità di dati da raccogliere per il determinato tipo di analisi e per il numero di server compreso nell'ambito dell'analisi.

Il Tempo rimanente previsto viene aggiornato dinamicamente e viene calcolato nuovamente ogni 60 secondi. Exchange Server Best Practices Analyzer è multithread, pertanto è in grado di analizzare più di un server di Exchange contemporaneamente. Lo strumento consente infatti di analizzare fino a 10 gruppi amministrativi e fino a 50 server di Exchange contemporaneamente. I server aggiuntivi vengono inseriti in coda e vengono analizzati una volta completata l'analisi di quelli precedenti.

La finestra Dettagli analisi server visualizza lo stato di ciascun server selezionato per l'analisi. I server possono trovarsi in uno dei seguenti tre stati: In sospeso, In corso o Completato. Se un server si trova nello stato In corso, l'indicatore di stato visualizza la relativa percentuale completa. Quando un server si trova nello stato Completato, un'icona indica se lo strumento è stato in grado di accedere al server. Un segno di spunta verde indica che Exchange Server Best Practices Analyzer è stato in grado di accedere al server, che l'analisi è stata eseguita correttamente e che le soglie di timeout non sono state superate durante l'analisi. Un segno di spunta giallo indica che Exchange Server Best Practices Analyzer è stato in grado di accedere al server, ma che l'operazione di analisi non è riuscita o che le soglie di timeout durante l'analisi sono state superate. Una X rossa indica che Exchange Server Best Practices Analyzer non è stato in grado di accedere al server e che l'analisi del server non è stata eseguita.

Oltre a raccogliere dati dai server di Exchange, lo strumento deve raccogliere dati dal servizio directory di Active Directory®. Il progresso della raccolta dei dati da Active Directory viene visualizzato dall'indicatore di stato e come parte del Tempo rimanente previsto in alto alla pagina, ma non nella finestra Dettagli analisi server. Quindi lo stato generale dell'analisi può essere in corso anche se tutti i server di Exchange sono in stato In sospeso o Completato.

Dopo il completamento dell'analisi di tutti i server selezionati, è possibile aprire la pagina Visualizza rapporto Best Practices.

In questa sezione

Configurazione dell'analisi in Microsoft Exchange Server Best Practices Analyzer Tool

Verifica della rete e delle autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool

Configurazione di Microsoft Exchange Server Best Practices Analyzer Tool


Configurazione dell'analisi in Microsoft Exchange Server Best Practices Analyzer Tool

Configurazione dell'analisi in Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

Quando si avvia Microsoft® Exchange Server Best Practices Analyzer Tool è necessario impostare i parametri per l'analisi. Innanzitutto è necessario scegliere se si desidera scaricare l'aggiornamento più recente delle regole consigliate. Per ulteriori informazioni sulla ricerca di aggiornamenti e sul download del file di aggiornamento più recente, consultare Installazione di Microsoft Exchange Server Best Practices Analyzer Tool.

Successivamente, è necessario selezionare un'azione. Nella pagina di benvenuto scegliere Seleziona le opzioni per una nuova analisi oppure Seleziona un rapporto Best Practices da visualizzare. Se si desidera visualizzare un rapporto esistente, è possibile selezionare un file dall'elenco di file di output archiviati localmente. È inoltre possibile importare un file di output da un'altra posizione invece di selezionarne uno dai file di output archiviati localmente. Dopo aver selezionato un file di output, è possibile visualizzare il rapporto da quel file. Per ulteriori informazioni sui rapporti, consultare Analisi dell'output di Microsoft Exchange Server Best Practices Analyzer Tool.

Se si sceglie Seleziona le opzioni per una nuova analisi, è necessario connettersi al servizio directory di Active Directory® ed eseguire una nuova analisi. Per impostazione predefinita, Exchange Server Best Practices Analyzer rileverà il server Active Directory più vicino. Sarà possibile connettersi a questo server oppure a un server diverso di Active Directory digitando il nome di tale server.

In Exchange Server Best Practices Analyzer viene utilizzato l'account sul quale è in esecuzione lo strumento per impostazione predefinita. Per utilizzare account differenti per accedere ad Active Directory o ai server di Exchange, fare clic su Mostra opzioni di accesso avanzate per espandere le opzioni. La parte superiore della finestra espansa consente l'inserimento di credenziali dell'account per accedere ad Active Directory. La parte inferiore della finestra espansa consente l'inserimento di credenziali dell'account per accedere ai server di Exchange.

Per accedere ad Active Directory e ai server di Exchange, è possibile utilizzare lo stesso account oppure account diversi. Se si lascia vuota la parte superiore o quella inferiore della finestra espansa, l'accesso verrà eseguito con l'account su cui è in esecuzione Exchange Server Best Practices Analyzer.

Vedere anche

Concetti

Installazione di Microsoft Exchange Server Best Practices Analyzer Tool
Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool
Configurazione di Microsoft Exchange Server Best Practices Analyzer Tool

Altre risorse

Analisi dell'output di Microsoft Exchange Server Best Practices Analyzer Tool
Verifica della rete e delle autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Verifica della rete e delle autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool

Verifica della rete e delle autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

Prima di iniziare un'analisi, Microsoft® Exchange Server Best Practices Analyzer Tool eseguirà un controllo della rete e delle autorizzazioni, verificando che le credenziali dell'account specificate siano valide e che lo strumento sia in grado connettersi al servizio directory di Active Directory®. Se uno di questi controlli dovesse avere esito negativo, è possibile tornare alla pagina Connessione a Active Directory e inserire nuovamente il nome del server sul quale Active Directory è in esecuzione e le credenziali per l'accesso a Active Directory e ai server di Exchange.

Vedere anche

Concetti

Autorizzazioni per Microsoft Exchange Server Best Practices Analyzer Tool
Configurazione di Microsoft Exchange Server Best Practices Analyzer Tool

Altre risorse

Configurazione dell'analisi in Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Configurazione di Microsoft Exchange Server Best Practices Analyzer Tool

Configurazione di Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2006-10-10

Prima di eseguire l'analisi, è necessario eseguire i seguenti passaggi conclusivi:

  1. Impostare un'etichetta per l'analisi.

  2. Impostare l'ambito.

  3. Impostare il tipo di analisi.

  4. Impostare la velocità di rete.

Dopo aver specificato l'etichetta, l'ambito, il tipo di analisi e la velocità di rete, in Microsoft® Exchange Server Best Practices Analyzer Tool verrà avviata l'analisi.

Impostazione dell'etichetta per l'analisi

Per impostare un'etichetta per l'analisi, inserire un'etichetta univoca nella casella Immettere un'etichetta di identificazione per l'analisi nella pagina Avvia una nuova analisi Best Practices. Se in seguito si sceglie di visualizzare un rapporto esistente, è possibile identificarlo mediante l'etichetta inserita nella casella Immettere un'etichetta di identificazione per l'analisi.

È possibile visualizzare un rapporto esistente nei due modi seguenti:

  • Nella pagina iniziale scegliere Seleziona un rapporto Best Practices da visualizzare.

  • Nel riquadro di esplorazione sinistro della finestra Exchange Server Best Practices Analyzer scegliere Seleziona un'analisi da visualizzare.

Impostazione dell'ambito dell'analisi

Per impostare l'ambito dell'analisi, selezionare i server o i gruppi amministrativi dei quali si desidera eseguire l'analisi nella pagina Avvia una nuova analisi Best Practices.

Sono disponibili tre ambiti:

  • È possibile selezionare l'intera organizzazione di Exchange Server.

  • È possibile selezionare uno o più gruppi amministrativi.

  • È possibile selezionare uno o più server da qualsiasi gruppo amministrativo nell'organizzazione di Exchange Server.

Scelta del tipo di analisi

Successivamente, è necessario scegliere il tipo di analisi. Sono disponibili tre tipi di analisi:

  • Controllo di integrità

  • Controllo di integrità/prestazioni

  • Test di connettività

  • Linea di base

L'analisi Controllo di integrità consente di eseguire un'analisi completa. Include la verifica di errori, avvisi, configurazioni non predefinite, modifiche recenti e altre informazioni sulla configurazione. Si consiglia di eseguire un'analisi Controllo di integrità se si desidera verificare l'integrità dell'organizzazione di Exchange Server oppure risolvere un problema specifico.

L'analisi Controllo di integrità/prestazioni esegue l'analisi Controllo di integrità e successivamente esamina un intervallo di contatori di prestazioni di Exchange Server per un periodo di due ore.

L'analisi Test di connettività consente di analizzare le connessioni e le autorizzazioni di rete per ciascun server di Exchange Server specificato nell'ambito. Si consiglia di eseguire un'analisi Test di connettività se si sospetta un problema di autorizzazioni di accesso o se sono presenti firewall nella topologia. Se l'analisi Test di connettività viene completata correttamente, è possibile eseguire un'analisi Controllo di integrità.

L'analisi Test di connettività è molto veloce. Exchange Server Best Practices Analyzer esegue una query in un parametro del Registro di sistema e in due classi Microsoft WMI (Strumentazione gestione Windows®). La prima query WMI garantisce l'accesso all'archivio WMI. La seconda interroga i server del servizio directory di Active Directory® utilizzati da Exchange Server. Dopo aver eseguito l'analisi di tutti i server di Exchange specificati nell'ambito, Exchange Server Best Practices Analyzer cerca di convalidare la connettività e le autorizzazioni di rete nei server di Active Directory utilizzati da Exchange Server.

L'analisi Linea di base consente di eseguire le seguenti attività:

  • Consente di selezionare le proprietà.

  • Consente di impostare i valori della linea di base per tali proprietà.

  • Consente infine di selezionare i server nei quali confrontare tali proprietà.

L'analisi Linea di base verifica la presenza di eventuali discrepanze rispetto ai valori impostati per la linea di base. Il rapporto dell'analisi Linea di base identifica come incongruenze di base tutte le proprietà dei server selezionati i cui valori differiscono da quelli di origine delle proprietà selezionate.

Per eseguire un'analisi Linea di base

  1. Nella pagina Avvia una nuova analisi Best Practices, nel menu Selezionare il tipo di analisi da eseguire, scegliere Linea di base, quindi fare clic su Opzioni linea di base.

  2. Dal menu Opzioni linea di base scegliere un'analisi esistente oppure digitare una nuova etichetta.

  3. Fare clic sulla freccia Valori origine per espandere l'elenco delle proprietà di base.

    • Sono le proprietà raccolte nel file ExBPA.config.xml. Per scegliere quali proprietà confrontare nell'analisi Linea di base, selezionare o deselezionare le caselle di controllo. I valori delle proprietà sono i valori predefiniti contenuti nel file ExBPA.config.xml. Impostare questi valori nelle caselle di testo.

  4. Fare clic sulla freccia Oggetti di test per espandere l'elenco dei server da analizzare.

  5. Selezionare tutti i server che si desidera analizzare per le incongruenze di base.

Impostazione della velocità di rete

Dopo aver selezionato il tipo di analisi, occorre impostare la velocità di rete. Per eseguire questa operazione, selezionare una delle quattro opzioni riportate di seguito:

  • Fast LAN

  • LAN

  • Fast WAN

  • WAN

L'impostazione della velocità di rete viene utilizzata per stimare il tempo necessario per completare l'analisi. Viene inoltre utilizzata per impostare il valore di timeout.

Durante l'analisi, Exchange Server Best Practices Analyzer attende una risposta da ciascun server per un tempo specifico. Se non riceve una risposta entro il timeout specificato, Exchange Server Best Practices Analyzer procede con il completamento dell'analisi. Su reti più lente il timeout è più lungo perché tiene conto di latenze di rete più estese. Si consiglia di selezionare il collegamento più lento nella topologia per questo parametro in modo tale che il timeout non risulti troppo breve.

Esecuzione dell'analisi

Dopo aver impostato tutte le opzioni per un'analisi, è possibile scegliere tra Avvia l'analisi o Pianifica un'analisi. Se si sceglie Avvia l'analisi, l'analisi dell'organizzazione di Exchange verrà avviata immediatamente. Per ulteriori informazioni, consultare Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool.

Se si sceglie Pianifica un'analisi, verrà visualizzata la pagina Pianifica un'analisi. Per pianificare un'analisi, è innanzitutto necessario inserire le credenziali di protezione richieste e selezionare la casella Abilita pianificazione dell'analisi. Per ulteriori informazioni sull'inserimento delle credenziali richieste, consultare Configurazione dell'analisi in Microsoft Exchange Server Best Practices Analyzer Tool.

Successivamente, è necessario impostare l'ora di inizio. Per ora di inizio si intende il giorno e l'ora in cui verrà eseguita la prima analisi pianificata.

Infine, è necessario impostare la frequenza. La frequenza corrisponde alla frequenza di esecuzione delle analisi pianificate. Per chiudere Exchange Server Best Practices Analyzer, fare clic su Esci dallo strumento. Per eseguire un'analisi pianificata, non è necessario che Exchange Server Best Practices Analyzer sia in esecuzione. Se si esce da Exchange Server Best Practices Analyzer, l'analisi pianificata verrà eseguita in background nella data e nell'ora specificate. Per visualizzare il rapporto di un'analisi pianificata, è necessario riavviare Exchange Server Best Practices Analyzer.

Vedere anche

Concetti

Tipi di informazioni di output

Altre risorse

Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Configurazione avanzata
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2006-10-26

Microsoft® Exchange Server Analyzer Tool dispone dei seguenti parametri configurabil del Registro di sistema:

Posizione | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Valore | OpenRelayTest
Tipo | REG_DWORD
Descrizione | Impostare il parametro su 0x0, se non si desidera che Best Practices Analyzer verifichi le funzionalità di inoltro aperto di ogni server SMTP. Se il parametro non è presente, l'impostazione predefinita di Best Practices Analyzer sarà 0x1.

Posizione | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Valore | OpenRelayTestSender
Tipo | REG_SZ
Descrizione | Impostare il parametro sull'indirizzo SMTP da utilizzare per MAIL FROM: quando si esegue un test di inoltro aperto. Se il parametro non è presente, l'impostazione predefinita di Best Practices Analyzer sarà "ExBPA-OpenRelayTest@Fabrikam.com".

Posizione | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Valore | TopoCreateTimeoutSecs
Tipo | REG_SZ
Descrizione | Impostare il parametro sull'indirizzo SMTP da utilizzare per RCPT TO: quando si esegue un test di inoltro aperto. Se il parametro non è presente, l'impostazione predefinita di Best Practices Analyzer sarà "ExBPA-OpenRelayTest@Fabrikam.com".

Posizione | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Valore | SMTPTest
Tipo | REG_DWORD
Descrizione | Impostare il parametro su 0x0, se non si desidera che Best Practices Analyzer invii un messaggio di prova a ogni server SMTP incluso nell'analisi. Se il parametro manca, l'impostazione predefinita di Best Practices Analyzer sarà 0x1.

Posizione | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Valore | SMTPTestSender
Tipo | REG_SZ
Descrizione | Impostare il parametro sull'indirizzo SMTP da utilizzare per MAIL FROM: quando si esegue un test di accettazione della posta SMTP. Se il parametro non è presente, l'impostazione predefinita di Best Practices Analyzer sarà "ExBPA-MailAcceptTest@Fabrikam.com".

Posizione | HKEY_CURRENT_USER\Software \Microsoft\Exchange\ExBPA
Valore | T SMTPTestRecipient
Tipo | REG_SZ
Descrizione | Impostare il parametro sull'indirizzo SMTP da utilizzare per RCPT TO: quando si esegue un test di accettazione della posta SMTP. Se il parametro non è presente, l'impostazione predefinita di Best Practices Analyzer sarà l'account Postmaster definito dal servizio SMTP.


Analisi dell'output di Microsoft Exchange Server Best Practices Analyzer Tool
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2006-02-08

Il rapporto Microsoft® Exchange Server Analyzer Tool consente di visualizzare l'analisi dei dati raccolti durante l'analisi dell'organizzazione di Exchange. È possibile selezionare tre tipi di rapporti, ovvero Rapporti elenco, Rapporti struttura e Altri rapporti.

  • I Rapporti elenco includono:

    • Elenco di problemi critici

    • Elenco completo dei problemi

    • Elenco delle impostazioni non predefinite

    • Elenco delle modifiche recenti

    • Elenco della linea di base

    • Elementi informativi

  • I Rapporti struttura includono:

    • Visualizzazione dettagli

    • Visualizzazione riepilogo

  • Altri rapporti

    • Elementi nascosti

    • Registro di run-time

Rapporti elenco

La visualizzazione predefinita è l'Elenco di problemi critici. Nell'Elenco di problemi critici vengono visualizzati solo gli errori trovati. Gli errori sono problemi critici che influiscono immediatamente sulle prestazioni e sulla disponibilità di Exchange Server. Nell'Elenco completo dei problemi vengono visualizzati errori, avvisi e violazioni delle procedure consigliate. Nell'Elenco delle impostazioni non predefinite vengono visualizzate le modifiche di configurazione apportate sul server dopo l'installazione di Exchange Server. Nell'Elenco delle modifiche recenti vengono visualizzate le modifiche di configurazione apportate nel server negli ultimi cinque giorni inclusa l'installazione di Service Pack e di altri aggiornamenti. Nell'Elenco della linea di base vengono visualizzate le differenze di configurazione tra i nodi di un cluster.

Rapporti struttura

Nella Visualizzazione dettagli sono riportate tutte le impostazioni di configurazione raccolte da Exchange Server Analyzer Tool. Nella Visualizzazione riepilogo è riportata una rappresentazione gerarchica di tutti i problemi rilevati nell'ambiente Exchange.

Altri rapporti

Nel rapporto Elementi nascosti vengono visualizzati i problemi che sono stati nascosti dal programma di amministrazione di Microsoft Exchange negli altri rapporti di Exchange Server Analyzer Gli elementi di questo elenco, se visualizzati nuovamente, possono essere inclusi in altri rapporti. Nel rapporto Registro di run-time vengono visualizzate informazioni importanti sul processo di raccolta, nonché tutti gli errori rilevati durante il processo.

Nell'Elenco di problemi critici, nell'Elenco completo dei problemi e nell'Elenco delle impostazioni non predefinite è possibile selezionare un errore o un avviso per visualizzare una spiegazione. È possibile fare clic su Ulteriori informazioni su questo problema e su come risolverlo per ottenere ulteriori informazioni dettagliate.

Nota:
Il file di output di dati XML e un file di registro dell'analisi si trovano in <unità di sistema>\Documents and Settings\<nome utente>\Application Data\Microsoft\ExBPA.

In questa sezione

Tipi di informazioni di output

Risolvere e nascondere problemi

Visualizzazione di un rapporto precedente di Microsoft Exchange Server Best Practices Analyzer Tool


Tipi di informazioni di output

Tipi di informazioni di output |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Analisi dell'output di Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2006-09-29

Nel rapporto di Microsoft® Exchange Server Best Practices Analyzer Tool sono presenti sette tipi di informazioni:

  • Errore

  • Avviso

  • Configurazione non predefinita

  • Modifiche recenti

  • Incongruenze di base

  • Configurazione ottimale

  • Informazioni

Errore

Un errore indica un problema critico che necessita un intervento. Ad esempio, l'istanza di un server non attivo o non raggiungibile viene ritenuta un errore.

Gli errori vengono visualizzati nei seguenti rapporti:

  • Elenco di problemi critici

  • Elenco completo dei problemi

  • Elenco Visualizzazione dettagli

  • Visualizzazione Dettagli—Elenco completo dei problemi

Se si disabilita un errore, Exchange Server Best Practices Analyzer visualizzerà tale errore nell'Elenco problemi disabilitati.

In Exchange Server Best Practices Analyzer gli errori sono contrassegnati da una X rossa (Figura 1).

Figura 1 Icona di errore

Icona indicante uno stato di errore

Avviso

Un avviso indica un problema che non dovrebbe verificarsi se le impostazioni sono configurate in modo ottimale. Tale problema potrebbe richiedere un intervento oppure essere un problema noto che non richiede interventi nell'organizzazione di Exchange Server. Ad esempio, un servizio che non viene avviato su un server genera un avviso.

Gli avvisi vengono visualizzati nei seguenti rapporti:

  • Elenco completo dei problemi

  • Elenco Visualizzazione dettagli

  • Visualizzazione Dettagli—Elenco completo dei problemi

Se si disabilita un avviso, Exchange Server Best Practices Analyzer visualizzerà tale avviso nell'Elenco problemi disabilitati.

In Exchange Server Best Practices Analyzer gli avvisi sono contrassegnati da un simbolo giallo (Figura 2).

Figura 2 Icona di avviso

Icona di avviso, triangolo giallo con punto esclamativo nero

Configurazione non predefinita

Una configurazione non predefinita indica che il valore di un'impostazione non corrisponde a quello predefinito. Se Exchange Server Best Practices Analyzer determina che una configurazione non predefinita è un errore o un avviso, tale configurazione verrà indicata con il simbolo appropriato di errore o di avviso in un'altra sezione del rapporto, oltre a essere indicata come configurazione non predefinita.

Le configurazioni non predefinite vengono visualizzate nei seguenti rapporti:

  • Elenco completo dei problemi

  • Elenco Visualizzazione dettagli

  • Visualizzazione Dettagli—Elenco completo dei problemi

Se si disabilita una configurazione non predefinita, Exchange Server Best Practices Analyzer visualizzerà tale configurazione nell'Elenco problemi disabilitati.

In Exchange Server Best Practices Analyzer le configurazioni non predefinite sono contrassegnate dal simbolo di un puntatore a un documento (Figura 3).

Figura 3 Icona di configurazione non predefinita

Icona delle proprietà non predefinite

Modifiche recenti

Una modifica recente indica che un'impostazione è stata modificata negli ultimi 5 giorni. Exchange Server Best Practices Analyzer è in grado di identificare come modifiche recenti solo quelle impostazioni che dispongono della proprietà ultima modifica. Se Exchange Server Best Practices Analyzer determina che un'impostazione recentemente modificata rappresenta un errore, un avviso o una configurazione non predefinita, la modifica recente verrà indicata con il simbolo appropriato di errore, avviso o configurazione non predefinita in un'altra sezione del rapporto, oltre a essere indicata come modifica recente.

Le modifiche recenti vengono visualizzate nei seguenti rapporti:

  • Elenco completo dei problemi

  • Elenco Visualizzazione dettagli

  • Visualizzazione Dettagli—Elenco completo dei problemi

Se si disabilita una modifica recente, Exchange Server Best Practices Analyzer visualizzerà tale modifica nell'Elenco problemi disabilitati.

In Exchange Server Best Practices Analyzer le modifiche recenti sono contrassegnate dal simbolo di una correzione a matita (Figura 4).

Figura 4 Icona di modifica recente

Icona delle modifiche recenti

Incongruenze di base

Un'incongruenza di base indica un'impostazione il cui valore non corrisponde al valore della stessa impostazione nel server di base. Per visualizzare le incongruenze di base, è necessario eseguire un'analisi di base. Se Exchange Server Best Practices Analyzer determina che un'incongruenza di base rappresenta un errore, un avviso o una configurazione non predefinita, l'incongruenza di base verrà indicata con il simbolo appropriato di errore, avviso o configurazione non predefinita, oltre a essere indicata come incongruenza di base.

Le incongruenze di base vengono visualizzate nei seguenti rapporti:

  • Elenco completo dei problemi

  • Elenco Visualizzazione dettagli

  • Visualizzazione Dettagli—Elenco completo dei problemi

Se si disabilita un'incongruenza di base, Exchange Server Best Practices Analyzer visualizzerà tale incongruenza nell'Elenco problemi disabilitati.

In Exchange Server Best Practices Analyzer le incongruenze di base sono contrassegnate dal simbolo degli appunti e del segno di spunta (Figura 5).

Figura 5 Icona di incongruenza di base

Icona del rapporto di riferimento in ExBPA

Configurazione ottimale

Un messaggio di configurazione ottimale indica un'impostazione che non è considerata ottimale. I messaggi di configurazione ottimale non sono avvisi, poiché il problema non ha effetto sulla stabilità generale dell'organizzazione di Exchange Server. Sono azioni consigliate. Se Exchange Server Best Practices Analyzer determina che un messaggio di configurazione ottimale rappresenta una configurazione non predefinita o una modifica recente, il messaggio verrà indicato con il simbolo appropriato di configurazione non predefinita o modifica recente in un'altra sezione del rapporto, oltre a essere indicato come messaggio di configurazione ottimale.

I messaggi di configurazione ottimale vengono visualizzati nei seguenti rapporti:

  • Elenco completo dei problemi

  • Elenco Visualizzazione dettagli

  • Visualizzazione Dettagli—Elenco completo dei problemi

Se si disabilita un messaggio di configurazione ottimale, Exchange Server Best Practices Analyzer visualizzerà tale elemento nell'Elenco problemi disabilitati.

In Exchange Server Best Practices Analyzer i messaggi di configurazione ottimale sono contrassegnati da un punto esclamativo blu (Figura 6).

Figura 6 Icona di configurazione ottimale

Icona di avviso procedura consigliata

Informazioni

Un messaggio di informazioni indica informazioni non fornite da Exchange Server Best Practices Analyzer negli altri cinque tipi di rapporti. Ad esempio, un'informazione può comunicare il numero di oggetti Exchange Server nel servizio directory di Active Directory®.

I messaggi di informazioni vengono visualizzati nei seguenti rapporti:

  • Elenco Visualizzazione dettagli

  • Visualizzazione Dettagli—Elenco completo dei problemi

In Exchange Server Best Practices Analyzer le informazioni vengono contrassegnate da una lettera "i" minuscola (Figura 7).

Figura 7 Icona di informazioni

Icona di informazioni

Vedere anche

Concetti

Configurazione di Microsoft Exchange Server Best Practices Analyzer Tool

Altre risorse

Risolvere e nascondere problemi

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Risolvere e nascondere problemi
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Analisi dell'output di Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2006-02-08

Dopo aver eseguito Microsoft® Exchange Server Analyzer Tool sull'organizzazione Exchange, potrebbero essersi verificati i problemi elencati nel rapporto da risolvere. Se si seleziona un problema, verranno visualizzate una spiegazione e tre opzioni:

  • Fare clic sulla prima opzione per ottenere ulteriori informazioni sul problema e sulla relativa risoluzione.

  • Fare clic sulla seconda opzione per nascondere il problema su questo server.

  • Fare clic sulla terza opzione per nascondere il problema su tutti i server. I problemi che vengono nascosti non verranno visualizzati nell'elenco di problemi critici o nell'elenco completo dei problemi in questo o in qualsiasi altro rapporto. Per visualizzare i problemi nascosti, selezionare il relativo elenco. Dall'elenco problemi nascosti, è possibile attivare nuovamente i problemi per consentirne nuovamente la visualizzazione nell'elenco di problemi critici e nell'elenco completo dei problemi.

Exchange Server Analyzer non apporta alcuna modifica all'organizzazione di Exchange durante la risoluzione dei problemi. Vengono solo visualizzate delle informazioni per la risoluzione dei problemi.

In questa sezione

Tipi di informazioni di output


Visualizzazione di un rapporto precedente di Microsoft Exchange Server Best Practices Analyzer Tool

Visualizzazione di un rapporto precedente di Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool > Analisi dell'output di Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

Invece di eseguire una nuova analisi, è possibile eseguire Microsoft® Exchange Server Best Practices Analyzer Tool per visualizzare un rapporto da un'analisi precedente.

Per visualizzare un rapporto precedente

  1. Eseguire ExBPA.exe per avviare Exchange Server Best Practices Analyzer.

  2. Scegliere se si desidera scaricare le regole più recenti.

  3. Sulla pagina di benvenuto scegliere Seleziona un rapporto Best Practices da visualizzare.

  4. Selezionare il rapporto che si desidera visualizzare dall'elenco dei rapporti archiviati localmente.

    Verrà creato un elenco dai file memorizzati in <unità di sistema>\Documents and Settings\<nome utente>\Application Data\Microsoft\ExBPA. Quando si seleziona un rapporto, verranno visualizzate ulteriori informazioni relative alle dimensioni e all'ambito di questo rapporto. Fare clic su Visualizza rapporto per visualizzare il rapporto completo.

    È inoltre possibile importare un rapporto da un'altra posizione selezionando Importa rapporto nell'angolo in alto a destra della pagina. Se la versione del file ExBPA.Config.xml non corrisponde alla versione utilizzata per la raccolta dei dati nel rapporto importato, lo strumento potrebbe analizzare nuovamente il file importato dopo l'importazione.

  5. Visualizzare il rapporto Exchange Server Best Practices Analyzer.

Vedere anche

Altre risorse

Analisi dell'output di Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Effetto sulle prestazioni di Microsoft Exchange Server Best Practices Analyzer Tool

Effetto sulle prestazioni di Microsoft Exchange Server Best Practices Analyzer Tool |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

Microsoft® Exchange Server Best Practices Analyzer Tool potrebbe influenzare le prestazioni dei seguenti computer dell'organizzazione di Exchange:

  • Il computer sul quale viene eseguito Exchange Server Best Practices Analyzer.

  • Il server sul quale viene eseguito il servizio directory di Active Directory®.

  • I server di Exchange ai quali lo strumento accede.

Prestazioni del computer sul quale viene eseguito Exchange Server Best Practices Analyzer

Exchange Server Best Practices Analyzer utilizzerà le seguenti risorse del computer sul quale viene eseguito:

  • Da 5 a 10 megabyte (MB) di RAM per ciascun server analizzato.

  • Dal 50 al 75% della CPU durante l'analisi dell'organizzazione di Exchange

  • da 0,5 a 2 MB di spazio su disco utilizzato per dati XML (extensible markup language)

Per ulteriori informazioni sulla scelta del computer nel quale installare ed eseguire Exchange Server Best Practices Analyzer, consultare Installazione di Microsoft Exchange Server Best Practices Analyzer Tool.

Prestazioni sul server Active Directory

Exchange Server Best Practices Analyzer utilizzerà le seguenti risorse del server Active Directory:

  • Dal 25 al 50% della CPU durante il tempo di accesso dello strumento al server Active Directory.

Nota:
Lo strumento accede al server Active Directory sporadicamente e ogni accesso dura in media da 10 a 15 secondi. L'intervallo sarà più lungo per le organizzazioni di Exchange di grandi dimensioni.

Prestazioni sui server di Exchange

Non si noterà una riduzione notevole delle prestazioni dei server di Exchange durante l'analisi dell'organizzazione da parte di Exchange Server Best Practices Analyzer.

Nota:
Il tempo impiegato dallo strumento per la raccolta dei dati da un server di Exchange varia a seconda del carico sul server di Exchange e della velocità di rete. Sulle reti lente, lo strumento impiegherà almeno un'ora per la raccolta dei dati. Sulle reti veloci, lo strumento impiegherà meno di dieci minuti per la raccolta dei dati.

Vedere anche

Concetti

Installazione di Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Utilizzo di Microsoft Exchange Server Best Practices Analyzer Tool dalla riga di comando

Utilizzo di Microsoft Exchange Server Best Practices Analyzer Tool dalla riga di comando |
 | Vedere anche
Informazioni generali su Microsoft Exchange Server Best Practices Analyzer Tool >

Ultima modifica: 2005-07-08

È disponibile una versione del programma della riga di comando di Microsoft® Exchange Server Best Practices Analyzer Tool. Il file eseguibile del programma della linea di comando è il file ExBPACmd.exe, installato nella directory <unità di sistema>\Programmi\ExBPA se la versione con interfaccia visiva grafica (GUI) è installata. In alcuni casi, potrebbe essere preferibile utilizzare il programma della riga di comando invece della versione con interfaccia visiva grafica. Ad esempio, è possibile utilizzare il programma della riga di comando per creare uno script per eseguire analisi programmate. Oppure il Servizio Supporto Tecnico Clienti Microsoft potrebbe richiedere di eseguire il programma della riga di comando per risolvere un problema.

Sintassi ExBPACmd.exe

Utilizzo: ExBPACmd.exe [-cfg <config XML>] [-dat <data XML>] [-d <dc name>] [-n <name>] [-u <context> <[domain\]user> <password | *> ...] [-rs <scope> <sub1> ...] [-rc <cat>,...] [-rl <level>] [-th <max threads>] [-to <timeout>] [-a] [-c] [-e] [-?]

-cfg: consente di specificare il file di configurazione XML che determina le impostazioni da recuperare. Il valore predefinito è ExBPA.Config.xml.

-dat: consente di specificare il file di dati XML da utilizzare. Se si specifica un nome di file di dati XML non presente nella directory corrente, verrà utilizzato il nome del file specificato per il file di output. Se si specifica un file di dati XML esistente e si esegue un'analisi, verranno letti e analizzati i dati raccolti nel file specificato e il file specificato con l'output dell'analisi verrà sovrascritto. Se si specifica un nome di file di dati XML esistente e si esegue un'analisi della raccolta, il file specificato con l'output dell'analisi verrà sovrascritto.

Il valore predefinito se si esegue un'analisi è output.<ts>.xml, in cui <ts> è il time stamp più recente nella directory corrente. Il valore predefinito se si esegue una raccolta è output.<ts>.xml, in cui <ts> è il nuovo time stamp.

-d: consente di specificare il controller di dominio da utilizzare per accedere al servizio directory di Active Directory®. Per impostazione predefinita, verrà utilizzato il server Active Directory più vicino.

-n: consente di attribuire un nome descrittivo al cliente al quale appartiene la topologia analizzata.

-u: consente di attribuire credenziali separate in base al contesto.

Contesti utente validi: ADLOGON per le credenziali di accesso ad Active Directory o EXLOGON per le credenziali di accesso ai server di Exchange.

-rs: consente di includere nell'analisi esclusivamente gli oggetti che si trovano negli ambiti specificati. I campi <sub> indicano valori per l'ambito specificato. Se non si utilizza l'opzione -rs, l'analisi includerà l'intera organizzazione Exchange. Se si utilizza l'opzione -rs, è possibile limitare l'analisi a specifici gruppi amministrativi o server. È possibile specificare uno o più gruppi amministrativi o uno o più server.

Ambiti validi: AdminGroup, Server

-rc: consente di includere nell'analisi esclusivamente le impostazioni e gli oggetti che corrispondono a categorie specificate. Il file di configurazione XML definisce le categorie per impostazioni e oggetti. Se si utilizza l'opzione -rc per limitare un'analisi a una categoria, l'analisi includerà esclusivamente le impostazioni per le quali è definita tale categoria. Questa opzione consente di includere più di una categoria.

Le categorie valide che si possono utilizzare con l'opzione -rc potrebbero variare leggermente a seconda della versione del file di configurazione XML. Per determinare le categorie valide per una versione specifica del file di configurazione XML, eseguire ExBPACmd.exe -?.

-rl: consente di includere nell'analisi esclusivamente le impostazioni e gli oggetti che corrispondono al livello di dettaglio specificato o inferiore. Il file di configurazione XML definisce il livello di dettaglio per impostazioni e oggetti. Il valore predefinito è 4.

I livelli validi che si possono utilizzare con l'opzione -rl potrebbero variare leggermente a seconda della versione del file di configurazione XML. Per determinare i livelli validi per una versione specifica del file di configurazione XML, eseguire ExBPACmd.exe -?.

-th: consente di impostare il numero massimo di thread da eseguire contemporaneamente. Il valore predefinito è 25.

-to: consente di impostare il tempo predefinito (in secondi) di attesa dello strumento durante la raccolta di dati da un server nell'organizzazione di Exchange. Il valore predefinito è 300 secondi.

-a: consente di analizzare il file di dati XML utilizzando le regole del file di configurazione XML. Questa opzione può essere utilizzata per analizzare un file di output esistente di un'analisi specificando il file di dati XML da utilizzare. Questa opzione può inoltre essere utilizzata per raccogliere e analizzare i dati per una nuova analisi specificando un file di dati XML che non si trovi nella directory corrente oppure non specificando alcun file di dati XML.

-c: consente di raccogliere i dati dall'organizzazione di Exchange specificata nel file di configurazione XML. Lo strumento non analizza i dati utilizzando le regole del file di configurazione XML, ma raccoglie i dati solamente. Se nessun passaggio di analisi (-a) o raccolta (-c) è specificato, questo sarà attivato per impostazione predefinita.

-e: consente di indicare che lo strumento dovrebbe eliminare i valori di tutte le impostazioni contrassegnate come NotForExport nel file di configurazione XML.

-? Visualizza informazioni di sintassi.

Vedere anche

Altre risorse

Analisi dell'organizzazione di Exchange con Microsoft Exchange Server Best Practices Analyzer Tool

© 2007 Microsoft Corporation. Tutti i diritti riservati.


Articoli su Microsoft Exchange Server Analyzer

Ultima modifica: 2006-10-06

Gli articoli in questa sezione descrivono le regole e i relativi messaggi generati dai seguenti strumenti Microsoft® Exchange Analyzer:

  • Exchange Best Practices Analyzer

  • Exchange Troubleshooting Assistant

Exchange Troubleshooting Assistant fornisce l'accesso alle seguenti funzionalità:

  • Exchange Performance Troubleshooter

  • Exchange Database Troubleshooter

  • Exchange Database Recovery Management

  • Exchange Mail Flow Troubleshooter

In ogni articolo viene descritto un messaggio di errore, di avviso o di configurazione non predefinita che può essere rilevato da Exchange Server Analyzer.

La pagina Web degli strumenti Microsoft Exchange Analyzer all'indirizzo http://go.microsoft.com/fwlink/?linkid=34707 contiene download delle versioni correnti di Exchange Best Practice Analyzer ed Exchange Troubleshooting Assistant. Inoltre, la pagina contiene informazioni sui requisiti di sistema e un collegamento a un newsgroup per discussioni sugli strumenti di analisi.

Se si esegue il programma in un ambiente in cui non è possibile utilizzare la funzionalità di aggiornamento automatico per Exchange Best Practices, è possibile accedere alla pagina Web di Microsoft Exchange Best Practices Analyzer Web Update Pack Web all'indirizzo http://go.microsoft.com/fwlink/?linkid=34290 (in inglese). Da questa pagina sarà possibile scaricare i file di configurazione e della Guida più recenti.

Nota:
Se gli aggiornamenti vengono applicati in modo automatico, non sarà necessario utilizzare questo download.


Active Directory
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-17

Gli articoli contenuti in questa sezione illustrano in dettaglio gli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente al servizio directory di Active Directory®. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere avvisi, messaggi di errore e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi ad Active Directory.


Server Active Directory Connector inattivo o irraggiungibile
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool utilizza chiamate di procedura remota (RPC, Remote Procedure Call) per leggere il valore della stringa CurrentVersion dalla seguente chiave del Registro di sistema nel server Active Directory Connector (ADC):

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

In un computer Microsoft® Windows 2000 Server, il valore previsto della stringa CurrentVersion è 5.0. In un computer con Microsoft® Windows Server™ 2003 in esecuzione il valore previsto è 5.2.

Se Exchange Server Analyzer non è in grado di leggere questo valore del Registro di sistema per qualsiasi motivo, verrà visualizzato un messaggio di errore.

Per risolvere il problema

  1. Assicurarsi che il server ADC sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il server ADC sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  4. Verificare che il servizio Registro di sistema remoto sul server ADC sia stato avviato.

  5. Controllare le autorizzazioni dell'account utilizzato per l'esecuzione di Exchange Server Analyzer per verificare che siano sufficienti per leggere il Registro di sistema nel server ADC.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, consultare:

  • l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).


Il server Active Directory Connector non sta eseguendo alcun Contratto di connessione e pertanto può essere rimosso
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchChildSyncAgreements, che rappresenta i Contratti di connessione in esecuzione su un server ADC (Active Directory Connector). Questo attributo è una stringa multivalore ed è impostata sul seguente oggetto Active Directory: CN=Active Directory Connector (nomeserver),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Tramite Exchange Server Analyzer viene recuperato il numero di voci (conteggio) in questo attributo. Se è pari a 0, il conteggio indica che nessun Contratto di connessione è in esecuzione, pertanto verrà visualizzato un avviso.

Se viene rilevato che tutti i contratti di connessione richiesti sono in esecuzione su altri server ADC, il servizio ADC su questo server deve essere rimosso o disabilitato. Se si esegue il servizio ADC senza alcun Contratto di connessione, non si verificano problemi. Tuttavia, è consigliabile non eseguire alcun servizio se non è necessario. Pertanto, è opportuno disabilitare o disinstallare il servizio ADC dal server ADC.

Per risolvere il problema

  1. Per disabilitare il servizio ADC sul server che esegue il servizio ADC, fare clic con il pulsante destro del mouse su Risorse del computer sul desktop e scegliere Gestisci.

  2. Espandere il nodo Servizi e applicazioni, quindi scegliere il nodo Servizi.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse su Microsoft Active Directory Connector e scegliere Proprietà.

  4. Modificare l'opzione Tipo di avvio in Disattivato. Al successivo riavvio del computer, il servizio ADC non verrà eseguito.

  5. Fare clic su Applica, quindi su OK.

Se si decide di disinstallare il servizio ADC, per eseguire questa operazione è possibile utilizzare il CD di Microsoft Exchange Server 2003 o Microsoft Exchange 2000 Server. Andare alla cartella \ADC\I386 e fare doppio clic sul programma Setup.exe. Per disinstallare il servizio ADC, seguire le istruzioni visualizzate.

Per ulteriori informazioni su Active Directory Connector, consultare i seguenti articoli Microsoft Support Webcast:

  • "Support Webcast: Introduzione ad Active Directory Connector" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300 (informazioni in lingua inglese).

  • "Support Webcast: Microsoft Advanced Active Directory Connector" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221 (informazioni in lingua inglese).

  • Per ulteriori informazioni sull'installazione e la configurazione di Active Directory Connector, consultare l'articolo 312632 della Microsoft Knowledge Base: "HOW TO: Installazione e configurazione di Active Directory Connector in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632.


Sul server Active Directory Connector non è in esecuzione il Service Pack più recente per Windows 2000 Server
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esamina la classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave ServicePackMajorVersion sul server Active Directory Connector (ADC). Exchange Server Analyzer esamina inoltre il seguente valore del Registro di sistema per determinare la versione di Windows in esecuzione sul server ADC:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se Exchange Server Analyzer rileva che nel server ADC è in esecuzione un sistema operativo Microsoft Windows 2000 Server ma non il Service Pack 4 (SP4) per Windows 2000 Server, verrà visualizzato un avviso.

Si consiglia di eseguire i Service Pack più recenti per tutto il software presente nelle installazioni di, inclusi i server ADC.

Per risolvere il problema

  1. Aggiornare tutti i server ADC e qualsiasi altro server nei quali sia in esecuzione un sistema operativo Windows 2000 Server installando il Service Pack 4, oltre agli aggiornamenti rapidi e agli aggiornamenti più recenti da Windows Update.

  2. Aggiornare tutti i computer Exchange Server nei quali è eseguito un sistema operativo Windows 2000 Server installando il Service Pack e gli aggiornamenti cumulativi più recenti.

Per ulteriori informazioni su come richiedere e installare Service Pack per i sistemi operativi Windows 2000 Server, consultare la pagina Web http://go.microsoft.com/fwlink/?LinkId=18353.

Per ulteriori informazioni su come richiedere e installare Service Pack e aggiornamenti cumulativi di Exchange Server, consultare la pagina Web http://go.microsoft.com/fwlink/?LinkId=21573.


Possibile sovraccarico del server Active Directory Connector
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchChildSyncAgreements, che rappresenta i Contratti di connessione in esecuzione su un server ADC (Active Directory Connector). Questo attributo è una stringa multivalore ed è impostata sul seguente oggetto Active Directory: CN=Active Directory Connector (nomeserver),CN=Exchange Settings,CN=ServerName,CN=Servers,CN=SiteName,CN=Sites,CN=Configuration,DC=Domain,DC=com

Tramite Exchange Server Analyzer viene recuperato il numero di voci (conteggio) in questo attributo. Se il numero è maggiore di 80, verrà visualizzato un avviso.

Si consiglia l'esecuzione con meno di 80 Contratti di connessione per server ADC. Se esistono altri server ADC che non ospitano il numero massimo consigliato di Contratti di connessione, spostare alcuni contratti da questo server all'altro server ADC. Se non sono presenti altri server ADC, installare il programma ADC incluso con Microsoft Exchange 2000 Server o Exchange Server 2003 in un altro computer che esegue Microsoft Windows® 2000 Server o Windows Server™ 2003.

Quando si sposta un Contratto di connessione da un server ADC a un altro, gli attributi principali dello specifico contratto non cambiano. Ad esempio, i contenitori di origine e di destinazione utilizzati per la replica e i dati configurati per eseguirla rimangono inalterati. Quando si sposta un Contratto di connessione, cambierà solo il server ADC su cui veniva eseguito il contratto.

Per risolvere il problema

  1. Fare clic su Start, scegliere Programmi, Strumenti di amministrazione, quindi Gestione di Active Directory Connector per aprire la console di gestione di ADC.

  2. Nel riquadro sinistro della console MMC verrà visualizzato un elenco di server su cui viene eseguito il servizio ADC. Selezionare l'ADC per il server su cui è situato il Contratto di connessione che si desidera spostare.

  3. Nel riquadro dei dettagli della console MMC vengono visualizzati i Contratti di connessione ospitati sul server ADC selezionato.

  4. Fare clic con il pulsante destro del mouse sul Contratto di connessione che si desidera spostare, quindi scegliere Proprietà.

  5. Nella scheda Generale, all'interno dell'elenco a discesa Selezionare un server per l'esecuzione del Contratto di connessione, selezionare il server su cui si desidera eseguire il Contratto di connessione, quindi scegliere OK.

  6. In Connetti come (server Windows) immettere la password e il nome dell'account del servizio ADC, quindi scegliere OK.

  7. In Connetti come (server Exchange) immettere l'account e la password del servizio di Exchange, quindi scegliere OK.

Per ulteriori informazioni sullo spostamento dei Contratti di connessione, consultare l'articolo 326060 della Microsoft Knowledge Base "XADM: Spostamento di un Contratto di connessione su un server diverso" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=326060.

Per ulteriori informazioni sull'installazione del programma ADC di Exchange 2000 Server in un altro server, consultare l'articolo 312632 della Microsoft Knowledge Base "Installazione e configurazione di Active Directory Connector in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312632.

Per ulteriori informazioni sull'installazione del programma ADC di Exchange Server 2003 in un altro server, consultare il "Manuale di installazione di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.


È necessario l'aggiornamento del software di Active Directory Connector
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-10-10

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per Adc.exe, ovvero il file di Active Directory Connector (ADC). La chiave WMI Version indica il numero di build per questo file.

Exchange Server Analyzer Tool esegue inoltre una query in Active Directory per determinare il valore dell'attributo msDS-Behavior-Version dell'oggetto insieme di strutture in Active Directory; Impostazioni NTDS. Questo valore indica il livello di funzionalità dell'insieme di strutture di Active Directory. I valori validi per l'attributo msDS-Behavior-Version sono elencati nella seguente tabella.

Valore | Livello di funzionalità dell'insieme di strutture
0 | Microsoft Windows 2000 Server modalità mista
1 | Windows Server™ 2003 modalità provvisoria
2 | Windows Server 2003 modalità nativa

Se Exchange Server Best Practices Analyzer rileva che il numero di build per Adc.exe è inferiore a 6.0.6615.0 su un computer che esegue Exchange Server in un insieme di strutture Active Directory in modalità Windows Server 2003 provvisoria o nativa, verrà visualizzato un messaggio di errore. Tale errore indica che una versione di Exchange 2000 Server del programma ADC è in esecuzione in un livello dell'insieme di strutture Active Directory di Windows Server 2003 non compatibile. È necessario un aggiornamento del programma Exchange Active Directory Connector (ADC) per risolvere il problema.

L'esecuzione di una versione precedente di ADC nel livello di funzionalità di un insieme di strutture misto o nativo potrebbe comportare un aggiornamento incompleto della directory e una perdita di dati. Si consiglia di eseguire l'aggiornamento alla versione più recente di ADC di Exchange Server 2003 su tutti i computer dell'organizzazione.

È possibile scaricare la versione più recente di ADC assieme al Service Pack più recente per Exchange Server 2003 dal sito "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (in inglese). È inoltre possibile installare la versione finale di ADC di Exchange Server 2003 dal CD di Exchange Server.

Per eseguire l'aggiornamento alla versione più recente di ADC

  1. Sul server che esegue la versione precedente di ADC, fare clic su Start, scegliere Esegui e digitare E:\setup\adc\i386\setup.exe, dove E corrisponde alla posizione del download del Service Pack di Exchange Server.

  2. Nella pagina Installazione guidata di Active Directory Connector fare clic su Avanti.

  3. Nella pagina Rilevata installazione precedente fare clic su Reinstalla per aggiornare ADC.

  4. Nella pagina di completamento dell'Installazione guidata di Active Directory Connector fare clic su Fine.

Per ulteriori informazioni sul modo in cui il livello operativo dell'insieme di strutture influisce su ADC, consultare l'articolo 825916 della Microsoft Knowledge Base "Active Directory Connector di Exchange 2000 non replica correttamente le modifiche all'appartenenza a un gruppo in Active Directory Windows Server 2003 nei livelli funzionali 1 o 2 dell'insieme di strutture" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=825916.

Per ulteriori informazioni sui livelli operativi dell'insieme di strutture e del dominio, consultare l'articolo 322692 della Microsoft Knowledge Base "HOW TO: Aumentare il livello funzionalità di dominio in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322692.


L'insieme di strutture di Active Directory è configurato per l'ambiente Exchange ospitato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo LinkID nell'oggetto attributo di schema Global-Address-List . L'oggetto Global-Address-List viene utilizzato su un contenitore di Exchange per archiviare il nome distinto di un elenco indirizzi globale (GAL) appena creato.

Se Exchange Server Analyzer rileva che il valore dell'attributo LinkID dell'oggetto Global-Address-List è stato impostato sul valore 4048, verrà visualizzato un messaggio di configurazione non predefinita. Il valore 4048 indica che l'insieme di strutture di Active Directory è configurato per un ambiente Exchange ospitato.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sugli ambienti Exchange ospitati, consultare i seguenti articoli:

  • "Information for Hosters" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46307 (informazioni in lingua inglese).

  • "Chapter 23 - Hosted Service Environments" in Exchange Server 2000 Resource Kit all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46326 (informazioni in lingua inglese).


Server di Active Directory inattivo o irraggiungibile
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool utilizza chiamate di procedura remota (RPC, Remote Procedure Call) per leggere il valore della stringa CurrentVersion dalla seguente chiave del Registro di sistema nel server di elenchi in linea di Active Directory®:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

In un computer Microsoft Windows® 2000 Server, il valore previsto della stringa CurrentVersion è 5.0. In un computer Microsoft® Windows Server™ 2003 il valore previsto è 5.2.

Se Exchange Server Analyzer non è in grado di leggere questo valore del Registro di sistema per qualsiasi motivo, verrà visualizzato un messaggio di errore.

Per risolvere il problema

  1. Assicurarsi che il server di elenchi in linea sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il server di elenchi in linea sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  4. Verificare che il servizio Registro di sistema remoto sul server di elenchi in linea sia stato avviato.

  5. Controllare le autorizzazioni dell'account utilizzato per l'esecuzione di Exchange Server Analyzer per verificare che siano sufficienti per leggere il Registro di sistema nel server Active Directory.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla connettività di rete, consultare quanto segue:

  • Articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).


Nel server di Active Directory è disponibile meno di 1 GB di memoria, ma nel file Boot.ini sono impostate le opzioni /3GB e /USERVA=3030
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query in due classi Microsoft WMI (Strumentazione gestione Windows®) per determinare la quantità di memoria fisica nel server del servizio directory di Active Directory® e la quantità di spazio di indirizzi virtuali assegnata ai processi in modalità utente. Nella tabella sono illustrate le classi e le chiavi valutate da Exchange Server Analyzer.

Classe | Chiave | Descrizione
Win32_OperatingSystem | MaxProcessMemorySize | Numero massimo di KB di memoria che possono essere assegnati a un processo.
Win32_OperatingSystem | OSProductSuite | Aggiunte installate e con licenza del sistema operativo.
Win32_ComputerSystem | TotalPhysicalMemory | Quantità di RAM (Random Access Memory) installata nel computer.

Se Exchange Server Analyzer determina che il server di elenchi in linea dispone di meno di 950 MB di RAM e che il valore di MaxProcessMemorySize è maggiore di 2097024 e minore di 3104640, verrà visualizzato un avviso.

Questo avviso indica che il server di elenchi in linea non è configurato correttamente per un utilizzo ottimale della memoria da due punti di vista:

  • È stata impostata l'opzione di avvio /USERVA=3030. Questa opzione è necessaria solo su computer Exchange Server con almeno 1 GB di memoria che eseguono un sistema operativo Microsoft Windows Server™ 2003.

  • È stata impostata l'opzione di avvio /3GB. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

Se questo avviso viene visualizzato in un sistema in cui è installato 1 GB di memoria fisica, potrebbe indicare che parte di questa memoria è stata allocata a livello di hardware a un altro componente, quale una scheda video, rendendo, di conseguenza, la memoria fisica allocata non disponibile per il sistema operativo. In tali casi, la quantità di memoria installata fisicamente in base a Windows sarà inferiore alla quantità effettiva di memoria fisica installata nel computer. Se si riscontra questa situazione, sarà necessario confrontare la quantità di memoria installata riportata dal BIOS con la quantità riportata da Windows.

Per correggere questo errore su Windows Server 2003

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  2. Fare clic su Avanzate.

  3. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  4. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  5. Nella sezione [Operating Systems] eliminare da tutte le righe di avvio le seguenti opzioni: /3GB /USERVA=3030

  6. Salvare le modifiche e chiudere Blocco note.

  7. Per rendere effettiva la modifica, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer.

Per correggere questo errore su Windows 2000 Server

  1. In Esplora risorse, individuare la partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, nelle Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra di Esplora risorse fare clic su Strumenti, selezionare Opzioni cartella, quindi scegliere la scheda Visualizzazione. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con e fare clic su Blocco note per aprire il file.

  4. Nella sezione [Operating Systems] , eliminare le seguenti opzioni da tutte le righe di avvio: /3GB /USERVA=3030

  5. Salvare le modifiche e chiudere Blocco note.

  6. Per rendere effettiva la modifica, riavviare il computer.

Per ulteriori informazioni sull'utilizzo delle opzioni di avvio /3GB e /USERVA, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 30356, "Utilizzo della memoria da parte del processo Lsass.exe in controller di dominio basati su Windows 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356.

  • 297812, "Utilizzo della funzione di ottimizzazione della RAM 4GT" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 316739, "Utilizzo dell'opzione /USERVA nel file Boot.ini per l'ottimizzazione delle configurazioni /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


Nel server di Active Directory è disponibile meno di 1 GB di memoria, ma è impostata l'opzione /3GB all'interno del file Boot.ini
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query in due classi Microsoft WMI (Strumentazione gestione Windows®) per determinare la quantità di memoria fisica nel server del servizio directory di Active Directory® e la quantità di spazio di indirizzi virtuali assegnata ai processi in modalità utente. Nella tabella sono illustrate le classi e le chiavi prese in esame da Exchange Server Analyzer.

Classe | Chiave | Descrizione
Win32_OperatingSystem | MaxProcessMemorySize | Numero massimo di KB di memoria che possono essere assegnati a un processo.
Win32_OperatingSystem | OSProductSuite | Aggiunte installate e con licenza del sistema operativo.
Win32_ComputerSystem | TotalPhysicalMemory | Numero di byte di memoria RAM (Random Access Memory) installati nel computer.

Se Exchange Server Analyzer determina che il server di elenchi in linea dispone di meno di 950 MB di RAM e che il valore di MaxProcessMemorySize è maggiore di 2097024 e minore di 3104640, verrà visualizzato un avviso.

Questo avviso indica che il server di elenchi in linea non è configurato correttamente per un utilizzo ottimale della memoria. L'opzione di avvio /3GB è stata impostata su questo computer e deve essere rimossa. L'opzione dovrebbe essere utilizzata solo per i server di Active Directory con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server™ 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

Se questo avviso viene visualizzato in un sistema in cui è installato 1 GB di memoria fisica, potrebbe indicare che parte di questa memoria è stata allocata a livello di hardware a un altro componente, quale una scheda video, rendendo, di conseguenza, la memoria fisica allocata non disponibile per il sistema operativo. In tali casi, la quantità di memoria installata fisicamente in base a Windows sarà inferiore alla quantità effettiva di memoria fisica installata nel computer. Se si riscontra questa situazione, sarà opportuno confrontare la quantità di memoria installata riportata dal BIOS con la quantità riportata da Windows.

Per correggere questo errore su Windows Server 2003

  1. Fare clic con il pulsante destro del mouse su Risorse del computer, quindi scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  2. Fare clic su Avanzate.

  3. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  4. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  5. Nella sezione [Operating Systems] eliminare da tutte le righe di avvio la seguente opzione: /3GB

  6. Salvare le modifiche e chiudere Blocco note.

  7. Per rendere effettiva la modifica, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer.

Per correggere questo errore su Windows 2000 Server

  1. In Esplora risorse passare alla partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, in Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra di Esplora risorse fare clic su Strumenti, selezionare Opzioni cartella, quindi scegliere Visualizzazione. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con e fare clic su Blocco note per aprire il file.

  4. Nella sezione [Operating Systems] eliminare da tutte le righe di avvio la seguente opzione: /3GB

  5. Salvare le modifiche e chiudere Blocco note.

  6. Per rendere effettiva la modifica, riavviare il computer.

Per ulteriori dettagli sull'utilizzo dell'opzione /3GB consultare i seguenti articoli della Microsoft Knowledge Base:

  • 30356, "Utilizzo della memoria da parte del processo Lsass.exe sui controller di dominio che eseguono Windows Server 2003 o Windows Server 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356.

  • 297812, "Utilizzio della funzione Ottimizzazione 4GT della RAM" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle voci della tabella pagine di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 316739, "Utilizzo dell'opzione /USERVA nel file Boot.ini per l'ottimizzazione delle configurazioni /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739.

  • 325044, "HOW TO: Risoluzione del problema della frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


Sul server di Active Directory è in esecuzione Windows 2000 Server ed è impostata l'opzione /3GB
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare la quantità di spazio di indirizzi virtuali assegnato ai processi in modalità utente (MaxProcessMemorySize) e la versione di Windows® (OSProductSuite) in esecuzione sul server del servizio directory di Active Directory®. Nella tabella sono illustrate le classi e le chiavi prese in esame da Exchange Server Analyzer.

Se Exchange Server Analyzer determina che il valore della chiave MaxProcessMemorySize è 3104640 e che il valore di OSProductSuite è impostato su Windows 2000 Server, verrà visualizzato un messaggio di errore.

Questo messaggio di errore indica che l'opzione /3GB è impostata nel file Boot.ini su un server di elenchi in linea che esegue Microsoft Windows 2000 Server. Questa opzione non è supportata da Windows 2000 Server e dovrebbe essere utilizzata solo per i computer con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Per rimuovere l'opzione /3GB dal file Boot.ini

  1. In Esplora risorse, passare alla partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, in Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra di Esplora risorse fare clic su Strumenti, selezionare Opzioni cartella, quindi scegliere la scheda Visualizzazione. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con e fare clic su Blocco note per aprire il file.

  4. Nella sezione [Operating Systems], eliminare da tutte le righe di avvio le seguenti opzioni: /3GB /USERVA=3030

  5. Salvare le modifiche e chiudere Blocco note.

  6. Riavviare il server di elenchi in linea per rendere effettive le modifiche.

Per ulteriori dettagli sull'utilizzo dell'opzione /3GB consultare i seguenti articoli della Microsoft Knowledge Base:

  • 297812, "Utilizzo della funzione di ottimizzazione della RAM 4GT" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 316739, "Utilizzo dell'opzione /USERVA nel file Boot.ini per l'ottimizzazione delle configurazioni /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


Impossibile accedere al Registro di sistema del server Active Directory
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema su ciascun controller di dominio:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion\CurrentVersion

Se Exchange Server Analyzer non può leggere questo valore del Registro di sistema per qualsiasi motivo, verrà visualizzato un messaggio di errore.

Per risolvere il problema

  1. Assicurarsi che il controller di dominio sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il controller di dominio sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  4. Assicurarsi che il servizio Remote Registry sul controller di dominio sia stato avviato.

  5. Controllare le autorizzazioni per l'account su cui è in esecuzione Exchange Server Analyzer. Questo account deve disporre delle autorizzazioni di amministratore su ciascun controller di dominio di cui viene eseguita l'analisi.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, consultare:

  • l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).

Per ulteriori informazioni sui requisiti delle porte, consultare l'articolo 832017 della Microsoft Knowledge Base "Requisiti delle porte per il sistema di server Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017.


Aggiornamento del software del server Active Directory disponibile
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-02-20

Lo strumento Microsoft Exchange Analyzer interroga la classe di Microsoft Strumentazione gestione Windows (WMI) Exchange_DSAccessDC nello spazio dei nomi ROOT\MicrosoftExchangeV2 per determinare il valore della proprietà Name. La proprietà Name specifica il nome del computer del controller di dominio utilizzato dal server di Exchange per le ricerche del servizio directory di Active Directory.

Exchange Analyzer esegue quindi una query in Active Directory per i valori degli attributi specifici di tale controller di dominio allo scopo di determinare quanto segue:

  • Se sul controller di dominio di Active Directory è in esecuzione il sistema operativo Windows Server 2003

  • Se sul controller di dominio di Active Directory è in esecuzione una versione del sistema operativo Microsoft Windows Server 2003 non in lingua inglese

  • Se è presente un server Microsoft Exchange Server 2007 nell'organizzazione di Exchange

  • Se il valore della chiave Version per il file ntdsa.dll sul server è inferiore a 2700

Se Exchange Analyzer rileva che tutte queste condizioni sono vere, verrà visualizzato un avviso.

Tale avviso indica che sui client di Exchange Outlook Web Access potrebbero verificarsi dei problemi di indicizzazione della Rubrica di Exchange.

In Outlook Web Access l'utente può selezionare la lingua preferita per l'interfaccia utente. La lingua selezionata dagli utenti determina le impostazioni internazionali. Outlook Web Access utilizza inoltre tale lingua per ordinare i risultati di Active Directory, quali la rubrica. Quando si esegue una query Virtual List Views (VLV) in Exchange specificando una lingua non disponibile nel controller di dominio, si verifica un errore. Questo problema si verifica poiché attualmente non è presente alcun meccanismo di indicizzazione predefinito che consenta a Exchange di utilizzare una lingua differente se quella specificata per una query VLV non corrisponde alla lingua del controller di dominio.

Per risolvere l'errore, procurarsi e installare l'aggiornamento del file menzionato nell'articolo 919166 della Microsoft Knowledge Base "The address book function in Exchange 2007 is broken when an Exchange OWA client and a Windows Server 2003-based domain controller do not have the same locale setting", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=919166.


Impossibile accedere alla classe WMI del server Acrive Directory
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se un valore è impostato per la chiave Name sul controller del dominio. Se si verifica un errore nella query WMI, verrà visualizzato un messaggio di errore.

Questo errore può essere provocato dai due motivi riportati di seguito:

  • L'account che esegue Exchange Server Analyzer non dispone delle autorizzazioni necessarie per eseguire una query WMI.

  • Un problema di rete impedisce a Exchange Server Analyzer di accedere al computer.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il computer Exchange Server sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  4. Controllare le autorizzazioni per l'account su cui è in esecuzione Exchange Server Analyzer. Questo account deve disporre delle autorizzazioni di amministratore locale su ciascun computer Exchange Server di cui esegue l'analisi.

    In alternativa, è possibile concedere un'autorizzazione WMI specifica all'account su cui è in esecuzione Exchange Server Analyzer.

    1. Sul computer Exchange aprire la struttura della console MMC Gestione computer.

    2. In Servizi e applicazioni fare clic con il pulsante destro del mouse su Controllo WMI e scegliere Proprietà.

    3. Nella pagina delle proprietà Controllo WMI fare clic sulla scheda Protezione, quindi espandere Directory principale.

    4. Selezionare la cartella CIMV2, quindi fare clic su Protezione.

    5. Nella pagina Protezione per ROOT\CIMV2 aggiungere l'account sul quale è in esecuzione Exchange Server Analyzer.

    6. Selezionare l'account che è stato aggiunto nel passaggio E. In Autorizzazioni per Selected_Account nella colonna Consenti selezionare sia Abilita remoto sia Protezione da lettura, quindi fare clic su OK.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, consultare:

  • l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

  • "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).

Per ulteriori informazioni sui requisiti delle porte, consultare l'articolo 832017 della Microsoft Knowledge Base "Requisiti delle porte per il sistema di server Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017.


Rilevato attributo ADCDisabledMail
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'organizzazione di Exchange è in modalità mista o nativa. Se l'organizzazione Exchange è in modalità nativa, Exchange Server Analyzer esegue una query in Active Directory per determinare se per oggetti abilitati alla posta nei domini dell'organizzazione il valore dell'attributo legacyExchangeDN è impostato su ADCDisabledMail. Se vengono rilevati oggetti abilitati alla posta con il valore dell'attributo legacyExchangeDN impostato su ADCDisabledMail, verrà visualizzato un avviso che elenca gli oggetti e il rispettivo dominio.

Questo problema può verificarsi sia su Exchange 2000 Server sia su Exchange Server 2003 quando viene eliminata una cassetta postale. Quando viene eliminata la cassetta postale, il valore dell'attributo legacyExchangeDN dell'account viene contrassegnato con ADCDisabledMail. Questo valore viene utilizzato per richiedere all'ADC di eliminare gli oggetti dal servizio directory di Exchange Server 5.5 quando l'oggetto associato è stato disabilitato alla posta in Active Directory. Se sono state eliminate diverse cassette postali in un gruppo di distribuzione di grandi dimensioni, l'elaborazione del messaggio viene rimandata e viene eseguita una ricerca di un valore univoco valore dell'attributo legacyExchangeDN di ADCDisabledMail. Poiché a più caselle postali è associato lo stesso legacyExchangeDN attribute value, la ricerca richiede molto tempo. provocando ritardi nell'elaborazione dei messaggi. I ritardi nell'elaborazione dei messaggi possono anche verificarsi quando il gruppo di distribuzione viene espanso nelle righe "A:/Cc:/Ccn:" del messaggio da un client Microsoft Office Outlook® 2003.

Per risolvere il problema, è possibile eliminare gli oggetti o utilizzare lo strumento ADSI Edit, lo strumento ldp.exe o un altro client LDAP della versione 3 per rimuovere il contenuto dell'attributo legacyExchangeDn. Se il valore dell'attributo legacyExchangeDN è impostato su NULL, la ricerca in Active Directory verrà impostata su "/O=NT5/ou=<GUID oggetto del dominio>/cn=<GUID oggetto dell'utente>" e il rapporto di mancato recapito verrà generato molto più rapidamente.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per rimuovere il valore ADCDisabledMail dell'attributo legacyExchangeDN

  1. Avviare lo strumento ADSI Edit dagli Strumenti di supporto di Windows 2000 o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore dominio

    • DC=Domain_name

    • Contenitore utenti

  3. Fare clic con il pulsante destro del mouse su User_Name e scegliere Proprietà.

  4. Fare clic su legacyExchangeDN nell'elenco Attributi, quindi scegliere Modifica.

  5. Rimuovere il valore originale legacyExchangeDN contenente ADCDisabledMail selezionando il valore originale e facendo clic su Cancella.

  6. Fare clic su OK due volte per rendere effettiva la modifica.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.


L'impostazione del filtro dell'elenco di indirizzi può provocare la mancata visualizzazione di nuovi destinatari negli elenchi di indirizzi
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare gli attributi impostati per l'attributo purportedSearch per ciascun oggetto Elenco indirizzi. Se Exchange Server Analyzer rileva che l'attributo purportedSearch contiene la stringa "proxyAddresses=*", verrà visualizzato un messaggio di errore.

Dopo aver creato un nuovo oggetto utente, il Servizio aggiornamento destinatari assegna specifici attributi a quell'oggetto destinatario quali, ad esempio, indirizzi proxy. Tuttavia, il Servizio aggiornamento destinatari può non riuscire ad assegnare l'attributo ShowInAddressBook. L'attributo ShowInAddressBook di un oggetto destinatario indica gli elenchi di indirizzi di cui il destinatario è membro. Gli oggetti destinatario a cui non è assegnato questo attributo non vengono visualizzati nell'elenco indirizzi globale né in altri elenchi di indirizzi, anche se l'oggetto corrisponde ai criteri del filtro dell'elenco di indirizzi.

Questa situazione si può verificare se uno o più filtri dell'elenco di indirizzi includono l'attributo proxyAddresses. È possibile determinare se si sia verificata questa situazione riesaminando le proprietà di ciascun celenco di indirizzi e cercando la seguente stringa nella casella Regole filtri: "proxyAddresses=*".

Procedere come segue per attivare il Servizio aggiornamento destinatari affinché assegni correttamente gli attributi agli oggetti destinatario e questi ultimi possano essere visualizzati nell'elenco indirizzi globale o in altri elenchi di indirizzi.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Destinatario, Tutti gli elenchi indirizzi globali, quindi Criteri destinatari.

  3. Nel riquadro destro, fare clic con il pulsante destro del mouse sull'elenco di indirizzi da modificare e scegliere Proprietà.

  4. Nella scheda Generale della pagina Proprietà, in Regole filtri fare clic su Modifica.

  5. Dal menu a discesa Find Exchange Recipients scegliere Ricerca personalizzata. Se l'elenco di indirizzi è stato creato in origine da una ricerca personalizzata, verrà visualizzata la pagina Find Custom Search dopo aver fatto clic su Modifica al Passaggio 3.

  6. Selezionare la voce Proxy addresses is (exactly) * dall'elenco dei criteri e fare clic su Rimuovi.

  7. Fare clic su OK per chiudere le finestre di dialogo.

  8. Fare clic con il pulsante destro del mouse sul criterio destinatario e scegliere Applica criterio.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328738, "XADM: Applicazione dei criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328738.

  • 319065, "Utilizzo del Servizio aggiornamento destinatari di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319065.


Modalità del gruppo amministrativo sconosciuta
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per verificare la modalità del gruppo amministrativo, controllando l'attributo msExchAdminGroupMode dell'oggetto gruppo amministrativo nel contenitore Gruppi amministrativi di Active Directory. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchAdminGroupMode non equivale a 0, 1, o 2, verrà visualizzato un messaggio di errore.

In Exchange viene utilizzata la modalità del gruppo amministrativo per indicare se tale gruppo può includere i server di Exchange Server 5.5, di Exchange Server 2003, oppure di Exchange 2000 Server. Se il valore di questo attributo è diverso da 0, 1 o 2, è probabile che sia stato modificato manualmente dall'amministratore. Nel programma di installazione di Exchange o in Gestore di sistema di Exchange questo valore viene impostato correttamente.

È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per modificare l'attributo MSExchAdminGroupMode

  1. Utilizzo di un editor di Active Directory, ad esempio ADSI Edit, per individuare l'oggetto gruppo amministrativo in Active Directory.

    L'attributo MSExchAdminGroupMode è reperibile in:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. Digitare uno dei seguenti valori interi:

    0=modalità nativa (il gruppo amministrativo è stato creato utilizzando Exchange 2000 Server o Exchange Server 2003).

    1=modalità Exchange Server 5.5 (il gruppo amministrativo è stato creato utilizzando Exchange 5.5 Server e include solo i server di Exchange Server 5.5).

    2=modalità mista (il gruppo amministrativo può includere i server di Exchange Server 5.5, di Exchange 2000 Server oppure di Exchange Server 2003).

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo della Microsoft Knowledge Base 260745 "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


La configurazione di Authenticated Users è errata per l'ambiente Exchange ospitato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'ambiente Exchange Server è configurato come un ambiente Exchange ospitato. Se l'ambiente Exchange Server è un ambiente Exchange ospitato, Exchange Server Analyzer esegue una query in Active Directory per determinare se il gruppo Authenticated Users fa parte del gruppo Accesso compatibile precedente a Windows® 2000 nel dominio.

Se il gruppo Authenticated Users fa parte del gruppo Accesso compatibile precedente a Windows 2000, verrà visualizzato un avviso. Non si consiglia questa configurazione per una soluzione Exchange ospitata.

Per correggere questo errore rimuovendo il gruppo Authenticated Users dal gruppo di protezione Accesso compatibile precedente a Windows 2000

  1. Aprire Utenti e computer di Active Directory.

  2. Espandere il nodo del dominio e fare clic sul contenitore Builtin.

  3. Fare clic con il pulsante destro del mouse sul gruppo di protezione Accesso compatibile precedente a Windows 2000 e selezionare Proprietà.

  4. Fare clic sulla scheda Membri.

  5. Selezionare Utenti autenticati.

  6. Fare clic su Rimuovi.

  7. Fare clic su OK.

Per ulteriori informazioni sugli ambienti Exchange ospitati, consultare i seguenti articoli:

  • "Information for Hosters" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46307 (informazioni in lingua inglese).

  • "Chapter 23 - Hosted Service Environments" in Exchange Server 2000 Resource Kit all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46326 (informazioni in lingua inglese).


Mancata corrispondenza principale del certificato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nell'oggetto Server Certificate nel sistema del server Exchange per recuperare varie proprietà nei certificati X509. Per ciascun certificato SSL rilevato, Exchange Server Analyzer valuta l'attributo Principal per identificare il nome di dominio completo (FQDN) assegnato al certificato, ad esempio, www.microsoft.com.

Microsoft Exchange Server Analyzer rilascia un avviso se il nome di dominio completo Principal non corrisponde all'indirizzo o l'URL dell'host. L'avviso di mancata corrispondenza dell'attributo Principal nel certificato significa che gli utenti potrebbero non essere in grado di connettersi alle proprie cassette postali utilizzando Microsoft Office Outlook® Web Access per Exchange Server 2003, Outlook via Internet per Exchange Server 2007, ActiveSync di Exchange Server e RPC su HTTP.

Nota:
È necessario che un server disponga di un certificato server quando esegue un protocollo SSL. In caso contrario, il server potrebbe richiedere il certificato del client. Il certificato server contiene il nome del sito Web. Il browser verifica che il sito Web corrisponda al nome immesso. Ad esempio, se il sito Web è https://www.esempio.com, il nome del certificato deve essere www.esempio.com.

Potrebbe risultare una mancata corrispondenza se si verifica una delle seguenti condizioni:

  • Il certificato viene accidentalmente applicato al server errato

  • Il client accede ai dati su un server utilizzando l'URL host errato quando i server hanno più di un nome host

Per risolvere la mancata corrispondenza del nome del certificato

  • Verificare che il certificato SSL sia stata concesso e che sia stato applicato all'host corretto.

Per ulteriori informazioni

  • Per informazioni sull'utilizzo dei certificati con server virtuali in Exchange Server 2003, consultare l'articolo 823024 della Microsoft Knowledge Base "Utilizzo dei certificati con server virtuali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024.

  • Per informazioni su come utilizzare SSL e come ottenere e installare certificati server, consultare "Configurazione di Exchange Server 2003 per l'accesso client" nella Guida all'accesso client di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47568.

  • Per informazioni su come utilizzare SSL e come ottenere e installare certificati server per Exchange Server 2007, vedere "Come configurare SSL per Outlook via Internet" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80875.


La pianificazione di attivazione del contratto di connessione è stata impostata su Mai
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo activationStyle per ogni oggetto Contratto di connessione. L'attributo activationStyle rappresenta l'impostazione pianificata per il Contratto di connessione. Se la pianificazione è impostata su Mai, verrà visualizzato un avviso.

Se si è stabilito che il Contratto di connessione non è più necessario, è opportuno eliminarlo. In caso contrario, è opportuno configurarlo in modo che venga eseguito secondo una pianificazione appropriata.

Per risolvere il problema

  1. Fare clic su Start, scegliere Programmi, Strumenti di amministrazione, quindi fare clic su Active Directory Connector.

  2. Nel riquadro sinistro fare clic sul server Active Directory Connector (ADC) che ospita il Contratto di connessione da modificare.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse sul Contratto di connessione da modificare, quindi scegliere Proprietà.

  4. Selezionare la scheda Pianificazione.

  5. Impostare la pianificazione su Sempre o su Orari selezionati. Se si seleziona la seconda opzione, fare clic sulle aree appropriate della griglia per fare in modo che il Contratto di connessione sia eseguito negli orari selezionati.

Per ulteriori informazioni sulla configurazione di un Contratto di connessione destinatario bidirezionale, consultare l'articolo 296260 della Microsoft Knowledge Base "XGEN: Configurazione di un Contratto di connessione destinatario bidirezionale per utenti di Exchange 5.5" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260.


Il Contratto di connessione è isolato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se ciascun Contratto di connessione ha un valore valido per msExchHomeSyncService. Se Exchange Server Analyzer rileva che il Contratto di connessione non presenta un valore valido per questo asstributo, verrà visualizzato un avviso.

L'attributo msExchHomeSyncService contiene il server ADC (Active Directory Connector) in cui si trova il Contratto di connessione.

L'avviso verrà visualizzato se si rimuove un server ADC senza prima rimuovere l'ADC o i Contratti di connessione sul server ADC. Quando si rimuove il server ADC, la connessione tra i contratti di connessione e il server ADC verrà interrotta. Di conseguenza, non verranno replicati gli oggetti di cui sono responsabili i contratti di connessione. Se si utilizza lo snap-in di gestione di ADC in un altro server ADC, i contratti di connessione situati nel server ADC rimosso non verranno visualizzati. Tuttavia, questi contratti di connessione sono ancora presenti in Active Directory.

Per risolvere il problema, riassociare i contratti di connessione precedenti a un nuovo server ADC. Per eseguire questa operazione, è possibile creare un nuovo Contratto di connessione nel nuovo server ADC, quindi copiare l'attributo msExchHomeSyncService dal nuovo Contratto di connessione e incollarlo nel Contratto precedente.

Per riassociare un Contratto di connessione a un server ADC

  1. Avviare lo snap-in di gestione di ADC.

  2. Creare un nuovo Contratto di connessione.

  3. Avviare ADSI Edit (Active Directory Service Interfaces).

  4. Espandere Configurazione, quindi Servizi, Microsoft Exchange, infine fare clic su Connessioni di Active Directory.

  5. Nel riquadro destro aprire la finestra di dialogo Proprietà del Contratto di connessione appena creato.

  6. Nell'elenco a discesa Selezionare una proprietà da visualizzare fare clic su msExchHomeSyncService.

  7. Copiare l'intero attributo dalla casella Valori, quindi fare clic su OK.

  8. Aprire la finestra di dialogo Proprietà del Contratto di connessione da riassociare.

  9. Nell'elenco a discesa Selezionare una proprietà da visualizzare fare clic sull'attributo msExchHomeSyncService.

  10. Incollare il valore copiato nella casellaModifica attributo.

  11. Fare clic su Imposta, Applica, quindi su OK.

Per ulteriori informazioni sui contratti di connessione isolati, consultare l'articolo 319486 della Microsoft Knowledge Base "XADM: Contratti di connessione non visualizzati dopo la rimozione di Active Directory Connector" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319486.


Nome visualizzato predefinito modificato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo createDialog per ciascuna classe oggetto displaySpecifier. La classe oggetto displaySpecifier descrive i menu di scelta rapida e le pagine delle proprietà da utilizzare in Active Directory. Se Exchange Server Analyzer rileva che è stato impostato l'attributo LimitEmbeddingDepth, verrà visualizzato un messaggio di configurazione non predefinita.

Durante la creazione di un nuovo utente o di un nuovo oggetto contatto, il campo Nome completo è sempre generato secondo il formato Nome Cognome. A sua volta, al momento della creazione questo campo imposta il campo Nome visualizzato, pertanto si otterrà un elenco indirizzi globale con formato FirstName LastName.

Se si desidera, è possibile utilizzare un editor Active Directory, ad esempio ADSI Edit, per modificare le modalità di creazione del campo Nome visualizzato. ADSI Edit non solo modifica la modalità di creazione di questo campo, ma anche quella del campo Nome completo. Pertanto gli utenti sono visualizzati nel formato selezionato in Utenti e computer di Active Directory.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Prima di apportare queste modifiche, è necessario tenere presente che potrebbero provocare problemi. Per ulteriori informazioni su Exchange Server e Windows Server 2003, consultare l'articolo 276266 della Microsoft Knowledge Base "Modifiche di gruppo per utenti con caratteri limitati a LDAP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=276266.

Per modificare il formato di visualizzazione predefinito per gli utenti e gli oggetti contatto

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Fare clic con il pulsante destro del mouse sul nodo alto, quindi scegliere Connessione a.

  3. Modificare il Contesto dei nomi in "Contenitore di configurazione", quindi fare clic su OK per effettuare associazione e autenticazione.

  4. Espandere il nodo Contenitore di configurazione, quindi espandere il nodo Configurazione.

  5. Espandere il nodo cn=DisplaySpecifiers, quindi fare doppio clic su CN=409. Nota: 409 è l'ID delle impostazioni internazionali per l'inglese Stati Uniti. Se si opera in un ambiente internazionale, potrebbe essere necessario effettuare delle modifiche agli altri codici.

  6. Nel riquadro di destra, individuare ed eliminare CN=user-Display.

  7. Scorrere fino all'attributo facoltativo createDialog.

  8. Impostare l'attributo su %<sn>.%<givenName> quindi fare clic su Imposta. Nota: gli unici token che possono essere formattati sono %<sn>, %<givenName> e %<initials>.

  9. Fare clic su OK per chiudere la finestra di dialogo.

  10. Creare un nuovo utente in Active Directory per verificare che il Nome completo e il Nome visualizzato siano stati creati come previsto. Nota: in un ambiente a più domini, potrebbe essere necessario attendere il completamento della replica prima che lo strumento Utenti e computer di Active Directory visualizzi le modifiche apportate.

I passaggi elencati modificheranno il formato del nome visualizzato in Nome.Cognome. Inoltre, la procedura elencata sopra viene utilizzata per gli oggetti utente. Per gli oggetti contatto, modificare il passaggio 6 in visualizzazione Contatto.

Per ulteriori informazioni sull'utilizzo di uno script ADSI per l'esecuzione di tale attività, consultare l'articolo 277717 della Microsoft Knowledge Base "Modifica dei nomi visualizzatidegli utenti di Active Directory con lo script ADSI" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=277717.

La International Telecommunication Union (ITU) e la International Organization for Standardization (ISO) definiscono le tabelle codici. Per ulteriori informazioni, visitare le seguenti pagine Web delle organizzazioni ITU e ISO:

  • http://www.itu.int

  • http://www.iso.ch/iso/en/ISOOnline.openerpage

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sul supporto dei client Exchange localizzati, consultare l'articolo 150977 della Microsoft Knowledge Base "XADM: Supporto dei client Exchange localizzati" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=150977.


Il mantenimento degli elementi eliminati è stato disabilitato per l'archivio delle cassette postali
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore per l'attributo garbageCollPeriod di ciascun archivio delle cassette postali. Se Exchange Server Analyzer rileva che l'attributo garbageCollPeriod è impostato su 0 per un archivio delle cassette postali, verrà visualizzato un messaggio di configurazione ottimale.

La raccolta cestino è un processo di manutenzione interna di Exchange che consente di liberare spazio nel database dell'archivio delle cassette postali. Per impostazione predefinita, gli elementi eliminati vengono archiviati nel database dell'archivio delle cassette postali per un certo numero di giorni prima di essere eliminati definitivamente da Exchange. È possibile impostare la durata del periodo di mantenimento degli elementi eliminati utilizzando le impostazioni predefinite dell'archivio delle cassette postali oppure selezionando il numero di giorni in cui un elemento eliminato verrà mantenuto prima dell'eliminazione definitiva.

È possibile selezionare un numero compreso tra 0 e 24.855. Si consiglia di configurare l'impostazione su 7 giorni. Se il periodo di mantenimento degli elementi eliminati è impostato su 0, tali elementi verranno rimossi immediatamente dal server in modo definitivo. A meno che non esista un problema di spazio su disco, si consiglia di non disabilitare la funzione di mantenimento degli elementi eliminati. Seguire le procedure indicate di seguito per specificare il numero di giorni in cui gli elementi eliminati resteranno nell'archivio prima di essere rimossi definitivamente.

Per configurare il mantenimento elementi eliminati in Gestore di sistema di Exchange

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere il gruppo amministrativo o l'organizzazione, fare clic su Server e quindi su Archivio cassette postali.

  3. Fare clic con il pulsante destro del mouse sull'archivio delle cassette postali, quindi scegliere Proprietà.

  4. Nella scheda Limiti impostare il periodo di mantenimento degli elementi eliminati eseguendo le seguenti operazioni:

    • Per impostare un periodo di mantenimento per gli elementi eliminati, fare clic su Mantieni elementi eliminati per (giorni), quindi digitare un valore.

    • Per mantenere gli elementi fino all'esecuzione del backup, fare clic su Elimina definitivamente cassette postali ed elementi solo dopo il backup dell'archivio.

Per configurare il mantenimento elementi eliminati in Utenti e computer di Active Directory

  1. Aprire Utenti e computer di Active Directory.

  2. Nella struttura della console espandere il dominio.

  3. Fare doppio clic su Utenti oppure sul nodo contenente le informazioni sul destinatario che si desidera modificare.

  4. Nel riquadro dei dettagli fare doppio clic sul destinatario da modificare.

  5. Nella scheda Impostazioni generali di Exchange fare clic su Limiti di archiviazione.

  6. Nella finestra di dialogo Limiti di archiviazione in Mantenimento elementi eliminati fare clic per deselezionare la casella di controllo Usa impostazioni di archiviazione predefinite della cassetta postale, quindi digitare un valore in Mantieni elementi eliminati per (giorni).

    Per impedire che gli elementi eliminati vengano rimossi definitivamente prima del backup, selezionare la casella di controllo Elimina definitivamente elementi dopo il backup dell'archivio.

Per ulteriori informazioni sull'impostazione dei limiti di archiviazione delle cassette postali, consultare l'articolo 319583 della Microsoft Knowledge Base "HOW TO: Configurazione dei limiti di archiviazione per le cassette postali in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319583.


Il mantenimento degli elementi eliminati è stato disabilitato per l'archivio delle cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore di garbageCollPeriod di ciascun archivio delle cartelle pubbliche. Se Exchange Server Analyzer rileva che l'attributo garbageCollPeriod è impostato su 0 per un archivio delle cartelle pubbliche, verrà visualizzato un messaggio di configurazione ottimale.

La raccolta cestino è un processo di manutenzione interna di Exchange che consente di liberare spazio nel database dell'archivio delle cartelle pubbliche. Per impostazione predefinita, gli elementi eliminati vengono archiviati nel database dell'archivio delle cartelle pubbliche per un certo numero di giorni prima di essere eliminati definitivamente da Exchange. È possibile impostare la durata del periodo di mantenimento degli elementi eliminati utilizzando le impostazioni predefinite dell'archivio delle cartelle pubbliche oppure selezionando il numero di giorni in cui un elemento eliminato verrà mantenuto prima dell'eliminazione definitiva.

È possibile selezionare un numero compreso tra 0 e 24.855. Si consiglia di configurare l'impostazione su 7 giorni. Se il periodo di mantenimento degli elementi eliminati è impostato su 0, tali elementi verranno rimossi immediatamente dal server in modo definitivo. A meno che non esista un problema di spazio su disco, si consiglia di non disabilitare la funzione di mantenimento degli elementi eliminati.

Per configurare il mantenimento degli elementi eliminati in Gestore di sistema di Exchange

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere il gruppo amministrativo o i server, fare clic su Server e quindi su Archivio cartelle pubbliche.

  3. Fare clic con il pulsante destro del mouse sull'archivio delle cartelle pubbliche, quindi scegliere Proprietà.

  4. Nella scheda Limiti impostare il periodo di mantenimento degli elementi eliminati eseguendo le seguenti operazioni:

    • Per impostare un periodo di mantenimento per gli elementi eliminati, fare clic su Mantieni elementi eliminati per (giorni), quindi digitare un valore.

    • Per mantenere gli elementi fino all'esecuzione del backup, fare clic su Elimina definitivamente elementi dopo il backup dell'archivio.

Per ulteriori informazioni sull'impostazione dei limiti di archiviazione per le cartelle pubbliche, consultare l'articolo 319439 della Microsoft Knowledge Base: "HOW TO: Configurazione dei limiti di archiviazione nelle cartelle pbbliche in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319439.


Il mantenimento delle cassette postali eliminate è disabilitato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchMailboxRetentionPeriod di ciascun archivio delle cassette postali. Se Exchange Server Analyzer rileva che l'attributo msExchMailboxRetentionPeriod di uno qualsiasi degli archivi delle cassette postali è impostato su 0, verrà visualizzato un messaggio di configurazione ottimale.

L'attributo msExchMailboxRetentionPeriod indica il numero di giorni durante i quali le cassette postali eliminate verranno mantenute prima di essere eliminate definitivamente. È possibile selezionare un numero compreso tra 0 e 24.855.. L'impostazione predefinita per il mantenimento delle cassette postali eliminate è 30 giorni. Se il periodo di mantenimento delle cassette postali è impostato su 0, tali cassette verranno rimosse immediatamente dal server in modo definitivo. A meno che non esista un problema di spazio su disco, si consiglia di non disabilitare la funzione di mantenimento delle cassette postali.

Per configurare il mantenimento delle cassette postali

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo, Server e infine il proprio gruppo di archiviazione. Se il nodo Gruppi amministrativi non viene visualizzato in Gestore di sistema di Exchange, espandere Server e quindi il proprio gruppo di archiviazione.

  3. Fare clic con il pulsante destro del mouse sulla cassetta postali che si desidera configurare e scegliere Proprietà.

  4. Nella scheda Limiti immettere un periodo di mantenimento delle cassette postali nel campo Mantieni cassette postali eliminate per (giorni).

  5. Fare clic su OK per salvare le modifiche.
Nota:
È possibile eseguire il recupero di una cassetta postale, se il relativo periodo di mantenimento non è scaduto e l'oggetto utente associato non è stato eliminato.

Per ulteriori informazioni sul recupero delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 274343, "Recupero di una cassetta postale eliminata in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=274343.

  • 813337, "Recupero o ripristino di una singola cassetta postale in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=813337.

  • 823176, "Recupero o ripristino di una singola cassetta postale in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823176.


Il dominio presenta una firma di Exchange sconosciuta
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare la versione di DomainPrep eseguita per ultima nel dato dominio. Il numero di versione di DomainPrep funge da firma di Exchange per il dominio. Exchange Server Analyzer esamina l'attributo objectVersion dell'oggetto Oggetti di sistema di Exchange del dato dominio. Sono possibili due numeri interi validi:

  • Per Exchange 2000 Server, il valore objectVersion è 4406.

  • Per Exchange Server 2003, il valore objectVersion è 6936.

  • Per Exchange Server 2007, il valore objectVersion è 10628.

Se Exchange Server Analyzer non rileva uno dei valori sopra indicati per l'attributo objectVersion, verrà visualizzato un messaggio di errore.

Questo valore risulterà probabilmente errato se è stata installata una versione non definitiva di Exchange 2000 Server o Exchange Server 2003 nel dato dominio, ma non è stata eseguita la versione rilasciata di DomainPrep.

Nota:
In Microsoft Exchange 2000 Server e Exchange Server 2003 venivano eseguiti i passaggi di preparazione di Active Directory mediante l'esecuzione dei programmi di installazione /forestprep e /domainprep. In Exchange 2007 non sono disponibili le opzioni /forestprep e /domainprep. In Exchange Server 2007 viene eseguito il processo di installazione /PrepareDomain, oppure l'installazione guidata, con un account che dispone delle autorizzazioni richieste per preparare Active Directory e il dominio.

Per correggere questo errore in Exchange 2000 Server o Exchange Server 2003, eseguire la versione finale di Exchange 2000 Server DomainPrep, Exchange Server 2003 DomainPrep, la versione finale del processo PrepareDomain o l'installazione guidata di Exchange Server 2007. L'account utilizzato per eseguire DomainPrep, PrepareDomain o l'installazione guidata deve essere un membro del gruppo di protezione Domain Admins nel dominio locale e un amministratore del computer locale.

  • Il dominio principale.

  • Tutti i domini che contengono computer Exchange 2000 Server o Exchange Server 2003.

  • Tutti i domini che contengono oggetti (utenti e gruppi) abilitati per le cassette postali Exchange 2000 Server o Exchange Server 2003, anche se nel dominio non è installato un server di Exchange.

  • Tutti i domini che contengono server di catalogo globale potenzialmente utilizzabili dai componenti con accesso diretto a Exchange.

  • Tutti i domini che contengono utenti e gruppi di Exchange 2000 Server o Exchange Server 2003 che vengono utilizzati per gestire l'organizzazione di Exchange.

Per eseguire DomainPrep per Exchange 2000 Server o Exchange Server 2003

  1. Inserire il CD di Exchange nell'unità CD-ROM. DomainPrep può essere eseguito su qualsiasi computer del dominio.

  2. Al prompt dei comandi, digitare <unità>:\setup\i386\setup /DomainPrep, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti verificare che Operazione sia impostato su DomainPrep. In caso contrario, fare clic sulla freccia a discesa e scegliere DomainPrep. Fare clic su Avanti.

  7. Nella pagina di completamento dell'installazione guidata di Microsoft Exchange, fare clic su Fine.

Per eseguire PrepareDomain per Exchange Server 2007

  1. Seguire la procedura passo passo riportata in "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.

Per ulteriori informazioni sull'esecuzione di Exchange Server 2003 DomainPrep, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sull'esecuzione di Exchange 2000 Server DomainPrep, consultare "Microsoft Exchange 2000 Server Installation and Setup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=5906 (informazioni in lingua inglese).

Per ulteriori informazioni sulla preparazione di Active Directory e dei domini per Exchange Server 2007, vedere "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.


Sul controller di dominio è in esecuzione Virtual Server 2005 con Exchange Server installato come Guest
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se il valore della chiave Model è impostato su Virtual machine.

Exchange Server Analyzer controlla inoltre la presenza del seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Inoltre, Exchange Server Analyzer legge la chiave Domain Role di Win32_ComputerSystem nel computer fisico che esegue Microsoft Virtual Server 2005. Un valore maggiore di 3 indica che il computer fisico è un controller di dominio.

Se Exchange Server Analyzer rileva che la chiave Model contiene la stringa Virtual Machine, che il ramo del Registro di sistema indicato sopra esiste e che Domain Role è maggiore di 3, verrà visualizzato un messaggio di errore.

Il valore Virtual Machine per la chiave Model indica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Virtual Server 2005 o Microsoft Virtual PC 2004. Poiché il ramo del Registro di sistema indicato sopra viene creato esclusivamente da Virtual Server 2005, la sua esistenza implica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Virtual Server 2005.

Microsoft non supporta l'esecuzione di versioni di Exchange Server su un macchina virtuale o un emulatore. Questo vale per Exchange Server in esecuzione su Virtual Server 2005, Virtual PC 2004 o altri programmi di computer virtuali di terze parti. Le piattaforme Exchange Server sono state progettate e testate per essere eseguite solo su hardware fisico, in particolare le piattaforme hardware elencate nel catalogo di Windows Server alla pagina http://go.microsoft.com/fwlink/?linkid=17219.

Inoltre, l'esecuzione di Exchange come Guest di Microsoft Virtual Server 2005 su un controller di dominio non è consigliabile in quanto non consente un'adeguata ridondanza in tutti i servizi.

Per risolvere il problema

  1. Spostare le cassette postali dal server di Exchange in esecuzione su Virtual Server 2005 a un computer Exchange Server non virtuale.

  2. Se necessario, spostare le cartelle pubbliche e trasferire i ruoli contenuti dal server virtuale di Exchange.

  3. Disinstallare Exchange dal macchina virtuale per non concedere l'autorizzazione ed eseguire la rimozione dall'infrastruttura di Exchange e dal servizio directory di Active Directory®.

Per ulteriori informazioni sullo spostamento delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.

  • 224975, "XADM: Differenze tra i metodi di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975.

Per ulteriori informazioni sul supporto per i computer Exchange Server che funzionano in ambienti virtuali, consultare l'articolo 320220 della Microsoft Knowledge Base "Criteri di supporto per i prodotti software Microsoft in esecuzione con software di virtualizzazione dell'hardware di terze parti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

Per ulteriori informazioni su Microsoft Virtual Server 2005, consultare il sito Web http://go.microsoft.com/fwlink/?linkid=34938.

Per ulteriori informazioni su Microsoft Virtual PC 2004, consultare il sito Web http://go.microsoft.com/fwlink/?linkid=34663.


Il ruolo FSMO per la denominazione dei domini non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo fSMORoleOwner del master operazioni di denominazione di dominio nel contesto dei nomi di configurazione. Ad esempio, nel dominio contoso.com, l'attributo fSMORoleOwner per il master delle operazioni di denominazione di dominio è un attributo di CN=Partitions,CN=Configuration,DC=contoso,DC=com. Quindi, tramite Exchange Server Analyzer verrà tentato di stabilire una connessione LDAP (Lightweight Directory Access Protocol) alla porta TCP 389 sul controller di dominio che riveste questo ruolo. Se non è possibile stabilire la connessione a questo controller di dominio, verrà visualizzato un messaggio di errore.

Il master di denominazione di dominio è un ruolo di master operazioni esteso a tutte le strutture poiché gestisce l'aggiunta e la rimozione di tutte le partizioni della directory, indipendentemente dal dominio, nella gerarchia della struttura. Il controller di dominio con il ruolo di master di denominazione di dominio è l'unico controller di dominio che può effettuare le seguenti operazioni:

  • Aggiungere nuovi domini all'insieme di strutture.

  • Rimuovere i domini esistenti dall'insieme di strutture.

  • Aggiungere o rimuovere oggetti con riferimento incrociato da directory esterne.

Nell'intero insieme di strutture può esistere un unico master per la denominazione dei domini.

Per risolvere il problema

  1. Verificare che il server di elenchi in linea specificato nel messaggio di errore sia in linea e accessibile dai server di Exchange nell'organizzazione.

  2. Se il server di elenchi in linea non dispone dell'autorizzazione, è necessario assegnare il ruolo di master di denominazione di dominio a un altro controller di dominio.

Per ulteriori informazioni sul trasferimento del ruolo di master operazioni di denominazione di dominio da un controller di dominio a un altro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801 "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows Server 2000, consultare l'articolo 255690 "HOW TO: Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Ruolo FSMO per la denominazione dei domini non trovato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare l'attributo fSMORoleOwner del master operazioni di denominazione di dominio nel contesto dei nomi di configurazione. Ad esempio, nel dominio contoso.com, fSMORoleOwner per il master per la denominazione dei domini è un attributo di CN=Partitions, CN=Configuration, DC=contoso, DC=com Tramite Exchange Server Analyzer si tenterà di stabilire una connessione LDAP (Lightweight Directory Access Protocol) con il controller di dominio. Se Exchange Server Analyzer rileva che il controller di dominio specificato nell'attributo fSMORoleOwner non risponde, verrà visualizzato un messaggio di errore.

Il controller di domino del master di denominazione di dominio controlla l'aggiunta o la rimozione di domini nell'insieme di strutture. Nell'intero insieme di strutture può esistere un unico master per la denominazione dei domini.

Per l'insieme di strutture di Active Directory è necessario definire un master di denominazione di dominio. Il programma di installazione di Exchange e di Exchange Service Pack non verrà eseguito correttamente se il controller del dominio master di denominazione del dominio non è in linea durante l'installazione. Se il controller di dominio elencato come master di denominazione di dominio non in linea, deve essere portato nuovamente in linea.

Per risolvere il problema

  1. Verificare che il server Active Directory designato sia fisicamente presente.

  2. Se il server di elenchi in linea non dispone dell'autorizzazione, assegnare il ruolo di master di denominazione di dominio a un altro controller di dominio.

Per ulteriori informazioni sull'assegnazione del ruolo di master di denominazione di dominio a un altro controller di dominio, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801 "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows Server 2000, consultare l'articolo 255690 "HOW TO: "Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Errore nella risoluzione dei nomi tramite DNS per il server di elenchi in linea
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool tenta di eseguire una query in Domain Name System (DNS) per ricercare i server DNS configurati per ogni servizio directory di Active Directory®. Questa connessione viene effettuata mediante un elaboratore di oggetti personalizzati su cui viene eseguita una richiesta di risoluzione dei nomi e vengono analizzati i risultati. Se Exchange Server Analyzer non riceve un indirizzo IP nell'ambito dei risultati della query, verrà visualizzato un messaggio di errore.

Tale errore indica che non è stato rilevato un server di elenchi in linea in DNS. Sia Exchange Server che Active Directory richiedono la corretta configurazione del DNS per funzionare. I problemi relativi alla risoluzione e registrazione DNS possono provocare effetti diffusi sulla capacità di invio, ricezione e recapito dei messaggi.

Per assicurarsi che Active Directory e Exchange Server funzionino correttamente, è necessario configurare in modo appropriato il DNS. Per una descrizione più dettagliata sulla configurazione DNS per Active Directory, consultare l'articolo 237675 della Microsoft Knowledge Base "Configurazione di Domain Name System (DNS) per Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675.

Per risolvere il problema

  1. Analizzare le seguenti voci di configurazione per assicurare che il DNS funzioni e che le voci DNS di Active Directory siano registrate correttamente:

    • Configurazione IP DNS

    • Aggiornamenti dinamici delle zone

    • Server di inoltro DNS

  2. Verificare l'esistenza di una voce Root Zone. Visualizzare le zone Ricerca diretta nella console di DNS Management. Dovrebbe essere presente una voce per il dominio. Possono esistere altre voci di zona. Non dovrebbe essere presente una zona punto ("."). Se lo fosse, eliminare la zona punto ("."), poiché identifica il server DNS come server principale. Normalmente un dominio di Active Directory che richiede accesso esterno (Internet) non dovrebbe essere configurato come server DNS principale. Registrare di nuovo, manualmente, l'indirizzo IP del server Exchange utilizzando Ipconfig /registerdns nel server di elenchi in linea dopo aver eliminato il punto ("."). Potrebbe essere anche necessario riavviare il servizio Netlogon.

  3. Ripopolare manualmente le voci DNS di Active Directory utilizzando netdiag /fix nel server di elenchi in linea.

Per ulteriori informazioni sull'utilizzo di DNS con Active Directory, consultare l'articolo 323418 della Microsoft Knowledge Base, "HOW TO: Integrare DNS con un'infrastruttura DNS esistente se Active Directory è attivato in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418.

Per ulteriori informazioni sulla risoluzione dei problemi relativi a DNS e Active Directory, consultare l'articolo 260371 della Microsoft Knowledge Base, "Risoluzione dei problemi nell'installazione comune di Active Directory in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371.


dSHeuristics non è impostato correttamente per l'ambiente Exchange ospitato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se si tratta di una distribuzione di Exchange ospitata. Se la distribuzione di Exchange viene eseguita in un ambiente ospitato, Exchange Server Analyzer esegue una query in Active Directory per determinare se l'attributo dSHeuristics nel contenitore Servizio directory è impostato correttamente per una distribuzione di Exchange ospitata.

Se il valore di dSHeuristics non è pari a 1, verrà visualizzato un avviso. In un ambiente Exchange ospitato l'attributo dSHeuristics deve essere impostato su 1.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Utilizzare un editor di Active Directory, ad esempio ADSI Edit, per individuare l'oggetto servizio directory in Active Directory.

    L'attributo dSHeuristics è reperibile in:

    CN=Configuration, CN=Services, CN=Windows NT, CN=Directory Service

  2. Immettere il valore 1 per dSHeuristics.

Per ulteriori informazioni sugli ambienti Exchange ospitati, consultare i seguenti articoli:

  • "Information for Hosters" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46307 (informazioni in lingua inglese).

  • "Hosted Service Environments" nel Resource Kit di Exchange Server 2000 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46326.


Il contenitore Oggetti di sistema di Microsoft Exchange duplicato esiste in Active Directory
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se esiste il contenitore Oggetti di sistema di Microsoft Exchange esiste nel contesto dei nomi di dominio.

Se Exchange Server Analyzer rileva un duplicato del contenitore Oggetti di sistema di Microsoft Exchange in Active Directory, verrà visualizzato un messaggio di errore: "Il dominio di Active Directory risulta preparato per Exchange ma esistono più contenitori Oggetti di sistema di Microsoft Exchange. Potrebbe essere necessaria l'eliminazione".

Questo problema può verificarsi in ambienti Exchange Server nei quali:

  • Un Contratto di connessione bidirezionale di un server ADC tra Active Directory ed Exchange Server 5.5 è stato eliminato e sostituito.

  • Un nuovo Contratto di connessione per server ADC unidirezionale da Exchange Server 5.5 ad Active Directory è attivo.

  • È stata effettuata la migrazione di un ambiente a modalità mista con Exchange Server 5.5 in esecuzione a un ambiente Exchange Server 2003.

  • È stata effettuata una migrazione da un server di posta esterno a Exchange Server 2003.

Quando viene visualizzato questo messaggio di errore, è necessario eliminare l'unità organizzativa (OU) o il contenitore Oggetti di sistema di Microsoft Exchange duplicato non corretto. Se esiste un contenitore Oggetti di sistema di MicrosoftExchange duplicato, non è possibile risolvere il problema eseguendo di nuovo DomainPrep. È necessario identificare ed eliminare il contenitore duplicato non corretto.

Per rimuovere il contenitore Oggetti di sistema di Microsoft Exchange duplicato

  1. Accedere al controller di dominio con credenziali ammnistrative.

  2. Fare clic su Start, scegliere Programmi, Strumenti di amministrazione, quindi fare clic su Utenti e computer di Active Directory.

  3. Nel riquadro della console di gestione Utenti e computer di Active Directory, dal menu della barra degli strumenti fare clic su Visualizza e scegliere Avanzate.

  4. Nel riquadro della console di gestione Utenti e computer di Active Directory, individuare il contenitore o l'unità organizzativa (UO) Oggetti di sistema di Microsoft Exchange duplicati non corretti.

  5. Verificare che il contenitore o unità organizzativa non contenga oggetti Active Directory validi.

  6. Fare clic con il pulsante destro del mouse sul contenitore o unità organizzativa e fare clic su Elimina.

  7. Confermare l'eliminazione facendo clic su Sì nella finestra di dialogo di Active Directory.

    Nota:
    Se si desidera che la modifica venga immediatamente replicata, è necessario avviare manualmente la replica tra i controller di dominio.

Per ulteriori informazioni su questo problema in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 316280, "XADM: Descrizione dell'attributo ADC Global Names" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=316280.

  • 252228, "XADM: ADC potrebbe creare oggetti duplicati" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=252228.

  • 253800, "XADM: ADC potrebbe creare oggetti duplicati in Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253800.

  • 274480, "XADM: Oggetti duplicati creati durante la replica di oggetti da Exchange Server 5.5 ad Active Directory di Windows 2000++" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=274480.

  • 288578, "XADM: ADC crea account duplicati in Exchange Server 5.5 e in Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288578.


Errore durante l'accesso ad Active Directory
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool ha determinato che potrebbe non essere disponibile un controller di dominio del servizio directory di Active Directory®. Verificare che esista connettività di rete a un controller di dominio Active Directory.

Per risolvere il problema

  • Se è stato specificato un controller di dominio Active Directory in Exchange Server Analyzer, tentare di eseguire la connessione senza specificare un controller di dominio.

  • Se non è stato specificato alcun controller di dominio, specificarne uno disponibile e in esecuzione.


Errore di accesso ai gruppi amministrativi di Exchange
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool ha rilevato che un'organizzazione di Exchange è stata installata nell'insieme di strutture del servizio directory di Active Directory® e che l'accesso alle informazioni di configurazione dell'organizzazione di Exchange in Active Directory è stato eseguito correttamente. Tuttavia non sono stati rilevati gruppi amministrativi contenenti server di Exchange.

Per risolvere il problema:

  • Verificare di disporre delle autorizzazioni appropriate in Active Directory per accedere al contenitore per i gruppi amministrativi di Exchange.

  • Se la workstation dalla quale eseguito Exchange Server Analyzer appartiene a un insieme di strutture di Active Directory diverso oppure non si è eseguito l'accesso con un account di dominio, sarà necessario eseguire la connessione a un controller di dominio di Active Directory per un insieme di strutture contenente server di Exchange.


Errore durante l'accesso al contenitore della configurazione di Exchange
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool ha rilevato che il contenitore della configurazione di Exchange è inaccessibile. Le informazioni sulla configurazione dei server, quelle relative ai gruppi amministrativi e le informazioni sulle organizzazioni di Exchange vengono archiviate nel contesto dei nomi di configurazione all'interno del servizio directory di Active Directory®. Per accedere alle informazioni sulla configurazione di Exchange, occorre disporre delle autorizzazioni necessarie per leggere il ramo di Microsoft Exchange relativo al contenitore della configurazione di Active Directory.

Per risolvere il problema:

  • Assicurarsi di disporre delle autorizzazioni necessarie per leggere il contenitore della configurazione di Active Directory.

  • Assicurarsi di disporre della connettività di rete per accedere a un controller di dominio Active Directory.


Al gruppo di protezione Everyone non viene negato il diritto di creare cartelle pubbliche principali
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'identificatore di protezione (SID) per il gruppo di protezione Everyone è elencato nell'attributo ntSecurityDescriptor dell'oggetto organizzazione di Exchange. Se Exchange Server Analyzer rileva che il SID del gruppo Everyone è presente nell'attributo ntSecurityDescriptor dell'oggetto organizzazione, verrà visualizzato un avviso. Questo avviso indica che al gruppo Everyone non è stato negato il diritto di creare cartelle pubbliche principali.

In Exchange 2000 Server il diritto di creare cartelle pubbliche principali viene concesso per impostazione predefinita. Tuttavia, se si esegue la versione di ForestPrep per Exchange Server 2003 o la versione di PrepareAD per Exchange Server 2007, al gruppo di protezione Everyone non verrà concesso il diritto di creare cartelle pubbliche principali. La funzionalità che consente di negare tale diritto è stata implementata per motivi di protezione. Se si consente al gruppo di protezione Everyone di creare cartelle pubbliche principali, l'organizzazione potrebbe essere soggetta ad attacchi di tipo DoS (Denial of Service).

Pertanto, si consiglia di negare al gruppo di protezione Everyone il diritto di creare cartelle pubbliche principali. Se si dispone di Exchange Server 2003 o Exchange Server 2007, è necessario eseguire la versione di ForestPrep per Exchange Server 2003 o la versione di PrepareAD per Exchange Server 2007, rispettivamente. È possibile eseguire la versione di ForestPrep per Exchange Server 2003 anche in un ambiente Exchange 2000 Server. Tuttavia, le successive installazioni di Exchange 2000 Server comporteranno il ripristino delle autorizzazioni per consentire al gruppo di protezione Everyone di creare cartelle pubbliche principali.

Se non si dispone di Exchange Server 2003 o Exchange Server 2007, è possibile impostare questa autorizzazione manualmente. Tenere presente che le successive installazioni di Exchange 2000 Server comporteranno il ripristino di tale autorizzazione. Pertanto sarà necessario configurare questa autorizzazione manualmente al termine di ogni installazione di Exchange 2000 Server. Prima di impostare l'autorizzazione, è necessario abilitare la visualizzazione della scheda Protezione in Gestore di sistema di Exchange. Per eseguire questa operazione, occorre aggiungere la voce ShowSecurityPage al Registro di sistema sul computer Exchange Server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per aggiungere la voce ShowSecurityPage al Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

  3. Fare clic su Modifica, selezionare Nuovo, quindi fare clic su Valore DWORD.

  4. Denominare il nuovo valore ShowSecurityPage, quindi premere INVIO.

  5. Fare doppio clic su ShowSecurityPage, digitare 1 nel campo Dati valore, quindi fare clic su OK.

Per negare manualmente al gruppo di protezione Everyone il diritto di creare cartelle pubbliche principali in un ambiente Exchange 2000 Server

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic con il pulsante destro del mouse su Organization_Name, quindi scegliere Proprietà.

  3. Nella pagina delle proprietà di Organization_Name fare clic sulla scheda Protezione.

  4. Nella scheda Protezione in Utenti e gruppi selezionare Everyone. Nella finestra di dialogo Permissions for Everyone scorrere verso il basso fino all'autorizzazione Create top-level public folder, deselezionare la casella di controllo nella colonna Consenti, quindi fare clic su Applica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'esecuzione di Exchange Server 2003 ForestPrep, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sull'esecuzione di PrepareAD per Exchange Server 2007, vedere "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.

Per ulteriori informazioni su come negare al gruppo di protezione Everyone i diritti per creare una cartella pubblica principale in Exchange 2000 Server, consultare l'articolo 328808 della Microsoft Knowledge Base "HOW TO: Rimozione dell'autorizzazione utente per la creazione di una cartella pubblica principale in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328808.


Problema del contenitore di dominio di Exchange
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se esiste il contenitore Oggetti di sistema di Microsoft Exchange nel contesto dei nomi di dominio. Se Exchange Server Analyzer rileva che il contenitore Oggetti di sistema di Microsoft Exchange non esiste oppure è formato in modo errato o non valido, verrà visualizzato un messaggio di errore.

Il contenitore Oggetti di sistema di Microsoft Exchange viene creato in ogni dominio in cui è in esecuzione Exchange DomainPrep.

È necessario eseguire DomainPrep nel dominio in cui viene rilevato l'errore. Il nome del dominio in cui manca il contenitore Oggetti di sistema di Microsoft Exchange è elencato nel file di output di Exchange Server Analyzer.

L'account da utilizzare per eseguire DomainPrep deve essere un membro del gruppo di protezione Domain Admins nel dominio locale e un amministratore del computer locale.

In genere, DomainPrep va eseguito nei seguenti domini:

  • Il dominio principale.

  • Tutti i domini che contengono computer Exchange 2000 Server o Exchange Server 2003.

  • Tutti i domini che contengono oggetti (utenti e gruppi) abilitati per le cassette postali Exchange 2000 Server o Exchange Server 2003, anche se nel dominio non è installato un server di Exchange.

  • Tutti i domini che contengono server di catalogo globale potenzialmente utilizzabili dai componenti con accesso diretto a Exchange.

  • Tutti i domini che contengono utenti e gruppi di Exchange 2000 Server o Exchange Server 2003 che vengono utilizzati per gestire l'organizzazione di Exchange.

Per eseguire DomainPrep

  1. Inserire il CD di Exchange nell'unità CD-ROM. DomainPrep può essere eseguito su qualsiasi computer del dominio.

  2. Al prompt dei comandi, digitare <unità>:\setup\i386\setup /DomainPrep, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti verificare che Operazione sia impostato su DomainPrep. In caso contrario, fare clic sulla freccia a discesa e scegliere DomainPrep. Fare clic su Avanti.

  7. Nella pagina di completamento dell'installazione guidata di Microsoft Exchange fare clic su Fine.

Per ulteriori informazioni sull'esecuzione di Exchange 2003 DomainPrep, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sull'esecuzione di Exchange 2000 Server DomainPrep, consultare "Microsoft Exchange 2000 Server Installation and Setup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=5906 (informazioni in lingua inglese).


Il gruppo Exchange Domain Servers non è stato rilevato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo ntSecurityDescriptor dell'oggetto Oggetti di sistema di Microsoft Exchange per determinare quale versione di DomainPrep è stata eseguita nel dominio.

Sono possibili due numeri interi validi:

  • Per Exchange 2000 Server, il valore di ntSecurityDescriptor è 4406.

  • Per Exchange Server 2003, il valore di ntSecurityDescriptor è 6936.

Se viene rilevato che è stata usata una delle versioni di DomainPrep indicate, Exchange Server Analyzer esegue una query in Active Directory per determinare il valore dell'attributo objectGuid dell'oggetto Oggetti di sistema di Microsoft Exchange per determinare se il gruppo Exchange Domain Servers esiste. Se Exchange Server Analyzer stabilisce che questo gruppo non esiste, verrà visualizzato un messaggio di errore.

Per risolvere questo errore, eseguire la versione finale di Exchange 2000 Server DomainPrep o Exchange Server 2003 DomainPrep. L'account da utilizzare per eseguire DomainPrep deve essere un membro del gruppo di protezione Domain Admins nel dominio locale e un amministratore del computer locale.

DomainPrep va eseguito nei seguenti domini:

  • Il dominio principale.

  • Tutti i domini che contengono computer Exchange 2000 Server o Exchange Server 2003.

  • Tutti i domini che contengono oggetti (utenti e gruppi) abilitati per le cassette postali Exchange 2000 Server o Exchange Server 2003, anche se nel dominio non è installato un server di Exchange.

  • Tutti i domini che contengono server di catalogo globale potenzialmente utilizzabili dai componenti con accesso diretto a Exchange.

  • Tutti i domini che contengono utenti e gruppi di Exchange 2000 Server o Exchange Server 2003 che vengono utilizzati per gestire l'organizzazione di Exchange.

Per eseguire DomainPrep

  1. Inserire il CD di Exchange nell'unità CD-ROM. DomainPrep può essere eseguito su qualsiasi computer del dominio.

  2. Al prompt dei comandi, digitare <unità>:\setup\i386\setup /DomainPrep, dove <unità> è la lettera corrispondente all'unità CD.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti verificare che Operazione sia impostato su DomainPrep. In caso contrario, fare clic sulla freccia a discesa e scegliere DomainPrep. Fare clic su Avanti.

  7. Nella pagina di completamento dell'installazione guidata di Microsoft Exchange fare clic su Fine.

Per ulteriori informazioni sull'esecuzione di Exchange Server 2003 DomainPrep, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sull'esecuzione di Exchange 2000 Server DomainPrep, consultare "Microsoft Exchange 2000 Server Installation and Setup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=5906 (informazioni in lingua inglese).


Il gruppo Exchange Enterprise Servers non è stato rilevato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo ntSecurityDescriptor dell'oggetto Oggetti di sistema di Microsoft Exchange per determinare la versione di DomainPrep che è stata eseguita nel dominio.

Sono possibili due numeri interi validi:

  • Per Exchange 2000 Server, il valore di ntSecurityDescriptor è 4406.

  • Per Exchange Server 2003, il valore di ntSecurityDescriptor è 6936.

Se viene rilevato che è stata usata una delle versioni di DomainPrep indicate, Exchange Server Analyzer esegue una query in Active Directory per determinare il valore dell'attributo objectGuid dell'oggetto Oggetti di sistema di Microsoft Exchange per determinare se il gruppo Exchange Enterprise Servers esiste. Se Exchange Server Analyzer stabilisce che questo gruppo non esiste, verrà visualizzato un messaggio di errore.

Per risolvere questo errore, eseguire la versione finale di Exchange 2000 Server DomainPrep o Exchange Server 2003 DomainPrep. L'account da utilizzare per eseguire DomainPrep deve essere un membro del gruppo di protezione Domain Admins nel dominio locale e un amministratore del computer locale.

DomainPrep va eseguito nei seguenti domini:

  • Il dominio principale.

  • Tutti i domini che contengono computer Exchange 2000 Server o Exchange Server 2003.

  • Tutti i domini che contengono oggetti (utenti e gruppi) abilitati per le cassette postali Exchange 2000 Server o Exchange Server 2003, anche se nel dominio non è installato un server di Exchange.

  • Tutti i domini che contengono server di catalogo globale potenzialmente utilizzabili dai componenti con accesso diretto a Exchange.

  • Tutti i domini che contengono utenti e gruppi di Exchange 2000 Server o Exchange Server 2003 che vengono utilizzati per gestire l'organizzazione di Exchange.

Per eseguire DomainPrep

  1. Inserire il CD di Exchange nell'unità CD-ROM. DomainPrep può essere eseguito su qualsiasi computer del dominio.

  2. Al prompt dei comandi, digitare <unità>:\setup\i386\setup /DomainPrep, dove <unità> è la lettera corrispondente all'unità CD.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti verificare che Operazione sia impostato su DomainPrep. In caso contrario, fare clic sulla freccia a discesa e scegliere DomainPrep. Fare clic su Avanti.

  7. Nella pagina di completamento dell'installazione guidata di Microsoft Exchange fare clic su Fine.

Per ulteriori informazioni sull'esecuzione di Exchange Server 2003 DomainPrep, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sull'esecuzione di Exchange 2000 Server DomainPrep, consultare "Microsoft Exchange 2000 Server Installation and Setup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=5906 (informazioni in lingua inglese).


Oggetto di Exchange nel contenitore Lost and Found
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-01

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se sono presenti oggetti nel contenitore LostAndFoundConfig del contenitore Configuration. Se Exchange Server Analyzer rileva che nel contenitore LostAndFoundConfig è presente un oggetto, verrà visualizzato un messaggio di errore, insieme all'oggetto rilevato e alla classe a cui appartiene.

Il contenitore LostAndFoundConfig contiene gli oggetti che non possono essere risolti da Active Directory. Assicurarsi di eliminare gli oggetti del contenitore LostAndFoundConfig, poiché Exchange tenterà di utilizzarli. Ad esempio, quando Exchange esegue una query in Active Directory per una classe oggetto (ovvero, Server), tutti gli oggetti, indipendentemente dal fatto che appartengano o meno al contenitore LostAndFoundConfig, vengono restituiti come oggetti validi. Di conseguenza, è possibile che Exchange tenti di collegarsi al server presente nel contenitore the LostAndFoundConfig invece che all'oggetto reale. Ciò potrebbe provocare comportamenti anomali di Exchange e anche errori del server. La presenza di questi oggetti, inoltre, può impedire la creazione di oggetti della stessa classe.

Per risolvere il problema, è necessario rimuovere da Active Directory le voci presenti nel contenitore LostAndFoundConfig utilizzando ADSI Edit.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Nota:
ADSI Edit è uno strumento fornito con gli strumenti di supporto di Windows 2000 Server e Windows Server 2003.

Per risolvere il problema

  1. Aprire lo snap-in MMC ADSI Edit.

  2. Scegliere Connetti a dal menu Operazione.

  3. Nel campo Nome della finestra di dialogo Impostazioni di connessione, immettere un nome per la connessione ADSI. In Punto di connessione fare clic su Selezionare un contesto dei nomi conosciuto, quindi scegliere Configurazione dal menu a discesa. Fare clic su OK.

  4. Nel riquadro sinistro fare doppio clic sull'oggetto Configurazione, quindi su LostAndFoundConfig.

  5. Nel riquadro destro eliminare tutti gli oggetti e i contenitori. Fare clic con il pulsante destro del mouse sull'oggetto o sul contenitore, quindi su Elimina e infine su Sì.

  6. Uscire da ADSI Edit.


L'organizzazione di Exchange non dispone di alcun criterio destinatario
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo Name nell'oggetto Criteri destinatari di ogni organizzazione di Exchange. Se Exchange Server Analyzer determina che non è presente l'oggetto Criteri destinatari o che in esso non è contenuto alcun criterio destinatario, verrà visualizzato un messaggio di errore.

Se si installa Exchange Server, viene creato un criterio destinatario predefinito che assegna indirizzi SMTP (Simple Mail Transfer Protocol) e X.400 a tutti i destinatari dell'organizzazione di Exchange. È possibile modificare il criterio predefinito oppure crearne di nuovi. Tuttavia, è necessario non eliminare il criterio predefinito. Tutti i destinatari di un'organizzazione di Exchange devono disporre sia di un indirizzo SMTP che di un indirizzo X.400. Se l'organizzazione di Exchange non dispone di criteri destinatari, si verificheranno problemi in termini di affidabilità.

Per creare un criterio destinatario

  1. Fare clic su Start, scegliere Tutti i programmi, Microsoft Exchange, quindi fare clic su Gestore di sistema.

  2. Nel riquadro destro di Gestore di sistema di Exchange espandere l'organizzazione, Destinatari, fare clic con il pulsante destro del mouse su Criteri destinatari, scegliere Nuovo, quindi fare clic su Criterio destinatario.

  3. Nella finestra di dialogo Nuovi criteri scegliere il tipo di criterio che si desidera creare selezionando le caselle di controllo Indirizzi di posta elettronica, Impostazioni di Gestione cassette postali, oppure entrambe, quindi fare clic su OK.

  4. Nella finestra di dialogo Proprietà digitare un nome per il nuovo criterio destinatario, quindi fare clic su Modifica per creare il filtro corrispondente.

    Nota:
    Se non si crea un filtro, il criterio non verrà applicato ad alcun destinatario.

  5. Per personalizzare il criterio destinatario, passare alla scheda Indirizzi di posta elettronica (Criterio) oppure alla scheda Impostazioni di Gestione cassette postali (Criterio) nella finestra di dialogo Proprietà. Utilizzare le impostazioni di queste schede per configurare il criterio destinatario, quindi fare clic su OK per creare il criterio.

  6. Fare clic con il pulsante destro del mouse sul criterio destinatario in Gestore di sistema di Exchange, quindi selezionare Applica criterio.

Per ulteriori informazioni sui destinatari e sui criteri destinatari, consultare "Gestione dei destinatari e dei criteri destinatari" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

Per ulteriori informazioni sulla procedura di creazione e di configurazione dei criteri destinatari, consultare l'articolo 249299 della Microsoft Knowledge Base "HOW TO: XADM: Configurare criteri destinatari in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299.


L'organizzazione di Exchange non dispone di alcun criterio di sistema
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il nome di ciascun criterio di sistema nell'oggetto Criteri di sistema di ogni organizzazione di Exchange. Se Exchange Server Analyzer determina che non è presente l'oggetto Criteri di sistema o che in esso non è contenuto alcun criterio di sistema, verrà visualizzato un messaggio di errore.

È possibile utilizzare gli oggetti Criteri di sistema per semplificare la gestione del sistema configurando parametri per più server di Exchange tramite un unico oggetto di configurazione, ad esempio un archivio delle cassette postali, un archivio delle cartelle pubbliche oppure le impostazioni del server. Per impostazione predefinita, i seguenti criteri di sistema vengono creati quando nell'organizzazione viene eseguito ForestPrep:

  • Hidden DL Membership

  • Mail-Enabled Recipient

  • Mailbox-Enabled User

Se questi criteri di sistema predefiniti non esistono nell'organizzazione di Exchange, si verificheranno problemi in termini di affidabilità. Per creare nuovamente i criteri di sistema predefiniti, è necessario eseguire ForestPrep.

Per eseguire Exchange Server 2003 ForestPrep

  1. Inserire il CD di Exchange nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare drive:\setup\i386\setup /ForestPrep, dove drive è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti verificare che Operazione sia impostato su ForestPrep. In caso contrario, fare clic sulla freccia a discesa e scegliere ForestPrep. Fare clic su Avanti.

    Importante:
    Se ForestPrep non viene visualizzato in Operazione, è possibile che il comando ForestPrep non sia stato scritto correttamente nel passaggio 2. In questo caso, tornare al passaggio 2 e digitare nuovamente il comando.

  7. Nella casella Account della pagina Account di amministratore di Microsoft Exchange Server digitare il nome dell'account o del gruppo responsabile dell'installazione di Exchange.

    Nota:
    L'account specificato disporrà anche dell'autorizzazione per l'utilizzo dell'Impostazione guidata Delega amministrazione di Exchange per creare altri account amministratore di Exchange. Per ulteriori informazioni sull'Impostazione guidata Delega amministrazione di Exchange, consultare il Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47617.

  8. Fare clic su Avanti per avviare ForestPrep. Dopo l'avvio non sarà possibile annullare il processo.

    Nota:
    A seconda della topologia di rete e della velocità del controller di dominio di Microsoft Windows® 2000 o di Microsoft Windows Server™ 2003, il completamento di ForestPrep potrebbe richiedere molto tempo.

  9. Nella pagina di completamento dell'installazione guidata di Microsoft Exchange fare clic su Fine.

Per ulteriori informazioni sull'utilizzo dei criteri di sistema in Exchange, consultare l'articolo 253838 della Microsoft Knowledge Base "XADM: Applicazione dei Criteri di sistema da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=253838.

Per ulteriori informazioni sui criteri di sistema, consultare "Architettura del Gestore di sistema di Exchange" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47891.

Per ulteriori informazioni sulla creazione di criteri di sistema non predefiniti in Exchange, consultare l'articolo 256141 della Microsoft Knowledge Base "Creazione di criteri di sistema in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256141.


La porta NSPI del catalogo globale è stata ignorata
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-01-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema su server di catalogo globali per determinare se la chiave TCP/IP Port del Registro di sistema è impostata:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters\TCP/IP Port

Se Exchange Server Analyzer rileva che la chiave TCP/IP Port del Registro di sistema è stata creata e impostata, verrà visualizzato un messaggio di configurazione non predefinita.

La chiave TCP/IP Port del registro è necessaria quando un server di catalogo globale deve utilizzare una porta specifica per elaborare le richieste dei client MAPI. Se tale requisito non esiste nell'ambiente di Exchange, è possibile rimuovere la chiave.

.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per eliminare la porta TCP/IP nel server di catalogo globale

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

  3. Fare clic con il pulsante destro del mouse sulla chiave TCP/IP Port, quindi scegliere Elimina.

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla configurazione di chiamate RPC su HTTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833401, "Configurazione di chiamate RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  • 827330, "Risoluzione dei problemi di chiamata RPC del client tramite connessione HTTP in Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  • 298369, "Configurazione di un server di catalogo globale per l'utilizzo di una porta specifica nel servizio di un client MAPI" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298369.

  • 24823, "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=24823.


La porta 3268 del catalogo globale non risponde
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore configurato per l'attributo isGlobalCatalogReady di questo server. Il valore True per questo attributo indica che il server di elenchi in linea è in grado di operare anche come server di catalogo globale, mentre il valore False indica che il server di elenchi in linea non è un server di catalogo globale.

Successivamente Exchange Server Analyzer si connette alla porta 3268 sul server di Exchange per verificare che la porta risponda.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • Il server è un server di catalogo globale.

  • Nessuna risposta dalla porta 3268.

Nota:
Questo messaggio può essere visualizzato per errore se è presente un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il server di catalogo globale.

Questo problema si verifica in genere quando la casella di controllo del server di catalogo globale è stata selezionata ma il server non è stato riavviato.

Per risolvere il problema

  • Riavviare il server.

Per ulteriori informazioni sulla promozione dei controller di dominio consultare l'articolo 304403 della Microsoft Knowledge Base "XADM: Considerazioni sulla promozione di un controller di dominio a server di catalogo globale in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403.


Errore nello schema della classe degli oggetti gruppo
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-01

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se la classe msExchBaseClass viene visualizzata nell'attributo auxiliaryClass degli oggetti gruppo nello schema di Active Directory.

Active Directory dispone di classi predefinite che definiscono tutti i diversi tipi di oggetto necessari per il funzionamento corretto della directory. Le definizioni degli oggetti vengono create mediante la nidificazione delle classi, un'operazione che genera una relazione padre/figlio tra le diverse classi.

La classe msExchBaseClass viene aggiunta ad Active Directory al momento dell'installazione di Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007. La classe msExchBaseClass rappresenta la classe ausiliaria di base applicata a tutte le classi estese dal modello CDO (Component Object Model) per Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007 (CDOEX). CDOEX fornisce le interfacce e le classi COM (Component Object Model) principali utilizzate per gestire la maggior parte dei tipi di informazioni nell'archivio di Exchange.

Se si modifica in modo errato lo schema di Active Directory, la relazione tra la classe msExchBaseClass e l'attributo auxiliaryClass degli oggetti gruppo potrebbe interrompersi. Questa interruzione può provocare l'instabilità del server di Exchange, ad esempio errori di elaborazione del Servizio aggiornamento destinatari, oppure può impedire l'installazione dei nuovi server di Exchange Server 200x nell'organizzazione.

Se Exchange Server Analyzer rileva che la classe msExchBaseClass non viene visualizzata nell'attributo auxiliaryClass degli oggetti gruppo nello schema di Active Directory, significa che la relazione è interrotta. Verrà quindi visualizzato un messaggio di errore.

Per risolvere il problema, contattare il Supporto Tecnico Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41364.


L'ambiente Exchange ospitato richiede un'organizzazione di Exchange in modalità nativa
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'ambiente Exchange Server è configurato come un ambiente Exchange ospitato. Se l'ambiente Exchange Server è un ambiente Exchange ospitato, viene eseguita una query in Active Directory per determinare se l'organizzazione di Exchange viene eseguita in modalità mista.

Se questa condizione è soddisfatta, verrà visualizzato un avviso. Le soluzioni Exchange ospitate richiedono un'organizzazione in modalità nativa.

Dopo il passaggio alla modalità nativa non sarà più possibile tornare alla modalità mista.

Per passare alla modalità nativa

  1. Avviare Gestore di sistema di Exchange: fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nella struttura della console fare clic con il pulsante destro del mouse sull'organizzazione che si desidera impostare sulla modalità nativa, quindi fare clic su Proprietà.

  3. In <Nome organizzazione> Proprietà, in Cambio modalità operativa, fare clic su Cambia modalità.

  4. Nella finestra di dialogo di avviso fare clic su Sì per passare definitivamente alla modalità nativa. Fare clic su Applica per accettare la nuova modalità di Exchange.

Per un utilizzo ottimale della modalità nativa di Exchange, è necessario riavviare il servizio Archivio informazioni di Microsoft Exchange su tutti i server di Exchange all'interno dell'organizzazione. Non è necessario riavviare contemporaneamente tutti i servizi Archivio informazioni di Microsoft Exchange. Tuttavia, per usufruire di tutte le funzionalità della modalità nativa di Exchange, occorre riavviare il servizio su ogni server. Riavviare il servizio sui server dopo che il passaggio alla modalità nativa è stato replicato al controller di dominio di Microsoft Windows®.

Per riavviare il servizio Archivio informazioni di Microsoft Exchange

  1. Fare clic su Start, Esegui, digitare services.msc, quindi fare clic su OK.

  2. Nel riquadro Servizi (locale) individuare il servizio Archivio informazioni di Microsoft Exchange.

  3. Fare clic con il pulsante destro del mouse sul servizio, quindi scegliere Riavvia.

Per ulteriori informazioni sugli ambienti Exchange ospitati, consultare i seguenti articoli:

  • "Information for Hosters" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46307 (informazioni in lingua inglese).

  • "Chapter 23 - Hosted Service Environments" nel Resource Kit di Exchange Server 2000 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46326 (informazioni in lingua inglese).

Per ulteriori informazioni sulla conversione dalla modalità mista a quella nativa, consultare l'articolo 32779 della Microsoft Knowledge Base "Conversione dalla modalità mista a quella nativa in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779.


Il ruolo del server FSMO di infrastruttura non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo fSMORoleOwner del master infrastruttura nel contesto di denominazione di dominio (Domain Naming Context). Ad esempio, in un dominio che si chiama contoso.com, l'attributo fSMORoleOwner per il master infrastruttura è un attributo di CN=Infrastructure,DC=contoso,DC=com. Quindi, tramite Exchange Server Analyzer verrà tentato di stabilire una connessione LDAP (Lightweight Directory Access Protocol) alla porta TCP 389 sul controller di dominio che riveste questo ruolo. Se non è possibile stabilire la connessione a questo controller di dominio, verrà visualizzato un messaggio di errore.

Il master infrastruttura aggiorna i riferimenti da gruppo a utente ogni volta che i membri dei gruppi vengono rinominati o cambiati all'interno di un dominio. Il controller di dominio che ha il ruolo di master infrastrutture per il dominio del gruppo aggiorna il riferimento da gruppo a utente all'interno del dominio in base al nuovo nome dell'utente. Periodicamente, il master infrastruttura esegue l'analisi degli account di dominio e verifica l'appartenenza dei gruppi. Se un account utente viene spostato in un nuovo dominio, il master infrastruttura identifica il nuovo dominio dell'account utente e aggiorna il gruppo di conseguenza. Dopo che il master infrastruttura aggiorna localmente tali riferimenti, utilizza le repliche per aggiornare tutte le altre repliche del dominio. Se il master infrastruttura non è disponibile, gli aggiornamenti vengono eseguiti in ritardo. In qualunque momento, può esserci solo un controller di dominio che funge da master infrastruttura in ciascun dominio.

Per risolvere il problema

  1. Verificare che il server di elenchi in linea specificato nel messaggio di errore sia in linea e accessibile dai server di Exchange nell'organizzazione.

  2. Se il server di elenchi in linea non dispone dell'autorizzazione, è necessario assegnare il ruolo di master infrastruttura a un altro controller di dominio.

Per ulteriori informazioni sul trasferimento del ruolo di master infrastruttura da un controller di dominio a un altro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801, "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows Server 2000, consultare l'articolo 255690, "HOW TO: Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Attributo di versione non valido nell'oggetto organizzazione di Exchange
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-02-28

Lo strumento Microsoft Exchange Server Analyzer esegue una query nel servizio directory di Active Directory per determinare le informazioni relative alla versione dello schema per Exchange. Nello specifico, Exchange Server Analyzer esamina il seguente oggetto Active Directory per determinare il valore corrente dell'attributo rangeUpper:

CN=ms-Exch-Schema-Version-Pt,CN=Schema,CN=Configuration,DC=<DN-of-forest-root-domain>

Un valore rangeUpper corrispondente a 4397 indica che è installato Exchange 2000 Server.

Un valore rangeUpper corrispondente a 6870 indica che è installato Exchange Server 2003.

Un valore rangeUpper corrispondente a 10637 indica che è installato Exchange Server 2007.

Se Exchange Server Analyzer rileva un altro valore di rangeUpper, verrà visualizzato un messaggio di errore.

Il valore rangeUpper viene inserito da Exchange 2000 Server o Exchange Server 2003 durante il processo ForestPrep. Un valore diverso da 4397, 6870 o 10637 indica, in genere, che è stata utilizzata una versione beta o non definitiva di Exchange per l'esecuzione di ForestPrep o, nel caso di Exchange Server 2007, PrepareDomain.

Per risolvere il problema in Exchange 2000 Server o Exchange Server 2003, rieseguire il processo ForestPrep utilizzando la versione finale di Exchange installata nell'ambiente. Per risolvere il problema in Exchange Server 2007, rieseguire il processo PrepareSchema utilizzando la versione finale di Exchange installata nell'ambiente. È necessario eseguire ForestPrep o PrepareSchema durante l'accesso con un account che disponga almeno dei seguenti diritti:

  • Amministratore dell'organizzazione

  • Amministratore di schema

  • Amministratore del dominio

  • Amministratore del computer locale (se in esecuzione solo su un server membro)

Per risolvere il problema in Exchange 2000 Server o Exchange Server 2003

  1. Eseguire setup.exe /forestprep.

  2. Verificare che il processo ForestPrep sia completato correttamente.

Per risolvere il problema in Exchange Server 2007

  1. Eseguire setup.exe /PrepareSchema.

  2. Verificare che il processo PrepareSchema sia completato correttamente.

Per ulteriori dettagli sulla procedura di installazione di Exchange e di esecuzione del processo PrepareSchema, consultare la seguente documentazione del prodotto:

  • "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.

Per ulteriori dettagli sulla procedura di installazione di Exchange e di esecuzione del processo ForestPrep, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 312371, "COME: Preparare la foresta con ForestPrep in Exchange 2000 Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371. Questo articolo riguarda Exchange 2000 Server ed Exchange Server 2003.

  • 274737, "Verifica del corretto completamento di ForestPrep e DomainPrep in Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=274737.

  • 828765 "Autorizzazioni necessarie per l'installazione dei componenti in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=828765.


Informazioni sull'account precedente presenti nel gruppo amministrativo in modalità nativa
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchLegacyAccount presente in ogni oggetto gruppo amministrativo di Exchange contiene dati.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il valore dell'attributo msExchAdminGroupMode di ogni gruppo amministrativo. Il valore 0 per l'attributo msExchAdminGroupMode indica che il gruppo amministrativo è in modalità nativa di Exchange. Il valore 1 indica un ambiente Exchange Server 5.5 puro mentre il valore 2 indica la modalità mista di Exchange.

Se Exchange Server Analyzer rileva che l'attributo msExchLegacyAccount contiene dati e che il valore dell'attributo msExchAdminGroupMode è 0, verrà visualizzato un messaggio di errore.

Quando si passa alla modalità nativa di Exchange, l'attributo msExchLegacyAccount viene eliminato. Questo attributo viene utilizzato solo in organizzazioni di Exchange in modalità mista dove è ancora presente Exchange Server 5.5. I dati effettivi dell'attributo sono rappresentati dall'account di servizio di Exchange Server 5.5 e la relativa presenza nell'attributo msExchLegacyAccount di un'organizzazione di Exchange in modalità nativa determinerà malfunzionamenti durante gli aggiornamenti e le installazioni di Service Pack. In effetti, la presenza dell'attributo, anche senza dati presenti in esso, provocherà difetti di funzionamento. Ciò si verifica in quanto nel programma di installazione di Exchange l'attributo viene utilizzato come strumento per rilevare se un'organizzazione di Exchange è in modalità mista o nativa. Se l'attributo esiste, il programma di installazione di Exchange verrà eseguito in una configurazione a modalità mista per un'installazione che in effetti è in modalità nativa.

È probabile che l'attributo msExchLegacyAccount sia ancora esistente se i dati sono stati rimossi manualmente da Active Directory mediante lo snap-in ADSI Edit (Active Directory Service Interfaces).

È necessario rimuovere questi dati da msExchLegacyAccount modificando manualmente l'attributo con lo strumento LDP (ldp.exe). È necessario utilizzare lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3 che consentirà di rimuovere completamente sia i dati che l'attributo dalla directory. Lo snap-in ADSI Edit non è sufficiente in questo caso, poiché rimuove solo i dati e lascia l'attributo. LDP.exe è incluso nel pacchetto Strumenti di supporto Windows®.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per rimuovere l'attributo msExchLegacyAccount

  1. Avviare LDP.exe.

  2. Dal menu Connessione scegliere Connetti; nella finestra di dialogo Connetti immettere il nome di un controller di dominio nello stesso insieme di strutture Active Directory dell'organizzazione di Exchange, quindi fare clic su OK.

  3. Dal menu Connessione scegliere Associa; nella finestra di dialogo Associa immettere le credenziali che dispongano almeno dei diritti di Amministratore completo di Exchange a livello di Gruppo amministrativo, quindi fare clic su OK.

  4. Nel menu Visualizza, fare clic su Struttura; nella finestra di dialogo Visualizzazione struttura, lasciare il campo vuoto se si effettua la connessione dal dominio principale, in caso contrario, immettere CN=Configuration,DC=Domain_name, DC=Domain_suffix dove Domain_name è il dominio principale nell'insieme di strutture di Active Directory e Domain_suffix è il suffisso del dominio, ad esempio com, net e org. Fare clic su OK.

  5. Espandere la visualizzazione della gerarchia nel riquadro sinistro di LDP fino ad aprire il proprio gruppo amministrativo. Per eseguire l'operazione, fare doppio clic sui nodi nell'ordine seguente (notare che ogni nodo in LDP è seguito dal nome distinto (DN, Distinguished Name) completo; per motivi di chiarezza, qui vengono indicati solo i CN più a sinistra):

    1. DC=Domain_name

    2. CN=Configuration

    3. CN=Services

    4. CN=Microsoft Exchange

    5. CN=Organization_name

    6. CN=Administrative Groups

    7. CN=Administrative_group_name

    Nel riquadro dei dettagli (destro) di LDP, scorrere verso il basso per visualizzare gli attributi del proprio gruppo amministrativo. Se l'attributo msExchLegacyAccount è presente, sarà necessario eliminarlo. Se l'attributo msExchLegacyAccount è presente, è probabile che anche gli attributi msExchLegacyDomain e msExchEncryptedPassword siano presenti. Se lo sono, è necessario eliminare anche questi.

  6. Nel riquadro della gerarchia (sinistro) di LDP, fare clic con il pulsante destro del mouse sul Nome_gruppo_amministrativo quindi scegliere Modifica.

  7. Nella finestra di dialogo Modifica verificare che il DN completo elencato nel campo Dn identifichi in modo corretto il gruppo amministrativo da modificare. Dovrebbe essere visualizzato: CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name.

  8. Nella finestra di dialogo Modifica, sotto Operazioni, selezionare Elimina; sotto Modifica voce immettere msExchLegacyAccount nel campo Attributo, quindi fare clic su Invia. In tal modo si aggiunge msExchLegacyAccount all'Elenco voci. L'Elenco voci definisce gli attributi che verranno eliminati quando si fa clic su Esegui.

  9. Se gli attributi msExchLegacyDomain o msExchEncryptedPassword esistono nel gruppo amministrativo, aggiungerli all'Elenco voci come descritto nel passaggio 8.

  10. Quando l'Elenco voci contiene gli attributi da eliminare, fare clic su Esegui. Verrà visualizzato un messaggio di stato nel riquadro dei dettagli di LDP.

  11. Dal menu Connessione scegliere Nuova per eliminare ogni voce dal riquadro dei dettagli di LDP.

  12. Passare a CN=Administrative_group_name e fare doppio clic sull'oggetto. Analizzare il contenuto del riquadro destro per verificare che gli attributi siano stati eliminati.

Per ulteriori informazioni sulla modifica di Active Directory con lo strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.


Attributo legacyExchangeDN per l'organizzazione di Exchange non valido
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-02-01

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il formato dell'attributo legacyExchangeDN nell'oggetto organizzazione di Exchange. Se Exchange Server Analyzer rileva che l'attributo legacyExchangeDN è non valido o incorretto, verrà visualizzato un messaggio di errore.

Il valore di questo attributo presenta il formato /o=Organizzazione, dove Organizzazione è il nome dell'organizzazione di Exchange. Se il valore non inizia con /o= o /O=, non verrà considerato corretto. È necessario risolvere al più presto il problema.

Per risolvere il problema in Exchange 2000 Server o Exchange Server 2003

  1. Eseguire il processo ForestPrep di Exchange Server. Se, durante il processo, il programma di installazione determina che legacyExchangeDN presenta un formato errato, risolverà automaticamente il problema.

Per risolvere il problema in Exchange Server 2007

  1. Eseguire il processo PrepareAD di Exchange Server. Se, durante il processo, il programma di installazione determina che legacyExchangeDN presenta un formato errato, il problema verrà risolto automaticamente.

Per ulteriori informazioni sul processo ForestPrep, consultare l'articolo 312371 della Microsoft Knowledge Base "HOW TO: Preparazione della foresta con ForestPrep in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=312371.

Per ulteriori informazioni sul processo PrepareAD, vedere "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.

Per ulteriori informazioni sull'attributo legacyExchangeDN e sulle modalità per modificarlo, consultare gli articoli della Microsoft Knowledge Base sui seguenti argomenti:

  • 324606, XADM: Utilizzo di Legacydn.exe per correggere i nomi dell'organizzazione di Exchange o del gruppo amministrativo, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324606.

  • 286783, XADM: Messaggio di errore durante l'aggiornamento dei dati di disponibilità in Exchange 2000 Server, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=286783.

  • 301585, XADM: Soluzioni alternative per i problemi con MBconn.exe, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301585.


Informazioni sul dominio precedente presenti nel gruppo amministrativo in modalità nativa
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchLegacyAccount presente in ogni oggetto gruppo amministrativo di Exchange contiene dati.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il valore dell'attributo msExchAdminGroupMode di ogni gruppo amministrativo. Il valore 0 per l'attributo msExchAdminGroupMode indica che il gruppo amministrativo è in modalità nativa di Exchange. Il valore 1 indica un ambiente Exchange Server 5.5 puro mentre il valore 2 indica la modalità mista di Exchange.

Se Exchange Server Analyzer rileva che l'attributo msExchLegacyDomain contiene dati e che il valore dell'attributo msExchAdminGroupMode è 0, verrà visualizzato un messaggio di errore.

Quando si passa alla modalità nativa di Exchange, l'attributo msExchLegacyDomain viene eliminato. Questo attributo viene utilizzato solo in organizzazioni di Exchange in modalità mista dove è ancora presente Exchange Server 5.5. I dati effettivi dell'attributo sono rappresentati dal dominio dell'account di servizio di Exchange Server 5.5 e la relativa presenza nell'attributo msExchLegacyDomain di un'organizzazione di Exchange in modalità nativa determinerà malfunzionamenti durante gli aggiornamenti e le installazioni di service pack. In effetti, la presenza dell'attributo, anche senza dati presenti in esso, provocherà difetti di funzionamento. Ciò si verifica in quanto nel programma di installazione di Exchange l'attributo viene utilizzato come strumento per rilevare se un'organizzazione di Exchange è in modalità mista o nativa. Se l'attributo esiste, il programma di installazione di Exchange verrà eseguito in una configurazione a modalità mista per un'installazione che in effetti è in modalità nativa.

È probabile che l'attributo msExchLegacyDomain sia ancora esistente se i dati sono stati rimossi manualmente da Active Directory mediante lo snap-in ADSI Edit.

È necessario rimuovere questi dati da msExchLegacyDomain modificando manualmente l'attributo con lo strumento LDP (ldp.exe). È necessario utilizzare lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3 che consentirà di rimuovere completamente sia i dati che l'attributo dalla directory. Lo snap-in ADSI Edit non è sufficiente in questo caso, poiché rimuove solo i dati ma lascia l'attributo. LDP.exe è incluso nel pacchetto Strumenti di supporto Windows®.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per rimuovere l'attributo msExchLegacyDomain

  1. Avviare LDP.exe.

  2. Dal menu Connessione scegliere Connetti; nella finestra di dialogo Connetti immettere il nome di un controller di dominio nello stesso insieme di strutture Active Directory dell'organizzazione di Exchange, quindi fare clic su OK.

  3. Dal menu Connessione scegliere Associa; nella finestra di dialogo Associa immettere le credenziali che dispongano almeno dei diritti di Amministratore completo di Exchange a livello di Gruppo amministrativo, quindi fare clic su OK.

  4. Nel menu Visualizza fare clic su Struttura. Nella finestra di dialogo Visualizzazione struttura lasciare il campo vuoto se si effettua la connessione dal dominio principale, in caso contrario, immettere CN=Configuration,DC=Domain_name, DC=Domain_suffix dove Domain_name è il dominio principale nell'insieme di strutture di Active Directory e Domain_suffix è il suffisso del dominio, ad esempio com, net od org. Fare clic su OK.

  5. Espandere la visualizzazione della gerarchia nel riquadro sinistro di LDP fino ad aprire il proprio gruppo amministrativo. Per eseguire l'operazione, fare doppio clic sui nodi nell'ordine seguente (notare che ogni nodo in LDP è seguito dal nome distinto (DN, Distinguished Name) completo. Per motivi di chiarezza, qui vengono indicati solo i CN più a sinistra):

    • DC=Domain_name

    • CN=Configuration

    • CN=Services

    • CN=Microsoft Exchange

    • CN=Organization_name

    • CN=Administrative Groups

    • CN=Administrative_group_name

    Nel riquadro dei dettagli (destro) di LDP, scorrere verso il basso per visualizzare gli attributi del proprio gruppo amministrativo. Se l'attributo msExchLegacyDomain è presente, sarà necessario eliminarlo. Se l'attributo msExchLegacyDomain è presente, è probabile che anche gli attributi msExchLegacyDomain e msExchEncryptedPassword siano presenti. Se lo sono, è necessario eliminare anch'essi.

  6. Nel riquadro della gerarchia (sinistro) di LDP, fare clic con il pulsante destro del mouse su Administrative_group_name quindi scegliere Modifica.

  7. Nella finestra di dialogo Modifica verificare che il DN completo elencato nel campo Dn identifichi in modo corretto il gruppo amministrativo da modificare. Dovrebbe essere visualizzato: CN=Administrative_group_name,CN=Administrative Groups,CN=Organization_name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain_name.

  8. Nella finestra di dialogo Modifica, sotto Operazioni, selezionare Elimina; sotto Modifica voce immettere msExchLegacyAccount nel campo Attributo, quindi fare clic su Invia. In tal modo si aggiunge msExchLegacyAccount all'Elenco voci. L'Elenco voci definisce gli attributi che verranno eliminati quando si fa clic su Esegui.

  9. Se gli attributi msExchLegacyAccount o msExchEncryptedPassword esistono nel gruppo amministrativo, aggiungerli all'Elenco voci come descritto nel passaggio 8.

  10. Quando l'Elenco voci contiene gli attributi da eliminare, fare clic su Esegui. Verrà visualizzato un messaggio di stato nel riquadro dei dettagli di LDP.

  11. Dal menu Connessione scegliere Nuova per eliminare ogni voce dal riquadro dei dettagli di LDP.

  12. Passare a CN=Administrative_group_name e fare doppio clic sull'oggetto. Analizzare il contenuto del riquadro destro per verificare che gli attributi siano stati eliminati.

Per ulteriori informazioni sulla modifica di Active Directory con lo strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.


L'attributo LegacyExchangeDN per questo gruppo amministrativo non corrisponde all'organizzazione principale
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-11-30

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il formato dell'attributo legacyExchangeDN dell'oggetto contenitore del gruppo amministrativo. Se Exchange Server Analyzer rileva che l'attributo legacyExchangeDN del gruppo amministrativo non corrisponde all'attributo legacyExchangeDN dell'organizzazione di Exchange, verrà visualizzato un messaggio di errore.

Il valore legacyExchangeDN viene utilizzato in Exchange per identificare gli oggetti di Exchange presenti in Active Directory. Il valore legacyExchangeDN rappresenta un nome distinto che indica la posizione dell'oggetto nell'organizzazione di Exchange, ad esempio:

/o= organization /ou= administrative group

Oggetti quali server e gerarchie di cartelle ereditano parte dei loro valori legacyExchangeDN dal gruppo amministrativo. Di conseguenza, se esiste un problema con il valore del gruppo amministrativo, molti altri oggetti potrebbero ereditare lo stesso problema.

Generalmente i problemi relativi a legacyExchangeDN si verificano quando l'amministratore tenta di modificare direttamente il valore. È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Utilizzare un editor di Active Directory, ad esempio ADSI Edit, per individuare l'oggetto gruppo amministrativo in Active Directory.

    L'attributo legacyExchangeDN è reperibile in:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN= Administrative group

  2. Immettere un nuovo valore di stringa del formato:

    /o= organization /ou= administrative group

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


L'attributo legacyExchangeDN per questo gruppo amministrativo non è valido
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per verificare il valore legacyExchangeDN di un gruppo amministrativo. Questo messaggio di errore viene visualizzato se l'organizzazione o il gruppo amministrativo specificato nel valore legacyExchangeDN non corrisponde al nome effettivo dell'organizzazione o del gruppo o se parte del valore manca completamente.

Il valore legacyExchangeDN viene utilizzato in Exchange per identificare gli oggetti di Exchange presenti in Active Directory. Il valore legacyExchangeDN rappresenta un nome distinto che indica la posizione dell'oggetto nell'organizzazione di Exchange, ad esempio:

/o=organizzazione/ou=gruppo amministrativo

Oggetti quali server e gerarchie di cartelle ereditano parte dei loro valori legacyExchangeDN dal gruppo amministrativo. Di conseguenza, se esiste un problema con il valore del gruppo amministrativo, molti altri oggetti potrebbero ereditare lo stesso problema.

In genere, si verificano problemi con legacyExchangeDN quando un amministratore tenta di modificare direttamente il valore. È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Utilizzare un editor di Active Directory, ad esempio ADSI Edit, per individuare l'oggetto gruppo amministrativo in Active Directory.

    L'attributo legacyExchangeDN è reperibile in:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=Organization, CN=Administrative Groups, CN=Administrative group

  2. Digitare un nuovo valore di stringa del modulo:

    /o=organizzazione/ou=gruppo amministrativo

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


Presenza di gruppi non universali abilitati alla posta
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di domini nell'ambiente. Se Exchange Server Analyzer rileva la presenza di più domini Active Directory discreti nell'insieme di strutture, in ogni dominio verrà eseguita una query per determinare se sono presenti uno o più gruppi non universali abilitati alla posta.

Se Exchange Server Analyzer determina la presenza di gruppi non universali abilitati alla posta nell'insieme di strutture con più domini, verrà visualizzato un avviso.

Se si utilizzano gruppi di distribuzione globali o locali in un insieme di strutture con più domini, si possono verificare problemi di recapito dei messaggi di posta elettronica per i seguenti motivi:

  • Per espandere i gruppi di distribuzione in singoli destinatari, in Exchange viene contattato un server di catalogo globale.

  • Sebbene disponga di un elenco di tutti i tipi di gruppo per ciascun dominio, il server di catalogo globale non contiene l'elenco di appartenenza per i gruppi di dominio locali e globali creati in domini remoti.

  • Se viene inviato un messaggio a un gruppo di distribuzione globale e viene espanso in un dominio non principale, in Exchange il messaggio non verrà recapitato correttamente ai membri del gruppo.

  • Dal momento che il classificatore non è in grado di espandere la lista di distribuzione, quando un utente invia un messaggio a un gruppo di protezione abilitato alla posta in un insieme di strutture con più domini, è possibile che gli utenti del gruppo di distribuzione globale non ricevano il messaggio.

  • L'ultima voce dei registri di verifica è un messaggio inviato al classificatore. Il mittente del messaggio non riceve un rapporto di mancato recapito (NDR).

Per risolvere questo problema e garantire il recapito della posta elettronica, utilizzare gruppi di distribuzione universali in un ambiente con più domini. L'appartenenza ai gruppi di distribuzione universali viene replicata a ogni server di catalogo globale in ciascun dominio.

Per ulteriori informazioni su questo particolare problema e sui gruppi di distribuzione universali, consultare i seguenti argomenti:

  • "Gestione degli archivi di cassette postali e cartelle pubbliche" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

  • La sezione "Group Scope" di "Understanding Groups" nell'argomento Active Directory all'indirizzo http://go.microsoft.com/fwlink/?LinkId=51276 (informazioni in lingua inglese).

  • "Informazioni sui gruppi di distribuzione basati su query" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

Consultare anche i seguenti articoli della Microsoft Knowledge Base:

  • 231273, "XADM: Il recapito dei messaggi ai gruppi globali potrebbe non funzionare correttamente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=271930.

  • 283051, "XCON: Scomparsa dei messaggi di posta elettronica inviati a gruppi globali abilitati alla posta" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=283051.

  • 231273, "Utilizzo dei tipi di gruppi e di ambiti in Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231273.


È necessario modificare il criterio di sistema di Mailbox Enable User
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-08-10

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo purportedSearch per ciascun oggetto criterio di sistema di Exchange Server. L'attributo purportedSearch indica l'argomento di ricerca utilizzato quando si applica il criterio.

Exchange Server Analyzer Tool esegue inoltre una query in Active Directory per determinare il valore dell'attributo msDS-Behavior-Version dell'oggetto insieme di strutture in Active Directory; Impostazioni NTDS. Questo valore indica il livello di funzionalità dell'insieme di strutture di Active Directory. I valori validi per l'attributo msDS-Behavior-Version sono elencati nella seguente tabella.

Valore | Livello di funzionalità dell'insieme di strutture
0 | Microsoft Windows® 2000 Server modalità mista
1 | Microsoft Windows Server™ 2003 modalità provvisoria
2 | Microsoft Windows Server 2003 modalità nativa

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il valore dell'attributo revision del contenitore Windows2003Update. Il valore di questo attributo indica se l'utilità di preparazione di Active Directory (ADPrep.exe) è stata eseguita.

Infine, Microsoft® Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore della chiave OSProductSuite indica la versione di Windows in esecuzione sul computer.

Se Exchange Server Analyzer rileva che i criteri seguenti sono veri, verrà visualizzato un avviso:

  • Il valore dell'attributo purportedSearch del criterio di sistema Mailbox Enable User è diverso da (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*)).

  • Il livello operativo dell'insieme di strutture di Active Directory è Windows Server 2003 modalità provvisoria o Windows Server 2003 modalità nativa.

  • Nel computer Exchange Server non è in esecuzione Windows Small Business Server 2003.

Per evitare problemi di assegnazione di una nuova posizione alla cassetta postale, è necessario modificare i criteri di sistema. È possibile eseguire questo aggiornamento utilizzando ADSI Edit (AdsiEdit.msc), LDP (ldp.exe) o un altro strumento di modifica di Active Directory.

Se Windows Server 2003 viene utilizzato come controller di dominio e il criterio Mailbox Enable User non è aggiornato, la funzione di replica del valore collegato in Windows Server 2003 provocherà la sovrascrittura del valore dell'attributo homeMDB di nuovi utenti da parte del Servizio aggiornamento destinatari, con conseguente assegnazione di nuove posizioni alle relative cassette postali nel primo archivio sul server.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Windows Server 2003, Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Selezionare CN=System Policies.

  4. Nel riquadro destro fare clic con il pulsante destro del mouse su CN=Mailbox Enable User e scegliere Proprietà.

  5. Scorrere verso il basso per selezionare l'attributo purportedSearch, quindi fare clic su Modifica.

  6. Deselezionare l'attributo e configurarlo con il seguente filtro:

    (&(objectCategory=person)(objectClass=user)(mailnickname=*)(homeMdb=*))

    Nota:
    Nel filtro indicato al Passaggio 6 sono stati aggiunti ritorni a capo per renderlo più leggibile. Assicurarsi di immettere il filtro senza spazi o ritorni a capo.

  7. Fare nuovamente clic su OK per salvare le modifiche e chiudere ADSI Edit.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni su questo problema e il relativo impatto, consultare l'articolo 903291 della Microsoft Knowledge Base "Recipient Update Service may overwrite the value of the homeMDB attribute for new Exchange Server 2003 users" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=903291 (informazioni in lingua inglese).


Interfaccia MAPI disabilitata nel catalogo globale
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool legge la chiave del Registro di sistema indicata di seguito per stabilire se la chiave del Registro esiste:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

Se Exchange Server Analyzer rileva che la chiave del Registro di sistema Initialize MAPI interface è presente e configurata in modo da accettare qualsiasi valore numerico, verrà visualizzato un messaggio di errore.

Se la chiave Initialize MAPI interface del Registro di sistema è presente, i client Microsoft Office Outlook® non potranno contattare la rubrica di questo server. Per risolvere il problema è necessario rimuovere la chiave Initialize MAPI interface del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\NTDS\Parameters\Initialize MAPI interface

  3. Fare clic con il pulsante destro del mouse sulla chiave Initialize MAPI interface e scegliere Elimina.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla chiave del Registro di sistema Initialize MAPI interface, consultare l'articolo 275127 della Microsoft Knowledge Base "XADM: Configurazione di Exchange Server 5.5 per l'esecuzione su un controller di dominio corrispondente a un catalogo globale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=275127.


MaxActiveQueries modificato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero massimo di query LDAP (Lightweight Directory Access Protocol) che è possibile elaborare contemporaneamente. Questo valore è ottenuto esaminando i correnti criteri amministratici LDAP. Nello specifico, Exchange Server Analyzer verifica la presenza di MaxActiveQueries. Se Exchange Server Analyzer determina che MaxActiveQueries è presente ed è configurato con un valore diverso da 20, verrà visualizzato un messaggio di configurazione non predefinita.

I limiti amministrativi LDAP equilibrano le capacità operative di Active Directory e le relative prestazioni. Questi limiti impediscono che specifiche operazioni influenzino negativamente le prestazioni del server. Configurare le impostazioni oltre il valore predefinito può avere un effetto negativo sull'infrastruttura di Active Directory.

Il valore MaxActiveQueries dell'attributo LDAPAdminLimits regola il numero massimo delle query LDAP simultanee per i criteri query predefiniti. Per impostazione predefinita, viene imposto un limite di 20 query attive. Se viene raggiunto questo limite, viene visualizzato "LDAP_ADMIN_LIMIT_EXCEEDED" e non vengono elaborate ulteriori query LDAP.

Per avviare Ntdsutil.exe

  1. Fare clic su Start, quindi scegliere Run.

  2. Nella casella di testo Apri, digitare ntdsutil, quindi premere INVIO. Per visualizzare la Guida in linea in qualunque momento, digitare ? al prompt dei comandi.

Per visualizzare le impostazioni relative ai criteri

  1. Al prompt dei comandi Ntdsutil.exe digitare LDAP policies e premere INVIO.

  2. Al prompt dei comandi dei criteri LDAP, digitare connectionsquindi premere INVIO.

  3. Al prompt dei comandi della connessione al server, digitare connect to server nome DNS del server, quindi premere INVIO. Connettersi al server con cui si sta lavorando.

  4. Al prompt dei comandi della connessione al server, digitare q, quindi premere INVIO per tornare al menu precedente.

  5. Al prompt dei comandi dei criteri LDAP, digitare Show Valuesquindi premere INVIO.

    Verranno visualizzati i criteri esistenti.
Nota:
Questa procedura consente di visualizzare solo le impostazioni relative ai criteri di dominio predefiniti. Se si applica un'impostazione personalizzata relativa ai criteri, la procedura non verrà visualizzata.

Per modificare le impostazioni relative ai criteri

  1. Al prompt dei comandi Ntdsutil.exe digitare LDAP policies e premere INVIO.

  2. Al prompt dei comandi dei criteri LDAP, digitare Set MaxActiveQueries to 20 quindi premere INVIO.

    È possibile utilizzare il comando Show Values per verificare le modifiche apportate.

  3. Per salvare le modifiche, utilizzare il comando Conferma modifiche.

  4. Al termine, digitare q quindi premere INVIO.

  5. Per uscire da Ntdsutil.exe, al prompt dei comandi digitare q quindi premere INVIO.

Per ulteriori informazioni sulla configurazione dei criteri LDAP, consultare l'articolo 315071 della Microsoft Knowledge Base "Visualizzazione e impostazione dei criteri LDAP utilizzando Ntdsutil.exe in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071.


Parametro MaxPageSize non predefinito
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool verifica la configurazione LDAP (Lightweight Directory Access Protocol) del controller di dominio controllando gli attributi dell'oggetto Criteri query predefiniti nel contenitore Criteri query del servizio directory di Active Directory®. Se Exchange Server Analyzer determina che il valore MaxPageSize dell'attributo LDAPAdminLimits è stato modificato rispetto all'impostazione predefinita di 1.000, verrà visualizzato un messaggio di configurazione non predefinita.

I limiti amministrativi LDAP equilibrano le capacità operative di Active Directory e le relative prestazioni. Tali limiti impediscono a operazioni specifiche di compromettere le prestazioni del server e lo rendono più flessibile nella difesa contro gli attacchi DoS (Denial of Service). La configurazione dell'impostazione su un valore diverso da quello predefinito può avere un impatto negativo sull'infrastruttura di Active Directory.

I criteri LDAP vengono implementati utilizzando oggetti della classe queryPolicy. I criteri query possono essere creati nel contenitore Query-Criteri che, nel contesto dei nomi di configurazione, è di livello inferiore al contenitore Servizio directory.

Il valore MaxPageSize dell'attributo LDAPAdminLimits determina il numero di record che possono essere restituiti per una query LDAP. L'impostazione predefinita è 1.000 record. Se vengono restituiti più di 1000 elementi, in Active Directory verrà rilevato questo valore massimo e non verrà restituito nessun record.

Questo limite controlla il numero supportato di diversi tipi di oggetti Active Directory. Ad esempio, ogni organizzazione può disporre di un massimo di 1.000 server, 1.000 gruppi amministrativi e 1.000 elenchi di indirizzi; ogni gruppo amministrativo può disporre di un massimo di 1.000 gruppi di routing e ognuno di essi può disporre di un massimo di 1.000 connettori.

Se non vengono fornite istruzioni dal Servizio Supporto Tecnico Clienti Microsoft sull'immissione di un valore diverso, è preferibile reimpostare il valore su 1000.

Per avviare Ntdsutil.exe

  1. Fare clic su Start, quindi scegliere Esegui.

  2. Nella casella di testo Apri digitare ntdsutil, quindi premere INVIO. Per visualizzare la Guida in linea in qualunque momento, digitare ? al prompt dei comandi.

Per visualizzare le impostazioni relative ai criteri

  1. Al prompt dei comandi Ntdsutil.exe digitare Criteri LDAP, quindi premere INVIO.

  2. Al prompt dei comandi dei criteri LDAP, digitare connections quindi premere INVIO.

  3. Al prompt dei comandi della connessione al server, digitare Connetti al server nome server DNS, quindi premere INVIO. Connettersi al server con cui si sta lavorando.

  4. Al prompt dei comandi della connessione al server, digitare q, quindi premere INVIO per tornare al menu precedente.

  5. Al prompt dei comandi dei criteri LDAP, digitare Mostra valori, quindi premere INVIO.

    Verranno visualizzati i criteri esistenti.

    Nota:
    Questa procedura consente di visualizzare solo le impostazioni relative ai criteri dominio predefiniti. Se si applica un'impostazione personalizzata relativa ai criteri, la procedura non verrà visualizzata.

Per modificare le impostazioni relative ai criteri

  1. Al prompt dei comandi Ntdsutil.exe digitare Criteri LDAP, quindi premere INVIO.

  2. Al prompt dei comandi dei criteri LDAP, digitare Imposta MaxPageSize su 1.000, quindi premere INVIO.

    È possibile utilizzare il comando Mostra valori per verificare le modifiche apportate.

  3. Per salvare le modifiche, utilizzare il comando Conferma modifiche.

  4. Al termine, digitare q quindi premere INVIO.

  5. Per uscire da Ntdsutil.exe, al prompt dei comandi digitare q quindi premere INVIO.

Per ulteriori informazioni sulla configurazione dei criteri LDAP, consultare l'articolo 315071 della Microsoft Knowledge Base "Visualizzazione e impostazione dei criteri LDAP utilizzando Ntdsutil.exe in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071.


Il valore impostato per MaxPageSize è troppo alto
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare l'impostazione del valore MaxPageSize per l'attributo LDAPAdminLimits dell'oggetto Criteri query predefiniti nel contenitore Criteri query. Se Exchange Server Analyzer determina che il valore della chiave MaxPageSize è maggiore di 2.500, verrà visualizzato un messaggio di errore.

I limiti amministrativi LDAP (Lightweight Directory Access Protocol) equilibrano le capacità operative di Active Directory e le relative prestazioni. Questi limiti impediscono che specifiche operazioni compromettano le prestazioni del server. Inoltre, lo rendono più flessibile nella difesa contro gli attacchi DoS (Denial of Service). La configurazione dell'impostazione su un valore diverso da quello predefinito può avere un impatto negativo sull'infrastruttura di Active Directory.

I criteri LDAP vengono implementati utilizzando oggetti della classe queryPolicy. I criteri query possono essere creati nel contenitore Criteri query che, nel contesto dei nomi di configurazione, è di livello inferiore al contenitore Servizio directory.

Il valore MaxPageSize dell'attributo LDAPAdminLimits determina il numero di record che possono essere restituiti per una query LDAP. L'impostazione predefinita è 1.000 record. Se vengono restituiti più di 1.000 elementi, in Active Directory verrà rilevato questo valore massimo e non verrà restituito nessun record.

Questo limite controlla il numero supportato di diversi tipi di oggetti Active Directory. Ad esempio, ogni organizzazione può avere fino a 1.000 server, fino a 1.000 gruppi amministrativi e fino a 1.000 elenchi di indirizzi. Ogni gruppo amministrativo può avere fino 1.000 gruppi di routing e ciascuno di questi gruppi può avere fino a 1.000 connettori.

Se non sono state fornite istruzioni dal Servizio Supporto Tecnico Clienti Microsoft sull'immissione di un valore diverso, è preferibile reimpostare il valore su 1.000.

Per avviare Ntdsutil.exe

  1. Scegliere Esegui dal menu di avvio.

  2. Nella casella di testo Apri digitare ntdsutil, quindi premere INVIO. Per visualizzare la Guida in linea in qualunque momento, digitare ? al prompt dei comandi.
Per visualizzare le impostazioni relative ai criteri

  1. Al prompt del comando Ntdsutil.exe, digitare LDAP policies e premere INVIO.

  2. Al prompt dei comandi dei criteri LDAP, digitare connections quindi premere INVIO.

  3. Al prompt dei comandi della connessione al server, digitare connect to server <nome DNS del server>, quindi premere INVIO. Connettersi al server con cui si sta lavorando.

  4. Al prompt dei comandi della connessione al server, digitare q, quindi premere INVIO per tornare al menu precedente.

  5. Al prompt dei comandi dei criteri LDAP, digitare Show Values, quindi premere INVIO.

    Verranno visualizzati i criteri esistenti.

    Nota:
    Questa procedura consente di visualizzare solo le impostazioni relative ai criteri di dominio predefiniti. Se si applica un'impostazione personalizzata relativa ai criteri, la procedura non verrà visualizzata.
Per modificare le impostazioni relative ai criteri

  1. Al prompt del comando Ntdsutil.exe, digitare LDAP policies e premere INVIO.

  2. Al prompt dei comandi dei criteri LDAP, digitare Set MaxPageSize to 1000, quindi premere INVIO.

    È possibile utilizzare il comando Show Values per verificare le modifiche apportate.

  3. Per salvare le modifiche, utilizzare il comando Conferma modifiche.

  4. Al termine, digitare q quindi premere INVIO.

  5. Per uscire da Ntdsutil.exe, al prompt dei comandi digitare q quindi premere INVIO.

Per ulteriori informazioni sulla configurazione dei criteri LDAP, consultare l'articolo 315071 della Microsoft Knowledge Base "Visualizzazione e impostazione del criterio LDAP in Active Directory utilizzando Ntdsutil.exe" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=315071.


Sono presenti più di 800 elenchi di indirizzi
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il numero di elenchi di indirizzi nel gruppo Tutti gli elenchi indirizzi di Active Directory è maggiore di 800. Se Exchange Server Analyzer rileva che sono presenti più di 800 elenchi di indirizzi nell'organizzazione di Exchange Server, verrà visualizzato un avviso.

Si consiglia di ridurre a un numero minore di 800 gli elenchi di indirizzi nel gruppo Tutti gli elenchi indirizzi, per evitare gravi latenze durante le operazioni del Servizio aggiornamento destinatari. Se sono presenti più di 800 elenchi di indirizzi nell'organizzazione di Exchange Server, nel Servizio aggiornamento destinatari si verificheranno gravi latenze quando verranno contrassegnati gli oggetti abilitati alla posta.

In alternativa, è possibile disattivare il Servizio aggiornamento destinatari e usare script per gestire le attività svolte dal servizio.

Per ulteriori informazioni sulla disattivazione del Servizio aggiornamento destinatari, consultare l'articolo della Microsoft Knowledge Base "Requisiti per disabilitare il Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479.

Per ulteriori informazioni sugli elenchi di indirizzi e il Servizio aggiornamento destinatari, consultare il capitolo "Gestione dei destinatari e dei criteri destinatario" del Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


Sono presenti più di 800 elenchi di indirizzi globali
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il numero di elenchi di indirizzi nel gruppo Tutti gli elenchi indirizzi globali di Active Directory è maggiore di 800. Se Exchange Server Analyzer rileva che sono presenti più di 800 elenchi di indirizzi globali nell'organizzazione di Exchange Server, verrà visualizzato un avviso.

Si consiglia di ridurre a un numero minore di 800 gli elenchi di indirizzi nel gruppo Tutti gli elenchi indirizzi globali, per evitare gravi latenze durante le operazioni del Servizio aggiornamento destinatari. Se sono presenti più di 800 elenchi di indirizzi globali nell'organizzazione di Exchange Server, nel Servizio aggiornamento destinatari si verificheranno gravi latenze quando verranno contrassegnati gli oggetti abilitati alla posta.

In alternativa, è possibile disattivare il Servizio aggiornamento destinatari e usare script per gestire le attività svolte dal servizio.

Per ulteriori informazioni sulla disattivazione del Servizio aggiornamento destinatari, consultare l'articolo 296479 della Microsoft Knowledge Base "Requisiti per disabilitare il Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?Linkid=3052&kbid=296479.

Per ulteriori informazioni sugli elenchi di indirizzi e il Servizio aggiornamento destinatari, consultare il capitolo "Gestione dei destinatari e dei criteri destinatario" del Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


L'attributo msExchHomeMDB è indicizzato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo Routing Group Back-Link è stato configurato per l'indicizzazione in Active Directory. Nello specifico, Exchange Server Analyzer esegue una query in Active Directory per determinare il valore di indicizzazione corrente dell'attributo msExchHomeMDB, che è un attributo degli oggetti abilitati alle cassette postali in Active Directory. Per impostazione predefinita, questo attributo non è indicizzato. Se Exchange Server Analyzer rileva che l'attributo è configurato per l'indicizzazione, verrà visualizzato un messaggio di configurazione non predefinita.

L'indicizzazione dell'attributo msExchHomeMDB incide in maniera minima. Si verificherà un modesto aumento della quantità di memoria utilizzata nel server di catalogo globale poiché l'indice viene mantenuto in memoria.

Se uno dei seguenti scenari è applicabile alla propria organizzazione, l'indicizzazione dell'attributo potrebbe risultare utile:

  • Sono presenti diversi oggetti abilitati alla posta. In ambienti di grandi dimensioni, con 100.000 o più oggetti abilitati alla posta, l'indicizzazione dell'attributo può anche migliorare le prestazioni di Gestore di sistema di Exchange, oltre che operazioni specifiche di Exchange che possono essere eseguite con Utenti e computer di Active Directory.

  • Se si utilizza frequentemente il programma ExMerge (Exchange Mailbox Merge Program), è stato rilevato che l'indicizzazione dell'attributo msExchHomeMDB è occasionalmente necessaria in ambienti di medie e grandi dimensioni che utilizzano ExMerge. È stato dimostrato che indicizzare l'attributo msExchHomeMDB aumenta la velocità e migliora le prestazioni di ExMerge.

Se nessuna di queste situazioni è applicabile, è consigliabile ripristinare l'impostazione al valore predefinito non indicizzato.

Per risolvere il problema

  • Non è necessario eseguire operazioni particolari dal momento che il messaggio generato da Exchange Server Analyzer è puramente informativo.


L'attributo msExchRoutingGroupMembersBL è indicizzato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo Routing Group Back-Link è stato configurato per l'indicizzazione in Active Directory. Nello specifico, Exchange Server Analyzer esamina il seguente oggetto Active Directory per determinare il valore di indicizzazione corrente dell'attributo msExchRoutingGroupMembersBL:

CN=Configuration,DC=domain,DC=com, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Routing Groups, CN=RoutingGroupName

Per impostazione predefinita, questo attributo non è indicizzato. Se Exchange Server Analyzer rileva che l'attributo è configurato per l'indicizzazione, verrà visualizzato un messaggio di configurazione non predefinita.

In una installazione di Exchange distribuita o nelle filiali, contenente un grande numero di gruppi di routing, se questo attributo rimane non indicizzato può verificarsi una riduzione del livello delle prestazioni. Se, ad esempio, sono presenti centinaia di gruppi di routing nell'organizzazione di Exchange, è possibile osservare un incremento dell'attività su uno o più server di catalogo globale ogni 15 minuti. L'incremento di attività si verifica in quanto il componente DSAccess di Exchange rilegge la configurazione dei gruppi di routing. Nei casi gravi, è possibile che il catalogo globale venga consumato a causa di tale attività.

Per ridurre al minimo questo carico sul catalogo globale, è possibile indicizzare l'attributo Routing Group Back-Link riducendo, di conseguenza, il tempo impiegato da DSAccess per la lettura delle informazioni sui gruppo di routing e riducendo il carico posizionato sul catalogo globale da questa attività.

Per risolvere il problema

  • Non è necessario eseguire operazioni particolari dal momento che il messaggio generato da Exchange Server Analyzer è puramente informativo.

Per ulteriori informazioni sulla regolazione di Exchange per un migliore livello di prestazioni, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47576.


Rilevate più gerarchie di cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di gerarchie di cartelle pubbliche con il valore 1 per l'attributo msExchPFTreeType. Il valore 1 per l'attributo msExchPFTreeType indica che la gerarchia di cartelle pubbliche è la gerarchia di cartelle pubbliche designata per i client MAPI. Se Exchange Server Analyzer determina che per più di una gerarchia di cartelle pubbliche nell'organizzazione di Exchange è impostato il valore 1 per l'attributo msExchPFTreeType, verrà visualizzato un messaggio di errore.

Questo errore indica che nell'organizzazione di Exchange è stata rilevata più di una gerarchia di cartelle pubbliche per i client MAPI. La presenza di più gerarchie di cartelle pubbliche per i client MAPI può provocare problemi.

Per risolvere il problema, è possibile usare uno strumento di modifica di Active Directory per impostare su msExchPFTreeType il valore dell'attributo 0 di tutte le gerarchie di cartelle pubbliche ad eccezione di quella per i client MAPI. Se necessario, riconfigurare gli archivi delle cassette postali nei server di Exchange per impostare la gerarchia di cartelle pubbliche MAPI come archivio delle cartelle pubbliche per i client MAPI.

Gli strumenti seguenti sono strumenti di modifica di Active Directory:

  • ADSI Edit (Active Directory Service Interfaces, AdsiEdit.msc).

  • Strumento LDP (ldp.exe)

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Usare uno strumento di modifica di Active Directory per localizzare gli oggetti delle cartelle pubbliche in Active Directory. Gli oggetti delle cartelle pubbliche sono reperibili in: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Modificare l'attributo msExchPFTreeType per gli oggetti di tutte le gerarchie di cartelle pubbliche ad eccezione di quelli della gerarchia di cartelle pubbliche MAPI immettendo 0 come nuovo valore.

  3. Chiudere l'editor di Active Directory.

  4. Aprire Gestore di sistema di Exchange.

  5. Per accedere alle proprietà di ogni archivio delle cassette postali, fare clic su Gruppi amministrativi, espandere il proprio gruppo amministrativo, Server, il proprio server e, infine, il proprio gruppo di archiviazione. Quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali di cui si desidera modificare le proprietà e selezionare Proprietà.

  6. Nella scheda Generale fare clic su Sfoglia vicino al campo Archivio pubblico predefinito.

  7. Selezionare la gerarchia di cartelle pubbliche MAPI e fare clic su OK due volte per salvare le modifiche.

  8. Ripetere i passaggi da 5 a 7 per ogni archivio delle cassette postali.

Per ulteriori informazioni sulla modifica di Active Directory con lo strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sulle gerarchie di cartelle pubbliche per MAPI e per le applicazioni, consultare le seguenti risorse:

  • Articolo 258509 della Microsoft Knowledge Base "Descrizione dei tipi di struttura delle cartelle pubbliche in Exchange 2000 Server e in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509.

  • La voce del blog del team di Exchange "How mail-enabled Public Folders work" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41913 (informazioni in lingua inglese).


Parametro "NeverPing" consigliato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di trust stabiliti per ciascun dominio. Se almeno un controller di dominio in ciascun dominio ha il valore NeverPing impostato, verrà visualizzato un messaggio di configurazione ottimale.

Se le seguenti condizioni sono vere per ciascun dominio dell'ambiente Exchange Server 2003, verrà visualizzato un avviso:

  • Il dominio ha più di 50 trust stabiliti

  • I controller di dominio nel dominio hanno il valore della sottochiave NeverPing del Registro di sistema impostato su null (0)

Questo avviso indica che il processo LSASS.exe o il processo per l'autenticazione degli utenti nel dominio potrebbe essere ritardato. LSASS (Local Security Authority Subsystem Service) è un processo dei sistemi operativi Microsoft Windows che verifica l'accesso degli utenti a server o computer basati su Windows.

Per risolvere il problema, impostare il valore della sottochiave NeverPing del Registro di sistema per i controller di dominio su 1, come descritto di seguito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per impostare il parametro NeverPing per i controller di dominio nell'ambiente Exchange 2003

  1. Fare clic su Start, scegliere Esegui, digitare regedit, quindi fare clic su OK.

  2. Individuare la seguente sottochiave del Registro di sistema: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters.

  3. Fare clic con il pulsante destro del mouse sulla sottochiave, quindi scegliere Nuovo, Valore DWORD, digitare NeverPing, quindi premere INVIO.

  4. Fare clic con il pulsante destro del mouse su NeverPing, scegliere Modifica, digitare 1 nella casella Dati valore, quindi fare clic su OK.

  5. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su questo problema e per impostare il valore del parametro NeverPing per il controller di dominio, consultare l'articolo 825107 della Microsoft Knowledge Base "Il processo Lsass.exe potrebbe cessare di rispondere se sono presenti troppi trust esterni in un controller di dominio basato su Windows 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=825107.

Nota:
Sebbene l'articolo si riferisca a Microsoft Windows 2000 Server, le informazioni sono valide anche per Windows Server™ 2003. L'aggiornamento menzionato nell'articolo non è necessario per Windows Server 2003.


È disponibile una nuova versione di Active Directory Connector
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ogni oggetto Contratto di connessione. L'attributo versionNumber rappresenta la versione di Active Directory Connector in esecuzione sul computer.

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per Adc.exe, ovvero il file di Active Directory Connector. La chiave WMI (Strumentazione gestione Windows®) Version indica il numero di build del file.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • L'attributo versionNumber per l'oggetto Contratto di connessione è impostato su 16973842.

  • L'attributo versionNumber per l'oggetto Contratto di connessione è impostato su16973843 e il valore della chiave Version key for per Adc.exe è inferiore a 7250.0.

Il valore 16973842 indica che sul computer è in esecuzione la versione originale in commercio di ADC del CD di Exchange Server 2003 e il valore 16973843 con una chiave Version per Adc.exe inferiore a 7250.0 indica che sul computer è in esecuzione Exchange Server 2003 Service Pack 1 (SP1).

È disponibile una versione più recente di Active Directory Connector con Service Pack 2 per Exchange Server 2003. Si consiglia di utilizzare questa versione.

Per risolvere il problema

  1. Andare a Service Pack 2 per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54751 per scaricare la versione più recente di ADC.

  2. Disinstallare la versione esistente di ADC e installare la versione aggiornata.

Per ulteriori informazioni sui contratti di connessione ADC, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823601, "Requisiti ed effetti di Active Directory Connector in un'organizzazione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601.

  • 303180, "Requisiti del Contratto di connessione di Active Directory Connector per gruppi amministrativi in modalità mista" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180.

  • 317721, "XADM: Rimozione dei diritti del proprietario della cassetta postale di Exchange Server 5.5 quando si modifica il Contratto di connessione ADC impostandolo da unidirezionale a bidirezionale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721.


Il server di Exchange nominato per il Contratto di connessione non è presente nell'organizzazione
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchServer2NetworkAddress in ciascun oggetto Contratto di connessione. L'attributo msExchServer2NetworkAddress rappresenta l'indirizzo di rete del server che partecipa a questo Contratto di connessione. Exchange Server Analyzer enumera i gruppi amministrativi di Active Directory per verificare se il nome di questo server è elencato tra i membri di un Gruppo amministrativo che hanno un Contratto di connessione. Se il nome del server non è elencato in un gruppo amministrativo, verrà visualizzato un messaggio di errore.

Questo errore indica un Contratto di connessione isolata. Questa situazione può verificarsi nel caso in cui un computer Exchange Server non sia autorizzato. Se il computer Exchange Server è stato rimosso dall'organizzazione, è possibile modificare il nome del server di Exchange nella scheda Connessioni della finestra di dialogo Proprietà del Contratto di connessione nello strumento di amministrazione ADC (Active Directory Connector). Se il server di Exchange in questione non è in linea per manutenzione o per qualsiasi altro motivo, è possibile ignorare questo messaggio di errore.

Per risolvere il problema

  1. Fare clic su Start, scegliere Programmi, Strumenti di amministrazione, quindi fare clic su Active Directory Connector.

  2. Nel riquadro sinistro fare clic sul server ADC che ospita il Contratto di connessione da modificare.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse sul Contratto di connessione da modificare, quindi scegliere Proprietà.

  4. Selezionare la scheda Connessioni.

  5. Modificare il nome del server utilizzato per le connessioni nel nome di un server esistente.

Per ulteriori informazioni sui contratti di connessione ADC, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823601, "Requisiti ed effetti di Active Directory Connector in un'organizzazione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601.

  • 303180, "Requisiti del Contratto di connessione di Active Directory Connector per gruppi amministrativi in modalità mista" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180.


Il server della Rubrica non in linea incaricato non è presente nell'organizzazione
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo offLineABServer dell'oggetto di configurazione della rubrica non in linea. L'attributo offLineABServer è un attributo a valore singolo di nome distinto che consente di archiviare il nome distinto del computer Exchange Server responsabile della creazione di una rubrica non in linea.

Exchange Server Analyzer inoltre esamina il valore dell'attributo distinguishedName degli oggetti Exchange Server in Active Directory.

Se Exchange Server Analyzer rileva che il server elencato nell'attributo offLineABServer non corrisponde agli attributi distinguishedName trovati di oggetti Exchange Server e che l'attributo offLineABServer non contiene la stringa DEL:, verrà visualizzato un messaggio di errore.

Per ogni Rubrica non in linea Exchange genera e archivia i file della rubrica non in linea in un set di cartelle pubbliche in un server specifico. Se viene visualizzato questo messaggio significa che il server specificato nell'oggetto dell'elenco indirizzi non in linea non esiste. Questa situazione può verificarsi se il server della rubrica non in linea non dispone dell'autorizzazione o se è stato rimosso dalla topologia. Exchange non genererà la Rubrica non in linea fino a quando non si specifica un nuovo server.

Per risolvere il problema in Exchange 2000 Server ed Exchange Server 2003

  1. Nel Gestore di sistema di Exchange in Destinatari, fare clic su Elenchi di indirizzi non in linea. Nel riquadro destro fare clic con il pulsante destro del mouse su Elenco di indirizzi non in linea predefinito (o un altro elenco di indirizzi non in linea che ha generato il messaggio), quindi scegliere Proprietà.

  2. Nella sezione Server elenco indirizzi non in linea della scheda Generale fare clic su Sfoglia, quindi selezionare il server da utilizzare.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Microsoft Exchange e Configurazione organizzazione, quindi selezionare Cassetta postale.

  3. Nel riquadro dei risultati fare clic sulla scheda Rubrica fuori rete.

  4. Nella scheda Rubrica fuori rete selezionare "Rubrica fuori rete predefinita". Nel riquadro dei risultati fare clic su Sposta per avviare la procedura guidata Sposta Rubrica fuori rete, che consente di spostare la generazione della Rubrica fuori rete su un server diverso. Consente, inoltre, di copiare i file esistenti della Rubrica fuori rete sul server specificato.

Per utilizzare Exchange Management Shell per impostare il server che ospiterà la generazione della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dove: <OAB> è il nome distinto, il nome di dominio\account o l'identificatore univoco globale (GUID) della Rubrica fuori rete e <Server> consente di specificare il server di Exchange su cui eseguire l'operazione selezionata.

    Ad esempio, per spostare la generazione della Rubrica fuori rete su SERVER01, immettere:
Copia codice
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2003, consultare "Configurazione delle rubriche non in linea di Exchange Server 2003" in Utilizzo degli archivi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2007, consultare la sezione "Configurazione dell'organizzazione > Cassetta postale > Rubriche fuori rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=79247.


Il server di Exchange nominato per il Servizio aggiornamento destinatari non è presente nell'organizzazione
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-03-29

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo distinguishedName per tutti gli oggetti di Exchange Server nella directory. Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory per determinare il valore dell'attributo msExchAddressListServiceLink per ciascun oggetto del Servizio aggiornamento destinatari della directory. L'attributo msExchAddressListServiceLink è un collegamento dal servizio elenco di indirizzi al computer Exchange Server sul quale dovrebbe essere eseguito. Se Exchange Server Analyzer rileva che il valore per l'attributo msExchAddressListServiceLink non contiene la stringa DEL: e non corrisponde a quello per l'attributo distinguishedName per qualsiasi oggetto di Exchange Server nella directory, verrà visualizzato un messaggio di errore.

Ogni istanza del Servizio aggiornamento destinatari è associata a un computer Exchange Server che esegue il servizio. Se viene visualizzato questo messaggio, l'istanza del Servizio aggiornamento destinatari è associata a un computer Exchange Server che non esiste nell'organizzazione di Exchange. È possibile che le autorizzazioni per il server siano state rimosse o che il server sia stato rimosso dalla topologia.

Per eseguire questa istanza del Servizio aggiornamento destinatari, è necessario associarla a un server Exchange esistente.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. In Destinatari fare clic su Servizi aggiornamento destinatari. Nel riquadro destro fare clic con il pulsante destro del mouse sull'istanza appropriata del Servizio aggiornamento destinatari, quindi fare clic su Proprietà.

  3. Nella scheda Generale, in Exchange Server fare clic su Sfoglia e specificare un nuovo server per eseguire l'istanza.

  4. Per rendere effettive le modifiche, fare clic su OK, quindi su OK.

  5. Chiudere Gestore di sistema di Exchange.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti argomenti di Exchange e articoli della Microsoft Knowledge Base:

  • "Gestione dei destinatari e dei criteri destinatario" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47617.

  • 328738, "XADM: Applicazione dei criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • 246127, "XADM: Verifica dell'esecuzione del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127.

  • 253770, "XADM: 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.


Il server principale del gruppo di routing nominato non è stato rilevato in questo gruppo amministrativo
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchRoutingMasterDN per ogni contenitore del gruppo di routing. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchRoutingMasterDN non contiene un nome server valido e non contiene la stringa "DEL:", verrà visualizzato un avviso.

Il problema può verificarsi se il precedente master del gruppo di routing non dispone dell'autorizzazione oppure è stato rimosso in maniera inappropriata dalla topologia. Senza il master del gruppo di routing, Exchange non sarà in grado di aggiornare correttamente o mantenere la topologia di routing.

Quando si crea un gruppo di routing, al primo server in quel gruppo viene assegnato il ruolo di master del gruppo di routing. Il master del gruppo di routing conserva le informazioni sullo stato corrente del collegamento per il proprio gruppo di routing e le propaga agli altri server all'interno del gruppo. Il master del gruppo di routing controlla la configurazione di routing scritta in Active Directory solo per il proprio gruppo di routing. I server membri possono comunicare al master del gruppo di routing qualunque informazione relativa allo stato del connettore o alla disponibilità del server. Ad esempio, se un server membro tenta di contattare un altro server in un diverso gruppo di routing tramite un connettore ma il collegamento non è disponibile, il server membro informa immediatamente il master del gruppo di routing. Allo stesso modo, quando un server non master riceve informazioni sullo stato di un nuovo collegamento, trasferisce immediatamente le informazioni sullo stato del connettore al master del gruppo di routing, in modo che gli altri server possano ricevere informazioni sulla modifica del routing.

Per risolvere il problema

  1. In Gestore di sistema di Exchange, in Gruppi amministrativi, espandere AdministrativeGroup, quindi Gruppi di routing.

  2. Espandere la struttura del gruppo di routing, quindi fare clic su Membri.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse sul computer Exchange da configurare come master del gruppo di routing, quindi scegliere Imposta come master.

Per ulteriori informazioni sui master del gruppo di routing, consultare "Configurazione della topologia di routing" in Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47579.


Il numero di contratti di connessione cartelle pubbliche è minore del numero di contratti di connessione configurazione
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se è disponibile un Contratto di connessione cartelle pubbliche tra Active Directory e ogni sito Exchange Server 5.5. L'operazione viene eseguita ricercando sia il numero di contratti di connessione cartelle pubbliche sia il numero di contratti di connessione configurazione. Se Exchange Server Analyzer rileva che il numero di contratti di connessione cartelle pubbliche è inferiore al numero di contratti di connessione configurazione, verrà visualizzato un avviso.

Tale messaggio indica che almeno un sito Exchange Server 5.5 non dispone di un Contratto di connessione cartelle pubbliche con Active Directory e non è in grado di replicare in Active Directory gli oggetti di directory per le cartelle pubbliche. Pertanto, la posta non può passare dalle cassette postali di Exchange 2000 Server o Exchange Server 2003 alle cartelle pubbliche di Exchange Server 5.5, né dalle cassette postali di Exchange Server 5.5 alle cartelle pubbliche abilitate per l'utilizzo di posta elettronica di Exchange 2000 Server o Exchange Server 2003.

I contratti di connessione configurazione vengono generati automaticamente quando si installa un computer Exchange 2000 Server o Exchange Server 2003 in un sito Exchange Server 5.5. I contratti di connessione cartelle pubbliche sono definiti dall'utente. Se esiste un Contratto di connessione cartelle pubbliche tra ciascun sito Exchange Server 5.5 e Active Directory, si avrà almeno lo stesso numero di Contratti di connessione cartelle pubbliche e di Contratti di connessione configurazione.

Per creare un Contratto di connessione cartelle pubbliche

  1. In un server Active Directory Connector (ADC) avviare il programma di gestione di Active Directory Connector. (Scegliere Programmi o Tutti i programmi dal menu d'avvio, scegliere Microsoft Exchange, quindi fare clic su Active Directory Connector).

  2. Nella struttura della console fare clic su Active Directory Connector. Nella finestra di destra sono elencati i contratti di connessione. Utilizzare questo elenco per determinare quali siti non dispongono di contratti di connessione cartelle pubbliche.

  3. Selezionare Nuovo dal menu Azione, quindi fare clic su Contratto di connessione cartelle pubbliche per visualizzare la finestra di dialogo Proprietà.

  4. Nella scheda Generale digitare un nome per il Contratto di connessione nel campo Nome.

  5. Nella casella Servizio Active Directory Connector selezionare un server in cui eseguire il Contratto di connessione.

  6. Nella scheda Connessioni selezionare il server Active Directory e il server di Exchange Server 5.5 di cui replicare gli oggetti delle cartelle pubbliche, specificando l'account e le credenziali adeguate per ciascuno.

  7. Nella scheda Pianificazione selezionare la pianificazione della replica.

  8. Fare clic su OK.

Per ulteriori informazioni sui Contratti di connessione cartelle pubbliche e Contratti di connessione configurazione, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 264889, "XADM: Contratti di connessione cartelle pubbliche" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=264889.

  • 281223, "I Contratti di connessione in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=281223.


La generazione della rubrica fuori rete è impostata per l'aggiornamento continuo
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-04

The Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo offLineABSchedule nella classe msExchOAB è stato configurato per la generazione della rubrica non in linea. L'attributo offLineABSchedule determina la pianificazione della rubrica non in linea. Se Exchange Server Analyzer rileva che la pianificazione per la generazione dell'elenco indirizzi non in linea è impostato per l'aggiornamento continuo, verrà visualizzato un messaggio di errore.

Una rubrica non in linea è un contenitore in cui viene archiviata una raccolta di elenchi di indirizzi non in linea. Le rubriche fuori rete disponibili vengono configurate dagli amministratori. Gli utenti di Microsoft Office Outlook® 2003 e Outlook 2007 possono scegliere quali elenchi di indirizzi non in linea desiderano scaricare. Gli elenchi di indirizzi non in linea possono essere scaricati dai client MAPI, ad esempio, Outlook 2003 e Outlook 2007. Pertanto, gli utenti possono scrivere messaggi di posta elettronica anche quando sono disconnessi dal server di Exchange.

È possibile pianificare l'aggiornamento degli elenchi di indirizzi non in linea. Assicurarsi, tuttavia, di configurare una pianificazione dell'aggiornamento che preveda un intervallo di tempo sufficiente per il completamento della generazione dell'elenco indirizzi non in linea prima che inizi l'aggiornamento successivo. Ad esempio, se le seguenti condizioni vengono soddisfatte, sarà necessario un periodo di almeno quattro ore tra ciascun intervallo di aggiornamento:

  • Vengono specificati tre aggiornamenti in un intervallo di tempo di 24 ore.

  • È necessario un intervallo di quattro ore per aggiornare gli elenchi di indirizzi non in linea.

In genere non è consigliabile eseguire aggiornamenti frequenti in quanto potrebbero influenzare le prestazioni del client e del server nei seguenti modi:

  • Il server deve generare la rubrica non in linea a intervalli di tempo più frequenti. Il completamento potrebbe richiedere ore, a seconda della dimensione di Active Directory.

  • Per ciascun aggiornamento, in Outlook deve essere creata una copia della rubrica non in linea sul computer locale e devono essere applicate le modifiche incrementali recuperate dal server. Se la dimensione della rubrica non in linea sul computer locale è pari a 150 MB, è necessario che in Outlook venga creata una copia di tali dati con ciascun aggiornamento.

  • Outlook dispone di un meccanismo di limitazione che consente di rallentare l'aggiornamento della rubrica non in linea quando si rileva un'attività dell'utente. Quando l'attività dell'utente è continua, la dimensione della rubrica non in linea ha effetto sull'intervallo di tempo richiesto per gli aggiornamenti. Questo intervallo di tempo può variare da un'ora a otto ore.

Se si desidera aumentare la frequenza degli aggiornamenti, assicurarsi che la dimensione della rubrica non in linea sia ragionevolmente ridotta, ovvero che la dimensione non compressa sia compresa tra 1 MB a 25 MB.

Per pianificare un intervallo di tempo per l'aggiornamento degli elenchi di indirizzi non in linea in Exchange 2000 Server ed Exchange Server 2003

  1. In Gestore di sistema fare doppio clic su Destinatari, quindi su Elenchi indirizzi non il linea.

  2. Nel riquadro dei dettagli fare doppio clic sull'elenco di indirizzi non in linea per il quale si desidera impostare una pianificazione di aggiornamento.

    1. Per scegliere un intervallo di aggiornamento preconfigurato, nella scheda Generale selezionare uno degli intervalli forniti nell'elenco a discesa Intervallo di aggiornamento.

      Importante:
      Se si seleziona Non eseguire mai dall'elenco a discesa, l'elenco di indirizzi non in linea non verrà aggiornato.
    2. Per impostare una pianificazione di aggiornamento specifica, fare clic su Personalizza. Nella finestra di dialogo Pianificazione impostare la pianificazione di aggiornamento nella griglia visualizzata relativa alla data e all'ora, quindi fare clic su OK.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Microsoft Exchange e Configurazione organizzazione, quindi selezionare Cassetta postale.

  3. Nel riquadro dei risultati fare clic sulla scheda Rubrica fuori rete.

  4. Nella scheda Rubrica fuori rete selezionare "Rubrica fuori rete predefinita". Nel riquadro azioni fare clic su Proprietà.

  5. Nella scheda Generale selezionare l'esecuzione dall'elenco a discesa Pianificazione aggiornamento oppure selezionare Personalizza per impostare una pianificazione personalizzata.

  6. Fare clic su OK per salvare le modifiche.
Per usare Exchange Management Shell per impostare la pianificazione della generazione della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Dove: <OAB> è il nome distinto, il nome di dominio\account o l'identificatore univoco globale (GUID) della Rubrica fuori rete e<Schedule> consente di specificare gli orari pianificati per l'avvio della generazione della Rubrica fuori rete con il formato StartDay.Hour:Minute [AM/PM]. Per i giorni è possibile utilizzare i seguenti valori:

    • Nome completo del giorno

    • Nome abbreviato del giorno

    • Numero intero compreso tra 0 e 6, dove 0 = domenica

    Per utilizzare il formato di 24 ore per l'orario, omettere AM/PM.

    Ad esempio, per impostare la pianificazione della generazione della Rubrica fuori rete predefinita su un orario compreso tra l'1 e le 3 del mattino di ogni giorno, immettere:
Copia codice
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Per ulteriori informazioni, consultare il manuale Offline Address Book Best Practices Guide all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47583 (informazioni in lingua inglese).

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2003, consultare "Configurazione delle rubriche non in linea di Exchange Server 2003" in Utilizzo degli archivi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2007, consultare la sezione "Configurazione dell'organizzazione > Cassetta postale > Rubriche fuori rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=79247.


La pianificazione di generazione della Rubrica fuori rete è stata impostata su Mai
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo offLineABSchedule dell'oggetto di configurazione della rubrica non in linea. L'attributo offLineABSchedule rappresenta la pianificazione di generazione della rubrica non in linea per l'Elenco di indirizzi non in linea predefinito nel contenitore Elenchi di indirizzi in Active Directory. Se Exchange Server Analyzer rileva che l'attributo offLineABSchedule è impostato su Mai, verrà visualizzato un avviso.

Per impostazione predefinita, Exchange mantiene un'unica rubrica non in linea. Exchange aggiorna questa rubrica non in linea (o ne genera una nuova versione) ogni notte durante il ciclo di manutenzione. È possibile creare ulteriori rubriche fuori rete e utilizzare la procedura descritta di seguito per controllarne la pianificazione di generazione.

Questo avviso indica che la pianificazione è stata modificata in Mai. Exchange non aggiornerà la rubrica non in linea esistente fino a quando non verrà impostata una nuova pianificazione. Gli utenti possono scaricare la rubrica non in linea esistente, ma non riceveranno aggiornamenti.

Per risolvere il problema in Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Nella sezione Destinatari fare clic su Elenchi di indirizzi non in linea.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse su Elenco di indirizzi non in linea predefinito e fare clic su Proprietà. Se non si desidera utilizzare una rubrica non in linea, fare clic con il pulsante destro del mouse su Rubrica non in linea predefinita, quindi fare clic su Elimina. Altrimenti, utilizzare il resto della procedura per impostare una pianificazione.

  4. Nella scheda Generale selezionare l'esecuzione dall'elenco a discesa Intervallo di aggiornamento oppure selezionare Personalizza per impostare una pianificazione personalizzata.

  5. Fare clic su OK per salvare le modifiche.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Microsoft Exchange e Configurazione organizzazione, quindi selezionare Cassetta postale.

  3. Nel riquadro dei risultati fare clic sulla scheda Rubrica fuori rete.

  4. Nella scheda Rubrica fuori rete selezionare "Rubrica fuori rete predefinita". Nel riquadro azioni fare clic su Proprietà.

  5. Nella scheda Generale selezionare l'esecuzione dall'elenco a discesa Pianificazione aggiornamento oppure selezionare Personalizza per impostare una pianificazione personalizzata.

  6. Fare clic su OK per salvare le modifiche.

Per usare Exchange Management Shell per impostare la pianificazione della generazione della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Set-OfflineAddressBook -Identity <OAB Name> -Schedule <Schedule>

    Dove: <OAB> è il nome distinto, il nome di dominio\account o l'identificatore univoco globale (GUID) della Rubrica fuori rete e<Schedule> consente di specificare gli orari pianificati per l'avvio della generazione della Rubrica fuori rete con il formato StartDay.Hour:Minute [AM/PM]. Per i giorni è possibile utilizzare i seguenti valori:

    • Nome completo del giorno

    • Nome abbreviato del giorno

    • Numero intero compreso tra 0 e 6, dove 0 = domenica

    Per utilizzare il formato di 24 ore per l'orario, omettere AM/PM.

    Ad esempio, per impostare la pianificazione della generazione della Rubrica fuori rete predefinita su un orario compreso tra l'1 e le 3 del mattino di ogni giorno, immettere:
Copia codice
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -Schedule 0.01:00-0.03:00,1.01:00-1.03:00,2.01:00-2.03:00,3.01:00-3.03:00,4.01:00-4.03:00,5.01:00-5.03:00,6.01:00-6.03:00

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2003, consultare "Configurazione delle rubriche non in linea di Exchange Server 2003" in Utilizzo degli archivi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2007, consultare la sezione "Configurazione dell'organizzazione > Cassetta postale > Rubriche fuori rete" all'indirizzo http://go.microsoft.com/fwlink?LinkId=79247.


Rilevata versione precedente del Contratto di connessione
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber in ogni Contratto di connessione Active Directory Connector (ADC).

Se Exchange Server Analyzer rileva che il valore dell'attributo versionNumber di un Contratto di connessione è inferiore a 16973842 in un'organizzazione di Exchange contenente uno o più computer che eseguono Exchange Server 2003, verrà visualizzato un avviso.

Un valore minore di 16973842 indica che il Contratto di connessione è stato creato ed è gestito da un ADC di Exchange 2000 Server. Se vengono eseguite istanze di Exchange Server 2003 nella propria organizzazione, in cui sono in esecuzione Exchange 2000 Server o Exchange Server 5.5, sarà necessario aggiornare tutte le istanze dell'ADC alla versione inclusa con Exchange Server 2003. Dopo l'aggiornamento a Exchange Server 2003 o alla versione Exchange Server 2003 Service Pack 1 (SP1) dell'ADC, verranno aggiornati a tale versione anche i Contratti di connessione di proprietà dell'ADC. L'attributo versionNumber di ciascun Contratto di connessione verrà aggiornato con il valore più recente.

Per risolvere il problema

  1. Scaricare Exchange Server 2003 SP1 dalla pagina http://go.microsoft.com/fwlink/?LinkId=29090.

  2. Eseguire un backup completo del computer che esegue Exchange Server.

  3. Nel server su cui è in esecuzione l'ADC di Exchange 2000 Server, fare clic su Start, scegliere Esegui, quindi digitare <percorso>\adc\i386\setup.exe dove <path> è il percorso del download di Exchange Server 2003 SP1.

  4. Nella pagina Installazione guidata di Active Directory Connector, fare clic su Avanti.

  5. Nella pagina Rilevata installazione precedente fare clic su Reinstalla per aggiornare l'ADC di Exchange 2000 Server all'ADC di Exchange Server 2003.

  6. Nella pagina di completamento dell'Installazione guidata di Active Directory Connector, fare clic su Fine.

Per ulteriori informazioni sull'installazione e l'aggiornamento di ADC, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823601, "Requisiti ed effetti di Active Directory Connector in un'organizzazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823601.

  • 822942, "Considerazioni sull'aggiornamento a Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822942.


Il ruolo FSMO dell'emulatore PDC non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo fSMORoleOwner dell'elemento principale della partizione della directory di dominio nel contesto dei nomi di dominio. Ad esempio, in un dominio che si chiama contoso.com, l'attributo fSMORoleOwner per il controller di dominio privato (PDC) è un attributo di DC=contoso,DC=com. Exchange Server Analyzer tenta quindi di stabilire una connessione LDAP (Lightweight Directory Access Protocol) alla porta TCP 389 sul controller di dominio che riveste questo ruolo. Se non è possibile stabilire la connessione a questo controller di dominio, verrà visualizzato un messaggio di errore.

L'emulatore PDC funge da controller del dominio per compatibilità con le versioni precedenti dei sistemi operativi di Microsoft Windows®. Microsoft Windows 2000 Server e Microsoft Windows Server™ 2003 interagiscono con le workstation Microsoft Windows NT®, i server membri e i controller di dominio di backup. Il controller di dominio primario (PDC) in un dominio Microsoft Windows NT 3.51 o Microsoft Windows NT 4.0 è responsabile delle seguenti operazioni:

  • Elaborazione delle modifiche delle password da utenti e computer

  • Replica degli aggiornamenti per eseguire il backup dei controller di dominio

  • Esecuzione del browser principale dominio

In qualsiasi momento il ruolo master emulatore PCD può essere assegnato a un unico controller di dominio in ciascun dominio.

Per risolvere il problema

  1. Verificare che il server di elenchi in linea specificato nel messaggio di errore sia in linea e accessibile dai server di Exchange nell'organizzazione.

  2. Se il server di elenchi in linea non dispone dell'autorizzazione, è necessario assegnare il ruolo di emulatore PDC a un altro controller di dominio.

Per ulteriori informazioni sul trasferimento del ruolo di emulatore PCD da un controller di dominio a un altro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801 della Knowledge Base, "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows 2000 Server, consultare l'articolo 255690, "HOW TO: Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Blocco dell'ereditarietà delle autorizzazioni per l'oggetto configurazione
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-04-13

Microsoft® Exchange Server Analyzer Tool esegue una query in tutti gli oggetti di configurazione di Exchange nel database di Active Directory® per determinare se sono presenti oggetti con ereditarietà delle autorizzazioni bloccata. Se l'ereditarietà delle autorizzazioni è bloccata per un oggetto configurazione di Exchange, verrà visualizzato un messaggio di errore.

Exchange Server Analyzer identifica l'oggetto configurazione per il quale è stata bloccata l'ereditarietà delle autorizzazioni.

Exchange Server Analyzer recupera gli elenchi di controllo di accesso discrezionale (DACL, Discretionary Access Control Lists) da Active Directory per gli oggetti configurazione di Exchange. Per impostazione predefinita, gli oggetti configurazione quali i server Exchange e i protocolli di Exchange Server sono impostati per ereditare le autorizzazioni quando viene installato Exchange. Se le autorizzazioni vengono accidentalmente deselezionate o modificate, l'ereditarietà delle autorizzazioni per un oggetto può risultare bloccata. In questa situazione, problemi nel flusso di posta, ad esempio la permanenza dei messaggi in coda, e problemi nell'installazione dell'archivio possono rallentare la capacità di risposta del server Exchange.

Nota:
L'elenco di controllo di accesso (ACL, Access Control List) è un elenco di protezioni che si applicano a un oggetto intero, a un set di proprietà dell'oggetto o a una singola proprietà dell'oggetto. Esistono due tipi di elenchi di controllo di accesso: discrezionale e di sistema.

Per risolvere il problema, riabilitare l'ereditarietà delle autorizzazioni per l'oggetto.

Per riabilitare l'ereditarietà delle autorizzazioni per un oggetto configurazione di Exchange

  1. Abilitare la scheda Protezione nella casella delle proprietà dell'oggetto nel Gestore di sistema di Exchange impostando un parametro del Registro di sistema. Per la procedura dettagliata, consultare l'articolo 264733 della Microsoft Knowledge Base "Abilitazione della scheda Protezione per l'oggetto organizzazione in Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264733.

    Nota:
    Per impostazione predefinita, la scheda Protezione non è abilitata nella casella delle proprietà dell'oggetto configurazione.

  2. Aprire il Gestore di sistema di Exchange, trovare l'oggetto in questione e riabilitare l'ereditarietà delle autorizzazioni.

  3. Riavviare Exchange Server.

Per ulteriori informazioni sugli elenchi di controllo di accesso discrezionale in Windows Server 2003 Active Directory, consultare "Descrittori di protezione ed elenchi di controllo di accesso" all'indirizzo

(http://go.microsoft.com/fwlink/?LinkId=64193.

Per ulteriori informazioni sull'ereditarietà delle autorizzazioni, consultare "Autorizzazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64195.


Blocco dell'ereditarietà delle autorizzazioni per l'oggetto dominio
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-04-13

Microsoft® Exchange Server Analyzer Tool controlla gli oggetti di dominio di Active Directory® quali contenitori e unità organizzative. Se l'ereditarietà delle autorizzazioni viene bloccata nei contenitori o nelle unità organizzative, verrà visualizzato un messaggio di errore.

Exchange Server Analyzer identifica l'oggetto specifico.

Quando vengono effettuate modifiche a un oggetto di dominio Active Directory, vengono sovrascritte le modifiche all'elenco di controllo di accesso (ACL). Anche se l'opzione "Eredita dall'oggetto padre" è abilitata manualmente, l'ereditarietà applicata viene disabilitata quando le modifiche vengono applicate all'elenco di controllo di accesso. Questa condizione provoca problemi al Servizio aggiornamento destinatari (RUS, Recipient Update Service), poiché tale servizio non dispone delle autorizzazioni necessarie per l'unità organizzativa di Active Directory nella quale risiede l'account.

Questa situazione si può verificare se è stata deselezionata la casella di controllo Consenti propagazione delle autorizzazioni ereditabili dall'oggetto padre a questo oggetto nell'unità organizzativa di Active Directory nella quale risiede l'account.

Per risolvere questo problema, utilizzare lo snap-in Utenti e computer di Active Directory oppure ADSI Edit per ristabilire le autorizzazioni ereditabili per l'unità organizzativa. Seguire la procedura dettagliata descritta nello scenario due dell'articolo 254030 della Microsoft Knowledge Base "La mancanza delle autorizzazioni non consente al Servizio aggiornamento destinatari di elaborare gli account in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=254030.

Per ulteriori informazioni sugli elenchi di controllo di accesso in Microsoft Windows Server 2003™ Active Directory, consultare "Descrittori di protezione ed elenchi di controllo di accesso" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64193.

Per ulteriori informazioni sull'ereditarietà delle autorizzazioni, consultare "Autorizzazioni all'indirizzo http://go.microsoft.com/fwlink/?LinkId=64195 (informazioni in lingua inglese).


Impossibile trovare la gerarchia di cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di gerarchie di cartelle pubbliche con il valore 1 per l'attributo msExchPFTreeType. Il valore 1 per l'attributo msExchPFTreeType indica che una particolare gerarchia di cartelle pubbliche è la gerarchia di cartelle pubbliche designata per i client MAPI. Se Exchange Server Analyzer determina che per nessuna gerarchia di cartelle pubbliche nell'organizzazione di Exchange è impostato il valore 1 per l'attributo msExchPFTreeType, verrà visualizzato un errore.

Tale messaggio indica che non esistono gerarchie di cartelle pubbliche per i client MAPI nell'organizzazione. L'assenza di una gerarchia di cartelle pubbliche per i client MAPI può provocare problemi. Ad esempio, l'assenza di una gerarchia di cartelle pubbliche per i client MAPI può impedire l'aggiornamento di un server virtuale di Exchange eseguito in un server cluster di Microsoft Windows®.

Per risolvere il problema, è possibile usare uno strumento di modifica di Active Directory per impostare il valore dell'attributo msExchPFTreeType della gerarchia di cartelle pubbliche per i client MAPI su 1. Gli strumenti seguenti sono strumenti di modifica di Active Directory:

  • ADSI Edit (Active Directory Service Interfaces, AdsiEdit.msc).

  • Strumento LDP (ldp.exe)

È preferibile modificare solo la gerarchia di cartelle pubbliche MAPI. Se l'organizzazione di Exchange include gerarchie di cartelle pubbliche di applicazioni, assicurarsi di modificare l'attributo solo per la gerarchia di cartelle pubbliche MAPI.

Dopo aver impostato il valore dell'attributo msExchPFTreeType della gerarchia di cartelle pubbliche MAPI su 1, configurare gli archivi cassette postali nei server di Exchange affinché facciano riferimento alla gerarchia di cartelle pubbliche MAPI come archivio di cartelle pubbliche predefinito.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Windows Server 2003, Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Usare uno strumento di modifica di Active Directory per localizzare gli oggetti della gerarchia di cartelle pubbliche in Active Directory. Gli oggetti delle cartelle pubbliche sono reperibili in CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Folder Hierarchies

  2. Modificare l'attributo msExchPFTreeType immettendo 1 come nuovo valore.

  3. Chiudere l'editor di Active Directory.

  4. Aprire Gestore di sistema di Exchange.

  5. Per accedere alle proprietà di ogni archivio delle cassette postali, fare clic su Gruppi amministrativi, espandere il proprio gruppo amministrativo, Server, il proprio server e, infine, il proprio gruppo di archiviazione. Quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali di cui si desidera modificare le proprietà e selezionare Proprietà.

  6. Nella scheda Generale fare clic su Sfoglia vicino al campo Archivio pubblico predefinito.

  7. Selezionare la gerarchia di cartelle pubbliche MAPI e fare clic su OK due volte per salvare le modifiche.

  8. Ripetere i passaggi da 5 a 7 per ogni archivio delle cassette postali.

Per ulteriori informazioni sulla modifica di Active Directory con lo strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sulle gerarchie di cartelle pubbliche per MAPI e per le applicazioni, consultare le seguenti risorse:

  • Articolo 258509 della Microsoft Knowledge Base "Descrizione dei tipi di struttura delle cartelle pubbliche in Exchange 2000 Server e in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258509.

  • La voce del blog del team di Exchange "How mail-enabled Public Folders work" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41913 (informazioni in lingua inglese).


La pianificazione repliche del Contratto di connessione destinatario non è impostata su "Sempre"
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare su quale valore è impostato l'attributo activationStyle per ogni contratto di connessione ADC (Active Directory Connector). L'attributo activationStyle corrisponde alla frequenza di esecuzione del Contratto di connessione ADC. Il valore 0 indica che la pianificazione repliche è impostata su Mai. Il valore 1 indica che la pianificazione repliche è impostata su Orari selezionati. Il valore 2 indica che la pianificazione repliche è impostata su Sempre.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchServer2SearchFilter per ciascun oggetto contratto di connessione ADC. L'attributo msExchServer2SearchFilter rappresenta il filtro di ricerca utilizzato quando si esegue una ricerca nella directory.

Se Exchange Server Analyzer rileva che l'attributo activationStyle non è impostato su Sempre e che l'attributo msExchServer2SearchFilter esegue una replica delle informazioni sul destinatario, verrà visualizzato un avviso.

In genere, si consiglia di impostare la pianificazione repliche del Contratto di connessione destinatario su Sempre. In alcuni casi, se il Contratto di connessione viene impostato su una pianificazione diversa e se le cassette postali vengono spostate da siti Exchange Server 5.5 a organizzazioni Exchange Server 2003, possono essere generati dei rapporti di mancato recapito (NDR).

Per risolvere il problema

  1. Aprire lo snap-in Servizi MMC di Active Directory Connector.

  2. Aprire il Contratto di connessione.

  3. Nella pagina Proprietà Contratto di connessione selezionare la scheda Pianificazione, Sempre quindi fare clic su OK.

Per ulteriori informazioni sulla distribuzione di ADC e sulla configurazione dei contratti di connessione, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.


Il criterio destinatario include delle variabili
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo gatewayProxy per ciascun oggetto criterio destinatario. Se Exchange Server Analyzer rileva che un oggetto criterio destinatario contiene la stringa SMTP:% nell'attributo gatewayProxy, verrà visualizzato un messaggio di configurazione non predefinita.

Se si modifica un criterio destinatario per generare indirizzi SMTP (Simple Mail Transfer Protocol) utilizzando stringhe di sostituzione, il criterio destinatario includerà delle variabili. L'utilizzo di variabili nel criterio destinatario predefinito può provocare problemi di replica nelle versioni di Exchange 2000 Server precedenti al Service Pack 2 (SP2). Pertanto, si consiglia di non utilizzare variabili nei criteri destinatari oppure di aggiornare Exchange 2000 Server al Service Pack più recente. In Exchange 2000 Server SP2 e versioni successive le variabili nel criterio destinatario predefinito sono supportate.

Per modificare un criterio destinatario

  1. Avviare Gestore di sistema di Exchange.

  2. Fare clic su Organizzazione, quindi su Destinatari e infine su Criteri destinatari.

  3. Fare doppio clic sul criterio che si desidera modificare.

  4. Fare clic sulla scheda Indirizzi di posta elettronica, quindi modificare l'indirizzo SMTP o la regola di generazione appropriata.

Per ulteriori informazioni sulla procedura di configurazione dei criteri destinatari, consultare l'articolo 249299 della Microsoft Knowledge Base "HOW TO: XADM: Configurare criteri destinatari in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249299.

Per ulteriori informazioni sull'utilizzo delle regole di generazione per personalizzare gli indirizzi SMTP, consultare l'articolo 822447 della Microsoft Knowledge Base "Modifica di un indirizzo di posta elettronica SMTP mediante criteri destinatari" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822447.

Per ulteriori informazioni sui problemi che possono verificarsi in Exchange 2000 Server se il criterio destinatario predefinito include variabili, consultare l'articolo 271339 della Microsoft Knowledge Base "XADM: L'utente non riesce a installare il database e si verifica l'ID evento 9546" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=271339.

Per ottenere i Service Pack più recenti per Exchange 2000 Server, consultare "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Il Servizio aggiornamento destinatari sembra bloccato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchServer1HighestUSN per ciascun oggetto del Servizio aggiornamento destinatari di Active Directory. Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory per determinare il valore dell'attributo activationStyle per ciascun oggetto del Servizio aggiornamento destinatari di Active Directory. L'attributo activationStyle indica l'intervallo di aggiornamento del Servizio aggiornamento destinatari.

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo highestCommittedUSN per l'attributo RootDSE del controller di dominio utilizzato dal Servizio aggiornamento destinatari. L'attributo highestCommittedUSN è il numero di sequenza di aggiornamento (USN, Update Sequence Number) più alto per qualunque oggetto sul server che è stato salvato nel database su questo controller di dominio.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory per determinare il valore dell'attributo msExchServer1LastUpdateTime per ciascun oggetto del Servizio aggiornamento destinatari di Active Directory. L'attributo msExchServer1LastUpdateTime indica la data e l'ora dell'aggiornamento più recente dell'ultima sincronizzazione eseguita correttamente dalla directory.

Se Exchange Server Analyzer rileva le tre condizioni indicate di seguito, verrà visualizzato un avviso:

  • L'attributo activationStyle è impostato su 2 e indica che la pianificazione per questo Servizio aggiornamento destinatari è impostata su Sempre.

  • Il valore del numero di sequenza elencato in msExchServer1HighestUSN supera di almeno 5.000 unità il numero di sequenza elencato in highestCommittedUSN.

  • Sono trascorse almeno sei ore da quando è stato registrato il time stamp nell'attributo msExchServer1LastUpdateTime.

Questo avviso indica che il Servizio aggiornamento destinatari specificato non è stato eseguito da diverse ore e potrebbe essere bloccato.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Destinatari, quindi selezionare Servizio aggiornamento destinatari.

  3. Fare clic con il pulsante destro del mouse sul Servizio aggiornamento destinatari specificato e scegliere Aggiorna.

  4. Attendere 30 minuti, quindi eseguire nuovamente Exchange Server Analyzer per vedere se viene ancora rilevata la condizione di avviso. In caso affermativo, procedere al passaggio 5. Se la condizione non viene più rilevata, non sarà necessario eseguire ulteriori operazioni.

  5. Riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • 253838, "XADM: Applicazione dei criteri di sistema da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838.

  • 328738, "XADM: Applicazione dei criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.


Il Servizio aggiornamento destinatari non ha elaborato tutte le modifiche
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se esistono valori dell'attributo gatewayProxy per ciascun oggetto Servizio aggiornamento destinatari di Active Directory. Se Exchange Server Analyzer rileva valori impostati per l'attributo gatewayProxy per ciascun oggetto Servizio aggiornamento destinatari, verrà visualizzato un avviso.

Questo avviso indica che l'attributo gatewayProxy di un oggetto del Servizio aggiornamento destinatari contiene dati obsoleti non completamente elaborati. Tali dati dovrebbero essere rimossi manualmente.

È necessario rimuovere i dati obsoleti dall'attributo gatewayProxy. In caso contrario, questi indirizzi verranno visualizzati come "applicati". Se l'amministratore decide di modificare un criterio utilizzando le opzioni "Ricostruisci" e "Aggiorna", gli indirizzi utente validi potrebbero essere accidentalmente sovrascritti, causando la modifica degli indirizzi SMTP per ciascun utente. Per ulteriori informazioni, consultare l'articolo del blog di Exchange Recipient Policies and pure Exchange 2000/2003 sites (informazioni in lingua inglese).

Nota:
Il collegamento a questo blog viene fornito a scopo puramente informativo. Il contenuto può essere modificato senza preavviso.

L'attributo gatewayProxy di un oggetto del Servizio aggiornamento destinatari può contenere dati obsoleti non completamente elaborati, se si verifica una delle seguenti condizioni:

  • Si sono verificati problemi con la replica di Active Directory. Se Gestore di sistema di Exchange utilizza un controller di domino diverso da quello utilizzato dal server Exchange in cui viene eseguito il Servizio aggiornamento destinatari, si possono verificare problemi di latenza o altri problemi con la replica di Active Directory.

  • Sono presenti problemi di intervalli non di transazione che provocano la perdita delle modifiche. Questo comportamento si può verificare quando Gestore di sistema di Exchange e Supervisore sistema accedono all'attributo gatewayProxy simultaneamente. Sia Gestore di sistema di Exchange che Supervisore sistema provano a leggere l'attributo, apportare modifiche e riscrivere l'attributo.

È necessario rimuovere i dati obsoleti utilizzando uno strumento come ADSI Edit (AdsiEdit.msc), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Impostare l'intervallo di aggiornamento del Servizio aggiornamento destinatari su Mai come indicato di seguito:

    1. Aprire Gestore di sistema di Exchange.

    2. Espandere Destinatari e Servizio aggiornamento destinatari.

    3. Fare clic con il pulsante destro del mouse sul Servizio aggiornamento destinatari da modificare, quindi scegliere Proprietà.

    4. Nella scheda Generale utilizzare l'elenco Intervallo di aggiornamento per impostare la pianificazione su Non eseguire mai.

  2. Attendere circa uno o due minuti.

  3. Quindi utilizzare ADSI Edit o uno strumento simile per individuare l'oggetto del Servizio aggiornamento destinatari il cui attributo gatewayProxy contenga dati obsoleti. Gli oggetti Servizio aggiornamento destinatari si trovano in:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

    1. Fare clic con il pulsante destro del mouse sull'oggetto del Servizio aggiornamento destinatari contenente dati obsoleti, quindi scegliere Proprietà.

    2. Nell'editor degli attributi scorrere verso il basso e selezionare l'attributo gatewayProxy.

    3. Fare clic su Modifica per modificare questo attributo.

    4. Nella casella Valori fare clic sul tipo di indirizzo precedente da rimuovere, fare clic su Rimuovi, quindi su OK. Ripetere questo passaggio finché non vengono rimossi tutti i tipi di indirizzo.

    5. Fare clic su OK per salvare le modifiche e chiudere ADSI Edit.

  4. Imporre una replica della directory dopo l'eliminazione dell'attributo gatewayProxy. Assicurarsi che la replica venga completata prima che venga eseguito nuovamente il Servizio aggiornamento destinatari del dominio.

  5. Riconfigurare la pianificazione originale del Servizio aggiornamento destinatari.

  6. Se necessario, applicare nuovamente i criteri destinatari specifici. Utilizzare lo snap-in Siti e servizi di Active Directory per eseguire una replica manuale di Active Directory.

Per ulteriori informazioni sull'argomento, consultare l'articolo 821743 della Microsoft Knowledge Base "L'attributo gatewayProxy nel Servizio aggiornamento destinatari non è deselezionato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821743.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni su come forzare la replica delle directory, consultare l'articolo 232072 della Microsoft Knowledge Base "Inizializzazione della replica tra partner di replica diretta in Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server 2003.


Ricostruzione completa del Servizio aggiornamento destinatari
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msDS-ReplAttributeMetaData dell'oggetto Servizio aggiornamento destinatari dal controller di dominio di configurazione utilizzato da Exchange Server. L'attributo msDS-ReplAttributeMetaData contiene, oltre ad altre informazioni, la data e l'ora in cui è stata apportata l'ultima modifica a questo attributo. Se Exchange Server Analyzer rileva che sono trascorsi meno di cinque giorni dalla data e dall'ora elencate nell'attributo msDS-ReplAttributeMetaData, verrà visualizzato un avviso.

Questo avviso indica che è stata recentemente pianificata una ricostruzione completa del Servizio aggiornamento destinatari. Se è stata configurata una ricostruzione completa, al successivo avvio del Servizio aggiornamento destinatari, in base alla pianificazione o tramite il comando Aggiorna, non verranno eseguite query solo per i nuovi oggetti ma verrà esaminato ciascun oggetto. Questo processo può richiedere molto tempo e provocare un ritardo del sistema.

Se si intende eseguire una ricostruzione completa, è possibile ignorare l'avviso. In caso contrario, è possibile risolvere il problema utilizzando ADSI Edit (AdsiEdit.msc) e la procedura indicata di seguito per modificare da True a False il valore dell'attributo msExchDoFullReplication in Active Directory.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Utilizzare ADSI Edit o uno strumento simile per individuare l'attributo msExchDoFullReplication dell'oggetto Servizio aggiornamento destinatari specificato. Gli oggetti Servizio aggiornamento destinatari si trovano in: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. Fare clic con il pulsante destro del mouse sul Servizio aggiornamento destinatari specificato e scegliere Proprietà.

  3. Nella scheda Editor attributi scorrere verso il basso e selezionare l'attributo msExchDoFullReplication.

  4. Fare clic su Modifica per modificare questo attributo.

  5. Nella finestra di dialogo dell'editor degli attributi booleani modificare la selezione da True a False e fare clic su OK.

  6. Fare nuovamente clic su OK per salvare le modifiche e chiudere ADSI Edit.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • 253838, "XADM: Applicazione dei criteri di sistema da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838.

  • 328738, "XADM: Applicazione dei criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.


Il Servizio aggiornamento destinatari è configurato per la ricostruzione completa
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchDoFullReplication di ciascun oggetto del Servizio aggiornamento destinatari di Active Directory. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchDoFullReplication per ciascun oggetto del Servizio aggiornamento destinatari è impostato su True, verrà visualizzato un avviso.

Questo avviso indica che il Servizio aggiornamento destinatari è configurato per eseguire una ricostruzione completa durante il successivo ciclo di elaborazione. Se l'attributo msExchDoFullReplication è impostato su True, al successivo avvio del Servizio aggiornamento destinatari, in base alla pianificazione o tramite il comando Aggiorna, non verranno eseguite query solo per i nuovi oggetti ma verrà esaminato ciascun oggetto. Questo processo può richiedere molto tempo e provocare un ritardo del sistema.

Se si intende eseguire una ricostruzione completa, è possibile ignorare l'avviso. In caso contrario, è possibile risolvere il problema utilizzando ADSI Edit (AdsiEdit.msc) e la procedura indicata di seguito per modificare da True a False il valore dell'attributo msExchDoFullReplication in Active Directory.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Utilizzare ADSI Edit o uno strumento simile per individuare l'attributo msExchDoFullReplication dell'oggetto Servizio aggiornamento destinatari specificato. Gli oggetti Servizio aggiornamento destinatari si trovano in: CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Address Lists Container,CN=Recipient Update Services

  2. Fare clic con il pulsante destro del mouse sul Servizio aggiornamento destinatari specificato e scegliere Proprietà.

  3. Nella scheda Editor attributi scorrere verso il basso e selezionare l'attributo msExchDoFullReplication.

  4. Fare clic su Modifica per modificare questo attributo.

  5. Nella finestra di dialogo dell'editor degli attributi booleani modificare la selezione da True a False e fare clic su OK.

  6. Fare nuovamente clic su OK per salvare le modifiche e chiudere ADSI Edit.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • 253838, "XADM: Applicazione dei criteri di sistema da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838.

  • 328738, "XADM: Applicazione dei criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.


Il Servizio aggiornamento destinatari non è attivo
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo activationStyle per ciascun oggetto del Servizio aggiornamento destinatari di Active Directory. Se Exchange Server Analyzer rileva che il valore dell'attributo activationStyle per ciascun oggetto del Servizio aggiornamento destinatari è impostato su 0, verrà visualizzato un avviso.

Questo avviso indica che la pianificazione per l'oggetto del Servizio aggiornamento destinatari è impostata su Mai. Se la pianificazione per il Servizio aggiornamento destinatari è impostata su Mai, non verranno elaborati nuovi oggetti.

Se l'oggetto del Servizio aggiornamento destinatari non è più necessario, si consiglia di eliminarlo. Se l'oggetto del Servizio aggiornamento destinatari è necessario, si consiglia di configurarne la pianificazione.

Per correggere questo errore configurando una pianificazione

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Destinatari, quindi selezionare Servizio aggiornamento destinatari.

  3. Fare clic con il pulsante destro del mouse sul Servizio aggiornamento destinatari per cui si è impostata la pianificazione su Mai, quindi selezionare Proprietà.

  4. Selezionare una pianificazione predefinita utilizzando l'elenco Intervallo di aggiornamento oppure fare clic su Personalizza per creare una pianificazione personalizzata.

  5. Fare clic su OK per salvare le modifiche.

  6. Fare clic con il pulsante destro del mouse sul Servizio aggiornamento destinatari e selezionare Aggiorna.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828

  • 253838, "XADM: Applicazione di criteri di sistema da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253838.

  • 328738, "XADM: Applicazione di criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.


È necessario aggiornare il software del Servizio aggiornamento destinatari
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®)CIM_Datafile per determinare il valore della chiave Version per il Servizio visualizzazione Rubrica e Gruppi dinamici (abv_dg.dll), noto anche come Servizio aggiornamento destinatari. La chiave WMI Version indica il numero di build per questo file.

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il valore per l'attributo msDS-Behavior-Version dell'oggetto impostazioni NTDS. Questo valore indica il livello di funzionalità dell'insieme di strutture di Active Directory. I valori validi per l'attributo msDS-Behavior-Version sono elencati nella seguente tabella.

Valore | Livello di funzionalità dell'insieme di strutture
0 | Microsoft Windows 2000 Server modalità mista
1 | Microsoft Windows Server™ 2003 modalità provvisoria
2 | Microsoft Windows Server 2003 modalità nativa

Se Exchange Server Analyzer rileva che il numero di build per abv_dg.dll è inferiore a 6.0.6615.0 su un server di Exchange in un insieme di strutture Active Directory in modalità Windows Server 2003 provvisoria o nativa, verrà visualizzato un messaggio di errore. Tale errore indica che una versione di Exchange 2000 Server del Servizio aggiornamento destinatari è in esecuzione in un livello dell'insieme di strutture Active Directory di Windows Server 2003 incompatibile. È necessario un aggiornamento del Servizio aggiornamento destinatari per risolvere il problema.

Quando si utilizza il Servizio aggiornamento destinatari in Exchange 2000 Server per aggiornare gli oggetti destinatario in un insieme di strutture Windows Server 2003, il Servizio aggiornamento destinatari non aggiorna correttamente gli oggetti. Ad esempio, il Servizio aggiornamento destinatari non riconosce le modifiche apportate all'appartenenza al gruppo. Inoltre, se si utilizza Active Directory Connector (ADC) di Exchange 2000 Server, ADC potrebbe non replicare le modifiche dell'appartenenza al gruppo da Active Directory alla directory di Exchange Server 5.5.

Per eseguire l'aggiornamento alla versione più recente del Servizio aggiornamento destinatari

  1. Richiedere l'aggiornamento desiderato seguendo le istruzioni nell'articolo 873059 della Microsoft Knowledge Base "Il Servizio aggiornamento destinatari non aggiorna correttamente gli oggetti se Exchange 2000 Server è in esecuzione in un insieme di strutture Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=873059.

  2. Installare l'aggiornamento. Dopo aver eseguito questa operazione, non è necessario riavviare il computer. Tuttavia, i servizi relativi a Exchange vengono riavviati automaticamente dopo l'installazione dell'aggiornamento.


L'istanza RUS non esiste per il dominio
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per ottenere l'elenco dei domini contenuti nell'insieme di strutture. Exchange Server Analyzer, inoltre, legge l'attributo msExchangeDomainLink per ottenere l'elenco delle istanze del Servizio aggiornamento destinatari (RUS, Recipient Update Service) relative ai domini esistenti. Successivamente l'elenco dei domini restituito viene confrontato con l'elenco delle istanze RUS restituito per verificare se esiste una corrispondenza. Se le seguenti condizioni sono vere, verrà visualizzato un messaggio di errore:

  • È presente un dominio.

  • Non esiste alcuna istanza RUS per tale dominio.

Il messaggio di errore verrà visualizzato se il dominio è stato preparato utilizzando DomainPrep ma non esistono istanze RUS relative ad esso. L'incongruenza può verificarsi in scenari in cui l'amministratore aggiunge un nuovo dominio di Active Directory all'insieme di strutture, prepara il dominio per Exchange utilizzando DomainPrep, ma non aggiunge un'istanza RUS per il dominio. Se si verifica questo comportamento, i nuovi oggetti utente creati nel dominio non riceveranno gli indirizzi di posta elettronica inviati. Se si riceve questo messaggio di errore, creare un nuovo Servizio aggiornamento destinatari per il dominio.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Destinatari.

  3. Fare clic con il pulsante destro del mouse sul nodo Servizi aggiornamento destinatari, su Nuovo, quindi su Servizio aggiornamento destinatari.

  4. Nella finestra Nuovo oggetto fare clic su Sfoglia per individuare il nome del dominio.

  5. Selezionare il nome del dominio e fare clic su OK.

  6. Nella finestra Nuovo oggetto fare clic su Avanti, quindi su Fine.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328738, "Applicazione di criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • 246127, "Verifica dello stato del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127.

  • 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.


Modifica dell'epoch di replica
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo ms-DS-ReplicationEpoch dell'oggetto NTDS Settings è stato impostato per ogni controller di dominio.

Un epoch è il periodo di tempo durante il quale un dominio ha un nome specifico. Un nuovo epoch inizia quando viene creato un dominio e quando un nome di dominio viene modificato.

L'attributo ms-DS-ReplicationEpoch viene applicato all'epoch di replica di tutti i controller di dominio. Se Exchange Server Analyzer rileva che è stato impostato un valore per questo attributo, verrà visualizzato un messaggio di configurazione non predefinita.

In genere, la presenza del valore per l'attributo ms-DS-ReplicationEpoch indica che il dominio in cui si trova il server interessato è stato rinominato. Microsoft Windows Server™ 2003 Standard Edition, Windows Server 2003 Enterprise Edition e Windows Server 2003 Datacenter Edition consentono agli amministratori di rinominare i domini in un insieme di strutture di Active Directory dopo che l'insieme di strutture è stato attivato. Il sistema operativo Windows 2000 Server non consente agli amministratori di rinominare i domini in un insieme di strutture di Active Directory dopo che l'insieme di strutture è stato attivato.

La struttura di Active Directory è determinata dall'ordine in cui vengono creati i domini e i nomi gerarchici di tali domini. Si inizia con il dominio principale dell'insieme di strutture. I nomi distinti e i nomi DNS predefiniti di tutti i domini figlio derivano dal nome del dominio principale dell'insieme di strutture. Si procede nello stesso modo per ciascuna struttura aggiuntiva dell'insieme di strutture.

È possibile modificare la struttura gerarchica di una struttura di domini esistenti rinominando i domini. Ad esempio, è possibile rinominare un dominio figlio affinché abbia un dominio padre diverso o diventi il dominio principale di una nuova struttura. In entrambi i casi, si riposiziona un dominio esistente per creare una struttura di domini diversa.

Inoltre, è possibile rinominare i domini senza influire sulla struttura. Ad esempio, se si rinomina un dominio principale, è possibile modificare i nomi di tutti i domini figlio del dominio principale. Tuttavia, non si è creata una struttura di domini diversa.

La ridenominazione dei domini non è supportata negli insiemi di strutture che contengono Exchange 2000 Server o Exchange Server 5.5. Gli strumenti di ridenominazione dei domini di Windows Server 2003 sono stati progettati per rinominare i domini negli insiemi di strutture di Active Directory che non contengono server di Exchange 2000 Server o di Exchange Server 5.5. Questa limitazione è stata applicata per i seguenti motivi:

  • La ridenominazione di un dominio influisce su diversi attributi di Exchange.

  • Gli strumenti di ridenominazione dei domini di Windows Server 2003 non dispongono delle funzionalità per risolvere i problemi relativi a tali attributi.

La ridenominazione dei domini è supportata negli insiemi di strutture che contengono Exchange Server 2003. Lo strumento Exchange Domain Rename Fix-Up (XDR-fixup.exe) consente di risolvere i problemi relativi agli attributi di Exchange Server dopo la ridenominazione di un dominio contenente dei server di Exchange 2003 Server. Lo strumento Exchange Domain Rename Fix-Up può essere utilizzato con lo strumento di ridenominazione delle directory di Windows Server 2003 (Rendom.exe).

Per ulteriori informazioni sugli strumenti di ridenominazione dei domini Active Directory in Windows Server 2003 e per eseguirne il download, consultare "Windows Server 2003 Active Directory Domain Rename Tools" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=40992 (informazioni in lingua inglese).

Per rinominare un dominio, è necessario eseguire lo strumento XDR-fixup. Lo strumento XDR-fixup consente di modificare gli attributi di Active Directory in Exchange Server per riflettere il nuovo nome del dominio. Lo strumento XDR-fixup non sostituisce gli strumenti di ridenominazione dei domini di Windows Server 2003. Lo strumento XDR-fixup, inoltre, non estende la funzionalità degli strumenti di ridenominazione dei domini di Windows Server 2003. È necessario eseguire lo strumento XDR-fixup ogni volta che si esegue Rendom.exe.

Per ulteriori informazioni sulla procedura di ridenominazione dei domini e sulle relative conseguenze su Exchange Server, consultare i seguenti strumenti e documenti:

  • "Windows Server 2003 Active Directory Domain Rename Tools" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=40992 (informazioni in lingua inglese).

  • "Understanding How Domain Rename Works" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41906 (informazioni in lingua inglese).

  • "Step-by-Step Guide to Implementing Domain Rename" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41359 (informazioni in lingua inglese).

  • "Microsoft Exchange Server 2003 Correzione dei problemi di ridenominazione dei domini (XDR-Fixup)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34171.

  • "Exchange and Domain Rename Operations" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41908 (informazioni in lingua inglese).


Replica della Rubrica fuori rete versione 2 non rilevata
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-01-29

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_Public_Folder per determinare il valore corrente di HasLocalReplica. Se Exchange Server Analyzer rileva che il valore di HasLocalReplica è impostato su False per l'istanza della rubrica non in linea versione 2 di un elenco indirizzi non in linea, verrà visualizzato un messaggio di errore.

Se HasLocalReplica è impostato su False per l'istanza della rubrica non in linea versione 2, gli elenchi indirizzi non in linea non verranno generati correttamente. Di conseguenza, non potranno essere scaricati dagli utenti di Microsoft Outlook® 2002 e delle versioni precedenti.

Questo problema può verificarsi se non si è configurato alcun archivio delle cartelle pubbliche per contenere le repliche della rubrica non in linea versione 2. Per impostazione predefinita, il contenuto della rubrica non in linea viene replicato nell'archivio delle cartelle pubbliche del server in cui è installata. Se l'archivio delle cartelle pubbliche viene rimosso dalla configurazione di replica della rubrica non in linea, si verificherà il problema descritto nel paragrafo precedente.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, quindi fare clic su Cartelle.

  3. Fare clic con il pulsante destro del mouse su Cartelle pubbliche e scegliere Visualizza cartelle di sistema.

  4. Fare clic per espandere l'oggetto Rubrica non in linea.

  5. In Rubrica non in linea fare clic con il pulsante destro del mouse su o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List e scegliere Proprietà.

  6. Nella scheda Replica verificare che sia stato inserito un archivio di cartelle pubbliche nella casella Replica contenuto in questi archivi pubblici. Se non è stato inserito, fare clic su Aggiungi e inserire l'archivio pubblico appropriato per la rubrica non in linea.

  7. Fare clic su Applica, quindi su OK.

  8. Fare clic per espandere o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List.

  9. In o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List fare clic con il pulsante destro del mouse su offline Address Book Version 2 e scegliere Proprietà.

  10. Nella scheda Replica verificare che sia stato inserito un archivio di cartelle pubbliche nella casella Replica contenuto in questi archivi pubblici. Se non è stato inserito, fare clic su Aggiungi e inserire l'archivio pubblico appropriato per la rubrica non in linea.

  11. Fare clic su Applica, quindi su OK.

Per ulteriori informazioni su questo problema, consultare l'articolo 286328 della Microsoft Knowledge Base "Rubrica non in linea mancante e non generabile in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328.

Per ulteriori informazioni sulla generazione dell'elenco della Rubrica fuori rete, vedere "Offline Address List Generation Overview" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=82242 (informazioni in lingua inglese).

Per ulteriori informazioni sulla rimozione corretta da un gruppo amministrativo del primo computer che esegue Exchange Server 2003, consultare l'articolo 822931 della Microsoft Knowledge Base "Rimozione del primo computer Exchange Server 2003 dal gruppo amministrativo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931.


Replica della Rubrica fuori rete versione 3a non rilevata
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Public_Folder per determinare il valore della chiave HasLocalReplica. Se Exchange Server Analyzer rileva che il valore di HasLocalReplica è impostato su False per l'istanza della rubrica non in linea versione 3a di un elenco indirizzi non in linea, verrà visualizzato un messaggio di errore.

Se HasLocalReplica è impostato su False per l'istanza della rubrica non in linea versione 3a, gli elenchi indirizzi non in linea non verranno generati correttamente. Di conseguenza, non potranno essere scaricati dagli utenti di Microsoft Office Outlook® 2003.

Questo problema può verificarsi se non si è configurato alcun archivio delle cartelle pubbliche per contenere le repliche della rubrica non in linea versione 3a. Per impostazione predefinita, il contenuto della rubrica non in linea viene replicato nell'archivio delle cartelle pubbliche del server in cui è installata. Se l'archivio delle cartelle pubbliche viene rimosso dalla configurazione di replica della rubrica non in linea, si verificherà il problema descritto nel paragrafo precedente.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, quindi fare clic su Cartelle.

  3. Fare clic con il pulsante destro del mouse su Cartelle pubbliche e scegliere Visualizza cartelle di sistema.

  4. Fare clic per espandere l'oggetto Rubrica non in linea.

  5. In Rubrica non in linea fare clic con il pulsante destro del mouse su o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List e scegliere Proprietà.

  6. Nella scheda Replica verificare che sia stato inserito un archivio di cartelle pubbliche nella casella Replica contenuto in questi archivi pubblici. Se non è stato inserito, fare clic su Aggiungi e inserire l'archivio pubblico appropriato per la rubrica non in linea.

  7. Fare clic su Applica, quindi su OK.

  8. Fare clic per espandere o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List.

  9. In o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List fare clic con il pulsante destro del mouse su offline Address Book Version 3a e scegliere Proprietà.

  10. Nella scheda Replica verificare che sia stato inserito un archivio di cartelle pubbliche nella casella Replica contenuto in questi archivi pubblici. Se non è stato inserito, fare clic su Aggiungi e inserire l'archivio pubblico appropriato per la rubrica non in linea.

  11. Fare clic su Applica, quindi su OK.

Per ulteriori informazioni su questo problema, consultare l'articolo 286328 della Microsoft Knowledge Base "Rubrica non in linea mancante e non generabile in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328.

Per ulteriori informazioni sulla rimozione corretta da un gruppo amministrativo del primo computer che esegue Exchange Server 2003, consultare l'articolo 822931 della Microsoft Knowledge Base "Rimozione del primo computer Exchange Server 2003 dal gruppo amministrativo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931.


Pianificazione connettore di replica di directory
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo activationSchedule di ogni oggetto Contratto di connessione ADC (Active Directory Connector). L'attributo activationSchedule corrisponde alla frequenza di esecuzione del Contratto di connessione ADC. Il valore 0 indica che la pianificazione repliche è impostata su Mai. Il valore 1 indica che la pianificazione repliche è impostata su Orari selezionati. Il valore 2 indica che la pianificazione repliche è impostata su Sempre.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchServer2SearchFilter per ciascun oggetto contratto di connessione ADC. L'attributo msExchServer2SearchFilter rappresenta il filtro di ricerca utilizzato quando si esegue una ricerca nella directory.

Se Exchange Server Analyzer rileva che l'attributo activationSchedule è impostato su Orari selezionati, con un intervallo di replica superiore a 6 ore, e che l'attributo msExchServer2SearchFilter sta eseguendo una replica delle informazioni sul destinatario, verrà visualizzato un avviso.

Si consiglia, generalmente, di impostare la pianificazione repliche del Contratto di connessione del destinatario su Sempre. Talvolta, se il Contratto di connessione viene impostato su una pianificazione diversa possono essere generati dei rapporti di mancato recapito (NDR), in seguito allo spostamento delle cassette postali da siti Exchange Server 5.5 a Exchange 2000 Server o Exchange Server 2003.

Per risolvere il problema

  1. Aprire lo snap-in Servizi MMC di Active Directory Connector.

  2. Aprire il Contratto di connessione.

  3. Nella pagina Connection_Agreement Properties fare clic sulla scheda Pianificazione, su Sempre, quindi su OK.

Per ulteriori informazioni sulla distribuzione di ADC e sulla configurazione dei contratti di connessione, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.


Il ruolo del server FSMO RID non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo fSMORoleOwner del master operazioni ID relativo (RID) nel contesto dei nomi di domini. Ad esempio, in un dominio denominato contoso.com, l'attributo fSMORoleOwner per il master operazioni RID è un attributo di CN=RID Manager$, CN=System, DC=contoso, DC=com. Quindi, tramite Exchange Server Analyzer verrà tentato di stabilire una connessione LDAP (Lightweight Directory Access Protocol) alla porta TCP 389 sul controller di dominio che riveste questo ruolo. Se non è possibile stabilire la connessione a questo controller di dominio, verrà visualizzato un messaggio di errore.

Tramite il master RID è possibile assegnare gli ID relativi a tutti i controller di dominio per garantire che tutte le entità di protezione dispongano di un identificatore unico. È possibile creare un nuovo oggetto entità di protezione (utente, gruppo o computer) in qualsiasi controller di dominio. Quando si crea un oggetto entità di protezione, il controller di dominio assegna all'oggetto un ID di protezione univoco (SID, Security Identifier). Esistono quattro elementi di un SID di dominio, uno dei quali è il RID per il dominio. Il master operazioni RID di un particolare dominio è responsabile dell'elaborazione delle richieste del pool RID provenienti da tutti i controller di un determinato dominio. In qualsiasi momento può esistere un solo controller di dominio che riveste il ruolo di master RID all'interno del dominio.

Per risolvere il problema

  1. Verificare che il server di elenchi in linea specificato nel messaggio di errore sia in linea e accessibile dai server di Exchange nell'organizzazione.

  2. Se il server di elenchi in linea non dispone dell'autorizzazione, è necessario assegnare il ruolo di master RID a un altro controller di dominio.

Per ulteriori informazioni sul trasferimento del ruolo di master operazioni RID da un controller di dominio a un altro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801, "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows Server 2000, consultare l'articolo 255690 "HOW TO: Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Ruolo FSMO dello schema non trovato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il controller di dominio che è specificato come FSMO dello schema (fSMORoleOwner nel contesto di denominazione dello schema). Se Exchange Server Analyzer rileva che il controller di dominio specificato nell'attributo fSMORoleOwner non esiste nell'insieme di strutture, verrà visualizzato un messaggio di errore.

L'attributo fSMORoleOwner nel contesto di denominazione dello schema (CN=Schema,CN=Configuration,DC=domain,DC=com) definisce il controller di dominio che è il master schema dell'insieme di strutture. Il controller di dominio del master schema controlla tutti gli aggiornamenti e le modifiche apportate allo schema. Per aggiornare lo schema di un insieme di strutture è necessario disporre dell'accesso al master schema. Nell'intero insieme di strutture può esistere un unico master schema.

Per l'insieme di strutture di Active Directory è necessario definire un master schema. Il programma di installazione di Exchange 2000 Server e del Service Pack di Exchange 2000 Server non verrà eseguito (anche se non si aggiorna lo schema), se durante l'installazione non è in linea un controller di dominio del master schema. Se il controller di dominio elencato come master schema non è in linea, deve essere portato nuovamente in linea. Questo non riguarda Exchange Server 2003. Il programma di installazione di Exchange 2003 contatta il master schema solo se rileva che lo schema non è stato esteso.

Per risolvere il problema

  1. Verificare che il server Active Directory designato sia fisicamente presente.

  2. Se il server di elenchi in linea non dispone dell'autorizzazione, assegnare il ruolo di master schema a un altro controller di dominio.

Per ulteriori informazioni sull'assegnazione del ruolo di master schema a un altro controller di dominio, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 280178, "XADM: L'installazione di Exchange 2000 richiede l'accesso al master schema", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=280178.

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801, "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows Server 2000, consultare l'articolo 255690 "HOW TO: Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Il ruolo FSMO dello schema non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo fSMORoleOwner del master operazioni schema nel contesto dei nomi degli schemi (Schema Naming Context). Ad esempio, in un dominio che si chiama contoso.com, l'attributo fSMORoleOwner per il master operazioni schema è un attributo di CN=Schema,CN=System,DC=contoso,DC=com. Exchange Server Analyzer tenta quindi di stabilire una connessione LDAP (Lightweight Directory Access Protocol) alla porta TCP 389 sul controller di dominio che riveste questo ruolo. Se non è possibile stabilire la connessione a questo controller di dominio, verrà visualizzato un messaggio di errore.

Il controller di dominio con il ruolo di master schema è l'unico controller di dominio che può eseguire operazioni di scrittura nello schema di directory. Quegli aggiornamenti dello schema sono replicati dal master schema in tutti gli altri controller di dominio della struttura. Il master schema è un ruolo di master operazioni per struttura, poiché esiste un unico schema nella struttura, indipendentemente dal numero di domini. Per aggiornare lo schema di un insieme di strutture è necessario disporre dell'accesso al master schema. Nell'intero insieme di strutture può esistere un unico master schema.

Per risolvere il problema

  1. Verificare che il server di elenchi in linea specificato nel messaggio di errore sia in linea e accessibile dai server di Exchange nell'organizzazione.

  2. Se il server di elenchi in linea non dispone dell'autorizzazione, è necessario assegnare il ruolo di master schema a un altro controller di dominio.

Per ulteriori informazioni sul trasferimento del ruolo di master schema da un controller di dominio a un altro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801 "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows Server 2000, consultare l'articolo 255690 "HOW TO: "Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Scadenza tra breve di un certificato SSL (Secure Sockets Layer)
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nell'oggetto Server Certificate nel sistema del server Exchange per recuperare varie proprietà dei certificati X509. Per ciascun certificato SSL rilevato, Exchange Server Analyzer valuta l'attributo ExpirationDate per identificare la data di scadenza del certificato.

Nota:
È necessario che un server disponga di un certificato server quando esegue un protocollo SSL. Il certificato server contiene il nome del sito Web. Il browser verifica che il sito Web corrisponda al nome immesso. Ad esempio, se il sito Web è https://www.esempio.com, il nome del certificato deve essere www.esempio.com.

Se la ExpirationDate è lontana da 3 a 20 giorni dalla data attuale, verrà visualizzato un avviso. Se la ExpirationDate è lontana meno di 3 giorni, verrà visualizzato un messaggio di errore.

Se il certificato è scaduto, si verificherà un errore nelle connessioni all'URL specificato nel messaggio. Analogamente, si verificherà un errore nelle connessioni RPC su HTTP ed Exchange Server ActiveSync che utilizzano l'URL.

Per risolvere l'avviso o l'errore relativo alla scadenza del certificato, rinnovare il certificato specificato nel messaggio. La procedura da seguire per il rinnovo del certificato dipende dall'Autorità di certificazione utilizzata.

Per ulteriori informazioni

Per ulteriori informazioni sulla crittografia SSL e l'uso dei certificati con i server virtuali nel server Exchange, vedere le seguenti risorse di Exchange:

  • Per informazioni sull'utilizzo dei certificati con server virtuali in Exchange Server 2003, consultare l'articolo 823024 della Microsoft Knowledge Base "Utilizzo dei certificati con server virtuali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823024.

  • Per informazioni su come utilizzare SSL e come ottenere e installare certificati server, consultare "Configurazione di Exchange Server 2003 per l'accesso client" nella Guida all'accesso client di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47568.

  • Per informazioni sull'utilizzo della crittografia SSL e su come ottenere e installare certificati del server per Exchange Server 2007, vedere "Come configurare SSL per Outlook via Internet" all'indirizzo http://go.microsoft.com/fwlink/?LinkId =80875.


Contenitore server mancante
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo distingushedName per tutti gli oggetti Routing Group individuati nel gruppo amministrativo corrente.

Exchange Server Analyzer esegue quindi una query in Active Directory per determinare se nel gruppo amministrativo corrente è presente un contenitore Server.

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • Il gruppo amministrativo corrente contiene uno o più gruppi di routing.

  • Non esiste un contenitore Server.

L'errore indica che non è installato alcun server nel gruppo amministrativo e che le informazioni di routing potrebbero non essere propagate correttamente tra i server all'interno di un'organizzazione di Exchange.

Per risolvere il problema, assicurarsi che l'organizzazione di Exchange sia in modalità nativa ed eseguire la procedura seguente.

Procedura necessaria

  1. Creare un nuovo gruppo amministrativo.

  2. Creare un nuovo contenitore Gruppi di routing nel nuovo gruppo amministrativo.

  3. Trascinare i gruppi di routing esistenti dal contenitore Gruppi di routing precedente a quello nuovo.

  4. Riavviare tutti i servizi di Exchange.

Per ulteriori informazioni su questo problema, consultare l'articolo della Microsoft Knowledge Base 318491 "XADM: Le informazioni di routing non vengono propagate in un'organizzazione di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=318491.


Nome principale di servizio mancante dal server di catalogo globale
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-05-12

Microsoft® Exchange Server Analyzer Tool esegue una query nel server di catalogo globale del servizio directory di Active Directory® per individuare i valori restituiti per il nome di dominio completo e il nome NetBIOS dell'attributo servicePrincipalName delle risorse di exchangeAB e HOST.

Se una delle seguenti condizioni è vera, verrà visualizzato un messaggio di errore:

  • Nell'attributo servicePrincipalName della risorsa exchangeAB manca uno dei valori previsti per i nomi FQDN o NetBIOS.

  • Nell'attributo servicePrincipalName della risorsa HOST di Exchange manca uno dei valori previsti per i nomi di dominio completo o NetBIOS.

Un nome principale di servizio (SPN, Service Principal Name) è un nome univoco che identifica l'istanza di un servizio ed è associato all'account di accesso in cui viene eseguita l'istanza del servizio. L'autenticazione Kerberos non è possibile per i servizi di Exchange senza nomi principali di servizio impostati correttamente.

  • Se i client che eseguono Outlook 2003® o versioni successive hanno problemi di autenticazione con Active Directory, tali problemi possono indicare la mancanza di un nome principale di servizio valido per la risorsa di exchangeAB.

  • Gli errori di autenticazione tra i server possono essere indice della mancanza di un nome principale di servizio valido per la risorsa HOST.

Per risolvere il problema, seguire i passaggi riportati di seguito per aggiungere i valori mancanti dell'attributo servicePrincipalName.

Utilizzare lo strumento SETSPN.exe per aggiungere un nome principale di servizio ai valori mancanti

  1. Installare lo strumento Setspn.exe. Per ottenere lo strumento Setspn.exe, vedere "Windows 2000 Resource Kit Tool: Setspn.exe" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=28103 (informazioni in lingua inglese).

    La versione di Windows Server 2003 dello strumento con riga di comando Setspn.exe è disponibile con gli strumenti di supporto di Windows Server 2003 inclusi nel CD di Windows Server 2003. Per installare gli strumenti di supporto di Windows Server 2003, fare doppio clic sul file Suptools.msi nella cartella Support/Tools.

  2. Seguire le informazioni aggiuntive del file SETSPN.EXE Setspn_d.txt per aggiungere il valore mancante all'oggetto Active Directory per il server di Exchange. Nell'esempio seguente viene illustrata l'aggiunta del valore del nome di dominio completo per un nome principale di servizio del server SMTP virtuale:

    • Avviare un prompt dei comandi, quindi passare alla directory in cui è installato Setspn.exe.

    • Al prompt dei comandi, digitare il seguente comando:

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      Nota:
      Sostiuire mail.yourdomain.com con il nome di dominio completo del server virtuale SMTP e YOURSERVERNAME con il nome del server di Exchange.
      Premere Invio.


L'archivio delle cartelle pubbliche del server della cartella sito relativo a questo gruppo amministrativo non è presente all'interno del gruppo
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore di distinguishedName di ciascun archivio delle cartelle pubbliche. Inoltre, Exchange Server Analyzer esegue una query in Active Directory per determinare il valore degli attributi siteFolderServer e msExchAdminGroupMode di ciascun gruppo amministrativo. L'attributo siteFolderServer rappresenta il nome del server che ospita le cartelle del sito (normalmente è il primo server nel sito o nel gruppo amministrativo). L'attributo msExchAdminGroupMode rappresenta la modalità del gruppo amministrativo, la quale può essere:

  • Exchange Server 5.5 puro

  • Modalità mista di Exchange Server 5.5, Exchange 2000 Server e Exchange Server 2003

  • Modalità nativa di Exchange 2000 Server o Exchange Server 2003

Se Exchange Server Analyzer determina che il gruppo amministrativo non è in modalità nativa e il valore di siteFolderServer non corrisponde al valore di distinguishedName di ogni archivio delle cartelle pubbliche e che, inoltre, il valore dell'attributo siteFolderServer non contiene la stringa DEL:, verrà visualizzato un avviso.

Per impostazione predefinita, il server della cartella sito è il primo server installato nel gruppo amministrativo. L'archivio delle cartelle pubbliche in questo server è la posizione predefinita delle cartelle relative alla disponibilità e delle cartelle della rubrica non in linea per il gruppo amministrativo. Se si rimuove o non si concede l'autorizzazione al server delle cartelle sito senza replicare le cartelle in un altro server e designare il server come server della rubrica non in linea, si verificheranno problemi per gli utenti di Outlook con la rubrica non in linea e i dati di disponibilità.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Individuare l'archivio informazioni cartella pubblica che si desidera designare come server della cartella sito, espandendo quanto segue: CN=<NomeArchivioCartellePubbliche>, CN=<NomeGruppoDiArchiviazione>, CN=InformationStore, CN=<NomeServer>, CN=Servers, CN=<NomeGruppoAmministrativo> ,CN=Administrative Groups, CN=<NomeOrganizzazione>, CN=Microsoft Exchange, CN=Services, CN=Configuration,DC=<NomeDominio>,DC=com.

  3. Nel riquadro di destra fare clic con il pulsante destro del mouse su CN=<NomeArchivioCartellePubbliche> e scegliere Proprietà.

  4. Nel campo Attributi scorrere verso il basso e selezionare l'attributo distinguishedName.

  5. Fare clic sul pulsante Modifica, quindi copiare l'intero attributo negli Appunti.

  6. Espandere il contenitore della configurazione, quindi espandere CN=Administrative Groups,CN=<NomeOrganizzazione>,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=<NomeDominio>,DC=com.

  7. Fare clic con il pulsante destro del mouse sul gruppo amministrativo che si desidera modificare e selezionare Proprietà.

  8. Nel campo Attributi scorrere verso il basso e selezionare l'attributo siteFolderServer.

  9. Fare clic sul pulsante Modifica e incollare il valore dell'attributo distinguishedName nel campo Valore.

  10. Fare doppio clic sul contenuto del campo Valore per assicurarsi che l'operazione Incolla sia stata eseguita correttamente, quindi scegliere OK per salvare le modifiche.

  11. Fare clic su OK per chiudere la finestra di dialogo delle proprietà del gruppo amministrativo.

  12. Per rendere effettiva la modifica, uscire da ADSI Edit e riavviare il servizio Archivio informazioni di Microsoft Exchange in tutti i computer Exchange Server del sito.

Per ulteriori informazioni sulla ricreazione di cartelle di sistema e la reimpostazione del server della cartella sito, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 275171, "Reimpostazione delle cartelle di sistema su un computer che esegue Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171.

  • 284200, "La cartella di sistema Schedule+ Free/Busy è mancante" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida di Windows Server 2003.


L'archivio delle cartelle pubbliche del server della cartella sito utilizzato dalla Rubrica fuori rete non è stato rilevato
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2007-02-01

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo siteFolderServer in tutti gli archivi delle cartelle pubbliche (archivi che hanno un objectClass di objectClass=msExchPublicMDB). L'attributo siteFolderServer rappresenta l'archivio delle cartelle pubbliche utilizzato per il server della rubrica non in linea.

Se Exchange Server Analyzer determina che un server non è elencato, se il server elencato non è attivo oppure se il server elencato non esiste, verrà visualizzato un avviso. Se l'attributo siteFolderServer contiene la stringa DEL:, verrà visualizzato un messaggio di errore.

Per impostazione predefinita, Exchange Server 2003 genera file della Rubrica fuori rete nel server della cartella sito (il primo server installato nel gruppo amministrativo). Se si è designato un server differente come server della rubrica non in linea, l'archivio delle cartelle pubbliche elencato in questo attributo sarà l'archivio nel nuovo server della rubrica non in linea e non l'archivio nel server effettivo della cartella sito del gruppo amministrativo.

Quando Exchange Server 2003 genera file della rubrica non in linea, allega i file ai messaggi di posta elettronica e inserisce i messaggi in cartelle pubbliche speciali. Microsoft® Office Outlook® 2003 recupera i messaggi dalla cartella e scarica i file allegati.

In Exchange Server 2003, i messaggi della Rubrica fuori rete vengono archiviati nelle sottocartelle della cartella Rubrica fuori rete, che è una delle cartelle di sistema della struttura Cartelle pubbliche predefinita. Questa cartella contiene una sottocartella per ogni gruppo amministrativo o sito nella topologia. Per impostazione predefinita, una replica del contenuto della cartella di uno specifico gruppo amministrativo si trova nel primo server installato nel gruppo amministrativo (definito server della cartella sito).

Se l'organizzazione di Exchange è Exchange Server 2007, senza client di livello inferiore (Outlook 2003 o versioni precedenti), è possibile ignorare l'avviso o l'errore. Se l'organizzazione di Exchange Server 2007 è host di client su cui è in esecuzione Outlook 2003 o una versione precedente, seguire la procedura riportata di seguito per abilitare la distribuzione delle cartelle pubbliche dei file della Rubrica fuori rete. La distribuzione delle cartelle pubbliche è il metodo di distribuzione con cui i client su cui è in esecuzione Outlook 2003 o una versione precedente accedono alla Rubrica fuori rete quando operano in modalità non linea o tramite una connessione remota.

Per risolvere il problema in Exchange Server 2003

  1. Se si è certi dell'esistenza del server, in Gestore di sistema di Exchange, nella sezione Server, espandere la struttura del server e il gruppo di archiviazione, quindi fare clic su Archivio delle cartelle pubbliche. Nel riquadro destro verificare che l'archivio sia in esecuzione.

  2. Per designare un nuovo server della Rubrica fuori rete, in Destinatari fare clic su Elenchi di indirizzi non in linea. Quindi nel riquadro destro fare clic su Elenco di indirizzi non in linea predefinito (o un altro elenco di indirizzi non in linea che ha generato il messaggio).

    Se non si desidera utilizzare una rubrica non in linea, fare clic con il pulsante destro del mouse su Rubrica non in linea predefinita, quindi fare clic su Elimina. Altrimenti, utilizzare il resto della procedura per impostare una pianificazione.

  3. Fare clic con il pulsante destro del mouse su Elenco di indirizzi non in linea predefinito e fare clic su Proprietà.

  4. Nella sezione Server della rubrica non in linea della scheda Generale, fare clic su Sfoglia per selezionare un server.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Microsoft Exchange e Configurazione organizzazione, quindi selezionare Cassetta postale.

  3. Nel riquadro dei risultati fare clic sulla scheda Rubrica fuori rete.

  4. Nella scheda Rubrica fuori rete selezionare "Rubrica fuori rete predefinita".

    1. Per abilitare la distribuzione delle cartelle pubbliche della Rubrica fuori rete, nella scheda Distribuzione selezionare Abilita distribuzione delle cartelle pubbliche.

    2. Fare clic su OK per salvare le modifiche.

  5. Per designare un nuovo server della Rubrica fuori rete, nel riquadro azioni fare clic su Sposta per avviare la procedura guidata Sposta Rubrica fuori rete, che consente di spostare la generazione della Rubrica fuori rete su un server diverso. Consente, inoltre, di copiare i file esistenti della Rubrica fuori rete sul server specificato.

Per utilizzare Exchange Management Shell per abilitare la distribuzione delle cartelle pubbliche dei file della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Dove: <OAB> è il nome distinto, il nome di dominio/account o l'identificatore univoco globale (GUID) della Rubrica fuori rete.

    Ad esempio, per abilitare la distribuzione delle cartelle pubbliche della Rubrica fuori rete predefinita, immettere:
Copia codice
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Per utilizzare Exchange Management Shell per impostare il server che ospiterà la generazione della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dove: <OAB> è il nome distinto, il nome di dominio\account o l'identificatore univoco globale (GUID) della Rubrica fuori rete e <Server> consente di specificare il server di Exchange su cui eseguire l'operazione selezionata.

    Ad esempio, per spostare la generazione della Rubrica fuori rete su SERVER01, immettere:
Copia codice
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2003, consultare "Configurazione delle rubriche non in linea di Exchange Server 2003" in Utilizzo degli archivi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2007, consultare "Configurazione dell'organizzazione > Cassetta postale > Rubriche fuori rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId =79247.


SiteName è hardcoded
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore SiteName del Registro di sistema è presente sul server di Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters\SiteName

Se Exchange Server Analyzer rileva che il valore SiteName del Registro di sistema è presente, verrà visualizzato un avviso.

Questo avviso indica che l'appartenenza ai siti del servizio directory di Active Directory® è hardcoded su questo computer di Microsoft Windows®. Questa configurazione non è consigliata per Exchange Server.

Quando un sito Windows viene specificato a livello di codice, è possibile provocare errori del servizio Supervisore sistema di Microsoft Exchange ed errori generali di Exchange Server. È consigliabile rimuovere il valore SiteName del Registro di sistema. Se si rimuove il valore SiteName del Registro di sistema, Windows accederà automaticamente al sito Active Directory appropriato.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per rimuovere il valore SiteName del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\Netlogon\Parameters

  3. Nel riquadro destro individuare ed eliminare il valore SiteName.

  4. Chiudere l'editor del Registro di sistema e riavviare il server per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore SiteName del Registro di sistema, consultare l'articolo 322834 della Microsoft Knowledge Base "XADM: Evento 1005, il Supervisore sistema non si avvia" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322834.


Nell'organizzazione di Exchange sono presenti più di 900 gruppi amministrativi
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di gruppi amministrativi presenti nell'organizzazione di Exchange. Se Exchange Server Analyzer rileva più di 900 gruppi amministrativi, verrà visualizzato un avviso.

Si consiglia di disporre di un massimo di 900 istanze per i singoli tipi di oggetto di Exchange, poiché in Active Directory il valore predefinito per la dimensione massima della pagina per ogni data richiesta è 1.000. Di conseguenza, se viene inviata una richiesta LDAP (Lightweight Directory Access Protocol) per un oggetto e in Active Directory esistono più di 1000 istanze di tale oggetto, non verrà restituito alcun risultato perché è stata superata la dimensione massima della pagina.

Nel caso di Exchange, i diversi processi richiedono la creazione di istanze per specifici tipi di oggetto. Ad esempio, Gestore di sistema di Exchange invia una richiesta LDAP ad Active Directory per creare una visualizzazione elenco di tutti i gruppi amministrativi all'interno dell'organizzazione di Exchange. Nel caso in cui vi siano più di 1.000 gruppi amministrativi, Active Directory non restituisce alcun risultato. Come risultato, verrà visualizzato un messaggio di errore in Gestore di sistema di Exchange e non verrà visualizzato alcun gruppo amministrativo.

Sebbene sia possibile aumentare il valore di dimensione massima della pagina per Active Directory, non è un'operazione consigliabile o supportata per Exchange. Sono stati rilevati errori e comportamenti anomali in ambienti Exchange, in cui è stato incrementato il valore massimo della dimensione della pagina.

Sebbene sia consigliabile non superare le 900 unità per ogni singolo tipo di oggetto in Exchange, sono supportati fino a 1.000 tipi di oggetto.

Per risolvere questo problema, prendere in considerazione il consolidamento dei gruppi amministrativi.

Per ulteriori informazioni sul consolidamento dei siti Exchange e dei gruppi amministrativi, consultare:

  • Deploying a Worldwide Site Consolidation Solution for Exchange Server 2003 at Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33531 (informazioni in lingua inglese).


Nell'organizzazione di Exchange sono presenti più di 900 server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-03-30

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per ottenere il conteggio degli oggetti nella directory che presentano un objectCategory di msExchExchangeServer. Il conteggio rappresenta il numero di computer che eseguono Exchange Server rilevati in Active Directory. Se Exchange Server Analyzer rileva più di 900 computer che eseguono Exchange Server, verrà visualizzato un avviso.

Si consiglia di utilizzare un massimo di 900 istanze per i singoli tipi di oggetto di Exchange, poiché in Active Directory il valore predefinito per la dimensione massima della pagina per ogni data richiesta è 1.000. Di conseguenza, se viene inviata una richiesta LDAP (Lightweight Directory Access Protocol) per un oggetto e in Active Directory esistono più di 1000 istanze di tale oggetto, non verrà restituito alcun risultato perché è stata superata la dimensione massima della pagina.

Nel caso di Exchange Server, i diversi processi richiedono la creazione di istanze per specifici tipi di oggetto. Ad esempio, Gestore di sistema di Exchange invia una richiesta LDAP ad Active Directory per creare una visualizzazione elenco di tutti i server Exchange presenti nell'organizzazione di Exchange. Se sono presenti più di 1.000 server Exchange, Active Directory non restituirà risultati. Di conseguenza, in Gestore di sistema di Exchange verrà visualizzato un messaggio di errore e non verrà visualizzato alcun computer che esegue Exchange Server.

Sebbene sia possibile aumentare il valore di dimensione massima della pagina per Active Directory, non è un'operazione consigliabile o supportata per Exchange. Sono stati rilevati errori e comportamenti anomali in ambienti Exchange, in cui è stato incrementato il valore massimo della dimensione della pagina.

Sebbene sia consigliabile non superare le 900 unità per ogni singolo tipo di oggetto in Exchange Server, sono supportati fino a 1.000 tipi di oggetto.

Per risolvere il problema

  1. Prendere in considerazione il consolidamento dei server Exchange nella propria organizzazione.

  2. Esaminare Active Directory per individuare eventuali computer isolati che eseguono Exchange Server e rimuoverli da Active Directory.

Per ulteriori informazioni sul consolidamento dei server Exchange, consultare "Consolidamento dei server utilizzando Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47586.


Sono presenti più di dieci amministratori delegati al livello organizzativo
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di utenti che dispongono di autorizzazioni di amministratore o di amministratore completo di Exchange. Exchange Server Analyzer esegue il conteggio delle voci elencate nell'attributo msExchAdmins, che è un collegamento a tutti gli amministratori di Exchange all'interno dell'organizzazione e alle relative autorizzazioni. Se Exchange Server Analyzer rileva la presenza di più di 10 utenti con autorizzazioni di amministratore o di amministratore completo di Exchange, verrà visualizzato un avviso.

msExchAdmins è un attributo multivalore del contenitore principale dell'organizzazione di Exchange. Contiene un elenco di identificatori di protezione (SID) che rappresenta gli account degli utenti delegati di Exchange.

È consigliabile limitare il numero di utenti con accesso in scrittura all'organizzazione di Exchange. Provare a ridurre il numero di amministratori e di amministratori completi di Exchange a livello di organizzazione. Riesaminando i ruoli amministrativi in base ai requisiti dell'infrastruttura di messaggistica, è possibile scoprire che molti di questi utenti possono essere convertiti in amministratori con diritti di sola visualizzazione a livello di organizzazione e che possono essere delegati al ruolo di amministratore di Exchange a livello di Gruppo amministrativo.

Per risolvere il problema

  1. Provare a ridurre il numero di utenti con autorizzazioni di amministratore e/o amministratore completo di Exchange.

  2. Provare a eseguire un controllo delle autorizzazioni di Exchange Server all'interno dell'organizzazione per verificarne la correttezza.

Per ulteriori informazioni sulla pianificazione e le autorizzazioni di configurazione in Exchange, consultare quanto segue:

  • "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.

  • "Configurazione delle autorizzazioni" in Microsoft Exchange Server 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78432.

  • "Considerazioni sulle autorizzazioni" in Microsoft Exchange Server 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78433.

Per ulteriori informazioni sui ruoli di amministratore in Exchange 2003, consultare l'articolo 823018 della Microsoft Knowledge Base "Panoramica delle autorizzazioni per i ruoli amministratore in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823018.

Per ulteriori informazioni sui ruoli di amministratore in Exchange 2000 Server, consultare l'articolo 289811 della Microsoft Knowledge Base "XGEN: Autorizzazioni per i ruoli in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=289811.


Il Contratto di connessione non è impostato per la creazione di account disabilitati quando non viene riscontrata alcuna corrispondenza
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchServer1AlwaysCreateAs in ciascun oggetto Contratto di connessione. Se Exchange Server Analyzer determina che l'attributo msExchServer1AlwaysCreateAs non è impostato su 1, verrà visualizzato un avviso.

L'attributo msExchServer1AlwaysCreateAs determina le modalità di sincronizzazione degli oggetti X.500 con Active Directory. Il valore 0 indica che il Contratto di connessione è stato configurato per la creazione di contatti Microsoft Windows®. Se l'attributo è impostato sul valore 1 significa che il Contratto di connessione è stato configurato per la creazione di account utente Windows in Active Directory. Il valore 2 indica che il Contratto di connessione è stato configurato per la creazione di nuovi account utente Windows®.

Exchange Server Analyzer rilascia un avviso poiché in una situazione in cui Exchange Server 5.5 deve coesistere con Active Directory ed è prevista una migrazione completa verso Exchange Server 2003, è importante che ADC (Active Directory Connector) crei account utente Windows disabilitati. Tali account utente Windows disabilitati sono "abilitati alle cassette postali", ovvero sono collegati in modo logico a una cassetta postale presente nel computer Exchange Server 5.5. La creazione di account utente Windows disabilitati è necessaria affinché l'oggetto utente che rappresenta l'account Windows disabilitato in seguito possa disporre dell'accesso alle cartelle pubbliche e ad altri oggetti protetti di Active Directory.

Nell'interfaccia utente ADC sono disponibili tre opzioni per la creazione di nuovi oggetti quando in Active Directory non viene rilevato un oggetto corrispondente per una cassetta postale in Exchange Server 5.5. Tali opzioni sono elencate nel modo seguente nella scheda Avanzate nelle proprietà del Contratto di connessione:

  • Crea un contatto Windows Opzione non consigliata dal momento che un oggetto Contatto non dispone di contesto di protezione.

  • Crea un nuovo account utente Windows Opzione non consigliata dal momento che il nuovo account creato avrà un nuovo SID e, pertanto, la cronologia SID dell'account utente Microsoft Windows NT® Server 4.0 non verrà trasferita al nuovo account durante la migrazione (poiché i SID sono diversi).

  • Crea un account utente Windows disattivato Opzione consigliata dal momento che consente all'utente Windows NT® Server 4.0 di coesistere con il nuovo account (con accesso corretto alle risorse) fino a quando viene completata l'intera migrazione.

Per risolvere il problema

  1. Configurare il Contratto di connessione destinatario di Active Directory per creare account utente Windows disabilitati, abilitati alle cassette postali.

  2. Utilizzare l'Utilità di migrazione di Active Directory che consente la migrazione di account utente Microsoft Windows NT® Server 4.0 ad Active Directory e la creazione account Windows abilitati. Tali account Windows abilitati presentano lo stesso SID degli account Windows disabilitati creati da ADC.

  3. Utilizzare ADClean (Active Directory Cleanup Wizard, Pulitura guidata account di Active Directory), che unisce le informazioni dall'account creato con l'Utilità di migrazione di Active Directory a quelle dell'account creato con ADC.

Per ulteriori informazioni sui contratti di connessione destinatario di Active Directory Connector, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823601, "Requisiti ed effetti di Active Directory Connector in un'organizzazione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601.

  • 303180, "Requisiti del Contratto di connessione di Active Directory Connector per gruppi amministrativi in modalità mista" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180.

  • 296260, "XGEN: Configurazione di un Contratto di connessione destinatario bidirezionale per utenti di Exchange 5.5" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=296260.

  • Per ulteriori informazioni sulla Pulitura guidata account di Active Directory, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 270652, "Utilizzi possibili della Pulitura guidata account di Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270652.

  • Per ulteriori informazioni sull'Utilità di migrazione di Active Directory, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 260871, "HOW TO: Configurare ADMT per la migrazione da Windows NT 4.0 a Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260871.


Contratto di connessione unidirezionale di Exchange
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchSynchronizationDirection in ogni oggetto Contratto di connessione. L'attributo msExchSynchronizationDirection rappresenta la direzione in cui verranno sincronizzate le directory. Se questo attributo è impostato su 2, verrà visualizzato un avviso.

L'attributomsExchSynchronizationDirection può presentare un valore 0 oppure 2. Se è impostato su 0, l'attributo indica un Contratto di connessione bidirezionale. Se è impostato su 2, l'attributo indica un Contratto di connessione unidirezionale dal computer Exchange Server.

Si consiglia di utilizzare i contratti di connessione bidirezionali. Ambienti Exchange in modalità mista, ovvero gli ambienti in cui Exchange Server 5.5 coesiste con Exchange 2000 Server o con Exchange Server 2003, necessitano di un Contratto di connessione bidirezionale.

Per risolvere il problema

  1. Rimuovere il Contratto di connessione unidirezionale.

  2. Creare un Contratto di connessione bidirezionale di sostituzione.

Per ulteriori informazioni sui contratti di connessione di Active Directory Connector (ADC), consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823601, "Requisiti ed effetti di Active Directory Connector in un'organizzazione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601.

  • 303180, "Requisiti del Contratto di connessione di Active Directory Connector per gruppi amministrativi in modalità mista" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180.

  • 317721, "XADM: Rimozione dei diritti del proprietario della cassetta postale di Exchange Server 5.5 quando si modifica il Contratto di connessione ADC impostandolo da unidirezionale a bidirezionale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721.


Contratto di connessione unidirezionale di Windows
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchSynchronizationDirection in ogni oggetto Contratto di connessione. L'attributo msExchSynchronizationDirection rappresenta la direzione in cui verranno sincronizzate le directory. Se questo attributo è impostato su 1, verrà visualizzato un avviso.

L'attributo msExchSynchronizationDirection può presentare un valore pari a 0, 1 o 2. Il valore 0 indica un Contratto di connessione bidirezionale, il valore 1 indica una connessione unidirezionale da Active Directory e il valore 2 indica un Contratto di connessione unidirezionale dal computer che esegue Exchange Server.

Si consiglia di utilizzare i Contratti di connessione bidirezionali. Ambienti Exchange in modalità mista, ovvero gli ambienti in cui Exchange Server 5.5 coesiste con Exchange 2000 Server o con Exchange Server 2003, necessitano di un Contratto di connessione bidirezionale.

Per risolvere il problema

  1. Rimuovere il Contratto di connessione unidirezionale.

  2. Creare un Contratto di connessione bidirezionale di sostituzione.

Per ulteriori informazioni sui contratti di connessione ADC (Active Directory Connector), consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823601, "Requisiti ed effetti di Active Directory Connector in un'organizzazione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823601.

  • 303180, "Requisiti del Contratto di connessione di Active Directory Connector per gruppi amministrativi in modalità mista" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=303180.

  • 317721, "XADM: Rimozione dei diritti del proprietario della cassetta postale di Exchange Server 5.5 quando si modifica il Contratto di connessione ADC impostandolo da unidirezionale a bidirezionale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=317721.


La differenza tra i timestamp di Exchange e di Active Directory è superiore a 5 minuti
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_UTCTime per determinare la data e l'ora su ciascun server di Exchange. In Exchange Server Analyzer, inoltre, vengono recuperati la data e l'ora correnti sul controller di dominio predefinito. Se Exchange Server Analyzer rileva una differenza di almeno cinque minuti tra i due server, verrà visualizzato un messaggio di errore.

In Microsoft Windows 2000 Server e in Windows Server™ 2003 viene utilizzato il servizio Ora di Windows per sincronizzare la data e l'ora dei computer eseguiti su una rete basata su Windows. L'ora sincronizzata è un componente fondamentale in Windows 2000 Server e in Windows Server 2003 poiché nel protocollo di autenticazione predefinito viene utilizzata l'ora della workstation come parte del processo di generazione del ticket di autenticazione. MIT Kerberos versione 5 è il protocollo di autenticazione predefinito.

Per tutti i server basati su Windows in un dominio del servizio directory di Active Directory®, il servizio Ora di Windows si configura automaticamente utilizzando il servizio Ora di Windows disponibile sui controller di dominio. Il servizio Ora di Windows configura un controller di dominio nel proprio dominio come un'origine ora affidabile e si sincronizza periodicamente con tale origine.

Per correggere questo errore, è necessario sincronizzare l'orologio sul server Exchange con il server di elenchi in linea.

Per sincronizzare l'orologio su un server in un dominio di Active Directory

  1. Aprire un prompt dei comandi.

  2. Digitare w32tm /resync, quindi premere INVIO.

Se l'errore persiste o se viene generato da molti computer dell'organizzazione, controllare come è stato distribuito e configurato il servizio Ora di Windows neIla struttura di Active Directory. Per ulteriori informazioni sul servizio Ora di Windows, consultare "Windows Time Service Technical Reference" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=40648 (informazioni in lingua inglese).

Quando server Exchange front-end non sono sincronizzati con l'ora di Active Directory, nei client possono essere visualizzati errori del tipo "HTTP 500 - Errore interno del server" quando si tenta la connessione a Microsoft Office Outlook® Web Access. Per ulteriori informazioni su questa situazione, consultare l'articolo 841546 della Microsoft Knowledge Base "Problemi noti che provocano il messaggio di errore "500 - Errore interno del server" in Exchange 2000 Outlook Web Access" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841546.


La differenza tra i timestamp del server ADC e di Active Directory è superiore a 5 minuti
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_UTCTime per determinare la data e l'ora su ciascun server ADC (Active Directory Connector). In Exchange Server Analyzer, inoltre, vengono recuperati la data e l'ora correnti sul controller di dominio predefinito. Se Exchange Server Analyzer determina che esiste una differenza di almeno cinque minuti tra i due server, verrà visualizzato un messaggio di errore.

In Microsoft Windows 2000 Server e in Windows Server™ 2003 viene utilizzato il servizio Ora di Windows per sincronizzare la data e l'ora dei computer eseguiti su una rete basata su Windows. L'ora sincronizzata è un componente fondamentale in Windows 2000 Server e in Windows Server 2003 poiché nel protocollo di autenticazione predefinito viene utilizzata l'ora della workstation come parte del processo di generazione del ticket di autenticazione. MIT Kerberos versione 5 è il protocollo di autenticazione predefinito.

Per tutti i server Windows in un dominio del servizio directory di Active Directory®, il servizio Ora di Windows si configura automaticamente utilizzando il servizio Ora di Windows disponibile sui controller di dominio. Il servizio Ora di Windows configura un controller di dominio nel proprio dominio come un'origine ora affidabile e si sincronizza periodicamente con tale origine.

Per correggere questo errore, è necessario sincronizzare l'orologio sul server ADC con il server di elenchi in linea.

Per sincronizzare l'orologio su un server in un dominio di Windows 2000 Server o di Windows Server 2003

  1. Aprire un prompt dei comandi.

  2. Digitare w32tm /resync, quindi premere INVIO.

Se l'errore persiste o se viene generato da molti computer dell'organizzazione, controllare come è stato distribuito e configurato il servizio Ora di Windows neIla struttura di Active Directory. Per ulteriori informazioni sul servizio Ora di Windows, consultare "Windows Time Service Technical Reference" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=40648 (informazioni in lingua inglese).


Non è attiva la build finale rilasciata di Windows Server 2003
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave Version nei server ADC (Active Directory Connector) dell'organizzazione di Exchange. Exchange Server Analyzer esamina inoltre il seguente valore del Registro di sistema per determinare la versione di Windows in esecuzione sui server ADC:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se Exchange Server Analyzer rileva che il valore della seconda istanza di CurrentVersion è 5.2 e il valore di Version non corrisponde a 5.2.3790, verrà visualizzato un messaggio di errore.

Un valore CurrentVersion corrispondente a 5.2 indica che sul computer è in esecuzione un sistema operativo Windows Server 2003. Il valore Version relativo alla versione rilasciata di tutti i sistemi operativi Windows Server 2003 è 5.2.3790. Qualsiasi altro valore della chiave Version indica che è in uso una versione non definitiva di Windows Server 2003.

A meno che non si faccia parte di un programma TAP (Technology Adoption Program) o di un programma simile sponsorizzato da Microsoft, non è supportato né consigliato l'utilizzo di versioni preliminari di software in ambienti di produzione.

Per risolvere il problema

  1. Eseguire l'aggiornamento all'ultimo software rilasciato di tutti i server dell'infrastruttura di Exchange, inclusi i controller di dominio, i server di catalogo globale, i server ADC e i computer che eseguono Exchange Server.

  2. Se l'opzione di aggiornamento è disponibile o supportata, ricostruire il sistema operativo e ripristinare i dati e le impostazioni di Exchange Server.

Eseguire l'aggiornamento all'ultimo software rilasciato di tutti i server dell'infrastruttura di Exchange, inclusi i controller di dominio, i server di catalogo globale, i server ADC e i computer che eseguono Exchange Server.

Per ulteriori informazioni sugli aggiornamenti software di Windows Server 2003, consultare il sito Web "Windows Server 2003 Software Updates" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33760 (informazioni in lingua inglese).


Su Windows Server 2003 è in esecuzione una versione non definitiva del software
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esamina la classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave ServicePackMajorVersion. Exchange Server Analyzer esamina inoltre il seguente valore del Registro di sistema per determinare la versione di Windows in esecuzione sul computer di destinazione:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se il valore della seconda istanza di CurrentVersion è 5.2 e il valore di ServicePackMajorVersion è maggiore di 1, verrà visualizzato un avviso.

Un valore CurrentVersion corrispondente a 5.2 indica che sul computer è in esecuzione un sistema operativo Microsoft Windows Server™ 2003. Un valore di ServicePackMajorVersion maggiore di 1 indica che è stata installata una versione successiva del Service Pack 1. Dal momento che il Service Pack 1 è l'unica versione di Service Pack rilasciata per Windows Server 2003, significa che tutti i Windows Server 2003 Service Pack 2 o successivi installati sono versioni non definitive del software.

A meno che non si faccia parte di un programma TAP (Technology Adoption Program) o di un programma simile sponsorizzato da Microsoft, è consigliabile non eseguire versioni non definitive del software in ambienti di produzione.

Per risolvere il problema

  1. Disinstallare eventuali versioni di software non definitive.

  2. Se è disponibile l'opzione di disinstallazione, ricreare il sistema operativo e ripristinare le impostazioni e i dati di Exchange Server.

Per ulteriori informazioni sugli aggiornamenti software di Windows Server 2003, consultare il sito Web "Windows Server 2003 Software Updates" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33760 (informazioni in lingua inglese).


Il Service Pack 4 non è in esecuzione su Windows 2000 Server
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool analizza la classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave ServicePackMajorVersion. Exchange Server Analyzer analizza anche la voce del Registro di sistema indicata di seguito per determinare la versione di Windows in esecuzione sul computer specificato:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se Exchange Server Analyzer rileva che nel sistema specificato è in esecuzione un sistema operativo della famiglia Windows 2000 Server ma non il Service Pack 4 per Windows 2000 Server, verrà visualizzato un avviso.

È consigliabile installare i Service Pack più recenti per tutti i prodotti software presenti nell'installazione di Exchange.

Per risolvere il problema

  1. Aggiornare tutti i controller di dominio e i server di catalogo globale in esecuzione nel sistema operativo Windows 2000 Server installando il Service Pack 4, oltre agli aggiornamenti rapidi e agli aggiornamenti più recenti da Windows Update.

  2. Aggiornare tutti i computer Exchange Server installando il Service Pack e l'aggiornamento cumulativo più recente.

Per ulteriori informazioni su come richiedere e installare i Service Pack per il sistema operativo Windows 2000 Server, consultare il sito Web "Windows 2000 Service Packs" all'indirizzo http://go.microsoft.com/fwlink/?linkid=18353 (informazioni in lingua inglese).

Per ulteriori informazioni su come richiedere e installare service pack e aggiornamenti cumulativi di Exchange Server, consultare il sito Web "Microsoft Exchange Server" all'indirizzo http://www.microsoft.com/italy/exchange/default.mspx.


Non è attiva la build finale rilasciata di Windows Server 2000
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2005-11-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave Version.

Exchange Server Analyzer esamina inoltre il seguente valore del Registro di sistema per determinare la versione di Windows in esecuzione sul computer:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Un valore CurrentVersion corrispondente a 5,0 indica che sul computer è in esecuzione un sistema operativo Microsoft Windows 2000 Server™. Il valore Version relativo alla versione rilasciata di tutti isistemi operativi Windows 2000 Server è 5.0.2195. Qualsiasi altro valore della chiave Version indica che è in uso una versione non definitiva di Windows 2000 Server.

Se Exchange Server Analyzer rileva che il valore della seconda istanza di CurrentVersion è 5.0 e il valore di Version non corrisponde a 5.0.2195, verrà visualizzato un messaggio di errore.

A meno che non si faccia parte di un programma TAP (Technology Adoption Program) o di un programma simile sponsorizzato da Microsoft, non è supportato né consigliato l'utilizzo di versioni non definitive del software in ambienti di produzione.

Per risolvere il problema

  1. Eseguire l'aggiornamento all'ultimo software rilasciato di tutti i server dell'infrastruttura di Exchange, inclusi i controller di dominio, i server di catalogo globale, i server ADC e i computer che eseguono Exchange Server.

  2. Se l'opzione di aggiornamento è disponibile o supportata, ricostruire il sistema operativo e ripristinare i dati e le impostazioni di Exchange Server.

Per informazioni su come ottenere e installare Windows 2000 Service Pack 4, consultare il sito Web "Windows 2000 Service Pack 4" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33241.


Carattere finale dell'indirizzo X.400 non valido
Articoli su Microsoft Exchange Server Analyzer > Active Directory >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore di gatewayProxy nei criteri destinatari e verificare che l'indirizzo X.400 termini con un punto e virgola.

Per essere in formato corretto, un indirizzo X.400 in un criterio destinatario deve terminare con un punto e virgola. Se il punto e virgola non è presente, il routing dei messaggi all'indirizzo X.400 verrà interrotto.

Per risolvere questo problema è necessario aggiungere un punto e virgola alla fine dell'indirizzo utilizzando ADSI Edit (Active Directory Service Interfaces) o lo strumento LDP.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Espandere Configurazione [NomeDominio], quindi CN=Configuration, DC=NomeDominio, DC=SuffissoDominio.

  3. Espandere CN=Services, quindi CN=Microsoft Exchange.

  4. Espandere CN=NomeOrganizzazione, CN=Administrative Groups, quindi CN=Recipient Policies.

  5. Fare clic con il pulsante destro del mouse su CN=NomeCriterio e scegliere Proprietà.

  6. Scorrere verso il basso fino a individuare gatewayProxy, selezionarlo e fare clic su Modifica.

  7. Nel campo Valore immettere il corretto attributo gatewayProxy.

  8. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il computer che esegue Exchange Server.


Ripristino dei database
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2007-01-22

Negli articoli contenuti in questa sezione vengono illustrati i dettagli sugli errori del database e sugli eventi di avviso rilevati dallo strumento Microsoft® Exchange Database Troubleshooter nel registro eventi dell'applicazione. Tale strumento utilizza lo stesso motore di Microsoft Exchange Troubleshooting Assistant per eseguire a livello di programmazione una serie di procedure di risoluzione dei problemi, allo scopo di determinare le cause principali dei problemi di installazione del database. In questi articoli, inoltre, sono descritte le procedure da eseguire per determinare i sintomi e risolvere gli errori relativi ai database.

Per ulteriori informazioni nonché per scaricare lo strumento, vedere Microsoft Exchange Troubleshooting Assistant v1.0 (informazioni in lingua inglese).


ESE 428 (0xfffff8f0): Spazio disponibile insufficiente nell'unità di registro delle transazioni
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-04-02

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi ESE 428 nel Registro applicazione. L'evento indica che lo spazio su disco disponibile nell'unità del registro delle transazioni è insufficiente. Quando viene generato questo errore, Exchange Server non sarà in grado di creare un nuovo file di registro delle transazioni. In tal modo tutti i database nel gruppo di archiviazione interessato verranno messi fuori linea, perché è necessario registrare gli aggiornamenti dei database nel registro delle transazioni.

Spiegazione

In Exchange Server sono disponibili due meccanismi per impedire che si esaurisca lo spazio sull'unità del registro delle transazioni:

  • Registrazione circolare. I registri delle transazioni vengono eliminati automaticamente dopo che il checkpoint del database è avanzato superandoli. Lo spazio su disco utilizzato per i file del registro delle transazioni resterà al di sotto dei 50 MB nella maggior parte dei casi. Durante il backup è possibile sospendere la rimozione dei registri delle transazioni fino al termine del backup.

    Nota:
    Per impostazione predefinita, la registrazione circolare non è abilitata in Microsoft Exchange 2000 Server e versioni successive.
  • Backup del gruppo di archiviazione. In Exchange Server è possibile rimuovere i registri in eccesso dopo che è stato eseguito un backup in linea completo o incrementale di tutti i database in un gruppo di archiviazione utilizzando un metodo che implementi il Servizio Copia Shadow dei volumi o API di stream per backup in linea di Exchange Server.

Se la registrazione circolare non è abilitata e una delle condizioni riportate di seguito è vera, i file del registro delle transazioni aumenteranno di numero fino a quando lo spazio sul disco rigido non sarà esaurito:

  • Il programma di backup non rimuove i file del registro delle transazioni.

  • È stata interrotta l'esecuzione del programma di backup.

  • I file del registro delle transazioni non vengono eliminati se si utilizzano altri metodi.

Occasionalmente può essere necessario rimuovere manualmente i file del registro delle transazioni, se si è esaurito lo spazio sul disco rigido. Oppure, a volte, potrebbe essere necessario rimuovere manualmente i file del registro delle transazioni se si prevede di esaurire lo spazio disponibile sul disco rigido prima di eseguire un backup in linea completo o incrementale di tutti i database in uno specifico gruppo di archiviazione. Se si rimuovono i registri che ancora non hanno raggiunto un checkpoint del database e il database viene interrotto in modo anomalo, non sarà possibile montare tale database fino a quando non verranno ripristinati i registri necessari. Pertanto, è necessario determinare quali siano i registri che è possibile rimuovere senza problemi prima di rimuovere manualmente i file del registro delle transazioni di Exchange Server.

L'errore può anche essere segnalato come JET_errDiskFull oppure con il codice di errore 0xfffff8f0. Questo errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere il problema, applicare una delle soluzioni seguenti:

  • Eseguire lo strumento Database Recovery Management. In Microsoft Exchange Server 2007 lo strumento è elencato tra gli strumenti di Ripristino del database nella Casella degli strumenti di Exchange Management Console. Exchange Server Analyzer è in grado di determinare automaticamente i file di registro che possono essere rimossi in sicurezza, copiandoli in un percorso di backup. Si consiglia di utilizzare Exchange Server Analyzer per spostare i file di registro.

    Nota:
    Exchange Server Analyzer non funziona in Exchange 2007 se il gruppo di archiviazione che contiene il database è abilitato per la replica continua di tipo cluster (CCR, Cluster Continuous Replication).
  • Controllare i valori di Stato e Registro richiesto in ogni intestazione di database per determinare quali file del registro delle transazioni possono essere rimossi manualmente senza problemi.

    Nota:
    Ai fini di questo articolo, la rimozione di un file del registro delle transazioni significa lo spostamento di tale file in un altro percorso dove sarà possibile eseguirne il backup, archiviarlo o eliminarlo. L'operazione dipende dalle esigenze dell'utente. Ai fini di questo articolo, l'eliminazione di un file del registro delle transazioni indica il tipo di rimozione che non consente di eseguire il backup o il ripristino di tale file.

Seguire questa procedura dettagliata per determinare quali file del registro delle transazioni è possibile rimuovere manualmente senza problemi.

Per esaminare l'intestazione del database e rimuovere file di registro non necessari

  1. Smontare il database di cui si desidera esaminare l'intestazione.

  2. Fare clic su Start, scegliere Esegui, quindi digitare cmd per aprire la finestra del prompt dei comandi.

  3. Al prompt dei comandi, passare al percorso di directory in cui si trova il file di database.

    Nota:
    In Exchange 2000 Server ed Exchange Server 2003, per determinare il percorso e il nome di file dei file EDB e STM di un database, usare Exchange System Manager per visualizzare la scheda Database della finestra di dialogo delle proprietà per ogni oggetto di database. In Exchange Server 2007, per determinare il nome e il percorso del file di database, espandere Exchange Management Console in Configurazione server, fare click su Cassetta postale, quindi visualizzare la scheda Gestione del database.

  4. Al prompt dei comandi digitare il seguente comando Eseutil assieme all'opzione /MH:

    Copia codice
    "eseutil /MH databasefilename.edb"
    Nota:
    Nella sintassi, databasefilename è il nome del database che si desidera esaminare.

  5. Esaminare i valori di Stato e Registro richiesto nelle informazioni delle intestazioni che vengono visualizzate.

    Il valore di Stato fornisce le informazioni riportate di seguito relativamente allo scollegamento corretto o errato del database:

    • Se il database è stato scollegato in modo corretto, il valore di Stato è Chiusura normale o Coerente. Tale valore dipende dalla versione di Exchange Server in esecuzione. È possibile rimuovere tutti i file del registro delle transazioni tranne il file del registro delle transazioni corrente.

      Nota:
      Se il file di registro corrente viene spostato quando tutti i database sono nello stato di chiusura normale, verrà eseguito il ripristino della sequenza del file di registro. Questa situazione non impedisce l'avvio dei database. Tuttavia, un ripristino della sequenza del file di registro influenza la capacità di eseguire il roll forward di un database da un precedente backup, qualora si verifichi la situazione.
    • Se il database è stato scollegato in modo non corretto, il valore di Stato è Chiusura anomala o Incoerente. Determinare i file del registro delle transazioni che è possibile rimuovere selezionando il campo Registro richiesto nell'intestazione del database.

      Nota:
      Se lo stato del database è Chiusura anomala o Incoerente, alcuni dei file del registro delle transazioni contengono transazioni in sospeso richieste dal database. Se si rimuovono i file del registro delle transazioni in questo caso, non sarà possibile riavviare il database fino a quando non verrà ripristinato da un backup In alternativa è possibile riparare il database utilizzando il comando Eseutil e il comando Isinteg.
      È necessario esaminare i valori di Registro richiesto per ogni database in un gruppo di archiviazione prima di rimuovere eventuali registri per tale gruppo di archiviazione.

      Nel campo Registro richiesto è elencato l'intervallo di file di registro numerati necessari per avviare il database. Se l'intervallo è 0 - 0, non sono necessari file di registro per avviare il database. Significa che lo stato del database è Chiusura normale o Coerente. Se sono presenti file di registro precedenti al registro del checkpoint, è possibile rimuovere tali file di registro escludendo il registro del checkpoint.

      Se si esegue una versione di Exchange Server precedente a Exchange Server 2003 Service Pack 1 (SP1), è necessario convertire l'intervallo decimale elencato nel campo Registro richiesto in valori esadecimali. Ad esempio, se il valore di Registro richiesto è 28217 - 28221, per il database sono necessari i file di registro compresi tra 06E39 e 06E3D. In Exchange 2003 SP1 il campo Registro richiesto è stato migliorato in modo da riportare sia i valori decimali sia quelli esadecimali.

      Nota:
      È possibile utilizzare la modalità Scientifica della Calcolatrice di Windows per convertire i valori da decimali a esadecimali. Avviare la Calcolatrice, quindi fare clic su Scientifica nel menu Visualizza. Immettere il numero decimale, quindi fare clic su Hex.
      Poiché è possibile avere fino a quattro gruppi di archiviazione in Exchange 2000 e in Exchange 2003, con ogni gruppo che contiene uno specifico set di file di registro, il prefisso Edb non viene visualizzato nei nomi dei file del registro delle transazioni. In Exchange 2000 e in Exchange 2003 il prefisso Edb è sostituito da E00, E01, E02 o E03. Per un gruppo di archiviazione di ripristino il prefisso Edb è sostituito da R00. Il prefisso del file di registro nel gruppo di archiviazione è visualizzato nel Gestore di sistema di Exchange nella scheda Generale della finestra di dialogo delle proprietà dello specifico oggetto gruppo di archiviazione. Pertanto, se il prefisso del gruppo di archiviazione è E01 e se la voce di Registro richiesto è 28217 - 28221 (0x06E39 - 0x06E3D), i registri effettivi che sono richiesti sono compresi tra E0106E39.log e E0106E3D.log.

  6. È possibile rimuovere senza problemi tutti i file di registro il cui numero sia inferiore alla voce minore in un campo Registro richiesto per qualunque database nel gruppo di archiviazione.

    Nota:
    Ricordarsi di spostare, senza eliminare, i file di registro.
    Nota:
    È consigliabile non rimuovere il file del registro delle transazioni più recente. Si tratta del file di registro con il timestamp più recente e che ancora non dispone di un numero di sequenza nel nome. Anche se si è determinato che è possibile rimuovere il file, è meglio mantenerlo, per impedire il ripristino a 0 della sequenza di file di registro. Se si reimposta la sequenza di file di registro, verranno influenzati i cicli di backup. Può essere impossibile eseguire il roll forward del database da un backup eseguito prima del ripristino.


ESE 454 -515: File di registro delle transazioni necessario mancante
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Microsoft® Exchange Server Analyzer Tool ha rilevato un evento ESE 454 con codice di errore -515. Tale errore indica che non è stato possibile installare il database di Exchange in quanto un file di registro delle transazioni necessario è mancante.

Spiegazione

Un evento ESE 454 con errore -515 può verificarsi se ESE (Extensible Storage Engine) tenta di riportare tutti i database in un gruppo di archiviazione a uno stato coerente durante il processo di recupero. Se un eventuale file di registro delle transazioni necessario è mancante, il processo di recupero non riesce e risulta impossibile installare il database con l'errore -515.

Operazione dell'utente

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti:

  • Attenendosi alle procedure indicate, individuare i file di registro delle transazioni mancanti e la relativa posizione. Quindi, spostarli nuovamente nella directory del registro delle transazioni per il gruppo di archiviazione.

  • Ripristinare il database o i database interessati dal backup.

Attenzione
Provare a ripristinare il database solo se la precedente soluzione, che consiste nel rilevare e ripristinare gli specifici file di registro delle transazioni mancanti, ha avuto esito negativo. In caso contrario, tutti i dati successivi all'ultimo backup verranno sovrascritti.
Nota:
Prima di ripristinare il database o i database, spostare o eliminare dal percorso di destinazione gli eventuali file di registro delle transazioni associati al gruppo di archiviazione interessato.
Per identificare i file di registro delle transazioni mancanti utilizzando Microsoft Exchange Troubleshooting Assistant in Exchange Server 2003 ed Exchange Server 2007

  1. Nella finestra Visualizza risultati del registro eventi di analisi di Microsoft Exchange Troubleshooting Assistant, fare clic sul collegamento Per verificare e risolvere questo problema, utilizzare l'attività correlata di Gestione ripristino dei database per identificare i file di registro delle transazioni necessari mancanti.

  2. Annotare i nomi dei file di registro riportati al punto 1.

  3. Determinare la posizione corrente dei file di registro e spostarli nuovamente nella posizione prevista.
Nota:
Nel determinare la posizione corrente dei file di registro delle transazioni mancanti, assicurarsi di cercare anche nel Cestino e nelle eventuali cartelle di quarantena.
  1. Provare a installare il database di Exchange interessato.

 Per identificare e ripristinare manualmente i registri delle transazioni mancanti in Exchange 2000 Server o Exchange Server 2003

  1. Avviare il Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo e Server, fare clic con il pulsante destro del mouse sul gruppo di archiviazione e scegliere Proprietà.

  3. Nella scheda Generale, in Posizione registro transazioni annotare il percorso in cui si trovano i file di registro delle transazioni.

  4. Al prompt dei comandi, aprire la directory in cui si trova Eseutil.exe. Il percorso predefinito per Eseutil.exe in Exchange 2000 Server ed Exchange Server 2003 è C:\Programmi\exchsrvr\bin.

  5. Al prompt dei comandi, immettere il seguente comando:

    Copia codice
    eseutil /ml "logpath\logprefix"

    Dove logpath è il percorso dei file di registro delle transazioni annotato al punto 3 e logprefix è il prefisso dei file di registro delle transazioni, di solito e00.

    Un esempio di questo comando con i valori predefiniti è il seguente:

    eseutil /ml "c:\program files\exchsrvr\mdbdata\e00".

  6. I file di registro delle transazioni mancanti verranno segnalati in uno dei due formati seguenti, a seconda di quale file di registro è mancante:

    • File di registro mancante: c:\Programmi\exchsrvr\mdbdata\E0002BE2.log

    • ERRORE: File di registro mancante/i. Il file di registro è di generazione 11,235 (0x2BE3), ma la generazione prevista è 11,234 (0x2BE2).

    Dove 0x2BE2 è il file di registro mancante, E0002BE2.log.

  7. Annotare i nomi dei file di registro riportati al punto 6.

  8. Determinare la posizione corrente dei file di registro e spostarli nuovamente nella posizione prevista al punto 3.
Nota:
Nel determinare la posizione corrente dei file di registro delle transazioni mancanti, assicurarsi di cercare anche nel Cestino e nelle eventuali cartelle di quarantena.
  1. Provare a installare il database di Exchange interessato.

 Per identificare e ripristinare manualmente i registri delle transazioni mancanti in Exchange Server 2007

  1. Avviare Exchange Management Console sul server sul quale si trova il gruppo di archiviazione.

  2. Nella struttura della console espandere Configurazione server e fare clic su Cassetta postale.

  3. Nel riquadro dei risultati, fare clic sul server cassette postali contenente il gruppo di archiviazione per il quale si desidera ripristinare i file di registro delle transazioni mancanti.

  4. Fare clic con il pulsante destro del mouse sul proprio gruppo di archiviazione, quindi scegliere Proprietà.

  5. . Nella scheda Generale, in Percorso registro annotare il percorso in cui si trovano i file di registro delle transazioni.

  6. Al prompt dei comandi, aprire la directory in cui si trova Eseutil.exe. In Exchange Server 2007 Eseutil si trova nella cartella di installazione predefinita di Exchange, ovvero <Unità di sistema>:\Programmi\Microsoft\Exchange Server\Bin.

  7. Al prompt dei comandi, immettere il seguente comando:

    Copia codice
    eseutil /ml "logpath\logprefix"

    Dove logpath è il percorso dei file di registro delle transazioni annotato al punto 5 e logprefix è il prefisso dei file di registro delle transazioni, di solito e00.

    Un esempio di questo comando con i valori predefiniti è il seguente:

    eseutil /ml "c:\Program Files\Microsoft\Exchange Server\Bin\e00".

  8. I file di registro delle transazioni mancanti verranno segnalati in uno dei due formati seguenti, a seconda di quale file di registro è mancante:

    • File di registro mancante: c:\Programmi\Microsoft\Exchange Server\Bin\E000000049A.log

    • ERRORE: File di registro mancante/i. Il file di registro è di generazione 11,235 (0x2BE3), ma la generazione prevista è 11,234 (0x2BE2).

    Dove 0x2BE2 è il file di registro mancante, E0002BE2.log.

  9. Annotare i nomi dei file di registro riportati al punto 8.

  10. Determinare la posizione corrente dei file di registro e spostarli nuovamente nella posizione prevista al punto 5.
Nota:
Nel determinare la posizione corrente dei file di registro delle transazioni mancanti, assicurarsi di cercare anche nel Cestino e nelle eventuali cartelle di quarantena.
  1. Provare a installare il database di Exchange interessato.

Per ulteriori informazioni sull'evento ESE 454, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81883.


ESE 455 -1811 (0xfffff8ed): File di registro delle transazioni (E##.log) correnti mancante
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-05-31

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi ESE 455 con codice di errore -1811 (0xfffff8ed) nel registro applicazioni. L'evento indica che il registro delle transazioni in uso (exx.log) risulta mancante, non accessibile o con firma non corrispondente.

Spiegazione

Le cause dell'errore possono essere le seguenti:

  • Errore 1811 corrispondente a JET_errFileNotFound. Il problema può insorgere in un file di registro di Exchange con mancata corrispondenza della firma e numero di generazione registro interno (LGeneration). In genere, il file di registro di Exchange è il file E00.log. In caso di mancata corrispondenza della firma nel file E00.log, l'archivio informazioni potrebbe non essere installato anche se il database è coerente.

  • Un programma antivirus mette in quarantena o elimina il file di registro di Exchange in uso.

  • Non sono stati rimossi i file di registro dopo l'esecuzione del comando di ripristino eseutil /p sui database interessati.

  • Il comando di recupero eseutil /r è stato eseguito con un nome di base del file di registro errato, come nell'esempio eseutil /r Exx.log, dove Exx.log è un nome di base di file di registro a tre caratteri.

L'errore può essere anche identificato come errore -1811, JET_errFileNotFound. Questo errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per correggere l'errore, eseguire uno o più dei seguenti passaggi:

  • In caso di mancata corrispondenza della firma e del numero di generazione registro nel file di registro, contattare il Servizio Supporto Tecnico Clienti Microsoft. Per ulteriori informazioni, visitare la pagina "Vuoi contattarci?" del sito Web del Supporto Tecnico Microsoft.

  • Se un programma antivirus mette in quarantena o elimina il file di registro di Exchange in uso, procedere come descritto di seguito:

    • Esaminare la configurazione del programma antivirus.

    • Accertarsi che il programma antivirus non sia configurato per eseguire la scansione delle directory di Exchange Server.

    • Per impostazione predefinita, alcuni programmi antivirus sono impostati per eseguire la scansione delle unità e delle directory ogni settimana in modalità manuale o automatica. Questa impostazione sfugge spesso all'attenzione dell'utente. Accertarsi di aggiungere le directory di Exchange Server ai percorsi esclusi del programma antivirus. Per ulteriori informazioni sulle modalità di configurazione dei programmi antivirus per l'utilizzo con Exchange, vedere l'articolo 823166 della Microsoft Knowledge Base Panoramica di Exchange Server 2003 e software antivirus.

    • Analizzare i file di registro del programma antivirus per verificare che il file di registro di Exchange sia stato messo in quarantena o eliminato.

    Per recuperare il file di registro di Exchange, utilizzare uno dei seguenti metodi:

Metodo 1: se il file di registro di Exchange è stato messo in quarantena

  1. Recuperare il registro di Exchange nella cartella contenente i file di registro di produzione.

  2. Avviare il servizio Archivio informazioni di Microsoft Exchange. Se nessun altro file è mancante, il database viene installato. Se mancano altri file di registro, verificare se si trovano nella cartella di quarantena del programma antivirus. Se i file di registro non si trovano nella cartella di quarantena, vedere il Metodo 2.

Se il file di registro di Exchange è stato eliminato, è necessario ripristinare il database del gruppo di archiviazione da un backup. Quindi, è necessario rieseguire i file di registro. Per ripristinare un database disponibile, procedere come segue:

Metodo 2: se il file di registro di Exchange è stato eliminato

  1. Spostare tutti i database incoerenti in una cartella di backup.

  2. Se è stato creato un nuovo file E00.log, spostarlo nella cartella di backup. Inoltre, spostare il file E00.chk nella cartella di backup.

  3. Copiare tutti i file di registro esistenti nella cartella di backup.Nota: è necessario copiare i file di registro. Non spostare i file di registro.

  4. Rinominare l'ultimo file E00*.log in E00.log.

  5. Ripristinare il database da un backup. Quindi, rieseguire i file di registro. In tal modo, viene ripristinato uno stato coerente del database, il quale, tuttavia, non include il file E00.log copiato nella cartella di backup. Benché si sia verificata una perdita di dati, è possibile installare il database ottenuto.

    Nota:
    Se risulta impossibile ripristinare il database da un backup, eseguire le utilità di ripristino sul database per ripristinarne lo stato coerente

  6. Avviare il servizio Archivio informazioni di Microsoft Exchange.

Se non sono stati rimossi i file di registro dopo l'esecuzione del comando di ripristino eseutil /p sui database interessati, procedere come descritto di seguito:

Per verificare che il comando eseutil /p sia stato eseguito

  1. Fare clic su Start, Esegui, digitare cmd, quindi scegliere OK.

  2. Al prompt dei comandi digitare quanto segue:

    Copia codice
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\<name of Exchange database.edb>"

    La sintassi precedente presume quanto segue:

    • I file di programma di Exchange Server sono stati installati nella cartella c:\Programmi\exchsrvr.

    • Il database si trova nella cartella c:\Programmi\exchsrvr\mdbdata.

  3. Rilevare l'attributo conteggio ripristini. Se è uguale a 0 (zero), il comando eseutil /p non è stato eseguito. Se corrisponde a un numero diverso da 0, il comando eseutil /p è stato eseguito sul database.

Se lo stato dei database pubblici e privati è coerente o di chiusura normale, è possibile spostare i file di registro delle transazioni in un'altra cartella. Per determinare se lo stato dei database è coerente o di chiusura normale, procedere come descritto di seguito:

Per determinare se lo stato dei database è coerente o di chiusura normale

  1. Fare clic su Start, Esegui, digitare cmd, quindi scegliere OK.

  2. Per esaminare l'archivio informazioni privato, digitare quanto segue:

    Copia codice
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\priv1.edb"

  3. Per esaminare l'archivio informazioni pubblico, digitare quanto segue:

    Copia codice
    c:\program files\exchsrvr\bin>eseutil /mh "drive:\program files\exchsrvr\mdbdata\pub1.edb"

    La sintassi riportata ai punti 2 e 3 presume quanto segue:

    • I file di programma di Exchange Server sono stati installati nella cartella C:\Programmi\exchsrvr.

    • Il database si trova nella cartella C:\Programmi\exchsrvr\mdbdata.

  4. Analizzare i risultati della verifica di coerenza. Se il database è coerente (stato di Chiusura normale), tutti i file di registro sono stati salvati nell'archivio informazioni. Se il database non è coerente (stato di Chiusura anomala), è possibile che il database non sia danneggiato e che i file di registro non siano stati ancora salvati nel database.

  5. Se lo stato è di chiusura normale, spostare tutti i file di registro da tutte le directory mdbdata in una cartella di backup.

  6. Installare i database.
  • Se il comando di recupero eseutil /r è stato eseguito con un nome di base del file di registro errato, utilizzare l'opzione esatta per eseguire correttamente il comando. I nomi di base dei file di registro comuni sono e00, e01, e02 ed e03. Ad esempio, il seguente comando contiene un nome di base di file di registro corretto:

    Copia codice
    eseutil /r e00
  • Se il problema persiste, contattare il Supporto Tecnico Microsoft. Per ulteriori informazioni, visitare la pagina "Vuoi contattarci?" del sito Web Supporto Tecnico Microsoft.


ESE 474 -1018: Errore irreversibile rilevato nel database
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-03-28

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi ESE 474 con codice di errore 1018 nel registro applicazioni. L'errore viene generato se il componente di verifica dell'integrità Exchange di Microsoft determina che Exchange Server non è stato in grado di archiviare o recuperare i dati del file del database Exchange dal sottosistema del disco rigido.

Spiegazione

Un evento ESE 474 con codice di errore -1018 può verificarsi a causa di un componente hardware del sottosistema del disco rigido difettoso o a causa di driver incompatibili oppure obsoleti e/o firmware nel sottosistema del disco rigido.

Dopo la restituzione di un errore -1018, i test diagnostici dell'hardware eseguiti sul server potrebbero segnalare l'assenza di problemi hardware del sottosistema del disco ed è probabile che l'errore sia causato da Exchange Server.

Analisi approfondite da parte di Microsoft e dei rivenditori di hardware hanno determinato che all'origine della maggior parte degli errori -1018 vi sono problemi delicati legati ai componenti hardware del sottosistema del disco, ai driver e/o al firmware di supporto.

Exchange restituisce un errore -1018 quando viene rilevata una pagina inizializzata nel file del database con una delle condizioni seguenti:

  • Il checksum archiviato nella pagina non corrisponde al risultato del nuovo calcolo de l checksum eseguito alla lettura della pagina.

  • Il numero di pagina archiviato nella pagina stessa non corrisponde al numero che dovrebbe essere visualizzato sulla pagina in base alla posizione fisica della stessa nel file del database.

È probabile che Exchange sia responsabile della generazione automatica di un errore -1018 in caso di uno degli scenari seguenti:

  • Exchange crea una pagina con il checksum errato.

  • Exchange crea una pagina correttamente ma segnala al sistema operativo di scrivere la pagina nella posizione errata.

Exchange genera un checksum per una pagina che sarà scritta sul disco dopo che tutti i dati sono stati scritti sulla pagina. Questo include anche il numero della pagina. Dopo aver aggiunto il checksum alla pagina, Exchange indica al sistema operativo Windows di scrivere la pagina sul disco utilizzando le API standard pubblicate basate su Windows.

Errori di memoria temporanei possono indurre la scrittura della pagina nella posizione errata sul disco rigido.

Anche se il checksum della pagina è corretto, Exchange restituisce un errore -1018 poiché il numero di pagina logico non corrisponde al numero di pagina fisico.

In genere, un singolo errore -1018 segnalato in un database di Exchange non induce l'arresto del database di Exchange o sintomi diversi dalla presenza dell'errore stesso. È probabile che la pagina interessata dall'errore non sia visualizzata frequentemente, ad esempio nel caso delle cartelle Posta inviata o Posta eliminata, o che sia relativa a un allegato aperto di rado o persino vuoto.

Anche se è improbabile che un singolo errore -1018 causi sostanziali perdite di dati, tali errori rappresentano un problema poiché possono indicare che il sistema di archiviazione non ha archiviato o recuperato i dati in modo affidabile almeno una volta. L'errore -1018 rappresenta una segnalazione preventiva di un problema che potrebbe tendere progressivamente a peggiorare. Anche se il primo errore -1018 viene restituito per una pagina vuota nel database, è impossibile sapere quale pagina potrebbe essere successivamente danneggiata. Se viene danneggiata una tabella globale critica, è probabile il database di Exchange non si avvii e che la relativa riparazione non possa essere eseguita oppure possa essere eseguita solo parzialmente.

Dopo che viene registrato un errore -1018, valutare e pianificare la possibilità di un errore imminente o di ulteriori danni casuali al database fino a quando non viene individuata la causa all'origine dell'errore.

Azione utente

Prima di provare a correggere gli errori ESE 474 -1018 nel registro applicazioni, accertarsi che il sottosistema del disco del server sia stabile.

Per risolvere il problema del sottosistema del disco, procedere come segue:

  1. Aprire il registro applicazioni e ricercare gli eventi ESE 474. Per ogni evento, annotare il percorso completo del database interessato. Dopo aver compilato un elenco dei database interessati, annotare la lettera dell'unità a cui si fa riferimento nei percorsi del database. Tali informazioni consentiranno di indirizzare l'impegno di risoluzione dei problemi direttamente sui dischi fisici.

  2. Esaminare il registro di sistema e accertarsi che non siano registrati errori di lettura, scrittura o timeout sul disco.

  3. Utilizzare le unità di diagnostica del sottosistema del disco fornite dal produttore e contattare il rivenditore hardware per assistenza sulla verifica dell'integrità del sottosistema del disco.

Dopo aver corretto i problemi nel sottosistema del disco o averne verificato in altro modo la stabilità, utilizzare uno dei seguenti metodi per correggere l'errore -1018. I metodi sono elencati nell'ordine o utilizzo preferito:

Primo metodo Spostare le cassette postali dai database a cui si fa riferimento negli eventi ESE 474 dal registro applicazioni. Spostare le cassette postali sugli archivi integri esistenti oppure creare un nuovo archivio cassette postali specifico per tale scopo. Dopo aver spostato tutte le cassette postali, eliminare gli archivi cassette postali danneggiati.

Per spostare le cassette postali su Exchange 2000 Server e Exchange Server 2003

  1. In Utenti e computer di Active Directory, selezionare l'utente o gli utenti proprietari delle cassette postali che si desidera spostare.

  2. Fare clic con il pulsante destro del mouse sull'elenco utente selezionato nel passaggio precedente e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange, fare clic su Sposta cassetta postale e poi su Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.
Per spostare le cassette postali in Exchange Server 2003

  1. In Gestore di sistema di Exchange, espandere Server, quindi espandere il server dal quale si desidera sposare le cassette postali, il Gruppo di archiviazione da cui si desidera spostare le cassette postali, la struttura Archivio cassette postali contenente le cassette postali che si desidera spostare. Fare clic su Cassette postali.

  2. Nel riquadro dei dettagli, fare clic con il pulsante destro del mouse sull'utente o sugli utenti proprietari delle cassette postali che si desidera spostare e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange, fare clic su Sposta, quindi su Cassetta postale e scegliere Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.
Per spostare le cassette postali in Exchange Server 2007 utilizzando Exchange Management Console

  1. Avviare la Exchange Management Console.

  2. Nella struttura della console, espandere Configurazione destinatario e fare clic su Cassetta postale.

  3. Nel riquadro dei risultati, scegliere la cassetta postale o le cassette postali che si desidera spostare.

  4. Nel riquadro delle azioni, fare clic su Sposta cassetta postale.

  5. Nella pagina Introduzione della procedura guidata Sposta cassetta postale, selezionare il server, il gruppo di archiviazione e il database delle cassette postali dove si desidera spostare la cassetta postale, quindi fare clic su Avanti.

  6. Nella pagina Opzioni di spostamento, selezionare un'opzione per la gestione dei messaggi danneggiati in una cassetta postale e fare clic su Avanti.

  7. Nella pagina Pianificazione spostamento, specificare quando effettuare lo spostamento e fare clic su Avanti.

  8. Nella pagina Sposta cassetta postale, esaminare il riepilogo per confermare gli spostamenti delle cassette postali e fare clic su Sposta.

  9. Nella pagina Completamento, fare clic su Fine.

Per ulteriori informazioni sugli scenari supportati per l'utilizzo della procedura guidata di spostamento delle cassette postali e sul cmdlet Move-Mailbox, vedere "Spostare le cassette postali" nella documentazione del prodotto Exchange Server 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=85754.

Secondo metodo Ripristinare il database o i database da una copia di backup valida. Per ulteriori informazioni sul ripristino dei database di Exchange Server, consultare i seguenti articoli:

  • "Ripristino di emergenza" di Exchange Server 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=85802

  • "Guida al ripristino di emergenza di Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=30250

Terzo metodo Utilizzare Eseutil per eseguire un recupero a freddo del database o dei database interessati. Eseguire questo metodo solo nel caso in cui i due precedenti metodi abbiano avuto esito negativo. Dopo aver effettuato la riparazione estrema, eseguire anche una deframmentazione non in linea del database riparato ed eseguire lo strumento Isinteg per riparare il danneggiamento logico. Tali operazioni possono essere eseguite utilizzando l'attività di ripristino dello strumento Exchange Database Troubleshooter. Le procedure di ripristino Eseutil /P, Eseutil /D e Isinteg saranno eseguite in modo automatico.

Per ulteriori informazioni

Per ulteriori informazioni su questo problema, consultare i seguenti articoli della Microsoft Knowledge Base e le risorse di Exchange:

  • 314917, "Interpretazione e analisi degli errori -1018, -1019 e -1022 del database di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=314917.

  • 867626, "Il nuovo codice di correzione errore è incluso in Exchange Server 2003 SP1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=867626

  • 259851, "Considerazioni relative all'esecuzione del comando eseutil /p o edbutil /d /r in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=259851

  • "Exchange Server Error -1018" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=85807 (informazioni in lingua inglese).


MSExchangeIS 1003: Spazio libero residuo insufficiente sull'unità del database di Exchange
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-22

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 1003 nel Registro applicazione. Questo errore può verificarsi se lo spazio disponibile nell'unità che contiene i database da installare è insufficiente.

Spiegazione

Quando non vi è più spazio disponibile sul disco contenente i database di Exchange, il servizio Archivio informazioni di Microsoft Exchange registra un evento MSExchangeIS 1003 e i database interessati vengono disinstallati. Se ciò si verifica, può non essere possibile installare i database per il gruppo di archiviazione interessato. Questo errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere questo problema, liberare spazio sul disco dell'unità del database e riprovare a installare i database. A tale scopo, eseguire uno o più passaggi tra i seguenti:

  • Se i file di database di Exchange sono gli unici presenti sul disco rigido, per liberare spazio su disco può essere necessario eseguire una deframmentazione non in linea dei database.

    Nota:
    A seconda della quantità di spazio libero disponibile nel database, questa procedura potrebbe non risolvere il problema.
    Per ulteriori informazioni sull'esecuzione di questa procedura, consultare l'articolo 328804 della Microsoft Knowledge Base Deframmentazione dei database di Exchange.

    In aggiunta, vedere Esecuzione di Eseutil /D (Deframmentazione).

  • Se anche i file di registro delle transazioni di Exchange si trovano su questa unità, può essere possibile liberare spazio su disco rimuovendo i file di registro superflui.

    Per ulteriori informazioni sull'esecuzione di questa procedura, consultare l'articolo 240145 della Microsoft Knowledge Base Come eliminare i file di registro delle transazioni di Exchange Server.


MSExchangeIS 1088: Impossibile installare il database a causa di legacyExchangeDN non validi
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato un evento MSExchangeIS 1088. Tale evento indica che non è stato possibile installare un database di Exchange poiché è caratterizzato da un valore di attributo legacyExchangeDN diverso da quello archiviato in Active Directory.

Spiegazione

Un evento MSExchangeIS 1088 può verificarsi se si ripristina un database di Exchange in un gruppo amministrativo con un valore diverso per l'attributo legacyExchangeDN rispetto al relativo gruppo amministrativo originale. Non si tratta di un problema. Per installare archivi su un server Exchange, il valore dell'attributo legacyExchangeDN dell'Organizzazione e il Gruppo amministrativo dei database di Exchange deve corrispondere al valore dell'attributo legacyExchangeDN dell'Organizzazione e del Gruppo amministrativo in Active Directory.

Operazione dell'utente

Per risolvere il problema, procedere come segue:

  • Ripristinare il database di Exchange nel Gruppo amministrativo originale.

  • Se non è possibile ripristinare il database di Exchange nel relativo Gruppo amministrativo originale, rinominare gli oggetti di Active Directory della destinazione desiderata in modo che abbiano lo stesso valore per l'attributo legacyExchangeDN del database di Exchange. È possibile correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione:
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto gruppo amministrativo in Active Directory.

    L'attributo legacyExchangeDN è reperibile in:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. Immettere un nuovo valore di stringa del formato:

    /o= organization /ou= administrative group

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida di Windows Server 2003.

Per ulteriori informazioni sull'evento MSExchangeIS 1088, consultare le seguenti risorse:

  • Events and Errors Message Center

  • Articolo 280652 della Microsoft Knowledge Base "XADM: Viene registrato l'ID evento 1088 e non è possibile installare l'archivio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=280652.


MSExchangeIS 5000 (0x3f5): Account di servizio non valido configurato per il servizio Archivio informazioni
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-02-27

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 5000 con codice di errore 0x3f5 nel Registro applicazione. Questo errore si verifica quando il servizio Archivio informazioni di Microsoft Exchange è configurato per essere avviato con un account diverso da quello del sistema locale.

Spiegazione

Questo problema può verificarsi se il servizio Archivio informazioni di Microsoft Exchange (Store.exe) utilizza un account diverso da quello del sistema locale oppure se i criteri di protezione del controller di dominio, del dominio o del computer locale non includono l'account del servizio locale nei criteri di generazione dei controlli di protezione. Quando si verifica questo problema, non è possibile inizializzare il servizio Archivio informazioni di Microsoft Exchange. L'errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti:

  • Per impostazione predefinita, il servizio Archivio informazioni di Microsoft Exchange utilizza l'Account di sistema locale per avviare il servizio Archivio informazioni (NOMECOMPUTER$). Per verificare quale account viene utilizzato per l'avvio del servizio Archivio informazioni, utilizzare lo snap-in Services.msc. Se l'account è quello del sistema locale, è necessario concedere a tale account il diritto Generazione controlli di protezione. A tale scopo, utilizzare uno dei seguenti metodi:

    • Eseguire nuovamente il comando /domainprep di installazione di Exchange da questo computer.

    • Concedere manualmente all'account di sistema locale il diritto di Generazione controlli di protezione su uno dei seguenti criteri:

    1. Criteri del controller di dominio

    2. Criteri del dominio

    3. Criteri di protezione del computer locale

      Per concedere nuovamente questo diritto al criterio di protezione del computer locale di un server membro, procedere come segue.

      Nota:
      È consigliabile implementare questa soluzione se il problema si verifica su un solo server.
      Per concedere nuovamente il diritto di controllo al criterio di protezione del computer locale di un server membro

      1. Fare clic su Start, quindi su Strumenti di amministrazione e infine su Criteri di protezione locali.

      2. Espandere Impostazioni di protezione, fare clic su Criteri locali, quindi su Assegnazione diritti utente.

      3. Nel riquadro destro, fare doppio clic su Generazione di controlli di protezione, scegliere Aggiungi, immettere il NOMECOMPUTER$, quindi fare due volte clic su OK.

      4. Chiudere lo snap-in Criteri di gruppo.
  • Se viene avviato il servizio Archivio informazioni utilizzando un account diverso da sistema locale, modificarlo in account di sistema locale (NOMECOMPUTER$). Quindi, provare ad avviare il servizio Archivio informazioni. Per ulteriori informazioni sull'utilizzo dell'account di sistema locale in Exchange 2000 Server ed Exchange Server 2003 per avviare i servizi di Exchange, vedere l'articolo 239762 della Microsoft Knowledge Base, Esecuzione dei servizi di Exchange in LocalSystem.

Per ulteriori informazioni

Per ulteriori informazioni, vedere l'articolo 281850 della Microsoft Knowledge Base, L'archivio informazioni non viene avviato con messaggi ID evento 9530 e 5000 in Exchange 2000 Server e in Exchange Server 2003.


MSExchangeIS 5000 (0x80004005): Impossibile installare il database a causa di un account di servizio errato, di autorizzazioni SeSecurityPrivilege mancanti o di appartenenza ai gruppi errata
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-02-19

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 5000 con codice di errore 0x80004005 nel registro applicazioni. L'evento indica che non è possibile installare uno o più database sul server di Exchange a causa di un account di servizio errato, di autorizzazioni SeSecurityPrivilege mancanti o di appartenenza ai gruppi errata.

Spiegazione

L'evento può verificarsi quando è vera una delle seguenti condizioni.

  • L'autorizzazione Gestione file del registro di controllo e di protezione (SeSecurityPrivilege) è stata rimossa dal gruppo Exchange Enterprise Servers su uno o più controller di dominio. Il gruppo Exchange Enterprise Servers deve disporre dell'autorizzazione Gestione file del registro di controllo e di protezione su tutti i controller di dominio. Quando questa condizione è vera, non sarà possibile avviare uno o più servizi correlati a Exchange Server.

  • Il servizio Archivio informazioni di Microsoft Exchange viene avviato con un account diverso da quello del sistema locale oppure i criteri di protezione del controller di dominio, del dominio o del computer locale non includono l'account del servizio locale nei criteri di generazione dei controlli di protezione. Quando questa condizione è vera, il servizio Archivio informazioni di Exchange non viene avviato.

  • Il gruppo Exchange Enterprise Servers del dominio padre non contiene il gruppo Exchange Domain Servers del dominio figlio.

L'evento può essere identificato anche come MAPI_E_CALL_FAILED e può verificarsi nelle seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti:

  • Se l'autorizzazione Gestione file del registro di controllo e di protezione (SeSecurityPrivilege) è stata rimossa dal gruppo Exchange Enterprise Servers su uno o più controller di dominio, procedere come segue:

    Per aggiungere autorizzazioni a uno o più controller di dominio

    1. Utilizzare Policytest.exe per risolvere i problemi relativi alle autorizzazioni. Policytest.exe si trova nella cartella Support\Utils\I386 sul CD di Exchange 2000 Server oppure nella cartella Support\ExDeploy sul CD di Exchange Server 2003. Utilizzare Policytest.exe per determinare se un controller di dominio non dispone dell'autorizzazione "Gestione file registro di controllo e di protezione" per il gruppo Exchange Enterprise Servers. Se il risultato è corretto, saranno visualizzate informazioni simili a quelle riportate di seguito.

      Local domain is "<contoso.com>" (contoso) Account is "CONTOSO\Exchange Enterprise Servers" DC = "<ComputerName>" In site = "<Default-First-Site-Name>" Right found: "SeSecurityPrivilege"

      Nota Se il risultato è corretto, l'autorizzazione "Gestione file registro di controllo e di protezione" è esistente. Per eseguire Policytest.exe è necessario disporre dei diritti di amministratore di dominio. Per ulteriori informazioni sull'utilità Policytest.exe, vedere l'articolo 281537 della Microsoft Knowledge Base XADM: Description of the Policytest.exe Utility.

    2. Reimpostare le autorizzazioni predefinite di Exchange Enterprise Server a livello di dominio. Per eseguire l'operazione, procedere come segue:

      1. Eseguire il comando setup /domainprep dal CD di Exchange Server o da un punto di installazione in rete. Il comando setup /domainprep consente di aggiungere il gruppo Exchange Enterprise Servers al dominio con le autorizzazioni predefinite. Quando si esegue il comando setup /domainprep, le autorizzazioni vengono immediatamente aggiunte a un controller di dominio. Quindi, la modifica viene replicata negli altri controller di dominio.

      2. Ripristinare l'ereditarietà delle autorizzazioni alle altre unità organizzative. Quindi, attendere la replica delle modifiche in tutto il dominio da parte dei controller di dominio.

      3. Eseguire Policytest.exe. Annotare quali controller di dominio restituiscono il seguente risultato corretto:

        Right found: "SeSecurityPrivilege"

        Se tutti i controller di dominio dispongono delle autorizzazioni corrette, riavviare i servizi di Exchange Server. Se nessun controller di dominio dispone delle autorizzazioni corrette, passare al punto 3.

    3. Verificare il criterio dei controller di dominio predefiniti. Per eseguire l'operazione, procedere come segue:

      1. Avviare lo snap-in Utenti e computer di Active Directory.

      2. Fare clic con il pulsante destro del mouse sul contenitore Controller di dominio, quindi scegliere Proprietà.

      3. Fare clic sulla scheda Criteri di gruppo e verificare che Criteri predefiniti controller di dominio sia elencato nella casella Collegamenti Oggetti criteri di gruppo.Nota Se Criteri predefiniti controller di dominio non è in elenco, fare clic su Aggiungi, quindi su Criteri predefiniti controller di dominio, infine su OK. Quindi, attendere che la modifica venga replicata in tutti gli altri controller di dominio.

      4. Eseguire il comando setup /domainprep dal CD di Exchange Server o da un punto di installazione in rete. Il comando setup /domainprep consente di aggiungere il gruppo Exchange Enterprise Servers al dominio con le autorizzazioni predefinite.

      5. Eseguire Policytest.exe. Annotare quali controller di dominio restituiscono il seguente risultato corretto:

      Right found: "SeSecurityPrivilege"

      Se tutti i controller di dominio dispongono delle autorizzazioni corrette, riavviare i servizi di Exchange Server. Se alcuni controller di dominio non dispongono delle autorizzazioni corrette, passare al punto 4.

    4. Aggiungere manualmente le autorizzazioni al controller di dominio. Il servizio Replica file (FRS) potrebbe non replicare il criterio di protezione aggiornato in uno o più controller di dominio dopo che è stato eseguito il comando setup /domainprep. Se tale problema si verifica, occorre assegnare manualmente le autorizzazioni corrette al gruppo Exchange Enterprise Servers. Se alcuni o tutti i controller di dominio non dispongono delle autorizzazioni corrette, assegnare l'autorizzazione "Gestione file registro di controllo e di protezione" al gruppo Exchange Enterprise Servers. Quindi, attendere che l'impostazione venga replicata negli altri controller di dominio. Per eseguire l'operazione, procedere come segue:

      1. Avviare lo snap-in Utenti e computer di Active Directory.

      2. Fare clic con il pulsante destro del mouse sul contenitore Controller di dominio, quindi scegliere Proprietà.

      3. Fare clic sulla scheda Criteri di gruppo, quindi su Criteri predefiniti controller di dominio nella casella Collegamenti Oggetti criteri di gruppo, infine scegliere Modifica.

      4. Espandere Configurazione computer, Impostazioni Windows, Impostazioni protezione e Criteri locali, quindi fare clic su Assegnazione diritti utente.

      5. Nel riquadro destro, fare doppio clic su Gestione file registro di controllo e di protezione, fare clic su Aggiungi, Sfoglia, quindi aggiungere il gruppo di Exchange Enterprise Servers.

      6. Nella finestra di dialogo Aggiungi utente o gruppo fare clic su OK. Quindi, fare di nuovo clic su OK.

      7. Uscire dallo snap-in Criteri di gruppo e fare clic su OK nella finestra di dialogo Proprietà dei Controller di dominio.Nota talvolta, il gruppo Exchange Enterprise Servers potrebbe non essere visibile facendo clic su Sfoglia nella finestra di dialogo Aggiungi utente o gruppo. In tal caso, aggiungere il gruppo Exchange Domain Servers ed eseguire nuovamente il comando setup /domainprep. Questo processo rende permanente l'aggiunta del gruppo Exchange Enterprise Servers in tutti i controller di dominio.
  • Il servizio Archivio informazioni di Exchange viene avviato con un account diverso da quello del sistema locale oppure i criteri di protezione del controller di dominio, del dominio o del computer locale non includono l'account del servizio locale nei criteri di generazione dei controlli di protezione.

    Per impostazione predefinita, il servizio Archivio informazioni di Microsoft Exchange utilizza l'Account di sistema locale per avviare il servizio Archivio informazioni (NOMECOMPUTER$). Per verificare quale account viene utilizzato per l'avvio del servizio Archivio informazioni, utilizzare lo snap-in Services.msc. Se l'account è quello del sistema locale, è necessario concedere nuovamente a tale account il diritto Generazione controlli di protezione. A tale scopo, utilizzare uno dei seguenti metodi:

    Per concedere nuovamente il diritto Generazione controlli di protezione all'account del sistema locale

    1. Eseguire nuovamente il comando setup /domainprep di Exchange da questo computer.

    2. Concedere manualmente all'account di sistema locale il diritto di Generazione controlli di protezione su uno dei seguenti criteri:

      • Criteri del controller di dominio

      • Criteri del dominio

      • Criteri di protezione del computer locale

    Per concedere nuovamente il diritto di Generazione controlli di protezione al criterio di protezione del computer locale di un server membro

    1. Fare clic su Start, quindi su Strumenti di amministrazione e infine su Criteri di protezione locali.

    2. Espandere Impostazioni di protezione, fare clic su Criteri locali, quindi su Assegnazione diritti utente.

    3. Nel riquadro destro, fare doppio clic su Generazione di controlli di protezione, scegliere Aggiungi, immettere il NOMECOMPUTER$, quindi fare due volte clic su OK.

    4. Chiudere lo snap-in Criteri di gruppo.
    Se viene avviato il servizio Archivio informazioni utilizzando un account diverso da sistema locale, modificarlo in account di sistema locale (NOMECOMPUTER$). Quindi, provare ad avviare il servizio Archivio informazioni. Per ulteriori informazioni sull'utilizzo dell'account di sistema locale in Exchange 2000 Server ed Exchange Server 2003 per avviare i servizi di Exchange, vedere l'articolo 239762 della Microsoft Knowledge Base, Exchange Services Run Under LocalSystem.

  • Se il gruppo Exchange Enterprise Servers del dominio padre non contiene il gruppo Exchange Domain Servers del dominio figlio, aggiungere il gruppo Exchange Domain Servers del dominio figlio al gruppo Exchange Enterprise Servers del dominio padre. È inoltre possibile risolvere questo problema creando il Servizio aggiornamento destinatari nel dominio radice.

    Per risolvere il problema, eseguire il programma di installazione di Exchange con l'opzione /domainprep su un server nel dominio di Windows remoto. Quindi, sul server di Exchange, utilizzare il Gestore di sistema di Exchange per creare un Servizio aggiornamento destinatari per il dominio remoto. Per eseguire l'operazione, procedere come segue:

    Per creare un Servizio aggiornamento destinatari per il dominio remoto

    1. Fare clic su Start, scegliere Programmi, Microsoft Exchange, quindi fare clic su Gestore di sistema.

    2. Espandere l'oggetto Organizzazione, quindi espandere il contenitore Destinatari.

    3. Fare clic su Servizio aggiornamento destinatari.

    4. Nel riquadro destro fare clic con il pulsante destro del mouse su Nuovo, quindi su Servizio aggiornamento destinatari.

    5. Fare clic sul dominio che non dispone di un'istanza del Servizio aggiornamento destinatari e i cui utenti devono essere aggiornati con Exchange.

    6. Fare clic su Avanti.

    7. Selezionare il server su cui si desidera eseguire il Servizio aggiornamento destinatari ed elaborare tutti gli utenti necessari con gli attributi di Exchange.

    8. Fare clic su Avanti.

    9. Fare clic su Fine.

    10. Per avviare manualmente un aggiornamento dei destinatari in tale dominio, fare clic con il pulsante destro del mouse su Servizio aggiornamento destinatari, quindi fare clic su Aggiorna per forzare un aggiornamento.
    Per ulteriori informazioni, vedere l'articolo 253770 della Microsoft Knowledge Base, Tasks performed by the Exchange Recipient Update Service.


MSExchangeIS 5000 (0x80040154): Estensioni del servizio SMTP mancanti o danneggiate
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-02-19

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 5000 con codice di errore 0x80040154 nel registro applicazioni. Questo errore può verificarsi se le estensioni del servizio SMTP (Simple Mail Transfer Protocol) del server Exchange sono mancanti o danneggiate.

Spiegazione

Questo errore si verifica poiché le estensioni del servizio SMTP del server Exchange sono mancanti o danneggiate. Questo comportamento provoca la perdita di funzionalità tra Exchange e il servizio SMTP. Il servizio SMTP è un servizio necessario che viene installato come sottocomponente di Microsoft Internet Information Services (IIS).

Le cause di questo errore possono essere:

  • Il servizio IIS è stato rimosso.

  • Il sottocomponente servizio SMTP è stato rimosso da IIS.

  • Il servizio IIS è stato rimosso, quindi reinstallato come componente di Windows, ma privo del sottocomponente servizio SMTP necessario.

  • Il servizio IIS è stato rimosso, quindi reinstallato come componente di Windows con l'elenco appropriato di sottocomponenti. Tuttavia, le estensioni del servizio SMTP di Exchange non sono state reinstallate.

Questo errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere questo errore, vedere l'articolo 326305 della Microsoft Knowledge Base The Information Store does not start and MSExchangeIS Event ID 5000 and 9538 messages occur in Exchange 2000 Server and Exchange Server 2003.

Per ripristinare le estensioni del servizio SMTP

  1. Confermare l'assenza delle estensioni del servizio SMTP di Exchange. Per eseguire l'operazione, procedere come segue:

    1. Accedere al computer che esegue Microsoft Exchange con un account che disponga delle credenziali di amministrazione.

    2. Fare clic su Start, Esegui, digitare cmd, quindi fare clic su OK.

    3. Al prompt dei comandi, digitare telnet 127.0.0.1 25 per visualizzare la voce "220 server.domain.com Microsoft ESMTP Mail Service".

    4. Digitare EHLO, quindi premere Invio per visualizzare un elenco di 250 comandi. Se non vi sono comandi il cui nome inizi per "X," le estensioni del servizio SMTP sono mancanti.

  2. Eseguire il backup completo della partizione del sistema. Includere lo stato del sistema e i file del database di Exchange. Per ulteriori informazioni su questa procedura, vedere l'articolo 258243 della Microsoft Knowledge Base How to back up and restore an Exchange computer by using the Windows Backup program.

  3. Verificare che il servizio IIS sia stato correttamente reinstallato in modo da includere nuovamente i sottocomponenti richiesti che dipendono da Exchange.

    IIS 6.0

    1. Fare clic su Start, Impostazioni, Pannello di controllo.

    2. Fare doppio clic su Installazione applicazioni.

    3. Nel riquadro sinistro fare clic su Installazione componenti di Windows.

    4. Nella procedura guidata Componenti di Windows, individuare Server applicazioni nell'elenco dei componenti, quindi scegliere Dettagli.

    5. Installare i seguenti componenti qualora non fossero presenti:

      ASP.NET

      Abilitare l'accesso COM+ alla rete

      Internet Information Services (IIS)

    6. Fare clic su Internet Information Services (IIS), quindi scegliere Dettagli

    7. Installare i seguenti componenti qualora non fossero presenti:

      File comuni

      Gestione Internet Information Services

      Servizio NNTP

      Servizio SMTP

      Servizio Web

    8. Fare clic su OK due volte. Nella finestra principale Componenti di Windows, fare clic su Avanti, quindi su Fine.

    IIS 5.0

    1. Fare clic su Start, Impostazioni, Pannello di controllo.

    2. Fare doppio clic su Installazione applicazioni.

    3. Nel riquadro sinistro fare clic su Installazione componenti di Windows.

    4. Nella finestra di dialogo Aggiunta guidata componenti di Windows, individuare Internet Information Services (IIS) nell'elenco dei componenti. Se la casella di controllo Internet Information Services (IIS) è selezionata, il servizio IIS è installato. Per verificare l'installazione dei sottocomponenti di IIS, fare clic su Internet Information Services (IIS), quindi scegliere Dettagli.

    5. Se IIS non è installato, selezionare la casella di controllo Internet Information Services (IIS), quindi scegliere Dettagli. Installare i sottocomponenti di IIS 5.0 e fare clic su OK. Di seguito sono elencati i sottocomponenti di IIS 5.0 minimi richiesti per poter installare Exchange 2000.

      File comuni

      Snap-in di Internet Information Services

      Servizio SMTP

      Servizio NNTP (Network News Transfer Protocol, per i newsgroup)

      Servizio Web

    6. Fare clic su Avanti, quindi su Fine.

  4. Ripristinare le estensioni del servizio SMTP di Exchange.

    Exchange Server 2003

    Se si reinstalla Exchange 2003 su un'installazione esistente di Exchange 2003, i file del database e le autorizzazioni rimangono intatti. Per eseguire l'operazione, procedere come segue:

    1. Inserire il CD di Exchange 2003.

    2. Nella cartella \SETUP\I386, fare doppio clic sul file Setup.exe.

    3. Nella pagina iniziale, fare clic su Avanti fino a raggiungere la pagina Selezione componenti.

    4. Nella pagina Selezione componenti, fare clic su Reinstalla nella colonna Azione, quindi fare clic su Avanti.

    5. Verificare le selezioni effettuate nella pagina di riepilogo, quindi fare clic su Avanti per continuare con l'installazione di Exchange 2003.

    Exchange 2000 Server

    I metodi utilizzabili per ripristinare le estensioni del servizio SMTP di Exchange 2000 dipendono dalla quantità di sottocomponenti IIS rimossi. Se il servizio SMTP è l'unico sottocomponente di IIS rimosso ed è stato installato Exchange 2000 Server Service Pack 2 (SP2) o versione successiva, eseguire l'utilità della riga di comando Smtpreinstall.exe. L'utilità della riga di comando Smtpreinstall.exe si trova nella cartella Server\Support\Utils\I386.

    Per eseguire l'utilità Smtpreinstall.exe

    1. Copiare il file Smtpreinstall.exe nella cartella Exchsrvr\Bin.

    2. Al prompt dei comandi, passare alla cartella Exchsrvr\Bin, quindi digitare il seguente comando:

      smtpreinstall.exe

    3. Riavviare il computer quando richiesto.

    Se IIS 5.0 è stato rimosso come componente oppure se sono stati rimossi da IIS 5.0 altri sottocomponenti oltre al servizio SMTP, reinstallare Exchange 2000 sull'installazione esistente come parte dell'installazione integrata di Microsoft Small Business Server 2000.

    Per reinstallare Exchange 2000 Server

    Nota:
    Se si reinstalla Exchange 2000 su un'installazione esistente di Exchange 2000, i file del database e le autorizzazioni rimangono intatti.
    1. Inserire il CD di Exchange 2000 Server.

    2. Nella cartella \SETUP\I386, fare doppio clic sul file Setup.exe.

    3. Nella pagina iniziale fare clic su Avanti.

    4. Se richiesto, immettere il proprio codice "CD Key", quindi fare clic sul Avanti.

    5. Nella pagina dei selezione dei componenti, fare clic su Reinstalla nella colonna Azione, quindi fare clic su Avanti.

    6. Verificare le selezioni effettuate nella pagina di riepilogo, quindi fare clic su Avanti per continuare con l'installazione di Exchange 2000.

  5. Reinstallare i service pack e gli aggiornamenti rapidi di Exchange.

    Per ulteriori informazioni, vedere i seguenti articoli della Microsoft Knowledge Base:

    836993 How to obtain the latest service packs for Exchange Server 2003.

    301378 How to obtain the latest Exchange 2000 Server service pack.


MSExchangeIS 5000 (0xc004038a): Impossibile installare il database a causa di autorizzazioni errate o dell'eliminazione del gruppo di routing
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-05-31

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 5000 con codice di errore 0xc004038a nel registro applicazioni. Quando si verifica questo errore, il servizio Archivio informazioni di Microsoft Exchange non viene inizializzato e i database non verranno installati.

Spiegazione

L'evento MSExchangeIS 5000 con codice di errore 0xc004038a può verificarsi a causa di autorizzazioni non valide o dell'eliminazione di un gruppo di routing. Tale evento potrebbe essere causato da uno o più tra i seguenti motivi:

  • Il server Exchange non è più membro di un gruppo di routing, oppure il relativo gruppo di routing è stato eliminato da Active Directory.

  • Il gruppo Exchange Domain Servers non dispone delle autorizzazioni appropriate in Active Directory.

Questo evento riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere l'errore, eseguire uno o più dei seguenti passaggi:

  • Se il gruppo Exchange Domain Servers non dispone delle autorizzazioni appropriate, accertarsi tramite l'utilità Editor ADSI (Active Directory Service Interfaces) che il gruppo Exchange Domain Servers disponga delle autorizzazioni necessarie in Active Directory. Assicurarsi di aver selezionato la casella di controllo Consenti propagazione delle autorizzazioni ereditabili dall'oggetto padre a questo oggetto nella scheda Protezione del gruppo Administrators, del gruppo Exchange Domain Servers e di qualsiasi altro gruppo relativo alla propria configurazione.

    Nota:
    Se necessario, imporre una replica tra i controller di dominio per assicurarsi che le modifiche vengano propagate attraverso l'intero dominio.
    Nota:
    Lo strumento Editor ADSI è incluso negli Strumenti di supporto di Microsoft Windows 2000 e di Microsoft Windows Server 2003, disponibili sul CD di installazione di Windows 2000 e Windows 2003.
  • Se il server Exchange non è più membro di un gruppo di routing, oppure se il relativo gruppo di routing è stato eliminato da Active Directory, aggiungere o ripristinare il gruppo di routing. Scegliere la soluzione più appropriata al proprio problema tra le seguenti:

Soluzione 1: aggiungere il server al gruppo di routing. Procedere come segue per verificare che il server non sia più membro del gruppo di routing.

  1. Avviare il Gestore di sistema di Exchange.

  2. EspandereOrganization, Administrative Groups, NomeGruppoAmministrativo e infine Routing Groups.

    Nota:
    In questo passaggio, NomeGruppoAmministrativo è il nome del gruppo amministrativo.
  3. Sfogliare tutti i gruppi di routing disponibili e verificare che questo server non sia elencato.

    Nota:
    Se nessun gruppo di routing è visibile, vedere la Soluzione 2.
  4. Dopo aver verificato che il server non sia membro di un gruppo di routing, aggiungerlo nuovamente a un gruppo di routing esistente. Per eseguire l'operazione, procedere come segue:

    Importante:
    Se si utilizza lo snap-in ADSI Edit, l'utilità LDAP o un altro client LDAP versione 3 e si modifica in modo errato gli attributi degli oggetti Active Directory, si possono provocare problemi gravi. Tali problemi possono richiedere la reinstallazione di Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 o sia di Windows che di Exchange. Microsoft non garantisce la risoluzione dei problemi che si verificano in caso di modifica errata degli attributi degli oggetti Active Directory. L'utente modifica tali attributi a proprio rischio.
Per aggiungere di nuovo il server al gruppo di routing

  1. Fare clic su Start, Esegui, digitare adsiedit.msc, quindi fare clic su OK.

    Nota:
    Lo strumento ADSI Edit è incluso tra gli strumenti di supporto di Microsoft Windows 2000 e di Microsoft Windows Server 2003. Per installare gli strumenti di supporto, effettuare le operazioni descritte di seguito.
    • Per i computer basati su Windows 2000 Server, fare doppio clic su Setup.exe nella cartella Support\Tools del CD di Windows 2000, quindi seguire la procedura di installazione guidata per completare l'installazione degli Strumenti di supporto di Windows 2000.

    • Per i computer basati su Windows Server 2003, fare clic con il pulsante destro del mouse su Suptools.msi nella cartella Support\Tools del CD di Windows Server 2003, scegliere Install, quindi seguire la procedura di installazione guidata per completare l'installazione degli Strumenti di supporto di Windows Server 2003.

  2. Espandere Configuration [ nomeserver.nome_dominio.com ], CN=Configuration, DC= nome_dominio, DC= com, CN=Services, CN=Microsoft Exchange, CN= NomeOrganizzazione, CN=Administrative Groups, CN= NomeGruppoAmministrativo, infine fare clic su CN=Routing Groups.

    Nota:
    In questo passaggio, nomeserver è il nome del server, nome_dominio.com è il nome del dominio, NomeOrganizzazione è il nome dell'organizzazione di Exchange Server e NomeGruppoAmministrativo è il nome del gruppo amministrativo.

  3. Fare clic con il pulsante destro del mouse sul gruppo di routing di cui il server deve essere membro, quindi scegliere Proprietà.

  4. Fare clic sull'attributodistinguishedName, quindi scegliere Modifica.

  5. Copiare il valore dell'attributo distinguishedName nel Blocco note.

  6. Fare clic su Annulla due volte per chiudere le proprietà.

  7. Nello strumento ADSIEdit, espandere Configuration [ nomeserver.nome_dominio.com ], CN=Configuration,DC= nome_dominio ,DC= com, CN=Services, CN=Microsoft Exchange, CN= NomeOrganizzazione, CN=Administrative Groups, CN= NomeGruppoAmministrativo, quindi espandere CN=Servers.

  8. Fare clic con il pulsante destro del mouse su nomeserver, quindi scegliere Proprietà.

  9. Fare clic sull'attributomsExchHomeRoutingGroup, quindi scegliere Modifica.

  10. Incollare il valore copiato nel Blocco note al punto 5, quindi fare clic su OK due volte per salvare il nuovo valore.

  11. Nel Gestore di sistema di Exchange, individuare il gruppo di routing a cui è stato aggiunto il server.

  12. Aggiornare il Gestore di sistema di Exchange in modo da visualizzare il server.

    Nota:
    Se il server di Exchange non viene immediatamente visualizzato, attendere la replica di Active Directory.

  13. Se per nessun altro server di Exchange in questo gruppo di routing il Tipo di server è impostato su Master, fare clic con il pulsante destro del mouse su questo server di Exchange, quindi scegliere Imposta come master.

  14. Avviare il servizio Archivio informazioni e il servizio Stack Agente di trasferimento messaggi.

Soluzione 2: Ripristinare il gruppo di routing. Se si rimuove un gruppo di routing per errore, è possibile ripristinarlo servendosi del backup dello stato del sistema più recente. Se non si dispone di un backup recente dello stato del sistema e sono presenti più controller di dominio, eseguire un'operazione di ripristino autorevole del gruppo di routing rimosso.

Per ripristinare il gruppo di routing

  1. Avviare il Gestore di sistema di Exchange, quindi creare un nuovo gruppo di routing con lo stesso nome del gruppo di routing rimosso. Per eseguire l'operazione, procedere come segue:

    1. Espandere Administrative Groups, NomeGruppoAmministrativo, quindi Routing Groups.

      In questo passaggio, NomeGruppoAmministrativo è il nome del gruppo amministrativo dell'utente.

    2. Fare clic con il pulsante destro del mouse su Routing Groups, selezionare New, quindi fare clic su Routing Group.

    3. Nella casella Name digitare il nome del gruppo di routing, quindi fare clic su OK.

      Adoperare lo stesso nome utilizzato per il gruppo di routing rimosso per errore.

    4. Uscire dal Gestore di sistema di Exchange.

  2. Avviare ADSI Edit. A tale scopo, fare clic su Start, Esegui, digitare adsiedit.msc nella casella Apri, quindi scegliere OK.

    Nota:
    Lo strumento ADSI Edit è incluso tra gli strumenti di supporto di Microsoft Windows 2000 e di Microsoft Windows Server 2003. Per installare gli strumenti di supporto, effettuare le operazioni descritte di seguito.
    • Per i computer basati su Windows 2000 Server, fare doppio clic su Setup.exe nella cartella Support\Tools del CD di Windows 2000, quindi seguire la procedura di installazione guidata per completare l'installazione degli Strumenti di supporto di Windows 2000.

    • Per i computer basati su Windows Server 2003, fare clic con il pulsante destro del mouse su Suptools.msi nella cartella Support\Tools del CD di Windows Server 2003, scegliere Install, quindi seguire la procedura di installazione guidata per completare l'installazione degli Strumenti di supporto di Windows Server 2003.

  3. Espandere Configuration [nomeserver.nome_dominio.com], CN=Configuration, DC=nome_dominio, DC=com, CN=Services, CN=Microsoft Exchange, CN=NomeOrganizzazione, CN=Administrative Groups, CN=NomeGruppoAmministrativo, infine fare clic su CN=Routing Groups.

    In questo passaggio, nomeserver è il nome del server, nome_dominio.com è il nome del dominio, NomeOrganizzazione è il nome dell'organizzazione di Exchange Server e NomeGruppoAmministrativo è il nome del gruppo amministrativo.

  4. Nel riquadro destro fare clic con il pulsante destro del mouse sul nuovo gruppo di routing appena creato, quindi scegliere Proprietà.

  5. Se non sono già selezionate, selezionare le caselle di controllo Visualizza attributi obbligatori e Visualizza attributi facoltativi.

  6. Nell'elenco Attributi, fare clic su msExchRoutingGroupMembersBL, quindi scegliere Modifica.

    L'elenco Valori è vuoto.

  7. Fare clic su Annulla.

  8. Nell'elenco Attributi fare doppio clic su distinguishedName.

  9. Fare clic con il pulsante destro del mouse sul nome distinto nella casella Valore, quindi scegliere Copia.

  10. Avviare un editor di testo, ad esempio Blocco note, quindi fare clic su Incolla nel menu Modifica per incollare il nome distinto.

  11. Nella finestra di dialogo Editor attributo stringa, fare clic su Annulla, quindi di nuovo su Annulla per chiudere la finestra di dialogo CN=NomeGruppoRouting.

    In questo passaggio, NomeGruppoRouting è il nome del gruppo di routing dell'utente.

  12. In ADSI Edit, sotto CN=NomeGruppoAmministrativo, scegliere CN=Servers.

  13. Nel riquadro destro fare clic con il pulsante destro del mouse su CN=NomeServer, quindi scegliere Proprietà.

    In questo passaggio, NomeServer indica uno dei computer di Exchange in questo gruppo di routing.

  14. Nell'elenco Attributi, fare clic su msExchHomeRoutingGroup, quindi scegliere Modifica.

  15. Nella casella Valore, incollare il nome distinto copiato ai punti 9 e 10, quindi fare clic su OK.

  16. Fare clic su Applica, quindi su OK.

  17. Ripetere i passaggi da 13 a 15 per ciascun server membro del gruppo di routing rimosso per errore.

  18. Sotto CN=NomeGruppoAmministrativo, fare clic su CN=Routing Groups.

  19. Nel riquadro destro fare clic con il pulsante destro del mouse sul nuovo gruppo di routing appena creato, quindi scegliere Proprietà.

  20. Nell'elenco Attributi, fare clic su msExchRoutingGroupMembersBL, quindi scegliere Modifica.

    L'elenco Valori non è più vuoto.

  21. Fare clic su Annulla due volte.

  22. Uscire da ADSI Edit.

  23. Impostare il master del gruppo di routing mediante il Gestore di sistema di Exchange. Per eseguire l'operazione, procedere come segue:

    1. Avviare il Gestore di sistema di Exchange.

    2. Espandere Administrative Groups, NomeGruppoAmministrativo, quindi Routing Groups.

    3. Espandere il nuovo gruppo di routing creato, quindi fare clic su Membri.

    4. Nel riquadro destro fare clic con il pulsante destro del mouse sul computer Exchange da configurare come master del gruppo di routing, quindi scegliere Imposta come master.

    5. Uscire dal Gestore di sistema di Exchange.

  24. Attendere la propagazione delle modifiche in tutto il dominio.

  25. Avviare i servizi di Microsoft Exchange che erano stati interrotti.


MSExchangeIS 5000 (0x8004010f): Impossibile installare il database a causa di autorizzazioni di accesso errate o di caratteri non validi nel nome organizzazione
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 5000 con codice di errore 0x8004010f nel Registro applicazione. Tale evento indica che uno o più database nel server di Exchange non possono essere installati a causa di autorizzazioni di accesso errate o di caratteri non validi nel nome organizzazione di Exchange.

Spiegazione

L'evento MSExchangeIS 5000 con codice di errore 0x8004010f può verificarsi in presenza di una delle seguenti condizioni:

  • Gli utenti autenticati non dispongono dell'accesso in lettura nei contenitori di dominio o di configurazione di Active Directory. Quando questa condizione è vera, potrebbe risultare impossibile installare un secondo server di Exchange in un gruppo amministrativo che ne contiene già uno. Inoltre, il servizio Archivio informazioni di Microsoft Exchange potrebbe non avviarsi.

  • L'account Everyone non dispone dell'autorizzazione di accesso in lettura nel contenitore delle entità di protezione conosciute al di sotto del contenitore Configurazione di Active Directory. Quando questa condizione è vera, non è possibile avviare il servizio Archivio informazioni di Exchange su un server membro.

  • Il nome organizzazione di Exchange contiene caratteri non supportati. Quando questa condizione è vera, dopo l'installazione di Exchange 2000 Server o Exchange Server 2003, il servizio Archivio informazioni di Exchange potrebbe non avviarsi e nel Registro applicazione potrebbero essere registrati eventi MSExchangeIS 5000 e MSExchangeIS 1121.

L'evento può essere identificato anche come MAPI_E_NOT_FOUND e può verificarsi nelle seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti.

Importante:
Se si utilizza lo snap-in Active Directory Service Interfaces (ADSI) Edit, l'utilità LDP o un altro client LDAP versione 3, e si modificano in modo errato gli attributi degli oggetti di Active Directory, si possono provocare problemi gravi. Tali problemi possono richiedere la reinstallazione di Microsoft Windows® 2000 Server, Microsoft Windows Server™ 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003 o sia di Windows che di Exchange. Microsoft non garantisce la risoluzione dei problemi che si verificano in caso di modifica errata degli attributi degli oggetti Active Directory. L'utente modifica tali attributi a proprio rischio.
  • Qualora utenti autenticati non disponessero dell'autorizzazione in lettura nei contenitori di dominio o di configurazione di Active Directory, tale autorizzazione può essere accordata mediante lo strumento ADSI Edit di Exchange Server 2003 ed Exchange 2000 Server. Eseguire le operazioni indicate di seguito.

    Nota:
    Lo strumento ADSI Edit si trova tra gli strumenti di supporto di Microsoft Windows 2000 e di Microsoft Windows Server 2003. Per installare gli strumenti di supporto di Windows, eseguire il programma di installazione dalla cartella Support\Tools del CD di Windows. Per ulteriori informazioni sugli strumenti di supporto di Windows, vedere il file Sreadme.doc nella cartella Support\Tools del CD di Windows.
Per concedere a utenti autenticati l'accesso in lettura ai contenitori di dominio o di configurazione in Active Directory

  1. Fare clic su Start, Esegui, digitare adsiedit.msc, quindi fare clic su OK.

  2. Espandere il contenitore Domain NC e fare clic con il pulsante destro del mouse sulla cartella corrispondente al dominio (DC=dominio,DC=com), quindi scegliere Proprietà per visualizzare le proprietà della cartella.

  3. Fare clic sulla scheda Protezione, quindi accertarsi che nella colonna Consenti sia selezionata la casella dell'autorizzazione in Lettura corrispondente agli Utenti autenticati. Se la casella dell'autorizzazione in Lettura non è selezionata, selezionarla e scegliere OK.

  4. Espandere il Contenitore di configurazione e fare clic con il pulsante destro del mouse sulla cartella corrispondente (CN=Configurazione,DC=dominio,DC=com), quindi scegliere Proprietà per visualizzare le proprietà della cartella.

  5. Fare clic sulla scheda Protezione, quindi accertarsi che nella colonna Consenti sia selezionata la casella dell'autorizzazione in Lettura corrispondente agli Utenti autenticati. Se la casella dell'autorizzazione in Lettura non è selezionata, selezionarla e scegliere OK.

  6. Uscire da ADSI Edit.

  7. Attendere che la modifica venga replicata nei controller di dominio.

  8. Avviare il servizio Archivio informazioni.
  • Se l'account Everyone non dispone dell'autorizzazione di accesso in lettura al contenitore delle entità di protezione conosciute al di sotto del contenitore Configurazione di Active Directory, procedere come segue per risolvere il problema:

Per accordare l'autorizzazione di accesso in lettura per l'account Everyone al contenitore delle entità di protezione conosciute in Active Directory

  1. Effettuare l'accesso come amministratore di dominio, quindi avviare ADSI Edit.

  2. Espandere il contenitore Configurazione e fare clic sul contenitore CN=WellKnown Security Principals.

  3. Fare clic con il pulsante destro del mouse su Proprietà, quindi individuare la scheda Protezione.

  4. Fare clic su Aggiungi, digitare everyone, quindi scegliere OK.

  5. Nella colonna Consenti selezionare la casella di controllo Lettura.
  • Rimuovere eventuali caratteri non validi dal nome organizzazione di Exchange. Per ulteriori informazioni sui caratteri non validi, vedere l'articolo 329599 della Microsoft Knowledge Base, Exchange Information Store Does Not Start and Events 1121 and 5000 Are Logged.


MSExchangeIS 9518 (0xfffffddc): È stato superato il numero massimo di file del registro delle transazioni disponibile per il gruppo di archiviazione
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-22

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con il codice di errore 0xfffffddc nel Registro applicazione. Ciò indica che è stato superato il numero massimo di registri delle transazioni disponibile per il gruppo di archiviazione.

Spiegazione

Un evento MSExchangeIS 9518 con codice di errore 0xfffffddc viene registrato quando si tenta di installare i database di un gruppo di archiviazione e si verificano entrambe le seguenti condizioni:

  • È stato superato il numero massimo di registri delle transazioni disponibile per il gruppo di archiviazione.

  • Tutti i database nel gruppo di archiviazione sono nello stato di chiusura normale.

Inoltre, un evento MSExchangeIS 1159 con codice di errore 0xfffffdf9 deve essere registrato nel Registro applicazione prima dell'arresto dei database interessati. L'evento indica che Exchange Server ha utilizzato tutti i file di registro delle transazioni disponibili per il gruppo di archiviazione. Quando il registro delle transazioni è pieno, tutti i database all'interno del gruppo di archiviazione vengono disinstallati e non è possibile riavviarli.

Exchange utilizza file di registro delle transazioni numerati in modo sequenziale. In Exchange 2000 Server ed Exchange Server 2003, i file di registro delle transazioni iniziano con Exx00001.log, quindi aumentano in modo sequenziale fino a ExxFFFF0.log. Il numero massimo di file di registro delle transazioni che è possibile generare in una singola sequenza è 1.048.560 (0xFFFF0). In genere, sono necessari diversi anni di operatività per generare un numero così elevato di file di registro.

In Exchange Server 2007, i file di registro delle transazioni sono più grandi. In un flusso di registrazione possono essere presenti al massimo 2.147.483.647 file di registro (0x7FFFFFFF in valore esadecimale poiché i nomi dei file di registro sono espressi in questa unità). I file di registro delle transazioni sono 1 megabyte (MB) ciascuno. È probabile che l'errore non si verifichi in Exchange Server 2007.

Operazione dell'utente

Per risolvere l'errore, è necessario rimuovere tutti i file di registro delle transazioni e reimpostarne la sequenza a 1. Dopo aver reimpostato la sequenza, il nome dei file di registro è Exx00001.log in Exchange Server 2003 o versioni precedenti ed Exx00000001.log in Exchange Server 2007.

Per eseguire questa operazione, utilizzare l'attività Azzeramento numero generazione registro dello strumento Database Recovery Management di Microsoft Exchange Troubleshooting Assistant. Lo strumento verifica che tutti i database siano stati chiusi correttamente, quindi sposta in modo sicuro tutti i file di registro delle transazioni in un percorso di backup.

Nota:
I file di registro delle transazioni possono anche essere rimossi manualmente, ma questa operazione potrebbe provocare la chiusura errata di un database nel gruppo di archiviazione e l'impossibilità di installarlo nuovamente. Per evitare il problema, è consigliabile utilizzare lo strumento Database Recovery Management.

Per ulteriori informazioni e per scaricare lo strumento, vedere Microsoft Exchange Troubleshooting Assistant v1.0 (informazioni in lingua inglese).


MSExchangeIS 9518 (0xfffff745): Impossibile creare o accedere ai file TMP
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffff745 nel Registro applicazione. Tale errore si verifica se Exchange non è in grado di creare o accedere ai file nelle cartelle specificate nelle variabili di ambiente TMP e TEMP del sistema.

Spiegazione

Il problema può verificarsi se una delle condizioni riportate di seguito è vera.

  • Il percorso a cui fa riferimento la variabile d'ambiente TMP o TEMP non è disponibile o è di sola lettura. Ad esempio, il problema si verifica se la variabile di ambiente TMP è mappata a un'unità remota o a una rete SAN (Storage Area Network) e l'unità o la SAN mappata non è più disponibile.

  • La variabile di ambiente TMP o TEMP è impostata in modo non corretto nel Registro di sistema.

  • Exchange non dispone delle autorizzazioni di controllo completo dalla directory principale dell'unità ai registri delle transazioni e ai database.

Operazione dell'utente

Per risolvere questo problema, eseguire una o più operazioni tra quelle indicate di seguito:

Nota Poiché esistono diverse versioni di Microsoft Windows, le operazioni che seguono possono essere diverse sul computer in uso. In tal caso, consultare la documentazione del prodotto per completare la procedura.

  • Verificare che sia la variabile di ambiente TMP che la variabile di ambiente TEMP facciano riferimento a un percorso valido in Windows. Per eseguire l'operazione, procedere come segue:

    Per impostare un percorso valido per le variabili TEMP e TMP

    1. Fare clic su Start, Impostazioni, Pannello di controllo.

    2. Fare doppio clic su Sistema, quindi fare clic sulla scheda Avanzate e su Variabili d'ambiente.

    3. In Variabili di sistema fare clic su TEMP e quindi su Modifica.

    4. Se non viene visualizzato un percorso valido nella casella Valore variabile, digitare un percorso valido per la variabile TEMP e fare clic su OK. Ad esempio, digitare %systemroot%\Temp e fare clic su OK.

    5. In Variabili di sistema fare clic su TMP e quindi su Modifica.

    6. Se non viene visualizzato un percorso valido nella casella Valore variabile, digitare un percorso valido per la variabile TMP e fare clic su OK. Ad esempio, digitare %systemroot%\Temp e fare clic su OK.

    7. Fare clic su OK due volte per chiudere la finestra di dialogo Proprietà sistema.

    8. Riavviare il computer.
  • Verificare e assegnare le autorizzazioni Controllo completo al gruppo Administrators locale o all'account SYSTEM per la cartella Temp. Non è sufficiente assegnare le autorizzazioni Controllo completo al gruppo Domain Admins. Per impostazione predefinita, viene specificato il seguente percorso per le variabili di ambiente TMP e TEMP del sistema:

    %SYSTEMROOT%\Temp

    Exchange deve accedere a questo percorso utilizzando l'account SYSTEM. Per visualizzare le autorizzazioni effettuare le operazioni descritte di seguito.

    Per verificare le autorizzazioni per la cartella Temp

    1. Fare clic con il pulsante destro del mouse su Start e scegliere Esplora.

    2. Fare clic con il pulsante destro del mouse sulla cartella Temp specificata nella variabile di ambiente di sistema, quindi scegliere Proprietà. Di solito la cartella è %systemroot%\Temp.

    3. Selezionare la scheda Protezione.

    4. Nell'elenco Nome fare clic su SYSTEM e visualizzare le autorizzazioni assegnate, riportate nell'elenco Autorizzazioni.
    Se le autorizzazioni per la cartella Temp sono corrette, verificare le autorizzazioni per ciascuna unità che contiene i file di database di Exchange o i file di registro di Exchange. L'account SYSTEM deve disporre delle autorizzazioni Controllo completo per la directory principale dell'unità e per ciascuna cartella che contiene i file di database di Exchange o i file di registro delle transazioni di Exchange. Se ad esempio i registri delle transazioni sono nella cartella C:\Exchsrvr\Mdbdata, l'account SYSTEM deve disporre delle autorizzazioni Controllo completo per la directory principale dell'unità C, la cartella Exchsrvr e la cartella Mdbdata.

  • Verificare se il problema è causato da impostazioni non corrette nel Registro di sistema. Eseguire le operazioni indicate di seguito.

    Per verificare le impostazioni del Registro di sistema

    1. Fare clic su Start, Esegui, digitare Regedt32.exe e scegliere OK.

    2. Individuare la seguente chiave del Registro di sistema:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

    3. Individuare il nome TMP o TEMP. La chiave deve essere del tipo REG_EXPAND_SZ.

    4. Se una delle chiavi non è corretta, effettuare una copia della sottochiave Environment ed eliminare il valore TMP o TEMP a destra.

    5. Fare clic su Start, Esegui, digitare Sysdm.cpl, quindi scegliere OK.

    6. Fare clic su Variabili d'ambiente nella scheda Avanzate.

    7. Verificare che i valori eliminati nel passaggio 4 non siano presenti nell'elenco delle variabili di sistema.

      Nota:
      Potrebbe essere necessario scorrere l'elenco verso il basso per vedere le variabili TEMP o TMP.

    8. Fare clic su Nuova. Nella casella Nome variabile digitare i nomi eliminati nel passaggio 4, ad esempio C:\Winnt\TEMP.

    9. Fare clic su OK tre volte e riavviare il computer.


MSExchangeIS 9518 0xfffffbc4: Percorso file di registro già in uso
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-05-14

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffffbc4 nel registro applicazioni. Il codice di errore indica che uno o più gruppi di archiviazione sono configurati per utilizzare lo stesso percorso dei file di registro o dei file di sistema.

Spiegazione

L'errore può verificarsi se più gruppi di archiviazione sono stati configurati per utilizzare lo stesso percorso dei file di registro o dei file di sistema. È necessario che ogni gruppo di archiviazione abbia un percorso univoco per i file di registro e di sistema.

Azione utente

Per risolvere il problema, accertarsi che ciascun gruppo di configurazione sia configurato con un percorso univoco dei file di registro e di sistema.

Nota:
Un gruppo di archiviazione di contenuto discreto può condividere lo stesso percorso dei file di registro e di sistema. Tuttavia, lo stesso percorso non può essere utilizzato come percorso dei file di registro o dei file di sistema per un altro gruppo di archiviazione.
Per verificare o impostare il percorso dei file di registro e di sistema su Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo e Server, fare clic con il pulsante destro del mouse sul gruppo di archiviazione e scegliere Proprietà.

  3. Nella scheda Generale, in Posizione registro transazioni, fare clic su Sfoglia.

  4. Verificare che il Percorso file di registro e il Percorso file di sistema siano univoci per il gruppo di archiviazione.

  5. Se il Percorso file di registro e il Percorso file di sistema del gruppo di archiviazione non sono univoci, immettere il percorso della nuova posizione dei file di registro o dei file di sistema, quindi fare clic su OK.

  6. Fare clic su OK.
Per verificare o impostare il percorso dei file di registro e di sistema di un gruppo di archiviazione su Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere la struttura Configurazione server e selezionare Cassetta postale.

  3. Selezionare il server che si desidera utilizzare dal riquadro Cassetta postale.

  4. Nel riquadro Gestione database, fare clic con il pulsante destro del mouse sul gruppo di archiviazione che si desidera utilizzare e scegliere Proprietà.

  5. Verificare che il Percorso file di registro e il Percorso file di sistema siano univoci per il gruppo di archiviazione.

  6. Se il Percorso file di registro e il Percorso file di sistema del gruppo di archiviazione non sono univoci, seguire le istruzioni indicate nella documentazione di Exchange Server 2007, "Come impostare o modificare il percorso dei file di registro del gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80702 per impostare i percorsi dei file su una posizione univoca per ogni gruppo di archiviazione.

Per ulteriori informazioni sullo spostamento dei file di registro in Exchange Server 2003, consultare l'articolo 821915 della Microsoft Knowledge Base "Spostamento dei registri e dei database di Exchange in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915.

Per ulteriori informazioni sullo spostamento dei file di registro in Exchange 2000 Server, consultare l'articolo 239944 della Microsoft Knowledge Base "XADM: Spostare un registro delle transazioni o un registro di sistema in una posizione diversa" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944.


MSExchangeIS 9518 (0xfffffd9a): File del punto di controllo mancante. Sono presenti oltre 1.008 file del registro delle transazioni
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffffd9a nel Registro applicazione. L'errore indica che il file del punto di controllo (Exx.chk) per il gruppo di archiviazione è mancante o è stato eliminato e che sono presenti più di 1.008 file del registro delle transazioni da eseguire nel database.

Spiegazione

Il problema può verificarsi se le condizioni descritte di seguito sono vere.

  • I file del registro e i database sono stati chiusi correttamente e pertanto non sono presenti situazioni di emergenza da risolvere.

  • Il file del punto di controllo Exx.chk è stato rinominato o eliminato.

  • Tra i punti di controllo sono presenti più di 1.008 file di registro che devono essere rieseguiti sul server.

  • In un ripristino di tipo roll forward, uno o più database del gruppo di archiviazione sono andati perduti ma i file di registro restano intatti sul server al momento del ripristino. L'operazione di ripristino roll forward non viene completata correttamente.

In questa situazione, il servizio Archivio informazioni di Microsoft Exchange esegue un ripristino dei dati e riesegue tutti i file di registro durante l'avvio. Poiché i file di registro e il database sono stati chiusi correttamente, non è necessario eseguire alcun ripristino. In assenza di punti di controllo, Exchange elabora tutti i registri finché rileva un record di arresto normale. Poiché sono presenti più di 1.008 file di registro, Exchange raggiunge il limite di 1.008 file prima di individuare il record di arresto normale.

Nota:
È possibile riscontrare i sintomi descritti anche se le condizioni indicate in precedenza sono vere e si rieseguono i file di registro utilizzando il comando eseutil /r. Il comando eseutil /r esegue inoltre un recupero a caldo nell'archivio delle cassette postali.

L'errore può essere identificato anche come errore JET_errCheckpointDepthTooDeep, -614 e può essere riscontrato solo in Microsoft Exchange Server 2003.

Operazione dell'utente

Per risolvere il problema in Exchange Server 2003, applicare l'aggiornamento rapido indicato nell'articolo 836611 della Microsoft Knowledge Base, I database dell'archivio informazioni non vengono installati e si riceve un messaggio di errore "Operazione terminata con errore -614" quando si avvia un computer che esegue Exchange Server 2003.


MSExchangeIS 9518 0xfffffb40: File del database mancante
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-05-23

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffffb40 nel registro applicazioni. Ciò indica che uno o più file del database del gruppo di archiviazione sono mancanti.

Spiegazione

L'errore può verificarsi quando ESE (Extensible Storage Engine) tenta di portare tutti i database in un gruppo di archiviazione a uno stato coerente durante il ripristino ma rileva che alcuni file del database risultano mancanti o sono stati sostituiti con versioni differenti.

Se un file del database del gruppo di archiviazione risulta mancante o è stato sostituito con versioni differenti, ESE restituisce l'errore -1216, interrompe la procedura di ripristino e non avvia il gruppo di archiviazione.

Azione utente

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti:

  • Metodo 1: se il file del database mancante è stato spostato o rinominato, individuare gli eventi ESE 494 nel registro applicazioni che si sono verificati dopo il tentativo di installazione del database. Per ciascun evento, annotare il file del database specifico che risulta mancante, individuare la posizione corrente del file e spostarlo nel percorso appropriato.

Nota:
Se sul server è installato un software antivirus a livello di file e le esclusioni non sono state configurate correttamente, è probabile che il database sia stato eliminato o messo in quarantena. Verificare le cartelle di quarantena e il registro dei file eliminati del programma antivirus.
  • Metodo 2:

    • Metodo 2 A: se il file del database mancante è stato eliminato o è andato perso, ripristinare il file da una copia di backup nel gruppo di archiviazione di produzione. È possibile utilizzare l'attività Verifica database e file di registro delle transazioni dello strumento Gestione ripristino dei database di Exchange per verificare la disponibilità del file del database ripristinato per l'esecuzione del ripristino.

      Durante il ripristino del file del database, è inoltre possibile installare e accedere ad altri database integri nel gruppo di archiviazione attenendosi alla seguente procedura:

Per consentire l'accesso della cassetta postale utente ai database integri

  1. Eseguire eseutil /R /L <Path to Log Files> /S <Path to System Files> Log Base Name /I (dove Log Base Name corrisponde ai primi tre caratteri dei file di registro del gruppo di archiviazione, ad esempio E00, E01, e così via). Ciò consente a ESE di portare i file del database presenti a uno stato coerente, ignorando i file del database mancanti. Dopo l'esecuzione del comando, tutti i file del database mancanti dovranno essere ripristinati dal backup.
Nota:
Le opzioni /L e /S sono facoltative e non è necessario utilizzarle se eseutil viene eseguito dallo stesso percorso dei file di registro e di sistema.
  1. Installare i file del database presenti e coerenti nel gruppo di archiviazione.

  2. Gli utenti con cassette postali ospitate dal database attualmente installato possono ora accedere alla posta.
  • Metodo 2 B: ripristinare il file del database dal backup in un gruppo di archiviazione di ripristino. È possibile fornire immediatamente la funzionalità di invio e ricezione avviando un nuovo database il prima possibile, operazione nota come ripristino temporaneo. I client visualizzano una cassetta postale vuota ma possono usufruire della funzione di invio e ricezione in maniera più rapida anziché attendere il completamento della procedura di ripristino o riparazione.

Nota:
L'opzione di ripristino temporaneo richiederà l'eventuale unione dei nuovi dati (successivi) con i dati ripristinati.

Per ulteriori informazioni sul ripristino temporaneo, vedere "Portabilità temporanea" nell'argomento Ripristino di emergenza della documentazione del prodotto Exchange 2007.

Per ulteriori informazioni sui gruppi di archiviazione di ripristino, vedere "Concetti relativi ai gruppi di archiviazione di ripristino" nell'argomento Ripristino di emergenza nella documentazione del prodotto Exchange 2007.
  • Metodo 3: se è stato eseguito un ripristino a freddo, in modo manuale o da parte dell'attività Ripristino database dell'assistente risoluzione dei problemi di Exchange, di uno o più database nel gruppo di archiviazione, e se i database sono in uno stato coerente, è probabile che i file di registro del gruppo di archiviazione non siano stati rimossi. Se tutti i database del gruppo di archiviazione sono nel percorso corretto, verificare che tutti i database siano in uno stato coerente eseguendo il comando seguente.

Per verificare manualmente lo stato di coerenza dei file del database:

  1. Eseguire eseutil /mh <path to database .edb file>

  2. Nell'output del comando, ricercare il campo Stato: e verificare che il valore sia Chiusura normale.

  3. Se tutti i database del gruppo di archiviazione sono nello stato di chiusura normale, spostare tutti i registri delle transazioni e i registri di sistema del gruppo di archiviazione in un percorso di backup, quindi provare a installare l'archivio. Se tutti i database sono installati correttamente, si consiglia di eseguire immediatamente un backup del gruppo di archiviazione.

Per ulteriori informazioni

Per ulteriori informazioni sull'evento MSExchangeIS 9518 con codice di errore 0xfffffb40, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91705.

Per ulteriori informazioni sul ripristino a seguito di questo errore, consultare l'articolo 296843 della Microsoft Knowledge Base "Recupero di un database di Exchange 2000 Server dopo errore -1216" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=296843.

Per ulteriori informazioni sulla pianificazione del ripristino di emergenza di Exchange, vedere "Guida per la pianificazione del ripristino di emergenza di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91706).

Per ulteriori informazioni sulle procedure guidate di risoluzione dei problemi del database e di gestione del ripristino di emergenza, vedere "Strumenti gestione ripristino dei database e Risoluzione dei problemi di database" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91707.

Per ulteriori informazioni sul ripristino temporaneo, vedere "Portabilità temporanea" nell'argomento Ripristino di emergenza nella documentazione del prodotto Exchange 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=91703.

Per ulteriori informazioni sui gruppi di archiviazione di ripristino, vedere "Concetti relativi ai gruppi di archiviazione di ripristino" nell'argomento Ripristino di emergenza nella documentazione del prodotto Exchange 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80784.


MSExchangeIS 9518 (0xfffffea8): Timestamp del database non corrispondente nel file del database
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffffea8 nel Registro applicazione. L'errore si verifica se il valore dbtime nella pagina corrente del database è superiore al valore dbtime globale del database.

Spiegazione

Quando si verifica questo errore, non è possibile installare i database delle cassette postali o delle cartelle pubbliche interessati. L'errore viene identificato anche come JET_errDbTimeCorrupted.

L'errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere la mancata corrispondenza del timestamp del database, eseguire il comando eseutil /d per deframmentare il database che presenta il problema e successivamente installare il database. Per ulteriori informazioni sulla modalità di esecuzione di eseutil /d, vedere Esecuzione di Eseutil /D (Deframmentazione). Consultare inoltre l'articolo 328804 della Microsoft Knowledge Base Deframmentazione dei database di Exchange.


MSExchangeIS 9518 (0xfffff764): File di flusso mancante o inaccessibile
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffff764 nel Registro applicazione. Questo errore si può verificare se Exchange non è in grado di accedere al file di flusso (stm) associato a un database.

Spiegazione

L'errore si verifica se il file di flusso (stm) associato a un database è stato eliminato o spostato, oppure se Exchange non è in grado di accedere al file di flusso a causa di una modifica delle autorizzazioni.

Nota:
In alcune circostanze, i programmi antivirus possono eliminare o modificare le autorizzazioni dei file di Exchange, compresi i file con estensione stm, se le directory di Exchange non sono state escluse dalla scansione secondo le procedure consigliate per Microsoft Exchange. Per ulteriori informazioni su questo argomento, vedere l'articolo 823166 della Microsoft Knowledge Base, Panoramica di Exchange Server 2003 e software antivirus.

Questo errore può essere inoltre identificato come -2204 e può verificarsi nelle seguenti versioni di server di Exchange:

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti:

  • Ripristinare il file di flusso da una copia di backup del database.

  • Verificare se il software antivirus in uso ha spostato il file di flusso nella cartella di quarantena. Se il file si trova in tale cartella, spostarlo nella posizione originale e configurare il programma antivirus in modo tale che non esegua la scansione delle cartelle di Exchange Server 2003.

    Nota:
    Alcuni programmi antivirus impostano le proprietà dei file su Sola lettura quando i file vengono spostati nella cartella di quarantena. Se il file di flusso si trova nella cartella di quarantena, fare clic con il pulsante destro del mouse sul file e scegliere Proprietà. Fare clic per deselezionare la casella di controllo Sola lettura prima di tentare l'installazione del database.
  • È possibile eseguire lo strumento Microsoft Exchange Database Recovery Management che fa parte di Microsoft Exchange Troubleshooting Assistant. Database Recovery Management è in grado di analizzare il database e i file di registro delle transazioni per il gruppo di archiviazione e fornire ulteriori dettagli sul problema. Per ulteriori informazioni nonché per scaricare lo strumento, vedere Microsoft Exchange Troubleshooting Assistant v1.0 (informazioni in lingua inglese).


MSExchangeIS 9518 (0xfffffbf8): Autorizzazioni necessarie mancanti sulla cartella o sull'unità del database di Exchange
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-03-15

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffffbf8 nel registro applicazioni. Ciò indica che alla cartella o all'unità contenente i database di Exchange non sono state assegnate le autorizzazioni appropriate.

Spiegazione

L'errore indica che alla cartella o all'unità contenente i database di Exchange non sono state assegnate le autorizzazioni appropriate necessarie per l'esecuzione delle funzioni minime. È probabile che si verifichino difficoltà di accesso o installazione degli archivi di cassette postali o di cartelle pubbliche.

Azione utente

Per risolvere il problema, concedere le autorizzazioni predefinite alla cartella contenente i database di Exchange e all'unità in cui risiede la cartella.

Per concedere le autorizzazioni predefinite alla cartella contenente i database di Exchange in Exchange 2007

  1. Avviare Esplora risorse, quindi passare alla cartella contenente i database di Exchange. Per impostazione predefinita, si tratta di C:\Programmi\Microsoft\Exchange\Mailbox\Nome gruppo archiviazione\

  2. Fare clic con il pulsante destro del mouse sulla cartella, quindi scegliere Proprietà.

  3. Selezionare la scheda Protezione, quindi concedere le autorizzazioni predefinite riportate di seguito

Account | Autorizzazioni
Amministratori | Controllo completo
Sistema | Controllo completo
 Per concedere le autorizzazioni predefinite all'unità contenente i database di Exchange in Exchange 2007

  1. Avviare Esplora risorse.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Disco locale contenente la cartella del database di Exchange, quindi scegliere Proprietà.

  3. Selezionare la scheda Protezione, quindi concedere le autorizzazioni predefinite riportate di seguito in base al sistema operativo installato:

Per Windows 2000 Server:

Account | Autorizzazioni
Tutti | Controllo completo

Per Windows Server 2003:

Account | Autorizzazioni
Administrators | Controllo completo
Creator Owner | Nessuno
Everyone | Nessuno
Sistema | Controllo completo
Users | Lettura ed esecuzione, Visualizzazione contenuto cartella, Lettura
 Per concedere le autorizzazioni predefinite alla cartella Mdbdata di Exchange 2000 Server ed Exchange Server 2003

  1. Avviare Esplora risorse, quindi passare alla cartella Exchsvr ed espanderla.

  2. Fare clic con il pulsante destro del mouse sulla cartella Mdbdata, quindi scegliere Proprietà.

  3. Selezionare la scheda Protezione, quindi concedere le seguenti autorizzazioni predefinite:

Account | Autorizzazioni
Administrators | Controllo completo
Authenticated Users | Lettura ed esecuzione, Visualizzazione contenuto cartella, Lettura
Creator Owner | Nessuno
Server Operators | Modifica, Lettura ed esecuzione, Visualizzazione contenuto cartella, Lettura, Scrittura
System | Controllo completo
 Per concedere le autorizzazioni predefinite all'unità contenente la cartella Mdbdata di Exchange 2000 Server ed Exchange Server 2003

  1. Avviare Esplora risorse.

  2. Fare clic con il pulsante destro del mouse sull'oggetto Disco locale contenente la cartella Mdbdata, quindi scegliere Proprietà.

  3. Selezionare la scheda Protezione, quindi concedere le autorizzazioni predefinite seguenti in base al sistema operativo installato:

Per Windows 2000 Server:

Account | Autorizzazioni
Everyone | Controllo completo

Per Windows Server 2003:

Account | Autorizzazioni
Administrators | Controllo completo
Creator Owner | Nessuno
Everyone | Nessuno
System | Controllo completo
Users | Lettura ed esecuzione, Visualizzazione contenuto cartella, Lettura

Per ulteriori informazioni

Per ulteriori informazioni su questo problema, consultare l'articolo 823022 della Microsoft Knowledge Base, "Evento con ID 490, messaggio di errore quando si tenta di installare l'archivio delle cassette postali o l'archivio pubblico in Exchange Server: "N. ID: c1041724"", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823022.


MSExchangeIS 9518 (0xfffff743): troppi file di tipo Temp
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-03-14

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffff743 nel registro applicazioni. Ciò indica che lo spazio dei nomi dei file temporanei di un server è esaurito oppure che non è disponibile spazio per la scrittura nella cartella Temp.

Spiegazione

Exchange 2000 Server e Exchange Server 2003 creano file temporanei nella cartella Temp quando un oggetto di grandi dimensioni, ad esempio un messaggio o un file, viene trasmesso come flusso nell'archivio e il file stm è troppo frammentato per supportare la scrittura dell'intero oggetto al suo interno.

Se si arrestano i servizi di Exchange durante il normale funzionamento, questi file verranno rimossi dalla cartella Temp. Rimangono invece disponibili nella cartella in caso di arresto imprevisto del server di Exchange o dei servizi di Exchange. Al successivo riavvio dei servizi di Exchange, verranno creati nuovi file temporanei con la conseguente diminuzione del livello delle prestazioni. Quando lo spazio dei nomi di file temporanei (64.000) si esaurisce, non è più possibile avviare i servizi di Exchange e gli eventi 9518 con il codice di errore 0xfffff743 vengono registrati nel registro applicazioni del Visualizzatore eventi.

Azione utente

Per risolvere il problema, procedere come segue:

  • Verificare l'esistenza dei file lb*.tmp nella cartella Temp di Windows. Se i file esistono, rimuoverli utilizzando seguire la procedura seguente.

  • Verificare che lo spazio disponibile nell'unità in cui risiede la cartella Temp sia sufficiente. Se lo spazio libero su disco è insufficiente, seguire la procedura riportata di seguito per spostare le cartelle Temp e Tmp in un'altra unità.

Per rimuovere i file lb*.tmp dalla cartella Temp di Windows

  1. Fare clic su Start, scegliere Programmi, Strumenti di amministrazione, quindi fare clic su Servizi.

  2. Scorrere fino a Archivio informazioni di Microsoft Exchange.

  3. Se lo stato del servizio è Started, fare clic con il pulsante destro del mouse sul servizio, quindi scegliere Interrompi
Nota:
Tutti gli utenti verranno disconnessi dalle relative cassette postali.
  1. Individuare la cartella %windir%\temp, dove %windir% è la cartella radice del sistema Windows, per impostazione predefinita corrispondente a C:\Windows\Temp.

  2. Eliminare tutti i file lb*.tmp.

  3. Nella console di gestione Servizi, fare clic con il pulsante destro del mouse sul servizio Archivio informazioni di Microsoft Exchange, quindi fare clic su Inizio.

 Per spostare le cartelle Temp e Tmp in un'altra unità

  1. Sul computer che esegue Exchange Server, fare clic su Start, Pannello di controllo, quindi fare doppio clic su Sistema.

  2. Fare clic sulla scheda Avanzate, quindi scegliere Variabili d'ambiente.

  3. Nella sezione Variabili di sistema, fare clic sulla riga che include l'unità e la variabile TEMP, scegliere Modifica, quindi digitare la posizione della nuova unità.

  4. In Variabili di sistema, fare clic sulla riga che include l'unità e la variabile TMP, scegliere Modifica, quindi digitare la posizione della nuova unità.
Nota:
Assicurarsi che la modifica venga applicata a Variabili di sistema e non a Variabili utente.
Nota:
Se questa procedura non risolve il problema, consultare l'articolo 307242 della Microsoft Knowledge Base, "Impossibile installare l'archivio informazioni in presenza degli errori 0xfffff745 e -2235" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242.

Per ulteriori informazioni

Per ulteriori informazioni su questo problema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 294462, "I file lb*.tmp nella cartella Temp di Windows causano l'errore ESE -2237 "all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=294462.

  • 307242, "Impossibile installare l'archivio informazioni in presenza degli errori 0xfffff745 e -2235", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307242.


MSExchangeIS 9519 (0xfffffb3a): Rilevati più database con la stessa firma in uso
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9519 con codice di errore 0xfffffb3a nel Registro applicazione. L'errore indica che è già in esecuzione un'altra copia dello stesso database.

Spiegazione

Ogni database di Exchange dispone di una propria firma univoca. Se il servizio Archivio informazioni di Microsoft Exchange rileva più database con la stessa firma, impedisce l'installazione del database duplicato.

L'evento può essere identificato anche come errore -1222, JET_errDatabaseSignInUse.

Operazione dell'utente

È possibile verificare la presenza di due copie dello stesso database in un solo gruppo di archiviazione effettuando le operazioni riportate di seguito.

  1. Disinstallare tutti gli altri database presenti nel gruppo di archiviazione e provare a installare il database che ha causato il messaggio di errore.

  2. Se è possibile installare il database, provare successivamente a installare tutti gli altri database del gruppo di archiviazione.

  3. Se un altro database del gruppo di archiviazione genera lo stesso errore nel Registro applicazione, i due database hanno la stessa firma e sono quindi copie dello stesso database.

Per risolvere il problema, accertarsi che solo una copia del database sia presente in quel determinato gruppo di archiviazione.


MSExchangeIS 9519 (0xfffffe07): Impossibile installare il database a causa di un processo di backup in esecuzione
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-02-27

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9519 con codice di errore 0xfffffe07 nel Registro applicazioni. Questo errore indica che non è stato possibile installare il database specificato a causa di un processo di backup in esecuzione.

Spiegazione

Tale errore può verificarsi se il gruppo di archiviazione di cui fa parte il database contiene più database (database delle cassette postali o database di cartelle pubbliche) e se al momento in cui è stato eseguito il tentativo di installazione del database era in corso il backup di uno di tali database. Non si tratta di un problema. Non è possibile installare un database in un gruppo di archiviazione quando è in corso la procedura di backup di un altro database nello stesso gruppo di archiviazione.

L'errore potrebbe anche essere identificato come errore -505, JET_errBackupInProgress.

Operazione dell'utente

Assicurarsi che non sia in corso il backup di nessun altro database nel gruppo di archiviazione, quindi provare a installare il database. In alternativa, attendere il completamento della procedura di backup dell'altro database nel gruppo di archiviazione prima di tentare l'installazione di questo database.


MSExchangeIS 9519 (0x3f3): Casella di controllo "Database riscrivibile da un ripristino" non selezionata dopo il ripristino
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9519 con codice di errore 0x3f3 nel Registro applicazione. L'errore indica che è stato eseguito il ripristino di un database senza aver selezionato la casella di controllo "Database riscrivibile da un ripristino".

Spiegazione

Questo evento si verifica quando viene eseguita un'operazione di ripristino di un database ed Exchange rileva che la casella di controllo "Database riscrivibile da un ripristino" non è stata selezionata nelle proprietà dell'archivio.

Operazione dell'utente

Per risolvere il problema, accertarsi che il database possa essere sovrascritto da un ripristino effettuando le seguenti operazioni.

Per abilitare l'opzione in Exchange Server 2003 ed Exchange 2000 Server

  1. Avviare il Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, se necessario.

  3. Espandere Server, <Nome server>, <Gruppo di archiviazione> e fare clic sul database ripristinato.

  4. Fare clic con il pulsante destro del mouse sul database, quindi scegliere Proprietà.

  5. Selezionare la scheda Database.

  6. Fare clic per selezionare la casella di controllo Database riscrivibile da un ripristino.

  7. Fare clic su OK.

  8. Per installare il database, fare clic con il pulsante destro del mouse sul database e scegliere Installa archivio.
Per abilitare l'opzione in Exchange Server 2007

  1. Avviare Exchange Management Console.

  2. Selezionare Cassetta postale in Configurazione server.

  3. Nel riquadro Gestione database fare clic con il pulsante destro del mouse sul database ripristinato.

  4. Fare clic su Proprietà.

  5. Selezionare la scheda Generale.

  6. Fare clic per selezionare la casella di controllo Database riscrivibile da un ripristino.

  7. Fare clic su OK.

  8. Per installare il database, fare clic con il pulsante destro del mouse sul database e scegliere Installa database.


MSExchangeIS 9518 (0xfffffc01): Unità o directory del database o del file di registro delle transazioni errata
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9518 con codice di errore 0xfffffc01 nel Registro applicazione. Ciò indica che per il database di Exchange o per i file di registro è stata impostata una lettera di unità o un percorso errati.

Spiegazione

L'errore indica che il percorso del database o del file di registro nel gruppo di archiviazione interessato fa riferimento a una lettera di unità non valida o che il percorso del file è errato. Se si verifica questo errore, sarà impossibile installare tutti i database nel gruppo di archiviazione interessato.

Il problema potrebbe verificarsi anche se il software antivirus blocca l'accesso in scrittura alle unità che contengono il database di Exchange o i file di registro delle transazioni.

L'evento può essere indicato anche come errore -1023, JET_errInvalidPath.

Operazione dell'utente

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti:

  • Per determinare se il software antivirus è all'origine del problema, disattivarlo provvisoriamente nella console Servizi. Quindi provare a installare i database interessati. Se i database si installano correttamente, contattare il fornitore del programma antivirus e richiedere la build più recente del software.

  • Verificare e impostare i percorsi corretti del sistema, del database e dei file di registro delle transazioni per ogni gruppo di archiviazione e per ogni database influenzato negativamente dall'errore. Procedere come descritto di seguito.

Per verificare e impostare i percorsi del file corretti in Exchange Server 2003 o Exchange 2000 Server

  1. Avviare il Gestore di sistema di Exchange. Fare clic su Start, scegliere Programmi , quindi Microsoft Exchange e infine fare clic su Gestore di sistema.

  2. Se in Exchange System Manager sono visualizzati gruppi amministrativi, espandere la struttura Gruppi amministrativi, quindi la struttura del gruppo amministrativo in cui è stato riscontrato il problema.

  3. Espandere la struttura Server, quindi la struttura del server sul quale è stato riscontrato il problema.

  4. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione contenente l'archivio che non è possibile installare e scegliere Proprietà.

  5. Nella scheda Generale esaminare il percorso visualizzato nella casella Posizione registro transazioni. Esaminare il percorso nella casella Posizione percorso di sistema.

    Se i percorsi non sono corretti, rivolgersi al Servizio Supporto Tecnico Clienti Microsoft per risolvere il problema.

  6. Seguire i passaggi da 3 a 5 per ogni gruppo di archiviazione presente per verificare il percorso del database e quello del file di registro delle transazioni.

  7. Dopo aver verificato il percorso di sistema e quello del file di registro delle transazioni per ogni gruppo di archiviazione, controllare i percorsi del database di ogni archivio in ciascun gruppo di archiviazione. Per eseguire l'operazione, procedere come segue:

    1. Espandere un gruppo di archiviazione. Ad esempio, espandere Primo gruppo di archiviazione.

    2. Fare clic con il pulsante destro del mouse su StoreName (NomeServer), quindi scegliere Proprietà.

    3. Scegliere la scheda Database, quindi verificare il percorso visualizzato nella casella Database di Exchange. Verificare il percorso visualizzato nella casella Database di flusso di Exchange.

      Se un percorso specifico è errato, rivolgersi al Servizio Supporto Tecnico Clienti Microsoft per risolvere il problema.

    4. Ripetere i passaggi 7b e 7c per verificare i percorsi di ogni archivio di cassette postali o di cartelle pubbliche presente in ogni gruppo di archiviazione.

  8. Installare l'archivio delle cassette postali o quello delle cartelle pubbliche.

Per verificare e impostare i percorsi dei file corretti in Exchange Server 2007

  1. Avviare Exchange Management Console. Fare clic su Start, scegliere Programmi , quindi Microsoft Exchange e infine fare clic su Exchange Management Console.

  2. Espandere la struttura Configurazione server e selezionare Cassetta postale.

  3. Nel riquadro Gestione del database selezionare il gruppo di archiviazione che contiene i database che non è possibile installare.

  4. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione, quindi scegliere Proprietà.

  5. Nella scheda Generale esaminare il percorso elencato in Percorso registro e Percorso di sistema.

    Se i percorsi sono errati, fare clic con il pulsante destro del mouse sul gruppo di archiviazione, quindi selezionare Sposta percorso gruppo di archiviazione. In Percorso file di registro e Percorso file di sistema scegliere Sfoglia per individuare la cartella contenente i file di registro delle transazioni o i file del database. Per impostazione predefinita, i file di registro delle transazioni e i file del database si trovano nella cartella seguente:

    %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<nome gruppo di archiviazione>

  6. Fare clic su OK.

  7. Seguire i passaggi da 3 a 5 per ogni gruppo di archiviazione presente per verificare il percorso di sistema e quello del file di registro delle transazioni.

  8. Dopo aver verificato il percorso di sistema e quello del file di registro delle transazioni per ogni gruppo di archiviazione, controllare i percorsi del database di ogni database in ciascun gruppo di archiviazione. Per eseguire l'operazione, procedere come segue:

    1. Espandere un gruppo di archiviazione. Ad esempio, espandere Primo gruppo di archiviazione.

    2. Verificare il percorso visualizzato in Percorso file database nel riquadro Gestione del database.

    3. Se un percorso specifico è errato, fare clic con il pulsante destro del mouse sul database, quindi selezionare Sposta percorso database.

    4. Scegliere Sfoglia per individuare la cartella corretta per il file del database. Per impostazione predefinita, il file del database di Exchange (edb) si trova nella cartella seguente:

      %PROGRAMFILES%\Microsoft\Exchange Server\Mailbox\<nome gruppo di archiviazione>\<nome database.edb>

    5. Fare clic su OK.

    6. Ripetere i passaggi da 8b a 8e per verificare i percorsi di ogni database di cassette postali o di cartelle pubbliche presente in ogni gruppo di archiviazione.

  9. Installare il database delle cassette postali o quello delle cartelle pubbliche.


MSExchangeIS 9519 (0xfffffbda): Impostazioni locali del set di caratteri a due byte mancanti configurate come valore predefinito
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-23

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9519 con codice di errore 0xfffffbda nel Registro applicazione. Questo evento indica che sono state installate impostazioni locali predefinite non inglesi. Una volta installato Exchange Server, le impostazioni locali predefinite del sistema sono state disinstallate.

Spiegazione

Se l'evento MSExchangeIS 9519 con codice di errore 0xfffffbda attiva il riavvio del server di Exchange, non sarà possibile installare i database di Exchange. Inoltre, nel registro eventi dell'applicazione vengono registrati gli eventi di errore ESE 604 e MSExchangeIS 9519.

Questo comportamento può verificarsi nel caso in cui nel sistema fossero precedentemente installate come predefinite impostazioni locali non inglesi. L'evento si verifica infatti quando l'utente sceglie impostazioni locali differenti come impostazioni predefinite del sistema, rimuove le impostazioni locali non inglesi, quindi riavvia Exchange 2000 Server o Exchange Server 2003.

L'evento può essere identificato anche come -1062, JET_errInvalidLanguageId e può verificarsi nelle seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere il problema, reinstallare le impostazioni locali non inglesi oppure creare nuovi database. Se si sceglie di reinstallare le impostazioni locali non inglesi, non sarà necessario impostarle come predefinite per il sistema.


MSExchangeIS 9519 (0xfffff05b): Rilevati database o file di registro compressi su un server che esegue Exchange Server 2000 SP3 o versione successiva
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-02-19

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9519 con codice di errore 0xfffff05b nel registro applicazioni. Questo errore indica che il database di Exchange o i file di registro delle transazioni si trovano su un'unità per cui è stata attivata la compressione del file system.

Spiegazione

Questo evento può verificarsi quando si applica Exchange 2000 Server Service Pack 3 a un server Exchange 2000 contenente un database dell'archivio informazioni compresso mediante la compressione del file system NTFS. Tale evento può inoltre verificarsi quando viene eseguito l'aggiornamento da Exchange 2000 Server a Exchange Server 2003. Exchange 2000 Server SP3, Exchange 2003 ed Exchange Server 2007 impediscono l'installazione dei database dell'archivio informazioni compressi.

L'errore può anche essere identificato come -4005, JET_errFileCompressed. Questo errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server SP3

Operazione dell'utente

Per risolvere questo problema, è necessario decomprimere le cartelle in cui si trovano i database e i registri dell'archivio informazioni, eseguire la deframmentazione dei database, quindi eseguire un backup in linea, che riconosca Exchange, dei gruppi di archiviazione dell'archivio informazioni in cui si trovano i database e i registri. A tale scopo, vedere l'articolo 327772 della Microsoft Knowledge Base Database does not mount, and you receive error 0xfffff05b after you apply SP3 to Exchange 2000.


MSExchangeIS 9519 (0xfffffa84): Indici dei database mancanti o danneggiati
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-01-22

Lo strumento Microsoft® Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9519 con codice di errore 0xfffffa84 nel Registro applicazione. L'evento indica che gli indici del database sono danneggiati o mancanti.

Spiegazione

Un indice del database danneggiato o mancante potrebbe essere causato da uno dei motivi seguenti:

  • L'errore potrebbe verificarsi durante la pulitura dell'indice di un database di Exchange dopo aver applicato un nuovo Service Pack di Microsoft Windows. Dopo aver applicato il Service Pack, non è possibile installare i database delle cassette postali e delle cartelle pubbliche nel server Exchange. Inoltre, nel registro eventi dell'applicazione sono registrati gli eventi ESE 609 e ESE 611.

  • L'errore potrebbe verificarsi dopo aver eseguito un'operazione di ripristino del database (eseutil /p). L'operazione potrebbe rimuovere un indice generato quando viene creato il database. L'esecuzione del comando di ripristino Eseutil causa la rimozione dell'indice.

L'errore può essere indicato anche come -1404, JET_errIndexNotFound. Questo errore riguarda le seguenti versioni del server Exchange:

  • Microsoft Exchange Server 2007

  • Microsoft Exchange Server 2003

  • Microsoft Exchange 2000 Server

Operazione dell'utente

Per risolvere il problema, seguire la risoluzione che corrisponde allo scenario del problema descritto in precedenza:

  • Se un indice viene danneggiato durante la pulitura dell'indice di un database di Exchange dopo aver applicato un nuovo Service Pack di Microsoft Windows, procedere come descritto di seguito:

    1. Ripristinare il database delle cassette postali o delle cartelle pubbliche in questione da una copia di backup valida.

    2. Eseguire un'operazione di deframmentazione non in linea del database interessato eseguendo lo strumento eseutil /d. Per informazioni sulle modalità di deframmentazione del database interessato non in linea, vedere gli argomenti seguenti:

      Database di Exchange 2000 Server ed Exchange Server 2003: Esecuzione di Eseutil /D (Deframmentazione)

      Database di Exchange Server 2007: Esecuzione di Eseutil /D (Deframmentazione)

  • Se un indice risulta mancante dopo aver eseguito un'operazione di ripristino del database (eseutil /p), applicare l'aggiornamento rapido descritto nell'articolo 924627 della Microsoft Knowledge Base, Viene registrato l'ID evento 9519 che comprende l'errore 0xfffffa84 quando si tenta di installare un database dopo aver utilizzato le utilità Eseutil e Isinteg per ripristinare il database in Exchange 2003.


MSExchangeIS 9519 0x972: Il contenitore delle cartelle pubbliche è stato eliminato o mancano gli attributi obbligatori
Articoli su Microsoft Exchange Server Analyzer > Ripristino dei database >

Ultima modifica: 2007-08-30

Lo strumento Microsoft Exchange Database Troubleshooter ha rilevato uno o più eventi MSExchangeIS 9519 con codice di errore 0x972 nel Registro applicazione. Ciò indica un errore di installazione dei database delle cartelle pubbliche perché il contenitore delle cartelle pubbliche è stato eliminato oppure mancano gli attributi necessari.

Spiegazione

Questo errore può verificarsi quando il contenitore delle cartelle pubbliche è stato eliminato da Active Directory o se l'archivio pubblico interessato non è configurato per l'utilizzo del contenitore delle cartelle pubbliche, ad esempio se il valore dell'attributo msExchOwningPFTreeBL del contenitore delle cartelle pubbliche non fa riferimento all'archivio pubblico. La causa più probabile dell'errore è l'eliminazione del gruppo amministrativo contenente il contenitore delle cartelle pubbliche senza aver prima spostato il contenitore in un nuovo gruppo amministrativo.

Operazione dell'utente

Per risolvere il problema, utilizzare ADSI Edit o uno strumento simile per determinare se il contenitore delle cartelle pubbliche esiste e se l'attributo msExchOwningPFTreeBL è configurato correttamente per fare riferimento all'archivio pubblico pertinente.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per determinare la causa dell'errore

  1. Individuare, mediante ADSI Edit o uno strumento simile, ogni oggetto gruppo amministrativo in Active Directory.

    L'oggetto gruppo amministrativo è reperibile in:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. Espandere ogni gruppo amministrativo e verificare se è presente il contenitore CN=Folder Hierarchies. Se il contenitore CN=Folder Hierarchies esiste, evidenziarlo e verificare che l'oggetto CN=Public Folders sia presente nel riquadro di destra. Se non esistono oggetti CN=Public Folders nei gruppi amministrativi, passare alla Soluzione 1: ricreare le gerarchie delle cartelle e i contenitori delle cartelle pubbliche. Se viene rilevato un contenitore CN=Public Folders, procedere al passaggio 3.

  3. Fare clic con il pulsante destro del mouse sull'oggetto CN=Public Folders, quindi scegliere Proprietà.

  4. Nell'elenco Attributi, selezionare l'attributo msExchOwningPFTreeBL, quindi scegliere Modifica.

  5. Accertarsi che l'archivio delle cartelle pubbliche interessato sia visualizzato nell'elenco Valori. In caso contrario, procedere alla Soluzione 2.
Soluzione 1: ricreare le gerarchie delle cartelle e i contenitori delle cartelle pubbliche

  1. Utilizzare ADSI Edit o uno strumento simile per individuare ed espandere Exchange Administrative Group (FYDIBOHF23SPDLT).

    L'oggetto Exchange Administrative Group (FYDIBOHF23SPDLT) è reperibile in:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups

  2. Fare clic con il pulsante destro del mouse sull'oggetto Exchange Administrative Group (FYDIBOHF23SPDLT), scegliere Nuovo, quindi Oggetto.

  3. Dall'elenco Selezionare una classe selezionare msExchPublicFolderTreeContainer e fare clic su Avanti.

  4. Nella casella Valore digitare Gerarchie cartelle, fare clic su Avanti, quindi su Fine.

  5. Fare clic col pulsante destro del mouse sull'oggetto Gerarchie cartelle appena creato e scegliere Nuovo, quindi Oggetto.

  6. Dall'elenco Selezionare una classe selezionare msExchPFTree e fare clic su Avanti.

  7. Nella casella Valore digitare Cartelle pubbliche, quindi fare clic su Avanti.

  8. Fare clic su Altri attributi.

  9. Dal menu a discesa Selezionare una proprietà da visualizzare selezionare msExchPFTree.

  10. Nella casella Modifica attributo digitare 1, fare clic su Imposta, OK, quindi su Fine.

  11. Per assegnare il contenitore delle cartelle pubbliche a ogni archivio pubblico, fare clic con il pulsante destro del mouse sul contenitore Cartelle pubbliche e scegliere Proprietà.

  12. Dall'elenco Attributi selezionare distinguishedName, quindi fare clic su Modifica.

  13. Copiare il contenuto della casella Valore negli Appunti, quindi fare clic su Annulla.

  14. Per ogni server sul quale è stato rilevato l'evento MSExchangeIS 9519 con codice di errore 0x972, accedere all'oggetto Archivio cartelle pubbliche. Il percorso predefinito dell'oggetto è il seguente:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= NomeServer , CN= InformationStore , CN=Second Storage Group.

  15. Fare clic con il pulsante destro del mouse sull'oggetto Archivio cartelle pubbliche, quindi scegliere Proprietà.

  16. Dall'elenco Attributi selezionare msExchOwningPFTree, quindi fare clic su Modifica.

  17. Incollare il valore copiato negli Appunti al passaggio 13 nella casella Valore, quindi fare clic su OK due volte per terminare la procedura.

  18. Ripetere i passaggi da 15 a 17 per ogni server nel quale è stato rilevato l'evento MSExchangeIS 9519 con codice di errore 0x972.

  19. Riavviare il servizio Archivio informazioni di Microsoft Exchange sui server interessati.

Soluzione 2: ripopolare il valore dell'attributo msExchOwningPFTreeBL per l'oggetto contenitore delle cartelle pubbliche

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto Cartelle pubbliche in Active Directory.

    L'oggetto Cartelle pubbliche è reperibile in:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Folder Hierarchies,CN=Public Folders

  2. Fare clic con il pulsante destro del mouse sul contenitore Cartelle pubbliche e selezionare Proprietà.

  3. Dall'elenco Attributi selezionare distinguishedName, quindi fare clic su Modifica.

  4. Copiare il contenuto della casella Valore negli Appunti, quindi fare clic su Annulla.

  5. Per ogni server sul quale è stato rilevato l'evento MSExchangeIS 9519 con codice di errore 0x972, accedere all'oggetto Archivio cartelle pubbliche. Il percorso predefinito dell'oggetto è il seguente:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT), CN=Servers, CN= NomeServer , CN= InformationStore , CN=Second Storage Group.

  6. Fare clic con il pulsante destro del mouse sull'oggetto Archivio cartelle pubbliche, quindi scegliere Proprietà.

  7. Dall'elenco Attributi selezionare msExchOwningPFTree, quindi fare clic su Modifica.

  8. Incollare il valore copiato negli Appunti al passaggio 4 nella casella Valore, quindi fare clic su OK due volte per terminare la procedura.

  9. Ripetere i passaggi da 6 a 8 per ogni server nel quale è stato rilevato l'evento MSExchangeIS 9519 con codice di errore 0x972.

  10. Riavviare il servizio Archivio informazioni di Microsoft Exchange sui server interessati.


Cluster di Exchange
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente ai cluster di Exchange. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere avvisi, messaggi di errore e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi al cluster di Exchange.


Il debug dei cluster è abilitato
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il debug dei cluster è abilitato sul server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Cluster\Debug

Se Exchange Server Analyzer rileva che il valore Debug equivale a 1, verrà visualizzato un avviso.

Questo valore del Registro di sistema per il debug dei cluster impedisce il failover di tutte le risorse cluster tra i nodi. È consigliabile utilizzare questo valore del Registro di sistema solo se si verifica un problema di debug per cui sia necessario impedire il failover delle risorse.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per disabilitare la chiave del Registro di sistema per il debug dei cluster

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a HKLM\Software\Microsoft\Exchange\Cluster.

  3. Modificare il valore Debug impostandolo su 0.

  4. Uscire dall'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui cluster Exchange, consultare l'argomento "Gestione dei cluster di Exchange" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


Priorità di rete heartbeat dedicata per il cluster impostata in modo non corretto
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'ordine di priorità di ciascuna risorsa dell'interfaccia di rete nel cluster di Exchange Server:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Priority

Il valore di Priority indica la priorità di rete configurata per la risorsa dell'interfaccia di rete. La risorsa dell'interfaccia di rete con la priorità più alta presenta il valore 1, quella successiva più alta presenta il valore 2 e così via.

Exchange Server Analyzer legge anche la seguente voce del Registro di sistema per determinare il ruolo definito per ciascuna rete nel cluster di Exchange Server:

HKLM\Cluster\Networks\<GUIDInterfacciaDiRete>\Role

Il valore 1 indica che la risorsa di rete è stata configurata come rete privata dedicata (heartbeat). Il valore 2 indica che la risorsa di rete è stata configurata come rete pubblica dedicata (accesso client). Il valore 3 indica che la risorsa di rete è stata configurata come rete mista che consente sia il traffico heartbeat che il traffico di accesso client.

Se Exchange Server Analyzer determina che una risorsa dell'interfaccia di rete con un valore di Role pari a 1 presenta un valore di Priority maggiore di 1, verrà visualizzato un avviso. L'avviso indica che è stata rilevata una rete heartbeat dedicata, ma la relativa priorità non è impostata in modo corretto.

La configurazione di una rete privata dedicata da utilizzare per la risorsa heartbeat cluster è consigliabile per tutti i cluster Exchange Server. La comunicazione tra i nodi è fondamentale per operazioni cluster senza problemi. Utilizzare le istruzioni riportate di seguito per configurare in modo corretto la priorità di rete per la rete heartbeat dedicata.

Per risolvere il problema

  1. Aprire il programma di amministrazione dei cluster e connettersi al cluster di Exchange Server.

  2. Nel riquadro sinistro fare clic con il pulsante destro del mouse sull'oggetto Cluster situato in cima alla gerarchia, quindi scegliere Proprietà.

  3. Fare clic su Priorità rete.

  4. Selezionare la risorsa di rete heartbeat dedicata.

  5. Fare clic su Sposta su fino a quando la risorsa di rete heartbeat dedicata non viene posizionata in cima alle risorse di rete elencate.

  6. Fare clic su OK.

Per ulteriori informazioni sulle reti heartbeat cluster, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 258750, "Configurazione consigliata per la rete "heartbeat" privata su un server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.

  • 307962, "Supporto multicast abilitato per l'heartbeat cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962.

Per ulteriori informazioni, consultare Exchange Server 2003 Cluster Configuration Checklist all'indirizzo http://go.microsoft.com/fwlink/?linkid=36083 (informazioni in lingua inglese).


Il numero di build di Windows per i nodi cluster non corrisponde a quello del primo nodo
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione principale del sistema operativo Microsoft Windows® in esecuzione su ogni nodo del cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Numero Nodo>\BuildNumber

Se Exchange Server Analyzer rileva che il valore di BuildNumber nel secondo o successivo nodo del cluster di Exchange è diverso dal valore di BuildNumber nel primo nodo del cluster di Exchange, verrà visualizzato un messaggio di errore.

Se un cluster di Exchange viene eseguito in diverse versioni di Windows, è possibile che il failover non si verifichi come previsto o configurato. In un ambiente Windows in cui sono presenti versioni precedenti insieme a versioni più recenti del sistema operativo, il failover si verificherà solo da un sistema operativo precedente a uno successivo (ad esempio, da Windows 2000 Advanced Server a Windows Server™ 2003 Enterprise Edition). Non si verificherà, invece, da un sistema operativo successivo a uno precedente (ad esempio, da Windows Server 2003 a Windows 2000 Server).

Per risolvere il problema è necessario aggiornare tutti i nodi in modo che eseguano la stessa versione del sistema operativo e del relativo Service Pack. Per ridurre al minimo i tempi di inattività, è possibile eseguire un aggiornamento in sequenza del cluster.

Per risolvere il problema

  1. Per rivedere le istruzioni per l'esecuzione di un aggiornamento in sequenza di un cluster, consultare l'articolo 811272 della Microsoft Knowledge Base "Esecuzione di un aggiornamento in sequenza di cluster di server Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272.

  2. Esaminare l'articolo "Windows 2000 Clustering: Performing a rolling upgrade" all'indirizzo http://go.microsoft.com/fwlink/?linkid=1718 (informazioni in lingua inglese).

  3. Eseguire un aggiornamento in sequenza di ogni nodo il cui valore BuildNumber non sia lo stesso di quello del primo nodo del cluster.

Per informazioni sulle procedure alternative, consultare "Alternatives to Rolling Upgrades" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41363 (informazioni in lingua inglese).


La versione del Service Pack di Windows per i nodi cluster non corrisponde a quella del primo nodo
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione del Service Pack di Microsoft Windows® installato su ogni nodo del cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\<Numero nodo>\CSDVersion

Se Exchange Server Analyzer rileva che il valore per CSDVersion nel secondo o successivo nodo del cluster di Exchange è diverso dal valore per CSDVersion nel primo nodo del cluster di Exchange, verrà visualizzato un messaggio di errore.

Questo messaggio indica che sui nodi di questo cluster di Exchange non è in esecuzione la stessa versione del Service Pack di Windows. Si consiglia di eseguire su tutti i nodi del cluster di Exchange la stessa versione del sistema operativo e del Service Pack.

Per risolvere il problema è necessario aggiornare tutti i nodi in modo che eseguano la stessa versione del sistema operativo e del relativo Service Pack. Per ridurre al minimo i tempi di inattività, è possibile eseguire un aggiornamento in sequenza del cluster.

Per risolvere il problema

  1. Per rivedere le istruzioni per l'esecuzione di un aggiornamento in sequenza di un cluster, consultare l'articolo 811272 della Microsoft Knowledge Base "Esecuzione di un aggiornamento in sequenza di cluster di server Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=811272.

  2. Esaminare l'articolo "Windows 2000 Clustering: Esecuzione di un aggiornamento in sequenza" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34288.

  3. Eseguire un aggiornamento in sequenza di ogni nodo il cui valore CSDVersion è diverso da quello del primo nodo del cluster.

Per informazioni sulle procedure alternative, consultare "Alternative agli aggiornamenti in sequenza" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34289.


Il percorso TEMP/TMP del cluster si trova sulla stessa unità della partizione di sistema
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

In un computer Exchange Server non cluster, Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare il valore delle variabili di ambiente TEMP e TMP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Quando Exchange Server Analyzer viene eseguito su un server virtuale di Exchange (EVS) in un cluster di server Microsoft Windows®, non legge l'hive del Registro di sistema HKLM. Invece, legge le seguenti voci del Registro di sistema:

HKEY_USERS\<SID account servizio cluster>\Environment\TEMP

HKEY_USERS\<SID account servizio cluster>\Environment\TMP

Se Exchange Server Analyzer rileva che le variabili di ambiente TEMP e/o TMP iniziano con %SYSTEMROOT, verrà visualizzato un avviso.

Il servizio Archivio informazioni di Microsoft Exchange consente di utilizzare le cartelle TEMP e TMP come archivio temporaneo durante alcune operazioni, ad esempio nelle operazioni di conversione dei messaggi o spostamento delle cassette postali. Su un server di Exchange non cluster il servizio Archivio informazioni di Microsoft Exchange consente di utilizzare SYSTEM (ad esempio, il sistema locale) in cui viene utilizzata l'impostazione predefinita delle variabili di ambiente %Systemroot%\Temp sia per TEMP sia per TMP.

Nei server virtuali di Exchange in esecuzione su cluster di Windows Server vengono utilizzate le impostazioni delle variabili di ambiente per l'account del servizio cluster, che viene eseguito nel contesto di protezione specifico di un utente. Per gli account utente, la variabile di ambiente predefinita per TEMP e TMP è impostata su %Userprofile%\temp.

Le variabili di ambiente TEMP e TMP vengono utilizzate per determinare quali cartelle del file system (ad esempio, quale percorso) deve essere utilizzato dalle applicazioni che richiedono un'area di lavoro temporanea. In genere, la variabile TEMP viene utilizzata da applicazioni quali Exchange, mentre la variabile TMP da strumenti di sviluppo quali Microsoft Visual C++®. Il percorso di ciascuna variabile generalmente è relativo al contesto di protezione dell'applicazione o dello strumento.

Per prestazioni ottimali, è consigliabile non utilizzare il disco contenente il sistema operativo per le cartelle TEMP e TMP utilizzate da Exchange. È inoltre preferibile assicurarsi che tali variabili di ambiente siano impostate su percorsi che si trovano su un disco rapido o un sottosistema disco, ad esempio un set di spindle RAID 0+1. È inoltre consigliabile non utilizzare il disco contenente il sistema operativo per le cartelle TEMP e TMP utilizzate da Exchange o da server virtuali di Exchange.

Per risolvere il problema

  1. Accedere a un nodo nel cluster tramite l'account del servizio cluster.

  2. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà.

  3. Fare clic su Avanzate.

  4. Fare clic su Variabili di ambiente.

  5. Nell'area Variabili utente per <nome account>, selezionare TEMP e fare clic su Modifica.

  6. Nel campo Valore variabile immettere il nuovo percorso per la variabile ambiente TEMP e fare clic su OK.

  7. Nell'area Variabili utente per <nome account>, selezionare TMP e fare clic su Modifica.

  8. Nel campo Valore variabile immettere il nuovo percorso per la variabile ambiente TMP e fare clic su OK.

  9. Per chiudere la finestra di dialogo Variabili di ambiente, fare clic su OK e per chiudere la finestra di dialogo Proprietà del sistema, fare clic di nuovo su OK.

  10. Riavviare il nodo per rendere effettiva la modifica.

  11. Ripetere i passaggi da 1 a 10 per ciascun nodo nel cluster.

Per ulteriori informazioni sulla modifica delle variabili di ambiente TEMP/TMP su un computer Exchange Server non raggruppato, consultare La variabile TEMP/TMP potrebbe fare riferimento a una cartella non valida o non appropriata.


Heartbeat del cluster dedicato non trovato
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il ruolo definito per ciascuna risorsa dell'interfaccia di rete nel cluster di Exchange Server:

HKEY_LOCAL_MACHINE\Cluster\Networks\<NetworkInterfaceGUID>\Role

Il valore 1 indica che la risorsa di rete è stata configurata come rete privata dedicata (heartbeat). Il valore 2 indica che la risorsa di rete è stata configurata come rete pubblica dedicata (accesso client). Il valore 3 indica che la risorsa di rete è stata configurata come rete mista che consente sia il traffico heartbeat che il traffico di accesso client.

Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster di Windows (ClusSvc). Il valore True indica che il servizio cluster è avviato, mentre il valore False indica che non è in esecuzione.

Se Exchange Server Analyzer non rileva una risorsa di rete in un cluster di Exchange configurato come rete privata dedicata, verrà visualizzato un avviso.

Si consiglia di configurare per tutti i cluster di Exchange Server una rete privata dedicata da utilizzare per l'heartbeat cluster. La comunicazione tra i nodi è fondamentale per operazioni cluster senza problemi. È necessario configurare le reti utilizzate per la comunicazione del cluster in modo ottimale e attenersi a tutti i requisiti dell'elenco di compatibilità hardware. Per la configurazione di rete è necessario che due o più reti indipendenti colleghino i nodi di un cluster per evitare un singolo punto di errore. In genere si utilizzano due reti LAN. Il Servizio Supporto Tecnico Clienti Microsoft non supporta la configurazione di un cluster con nodi collegati da una sola rete.

Per risolvere il problema

  1. Se non è già presente, aggiungere schede di interfaccia di rete a ciascun nodo del cluster Exchange e configurarle come reti private nel programma di amministrazione dei cluster.

  2. Se sono presenti schede di rete aggiuntive ma sono utilizzate per reti miste, è necessario riconfigurare le reti appropriate come reti private dedicate.

Per ulteriori informazioni sulle reti heartbeat cluster, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 258750, "Configurazione consigliata per la rete "heartbeat" privata su un server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.

  • 307962, "Supporto multicast abilitato per l'heartbeat cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307962.

Per ulteriori informazioni, consultare Exchange Server 2003 Cluster Configuration Checklist all'indirizzo http://go.microsoft.com/fwlink/?linkid=36083 (informazioni in lingua inglese).


È necessario aumentare la dimensione file predefinita per il file cluster.log impostandola sul valore 32
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il parametro ClusterLogSize è stato impostato:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\

Se Exchange Server Analyzer rileva che il valore ClusterLogSize non è presente o che il valore ClusterLogSize è minore o uguale a 8, verrà visualizzato un avviso. Su un cluster occupato, il file cluster.log viene scritto con velocità tale che alcune voci potrebbero andare perse quando si risolvono situazioni di failover nelle seguenti circostanze:

  • La risoluzione dei problemi richiede un'analisi dettagliata del file di registro del cluster.

  • Il cluster gestisce molte risorse.

Pertanto, quando la risoluzione dei problemi richiede l'utilizzo del file cluster.log, è necessario creare il parametro ClusterLogSize, se non è già presente, e aumentare la dimensione predefinita impostandola almeno sul valore 32, 64 o 96.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per creare il parametro ClusterLogSize e impostarne il valore

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedit32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Nel riquadro sinistro fare clic su Environment.

  4. Dal menu Modifica scegliere Nuovo, quindi Valore DWORD.

  5. Digitare ClusterLogSize, quindi premere INVIO per assegnare un nome alla nuova voce del Registro di sistema.

  6. Fare clic con il pulsante destro del mouse su ClusterLogSize, quindi scegliere Modifica.

  7. Modificare il campo Dati valore di ClusterLogSize impostandolo su una dimensione diversa del file di registro. Ad esempio, impostare il valore ClusterLogSize su 32, 64 o 96, quindi premere INVIO.

  8. Uscire dall'editor del Registro di sistema.
Per modificare la dimensione predefinita del file cluster.log

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment.

  3. Fare clic con il pulsante destro del mouse su ClusterLogSize, quindi scegliere Modifica.

  4. Modificare il campo Dati valore di ClusterLogSize impostandolo su una dimensione diversa del file di registro. Ad esempio, impostare il valore ClusterLogSize su 32, 64 o 96, quindi premere INVIO.

  5. Uscire dall'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla registrazione cluster in Microsoft Cluster Server, consultare l'articolo 168801 della Microsoft Knowledge Base "Attivazione della registrazione cluster in Microsoft Cluster Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=168801.


Abilitazione dell'autenticazione Kerberos per SMTP
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2006-05-12

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il server Microsoft Exchange Server 2003 installato in un servizio cluster di Windows™ Server 2003 dispone del nome di dominio completo del server come valore della risorsa SMTPSVC dell'attributo servicePrincipalName.

Se Exchange Server Analyzer rileva che l'attributo servicePrincipalName della risorsa di Exchange SMTPSVC del servizio cluster non contiene il nome di dominio completo del server come valore, verrà visualizzato un messaggio di configurazione ottimale.

È consigliabile abilitare l'autenticazione Kerberos per i servizi SMTP (Simple Mail Transfer Protocol) nei server cluster di Windows Server 2003 che eseguono Exchange Server 2003. È possibile abilitare l'autenticazione Kerberos impostando manualmente un nuovo valore per il nome principale di servizio (SPN, Service Principal Name) della risorsa di Exchange SMTPSVC.

Per impostazione predefinita, Windows Server 2003 utilizza l'autenticazione NTLM. Il protocollo Kerberos è più flessibile, efficiente e sicuro dell'autenticazione NTLM. Di seguito vengono riportati i vantaggi ottenuti utilizzando l'autenticazione Kerberos:

  • Connessioni più veloci. Con l'autenticazione NTLM, un server applicazioni deve connettersi a un controller di dominio per autenticare ogni client. Con l'autenticazione Kerberos, il server non deve individuare il controller di dominio. Il server può autenticare il client esaminando le credenziali presentate dal client. I client possono ottenere una sola volta le credenziali per un determinato server e riutilizzarle in una sessione di accesso alla rete.

  • Autenticazione reciproca. NTLM abilita i server per la verifica delle identità dei client. NTLM non abilita i client per la verifica dell'identità del server né abilita un server per la veriifica dell'identità di un altro server. L'autenticazione NTLM è stata progettata per un ambiente di rete in cui si presupponeva che i server fossero autentici. Il protocollo Kerberos non si basa su una tale presupposizione. Le parti alle due estremità di una connessione di rete sono in grado di sapere che la parte che si trova all'altra estremità è chi asserisce di essere.

  • Autenticazione delegata. I servizi Windows rappresentano i client durante l'accesso alle risorse per conto dei client. Spesso un servizio è in grado di completare la propria attività per il client accedendo alle risorse nel computer locale. NTLM e Kerberos forniscono entrambi le informazioni di cui deve disporre un servizio per rappresentare il client localmente. Tuttavia, alcune applicazioni distribuite sono progettate in modo tale che un servizio front-end debba rappresentare i client quando si connette ai servizi back-end in altri computer. Il protocollo Kerberos utilizza un meccanismo proxy che abilita un servizio alla rappresentazione del client quando si connette ad altri servizi. Nessun servizio equivalente è disponibile in NTLM.

Per risolvere il problema, seguire i passaggi riportati di seguito per aggiungere i valori mancanti per gli attributi interessati.

Utilizzare lo strumento SETSPN.exe per aggiungere un nome principale di servizio ai valori mancanti

  1. Installare lo strumento Setspn.exe. Per ottenere lo strumento Setspn.exe, vedere "Windows 2000 Resource Kit Tool: Setspn.exe" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=28103 (informazioni in lingua inglese).

    La versione di Windows Server 2003 dello strumento con riga di comando Setspn.exe è disponibile con gli strumenti di supporto di Windows Server 2003 inclusi nel CD di Windows Server 2003. Per installare gli strumenti di supporto di Windows Server 2003, fare doppio clic sul file Suptools.msi nella cartella Support/Tools.

  2. Seguire le informazioni aggiuntive del file SETSPN.EXE Setspn_d.txt per aggiungere il valore mancante all'oggetto Active Directory per il server di Exchange. Nell'esempio seguente viene illustrata l'aggiunta del valore del nome di dominio completo per un nome principale di servizio del server SMTP virtuale:

    • Avviare un prompt dei comandi, quindi passare alla directory in cui è installato Setspn.exe.

    • Al prompt dei comandi, digitare il seguente comando:

      setspn.exe-a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      Nota:
      Sostiuire mail.yourdomain.com con il nome di dominio completo del server virtuale SMTP e YOURSERVERNAME con il nome del server di Exchange.
    • Premere Invio.


Impossibile contattare il nodo cluster di Exchange
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster (ClusSvc). Il valore True indica che il servizio cluster è avviato, mentre il valore False indica che non è in esecuzione.

Exchange Server Analyzer legge anche la seguente voce del Registro di sistema per determinare la versione di Windows in esecuzione sul computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue Windows Server™ 2003.

Se Exchange Server Analyzer non determina la versione di Windows in esecuzione sul cluster o non riesce a individuare se il servizio cluster è in esecuzione, verrà visualizzato un messaggio di errore. Questo errore indica che Exchange Server Analyzer non riesce a contattare un nodo in un cluster Exchange Server.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando ping per verificare che il computer Exchange Server sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC (Remote Procedure Call) sono bloccate.

  4. Verificare che il servizio Registro di sistema remoto sul computer Exchange Server sia stato avviato.

  5. Controllare le autorizzazioni dell'account utilizzato per l'esecuzione di Exchange Server Analyzer per verificare che siano sufficienti per leggere il Registro di sistema nel computer Exchange Server.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, consultare l'articolo 325847 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.


Il percorso dati di Exchange in Active Directory non corrisponde al registro cluster
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2006-04-28

Microsoft® Exchange Server Analyzer Tool esegue una query nel registro cluster (HKEY_LOCAL_MACHINE\Cluster) e nel servizio directory di Active Directory® per determinare se i percorsi dei file di dati di Exchange (ad esempio i file di registro di verifica messaggi) sono gli stessi in entrambe le posizioni. Questi valori vengono configurati nel Registro di sistema e in Active Directory se il programma di installazione di Exchange viene utilizzato per installare Exchange in un node all'interno di un server cluster di Microsoft Windows®.

Il valore del Registro di sistema creato dal programma di installazione di Exchange e letto da Exchange Server Analyzer è:

HKLM\Cluster\Resources\<GUID della risorsa Archivio informazioni>\Parameters\DestPath

Il valore di Active Directory creato dal programma di installazione di Exchange e letto da Exchange Server Analyzer è: msExchDataPath. Questo valore è un attributo dell'oggetto computer Exchange Server in Active Directory, reperibile in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName =Administrative Groups, CN= NomeGruppoAmministrativo , CN=Servers, CN= ServerName

Se Exchange Server Analyzer rileva che il i valori per DestPath e msExchDataPath non corrispondono, verrà visualizzato un messaggio di errore.

Spesso vi è una discrepanza tra questi valori quando la posizione di alcuni o di tutti i file di dati di Exchange viene modificata. Ad esempio, se l'hardware viene aggiornato, i file di registro di verifica messaggi vengono spostati e una lettera corrispondente a un'unità viene modificata, le modifiche vengono riflettute nel registro cluster, ma non in Active Directory. Dopo una tale modifica, errori di avvio del servizio, problemi di installazione del database e altri problemi potrebbero verificarsi, specialmente durante l'installazione di un Service Pack o di un aggiornamento cumulativo di Exchange.

Nota:
È preferibile correggere al più presto questa discrepanza. Non installare nessun Service Pack o aggiornamento sul server di Exchange fino alla risoluzione del problema.

Per eseguire la seguente procedura, sarà necessario utilizzare un editor di Active Directory come ADSI Edit (Active Directory Service Interfaces) o lo strumento LDP (ldp.exe).

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Modificare il valore msExchDataPath del server virtuale di Exchange (EVS) interessato in modo che corrisponda al valore del registro cluster di DestPath. L'attributo msExchDataPath è reperibile in: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName

  2. Riavviare la risorsa di Supervisore sistema di Microsoft Exchange del server virtuale per rendere effettiva la modifica.

Per ulteriori informazioni sulla modifica di Active Directory con lo strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745.

Per ulteriori informazioni su come utilizzare ADSI Edit per modificare l'attributo msExchDataPath, consultare l'articolo 288362 della Microsoft Knowledge Base "XADM: Il messaggio dell'ID evento 5007 "Impossibile trovare il percorso specificato" viene registrato dal Supervisore sistema di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=288362.


La replica del registro eventi è abilitata
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema su ciascun server che corrisponde a un nodo cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\X\EnableEventLogReplication

Nota:
X indica il numero del nodo, iniziando da 1.

Se Exchange Server Analyzer rileva che il valore di EnableEventLogReplication è 1, verrà visualizzato un messaggio di configurazione ottimale.

Se la voce EnableEventLogReplication del Registro di sistema è impostata su 1, il nodo cluster replica gli eventi nel registro eventi a tutti gli altri nodi del cluster. Se è abilitata la replica nel registro eventi, gli strumenti che eseguono il monitoraggio di più server, ad esempio Microsoft Operations Manager (MOM), segnalano un singolo evento più volte, ovvero una volta da ciascun nodo. Se si utilizza il monitoraggio automatico, si consiglia di disabilitare la replica del registro eventi sui nodi cluster.

Per disabilitare la replica del registro eventi su tutti i nodi di un cluster

  1. Connettersi a un nodo del cluster tramite un account utente del dominio oppure un account di un membro di un gruppo globale.

  2. Fare clic su Start, scegliere Esegui, quindi digitare

    cluster /prop EnableEventLogReplication=0
Per disabilitare la replica del registro eventi su un singolo nodo cluster

  1. Connettersi a un nodo del cluster tramite un account utente del dominio oppure un account di un membro di un gruppo globale.

  2. Fare clic su Start, scegliere Esegui, quindi digitare

    Cluster <il nome del nodo da disabilitare> /prop EnableEventLogReplication=0

Per ulteriori informazioni sulla procedura di configurazione della replica del registro eventi, consultare l'articolo 224969 della Microsoft Knowledge Base "HOW TO: Configurazione della replica del registro degli eventi nei server cluster in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224969.

Per ulteriori informazioni sulla gestione dei cluster di server, consultare Administering Server Clusters all'indirizzo http://go.microsoft.com/fwlink/?LinkId=45971 (informazioni in lingua inglese).


Kerberos disabilitato sulla risorsa Nome rete
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di Microsoft Windows® in esecuzione sul server di Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue Windows Server™ 2003.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Exchange Server 2003.

Infine, Exchange Server Analyzer legge il seguente valore del Registro di sistema per determinare se Exchange Server è in esecuzione in un cluster con una risorsa cluster Nome rete abilitata per Kerberos:

HKLM\Cluster\Resources\<GUID della risorsa Nome rete>\Parameters\RequireKerberos

Il valore 0 per RequireKerberos indica che la risorsa Nome rete non è abilitata per Kerberos, mentre il valore 1 indica che tale risorsa è abilitata per Kerberos.

Se Exchange Server Analyzer rileva che il valore di RequireKerberos è impostato su 0 in un server virtuale di Exchange Server 2003 che viene eseguito in un cluster basato su server di Windows Server 2003, verrà visualizzato un avviso.

L'avviso indica che non viene utilizzata una risorsa cluster Nome rete abilitata per Kerberos per un server virtuale di Exchange Server 2003. Questa configurazione non è supportata e deve essere corretta appena possibile.

Per risolvere il problema

  1. Aprire il programma di amministrazione dei cluster.

  2. Disconnettere la risorsa Nome rete. Questa operazione comporterà la disconnessione anche di tutte le risorse che dipendono da Nome rete, inclusa la risorsa di Supervisore sistema di Microsoft Exchange.

  3. Fare clic con il pulsante destro del mouse sulla risorsa Nome rete, quindi scegliere Proprietà.

  4. Nella scheda Parametri fare clic sull'opzione Abilita autenticazione Kerberos, quindi su OK.

  5. Portare in linea la risorsa Nome rete, quindi anche le altre risorse ancora non in linea.

Per ulteriori informazioni sull'utilizzo di risorse Nome rete abilitate per Kerberos in un cluster di Windows Server 2003, consultare l'articolo 302389 della Microsoft Knowledge Base "Descrizione delle proprietà della risorsa cluster Nome rete in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=302389.

Per ulteriori informazioni sul clustering, consultare i seguenti argomenti:

  • "Distribuzione di Exchange 2003 in un cluster" nel Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47569.

  • "Pianificazione del clustering di Exchange" nella Guida alla massima disponibilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47571.


Kerberos abilitato sulla risorsa Nome rete
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di Microsoft Windows® in esecuzione sul server di Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue un sistema operativo Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue un sistema operativo Windows Server™ 2003.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa include "Version 5.5", il computer esegue Microsoft Exchange Server 5.5. Se la stringa include "Version 6.0", il computer esegue Microsoft Exchange 2000 Server. Se la stringa include "Version 6.5", il computer esegue Microsoft Exchange Server 2003.

Infine, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se Exchange viene eseguito in un cluster con una risorsa Nome rete abilitata per Kerberos:

HKLM\Cluster\Resources\<GUID della risorsa Nome rete>\RequireKerberos

Il valore 0 per RequireKerberos indica che la risorsa Nome rete non è abilitata per Kerberos, mentre il valore 1 indica che tale risorsa è abilitata per Kerberos.

Se Exchange Server Analyzer rileva che il valore di RequireKerberos è impostato su 1 in un server virtuale di Exchange 2000 Server che viene eseguito in un cluster basato su server di Windows 2000 Server, verrà visualizzato un avviso.

Questo avviso indica che per il server virtuale Exchange 2000 Server viene utilizzata una risorsa cluster Nome rete abilitata per Kerberos. Questa configurazione non è supportata e deve essere corretta appena possibile. Come illustrato nell'articolo 235529 della Microsoft Knowledge Base "Supporto Kerberos nei cluster di server basati su Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529, l'autenticazione Kerberos per una risorsa Nome rete di Exchange 2000 Server non è supportata. Exchange 2000 Server non è stato testato per garantire che un server virtuale Exchange 2000 Server supporti l'autenticazione Kerberos.

Per risolvere il problema

  1. Aprire un prompt dei comandi in un qualsiasi nodo del cluster.

  2. Eseguire il comando seguente: cluster res "Nome della risorsa Nome rete" /priv requirekerberos=0:dword

    Nota:
    Il nome della risorsa deve essere racchiuso tra virgolette.

  3. Portare la risorsa Nome rete non in linea e cancellarla.

  4. Aprire Utenti e computer di Active Directory.

  5. Individuare l'oggetto account del computer della risorsa Nome rete eliminata, quindi eliminarlo da Active Directory.

  6. Creare una nuova risorsa Nome rete per questo server virtuale di Exchange (EVS, Exchange Virtual Server) e non applicare l'abilitazione Kerberos. È possibile utilizzare lo stesso nome e la stessa configurazione della risorsa Nome rete eliminata nel passaggio 3.

  7. Portare la risorsa Nome rete in linea, quindi anche le restanti risorse di EVS.

Per ulteriori informazioni sull'utilizzo delle risorse Nome rete abilitate per Kerberos in un cluster Windows 2000 Server, consultare l'articolo 235529 della Microsoft Knowledge Base "Supporto Kerberos nei cluster di server basati su Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=235529.


Risorsa MSDTC mancante da un cluster
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare l'esistenza della risorsa MSDTC (Microsoft Distributed Transaction Coordinator) in un cluster:

HKEY_LOCAL_MACHINE\Cluster\Resources\

Se il valore di ClusterMSDTCInstance è 0, verrà visualizzato un avviso.

Per supportare l'installazione iniziale e l'aggiornamento del Service Pack, è necessario che la risorsa MSDTC sia presente in un cluster di Exchange Server. Tuttavia non si tratta di un componente fondamentale e non è necessario se Exchange è in esecuzione.

L'amministratore dell'organizzazione potrebbe aver rimosso la risorsa MSDTC in quanto non necessaria se Exchange è in esecuzione.

Tuttavia, non è consigliabile rimuovere la risorsa MSDTC dopo l'installazione iniziale di Exchange Server 2003. Se la risorsa MSDTC viene conservata nel cluster, sarà possibile eseguire l'installazione dei Service Pack e altri aggiornamenti.

Per risolvere il problema indicato in questo avviso, creare una nuova risorsa MSDTC. Per la procedura specifica di creazione di una risorsa MSDTC, consultare "Installazione di Microsoft Distributed Transaction Coordinator in un cluster di server di Windows Server 2003" in "Distribuzione di Exchange Server 2003 in un cluster" nella Guida alla distribuzione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni

Per ulteriori informazioni su MSDTC ed Exchange, consultare "Gruppi di cluster" in "Concetti relativi al clustering di Exchange Server 2003" nella Guida alla elevata disponibilità di Exchange 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47571.

Per ulteriori informazioni su come aggiungere la risorsa MSDTC in Microsoft Windows Server™ 2003, consultare l'articolo 301600 della Microsoft Knowledge Base "Configurazione di Microsoft Distributed Transaction Coordinator in un cluster Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600.

Nota:
L'articolo 301600 della Microsoft Knowledge Base include un riferimento all'articolo 817064 "HOW TO: Abilitare l'accesso DTC alla rete in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064. Per motivi di protezione, non è consigliabile abilitare l'accesso di rete DTC per un cluster di Exchange. Se si sta configurando la risorsa DTC per un cluster di Exchange, non abilitare l'accesso DTC alla rete.


Le interruzioni della risorsa MSDTC influiranno sul gruppo cluster
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se la configurazione prevede che un errore nella risorsa MSDTC (Microsoft Distributed Transaction Coordinator) influisca sul gruppo:

HKEY_LOCAL_MACHINE\Cluster\Resources\

Se il valore di ClusterMSDTCInstance è 2, verrà visualizzato un avviso.

Per supportare l'installazione iniziale e l'aggiornamento del Service Pack, è necessario che la risorsa MSDTC sia presente in un cluster di Exchange. Non è necessario se Exchange è in esecuzione.

Per impostazione predefinita, un errore nella risorsa MSDTC influisce sul gruppo. Di seguito sono vengono riportati due esempi di errore nella risorsa:

  • La dimensione del file di registro supera la capacità del disco.

  • Errore nel disco fisico della risorsa MSDTC.

Nello specifico, un errore nella risorsa MSDTC provoca un failover di tutti i servizi di Exchange in esecuzione nel nodo cluster a un nodo diverso del cluster. Tuttavia, poiché MSDTC non è una risorsa necessaria, non è indispensabile configurarla affinché influisca sul gruppo.

Per risolvere il problema indicato da questo avviso, configurare il cluster di Exchange in modo che un errore nella risorsa MSDTC non influisca sul gruppo.

Per configurare Exchange in modo che un errore nella risorsa MSDTC non influisca sul gruppo

  1. Accedere a un nodo del cluster.

  2. Fare clic su Start, scegliere Programmi, quindi Strumenti di amministrazione e infine Amministrazione cluster.

  3. In Gruppi fare clic con il pulsante destro del mouse sul gruppo cluster che include la risorsa MSDTC.

  4. Fare clic con il pulsante destro del mouse sulla risorsa MSDTC, quindi scegliere Proprietà.

  5. Nella scheda Avanzate deselezionare la casella di controllo Influisce sul gruppo, quindi fare clic su OK.

Per ulteriori informazioni

Per la procedura specifica di creazione di una risorsa MSDTC, consultare "Installazione di Microsoft Distributed Transaction Coordinator in un cluster di server di Windows Server 2003" in "Distribuzione di Exchange Server 2003 in un cluster" nella Guida alla distribuzione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni su MSDTC ed Exchange, consultare "Gruppi di cluster" in "Concetti relativi al clustering di Exchange Server 2003" nella Guida alla elevata disponibilità di Exchange 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47571.

Per ulteriori informazioni su come aggiungere la risorsa MSDTC in Microsoft Windows Server™ 2003, consultare l'articolo 301600 della Microsoft Knowledge Base "Configurazione di Microsoft Distributed Transaction Coordinator in un cluster Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301600.

Nota:
L'articolo 301600 della Microsoft Knowledge Base include un riferimento all'articolo 817064 "HOW TO: Abilitare l'accesso DTC alla rete in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=817064. Per motivi di protezione, non è consigliabile abilitare l'accesso di rete DTC per un cluster di Exchange. Se si sta configurando la risorsa DTC per un cluster di Exchange, non abilitare l'accesso DTC alla rete.


Le interruzioni dell'agente di trasferimento messaggi (MTA) influiranno sul gruppo cluster
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool analizza le impostazioni Cluster\Resources del Registro di sistema del sistema del server Exchange.

HKEY_LOCAL_MACHINE\Cluster\Resources

Se Exchange Server Analyzer rileva che le risorse del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi sono in esecuzione nel cluster di Exchange Server 2003 in un'organizzazione in modalità nativa, verrà visualizzato un messaggio di configurazione ottimale.

È consigliabile che l'amministratore di Exchange configuri la risorsa MTA in modo che non provochi un possibile failover del server virtuale di Exchange quando si verifica un errore nella risorsa MTA o quando la risorsa MTA si arresta.

Nota:
Il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi in Microsoft Exchange 2000 Server e Microsoft Exchange Server 2003 viene frequentemente utilizzato per fornire servizi di trasferimento messaggi compatibili con le versioni precedenti tra i server Exchange 2000 Server o Exchange Server 2003 e i server Microsoft Exchange Server 5.5 in un ambiente in modalità mista. Se la transizione viene effettuata verso un ambiente Exchange 2000 Server puro o un ambiente Exchange Server 2003 in modalità nativa, l'agente di trasferimento messaggi non è una risorsa fondamentale per l'esecuzione dei servizi di Exchange.

Se si verifica un errore nel servizio Microsoft Exchange - Stack Agente di trasferimento messaggi o il servizio si arresta, è possibile che venga attivato un failover del server virtuale di Exchange. Per evitare un possibile failover del server virtuale di Exchange (EVS), è consigliabile configurare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi nel modo seguente.

Per configurare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi in modo che lo stato non sia interessato in un cluster di Exchange Server

  1. Aprire Cluster Administrator

  2. Deselezionare l'opzione Affect this Group per la risorsa servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Per ulteriori informazioni

Per informazioni sulle linee guida per il supporto del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi per Exchange Server 2003, consultare l'articolo 810489 della Microsoft Knowledge Base "Linee guida per il supporto del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810489.

Per ulteriori informazioni sulla risorsa MTA nell'architettura di Exchange Server 2003, consultare "L'agente di trasferimento messaggi (MTA) di Exchange nell'architettura di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63496.

Per informazioni sulla distribuzione di Exchange Server 203 in un cluster, consultare "Distribuzione di Exchange 2003 in un cluster" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63495.

Per informazioni sull'utilizzo del programma di amministrazione dei cluster, consultare "Utilizzo di Amministrazione cluster per gestire i cluster di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63493.


Questo è un cluster attivo/attivo a 2 nodi
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2006-04-28

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per ClusSvc, il servizio cluster. Il valore True indica che il servizio cluster è in esecuzione, mentre il valore False indica che il servizio non è in esecuzione.

Inoltre, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare il numero di nodi nel cluster:

HKEY_LOCAL_MACHINE\Cluster\Nodes\ <Numero nodo> \NodeName

Il conteggio delle istanze di NodeName rappresenta il numero di nodi nel cluster. Inoltre, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare il numero di risorse di Exchange Server nel cluster:

HKLM\Cluster\Resources\ <GUID risorsa cluster> \Parameters\DestPath

Le seguenti risorse in un cluster di Exchange Server avranno un valore per DestPath:

  • Agente di trasferimento messaggi di Microsoft Exchange

  • Archivio informazioni di Microsoft Exchange

Il conteggio delle istanze di DestPath indica il numero di server che eseguono EVS (Exchange Virtual Server) nel cluster.

Se Exchange Server Analyzer rileva che sono presenti 3 istanze di DestPath in un cluster con 2 istanze di NodeName, verrà visualizzato un avviso. Tale avviso indica che si tratta di un cluster a due nodi con due server che eseguono EVS, noto come cluster attivo/attivo.

  • Nel modello di cluster attivo/attivo, il numero di server virtuali di Exchange nel cluster è uguale a o maggiore del numero di nodi fisici nel cluster.

Nota:
È possibile creare cluster attivo/attivo di Exchange solo in cluster composti di due nodi. Se si hanno almeno tre nodi nel cluster, è necessario utilizzare il modello attivo/passivo.
  • Nel modello di cluster attivo/passivo il numero di server virtuali di Exchange nel cluster è uguale a o minore del numero di nodi fisici nel cluster.

Sebbene Microsoft supporti la creazione di cluster attivo/attivo per Exchange Server, è consigliabile utilizzare implementazioni attivo/passivo per i cluster di Exchange. Microsoft supporta solo cluster attivo/attivo di Exchange che rispettano i seguenti limiti di scala:

  • Il numero di connessioni utente simultanee per ciascun server virtuale di Exchange per ciascun nodo fisico non deve esser mai maggiore di 1.900. Se un nodo del cluster non è disponibile e se tutti i server virtuali di sono in linea in un singolo nodo, i limiti di scala restano pari a 3.800 connessioni per i due server virtuali di Exchange. Poiché ogni utente può eseguire più connessioni, il numero di cassette postali non è un modo accurato per valutare il numero di connessioni.

  • L'utilizzo medio della CPU per ogni processo dell'archivio di Exchange non deve essere superiore al 40%. Se l'utilizzo totale della CPU da parte del processo STORE.EXE in un nodo è superiore al 40% per un periodo di almeno 10 minuti, è necessario spostare utenti su un altro server virtuale di Exchange o su un server di Exchange. Notare che questo carico non include l'utilizzo della CPU da parte di attività di amministrazione.

La migrazione da una configurazione cluster attivo/attivo a una configurazione attivo/passivo include lo spostamento delle risorse per rimuoverle dal secondo EVS e la successiva rimozione delle autorizzazioni per il server.

Per migrare da un cluster attivo/attivo a un cluster attivo/passivo

  1. Spostare le cassette postali ospitate sul secondo EVS nel primo EVS del cluster. Il primo EVS del cluster contiene sempre l'unica risorsa Agente di trasferimento messaggi (MTA) di Microsoft Exchange nel cluster.

  2. Dopo aver spostato tutte le cassette postali nel primo EVS, disconnettere il secondo EVS.

  3. Rimuovere il secondo EVS eseguendo una delle seguenti operazioni:

    • In un cluster di Exchange Server 2003 fare clic con il pulsante destro del mouse sulla risorsa Supervisore sistema di Microsoft Exchange e scegliere Rimuovi server virtuale di Exchange.

    • In un cluster di Exchange Server 2000 fare clic con il pulsante destro del mouse sulla risorsa Supervisore sistema di Microsoft Exchange e scegliere Elimina.

  4. Verificare che l'oggetto EVS sia stato rimosso dal servizio directory di Active Directory®. A causa di modifiche delle autorizzazioni dell'account del servizio cluster in Exchange Server 2003, l'account utente deve disporre delle autorizzazioni per rimuovere gli oggetti Active Directory.

  5. Disconnettere le restanti risorse nel secondo EVS (ad esempio, Disco fisico, Nome rete e Indirizzo IP), quindi eliminarle.

  6. Eliminare il gruppo di risorse che conteneva il secondo EVS.

Per ulteriori informazioni sulla rimozione di un EVS, consultare la sezione "Removing an Exchange virtual server from a Cluster" in Deploying Microsoft Exchange 2000 Server Clusters Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=9393 (informazioni in lingua inglese).

Per ulteriori informazioni sulle configurazioni ottimali e sulle operazioni consigliate per i cluster di Exchange, vedere il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sulla distribuzione di Exchange in un cluster di server Windows, consultare l'articolo 815180 della Microsoft Knowledge Base "Considerazioni sulla distribuzione di Exchange su un cluster attivo/attivo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815180.


Registro quorum troppo piccolo
Articoli su Microsoft Exchange Server Analyzer > Cluster di Exchange >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la dimensione del registro quorum configurata per il cluster:

HKEY_LOCAL_MACHINE\Cluster\Quorum\MaxQuorumLogSize

Se Exchange Server Analyzer rileva che il valore di MaxQuorumLogSize è inferiore a 4194304 decimale (0x400000 esadecimale), verrà visualizzato un avviso.

Il valore MaxQuorumLogSize del Registro di sistema rappresenta il valore attualmente configurato per il parametro quorum del cluster Reimposta registro quorum a. Questo avviso viene generato se il valore MaxQuorumLogSize è minore di 4096 kilobyte (KB).

Il cluster registra tutte le modifiche apportate al database cluster nel file del registro quorum. Quando il registro quorum raggiunge la dimensione specificata, il cluster salva il database e reimposta il file di registro. Nei cluster basati su Microsoft Windows® 2000 Server, il limite di dimensione predefinito per il quorum è 64 KB. Nei cluster basati su Windows Server™ 2003, il limite di dimensione predefinito per il quorum è 4.096 KB. Per i cluster di Exchange Server, si consiglia di configurare la proprietà Reimposta registro quorum a su 4.096 KB. In tal modo, sarà disponibile spazio sufficiente per contenere le informazioni di configurazione del cluster: quali server fanno parte del cluster, quali risorse sono installate al suo interno e in quale stato si trovano tali risorse (ad esempio, in linea o non in linea).

Per risolvere il problema

  1. Aprire il programma di amministrazione dei cluster.

  2. Nel riquadro sinistro fare clic con il pulsante destro del mouse sull'oggetto che rappresenta il cluster, quindi scegliere Proprietà.

  3. Nella scheda Quorum configurare Reimposta registro quorum a con un valore di 4.096.

  4. Fare clic su OK per salvare le modifiche.

Per ulteriori informazioni sul limite di dimensione predefinito per il registro quorum, consultare l'articolo 225081 della Microsoft Knowledge Base "La dimensione del registro quorum per le risorse del cluster è configurata su 64 KB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=225081.


Exchange Server
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente ai computer Exchange Server. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere avvisi, messaggi di errore e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi a Exchange.


Blocco account installato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-08-28

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare se è presente un file denominato ALockout.dll nella cartella System32 sul server di Exchange: ALockout.dll fa parte degli strumenti di gestione e di blocco degli account (ALTools.exe). Questi strumenti consentono agli amministratori di gestire gli account e di risolvere i problemi relativi al blocco degli account.

Se Exchange Server Analyzer rileva che ALockout.dll è presente su un server di Exchange, verrà visualizzato un messaggio di errore.

Gli strumenti di gestione e di blocco degli account non devono essere utilizzati su server che ospitano applicazioni o servizi di rete, inclusi i server di Exchange. Se sono installati in un server di Exchange, gli strumenti di gestione e di blocco degli account possono impedire l'avvio dei servizi di Exchange. Pertanto, si consiglia di disinstallare gli strumenti di gestione e di blocco degli account dal server di Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Al prompt dei comandi, digitare regsvr32 /u alockout.dll.

  2. Eliminare il valore di ALockout.dll nella seguente chiave del Registro di sistema: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
Nota:
Dopo aver eliminato il valore di ALockout.dll, la voce AppInit_DLLs del Registro di sistema sarà vuota. Riavviare il computer.
  1. Eliminare il file ALockout.dll dalla cartella System32.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sugli strumenti di gestione e di blocco degli account, consultare "Account Lockout Tools" in Account Passwords and Policies all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52465 (informazioni in lingua inglese).


Mancata corrispondenza del sito Active Directory
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool implementa la funzione Win32 API DsGetSiteName per eseguire la query relativa al nome del sito del servizio directory Active Directory® del controller di dominio e al nome del sito Active Directory del server Exchange locale.

Se Exchange Server Analyzer rileva che il nome del sito Active Directory del controller di dominio e il nome del sito Active Directory del server Exchange locale non corrispondono, verrà visualizzato un avviso.

L'avviso indica che il processo DSAccess agisce all'esterno del sito locale Active Directory per le richieste LDAP. Questo può provocare forti riduzioni nelle prestazioni del server Exchange.

Questa situazione può essere provocata dalla configurazione statica di un controller di dominio esterno al sito, da un'interruzione del controller di dominio o della rete che rende irraggiungibile il controller di dominio residente nel sito o da una topologia di Active Directory progettata in maniera non corretta che non include il controller di dominio Active Directory nello stesso sito del server Exchange.

DSAccess è un componente condiviso di Exchange Server che accede alle informazioni relative alle directory e le memorizza nella cache. DSAccess rileva in modo dinamico i server di elenchi in linea che altri componenti di Exchange devono contattare, basandosi su criteri quali la configurazione del sito Active Directory e la disponibilità del server Active Directory. I server front-end di Exchange utilizzano DSAccess per determinare quale server contiene la cassetta postale di un determinato utente, l'indirizzo SMTP di un oggetto utente e i server che contengono archivi di cartelle pubbliche.

Durante la fase di inizializzazione, se non rileva un set di controller di dominio o cataloghi globali configurati staticamente nel Registro di sistema, DSAccess utilizza un processo di rilevamento per identificare la topologia di rete e determina la disponibilità e l'idoneità dei server di elenchi in linea. Per determinare in parte l'idoneità di un controller di dominio, viene verificato se il controller di dominio si trova nello stesso sito Active Directory del server Exchange.

Per ridurre la latenza che potrebbe verificarsi in seguito a richieste LDAP intersito, è necessario che i server Exchange si trovino in un sito Active Directory che contiene un controller di dominio residente.

Per risolvere questo problema:

  • Valutare le definizioni del sito per la topologia di Active Directory per verificare che ciascun server Exchange disponga dell'accesso a un controller di dominio nello stesso sito Active Directory.

  • Verificare che tutti i controller di dominio configurati staticamente risiedano nello stesso sito Active Directory del server Exchange.

Per ulteriori informazioni

Per ulteriori informazioni sulla configurazione e la risoluzione dei problemi di DSAccess, consultare le seguenti risorse di Exchange:

  • "Integrazione directory e Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63447

  • "Concetti relativi all'accesso alla directory e risoluzione dei problemi" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=39012.

  • Articolo 250570 della Microsoft Knowledge Base "Rilevamento del server del servizio directory e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570


Le condivisioni amministrative dei file sono disabilitate
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le condivisioni amministrative sono state disabilitate:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\AutoShareServer

Se Exchange Server Analyzer rileva che il valore di AutoShareServer è impostato su 0, verrà visualizzato un messaggio di errore.

Questo errore indica che le condivisioni amministrative predefinite create dal server sono state disabilitate. In questo contesto, le operazioni di ripristino e di backup in linea di Exchange Server potrebbero non funzionare correttamente. A seconda del programma di backup, è possibile che vengano visualizzati messaggi di errore quando si tenta di ripristinare i dati. Tali messaggi potrebbero essere visualizzati anche nel registro di backup dei nastri.

Inoltre, dopo la rimozione delle condivisioni amministrative, è possibile che venga visualizzato il seguente messaggio durante un backup in linea di Exchange Server: Errore imprevisto 0xc0040000. Il computer che esegue Microsoft Exchange Server non è disponibile. Per risolvere questo problema, si consiglia di riabilitare le condivisioni amministrative predefinite modificando il Registro di sistema e riavviando il servizio Server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  3. Nel riquadro destro fare doppio clic su AutoShareServer.

  4. Cambiare il valore 0 impostandolo su 1.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio Server per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul ripristino delle condivisioni amministrative predefinite in Microsoft Windows Server™ 2003, consultare l'articolo 816113 della Microsoft Knowledge Base "HOW TO: Utilizzare l'editor del Registro di sistema per ripristinare le condivisioni amministrative in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=816113.


Interoperabilità del driver AFD.SYS e del connettore X.400
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di Microsoft Windows® in esecuzione sul computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore CurrentVersion 4.0 indica che sul computer Exchange Server è in esecuzione Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer Exchange Server esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer Exchange Server esegue Microsoft Windows Server™ 2003.

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore impostato per la chiave NumberOfProcessors. Questo valore rappresenta il numero di processori installati nel computer. Questi processori includono sia i processori fisici sia quelli logici. Un processore fisico può essere diviso in due processori logici utilizzando la tecnologia di hyper-threading di Intel.

Exchange Server Analyzer legge inoltre la seguente voce del Registro di sistema per determinare se Exchange Server è una testa di ponte per un connettore X.400:

HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeMTA

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per un file denominato Afd.sys.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • Il computer Exchange Server è in esecuzione su Windows Server 2000.

  • Il valore di NumberOfProcessors è superiore a 1.

  • Il server di Exchange è una testa di ponte per un connettore X.400.

  • Il valore della chiave Version per WINDOWSPATH%\\system32\\drivers\\afd.sys è nell'intervallo di 5.0.2195.7036 e 5.0.2195.7060.

Questo avviso indica che la versione di Afd.sys installata nel server può provocare problemi al flusso di porta con connettori X.400 in questo server.

Per risolvere questo problema, procurarsi l'aggiornamento menzionato nell'articolo 904712 della Microsoft Knowledge Base "Il recapito della posta è più lento del previsto o si arresta su un connettore X.400 a un sito remoto Exchange Server 5.5" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=904712.


Intervallo di Aging Keep Time per il database non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se è stato impostato dell'attributo msExchAgingKeepTime. Questo attributo rappresenta il valore dell'intervallo di tempo utilizzato per determinare quando verrà eseguita la rimozione degli indici, delle visualizzazioni e delle categorizzazioni. Se Exchange Server Analyzer rileva che l'attributo è impostato, verrà visualizzato un messaggio di configurazione non predefinita.

Gli indici utilizzati per visualizzazioni create nelle tabelle di database Exchange da un client Exchange inutilizzato per un determinato periodo vengono eliminati. L'attributo msExchAgingKeepTime specifica la durata minima dell'indice prima che venga eliminato. Il valore predefinito nella versione originale di Exchange 2000 Server era 8 giorni. Nel Service Pack 1 (SP1) per Exchange 2000 Server e nelle versioni successive di Exchange Server, inclusi Exchange Server 2003 ed Exchange Server 2007, il valore predefinito è 40 giorni.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per visualizzare o modificare il valore Aging Keep Time

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo> e infine CN=Servers.

  4. Espandere CN=<NomeServer>, CN=InformationStore, quindi selezionare CN=<NomeGruppoDiArchiviazione>.

  5. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su CN=<NomeArchivioCassettePostali> e scegliere Proprietà.

  6. Nell'editor degli attributi fare clic sull'attributo msExchAgingKeepTime, quindi scegliere Modifica.

  7. Nella finestra Modifica attributo fare clic su Cancella per cancellare il valore.

  8. Fare clic su Applica, quindi su OK.

  9. Chiudere ADSI Edit. Riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni su potenziali problemi di accesso alle cartelle dell'archivio informazioni in Exchange Server, vedere l'articolo 216076 della Microsoft Knowledge Base "Rallentamento nell'accesso alle cartelle dell'archivio informazioni in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=216076.


Aggiornamento di Antigen disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-06-20

Lo strumento Microsoft Exchange Server Analyzer Tool esegue una query nella classe Microsoft® WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per MimeNavigator.dll. Il modulo è incluso in Microsoft Antigen versioni 8 e 9.

Se Exchange Analyzer rileva che il valore della chiave Version per MimeNavigator.dll è inferiore a 8.00.1517.0 per la versione 8 e inferiore a 9.00.1055.0 per la versione 9, viene visualizzato un avviso.

L'avviso indica che Microsoft Antigen versione 8 o 9 è installato nel server di Exchange e che è disponibile un aggiornamento del software. Questo aggiornamento è consigliato e consente di migliorare le prestazioni e l'affidabilità complessive del server.

Per risolvere il problema, rivedere e applicare le raccomandazioni specificate nell'articolo 928082 della Microsoft Knowledge Base, Le dimensioni dei messaggi SMTP potrebbero aumentare durante la procedura di scansione in Antigen.


Dimensione del registro applicazione
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-11-09

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la dimensione massima del file di registro dell'applicazione:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\MaxSize

Se Exchange Server Analyzer rileva che il valore di MaxSize è minore di 40 MB, verrà visualizzato un messaggio di configurazione ottimale.

Per impostazione predefinita, la dimensione massima per il file registro applicazione è 16.777.216 byte (16.384 KB) per Windows Server 2003 e 524.288 byte (512 KB) per Windows 2000 Server. Per i computer che eseguono Exchange Server è consigliabile impostare la dimensione massima del file registro applicazione su un valore di 40 MB (immesso come 40960KB) o superiore. Aumentando la dimensione massima del file, è possibile mantenere più eventi applicazione. Le informazioni aggiuntive sugli eventi risultano utili al momento della risoluzione dei problemi.

Per aumentare la dimensione massima del registro applicazione

  1. Aprire lo snap-in MMC Visualizzatore eventi.

  2. Fare clic con il pulsante destro del mouse sul registro Applicazione, quindi scegliere Proprietà.

  3. Nella scheda Generale immettere 40960 o un valore superiore nella casella Dimensione massima registro della sezione Dimensione file di registro, quindi fare clic su OK.


Il valore Rootver per ASP.NET è incorretto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore impostato della chiave Rootver per ASP.NET:

HKEY_LOCAL_MACHINE\Software\Microsoft\ASP.NET

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • Exchange Server Analyzer rileva che il valore Rootver è impostato su 0.0.0.0.

  • Il servizio cluster è in esecuzione.

Talvolta il programma di installazione di ASP.NET non viene eseguito e non viene fornita una notifica dell'errore. In questi casi, la chiave Rootver è impostata su 0.0.0.0. L'impostazione del valore Rootver su 0.0.0.0 provoca un errore durante l'avvio del servizio Supervisore sistema di Microsoft Exchange o di altri servizi di Exchange Server sui cluster di Exchange Server 2003 e di Exchange Server 2007. È necessario correggere l'errore impostando il valore Rootver su uno dei seguenti:

  • Chiave Rootver di Exchange Server 2003 = 1.1.4322.0.

  • Chiave Rootver di Exchange Server 2007 = 2.0.50727.0

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per impostare Rootver su 1.1.4322.0

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\ASP.NET\

  3. Nel riquadro dei dettagli fare doppio clic sulla chiave RootVer.

  4. Nella finestra di dialogo Modifica stringa impostare Dati valore sul valore appropriato secondo l'articolo precedente, quindi fare clic su OK.

  5. Uscire dall'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il debug automatico del sistema operativo è stato disabilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il debug del sistema operativo è stato disabilitato:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Auto

Se Exchange Server Analyzer rileva che il valore di Auto è impostato su 0, verrà visualizzato un avviso.

Per impostazione predefinita, nei sistemi operativi Microsoft® Windows® 2000 Server e Microsoft® Windows Server™ 2003 è stato installato un debugger delle applicazioni denominato Dr. Watson. Un debugger è un programma che consente di rilevare, localizzare e correggere errori in un altro programma, consentendo a un programmatore di eseguire i vari passaggi di un programma, di verificarne i dati e di controllarne le condizioni quali i valori delle variabili.

Le opzioni predefinite vengono impostate alla prima esecuzione di Dr. Watson, ovvero quando si verifica un errore nel programma oppure quando Dr. Watson viene avviato dall'utente.

Quando si verifica un errore dell'applicazione, Windows ricerca un gestore degli errori dell'applicazione. Un gestore degli errori dell'applicazione gestisce gli errori che si verificano durante l'esecuzione di un programma. Se Windows non è in grado di rilevare un gestore degli errori dell'applicazione, stabilisce che non viene eseguito il debug del programma e considera l'errore come non gestito. Windows elabora quindi gli errori non gestiti e ricerca nel Registro di sistema un debugger degli errori dell'applicazione.

Il comportamento di Windows dipende dalle impostazioni di due valori del Registro di sistema sotto: HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug

Le voci sono Debugger e Auto. Il valore della voce Debugger determina il comando del debugger da utilizzare per l'analisi degli errori dell'applicazione. Se il valore della voce Debugger viene rilevato, Windows controlla se il valore della voce Auto è impostato su 0 oppure su 1:

  • Se il valore della voce Auto è impostato su 0, in Windows viene visualizzata una finestra di messaggio per segnalare che si è verificato un errore dell'applicazione . Se il valore della voce Debugger determina il comando per un debugger valido, nella finestra di messaggio verranno visualizzati due pulsanti: OK e Annulla. Se si fa clic su OK, il programma viene arrestato. Se si fa clic su Annulla, viene avviato il debugger specificato. Se il valore della voce Debugger è vuota, nella finestra di messaggio verrà visualizzato solo OK e non verrà avviato alcun debugger.

  • Se il valore della voce Auto è impostato su 1 e il valore della voce Debugger determina il comando per un debugger valido, il debugger verrà avviato automaticamente e non verrà visualizzata la finestra di messaggio.

Se è installato Windows, il valore predefinito della voce Auto è impostato su 1 e il valore della voce Debugger specifica il comando per l'avvio di Dr. Watson (drwtsn32 -p %ld -e %ld -g). Questo significa che quando si verifica un errore dell'applicazione, tramite Dr. Watson viene eseguita automaticamente la diagnosi dell'errore e la registrazione delle informazioni di diagnostica appropriate.

Per ottenere prestazioni migliori, è consigliabile utilizzare il debugger degli errori dell'applicazione su computer Exchange Server. Se è stato utilizzato un programma diverso da Dr. Watson come debugger predefinito e se si desidera utilizzare Dr. Watson, visualzizare il prompt dei comandi e digitare il comando drwtsn32 -i per avviare l'applicazione. Se si digita -i verranno apportate le modifiche richieste al Registro di sistema.

Per registrare Dr. Watson come debugger predefinito utilizzando il prompt dei comandi

  1. Aprire una finestra del prompt dei comandi.

  2. Eseguire il comando seguente: drwtsn32 -i

  3. Verrà visualizzato il messaggio Dr. Watson è stato installato come debugger predefinito delle applicazioni. Fare clic su OK.

Per registrare Dr. Watson come debugger predefinito utilizzando l'interfaccia utente

  1. Fare clic su Start, scegliere Esegui, digitare drwtsn32, quindi premere INVIO. Verrà visualizzata l'interfaccia utente di Dr. Watson per Windows.

  2. Selezionare la casella di controllo Crea file di dettagli arresto anomalo del sistema.

  3. Fare clic su OK per salvare le modifiche e chiudere l'interfaccia utente di Dr. Watson per Windows.

Per ulteriori informazioni su Dr. Watson per Windows, consultare il file della Guida in linea per Dr. Watson premendo F1 quando è visualizzata l'interfaccia utente di Dr. Watson.

Se si desidera utilizzare un debugger degli errori dell'applicazione diverso da Dr. Watson, è possibile disabilitare Dr. Watson utilizzando la procedura descritta nell'articolo 188296 della Microsoft Knowledge Base "Disabilitazione di Dr. Watson per Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296.


Latenza media della lettura LDAP superiore a 50 millisecondi
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-14

Lo strumento Microsoft Exchange Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni su computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni LDAP Read Time dell'oggetto prestazioni MSExchangeDSAccess Process per analizzare i dati delle prestazioni.

Il contatore di prestazioni LDAP Read Time visualizza il tempo in millisecondi che una richiesta di lettura LDAP impiega per essere eseguita. Exchange Analyzer recupera un esempio ogni 5 secondi per un periodo di 5 minuti e segnala il valore massimo per il contatore di prestazioni durante l'intervallo di raccolta. Se il valore medio supera i 50 millisecondi, verrà visualizzato un avviso.

Le latenze elevate della lettura LDAP possono essere causate da latenze RPC (Remote Procedure Call) elevate e dall'aumento delle dimensioni delle code. In genere, le latenze elevate della lettura LDAP indicano uno dei seguenti problemi:

  • Un problema di prestazioni nella connessione di rete al controller di dominio.

  • Problemi di prestazioni nel controller di dominio.

Nota:
Le latenze LDAP sono in genere più elevate quando vengono eseguite connessioni a controller di dominio che si trovano in siti fisici diversi. Tuttavia, in generale si consiglia di attenersi alle indicazioni fornite in questo articolo relative alle latenze massime.

Se il controller di dominio in cui è stato registrato l'avviso si trova in un sito fisico diverso e se è possibile verificare che non sia utilizzato dal server di Exchange, il messaggio di errore potrà essere ignorato senza problemi. Per determinare se un controller di dominio è utilizzato da Exchange, è possibile impostare su Minimo il livello di registrazione diagnostica per il componente Topologia del servizio MSExchangeDSAccess. Se non viene visualizzato l'ID evento MSExchangeDSAccess 2080, è possibile ignorare l'avviso.

Per risolvere l'avviso, procedere come segue:

  • Verificare che tutte le connessioni di rete al controller di dominio siano funzionanti e che supportino il traffico ICMP (Internet Control Monitoring Protocol).

  • Consultare le procedure consigliate nei seguenti articoli:

    • Per ulteriori informazioni sul contatore di prestazioni LDAP Read Time e altri contatori utilizzabili per risolvere problemi relativi ad Active Directory, consultare l'argomento "Esclusione di problemi correlati ad Active Directory" in Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588. L'articolo include anche informazioni su come migliorare le prestazioni di Active Directory.

    • Per ulteriori informazioni sull'aumento delle prestazioni di Active Directory, consultare l'argomento "Ottimizzazione dell'integrazione in Active Directory" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

    • Per informazioni su come garantire la disponibilità elevata dei server Active Directory, consultare le sezioni Accesso affidabile garantito ad Active Directory e al DNS (Domain Name System) dell'argomento "Misure di tolleranza di errore a livello di sistema" della Guida alla elevata disponibilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47571.

    • Per informazioni sulle considerazioni relative alla larghezza di banda della rete, consultare la sezione Prestazioni di rete dell'argomento "Nozioni fondamentali sulle prestazioni di Exchange" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.


Latenza massima della lettura LDAP superiore a 100 millisecondi
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-14

Lo strumento Microsoft Exchange Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni su computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni LDAP Read Time dell'oggetto prestazioni MSExchangeDSAccess Process per analizzare i dati delle prestazioni.

Il contatore di prestazioni LDAP Read Time visualizza il tempo in millisecondi che una richiesta di lettura LDAP impiega per essere eseguita. Exchange Analyzer recupera un esempio ogni 5 secondi per un periodo di 5 minuti e segnala il valore massimo per il contatore di prestazioni durante l'intervallo di raccolta. Se il valore massimo supera i 100 millisecondi, verrà visualizzato un messaggio di errore.

Le latenze elevate della lettura LDAP possono essere causate da latenze RPC (Remote Procedure Call) elevate e dall'aumento delle dimensioni delle code. In genere, le latenze elevate della lettura LDAP indicano uno dei seguenti problemi:

  • Un problema di prestazioni nella connessione di rete al controller di dominio.

  • Problemi di prestazioni nel controller di dominio.

Nota:
Le latenze LDAP sono in genere più elevate quando vengono eseguite connessioni a controller di dominio che si trovano in siti fisici diversi. Tuttavia, in generale si consiglia di attenersi alle indicazioni fornite in questo articolo relative alle latenze massime.

I server Exchange eseguiranno una query nei server di catalogo globale esterni al dominio ogni 15 minuti per mantenere un elenco aggiornato dei server di catalogo globale e dei controller di dominio. Dato che alcuni server di elenchi in linea potrebbero essere remoti, le latenze di queste query potrebbero risultare elevate. Ciò è accettabile fintanto che la frequenza delle richieste è bassa. Ad esempio, se la frequenza è inferiore a 0,5 richieste al secondo.

Se il controller di dominio in cui è stato registrato l'errore si trova in un sito fisico diverso e se è possibile verificare che non sia utilizzato dal server Exchange, il messaggio di errore potrà essere ignorato senza problemi. Per determinare se un controller di dominio è utilizzato da Exchange, è possibile impostare su Minimo il livello di registrazione diagnostica per il componente Topologia del servizio MSExchangeDSAccess. Se non viene visualizzato l'ID evento MSExchangeDSAccess 2080, è possibile ignorare il messaggio di errore.

Importante:
Solo per gli ambienti a modalità mista, con Exchange 2000 SP2 è stato introdotto il comportamento relativo al tempo per certi attributi specifici dell'utente relativi alla protezione, quali tokenGroups e tokengroupsGlobalandUniversal, utilizzati per determinare i gruppi di protezione dei quali un utente è membro e quindi le autorizzazioni di cui dispone per la protezione di risorse come le cartelle pubbliche. Tale comportamento prevede che venga richiesto al server Exchange di eseguire una query in un controller di dominio autorevole per il dominio principale dell'utente. Il controller di dominio autorevole può trovarsi in un sito remoto e le query provenienti da un numero elevato di utenti remoti del dominio che accedono alle cartelle pubbliche locali possono contribuire al verificarsi di latenze RPC elevate.

Per ulteriori informazioni su questo comportamento, vedere il seguente argomento del blog di Exchange Server:

  • Exchange Does Not Always Use Local GCs (informazioni in lingua inglese)

    Nota:
    I collegamenti ai blog vengono forniti per consentire di trovare le informazioni tecniche necessarie. Il contenuto di ciascun blog e il relativo URL sono soggetti a modifiche senza preavviso.

Per risolvere l'errore, procedere come segue:

  • Verificare che tutte le connessioni di rete al controller di dominio siano funzionanti e che supportino il traffico ICMP (Internet Control Monitoring Protocol).

  • Consultare le procedure consigliate nei seguenti articoli:

    • Per ulteriori informazioni sul contatore di prestazioni LDAP Read Time e altri contatori utilizzabili per risolvere problemi relativi ad Active Directory, consultare l'argomento "Esclusione di problemi correlati ad Active Directory" in Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588. L'articolo include anche informazioni su come migliorare le prestazioni di Active Directory.

    • Per ulteriori informazioni sull'aumento delle prestazioni di Active Directory, consultare l'argomento "Ottimizzazione dell'integrazione in Active Directory" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

    • Per informazioni su come garantire la disponibilità elevata dei server Active Directory, consultare le sezioni Accesso affidabile garantito ad Active Directory e al DNS (Domain Name System) dell'argomento "Misure di tolleranza di errore a livello di sistema" della Guida alla elevata disponibilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47571.

    • Per informazioni sulle considerazioni relative alla larghezza di banda della rete, consultare la sezione Prestazioni di rete dell'argomento "Nozioni fondamentali sulle prestazioni di Exchange" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.


Latenza media della ricerca LDAP superiore a 50 millisecondi
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-14

Lo strumento Microsoft Exchange Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni LDAP Search Time dell'oggetto prestazioni MSExchangeDSAccess Process per analizzare i dati relativi alle prestazioni.

Il contatore di prestazioni LDAP Search Time visualizza il tempo in millisecondi che una richiesta di ricerca LDAP impiega per essere eseguita. Exchange Server Analyzer recupera un campione ogni 5 secondi per un periodo di 5 minuti e segnala il valore massimo raggiunto dal contatore di prestazioni durante l'intervallo di raccolta. Se il valore medio supera i 50 millisecondi, verrà visualizzato un avviso.

Le latenze elevate della ricerca LDAP possono essere causate da latenze RPC (Remote Procedure Call) elevate e dall'aumento delle dimensioni delle code. In genere, le latenze elevate della ricerca LDAP indicano uno dei seguenti problemi:

  • Un problema di prestazioni nella connessione di rete al controller di dominio.

  • Problemi di prestazioni nel controller di dominio.

Nota:
Le latenze LDAP sono in genere più elevate quando vengono eseguite connessioni a controller di dominio che si trovano in siti fisici diversi. Tuttavia, in generale si consiglia di attenersi alle indicazioni fornite in questo articolo relative alle latenze massime.

Se il controller di dominio in cui è stato registrato l'avviso si trova in un sito fisico diverso e se è possibile verificare che non sia utilizzato dal server di Exchange, il messaggio di errore potrà essere ignorato senza problemi. Per determinare se un controller di dominio è utilizzato da Exchange, è possibile impostare su Minimo il livello di registrazione diagnostica per il componente Topologia del servizio MSExchangeDSAccess. Se non viene visualizzato l'ID evento MSExchangeDSAccess 2080, è possibile ignorare l'avviso.

Per risolvere il problema, procedere come segue:

  • Verificare che tutte le connessioni di rete al controller di dominio funzionino e che supportino il traffico ICMP (Internet Control Monitoring Protocol).

  • Consultare le procedure consigliate nei seguenti articoli:

    • Per ulteriori informazioni sul contatore di prestazioni LDAP Read Time e altri contatori utilizzabili per risolvere problemi relativi ad Active Directory, consultare l'argomento "Ruling Out Active Directory-Bound Problems" in Risoluzione dei problemi di Exchange 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese). L'articolo include anche informazioni su come migliorare le prestazioni di Active Directory.

    • Per ulteriori informazioni sull'aumento delle prestazioni di Active Directory, consultare l'argomento "Ottimizzazione dell'integrazione in Active Directory" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

    • Per informazioni su come verificare l'elevata disponibilità dei server Active Directory, consultare le sezioni Accesso affidabile garantito ad Active Directory e al DNS (Domain Name System) dell'argomento "Misure per la tolleranza di errore a livello di sistema" della Guida alla elevata disponibilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47571.

    • Per informazioni sulle considerazioni relative alla larghezza di banda della rete, consultare la sezione Prestazioni di rete dell'argomento "Nozioni fondamentali sulle prestazioni di Exchange" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.


Latenza massima della ricerca LDAP superiore a 100 millisecondi
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-14

Lo strumento Microsoft Exchange Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni LDAP Search Time dell'oggetto prestazioni MSExchangeDSAccess Process per analizzare i dati relativi alle prestazioni.

Il contatore di prestazioni LDAP Search Time visualizza il tempo in millisecondi che una richiesta di ricerca LDAP impiega per essere eseguita. Exchange Analyzer recupera un esempio ogni 5 secondi per un periodo di 5 minuti e segnala il valore massimo per il contatore di prestazioni durante l'intervallo di raccolta. Se il valore massimo supera i 100 millisecondi, verrà visualizzato un messaggio di errore.

Le latenze elevate della ricerca LDAP possono essere causate da latenze RPC (Remote Procedure Call) elevate e dall'aumento delle dimensioni delle code. In genere, le latenze elevate della ricerca LDAP indicano uno dei seguenti problemi:

  • Un problema di prestazioni nella connessione di rete al controller di dominio.

  • Problemi di prestazioni nel controller di dominio.

Nota:
Le latenze LDAP sono in genere più elevate quando vengono eseguite connessioni a controller di dominio che si trovano in siti fisici diversi. Tuttavia, in generale si consiglia di attenersi alle indicazioni fornite in questo articolo relative alle latenze massime.

I server di Exchange eseguiranno una query nei server di catalogo globale esterni al dominio ogni 15 minuti per mantenere un elenco aggiornato dei server di catalogo globale e dei controller di dominio. Poiché alcuni dei server di elenchi in linea potrebbero essere remoti, le latenze delle query potrebbero risultare relativamente elevate. Ciò è accettabile fintanto che la frequenza delle richieste è bassa: ad esempio, se la frequenza è inferiore a 0,5 richieste al secondo.

Se il controller di dominio in cui è stato registrato l'errore si trova in un sito fisico diverso e se è possibile verificare che non sia utilizzato dal server Exchange, il messaggio di errore potrà essere ignorato senza problemi. Per determinare se un controller di dominio è utilizzato da Exchange, è possibile impostare su Minimo il livello di registrazione diagnostica per il componente Topologia del servizio MSExchangeDSAccess. Se non viene visualizzato l'ID evento MSExchangeDSAccess 2080, è possibile ignorare il messaggio di errore.

Importante:
Solo per gli ambienti a modalità mista, con Exchange 2000 SP2 è stato introdotto un intervallo di tempo per alcuni attributi specifici dell'utente relativi alla protezione, quali tokenGroups e tokengroupsGlobalandUniversal, utilizzati per determinare i gruppi di protezione dei quali un utente è membro e quindi le autorizzazioni di cui dispone per la protezione di risorse come le cartelle pubbliche. Tale comportamento prevede che venga richiesto al server di Exchange di eseguire una query in un controller di dominio autorevole per il dominio principale dell'utente. Il controller di dominio autorevole può trovarsi in un sito remoto e le query provenienti da un numero elevato di utenti remoti del dominio che accedono alle cartelle pubbliche locali possono contribuire al verificarsi di latenze RPC elevate.

Per ulteriori informazioni su questo comportamento, vedere il seguente articolo del blog di Exchange Server:

  • Exchange Does Not Always Use Local GCs (informazioni in lingua inglese)

    Nota:
    I collegamenti ai blog vengono forniti per consentire di trovare le informazioni tecniche necessarie. Il contenuto di ciascun blog e il relativo URL sono soggetti a modifiche senza preavviso.

Per correggere l'errore, procedere come segue:

  • Verificare che tutte le connessioni di rete al controller di dominio funzionino e che supportino il traffico ICMP (Internet Control Monitoring Protocol).

  • Consultare le procedure consigliate nei seguenti articoli:

    • Per ulteriori informazioni sul contatore di prestazioni LDAP Read Time e altri contatori utilizzabili per risolvere problemi relativi ad Active Directory, consultare l'argomento "Ruling Out Active Directory-Bound Problems" in Risoluzione dei problemi di Exchange 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese). L'articolo include anche informazioni su come migliorare le prestazioni di Active Directory.

    • Per ulteriori informazioni sull'aumento delle prestazioni di Active Directory, consultare l'argomento "Ottimizzazione dell'integrazione in Active Directory" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

    • Per informazioni su come verificare la massima disponibilità dei server Active Directory, consultare le sezioni Accesso affidabile garantito ad Active Directory e al DNS (Domain Name System) dell'argomento "Misure di tolleranza di errore a livello di sistema" della Guida alla elevata disponibilità di Exchange 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47571.

    • Per informazioni sulle considerazioni relative alla larghezza di banda della rete, consultare la sezione Prestazioni di rete dell'argomento "Nozioni fondamentali sulle prestazioni di Exchange" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.


Impossibile identificare il gateway di Exchange specificato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-08-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per trovare il nome cn di ciascun oggetto directory che dispone di una classe oggetto di msExchExchangeServer e determinare se esiste una corrispondenza con il server gateway di Exchange specificato dall'utente.

Il valore cn rappresenta una stringa contenente il nome breve del computer che esegue Exchange Server.

Se Exchange Server Analyzer non è in grado di trovare un valore cn corrispondente al server gateway di Exchange specificato dall'utente in Active Directory, verrà visualizzato un errore.

L'errore indica l'esistenza di una delle seguenti condizioni:

  • Il server gateway di Exchange specificato dall'utente non esiste nell'organizzazione di Exchange Server locale.

  • Il server gateway di Exchange specificato dall'utente è stato immesso in modo errato.

Per risolvere il problema, verificare di immettere correttamente il server gateway di Exchange specificato e riprovare a eseguire l'operazione.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizza ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per verificare il valore cn del nome server

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto server in Active Directory.

    L'attributo CN è reperibile in:

    Copia codice
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server.


Lunghezza coda classificatore superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Categorizer Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che il contatore Categorizer Queue Length ha superato il valore massimo di 10 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Il contatore SMTP Server\Categorizer Queue Length indica il numero di messaggi nella coda SMTP (Simple Mail Transfer Protocol) del classificatore in attesa delle ricerche dell'attributo del servizio directory tramite i server di catalogo globale.

Il classificatore esegue le seguenti operazioni principali:

  • Risolve e convalida tutti i destinatari.

  • Determina i limiti e le restrizioni per tutti i destinatari.

  • Espande le liste di distribuzione, se richiesto.

  • Determina se il messaggio è destinato al recapito locale o remoto.

Questo errore indica che potrebbero essere presenti problemi relativi alle prestazioni del server o della rete, a DSAccess (Directory Service Access), al servizio directory di Active Directory® o a interruzioni dei server principali nell'organizzazione di Exchange Server. Un aumento del contatore Categorizer Queue Length potrebbe indicare lentezza o mancanza di risposta nella consultazione di Active Directory o nella gestione dei messaggi per il recapito locale o SMTP. Potrebbero verificarsi ritardi nel recapito della posta.

Per risolvere il problema

  • Verificare la disponibilità di un numero sufficiente di risorse di Active Directory per il server di Exchange. Tali risorse includono sia i controller di dominio sia i server di catalogo globale. Si consiglia di mantenere un rapporto di tipo 4:1 tra i processori del server di Exchange e qualli del server di catalogo globale con velocità simile.

  • Dal Gestore di sistema di Exchange verificare che tutti i controller di dominio elencati nella scheda DSAccess del server di Exchange funzionino correttamente. La verifica include i server elencati in ConfigDC, il controller di dominio e i ruoli del server di catalogo globale.

  • Verificare la presenza di eventuali colli di bottiglia monitorando le prestazioni di rete tra il server di Exchange e i relativi controller di dominio e server di catalogo globale selezionati.

  • Monitorare l'utilizzo del processore da parte del server di Exchange e del processo Inetinfo.exe. Questo include il componente classificatore.

  • Verificare il corretto funzionamento degli oggetti gruppo e utente relativi a Exchange utilizzando l'oggetto di configurazione e2kdsinteg dello strumento ConfigDSInteg in Exchange Server Strumenti di distribuzione di Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21231. Gli oggetti con indirizzi non corretti o informazioni incomplete possono causare ritardi nell'individuazione e nella classificazione dei destinatari.

Ulteriori informazioni

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


File CDO.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Aggiornamento di CimWin32.dll disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-19

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di Microsft Windows® in esecuzione sul computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore CurrentVersion 4.0 indica che sul computer Exchange Server è in esecuzione Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer Exchange Server esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer Exchange Server esegue Microsoft Windows Server™ 2003.

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version del file Cimwin32.dll.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • Il computer Exchange Server è in esecuzione su Windows 2000 Server.

  • Il valore per la chiave Version corrisponde a una versione specifica del file Cimwin32.dll.

È disponibile un aggiornamento del file Cimwin32.dll che consentirà un funzionamento più efficiente di Exchange Server Analyzer.

Per risolvere il problema rivedere e applicare i suggerimenti dell'articolo 820608 della Microsoft Knowledge Base "La classe CIM_DataFile restituisce un valore errato o NULL per i file di dimensione superiore a 2 GB in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=820608.


Impatto delle applicazioni client sulle prestazioni del server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato la presenza di tipi specifici di computer client o applicazioni lato client che possono causare un incremento del carico del server nell'organizzazione di Exchange.

Sono numerose le applicazioni che possono produrre un incremento del carico sul server. Se si è riscontrato un aumento del carico, verificare quali applicazioni sono in esecuzione e stabilire se si desidera limitare l'utilizzo di alcune di esse. L'esecuzione di determinate applicazioni che accedono alla posta elettronica (applicazioni di terze parti o plug-in di Microsoft Office Outlook®) può generare un incremento del carico sul server. Se si verifica un aumento delle latenze RPC (Remote Procedure Call) o del carico del server, è consigliabile individuarne la causa.

Per identificare gli utenti interessati da un aumento delle latenze o responsabili di un incremento del carico del server, è possibile utilizzare ExMon (Exchange Server User Monitor). Per scaricare tale strumento, accedere all'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54983.

Procedura

Per risolvere il problema

  • Utilizzare ExMon per identificare gli utenti responsabili di un incremento del carico del server. Successivamente, contattare tali utenti e stabilire se le applicazioni indicate di seguito sono all'origine del carico aggiuntivo:

    • Plug-in di computer client di terze parti;

    • Periferiche di sincronizzazione desktop, ad esempio Exchange ActiveSync® o Blackberry;

    • Altre applicazioni MAPI, ad esempio motori di ricerca desktop.

    Se le suddette applicazioni non sono necessarie per scopi aziendali o se è disponibile per tali applicazioni un aggiornamento rapido pubblicato, chiudere le applicazioni o aggiornarle in modo da ridurre il carico a un livello ragionevole.

  • Configurare i computer client più dispendiosi a livello operativo (soprattutto quelli con latenze lunghe nelle operazioni Restrict, SetColumns o FindRow) in modo che utilizzino la modalità cache di Exchange. Tale modalità infatti isola il server dalla maggior parte del traffico RPC in eccesso.

    Inoltre, incoraggiare gli utenti le cui cartelle contengono numerosi elementi ad archiviare i dati meno recenti in un file PST. Oppure, se tali utenti desiderano conservare i dati sul server, incoraggiarli a spostare gli elementi meno recenti in cartelle appena create.

    Infine, è consigliabile che il numero di elementi nelle cartelle Posta in arrivo, Calendario, Posta inviata, Contatti e Posta eliminata non sia superiore a 5.000.
Nota:
Alcune applicazioni possono produrre un incremento significativo del carico del server anche se non viene eseguito un numero elevato di operazioni MAPI. Ciò accade poiché alcune operazioni sono più costose di altre. A volte è sufficiente un lieve aumento del numero di operazioni dispendiose per determinare un impatto considerevole sulle prestazioni del server. In ExMon gli utenti che utilizzano tali applicazioni vengono indicati come responsabili di un impatto sulla CPU relativamente alto, senza che abbiano necessariamente eseguito una quantità elevata di operazioni MAPI.

Ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dei client Outlook, consultare "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803.

  • Per ulteriori informazioni sui programmi di ricerca desktop, consultare l'articolo 905184 della Microsoft Knowledge Base "Possibile impatto sulle prestazioni di Exchange 2000 Server e di Exchange Server 2003 dei motori di ricerca desktop in esecuzione sui client Outlook o su altri computer client MAPI" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184.


Percorso TEMP del cluster non valido o non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

In un computer Exchange Server non cluster, Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore della variabile di ambiente TEMP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

Quando Exchange Server Analyzer viene eseguito su un server virtuale di Exchange (EVS, Exchange Virtual Server) in un cluster di server Microsoft Windows®, non legge l'hive del Registro di sistema HKLM. Legge invece la seguente voce del Registro di sistema:

HKEY_USERS\<Identificatore di protezione (SID, Security Identifier) dell'account del servizio cluster>\Environment\TEMP

Se Exchange Server Analyzer rileva che la variabile di ambiente TEMP non è impostata su un percorso disponibile nel sistema corrente, verrà visualizzato un avviso. Se il percorso non è valido, potrebbe verificarsi un errore di recapito della posta elettronica nell'organizzazione. Per impostazione predefinita, Exchange Server Analyzer richiede che il percorso sia impostato su %PROFILOUTENTE%\Impostazioni locali\Temp. Sebbene questo percorso possa essere modificato per individuare altre posizioni, dopo l'installazione di un aggiornamento o di un aggiornamento rapido e il riavvio del nodo cluster, il sistema richiede che il percorso sia impostato sulla configurazione predefinita.

La variabile di ambiente TEMP viene utilizzata per determinare quale cartella del file system deve essere utilizzata dalle applicazioni che richiedono un'area di lavoro temporanea. In genere, TEMP viene utilizzata da applicazioni quali, ad esempio, Exchange Server. Il percorso di ciascuna variabile generalmente è relativo al contesto dell'applicazione. Ad esempio, nei processi del servizio Archivio informazioni di Microsoft Exchange, la cartella TEMP viene utilizzata come archivio temporaneo durante alcune operazioni, quali le operazioni di conversione dei messaggi o spostamento delle cassette postali.

Per risolvere il problema

  1. Accedere a un nodo nel cluster tramite l'account del servizio cluster.

  2. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà.

  3. Selezionare Avanzate.

  4. Fare clic su Variabili di ambiente.

  5. Nell'area Variabili utente per <nome account>, selezionare TEMP e fare clic su Modifica.

  6. Nel campo Valore variabile immettere il percorso predefinito per la variabile di ambiente TEMP e fare clic su OK.

  7. Per chiudere la finestra di dialogo Variabili di ambiente, fare clic su OK e per chiudere la finestra di dialogo Proprietà del sistema, fare clic di nuovo su OK.

  8. Riavviare il nodo per rendere effettiva la modifica.

  9. Ripetere i passaggi da 1 a 8 per ciascun nodo del cluster che presenta l'impostazione non predefinita.


Repliche multiple di rubriche non in linea
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-08-14

Microsoft® Exchange Server Analyzer Tool esegue una query nella Exchange_PublicFolder classe WMI (Strumentazione gestione Windows®) sotto lo spazio dei nomi root\MicrosoftExchangeV2 per determinare il numero delle voci per la chiave ReplicaList. Il numero delle voci rappresenta il numero di repliche di rubriche non in linea presenti in ciascun gruppo amministrativo.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il numero degli oggetti del database di cartelle pubbliche che hanno il set di attributilegacyExchangeDN. Il numero degli oggetti con questo set di attributi rappresenta il numero di archivi delle cartelle pubbliche esistenti nell'organizzazione.

Se Exchange Server Analyzer rileva che esiste soltanto una replica di una rubrica non in linea in un'organizzazione Exchange che è dotata di più archivi delle cartelle pubbliche, verrà visualizzato un messaggio di configurazione ottimale.

Per motivi di disponibilità e di prestazioni, si consiglia di impostare più repliche di ogni rubrica non in linea. Talvolta la presenza di più repliche di rubriche non in linea può contribuire a migliorare le prestazioni e la resilienza. In organizzazioni Exchange di grandi dimensioni una singola replica di una rubrica non in linea potrebbe diventare sovraccarica. In tutte le organizzazioni Exchange una singola replica di una rubrica non in linea rappresenta un singolo punto di errore.

L'esecuzione di più repliche è consigliabile anche se determina un traffico di replica aggiuntivo. Come minimo dovrebbero essere eseguite due repliche per ogni rubrica non in linea.

Per aggiungere repliche di una rubrica non in linea a una organizzazione Exchange

  1. Aprire il Gestore di sistema di Exchange.

  2. Espandere Cartelle, fare clic con il pulsante destro del mouse su Cartelle pubbliche e scegliere Visualizza cartelle di sistema. Nota Se il nodo Cartelle non è visibile, espandere prima Gruppi amministrativi e successivamente il gruppo amministrativo contenente le cartelle di sistema che si desidera visualizzare. Fare clic con il pulsante destro del mouse su Cartelle pubbliche e scegliere Visualizza cartelle di sistema.

  3. Espandere il contenitoreRUBRICA NON IN LINEA, quindi fare clic con il pulsante destro del mouse sul contenitore Rubrica non in linea per cui si desidera aggiungere una replica scegliendo Proprietà dall'elenco a discesa risultante.

  4. Scegliere la scheda Replica, quindi fare doppio clic su Aggiungi per selezionare l'archivio pubblico a cui si desidera aggiungere la replica. Fare clic su OK per completare l'operazione.

  5. Ripetere i passaggi 3 e 4 per tutti gli oggetti figlio nel contenitore Rubrica non in linea di cui si desidera una replica. Questa ripetizione garantirà che tutti i formati supportati siano inclusi nella replica, ovvero più specificamente Aggiungi gli oggetti figlio OAB versione 2, OAB versione 3a e così via.

Per ulteriori informazioni relative alla gestione e configurazione delle rubriche non in linea, consultare i seguenti articoli nel Microsoft Exchange Server TechCenter:

  • "Offline Address Book - Things to Consider" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=57581 (informazioni in lingua inglese).

  • "Troubleshooting Exchange Server 2003 Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).

  • "Offline Address Book Best Practices Guide" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47583 (informazioni in lingua inglese).

  • "OAB Version 4 in Exchange Server 2003 Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=53097 (informazioni in lingua inglese).

  • "How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=53099 (informazioni in lingua inglese).


Connessione al controller di dominio del Servizio aggiornamento destinatari
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-05-18

Microsoft® Exchange Server Analyzer Tool apre una connessione del socket TCP sulla porta 389 su ciascun controller di dominio: Questa connessione viene eseguita tramite un elaboratore di oggetti personalizzati che restituisce una stringa specifica se la connessione riesce.

Se Exchange Server Analyzer non riceve 389 Available come parte della stringa restituita, verrà visualizzato un avviso.

Questo avviso indica che il controller di dominio non ha risposto a un tentativo di connessione sulla porta TCP 389. La porta TCP 389 è la porta predefinita per comunicazioni LDAP (Lightweight Directory Access Protocol). Se si riceve questo avviso, potrebbe verificarsi una delle seguenti condizioni:

  • Potrebbero essere presenti problemi di connettività tra Exchange Server Analyzer e il controller di dominio.

  • Il server potrebbe essere inattivo.

  • Il server potrebbe non disporre dell'autorizzazione.

Quando Exchange Server Analyzer esegue una query, il controller di dominio può non essere in grado di elaborare correttamente le richieste LDAP per diversi motivi.

Per risolvere il problema

  1. Verificare che l'account da cui viene eseguito lExchange Server Analyzer sia autorizzato a eseguire query nel controller di dominio. Sono necessarie autorizzazioni a livello di utente per il dominio in cui viene eseguito il controller di dominio. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per aprire il file della Guida in linea di Exchange Server Analyzer, fare clic su ?, quindi scegliere Guida in linea Microsoft Exchange Server Analyzer Tool.

  2. Verificare che non siano presenti firewall o restrizioni di porta tra il computer su cui viene eseguito Exchange Server Analyzer e il controller di dominio che non risponde correttamente.

  3. Verificare che il controller di dominio sia connesso alla rete e funzioni correttamente.

  4. Verificare che il server disponga dell'autorizzazione e che sia ancora elencato tra i controller di dominio disponibili per Exchange Server.

Per ulteriori informazioni, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 319065, "Utilizzo del Servizio aggiornamento destinatari di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkId=3052&kbid=319065.

  • 816103, "HOW TO: Utilizzo di Portqry per risolvere i problemi di connettività di Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103.


Disponibilità di aggiornamenti del contenuto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-06-21

Per ulteriori informazioni, vedere la pagina relativa al download della documentazione di Exchange Server 2007.


È abilitata l'indicizzazione dei contenuti per l'archivio delle cartelle pubbliche ma non sono pianificati aggiornamenti
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore di msExchCIAvailable di ciascun archivio delle cartelle pubbliche. Il valore dell'attributo indica se l'indicizzazione dei contenuti è stata abilitata per l'archivio delle cartelle pubbliche. Il valore True indica che un indice del contenuto esiste per l'archivio delle cartelle pubbliche e che l'impostazione Indice correntemente disponibile per la ricerca in base al client del Gestore di sistema di Exchange è selezionata. Il valore False indica che un indice del contenuto esiste per l'archivio delle cartelle pubbliche ma che l'impostazione Indice correntemente disponibile per la ricerca in base al client del Gestore di sistema di Exchange non è selezionata. Il valore <Not Set> indica che non esiste alcun indice del contenuto per l'archivio delle cartelle pubbliche.

Microsoft® Exchange Server Analyzer Tool esegue una query in Active Directory® anche per determinare il valore dell'attributo msExchCIRebuildSchedule di ciascun archivio delle cartelle pubbliche. Il valore di questo attributo indica le impostazioni per la pianificazione di ricostruzione relativa all'indice di contenuto. L'attributo viene memorizzato come stringa di ottetti con 82 coppie di valori esadecimali.

Se Exchange Server Analyzer rileva che il valore dell'attributo msExchCIAvailable è impostato su True, ma il valore della stringa di ottetti per l'attributo msExchCIRebuildSchedule viene convertito in Non eseguire mai, verrà visualizzato un avviso.

Per l'impostazione dell'intervallo di aggiornamento, è consigliabile pianificare aggiornamenti incrementali almeno una volta al giorno. È possibile pianificare aggiornamenti più frequenti poiché l'indice è aggiornato solo all'ultima volta che è stato compilato. Gli indici non aggiornati regolarmente possono produrre risultati non corretti e obsoleti.

È inoltre preferibile tenere presente il tempo necessario per eseguire la compilazione incrementale. Ad esempio, in una pianificazione tipica gli aggiornamenti incrementali vengono impostati all'inizio di ogni ora. Se, tuttavia, l'aggiornamento dura più di un'ora, la successiva compilazione incrementale inizia al principio dell'ora seguente.

In genere, se l'archivio delle cartelle pubbliche ha una dimensione massima di 6 GB, gli aggiornamenti incrementali possono essere eseguiti ogni ora. Se l'archivio presenta una dimensione maggiore di 6 GB o si utilizza gran parte della memoria del server, l'indice potrà essere aggiornato con minore frequenza.

Per impostare l'intervallo di aggiornamento dell'indicizzazione di testo completo su un archivio delle cartelle pubbliche specifico

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Gruppi amministrativi, il proprio gruppo amministrativo, la struttura Server, il server e infine il gruppo di archiviazione, quindi fare clic con il pulsante destro del mouse sull'archivio delle cartelle pubbliche e infine su Proprietà. Se il nodo Gruppi amministrativi non viene visualizzato in Gestore di sistema di Exchange, espandere Server, fare clic con il pulsante destro del mouse sul server, quindi fare clic su Proprietà.

  3. Nella scheda Indicizzazione di testo completo scegliere un'opzione diversa da Never run.

  4. Se si sceglie Utilizza pianificazione personalizzata, fare clic su Personalizza, impostare una pianificazione personalizzata, quindi fare clic su OK.

  5. Fare clic su Applica.

Per ulteriori informazioni sull'indicizzazione di testo completo in Exchange Server, consultare "Procedure principali per la distribuzione dell'indicizzazione di testo completo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=5223.


È abilitata l'indicizzazione dei contenuti per l'archivio delle cassette postali ma non sono pianificati aggiornamenti
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchCIAvailable di ciascun archivio delle cassette postali. Il valore dell'attributo indica se l'indicizzazione dei contenuti è stata abilitata per l'archivio delle cassette postali. Il valore True indica che per l'archivio delle cassette postali esiste un indice dei contenuti e che l'impostazione Indice correntemente disponibile per la ricerca in base al client del Gestore di sistema di Exchange è selezionata. Il valore False indica che per l'archivio delle cassette postali esiste un indice dei contenuti e che l'impostazione Indice correntemente disponibile per la ricerca in base al client del Gestore di sistema di Exchange non è selezionata. Il valore <Non impostato> indica che non esiste alcun indice dei contenuti per l'archivio delle cassette postali.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il valore dell'attributo msExchCIRebuildSchedule di ciascun archivio delle cassette postali. Il valore di questo attributo indica le impostazioni per la pianificazione di ricostruzione relativa all'indice di contenuto. L'attributo viene archiviato come stringa di ottetti con 82 coppie di valori esadecimali.

Se Exchange Server Analyzer rileva che il valore dell'attributo msExchCIAvailable è impostato su TRUE, ma il valore della stringa di ottetti per l'attributo msExchCIRebuildSchedule viene convertito in "Non eseguire mai", verrà visualizzato un avviso.

Per l'impostazione dell'intervallo di aggiornamento, è consigliabile pianificare aggiornamenti incrementali almeno una volta al giorno. Può essere consigliabile pianificare aggiornamenti più frequenti poiché l'aggiornamento dell'indice corrisponde all'ultima compilazione eseguita. Gli indici non aggiornati regolarmente possono produrre risultati non corretti e obsoleti.

È inoltre preferibile tenere presente il tempo necessario per eseguire una compilazione incrementale. Ad esempio, in una pianificazione tipica gli aggiornamenti incrementali vengono impostati all'inizio di ogni ora. Tuttavia, se l'aggiornamento dura più di un'ora, la successiva compilazione incrementale inizia al principio dell'ora seguente.

In genere, se l'archivio delle cassette postali ha una dimensione massima di 6 GB, gli aggiornamenti incrementali possono essere eseguiti ogni ora. Se l'archivio presenta una dimensione maggiore di 6 GB o si utilizza gran parte della memoria del server, l'indice potrà essere aggiornato con minore frequenza.

Per impostare l'intervallo di aggiornamento dell'indicizzazione di testo completo su un archivio delle cassette postali specifico

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Gruppi amministrativi, il proprio gruppo amministrativo, la struttura Server, il server e infine il gruppo di archiviazione, quindi fare clic con il pulsante destro del mouse su Archivio cassette postali e infine fare clic su Proprietà. Se il nodo Gruppi amministrativi non viene visualizzato in Gestore di sistema di Exchange, espandere Server, fare clic con il pulsante destro del mouse sul server, quindi fare clic su Proprietà.

  3. Nella scheda Indicizzazione di testo completo scegliere un'opzione diversa da Non eseguire mai.

  4. Se si sceglie Utilizza pianificazione personalizzata, fare clic su Personalizza, impostare una pianificazione personalizzata, quindi fare clic su OK.

  5. Fare clic su Applica.

Per ulteriori informazioni sulla configurazione e la risoluzione dei problemi di indicizzazione di testo completo in Exchange, consultare l'articolo 822932 della Microsoft Knowledge Base, "HOW TO: Configurazione dell'indicizzazione di testo completo negli archivi di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932 e l'articolo 319436, "Configurazione dell'indicizzazione di testo completo negli archivi di cassette postali in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436.

Per ulteriori informazioni sull'indicizzazione di testo completo per Exchange Server, consultare "Raccomandazioni per la distribuzione delle indicizzazioni di testo completo" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=5223.


Aggiornamento del driver CQPCIDRV.SYS disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-08-14

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di Microsoft Windows® in esecuzione sul server di Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il server di Exchange esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il server di Exchange esegue Microsoft Windows 2000 Server. Il valore 5.2 indica che il computer Exchange Server esegue Windows Server™ 2003.

Exchange Server Analyzer Tool esamina inoltre la classe WMI (Strumentazione gestione Windows) Win32_Processor per determinare il valore della chiave DataWidth.

Il valore 32 della chiave DataWidth indica che il server esegue una versione a 32 bit del sistema operativo Windows, mentre il valore 64 della chiave DataWidth indica che il server esegue una versione a 64 bit del sistema operativo Windows.

Infine, Exchange Server Analyzer esegue una query nella classe WMI CIM_Datafile per determinare il valore della chiave Version per il file CpqCiDrv.sys.

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • Il server di Exchange esegue Windows Server 2003.

  • Il server di Exchange esegue una versione a 64 bit del sistema operativo Windows.

  • La versione del driver CPQCIDRV.sys di Integrated Lights-Out Management Interface HP è precedente alla 1.8.

L'errore indica che la versione del driver CpqCiDrv.sys installata sul server potrebbe causare errori di allocazione della memoria kernel.

Per risolvere il problema, seguire le istruzioni del fornitore nell'ID documento: c00688313 all'indirizzo http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00688313 (informazioni in lingua inglese).

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


CrashOnAuditFail attivato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il parametro CrashOnAuditFail è stato impostato:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\CrashOnAuditFail

Se Exchange Server Analyzer rileva che il valore di CrashOnAuditFail è uguale a 2, verrà visualizzato un messaggio di errore.

La chiave CrashonAuditFail del Registro di sistema viene utilizzata per configurare un server in modo che gli utenti finali non possano accedere al computer quando i registri di protezione raggiungono il limite di dimensione configurato. Disabilitando l'accesso al computer si assicura che le informazioni di controllo, che altrimenti verrebbero registrate, non vengano ignorate.

Quando è abilitata, la chiave CrashonAuditFail del Registro di sistema è impostata sul valore 1. Tuttavia, quando viene raggiunto il limite del registro di protezione, il server imposta la chiave sul valore 2 e questa, a sua volta, interrompe l'elaborazione sul server. Talvolta questo processo provoca un arresto completo, ossia STOP 0xC0000244, anche noto come errore di interruzione. Nella migliore delle ipotesi, gli utenti non potranno accedere alle risorse del server e le prestazioni si ridurranno notevolmente. Inoltre, quando il server si trova in questo stato, possono accedervi soltanto gli utenti che dispongono di diritti di amministratore.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\LSA.

  3. Eliminare il valore denominato CrashOnAuditFail (è necessario eliminare l'intero valore, non solo i dati valore).

  4. Copiare il registro eventi di protezione in una posizione separata. Per impostazione predefinita, i registri eventi di protezione (SecEvent.Evt) si trovano in %SystemRoot%\System32\Config, in cui %SystemRoot% è il percorso di installazione del sistema operativo Microsoft Windows®.

  5. Aprire il Visualizzatore eventi, fare clic con il pulsante destro del mouse su Protezione, quindi su Proprietà.

  6. Nella pagina Proprietà protezione fare clic su Cancella registro. Quando viene richiesto di salvare il registro, fare clic su Sì quindi specificare un percorso per il salvataggio.

    Nota Nella pagina Proprietà protezione è anche possibile aumentare le dimensioni del registro modificando il campo Dimensione massima registro quindi facendo clic su Applica.

  7. Riavviare il server.

  8. Verificare che gli utenti possano accedere al server connettendosi a una cassetta postale di Exchange.

  9. Ricreare la chiave CrashonAuditFail del Registro di sistema e impostare i dati del valore su 1.

  10. Riavviare il server per rendere effetive le impostazioni di CrashonAuditFail.

  11. Eliminare e salvare periodicamente i registri di protezione del server per assicurare che non venga superata la dimensione massima. Per ulteriori informazioni, consultare l'articolo 312571 della Microsoft Knowledge Base "Il registro eventi interrompe la registrazione prima di raggiungere la dimensione massima del registro" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=312571.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul ripristino da errori di CrashOnAuditFail, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 232564 "Interruzione 0xC0000244 quando il registro di protezione è pieno" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232564.

  • 829082 "Ricezione del messaggio di errore "Errore di interruzione 0xC0000244 {Controllo fallito}" quando la chiave crashonauditfail del Registro di sistema è impostata su 1 in un computer basato su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=829082.


Elenco di riferimenti personalizzati alle cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchFolderAffinityCustom contiene nomi server di Exchange. Se Exchange Server Analyzer rileva che l'attributo msExchFolderAffinityCustom elenca nomi server, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Exchange Server 2003 utilizza gruppi di routing per determinare i riferimenti alle cartelle pubbliche.

Per impostazione predefinita, Exchange Server 2007 utilizza i costi da sito a sito del servizio directory di Active Directory per determinare il routing dei riferimenti alle cartelle pubbliche.

Se l'attributo msExchFolderAffinityCustom elenca nomi di server, sono stati configurati riferimenti personalizzati sul server di Exchange. L'attributo msExchFolderAffinityCustom è un attributo per server.

In generale è consigliabile utilizzare il comportamento predefinito per i riferimenti alle cartelle pubbliche. Tuttavia, può essere necessario creare un elenco di riferimenti personalizzati. Il messaggio di configurazione non predefinita è un messaggio puramente informativo. Non è richiesta alcuna operazione.

Per ripristinare la configurazione predefinita in Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Localizzare l'oggetto server nel quale sono stati configurati i riferimenti personalizzati alle cartelle pubbliche. Il nome del server di Exchange in cui sono configurati i riferimenti alle cartelle pubbliche personalizzate è specificato nel messaggio di Exchange Server Analyzer.

  3. Fare clic con il pulsante destro del mouse su Server_Name, quindi scegliere Proprietà.

  4. Nella scheda Riferimenti a cartelle pubbliche, selezionare Utilizza gruppi di routing nella finestra a discesa Opzioni di riferimento a cartelle pubbliche.

  5. Fare clic su Applica, quindi su OK.
Per ripristinare la configurazione predefinita in Exchange Server 2007

  1. Il codice seguente è un esempio del comando Set-PublicFolderDatabase di Exchange Management Shell che disattiva l'utilizzo di PublicFolderRefferalServerList per il database delle cartelle pubbliche "MyServer\First Storage Group\Public Folder Database".
Copia codice
Set-PublicFolderDatabase -Identity "MyServer\First Storage Group\Public Folder Database" -UseCustomReferralServerList $false

Il parametro UseCustomReferralServerList specifica se usare i costi del server specificati dal parametro PublicFolderReferralServerList. Se impostato su $true, il server utilizza i costi del parametro PublicFolderReferralServerList per creare i riferimenti alle cartelle pubbliche. Se impostato su $false, il server utilizza i costi da sito a sito di Active Directory per creare i riferimenti alle cartelle pubbliche.

Nota:
Se si imposta il parametro su $false, il parametro PublicFolderReferralServerList verrà annullato.

Per ulteriori informazioni sul comando Set-PublicFolderDatabase di Exchange Management Shell, consultare "Set-PublicFolderDatabase" nella sezione Informazioni tecniche della documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80813.

Per ulteriori informazioni sulla replica di cartelle pubbliche, consultare Best Practices for Exchange Server Public Folders all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46437 (informazioni in lingua inglese).


L'oggetto Performance Monitor Database non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Log Record Stalls/sec dell'oggetto prestazioni Database per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni Database è disabilitato.

  • L'oggetto Performance Monitor Database non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestazione.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®).

Nella procedura seguente viene illustrato come correggere le prime due condizioni. Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni Database sia abilitato.

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina Exctrlst.exe: Extensible Performance Counter List all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300965 della Microsoft Knowledge Base "Ricreazione manuale dei valori della libreria dei contatori delle prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


File DAVEX.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Il servizio Client DHCP non è in esecuzione
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio Client DHCP (Dynamic Host Configuration Protocol). Se Exchange Server Analyzer rileva che il valore della chiave Started per il servizio Client DHCP su un server di Exchange è impostato su False, verrà visualizzato un avviso.

Questo avviso indica che il servizio Client DHCP non è in esecuzione. Il servizio Client DHCP esegue aggiornamenti dinamici del DNS (Domain Name System). Se il servizio Client DHCP non è in esecuzione, possono verificarsi errori di aggiornamento dinamico. Se un server di Exchange non esegue questo servizio, il problema più comune che può verificarsi sarà relativo al flusso di posta.

Per risolvere il problema, impostare il servizio Client DHCP sull'avvio automatico, quindi avviare il servizio.

Nota:
Il servizio Client DHCP deve essere in esecuzione, anche se il server è configurato per l'utilizzo degli indirizzi IP statici anziché di DHCP.
Per abilitare il servizio Client DHCP

  1. Aprire lo snap-in Servizi.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su Servizio Client DHCP e scegliere Proprietà.

  3. Nella scheda Generale fare clic su Tipo di avvio e selezionare Automatico.

  4. Fare clic su Start, quindi su OK.

Per ulteriori informazioni sul servizio Client DHCP, consultare l'articolo 264539 della Microsoft Knowledge Base "Gli aggiornamenti dinamici del DNS non funzionano se si interrompe il servizio Client DHCP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264539.

Per ulteriori informazioni sul protocollo di aggiornamento dinamico del DNS, consultare l'articolo 816592 della Microsoft Knowledge Base "Configurazione di aggiornamenti dinamici del DNS in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592.


Dr. Watson non abilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il valore relativo alla seguente chiave del Registro di sistema per determinare se Dr. Watson è configurato come debugger predefinito delle applicazioni in Windows®:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

Se Exchange Server Analyzer rileva che il valore Debugger non comincia per drwtsn32, verrà visualizzato un messaggio di configurazione non predefinita.

Questo messaggio indica che Dr. Watson non è abilitato. A partire da Windows NT®, è stato incluso in Windows un debugger in modalità applicazione denominato Dr. Watson. Quando un'applicazione si arresta in modo anomalo, l'errore può essere intercettato mediante Dr. Watson che registra una serie di informazioni, quali dati sulla piattaforma, un elenco dei processi in esecuzione, l'ID del processo che ha provocato l'errore, un'immagine della memoria di tale processo, uno o più stack di chiamate e un puntatore all'errore stesso. La maggior parte delle informazioni raccolte rappresenta informazioni di debug a basso livello destinate allo sviluppatore del processo che ha provocato l'errore.

È consigliabile eseguire Windows con un debugger in modalità applicazione abilitato. Se Dr. Watson non è abilitato e non è in uso un debugger delle applicazioni alternativo, si consiglia di abilitare Dr. Watson mediante la procedura riportata di seguito.

Per abilitare Dr. Watson

  1. Aprire una finestra del prompt dei comandi.

  2. Al prompt dei comandi, digitare drwtsn32 -i.

Per ulteriori informazioni sull'abilitazione o disabilitazione di Dr. Watson, consultare l'articolo 188296 della Microsoft Knowledge Base "Disabilitazione di Dr. Watson per Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=188296.


Nome computer DSA non corrispondente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione del valore DSA Computer:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo name per ciascun oggetto di Exchange Server.

Infine, Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster (ClusSvc). Il valore True indica che il servizio cluster è avviato, mentre il valore False indica che non è in esecuzione.

Se Exchange Server Analyzer rileva che il valore della chiave DSA Computer non corrisponde al valore dell'attributo name dell'oggetto server in Active Directory per i computer Exchange Server non eseguiti in un cluster di Windows Server, verrà visualizzato un messaggio di errore.

Per correggere questo errore, è necessario modificare la chiave DSA Computer del Registro di sistema affinché corrisponda al valore dell'attributo name in Active Directory.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro fare doppio clic su DSA Computer, digitare il nome corretto per questo computer, quindi fare clic su OK.

  4. Uscire dall'editor del Registro di sistema e riavviare il computer Exchange Server per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


File DSACCESS.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


La cache di configurazione di DSAccess è piena
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-05-24

Microsoft® Exchange Server Analyzer Tool esegue query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches per determinare il valore corrente di TotalEntriesMemoryConfigurationData. Se Exchange Server Analyzer Tool rileva che il valore di TotalEntriesMemoryConfigurationData equivale alla dimensione totale della cache di configurazione di DSAccess (MaxMemoryConfig), verrà visualizzato un avviso.

DSAccess è un componente interno di Exchange 2000 Server ed Exchange Server 2003 che consente di controllare il modo in cui i componenti di Exchange accedono al servizio directory di Active Directory®. La funzione principale di DSAccess è quella di conservare le informazioni su diversi eventi e operazioni relativi alle directory. Ad esempio, DSAccess trova la topologia di Active Directory e rileva se i controller di dominio e i server di catalogo globali sono disponibili e rispondono alle query. Inoltre, tutte le query eseguite nelle directory da componenti interni quali l'archivio di Exchange, ad esempio la risoluzione dei destinatari, le ricerche di impostazioni di configurazione e così via, vengono instradate tramite DSAccess. Come parte di questo processo, DSAccess memorizza nella cache i risultati di alcune di queste query. In tal modo, se la stessa informazione viene richiesta due volte, può essere recuperata dalla cache di DSAccess anziché tramite un'ulteriore query LDAP (Lightweight Directory Access Protocol) in Active Directory.

Poiché la dimensione massima predefinita per la cache di configurazione di DSAccess è stata ridotta da un valore di 25 MB in Exchange 2000 Server a un valore di 5 MB in Exchange Server 2003, questo avviso può essere generato su entrambe le versioni di Exchange. Indipendentemente dalla versione di Exchange che genera questo avviso, il problema deve essere corretto al più presto.

Il valore MaxMemoryConfig viene spesso utilizzato insieme al valore MaxMemoryUser che controlla la quantità massima di memoria che gli oggetti dati utente nella cache di DSAccess possono utilizzare. Se si modifica o si rimuove il valore MaxMemoryConfig come descritto nella procedura seguente, è necessario modificare o rimuovere analogamente il valore MaxMemoryUser, come descritto in DSAccess user cache value is non-default.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Aumentare il valore di MaxMemoryConfig. Se la chiave Instance0 o il valore DWORD MaxMemoryConfig non esistono, è possibile crearli manualmente. I dati valore per la chiave MaxMemoryConfig del Registro di sistema sono in kilobyte (KB); pertanto una voce decimale 15000 equivale a 15 MB. Se il valore esiste, aumentarlo del 10%. Se il valore non esiste, è consigliabile un punto di partenza di 10 MB.

  4. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Supervisore sistema di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Valore della cache di configurazione di DSAccess non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se la dimensione della cache di configurazione di DSAccess è stata modificata rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryConfig

Se Exchange Server Analyzer rileva la presenza e l'avvenuta configurazione di MaxMemoryConfig, verrà visualizzato un messaggio di configurazione non predefinita.

MaxMemoryConfig è un parametro del Registro di sistema di Exchange 2000 Server che in genere non è più necessario in Exchange Server 2003. MaxMemoryConfig controlla la quantità massima di memoria che gli oggetti dati di configurazione nella cache di configurazione di DSAccess possono utilizzare. DSAccess è un componente interno di Exchange 2000 Server e Exchange Server 2003 che controlla il modo in cui tutti i componenti di Exchange accedono al servizio directory di Active Directory®. La funzione principale di DSAccess è quella di conservare le informazioni su diversi eventi e operazioni relativi alle directory. Ad esempio, DSAccess trova la topologia di Active Directory e rileva se i controller di dominio e i server di catalogo globali sono disponibili e rispondono alle query. Inoltre, tutte le query eseguite nelle directory da componenti interni quali l'archivio di Exchange, ad esempio la risoluzione dei destinatari, le ricerche di impostazioni di configurazione e così via, vengono instradate tramite DSAccess. Come parte di questo processo, DSAccess memorizza nella cache i risultati di alcune di queste query. In tal modo, se la stessa informazione viene richiesta due volte, può essere recuperata dalla cache di DSAccess anziché tramite un'ulteriore query LDAP (Lightweight Directory Access Protocol) in Active Directory.

In Exchange 2000 Server, la dimensione della cache di configurazione inizialmente era impostata su 25 MB. Nella maggior parte dei server di Exchange tale valore era maggiore del necessario. L'impostazione MaxMemoryConfig era utilizzata per recuperare e riallocare parte della memoria utilizzata dalla cache di configurazione di DSAccess. In genere, il valore configurato era pari a 5 MB. Grazie a verifiche interne e ai commenti e suggerimenti dei clienti, Microsoft ha scoperto che 3 MB è la dimensione ottimale, infatti Exchange Server 2003 utilizza questa come impostazione preconfigurata. Quando si esegue un aggiornamento da Exchange 2000 Server a Exchange Server 2003, vengono conservate tutte le impostazioni manuali. Se il server di Exchange viene aggiornato da Exchange 2000 Server a Exchange Server 2003, è opportuno assicurarsi che il valore MaxMemoryConfig non sia superiore a 5 MB.

Il valore MaxMemoryConfig viene spesso utilizzato insieme al valore MaxMemoryUser che controlla la quantità massima di memoria che gli oggetti dati utente nella cache di DSAccess possono utilizzare. Se si modifica o si rimuove il valore MaxMemoryConfig come descritto nella procedura seguente, è necessario modificare o rimuovere analogamente il valore MaxMemoryUser, come descritto in Valore della cache utente di DSAccess non predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per utilizzare il valore MaxMemoryConfig del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Verificare o modificare il valore MaxMemoryConfig.
Nota:
Il valore per questa voce del Registro di sistema è in kilobyte (KB). Se il valore è impostato su 3000 o su un valore inferiore, è necessario eliminare MaxMemoryConfig e riavviare il servizio Supervisore sistema di Microsoft Exchange per ripristinare le impostazioni predefinite di Exchange Server 2003.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su DSAccess, consultare l'articolo 250570 della Knowledge Base "Rilevamento del server del servizio directory e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570.


Parametro DSAccess DisableNetLogonCheck del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se DSAccess (Directory Service Access) è stato configurato per l'utilizzo di un protocollo ping non predefinito:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\DisableNetLogonCheck

Se Exchange Server Analyzer rileva che la chiave DisableNetLogonCheck è presente e configurata con un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Quando DSAccess rileva la topologia del servizio directory di Active Directory, determina se i controller di dominio funzionanti rilevati e i server di catalogo globale sono adatti all'uso. Nel rilevamento iniziale e nei rilevamenti successivi DSAccess determina l'idoneità del server eseguendo una serie di test. Un test invia una RPC al server directory per verificarne l'idoneità generale. In uno scenario di rete perimetrale in cui il traffico RPC non è di solito consentito, si verifica un errore nella ricerca RPC DSAccess. Tuttavia, DSAccess continua a generare RPC finché non si verifica un errore, che può richiedere molto tempo. Verifiche così frequenti possono compromettere le prestazioni dei computer che eseguono Exchange Server. Per questo motivo, gli amministratori aggiungono frequentemente la chiave DisableNetLogonCheck del Registro di sistema e la configurano con un valore di 1 nei server Exchange localizzati nella rete perimetrale.

Se il server di Exchange che ha generato il messaggio di configurazione non predefinita si trova in una rete perimetrale nella quale RPC è disabilitata, o se si è stabilito che DSAccess non esegua il test di idoneità, è preferibile impostare la chiave DisableNetLogonCheck su 1. In caso contrario, è necessario eliminare la chiave DisableNetLogonCheck.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per utilizare la chiave DisableNetLogonCheck

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Fare doppio clic sulla chiave DisableNetLogonCheck e impostare il valore DWORD su 1..

  4. Chiudere l'editor del Registro di sistema. Non è necessario riavviare nessun servizio per rendere effettive le modifiche.

Per eliminare la chiave DisableNetLogonCheck

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Eliminare il valore denominato DisableNetLogonCheck.

  4. Chiudere l'editor del Registro di sistema. Non è necessario riavviare nessun servizio per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla chiave DisableNetLogonCheck del Registro di sistema, consultare l'articolo 320228 della Microsoft Knowledge Base "XADM: Utilizzo del valore DisableNetLogonCheck del Registro di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320228.


DSAccess è stato hardcoded
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_DSAccessDC nello spazio dei nomi ROOT\MicrosoftExchangeV2 per determinare il valore della chiave ConfigurationType. Se il valore di questa chiave è 0, verrà visualizzato un messaggio di configurazione non predefinita.

La proprietà ConfigurationType indica se l'istanza descrive un controller di dominio che è stato rilevato automaticamente oppure un controller specificato manualmente. Per impostazione predefinita, il componente Directory Service Access (DSAccess) di Exchange Server rileva in modo dinamico la topologia del servizio directory di Active Directory® e individua automaticamente i controller di dominio e i server di catalogo globale. Nei computer che eseguono Exchange Server 2000 Service Pack 2 o versioni successive o Exchange Server 2003, Exchange System Manager include la possibilità di immettere un elenco hardcoded dei server Active Directory per l'utilizzo da parte di DSAccess.

A meno che l'hard-coding dei server di elenchi in linea per DSAccess non sia stato eseguito per un motivo specifico, è necessario rimuovere l'elenco dei server e ripristinare le impostazioni predefinite di rilevamento automatico. È consigliabile utilizzare il rilevamento automatico della topologia per usufruire del failover del catalogo globale.

Per ripristinare l'impostazione predefinita

  1. Fare clic su Start, scegliere Programmi, Microsoft Exchange, quindi fare clic su Gestore di sistema.

  2. Espandere Gruppi amministrativi, <NomeGruppoAmministrativo>, Server, <NomeServer> (dove AdminGroupName è il nome del gruppo amministrativo che contiene il server di Exchange e ServerName è il nome del server di Exchange che si desidera configurare).

  3. Fare clic con il pulsante destro del mouse sul server di Exchange, quindi scegliere Proprietà.

  4. Selezionare la scheda Accesso alla directory.

  5. Dalla casella di riepilogo Mostra, scegliere Controller di dominio di configurazione.

  6. Selezionare la casella di controllo Rileva automaticamente i server.

  7. Fare clic su Sì quando viene visualizzato il seguente prompt dei comandi di Gestore di sistema di Exchange: "Il server o i server selezionati manualmente specificati verranno eliminati. Continuare?"

  8. Dalla casella di riepilogo Mostra, scegliere Controller di dominio.

  9. Selezionare la casella di controllo Rileva automaticamente i server.

  10. Fare clic su Sì quando viene visualizzato il seguente prompt dei comandi di Gestore di sistema di Exchange: "Il server o i server selezionati manualmente specificati verranno eliminati. Continuare?"

  11. Dalla casella di riepilogo Mostra, scegliere Server di catalogo globali.

  12. Selezionare la casella di controllo Rileva automaticamente i server.

  13. Fare clic su Sì quando viene visualizzato il seguente prompt dei comandi di Gestore di sistema di Exchange: "Il server o i server selezionati manualmente specificati verranno eliminati. Continuare?"

  14. Fare clic su OK per salvare le modifiche.

Per ulteriori informazioni su DSAccess e sul rilevamento dei servizi directory, consultare l'articolo 250570 della Microsoft Knowledge Base "Rilevamento del servizio directory del server e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570.


La porta 389 non viene utilizzata da DSAccess per le richieste LDAP del controller di dominio
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_DSAccessDC nello spazio dei nomi ROOT\MicrosoftExchangeV2 per determinare il valore della chiave LDAPPort. Se il valore per la chiave LDAPPort non è impostato su 389, verrà visualizzato un messaggio relativo a una configurazione non predefinita.

La chiave LDAPPort rappresenta il numero di porta TCP su cui il controller di dominio ascolta le richieste LDAP (Lightweight Directory Access Protocol). Gli amministratori possono utilizzare LDAP su Secure Sockets Layer (SSL) sulla porta TCP 636 (controller di dominio) o sulla porta TCP 3269 (catalogo globale) come misura di protezione.

Per impostazione predefinita, un server di catalogo globale ascolta le comunicazioni LDAP sulla porta 3268. Tuttavia, se è installata una CA Enterprise, tutti i controller di dominio richiedono automaticamente un certificato e sono in grado di supportare comunicazioni LDAP su SSL sulla porta TCP 636. Se il controller di dominio è configurato anche come catalogo globale, è anche in grado di supportare comunicazioni LDAP su SSL sulla porta 3269.

Per risolvere il problema

  • Non è richiesta alcuna operazione. Exchange Server Analyzer identifica una configurazione non predefinita.

Per ulteriori informazioni su DSAccess e le porte LDAP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 247078, "Abilitazione della comunicazione SSL su LDAP per i controller di dominio in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078.

  • 246228, "XGEN: Profili DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228.


La porta 3268 non viene utilizzata daDSAccess per le richieste del catalogo globale LDAP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_DSAccessDC nello spazio dei nomi ROOT\MicrosoftExchangeV2 per determinare il valore della chiave LDAPPort. Se il valore per la chiave LDAPPort non è impostato su 3268, verrà visualizzato un messaggio relativo a una configurazione non predefinita.

La chiave LDAPPort rappresenta il numero di porta TCP su cui il controller di dominio ascolta le richieste LDAP (Lightweight Directory Access Protocol). Gli amministratori possono utilizzare LDAP su Secure Sockets Layer (SSL) sulla porta TCP 636 (controller di dominio) o sulla porta TCP 3269 (catalogo globale) come misura di protezione.

Per impostazione predefinita, un server di catalogo globale ascolta le comunicazioni LDAP sulla porta 3268. Tuttavia, se è installata una CA Enterprise, tutti i controller di dominio richiedono automaticamente un certificato e sono in grado di supportare comunicazioni LDAP su SSL sulla porta TCP 636. Se il controller di dominio è configurato anche come catalogo globale, è anche in grado di supportare comunicazioni LDAP su SSL sulla porta 3269.

Per ulteriori informazioni su DSAccess e le porte LDAP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 247078, "Abilitazione della comunicazione SSL su LDAP per i controller di dominio in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=247078.

  • 246228, "XGEN: Profili DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246228.


Parametro DSAccess LdapKeepAliveSecs del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se DSAccess è stato configurato per l'utilizzo del protocollo di implementazione LDAP (wLDAP) per sistemi operativi Microsoft Windows®:

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Se Exchange Server Analyzer rileva che il valore LdapKeepAliveSecs è presente e configurato con un valore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Quando DSAccess rileva la topologia del servizio directory di Active Directory, determina se l'elenco dei controller di dominio funzionanti rilevato e dei server di catalogo globale è adatto all'uso. Nel rilevamento iniziale e nei rilevamenti successivi DSAccess determina l'idoneità del server eseguendo una serie di test. Per impostazione predefinita, uno dei test di idoneità utilizza il protocollo ICMP per eseguire il ping nei controller di dominio per verificare la disponibilità dei server.

Non tutte le connessioni nella rete supportano il protocollo ICMP. Questa situazione si verifica ad esempio in una rete perimetrale nella quale la connettività ICMP tra il server di Exchange e i controller di dominio non è permessa. In questi casi l'impostazione del parametro LdapKeepAliveSecs del Registro di sistema su 0 impone a DSAccess l'utilizzo dell'implementazione Windows di LDAP (wLDAP) per i test di idoneità.

Se il server di Exchange che ha generato il messaggio di configurazione non predefinita si trova in una rete perimetrale nella quale RPC è disabilitato o in una rete nella quale il protocollo ICMP non è supportato, è necessario non modificare la configurazione della chiave LdapKeepAliveSecs. In caso contrario, è necessario eliminare la chiave.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per eliminare la chiave LdapKeepAliveSecs

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Eliminare il valore denominato LdapKeepAliveSecs.

  4. Chiudere l'editor del Registro di sistema. Non è necessario riavviare nessun servizio per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla chiave LdapKeepAliveSecs del Registro di sistema, consultare l'articolo 320529 della Microsoft Knowledge Base "XADM: L'utilizzo di DSAccess in uno scenario firewall in una rete perimetrale richiede l'impostazione della chiave del Registro di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529.


Il parametro LdapKeepAliveSecs DSAccess del Registro di sistema è impostato su un valore non supportato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Best Practices Analyzer legge la seguente voce del Registro di sistema per determinare se DSAccess è stato configurato per l'utilizzo del protocollo di implementazione LDAP (Lightweight Directory Access Protocol) di sistemi operativi Microsoft Windows® (wLDAP):

HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet\Services\MSExchangeDSAccess\ LdapKeepAliveSecs

Se Exchange Server Analyzer rileva che la voce LdapKeepAliveSecs è presente ed è stata configurata con un valore diverso da 0, verrà visualizzato un avviso.

Quando DSAccess rileva la topologia del servizio directory di Active Directory, determina se l'elenco dei controller di dominio funzionanti rilevato e dei server di catalogo globale è adatto all'uso. Nel rilevamento iniziale e nei rilevamenti successivi DSAccess determina l'idoneità del server eseguendo una serie di test. Per impostazione predefinita, uno dei test di idoneità utilizza il protocollo ICMP per eseguire il ping nei controller di dominio per verificare la disponibilità dei server.

Non tutte le connessioni nella rete supportano il protocollo ICMP. Questa situazione si verifica ad esempio in una rete perimetrale nella quale la connettività ICMP tra il server di Exchange e i controller di dominio non è permessa. In questi casi l'impostazione del parametro LdapKeepAliveSecs del Registro di sistema su 0 impone a DSAccess l'utilizzo dell'implementazione Windows di LDAP (wLDAP) per i test di idoneità.

Se il server di Exchange che ha generato l'avviso si trova in una rete perimetrale nella quale la RPC è disabilitata o in una rete nella quale ICMP non è consentito, impostare la chiave LdapKeepAliveSecs su 0. In caso contrario, è necessario eliminare la chiave. Qualsiasi valore diverso da zero non è supportato da questa chiave del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per modificare la chiave LdapKeepAliveSecs

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Fare doppio clic sulla chiave LdapKeepAliveSecs e impostare il valore DWORD su 0 (zero).

  4. Chiudere l'editor del Registro di sistema. Non è necessario riavviare nessun servizio per rendere effettive le modifiche.

Per eliminare la chiave LdapKeepAliveSecs

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess

  3. Eliminare il valore denominato LdapKeepAliveSecs.

  4. Chiudere l'editor del Registro di sistema. Non è necessario riavviare nessun servizio per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla chiave LdapKeepAliveSecs del Registro di sistema, consultare l'articolo 320529 della Microsoft Knowledge Base "XADM: L'utilizzo di DSAccess in uno scenario firewall in una rete perimetrale richiede l'impostazione della chiave del Registro di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320529.


Parametro DSAccess PreloadBaseDNs del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la funzionalità di precaricamento della ricerca di DSAccess (Directory Service Access) è stata modificata rispetto alla configurazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadBaseDNs

I dati del valore predefinito per PreloadBaseDNs sono riportati di seguito:

'"'

'"'

'"'

'"'

'"'

Se Exchange Server Analyzer rileva che il valore di PreloadBaseDNs è stato modificato rispetto alle impostazioni predefinite, verrà visualizzato un avviso. Questa configurazione viene segnalata perché riguarda un'impostazione che dovrebbe essere modificata solo dopo aver contattato il Servizio Supporto Tecnico Clienti Microsoft.

La cache di DSAccess si trova sul server di Exchange e contiene i record di configurazione e quelli dell'utente recuperati dal servizio directory di Active Directory®. È possibile accedere ai record contenuti nella cache di DSAccess utilizzando il nome distinto (DN) di un oggetto, l'identificatore univoco globale (GUID), oppure una chiave costituita dall'ambito, BaseDN, e dal filtro di ricerca utilizzato per rilevare l'oggetto in Active Directory. Per gli accessi successivi in cui si utilizza lo stesso DN, GUID o chiave, il record verrà rilevato nella cache. Pertanto, si impedisce un inutile sovraccarico di Active Directory per ricerche identiche. Tuttavia, sebbene DSAccess richieda lo stesso set di attributi per l'oggetto utente, il carico su Active Directory non viene impedito quando il filtro di ricerca è diverso da quello contenuto nella cache.

Il precaricamento della ricerca consente di evitare i problemi delle ricerche multiple in Active Directory provocati dalla presenza di vari filtri di ricerca sul medesimo oggetto utente. Il precaricamento della ricerca funziona in base alle caratteristiche costitutive della chiave descritta precedentemente, in cui ciascuna voce di ricerca è costituita dall'ambito, BaseDN, e dal filtro di ricerca.

Per ulteriori informazioni sulla configurazione del precaricamento della ricerca di DSAccess, consultare l'articolo 250572 della Microsoft Knowledge Base "XCON: Precaricamento e cache di DSAccess Cache" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572.


Parametro DSAccess PreloadFilters del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la funzionalità di precaricamento della ricerca di DSAccess (Directory Service Access) è stata modificata rispetto alla configurazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\PreloadFilters

I dati del valore predefinito per PreloadFilters sono riportati di seguito:

(&(|(msExchMasterAccountSID=%)(objectSid=%))(!(objectClass=foreignSecurityPrincipal)))(|(msExchMailboxGUID=%)(objectGUID=%))(legacyExchangeDN=%)(msExchMailboxGUID=%)(&(proxyAddresses=%)(|(objectClass=user)(objectClass=contact)))

Se Exchange Server Analyzer rileva che il valore per PreloadFilters è stato modificato rispetto alle impostazioni predefinite, verrà visualizzato un avviso. In Exchange Server Analyzer viene segnalata questa configurazione perché le impostazioni del registro di PreloadFilters dovrebbero essere modificate solo dopo aver contattato il Servizio Supporto Tecnico Clienti Microsoft.

La cache di DSAccess si trova sul server di Exchange e contiene i record di configurazione e quelli dell'utente recuperati dal servizio directory di Active Directory®. È possibile accedere ai record contenuti nella cache utilizzando il nome distinto (DN) di un oggetto, l'identificatore univoco globale (GUID), oppure una chiave costituita dall'ambito, BaseDN, e dal filtro di ricerca utilizzato per rilevare l'oggetto in Active Directory. Per gli accessi successivi in cui si utilizza lo stesso DN, GUID o chiave, il record verrà rilevato nella cache. Pertanto, si impedisce un inutile sovraccarico di Active Directory per ricerche identiche. Tuttavia, sebbene DSAccess richieda lo stesso set di attributi per l'oggetto utente, il carico su Active Directory non viene impedito quando il filtro di ricerca è diverso da quello contenuto nella cache.

Il precaricamento della ricerca consente di evitare i problemi delle ricerche multiple in Active Directory provocati dalla presenza di vari filtri di ricerca sul medesimo oggetto utente. Il precaricamento della ricerca funziona in base alle caratteristiche costitutive della chiave descritta precedentemente, in cui ciascuna voce di ricerca è costituita dall'ambito, BaseDN, e dal filtro di ricerca.

Per ulteriori informazioni sulla configurazione del precaricamento della ricerca di DSAccess, consultare l'articolo 250572 della Microsoft Knowledge Base "XCON: Precaricamento e cache di DSAccess Cache" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250572.


DSAccess segnala che il server di Active Directory non funziona
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_DSAccessDC nello spazio dei nomi ROOT\MicrosoftExchangeV2 per determinare il valore della chiave IsUp. Se la chiave IsUp è impostata su False, verrà visualizzato un messaggio di errore.

Se la chiave IsUp è impostata su True, indica che il controller di dominio che ha risposto per ultimo al server di Exchange ha tentato di stabilire una connessione. Se la chiave IsUp è impostata su False, indica che il controller di dominio non ha risposto ai tentativi di connessione.

La mancata risposta non sempre indica che il controller di dominio o il catalogo globale è inattivo o che non funziona correttamente. A volte, è possibile che l'errore sia provocato da problemi di connettività della rete tra il server di Exchange e il controller di dominio. Questo errore potrebbe essere anche il risultato di un firewall tra il server di Exchange e il controller di dominio su cui non sono state aperte le porte appropriate.

Per risolvere il problema

  1. Eseguire il PING per verificare che il controller di dominio sia in esecuzione.

  2. Nel caso in cui sia presente un firewall, assicurarsi che siano aperte le porte appropriate. Tenere presente che i firewall possono essere configurati anche per rifiutare pacchetti PING. Per ulteriori informazioni sull'apertura e sulla chiusura di porte specifiche, consultare la documentazione del firewall.

  3. Assicurarsi che non siano presenti altri problemi di rete, ad esempio opzioni, router e cavi che non funzionano correttamente.

Per ulteriori informazioni su DSAccess e sul rilevamento dei servizi directory, consultare l'articolo 250570 della Microsoft Knowledge Base "Rilevamento del servizio directory del server e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, consultare l'articolo 325847 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.


DSAccess segnala che il server di Active Directory non è sincronizzato con il resto della topologia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_DSAccessDC nello spazio dei nomi ROOT\MicrosoftExchangeV2 per determinare il valore della chiave IsInSync. Se il valore della chiave IsInSync è False, verrà visualizzato un messaggio di errore.

La chiave IsInSync indica se il controller di dominio è sincronizzato con il server di catalogo globale e con il controller di dominio di configurazione. Il valore True indica che il server è sincronizzato, mentre il valore False indica che il controller di dominio non è sincronizzato.

Per risolvere il problema

  1. Esaminare l'ora su controller di dominio o catalogo globale. Assicurarsi che il servizio Ora sia avviato o sincronizzare l'ora del server Exchange con quella del server di catalogo globale e con il controller di dominio di configurazione.

  2. Utilizzare lo strumento Monitoraggio replica (Replmon) per controllare, verificare e, se necessario, risolvere i problemi relativi alla replica del controller di dominio. Replmon è incluso negli strumenti di supporto di Microsoft® Windows 2000 Server e Microsoft® Windows Server™ 2003, è si trova nella cartella Support\Tools del CD di Windows Server.

Per ulteriori informazioni sul rilevamento di DSAccess e dei servizi directory, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 316300, "ID evento 2080 e MSExchangeDSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316300.

  • 250570, "Rilevamento del servizio directory del server e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570.


DSAccess segnala che il server di Active Directory impiega più di 2 secondi per rispondere alle richieste LDAP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_DSAccessDC nello spazio dei nomi ROOT\MicrosoftExchangeV2 per determinare i valori della chiave IsFast e della chiave IsUp. Se il valore della chiave IsUp è True, significa che il server di elenchi in linea utilizzato dal componente DSAccess (Directory Service Access) di Exchange Server è connesso alla rete e risponde. Il valore False indica che il server di elenchi in linea non risponde. Se il valore di IsFast è True, significa che il tempo di risposta di questo server di elenchi in linea è minore di due secondi. Il valore False indica che il tempo di risposta è maggiore di due secondi. Se il valore di IsUp è True, ma il valore di IsFast è False, verrà visualizzato un messaggio di errore.

Per risolvere il problema

  1. Esaminare il carico del controller di dominio e del catalogo globale. Un controller di dominio e un catalogo globale sovraccarichi possono presentare tempi di risposta più lunghi alle chiamate LDAP (Lightweight Directory Access Protocol).

  2. Verificare che almeno un catalogo globale nel sito locale del servizio directory di Active Directory® abbia prestazioni ottimali.

Per ulteriori informazioni su DSAccess e sul rilevamento dei servizi directory, consultare l'articolo 250570 della Microsoft Knowledge Base "Rilevamento del servizio directory del server e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570.


Parametro DSAccess TopoCreateTimeoutSecs del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stato modificato il timeout di inizializzazione predefinito di DSAccess (Directory Service Access):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess\TopoCreateTimeoutSecs

Se Exchange Server Analyzer rileva che la chiave TopoCreateTimeoutSecs del Registro di sistema esiste e presenta un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

All'avvio, in DSAccess viene utilizzato un processo di rilevamento per identificare la topologia del servizio directory di Active Directory® e per valutare la disponibilità dei controller di dominio e dei server di catalogo globale. A intervalli di 15 minuti dal completamento dell'avvio, in DSAccess viene utilizzato quasi lo stesso processo per rilevare nuovamente la topologia e per verificare le modifiche apportate alla disponibilità del server. Per impostazione predefinita, l'inizializzazione di DSAccess durante l'avvio deve essere completata entro un minuto. In caso contrario, DSAccess verrà arrestato. In genere, l'intervallo di un minuto è sufficiente per completare l'inizializzazione.

Nota:
Se i server di elenchi in linea utilizzati da DSAccess sono hardcoded, verrà ignorato il processo di rilevamento e verrà eseguita solo la verifica dell'idoneità del server.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Eliminare il valore denominato TopoCreateTimeoutSecs.

  4. Chiudere l'editor del Registro di sistema.

Se è presente questa chiave del Registro di sistema, sarà necessario valutare la topologia della rete in uso. La necessità di un intervallo di tempo aggiuntivo per l'inizializzazione di DSAccess nell'organizzazione potrebbe indicare un problema di struttura o di rete. Per garantire il funzionamento ottimale di Exchange, è necessario un accesso rapido e affidabile ai controller di dominio e in particolare ai server di catalogo globale.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'accesso alla directory, consultare Understanding and Troubleshooting Directory Access all'indirizzo http://go.microsoft.com/fwlink/?LinkId=39012 (informazioni in lingua inglese).


La cache utente di DSAccess è piena
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeDSAccess_MSExchangeDSAccessCaches per determinare il valore corrente di TotalEntriesMemoryUserData. Se Exchange Server Analyzer rileva che il valore di TotalEntriesMemoryUserData equivale alla dimensione totale della cache utente di DSAccess (MaxMemoryUser), verrà visualizzato un avviso.

DSAccess è un componente interno di Exchange 2000 Server ed Exchange Server 2003 che consente di controllare il modo in cui i componenti di Exchange accedono al servizio directory di Active Directory®. La funzione principale di DSAccess è quella di conservare le informazioni su diversi eventi e operazioni relativi alle directory. Ad esempio, DSAccess trova la topologia di Active Directory e rileva se i controller di dominio e i server di catalogo globali sono disponibili e rispondono alle query. Inoltre, tutte le query su directory eseguite da componenti interni di Exchange come archivio di Exchange vengono instradate tramite DSAccess, come ad esempio la risoluzione del destinatario, ricerche delle impostazioni di configurazione e altre. Come parte di questo processo, DSAccess memorizza nella cache i risultati di alcune di queste query. In tal modo, se la stessa informazione viene richiesta due volte, può essere recuperata dalla cache di DSAccess anziché tramite un'ulteriore query LDAP (Lightweight Directory Access Protocol) in Active Directory.

In Exchange 2000 Server, la cache utente era inizialmente impostata su una dimensione di 25 MB. Nei computer Exchange 2000 Server che servono un grande numero di client Microsoft Office Outlook® 2003, la dimensione predefinita della cache utente di DSAccess non era sufficiente. Per migliorare le prestazioni, in Exchange Server 2003 il valore predefinito della cache utente è stato ottimizzato e impostato su 140 MB.

Poiché la dimensione massima predefinita per la cache utente di DSAccess è stata aumentata da un valore di 25 MB in Exchange 2000 Server a un valore di 140 MB in Exchange Server 2003, questo avviso può essere generato su entrambe le versioni di Exchange. Indipendentemente dalla versione di Exchange che genera questo avviso, il problema deve essere corretto al più presto. Nei sistemi con una cache di DSAccess di dimensione limitata il recapito dei messaggi locale e la risoluzione dei nomi della Rubrica potrebbero essere più lenti di quanto desiderato.

È possibile configurare manualmente la dimensione massima della cache utenti mediante una voce del Registro di sistema sul server Exchange. MaxMemoryUser è un parametro del Registro di sistema di Exchange 2000 Server che consente a un amministratore di Exchange di controllare la quantità massima di memoria utilizzabile dagli oggetti dati utente della cache di DSAccess.

Il valore MaxMemoryUser viene spesso utilizzato insieme al valore MaxMemoryConfig, che controlla la quantità massima di memoria utilizzabile dagli oggetti dati di configurazione della cache di DSAccess. Se si modifica o si rimuove il valore MaxMemoryUser come descritto nella procedura che segue, allo stesso modo sarà necessario modificare o rimuovere il valore MaxMemoryConfig come descritto in Valore della cache di configurazione di DSAccess non predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema su un computer Exchange 2000 Server

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Aumentare il valore di MaxMemoryUser. Se questo valore DWORD non esiste, è possibile crearlo manualmente. I dati valore per questa voce del Registro di sistema sono in kilobyte (KB); pertanto una voce decimale 140000 equivale a 140 MB.

  4. Diminuire il valore di MaxMemoryConfig. Se questo valore DWORD non esiste, è possibile crearlo manualmente. Anche il valore per questa voce del Registro di sistema è in kilobyte (KB). È consigliato un valore di 5000 decimali, equivalenti a 5 MB.

  5. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il Supervisore sistema di Microsoft Exchange.

Per risolvere il problema su un computer Exchange Server 2003

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Se MaxMemoryUser esiste ed è configurato per meno di 140 MB, eliminare il valore MaxMemoryUser. Se MaxMemoryUser esiste ed è superiore a 140 MB, aumentarne il valore del 10%.

  4. Se MaxMemoryConfig esiste, eliminarlo.

  5. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il Supervisore sistema di Microsoft Exchange.

Prima di modificare il Registro di sistema e per informazioni sulle relative modalità, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su DSAccess, consultare l'articolo 250570 della Knowledge Base "Rilevamento del server del servizio directory e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570.


Valore della cache utente di DSAccess non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se la dimensione della cache degli oggetti utente di Accesso al servizio directory (DSAccess, Directory Service Access) è stata modificata rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0\MaxMemoryUser

Se Exchange Server Analyzer rileva la presenza e l'avvenuta configurazione di MaxMemoryUser , verrà visualizzato un messaggio di configurazione non predefinita.

MaxMemoryUser è un parametro del Registro di sistema del server di Exchange che consente a un amministratore di Exchange di controllare la quantità massima di memoria utilizzabile dagli oggetti dati utente della cache di DSAccess.

DSAccess è un componente interno di Exchange 2000 Server ed Exchange Server 2003 che consente di controllare il modo in cui i componenti di Exchange accedono al servizio directory di Active Directory®. La funzione principale di DSAccess è quella di conservare le informazioni su diversi eventi e operazioni relativi alle directory. Ad esempio, DSAccess trova la topologia di Active Directory e rileva se i controller di dominio e i server di catalogo globali sono disponibili e rispondono alle query. Inoltre, tutte le query eseguite nelle directory da componenti interni quali l'archivio di Exchange, ad esempio la risoluzione dei destinatari, le ricerche di impostazioni di configurazione e così via, vengono instradate tramite DSAccess. Come parte di questo processo, DSAccess memorizza nella cache i risultati di alcune di queste query. In tal modo, se la stessa informazione viene richiesta due volte, può essere recuperata dalla cache di DSAccess anziché tramite un'ulteriore query LDAP (Lightweight Directory Access Protocol) in Active Directory.

In Exchange 2000 Server, la dimensione della cache utente inizialmente era impostata su 25 MB. Nei computer Exchange 2000 Server che servono un grande numero di client Microsoft Office Outlook® 2003, la dimensione predefinita della cache utente di DSAccess non era sufficiente. Nei sistemi con una cache di DSAccess di dimensione limitata, il recapito dei messaggi locale e la risoluzione dei nomi della Rubrica potrebbero essere più lenti di quanto desiderato.

Per migliorare le prestazioni, in Exchange Server 2003 il valore predefinito per la cache utente è stato ottimizzato e impostato su 140 MB. Quando si esegue l'aggiornamento da Exchange 2000 Server a Exchange Server 2003, tutte le impostazioni manuali verranno mantenute. Se il server di Exchange in questione è stato aggiornato da Exchange 2000 Server a Exchange Server 2003, sarà necessario accertarsi che il valore di MaxMemoryUser sia almeno 140 MB.

Il valore MaxMemoryUser è stato di frequente utilizzato insieme al valore MaxMemoryConfig, che controlla la quantità massima di memoria utilizzabile dagli oggetti dati di configurazione della cache di DSAccess. Se si modifica o si rimuove il valore MaxMemoryUser come descritto nella procedura seguente, è necessario modificare o rimuovere analogamente il valore MaxMemoryConfig, come descritto in Valore della cache di configurazione di DSAccess non predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per utilizzare la chiave MaxMemoryUser del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Instance0

  3. Verificare o modificare il valore di MaxMemoryUser.

    Il valore per questa voce del Registro di sistema è in kilobyte (KB). Se il valore è impostato su 140.000 o una cifra minore, sarà necessario eliminare MaxMemoryUser e riavviare Supervisore sistema di Microsoft Exchange per utilizzare l'impostazione predefinita di Exchange Server 2003.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su DSAccess, consultare l'articolo 250570 della Knowledge Base "Rilevamento del server del servizio directory e utilizzo di DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570.


Il servizio DSProxy RFR è stato disabilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se il servizio di riferimento Directory Services Proxy (DSProxy RFR) è stato disabilitato:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\MSExchangeSA\Parameters\ No RFR Service

Se Exchange Server Analyzer che No RFR Service è presente e impostato sul valore 1, verrà visualizzato un messaggio di configurazione non predefinita.

Il componente DSProxy di Exchange 2000 Server e Exchange Server 2003 consente l'accesso alle directory in un controller di dominio o a un catalogo globale per client Microsoft® Office Outlook® 98 e Outlook 97. Outlook 2000 Service Release 2 (SR-2) e le versioni successive sono in grado di eseguire query direttamente in un server di catalogo globale.

La prima volta che si connette a un server di Exchange 2000 o a computer Exchange 2000 o versioni successive, il client Outlook 2000 SR-2 o versioni successive cerca il servizio directory presente nel server Exchange principale. Inizialmente Outlook inoltra il processo DSProxy per la prima sessione in assoluto. Dopo che ilcliente ha contattato il servizio DSProxy (il client tenta tutti protocolli di trasporto), un riferimento DSProxy viene passato al client che viene informato che tutte le richieste di directory future devono arrivare al server di catalogo globale. Outlook imposta il riferimento nel profilo MAPI del Registro di sistema. Il meccanismo di riferimento DSProxy riduce il carico sul server di Exchange e la latenza per i criteri di ricerca per la Rubrica. Se nel profilo viene immesso un nome server esplicito, Outlook deve essere riavviato se si verifica un errore di tale server di servizio directory di Active Directory®. Se si verifica una situazione di questo tipo, il server di Exchange invia a Outlook un nuovo riferimento.

In alcuni scenari è possibile imporre ai client Outlook, anche alle versioni più recenti, di passare sempre attraverso il processo DSProxy senza riferimenti. Questa operazione potrebbe essere necessaria, ad esempio, se tra Outlook e il server di Exchange è presente un firewall.

Se si aggiunge la voce No RFR Service del Registro di sistema e la si imposta su 1, il server di Exchange si comporta come un proxy per i client Outlook invece di fare riferimento ai client del server di catalogo globale appropriato per la comunicazione diretta. Se si imposta il parametro No RFR Service del Registro di sistema su 1, le prestazioni del server di Exchange diminuiranno poiché il server fungerà da proxy per tutti i client Outlook, incluso Outlook 2000 SR-2 e i client più recenti che possono comunicare direttamente con Active Directory.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per abilitare il servizio DSProxy RFR

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Creare un nuovo valore DWORD denominato No RFR Service.

  4. Configurare il valore No RFR Service su 1.

Per disabilitare il servizio DSProxy RFR, eliminare il valore No RFR Service del Registro di sistema oppure impostarlo su 0.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'interazione di client Outlook 2000 SR-2 e versioni successive con Active Directory®, consultare l'articolo 256976 della Microsoft Knowledge Base: Accesso ad Active Directory in Outlook 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914.

Per infromazioni sull'accesso ad Active Directory da parte deiclient MAPI, consultare l'articolo 256976 della Microsoft Knowledge Base, "XCLN: Accesso ad Active Directory nei client MAPI" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976.


File EMSMTA.EXE mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


La chiave EnableAuthEpResolution del Registro di sistema è abilitata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la chiave del Registro di sistema delle restrizioni sull'interfaccia della chiamata a procedura remota (RPC) è abilitata:

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Se Exchange Server Analyzer rileva che il valore EnableAuthEpResolution del Registro di sistema è presente, verrà visualizzato un messaggio di configurazione non predefinita.

Le restrizioni per l'interfaccia RPC forniscono una maggiore protezione della rete rendendo i sistemi meno vulnerabili agli attacchi.

Un'interfaccia RPC disponibile in modalità remota e anonima e registrata per impostazione predefinita su Microsoft Windows® XP presenta rischi significativi per la sicurezza. È necessario che RPC registri l'interfaccia stessa per fornire una risoluzione endpoint utilizzando endpoint dinamici. Il valore RestrictRemoteClients del Registro di sistema modifica il comportamento delle interfacce RPC del sistema. Per impostazione predefinita, il valore RestrictRemoteClients del Registro di sistema impedisce l'accesso anonimo remoto alle interfacce RPC del sistema, con alcune eccezioni. Quindi, l'interfaccia RPC Endpoint Mapper non è più disponibile in modalità anonima.

Un client RPC che tenta di effettuare una chiamata utilizzando un endpoint dinamico effettuerà per prima cosa una query all' Endpoint Mapper RPC sul server per determinare a quale endpoint dinamico si dovrà connettere. La query viene effettuata in modalità anonima, anche se la chiamata viene effettuata utilizzando la protezione RPC. Per impostazione predefinita, le chiamate anonime all'interfaccia RPC Endpoint Mapper non verranno effettuate correttamente in Microsoft Windows XP Service Pack 2 in quanto la funzionalità RestrictRemoteClients predefinita impedisce l'accesso anonimo remoto alle interfacce RPC del sistema. A causa di questa restrizione all'interfaccia RPC, il runtime del client RPC viene modificato per effettuare una query autenticata all'Endpoint Mapper. Questa restrizione all'interfaccia RPC rappresenta il comportamento predefinito in Windows XP Service Pack 2. Il runtime del client RPC utilizza quindi l'autenticazione Windows integrata, precedentemente definita NTLM, per l'Endpoint Mapper. L'autenticazione Windows integrata si verifica se l'attuale chiamata client RPC utilizza questo tipo di autenticazione. Si verifica una configurazione non predefinita nelle seguenti condizioni:

  • La chiave RPC del Registro di sistema e il valore EnableAuthEpResolution descritto sono stati creati.

  • Il valore EnableAuthEpResolution del Registro di sistema è stato impostato su 0.

Per ulteriori informazioni sulle modifiche al servizio RPC in Windows XP Service Pack 2, consultare "Restrizioni per l'interfaccia RPC" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47371.


Lunghezza coda messaggi inviati dal client (IMAP) di Epoxy superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Client Out Queue Length (IMAP) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni.

Il contatore di prestazioni Client Out Queue Length (IMAP) indica il numero di messaggi presenti nella coda contenente i messaggi di IMAP4 inviati dal processo Inetinfo.exe al processo Store.exe. Le code non devono mai contenere più di 50 messaggi. Se Exchange Server Analyzer determina che il contatore Client Out Queue Length (IMAP) ha superato il valore massimo di 50 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Epoxy (ExIPC) è un meccanismo di condivisione della memoria che consente ai processi dei servizi IIS (Inetinfo.exe) e Archivio informazioni di Microsoft Exchange (Store.exe) di inviare e ricevere rapidamente i dati. Consente inoltre la comunicazione bidirezionale e interprocesso tra Inetinfo.exe e Store.exe.

Nota:
Inetinfo.exe accetta richieste da protocolli Internet quali WebDAV, IMAP4, NNTP, POP3 e SMTP.

Questa memoria viene utilizzata anche da DSAccess, il componente di Exchange che memorizza nella cache le informazioni di Active Directory®.

Questo errore indica la presenza di problemi relativi alle prestazioni del processo Store.exe, oppure di risorse da cui dipende il processo Store.exe, che provocano un aumento dei messaggi in coda. Questo causerà anche un aumento del tempo di risposta del server.

Per risolvere il problema, identificare il collo di bottiglia delle prestazioni verificatosi in Store.exe o nelle risorse correlate utilizzando le risorse descritte nella sezione "Ulteriori informazioni". Il collo di bottiglia potrebbe dipendere da prestazioni ridotte del disco o da un utilizzo elevato della CPU.

Ulteriori informazioni

  • Per ulteriori informazioni sull'identificazione dell'aumento dei messaggi in coda in Epoxy, consultare "Identifying Rising Queues in Epoxy" in Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore.

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'archivio, consultare l'articolo 257725 della Microsoft Knowledge Base "XADM: Raccolta dei dati di diagnostica per la risoluzione dei problemi dell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Lunghezza coda messaggi inviati dal client (POP) di Epoxy superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Client Out Queue Length (POP) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni.

Il contatore di prestazioni Client Out Queue Length (POP) indica il numero di messaggi presenti nella coda contenente i messaggi di POP3 inviati dal processo Inetinfo.exe al processo Store.exe. Le code non devono mai contenere più di 50 messaggi. Exchange Server Analyzer recupera un esempio dal contatore ogni 5 secondi per un periodo di 5 minuti. Se determina che il contatore Client Out Queue Length (POP) ha superato il valore massimo di 50 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Epoxy (ExIPC) è un meccanismo di condivisione della memoria che consente ai processi dei servizi IIS (Inetinfo.exe) e Archivio informazioni di Microsoft Exchange (Store.exe) di inviare e ricevere rapidamente i dati. Consente inoltre la comunicazione bidirezionale e interprocesso tra Inetinfo.exe e Store.exe.

Nota:
Inetinfo.exe accetta richieste da protocolli Internet quali WebDAV, IMAP4, NNTP, POP3 e SMTP.

Questa memoria viene utilizzata anche da DSAccess, il componente di Exchange che memorizza nella cache le informazioni di Active Directory®.

Questo errore indica la presenza di problemi relativi alle prestazioni del processo Store.exe, oppure di risorse da cui dipende il processo Store.exe, che provocano un aumento dei messaggi in coda. Questo causerà anche un aumento del tempo di risposta del server.

Per risolvere il problema, identificare il collo di bottiglia delle prestazioni verificatosi in Store.exe o nelle risorse correlate utilizzando le risorse descritte nella sezione "Ulteriori informazioni". Il collo di bottiglia potrebbe dipendere da prestazioni ridotte del disco o da un utilizzo elevato della CPU.

Ulteriori informazioni

  • Per ulteriori informazioni sull'identificazione dell'aumento dei messaggi in coda in Epoxy, consultare "Identifying Rising Queues in Epoxy" in Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore.

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'archivio, consultare l'articolo 257725 della Microsoft Knowledge Base "XADM: Raccolta dei dati di diagnostica per la risoluzione dei problemi dell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


File EPOXY.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per risolvere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


L'oggetto Performance Monitor Epoxy non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Client Out Queue Length dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto Performance Monitor Epoxy è disabilitato.

  • L'oggetto Performance Monitor Epoxy non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestaizone.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Nella procedura seguente viene illustrato come correggere le prime due condizioni. Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni Epoxy sia abilitato:

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dal sito Web "Exctrlst.exe: Extensible Performance Counter List" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base, "Ricostruzione manuale dei valori della Libreria dei contatori di prestazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


Lunghezza coda messaggi inviati dall'Archivio (IMAP) di Epoxy superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Store Out Queue Length (IMAP) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni.

Il contatore di prestazioni Store Out Queue Length (IMAP) indica il numero di messaggi presenti nella coda contenente i messaggi di IMAP4 inviati dal processo Store.exe al processo Inetinfo.exe. La coda non deve mai contenere più di 50 messaggi. Exchange Server Analyzer recupera un esempio dal contatore ogni 5 secondi per un periodo di 5 minuti. Se determina che il contatore Store Out Queue Length (IMAP) ha superato il valore massimo di 50 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Epoxy (ExIPC) è un meccanismo di condivisione della memoria che consente ai processi dei servizi IIS (Inetinfo.exe) e Archivio informazioni di Microsoft Exchange (Store.exe) di inviare e ricevere rapidamente i dati. Consente inoltre la comunicazione bidirezionale e interprocesso tra Inetinfo.exe e Store.exe.

Nota:
Inetinfo.exe accetta richieste da protocolli Internet quali WebDAV, IMAP4, NNTP, POP3 e SMTP.

Questa memoria viene utilizzata anche da DSAccess, il componente di Exchange che memorizza nella cache le informazioni di Active Directory®.

Questo errore indica la presenza di problemi relativi alle prestazioni del processo Inetinfo.exe, oppure di risorse da cui dipende il processo Inetinfo.exe, che provocano un aumento dei messaggi in coda. Questo potrebbe aumentare il tempo di risposta del server e per gli utenti si potrebbero verificare ritardi di risposta dal server.

Per risolvere il problema, identificare il collo di bottiglia delle prestazioni verificatosi in Inetinfo.exe o nelle risorse correlate utilizzando le risorse descritte nella sezione "Ulteriori informazioni". Il collo di bottiglia potrebbe dipendere da prestazioni ridotte del disco o da un utilizzo elevato della CPU.

Ulteriori informazioni

  • Per ulteriori informazioni sull'identificazione dell'aumento dei messaggi in coda in Epoxy, consultare "Identifying Rising Queues in Epoxy" in Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore.

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'archivio, consultare l'articolo 257725 della Microsoft Knowledge Base "XADM: Raccolta dei dati di diagnostica per la risoluzione dei problemi dell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Lunghezza coda messaggi inviati dall'Archivio (POP) di Epoxy superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Store Out Queue Length (POP) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni.

Il contatore di prestazioni Store Out Queue Length (POP) indica il numero di messaggi presenti nella coda contenente i messaggi di POP3 inviati dal processo Store.exe al processo Inetinfo.exe. La coda non deve mai contenere più di 50 messaggi. Exchange Server Analyzer recupera un esempio dal contatore ogni 5 secondi per periodo di 5 minuti. Se determina che il contatore Store Out Queue Length (POP) ha superato il valore massimo di 50 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Epoxy (ExIPC) è un meccanismo di condivisione della memoria che consente ai processi dei servizi IIS (Inetinfo.exe) e Archivio informazioni di Microsoft Exchange (Store.exe) di inviare e ricevere rapidamente i dati. Consente inoltre la comunicazione bidirezionale e interprocesso tra Inetinfo.exe e Store.exe.

Nota:
Inetinfo.exe accetta richieste da protocolli Internet quali WebDAV, IMAP4, NNTP, POP3 e SMTP.

Questa memoria viene utilizzata anche da DSAccess, il componente di Exchange che memorizza nella cache le informazioni di Active Directory®.

Questo errore indica la presenza di problemi relativi alle prestazioni del processo Inetinfo.exe, oppure di risorse da cui dipende il processo Inetinfo.exe, che provocano un aumento dei messaggi in coda. Questo potrebbe aumentare il tempo di risposta del server e per gli utenti si potrebbero verificare ritardi di risposta dal server.

Per risolvere il problema, identificare il collo di bottiglia delle prestazioni verificatosi in Inetinfo.exe o nelle risorse correlate utilizzando le risorse descritte nella sezione "Ulteriori informazioni". Il collo di bottiglia potrebbe dipendere da prestazioni ridotte del disco o da un utilizzo elevato della CPU.

Ulteriori informazioni

  • Per ulteriori informazioni sull'identificazione dell'aumento dei messaggi in coda in Epoxy, consultare "Identifying Rising Queues in Epoxy" in Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore.

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'archivio, consultare l'articolo 257725 della Microsoft Knowledge Base "XADM: Raccolta dei dati di diagnostica per la risoluzione dei problemi dell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Errore durante l'accesso al server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool non riesce ad accedere al server di Exchange. Questo errore indica che il servizio directory di Active Directory® non contiene le informazioni di configurazione del server di Exchange specificato.

Per risolvere il problema

  • Assicurarsi di aver digitato il nome server corretto.

  • Immettere solo il nome host o NetBIOS del server (ad esempio, Server1) invece del nome di dominio completo (ad esempio, Server1.esempio.com).

  • Verificare di disporre delle autorizzazioni necessarie per accedere alle informazioni di configurazione di Active Directory per il server in questione.


Errore durante l'accesso alle informazioni di Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha riscontrato un problema durante l'accesso alle informazioni di configurazione del servizio directory di Active Directory® per il server di Exchange.

Per risolvere il problema

  • Verificare che l'attuale account di accesso disponga delle autorizzazioni appropriate per la lettura delle informazioni di configurazione del server di Exchange in Active Directory.

  • Verificare che si disponga della connettività di rete a un controller di dominio di Active Directory.

  • Per accedere ad Active Directory, immettere in Exchange Analyzer Tool le credenziali esplicite dell'account.

  • Specificare in Exchange Server Analyzer un controller di dominio di Active Directory.

  • Assicurarsi che il server di Exchange specificato esista e verificare di aver digitato correttamente il nome del server.


Errore di accesso al registro di verifica dei messaggi
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella proprietà MessageID per rilevare ogni istanza della classe WMI (Strumentazione gestione Windows®) Exchange_MessageTrackingEntry.

Se Microsoft Exchange Server Analyzer Tool non riceve risultati dalla query, verrà visualizzato un errore.

La causa più probabile dell'errore è la disabilitazione del Centro di verifica messaggi.

Il Centro di verifica messaggi, se abilitato, registra le informazioni su mittente, messaggio di posta e destinatari. Nella fattispecie, è possibile consultare le statistiche, quali ora di invio o di ricezione del messaggio, dimensioni e priorità e l'elenco dei destinatari. È inoltre possibile registrare la riga dell'oggetto. Il Centro di verifica messaggi esegue la ricerca, ad esempio, di messaggi di sistema, di cartelle pubbliche e di posta elettronica.

È necessario abilitare il Centro di verifica messaggi su ogni server di cui si desidera verificare i messaggi. Se abilitato, tutti i messaggi instradati tramite un server verranno inseriti nei registri di verifica messaggi.

Microsoft Exchange Server Analyzer Tool necessita dell'abilitazione della funzione verifica dei messaggi per poterla eseguire.

Nota:
Sono necessarie le seguenti autorizzazioni per eseguire questa procedura: membro del gruppo Administrators locale e di un gruppo a cui è stato assegnato il ruolo Administrators di Exchange a livello di gruppo amministrativo.
Per abilitare il Centro di verifica messaggi sul server

  1. Nel Gestore di sistema di Exchange, espandere Server, fare clic con il tasto destro del mouse sul server sul quale si desidera abilitare la funzione di verifica dei messaggi, quindi su Proprietà.

  2. Nella scheda Generale selezionare la casella di controllo Abilita verifica messaggi.

  3. Per registrare l'oggetto dei messaggi inviati al, dal o attraverso il server, selezionare la casella di controllo Abilita registrazione e visualizzazione oggetto.

    Nota:
    Abilitando la funzione di registrazione dell'oggetto è possibile che le prestazioni diminuiscano.

  4. In Manutenzione file di registro è possibile evitare la rimozione dei file di registro o la modifica del periodo di conservazione dei file. Il periodo di conservazione predefinito è di sette giorni.

    Nota:
    Le dimensioni dei registri di verifica aumentano rapidamente nei server che elaborano grandi quantità di messaggi. Accertarsi di disporre di spazio su disco sufficiente per i file di registro e per altri servizi o applicazioni in uso.

  5. Fare clic su OK o Applica. Non è necessario riavviare i servizi per rendere effettive le modifiche.

Per ulteriori informazioni sull'utilizzo del Centro di verifica messaggi, vedere l'articolo 262162 della Microsoft Knowledge "XADM: UUtilizzare il Centro verifica messaggi per tenere la traccia di un messaggio" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

Per ulteriori informazioni sulla risoluzione dei problemi di trasporto di Exchange Server, vedere l'articolo 821910 della Microsoft Knowledge Base, "Come risolvere il relativo problema per i problemi di trasporto Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910.


Errore durante l'aggiornamento degli elenchi di controllo di accesso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-15

Lo strumento Microsoft Exchange Analyzer interroga la classe di Microsoft Strumentazione gestione Windows (WMI) Win32_NTLogEvent per determinare se nell'ultima ora è stato registrato un errore di evento 9551 di MSExchangeIS.

Se Microsoft Exchange Analyzer rileva che un errore di evento 9551 è stato registrato nell'ultima ora, verrà conteggiato il numero totale di errori di evento 9551 registrati in quell'ora.

Infine, se Microsoft Exchange Server Analyzer rileva che un errore di evento 9551 è stato registrato almeno 20 volte nell'ultima ora, verrà visualizzato un avviso.

Questo errore indica che nell'elenco di controllo di accesso potrebbero essere visualizzati alcuni account utente per una risorsa di cassetta postale o una cartella pubblica che non sono associati a oggetti servizio directory di Active Directory validi.

Per essere accessibile, una cassetta postale presente su un server su cui viene eseguito Microsoft Exchange Server 2003 o Exchange 2000 Server deve essere rappresentata da un account utente valido del servizio directory di Active Directory.

È possibile creare un account privo di rappresentazione valida in Active Directory se la risorsa cassetta postale o la cartella pubblica di Exchange 2000 Server o Exchange Server 2003 non è stata aggiornata dopo aver eliminato una cassetta postale sul computer basato su Exchange Server 5.5.

Se l'account della cassetta postale eliminato resta nell'elenco di controllo di accesso di una risorsa cassetta postale o di una cartella pubblica, ogni volta che si accede a tale cassetta o cartella ed Exchange tenta di risolvere gli account elencati, non è possibile risolvere l'account privo di rappresentazione valida in Active Directory. Questo processo può manifestarsi come problema di prestazioni.

Per risolvere il problema:

  • Accertarsi che sia stato installato Exchange 2000 Server Service Pack 3 (SP3) o versione successiva. Per ottenere la versione più recente di Exchange 2000 Server Service Pack, consultare l'articolo 301378 della Microsoft Knowledge Base, "How to obtain the latest Exchange 2000 Server service pack" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378.

  • Utilizzare il Gestore di sistema di Exchange per rimuovere manualmente gli account di cassetta postale non validi dall'elenco di controllo di accesso.

  • Se l'ambiente di Exchange è in modalità mista, eseguire la verifica di coerenza DS/IS sull'archivio informazioni.

  • Se l'ambiente di Exchange è nella modalità nativa di Exchange, seguire le istruzioni indicate nell'articolo 324323 della Microsoft Knowledge Base "XADM: Skipping User Accounts That Are Not Represented in Active Directory During Access Control List Conversion", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323.

Per utilizzare il Gestore di sistema di Exchange per rimuovere manualmente gli account di cassetta postale non validi dall'elenco di controllo di accesso

  1. Avviare il Gestore di sistema di Exchange e individuare la cartella identificata dall'errore 9551.

  2. Fare clic con il pulsante destro del mouse sulla cartella e selezionare Proprietà.

  3. Selezionare la scheda Autorizzazioni e fare clic su Autorizzazioni client.

  4. Nel riquadro Nome, selezionare l'account utente identificato dall'errore 9551, quindi fare clic sul pulsante Rimuovi per rimuovere l'account dall'elenco di controllo di accesso.
Per eseguire la verifica di coerenza DS/IS sull'archivio informazioni in modalità mista di Exchange

  1. Nel programma Exchange Server 5.5 Administrator, fare clic sul computer con Exchange 5.5 Server contenente l'archivio informazioni.

  2. Dal menu File scegliere Proprietà, quindi fare clic sulla scheda Avanzate.

  3. Fare clic su Consistency Adjustment.

  4. Selezionare le caselle di controllo Remove unknown user accounts from public folder permissions e Remove unknown user accounts from mailbox permissions, quindi scegliere il pulsante All Inconsistencies.

  5. Deselezionare tutte le altre caselle di controllo, quindi fare clic su OK.

Per ulteriori informazioni

Per ulteriori informazioni su questo problema, consultare i seguenti articoli della Microsoft Knowledge Base e le risorse di Exchange Server:

  • Events and Errors Message Center: Event Details: MSExchangeIS Mailbox Store Event 9551 details, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83189.

  • Articolo 301378 della Microsoft Knowledge Base, "How to obtain the latest Exchange 2000 Server service pack", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378.

  • Articolo 324323 della Microsoft Knowledge Base, "XADM: Skipping User Accounts That Are Not Represented in Active Directory During Access Control List Conversion", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323.


File ESE.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=33457 (informazioni in lingua inglese).


File ESEUTIL.EXE mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack di Exchange 2000 Server, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXCDO.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXCHMEM.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione di Exchange utilizzata. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXMIME.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows® ) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per risolvere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXOLEDB.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXPOP3.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per risolvere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi né reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXPROX.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXRES.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File EXSMTP.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Versione del file EXSMTP.DLL obsoleta
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per EXSMTP.DLL. Se Exchange Server Analyzer rileva che la chiave Version per EXSMTP.DLL non corrisponde a 6556.0, verrà visualizzato un avviso.

Questo avviso indica che la versione di EXSMTP.DLL in questo computer Exchange Server proviene dalla versione 1 dell'aggiornamento cumulativo successivo al Service Pack 3 per Exchange 2000 Server datata maggio 2004. È disponibile per il download un aggiornamento cumulativo successivo.

Per risolvere il problema

  1. Scaricare l'aggiornamento più recente (agosto 2004) dalla pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).

  2. Per ulteriori informazioni sull'aggiornamento, consultare l'articolo 870540 della Microsoft Knowledge Base "Disponibile l'aggiornamento cumulativo successivo al Service Pack 3 per Exchange 2000 Server di agosto 2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Installare l'aggiornamento di agosto 2004.

Per ulteriori informazioni sull'installazione di questo e altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


L'analisi di ActiveSync di Exchange è abilitata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'analisi è stata abilitata per Exchange ActiveSync®:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync\Enabled

Se Exchange Server Analyzer rileva che il valore Enabled è presente e configurato con un valore numerico maggiore di 0, verrà visualizzato un avviso.

Exchange ActiveSync è implementato come un'estensione di ISAPI (Internet Server Application Programming Interface) nei servizi IIS (Internet Information Services). IIS, Exchange ActiveSync e molte periferiche client in cui viene utilizzato Exchange ActiveSync includono funzionalità di analisi native; pertanto, non è necessario utilizzare quelle di Microsoft Windows Server™2003.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Tracing\Microsoft Server ActiveSync\MasSync

  3. Eliminare il valore Enabled.

  4. Uscire dall'editor del Registro di sistema e riavviare il computer Exchange Server per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'analisi e la registrazione di Exchange ActiveSync e dei client corrispondenti, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 330463, "XCCC: "XCCC: Risoluzione del problema dei codici di errore HTTP nel server ActiveSync" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=330463.

  • 330461, "HOW TO: Risoluzione dei problemi nel server ActiveSync" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=330461.

  • 822176, "Risoluzione del problema della notifica sempre aggiornata in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822176.


La versione di file binari di Exchange è più recente della versione installata di Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più alto del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione successiva indica che il file è più recente del previsto. Ciò può succedere se è installato un aggiornamento rapido.

Per risolvere questo avviso

  1. Non è necessario intraprendere azioni. L'avviso indica solo la presenza di file più recenti che rappresentano il risultato dell'installazione di un aggiornamento rapido o di un altro aggiornamento.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Questo nodo cluster di Exchange è anche un controller di dominio
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Best Practices Analyzer Tool esegue una query nella classe oggetto WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore di DomainRole per il server. Il valore DomainRole rappresenta il ruolo di un computer in un dominio. La tabella riportata di seguito elenca i valori validi per DomainRole.

Valore | Significato
0 | Workstation autonoma
1 | Workstation membro
2 | Server autonomo
3 | Server membro
4 | Controller di dominio di backup
5 | Controller di dominio primario

Exchange Server Analyzer esegue inoltre una query nell'oggetto ClusSvc WMI (Strumentazione gestione Windows®) classe Win32_Service del servizio cluster di Windows per determinare il relativo valore Started. Il valore True indica che il servizio cluster è avviato, mentre il valore False indica che non è in esecuzione.

Se Exchange Server Analyzer determina che il valore di DomainRole è maggiore di 3 su un computer Exchange Server sul quale il servizio cluster di Windows è avviato, verrà visualizzato un messaggio di errore. Questo errore indica che un Exchange Server è in esecuzione su un server cluster di Windows Server, i cui nodi sono controller di dominio.

L'esecuzione di un nodo cluster Exchange Server come controller di dominio non è una configurazione supportata.

Per risolvere il problema

  1. Selezionare un server non-cluster come controller di dominio ed eseguire l'Installazione guidata di Active Directory (dcpromo) per alzare il livello di quel server.

  2. Dopo aver configurato il servizio directory di Active Directory® sul nuovo controller di dominio, attendere che il contenuto esistente di Active Directory sia replicato sul nuovo server.

    A seconda delle dimensioni di Active Directory,questa operazione potrebbe richiedere diverse ore.

  3. Eseguire l'Installazione guidata di Active Directory (dcpromo) sul server cluster per abbassare il livello del server e rimuovere Active Directory.

Per ulteriori informazioni sulla procedura per alzare e abbassare il livello dei controller di dominio, consultare l'articolo della Microsoft Knowledge Base "Promozione e retrocessione del controller di dominio in server membro in Windows 2000" all'indirizzo (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=238369).


Segnalazione errori di Exchange è disattivata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la segnalazione errori di Exchange è attivata:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\DisableErrorReporting

Se Exchange Server Analyzer rileva che il valore di DisableErrorReporting è impostato su 1, verrà visualizzato un avviso. Il valore 1 indica che la segnalazione errori di Exchange è disattivata.

Il supporto per la Segnalazione errori Microsoft, denominata anche Segnalazione errori di Windows, funzionalità di segnalazione eventi Microsoft e funzionalità di segnalazione automatica errori, è stato inizialmente aggiunto in Exchange 2000 Server Service Pack 2. In Exchange Server 2003 è inclusa una versione avanzata della Segnalazione errori Microsoft denominata funzionalità di segnalazione errori di Exchange, che semplifica la segnalazione degli errori agli amministratori, si integra con la Segnalazione errori a server interno e offre uno strumento di segnalazione avanzato per il Servizio aggiornamento destinatari di Exchange Server 2003.

La Segnalazione errori di Exchange consente agli amministratori di Exchange Server di inviare segnalazioni di arresti anomali e di errori irreversibili tramite Internet, utilizzando il protocollo HTTPS, a un server di segnalazione errori Microsoft. È consigliabile inviare i rapporti sugli errori al sito Web Microsoft Windows Online Crash Analysis. La raccolta dei dati sugli errori irreversibili dei server Exchange consente al personale dei prodotti Exchange di rilevare e di correggere gli errori presenti nel software.

Se si verifica un errore irreversibile mentre si utilizza il Gestore di sistema di Exchange oppure mentre si esegue un'attività di Exchange con Utenti e computer di Active Directory su un computer in cui è installato il Gestore di sistema di Exchange, la Segnalazione errori di Exchange consente di notificare l'errore all'amministratore e di richiedere se si desidera segnalare l'errore a Microsoft. Inoltre, la Segnalazione errori di Exchange segnala e registra gli errori rilevati dal Supervisore sistema di Microsoft Exchange, dall'Archivio informazioni di Microsoft Exchange e da altri servizi di Exchange. Inoltre, dal momento che gli errori rilevati dal Servizio aggiornamento destinatari possono determinare uno stato non corretto del componente Supervisore sistema, la Segnalazione errori di Exchange esegue un rapporto anche sulle violazioni dell'accesso e altri errori interni che si verificano nel Servizio aggiornamento destinatari.

Mediante la selezione di una casella nella pagina delle proprietà del server nel Gestore di sistema di Exchange, è possibile configurare ciascun server Exchange per l'invio di informazioni sugli errori irreversibili.

Per configurare Exchange 2000 Server oppure Exchange Server 2003 per l'invio di dati sugli errori irreversibili a Microsoft

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo, Server, fare clic con il pulsante destro del mouse sul server, quindi scegliere Proprietà. Se il nodo Gruppi amministrativi non viene visualizzato in Gestore di sistema di Exchange, espandere Server, fare clic con il pulsante destro del mouse sul server e scegliere Proprietà.

  3. Nella scheda Generale della pagina Proprietà <nome server> selezionare la casella di controllo Invia automaticamente a Microsoft informazioni su errori irreversibili del servizio, quindi fare clic su Applica.

  4. Fare clic su Sì per confermare l'attivazione della Segnalazione errori di Exchange.

  5. Fare clic su OK.

Quando si verifica un errore irreversibile, viene creato un file di rapporto errori compresso (in genere di 10-50 KB). Il rapporto contiene, tra le altre cose, un file di dettagli. Un file di dettagli è un file che contiene informazioni sul processo in cui si è verificato l'errore. Sebbene gli errori possano verificarsi a diversi livelli di programmazione (ad esempio, a livello dei thread, a livello dell'interfaccia e a livello dei metodi oppure delle funzioni), si verificano tutti nel contesto di un unico processo. In genere, il file di dettagli include le informazioni sul processo che ha provocato l'errore come, ad esempio, i dettagli sull'attività di ciascun thread, le diverse aree della memoria utilizzate dal processo, le informazioni di sistema e altre informazioni di debug rilevanti. In Exchange Server, i rapporti di errori includono anche le informazioni relative allo stato di Exchange Server, le informazioni sulla versione del sistema operativo, i dettagli sull'hardware del computer, l'indirizzo IP del computer e l'ID digitale del prodotto che viene utilizzato per identificare la licenza.

Dal momento che Microsoft non raccoglie intenzionalmente informazioni personali, prendiamo atto che alcune delle informazioni raccolte potrebbero contenere informazioni in grado di identificare univocamente il proprio sistema. Tuttavia, Microsoft utilizza i dati raccolti solo per rapporti sugli arresti anomali e per la correzione di errori. Per ulteriori informazioni, consultare la pagina dei criteri per la segnalazione degli errori, "Criteri per la raccolta dei dati" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33818.


Per questo server front-end di Exchange è impostata l'opzione di avvio /3GB nel file Boot.ini
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare la quantità di spazio di indirizzi virtuali assegnato ai processi in modalità utente (MaxProcessMemorySize) nel computer Exchange Server. Exchange Server Analyzer analizza inoltre la classe WMI Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Se Exchange Server Analyzer stabilisce che il valore della chiave MaxProcessMemorySize non è uguale a 2097024 e che la chiave IsFrontEndServer è impostata su True, verrà visualizzato un avviso.

Questo avviso indica che il computer Exchange Server non è configurato correttamente per l'utilizzo ottimale della memoria dal momento che l'opzione di avvio /3GB è stata impostata nel file Boot.ini. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

Quando il parametro /3GB è incluso nel file Boot.ini di un server che esegue Microsoft Windows 2000 Server o Microsoft Windows Server 2003, Windows assegna 3 GB su un massimo di 4 GB di spazio di indirizzi virtuali al processo utente e 1 GB al kernel. Generalmente (quando il parametro /3GB non è utilizzato), Windows assegna 2 GB al processo utente e 2 GB al kernel. Pertanto, grazie all'opzione /3GB, le applicazioni che comportano un uso intensivo della memoria dispongono di un maggiore spazio di indirizzi della memoria virtuale per funzionare e le prestazioni risultano migliorate.

L'utilizzo dell'opzione /3GB supporta principalmente le applicazioni che comportano un uso intensivo della memoria, come il processo Store.exe in un server di Exchange che contiene cassette postali degli utenti. Un server front-end non contiene cassette postali degli utenti, pertanto, l'utilizzo dell'opzione /3GB in questo tipo di server non comporterebbe alcun vantaggio.

Per risolvere il problema

  1. In Esplora risorse, passare alla partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, in Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse è sufficiente scegliere Strumenti, Opzioni cartella e selezionare la scheda Visualizza. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con e fare clic su Blocco note per aprire il file.

  4. Nella sezione [Operating Systems] , eliminare le seguenti opzioni da tutte le righe di avvio: /3GB

  5. Salvare le modifiche e chiudere Blocco note.

  6. Per rendere effettiva la modifica, riavviare il computer.

Per ulteriori dettagli sull'utilizzo dell'opzione di avvio /3GB, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 297812, "Utilizzo della funzione di ottimizzazione della RAM 4GT" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 31679, "Utilizzo dell'opzione /USERVA nel file Boot.ini per l'ottimizzazione delle configurazioni /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


L'unità IFS di Exchange non è stata esplicitamente esclusa da Windows Backup
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare i file e le cartelle esclusi dai backup mediante Backup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer ricerca specificatamente un valore di stringa denominato Exchange IFS.

Exchange Server Analyzer legge, inoltre, la seguente voce del Registro di sistema per ottenere la lettera che rappresenta l'unità File system installabile (IFS, Installable File System) di Exchange:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

In Exchange 2000 Server la lettera dell'unità predefinita è M. L'unità IFS viene disattivata per impostazione predefinita in Exchange Server 2003.

Se Exchange Server Analyzer rileva che la chiave FilesNotToBackup non contiene un valore di stringa denominato Exchange IFS o se contiene Exchange IFS ma i dati di valore relativi a Exchange IFS non corrispondono a M:\* /s (dove M è la lettera dell'unità che rappresenta IFS), verrà visualizzato un avviso.

Per impostazione predefinita, quando è abilitato il mapping della lettera dell'unità IFS, Exchange IFS viene aggiunto alla chiave FilesNotToBackup del Registro di sistema. L'unità M:\ costituisce una visualizzazione logica dell'archivio di Exchange, non un'unità reale, ed eseguirne il backup può provocare notevoli problemi quali la perdita di allegati. Inoltre è possibile che il software di backup non tronchi i file di registro nel modo appropriato, determinando un imprevisto esaurimento dello spazio su disco nel server.

Se non si utilizza Backup, è possibile ignorare questo avviso. Se invece si utilizza Backup, si consiglia di escludere l'unità IFS da tutti i processi di backup. Se si esegue il backup dell'unità IFS con Backup o un altro programma di backup, potrebbe verificarsi il danneggiamento dei database dell'archivio informazioni, la perdita di dati e non essere possibile ripristinare i dati da un backup dell'unità IFS.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Fare clic con il pulsante destro del mouse su FilesNotToBackup e selezionare Nuovo | Valore multistringa. Digitare Exchange IFS per il nome e premere INVIO.

  4. Nel riquadro destro fare doppio clic su Exchange IFS e immettere i dati di valore di M:\* /s. Assicurarsi di utilizzare la lettera di unità corretta nel caso in cui il sistema non utilizzi la lettera di unità predefinita M.

  5. Chiudere l'Editor del Registro di sistema.

Per ulteriori informazioni sul Registro di sistema di Microsoft Windows®, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni sul backup e il ripristino di Exchange, consultare Guida al ripristino di emergenza di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47570. Per ulteriori informazioni, consultare i seguenti articoli della Knowledge Base:

  • 258243, "XADM: Come eseguire il backup e il ripristino di un computer che esegue Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258243.

  • 233427, "File e cartelle di cui non viene eseguito il backup quando lo strumento Ntbackup.exe viene utilizzato in Windows Server 2003, Windows XP e Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=233427.

Per ulteriori informazioni sui problemi che possono verificarsi se si esegue l'analisi dell'unità IFS con software antivirus, consultare i seguenti articoli della Knowledge Base:

  • 298924, "XADM: Problemi causati dal backup o dall'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Messaggio di errore C1041737 quando si installano i database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


Questo server cassette postali di Exchange dispone di 1 o più GB di memoria ma non presenta l'opzione /3GB nel file Boot.ini
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query in due classi Microsoft WMI (Strumentazione gestione Windows®) per determinare la quantità di memoria fisica nel server di Exchange e la quantità di spazio di indirizzi virtuali assegnata ai processi in modalità utente. Nella tabella sono illustrate le classi e le chiavi prese in esame da Exchange Server Analyzer.

Classe in cui è eseguita la query | Chiavi in cui è eseguita la query | Descrizione
Win32_OperatingSystem | MaxProcessMemorySize | Numero massimo di KB di memoria che possono essere assegnati a un processo.
Win32_OperatingSystem | OSProductSuite | Aggiunte installate e con licenza del sistema operativo.
Win32_ComputerSystem | TotalPhysicalMemory | Numero di byte di memoria RAM (Random Access Memory) installati nel computer.

Se Exchange Server Analyzer rileva che nel computer Exchange Server non è in esecuzione Windows 2000 Server, che tale computer dispone di almeno 1 GB di memoria fisica installata e che il valore di MaxProcessMemorySize è maggiore di 2097024 ma minore di 3104640, verrà visualizzato un avviso.

Questo avviso indica che il server di Exchange non soddisfa i requisiti impostati nell'articolo "In Exchange 2000 è necessaria l'opzione /3GB con oltre 1 GB di RAM fisica" della Microsoft Knowledge Base all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096. Questa configurazione di produzione non è consigliata.

Microsoft Windows Server 2003 include il supporto per due opzioni di avvio, /3GB e /USERVA, che consentono di regolare l'assegnazione dell'utilizzo di memoria e dello spazio di indirizzi della memoria. Indipendentemente dalla quantità di memoria fisica nel sistema, in Windows viene utilizzato uno spazio di indirizzi virtuali pari a 4 GB: 2 GB sono assegnati a processi in modalità utente quali, ad esempio, le applicazioni, e 2 GB a processi in modalità kernel, quali, ad esempio, il sistema operativo e i driver in modalità kernel. Su sistemi che dispongono di 1 GB o più di memoria fisica, queste due opzioni di avvio possono essere utilizzate per assegnare una quantità maggiore di memoria alle applicazioni (3 GB) e una quantità minore al sistema operativo (1 GB). Lo spazio aggiuntivo di indirizzi virtuali consente di ridurre la quantità di frammentazione della memoria nello spazio di indirizzi virtuali del processo di archivio informazioni di Exchange.

L'opzione /3GB viene utilizzata per rendere effettiva la modifica di questa assegnazione. L'opzione viene immessa nel file Boot.ini del sistema e diventa effettiva al riavvio. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

L'opzione /USERVA è nuova in Windows Server 2003. La sua funzione è quella di offrire un miglior livello di controllo sulla divisione dello spazio di indirizzi virtuali tra processi in modalità utente e processi in modalità kernel. L'opzione dovrebbe essere utilizzata solo per applicazioni che la supportano, quali, ad esempio, Exchange 2000 Server e Exchange Server 2003, e con i valori specifici supportati dalle applicazioni.

Nota:
Nel Servizio Supporto Tecnico Clienti Microsoft non sono supportate impostazioni arbitrarie di /USERVA; i clienti dovrebbero aggiungere questa impostazione al file Boot.ini solo dietro consiglio del produttore.

Se l'opzione viene utilizzata su sistemi Exchange Server 2003, l'unico valore supportato per /USERVA equivale a 3030 (ad esempio, /USERVA=3030). L'impostazione di questo valore fa in modo che debbano essere allocati altri 40 megabyte (MB) al sistema operativo e consente di aggiungere un maggior numero di utenti senza utilizzare tutte le risorse di sistema disponibili.

Per risolvere il problema

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  2. Selezionare la scheda Avanzate.

  3. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  4. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  5. Nella sezione [Operating Systems] aggiungere le seguenti opzioni alla fine della riga di avvio che include l'opzione /fastdetect: /3GB /USERVA=3030

  6. Salvare le modifiche e chiudere Blocco note.

  7. Per rendere effettiva la modifica, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer di Exchange Server.

Per ulteriori informazioni su come ottimizzare l'utilizzo della memoria e le prestazioni di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266096, "In Exchange 2000 è necessaria l'opzione /3GB con oltre 1 GB di RAM fisica" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 810371, "XADM: Utilizzo dell'opzione /Userva in server di Exchange basati su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • 823440, "Utilizzo obbligatorio dell'opzione /3GB nell'installazione di Exchange Server 2003 in un sistema basato su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440.

  • 822178, "Informazioni generali sulle dipendenze e sui requisiti per le funzioni di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822178.


La traccia del provider di Exchange è abilitata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-06-20

Lo strumento Microsoft Exchange Server Analyzer esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Microsoft Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Microsoft Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Microsoft Exchange Server 2003. Se la stringa comprende "Version 8.0", il computer esegue Microsoft Exchange Server 2007.

Exchange Analyzer esegue una query nella classe CIM_Datafile WMI (Strumentazione gestione Microsoft® Windows®) per determinare il valore della chiave Version relativa a Emsmdb32.dll, il provider di trasporto di Exchange. La chiave WMI Version indica il numero di versione del file.

Exchange Analyzer esegue infine una query nella seguente voce del Registro di sistema per stabilire se la traccia del provider di Exchange è stata configurata e abilitata.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing

Verrà visualizzato un messaggio di errore se si verificano le condizioni riportate di seguito:

  • Nel server non è in esecuzione Exchange Server 2007

  • La chiave Version per Emsmdb32.dll corrisponde alla versione 6.5.7233.47 o successive

  • La voce HKML\Software\Microsoft\Exchange\Exchange Provider\Enable Tracing è già esistente ed è impostata su un valore diverso da 0

Questo errore indica che la traccia del provider di trasporto di Exchange è abilitata sul computer.

Le versioni del provider di trasporto di Exchange a partire dalla 6.5.7233.47 includono funzionalità di traccia incorporate. Un file TTD consente la traccia dei seguenti programmi:

  • Tutti i programmi che utilizzano la tecnologia MAPI sul server che esegue Exchange Server 2003

  • Tutti i programmi installati utilizzando gli strumenti di gestione del sistema di Microsoft Exchange.

È consigliabile abilitare la traccia del provider di trasporto solo per la risoluzione di un problema attivo per non ridurre le prestazioni tipiche del server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di conoscere le operazioni per ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per disabilitare la traccia del provider di Exchange in Exchange Server 2003

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Cercare: HKML\Software\Microsoft\Exchange\Exchange Provider\

  3. Nel riquadro di spostamento destro:

    1. Fare clic con il pulsante destro del mouse ed eliminare la sottochiave Enable Tracing; in alternativa,

    2. Fare doppio clic su Enable Tracing.

  4. Configurare la sottochiave Enable Tracing impostando il valore su 0.

  5. Chiudere l'editor del Registro di sistema.

  6. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base, Descrizione del Registro di sistema di Microsoft Windows.


Il servizio Exchange - Gestione non è in esecuzione come LocalSystem
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della proprietà StartName per il servizio Microsoft Exchange - Gestione (MSExchangeMGMT). Se Exchange Server Analyzer rileva che il servizio Exchange - Gestione è in esecuzione con un account diverso dall'account LocalSystem (SYSTEM), verrà visualizzato un messaggio di errore.

Questo errore indica che il servizio Exchange - Gestione non è in esecuzione su una configurazione supportata. Se si esegue il servizio Exchange - Gestione con un altro account, si provocheranno problemi di accesso e di autorizzazione.

Per risolvere questo problema, è necessario configurare il servizio Exchange - Gestione in modo che venga avviato con l'account LocalSystem (SYSTEM).

Per configurare l'account del servizio Exchange - Gestione

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Individuare e arrestare il servizio Microsoft Exchange - Gestione.

  3. Fare doppio clic sul servizio Microsoft Exchange - Gestione.

  4. Nella scheda Connessione della pagina delle proprietà di Microsoft Exchange - Gestione in Accedi come scegliere Account di sistema locale, quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia e quindi su OK.

  6. Chiudere lo snap-in Servizi.

Per ulteriori informazioni sull'esecuzione dei servizi di Exchange con l'account LocalSystem, consultare l'articolo 239762 della Microsoft Knowledge Base "Esecuzione dei servizi di Exchange in LocalSystem" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Il servizio Microsoft Exchange - Gestione è stato interrotto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Process per determinare il valore della chiave Started per l'istanza MSExchangeMGMT, che rappresenta il servizio Microsoft Exchange - Gestione. Se Exchange Server Analyzer rileva che il valore della chiave Started per l'istanza MSExchangeMGMT non equivale a True, verrà visualizzato un avviso.

Il servizio Microsoft Exchange - Gestione è stato introdotto con Exchange 2000 Server Service Pack 2. Tra le altre cose, la funzionalità del Centro di verifica messaggi di Exchange Server e diverse funzioni del Gestore di sistema di Exchange dipendono da questo servizio.

Il servizio Microsoft Exchange - Gestione consente di specificare, mediante l'interfaccia utente, quale controller di dominio o server di catalogo globale Exchange Server 2003 o Exchange 2000 Server utilizzare per l'accesso al servizio directory di Active Directory®. Questo servizio è richiesto anche per la verifica messaggi. È possibile disattivare il servizio senza influenzare la funzionalità di base di Exchange. Tuttavia, quando si verifica la funzionalità di Exchange Server, potrebbero essere necessarie le funzionalità di verifica messaggi su tutti i computer di Exchange Server che instradano la posta.

Nota:
Dal momento che i server front-end vengono utilizzati più di frequente per accedere alla posta invece che per instradarla, è possibile che non sia necessario eseguire il servizio Microsoft Exchange - Gestione sui server front-end.

Per configurare il servizio Microsoft Exchange - Gestione per l'esecuzione automatica

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Fare doppio clic sul servizio Microsoft Exchange - Gestione.

  3. Nella scheda Generale della pagina delle proprietà di Microsoft Exchange - Gestione selezionare Automatico dalla finestra di dialogo Tipo di avvio, quindi fare clic su Applica.

  4. In Stato server, fare clic su Start e su OK.

Per ulteriori informazioni sul servizio Microsoft Exchange - Gestione, consultare l'articolo 307413 della Microsoft Knowledge Base "XGEN: Informazioni generali sul servizio Microsoft Exchange - Gestione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307413.

Per ulteriori informazioni sulla gestione di Exchange, consultare il Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


Su Exchange 2000 Server non è in esecuzione il Service Pack più recente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il processo STORE.EXE. Se Exchange Server Analyzer determina che la chiave Version per STORE.EXE presenta un valore maggiore di 4416 e minore di o pari a 6249, verrà visualizzato un avviso.

Questo avviso indica che il computer Exchange Server non esegue il codice più recente disponibile per la versione di Exchange in esecuzione sul computer.

Per risolvere il problema

  1. Scaricare Exchange 2000 Server Service Pack 3 dalla pagina http://go.microsoft.com/fwlink/?LinkId=17058.

  2. Consultare la Guida all'installazione di Exchange 2000 Server Service Pack 3 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=12337.

  3. Scaricare l'aggiornamento più recente (agosto 2004) dalla pagina http://go.microsoft.com/fwlink/?LinkId=33457.

  4. Per ulteriori informazioni sull'aggiornamento più recente, consultare l'articolo 870540 della Microsoft Knowledge Base "Disponibile l'aggiornamento cumulativo successivo al Service Pack 3 per Exchange 2000 Server di agosto 2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  5. Eseguire un backup completo del computer Exchange Server.

  6. Installare Exchange 2000 Server Service Pack 3.

  7. Installare l'aggiornamento di agosto 2004.

Per ulteriori informazioni su come richiedere il Service Pack più recente per Exchange 2000 Server, consultare l'articolo 301378 della Microsoft Knowledge Base "Come ottenere il service pack più recente per Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378.

Per ulteriori informazioni sull'installazione di questo e di altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Exchange 2000 Server non è supportato su Windows Server 2003
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul computer che dispone di Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue Windows Server™ 2003.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti che dispongono di una classe oggetto di msExchExchangeServer. Se la stringa comprende Version 5.5, il computer esegue Microsoft Exchange Server versione 5.5. Se la stringa comprende Version 6.0, il computer esegue Exchange 2000 Server. Se la stringa comprende Version 6.5, il computer esegue Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore di CurrentVersion è 5.2 e che il valore dell'attributo serialNumber contiene Version 6.0, verrà visualizzato un messaggio di errore. Si tratta di una configurazione non supportata, pertanto è necessario correggere questo errore non appena possibile.

Per risolvere il problema

  1. Effettuare una delle seguenti operazioni:

    • Installare Exchange 2000 Server in un server su cui è in esecuzione un sistema operativo supportato e spostare le cassette postali in tale server.

    • Aggiornare Exchange 2000 Server a Exchange Server 2003.

Per ulteriori informazioni sulle configurazioni supportate, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni su Exchange Server e Windows Server 2003, consultare l'articolo 810591 della Microsoft Knowledge Base "Compatibilità di Exchange 2000 Server e di Exchange Server 5.5 con Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591.


È stata installata una versione non definitiva di Exchange 2007
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-20

Lo strumento Microsoft Exchange Server Analyzer esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo serialNumber per tutti gli oggetti di Exchange Server nella directory. L'attributo serialNumber è un valore di stringa che include sia la versione di Exchange Server sia, se installato, la versione del Service Pack. Ad esempio, in un computer Exchange Server 2007 dove non è stato installato alcun Service Pack, l'attributo serialNumber è pari a Versione 8.0 (build 0685).

Se Exchange Server Analyzer rileva che la stringa del valore dell'attributo serialNumber contiene 8.0, ma ha un numero di build inferiore a 0685, verrà visualizzato un errore.

Tale errore indica che sul computer di Exchange Server 2007 è in esecuzione una versione non definitiva di Exchange Server 2007.

Le installazioni di versioni non definitive di Exchange Server 2007 non sono supportate negli ambienti di produzione.

Per risolvere questo errore, installare una versione di produzione di Exchange Server 2007.


Oggetto server di Exchange 2007 spostato in un gruppo amministrativo diverso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-08-11

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti di Exchange Server nella directory.

Exchange Server Analyzer esegue inoltre una query nel valore per individuare l'attributo cn del gruppo amministrativo in cui si trova il server che esegue Exchange Server per determinare se si tratta del gruppo amministrativo di Exchange 2007 dedicato, ovvero Gruppo amministrativo di Exchange (FYDIBOHF23SPDLT).

Se Exchange Server Analyzer determina che il server esegue Microsoft Exchange Server 2007 ma si trova in un gruppo amministrativo diverso da Gruppo amministrativo di Exchange (FYDIBOHF23SPDLT), in Exchange Server Analyzer verrà visualizzato un errore.

L'errore indica che il server potrebbe essere stato spostato manualmente dal gruppo amministrativo di Exchange 2007 dedicato con conseguenti problemi di flusso di posta.

L'attributo serialNumber è un valore di stringa che include sia la versione di Exchange Server sia quella del Service Pack, se installato. Un valore dell'attributo serialNumber pari a Versione 8.0 indica che il server esegue Exchange 2007.

Microsoft Exchange Server 2003 e Microsoft Exchange 2000 Server utilizzano i gruppi amministrativi per raggruppare gli oggetti di Exchange e delegare l'autorizzazione alla gestione di tali oggetti. Exchange 2007 non utilizza i gruppi amministrativi come unità di gestione logica. Per supportare la coesistenza tra Exchange Server 2003 o Exchange 2000 Server ed Exchange 2007, tutti i server di Exchange 2007 vengono automaticamente aggiunti a un unico gruppo amministrativo durante l'installazione di Exchange 2007. Il gruppo amministrativo viene riconosciuto nel Gestore di sistema di Exchange in Exchange Server 2003 come Gruppo amministrativo di Exchange (FYDIBOHF23SPDLT).

Per risolvere il problema, rimuovere e reinstallare il server.


Il server di Exchange sul controller di dominio non è un server di catalogo globale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave DomainRole. I valori validi per questa chiave sono elencati nella seguente tabella.

Valore | Significato
0 | Workstation autonoma
1 | Workstation membro
2 | Server autonomo
3 | Server membro
4 | Controller di dominio di backup
5 | Controller di dominio primario

Exchange Server Analyzer esegue una query anche nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster ClusSvc. Inoltre, Exchange Server Analyzer esegue una query nella classe WMI Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore della chiave OSProductSuite indica la versione di Windows in esecuzione sul computer.

Exchange Server Analyzer esegue una query anche nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti directory con la categoria oggetto msExchExchangeServer. Il valore dell'attributo serialNumber indica la versione di Exchange Server in uso.

Infine, Exchange Server Analyzer esegue una query in Active Directory per determinare il valore dell'attributo isGlobalCatalogReady di questo server. Il valore True per questo attributo indica che il server di elenchi in linea è in grado di operare anche come server di catalogo globale, mentre il valore False indica che il server di elenchi in linea non è un server di catalogo globale.

Se Exchange Server Analyzer determina che il valore della chiave DomainRole è maggiore di 3 su un computer Exchange Server, che tale computer non è in esecuzione su un cluster Windows oppure che sul computer non è in esecuzione Windows Small Business Server o Exchange Server versione 5.5 e che l'attributo isGlobalCatalogReady è impostato su False, verrà visualizzato un avviso.

Questo avviso indica che Exchange Server è in esecuzione su un server di elenchi in linea che non è in grado di operare anche come server di catalogo globale. Questa configurazione non è supportata e potrebbe provocare errori nei servizi di Exchange.

Se si esegue Exchange Server in un controller di dominio senza Small Business Server, è necessario tenere presente i seguenti problemi:

  • Exchange Server e Active Directory sono entrambe applicazioni che richiedono un utilizzo intensivo delle risorse. Quando vengono eseguite entrambe sullo stesso computer, le prestazioni ne verranno influenzate.

  • Se Exchange Server viene eseguito in un controller di dominio, è inoltre necessario rendere tale controller di dominio un server di catalogo globale.

  • Diversi componenti della directory di Exchange Server quali, ad esempio, DSAccess (Directory Service Access), DSProxy (Directory Service Proxy) e il classificatore di messaggi non eseguiranno il failover in altri controller di dominio o server di catalogo globale.

  • Non è consigliabile utilizzare l'opzione di avvio /3GB in Windows perché potrebbe provocare il consumo di tutta la memoria da parte di Exchange Server, riducendo la memoria disponbile per Active Directory.

  • L'arresto del sistema richiederà molto più tempo se i servizi di Exchange Server non vengono arrestati prima di arrestare o riavviare il server.

  • Questa configurazione è meno sicura perché gli amministratori di Exchange disporranno di accesso amministrativo locale ad Active Directory. In tal modo potranno elevare i propri privilegi. Inoltre, eventuali vulnerabilità della protezione rilevate in Exchange Server o in Active Directory espongono l'altra applicazione a compromessi.

  • Se si esegue Exchange Server 2003 o Exchange Server 2007 in un controller di dominio, l'utilizzo dello strumento di promozione del controller di dominio (DCPromo) per modificare il ruolo del computer non è supportato ed è stato accertato che provoca l'arresto di componenti come Microsoft Outlook® Mobile Access.

  • L'esecuzione di Exchange Server 2003 o Exchange Server 2007 in un nodo cluster che sia anche un controller di dominio di Active Directory non è supportata e non deve mai essere eseguita. Significa che, se si esegue Exchange 2000 Server in un nodo di un cluster che è anche un controller di dominio, è necessario abbassare il server al livello di server membro prima di eseguire l'aggiornamento da Exchange 2000 Server a Exchange Server 2003.

Se sul computer viene eseguito Exchange 2000 Server, è consigliabile abbassare di livello il server fino a un server membro utilizzando DCPromo non appena possibile. Se sul computer viene eseguito Exchange Server 2003 o Exchange Server 2007, utilizzare una delle procedure indicate di seguito per risolvere il problema.

Per risolvere il problema spostando Exchange su un altro computer

  1. Installare Exchange Server in un diverso computer.

  2. Utilizzare Sposta cassetta postale dell'Operazione guidata di Exchange per spostare eventuali cassette postali esistenti dal controller di dominio al nuovo server Exchange.

  3. Assegnare una nuova posizione alle cartelle pubbliche e ai ruoli del precedente computer Exchange Server nel nuovo computer Exchange Server.

  4. Disinstallare Exchange Server dal controller di dominio.
Per risolvere questo problema rendendo il server Exchange un server di catalogo globale

  1. Aprire Siti e servizi di Active Directory.

  2. Espandere Siti, il sito e infine Server.

  3. Selezionare il controller di dominio che si desidera specificare come server di catalogo globale.

  4. Nel riquadro di destra fare clic con il pulsante destro del mouse su Impostazioni NTDS e scegliere Proprietà.

  5. Nella scheda Generale selezionare la casella di controllo Catalogo globale. Se il server di elenchi in linea esegue Windows 2000 Service Pack 2 o una versione precedente, riavviare il server per rendere effettiva la modifica. Se il server di elenchi in linea esegue Windows 2000 Service Pack 3 o una versione successiva oppure se esegue Windows Server™ 2003, la modifica viene applicata in modo dinamico senza dover riavviare il server.

Per ulteriori informazioni sull'installazione di Exchange Server in un controller di dominio, consultare l'articolo 250989 della Microsoft Knowledge Base "XADM: Installazione di ADC in un controller di dominio Windows 2000 che esegue anche Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989.


Exchange Server 5.5 rilevato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se il valore della stringa include Version 5.5, sul computer viene eseguito Microsoft Exchange Server versione 5.5. Se il valore della stringa include Version 6.0, sul computer viene eseguito Exchange 2000 Server. Se il valore della stringa include Version 6.5, sul computer viene eseguito Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore di serialNumber include Version 5.5, verrà visualizzato un messaggio di errore.

Tale errore indica che la versione di Exchange Server rilevata non può essere ulteriormente analizzata da questa versione Exchange Server Analyzer.

Exchange Server Analyzer dipende da varie interfacce di programma specifiche che non sono disponibili nella versione di Exchange Server rilevata.

Per risolvere il problema, specificare un server Exchange su cui è in esecuzione Exchange 2000 o versioni successive.

Se si ritiene che questa regola sia stata attivata per errore, verificare che il valore dell'attributo serialNumber dell'oggetto Exchange Server in Active Directory sia impostato correttamente.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per visualizzare il valore dell'attributo serialNumber

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo> e infine CN=Servers.

  4. Fare clic con il pulsante destro del mouse sull'oggetto server virtuale, quindi scegliere Proprietà.

  5. Fare doppio clic sull'attributo serialNumber per visualizzarne il valore corrente.

Per ulteriori informazioni sulla distribuzione di Exchange Server 2003, vedere la "Guida alla distribuzione di Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sulla migrazione da Exchange Server 5.5 a Exchange Server 2003, consultare l'articolo 259912 della Microsoft Knowledge Base "Prerequisiti per l'aggiornamento di Exchange Server 5.5 a Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912.

Per ulteriori informazioni sulla migrazione e sull'aggiornamento a Exchange Server 2003, vedere "Aggiornamento a Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34186.


Su Exchange Server 5.5 non è in esecuzione il Service Pack più recente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il processo STORE.EXE. Se Exchange Server Analyzer determina che la chiave Version per STORE.EXE presenta un valore maggiore di 1959, ma minore di 2653, verrà visualizzato un avviso. Ciò indica che sul computer è in esecuzione Exchange Server 5.5 con la versione non definitiva di Service Pack 4.

Questo avviso indica che il computer Exchange Server non esegue il codice più recente disponibile per la versione di Exchange in esecuzione sul computer.

Per risolvere il problema

  1. Scaricare Exchange 5.5 Server Service Pack 4 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33456.

  2. Scaricare l'aggiornamento più recente (maggio 2004) di Exchange Server 5.5 dall'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33456.

  3. Per ulteriori informazioni relative a questo aggiornamento, consultare l'articolo 841765 della Microsoft Knowledge Base "Aggiornamento cumulativo del maggio 2004 per Exchange Server 5.5" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765.

  4. Eseguire un backup completo del computer Exchange Server.

  5. Installare Exchange Server 5.5 Service Pack 4.

  6. Installare l'aggiornamento del maggio 2004.

Per ulteriori informazioni sull'installazione di questo e altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Exchange Server 5.5 non è supportato in Windows 2003
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue Windows Server™ 2003.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende Version 5.5, il computer esegue Microsoft Exchange Server versione 5.5. Se la stringa comprende Version 6.0, il computer esegue Exchange 2000 Server. Se la stringa comprende Version 6.5, il computer esegue Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore di CurrentVersion è 5.2 e che il valore serialNumber contiene "Version 5.5", verrà visualizzato un messaggio di errore. Si tratta di una configurazione non supportata, pertanto è opportuno correggere questo errore non appena possibile.

Per risolvere il problema

  • Eseguire una delle seguenti operazioni:

    • Installare Exchange Server 5.5 in un server su cui è in esecuzione un sistema operativo supportato e spostare le cassette postali in tale server.

    • Eseguire la migrazione da Exchange Server 5.5 a Exchange Server 2003.

Per ulteriori informazioni sulla distribuzione di Exchange Server 2003, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni su Exchange Server e Windows Server 2003, consultare l'articolo 810591 della Microsoft Knowledge Base "Compatibilità di Exchange 2000 Server e di Exchange Server 5.5 con Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810591.

Per ulteriori informazioni sulla migrazione da Exchange Server 5.5 a Exchange Server 2003, consultare l'articolo 259912 della Microsoft Knowledge Base "Prerequisiti per l'aggiornamento di Exchange Server 5.5 a Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=259912.

Per ulteriori informazioni sulla migrazione e sull'aggiornamento a Exchange Server 2003, consultare la pagina dedicata alla migrazione e all'aggiornamento "Upgrade to Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34186 (informazioni in lingua inglese).


Exchange Server 5.0 non è aggiornato il Service Pack o aggiornamento cumulativo più recente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il processo STORE.EXE. Se Exchange Server Analyzer rileva che il valore della chiave Version per STORE.EXE è maggiore o uguale a 1456 e minore di 1460, verrà visualizzato un avviso.

Questo avviso indica che il computer Exchange Server non esegue il codice più recente disponibile per la versione di Exchange in esecuzione sul computer.

Per risolvere il problema

  1. Scaricare il Service Pack 2 di Exchange Server 5.0 dalla pagina http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858.

  2. Leggere il file README.TXT del Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168735.

  3. Consultare l'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41361 per scaricare l'aggiornamento più recente (aprile 2004) per Exchange Server 5.0.

  4. Per ulteriori informazioni su a questo aggiornamento, consultare l'articolo 834130 della Microsoft Knowledge Base "Aggiornamento cumulativo per Microsoft Exchange 5.0" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130.

  5. Eseguire un backup completo del computer Exchange Server.

  6. Installare il Service Pack 2 per Exchange Server 5.0.

  7. Installare l'aggiornamento di aprile 2004.

Per ulteriori informazioni sull'installazione di questo e altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Exchange Server 5.5 residente sul controller di dominio di Active Directory
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave DomainRole. I valori validi per questa chiave sono elencati nella seguente tabella.

Valore | Significato
0 | Workstation autonoma
1 | Workstation membro
2 | Server autonomo
3 | Server membro
4 | Controller di dominio di backup
5 | Controller di dominio primario

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_Service per determinare il valore della chiave Started per il servizio cluster (ClusSvc).

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti directory con la categoria oggetto msExchExchangeServer. Il valore dell'attributo serialNumber indica la versione di Exchange Server in uso.

Se Exchange Server Analyzer rileva che il valore della chiave DomainRole è maggiore di 3 in un computer Exchange Server e che tale computer non è in esecuzione su un cluster Windows oppure sul computer non è in esecuzione Exchange Server versione 5.5, verrà visualizzato un avviso.

Questo avviso indica che Exchange Server 5.5 è in esecuzione su un server Active Directory. Questa situazione può provocare problemi di conflitti di porta con Active Directory Connector. Se Active Directory Connector utilizza questo server come destinazione, è necessario assicurarsi che venga utilizzato il numero corretto della porta LDAP di Exchange. Per impostazione predefinita, il server di elenchi in linea è configurato per l'ascolto delle richieste LDAP sulla porta TCP 389. A meno che la porta per Exchange non sia modificata e ADC configurato per utilizzare la porta di Exchange, ADC non potrà comunicare con Exchange.

Active Directory utilizza la porta LDAP standard 389 per l'accesso LDAP. Tuttavia, utilizzando il numero di porta standard viene ignorato il server di Exchange che si trova sullo stesso server e che sta tentando l'ascolto sulla porta LDAP 389. Per garantire al server di Exchange l'accesso LDAP alla directory, è necessario assegnare nuovamente la porta LDAP per Exchange.

Per risolvere il problema

  1. Aprire il programma di amministrazione di Microsoft Exchange.

  2. Espandere Nome sito, Configurazione, Protocolli e infine Impostazioni predefinite sito LDAP (directory).

  3. Modificare l'assegnazione della porta dal numero corrente 389 a un numero di porta che non è in uso.

  4. Fare clic su OK per salvare la modifica.

  5. Per rendere effettiva la modifica, riavviare il servizio directory di Microsoft Exchange.

  6. Se necessario, riconfigurare Active Directory Connector che utilizza questo server come destinazione in modo che utilizzi la nuova porta.

Per ulteriori informazioni su come modificare l'assegnazione della porta LDAP in Exchange Server 5.5, consultare l'articolo 224447 della Microsoft Knowledge Base "XADM: Modifica delle assegnazioni della porta LDAP in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=224447.


Errore nella risoluzione dei nomi DNS di Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool tenta di eseguire una query in Domain Name System (DNS) per ricercare i server DNS configurati per ogni computer Exchange Server. Questa connessione viene effettuata mediante un elaboratore di oggetti personalizzati su cui viene eseguita una richiesta di risoluzione dei nomi e vengono analizzati i risultati. Se Exchange Server Analyzer non riceve un indirizzo IP (Internet Protocol) nell'ambito dei risultati della query, verrà visualizzato un messaggio di errore.

Tale errore indica che non è stato rilevato un computer Exchange Server in DNS. Sia Exchange Server che il servizio directory di Active Directory® richiedono la corretta configurazione del DNS per funzionare. I problemi relativi alla risoluzione e registrazione DNS possono provocare effetti diffusi sulla capacità di invio, ricezione e recapito dei messaggi.

Per assicurarsi che Active Directory e Exchange Server funzionino correttamente, è necessario configurare in modo appropriato il DNS. Per una descrizione più dettagliata sulla configurazione DNS per Active Directory, consultare l'articolo 237675 della Microsoft Knowledge Base "Configurazione di Domain Name System (DNS) per Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=237675.

Per risolvere il problema

  1. Esaminare le seguenti voci di configurazione per assicurare che il DNS funzioni e che le voci DNS di Exchange Server siano registrate correttamente:

    • Configurazione IP DNS

    • Aggiornamenti dinamici delle zone

    • Server di inoltro DNS

  2. Verificare l'esistenza di una voce Root Zone. Visualizzare le zone Ricerca diretta nella console di DNS Management. Dovrebbe essere presente una voce per il dominio. Possono esistere altre voci di zona. Non dovrebbe essere presente una zona punto ("."). Se lo fosse, eliminare la zona punto ("."), poiché identifica il server DNS come server principale. Normalmente un dominio di Active Directory che richiede accesso esterno (Internet) non dovrebbe essere configurato come server DNS principale. Registrare di nuovo, manualmente, l'indirizzo IP del server Exchange utilizzando Ipconfig /registerdns nel server di elenchi in linea dopo aver eliminato un punto ("."). Potrebbe essere anche necessario riavviare il servizio Netlogon.

  3. Ripopolare manualmente le voci DNS di Exchange Server utilizzando netdiag /fix nel computer Exchange Server.

Per ulteriori informazioni sull'utilizzo di DNS con Active Directory, consultare l'articolo 323418 della Microsoft Knowledge Base, "HOW TO: Integrare DNS con un'infrastruttura DNS esistente se Active Directory è attivato in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418.

Per ulteriori informazioni sulla risoluzione dei problemi relativi a DNS e Active Directory, consultare l'articolo 260371 della Microsoft Knowledge Base, "Risoluzione dei problemi nell'installazione comune di Active Directory in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260371.


Il server di Exchange è stato designato come front-end e potrebbe ospitare cassette postali
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nell'oggetto Microsoft WMI (Strumentazione gestione Windows®) di Exchange Server (classe Exchange_Server) per determinare il valore di IsFrontEndServer per il server. Se il valore è True, il server di Exchange funziona come server front-end. Se il server dispone di archivi delle cassette postali, Exchange Server Analyzer eseguirà una query nel servizio directory di Active Directory® per determinare quante cassette postali si trovano sul server. Ciascun oggetto archivio delle cassette postali (classe msExchPrivateMDB) presenta un attributo multivalore homeMDBBL che elenca tutte le cassette postali del'archivio. Contando questi valori, Exchange Server Analyzer ottiene il numero totale delle cassette postali presenti sul server.

Se il server Exchange viene designato come server front-end e contiene più di 20 cassette postali configurate, verrà visualizzato un avviso.

A seconda della configurazione, potrebbe essere necessario posizionare delle cassette postali di servizio sul server front-end. Ad esempio, se il server front-end accetta posta SMTP (Simple Mail Transfer Protocol) da Internet, potrebbe essere necessaria una cassetta postale dedicata al servizio Exchange SMTP sul server. Exchange Server Analyzer rende conto di queste cassette postali di servizio visualizzando un avviso se più di 20 cassette postali configurate si trovano sul server di Exchange.

È consigliabile non posizionare le cassette postali degli utenti sul server front-end. Tale configurazione non è supportata.

Se le cassette postali degli utenti si trovano sul server front-end, utilizzare Gestore di sistema di Exchange (solo Exchange Server 2003) o Utenti e computer di Active Directory per spostarle su un server back-end appropriato.

Per spostare le cassette postali su Exchange 2000 Server e Exchange Server 2003 procedere come segue

  1. In Utenti e computer di Active Directory selezionare l'utente o gli utenti proprietari delle cassette postali che si desidera spostare.

  2. Fare clic con il pulsante destro del mouse sull'elenco utente selezionato nel passaggio precedente e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange fare clic su Sposta cassetta postale e poi su Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.

Per spostare le cassette postali in Exchange Server 2003 procedere come segue

  1. In Gestore di sistema di Exchange espandere Server, il server dal quale si desidera sposare le cassette postali, il Gruppo di archiviazione da cui si desidera spostare le cassette postali, la struttura Archivio cassette postali contenente le cassette postali che si desidera spostare e fare clic su Cassette postali.

  2. Nel riquadro dettagli fare clic con il pulsante destro del mouse sull'utente o sugli utenti proprietari delle cassette postali che si desidera spostare e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange fare clic su Sposta cassetta postale e poi su Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.

Per ulteriori informazioni relative alla configurazione dei server front-end di Exchange, consultare l'articolo 822443 della Microsoft Knowledge Base "Raccomandazioni per i server front-end in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822443.

Per consigli generali sull'installazione e sulla configurazione dei server front-end di Exchange, consultare il Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sugli errori che possono verificarsi durante l'esecuzione di cassette postali degli utenti su un server front-end di Exchange, consultare l'articolo 273296 della Microsoft Knowledge Base, "XCON: Gli utenti non possono recuperare la posta in un server front-end" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273296.

Per ulteriori informazioni sullo spostamento di cassette postali su Exchange Server 2003, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821829, "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.


Questo server Exchange è anche un controller di dominio. Tale configurazione non è consigliata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-28

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave DomainRole. I valori validi per questa chiave sono elencati nella seguente tabella.

Valore | Significato
0 | Workstation autonoma
1 | Workstation membro
2 | Server autonomo
3 | Server membro
4 | Controller di dominio di backup
5 | Controller di dominio primario

Inoltre, Exchange Server Analyzer esegue una query nella classe WMI Win32_Service per determinare il valore della chiave Started per ClusSvc, il servizio cluster.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti directory con la categoria oggetto msExchExchangeServer. Il valore dell'attributo serialNumber indica la versione di Exchange Server in uso.

Se Exchange Server Analyzer rileva che il valore della chiave DomainRole è maggiore di 3 in un computer Exchange Server e che su tale computer non è in esecuzione Exchange Server versione 5.5 oppure il computer non è in esecuzione in un cluster Windows, verrà visualizzato un avviso.

Se si esegue Exchange Server come parte di Microsoft Windows Small Business Server 2000 o di Windows Small Business Server 2003, è possibile installare Exchange Server in un controller di dominio. Tuttavia, se non si esegue Exchange Server come parte di Windows Small Business Server, è consigliabile non eseguire Exchange Server su un controller di dominio.

Se si esegue Exchange Server in un controller di dominio senza Small Business Server, è necessario essere consapevoli dei seguenti problemi:

  • Exchange Server e Active Directory sono entrambe applicazioni che richiedono un utilizzo intensivo delle risorse. Quando vengono eseguite entrambe sullo stesso computer, le prestazioni ne verranno influenzate.

  • Se Exchange Server viene eseguito in un controller di dominio, è inoltre necessario rendere tale controller di dominio un server di catalogo globale. Per ulteriori informazioni sulla creazione di un server di catalogo globale, consultare l'articolo 313994 della Microsoft Knowledge Base "HOW TO: Creare o spostare un catalogo globale in Windows Server 2003, Windows 2000 o Small Business Server 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid= 313994.

  • Diversi componenti della directory di Exchange Server quali, ad esempio, DSAccess (Directory Service Access), DSProxy (Directory Service Proxy) e il Classificatore di messaggi non eseguiranno il failover in altri controller di dominio o server di catalogo globali.

  • Non è consigliabile utilizzare l'opzione di avvio /3GB in Windows perché potrebbe provocare l'utilizzo dell'intera memoria da parte di Exchange Server, riducendo la memoria disponbile per Active Directory.

  • L'arresto del sistema richiederà molto più tempo se i servizi di Exchange Server non vengono arrestati prima di arrestare o riavviare il server.

  • Questa configurazione è meno sicura perché gli amministratori di Exchange disporranno di accesso amministrativo locale ad Active Directory. In tal modo potranno elevare i propri privilegi. Inoltre, eventuali vulnerabilità della protezione rilevate in Exchange Server o in Active Directory espongono l'altra applicazione a compromessi.

  • Se si esegue Exchange Server 2003 o Exchange Server 2007 su un controller di dominio, l'utilizzo dello strumento di promozione del controller di dominio (DCPromo) per modificare il ruolo del computer non è supportato ed è stato accertato che provoca l'arresto di componenti come Microsoft Outlook® Mobile Access.

  • Exchange Server 2003 o Exchange Server 2007 non deve essere eseguito in un nodo cluster che sia anche un controller di dominio di Active Directory in quanto tale configurazione non è supportata. Significa che, se si esegue Exchange 2000 Server in un nodo di un cluster che è anche un controller di dominio, è necessario abbassare di livello il server fino a un server membro prima di eseguire l'aggiornamento da Exchange 2000 Server a Exchange Server 2003.

Se sul computer viene eseguito Exchange 2000 Server, è consigliabile abbassare di livello il server a server membro utilizzando DCPromo non appena possibile. Se sul computer viene eseguito Exchange Server 2003, utilizzare la procedura indicata di seguito per risolvere il problema.

Per risolvere il problema

  1. Installare Exchange Server in un diverso computer.

  2. Utilizzare Sposta cassetta postale dell'Operazione guidata di Exchange per spostare eventuali cassette postali esistenti dal controller di dominio al nuovo server di Exchange.

  3. Assegnare una nuova posizione alle cartelle pubbliche e ai ruoli del precedente computer Exchange Server nel nuovo computer Exchange Server.

  4. Disinstallare Exchange Server dal controller di dominio.

Per ulteriori informazioni sull'installazione di Exchange Server in un controller di dominio, consultare l'articolo 250989 della Microsoft Knowledge Base "XADM: Installazione di ADC in un controller di dominio Windows 2000 che esegue anche Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250989.


Questo server Exchange è inattivo o irraggiungibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool utilizza chiamate di procedura remota (RPC, Remote Procedure Call) per leggere il valore della stringa CurrentVersion dalla seguente chiave del Registro di sistema nel computer in cui è installato Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se Exchange Server Analyzer non è in grado di leggere questo valore del Registro di sistema per qualsiasi motivo, verrà visualizzato un messaggio di errore.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando Ping per verificare che il computer Exchange Server sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  4. Verificare che il servizio Registro di sistema remoto sul computer in cui è installato Exchange Server sia stato avviato.

  5. Controllare le autorizzazioni dell'account utilizzato per l'esecuzione di Exchange Server Analyzer Tool per verificare che siano sufficienti per leggere il Registro di sistema nel server Exchange.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, consultare l'articolo 325847 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività di Exchange Server Best Practices Analyzer Tool, consultare "Risoluzione dei problemi di connettività di Microsoft Exchange Server Best Practices Analyzer Tool" all'indirizzo http://go.microsoft.com/fwlink/?linkid=56285.


Questo server Exchange esegue il sistema operativo Windows NT4.0, pertanto sono disponibili informazioni di diagnostica limitate
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione del sistema operativo Windows in esecuzione sul computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue Windows Server™ 2003.

Se Exchange Server Analyzer rileva che il valore di CurrentVersion è uguale a 4.0, verrà visualizzato un avviso.

Il messaggio di avviso indica che il computer Exchange Server esegue Windows NT Server 4.0. In Windows NT Server 4.0 sono presenti meno informazioni di diagnostica rispetto alle versioni successive di Windows Server. Di conseguenza, Exchange Server Analyzer raccoglie e analizza solo una quantità limitata di informazioni.

Per risolvere il problema

  1. Non è necessario eseguire alcuna operazione. Questo messaggio è puramente informativo.

  2. Poiché Windows NT Server 4.0 ed Exchange Server versione 5.5 sono prossimi al termine del ciclo di vita del prodotto, è preferibile eseguire un aggiornamento a Windows Server 2003 e a Exchange Server 2003.

Per ulteriori informazioni sul ciclo di vita del prodotto per Windows NT Server 4.0 ed Exchange Server 5.5, consultare il sito Web Microsoft Support Lifecycle all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21759 (informazioni in lingua inglese).

Per ulteriori informazioni su Windows Server 2003, consultare la home page del prodotto, "Microsoft Windows Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=26095.

Per ulteriori informazioni su Exchange Server 2003, consultare la home page del prodotto, "Microsoft Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21573.


La build finale del Service Pack 2 non è in esecuzione su questo server di Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti di Exchange Server nella directory. L'attributo serialNumber è un valore di stringa che include sia la versione di Exchange Server sia, se installato, la versione del Service Pack. Ad esempio, in un computer Exchange Server 2003 nel quale è stato installato Service Pack 1, l'attributo serialNumber è pari a Versione 6.5 build 7638: Service Pack 2).

Se Exchange Server Analyzer rileva che la stringa del valore dell'attributo serialNumber contiene 6.5 e Service Pack 2, ma non contiene 7638, verrà visualizzato un avviso.

Tale messaggio indica che sul computer Exchange Server 2003 viene eseguita una versione non definitiva di Exchange Server 2003 Service Pack 2.

Nota:
Poiché non è possibile disinstallare i Service Pack di Exchange, è consigliabile eseguire un backup completo del computer che esegue Exchange Server prima di installare eventuali Service Pack.
Per risolvere il problema

  1. Scaricare la versione finale di Exchange Server 2003 Service Pack 2 dal sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.

  2. Per ulteriori informazioni relative alle note sulla versione di Exchange Server 2003, consultare l'indirizzo Web http://go.microsoft.com/fwlink/?LinkId=52072.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Installare il Service Pack 2 per Exchange Server 2003.

  5. Eseguire un altro backup completo del computer che esegue Exchange Server.

Per ulteriori informazioni sull'installazione di un Service Pack di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Applicazione di service pack e aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Sul server di Exchange è in esecuzione SharePoint Portal Server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per Microsoft Windows SharePoint® Portal Server (MSDMSERV). Il valore True indica che SharePoint Portal Server è in esecuzione sul server di Exchange.

Se Exchange Server Analyzer determina che SharePoint Portal Server è in esecuzione su un computer Exchange Server, verrà visualizzato un avviso.

SharePoint Portal Server non è compatibile con Exchange Server e deve essere rimosso. SharePoint Portal Server ed Exchange Server sono progettati per funzionare assieme e svolgere un ruolo nell'ambiente di collaborazione dell'organizzazione. Tuttavia, SharePoint Portal Server ed Exchange Server sono progettati per funzionare l'uno a fianco dell'altro e non per coesistere sullo stesso componente hardware.

Per risolvere il problema

  • Spostare Exchange Server o SharePoint Portal Server su un altro computer. È consigliata la rimozione di uno di questi programmi dal computer.

Per ulteriori informazioni sullo spostamento delle cassette postali di Exchange Server, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Per ulteriori informazioni sulla compatibilità tra Exchange Server e SharePoint Portal Server, consultare l'articolo 277567 della Microsoft Knowledge Base, "Impossibile installare SharePoint Portal Server su un computer che esegue Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=277567.


Su Exchange Server è in esecuzione Virtual Server 2005 con un altro Exchange Server installato come Guest
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge i valori nella seguente chiave del Registro di sistema per determinare se il server è un server virtuale:

HKEY_LOCAL_MACHINE\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1

Exchange Server Analyzer verifica anche la presenza del seguente valore del Registro di sistema:

HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters

Inoltre, Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il servizio Microsoft Exchange Information Store (MSExchangeIS) è attivo sul computer fisico che esegue Microsoft Virtual Server 2005.

Se Exchange Server Analyzer rileva che il server è un server virtuale, che il ramo del Registro di sistema precedentemente specificato esiste e che MSExchangeIS è attivo sul computer fisico, verrà visualizzato un messaggio di errore.

La presenza della chiave HKLM\Software\Classes\Installer\Products\354F2D7F395B57846953B997DF778AC1 indica che nel computer che esegue Exchange Server è installato Virtual Machine Additions. Questa circostanza e l'esistenza della chiave HKLM\Software\Microsoft\Virtual Machine\Guest\Parameters indicano che il computer che esegue Exchange Server è in esecuzione come macchina virtuale Guest in Microsoft Virtual Server 2005.

Microsoft non supporta l'esecuzione di versioni di Exchange Server su un macchina virtuale o un emulatore. Questo vale per Exchange Server in esecuzione su Virtual Server 2005, Microsoft Virtual PC 2004 o altri programmi di computer virtuali di terze parti. Le piattaforme Exchange Server sono state progettate e testate per essere eseguite solo su hardware fisico, in particolare le piattaforme hardware elencate nel catalogo di Windows Server alla pagina http://go.microsoft.com/fwlink/?linkid=17219.

Inoltre, l'esecuzione di Exchange come guest del server virtuale su un computer che esegue Exchange Server non è consigliabile in quanto non consente un'adeguata ridondanza in tutti i servizi.

Per risolvere il problema

  1. Spostare le cassette postali da Exchange Server in esecuzione su Virtual Server 2005 a un computer Exchange Server non virtuale.

  2. Assegnare una nuova posizione alle cartelle pubbliche e trasferire i ruoli contenuti dal server virtuale di Exchange come richiesto.

  3. Disinstallare Exchange dalla macchina virtuale per non concedere l'autorizzazione ed eseguire la rimozione dall'infrastruttura di Exchange e dal servizio directory di Active Directory®.

Per ulteriori informazioni sullo spostamento delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.

  • 224975, "XADM: Differenze tra i metodi di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975.

Per ulteriori informazioni sul supporto per i computer Exchange Server che funzionano in ambienti virtuali, consultare l'articolo 897615 della Microsoft Knowledge Base "Criteri di supporto per i prodotti software Microsoft in esecuzione con software di virtualizzazione dell'hardware di terze parti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

Per ulteriori informazioni su Virtual Server 2005, consultare "Microsoft Virtual Server 2005" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34938.

Per ulteriori informazioni su Virtual PC°2004, consultare "Microsoft Virtual PC°2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34663.


Servizi DNS in esecuzione sul server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio Server DNS (DNS). Il valore True indica che il servizio Server DNS è in esecuzione sul server di Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore restituito per questa chiave indica la versione del sistema operativo Windows in esecuzione sul computer Exchange Server.

Exchange Server Analyzer, inoltre, esegue query nel servizio directory di Active Directory® per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer determina che il servizio Server DNS è avviato in un computer Exchange Server che soddisfa i seguenti criteri, verrà visualizzato un avviso:

  • Il computer Exchange Server contiene più di 100 cassette postali.

  • Il computer che esegue Exchange Server non è in esecuzione su Windows Small Business Server 2003 o Small Business Server 2000.

Non è consigliata l'esecuzione del servizio Server DNS sullo stesso computer di un server cassette postali di Exchange di produzione. Se il servizio Server DNS ed Exchange Server vengono ospitati nello stesso computer di un ambiente di produzione, ne conseguirà probabilmente una riduzione delle prestazioni da parte di uno o entrambi i server.

Per risolvere il problema

  1. Prendere in considerazione una delle seguenti opzioni per risolvere il problema:

    • Spostare il server Exchange o il servizio Server DNS su un altro computer. È consigliata la rimozione completa di una delle applicazioni server dal computer.

    • Spostare le cassette postali di Exchange in una posizione esterna al server. È preferibile almeno rimuovere le cassette postali e convertire il server Exchange in un server di protocollo o infrastruttura. In tal modo si ridurrà notevolmente il carico per il l'I/O del disco e, marginalmente, per la CPU (quest'ultima dipende dal ruolo dell'infrastruttura di Exchange).

    • In alternativa, è possibile installare Small Business Server. Se si esegue Exchange in un ambiente di piccole dimensioni con meno di 75 in cui non è richiesto più di un server di Exchange, è possibile trarre vantaggio dall'installazione di Windows Small Business Server. Windows Small Business Server include sia Microsoft SQL Server™ che Exchange Server, assieme ad altre applicazioni server Microsoft residenti in memoria ed è stato sviluppato, testato e ottimizzato per l'installazione su un singolo computer.

Per ulteriori informazioni sullo spostamento di cassette postali e server di Exchange, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.

  • 224975, "XADM: Differenze tra i metodi di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975.

  • 297289, "Spostamento di Exchange 2000 in un nuovo hardware mantenendo lo stesso nome server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289.

Per ulteriori informazioni su Small Business Server, consultare "Microsoft Windows Small Business Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=23456.


SQL Server in esecuzione nel server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio Microsoft SQL Server™ (MSSQLSERVER). Il valore True indica che il servizio SQL Server è in esecuzione sul server di Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore restituito per questa chiave indica la versione del sistema operativo Windows in esecuzione sul computer Exchange Server.

Exchange Server Analyzer, inoltre, esegue query nel servizio directory di Active Directory® per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer rileva che il servizio SQL Server è stato avviato in un computer Exchange Server che soddisfa i requisiti elencati di seguito, verrà visualizzato un avviso:

  • Il computer Exchange Server contiene più di 100 cassette postali.

  • Il computer che esegue Exchange Server non è in esecuzione su Windows Small Business Server 2003 o Small Business Server 2000.

Non è consigliabile eseguire SQL Server nello stesso computer in cui viene eseguito un server cassette postali Exchange di produzione. Per garantire un funzionamento ottimale, sia nei server cassette postali di SQL Server che in quelli di Exchange viene utilizzata una grande quantità di memoria e di risorse disco. Se nello stesso computer si utilizzano SQL Server e Exchange Server in un ambiente di produzione, è molto probabile che si otterranno scarse prestazioni da uno o da entrambi i server. Inoltre, la risoluzione dei problemi e la protezione di questo tipo di installazione non sono facilmente gestibili.

Infine, è possibile che si verifichino un certo numero di problemi di interoperabilità se SQL Server e Exchange Server vengono eseguiti nello stesso computer. La maggior parte di questi problemi sono il risultato delle incoerenze tra le versioni di file o programmi comuni ai due server, ad esempio MS DTC (Microsoft Distributed Transaction Coordinator), ADO (Microsoft ActiveX® Data Objects) e OLE DB (OLE Database).

Per risolvere il problema

  • Prendere in considerazione una delle seguenti opzioni per risolvere il problema:

    • Spostare Exchange Server o SQL Server dal computer. È consigliata la rimozione completa di uno di questi programmi dal computer.

    • Spostare le cassette postali di Exchange dal server. È preferibile almeno rimuovere le cassette postali e convertire il server di Exchange in un server di protocollo o infrastruttura. In tal modo si ridurrà notevolmente il carico per le operazioni di I/O del disco e, marginalmente, per la CPU (quest'ultima dipende dal ruolo dell'infrastruttura di Exchange).

    • In alternativa, è anche possibile installare Small Business Server. Se si esegue Exchange in un ambiente di piccole dimensioni dove non si richiede più di un server di Exchange, è possibile trarre vantaggio dall'installazione di Small Business Server. Windows Small Business Server include sia SQL Server che Exchange Server, assieme ad altre applicazioni server Microsoft residenti in memoria ed è stato sviluppato, testato e ottimizzato per l'installazione su un singolo computer.

Per ulteriori informazioni sullo spostamento di cassette postali e server di Exchange, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.

  • 224975, "XADM: Differenze tra i metodi di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975.

  • 297289, "Spostamento di Exchange 2000 in un nuovo hardware mantenendo lo stesso nome server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=297289.

Per ulteriori informazioni su Small Business Server, consultare "Microsoft Windows Small Business Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=23456.


Il server Exchange è in esecuzione su VMware
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-10-26

Per ulteriori informazioni sul supporto per i computer Exchange Server che funzionano in ambienti virtuali, consultare l'articolo 897615 della Microsoft Knowledge Base "Criteri di supporto per i prodotti software Microsoft in esecuzione con software di virtualizzazione dell'hardware di terze parti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=897615.


Sul server di Exchange è disponibile meno di 1 GB di memoria, ma nel file boot.ini sono impostate le opzioni /3GB e /USERVA=3030
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query in due classi WMI (Strumentazione gestione Windows®) per determinare la quantità di memoria fisica nel computer Exchange Server e la quantità di spazio di indirizzi virtuali assegnata ai processi in modalità utente. Nella tabella sono illustrate le classi e le chiavi prese in esame da Exchange Server Analyzer.

Classe | Chiave | Descrizione
Win32_OperatingSystem | MaxProcessMemorySize | Numero massimo di KB di memoria che possono essere assegnati a un processo.
Win32_OperatingSystem | OSProductSuite | Aggiunte installate e con licenza del sistema operativo.
Win32_ComputerSystem | TotalPhysicalMemory | Numero di byte di memoria RAM (Random Access Memory) installati nel computer.

Se Exchange Server Analyzer determina che il computer di Exchange Server dispone di meno di 950 MB di RAM e che il valore di MaxProcessMemorySize è maggiore di 2097024 e minore di 3104640, verrà visualizzato un avviso.

Questo avviso indica che il computer Exchange Server non è configurato correttamente per un utilizzo ottimale della memoria da due punti di vista:

  • È stata impostata l'opzione di avvio /USERVA=3030. Questa opzione è necessaria solo su computer Exchange Server con almeno 1 GB di memoria che eseguono un sistema operativo Microsoft Windows Server™ 2003.

  • È stata impostata l'opzione di avvio /3GB. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

    • Microsoft Windows Server 2003 Standard Edition

    • Microsoft Windows Server 2003 Enterprise Edition

    • Microsoft Windows Server 2003 Datacenter Edition

    • Microsoft Windows 2000 Advanced Server

    • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

Se questo avviso viene visualizzato in un sistema in cui è installato 1 GB di memoria fisica, potrebbe indicare che parte di questa memoria è stata allocata a livello di hardware a un altro componente, quale una scheda video, rendendo, di conseguenza, la memoria fisica allocata non disponibile per il sistema operativo. In tali casi, la quantità di memoria installata fisicamente in base a Windows sarà inferiore alla quantità effettiva di memoria fisica installata nel computer. Se si riscontra questa situazione, sarà necessario confrontare la quantità di memoria installata riportata dal BIOS con la quantità riportata da Windows.

Per correggere questo errore su Windows Server 2003

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  2. Fare clic su Avanzate.

  3. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  4. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  5. Nella sezione [Operating Systems] eliminare da tutte le righe di avvio le seguenti opzioni: /3GB /USERVA=3030

  6. Salvare le modifiche e chiudere Blocco note.

  7. Per rendere effettiva la modifica, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer.

Per correggere questo errore su Windows 2000 Server

  1. In Esplora risorse, passare alla partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, nelle Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse fare clic su Strumenti, scegliere Opzioni cartella e quindi fare clic su Visualizza. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse su di esso, scegliere Apri con, quindi Blocco note per aprire il file.

  4. Rimuovere l'opzione /3GB e, se presente, /USERVA=3030.

  5. Salvare le modifiche e chiudere Blocco note.

  6. Per rendere effettiva la modifica, riavviare il computer.

Per ulteriori informazioni sull'utilizzo delle opzioni di avvio /3GB e /USERVA, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 30356, "Utilizzo della memoria da parte del processo Lsass.exe in controller di dominio basati su Windows 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356.

  • 297812, "Utilizzo della funzione di ottimizzazione della RAM 4GT" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 316739, "Utilizzo dell'opzione /USERVA nel file Boot.ini per l'ottimizzazione delle configurazioni /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


Questo server Exchange dispone di meno di 1 GB di memoria ma presenta l'opzione /3GB nel file Boot.ini
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query in due classi Microsoft WMI (Strumentazione gestione Windows®) per determinare la quantità di memoria fisica nel computer Exchange Server e la quantità di spazio di indirizzi virtuali assegnata ai processi in modalità utente eseguiti sul computer Exchange Server. Nella tabella sono illustrate le classi e le chiavi prese in esame da Exchange Server Analyzer.

Classe in cui è eseguita la query | Chiavi in cui è eseguita la query | Descrizione
Win32_OperatingSystem | MaxProcessMemorySize | Numero massimo di KB di memoria che possono essere assegnati a un processo.
Win32_ComputerSystem | TotalPhysicalMemory | Numero di byte di memoria RAM (Random Access Memory) installati nel computer.

Se Exchange Server Analyzer stabilisce che il valore della chiave TotalPhysicalMemory è inferiore a 1073741824 e che il valore della chiave MaxProcessMemorySize è pari a 3145600, verrà visualizzato un avviso.

Tale messaggio indica che il sistema dispone di meno di 950 MB di memoria fisica, ma è stato configurato con l'opzione di avvio /3GB nel file Boot.ini. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

Se questo avviso viene visualizzato in un sistema in cui è installato 1 GB di memoria fisica, potrebbe indicare che parte di questa memoria è stata allocata a livello di hardware a un altro componente, quale una scheda video, rendendo, di conseguenza, la memoria fisica allocata non disponibile per il sistema operativo. In tali casi, la quantità di memoria installata fisicamente in base a Windows sarà inferiore alla quantità effettiva di memoria fisica installata nel computer. Se si riscontra questa situazione, sarà opportuno confrontare la quantità di memoria installata riportata dal BIOS con la quantità riportata da Windows.

Per correggere questo errore su Windows Server 2003

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  2. Fare clic su Avanzate.

  3. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  4. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  5. Nella sezione [Operating Systems], eliminare da tutte le righe di avvio le seguenti opzioni: /3GB

  6. Salvare le modifiche e chiudere Blocco note.

  7. Per rendere effettiva la modifica, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer.

Per correggere questo errore su Windows 2000 Server

  1. In Esplora risorse aprire Partizione di sistema. Questa è la partizione che contiene i file specifici dell'hardware come Boot.ini e NTLDR.

  2. Se non è possibile visualizzare il file Boot.ini, nelle Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse fare clic su Strumenti, scegliere Opzioni cartella e quindi fare clic su Visualizza. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene richiesto, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse su di esso, scegliere Apri con, quindi Blocco note per aprire il file.

  4. Nella sezione [Operating Systems], eliminare da tutte le righe di avvio le seguenti opzioni: /3GB

  5. Salvare le modifiche e chiudere Blocco note.

  6. Per rendere effettiva la modifica, riavviare il computer.

Per ulteriori informazioni su come ottimizzare l'utilizzo della memoria di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


Questo server Exchange presenta l'opzione di avvio /3GB nel file Boot.ini
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare la quantità di spazio di indirizzi virtuali assegnato ai processi in modalità utente (MaxProcessMemorySize) nel computer Exchange Server.

Exchange Server Analyzer analizza inoltre la classe WMI Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il servizio cluster (ClusSvc) è presente e avviato.

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il conteggio per l'attributo homeMDBBL dell'oggetto archivio cassette postali (msExchPrivateMDB). Il conteggio risultante è il numero di cassette postali rilevate nel computer Exchange Server.

Se Exchange Server Analyzer determina che il valore della chiave MaxProcessMemorySize non equivale a 2097024, che il valore della chiave IsFrontEndServer è impostato su False, che il servizio cluster non è in esecuzione, che l'archivio delle cassette postali di Exchange Server contiene meno di 20 cassette postali e che Exchange non è in esecuzione su Microsoft Windows Small Business Server 2003, verrà visualizzato un avviso.

Questo avviso indica che il server di elenchi in linea non è configurato correttamente per l'utilizzo ottimale della memoria dal momento che l'opzione di avvio /3GB è stata impostata nel file Boot.ini. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows Server 2000 dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

Quando il parametro /3GB è incluso nel file Boot.ini di un sistema operativo supportato, Windows assegna 3 GB su un massimo di 4 GB di spazio di indirizzi virtuali al processo utente e 1 GB al kernel. Generalmente (quando il parametro /3GB non è utilizzato), Windows assegna 2 GB al processo utente e 2 GB al kernel. Pertanto, grazie all'opzione /3GB, le applicazioni che comportano un uso intensivo della memoria dispongono di un maggiore spazio di indirizzi della memoria virtuale per funzionare e le prestazioni risultano migliorate.

L'utilizzo dell'opzione /3GB supporta principalmente le applicazioni che comportano un uso intensivo della memoria, come il processo Store.exe in un server di Exchange che contiene cassette postali degli utenti. Un server front-end non contiene cassette postali degli utenti, pertanto, l'utilizzo dell'opzione /3GB in questo tipo di server non comporterebbe alcun vantaggio.

Per risolvere il problema

  1. In Esplora risorse, passare alla partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, in Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse è sufficiente scegliere Strumenti, Opzioni cartella e selezionare la scheda Visualizza. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con e fare clic su Blocco note per aprire il file.

  4. Nella sezione [Operating Systems] eliminare le seguenti opzioni da tutte le righe di avvio: /3GB

  5. Salvare le modifiche e chiudere Blocco note.

  6. Per rendere effettiva la modifica, riavviare il computer.

Per ulteriori informazioni sull'utilizzo dell'opzione del Registro di sistema /3GB, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi relativi alla frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044)

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003"

    (http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372)


Su questo server Exchange 2003 non è in esecuzione la versione finale del Service Pack 1 build 7226.6
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti di Exchange Server nella directory. L'attributo serialNumber è un valore di stringa che include sia la versione di Exchange Server sia, se installato, la versione del Service Pack. Ad esempio, in un computer Exchange Server 2003 dove è stato installato Service Pack 1, l'attributo serialNumber è pari a Versione 6.5 (build 7226.6: Service Pack 1).

Se Exchange Server Analyzer rileva che la stringa del valore dell'attributo serialNumber contiene 6.5 e Service Pack 1, ma non contiene 7226.6, verrà visualizzato un avviso.

Tale messaggio indica che sul computer Exchange Server 2003 viene eseguita una versione non definitiva di Exchange Server 2003 Service Pack 1.

Nota:
Poiché non è possibile disinstallare i Service Pack di Exchange, è consigliabile eseguire un backup completo del computer Exchange Server prima di installare eventuali Service Pack.

Per risolvere il problema

  1. Per richiedere la versione più recente di Exchange Server 2003 Service Pack 1, visitare il sito Web http://go.microsoft.com/fwlink/?linkid=29090.

  2. Per ulteriori informazioni relative alle note sulla versione di Exchange Server 2003, consultare l'indirizzo Web http://go.microsoft.com/fwlink/?linkid=23235.

  3. Per ulteriori informazioni sugli aggiornamenti inclusi nel Service Pack 1, consultare l'indirizzo http://go.microsoft.com/fwlink/?linkid=34272.

  4. Eseguire un backup completo del computer Exchange Server.

  5. Installare il Service Pack 1 per Exchange Server 2003.

  6. Eseguire un altro backup completo del computer Exchange Server.

Per ulteriori informazioni sull'installazione di un Service Pack di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Applicazione di service pack e aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Su questo server Exchange è in esecuzione Windows 2000 Server ma è impostata l'opzione /3GB nel file boot.ini
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query in due classi Microsoft WMI (Strumentazione gestione Windows®) per determinare la quantità di memoria fisica nel computer Exchange Server e la quantità di spazio di indirizzi virtuali assegnata ai processi in modalità utente. Nella tabella sono illustrate le classi e le chiavi prese in esame da Exchange Server Analyzer.

Classe | Chiave | Descrizione
Win32_OperatingSystem | MaxProcessMemorySize | Numero massimo di KB di memoria che possono essere assegnati a un processo.
Win32_OperatingSystem | OSProductSuite | Aggiunte installate e con licenza del sistema operativo.
Win32_ComputerSystem | TotalPhysicalMemory | Numero di byte di memoria RAM (Random Access Memory) installati nel computer.

Se Exchange Server Analyzer rileva che il valore della chiave MaxProcessMemorySize non è uguale a 2097024 e che il valore della chiave OSProductSuite punta a Windows 2000 Server, verrà visualizzato un messaggio di errore.

Questo avviso indica che il server di elenchi in linea non è configurato correttamente per l'utilizzo ottimale della memoria dal momento che l'opzione di avvio /3GB è stata impostata nel file Boot.ini. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server™ 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

  • Microsoft Windows 2000 Advanced Server

  • Microsoft Windows 2000 Datacenter Server

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica.

Per risolvere il problema in Windows Server 2003

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Viene visualizzata la finestra di dialogo Proprietà del sistema.

  2. Selezionare la scheda Avanzate.

  3. Nell'area Avvio e ripristino fare clic sul pulsante Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  4. Nell'area Avvio sistema fare clic sul pulsante Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  5. Nella sezione [Operating Systems], eliminare da tutte le righe di avvio le seguenti opzioni: /3GB.

  6. Salvare le modifiche e chiudere Blocco note.

  7. Per rendere effettiva la modifica, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il server di elenchi in linea.

Per risolvere il problema in Windows 2000 Server

  1. In Esplora risorse, passare alla partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, in Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse è sufficiente scegliere Strumenti, Opzioni cartella e selezionare la scheda Visualizza. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con e fare clic su Blocco note per aprire il file.

  4. Rimuovere /3GB e salvare il file.

  5. Riavviare il server di elenchi in linea per rendere effettive le modifiche.

Per ulteriori dettagli sull'utilizzo delle opzioni di avvio /3GB e /USERVA consultare i seguenti articoli della Microsoft Knowledge Base:

  • 297812, "Utilizzo della funzione di ottimizzazione della RAM 4GT" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 316739, "Utilizzo dell'opzione /USERVA nel file Boot.ini per l'ottimizzazione delle configurazioni /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


Impossibile accedere alla classe WMI del server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-08-24

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se un valore è impostato per la chiave Name. Se si verifica un errore nella query WMI e se sul server Exchange non è in esecuzione Microsoft® Windows NT® Server°4.0, verrà visualizzato un messaggio di errore.

Questo errore può essere provocato dai due motivi riportati di seguito:

  • L'account che esegue Exchange Server Analyzer non dispone delle autorizzazioni necessarie per eseguire una query WMI.

  • Un problema di rete impedisce a Exchange Server Analyzer di accedere al computer.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il computer Exchange Server sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC (Remote Procedure Call) sono bloccate.

  4. Controllare le autorizzazioni per l'account su cui è in esecuzione Exchange Server Analyzer. Questo account deve disporre delle autorizzazioni di amministratore locale su ciascun server Exchange di cui esegue l'analisi.

    In alternativa, è possibile concedere un'autorizzazione WMI specifica all'account su cui è in esecuzione Exchange Server Analyzer.

    1. Sul computer Exchange aprire la struttura della console MMC (Microsoft Management Console) Gestione computer.

    2. In Servizi e applicazioni fare clic con il pulsante destro del mouse su Controllo WMI e scegliere Proprietà.

    3. Nella pagina delle proprietà Controllo WMI fare clic sulla scheda Protezione, quindi espandere Directory principale.

    4. Selezionare la cartella CIMV2, quindi fare clic su Protezione.

    5. Nella pagina Protezione per ROOT\CIMV2 aggiungere l'account sul quale è in esecuzione Exchange Server Analyzer.

  5. Selezionare l'account aggiunto nel Passaggio 5. In Autorizzazioni per Account selezionato, nella colonna Consenti, selezionare sia Abilita remoto sia Protezione da lettura, quindi fare clic su OK.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, consultare l'articolo 325847 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività di Exchange Server Analyzer Tool, consultare "Risoluzione dei problemi di connettività di Microsoft Exchange Server Best Practices Analyzer Tool" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285.

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Informazioni generali sul servizio e sui requisiti delle porte di rete del sistema Microsoft Windows Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017 (in inglese).


Il servizio Supervisore sistema di Exchange non è in esecuzione su questo server front-end
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per stabilire il valore della chiave Started per il servizio Supervisore sistema di Microsoft Exchange. Il valore False indica che il Supervisore sistema di Microsoft Exchange non è in esecuzione. Il valore True indica che il Supervisore sistema di Microsoft Exchange è in esecuzione.

Inoltre, Exchange Server Analyzer esamina la classe WMI (Strumentazione gestione Windows®) Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Se Exchange Server Analyzer rileva che il valore della chiave Started è impostato su False in un server front-end di Exchange verrà visualizzato un avviso.

In genere, sulla maggior parte dei server di Exchange il servizio Supervisore sistema è sempre in esecuzione. A volte, tuttavia, l'esecuzione di tale servizio non è necessaria. Ad esempio, in un server front-end il servizio Supervisore sistema è necessario soltanto per apportare modifiche alla configurazione del server.

Exchange Server memorizza tutte le informazioni di configurazione nel servizio directory di Active Directory®, incluse quelle sui criteri destinatari, sulla configurazione dei server virtuali SMTP, sulle impostazioni RPC (Remote Procedure Call) su HTTP (Hypertext Transfer Protocol) e sulle cassette postali degli utenti. Tuttavia, le impostazioni SMTP vengono lette dalla metabase di Internet Information Services (IIS). Per inserire nella metabase di IIS le informazioni necessarie a Exchange per SMTP e la funzionalità HTTP su RPC, tramite il componente DS2MB (directory service to metabase, servizio directory nella metabase) del servizio Supervisore sistema viene eseguita la replica delle informazioni di configurazione da Active Directory alla metabase di IIS. Se il servizio Supervisore sistema non è in esecuzione, le modifiche apportate alle impostazioni di configurazione di Exchange Server memorizzate in Active Directory non verranno copiate nella metabase di IIS di Exchange Server. Se non sono state apportate modifiche alla configurazione e i messaggi SMTP non sono stati elaborati, è possibile che il servizio Supervisore sistema rimanga in uno stato di interruzione.

Se è necessario apportare modifiche alla configurazione, avviare il servizio Supervisore sistema, apportare le modifiche, quindi attendere che ne venga eseguita la replica nella metabase di IIS. Per determinare se le modifiche sono state replicate da Active Directory nella metabase di IIS, verificare la presenza nel registro eventi applicazioni del server di Exchange delle tre voci con un'origine evento MSExchangeMU e un ID evento 1005. Questi eventi verranno registrati dopo il completamento della replica DS2MB. È possibile arrestare il servizio Supervisore sistema non appena terminata la registrazione degli eventi.

A meno che SMTP non venga utilizzato su un server front-end, implementare la configurazione consigliata arrestando il servizio Supervisore sistema, quindi impostando l'opzione di disabilitazione. Nei server front-end che utilizzano SMTP e in tutti gli altri computer che eseguono Exchange Server, è necessario che il servizio Supervisore sistema sia in esecuzione per recapitare messaggi, elaborare transazioni dell'archivio delle cassette postali e SMTP nonché eseguire la replica DS2MB.

È preferibile che il servizio Supervisore sistema di Microsoft Exchange sia sempre in esecuzione sui server back-end e su qualsiasi altro server di Exchange in cui siano presenti cassette postali o cartelle pubbliche.

Per risolvere il problema

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Nel riquadro destro scorrere fino a visualizzare il servizio Supervisore sistema di Microsoft Exchange, quindi fare doppio clic su di esso. Verrà visualizzata la finestra di dialogo System Attendant Service Properties.

  3. Impostare il valore nell'elenco a discesa Tipo di avvio su Automatico.

  4. Fare clic su Start per avviare il servizio Supervisore sistema.

  5. Fare clic su OK per salvare le modifiche apportate, quindi chiudere la finestra di dialogo System Attendant Service Properties.

  6. Aprire lo snap-in Servizi.

Per ulteriori informazioni sulla disabilitazione del servizio Supervisore sistema e sulla protezione dei server di Exchange consultare i seguenti argomenti di Exchange Server:

  • "Securing Exchange 2000 Servers Based on Role" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=35585 (informazioni in lingua inglese).

  • "Exchange Server 2003 Security Hardening Guide" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47578 (informazioni in lingua inglese).


Il Supervisore sistema di Exchange non è in esecuzione
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) di Win32_Service per stabilire il valore della chiave Started per il Supervisore sistema di Microsoft Exchange. Il valore False indica che il servizio Supervisore sistema di Microsoft Exchange non è in esecuzione. Il valore True indica che il servizio Supervisore sistema di Microsoft Exchange è in esecuzione.

Exchange Server Analyzer analizza inoltre la classe WMI Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Se Exchange Server Analyzer rileva che il valore della chiave Started è impostato su False in un computer Exchange Server che non costituisce un server front-end, verrà visualizzato un avviso.

In genere, sulla maggior parte dei server di Exchange il servizio Supervisore sistema è sempre in esecuzione. A volte, tuttavia, l'esecuzione di tale servizio non è necessaria. Ad esempio, in un server front-end di Exchange 2000 Server o Exchange Server 2003, il servizio Supervisore sistema è necessario soltanto per apportare modifiche alla configurazione del server.

Exchange Server memorizza tutte le informazioni di configurazione nel servizio directory di Active Directory®, incluse quelle sui criteri destinatari, sulla configurazione dei server virtuali SMTP, sulle impostazioni RPC (Remote Procedure Call) su HTTP (Hypertext Transfer Protocol) e sulle cassette postali degli utenti. Tuttavia, le impostazioni SMTP vengono lette dalla metabase di Internet Information Services (IIS). Per inserire nella metabase di IIS le informazioni necessarie a Exchange per SMTP e la funzionalità HTTP su RPC, tramite il componente DS2MB (directory service to metabase, servizio directory nella metabase) del servizio Supervisore sistema viene eseguita la replica delle informazioni di configurazione da Active Directory alla metabase di IIS. Se il servizio Supervisore sistema non è in esecuzione, le modifiche apportate alle impostazioni di configurazione di Exchange Server memorizzate in Active Directory non verranno copiate nella metabase di IIS di Exchange Server. Se non sono state apportate modifiche alla configurazione e i messaggi SMTP non sono stati elaborati, è possibile che il servizio Supervisore sistema rimanga in uno stato di interruzione.

Se è necessario apportare modifiche alla configurazione, avviare il servizio Supervisore sistema, apportare le modifiche, quindi attendere che ne venga eseguita la replica nella metabase di IIS. Per determinare se le modifiche sono state replicate da Active Directory nella metabase di IIS, verificare la presenza nel registro eventi applicazioni del server di Exchange delle tre voci con un'origine evento MSExchangeMU e un ID evento 1005. Questi eventi verranno registrati dopo il completamento della replica DS2MB. È possibile arrestare il servizio Supervisore sistema non appena terminata la registrazione degli eventi.

A meno che SMTP non venga utilizzato su un server front-end di Exchange 2000 Server o Exchange Server 2003, implementare la configurazione consigliata arrestando il servizio Supervisore sistema, quindi impostando l'opzione di disabilitazione. Nei server front-end Exchange 2000 Server o Exchange Server 2003 che utilizzano SMTP e in tutti gli altri computer che eseguono Exchange Server, è necessario che il servizio Supervisore sistema di Exchange sia in esecuzione per poter recapitare messaggi, elaborare transazioni dell'archivio delle cassette postali e SMTP nonché eseguire la replica DS2MB.

È preferibile che il servizio Supervisore sistema di Microsoft Exchange sia sempre in esecuzione sui server back-end e su qualsiasi altro server di Exchange in cui siano presenti cassette postali o cartelle pubbliche.

Per risolvere il problema

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Nel riquadro destro scorrere fino a visualizzare il servizio Supervisore sistema di Microsoft Exchange, quindi fare doppio clic su di esso. Verrà visualizzata la finestra di dialogo System Attendant Service Properties.

  3. Impostare il valore nel menu a discesa Tipo di avvio su Automatico.

  4. Fare clic su Start per avviare il servizio Supervisore sistema.

  5. Fare clic su OK per salvare le modifiche apportate, quindi chiudere la finestra di dialogo System Attendant Service Properties.

  6. Aprire lo snap-in Servizi.

Per ulteriori informazioni sulla disabilitazione del servizio Supervisore sistema e sulla protezione dei server di Exchange, consultare "Protezione dei server di Exchange 2000 basati sui ruoli" all'indirizzo http://go.microsoft.com/fwlink/?linkid=35585.


Exchmem Heaps indica un problema di prestazioni
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha analizzato i contatori di prestazioni Exchmem Heap nell'oggetto prestazioni MSExchangeIS per determinare un'eventuale calo di prestazioni sul server di Exchange. Exchange Server Analyzer Tool fornisce informazioni sui contatori Exchmem nel modo seguente:

  • Se il numero di Exchmem: Numero di heap con errori di memoria è superiore a zero, verrà generato un avviso. Se il valore è superiore a cinque, verrà visualizzato un errore.

  • Se il numero di Exchmem: Numero di errori di memoria è superiore a 500, verrà generato un errore.

  • Se il numero di Exchmem: Numero di heap aggiuntivi è superiore a tre, verrà generato un errore.

Il processo Store.exe utilizza il proprio meccanismo di allocazione heap e le proprie strutture, denominati Exchmem. All'avvio, il processo Store.exe crea molteplici heap Exchmem. Store.exe non aumenta il numero di heap a meno che il numero attuale sia completamente utilizzato o frammentato al punto che un'assegnazione non riesce a trovare memoria contigua sufficiente per effettuare l'operazione.

In caso di problemi di utilizzo della memoria o di frammentazione interna, ovvero di frammentazione negli heap Exchmem che risiedono all'interno dello spazio della memoria virtuale dell'archivio di Exchange, il processo Store.exe crea nuovi heap Exchmem.

In generale, se il processo Store.exe deve creare ripetutamente heap aggiuntivi, la memoria virtuale complessiva dell'archivio di Exchange viene frammentata o si riduce. Se si verificano i contatori sopra elencati, è possibile determinare se gli heap Exchmem costituiscono l'origine di un problema o se si registra un calo delle prestazioni a seguito della rispettiva frammentazione.

Per risolvere il problema

  • Scaricare e installare gli aggiornamenti dell'archivio di Exchange.

    • Per ottenere gli aggiornamenti di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097.

    • Per ottenere gli aggiornamenti di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457.

  • Scaricare e installare gli aggiornamenti per tutte le applicazioni eseguite nel processo Store.exe. Talvolta le applicazioni di terze parti eseguite nel processo Store.exe possono causare la frammentazione degli heap.

  • Valutare la necessità di spostare le cassette postali per rimuoverle dal server interessato e ridurne in tal modo il carico. Per ulteriori informazioni, consultare Spostare le cassette postali degli utenti su un server diverso.

  • Dopo aver identificato la causa del problema, è possibile riavviare il sistema per ripristinare la memoria.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi di prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Microsoft Exchange Server 2003 http://go.microsoft.com/fwlink/?LinkId=47588.


EXCHMEM.DLL è presente nella cartella System32 di Windows
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare se può leggere il valore della chiave Version per \Windows\System32\Exchmem.dll. Se Exchange Server Analyzer può leggere la chiave Version, il file Exchmem.dll è presente nella cartella System32.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se il valore della stringa comprende "Version 6", il computer esegue Exchange 2000 Server o Exchange Server 2003.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • Exchmem.dll è presente nella cartella System32.

  • Il computer esegue Exchange 2000 Server o Exchange Server 2003.

In genere, nei server di Exchange è presente una sola copia di Exchmem.dll. Tuttavia, talvolta viene aggiunto un secondo file Exchmem.dll file mediante un aggiornamento sul posto da precedenti versioni del prodotto. La presenza di due versioni del file può causare errori durante l'installazione di Service Pack. Per evitare problemi, è consigliabile rinominare o rimuovere il file Exchmem.dll nella cartella \Windows\System32.

Per rimuovere o rinominare una seconda versione di Exchmem.dll

  1. Interrompere tutti i servizi di Exchange.

  2. Rinominare o rimuovere il file Exchmem.dll nella cartella \Windows\System32.

  3. Riavviare tutti i servizi di Exchange.


Trovato errore irreversibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool tenta di accedere a diverse risorse specifiche per eseguirne l'analisi:

  • Servizio directory di Microsoft Active Directory®

  • Centro di verifica messaggi di Exchange Server

  • Registro di sistema di Microsoft Windows®

  • Microsoft WMI (Strumentazione gestione Windows®)

  • Metabase IIS (Internet Information Services)

Se Exchange Server Analyzer non può accedere a una o più delle risorse richieste, verrà visualizzato un messaggio di errore.

Tale messaggio di errore indica che non è possibile eseguire un'ulteriore analisi poiché non è possibile accedere a una o più di tali risorse di base.

Per risolvere il problema, analizzare le indicazioni specifiche dell'errore e i collegamenti forniti da Exchange Server Analyzer.


Funzione FCL non abilitata sul server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-20

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende Version 5.5, il computer esegue Microsoft Exchange Server versione 5.5. Se la stringa comprende Version 6.0, il computer esegue Microsoft Exchange 2000 Server. Se la stringa comprende Version 6.5, il computer esegue Microsoft Exchange Server 2003.

Microsoft Exchange Server Analyzer Tool esegue anche una query per verificare la presenza della sottochiave Disable Call Tracing nella seguente voce, al fine di determinare se la funzione di registrazione delle chiamate di funzione (FCL, Function Call Logging) di Microsoft Exchange è abilitata sul server di Exchange:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server è in grado di analizzare le prestazioni delle chiamate interne eseguite dal servizio Archivio informazioni di Microsoft Exchange (Store.exe). È possibile utilizzare la funzione FCL per isolare il componente e la chiamata di funzione alla base del problema di prestazioni.

La funzione FCL del servizio Archivio informazioni di Microsoft Exchange tiene traccia delle chiamate ai seguenti componenti:

  • LSASS (Lsass.exe)

  • DSAccess

  • Extensible Storage Engine (ESE)

  • IMAIL

  • Virusscan

La funzione FCL è una registrazione a sovraccarico ridotto che acquisisce i dati relativi a problemi, quali problemi di arresto di Exchange Server o situazioni in cui il servizio Archivio informazioni di Exchange (Store.exe) evidenzia un calo di prestazioni oppure non risponde.

La funzione FCL registra automaticamente i dati relativi alle chiamate di funzione non appena viene abilitata. Non sono necessari l'intervento dell'utente né una configurazione specifica, quale l'acquisizione di un file di immagine utente del server di produzione o l'uso di un debugger.

La funzione FCL è abilitata per impostazione predefinita su Microsoft Exchange Server 2003, mentre deve essere appositamente abilitata su Microsoft Exchange 2000 Server.

Se si verificano le seguenti condizioni, Microsoft Exchange Server Analyzer Tool visualizzerà un messaggio di configurazione ottimale:

  • Il server di Microsoft Exchange 2000 Server e la sottochiave Disable Call Tracing non sono presenti, oppure la sottochiave Disable Call Tracing è presente ma contiene un valore diverso da 0.

  • Il server che esegue Microsoft Exchange Server 2003 e la sottochiave Disable Call Tracing sono presenti e la sottochiave contiene un valore diverso da 0.

Il messaggio di configurazione ottimale indica che la funzione FCL è disabilitata.

Si consiglia di abilitare la funzione FCL su tutti i server di Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del registro di sistema. Prima di modificare il registro di sistema, assicurarsi di conoscere le operazioni per ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, vedere l'argomento della Guida relativo al ripristino del registro di sistema in Regedit.exe o Regedt32.exe.
Per abilitare la funzione di registrazione delle chiamate di funzione su Microsoft Exchange 2000 Server

  1. Aprire un editor del registro di sistema, quale Regedit.exe o Regedt32.exe.

  2. Andare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

  3. Nel riquadro destro fare doppio clic su Disable Call Tracing. Se la sottochiave Disable Call Tracing non è presente, crearla come nuovo valore DWORD.

  4. Configurare la sottochiave Disable Call Tracing impostando il valore a 0.
Nota:
Per impostazione predefinita, la funzione FCL è disattivata su Microsoft Exchange 2000 Server e il valore è impostato a 1.
  1. Chiudere l'editor del registro di sistema.

  2. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

 Per abilitare la funzione di registrazione delle chiamate di funzione su Microsoft Exchange Server 2003

  1. Aprire un editor del registro di sistema, quale Regedit.exe o Regedt32.exe.

  2. Andare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing.

  3. Nel riquadro destro fare doppio clic su Disable Call Tracing.

  4. Configurare la sottochiave Disable Call Tracing impostando il valore a 0.
Nota:
Per impostazione predefinita, la funzione FCL è attivata su Microsoft Exchange Server 2003 e la sottochiave Disable Call Tracing è stata creata impostando un valore diverso da 0 per disattivarla.
  1. Chiudere l'editor del registro di sistema.

  2. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al registro di sistema e per ulteriori informazioni su questa procedura, vedere l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Le PTE (Page Table Entry) sono al livello di soglia critico
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_PerfOS_Memory per determinare il valore corrente dell'oggetto FreeSystemPageTableEntries. Se il valore per FreeSystemPageTableEntries è inferiore o uguale a 5000, verrà visualizzato un messaggio di errore.

Microsoft Windows Server™ 2003 e Windows 2000 Server possono indirizzare direttamente fino a 4 GB di spazio di indirizzi della memoria, indipendentemente dalla quantità di RAM fisica installata. Dal punto di vista del processo, ciascun elemento dell'indirizzo virtuale fa riferimento concettualmente a un byte di memoria fisica. È compito del Gestore della memoria virtuale (VMM, Virtual Memory Manager), insieme all'unità di gestione della memoria (MMU, Memory Manager Unit) del processore, tradurre o eseguire il mapping di ciascun indirizzo virtuale a un indirizzo fisico corrispondente. VMM esegue il mapping dividendo la RAM in pagine di memoria di dimensioni definite, creando PTE (Page Table Entry) di sistema per archiviare le informazioni relative a tali pagine ed eseguirne il mapping. Le PTE di sistema sono piccoli buffer di memoria in modalità kernel che vengono utilizzati per comunicare con il sottosistema di I/O del disco e con la rete. Ciascuna PTE rappresenta una pagina di memoria e contiene informazioni necessarie al VMM per individuare una pagina.

In un sistema x86 che utilizza una dimensione di pagina pari a 4 KB, il numero massimo di PTE necessarie per eseguire il mapping di 2 GB di spazio di indirizzi è 524.288 (2 GB/4 KB). In un sistema simile che utilizza l'opzione /3GB, il numero di PTE necessarie per il mapping di 3 GB di spazio di indirizzi è 786.432 (3 GB/4 KB). In un sistema tipico, questo spazio viene utilizzato nel seguente modo:

  • Un massimo di 50.000 PTE (circa 195 MB di spazio di indirizzi) sono riservate all'utilizzo generale.

  • Le rimanenti vengono utilizzate per eseguire il mapping della cache di sistema, dell'iperspazio, della riserva di paging, della riserva non di paging, dell'area di dettagli arresto anomalo e così via.

La dimensione del pool delle PTE viene determinata automaticamente all'avvio del sistema in base alla quantità di memoria fisica nel sistema. Questo pool è suddiviso tra riserva di paging e riserva non di paging. Anche quest'ultima aumenta in base alla quantità di memoria fisica nel sistema.

Il pool delle PTE di sistema può essere sottoposto a un notevole utilizzo e a una considerevole frammentazione. In questo modo possono verificarsi situazioni in cui non è possibile caricare un driver. Inoltre, se la riserva delle PTE di sistema è completamente esaurita, si verificherà una riduzione del livello delle prestazioni di altre parti del sistema, causando anche la mancata creazione di thread, blocchi e potenziali arresti anomali del sistema

Un computer Exchange Server che funziona correttamente dovrebbe avere almeno 8.000 PTE di sistema disponibili in qualsiasi momento. Se il numero delle PTE di sistema disponibili scende al di sotto di 8.000 ma rimane al di sopra di 5.000, verrà visualizzato l'avviso descritto in Il numero di PTE (Page Table Entry) libere ha raggiunto la soglia di avviso. Quando il numero delle PTE di sistema disponibili scende al di sotto di 5.000, verrà visualizzato questo messaggio di errore.

Per risolvere il problema, è possibile utilizzare la procedura descritta di seguito per configurare correttamente il valore SystemPages del Registro di sistema per il sistema operativo del computer che esegue Exchange Server. Quando si esegue Exchange Server 2003 Service Pack 1 (SP1) in Windows Server 2003 con almeno 1 GB di RAM, è consigliabile impostare la chiave SystemPages del Registro di sistema su zero. Questa indicazione è in contrasto con quella valida per Windows 2000 Server, in cui la chiave SystemPages del Registro di sistema deve essere impostata sul valore 31000 (decimale).

Dopo aver eseguito la procedura descritta di seguito, è preferibile controllare il numero delle PTE di sistema libere. È possibile eseguire questa operazione monitorando i contatori di prestazioni Memoria | PTE libere di sistema con Monitor di sistema di Windows (noto anche come Performance Monitor). Se, dopo aver apportato al Registro di sistema le modifiche, il numero di PTE di sistema libere rimane insufficiente, verificare quanto segue per assicurarsi che il computer Exchange Server sia configurato correttamente:

  • Driver Un driver che non funziona correttamente rappresenta una delle cause più comuni di PTE di sistema insufficienti. Verificare con il produttore dell'hardware che i driver utilizzati per l'hardware siano aggiornati. Esiste inoltre la possibilità di effettuare un downgrade a un driver di livello inferiore. Ad esempio, i computer che eseguono applicazioni basate su server come Exchange Server in genere non richiedono i più avanzati driver video con tutte le funzioni. Spesso è sufficiente un driver di livello inferiore. Il passaggio da un driver video avanzato a uno di livello inferiore dovrebbe aumentare il numero delle PTE di sistema libere.

  • Configurazione di sistema Se il sistema Windows Server 2003 dispone di almeno 1 GB di memoria fisica installata, è consigliabile verificare che il relativo file Boot.ini sia correttamente configurato con le opzioni /3GB e /USERVA=3030, come illustrato negli articoli della Microsoft Knowledge Base 823440, "Utilizzo obbligatorio dell'opzione /3GB nell'installazione di Exchange Server 2003 in un sistema basato su Windows Server 2003", disponibile all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440, e 810371, "XADM: Utilizzo dell'opzione /Userva in server di Exchange basati su Windows Server 2003", disponibile all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • Registri eventi Controllare la presenza di eventuali errori o avvisi nel registro eventi dell'applicazione sul server di Exchange, in particolare eventi 9582 (errori e avvisi), 9665 (avviso) e 12880 (errore) MSExchangeIS. La presenza dell'evento 9665 potrebbe indicare anche che la chiave SystemPages non è configurata per prestazioni ottimali. Per ulteriori informazioni su tali eventi, consultare l'articolo 325044 della Microsoft Knowledge Base "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per correggere questo errore su un computer che esegue Windows 2000 Server

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore digitare il valore 31000 decimale (31000 è la rappresentazione decimale di 7918 esadecimale. In Regedit.exe i valori predefiniti sono esadecimali), quindi fare clic su OK.

  5. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Per correggere questo errore su un computer che esegue la versione originale di Windows Server 2003

  • Per ulteriori informazioni su come determinare il numero effettivo delle PTE libere di sistema, consultare l'articolo 894067 della Microsoft Knowledge Base "Lo strumento Prestazioni non consente di visualizzare correttamente le PTE libere di sistema in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067.

Per correggere questo errore su un computer che esegue Windows Server 2003 SP1

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore digitare 0 e fare clic su OK.

  5. Chiudere l'editor del Registro di sistema.

  6. Fare clic con il pulsante destro del mouse su Risorse del computer, quindi scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  7. Fare clic su Avanzate.

  8. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  9. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  10. Controllare la sezione [Operating Systems].

    1. Se è presente l'opzione /3GB ma non è presente l'opzione /USERVA=3030, aggiungerla alla riga di avvio in modo tale che sia configurata come /3GB /USERVA=3030.

    2. Se le opzioni /3GB /USERVA=3030 sono già configurate, modificare il valore dell'opzione /USERVA impostandolo su /USERVA=2970.

  11. Salvare le modifiche e chiudere Blocco note.

  12. Per rendere effettive le modifiche, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'ottimizzazione della memoria di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 894067, "Lo strumento Prestazioni non consente di visualizzare correttamente le PTE libere di sistema in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067.

  • 325044, "HOW TO: Risoluzione del problema della frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 823150, "Raccolta dei dati per risolvere i problemi di memoria virtuale in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.


Il numero di PTE (Page Table Entry) libere ha raggiunto la soglia di avviso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_PerfOS_Memory per determinare il valore corrente dell'oggetto FreeSystemPageTableEntries. Se il valore di FreeSystemPageTableEntries è maggiore di 5000 ma minore o uguale a 8000, verrà visualizzato un avviso.

Microsoft Windows Server™ 2003 e Windows 2000 Server possono indirizzare direttamente fino a 4 GB di spazio di indirizzi della memoria, indipendentemente dalla quantità di RAM fisica installata. Dal punto di vista del processo, ciascun elemento dell'indirizzo virtuale fa riferimento concettualmente a un byte di memoria fisica. È compito del Gestore della memoria virtuale (VMM, Virtual Memory Manager) insieme all'unità di gestione della memoria (MMU, Memory Manager Unit) del processore tradurre o eseguire il mapping di ciascun indirizzo virtuale a un indirizzo fisico corrispondente. VMM esegue il mapping dividendo la RAM in pagine di memoria di dimensioni definite, creando PTE (Page Table Entry) di sistema per archiviare le informazioni relative a tali pagine ed eseguirne il mapping. Le PTE di sistema sono piccoli buffer di memoria in modalità kernel che vengono utilizzati per comunicare con il sottosistema di I/O del disco e con la rete. Ciascuna PTE rappresenta una pagina di memoria e contiene informazioni necessarie al VMM per individuare una pagina.

In un sistema x86 che utilizza una dimensione di pagina pari a 4 KB, il numero massimo di PTE necessarie per eseguire il mapping di 2 GB di spazio di indirizzi è 524.288 (2 GB/4 KB). In un sistema simile che utilizza l'opzione /3GB, il numero di PTE necessarie per il mapping di 3 GB di spazio di indirizzi è 786.432 (3 GB/4 KB). In un sistema tipico, questo spazio viene utilizzato nel seguente modo:

  • Un massimo di 50.000 PTE (circa 195 MB di spazio di indirizzi) sono riservate all'utilizzo generale.

  • Le rimanenti vengono utilizzate per eseguire il mapping della cache di sistema, dell'iperspazio, della riserva di paging, della riserva non di paging, dell'area di dettagli arresto anomalo e così via.

La dimensione del pool delle PTE viene determinata automaticamente all'avvio del sistema in base alla quantità di memoria fisica nel sistema. Questo pool è suddiviso tra riserva di paging e riserva non di paging. Anche quest'ultima aumenta in base alla quantità di memoria fisica nel sistema.

Il pool delle PTE di sistema può essere sottoposto a un notevole utilizzo e a una considerevole frammentazione. In questo modo possono verificarsi situazioni in cui non è possibile caricare un driver. Inoltre, se il pool delle PTE di sistema è completamente esaurito, si verificherà una riduzione del livello delle prestazioni di altre parti del sistema, causando anche la mancata creazione di thread, blocchi e potenziali arresti anomali del sistema.

Un computer Exchange Server che funziona correttamente dovrebbe avere almeno 8.000 PTE di sistema disponibili in qualsiasi momento. Se il numero delle PTE di sistema libere scende al di sotto di 5.000, verrà visualizzato l'errore descritto in Le PTE (Page Table Entry) sono al livello di soglia critico. Quando il numero delle PTE di sistema libere scende al di sotto di 8.000 ma rimane al di sopra di 5.000, verrà visualizzato questo avviso.

Per risolvere il problema, è possibile utilizzare la procedura descritta di seguito per configurare correttamente il valore SystemPages del Registro di sistema per il sistema operativo del computer che esegue Exchange Server. Quando si esegue Exchange Server 2003 Service Pack 1 (SP1) in Windows Server 2003 con almeno 1 GB di RAM, è consigliabile impostare la chiave SystemPages del Registro di sistema su zero. Questa indicazione è in contrasto con quella valida per Windows 2000 Server, in cui la chiave SystemPages del Registro di sistema deve essere impostata sul valore 31.000 (decimale).

Dopo aver eseguito la procedura descritta di seguito, è consigliabile controllare il numero di PTE di sistema libere. È possibile eseguire questa operazione monitorando i contatori di prestazioni Memoria | PTE libere di sistema con Monitor di sistema di Windows (noto anche come Performance Monitor). Se, dopo aver apportato al Registro di sistema le modifiche descritte di seguito, il numero di PTE di sistema libere rimane insufficiente, verificare quanto segue per assicurarsi che il computer Exchange Server sia configurato correttamente:

  • Driver Un driver che non funziona correttamente rappresenta una delle cause più comuni di PTE di sistema insufficienti. Contattare il produttore hardware per assicurarsi che i driver utilizzati per l'hardware siano aggiornati. Esiste inoltre la possibilità di effettuare un downgrade a un driver di livello inferiore. Ad esempio, i computer che eseguono applicazioni basate su server come Exchange Server in genere non richiedono i più avanzati driver video con tutte le funzioni. Spesso è sufficiente un driver di livello inferiore. Il passaggio da un driver video avanzato a uno di livello inferiore dovrebbe aumentare il numero delle PTE di sistema libere.

  • Configurazione di sistema Se il sistema Windows Server 2003 dispone di almeno 1 GB di memoria fisica installata, è consigliabile verificare che il relativo file Boot.ini sia configurato correttamente con le opzioni /3GB e /USERVA=3030 come illustrato negli articoli della Microsoft Knowledge Base 823440, "Utilizzo obbligatorio dell'opzione /3GB nell'installazione di Exchange Server 2003 in un sistema basato su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440 e 810371, "XADM: Utilizzo dell'opzione /Userva in server di Exchange basati su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • Registri eventi Controllare la presenza di eventuali errori o avvisi nel registro eventi dell'applicazione sul server di Exchange, in particolare eventi 9582 (errori e avvisi), 9665 (avviso) e 12880 (errore) MSExchangeIS. La presenza dell'evento 9665 potrebbe indicare anche che la chiave SystemPages non è configurata per prestazioni ottimali. Per ulteriori informazioni su tali eventi, consultare l'articolo 324044 della Microsoft Knowledge Base "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per correggere questo errore su un computer che esegue Windows Server 2000

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore digitare il valore 31000 decimale (31000 è la rappresentazione decimale di 7918 esadecimale. In Regedit.exe i valori predefiniti sono esadecimali), quindi fare clic su OK.

  5. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Per correggere questo errore su un computer che esegue la versione originale di Windows Server 2003

  • Per ulteriori informazioni su come determinare il numero effettivo delle PTE libere di sistema, consultare l'articolo 894067 della Microsoft Knowledge Base "Lo strumento Prestazioni non consente di visualizzare correttamente le PTE libere di sistema in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067.

Per correggere questo errore su un computer che esegue Windows Server 2003 SP1

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore digitare 0 e fare clic su OK.

  5. Chiudere l'editor del Registro di sistema.

  6. Fare clic con il pulsante destro del mouse su Risorse del computer, quindi scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  7. Fare clic su Avanzate.

  8. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  9. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  10. Controllare la sezione [Operating Systems].

    1. Se è presente l'opzione /3GB ma non è presente l'opzione /USERVA=3030, aggiungerla alla riga di avvio in modo tale che sia configurata come /3GB /USERVA=3030.

    2. Se le opzioni /3GB /USERVA=3030 sono già configurate, modificare il valore dell'opzione /USERVA impostandolo su /USERVA=2970.

  11. Salvare le modifiche e chiudere Blocco note.

  12. Per rendere effettive le modifiche, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'ottimizzazione della memoria di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 894067, "Lo strumento Prestazioni non consente di visualizzare correttamente le PTE libere di sistema in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 823150, "Raccolta dei dati per risolvere i problemi di memoria virtuale in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823150.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.


Sul server front-end è in esecuzione il Servizio di replica siti
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nell'oggetto Microsoft WMI (Strumentazione gestione Windows®) di Exchange Server (classe Exchange_Server) per determinare il valore di IsFrontEndServer per il server. Se il valore è True, il server di Exchange funziona come server front-end. Exchange Server Analyzer esegue inoltre una query nell'oggetto WMI MSExchangeSRS (classe Win32_Service) per stabilire il valore della proprietà Started per tale oggetto. Se il valore è True, il Servizio di replica siti è in esecuzione in questo server.

Se il server di Exchange viene designato come server front-end e contiene un'istanza del Servizio di replica siti in esecuzione, verrà visualizzato un avviso.

Il Servizio di replica siti viene utilizzato in Exchange se la topologia include server che eseguono Exchange Server versione 5.5 ed Exchange 2000 Server o Exchange Server 2003. Grazie a questo servizio, le versioni successive di Exchange possono replicare le informazioni di configurazione del server sui server di Exchange Server 5.5 in una forma compatibile con la directory di Exchange Server 5.5 e possono inoltre elaborare correttamente le informazioni di configurazione replicate dalla directory di Exchange Server 5.5 in modo che possano essere archiviate nel servizio directory di Active Directory®. Se la topologia utilizzata è configurata per i server front-end e back-end, il Servizio di replica siti deve essere eseguito solo su server back-end. A partire da Exchange 2000 Server Service Pack 2, il Servizio di replica siti non funziona correttamente sui server front-end e possono verificarsi dei problemi.

Per risolvere questo problema, convertire il server front-end in un server back-end e configurare un nuovo server front-end. Non è consigliabile tentare di rimuovere il Servizio di replica siti dal server.

Per risolvere il problema

  1. Configurare un nuovo server front-end.

  2. Nel server front-end in cui si verifica il problema, in Gestore di sistema di Exchange, fare clic con il pulsante destro del mouse sul server stesso in Server, quindi fare clic su Proprietà.

  3. Deselezionare la casella di controllo Questo è un server front-end.

Per ulteriori informazioni sul server front-end e sul Servizio di replica siti, consultare l'articolo 313646 della Microsoft Knowledge Base "Disattivazione dei servizi sui server front-end dopo l'aggiornamento di Exchange 2000 Server SP2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=313646.


File GAPI32.DLL mancante dalla cartella bin
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File GAPI32.DLL mancante dalla cartella system32
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi né reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


GlobalFlag impostato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare il valore della voce GlobalFlag:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Se Exchange Server Analyzer trova il valore di GlobalFlag presente e configurato con qualsiasi valore diverso da 0 o null, verrà visualizzato un avviso.

L'impostazione del valore del Registro di sistema GlobalFlag è una maschera di bit che determina quali opzioni di debug sono state attivate per un particolare processo. In questo caso, Exchange Server Analyzer esegue una ricerca per verificare se sono state abilitate eventuali opzioni di debug per una serie di componenti Exchange:

  • STORE.EXE (il processo dell'archivio informazioni)

  • MAD.EXE (il processo di supervisore sistema)

  • INETINFO.EXE (il processo di Amministrazione IIS e il processo padre)

  • EMSMTA.EXE (il processo dell'agente di trasferimento messaggi)

A meno che non si esegua il debug o l'analisi di un problema con l'aiuto del Servizio Supporto Tecnico Clienti Microsoft, è consigliabile impostare sempre il valore GlobalFlag su 0 oppure eliminarlo completamente, dal momento che le due operazioni producono lo stesso effetto.

Per impostazione predefinita il valore PageHeapFlags del Registro di sistema non è presente e deve essere aggiunto manualmente se è necessario il debug del processo STORE.EXE (o qualsiasi altro processo). È possibile utilizzare lo strumento Gflags fornito con gli Strumenti di supporto di Microsoft® Windows Server™ 2003 che si trovano nella cartella \Support del CD di Windows. In alternativa, è possibile impostare manualmente il valore su 0 oppure eliminare completamente il valore GlobalFlag utilizzando un editor del Registro di sistema. Entrambe le procedure sono descritte in questo articolo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema utilizzando Gflags

  1. Fare clic su Start, Esegui e, nel campo Apri, eseguire GFlags. Verrà visualizzata l'interfaccia utente di Global Flags.

  2. Nel campo Nome del file immagine digitare STORE.EXE.

  3. Selezionare Image File Options.

  4. Deselezionare tutte le caselle di controllo, quindi fare clic su Applica.

  5. Ripetere i passaggi da 2 a 4 per ciascuno dei processi Exchange elencati sopra.

  6. Per rendere effettiva la modifica, fare clic su OK per uscire dallo strumento GFlags e riavviare i servizi interessati.

Per risolvere il problema utilizzando un editor del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Eliminare il valore denominato GlobalFlag.

  4. Ripetere i passaggi 2 e 3 per ciascuno dei processi Exchange elencati sopra.

  5. Per rendere effettive le modifiche, uscire dall'editor del Registro di sistema e riavviare i servizi interessati.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Numero elevato di errori dell'aggiornamento ACL
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeIS_MSExchangeIS per determinare il valore attuale della chiave ACLUpgradefailures. La chiave ACLUpgradefailures rappresenta il contatore di prestazioni ACL Upgrade: failures dell'oggetto prestazioni MSExchangeIS.

Se Exchange Server Analyzer rileva che il valore della chiave ACLUpgradefailures è maggiore di 500, verrà visualizzato un avviso.

L'avviso indica che il server di Exchange ha rilevato molti errori nell'aggiornamento dell'elenco di controllo di accesso (ACL). Un numero eccessivo di errori nell'aggiornamento dell'ACL può provocare gravi problemi di prestazioni, trai quali interruzioni casuali del processo dell'Archivio informazioni (store.exe).

Gli errori nell'aggiornamento dell'ACL può verificarsi per molti motivi e quando si verificano le seguenti condizioni:

  • In un'organizzazione di Exchange a modalità mista, il regolatore della coerenza di Exchange Server 5.5 non è stato avviato prima dell'implementazione del server ADC. Il regolatore della coerenza di Exchange Server 5.5 rimuove gli ACL isolati.

  • La replica di Active Directoyry non funziona correttamente.

  • La replica di ADC non replica correttamente gli account da Exchange Server 5.5 ad Active Directory.

  • Migrazione di account utente non corretta.

Per risolvere il problema

  1. Rivedere l'articolo 812963 della Knowledge Base, "Utilizzo della chiave Ignore Zombie Users del Registro di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963.

  2. Dopo aver compreso le implicazioni dell'utilizzo della chiave Ignore Zombie Users, aggiungerla a proprio rischio.

  3. Eseguire Exchange Server Analyzer o monitorare il contatore di prestazioni ACL Upgrade: failures per individuare eventuali errori di aggiornamento ACL.


Utente Exmon molto attivo
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento ExMon (Exchange Server User Monitor) per determinare se la causa di una percentuale sproporzionatamente alta del carico del server corrente sia da individuare in un utente o un processo (o un gruppo di utenti o di processi).

Gli scenari valutati da ExMon sono diversi:

  • Restrizioni client

  • Operazioni RPC (Remote Procedure Call) di massa

  • Operazioni di sincronizzazione RPC

  • Numero elevato di operazioni client in linea

  • Operazioni di visualizzazione degli utenti

Nelle sezioni seguenti vengono forniti dettagli su tutti gli scenari riportati e consigliate le operazioni più adeguate a ciascuno di essi.

Restrizioni client

In questo scenario, i dati RPC di ExMon indicano che sono le restrizioni dei computer client a causare l'elevato carico del server. Nel contesto MAPI, una restrizione fa riferimento all'operazione MAPI denominata Restrict. Questa operazione viene utilizzata per selezionare gli elementi che corrispondono a particolari criteri. L'operazione Restrict fa parte del processo per richiedere a Exchange di creare una visualizzazione su una cartella o una serie di cartelle, ovvero, in pratica, una tabella di database con criteri associati. Se la visualizzazione sulla cartella o la serie di cartelle ha già una restrizione corrispondente, per soddisfare la richiesta dell'utente verrà utilizzata la visualizzazione esistente. Se la visualizzazione non ha una restrizione corrispondente, verrà creata una nuova visualizzazione. Per creare una nuova visualizzazione occorrono più risorse di quante ne servano per utilizzare una visualizzazione esistente.

Se vengono spostate molte cassette postali, le restrizioni client consumeranno più risorse per un breve periodo. L'operazione move-mailbox costringe il server a ricreare indici sulle cartelle. Quindi, quando i client visualizzano per la prima volta cartelle su un nuovo server, devono essere ricreate nuovamente tutte le restrizioni e, di conseguenza, le prestazioni possono subire un peggioramento. Se non sono state spostate cassette postali di recente, verificare che:

  • Non sia installata un'altra applicazione MAPI sui computer client. I componenti aggiuntivi di Microsoft Office Outlook® e le altre applicazioni MAPI causano spesso la creazione di troppe restrizioni.

  • Le dimensioni delle cassette postali siano adeguate e siano stati appropriatamente impostati limiti nell'organizzazione.

Per ulteriori informazioni sulla dimensione adeguata delle cassette postali e il numero appropriato di elementi in esse contenuti, consultare il blog del team di Microsoft Exchange "Recommended Mailbox Size Limits" all'indirizzo http://go.microsoft.com/fwlink/?linkid=55097 (informazioni in lingua inglese).

Operazioni RPC di massa

Tra gli esempi di operazioni RPC di massa sono inclusi lo spostamento, l'eliminazione o l'impostazione di proprietà (ovvero il flag di lettura) su centinaia o migliaia di elementi in una sola operazione. Questo tipo di operazioni può causare un peggioramento delle prestazioni del server per un breve intervallo di tempo. Se le operazioni RPC di massa vengono eseguite di frequente e si verifica un collo di bottiglia del server a livello del disco o del processore, le prestazioni di Outlook per gli altri utenti dello stesso server subiranno un peggioramento.

Per risolvere il problema

  1. Verificare che siano impostati limiti per le cassette postali.

  2. Consigliare agli utenti di archiviare gli elementi in file con estensione pst.

    Nota:
    Come norma generale, è sempre consigliabile che le cartelle utilizzate di frequente contengano meno di 5.000 elementi.

Operazioni di sincronizzazione RPC

Un numero elevato di operazioni di sincronizzazione indica che molti utenti stanno sincronizzando elementi. Di conseguenza, il carico del server aumenta.

Per risolvere il problema

  • Assicurarsi di aver scalato i server Exchange basandosi sul numero di computer client che eseguono Outlook in modalità cache di Exchange. Per ulteriori informazioni, consultare Scenari di distribuzione di RPC su HTTP in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47577.

  • Il rallentamento delle richieste client della modalità cache di Exchange può aiutare a impedire che un numero elevato di operazioni di sincronizzazione RPC diventi un problema per le prestazioni. Per ulteriori informazioni, consultare l'articolo 818484 della Microsoft Knowledge Base "Valori del Registro di sistema e contatori utilizzabili per configurare e monitorare la sincronizzazione dei client di Outlook" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=818484.

Numero elevato di operazioni client in linea

Talvolta, in Exchange può verificarsi un picco inconsueto di problemi di prestazioni causati da un carico elevato distribuito tra gli utenti. Tale situazione può essere provocata da una pianificazione non adeguata alla crescita di un'organizzazione. Se per scalare l'organizzazione sono state seguite le procedure consigliate da Microsoft, ma le prestazioni continuano a essere peggiorate dalle numerose operazioni in linea dei client, è possibile che gli utenti stiano eseguendo applicazioni MAPI o plug-in di Outlook di terze parti.

Operazioni di visualizzazione degli utenti

I dati RPC di ExMon indicano che un utente sta creando nuove visualizzazioni, causando un carico elevato sul server. In questo scenario, un solo utente è responsabile di una significativa percentuale di utilizzo della CPU RPC.

Per risolvere il problema, considerare i seguenti scenari:

  • L'utente potrebbe stare eseguendo operazioni su una cartella che contiene molti elementi. Per risolvere il problema, incoraggiare gli utenti a ridurre il numero di elementi presenti in una sola cartella. Come norma generale, è sempre consigliabile che le cartelle contengano meno di 2.000 elementi.

  • L'utente potrebbe stare eseguendo un'applicazione scritta male che causa un carico eccessivo. Per risolvere il problema, rimuovere l'applicazione.

Ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare Exchange Server 2003 Performance and Scalability Guide all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulla dimensione adeguata delle cassette postali e il numero appropriato di elementi in esse contenuti, consultare il blog del team di Microsoft Exchange "Recommended Mailbox Size Limits" all'indirizzo http://go.microsoft.com/fwlink/?linkid=55097 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle restrizioni delle cassette postali, consultare il blog del team di Microsoft Exchange "Putting the Restrictions on Restrictions" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=55098 (informazioni in lingua inglese).

  • Per ulteriori informazioni su ExMon, visitare il sito Web da cui è possibile scaricare ExMon all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54983 (informazioni in lingua inglese).


IIS crea processi a 32 bit su un computer a 64 bit
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-05-03

Lo strumento Microsoft Exchange Server Analyzer esegue una query sul metabase di Internet Information Services (IIS) alla ricerca del valore della proprietà del metabase w3svc/AppPools/Enable32BitAppOnWin64 su tutti i server Windows Server 2003 Service Pack 1 (SP1) a 64 bit che eseguono Exchange Server 2007 per determinare se IIS è configurato per creare processi di lavoro a 32 bit.

Il valore 1 (vero) indica che IIS è configurato per creare processi di lavoro a 32 bit. Il valore 0 (falso) indica che IIS è configurato per creare processi di lavoro a 64 bit.

Se Exchange Analyzer determina che il valore della proprietà del metabase w3svc/AppPools/Enable32BitAppOnWin64 è impostato su 1 (vero), viene visualizzato un errore. L'errore indica che IIS è configurato per creare processi di lavoro a 32 bit su un server Windows a 64 bit che esegue Exchange 2007. Questa configurazione impedirà il corretto funzionamento delle directory virtuali di Exchange 2007.

Per risolvere l'errore, configurare IIS in modo da creare processi di lavoro a 64 bit sul server Windows Server 2003 (SP1) a 64 bit che esegue Exchange 2007.

Per passare alla modalità a 64 bit

  1. Aprire un prompt dei comandi.

  2. Digitare quanto segue:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Premere Invio

Per ulteriori informazioni sull'esecuzione dei processi di lavoro a 32 bit di IIS 6.0 su un server Windows Server 2003 SP1 a 64 bit, vedere l'articolo 895976 della Microsoft Knowledge Base "Windows Server 2003 SP1 abilita la compatibilità WOW64 per le applicazioni Web a 32 bit in IIS 6.0" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=895976.


Miglioramento della memoria del kernel
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool sottopone a verifica i livelli della memoria di sistema per controllare che rientrino in un intervallo accettabile. Se Exchange Server Analyzer rileva che uno dei contatori della memoria kernel di Perfmon (Performance Monitor) è al di sotto dei livelli appropriati, verrà visualizzato un messaggio di risoluzione dei problemi.

La memoria del kernel di Microsoft Windows® è composta da numerose strutture, tra cui memoria di riserva di paging e non di paging e PTE (Page Table Entry) di sistema. Tali strutture vengono utilizzate dal sistema operativo per fornire un ambiente valido per l'esecuzione di applicazioni come Exchange. Per garantire sempre un corretto funzionamento di Exchange, monitorare la memoria del kernel.

L'ottimizzazione della memoria del kernel può rivelarsi un'operazione complessa. Per informazioni dettagliate sull'utilizzo della memoria del kernel e sulla risoluzione di eventuali problemi correlati, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese). Se si desidera rendere disponibili più risorse server, controllare il carico delle cassette postali degli utenti sul server. Valutare quindi l'opportunità di spostare parte delle cassette postali degli utenti su un altro server onde ridurre il carico del server e tentare di risolvere il problema. Per ulteriori informazioni, consultare Spostare le cassette postali degli utenti su un server diverso.

Ulteriori informazioni

Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sullo spostamento di cassette postali degli utenti ai fini di ridurre il carico del server, consultare Spostare le cassette postali degli utenti su un server diverso


Aumentare la memoria utente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-28

Microsoft® Exchange Server Analyzer Tool ha determinato che i contatori di prestazioni della memoria utente hanno superato la soglia consigliabile per un corretto funzionamento del server Exchange. Exchange Server Analyzer esegue una query nei contatori di prestazioni MByte disponibili e Pagine di memoria/sec nell'oggetto prestazioni Memoria. Un livello della memoria del server basso o un'elevata attività di paging indicano un collo di bottiglia della memoria.

Il contatore di prestazioni MByte disponibili mostra la quantità di memoria fisica (in MB) immediatamente disponibile per essere allocata a un processo o per essere utilizzata dal sistema. La quantità di memoria disponibile equivale alla memoria complessiva assegnata alle pagine nella cache, libere e azzerate.

Il contatore di prestazioni Pagine di memoria/sec indica la velocità di lettura o di scrittura delle pagine da o su un disco per risolvere gli errori di pagina di memoria hardware. Man mano che il server utilizza memoria e la memoria disponibile si riduce, il sistema operativo inizia a tagliare il working set del processo e a utilizzare più intensamente il file di paging. L'utilizzo del file di paging incide sulle prestazioni globali poiché le operazioni su disco durano di più di quelle di memoria. Questo contatore è l'indicatore primario dei tipi di errori che causano ritardi in tutto il sistema e include le pagine recuperate per soddisfare gli errori di pagina nella cache del file system. Queste pagine vengono normalmente richieste dalle applicazioni. Il valore del contatore in questione deve essere sempre inferiore a 1.000.

Se Exchange Server Analyzer rileva che il contatore di prestazioni MByte disponibili indica meno di 50 MB di memoria disponibile e che la velocità di lettura o scrittura delle pagine di memoria sul disco supera le 1.000 pagine al secondo, verrà visualizzato un messaggio di errore.

Nell'elenco seguente viene descritto in che modo è possibile migliorare le prestazioni della memoria dello spazio utente.

Per risolvere il problema

  1. Utilizzare Microsoft Exchange Server Best Practices Analyzer Tool, disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705, per verificare che le impostazioni di memoria del server siano configurate correttamente.

  2. Rimuovere il software superfluo. Per rendere disponibili più risorse per Exchange, rimuovere eventuali strumenti software di terze parti che eseguono funzioni di monitoraggio o qualsiasi tipo di servizio non essenziale. Lo snap-in Performance (Perfmon.msc) consente di verificare la quantità di memoria utilizzata dalle applicazioni.

  3. Eseguire le attività di manutenzione del server nelle ore non di punta. Per l'esecuzione di strumenti di manutenzione, quali Eseutil, o attività di manutenzione, quali la gestione delle cassette postali, nelle ore di punta viene infatti utilizzata memoria che verrebbe altrimenti utilizzata da Exchange. È quindi consigliabile eseguire tali strumenti e attività lontano dalle ore di punta o durante periodi di ridotto utilizzo.

  4. Considerare l'opportunità di spostare le cassette postali degli utenti dal server interessato a un altro server per ridurre il carico del sistema. Per ulteriori informazioni, vedere Spostare le cassette postali degli utenti su un server diverso.

Ulteriori informazioni

Per ulteriori informazioni, consultare le seguenti risorse Microsoft:

  • Spostare le cassette postali degli utenti su un server diverso

  • Troubleshooting Microsoft Exchange Server 2003 Performance, disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Sezione "Ottimizzazione dell'utilizzo della memoria" del Manuale sulle prestazioni e la scalabilità di Exchange Server 2003, disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Microsoft Exchange Server Best Practices Analyzer Tool, disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Articolo 815372 della Microsoft Knowledge Base "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003", disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.

  • "Exchange 2003 Memory Configuration change for Windows 2003 (PAE Support)", disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54979 (informazioni in lingua inglese).

    Nota:
    Il contenuto di ciascun blog e il relativo URL sono soggetti a modifiche senza preavviso.


Miglioramento della memoria virtuale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato problemi di frammentazione della memoria virtuale nel server.

Nei sistemi Microsoft Windows® a 32 bit sono disponibili due tipi di memoria:

  • Memoria fisica La quantità di memoria effettiva installata nel sistema

  • Spazio di indirizzi della memoria virtuale Uno spazio di memoria virtuale da 4 GB

Indipendentemente dalla quantità di memoria fisica installata nel sistema, la dimensione totale dello spazio di indirizzi virtuali è sempre la stessa: 4 GB Sebbene la situazione non sia identica per tutte le applicazioni a 32 bit, per quanto riguarda Exchange Server lo spazio di indirizzi virtuali equivale alla memoria virtuale, ovvero i due termini vengono utilizzati in modo interscambiabile.

Durante l'esecuzione delle normali operazioni, l'Archivio di Exchange procederà ad allocare, utilizzare e deallocare la memoria virtuale più volte. Se la memoria virtuale viene allocata, utilizzata e deallocata frequentemente è possibile che si verifichi una frammentazione della memoria stessa. La frammentazione della memoria virtuale è analoga alla frammentazione del file system che può verificarsi nel tempo. Dopo poco i segmenti di memoria virtuale allocati non sono più contigui e le prestazioni cominciano a risentirne. Nel caso del file system è disponibile un'applicazione che consente di eseguire la deframmentazione del file system. Nella maggior parte dei casi la deframmentazione può essere eseguita mentre il sistema è in linea e in uso. In caso di frammentazione della memoria virtuale, non è disponibile uno strumento di deframmentazione e, per risolvere il problema, è necessario arrestare e riavviare il servizio Archivio informazioni di Microsoft Exchange oppure riavviare il sistema.

La frammentazione della memoria virtuale può essere provocata da software di terze parti eseguito nei processi archivio/inetinfo. Verificare di disporre dei driver aggiornati per le applicazioni di terze parti. Se il problema persiste anche dopo il riavvio del computer, provare a disabilitare il software di terze parti oppure a spostare le cassette postali per rimuoverle dal server interessato e ridurne in tal modo il carico e verificare se il problema è stato risolto. Per ulteriori informazioni, consultare Spostare le cassette postali degli utenti su un server diverso.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi di prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Microsoft Exchange Server 2003 http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alla frammentazione della memoria virtuale in Microsoft Exchange Server 2003 e in Exchange 2000 Server, consultare l'articolo 325044 della Microsoft Knowledge Base "HOW TO: Troubleshoot Virtual Memory Fragmentation in Exchange 2003 and Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • Per ulteriori informazioni sull'ottimizzazione dell'utilizzo della memoria virtuale, consultare l'articolo 815372 della Microsoft Knowledge Base "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • Per ulteriori informazioni sulle modalità di spostamento delle cassette postali per rimuoverle dal server interessato e ridurne in tal modo il carico, vedere Spostare le cassette postali degli utenti su un server diverso.


Il Filtro messaggi intelligente non è installato in uno o più server in cui viene eseguito Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchExchangeServer per ogni oggetto di Exchange Server nell'organizzazione. Exchange Server Analyzer utilizza i risultati della query per determinare il numero totale di server nell'organizzazione nei quali viene eseguito Exchange Server 2003. Inoltre, esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare se il Filtro messaggi intelligente di Microsoft Exchange è installato in tutti i server che eseguono Exchange Server 2003 nell'organizzazione. Se Exchange Server Analyzer rileva che il Filtro messaggi intelligente non è installato su uno o più server in cui viene eseguito Exchange Server 2003, verrà visualizzato un messaggio di configurazione ottimale.

Il Filtro messaggi intelligente consente di identificare i messaggi che potrebbero essere posta elettronica commerciale indesiderata (UCE). In una topologia classica di Exchange Server 2003 il Filtro messaggi intelligente è installato sui server gateway per filtrare i messaggi Internet in arrivo. Se si utilizza un sistema di posta elettronica non Microsoft come server gateway Internet, è necessario installare il Filtro messaggi intelligente sul server testa di ponte Exchange che accetta i messaggi Internet in arrivo dai server gateway dell'utente.

Per installare il Filtro messaggi intelligente, utilizzare un account disponga delle autorizzazioni di amministrazione locale e un membro di un gruppo a cui è stato assegnato il ruolo di amministratore di Exchange.

Per ulteriori informazioni, consultare la pagina Web Exchange Intelligent Message Filter all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607.


È disponibile un aggiornamento di ISA Server 2000
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare la versione del file smtpfltr.dll che viene utilizzato dalla funzionalità SMTP Message Screener di ISA (Internet Security and Acceleration) Server 2000. Se Exchange Server Analyzer rileva che il valore del numero della versione è precedente a 2004, verrà visualizzato un avviso.

Questo avviso indica che è disponibile una versione più recente di ISA Server 2000. È consigliabile installare ISA Server 2000 Service Pack 2. L'aggiornamento al Service Pack 2 è particolarmente importante se si utilizza la funzionalità SMTP Message Screener. Le versioni precedenti di SMTP Message Screener provocano un collo di bottiglia con conseguente riduzione del livello complessivo delle prestazioni nella trasmissione dei messaggi.

Per risolvere il problema

  1. Scaricare ISA Server 2000 Service Pack 2 dall'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=37592.

  2. Per ulteriori informazioni relative alle note sulla versione del Service Pack 2, consultare la pagina http://go.microsoft.com/fwlink/?linkid=37584.

  3. Installare il Service Pack 2 utilizzando le istruzioni fornite nelle Note sulla versione.

Per ulteriori informazioni sui download di ISA Server, incluso ISA Server 2000 Service Pack 2, consultare la pagina "ISA Server 2000 Downloads" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=18919 (informazioni in lingua inglese).


Il destinatario diario non è valido
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-27

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo mailNickname sull'oggetto destinatario diario è valido. Perché l'attributo mailNickname sia valido è necessario che il nome alternativo sia impostato. Se l'attributo mailNickname relativo all'oggetto destinatario diario nominato non è valido, i messaggi di inserimento nel diario verranno messi in coda. Inoltre, un attributo mailNickname non valido può indicare che la funzione di inserimento nel diario è stata configurata per la copia dei messaggi di inserimento nel diario in un oggetto destinatario disabilitato alle cassette postali. Se Exchange Server Analyzer rileva che il valore dell'attributo mailNickname relativo all'oggetto destinatario diario non è valido, verrà visualizzato un messaggio di errore.

Per risolvere il problema per Exchange Server 2003, utilizzare Utenti e computer di Active Directory e Gestore di sistema di Exchange per eseguire le operazioni indicate di seguito, in base alle necessità.

  • Abilitare alle cassette postali l'oggetto destinatario diario.

  • Designare una nuova cassetta postale utente come destinatario diario.

Per risolvere il problema per Exchange Server 2003, utilizzare Utenti e computer di Active Directory e Gestore di sistema di Exchange per eseguire le operazioni indicate di seguito, in base alle necessità.

Per abilitare alle cassette postali l'oggetto destinatario del journal per Exchange Server 2003

  1. Aprire Utenti e computer di Active Directory.

  2. Nella struttura della console espandere il dominio.

  3. Passare al contenitore padre del destinatario che si desidera modificare.

  4. Nel riquadro dettagli fare clic con il pulsante destro del mouse sul destinatario da modificare e scegliere Operazioni di Exchange.

  5. Nell'Operazione guidata di Exchange selezionare Crea cassetta postale nella finestra di dialogo Operazioni disponibili, quindi fare clic su Avanti.

  6. Nella finestra di dialogo Crea cassetta postale verificare le informazioni presenti nei campi Alias, Archivio e Server cassette postalo, quindi fare clic su Avanti.

  7. Fare clic su Fine per chiudere l'Operazione guidata di Exchange.
Per designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal per Exchange Server 2003

  1. Avviare Gestore di sistema di Exchange.

  2. Espandere Server, <server di Exchange> e <gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali e scegliere Proprietà.

  3. Fare clic su Sfoglia, a destra del testo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio, per specificare la cassetta postale di inserimento nel diario.

    Nota:
    Tutti i messaggi inseriti nel diario per i mittenti presenti in questo archivio di cassette postali verranno inviati alla cassetta postale specificata.

Per risolvere questo problema in Exchange Server 2007, utilizzare Exchange Management Console o Exchange Management Shell per eseguire le operazioni descritte di seguito secondo le necessità.

  • Creare una cassetta postale per l'oggetto destinatario del journal.

  • Designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal.

Per abilitare alle cassette postali l'oggetto destinatario del journal per Exchange Server 2007 utilizzando Exchange Management Console

  1. In Exchange Management Console, espandere Configurazione destinatario, fare clic con il pulsante destro del mouse sull'oggetto Cassetta postale e selezionare Nuova cassetta postale per avviare la Creazione guidata nuova cassetta postale.

  2. Nella finestra Introduzione selezionare Cassetta postale utente e fare clic su Avanti.

  3. Nella finestra Tipo utente selezionare Utente esistente e utilizzare il pulsante Sfoglia per selezionare l'oggetto destinatario del journal per il quale si desidera creare la cassetta postale.

  4. Nella finestra Impostazioni cassetta postale verificare i dati riportati nei campi Alias, Server, Gruppo di archiviazione e Database delle cassette postali, quindi fare clic su Avanti.

  5. Nella finestra Nuova cassetta postale fare clic su Nuova per creare la cassetta postale per l'oggetto destinatario del journal.

  6. Fare clic su Fine per chiudere la Creazione guidata nuova cassetta postale.
Per abilitare alle cassette postali l'oggetto destinatario del journal per Exchange Server 2007 utilizzando Exchange Management Shell

  1. Seguire le istruzioni riportate nell'argomento "Enable-Mailbox" della documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80827 (informazioni in lingua inglese).

Per designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal in Exchange Server 2007

  1. In Exchange Management Console espandere Configurazione server, <il server di Exchange> e il <gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sul database delle cassette postali e scegliere Proprietà.

  2. Nella scheda Generale, in Destinatario journal, fare clic su Sfoglia per specificare una cassetta postale come cassetta postale di inserimento nel journal.

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel journal con Exchange Server 2003, vedere Journaling with Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel journal con Exchange Server 2007, vedere Panoramica dell'inserimento nel journal all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80820.


La destinazione dell'inserimento nel diario fa riferimento a un oggetto eliminato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-01

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo msExchMessageJournalRecipient contiene la stringa DEL:. Questo attributo indica che l'inserimento nel diario è stato configurato per copiare messaggi in una cassetta postale eliminata. Per il funzionamento corretto dell'inserimento nel diario, è necessaria una cassetta postale di destinazione valida a cui vengono inviati i messaggi copiati. L'attributo msExchMessageJournalRecipient viene impostato quando l'inserimento nel diario è attivo su un database di cassette postali. Questo attributo è un attributo di database di cassette postali e reca il nome distinto della cassetta postale di inserimento nel diario.

Se la cassetta postale di destinazione di inserimento nel diario è stata eliminata, i messaggi di inserimento nel diario verranno accodati. Se Exchange Server Analyzer rileva che il valore per l'attributo msExchMessageJournalRecipient contiene la stringa DEL:, verrà visualizzato un messaggio di errore.

Per correggere questo errore, utilizzare il Gestore di sistema di Exchange o Exchange Management Console per designare una nuova cassetta postale come destinatario dell'inserimento nel journal.

Per designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal in Exchange Server 2003

  1. Avviare il Gestore di sistema di Exchange.

  2. Espandere la struttura Server, espandere la struttura del <server di Exchange>, espandere la struttura <Gruppo di archiviazione>, quindi fare clic con il pulsante destro sull'archivio delle cassette postali e selezionare Proprietà.

  3. Fare clic su Sfoglia alla destra del testo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio per specificare una cassetta postale di inserimento nel diario.

    Nota:
    Tutti i messaggi inseriti nel diario per i mittenti in questo archivio delle cassette postali vengono inviati alla cassetta postale specificata.
Per designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal in Exchange Server 2007

  1. In Exchange Management Console espandere Configurazione server, <il server di Exchange> e il <gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sul database delle cassette postali e scegliere Proprietà.

  2. Nella scheda Generale, in Destinatario journal, fare clic su Sfoglia per specificare una cassetta postale come cassetta postale di inserimento nel journal.

Per ulteriori informazioni sulle modalità di distribuzione di una soluzione di inserimento nel journal per Exchange Server 2003, vedere Journaling with Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel journal con Exchange Server 2007, vedere Panoramica dell'inserimento nel journal all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80820.


Il destinatario diario fa riferimento a un account disabilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo msExchUserAccountControl dell'oggetto destinatario diario indica un account utente disabilitato. Se il valore dell'attributo msExchUserAccountControl dell'oggetto destinatario diario è impostato su 2, la funzione di inserimento nel diario è stato configurata per la copia dei messaggi di inserimento nel diario in un account utente disabilitato. A causa di questa configurazione i messaggi di inserimento nel diario potrebbero essere messi in coda o inviati alla cartella della posta scartata. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchUserAccountControl del destinatario diario indica un account utente disabilitato, verrà visualizzato un avviso.

Per risolvere il problema per Exchange Server 2003, utilizzare Utenti e computer di Active Directory e Gestore di sistema di Exchange per eseguire le operazioni indicate di seguito, in base alle necessità.

  • Abilitare l'account utente del destinatario diario corrente.

  • Designare una nuova cassetta postale utente come destinatario diario.

Per abilitare l'account del destinatario del journal per Exchange Server 2003

  1. Aprire Utenti e computer di Active Directory.

  2. Nella struttura della console espandere il dominio.

  3. Passare al contenitore padre del destinatario diario che si desidera modificare.

  4. Nel riquadro dettagli fare clic con il pulsante destro del mouse sul destinatario da modificare e scegliere Abilita account.
Per designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal per Exchange Server 2003

  1. Avviare Gestore di sistema di Exchange.

  2. Espandere Server, <server di Exchange> e <gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali e scegliere Proprietà.

  3. Fare clic su Sfoglia, a destra del testo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio, per specificare la cassetta postale di inserimento nel diario.

    Nota:
    Tutti i messaggi inseriti nel diario per i mittenti presenti in questo archivio di cassette postali verranno inviati alla cassetta postale specificata.

Per risolvere questo problema in Exchange Server 2007, utilizzare Exchange Management Console o Exchange Management Shell per eseguire le operazioni descritte di seguito secondo le necessità.

  • Creare una cassetta postale per l'oggetto destinatario del journal.

  • Designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal.

Per abilitare alle cassette postali l'oggetto destinatario del journal per Exchange Server 2007 utilizzando Exchange Management Console

  1. In Exchange Management Console, espandere Configurazione destinatario, fare clic con il pulsante destro del mouse sull'oggetto Cassetta postale e selezionare Nuova cassetta postale per avviare la Creazione guidata nuova cassetta postale.

  2. Nella finestra Introduzione selezionare Cassetta postale utente e fare clic su Avanti.

  3. Nella finestra Tipo utente selezionare Utente esistente e utilizzare il pulsante Sfoglia per selezionare l'oggetto destinatario del journal per il quale si desidera creare la cassetta postale.

  4. Nella finestra Impostazioni cassetta postale verificare le informazioni nei campi Alias, Server, Gruppo di archiviazione e Database delle cassette postali, quindi scegliere Avanti.

  5. Nella finestra Nuova cassetta postale fare clic su Nuova per creare la cassetta postale per l'oggetto destinatario del journal.

  6. Fare clic su Fine per chiudere la Creazione guidata nuova cassetta postale.
Per abilitare alle cassette postali l'oggetto destinatario del journal per Exchange Server 2007 utilizzando Exchange Management Shell

  1. Seguire le indicazioni nella documentazione del prodotto Exchange Server 2007, "Enable-Mailbox", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80827.

Per designare una nuova cassetta postale utente come destinatario dell'inserimento nel journal in Exchange Server 2007

  1. In Exchange Management Console espandere Configurazione server, <il server di Exchange> e <il gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sul database delle cassette postali e scegliere Proprietà.

  2. Nella scheda Generale, in Destinatario journal, fare clic su Sfoglia per specificare una cassetta postale come cassetta postale di inserimento nel journal.

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel journal con Exchange Server 2003, vedere Journaling with Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel journal con Exchange Server 2007, vedere Panoramica dell'inserimento nel journal all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80820.


La destinazione della funzione di inserimento nel diario fa riferimento al server locale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo msExchHomeServerName sull'oggetto destinazione della funzione di inserimento nel diario per un archivio cassette postali corrisponde al valore dell'attributo legacyExchangeDN per il server locale. Se i valori degli attributi corrispondono, significa che i messaggi della funzione di inserimento nel diario vengono copiati in una cassetta postale sul server su cui è in esecuzione la funzione attiva di inserimento nel diario. A causa dell'elevato volume di traffico della funzione di inserimento nel diario che potrebbe essere generato, si consiglia di far risiedere la cassetta postale del destinatario della funzione di inserimento nel diario su un server dedicato.

Se Exchange Server Analyzer rileva che i valori dell'attributo msExchHomeServerName dell'oggetto destinatario della funzione di inserimento nel diario corrispondono ai valori legacyExchangeDN del server locale, verrà visualizzato un messaggio di configurazione ottimale.

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel journal in Exchange Server 2003, vedere Journaling with Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel journal in Exchange Server 2007, vedere Panoramica dell'inserimento nel journal all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80820.


Il destinatario diario deve essere nascosto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo msExchHideFromAddressLists dell'oggetto destinatario diario è impostato su True. Un valore di questo attributo diverso da True indica che il destinatario diario per l'archivio delle cassette postali non è nascosto negli elenchi di indirizzi di Exchange Server e potrebbe quindi diventare il destinatario di messaggi non correlati all'inserimento nel diario. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchHideFromAddressLists relativo all'oggetto destinatario diario non è impostato su True, verrà visualizzato un messaggio di configurazione ottimale.

Per risolvere il problema per Exchange Server 2003, utilizzare lo strumento Utenti e computer di Active Directory per nascondere la cassetta postale del destinatario dell'inserimento nel journal negli elenchi di indirizzi di Exchange Server.

Per risolvere il problema per Exchange Server 2007, utilizzare Exchange Management Console per nascondere la cassetta postale del destinatario dell'inserimento nel journal negli elenchi di indirizzi di Exchange Server.

Per nascondere la cassetta postale del destinatario del journal nominato negli elenchi di indirizzi di Exchange Server con Exchange Server 2003

  1. Aprire Utenti e computer di Active Directory.

  2. Nella struttura della console espandere il dominio.

  3. Passare al contenitore padre del destinatario che si desidera modificare.

  4. Nel riquadro dei dettagli fare doppio clic sul destinatario che si desidera modificare.

  5. Nella scheda Impostazioni avanzate di Exchange selezionare la casella di controllo Non visualizzare negli elenchi di indirizzi di Exchange.

  6. Fare clic su OK.
Per nascondere la cassetta postale del destinatario del journal nominato negli elenchi di indirizzi di Exchange Server con Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Nella struttura della console, passare al contenitore padre del destinatario che si desidera modificare.

  3. Nel riquadro dei dettagli fare doppio clic sull'oggetto cassetta postale per il destinatario designato dell'inserimento nel journal al fine di visualizzarne le proprietà.

  4. Nella scheda Generale selezionare la casella di controllo Non visualizzare negli elenchi di indirizzi di Exchange.

  5. Fare clic su OK.

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel journal con Exchange Server 2003, vedere Journaling with Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel journal con Exchange Server 2007, vedere Panoramica dell'inserimento nel journal all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80820.


Junk store threshold not configured
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-07-30

Microsoft Exchange Analyzer Tool esegue una query nell'ambiente Exchange per determinare la presenza dei ruoli del server Trasporto Hub o Cassette postali di Exchange Server 2007.

Se vengono rilevati i ruoli del server Trasporto Hub o Cassette postali di Exchange Server 2007, Exchange Analyzer esegue il seguente cmdlet di Exchange Management Shell per eseguire una query sul valore del parametro SCLJunkThreshold per l'organizzazione di Exchange:

Get-OrganizationConfig

Il parametro SCLJunkThreshold per un'organizzazione specifica il livello SCL (Spam Confidence Level) al raggiungimento del quale un messaggio viene spostato nella cartella Posta indesiderata.

Se Exchange Analyzer determina che il parametro SCLJunkThreshold per un'organizzazione è impostato sul valore predefinito 8, verrà visualizzato un avviso.

Tale avviso indica che la soglia SCL per lo spostamento dei messaggi nella cartella Posta indesiderata è impostata in modo tale che la posta inviata dagli utenti legittimi potrebbe essere filtrata e spostata nella cartella Posta indesiderata. Il valore consigliato per il parametro SCLJunkThreshold è 4.

Per risolvere l'avviso, utilizzare il cmdlet Set-OrganizationConfig in Exchange Management Shell per impostare il valore del parametro SCLJunkThreshold su 4.

Per impostare il valore del parametro SCLJunkThreshold su 4 utilizzando il cmdlet Set-OrganizationConfig

  1. Il codice seguente è un esempio del comando Set-OrganizationConfig che consente di impostare il valore del parametro SCLJunkThreshold su 4.

  2. Set-OrganizationConfig -SCLJunkThreshold 4


Memoria del kernel esaurita
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-15

Lo strumento Microsoft Exchange Analyzer interroga la classe di Microsoft Strumentazione gestione Windows (WMI) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un errore di evento 2000, 2019 o 2020 per l'origine SRV (server) o NCP Server.

  • L'ID evento 2000 per SRV (server) indica che una chiamata del server a un servizio del sistema ha restituito un errore imprevisto a causa di un esaurimento generale della memoria del kernel del sistema.

  • L'ID evento 2019 per SRV indica un esaurimento della memoria di riserva non di paging del sistema.

  • L'ID evento 2020 per SRV indica un esaurimento della memoria di riserva di paging del sistema.

Se Microsoft Exchange Analyzer rileva che uno o più di tali eventi sono stati registrati nelle ultime 24 ore, verrà visualizzato un errore.

L'avviso indica che la memoria del kernel sul server è esaurita e che potrebbero verificarsi problemi di prestazioni.

La memoria del kernel di Microsoft Windows è composta da numerose strutture, tra cui memoria di riserva di paging e non di paging, nonché le voci PTE (Page Table Entry) di sistema. Tali strutture vengono utilizzate dal sistema operativo per fornire un ambiente valido per l'esecuzione di applicazioni come Exchange.

Per risolvere il problema, seguire le istruzioni riportate negli articoli di Exchange Analyzer relativi ai problemi specifici elencati di seguito:

  • Miglioramento della memoria del kernel

  • La riserva di paging ha superato la soglia di avviso

  • La riserva non di paging ha superato la soglia di avviso

  • La riserva di paging ha superato la soglia di errore

In generale, per garantire sempre un corretto funzionamento di Exchange, accertarsi di monitorare periodicamente la memoria del kernel di Exchange Server.

Per ulteriori informazioni

Per ulteriori informazioni sugli eventi SRV 2000, 2019 o 2020, vedere "Events and Errors Message Center: Event Details".

  • ID evento 2000 per SRV, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83250.

  • ID evento 2019 per SRV all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83251.

  • ID evento 2020 per SRV all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83252.

Per ulteriori informazioni sull'ottimizzazione della memoria di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 912376, "How to monitor and troubleshoot the use of paged pool memory in Exchange Server 2003 or in Exchange 2000 Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376.

  • 815372, "How to optimize memory usage in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 894067, "The Performance tool does not accurately show the available Free System Page Table entries in Windows Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=894067.

  • 311901, "The effects of 4GT tuning on System Page Table Entries", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 912376, "How to monitor and troubleshoot the use of paged pool memory in Exchange Server 2003 or in Exchange 2000 Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=912376.


Utilizzo della risorsa kernel: aggiornamento del Servizio Copia Shadow del volume
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare l'esistenza del file Vssvc.exe.

Exchange Server Analyzer esegue una query nel Registro di sistema per determinare se il Servizio Copia Shadow del volume (VSS) o il Servizio Dischi virtuali (VDS) viene eseguito su Windows Server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS

Inoltre, Exchange Server Analyzer legge il seguente valore del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul server di Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Un valore di CurrentVersion pari a 5.0 indica che il server di Exchange è in esecuzione su Microsoft Windows 2000 Server. Un valore di CurrentVersion pari a 5.2 indica che il server di Exchange è in esecuzione su Microsoft Windows Server™ 2003.

Infine, Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave ServicePackMajorVersion. Il valore della chiave ServicePackMajorVersion indica la versione del Service Pack di Windows installata nel computer.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • Il server di Exchange è installato in Windows Server 2003 Service Pack 1 (SP1).

  • Il Servizio Copia Shadow del volume (VSS) o il Servizio Dischi virtuali (VDS) è in esecuzione su Windows Server 2003 SP 1.

  • In questa configurazione di Exchange Server non è installato l'aggiornamento del Servizio Copia Shadow del volume.

L'aggiornamento del Servizio Copia Shadow del volume consente di risolvere problemi quali l'utilizzo della risorsa kernel.

Per risolvere il problema

  • Installare l'aggiornamento del Servizio Copia Shadow del volume che può essere scaricato dall'articolo 891957 della Microsoft Knowledge Base "Disponibilità di un aggiornamento per la correzione di numerosi problemi relativi al servizio Copia Shadow del volume in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=891957.

Per informazioni sulle procedure consigliate per l'utilizzo del Servizio Copia Shadow del volume con Exchange Server 2003, consultare Best Practices for Using Volume Shadow Copy Service with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56571 (informazioni in lingua inglese).


LeakDiag installato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se LeakDiag.exe è installato nel computer:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag

Se Exchange Server Analyzer rileva la presenza di questo ramo del Registro di sistema, verrà visualizzato un messaggio di configurazione non predefinita.

LeakDiag è un pacchetto costituito da una serie di strumenti che consentono a sviluppatori e personale del supporto tecnico di diagnosticare perdite di memoria, frammentazione e altri problemi relativi alla memoria in applicazioni o servizi eseguiti su computer Microsoft Windows NT®, Microsoft Windows® 2000 Server, Microsoft Windows® XP e Microsoft Windows Server™ 2003.

È possibile utilizzare gli strumenti LeakDiag per individuare perdite di memoria fino alla riga di codice. Grazie alla tecnologia Microsoft Detours, LeakDiag intercetta chiamate ad allocazioni di memoria specificate e tiene traccia dei vari stack di chiamate. Viene generato un rapporto sulla memoria che è stata allocata ma non ancora liberata. Queste informazioni consentono di risolvere i problemi di perdita di memoria per conoscere con esattezza i componenti che hanno eseguito le allocazioni. Con i corretti simboli di debug, è possibile visualizzare anche la riga di codice che ha richiesto le allocazioni.

Si consiglia di non eseguire LeakDiag su server di Exchange che si trovano in un ambiente di produzione. Quando viene abilitato, LeakDiag tiene traccia di tutte le allocazioni di memoria per tutti i processi ogni volta in cui viene avviato il server di Exchange. Con questo metodo verrà utilizzata una grande quantità di risorse di processore e di memoria e non è consigliabile, a meno che l'utente non stia risolvendo attivamente un problema relativo alla memoria. Se non si sta risolvendo attivamente un problema relativo alla memoria, è necessario disattivare LeakDiag. L'esecuzione di LeakDiag in un ambiente di produzione Exchange Server può provocare una frammentazione o un deterioramento della memoria e, in ultima analisi, un errore di Exchange.

Nota:
Risolvere sempre i problemi di LeakDiag durante gli orari di scarso traffico. Se si utilizza LeakDiag durante le ore di punta, si può verificare una diminuzione significativa delle prestazioni del computer Exchange Server.

Informazioni sul messaggio

  1. Questo messaggio è puramente informativo. Fino a quando non viene abilitato ed eseguito, la sola installazione di LeakDiag non influenza le prestazioni di Exchange Server. LeakDiag richiede almeno 4 MB di spazio libero su disco (ad esclusione dei file di registro).

  2. Per liberare lo spazio su disco necessario, è possibile rimuovere LeakDiag.exe andando nel Pannello di controllo, facendo clic su Installazione applicazioni, quindi su LeakDiag e su Rimuovi.

La versione più recente di LeakDiag si trova nel sito FTP pubblico di Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41401.


LeakDiag abilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se LeakDiag.exe è abilitato sul computer:

HKEY_LOCAL_MACHINE\Software\Microsoft\LeakDiag\EnableAutoStart

Se Exchange Server Analyzer rileva che il valore di EnableAutoStart è impostato su 1, verrà visualizzato un avviso. EnableAutoStart viene configurato utilizzando l'interfaccia utente LeakDiag. Il valore predefinito è 0. Il valore 1 indica che LeakDiag è abilitato e attivo.

LeakDiag è un pacchetto costituito da una serie di strumenti che consentono a sviluppatori e personale del supporto tecnico di diagnosticare perdite di memoria, frammentazione e altri problemi relativi alla memoria in applicazioni o servizi eseguiti su computer Microsoft Windows NT®, Microsoft Windows® 2000 Server, Microsoft Windows® XP e Microsoft Windows Server™ 2003.

È possibile utilizzare gli strumenti LeakDiag per individuare perdite di memoria fino alla riga di codice. Grazie alla tecnologia Microsoft Detours, LeakDiag intercetta chiamate ad allocazioni di memoria specificate e tiene traccia dei vari stack di chiamate. Viene generato un rapporto sulla memoria che è stata allocata ma non ancora liberata. Queste informazioni consentono di risolvere i problemi relativi alla perdita di memoria individuando con esattezza i componenti che hanno eseguito le allocazioni. Con i corretti simboli di debug, è possibile visualizzare anche la riga di codice che ha richiesto le allocazioni.

Si consiglia di non eseguire LeakDiag su server di Exchange che si trovano in un ambiente di produzione. Quando viene abilitato, LeakDiag tiene traccia di tutte le allocazioni di memoria per tutti i processi ogni volta in cui viene avviato il server di Exchange. Con questo metodo verrà utilizzata una grande quantità di risorse di processore e di memoria e non è consigliabile, a meno che l'utente non stia risolvendo attivamente un problema relativo alla memoria. Se non si sta risolvendo attivamente un problema relativo alla memoria, è necessario disattivare LeakDiag. L'esecuzione di LeakDiag in un ambiente di produzione Exchange Server può provocare una frammentazione o un deterioramento della memoria e, in ultima analisi, un errore di Exchange.

Nota:
Risolvere sempre i problemi di LeakDiag durante gli orari di scarso traffico. Se si utilizza LeakDiag durante le ore di punta, si può verificare una diminuzione significativa delle prestazioni del computer Exchange Server.

Per disattivare Avvio automatico in LeakDiag.exe

  1. Fare clic su Start, quindi scegliere LeakDiag.

  2. Nel menu Strumenti fare clic su Opzioni.

  3. Nella pagina Opzioni deselezionare la casella di controllo Allow AutoStart quindi fare clic su OK.

La versione più recente di LeakDiag si trova nel sito FTP pubblico di Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41401.


Meno di sette giorni di spazio rimasto per i file di registro
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-13

Microsoft Exchange Server Analyzer Tool calcola il tempo mancante prima che lo spazio sulle unità disco riservate ai file di registro delle transazioni in un gruppo di archiviazione di Exchange Server sia pieno. Exchange Server Analyzer calcola il tempo in cui tale unità raggiunge la capacità massima controllando i timestamp nei file del registro delle transazioni presenti nell'unità. Se viene rilevato che mancano meno di sette giorni all'esaurimento dello spazio sull'unità riservata ai file di registro, verrà visualizzato un messaggio di errore.

Lo spazio su disco dell'unità che ospita i file di registro dei database di Exchange Server si sta esaurendo.

Quando lo spazio su disco dell'unità di registro si esaurisce, possono verificarsi i seguenti problemi:

  • Il database non si avvia o si arresta.

  • Il database si arresta in modo anomalo e assume uno stato incoerente.

  • Gli utenti non possono accedere alla posta o alle cartelle pubbliche.

Lo spazio sull'unità riservata ai file di registro può esaurirsi perché la registrazione circolare è disabilitata. Pertanto, i file di registro delle transazioni vengono lasciati nell'unità fino a quando non viene eseguito un backup in linea completo o incrementale utilizzando un software di backup che riconosce Exchange Server.

Nelle versioni di Exchange precedenti a Exchange 2003, i database potrebbero non essere in grado di raggiungere lo stato di chiusura normale prima dell'arresto. Durante un'emergenza di spazio su disco mancante, due file di registro delle transazioni di riserva, Res1.log e Res2.log, vengono convertiti in registri delle transazioni normali.

In Exchange Server 2003 sono state implementate ottimizzazioni che consentono la chiusura normale dei database fino all'esaurimento dei file di registro di riserva. Se un database non viene chiuso normalmente, è molto importante che non vengano eliminati gli ultimi registri delle transazioni associati al database. Questi registri delle transazioni contengono ancora informazioni che è necessario applicare al database per ripristinare la coerenza. Se questi file di registro vengono eliminati, il database non potrà essere riavviato fino a quando non sarà stato riparato o ripristinato.

Se tutti i database di un gruppo di archiviazione si trovano nello stato di chiusura normale, la rimozione di tutti i registri delle transazioni non impedisce l'avvio del database. Tuttavia, se vengono rimossi i registri delle transazioni, tutti i precedenti backup verranno invalidati. La rimozione non significa che non è possibile ripristinare backup precedenti, ma che non sarà possibile eseguire il roll forward di un database ripristinato oltre il punto in cui sono stati eliminati i file di registro.

La procedura guidata di Exchange Server Analyzer per lo spazio su disco analizza i file di registro delle transazioni esistenti e consente di spostare quelli non più necessari per il database. Inoltre garantisce che anche se tutti i database sono nello stato di chiusura normale, il file di registro corrente non venga rimosso. Se il file di registro corrente non viene rimosso, i backup precedenti rimangono validi.

Per liberare spazio sull'unità riservata ai file di registro, rimuovere i file di registro non necessari. Si consiglia di eseguire le seguenti azioni.

Per liberare spazio sull'unità disco riservata ai file di registro quando lo spazio è esaurito o sta per esaurirsi

  • Selezionare un backup di flusso in linea che riconosca Exchange o un backup VSS del database. Per ulteriori informazioni sul backup VSS, consultare "Pratiche consigliate per l'utilizzo del servizio Copia Shadow del volume con Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56571.

    Nota:
    Il metodo preferito per l'eliminazione dei file di registro non necessari è selezionare un backup di flusso in linea o un backup VSS.

  • Se il database viene arrestato perché lo spazio sull'unità riservata ai file di registro sta per esaurirsi, è possibile utilizzare la procedura guidata di gestione dello spazio riservato ai file di registro di Exchange Server Analyzer. È possibile utilizzare la procedura guidata per spostare i file di registro superflui. In alternativa, è possibile spostare manualmente i file di registro superflui prima di reinstallare il database.

    Per rimuovere manualmente i file di registro, seguire le procedure e i consigli dell'articolo 240145 della Microsoft Knowledge Base "Eliminazione dei file di registro delle transazioni di Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240145.


L'attributo LegacyExchangeDN per questo server di Exchange non corrisponde al gruppo amministrativo principale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per verificare il valore legacyExchangeDN di un server controllando gli attributi dell'oggetto server nel contenitore Server di Active Directory e confrontando questo valore con il nome effettivo dell'organizzazione e del gruppo amministrativo in cui si trova il server. Se il valore legacyExchangeDN del server è diverso dall'organizzazione o dal gruppo amministrativo, verrà visualizzato un messaggio di errore.

Il valore legacyExchangeDN viene utilizzato in Exchange per identificare gli oggetti di Exchange presenti in Active Directory. Il valore legacyExchangeDN rappresenta un nome distinto che indica la posizione dell'oggetto nell'organizzazione di Exchange, ad esempio:

/o= organizzazione /ou= gruppo amministrativo /ou= server

Gli oggetti quali gli archivi di cassette postali o di cartelle pubbliche ereditano parte dei propri valori legacyExchangeDN dal server. Di conseguenza, se esiste un problema con il valore del server, altri oggetti potrebbero ereditare lo stesso problema.

In genere, si verificano problemi con legacyExchangeDN quando un amministratore tenta di modificare direttamente il valore. È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto gruppo amministrativo in Active Directory.

    L'attributo legacyExchangeDN è reperibile in:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=server

  2. Immettere un nuovo valore di stringa del formato:

    /o= organizzazione /ou= gruppo amministrativo /ou= server

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server 2003.


L'attributo LegacyExchangeDN per questo server di Exchange non è valido
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per verificare il valore legacyExchangeDN del server di Exchange. Questo messaggio di errore viene visualizzato se l'organizzazione o il gruppo amministrativo specificato nel valore legacyExchangeDN non corrisponde al nome effettivo dell'organizzazione o del gruppo o se parte del valore manca completamente.

Il valore legacyExchangeDN viene utilizzato in Exchange per identificare gli oggetti di Exchange presenti in Active Directory. Il valore legacyExchangeDN rappresenta un nome distinto che indica la posizione dell'oggetto nell'organizzazione di Exchange, ad esempio:

/o= organization /ou= administrative group

Oggetti quali server e gerarchie di cartelle ereditano parte dei loro valori legacyExchangeDN dal gruppo amministrativo. Di conseguenza, se esiste un problema con il valore del gruppo amministrativo, molti altri oggetti potrebbero ereditare lo stesso problema.

In genere, si verificano problemi con legacyExchangeDN quando un amministratore tenta di modificare direttamente il valore. È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit, lo strumento LDP o altri client LDAP versione 3.

Attenzione:
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto gruppo amministrativo in Active Directory.

    L'attributo legacyExchangeDN è reperibile in:

    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group

  2. Immettere un nuovo valore di stringa del modulo:

    /o= organization /ou= administrative group

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo della Microsoft Knowledge Base 260745 "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida di Windows Server 2003.


Il Servizio registrazione licenze è impostato su Automatico
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il Servizio registrazione licenze (LicenseService). Il valore False indica che il Servizio registrazione licenze non è in esecuzione su questo server di Exchange. Il valore True indica che il Servizio registrazione licenze è in esecuzione.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore restituito per questa chiave indica la versione del sistema operativo Windows in esecuzione sul computer Exchange Server.

Exchange Server Analyzer, inoltre, esegue query nel servizio directory di Active Directory® per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero delle cassette postali presenti nell'archivio.

Se Exchange Server Analyzer determina che il Servizio registrazione licenze è stato avviato in un computer Exchange Server che soddisfa i requisiti elencati di seguito, verrà visualizzato un avviso:

  • Il computer Exchange Server non è un server front-end.

  • Il computer Exchange Server contiene più di 20 cassette postali.

  • Il computer che esegue Exchange Server non è in esecuzione su Microsoft Windows Small Business Server 2003 o Small Business Server 2000.

Il Servizio registrazione licenze è uno strumento progettato per aiutare i clienti a gestire le licenze per i prodotti del server Microsoft con licenze di tipo CAL (Client Access License).

Per impostazione predefinita, il Servizio registrazione licenze è disabilitato in Microsoft Windows Server™ 2003. A causa delle restrizioni imposte alla progettazione originale e delle modifiche apportate ai termini e alle condizioni, il Servizio registrazione licenze non può offrire una panoramica accurata del numero totale di CAL acquistate rispetto al numero totale di quelle utilizzate su un unico server o all'interno di un'organizzazione. I CAL riportati dal Servizio registrazione licenze possono contrastare con l'interpretazione dei Contratti di Licenza con l'utente finale (EULA) e i Diritti di utilizzo dei prodotti (PUR). Il Servizio registrazione licenze non verrà incluso nelle versioni future del sistema operativo Windows.

Microsoft definisce requisiti specifici e raccomandazioni per l'utilizzo del Servizio registrazione licenze sui computer Exchange Server:

  • Su server di Exchange front-end in cui si utilizza SSL (Secure Sockets Layer) è necessario abilitare e avviare il Servizio registrazione licenze. Se il Servizio registrazione licenze non è in esecuzione, IIS (Internet Information Services) limiterà a 10 il numero di connessioni SSL simultanee autenticate.

  • Su server di Exchange back-end è consigliabile arrestare il Servizio registrazione licenze e impostarlo su Disabilitato.

  • Su server di Exchange di tipo cluster è consigliabile arrestare il Servizio registrazione licenze e impostarlo su Disabilitato.

  • Su server di Exchange in esecuzione su Microsoft Windows Small Business Server 2003 oppure su Small Business Server 2000 il Servizio registrazione licenze è necessario solo quando sono richieste più di 10 connessioni SSL autenticate.

Per impostare lo stato del Servizio registrazione licenze

  1. Avviare lo snap-in Servizi dal menu Strumenti di amministrazione.

  2. Individuare e fare doppio clic su Servizio registrazione licenze.

  3. Nell'elenco a discesa Tipo di avvio selezionare l'opzione appropriata:

    • Impostare il servizio su Automatico sui server di Exchange front-end che utilizzano SSL.

    • Impostare il servizio su Disabilitato sui server di Exchange back-end e sui server di Exchange di tipo cluster.

  4. Se si disabilita il Servizio registrazione licenze, fare anche clic su Arresta per interrompere il servizio.

  5. Fare clic su OK per salvare le modifiche e chiudere lo snap-in Servizi.

Per ulteriori informazioni sul Servizio registrazione licenze, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 824196, "Descrizione del Servizio registrazione licenze su sistemi operativi Windows Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=824196.

  • 316631, "Disattivazione del Servizio registrazione licenze" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316631.


Il nome file del registro non corrisponde al numero di generazione
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool confronta il valore del numero di generazione interno lGeneration dell'intestazione del file di registro con il nome file del registro per determinare se corrispondono.

Se il numero di generazione del file di registro non corrisponde al numero di generazione interno del nome file del registro delle transazioni, Microsoft Exchange Server Analyzer Tool visualizzerà un errore.

A meno che il file di registro non sia il registro corrente, il file più recente disponible deve avere un nome che corrisponde al rispettivo numero di generazione. Se il file di registro è il registro attuale, non è necessario che il nome contenga il numero di generazione ma solo il prefisso del registro del gruppo di archiviazione. Per esempio, i log delle transazioni precedenti all'interno della stessa serie potrebbero essere denominati E0154321.LOG, E0154322.LOG, E0154323.LOG e così via, con il log attuale denominato E01.LOG.

È possibile utilizzare il comando Eseutil /ML LOGFILE per visualizzare il valore lGeneration interno di un file di registro.

Per ulteriori informazioni sulla registrazione delle transazioni di Exchange, vedere "Exchange Transaction Logging in Exchange Server 2003" in Using Recovery Storage Groups in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47589 (in inglese).


Mancata corrispondenza con la firma della sequenza registri
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool confronta il valore della Signature di un registro con il valore della Signature di un registro successivo per determinare se corrispondono.

Se il valore della Signature del registro non corrisponde con quello della Signature del file di registro successivo, Exchange Server Analyzer visualizzerà un errore.

Exchange utilizza un serie di file di registro, ciascuno di cinque megabyte esatti, invece di scrivere tutte le informazioni su un unico file di grandi dimensioni. Se un file di registro è pieno, Exchange lo chiude e lo rinomina con un numero di sequenza.

Inizializzando una nuova sequenza di file di registro delle translazioni di un gruppo di archivio di Exchange, viene scritta una Signature nel primo file di registro che viene copiata in tutti quelli successivi. La Signature identifica in modo univoco un particolare file di registro come parte di una determinata sequenza.

È impossibile trovare file di registro con firme diverse nelle stesse cartelle. Se ciò avviene, è possibile che file di registri esterni siano stati copiati nel gruppo di archiviazione o che file di registro siano stati reimpostati senza prima eliminare i vecchi.

È possibile utilizzare il comando Eseutil /ML LOGFILE per visualizzare il valore Signature di un file di registro.

Per ulteriori informazioni sulla registrazione delle transazioni di Exchange, vedere "Exchange Transaction Logging in Exchange Server 2003" in Using Recovery Storage Groups in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47589 (in inglese).


Problema firma registro
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool confronta la firma nell'intestazione del file di registro delle transazioni attuali di Exchange di un server con la firma del database del gruppo di archiviazione.

Se la firma del file di registro delle transazioni non corrisponde alla firma del registro dei file del database, verrà visualizzato un errore.

L'errore indica l'esistenza di una delle seguenti condizioni:

  • Il file di registro delle transazioni corrente non esiste.

  • Il file di registro delle transazioni corrente non corrisponde a uno dei database del gruppo di archiviazione.

Le cause di questo comportamento possono essere:

  • I registri delle transazione del gruppo di archiviazione sono stati eliminati manualmente.

  • Un database di un altro gruppo di archiviazione è stato ripristinato o copiato nel gruppo di archiviazione in uso.

  • I file di registro delle transazioni di una sequenza o un gruppo di archiviazione diversi sono stati copiati nel gruppo di archiviazione in uso.

L'installabilità di un database in funzione di questa condizione dipende dallo stato di arresto (normale o anomalo) del file di database.

Nota:
È possibile che un database in stato di arresto normale non possa comunque essere installato perché altri database all'interno del gruppo di archiviazione non sono installabili. In questi casi utilizzare Microsoft Exchange Server Disaster Recovery Analyzer Tool per eseguire la diagnosi e ottenere informazioni sulla possibile procedura da seguire per installare i database.

Quando il database di Exchange si arresta correttamente, tutti i dati in attesa vengono scritti nei rispettivi file. Dopo l'arresto normale, il set dei file di database (con estensione .edb e .stm) è considerato coerente. Exchange quindi scollega il set di file di database dal flusso di registrazione. Ciò significa che ora i file di database sono completamente aggiornati. Per avviare i file di database non sono necessari i registri precedenti.

I database nello stato di Arresto normale sono stati scollegati dai rispettivi file di registro e possono essere collegati a un altro flusso di registrazione. Pertanto, la mancata corrispondenza tra i file di registro e i database non indica necessariamente un problema.

I database in stato di Arresto anomalo non sono stati scollegati correttamente dai rispettivi file di registro. È necessario ripristinarli con i rispettivi file di registro collegati. Se non è possibile individuare i file di registro collegati, non è possibile neanche installare il database. È necessario ripristinare da backup o riparare il database prima di poterlo installare.

È possibile verificare se il database è stato arrestato normalmente inserendo il comando Eseutil /mh e controllando le intestazioni file. In Microsoft Exchange 2000 Service Pack 1 e versioni successive, la riga dell'intestazione riporta "Stato: Arresto normale" o "Stato: Arresto anomalo". Nelle versioni precedenti di Exchange, la stessa indicazione è riportata come "Stato: Coerente" o "Stato: Incoerente".

Per ulteriori informazioni sulla registrazione delle transazioni di Exchange, vedere "Exchange Transaction Logging in Exchange Server 2003" in Using Recovery Storage Groups in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47589 (in inglese).


Byte record di registro al secondo oltre la soglia di errore
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-23

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente vengono eseguite in maniera ragionevolmente prevedibile su un server Exchange che funziona correttamente.

Come parte della procedura di analisi eseguita da Exchange Server Analyzer, viene verificato l'utilizzo del registro per determinare se le operazioni MAPI dell'utente causano la scrittura di oltre 5 MB di dati al minuto nei registri delle transazioni di Exchange.

Lo sviluppo eccessivo del file di registro delle transazioni a causa delle operazioni MAPI può provocare colli di bottiglia nelle risorse del server ed errori quali il superamento della profondità del punto di arresto, colli di bottiglia nelle prestazioni I/O del disco e spazio su disco insufficiente.

Se Exchange Server Analyzer determina che una o più operazioni MAPI dell'utente implicano la scrittura di oltre 5 MB di dati al minuto nei registri delle transazioni di Exchange, verrà visualizzato un errore.

Non sempre le operazioni MAPI che implicano la scrittura di oltre 5 MB di dati al minuto nei registri delle transazioni di Exchange rappresentano un problema. La scrittura ad elevata frequenza è prevista per determinate azioni, quali gli spostamenti delle cassette postali o altre operazioni in blocco riguardanti molti messaggi, che generano ingenti quantità di dati del registro delle transazioni. In questo caso, è opportuno sostenere frequenze elevate solo per pochi minuti.

Se sul server si verificano altri problemi, quali un'alta latenza RPC, collaborare con l'utente che genera i dati del registro delle transazioni al fine di determinare quale attività dell'utente stia causando l'elevata frequenza di scrittura nel record di registro.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).

  • Articolo 905803 della Microsoft Knowledge Base, "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803.


L'oggetto Performance Monitor LogicalDisk non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Read dell'oggetto prestazioni LogicalDisk per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni LogicalDisk è disabilitato. Per impostazione predefinita, in Microsoft Windows Server™ 2003 l'oggetto prestazioni LogicalDisk è abilitato. Tuttavia, in Microsoft Windows® 2000 Server LogicalDisk non è abilitato per impostazione predefinita.

  • L'oggetto Performance Monitor LogicalDisk non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestaizone.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®).

Nella procedura seguente viene illustrato come correggere le prime due condizioni. Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni LogicalDisk sia abilitato:

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina Exctrlst.exe: Extensible Performance Counter List all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base, "Ricostruzione manuale dei valori della Libreria dei contatori di prestazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


Rilevate operazioni MAPI ad alta latenza
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-11-22

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento Exchange Server User Monitor (ExMon) per raccogliere dati, in un campione di cinque minuti, al fine di determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Se nel margine di tempo di raccolta dei dati Exchange Server Analyzer determina che un utente ha eseguito una o più operazioni MAPI impiegando più di 30 secondi, viene visualizzato un errore ed eseguita un'ulteriore analisi sulle azioni degli utenti che hanno generato l'errore.

Non sempre le operazioni MAPI che impiegano oltre 30 secondi costituiscono un problema. Il salvataggio di grandi quantità di dati o di allegati dei messaggi può implicare un tempo di esecuzione delle operazioni più lungo del normale.

Se si verificano frequenti ritardi o se i ritardi si ripercuotono in maniera negativa sulle operazioni di messaggistica, è necessario verificare che non siano sintomatici di problemi di latenza più gravi come, ad esempio, colli di bottiglia nelle risorse o dipendenze nidificate.

Per risolvere il problema:

  • Provare a utilizzare lo strumento ExMon per acquisire un campione di dati più ampio da analizzare tramite Exchange Server Analyzer. A causa dell'ampio volume di dati generato da ExMon, è consigliabile limitare il campione di raccolta dei dati a 30 minuti o meno.

  • Esaminare eventuali errori di latenza e articoli associati che descrivono tale particolare operazione nonché la relativa procedura di risoluzione. Se Exchange Server Analyzer non segnala errori di latenza correlati, l'ulteriore analisi delle azioni dell'utente non ha rilevato alcun problema.


Operazione globale MAPI a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-23

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Nell'ambito dell'analisi, Exchange Server Analyzer controlla i dati ExMon relativi alle operazioni globali MAPI eseguite dall'utente che impiegano più di 30 secondi per il completamento.

Le operazioni globali MAPI sono operazioni che agiscono su più di un oggetto e, di norma, sono dispendiose poiché richiedono molti I/O.

Se Exchange Server Analyzer determina che una o più operazioni globali MAPI eseguite da un utente impiegano più di 30 secondi, verrà visualizzato un messaggio di errore.

Le operazioni globali MAPI che impiegano più di 30 secondi non sempre rappresentano un problema. Se un utente interviene su un migliaio o più di messaggi alla volta, copiando, eliminando, impostando i flag degli attributi e così via, le operazioni globali MAPI potrebbero impiegare più tempo di quanto normalmente previsto.

Se si verificano frequenti ritardi o se i ritardi si ripercuotono in maniera negativa sulle operazioni di messaggistica, è necessario verificare che non siano sintomatici di problemi di latenza più gravi come, ad esempio, colli di bottiglia nelle risorse o dipendenze nidificate.

Per risolvere il problema:

  • Provare a utilizzare lo strumento ExMon per acquisire un campione di dati più ampio da analizzare tramite Exchange Server Analyzer. A causa dell'ampio volume di dati generato da Exchange, è consigliabile limitare il campione di raccolta dei dati a 30 minuti o meno.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese)

  • Articolo 905803 della Microsoft Knowledge Base "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803


Operazione MAPI "FindRow" a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-11-22

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Nell'ambito dell'analisi, Exchange Server Analyzer controlla i dati ExMon relativi alle operazioni MAPI FindRow eseguite dall'utente che impiegano più di 30 secondi per il completamento.

L'aumento del numero di visualizzazioni per ogni cartella può sovraccaricare ulteriormente molte operazioni MAPI. Le applicazioni client utilizzano le operazioni MAPI SeekRow o FindRow per spostare il puntatore tra le righe di una visualizzazione. SeekRow consente di specificare di quante righe spostare il puntatore ed è un'operazione molto economica in termini di tempo di CPU. FindRow è un'operazione piuttosto costosa poiché consente di spostare il puntatore sul primo elemento in una visualizzazione non materializzata (che non verrà memorizzata nella cache) che soddisfa i criteri di restrizione e quindi elimina la visualizzazione quando l'applicazione client termina l'azione. Il costo finale di FindRow per la CPU dipende dalla complessità della restrizione e dal numero di righe che l'archivio deve esaminare prima di trovare il primo elemento che soddisfa il criterio ed è quindi liberamente correlato al numero di elementi presenti nella cartella.

A causa dei costi elevati, è preferibile eseguire FindRow in modalità cache per ridurre i costi del server. È necessario tenere presente che talvolta l'elevata percentuale di CPU utilizzata da queste operazioni può essere causata semplicemente da calendari condivisi, nel qual caso la modalità cache non risulterà utile. Un'elevata percentuale di tempo di CPU utilizzato dalle operazioni FindRow può indicare numerose creazioni di visualizzazioni, visualizzazioni costose e un numero molto elevato di elementi presenti nelle cartelle.

Se Exchange Server Analyzer determina che un'operazione MAPI FindRow eseguita dall'utente ha impiegato oltre 30 secondi, verrà visualizzato un errore.

Non sempre le operazioni MAPI FindRow che impiegano oltre 30 secondi costituiscono un problema. Se l'utente o gli utenti identificati riscontrano ritardi frequenti o ritardi che influiscono negativamente sulle attività di messaggistica, è necessario capirne i motivi. Collaborare con l'utente che ha riscontrato l'alta latenza per determinare quanto segue:

  • Se il conteggio degli elementi nelle cartelle è elevato.

  • Quali applicazioni sono in esecuzione.

Per risolvere il problema:

  • Incoraggiare gli utenti le cui cartelle contengono numerosi elementi a ridurre il numero di elementi per cartella. È consigliabile che il numero di elementi nelle cartelle Posta in arrivo, Calendario, Posta inviata, Contatti e Posta eliminata non sia superiore a 5.000.

  • Configurare i computer client più dispendiosi a livello operativo (soprattutto quelli con latenze lunghe nelle operazioni Restrict, SetColumns o FindRow) in modo che utilizzino la modalità cache di Exchange. Tale modalità infatti isola il server dalla maggior parte del traffico RPC in eccesso.

  • Provare a chiudere tutte le applicazioni e a riaprirle una ad una per individuare quella che genera l'errore. Se le suddette applicazioni non sono necessarie per l'azienda o se è disponibile per tali applicazioni un aggiornamento rapido pubblicato, chiudere definitivamente le applicazioni o aggiornarle in modo da ridurre il carico a un livello ragionevole.

Nota:
Alcune applicazioni possono produrre un incremento significativo del carico del server anche se non viene eseguito un numero elevato di operazioni MAPI. Ciò accade poiché alcune operazioni sono più costose di altre. A volte è sufficiente un lieve aumento del numero di operazioni dispendiose per determinare un impatto considerevole sulle prestazioni del server. In ExMon gli utenti che utilizzano tali applicazioni vengono indicati come responsabili di un effetto consistente sulla CPU, senza che abbiano necessariamente eseguito una quantità elevata di operazioni MAPI.

Tenere inoltre presente che quando si verifica un collo di bottiglia per le risorse, in genere un collo di bottiglia del disco o della CPU, le latenze delle operazioni FindRow aumentano.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).

  • Articolo 905803 della Microsoft Knowledge Base, "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803


Operazione in linea MAPI a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-23

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni in linea MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Un esempio di operazione in linea MAPI è l'operazione QueryRows.

L'operazione QueryRows è utilizzata per restituire righe nella visualizzazione corrente. QueryRows utilizza i dati di una tabella per soddisfare la richiesta dell'utente. L'operazione SetColumns determina i dati disponibili per QueryRows. L'esecuzione dell'operazione QueryRows aumenta la dimensione delle proprietà richieste, il numero di proprietà richieste e il numero di righe di dati richieste. L'operazione QueryRows può inoltre essere dispendiosa se viene richiesto un numero elevato di colonne e righe.

All'aumentare del numero di elementi nelle cartelle principali di Exchange Server 2003 aumenta anche il costo del disco fisco per l'esecuzione di alcune operazioni da parte degli utenti di Outlook. Il primo ordinamento della cartella Posta in arrivo in base alle dimensioni è molto dispendioso poiché richiede numerosi I/O del disco. Le successive operazioni di ordinamento saranno meno dispendiose.

Se Exchange Server Analyzer determina che, nel periodo di tempo in cui sono stati raccolti i dati, una o più operazioni in linea MAPI eseguite da un utente impiegano più di 30 secondi, verrà visualizzato un messaggio di errore.

Latenze lunghe nelle operazioni in linea MAPI possono indicare un collo di bottiglia nelle risorse del server. Per l'operazione QueryRows, potrebbero anche indicare un conteggio elevato di elementi in una cartella o l'impostazione di numerose proprietà sulle tabelle interne.

Se l'operazione in linea ad alta latenza sta gestendo contemporaneamente un numero elevato di dati, l'alta latenza potrebbe non essere correlata a problemi relativi alle prestazioni del server. Un esempio di tale situazione è quando un utente seleziona tutti gli elementi di una cartella e li segna come letti eseguendo una singola operazione. Collaborare con l'utente che ha riscontrato l'alta latenza per determinare quanto segue:

  • Se il conteggio degli elementi nelle cartelle è elevato.

  • Quali applicazioni sono in esecuzione.

Per risolvere il problema:

  • Incoraggiare gli utenti le cui cartelle contengono numerosi elementi a ridurre il numero di elementi per cartella. È consigliabile che il numero di elementi nelle cartelle Posta in arrivo, Calendario, Posta inviata, Contatti e Posta eliminata non sia superiore a 5.000.

  • Provare a chiudere tutte le applicazioni e a riaprirle una ad una per individuare quella che genera l'errore. Se le suddette applicazioni non sono necessarie per l'azienda o se è disponibile per tali applicazioni un aggiornamento rapido pubblicato, chiudere definitivamente le applicazioni o aggiornarle in modo da ridurre il carico a un livello ragionevole.

Nota:
Alcune applicazioni possono produrre un incremento significativo del carico del server anche se non viene eseguito un numero elevato di operazioni in linea MAPI. Ciò accade poiché alcune operazioni sono più costose di altre. A volte è sufficiente un lieve aumento del numero di operazioni dispendiose per determinare un impatto considerevole sulle prestazioni del server. In ExMon gli utenti che utilizzano tali applicazioni vengono indicati come responsabili di un impatto sulla CPU relativamente alto, senza che abbiano necessariamente eseguito una quantità elevata di operazioni MAPI.

Si noti inoltre che quando si verifica un collo di bottiglia per le risorse (in genere un collo di bottiglia del disco o della CPU), le latenze delle operazioni in linea MAPI aumentano. Identificare i colli di bottiglia nelle risorse del server e aumentare la capacità delle risorse del server oppure spostare gli utenti su un server con un carico inferiore.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).

  • Articolo 905803 della Microsoft Knowledge Base, "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803


Operazione MAPI a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-11-22

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Se Exchange Server Analyzer determina che una o più operazioni MAPI eseguite da un utente impiegano più di 30 secondi, verrà visualizzato un messaggio di errore.

L'aumento del numero di visualizzazioni per ogni cartella può sovraccaricare ulteriormente molte operazioni MAPI. In questa sezione vengono illustrate due delle operazioni più comuni: SeekRow e FindRow. In genere, le modalità di risoluzione applicate alle operazioni SeekRow e FindRow consentono di risolvere anche eventuali altre operazioni MAPI che Exchange Server Analyzer rileva come "a esecuzione prolungata".

Le applicazioni client utilizzano le operazioni MAPI SeekRow o FindRow per spostare il puntatore tra le righe di una visualizzazione. SeekRow consente di specificare di quante righe spostare il puntatore ed è un'operazione molto economica in termini di tempo di CPU. FindRow è un'operazione piuttosto costosa poiché consente di spostare il puntatore sul primo elemento in una visualizzazione non materializzata (che non verrà memorizzata nella cache) che soddisfa i criteri di restrizione e quindi elimina la visualizzazione quando l'applicazione client termina l'azione. Il costo effettivo di CPU di FindRow dipende dalla complessità della restrizione, dal numero delle proprietà dei messaggi cui si accede per ciascun messaggio, nonché dal numero di righe che l'archivio deve rivedere prima di trovare il primo elemento corrispondente ai criteri, ed è pertanto in qualche modo correlato al numero di elementi presenti nella cartella.

Non sempre le operazioni MAPI che impiegano oltre 30 secondi costituiscono un problema. Se l'utente o gli utenti identificati riscontrano ritardi frequenti o ritardi che influiscono negativamente sulle attività di messaggistica, è necessario capirne i motivi. Collaborare con l'utente che ha riscontrato l'alta latenza per determinare quanto segue:

  • Se il conteggio degli elementi nelle cartelle è elevato.

  • Quali applicazioni sono in esecuzione.

Per risolvere il problema:

  • Incoraggiare gli utenti le cui cartelle contengono numerosi elementi a ridurre il numero di elementi per cartella. È consigliabile che il numero di elementi nelle cartelle Posta in arrivo, Calendario, Posta inviata, Contatti e Posta eliminata non sia superiore a 5.000.

  • Configurare i computer client più dispendiosi a livello operativo (soprattutto quelli con latenze lunghe nelle operazioni Restrict, SetColumns o FindRow) in modo che utilizzino la modalità cache di Exchange. Tale modalità infatti isola il server dalla maggior parte del traffico RPC in eccesso.

  • Provare a chiudere tutte le applicazioni e a riaprirle una ad una per individuare quella che genera l'errore. Se le suddette applicazioni non sono necessarie per l'azienda o se è disponibile per tali applicazioni un aggiornamento rapido pubblicato, chiudere definitivamente le applicazioni o aggiornarle in modo da ridurre il carico a un livello ragionevole.

Nota:
Alcune applicazioni possono produrre un incremento significativo del carico del server anche se non viene eseguito un numero elevato di operazioni MAPI. Ciò accade poiché alcune operazioni sono più costose di altre. A volte è sufficiente un lieve aumento del numero di operazioni dispendiose per determinare un impatto considerevole sulle prestazioni del server. In ExMon gli utenti che utilizzano tali applicazioni vengono indicati come responsabili di un effetto consistente sulla CPU, senza che abbiano necessariamente eseguito una quantità elevata di operazioni MAPI.

Si noti inoltre che quando si verifica un collo di bottiglia per le risorse (in genere un collo di bottiglia del disco o della CPU), le latenze delle operazioni MAPI aumentano. Identificare i colli di bottiglia nelle risorse del server e aumentare la capacità delle risorse del server oppure spostare gli utenti su un server con un carico inferiore.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).

  • Articolo 905803 della Microsoft Knowledge Base, "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803


Operazione MAPI "SaveChangesMessage" a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-11-22

Microsoft® Exchange Server Analyzer utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Nell'ambito dell'analisi, Exchange Server Analyzer controlla i dati ExMon relativi alle operazioni MAPI SaveChangesMessage eseguite dall'utente che impiegano più di 30 secondi per il completamento.

L'operazione MAPI SaveChangesMessage viene chiamata quando un'applicazione salva il contenuto e/o le proprietà di un messaggio sul server. Il tempo richiesto per il completamento dell'operazione dipende dai dati scritti, dalla velocità del database e dai dischi del registro delle transazioni su cui viene eseguita la scrittura, nonché dall'eventuale presenza di un collo di bottiglia nelle risorse.

Se Exchange Server Analyzer rileva che un'operazione MAPI SaveChangesMessage eseguita dall'utente ha impiegato oltre 30 secondi, verrà visualizzato un messaggio di errore.

Non sempre le operazioni MAPI SaveChangesMessage che impiegano oltre 30 secondi costituiscono un problema. Il salvataggio di grandi quantità di dati o di allegati dei messaggi può implicare un tempo di esecuzione dell'operazione MAPI SaveChangesMessage più lungo del normale. Tuttavia, se l'utente o gli utenti riscontrano ritardi frequenti o con impatto negativo sulle sessioni di messaggistica, la causa più probabile è un collo di bottiglia del disco.

Per ulteriori informazioni

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sulle procedure consigliate per la progettazione delle architetture di archiviazione, vedere Procedure consigliate comuni a più architetture all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72988.

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, vedere Spostare le cassette postali degli utenti su un server diverso.

  • Per ulteriori informazioni sulle dimensioni dei dischi, la latenza e le frequenze di I/O, consultare i seguenti blog sul sito Web del blog del team Microsoft Exchange:

    • "A few basic concepts in disk sizing" all'indirizzo http://go.microsoft.com/fwlink/?linkid=39538 (informazioni in lingua inglese).

    • "Some more thoughts on disk IO and calculations…" (all'indirizzo http://go.microsoft.com/fwlink/?linkid=39539 (informazioni in lingua inglese).

    • "Come calcolare i requisiti di I/O del disco" all'indirizzo http://go.microsoft.com/fwlink/?linkid=69747.


Operazione MAPI "SetColumns" a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-23

Microsoft® Exchange Server Analyzer utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server che esegue Exchange Server che funziona correttamente.

Nell'ambito dell'analisi, Exchange Server Analyzer controlla i dati ExMon relativi alle operazioni MAPI SetColumns eseguite dall'utente che impiegano più di 30 secondi per il completamento.

Viene creata una visualizzazione di base mediante la chiamata MAPI SetColumns. La chiamata a SetColumns consente di definire le proprietà corrispondenti alle colonne della nuova tabella di visualizzazione.

La prima volta che in una visualizzazione viene richiesta una proprietà, il server viene caricato di ulteriore lavoro per generare la visualizzazione. Una volta richiesta in una visualizzazione, la proprietà rimarrà disponibile per le visualizzazioni future. Ciò significa che la prima volta che si richiedono nuove proprietà, la chiamata a SetColumns può richiedere molto più tempo. Il tempo necessario è proporzionale al numero di nuove proprietà e al numero di elementi presenti nella cartella. Ad esempio, la prima volta che un utente visualizza la cartella Posta in arrivo dopo lo spostamento di una cassetta postale, il server impiegherà più tempo per generare la visualizzazione. Questo avviene poiché le visualizzazioni non vengono spostate insieme alla cassetta postale ma vengono ricreate.

L'aggiunta di proprietà alla visualizzazione è un'operazione molto costosa. Il costo per l'aggiunta delle proprietà è proporzionale al numero di elementi presenti nella cartella e al numero di proprietà aggiunte. L'utilizzo standard di Microsoft Office® Outlook® non prevede l'aggiunta di molte proprietà alla tabella delle cartelle dei messaggi, ma è possibile aggiungerne altre manualmente. Questo normalmente non rappresenta un problema. Tuttavia, possono verificarsi ritardi se un'applicazione aggiunge regolarmente colonne, aggiunge molte colonne o se un client aggiunge diverse colonne a molti elementi. Più colonne sono presenti nella tabella delle cartelle dei messaggi, maggiore è il sovraccarico che si aggiunge alle altre azioni eseguite sugli elementi delle cartelle. Se una colonna viene aggiunta, non sarà possibile rimuoverla. Ciascuna proprietà nella tabella delle cartelle dei messaggi aggiunge un sovraccarico all'inserimento di elementi nelle cartelle.

Se Exchange Server Analyzer determina che un'operazione MAPI SetColumns eseguita dall'utente ha impiegato oltre 30 secondi, verrà visualizzato un errore.

La prima volta che un utente accede alla propria cassetta postale dopo che è stata spostata in un nuovo database o un nuovo server, il server dovrà creare nuove visualizzazioni. In questo caso sono previste chiamate prolungate a SetColumns e Restrict. È possibile ignorare senza problemi questi errori per alcuni giorni dopo lo spostamento della cassetta postale.

Alcune applicazioni creano nuove visualizzazioni e innalzano il livello delle proprietà a strutture di dati di archiviazione interna. Questo può avere un effetto a lungo termine sulle prestazioni del server quando viene effettuato l'accesso ai dati dell'utente. Se l'utente o gli utenti identificati riscontrano ritardi frequenti o ritardi che influiscono negativamente sulle attività di messaggistica, è necessario capirne i motivi. Collaborare con l'utente che ha riscontrato l'alta latenza per determinare quanto segue:

  • Se il conteggio degli elementi nelle cartelle è elevato.

  • Quali applicazioni sono in esecuzione.

Per risolvere il problema, procedere come segue:

  • Incoraggiare gli utenti le cui cartelle contengono numerosi elementi a ridurre il numero di elementi per cartella. È consigliabile che il numero di elementi nelle cartelle Posta in arrivo, Calendario, Posta inviata, Contatti e Posta eliminata non sia superiore a 5.000.

  • Configurare i computer client più dispendiosi a livello operativo in modo che utilizzino la modalità cache di Exchange. Prestare ulteriore attenzione ai computer client con latenze lunghe nelle operazioni Restrict, SetColumns o FindRow. Tale modalità infatti isola il server dalla maggior parte del traffico RPC in eccesso.

  • Provare a chiudere tutte le applicazioni, quindi riaprirle una ad una per individuare quella che genera l'errore. Chiudere definitivamente le applicazioni che causano problemi o aggiornarle in modo da ridurre il carico a un livello ragionevole se esiste una delle seguenti condizioni:

    • L'applicazione non è necessaria per l'attività lavorativa.

    • È stato pubblicato un aggiornamento per l'applicazione.

Nota:
Alcune applicazioni possono produrre un incremento significativo del carico del server anche se non viene eseguito un numero elevato di operazioni MAPI. Ciò accade poiché alcune operazioni sono più costose di altre. A volte è sufficiente un lieve aumento del numero di operazioni dispendiose per determinare un impatto considerevole sulle prestazioni del server. In ExMon gli utenti che utilizzano tali applicazioni vengono indicati come responsabili di un forte impatto sulla CPU, senza che abbiano necessariamente eseguito molte operazioni MAPI.

Si osservi inoltre che quando si verifica un collo di bottiglia per le risorse (in genere un collo di bottiglia del disco o della CPU), le latenze delle operazioni SetColumns aumentano.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).

  • Articolo 905803 della Microsoft Knowledge Base, "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803


Operazione di sincronizzazione MAPI a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-23

Microsoft® Exchange Server Analyzer Tool utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Nell'ambito dell'analisi, Exchange Server Analyzer controlla i dati ExMon relativi alle operazioni di sincronizzazione MAPI eseguite dall'utente che impiegano più di 30 secondi per il completamento.

Le operazioni di sincronizzazione MAPI vengono eseguite per mantenere sincronizzato il file delle cartelle fuori rete di Microsoft Office® Outlook® (ost) o la copia locale della cassetta postale dell'utente con i dati della cassetta postale dell'utente sul server.

Non sempre le operazioni di sincronizzazione MAPI che impiegano oltre 30 secondi costituiscono un problema. Per impostazione predefinita, tutti i messaggi di posta elettronica memorizzati sul server di Exchange che rappresentano copie complete dell'Elenco indirizzi globale vengono scaricati sul computer dell'utente quando la modalità cache di Exchange viene abilitata per la prima volta in Outlook 2003.

Durante la sincronizzazione iniziale con il server di Exchange, gli utenti di Outlook 2003 possono riscontrare ritardi nelle risposte.

Se dopo la sincronizzazione all'avvio della modalità cache si verificano frequenti ritardi o se i ritardi si ripercuotono in maniera negativa sulle operazioni di messaggistica, è necessario verificare che non siano sintomatici di problemi di latenza più gravi come, ad esempio, colli di bottiglia nelle risorse.

Ogni volta che si verifica un collo di bottiglia per le risorse, in genere un collo di bottiglia del disco o della CPU, le latenze delle operazioni di sincronizzazione MAPI aumentano. Identificare i colli di bottiglia nelle risorse del server e aumentare la capacità delle risorse del server oppure spostare gli utenti su un server con un carico inferiore.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).

  • Articolo 905803 della Microsoft Knowledge Base, "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803


Operazione MAPI "TaskQ" a esecuzione prolungata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-20

Lo strumento Microsoft Exchange Analyzer utilizza lo Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server Exchange che funziona correttamente.

Nell'ambito dell'analisi, Exchange Server Analyzer controlla i dati ExMon relativi alle operazioni globali TaskQ MAPI eseguite dall'utente che impiegano più di 30 secondi per il completamento.

Le operazioni TaskQ sono attività asincrone eseguite fuori dal contesto di una chiamata RPC. Le operazioni TaskQ e TaskQ User Unknown sono attività eseguite su richiesta di Exchange e includono la manutenzione degli archivi. Le operazioni TaskQ User Known sono attività asincrone avviate dietro richiesta diretta dell'utente e includono la popolazione della cartella di ricerca, l'ordinamento e operazioni globali quali lo spostamento, la copia, l'eliminazione e il contrassegno di più messaggi in lettura.

Se Exchange Analyzer rileva che il completamento delle operazioni MAPI TaskQ ha impiegato oltre 30 secondi, verrà visualizzato un avviso.

Non sempre ciò indica un problema di prestazioni, in quanto le operazioni TaskQ impiegano di norma lunghi intervalli di tempo per il completamento.

Per risolvere il problema, procedere come segue:

  • Provare a utilizzare lo strumento ExMon per acquisire un campione di dati più ampio da analizzare tramite Exchange Server Analyzer. A causa dell'ampio volume di dati generato da Exchange, è consigliabile limitare il campione di raccolta dei dati a 30 minuti o meno.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale relativo alle prestazioni e alla scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).


Operazione a esecuzione prolungata dovuta a operazione MAPI "Restrict"
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-23

Microsoft® Exchange Server Analyzer utilizza lo strumento Exchange Server User Monitor (ExMon) per determinare se le operazioni MAPI dell'utente impiegano più tempo di quanto ragionevolmente previsto su un server che esegue Exchange Server che funziona correttamente.

Nell'ambito dell'analisi, Exchange Server Analyzer controlla i dati ExMon relativi alle operazioni MAPI Restrict eseguite dall'utente che impiegano più di 30 secondi per il completamento.

L'operazione MAPI Restrict viene utilizzata dalle applicazioni client per selezionare elementi che soddisfano determinati criteri. Il server crea una visualizzazione che in effetti è una tabella con il criterio associato detto restrizione. Se la visualizzazione ha un restrizione corrispondente già esistente, il server utilizza la visualizzazione esistente per soddisfare la richiesta dell'utente. Quest'ultima è un'operazione meno onerosa rispetto alla creazione di una nuova visualizzazione. Per impostazione predefinita, l'archivio memorizza nella cache solo 11 visualizzazioni per ogni cartella. Se viene richiesto di creare la dodicesima visualizzazione, la visualizzazione più vecchia memorizzata nella cache viene eliminata per creare la nuova visualizzazione. Le visualizzazioni aggiungono sovraccarico a tutte le azioni sugli elementi.

Se Exchange Server Analyzer rileva che un'operazione MAPI Restrict ha impiegato oltre 30 secondi, verrà visualizzato un messaggio di errore.

Non sempre le operazioni MAPI Restrict che impiegano oltre 30 secondi costituiscono un problema. Tuttavia, se l'utente o gli utenti riscontrano ritardi frequenti o con impatto negativo sulle sessioni di messaggistica, è possibile che l'applicazione utente stia causando la creazione di nuove visualizzazioni.

Per risolvere questo errore, collaborare con l'utente che ha riscontrato una latenza elevata per determinare quanto segue:

  • Se il conteggio degli elementi nelle cartelle è elevato.

  • Quali applicazioni sono in esecuzione.

Per risolvere il problema, procedere come segue:

  • Incoraggiare gli utenti le cui cartelle contengono numerosi elementi a ridurre il numero di elementi per cartella. È consigliabile che il numero di elementi nelle cartelle Posta in arrivo, Calendario, Posta inviata, Contatti e Posta eliminata non sia superiore a 5.000.

  • Configurare i computer client più dispendiosi a livello operativo in modo che utilizzino la modalità cache di Exchange. Prestare ulteriore attenzione ai computer client con latenze lunghe nelle operazioni Restrict, SetColumns o FindRow. Tale modalità infatti isola il server dalla maggior parte del traffico RPC in eccesso.

  • Per attivare l'analisi delle restrizioni del registro eventi, seguire le istruzioni fornite nel blog del team di Exchange menzionato nella sezione successiva. Quindi, attivare una per una le applicazioni utente per rilevare quale applicazione stia causando la restrizione a esecuzione prolungata.

  • Provare a chiudere tutte le applicazioni, quindi riaprirle una ad una per individuare quella che genera l'errore. Chiudere definitivamente le applicazioni che causano problemi o aggiornarle in modo da ridurre il carico a un livello ragionevole se esiste una delle seguenti condizioni:

    • L'applicazione non è necessaria per l'attività lavorativa.

    • È stato pubblicato un aggiornamento per l'applicazione.

Nota:
Alcune applicazioni possono produrre un incremento significativo del carico del server anche se non viene eseguito un numero elevato di operazioni MAPI. Ciò accade poiché alcune operazioni sono più costose di altre. A volte è sufficiente un lieve aumento del numero di operazioni dispendiose per determinare un impatto considerevole sulle prestazioni del server. In ExMon gli utenti che utilizzano tali applicazioni vengono indicati come responsabili di un forte impatto sulla CPU, senza che abbiano necessariamente eseguito molte operazioni MAPI.

Si osservi inoltre che quando si verifica un collo di bottiglia per le risorse (in genere un collo di bottiglia del disco o della CPU), le latenze delle operazioni Restrict aumentano.

Per ulteriori informazioni

Per ulteriori informazioni sull'operazione MAPI Restrict, consultare il blog del team di Microsoft Exchange "Putting the Restrictions on Restrictions" all'indirizzo http://go.microsoft.com/fwlink/?linkid=55098 (informazioni in lingua inglese).

Nota:
Il contenuto di ciascun blog e il relativo URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • "Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • "Exchange Server 2003 Performance: 10 Things to Think About" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460 (informazioni in lingua inglese).

  • Articolo 905803 della Microsoft Knowledge Base, "Riduzione delle prestazioni di Outlook in caso di utilizzo di cartelle contenenti numerosi elementi su un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803


File MAD.EXE mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


La porta NSPI MAD ha un valore inferiore a 5000.
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione TCP/IP NSPI Port per il servizio Supervisore sistema di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Se Exchange Server Analyzer rileva che TCP/IP NSPI Port è impostato su un valore inferiore a 5000 (decimale), verrà visualizzato un avviso.

Se è necessario impostare TCP/IP NSPI Port su un valore statico, si raccomanda di impostare un valore superiore a 5000. L'assegnazione di numeri di porta statici inferiori a 5000 potrebbe causare conflitti di porta con altri processi e provocare errori nell'elaborazione del servizio Supervisore sistema di Microsoft Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave del Registro di sistema TCP/IP NSPI port

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave TCP/IP NSPI Port e impostare il campo Dati valore su un valore intero superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il servizio Supervisore sistema di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui limiti di porta, consultare l'articolo 194952 della Microsoft Knowledge Base, "XADM: Limitazioni nelle porte mappate staticamente per Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)


La porta MAD RFR è stata sostituita manualmente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore della porta di riferimento della directory Supervisore sistema di Microsoft Exchange è stato sostituito manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Se Exchange Server Analyzer rileva che TCP/IP Port è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Il motivo più comune per cui questo valore viene configurato è quello di consentire ai client MAPI di connettersi a un server di Exchange situato sull'altro lato di un firewall. Questo scenario implica l'apertura di più porte su un firewall per consentire ai client Microsoft Office Outlook® 2003 di connettersi mediante MAPI a un server di Exchange, in genere tramite Internet. Questa configurazione è supportata. Per ulteriori informazioni sulla configurazione di client MAPI da connettere a Exchange con un firewall, consultare l'articolo 270836 della Microsoft Knowledge Base "Mapping statici delle porte in Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836. Se non si sta utilizzando questo scenario, rimuovere questa chiave del Registro di sistema.

L'implementazione consigliata per l'utilizzo di Outlook in modalità Corporate o Workgroup per connettersi a un server di Exchange tramite Internet consiste nell'utilizzare le funzioni RPC (Remote Procedure Call) su HTTP reperibili in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 e Windows® XP Professional. La modalità MAPI è stata precedentemente definita come modalità "Corporate" o "Workgroup".

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per rimuovere la chiave TCP/IP Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Eliminare il valore del Registro di sistema denominato TCP/IP Port.

  4. Uscire dall'editor del Registro di sistema e riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per distribuire RPC su HTTP

  1. Esaminare Scenari di distribuzione di RPC su HTTP in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare l'articolo 833401 della Microsoft Knowledge Base "Configurazione di chiamate RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Esaminare "Support WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


La porta MAD RFR ha un valore inferiore a 5000.
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione TCP/IP Port per il servizio Supervisore sistema di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

Se Exchange Server Analyzer rileva che TCP/IP Port è impostato su un valore inferiore a 5000 (decimale), verrà visualizzato un avviso.

Se è necessario impostare TCP/IP Port su un valore statico, si consiglia di impostarla su un valore appena superiore a 5000. L'assegnazione di numeri di porta statici inferiori a 5000 potrebbe causare conflitti di porta con altri processi e provocare errori nell'elaborazione del servizio Supervisore sistema di Microsoft Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave Porta TCP/IP del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave TCP/IP Port e impostare il campo Dati valore su un valore intero superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il servizio Supervisore sistema di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni delle porte, consultare l'articolo 194952 della Microsoft Knowledge Base 194952 "XADM: Limitazioni nelle porte mappate staticamente in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)


File MAPI32.DLL mancante dalla cartella bin
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File MAPI32.DLL mancante dalla cartella system32
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi né reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File MAPISTUB.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File MAPISP32.EXE mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Dimensione massima della cache ESE maggiore di 1,2 GB
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni DataBase Cache Size (DBCacheSize) dell'oggetto prestazioni DataBase per analizzare i dati delle prestazioni.

Il contatore di prestazioni DataBase Cache Size (DBCacheSize) indica la dimensione corrente della cache utilizzata dall'archivio. Se Exchange Server Analyzer rileva che il valore del contatore di prestazioni DataBase Cache Size (DBCacheSize) è maggiore di 307200 (1,2 GB), verrà visualizzato un messaggio di errore.

Questo errore indica che il valore dell'attributo msExchESEParamCacheSizeMax per l'oggetto Archivio informazioni di Microsoft Exchange (MSExchangeIS) è stato aumentato oltre il valore massimo consigliato di 307200 (1,2 GB).

La cache del database dell'archivio è denominata anche buffer ESE (Extensible Storage Engine). Le transazioni del database vengono memorizzate in questa cache prima di essere salvate nel database stesso.

In Exchange 2000 Server, un'ampia area della memoria virtuale utilizzata da Store.exe viene allocata per il buffer ESE. Exchange 2000 Server utilizza un valore predefinito specificato a livello di codice di 858 MB per questo buffer. In Exchange Server 2003 l'allocazione del buffer ESE è basata sulla presenza dell'opzione /3GB nel file Boot.ini. Se è presente l'opzione /3GB, il buffer ESE è regolato su 896 MB. Se l'opzione /3GB non è presente, il buffer ESE è regolato su 576 MB. La regolazione automatica è sempre utile, tuttavia può essere necessario ignorare questa funzione e impostare manualmente un valore più appropriato per il proprio ambiente.

È possibile regolare questo valore relativo alla memoria effettiva allocata su qualsiasi multiplo di 8.192 byte, tuttavia è consigliabile utilizzare solo un valore tra quelli indicati nella seguente tabella.

Valore consigliato | Memoria allocata | Commenti
147456 | 576 MB | Questo è il valore minimo consigliato. Non impostare su un valore inferiore. Questo valore è utile su server con memoria virtuale limitata e sui computer con Exchange Server 2003 in esecuzione su Microsoft Windows® 2000 Server, che non supporta l'opzione /3GB. Questo è il valore predefinito anche nei sistemi che non utilizzano l'opzione /3GB.
196608 | 768 MB | Questo valore è consigliato per i server con grandi quantità di memoria virtuale che generano frequentemente l'evento 9582.
219726 | 858 MB | Questo è il valore predefinito in Exchange 2000 Server ed è una buona soluzione da utilizzare nei sistemi che vengono aggiornati sul posto e che hanno grandi quantità di memoria virtuale.
229376 | 896 MB | Questo è il valore predefinito in Exchange Server 2003 ed è una buona soluzione da utilizzare nei nuovi sistemi, a meno che il registro eventi dell'applicazione indichi diversamente con la presenza di eventi 9582.
307200 | 1,2 GB | Questo è il valore massimo configurabile. Questo valore dovrebbe essere utilizzato in sistemi con almeno 2 GB di memoria fisica.

Prima di riconfigurare questo valore, è consigliabile verificare la quantità di memoria virtuale utilizzata dal processo Store.exe. È possibile eseguire questa operazione verificando l'oggetto Prestazione processo di Microsoft Windows. Nei sistemi che utilizzano l'opzione /3GB, il valore del contatore Virtual Bytes per l'istanza Store.exe dell'oggetto Process deve essere inferiore a 2,8 GB. Nei sistemi che non utilizzano l'opzione /3GB, il valore del contatore Virtual Bytes per l'istanza Store.exe dell'oggetto Process deve essere inferiore a 1,8 GB. Se i valori sono superiori a quelli indicati, può essere necessario ridurre il valore di msExchESEParamCacheSizeMax. Se i valori sono inferiori, può essere necessario aumentare il valore di msExchESEParamCacheSizeMax.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory® quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per regolare l'attributo msExchESEParamCacheSizeMax

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione.

  3. Espandere la struttura CN=Services.

  4. Espandere la struttura CN=Microsoft Exchange.

  5. Espandere la struttura CN=<Nome organizzazione di Exchange>.

  6. Espandere la struttura CN=Administrative Groups.

  7. Espandere la struttura CN=<Nome gruppo amministrativo>.

  8. Espandere la struttura CN=Servers.

  9. Espandere la struttura CN=<Nome server di Exchange>.

  10. Fare clic con il pulsante destro del mouse su CN=InformationStore, quindi scegliere Proprietà.

  11. Nel campo degli attributi scorrere e fare doppio clic su msExchESEParamCacheSizeMax.

  12. Nel campo Valore digitare il valore che si desidera impostare. Utilizzare la tabella per determinare il valore ottimale del sistema.

  13. Fare clic su OK, quindi nuovamente su OK.

  14. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'ottimizzazione dell'utilizzo della memoria, consultare "Ottimizzazione dell'utilizzo della memoria" in Pianificazione di un sistema di messaggistica Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47584.

Per ulteriori informazioni sull'attributo msExchESEParamCacheSizeMax, consultare l'articolo 266768 della Microsoft Knowledge Base "Modifica della dimensione massima della cache nel database dell'archivio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768.


Il limite massimo dei destinatari è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchRecipLimit è stato modificato rispetto al valore predefinito. Il valore per il numero massimo globale dei destinatari per ciascun messaggio di posta elettronica è archiviato nell'attributo msExchRecipLimit. Per impostazione predefinita, il valore dell'attributo msExchRecipLimit è 5000. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchRecipLimit è diverso da 5000, verrà visualizzato un messaggio di configurazione non predefinita.

Il limite massimo globale dei destinatari si applica all'intera organizzazione di Exchange. Il valore dell'attributo msExchRecipLimit consente di limitare il numero di destinatari per un singolo messaggio di posta elettronica. Il limite massimo globale dei destinatari influisce sui messaggi di sistema e su quelli non di sistema. I messaggi di sistema includono i messaggi di replica della cartella pubblica.

Nota:
È inoltre possibile impostare i limiti per i destinatari in base a ciascun utente mediante lo strumento Utenti e computer di Active Directory. L'impostazione per utente ha la precedenza sull'impostazione globale, che verrà ignorata. Per impostazione predefinita, il limite dei destinatari per utente è configurato per utilizzare il limite massimo globale di destinatari.
Nota:
Su un server virtuale SMTP è possibile impostare un limite al numero di destinatari per messaggio per i messaggi ricevuti da utenti di Internet. Tale limite è diverso dal limite massimo globale dei destinatari e dal limite dei destinatari per utente. Il limite massimo globale dei destinatari e il limite dei destinatari per utente consentono di limitare il numero di destinatari a cui un utente di Exchange può inviare un messaggio.
Per impostare il limite massimo globale dei destinatari sul valore predefinito

  1. Avviare Gestore di sistema di Exchange.

  2. Nel riquadro sinistro espandere Impostazioni globali.

  3. Fare clic con il pulsante destro del mouse su Recapito messaggi, quindi scegliere Proprietà.

  4. Nella scheda Valori predefiniti in Limite numero destinatari fare clic su Limite massimo e digitare 5000.

  5. Riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'impostazione dei limiti dei destinatari e sulla configurazione dei client Microsoft Office Outlook® Web Access, consultare "Impostazioni di Outlook Web Access con controllo S/MIME" nella Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47574.

Per ulteriori informazioni sulla cronologia del limite massimo dei destinatari, consultare l'articolo del blog Web di Exchange "Me Too!" (all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41848 (informazioni in lingua inglese).


Il limite massimo dei destinatari è alto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore msExchRecipLimit per i messaggi è maggiore di 7500. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchRecipLimit è maggiore di 7500, verrà visualizzato un avviso.

Il valore per il numero massimo globale dei destinatari per ciascun messaggio di posta elettronica è archiviato nell'attributo msExchRecipLimit. Il valore consente di limitare il numero di destinatari per un singolo messaggio di posta elettronica. Inoltre, influenza i messaggi di sistema e quelli non di sistema. I messaggi di sistema includono i messaggi di replica della cartella pubblica. Per impostazione predefinita, il valore dell'attributo msExchRecipLimit è 5000.

Se il valore dell'attributo msExchRecipLimit è maggiore di 7500, potrebbe aumentare il rischio di problemi provocati da messaggi con molti destinatari.

Nota:
È inoltre possibile impostare i limiti per i destinatari in base a ciascun utente mediante lo strumento Utenti e computer di Active Directory. L'impostazione per utente ha la precedenza sull'impostazione globale, che verrà ignorata. Per impostazione predefinita, il limite dei destinatari per utente è configurato per utilizzare il limite massimo globale di destinatari.
Nota:
Su un server virtuale SMTP è possibile impostare un limite al numero di destinatari per messaggio per i messaggi ricevuti da utenti di Internet. Tale limite è diverso dal limite massimo globale dei destinatari e dal limite dei destinatari per utente. Il limite massimo globale dei destinatari e il limite dei destinatari per utente consentono di limitare il numero di destinatari a cui un utente di Exchange può inviare un messaggio.
Per impostare il limite massimo globale dei destinatari sul valore predefinito

  1. Avviare Gestore di sistema di Exchange.

  2. Nel riquadro sinistro espandere Impostazioni globali.

  3. Fare clic con il pulsante destro del mouse su Recapito messaggi, quindi scegliere Proprietà.

  4. Nella scheda Valori predefiniti in Limite numero destinatari fare clic su Limite massimo e digitare 5000.

  5. Riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'impostazione dei limiti dei destinatari e sulla configurazione dei client Microsoft Office Outlook® Web Access, consultare "Impostazioni di Outlook Web Access con controllo S/MIME" nella Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47574.

Per ulteriori informazioni sulla cronologia del limite massimo globale dei destinatari, consultare l'articolo del blog Web di Exchange "Me Too!" (all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41848 (informazioni in lingua inglese).


Il limite massimo dei destinatari è troppo basso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore msExchRecipLimit relativo ai messaggi è inferiore al numero di archivi di cartelle pubbliche presenti nell'organizzazione di Exchange. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchRecipLimit è inferiore al numero di archivi di cartelle pubbliche, verrà visualizzato un messaggio di errore.

Il valore per il numero massimo globale dei destinatari per ciascun messaggio di posta elettronica è archiviato nell'attributo msExchRecipLimit. Il valore consente di limitare il numero di destinatari per un singolo messaggio di posta elettronica. Inoltre, influenza i messaggi di sistema e quelli non di sistema. I messaggi di sistema includono i messaggi di replica della cartella pubblica. Per impostazione predefinita, il valore dell'attributo msExchRecipLimit è 5000. Se il valore dell'attributo msExchRecipLimit è minore del numero di archivi di cartelle pubbliche nell'organizzazione di Exchange, si verificheranno dei problemi con la replica della gerarchia di cartelle pubbliche.

Nota:
È inoltre possibile impostare i limiti per i destinatari in base a ciascun utente mediante lo strumento Utenti e computer di Active Directory. L'impostazione per utente ha la precedenza sull'impostazione globale, che verrà ignorata. Per impostazione predefinita, il limite dei destinatari per utente è configurato per utilizzare il limite massimo globale di destinatari.
Nota:
Su un server virtuale SMTP (Simple Mail Transfer Protocol) è possibile impostare un limite al numero di destinatari per messaggio per i messaggi ricevuti da utenti di Internet. Tale limite è diverso dal limite massimo globale dei destinatari e dal limite dei destinatari per utente. Il limite massimo globale dei destinatari e il limite dei destinatari per utente consentono di limitare il numero di destinatari a cui un utente di Exchange può inviare un messaggio.
Per impostare il limite massimo globale dei destinatari sul valore predefinito

  1. Avviare Gestore di sistema di Exchange.

  2. Nel riquadro sinistro espandere Impostazioni globali.

  3. Fare clic con il pulsante destro del mouse su Recapito messaggi, quindi scegliere Proprietà.

  4. Nella scheda Valori predefiniti in Limite numero destinatari fare clic su Limite massimo e assicurarsi che il valore non sia minore del numero di archivi di cartelle pubbliche nell'organizzazione di Exchange.

  5. Riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'impostazione dei limiti dei destinatari e sulla configurazione dei client Microsoft Office Outlook® Web Access, consultare "Impostazioni di Outlook Web Access con controllo S/MIME" nella Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47574.

Per ulteriori informazioni sulla cronologia del limite massimo globale dei destinatari, consultare l'articolo del blog Web di Exchange "Me Too!" (all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41848 (informazioni in lingua inglese).


Chiave MaxUserPort mancante o non predefinita
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-23

Lo strumento Microsoft Exchange Analyzer esegue query nel servizio directory di Active Directory per determinare il valore dell'attributo serialNumber per tutti gli oggetti con classe oggetto msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Exchange Server 2003. Se la stringa comprende "Version 8.0", il computer esegue Exchange Server 2007.

Lo strumento Exchange Analyzer legge quindi il ramo del Registro di sistema seguente per ogni server di Exchange Server 2007 rilevato, allo scopo di determinare se il valore della chiave MaxUserPort è impostato sul valore predefinito, ovvero su 60000.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

La chiave MaxUserPort determina il numero di porta massimo che può essere assegnato dal protocollo TCP quando il sistema richiede una porta utente disponibile.

Per impostazione predefinita, in Microsoft Windows Server 2003 il valore MaxUserPort è impostato su 5000. In Microsoft Windows 2000, il valore MaxUserPort non viene aggiunto al Registro di sistema. Tale valore può comunque essere aggiunto manualmente. Tuttavia, per Exchange Server 2003 ed Exchange Server 2007 in esecuzione su Windows Server 2003 e su Windows 2000 Server, il valore predefinito è impostato su 60000. In Exchange 2000 Server non viene impostato alcun valore.

Si consiglia di impostare il valore MaxUserPort su 60000. Se si imposta il valore MaxUserPort su un numero minore di 60000, si potrebbero generare messaggi di avviso del proxy NSPI, quale, ad esempio, l'evento 9040 descritto nella seguente tabella:

ID evento | 9040
Categoria evento | Proxy NSPI
Origine evento | MSExchangeSA
Tipo di evento | Avviso
Descrizione dell'evento | Il proxy NSPI ha rilevato un errore durante le ricezione di un pacchetto. Il controller di dominio di destinazione, la rete oppure un client potrebbero essere inattivi. Il sottosistema Winsock ha restituito l'errore:[0x2746]. Il circuito che ha ricevuto l'errore verrà chiuso.
Importante:
Questo argomento contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di aver compreso a fondo come ripristinarlo in caso di problemi. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, ad esempio Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Fare doppio clic su MaxUserPort, impostare il campo Dati valore su 60000 (decimale), quindi fare clic su OK.

  4. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Il problema è correlato al problema di Analyzer La chiave TcpTimedWaitDelay è mancante o non predefinita.

Per ulteriori informazioni sull'effetto delle chiavi del Registro di sistema MaxUserPort e TcpTimedWaitDelay, vedere l'argomento relativo al protocollo di controllo trasmissioni del Resource Kit di Windows 2000 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=85654.


Il valore MaxUserPort è troppo basso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare il valore massimo della porta TCP temporanea:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\MaxUserPort

Una porta temporanea è una porta che viene utilizzata per un breve periodo di tempo.

Se Exchange Server Analyzer rileva che il valore della chiave MaxUserPort del Registro di sistema è minore di 50000, verrà visualizzato un avviso.

Il valore MaxUserPort specifica il numero di porta massimo che può essere assegnato dal protocollo TCP quando viene richiesta una porta utente disponibile. In genere, alle porte temporanee viene assegnato un numero di porta compreso tra 1024 e 5000.

Per impostazione predefinita, in Microsoft Windows Server™ 2003 il valore MaxUserPort è impostato su 5000. In Microsoft Windows® 2000 il valore MaxUserPort non viene aggiunto al Registro di sistema. È possibile aggiungere manualmente il valore MaxUserPort al Registro di sistema. Tuttavia, per Exchange Server 2003 in esecuzione su Windows Server 2003 e su Windows 2000 Server, il valore predefinito è impostato su 60000. In Exchange 2000 Server non viene impostato alcun valore.

Si consiglia di impostare il valore MaxUserPort su 60000. Se si imposta il valore MaxUserPort su un numero minore di 60000, potrebbero essere generare messaggi di avviso del proxy NSPI, quali, ad esempio, l'evento 9040 descritto nella seguente tabella.

ID evento | 9040
Categoria evento | Proxy NSPI
Origine evento | MSExchangeSA
Tipo di evento | Avviso
Descrizione dell'evento | Il proxy NSPI ha rilevato un errore durante le ricezione di un pacchetto. Il controller di dominio di destinazione, la rete oppure un client potrebbe essere inattivo. Il sottosistema Winsock ha restituito l'errore:[0x2746]. Il circuito che ha ricevuto l'errore verrà chiuso.

Per risolvere il problema, impostare il valore della chiave MaxUserPort del Registro di sistema su 60000.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. Fare doppio clic su MaxUserPort, impostare il campo Dati valore su ea60 (esadecimale), quindi fare clic su OK.

  4. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


File MDBSZ.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per risolvere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente della versione di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità Reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange, fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


L'oggetto Performance Monitor Memory non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Available Mbytes dell'oggetto prestazioni Memory per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni Memory è disabilitato.

  • L'oggetto Performance Monitor Memory non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestazione.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®).

Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni Memory sia abilitato:

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina Exctrlst.exe: Extensible Performance Counter List all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base "Ricreazione manuale dei valori della libreria dei contatori delle prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


L'oggetto Performance Monitor dei processi MSExchangeDSAccess non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni LDAP Read Time dell'oggetto prestazioni MSExchangeDSAccess per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni MSExchangeDSAccess è disabilitato.

  • L'oggetto Performance Monitor MSExchangeDSAccess non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestaizone.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Nella procedura seguente viene illustrato come correggere le prime due condizioni. Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni.

Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni MSExchangeDSAccess sia abilitato:

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina Exctrlst.exe: Extensible Performance Counter List all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base, "Ricostruzione manuale dei valori della Libreria dei contatori di prestazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


L'oggetto Performance Monitor MSExchangeIS Mailbox non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Send Queue Size dell'oggetto prestazioni MSExchangeIS Mailbox per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni MSExchangeIS Mailbox è disabilitato.

  • L'oggetto Performance Monitor MSExchangeIS Mailbox non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestazione.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®).

Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni MSExchangeIS Mailbox sia abilitato:

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina Exctrlst.exe: Extensible Performance Counter List all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base "Ricreazione manuale dei valori della libreria dei contatori delle prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


L'oggetto Performance Monitor MSExchangeIS non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-03

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni RPC Operations/sec dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni MSExchangeIS è disabilitato.

  • L'oggetto Performance Monitor MSExchangeIS non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestazione.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni MSExchangeIS sia abilitato:

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina Exctrlst.exe: Extensible Performance Counter List all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base "Ricreazione manuale dei valori della libreria dei contatori delle prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività di Exchange Server Best Practices Analyzer Tool, consultare "Risoluzione dei problemi di connettività di Microsoft Exchange Server Best Practices Analyzer Tool" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285.


L'oggetto Performance Monitor MSExchangeIS Public non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Send Queue Size dell'oggetto prestazioni MSExchangeIS Public per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni MSExchangeIS Public è disabilitato.

  • L'oggetto Performance Monitor MSExchangeIS Public non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestazione.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni MSExchangeIS Public sia abilitato:

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina Exctrlst.exe: Extensible Performance Counter List all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base "Ricreazione manuale dei valori della libreria dei contatori delle prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


Aggiornamento del driver MSGINA.DLL disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di Microsoft Windows® in esecuzione sul server di Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il server di Exchange esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il server di Exchange esegue Microsoft Windows 2000 Server. Il valore 5.2 indica che il server di Exchange esegue Windows Server™ 2003.

Exchange Server Analyzer Tool esamina inoltre la classe Microsoft WMI (Strumentazione gestione Windows) Win32_OperatingSystem per determinare il valore della chiave ServicePackMajorVersion.

Il valore 1 della chiave ServicePackMajorVersion indica che nel server è installato Service Pack 1 (SP1).

Infine, Exchange Server Analyzer esegue una query nella classe WMI CIM_Datafile per determinare il valore della chiave Version per il file Msgina.dll.

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • Nel server è in esecuzione Windows Server™ 2003 SP1.

  • Il numero di build del file Msgina.dll è precedente a 5.2.3790.2525.

L'errore indica che la versione del file Msgina.dll installata nel server potrebbe causare un'attività eccessiva del file di paging e una riduzione delle prestazioni.

Per risolvere il problema, eseguire l'aggiornamento menzionato nell'articolo 905865 della Microsoft Knowledge Base "Le dimensioni dei working set di tutti i processi in una sessione della console possono essere tagliati quando si utilizza Terminal Services per eseguire l'accesso o la disconnessione da un computer che esegue Windows Server 2003" http://go.microsoft.com/fwlink/?linkid=3052&kbid=905865.


Parametro MTA APDU logging required non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\APDU logging required

Se Exchange Server Analyzer rileva che il valore di APDU logging required è presente e impostato su qualsiasi altro valore diverso da 0, verrà visualizzato un messaggio di configurazione non predefinita.

I file di registro APDU (Application Protocol Data Unit) sono rappresentazioni binarie delle comunicazioni tra agenti di trasferimento messaggi (MTA, Message Transfer Agents) Exchange in diversi siti e tra MTA e applicazioni client all'interno di un sito. I registri APDU costituiscono uno strumento utile per diagnosticare eventuali problemi con i MTA. Tuttavia, essi sono utili solo agli utenti che hanno una certa familiarità con le traduzioni ASCII del protocollo X.400.

Quando il parametro APDU logging required del Registro di sistema è presente e impostato sul valore 0, tutti gli APDU inviati o ricevuti dai MTA vengono registrati come dati binari in MTADATA\BF*.LOG.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione APDU logging predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro a destra, individuare e fare doppio clic sul valore APDU logging required.

  4. Nel campo Dati valore inserire 0 e scegliere OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui registri APDU, consultare l'articolo 163324 della Microsoft Knowledge Base "XCON: Registri APDU (Application Protocol Data Unit) (BF0.LOG)" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=163324.


Parametro MTA Call-stack diagnostics required non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Call-stack diagnostics required

Se Exchange Server Analyzer rileva che il valore di Call-stack diagnostics required è presente e non impostato su 1, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore del Registro di sistema Call-stack diagnostics required è utilizzato per operazioni avanzate di debug è può essere letto solo da una versione debug dell'MTA. I dati di valore relativi dovrebbero sempre essere impostati su 1. Quando viene utilizzata una versione debug dell'MTA, questo valore offre uno stack chiamate per ciascun thread MTA al momento della chiusura.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro a destra, individuare e fare doppio clic sul valore Call-stack diagnostics required.

  4. Nel campo Dati valore inserire 1 e scegliere OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Nome computer MTA non corrispondente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione del valore MTA Computer: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo name per ciascun oggetto di Exchange Server.

Infine, Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster (ClusSvc). Il valore True indica che il servizio cluster è avviato, mentre il valore False indica che non è in esecuzione.

Se Exchange Server Analyzer rileva che il valore della chiave MTA Computer non corrisponde al valore dell'attributo name dell'oggetto server in Active Directory per i computer Exchange Server non eseguiti in un cluster di Windows Server, verrà visualizzato un messaggio di errore.

Per correggere questo errore, è necessario modificare la chiave MTA Computer del Registro di sistema affinché corrisponda al valore dell'attributo name in Active Directory.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro fare doppio clic su MTA Computer immettere il nome corretto per questo computer, quindi fare clic su OK.

  4. Uscire dall'editor del Registro di sistema e riavviare il computer Exchange Server per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA Concurrent connections to LAN-MTAs non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to LAN-MTAs

Se Exchange Server Analyzer rileva che il valore Concurrent connections to LAN-MTAs è presente ed è uguale a qualsiasi altro valore diverso da 0x28 (esadecimale) o 40 (decimale), verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Concurrent connections to LAN-MTAs del Registro di sistema determina il numero massimo di connessioni contemporanee agli agenti di trasferimento messaggi (MTA, Message Transfer Agent) sulla rete LAN. Gli MTA che comunicano mediante LAN sono noti come LAN-MTA. L'MTA locale può disporre di più connessioni a un MTA remoto, in base alla configurazione e al caricamento del sistema. Il numero massimo di connessioni contemporanee MTA basate su LAN è 240.

Importante:
Questo articolo contiene informazioni sulla modifica al Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione delle connessioni contemporanee MTA predefinite

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro a destra, individuare il valore Concurrent connections to LAN-MTAs e fare doppio clic su di esso.

  4. Verificare che Base sia impostato su esadecimale, immettere 28 nel campo Dati valore e fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul numero massimo di connessioni contemporanee agli MTA sulla rete LAN, consultare l'articolo 243402 della Microsoft Knowledge Base "XCON: "ID evento MTA di Exchange Server 9280" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=243402.


Parametro MTA Concurrent connections to X.400 gateways non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent connections to X.400 gateways

Se Exchange Server Analyzer rileva che il valore di Concurrent connections to X.400 gateways è presente ed è impostato su un valore diverso da 6, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Concurrent connections to X.400 gateways del Registro di sistema rappresenta il numero massimo di connessioni contemporanee a MTA X.400 remoti. Il valore predefinito 6 è sufficiente per la maggior parte delle organizzazioni. Si verifica un problema noto quando si utilizzano più di 4 connettori EDK su un server che esegue Microsoft® Exchange Server 5.5 per il quale è necessario aumentare il valore di Concurrent connections to X.400 gateways a 0x12 (esadecimale) o a 18 (decimale). Per ulteriori informazioni su questo problema, consultare l'articolo 282115 della Microsoft Knowledge Base "Se vengono installati più di 4 connettori EDK Exchange, il flusso di posta si interrompe" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=282115. A meno che non venga riscontrato il problema illustrato nel suddetto articolo, è opportuno lasciare il valore Concurrent connections to X.400 gateways del Registro di sistema impostato su 6.

Per risolvere questo problema, ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore Concurrent connections to X.400 gateways e fare doppio clic su di esso.

  4. Nel campo Dati valore inserire 6, quindi scegliere OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA Concurrent MDB/delivery queue clients non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Concurrent MDB/delivery queue clients

Se Exchange Server Analyzer rileva che il valore Concurrent MDB/delivery queue clients è presente ed è uguale a qualsiasi altro valore diverso da 3, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Concurrent MDB/delivery queue clients rappresenta il numero massimo di client con coda di recapito MDB (Messaging Database) e XAPI (Exchange Application Program Interface) che l'MTA può supportare. Ciascun client può avere più di una sessione. Questo valore deve essere impostato almeno su 2 per supportare entità MDB private e pubbliche.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro a destra, individuare e fare doppio clic sul valore Concurrent MDB/delivery queue clients.

  4. Nel campo Dati valore inserire 3 e scegliere OK.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Scrittura dei file di dati dell'MTA in una cartella compressa
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Compressed per il percorso dati dell'Agente di trasferimento messaggi (MTA). Se Exchange Server Analyzer determina che il valore della chiave Compressed è True, verrà visualizzato un messaggio di errore.

Microsoft non supporta la memorizzazione dei file di dati di Exchange in un volume di file system NTFS compresso. Quando si archiviano i file di dati di Exchange in un volume compresso, l'overhead aggiuntivo influenza in modo significativo le prestazioni di Exchange. Inoltre, quando un database dell'archivio Exchange raggiunge una determinata dimensione (circa 4 GB), potrebbe presentare problemi di installazione o essere danneggiato.

I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

I file gestiti da Extensible Storage Engine (ESE) non sono progettati per l'archiviazione in un'unità compressa. L'Extensible Storage Engine dipende dall'indipendenza dei settori per il ripristino basato su log e la compressione dei file invalida tale indipendenza. La compressione non deve essere attivata per i volumi che ospitano database ESE o altri database che utilizzano la registrazione write-ahead.

Prima di Exchange 2000 Server Service Pack 3, era possibile installare database dell'archivio Exchange compressi. Tuttavia, i registri e i database dell'archivio Exchange di Exchange 2000 compressi mediante la compressione NTFS possono risultare danneggiati.

Con Exchange 2000 Server Service Pack 3, i file di database dell'archivio informazioni compressi di dimensione pari o inferiore a 128 MB vengono decompressi automaticamente. Se la dimensione dei file di database diventa maggiore di 128 MB, il database non verrà installato e nel Registro applicazione verranno generati messaggi di errore. Exchange 2000 Server Service Pack 3 impedisce l'installazione dei database compressi di dimensioni superiori a 128 MB.

Per disattivare la compressione dei file in una specifica cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

Per cambiare la posizione dei file di database MTA

  1. Su Exchange Server 5.5 è possibile eseguire questa operazione utilizzando lo strumento Performance Optimizer. Per ulteriori informazioni su come eseguire questa operazione su Exchange 2000 Server o Exchange Server 2003, consultare l'articolo 259896 della Microsoft Knowledge Base "XCON: Modifica del percorso del database MTA e della directory di esecuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=259896.

Per ulteriori informazioni sui file di dati di Exchange e sulla compressione NTFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 170009, "XADM: La compressione NTFS del volume provoca errori nell'archivio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009.

  • 327772, "XADM: Non è possibile installare il database e viene restituito l'errore 0xfffff05b dopo l'applicazione del SP3" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772.


Scrittura dei file di dati dell'MTA in una cartella crittografata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Encrypted per il percorso dati dell'Agente di trasferimento messaggi (MTA). Se Exchange Server Analyzer rileva che il valore di questa chiave è True, verrà visualizzato un messaggio di errore.

In un computer che esegue Exchange 2000 Server o Exchange Server 2003, i file dell'MTA vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Exchsrvr\MTAdata

Microsoft non supporta l'archiviazione dei file di dati di Exchange in un volume crittografato EFS (Encrypting File System). Quando si archiviano i file di dati di Exchange in un volume crittografato, l'overhead aggiuntivo influenza in modo significativo le prestazioni di Exchange. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per proteggere i file di dati di Exchange, è consigliabile impedire l'accesso non autorizzato al computer che esegue Exchange e utilizzare il formato messaggio S/MIME per crittografare i dati dei messaggi.

Per disattivare la crittografia dei file in una cartella specifica

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Crittografa contenuto per la protezione dei dati e scegliere OK.

Per ulteriori informazioni sui file di dati di Exchange Server ed EFS (Encrypting File System, Crittografia file system), consultare l'articolo 834638 della Microsoft Knowledge Base "Informazioni sull'archiviazione dei file di dati in un volume crittografato in Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Per informazioni sulle modalità di protezione dei messaggi in Exchange Server 2003, consultare la Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47574.


Scrittura dei file di dati dell'MTA in una partizione non NTFS
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave FSName per la cartella dati dell'Agente di trasferimento messaggi (MTA) Exchange. Se Exchange Server Analyzer determina che il valore per la chiave FSName non è uguale a NTFS, verrà visualizzato un messaggio di errore.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in volumi non NTFS. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Se viene riscontrato questo errore, sarà necessario spostare la cartella dati MTA in un'unità NTFS. In alternativa, se l'unità in cui è memorizzata la cartella dei dati MTA è formattata come unità FAT (File Allocation Table, tabella di allocazione file), sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertirla in unità NTFS.

Per spostare la cartella mtadata di Exchange

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo e Server, fare clic con il pulsante destro del mouse sul gruppo di archiviazione e scegliere Proprietà.

  3. Nella pagina delle proprietà del gruppo di archiviazione, accanto al campo Posizione percorso di sistema, fare clic su Sfoglia.

  4. Digitare il nuovo percorso della cartella mtadata e fare clic su OK.

  5. Fare clic su OK.

In alternativa a questa procedura, se l'unità in cui sono archiviati i file è formattata come un'unità FAT, è possibile utilizzare lo strumento della riga di comando convert.exe per convertirla in unità NTFS. Per ulteriori informazioni sull'utilizzo dello strumento della riga di comando convert.exe per convertire una partizione FAT in una partizione NTFS, consultare l'articolo 214579 della Microsoft Knowledge Base: "Utilizzo di Convert.exe per convertire una partizione nel file system NTFS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579.


Parametro MTA DB data buffers per object non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB data buffers per object

Se Exchange Server Analyzer rileva che il valore relativo a DB data buffers per object è presente e maggiore di zero ma non impostato su 3 o 6, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore DB data buffers per object rappresenta il numero di buffer da 4 KB del server database configurati per ciascun oggetto di database. Un numero più elevato di buffer richiede una maggiore quantità di memoria, ma riduce le possibilità di roll-out su disco di un oggetto di database a causa di una mancanza di spazio del buffer. Un caso in cui è opportuno modificare questo valore è quando un Agente di trasferimento messaggi (MTA) comunica con più computer che eseguono Exchange Server 5.5 all'interno di un sito o tra diversi siti. Si consiglia di modificare il valore in 6. Se l'MTA non soddisfa questo criterio, è preferibile riportare il valore all'impostazione predefinita di 3.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore DB data buffers per object e fare doppio clic su di esso.

  4. Nel campo Dati valore inserire 3, quindi scegliere OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA DB file handles non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\DB file handles

Se Exchange Server Analyzer rileva che il valore di DB file handles è presente e non impostato su 192, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore DB file handles rappresenta il numero di handle di file del server database configurati. Questo valore determina il numero massimo di file di database che possono essere aperti simultaneamente. Se sono necessari più file aperti rispetto al valore configurato, gli oggetti di database verranno copiati su disco.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore DB file handles e fare doppio clic su di esso.

  4. Nel campo Dati valore inserire 192 e scegliere OK.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il livello di registrazione diagnostica dell'MTA è maggiore di 5 (l'MTA è in modalità debug)
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge una serie di chiavi del Registro di sistema per determinare il livello di registrazione dell'Agente di trasferimento messaggi (Diagnostica MTA) impostato nel server di Exchange. Il percorso delle chiavi del Registro di sistema è:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

Il valore predefinito per queste chiavi è 0. Se Exchange Server Analyzer rileva che il valore di queste chiavi è maggiore di 5, verrà visualizzato un messaggio di errore.

Queste chiavi del Registro di sistema vengono impostate da Gestore di sistema di Exchange quando vengono regolati i livelli di registrazione nella scheda Registrazione diagnostica della pagina delle proprietà di un server specifico. Gestore di sistema di Exchange consente a un amministratore di impostare uno specifico livello di registrazione su Nessuno, Minimo, Medio e Massimo. I corrispondenti valori delle chiavi del Registro di sistema sono rispettivamente 0, 1, 3 o 5.

Pertanto, un valore maggiore di 5 può essere impostato solo modificando manualmente il Registro di sistema ed è preferibile impostarlo su questo livello solo durante gli orari di scarso traffico per eseguire brevi operazioni di debug e risoluzione dei problemi. L'impostazione di queste chiavi su numeri interi maggiori di 5 aumenta la registrazione a livelli di debug, richiedendo un utilizzo intensivo delle risorse. Oltre alla registrazione a livelli di debug, l'impostazione di queste chiavi su valori maggiori di 5 comporta la creazione, a intervalli di pochi secondi, di file di traccia di debug "call.out" di circa 40 MB. In questo modo, il registro eventi del computer viene riempito in meno di un minuto.

Nella seguente tabella sono mostrate le categorie di registrazione MTA così come sono elencate nella scheda Registrazione diagnostica nel Gestore di sistema di Exchange e i corrispondenti nomi delle chiavi nel Registro di sistema.

Categoria visualizzata nel Gestore di sistema di Exchange | Nome chiave del Registro di sistema corrispondente
Servizio X.400 | 1 X.400 Service
Risorsa | 2 Resource
Protezione | 3 Security
Interfaccia | 4 Interface
Progettazione campo | 5 Field Engineering
Amministrazione MTA | 6 MTA Administration
Configurazione | 7 Configuration
Accesso alla directory | 8 Directory Access
Sistema operativo | 9 Operating System
Elaborazione interna | 10 Internal Processing
Interoperabilità | 11 Interoperability
APDU (Application Protocol Data Unit) | 12 APDU

Nel riferimento alla fine del presente articolo sono contenute maggiori informazioni sugli eventi registrati in ciascuna categoria MTA.

È consigliabile impostare la registrazione per ciascuna categoria MTA su Nessuno (0) a meno che non si stiano risolvendo attivamente dei problemi. Il motivo di questo suggerimento consiste nel mantenere un numero gestibile di eventi registrati. Anche un livello pari a Minimo (1) potrebbe generare centinaia di registri eventi in pochi giorni, a seconda della categoria in cui viene impostato il livello.

Se non si stanno risolvendo problemi, è probabile che questi valori siano stati impostati su un livello più alto durante un'esercitazione sulla risoluzione dei problemi e che siano rimasti inavvertitamente impostati in tal modo. È necessario impostare questi valori almeno su Massimo (5), ma è preferibile impostare il livello di registrazione su Nessuno (0) per ciascuna categoria di Registrazione diagnostica MTA a meno ce non si stiano risolvendo attivamente dei problemi.

Per impostare le categorie di Registrazione diagnostica MTA su Nessuno

  1. Avviare Gestore di sistema di Exchange: fare clic su Start, scegliere Tutti i programi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nella struttura della console espandere Server, il server desiderato, quindi fare clic su Proprietà.

  3. In <Proprietà> Server selezionare la scheda Registrazione diagnostica.

  4. Nella sezione Servizi scegliere MSExchangeMTA.

  5. Per ciascuna voce presente in Categorie impostare il livello di registrazione su Nessuno selezionando la categoria e scegliendo Nessuno in Livello di registrazione.

  6. Una volta impostate tutte le categorie su Nessuno, fare clic su Applica, quindi scegliere OK.

Per ulteriori informazioni sulla Registrazione diagnostica MTA in Exchange 2000 Server e Exchange Server 2003, consultare l'articolo 163033 della Microsoft Knowledge Base "XCON: Descrizione delle categorie diagnostiche MTA" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033.

Per ulteriori informazioni sulla Registrazione diagnostica MTA in Exchange Server 5.5, consultare l'articolo 163032 della Microsoft Knowledge Base "XCON: Descrizione della registrazione diagnostica MTA" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032.


Il livello di registrazione diagnostico MTA è diverso da zero
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge una serie di chiavi del Registro di sistema per determinare il livello di registrazione diagnostica dell'Agente di trasferimento messaggi (MTA, Message Transfer Agent) impostato nel server di Exchange. Il percorso delle chiavi del Registro di sistema è:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Diagnostics

Il valore predefinito per queste chiavi è 0. Se Exchange Server Analyzer rileva che il valore di una di queste chiavi è maggiore di 1 ma minore di 6, verrà visualizzato un messaggio di configurazione non predefinita.

Queste chiavi del Registro di sistema vengono impostate da Gestore di sistema di Exchange quando vengono regolati i livelli di registrazione nella scheda Registrazione diagnostica della pagina delle proprietà di un server specifico. Gestore di sistema di Exchange consente a un amministratore di impostare uno specifico livello di registrazione su Nessuno, Minimo, Medio e Massimo. I corrispondenti valori delle chiavi del Registro di sistema, rispettivamente, sono 0, 1, 3 o 5.

Nella seguente tabella sono mostrate le categorie di registrazione MTA così come sono elencate nella scheda Registrazione diagnostica nel Gestore di sistema di Exchange e i corrispondenti nomi delle chiavi nel Registro di sistema.

Categoria visualizzata nel Gestore di sistema di Exchange | Nome chiave del Registro di sistema corrispondente
Servizio X.400 | 1 X.400 Service
Risorsa | 2 Resource
Protezione | 3 Security
Interfaccia | 4 Interface
Progettazione campo | 5 Field Engineering
Amministrazione MTA | 6 MTA Administration
Configurazione | 7 Configuration
Accesso alla directory | 8 Directory Access
Sistema operativo | 9 Operating System
Elaborazione interna | 10 Internal Processing
Interoperabilità | 11 Interoperability
APDU (Application Protocol Data Unit) | 12 APDU

Nel riferimento alla fine del presente articolo sono contenute maggiori informazioni sugli eventi registrati in ciascuna categoria MTA.

La procedura maggiormente consigliata relativa alla registrazione diagnostica consiste nell'impostazione della registrazione per ciascuna categoria MTA su Nessuno (0), a meno che non si stiano risolvendo attivamente dei problemi. Il motivo di questo suggerimento consiste nel mantenere un numero gestibile di eventi registrati. Anche un livello pari a Minimo (1) potrebbe generare centinaia di registri eventi in pochi giorni, a seconda della categoria in cui viene impostato il livello.

Se non si stanno risolvendo problemi, è probabile che questi valori siano stati impostati su un livello più alto durante un'esercitazione sulla risoluzione dei problemi e che siano rimasti inavvertitamente impostati in tal modo. È possibile impostare il livello di registrazione su Nessuno (0) per ciascuna categoria di registrazione diagnostica MTA.

Per risolvere il problema in Exchange Server 2003 o Exchange 2000 Server

  1. Aprire Gestore di sistema di Exchange.

  2. Nella struttura della console espandere Server, il server desiderato, quindi fare clic su Proprietà.

  3. In <Proprietà> Server selezionare la scheda Registrazione diagnostica.

  4. Nella sezione Servizi scegliere MSExchangeMTA.

  5. Per ciascuna voce presente in Categorie impostare il livello di registrazione su Nessuno selezionando la categoria e scegliendo Nessuno in Livello di registrazione.

  6. Una volta impostate tutte le categorie su Nessuno, fare clic su Applica, quindi scegliere OK.

Per risolvere il problema in Exchange Server 5.5

  1. Avviare il programma Microsoft Exchange Server Administrator.

  2. Aprire l'oggetto che rappresenta il server che ha problemi con MTA.

  3. Fare doppio clic sull'oggetto Agente di trasferimento messaggi nel riquadro destro.

  4. Nella scheda Registrazione diagnostica scegliere X.400 Service, quindi fare clic su Massimo.

  5. Selezionare Resource.

  6. Tenere premuto CTRL e fare clic su ciascuna risorsa di cui si desidera eseguire il debug.

  7. Scegliere Opzione per un livello di registrazione pari a Nessuno.

  8. Fare clic su OK.

Per ulteriori informazioni sulla Registrazione diagnostica MTA in Exchange 2000 Server, consultare l'articolo 163033 della Microsoft Knowledge Base "XCON: Descrizione delle categorie diagnostiche MTA" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163033.

Per ulteriori informazioni sul ripristino della registrazione avanzata in Exchange Server 5.5, consultare l'articolo 168906 della Microsoft Knowledge Base "XCON: Impostazione della registrazione avanzata negli MTA in Exchange 5.0 e 5.5" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168906.

Per ulteriori informazioni sulla registrazione diagnostica MTA in Exchange Server 5.5, consultare l'articolo 163032 della Microsoft Knowledge Base "XCON: Descrizione delle categorie diagnostiche MTA" all'indirizzo (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=163032.


Parametro MTA Dispatcher threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Dispatcher threads

Se Exchange Server Analyzer rileva che il valore di Dispatcher threads è presente e maggiore di zero ma non impostato su 1 o 2, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Dispatcher threads è il numero dell'Agente di trasferimento messaggi (MTA) Dispatcher threads. Tale valore viene moltiplicato per i tre sottotipi (Router, Fanout, Result) del thread Dispatcher. Uno dei motivi per cui è consigliato modificare questo valore è nel caso in cui un MTA comunichi con più di cinque computer Exchange Server 5.5, all'interno di un sito o tra più siti, oppure nel caso in cui siano molto utilizzate le liste di distribuzione. In tal caso, si consiglia di modificare il valore in 3. Se l'MTA non soddisfa questo criterio, è preferibile riportare il valore all'impostazione predefinita di 1.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore Dispatcher threads e fare doppio clic su di esso.

  4. Nel campo Dati valore digitare 1 e fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


L'MTA non è in esecuzione con l'account LocalSystem
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Mediante Microsoft® Exchange Server Analyzer Tool viene eseguita una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave StartName per il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi. Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per l'oggetto Exchange Server nella directory. L'attributo serialNumber sull'oggetto Exchange Server identifica la versione di Exchange Server in esecuzione sul computer rappresentato dall'oggetto. Se il valore per la chiave StartName non corrisponde a LocalSystem su un server di Exchange sul quale è in esecuzione Exchange 2000 Server o Exchange Server 2003, verrà visualizzato un messaggio di errore.

L'esecuzione di MTA Stacks di Exchange con un altro account provoca problemi di autorizzazione e di accesso e non è una configurazione supportata.

Per risolvere questo problema, è necessario configurare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi in modo che venga avviato con l'account LocalSystem (aks SYSTEM).

Nota:
Questo errore non riguarda Exchange Server versione 5.5. Solo Exchange 2000 Server e Exchange Server 2003 richiedono che il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi venga eseguito con l'account LocalSystem.

Per configurare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Individuare e interrompere il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

  3. Fare doppio clic sul servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

  4. Nella scheda Connessione della pagina delle Proprietà di Microsoft Exchange - Stack Agente di trasferimento messaggi selezionare Account LocalSytem da Accedi come, quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia, quindi su OK.

  6. Aprire lo snap-in Servizi.

Per ulteriori informazioni sull'esecuzione dei servizi di Exchange con l'account LocalSystem, consultare l'articolo 239762 della Microsoft Knowledge Base "Esecuzione dei servizi di Exchange in LocalSystem" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Parametro MTA Kernel threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Kernel threads

Se Exchange Server Analyzer rileva che il valore di Kernel threads è presente e maggiore di 0 ma non impostato su 1 o su 3, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Kernel threads rappresenta il numero di thread di piattaforma che gestiscono il livello di presentazione e sessione dello stack OSI (Open Systems Interconnection). Questi thread costituiscono la base per l'elaborazione dei messaggi dell'Agente di trasferimento messaggi (MTA, Message Transfer Agent). Se l'MTA comunica con molti altri server di Exchange Server versione 5.5 che utilizzano la chiamata di procedura remota (RPC, Remote Procedure Call) con connessioni di rete lente o non affidabili, si consiglia di utilizzare un valore elencato nella tabella riportata di seguito.

Valore | Descrizione
0x3 (esadecimale) | Valore consigliato. Utilizzare questo valore per tutti gli MTA che comunicano con altri server di Exchange Server 5.5 che utilizzano RPC con connessioni di rete lente o non affidabili.
0x8 (esadecimale) | Utilizzare questo valore per MTA di Exchange 2000 Server o Exchange Server 2003 che appartengono a un sito contenente più di 15 computer Exchange Server 5.5.
0xC (esadecimale) | Utilizzare questo valore per MTA di Exchange 2000 Server o Exchange Server 2003 che appartengono a un sito contenente più di 30 computer Exchange Server 5.5.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il valore Kernel threads

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore Kernel threads e fare doppio clic su di esso.

  4. Nel campo Dati valore immettere il valore appropriato per l'organizzazione e fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA LAN-MTAs non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\LAN-MTAs

Se Exchange Server Analyzer rileva che il valore di LAN-MTAs è presente e impostato su un valore diverso da 20, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore LAN-MTAs indica il numero degli agenti di trasferimento messaggi di rete (MTA) supportati dall'MTA. Si consiglia di utilizzare il valore 20 per questo valore del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore LAN-MTAs e fare doppio clic su di esso.

  4. Nel campo Dati valore inserire 20, quindi scegliere OK.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA MDB users non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\MDB users

Se Exchange Server Analyzer rileva che il valore di MDB users è presente e non impostato su 500, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore MDB users è il numero massimo di utenti MDB supportati dall'MTA. Tutti gli utenti Exchange Server sono utenti MDB per impostazione predefinita a meno che non siano esplicitamente impostati in modo diverso.

Il valore MDB users del Registro di sistema definisce il numero di nomi distinti (DN) di cui eseguire la copia cache dalla directory. Se l'organizzazione comprende più di 1500 utenti, è preferibile cambiare il valore a un terzo delle dimensioni dell'elenco indirizzi globale, ma soltanto fino a un massimo di 5000 utenti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore MDB users e fare doppio clic su di esso.

  4. Nel campo Dati valore digitare 500 e fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA Max RPC calls outstanding non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Max RPC Calls Outstanding

Se Exchange Server Analyzer rileva che il valore di Max RPC Calls Outstanding è presente e diverso da 50, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Max RPC Calls Outstanding è il numero massimo di thread RPC (Remote Procedure Call). Questo valore è il numero massimo di chiamate RPC la cui elaborazione è garantita in una sola volta. Il valore è utilizzato da RpcServerUseAllProtSeqs() e RpcServerListen().

In scenari in cui sono presenti più sistemi e in cui Exchange 2000 Server e/o Exchange Server 2003 coesistono con computer Exchange Server versione 5.5 ed è stato aumentato il numero di thread di gateway in entrata/in uscita nel processo Store.exe, è consigliabile aumentare i dati valore a 0x80 (esadecimale) o 128 (decimale).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro a destra, individuare e fare doppio clic sul valore Max RPC Calls Outstanding.

  4. Nel campo Dati valore inserire 50 e scegliere OK.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA Min RPC threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Min RPC Threads

Se Exchange Server Analyzer rileva che il valore di Min RPC Threads è presente e impostato su un valore diverso da 4, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Min RPC Threads rappresenta il numero minimo di thread RPC (Remote Procedure Call). Il valore identifica il numero minimo di thread di chiamata. Il valore è utilizzato da RpcServerListen(). Normalmente non è opportuno modificare l'impostazione predefinita di questo valore del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore Min RPC Threads e fare doppio clic su di esso.

  4. Nel campo Dati valore digitare 4 e fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA RTS threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\RTS threads

Se Exchange Server Analyzer rileva che il valore di RTS threads è presente e maggiore di 0 ma non impostato su 1 o 3, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore RTS threads rappresenta il numero di thread di piattaforma che gestiscono il livello dell'elemento servizio trasferimenti affidabili (RTSE) dello stack OSI (Open Systems Interconnection). I thread RTS sono responsabili dell'immissione dei dati nelle code. È necessario adeguare il valore RTS threads del Registro di sistema dall'impostazione predefinita di 1 a 3 se l'MTA in questione comunica con più computer che eseguono Exchange Server 5.5 all'interno di un sito o tra diversi siti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ottimizzare il valore RTS threads del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore RTS threads e fare doppio clic su di esso.

  4. Nel campo Dati valore immettere il valore appropriato (1 o 3), quindi fare clic su OK.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il servizio MTA non è in esecuzione
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-19

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se le chiavi Started dei servizi indicati di seguito sono impostate su True o su False:

  • Servizio Microsoft Exchange - Stack Agente di trasferimento messaggi

  • Servizio cluster

Il valore False indica che il servizio non è in esecuzione su questo computer Exchange Server. Il valore True indica che il servizio è in esecuzione.

Exchange Server Analyzer analizza inoltre la classe WMI Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Se il valore per tutte le tre chiavi valutate è False, verrà visualizzato un avviso.

È consigliabile avviare il servizio Microsoft Exchange - Stack Agente di trasferimento in tutti i computer Exchange Server che instradano la posta. Questo è particolarmente importante in un ambiente a modalità mista in cui i messaggi vengono trasferiti tra Exchange Server 5.5 ed Exchange Server 2003 e/o Exchange 2000 Server. Inoltre, tutti i connettori X.400 richiedono il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi; pertanto la disabilitazione del servizio genererà errori e potrebbero verificarsi problemi di funzionalità. Anche lo spostamento di cassette postali richiede l'avvio del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Per risolvere questo avviso, avviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Per avviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi

  1. Dal menu Start, scegliere Programmi, Strumenti di amministrazione, quindi lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio Microsoft Exchange - Stack Agente di trasferimento messaggi e scegliere Proprietà.

  3. Nella scheda Generale della pagina delle proprietà di Microsoft Exchange - Stack Agente di trasferimento messaggi accertarsi che l'opzione Tipo di avvio sia impostata su Automatico. In caso contrario, fare clic su Applica, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio Microsoft Exchange - Stack Agente di trasferimento messaggi e scegliere Avvia.

  5. Aprire lo snap-in Servizi.

Per ulteriori informazioni su come mantenere in funzione in Exchange il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi, consultare l'articolo 810489 della Microsoft Knowledge Base "Il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi deve rimanere abilitato su Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489.


Il servizio MTA è impostato su Disabilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore impostato per la chiave StartMode del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi. Il valore Disabilitato indica che il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi è stato disabilitato e non può essere avviato finché il valore StartMode non viene cambiato in Manuale o Automatico.

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_Service per determinare il valore della chiave Started per il servizio SMTP (Simple Mail Transfer Protocol). Il valore False indica che il servizio non è in esecuzione. Il valore True indica che il servizio è in esecuzione.

Infine, Exchange Server Analyzer esegue una query nella classe WMI Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore di questa chiave corrisponde a una versione specifica del sistema operativo Microsoft Windows Server™ 2003.

Se Exchange Server Analyzer rileva che il valore della chiave StartMode è impostato su Disabilitato in un computer che esegue Exchange Server e su cui è stato avviato il servizio SMTP e che questo computer non fa parte di un'installazione di Microsoft Windows Small Business Server 2003, verrà visualizzato un avviso.

Se il server non fa parte di un'installazione di Microsoft Windows Small Business Server 2003 oppure se non si trova in un ambiente Exchange Server 2003 puro in modalità nativa, in tutti i computer che eseguono Exchange Server e che instradano posta è necessario che il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi sia impostato su Automatico. L'instradamento della posta su un server in cui il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi è disabilitato può produrre una serie di messaggi di errore. In alcuni casi, gli errori verranno registrati se si sta effettuando l'esecuzione in un ambiente Exchange 2000 Server o Exchange Server 2003 in cui è ancora in esecuzione Exchange Server versione 5.5. Inoltre, tutti i connettori X.400 richiedono il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi; pertanto la disabilitazione del servizio genererà errori e potrebbero verificarsi problemi di funzionalità.

Nota:
Ad eccezione della connettività diretta con sistemi di posta X.400 esterni o dell'esecuzione di connettori dell'EDK (Exchange Development Kit), ad esempio, Novell GroupWise Connector, Lotus Notes Connector o di un connettore fax di terze parti, in Exchange Server 2003 le dipendenze del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi sono state rimosse. Pertanto, ora Microsoft supporta le distribuzioni pure di Exchange Server 2003 in modalità nativa in cui il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi è stato disabilitato.

Per risolvere questo errore, è necessario configurare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi in modo che venga avviato automaticamente nei server che instradano posta.

Per configurare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi per l'avvio automatico

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Fare doppio clic sul servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

  3. Nella scheda Generale della pagina delle proprietà di Microsoft Exchange - Stack Agente di trasferimento messaggi selezionare Automatico dalla finestra di dialogo a discesa Tipo di avvio, quindi fare clic su Applica.

  4. In Stato server fare clic su Start e su OK.

  5. Aprire lo snap-in Servizi.

Per ulteriori informazioni su come mantenere in funzione in Exchange il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi, consultare l'articolo 810489 della Microsoft Knowledge Base "Linee guida per il supporto del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810489.


Parametro MTA Submit/deliver threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\ Submit/deliver threads

Se Exchange Server Analyzer rileva che il valore di Submit/deliver threads è presente e non impostato su 2, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Submit/deliver threads è il numero dell'Agente di trasferimento messaggi (MTA) Submit/Deliver threads. Questi thread vengono utilizzati dall'MTA per passare messaggi all'archivio informazioni. In alcuni computer che eseguono Exchange Server 5.5, è possibile che questo valore sia stato cambiato automaticamente mediante Exchange Performance Optimizer dall'impostazione predefinita di 2 a un valore più appropriato al server di Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore Submit/deliver threads e fare doppio clic su di esso.

  4. Verificare che nel campo Dati valore sia stato inserito il valore 2 e fare clic su OK.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Nei computer che eseguono Exchange 2000 Server e Exchange Server 2003, il valore di questa voce non deve essere maggiore di 3. In alternativa alla procedura indicata sopra, per computer che eseguono Exchange Server 5.5, è possibile eseguire Exchange Performance Optimizer in modalità dettagliata (perfwiz.exe -v) e impostare il valore mediante questo strumento.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle situazioni in cui il valore MTA Submit/deliver threads del Registro di sistema deve essere modificato rispetto all'impostazione predefinita, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 234280, "XCON: Come aumentare la capacità del servizio MTA di inviare messaggi di posta elettronica su connessioni di rete lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280.

  • 265186, "XCON: Rallentamenti del fan-out dell'MTA su server multiprocessore e backup dei messaggi nell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186.

  • 234702, "XGEN: Rallentamento nell'elaborazione della coda MTA nell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=234702.

  • 327260, "Rallentamenti o blocchi dell'MTA in Exchange Server 5.5 e backup dei messaggi nell'archivio informazioni privato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260.

  • Per ulteriori informazioni sull'utilizzo di Exchange Performance Optimizer in modalità dettagliata, consultare l'articolo 246125 della Microsoft Knowledge Base "XADM: "Performance Optimizer in modalità dettagliata in Exchange Server 5.5" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246125.


Parametro MTA TCP/IP control blocks non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP control blocks

Se Exchange Server Analyzer rileva che il valore di TCP/IP control blocks è presente e non impostato su 20, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore TCP/IP control blocks rappresenta il numero massimo di connessioni RFC1006 (TCP/IP) contemporanee supportate. Questa impostazione consente di controllare il numero di buffer disponibili per le connessioni X.400. Se l'Agente di trasferimento messaggi (MTA) ospita più connettori X.400, sarà necessario adeguare il valore TCP/IP control blocks. Devono esistere 10 blocchi di controllo per ciascun connettore X.400 ospitato e un blocco di controllo per elaborare le connessioni in ingresso. Pertanto, per un sistema con tre connessioni X.400, il valore appropriato sarebbe 33.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il valore TCP/IP control blocks

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore TCP/IP control blocks e fare doppio clic su di esso.

  4. Nel campo Dati valore immettere il valore appropriato per questo MTA, quindi fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA TCP/IP threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\TCP/IP threads

Se Exchange Server Analyzer rileva che il valore di TCP/IP threads è presente e non impostato su 2, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore TCP/IP threads corrisponde al numero massimo di thread MTA (Message Transfer Agent) DMOD (Dynamic Address Module) che gestiscono connessioni RFC1006. Questo numero viene moltiplicato per due in base ai due sottotipi (Drivere Async Notify) di thread RFC1006. Per i server testa di ponte della replica della directory X.400 e i server delle cartelle pubbliche dedicate che gestiscono un ampio numero di connessioni, è consigliabile che l'impostazione predefinita 2 di questo valore venga modificata in 10.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il valore TCP/IP threads

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore TCP/IP threads e fare doppio clic su di esso .

  4. Nel campo Dati valore immettere il valore appropriato, quindi fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Parametro MTA Transfer threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transfer threads

Se Exchange Server Analyzer rileva che il valore di Transfer threads è presente e maggiore di 0 ma non impostato su 1 o su 2, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Transfer threads è il numero dei thread di trasferimento dell'Agente di trasferimento messaggi (MTA). Viene moltiplicato per due in base ai due sottotipi (Transfer In e Transfer Out) di ciascun thread di trasferimento. Si tratta dell'equivalente del valore Submit/deliver threads (correlato al trasferimento messaggi dell'archivio informazioni e dell'MTA) ma relativo ai gateway e agli MTA. Per ulteriori informazioni sul valore Submit/deliver threads, consultare Parametro MTA Submit/deliver threads non predefinito.

Se si tratta di un MTA di Exchange 2000 Server o Exchange Server 2003 che comunica con più computer che eseguono Exchange Server versione 5.5 all'interno di un sito o tra diversi siti, si consiglia di modificare il valore Transfer threads impostandolo su 3.

In alcuni computer che eseguono Exchange Server 5.5, è possibile che il valore predefinito di 2 sia stato modificato automaticamente da Exchange Performance Optimizer e impostato su un valore più appropriato per il computer che esegue Exchange Server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il valore Transfer threads

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore Transfer threads e fare doppio clic su di esso.

  4. Nel campo Dati valore immettere il valore appropriato, quindi fare clic su OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Nei computer che eseguono Exchange 2000 Server ed Exchange Server 2003 il valore di questa voce non deve essere maggiore di 3. In alternativa alla procedura indicata sopra, è possibile eseguire Exchange Performance Optimizer in modalità dettagliata (perfwiz.exe -v) e impostare il valore mediante questo strumento.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle situazioni in cui il valore Transfer threads del Registro di sistema per l'MTA deve essere modificato rispetto all'impostazione predefinita, consultare i seguenti articoli della Knowledge Base:

  • 234280, "XCON: Come aumentare la capacità del servizio MTA di inviare messaggi di posta elettronica su connessioni di rete lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=234280.

  • 265186, "XCON: Rallentamenti del fan-out dell'MTA su server multiprocessore e backup dei messaggi nell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=265186.

  • 327260, "Rallentamenti o blocchi dell'MTA in Exchange Server 5.5 e backup dei messaggi nell'archivio informazioni privato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327260.


Parametro MTA Transport threads non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinarne il valore corrente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeMTA\Parameters\Transport threads

Se Exchange Server Analyzer rileva che il valore di Transport threads è presente e non impostato su 1, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Transport threads è il numero dell'Agente di trasferimento messaggi (MTA) Transport threads. Il valore predefinito 1 è generalmente sufficiente per tutte le organizzazioni. A meno che non venga indicato dal Servizio Supporto Tecnico Clienti Microsoft, questo valore dovrebbe rimanere impostato su 1.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il valore Transport threads

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeMTA\Parameters

  3. Nel riquadro destro individuare il valore Transport threads e fare doppio clic su di esso.

  4. Nel campo Dati valore inserire 1 e scegliere OK.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Verifica messaggi disabilitata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-06

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se la proprietà messageTrackingEnabled dell'oggetto server è stata impostata su TRUE (abilitata) o FALSE (disabilitata).

Se Microsoft Exchange Server Analyzer Tool rileva che la proprietà messageTrackingEnabled dell'oggetto server è impostata su False, verrà visualizzato un messaggio di errore.

La proprietà messageTrackingEnabled dell'oggetto server determina lo stato del Centro di verifica messaggi del server.

Il Centro di verifica messaggi, se abilitato, registra le informazioni su mittente, messaggio di posta e destinatari. Nella fattispecie, è possibile consultare le statistiche, quali ora di invio o di ricezione del messaggio, dimensioni e priorità e l'elenco dei destinatari. È inoltre possibile registrare la riga dell'oggetto. Il Centro di verifica messaggi esegue la ricerca, ad esempio, di messaggi di sistema, di cartelle pubbliche e di posta elettronica.

È necessario abilitare il Centro di verifica messaggi su ogni server di cui si desidera verificare i messaggi. Se abilitato, tutti i messaggi instradati tramite un server verranno inseriti nei registri di verifica messaggi.

Microsoft Exchange Server Analyzer Tool necessita dell'abilitazione della funzione verifica dei messaggi per poterla eseguire.

Nota:
Sono necessarie le seguenti autorizzazioni per eseguire questa procedura: membro del gruppo Administrators locale e di un gruppo a cui è stato assegnato il ruolo Administrators di Exchange a livello di gruppo amministrativo.
Per abilitare il Centro di verifica messaggi sul server

  1. Nel Gestore di sistema di Exchange, espandere Server, fare clic con il tasto destro del mouse sul server sul quale si desidera abilitare la funzione di verifica dei messaggi, quindi su Proprietà.

  2. Nella scheda Generale selezionare la casella di controllo Abilita verifica messaggi.

  3. Per registrare l'oggetto dei messaggi inviati al, dal o attraverso il server, selezionare la casella di controllo Abilita registrazione e visualizzazione oggetto.

    Nota:
    Abilitando la funzione di registrazione dell'oggetto è possibile che le prestazioni diminuiscano.

  4. In Manutenzione file di registro è possibile evitare la rimozione dei file di registro o la modifica del periodo di conservazione dei file. Il periodo di conservazione predefinito è di sette giorni.

    Nota:
    Le dimensioni dei registri di verifica aumentano rapidamente nei server che elaborano grandi quantità di messaggi. Accertarsi di disporre di spazio su disco sufficiente per i file di registro e per altri servizi o applicazioni in uso.

  5. Fare clic su OK o Applica. Non è necessario riavviare i servizi per rendere effettive le modifiche.

Per ulteriori informazioni sull'utilizzo del Centro di verifica messaggi, vedere l'articolo 262162 della Microsoft Knowledge "XADM: Utilizzare il Centro verifica messaggi per tenere la traccia di un messaggio" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

Per ulteriori informazioni sulla risoluzione dei problemi di trasporto di Exchange Server, vedere l'articolo 821910 della Microsoft Knowledge Base, "Come risolvere il relativo problema per i problemi di trasporto Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821910.


Scrittura dei registri di verifica messaggi in una cartella compressa
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per stabilire il valore della chiave Compressed per il percorso del file di registro di verifica messaggi. Se Exchange Server Analyzer determina che il valore della chiave Compressed è True, verrà visualizzato un messaggio di errore.

Quando viene abilitata la verifica dei messaggi in un computer che esegue Exchange 2000 Server o Exchange Server 2003, i registri di verifica verranno scritti nella seguente posizione predefinita:

<unità> :\Programmi\Exchsrvr\ NomeServer .log

dove <unità> è l'unità contenente il percorso \Programmi\Exchsrvr e NomeServer è il nome host del computer che esegue Exchange Server.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in un volume NTFS compresso. Quando si esegue l'archiviazione dei file di dati di Exchange in un volume compresso, il sovraccarico aggiuntivo influisce notevolmente sulle prestazioni di Exchange. Inoltre, quando un database dell'archivio informazioni raggiunge una determinata dimensione (circa 4 GB), potrebbe presentare problemi di installazione o essere danneggiato.

I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

I file gestiti da Extensible Storage Engine (ESE) non sono progettati per l'archiviazione in un'unità compressa. L'Extensible Storage Engine dipende dall'indipendenza dei settori per il ripristino basato sui registri e la compressione dei file invalida tale indipendenza. La compressione non deve essere attivata per i volumi che ospitano database ESE o altri database che utilizzano la registrazione write-ahead.

Prima di Exchange 2000 Server Service Pack 3, era possibile installare database dell'archivio informazioni compressi. Tuttavia, i registri e i database dell'archivio informazioni di Exchange 2000 Server compressi mediante la compressione NTFS possono risultare danneggiati.

Con Exchange 2000 Server Service Pack 3, i file di database dell'archivio informazioni compressi di dimensione pari o inferiore a 128 MB vengono decompressi automaticamente. Se la dimensione dei file di database diventa maggiore di 128 MB, il database non verrà installato e nel Registro applicazione verranno generati messaggi di errore. Exchange 2000 Server Service Pack 3 impedisce l'installazione dei database compressi di dimensioni superiori a 128 MB.

Per disattivare la compressione dei file di una specifica cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

In alternativa alla procedura precedente, è possibile spostare i file di registro di verifica messaggi in una cartella diversa non compressa. Per ulteriori informazioni sullo spostamento dei file di registro di verifica messaggi, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 84103, "Modifica della posizione dei registri di verifica dei messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089.

  • 317700, "Modifica della posizione dei registri di verifica dei messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700.

Per ulteriori informazioni sui file di dati di Exchange e sulla compressione NTFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 170009, "XADM: La compressione NTFS del volume provoca errori nell'archivio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=170009.

  • 327772, "XADM: Non è possibile installare il database e viene restituito l'errore 0xfffff05b dopo l'applicazione del SP3" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327772.


Scrittura dei registri di verifica messaggi in una partizione non NTFS
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Microsoft Windows®) Win32_Directory per determinare il valore della chiave FSName per il percorso dei file di registro di verifica di Exchange. Se Exchange Server Analyzer determina che il valore della chiave FSName non equivale a NTFS, verrà visualizzato un messaggio di errore.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in volumi non NTFS. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Se viene riscontrato questo errore, sarà necessario spostare i registri di verifica dei messaggi in una cartella dell'unità NTFS. In alternativa, se l'unità in cui sono memorizzati i registri di verifica dei messaggi è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertire l'unità in NTFS.

Per spostare i registri di verifica messaggi in Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo, Server, fare clic con il pulsante destro del mouse sul server, quindi scegliere Proprietà.

  3. Nella scheda Generale scegliere Cambia.

  4. Digitare il nuovo percorso dei registri di verifica messaggi e fare clic su OK.

  5. Fare clic su OK.
Nota:
Per impostazione predefinita, la modifica della posizione del file di registro di verifica è valida dalla mezzanotte dell'ora UTC (Coordinated Universal Time). Dopo aver reso effettiva questa modifica, il componente per la verifica dei messaggi di Exchange crea nuovi file di registro nella nuova posizione specificata. Tuttavia, i file di registro precedenti non vengono spostati nella nuova posizione. A causa di questo mancato spostamento, è necessario attendere fino a quando ha effetto la modifica della posizione del file di registro, quindi spostare manualmente i file di registro dalla posizione precedente a quella nuova. Se il servizio Supervisore sistema di Microsoft Exchange viene riavviato, il percorso del file di registro viene immediatamente modificato e impostato per riflettere la nuova posizione. In questo scenario, quando un utente invia un messaggio, Verifica messaggi di Exchange crea un nuovo file di registro in una nuova posizione. Si avranno pertanto due file di registro con lo stesso nome: uno nella posizione originale e l'altro nella nuova posizione specificata. In questo caso, è necessario rinominare il file di registro che si trova nella posizione originale prima di spostarlo nella posizione del nuovo file di registro. Utilizzare la stessa convenzione di denominazione utilizzata da Verifica messaggi di Exchange (aaaammgg). Tuttavia, in questo caso, utilizzare una data precedente rispetto a uno qualsiasi dei file di registro esistenti in modo che il file di registro rinominato non interferisca con i file di registro futuri.

Per ulteriori informazioni sullo spostamento dei file di registro di verifica messaggi su un computer che esegue Exchange 2000 Server, consultare l'articolo 317700 della Microsoft Knowledge Base "Modifica della posizione dei registri di verifica dei messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700.

In alternativa alla procedura descritta sopra, se l'unità in cui sono archiviati i file è formattata come un'unità FAT, è possibile utilizzare lo strumento della riga di comando convert.exe per convertirla in unità NTFS. Per ulteriori informazioni sull'utilizzo dello strumento della riga di comando convert.exe per convertire una partizione FAT in una partizione NTFS, consultare l'articolo 214579 della Microsoft Knowledge Base: "Utilizzo di Convert.exe per convertire una partizione nel file system NTFS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579.


Scrittura dei registri di verifica messaggi in una cartella crittografata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per stabilire il valore della chiave Encrypted per i file di registro di verifica messaggi. Se il valore della chiave è True, verrà visualizzato un messaggio di errore.

Quando viene abilitata la verifica messaggi in un computer che esegue Exchange 2000 Server o Exchange Server 2003, i registri di verifica verranno scritti nella seguente posizione predefinita:

<unità>:\Programmi\Exchsrvr\ NomeServer .log

dove <unità> è l'unità contenente il percorso \Programmi\Exchsrvr e NomeServer è il nome host del computer che esegue Exchange Server.

Microsoft non supporta la memorizzazione dei file di dati di Exchange in un volume crittografato EFS (Encrypting File System). Quando si esegue l'archiviazione dei file di dati di Exchange in un volume crittografato, il sovraccarico aggiuntivo influisce notevolmente sulle prestazioni di Exchange. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per proteggere i file di dati di Exchange, è consigliabile impedire l'accesso non autorizzato al computer che esegue Exchange e utilizzare il formato messaggio S/MIME per crittografare i dati dei messaggi.

Per disattivare la crittografia dei file in una cartella specifica

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la crittografia dei file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Crittografa contenuto per la protezione dei dati e scegliere OK.

In alternativa alla procedura precedente, è possibile spostare i file di registro di verifica messaggi in una cartella diversa non crittografata. Per ulteriori informazioni sullo spostamento dei file di registro di verifica messaggi, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 841089, "Modifica della posizione dei registri di verifica messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=841089.

  • 317700, "Modifica della posizione dei registri di verifica messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317700.


Impossibile accedere alla metabase
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-13

Microsoft® Exchange Server Analyzer Tool tenta di leggere diverse proprietà dell'istanza di server virtuale SMTP dal percorso della metabase IIS (Internet Information Services):

/LM/SmtpSvc/<istanza del server virtuale SMTP>

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • La query nella metabase non viene eseguita correttamente.

  • Exchange Server non è in esecuzione in Microsoft Windows NT® Server 4.0.

L'errore indica che Exchange Server Analyzer non è in grado di eseguire la connessione alla metabase IIS.

La metabase IIS include informazioni che incidono su Exchange Server, quali le impostazioni di protocollo per HTTP, le directory virtuali per l'accesso alle cassette postali e ai dispositivi portatili e le impostazioni di protezione HTTP.

Per risolvere il problema, verificare l'integrità della metabase e che IIS sia installato correttamente.

Per verificare che la metabase non sia danneggiata e che IIS sia installato correttamente, vedere le seguenti risorse:

  • Articolo 240225 della Microsoft Knowledge Base, "Description of Adsutil and MetaEdit Utilities Used to Modify the Metabase", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225.

  • Articolo 317678 della Microsoft Knowledge Base "HOW TO: Restart Internet Information Services (IIS) on Exchange 2000 Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678.

Se le indicazioni presenti in queste risorse non risolvono il problema, disinstallare e reinstallare IIS.

Per disinstallare IIS utilizzando Installazione componenti di Windows nel Pannello di controllo

  1. Fare clic su Start, quindi scegliere Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Nell'elenco Componenti fare clic sulla casella di controllo Server applicazioni.

  5. Fare clic su Dettagli.

  6. Fare clic su Gestione Internet Information Services.

  7. Fare clic su Avanti.

  8. Una volta disinstallato IIS, fare clic su Fine.
Per installare IIS tramite il Pannello di controllo

  1. Fare clic su Start, quindi scegliere Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Nell'elenco Componenti fare clic sulla casella di controllo Server applicazioni.

  5. Fare clic su Dettagli.

  6. Fare clic sulla casella di controllo Gestione Internet Information Services.

  7. Fare clic su OK fino a quando non viene visualizzato Aggiunta guidata componenti di Windows.

  8. Fare clic su Avanti e completare l'Aggiunta guidata componenti di Windows.


Valore MinUserDC non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-08

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema elencate di seguito per determinare se il controller di dominio del servizio directory di Active Directory® che funge da emulatore PDC (Primary Domain Controller, controller di dominio primario) è stato escluso manualmente dall'elenco dei controller di dominio disponibili per Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

Se Exchange Server Analyzer rileva la presenza e l'avvenuta configurazione di MinUserDC, verrà visualizzato un messaggio di configurazione non predefinita.

L'emulatore PDC è un computer con il ruolo di master operazioni in Active Directory che elabora richieste di replica dai controller di dominio di backup Microsoft® Windows NT® 4.0 ed elabora tutti gli aggiornamenti delle password per i client che non eseguono software client abilitati ad Active Directory. Gli emulatori PDC sono anche controller di dominio, pertanto possono essere utilizzati da applicazioni come Exchange.

DSAccess è un componente interno di Exchange 2000 Server e Exchange Server 2003 che consente di controllare il modo in cui tutti i componenti di Exchange accedono ad Active Directory. La funzione principale di DSAccess è quella di conservare le informazioni su diversi eventi e operazioni relativi alle directory. Ad esempio, DSAccess trova la topologia di Active Directory e rileva se i controller di dominio e i server di catalogo globali sono disponibili e rispondono alle query.

Per impostazione predefinita, DSAccess include il computer emulatore PDC nel suo elenco di controller di dominio disponibili e utilizzabili. Se programmi diversi da Exchange lutilizzano frequentemente l'emulatore PDC, l'utilizzo dell'emulatore da parte di DSAccess potrebbe provocare problemi di prestazioni nel computer emulatore PDC oltre che nel server di Exchange e al computer in cui è installato il programma diverso da Exchange.

Per evitare problemi di prestazioni, il valore MinUserDC può essere aggiunto al Registro di sistema su un server di Exchange in modo da imporre a DSAccess l'esecuzione di una query in tutti gli altri controller di dominio disponibili prima di eseguire una query nel controller di dominio che ha il ruolo di master operazioni dell'emulatore PDC.

Nota:
Un server di Exchange configurato con il valore MiniUserDC del Registro di sistema tenterà di utilizzare prima altri server dello stesso dominio. Di conseguenza, si consiglia di impostare questa configurazione solo se il sito contiene almeno due controller di dominio per il dominio contenente i server di Exchange.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per verificare e modificare il valore MinUserDC del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Individuare il valore MinUserDC e apportare le modifiche desiderate. Se il valore DWORD non esiste, è possibile crearlo manualmente.

  4. I dati di valore configurati per la voce MinUserDC del Registro di sistema rappresentano il numero massimo di controller di dominio da contattare prima di contattare l'emulatore PDC. Ad esempio, se MinUserDC viene impostato su 4, DSAccess esclude l'emulatore PDC solo quando sono disponibili 4 controller di dominio in tutto. Se si verifica questa situazione, l'emulatore PDC viene escluso dall'utilizzo e DSAccess comunica solo con i rimanenti 3 controller di dominio.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'utilizzo della voce MinUserDC del Registro di sistema, consultare l'articolo 298879 della Microsoft Knowledge Base "XADM: Problemi di prestazioni in Exchange 2000 quando viene utilizzato un emulatore PDC per DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879.


Sono presenti più di 1.000 archivi di cassette postali
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-13

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® e mantiene un conteggio degli oggetti dell'Archivio informazioni di Microsoft Exchange, con una classe oggetto di msExchPrivateMDB. Se Exchange Server Analyzer determina che sono presenti più di 1.000 archivi di cassette postali in un'organizzazione, verrà visualizzato un avviso.

Viene visualizzato un avviso in quanto esiste un problema noto per cui gli utenti che accedono alle cassette postali da Microsoft Office Outlook® Web Access 2003 attraverso server front-end di organizzazioni con più di 1.000 archivi di cassette postali, non possono accedere alle proprie cassette postali. Questo problema è determinato dal modo in cui il server front-end di Exchange elabora la richiesta di autenticazione al server back-end di Exchange.

Se i propri utenti accedono agli archivi di cassette postali dai server front-end di Exchange e viene visualizzato questo avviso, sarà necessario procedere come segue:

  • Richiedere e installare l'aggiornamento rapido di Exchange Server cui fa riferimento l'articolo 899902 della Microsoft Knowledge Base "Visualizzazione del messaggio di errore 401 quando si tenta di accedere a una cassetta postale su un server front-end che esegue Exchange Server 2003 utilizzando Outlook Web Access" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=899902.

  • Se possibile, consolidare le cassette postali su un numero inferiore di archivi.

  • Impostare i server front-end in modo che eseguano l'autenticazione ai server back-end con l'autenticazione di base. Questa opzione viene descritta nella parte restante di questo articolo.

Per impostazione predefinita, i server front-end di Exchange Server 2003 utilizzano l'autenticazione Kerberos per consentire la protezione delle credenziali utente tra i server front-end e back-end. Se l'autenticazione Kerberos non riesce, verrà registrato un evento di avviso e il server front-end tenterà di eseguire l'autenticazione NTLM. Se l'autenticazione NTLM non viene eseguita correttamente, verrà registrato un errore. L'autenticazione Kerberos verrà ritentata dopo 30 minuti. Quando i computer front-end che eseguono Exchange 2000 Server o Exchange Server 2003 effettuano l'autenticazione con i computer back-end che eseguono Exchange 2000 Server, verrà utilizzata NTLM. In Internet Information Services (IIS) o Gestore di sistema di Exchange non è disponibile un'interfaccia utente per selezionare i meccanismi di autenticazione.

La configurazione del server front-end di Exchange per l'utilizzo dell'autenticazione di base richiede l'impostazione di una chiave del Registro di sistema in tutti i server front-end dell'organizzazione. Nella procedura seguente viene illustrato come impostare manualmente la chiave.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare i server front-end di Exchange per l'utilizzo dell'autenticazione di base nei confronti dei server back-end di Exchange

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    Passare a:= HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service\MSExchangeWeb

  2. Fare clic con il pulsante destro del mouse su MSExchangeWeb, scegliere Nuova, quindi fare clic su Chiave. Denominare la nuova chiave Dav.

  3. Fare clic con il pulsante destro del mouse sulla nuova chiave Dav, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Denominare il nuovo valore UseBasicAuthToBE, quindi impostarlo su 1.

  5. Aprire lo snap-in Servizi MMC (Microsoft Management Console), fare clic con il pulsante destro del mouse su Servizio Amministrazione IIS quindi scegliere Riavvia.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


La maggior parte delle chiamate Store.exe in corso è in attesa di risposta da ESE
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano chiamate a vari componenti in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente VAPI (Virus API) .

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

L'Archivio informazioni di Microsoft Exchange presiede a un database ESE. ESE è un modulo di gestione di database sofisticato basato su transazioni. Una transazione consiste in una serie di operazioni trattate come un unico elemento indivisibile. Tutte le operazioni all'interno di una transazione sono completate o permanentemente salvate, oppure nessuna di esse viene eseguita.

Microsoft Exchange Server utilizza ESE come modulo di gestione di database incorporato che determina la struttura del database e gestisce la memoria. Il modulo di gestione di database memorizza nella cache i database in memoria trasferendo blocchi di dati (pagine) composti da 4 KB in ingresso e in uscita. Aggiorna le pagine in memoria e riscrive sul disco quelle nuove o aggiornate. Quando il sistema riceve le richieste, il modulo di gestione di database memorizza nel buffer i dati in memoria. Pertanto, non accede sempre al disco.

La memorizzazione nella cache dei dati in memoria è il metodo più rapido ed efficace per elaborare i dati. Tuttavia, durante l'esecuzione di Exchange, le informazioni su disco non sono mai completamente aggiornate. In memoria è presente l'ultima versione del database. Il database e la memoria non sono comunque sincronizzati, poiché molte modifiche non sono ancora memorizzate sul disco. Il disco del registro delle transazioni viene sempre aggiornato con le informazioni su ogni transazione.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano la predominanza di chiamate dal servizio Archivio informazioni di Exchange (Store.exe) al database ESE, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Microsoft Exchange a ESE:

  • Deframmentazione in linea di Microsoft Exchange.

  • Backup di dati.

    Nota:
    Se il backup dei dati o la deframmentazione in linea erano in corso durante la raccolta dei dati dal registro delle chiamate di Exchange, il messaggio di errore non indica un problema di prestazioni di Exchange Server e può essere ignorato.
  • Colli di bottiglia nelle unità database dovuti, ad esempio, a capacità insufficiente rispetto al numero di utenti del server.

  • Colli nelle unità TEMP e TMP.

Per risolvere il problema, procedere come segue:

  • Si consiglia di non sovrapporre finestre di backup o operazioni di manutenzione in linea negli orari di maggior traffico.

  • Accertarsi che le unità disco dei database funzionino correttamente e dispongano di velocità effettiva sufficiente a sopportare il carico di I/O.

  • Eseguire Microsoft Exchange Server Analyzer Tool per eseguire un'ulteriore analisi del server. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sulla configurazione della finestra oraria per la deframmentazione in linea, vedere l'articolo 244524 della Microsoft Knowledge Base "XADM: Come configurare l'Exchange Server Intervallo di tempo di deframmentazione della linea" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524.

Per ulteriori informazioni sui colli di bottiglia nel disco del server di Exchange, vedere Rilevato collo di bottiglia di disco.

Per ulteriori informazioni sul dimensionamento e l'ottimizzazione dei dischi del server di Exchange, vedere "Calcolo dei requisiti di I/O del disco" e "Procedure consigliate comuni a più architetture" in Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=49324.

Per ulteriori informazioni su ESE, vedere "Architettura ESE" all'indirizzo http://go.microsoft.com/fwlink/?linkid=67009.


La maggior parte delle chiamate Store.exe in corso è in attesa di risposta da IMAIL
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano una predominanza di chiamate in corso tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente MAPI del client MAPI.

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Il componente IMAIL di Exchange Server è un servizio di conversione flessibile utilizzato dal servizio Archivio informazioni di Microsoft Exchange tra Internet e messaggi MAPI. Ciò consente l'interoperabilità tra i client che utilizzano RFC-822 o il formato Internet e i client che utilizzano il formato di archiviazione interno di Exchange Server, quali i client MAPI o le attività di archiviazione interne.

Exchange utilizza il meccanismo IMAIL per applicare i formati dei messaggi ai contenuti per ogni mittente, secondo quanto definito nei domini Internet del Gestore di sistema di Exchange o specificato dall'utente in Microsoft Office Outlook®. Se IMAIL non riceve informazioni sui parametri di formattazione procederà alla conversione dei messaggi MAPI in formato S/TNEF (Summary TNEF) per il trasferimento tra i vari server.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano una predominanza di chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente MAPI del client MAPI, verrà visualizzato un avviso.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange al componente IMAIL del client MAPI possono verificarsi nelle seguenti condizioni:

  • Tentativo di IMAIL di elaborare molti dati in un messaggio o allegato.

  • Richiesta di conversione dati da molti client.

  • Tempi di risposta lenti alle richieste di DSAccess.

  • Colli di bottiglia nelle unità TEMP e TMP.

  • Spostamenti di cassette postali in corso.

Per risolvere il problema, procedere come segue:

  • Programmare gli spostamenti delle cassette postali in orari di scarso traffico.

  • Avviare Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi al server, quali limitazioni delle dimensioni di messaggi e allegati. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sui colli di bottiglia nel disco in Exchange Server, vedere Rilevato collo di bottiglia di disco.

Per ulteriori informazioni sul dimensionamento e l'ottimizzazione dei dischi del server di Exchange, vedere "Calcolo dei requisiti di I/O del disco" e "Procedure consigliate comuni a più architetture" in Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=49324.

Per ulteriori informazioni sulle limitazioni delle dimensioni dei messaggi consigliate su Exchange Server, vedere La dimensione massima del messaggio in uscita non è stata impostata.

Per ulteriori informazioni sulle prestazioni di DSAccess ed Exchange Server, vedere "Configurazione della cache utente DSAccess" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


La maggior parte delle chiamate Store.exe in corso è in attesa di risposta da LSASS
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-11

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano una predominanza di chiamate in corso tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al processo LSASS (Lsass.exe) .

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Il processo LSASS (Lsass.exe) è un sottosistema di protezione richiamato da altri processi per la verifica delle informazioni sull'account e la convalida dell'accesso.

All'accesso del client, Exchange Server invia una richiesta di ricerca del rispettivo ID di protezione (SID) account e genera una chiamata all'interno del processo LSASS (Lsass.exe).

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano una predominanza di chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al processo LSASS (Lsass.exe), verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Microsoft Exchange al processo LSASS:

  • Problemi alle risorse del server correlati al numero di utenti che si autenticano nello stesso momento.

  • Latenza di rete tra il server di Exchange e il controller di dominio o il server di catalogo globale.

  • Problemi dovuti a colli di bottiglia nelle risorse del server.

Per risolvere il problema, procedere come segue:

  • Implementare il parametro NeverPing come descritto in Parametro "NeverPing" consigliato.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sul processo Lsass.exe e l'utilizzo della memoria, vedere l'articolo 308356 della Microsoft Knowledge "Utilizzo della memoria da parte del processo Lsass.exe in controller di dominio basati su Windows 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356.

Per ulteriori informazioni sui problemi di accesso dei client di Exchange e LSAA, vedere l'articolo 161938 della Microsoft Knowledge Base "Rallentare Accesso Due client di Exchange al blocco critico di risorsa" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938.

Per ulteriori informazioni sulla latenza di rete tra server di Exchange e controller di dominio o server di catalogo globale, vedere il seguente blog del team di Microsoft Exchange "Exchange Does Not Always Use Local GCs" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69166 (in inglese).

Nota:
Il contenuto di ciascun blog e il relativo URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni sui colli di bottiglia nelle risorse del processore, vedere Collo di bottiglia del processore.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


La maggior parte delle chiamate Store.exe in corso è in attesa di risposta dalla directory
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-14

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano una predominanza di chiamate in corso tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al servizio directory Active Directory®.

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Active Directory fornisce tutte le informazioni sulle casette postali, i servizi elenco di indirizzi e altre informazioni relative ai destinatari. La maggior parte delle informazioni sulla configurazione di Microsoft Exchange Server 2003 è salvata anche in Active Directory.

Exchange Server gestisce le informazioni sull'accesso salvate in Active Directory e le scrive su Active Directory.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano la predominanza di chiamate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad Active Directory, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Microsoft Exchange a Active Directory:

  • Latenza di rete tra il server di Exchange e il controller di dominio.

  • Configurazione statica o comunque non corretta di DSAccess.

  • Sovraccarico del controller di dominio e del catalogo globale.

  • Progettazione non corretta della topologia di Active Directory.

Per risolvere il problema, procedere come segue:

  • Avviare Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi al server, quali limitazioni delle dimensioni di messaggi e allegati. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Verificare le prestazioni dei server dei controller di dominio di Active Directory.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sulle prestazioni di Exchange e DSAccess, vedere l'articolo 250570 della Knowledge Base "Rilevamento di servizio di directory di server e l'utilizzo DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

Per ulteriori informazioni sulle prestazioni del controller di dominio, vedere le seguenti risorse per Windows Server:

  • "Pianificazione della capacità del controller di dominio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70191 (in inglese).

  • "Monitoraggio Active Directory dei controller di dominio" in Manuale di installazione e pianificazione Active Directory per Windows 2000 Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70193 (in inglese).


La maggior parte delle chiamate Store.exe in corso è in attesa di risposta dal programma antivirus
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano una predominanza di chiamate incorso tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente VAPI (Virus API) Virusscan.

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano la predominanza di chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente VAPI Virusscan, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Microsoft Exchange al componente VAPI Virusscan:

  • Aggiornamenti a un programma antivirus che avvia nuove analisi degli elementi dell'Archivio informazioni.

  • Configurazione non corretta del programma antivirus.

  • Il software antivirus elabora messaggi o allegati di grandi dimensioni.

Per risolvere il problema, procedere come segue:

  • Programmare gli aggiornamenti del motore di ricerca virus in orari in cui l'utilizzo delle risorse è basso, ossia negli orari di scarso traffico.

  • Reinstallare il software antivirus, ma negli orari di scarso traffico.

  • Verificare la corretta configurazione di thread, esclusioni file, ecc. del motore di ricerca virus. Vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, vedere l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


La maggior parte delle chiamate Store.exe in corso è in attesa di risposta dallo snapshot Servizio Copia Shadow del volume
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano chiamate in corso tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente snapshot Servizio Copia Shadow del volume.

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Il Servizio Copia Shadow del volume è un insieme di API COM che implementa una struttura che consente l'esecuzione di backup del volume da eseguire quando le applicazioni di un sistema continuano a scrivere sui volumi.

Microsoft Exchange Server 2003 utilizza il Servizio Copia Shadow del volume incluso nel sistema operativo Microsoft Windows Server™ 2003 per eseguire copie shadow del volume di database e file di registro delle transazioni di Microsoft Exchange Server 2003.

Lo snapshot Servizio Copia Shadow del volume non è completamente indipendente dai dati originali. Generalmente gli snapshot vengono creati quando si definisce un indicatore temporale e assicura che i dati possano essere ripristinati a tale data.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente snapshot Servizio Copia Shadow del volume, verrà visualizzato un messaggio di configurazione ottimale.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Nota:
Se uno snapshot servizio di Copia Shadow del volume è stato avviato intenzionalmente entro 20 secondi dalla raccolta dei dati dal registro delle chiamate di Exchange, l'errore non indica un problema di prestazioni a carico di Exchange Server e può essere ignorato.

Si consiglia di non sovrapporre finestre di backup con operazioni di manutenzione in linea o negli orari di maggior traffico di richieste da parte degli utenti.

Per ulteriori informazioni

Per ulteriori informazioni sul Servizio Copia Shadow del volume, vedere "Consigli per l'utilizzo del Servizio Copia Shadow del volume in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56571 (in inglese).


Versione non corretta del file MOUNTMGR.SYS
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è installato Microsoft Windows® Server 2003: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\

Exchange Server Analyzer esegue query anche per quanto riguarda:

  • La classe Microsoft WMI (Windows Management Instrumentation) Win32_OperatingSystem per determinare se è installato Windows Server 2003 Service Pack 1.

  • La classe WMI Win32_Service per determinare se è in esecuzione il servizio cluster.

  • La classe WMI Win32_Volume per determinare se sono presenti punti di montaggio dei volumi.

  • La classe WMI CIM_Datafile per determinare se il valore della chiave Version per Mountmgr.sys è inferiore a 2443.

Se si verificano le seguenti condizioni, un messaggio di errore:

  • La chiave Version per Mountmgr.sys è inferiore a 2443.

  • Il server è un nodo di un cluster che esegue Windows Server 2003 Service Pack 1.

  • Sul server sono presenti punti di montaggio dei volumi.

La versione di Mountmgr.sys installata sul nodo cluster può causare errori dei punti di montaggio dei volumi. L'origine del problema è un errore nel driver Mountmgr.sys. Questo problema è intermittente e può verificarsi quando un volume viene installato su un punto di montaggio.

Nota:
Generalmente il problema non si verifica in ambienti non cluster in quanto il processo di montaggio dei volumi è diverso.

Per ulteriori informazioni su questo problema, consultare l'articolo 898790 della Microsoft Knowledge Base "I punti di montaggio dei volumi sui dischi in un cluster di server potrebbero essere temporaneamente non disponibili, dopo l'installazione di Windows Server 2003 Service Pack 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790.


Spostamento delle directory TEMP e TMP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-01

Microsoft® Exchange Server Analyzer Tool ha rilevato che la posizione delle cartelle TEMP e TMP per il server potrebbe non essere tale da non garantire prestazioni ottimali del disco. Si consiglia di archiviare le cartelle TEMP e TMP su un sottosistema disco che non sia condiviso dalla cartella di sistema o dai file dei dati di Exchange.

Il servizio Archivio informazioni di Microsoft Exchange consente di utilizzare le cartelle TEMP e TMP come archivio temporaneo durante alcune operazioni, ad esempio nelle operazioni di conversione dei messaggi o spostamento delle cassette postali e quando si lavora con allegati di grandi dimensioni. Le variabili di ambiente TEMP e TMP vengono utilizzate per determinare quali cartelle del file system (ad esempio quale percorso) devono essere utilizzate dalle applicazioni che richiedono un'area di lavoro temporanea. In genere, la variabile TEMP viene utilizzata da applicazioni quali Microsoft Exchange, mentre la variabile TMP da strumenti di sviluppo quali Microsoft Visual C++®. Il percorso di ciascuna variabile generalmente è relativo al contesto di protezione dell'applicazione o dello strumento.

Su un server di Exchange non cluster, l'Archivio informazioni di Microsoft Exchange consente di utilizzare SYSTEM (ad esempio, il sistema locale) in cui viene utilizzata l'impostazione predefinita delle variabili di ambiente %Systemroot%\Temp sia per TEMP sia per TMP. Nei server virtuali di Exchange in esecuzione su cluster di server Microsoft Windows® vengono utilizzate le impostazioni delle variabili di ambiente per l'account del servizio cluster, che viene eseguito nel contesto di protezione specifico di un utente. Per gli account utente, la variabile di ambiente predefinita per TEMP e TMP è impostata su %Userprofile%\Temp.

In questo articolo viene spiegato come spostare le directory TEMP e TMP in ambienti cluster e non cluster. Prima di eseguire le procedure illustrate nel presente articolo, tenere presente quanto segue:

  • Per prestazioni ottimali, è consigliabile non utilizzare il disco contenente il sistema operativo per le cartelle TEMP e TMP utilizzate da Exchange. È inoltre preferibile assicurarsi che tali variabili di ambiente siano impostate su percorsi che si trovano su un disco rapido o un sottosistema disco, ad esempio un set di assi RAID-0+1.

  • Si consiglia di non utilizzare i registri di transazione di Exchange del disco per le cartelle TEMP e TMP utilizzate.

Per spostare le cartelle TEMP o TMP in un ambiente non cluster

  1. Accedere al computer Exchange Server con un account che disponga delle autorizzazioni di amministrazione.

  2. Fare clic con il pulsante destro del mouse su Risorse di computer e scegliere Proprietà.

  3. Selezionare la scheda Avanzate.

  4. Fare clic su Variabili di ambiente.

  5. Nell'area Variabili di sistema selezionareTEMP e fare clic sul pulsante Modifica.

  6. Nel campo Valore variabile immettere il nuovo percorso per la variabile ambiente TEMP e fare clic su OK.

  7. Nell'area Variabili di sistema selezionare TMP e fare clic sul pulsante Modifica.

  8. Nel campo Valore variabile immettere il nuovo percorso per la variabile ambiente TMP e fare clic su OK.

  9. Per chiudere la finestra di dialogo Variabili di ambiente, fare clic su OK e per chiudere la finestra di dialogo Proprietà del sistema, fare nuovamente clic su OK.

  10. Riavviare il server per rendere effettive tutte le modifiche.
Per spostare le cartelle TEMP o TMP in un ambiente cluster

  1. Accedere a un nodo nel cluster tramite l'account del servizio cluster.

  2. Fare clic con il pulsante destro del mouse su Risorse di computer e scegliere Proprietà.

  3. Fare clic su Avanzate.

  4. Fare clic su Variabili di ambiente.

  5. Nell'area Variabili utente per <nome account> selezionare TEMP e fare clic su Modifica.

  6. Nel campo Valore variabile immettere il nuovo percorso per la variabile ambiente TEMP e fare clic su OK.

  7. Nell'area Variabili utente per <nome account> selezionare TMP e fare clic su Modifica.

  8. Nel campo Valore variabile immettere il nuovo percorso per la variabile ambiente TMP e fare clic su OK.

  9. Per chiudere la finestra di dialogo Variabili di ambiente, fare clic su OK e per chiudere la finestra di dialogo Proprietà del sistema, fare nuovamente clic su OK.

  10. Riavviare il nodo per rendere effettiva la modifica.

  11. Ripetere i passaggi da 1 a 10 per ciascun nodo nel cluster.
Importante:
È necessario assegnare all'account Authenticated Users le autorizzazioni appropriate per l'accesso al nuovo percorso delle cartelle TMP e TEMP.
Per assegnare al gruppo Authenticated Users le autorizzazioni di accesso alle cartelle TMP o TEMP

  1. Avviare Esplora risorse, individuare e fare clic con il pulsante destro del mouse sulla cartella alla quale fa riferimento la variabile TEMP o TMP e quindi fare clic su Proprietà.

  2. Nella finestra di dialogo Proprietà Temp fare clic sulla scheda Protezione e quindi su Aggiungi.

  3. Nella finestra di dialogo Selezione Utenti, Computer o Gruppi aggiungere il gruppo Authenticated Users all'elenco dei nomi degli oggetti e fare clic su OK.

  4. Fare clic su Avanzate per accedere alle impostazioni di protezione avanzate.

  5. Selezionare Authenticated Users nell'elenco Nome e fare clic su Modifica per visualizzare la finestra di dialogo Voce di autorizzazione.

  6. Utilizzare i campi dell'area Autorizzazioni per assegnare le autorizzazioni speciali riportate di seguito:

    Visita cartella / Esecuzione file

    Creazione file / Scrittura dati

    Creazione cartelle / Aggiunta dati

  7. Fare clic su OK tre volte per applicare le autorizzazioni e uscire dalla finestra di dialogo.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alle prestazioni di Exchange Server, consultare Risoluzione dei problemi di prestazioni di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Spostare le cassette postali degli utenti su un server diverso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool ha rilevato che sul server è attualmente presente un carico utente superiore al livello che può supportare in modo efficace. L'attuale carico utente sta creando problemi di prestazioni. Si consiglia di spostare gli utenti su un altro server spostando ogni sera un numero limitato di utenti (generalmente il 5% degli utenti complessivi) fino a quando il problema di prestazioni è stato risolto.

Si consiglia di implementare questa procedura in quanto si è verificato uno dei seguenti problemi:

  • Alcuni file del database di Exchange sono presenti su dischi che hanno raggiunto o superato il limite della capacità di trasmissione.

  • La capacità di altre risorse del server (ad esempio la memoria o la CPU) è stata superata.

  • La capacità di un disco è stata superata. Questo indica che il sottosistema del disco che supporta attualmente uno o più archivi di Exchange ha una latenza I/O media del disco che supera gli attuali livelli consigliati. Spostare il 5% degli utenti in un database su un disco diverso fino a quando il problema è stato risolto. Se le unità del database rappresentano un collo di bottiglia, spostare gli utenti su un database archiviato su un'unità differente. Se il collo di bottiglia è un'unità dei gruppi di archiviazione, spostare gli utenti su un database in un gruppo di archiviazione diverso presente in un altro database. Se le unità sono condivise da un'altra risorsa, provare a ridurre il carico delle altre applicazioni sulle unità.

  • La capacità del server fisico è stata superata. Non si dispone attualmente di memoria o capacità del processore sufficienti per supportare il carico del server generato dagli utenti. Spostare il 5% degli utenti su un server diverso fino a quando i problemi di prestazione sono stati risolti.

Nota:
Anche se non è necessario disconnettere i client Exchange dalle relative cassette postali durante lo spostamento di queste ultime, si consiglia di effettuare l'operazione quando l'attività del client è ridotta, ad esempio in orari di scarso traffico, per evitare possibili interruzioni del servizio.
Per spostare le cassette postali in Exchange Server 2003 procedere come segue

  1. Avviare il Gestore di sistema di Exchange sul computer Exchange Server 2003 qul quale si desidera eseguire il processo.

  2. Fare doppio clic su Server, quindi individuare il contenitore del server contenente le cassette postali degli utenti.

    Ad esempio, se si desidera spostare le cassette postali dal gruppo di archiviazione e dall'archivio cassette postali predefiniti, fare doppio clic su Primo gruppo di archiviazione, quindi doppio clic su Archivio cassette postali e scegliere Cassette postali.

  3. Nel riquadro dei dettagli scegliere le cassette postali che si desidera spostare.

  4. Fare clic con il pulsante destro del mouse sugli utenti selezionati, quindi scegliere Operazioni di Exchange.

  5. Nell'Operazione guidata di Exchange scegliere Avanti.

  6. Nella pagina Operazioni disponibili, scegliere Sposta cassetta postale nella sezione Selezionare un'operazione da eseguire, quindi fare clic su Avanti.

  7. Nella pagina Sposta cassetta postale, nell'elenco Server, scegliere il server desiderato e dall'elenco Archivio cassette postali, scegliere l'archivio cassette postali desiderato.

  8. Fare clic su Avanti.

  9. Configurare le modalità di gestione dei messaggi danneggiati rilevati nel corso della procedura di spostamento, quindi fare clic suAvanti.

  10. Fare clic su Avanti.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi di prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Microsoft Exchange Server 2003 http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

  • Per ulteriori informazioni sullo spostamento delle cassette postali tra Exchange 2000 Server e Exchange Server 5.5, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.


Problema di configurazione di NAS
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamLogFilePath per ogni oggetto del gruppo di archiviazione. Questo attributo specifica la posizione dei file di log delle transazioni utilizzati dai database nel gruppo di archiviazione.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ogni archivio cassette postali. Il conteggio di questo attributo rappresenta il numero delle cassette postali presenti nell'archivio.

Inoltre, Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio Microsoft Windows Storage Server 2003 Feature Pack (wssexchmap). Il valore False indica che il servizio Windows Storage Server 2003 Feature Pack non è in esecuzione su questo server di Exchange. Il valore True indica che il servizio Windows Storage Server 2003 Feature Pack è in esecuzione.

Se Exchange Server Analyzer determina che il valore di un attributo msExchESEParamLogFilePath inizia con S:\{ e che il servizio Windows Storage Server 2003 Feature Pack viene avviato in un computer Exchange Server con più di 1500 cassette postali, verrà visualizzato un avviso.

Windows Storage Server 2003 è la piattaforma Microsoft per le periferiche NAS. In Exchange Server 2003, si consiglia di utilizzare il layout di archiviazione di Windows Storage Server 2003, che è diverso dal layout standard di Exchange Server. La configurazione consigliata prevede la collocazione dei database Exchange Server in Windows Storage Server 2003 e dei file di log delle transazioni in un disco locale nel computer Exchange Server.

Microsoft ha sviluppato Windows Storage Server 2003 Feature Pack per tre tipi specifici di carico di lavoro:

  • Carichi di lavoro di piccole dimensioni, per un numero massimo di 250 cassette postali per ciascun Exchange Server collegato a un computer Windows Storage Server. In questo scenario, la configurazione di Windows Storage Server consigliata prevede un processore da 1 GHz o superiore, 512 MB di memoria RAM, quattro dischi di tipo SCSI o IDE/SATA configurati come volume RAID-5 e due schede di interfaccia di rete (NIC): una per la connessione a una rete LAN e una scheda Gigabit Ethernet privata per la connessione diretta al server di Exchange. I database Exchange sono memorizzati nel volume RAID-5; i registri delle transazioni rimangono nel volume RAID-1 locale del server di Exchange.

  • Carichi di lavoro di medie dimensioni, con un massimo di 750 cassette postali per gruppo di archiviazione contenute in un computer Exchange Server e un solo computer Windows Storage Server. In questa configurazione, il computer Windows Storage Server deve disporre di alcuni processori da 1 GHz o superiori, 1 GB di memoria RAM, sei dischi di tipo SCSI e alcune schede di interfaccia di rete. I dischi devono essere configurati come array di 4 dischi RAID-5 per i database e come un set di mirror da due dischi separato per i registri delle transazioni.

  • Carichi di lavoro di grandi dimensioni, con uno o due server di Exchange Server 2003 contenenti fino a 1.500 cassette postali in due gruppi di archiviazione. In questa configurazione, Windows Storage Server deve disporre di due processori da 1 GHz o superiori, 2 GB di memoria RAM e un totale di 14 dischi: 10 dischi in un array RAID 0+1 che contiene i database e due set di dischi con mirroring per i registri delle transazioni.

Questo avviso indica che il computer Exchange Server è stato configurato per eseguire l'archiviazione con Windows Storage Server 2003. Quando si utilizza Windows Storage Server per l'archiviazione dei dati di Exchange Server, è consigliabile non superare il limite di 1.500 utenti simultanei che accedono a Exchange Server.

Per risolvere il problema

  • Eseguire una delle seguenti operazioni:

    • Spostare i registri delle transazioni in un disco locale nel computer Exchange Server.

    • Spostare alcune cassette postali del computer Exchange Server in un altro computer Exchange Server in modo che nel computer Exchange Server che utilizza Windows Storage Server siano presenti al massimo 1.500 cassette postali.

Per ulteriori informazioni sull'utilizzo di Windows Storage Server 2003 Feature Pack con Exchange Server 2003, consultare il documento "Managing Exchange Storage with the Windows Storage Server 2003 Feature Pack" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34942 (informazioni in lingua inglese).

Per ulteriori informazioni, consultare le seguenti risorse aggiuntive:

  • Introduction to Windows Storage Server 2003 Architecture and Deployment all'indirizzo http://go.microsoft.com/fwlink/?linkid=34943 (informazioni in lingua inglese).

  • Building Better Protected Storage using Windows Storage Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=34944 (informazioni in lingua inglese).

  • Server Consolidation Using Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47586 (informazioni in lingua inglese).


L'attributo networkAddress non è impostato correttamente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo networkAddress contiene la stringa ncacn_ip_tcp. Se le seguenti condizioni vengono soddisfatte, verrà visualizzato un messaggio di errore:

  • La stringa ncacn_ip_tcp non esiste.

  • La stringa ncacn_ip_tcp è danneggiata.

In Microsoft Office Outlook® Web Access per Exchange Server 2003, il valore dell'attributo networkaddress viene esaminato dal server front-end quando questo tenta di connettersi a un server back-end di Exchange.

Nota:
Questa operazione non è possibile con Outlook Web Access per Exchange 2000 Server.

Il server front-end richiede un valore del nome di dominio completo. Il server front-end verifica la presenza di un punto nel valore restituito per networkaddress ncacn_ip_tcp. Se le seguenti condizioni vengono soddisfatte, si verificherà un errore nella richiesta di connessione per la cassetta postale sul server back-end e il server front-end restituirà all'utente il messaggio di errore "HTTP 500 - Errore interno del server":

  • Il valore networkaddress ncacn_ip_tcp è un nome host o un nome NetBIOS (Network Basic Input/Output System).

  • Il valore networkaddress ncacn_ip_tcp non è un nome di dominio completo.

Per garantire la corretta funzionalità di Outlook Web Access 2003, è necessario aggiornare il valore networkaddress ncacn_ip_tcp nell'oggetto server di Active Directory. Il nome del server interessato viene fornito nel messaggio di errore di Exchange Server Analyzer.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Nota:
Prima di aggiornare il valore ncacn_ip_tcp, leggere il resto di questo articolo. Per ridurre al minimo i tempi di inattività dovuti al riavvio dei servizi Exchange Server, è necessario eseguire un'ulteriore procedura.
Per aggiornare il valore ncacn_ip_tcp dell'attributo networkAddress

  1. Avviare lo strumento ADSI Edit dagli strumenti di supporto di Windows 2000 Server o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Gruppi amministrativi

    • Administrative_Group_Name

    • Server

  3. Fare clic con il pulsante destro del mouse su Exchange_Server_Name e scegliere Proprietà.

  4. Fare clic su networkaddress nell'elenco Attributi, quindi selezionare Modifica.

  5. Aggiungere un nuovo valore per ncacn_ip_tcp. Utilizzare il nome di dominio completo del server invece del nome NetBIOS o del nome host.

    La sintassi per questo valore è ncacn_ip_tcp:FQDN. Ad esempio, se il server back-end di Exchange dispone di un nome host quale, ad esempio, EXCHANGE1 e se il nome di dominio completo è EXCHANGE1.contoso.com, utilizzare il valore seguente per ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com

  6. Fare clic su OK due volte per rendere effettiva la modifica.

  7. Riavviare tutti i servizi Exchange Server sul server.

  8. Se sono presenti più controller di dominio, attendere la replica prima di tentare l'accesso dal server front-end. Se il problema persiste dopo il completamento della replica, riavviare il servizio Amministrazione IIS sul server front-end.

Se si mantengono file host sui server back-end per correlare un indirizzo IP del server contenente un nome host breve, è necessario aggiornare anche il valore UpdateProtocols registry. Se viene utilizzato un file host, il valore ncacn_ip_tcp potrebbe essere nuovamente modificato al riavvio di Supervisore sistema di Microsoft Exchange. Se il server back-end è di tipo cluster, il valore ncacn_ip_tcp potrebbe essere nuovamente modificato dopo il failover.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per modificare il valore UpdateProtocols del Registro di sistema per server back-end in cui si utilizzano file host

  1. Utilizzare un editor del Registro di sistema per configurare il seguente valore sui server o sul server back-end: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Nota:
    Se il valore UpdateProtocols non è presente, è necessario crearlo. Per eseguire l'operazione, procedere come segue:

  2. Aprire un editor del Registro di sistema e individuare la seguente sottochiave: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    1. Fare clic con il pulsante destro del mouse su Parametri, scegliere Nuovo, quindi fare clic su Valore DWORD.

    2. Digitare UpdateProtocols, quindi premere INVIO.

  3. Fare clic con il pulsante destro del mouse su UpdateProtocols, selezionare Modifica, digitare 0 nel campo Dati valore e fare clic su OK.

  4. Se nella rete viene utilizzato un file Hosts sul nodo cluster back-end, modificare l'ordine della voce UpdateProtocols nel modo seguente:

    IPAddress to FQDN

    IPAddress to NetBIOS

    invece di:

    IPAddress to NetBIOS

    IPAddress to FQDN

  5. Riavviare tutti i servizi Exchange Server sul server.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


L'oggetto Performance Monitor Network Interface non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Bytes Total/sec dell'oggetto prestazioni Network Interface per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni Network Interface è disabilitato.

  • L'oggetto Performance Monitor Network Interface non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestaizone.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni Network Interface sia abilitato.

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina "Exctrlst.exe: Extensible Performance Counter List" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base, "Ricostruzione manuale dei valori della Libreria dei contatori di prestazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


Versione di MSGTRACK.dll più recente disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-10-05

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati da più contatori di prestazioni dell'oggetto prestazioni Processor per analizzare i dati delle prestazioni.

Inoltre, Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version del file Msgtrak.dll.

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • Nel server si è verificato un elevato utilizzo della CPU.

  • Il valore della chiave Version per il file Msgtrak.dll è inferiore a 6.0.6373.0.

Tale avviso indica che la versione del file Msgtrack.dll rilevata può essere la potenziale causa dell'elevato utilizzo della CPU. Indica, inoltre, che la versione del file Msgtrack.dll rilevata può causare un elevato utilizzo della memoria da parte del processo Inetinfo.exe.

Per ulteriori informazioni sul problema, richiedere l'aggiornamento a cui fa riferimento l'articolo 811409 della Microsoft Knowledge Base relativo alla verifica dei messaggi che può causare un elevato utilizzo ella memoria da parte del processo Inetinfo.exe, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=811409.


Versione di WLDAP32.DLL più recente disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati da più contatori di prestazioni dell'oggetto prestazioni Processor per analizzare i dati delle prestazioni.

Microsoft Exchange Server Analyzer Tool legge inoltre la seguente voce del Registro di sistema per determinare la versione di Microsoft Windows® in esecuzione sul computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 di CurrentVersion indica che sul computer Exchange Server è in esecuzione Microsoft Windows NT® 4.0. Il valore 5.0 indica che sul computer Exchange Server è in esecuzione Windows 2000 Server, mentre il valore 5.2 indica che sul computer Exchange Server è in esecuzione Microsoft Windows Server™ 2003.

Inoltre, Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore impostato per la chiave Version del file Wldap32.dll.

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • Exchange Server Analyzer ha rilevato un elevato utilizzo della CPU sul server analizzato.

  • Sul computer Exchange Server è in esecuzione Windows 2000 Server.

  • Il valore della chiave Version del file Wldap32.dll indica una versione precedente alla 5.0.2195.7044.

Tale avviso indica che la versione di Wldap32.dll rilevata può causare un utilizzo del 100% della CPU da parte del processo Inetinfo.exe sui sistemi Windows 2000 Server.

Per risolvere il problema, richiedere l'aggiornamento a cui fa riferimento l'articolo 899019 della Microsoft Knowledge Base relativo al processo Inetinfo.exe che può utilizzare il 100 % delle risorse di CPU in un computer Windows 2000 Server in cui viene eseguito Exchange 2000 Server, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=899019.


Il servizio NNTP è abilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio NNTP (NntpSvc). Il valore True indica che il servizio NNTP (Network News Transfer Protocol) è in esecuzione sul server di Exchange.

Exchange Server Analyzer legge inoltre la seguente proprietà nella metabase di IIS (Internet Information Services) per determinare se la sessione di inserimento dati NNTP è configurata per il server di Exchange:

/LM/NNTPSVC/1/Feeds

Se Exchange Server Analyzer rileva che il servizio NNTP è avviato ma che non è stata configurata nessuna sessione di inserimento dati per il server, verrà visualizzato un avviso.

Per risparmiare risorse e come misura di protezione generale, non è consigliabile eseguire servizi per componenti che non vengono utilizzati. Ciascun servizio che viene eseguito presenta funzionalità che potrebbero essere utilizzate da utenti malintenzionati. È consigliabile disabilitare tutti i servizi che non vengono utilizzati.

Per disabilitare il servizio NNTP

  1. Fare clic su Start, scegliere Programmi, Strumenti di amministrazione, quindi fare clic su Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio (NNTP) Network News Transfer Protocol e scegliere Proprietà.

  3. Nella scheda Generale scegliere Arresta.

  4. In Tipo di avvio selezionare Disabilitato, quindi fare clic su OK.

Per ulteriori informazioni sulla configurazione di Exchange Server 2003 per la scalabilità, consultare la Guida alla massima disponibilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47578.


Nessun server DNS disponibile per i test
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-12-05

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per ottenere l'attributo DNSServerSearchOrder per i server remoti ai quali il server su cui è eseguito Exchange Server tenta di inviare messaggi. Questo attributo è un array di indirizzi IP di server utilizzati per la ricerca di server DNS.

Microsoft® Exchange Server Analyzer Tool esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchSMTPExternalDNSServers nella classe protocolCfgSMTPServer per gli oggetti server di Exchange 2000 Server ed Exchange Server 2003. La classe protocolCfgSMTPServer contiene le impostazioni per un server virtuale SMTP. Se l'attributo msExchSMTPExternalDNSServers è impostato, il server virtuale SMTP utilizza un server DNS esterno.

Infine, viene utilizzato il cmdlet di Exchange Management Shell riportato di seguito per eseguire una query sui valori delle proprietà ExternalDNSServers e InternalDNSServers di ruoli del server di trasporto di un server Exchange 2007 di destinazione. La proprietà ExternalDNSServers specifica l'elenco di server DNS esterni in cui viene eseguita la ricerca quando viene risolto un dominio remoto. La proprietà InternalDNSServers specifica l'elenco di server DNS da utilizzare per risolvere un nome di dominio locale per il server di destinazione.

Copia codice
get-TransportServer -Identity %ExchangeServerName% -DomainController %DomainControllerName%

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • Microsoft Exchange Server Analyzer non è in grado di recuperare il valore dell'attributo DNSServerSearchOrder. Oppure l'attributo non contiene dati.

  • L'attributo msExchSMTPExternalDNSServers per gli oggetti server di Exchange 2000 Server ed Exchange Server 2003 non è impostato.

  • I valori delle proprietà ExternalDNSServers e InternalDNSServers per i ruoli del server di trasporto di Exchange 2007 non contengono dati.

Tale errore indica che Exchange Server Analyzer non è in grado di identificare server DNS utilizzati dal server di Exchange di destinazione. Inoltre, il flusso della posta potrebbe essere influenzato negativamente da questa condizione.

Le cause della condizione possono essere le seguenti:

  • Il servizio DNS è configurato in modo errato sul server di destinazione.

  • Si è verificato un errore di WMI o non è possibile l'accesso.

Per risolvere questo problema:

  • Esaminare la configurazione di DNS sul server di destinazione.

  • Verificare che sia possibile accedere a WMI di Exchange.

Per verificare che sia possibile accedere a WMI di Exchange

  1. Assicurarsi che il server di Exchange sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il server di Exchange sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC (Remote Procedure Call) sono bloccate.

  4. Controllare le autorizzazioni dell'account per cui è in esecuzione Microsoft Exchange Server Analyzer Tool. L'account deve disporre delle autorizzazioni di amministratore locale su ciascun server di Exchange analizzato.

    In alternativa, è possibile concedere un'autorizzazione WMI specifica all'account su cui è in esecuzione Exchange Server Analyzer:

    1. Sul server di Exchange aprire la struttura della console MMC (Microsoft Management Console) Gestione computer.

    2. In Servizi e applicazioni fare clic con il pulsante destro del mouse su Controllo WMI e scegliere Proprietà.

    3. Nella pagina delle proprietà Controllo WMI fare clic sulla scheda Protezione, quindi espandere Directory principale.

    4. Selezionare la cartella CIMV2, quindi fare clic su Protezione.

    5. Nella pagina Protezione per ROOT\CIMV2 aggiungere l'account sul quale è in esecuzione Exchange Server Analyzer.

  5. Selezionare l'account che è stato aggiunto nel passaggio 4. In Autorizzazioni per Account selezionato nella colonna Consenti selezionare sia Abilita accesso remoto sia Protezione da lettura, quindi fare clic su OK.

Per ulteriori informazioni sulla configurazione del server DNS da utilizzare con Exchange, vedere l'articolo 322856 della Microsoft Knowledge Base relativo alla configurazione del server DNS per l'utilizzo con Exchange Server, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sui problemi di connettività di Exchange Server Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (in inglese).

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Panoramica dei servizi e requisiti per le porte di rete per il sistema server Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017.


Nessun SID di account principale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-14

Lo strumento Microsoft Exchange Analyzer interroga la classe di Microsoft Strumentazione gestione Windows (WMI) Win32_NTLogEvent per determinare se nell'ultima ora è stato registrato un avviso di evento 9548 di MSExchangeIS.

Se Microsoft Exchange Analyzer rileva che un avviso di evento 9548 è stato registrato nell'ultima ora, verrà conteggiato il numero totale di avvisi di evento 9548 registrati in quell'ora.

Infine, se Exchange Analyzer rileva che un avviso di evento 9548 è stato registrato almeno 20 volte nell'ultima ora, verrà visualizzato un avviso.

Tale avviso indica la possibilità che alcuni account utente disattivati nel servizio directory di Active Directory siano associati alle cassette postali di Exchange Server e non abbiano attributi msExchMasterAccountSID validi.

Per essere disponibile, una cassetta postale presente su un server su cui viene eseguito Microsoft Exchange Server 2003 o Exchange 2000 Server deve essere collegata a un account utente del servizio directory di Active Directory. Tale collegamento è ottenibile parzialmente mediante l'impostazione dell'attributo msExchMasterAccountSid di Active Directory sulla cassetta postale. Lo stato dell'account di Active Directory a cui è collegata la cassetta postale di Exchange può essere attivo o non attivo. Solo per gli account non attivi è necessario un utente con attributo msExchMasterAccountSid.

Se il valore dell'attributo msExchMasterAccountSid su un account utente non attivo non è specificato o è danneggiato e se viene creato un elenco di controllo di accesso (ACL) che include tale account utente, è possibile che si verifichino dei problemi di prestazioni quando l'elenco di controllo di accesso viene utilizzato per accedere alle risorse della cassetta postale o della cartella pubblica.

Per risolvere il problema:

  • Accertarsi che sia stato installato Exchange Server 2003 Service Pack 2 (SP2) con l'aggiornamento rapido menzionato nell'articolo 916783 della Microsoft Knowledge Base "A hotfix is available to change the way that Exchange Server 2003 SP2 handles a disabled Active Directory user account that is associated with an Exchange Server 2003 mailbox" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783.

  • Analizzare l'elenco di controllo di accesso e l'account utente menzionati nell'avviso di evento 9548 per determinare se il valore dell'attributo msExchMasterAccountSid non è specificato o è danneggiato e, se necessario, generare un valore di attributo msExchMasterAccountSID valido per l'account in base alle istruzioni contenute nell'articolo 328880 della Microsoft Knowledge Base "How to troubleshoot public folder performance issues that are related to ACL conversions in Exchange 2000 and in Exchange 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880.

  • Rimuovere l'account utente non attivo dall'elenco di controllo di accesso in base alle istruzioni contenute nell'articolo 278966 della Microsoft Knowledge Base "You cannot move or log on to an Exchange resource mailbox", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966.

Per ulteriori informazioni

Per ulteriori informazioni su questo problema, consultare i seguenti articoli della Microsoft Knowledge Base e le risorse di Exchange Server:

  • Events and Errors Message Center: Event Details: MSExchangeIS Mailbox Store Event 9548 details, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83135 (informazioni in lingua inglese).

  • Articolo 916783 della Microsoft Knowledge Base "A hotfix is available to change the way that Exchange Server 2003 SP2 handles a disabled Active Directory user account that is associated with an Exchange Server 2003 mailbox", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=916783.

  • Articolo 328880 della Microsoft Knowledge Base, "How to troubleshoot public folder performance issues that are related to ACL conversions in Exchange 2000 and in Exchange 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328880.

  • Articolo 278966 della Microsoft Knowledge Base "You cannot move or log on to an Exchange resource mailbox", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=278966.


Nessuna istanza SMTP trovata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-08-08

Microsoft® Exchange Server Analyzer Tool esegue una query nell'attributo distingushedName del servizio directory di Active Directory® della classe oggetto protocolCfgSMTPServer per determinare se un'istanza del server virtuale SMTP (Simple Mail Transfer Protocol) è in esecuzione per il nome del server gateway di Exchange specificato dall'utente.

Se Exchange Server Analyzer non riesce a trovare un'istanza del server virtuale SMTP per il server gateway di Exchange specificato dall'utente, verrà visualizzato un errore.

L'errore potrebbe essere causato da problemi di rete oppure indicare informazioni non corrette in Active Directory.

Per risolvere il problema rivedere la configurazione del server virtuale SMTP per il server gateway di Exchange specificato dall'utente.

Per visualizzare la configurazione dell'istanza del server virtuale SMTP

  1. Avviare il Gestore di sistema di Exchange:

    Fare clic su Start, scegliere Programmi , quindi Microsoft Exchange e infine fare clic su Gestore di sistema.

  2. Passare al contenitore seguente:

    \Administrative Groups\GroupName\Servers\ServerName\Protocols\SMTP\SMTP Virtual Server Instance\

  3. Fare clic con il pulsante destro del mouse sull'istanza del server virtuale SMTP desiderata e selezionare Proprietà.

  4. Verificare che la configurazione dell'istanza del server virtuale SMTP sia corretta.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP vedere gli articoli della Knowledge Base riportati di seguito:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sul design del servizio SMTP vedere "Design del servizio SMTP" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=58876.

Per ulteriori informazioni sui problemi di connettività della rete vedere l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.


Il server di destinazione NSPI è stato sostituito manualmente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se il servizio NSPI del server di destinazione (Name Service Provider Interface, interfaccia provider del servizio nomi) è stato ignorato manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\NSPI Target Server

Se Exchange Server Analyzer rileva che RFR Target Server è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

I diversi tipi di client utilizzano controller di dominio e server di catalogo globale in modo differente per l'accesso all'elenco indirizzi globale (GAL, Global Address List). I client Exchange precedenti a Microsoft Outlook® 2000 Service Release 2 (SR-2) richiedono un servizio directory nel server di Exchange. Exchange 2000 Server e Exchange Server 2003 utilizzano un meccanismo denominato Directory Service Proxy (DSProxy) per stabilire una connessione con il server di catalogo globale per conto del client e comunicazioni proxy tra Outlook e il server di catalogo globale. A seconda dei requisiti di distribuzione, è possibile specificare esplicitamente un particolare server di catalogo globale da utilizzare per la gestione delle richieste DSProxy. Per eseguire questa operazione, è necessario specificare a livello di codice la voce NSPI Target Server nel Registro di sistema del server di Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per specificare manualmente un server NSPI

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Creare un nuovo valore REG_MULTISZ denominato NSPI Target Server.

  4. Configurare il valore NSPI Target Server con il nome di dominio completo per i server da specificare.

Per disabilitare un'impostazione statica per il server NSPI, rimuovere il nome di dominio completo del server da rimuovere. Se è stato immesso un solo server di destinazione NSPI, eliminare il valore NSPI Target Server del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'interazione di client Outlook 2000 SR-2 e versioni successive con il servizio directory di Active Directory®, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 302914, "XCCC: Accesso di Outlook 2000 ad Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914.

  • 256976, "XCLN: Accesso di client MAPI ad Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976.


È installato un sottosistema MAPI non Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare la versione di MAPI32.dll presente nelle due cartelle seguenti:

<unità>:\Programmi\Exchsrvr\Bin

%Systemroot%\System32

Se la stessa versione e la copia di MAPI32.DLL non vengono rilevate in entrambe le cartelle, verrà visualizzato un messaggio di errore.

Per assicurare che una versione singola del MAPI sia in uso, il programma di installazione di Exchange Server copia MAPI32.dll in entrambe le <unità> :\Programmi\Exchsrvr\Bin e nelle directory %Systemroot%\system32. Se nel computer Exchange Server viene installata un'altra applicazione MAPI, ad esempio Microsoft® Office Outlook® o un programma di terze parti, è possibile copiare una versione diversa di MAPI32.DLL nella cartella System32 e interrompere potenzialmente la funzionalità Exchange. Questo si verifica perché le versioni dei due prodotti ptovocano un conflitto del sottosistema MAPI, che non può essere risolto senza interrompere Exchange Server o l'altra applicazione MAPI.

Si consiglia di non installare nello stesso computer Outlook 2000 o versioni più recenti insieme a Exchange Server 2003, Exchange 2000 Server o Exchange Server 5.5.

Un motivo comune per installare Outlook nello stesso computer in cui è installto Exchange Server è la possibilità di usufruire di determinati componenti di Outlook in programmi lato server. Per la maggior parte dei requisiti di sviluppo dei programmi, Outlook non è richiesto su un computer Exchange. Exchange Server include il modello CDO (Collaboration Data Objects) con funzionalità simili a quelle dell'Outlook Object Model. Il CDO è progettato per l'utilizzo sul lato server ed evita le implicazioni incluse nelle ultime versioni di Outlook. Per ulteriori informazioni, consultare l'articolo 290500 della Microsoft Knowledge Base, "OL2002: Informazioni dello sviluppatore sulle funzioni di protezione dei messaggi di posta" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=290500.

Un altro motivo comune è la necessità di creare profili MAPI. Exchange Server include tutte le funzionalità necessarie alla creazione dei profili MAPI e non richiede assolutamente Outlook. Per ulteriori informazioni sulla creazione di profili MAPI senza l'installazione di Outlook, consultare l'articolo 306962 della Microsoft Knowledge Base, "HOW TO: Creazione di profili MAPI senza installare Outlook" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306962.

Se è necessario installare Outlook ed Exchange Server nello stesso computer a scopo dimostrativo si consiglia di utilizzare una delle seguenti configurazioni che sono state verificate a scopo dimostrativo:

  • Exchange 2000 Server utilizzato con Outlook 2000

  • Exchange 2000 Server utilizzato con Outlook 2002

Per risolvere il problema

  1. Disinstallare Microsoft Outlook o l'applicazione MAPI di terze parti dal server di Exchange.

  2. Eseguire nuovamente il programma di installazione di Exchange Server e fare clic su Reinstalla.

Per ulteriori informazioni sull'utilizzo di Microsoft Office Outlook 2003 e Microsoft Exchange Server sullo stesso computer, consultare l'articolo 266418 della Microsoft Knowledge Base, "XCCC: Microsoft sconsiglia l'installazione di Exchange 2000 Server e Outlook 2000 o successivo nello stesso computer" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418.

Per ulteriori informazioni sulla risoluzione dei conflitti MAPI, consultare l'articolo 229700 della Microsoft Knowledge Base, "HOW TO: Trovare il percorso corretto per MAPISVC.INF in Outlook 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=229700.

Per ulteriori informazioni sulla libreria stub MAPI32, consultare Messaging API (MAPI) all'indirizzo http://go.microsoft.com/fwlink/?linkid=34395.


Rilevato motore ESE non Microsoft
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il file Ese.dll, il Motore di archiviazione del database di Microsoft Exchange, conosciuto anche come ESE (Extensible Storage Engine).

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Microsoft Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Microsoft Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Microsoft Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore di Version non contiene una sottostringa 6 come parte delle informazioni sulla versione, ma il valore di serialNumber indica che sono installati Exchange 2000 Server o Exchange Server 2003, verrà visualizzato un avviso. Questo avviso indica che in questo computer Exchange Server è installata ed eseguita una versione di Ese.dll non Microsoft. È necessario correggere al più presto il problema.

Una causa possibile di questo problema può essere l'utilizzo di un software antivirus basato su ESE. Alcuni programmi antivirus basati su ESE utilizzano un'interfaccia non supportata tra l'archivio di informazioni di Exchange ed ESE. Quando si utilizza questo tipo di software, si corre il rischio di danneggiare il database e perdere dati, qualora si verifichino errori nell'implementazione del software.

Durante l'installazione, il programma antivirus basato su ESE modifica il servizio Archivio informazioni di Microsoft Exchange, in modo che dipenda dal servizio del programma antivirus basato su ESE. Questo garantisce che il servizio del programma antivirus basato su ESE venga avviato prima del servizio Archivio informazioni di Microsoft Exchange. Quando viene avviato il programma antivirus basato su ESE, la versione di Ese.dll inclusa in Exchange Server viene temporaneamente rinominata Xese.dll e la versione di Ese.dll del programma antivirus basato su ESE sostituisce il file originale. Dopo che viene caricata la versione di Ese.dll del programma antivirus basato su ESE, la versione inclusa in Exchange Server viene rinominata Ese.dll e il servizio Archivio informazioni di Microsoft Exchange completa il processo di avvio.

Si consiglia di non utilizzare implementazioni non Microsoft di ESE su computer Exchange Server. Ai clienti che si rivolgono al Servizio Supporto Tecnico Clienti Microsoft può venire chiesto di disattivare il programma antivirus basato su ESE per aiutare a identificare i problemi, ma i clienti sono liberi di riattivare il software dopo che è stata correttamente diagnosticata la causa principale del problema.

Il programma antivirus basato su ESE più utilizzato è Antigen per Microsoft Exchange di Sybari Software. Microsoft e Sybari concordano che la disattivazione di Sybari Antigen è un corretto passaggio in una procedura di risoluzione di problemi per riuscire a determinare la causa dei problemi stessi. Per contattare Sybari Software, visitare il relativo sito Web all'indirizzo http://www.sybari.com.

Nota:
Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli indirizzi Web sono soggetti a modifiche senza preavviso.

È inoltre consigliabile utilizzare programmi antivirus che supportano l'interfaccia VSAPI (Virus Scanning Application Programming Interface), conosciuta anche come AVAPI (AntiVirus API).

Per risolvere il problema

  1. Eseguire un backup completo del computer Exchange Server.

  2. Disinstallare Exchange Server dal computer.

  3. Reinstallare Exchange Server nel computer.

  4. Installare il Service Pack e aggiornamenti più recenti per Exchange Server.

Per ulteriori informazioni sull'esecuzione di software antivirus in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.


Rilevato Extensible Storage Engine non Microsoft
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il file Ese.dll, il Motore di archiviazione del database di Exchange, noto anche come ESE (Extensible Storage Engine).

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Microsoft Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Microsoft Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Microsoft Exchange Server 2003.

Se Exchange Server Best Practices Analyzer rileva che il valore di Version non contiene una sottostringa 5.5 come parte delle informazioni sulla versione, ma il valore di serialNumber indica che è installato Exchange Server 5.5, verrà visualizzato un avviso. Questo avviso indica che in questo computer Exchange Server è installata ed eseguita una versione di Ese.dll non Microsoft. È necessario correggere al più presto il problema.

Una causa possibile di questo problema può essere l'utilizzo di un software antivirus basato su ESE. Alcuni programmi antivirus basati su ESE utilizzano un'interfaccia non supportata tra l'archivio di informazioni di Exchange ed ESE. Quando si utilizza questo tipo di software, si corre il rischio di danneggiare il database e perdere dati, qualora si verifichino errori nell'implementazione del software.

Durante l'installazione, il programma antivirus basato su ESE modifica il servizio Archivio informazioni di Microsoft Exchange, in modo che dipenda dal servizio del programma antivirus basato su ESE. Questo garantisce che il servizio del programma antivirus basato su ESE venga avviato prima del servizio Archivio informazioni di Microsoft Exchange. Quando viene avviato il programma antivirus basato su ESE, la versione di Ese.dll inclusa in Exchange Server viene temporaneamente rinominata Xese.dll e la versione di Ese.dll del programma antivirus basato su ESE sostituisce il file originale. Dopo che è stata caricata la versione di Ese.dll del programma antivirus basato su ESE, la versione inclusa in Exchange Server viene rinominata Ese.dll e il servizio Archivio informazioni di Microsoft Exchange completa il processo di avvio.

Si consiglia di non utilizzare implementazioni non Microsoft di ESE su computer Exchange Server. Ai clienti che si rivolgono al Servizio Supporto Tecnico Clienti Microsoft può venire chiesto di disattivare il programma antivirus basato su ESE per aiutare a identificare i problemi, ma i clienti possono riattivare il software dopo che è stata correttamente diagnosticata la causa principale del problema.

Per risolvere il problema

  1. Eseguire un backup completo del computer Exchange Server.

  2. Reinstallare Exchange Server nel computer.

  3. Installare il Service Pack o gli aggiornamenti cumulativi più recenti per Exchange Server, che è possibile ottenere nel sito Web di Microsoft Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21573.
  • Per ulteriori informazioni sull'esecuzione di programmi antivirus in Exchange Server, consultare l'articolo 328841 della Microsoft Knowledge Base "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

  • Per ulteriori informazioni sulla ricostruzione di un computer Exchange Server 5.5 utilizzando lo stesso nome del computer, consultare l'articolo 155216 della Microsoft Knowledge Base "XADM: Spostamento di Exchange Server su un nuovo computer con lo stesso nome" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=155216.


La riserva non di paging ha superato la soglia di avviso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_PerfOS_Memory per determinare il valore corrente della chiave PoolNonpagedBytes. Le operazioni eseguite da Exchange Server Analyzer dipendono dal sistema operativo sottostante, dalla presenza o assenza dell'opzione /3GB nel file Windows Boot.ini e dal valore rilevato per questa chiave.

Nella seguente tabella viene visualizzata la matrice di valutazioni utilizzata da Exchange Server Analyzer per determinare se questo valore è oltre i limiti per un server di Exchange specificato. Se le condizioni della seguente tabella sono soddisfatte, verrà visualizzato un avviso.

Sistema operativo | Impostazione Boot.ini | La riserva non di paging corrente è
Microsoft Windows 2000 Server o Advanced Server | /3GB | Almeno 100 MB
Microsoft Windows 2000 Server o Advanced Server | Nessuno | Almeno 200 MB
Microsoft Windows Server™ 2003 | /3GB | Almeno 100 MB
Microsoft Windows Server 2003 | Nessuno | Almeno 200 MB

Il valore della chiave PoolNonpagedBytes rappresenta la dimensione, in byte, della riserva non di paging della memoria del kernel. Si tratta di un'area di memoria fisica di sistema per gli oggetti che non possono essere scritti su disco anche quando non vengono utilizzati. Questo è l'ultimo valore osservato per questa chiave. In un server di Exchange che funziona correttamente dovrebbero essere disponibili, a meno che non sia in corso un'operazione di backup o ripristino, non più di 85 MB di memoria di riserva non di paging in uso.

In Windows 2000 Server e Windows 2000 Advanced Server, il valore massimo della memoria di riserva non di paging è 256 MB. Poiché non è possibile aumentare il limite relativo a tale memoria oltre i valori elencati sopra, è necessario correggere questa condizione al più presto. Indipendentemente dal sistema operativo in uso o dalla presenza o assenza dell'opzione /3GB, è possibile accedere mediante Windows solo a tale quantità di memoria di riserva non di paging. Se Windows esaurisce la memoria del kernel, possono essere visualizzati messaggi di errore e il sistema si può arrestare in modo anomalo. La memoria del kernel è fondamentale per il corretto funzionamento del sistema e, pertanto, è necessario monitorarla attentamente.

Se questa condizione si verifica anche dopo il riavvio di Exchange Server, l'operazione successiva da compiere consiste nell'assicurarsi che il sistema sia regolato in modo corretto e che tutti i prodotti software e hardware presenti in esso sia aggiornati. La procedura include l'installazione delle ultime versioni di:

  • Service Pack del sistema operativo Windows

  • Service Pack di Exchange Server

  • Hardware, firmware e driver

  • Aggiornamenti del BIOS del sistema

  • Aggiornamenti di eventuali applicazioni di terze parti installate e in esecuzione

Se gli aggiornamenti di software e hardware non risolvono il problema, è preferibile disabilitare tutti i programmi software di terze parti, riavviare il computer Exchange Server e monitorare la memoria del kernel.

Per risolvere il problema

  1. Riattivare il computer Exchange Server non appena possibile.

  2. Monitorare il contatore di prestazioni Memoria | Byte della riserva non di paging per assicurarsi che non oltrepassi il limite elencato sopra per il sistema.

Per ulteriori informazioni sulla corretta regolazione di Exchange Server, consultare i seguenti documenti e articoli della Microsoft Knowledge Base:

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 266096, "XGEN: In Exchange 2000 è necessario il parametro /3GB con oltre 1 GB di RAM fisica" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096.

  • "Troubleshooting Exchange Server 2003 Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • "Troubleshooting Exchange 2000 Server Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=18177 (informazioni in lingua inglese).

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla memoria di riserva non di paging e sugli argomenti correlati, consultare i seguenti articoli della Knowledge Base:

  • 294418, "Confronto fra le architetture della memoria a 32 e a 64 bit" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=294418.

  • 177415, "Utilizzo dello strumento Poolmon.exe per la risoluzione dei problemi di perdita di memoria in modalità kernel" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=177415.

  • 268343, "Umdhtools.exe: utilizzo di Umdh.exe per rilevare le perdite di memoria" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268343.


Il numero di PTE (Page Table Entry) libere è basso e potrebbe provocare l'instabilità del sistema
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'impostazione del valore del Registro di sistema SystemPages:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Se Exchange Server Analyzer rileva che il valore di SystemPages è impostato su 0 e il numero di PTE libere è minore di 3001, verrà visualizzato un avviso.

Windows Server 2003™ e Windows 2000® Server possono indirizzare direttamente fino a 4 GB di spazio di indirizzi della memoria, indipendentemente dalla quantità di RAM fisica installata. Dal punto di vista del processo, ciascun elemento dell'indirizzo virtuale fa riferimento concettualmente a un byte di memoria fisica. Spetta al Gestore della memoria virtuale (VMM, Virtual Memory Manager) insieme all'unità di gestione della memoria (MMU, Memory Manager Unit) del processore tradurre o eseguire il mapping di ciascun indirizzo virtuale in un indirizzo fisico corrispondente. VMM esegue il mapping dividendo la RAM in pagine di memoria di dimensioni definite, creando PTE (Page Table Entry) di sistema per archiviare le informazioni relative a tali pagine e associandole. Le PTE di sistema sono piccoli buffer di memoria in modalità kernel che vengono utilizzate per comunicare con il sottosistema di I/O del disco e con la rete. Ciascuna PTE rappresenta una pagina di memoria e contiene informazioni necessarie al VMM per individuare una pagina.

In un sistema x86 che utilizza una dimensione di pagina pari a 4 KB, il numero massimo delle PTE necessarie per eseguire il mapping di 2 GB di spazio di indirizzi è 524.288 (2 GB/4 KB). In un sistema simile che utilizza l'opzione /3GB, il numero di PTE necessarie per il mapping di 3 GB di spazio di indirizzi è 786.432 (3 GB/4 KB). In un sistema tipico, questo spazio viene utilizzato nel seguente modo:

  • Un massimo di 50.000 PTE (circa 195 MB di spazio di indirizzi) sono riservate all'utilizzo generale.

  • Il resto viene utilizzato nel mapping della cache di sistema, iperspazio, pool di paging, pool non di paging, area di dettagli crash e così via.

Questa dimensione del pool di PTE viene determinata automaticamente all'avvio del sistema in base alla quantità di memoria fisica nel sistema. Questo pool è compresso tra riserva di paging e riserva non di paging. Inoltre, aumenta anche in base alla quantità di memoria fisica nel sistema.

Il pool delle PTE di sistema può essere sottoposto a un notevole utilizzo e a una considerevole frammentazione. In questo modo possono verificarsi situazioni in cui non è possibile caricare un driver. Inoltre, se la riserva delle PTE di sistema è completamente esaurita, si verificherà una riduzione del livello delle prestazioni di altre parti del sistema, causando anche la mancata creazione di thread, blocchi e potenziali arresti anomali del sistema.

Un computer Exchange Server che funziona correttamente dovrebbe avere almeno 5.000 PTE di sistema disponibili in qualsiasi momento. Se il numero delle PTE di sistema disponibili scende al di sotto di 5.000 ma rimane al di sopra di 3.001, verrà visualizzato l'avviso descritto in Il numero di PTE (Page Table Entry) libere ha raggiunto la soglia di avviso. Quando il numero delle PTE di sistema disponibili scende al di sotto di 3.001, verrà visualizzato questo messaggio di errore. Per risolvere il problema, è possibile utilizzare la procedura descritta di seguito per configurare correttamente il valore SystemPages del Registro di sistema per il sistema operativo del computer che esegue Microsoft Exchange Server. Quando si esegue Exchange Server 2003 Service Pack 1 (SP1) su Microsoft Windows Server 2003 con almeno 1 GB di memoria RAM, è consigliabile impostare la chiave SystemPages del Registro di sistema su 0. Questa indicazione è in contrasto con quella valida per Microsoft Windows® 2000 Server, in cui la chiave SystemPages deve essere impostata su un valore compreso tra 24.000 e 31.000.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Dopo aver eseguito la procedura descritta di seguito, è preferibile controllare il numero delle PTE di sistema libere. È possibile eseguire questa operazione monitorando i contatori di prestazioni Memoria | PTE libere di sistema con Monitor di sistema di Windows (noto anche come Performance Monitor). Se, dopo aver apportato al Registro di sistema le modifiche descritte di seguito, il numero di PTE di sistema libere rimane insufficiente, verificare quanto segue per assicurarsi che il computer Exchange Server sia configurato correttamente:

  • Driver Un driver che non funziona correttamente rappresenta una delle cause più comuni di PTE di sistema insufficienti. Verificare con il produttore hardware che i driver utilizzati per l'hardware siano aggiornati. Esiste inoltre la possibilità di effettuare un downgrade a un driver di livello inferiore. Ad esempio, i computer che eseguono applicazioni basate su server come Exchange Server in genere non richiedono i più avanzati driver video con tutte le funzioni. Spesso è sufficiente un driver di livello inferiore. Il passaggio da un driver video avanzato a uno di livello inferiore dovrebbe aumentare il numero delle PTE di sistema libere.

  • Configurazione di sistema Se il sistema dispone di almeno 1 GB di memoria fisica installata, è consigliabile verificare che il relativo file Boot.ini sia correttamente configurato con le opzioni /3GB e /USERVA=3030, come descritto nei seguenti articoli della Microsoft Knowledge Base:

    • 823440, "Utilizzo obbligatorio dell'opzione /3GB nell'installazione di Exchange Server 2003 in un sistema basato su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440.

    • 810371, "XADM: Utilizzo dell'opzione /Userva in server di Exchange basati su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • Registri eventi Controllare la presenza di eventuali errori o avvisi nel registro eventi dell'applicazione sul server di Exchange, in particolare eventi 9582 (errori e avvisi), 9665 (avviso) e 12880 (errore) MSExchangeIS. La presenza dell'evento 9665 potrebbe indicare anche che la chiave SystemPages non è configurata per prestazioni ottimali. Per ulteriori informazioni su tali eventi, consultare l'articolo 325044 della Microsoft Knowledge Base "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

Per correggere questo errore su Windows 2000 Server

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore immettere un valore compreso tra 24000 e 31000 (decimale) e fare clic su OK.

  5. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Per correggere questo errore su Windows Server 2003

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore digitare 0 e fare clic su OK.

  5. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'ottimizzazione della memoria di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.


Il numero di chiamate in corso attualmente in attesa di ricerca virus è quasi al limite
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per determinare il numero di chiamate in corso attuale dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente VAPI (Virus API) .

Microsoft Exchange Server Analyzer Tool esegue inoltre una query nella chiave ScanningThreads dalla seguente voce del registro di sistema per determinare il numero massimo consentito di thread per le chiamate del componente VAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Microsoft Exchange Server Analyzer Tool rileva che il numero di chiamate in corso dal servizio Archivio informazioni di Exchange (Store.exe) al componente VAPI è prossimo al numero massimo consentito di thread, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Microsoft Exchange al componente VAPI:

  • Aggiornamenti a un programma antivirus che avvia nuove analisi degli elementi dell'Archivio informazioni.

  • Configurazione non corretta del programma antivirus.

  • Il software antivirus elabora messaggi o allegati di grandi dimensioni.

Per risolvere il problema, procedere come segue:

  • Programmare gli aggiornamenti del motore di ricerca virus in orari in cui l'utilizzo delle risorse è basso, ossia negli orari di scarso traffico.

  • Reinstallare il software antivirus, ma negli orari di scarso traffico.

  • Verificare la corretta configurazione di thread, esclusioni file, ecc. del motore di ricerca virus. Vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Aumentare il numero dei thread per il componente VAPI:

    Il valore opzionale di ScanningThreads è uguale a (2 * NumberOfProcessors) + 1. Per esempio, per un server di Exchange Server dotato di due processori, il valore ottimale di ScanningThreads è 5.

    Nota:
    Se la tecnologia Hyper-Threading è abilitata, il valore per NumberOfProcessorssarà il doppio del numero di processori fisici. Si consiglia di verificare con il produttore del software antivirus se nella formula è necessario utilizzare i processori fisici o quelli logici.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di conoscere le operazioni per ripristinarlo qualora si verifichi un problema. Per informazioni su questa procedura, vedere l'argomento della Guida relativo al ripristino del registro di sistema in Regedit.exe o Regedt32.exe.
Per aumentare il numero dei thread

  1. Aprire un editor del registro di sistema, quale Regedit.exe o Regedt32.exe.

  2. Andare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Nel riquadro destro fare doppio clic su ScanningThreads.

  4. Immettere il valore restituito dalla formula indicata sopra.

  5. Chiudere l'editor del registro di sistema, quindi riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al registro di sistema e per ulteriori informazioni su questa procedura, vedere l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, vedere l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

Per ulteriori informazioni sulla tecnologia Hyper-Threading, vedere il sito Web di Intel all'indirizzo http://www.intel.com/technology/hyperthread.

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


File OABGEN.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di alcuni dei file precedenti, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Richiesta del Service Pack/aggiornamento cumulativo più recente per Exchange Server 5.0
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il processo STORE.EXE. Se Exchange Server Analyzer determina che la chiave Version per STORE.EXE presenta un valore maggiore o uguale a 1460 e minore di 1462, verrà visualizzato un avviso.

Questo avviso indica che il computer Exchange Server non esegue il codice più recente disponibile per la versione di Exchange in esecuzione sul computer.

Per risolvere il problema

  1. Consultare l'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41361 per scaricare l'aggiornamento più recente (aprile 2004) per Exchange Server 5.0.

  2. Per ulteriori informazioni su a questo aggiornamento, consultare l'articolo 834130 della Microsoft Knowledge Base "Aggiornamento cumulativo per Microsoft Exchange 5.0" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834130.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Applicare l'aggiornamento di aprile 2004.

Per ottenere l'aggiornamento cumulativo più recente per Exchange Server 5.0 Service Pack 2, consultare l'articolo 168858 della Microsoft Knowledge Base "XGEN: Come ottenere Exchange Server 5.0 U.S. Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=168858.

Per ulteriori informazioni sull'installazione di questo e di altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Richiesta del Service Pack/aggiornamento cumulativo più recente per Exchange Server 5.5
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il processo STORE.EXE. Se Exchange Server Analyzer determina che la chiave Version per STORE.EXE presenta un valore maggiore o uguale a 2653, ma minore di 2658, verrà visualizzato un avviso. Ciò indica che il computer esegue Exchange Server 5.5 Service Pack 4 o Exchange Server 5.5 Service Pack 4 con aggiornamenti rapidi.

Questo avviso indica che il computer Exchange Server non esegue il codice più recente disponibile per la versione di Exchange in esecuzione sul computer.

Per risolvere il problema

  1. Visitare l'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33456 per scaricare l'aggiornamento più recente (maggio 2004) per Exchange Server 5.5.

  2. Per ulteriori informazioni relative a questo aggiornamento, consultare l'articolo 841765 della Microsoft Knowledge Base "Aggiornamento cumulativo del maggio 2004 per Exchange Server 5.5" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=841765.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Applicare l'aggiornamento di maggio 2004.

Per ulteriori informazioni sull'installazione di questo e altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Richiesta del Service Pack/aggiornamento cumulativo più recente per Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il processo STORE.EXE.

  • Il valore 7638 per la chiave Version indica Exchange Server 2003 Service Pack 2

  • Il valore 7226 per la chiave Version indica Exchange 2003 Server Service Pack 1

  • Il valore di 6944 per la chiave Version indica la versione originale di Exchange Server 2003

  • Un valore tra le versioni riportate in precedenza indica che sul server è in esecuzione un versione di aggiornamento rapido del processo Store.exe.

Se Exchange Server Analyzer rileva che il valore della chiave Version per Store.exe è minore di 7638, verrà visualizzato un avviso.

Questo avviso indica che il computer Exchange Server non esegue il codice disponibile più recente per la versione di Exchange in esecuzione sul computer.

Per risolvere il problema

  1. Scaricare oppure ordinare il Service Pack 2 per Exchange Server 2003 dal sito Web "Exchange Server 2003 Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54751.

  2. Per ulteriori informazioni relative alle note sulla versione del Service Pack 2, consultare il sito Web di Exchange Server 2003 Service Pack 2 (SP2) all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52072.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Installare il Service Pack 2 per Exchange Server 2003.

Per ulteriori informazioni sull'installazione di questo e altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Richiesta del Service Pack/aggiornamento cumulativo più recente per Exchange 2000 Server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il processo STORE.EXE. Se Exchange Server Analyzer rileva che il valore della chiave Version per STORE.EXE è compreso in uno dei seguenti intervalli, verrà visualizzato un avviso:

  • Maggiore di 6249 e minore o uguale a 6396

  • Maggiore di 6396 e minore o uguale a 6487

  • Maggiore di 6487 e minore o uguale a 6556

  • Maggiore di 6556 e minore o uguale a 6603

  • Maggiore di 6603 e minore di 6700

Questo avviso indica che il computer Exchange Server non esegue il codice disponibile più recente per la versione di Exchange in esecuzione nel computer.

Per risolvere il problema

  1. Scaricare l'aggiornamento più recente (agosto 2004) dalla pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).

  2. Per ulteriori informazioni sull'aggiornamento più recente, consultare l'articolo 870540 della Microsoft Knowledge Base "Disponibile l'aggiornamento cumulativo successivo al Service Pack 3 per Exchange 2000 Server di agosto 2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Installare l'aggiornamento di agosto 2004.

Per ulteriori informazioni sull'installazione di questo e di altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Il server della Rubrica fuori rete è stato eliminato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo offLineABServer dell'oggetto di configurazione della rubrica non in linea. Se Exchange Server Analyzer rileva che il valore dell'attributo offLineABServer contiene la stringa DEL:, verrà visualizzato un messaggio di errore.

L'attributo offLineABServer è un attributo a valore singolo di nome distinto che consente di archiviare il nome distinto del computer Exchange Server responsabile della creazione di una Rubrica non in linea. Per ogni Rubrica non in linea Exchange genera e archivia i file della rubrica non in linea in un set di cartelle pubbliche in un server specifico. Questo errore indica che il server specificato nell'attributo offLineABServer dell'oggetto di configurazione della rubrica non in linea non esiste. Questa situazione può verificarsi se il server della rubrica non in linea non dispone dell'autorizzazione o se è stato rimosso dalla topologia. Exchange non genererà la Rubrica non in linea fino a quando non si specifica un nuovo server.

Per risolvere il problema in Exchange 2000 Server ed Exchange Server 2003

  1. Nel Gestore di sistema di Exchange, in Destinatari, fare clic su Elenchi di indirizzi non in linea. Nel riquadro destro fare clic con il pulsante destro del mouse su Elenco di indirizzi non in linea predefinito (o un altro elenco di indirizzi non in linea che ha generato il messaggio), quindi scegliere Proprietà.

  2. Nella sezione Server elenco indirizzi non in linea della scheda Generale fare clic su Sfoglia, quindi selezionare il server da utilizzare.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Microsoft Exchange e Configurazione organizzazione, quindi selezionare Cassetta postale.

  3. Nel riquadro dei risultati fare clic sulla scheda Rubrica fuori rete.

  4. Nella scheda Rubrica fuori rete selezionare "Rubrica fuori rete predefinita". Nel riquadro dei risultati fare clic su Sposta per avviare la procedura guidata Sposta Rubrica fuori rete, che consente di spostare la generazione della Rubrica fuori rete su un server diverso. Consente, inoltre, di copiare i file esistenti della Rubrica fuori rete sul server specificato.

Per utilizzare Exchange Management Shell per impostare il server che ospiterà la generazione della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dove: <OAB> è il nome distinto, il nome di dominio\account o l'identificatore univoco globale (GUID) della Rubrica fuori rete e <Server> consente di specificare il server di Exchange su cui eseguire l'operazione selezionata.

    Ad esempio, per spostare la generazione della Rubrica fuori rete su SERVER01, immettere:
Copia codice
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2003, consultare "Configurazione delle rubriche non in linea di Exchange Server 2003" in Utilizzo degli archivi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2007, consultare la sezione "Configurazione dell'organizzazione > Cassetta postale > Rubriche fuori rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=79247.


Server della Rubrica fuori rete in esecuzione su un server front-end
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo offLineABServer dell'oggetto di configurazione della rubrica non in linea. L'attributo offLineABServer è un attributo a valore singolo di nome distinto che consente di archiviare il nome distinto del computer Exchange Server responsabile della creazione di una rubrica non in linea.

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_Server Microsoft per determinare il valore della chiave IsFrontEndServer per il server di Exchange. Se il valore per la chiave IsFrontEndServer è True, il server di Exchange funziona come server front-end.

Se Exchange Server Analyzer determina che un server designato della rubrica non in linea è anche un server front-end, verrà visualizzato un messaggio di errore.

Il messaggio indica che il server di Exchange nominato per la generazione delle rubriche fuori rete è un server front-end. Se il server della rubrica non in linea designato è anche un server front-end, la generazione della rubrica non viene eseguita. Per questa attività è necessario nominare un nuovo server. Se un server con Microsoft Exchange 2000 Server Service Pack 2 o successivo in esecuzione viene designato come server fornt-end, non potranno più essere eseguiti i seguenti servizi:

  • DSProxy

  • Generazione Elenco di indirizzi non in linea

  • Servizio aggiornamento destinatari

  • Attività relative alla disponibilità

  • Agente di pulitura delle cassette postali

  • Servizio eventi di Exchange

  • Servizio di replica siti (SRS)

I server front-end vengono designati per gestire le richieste del client in arrivo da Microsoft Office Outlook® Web Access, POP3, IMAP4, Exchange ActiveSync, Outlook Mobile Access e dai client Outlook configurati per utilizzare RPC su HTTP. I server front-end vengono talvoltautilizzati anche per inoltrare messaggi SMTP a server interni di Exchange.

Per risolvere questo problema, si consiglia di designare un server back-end di Exchange come server della rubrica non in linea.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Nella sezione Destinatari fare clic su Elenchi di indirizzi non in linea.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse su Elenco di indirizzi non in linea predefinito e fare clic su Proprietà.

    Nota:
    Seguire la stessa procedura per ogni altro elenco di indirizzi non in linea che provoca questo errore.

  4. Nella sezione Server elenco indirizzi non in linea della scheda Generale fare clic su Sfoglia, quindi selezionare il server back-end di Exchange da utilizzare.

Per ulteriori informazioni sulle operazioni con rubriche fuori rete, consultare "Configurazione delle rubriche non in linea", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Cartella pubblica sito della Rubrica fuori rete eliminata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo siteFolderServer di ciascun oggetto dell'archivio delle cartelle pubbliche. Se Exchange Server Analyzer rileva che il valore dell'attributo siteFolderServer contiene la stringa DEL:, verrà visualizzato un messaggio di errore.

L'attributo siteFolderServer rappresenta l'archivio delle cartelle pubbliche utilizzato per il server della rubrica non in linea. Per impostazione predefinita, Exchange Server genera file della rubrica non in linea nel server della cartella sito (il primo server installato nel gruppo amministrativo). Se si è designato un server differente come server della rubrica non in linea, l'archivio delle cartelle pubbliche elencato in questo attributo sarà l'archivio nel nuovo server della rubrica non in linea e non l'archivio nel server effettivo della cartella sito del gruppo amministrativo.

Quando Exchange Server 2003 genera file della rubrica non in linea, allega i file ai messaggi di posta elettronica e inserisce i messaggi in cartelle pubbliche speciali. Microsoft® Office Outlook® 2003 recupera i messaggi dalla cartella e scarica i file allegati.

I messaggi della rubrica non in linea vengono archiviati nelle sottocartelle della cartella Rubrica non in linea, che è una delle cartelle di sistema della struttura Cartelle pubbliche predefinita. Questa cartella contiene una sottocartella per ogni gruppo amministrativo o sito nella topologia. Per impostazione predefinita, una replica del contenuto della cartella di uno specifico gruppo amministrativo si trova nel primo server installato nel gruppo amministrativo (definito server della cartella sito).

Se l'organizzazione di Exchange è Exchange Server 2007, senza client di livello inferiore (Outlook 2003 o versioni precedenti), è possibile ignorare l'avviso o l'errore. Se l'organizzazione di Exchange Server 2007 è host di client su cui è in esecuzione Outlook 2003 o una versione precedente, seguire la procedura riportata di seguito per abilitare la distribuzione delle cartelle pubbliche dei file della Rubrica fuori rete. La distribuzione delle cartelle pubbliche è il metodo di distribuzione con cui i client su cui è in esecuzione Outlook 2003 o una versione precedente accedono alla Rubrica fuori rete quando operano in modalità non linea o tramite una connessione remota.

Per risolvere il problema

  1. Se si è certi dell'esistenza del server, in Gestore di sistema di Exchange, nella sezione Server, espandere la struttura del server e il gruppo di archiviazione, quindi fare clic su Archivio delle cartelle pubbliche. Nel riquadro destro verificare che l'archivio di Exchange sia in esecuzione.

  2. Per designare un nuovo server della rubrica non in linea, in Destinatari fare clic su Elenchi di indirizzi non in linea. Quindi nel riquadro destro fare clic su Elenco di indirizzi non in linea predefinito (o un altro elenco di indirizzi non in linea che ha generato il messaggio).

    Se non si desidera utilizzare una rubrica non in linea, fare clic con il pulsante destro del mouse su Rubrica non in linea predefinita, quindi fare clic su Elimina. Altrimenti, utilizzare il resto della procedura per impostare una pianificazione.

  3. Fare clic con il pulsante destro del mouse su Elenco di indirizzi non in linea predefinito e fare clic su Proprietà.

  4. Nella sezione Server della rubrica non in linea della scheda Generale fare clic su Sfoglia per selezionare un server.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Microsoft Exchange e Configurazione organizzazione, quindi selezionare Cassetta postale.

  3. Nel riquadro dei risultati fare clic sulla scheda Rubrica fuori rete.

  4. Nella scheda Rubrica fuori rete selezionare "Rubrica fuori rete predefinita".

    1. Per abilitare la distribuzione delle cartelle pubbliche della Rubrica fuori rete, nella scheda Distribuzione selezionare Abilita distribuzione delle cartelle pubbliche.

    2. Fare clic su OK per salvare le modifiche.

  5. Per designare un nuovo server della Rubrica fuori rete, nel riquadro azioni fare clic su Sposta per avviare la procedura guidata Sposta Rubrica fuori rete, che consente di spostare la generazione della Rubrica fuori rete su un server diverso. Consente, inoltre, di copiare i file esistenti della Rubrica fuori rete sul server specificato.

Per utilizzare Exchange Management Shell per abilitare la distribuzione delle cartelle pubbliche dei file della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Set-OfflineAddressBook -Identity <OAB> -PublicFolderDistributionEnabled $true

    Dove: <OAB> è il nome distinto, il nome di dominio/account o l'identificatore univoco globale (GUID) della Rubrica fuori rete.

    Ad esempio, per abilitare la distribuzione delle cartelle pubbliche della Rubrica fuori rete predefinita, immettere:
Copia codice
Set-OfflineAddressBook -Identity "\Default Offline Address Book" -PublicFolderDistributionEnabled $true

Per utilizzare Exchange Management Shell per impostare il server che ospiterà la generazione della Rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Move-OfflineAddressBook -Identity <OAB> -Server <Server>

    Dove: <OAB> è il nome distinto, il nome di dominio\account o l'identificatore univoco globale (GUID) della Rubrica fuori rete e <Server> consente di specificare il server di Exchange su cui eseguire l'operazione selezionata.

    Ad esempio, per spostare la generazione della Rubrica fuori rete su SERVER01, immettere:
Copia codice
Move-OfflineAddressBook -Identity "My OAB" -Server "Server1"

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2003, consultare "Configurazione delle rubriche non in linea di Exchange Server 2003" in Utilizzo degli archivi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

Per ulteriori informazioni sulla generazione di Rubriche fuori rete in Exchange Server 2007, consultare la sezione "Configurazione dell'organizzazione > Cassetta postale > Rubriche fuori rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=79247.


Rilevato file CDO.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack più recente o aggiornamento cumulativo per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file DAVEX.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file DRVIIS.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • DrvIis.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è inferiore al valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per risolvere il problema, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Download per Exchange Server 2007" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (in inglese).


Rilevato file DSACCESS.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EMSMTA.EXE precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack più recente o aggiornamento cumulativo per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi né reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EPOXY.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file ESE.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-06-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, vedere la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file ESEUTIL.EXE precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EXCDO.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EXCHMEM.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


EXCHMEM.DLL meno recente presente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binary principali di Exchange Server. Questi file comprendono Exchmem.dll. Se Exchange Server Analyzer determina che il file Exchmem.dll nella cartella \%systemroot%\system32 è meno recente rispetto al file Exchmem.dll nella cartella \%exchangeroot%\bin, verrà visualizzato un avviso.

Di norma, su un server non sono presenti due copie di Exchmem.dll. Tuttavia, talvolta viene aggiunto un secondo file Exchmem.dll con un aggiornamento sul posto da una precedente versione del prodotto. La presenza di due versioni del file potrebbe provocare errori durante l'installazione delle versioni del servizio. Per impedire che si verifichino problemi, si consiglia di rinominare il file Exchmem.dll presente nella cartella \%systemroot%\system32.

Per risolvere il problema

  1. Arrestare tutti i servizi di Exchange.

  2. Rinominare il file Exchmem.dll presente nella cartella \%systemroot%\system32 in Exchmem.dll.old.

  3. Riavviare tutti i servizi di Exchange.


Rilevato file EXMIME.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EXOLEDB.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EXPOP3.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EXPROX.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EXRES.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file EXSMTP.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file MAD.EXE precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file MAPI32.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file MAPI32.DLL precedente nella cartella system32
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Il numero di una versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file MDBSZ.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file OABGEN.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack più recente o aggiornamento cumulativo per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi né reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file PHATCAT.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file PHATQ.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file REAPI.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file RESVC.DLL precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è più basso del valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Rilevato file STORE.EXE precedente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per diversi file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva che il valore Version di uno dei suddetti file è inferiore al valore Version di Exchange Server, verrà visualizzato un avviso. Un numero di versione precedente indica che potrebbero essere in uso file obsoleti.

Per risolvere il problema, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (in inglese).


Chiamate ad Active Directory in corso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-14

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano la presenza di chiamate in corso a vari componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al servizio directory di Active Directory®.

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Active Directory fornisce tutte le informazioni sulle casette postali, i servizi elenco di indirizzi e altre informazioni relative ai destinatari. La maggior parte delle informazioni sulla configurazione di Microsoft Exchange Server 2003 è salvata anche in Active Directory.

Exchange Server gestisce le informazioni sull'accesso salvate in Active Directory e le scrive su Active Directory.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad Active Directory, verrà visualizzato un avviso.

Questo avviso indica che nel server potrebbe esservi un problema di prestazioni. Chiamate in corso occasionali non indicano necessariamente un problema, ma il loro ripetersi verso la stessa area potrebbe.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Microsoft Exchange a Active Directory:

  • Latenza di rete tra il server di Exchange e il controller di dominio.

  • Configurazione statica o comunque non corretta di DSAccess.

  • Sovraccarico del controller di dominio e del catalogo globale.

  • Progettazione non corretta della topologia di Active Directory.

Per risolvere il problema, procedere come segue:

  • Eseguire Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi del server. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Verificare le prestazioni dei server dei controller di dominio di Active Directory.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sulle prestazioni di Exchange e DSAccess, vedere l'articolo 250570 della Knowledge Base "Rilevamento di servizio di directory di server e l'utilizzo DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

Per ulteriori informazioni sulle prestazioni del controller di dominio, vedere le seguenti risorse per Windows Server:

  • "Pianificazione della capacità del controller di dominio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70191 (in inglese).

  • "Monitoraggio Active Directory dei controller di dominio" in Manuale di installazione e pianificazione Active Directory per Windows 2000 Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70193 (in inglese).


Chiamate a ESE in corso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano chiamate a vari componenti in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente VAPI (Virus API) .

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

L'Archivio informazioni di Microsoft Exchange presiede a un database ESE. ESE è un modulo di gestione di database sofisticato basato su transazioni. Una transazione consiste in una serie di operazioni trattate come un unico elemento indivisibile. Tutte le operazioni all'interno di una transazione sono completate o permanentemente salvate, oppure non viene eseguita alcuna operazione.

Microsoft Exchange Server utilizza ESE come modulo di gestione di database incorporato che determina la struttura del database e gestisce la memoria. Il modulo di gestione di database memorizza nella cache i database in memoria trasferendo blocchi di dati (pagine) in ingresso e in uscita. Aggiorna le pagine in memoria e riscrive sul disco quelle nuove o aggiornate. Quando il sistema riceve le richieste, il modulo di gestione di database memorizza nel buffer i dati in memoria. Pertanto, non accede sempre al disco.

La memorizzazione nella cache dei dati in memoria è il metodo più rapido ed efficace per elaborare i dati. Tuttavia, durante l'esecuzione di Exchange, le informazioni su disco non sono mai completamente aggiornate. In memoria è presente l'ultima versione del database. Il database e la memoria non sono comunque sincronizzati, poiché molte modifiche non sono ancora memorizzate sul disco. Il disco del registro delle transazioni viene sempre aggiornato con le informazioni su ogni transazione.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al database ESE, verrà visualizzato un avviso.

Questo avviso indica che nel server potrebbe esservi un problema di prestazioni. Chiamate in corso occasionali non indicano necessariamente un problema, ma il loro ripetersi verso la stessa area potrebbe.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Microsoft Exchange all'ESE:

  • Deframmentazione in linea di Microsoft Exchange.

  • Backup di dati.

    Nota:
    Se il backup dei dati o la deframmentazione in linea erano in corso durante la raccolta dei dati dal registro delle chiamate di Exchange, l'avviso non indica un problema di prestazioni di Exchange Server e può essere ignorato.
  • Colli di bottiglia nelle unità database dovuti, per esempio, a capacità insufficiente rispetto al numero di utenti del server.

  • Colli nelle unità TEMP e TMP.

Per risolvere il problema, procedere come segue:

  • Si consiglia di non sovrapporre finestre di backup o operazioni di manutenzione in linea negli orari di maggior traffico.

  • Accertarsi che le unità disco dei database funzionino correttamente e dispongano di velocità effettiva sufficiente a sopportare il carico di I/O.

  • Avviare Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi al server, quali limitazioni delle dimensioni di messaggi e allegati. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sulla configurazione della finestra oraria per la deframmentazione in linea, vedere l'articolo 244524 della Microsoft Knowledge Base "XADM: Come configurare l'Exchange Server Intervallo di tempo di deframmentazione della linea" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524.

Per ulteriori informazioni sui colli di bottiglia nel disco del server di Exchange, vedere Rilevato collo di bottiglia di disco.

Per ulteriori informazioni sul dimensionamento e l'ottimizzazione dei dischi del server di Exchange, vedere "Calcolo dei requisiti di I/O del disco" e "Procedure consigliate comuni a più architetture" in Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=49324.

Per ulteriori informazioni su ESE, vedere "Architettura ESE" all'indirizzo http://go.microsoft.com/fwlink/?linkid=67009.


Chiamate a IMail in corso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano chiamate in corso tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al client MAPI.

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Il componente IMAIL di Exchange Server è un servizio di conversione flessibile utilizzato dal servizio Archivio informazioni di Microsoft Exchange tra Internet e messaggi MAPI. Ciò consente l'interoperabilità tra i client che utilizzano RFC-822 o il formato Internet e i client che utilizzano il formato di archiviazione interno di Exchange Server, quali i client MAPI o le attività di archiviazione interna.

Exchange utilizza il meccanismo IMAIL per applicare i formati dei messaggi ai contenuti per ogni mittente, secondo quanto definito nei domini Internet del Gestore di sistema di Exchange o specificato dall'utente in Microsoft Office Outlook®. Se IMAIL non riceve informazioni sui parametri di formattazione procederà alla conversione dei messaggi MAPI in formato S/TNEF (Summary TNEF) per il trasferimento tra i vari server.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al client MAPI, verrà visualizzato un avviso.

Questo avviso indica che nel server potrebbe esservi un problema di prestazioni. Chiamate in corso occasionali non indicano necessariamente un problema, ma il loro ripetersi verso la stessa area potrebbe.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le chiamate in corso dal servizio Archivio informazioni di Exchange al componente IMAIL del client MAPI possono verificarsi nelle seguenti condizioni:

  • Tentativo di IMAIL di elaborare molti dati in un messaggio o allegato.

  • Richiesta di conversione dati da molti client.

  • Tempi di risposta lenti alle richieste di DSAccess.

  • Colli di bottiglia nelle unità TEMP e TMP.

  • Spostamenti di cassette postali in corso.

Per risolvere il problema, procedere come segue:

  • Programmare gli spostamenti delle cassette postali in orari di scarso traffico.

  • Avviare Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi al server, quali limitazioni delle dimensioni di messaggi e allegati. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sui colli di bottiglia nel disco in Exchange Server, vedere Rilevato collo di bottiglia di disco.

Per ulteriori informazioni sul dimensionamento e l'ottimizzazione dei dischi del server di Exchange, vedere "Calcolo dei requisiti di I/O del disco" e "Procedure consigliate comuni a più architetture" in Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=49324.

Per ulteriori informazioni sulle limitazioni delle dimensioni dei messaggi consigliate su Exchange Server, vedere La dimensione massima del messaggio in uscita non è stata impostata.

Per ulteriori informazioni sulle prestazioni di DSAccess ed Exchange Server, vedere "Configurazione della cache utente DSAccess" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


Chiamate a LSASS in corso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano chiamate tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al processo LSASS (Lsass.exe) .

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Il processo LSASS (Lsass.exe) è un sottosistema di protezione richiamato da altri processi per la verifica delle informazioni sull'account e la convalida dell'accesso.

All'accesso del client, Exchange Server invia una richiesta di ricerca del rispettivo ID di protezione (SID) account e genera una chiamata all'interno del processo LSASS (Lsass.exe).

Se Exchange Server Analyzer rileva all'interno del file di registro Store.fcl eventi che evidenziano chiamate in corso dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al processo LSASS (Lsass.exe), verrà visualizzato un avviso.

Questo avviso indica che nel server potrebbe esservi un problema di prestazioni. Chiamate in corso occasionali non indicano necessariamente un problema, ma il loro ripetersi verso la stessa area potrebbe.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate successive del servizio Archivio informazioni di Exchange al processo LSASS:

  • Problemi alle risorse del server correlati al numero di utenti che si autenticano nello stesso momento.

  • Latenza di rete tra il server di Exchange e il controller di dominio o il server di catalogo globale.

  • Problemi dovuti a colli di bottiglia nelle risorse del server.

Per risolvere il problema, procedere come segue:

  • Implementare il parametro NeverPing come descritto in Parametro "NeverPing" consigliato.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sul processo Lsass.exe e l'utilizzo della memoria, vedere l'articolo 308356 della Microsoft Knowledge "Utilizzo della memoria da parte del processo Lsass.exe in controller di dominio basati su Windows 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356.

Per ulteriori informazioni sui problemi di accesso dei client di Exchange e LSAA, vedere l'articolo 161938 della Microsoft Knowledge Base "Rallentare Accesso Due client di Exchange al blocco critico di risorsa" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938.

Per ulteriori informazioni sulla latenza di rete tra server di Exchange e controller di dominio o server di catalogo globale, vedere il seguente blog del team di Microsoft Exchange "Exchange Does Not Always Use Local GCs" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69166 (in inglese).

Nota:
Il contenuto di ciascun blog e il relativo URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni sui colli di bottiglia nelle risorse del processore, vedere Collo di bottiglia del processore.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


Chiamate all'antivirus in corso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi che indicano chiamate in corso tra componenti dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente VAPI (Virus API) Virusscan.

Le chiamate in corso sono richieste inviate dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) ad altri componenti che non hanno ricevuto risposta al momento della scrittura dei dati del registro FCL di Exchange nel file Store.fcl.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file di registro Store.fcl eventi che evidenziano chiamate successive dal servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente VAPI, verrà visualizzato un avviso.

Questo avviso indica che nel server potrebbe esservi un problema di prestazioni. Chiamate in corso occasionali non indicano necessariamente un problema, ma il loro ripetersi verso la stessa area potrebbe.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate in corso del servizio Archivio informazioni di Exchange al componente VAPI:

  • Aggiornamenti a un programma antivirus che avvia nuove analisi degli elementi dell'Archivio informazioni.

  • Configurazione non corretta del programma antivirus.

  • Il software antivirus elabora messaggi o allegati di grandi dimensioni.

Per risolvere il problema, procedere come segue:

  • Programmare gli aggiornamenti del motore di ricerca virus in orari in cui l'utilizzo delle risorse è basso, ossia negli orari di scarso traffico.

  • Reinstallare il software antivirus, ma negli orari di scarso traffico.

  • Verificare la corretta configurazione di thread, esclusioni file, ecc. del motore di ricerca virus. Vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, vedere l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


GlobalFlag del sistema operativo impostato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore della voce GlobalFlag:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager

Se Exchange Server Analyzer trova il valore di GlobalFlag presente e configurato con qualsiasi valore diverso da 0 o null, verrà visualizzato un avviso.

  • L'impostazione del valore del Registro di sistema GlobalFlag è una maschera di bit che determina quali opzioni di debug sono state attivate per il sistema operativo. A meno che l'utente non sia effettivamente occupato con il debug o con la risoluzione di un problema tramite il Servizio Supporto Tecnico Clienti Microsoft, si consiglia di impostare il valore GlobalFlag sempre su 0.

Il valore del registro di sistema GlobalFlag è impostato su 0 per impostazione predefinita. Se questo valore viene modificato, è possibile utilizzare lo strumento Gflags incluso negli Strumenti di supporto di Microsoft Windows Server™ 2003, disponibili nella cartella \Support del CD di Windows Server 2003. In alternativa, è possibile impostare manualmente il valore su 0 utilizzando un editor del Registro di sistema. Entrambe le procedure sono descritte di seguito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema utilizzando GFlags

  1. Fare clic su Start, Esegui e, nel campo Apri, digitare GFlags. Verrà visualizzata l'interfaccia utente di Global Flags.

  2. Deselezionare tutte le caselle di controllo, quindi fare clic su Applica.

  3. Per rendere effettiva la modifica, fare clic su OK per uscire dallo strumento GFlags e riavviare il computer.

Per risolvere il problema utilizzando un editor del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\ System\CurrentControlSet\Control\Session Manager

  3. Fare doppio clic sul valore denominato GlobalFlag e impostare i dati valore su 0.

  4. Uscire dall'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.


Il sistema operativo è in modalità debug
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare se è impostato un valore per la proprietà Debug. Se il valore per questa chiave su un computer Exchange Server è impostato su True, verrà visualizzato un messaggio di errore.

È possibile attivare la modalità di debug di Windows aggiungendo il parametro /debug nel file Boot.ini. Quando nel file Boot.ini di un computer Windows Server viene specificato /debug, il debugger del kernel viene caricato durante il processo di avvio e conservato in memoria. Questo consente al personale del supporto tecnico di connettersi al sistema di cui viene eseguito il debug e di accedere al debugger anche quando il sistema non viene sospeso alla schermata di arresto del kernel. A differenza dell'opzione /crashdebug, l'opzione /debug utilizza la porta COM indipendentemente dal fatto che il debug sia in esecuzione o meno. Questa opzione viene utilizzata quando si verificano ripetutamente gli stessi problemi di debug. È probabile che il parametro /debug sia stato impostato per consentire di risolvere un problema e che in seguito non sia stato disattivato.

A causa dell'esecuzione di processi aggiuntivi, si può verificare una diminuzione significativa delle prestazioni. Di conseguenza, non è consigliata l'esecuzione di Exchange Server su un computer in cui Windows viene eseguito in modalità di debug.

Per correggere questo errore, modificare il file Boot.ini e rimuovere il parametro /debug.

Per risolvere il problema

  1. In Esplora risorse aprire Partizione di sistema. È la partizione che contiene i file specifici dell'hardware come Boot.ini e NTLDR.

  2. Se non è possibile visualizzare il file Boot.ini, nelle Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse fare clic su Strumenti, scegliere Opzioni cartella e quindi fare clic su Visualizza. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene richiesto, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con, quindi Blocco note per aprire il file.

  4. Nella sezione [Sistemi operativi] rimuovere il parametro /debug.

  5. Per rendere effettiva la modifica, salvare e chiudere il computer, quindi riavviare il computer che esegue Exchange Server.

Per maggiori informazioni sui parametri che possono essere utilizzati nel file Boot.ini, consultare l'articolo 833721 della Microsoft Knowledge Base "Opzioni dei parametri disponibili per i file Boot.ini di Windows XP e di Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833721.


È necessario un aggiornamento rapido di Outlook Web Access per Windows Server 2003 SP1
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-08-28

Microsoft® Exchange Server Analyzer Tool esegue una query in diverse classi Microsoft WMI (Strumentazione gestione Windows®) per raccogliere le seguenti informazioni:

  • La versione del sistema operativo Microsoft Windows® Server in cui è installato Exchange Server.

  • Se Exchange Server viene eseguito in un cluster.

Se Exchange Server Analyzer determina che le condizioni indicate di seguito sono vere, verrà visualizzato un avviso:

  • Exchange Server 2003 Service Pack 1 (SP1) è installato.

  • Microsoft Windows Server™ 2003 SP1 non è installato.

  • Il servizio cluster è in esecuzione.

  • Il valore Version di Davex.dll è minore di 6.5.7232.

Se si esegue questa configurazione, è necessario scaricare e installare un aggiornamento rapido di Exchange Server prima di installare Windows Server 2003 SP1. Se non si installa l'aggiornamento rapido di Exchange Server, gli utenti di Microsoft Office Outlook® Web Access per Exchange Server 2003 non potranno accedere alle proprie cassette postali. Per gli utenti che dispongono di cassette postali ospitate nei cluster verrà visualizzato il seguente messaggio di errore quando provano a connettersi utilizzando Outlook Web Access:

  • "500 - Errore interno del server"

Questo errore è provocato da alcuni miglioramenti della protezione inclusi in Windows Server 2003 SP1.

Quando un utente prova ad accedere a una cassetta postale usando Outlook Web Access, il protocollo HTTP inoltra richieste all'API del cluster tramite l'account dell'utente connesso. Tuttavia, sono state apportate modifiche alla protezione in Windows Server 2003 SP1. Le restrizioni di protezione per le API che eseguono l'accesso remoto al Registro di sistema sono state modificate, pertanto il tentativo di accesso non verrà eseguito correttamente.

Per correggere questo errore, è necessario scaricare e installare l'aggiornamento rapido di Exchange Server descritto nell'articolo 841561 della Microsoft Knowledge Base "Messaggio di errore "500 - Errore interno del server" quando un utente cerca di accedere a un server back-end Exchange Server 2003 cluster mediante Outlook Web Access" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561.


File di modello di Outlook Web Access non corrispondente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il numero di versione del file Wmtemplates.dll. Exchange Server Analyzer confronta quindi il numero di versione di Wmtemplates.dll su tutti i server del gruppo di amministrazione. Se rileva che i numeri di versione di Wmtemplates.dll dei server front-end e back-end di Exchange non corrispondono, verrà visualizzato un messaggio di configurazione ottimale.

Il file Wmtemplates.dll viene utilizzato dai controlli di Microsoft Office Outlook® Web Access. Versioni non corrispondenti di Wmtemplates.dll sui server front-end e back-end di Exchange possono causare errori di livello 400 quando gli utenti tentano di accedere a Outlook Web Access attraverso il server front-end di Exchange.

Sono presenti due aggiornamenti recenti rilasciati da Microsoft per Wmtemplates.dll:

  • "Il servizio Archivio informazioni di Microsoft Exchange si arresta in modo anomalo periodicamente dopo l'installazione di Exchange Server 2003 SP1" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=872963.

  • "Il controllo S/MIME non si carica in OWA se si esegue il client OWA di Exchange Server 2003 in un computer Windows XP Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=883543.

Se è stato installato recentemente uno di questi aggiornamenti, potrebbero verificarsi le seguenti condizioni:

  • Gli aggiornamenti non sono stati installati nell'ordine corretto.

  • L'aggiornamento non è stato installato sia sul server front-end sia sul server back-end.

Quando si installano gli aggiornamenti di Outlook Web Access, è necessario installarli sul server front-end, riavviare il server, quindi installarli sul server back-end.

Se non è stato installato uno di questi aggiornamenti, assicurarsi che tutti i server vengano eseguiti i service pack e degli aggiornamenti di Exchange Server più recenti.

Per informazioni sui service pack e sugli aggiornamenti più recenti di Exchange Server, visitare i seguenti siti Web:

  • Downloads for Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21236 (informazioni in lingua inglese).

  • Downloads for Exchange 2000 Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Le richieste RPC in attesa hanno raggiunto la soglia massima
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni RPC Requests dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che il numero di richieste RPC ha raggiunto il valore massimo 100 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Il contatore di prestazioni RPC Requests indica il numero di richieste MAPI RPC o client in esecuzione nel servizio Archivio informazioni di Microsoft Exchange. Il valore medio dell'oggetto prestazioni RPC Requests dovrebbe essere inferiore a 30 in ogni momento. Per impostazione predefinita, il valore massimo per le richieste RPC è 100. Di conseguenza, se non configurato diversamente, il servizio Archivio informazioni di Microsoft Exchange può elaborare contemporaneamente solo 100 richieste RPC. Tutte le nuove operazioni RPC saranno rifiutate, non sarà possibile eseguire la connessione al server fino a quando le richieste RPC non scenderanno al di sotto di 100, il server potrebbe cessare di rispondere e il flusso di posta potrebbe arrestarsi. È possibile che in Outlook venga visualizzata la finestra di dialogo Richiesta di annullamento RPC

Questo messaggio di errore indica che si sta verificando un collo di bottiglia sul server oppure che un processo ha cessato di rispondere.

Un collo di bottiglia delle prestazioni può verificarsi nella CPU, nel disco, nella rete o nella memoria e può essere causato da un aumento del carico sul server oppure da risorse del server insufficienti. Utilizzare lo strumento Performance Monitor (Perfmon.msc) per determinare se il collo di bottiglia è causato da un maggiore carico sul server o da dimensioni limitate del server. Se il carico sul server è aumentato, identificare e ridurre l'origine del carico. Se le risorse del server sono insufficienti, aumentarle o spostare gli utenti su un altro server.

Un processo cessa di rispondere perché l'archivio è in attesa di una risposta da parte di una risorsa, ad esempio quando un cluster perde l'unità che ospita la verifica dei messaggi o quando si manifesta un problema nel programma antivirus. Quando un processo cessa di rispondere, le richieste RPC restano attive ed è necessario riavviare l'archivio.

Ulteriori informazioni

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Collo di bottiglia del processore

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sull'ottimizzazione delle prestazioni di Exchange Server, consultare Exchange Server 2003 Performance: 10 Things to Think About all'indirizzo http://go.microsoft.com/fwlink/?LinkID=56460 (informazioni in lingua inglese).

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, consultare l'argomento Spostare le cassette postali degli utenti su un server diverso.


File PHATCAT.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di alcuni dei file precedenti, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


File PHATQ.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di uno o più file, verrà visualizzato un messaggio di errore. Per risolvere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Problema di prestazioni del file di paging
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dai contatori di prestazioni Avg Disk sec/Read e Avg Disk sec/Write per l'istanza PAGEDISK dell'oggetto prestazioni LogicalDisk per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che i contatori Avg Disk sec/Read e Avg Disk sec/Write hanno superato il valore di 10 millisecondi durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

L'oggetto prestazioni LogicalDisk è composto da contatori quali Avg Disk sec/Read e Avg Disk sec/Write che monitorano le partizioni logiche dei dischi rigidi. Il contatore di prestazioni Avg Disk sec/Read indica il tempo medio, in secondi, di lettura dei dati dal disco. Il contatore di prestazioni Avg Disk sec/Write indica il tempo medio, in secondi, di scrittura dei dati sul disco. Il valore medio dei contatori di prestazioni Avg Disk sec/Read e Avg Disk sec/Write deve essere inferiore a 10 millisecondi.

L'istanza PAGEDISK dell'oggetto prestazioni LogicalDisk su un server rappresenta il file di paging (Pagefile.sys). Pagefile.sys è un file di sistema nascosto sul disco rigido utilizzato da Microsoft Windows® per conservare i dati temporanei quando la quantità di RAM del sistema è insufficiente. Il file di paging è definito anche file di scambio.

Questo errore segnala la presenza di un problema di latenza sul disco che contiene il file di paging.

Per risolvere il problema, procedere come segue:

  • Identificare la causa della latenza. Se il problema è provocato da un'attività di paging eccessiva, è possibile che la causa derivi da problemi relativi alla memoria del server.

  • Provare a posizionare il file di paging in una partizione dedicata o in un disco ad alta velocità dedicato.

  • Provare a creare un file di paging secondario in un'unità alternativa come descritto nell'articolo 197379 della Microsoft Knowledge Base "Configurazione dei file di paging a scopo di ottimizzazione e ripristino" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379.

  • Eseguire le attività di manutenzione del server nelle ore non di punta. Se nelle ore di punta si eseguono strumenti di manutenzione, quali utilità del database di Exchange Server (Eseutil.exe), o si eseguono attività quali la gestione delle cassette postali, viene infatti utilizzata memoria che altrimenti verrebbe utilizzata da Exchange. Pertanto è consigliabile eseguire tali strumenti e attività nelle ore non di punta o durante periodi di ridotto utilizzo.

Ulteriori informazioni

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sull'ottimizzazione delle prestazioni del file di paging, consultare l'articolo 197379 della Microsoft Knowledge Base "Configurazione dei file di paging a scopo di ottimizzazione e ripristino" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle procedure consigliate per la progettazione delle architetture di archiviazione, vedere Procedure consigliate comuni a più architetture all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72988.

  • Per ulteriori informazioni sulle dimensioni dei dischi, la latenza e le frequenze di I/O, consultare i seguenti blog sul sito Web del blog del team Microsoft Exchange:

    • A few basic concepts in disk sizing all'indirizzo http://go.microsoft.com/fwlink/?linkid=39538 (informazioni in lingua inglese)

    • Some more thoughts on disk IO and calculations…all'indirizzo http://go.microsoft.com/fwlink/?linkid=39539 (informazioni in lingua inglese)

    • "Come calcolare i requisiti di I/O del disco" all'indirizzo http://go.microsoft.com/fwlink/?linkid=69747.


Contatore Utilizzo del file di paging superiore al 50%
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore % Usage dell'oggetto prestazioni Paging File per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che il contatore % Usage ha superato il 50% durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Il file di paging (Pagefile.sys) è un file nascosto sul disco rigido utilizzato da Windows per conservare i dati temporanei quando la quantità di RAM del sistema è insufficiente. Il file di paging è definito anche file di scambio. L'utilizzo del file di paging incide sulle prestazioni globali poiché le operazioni su disco durano di più di quelle di memoria. Inoltre, quando il paging del disco aumenta in entrambe le direzioni, può verificarsi un collo di bottoglia che influisce sulle prestazioni. In questo caso, la vera causa del problema è la memoria e il collo di bottiglia del disco ne è solo un sintomo.

La contesa della memoria non è più accettabile quando, per gestire il problema della memoria limitata, il sistema impiega molto tempo rispetto a quello necessario per il lavoro effettivo. Se si visualizzano in un grafico la contesa di memoria e i tempi medi di risposta, si noterà una linea pressoché continua tra il valore zero della contesa e il punto in cui aumentano significativamente i tempi di risposta. Tale punto è denominato punto di thrashing. Quando la contesa della memoria supera il punto di thrashing, i tempi di risposta aumentano in modo esponenziale. In alcuni ambienti il punto di thrashing è accattabile, ma si consiglia di evitarlo comunque.

Questo errore segnala la presenza di un problema di prestazioni sul disco che contiene il file di paging. Questo problema, infine, può essere correlato a un problema di memoria sul server.

Per risolvere il problema, procedere come segue:

  • Provare a creare un file di paging secondario in un'unità alternativa come descritto nell'articolo 197379 della Microsoft Knowledge Base "Configurazione dei file di paging a scopo di ottimizzazione e ripristino" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379.

  • Provare a posizionare il file di paging in una partizione dedicata o in un disco ad alta velocità dedicato.

  • Rimuovere il software superfluo. Per rendere disponibili più risorse per Exchange, rimuovere eventuali strumenti software di terze parti che eseguono funzioni di monitoraggio o qualsiasi tipo di servizio non essenziale. Lo snap-in Performance, disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56118, può aiutare a comprendere la percentuale di memoria utilizzata dalle applicazioni.

  • Eseguire le attività di manutenzione del server nelle ore non di punta. Se nelle ore di punta si eseguono strumenti di manutenzione, quali utilità del database di Exchange Server (Eseutil.exe), o si eseguono attività quali la gestione delle cassette postali, viene infatti utilizzata memoria che altrimenti verrebbe utilizzata da Exchange. Pertanto è consigliabile eseguire tali strumenti e attività nelle ore non di punta o durante periodi di ridotto utilizzo.

  • Considerare l'opportunità di spostare le cassette postali degli utenti dal server interessato a un altro server per ridurre il carico del sistema. Per ulteriori informazioni, consultare Spostare le cassette postali degli utenti su un server diverso.

Ulteriori informazioni

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sull'ottimizzazione delle prestazioni del file di paging, consultare l'articolo 197379 della Microsoft Knowledge Base "Configurazione dei file di paging a scopo di ottimizzazione e ripristino" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379.

  • Per ulteriori informazioni sul miglioramento delle prestazioni della memoria, consultare Aumentare la memoria utente.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle procedure consigliate per la progettazione delle architetture di archiviazione, vedere Procedure consigliate comuni a più architetture all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72988.

  • Per ulteriori informazioni sulle dimensioni dei dischi, la latenza e le frequenze di I/O, consultare i seguenti blog sul sito Web del blog del team Microsoft Exchange:

    • A few basic concepts in disk sizing all'indirizzo http://go.microsoft.com/fwlink/?linkid=39538 (informazioni in lingua inglese).

    • Some more thoughts on disk IO and calculations…all'indirizzo http://go.microsoft.com/fwlink/?linkid=39539 (informazioni in lingua inglese).

    • Come calcolare i requisiti di I/O del disco all'indirizzo http://go.microsoft.com/fwlink/?linkid=69747.


PageHeapFlags impostato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito per determinare il valore della voce PageHeapFlags:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\MAD.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\INETINFO.EXE

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\EMSMTA.EXE

Se Exchange Server Analyzer trova il valore di PageHeapFlags presente e configurato con un valore diverso da 0 o null, verrà visualizzato un avviso.

L'opzionePageHeapFlags viene utilizzata congiuntamente al valore GlobalFlag del Registro di sistema illustrato in GlobalFlag impostato. L'opzione PageHeapFlags consente di selezionare una verifica heap standard, che scrive schemi di riempimento al termine di ogni allocazione heap ed esamina gli schemi quando le allocazioni vengono liberate oppure una verifica heap di pagine intere. In questo modo viene collocata una pagina inaccessibile al termine di ciascuna allocazione, in modo che il programma si arresta immediatamente se accede alla memoria oltre l'allocazione. Poiché la verifica heap di pagine intere utilizza una pagina intera di memoria per ciascuna allocazione, è possibile che se viene utilizzata troppo frequentemente si verifichino carenze della memoria di sistema.

In questo caso, Exchange Server Analyzer esegue una ricerca per verificare se è stato abilitato un valore PageHeapFlags per una serie di componenti Exchange:

  • STORE.EXE - il processo dell'archivio informazioni

  • MAD.EXE - il processo di supervisore sistema

  • INETINFO.EXE - il processo di Amministrazione IIS e il processo padre

  • EMSMTA.EXE - il processo dell'agente di trasferimento messaggi

A meno che non si esegua il debug o l'analisi di un problema con l'aiuto del Servizio Supporto Tecnico Clienti Microsoft, è consigliabile impostare sempre il valore PageHeapFlags su 0 oppure eliminarlo completamente, dal momento che le due operazioni producono lo stesso effetto.

Il valore PageHeapFlags del Registro di sistema non è presente per impostazione predefinita e deve essere aggiunto manualmente se è necessario il debug del processo STORE.EXE (o qualsiasi altro processo). È possibile utilizzare lo strumento Gflags fornito con gli Strumenti di supporto di Microsoft® Windows Server™ 2003 che si trovano nella cartella \Support del CD di Windows®. In alternativa, è possibile impostare manualmente il valore su 0 oppure eliminare completamente il valore PageHeapFlags utilizzando un editor del Registro di sistema. Entrambe le procedure sono descritte in questo articolo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema utilizzando GFlags

  1. Fare clic su Start | Esegui e nel campo Apri eseguire GFlags. Verrà visualizzata l'interfaccia utente di Global Flags.

  2. Nel campo Nome del file immagine immettere STORE.EXE.

  3. Fare clic su Image File Options.

  4. Deselezionare tutte le caselle di controllo, quindi fare clic su Applica.

  5. Ripetere i passaggi da 2 a 4 per ciascuno dei processi Exchange elencati sopra.

  6. Per rendere effettiva la modifica, fare clic su OK per uscire dallo strumento GFlags e riavviare i servizi interessati.

  7. Quando si utilizza lo strumento GFlags per eliminare questo valore, non viene eliminato o modificato il valore di PageHeapFlags. Il valore GlobalFlag invece, viene impostato su 0, pertanto viene ignorato e disattivato il funzionamento configurato con la voce PageHeapFlags.

Per risolvere il problema utilizzando un editor del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\STORE.EXE

  3. Eliminare il valore denominato PageHeapFlags.

  4. Ripetere i passaggi 2 e 3 per ciascuno dei processi Exchange elencati sopra.

  5. Per rendere effettive le modifiche, uscire dall'editor del Registro di sistema e riavviare i servizi interessati.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


La riserva di paging ha superato la soglia di errore
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_PerfOS_Memory per determinare il valore corrente della chiave PoolNonpagedBytes. Le operazioni eseguite da Exchange Server Analyzer dipendono dal sistema operativo sottostante, dalla presenza o assenza dell'opzione /3GB nel file Boot.ini di Windows e dal valore rilevato per la chiave in questione.

La seguente matrice di valutazioni viene utilizzata da Exchange Server Analyzer per determinare se questo valore è oltre i limiti per un server di Exchange specificato. Se le condizioni della matrice sono soddisfatte, verrà visualizzato un messaggio di errore.

Sistema operativo | Impostazione Boot.ini | La riserva non di paging corrente è
Windows 2000 Server o Advanced Server | /3GB | Almeno 110 MB
Windows 2000 Server o Advanced Server | Nessuno | Almeno 220 MB
Windows Server™ 2003 | /3GB | Almeno 110 MB
Windows Server 2003 | Nessuno | Almeno 220 MB

Il valore della chiave PoolNonpagedBytes rappresenta la dimensione, in byte, della riserva non di paging della memoria del kernel. La riserva non di paging è un'area di memoria di sistema fisica per gli oggetti che non possono essere scritti su disco ma che devono rimanere nella memoria fisica fino a quando non vengono allocati. Questo è l'ultimo valore osservato per questa chiave. In un computer Exchange Server che funziona correttamente, questo valore dovrebbe rimanere invariato. Se il valore per questo contatore aumenta costantemente, potrebbe indicare una perdita di memoria.

Poiché non è possibile aumentare il limite relativo alla memoria di riserva non di paging oltre i valori elencati sopra, è necessario correggere questa condizione al più presto. Indipendentemente dal sistema operativo in uso o dalla presenza o assenza dell'opzione /3GB, è possibile accedere mediante il sistema operativo Windows® solo a tale quantità di memoria di riserva non di paging. Se Windows esaurisce la memoria del kernel, possono essere visualizzati messaggi di errore e il sistema si può arrestare in modo anomalo. La memoria del kernel è necessaria per il corretto funzionamento del sistema e, pertanto, è preferibile monitorarla attentamente.

Se questa condizione si verifica anche dopo il riavvio di Exchange Server, l'operazione successiva da compiere consiste nell'assicurarsi che il sistema sia regolato in modo corretto e che tutti i prodotti software e hardware presenti in esso sia aggiornati. La procedura include l'installazione delle ultime versioni di:

  • Service Pack del sistema operativo Windows

  • Service Pack di Exchange Server

  • Hardware, firmware e driver

  • Aggiornamenti del BIOS del sistema

  • Aggiornamenti di eventuali applicazioni di terze parti installate e in esecuzione

Se gli aggiornamenti di software e hardware non risolvono il problema, è preferibile disabilitare tutti i programmi software di terze parti, riavviare il computer Exchange Server e monitorare la memoria del kernel.

Per risolvere il problema

  1. Riattivare il computer Exchange Server non appena possibile.

  2. Monitorare il contatore di prestazioni Memoria | Byte della riserva non di paging per assicurarsi che non oltrepassi il limite elencato sopra per il sistema.

Per ulteriori informazioni sulla regolazione corretta della memoria di Exchange Server, consultare i seguenti articoli e argomenti della Microsoft Knowledge Base:

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 266096, "XGEN: In Exchange 2000 è necessario il parametro /3GB con oltre 1 GB di RAM fisica" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096.

  • "Troubleshooting Exchange Server 2003 Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • "Troubleshooting Exchange 2000 Server Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=18177 (informazioni in lingua inglese).

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.


La riserva di paging ha superato la soglia di avviso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PerfRawData_PerfOS_Memory per determinare il valore corrente della chiave PoolPagedBytes. Le operazioni eseguite da Exchange Server Analyzer dipendono dal sistema operativo sottostante, dalla presenza o assenza dell'opzione /3GB nel file Windows Boot.ini e dal valore rilevato per questa chiave.

Nella seguente tabella viene visualizzata la matrice di valutazioni utilizzata da Exchange Server Analyzer per determinare se questo valore è oltre i limiti per un server Exchange specificato. Se le condizioni della tabella sono soddisfatte, verrà visualizzato un avviso.

Sistema operativo | Impostazione Boot.ini | La riserva di paging corrente è
Windows 2000 Server o Advanced Server | /3GB | Almeno 180 MB
Windows 2000 Server o Advanced Server | Nessuno | Almeno 180 MB
Windows Server™ 2003 | /3GB | Almeno 200 MB
Windows Server 2003 | Nessuno | Almeno 300 MB

Il valore della chiave PoolPagedBytes rappresenta la dimensione, in byte, della riserva di paging della memoria del kernel. La riserva di paging è un'area di memoria fisica di sistema per gli oggetti che possono essere scritti su disco anche quando non vengono utilizzati. Questo è l'ultimo valore osservato per questa chiave. In un server Exchange che funziona correttamente dovrebbero essere disponibili, a meno che non sia in corso un'operazione di backup o ripristino, non più di 180 MB di memoria di riserva di paging in uso.

In Windows 2000 Server e Windows 2000 Advanced Server, il valore massimo della memoria di riserva di paging è 470 MB. Quando l'opzione /3GB viene aggiunta a un computer Windows 2000 Advanced Server, il valore massimo per la memoria di riserva di paging è di 192 MB. Su un computer Microsoft® Windows Server™ 2003 senza opzione /3GB, il valore massimo per la memoria di riserva di paging è di 491 MB. Su un computer Microsoft® Windows Server™ 2003 con l'opzione /3GB, il valore massimo per la memoria di riserva di paging è di 256 MB.

Poiché non è possibile aumentare il limite relativo alla memoria di riserva di paging oltre i valori elencati sopra, è preferibile correggere questa condizione al più presto. Indipendentemente dal sistema operativo in uso o dalla presenza o assenza dell'opzione /3GB, è possibile accedere mediante Windows solo a tale quantità di memoria di riserva di paging. Se Windows esaurisce la memoria del kernel, possono essere visualizzati messaggi di errore e il sistema si può arrestare in modo anomalo. La memoria del kernel è fondamentale per il corretto funzionamento del sistema e, pertanto, è preferibile monitorarla attentamente.

Se questa condizione si verifica anche dopo il riavvio del server Exchange, l'operazione successiva da compiere consiste nell'assicurarsi che il sistema sia regolato in modo corretto e che tutti i prodotti software e hardware presenti in esso sia aggiornati. La procedura include l'installazione delle ultime versioni di:

  • Service Pack sistema operativo Windows

  • Service Pack di Exchange Server

  • Hardware, firmware e driver

  • Aggiornamenti del BIOS del sistema

  • Aggiornamenti di eventuali applicazioni di terze parti installate e in esecuzione

Se gli aggiornamenti di software e hardware non risolvono il problema, è preferibile disabilitare tutti i programmi software di terze parti, riavviare il computer Exchange Server e monitorare la memoria del kernel.

Per risolvere il problema

  1. Riattivare il computer Exchange Server non appena possibile.

  2. Monitorare il contatore di prestazioni Memoria | Byte riserva di paging per assicurarsi che non oltrepassi la soglia elencata sopra per il sistema.

Per ulteriori informazioni sulla corretta regolazione di Exchange Server, vedere i seguenti argomenti e articoli della Microsoft Knowledge Base:

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 266096, "XGEN: In Exchange 2000 è necessario il parametro /3GB con oltre 1 GB di RAM fisica" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266096.

  • "Troubleshooting Exchange Server 2003 Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • "Troubleshooting Exchange 2000 Server Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=18177 (informazioni in lingua inglese).

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni, consultare i seguenti articoli blog di Exchange:

  • "Microsoft Windows Kernel Memory Management and Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63477 (informazioni in lingua inglese)

  • "Configuring Hot-Add and Large Memory for Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63478 (informazioni in lingua inglese)

  • "Large Security Tokens and Kernel Memory Exhaustion" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63479 (informazioni in lingua inglese)

    Nota:
    I collegamenti a questi blog sono forniti a scopo puramente informativo. Il contenuto può essere modificato senza preavviso.


Il percorso dell'estensione server proxy RPC non è corretto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente proprietà nella metabase IIS (Internet Information Services) per determinare se il relativo valore è stato configurato correttamente:

LM/W3SVC/Filters/RpcProxy

Questa proprietà nella metabase è la proprietà dell'estensione server proxy RPC (Remote Procedure Call) nelle estensioni del servizio Web in IIS. Il valore corretto per questa proprietà è il seguente:

<Directory di Windows>\system32\rpcproxy\rpcproxy.dll

Se Exchange Server Analyzer rileva che la proprietà non presenta il valore corretto, verrà visualizzato un avviso.

La proprietà dell'estensione server proxy RPC viene impostata quando si installa il sottocomponente proxy RPC su HTTP del componente Servizi di rete di Microsoft Windows®. Se la proprietà è impostata in modo errato o se è stato modificato manualmente il relativo valore, procedere come segue:

  1. Rimuovere la proprietà errata dell'estensione del server proxy RPC.

  2. Rimuovere il sottocomponente proxy RPC su HTTP.

  3. Reinstallare il sottocomponente proxy RPC su HTTP.

Per rimuovere la proprietà errata dell'estensione server proxy RPC.

  1. Aprire Gestione Internet Information Services (IIS).

  2. Nel riquadro sinistro della finestra Gestione Internet Information Services (IIS) espandere il nome del server e fare clic su Web Extensions.

  3. Nel riquadro destro della finestra Gestione Internet Information Services (IIS) fare clic con il pulsante destro del mouse su Estensione server proxy RPC quindi scegliere Proprietà.

  4. Nella scheda File richiesti selezionare il file errato dall'elenco, fare clic su Rimuovi e quindi su OK.

    Nota:
    Per visualizzare il percorso completo, regolare la larghezza della colonna Nome file nell'elenco dei file.
Per rimuovere il sottocomponente proxy RPC su HTTP

  1. Fare clic su Start, scegliere Pannello di controllo, quindi fare clic su Installazione applicazioni.

  2. Nel riquadro sinistro fare clic su Installazione componenti di Windows.

  3. Selezionare Servizi di rete quindi fare clic su Dettagli.

  4. Deselezionare la casella di controllo di Proxy RPC su HTTP, fare clic su OK e quindi su Avanti.

  5. Al termine del processo di Aggiunta guidata componenti di Windows fare clic su Fine per chiudere la procedura guidata.
Per reinstallare il sottocomponente proxy RPC su HTTP

  1. Fare clic su Start, scegliere Pannello di controllo, quindi fare clic su Installazione applicazioni.

  2. Nel riquadro sinistro fare clic su Installazione componenti di Windows.

  3. Selezionare Servizi di rete quindi fare clic su Dettagli.

  4. Selezionare la casella di controllo Proxy RPC su HTTP, fare clic su OK e quindi su Avanti.

  5. Al termine del processo di Aggiunta guidata componenti di Windows fare clic su Fine per chiudere la procedura guidata.

Per ulteriori informazioni sui problemi dell'estensione server proxy RPC che non viene caricata correttamente, consultare la sezione Risoluzione dei problemi dell'articolo 833401 della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833401.

Per ulteriori informazioni sulla distribuzione di RPC su HTTP in Exchange Server 2003, consultare il manuale Scenari di distribuzione di RPC su HTTP in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=24823.


L'emulatore PDC non è stato escluso dalla topologia DSAccess
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se il controller di dominio di Active Directory® che funge da emulatore PDC (Primary Domain Controller, controller di dominio primario) è stato escluso manualmente dall'elenco dei controller di dominio disponibili per Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default\MinUserDC

Se Exchange Server Analyzer rileva che il controller di dominio che funge da emulatore PDC non è stato escluso manualmente dall'elenco dei controller di dominio disponibili per Exchange Server, verrà visualizzato un messaggio di configurazione ottimale.

L'emulatore PDC è un computer con il ruolo di master operazioni in Active Directory che elabora richieste di replica dai controller di dominio di backup Microsoft® Windows NT® 4.0 ed elabora tutti gli aggiornamenti delle password per i client che non eseguono software client abilitati ad Active Directory. Gli emulatori PDC sono anche controller di dominio, pertanto possono essere utilizzati da applicazioni come Exchange Server.

DSAccess (Directory Service Access) è un componente interno di Exchange 2000 Server ed Exchange Server 2003 che consente di controllare il modo in cui tutti i componenti di Exchange Server accedono ad Active Directory. La funzione principale di DSAccess è quella di conservare le informazioni su diversi eventi e operazioni relativi alle directory. Ad esempio, DSAccess trova la topologia di Active Directory e rileva se i controller di dominio e i server di catalogo globali sono disponibili e rispondono alle query.

Per impostazione predefinita, DSAccess include il computer emulatore PDC nel suo elenco di controller di dominio disponibili e utilizzabili. Se programmi diversi da Exchange Server utilizzano frequentemente l'emulatore PDC, l'utilizzo dell'emulatore da parte di DSAccess potrebbe provocare problemi di prestazioni nel computer emulatore PDC oltre che nel server di Exchange e nel computer non Exchange Server.

Per evitare problemi di prestazioni, il valore MinUserDC può essere aggiunto al Registro di sistema su un server di Exchange in modo da imporre a DSAccess l'esecuzione di una query in tutti gli altri controller di dominio disponibili prima di eseguire una query nel controller di dominio che ha il ruolo di master operazioni dell'emulatore PDC.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per verificare e modificare il valore MinUserDC del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess\Profiles\Default

  3. Individuare il valore MinUserDC e apportare le modifiche desiderate. Se questo valore DWORD non esiste, è possibile crearlo manualmente.

    Nota:
    I dati valore configurati per la voce MinUserDC del Registro di sistema rappresentano il numero massimo di controller di dominio da contattare prima di contattare l'emulatore PDC. Ad esempio, se MinUserDC viene impostato su 4, DSAccess esclude l'emulatore PDC solo quando sono disponibili 4 controller di dominio in tutto.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su come utilizzare la voce MinUserDC del Registro di sistema, consultare l'articolo 298879 della Microsoft Knowledge Base "Problemi di prestazioni in Exchange 2000 quando viene utilizzato un emulatore PDC per DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298879.


Dati sulle prestazioni del contatore Available MBytes
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Available MBytes dell'oggetto prestazioni Memory per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Available MBytes, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Available MBytes mostra la quantità di memoria fisica in MB immediatamente disponibile per l'assegnazione a un processo o per l'utilizzo nel sistema. La quantità di memoria disponibile equivale alla memoria complessiva assegnata alle pagine in sospeso (nella cache), libere e azzerate.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni del contatore Average Disk sec/Read dell'oggetto prestazioni LogicalDisk
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Read dell'oggetto prestazioni LogicalDisk per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Read, vengono visualizzate le informazioni di base sui dati raccolti.

L'oggetto prestazioni Logical Disk è composto da contatori quali Avg. Disk sec/Read, che eseguono il monitoraggio delle partizioni logiche dei dischi rigidi. L'oggetto prestazioni Avg. Disk sec/Read indica il tempo medio, in secondi, di lettura dei dati dal disco. Il valore medio del contatore di prestazioni Avg. Disk sec/Read deve essere inferiore a 10 millisecondi. Il valore medio del contatore di prestazioni Avg. Disk sec/Read non deve essere superiore a 50 millisecondi.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'ottimizzazione del sistema di archiviazione in Exchange Server 2003, consultare Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=49324.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni del contatore Average Disk sec/Read dell'oggetto prestazioni PhysicalDisk
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Read dell'oggetto prestazioni PhysicalDisk per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Read, vengono visualizzate le informazioni di base sui dati raccolti.

L'oggetto prestazioni Avg. Disk sec/Read indica il tempo medio, in secondi, di lettura dei dati dal disco. Il valore medio del contatore di prestazioni Avg. Disk sec/Read deve essere inferiore a 10 millisecondi. Il valore medio del contatore di prestazioni Avg. Disk sec/Read non deve essere superiore a 50 millisecondi.

Se vengono raccolti i risultati dai contatori Disk Reads/sec e Disk Writes/sec, è possibile determinare se l'I/O generato da Exchange Server sta aumentando o diminuendo nel tempo. Se vengono raccolti i risultati dai contatori Avg. Disk sec/Read e Avg. Disk sec/Write, è possibile determinare se la latenza dell'archiviazione si è modificata nel tempo. Ad esempio, i seguenti passaggi consentono di prevedere se la trasmissione dell'archiviazione ha provocato o provocherà un collo di bottiglia:

  1. Effettuare verifiche a scadenza mensile, preferibilmente lo stesso giorno di ogni mese e alla stessa ora del giorno.

  2. Analizzare i dati raccolti.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Average Disk sec/Write dell'oggetto prestazioni LogicalDisk
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Write dell'oggetto prestazioni LogicalDisk per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Write, verranno visualizzate le informazioni di base sui dati raccolti.

L'oggetto prestazioni Logical Disk è composto da contatori quali Avg. Disk sec/Write che monitorano le partizioni logiche dei dischi rigidi. Il contatore di prestazioni Avg. Disk sec/Write indica il tempo medio, in secondi, di scrittura dei dati sul disco. Il valore medio del contatore di prestazioni Avg. Disk sec/Write deve essere inferiore a 10 millisecondi. Il valore medio del contatore di prestazioni Avg. Disk sec/Write non deve essere superiore a 50 millisecondi.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'ottimizzazione del sistema di archiviazione in Exchange Server 2003, consultare Ottimizzazione del sistema di archiviazione per Exchange Server 2003 nel sito Web di Microsoft TechNet all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34649.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Average Disk sec/Write
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer che eseguono Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Write dell'oggetto prestazioni Physical Disk per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Write, verranno visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Avg. Disk sec/Write mostra il tempo medio, in secondi, di scrittura dei dati sul disco. Il valore medio del contatore di prestazioni Avg. Disk sec/Write deve essere inferiore a 10 millisecondi. Il valore medio del contatore di prestazioni Avg. Disk sec/Write non deve essere superiore a 50 millisecondi.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Client Out Queue Length (DSAccess) di Epoxy
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Client Out Queue Length (DSAccess) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie dati dal contatore di prestazioni Client Out Queue Length (DSAccess) , verranno visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Client Out Queue Length (DSAccess) indica il numero di messaggi presenti nella coda contenente i messaggi di DSAccess (Directory Service Access) inviati dal processo Inetinfo.exe. Le code non devono contenere più di 10 messaggi in ogni momento.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Client Out Queue Length (SMTP) di Epoxy
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Client Out Queue Length (SMTP) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Client Out Queue Length (SMTP), vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Client Out Queue Length (SMTP) indica il numero di messaggi presenti nella coda contenente i messaggi SMTP (Simple Mail Transfer Protocol) inviati dal processo Inetinfo.exe. Le code non devono contenere più di 50 messaggi in ogni momento, a meno che non sia presente una coda di posta.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Store Out Queue Length (DSAccess) di Epoxy
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Store Out Queue Length (DSAccess) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Store Out Queue Length (DSAccess), verranno visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Store Out Queue Length (DSAccess) indica il numero di messaggi presenti nella coda contenente i messaggi di DSAccess (Directory Service Access) inviati dal processo Store.exe. Le code non devono contenere più di 10 messaggi in ogni momento.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Store Out Queue Length (SMTP) di Epoxy
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool nclude un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Store Out Queue Length (SMTP) dell'oggetto prestazioni Epoxy per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Store Out Queue Length (SMTP), verranno visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Store Out Queue Length (SMTP) indica il numero di messaggi presenti nella coda contenente i messaggi SMTP (Simple Mail Transfer Protocol) inviati dal processo Store.exe. Le code non devono contenere più di 50 messaggi in ogni momento, a meno che non sia presente una coda di posta.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore latenza media RPC
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni RPC Averaged Latency dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni RPC Averaged Latency, vengono visualizzate le informazioni di base sui dati raccolti.

Nel contatore di prestazioni RPC Averaged Latency viene visualizzata la latenza in millisecondi della RPC, effettuando la media degli ultimi 1.024 pacchetti. Il valore massimo del contatore di prestazioni RPC Averaged Latency deve essere inferiore a 50 millisecondi in ogni momento.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Quindi, il valore massimo non rappresenta l'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore operazioni RPC al secondo
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni RPC Operations/sec dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni RPC Operations/sec, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni RPC Operations/sec visualizza la frequenza con cui avvengono le operazioni RPC (chiamata di procedura remota). Il contatore di prestazioni RPC Operations/sec è un ottimo contatore di frequenza che consente un'adeguata misurazione del carico di lavoro di Exchange Server, in quanto tutte le azioni MAPI utilizzano il protocollo RPC.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore RPC Requests
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni RPC Requests dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie dati dal contatore di prestazioni RPC Requests, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni RPC Requests indica il numero di richieste MAPI RPC o client in esecuzione nel servizio Archivio informazioni di Microsoft Exchange. Il valore medio dell'oggetto prestazioni RPC Requests dovrebbe essere inferiore a 30 in ogni momento. Per impostazione predefinita, il valore massimo di richieste RPC è 100. Pertanto, a meno che non sia configurato diversamente, il servizio Archivio informazioni di Microsoft Exchange è in grado di gestire solo 100 richieste RPC contemporaneamente, oltre le quali rifiuta le richieste client.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Categorizer Queue Length SMTP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Categorizer Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati delle prestazioni. Exchange Server Analyzer segnala il numero totale di messaggi trovati nella coda Classificatore.

Il contatore SMTP Server\Categorizer Queue Length indica il numero di messaggi nella coda SMTP (Simple Mail Transfer Protocol) del classificatore in attesa delle ricerche dell'attributo del servizio directory tramite i server di catalogo globale. Come regola generale, il valore massimo deve essere inferiore a 10.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Il contatore Categorizer Queue Length indica il numero di messaggi nella coda del classificatore dei messaggi. Il classificatore esegue le seguenti operazioni principali:

  • Risolve e convalida tutti i destinatari.

  • Determina i limiti e le restrizioni per tutti i destinatari.

  • Espande le liste di distribuzione se necessario.

  • Determina se il messaggio è destinato al recapito locale o remoto.

Un aumento del contatore Categorizer Queue Length indica la presenza di potenziali problemi relativi alle prestazioni del server, a DSAccess (Directory Service Access), al servizio directory di Active Directory® o a interruzioni dei server principali nell'organizzazione di Exchange Server. Un aumento del contatore Categorizer Queue Length potrebbe indicare lentezza o mancanza di risposta nella consultazione di Active Directory o nella gestione dei messaggi per il recapito locale o SMTP.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Local Queue Length SMTP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Local Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati delle prestazioni. In Exchange Server Analyzer viene segnalato il numero totale di messaggi rilevati nella coda locale SMTP.

Il contatore SMTP Server\Local Queue Length indica il numero di messaggi nella coda SMTP per il recapito locale. Come regola generale, il valore massimo deve essere inferiore a 1.000. È necessario mantenere il valore della coda vicino alla media, con variazioni minime.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Un aumento di messaggi nella coda di recapito locale indica un problema di prestazioni o interruzioni del server, in quanto il server non è più in grado di recapitare la posta in arrivo in tempo utile. Il ritardo può essere dovuto alle seguenti condizioni:

  • Il servizio directory di Active Directory® non è stato consultato immediatamente.

  • I messaggi non vengono gestiti immediatamente per il recapito locale o SMTP.

  • I database sono stati disinstallati.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Categorizer Queue Length SMTP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Remote Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati delle prestazioni. In Exchange Server Analyzer viene segnalato il numero totale di messaggi rilevati nella coda remota SMTP.

Il contatore SMTP Server\Remote Queue Length indica il numero di messaggi presenti nella coda SMTP per il recapito remoto. Come regola generale, il valore massimo deve essere inferiore a 1.000. È necessario mantenere il valore della coda vicino alla media, con variazioni minime.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Un aumento della lunghezza della coda remota indica che i messaggi non vengono inviati ad altri server. Il mancato invio dei messaggi può essere dovuto a interruzioni o problemi di prestazioni nella rete o nei server remoti. Tali interruzioni o problemi di prestazioni impediscono alla rete o ai server remoti di ricevere correttamente i messaggi.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Virus Scan Queue Length
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Virus Scan Queue Length dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Virus Scan Queue Length, verranno visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Virus Scan Queue Length indica il numero corrente di richieste in attesa accodate per la ricerca virus. Il valore consigliato per il contatore è specifico per la propria organizzazione.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Log Record Stalls/sec
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Log Record Stalls/sec dell'oggetto prestazioni Database per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie dati dal contatore di prestazioni Log Record Stalls/sec, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Log Record Stalls/sec indica il numero dei record di registro che non possono essere aggiunti ai buffer di registro al secondo i buffer sono pieni. Il valore medio del contatore di prestazioni Log Record Stalls/sec deve essere inferiore a 10 al secondo. Il valore massimo non deve essere superiore a 100 al secondo.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni per il contatore Thread in attesa di registrazione
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Log Threads Waiting dell'oggetto prestazioni Database per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Log Threads Waiting, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Log Threads Waiting indica il numero di thread i cui dati sono in attesa di scrittura nel registro per completare un aggiornamento del database. Se il valore del contatore di prestazioni Log Threads Waiting è troppo elevato, il registro potrebbe rappresentare un collo di bottiglia per altre transazioni.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Pagine/sec
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Pages/sec dell'oggetto prestazioni Memory per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie dati dal contatore di prestazioni Pages/sec, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Pages/sec visualizza la frequenza con la quale le pagine vengono lette dal disco o scritte sul disco per risolvere gli errori di pagina gravi. Il contatore è un indicatore primario dei tipi di errore che provocano ritardi a livello di sistema. Il conteggio include le pagine recuperate per risolvere gli errori di pagina nella cache del file system. Le pagine sono normalmente richieste dalle applicazioni. È necessario che il contatore abbia un valore in ogni momento inferiore a 1.000.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni del contatore % Processor Time
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni % Processor Time dell'oggetto prestazioni Processor per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie dati dal contatore di prestazioni % Processor Time, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni % Processor Time mostra la percentuale di tempo nella quale il processore esegue thread non inattivi. Questo contatore consente di controllare l'utilizzo generale dei processori o l'utilizzo di ogni processore. L'utilizzo medio della CPU deve essere in ogni momento inferiore al 90%.

Nota:
Il contatore di prestazioni % Processor Time visualizzato da Exchange Server Analyzer è un valore aggregato basato sul numero totale di CPU rilevate, sia fisiche che logiche, diviso per la somma del conteggio CPU.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore Bytes Total/sec
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Bytes Total/sec dell'oggetto prestazioni Network Interface per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni Bytes Total/sec, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni Bytes Total/sec mostra la frequenza con cui la scheda di rete elabora i byte di dati. Il contatore include tutti i dati sulle applicazioni e sui file, oltre alle informazioni sui protocolli quali, ad esempio, le intestazioni dei pacchetti. Per una scheda di rete a 100 Mbps, il valore del contatore di prestazioni Bytes Total/sec deve essere inferiore a 7 megabyte al secondo. Per una scheda di rete a 1000 Mbps, il valore del contatore di prestazioni Bytes Total/sec deve essere inferiore a 70 megabyte al secondo.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore LDAP Read Time
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-06

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni LDAP Read Time dell'oggetto prestazioni MSExchangeDSAccess Process per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie i dati dal contatore di prestazioni LDAP Read Time, verranno visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni LDAP Read Time mostra l'intervallo di tempo in millisecondi necessario perché venga eseguita una richiesta di lettura LDAP. Il valore medio deve essere inferiore a 50 millisecondi. Il valore massimo non deve essere superiore a 100 millisecondi.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il novantesimo valore percentile.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Dati sulle prestazioni dal contatore LDAP Search Time
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni LDAP Search Time dell'oggetto prestazioni MSExchangeDSAccess Processes per analizzare i dati delle prestazioni. Se Exchange Server Analyzer raccoglie dati dal contatore di prestazioni LDAP Search Time, vengono visualizzate le informazioni di base sui dati raccolti.

Il contatore di prestazioni LDAP Search Time visualizza il tempo in millisecondi che una richiesta di ricerca LDAP impiega per essere eseguita. Il valore medio deve essere inferiore a 50 millisecondi. Il valore massimo non deve essere superiore a 100 millisecondi.

Per impostazione predefinita, Exchange Server Analyzer recupera un esempio ogni 30 secondi in un periodo di due ore. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. In Exchange Server Analyzer viene segnalato anche il novantesimo percentile di tutti i dati raccolti.

Nota:
Se tutti i valori raccolti da Exchange Server Analyzer vengono elencati in ordine crescente, il novantesimo percentile sarà il valore posizionato in corrispondenza del novanta per cento dell'elenco. Il novantesimo valore percentile indica i valori elevati del contatore durante l'intervallo di raccolta.

In alcuni casi il valore massimo corrisponderà a quello posizionato nel punto più elevato all'interno dell'intervallo. Pertanto, il valore massimo non è rappresentativo dell'intero intervallo. Il valore medio non rappresenta sempre un indicatore accurato del carico di lavoro, poiché include il tempo di inattività durante l'intervallo di raccolta. Quindi, viene segnalato il valore massimo e il valore al 90 per cento.

Le informazioni contenute in questo messaggio di base sono solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle soglie consigliate dei contatori di prestazioni, consultare Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


L'oggetto Performance Monitor PhysicalDisk non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Avg. Disk sec/Read dell'oggetto prestazioni PhysicalDisk per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni PhysicalDisk è disabilitato.

  • L'oggetto Performance Monitor PhysicalDisk non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestaizone.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Nella procedura seguente viene illustrato come correggere le prime due condizioni. Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni PhysicalDisk sia abilitato.

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dal sito Web Microsoft "Exctrlst.exe: Extensible Performance Counter List" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base, "Ricostruzione manuale dei valori della Libreria dei contatori di prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


Porta del Servizio di replica siti in conflitto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se sono presenti conflitti di porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se Exchange Server Analyzer rileva che il valore HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP corrisponde a uno dei valori specificati negli altri sei valori di porta del Registro di sistema elencati in precedenza, verrà visualizzato un messaggio di errore. Viene anche visualizzato un errore per la porta che entra in conflitto con HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP.

Per risolvere questo problema è necessario modificare questa chiave o della chiave in conflitto impostando un valore unico, come specificato nel file di output di Exchange Server Analyzer.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare il parametro TCP/IP del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Fare doppio clic sulla chiave TCP/IP e impostare il campo Dati valore su un valore univoco superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva l'impostazione, riavviare il computer.

Per distribuire RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare l'articolo della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Esaminare "Support WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle porte mappate staticamente utilizzate da Exchange, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 194952, "XADM: Limitazioni nelle porte mappate staticamente in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)

  • 270836, "Mappatura statica delle porte in Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836.


Conflitto di porta: HTTP Archivio
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se sono presenti conflitti di porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

La chiave Rpc/HTTP Port del Registro di sistema viene utilizzata da Exchange per supportare la funzione RPC su HTTP in Microsoft Office Outlook® 2003 e Outlook via Internet in Exchange Server 2007. If the Exchange Server Analyzer rileva che il valore HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port corrisponde a uno dei valori specificati negli altri sei valori di porta del Registro di sistema elencati in precedenza, verrà visualizzato un messaggio di errore. Viene visualizzato un messaggio di errore anche per la porta in conflitto con HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters\Rpc/HTTP Port.

Per risolvere questo problema è necessario modificare questa chiave o della chiave in conflitto impostando un valore unico, come specificato nel file di output di Exchange Server Analyzer.

Se i client RPC su HTTP in Outlook 2003 oppure Outlook 2007 sono supportati, impostare la chiave Rpc/HTTP Port sul valore decimale 6001. Inoltre, si consiglia di rivedere le configurazioni RPC su HTTP.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare il valore Rpc/HTTP Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Parameters

  3. Fare doppio clic sulla chiave Rpc/HTTP Port e impostare il campo Dati valore su un valore unico superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Per rivedere le configurazioni RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare "Implementazione di Outlook via Internet" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80831.

  3. Esaminare l'articolo 833401 della Microsoft Knowledge Base "Configurazione di chiamate RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Esaminare l'articolo 827330 della Microsoft Knowledge Base "Risoluzione dei problemi di chiamata RPC del client tramite connessione HTTP in Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Esaminare il Webcast di supporto Microsoft "Utilizzo di Microsoft Exchange in Internet (RPC/HTTP) con Microsoft Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Conflitti di porta: Archivio TCP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-30

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se sono presenti conflitti di porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

If the Exchange Server Analyzer rileva che il valore HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port corrisponde a uno dei valori specificati negli altri sei valori di porta del Registro di sistema elencati in precedenza, verrà visualizzato un messaggio di errore. Verrà anche visualizzato un errore per la porta che entra in conflitto con HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port.

Il motivo più comune per cui questo valore viene configurato è quello di consentire ai client MAPI di connettersi a un server di Exchange situato sull'altro lato di un firewall. Questo scenario implica l'apertura di più porte su un firewall per consentire ai client Microsoft Office Outlook® 2003 o Outlook 2007 di connettersi mediante MAPI a un server di Exchange, in genere tramite Internet.

L'implementazione consigliata per l'utilizzo di Outlook in modalità MAPI per connettersi a un server di Exchange tramite Internet consiste nell'utilizzare le funzioni RPC su HTTP reperibili in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. La modalità MAPI è stata precedentemente definita come modalità "Corporate" o "Workgroup".

Per risolvere questo problema è necessario modificare questa chiave o della chiave in conflitto impostando un valore unico, come specificato nel file di output di Exchange Server Analyzer.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave TCP/IP Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Fare doppio clic sulla chiave TCP/IP Port e impostare il campo Dati valore su un valore univoco superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Per distribuire RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare "Implementazione di Outlook via Internet" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80831.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Esaminare "Support WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla mappatura statica delle porte utilizzate da Exchange, consultare l'articolo 270836 della Microsoft Knowledge Base "Mappatura statica delle porte di Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836.


Porta RFR: Supervisore sistema HTTP
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se sono presenti conflitti di porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

La chiave HTTP Port viene utilizzata da Exchange per supportare la funzione RPC su HTTP in Microsoft Office Outlook® 2003 e Outlook via Internet di Exchange Server 2007. Se Exchange Server Analyzer rileva che il valore di HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port corrisponde a uno dei valori specificati negli altri sei valori di porta del Registro di sistema elencati in precedenza, verrà visualizzato un messaggio di errore. Viene visualizzato un messaggio di errore anche per la porta in conflitto con HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port.

Per risolvere questo problema è necessario modificare questa chiave o della chiave in conflitto impostando un valore unico, come specificato nel file di output di Exchange Server Analyzer.

Se i client RPC su HTTP in Outlook 2003 o Outlook 2007 sono supportati, impostare la chiave HTTP Port sul valore decimale 6002. Inoltre, si consiglia di rivedere le configurazioni RPC su HTTP.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare il valore HTTP Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave HTTP Port e impostare il campo Dati valore su un valore unico superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Per rivedere le configurazioni RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare "Implementazione di Outlook via Internet" all'indirizzo http://www.microsoft.com/technet/prodtechnol/exchange/e2k7help/7b2d1ce2-b6df-4604-80fd-2f6cafc47e82.mspx.

  3. Esaminare l'articolo 833401 della Microsoft Knowledge Base "Configurazione di chiamate RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Esaminare l'articolo 827330 della Microsoft Knowledge Base "Risoluzione dei problemi di chiamata RPC del client tramite connessione HTTP in Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Esaminare il Webcast di supporto Microsoft "Utilizzo di Microsoft Exchange in Internet (RPC/HTTP) con Microsoft Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Conflitti di porta: HTTP NSPI Supervisore sistema
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-30

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se sono presenti conflitti di porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

La chiave Rpc/HTTP NSPI Port del Registro di sistema viene utilizzata da Exchange per supportare la funzione RPC su HTTP in Microsoft Office Outlook® 2003 e Outlook via Internet in Exchange Server 2007. Se Exchange Server Analyzer rileva che il valore HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port corrisponde a uno dei valori specificati negli altri sei valori di porta del Registro di sistema elencati in precedenza, verrà visualizzato un messaggio di errore. Verrà anche visualizzato un errore per la porta che entra in conflitto con HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\ Rpc/HTTP NSPI Port.

Per risolvere questo problema è necessario modificare questa chiave o della chiave in conflitto impostando un valore unico, come specificato nel file di output di Exchange Server Analyzer.

Se i client RPC su HTTP in Outlook 2003 oppure Outlook 2007 sono supportati, impostare la chiave Rpc/HTTP NSPI Port sul valore decimale 6004. Inoltre, rivedere le configurazioni RPC su HTTP nell'ambiente.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave Rpc/HTTP NSPI Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave Rpc/HTTP NSPI Port e impostare il campo Dati valore su un valore univoco superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Per rivedere le configurazioni RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare "Implementazione di Outlook via Internet" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80831.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Esaminare "Support WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Conflitti di porta: NSPI del Supervisore sistema
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se sono presenti conflitti di porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se Exchange Server Analyzer rileva che il valore di HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port corrisponde a uno dei valori specificati negli altri sei valori di porta del Registro di sistema elencati in precedenza, verrà visualizzato un messaggio di errore. Viene visualizzato un messaggio di errore anche per la porta in conflitto con HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port.

Il motivo più comune per cui questo valore viene configurato è quello di consentire ai client MAPI di connettersi a un server di Exchange situato sull'altro lato di un firewall. Questo scenario implica l'apertura di più porte su un firewall per consentire ai client Microsoft Office Outlook® 2003 e Outlook 2007 di connettersi mediante MAPI a un server di Exchange, in genere tramite Internet.

L'implementazione consigliata per l'utilizzo di Outlook in modalità MAPI per connettersi a un server di Exchange tramite Internet consiste nell'utilizzare le funzioni RPC su HTTP reperibili in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. La modalità MAPI è stata precedentemente definita come modalità "Corporate" o "Workgroup".

Per risolvere questo problema è necessario modificare questa chiave o della chiave in conflitto impostando un valore unico, come specificato nel file di output di Exchange Server Analyzer.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave TCP/IP NSPI Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave TCP/IP NSPI Port e impostare il campo Dati valore su un valore univoco superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Per distribuire RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare "Implementazione di Outlook via Internet" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80831.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Esaminare "Support WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul mapping statico delle porte in Exchange, consultare il seguente articolo della Microsoft Knowledge Base:

  • 270836, "Mappatura statica delle porte in Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836.


Porta RFR di Supervisore sistema in conflitto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-30

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se sono presenti conflitti di porta:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port

HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se Exchange Server Analyzer rileva che il valore per HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port corrisponde a uno dei valori specificati negli altri sei valori di porta del Registro di sistema elencati in precedenza, verrà visualizzato un messaggio di errore. Verrà anche visualizzato un errore per la porta che entra in conflitto con HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP Port.

Il motivo più comune per cui questo valore viene configurato è quello di consentire ai client MAPI di connettersi a un server di Exchange situato sull'altro lato di un firewall. Questo scenario implica l'apertura di più porte su un firewall per consentire ai client Microsoft Office Outlook® 2003 o Outlook 2007 di connettersi mediante MAPI a un server di Exchange, in genere tramite Internet.

L'implementazione consigliata per l'utilizzo di Outlook in modalità MAPI per connettersi a un server di Exchange tramite Internet consiste nell'utilizzare le funzioni RPC su HTTP reperibili in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. La modalità MAPI è stata precedentemente definita come modalità "Corporate" o "Workgroup".

Per risolvere questo problema è necessario modificare questa chiave o della chiave in conflitto impostando un valore unico, come specificato nel file di output di Exchange Server Analyzer.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave TCP/IP Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave TCP/IP Port e impostare il campo Dati valore su un valore univoco superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Per distribuire RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare "Implementazione di Outlook via Internet" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80831.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  4. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  5. Esaminare "Support WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla mappatura statica delle porte utilizzate da Exchange, consultare l'articolo 270836 della Microsoft Knowledge Base "Mappatura statica delle porte di Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836.


Rilevato aggiornamento cumulativo della versione non definitiva del Service Pack
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Server Analyzer inoltre esegue query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il file di libreria ExCDO (Exchange Collaboration Data Object), ExCDO.dll. Se Exchange Server Analyzer determina che il valore della chiave Version per ExCDO.dll è pari a 6603.0, verrà visualizzato un avviso.

Se un computer Exchange 2000 Server esegue la versione 6603.0 di ExCDO.dll significa che esegue la versione 1 dell'aggiornamento cumulativo successivo al Service Pack 3 (SP3) per Exchange 2000 Server datata agosto 2004. Adesso è disponibile la versione 2 di questo aggiornamento cumulativo. È consigliabile installare l'aggiornamento cumulativo di agosto 2004.

Per risolvere il problema

  1. Per ulteriori informazioni sull'aggiornamento, consultare l'articolo 870540 della Microsoft Knowledge Base "Disponibile l'aggiornamento cumulativo successivo al Service Pack 3 per Exchange 2000 Server di agosto 2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=870540.

  2. Scaricare l'ultimo aggiornamento (Agosto 2004) dalla pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457.

  3. Eseguire un backup del computer Exchange Server.

  4. Installare l'aggiornamento cumulativo di Agosto 2004.

Per ulteriori informazioni su come richiedere il Service Pack più recente per Exchange 2000 Server, consultare l'articolo 301378 della Microsoft Knowledge Base "Come ottenere il service pack più recente per Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378.

Per ulteriori informazioni sull'installazione di questo e di altri aggiornamenti di Exchange Server, consultare l'articolo 328839 della Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Problemi con la posizione del file di paging
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che il file di paging si trova in una posizione che potrebbe influire negativamente sulle prestazioni del server. Il file di paging non dovrebbe essere posizionato nello stesso disco in cui si trovano i database o i file di registro di Exchange. Inoltre, è consigliabile isolare il file di paging dai file di sistema.

Si consiglia di posizionare il file di paging in una partizione dedicata o in un disco ad alta velocità dedicato.

Per risolvere il problema

  • Spostare il file di paging in una posizione che non contenga database o file di registro di Exchange e, se possibile, che non contenga la partizione di sistema.

Per ulteriori informazioni

  • Per ulteriori informazioni sulla configurazione del file di paging, consultare l'articolo 197379 della Microsoft Knowledge Base "Configurazione dei file di paginazione a scopo di ottimizzazione e ripristino" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=197379.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alle prestazioni di Exchange Server, consultare Risoluzione dei problemi di prestazioni di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Collo di bottiglia del processore
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-24

Microsoft® Exchange Server Analyzer Tool ha rilevato che sul server si è verificato un collo di bottiglia della CPU. L'utilizzo della CPU del server ha superato la soglia consigliata. I contatori utilizzati per identificare i colli di bottiglia del processore o i problemi con il processore includono:

  • Contatore di prestazioni Commutazioni di contesto al secondo nell'oggetto prestazioni Sistema.

  • Contatore di prestazioni % Tempo processore (_Total) nell'oggetto prestazioni Processore.

  • Contatore di prestazioni Lunghezza coda processore nell'oggetto prestazioni Sistema.

Rilevamento di un collo di bottiglia del processore

Se è soddisfatta una delle seguenti condizioni, Exchange Server Analyzer rileva un collo di bottiglia:

  • La media del contatore % Tempo processore (_Total) nell'oggetto prestazione Processo è superiore al 70%.

  • La media del contatore % Tempo processore (_Total) nell'oggetto prestazione Processo è superiore al 70%.

  • La media del contatore di prestazioni Commutazioni di contesto al secondo nell'oggetto prestazione Sistema è superiore a 20.000.

  • Il contatore di prestazioni Lunghezza coda processore nell'oggetto prestazione Sistema è superiore a due.

  • Questo contatore di prestazioni % Tempo processore (_Total) nell'oggetto prestazioni Processo offre l'utilizzo complessivo dei processori. L'utilizzo medio della CPU deve essere sempre inferiore all'80%. Medie più elevate indicano la presenza di un collo di bottiglia del processore. Se l'utilizzo medio del processore è superiore al 70%, verrà visualizzato un avviso. Anche frequenti sovraccarichi nel tempo processore superiori al 90% indicano un collo di bottiglia del processore.

  • Il contatore di prestazioni Lunghezza coda processore nell'oggetto prestazione Sistema indica il numero di thread nella coda del processore. Vi è una sola coda per tempo processore, perfino sui computer con più processori. Un numero superiore a due indica che i thread sono in attesa del tempo processore e che si è verificato un collo di bottiglia del processore.

Determinazione delle origini del carico del processore

Se viene individuato un collo di bottiglia, è necessario stabilire qual è la causa dell'utilizzo intensivo della CPU. Su un server back-end di Exchange, la maggior parte dell'utilizzo della CPU è dovuto al processo Store.exe. Se più del 20% dell'utilizzo della CPU proviene da un processo diverso da Store.exe, è importante individuare quali altri processi utilizzano la CPU.

Se l'utilizzo della CPU per i processi elencati nella tabella sottostante è superiore alla soglia, verrà visualizzato un messaggio di errore.

Processo | Soglia per il contatore di prestazioni % Tempo processore nell'oggetto prestazioni Processo.
Store | 90%
Inetinfo | 20%
Emsmts | 40%
Lsass | 40%
Sistema | 40%
Mad | 40%
ExMGMT | 20%
W3WP | 40%

Exchange Server Analyzer misura inoltre la differenza tra il tempo inattivo del processore che viene misurato dal contatore di prestazioni % Tempo processore (istanza Inattivo) e dal contatore di prestazioni % Tempo processore (istanza _Total) nell'oggetto prestazione Processo. Su un server back-end di Exchange che funziona correttamente, almeno il 70% del tempo processore in uso dovrebbe essere dovuto al processo Store.exe.

Se si verificano le seguenti condizioni, verrà visualizzato un messaggio di errore:

  • Se la quantità di tempo processore non utilizzato nei processi relativi al server Exchange (processi Store.exe, inetinfo.exe, emsmta.exe, lsass.exe, w3wp.exe, exmgmt.exe o mad.exe) è superiore al 35%.

  • Se il tempo processore non relativo a Exchange è superiore al 20%.

  • Se vi è un collo di bottiglia del processore e meno del 70% del tempo processore è utilizzato dal processo Store.exe.

In tutti questi casi si consiglia di rilevare quali altri processi utilizzano il tempo della CPU del server.

Cause comuni dei colli di bottiglia del processore sui server back-end

Sono molte le possibili cause di un collo di bottiglia delle prestazioni, tra cui:

  • Altre applicazioni che utilizzano la CPU sul server

  • Elevata frequenza di RPC

  • Espansione lista di distribuzione

  • Backup e manutenzione in esecuzione durante le ore di maggiore traffico

  • Conversione del contenuto in messaggi dovuta a:

    • Esecuzione di più protocolli (ad esempio HTTP, POP3, IMAP4, Microsoft Office Outlook®)

    • Outlook 2000 o versioni precedenti che utilizzano cartelle non in linea (file .ost)

Rimozione di colli di bottiglia del processore

Esistono numerosi metodi per rimuovere i colli di bottiglia dal server Exchange.

Per rimuovere i colli di bottiglia del processore

  • Se possibile, aggiungere al server altri processori o processori più veloci. Attivare inoltre la tecnologia di hyper-threading, se è supportata dai processori. È possibile attivare la tecnologia di hyper-threading configurando il BIOS di sistema. Per ulteriori informazioni, vedere la Guida in linea del produttore del computer.

  • Se non è possibile aumentare la potenza di elaborazione, è necessario ridurre il carico sui processori. Per ridurre l'impatto complessivo sul server, è importante assicurarsi che le attività con utilizzo intensivo di I/O, CPU o di memoria vengano eseguite al di fuori del normale orario di lavoro.

    Innanzitutto individuare le applicazioni o le attività che causano il carico del server. Se un'applicazione non relativa a Exchange non è importante per quel server, eseguirla su un server diverso. Se possibile, spostare anche i ruoli del server su altri computer. Se ad esempio il processo Inetinfo utilizza troppo la CPU, prendere in considerazione la possibilità di aggiungere server front-end responsabili del lavoro di protocollo eseguito da Inetinfo. È inoltre possibile spostare l'accesso alla cartella pubblica in un server di cartelle pubbliche dedicato. Infine, se un server esegue un numero elevato di espansioni di liste di distribuzione, è possibile ridurre l'utilizzo della CPU spostando l'espansione della lista di distribuzione su un server di espansione di liste di distribuzione dedicato.

  • Assicurarsi che le attività che richiedono un utilizzo intensivo della CPU (ad esempio le attività di backup o di manutenzione) vengano eseguite in orari con scarso traffico. e che tali attività vengano eseguite in modo gestito. Gestire un'attività significa impostare diversi tempi di avvio e preferibilmente tempi di fine per ciascuna attività. Gestendo la manutenzione e il backup dei database o dei gruppi di archiviazione, inoltre, si riduce l'effetto delle attività che utilizzano una quantità elevata di risorse.

  • Se sono state rimosse tutte le sorgenti di carico e l'utilizzo della CPU risulta ancora troppo elevato, per ridurre il carico è necessario spostare gli utenti su un server diverso. Per ulteriori informazioni, consultare Spostare le cassette postali degli utenti su un server diverso.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare il Manuale sulla risoluzione dei problemi di prestazioni di Microsoft Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, consultare Spostare le cassette postali degli utenti su un server diverso.


L'oggetto Performance Monitor Processor non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni % Processor Time dell'oggetto prestazioni Processor per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si verifica una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni Processor è disabilitato.

  • L'oggetto Performance Monitor Processor non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestazione.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Nella procedura seguente viene illustrato come correggere le prime due condizioni. Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni Processor sia abilitato.

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina "Exctrlst.exe: Extensible Performance Counter List" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base "Ricreazione manuale dei valori della libreria dei contatori delle prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


Replica del contenuto della cartella pubblica in pausa
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se per l'organizzazione di Exchange Server è stato impostato l'attributo heuristics. Se Exchange Server Analyzer rileva che stato impostato il bit 1024 in heuristics, verrà visualizzato un avviso.

In Exchange Server 2003 SP2 l'amministratore ha la possibilità di interrompere la repliche del contenuto di tutte le cartelle pubbliche nell'organizzazione. È possibile interrompere la replica del contenuto di tutte le cartelle pubbliche facendo clic con il tasto destro del mouse su Gestore di sistema di Exchange quindi su Interrompi la replica del contenuto delle cartelle pubbliche. Dopo aver fatto clic su Interrompi la replica del contenuto delle cartelle pubbliche, bit 1024 viene impostato nell'attributo heuristics. Si consiglia di interrompere la replica di tutte le cartele pubbliche solo in casi estremi, ad esempio durante la risoluzione di problemi nelle cartelle pubbliche a livello dell'organizzazione o nel flusso di posta.

È necessario riprendere la replica del contenuto delle cartelle pubbliche se si verificano le seguenti condizioni:

  • Non si sta effettuando la risoluzione dei problemi.

  • In caso contrario, non è necessario interrompere l'operazione.

Per riprendere la replica del contenuto delle cartelle pubbliche a livello dell'organizzazione

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic con il pulsante destro del mouse su Nome_organizzazione, quindi scegliere Riprendi la replica del contenuto delle cartelle pubbliche.

Per ulteriori informazioni sulla replica di cartelle pubbliche, consultare Best Practices for Exchange Server Public Folders all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46437 (informazioni in lingua inglese).


Archivio delle cartelle pubbliche presente sul server front-end
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-07

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se in ciascun server di Exchange è presente un archivio cartelle pubbliche. Se Exchange Server Analyzer rileva che l'oggetto InformationStore fa parte della classe oggetto msExchPublicMDB, il server contiene un archivio cartelle pubbliche.

Microsoft® Exchange Server Analyzer Tool esegue una query anche nella classe Microsoft WMI (Strumentazione gestione Windows®) MicrosoftExchangeV2 per determinare se è impostato un valore per la chiave IsFrontEndServer. Il valore True indica che il server di Exchange è configurato come server front-end, al contrario il valore False indica che il server di Exchange non è configurato come server front-end. Se Exchange Server Analyzer rileva che un server di Exchange configurato come server front-end contiene un archivio informazioni pubblico, verrà visualizzato un avviso.

È consigliabile non eseguire archivi di cartelle pubbliche in server front-end. Gli archivi di cartelle pubbliche non sono necessari nei server front-end poiché tali server non contengono cassette postali. Inoltre, quando gli archivi di cartelle pubbliche si trovano su server front-end che eseguono Exchange 2000 Server, si verificano problemi di replica, di riferimenti alle cartelle pubbliche e di perdite di memoria. Pertanto, è opportuno disinstallare tutti gli archivi di cartelle pubbliche in tutti i server front-end.

Dopo aver disinstallato gli archivi di cartelle pubbliche, è possibile disattivare il servizio Archivio informazioni di Microsoft Exchange dal momento che non esegue più alcuna funzione sui server front-end. Rimuovendo i servizi non necessari, si riduce il carico e si migliorano le funzioni di protezione e le prestazioni.

Nota:
Se il server front-end riceve anche messaggi SMTP da Internet, il servizio Archivio informazioni di Microsoft Exchange deve rimanere in esecuzione e deve rimanere installato un archivio delle cassette postali. Tuttavia, non si dovrebbe mai installare un archivio di cartelle pubbliche in un server front-end.

Per arrestare e disabilitare la cassetta postale e i database delle cartelle pubbliche

  1. In Gestore di sistema di Exchange, espandere la struttura Server, il proprio server, quindi la struttura Primo gruppo di archiviazione.

    Fare clic con il pulsante destro del mouse su Archivio cassette postali (Nomeserver), fare clic su Disinstalla archivio, quindi su Sì per disinstallare l'archivio.

    Importante:
    Se si utilizza un server front-end come server testa di ponte SMTP, è necessario che nel server sia installato un archivio delle cassette postali. In questo caso, non disinstallare ed eliminare l'archivio, ma verificare che non vi siano cassette postali archiviate sul server.

  2. Fare clic con il pulsante destro del mouse su Archivio cassette postali (Nomeserver), quindi fare clic su Proprietà.

  3. Fare clic sulla scheda Database, selezionare la casella di controllo Do not mount this store at startup, quindi scegliere OK.

    Fare clic con il pulsante destro del mouse su Archivio cartelle pubbliche (Nomeserver), quindi fare clic su Disinstalla archivio.

    Attenzione:
    Prima di disinstallare l'archivio delle cartelle pubbliche accertarsi che ne esista una replica in un altro archivio. In caso contrario, potrebbe verificarsi una perdita delle informazioni.

  4. Fare clic su Sì per disinstallare l'Archivio cartelle pubbliche.

Per disattivare il servizio Archivio informazioni di Microsoft Exchange

  1. Nello snap-in Servizi di MMC, fare clic con il pulsante destro del mouse su Archivio informazioni di Microsoft Exchange nell'elenco Nome e fare clic su Proprietà.

  2. Nell'elenco Tipo di avvio scegliere Disabilitato e fare clic su Arresta.

Per eliminare definitivamente i database delle cassette postali e delle cartelle pubbliche

  • Seguire le istruzioni della Guida alla protezione avanzata di Exchange Server, Disinstallazione ed eliminazione degli archivi di cassette postali e di cartelle pubbliche all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25210.

Per ulteriori informazioni sui problemi relativi ai servizi di archivio in esecuzione sui server front-end, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 286822, "XCCC: I server front-end stabiliscono un elevato numero di connessioni con se stessi" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=286822.

  • 320298, "Elevato numero di connessioni stabilite su server front-end che eseguono Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320298.

Per ulteriori informazioni sui server front-end e back-end, consultare la guida Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology all'indirizzo http://go.microsoft.com/fwlink/?linkid=34216 (informazioni in lingua inglese).


File REAPI.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di alcuni dei file precedenti, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Recipient Update Service is missing or is not configured
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-07-11

Microsoft Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo msExchAddressListServiceLink per ogni oggetto del Servizio aggiornamento destinatari della directory. L'attributo msExchAddressListServiceLink è un collegamento dal servizio elenco di indirizzi al computer Exchange Server sul quale dovrebbe essere eseguito. Se Exchange Analyzer rileva che l'attributo msExchAddressListServiceLink per un oggetto del Servizio aggiornamento destinatari è mancante o che il relativo valore non è popolato, verrà visualizzato un messaggio di errore.

Ogni istanza del Servizio aggiornamento destinatari è in genere associata a un computer Exchange Server che esegue il servizio. Se viene visualizzato questo messaggio, l'istanza del Servizio aggiornamento destinatari non è associata ad alcun computer Exchange Server. Questo può causare il mancato aggiornamento degli elenchi degli indirizzi e dei destinatari di Exchange.

Per eseguire questa istanza del Servizio aggiornamento destinatari, è necessario associarla a un server di Exchange esistente.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. In Destinatari fare clic su Servizi aggiornamento destinatari. Nel riquadro destro fare clic con il pulsante destro del mouse sull'istanza appropriata del Servizio aggiornamento destinatari, quindi scegliere Proprietà.

  3. Nella scheda Generale in Exchange Server fare clic su Sfoglia e specificare un nuovo server per eseguire l'istanza.

  4. Per rendere effettive le modifiche, fare clic su OK, quindi fare nuovamente clic su OK.

  5. Chiudere Gestore di sistema di Exchange.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare l'argomento e gli articoli della Microsoft Knowledge Base riportati di seguito:

  • "Gestione dei destinatari e dei criteri destinatari in Exchange Server 2003" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47617.

  • Articolo 328738: "Applicazione di criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.

  • Articolo 253828: "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • Articolo 246127: "Verifica dell'esecuzione del Servizio aggiornamento destinatari di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127.

  • Articolo 253770: "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.


Aggiornamenti consigliati per Windows 2000 Server SP 4 su un cluster
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul server di Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

Nota:
Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che sul computer è in esecuzione Microsoft Windows 2000 Server. Il valore 5.2 indica che sul computer è in esecuzione Microsoft Windows Server™ 2003.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave ServicePackMajorVersion.

Infine, Exchange Server Analyzer esegue una query nella classe WMI Win32_Service per determinare se il servizio ClusSvc è avviato.

Se le seguenti condizioni risultano soddisfatte, verrà visualizzato un messaggio di configurazione ottimale:

  • Il server di Exchange è in esecuzione su un computer che dispone di Windows 2000 Server aggiornato al Service Pack 4:

  • Il servizio ClusSvc è avviato.

Si consiglia di valutare gli aggiornamenti e gli aggiornamenti rapidi disponibili e di stabilire se possono risolvere i problemi nel proprio ambiente.

Per ulteriori informazioni e per un elenco degli aggiornamenti disponibili per i server che eseguono Windows 2000 Server, consultare l'articolo 895090 della Microsoft Knowledge Base "Aggiornamenti rapidi consigliati per i cluster di server basati su Windows 2000 Service Pack 4" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895090.


Lunghezza coda remota superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-04-09

Lo strumento Microsoft Exchange Analyzer include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Remote Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati relativi alle prestazioni.

Se lo strumento Exchange Analyzer determina che il contatore Remote Queue Length ha superato il valore massimo di 1000 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Il contatore SMTP Server\Remote Queue Length indica il numero di messaggi in attesa per il recapito remoto nella coda SMTP (Simple Mail Transfer Protocol). Un aumento del valore di Remote Queue Length indica che i messaggi non vengono inviati agli altri server.

Il mancato invio dei messaggi può essere dovuto a interruzioni o problemi di prestazioni nella rete o nei server remoti. Tali interruzioni o problemi di prestazioni impediscono alla rete o ai server remoti di ricevere correttamente i messaggi.

Per risolvere il problema, utilizzare le risorse disponibili nei seguenti collegamenti per identificare il server o il componente di rete in cui si è verificato il problema e inviare i problemi di prestazioni.

Ulteriori informazioni

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alle prestazioni di Exchange Server, consultare "Identifying Rising Mail Queues" nella sezione "Identifying Symptoms of Poor Performance" di Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni su Exchange Server Performance, consultare Exchange Server 2003 Performance: 10 Things to Think About all'indirizzo http://go.microsoft.com/fwlink/?LinkID=56460 (informazioni in lingua inglese).


Lunghezza coda tentativi remota superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Remote Retry Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati delle prestazioni.

Il contatore SMTP Server\Remote Retry Queue Length indica il numero di messaggi nella coda tentativi remota SMTP che non può essere inviato a un server di destinazione. Se Exchange Server Analyzer determina che il contatore Remote Retry Queue Length ha superato il valore massimo di 1000 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Il mancato invio dei messaggi può essere dovuto a interruzioni o problemi di prestazioni nella rete o nei server remoti. Tali interruzioni o problemi di prestazioni impediscono alla rete o ai server remoti di ricevere correttamente i messaggi.

Per risolvere il problema, utilizzare le risorse disponibili nei seguenti collegamenti per identificare il server o il componente di rete in cui si è verificato il problema e inviare i problemi di prestazioni.

Ulteriori informazioni

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alle prestazioni di Exchange Server, consultare "Identifying Rising Mail Queues" nella sezione "Identifying Symptoms of Poor Performance" di Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni su Exchange Server Performance, consultare Exchange Server 2003 Performance: 10 Things to Think About all'indirizzo http://go.microsoft.com/fwlink/?LinkID=56460 (informazioni in lingua inglese).


Replica della rubrica non in linea versione 4 non rilevata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_Public_Folder per determinare il valore della chiave HasLocalReplica. Se Exchange Server Analyzer rileva che il valore di HasLocalReplica è impostato su False per l'istanza della rubrica non in linea versione 4 di un elenco indirizzi non in linea, verrà visualizzato un messaggio di errore.

Se HasLocalReplica è impostato su False per l'istanza della rubrica non in linea versione 4, gli elenchi indirizzi non in linea non verranno generati correttamente. Di conseguenza, non potranno essere scaricati dagli utenti di Microsoft Office Outlook® 2003.

Questo problema può verificarsi se non si è configurato alcun archivio delle cartelle pubbliche per contenere le repliche della rubrica non in linea versione 4. Per impostazione predefinita, il contenuto della rubrica non in linea viene replicato nell'archivio delle cartelle pubbliche del server in cui è installata. Se l'archivio delle cartelle pubbliche viene rimosso dalla configurazione di replica della rubrica non in linea, si verificherà il problema descritto nel paragrafo precedente.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, quindi fare clic su Cartelle.

  3. Fare clic con il pulsante destro del mouse su Cartelle pubbliche e scegliere Visualizza cartelle di sistema.

  4. Fare clic per espandere l'oggetto RUBRICA NON IN LINEA.

  5. In RUBRICA NON IN LINEA fare clic con il pulsante destro del mouse su o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List e scegliere Proprietà.

  6. Nella scheda Replica verificare che sia stato inserito un archivio di cartelle pubbliche nella casella Replica contenuto in questi archivi pubblici. Se non è stato inserito, fare clic su Aggiungi e inserire l'archivio pubblico appropriato per la rubrica non in linea.

  7. Fare clic su Applica, quindi su OK.

  8. Fare clic per espandere o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List.

  9. In o=org/cn=addrlists/cn=oabs/cn=Default Offline Address List fare clic con il pulsante destro del mouse su offline Address Book Version 4 e scegliere Proprietà.

  10. Nella scheda Replica verificare che sia stato inserito un archivio di cartelle pubbliche nella casella Replica contenuto in questi archivi pubblici. Se non è stato inserito, fare clic su Aggiungi e inserire l'archivio pubblico appropriato per la rubrica non in linea.

  11. Fare clic su Applica, quindi su OK.

Per ulteriori informazioni su questo problema, consultare l'articolo 286328 della Microsoft Knowledge Base "Rubrica non in linea mancante e non generabile in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=286328.

Per ulteriori informazioni sulla rimozione corretta da un gruppo amministrativo del primo computer che esegue Exchange Server 2003, consultare l'articolo 822931 della Microsoft Knowledge Base "Rimozione del primo computer Exchange Server 2003 dal gruppo amministrativo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822931.

Per ulteriori informazioni sui problemi della rubrica non in linea, consultare le seguenti risorse di Exchange Server:

  • "Offline Address Book - Things to Consider" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=57581 (informazioni in lingua inglese).

  • "How Outlook 2003 SP2 and Exchange Server 2003 SP2 OAB Version 4 Work Together" all'indirizzo http://go.microsoft.com/fwlink/?linkid=53099 (informazioni in lingua inglese).

  • "OAB Version 4 in Exchange Server 2003 Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=53097 (informazioni in lingua inglese).


Lunghezza coda di ricezione messaggi di replica superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Replication Receive Queue Size dell'oggetto prestazioni MSExchangeIS Public per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che il contatore Replication Receive Queue Size ha superato il valore massimo di 1000 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

I messaggi di replica delle cartelle pubbliche vengono recapitati da SMTP, classificati e gestiti dalla coda SMTP locale. Tali messaggi vengono inviati all'Archivio cartelle pubbliche, inseriti nella coda di ricezione messaggi di replica ed elaborati. Infine le modifiche vengono eseguite nella cartella pubblica appropriata. Il contatore di prestazioni Replication Receive Queue Size indica il numero di messaggi di replica delle cartelle pubbliche in attesa di elaborazione.

Più aumentano le dimensioni della coda di replica, inferiore sarà la sincronizzazione del contenuto delle cartelle. Con l'aumento delle dimensioni delle code di replica, infatti, aumenta anche il carico sulle risorse dovuto all'elaborazione dei messaggi nella coda di replica. Inoltre, un aumento delle dimensioni code di replica indica che il contenuto delle cartelle pubbliche è obsoleto.

Non è necessario eseguire alcuna azione nelle due istanze in cui è previsto un aumento della coda di ricezione messaggi di replica ed è possibile adottare misure appropriate:

  • Su un server di cartelle pubbliche appena introdotto l'aumento nella coda di ricezione messaggi di replica può essere causato dalla replica del recupero di informazioni iniziale.

  • Se nella topologia di Exchange si sta verificando il consolidamento del sito o un'altra modifica importante, quando il contenuto verrà spostato verranno generate numerose repliche.

Per i server esistenti e in stato stazionario in cui le repliche di cartelle pubbliche non vengono modificate in massa, questo errore può indicare:

  • Colli di bottiglia delle prestazioni delle risorse del server, ad esempio del disco, della CPU, della rete o della memoria. Se sul server si verifica un collo di bottiglia, il processo Store.exe non sarà in grado di elaborare rapidamente i messaggi di replica, quindi le dimensioni della coda aumenteranno.

  • L'intervallo di replica delle cartelle pubbliche è troppo ridotto e la replica non potrà essere completata prima dell'inizio del ciclo di replica successivo.

Per risolvere il problema, procedere come segue:

  • Aumentare l'intervallo di replica e controllare il contatore MSExchangeIS Public\Replication Receive Queue Size fino a quando indicherà che la replica verrà completata prima dell'inizio del ciclo di replica successivo.

  • Utilizzare le risorse dei collegamenti successivi per determinare se un collo di bottiglia delle prestazioni sta provocando un aumento della coda e per risolvere il problema.

  • Provare a ridurre il numero complessivo di repliche nell'organizzazione di Exchange per ridurre la quantità di traffico di replica richiesta.

Ulteriori informazioni

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alle prestazioni di Exchange Server, consultare "Handling Special Exchange Roles and Performance" in Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulla replica delle cartelle pubbliche in Exchange Server, consultare "Controllo della replica di cartelle pubbliche" in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

  • Per ulteriori informazioni sulle procedure consigliate per le cartelle pubbliche di Exchange, consultare Exchange Public Folder Best Practices: Implementing Replication all'indirizzo http://go.microsoft.com/fwlink/?LinkId=46440 (informazioni in lingua inglese).

  • Per ulteriori informazioni sui miglioramenti per la gestione delle cartelle pubbliche introdotti in Exchange Server 2003 Service Pack 2, consultare Microsoft Exchange Server 2003 Service Pack 2 Release Notes all'indirizzo http://go.microsoft.com/fwlink/?linkid=52072 (informazioni in lingua inglese).


File RESVC.DLL mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di alcuni dei file precedenti, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Digitare il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella colonna Operazione della pagina Selezione dei componenti utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina Web "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina Web "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


La chiave RestrictRemoteClients del Registro di sistema è abilitata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le restrizioni sull'interfaccia RPC (Remote Procedure Call) sono abilitate:

HKEY_LOCAL_MACHINE\ Software\Policies\Microsoft\Windows NT\RPC

Se Exchange Server Analyzer rileva che la chiave RestrictRemoteClients del Registro di sistema è configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Le restrizioni per l'interfaccia RPC forniscono una maggiore protezione della rete rendendo i sistemi meno vulnerabili agli attacchi. Il valore RestrictRemoteClients del Registro di sistema modifica il comportamento di tutte le interfacce RPC del sistema. Per impostazione predefinita, il valore RestrictRemoteClients del Registro di sistema impedisce l'accesso anonimo remoto alle interfacce RPC del sistema, con alcune eccezioni.

Quando viene registrata un'interfaccia utilizzando RpcServerRegisterIf, RPC consente all'applicazione server di limitare l'accesso all'interfaccia, in genere tramite una richiamata di protezione. Il valore RestrictRemoteClients del Registro di sistema consente a RPC di eseguire controlli di protezione aggiuntivi per tutte le interfacce, anche se per l'interfaccia non è stata registrata una richiamata di protezione.

Nota:
I client RPC in cui viene utilizzata la sequenza di protocollo named pipe non sono soggetti alle restrizioni. La sequenza di protocollo non può essere sottoposta a restrizioni a causa di notevoli problemi di compatibilità con le versioni precedenti.
Nota:
È inoltre possibile configurare la chiave the RestrictRemoteClients del Registro di sistema utilizzando l'editor oggetti Criteri di gruppo.

La chiave RestrictRemoteClients del Registro di sistema viene configurata utilizzando i valori DWORD. Se il valore del Registro di sistema non è presente, sarà equivalente al valore RPC_Restrict_Remote_Client_Default.

Nella tabella seguente vengono fornite informazioni sulle impostazioni di configurazione di RestrictRemoteClients.

Valore (DWORD) della chiave del Registro di sistema Descrizione

0 (Predefinito)

RPC_RESTRICT_REMOTE_CLIENT_NONE (0) rappresenta il valore predefinito in Microsoft Windows Server™ 2003 Service Pack 1. Se si imposta il valore predefinito, la restrizione per l'interfaccia RPC verrà ignorata.

L'impostazione del valore predefinito corrisponde al valore di RPC_RESTRICT_REMOTE_CLIENT_NONE. L'applicazione server è responsabile dell'imposizione delle restrizioni RPC appropriate. L'impostazione predefinita è equivalente all'impostazione di RestrictRemoteClients nelle versioni precedenti di Windows.

1

Il valore 1 nella chiave RestrictRemoteClients del Registro di sistema è il valore predefinito in Microsoft Windows® XP Service Pack 2. Se si imposta questo valore, verrà limitato l'accesso a tutte le interfacce RPC. Tutte le chiamate anonime remote verranno rifiutate dal runtime RPC

Questa impostazione del valore corrisponde al valore di RPC_RESTRICT_REMOTE_CLIENT_DEFAULT. Se un'interfaccia registra una richiamata di protezione e fornisce il flag RPC_IF_ALLOW_CALLBACKS_WITH_NO_AUTH, la restrizione non verrà applicata a tale interfaccia.

2

Il valore 2 nella chiave RestrictRemoteClients del Registro di sistema indica che tutte le chiamate anonime remote vengono rifiutate dal runtime RPC senza eccezioni.

Questa impostazione del valore corrisponde al valore di RPC_RESTRICT_REMOTE_CLIENT_HIGH. Quando si imposta questo valore di RestrictRemoteClients, un sistema non può ricevere chiamate anonime remote tramite RPC.

Per ulteriori informazioni sulle modifiche al servizio RPC in Windows XP Service Pack 2, consultare l'articolo di MSDN® "RPC Interface Restrictions" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47371 (informazioni in lingua inglese).


Il server di destinazione RFR è stato sostituito manualmente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema sul server di Exchange per determinare se il servizio Directory Services Proxy Referral (DSProxy referral) è stato sostituito manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\RFR Target Server

Se Exchange Server Analyzer rileva la presenza e l'avvenuta configurazione di RFR Target Server, verrà visualizzato un messaggio di configurazione non predefinita.

La prima volta che il client Microsoft Office Outlook® 2000 Service Release 2 (SR-2) o versione successiva viene connesso a un computer Exchange 2000 Server o Exchange Server 2003, viene ricercato il servizio directory del server principale di Exchange. Inizialmente viene eseguito il processo DSProxy per la prima sessione di Outlook. Dopo la connessione al servizio DSProxy, un riferimento DSProxy viene passato al client che viene informato che tutte le richieste di directory future devono arrivare al server di catalogo globale. Outlook imposta le informazioni del riferimento DSProxy del profilo MAPI nel Registro di sistema.

Il meccanismo di riferimento DSProxy riduce il carico sul server di Exchange e la latenza per i criteri di ricerca per la Rubrica. Se nel profilo viene immesso un nome server esplicito, è necessario riavviare Outlook se si verifica un errore nel server di catalogo globale. Se si verifica una situazione di questo tipo, il server di Exchange invia a Outlook un nuovo riferimento.

In alcune situazioni è consigliabile specificare a livello di codice la voce RFR Target Server per determinare i server da utilizzare per il servizio di riferimento al client MAPI. Ad esempio, una settimana prima dell'abbassamento di livello di un server di catalogo globale a server membro, è preferibile specificare a livello di codice la voce RFR Target Server in un gruppo di server di catalogo globale definito. Questo garantisce che venga fatto alcun riferimento al server di catalogo globale abbassato di livello nei profili MAPI sui client di Outlook. Per ulteriori informazioni su questo specifico utilizzo della voce RFR Target Server del Registro di sistema, consultare l'articolo 305065 della Microsoft Knowledge Base "XADM: Considerazioni sull'abbassamento di livello di un server di catalogo globale a controller di dominio in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per utilizzare il valore del Registro di sistema RFR Target Server

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Creare un nuovo valore REG_MULTISZ chiamato RFR Target Server.

  4. Configurare il valore RFR Target Server con il nome di dominio completo per i server da specificare.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per disabilitare un'impostazione statica per il server RFR, rimuovere il nome di dominio completo del server da rimuovere. Se è stato immesso un solo server di destinazione RFR, eliminare il valore RFR Target Server del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'interazione di client Outlook 2000 SR-2 e versioni successive con il servizio directory di Active Directory®, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 302914, "XCCC: Accesso di Outlook 2000 ad Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=302914.

  • 256976, "XCLN: Accesso di client MAPI ad Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256976.


RegTrace attualmente abilitato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'analisi diagnostica avanzata è stata abilitata nel computer che esegue Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\MosTrace\CurrentVersion\DebugAsyncTrace\EnabledTraces

Se Exchange Server Analyzer rileva che la voce EnabledTraces del Registro di sistema è presente e configurata con un valore diverso da 0, verrà visualizzato un messaggio di errore.

L'analisi diagnostica avanzata dei componenti di routing e trasporto di Exchange Server può essere eseguita mediante l'utilità Regtrace (Regtrace.exe). Regtrace è uno strumento particolarmente utile per la diagnosi e la risoluzione dei problemi relativi ai rapporti di mancato recapito (NDR, Non-Delivery Report). L'utilità Regtrace è reperibile nel CD di Exchange Server all'interno della cartella \Support\Utils\I386.

Il file di traccia è disponibile nel percorso specificato nella scheda Output dell'utilità Regtrace. Il percorso predefinito per il file è C:\Trace.atf. Il file di traccia è un file codificato come binario che contiene informazioni a livello di debug sui componenti di routing e trasporto analizzati. Per questo motivo, il Servizio Supporto Tecnico Clienti Microsoft richiede che i clienti inviino i file di traccia per un'analisi interna.

A meno che non si stia risolvendo attivamente un problema, si avverte che l'abilitazione di Regtrace causa forti riduzioni di prestazione del server e dovrebbe essere utilizzato per brevi periodi di tempo dietro la guida del Servizio Supporto Tecnico Clienti Microsoft. Inoltre, lo spazio su disco per il file di traccia può essere utilizzato alla velocità di 10 o più MB al minuto. Per evitare questo errore nel caso in cui non si stia risolvendo un problema, è possibile utilizzare Regtrace per disabilitare l'analisi.

Per disabilitare l'analisi diagnostica avanzata con Regtrace

  1. Copiare Regtrace.exe dal CD di Exchange Server nel computer che esegue Exchange Server.

  2. Eseguire Regtrace.exe nel computer che esegue Exchange Server. Verrà visualizzata l'interfaccia utente di Regtrace.

  3. Nella scheda Traces, deselezionare tutte le caselle di controllo.

  4. Selezionare la scheda Output e scegliere No Tracing.

  5. Fare clic su OK per salvare le modifiche e chiudere l'utilità Regtrace.
  • Per ulteriori informazioni sullo strumento Regtrace, consultare l'articolo 238614 della Microsoft Knowledge Base, "XCON: Impostazione di Regtrace per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=238614.

  • Per ulteriori informazioni sulla risoluzione dei problemi di messaggistica in generale, consultare l'articolo 281800 della Microsoft Knowledge Base "XCON: Risoluzione dei problemi nei messaggi in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=281800.


Rejection threshold not configured
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-07-30

Microsoft Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore dei seguenti attributi su tutti gli oggetti di classe ContentFilterConfig:

msExchAgentsFlags Il valore dell'attributo msExchAgentsFlag indica lo stato dell'agente filtro contenuto di Microsoft Exchange Server 2007 e dell'azione di rifiuto SCL (Spam Confidence Level). Se l'agente filtro contenuto è abilitato su un computer, verranno filtrati tutti i messaggi provenienti dai connettori di ricezione disponibili su tale computer. Se abilitata, l'azione di rifiuto SCL invia una risposta di rifiuto durante la transazione SMTP per tutti i messaggi che superano la soglia di rifiuto SCL.

msExchMessageHygieneSCLRejectThreshold Il valore dell'attributo msExchMessageHygieneSCLRejectThreshold indica il livello impostato per l'azione di rifiuto SCL. Tale valore rappresenta il livello SCL che un messaggio specifico deve superare affinché l'agente filtro contenuto rifiuti il messaggio e invii un rapporto di mancato recapito (NDR) al mittente.

Exchange Analyzer esegue inoltre il seguente cmdlet di Exchange Management Shell per eseguire una query su tutti i ruoli del server Trasporto Hub nei quali sono installati gli agenti di protezione dalla posta indesiderata:

Get-TransportServer | where { $_.AntispamAgentsEnabled -eq $True}

Se Exchange Analyzer rileva che tutte le seguenti condizioni sono presenti per un server, verrà visualizzato un avviso:

  • Il filtro contenuto è abilitato

  • L'azione di rifiuto SCL è abilitata

  • La soglia di rifiuto SCL è impostata sul valore 9

  • Nel server sono abilitati gli agenti di protezione dalla posta indesiderata.

L'avviso indica che sebbene il filtro contenuto e l'azione di rifiuto SCL siano abilitati, la soglia dell'azione di rifiuto SCL è impostata sul valore predefinito 9. È probabile che i messaggi provenienti da utenti legittimi vengano rifiutati. L'impostazione consigliata per il valore della soglia dell'azione di rifiuto SCL è 7.

Per risolvere l'avviso, impostare il valore della soglia dell'azione di rifiuto SCL su 7 utilizzando la scheda Anti-spam in Exchange Management Console oppure il cmdlet Set-ContentFilterConfig in Exchange Management Shell.

Per configurare la soglia dell'azione di rifiuto SCL, seguire le istruzioni contenute nell'argomento "Come abilitare e configurare le soglie del livello di probabilità di posta indesiderata (SCL, Spam Confidence Level)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=96099 nella documentazione del prodotto di Exchange Server 2007.

Per ulteriori informazioni

Per ulteriori informazioni sulla gestione delle funzionalità di protezione dalla posta indesiderata e antivirus, vedere "Gestione delle funzionalità protezione da posta indesiderata e antivirus " all'indirizzo http://go.microsoft.com/fwlink/?LinkId=96103 nella documentazione del prodotto di Exchange Server 2007.


Servizio aggiornamento destinatari eliminato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchAddressListServiceLink per ciascun oggetto del Servizio aggiornamento destinatari della directory. L'attributo msExchAddressListServiceLink è un collegamento dal servizio elenco di indirizzi al computer Exchange Server in cui dovrebbe essere eseguito. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchAddressListServiceLink è impostato su DEL:, verrà visualizzato un messaggio di errore.

Ogni istanza del Servizio aggiornamento destinatari è associata a un computer Exchange Server che esegue il servizio. Se viene visualizzato questo messaggio, l'istanza del Servizio aggiornamento destinatari è associata a un computer Exchange Server che non esiste nell'organizzazione di Exchange. È possibile che le autorizzazioni per il server siano state rimosse o che il server sia stato rimosso dalla topologia.

Per eseguire questa istanza del Servizio aggiornamento destinatari, è necessario associarla a un server Exchange esistente.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. In Destinatari fare clic su Servizi aggiornamento destinatari. Nel riquadro destro fare clic con il pulsante destro del mouse sull'istanza appropriata del Servizio aggiornamento destinatari, quindi fare clic su Proprietà.

  3. Nella scheda Generale in Exchange Server fare clic su Sfoglia e specificare un nuovo server per eseguire l'istanza.

  4. Per rendere effettive le modifiche, fare clic su OK, quindi fare nuovamente clic su OK.

  5. Chiudere Gestore di sistema di Exchange.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti argomenti di Exchange e articoli della Microsoft Knowledge Base:

  • "Gestione dei destinatari e dei criteri destinatario" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47617.

  • 328738, "XADM: Applicazione dei criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • 246127, "XADM: Verifica dell'esecuzione del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127.

  • 253770, "XADM: 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.


Il binding RPC non contiene un nome di dominio completo (FQDN)
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore ncacn_ip_tcp dell'attributo networkAddress contiene un nome di dominio completo (FQDN). Se Exchange Server Analyzer rileva che il valore ncacn_ip_tcp non contiene un punto (.), verrà visualizzato un messaggio di errore.

In Microsoft Office Outlook® Web Access per Exchange Server 2003, il valore dell'attributo networkaddress viene esaminato dal server front-end quando questo tenta di connettersi a un server back-end di Exchange.

Nota:
Questa operazione non è possibile con Outlook Web Access per Exchange 2000 Server. Per il server front-end è necessario il valore di un nome di dominio completo.

Il server front-end verifica la presenza di un punto nel valore restituito per networkaddress ncacn_ip_tcp. Se le seguenti condizioni vengono soddisfatte, si verificherà un errore nella richiesta di connessione per la cassetta postale sul server back-end e il server front-end restituirà all'utente il messaggio di errore "HTTP 500 - Errore interno del server":

  • Il valore ncacn_ip_tcp è un nome host o un nome NetBIOS (Network Basic Input/Output System).

  • Il valore ncacn_ip_tcp non è un nome di dominio completo.

Per garantire il corretto funzionamento di Outlook Web Access per Exchange Server 2003, è necessario aggiornare il valore ncacn_ip_tcp nell'oggetto server di Active Directory. L'output di Exchange Server Analyzer fornisce il nome del server interessato.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Nota:
Prima di aggiornare il valore ncacn_ip_tcp, leggere il resto di questo articolo. Potrebbe essere necessario eseguire una procedura aggiuntiva prima di riavviare i servizi Exchange Server.
Per aggiornare il valore ncacn_ip_tcp dell'attributo networkAddress

  1. Avviare lo strumento ADSI Edit dagli strumenti di supporto di Windows 2000 Server o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Gruppi amministrativi

    • Administrative_Group_Name

    • Server

  3. Fare clic con il pulsante destro del mouse su Exchange_Server_Name e scegliere Proprietà.

  4. Fare clic su networkaddress nell'elenco Attributi, quindi selezionare Modifica.

  5. Aggiungere un nuovo valore per ncacn_ip_tcp. Utilizzare il nome di dominio completo del server invece del nome NetBIOS o del nome host.

    La sintassi per questo valore è ncacn_ip_tcp:FQDN. Ad esempio, se il server back-end di Exchange dispone di un nome host quale, ad esempio, EXCHANGE1 e se il nome di dominio completo è EXCHANGE1.contoso.com, utilizzare il valore seguente per ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Per rimuovere il valore ncacn_ip_tcp originale che contiene il nome NetBIOS o il nome host del server back-end, selezionare il valore originale e fare clic su Rimuovi. Fare clic su OK due volte per rendere effettiva la modifica.

  7. Riavviare tutti i servizi Exchange Server sul server.

  8. Se sono presenti più controller di dominio, attendere la replica prima di tentare l'accesso dal server front-end. Se il problema persiste dopo il completamento della replica, riavviare il servizio Amministrazione IIS sul server front-end.

Se si mantengono file host sui server back-end per correlare un indirizzo IP del server contenente un nome host breve, è necessario aggiornare anche il valore UpdateProtocols del Registro di sistema. Se viene utilizzato un file host, il valore ncacn_ip_tcp potrebbe essere nuovamente modificato al riavvio di Supervisore sistema di Microsoft Exchange. Se il server back-end è di tipo cluster, il valore ncacn_ip_tcp potrebbe essere nuovamente modificato dopo il failover.

Per ridurre al minimo i tempi di inattività causati dal riavvio dei servizi Exchange Server, è necessario eseguire prima la seguente operazione aggiornando il valore ncacn_ip_tcp nell'attributo networkaddress come descritto nella procedura indicata sopra.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per modificare il valore UpdateProtocols del Registro di sistema per server back-end in cui si utilizzano file host

  1. Utilizzare un editor del Registro di sistema per configurare il seguente valore sui server back-end: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Nota:
    Se il valore UpdateProtocols non è presente, è necessario crearlo. Per eseguire l'operazione, procedere come segue:
    1. Aprire un editor del Registro di sistema e individuare la seguente sottochiave: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    2. Fare clic con il pulsante destro del mouse su Parametri, scegliere Nuovo, quindi fare clic su Valore DWORD.

    3. Digitare UpdateProtocols, quindi premere INVIO.

  2. Fare clic con il pulsante destro del mouse su UpdateProtocols, selezionare Modifica, digitare 0 nel campo Dati valore e fare clic su OK.

  3. Se nella rete viene utilizzato un file Hosts sul nodo cluster back-end, modificare l'ordine della voce UpdateProtocols nel modo seguente:

    IPAddress to FQDN

    IPAddress to NetBIOS

    invece di:

    IPAddress to NetBIOS

    IPAddress to FQDN

  4. Riavviare tutti i servizi Exchange Server sul server.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Binding RPC non corrispondente al nome DNS risolto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool tenta di eseguire una query in Domain Name System (DNS) per ricercare i server DNS configurati per ogni computer Exchange Server. Questa connessione viene effettuata mediante un elaboratore di oggetti personalizzati su cui viene eseguita una richiesta di risoluzione dei nomi e vengono analizzati i risultati. Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare se il valore ncacn_ip_tcp del server nell'attributo networkAddress e il nome di dominio completo (FQDN, Fully Qualified Domain Name) restituito dopo la risoluzione DNS sono diversi. L'attributo networkAddress è presente in ogni oggetto Exchange Server in Active Directory. Se Exchange Server Analyzer rileva che il valore ncacn_ip_tcp del server in Active Directory non corrisponde al nome FQDN dopo la risoluzione DNS, verrà visualizzato un avviso.

Questa situazione si verifica se il FQDN del server viene modificato dopo l'installazione di Exchange. Sia Exchange Server che Active Directory richiedono la corretta configurazione del DNS per funzionare. La risoluzione dei problemi e la reigstrazione dei servizi di denominazione dei domini possono interessare in maniera significativa la capacità del computer Exchange Server di inviare, ricevere e recapitare messaggi. È poossibile prevenire i problemi facendo corrispondere i due indirizzi, modificando manualmente l'attributo networkAddress nell'oggetto Exchange Server in Active Directory.

È necessario aggiornare il valore ncacn_ip_tcp nell'oggetto server in Active Directory per assicurarsi che il valore ncacn_ip_tcp corrisponda al FQDN DNS del server. L'output di Exchange Server Analyzer fornisce il nome del server interessato.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per aggiornare il valore ncacn_ip_tcp dell'attributo networkAddress

  1. Avviare lo strumento ADSI Edit dagli Strumenti di supporto di Windows® 2000 o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Gruppi amministrativi

    • Administrative_Group_Name

    • Server

  3. Fare clic con il pulsante destro del mouse su Exchange_Server_Name e scegliere Proprietà.

  4. Fare clic su networkaddress nell'elenco Attributi, quindi selezionare Modifica.

  5. Aggiungere un nuovo valore per ncacn_ip_tcp. Utilizzare il FQDN del server al posto del valore corrente.

    La sintassi per questo valore è ncacn_ip_tcp:FQDN. Ad esempio, se il server di Exchange dispone di un nome host quale, ad esempio, EXCHANGE1 e se il nome di dominio completo è EXCHANGE1.contoso.com, utilizzare il valore seguente per ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.contoso.com.

  6. Rimuovere il valore ncacn_ip_tcp originale che contiene il nome errato del server selezonando il valore originale e facendo clic su Rimuovi. Fare clic su OK due volte per rendere effettiva la modifica.

  7. Riavviare tutti i servizi Exchange Server sul server.

Per ulteriori informazioni sull'utilizzo di DNS con Active Directory, consultare l'articolo 323418 della Microsoft Knowledge Base "HOW TO: Integrare DNS con un'infrastruttura DNS esistente se Active Directory è attivato in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=323418.


L'ordine di binding RPC non è corretto
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'ordine di associazione della chiamata di procedura remota (RPC, Remote Procedure Call) utilizzata dal computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Se Exchange Server Analyzer rileva che il valore di Rpc_Svr_Binding_Order non inizia con ncacn_ip_tcp, verrà visualizzato un messaggio di errore.

La voce Rpc_Svr_Binding_Order del Registro di sistema viene creata quando si installa Exchange Server in un computer. Tale voce determina la sequenza di protocollo utilizzata per le comunicazioni RPC da server a server.

Per impostazione predefinita, la voce Rpc_Svr_Binding_Order contiene i seguenti dati di valore:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Nota:
È possibile che nella stringa siano contenuti altri valori se nel computer che esegue Exchange Server sono installati anche altri protocolli.

Questa voce consente di specificare l'ordine in cui Exchange Server prova i protocolli di comunicazione di rete per le comunicazioni RPC con altri server. Ad esempio, poiché il protocollo TCP/IP è stato specificato per primo, Exchange Server proverà a comunicare con altri server utilizzando la RPC tramite TCP/IP prima di provare una RPC con altri protocolli.

Si consiglia di non modificare l'ordine di binding RPC rispetto al valore predefinito. Se il valore predefinito è stato modificato, si possono verificare problemi durante l'avvio del server o del servizio oppure durante le comunicazioni da server a server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Nel riquadro di destra fare doppio clic su Rpc_Svr_Binding_Order.

  4. Nella finestra di dialogo Dati valore digitare ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Fare clic su OK, quindi chiudere l'editor del Registro di sistema.

  6. Per rendere effettive le modifiche, riavviare tutti i servizi di Exchange Server o riavviare il computer che esegue Exchange Server.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'ordine di binding RPC, consultare l'articolo 325930 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività causati dalle voci del Registro di sistema relative al protocollo del client RPC" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930.


È stata rilevata la presenza della voce di registro Rpc_Binding_Order
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'ordine di associazione della chiamata di procedura remota (RPC, Remote Procedure Call) utilizzata dal computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Binding_Order

Se Exchange Server Analyzer rileva la presenza della voce Rpc_Binding_Order, verrà visualizzato un avviso.

La presenza del valore Rpc_Binding_Order indica che sul computer è installato almeno uno dei seguenti elementi:

  • Exchange Server 5.5

  • Microsoft Office Outlook® 2003

  • Cluster di Windows

  • La voce RPC_Binding_Order determina la sequenza dei protocolli utilizzata quando vengono inizializzate le comunicazioni RPC di Outlook. Questa voce non viene creata in Exchange Server 2003 né in Exchange 2000 Server. Questa voce viene creata solo in Exchange Server 5.5 e nelle versioni precedenti di Exchange. Se Exchange Server 5.5 o Microsoft Outlook sono stati installati nel computer e rimossi in un secondo tempo, è possibile rimuovere manualmente questa voce del Registro di sistema. Inoltre, si consiglia di rimuovere Outlook dai computer che eseguono Exchange Server, poiché questa configurazione non è supportata. Per ulteriori informazioni sull'esecuzione di Exchange e di Outlook sullo stesso computer, consultare l'articolo 266418 della Microsoft Knowledge Base "Microsoft does not recommend installing Exchange Server and Outlook on the same computer" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266418 (informazioni in lingua inglese).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per rimuovere la voce del Registro di sistema Rpc_Binding_Order

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Eliminare il valore di Rpc_Binding_Order.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema, quindi riavviare tutti i servizi di Exchange Server o riavviare il computer che esegue Exchange Server.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla voce RPC_Binding_Order del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325930, "Risoluzione dei problemi di connettività causati dalle voci del Registro di sistema relative al protocollo del client RPC" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930.

  • 326036, "XADM: Impossibile accedere al computer Exchange 2000 Server utilizzando le credenziali corrette" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=326036.


Il valore Rpc_Svr_Binding_Order del Registro di sistema è stato modificato rispetto al valore predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'ordine di associazione della chiamata di procedura remota (RPC, Remote Procedure Call) utilizzata dal computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider\Rpc_Svr_Binding_Order

Se Exchange Server Analyzer rileva che il valore di Rpc_Svr_Binding_Order non è impostato su ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp, verrà visualizzato un avviso.

La voce Rpc_Svr_Binding_Order del Registro di sistema viene creata quando si installa Exchange Server in un computer. Tale voce determina la sequenza di protocollo utilizzata per le comunicazioni RPC da server a server.

Per impostazione predefinita, la voce Rpc_Svr_Binding_Order contiene i seguenti dati di valore:

ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp

Nota:
È possibile che nella precedente stringa siano contenuti altri valori se nel computer che esegue Exchange Server sono installati anche altri protocolli.

Questa voce consente di specificare l'ordine in cui Exchange Server prova i protocolli di comunicazione di rete per le comunicazioni RPC con altri server. Ad esempio, poiché il protocollo TCP/IP è stato specificato per primo, Exchange Server proverà a comunicare con altri server utilizzando la RPC tramite TCP/IP prima di provare una RPC con altri protocolli.

Si consiglia di non modificare l'ordine di binding RPC rispetto al valore predefinito. Se il valore predefinito è stato modificato, si possono verificare problemi durante l'avvio del server o del servizio oppure durante le comunicazioni da server a server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Exchange\Exchange Provider

  3. Nel riquadro di destra fare doppio clic su Rpc_Svr_Binding_Order.

  4. Nella finestra di dialogo Dati valore digitare ncacn_ip_tcp,ncacn_spx,ncacn_vns_spp.

  5. Fare clic su OK, quindi chiudere l'editor del Registro di sistema.

  6. Per rendere effettive le modifiche, riavviare tutti i servizi di Exchange Server o riavviare il computer che esegue Exchange Server.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'ordine di binding RPC, consultare l'articolo 325930 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività causati dalle voci del Registro di sistema relative al protocollo del client RPC" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325930.


Il ciclo di andata e ritorno al server Active Directory è maggiore di 100 ms
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) WIN32_PingStatus nello spazio dei nomi root\cimv2 per determinare il valore della chiave ResponseTime. Se Exchange Server Analyzer rileva che il valore della chiave ResponseTime è maggiore di 100 millisecondi (ms), verrà visualizzato un messaggio di errore.

La chiave ResponseTime rappresenta il tempo trascorso (in millisecondi) fino alla risposta a una richiesta echo ICMP (ping). I controller di dominio utilizzati da un computer Exchange Server dovrebbero presentare sempre un tempo di risposta minore o uguale a 10 ms. Se il tempo di risposta supera i 100 ms, il ritardo potrebbe indicare problemi di prestazioni o di connettività.

Per risolvere il problema

  1. Verificare che il controller di dominio in questione non sia sovraccarico. Utilizzare lo strumento ADTest.exe per eseguire verifiche sul controller di dominio e verificare se l'hardware è in grado di gestire il carico anticipato.

  2. Controllare i registri eventi sul server Exchange e il controller di dominio per verificare se eventi legati alla rete a cui si ha accesso indicano uno o più problemi.

  3. Utilizzare i comandi DCDiag.exe e NetDiag.exe sul controller di dominio per verificare che la configurazione e il funzionamento siano corretti.

  4. Analizzare infine la struttura del sito del servizio directory di Active Directory®. Un sito Active Directory può essere considerato come una sezione di rete che presenta elevata larghezza di banda e scarsa latenza. Se la rete non è partizionata in maniera conforme a questa specifica, è necessario partizionarla in più siti Active Directory.
Nota:
Quando viene eseguita la query WMI per il test ping, vengono ignorati la dimensione predefinita del pacchetto e i valori del timeout. Viene invece utilizzata la dimensione del pacchetto 4096 ICMP (anziché la dimensione di 32 byte predefinita) e un valore del timeout di 2000 ms (anziché il valore predefinito di 1000 ms).

Per l'emulazione manuale del comportamento del ping, procedere come segue.

Per eseguire manualmente il test ping

  • Eseguire il seguente comando nella riga di comando del server Exchange:ping -L 4096 -N 6 <Active Server server name>Nota Il comando avvia sei richieste ping di 4096 byte ciascuna.

Per ulteriori informazioni sullo strumento ADTest.Exe, consultare il sito Web "Active Directory Performance Testing Tool (ADTest.exe)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33758 (informazioni in lingua inglese).

Per ulteriori informazioni sulla classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PingStatus, consultare l'articolo di MSDN® "Win32_PingStatus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33549 (informazioni in lingua inglese).

Per ulteriori informazioni sulla struttura del sito Active Directory, consultare "Designing the Site Topology" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33551 (informazioni in lingua inglese).


Il ciclo di andata e ritorno al server Active Directory è maggiore di 10 ms
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) WIN32_PingStatus nello spazio dei nomi root\cimv2 per determinare il valore della chiave ResponseTime. Se Exchange Server Analyzer rileva che il valore della chiave ResponseTime è maggiore di 10 millisecondi (ms) ma minore di 100 ms, verrà visualizzato un avviso.

La chiave ResponseTime rappresenta il tempo trascorso (in millisecondi) per la risposta ai pacchetti di richieste echo (ping) del protocollo Internet Control Message Protocol (ICMP) inviata dal server Exchange al controller di dominio. I controller di dominio utilizzati da un computer Exchange Server dovrebbero presentare sempre un tempo di risposta minore o uguale a 10 ms. Se il tempo di risposta supera i 10 ms, il ritardo potrebbe indicare problemi di prestazioni o di connettività.

Per risolvere il problema

  1. Verificare che il controller di dominio in questione non sia sovraccarico. Utilizzare lo strumento ADTest.exe per eseguire verifiche sul controller di dominio e verificare se l'hardware è in grado di gestire il carico anticipato.

  2. Controllare i registri eventi sul server Exchange e il controller di dominio, per verificare se sono stati registrati eventi relativi alla rete che indicano uno o più problemi.

  3. Utilizzare i comandi DCDiag.exe e NetDiag.exe sul controller di dominio per verificare che la configurazione e il funzionamento siano corretti.

  4. Analizzare infine la struttura del sito del servizio directory di Active Directory®. Un sito Active Directory è considerato come una sezione di rete con elevata larghezza di banda e scarsa latenza. Se la rete non è partizionata in modo conforme a questa specifica, è possibile decidere di partizionarla in più siti Active Directory.
Nota:
Quando viene eseguita la query WMI per il test ping, vengono ignorati la dimensione predefinita del pacchetto e i valori del timeout. Viene invece utilizzata la dimensione del pacchetto 4096 ICMP (anziché la dimensione di 32 byte predefinita) e un valore del timeout di 2000 ms (anziché il valore predefinito di 1000 ms).

Per l'emulazione manuale del comportamento del ping, procedere come segue.

Per eseguire manualmente il test ping

  • Eseguire il seguente comando nella riga di comando del server Exchange:ping -L 4096 -N 6 <Active Server server name>Nota Il comando avvia sei richieste ping di 4096 byte ciascuna.

Per ulteriori informazioni sullo strumento ADTest.Exe, consultare il sito Web "Active Directory Performance Testing Tool (ADTest.exe)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33758 (informazioni in lingua inglese).

Per ulteriori informazioni sulla classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PingStatus, consultare l'articolo di MSDN® "Win32_PingStatus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33549 (informazioni in lingua inglese).

Per ulteriori informazioni sulla struttura del sito Active Directory, consultare "Designing the Site Topology" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33551 (informazioni in lingua inglese).


Il ciclo di andata e ritorno al server di catalogo globale impiega più di 100 ms
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) WIN32_PingStatus nello spazio dei nomi root\cimv2 per determinare il valore della chiave ResponseTime. Se Exchange Server Analyzer rileva che il valore della chiave ResponseTime è maggiore di 100 millisecondi (ms), verrà visualizzato un messaggio di errore.

La chiave ResponseTime rappresenta il tempo trascorso (in millisecondi) per la risposta ai pacchetti di richieste echo (ping) del protocollo Internet Control Message Protocol (ICMP) inviata da Exchange Server al server di catalogo globale. I server di catalogo globale utilizzati da un computer che esegue Exchange Server devono presentare sempre un tempo di risposta inferiore o uguale a 10 ms. Se il tempo di risposta è maggiore di 10 ms, potrebbero verificarsi problemi in termini di prestazioni o connettività.

Per risolvere il problema

  1. Assicurarsi che il server di catalogo globale in questione non sia sovraccarico. Utilizzare lo strumento ADTest.exe per eseguire verifiche del server di catalogo globale e scoprire se l'hardware è in grado di gestire il carico previsto.

  2. Esaminare i registri eventi del server Exchange e del server di catalogo globale per verificare se sono stati registrati eventi relativi alla rete che indicano la presenza di uno o più problemi.

  3. Utilizzare i comandi DCDiag.exe e NetDiag.exe sul server di catalogo globale per verificarne la corretta configurazione e l'integrità.

  4. Analizzare infine la struttura del sito del servizio directory di Active Directory®. Un sito Active Directory può essere considerato come una sezione di rete che presenta elevata larghezza di banda e scarsa latenza. Se la rete non è partizionata in maniera conforme a questa specifica, è necessario partizionarla in più siti Active Directory.
Nota:
Quando viene eseguita la query WMI per il test ping, vengono ignorati la dimensione predefinita del pacchetto e i valori del timeout. Viene invece utilizzata la dimensione del pacchetto 4096 ICMP (anziché la dimensione di 32 byte predefinita) e un valore del timeout di 2000 ms (anziché il valore predefinito di 1000 ms).

Per l'emulazione manuale del comportamento del ping, procedere come segue.

Per eseguire manualmente il test ping

  • Eseguire il seguente comando nella riga di comando del server Exchange:ping -L 4096 -N 6 <Active Server server name>Nota Il comando avvia sei richieste ping di 4096 byte ciascuna.

Per ulteriori informazioni sullo strumento ADTest.exe, consultare il sito Web "Active Directory Performance Testing Tool (ADTest.exe)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33758 (informazioni in lingua inglese).

Per ulteriori informazioni sulla classe WMI Win32_PingStatus, consultare l'articolo di MSDN® "Win32_PingStatus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33549 (informazioni in lingua inglese).

Per ulteriori informazioni sulla struttura del sito di Active Directory, consultare la sezione "Designing the Site Topology" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33551 (informazioni in lingua inglese).

Per informazioni sull'installazione degli strumenti di supporto di Windows 2000 Server, consultare l'articolo 301423 della Microsoft Knowledge Base "Installazione degli strumenti di supporto di Windows 2000 in un computer basato su Windows 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301423.

Per informazioni sull'installazione degli strumenti di supporto di Windows Server 2003, consultare "Install Windows Support Tools" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41362 (informazioni in lingua inglese).


Il ciclo di andata e ritorno al server di catalogo globale impiega più di 10 ms
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) WIN32_PingStatus nello spazio dei nomi root\cimv2 per determinare il valore della chiave ResponseTime. Se Exchange Server Analyzer rileva che il valore della chiave ResponseTime è maggiore di 10 millisecondi (ms) ma minore di 100 ms, verrà visualizzato un avviso.

La chiave ResponseTime rappresenta il tempo trascorso (in millisecondi) per la risposta ai pacchetti di richieste echo (ping) del protocollo Internet Control Message Protocol (ICMP) inviata dal server Exchange al server di catalogo globale. I server di catalogo globale utilizzati da un computer Exchange Server devono sempre presentare un tempo di risposta minore o uguale a 10 millisecondi. Se il tempo di risposta supera i 10 millisecondi, è possibile che si siano verificati problemi di prestazioni o di connettività.

Per risolvere il problema

  1. Assicurarsi che il server di catalogo globale in questione non sia sovraccarico. Utilizzare lo strumento ADTest.exe per eseguire verifiche del server di catalogo globale e scoprire se l'hardware è in grado di gestire il carico previsto.

  2. Esaminare i registri eventi del server Exchange e del server di catalogo globale per verificare se sono stati registrati eventi relativi alla rete che indicano la presenza di uno o più problemi.

  3. Utilizzare i comandi DCDiag.exe e NetDiag.exe sul server di catalogo globale per verificarne la corretta configurazione e l'integrità.

  4. Analizzare infine la struttura del sito del servizio directory di Active Directory®. Un sito Active Directory può essere considerato come una sezione di rete che presenta elevata larghezza di banda e scarsa latenza. Se la rete non è partizionata in maniera conforme a questa specifica, è necessario partizionarla in più siti Active Directory.
Nota:
Quando viene eseguita la query WMI per il test ping, vengono ignorati la dimensione predefinita del pacchetto e i valori del timeout. Viene invece utilizzata la dimensione del pacchetto 4096 ICMP (anziché la dimensione di 32 byte predefinita) e un valore del timeout di 2000 ms (anziché il valore predefinito di 1000 ms).

Per l'emulazione manuale del comportamento del ping, procedere come segue.

Per eseguire manualmente il test ping

  • Eseguire il seguente comando nella finestra della riga di comando del server Exchange:

    ping -L 4096 -N 6 <Active Server server name>

    Nota:
    Il comando avvia sei richieste ping di 4096 byte ciascuna.

Per ulteriori informazioni sullo strumento ADTest.exe, consultare il sito Web "Active Directory Performance Testing Tool (ADTest.exe)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33758 (informazioni in lingua inglese).

Per ulteriori informazioni sulla classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PingStatus, consultare l'articolo di MSDN® "Win32_PingStatus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=33549 (informazioni in lingua inglese).

Per ulteriori informazioni sulla struttura del sito Active Directory, consultare "Designing the Site Topology" all'indirizzo http://go.microsoft.com/fwlink/?linkid=33551 (informazioni in lingua inglese).


Richiesta la modifica del filtro di ricerca per il criterio destinatario
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo purportedSearch per ciascun oggetto criterio destinatario di Exchange Server. L'attributo purportedSearch indica l'argomento di ricerca utilizzato quando si applica il criterio.

Viene inoltre eseguita una query in Active Directory® per determinare il valore dell'attributo msDS-Behavior-Version dell'oggetto Impostazioni NTDS dell'insieme di strutture di Active Directory. Questo valore indica il livello operativo dell'insieme di strutture di Active Directory. I valori validi per l'attributo msDS-Behavior-Version sono elencati nella seguente tabella.

Valore | Livello operativo dell'insieme di strutture
0 | Microsoft Windows® 2000 Server modalità mista
1 | Microsoft Windows Server™ 2003 modalità provvisoria
2 | Windows Server 2003 modalità nativa

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il valore dell'attributo revision del contenitore Windows2003Update. Il valore di questo attributo indica se lo strumento di preparazione di Active Directory (ADPrep.exe) è stato eseguito.

Microsoft® Exchange Server Analyzer Tool infine esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore della chiave OSProductSuite indica la versione di Windows in esecuzione sul computer.

Se Exchange Server Analyzer rileva che il seguente criterio è vero, verrà visualizzato un avviso:

  • Il valore dell'attributo purportedSearch del criterio destinatario contiene homeMdb.

  • Il livello operativo dell'insieme di strutture di Active Directory è Windows Server 2003 modalità provvisoria o Windows Server 2003 modalità nativa.

  • Sul computer Exchange Server non è in esecuzione Windows Small Business Server 2003.

Questo avviso indica che l'insieme di strutture di Active Directory è stato preparato per Windows Server 2003. Per evitare problemi di contrassegno dell'indirizzo di posta elettronica quando l'insieme di strutture viene aggiornato al livello operativo completo di Windows Server 2003, sarà necessario apportare una modifica ai criteri destinatari. Il criterio destinatario interessato viene specificato nel file di output di Exchange Server Analyzer.

Se Windows Server 2003 viene utilizzato come controller di dominio e i criteri destinatario non sono aggiornati, la funzione di replica del valore collegato in Windows Server 2003 provocherà la scrittura errata degli indirizzi di posta elettronica dei nuovi utenti da parte del Servizio aggiornamento destinatari. È possibile che il Servizio aggiornamento destinatari rilevi l'utente per la prima volta durante la replica di mailnickname e la replica di homeMDB, a causa della replica del valore collegato. Pertanto, l'utente è soggetto ai criteri predefiniti anziché ai criteri basati su homeMDB. Dopo qualche minuto, quando viene replicato homeMDB, l'utente è soggetto al criterio homeMDB. Tuttavia, l'utente è già in possesso di indirizzi che soddisfano i criteri predefiniti.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Destinatari, selezionare Criteri destinatari, fare clic con il pulsante destro del mouse su RecipientPolicyName e scegliere Proprietà.

  3. Nella pagina RecipientPolicyName Properties nella scheda Generale in Regole filtri fare clic su Modifica.

  4. Dal menu Trova destinatari Exchange scegliere Ricerca personalizzata. Se il criterio destinatario è stato creato in origine da una ricerca personalizzata, verrà visualizzata la pagina Torva ricerca personalizzata dopo aver fatto clic su Modifica al Passaggio 3.

  5. Modificare la query LDAP in modo che l'attributo homeMdb non venga utilizzato come parte delle condizioni del filtro. Attributi quali extensionAttribute, msExchHomeServerName oppure UPN sono argomenti validi che potrebbero consentire di ottenere lo stesso risultato di ricerca.

  6. Fare clic su OK per salvare la modifica e chiudere Gestore di sistema di Exchange.


Richiesta la modifica del filtro di ricerca per il criterio destinatario
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo purportedSearch per ciascun oggetto criterio destinatario di Exchange. L'attributo purportedSearch indica l'argomento di ricerca utilizzato quando si applica il criterio.

Exchange Server Analyzer Tool esegue inoltre una query in Active Directory per determinare il valore dell'attributo msDS-Behavior-Version dell'oggetto dell'insieme di strutture Impostazioni NTDS di Active Directory. Questo valore indica il livello di funzionalità dell'insieme di strutture di Active Directory. I valori validi per l'attributo msDS-Behavior-Version sono elencati nella seguente tabella.

Valore | Livello di funzionalità dell'insieme di strutture
0 | Windows® 2000 Server modalità mista
1 | Windows Server™ 2003 modalità provvisoria
2 | Windows Server 2003 modalità nativa

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il valore dell'attributo revision del contenitore Windows2003Update. Il valore di questo attributo indica se lo strumento di preparazione di Active Directory (ADPrep.exe) è stato eseguito.

Infine, Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore della chiave OSProductSuite indica la versione di Windows in esecuzione sul computer.

Se Exchange Server Analyzer rileva che i criteri seguenti sono veri, verrà visualizzato un avviso:

  • Il valore dell'attributo purportedSearch del criterio destinatario contiene (homeMdb=).

  • Il livello operativo dell'insieme di strutture di Active Directory è Windows 2000 Server modalità mista.

  • L'insieme di strutture di Active Directory è stato preparato per i controller di dominio di Windows Server 2003.

  • Sul computer Exchange Server non è in esecuzione Windows Small Business Server 2003.

Questo avviso indica che l'insieme di strutture di Active Directory è stato preparato per Windows Server 2003. Per evitare problemi di contrassegno dell'indirizzo di posta elettronica quando l'insieme di strutture Active Directory viene aggiornato al livello operativo completo di Windows Server 2003, sarà necessario apportare una modifica ai criteri destinatari. Il criterio destinatario interessato viene specificato nel file di output di Exchange Server Analyzer.

Se Windows Server 2003 viene utilizzato come controller di dominio e il criterio destinatari non viene aggiornato, la funzione di replica del valore collegato in Windows Server 2003 provocherà la scrittura errata degli indirizzi di posta dei nuovi utenti da parte del Servizio aggiornamento destinatari.

A causa della replica del valore collegato, il Servizio aggiornamento destinatari potrebbe rilevare un nuovo utente per la prima volta tra il tempo di replica di mailnickname e il tempo di replica di homeMdb. Pertanto, l'utente è soggetto ai criteri predefiniti anziché ai criteri basati su homeMdb. Dopo qualche minuto, quando viene replicato homeMdb, l'utente è soggetto al criterio homeMdb. Tuttavia, l'utente è già in possesso di indirizzi che soddisfano i criteri predefiniti.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Destinatari, selezionare Criteri destinatari, fare clic con il pulsante destro del mouse su RecipientPolicyName e scegliere Proprietà.

  3. Nella pagina RecipientPolicyName Properties nella scheda Generale in Regole filtri fare clic su Modifica.

  4. Dal menu Trova destinatari Exchange scegliere Ricerca personalizzata. Se il criterio destinatario è stato creato in origine da una ricerca personalizzata, verrà visualizzata la pagina Trova ricerca personalizzata dopo aver fatto clic su Modifica al Passaggio 3.

  5. Modificare la query LDAP (Lightweight Directory Access Protocol) in modo che l'attributo homeMdb non venga utilizzato come parte della condizione di filtro. Attributi quali extensionAttribute, msExchHomeServerName o UPN sono argomenti validi che potrebbero consentire di raggiungere lo stesso risultato di ricerca.

  6. Fare clic su OK due volte per salvare la modifica, quindi chiudere Gestore di sistema di Exchange.


L'ID mittente non è configurato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-05-10

Microsoft Exchange Best Practices Analyzer Tool utilizza il seguente cmdlet di Exchange Management Shell per eseguire una query sui valori delle proprietà Enabled e ExternalMailEnabled dell'oggetto SenderIdConfig per tutti i ruoli server Trasporto Edge o Trasporto Hub di Exchange Server 2007 di destinazione.

Copia codice
- get-SenderIdConfig

Il valore della proprietà Enabled specifica se l'agente dell'ID mittente è abilitato. L'input valido per il parametro Enabled è $true o $false. L'impostazione predefinita è $true. Se il parametro Enabled è impostato su $true, l'agente dell'ID mittente è abilitato.

Il valore della proprietà ExternalMailEnabled indica se tutti i messaggi provenienti da connessioni non autenticate possono attraversare l'agente dell'ID mittente e venire elaborati. L'input valido per il parametro ExternalMailEnabled è $true o $false. L'impostazione predefinita è $true. Se il parametro ExternalMailEnabled è impostato su $true, tutti i messaggi provenienti da connessioni non autenticate possono attraversare l'agente dell'ID mittente e venire elaborati.

Se Exchange Best Practices Analyzer rileva che i valori dell'oggetto SenderIdConfig o delle proprietà Enabled o ExternalMailEnabled non sono impostati su $true, visualizzerà un messaggio di configurazione ottimale.

Questo messaggio indica che l'ID mittente non è abilitato nei ruoli server Trasporto Edge o Trasporto Hub di Exchange 2007 di destinazione.

ID mittente cerca di verificare che ciascun messaggio di posta elettronica provenga effettivamente dal dominio Internet dichiarato.

Se ID mittente è abilitato su un computer, verranno filtrati tutti i messaggi provenienti dai connettori di ricezione disponibili su tale computer. Vengono filtrati solo i messaggi provenienti da origini esterne. Le origini esterne vengono definite come origini non autenticate. e considerate come origini anonime di Internet.

Per risolvere questo problema, abilitare ID mittente sui ruoli server Trasporto Edge o Trasporto Hub di Exchange 2007 di destinazione.

Per utilizzare Exchange Management Shell allo scopo di abilitare la funzionalità ID mittente

  • Per abilitare il filtro mittente, eseguire il seguente comando:

    Copia codice
    Set-SenderIdConfig -Enabled $true -ExternalMailEnabled $true

Per ulteriori informazioni su ID mittente, consultare i seguenti argomenti:

  • Home page di ID mittente all'indirizzo http://go.microsoft.com/fwlink/?linkid=50977

  • ID mittente di Exchange 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89719

  • Configurazione di ID mittente all'indirizzo http://go.microsoft.com/fwlink/?LinkId=89720


Maiuscole/minuscole del nome server non corrispondenti
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore archiviato in Active Directory per il nome del server di Exchange (CN=<ExchangeServerName>). Dopo aver recuperato questo nome, Exchange Server Analyzer conta il numero di caratteri in esso contenuti.

Exchange Server Analyzer legge inoltre la seguente voce del Registro di sistema per determinare il valore archiviato nel Registro di sistema del computer Exchange Server per il nome host del server di Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per ClusSvc, il servizio cluster di Windows®.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione non predefinita:

  • Il valore per CN=<ExchangeServerName> non corrisponde al valore in Hostname. Ad esempio, CN=ComputerName and Hostname viene impostato su COMPUTERNAME.

    Nota:
    Anche se è supportata, la modifica del carattere del nome del server nel Registro di sistema non è consigliata.
  • Il nome del server di Exchange contiene 15 caratteri o meno.

  • Il server di Exchange non è in esecuzione in un cluster Windows.

La causa più comune di questo errore è rappresentata dalla modifica manuale nel Registro di sistema del nome del server di Exchange.


Nome server non corrispondente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'impostazione del valore This Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo name di ciascun oggetto server di Exchange.

Infine, esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster di Windows (ClusSvc). Il valore TRUE indica che il servizio cluster è avviato, mentre il valore FALSE indica che non è in esecuzione.

Se Exchange Server Analyzer rileva che il valore per la chiave This Server non corrisponde al valore per l'attributo name dell'oggetto server in Active Directory per qualsiasi computer di Exchange Server non eseguito in un cluster di server, verrà visualizzato un messaggio di errore.

Per correggere questo errore, è necessario modificare la chiave This Server del Registro di sistema affinché corrisponda al valore dell'attributo name in Active Directory.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. Nel riquadro destro fare doppio clic su This Server, immettere il nome corretto del computer e fare clic su OK.

  4. Uscire dall'editor del Registro di sistema e riavviare il computer Exchange Server per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Nome server troppo lungo
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-22

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il nome (cn) di ciascun oggetto directory con una classe oggetto msExchExchangeServer. Il valore cn rappresenta una stringa contenente il nome breve del computer che esegue Exchange Server. Exchange Server Analyzer recupera il valore cn e determina la lunghezza della stringa. Quest'ultima è data dal numero di caratteri presenti nel nome server di Exchange. Se Exchange Server Analyzer determina che il nome server di Exchange supera i 15 caratteri, verrà visualizzato un messaggio di errore.

Exchange Server 2007, Exchange Server 2003 ed Exchange 2000 Server presentano diverse dipendenze NetBIOS che possono richiedere l'utilizzo della risoluzione dei nomi NetBIOS in differenti subnet per il corretto funzionamento di tutti i componenti di Exchange, a seconda della topologia di rete. La convenzione di denominazione NetBIOS consente la presenza di 16 caratteri in un nome NetBIOS. Microsoft, invece, limita i nomi NetBIOS a 15 caratteri e utilizza il sedicesimo come suffisso NetBIOS.

Poiché Exchange Server presenta dipendenze NetBIOS e i nomi NetBIOS non possono superare i 15 caratteri, i nomi server che superano questo limite non sono supportati in un'organizzazione di Exchange. Inoltre, a causa degli effetti estesi che la ridenominazione di un computer Exchange Server può produrre in tutta l'organizzazione di Exchange e Active Directory, questa operazione non è supportata.

Per risolvere il problema

  1. Rimuovere il computer Exchange Server denominato in modo non corretto mediante l'opzione Rimuovi.

  2. Rinominare il computer con un nome di 15 caratteri o meno.

  3. Reinstallare Exchange Server nel computer.

Per informazioni sulla rimozione di Exchange Server 2007, vedere "Come rimuovere completamente Exchange 2007 da un server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=79246 nella documentazione sulla distribuzione di Microsoft Exchange Server 2007.

Per ulteriori informazioni sulla rimozione di Exchange Server 2003, consultare il capitolo "Disinstallazione di Exchange 2003" del Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 833396, "Rimozione manuale di Exchange Server 2003 dal computer" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=833396.

  • 260378, "XADM: Rimozione manuale di un'installazione di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260378.

  • 328810, "Spostamento delle cassette postali tra server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

  • 821829, "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.


L'indirizzo di rete RPC del server non corrisponde al nome del server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo networkAddress per ogni oggetto Exchange Server della directory. Generalmente esistono varie voci elencate per questo attributo multistringa, come illustrato dai seguenti esempi:

ncacn_ip_tcp:<nome completo del dominio di Exchange Server>

ncacn_np:<nome host di Exchange Server>

ncacn_spx:<nome host di Exchange Server>

ncacn_vns_spp:<nome host di Exchange Server>

ncalrpc:<nome host di Exchange Server>

netbios:<nome host di Exchange Server>

Microsoft® Exchange Server Analyzer Tool esegue inoltre query nel servizio directory di Active Directory® per determinare il valore dell'attributo name per ciascun oggetto di Exchange Server.

Se Exchange Server Analyzer rileva che il valore dell'attributo name non corrisponde alla parte di nome di una qualsiasi delle stringhe rilevate nell'attributo networkAddress, verrà visualizzato un messaggio di errore.

Questo errore può verificarsi se un amministratore ha modificato manualmente il valore cn dell'oggetto server. L'attributo networkAddress viene creato e gestito da Exchange Server e contiene valori multistringa per il supporto dei diversi protocolli di comunicazione di rete supportati da Exchange Server. Ogni valore associa un protocollo con il formato appropriato del nome del server come richiesto dal particolare protocollo.

Per correggere questo errore, verificare se il nome del server è stato modificato o se il valore non è valido e adottare le misure appropriate:

  • Se il nome del server è stato modificato, utilizzare la procedura descritta più avanti per correggere i valori in modo appropriato.

  • Se i valori non sono validi per altri motivi, eseguire nuovamente il programma di installazione di Exchange Setup sul server.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto gruppo amministrativo in Active Directory.

    L'attributo networkAddress è reperibile in:

    CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=NomeOrganizzazione, CN=Administrative Groups, CN=Nome Gruppo Amministrativo, CN=Servers, CN=Nome Server

  2. Notare il formato di ogni valore nell'elenco. Aggiornare i valori nel modo necessario modificando solo la parte corrispondente al nome del server in ciascun valore.

    Nota:
    Assicurarsi che, per il valore ncacn_ip_tcp, il nome del server presenti il formato di un nome di dominio completo, non un nome NetBIOS o un indirizzo di protocollo Internet.

  3. Chiudere l'editor di Active Directory e riavviare il servizio Microsoft Exchange - Motore di routing.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sui problemi di routing di Exchange, consultare "Risoluzione dei problemi di routing" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Nome principale di servizio mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-08-14

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per identificare i valori restituiti per l'attributo servicePrincipalName degli account del computer Exchange Server per le risorse di Exchange elencate nella tabella seguente.

Valore servicePrincipalName della risorsa di Exchange | Valore previsto restituito
exchangeMDB | Nome di dominio completo (FQDN, Fully Qualified Domain Name)
exchangeMDB | Nome NetBIOS
exchangeRFR | Nome di dominio completo (FQDN, Fully Qualified Domain Name)
exchangeRFR | Nome NetBIOS
SMTP | Nome di dominio completo (FQDN, Fully Qualified Domain Name)
SMTP | Nome NetBIOS
SMTPSVC | Nome di dominio completo (FQDN, Fully Qualified Domain Name)
SMTPSVC | Nome NetBIOS
HOST | Nome di dominio completo (FQDN, Fully Qualified Domain Name)
HOST | Nome NetBIOS

Se Exchange Server Analyzer rileva che nell'attributo servicePrincipalName per l'account del computer di una risorsa di Exchange manca uno dei valori previsti qui elencati, verrà visualizzato un messaggio di errore.

Un nome principale di servizio (SPN, Service Principal Name) è un nome univoco che identifica l'istanza di un servizio ed è associato all'account di accesso in cui viene eseguita l'istanza del servizio. L'autenticazione Kerberos non è possibile per i servizi di Exchange senza nomi principali di servizio impostati correttamente.

  • Problemi di autenticazione tra i client che eseguono Microsoft Office Outlook® 2003 o versioni successive e l'Archivio informazioni di Exchange (dati delle cassette postali) possono indicare la mancanza di un nome principale di servizio valido per la risorsa di exchangeMDB.

  • I client Outlook 2003 o versioni successive con problemi di autenticazione di Active Directory possono indicare la mancanza di un nome principale di servizio valido per la risorsa di exchangeRFR.

  • Errori di autenticazione tra i server virtuali SMTP (Simple Mail Transport Protocol) possono indicare la mancanza di un nome principale di servizio valido per la risorsa di SMTPSVC o HOST.

Per risolvere il problema, seguire i passaggi riportati di seguito per aggiungere i valori mancanti per gli attributi interessati.

Utilizzare lo strumento SETSPN.exe per aggiungere un nome principale di servizio ai valori mancanti

  1. Installare lo strumento Setspn.exe. Per ottenere lo strumento Setspn.exe, vedere "Windows 2000 Resource Kit Tool : Setspn.exe" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=28103 (informazioni in lingua inglese).

    La versione di Windows Server 2003 dello strumento con riga di comando Setspn.exe è disponibile con gli strumenti di supporto di Windows Server 2003 inclusi nel CD di Windows Server 2003. Per installare gli strumenti di supporto di Windows Server 2003, fare doppio clic sul file Suptools.msi nella cartella Support/Tools.

  2. Seguire le informazioni aggiuntive del file SETSPN.EXE Setspn_d.txt per aggiungere il valore mancante all'oggetto Active Directory per il server di Exchange. Nell'esempio seguente viene illustrata l'aggiunta del valore del nome di dominio completo per un nome principale di servizio del server SMTP virtuale:

    • Avviare un prompt dei comandi, quindi passare alla directory in cui è installato Setspn.exe.

    • Al prompt dei comandi, digitare il seguente comando:

      setspn.exe -a SMTPSVC/ mail.yourdomain.com YOURSERVERNAME

      Nota:
      Sostiuire mail.yourdomain.com con il nome di dominio completo del server virtuale SMTP e YOURSERVERNAME con il nome del server di Exchange.
      Premere Invio.


Interruzione imprevista di un servizio nelle ultime 24 ore
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-14

Lo strumento Microsoft Exchange Analyzer interroga la classe di Strumentazione gestione Windows (WMI) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un avviso di evento 7031 per l'origine di Gestione controllo servizi.

Un avviso di evento 7031 indica che è impossibile continuare il servizio specificato. Il servizio è configurato per la segnalazione del numero di errori e, dopo un numero specifico di errori segnalati, la Gestione controllo servizi eseguirà l'operazione di recupero configurata per il servizio specificato.

Se Exchange Analyzer rileva che uno o più di tali eventi sono stati registrati nelle ultime 24 ore, verrà visualizzato un messaggio informativo.

Il problema potrebbe avere varie cause. Le più comuni sono riportate di seguito:

  • È in corso l'elaborazione di un messaggio danneggiato.

  • Problemi di configurazione dell'applicazione antivirus.

Per risolvere il problema:

  • Seguire le istruzioni riportate nell'articolo 286350 della Microsoft Knowledge Base, "How to use ADPlus to troubleshoot "hangs" and "crashes", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=286350 per isolare la causa di un processo che cessa di rispondere (blocco) o si interrompe in modo imprevisto (arresto anomalo).

  • Richiedere il Service Pack più recente per Microsoft Windows 2000.

  • Richiedere il Service Pack più recente per Microsoft Exchange Server.

  • Contrattare il fornitore dell'applicazione antivirus per richiedere gli aggiornamenti e le informazioni di configurazione più recenti.

Per ulteriori informazioni

Per ulteriori informazioni sull'avviso di evento 7031, vedere "Events and Errors Message Center: Event Details" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83114 (informazioni in lingua inglese).

Per ulteriori informazioni su come richiedere il Service Pack più recente per Windows 2000 Server, consultare l'articolo della Microsoft Knowledge Base 260910, "How to obtain the latest Windows 2000 service pack", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260910.

Per ulteriori informazioni su come richiedere il Service Pack più recente per Exchange 2000 Server, consultare l'articolo della Microsoft Knowledge Base 301378, "How to obtain the latest Exchange 2000 Server service pack" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=301378.

Per ulteriori informazioni su come richiedere il Service Pack più recente per Exchange Server 2003, vedere l'articolo "Why Try Service Pack 2 for Exchange Server 2003?" (all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073 (informazioni in lingua inglese).

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange and antivirus software" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Overview of Exchange Server 2003 and antivirus software" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Microsoft's Position on Antivirus Solutions for Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Recommendations for troubleshooting an Exchange Server computer that has antivirus software installed" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terze parti disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226.


Services Value is Missing or Inaccessible
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-07-24

Microsoft Exchange Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'esistenza del valore del tipo di stringa Services:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup

Se Exchange Analyzer rileva che il valore del tipo di stringa Services è mancante o inaccessibile, verrà visualizzato un messaggio di errore.

Il messaggio di errore indica che il valore del tipo di stringa Services, utilizzato per contenere il percorso della directory radice di installazione di Exchange, è mancante o inaccessibile. L'assenza del percorso della directory radice di installazione di Exchange può impedire l'inizializzazione dei driver e dei protocolli critici con conseguenti errori dei servizi di archivio informazioni e dei servizi dipendenti di Exchange al momento dell'avvio.

Per risolvere il problema, seguire le istruzioni riportate nell'articolo 285116 della Microsoft Knowledge Base "L'archivio Exchange non viene avviato: errori 7024, 1026, 9542 e 5000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=285116.


Rilevata singola replica dei dati di disponibilità
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_PublicFolder, all'interno dello spazio dei nomi root\MicrosoftExchangeV2, per determinare il numero di repliche dei dati di disponibilità presenti in ogni gruppo amministrativo.

Se Exchange Server Analyzer rileva che esiste una sola replica in un gruppo amministrativo, verrà visualizzato un messaggio di configurazione ottimale.

In genere è consigliabile la presenza di più repliche della cartella relativa alla disponibilità in ogni gruppo amministrativo. In alcuni casi l'esistenza di più repliche dei dati di disponibilità produce un incremento delle prestazioni e della capacità di recupero. Nelle organizzazioni di Exchange di grandi dimensioni la presenza di una sola replica può causare problemi di sovraccarico. In generale, in tutte le organizzazioni di Exchange, un'unica replica dei dati di disponibilità rappresenta un singolo punto di errore.

L'utilizzo di più repliche è preferibile nonostante le seguenti considerazioni:

  • La presenza di più repliche può determinare un ulteriore incremento del traffico sulla rete.

  • Il rischio di conflitti di pianificazione aumenta se le repliche sono più di una.

È necessario disporre di almeno una replica per ogni 10.000 cassette postali.

Per ulteriori informazioni sulle cartelle relative alla disponibilità e sulla pubblicazione di informazioni sulla disponibilità, consultare "Working with Exchange Server 2003 Stores" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).


Rilevamento di una sola replica di diponibilità per un numero elevato di cassette postali
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_PublicFolder nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il numero delle voci per la chiave ReplicaList. Il numero delle voci rappresenta il numero di repliche di disponibilità presenti in ciascun gruppo amministrativo.

Exchange Server Analyzer esegue query nel servizio directory di Active Directory® per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se viene rilevata la presenza di una sola replica di disponibilità in un gruppo amministrativo contenente più di 10.000 caselle postali, verrà visualizzato un messaggio di errore.

In genere è consigliabile che siano presenti più repliche della cartella di disponobilità per ogni gruppo amministrativo. Talvolta la presenza di più repliche della disponibilità può contribuire a migliorare le prestazioni e la resilienza. In organizzazioni Exchange di grandi dimensioni una singola replica dei dati di disponibilità potrebbe diventare sovraccarica. In tutte le organizzazioni Exchange una singola replica dei dati di disponibilità rappresenta un singolo punto di errore.

Si consiglia di utilizzare più repliche nonostante le seguenti considerazioni:

  • Le repliche multiple causano un traffico di replica aggiuntivo sulla rete.

  • Il rischio di conflitti della pianificazione aumenta con le repliche multiple.

Deve essere presente almeno una replica ogni 10.000 caselle postali.

Per ulteriori informazioni sulle cartelle di disponibilità e sulla pubblicazione di informazioni sulla disponibilità, consultare l'articolo "Working with Exchange Server 2003 Stores" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).


Nella topologia è presente un singolo catalogo globale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_DSAccess, nello spazio dei nomi root\MicrosoftExchangeV2, per determinare il server di catalogo globale presenti nella topologia. Il numero di server di catalogo globale viene determinato contando il numero di voci per la chiave WMI DSAccessNameGC. Se Exchange Server Analyzer rileva la presenza di un solo server di catalogo globale nella topologia, verrà visualizzato un messaggio di configurazione ottimale.

Per la tolleranza d'errore è consigliabile la presenza di almeno due server di catalogo globale disponibili per soddisfare i server e gli utenti di Exchange. Un unico server di catalogo globale rappresenta un singolo punto di errore. Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007 dipendono dai server di catalogo globale per una serie di funzioni. Se un server di catalogo globale non è disponibile, il recapito della posta può rallentare o interrompersi completamente. Inoltre, se un server di catalogo globale non è disponibile, i servizi di Exchange Server potrebbero non essere avviati. Se i servizi di Exchange Server non vengono avviati, gli utenti non possono accedere alle rispettive cassette postali.

Per motivi di scalabilità e di tolleranza dell'errore è consigliabile configurare almeno due server di catalogo globale in ogni sito del servizio directory di Active Directory. Se un sito occupa più domini, è consigliabile configurare un catalogo globale per ogni dominio in cui risiedono computer Exchange 2000 Server o Exchange Server 2003 oppure computer e client Exchange Server 2007. Inoltre, è consigliabile distribuire un server di catalogo globale ogni quattro processori di computer Exchange Server.

Per ulteriori informazioni sulla creazione di server di catalogo globale aggiuntivi, consultare l'articolo 313994 della Microsoft Knowledge Base "HOW TO: Creare o spostare un catalogo globale in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994.

Per ulteriori informazioni sul posizionamento e la disponibilità di server di catalogo globale in relazione a Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 875427, "Posizionamento e disponibilità dei server di catalogo globale in un'organizzazione Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427.

  • 322801, "Il Supervisore sistema di Exchange non si avvia e viene visualizzato il messaggio di errore "Nessuna risposta dai server di catalogo globale"" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322801.

  • 829361, "Il computer Exchange Server 2003 impiega più tempo del previsto per arrestarsi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829361.

  • 304403, "Considerazioni sulla promozione di un controller di dominio a server di catalogo globale in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=304403.

  • 305065, "Considerazioni sull'abbassamento di livello di un catalogo globale a controller di dominio in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=305065.


Server della cartella sito eliminato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-01

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo siteFolderServer per ciascun oggetto gruppo amministrativo. Se Exchange Server Analyzer rileva che il valore dell'attributo siteFolderServer contiene la stringa DEL:, verrà visualizzato un messaggio di errore.

L'attributo siteFolderServer rappresenta il nome distinto (DN, Distinguished Name) dell'archivio delle cartelle pubbliche che ospita le cartelle del sito (normalmente è il primo server nel sito o nel gruppo amministrativo).

Per impostazione predefinita, il server della cartella sito è il primo server installato nel gruppo amministrativo. L'archivio delle cartelle pubbliche in questo server è la posizione predefinita delle cartelle relative alla disponibilità e delle cartelle della rubrica non in linea per il gruppo amministrativo. Se si rimuove o non si concede l'autorizzazione al suddetto server senza replicare le cartelle in un altro server e designare questo come server della rubrica non in linea, si verificheranno problemi per gli utenti di Microsoft Office Outlook® 2003 con la rubrica non in linea e i dati di disponibilità.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Individuare l'archivio informazioni delle cartelle pubbliche che si desidera designare come server della cartella sito, espandendo i seguenti nodi del contenitore della configurazione:

    CN=Configuration,DC=<NomeDominio>,DC=com, CN=Services, CN=Microsoft Exchange, CN=<NomeOrganizzazione>, CN=Administrative Groups, CN=<NomeGruppoAmministrativo> CN=Servers, CN=<NomeServer>, CN=InformationStore, CN=<NomeGruppoDiArchiviazione>

  3. Nel riquadro destro fare clic con il pulsante destro del mouse su CN=<NomeArchivioCartellePubbliche>, quindi scegliere Proprietà.

  4. Nel campo Attributi scorrere verso il basso e selezionare l'attributo distinguishedName.

  5. Fare clic su Modifica, quindi copiare l'intero attributo negli Appunti.

  6. Espandere il contenitore della configurazione, quindi espandere CN=Configuration,CN=<NomeDominio>,CN=com, CN=Services, CN=Microsoft Exchange, CN=<NomeOrganizzazione>, CN=Administrative Groups

  7. Fare clic con il pulsante destro del mouse sul gruppo amministrativo che si desidera modificare, quindi selezionare Proprietà.

  8. Nel campo Attributi scorrere verso il basso e selezionare l'attributo siteFolderServer.

  9. Fare clic su Modifica, quindi incollare il valore dell'attributo distinguishedName nel campo Valore.

  10. Fare doppio clic sul contenuto del campo Valore per assicurarsi che l'operazione Incolla sia stata eseguita correttamente, quindi scegliere OK per salvare le modifiche.

  11. Fare clic su OK per chiudere la finestra delle proprietà del gruppo amministrativo.

  12. Per rendere effettiva la modifica, uscire dall'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange Server in tutti i computer Exchange Server del sito.

Per ulteriori informazioni sulla ricreazione di cartelle di sistema e la reimpostazione del server della cartella sito, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822444, "Reimpostazione di una cartella sito in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822444.

  • 275171, "Reimpostazione delle cartelle di sistema su Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=275171.

  • 284200, "La cartella di sistema Schedule+ Free/Busy è mancante" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=284200.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


Chiamate servizio directory di Active Directory lente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-14

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi del componente del servizio directory di Directory Active Directory® il cui tempo di risposta supera 2,5 secondi.

Gli eventi del componente Active Directory del registro FCL di Exchange rappresentano chiamate di funzione del servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente Active Directory.

Active Directory fornisce tutte le informazioni sulle casette postali, i servizi elenco di indirizzi e altre informazioni relative ai destinatari. La maggior parte delle informazioni sulla configurazione di Microsoft Exchange Server 2003 è salvata anche in Active Directory.

Microsoft Exchange Server gestisce le informazioni sull'accesso salvate in Active Directory e le scrive su Active Directory.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file FCL eventi con un tempo di risposta alle chiamate di funzione Active Directory del servizio Archivio informazioni di Microsoft Exchange (Store.exe) superiore a 2,5 secondi, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le cause alla base delle chiamate ad Active Directory del servizio Archivio informazioni di Microsoft Exchange di più di 2,5 secondi di durata possono essere le seguenti:

  • Latenza di rete tra il server di Exchange e il controller di dominio.

  • Configurazione statica o comunque non corretta di DSAccess.

  • Sovraccarico del controller di dominio e del catalogo globale.

  • Progettazione non corretta della topologia di Active Directory.

Per risolvere il problema, procedere come segue:

  • Eseguire Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi del server. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Verificare le prestazioni dei server dei controller di dominio di Active Directory.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sulle prestazioni di Exchange e DSAccess, vedere l'articolo 250570 della Knowledge Base "Rilevamento di servizio di directory di server e l'utilizzo DSAccess" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=250570.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.

Per ulteriori informazioni sulle prestazioni del controller di dominio, vedere le seguenti risorse per Windows Server:

  • "Pianificazione della capacità del controller di dominio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70191 (in inglese).

  • "Monitoraggio Active Directory dei controller di dominio" in Manuale di installazione e pianificazione Active Directory per Windows 2000 Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70193 (in inglese).


Chiamate ESE lente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi del componente ESE (Extensible Storage Engine) di Exchange il cui tempo di risposta supera 2,5 secondi.

Gli eventi del componente ESE nel registro FCL di Exchange rappresentano le chiamate di funzione del servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente ESE.

L'Archivio informazioni di Microsoft Exchange presiede a un database ESE. ESE è un modulo di gestione di database sofisticato basato su transazioni. Una transazione consiste in una serie di operazioni trattate come un unico elemento indivisibile. Tutte le operazioni all'interno di una transazione sono completate o permanentemente salvate, oppure nessuna di esse viene eseguita.

Microsoft Exchange Server utilizza ESE come modulo di gestione di database incorporato che determina la struttura del database e gestisce la memoria. Il modulo di gestione di database memorizza nella cache i database in memoria trasferendo blocchi di dati (pagine) composti da 4 KB in ingresso e in uscita. Aggiorna le pagine in memoria e riscrive sul disco quelle nuove o aggiornate. Quando il sistema riceve le richieste, il modulo di gestione di database memorizza nel buffer i dati in memoria. Pertanto, non accede sempre al disco.

La memorizzazione nella cache dei dati in memoria è il metodo più rapido ed efficace per elaborare i dati. Tuttavia, durante l'esecuzione di Microsoft Exchange, le informazioni su disco non sono mai completamente aggiornate, benché il disco del registro delle transazioni venga sempre aggiornato con le informazioni relative a ciascuna transazione. Il database e la memoria non sono comunque sincronizzati, poiché molte modifiche non sono ancora memorizzate sul disco.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file Store.fcl eventi con un tempo di risposta alle chiamate di funzione del componente ESE del servizio Archivio informazioni di Microsoft Exchange (Store.exe) superiore a 2,5 secondi, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le seguenti condizioni sono alla base delle chiamate ESE:

  • Deframmentazione in linea di Microsoft Exchange.

  • Backup di dati.

    Nota:
    Se il backup dei dati o la deframmentazione in linea erano intenzionalmente in corso durante la raccolta dei dati dal registro delle chiamate di Exchange, il messaggio non indica un problema di prestazioni di Exchange Server e può essere ignorato.
  • Colli di bottiglia nell'unità del database.

Per risolvere il problema, procedere come segue:

  • Si consiglia di non sovrapporre finestre di backup o operazioni di manutenzione in linea negli orari di maggior traffico.

  • Eseguire Microsoft Exchange Server Analyzer Tool per eseguire un'ulteriore analisi del server. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sulla configurazione della finestra oraria per la deframmentazione in linea, vedere l'articolo 244524 della Microsoft Knowledge Base "XADM: Come configurare l'Exchange Server Intervallo di tempo di deframmentazione della linea" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=244524.

Per ulteriori informazioni sui colli di bottiglia nel disco del server di Exchange, vedere Rilevato collo di bottiglia di disco.

Per ulteriori informazioni sul dimensionamento e l'ottimizzazione dei dischi del server di Exchange, vedere "Calcolo dei requisiti di I/O del disco" e "Procedure consigliate comuni a più architetture" in Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=49324.

Per ulteriori informazioni su ESE, vedere "Architettura ESE" all'indirizzo http://go.microsoft.com/fwlink/?linkid=67009.


Chiamate IMAIL lente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-12

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi il cui tempo di risposta supera 2,5 secondi.

Gli eventi del componente IMAIL MAPI del registro FCL di Exchange rappresentano chiamate di funzione del servizio Archivio informazioni di Microsoft Exchange (Store.exe) per la conversione nel formato Internet e dal formato Internet nel formato MAPI.

Il componente IMAIL di Exchange Server è un servizio di conversione flessibile utilizzato dal servizio Archivio informazioni di Microsoft Exchange tra Internet e messaggi MAPI. Ciò consente l'interoperabilità tra i client che utilizzano RFC-822 o il formato Internet e i client che utilizzano il formato di archiviazione interno di Exchange Server, quali i client MAPI o le attività di archiviazione interna.

Exchange utilizza il meccanismo IMAIL per applicare i formati dei messaggi ai contenuti per ogni mittente, secondo quanto definito nei domini Internet del Gestore di sistema di Exchange o specificato dall'utente in Microsoft Office Outlook®. Se IMAIL non riceve informazioni sui parametri di formattazione procederà alla conversione dei messaggi MAPI in formato S/TNEF (Summary TNEF) per il trasferimento tra i vari server.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file Store.fcl eventi con un tempo di risposta alle chiamate di funzione del componente IMAIL del client MAPI del servizio Archivio informazioni di Microsoft Exchange (Store.exe) superiore a 2,5 secondi, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le cause del rallentamento dei tempi di risposta alle chiamate di funzione esterne del servizio Archivio informazioni di Exchange (Store.exe) a MAPI sono le seguenti:

  • Tentativo di IMAIL di elaborare molti dati in un messaggio o allegato.

  • Richiesta di conversione dati da molti client.

  • Tempi di risposta lenti alle richieste di DSAccess.

  • Colli di bottiglia nelle unità TEMP e TMP.

  • Spostamenti di cassette postali in corso.

  • Per risolvere il problema, procedere come segue:

  • Programmare gli spostamenti delle cassette postali in orari di scarso traffico.

  • Avviare Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi al server, quali limitazioni delle dimensioni di messaggi e allegati. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sui colli di bottiglia nel disco del server di Exchange, vedere Rilevato collo di bottiglia di disco.

Per ulteriori informazioni sul dimensionamento e l'ottimizzazione dei dischi del server di Exchange, vedere "Calcolo dei requisiti di I/O del disco" e "Procedure consigliate comuni a più architetture" in Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=49324.

Per ulteriori informazioni sulle limitazioni delle dimensioni dei messaggi consigliate su Exchange Server, vedere La dimensione massima del messaggio in uscita non è stata impostata.


Chiamate LSASS lente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-12-04

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi del componente del processo LSASS (Lsass.exe) il cui tempo di risposta supera 25 millisecondi.

Gli eventi del componente del processo del registro FCL di Exchange rappresentano chiamate di funzione del servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente del processo LSASS (Lsass.exe).

Il processo LSASS (Lsass.exe) è un sottosistema di protezione richiamato da altri processi per la verifica delle informazioni sull'account e la convalida dell'accesso.

All'accesso del client il server di Exchange invia una richiesta di ricerca del rispettivo ID di protezione (SID) account e genera una chiamata all'interno del processo LSASS (Lsass.exe).

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file Store.fcl eventi con un tempo di risposta alle chiamate di funzione al componente LSASS (Lsass.exe) del servizio Archivio informazioni di Microsoft Exchange (Store.exe) superiore a 25 millisecondi, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le cause del rallentamento dei tempi di risposta alle chiamate di funzione esterne del servizio Archivio informazioni di Microsoft Exchange (Store.exe) a LSASS potrebbero essere le seguenti:

  • Problemi alle risorse del server correlati al numero di utenti che si autenticano nello stesso momento.

  • Latenza di rete tra il server di Exchange e il controller di dominio o il server di catalogo globale.

  • Problemi dovuti a colli di bottiglia nelle risorse del server.

Per risolvere il problema, procedere come segue:

  • Implementare il parametro NeverPing come descritto in Parametro "NeverPing" consigliato.

  • Avviare Microsoft Exchange Server Analyzer Tool per un'ulteriore analisi dei problemi al server, quali limitazioni delle dimensioni di messaggi e allegati. È possibile scaricare Microsoft Exchange Server Analyzer Tool da "Microsoft Exchange Server Best Practices Analyzer Tool v2.7" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34705.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sul processo Lsass.exe e l'utilizzo della memoria, vedere l'articolo 308356 della Microsoft Knowledge "Utilizzo della memoria da parte del processo Lsass.exe in controller di dominio basati su Windows 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308356.

Per ulteriori informazioni sui problemi di accesso dei client di Exchange e LSAA, vedere l'articolo 161938 della Microsoft Knowledge Base "Rallentare Accesso Due client di Exchange al blocco critico di risorsa" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=161938.

Per ulteriori informazioni sulla latenza di rete tra server di Exchange e controller di dominio o server di catalogo globale, vedere il seguente blog del team di Microsoft Exchange "Exchange Does Not Always Use Local GCs" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69166 (in inglese).

Nota:
Il contenuto di ciascun blog e il relativo URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni sui colli di bottiglia nelle risorse del server, consultare Collo di bottiglia del processore.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


Chiamate programma antivirus lente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-11

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi del componente VAPI (Virus API) Virusscan il cui tempo di risposta supera 2,5 secondi.

Gli eventi del componente VAPI Virusscan del registro FCL di Exchange rappresentano chiamate di funzione del servizio Archivio informazioni di Microsoft Exchange (Store.exe) a un software antivirus esterno.

Per ottimizzare la risoluzione dei problemi del VAPI, Exchange Server implementa una funzione di registrazione eventi che può essere utilizzata per verificare le prestazioni dell'API antivirus.

Gli eventi registrati comprendono:

  • Caricamento e scaricamento di DLL di fornitori.

  • Analisi completa degli elementi.

  • Virus ubicati nell'Archivio informazioni.

  • Comportamento imprevisto nel VAPI.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file Store.fcl eventi con un tempo di risposta alle chiamate di funzione al software antivirus esterno del servizio Archivio informazioni di Microsoft Exchange (Store.exe) con un tempo di risposta superiore a 2,5 secondi, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Le cause del rallentamento dei tempi di risposta alle chiamate di funzione esterne del servizio Archivio informazioni di Microsoft Exchange (Store.exe) al software antivirus possono essere le seguenti:

  • Aggiornamenti a un programma antivirus che avvia nuove analisi degli elementi dell'Archivio informazioni.

  • Configurazione non corretta del programma antivirus.

  • Il software antivirus elabora messaggi o allegati di grandi dimensioni.

Per risolvere il problema, procedere come segue:

  • Programmare gli aggiornamenti del motore di ricerca virus in orari in cui l'utilizzo delle risorse è basso, ossia negli orari di scarso traffico.

  • Reinstallare il software antivirus, ma negli orari di scarso traffico.

  • Verificare la corretta configurazione di thread, esclusioni file, ecc. del motore di ricerca virus. Vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Consultare gli articoli elencati nella sezione Per ulteriori informazioni di questo documento.

Per ulteriori informazioni

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, vedere l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (in inglese).

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni dell'Archivio informazioni, vedere l'articolo 257725 della Microsoft Knowledge Base "XADM: Come raccogliere i dati diagnostici per la risoluzione Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=257725.


Chiamate snapshot Servizio Copia Shadow del volume lente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-13

Microsoft® Exchange Server Analyzer Tool esamina il registro FCL di Exchange, il file Store.fcl, per verificare la presenza di eventi del componente snapshot Servizio Copia Shadow del volume il cui tempo di risposta supera 20 secondi.

Gli eventi del componente Servizio Copia Shadow del volume del registro FCL di Exchange rappresentano chiamate di funzione del servizio Archivio informazioni di Microsoft Exchange (Store.exe) al componente snapshot Servizio Copia Shadow del volume.

Il Servizio Copia Shadow del volume è un insieme di API COM che implementa una struttura che consente l'esecuzione di backup del volume da eseguire quando le applicazioni di un sistema continuano a scrivere sui volumi.

Microsoft Exchange Server 2003 utilizza il Servizio Copia Shadow del volume incluso nel sistema operativo Microsoft Windows Server™ 2003 per eseguire copie shadow del volume di database e file di registro delle transazioni di Microsoft Exchange Server 2003.

Lo snapshot Servizio Copia Shadow del volume non è completamente indipendente dai dati originali. Generalmente gli snapshot vengono creati quando si definisce un indicatore temporale e assicura che i dati possano essere ripristinati a tale data.

Se Microsoft Exchange Server Analyzer Tool rileva all'interno del file Store.fcl file eventi con un tempo di risposta alle chiamate di funzione al componente Snapshot SS del servizio Archivio informazioni di Microsoft Exchange (Store.exe) superiore a 20 secondi, verrà visualizzato un errore.

Quando le chiamate tra componenti del servizio Archivio informazioni di Microsoft Exchange (Store.exe) restano in attesa di risposta, i thread di chiamata di procedura remota (RPC, remote procedure call) possono sostituire tali richieste, causando problemi di prestazioni di Exchange Server, quali ritardi di risposta ai client.

Nota:
Se uno snapshot Servizio Copia Shadow del volume è stato avviato intenzionalmente entro 20 secondi dalla raccolta dei dati dal registro delle chiamate di Exchange, l'errore non indica un problema di prestazioni a carico di Exchange Server e può essere ignorato.

Si consiglia di non sovrapporre finestre di backup con operazioni di manutenzione in linea o negli orari di maggior traffico di richieste da parte degli utenti.

Per ulteriori informazioni

Per ulteriori informazioni sul Servizio Copia Shadow del volume, vedere "Consigli per l'utilizzo del Servizio Copia Shadow del volume in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56571 (in inglese).


È stato registrato un evento di errore "SMTPSVC" (ID: nelle ultime 24 ore
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-16

Lo strumento Microsoft Exchange Analyzer esegue una query nel metabase IIS per determinare il valore della proprietà LM/SmtpSvc/%SMTPInstance%/ServerState per ciascuna istanza del server virtuale SMTP.

La proprietà ServerState fornisce lo stato corrente dell'istanza del server. Gli stati e i codici corrispondenti possono essere i seguenti: 1 (avvio in corso), 2 (avviata), 3 (arresto in corso), 4 (arrestata), 5 (sospensione in corso), 6 (sospesa) o 7 (ripresa).

Se Exchange Analyzer determina che il valore della proprietà ServerState di un'istanza del server virtuale SMTP non è uguale a 2 (avviata), lo strumento esegue una query nella classe Win32_NTLogEvent di Microsoft Strumentazione gestione Windows (WMI) per determinare se è stato registrato un errore Evento 429 per il servizio SMTP (SMTPSVC) nelle ultime 24 ore.

Se Exchange Analyzer rileva che l'Istanza server virtuale (VSI, Virtual Server Instance) SMTP non è avviata e che è stato registrato almeno un errore Evento 429 per SMTPSVC nelle ultime 24 ore, viene visualizzato un avviso.

L'avviso indica che potrebbero esistere problemi con le directory designate per l'Istanza server virtuale SMTP.

SMTP è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

Se nel computer che esegue Exchange arrivano messaggi tramite il servizio SMTP, i dati vengono scritti sul disco rigido in un file con estensione eml. Per impostazione predefinita, questi file vengono memorizzati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange.

Questo problema può avere una delle seguenti cause:

  • Il percorso di directory <unità>:\Programmi\Exchsrvr\Mailroot o le cartelle contenute in tale percorso sono state spostate, sono mancanti o sono danneggiate.

  • Le autorizzazioni per il percorso <unità>:\Programmi\Exchsrvr\Mailroot o per le cartelle incluse in tale percorso non sono state impostate in modo adeguato.

  • Analisi dell'applicazione antivirus del percorso di directory <unità>:\Programmi\Exchsrvr\Mailroot o delle cartelle incluse in tale percorso.

Per risolvere l'avviso, eseguire uno o più passaggi tra i seguenti:

  • Verificare la posizione e l'integrità del percorso di directory <unità>:\Programmi\Exchsrvr\Mailroot e delle cartelle incluse in tale percorso.

  • Verificare le autorizzazioni del percorso di directory <unità>:\Programmi\Exchsrvr\Mailroot e delle cartelle incluse in tale percorso.

  • Assicurarsi che le applicazioni antivirus non eseguano l'analisi delle cartelle incluse nel percorso di directory <unità>:\Programmi\Exchsrvr\Mailroot.

Per verificare il percorso di directory della directory principale della posta in Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito), quindi scegliere Arresta.

  4. Fare clic di nuovo con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Fare clic sulla scheda Messaggi.

  6. Nel campo Directory della coda verificare il percorso completo della cartella Directory principale della posta appropriata. Per individuare il percorso sul computer locale, fare clic su Sfoglia.

  7. Fare clic su OK per salvare le modifiche.

  8. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start.
Per verificare il percorso di directory della cartella principale della posta su Exchange 2000 Server

  1. Arrestare tutti i servizi Exchange Server e IIS sul computer Exchange 2000 Server di cui si desidera verificare la cartella Directory principale della posta del server virtuale SMTP.

  2. Verificare che il valore del server virtuale SMTP interessato relativo a msExchSmtpQueueDirectory sia configurato con il percorso appropriato.

  3. Attendere in Active Directory la replica della modifica sui server di catalogo globale utilizzati dal server di Exchange.

  4. Avviare il servizio Supervisore sistema di Microsoft Exchange.

  5. Sul computer Exchange Server, verificare nel registro eventi dell'applicazione la presenza di tre istanze dell'ID evento 1005 che presentano l'origine evento MSExchangeMU e la categoria Generale.

  6. Per rendere effettiva la modifica, riavviare il computer Exchange Server.
Per verificare le autorizzazioni predefinite per il percorso di directory della cartella principale della posta su Exchange 2000 Server e Exchange Server 2003

  1. Avviare Esplora risorse, quindi individuare la cartella Exchsvr ed espanderla.

  2. Fare clic con il pulsante destro del mouse sulla cartella Mailroot, quindi scegliere Proprietà.

  3. Fare clic sulla scheda Protezione, quindi verificare le seguenti autorizzazioni predefinite:

Account | Autorizzazioni
Administrators | Controllo completo
Authenticated Users | Lettura ed esecuzione, visualizzazione contenuto cartella, lettura
Creator Owner | Nessuna
Server Operators | Modifica, lettura ed esecuzione, visualizzazione contenuto cartella, lettura
System | Controllo completo
  1. Verificare la presenza delle autorizzazioni predefinite elencate in precedenza per tutte le cartelle per ciascuna Istanza server virtuale.

Per ulteriori informazioni sulle procedure descritte, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 822933, "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933.

  • 318230, "XCON: Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sulla configurazione delle applicazioni di analisi antivirus per l'utilizzo con Exchange, vedere Le esclusioni di cartelle dalla ricerca di virus non sono state configurate.

Per ulteriori informazioni sulla configurazione delle esclusioni dall'analisi RealTime di Symantec AntiVirus Corporate Edition, consultare il sito Web di Symantec all'indirizzo http://www.symantec.com.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sulle modalità di protezione dell'ambiente Exchange Server da virus e worm contenuti nei messaggi di posta elettronica, vedere Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terze parti disponibili per Exchange Server, vedere "Exchange Server 2007 Partners: Antivirus, Antispam" all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Il nome di dominio completo dell'istanza SMTP non corrisponde al nome del server
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory Active Directory® per determinare se il valore della stringa ncacn_ip_tcp: dell'attributo networkAddress dell'oggetto server corrisponde al nome di dominio completo (FQDN, Fully Qualified Domain Name) nell'attributo msExchSmtpFullyQualifiedDomainName dell'oggetto server SMTP.

Se Microsoft Exchange Server Analyzer Tool determina che i valori di questi attributi non corrispondono, verrà visualizzato un avviso.

L'avviso indica che i valori di questi attributi potrebbero essere stati modificati manualmente e contribuire ai problemi di flusso di posta del server.

Il valore dell'attributo msExchSmtpFullyQualifiedDomainName specifica l'FQDN del server virtuale SMTP ed è necessario che sia risolto dal protocollo di rete DNS.

È necessario che per il valore dell'attributo sia presente un record DNS HOST (A) valido affinché i server di messaggistica che cercano di risolvere l'FQDN del server SMTP virtuale possano recuperare l'indirizzo IP corretto e instradare correttamente la posta.

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario, vedere "Aggiunta di un record di risorse a una zona DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63002 (in inglese).

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, vedere i seguenti articoli della Knowledge Base:

  • 266686, "XCON: Come configurare una parte 1 di server virtuale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Come configurare una parte 2 di server virtuale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sul design del servizio SMTP, vedere "Design del servizio SMTP" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=58876.


Lunghezza coda locale SMTP superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Local Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che il contatore Local Queue Length ha superato il valore massimo di 1000 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Il contatore SMTP Server\Local Queue Length indica il numero di messaggi nella coda SMTP (Simple Mail Transfer Protocol) per il recapito locale al servizio Archivio informazioni di Microsoft Exchange. I dati della coda locale SMTP (directory principale della posta) vengono conservati temporaneamente nella periferica di archiviazione durante l'elaborazione da parte di Exchange Server. Questa struttura impedisce la perdita di dati in caso di errori del server. Ad esempio, quando un server di destinazione non è raggiungibile, i messaggi da instradare a tale server verranno archiviati nella directory della coda locale del server fino a quando non potranno essere recapitati.

Questo errore indica un problema di prestazioni o interruzioni del server, in quanto il server non è più in grado di recapitare la posta in arrivo in tempo utile. Il ritardo può essere dovuto alle seguenti condizioni:

  • Il servizio directory di Active Directory® non è stato consultato immediatamente.

  • I messaggi non vengono gestiti immediatamente per il recapito locale o SMTP.

  • I database (archivi delle cassette postali e archivi delle cartelle pubbliche) sono stati disinstallati.

  • Per risolvere il problema, procedere come segue:

  • Assicurarsi che tutti i database (archivi delle cassette postali e archivi delle cartelle pubbliche) siano installati.

  • Identificare l'origine del collo di bottiglia delle prestazioni. Un collo di bottiglia delle prestazioni può verificarsi nella CPU, nel disco, nella rete o nella memoria e può essere causato da un aumento del carico sul server oppure da risorse del server insufficienti. Utilizzare lo strumento Performance Monitor (Perfmon.msc) per determinare se il collo di bottiglia è causato da un maggiore carico sul server o da dimensioni limitate del server. Se il carico sul server è aumentato, identificare e ridurre l'origine del carico. Se le risorse del server sono insufficienti, aumentarle o spostare gli utenti su un altro server.

  • Verificare la presenza di eventuali problemi di prestazioni monitorando le dipendenze esterne, ad esempio il servizio directory di Active Directory, quindi risolvere tali problemi e apportare le correzioni necessarie.

Ulteriori informazioni

  • Per ulteriori informazioni sull'ottimizzazione del trasporto SMTP, consultare l'argomento "Ottimizzazione del trasporto SMTP" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi al flusso di posta, consultare l'articolo 823489 della Microsoft Knowledge Base "Utilizzo del visualizzatore code per la risoluzione dei problemi di flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi al trasporto, consultare l'articolo 257265 della Microsoft Knowledge Base "Risoluzione dei problemi di trasporto per Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore.

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Rilevato collo di bottiglia di disco.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, consultare Spostare le cassette postali degli utenti su un server diverso.


L'oggetto Performance Monitor SMTP Server non è disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Local Queue Length dell'oggetto prestazioni SMTP Server per analizzare i dati delle prestazioni. Se il contatore non restituisce dati validi, viene visualizzato un messaggio di base.

Se il modulo di raccolta dei dati sulle prestazioni non restituisce dati validi, si può verificare una combinazione qualsiasi delle seguenti condizioni:

  • L'oggetto prestazioni SMTP Server è disabilitato.

  • L'oggetto Performance Monitor SMTP Server non è presente oppure è danneggiato.

  • Exchange Server Analyzer non dispone delle autorizzazioni appropriate per accedere agli oggetti prestazione.

Le prime due condizioni possono verificarsi possono verificarsi se il Registro di sistema viene danneggiato da determinati contatori flessibili oppure se viene modificato da programmi basati su Microsoft WMI (Strumentazione gestione Windows®). Nella procedura seguente viene illustrato come correggere le prime due condizioni. Prima di eseguire la procedura, verificare di disporre delle relative autorizzazioni. Per ulteriori informazioni sulle autorizzazioni necessarie per l'esecuzione di Exchange Server Analyzer, consultare la Guida in linea di Exchange Server Analyzer. Per accedere alla Guida aprire Exchange Server Analyzer e premere F1.

Per risolvere il problema

  1. Verificare che l'oggetto prestazioni SMTP Server sia abilitato.

    1. Scaricare e installare lo strumento Extensible Performance Counter List (Exctrlst.exe). È possibile scaricare Exctrlst.exe dalla pagina "Exctrlst.exe: Extensible Performance Counter List" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34436 (informazioni in lingua inglese).

    2. Aprire Exctrlst.exe, fare clic su Sort Order (Ordinamento), quindi su Service (Servizio).

    3. Individuare il servizio per il quale esegue rapporti l'oggetto prestazioni e verificare che la casella di controllo Performance Counters Enabled (Contatori di prestazioni abilitati) sia selezionata.

      In caso contrario, selezionare la casella di controllo Performance Counters Enabled, quindi riavviare il servizio associato ai contatori di prestazioni per verificare che siano operativi. Se non sono operativi oppure se la casella di controllo Performance Counters Enabled è già selezionata, procedere al passaggio 2.

  2. Ricostruire i contatori di prestazione mancanti o danneggiati come specificato nell'articolo 300956 della Microsoft Knowledge Base "Ricreazione manuale dei valori della libreria dei contatori delle prestazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=300956.

  3. Se questo articolo della Knowledge Base non è sufficiente per risolvere il problema, sarà necessario reinstallare Exchange Server in modalità di ripristino e installare i Service Pack più recenti per Exchange Server.


Su SQL Server è in esecuzione Virtual Server 2005 con Exchange Server installato come Guest
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se il valore della chiave Model è impostato su Virtual Machine.

Exchange Server Analyzer controlla inoltre la presenza del seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Inoltre, Exchange Server Analyzer esegue una query nella classe WMI Win32_Services per determinare se il servizio Microsoft SQL Server™ (MSSQLSERVER) è in esecuzione sul computer fisico che esegue Microsoft Virtual Server 2005.

Se Exchange Server Analyzer rileva che la chiave Model contiene la stringa Virtual Machine, che il ramo del Registro di sistema indicato sopra esiste e che MSSQLSERVER è in esecuzione, verrà visualizzato un messaggio di errore.

Il valore Virtual Machine per la chiave Model indica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Virtual Server 2005 o Microsoft Virtual PC 2004. Poiché il ramo del Registro di sistema indicato sopra viene creato esclusivamente da Virtual Server 2005, la sua esistenza implica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Virtual Server 2005.

Microsoft non supporta l'esecuzione di versioni di Microsoft Exchange su una macchina virtuale o un emulatore. Questo vale per Exchange Server in esecuzione su Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 o altri programmi di macchine virtuali di terze parti. Le piattaforme Exchange Server sono state progettate e testate per essere eseguite solo su hardware fisico, in particolare le piattaforme hardware elencate nel catalogo di Windows Server alla pagina http://go.microsoft.com/fwlink/?linkid=17219.

Inoltre, l'esecuzione di Exchange come Guest di server virtuale su un computer che esegue SQL Server non è consigliabile in quanto non consente un'adeguata ridondanza in tutti i servizi.

Per risolvere il problema

  1. Spostare le cassette postali da Exchange Server in esecuzione su Virtual Server 2005 in un computer Exchange Server non virtuale.

  2. Se necessario, spostare le cartelle pubbliche e trasferire i ruoli contenuti dal server virtuale di Exchange.

  3. Disinstallare Exchange dal macchina virtuale per non concedere l'autorizzazione ed eseguire la rimozione dall'infrastruttura di Exchange e dal servizio directory di Active Directory®.

Per ulteriori informazioni sullo spostamento delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.

  • 224975, "XADM: Differenze tra i metodi di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975.

Per ulteriori informazioni sul supporto per i computer Exchange Server che funzionano in ambienti virtuali, consultare l'articolo 320220 della Microsoft Knowledge Base "Limitazioni al supporto per Exchange Server su un macchina virtuale o un emulatore" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

Per ulteriori informazioni su Microsoft Virtual Server 2005, consultare il sito Web "Microsoft Virtual Server 2005" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34938 (informazioni in lingua inglese).

Per ulteriori informazioni su Microsoft Virtual PC 2004, consultare il sito Web "Microsoft Virtual PC 2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34938 (informazioni in lingua inglese).


SRS port is below 5000
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione di TCP/IP per il servizio di replica siti di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Se Exchange Server Analyzer rileva che TCP/IP è impostato su un valore inferiore a 5.000 (decimale), verrà visualizzato un avviso.

Se è necessario impostare TCP/IP su un valore statico, si consiglia di impostarlo su un valore appena superiore a 5000. L'assegnazione di numeri di porta statici inferiori a 5000 potrebbe causare conflitti di porta con altri processi e provocare errori nell'elaborazione del Servizio di replica siti di Microsoft Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave TCP/IP del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Fare doppio clic sulla chiave TCP/IP e impostare il campo Dati valore su un valore intero superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il Servizio di replica siti di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle limitazioni delle porte, consultare l'articolo 194952 della Microsoft Knowledge Base "XADM: Limitazioni nelle porte mappate staticamente in Exchange Server" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=194952)


La porta SRS è stata sostituita manualmente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore della porta per il servizio di replica siti di Microsoft Exchange è stato sostituito manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSRS\Parameters\TCP/IP

Se Exchange Server Analyzer rileva che TCP/IP è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Il motivo più comune per cui questo valore viene configurato è quello di consentire ai client MAPI di connettersi a un server di Exchange situato sull'altro lato di un firewall. Questo scenario implica l'apertura di più porte su un firewall per consentire ai client Microsoft Office Outlook® 2003 di connettersi mediante MAPI a un server di Exchange, in genere tramite Internet. Questa configurazione è supportata. Per ulteriori informazioni sulla configurazione di client MAPI da connettere a Exchange con un firewall, consultare l'articolo 270836 della Microsoft Knowledge Base "Mapping statici delle porte in Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836. Se non si sta utilizzando questo scenario, rimuovere questa chiave del Registro di sistema.

L'implementazione consigliata per l'utilizzo di Outlook in modalità MAPI per connettersi a un server di Exchange tramite Internet, consiste nell'utilizzare le funzioni RPC su HTTP reperibili in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 e Microsoft Windows® XP Professional. La modalità MAPI è stata precedentemente definita come modalità "Corporate" o "Workgroup".

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per rimuovere la voce TCP/IP del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSRS\Parameters

  3. Eliminare il valore del Registro di sistema denominato TCP/IP.

  4. Chiudere l'editor del Registro di sistema, quindi riavviare il Servizio di replica siti di Microsoft Exchange.

Per distribuire RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare l'articolo della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Esaminare "Support WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


L'account di avvio configurato per Supervisore sistema non è supportato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Services per determinare se l'account LocalSystem viene utilizzato dall'account di avvio specificato nella proprietà StartName del servizio Supervisore sistema di Microsoft Exchange (MSExchangeSA). Se Exchange Server Analyzer rileva che il valore della proprietà StartName in un computer Exchange 2000 Server o Exchange Server 2003 corrisponde a un account diverso da LocalSystem, verrà visualizzato un messaggio di errore. L'account LocalSystem è definito anche account SYSTEM.

È necessario avviare MSExchangeSA in Exchange 2000 Server ed Exchange Server 2003 nel contesto di protezione LocalSystem. Non avviare MSExchangeSA associando un account utente specifico. Quando un servizio di Exchange in esecuzione come LocalSystem esegue l'accesso a un server remoto, tale servizio Exchange viene autenticato utilizzando le credenziali dell'account del computer.

Il meccanismo standard per la modifica delle password modifica la password dell'account del computer ogni sette giorni. Modificando la password ogni sette giorni si migliora la protezione dell'account del computer, che risulta più sicuro di un normale account utente per i seguenti motivi:

  • La password di un normale account utente viene modificata con minore frequenza.

  • La password di un normale account utente è meno casuale di quella dell'account di un computer che viene generata in modo casuale.

In Exchange Server 5.5 gli account utente sono utilizzati per i servizi. Alcuni amministratori esperti di Exchange Server 5.5 modificano l'account di avvio dei servizi di Exchange 2000 Server ed Exchange Server 2003 dall'account LocalSystem predefinito a un account utente.

In Exchange 2000 Server ed Exchange Server 2003 Microsoft non supporta l'esecuzione di MSExchangeSA sugli account, ad eccezione dell'account LocalSystem.

Per risolvere il problema

  1. Dal menu Start scegliere Programmi, quindi Strumenti di amministrazione e fare clic su Servizi.

  2. Nell'elenco dei servizi fare clic con il pulsante destro del mouse su Supervisore sistema di Microsoft Exchange, quindi scegliere Proprietà.

  3. Nella scheda Connessione in Accedi come scegliere Account di sistema locale, quindi OK.

  4. Fare clic con il pulsante destro del mouse su Supervisore sistema di Microsoft Exchange e scegliere Riavvia.

Per ulteriori informazioni sui servizi di Exchange, consultare l'articolo 239762 della Microsoft Knowledge base "Esecuzione dei servizi di Exchange in LocalSystem" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


File STORE.EXE mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di una serie di file binari principali di Exchange:

  • Exres.dll

  • Gapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapi32.dll (nella cartella System32 e nella cartella \Exchsrvr\bin)

  • Mapisp32.dll

  • Mapistub.dll

  • Cdo.dll

  • DavEx.dll

  • DSAccess.dll

  • EmsMta.exe

  • Epoxy.dll

  • Ese.dll

  • Eseutil.exe

  • ExCdo.dll

  • ExchMem.dll

  • ExMime.dll

  • ExOleDb.dll

  • ExPop3.dll

  • ExSmtp.dll

  • Mad.exe

  • Mbdsz.dll

  • OabGen.dll

  • PhatCat.dll

  • Phatq.dll

  • Reapi.dll

  • ReSvc.dll

  • Store.exe

Se Exchange Server Analyzer rileva la mancanza di alcuni dei file precedenti, verrà visualizzato un messaggio di errore. Per correggere questo errore, installare il Service Pack o l'aggiornamento cumulativo più recente per la versione in uso di Exchange. Se l'errore persiste, eseguire il programma di installazione di Exchange 2000 Server o di Exchange Server 2003 e scegliere Reinstalla. L'esecuzione del programma di installazione in modalità di reinstallazione consente di installare solo i file binari. Non vengono rimossi o reimpostati dati utente o dati di configurazione. Se si reinstalla Exchange Server, è necessario reinstallare anche eventuali Service Pack o aggiornamenti rapidi di Exchange precedentemente installati.

Per reinstallare Exchange 2000 Server o Exchange Server 2003

  1. Accedere al server nel quale si desidera reinstallare Exchange. Inserire il CD di Exchange 2000 Server o Exchange Server 2003 nell'unità CD-ROM.

  2. Scegliere Esegui dal menu di avvio e digitare <unità>:\setup\i386\setup, dove <unità> è la lettera corrispondente all'unità CD-ROM.

  3. Nella pagina Installazione guidata di Microsoft Exchange fare clic su Avanti.

  4. Leggere il contratto nella pagina Contratto di licenza. Se si accettano i termini contenuti nel contratto, fare clic su Accetto, quindi su Avanti.

  5. Immettere il codice "Product Key" di 25 caratteri nella pagina Numero di serie del prodotto e fare clic su Avanti.

  6. Nella pagina Selezione dei componenti, nella colonna Operazione, utilizzare la freccia a discesa accanto al nodo Microsoft Exchange, scegliere Reinstalla e fare clic su Avanti.

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange Server 2003, consultare la pagina "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sui più recenti Service Pack, aggiornamenti cumulativi e componenti aggiuntivi di Exchange 2000 Server, consultare la pagina "Downloads for Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33457 (informazioni in lingua inglese).


Porta HTTP di archivio inferiore a 5000
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione Rpc/HTTP Port per il servizio Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Se Exchange Server Analyzer rileva che Rpc/HTTP Port è impostato su un valore inferiore a 5000 (decimale), verrà visualizzato un avviso.

La chiave Rpc/HTTP Port del Registro di sistema è impostata su 6001 dal programma di installazione di Exchange Server 2003 ed Exchange Server 2007. La chiave Rpc/HTTP Port del Registro di sistema è utilizzata per supportare la funzionalità RPC su HTTP per Microsoft Office Outlook® 2003 e Microsoft Office Outlook 2007.

A meno che la distribuzione RPC su HTTP non sia stata personalizzata tramite i servizi MCS (Microsoft Consulting Services) o su indicazione del Servizio Supporto Tecnico Clienti Microsoft, si consiglia di distribuire RPC su HTTP con i valori di porta predefiniti.

Se è necessario impostare la chiave Rpc/HTTP Port su un valore diverso da 6001, si consiglia di impostarla su un valore superiore a 5000. L'assegnazione di numeri di porta statici inferiori a 5000 potrebbe causare conflitti di porta con altri processi e provocare errori nell'elaborazione del servizio Archivio informazioni di Microsoft Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave del Registro di sistema relativa alla porta Rpc/HTTP sul valore predefinito

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

  3. Fare doppio clic sulla chiave Rpc/HTTP Port e impostare il campo Dati valore su 6001 (decimale) o su un valore intero superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla configurazione di chiamate RPC su HTTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833401, "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Archivio: HTTP Port non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore impostato per HTTP Port corrisponde al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc/HTTP Port

Se Exchange Server Analyzer rileva che il valore di Rpc/HTTP Port non è 6001 (decimale), verrà visualizzato un messaggio di configurazione non predefinita.

La chiave Rpc/HTTP Port del Registro di sistema è impostata su 6001 dal programma di installazione di Exchange Server 2003 ed Exchange Server 2007. La chiave Rpc/HTTP Port del Registro di sistema è utilizzata per supportare la funzionalità RPC su HTTP per Microsoft Office Outlook® 2003 e Microsoft Office Outlook 2007.

A meno che la distribuzione RPC su HTTP non sia stata personalizzata tramite i servizi MCS (Microsoft Consulting Services) o su indicazione del Servizio Supporto Tecnico Clienti Microsoft, si consiglia di distribuire RPC su HTTP con i valori di porta predefiniti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave Rpc/HTTP Port del Registro di sistema sul valore predefinito

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Fare doppio clic sulla chiave Rpc/HTTP Port e impostare il campo Dati valori su 6001 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla configurazione di chiamate RPC su HTTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833401, "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Impostazioni di memoria al di sotto del livello ottimale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-15

Lo strumento Microsoft Exchange Analyzer interroga la classe di Microsoft Strumentazione gestione Windows (WMI) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un errore di evento 9665 di MSExchangeIS.

Microsoft Exchange Server 2003 esegue un controllo della configurazione della memoria ottimale all'inizio del processo di archiviazione. Se le impostazioni della memoria non sono ottimali, nel Visualizzatore eventi verrà visualizzato l'evento 9665.

Se Microsoft Exchange Analyzer rileva che un evento 9665 è stato registrato nelle ultime 24 ore, in base al campo dati dell'evento verrà determinata la presenza di uno dei flag indicati nella seguente tabella.

Flag del campo dati evento | Avviso di Exchange Server Analyzer visualizzato | Problema di Exchange Server 2003
0x00000001 | Opzione /3GB non impostata | Sul server è in esecuzione Microsoft Windows 2000 Advanced Server o Microsoft Windows 2000 Datacenter Server, sono disponibili 1 o più GB di memoria fisica, ma l'opzione /3GB non è impostata nel file boot.ini.
0x00000002 | Opzione /Userva non impostata correttamente | Sul server è in esecuzione Microsoft Windows 2003 Standard Edition, Microsoft Windows Server 2003 Enterprise Edition o Microsoft Windows Server 2003 Datacenter Edition, sono disponibili 1 o più GB di memoria fisica ed è presente l'opzione /3GB, ma l'impostazione /USERVA non è presente nel file boot.ini.
0x00000004 | È necessario configurare l'impostazione SystemPages. | Sul server è in esecuzione una delle edizioni di Microsoft Windows Server 2000 e il valore SystemPages nel Registro di sistema non è compreso nell'intervallo tra 24000 e 31000.
0x00000008 | È necessario riconfigurare l'impostazione SystemPages | Sul server è in esecuzione Microsoft Windows 2003 Standard Edition, Microsoft Windows Server 2003 Enterprise Edition o Microsoft Windows Server 2003 Datacenter Edition e il valore SystemPages nel Registro di sistema è impostato su un valore diverso da 0.
0x00000010 | L'impostazione HeapDecommitFreeBlockThreshold non è configurata correttamente | Sul server è in esecuzione una delle versioni di Microsoft Windows Server 2000 o Microsoft Windows Server 2003 e l'impostazione HeapDeCommitFreeBlockThreshold nel Registro di sistema è configurata su un valore diverso da 0x00040000

A seconda del flag presente nel campo dati dell'evento 9665, in Exchange Analyzer viene visualizzato il corrispondente avviso riportato nella precedente tabella.

Tali avvisi indicano che la memoria di Exchange Server è impostata su uno stato non ottimale.

Per risolvere il problema, seguire le istruzioni riportate negli articoli di Exchange Analyzer relativi al problema specifico elencati di seguito:

  • Questo server cassette postali di Exchange dispone di 1 o più GB di memoria ma non presenta l'opzione /3GB nel file Boot.ini

  • USERVA è impostato in modo errato

  • SystemPages è impostato su un valore troppo elevato

  • Windows Server 2003 è in esecuzione su questo server e il valore SystemPages non è uguale a 0

  • Il server dispone di 1 o più GB di memoria fisica e HeapDeCommitFreeBlockThreshold non è stato impostato su 262144

Per ulteriori informazioni

Per ulteriori informazioni su questi problemi, consultare l'articolo 325044 della Microsoft Knowledge Base "How to troubleshoot virtual memory fragmentation in Exchange Server 2003 and Exchange 2000 Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

Per ulteriori informazioni sull'evento MSExchangeIS 9665, vedere "Events and Errors Message Center: Event Details".

  • Per informazioni sull'evento 9665 dell'archivio cassette postali, vedere l'articolo all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83210.

  • Per informazioni sull'evento 9665 dell'archivio pubblico, vedere l'articolo all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83213.


Ricerca desktop sospetta su client
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-05

Microsoft® Exchange Server Analyzer Tool ha rilevato la presenza di numerosi utenti che utilizzano un motore di ricerca desktop. Questo tipo di motore di ricerca può creare un numero elevato di chiamate di procedura remota (RPC, Remote Procedure Call) nelle cassette postali installate di un utente, nonché un traffico considerevole nelle cartelle pubbliche poiché esegue l'indicizzazione della struttura file dell'archivio di tali cartelle. Molti motori di ricerca, tuttavia, eseguono l'indicizzazione delle cartelle pubbliche solo se si trovano nell'elenco Preferiti delle cartelle pubbliche dell'utente. Pertanto, non sempre le ricerche desktop generano un carico elevato sui server delle cartelle pubbliche.

Di seguito sono riportate alcune operazioni che è possibile effettuare per risolvere il problema:

  • Chiedere agli utenti di disabilitare le funzioni Microsoft Office Outlook® del programma di analisi o di limitare l'analisi alla sola cassetta postale personale.

  • Eseguire Outlook in modalità cache di Exchange in modo che le analisi interessino solo la workstation locale e non il server.

  • Seguire le istruzioni dell'articolo 889086 della Microsoft Knowledge Base "Possibile comportamento imprevisto in un computer basato su Windows XP durante il tentativo di accesso alle cartelle pubbliche in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=889086 per ottenere l'aggiornamento rapido e impostare la chiave del Registro di sistema MaxObjsPerMapiSession sui computer che eseguono Exchange Server a cui accedono gli utenti dei motori di ricerca desktop.

Per verificare se l'applicazione di ricerca desktop è la causa del carico elevato di un utente specifico, utilizzare ExMon (Microsoft Exchange Server User Monitor) per monitorare le operazioni RPC e le operazioni del motore di ricerca, assicurandosi di raccogliere i dati per un periodo di tempo adeguato. Quindi, rimuovere il motore di ricerca ed eseguire nuovamente lo strumento ExMon. Se si rileva una significativa riduzione della frequenza RPC, si avrà la conferma che la causa dell'incremento del traffico è il motore di ricerca desktop. Se si nota inoltre una diminuzione della latenza RPC media, si otterrà la conferma che il carico notevole ha prodotto latenze RPC più elevate.

Nota:
Le frequenze di latenza RPC variano considerevolmente nell'arco della giornata. Pertanto, una verifica di cinque minuti rischia di rivelarsi inadeguata. Potrebbe essere necessario prolungare la verifica per un periodo di tempo maggiore.

Per scaricare ExMon, accedere all'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=54983.

Ulteriori informazioni

  • Per ulteriori informazioni sulle applicazioni di ricerca desktop, consultare quanto segue:

    • Articolo 905184 della Microsoft Knowledge Base "Possibile impatto sulle prestazioni di Exchange 2000 Server e di Exchange Server 2003 dei motori di ricerca desktop in esecuzione sui client Outlook o su altri computer client MAPI" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184.

    • Blog del team di Microsoft Exchange "Are your clients using desktop search engines that index Exchange mailboxes or public folders?" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54475 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


SystemPages è impostato su un valore troppo elevato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-03-13

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore di SystemPages:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Se Exchange Server Analyzer rileva che il valore di SystemPages è maggiore di 50000, verrà visualizzato un avviso.

Microsoft Windows Server™ e Microsoft® Windows 2000 Server possono indirizzare direttamente fino a 4 GB di spazio di indirizzi della memoria, indipendentemente dalla quantità di RAM fisica installata. Dal punto di vista del processo, ciascun elemento dell'indirizzo virtuale fa riferimento concettualmente a un byte di memoria fisica. È compito del Gestore della memoria virtuale (VMM, Virtual Memory Manager), insieme all'unità di gestione della memoria (MMU, Memory Manager Unit) del processore, tradurre o eseguire il mapping di ciascun indirizzo virtuale a un indirizzo fisico corrispondente. VMM esegue il mapping dividendo la RAM in pagine di memoria di dimensioni definite, creando PTE (Page Table Entry) di sistema per archiviare le informazioni relative a tali pagine ed eseguirne il mapping. Le PTE di sistema sono piccoli buffer di memoria in modalità kernel che vengono utilizzate per comunicare con il sottosistema di I/O del disco e con la rete. Ciascuna PTE rappresenta una pagina di memoria e contiene informazioni necessarie al VMM per individuare una pagina.

In un sistema x86 che utilizza una dimensione di pagina pari a 4 KB, il numero massimo delle PTE necessarie per eseguire il mapping di 2 GB di spazio di indirizzi è 524.288 (2 GB/4 KB). In un sistema simile che utilizza l'opzione /3GB, il numero di PTE necessarie per il mapping di 3 GB di spazio di indirizzi è 786.432 (3 GB/4 KB). In un sistema tipico, questo spazio viene utilizzato nel seguente modo:

  • Un massimo di 50.000 PTE (circa 195 MB di spazio di indirizzi) sono riservate all'utilizzo generale.

  • Le rimanenti vengono utilizzate per eseguire il mapping della cache di sistema, dell'iperspazio, della riserva di paging, della riserva non di paging, dell'area di dettagli arresto anomalo e così via.

La dimensione di questo pool di PTE viene determinata automaticamente all'avvio del sistema in base alla quantità di memoria fisica nel sistema. Questo pool è suddiviso tra riserva di paging e riserva non di paging. Anche quest'ultima aumenta in base alla quantità di memoria fisica nel sistema.

Il pool di PTE del sistema può essere sottoposto a un notevole utilizzo e a una considerevole frammentazione. In questo modo possono verificarsi situazioni in cui, ad esempio, non è possibile caricare un driver e così via. Inoltre, se la riserva delle PTE di sistema è completamente esaurita, si verificherà una riduzione del livello delle prestazioni di altre parti del sistema, causando anche la mancata creazione di thread, blocchi e potenziali arresti anomali del sistema.

Per impedire l'eccessiva frammentazione della riserva delle PTE di sistema, è preferibile configurare sempre in modo adeguato il valore SystemPages del Registro di sistema per il sistema operativo utilizzato dal computer Exchange Server. Quando si esegue Exchange Server in Windows Server 2003, è consigliabile impostare la chiave SystemPages del Registro di sistema su 0. Questa indicazione è in contrasto con quella valida per Windows 2000 Server, in cui la chiave SystemPages del Registro di sistema deve essere impostata su un valore compreso tra 24.000 e 31.000.

Dopo aver eseguito la procedura descritta di seguito, è preferibile controllare il numero delle PTE di sistema libere. È possibile eseguire questa operazione monitorando il contatore della memoria e delle PTE libere di sistema con Performance Monitor di Windows (noto anche come Monitor di sistema). Se, dopo aver apportato al Registro di sistema le modifiche descritte di seguito, il numero di PTE di sistema libere rimane insufficiente, verificare quanto segue per assicurarsi che il computer Exchange Server sia configurato correttamente:

  • Driver Un driver che non funziona correttamente rappresenta una delle cause più comuni di PTE di sistema insufficienti. Inoltre, in alcune versioni di driver della scheda video S3 Savage 4 il valore di SystemPages è impostato su 208896. In genere, questi tipi di driver si trovano su server IBM E-Series. Verificare con il produttore hardware che i driver utilizzati per l'hardware siano aggiornati. Esiste inoltre l'opportunità di effettuare un downgrade a un driver di livello inferiore. Ad esempio, i computer che eseguono applicazioni basate su server come Exchange Server in genere non richiedono i più avanzati driver video con tutte le funzioni. Spesso è sufficiente un driver di livello inferiore. Il passaggio da un driver video avanzato a uno di livello inferiore dovrebbe aumentare il numero di PTE di sistema libere.

  • Configurazione di sistema Se il sistema Windows Server 2003 dispone di almeno 1 GB di memoria fisica installata, è consigliabile verificare che il relativo file Boot.ini sia correttamente configurato con le opzioni /3GB e /USERVA=3030, come descritto nei seguenti articoli della Microsoft Knowledge Base:

    • 823440, "Utilizzo obbligatorio dell'opzione /3GB nell'installazione di Exchange Server 2003 in un sistema basato su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823440.

    • 810371, "XADM: Utilizzo dell'opzione /Userva in server Exchange basati su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810371.

  • Registri eventi Controllare la presenza di eventuali errori o avvisi nel registro eventi dell'applicazione sul server Exchange, in particolare eventi 9582 (errori e avvisi), 9665 (avviso) e 12880 (errore) MSExchangeIS. La presenza dell'evento 9665 potrebbe indicare anche che la chiave SystemPages non è configurata per prestazioni ottimali. Per ulteriori informazioni su tali eventi, consultare l'articolo 325044 della Microsoft Knowledge Base "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere questo errore su Windows 2000 Server modificando il valore di SystemPages

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore digitare un valore compreso tra 24000 e 31000 (decimale) e fare clic su OK. Se non si è sicuri di quale valore utilizzare, si consiglia 31000 (decimale).

  5. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Per risolvere questo errore su Windows Server 2003 modificando il valore di SystemPages

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore digitare 0 e fare clic su OK.

  5. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Per correggere questo errore tramite aggiornamento o downgrade del driver video

  • Eseguire una delle seguenti operazioni:

    • Contattare il produttore hardware per ottenere un driver video aggiornato che non esegua la configurazione dell'impostazione SystemPages.

    • Effettuare il downgrade del driver video a un driver VGA standard e modificare il valore di SystemPages come descritto in precedenza.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'ottimizzazione della memoria di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.


La porta del Supervisore sistema HTTP ha un valore inferiore a 5000.
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione HTTP Port per il Supervisore sistema di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Se Exchange Server Analyzer rileva che HTTP Port è impostato su un valore inferiore a 5000 (decimale), verrà visualizzato un avviso.

La chiave HTTP Port del Registro di sistema è impostata su 6002 dal programma di installazione di Exchange Server 2003 ed Exchange Server 2007. La chiave HTTP Port del Registro di sistema è utilizzata per supportare la funzionalità RPC su HTTP per Microsoft Office Outlook® 2003 e Microsoft Office Outlook 2007.

A meno che la distribuzione RPC su HTTP non sia stata personalizzata tramite i servizi di consulenza Microsoft (MCS, Microsoft Consulting Services) o su indicazione del Servizio Supporto Tecnico Clienti Microsoft, si consiglia di distribuire RPC su HTTP con i valori di porta predefiniti.

Se è necessario impostare HTTP Port su un valore diverso da 6002, si raccomanda di impostare un valore superiore a 5000. L'assegnazione di numeri di porta statici inferiori a 5000 potrebbe causare conflitti di porta con altri processi e provocare errori nell'elaborazione del Supervisore sistema di Microsoft Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave Porta HTTP del Registro di sistema sul valore predefinito

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave HTTP Port e impostare il campo Dati valore su 6002 (decimale) o su un valore intero superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla configurazione di chiamate RPC su HTTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833401, "Configurazione di chiamate RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  • 827330, "Risoluzione dei problemi di chiamata RPC del client tramite connessione HTTP in Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.


Porta NSPI HTTP di Supervisore sistema inferiore a 5000
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione Rpc/HTTP NSPI Port per il Supervisore sistema di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Se Exchange Server Analyzer rileva che Rpc/HTTP NSPI Port è impostato su un valore inferiore a 5000 (decimale), verrà visualizzato un avviso.

La chiave Rpc/HTTP NSPI Port del Registro di sistema è impostata su 6004 dal programma di installazione di Exchange Server 2003 ed Exchange Server 2007. La chiave Rpc/HTTP NSPI Port del Registro di sistema è utilizzata per supportare la funzionalità RPC su HTTP per Microsoft Office Outlook® 2003 e Microsoft Office Outlook 2007.

A meno che la distribuzione RPC su HTTP non sia stata personalizzata tramite i servizi di consulenza Microsoft (MCS, Microsoft Consulting Services) o su indicazione del Servizio Supporto Tecnico Clienti Microsoft, si consiglia di distribuire RPC su HTTP con i valori di porta predefiniti.

Se è necessario impostare Rpc/HTTP NSPI Port su un valore diverso da 6004, si consiglia di impostarla su un valore superiore a 5000. L'assegnazione di numeri di porta statici inferiori a 5000 potrebbe causare conflitti di porta con altri processi e provocare errori nell'elaborazione del servizio Supervisore sistema di Microsoft Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave Rpc/HTTP NSPI Port del Registro di sistema sul valore predefinito

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave Rpc/HTTP NSPI Port e impostare il campo Dati valore su 6004 (decimale) o su un valore intero superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla configurazione di chiamate RPC su HTTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833401, "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Supervisore sistema: porta HTTP NSPI non predefinita
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il parametro HTTP Port è stato impostato sul valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\Rpc/HTTP NSPI Port

Se Exchange Server Analyze rileva che il valore di Rpc/HTTP NSPI Port non corrisponde a 6004 (valore decimale), viene visualizzato un messaggio di configurazione non predefinita.

La chiave Rpc/HTTP NSPI Port del Registro di sistema è impostata su 6004 dal programma di installazione di Exchange Server 2003. La chiave Rpc/HTTP NSPI Port è utilizzata per supportare la funzionalità RPC su HTTP per Microsoft Office Outlook® 2003.

A meno che la distribuzione RPC su HTTP non sia stata personalizzata tramite i servizi di consulenza Microsoft (MCS, Microsoft Consulting Services) o su indicazione del Servizio Supporto Tecnico Clienti Microsoft, si consiglia di distribuire RPC su HTTP con i valori di porta predefiniti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave Rpc/HTTP NSPI Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave Rpc/HTTP NSPI Port e impostare il campo Dati valore su 6004 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla configurazione di chiamate RPC su HTTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833401, "Configurazione di chiamate RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  • 827330, "Risoluzione dei problemi di chiamata RPC del client tramite connessione HTTP in Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.


Supervisore sistema: valore HTTP port non predefinito
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore impostato per HTTP Port corrisponde al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\HTTP Port

Se Exchange Server Analyzer rileva che il valore di HTTP Port non è 6002 (decimale), verrà visualizzato un messaggio di configurazione non predefinita.

La chiave HTTP Port del Registro di sistema è impostata su 6002 dal programma di installazione di Exchange Server 2003 ed Exchange Server 2007. La chiave HTTP Port del Registro di sistema è utilizzata per supportare la funzionalità RPC su HTTP per Microsoft Office Outlook® 2003 e Microsoft Office Outlook 2007.

A meno che la distribuzione RPC su HTTP non sia stata personalizzata tramite i servizi di consulenza Microsoft (MCS, Microsoft Consulting Services) o su indicazione del Servizio Supporto Tecnico Clienti Microsoft, si consiglia di distribuire RPC su HTTP con i valori di porta predefiniti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave HTTP port del Registro di sistema sul valore predefinito

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Fare doppio clic sulla chiave HTTP Port e impostare il campo Dati valore su 6002 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla configurazione di chiamate RPC su HTTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833401, "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401)

  • 827330, "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330)


Valore legacyExchangeDN del Supervisore sistema mancante
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo legacyExchangeDN per l'oggetto Supervisore sistema di ogni computer Exchange Server. Se Exchange Server Analyzer non trova alcun valore per l'attributo legacyExchangeDN di uno qualsiasi degli oggetti Supervisore sistema, verrà visualizzato un messaggio di errore.

La mancanza di un attributo legacyExchangeDN potrebbe derivare da modifiche di Active Directory apportate da un amministratore per ripristinare un database in una situazione di ripristino di emergenza. Per risolvere il problema è necessario modificare l'attributo legacyExchangeDN utilizzando un editor di Active Directory come lo strumento LDP (ldp.exe) o ADSI Edit (Active Directory Service Interfaces).

Per assicurarsi che l'attributo legacyExchangeDN sia corretto, è necessario esaminare anche altri oggetti Supervisore sistema del server o di un altro server di Exchange che non genera l'errore, in quanto dovrebbero presentare lo stesso valore per l'attributo legacyExchangeDN.

Se l'attributo legacyExchangeDN manca in un database, è probabile che manchi anche in molti altri oggetti di sistema. Pertanto, se si utilizza LDP o ADSI Edit per aggiungere un nuovo valore di legacyExchangeDN, sarà necessario aggiungere un nuovo valore di legacyExchangeDN anche a tutti gli altri oggetti di sistema.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Espandere Configurazione [NomeDominio], CN=Configuration, DC=NomeDominio, DC=SuffissoDominio.

  3. Espandere CN=Services, quindi CN=Microsoft Exchange.

  4. Espandere CN=NomeOrganizzazione, CN=Administrative Groups, quindi CN=NomeGruppoAmministrativo.

  5. Espandere CN=Servers, quindi CN=NomeServer.

  6. Fare clic con il pulsante destro del mouse su CN=Supervisore sistema Microsoft e scegliere Proprietà.

  7. Scorrere verso il basso fino a individuare legacyExchangeDN, selezionarlo e fare clic su Modifica.

  8. Nel campo Valore immettere il corretto attributo legacyExchangeDN.

  9. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il computer che esegue Exchange Server.

Per ulteriori informazioni sull'utilizzo di ADSI Edit per creare un nuovo attributo legacyExchangeDN, consultare l'articolo 273863 della Microsoft Knowledge Base "Modifica dell'attributo LegacyExchangeDN in modalità nativa con ADSI Edit" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863.


La porta NSPI del Supervisore sistema è stata sostituita manualmente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se il servizio NSPI del server di destinazione (Name Service Provider Interface, interfaccia provider del servizio nomi) è stato ignorato manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\TCP/IP NSPI Port

Se Exchange Server Analyzer rileva la presenza e l'avvenuta configurazione di TCP/IP NSPI Port, verrà visualizzato un messaggio di configurazione non predefinita.

Il motivo più comune per cui questo valore viene configurato è quello di consentire ai client MAPI di connettersi a un server di Exchange situato sull'altro lato di un firewall. Questo scenario implica l'apertura di più porte su un firewall per consentire ai client Microsoft Office Outlook® 2003 di connettersi mediante MAPI a un server di Exchange, in genere tramite Internet.

L'implementazione consigliata per l'utilizzo di Outlook in modalità Corporate o Workgroup per connettersi a un server di Exchange tramite Internet consiste nell'utilizzare le funzioni RPC (Remote Procedure Call) su HTTP reperibili in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003 e Windows® XP Professional.

RPC su HTTP elimina la necessità di utilizzare una connessione VPN (Virtual Private Network) o di aprire più porte sul firewall per consentire l'accesso MAPI da Outlook 2003 a Exchange Server 2003. Un utente che esegue Outlook 2003 può connettersi a un server di Exchange tramite Internet. Il client RPC stabilisce la connessione Internet effettuando il tunneling del traffico RPC attraverso il protocollo HTTP. Se il client RPC è in grado di effettuare una connessione HTTP/HTTPS a un computer remoto che esegue Internet Information Services (IIS), tale client può connettersi a qualsiasi server della rete remota. Il server della rete remota deve essere configurato in modo da essere accessibile tramite Internet mediante RPC su HTTP. Inoltre, i programmi client e server RPC possono connettersi attraverso Internet, anche se entrambi sono protetti da firewall situati su reti differenti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per rimuovere la voce TCP/IP NSPI Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeSA\Parameters

  3. Eliminare il valore del Registro di sistema denominato TCP/IP NSPI Port.

  4. Uscire dall'editor del Registro di sistema e riavviare il servizio Supervisore sistema di Exchange.

Per distribuire RPC su HTTP

  1. Esaminare "Scenari di distribuzione di RPC su HTTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577.

  2. Esaminare l'articolo 833401 della Microsoft Knowledge Base "Configurazione di chiamate RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Esaminare l'articolo 827330 della Microsoft Knowledge Base "Risoluzione dei problemi di chiamata RPC del client tramite connessione HTTP in Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Esaminare Webcast di supporto Microsoft "Utilizzo di Microsoft Exchange in Internet (RPC/HTTP) con Microsoft Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'utilizzo del valore TCP/IP NSPI Port del Registro di sistema in un ambiente firewall, consultare l'articolo 270836 della Microsoft Knowledge Base "Mapping statici delle porte in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836.


Il Supervisore sistema è configurato per interagire con il desktop
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della proprietà DesktopInteract per il servizio Supervisore sistema di Microsoft Exchange (MSExchangeIS). Se Exchange Server Analyzer rileva che il Supervisore sistema è configurato per interagire con il desktop, verrà visualizzato un messaggio di errore.

Questa configurazione dovrebbe essere utilizzata solo dietro la guida del Servizio Supporto Tecnico Clienti Microsoft. Se non sono state fornite istruzioni dal Servizio Supporto Tecnico Clienti Microsoft per eseguire il Supervisore sistema in questa configurazione, è consigliabile riconfigurare le proprietà del Supervisore sistema in modo che non interagisca con il desktop.

Per configurare l'account del Supervisore sistema di Microsoft Exchange

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Individuare e interrompere il servizio Supervisore sistema di Microsoft Exchange. Notare che l'interruzione del Supervisore sistema comporterà anche l'interruzione di tutti i servizi che dipendono da esso, incluso il servizio Archivio informazioni di Microsoft Exchange.

  3. Fare doppio clic su Supervisore sistema di Microsoft Exchange.

  4. Nella scheda Connessione della pagina delle proprietà di Supervisore sistema di Microsoft Exchange, selezionare Account di sistema locale in Accedi come.

  5. Deselezionare la casella di controllo Consenti al servizio di interagire col desktop e fare clic su Applica.

  6. In Stato del servizio fare clic su Avvia e quindi su OK.

  7. Aprire lo snap-in Servizi.

Per ulteriori informazioni sulla corretta configurazione dei servizi di Exchange, consultare l'articolo 239762 della Microsoft Knowledge Base "Esecuzione dei servizi di Exchange in LocalSystem" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Il servizio Supervisore sistema non è in esecuzione come LocalSystem
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-01-09

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della proprietà StartName per il servizio Supervisore sistema di Microsoft Exchange (MSExchangeIS). Microsoft® Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per ogni oggetto di Exchange Server nella directory. L'attributo serialNumber sull'oggetto di Exchange Server identifica la versione di Exchange Server in esecuzione sul computer rappresentato dall'oggetto. Se Exchange Server Analyzer rileva che il servizio Supervisore sistema è in esecuzione con un account diverso dall'account LocalSystem (SYSTEM) su un server di Exchange che esegue Exchange 2000 Server, Exchange Server 2003 o Exchange Server 2007, verrà visualizzato un messaggio di errore.

Questo errore indica che il servizio Supervisore sistema non è in esecuzione su una configurazione supportata. Se si esegue il servizio Supervisore sistema con un altro account, si provocheranno problemi di accesso e di autorizzazione.

Per risolvere questo problema, è necessario configurare il servizio Supervisore sistema di Microsoft Exchange in modo che venga avviato con l'account LocalSystem (SYSTEM).

Nota:
Questo errore non riguarda Exchange Server versione 5.5. Solo Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007 richiedono che il servizio Supervisore sistema di Exchange venga eseguito con l'account LocalSystem.
Per configurare l'account del Supervisore sistema di Microsoft Exchange

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Individuare e arrestare il servizio Supervisore sistema di Microsoft Exchange. Notare che l'interruzione del Supervisore sistema comporterà anche l'interruzione di tutti i servizi che dipendono da esso, incluso il servizio Archivio informazioni di Microsoft Exchange.

  3. Fare doppio clic sul servizio Supervisore sistema di Microsoft Exchange.

  4. Nella scheda Connessione della pagina delle proprietà di Supervisore sistema di Microsoft Exchange in Accedi come scegliere Account di sistema locale, quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia e quindi su OK.

  6. Chiudere lo snap-in Servizi.

Per ulteriori informazioni sull'esecuzione dei servizi di Exchange con l'account LocalSystem, consultare l'articolo 239762 della Microsoft Knowledge Base "Esecuzione dei servizi di Exchange in LocalSystem" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


La chiave TcpTimedWaitDelay è mancante o non predefinita
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-03-13

Lo strumento Microsoft Exchange Analyzer esegue query nel servizio directory di Active Directory per determinare il valore dell'attributo serialNumber per tutti gli oggetti con classe oggetto msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Exchange Server 2003. Se la stringa comprende "Version 8.0", il computer esegue Exchange Server 2007.

Lo strumento Exchange Analyzer legge quindi il ramo del Registro di sistema seguente per ogni server di Exchange Server 2007 individuato per verificare se il valore della chiave TcpTimedWaitDelay è impostato sul valore predefinito 60.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

La chiave TcpTimedWaitDelay definisce il tempo che deve trascorrere prima che TCP possa rilasciare una connessione chiusa e riutilizzarne le risorse. L'intervallo compreso tra la chiusura e il rilascio è chiamato stato TIME_WAIT o 2MSL. Durante questo periodo è più conveniente riaprire la connessione tra il server e il client anziché stabilirne una nuova.

La riduzione del valore di questa voce consente a TCP di rilasciare più velocemente le connessioni chiuse, fornendo più risorse per le nuove connessioni. Se tuttavia il valore è troppo basso, il servizio TCP potrebbe rilasciare le risorse della connessione prima che questa venga completata, richiedendo al server ulteriori risorse per stabilire di nuovo la connessione.

Se Exchange Analyzer stabilisce che il valore della chiave TcpTimedWaitDelay è mancante o diverso da quello predefinito, vale a dire 60, verrà visualizzato un avviso.

Per ottenere prestazioni ottimali, è consigliabile impostare la chiave TcpTimedWaitDelay sul relativo valore predefinito 60 sui server Exchange Server 2007.

Importante:
Questo articolo contiene informazioni sulle modifiche del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di aver compreso a fondo come ripristinarlo in caso di problemi. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per impostare la chiave TcpTimedWaitDelay del Registro di sistema sul valore predefinito

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Fare doppio clic sulla chiave TcpTimedWaitDelay e impostare il campo Dati valore su 60 (decimale).

  4. Chiudere l'editor del Registro di sistema e riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Questo problema è correlato al problema Chiave MaxUserPort mancante o non predefinita in Analyzer.

Per ulteriori informazioni sull'effetto della chiavi MaxUserPort e TcpTimedWaitDelay del Registro di sistema, consultare l'argomento "Transmission Control Protocol" nel Resource Kit di Windows 2000, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=85654 (informazioni in lingua inglese).


La variabile TEMP/TMP potrebbe fare riferimento a una cartella non valida o non appropriata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

In un computer Exchange Server non cluster, Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare il valore delle variabili di ambiente TEMP e TMP:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment\TEMP

HKLM\System\CurrentControlSet\Control\Session Manager\Environment\TMP

Il servizio Archivio informazioni di Microsoft Exchange consente di utilizzare le cartelle TEMP e TMP come archivio temporaneo durante alcune operazioni, ad esempio nelle operazioni di conversione dei messaggi o spostamento delle cassette postali. Su un server di Exchange non cluster il servizio Archivio informazioni di Microsoft Exchange consente di utilizzare SYSTEM (ad esempio, il sistema locale) in cui viene utilizzata l'impostazione predefinita delle variabili di ambiente %Systemroot%\Temp sia per TEMP sia per TMP. Se una o entrambe le variabili di ambiente TEMP o TMP di Exchange Server iniziano con %SYSTEMROOT, verrà visualizzato un avviso.

Le variabili di ambiente TEMP e TMP vengono utilizzate per determinare quali cartelle del file system (quale percorso) devono essere utilizzate dalle applicazioni che richiedono un'area di lavoro temporanea. In genere, la variabile TEMP viene utilizzata da applicazioni quali Microsoft Exchange, mentre la variabile TMP da strumenti di sviluppo quali Microsoft Visual C++®. Il percorso di ciascuna variabile generalmente è relativo al contesto di protezione dell'applicazione o dello strumento.

Quando Exchange Server Analyzer viene eseguito su un server virtuale di Exchange in un cluster di Microsoft Windows Server™ 2003, non legge la struttura del Registro di sistema HKLM. Invece, legge le seguenti voci del Registro di sistema:

HKEY_USERS\<SID account servizio cluster>\Environment\TEMP

HKEY_USERS\<SID account servizio cluster>\Environment\TEMP

Nei server virtuali di Exchange in esecuzione in un cluster di Windows Server 2003 vengono utilizzate le impostazioni delle variabili di ambiente per l'account del servizio cluster, eseguito nel contesto di protezione di un utente specifico. Per gli account utente, la variabile di ambiente predefinita per TEMP e TMP è impostata su %Userprofile%\temp. Se una o entrambe le variabili di ambiente TEMP o TMP del server virtuale di Exchange iniziano con %SYSTEMROOT, verrà visualizzato un avviso.

Per prestazioni ottimali, è consigliabile non utilizzare il disco contenente il sistema operativo per le cartelle TEMP e TMP utilizzate da Exchange. È inoltre preferibile assicurarsi che tali variabili di ambiente siano impostate su percorsi che si trovano su un disco rapido o un sottosistema disco, ad esempio un set di spindle RAID 0+1. È inoltre consigliabile non utilizzare il disco contenente il sistema operativo per le cartelle TEMP e TMP utilizzate da Exchange o da server virtuali di Exchange.

Per risolvere il problema

  1. Accedere al computer Exchange Server con un account che disponga delle autorizzazioni di amministrazione.

  2. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà.

  3. Selezionare la scheda Avanzate.

  4. Fare clic sul pulsante Variabili di ambiente.

  5. Nell'area Variabili di sistema selezionare TEMP e fare clic sul pulsante Modifica.

  6. Nel campo Valore variabile immettere il nuovo percorso per la variabile di ambiente TEMP e fare clic su OK.

  7. Nell'area Variabili di sistema selezionare TMP e fare clic sul pulsante Modifica.

  8. Nel campo Valore variabile immettere il nuovo percorso per la variabile di ambiente TMP e fare clic su OK.

  9. Per chiudere la finestra di dialogo Variabili di ambiente, fare clic su OK e per chiudere la finestra di dialogo Proprietà del sistema, fare clic di nuovo su OK.

  10. Riavviare il nodo per rendere effettiva la modifica.

Per ulteriori informazioni sulla modifica delle variabili di ambiente TEMP/TMP su un server cluster di Exchange, consultare Il percorso TEMP/TMP del cluster si trova sulla stessa unità della partizione di sistema.


Il server dispone di 1 o più GB di memoria fisica e HeapDeCommitFreeBlockThreshold non è stato impostato su 262144
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-08-14

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se Exchange è stato regolato in modo ottimale in base alla quantità di memoria fisica presente nel sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\HeapDeCommitFreeBlockThreshold

Se Exchange Server Analyzer rileva che il valore di HeapDeCommitFreeBlockThreshold non è stato impostato in un computer Exchange Server con almeno 1 gigabyte (GB) di memoria fisica installata, verrà visualizzato un avviso.

Quando viene liberata memoria a un indirizzo specificato, la gestione dell'heap del sistema operativo controlla la quantità di byte contigui liberi intorno a tale indirizzo. Al termine della verifica la gestione dell'heap può effettuare una delle due operazioni seguenti:

  • Mantenere il blocco di memoria contigua impegnato.

  • Liberare il blocco di memoria contigua e contrassegnarlo solo come riservato.

La chiave HeapDeCommitFreeBlockThreshold del Registro di sistema specifica il numero di byte contigui al di sopra del quale la memoria viene liberata. Per impostazione predefinita, la gestione dell'heap non combina necessariamente tutti i blocchi liberi né esegue nuove allocazioni, pertanto è possibile liberare i blocchi e trasformarli in spazi vuoti inutili all'interno dello spazio di indirizzi virtuali. Questo può provocare una frammentazione della memoria virtuale, una riduzione delle prestazioni e instabilità del sistema.

Nei sistemi con almeno 1 GB di memoria fisica installata le prestazioni vengono ottimizzate controllando la dimensione dei blocchi di memoria liberata. La chiave HeapDeCommitFreeBlockThreshold del Registro di sistema consente di controllare il modo in cui viene gestita la memoria quando viene liberata. Quando si aggiunge questo valore al Registro di sistema, è necessario configurarlo con un valore esadecimale di 0x00040000 (262144, in valori decimali).

Microsoft non supporta altri valori per la chiave HeapDeCommitFreeBlockThreshold del Registro di sistema oltre al valore 0x00040000 (262144, in valori decimali).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Control\Session Manager

  3. Creare un valore DWORD denominato HeapDeCommitFreeBlockThreshold.

  4. Fare doppio clic sul valore HeapDeCommitFreeBlockThreshold e immettere il valore esadecimale 0x00040000 (262144, in valori decimali).

  5. Uscire dall'editor del Registro di sistema e riavviare il computer Exchange Server per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione della chiave HeapDeCommitFreeBlockThreshold del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 315407, "XADM: La "Chiave del Registro di sistema HeapDeCommitFreeBlockThreshold" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=315407.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.


Windows Server 2003 è in esecuzione su questo server e il valore SystemPages non è uguale a 0
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'impostazione del valore SystemPages:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\SystemPages

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore di questa chiave corrisponde a una versione specifica di un sistema operativo Microsoft Windows.

Se Exchange Server Analyzer rileva che il valore di SystemPages non è impostato su 0 in un computer Exchange Server su cui è in esecuzione un'applicazione Microsoft® Windows Server™ 2003 e che non fa parte dell'installazione Microsoft Windows Small Business Server 2003, verrà visualizzato un avviso.

Quando si esegue Exchange Server 2003 Service Pack 1 (SP1) su Microsoft Windows Server 2003 con almeno 1 GB di memoria RAM, è consigliabile impostare la chiave SystemPages del Registro di sistema su 0. Questa indicazione è in contrasto con quella valida per Microsoft Windows® 2000 Server, in cui la chiave SystemPages deve essere impostata su un valore compreso tra 24000 e 31000.

Su un computer Windows Server 2003 non appartenente all'installazione Microsoft Windows Small Business Server 2003, il valore del Registro di sistema SystemPages dovrà sempre essere impostato su 0. La modifica di questa impostazione impedisce il calcolo del valore ottimale del sistema e l'adeguamento del valore quando si apportano delle modifiche al sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Attenzione:
La conseguenza dell'impostazione del valore del Registro di sistema SystemPages su sistemi Windows Server 2003 è l'abbassamento delle dimensioni massime della riserva di paging. Questa implicazione può provocare l'esaurimento della riserva di paging e l'instabilità del server.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

  3. Nel riquadro destro fare doppio clic su SystemPages.

  4. Nel campo Dati valore, digitare 0 e fare clic su OK.

  5. Uscire dall'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'ottimizzazione della memoria di Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.


Per questo server di Exchange è stata impostata l'opzione di avvio /PAE nel file Boot.ini
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare le opzioni impostate nella proprietà SystemStartupOptions. Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il conteggio per l'attributo homeMDBBL dell'oggetto archivio delle cassette postali (msExchPrivateMDB). Il conteggio risultante è il numero di cassette postali rilevate nel computer Exchange Server.

Se Exchange Server Analyzer rileva che l'opzione di avvio /PAE è stata impostata nel file Boot.ini su un server di Exchange contenente meno di 500 cassette postali ed è eseguito su un Windows 2000 Server, verrà visualizzato un avviso.

Le PAE (Physical Addressing Extensions) consentono a un computer di accedere a oltre 4 GB di memoria fisica (RAM). Exchange Server non supporta le PAE. Le PAE consentono a Windows di accedere a oltre 4 GB di memoria fisica. In Exchange Server non è possibile utilizzare più di 4 GB di memoria fisica, pertanto non vi è alcun vantaggio se si installano più di 4 GB di RAM in un computer dedicato all'esecuzione di Exchange Server. La PAE è attivata quando l'opzione di installazione /PAE è presente nel file Boot.ini.

Per risolvere il problema solo in Windows 2000 Server, si consiglia di rimuovere l'opzione /PAE dal file Boot.ini.

Per risolvere il problema

  1. In Esplora risorse passare alla partizione di sistema. È la partizione che contiene i file specifici dell'hardware come Boot.ini e NTLDR.

  2. Se non è possibile visualizzare il file Boot.ini, in Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse fare clic su Strumenti, scegliere Opzioni cartella e quindi fare clic su Visualizza. Fare clic su Visualizza cartelle e file nascosti. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene richiesto, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse su di esso, scegliere Apri con, quindi Blocco note per aprire il file.

  4. Nella sezione [Operating Systems] rimuovere l'opzione /PAE.

  5. Per rendere effettiva la modifica, salvare e chiudere il file, quindi riavviare il computer che esegue Exchange Server.

Per ulteriori informazioni sull'opzione /PAE nel file Boot.ini, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 268363: 268363: "Intel Physical Addressing Extensions (PAE) in Windows 2000"

    (all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363.

  • 328882: 328882: "Exchange Memory Use and the /3GB Switch"

    (all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882.


Nel server di Exchange in esecuzione è abilitata la tecnologia PAE (Physical Address Extensions)
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-05-08

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare i valori delle seguenti chiavi:

  • PAEEnabled Il valore di questa chiave indica se le PAE (Physical Address Extensions, estensioni indirizzo fisico) sono abilitate. Il valore True indica che la PAE è abilitata mentre il valore False indica il contrario.

  • Version Il valore di questa chiave indica la versione di Microsoft Windows in esecuzione sul computer. Un valore di 5.0.2195 indica che è in esecuzione un sistema operativo Microsoft Windows 2000 Server, mentre un valore di 5.2.3790 indica che è in esecuzione un sistema operativo Microsoft Windows Server™ 2003.

  • ServicePackMajorVersion ll valore di questa chiave indica il numero principale della versione del Service Pack di Windows installato.

Exchange Server Analyzer esegue inoltre una query nella classe WMI CIM_Datafile per la versione secondaria di ntoskrnl.exe in esecuzione sul sistema per determinare se l'aggiornamento della protezione MS04-032 è installato nel computer. Se il numero della versione secondaria di ntoskrnl.exe è minore o uguale a 174 significa che MS04-032 non è installato. Se il numero della versione secondaria di ntoskrnl.exe è maggiore di 174 significa che MS04-032 è installato.

Se Exchange Server Analyzer rileva che il valore per PAEEnabled è impostato su True e che Exchange Server è in esecuzione su Windows Server 2003 senza che sia stato installato l'aggiornamento della protezione MS04-032, verrà visualizzato un messaggio di errore. L'errore indica che il computer è sensibile a un problema noto che può causare un arresto anomalo del servizio Archivio informazioni di Microsoft Exchange (Store.exe).

Exchange Server non supporta l'utilizzo di PAE. Le PAE consentono a Windows di accedere a oltre 4 GB di memoria fisica. In Exchange Server non è possibile utilizzare più di 4 GB di memoria fisica, pertanto non vi è alcun vantaggio se si installano più di 4 GB di RAM in un computer dedicato all'esecuzione di Exchange Server. La PAE è attivata quando è presente l'opzione di avvio /PAE nel file Boot.ini durante la sequenza di avvio oppure quando il sistema operativo Windows Server 2003 rileva periferiche di memoria a inserimento a caldo. In Windows Server 2003 Enterprise Edition e in Windows Server 2003 Datacenter Edition, le PAE vengono attivate automaticamente solo se nel server sono in uso periferiche di memoria a inserimento a caldo.

Per risolvere il problema installando l'aggiornamento MS04-032

  1. Per ottenere l'aggiornamento MS04-032, consultare l'articolo 840987 della Microsoft Knowledge Base "MS04-032: Aggiornamento della protezione di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=840987.

  2. Eseguire il backup completo del sistema.

  3. Applicare l'aggiornamento e riavviare il computer per rendere effettivo l'aggiornamento.

Per ulteriori informazioni sulle PAE, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 268363: 268363: "Intel Physical Addressing Extensions (PAE) in Windows 2000"

    (all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363.

  • 328882: 328882 "Exchange Memory Use and the /3GB Switch"

    (all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882.

Per ulteriori informazioni sull'opzione /NOPAE del file Boot.ini, consultare l'articolo di MSDN® "/nopae" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=51490 (informazioni in lingua inglese).


Il server di Exchange viene eseguito con le PAE (Physical Address Extensions, estensioni indirizzo fisico) abilitate e l'opzione di avvio /3GB
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave PAEEnabled. Il valore di questa chiave indica se le PAE sono abilitate. Il valore True indica che le PAE sono abilitate mentre il valore False indica il contrario. Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_OperatingSystem per determinare il valore della chiave MaxProcessMemorySize.

Se Exchange Server Analyzer rileva che il valore di PAEEnabled è True e il valore di MaxProcessMemorySize è maggiore di 2097024, verrà visualizzato un avviso. L'avviso indica che non vengono utilizzati i valori predefiniti. In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sulle PAE, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 268363: "Tecnologia PAE (Physical Addressing Extensions) di Intel in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363.

  • 328882: "Utilizzo della memoria di Exchange e opzione /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882.


In questo server di Exchange sono impostate le opzioni di avvio /PAE e /3GB
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare le opzioni impostate nella chiave SystemStartupOptions. Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_OperatingSystem per determinare il valore della chiave MaxProcessMemorySize.

Se Exchange Server Analyzer rileva che il valore della chiave SystemStartupOptions comprende /PAE, che il valore Win32_OperatingSystem indica che il computer esegue Microsoft Windows 2000 Server e che il valore di MaxProcessMemorySize è superiore a 2097024, verrà visualizzato un messaggio di errore.

Tale messaggio indica che le opzioni di avvio /PAE e /3GB sono state entrambe impostate nel file Boot.ini. Le PAE (Physical Address Extensions) consentono a un computer di accedere a oltre 4 GB di memoria fisica (RAM). Exchange Server non supporta le PAE. In Exchange Server non è possibile utilizzare più di 4 GB di memoria fisica, pertanto non vi è alcun vantaggio se si installano più di 4 GB di RAM in un computer dedicato all'esecuzione di Exchange Server. La PAE è attivata quando l'opzione di installazione /PAE è presente nel file Boot.ini all'avvio.

Per risolvere il problema in Windows 2000 Server, si consiglia di rimuovere l'opzione /PAE dal file Boot.ini.

Per risolvere il problema

  1. In Esplora risorse aprire Partizione di sistema. È la partizione che contiene i file specifici dell'hardware come Boot.ini e NTLDR.

  2. Se non è possibile visualizzare il file Boot.ini, in Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra Esplora risorse fare clic su Strumenti, scegliere Opzioni cartella e quindi fare clic su Visualizza. Fare clic su Visualizza cartelle e file nascosti. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene richiesto, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse su di esso, scegliere Apri con, quindi Blocco note per aprire il file.

  4. Nella sezione [Operating Systems] rimuovere l'opzione /PAE.

  5. Per rendere effettiva la modifica, salvare e chiudere il computer, quindi riavviare il computer che esegue Exchange Server.

Per ulteriori informazioni sull'opzione /PAE nel file Boot.ini, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 268363, "Tecnologia PAE (Physical Addressing Extensions) di Intel in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268363.

  • 328882, "Utilizzo della memoria di Exchange e opzione /3GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328882.


Server front-end configurato con il Servizio aggiornamento destinatari
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchAddressListServiceLink per tutti gli oggetti Recipient Update Service nella directory. L'attributo msExchAddressListServiceLink è un collegamento dal servizio elenco di indirizzi al computer Exchange Server che sta eseguendo il Servizio aggiornamento destinatari (RUS). Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • Il server di Exchange è configurato come server front-end.

  • Il computer Exchange Server esegue il Servizio aggiornamento destinatari.

Il Servizio aggiornamento destinatari è un componente del servizio Supervisore sistema di Exchange. Il Servizio aggiornamento destinatari crea e mantiene valori dell'attributo specifici di Exchange in Active Directory. Se viene creata una cassetta postale per un utente, il Servizio aggiornamento destinatari è responsabile per la generazione automatica dell'indirizzo SMTP e qualsiasi altro indirizzo proxy definito nei criteri destinatario.

Quando un server di Exchange configurato per l'utilizzo del Servizio aggiornamento destinatari è configurato come server front-end, gli oggetti utente appena creati non vengono eseguiti dal Servizio aggiornamento destinatari. Gli oggetti utente non possono così ricevere indirizzi di posta e i destinatari non vengono visualizzati nell'elenco di indirizzi. Inoltre, non vengono eseguiti gli aggiornamenti alla rubrica non in linea.

Se si riceve questo messaggio, il Servizio aggiornamento destinatari è in esecuzione su un server di Exchange configurato come server front-end.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. In Destinatari fare clic su Servizi aggiornamento destinatari. Nel riquadro destro fare clic con il pulsante destro del mouse sull'istanza appropriata del Servizio aggiornamento destinatari, quindi fare clic su Proprietà.

  3. Nella scheda Generale in Exchange Server fare clic su Sfoglia e specificare un nuovo server per eseguire l'istanza.

  4. Per rendere effettive le modifiche, fare clic su OK, quindi fare nuovamente clic su OK.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti argomenti di Exchange e articoli della Microsoft Knowledge Base:

  • 328738, "Applicazione dei criteri destinatario da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.

  • 253828, "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • 246127, "Verifica dell'esecuzione del Servizio aggiornamento destinatari di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127.

  • 253770, "XADM: Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.


È stata rilevata una discrepanza tra il nome del server Exchange presente nel Registro di sistema e quello in Active Directory
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore archiviato in Active Directory per il nome del server Exchange (CN=<ExchangeServerName>). Dopo aver recuperato il nome, Exchange Server Analyzer esegue il conteggio del numero di caratteri contenuti nel nome.

Exchange Server Analyzer legge inoltre la seguente voce del Registro di sistema per determinare il valore archiviato nel Registro di sistema del computer Exchange Server per il nome host del server Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Hostname

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per ClusSvc, il servizio cluster di Windows®.

Se Exchange Server Analyzer rileva che tutti i criteri seguenti sono veri, verrà visualizzato un messaggio di errore:

  • Il valore di CN=<NomeServerExchange> non corrisponde al valore di Hostname.

  • Il nome del server Exchange contiene 15 caratteri o meno.

  • Il server Exchange non è in esecuzione in un cluster Windows.

La causa più comune di questo errore è rappresentata dalla modifica del nome del server Exchange. Una modifica apportata al nome in questo modo viene applicata al Registro di sistema del computer e all'account del computer in Active Directory, ma non ai diversi riferimenti al nome del server Exchange presenti negli attributi e negli oggetti di Exchange in Active Directory.

Nota:
In alcuni software di terze parti, inoltre, verrà modificato il nome del computer per garantire la funzionalità di creazione di cluster. Se si utilizza un software di questo tipo, potrebbe essere necessario ignorare questo problema.

La ridenominazione di un computer Exchange Server non è supportata e, in genere, è causa di problemi come, ad esempio, un errore di avvio del servizio Supervisore sistema di Microsoft Exchange dopo la modifica del nome del computer. Se il computer Exchange Server rinominato non funziona correttamente sotto tutti i punti di vista, è possibile rimuovere manualmente Exchange Server dal computer utilizzando il processo di rimozione manuale illustrato nel presente articolo. Se il computer Exchange Server rinominato funziona correttamente sotto tutti i punti di vista, è preferibile ricostruire il server Exchange utilizzando la procedura di ricostruzione riportata di seguito, poiché questa configurazione non è supportata e può provocare dei problemi in futuro.

Per risolvere il problema eseguendo la rimozione manuale di Exchange Server

  1. Arrestare tutti i servizi Exchange Server ed eseguire un backup completo del computer.

  2. A seconda della versione di Exchange Server in uso, consultare il seguente articolo della Knowledge Base:

    • Se si utilizza Exchange Server 2007, consultare la procedura descritta nella documentazione di Exchange Server 2007, "Come rimuovere completamente Exchange 2007 da un server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=79246.

    • Se si utilizza Exchange Server 2003, consultare la procedura descritta nell'articolo 833396 della Microsoft Knowledge Base "Rimozione di Exchange Server 2003 dal computer" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396.

    • Se si utilizza Exchange 2000 Server, consultare la procedura descritta nell'articolo 260378 della Microsoft Knowledge Base "XADM: Rimozione manuale di un'installazione di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378.

  3. Se si utilizza Exchange 2000 Server o Exchange Server 2003 e se questo è l'unico server di Exchange presente nell'organizzazione, consultare la procedura descritta nell'articolo 273478 della Microsoft Knowledge Base "Rimozione completa di Exchange 2000 o Exchange 2003 da Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=273478.

Per risolvere il problema ricostruendo il computer Exchange Server

  1. Spostare le cassette postali, le cartelle pubbliche, i connettori e i ruoli in un altro computer Exchange Server dell'organizzazione.

  2. Disinstallare Exchange Server dal computer.

  3. Per eliminare il Registro di sistema di un computer su cui è in esecuzione Exchange Server 2003 o Exchange Server 2000, consultare le relative sezioni delle procedure descritte nei seguenti articoli della Microsoft Knowledge Base:

    • 833396, "Rimozione di Exchange Server 2003 dal computer" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833396.

    • 260378, "XADM: Rimozione manuale di un'installazione di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260378.

    In alternativa, è possibile ricostruire il sistema operativo.

  4. Installare Exchange Server nel computer.

  5. Spostare le cassette postali, le cartelle pubbliche, i connettori e i ruoli nel nuovo computer Exchange Server.

Per ulteriori informazioni sulla distribuzione dei cluster di Exchange Server 2003, consultare l'articolo 810986 della Microsoft Knowledge Base "Criteri di supporto Microsoft per le installazioni di Exchange Server su un servizio cluster di terze parti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810986.


Rilevata una discrepanza con il nome del server di Exchange in Active Directory
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo Name e l'attributo cn di un server (oggetto della classe msExchExchangeServer) corrispondono. Se Exchange Server Analyzer rileva una differenza tra questi attributi, verrà visualizzato un messaggio di errore.

Il valore cn dell'oggetto server viene utilizzato in Exchange per identificare il server internamente e utilizzare il valore Name per identificare il server nell'interfaccia utente di Gestore di sistema di Exchange.

Questo errore può verificarsi se un amministratore ha modificato il valore Name utilizzando strumenti quali ADSI Edit (Active Directory Service Interfaces) o LDP (ldp.exe). Questa operazione modifica il nome del server nell'interfaccia utente e crea una discrepanza che genera eventi di archiviazione e di supervisore sistema. È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit, lo strumento LDP o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto server in Active Directory.

    Gli attributi CN e Name sono reperibili in:

    Copia codice
    CN=Configuration,CN=Services,CN=Microsoft Exchange,CN=Organization,CN=Administrative Groups,CN=Administrative group,CN=Servers,CN=Server

  2. Per l'attributo Name, immettere un nuovo valore di stringa che corrisponde al valore dell'attributo CN.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo della Microsoft Knowledge Base 260745 "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


Sono presenti più reti tra il server di Active Directory e il server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) WIN32_PingStatus nello spazio dei nomi root\cimv2 per determinare il valore della chiave RouteRecord. La chiave RouteRecord contiene un record dei passaggi intermedi (ad esempio, il numero di router) tra il server di Exchange e il controller del dominio. Exchange Server Analyzer conta il numero di router elencati nella chiave RouteRecord. Se Exchange Server Analyzer rileva più di un router nell'elenco, verrà visualizzato un messaggio di errore.

Un servizio directory di Active Directory® ottimale è un servizio che garantisce la comunicazione del computer Exchange Server con un controller di dominio o un server di catalogo globale sulla sua subnet. Questo errore indica che il computer Exchange Server comunica con i controller di dominio su reti che sono più lontane di un hop.

Per risolvere il problema

  1. Verificare la topologia della rete e valutare nuovamente il posizionamento dei server Active Directory.

  2. Controllare i registri eventi sull'Exchange Server e il controller di dominio per verificare se eventi legati alla rete a cui si ha accesso indicano problemi potenziali.

  3. Analizzare la struttura del sito Active Directory. Se la rete non è partizionata in maniera conforme a questa specifica, è necessario partizionarla in più siti Active Directory.

Per ulteriori dettagli sulla classe WMI Win32_PingStatus, consultare l'articolo di MSDN "Win32_PingStatus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=33549 (informazioni in lingua inglese).

Per ulteriori informazioni sulla struttura del sito Active Directory, consultare "Designing the Site Topology" all'indirizzo http://go.microsoft.com/fwlink/?linkid=33551 (informazioni in lingua inglese).


Troppi hop
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-07-06

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server di Exchange all'account Postmaster o a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi di recapito del messaggio di prova.

Come parte dell'analisi, Microsoft Exchange Server Analyzer Tool esegue una query nella proprietà MessageID della classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio nomi root\MicrosoftExchangeV2 dei server attraverso cui passa il messaggio.

Un messaggio può essere instradato attraverso molti server SMTP diversi prima di arrivare a destinazione. I server in questo percorso di instradamento sono denominati hop.

Se il numero di istanze Exchange_MessageTrackingEntry del MessageID specifico aumenta a 30, Microsoft Exchange Server Analyzer Tool visualizzerà un errore.

L'errore indica che probabilmente il messaggio di prova sta viaggiando in un ciclo. Pertanto, Microsoft Exchange Server Analyzer Tool ha interrotto l'esecuzione di query su altre istanze Exchange_MessageTrackingEntry per evitare di creare un ciclo infinito.

L'ulteriore analisi della sezione del registro di verifica messaggi dell'output di Microsoft Exchange Server Analyzer Tool potrà essere di aiuto per stabilire se sussiste una condizione di ciclo.


Configurazione di macchina virtuale non supportata - rilevato server di Exchange non cluster
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se il valore per la chiave Model è impostato su "Virtual Machine".

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_Service per determinare il valore della chiave Started per il servizio cluster di Windows (ClusSvc). Il valore True della chiave Started indica che il servizio cluster è avviato, mentre il valore False indica che non è in esecuzione.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • Il valore della chiave Model è impostato su "Virtual Machine".

  • Il valore della chiave Started indicato per il servizio Cluster è impostato su True.

L'errore indica che il server di Exchange è di tipo cluster eseguito in un ambiente con una macchina virtuale. Questa configurazione non è supportata.

Per risolvere il problema

  1. Creare un cluster fisico e spostarvi le cassette postali dal server di Exchange eseguito nell'ambiente virtuale.

  2. Se è impossibile creare un cluster fisico, correggere l'errore come descritto di seguito:

    1. Spostare le cassette postali da Exchange Server in esecuzione nell'ambiente virtuale in un computer autonomo Exchange Server non virtuale.

    2. Spostare le cartelle pubbliche e trasferire i ruoli eseguiti dal server cluster di Exchange come richiesto.

    3. Disinstallare Exchange Server dalla macchina virtuale per rimuoverne le autorizzazioni ed eseguirne la rimozione dall'infrastruttura di Exchange Server e dal servizio directory di Active Directory.

Per ulteriori informazioni sui criteri di supporto per l'esecuzione di Exchange Server 2003 che funzionano in ambienti virtuali, consultare l'articolo 320220 della Microsoft Knowledge Base "Criteri di supporto per Exchange Server 2003 in esecuzione su software di virtualizzazione hardware" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.


Configurazione della macchina virtuale non supportata - Exchange Server 2003 Service Pack 2 o versione successiva non rilevato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Microsoft Windows®) Win32_ComputerSystem per determinare se il valore per la chiave Model è impostato su Virtual Machine.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Exchange 2000 Server. Se il valore di stringa comprende "Version 6.5", il computer esegue Exchange Server 2003. Se il valore di stringa comprende "Version 6.5" e "Service Pack 2", il computer esegue Exchange Server 2003 con Service Pack 2 (SP2).

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • La chiave Model è impostata su "Virtual Machine".

  • Il computer non esegue Exchange Server 2003 con SP2 o versione successiva.

Questo errore indica che Exchange server è una macchina virtuale ma che non è installato Exchange Server 2003 SP2 o versione successiva. Questa configurazione non è supportata.

Per risolvere il problema

  1. Installare Service Pack 2 o versione successiva per Exchange Server 2003.

  2. Consultare l'articolo 320220 della Microsoft Knowledge Base "Criteri di supporto per Exchange Server 2003 eseguito sul software di visualizzazione hardware" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

  3. Se non è possibile applicare Service Pack 2 o una versione successiva, è possibile correggere l'errore nel modo seguente:

    1. Spostare le cassette postali da Exchange Server in esecuzione su Virtual Server 2005 in un computer Exchange Server non virtuale.

    2. Spostare le cartelle pubbliche e trasferire i ruoli eseguiti dal server virtuale di Exchange come richiesto.

    3. Disinstallare Exchange Server dalla macchina virtuale per rimuoverne le autorizzazioni ed eseguirne la rimozione dall'infrastruttura di Exchange Server e dal servizio directory di Active Directory.


Configurazione di macchina virtuale non supportata: non è stato rilevato Virtual Machine Additions
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se il valore della chiave Model è impostato su "Virtual Machine".

Exchange Server Analyzer legge inoltre la seguente chiave del Registro di sistema per determinare se è stato installato Virtual Machine Additions:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

La presenza di questo percorso del Registro di sistema indica che Virtual Machine Additions è stato installato. L'assenza del suddetto percorso indica invece che Virtual Machine Additions non è stato installato.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • Il valore della chiave Model è impostato su "Virtual Machine".

  • Il percorso del Registro di sistema indicato non è presente.

Il messaggio di errore indica che il server di Exchange è una macchina virtuale ma che Virtual Machine Additions non è installato. Questa configurazione non è supportata.

Per installare Virtual Machine Additions

  1. Eseguire un backup del server di Exchange in esecuzione nell'ambiente virtuale.

  2. Installare Virtual Machine Additions utilizzando la console di amministrazione o il sito Web di Virtual Server 2005.

Per ulteriori informazioni sulla modalità di esecuzione di Exchange Server 2003 in un ambiente virtuale, consultare l'articolo 320220 della Microsoft Knowledge Base "Criteri di supporto per Exchange Server 2003 in esecuzione su software di virtualizzazione hardware" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220).


Aggiornamento per l'ora legale disponibile
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-07-30

Microsoft Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore relativo all'attributo versionNumber per ciascun oggetto di Exchange Server. L'attributo versionNumber rappresenta la versione di Exchange Server in esecuzione sul computer.

Exchange Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows® ) CIM_Datafile per determinare il valore della chiave Version per il processo Store.exe.

  • Il valore 7638 per la chiave Version indica Exchange Server 2003 Service Pack 2

  • Il valore 7226 per la chiave Version indica Exchange Server 2003 Service Pack 1

  • Il valore 6944 per la chiave Version indica la versione originale di Exchange Server 2003

  • Un valore compreso tra le versioni precedenti indica che sul server è in esecuzione una versione di aggiornamento rapido del processo Store.exe.

Se Exchange Analyzer determina che il valore della chiave Version per Store.exe su un server che esegue Exchange Server 2003 SP2 è inferiore a 7561 o che su un server che esegue Exchange Server 2003 SP1 è inferiore a 7234, verrà visualizzato un avviso.

Tale avviso indica che il computer Exchange Server esegue Exchange Server 2003 Service Pack 1 o Exchange Server 2003 SP2 senza l'aggiornamento relativo alle modifiche per il passaggio all'ora legale nel 2007.

Senza tale aggiornamento, gli elementi del calendario nei programmi basati su CDO e in Outlook Web Access funzionano come se fosse in vigore l'ora solare durante le settimane in cui è in vigore l'ora legale.

Per risolvere il problema per Exchange Server 2003 SP2

  1. Seguire le istruzioni riportate nell'articolo 926666 della Microsoft Knowledge Base "Aggiornamento delle modifiche per il passaggio all'ora legale nel 2007 relativo a Exchange 2003 Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=926666.
Per risolvere il problema per Exchange Server 2003 SP1

  1. Seguire le istruzioni riportate nell'articolo 931978 della Microsoft Knowledge Base "Aggiornamento delle modifiche per il passaggio all'ora legale nel 2007 relativo a Exchange 2003 Service Pack 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=931978.


Aggiornamento cumulativo di Windows 2000 SP4 non installato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) per determinare il valore della chiave ServicePackMajorVersion. Exchange Server Analyzer esamina inoltre il seguente valore del Registro di sistema per determinare la versione di Windows in esecuzione sul computer di destinazione:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Se Exchange Server Analyzer determina che nel sistema specificato è in esecuzione un sistema operativo Windows 2000 Server ma non l'aggiornamento cumulativo per Windows 2000 Server Service Pack 4, verrà visualizzato un avviso.

È consigliabile installare i Service Pack e gli aggiornamenti cumulativi più recenti per tutti i prodotti software presenti nell'installazione di Exchange.

Per risolvere il problema

  1. Aggiornare tutti i controller di dominio e i server di catalogo globale in esecuzione in Windows 2000 Server installando l'aggiornamento cumulativo per il Service Pack 4, oltre agli aggiornamenti rapidi e agli aggiornamenti più recenti da Windows Update.

  2. Aggiornare tutti i computer Exchange Server installando l'aggiornamento più recente e l'aggiornamento cumulativo.

Per ulteriori informazioni sull'aggiornamento cumulativo per Windows 2000 SP4, consultare l'articolo 891861 della Micrsoft Knowledge Base, "Raccolta completa di aggiornamenti 1 per Windows 2000 SP4 e problemi noti" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=891861.

Per ulteriori informazioni su come richiedere e installare service pack e aggiornamenti cumulativi di Exchange Server, consultare il sito Web http://go.microsoft.com/fwlink/?LinkId=21573.


URLScan è installato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare se esiste il seguente file nel percorso del server Exchange indicato di seguito:

%WINDOWSPATH%\\SYSTEM32\\INETSRV\URLSCAN\URLSCAN.DLL

La presenza di Urlscan.dll indica che lo strumento URLScan è installato nel server Exchange. Se Exchange Server Analyzer rileva che lo strumento URLScan è installato in un server Exchange, verrà visualizzato un messaggio di configurazione ottimale.

URLScan è un filtro ISAPI che consente agli amministratori del sito Web di limitare il tipo di richieste HTTP elaborate dal server. Il blocco di richieste HTTP specifiche impedisce a richieste potenzialmente pericolose di raggiungere il server e di provocare danni.

Quando si esegue URLScan su un server Exchange, è necessario assicurarsi che Urlscan.ini sia regolato in modo corretto per il ruolo del server Exchange. Per migliorare la protezione del server Exchange, è necessario modificare il file di configurazione Urlscan.ini per la rimozione delle funzionalità estranee. Per personalizzare il file Urlscan.ini per il ruolo specifico del computer Exchange Server 2003, è necessario rimuovere i comandi nella sezione [AllowVerbs] del file Urlscan.ini. Tuttavia, per garantire la corretta funzionalità, assicurarsi che siano inclusi i comandi consigliati per il ruolo del computer. Se in un singolo computer sono richieste funzioni basate sul Web, è necessario unire i requisiti appropriati della sezione [AllowVerbs].

È possibile modificare il file Urlscan.ini basato sul ruolo del computer Exchange Server 2003 utilizzando le informazioni sul modello Urlscan di Exchange Server 2003 incluse nell'articolo 823175 della Microsoft Knowledge Base "Reolazione ottimale e problemi noti durante l'utilizzo dello strumento Urlscan in ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823175.

Per ulteriori informazioni su URLScan, consultare "UrlScan Security Tool" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=24490 (informazioni in lingua inglese).

Per ulteriori informazioni sull'utilizzo di URLScan in un ambiente Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 309677, "XADM: Regolazione ottimale e problemi noti durante l'utilizzo della procedura guidata IIslockD in ambiente Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=309677.

  • 309508, "XCCC: Configurazioni di IISlockD e URLscan in ambiente Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=309508.

  • 325965, "Lo strumento URLScan può provocare problemi in Outlook Web Access" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325965.

  • 326444, "Configurazione dello strumento URLScan" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=326444.


USERVA è impostato in modo errato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-09-19

Microsoft® Exchange Server Analyzer Tool esegue una query in tre classi Microsoft WMI (Strumentazione gestione Windows®) per determinare la quantità di memoria fisica nel computer Exchange Server e la quantità di spazio di indirizzi virtuali assegnata ai processi in modalità utente eseguiti sul computer Exchange Server. Nella tabella seguente sono illustrate le classi e le chiavi valutate da Microsoft Exchange Server Analyzer Tool.

Classe in cui è eseguita la query | Chiavi in cui è eseguita la query | Descrizione
Win32_OperatingSystem | MaxProcessMemorySize | Numero massimo di KB di memoria che possono essere assegnati a un processo.
Win32_ComputerSystem | TotalPhysicalMemory | Numero di byte di memoria RAM (Random Access Memory) installati nel computer.
Win32_Service | Started | Stato del servizio. Il valore True indica che il servizio è in esecuzione, mentre il valore False indica che il servizio non è in esecuzione.

Microsoft Exchange Server Analyzer Tool legge inoltre la seguente voce del Registro di sistema per determinare la versione di Microsoft Windows in esecuzione sul computer Exchange Server:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che sul computer Exchange Server è in esecuzione Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer Exchange Server esegue Windows 2000 Server, mentre il valore 5.2 indica che il computer Exchange Server esegue Windows Server™ 2003.

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il conteggio per l'attributo homeMDBBL dell'oggetto archivio cassette postali (msExchPrivateMDB). Il conteggio risultante è il numero di cassette postali rilevate nel computer Exchange Server.

Se Exchange Server Analyzer rileva che tutti i criteri seguenti sono "true", verrà visualizzato un avviso:

  • Il computer Exchange Server è in esecuzione su Windows Server 2003.

  • Il valore di TotalPhysicalMemory è maggiore di 1073741824.

  • Il valore di MaxProcessMemorySize è uguale a 3145600.

  • Il servizio cluster (ClusSvc) presenta il valore True per Win32_Service\Started oppure il computer Exchange Server contiene più di 20 cassette postali.

Questo avviso indica che il computer Exchange Server non è configurato correttamente per un utilizzo ottimale della memoria virtuale. Nello specifico, l'opzione di avvio /USERVA=3030 non è presente nel file Boot.ini del computer Exchange Server. L'aggiunta di questa opzione potrebbe fornire un migliore livello di scalabilità e di prestazioni.

Windows Server 2003 include il supporto per due opzioni di avvio nel file Boot.ini, /3GB e /USERVA, che consentono di regolare l'assegnazione e l'utilizzo di memoria e dello spazio di indirizzi della memoria. Indipendentemente dalla quantità di memoria fisica nel sistema, in Windows viene utilizzato uno spazio di indirizzi virtuali pari a 4 GB: 2 GB sono assegnati a processi in modalità utente quali, ad esempio, le applicazioni, e 2 GB a processi in modalità kernel, quali, ad esempio, il sistema operativo e i driver in modalità kernel. Su sistemi che dispongono di 1 GB o più di memoria fisica, queste due opzioni di avvio possono essere utilizzate per assegnare una quantità maggiore di memoria alle applicazioni (3 GB) e una quantità minore al sistema operativo (1 GB). Su un computer Exchange Server, lo spazio aggiuntivo di indirizzi virtuali consente di ridurre la quantità di frammentazione della memoria nello spazio di indirizzi virtuali del processo dell'archivio informazioni. L'opzione /3GB viene utilizzata per rendere effettiva la modifica di questa assegnazione. L'opzione viene immessa nel file Boot.ini del sistema e diventa effettiva al riavvio. L'opzione dovrebbe essere utilizzata solo per i server di Exchange con almeno 1 GB di memoria in cui è installato uno dei seguenti sistemi operativi:

  • Microsoft Windows Server 2003 Standard Edition

  • Microsoft Windows Server 2003 Enterprise Edition

  • Microsoft Windows Server 2003 Datacenter Edition

Importante:
L'opzione /3GB non dovrebbe essere utilizzata su Windows 2000 Server dal momento che non è supportata e ciò potrebbe provocare un arresto anomalo dell'applicazione o del sistema operativo. Inoltre, l'opzione /3GB è supportata solo nei suddetti sistemi operativi quando viene installato almeno 1 GB di memoria fisica. L'opzione /3GB, infine, non dovrebbe essere utilizzata sui server Active Directory (ovvero sui controller di dominio e sui server di catalogo globale) in esecuzione su Windows Server 2003 Standard Edition.

L'opzione /USERVA è nuova in Windows Server 2003. La sua funzione è quella di offrire un miglior livello di controllo sulla divisione dello spazio di indirizzi virtuali tra processi in modalità utente e processi in modalità kernel. L'opzione dovrebbe essere utilizzata solo per applicazioni che la supportano, quali, ad esempio, Microsoft Exchange Server 2003, e con i valori specifici supportati dalle applicazioni. Se utilizzata su sistemi Microsoft Exchange Server 2003, il valore dell'opzione /USERVA dovrebbe essere sempre pari a 3030 (ad esempio, /USERVA=3030). L'impostazione di questo valore fa in modo che debbano essere allocati altri 40 MB al sistema operativo e consente di aggiungere un maggior numero di utenti senza utilizzare tutte le risorse di sistema disponibili.

Per correggere questo errore su Windows Server 2003

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  2. Selezionare la scheda Avanzate.

  3. Nell'area Avvio e ripristino fare clic su Impostazioni. Verrà visualizzata la finestra di dialogo Avvio e ripristino.

  4. Nell'area Avvio sistema fare clic su Modifica. Questa operazione consente di aprire il file Boot.ini di Windows con Blocco note.

  5. Nella sezione [Operating Systems] aggiungere le seguenti opzioni alla riga di avvio: /3GB /USERVA=3030

  6. Salvare le modifiche e chiudere Blocco note.

  7. Per rendere effettiva la modifica, fare clic su OK due volte per chiudere le finestre di dialogo aperte, quindi riavviare il computer che esegue Exchange Server.

Per ulteriori informazioni sull'utilizzo delle opzioni di avvio /3GB e /USERVA, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 297812, "Utilizzo della funzione di ottimizzazione della RAM 4GT" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297812.

  • 311901, "Effetti dell'ottimizzazione 4GT sulle PTE (Page Table Entry) di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311901.

  • 316739, "Utilizzo congiunto delle opzioni /userva e /3GB per ottimizzare lo spazio in modalità utente impostandolo su un valore compreso tra 2 e 3 GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=316739.

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=815372.


La versione del file Tcpip.sys installata nel computer potrebbe richiedere un aggiornamento rapido
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore impostato per la chiave Version del file Tcpip.sys. Se Exchange Server Analyzer rileva che il valore della chiave Version corrisponde a una versione specifica del file Tcpip.sys, verrà visualizzato un avviso.

Per ulteriori informazioni su tale avviso, seguire le indicazioni fornite nell'articolo 898060 della Microsoft Knowledge Base "L'installazione dell'aggiornamento della protezione MS05-019 o di Windows Server 2003 Service Pack 1 potrebbe causare l'interruzione della connettività di rete tra client e server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060.


Rilevata configurazione di macchina virtuale
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se il valore per la chiave Model è impostato su "Virtual Machine".

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_Service per determinare il valore della chiave Started per il servizio cluster di Windows (ClusSvc). Il valore True per la chiave Started indica che il servizio Cluster è in esecuzione. Il valore False indica che il servizio non è in esecuzione.

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se il valore della stringa comprende "Version 6.5" e "Service Pack 2", il computer esegue Exchange Server 2003 con Service Pack 2 (SP2).

Infine, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se Virtual Machine Additions è installato:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Se questo percorso di registro è presente, significa che Virtual Machine Additions è installato. In caso contrario, Virtual Machine Additions non è installato.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • Il server di Exchange è in esecuzione come Guest in Microsoft Virtual Server 2005.

  • Sul server di Exchange è in esecuzione Exchange Server 2003 con Service Pack 2 o versioni successive.

  • Il server di Exchange non è un server cluster.

  • Virtual Machine Additions per Virtual Server 2005 è stato installato nel server di Exchange.

Per l'esecuzione di questa configurazione sono necessari alcuni requisiti che Exchange Server Analyzer non riesce a rilevare. Pertanto si consiglia di consultare il seguente articolo per informazioni sul supporto e sull'ottimizzazione di questa configurazione prima di eseguire Exchange Server 2003 in un ambiente Virtual Server 2005:

320220 della Microsoft Knowledge Base "Criteri di supporto per Exchange Server 2003 eseguito sul software di visualizzazione hardware" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.


Memoria virtuale frammentata
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2007-02-15

Lo strumento Microsoft Exchange Analyzer interroga la classe di Strumentazione gestione Windows (WMI) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un errore di evento 9582 di MSExchangeIS.

Se Exchange Analyzer rileva che un evento 9582 è stato registrato nelle ultime 24 ore, verrà visualizzato un errore.

Questo errore indica che la memoria virtuale necessaria per eseguire il server di Exchange è frammentata.

Nei sistemi Microsoft Windows a 32 bit sono disponibili due tipi di memoria:

  • Memoria fisica La quantità di memoria effettiva installata nel sistema

  • Spazio di indirizzi della memoria virtuale Uno spazio di memoria virtuale da 4 GB

Indipendentemente dalla quantità di memoria fisica installata nel sistema, la dimensione totale dello spazio di indirizzi virtuali è sempre la stessa: 4 GB. Sebbene la situazione non sia identica per tutte le applicazioni a 32 bit, per quanto riguarda Exchange Server lo spazio di indirizzi virtuali equivale alla memoria virtuale, ovvero i due termini vengono utilizzati in modo interscambiabile.

Durante l'esecuzione delle normali operazioni, l'Archivio di Exchange procederà ad allocare, utilizzare e deallocare la memoria virtuale più volte. Se la memoria virtuale viene allocata, utilizzata e deallocata frequentemente, è possibile che si verifichi una frammentazione della memoria stessa. La frammentazione della memoria virtuale è analoga alla frammentazione del file system che può verificarsi nel tempo. Dopo poco, i segmenti di memoria virtuale allocati non sono più contigui e le prestazioni cominciano a risentirne. Nel caso del file system, è disponibile un'applicazione che consente di eseguirne la frammentazione. Nella maggior parte dei casi, la deframmentazione del file system può essere eseguita mentre il sistema è in linea e in uso. In caso di frammentazione della memoria virtuale, non è disponibile uno strumento di deframmentazione e, per risolvere il problema, è necessario arrestare e riavviare il servizio Archivio informazioni di Microsoft Exchange oppure riavviare il sistema.

Per risolvere il problema:

  • La frammentazione della memoria virtuale può essere provocata da software di terze parti eseguito nei processi archivio/inetinfo. Verificare di disporre dei driver aggiornati per le applicazioni di terze parti.

  • Utilizzare lo strumento Registri e avvisi sulle prestazioni per monitorare il contatore Totale byte di blocchi grandi liberi di VM per l'oggetto prestazioni MSExchangeIS. Utilizzare i dati raccolti tramite questo contatore per determinare l'intervallo di tempo migliore, incluso nelle successive 36 - 72 ore, per spegnere e riavviare il server.

Nota:
Se si tratta di un server cluster, arrestare e riavviare il nodo passivo prima di spostarvi le risorse cluster per assicurarsi che lo spazio di indirizzi della memoria virtuale di destinazione sia libero.
  • Se il problema persiste dopo il riavvio, considerare la disattivazione del software di terze parti.

  • Valutare quindi l'opportunità di spostare parte delle cassette postali degli utenti su un altro server onde ridurre il carico del server e tentare di risolvere il problema. Per ulteriori informazioni, consultare Spostare le cassette postali degli utenti su un server diverso.

Per ulteriori informazioni

  • Per ulteriori informazioni sull'evento MSExchangeIS 9852, vedere "Events and Errors Message Center: Event Details", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83209.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere Risoluzione dei problemi relativi alle prestazioni di Microsoft Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alla frammentazione della memoria virtuale in Microsoft Exchange Server 2003 e in Exchange 2000 Server, consultare l'articolo 325044 della Microsoft Knowledge Base "How to troubleshoot virtual memory fragmentation in Exchange Server 2003 and Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.

  • Per ulteriori informazioni sull'ottimizzazione dell'utilizzo della memoria virtuale, consultare l'articolo 815372 della Microsoft Knowledge Base "How to optimize memory usage in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, vedere Spostare le cassette postali degli utenti su un server diverso.


Virtual Server 2005 R2 o versione successiva non rilevato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per Vssrvc.exe, il processo rappresentato dal servizio Virtual Server incluso in Microsoft Virtual Server 2005. Se Exchange Server Analyzer rileva che il valore della chiaveVersion di Vssrvc.exe è uguale a 1.1.465.0, verrà visualizzato un messaggio di errore.

Il messaggio di errore indica che il server di Exchange è in esecuzione come Guest in un ambiente Microsoft Virtual Server 2005 in cui non è in esecuzione Virtual Server 2005 R2 o versione successiva. Questa configurazione non è supportata. Exchange Server 2003 con Service Pack 2 o versione successiva è supportato solo come Guest in un ambiente virtuale quando è in esecuzione Microsoft Virtual Server 2005 R2 o versione successiva.

Per risolvere il problema

  1. Consultare l'articolo 320220 della Microsoft Knowledge Base "Criteri di supporto per Exchange Server 2003 eseguito sul software di visualizzazione hardware" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

  2. Installare Microsoft Virtual Server 2005 R2 o versione successiva. Per ulteriori informazioni su Microsoft Virtual Server 2005 R2, visitare il sito Web di Microsoft Virtual Server 2005 R2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34938.

  3. Se non è possibile installare Virtual Server 2005 R2 o versione successiva, risolvere il problema come descritto di seguito:

    1. Spostare le cassette postali da Exchange Server in esecuzione su Virtual Server 2005 in un computer Exchange Server non virtuale oppure in un computer Exchange Server virtuale in esecuzione su Virtual Server 2005 R2.

    2. Spostare le cartelle pubbliche e trasferire i ruoli eseguiti dal server virtuale non supportato di Exchange come richiesto.

    3. Disinstallare Exchange Server dal macchina virtuale non supportato per non concedere l'autorizzazione ed eseguire la rimozione dall'infrastruttura di Exchange Service e da Active Directory.


Lunghezza coda ricerca virus superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-27

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Virus Scan Queue Length dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che il novantesimo valore percentile per il contatore Virus Scan Queue Length è maggiore di 10 durante l'intervallo di tempo di prova, verrà visualizzato un messaggio di errore.

Il contatore di prestazioni Virus Scan Queue Length indica il numero corrente di richieste in attesa accodate per la ricerca virus.

Questo messaggio di errore può indicare problemi di prestazioni correlati a:

  • Riduzione delle prestazioni del server, generalmente causata da un collo di bottiglia della CPU.

  • Carico del server superiore al normale.

  • Motore di ricerca virus obsoleto.

  • Motore di ricerca virus configurato in modo errato.

Per risolvere il problema, procedere come segue:

  • Cercare gli aggiornamenti del motore di ricerca virus.

  • Si consiglia di reinstallare il software antivirus.

  • Esaminare la configurazione del motore di ricerca virus per verificare la corretta configurazione thread, esclusioni a livello dei file e così via. Consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&k.

  • Utilizzare lo strumento Performance Monitor (Perfmon.msc) per determinare se il collo di bottiglia è causato da un maggiore carico sul server o da dimensioni limitate del server. Se il carico sul server è aumentato, identificare e ridurre l'origine del carico. Se le risorse del server sono insufficienti, aumentarle o spostare gli utenti su un altro server.

Rimozione dei colli di bottiglia del processore

È possibile rimuovere i colli di bottiglia del processore dal server Exchange in più modi.

  • Innanzitutto, controllare le applicazioni o le attività che causano il carico sul server. Verificare che il tempo processore utilizzato dall'applicazione sia corretto e che non rappresenti un problema.

  • Se un'applicazione non Exchange non è importante per il server, eseguire tale applicazione su un server diverso. Se è possibile eseguire l'applicazione su un server diverso, spostare anche i ruoli del server su un altro computer. Ad esempio, se il processo Inetinfo sta utilizzando quantità elevate di tempo di CPU, è possibile aggiungere server front-end responsabili del lavoro di protocollo eseguito da Inetinfo. È inoltre possibile spostare l'accesso a cartelle pubbliche su un server di cartelle pubbliche dedicato. Infine, se un server esegue un numero elevato di espansioni di liste di distribuzione, è possibile ridurre l'utilizzo del tempo di CPU spostando l'espansione della lista di distribuzione su un server di espansione di liste di distribuzione dedicato.

  • Se possibile, aggiungere al server ulteriori processori o sostituire quelli esistenti con processori più veloci. Attivare inoltre la tecnologia di hyper-threading, se è supportata dai processori. È possibile attivare la tecnologia di hyper-threading configurando il BIOS di sistema. Per ulteriori informazioni, vedere la Guida in linea del produttore del computer.

  • Se non è possibile aumentare la potenza di elaborazione, ridurre il carico sui processori. Per ridurre l'effetto complessivo sul server, assicurarsi che le attività con utilizzo intensivo di I/O, CPU o di memoria vengano eseguite al di fuori del normale orario di lavoro.

  • Assicurarsi che le attività che richiedono un utilizzo intensivo della CPU (ad esempio le attività di backup o di manutenzione) vengano eseguite in orari con scarso traffico e che tali attività vengano eseguite in modo gestito. Gestire un'attività significa impostare diversi tempi di avvio e, preferibilmente, di fine per ciascuna attività. Gestendo la manutenzione e il backup dei database o dei gruppi di archiviazione, inoltre, si riduce l'effetto delle attività che utilizzano una quantità elevata di risorse.

Ulteriori informazioni

  • Per una panoramica di Exchange Server e della ricerca di virus, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Per ulteriori informazioni sulla ricerca di virus ed Exchange Server, consultare l'articolo 285667 della Microsoft Knowledge Base "XADM: Nozioni fondamentali su Understanding Virus Scanning API 2.0 in Exchange 2000 Server SP1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667.

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, consultare Spostare le cassette postali degli utenti su un server diverso.


Lunghezza coda ricerca virus superiore alla soglia di avviso
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Virus Scan Queue Length dell'oggetto prestazioni MSExchangeIS per analizzare i dati delle prestazioni.

Se Exchange Server Analyzer determina che il novantesimo valore percentile per il contatore Virus Scan Queue Length è maggiore di 5 durante l'intervallo di tempo di prova, verrà visualizzato un avviso.

Il contatore di prestazioni Virus Scan Queue Length indica il numero corrente di richieste in attesa accodate per la ricerca virus.

Questo avviso indica che nel server può verificarsi un problema di prestazioni. I problemi di prestazioni possono essere correlati a:

  • Riduzione delle prestazioni del server, generalmente causata da un collo di bottiglia della CPU.

  • Carico del server superiore al normale.

  • Motore di ricerca virus obsoleto.

  • Motore di ricerca virus configurato in modo errato.

Per risolvere il problema, procedere come segue:

  • Cercare gli aggiornamenti del motore di ricerca virus.

  • Considerare l'opportunità di reinstallare il software antivirus.

  • Esaminare la configurazione del motore di ricerca virus per verificare la corretta configurazione thread, esclusioni a livello dei file e così via. Consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Utilizzare lo strumento Performance Monitor (Perfmon.msc) per determinare se il collo di bottiglia è causato da un maggiore carico sul server o da dimensioni limitate del server. Se il carico sul server è aumentato, identificare e ridurre l'origine del carico. Se le risorse del server sono insufficienti, aumentarle o spostare gli utenti su un altro server.

Rimozione dei colli di bottiglia del processore

È possibile risolvere i colli di bottiglia del processore sul server Exchange in più modi:

  • Innanzitutto, controllare le applicazioni o le attività che causano il carico del server. Verificare che il tempo processore utilizzato dall'applicazione sia corretto e che non rappresenti un problema.

  • Se un'applicazione non Exchange non è importante per il server, eseguire tale applicazione su un server diverso. Se possibile, spostare anche i ruoli del server su altri computer. Ad esempio, se il processo Inetinfo sta utilizzando quantità elevate di tempo di CPU, è possibile aggiungere server front-end responsabili del lavoro di protocollo eseguito da Inetinfo. È inoltre possibile spostare l'accesso a cartelle pubbliche su un server di cartelle pubbliche dedicato. Infine, se un server esegue un numero elevato di espansioni di liste di distribuzione, è possibile ridurre l'utilizzo del tempo di CPU spostando l'espansione della lista di distribuzione su un server di espansione di liste di distribuzione dedicato.

  • Se possibile, aggiungere al server ulteriori processori o sostituire quelli esistenti con processori più veloci. Attivare inoltre la tecnologia di hyper-threading, se è supportata dai processori. È possibile attivare la tecnologia di hyper-threading configurando il BIOS di sistema. Per ulteriori informazioni, vedere la Guida in linea del produttore del computer.

  • Se non è possibile aumentare la potenza di elaborazione, ridurre il carico sui processori. Per ridurre l'effetto complessivo sul server, assicurarsi che le attività con utilizzo intensivo di I/O, CPU o di memoria vengano eseguite al di fuori del normale orario di lavoro.

  • Assicurarsi che le attività che richiedono un utilizzo intensivo della CPU (ad esempio le attività di backup o di manutenzione) vengano eseguite in orari con scarso traffico e che tali attività vengano eseguite in modo gestito. Gestire un'attività significa impostare diversi tempi di avvio e preferibilmente tempi di fine per ciascuna attività. Gestendo la manutenzione e il backup dei database o dei gruppi di archiviazione, inoltre, si riduce l'effetto delle attività che utilizzano una quantità elevata di risorse.

Ulteriori informazioni

  • Per una panoramica di Exchange Server e della ricerca di virus, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Per ulteriori informazioni sulla ricerca di virus ed Exchange Server, consultare l'articolo 285667 della Microsoft Knowledge Base "XADM: Nozioni fondamentali su Virus Scanning API 2.0 in Exchange 2000 Server SP1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=285667.

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, consultare Spostare le cassette postali degli utenti su un server diverso.


Errore del punto di montaggio dei volumi: Windows Server 2003 SP1 non installato
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare l'esistenza del driver Mountmgr.sys.

Exchange Server Analyzer legge il seguente valore del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul server di Exchange: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Un valore CurrentVersion corrispondente a 5.0 indica che il server di Exchange è in esecuzione su Microsoft Windows 2000 Server. Un valore CurrentVersion corrispondente a 5.2 indica che il server di Exchange è in esecuzione su Microsoft Windows Server™ 2003.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster (ClusSvc). Il valore TRUE indica che il servizio cluster è avviato, mentre il valore FALSE indica che non è in esecuzione.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • Il computer Exchange Server è in esecuzione su Windows Server 2003.

  • Windows Server 2003 SP1 non è installato.

  • Exchange Server viene eseguito in un ambiente cluster.

  • I punti di montaggio dei volumi sono presenti.

L'avviso indica che se l'ambiente del nodo cluster di Exchange viene aggiornato a Windows Server 2003 SP1, sarà necessario anche l'aggiornamento menzionato nella seguente sezione. Se non viene eseguito tale aggiornamento, infatti, potrebbero verificarsi errori dei punti di montaggio dei volumi.

Per risolvere il problema

  • Installare l'aggiornamento menzionato nell'articolo 898790 della Microsoft Knowledge Base "I punti di montaggio dei volumi sui dischi in un cluster di server potrebbero essere temporaneamente non disponibili dopo l'installazione di Windows Server 2003 Service Pack 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790.


Il servizio Windows Firewall è abilitato sul server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio Windows Firewall (SharedAccess). Il valore True indica che il servizio Windows Firewall è abilitato su questo server di Exchange.

Se Exchange Server Analyzer determina che il servizio Windows Firewall è abilitato su un computer Exchange Server, verrà visualizzato un avviso. Se il servizio Windows Firewall è abilitato, potrebbero verificarsi i seguenti problemi:

  • Potrebbe verificarsi un'interruzione di risposta da parte di alcuni componenti di Exchange Server, quali il servizio di verifica messaggi o la comunicazione RPC (Remote Procedure Call).

  • Potrebbe essere visualizzato un messaggio di errore indicante una condizione di memoria insufficiente.

Per impostazione predefinita, il servizio Windows Firewall viene arrestato quando si installa Microsoft Windows Server™ 2003 Service Pack 1 (SP1). Tuttavia, il servizio verrà eseguito automaticamente se si verificano le seguenti condizioni:

  • Il servizio Windows Firewall viene abilitato manualmente da un amministratore.

  • Il servizio Windows Firewall viene abilitato dopo aver eseguito la Configurazione guidata di protezione.

Per risolvere il problema

  • Verificare le esclusioni del programma.

  • Verificare le esclusioni della porta.

  • Se i client non possono connettersi al server di Exchange, verificare le eccezioni del firewall.

  • Aprire manualmente le porte nel firewall in modo tale da poter eseguire Gestore di sistema di Exchange e il programma di amministrazione di Microsoft Exchange. Quando si aprono le porte nel servizio Windows Firewall, si aumenta la possibilità di accesso al computer da parte di altri programmi. Prima di eseguire questa operazione, pertanto, tenere presente i requisiti di protezione della rete.

  • Arrestare il servizio Windows Firewall.


Il servizio Strumentazione gestione Windows (WMI) non è in esecuzione come LocalSystem
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare i dati del valore ObjectName:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winmgmt

Il valore ObjectName in questo ramo del Registro di sistema indica le impostazioni dell'account del servizio Microsoft WMI (Strumentazione gestione Windows®), noto come servizio Winmgmt. Se Exchange Server Analyzer rileva che i dati del valore ObjectName non corrispondono a LocalSystem, verrà visualizzato un messaggio di errore.

Questo errore indica che il servizio WMI non è in esecuzione su una configurazione supportata. Se si esegue il servizio WMI con un account diverso dall'account LocalSystem, si provocheranno problemi di accesso e di autorizzazione.

Per risolvere questo problema, è necessario configurare il servizio WMI in modo che venga avviato con l'account LocalSystem (SYSTEM).

Per configurare l'account del servizio WMI

  1. Aprire lo snap-in MMC (Microsoft Management Console) Servizi.

  2. Individuare e arrestare il servizio Strumentazione gestione Windows (WMI).

  3. Fare doppio clic sul servizio Strumentazione gestione Windows (WMI).

  4. Nella scheda Connessione della pagina delle proprietà di Strumentazione gestione Windows (WMI) in Accedi come scegliere Account di sistema locale, quindi fare clic su Applica.

  5. In Stato del servizio fare clic su Avvia e quindi su OK.

  6. Chiudere lo snap-in Servizi.


Windows Server 2003 SP1: è necessario un aggiornamento rapido di Outlook Web Access
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query in diverse classi Microsoft WMI (Strumentazione gestione Windows®) per raccogliere le seguenti informazioni:

  • La versione del sistema operativo Microsoft Windows® Server in cui è installato Exchange Server.

  • Se Exchange Server viene eseguito in un cluster.

Se Exchange Server Analyzer determina che le condizioni indicate di seguito sono vere, verrà visualizzato un messaggio di errore:

  • Exchange Server 2003 Service Pack 1 (SP1) è installato.

  • Microsoft Windows Server™ 2003 Service Pack 1 (SP1) è installato.

  • Il servizio cluster è in esecuzione.

  • Il valore Version di Davex.dll è minore di 6.5.7232.

Se si esegue questa configurazione, è necessario scaricare e installare un aggiornamento rapido di Exchange Server prima di installare Windows Server 2003 SP1. Se non si installa l'aggiornamento rapido di Exchange Server, gli utenti di Microsoft Office Outlook® Web Access per Exchange Server 2003 non potranno accedere alle proprie cassette postali. Per gli utenti che dispongono di cassette postali ospitate nei cluster verrà visualizzato il seguente messaggio di errore quando provano a connettersi utilizzando Outlook Web Access:

  • "500 - Errore interno del server"

Questo errore è provocato da alcuni miglioramenti della protezione inclusi in Windows Server 2003 SP1.

Quando un utente prova ad accedere a una cassetta postale usando Outlook Web Access, il protocollo HTTP inoltra richieste all'API del cluster tramite l'account dell'utente connesso. Tuttavia, sono state apportate modifiche alla protezione in Windows Server 2003 SP1. Le restrizioni di protezione per le API che eseguono l'accesso al Registro di sistema remoto sono state modificate, pertanto il tentativo di accesso non verrà eseguito correttamente.

Per correggere questo errore, è necessario scaricare e installare l'aggiornamento rapido di Exchange Server descritto nell'articolo 841561 della Microsoft Knowledge Base "Il messaggio "500 - Errore interno del server" viene visualizzato quando un utente tenta di accedere a un server cluster back-end di Exchange Server 2003 utilizzando Outlook Web Access" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=841561.


È stato rilevato Windows Server 2003 SP1: Configurazione guidata di protezione
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul server di Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Un valore CurrentVersion corrispondente a 5.0 indica che il server di Exchange è in esecuzione su Microsoft Windows 2000 Server. Un valore CurrentVersion corrispondente a 5.2 indica che il server di Exchange è in esecuzione su Microsoft Windows Server™ 2003.

Exchange Server Analyzer legge inoltre il seguente valore del Registro di sistema per determinare il percorso della directory Programmi di Windows:

HKLM\Software\Microsoft\Windows\CurrentVersion\ProgramFilesDir

Exchange Server Analyzer esamina quindi la directory Programmi di Windows per determinare se contiene la cartella \Exchsrvr per Exchange Server.

Infine, Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave ServicePackMajorVersion. Il valore della chiave ServicePackMajorVersion indica la versione del Service Pack di Windows installata nel computer.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • Exchange Server Analyzer determina che sul computer Exchange Server è in esecuzione Windows Server 2003 Service Pack 1.

  • Exchange Server Analyzer determina che Exchange Server 2003 non è installato nel percorso predefinito \Programmi\Exchsrvr.

Questo avviso indica che Exchange Server 2003 non è installato nella cartella Programmi predefinita sul server e che la Configurazione guidata di protezione (SCW) è installata nel server di Exchange. SCW è uno strumento incluso in un componente opzionale di Windows Server 2003 Service Pack 1. Se SCW è installato in un server di Exchange, sarà necessario configurare manualmente la sezione relativa alla protezione di rete.

Nota:
Per installare SCW, è necessario installare prima Windows Server 2003 Service Pack 1. Al termine dell'installazione, aprire Installazione applicazioni nel Pannello di controllo per installare SCW.

SCW consente di ridurre i rischi di sicurezza nei server Windows presentando all'utente una serie di domande progettate per determinare i requisiti operativi di un server. In particolare, SCW consente di eseguire le seguenti attività:

  • Disabilita automaticamente i servizi inutili.

  • Blocca automaticamente le porte inutilizzate.

  • Consente di applicare ulteriori restrizioni di indirizzi oppure restrizioni di protezione per le porte che vengono lasciate aperte.

  • Se necessario, impedisce le estensioni Web inutili di ISS (Internet Information Services).

  • Riduce l'esposizione dei protocolli per SMB (Server Message Block), per LanMan e per il protocollo LDAP (Lightweight Directory Access Protocol).

  • Definisce un criterio di controllo per l'elevato rapporto segnale/rumore.

SCW consente di creare, modificare, applicare o ripristinare un criterio di protezione basato sui ruoli selezionati del server. I criteri di protezione creati mediante SCW sono file XML in cui sono configurati i servizi, la protezione di rete, i valori specifici del Registro di sistema e il criterio di controllo, quando questi vengono applicati. Se necessario, è possibile configurare anche Internet Information Services (IIS).

Oltre a eseguire altre funzioni, SCW include una funzionalità per la protezione della rete in cui è possibile configurare e aggiungere eccezioni a Windows Firewall. Windows Firewall è la nuova versione di un filtro di pacchetti incluso in Windows Server 2003 Service Pack 1. Windows Firewall era stato introdotto con Windows XP Service Pack 2 ed era denominato Firewall connessione Internet.

Se si esegue la funzionalità di protezione di rete in SCW su un server di Exchange in cui Exchange Server non sia installato nel percorso predefinito, si verifica un problema noto. In questa configurazione, l'applicazione del criterio può impedire l'accesso dei client al server di Exchange. Se si utilizza la funzionalità di protezione di rete su un server di Exchange in cui Exchange Server non sia installato nel percorso predefinito, SCW può configurare Windows Firewall in modo tale che blocchi l'accesso alla porta TPC/IP da parte dei processi di Exchange Server, ad esempio, il Supervisore di sistema (Mad.exe), l'Archivio informazioni di Microsoft Exchange (Store.exe), oppure l'Agente di trasferimento messaggi (Emsmta.exe). In questa configurazione, in SCW verrà visualizzato Non trovato accanto a ciascun processo. Se SCW viene eseguito fino al completamento con un processo contrassegnato dal messaggio Non trovato, verrà applicato un criterio di protezione a Windows Firewall che bloccherà l'accesso alla rete da parte di tale processo.

Se i processi bloccati includono uno o più processi di Exchange Server, i client e altri server potrebbero non riuscire ad accedere a Exchange Server. Se si verifica questa condizione, sarà necessario eseguire una delle seguenti procedure per risolvere il problema.

Per risolvere il problema

  • Eseguire una delle seguenti procedure.

    • Utilizzare la funzione di ripristino di SCW per ripristinare un criterio di protezione dopo che è stato applicato. Per ulteriori informazioni su questa procedura, consultare il file della Guida della Configurazione guidata di protezione incluso in Windows Server 2003 Service Pack 1. Per ulteriori informazioni su Windows Server 2003 Service Pack 1 e sulla Configurazione guidata di protezione, consultare Windows Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=45315.

    • In SCW, immettere manualmente il campo del percorso dell'applicazione per specificare la posizione dei file di processo eseguibili di Exchange Server. Per eseguire questa operazione, selezionare il processo contrassegnato da Non trovato e fare clic su Modifica. Si consiglia di eseguire SCW sul server di Exchange per assicurarsi che il percorso di ciascun file di processo eseguibile di Exchange Server sia corretto. Dopo l'approvazione di ciascun file di processo eseguibile, sarà possibile applicare il criterio di protezione di SCW ed Exchange Server dovrebbe disporre dell'accesso di rete necessario per funzionare correttamente.

Per ulteriori informazioni su Windows Server 2003 Service Pack 1 e sulla Configurazione guidata di protezione, consultare Windows Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=45315.


File XESE.DLL presente
Articoli su Microsoft Exchange Server Analyzer > Exchange Server >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per un file denominato Xese.dll.

Se Exchange Server Analyzer consente di ottenere un valore Version per questo file, significa che il file esiste e verrà visualizzato un messaggio di errore.

Alcuni programmi antivirus basati su ESE utilizzano un'interfaccia non supportata tra l'archivio di informazioni di Exchange ed ESE (Extensible Storage Engine ). Quando si utilizza questo tipo di software, si corre il rischio di danneggiare il database e perdere dati, qualora si verifichino errori nell'implementazione del software.

Durante l'installazione, il programma antivirus basato su ESE modifica il servizio Archivio informazioni di Microsoft Exchange, in modo che dipenda dal servizio del programma antivirus basato su ESE. Questo garantisce che il servizio del programma antivirus basato su ESE venga avviato prima del servizio Archivio informazioni di Microsoft Exchange. Quando viene avviato il programma antivirus basato su ESE, la versione di Ese.dll inclusa in Exchange Server viene temporaneamente rinominata Xese.dll e la versione di Ese.dll del programma antivirus basato su ESE sostituisce il file originale. Dopo che viene caricata la versione di Ese.dll del programma antivirus basato su ESE, la versione inclusa in Exchange Server viene rinominata Ese.dll e il servizio Archivio informazioni di Microsoft Exchange completa il processo di avvio.

Per risolvere questo avviso

  1. Si consiglia di non utilizzare implementazioni non Microsoft di ESE su computer Exchange Server. Ai clienti che si rivolgono al Servizio Supporto Tecnico Clienti Microsoft può venire chiesto di disattivare il programma antivirus basato su ESE per aiutare a identificare i problemi, ma i clienti sono liberi di riattivare il software dopo che è stata correttamente diagnosticata la causa principale del problema.

  2. Il programma antivirus basato su ESE più utilizzato è Antigen per Microsoft Exchange di Sybari Software. Microsoft e Sybari concordano che la disattivazione di Sybari Antigen è un corretto passaggio in una procedura di risoluzione di problemi per riuscire a determinare la causa dei problemi stessi. Per contattare Sybari Software, visitare il relativo sito Web all'indirizzo http://www.sybari.com.

    Nota:
    Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli indirizzi Web sono soggetti a modifiche senza preavviso.

  3. È inoltre consigliabile utilizzare programmi antivirus che supportano l'interfaccia VSAPI (Virus Scanning Application Programming Interface), conosciuta anche come AVAPI (AntiVirus API).

Per ulteriori informazioni sull'esecuzione di software antivirus in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=.

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=.


Hardware
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente all'hardware. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere avvisi, messaggi di errore e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi all'hardware.


La versione del BIOS è obsoleta
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_BIOS per determinare il valore delle chiavi SMBIOSBIOSVersion e ReleaseDate. Il valore restituito rappresenta il numero di versione e la data di rilascio del BIOS installato nel computer. Exchange Server Analyzer esamina inoltre la classe WMI (Strumentazione gestione Windows®) Win32_ ComputerSystem per determinare il valore della chiave Model.

Se Exchange Server Analyzer rileva che il valore di ReleaseDate indica una versione obsoleta da più di un anno e che la chiave Model contiene una delle seguenti stringhe, verrà visualizzato un avviso:

  • ProLiant DL320

  • ProLiant DL320 G2

  • ProLiant DL320 G3

  • ProLiant DL360

  • ProLiant DL360 G2

  • ProLiant DL360 G3

  • ProLiant DL360 G4

  • ProLiant DL380

  • ProLiant DL380 G2

  • ProLiant DL380 G3

  • ProLiant DL380 G4

  • ProLiant DL560

  • ProLiant DL570 G3

  • ProLiant DL580

  • ProLiant DL580 G2

  • ProLiant DL580 G3

  • ProLiant DL585 G1

  • ProLiant ML350

  • ProLiant ML350 G2

  • ProLiant ML350 G3

  • ProLiant ML350 G4

  • ProLiant ML370

  • ProLiant ML370 G2

  • ProLiant ML370 G3

  • ProLiant ML370 G4

  • ProLiant ML530

  • ProLiant ML530 G2

  • ProLiant ML570

  • ProLiant ML570 G2

  • ProLiant ML750

Per correggere questo errore e per ulteriori informazioni sul reperimento e l'aggiornamento di una nuova versione del BIOS, consultare il sito Web "Downloads" di Hewlett-Packard all'indirizzo http://h18023.www1.hp.com/support/files/server/us/romtabl.html (informazioni in lingua inglese).

Per ulteriori informazioni sui server ProLiant di Hewlett-Packard, consultare il sito Web di Hewlett-Packard all'indirizzo http://www.hp.com.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Il BIOS del server Dell PowerEdge è obsoleto
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_BIOS per determinare il valore della chiave SMBIOSBIOSVersion. Il valore restituito rappresenta il numero di versione del BIOS installato nel computer. Exchange Server Analyzer esamina inoltre la classe WMI (Strumentazione gestione Windows®) Win32_ ComputerSystem per determinare il valore della chiave Model.

Se Exchange Server Analyzer rileva che la chiave Model contiene una delle seguenti stringhe e SMBIOSBIOSVersion non è la versione più recente del modello, verrà visualizzato un avviso:

  • PowerEdge 2400

  • PowerEdge 2450

  • PowerEdge 2500

  • PowerEdge 2550

  • PowerEdge 2600

  • PowerEdge 2650

  • PowerEdge 2800

  • PowerEdge 2850

  • PowerEdge 3250

  • PowerEdge 4300

  • PowerEdge 4350

  • PowerEdge 4400

  • PowerEdge 4600

  • PowerEdge 6300

  • PowerEdge 6350

  • PowerEdge 6400

  • PowerEdge 6450

  • PowerEdge 6600

  • PowerEdge 6650

  • PowerEdge 6800

  • PowerEdge 6850

  • PowerEdge 7150

  • PowerEdge 7250

  • PowerEdge 8450

Per correggere questo errore e per ulteriori informazioni sul reperimento e sull'aggiornamento di una versione più recente del BIOS, consultare il sito Web "Downloads" di Dell all'indirizzo http://support.euro.dell.com/it/it/index.asp?referrer=http://support.euro.dell.com/it/it/filelib/index.aspx&segment=DHS.

Per ulteriori informazioni sui server Dell PowerEdge, visitare il sito Web di Dell all'indirizzo http://www.dell.com.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


È disponibile un aggiornamento del BIOS
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_BIOS per determinare il valore della chiave SMBIOSBIOSVersion. Il valore restituito rappresenta il numero di versione e la data di rilascio del BIOS installato nel computer. Exchange Server Analyzer esamina inoltre la classe WMI Win32_ComputerSystem per determinare il valore della chiave Model. Se Exchange Server Analyzer determina che il computer è un sistema IBM X445 con una versione del BIOS precedente a REJT48A, verrà visualizzato un errore.

Per correggere questo errore e per ulteriori infromazioni sul reperimento e l'aggiornamento di una nuova versione del BIOS, consultare il sito Web di IBM "Flash BIOS update (DOS update package) with RSA I and RSA II EXA support - IBM eServer xSeries 445" all'indirizzo http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089 (informazioni in lingua inglese).

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Scheda di interfaccia di rete del cluster abilitata per DHCP
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per determinare il valore della chiave DHCPEnabled per tutte le interfacce di rete nel cluster. Se Exchange Server Analyzer rileva il valore di DHCPEnabled impostato su True in un'interfaccia di rete privata, verrà visualizzato un messaggio di errore.

Il valore True per la chiave WMI (Strumentazione gestione Windows®) DHCPEnabled indica che un'interfaccia di rete è configurata per utilizzare DHCP (Dynamic Host Configuration Protocol). Microsoft non supporta l'utilizzo di DHCP sui nodi della rete privata in un server cluster di Windows. Inoltre, per i nodi di reti pubbliche che fanno parte di un server cluster di Windows®, si consiglia di utilizzare indirizzi IP statici. È sconsigliato, invece, l'utilizzo della configurazione dinamica di reti pubbliche tramite DHCP, in quanto il mancato rinnovo di un lease DHCP può compromettere il corretto funzionamento del cluster. Infine, la configurazione dinamica di reti private tramite DHCP non è supportata e non deve essere mai eseguita.

Per risolvere questo problema, riconfigurare le interfacce di rete delle reti private per utilizzare un indirizzo IP statico. Si consiglia di selezionare gli indirizzi compresi nei seguenti intervalli:

  • 10.0.0.0 - 10.255.255.255 (Rete di classe A)

  • 172.16.0.0 - 172.31.255.255 (Rete di classe B)

  • 192.168.0.0 - 192.168.255.255 (Rete di classe C)

Per risolvere il problema

  1. In Connessioni di rete fare clic con il pulsante destro del mouse sulla connessione di rete utilizzata per la scheda di rete privata, quindi fare clic su Proprietà.

  2. Fare clic su Protocollo Internet (TCP/IP), quindi su Proprietà.

  3. Nella scheda Generale immettere un indirizzo IP statico che non si trovi nella stessa subnet o nella stessa rete delle schede di rete pubbliche. Un esempio di indirizzo IP valido per le schede private è 10.10.10.10 sul nodo 1 e 10.10.10.11 sul nodo 2 con una subnet mask di 255.0.0.0. Se la rete pubblica utilizza la rete 10.x.x.x e la subnet mask 255.0.0.0, scegliere una subnet e un IP di rete privata diversi.

  4. Verificare che nella casella Gateway predefinito non sia stato impostato alcun valore.

  5. Verificare che nella casella Utilizza i seguenti indirizzi di server DNS non sia stato definito alcun valore.

  6. Fare clic su Avanzate.

  7. Verificare che nella scheda DNS non sia stato definito alcun valore. Verificare che le caselle di controllo Registra nel DNS gli indirizzi di questa connessione e Utilizza il suffisso DNS di questa connessione nella registrazione DNS non siano selezionate.

  8. Verificare che nella scheda WINS non sia stato definito alcun valore. Fare clic su Disabilita NetBIOS su TCP/IP.

  9. Quando si chiude la finestra di dialogo, verrà visualizzato il seguente prompt. Se viene visualizzato questo prompt, fare clic su Sì: questa connessione presenta un indirizzo WINS primario vuoto. Continuare?

  10. Fare clic su OK per salvare le modifiche.

  11. Completare i passaggi precedenti su tutti gli altri nodi del cluster.

Per ulteriori informazioni sulla configurazione di rete ottimale per i cluster dei server Windows, consultare il documento "Server Clusters: raccomandazioni per la configurazione della rete su Windows 2000 e Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34304.

Per ulteriori informazioni sulla corretta configurazione heartbeat del cluster, consultare l'articolo 258750 della Microsoft Knowledge Base "Configurazione consigliata per la rete "heartbeat" privata su un server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


Il suffisso DNS primario del computer non corrisponde al nome di dominio completo (FQDN) del dominio in cui si trova
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2006-05-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare il suffisso DNS primario di questo Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\NV Domain

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Domain

Se Exchange Server Analyzer rileva che i valori di NV Domain e Domain non corrispondono, verrà visualizzato un avviso.

Ilvalore NV Domain del Registro di sistema contiene il suffisso DNS primario del computer. Il valore Domain del Registro di sistema contiene il dominio DNS primario del computer. Per impostazione predefinita, il nome di dominio completo (FQDN) della parte di suffisso DNS primario di un computer deve essere uguale al nome del dominio del servizio directory di Active Directory® in cui si trova il computer. Nomi non corrispondenti possono impedire la registrazione DNS corretta. Se il nome del dominio DNS del computer non corrisponde al nome del dominio Active Directory, a intervalli di 22 minuti verranno visualizzati messaggi di errore nel Registro eventi di sistema del computer. Questa condizione è nota come spazio dei nomi disgiunto. Per consentire suffissi DNS primari diversi, è possibile creare un elenco con restrizioni dei suffissi consentiti creando un attributo di Active Directory denominato msDS-AllowedDNSSuffixes nel contenitore dell'oggetto dominio.

La procedura per assicurarsi di aver configurato correttamente uno spazio dei nomi disgiunto dipende dal sistema operativo utilizzato per i controller di dominio Active Directory.

  • Se nei controller di dominio Active Directory viene eseguito un sistema operativo della famiglia Microsoft Windows® 2000 Server, è possibile utilizzare la procedura descritta nell'articolo 258503 della Microsoft Knowledge Base "Errori della registrazione DNS 5788 e 5789 quando il nome dominio DNS e il nome del dominio Active Directory non corrispondono" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=258503 per configurare correttamente lo spazio dei nomi. Suddetto articolo include le procedure per correggere uno spazio dei nomi disgiunto non intenzionale e per configurare correttamente uno spazio dei nomi disgiunto nel caso ve ne sia uno intenzionale.

  • Se nei controller di dominio Active Directory si esegue Microsoft Windows Server™ 2003 e lo spazio dei nomi disgiunto non è intenzionale, è possibile utilizzare la prima procedura descritta di seguito per correggere lo spazio dei nomi non intenzionale e risolvere questo errore. Se nei controller di dominio Active Directory si esegue Windows Server 2003 e lo spazio dei nomi disgiunto è intenzionale, è possibile utilizzare la seconda procedura descritta di seguito per eseguire una configurazione corretta.

Per eseguire la seconda procedura riportata di seguitp, sarà necessario utilizzare un editor di Active Directory come ADSI Edit o lo strumento LDP (ldp.exe). Per ulteriori informazioni sulla modifica di Active Directory con lo strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Windows Server 2003, Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Se lo spazio dei nomi disgiunto non è intenzionale

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Viene visualizzata la finestra di dialogo Proprietà del sistema.

  2. Selezionare la scheda Nome computer.

  3. Fare clic su Cambia. Viene visualizzata la finestra di dialogo Cambiamenti nome computer.

  4. Fare clic su Altro. Viene visualizzata la finestra di dialogo Suffisso DNS e nome NetBIOS del computer.

  5. Selezionare la casella di controllo Cambia suffisso DNS primario quando cambia l'appartenenza al dominio.

  6. Fare clic su OK per salvare le modifiche e nuovamente su OK per uscire dalla finestra di dialogo Cambiamenti nome computer.

  7. Fare clic su OK per chiudere la finestra di dialogo Proprietà del sistema e riavviare il computer per rendere effettive le modifiche.

Se lo spazio dei nomi disgiunto è intenzionale

  1. Utilizzare la procedura precedentemente illustrata per assicurarsi che la casella di controllo Cambia suffisso DNS primario quando cambia l'appartenenza al dominio sia deselezionata.

  2. Modificare l'attributo msDS-AllowedDNSSuffixes di Active Directory nel contenitore dell'oggetto dominio. È possibile eseguire questa operazione utilizzando ADSI Edit e attenendosi alla seguente procedura:

    1. Fare doppio clic sulla partizione della directory di dominio per il dominio che si desidera modificare.

    2. Fare clic con il pulsante destro del mouse sull'oggetto contenitore dominio, quindi scegliere Proprietà.

    3. Nell'editor degli attributi, nella casella Attributi fare doppio clic sull'attributo msDS-AllowedDNSSuffixes.

    4. Nella finestra di dialogo Editor di stringa multivalore, nella casella Valore da aggiungere digitare un suffisso DNS, quindi fare clic su Aggiungi.

    5. Dopo avere aggiunto tutti i suffissi DNS per il dominio, fare clic su OK.

    6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del dominio.

    7. Ripetere questi passaggi per configurare più domini in modo analogo.

Per ulteriori informazioni sull'attributo msDS-AllowedDNSSuffixes, consultare la Guida in linea e supporto tecnico di Windows Server 2003. Per ulteriori informazioni sulla procedura utilizzata per modificare questo attributo, consultare "Step-by-Step Guide to Implementing Domain Rename" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=41359 (informazioni in lingua inglese).


È disponibile un aggiornamento critico del BIOS
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_BIOS per determinare il valore della chiave SMBIOSBIOSVersion. Il valore della chiave SMBIOSBIOSVersion rappresenta la versione del BIOS installato nel server. Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave Model. Il valore della chiave Model rappresenta le informazioni sul modello hardware fornite dal produttore dell'hardware.

Se Exchange Server Analyzer rileva che il valore per la chiave Version si trova su un server 42B la cui chiave Model inizia per eserver xSeries 445, verrà visualizzato un messaggio di errore. Questo errore indica che il BIOS del server IBM xSeries 445 deve essere aggiornato.

È stato rilevato un problema noto con la versione 42B del firmware BIOS che può provocare il danneggiamento dei dati. Il problema è limitato ai sistemi X445 con installato il BIOS 42B (versione 1.15). Il problema viene corretto con il BIOS 45A. È necessario aggiornare il BIOS su questo server alla versione 45A o successive al più presto possibile.

Per risolvere il problema

  1. Per ulteriori informazioni su questo problema, consultare il sito Web di IBM "Flash BIOS Update (DOS update package) - IBM eServer xSeries 445" all'indirizzo http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54089#BIOSVersion (informazioni in lingua inglese).

  2. Per informazioni, consultare il file Leggimi per l'aggiornamento del BIOS all'indirizzo ftp://ftp.software.ibm.com/pc/pccbbs/pc_servers/39y4888.txt.

  3. Scaricare l'aggiornamento del BIOS dal sito Web di IBM all'indirizzo http://www-307.ibm.com/pc/support/site.wss/license.do?filename=pc_servers/26r0663.exe.

  4. Aggiornare il BIOS sul server.

Per ulteriori informazioni sull'installazione di questo fondamentale aggiornamento del BIOS, consultare il sito Web di IBM all'indirizzo http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=DSHY-3TEPF6.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


La velocità corrente del processore è inferiore alla velocità massima possibile
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Processor per determinare i valori correnti di MaxClockSpeed e CurrentClockSpeed. Se Exchange Server Analyzer rileva che il valore di CurrentClockSpeed è inferiore al valore di MaxClockSpeed, verrà visualizzato un avviso.

Il valore CurrentClockSpeed corrisponde alla velocità corrente di ciascun processore in megahertz (MHz). Il valore MaxClockSpeed corrisponde alla velocità massima di ciascun processore in megahertz. Se viene visualizzato questo avviso, significa che almeno uno dei processori sul server di Exchange non funziona alla massima velocità. Di seguito sono elencate le cause che potrebbero provocare questo problema:

  1. Exchange Server è installato in un computer che esegue Microsoft® Windows® 2000 Server o Windows 2000 Advanced Server e in cui non è installato Windows 2000 Server Service Pack 3. In Windows 2000 Server Service Pack 3 è stato risolto un problema in cui WMI non restituiva i valori corretti di MaxClockSpeed o CurrentClockSpeed.

  2. Un'impostazione di risparmio energia errata nel BIOS del server di Exchange potrebbe aver forzato il processore a funzionare a velocità ridotta in modalità di risparmio energia.

Per risolvere il problema

  1. Se Exchange Server è installato su un computer che esegue Windows 2000 Server o Windows 2000 Advanced Server e in cui non è installato Windows 2000 Server Service Pack 3, è preferibile installare il Service Pack più recente. Per ulteriori informazioni sui più recenti Service Pack per Windows 2000, consultare il sito Web di Microsoft Windows 2000 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=18353.

  2. Se Exchange Server è installato in un computer che esegue Windows 2000 Server o Windows 2000 Advanced Server e in cui non è installato Windows 2000 Server Service Pack 3 o una versione successiva, verificare le impostazioni BIOS del server di Exchange. È inoltre necessario verificare le impostazioni di risparmio energia nel BIOS e nel Pannello di controllo o in Gestione periferiche.

Per informazioni su come visualizzare e configurare le impostazioni di risparmio energia, del processore e del BIOS di sistema, consultare il produttore dell'hardware.

Per ulteriori informazioni sulle funzioni di risparmio energia di Windows 2000 Server, consultare l'articolo 244806 della Microsoft Knowledge Base "Panoramica del risparmio energia in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=244806.

Per ulteriori informazioni sulle funzioni di risparmio energia in Microsoft Windows Server™ 2003, consultare "Risparmio energia" e "Opzioni risparmio energia" nella Guida in linea e supporto tecnico di Windows Server 2003, che può essere eseguita dal menu di avvio su un computer che esegue Windows Server 2003.

Per ulteriori informazioni sulle funzioni di risparmio energia in Windows Server 2000, consultare gli argomenti "Risparmio energia" e "Opzioni risparmio energia" nella Guida in linea di Windows 2000 Server, che può essere eseguita dal menu di avvio su un computer Windows 2000 Server.


DisableDHCPMediaSense non impostato correttamente su Windows Server 2003
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2006-10-02

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se Media Sense Detection è configurato in modo corretto:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server Analyzer esamina inoltre il seguente valore del Registro di sistema per determinare la versione di Windows in esecuzione sul computer di destinazione:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che sul computer è in esecuzione un sistema operativo Windows® 2000 Server, mentre il valore 5.2 indica che sul computer è in esecuzione un sistema operativo Windows Server™ 2003.

Inoltre, Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per ClusSvc, il servizio cluster di Microsoft Windows. Il valore True indica che il servizio cluster di Windows è in esecuzione, mentre il valore False indica che il servizio non è in esecuzione.

Se Exchange Server Analyzer rileva che il servizio cluster di Windows è in esecuzione su Windows Server 2003 Enterprise Edition o Windows Server 2003 Datacenter Edition e che il valore della chiave del Registro di sistema DisableDHCPMediaSense è impostato su 1, verrà visualizzato un avviso.

Se, durante l'utilizzo del servizio cluster di Windows Server 2003, viene interrotta la connettività di rete, lo stack TCP/IP non verrà scaricato per impostazione predefinita, come in Windows 2000 Server. Di conseguenza, non verrà più richiesto di impostare la chiave DisableDHCPMediaSense del Registro di sistema. In Windows 2000 Server, in caso di interruzione della connettività di rete, lo stack TCP/IP veniva scaricato con la conseguenza che tutte le risorse del cluster che dipendevano dagli indirizzi, incluse quelle di un server virtuale di Exchange, venivano disconnesse. Quando veniva ripristinata la connettività delle reti, veniva ripristinata anche l'impostazione predefinita relativa al rispettivo ruolo di rete (ovvero client e privata). Se si disabilita per impostazione predefinita la funzionalità Media Sense, verrà preservato il ruolo di rete e verranno mantenute in linea tutte le risorse dipendenti dagli indirizzi IP.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Nel riquadro destro fare clic con il pulsante destro del mouse per modificare (impostandolo su 0 o disattivandolo) oppure eliminare il valore DisableDHCPMediaSense del Registro di sistema.

  4. Chiudere l'Editor del Registro di sistema.

  5. Spostare tutte le risorse cluster in un altro nodo oppure disconnetterle. Quindi riavviare il nodo cluster, per rendere effettiva la modifica.

  6. Ripetere il processo in tutti gli altri nodi del cluster che hanno generato questo avviso.

Per ulteriori informazioni sul Registro di sistema di Microsoft Windows, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni su Media Sense Detection e sui cluster Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 254651, "Modifica automatica del ruolo di rete del cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651.

  • 239924, "Disattivazione della funzionalità di rilevamento del supporto per TCP/IP in Windows Me" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924.

  • 242430, "Scheda di rete non disponibile durante le configurazione del cluster con un cavo di crossover" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430.

  • 278007, "Funzionalità disponibili nei cluster di Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007.


DisableDHCPMediaSense non impostato correttamente su Windows 2000 Server
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se Media Sense Detection è configurato in modo corretto:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\DisableDHCPMediaSense

Exchange Server Analyzer analizza anche la voce del Registro di sistema indicata di seguito per determinare la versione di Windows in esecuzione sul computer specificato:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue Microsoft Windows® 2000 Server, mentre il valore 5.2 indica che il computer esegue Microsoft Windows Server 2003.

Inoltre, Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per ClusSvc, il servizio cluster di Microsoft Windows. Il valore True indica che il servizio cluster di Windows è in esecuzione, mentre il valore False indica che il servizio non è in esecuzione.

Se Exchange Server Analyzer rileva che il servizio cluster di Windows è in esecuzione su Windows 2000 Advanced Server o Windows 2000 Datacenter Server e se la chiave del Registro di sistema DisableDHCPMediaSense è presente e il suo valore non è impostato su 1, verrà visualizzato un avviso.

Quando si utilizza il servizio cluster di Windows Server Windows 2000, in caso di interruzione della connettività di rete, lo stack TCP/IP viene scaricato. Ciò significa che tutte le risorse del cluster, incluse quelle di un server virtuale di Exchange, che dipendevano dagli indirizzi IP venivano disconnesse. Quando veniva ripristinata la connettività delle reti, veniva ripristinata anche l'impostazione predefinita relativa al rispettivo ruolo di rete (client e privata). Per impedire che si verifichi questo, si raccomanda di disattivare Media Sense Detection su tutti i cluster basati su server Windows 2000. Media Sense Detection è disattivato automaticamente su tutti i cluster basati su server Windows 2003.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\Tcpip\Parameters

  3. Fare clic con il pulsante destro del mouse su Parameters, quindi su New | DWORD value. Digitare DisableDHCPMediaSense per il nome, quindi premere INVIO.

  4. Nel riquadro destro fare doppio clic su DisableDHCPMediaSense e digitare 1 nel campo Dati valore.

  5. Chiudere l'editor del Registro di sistema.

  6. Spostare tutte le risorse cluster in un altro nodo oppure disconnetterle. Quindi riavviare il nodo cluster, per rendere effettiva la modifica.

  7. Ripetere il processo in tutti gli altri nodi del cluster che hanno generato questo avviso.

Per ulteriori informazioni sul Registro di sistema di Microsoft Windows, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni su Media Sense Detection e sui cluster Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 254651, "Modifica automatica del ruolo di rete del cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=254651.

  • 239924, "Disattivazione della funzionalità di rilevamento del supporto per TCP/IP in Windows Me" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=239924.

  • 242430, "Scheda di rete non disponibile durante le configurazione del cluster con un cavo di crossover" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=242430.

  • 278007, "Funzionalità disponibili nei cluster di Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=278007.


Il timeout del disco non è impostato sul valore predefinito
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore del timeout del disco è diverso da quello predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk\TimeOutValue

Se Exchange Server Analyzer rileva che il valore di TimeOutValue è presente e configurato con un valore diverso da 10 e il server non è parte di un cluster, verrà visualizzato un messaggio di configurazione non predefinita. Se Exchange Server Analyzer rileva che il valore di TimeOutValue è presente e configurato con un valore diverso da 20 e il server è parte di un cluster, verrà visualizzato un messaggio di configurazione non predefinita.

Il timeout del disco è un'impostazione del Registro di sistema che definisce il tempo di attesa di Microsoft Windows® prima che un disco rigido risponda a un comando. In un sistema non cluster questa chiave non è presente e per tutti i dischi viene utilizzato un valore predefinito di 10 secondi. In un cluster Windows la chiave è presente e impostata su un valore predefinito di 20 secondi. Se l'intervallo di timeout è maggiore del valore di questa impostazione del Registro di sistema, Windows visualizzerà un messaggio di errore e interromperà l'accesso al disco. A volte è possibile impostare questa chiave su un valore maggiore se si esegue un software di accesso multipath al disco. Il software multipath consente di connettere più percorsi fisici (ad esempio, fibre ottiche) a una singola unità disco per creare una ridondanza. Il software multipath gestisce le diverse connessioni fisiche in modo che Windows possa gestire solo un singolo handle al disco.

L'installazione di schede bus host (HBA, Host Bus Adapter) o altri dispositivi di archiviazione può provocare la creazione e la configurazione di questa chiave. Quando si installano o si reinstallano questi driver, il valore del Registro di sistema TimeOutValue viene sovrascritto con il valore richiesto da tali driver. Potrebbe essere necessario rivolgersi al produttore del componente hardware per determinare il valore corretto di TimeOutValue per la propria configurazione.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\Disk\TimeOutValue

  3. Nel riquadro destro eliminare il valore di TimeOutValue del Registro di sistema. In alternativa fare doppio clic sulla voce TimeOutValue e impostarla su uno dei valori seguenti:

    • In un server non cluster impostare il valore su 10.

    • In un server cluster impostare il valore su 20.

    • Se il produttore del componente hardware consiglia un valore differente per un sistema cluster o non cluster, utilizzare il valore indicato dal produttore.

  4. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla voce TimeOutValue in sistemi cluster, consultare l'articolo 818877 della Microsoft Knowledge Base "I server cluster possono subire timeout di connessione alle unità dopo l'installazone o l'aggiornamento della funzione Servizio cluster di Windows in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=818877.


L'ordine di ricerca DNS non è stato specificato
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per determinare se è stato impostato un valore per DNSServerSearchOrder. Se il valore di questa chiave su un server di Exchange non è specificato, verrà visualizzato un avviso.

Questo avviso indica che nel computer una o più schede di rete non dispongono di indirizzi IP di server DNS associati. Pertanto, quando si tenta di connettere questo computer a un altro, viene eseguita la trasmissione degli indirizzi IP sulla rete locale. La risoluzione dei nomi sarà più lenta e questo potrebbe rallentare l'esecuzione di Exchange.

È consigliabile immettere l'indirizzo IP di almeno un server DNS valido. Se si dispone di più schede nel computer, verificare che tutte le schede dispongano di almeno un indirizzo IP valido del server DNS.

Per impostare l'indirizzo IP di un server DNS su una scheda di rete

  1. Nella finestra Connessioni di rete fare clic con il pulsante destro del mouse sulla scheda LAN appropriata, quindi scegliere Proprietà.

  2. Nella scheda Generale fare doppio clic su Protocollo Internet (TCP/IP).

  3. Nella scheda Generale della pagina Protocollo Internet (TCP/IP) immettere almeno un indirizzo IP di un server DNS valido, quindi selezionare OK.

Per ulteriori informazioni sulla configurazione del server DNS da utilizzare con Exchange, consultare l'articolo 322856 della Microsoft Knowledge Base "Configurazione del server DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322856.


La connessione heartbeat dispone di un gateway predefinito
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapter per determinare il valore della chiave NetConnectionID. Se il valore della chiave NetConnectionID contiene la stringa Internal o HEART, significa che l'interfaccia è la rete cluster privata (heartbeat).

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_NetworkAdapterConfiguration per determinare se è stato impostato un valore per la chiave DefaultIPGateway. Se è stato impostato, il valore indica che è stato configurato un gateway predefinito per l'interfaccia di rete.

Se Exchange Server Analyzer rileva un valore impostato per la chiave DefaultIPGateway nell'interfaccia di rete utilizzata per la rete heartbeat del cluster, verrà visualizzato un avviso.

Poiché le reti cluster private vengono utilizzate per comunicazioni interne al cluster, non è necessario configurare un gateway predefinito. Per eliminare possibili problemi di comunicazione, si consiglia di rimuovere tutto il traffico di rete non necessario dalla scheda di rete utilizzata per la rete cluster privata.

Per risolvere il problema

  1. Aprire la finestra Connessioni di rete. Fare clic con il pulsante destro del mouse su Risorse di rete e scegliere Proprietà oppure, se l'icona di Risorse di rete non è visualizzata sul desktop, fare clic su Start, Programmi, Accessori, Comunicazioni, quindi su Connessioni di rete.

  2. Nella finestra Connessioni di rete fare clic con il pulsante destro del mouse sulla scheda di rete utilizzata per la rete privata, quindi fare clic su Proprietà.

  3. Selezionare Protocollo Internet (TCP/IP) e fare clic su Proprietà.

  4. Nell'area Utilizza il seguente indirizzo IP, eliminare l'indirizzo IP del gateway predefinito.

  5. Fare clic su OK due volte per salvare le modifiche.

  6. Ripetere i passaggi da 1 a 5 per ciascun nodo nel cluster.

Per ulteriori informazioni sulle impostazioni consigliate per la rete privata in un cluster di server Windows, consultare l'articolo 258750 della Microsoft Knowledge Base "Configurazione "Heartbeat" privata consigliata su server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


La connessione heartbeat dispone di un indirizzo di ricerca DNS
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapter per determinare il valore della chiave NetConnectionID. Se il valore della chiave NetConnectionID contiene la stringa Internal o HEART, significa che l'interfaccia è la rete cluster privata (heartbeat).

Exchange Server Analyzer inoltre esegue una query nella classe WMI Win32_NetworkAdapterConfiguration per determinare se è stato impostato un valore per la chiave DNSServerSearchOrder. Se è stato impostato, il valore indica che è stato configurato un indirizzo di ricerca DNS per l'interfaccia di rete.

Se Exchange Server Analyzer rileva un valore impostato per la chiave DNSServerSearchOrder nell'interfaccia di rete utilizzata per la rete heartbeat di un cluster, verrà visualizzato un avviso.

Poiché le reti cluster private vengono utilizzate per comunicazioni interne al cluster, non è necessario configurare un server DNS. Per eliminare possibili problemi di comunicazione, si consiglia di rimuovere tutto il traffico di rete non necessario dalla scheda di rete utilizzata per la rete cluster privata.

Per risolvere il problema

  1. Aprire la finestra Connessioni di rete. Fare clic con il pulsante destro del mouse su Risorse di rete e scegliere Proprietà oppure, se l'icona di Risorse di rete non è visualizzata sul desktop, fare clic su Start, Programmi, Accessori, Comunicazioni, quindi su Connessioni di rete.

  2. Nella finestra Connessioni di rete fare clic con il pulsante destro del mouse sulla scheda di rete utilizzata per la rete privata, quindi scegliere Proprietà.

  3. Selezionare Protocollo Internet (TCP/IP), quindi scegliere Proprietà.

  4. Fare clic su Avanzate.

  5. Nella scheda DNS selezionare un indirizzo server DNS e fare clic su Rimuovi. Ripetere questo passaggio per ciascun indirizzo server DNS elencato.

  6. Deselezionare le caselle di controllo Registra nel DSN gli indirizzi di questa connessione e Utilizza il suffisso DNS di questa connessione nella registrazione DNS.

  7. Fare clic su OK tre volte per salvare le modifiche.

  8. Ripetere i passaggi da 1 a 7 per ciascun nodo nel cluster.

Per ulteriori informazioni sulle impostazioni consigliate per la rete privata in un cluster di server Windows, consultare l'articolo 258750 della Microsoft Knowledge Base "Configurazione "Heartbeat" privata consigliata su server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


La connessione heartbeat dispone di un indirizzo WINS
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapter per determinare il valore della chiave NetConnectionID. Se il valore della chiave NetConnectionID contiene la stringa Internal o HEART, significa che l'interfaccia è la rete cluster privata (heartbeat).

Exchange Server Analyzer inoltre esegue una query nella classe WMI Win32_NetworkAdapterConfiguration per determinare se è stato impostato un valore per la chiave WINSPrimaryServer. Se è stato impostato, il valore indica che è stato configurato un indirizzo WINS (Windows Internet Name Service) per l'interfaccia di rete.

Se Exchange Server Analyzer rileva un valore impostato per la chiave WINSPrimaryServer nell'interfaccia di rete utilizzata per la rete heartbeat del cluster, verrà visualizzato un avviso.

Poiché le reti cluster private vengono utilizzate per comunicazioni interne al cluster, non è necessario configurare server WINS o utilizzare NetBIOS. Per eliminare possibili problemi di comunicazione, si consiglia di rimuovere tutto il traffico di rete non necessario dalla scheda di rete utilizzata come scheda di rete cluster privata.

Per risolvere il problema

  1. Aprire la finestra Connessioni di rete. Fare clic con il pulsante destro del mouse su Risorse di rete e scegliere Proprietà oppure, se l'icona di Risorse di rete non è visualizzata sul desktop, fare clic su Start, Programmi, Accessori, Comunicazioni, quindi su Connessioni di rete.

  2. Nella finestra Connessioni di rete fare clic con il pulsante destro del mouse sulla scheda di rete utilizzata per la rete privata, quindi fare clic su Proprietà.

  3. Selezionare Protocollo Internet (TCP/IP), quindi scegliere Proprietà.

  4. Fare clic su Avanzate.

  5. Nella scheda WINS selezionare un indirizzo server WINS, quindi fare clic su Rimuovi. Ripetere questo passaggio per ciascun indirizzo WINS elencato.

  6. Nell'area delle impostazioni di NetBIOS, selezionare Disable NetBIOS over TCP/IP.

  7. Fare clic su OK tre volte per salvare le modifiche. Dopo aver fatto clic su OK la prima volta, potrebbe essere visualizzato il prompt riportato di seguito. Se viene visualizzato questo prompt, fare clic su Sì: "questa connessione presenta un indirizzo WINS primario vuoto. Continuare?"

  8. Ripetere i passaggi da 1 a 7 per ciascun nodo nel cluster.

Per ulteriori informazioni sulle impostazioni consigliate per la rete privata in un cluster di server Windows, consultare l'articolo 258750 della Microsoft Knowledge Base "Configurazione consigliata per la rete "heartbeat" privata su un server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


Nell'ordine di binding TCP/IP la connessione heartbeat ha precedenza sulla connessione pubblica
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query in due classi WMI (Strumentazione gestione Windows®) per effettuare le seguenti operazioni:

  • L'esecuzione di una query nella classe WMI Win32_NetworkConfiguration consente di determinare il valore della chiave SettingID per tutte le interfacce di rete nel cluster. Il valore della chiave SettingsID è un GUID che rappresenta una scheda di rete univoca.

  • L'esecuzione di una query nella classe WMI Win32_NetworkAdapter consente di determinare le schede di rete utilizzate per le comunicazioni di rete privata in un cluster di Exchange. La rete privata viene utilizzata per le comunicazioni interne del cluster, tra cui l'heartbeat del cluster.

  • Exchange Server Analyzer esamina, inoltre, il seguente valore del Registro di sistema per determinare l'ordine di binding delle schede di rete:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Linkage\Bind

Il valore Bind del Registro di sistema è un valore multistringa che contiene un elenco di schede di rete in ordine di binding. La prima voce dell'elenco rappresenta la prima scheda di rete associata, la seconda voce rappresenta la seconda scheda di rete nell'ordine di binding e così via.

Se Exchange Server Analyzer determina che la scheda di rete heartbeat del cluster è la prima nell'ordine di binding, verrà visualizzato un avviso.

Per risolvere questo problema, accertarsi che la scheda di rete pubblica costituisca il primo binding all'inizio dell'elenco di binding. Se sono presenti più schede di rete pubblica, accertarsi che la scheda di rete heartbeat privata sia elencata per ultima. Se è elencata per prima, può impedire la corretta installazione dei Service Pack e degli aggiornamenti.

Per risolvere il problema

  1. Nella finestra Connessioni di rete fare clic su Avanzate, quindi scegliere Impostazioni avanzate.

  2. Fare clic sulla scheda Schede e binding.

  3. Nel campo Connessioni, selezionare la scheda di rete privata e utilizzare la freccia GIÙ per spostare questa scheda alla fine dell'elenco.

  4. Ripetere questi passaggi per ciascun nodo nel cluster.

Per ulteriori informazioni sulla configurazione di rete ottimale per i cluster dei server Windows, consultare il documento "Server Clusters: Network Configuration Best Practices for Windows 2000 and Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34304 (informazioni in lingua inglese).

Per ulteriori informazioni sulla corretta configurazione heartbeat del cluster, consultare l'articolo 258750 della Microsoft Knowledge Base "Configurazione consigliata per la rete "heartbeat" privata su un server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


Velocità di rete heartbeat impostata su auto sense/auto detect
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapter per determinare il valore della chiave NetConnectionID. Se il valore della chiave NetConnectionID contiene la stringa Internal o HEART, significa che l'interfaccia è la rete cluster privata (heartbeat).

Exchange Server Analyzer legge inoltre il seguente valore del Registro di sistema per determinare la velocità del collegamento e le impostazioni del duplex della scheda di interfaccia di rete utilizzata per la rete heartbeat del cluster:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\<IDPerifericaSchedaDiRete>\SpeedDuplex

Inoltre, Exchange Server Analyzer legge il seguente valore del Registro di sistema per determinare se il rilevamento automatico della velocità di rete è abilitato:

HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\Ndi\Params\SpeedDuplex\enum\0

Se il valore della chiave0 contiene la stringa AUTO, il rilevamento automatico della velocità di rete è abilitato.

Se Exchange Server Analyzer determina che SpeedDuplex è impostato su 0 e il rilevamento automatico della velocità di rete è abilitato per la rete heartbeat del cluster, verrà visualizzato un avviso.

La comunicazione tra i nodi del server cluster è fondamentale per operazioni cluster senza problemi. Se si utilizza una scheda di interfaccia di rete Ethernet a più velocità per le comunicazioni del cluster e si configura la scheda per rilevare automaticamente la velocità della rete, la scheda potrebbe causare dei problemi all'interno del cluster. Durante il processo di rilevamento, la scheda non può gestire i pacchetti che devono essere nessi in coda. Alcune schede potrebbero attivare inavvertitamente il rilevamento automatico, che potrebbe ripetersi occasionalmente. Pertanto, le comunicazioni vengono messe in coda e la comunicazione viene ritardata. A causa di ritardi di questo tipo i nodi cluster potrebbero non ricevere i pacchetti tempestivamente e si potrebbe verificare il failover prematuro delle risorse cluster. È consigliabile impostare manualmente la rete heartbeat in un cluster a 10 megabit e half-duplex. Questa configurazione garantisce sufficiente larghezza di banda e una comunicazione affidabile.

Per risolvere il problema

  • Configurare la scheda di interfaccia di rete heartbeat su una velocità di collegamento di 10 megabit e le impostazioni del duplex su half-duplex. Poiché i passaggi della configurazione per ciascuna scheda di rete sono differenti, seguire le istruzioni del fornitore dell'hardware per la configurazione corretta della rete heartbeat. La configurazione di queste opzioni potrebbe richiedere un driver aggiornato.

Per ulteriori informazioni sulle impostazioni consigliate per la rete privata in un cluster di server Windows, consultare l'articolo 258750 della Microsoft Knowledge Base "Configurazione "Heartbeat" privata consigliata su server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


La profondità della coda dell'adattatore bus host è impostata su 32
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2006-10-11

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la profondità della coda delle schede HBA installate nel computer Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\elxstor\Parameters\Device\DriverParameter

Se Exchange Server Analyzer rileva che il valore di DriverParameter è impostato su 32, verrà visualizzato un avviso.

Una scheda HBA è un controller del disco per reti SAN (Storage Area Network). La profondità della coda HBA definisce il numero massimo di richieste in attesa in coda. In genere, il valore consigliato per DriverParameter è 128. Tuttavia, questo potrebbe non essere il valore ottimale per la profondità della coda HBA per ogni scheda HBA dei computer Exchange Server. Di conseguenza, è preferibile contattare il produttore delle schede HBA per richiedere il valore ottimale per l'hardware in uso.

Per risolvere il problema

  1. Contattare il produttore dell'hardware per determinare l'impostazione ottimale per le schede HBA in uso.

  2. Controllare le prestazioni del disco utilizzando l'utilità Monitor di sistema di Microsoft Windows®.

  3. Aggiornare l'hardware delle schede HBA con i firmware e i driver più recenti.

Per ulteriori informazioni relative alla struttura e all'ottimizzazione del sistema di archiviazione di Exchange Server, consultare il white paper Microsoft "Ottimizzazione del sistema di archiviazione per Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=49324.


Configurazione di memoria aggiunta a caldo
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2006-02-22

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Computer System per determinare se il server supporta funzionalità per l'aggiunta di memoria a caldo. Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_OperatingSystem per stabilire quanto segue:

  • Se l'opzione /3GB è stata impostata nel file Boot.ini.

  • Se il kernel PAE (Physical Address Extensions, estensioni indirizzo fisico) è stato caricato.

  • Quale edizione del sistema operativo è in esecuzione sul server.

Infine, Exchange Server Analyzer legge la seguente chiave del Registro di sistema per determinare se il parametro di configurazione DynamicMemory è presente e impostato correttamente:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Se Exchange Server Analyzer rileva che tutti i criteri elencati di seguito sono veri, verrà visualizzato un messaggio di errore:

  • Il computer supporta l'aggiunta di memoria a caldo e tale funzionalità è abilitata per impostazione predefinita.

  • Il computer esegue Microsoft Windows Server™ 2003 Enterprise Edition o Windows Server 2003 Datacenter Edition.

  • Il kernel PAE è stato caricato.

  • L'opzione /3GB è stata impostata nel file Boot.ini.

  • Il parametro di configurazione del Registro di sistema DynamicMemory non è stato impostato oppure è stato impostato su un valore pari a 0 o superiore a 3.

Nota:
Se il computer supporta l'aggiunta di memoria a caldo, ma il produttore hardware disabilita tale funzione per impostazione predefinita, verrà visualizzato un avviso anziché un messaggio di errore.

La funzione di aggiunta di memoria a caldo è stata introdotta in Windows Server 2003 Enterprise Edition e in Windows Server 2003 Datacenter Edition per consentire agli amministratori di sistema di aggiungere memoria fisica a un computer senza riavviarlo. Tale funzione risulta di grande utilità nel caso di server che supportano applicazioni di database relazionali che richiedono un uso intensivo della memoria, ad esempio Microsoft SQL Server. Tuttavia, è superflua nel caso di Exchange Server, poiché quest'ultimo non è in grado di utilizzare più di 4 GB di memoria fisica.

Non tutti i computer supportano l'aggiunta di memoria a caldo. Per quelli che la supportano, alcuni produttori hardware abilitano la funzione per impostazione predefinita, mentre altri forniscono appositi controlli all'interno del BIOS (Basic Input Output System). Se, durante il processo di avvio, l'aggiunta di memoria a caldo è abilitata, il kernel del sistema operativo deve preallocare una quantità di spazio sufficiente per gestire in modo adeguato qualsiasi eventuale aggiunta futura di memoria. Pertanto, le risorse del kernel vengono allocate in base alle funzionalità del computer anziché in base a quanto effettivamente installato. La memoria del kernel è estremamente preziosa nei computer che eseguono Microsoft Exchange Server. Dal momento che il kernel può allocare significative quantità di risorse per una memoria che potrebbe non essere mai installata e data la natura della memoria fisica utilizzata da Exchange Server, è possibile ottenere un livello più elevato di prestazioni e scalabilità disabilitando la funzione per l'aggiunta di memoria a caldo. Se si lascia la funzione abilitata, è possibile che il limite massimo della riserva di paging risulti molto al di sotto della soglia prevista. Ciò può determinare un considerevole calo delle prestazioni, blocchi del sistema e, infine, un'interruzione del servizio.

Di seguito sono riportati alcuni esempi di dimensioni massime previste per la riserva di paging (i valori più alti sono preferibili):

  • 240 MB Il computer dispone di 4 GB di memoria fisica e non supporta l'aggiunta di memoria a caldo o tale supporto risulta disabilitato.

  • 210 MB Il computer dispone di 4 GB di memoria fisica, ma è in grado di supportare fino a 32 GB di memoria aggiunta a caldo.

  • 160 MB Il computer dispone di 4 GB di memoria fisica, ma è in grado di supportare fino a 64 GB di memoria aggiunta a caldo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema su computer che eseguono Windows Server 2003 SP1 (Service Pack 1) o versione successiva

  1. Impostare il parametro del Registro di sistema indicato di seguito in modo da disabilitare la funzione di aggiunta di memoria a caldo:

    Percorso

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Valore

    DynamicMemory

    Tipo

    REG_DWORD

    Dati

    0x1
    Nota:
    Il valore di questo parametro di configurazione corrisponde alla quantità, espressa in GB, di memoria fisica indirizzabile, inclusa la memoria aggiunta a caldo, se la memoria fisica installata all'avvio non è di dimensioni maggiori. Se il valore viene impostato su 1, il kernel riserva 1 GB della memoria di sistema oppure la quantità totale di memoria fisica installata all'avvio, scegliendo tra le due opzioni quella che garantisce la maggiore disponibilità di spazio.

  2. Riavviare il computer.
Per risolvere il problema su computer che eseguono Windows Server 2003 senza SP1

  • Contattare il fornitore hardware per verificare se è possibile disabilitare nel BIOS la funzione di aggiunta di memoria a caldo.

  • Se invece non è possibile controllare l'aggiunta di memoria a caldo tramite hardware, si consiglia di eseguire l'aggiornamento a Windows Server 2003 SP1 e attuare la procedura sopra illustrata per l'implementazione del parametro DynamicMemory. Qualora non sia possibile eseguire l'aggiornamento a SP1, l'alternativa consiste nell'impostare l'opzione /NOPAE nel file Boot.ini. In tal modo al computer verrà imposto di non riconoscere una quantità di memoria superiore al limite di 4 GB. L'utilizzo di questa opzione è consigliato su computer che eseguono Windows Server 2003 senza SP1, mentre è sconsigliato nel caso di computer che eseguono SP1 poiché si potrebbe determinare la disabilitazione accidentale di nuove funzioni come, ad esempio, il supporto DEP (Data Execution Prevention).

Ulteriori informazioni

Per ulteriori informazioni sul supporto per l'aggiunta di memoria a caldo in Windows Server 2003, consultare Hot-Add Memory Support in Windows Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=57183 (informazioni in lingua inglese).


Il software Internet SCSI Initiator è obsoleto
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2006-04-03

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_SCSIController per determinare il valore della chiave DriverName per il driver iScsciPrt. Exchange Server Analyzer esegue inoltre query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version elencata nel file del driver iScsciPrt. Se Exchange Server Analyzer rileva un valore di stringa secondaria nella chiave Version del driver iScsciPrt inferiore a 1748, verrà visualizzato un avviso.

iSCSI (Internet small computer system interface) è un metodo basato su protocollo Internet (basato su indirizzi IP) progettato per inviare comandi SCSI (small computer systems interface) che vengono incapsulati in pacchetti IP tramite reti TCP/IP. Poiché iSCSI è basato su indirizzi IP, è possibile trasmettere i dati tramite reti locali LAN, reti WAN e Internet a posizioni di archiviazione remote. I sistemi operativi Microsoft® Windows® visualizzano i dischi rigidi iSCSI in programmi quali Exchange Server 2003 o Exchange 2000 Server come dischi rigidi collegati direttamente al computer Exchange Server.

È consigliabile eseguire con cautela la distribuzione di Exchange Server 2003 o Exchange 2000 Server con iSCSI. Poiché iSCSI utilizza il protocollo di trasporto SCSI per inviare dati di blocchi tramite reti TCP/IP, l'utilizzo di una rete può introdurre componenti che non sono tradizionalmente progettati come percorsi input/output ad elevata velocità. Per aumentare la velocità effettiva, è necessario configurare Exchange Server per aumentare le attività di catching e effettuare dei test per verificare che la latenza che interessa il traffico iSCSI venga ridotta. A meno che non vengano fornite indicazioni diverse dal rivenditore, è consigliabile utilizzare la build più recente disponibile di Microsoft iSCSI Software Initiator.

Per risolvere il problema

  1. Scaricare la versione più recente di Microsoft iSCSI Software Initiator dal Microsoft Download Center all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33817.

  2. Per ulteriori informazioni relative alle note sulla versione, consultare il sito Web di Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=40951.

  3. Consultare il Manuale dell'utente nel sito Web di Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=40963.

  4. Eseguire un backup completo del computer.

  5. Installare l'ultimo aggiornamento della versione.

Per ulteriori informazioni sul supporto iSCSI in Exchange 2000 e Exchange 2003, consultare l'articolo 839686 della Microsoft Knowledge Base, "Supporto per i componenti della tecnologia iSCSI in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839686.

Per ulteriori informazioni sulla tecnologia iSCSI e sul supporto Microsoft della tecnologia iSCSI, visitare il sito Web Microsoft "Microsoft Storage Technologies - iSCSI" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=27514.


I contatori di prestazioni del disco logico e fisico sono disabilitati
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se i contatori di prestazioni del disco logico e fisico sono stati disabilitati:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance\Disable Performance Counters

Se Exchange Server Analyzer rileva che il valore di Disable Performance Counters esiste ed è configurato con un valore pari a 1, verrà visualizzato un avviso.

In un computer server che esegue un sistema operativo Microsoft Windows® vengono pubblicati due tipi di contatori di prestazioni relativi al disco:

  • Quelli utilizzati dal sottosistema delle prestazioni di Microsoft Win32® e da WMI (Strumentazione gestione Windows®).

  • Quelli utilizzati dalle applicazioni già esistenti che chiamano l'API IOCTL_DISK_PERFORMANCE per recuperare le informazioni del contatore numerico.

  • Per impostazione predefinita i contatori di prestazioni utilizzati da Win32 e WMI sono abilitati in Microsoft Windows Server™ 2003 e Windows 2000 Server. Per impostazione predefinita i contatori numerici sono disabilitati in entrambi i sistemi operativi. Se il valore del Registro di sistema Disable Performance Counters, che per impostazione predefinita non è presente in nessuno dei due sistemi operativi, viene aggiunto e configurato con il valore 1, i contatori delle prestazioni di Win32/WMI vengono disabilitati e non verrà eseguita la raccolta di dati relativi alle prestazioni tramite tali contatori.

Il modo più comune per disabilitare i contatori di Win32/WMI è tramite l'utilizzo dello strumento Extensible Counter List (ExCtrLst.exe). Questo strumento grafico, disponibile nei Resource Kit sia di Windows 2000 Server che di Windows Server 2003, consente a un amministratore di abilitare o disabilitare in modo selettivo la pubblicazione degli oggetti prestazioni. Quando ExCtrLst.exe viene utilizzato per disabilitare un oggetto prestazioni, viene aggiunta la voce Disable Performance Counters al Registro di sistema e viene configurata con il valore 1. Se ExCtrLst.exe viene poi utilizzato per riabilitare un contatore disabilitato, il valore di Disable Performance Counters viene impostato su 0. Notare che la voce Disable Performance Counters non viene eliminata.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\Perfdisk\Performance

  3. Nel riquadro destro fare doppio clic su Disable Performance Counters e impostare la voce sul valore 0. In alternativa è possibile eliminare la voce Disable Performance Counters per riabilitare i contatori.

  4. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare un'applicazione per la raccolta dei dati sulle prestazioni.

Per ulteriori informazioni su ExCtrLst.exe, consultare "Exctrlst.exe: Extensible Performance Counter List" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34436 (informazioni in lingua inglese).


È stato rilevato più di un gateway predefinito
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per determinare il conteggio delle istanze della chiave DefaultIPGateway. Ogni scheda di rete pubblica in WMI il proprio indirizzo di gateway predefinito configurato tramite questa chiave. Se Exchange Server Analyzer rileva più di un'istanza configurata della chiave DefaultIPGateway, verrà visualizzato un avviso.

Tale messaggio indica che sono state rilevate più schede di rete e che più di una di tali schede dispone di un gateway predefinito configurato. Se si utilizzano e si configurano più schede di rete con gateway predefiniti separati, è possibile perdere la connettività con i computer in reti remote. Inoltre, è accertato che l'utilizzo di più gateway predefiniti che si collegano a differenti subnet di rete causa problemi con la risoluzione DNS (Domain Name System), il recapito dei messaggi SMTP (Simple Message Transfer Protocol), le query LDAP (Lightweight Directory Access Protocol) e le notifiche di nuovi messaggi di posta ai client Microsoft Office Outlook® 2003. Molti di questi problemi possono impedire l'avvio, l'invio e la ricezione di messaggi di Exchange Server.

È consigliabile rimuovere tutti i gateway predefiniti tranne uno da una delle schede di interfaccia di rete nel computer Exchange Server. I computer Exchange Server sono spesso multihomed, se sullo stesso computer è stato installato Microsoft Internet Security and Acceleration (ISA) Server. Anche quando si esegue Exchange Server e ISA Server sullo stesso computer, non è consigliabile l'utilizzo di più gateway predefiniti. Se Exchange Server e ISA Server non sono installati sullo stesso computer, è consigliabile non rendere multihome un computer Exchange Server.

Per risolvere il problema

  1. Aprire la finestra Connessioni di rete. Fare clic con il pulsante destro del mouse su Risorse di rete e scegliere Proprietà oppure, se l'icona di Risorse di rete non è visualizzata sul desktop, fare clic su Start, Programmi, Accessori, Comunicazioni, quindi su Connessioni di rete.

  2. Nella finestra Connessioni di rete fare clic con il pulsante destro del mouse sulla connessione di rete che contiene il gateway predefinito e scegliere Proprietà.

  3. Selezionare Protocollo Internet (TCP/IP) e fare clic su Proprietà.

  4. Eliminare l'indirizzo IP dal campo Gateway predefinito.

  5. Fare clic su OK due volte per salvare le modifiche.

  6. Ripetere la procedura per tutte le altre connessioni di rete che contengono una voce di gateway predefinito, ad eccezione di quella che si desidera mantenere.

Per ulteriori informazioni relative ai problemi rilevati in computer che utilizzano più gateway predefiniti, consultare l'articolo 159168 della Microsoft Knowledge Base "La presenza di più di un gateway predefinito può provocare problemi di connettività" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159168.

Per ulteriori informazioni sulla configurazione di gateway predefiniti in computer multihomed, consultare l'articolo 157025 della Microsoft Knowledge Base "Configurazione del gateway predefinito nei computer multihomed" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=157025.


Le dimensioni del file di paging sono superiori alla memoria fisica totale
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2007-07-30

Microsoft Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PageFile per determinare il valore della chiave MaximumSize. Questa chiave rappresenta la dimensione massima del file di paging attualmente configurata.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows) Win32_ComputerSystem per determinare il valore della chiave TotalPhysicalMemory. Questo valore rappresenta la quantità di RAM installata nel computer.

Se Exchange Analyzer determina che il valore della chiave MaximumSize della classe Win32_PageFile è superiore a 1,5 volte il valore della chiave Win32_ComputerSystem TotalPhysicalMemory, verrà visualizzato un messaggio di errore.

Il file di paging (pagefile.sys) è un file nascosto sul disco rigido utilizzato da Windows per conservare i dati temporanei quando la quantità di RAM del sistema è insufficiente. Il file di paging è definito anche file di scambio. La memoria virtuale è composta dal file di paging e dalla RAM.

La dimensione consigliata per il file di paging è equivalente a 1,5 volte la quantità di RAM, fino a un valore massimo di 4.095 MB. Significa che la dimensione massima del file di paging che è possibile impostare per ogni volume è 4.095 MB.

Nota:
Per impedire la frammentazione del file di paging, è consigliabile impostare sullo stesso valore la dimensione iniziale e la dimensione massima del file di paging. Se si diminuisce l'impostazione della dimensione iniziale o massima del file di paging, è necessario riavviare il computer per osservare gli effetti di tali modifiche. Normalmente, nel caso di un aumento delle dimensioni, non è necessario riavviare il computer.
Per modificare le impostazioni del file di paging

  1. Fare clic su Start, scegliere Pannello di controllo, quindi fare clic su Sistema.

  2. Nella scheda Avanzate, fare clic su Impostazioni nella sezione Prestazioni .

  3. Nella finestra di dialogo Opzioni prestazioni fare clic su Modifica nella sezione Memoria virtuale della scheda Avanzate.

  4. Nella sezione Unità [etichetta volume] fare clic sull'unità che contiene i file di paging da modificare.

  5. In Dimensioni file di paging per l'unità selezionata fare clic su Dimensioni personalizzate e immettere le dimensioni consigliate per il file di paging, in megabyte, nei campi Dimensioni iniziali (MB) e Dimensioni massime (MB), quindi fare clic su Imposta.

Per ulteriori informazioni sui file di paging, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 197379, "Configurazione dei file di paging a scopo di ottimizzazione e ripristino in Windows Server 2003, Windows 2000 e Windows NT" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=197379.

  • 307973, "HOW TO: Configurare tecniche di ripristino in Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307973.

  • 254649, "Panoramica delle opzioni relative ai file di immagine della memoria di Windows Server 2003, Windows XP e Windows Server 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=254649.

  • 241046, "Impossibile creare un file Memory.dmp nei computer con più di 4 GB di RAM" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=241046.


L'indirizzo del server WINS secondario non è stato specificato
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per determinare se è stato impostato un valore per la chiave WINSSecondaryServer. Se il valore di questa chiave su un server di Exchange non è specificato, verrà visualizzato un avviso.

Exchange Server 2003 ed Exchange 2000 Server presentano diverse dipendenze NetBIOS. Inoltre, i client che eseguono versioni di Microsoft® Outlook® precedenti a Microsoft Office Outlook 2003 richiedono anche la risoluzione dei nomi NetBIOS. Ad esempio, le seguenti funzionalità di Exchange dipendono dalla risoluzione dei nomi NetBIOS:

  • Programmi di installazione di Exchange Server 2003 ed Exchange 2000 Server, soprattutto nei server cluster.

  • Exchange Mailbox Merge Wizard (ExMerge) in un computer che esegue Exchange Server 2003 o Exchange 2000 Server.

  • Modifica della password di una cassetta postale di Exchange Server 2003 o Exchange 2000 Server attraverso Outlook Web Access.

  • Gestore di sistema di Exchange in un computer che esegue Exchange Server 2003 o Exchange 2000 Server.

A seconda della topologia di rete dell'organizzazione, potrebbe essere possibile ignorare tranquillamente questo avviso. Nelle reti costituite da un singolo subnet i broadcast di NetBIOS sono normalmente in grado di gestire i requisiti di risoluzione dei nomi NetBIOS di un'installazione di Exchange.

Nelle organizzazioni di grandi dimensioni, è possibile che la risoluzione dei nomi NetBIOS tramite broadcast non funzioni correttamente. Poiché in genere i broadcast NetBIOS non passano nelle subnet, le reti instradate richiedono un metodo alternativo per la risoluzione dei nomi NetBIOS. Il metodo preferito per eseguire questa operazione è WINS (Windows Internet Name Service). WINS offre un database distribuito per la registrazione e la ricerca di mapping dinamici dei nomi NetBIOS dei computer e dei gruppi utilizzati nella rete. WINS esegue il mapping dei nomi NetBIOS a indirizzi IP ed è stato designato per risolvere i problemi che si verificano a causa della risoluzione dei nomi NetBIOS in ambienti instradati. WINS rappresenta il metodo più adatto per la risoluzione dei nomi NetBIOS in reti instradate che utilizzano NetBIOS su TCP/IP.

Non sono state completamente testate le funzioni e l'operatività di Exchange Server 2003 ed Exchange 2000 Server in un'organizzazione di grandi dimensioni o con subnet priva di WINS. Per la risoluzione dei nomi NetBIOS, è necessario che le società eseguano Exchange in reti instradate o segmentate per WINS. L'esecuzione di Exchange in un ambiente instradato o segmentato senza WINS non è supportata.

È consigliabile installare un ambiente WINS a tolleranza d'errore che includa almeno due server WINS. I server WINS possono agire come server WINS primario o server WINS secondario per un client. La differenza tra server WINS primario e secondario è la priorità con cui i client li contattano. Un server WINS primario è il primo server che viene contattato da un client per eseguire le operazioni di servizio nomi NetBIOS. Il client contatta un server WINS secondario solo quando un server WINS primario non è in grado di soddisfare la richiesta, ad esempio se non è disponibile quando il client effettua la richiesta o se non è possibile risolvere un nome per il client.

Nel caso in cui un server WINS primario non soddisfi una richiesta, il client effettuerà la stessa richiesta al server WINS secondario. Se vengono configurati più di due server WINS per il client, quest'ultimo tenterà di contattare gli altri server WINS secondari fino a che non viene esaurito l'elenco o uno dei server WINS non risponde alla richiesta. Dopo l'utilizzo di un server WINS secondario, il client periodicamente tenta di tornare al server WINS primario per le future richieste di servizio nomi.

È consigliabile configurare almeno un server WINS secondario nei server di Exchange su una rete instradata o segmentata.

Per risolvere il problema

  1. Aprire Connessioni di rete.

  2. Fare clic con il pulsante destro del mouse sulla connessione di rete che si desidera configurare e scegliere Proprietà.

  3. Nella scheda Generale (per una connessione alla rete locale) o nella scheda Rete (per tutte le altre connessioni) selezionare Protocollo Internet (TCP/IP), quindi scegliere Proprietà.

  4. Fare clic su Avanzate, selezionare la scheda WINS, quindi scegliere Aggiungi.

  5. In Server WINS TCP/IP digitare l'indirizzo IP di un server WINS secondario, quindi fare clic su Aggiungi.

  6. Ripetere i passaggi 4 e 5 per ogni indirizzo IP degli altri server WINS che si desidera aggiungere, quindi fare clic su OK. È possibile modificare l'ordine di preferenza dei server WINS mediante i tasti di direzione.

  7. Assicurarsi che la casella Abilita NetBIOS su TCP/IP sia selezionata.

  8. Fare clic su OK per salvare le modifiche.

Per ulteriori informazioni sui requisiti della risoluzione dei nomi NetBIOS per Exchange, consultare l'articolo 837391 della Microsoft Knowledge Base "Exchange Server 2003 ed Exchange 2000 Server richiedono la risoluzione dei nomi NetBIOS per funzionare in modo ottimale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391.


Il server è un Virtual PC
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2007-03-28

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave Model per il computer Exchange Server. Se il valore della chiave contiene la stringa "Virtual Machine", verrà visualizzato un messaggio di errore.

La presenza della stringa "Virtual Machine" indica che il computer Exchange Server viene eseguito su una macchina virtuale Microsoft Virtual PC 200x. Virtual PC 200x è una soluzione di virtualizzazione del software che consente di eseguire più sistemi operativi basati su PC in una workstation. Microsoft non supporta l'esecuzione di versioni di Microsoft Exchange Server su una macchina virtuale o un emulatore. Questo vale per Exchange Server in esecuzione su Microsoft Virtual Server 200x, Microsoft Virtual PC 200x o altri programmi di macchine virtuali di terze parti. Le piattaforme Exchange Server sono state progettate e testate per essere eseguite solo su hardware fisico, in particolare le piattaforme hardware elencate nel catalogo di Windows Server alla pagina http://go.microsoft.com/fwlink/?linkid=17219.

Per risolvere il problema

  1. Spostare le cassette postali dal server di Exchange in esecuzione in Virtual PC 200x su un computer Exchange Server non virtuale.

  2. Se necessario, spostare le cartelle pubbliche e trasferire i ruoli contenuti dal server virtuale di Exchange.

  3. Disinstallare Exchange dal macchina virtuale per non concedere l'autorizzazione ed eseguire la rimozione dall'infrastruttura di Exchange e dal servizio directory di Active Directory®.

Per ulteriori informazioni sul supporto per i computer Exchange Server che funzionano in ambienti virtuali, consultare l'articolo 320220 della Microsoft Knowledge Base "Criteri di supporto per Exchange Server 2003 in esecuzione su software di virtualizzazione hardware" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

Per ulteriori informazioni su Microsoft Virtual PC, consultare la home page "Microsoft Virtual PC" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34663 (informazioni in lingua inglese).


È stato rilevato un errore del disco
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_DiskDrive per determinare il valore della chiave Status per ciascun disco. Se Exchange Server Analyzer determina che il valore della chiave Status per ciascun disco non equivale a OK, verrà visualizzato un messaggio di errore.

La chiave Status visualizza lo stato corrente dell'oggetto disco. È possibile definire diversi stati operativi e non operativi. Gli stati operativi includono:

  • OK

  • Danneggiato

  • Errore prev (un elemento, come un disco rigido abilitato SMART, potrebbe funzionare correttamente, ma prevedere un errore a breve termine).

  • Gli stati non operativi includono:

  • Errore

  • Avvio in corso

  • Arresto in corso

  • Servizio (questo può verificarsi durante la riconfigurazione del mirroring di un disco, il ricaricamento di un elenco di autorizzazioni utente e altre attività amministrative).

La chiave Status è ereditata dalla classe WMI CIM_ManagedSystemElement, che include i seguenti valori:

  • OK

  • Error

  • Degraded

  • Unknown

  • Pred Fail

  • Starting

  • Stopping

  • Service

  • Stressed

  • NonRecover

  • No Contact

  • Lost Comm

In generale, la documentazione per la risoluzione dei problemi relativi agli errori del disco per specifici rivenditori di hardware non viene fornita da Microsoft.

Per risolvere il problema

  1. Verificare tutte le connessioni dei dischi e dei cavi, attendere 10 minuti, quindi controllare il valore Status.

  2. Se il valore restituito non è un valore della modalità manutenzione (ad esempio, il valore non è uguale a Service, è preferibile seguire i passaggi della risoluzione dei problemi del disco raccomandati dal produttore del disco. In alcuni casi, i produttori dei dischi rigidi forniscono software per la risoluzione dei problemi che è possibile installare per analizzare il problema.

Per informazioni generiche relative all'archiviazione in Exchange, consultare "Storage Solutions for Microsoft Exchange 2000 Server" nell'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=1715 (informazioni in lingua inglese).

Per informazioni generali relative all'archiviazione in Microsoft Windows Server™ 2003, consultare "Windows Server 2003 Storage Services" nel Microsoft Windows Server 2003 TechCenter all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33811 (informazioni in lingua inglese).

Per informazioni generali relative all'archiviazione in Microsoft Windows 2000 Server, consultare "Windows 2000 Storage Services" nel sito Web di Windows 2000 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33812 (informazioni in lingua inglese).


Nel server di Exchange sono presenti più di 8 processori
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave NumberOfProcessors. Se Exchange Server Analyzer rileva che il valore di NumberOfProcessors è maggiore di 8, verrà visualizzato un avviso. Tuttavia, se questo server è configurato per utilizzare la tecnologia Hyper-Threading di Intel, questo avviso può essere ignorato. La tecnologia Hyper-Threading consente alle applicazioni multi-thread di eseguire thread in parallelo. La tecnologia Hyper-Threading richiede un sistema informatico con processore Intel® Pentium® 4 che supporta la tecnologia Hyper-Threading e, inoltre, chipset, BIOS e sistema operativo abilitati per la tecnologia HT.

Exchange 2000 Server e Exchange Server 2003 possono utilizzare in modo efficiente solo otto processori su ogni computer. In particolare, il servizio Archivio informazioni di Microsoft Exchange è ottimizzato per un massimo di otto processori.

Per i computer che dispongono di più di 8 processori, si raccomanda di utilizzare il partizionamento hardware per partizionare il computer in più computer da otto o da quattro processori. In alternativa, è possibile configurare l'affinità delle CPU per il processo Archivio informazioni di Microsoft Exchange (Store.exe) per solo otto processori.

Non appena il processo Archivio informazioni di Microsoft Exchange viene limitato a otto processori tramite l'affinità delle CPU o il partizionamento dell'hardware, eseguire l'aggiornamento ai più recenti Service Pack e aggiornamenti cumulativi di Exchange disponibili. Questo è importante soprattutto se si esegue Exchange Server 2003.

Precedentemente, le prestazioni dei server di Exchange hanno mostrato modesti miglioramenti quando i processori presenti nei server back-end sono più di quattro. Con più di otto processori, nel migliore dei casi, le prestazioni presentano un miglioramento trascurabile e talvolta possono anche peggiorare. Il peggioramento delle prestazioni in seguito all'aumento del numero dei processori è diventato più evidente con i tipi di processori utilizzati sui computer più recenti. Con Exchange Server 2003 Service Pack 1, la scalabilità con processori aggiuntivi è notevolmente migliorata. Quando la tecnologia hyper-threading è abilitata, i server a otto processori presentano un miglioramento delle prestazioni del 50% rispetto ai server a quattro processori. L'utilizzo di computer a otto processori per i server back-end è oggi appropriato in diverse circostanze. I server a due processori sono ancora raccomandati per i server front-end.

Come illustrato in precedenza, se questo computer Exchange Server utilizza la tecnologia Hyper-Threading, questo avviso può essere tranquillamente ignorato.

Per correggere questo errore su sistemi che non utilizzano la tecnologia Hyper-Threading

  1. Installare il Service Pack o gli aggiornamenti cumulativi più recenti per Exchange, che possono essere scaricati dalla pagina "Downloads" del sito Web di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=25097.

  2. Impostare l'affinità delle CPU per il servizio Archivio informazioni di Microsoft Exchange (Store.exe) su 8 CPU oppure utilizzare il partizionamento dell'hardware per creare un server di Exchange a otto processori. Contattare il produttore dell'hardware per ulteriori informazioni su come eseguire questa operazione.

Per ulteriori informazioni sulla scalabilità delle risorse di Exchange Server, consultare l'articolo 827281 della Microsoft Knowledge Base "Scalabilità della memoria e della CPU in Exchange 2000 e in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827281.

Per ulteriori informazioni, consultare anche l'articolo 271088 della Microsoft Knowledge Base "XGEN: Ottimizzazione dei server Active Directory di Windows 2000 con sei o otto processori per l'esecuzione in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=271088.

Per ulteriori informazioni sulla tecnologia Hyper-Threading, consultare il sito Web di Intel all'indirizzo http://www.intel.com/info/hyperthreading.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Sul server di Exchange sono disponibili più di 4 GB di memoria
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2006-06-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave TotalPhysicalMemory per ogni computer Exchange Server.

Se Exchange Server Analyzer rileva che il valore di TotalPhysicalMemory è maggiore di 4294967296 ma minore di 6442450944, verrà visualizzato un avviso.

Se Exchange Server Analyzer rileva che il valore di TotalPhysicalMemory è maggiore di 6442450944, verrà visualizzato un messaggio di errore.

Un valore di TotalPhysicalMemory maggiore di 4294967296 indica che nel computer Exchange Server sono installati più di 4 GB di memoria, mentre un valore di TotalPhysicalMemory maggiore di 6442450944 indica che la memoria installata è superiore a 6 GB. Su un computer con 4 o più GB di memoria fisica, Exchange Server non utilizzerà più di 3 GB. Di conseguenza, se il computer esegue esclusivamente Exchange Server, non è di nessuna utilità installare più di 4 GB di memoria.

È importante ricordare che più è la RAM fisica presente nel sistema, maggiore sarà il numero di voci indirizzo kernel del sistema operativo necessarie per eseguire le indispensabili operazioni di mapping dalla memoria virtuale a quella fisica. Si riducono quindi sia le PTE (Page Table Entry) di sistema libere, sia la memoria di riserva di paging disponibile, rendendo il sistema potenzialmente instabile.

Un computer con 8 GB di RAM fisica avrà, ad esempio, 3.000 PTE (Page Table Entry) di sistema libere in meno e subirà una riduzione della dimensione massima della riserva di paging di 30 MB rispetto a un computer con soli 4 GB di RAM fisica.

Si consiglia di adottare una delle seguenti soluzioni:

  • Ridurre la quantità di memoria nel sistema a 4 GB

  • Impostare il parametro BurnMemory nel file Boot.ini in modo da ridurre la memoria fisica a 4 GB come descritto più avanti.

Inoltre, se sono in esecuzione molte applicazioni che richiedono memoria aggiuntiva, è possibile eseguire un aggiornamento rapido di Windows che consente di impedire gli errori dell'archivio informazioni di Exchange che si verificano in presenza di più di 4 GB di RAM disponibili. È consigliabile dedicare un computer alla sola esecuzione di Exchange Server. Per ulteriori informazioni sull'aggiornamento rapido, consultare l'articolo 834628 della Microsoft Knowledge Base, "I dati vengono danneggiati se vengono abilitate le PAE in un computer basato su Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052.

Per risolvere il problema

  1. In Esplora risorse, passare alla partizione di sistema.

  2. Se non è possibile visualizzare il file Boot.ini, nelle Opzioni cartella potrebbe essere impostata l'opzione Nascondi i file protetti di sistema. In questo caso, nella finestra di Esplora risorse fare clic su Strumenti, selezionare Opzioni cartella, quindi scegliere la scheda Visualizzazione. Deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato). Quando viene visualizzata la finestra di avviso, fare clic su Sì.

  3. Quando il file Boot.ini è visualizzato in Esplora risorse, fare clic con il pulsante destro del mouse sul file, scegliere Apri con e fare clic su Blocco note per aprire il file.

  4. Nella sezione [Operating Systems] aggiungere la seguente opzione alla riga di avvio: /BURNMEMORY=<Valore in MB>

    Ad esempio:

    Se si dispone di 6 GB di memoria fisica installata, utilizzare /BURNMEMORY=2048 per ridurre la memoria disponibile a 4 GB. Se si dispone do 8 GB di memoria fisica installata, utilizzare /BURNMEMORY=4096.

  5. Salvare le modifiche e chiudere Blocco note.

  6. Riavviare il computer Exchange Server per rendere effettive le modifiche.

Per ulteriori informazioni sui parametri da utilizzare nel file Boot.ini, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 833721: "Opzioni dei parametri disponibili per i file Boot.ini di Windows XP e di Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052.

  • 102873: "BOOT.INI e convenzioni di denominazione dei percorsi ARC e loro utilizzo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052.


La quantità di spazio disponibile su questo disco logico è inferiore a 3 GB
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2007-03-14

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_LogicalDisk per determinare il valore della chiave FreeSpace per i dischi in cui la chiave Win32_LogicalDisk DriveType è impostata su 3 (che indica un disco locale). Se il valore della chiave FreeSpace per un disco locale di un computer che esegue Exchange Server è inferiore a 3 GB, verrà visualizzato un avviso. È consigliabile che tutti i dischi dei computer Exchange Server che contengono cassette postali siano sempre dotati di almeno il 50% di capacità disponibile.

È fondamentale disporre di spazio su disco sufficiente. In caso di spazio su disco insufficiente, il database passerà alla modalità non in linea. In caso di spazio insufficiente sul disco del log delle transazioni, tutti i database del gruppo di archiviazione passeranno alla modalità non in linea. Spesso è difficile mettere rapidamente a disposizione ulteriore spazio ed eseguire la compattazione non in linea per recuperare spazio può richiedere diverso tempo. Nella maggior parte dei casi, la mancanza di spazio su disco provoca un'interruzione della disponibilità di uno o più database per un periodo di tempo che, in genere, supera la maggior parte degli obiettivi RTO (Recovery Time Objectives) relativi ai tempi di recupero.

Per risolvere il problema

  1. Eliminare dal disco i file non necessari per liberare spazio su di esso.

  2. Se il disco che presenta meno del 50% di spazio disponibile contiene dati che possono essere spostati in modo sicuro in un altro disco (quali cassette postali o il file di paging di Windows), eseguire i passaggi necessari per lo spostamento dei dati.

  3. Aggiungere spazio su disco al computer che esegue Exchange Server.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Per ulteriori informazioni sullo spostamento delle cassette postali tra Exchange 2000 Server e Exchange Server 5.5, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Per ulteriori informazioni sull'impostazione di limiti per le cassette postali con criteri di sistema in Exchange Server 2003, consultare l'articolo 822938 della Microsoft Knowledge Base "HOW TO: Utilizzo di criteri di sistema per configurare i limiti di archiviazione delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938.

Per ulteriori informazioni sull'impostazione di limiti per le cassette postali con criteri di sistema in Exchange 2000 Server, consultare l'articolo 319130 della Microsoft Knowledge Base "HOW TO: Utilizzo di criteri di sistema per configurare i limiti di archiviazione delle cassette postali in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130.

Per ulteriori informazioni su


Questo punto di montaggio presenta meno di 3 GB di spazio disponibile
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Volume per determinare il valore della chiave FreeSpace per i punti di montaggio dei volumi utilizzati dal computer Exchange Server. Se il valore per FreeSpace, diviso per 1.000.000.000 e arrotondato al numero intero più prossimo risulta inferiore a 4, verrà visualizzato un avviso.

Questo avviso indica che sono disponibili meno di 3 GB di spazio di archiviazione per un punto di montaggio dei volumi. In Exchange Server 2003, i punti di montaggio dei volumi (noti anche come punti di giunzione del file system NTFS) sono supportati in qualità di posizione per l'archiviazione dei dati in una configurazione cluster quando Exchange Server 2003 è installato in un computer Microsoft Windows Server™ 2003 Enterprise Edition o su Windows Server 2003 Datacenter Edition. Grazie alla funzione Punti di montaggio dei volumi NTFS, è possibile superare il limite di 26 lettere per unità. Utilizzando i punti di montaggio dei volumi è possibile inserire o montare una partizione di destinazione in una cartella su un altro disco fisico. I punti di montaggio dei volumi non sono utilizzati da programmi quali Exchange Server 2003.

I punti di montaggio non sono supportati nelle seguenti condizioni:

  • Quando vengono utilizzati come posizione per l'archiviazione dei file binari di Exchange Server 2003.

  • Quando vengono utilizzati con cluster Exchange che eseguono Microsoft Exchange 2000 Server o versioni precedenti.

  • Quando vengono utilizzati con cluster Windows che eseguono Microsoft Windows 2000 Server o versioni precedenti.

Indipendentemente dal volume utilizzato da Exchange Server (disco fisico locale, volume logico o punto di montaggio volume), le procedure ideali per le implementazioni di Exchange Server devono disporre di almeno il 50% di spazio libero su disco in tutte le unità. In generale, Microsoft consiglia dal 25 al 30% di spazio libero su disco per la manutenzione di Exchange, come ad esempio le attività eseguite utilizzando le utilità del database quali Eseutil e Isinteg. Inoltre, per alcune operazioni di manutenzione, come la deframmentazione non in linea, Microsoft consiglia di disporre del 100% di spazio libero in più rispetto allo spazio di cui si desidera eseguire la deframmentazione. Ad esempio, se si desidera eseguire la deframmentazione di un database da 1 GB, è preferibile disporre di almeno 1 GB di spazio libero su disco.

Disporre di una grande quantità di spazio libero su disco è utile sia dal punto di vista della protezione sia da quello della disponibilità. Un attacco di tipo DoS (Denial of Service), un ciclo di messaggi o un attacco diffuso da parte di un virus può provocare un utilizzo eccessivo dello spazio su disco dovuto all'aumento del traffico dei messaggi, dell'attività del registro transazioni e così via.

Per risolvere il problema

  1. Analizzare le aree per recuperare spazio su disco e aumentare lo spazio disponibile.

  2. Se lo spazio libero su disco è insufficiente, è preferibile prendere in considerazione lo spostamento dei dati in un altro computer Exchange Server o server virtuale di Exchange che non abbia problemi di spazio. Se questa operazione non è già stata eseguita, l'impostazione dei limiti della cassetta postale può essere utile anche per la gestione del disco.

Per ulteriori informazioni sull'utilizzo dei punti di montaggio dei volumi in un cluster di Exchange Server 2003, consultare l'articolo 318458 della Microsoft Knowledge Base "Supporto per il punto di montaggio dei volumi per un cluster Exchange Server 2003 su un sistema Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=318458.

Per ulteriori informazioni sull'utilizzo dei punti di montaggio dei volumi in un cluster di Windows Server 2003, consultare l'articolo 280297 della Microsoft Knowledge Base "Configurazione dei punti di montaffio di un volume in un server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=280297.


Scheda di rete abilitata per DHCP
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per determinare se è stato impostato un valore per la proprietà DHCPEnabled. Se il valore per questa proprietà su un server di Exchange equivale a 1, verrà visualizzato un messaggio di errore.

L'esecuzione di Exchange su una scheda di rete abilitata per DHCP è una configurazione supportata. Tuttavia, questa configurazione non è consigliata. L'esecuzione di Exchange su computer abilitati per DHCP non è consigliata poiché, in caso di interruzione o errori del servizio DHCP, Exchange può interrompere il recapito della posta o generare degli errori.

Si consiglia di configurare tutti i computer che eseguono Exchange per l'utilizzo con indirizzi IP statici.

Per ulteriori informazioni sulla progettazione di reti TCP/IP Windows, consultare il sito Web Microsoft TechNet Networking all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33819.


L'indirizzo del server WINS primario non è stato specificato
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per determinare se è stato impostato un valore per la chiave WINSPrimaryServer. Se Exchange Server Analyzer rileva che il valore della chiave in un server di Exchange è vuoto, verrà visualizzato un avviso.

Exchange Server 2003 ed Exchange 2000 Server presentano diverse dipendenze NetBIOS. Inoltre, i client Microsoft® Office Outlook® precedenti a Microsoft Office Outlook 2003 richiedono anche la risoluzione dei nomi NetBIOS. Ad esempio, le seguenti funzionalità di Exchange dipendono dalla risoluzione dei nomi NetBIOS:

  • Programmi di installazione di Exchange Server 2003 ed Exchange 2000 Server, soprattutto nei server cluster.

  • Exchange Mailbox Merge Wizard (ExMerge) in un computer che esegue Exchange Server 2003 o Exchange 2000 Server.

  • Modifica della password di una cassetta postale di Exchange Server 2003 o Exchange 2000 Server attraverso Outlook Web Access.

  • Gestore di sistema di Exchange in un computer che esegue Exchange Server 2003 o Exchange 2000 Server.

A seconda della topologia di rete dell'organizzazione, potrebbe essere possibile ignorare tranquillamente questo avviso. Nelle reti costituite da un singolo subnet, i broadcast NetBIOS sono normalmente in grado di gestire i requisiti di risoluzione dei nomi NetBIOS di un'installazione di Exchange.

Nelle organizzazioni di grandi dimensioni, è possibile che la risoluzione dei nomi NetBIOS tramite broadcast non funzioni correttamente. Poiché in genere i broadcast NetBIOS non passano nelle subnet, le reti instradate richiedono un metodo alternativo per la risoluzione dei nomi NetBIOS. Il metodo preferito per eseguire questa operazione è WINS (Windows Internet Name Service). WINS offre un database distribuito per la registrazione e la ricerca di mapping dinamici dei nomi NetBIOS dei computer e dei gruppi utilizzati nella rete. WINS esegue il mapping dei nomi NetBIOS a indirizzi IP ed è stato designato per risolvere i problemi che si verificano a causa della risoluzione dei nomi NetBIOS in ambienti instradati. WINS rappresenta il metodo più adatto per la risoluzione dei nomi NetBIOS in reti instradate che utilizzano NetBIOS su TCP/IP.

Non sono state completamente testate le funzioni e l'operatività di Exchange Server 2003 ed Exchange 2000 Server in un'organizzazione di grandi dimensioni o con subnet priva di WINS. Per la risoluzione dei nomi NetBIOS, è necessario che le società eseguano Exchange in reti instradate o segmentate per WINS. L'esecuzione di Exchange in un ambiente instradato o segmentato senza WINS non è supportata.

È consigliabile installare un ambiente WINS a tolleranza d'errore che includa almeno due server WINS. I server WINS possono agire come server WINS primario o server WINS secondario per un client. La differenza tra server WINS primario e secondario è solo la priorità con cui i client li contattano. Un server WINS primario è il primo server che viene contattato da un client per eseguire le operazioni di servizio nomi NetBIOS. Il client contatta un server WINS secondario solo quando un server WINS primario non è in grado di soddisfare la richiesta, ad esempio se non è disponibile quando il client effettua la richiesta o se non è possibile risolvere un nome per il client.

Nel caso in cui un server WINS primario non soddisfi una richiesta, il client effettuerà la stessa richiesta al server WINS secondario. Se vengono configurati più di due server WINS per il client, quest'ultimo tenterà di contattare gli altri server WINS secondari fino a che non viene esaurito l'elenco o uno dei server WINS non risponde alla richiesta. Dopo l'utilizzo di un server WINS secondario, il client periodicamente tenta di tornare al server WINS primario per le future richieste di servizio nomi.

È consigliabile configurare almeno un server WINS secondario nei server di Exchange su una rete instradata o segmentata.

Per risolvere il problema

  1. Aprire Connessioni di rete.

  2. Fare clic con il pulsante destro del mouse sulla connessione di rete che si desidera configurare e scegliere Proprietà.

  3. Nella scheda Generale (per una connessione alla rete locale) o nella scheda Rete (per tutte le altre connessioni) selezionare Protocollo Internet (TCP/IP), quindi scegliere Proprietà.

  4. Fare clic su Avanzate, selezionare la scheda WINS, quindi scegliere Aggiungi.

  5. In Server WINS TCP/IP digitare l'indirizzo IP di un server WINS, quindi fare clic su Aggiungi.

  6. Ripetere i passaggi 4 e 5 per ogni indirizzo IP degli altri server WINS che si desidera aggiungere, quindi fare clic su OK. È possibile modificare l'ordine di preferenza dei server WINS mediante i tasti di direzione.

  7. Assicurarsi che la casella Abilita NetBIOS su TCP/IP sia selezionata.

  8. Fare clic su OK per salvare le modifiche.

Per ulteriori informazioni sui requisiti della risoluzione dei nomi NetBIOS per Exchange, consultare l'articolo 837391 della Knowledge Base, "Exchange Server 2003 ed Exchange 2000 Server richiedono la risoluzione dei nomi NetBIOS per la funzionalità completa" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=837391.


Rilevato Virtual Server
Articoli su Microsoft Exchange Server Analyzer > Hardware >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se il valore della chiave Model è impostato su Virtual Machine.

Exchange Server Analyzer controlla inoltre la presenza del seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Se Exchange Server Analyzer rileva che la chiave Model contiene la stringa Virtual Machine e che il ramo del Registro di sistema indicato sopra esiste, verrà visualizzato un messaggio di errore.

Il valore Virtual Machine per la chiave Model indica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Microsoft Virtual Server 2005 o Microsoft Virtual PC 2004. Poiché il ramo del Registro di sistema indicato sopra viene creato esclusivamente da Virtual Server 2005, la sua esistenza implica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Virtual Server 2005.

Microsoft non supporta l'esecuzione di versioni di Microsoft Exchange Server su una macchina virtuale o un emulatore. Questo vale per Exchange Server in esecuzione su Microsoft Virtual Server 2005, Microsoft Virtual PC 2004 o altri programmi di macchine virtuali di terze parti. Le piattaforme Microsoft Exchange Server sono state progettate e testate per essere eseguite solo su hardware fisico, in particolare le piattaforme hardware elencate nel catalogo di Windows Server alla pagina http://go.microsoft.com/fwlink/?linkid=17219.

Per risolvere il problema

  1. Spostare le cassette postali da Exchange Server in esecuzione su Virtual Server 2005 a un computer Exchange Server non virtuale.

  2. Se necessario, spostare le cartelle pubbliche e trasferire i ruoli contenuti dal server virtuale di Exchange.

  3. Disinstallare Exchange dal macchina virtuale per non concedere l'autorizzazione ed eseguire la rimozione dall'infrastruttura di Exchange e dal servizio directory di Active Directory®.

Per ulteriori informazioni sullo spostamento delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.

  • 224975, "XADM: Differenze tra i metodi di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975.

Per ulteriori informazioni su Microsoft Virtual Server 2005, consultare il sito Web "Microsoft Virtual Server 2005" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34938 (informazioni in lingua inglese).

Per ulteriori informazioni su Microsoft Virtual PC 2004, consultare il sito Web "Microsoft Virtual PC 2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34938 (informazioni in lingua inglese).


Rete
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente alla rete. In questi articoli, inoltre, sono descritte le operazioni eseguibili per risolvere errori, messaggi di avviso e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi alla rete.


Record DNS "Host" mancante
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2006-04-13

Microsoft® Exchange Server Analyzer Tool esegue una ricerca DNS nel server DNS per recuperare il record Host (A) del server Exchange. Se l'operazione di ricerca DNS non restituisce un indirizzo IP, verrà visualizzato un avviso che indica che il record Host (A) risulta mancante.

La ricerca DNS del record Host (A) dal computer che esegue Exchange Server 2003 potrebbe restituire un errore per i seguenti motivi:

  • Il server DNS potrebbe essere inattivo o non risponde a causa di un errore di rete o altri motivi.

  • Il record Host (A) di Exchange Server 2003 potrebbe essere mancante nel server DNS perché non disponibile, errato oppure il server DNS potrebbe non essere configurato per consentire gli aggiornamenti dinamici del record dell'host.

Se il server DNS è inattivo, potrebbero verificarsi ritardi nel routing o altri errori nei servizi.

Nota:
Exchange Server 2003 utilizza la risoluzione dei nomi host per i sistemi di messaggistica locali ed esterni basati su SMTP nella rete. La risoluzione dei nomi host si basa principalmente sul DNS, che è un servizio di rete fondamentale. Un errore in un server DNS potrebbe impedire agli utenti di individuare il sistema di messaggistica. Active Directory e l'organizzazione di Exchange Server 2003 non possono funzionare senza DNS. I client di messaggistica eseguiranno una query su DNS per individuare le risorse interne, quali controller di dominio e server cassette postali. Al contrario, Exchange Server 2003 fa affidamento sul DNS per recuperare gli indirizzi IP dei controller di dominio per le ricerche nella directory e gli host SMTP esterni quando Exchange Server 2003 invia messaggi a Internet.

Per risolvere questo problema, verificare che il server DNS sia in esecuzione e che il record Host (A) sia registrato.

Per verificare che il server DNS sia in linea e che il record Host sia presente

  1. Verificare che il server DNS sia in esecuzione eseguendo una o più dei seguenti passaggi:

    • Esaminare lo stato del server DNS utilizzando il programma di amministrazione DNS nel server DNS.

    • Riavviare il server DNS. Per ulteriori informazioni, consultare "Avvio, arresto, sospensione o riavvio di un server DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=62999.

    • Esaminare la capacità di risposta del server DNS utilizzando nslookup. Per ulteriori informazioni, consultare "Verificare la capacità di risposta del server DNS tramite il comando nslookup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63000.

  2. Utilizzare nslookup per verificare che il record Host (A) esista nel server DNS. Per ulteriori informazioni, consultare "Per verificare l'esistenza di record di risorse A nel sistema DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63001.

  3. Se il record di risorse Host (A) non esiste, aggiungere manualmente o modificare il record di risorse A oppure configurare il server DNS per consentire aggiornamenti dinamici del record

    • Aggiungere manualmente un record di risorse A. Per ulteriori informazioni, consultare "Aggiunta di un record di risorse a una zona DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63002.

    • Aggiungere manualmente un record di risorse A. Per ulteriori informazioni, consultare "Modifica di un record di risorsa esistente" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63014.

    • Abilitare il server DNS per consentire gli aggiornamenti dinamici del record dell'host. Per ulteriori informazioni, consultare l'articolo 816592 della Microsoft Knowledge Base "Configurazione degli aggiornamenti dinamici del DNS in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592.
  • Per informazioni sull'utilizzo da parte di Exchange Server 2003 del DNS per la risoluzione degli indirizzi IP esterni, consultare "Dipendenze del trasporto per Exchange Server 2003" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Per informazioni sulla risoluzione nomi DNS, consultare l'articolo 322856 della Microsoft Knowledge Base "Configurazione del DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • Per informazioni sulla risoluzione dei problemi del DNS, consultare "Risoluzione dei problemi relativi al servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63003.

Per informazioni sul monitoraggio del sistema di Exchange Server 2003, consultare "System Monitoring with Exchange Server 2003 Management Pack" in Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47573 (informazioni in lingua inglese).

  • Per informazioni sui record di risorse Host (A), consultare "Gestione dei record di risorse" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63004.


Le risposte DNS sono diverse tra UDP e TCP
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2007-03-16

Lo strumento Microsoft Exchange Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows) Win32_NetworkAdapterConfiguration per ottenere l'attributo DNSServerSearchOrder. Questo attributo è un array di indirizzi IP di server utilizzati per le query dei server DNS.

Dopo aver recuperato l'indirizzo del server DNS primario, Exchange Analyzer esegue un tentativo di query DNS nei server DNS configurati per ciascun server del servizio directory di Active Directory. Questa connessione viene effettuata mediante un processore di oggetti personalizzato che esegue sia una richiesta di risoluzione del nome TCP (Transmission Control Protocol) che UDP (User Datagram Protocol).

Se entrambe le richieste hanno esito negativo, Exchange Analyzer confronta le risposte restituite dalle richieste con esito positivo. Se le risposte restituite dalle query TCP e UDP non sono le stesse, viene visualizzato un avviso

che indica che potrebbero essere presenti problemi di configurazione del server DNS che stanno influenzando le prestazioni del flusso di posta.

SMTP (Simple Mail Transfer Protocol) è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

Affinché Exchange Server recapiti un messaggio Internet in uscita tramite il servizio SMTP, il DNS viene utilizzato dal seguente metodo:

  1. Un utente interno invia un messaggio a un destinatario in un dominio remoto.

  2. Per determinare se il destinatario è locale o remoto, il server virtuale SMTP del server Exchange del mittente utilizza le funzioni di trasporto interne per eseguire una query nel server di catalogo globale relativa all'indirizzo del destinatario. Se l'indirizzo del destinatario del messaggio non è contenuto in un criterio destinatario, l'indirizzo non viene memorizzato in Active Directory. Exchange determina quindi che il messaggio è destinato a un dominio remoto.

  3. Se necessario, il server Exchange recapita il messaggio al server virtuale SMTP appropriato.

  4. Il server virtuale SMTP utilizza le informazioni relative al metabase IIS disponibili per determinare il metodo di recapito di un messaggio a un dominio remoto.

  5. Il server virtuale SMTP sul server Exchange esegue quindi una delle seguenti azioni:

    • Utilizza il DNS per cercare l'indirizzo IP per il dominio di destinazione, quindi prova a recapitare il messaggio.

    • Inoltra il messaggio a uno smart host che provvede alla risoluzione DNS e al recapito del messaggio.

Per risolvere l'avviso, vedere l'articolo 820284 della Microsoft Knowledge Base, "La posta potrebbe non venire recapitata a determinati domini se il sistema operativo server è Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284.

Per ulteriori informazioni sui server DNS ed Exchange Server, vedere i seguenti articoli della Microsoft Knowledge Base e di WebCast:

  • 322856, "Configurazione del DNS per l'utilizzo con Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • 263237, "XCON: Windows 2000 ed Exchange 2000 SMTP utilizzano query DNS TCP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759.


Sul server DNS è in esecuzione Virtual Server 2005 con Exchange Server installato come Guest
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare se il valore della chiave Model è impostato su Virtual machine.

Exchange Server Analyzer consente inoltre di controllare la presenza del seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Virtual Machine\Guest\Parameters

Inoltre, Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il servizio Domain Name System (DNS) è attivo sul computer fisico che esegue Virtual Server 2005.

Se Exchange Server Analyzer rileva che la chiave Model contiene la stringa Virtual Machine, che il ramo del Registro di sistema indicato sopra esiste e che DNS è in esecuzione, verrà visualizzato un messaggio di errore.

Il valore Virtual Machine per la chiave Model indica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Virtual Server 2005 o Microsoft Virtual PC 2004. Poiché il ramo del Registro di sistema indicato sopra viene creato esclusivamente da Virtual Server 2005, la sua esistenza implica che il computer Exchange Server è in esecuzione come macchina virtuale Guest su Virtual Server 2005.

Microsoft non supporta l'esecuzione di versioni di Microsoft Exchange Server su un macchina virtuale o un emulatore. Questo vale per Exchange Server in esecuzione su Virtual Server 2005, Virtual PC 2004 o altri programmi di computer virtuali di terze parti. Le piattaforme Microsoft Exchange Server sono state progettate e testate per essere eseguite solo su hardware fisico, in particolare le piattaforme hardware elencate nel catalogo di Windows Server all'indirizzo http://go.microsoft.com/fwlink/?linkid=17219.

Inoltre, l'esecuzione di Exchange come Guest di Virtual Server 2005 in un computer che esegue Domain Name System non è consigliabile in quanto non consente un'adeguata ridondanza in tutti i servizi.

Per risolvere il problema

  1. Spostare le cassette postali da Exchange Server in esecuzione su Virtual Server 2005 a un computer Exchange Server non virtuale.

  2. Se necessario, spostare le cartelle pubbliche e trasferire i ruoli contenuti dal server virtuale di Exchange.

  3. Disinstallare Exchange dal macchina virtuale per non concedere l'autorizzazione ed eseguire la rimozione dall'infrastruttura di Exchange e dal servizio directory di Active Directory®.

Per ulteriori informazioni sullo spostamento delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822892, "Miglioramenti dello spostamento di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822892.

  • 224975, "XADM: Differenze tra i metodi di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=224975.

Per ulteriori informazioni sul supporto per i computer Exchange Server che funzionano in ambienti virtuali, consultare l'articolo 320220 della Microsoft Knowledge Base "Limitazioni al supporto per Exchange Server su un macchina virtuale o un emulatore" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320220.

Per ulteriori informazioni su Microsoft Virtual Server 2005, consultare il sito Web "Microsoft Virtual Server 2005" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34938 (informazioni in lingua inglese).

Per ulteriori informazioni su Microsoft Virtual PC 2004, consultare il sito Web "Microsoft Virtual PC 2004" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34938 (informazioni in lingua inglese).


Risposte del server DNS esterno differenti tra UDP e TCP
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2007-03-16

Microsoft Exchange Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo msExchSmtpExternalDNSServers nella classe protocolCfgSMTPServer per ciascun oggetto di Exchange Server. Se impostato, il valore dell'attributo msExchSmtpExternalDNSServers specifica l'indirizzo del server DNS (Domain Name System) esterno utilizzato dall'istanza del server virtuale SMTP (Simple Mail Transfer Protocol).

Dopo aver recuperato l'indirizzo del server DNS esterno primario, Exchange Analyzer tenta di eseguire una query DNS sui server DNS configurati per ciascun server del servizio directory di Active Directory. La connessione viene effettuata mediante un elaboratore di oggetti personalizzati su cui viene eseguita sia una richiesta di risoluzione dei nomi TCP (Transmission Control Protocol) che UDP (User Datagram Protocol).

Se entrambe le richieste di risoluzione dei nomi, TCP e UDP, sono eseguite correttamente, le risposte restituite delle richieste riuscite vengono analizzate. Se le risposte restituite dalle query TCP e UDP sono diverse, viene visualizzato un avviso.

Tale avviso indica che è probabile che vi siano problemi di configurazione del server DNS esterno che influenzano significativamente le prestazioni del flusso di posta.

SMTP è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

Per il recapito di un messaggio Internet in uscita mediante il servizio SMTP, viene utilizzato il DNS con il metodo seguente:

  1. Un utente interno invia un messaggio a un destinatario in un dominio remoto.

  2. Per determinare se il destinatario è locale o remoto, il server virtuale SMTP sul server Exchange del mittente utilizza le funzioni di trasporto interne per eseguire una query sul server di catalogo globale per l'indirizzo del destinatario. Se l'indirizzo del destinatario sul messaggio non è un criterio destinatario, non viene archiviato in Active Directory. Exchange determina pertanto che il messaggio è destinato a un dominio remoto.

  3. Se necessario, il server Exchange recapita il messaggio al server virtuale SMTP appropriato.

  4. Il server virtuale SMTP utilizza le relative informazioni metabase IIS per determinare il metodo di recapito di un messaggio a un dominio remoto.

  5. Il server virtuale SMTP sul server Exchange esegue quindi una delle due azioni seguenti:

    • Utilizza il DNS per ricercare l'indirizzo IP del dominio di destinazione, quindi cerca di recapitare il messaggio.

    • Inoltra il messaggio a uno SmartHost che si assume la responsabilità della risoluzione DNS e del recapito del messaggio.

Per risolvere il problema, vedere l'articolo 820284 della Microsoft Knowledge Base, "Possibili problemi di recapito della posta ad alcuni domini se il sistema operativo del server è Windows Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=820284.

Per ulteriori informazioni sui server DNS ed Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base e di WebCast:

  • 322856, "Configurazione del DNS per l'utilizzo con Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • 263237, "XCON: SMTP: utilizzo delle query TCP DNS in Windows 2000 ed Exchange 2000", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759.


Totale byte di rete al secondo superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Bytes Total/sec dell'oggetto prestazioni Network Interface per analizzare i dati delle prestazioni.

Il contatore di prestazioni Bytes Total/sec mostra la frequenza con cui la scheda di rete elabora i byte di dati. Il contatore include tutti i dati sulle applicazioni e sui file, oltre alle informazioni sui protocolli quali, ad esempio, le intestazioni dei pacchetti. Il contatore di prestazioni Bytes Total/sec è la somma di Network Interface\Bytes Received/sec e Network Interface/Bytes Sent/sec.

In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. Per una scheda di rete a 100 Mbps, il valore del contatore di prestazioni Bytes Total/sec deve essere inferiore a 7 megabyte al secondo. Per una scheda di rete a 1000 Mbps, il valore del contatore di prestazioni Bytes Total/sec deve essere inferiore a 70 megabyte al secondo. Se il valore di Bytes Total/sec è superiore al 7% della larghezza di banda della rete, verrà visualizzato un messaggio di errore.

In genere tale errore indica periodi di assenza di risposta del server che causano un rallentamento o un'interruzione del flusso di posta. Inoltre, nei client Microsoft Outlook® che eseguono la connessione a questo server è possibile che venga visualizzata la finestra di dialogo Richiesta di annullamento RPC.

Di seguito sono riportate alcune possibili cause dell'errore:

  • Una scheda di interfaccia di rete (NIC) nel computer non è in grado di supportare la larghezza di banda massima supportata dall'infrastruttura di rete.

  • Il server è sovraccarico.

  • La presenza di virus o posta indesiderata determina un aumento improvviso degli schemi di utilizzo della rete.

Per risolvere il problema

  • Se una scheda di interfaccia di rete non supporta la larghezza di banda massima della rete, aggiornare la scheda affinché possa supportare una larghezza di banda più veloce.

  • Ridurre il carico sul server. Per eseguire questa operazione, spostare le cassette postali in un server che ne contiene meno. Se necessario, aggiungere all'ambiente un server di Exchange.

  • Se si sospetta che il carico insolitamente elevato non dipenda dal numero eccessivo di cassette postali su un server, tentare di identificare l'origine del problema e risolverlo.

  • Consultare le procedure consigliate nei seguenti articoli:

    • Per informazioni sulle considerazioni relative alla larghezza di banda della rete, consultare la sezione Prestazioni di rete dell'argomento "Nozioni fondamentali sulle prestazioni di Exchange" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

    • Per ulteriori informazioni sulla risoluzione dei problemi di rete, consultare l'argomento "Ruling Out Network-Bound Problems" in Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Gruppo di schede di interfaccia di rete abilitato
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2006-10-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_NetworkAdapter per rilevare tutte le schede di interfaccia di rete collegate al protocollo TCP/IP.

Exchange Server Analyzer consente anche di eseguire query nel ramo del Registro di sistema indicato di seguito per determinare se la chiave TeamAdapters esiste per tali schede:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\%NICDEVICEID%\

Se Exchange Server Analyzer rileva che la chiave TeamAdapters esiste per una o più schede di interfaccia di rete sul server analizzato, verrà visualizzato un avviso.

Tale avviso indica che il gruppo di schede di interfaccia di rete è abilitato sul server Exchange analizzato. Sebbene il gruppo di schede di interfaccia di rete non causi generalmente un problema del flusso di posta, è necessario fare attenzione che il gruppo sia configurato correttamente con i più recenti driver di scheda di interfaccia di rete disponibili.

Per risolvere il problema:

  • Se il problema del flusso di posta si verifica sul su cui è abilitato il gruppo delle schede di interfaccia di rete, disattivare temporaneamente il gruppo per scoprire se il problema viene risolto.

  • Aggiornare i driver della scheda di interfaccia di rete con i più recenti disponibili presso il produttore della scheda.

  • Seguire attentamente le raccomandazioni di configurazione del gruppo fornite dal produttore della scheda.

Per ulteriori informazioni sul gruppo di schede di interfaccia di rete, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 278431, relativo all'utilizzo di gruppi di schede con bilanciamento del carico che potrebbero causare problemi di rete, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=278431.

  • 814607, relativo al supporto Microsoft per server cluster con componenti di sistema di terze parti, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=814607.


Pacchetti di rete in uscita superiori alla soglia
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni. Il motore raccoglie i dati dal contatore di prestazioni Packet Outbound errors dell'oggetto prestazioni Network Interface per analizzare i dati delle prestazioni.

Il contatore di prestazioni Packet Outbound errors indica il numero di pacchetti in uscita che non è stato possibile trasmettere a causa di un errore. Il valore del contatore di prestazioni Packet Outbound errors deve essere pari a zero. Se Exchange Server Analyzer determina che il valore del contatore di prestazioni Packet Outbound errors è maggiore di zero, verrà visualizzato un messaggio di errore.

In genere tale errore indica periodi di assenza di risposta del server che causano un rallentamento o un'interruzione del flusso di posta. Inoltre, nei client Microsoft Outlook® che eseguono la connessione a questo server è possibile che venga visualizzata la finestra di dialogo Richiesta di annullamento RPC.

Generalmente questo errore è causato da una scheda di interfaccia di rete (NIC) difettosa o danneggiata.

Per risolvere il problema, è necessario determinare la causa degli errori relativi ai pacchetti in uscita. Se gli errori dipendono da una scheda di interfaccia di rete difettosa, sostituire immediatamente la scheda.

Consultare le procedure consigliate nei seguenti articoli:

  • Per informazioni sulle considerazioni relative alla larghezza di banda della rete, consultare la sezione Prestazioni di rete dell'argomento "Nozioni fondamentali sulle prestazioni di Exchange" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi di rete, consultare l'argomento "Ruling Out Network-Bound Problems" in Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Lunghezza della coda di output di rete superiore alla soglia
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2007-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange Server 2000 o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Output Queue Length dell'oggetto prestazioni Network Interface per analizzare i dati delle prestazioni.

Il contatore di prestazioni Output Queue Length visualizza la lunghezza della coda dei pacchetti in uscita, misurata in pacchetti. In Exchange Server Analyzer viene segnalato il valore massimo del contatore di prestazioni durante l'intervallo di raccolta. Se il valore medio è superiore a 10, verrà visualizzato un messaggio di errore.

In genere tale errore indica periodi di assenza di risposta del server che causano un rallentamento o un'interruzione del flusso di posta. Inoltre, nei client Outlook che eseguono la connessione a questo server è possibile che venga visualizzata la finestra di dialogo Richiesta di annullamento RPC.

Di seguito sono riportate alcune possibili cause dell'errore:

Nota:
In alcune circostanze, in computer con Microsoft Windows 2000 Server il contatore di prestazioni Output Queue Length potrebbe indicare costantemente un valore casuale maggiore di zero. Per ulteriori informazioni sulle circostanze in cui il contatore di prestazioni Output Queue Length potrebbe visualizzare un valore casuale e su come risolvere il problema, vedere l'articolo 834940 della Microsoft Knowledge Base relativo al monitor di sistema che potrebbe visualizzare valori elevati per il contatore di prestazioni Lunghezza coda di output in Windows 2000, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834940.
  • Una scheda di interfaccia di rete (NIC) nel computer non è in grado di supportare la larghezza di banda massima supportata dall'infrastruttura di rete.

  • Il server è sovraccarico.

  • La presenza di virus o posta indesiderata determina un aumento improvviso degli schemi di utilizzo della rete.

Per risolvere il problema, procedere come segue:

  • Se una scheda di interfaccia di rete non supporta la larghezza di banda massima della rete, aggiornare la scheda affinché possa supportare una larghezza di banda più veloce.

  • Ridurre il carico sul server. Per eseguire questa operazione, spostare le cassette postali in un server che ne contiene meno. Se necessario, aggiungere all'ambiente un server di Exchange.

  • Se si sospetta che il carico insolitamente elevato non dipenda dal numero eccessivo di cassette postali su un server, tentare di identificare l'origine del problema e risolverlo.

Consultare le procedure consigliate nei seguenti articoli:

  • Per informazioni sulle considerazioni relative alla larghezza di banda della rete, consultare la sezione Prestazioni di rete dell'argomento "Nozioni fondamentali sulle prestazioni di Exchange" nel Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi di rete, consultare l'argomento "Ruling Out Network-Bound Problems" in Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Mancata risposta del DNS primario a una connessione UDP
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2007-03-16

Microsoft Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows) Win32_NetworkAdapterConfiguration per ottenere l'attributo DNSServerSearchOrder. Questo attributo è una matrice di indirizzi IP di server da utilizzare per la ricerca di server DNS.

Dopo aver recuperato l'indirizzo del server DNS (Domain Name System) primario, Exchange Analyzer tenta di eseguire una query DNS nei relativi server configurati di ciascun server del servizio di directory Active Directory. La connessione viene effettuata mediante un elaboratore di oggetti personalizzati su cui viene eseguita una richiesta di risoluzione dei nomi UDP (User Datagram Protocol) e vengono analizzati i risultati.

Se la risoluzione dei nomi UDP ha esito negativo, viene visualizzato un avviso

che indica che è possibile che il server DNS primario sia stato configurato per accettare solo query TCP.

SMTP (Simple Mail Transfer Protocol) è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

Per il recapito di un messaggio Internet in uscita mediante il servizio SMTP, viene utilizzato il DNS con il metodo seguente:

  1. Un utente interno invia un messaggio a un destinatario in un dominio remoto.

  2. Per determinare se il destinatario è locale o remoto, il server virtuale SMTP sul server Exchange del mittente utilizza le funzioni di trasporto interne per eseguire una query sul server di catalogo globale per l'indirizzo del destinatario. Se l'indirizzo del destinatario sul messaggio non è un criterio destinatario, non viene archiviato in Active Directory. Exchange determina pertanto che il messaggio è destinato a un dominio remoto.

  3. Se necessario, il server Exchange recapita il messaggio al server virtuale SMTP appropriato.

  4. Il server virtuale SMTP utilizza le relative informazioni metabase IIS per determinare il metodo di recapito di un messaggio a un dominio remoto.

  5. Il server virtuale SMTP sul server Exchange esegue quindi una delle due azioni seguenti:

    • Utilizza il DNS per ricercare l'indirizzo IP del dominio di destinazione, quindi cerca di recapitare il messaggio.

    • Inoltra il messaggio a uno SmartHost che si assume la responsabilità della risoluzione DNS e del recapito del messaggio.

Per impostazione predefinita i server DNS ascoltano le comunicazioni sul socket UDP 53, ad esempio le query sulla risoluzione dei nomi.

Se i servizi SMTP sul server di Exchange sono configurati per inviare solo query UDP e il server DNS primario è configurato per accettare solo query TCP, è possibile che si verifichino errori di instradamento della posta che potrebbero influire negativamente sulle prestazioni del flusso di posta.

Per risolvere il problema, procedere come segue:

  1. Assicurarsi che il server DNS sia stato avviato e sia connesso alla rete.

  2. Verificare che un firewall di rete o un filtro pacchetti non blocchino intenzionalmente le porte DNS conosciute quali la porta UDP 53.

  3. Verificare che il server DNS primario sia configurato per supportare le query sulla risoluzione dei nomi UDP.

Per ulteriori informazioni sui server DNS ed Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base e di WebCast:

  • 322856, "Come configurare DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856

  • 263237, "XCON: Windows 2000 ed Exchange 2000 SMTP Utilizzo query TCP DNS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237.

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi relativi a DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759.


Il server DNS primario è irraggiungibile
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per ottenere l'attributo DNSServerSearchOrder. Questo attributo è un array di indirizzi IP di server da utilizzare per la ricerca di server DNS. Dopo aver recuperato l'indirizzo del server DNS primario, Exchange Server Analyzer apre una connessione socket TCP alla porta 53 sul server. Questa connessione viene eseguita tramite un elaboratore di oggetti personalizzati che restituisce una stringa specifica se la connessione riesce. Se Exchange Server Analyzer non riceve 53 Available come parte della stringa restituita, verrà visualizzato un avviso.

Tale avviso indica che il server non ha risposto a un tentativo di connessione sulla porta TCP 53. Per impostazione predefinita, i server DNS ascoltano le comunicazioni sul socket TCP 53 quali le query sulla risoluzione dei nomi.

Se il server DNS primario non è raggiungibile e si esegue Exchange 2000 Server, il recapito della posta sarà più lento. Un aggiornamento rapido supportato di Microsoft è disponibile per correggere il problema del recapito di messaggi a destinatari esterni più lento del previsto quando il server DNS primario non è disponibile. Per richiedere l'aggiornamento, contattare il Servizio Supporto Tecnico Clienti Microsoft.

Inoltre, sarà necessario chiarire il motivo per cui il server DNS primario non è disponibile oppure modificare le impostazioni DNS nel server Exchange per utilizzare un server DNS diverso per la risoluzione dei nomi.

Per risolvere il problema

  1. Assicurarsi che il server DNS sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per stabilire se il server DNS è raggiungibile.

Per ulteriori informazioni sul recapito lento dei messaggi quando il server DNS primario non è disponibile e su come richiedere un aggiornamento rapido per risolvere il problema, consultare l'articolo 829722 della Microsoft Knowledge Base "Recapito della posta lento in Exchange 2000 quando il server DNS primario non è disponibile" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722.

Per ulteriori informazioni sui server DNS ed Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base e di WebCast:

  • 322856, "Configurazione del DNS per l'utilizzo con Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • 263237, "XCON: Utilizzo delle query TCP DNS da parte del SMTP in Windows 2000 and Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237.

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759.


Impossibile per il server DNS esterno primario rispondere a una connessione TCP
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2007-03-16

Microsoft Exchange Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo msExchSmtpExternalDNSServers nella classe protocolCfgSMTPServer per ciascun oggetto di Exchange Server. Se impostato, il valore dell'attributo msExchSmtpExternalDNSServers specifica l'indirizzo del server DNS (Domain Name System) esterno utilizzato dall'istanza del server virtuale SMTP (Simple Mail Transfer Protocol).

Dopo aver recuperato l'indirizzo del server DNS esterno primario, Exchange Server Analyzer apre una connessione socket TCP alla porta 53 sul server. Questa connessione viene eseguita tramite un elaboratore di oggetti personalizzati che restituisce una stringa specifica se la connessione riesce. Se Exchange Server Analyzer non riceve 53 Available come parte della stringa restituita, verrà visualizzato un avviso.

Tale avviso indica che il server non ha risposto a un tentativo di connessione sulla porta TCP 53. Per impostazione predefinita, i server DNS ascoltano le comunicazioni sul socket TCP 53 quali le query sulla risoluzione dei nomi.

SMTP è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

Per il recapito di un messaggio Internet in uscita mediante il servizio SMTP, viene utilizzato il DNS con il metodo seguente:

  1. Un utente interno invia un messaggio a un destinatario in un dominio remoto.

  2. Per determinare se il destinatario è locale o remoto, il server virtuale SMTP sul server Exchange del mittente utilizza le funzioni di trasporto interne per eseguire una query sul server di catalogo globale per l'indirizzo del destinatario. Se l'indirizzo del destinatario sul messaggio non è un criterio destinatario, non viene archiviato in Active Directory. Exchange determina pertanto che il messaggio è destinato a un dominio remoto.

  3. Se necessario, il server Exchange recapita il messaggio al server virtuale SMTP appropriato.

  4. Il server virtuale SMTP utilizza le relative informazioni metabase IIS per determinare il metodo di recapito di un messaggio a un dominio remoto.

  5. Il server virtuale SMTP sul server Exchange esegue quindi una delle due azioni seguenti:

    • Utilizza il DNS per ricercare l'indirizzo IP del dominio di destinazione, quindi cerca di recapitare il messaggio.

    • Inoltra il messaggio a uno SmartHost che si assume la responsabilità della risoluzione DNS e del recapito del messaggio.

Se il server DNS esterno primario non è raggiungibile e si esegue Exchange 2000 Server, il recapito della posta sarà più lento. Un aggiornamento rapido supportato di Microsoft è disponibile per correggere il problema del recapito di messaggi a destinatari esterni più lento del previsto quando il server DNS esterno primario non è disponibile. Per richiedere l'aggiornamento, contattare il Servizio Supporto Tecnico Clienti Microsoft.

Inoltre, sarà necessario chiarire il motivo per cui il server DNS esterno primario non è disponibile oppure modificare le impostazioni DNS nel server di Exchange per utilizzare un server DNS diverso per la risoluzione dei nomi.

Per risolvere il problema, procedere come segue:

  1. Assicurarsi che il server DNS esterno sia stato avviato e che esista la connettività con la rete di Exchange.

  2. Utilizzare il comando PING per verificare che il server DNS esterno sia raggiungibile.

Per ulteriori informazioni sul recapito lento dei messaggi quando il server DNS primario non è disponibile e su come richiedere un aggiornamento rapido per risolvere il problema, consultare l'articolo 829722 della Microsoft Knowledge Base "Recapito della posta lento in Exchange 2000 quando il server DNS primario non è disponibile" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829722.

Per ulteriori informazioni sui server DNS ed Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base e di WebCast:

  • 322856, "Come configurare DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856

  • 263237, "XCON: Windows 2000 and Exchange 2000 SMTP Use TCP DNS Queries" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237)

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi relativi al DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759.


Nessuna risposta del server DNS esterno primario a una connessione UDP
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2007-03-16

Microsoft Exchange Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo msExchSmtpExternalDNSServers nella classe protocolCfgSMTPServer per ciascun oggetto di Exchange Server. Se impostato, il valore dell'attributo msExchSmtpExternalDNSServers specifica l'indirizzo del server DNS (Domain Name System) esterno utilizzato dall'istanza del server virtuale SMTP (Simple Mail Transfer Protocol).

Dopo aver recuperato l'indirizzo del server DNS esterno primario, Exchange Analyzer tenta di eseguire una query DNS sui server DNS esterni configurati per ciascun server del servizio directory di Active Directory. La connessione viene effettuata mediante un elaboratore di oggetti personalizzati su cui viene eseguita una richiesta di risoluzione dei nomi UDP (User Datagram Protocol) e vengono analizzati i risultati.

Se la risoluzione dei nomi UDP ha esito negativo, viene visualizzato un avviso

che indica che il server DNS esterno primario può essere configurato per accettare solo query TCP.

SMTP è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

Per il recapito di un messaggio Internet in uscita mediante il servizio SMTP, viene utilizzato il DNS con il metodo seguente:

  1. Un utente interno invia un messaggio a un destinatario in un dominio remoto.

  2. Per determinare se il destinatario è locale o remoto, il server virtuale SMTP sul server Exchange del mittente utilizza le funzioni di trasporto interne per eseguire una query sul server di catalogo globale per l'indirizzo del destinatario. Se l'indirizzo del destinatario sul messaggio non è un criterio destinatario, non viene archiviato in Active Directory. Exchange determina pertanto che il messaggio è destinato a un dominio remoto.

  3. Se necessario, il server Exchange recapita il messaggio al server virtuale SMTP appropriato.

  4. Il server virtuale SMTP utilizza le relative informazioni metabase IIS per determinare il metodo di recapito di un messaggio a un dominio remoto.

  5. Il server virtuale SMTP sul server Exchange esegue quindi una delle due operazioni seguenti:

    • Utilizza il DNS per ricercare l'indirizzo IP del dominio di destinazione, quindi cerca di recapitare il messaggio.

    • Inoltra il messaggio a uno SmartHost che si assume la responsabilità della risoluzione DNS e del recapito del messaggio.

Per impostazione predefinita i server DNS ascoltano le comunicazioni sul socket UDP 53, ad esempio le query sulla risoluzione dei nomi.

Se i servizi SMTP sul server Exchange sono configurati per inviare solo query UDP e il server DNS esterno primario è configurato per accettare solo query TCP, è possibile che si verifichino errori nel routing della posta che potrebbero influenzare in modo significativo le prestazioni del flusso di posta.

Per risolvere il problema, procedere come segue:

  1. Assicurarsi che il server DNS esterno sia stato avviato e che sia connesso alla rete.

  2. Verificare che un firewall di rete o un filtro pacchetti non blocchino intenzionalmente le porte DNS conosciute quali la porta UDP 53.

  3. Verificare che il server DNS esterno primario sia configurato per supportare le query di risoluzione dei nomi UDP.

Per ulteriori informazioni sui server DNS ed Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base e di WebCast:

  • 322856, "Configurazione del DNS per l'utilizzo con Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • 263237, "XCON: SMTP: utilizzo delle query TCP DNS in Windows 2000 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=263237.

  • 324759, "Support WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324759.


Nessuna risposta dal server WINS primario
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NetworkAdapterConfiguration per ottenere l'attributo WINSPrimaryServer. L'attributo è l'indirizzo IP del server WINS (Windows Internet Name Service) primario per il computer Exchange Server. Dopo aver recuperato l'indirizzo del server WINS primario, Exchange Server Analyzer apre una connessione socket TCP alla porta 137 sul server. Questa connessione viene eseguita tramite un elaboratore di oggetti personalizzati che restituisce una stringa specifica se la connessione riesce. Se Exchange Server Analyzer non riceve 137 Available come parte della stringa restituita, verrà visualizzato un avviso.

Tale avviso indica che il server non ha risposto a un tentativo di connessione sulla porta TCP 137. Per impostazione predefinita, i server WINS ascoltano le comunicazioni sul socket TCP 137 quali le query sulla risoluzione dei nomi.

Se il server WINS primario non è raggiungibile e si esegue Exchange Server, il recapito della posta sarà più lento, specialmente nelle organizzazioni di dimensioni più grandi. Inoltre, sarà necessario chiarire il motivo per cui il server WINS primario non è disponibile oppure modificare le impostazioni WINS nel server Exchange per utilizzare un server WINS diverso per la risoluzione dei nomi.

Per risolvere il problema

  1. Assicurarsi che il server WINS sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per stabilire se il server WINS è raggiungibile.

Per informazioni sui motivi per cui Exchange 2000 Server ed Exchange Server 2003 richiedono WINS, vedere l'articolo 837391 della Microsoft Knowledge Base "Necessità della risoluzione dei nomi NetBIOS per garantire la funzionalità completa di Exchange Server 2003 ed Exchange 2000" (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=837391).


La porta 389 non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo dNSHostName per tutti i controller di dominio in Active Directory. Dopo aver recuperato i nomi dei controller di dominio, Exchange Server Analyzer apre una connessione socket TCP alla porta 389 su ciascun controller di dominio. Questa connessione viene eseguita tramite un elaboratore di oggetti personalizzati che restituisce una stringa specifica se la connessione riesce. Se Exchange Server Analyzer non riceve 389 Available come parte della stringa restituita, verrà visualizzato un avviso.

Questo avviso indica che il controller di dominio non ha risposto a un tentativo di connessione sulla porta TCP 389. La porta TCP 389 è la porta predefinita per comunicazioni LDAP (Lightweight Directory Access Protocol).

Se viene visualizzato questo messaggio di avviso, possono essersi verificati problemi di connettività tra Exchange Server Analyzer e il controller di dominio. Quando Exchange Server Analyzer esegue una query, il controller di dominio può non essere in grado di elaborare correttamente le richieste LDAP per diversi motivi.

Per risolvere il problema

  1. Verificare che l'account da cui viene eseguito lo strumento sia autorizzato a eseguire query nel controller di dominio. Sono necessarie autorizzazioni a livello di utente per il dominio in cui viene eseguito il controller di dominio. Ulteriori informazioni sulle autorizzazioni richieste per l'esecuzione di Exchange Server Analyzer sono disponibili nel file della Guida fornito con lo strumento. Aprire il file della Guida avviando Exchange Server Analyzer, fare clic su ?, quindi scegliere Guida in linea Microsoft Exchange Server Analyzer Tool.

  2. Verificare che non siano presenti firewall o restrizioni di porta tra il computer su cui viene eseguito Exchange Server Analyzer e il controller di dominio che non risponde correttamente.

  3. Verificare che il controller di dominio sia connesso alla rete e funzioni correttamente.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla connettività di Active Directory, consultare l'articolo 816103 della Microsoft Knowledge Base "HOW TO: Utilizzo di Portqry per risolvere i problemi di connettività di Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103.

Per ulteriori informazioni sulla configurazione del servizio Ora di Microsoft Windows® nei controller di dominio, consultare l'articolo 816042 della Microsoft Knowledge Base "Configurazione di un server di riferimento ora autorevole in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042.


La porta 636 non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo dNSHostName di tutti i controller di dominio in Active Directory. Dopo aver recuperato i nomi dei controller di dominio, Exchange Server Analyzer apre una connessione socket TCP alla porta 636 su ciascun controller di dominio. Questa connessione viene eseguita tramite un elaboratore di oggetti personalizzati che restituisce una stringa specifica se la connessione riesce. Se Exchange Server Analyzer non riceve 636 Available come parte della stringa restituita, verrà visualizzato un avviso.

Questo avviso indica che il controller di dominio non ha risposto al tentativo di connessione alla porta TCP 636. La porta TCP 636 è la porta predefinita per le comunicazioni LDAP (Secure Lightweight Directory Access Protocol) su SSL.

Con l'introduzione di Exchange 2000 Server Service Pack 3, Exchange Server consente il collegamento con LDAP su SSL se esiste un certificato valido nell'archivio certificati sul computer Exchange Server. Se non esiste alcun certificato, o se viene restituito un errore relativo al certificato (ad esempio il certificato di Exchange non viene considerato attendibile dal controller di dominio oppure il certificato utilizzato richiede la protezione a chiave avanzata), Exchange Server ricorre automaticamente a LDAP senza SSL. Se viene visualizzato questo messaggio di avviso, possono essersi verificati problemi di connettività tra Exchange Server Analyzer e il controller di dominio. I problemi relativi all'infrastruttura a chiave pubblica (PKI) o ad altri certificati non verranno rilevati da questo avviso.

Sono molti i motivi per cui le richieste LDAP su SSL possono non essere elaborate correttamente dal controller di dominio nel momento in cui vengono eseguite query da Exchange Server Analyzer.

Per risolvere il problema

  1. Verificare che l'account da cui viene eseguito lo strumento sia autorizzato a eseguire query nel controller di dominio. Sono necessarie autorizzazioni a livello di utente per il dominio in cui viene eseguito il controller di dominio. Per ulteriori informazioni sulle autorizzazioni necessarie per eseguire Exchange Server Analyzer, consultare il file della Guida fornito con lo strumento. Aprire il file della Guida avviando Exchange Server Analyzer, fare clic su ?, quindi scegliere Guida in linea Microsoft Exchange Server Analyzer Tool.

  2. Verificare che non siano presenti firewall o restrizioni di porta tra il computer su cui viene eseguito Exchange Server Analyzer e il controller di dominio che non risponde correttamente.

  3. Verificare che il controller di dominio sia connesso alla rete e funzioni correttamente.

  4. Verificare che l'ora sul computer in cui viene eseguito Exchange Server Analyzer e il controller di dominio che non risponde correttamente sia sincronizzata. Se il servizio Ora di Microsoft Windows® sul controller di dominio viene arrestato o disabilitato, l'ora locale del controller di dominio potrebbe non risultare sincronizzata. In tal caso, il controller di dominio non risponderà alle richieste LDAP su SSL finché l'orologio non sarà sincronizzato.

Per ulteriori informazioni sull'uso di LDAP su SSL, consultare l'articolo 321051 della Microsoft Knowledge Base "Abilitazione di LDAP su SSL con una CA di terze parti" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321051.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla connettività di Active Directory, consultare l'articolo 816103 della Microsoft Knowledge Base "HOW TO: Utilizzo di Portqry per risolvere i problemi di connettività di Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816103.

Per ulteriori informazioni sul servizio Ora di Windows, consultare l'articolo 816042 della Microsoft Knowledge Base "Configurazione di un server di riferimento ora autorevole in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=816042.


Il server SMTP non supporta il comando X-LINK2STATE
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool avvia una sessione SMTP con il server di Exchange per assicurare che siano elencati i comandi SMTP di Exchange corretti. Se il comando X-LINK2STATE non è elencato, verrà visualizzato un avviso.

Il comando X-LINK2STATE viene utilizzato da Exchange per aggiornare le tabelle di stato dei collegamenti nei server di routing principali. Le tabelle di stato dei collegamenti registrano informazioni aggiornate sullo stato dei collegamenti SMTP nell'intera organizzazione di Exchange. In Exchange queste informazioni vengono utilizzate per scegliere il costo più basso e le route più affidabili durante l'instradamento dei messaggi. Tale funzionalità viene anche definita "Routing intelligente".

Il comando X-LINK2STATE è richiesto da Exchange per l'esecuzione di un routing efficace e non viene utilizzato da altri provider SMTP. Pertanto, la funzionalità viene fornita in un file (xlsasink.dll) installato e registrato mediante il programma di installazione di Exchange.

Questo avviso può essere restituito per due motivi noti. Innanzitutto, alcuni amministratori possono aver disabilitato xlsasink.dll per aggirare la funzionalità di routing intelligente fornita. Si tratta di un'operazione non consigliabile, che determinerà probabilmente problemi in termini di prestazioni e affidabilità. In questo caso, si consiglia di reinstallare Exchange nel computer interessato per installare e registrare xlsasink.dll.

In secondo luogo, l'avviso può essere restituito se si esegue un prodotto antivirus che installa e utilizza un proprio stack del protocollo SMTP per analizzare i messaggi. In questo caso, il software antivirus può eseguire il proprio stack SMTP che intercetta e analizza i messaggi prima che raggiungano lo stack SMTP di Exchange. Sempre in questo caso, lo stack SMTP dell'antivirus non utilizza il comando X-LINK2STATE. Si consiglia di eseguire il software antivirus in una modalità che non richieda l'installazione del proprio stack SMTP nel server di Exchange.

Per ulteriori informazioni su X-LINK2STATE e altri comandi proprietari utilizzati da Exchange, consultare l'articolo della Microsoft Knowledge Base 812455 "Definizioni dei comandi utilizzati tra due server di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455.

Per ulteriori informazioni sulle procedure per visualizzare i comandi di Exchange e per reinstallare Exchange 2000 Server, consultare l'articolo 319885 della Knowledge Base "XCON: I messaggi inviati nell'organizzazione di Exchange 2000 Server non vengono recapitati" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885.

Per ulteriori informazioni sulle procedure per visualizzare i comandi di Exchange e per reinstallare Exchange Server 2003, consultare l'articolo 822939 della Knowledge Base "I messaggi inviati nell'organizzazione di Exchange 2000 Server non vengono recapitati" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939.


Il server SMTP non è riuscito a eseguire il test di accettazione della posta
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool tenta di inviare un messaggio all'account Postmaster per il dominio SMTP (Simple Mail Transfer Protocol) eseguendo le attività indicate di seguito:

  • Apertura di una connessione del socket al server SMTP. Se Exchange Server Analyzer riceve un codice di risposta pari a 220, questo passaggio è da considerarsi completato correttamente.

  • Trasmissione del comando SMTP EHLO. Se Exchange Server Analyzer riceve una serie di codici di risposta pari a 250, compresa una risposta che include 250-X-LINK2STATE e 250-XEXCH50, questo passaggio è da considerarsi completato correttamente.

  • Trasmissione del comando SMTP MAIL FROM: ExBPA-MailAcceptTest@Fabrikam.com. Se Exchange Server Analyzer riceve un codice di risposta pari a 250, questo passaggio è da considerarsi completato correttamente.

  • Trasmissione del comando SMTP RCPT TO: Postmaster@<nomedominio>.com. Se Exchange Server Analyzer riceve un codice di risposta pari a 250, questo passaggio è da considerarsi completato correttamente.

Se non è possibile completare correttamente tutti i passaggi, verrà visualizzato un messaggio di errore. Tale messaggio indica che può essersi verificato un problema generale di flusso di posta. I collegamenti indicati di seguito vengono elencati nell'ordine in cui dovrebbero essere risolti i problemi, iniziando dal livello di server e spostandosi al livello di rete.

Per risolvere il problema

  1. Consultare "Risoluzione dei problemi di routing" nella Guida al trasporto e al routing di Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=47579.

  2. Consultare l'articolo 324867 della Microsoft Knowledge Base "WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi di flusso di posta (rivisto)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867.

  3. Consultare l'articolo 823489 della Microsoft Knowledge Base "Utilizzo del visualizzatore code per risolvere i problemi relativi al flusso della posta" all'indirizzo (http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489.

  4. Consultare l'articolo 324759 della Microsoft Knowledge Base "WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759.

Per ulteriori informazioni sull'account Postmaster in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 223860, "XCON: La cassetta postale SMTP Postmaster deve essere impostata manualmente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860.

  • 313832, "HOW TO: Impostazione di un account SMTP Postmaster in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832.


Il server SMTP non ha eseguito correttamente il test di inoltro aperto
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2007-03-14

Microsoft® Exchange Server Analyzer Tool tenta di inoltrare un messaggio tramite un server SMTP (Simple Mail Transfer Protocol) eseguendo le attività indicate di seguito:

  • Apertura di una connessione del socket al server SMTP. Se Exchange Server Analyzer riceve un codice di risposta pari a 220, questo passaggio è da considerarsi completato correttamente.

  • Trasmissione del comando SMTP EHLO. Se Exchange Server Analyzer riceve una serie di codici di risposta pari a 250, compresa una risposta che include 250-X-LINK2STATE e 250-XEXCH50, questo passaggio è da considerarsi completato correttamente.

  • Trasmissione del comando SMTP MAIL FROM: ExBPA-OpenRelayTest@Fabrikam.com. Se Exchange Server Analyzer riceve un codice di risposta pari a 250, questo passaggio è da considerarsi completato correttamente.

  • Trasmissione del comando SMTP RCPT TO: ExBPA-OpenRelayTest@Fabrikam.com. Se Exchange Server Analyzer riceve un codice di risposta pari a 250, questo passaggio è da considerarsi completato correttamente.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore di questa chiave corrisponde a una versione specifica di un sistema operativo Windows Server.

Se Exchange Server Analyzer riesce a completare correttamente tutti i passaggi in un computer Exchange Server che fa parte di un'installazione Microsoft Small Business Server 2000 o Microsoft Windows Small Business Server 2003, verrà visualizzato un messaggio di errore.

Tale errore indica che questo server è configurato come un inoltro aperto.

Si sconsiglia di consentire l'inoltro aperto.

L'inoltro aperto si verifica quando un server di posta elettronica consente l'inoltro di messaggi di posta attraverso il sistema senza applicare restrizioni o controlli della posta inoltrata.

Nota:
Se per qualunque motivo l'organizzazione di Exchange utilziza un dominio SMTP denominato Fabrikam.com, è possibile che si verifichi questo errore. In tal caso, è possibile ignorarlo senza problemi. Il dominio Fabrikam.com è di proprietà di Microsoft Corporation e viene utilizzato per esercitazioni, documentazione e altri scopi simili.

L'inoltro non è necessariamente un evento negativo, perché il protocollo SMTP è stato progettato a tale scopo. Per ulteriori informazioni, consultare le sezioni 2.1 e 3.7 del documento RFC 2821 all'indirizzo http://ietf.org (informazioni in lingua inglese). Tuttavia, se l'inoltro non è controllato (un host non controllato è definito host di inoltro aperto), un utente malintenzionato potrebbe potenzialmente utilizzare la funzione di inoltro per inviare grandi quantità di messaggi pubblicitari non richiesti tramite posta elettronica (spamming). Rimandando a un host intermedio questi messaggi non richiesti, l'utente malintenzionato tenta di nascondere la propria identità. Inoltre, in tal modo si occupano risorse nell'host di inoltro che può non essere in grado di inviare messaggi di posta elettronica validi. In particolare, la maggior parte degli utenti che invia messaggi di posta elettronica non richiesti può inviare un singolo messaggio a un numero incredibile di destinatari senza utilizzare la propria ampiezza di banda per eseguire l'operazione.

Assicurarsi di non consentire inoltri anonimi ai propri server virtuali SMTP connessi a Internet. Nella propria configurazione predefinita, Exchange consente solo agli utenti autenticati di inoltrare messaggi di posta. Solo gli utenti autenticati possono usare Exchange per inviare messaggi di posta a un dominio esterno. Se si modificano le impostazioni di inoltro predefinite per consentire agli utenti non autenticati di eseguire inoltri oppure se si consente l'inoltro aperto a un dominio tramite un connettore, utenti non autorizzati o worm dannosi potranno utilizzare il server di Exchange per inviare spam. Il server si può bloccare e non essere in grado di inviare messaggi di posta elettronica a server remoti legittimi. Per impedire a utenti non autorizzati di utilizzare il server di Exchange per l'inoltro di posta, utilizzare almeno le restrizioni di inoltro predefinite.

Se si hanno motivi validi per eseguire inoltri, seguire le linee guida fornite per assicurarsi d mantenere la protezione dell'implementazione. L'operazione viene eseguita per lo più lasciando tutte le impostazioni predefinite di negazione, aggiungendo solo gli indirizzi IP dai quali saranno accettati messaggi di posta inoltrati e disabilitando l'accesso agli utenti autenticati.

Analizzare il modo in cui vengono utilizzati gli account incorporati (Amministratore locale) e gli altri utenti nei server gateway. È improbabile che si utilizzino gli account incorporati per tutti i tipi di inoltro. Se si utilizza la funzione di inoltro, probabilmente l'operazione viene eseguita da un insieme noto di utenti o computer. È consigliabile limitare i diritti di inoltro a utenti e computer espliciti o a un indirizzo IP.

Se si configurano autorizzazioni esplicite per l'inoltro, il server sarà ulteriormente protetto. Gli utenti malintenzionati possono tentare di attaccare il sistema per tentare di ottenere le password degli account incorporati o degli account utente trovati in Internet, in modo da utilizzare il server come proxy di spam. Pertanto non è consigliabile abilitare per i computer accessibili da Internet l'impostazione predefinita che consente a qualunque computer autenticato di eseguire inoltri. È consigliabile disabilitare questa impostazione.

Le procedure che seguono indicano come disabilitare l'inoltro anonimo se il server virtuale SMTP è o non è connesso a Internet. Come detto precedentemente in questo articolo, è consigliabile abilitare qualunque forma di inoltro anonimo solo nei casi in cui si sia compreso e accettato il rischio per la protezione dell'organizzazione. I riferimenti al termine di questo articolo offrono ulteriori informazioni su come utilizzare la funzione di inoltro.

Se un server virtuale SMTP non è accessibile da Internet, è consigliabile ripristinare le configurazioni di inoltro predefinite. In tal modo i server virtuali SMTP consentiranno solo l'inoltro interno da computer autenticati.

Per i server virtuali SMTP accessibili da Internet è consigliabile consolidare ulteriormente le configurazioni di inoltro predefinite, in modo che solo gli utenti e i computer con autorizzazioni esplicite possano eseguire inoltri.

Se si è verificato che Exchange è configurato in modo da bloccare l'inoltro ma il messaggio di errore continua a essere visualizzato in Exchange Server Analyzer, è preferibile controllare che non sia attivo un server proxy o un processo, come un firewall, un software antivirus o anti spam, che consente l'inoltro anonimo.

Per ripristinare le configurazioni predefinite di inoltro anonimo in server virtuali SMTP interni

  1. Aprire Gestore di sistema di Exchange.

  2. Nella struttura della console espandere Server, il server desiderato, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP al quale si desidera applicare limitazioni di inoltro e scegliere Proprietà.

  4. Nella finestra di dialogo <Proprietà di Server virtuale SMTP> fare clic sulla scheda Accesso, quindi su Inoltro.

  5. In Limitazioni inoltro, nella sezione Specificare quali computer sono autorizzati all'inoltro tramite il server virtuale, scegliere Solo i computer indicati nell'elenco, selezionare la casella di controllo Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sotto e fare clic su OK.

Per configurare le autorizzazioni di inoltro esplicite in server virtuali SMTP connessi a Internet in Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Nella struttura della console espandere Server, il server desiderato, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP al quale si desidera applicare limitazioni di inoltro e scegliere Proprietà.

  4. Nella finestra di dialogo <Proprietà di Server virtuale SMTP> fare clic sulla scheda Accesso, quindi su Inoltro.

  5. In Limitazioni inoltro deselezionare la casella di controllo Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sotto e fare clic su Utenti per specificare un sottoinsieme di utenti ai quali concedere autorizzazioni di inoltro sul server virtuale SMTP.

  6. In Autorizzazioni di invio e di inoltro selezionare un gruppo o un utente da rimuovere, quindi fare clic su Rimuovi.

  7. Per aggiungere un gruppo o un utente, fare clic su Aggiungere e scegliere gli utenti o i gruppi per i quali si desidera specificare le autorizzazioni. Selezionare una delle opzioni seguenti:

    • Nel campo Immetti il nome dell'oggetto da selezionare di Seleziona utenti, computer o gruppi in Microsoft Windows Server™ 2003 digitare il nome dell'utente o del gruppo. Se si desidera cercare l'utente o il gruppo, fare clic su Avanzate, cercare il nome dell'utente o del gruppo, quindi fare clic su Controlla nomi per convalidare il testo immesso.

      Suggerimento:
      Fare clic sul collegamento esempi per visualizzare i formati accettabili del testo da immettere.
    • In Seleziona utenti, computer o gruppi, in Windows 2000 Server, selezionare l'utente o il gruppo a cui si desidera concedere autorizzazioni di invio, quindi fare clic su Aggiungi.

  8. Fare clic su OK per tornare alla finestra di dialogo Autorizzazioni di invio e di inoltro.

  9. In Elenco nomi di gruppi o utenti selezionare il gruppo appena aggiunto.

  10. In Autorizzazioni per <il gruppo selezionato>, vicino a Autorizzazione di invio, se necessario, selezionare la casella di controllo nella sezione Consenti per consentire all'utente o al gruppo selezionato di inviare messaggi di posta tramite questo server virtuale SMTP.

  11. Selezionare la casella di controllo sotto Consenti, vicino a Autorizzazioni di inoltro, per consentire all'oggetto selezionato di eseguire inoltri tramite questo server virtuale SMTP, oppure selezionare la casella di controllo sotto Rifiuta per impedire all'oggetto selezionato di eseguire inoltri dal server virtuale.

    Nota:
    Se desidera concedere le autorizzazioni di inoltro, è prima necessario concedere le autorizzazioni di invio.

  12. Fare clic su OK.

Per configurare le autorizzazioni di inoltro in server virtuali SMTP connessi a Internet in Exchange 2000 Server

  1. Aprire Gestore di sistema di Exchange.

  2. Nella struttura della console espandere Server, il server desiderato, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP al quale si desidera applicare limitazioni di inoltro e scegliere Proprietà.

  4. Nella finestra di dialogo Proprietà di <Server virtuale SMTP> fare clic sulla scheda Accesso, quindi su Inoltro.

  5. In Limitazioni inoltro, nella sezione Specificare quali computer sono autorizzati all'inoltro tramite il server virtuale, selezionare Solo i computer indicati nell'elenco.

  6. Fare clic su Aggiungi per aggiungere un singolo computer, un gruppo di computer o un nome di dominio SMTP, quindi fare clic su OK. Ripetere questo passaggio per ogni voce aggiuntiva da aggiungere.

  7. Selezionare la casella di controllo Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sopra, quindi fare clic due volte su OK.

Per ulteriori informazioni sull'inoltro di messaggi e la protezione consultare i seguenti manuali della Libreria tecnica di Exchange Server 2003:

  • Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47579.

  • Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47587.

Per ulteriori informazioni sulla verifica e il consolidamento di un comportamento di inoltro aperto nel proprio ambiente Exchange e Microsoft Windows, consultare l'articolo 304897 della Microsoft Knowledge Base "Comportamento della funzionalità di inoltro SMTP in Windows 2000, Windows XP e in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=304897.


La versione di SMTP in esecuzione non supporta il comando XEXCH50
Articoli su Microsoft Exchange Server Analyzer > Rete >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool avvia una sessione SMTP con il server di Exchange per assicurare che siano elencati i comandi SMTP di Exchange corretti. Se il comando XEXCH50 non è elencato, verrà visualizzato un avviso.

Tra l'altro, il comando XEXCH50 viene utilizzato da Exchange per la replica delle cartelle pubbliche. L'esecuzione di una versione di SMTP su un server di Exchange che non supporta il comando XEXCH50 interromperà la replica delle cartelle pubbliche.

Il comando XEXCH50 non viene utilizzato da altri provider SMTP; pertanto, la relativa funzionalità viene fornita in un file (peexch50.dll) installato e registrato mediante il programma di installazione di Exchange.

È possibile che Exchange Server Analyzer restituisca questo avviso se si esegue un prodotto antivirus che installa e utilizza un proprio stack del protocollo SMTP per analizzare i messaggi. In questo caso, il software antivirus può eseguire il proprio stack SMTP che intercetta e analizza i messaggi prima che raggiungano lo stack SMTP di Exchange. Inoltre, lo stack SMTP del software antivirus non utilizza il comando XEXCH50.

Si consiglia di eseguire il software antivirus in una modalità che non richiede l'installazione del proprio stack SMTP nel server di Exchange o di eseguire tale software in corrispondenza del perimetro di ingresso della rete SMTP. Se lo stack SMTP del software antivirus è stato disabilitato e viene ancora visualizzato l'avviso, reinstallare Exchange in modo da installare e registrare peexch50.dll correttamente.

Per ulteriori informazioni su XEXCH50 e altri comandi proprietari utilizzati da Exchange, consultare l'articolo 812455 della Microsoft Knowledge Base "Definizioni di comandi utilizzati tra due server di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812455.

Per ulteriori informazioni sulle procedure per visualizzare i comandi di Exchange e per reinstallare Exchange 2000 Server, consultare l'articolo 319885 della Knowledge Base "XCON: I messaggi inviati nell'organizzazione di Exchange 2000 Server non vengono recapitati" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319885.

Per ulteriori informazioni sulle procedure per visualizzare i comandi di Exchange e per reinstallare Exchange Server 2003, consultare l'articolo 822939 della Knowledge Base "I messaggi inviati nell'organizzazione di Exchange 2000 Server non vengono recapitati" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822939.


Protocolli
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente ai protocolli Internet. In questi articoli, inoltre, sono descritte le operazioni eseguibili per risolvere errori, messaggi di avviso e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi ai protocolli Internet.


Errore risposta ciclo di andata e ritorno di Active Directory
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PingStatus per determinare il valore della chiave StatusCode restituito dal server del servizio directory di Active Directory®. Win32_PingStatus restituisce un oggetto con 24 proprietà che forniscono informazioni dettagliate relative ai pacchetti ping inviati dalla classe.

Se Exchange Server Analyzer rileva che il valore della chiave corrisponde a uno dei valori riportati nella seguente tabella, verrà visualizzato un messaggio di errore.

Verrà inoltre visualizzato il nome del server di Active Directory e il valore StatusCode corrispondente restituito con questo errore.

Valore StatusCode Significato Descrizione

11001

Buffer troppo piccolo

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11002

Rete di destinazione non raggiungibile

La richiesta non è riuscita perché la rete contenente il computer di destinazione non è raggiungibile. Non esiste una route valida verso il computer di destinazione.

Per informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11003

Host di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non è raggiungibile.

Per ulteriori informazioni, consultare Server di Active Directory inattivo o irraggiungibile.

Questo errore potrebbe anche essere il risultato di un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione oppure potrebbe essere un errore DSN.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11004

Protocollo di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non risponde al protocollo del pacchetto.

Questo errore potrebbe anche essere il risultato di un firewall tra il computer in cui viene eseguito Exchange Server Analyzer e il controller di dominio di destinazione.

11005

Porta di destinazione non raggiungibile

La richiesta non è riuscita perché la porta sul computer di destinazione non è disponibile.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11006

Nessuna risorsa

La richiesta non è riuscita perché le risorse di rete non sono sufficienti.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11007

Opzione non valida

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11008

Errore hardware

La richiesta non è riuscita perché si è verificato un errore hardware.

Assicurarsi che il controller di dominio funzioni correttamente eseguendo lo strumento di controllo di integrità dell'hardware fornito dal produttore del computer.

11009

Dimensioni pacchetto troppo elevate

La richiesta non è riuscita perché la dimensione del pacchetto contenente la richiesta è superiore all'unità massima di trasmissione (MTU) di un nodo (router o gateway) situato tra l'origine e la destinazione. L'MTU definisce la dimensione massima di un pacchetto per eseguirne la trasmissione.

La dimensione della richiesta inviata da Exchange Server Analyzer non è superiore a 10 KB. Assicurarsi che i router e i gateway dell'organizzazione siano configurati correttamente.

Per ulteriori informazioni, consultare l'articolo 159211 della Knowledge Base "Diagnosi e trattamento dei router black hole" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211.

11010

Timeout della richiesta

La risposta non è stata ricevuta entro l'intervallo di tempo assegnato. L'intervallo di tempo predefinito per le risposte è pari a cinque secondi.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11011

Richiesta non valida

La richiesta non è riuscita perché è stata codificata in modo errato.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11012

Route non valida

La richiesta non è riuscita perché non esiste una route valida tra i computer di origine e di destinazione.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11013

Transito TimeToLive scaduto

La richiesta non è riuscita perché la durata (TTL) ha raggiunto il valore zero e il nodo di inoltro (router o gateway) ha scartato il pacchetto.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11014

Riassemblaggio TimeToLive scaduto

La richiesta non è riuscita perché il pacchetto è stato frammentato per la trasmissione e non sono stati ricevuti tutti i frammenti entro l'intervallo di tempo assegnato al riassemblaggio. Nel documento RFC 2460 (disponibile all'indirizzo http://www.ietf.org/rfc/rfc2460.txt) viene specificato un limite di tempo di 60 secondi per la ricezione di tutti i frammenti del pacchetto.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11015

Problema di parametro

La richiesta non è riuscita perché in un nodo (router o gateway) si sono verificati dei problemi durante l'elaborazione dell'intestazione del pacchetto. Questo problema si verifica se, ad esempio, l'intestazione contiene dei dati di campo non validi oppure un'opzione non riconosciuta.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11016

Richiesta di rallentamento dell'origine

La richiesta non è riuscita perché il pacchetto è stato scartato. Ciò si verifica quando la coda di output del computer di origine non dispone di spazio di archiviazione sufficiente, oppure quando i pacchetti arrivano a destinazione troppo velocemente per consentirne l'elaborazione.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11017

Opzione troppo ampia

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11018

Destinazione non valida

La richiesta non è riuscita perché l'indirizzo IP di destinazione non può ricevere le richieste PING oppure non dovrebbe mai essere visualizzato nel campo dell'indirizzo di destinazione di un datagramma IP.

Ciò potrebbe anche essere provocato da un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione.

11032

Negoziazione IPSEC in corso

La richiesta non è riuscita perché una connessione IPsec potrebbe non essere stata negoziata.

11050

Errore generale

La richiesta non è riuscita per motivi sconosciuti.

Per informazioni, consultare l'articolo 325487 della Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.


Errore di risposta del ciclo di andata e ritorno da Active Directory a Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PingStatus per determinare il valore della chiave StatusCode restituito dal server del servizio directory di Active Directory®. Win32_PingStatus restituisce un oggetto con 24 proprietà che forniscono informazioni dettagliate relative ai pacchetti ping inviati dalla classe.

Se Exchange Server Analyzer rileva che il valore di questa chiave corrisponde a uno dei valori nella seguente tabella, verrà visualizzato un errore.

Viene visualizzato il nome del server Active Directory, il nome del server Exchange e il valore StatusCode corrispondente, restituito con l'errore.

Valore StatusCode Significato Descrizione

11001

Buffer troppo piccolo

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11002

Rete di destinazione non raggiungibile

La richiesta non è riuscita perché la rete contenente il computer di destinazione non è raggiungibile. Non esiste una route valida verso il computer di destinazione.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11003

Host di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non è raggiungibile.

Per ulteriori informazioni, vedere Server di Active Directory inattivo o irraggiungibile.

In alternativa, questo errore può essere provocato da una delle seguenti condizioni:

  • Un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione.

  • Un errore DNS.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11004

Protocollo di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non risponde al protocollo del pacchetto.

Questo errore potrebbe essere il risultato di un firewall tra il computer in cui viene eseguito Exchange Server Analyzer e il controller di dominio di destinazione.

11005

Porta di destinazione non raggiungibile

La richiesta non è riuscita perché la porta sul computer di destinazione non è disponibile.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11006

Nessuna risorsa

La richiesta non è riuscita perché le risorse di rete non sono sufficienti.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11007

Opzione non valida

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11008

Errore hardware

La richiesta non è riuscita perché si è verificato un errore hardware.

Assicurarsi che il controller di dominio funzioni correttamente eseguendo lo strumento di controllo di integrità dell'hardware fornito dal produttore del computer.

11009

Dimensioni pacchetto troppo elevate

La richiesta non è riuscita perché la dimensione del pacchetto contenente la richiesta è superiore all'unità massima di trasmissione (MTU) di un nodo router o gateway situato tra l'origine e la destinazione. L'MTU definisce la dimensione massima di un pacchetto per eseguirne la trasmissione.

La dimensione della richiesta inviata da Exchange Server Analyzer non è superiore a 10 KB. Assicurarsi che i router e i gateway dell'organizzazione siano configurati correttamente.

Per ulteriori informazioni, vedere l'articolo 159211 della Microsoft Knowledge Base "Diagnosi e trattamento dei router black hole" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211.

11010

Timeout della richiesta

La risposta non è stata ricevuta entro l'intervallo di tempo assegnato. L'intervallo di tempo predefinito per le risposte è pari a cinque secondi.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11011

Richiesta non valida

La richiesta non è riuscita perché è stata codificata in modo errato.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11012

Route non valida

La richiesta non è riuscita perché non esiste una route valida tra i computer di origine e di destinazione.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11013

Transito TimeToLive scaduto

La richiesta non è riuscita perché la durata (TTL) ha raggiunto il valore zero. Il nodo di inoltro router o gateway scarta il pacchetto.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11014

Riassemblaggio TimeToLive scaduto

La richiesta non è riuscita perché il pacchetto è stato frammentato per la trasmissione e non sono stati ricevuti tutti i frammenti entro l'intervallo di tempo assegnato al riassemblaggio. Nel documento RFC 2460 (disponibile all'indirizzo http://www.ietf.org/rfc/rfc2460.txt) viene specificato un limite di tempo di 60 secondi per la ricezione di tutti i frammenti del pacchetto.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11015

Problema di parametro

La richiesta non è riuscita perché in un nodo router o gateway si sono verificati dei problemi durante l'elaborazione dell'intestazione del pacchetto. Questo problema può verificarsi se l'intestazione contiene dei dati di campo non validi oppure un'opzione non riconosciuta.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11016

Richiesta di rallentamento dell'origine

La richiesta non è riuscita perché il pacchetto è stato scartato. Ciò si verifica quando la coda di output del computer di origine non dispone di spazio di archiviazione sufficiente. In alternativa, si può verificare quando i pacchetti arrivano a destinazione troppo velocemente per consentirne l'elaborazione.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11017

Opzione troppo ampia

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11018

Destinazione non valida

La richiesta non è riuscita per uno dei seguenti motivi:

  • L'indirizzo IP di destinazione non può ricevere le richieste PING.

  • L'indirizzo IP di destinazione non dovrebbe mai essere visualizzato nel campo dell'indirizzo di destinazione di un datagramma IP.

Ciò potrebbe essere provocato da un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione.

11032

Negoziazione IPSEC in corso

La richiesta non è riuscita perché una connessione IPsec potrebbe non essere stata negoziata.

11050

Errore generale

La richiesta non è riuscita per motivi sconosciuti.

Per ulteriori informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.


Accesso anonimo consentito sui server virtuali SMTP interni e su quelli dedicati per client IMAP e POP
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchAuthenticationFlags nella classe protocolCfgSMTPServer per l'oggetto Exchange Server. La classe protocolCfgSMTPServer contiene le impostazioni per un server virtuale SMTP. L'attributo msExchAuthenticationFlags rappresenta il tipo di autenticazione accettato dal server virtuale SMTP. Se le seguenti condizioni vengono soddisfatte, in Exchange Server Analyzer verrà visualizzato un avviso:

  • L'autenticazione sull'attributo msExchAuthenticationFlags è stata configurata per consentire l'accesso anonimo al server SMTP.

  • Il server non esegue Microsoft Small Business Server 2000 o Microsoft Windows® Small Business Server 2003.

  • Exchange Server contiene più di 20 cassette postali.

Per garantire una maggiore protezione, disabilitare l'accesso anonimo sui server virtuali SMTP interni che non accettano la posta Internet in arrivo. Per garantire una maggiore protezione, è inoltre possibile disabilitare l'accesso anonimo sui server virtuali SMTP dedicati per gli utenti remoti IMAP e POP.

Importante:
Non disabilitare l'accesso remoto sui server virtuali SMTP testa di ponte di Internet. I server virtuali SMTP che accettano la posta da Internet devono consentire l'accesso anonimo.

Quando si invia posta elettronica interna, i server di Exchange nell'organizzazione si autenticano reciprocamente per l'invio della posta. Pertanto, non è necessario abilitare l'accesso anonimo sui server virtuali SMTP interni. Evitando l'accesso anonimo sui server interni, non si verificheranno problemi nel flusso di posta elettronica e si fornirà un livello di protezione aggiuntivo al server virtuale SMTP interno.

Analogamente, i client IMAP e POP eseguono l'autenticazione con i server virtuali SMTP prima dell'invio della posta ai server virtuali SMTP. Pertanto, se si utilizzano server virtuali SMTP per i client IMAP e POP, sarà possibile configurare tali server affinché consentano solo l'accesso autenticato. Se si disabilita l'accesso anonimo su questi server, si impedirà l'accesso agli utenti non autorizzati.

Se non è possibile disabilitare l'accesso autenticato sul server virtuale SMTP per motivi aziendali, quali, ad esempio, l'autenticazione da parte di società partner, seguire i passaggi riportati di seguito per migliorare la protezione sul server gateway:

  • Applicare dei criteri di gestione delle password avanzati per tutti gli account utente, in particolare per l'account amministratore.

  • Disabilitare l'account Guest. Per ulteriori informazioni sulla disabilitazione dell'account Guest, consultare l'articolo 320053 della Microsoft Knowledge Base "Ridenominazione degli account Guest e amministratore in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053. Sebbene l'articolo si riferisca a Windows 2000 Server, si applicano principi analoghi anche a Windows Server 2003.

Per disabilitare l'autenticazione dell'accesso anonimo per un server virtuale SMTP

  1. In Gestore di sistema di Exchange espandere Server, <your inbound Exchange server>, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse sul server virtuale SMTP in ingresso e scegliere Proprietà.

  3. Fare clic sulla scheda Accesso, quindi su Autenticazione.

  4. In Autenticazione deselezionare la casella di controllo Accesso anonimo.

Per ulteriori informazioni sulla configurazione dell'organizzazione di Exchange Server 2003 per proteggere ulteriormente l'invio e la ricezione della posta Internet, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


La scansione antivirus in background è stata abilitata
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la ricerca di virus in background è stata abilitata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Se Exchange Server Analyzer rileva che il valore della voce BackgroundScanning è impostato su 1, verrà visualizzato un avviso.

Quando la voce BackgroundScanning del Registro di sistema è presente e impostata su 1, tutti i messaggi vengono nuovamente analizzati in background ogni volta che viene aggiornato il file della firma del programma antivirus. Questo comportamento influisce notevolmente sulle prestazioni ogni volta che un file della firma del programma antivirus viene aggiornato, pertanto non è consigliato da Microsoft.

Quando si utilizza un programma antivirus basato sulla tecnlogia VSAPI 2.0 (Virus Scanning Application Programming Interface) e un client tenta di aprire un messaggio, viene eseguito un confronto per assicurare che il corpo del messaggio e l'allegato siano stati analizzati dal file corrente delle firme dei virus. Se per analizzare il contenuto non è stato utilizzato il file delle firme corrente, un messaggio corrispondente viene inoltrato al programma antivirus prima che tale messaggio sia disponibile per il client.

Se il programma antivirus installato non include un'interfaccia utente che consenta di disabilitare la ricerca in background, è possibile utilizzare la procedura indicata di seguito per controllare questo comportamento modificando il Registro di sistema sul computer in cui è installato Exchange Server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Nel riquadro destro fare doppio clic sul valore BackgroundScanning.

  4. Nel campo Dati valore, modificare il valore impostandolo su 0.

  5. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange e i servizi del software antivirus.
  • Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

  • Per ulteriori informazioni sui diversi tipi di programmi antivirus utilizzati da Exchange, consultare l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.


Il valore CheckPop3Tail è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se esiste il seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\CheckPop3Tail

Se Exchange Server Analyzer rileva che il valore CheckPop3Tail è presente e configurato con il valore 1, verrà visualizzato un messaggio di configurazione non predefinita.

Il documento RFC (Request For Comments) IETF (Internet Engineering Task Force) 1939 (all'indirizzo http://www.ietf.org/rfc/rfc1939.txt) specifica una sequenza di terminazione di CRLF per i messaggi POP3. Nella terminologia Exchange, la sequenza CRLF viene definita POP3Tail. Se un client POP3 quale Microsoft Office Outlook® 2003 o Microsoft Outlook Express rileva un messaggio non corretto con POP3Tail errato (ad esempio, per mancanza di CRLF), è possibile che interrompa le operazioni di risposta e non riesca a scaricare tutti i messaggi presenti in Posta in arrivo. Il valore CheckPop3Tail del Registro di sistema rappresenta una possibilità di configurazione per gli amministratori che possono indicare al servizio Microsoft Exchange POP3 di controllare il POP3Tail di ciascun messaggio POP3 e aggiungere la corretta sequenza di terminazione, nel caso sia mancante.

Nota:
Questa impostazione correggerà i messaggi errati e consentirà al client POP3 di eseguire il download di tutti i messaggi nella cartella Posta in arrivo dell'utente; tuttavia, provocherà anche una lieve riduzione del livello delle prestazioni poiché verrà controllata la presenza di un POP3Tail appropriato per ogni messaggio.

Se si desidera, è possibile utilizzare la procedura indicata di seguito per rimuovere il valore CheckPop3Tail del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per eliminare il valore CheckPop3Tail del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Eliminare il valore denominato CheckPop3Tail.

  4. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange POP3.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'utilizzo del valore CheckPop3Tail del Registro di sistema, consultare l'articolo 816896 della Microsoft Knowledge Base "XCCC: Interruzione di risposta (blocco) da parte del client POP3 o timeout quando si tenta di scaricare messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=816896.


Defense Message System abilitato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo heuristics è stato configurato per l'attivazione del Sistema di difesa messaggi. Per impostazione predefinita, l'attributo heuristics non è configurato. Se Exchange Server Analyzer rileva che l'attributo heuristics è stato impostato su 256, verrà visualizzato un messaggio di configurazione non predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Il Sistema di difesa messaggi (DMS) è stato creato dal Sottosegretario alla difesa per facilitare e coordinare lo sviluppo di un sistema di messaggi integrato per l'utente comune che soddisfa le richieste writer-to-reader, riduce i costi e i livelli dello staff e migliora la funzionalità, la protezione, la longevità e la disponibilità.

Per ulteriori informazioni sul Sisitema di difesa messaggi, consultare il sito Web della Lockheed Martin all'indirizzo http://www.lockheedmartin.com (informazioni in lingua inglese).

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Avviso di Disable MAPI clients
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-05-01

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il blocco dei client MAPI è stato impostato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable MAPI Clients

Se Exchange Server Analyzer rileva che il valore impostato per Disabled MAPI Clients inizia con -10, -11 o -12, verrà visualizzato un avviso.

Per impostazione predefinita, la chiave Disable MAPI Clients non è abilitata. Pertanto, l'amministratore può impedire a determinate versioni di Microsoft Office Outlook® di connettersi a un computer su cui è in esecuzione Exchange 2000 Server, Exchange Server 2003 o Exchange Server 2007.

Se la chiave Disabled MAPI Clients è impostata su un valore che inizia con -10, -11 o -12, verranno bloccati intervalli completi di versioni MAPI. Questi intervalli corrispondono alle versioni di Outlook 2000, Outlook 2003 e Outlook 2007 e al Supervisore sistema di Microsoft Exchange in Exchange Server 2003. Se viene bloccato il servizio Supervisore sistema di Microsoft Exchange, è probabile che si verifichino dei funzionamenti errati di Exchange Server.

Per risolvere il problema, vedere le indicazioni e le procedure riportate in L'accesso al server è consentito per tutte le versioni di Outlook.

Per ulteriori informazioni sul blocco della connessione a computer che eseguono Exchange 2000 Server o Exchange Server 2003 per determinati client MAPI, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328240, "Come imporre restrizioni sul lato server ai client utilizzati per accedere alle cassette postali di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240.

  • 288894, "Disabilitazione dell'accesso dei client MAPI a un computer che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894.

Per ulteriori informazioni sul blocco della connessione a computer che eseguono Exchange Server 2007 per determinati client MAPI, consultare il cmdlet "Set-CasMailbox" di Exchange Management Shell nella documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80698.

Per ulteriori informazioni sul download di aggiornamenti della protezione per versioni precedenti di Outlook e sul blocco di altre versioni di Outlook, consultare Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=30732.


Valore DisableSMTPMailboxAddressing impostato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-08-11

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore è stato impostato per disattivare gli indirizzi delle cassette postali SMTP (Simple Mail Transfer Protocol):

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\DisableSMTPMailboxAddressing

Il valore 1 per la chiave DisableSMTPMailboxAddressing indica che l'indirizzamento delle cassette postali SMTP è disattivato (true) mentre il valore 0 indica che l'indirizzamento delle cassette postali SMTP non è disattivato (false).

Se Exchange Server Analyzer determina che il valore della chiave DisableSMTPMailboxAddressing è stato impostato per disattivare l'indirizzamento delle cassette postali SMTP con valore 1, verrà visualizzato un avviso.

L'errore indica che l'indirizzamento delle cassette postali SMTP è disattivato. In questo modo si potrebbero verificare degli errori di sincronizzazione per i client di Microsoft Exchange ActiveSync che si collegano a questo server.

Per risolvere l'errore impostare il valore della chiave DisableSMTPMailboxAddressing su 0.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di conoscere le operazioni per ripristinarlo qualora si verifichi un problema. Per informazioni su questa procedura, vedere l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per modificare il valore della chiave DisableSMTPMailboxAddressing

  1. Aprire un editor del Registro di sistema, ad esempio Regedit.exe o Regedt32.exe.

  2. Passare a:

HKeyLocalMachine\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

  1. Nel riquadro destro individuare DisableSMTPMailboxAddressing e fare doppio clic su di esso

  2. Modificare il valore 1 in 0.

  3. Chiudere l'editor del Registro di sistema e riavviare il servizio Server per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'errore di sincronizzazione associato all'avviso, consultare l'articolo 886346 della Microsoft Knowledge Base "Viene visualizzato un messaggio di errore HTTP_500 dopo la sincronizzazione di un dispositivo mobile con Microsoft Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=886346.


Distribuzione del carico utente
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool ha determinato che il server ha un conteggio di operazioni RPC al secondo elevato.

In questo caso è possibile utilizzare Exchange Server User Monitor (ExMon) per identificare la modalità di distribuzione del carico. È importante stabilire se la causa di tale carico sia da ascrivere a una delle seguenti circostanze:

  • Il numero di utenti attivi è relativamente basso.

  • Il carico è distribuito tra molti utenti.

Se viene rilevato che la responsabilità di un'elevata percentuale del carico è di un solo utente, viene visualizzato un avviso per segnalare che l'elevato utilizzo è da ricondurre a un singolo utente. In caso contrario, verrà visualizzato un messaggio in cui viene indicato che il carico è distribuito tra molti utenti.

Nota:
Il traffico RPC cambia nel tempo. Di conseguenza, per acquisire dati rilevanti a fini statistici sul modo in cui gli utenti utilizzano Exchange, può essere necessario raccogliere i dati più volte.

Inoltre, capita spesso che per alcune operazioni comuni degli utenti vengano utilizzate percentuali elevate di CPU per un breve periodo di tempo. Questa attività non deve destare preoccupazione, a meno che non sia un solo utente a consumare spesso e per lunghi periodi di tempo elevate quantità di CPU.

Nota:
È possibile ignorare questo avviso se l'origine del carico elevato è un servizio o un processo noto che prevede un carico elevato ed elabora richieste per molti utenti generando un carico superiore rispetto a utenti singoli. Alcuni servizi che sincronizzano dispositivi mobili, processi del server che gestiscono la disponibilità, servizi correlati a sistemi di caselle vocali o di messaggistica unificata e processi del server che trasferiscono utenti sono esempi di servizi o processi che possono generare un carico superiore rispetto a utenti singoli.
Per risolvere il problema

  • Se la frequenza RPC è elevata (per uno o per tutti gli utenti), verificare se gli utenti dispongono di motori di ricerca desktop, plug-in client di terze parti o dispositivi portatili che consentono di sincronizzare la posta elettronica con le cassette postali degli utenti. Per ulteriori informazioni sulla risoluzione dei problemi di applicazioni di terze parti, consultare Disattivazione di componenti aggiuntivi di terze parti sul client.

  • Gli utenti devono avere meno di 5.000 elementi nelle cartelle predefinite e in quelle molto utilizzate.

  • È consigliabile che la dimensione delle cassette postali non superi 1 GB. È consigliabile che gli utenti responsabili dell'elevato carico archivino gli elementi delle proprie cassette postali in un file con estensione pst. Sarà quindi possibile eseguire nuovamente lo strumento Exchange Performance (Perfmon) per verificare se gli utenti in questione continuino a causare l'elevato carico.

  • Contattare gli utenti individuati per identificare le applicazioni client che potrebbero stare accedendo al programma di posta elettronica client. Rimuovere tali applicazioni e reinstallarle una alla volta per esaminarne l'impatto sul server.

  • Quando si risolvono i problemi relativi al carico di lavoro degli utenti è facile ottenere falsi positivi. È quindi consigliabile eseguire nuovamente ExMon in una fase di elevato carico, per verificare che i risultati dell'analisi siano coerenti.

Per ulteriori informazioni

  • Per scaricare Exchange Server User Monitor (ExMon), consultare l'Area download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54983.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare il documento Risoluzione dei problemi di prestazioni di Microsoft Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni del client di Outlook, consultare l'articolo 905803 della Microsoft Knowledge Base "Peggioramento delle prestazioni di Outlook se gli utenti utilizzano cartelle contenenti molti elementi in un server che esegue Exchange Server 2003 o Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905803.

  • Per ulteriori informazioni sui programmi di ricerca desktop, consultare l'articolo 905184 della Microsoft Knowledge Base "Possibile impatto sulle prestazioni di Exchange 2000 Server e di Exchange Server 2003 dei motori di ricerca desktop in esecuzione sui client Outlook o su altri computer client MAPI" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905184.


La directory virtuale di Exchange per OMA e EAS è stata ignorata
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'indirizzo proxy SMTP di Exchange ActiveSync® è stato ignorato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\ExchangeVDir

Se Exchange Server Analyzer rileva che la voce ExchangeVDir del Registro di sistema è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

La voce ExchangeVDir del Registro di sistema viene utilizzata da Microsoft Outlook® Mobile Access e da Exchange ActiveSync. Tale voce specifica la directory virtuale utilizzata da Outlook Mobile Access e Exchange ActiveSync per accedere ai modelli di Microsoft Office Outlook Web Access di Exchange Server 2003 e a WebDAV (World Wide Web Distributed Authoring and Versioning) nei server back-end Exchange Server 2003 dove si trovano le cassette postali degli utenti.

Se la voce ExchangeVDir non esiste o se non è stato impostato un valore per essa, viene utilizzato il valore predefinito di /Exchange. In caso contrario, la voce conterrà il nome della directory virtuale, incluso il carattere di barra "/". È possibile configurare questo valore quando si desidera specificare una directory virtuale per Outlook Mobile Access o Exchange ActiveSync.

È stato rilevato un problema noto in Exchange Server 2003 quando i servizi mobili di Exchange non funzionano se si utilizza l'autenticazione basata su form (Forms Based Authentication, FBA) in una topologia costituita da un singolo computer Exchange Server 2003. Quando la directory virtuale /Exchange in un server back-end Exchange Server 2003 viene configurata in modo da richiedere SSL (Secure Sockets Layer) o quando viene abilitata l'autenticazione basata su form, Outlook Mobile Access non è in grado di accedere a tale directory virtuale. Il problema non si verifica quando si abilitano queste impostazioni nella directory virtuale /Exchange in un server front-end.

È disponibile la possibilità di eseguire la configurazione per risolvere questo problema che coinvolge la creazione del valore del Registro di sistema ExchangeVDir.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Esaminare ed eventualmente modificare il valore ExchangeVDir.

  4. Chiudere l'editor del Registro di sistema. Se viene apportata una modifica, riavviare il computer sul quale è eseguito Exchange Server per renderla effettiva.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla risoluzione di questo problema, consultare l'articolo 817317 della Microsoft Knowledge Base "Il mapping di più indirizzi proxy a più directory virtuali principali back-end sullo stesso server non è supportato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=817317.


È stato rilevato un prodotto compatibile con l'API antivirus di Exchange, ma attualmente non è abilitato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il software compatibile VSAPI (Virus Scanning Application Programming Interface) è abilitato nel computer che esegue Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per Ese.dll, il Motore di archiviazione del database di Exchange, noto anche come ESE (Extensible Storage Engine).

Infine, Exchange Server Analyzer esegue anche una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Microsoft Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Microsoft Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Microsoft Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore di Version non contiene una sottostringa di 6 nell'ambito delle informazioni sulla versione ma il valore di serialNumber indica che Exchange 2000 Server o Exchange Server 2003 è installato, significa che sul server di Exchange è in esecuzione una versione di ESE non Exchange.

Se Exchange Server Analyzer determina che non è in esecuzione una versione di ESE non Exchange e che il valore della chiave VirusScan \Enabled del Registro di sistema è uguale a 0, verrà visualizzato un avviso. Se invece Exchange Server Analyzer determina che in Exchange Server è in esecuzione una versione di ESE non Exchange, verrà visualizzato un avviso separato.

Si consiglia di distribuire il programma antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) o nei computer su cui è in esecuzione Exchange Server che ospitano cassette postali. Per maggiore protezione, eseguire il software antivirus sul gateway in cui viene effettuata l'analisi dei messaggi MIME in ingresso e avviare una ricerca virus sul computer su cui è in esecuzione Exchange Server in cui viene utilizzato VSAPI 2.0 (Exchange 2000 Server) o VSAPI 2.5 (Exchange Server 2003).

Inoltre, si consiglia di eseguire il programma antivirus sui computer client. Se si esegue il software antivirus progettato per i sistemi di messaggistica (ovvero un programma in grado di eseguire l'analisi e la scansione dei messaggi MIME) sul gateway o sul server di Exchange, sarà sufficiente avviare una ricerca virus a livello di file sui computer client.

Per risolvere il problema

  1. Nell'interfaccia utente del programma software antivirus, abilitare la ricerca virus VSAPI.

  2. Se il problema persiste anche dopo l'abilitazione della ricerca virus VSAPI, rivolgersi al fornitore del software antivirus.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, consultare l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

Per informazioni sulla protezione di un ambiente Exchange Server da virus e worm trasmessi tramite posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.


È stato rilevato un prodotto compatibile con l'API antivirus di Exchange, ma non è installato correttamente
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il software compatibile VSAPI (Virus Scanning Application Programming Interface) è in esecuzione sul computer e dispone di una libreria valida cui viene fatto riferimento:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Se Exchange Server Analyzer rileva che il valore di Library non contiene un percorso valido di un file di libreria (DLL) antivirus VSAPI, verrà visualizzato un avviso.

Si consiglia di distribuire il programma antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) o nei computer su cui è in esecuzione Exchange Server che ospitano cassette postali. Per maggiore protezione, eseguire il software antivirus sul gateway in cui viene effettuata l'analisi dei messaggi MIME in ingresso e avviare una ricerca virus sul computer su cui è in esecuzione Exchange Server in cui viene utilizzato VSAPI 2.0 (Exchange 2000 Server) o VSAPI 2.5 (Exchange Server 2003).

Inoltre, si consiglia di eseguire il programma antivirus sui computer client. Se si esegue il software antivirus progettato per i sistemi di messaggistica (ovvero un programma in grado di eseguire l'analisi e la scansione dei messaggi MIME) sul gateway o sul server di Exchange, sarà sufficiente avviare una ricerca virus a livello di file sui computer client.

Per risolvere il problema

  1. Disinstallare e reinstallare il software antivirus.

  2. Se il problema persiste anche dopo la reinstallazione del software, rivolgersi al fornitore del software antivirus.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

Per ulteriori informazioni sui programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, consultare l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

Per informazioni sulla protezione di un ambiente Exchange Server da virus e worm trasmessi tramite posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.


VS (Virus Scanning) API di Exchange presenta un conteggio thread insufficiente
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore di ScanningThreads:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Il valore del Registro di sistema ScanningThreads rappresenta il numero massimo di thread VSAPI (Virus Scanning API) allocati per la ricerca.

Inoltre, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se è abilitata l'analisi dei messaggi VSAPI:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Il valore 1 per Enabled indica che la ricerca VSAPI è abilitata. Il valore 0 indica che la ricerca VSAPI non è abilitata.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave NumberOfProcessors. Questo valore indica il numero di processori installati nel computer e include sia i processori fisici che quelli logici. L'utilizzo della tecnologia Hyper-Threading di Intel consente di suddividere un processore fisico in due processori logici.

Se Exchange Server Analyzer rileva che il valore di ScanningThreads è minore di (2 × NumberOfProcessors + 1) su un computer Exchange Server in cui è abilitata la ricerca VSAPI, verrà visualizzato un avviso. Il valore ottimale di ScanningThreads è uguale a (2 × NumberOfProcessors) + 1. Ad esempio, in un computer Exchange Server con due processori, il valore ottimale di ScanningThreads è 5.

Nota:
Se la tecnologia Hyper-Threading è abilitata, il valore per NumberOfProcessors sarà il doppio del numero di processori fisici. Si consiglia di verificare con il produttore del software antivirus se nella formula sopra riportata è necessario utilizzare i processori fisici o quelli logici.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

  3. Nel riquadro destro fare doppio clic su ScanningThreads.

  4. Immettere il valore restituito dalla formula indicata sopra.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla tecnologia Hyper-Threading, consultare il sito Web di Intel all'indirizzo http://www.intel.com/technology/hyperthread.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Il server DNS esterno viene utilizzato per SMTP
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchSMTPExternalDNSServers nella classe protocolCfgSMTPServer per ciascun oggetto di Exchange Server. La classe protocolCfgSMTPServer contiene le impostazioni per un server virtuale SMTP. Se l'attributo msExchSMTPExternalDNSServers è impostato, il server virtuale SMTP utilizza un server DNS esterno. Se Exchange Server Analyzer determina che l'attributo msExchSMTPExternalDNSServers è impostato, verrà visualizzato un avviso.

Se si configura il server virtuale SMTP per utilizzare un server DNS esterno, si possono verificare problemi di prestazioni. Pertanto, questa configurazione non è consigliata.

Per modificare le impostazioni del DNS esterno su un server virtuale SMTP

  1. In Gestore di sistema di Exchange espandere Server, <il server in ingresso di Exchange>, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  3. Selezionare la scheda Recapito e fare clic su Avanzate.

  4. Fare clic su Configura per configurare i server DNS esterni.

  5. Per aggiungere un server DNS esterno, fare clic su Aggiungi, digitare l'indirizzo IP del server DNS esterno nella finestra di dialogo Aggiungi e fare clic su OK.

  6. Per rimuovere un server DNS esterno, selezionare un indirizzo IP, quindi fare clic su Rimuovi.

  7. Fare clic su OK.

Per ulteriori informazioni sulla configurazione del DNS nell'organizzazione di Exchange Server 2003, consultare il capitolo "Configurazione del DNS" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla configurazione dei connettori SMTP per il collegamento a domini Internet in Exchange, consultare l'articolo 319426 della Microsoft Knowledge Base "HOW TO: Configurare il connettore SMTP per il collegamento a domini Internet in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?Linkid=3052&kbid=319426.


L'autenticazione di base non viene utilizzata dal server front-end
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'autenticazione di base è configurata tra un server front-end e uno back-end.

HKEY_LOCAL_MACHINE\CurrentControlSet\Services\MSExchangeWeb\DAV\UseBasicAuthToBE

Se Exchange Server Analyzer rileva che è stata impostata la chiave UseBasicAuthToBE, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, i server front-end di Exchange Server 2003 utilizzano l'autenticazione Kerberos per consentire la protezione delle credenziali utente tra i server front-end e back-end. Se l'autenticazione Kerberos non riesce, verrà registrato un evento di avviso e il server front-end tenterà di eseguire l'autenticazione NTLM. Se l'autenticazione NTLM non riesce, verrà registrato un errore. L'autenticazione Kerberos verrà ritentata dopo 30 minuti. Quando i computer front-end che eseguono Exchange 2000 Server o Exchange Server 2003 effettuano l'autenticazione con i computer back-end che eseguono Exchange 2000 Server, verrà utilizzata NTLM.

L'impostazione della chiave UseBasicAuthToBE del Registro di sistema sostituisce questa logica predefinita e forza i server front-end Exchange a utilizzare l'autenticazione di base per tutte le comunicazioni con i server back-end. Se nell'organizzazione di Exchange sono presenti più di 1.000 archivi delle cassette postali, è necessario impostare questa chiave del Registro di sistema. Esiste un problema noto per cui gli utenti che accedono alle cassette postali da Microsoft Office Outlook® Web Access per Exchange Server 2003 tramite server front-end di organizzazioni con più di 1.000 archivi delle cassette postali, non possono accedere alle proprie cassette postali.

Se non si dispone di più di 1.000 archivi di cassette postali e non è necessario forzare l'autenticazione di base, considerare la possibilità di eliminare la chiave UseBasicAuthToBE del Registro di sistema.

L'autenticazione di base invia le credenziali non crittografate. Se si sta eseguendo un server front-end di Exchange con la chiave UseBasicAuthToBE del Registro di sistema impostata, si consiglia di usare una crittografia IPSec.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per eliminare la chiave del Registro di sistema UseBasicAuthToBE

  1. Nel server front-end Exchange, aprire un editor del Registro di sistema, come ad esempio Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Service\MSExchangeWeb\Dav\ UseBasicAuthToBE.

  3. Fare clic con il pulsante destro del mouse su UseBasicAuthToBE, Elimina, quindi su Sì.

  4. Aprire lo snap-in Servizi MMC, fare clic con il pulsante destro del mouse su Servizio Amministrazione IIS quindi scegliere Riavvia.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


PING del server Gateway non riuscito
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PingStatus per determinare il valore della chiave StatusCode restituito da un server Gateway non Exchange. Win32_PingStatus restituisce un oggetto con 24 proprietà che forniscono informazioni dettagliate relative ai pacchetti ping inviati dalla classe.

Se Exchange Server Analyzer rileva che il valore di questa chiave corrisponde a uno dei valori nella seguente tabella, verrà visualizzato un errore.

Viene visualizzato il nome del server Gateway, il nome del server Exchange e il valore StatusCode corrispondente restituito con l'errore.

Valore StatusCode Significato Descrizione

11001

Buffer troppo piccolo

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11002

Rete di destinazione non raggiungibile

La richiesta non è riuscita perché la rete contenente il computer di destinazione non è raggiungibile. Non esiste una route valida verso il computer di destinazione.

Per informazioni, consultare l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11003

Host di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non è raggiungibile.

Per informazioni, vedere Server di Active Directory inattivo o irraggiungibile.

In alternativa, questo errore può essere provocato da una delle seguenti condizioni:

  • Un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione.

  • Un errore DNS.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11004

Protocollo di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non risponde al protocollo del pacchetto.

Questo errore potrebbe essere il risultato di un firewall tra il computer in cui viene eseguito Exchange Server Analyzer e il controller di dominio di destinazione.

11005

Porta di destinazione non raggiungibile

La richiesta non è riuscita perché la porta sul computer di destinazione non è disponibile.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11006

Nessuna risorsa

La richiesta non è riuscita perché le risorse di rete non sono sufficienti.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11007

Opzione non valida

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11008

Errore hardware

La richiesta non è riuscita perché si è verificato un errore hardware.

Assicurarsi che il controller di dominio funzioni correttamente eseguendo lo strumento di controllo di integrità dell'hardware fornito dal produttore del computer.

11009

Dimensioni pacchetto troppo elevate

La richiesta non è riuscita perché la dimensione del pacchetto contenente la richiesta è superiore all'unità massima di trasmissione (MTU) di un nodo router o gateway situato tra l'origine e la destinazione. L'MTU definisce la dimensione massima di un pacchetto per eseguirne la trasmissione.

La dimensione della richiesta inviata da Exchange Server Analyzer non è superiore a 10 KB. Assicurarsi che i router e i gateway dell'organizzazione siano configurati correttamente.

Per informazioni, vedere l'articolo 159211 della Microsoft Knowledge Base "Diagnosi e trattamento dei router black hole" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211.

11010

Timeout della richiesta

La risposta non è stata ricevuta entro l'intervallo di tempo assegnato. L'intervallo di tempo predefinito per le risposte è pari a 5 secondi.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11011

Richiesta non valida

La richiesta non è riuscita perché è stata codificata in modo errato.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11012

Route non valida

La richiesta non è riuscita perché non esiste una route valida tra i computer di origine e di destinazione.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11013

Transito TimeToLive scaduto

La richiesta non è riuscita perché la durata (TTL) ha raggiunto il valore zero. Il nodo di inoltro router o gateway scarta il pacchetto.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11014

Riassemblaggio TimeToLive scaduto

La richiesta non è riuscita perché il pacchetto è stato frammentato per la trasmissione e non sono stati ricevuti tutti i frammenti entro l'intervallo di tempo assegnato al riassemblaggio. Nel documento RFC 2460 (disponibile all'indirizzo http://www.ietf.org/rfc/rfc2460.txt) viene specificato un limite di tempo di 60 secondi per la ricezione di tutti i frammenti del pacchetto.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11015

Problema di parametro

La richiesta non è riuscita perché in un nodo router o gateway si sono verificati dei problemi durante l'elaborazione dell'intestazione del pacchetto. Questo problema può verificarsi se l'intestazione contiene dei dati di campo non validi oppure un'opzione non riconosciuta.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11016

Richiesta di rallentamento dell'origine

La richiesta non è riuscita perché il pacchetto è stato scartato. Ciò si verifica quando la coda di output del computer di origine non dispone di spazio di archiviazione sufficiente. In alternativa, si può verificare quando i pacchetti arrivano a destinazione troppo velocemente per consentirne l'elaborazione.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11017

Opzione troppo ampia

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11018

Destinazione non valida

La richiesta non è riuscita per uno dei seguenti motivi:

  • L'indirizzo IP di destinazione non può ricevere le richieste PING.

  • L'indirizzo IP di destinazione non dovrebbe mai essere visualizzato nel campo dell'indirizzo di destinazione di un datagramma IP.

Ciò potrebbe essere provocato da un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione.

11032

Negoziazione IPSEC in corso

La richiesta non è riuscita perché una connessione IPsec potrebbe non essere stata negoziata.

11050

Errore generale

La richiesta non è riuscita per motivi sconosciuti.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.


Parametro IIS 6.0 MaxFieldLength non impostato correttamente
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la lunghezza massima del campo per le richieste HTTP è stata specificata a livello di codice nel Registro di sistema.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxFieldLength

Exchange Server Analyzer esamina inoltre la seguente voce del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul computer di destinazione.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue un sistema operativo Microsoft Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue un sistema operativo Microsoft Windows Server 2003.

Infine, Exchange Server Analyzer analizza la classe WMI (Strumentazione gestione Windows®) Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Se Exchange Server Analyzer rileva che il valore per MaxFieldLength è impostato su 32768 in un server back-end di Exchange nel quale si verificano le seguenti condizioni, verrà visualizzato un avviso:

  • Il server back-end di Exchange esegue Windows Server 2003.

  • Il server back-end di Exchange non è configurato come server front-end.

  • Il server back-end di Exchange dispone di più di 500 cassette postali.

Il parametro MaxFieldLength IIS del Registro di sistema, non presente per impostazione predefinita, consente di specificare la dimensione massima delle singole richieste client HTTP. Questo valore è normalmente impostato congiuntamente con un valore complementare, MaxRequestBytes. Se, in ambienti più estesi, questi valori non sono impostati su 32768, si possono verificare errori di accesso per gli utenti di Microsoft Office Outlook® Web Access per Exchange Server. Nello specifico, l'assenza di questi valori può provocare errori di tipo HTTP 400 - Richiesta non valida. Quando si configura il valore MaxFieldLength del Registro di sistema è inoltre necessario impostare il parametro MaxRequestBytes su 32768, per consentire agli utenti membri di più di 75 gruppi di accedere a Outlook Web Access. Il valore MaxRequestBytes del Registro di sistema determina il limite superiore per la dimensione totale della riga Request e delle intestazioni. Se il valore è inferiore a MaxFieldLength, il valore di MaxFieldLength viene adeguato.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare i parametri MaxRequestBytes e MaxFieldLength

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Fare clic con il pulsante destro del mouse su Parameters, quindi su Nuovo | valore DWORD e denominare il valore MaxFieldLength.

  4. Fare clic con il pulsante destro del mouse su Parameters, quindi su Nuovo | valore DWORD e denominare il valore MaxRequestBytes.

  5. Nel riquadro destro fare doppio clic su MaxFieldLength e impostarne il valore su 32768 (decimale).

  6. Nel riquadro destro fare doppio clic su MaxRequestBytes e impostarne il valore su 32768 (decimale).

  7. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni HTTP del Registro di sistema per Internet Information Service (IIS), consultare l'articolo 820129 della Microsoft Knowledge Base "INF: Impostazioni Http.sys del Registro di sistema per IIS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129.


Parametro IIS 6.0 MaxRequestBytes non impostato correttamente
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la dimensione massima per le richieste HTTP è stata hardcoded nel Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\MaxRequestBytes

Exchange Server Analyzer esamina inoltre la seguente voce del Registro di sistema per determinare la versione del sistema operativo Microsoft Windows® in esecuzione sul computer di destinazione:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\CurrentVersion

Il valore 4.0 per CurrentVersion indica che il computer esegue Microsoft Windows NT® Server 4.0. Il valore 5.0 indica che il computer esegue un sistema operativo Microsoft Windows 2000 Server, mentre il valore 5.2 indica che il computer esegue un sistema operativo Microsoft Windows Server 2003.

Infine, Exchange Server Analyzer analizza la classe WMI (Strumentazione gestione Windows®) Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Se Exchange Server Analyzer rileva che il valore per MaxRequestBytes non è impostato su 32768 in un server back-end di Exchange nel quale si verificano le seguenti condizioni, verrà visualizzato un avviso:

  • Il server back-end di Exchange esegue Windows Server 2003.

  • Il server back-end di Exchange non è configurato come server front-end.

  • Il server back-end di Exchange dispone di più di 500 cassette postali.

Il valore MaxRequestBytes del Registro di sistema, che non è presente per impostazione predefinita, determina il limite superiore per la dimensione totale della riga Request e delle intestazioni. Questo valore è normalmente impostato congiuntamente con un valore complementare, MaxFieldLength. Il parametro MaxFieldLength IIS del Registro di sistema consente di specificare la dimensione massima delle singole richieste client HTTP. Se, in ambienti più estesi, questi valori non sono impostati su 32768, si possono verificare errori di accesso per gli utenti di Microsoft Office Outlook® Web Access per Exchange Server. Nello specifico, l'assenza di questi valori può provocare errori di tipo HTTP 400 - Richiesta non valida. Quando si configura il valore MaxFieldLength del Registro di sistema è inoltre necessario impostare il parametro MaxRequestBytes su 32768, per consentire agli utenti membri di più di 75 gruppi di accedere a Outlook Web Access. Se il valore è inferiore a MaxFieldLength, il valore di MaxFieldLength viene adeguato.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare i parametri MaxRequestBytes e MaxFieldLength

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\HTTP\Parameters

  3. Fare clic con il pulsante destro del mouse su Parametri, scegliere Nuovo | valore DWORD e denominare il valore MaxFieldLength.

  4. Fare clic con il pulsante destro del mouse su Parametri, scegliere Nuovo | valore DWORD e denominare il valore MaxRequestBytes.

  5. Nel riquadro destro fare doppio clic su MaxFieldLength e impostarne il valore su 32768 (decimale).

  6. Nel riquadro destro fare doppio clic su MaxRequestBytes e impostarne il valore su 32768 (decimale).

  7. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni HTTP del Registro di sistema per Internet Information Service (IIS), consultare l'articolo 820129 della Microsoft Knowledge Base "INF: Impostazioni Http.sys del Registro di sistema per IIS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=820129.


Flag di compatibilità IMAP4 impostato nel Registro di sistema
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se esiste il seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\Compatibility

Se Exchange Server Analyzer rileva che il valore Compatibilità è presente ed è impostato su un valore 0xfffffffe (esadecimale), verrà visualizzato un messaggio di configurazione non predefinita.

I computer client IP (Internet Protocol) Exchange Server che utilizzano i protocolli IMAP 4 (Internet Message Access Protocol 4) e POP3 (Post Office Protocol) versione 3 usano completamente il file dell'archivio di flusso (file con estensione STM) per leggere e scrivere i dati. Quando un client IP richiede un download di messaggi utilizzando POP3 o IMAP4, l'archivio di Exchange che contiene la cassetta postale dell'utente calcola la dimensione esatta dei messaggi nella cartella Posta in arrivo per l'invio al client prima che avvenga la trasmissione dei messaggi. In ambienti di grandi dimensioni, in particolare negli ambienti Exchange supportati, questa operazione può richiedere un intervallo di tempo considerevole. Il valore Compatibility rappresenta una possibilità di configurazione per gli amministratori che possono indicare all'archivio di Exchange di utilizzare una dimensione di messaggio approssimativa invece di eseguire calcoli esatti per le dimensioni dei messaggi.

Il valore Compatibility del Registro di sistema è disponibile per il servizio Exchange IMAP4, come illustrato in questo articolo, e per il servizio Exchange POP3, come illustrato in Flag di compatibilità POP3 impostato nel Registro di sistema.

Il valore Compatibility del Registro di sistema è utile anche durante lo spostamento di un grande numero di cassette postali o di cassette postali contenenti un elevato numero di messaggi MIME. Quando si spostano i dati, questi vengono innalzati di livello dall'archivio di flusso all'archivio MAPI (file con estensione EDB). Per i client che utilizzano i protocolli POP3 e IMAP4 per accedere alle relative cassette postali si possono verificare problemi di prestazioni dopo che si sono spostate le relative cassette postali tra database o server. Dopo l'accesso dell'utente è necessario calcolare le dimensioni dei messaggi e nella memoria e sul disco del server si verifica la conversione da MAPI a MIME. In casi estremi, quando si verifica questo comportamento, possono essere creati file temporanei di grandi dimensioni nel computer Exchange Server.

Non tutti i client di posta POP3 e IMAP4 possono funzionare correttamente con il valore Compatibility del Registro di sistema impostato. Le modifica di queste impostazioni provoca l'interruzione di alcuni client di posta meno recenti, come Fetchmail. L'impostazione di questa chiave del Registro di sistema causa anche l'interruzione della conformità al protocollo RFC del protocollo IMAP4. Nel caso in cui vengano riscontrati problemi di download dei messaggi con i protocolli POP3 e IMAP4 e si sta utilizzando il valore Compatibility del Registro di sistema, è possibile eliminarlo utilizzando la procedura descritta di seguito come soluzione per i problemi di download dei messaggi.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per eliminare il valore del Registro di sistema Compatibilità

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Eliminare il valore denominato Compatibilità.

  4. Per rendere effettive le modifiche, uscire dall'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange e il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'utilizzo del valore Compatibility del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 317722, "XADM: Si verificano latenze dei client durante la conversione della posta elettronica dal formato MAPI al formato MIME in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722.

  • 329067, "XADM: Promozione del contenuto di file con estensione STM tramite la funzionalità di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067.


Il valore IMAP4 MaxBufferSize è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-08-07

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se il seguente valore del registro esiste:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Se Exchange Server Analyzer rileva che il valore MaxBufferSize è presente e configurato con un valore numerico maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore del Registro di sistema MaxBufferSize viene utilizzato in una topologia Exchange front-end/back-end. Definisce la dimensione del buffer TCP/IP tra server front-end e server back-end. La dimensione predefinita del buffer è 1 kilobyte (KB). In reti ad alta latenza, l'adeguamento del valore MaxBufferSize può migliorare le prestazioni dei client IMAP4.

Quando si imposta la dimensione del buffer TCP/IP sul valore del Registro di sistema MaxBufferSize, è sempre preferibile impostare la dimensione del buffer su multipli di 1.024. Si consiglia di provare le prestazioni della configurazione server front-end/back-end con le seguenti dimensioni del buffer:

  • 8.192 byte

  • 16.384 byte

  • 32.768 byte

Si consiglia di non impostare la voce del Registro di sistema MaxBufferSize su un valore maggiore di 32.768. Tuttavia, è possibile notare un miglioramento delle prestazioni con un valore per le dimensioni del buffer pari a 65.536, in base alle condizioni della rete. Una maggiore dimensione del buffer utilizza più memoria nel computer Exchange Server e può ridurre il numero degli utenti in grado di accedere al server front-end. Non esistono limiti al valore massimo che può essere utilizzato per il valore del Registro di sistema MaxBufferSize, tuttavia, se si assegna un valore eccessivamente grande a questa voce del registro, si possono verificare prestazioni instabili e problemi di memoria.

Nota:
Per utilizzare il valore MaxBufferSize del Registro di sistema, è necessario eseguire Exchange 2000 Server Service Pack 2 o versione successiva.

Se il valore del Registro di sistema MaxBufferSize impostato è troppo basso, non si verificherà un miglioramento delle prestazioni e in Exchange Server Analyzer verrà visualizzato un messaggio di errore, come descritto in Il valore IMAP4 MaxBufferSize è troppo basso. Se invece il valore del Registro di sistema MaxBufferSize impostato è troppo alto, potrebbe conseguirne l'instabilità del sistema e in Exchange Server Analyzer verrà visualizzato un messaggio di errore, come descritto in Il valore IMAP4 MaxBufferSize è troppo alto.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il valore MaxBufferSize

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Creare un nuovo valore DWORD denominato MaxBufferSize.

  4. Fare doppio clic sul valore MaxBufferSize e impostarlo sulla nuova dimensione del buffer (in byte). Ad esempio, è possibile digitare 8192 per impostarlo su 8.192 byte.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - IMAP4.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su quando e come utilizzare il valore MaxBufferSize del Registro di sistema, consultare l'articolo 823857 della Microsoft Knowledge Base "XADM: Le prestazioni IMAP4 e POP3 tra server front-end e back-end risultano lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857.


Il valore IMAP4 MaxBufferSize è troppo alto
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-08-07

Microsoft® Exchange Server Analyzer Tool legge il Registro di sistema sul computer Exchange Server per determinare se esiste il seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Se Exchange Server Analyzer rileva che il valore MaxBufferSize è presente e configurato con un valore numerico maggiore di 32.768, verrà visualizzato un avviso.

Il valore del Registro di sistema MaxBufferSize viene utilizzato in una topologia Exchange front-end/back-end. Definisce la dimensione del buffer TCP/IP tra server front-end e server back-end. La dimensione predefinita del buffer è 1 kilobyte (KB). In reti ad alta latenza, l'adeguamento del valore MaxBufferSize può migliorare le prestazioni dei client IMAP4.

Quando si imposta la dimensione del buffer TCP/IP sul valore del Registro di sistema MaxBufferSize, è sempre necessario impostare la dimensione del buffer su multipli di 1.024. Si consiglia di provare le prestazioni della configurazione server front-end/back-end con le seguenti dimensioni del buffer:

  • 8.192 byte

  • 16.384 byte

  • 32.768 byte

Quando si utilizza questa voce del Registro di sistema, è necessario impostarla almeno su 1.024. Si consiglia di non impostare la voce MaxBufferSize del Registro di sistema su un valore maggiore di 32.768. Tuttavia, è possibile osservare un aumento delle prestazioni con una dimensione del buffer impostata su 65.536, a seconda delle condizioni della rete. Una maggiore dimensione del buffer utilizza più memoria nel computer Exchange Server e può ridurre il numero degli utenti in grado di accedere al server front-end. Non esistono limiti al valore massimo che può essere utilizzato per il valore del Registro di sistema MaxBufferSize, tuttavia, se si assegna un valore eccessivamente grande a questa voce del registro, si possono verificare prestazioni instabili e problemi di memoria.

Nota:
Per utilizzare il valore MaxBufferSize del Registro di sistema, è necessario eseguire Exchange 2000 Server Service Pack 2 o versione successiva.

Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo basso, non si verificherà un miglioramento delle prestazioni ed Exchange Server Analyzer visualizzerà un messaggio di errore, come descritto in Il valore IMAP4 MaxBufferSize è troppo basso. Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo alto, si potrà verificare un'instabilità del sistema e verrà visualizzato un messaggio di errore, come descritto in questo articolo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Creare un nuovo valore DWORD denominato MaxBufferSize.

  4. Fare doppio clic sul valore MaxBufferSize e impostarlo sulla nuova dimensione del buffer (in byte). Ad esempio, è possibile immettere 8192 per impostarlo su 8.192 byte.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange IMAP4.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su quando e come utilizzare il valore MaxBufferSize del Registro di sistema, consultare l'articolo 823857 della Microsoft Knowledge Base "XADM: Le prestazioni IMAP4 e POP3 tra server front-end e back-end risultano lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857.


Il valore IMAP4 MaxBufferSize è troppo basso
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-08-07

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se il seguente valore del registro esiste:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IMAP4Svc\Parameters\MaxBufferSize

Se Exchange Server Analyzer rileva il valore MaxBufferSize come presente e configurato con un valore numerico maggiore di 0 ma minore di 1024, verrà visualizzato un messaggio di errore.

Il valore del Registro di sistema MaxBufferSize viene utilizzato in una topologia Exchange front-end/back-end. Definisce la dimensione del buffer TCP/IP tra server front-end e server back-end. La dimensione predefinita del buffer è 1 kilobyte (KB). In reti ad alta latenza, l'adeguamento del valore MaxBufferSize può migliorare le prestazioni dei client IMAP4.

Quando si imposta la dimensione del buffer TCP/IP sul valore del Registro di sistema MaxBufferSize, è sempre preferibile impostare la dimensione del buffer su multipli di 1.024. Si consiglia di provare le prestazioni della configurazione server front-end/back-end con le seguenti dimensioni del buffer per deterimare un valore ottimale:

  • 8.192 byte

  • 16.384 byte

  • 32.768 byte

Quando si utilizza questa voce del Registro di sistema, è necessario impostarla almeno su 1.024. Si consiglia di non impostare la voce MaxBufferSize del Registro di sistema su un valore maggiore di 32.768. Tuttavia, è possibile osservare un aumento delle prestazioni con una dimensione del buffer impostata su 65.536, a seconda delle condizioni della rete. Una maggiore dimensione del buffer utilizza più memoria nel computer Exchange Server e può ridurre il numero degli utenti in grado di accedere al server front-end. Non esistono limiti al valore massimo che può essere utilizzato per il valore del Registro di sistema MaxBufferSize, tuttavia, se si assegna un valore eccessivamente grande a questa voce del registro, si possono verificare prestazioni instabili e problemi di memoria.

Nota:
Per utilizzare il valore MaxBufferSize del Registro di sistema, è necessario eseguire Exchange 2000 Server Service Pack 2 o versione successiva.

Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo basso, non si verificherà un miglioramento delle prestazioni e Exchange Server Analyzer visualizzerà un messaggio di errore, come descritto in questo articolo. Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo alto, si potrà verificare un'instabilità del sistema e verrà visualizzato un messaggio di errore, come descritto in Il valore IMAP4 MaxBufferSize è troppo alto.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\IMAP4Svc\Parameters

  3. Creare un nuovo valore DWORD denominato MaxBufferSize.

  4. Fare doppio clic sul valore MaxBufferSize e impostarlo sulla nuova dimensione del buffer (in byte). Ad esempio, è possibile immettere 8192 per impostarlo su 8.192 byte.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - IMAP4.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su quando e come utilizzare il valore MaxBufferSize del Registro di sistema, consultare l'articolo 823857 della Microsoft Knowledge Base "XADM: Le prestazioni IMAP4 e POP3 tra server front-end e back-end risultano lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857.


Operazioni MAPI non riuscite
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha determinato che sul server sono state riportate molte operazioni MAPI non riuscite. È previsto che di tanto in tanto alcune operazioni MAPI restituiscano errori. Tuttavia, a volte una applicazione client potrebbe non rispondere all'errore in modo corretto. Di conseguenza l'applicazione può ripetere la richiesta RPC che ha causato l'errore, aumentando in tal modo il carico sul server.

Un errore frequente del client si verifica, ad esempio, quando un client MAPI richiede un elenco di elementi in batch e continua a richiederli quando la richiesta è stata restituita da Exchange. Ad esempio, un computer client può richiedere tutti gli elementi presenti in una determinata cartella che contengono un allegato. Il client, inoltre, può richiedere che tutti gli elementi vengano restituiti in batch di 30 elementi ciascuno. In alcuni casi, quando il server di Exchange ha restituito l'ultimo elemento della richiesta, il client continuerà a richiedere un nuovo batch di 30 elementi. In questi casi Exchange restituisce l'errore "Non trovato". Se il computer client continua a richiedere elementi anche dopo la restituzione dell'errore "Non trovato", significa che il computer client non risponde correttamente all'errore. Pertanto Exchange Server User Monitor (ExMon) egnalerà più operazioni MAPI non riuscite. In tal caso, anche se il rapporto tra il numero di errori e il numero di operazioni è elevato, è prevedibile una frequenza elevata di operazioni non riuscite. Le operazioni MAPI per cui sono previste frequenze di errore elevate includono GetPerUserGuid, ImportMsgMove e Logon.

Per risolvere il problema

  1. Utilizzare ExMon per determinare l'utente o il gruppo di utenti che provoca l'elevato numero di errori MAPI.

  2. Determinare l'applicazione sul computer client provoca il problema.

  3. Riparare o rimuovere l'applicazione che provoca il problema.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare il Manuale sulla risoluzione dei problemi di prestazioni di Microsoft Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.


MaxClientRequestBuffer impostato su un valore non predefinito
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se esiste il valore Dimensione cache cassetta postale:

HKEY_LOCAL_MACHINE System\CurrentControlSet\w3svc\Parameters\MaxClientRequestBuffer

Se Exchange Server Analyzer rileva che la chiave MaxClientRequestBuffer è stata impostata, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, questo valore del Registro di sistema non esiste.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sul valore MaxClientRequestBuffer del Registro di sistema, consultare l'articolo della Microsoft Knowledge Base 260694 "Descrizione del valore MaxClientRequestBuffer del Registro di sistema" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260694.


MaxClientRequestBuffer impostato su un valore troppo basso
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare i dati di valore per il valore MaxClientRequestBuffer:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

Se Exchange Server Analyzer rileva che i dati di valore per il valore MaxClientRequestBuffer sono inferiori a 16.384, verrà visualizzato un avviso.

Se il valore per MaxClientRequestBuffer è troppo basso, potrebbe provocare errori per gli utenti di Microsoft Office Outlook® Web Access. Nello specifico, potrebbe provocare la restituzione al browser di HTTP 400 - Bad Request. Per correggerequesto errore, si consiglia di immettere un valore superiore a 16.384 o di rimuovere il valore del Registro di sistema per ripristinare le impostazioni predefinite. Il valore MaxClientRequestBuffers non è presente per impostazione predefinita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per correggere questo errore ayumentando il valore dei dati del valore

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Fare doppio clic sul valore MaxClientRequestBuffer e modificare i dati del valore. Impostare i dati del valore su un numero decimale uguale o superiore a 16.384.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange.
Per correggere questo errore rimuovendo il valore

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\W3SVC\Parameters\MaxClientRequestBuffer

  3. Fare clic con il pulsante destro del mouse sul valore MaxClientRequestBuffer, quindi scegliere Elimina.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore MaxClientRequestBuffer del Registro di sistema, consultare l'articolo 260694 della Microsoft Knowledge Base, "Descrizione del valore MaxClientRequestBuffer del Registro di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260694.


Sono configurati più binding della porta SMTP
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore per l'attributo msExchServerBindings è stato configurato con più binding della porta. Per impostazione predefinita, l'attributo msExchServerBindings è configurato per la porta TCP 25. Se Exchange Server Analyzer rileva che l'attributo msExchServerBindings è stato configurato con più binding della porta, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchServerBindings rappresenta la porta TCP su cui il server SMTP (Simple Mail Transfer Protocol) è configurato per l'ascolto di connessioni in ingresso. È possibile configurare i server virtuali SMTP per l'ascolto su una o più porte TCP. Per impostazione predefinita, tutti i server virtuali SMTP sono configurati per l'ascolto sulla porta TCP 25. La porta di attesa SMTP può essere modificata a condizione che anche l'intera infrastruttura di messaggistica interna venga modificata di conseguenza. In genere, tuttavia, non è possibile utilizzare porte alternative per server virtuali SMTP che accettano messaggi direttamente da Internet, dal momento che nei server SMTP in Internet i messaggi vengono inviati tramite la porta 25.

Notare che Exchange Server Analyzer esamina il valore del server virtuale dei protocolli SMTP di Exchange. Il server virtuale dei protocolli SMTP di Exchange può corrispondere o meno al server SMTP che riceve messaggi direttamente da Internet. Esistono alcuni prodotti antivirus e anti spam progettati per ricevere messaggi SMTP da Internet sulla porta 25 e per reindirizzarli a un server virtuale SMTP di Exchange su un'altra porta.

Per visualizzare o modificare la porta di attesa del server virtuale SMTP

  1. In Gestore di sistema di Exchange espandere Server, un server di Exchange, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP, ad esempio, il server virtuale SMTP predefinito, e scegliere Proprietà.

  3. Selezionare la scheda Generale e fare clic su Avanzate.

  4. Verrà visualizzato un elenco degli indirizzi IP e delle porte.

    • Per modificare la porta esistente, selezionare l'indirizzo IP quindi fare clic su Modifica.

    • Per rimuovere una porta esistente, selezionare l'indirizzo IP quindi fare clic su Rimuovi.

  5. Fare clic su OK per salvare le modifiche, quindi fare clic su OK per uscire dalla finestra di dialogo Avanzate.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


La dimensione della risposta PING è differente
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PingStatus utilizzando valori specifici dell'impostazione BufferSize e li confronta con i valori BufferSize restituiti per determinare se sono gli stessi.

Se il valore BufferSize restituito è differente dal valore inviato, verrà visualizzato un avviso.

L'avviso indica che il pacchetto è stato troncato durante il transito. Ciò potrebbe indicare un errore generale della rete o la presenza di un router black hole nell'ambiente.

In una rete WAN TCP/IP potrebbero verificarsi errori nella comunicazione tra alcune route se le dimensioni dei pacchetti dei segmenti intermedi della rete sono inferiori a quelle degli host con i quali stanno comunicando e se i router non inviano risposte ICMP appropriate per questa condizione. In alternativa, il firewall all'interno del percorso può inserire tali risposte. Un router che provoca questa condizione è talvolta denominato router black hole.

La presenza di un router black hole può provocare vari errori che non si verificano se un programma si connette a un computer in una subnet locale. Il comportamento può sembrare intermittente, ma esaminando in profondità le circostanze si rileva che il comportamento può essere riprodotto, ad esempio, disponendo di un client che legge un file di grandi dimensioni inviato da un host remoto.

Per ulteriori informazioni, seguire le istruzioni indicate nell'articolo 314825 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825.

Per ulteriori informazioni

Per ulteriori informazioni sul rilevamento e le contromisure per possibili router black hole, vedere le seguenti risorse:

  • Articolo 159211 della Microsoft Knowledge Base "Diagnosi e trattamento dei router black hole" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211.

  • "Router black hole PMTU (Path Maximum Transmission Unit)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66963.


Verifica ping non eseguita
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-08-09

Microsoft® Exchange Server Analyzer Tool tenta di eseguire una query nella classe WMI (Strumentazione gestione Windows®) Win32_PingStatus per analizzare l'oggetto in risposta a diverse impostazioni di configurazioni specifiche del flusso di posta.

Win32_PingStatus restituisce in genere un oggetto con 24 proprietà che forniscono informazioni dettagliate sui pacchetti ping inviati dalla classe.

Se Exchange Server Analyzer non riceve l'oggetto previsto in risposta alla query dopo sei tentativi consecutivi, verrà visualizzato un avviso.

L'avviso indica che non è possibile eseguire Win32_PingStatus.

Questo in genere si verifica perché il computer che tenta di utilizzare il comando Win32_PingStatus esegue Microsoft Windows® 2000 Server. Windows 2000 Server non supporta la classe WMI Win32_PingStatus.

Se il computer che tenta di utilizzare il comando Win32_PingStatus non esegue Windows 2000 Server, il problema potrebbe essere causato dalla rete o dalle autorizzazioni.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING dal computer che esegue Exchange Server Analyzer per verificare se il computer Exchange Server è raggiungibile.

  3. Utilizzare il comando PING da un server che si trova nella stessa subnet del server di Exchange di destinazione per verificare se il computer Exchange Server è raggiungibile.

  4. Se è attivo un firewall, verificare se le porte RPC (Remote Procedure Call) sono bloccate.

  5. Controllare le autorizzazioni dell'account per cui è in esecuzione Microsoft Exchange Server Analyzer Tool. L'account deve disporre delle autorizzazioni di amministratore locale su ciascun server di Exchange analizzato.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sui problemi di connettività di Exchange Server Best Practices Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).

Per ulteriori informazioni sulla classe WMI Win32_PingStatus, consultare l'articolo di MSDN® "Win32_PingStatus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=33549 (informazioni in lingua inglese).


La ricerca di virus nel testo normale è stata disabilitata
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore relativo alla ricerca di virus nei messaggi RFT (Rich Text Format):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Se Exchange Server Analyzer rileva che il valore di ScanPlainText è impostato su 0, verrà visualizzato un avviso.

La chiave ScanPlainText del Registro di sistema viene impostata dai fornitori di antivirus di terze parti che utilizzano VSAPI (Exchange Virus Scanning API). Si consiglia di analizzare tutti i tipi di messaggi con il programma antivirus, inclusi i messaggi di testo normale. È necessario attivare la ricerca di virus di tutti i messaggi che passano attraverso un computer Exchange Server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  • Nell'applicazione antivirus che riconosce Exchange attivare la ricerca di virus in tutti i messaggi.

    -oppure-

  • Modificare manualmente la voce nel Registro del sistema con la seguente procedura:

    1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    2. Passare a:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. Fare doppio clic sulla voce ScanPlainText del Registro di sistema e impostare i dati del valore su 1.

    4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange e i servizi del software antivirus che riconosce Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla protezione antivirus, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.


Flag di compatibilità POP3 impostato nel Registro di sistema
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se il seguente valore del registro esiste:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\Compatibility

Se Exchange Server Analyzer rileva che il valore Compatibilità è presente ed è impostato su un valore 0xfffffffe (esadecimale), verrà visualizzato un messaggio di configurazione non predefinita.

I computer client IP (Internet Protocol) Exchange Server che utilizzano i protocolli IMAP 4 (Internet Message Access Protocol 4) e POP3 (Post Office Protocol versione 3) usano completamente il file dell'archivio di flusso (file con estensione STM) per leggere e scrivere i dati. Quando un client IP richiede un download di messaggi utilizzando POP3 o IMAP4, l'archivio di Exchange che contiene la cassetta postale dell'utente calcola la dimensione esatta dei messaggi nella cartella Posta in arrivo per l'invio al client prima che avvenga la trasmissione dei messaggi. In ambienti di grandi dimensioni, in particolar modo gli ambienti Exchange supportati, questa operazione può richiedere un intervallo di tempo considerevole. Il valore Compatibility rappresenta una possibilità di configurazione per gli amministratori che possono indicare all'archivio Exchange di utilizzare una dimensione di messaggio approssimativa invece di eseguire calcoli esatti per le dimensioni dei messaggi.

Il valore Compatibility del Registro di sistema è disponibile per il servizio Exchange POP3, come illustrato in questo articolo, e per il servizio Exchange IMAP4, come illustrato in Flag di compatibilità IMAP4 impostato nel Registro di sistema.

Questo valore del Registro di sistema è utile anche durante lo spostamento di un grande numero di cassette postali o di cassette postali contenenti un elevato numero di messaggi MIME (Multipurpose Internet Mail Extensions). Quando si spostano i dati, questi vengono innalzati di livello dall'archivio di flusso all'archivio MAPI (file con estensione EDB). Per i client che utilizzano i protocolli POP3 e IMAP4 per accedere alle relative cassette postali si possono verificare problemi di prestazioni dopo che si sono spostate le relative cassette postali tra database o server. Dopo l'accesso dell'utente è necessario calcolare le dimensioni dei messaggi e nella memoria e sul disco del server si verifica la conversione da MAPI a MIME. In casi estremi, quando si verifica questo comportamento, possono essere creati file temporanei di grandi dimensioni nel computer Exchange Server.

Non tutti i client di posta POP3 e IMAP4 possono funzionare correttamente con il valore Compatibility del Registro di sistema impostato. Le modifica di queste impostazioni provoca l'interruzione di alcuni client di posta meno recenti (come Fetchmail). L'impostazione di questa chiave del Registro di sistema causa anche l'interruzione della conformità al protocollo RFC del protocollo POP3. Nel caso in cui vengano riscontrati problemi di download dei messaggi con i protocolli POP3 e IMAP4 e si sta utilizzando il valore Compatibility del Registro di sistema, è possibile eliminarlo utilizzando la procedura descritta di seguito come soluzione per i problemi di download dei messaggi.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per eliminare il valore del Registro di sistema Compatibility

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Eliminare il valore denominato Compatibility.

  4. Per rendere effettive le modifiche, uscire dall'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange e il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'utilizzo del valore Compatibility del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 317722, "XADM: Problemi di latenza del client durante la conversione della posta elettronica dal formato MAPI al formato MIME in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=317722.

  • 329067, "XADM: Promozione del contenuto di file con estensione STM tramite la funzionalità di spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329067.


Il valore MaxBufferSize per POP3 è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se esiste il seguente valore del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Se Exchange Server Analyzer rileva che il valore MaxBufferSize è presente e configurato con un valore numerico maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore del Registro di sistema MaxBufferSize viene utilizzato in una topologia Exchange front-end/back-end. Definisce la dimensione del buffer TCP/IP tra server front-end e server back-end. La dimensione predefinita del buffer è 1 kilobyte (KB). In reti ad alta latenza, l'adeguamento del valore MaxBufferSize può migliorare le prestazioni dei client POP3.

Quando si imposta la dimensione del buffer TCP/IP sul valore del Registro di sistema MaxBufferSize, è sempre necessario impostare la dimensione del buffer su multipli di 1.024. Si consiglia di provare le prestazioni della configurazione server front-end/back-end con le seguenti dimensioni del buffer:

  • 8.192 byte

  • 16.384 byte

  • 32.768 byte

Quando si utilizza questa voce del Registro di sistema, è necessario impostarla almeno su 1024. Si consiglia di non impostare la voce del Registro di sistema MaxBufferSize su un valore maggiore di 32768. Tuttavia, è possibile osservare un aumento delle prestazioni con un valore della dimensione del buffer pari a 65536, a seconda delle condizioni della rete. Una maggiore dimensione del buffer utilizza più memoria nel computer Exchange Server e può ridurre il numero degli utenti in grado di accedere al server front-end. Non esistono limiti al valore massimo che può essere utilizzato per il valore del Registro di sistema MaxBufferSize, tuttavia, se si assegna un valore eccessivamente grande a questa voce del registro, si possono verificare prestazioni instabili e problemi di memoria.

Nota:
Per utilizzare il valore del Registro di sistema MaxBufferSize, è necessario eseguire Exchange 2000 Server Service Pack 2 o una versione successiva.

Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo basso, non si verificherà un miglioramento delle prestazioni ed Exchange Server Analyzer visualizzerà un messaggio di errore, come descritto in Il valore POP3 MaxBufferSize è troppo basso. Se il valore MaxBufferSize del Registro di sistema è impostato su un numero troppo alto, si potrà verificare un'instabilità del sistema e verrà visualizzato un messaggio di errore, come descritto in Il valore POP3 MaxBufferSize è troppo alto.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Creare un nuovo valore DWORD denominato MaxBufferSize.

  4. Fare doppio clic sul valore MaxBufferSize e impostarlo sulla nuova dimensione del buffer (in byte). Ad esempio, è possibile immettere 8192 per impostarlo su 8.192 byte.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange POP3.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su quando e come utilizzare il valore MaxBufferSize del Registro di sistema, consultare l'articolo 823857 della Microsoft Knowledge Base "XADM: Le prestazioni IMAP4 e POP3 tra server front-end e back-end risultano lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857.


Il valore POP3 MaxBufferSize è troppo alto
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se il seguente valore del registro esiste:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Se Exchange Server Analyzer rileva che il valore MaxBufferSize è presente e configurato con un valore numerico maggiore di 32.768, verrà visualizzato un avviso.

Il valore del Registro di sistema MaxBufferSize viene utilizzato in una topologia Exchange front-end/back-end. Definisce la dimensione del buffer TCP/IP tra server front-end e server back-end. La dimensione predefinita del buffer è 1 kilobyte (KB). In reti ad alta latenza, l'adeguamento del valore MaxBufferSize può migliorare le prestazioni dei client POP3.

Quando si imposta la dimensione del buffer TCP/IP sul valore del Registro di sistema MaxBufferSize, è sempre necessario impostare la dimensione del buffer su multipli di 1.024. Si consiglia di provare le prestazioni della configurazione server front-end/back-end con le seguenti dimensioni del buffer:

  • 8.192 byte

  • 16.384 byte

  • 32.768 byte

Quando si utilizza questa voce del Registro di sistema, è necessario impostarla almeno su 1.024. Si consiglia di non impostare la voce del Registro di sistema MaxBufferSize su un valore maggiore di 32.768. Tuttavia, è possibile osservare un aumento delle prestazioni con una dimensione del buffer impostata su 65.535, a seconda delle condizioni della rete. Una maggiore dimensione del buffer utilizza più memoria nel computer Exchange Server e può ridurre il numero degli utenti in grado di accedere al server front-end. Non esistono limiti al valore massimo che può essere utilizzato per il valore del Registro di sistema MaxBufferSize, tuttavia, se si assegna un valore eccessivamente grande a questa voce del registro, si possono verificare prestazioni instabili e problemi di memoria.

Nota:
Per utilizzare il valore MaxBufferSize del Registro di sistema, è necessario eseguire Exchange 2000 Server Service Pack 2 o versione successiva.

Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo basso, non si verificherà un miglioramento delle prestazioni e Exchange Server Analyzer visualizzerà un messaggio di errore, come descritto in Il valore POP3 MaxBufferSize è troppo basso. Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo alto, si potrà verificare un'instabilità del sistema e Exchange Server Analyzer visualizzerà un messaggio pertinente, come descritto in questo articolo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Creare un nuovo valore DWORD denominato MaxBufferSize.

  4. Fare doppio clic sul valore MaxBufferSize e impostarlo sulla nuova dimensione del buffer (in byte). Ad esempio, è possibile immettere 8192 per impostarlo su 8.192 byte.

  5. Per rendere effettiva la modifica, uscire dall'editor del Registro di sistema e riavviare il servizio Microsoft Exchange POP3.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su quando e come utilizzare il valore MaxBufferSize del Registro di sistema, consultare l'articolo 823857 della Microsoft Knowledge Base "XADM: Le prestazioni IMAP4 e POP3 tra server front-end e back-end risultano lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857.


Il valore POP3 MaxBufferSize è troppo basso
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se il seguente valore del registro esiste:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\POP3Svc\Parameters\MaxBufferSize

Se Exchange Server Analyzer rileva il valore MaxBufferSize come presente e configurato con un valore numerico maggiore di 0 ma minore di 1024, verrà visualizzato un messaggio di errore.

Il valore del Registro di sistema MaxBufferSize viene utilizzato in una topologia Exchange front-end/back-end. Definisce la dimensione del buffer TCP/IP tra server front-end e server back-end. La dimensione predefinita del buffer è 1 kilobyte (KB). In reti ad alta latenza, l'adeguamento del valore MaxBufferSize può migliorare le prestazioni dei client POP3.

Quando si imposta la dimensione del buffer TCP/IP sul valore del Registro di sistema MaxBufferSize, è sempre preferibile impostare la dimensione del buffer su multipli di 1.024. Si consiglia di provare le prestazioni della configurazione server front-end/back-end con le seguenti dimensioni del buffer per deterimare un valore ottimale:

  • 8.192 byte

  • 16.384 byte

  • 32.768 byte

Quando si utilizza questa voce del Registro di sistema, è necessario impostarla almeno su 1.024. Si consiglia di non impostare la voce MaxBufferSize del Registro di sistema su un valore maggiore di 32.768. Tuttavia, è possibile osservare un aumento delle prestazioni con una dimensione del buffer impostata su 65.535, a seconda delle condizioni della rete. Una maggiore dimensione del buffer utilizza più memoria nel computer Exchange Server e può ridurre il numero degli utenti in grado di accedere al server front-end. Non esistono limiti al valore massimo che può essere utilizzato per il valore del Registro di sistema MaxBufferSize, tuttavia, se si assegna un valore eccessivamente grande a questa voce del registro, si possono verificare prestazioni instabili e problemi di memoria.

Nota:
Per utilizzare il valore MaxBufferSize del Registro di sistema, è necessario eseguire Exchange 2000 Server Service Pack 2 o versione successiva.

Se il valore del Registro di sistema MaxBufferSize è impostato su un numero troppo basso, non si verificherà un miglioramento delle prestazioni e Exchange Server Analyzer visualizzerà un messaggio di errore, come descritto in questo articolo. Se il valore MaxBufferSize del Registro di sistema è impostato su un numero troppo alto, si potrà verificare un'instabilità del sistema e verrà visualizzato un messaggio di errore, come descritto in Il valore POP3 MaxBufferSize è troppo alto.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\POP3Svc\Parameters

  3. Creare un nuovo valore DWORD denominato MaxBufferSize.

  4. Fare doppio clic sul valore MaxBufferSize e impostarlo sulla nuova dimensione del buffer (in byte). Ad esempio, è possibile immettere 8192 per impostarlo su 8.192 byte.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio POP3 di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su quando e come utilizzare il valore MaxBufferSize del Registro di sistema, consultare l'articolo 823857 della Microsoft Knowledge Base "XADM: Le prestazioni IMAP4 e POP3 tra server front-end e back-end risultano lente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823857.


La porta non ha risposto
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-16

Microsoft® Exchange Server Analyzer Tool esegue una query nel server definito dall'utente e tenta di stabilire una connessione socket al server specificato nella configurazione predefinita della porta TCP 25 o di una porta definita dall'utente. Se Exchange Server Analyzer non riceve come previsto la risposta personalizzata xx Available, dove xx è la porta predefinita 25 o il numero di porta alternativo definito dall'utente, verrà visualizzato un errore.

Questo errore indica che non è possibile accedere al server mediante la porta TCP desiderata e che potrebbero verificarsi errori. Per correggere questo errore, è possibile risolvere il problema di connettività con il server.

Per risolvere il problema di connettività con il server

  1. Verificare se è possibile eseguire una connessione telnet alla porta desiderata dal server designato. Se non è possibile, non si tratta di un problema di rete.

  2. Assicurarsi che siano stati eseguiti i collegamenti necessari e che l'hardware funzioni correttamente.

  3. Verificare che il DNS funzioni e sia configurato correttamente.

  4. Verificare che il router funzioni correttamente.

  5. Verificare la presenza di eventuali firewall che impediscono la connessione.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla connettività del server, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).


Potenziali router black hole
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PingStatus utilizzando valori di impostazione specifici BufferSize e NoFragmentation diversi per determinare se dei router black hole possono essere presenti nell'ambiente WAN.

Impostazione BufferSize | Impostazione NoFragmentation
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Se si verificano le seguenti condizioni, verrà visualizzato un messaggio di errore:

  • PING con valori BufferSize e NoFragmentation inferiori = True, l'operazione è corretta

  • PING con valori BufferSize e NoFragmentation superiori = True, si verifica il timeout

  • PING con valori BufferSize e NoFragmentation superiori = False, l'operazione è corretta, ma la dimensione BufferSize della risposta differisce dalla dimensione BufferSize inviata.

Questo messaggio di errore indica la possibile presenza di uno o più router black hole nella rete WAN.

In una rete WAN TCP/IP potrebbero verificarsi errori in alcune route se si verificano le seguenti condizioni:

  • I segmenti di rete intermedi hanno dimensioni dei pacchetti inferiori a quelle degli host di comunicazione

  • I router non inviano risposte ICMP appropriate a questa condizione.

In alternativa, il firewall all'interno del percorso può inserire tali risposte. Un router che provoca questa condizione è talvolta denominato router black hole.

La presenza di un router black hole può provocare vari errori che non si verificano se un programma si connette a un computer in una subnet locale. Il comportamento può sembrare intermittente, ma può essere riprodotto, ad esempio, mediante un client in grado di leggere un file di grandi dimensioni inviato da un host remoto.

Per ulteriori informazioni, seguire le istruzioni indicate nell'articolo 314825 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825.

Per ulteriori informazioni

Per ulteriori informazioni sul rilevamento e le contromisure per possibili router black hole, vedere le seguenti risorse:

  • Articolo 159211 della Microsoft Knowledge Base "Diagnosi e trattamento dei router black hole" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211.

  • "Router black hole PMTU (Path Maximum Transmission Unit)" nella colonna The Cable Guy - luglio 2004 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66963.


PING dell'host remoto non riuscito
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-03

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PingStatus utilizzando varie impostazioni BufferSize e NoFragmentation per determinare la dimensione dell'unità massima di trasmissione (MTU, Maximum Transmission Unit) per la rete e individuare possibili router black hole. Exchange Server Analyzer determina questi elementi esaminando il valore della chiave StatusCode restituito da un host remoto per ciascuna combinazione di impostazioni.

Impostazione BufferSize | Impostazione NoFragmentation
548 | True
1472 | True
1472 | False
4096 | True
4096 | False

Win32_PingStatus restituisce un oggetto con 24 proprietà che forniscono informazioni dettagliate relative ai pacchetti ping inviati dalla classe.

Se Exchange Server Analyzer Tool rileva che il valore di questa chiave corrisponde a uno dei valori nella seguente tabella, verrà visualizzato un errore.

Viene visualizzato il nome dell'host remoto, il nome del server Exchange e il valore StatusCode corrispondente restituito con l'errore.

Valore StatusCode Significato Descrizione

11001

Buffer troppo piccolo

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11002

Rete di destinazione non raggiungibile

La richiesta non è riuscita perché la rete contenente il computer di destinazione non è raggiungibile. Non esiste una route valida verso il computer di destinazione.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11003

Host di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non è raggiungibile.

Per ulteriori informazioni, vedere Server di Active Directory inattivo o irraggiungibile.

In alternativa, questo errore può essere provocato da una delle seguenti condizioni:

  • Un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione.

  • Un errore DNS.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11004

Protocollo di destinazione non raggiungibile

La richiesta non è riuscita perché il computer di destinazione non risponde al protocollo del pacchetto.

Questo errore potrebbe essere causato dalla presenza di un firewall tra il computer in cui viene eseguito Exchange Server Analyzer e il controller di dominio di destinazione.

11005

Porta di destinazione non raggiungibile

La richiesta non è riuscita perché la porta sul computer di destinazione non è disponibile.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11006

Nessuna risorsa

La richiesta non è riuscita perché le risorse di rete non sono sufficienti.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11007

Opzione non valida

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11008

Errore hardware

La richiesta non è riuscita perché si è verificato un errore hardware.

Assicurarsi che il controller di dominio funzioni correttamente eseguendo lo strumento di controllo di integrità dell'hardware fornito dal produttore del computer.

11009

Dimensioni pacchetto troppo elevate

La richiesta non è riuscita perché la dimensione del pacchetto contenente la richiesta è superiore all'unità massima di trasmissione (MTU) di un nodo router o gateway situato tra l'origine e la destinazione. L'MTU definisce la dimensione massima di un pacchetto per eseguirne la trasmissione.

La dimensione della richiesta inviata da Exchange Server Analyzer non è superiore a 10 KB. Assicurarsi che i router e i gateway dell'organizzazione siano configurati correttamente.

Per ulteriori informazioni, vedere l'articolo 159211 della Microsoft Knowledge Base "Diagnosi e trattamento dei router black hole" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159211.

11010

Timeout della richiesta

La risposta non è stata ricevuta entro l'intervallo di tempo assegnato. L'intervallo di tempo predefinito per le risposte è pari a 5 secondi.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11011

Richiesta non valida

La richiesta non è riuscita perché è stata codificata in modo errato.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11012

Route non valida

La richiesta non è riuscita perché non esiste una route valida tra i computer di origine e di destinazione.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11013

Transito TimeToLive scaduto

La richiesta non è riuscita perché la durata (TTL) ha raggiunto il valore zero. Il nodo di inoltro router o gateway scarta il pacchetto.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11014

Riassemblaggio TimeToLive scaduto

La richiesta non è riuscita perché il pacchetto è stato frammentato per la trasmissione e non sono stati ricevuti tutti i frammenti entro l'intervallo di tempo assegnato al riassemblaggio. Nel documento RFC 2460 (disponibile all'indirizzo http://www.ietf.org/rfc/rfc2460.txt) viene specificato un limite di tempo di 60 secondi per la ricezione di tutti i frammenti del pacchetto.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

11015

Problema di parametro

La richiesta non è riuscita perché in un nodo router o gateway si sono verificati dei problemi durante l'elaborazione dell'intestazione del pacchetto. Questo problema si verifica se l'intestazione contiene dei dati di campo non validi oppure un'opzione non riconosciuta.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11016

Richiesta di rallentamento dell'origine

La richiesta non è riuscita perché il pacchetto è stato scartato. Ciò si verifica quando la coda di output del computer di origine non dispone di spazio di archiviazione sufficiente. In alternativa, si può verificare quando i pacchetti arrivano a destinazione troppo velocemente per consentirne l'elaborazione.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11017

Opzione troppo ampia

La richiesta non è riuscita perché contiene un'opzione non valida.

È improbabile che venga restituito questo errore, poiché Exchange Server Analyzer genera una richiesta standard.

11018

Destinazione non valida

La richiesta non è riuscita per uno dei seguenti motivi:

  • L'indirizzo IP di destinazione non può ricevere le richieste PING.

  • L'indirizzo IP di destinazione non dovrebbe mai essere visualizzato nel campo dell'indirizzo di destinazione di un datagramma IP.

Ciò potrebbe essere provocato dalla presenza di un firewall tra il computer sul quale è in esecuzione Exchange Server Analyzer e il controller di dominio di destinazione.

11032

Negoziazione IPSEC in corso

La richiesta non è riuscita perché una connessione IPsec potrebbe non essere stata negoziata.

11050

Errore generale

La richiesta non è riuscita per motivi sconosciuti.

Per informazioni, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni su queste verifiche, vedere l'articolo 314825 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=314825.


Il motore di routing è stato arrestato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il servizio Microsoft Exchange - Motore di routing (RESvc, Routing Engine Service) e il servizio SMTPSVC (Simple Mail Transfer Protocol Service) sono in esecuzione. Se Exchange Server Analyzer rileva che le seguenti condizioni sono soddisfatte, verrà visualizzato un messaggio di errore:

  • Il servizio SMTPSVC è in esecuzione.

  • Il servizio RESvc non è in esecuzione.

Se il servizio RESvc non è in esecuzione su tutti i server di Exchange che inoltrano messaggi, potrebbero verificarsi problemi di routing. La configurazione di Exchange Server che consente di inoltrare messaggi senza eseguire il servizio RESvc non è supportata.

Analogamente a Exchange 2000 Server, in Exchange Server 2003 viene utilizzato un algoritmo e un protocollo di routing per propagare le informazioni sullo stato del collegamento sotto forma di una tabella di stato dei collegamenti. La tabella di stato dei collegamenti viene archiviata nella memoria di tutti i server di Exchange 2000 Server e Exchange Server 2003 all'interno dell'organizzazione.

Un algoritmo dello stato dei collegamenti offre i seguenti vantaggi:

  • Ogni server di Exchange è in grado di selezionare la route dei messaggi ottimale all'origine, invece di inviarli mediante una route in cui un collegamento non è disponibile.

  • In questo modo, si evita che i messaggi vengano trasmessi più volte da un server all'altro, poiché ogni server di Exchange dispone delle informazioni correnti sulla disponibilità di route alternative o ridondanti.

  • Il loop di messaggi non si verifica più. Nelle versioni precedenti di Exchange Server il loop di messaggi rappresentava talvolta un problema.

Exchange Server consente di raccogliere dalla tabella di stato dei collegamenti le informazioni seguenti:

  • Nella tabella di stato dei collegamenti è riportata la topologia di routing dell'intera organizzazione di Exchange.

  • Nella tabella di stato dei collegamenti è riportata la disponibilità di ciascun connettore nella topologia. Una topologia disponibile è "attiva". Una topologia non disponibile è "inattiva".

  • Nella tabella di stato dei collegamenti sono riportati i costi e gli spazi indirizzo associati a ciascun connettore disponibile.

In Exchange Server queste informazioni vengono utilizzate per determinare la route con il costo più basso in base all'indirizzo di destinazione. Se un connettore nella route con il costo più basso non è disponibile, Exchange Server è in grado di determinare la route alternativa ottimale in base ai costi e alla disponibilità del connettore. Per il routing in base allo stato dei collegamenti, è necessario il servizio RESvc.

Per correggere questo errore, è necessario che il servizio REScv sia configurato per l'esecuzione automatica. Inoltre, è necessario assicurarsi che il servizio REScv venga eseguito durante l'orario di produzione.

Per risolvere il problema

  1. Dal menu Start scegliere Programmi, quindi Strumenti di amministrazione e fare clic su Servizi.

  2. Nell'elenco dei servizi fare clic con il pulsante destro del mouse su Microsoft Exchange - Motore di routing, quindi scegliere Proprietà.

  3. Dal menu Tipo di avvio della scheda Generale scegliere Automatico, quindi fare clic su OK.

  4. Fare clic con il pulsante destro del mouse su Microsoft Exchange - Motore di routing e scegliere Avvia.

Per ulteriori informazioni sull'instradamento dei messaggi in Exchange Server 2003, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


RPC Performance Counters Indicate Poor Server Performance
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-08-24

Microsoft® Exchange Server Analyzer Tool ha rilevato prestazioni non ottimali del server. Exchange Server Analyzer valuta diversi contatori di prestazioni RPC (Remote Procedure Call). Se i dati riportati dai contatori di prestazioni RPC non soddisfano i livelli della tabella riportata di seguito, verrà visualizzato un avviso.

Numero di utenti sul server di Exchange | Soglia della latenza media RPC
Inferiore a 500 | Media superiore a 15
Superiore o uguale a 500 ma inferiore a 3000 | Media superiore a 30
Superiore a 3000 | Media superiore a 50

In questo articolo vengono descritti i seguenti contatori di prestazioni gestiti dall'oggetto prestazioni MSExchangeIS:

  • Latenza media RPC

  • Richieste RPC

Latenza media RPC

Il contatore di prestazioni Latenza media RPC registra il tempo medio in millisecondi (ms) necessario per elaborare gli ultimi 1024 pacchetti. La latenza rappresenta l'intervallo di tempo dal momento in cui il pacchetto viene ricevuto dal processo Store.exe e il momento in cui il pacchetto viene restituito. Il contatore di prestazioni Latenza media RPC non include alcuna latenza di rete o latenze introdotte da processi diversi da Store.exe. Il valore del contatore di prestazioni Latenza media RPC, sebbene non includa il tempo di transito in rete, fornisce il tempo di risposta più breve del server ai computer client. Se il valore del contatore di prestazioni Latenza media RPC è inferiore a 50 ms, il server può elaborare le richieste entro un intervallo di tempo ragionevole. Se invece il valore rimane superiore a 50 ms per diversi secondi, il server ha difficoltà a gestire il carico di richieste. Di conseguenza potrebbero verificarsi ritardi durante l'accesso alla posta elettronica. Se la latenza media è superiore a 100 ms, nei computer client che eseguono Microsoft Office Outlook® verrà visualizzata una finestra popup con il seguente messaggio: "Recupero dati in corso dal server di Microsoft Exchange ".

Interpretazione del contatore di prestazioni della latenza media RPC

Il valore del contatore Latenza media RPC può risultare fuorviante nelle due situazioni seguenti:

  • Innanzitutto, nel caso di operazioni MAPI che solitamente richiedono diverso tempo, ad esempio l'esecuzione di una ricerca in una cartella contenente migliaia di elementi per individuare tutti gli elementi che soddisfano criteri complessi. Se il server viene utilizzato da pochi utenti, questa operazione potrebbe provocare una punta del contatore di prestazioni Latenza media RPC. Se il carico RPC sul server è basso, si consiglia di non basarsi su una osservazione di breve durata (e di conseguenza più volatile), ma di controllare la media di questo valore durante un intervallo più lungo (almeno diversi minuti).

  • La seconda situazione si verifica quando il carico RPC sul server è molto basso. Talvolta la latenza può cambiare radicalmente, a seconda dell'attività dell'utente che esegue il maggior numero di operazioni. In questi casi, il carico del server è particolarmente elevato e il risultato di operazioni pesanti da parte di un singolo utente potrebbe modificare accidentalmente i dati della Latenza media RPC.

Richieste RPC

Il contatore di prestazioni Richieste RPC registra il numero di richieste dei computer client attualmente elaborate da Exchange. Il contatore ha un valore massimo di 100. Dopo aver eseguito 100 operazioni RPC, l'archivio di Exchange rifiuta regolarmente nuove connessioni. In un server che funziona correttamente, il numero di richieste in attesa dovrebbe essere inferiore a 50. Se tale numero risulta superiore a 50 per un intervallo di tempo prolungato, significa che le chiamate di procedura remota vengono sottoposte a backup, sono in attesa di elaborazione e probabilmente si stanno verificando ritardi nei computer client.

Interpretazione delle richieste RPC

La soglia di 50 richieste non è un limite fisso. Infatti, un server con carico ridotto può iniziare a presentare problemi di prestazioni prima che il contatore raggiunga il valore 30, mentre un server con carico elevato potrebbe funzionare correttamente anche con 50 richieste. Pertanto, in teoria sarebbe necessario stabilire un valore di base di questo contatore per ciascun server. Exchange Server Performance Troubleshooting Analyzer utilizza la soglia di 50 considerata la più adeguata per la maggior parte dei server di grandi dimensioni.

Rispetto a un server con carico elevato, un server con carico ridotto presenta un valore minore per le richieste RPC. Questo perché un server con un carico leggero richiede un minor numero di thread per gestire tutte le richieste. Per completare tutte le richieste e ottenere un valore di richieste RPC maggiore, un server con carico più elevato deve eseguire più operazioni contemporaneamente. Pertanto, su un server con carico elevato un valore RPC maggiore non determina, di per sé, un problema di prestazioni. Per determinare la "lentezza" del server, infatti, è necessario considerare anche il contatore di prestazioni Latenza media RPC.

Cause di latenza

Un aumento della latenza potrebbe essere causato da:

  • Un aumento del carico RPC

  • Un collo di bottiglia in una o più risorse server

Inoltre, un collo di bottiglia potrebbe essere causato da:

  • Elevato carico RPC (o qualunque altro tipo di carico sul server)

  • Funzionamento errato dell'hardware o configurazione errata

Per risolvere il problema

  • Seguire le raccomandazioni e le procedure consigliate fornite nei seguenti manuali di Exchange Server 2003:

    • Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576

    • Troubleshooting Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese)


Intervallo della porta RPC impostato su un server non cluster
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinarne i dati del valore delle porte:

HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Se Exchange Server Analyzer rileva che le condizioni indicate di seguito sono vere, verrà visualizzato un messaggio di errore:

  • La chiave HKLM\Software\Microsoft\Rpc\Internet\Ports è presente.

  • Il server non è un server cluster di Exchange.

  • Nel server si verificano altri errori.

Quando è presente la chiave del Registro di sistema, Exchange Server è limitato a un intervallo specifico di porte per chiamate RPC. Se il server di Exchange è sovraccarico e necessita di più porte rispetto a quelle correntemente disponibili, potrebbero verificarsi degli errori.

Per risolvere il problema, è necessario aggiungere altre 100 porte alla chiave HKLM\Software\Microsoft\Rpc\Internet\Ports.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire l'editor del Registro di sistema Regedt32.exe.

    Nota:
    Per modificare il valore REG_MULTI_SZ, è necessario utilizzare Regedt32.exe invece di Regedit.exe.

  2. Passare a: HKLM\Software\Microsoft\Rpc\Internet.

  3. Nel riquadro destro fare doppio clic sulla chiave Ports. Nella casella del valore aumentare l'intervallo di porte.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle chiavi HKLM\Software\Microsoft\Rpc\Internet del Registro di sistema, consultare l'articolo 154596 della Microsoft Knowledge Base "Configurazione dell'assegnazione dinamica di porte RPC per l'utilizzo di firewall" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596.


Intervallo di porte RPC impostato su un server cluster
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinarne il valore delle porte: HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet\Ports

Se Exchange Server Analyzer rileva che le condizioni indicate di seguito sono vere, verrà visualizzato un messaggio di errore:

  • La chiave HKLM\Software\Microsoft\Rpc\Internet\Ports è presente.

  • Il server è un server cluster di Exchange.

  • Nel server si verificano altri errori.

Quando è presente la chiave del Registro di sistema, Exchange Server è limitato a un intervallo specifico di porte per chiamate RPC. Se il server di Exchange è sovraccarico e necessita di più porte rispetto a quelle correntemente disponibili, potrebbero verificarsi degli errori.

Per risolvere il problema, è necessario aggiungere altre 100 porte alla chiave HKLM\Software\Microsoft\Rpc\Internet\Ports.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire l'editor del Registro di sistema Regedt32.exe.

    Nota:
    Per modificare il valore REG_MULTI_SZ, è necessario utilizzare Regedt32.exe invece di Regedit.exe.

  2. Passare a: HKLM\Software\Microsoft\Rpc\Internet.

  3. Nel riquadro destro fare doppio clic sulla chiave Ports. Nella casella del valore aumentare l'intervallo di porte.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle chiavi del Registro di sistema HKLM\Software\Microsoft\Rpc\Internet, consultare l'articolo 154596 della Microsoft Knowledge Base "Configurazione dell'allocazione delle porte dinamiche RPC perché funzionino con i firewall" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=154596.


Attività utente RPC dai contatori di prestazioni
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-02-14

Microsoft® Exchange Server Analyzer Tool ha determinato che sul server si sta verificando un carico elevato di chiamate di procedura remota (RPC).

La frequenza di operazioni RPC al secondo è un'indicazione del carico RPC presente sul server. Talvolta un aumento inatteso del carico di operazioni RPC provoca una riduzione delle prestazioni del server. Se si è verificato un problema di prestazioni sul server, è innanzitutto necessario rilevare se il carico sul server è più elevato del previsto. Sono disponibili diversi contatori di prestazioni che forniscono informazioni relative all'attività RPC sul server. I seguenti contatori di prestazioni trattati nel presente articolo sono tutti contenuti negli oggetti prestazioni di MSExchangeIS, MSExchangeIS Public o MSExchangeIS Cassetta postale:

  • Operazioni RPC al secondo

  • Numero di utenti attivi

  • Accessi client attivi (MSExchangeIS Public)

  • Accessi client attivi (MSExchangeIS Cassetta postale)

Individuazione del carico RPC del client

È possibile utilizzare due contatori per identificare la frequenza corrente di attività sui computer client.

  • Operazioni RPC al secondo Questo contatore fornisce il numero di operazioni RPC al secondo che i computer client richiedono correntemente dal server. Per contare gli utenti è possibile procedere nei seguenti modi:

    • È possibile contare tutte le cassette postali presenti sul server.

    • È possibile contare il numero complessivo di accessi sommando gli Accessi client attivi per MSExchangeIS Public e gli Accessi client attivi per MSExchangeIS Cassetta postale.

    • È possibile contare il numero totale di accessi dal contatore Numero di utenti attivi.

    Exchange Server Analyzer utilizza l'ultimo metodo descritto. Per calcolare la frequenza per utente attivo, dividere la media delle Operazioni RPC al secondo per il Numero di utenti attivi.

  • Operazioni RPC al secondo per utente Questo contatore fornisce un'indicazione del livello di attività degli utenti sul server. In genere gli impiegati di concetto che utilizzano Microsoft Office Outlook® hanno una frequenza di circa 0,1 operazioni al secondo per utente su un server cassette postali. Se gli utenti sul server eseguono applicazioni aggiuntive, il valore può aumentare.

Se Exchange Server Analyzer determina che le operazioni RPC al secondo per utente sono superiori a 0,15 ma inferiori a 0,25, , il livello di attività degli utenti è considerato moderato e in Exchange Server Analyzer verrà visualizzato un avviso.

Se Exchange Server Analyzer determina che le operazioni RPC al secondo per utente sono superiori a 0,25, il livello di attività degli utenti è considerato insolitamente alto e in Exchange Server Analyzer verrà visualizzato un messaggio di errore.

Azioni da eseguire se il carico RPC è elevato

Se le operazioni al secondo sono superiori al previsto, in primo luogo è necessario individuare la causa del carico elevato e quindi ridurlo. È possibile utilizzare Exchange Server User Monitor (ExMon) per capire se il numero di operazioni RPC per un determinato utente è particolarmente elevato.

Se non è possibile ridurre il carico sul server, è necessario riconoscere i colli di bottiglia delle prestazioni e aumentare la capacità del server.

Individuazione di un alto numero di accessi

È necessario che il server archivi in memoria alcune informazioni sugli accessi (nella memoria utente e del kernel). La quantità di memoria riservata è limitata. Se viene utilizzata, sul server può verificarsi un collo di bottiglia della memoria. Per tale ragione, se si verifica un problema relativo alle prestazioni su un server di Exchange, è necessario assicurarsi che il numero totale di accessi per utente non sia eccessivo.

Un impiegato di concetto in genere esegue l'accesso due o tre volte. Se gli utenti eseguono altre applicazioni, il numero di accessi aumenta. Exchange Server Analyzer consente di calcolare il numero di accessi per utente dividendo il numero totale di accessi al server per il numero di cassette postali sul server. È possibile determinare il numero totale di accessi al server mediante la somma dei valori dei contatori di prestazioni Accessi client attivi sugli oggetti prestazioni MSExchangeIS Cassetta postale e MSExchangeIS Public. Per server cassetta postale o cassetta postale mista e server cartelle pubbliche, Exchange Server Analyzer esamina solo questo rapporto.

Nota:
Se molti utenti visualizzano le cartelle condivise di altri utenti (quali calendari condivisi), il numero di accessi sarà più elevato.

Se il numero medio di accessi per utente è superiore a cinque e sul server si verifica un collo di bottiglia della memoria, ciò potrebbe indicare che gli utenti eseguono applicazioni che creano un numero elevato di accessi. Se gli utenti eseguono applicazioni non necessarie per l'attività lavorativa, richiedere che le applicazioni che provocano un numero di accessi troppo elevato al server di Exchange non vengano utilizzate.

Se non è possibile ridurre il numero di applicazioni eseguite dagli utenti, è necessario ridurre il numero di utenti per server spostando gli utenti su un altro server. Per stabilire se gli accessi sono provocati da molti utenti o se un singolo utente ha eseguito un numero eccessivo di accessi, è possibile utilizzare il Gestore di sistema di Exchange per visualizzare gli accessi attivi di ogni utente.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare il Manuale sulla risoluzione dei problemi di prestazioni di Microsoft Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.


La ricerca di virus nei file RTF è stata disabilitata
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore relativo alla ricerca di virus nei messaggi RFT (Rich Text Format):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

Se Exchange Server Analyzer rileva che il valore di ScanRTF è impostato su 0, verrà visualizzato un avviso.

La chiave ScanRTF del Registro di sistema viene impostata dai fornitori di antivirus di terze parti che utilizzano VSAPI (Exchange Virus Scanning API). I messaggi RTF consentono l'utilizzo di colori, tipi di carattere e formattazione ma questo formato può essere letto solo in Microsoft Office Outlook® 2003. Exchange Server legge i file in formato RTF in modo diverso rispetto a un elaboratore di testi quale Microsoft Word.

Si consiglia di analizzare tutti i tipi di messaggi con il programma antivirus, inclusi i messaggi RTF. È necessario attivare la ricerca di virus di tutti i messaggi che passano attraverso un computer Exchange Server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Nell'applicazione antivirus che riconosce Exchange attivare la ricerca di virus in tutti i messaggi.

    oppure

  2. Modificare manualmente la voce nel Registro del sistema con la seguente procedura:

    • Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    • Passare a:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan

    • Fare doppio clic sulla voce del Registro di sistema ScanRTF e impostare i dati del valore su 1.

    • Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange e i servizi del software antivirus che riconosce Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla protezione antivirus, consultare "Rallentamento e blocco dei virus trasmessi per posta elettronica in ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=30732.


Il banner SMTP è stato personalizzato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool tenta di inviare un messaggio all'account Postmaster o a un account definito dall'utente per il dominio SMTP (Simple Mail Transfer Protocol). Se Exchange Server Analyzer riceve da tale account una risposta diversa dalla risposta predefinita indicata di seguito, verrà visualizzato un avviso:

"220 Nome computer . Nome dominio .com Microsoft ESMTP MAIL Service, Version: NUmero versione ready at Data Ora +0000"

Questo avviso indica che la risposta predefinita visualizzata quando il programma esegue la connessione a un server virtuale SMTP Exchange è stata personalizzata.

Un banner SMTP personalizzato potrebbe non rappresentare un problema se l'amministratore di Exchange Server ha modificata intenzionalmente il banner nel modo descritto nell'articolo 281224 della Microsoft Knowledge Base "XCON: Modifica del banner SMTP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224.

Se il banner SMTP predefinito non è stato personalizzato intenzionalmente dall'amministratore di Exchange Server, l'avviso può indicare che Exchange Server si trova dietro un firewall o un proxy SMTP che filtra i comandi estesi SMTP di Exchange Server (ESMTP, Exchange Server Extended SMPT).

Se i comandi ESMTP di Exchange Server vengono filtrati, le prestazioni di Exchange possono risentirne e si può verificare il comportamento descritto nell'articolo 320027 della Microsoft Knowledge Base "Non è possibile inviare o ricevere messaggi di posta elettronica da dietro un firewall Cisco PIX" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027.

Per ulteriori informazioni sui banner SMTP personalizzati, consultare i seguenti articoli della Microsoft Knowledge Base:

  • "XCON: Modifica del banner SMTP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224.

  • "Non è possibile inviare o ricevere messaggi di posta elettronica da dietro un firewall Cisco PIX" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027.


Istanza SMTP sospesa
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella metabase IIS per determinare il valore della proprietà ServerState per ciascuna istanza del server virtuale SMTP.

La proprietà ServerState fornisce lo stato corrente dell'istanza del server. Gli stati e i codici corrispondenti possono essere i seguenti: 1 (avvio in corso), 2 (avviata), 3 (arresto in corso), 4 (arrestata), 5 (sospensione in corso), 6 (sospesa) o 7 (ripresa).

Se Exchange Server Analyzer Tool determina che il valore della proprietà ServerState per un'istanza del server virtuale SMTP è pari a 6 (sospesa), verrà visualizzato un errore.

SMTP è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

I server virtuali vengono eseguiti in un processo server che è possibile avviare, arrestare e interrompere, come avviene per altri processi server. Ad esempio, se si modifica la configurazione di un server virtuale oppure si eseguono altre attività di manutenzione, potrebbe essere necessario arrestare il server virtuale, apportare le modifiche, quindi riavviarlo. Quando un server virtuale viene arrestato, non vengono accettate connessioni da parte degli utenti e non è possibile utilizzarlo per recapitare o recuperare posta.

Un'alternativa all'arresto di un server virtuale è la sospensione. Quando si sospende un server virtuale, si impediscono nuove connesisoni client ma non vengono disconnesse le connessioni correnti. Quando si sospende un server virtuale SMTP, i client attivi possono continuare a inviare messaggi e il server virtuale può recapitare i messaggi esistenti che si trovano in coda per il recapito, ma non vengono accettate nuove connessioni.

Per le operazioni ordinarie di messaggistica, le istanze del server virtuale SMTP di Exchange Server devono essere in stato avviata.

Per correggere questo errore, procedere come segue per avviare l'istanza del server virtuale SMTP.

Per avviare l'istanza del server virtuale SMTP

  1. Nel Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sull'istanza del server virtuale da avviare.

  2. Dal menu Azioni scegliere Start.

Per ulteriori informazioni sull'avvio, arresto o interruzione dei server virtuali SMTP, vedere i seguenti articoli della Microsoft Knowledge Base:

  • "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

  • "XIMS: Svuotamento delle code di posta SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087.

  • "XGEN: "Disabilitazione dei protocolli in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330.


Istanza SMTP arrestata
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella metabase IIS per determinare il valore della proprietà ServerState per ciascuna istanza del server virtuale SMTP.

La proprietà ServerState fornisce lo stato corrente dell'istanza del server. Gli stati e i codici corrispondenti possono essere i seguenti: 1 (avvio in corso), 2 (avviata), 3 (arresto in corso), 4 (arrestata), 5 (sospensione in corso), 6 (sospesa) o 7 (ripresa).

Se Exchange Server Analyzer Tool determina che il valore della proprietà ServerState per un'istanza del server virtuale SMTP è pari a 4 (arrestata), verrà visualizzato un errore.

SMTP è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

I server virtuali vengono eseguiti in un processo server che è possibile avviare, arrestare e interrompere, come avviene per altri processi server. Ad esempio, se si modifica la configurazione di un server virtuale oppure si eseguono altre attività di manutenzione, potrebbe essere necessario arrestare il server virtuale, apportare le modifiche, quindi riavviarlo. Quando un server virtuale viene arrestato, non vengono accettate connessioni da parte degli utenti e non è possibile utilizzarlo per recapitare o recuperare posta.

Per le operazioni ordinarie di messaggistica, le istanze del server virtuale SMTP di Exchange Server devono essere in stato avviata.

Per correggere questo errore, procedere come segue per avviare l'istanza del server virtuale SMTP.

Per avviare l'istanza del server virtuale SMTP

  1. Nel Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sull'istanza del server virtuale da avviare.

  2. Dal menu Azioni scegliere Start.

Per ulteriori informazioni sull'avvio, arresto o interruzione dei server virtuali SMTP, vedere i seguenti articoli della Microsoft Knowledge Base:

  • "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

  • "XIMS: Svuotamento delle code di posta SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=251087.

  • "XGEN: "Disabilitazione dei protocolli in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=291330.


Il limite massimo dei destinatari SMTP potrebbe essere impostato su un valore troppo basso
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpMaxRecipients è minore di 250. Per impostazione predefinita, l'attributo msExchSmtpMaxRecipients è configurato per 64.000 destinatari. Se Exchange Server Analyzer rileva che l'attributo msExchSmtpMaxRecipients è configurato con un valore minore di 250, verrà visualizzato un avviso.

Dal punto di vista della protezione, si consiglia di limitare il numero massimo dei destinatari per ciascun messaggio. Si consiglia di non modificare l'impostazione dell'attributo msExchSmtpMaxRecipients sul valore predefinito 64000.

Ciascuna organizzazione dovrebbe determinare il numero massimo accettabile dei destinatari in base alle proprie esigenze aziendali. Si consiglia, tuttavia, di non impostare il numero massimo dei destinatari su un valore minore di 250. È possibile che i messaggi inviati a più liste di distribuzione presentino un numero di destinatari superiore a 250. Se si imposta il numero massimo dei destinatari su un valore minore di 250, il resto dei destinatari dovrà essere elaborato da Exchange utilizzando copie aggiuntive del messaggio. Queste copie aggiuntive provocano l'aumento del traffico di rete.

Per visualizzare e configurare il numero massimo dei destinatari

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP, ad esempio, il server virtuale SMTP predefinito, e scegliere Proprietà.

  4. Selezionare la scheda Messaggi.

  5. Per ripristinare l'impostazione predefinita 64000, verificare che la casella di controllo Limita numero di destinatari per messaggio a sia selezionata e immettere il valore 64000. In alternativa, è possibile configurare questo campo con il valore desiderato oppure deselezionare la casella di controllo per impostare un numero illimitato di destinatari.

  6. Fare clic su OK per salvare le modifiche e chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


L'indirizzo proxy SMTP di EAS è stato sostituito
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Messaggio di errore

Introduzione

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'indirizzo proxy SMTP di Exchange ActiveSync® è stato sostituito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MasSync\Parameters\SMTPProxy

Se Exchange Server Analyzer rileva che la voce SMTPProxy del Registro di sistema è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Gli indirizzi SMTP vengono utilizzati per identificare il percorso di una cassetta postale in Exchange Server e devono essere univoci. Ogni indirizzo presenta una parte sinistra (LHS, Left-Hand Side) e una parte destra (RHS, Right-Hand Side) separate da un simbolo @. Ad esempio, il formato di un indirizzo SMTP è come quello seguente:

Nomeutente@dominio.com = left-hand-side@right-hand-side (oppure LHS@RHS)

Exchange ActiveSync utilizza una richiesta WebDAV per accedere alle informazioni della cassetta postale dal server di Exchange. Exchange ActiveSync seleziona un valore RHS associato, con LHS@RHS indicante un indirizzo proxy SMTP, da utilizzare nella richiesta WebDAV. In ambienti che presentano un indirizzo RHS predefinito diverso da un indirizzo SMTP primario dell'utente, il valore SMTPProxy del Registro di sistema offre una possibilità di configurazione per consentire a Exchange ActiveSync di utilizzare un indirizzo proxy SMTP alternativo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per visualizzare o modificare il valore SMTPProxy del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MasSync\Parameters

  3. Esaminare ed eventualmente modificare il valore SMTPProxy.

  4. Se viene apportata una modifica, chiudere l'editor del Registro di sistema e riavviare il computer che esegue Exchange Server per renderla effettiva.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su Exchange Server ActiveSync, consultare "Exchange Server 2003 ActiveSync Architecture" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34203 (informazioni in lingua inglese).

Per ulteriori informazioni su Mobile Access ed Exchange Server 2003, consultare "Mobile Access Using Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=20098 (informazioni in lingua inglese).


Il server SMTP accetta l'autenticazione di base
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchAuthenticationFlags nella classe protocolCfgSMTPServer per l'oggetto di Exchange Server. La classe protocolCfgSMTPServer contiene le impostazioni per un server virtuale SMTP. L'attributo msExchAuthenticationFlags rappresenta il tipo di autenticazione accettato dal server virtuale SMTP. Se Exchange Server Analyzer determina che l'autenticazione di base è configurata sul server SMTP e che tale server non fa parte di Microsoft Small Business Server 2000 o di Microsoft Windows® Small Business Server 2003, verrà visualizzato un avviso.

Se sul server SMTP è configurata l'autenticazione di base, aumenta il rischio di violazioni della protezione. L'autenticazione di base consente l'invio in rete dei nomi utente e delle password in forma non crittografata. In assenza di crittografia, i nomi utente e le password possono essere intercettati facilmente su Internet.

Se si utilizza l'autenticazione di base, per garantire una maggiore protezione si consiglia di utilizzare anche la crittografia TSL (Transport Layer Security), che consente di crittografare i nomi utente, le password e i dati dei messaggi. È possibile richiedere che i client i quali si collegano al server virtuale SMTP utilizzino la crittografia TLS. Tale crittografia è progettata per la protezione dei messaggi in uscita, ma non per quella del traffico tra i client e il server.

La crittografia TLS è supportata da Microsoft Outlook Express. Per utilizzarla con il server virtuale SMTP, è necessario creare una coppia di chiavi e configurarne i relativi certificati. I client potranno quindi crittografare la sessione tramite il servizio SMTP. Tutti i messaggi verranno inviati. Il servizio SMTP consente inoltre di utilizzare la crittografia TLS nelle sessioni con server remoti.

Nota:
I client che non supportano la crittografia TLS non possono inoltrare i messaggi di posta elettronica tramite il server virtuale.

Se non è possibile disabilitare l'accesso autenticato sul server virtuale SMTP per motivi aziendali, quali, ad esempio, l'autenticazione da parte di società partner, seguire i passaggi riportati di seguito per migliorare la protezione sul server gateway:

  • Applicare dei criteri di gestione delle password avanzati per tutti gli account utente, in particolare per l'account amministratore.

  • Disabilitare l'account Guest. Per ulteriori informazioni sulla disabilitazione dell'account Guest, consultare l'articolo 320053 della Microsoft Knowledge Base "Ridenominazione degli account Guest e amministratore in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=320053. Sebbene l'articolo si riferisca a Microsoft Windows 2000 Server, si applicano principi analoghi anche a Windows Server™ 2003.

Per disabilitare l'autenticazione di base

  1. In Gestore di sistema di Exchange espandere Server, <il server in ingresso di Exchange>, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse sul server virtuale SMTP in ingresso e scegliere Proprietà.

  3. Fare clic sulla scheda Accesso, quindi su Autenticazione.

    Finestra di dialogo Autenticazione

  4. In Autenticazione deselezionare la casella di controllo Autenticazione di base.

    Importante:
    Se si utilizza l'autenticazione di base, prendere in considerazione l'implementazione di TLS per garantire una maggiore protezione. Utilizzare la casella di controllo Richiedi crittografia TLS se si dispone di un certificato digitale. La maggior parte degli ambienti ad alta protezione si avvalgono dei certificati digitali. Se si seleziona questa casella di controllo, nella corrispondente finestra di dialogo Dominio predefinito è necessario digitare il nome di dominio di Windows 2000 Server o di Windows Server 2003 in cui eseguire l'autenticazione se non viene specificato un dominio. Per ulteriori informazioni sulla crittografia TLS, consultare la documentazione in linea di Exchange.

Per ulteriori informazioni sulla configurazione dell'organizzazione di Exchange Server 2003 per proteggere ulteriormente l'invio e la ricezione della posta Internet, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=26041.


Servizio SMTP disabilitato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore impostato per la chiave StartMode per il servizio SMTP. Un valore di Disabled indica che il servizio SMTP è stato disabilitato e non può essere avviato finché il valore StartMode viene modificato in Manual o Automatic.

Exchange Server Analyzer esegue una query nella classe WMI Win32_Service per determinare il valore della chiave Started per il servizio SMTP. Un valore di False indica che il servizio non è in esecuzione. Un valore di True indica che il servizio è in esecuzione.

Se Exchange Server Analyzer rileva che il valore della chiave StartMode è impostato su Disabled in un computer Exchange Server in cui è stato avviato il servizio SMTP, verrà visualizzato un errore.

Il servizio SMTP di Windows è un componente di IIS (Internet Information Services) e viene eseguito come parte di Inetinfo.exe. Exchange Server fa riferimento al servizio SMTP come protocollo di trasporto nativo. Pertanto, Exchange utilizza il protocollo SMTP per instradare tutti i messaggi interni ed esterni.

È necessario che tutti i computer Exchange Server abbiano il servizio SMTP impostato su Automatic.

Per correggere questo errore, è necessario configurare il servizio SMTP per l'avvio automatico sui server che instradano la posta.

Per configurare il servizio SMTP per l'avvio automatico

  1. Aprire lo snap-in MMC Servizi.

  2. Fare doppio clic sul servizio SMTP (Simple Mail Transfer Protocol).

  3. Nella scheda Generale della pagina delle Proprietà SMTP (Simple Mail Transfer Protocol) selezionare Automatico dalla finestra di dialogo a discesa Tipo di avvio, quindi fare clic su Applica.

  4. In Stato server fare clic su Avvia e quindi su OK.

  5. Chiudere lo snap-in Servizi.

Per ulteriori informazioni sul servizio SMTP e sui server Exchange, vedere "Architettura di trasporto SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla configurazione del servizio SMTP per Exchange, vedere "Configurazione del servizio SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=24866.


Servizio SMTP non avviato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2007-03-13

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio SMTP. Un valore di False indica che il servizio SMTP non è in esecuzione. Un valore di True indica che il servizio SMTP è in esecuzione.

Se Exchange Server Analyzer rileva che il valore della chiave Started è impostato su False, verrà visualizzato un messaggio di errore.

Il servizio SMTP di Windows è un componente di IIS (Internet Information Services) e viene eseguito come parte di Inetinfo.exe. Exchange Server fa riferimento al servizio SMTP come protocollo di trasporto nativo. Pertanto, Exchange utilizza il protocollo SMTP per instradare tutti i messaggi interni ed esterni.

È necessario che il servizio SMTP sia sempre in esecuzione nei server Exchange.

Per correggere questo errore

  1. Aprire lo snap-in MMC Servizi.

  2. Nel riquadro destro scorrere fino a visualizzare il servizio SMTP (Simple Mail Transfer Protocol), quindi fare doppio clic su di esso. Verrà visualizzata la finestra di dialogo Proprietà SMTP (Simple Mail Transfer Protocol).

  3. Impostare il valore nel menu a discesa Tipo di avvio su Automatico.

  4. Fare clic su Start per avviare il servizio Supervisore sistema.

  5. Fare clic su OK per salvare le modifiche e chiudere la finestra di dialogo Proprietà SMTP (Simple Mail Transfer Protocol).

  6. Chiudere lo snap-in Servizi.

Per ulteriori informazioni sul servizio SMTP e sui server Exchange, vedere "Architettura di trasporto SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47891.

Per ulteriori informazioni sulla configurazione del servizio SMTP per Exchange, vedere "Configurazione del servizio SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=24866.


Servizio SMTP impostato su Manuale
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-05-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore impostato per la chiave StartMode per il servizio SMTP. Un valore di Manual indica che il servizio SMTP è stato impostato per richiedere l'avvio manuale, quindi non si avvierà automaticamente.

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_Service per determinare il valore della chiave Started per il servizio SMTP. Un valore di False indica che il servizio non è in esecuzione. Un valore di True indica che il servizio è in esecuzione.

Se Exchange Server Analyzer rileva che il valore della chiave StartMode è impostato su Manual in un computer Exchange Server in cui è stato avviato il servizio SMTP, verrà visualizzato un avviso.

Il servizio SMTP di Windows è un componente di IIS (Internet Information Services) e viene eseguito come parte di Inetinfo.exe. Exchange Server fa riferimento al servizio SMTP come protocollo di trasporto nativo. Pertanto, Exchange utilizza il protocollo SMTP per instradare tutti i messaggi interni ed esterni.

Se il servizio SMTP non si avvia automaticamente all'avvio, potrebbe non essere stato rilevato. Potrebbero verificarsi gravi problemi di flusso di posta.

È necessario che tutti i computer Exchange Server abbiano il servizio SMTP impostato su Automatic.

Per correggere questo errore, è necessario configurare il servizio SMTP per l'avvio automatico sui server che instradano la posta.

Per configurare il servizio SMTP per l'avvio automatico

  1. Aprire lo snap-in MMC Servizi.

  2. Fare doppio clic sul servizio SMTP (Simple Mail Transfer Protocol).

  3. Nella scheda Generale della pagina delle Proprietà SMTP (Simple Mail Transfer Protocol) selezionare Automatico dalla finestra di dialogo a discesa Tipo di avvio, quindi fare clic su Applica.

  4. In Stato server fare clic su Avvia e quindi su OK.

  5. Chiudere lo snap-in Servizi.

Per ulteriori informazioni sul servizio SMTP e sui server Exchange, vedere "Architettura di trasporto SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla configurazione del servizio SMTP per Exchange, vedere "Configurazione del servizio SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=24866.


Stato servizio SMTP sconosciuto
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio SMTP. Un valore di False indica che il servizio SMTP non è in esecuzione. Un valore di True indica che il servizio SMTP è in esecuzione.

Se Exchange Server Analyzer non è in grado di determinare il valore della chiave Started, verrà visualizzato un messaggio di errore.

Tale errore indica che la query WMI non è stata in grado di recuperare i dati richiesti.

I possibili motivi di questo errore sono riportati di seguito:

  • L'account che esegue Exchange Server Analyzer non dispone delle autorizzazioni necessarie per eseguire una query WMI.

  • Un problema di rete impedisce a Exchange Server Analyzer di accedere al computer.

  • Una condizione temporanea di origine sconosciuta ha provocato il timeout della query.

Per risolvere il problema

  1. Assicurarsi che il server che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il server di Exchange sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC (Remote Procedure Call) sono bloccate.

  4. Controllare le autorizzazioni dell'account per cui è in esecuzione Microsoft Exchange Server Analyzer Tool. L'account deve disporre delle autorizzazioni di amministratore locale su ciascun server di Exchange analizzato.

    In alternativa, è possibile concedere un'autorizzazione WMI specifica all'account su cui è in esecuzione Exchange Server Analyzer.

    1. Sul server di Exchange aprire la struttura della console MMC (Microsoft Management Console) Gestione computer.

    2. In Servizi e applicazioni fare clic con il pulsante destro del mouse su Controllo WMI e scegliere Proprietà.

    3. Nella pagina di dialogo delle proprietà di Controllo WMI fare clic sulla scheda Protezione, quindi espandere Directory principale.

    4. Selezionare la cartella CIMV2, quindi fare clic su Protezione.

    5. Nella pagina Protezione per ROOT\CIMV2 aggiungere l'account sul quale è in esecuzione Exchange Server Analyzer.

  5. Selezionare l'account che è stato aggiunto nel passaggio 5. In Autorizzazioni per Account selezionato nella colonna Consenti selezionare sia Abilita accesso remoto sia Protezione da lettura, quindi fare clic su OK.

Per ulteriori informazioni sul servizio SMTP e sui server di Exchange, vedere "Architettura di trasporto SMTP" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47891.

Per ulteriori informazioni sulla configurazione del servizio SMTP per Exchange, vedere "Configurazione del servizio SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=24866.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività di Exchange Server Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (in inglese).


I valori del Registro di sistema UseAltRegionalCharset e UseRegionalCharset sono entrambi abilitati
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare le impostazioni di lingua utilizzate dai client Microsoft Outlook® Web Access:

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

    L'impostazione 1 fa sì che i corpi dei messaggi UTF-8 vengano mantenuti in archivio nella tabella codici o nel set di caratteri internazionale anziché in formato UTF-8. Questa è l'impostazione predefinita per il valore del Registro di sistema UseRegionalCharset di Exchange Server 2003.

  • HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Il livello del browser determina la codifica dei messaggi se si verificano le seguenti condizioni:

  • La chiave UseAltRegionalCharset non è impostata o è impostata su 0.

  • La chiave UseAltRegionalCharset non è impostata o è impostata su 0.

I browser di versioni superiori come Internet Explorer 5 o versioni successive inviano i messaggi in formato UTF-8. I browser di versioni precedenti o diversi da Internet Explorer 5 inviano i messaggi nella codifica appropriata alla lingua di accettazione del browser in questione.

La chiave UseAltRegionalCharset modifica solo il comportamento dei browser configurati per le lingue riportate nel seguente elenco:

  • Coreano: KS_C_5601-1987

  • Giapponese: shift_jis

  • Europa occidentale: windows-1252

  • Russo: windows-1251

  • Europa centrale: windows-1250

Se la chiave UseAltRegionalCharset è impostata su 1, sia i browser di versioni superiori che quelli di versioni precedenti invieranno messaggi nelle seguenti codifiche:

  • Coreano: euc_kr

  • Giapponese: iso-2022-jp (JIS)

  • Europa occidentale: iso-8859-1

  • Russo: koi8-r

  • Europa centrale: iso-8859-2

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti che dispongono di una classe oggetto di msExchExchangeServer.

  • Se la stringa comprende "Version 6.0", il computer esegue Exchange 2000 Server.

  • Se la stringa comprende "Version 6.5", il computer esegue Exchange Server 2003.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • I valori UseAltRegionalCharset e UseRegionalCharset sono entrambi presenti

  • I valori UseAltRegionalCharset e UseRegionalCharset sono entrambi configurati per utilizzare un valore di 1 in un server Exchange 2000 o Exchange 2003.

Se in Exchange 2000 Server ed Exchange Server 2003 si verificano le seguenti condizioni, hanno la precedenza i set di caratteri alternativi:

  • È attivato l'uso dei caratteri internazionali: il valore REG_DWORD della chiave del Registro di sistema UseRegionalCharset è impostato su -1.

  • È attivato l'uso di set di caratteri alternativi: il valore REG_DWORD della chiave del Registro di sistema UseAltRegionalCharset è impostato su 0x1.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Nel computer Exchange aprire un editor del Registro di sistema, come Regedit.exe o RegEdt32.exe.

  2. Determinare quali sono le impostazioni di lingua di Outlook Web Access appropriate all'ambiente Exchange Server e rimuovere la chiave inappropriata.

    1. Passare a: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

    2. Selezionare la chiave da rimuovere, fare clic con il pulsante destro del mouse su di essa e scegliere Elimina dall'elenco a discesa.

  3. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni di lingua di Outlook Web Access, consultare le seguenti risorse su Exchange Server:

"Exchange Server Client Access Guide", disponibile all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47568.

Articolo article 311342 della Microsoft Knowledge Base, "XCCC: Chiavi del Registro di sistema OWA del lato server di Exchange 2000 Server SP2", disponibile all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342.


Il valore del Registro di sistema UseAltRegionalCharset è abilitato in Exchange 2000 Server
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stata utilizzata la chiave UseAltRegionalCharset per l'impostazione di lingua dei client di Microsoft Outlook® Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseAltRegionalCharset

Il livello del browser determina la codifica dei messaggi se si verificano le seguenti condizioni:

  • La chiave UseAltRegionalCharset non è impostata o è impostata su 0.

  • La chiave UseAltRegionalCharset non è impostata o è impostata su 0.

La chiave UseAltRegionalCharset modifica solo il comportamento dei browser configurati per le lingue riportate nel seguente elenco:

  • Coreano: KS_C_5601-1987

  • Giapponese: shift_jis

  • Europa occidentale: windows-1252

  • Russo: windows-1251

  • Europa centrale: windows-1250

Se la chiave UseAltRegionalCharset è impostata su 1, sia i browser di versioni superiori che quelli di versioni precedenti invieranno messaggi nelle seguenti codifiche:

  • Coreano: euc_kr

  • Giapponese: iso-2022-jp (JIS)

  • Europa occidentale: iso-8859-1

  • Russo: koi8-r

  • Europa centrale: iso-8859-2

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se il valore della stringa comprende "Version 6.0", il computer esegue Exchange 2000 Server.

Se Exchange Server Analyzer rileva che la chiave UseAltRegionalCharset è configurata per l'utilizzo di un valore maggiore di 0 su un computer che esegue Exchange 2000 Server, verrà visualizzato un messaggio di configurazione non predefinita.

Il messaggio indica che il parametro del Registro di sistema UseAltRegionalCharset in questo server di Exchange 2000 è abilitato. Se si prevede che gli utenti di Outlook Web Access dell'organizzazione si troveranno spesso a inviare posta a destinatari che utilizzano svariati set di caratteri, è possibile modificare le impostazioni del Registro di sistema, in modo che gli utenti che eseguono Internet Explorer 5 o versioni successive possano utilizzare caratteri UNICODE con codifica UTF-8 per l'invio dei messaggi. Se non è necessario gestire più set di caratteri, è possibile attenersi alla seguente procedura per ripristinare la configurazione predefinita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare l'impostazione di lingua predefinita per Outlook Web Access

  1. Nel computer di Exchange, aprire un editor del Registro di sistema quale, ad esempio, Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Nel riquadro destro eliminare il valore del Registro di sistema UseAltRegionalCharSet.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni di lingua di Outlook Web Access, vedere l'articolo 311342 della Microsoft Knowledge Base "XCCC: Chiavi del Registro di sistema OWA del lato server di Exchange 2000 Server SP2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=311342.


Il valore del Registro di sistema UseAltRegionalCharset è abilitato in Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per ricercare il valore del Registro di sistema UseAltRegionalCharset:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\

Il valore del Registro di sistema UseAltRegionalCharset consente agli utenti di Microsoft Outlook® Web Access di codificare i messaggi di posta elettronica utilizzando un set di caratteri alternativo.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se il valore della stringa include "Version 6.5", il computer esegue Microsoft Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore del Registro di sistema UseAltRegionalCharset è impostato su un numero maggiore di 0 su un server di Exchange 2003, verrà visualizzato un messaggio di configurazione non predefinita.

Il messaggio indica che UseAltRegionalCharset è stato configurato sul server di Exchange 2003. Questa impostazione può causare una codifica del set di caratteri non intenzionale per i messaggi di Outlook Web Access, rendendo alcuni messaggi illeggibili da determinati client. È consigliabile verificare che le impostazioni di lingua dei client siano corrette.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare l'impostazione di lingua predefinita per Outlook Web Access su Exchange Server 2003

  1. Nel computer di Exchange, aprire un editor del Registro di sistema quale, ad esempio, Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Nel riquadro destro eliminare il valore del Registro di sistema UseAltRegionalCharSet.

  4. Se il valore del Registro di sistema UseRegionalCharset non è presente, seguire i passaggi riportati di seguito per crearlo:

    1. Scegliere Nuovo dal menu Modifica e quindi fare clic su Valore DWORD.

    2. Digitare UseRegionalCharset come nome del valore DWORD, quindi premere INVIO.

  5. Se UseRegionalCharset è presente, fare doppio clic su di esso per modificarlo.

  6. Nella casella Dati valore digitare 1, quindi fare clic su OK.

  7. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui valori del Registro di sistema UseAltRegionalCharSet e UseRegionalCharset, consultare l'articolo 283214 della Microsoft Knowledge "XCCC: Possibilità di inviare un messaggio di Outlook Web Access in giapponese in SJIS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=283214.


Il valore del Registro di sistema UseRegionalCharset è abilitato su Exchange 2000 Server
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare le impostazioni di lingua utilizzate dai client Microsoft Outlook® Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Il valore del Registro di sistema UseRegionalCharset fa sì che i corpi dei messaggi UTF-8 vengano mantenuti in archivio nella tabella codici o nel set di caratteri internazionale anziché in formato UTF-8.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti che dispongono di una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 6.0", il computer esegue Exchange 2000 Server.

Se Exchange Server Analyzer rileva che UseRegionalCharset è stato configurato in modo da utilizzare un valore pari o superiore a 1 su un computer che esegue Exchange 2000 Server, verrà visualizzato un messaggio di configurazione non predefinita.

Tale messaggio indica che il parametro del Registro di sistema UseRegionalCharset è abilitato su questo server di Exchange 2000. Se si prevede che gli utenti di Outlook Web Access all'interno dell'organizzazione inviino frequentemente messaggi a destinatari che utilizzano un'ampia gamma di set di caratteri, è possibile modificare le impostazioni del Registro di sistema in modo da consentire agli utenti che dispongono di Internet Explorer 5 o versioni successive di utilizzare caratteri UNICODE con codifica UTF-8 per l'invio della posta. Se non si ha bisogno di più set di caratteri, è possibile implementare la procedura riportata di seguito per ripristinare la configurazione predefinita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare le impostazioni di lingua predefinite per Outlook Web Access

  1. Nel computer Exchange aprire un editor del Registro di sistema, come Regedit.exe o RegEdt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Nel riquadro destro eliminare il valore del Registro di sistema UseRegionalCharSet.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il valore del Registro di sistema UseRegionalCharset è disabilitato
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare le impostazioni di lingua utilizzate dai client Microsoft Outlook® Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Il valore del Registro di sistema UseRegionalCharset fa sì che i corpi dei messaggi UTF-8 vengano mantenuti in archivio nella tabella codici o nel set di caratteri internazionale anziché in formato UTF-8.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti che dispongono di una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 6.5", il computer esegue Exchange Server 2003.

Se Exchange Server Analyzer rileva che UseRegionalCharset è stato configurato in modo da utilizzare un valore pari o superiore a 1 su un computer che esegue Exchange Server 2003, verrà visualizzato un messaggio di configurazione non predefinita.

Tale messaggio indica che il parametro del Registro di sistema UseRegionalCharset è disabilitato su questo server di Exchange 2003. La disabilitazione del parametro può determinare una codifica non intenzionale dei set di caratteri per i messaggi di Outlook Web Access, da cui può risultare l'illeggibilità di alcuni messaggi da parte di determinati client.

Se si utilizza Microsoft Internet Explorer 5 o versioni successive per accedere a Outlook Web Access, Exchange Server 2003 si avvarrà delle impostazioni di lingua del browser per stabilire il set di caratteri da utilizzare per la codifica di informazioni quali messaggi di posta elettronica e convocazioni di riunione.

Se si prevede che gli utenti di Outlook Web Access all'interno dell'organizzazione inviino frequentemente messaggi a destinatari che utilizzano un'ampia gamma di set di caratteri, è possibile modificare le impostazioni del Registro di sistema in modo da consentire agli utenti che dispongono di Internet Explorer 5 o versioni successive di utilizzare caratteri UNICODE con codifica UTF-8 per l'invio della posta.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare le impostazioni di lingua predefinite per Outlook Web Access

  1. Nel computer Exchange aprire un editor del Registro di sistema, come Regedit.exe o RegEdt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Se il parametro UseRegionalCharset non è presente, attenersi alla procedura riportata di seguito per crearlo:

    1. Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.

    2. Digitare UseRegionalCharset come nome del valore DWORD, quindi premere INVIO.

  4. Se UseRegionalCharset è presente, fare doppio clic su di esso per modificarlo.

  5. Nella casella Dati valore digitare 1, quindi fare clic su OK.

  6. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni di lingua di Outlook Web Access, consultare "Exchange Server Client Access Guide" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47568 (informazioni in lingua inglese).


Il valore UseRegionalCharset del Registro di sistema è disabilitato o assente su Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare le impostazioni della lingua utilizzata dai client Microsoft Outlook® Web Access:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA\UseRegionalCharset

Il valore della chiave UseRegionalCharset del Registro di sistema induce i corpi dei messaggi UTF-8 a persistere nell'archiviazione della serie di caratteri regionali o della tabella codici anziché nel formato UTF-8.

Inoltre, Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende Version 6.5, il computer esegue Exchange Server 2003.

Se una delle seguenti condizioni è soddisfatta, in Exchange Server Analyzer verrà visualizzato un avviso:

  • La voce UseRegionalCharset per un server di Exchange 2003 non è presente.

  • La voce UseRegionalCharset presenta un valore diverso da 1.

Questo messaggio indica che il parametro UseRegionalCharset del Registro di sistma sul server Exchange 2003 è disabilitato o non è presente. Questa impostazione può indurre una codifica non intenzionale della serie di caratteri dei messaggi di Outlook Web Access e alcuni messaggi potrebbero risultare illeggibili.

Quando si utilizza Microsoft Internet Explorer 5 o versioni successive per accedere a Outlook Web Access, Exchange Server 2003 utilizza le impostazioni della lingua del browser per determinare la serie di caratteri da utilizzare per codificare le informazioni, ad esempio i messaggi di posta e le convocazioni di riunioni.

Se si prevede un invio frequente da parte degli utenti di Outlook Web Access nell'organizzazione di messaggi di posta a destinatari che utilizzano diversi set di caratteri, è possibile modificare le impostazioni del Registro di sistema in modo che gli utenti che utilizzano Internet Explorer 5 o versioni successive possano utilizzare i caratteri UNICODE codificati con UTF-8 per inviare i messaggi di posta.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare le impostazioni predefinite della lingua per Outlook Web Access

  1. Nel computer che esegue Exchange aprire un editor del Registro di sistema, ad esempio Regedit.exe o RegEdt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\

  3. Se non è presente UseRegionalCharset, procedere come descritto di seguito per crearlo:

    1. Dal menu Modifica, scegliere Nuovo, quindi fare clic su Valore DWORD.

    2. Immettere UseRegionalCharset per denominare DWORD, quindi premere INVIO.

  4. Se è presente UseRegionalCharset, fare doppio clic su di esso per modificarlo.

  5. Nella casella Dati valore digitare 1, quindi fare clic su OK.

  6. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni della lingua di Outlook Web Access, consultare "Exchange Server Client Access Guide" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47568 (informazioni in lingua inglese).


Carico utenti e operazioni MAPI
Articoli su Microsoft Exchange Server Analyzer > Protocolli >

Ultima modifica: 2006-10-17

Microsoft® Exchange Server Analyzer Tool ha rilevato che alcune operazioni MAPI sul server contribuiscono a una percentuale significativa del carico utenti del server. Questo rilevamento viene eseguito mediante una query sulle operazioni che utilizzano più del 4% del tempo CPU rispetto al tempo totale della CPU utilizzato nell'elaborazione di tutte le richieste RPC.

Cause comuni di operazioni MAPI con percentuale elevata di utilizzo della CPU

Un amministratore che ricerca la causa delle scarse prestazioni di Exchange Server deve controllare se la dimensione media delle cassette postali è elevata sui server con prestazioni ridotte. È necessario determinare se la dimensione delle singole cartelle è troppo elevata (più di 5.000 elementi nella cartella Posta in arrivo, Posta inviata, Posta eliminata o Calendario). Le dimensioni eccessive delle cartelle e l'aumento delle dimensioni delle cassette postali provocano un aumento del carico della CPU e d I/O. Inoltre, l'aumento del numero di visualizzazioni di ogni cartella sovraccarica ulteriormente molte operazioni MAPI.

Visualizzazioni

Molte delle comuni operazioni MAPI con esecuzione prolungata sono collegate alle visualizzazioni. Due fra le più importanti sono Restrict e FindRow. Queste operazioni non richiedono sempre molto tempo. Pertanto, se presentano problemi di prestazioni, è necessario comprenderne i motivi. Si noti inoltre che, in aggiunta ai seguenti motivi, quando si verifica un collo di bottiglia per le risorse (in genere un collo di bottiglia di disco o della CPU), le latenze delle operazioni aumentano.

Nota:
Talvolta può esservi un costo elevato in TaskQ User Known in associazione con operazioni Restrict o FindRow; ciò è dovuto al fatto che parte del lavoro per queste operazioni viene eseguito in TaskQ e il costo viene attribuito a TaskQ User Known.

Restrizioni

L'operazione MAPI Restrict viene utilizzata per selezionare elementi che soddisfano determinati criteri. Il server crea una visualizzazione che in effetti è una tabella con il criterio associato detto restrizione. Se la visualizzazione ha un restrizione corrispondente già esistente, il server utilizza la visualizzazione esistente per soddisfare la richiesta dell'utente. Il costo dell'utilizzo di questa visualizzazione è relativamente basso, mentre il costo della creazione di una nuova visualizzazione è abbastanza alto. Per impostazione predefinita, l'archivio memorizza nella cache solo 11 visualizzazioni per ogni cartella. Se viene richiesto di creare la dodicesima visualizzazione, la visualizzazione più vecchia memorizzata nella cache viene eliminata per creare la nuova visualizzazione. Le visualizzazioni aggiungono sovraccarico a tutte le azioni su elementi che corrispondono alla restrizione delle visualizzazioni.

FindRow

Le applicazioni client utilizzano le operazioni MAPI SeekRow o FindRow per spostare il cursore tra le righe di una visualizzazione. SeekRow consente di specificare di quante righe spostare il cursore ed è un'operazione molto economica in termini di tempo CPU. FindRow è un'operazione piuttosto costosa poiché consente di spostare il cursore sul primo elemento in una visualizzazione non materializzata (che non verrà memorizzata nella cache) che soddisfa i criteri di restrizione e quindi elimina la visualizzazione quando l'applicazione client termina l'azione. Il costo finale di FindRow per la CPU dipende dalla complessità della restrizione e dal numero di righe che l'archivio deve esaminare prima di trovare il primo elemento che soddisfa il criterio ed è quindi liberamente correlato al numero di elementi presenti nella cartella.

Poiché il costo delle operazioni Restrict e FindRow può risultare elevato, potrebbe essere consigliabile eseguire queste operazioni in modalità cache per ridurre i costi del server. È necessario tenere presente che talvolta l'elevata percentuale di CPU utilizzata da queste operazioni può essere stata causata semplicemente da calendari condivisi, nel qual caso la modalità cache non risulterà utile. Un elevata percentuale di tempo CPU utilizzato da queste operazioni può indicare numerose creazioni di visualizzazioni, visualizzazioni costose e un numero molto elevato di elementi presenti nelle cartelle.

Per ulteriori informazioni

Per ulteriori informazioni, vedere le seguenti risorse Exchange Server:

  • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Prestazioni di Exchange Server 2003: 10 considerazioni su cui soffermarsi all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56460.


Archiviazione
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente all'archiviazione. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere avvisi, messaggi di errore e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi all'archiviazione.


Aging Clean Interval per un archivio delle cassette postali non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'intervallo per la rimozione degli indici del database non utilizzati è stato modificato rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Aging Clean Interval

Se Exchange Server Analyzer rileva che la chiave Aging Clean Interval è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Una delle funzioni di ESE (Extensible Storage Engine) consiste nel creare in modo dinamico degli indici quando le informazioni vengono riordinate o quando viene richiesto un tipo di ordinamento diverso. Di conseguenza, il database dell'archivio di Exchange potrebbe disporre di migliaia di indici in una tabella. Questa situazione viene gestita dall'archivio di Exchange assegnando agli indici un'ora di scadenza. Le informazioni sull'indice vengono aggiunte a una tabella interna denominata tabella di durata dell'indice. Durante le operazioni di manutenzione in linea, la tabella di durata dell'indice viene esaminata e il valore dell'ora di eliminazione di ciascuna voce viene confrontato con quello dell'ora corrente. Se è scaduto, l'indice verrà rimosso. Per impostazione predefinita, questo processo viene eseguito a intervalli di 24 ore durante il ciclo di manutenzione dell'archivio di Exchange e consente di eliminare le voci presenti da più di 8 giorni in Exchange Server 5.5 e da più di 40 giorni in Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007. La chiave Aging Clean Interval rappresenta l'intervallo in millisecondi in base al quale l'archivio di Exchange esegue la rimozione degli indici non utilizzati. È possibile utilizzare la chiave del Registro di sistema per ignorare questa impostazione predefinita ed eseguire la medesima funzione a intervalli personalizzati.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Eliminare la chiave Aging Clean Interval.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla chiave Aging Clean Interval, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 159197, "XADM: Controllo della durata dell'indice delle cartelle" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197.

  • 216076, "Rallentamento nell'accesso alle cartelle dell'archivio informazioni in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076.


Aging Clean Interval per un archivio cartelle pubbliche non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'intervallo per la rimozione degli indici del database non utilizzati è stato modificato rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Aging Clean Interval

Se Exchange Server Analyzer rileva che la chiave Aging Clean Interval è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Una delle funzioni di ESE (Extensible Storage Engine) consiste nel creare in modo dinamico degli indici quando le informazioni vengono riordinate o quando viene richiesto un tipo di ordinamento diverso. Di conseguenza, il database dell'archivio di Exchange potrebbe disporre di migliaia di indici in una tabella. Questa situazione viene gestita dall'archivio di Exchange assegnando agli indici un'ora di scadenza. Le informazioni sull'indice vengono aggiunte a una tabella interna denominata tabella di durata dell'indice. Durante le operazioni di manutenzione in linea, la tabella di durata dell'indice viene esaminata e il valore dell'ora di eliminazione di ciascuna voce viene confrontato con quello dell'ora corrente. Se è scaduto, l'indice verrà rimosso. Per impostazione predefinita, questo processo viene eseguito a intervalli di 24 ore durante il ciclo di manutenzione dell'archivio di Exchange e consente di eliminare le voci presenti da più di 8 giorni in Exchange Server 5.5 e da più di 40 giorni in Exchange 2000 Server ed Exchange Server 2003. La chiave Aging Clean Interval rappresenta l'intervallo in millisecondi in base al quale l'archivio di Exchange esegue la rimozione degli indici. È possibile utilizzare la chiave del Registro di sistema per ignorare questa impostazione predefinita ed eseguire la medesima funzione a intervalli personalizzati.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Eliminare la chiave Aging Clean Interval.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla chiave Aging Clean Interval, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 159197, "XADM: Controllo della durata dell'indice delle cartelle" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=159197.

  • 216076, "Rallentamento nell'accesso alle cartelle dell'archivio informazioni in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=216076.


L'accesso al server è consentito per tutte le versioni di Outlook
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se ad alcune versioni di Microsoft Office Outlook® è impedita la connessione a Exchange Server:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che la chiave Disable MAPI Clients non esiste, verrà visualizzato un avviso.

La chiave Disable MAPI Clients, che per impostazione predefinita non è abilitata, consente all'amministratore di impedire a determinate versioni di Outlook di connettersi a un computer su cui è in esecuzione Exchange 2000 Server, Exchange Server 2003 o Exchange Server 2007.

Le versioni e i Service Pack recenti di Outlook includono molti miglioramenti relativi alla protezione antivirus e alla protezione in generale. A partire da Outlook 2002, il blocco degli allegati e Object Model Guard sono stati inclusi e attivati per impostazione predefinita. Queste funzioni sono componenti fondamentali nell'ambito della protezione contro i virus. La versione meno recente di Outlook supportata dal Servizio Supporto Tecnico Clienti Microsoft è Outlook 2000 Service Pack 3 (SP3). Se nella propria organizzazione vengono eseguite versioni precedenti di Outlook, è consigliabile aggiornarle a Outlook 2003 oppure aggiornare almeno il client Outlook alle versioni più recenti relative alla protezione.

Dopo l'aggiornamento di Outlook, è possibile bloccare l'accesso a Exchange per le versioni precedenti che non sono state aggiornate. Il blocco delle versioni precedenti di Outlook in cui non è supportato il blocco degli allegati e Object Model Guard consente di fornire uno specifico livello di protezione del client per le connessioni client MAPI.

Per la protezione da tutte le versioni precedenti di Outlook (Outlook 97, Outlook 98, Outlook 2000 precedente a SP3 e le versioni precedenti), è consigliabile disabilitare la connessione a Exchange Server per tutte le versioni di Outlook con build 5.3164.0.0 o precedenti.

Il client determina autonomamente la stringa di versione del client. Questa stringa è simile al numero di versione riportato nella finestra di dialogo del client Informazioni su. Tuttavia, è consigliabile non fare affidamento su questo numero di versione. Invece, utilizzare Gestore di sistema di Exchange per visualizzare la proprietà Versione client nella pagina Accessi archivio delle cassette postali.

Importante:
Prima di apportare delle modifiche, tenere presente che le versioni degli aggiornamenti rapidi e dei Service Pack possono influire sulla stringa di versione del client. Prestare attenzione quando si impongono restrizioni all'accesso client, poiché anche i componenti Exchange lato server eseguono l'accesso tramite il client MAPI. Nei nomi di alcuni componenti viene indicata la versione del client, ad esempio, SMTP oppure OLEDB, mentre in altri viene indicato il numero della build di Exchange, ad esempio, 6.0.4712.0. Pertanto, è necessario evitare di imporre restrizioni di accesso ai client i cui numeri di versione iniziano con 6.<x.x>. Ad esempio, per impedire completamente l'accesso MAPI, invece di specificare 0.0.0-65535.65535.65535, per garantire l'accesso ai componenti del server, specificare due intervalli come illustrato di seguito: 0.0.0-5.9.9; 7.0.0-65535.65535.65535.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Creare una nuova voce del valore di stringa denominata Disable MAPI Clients.

  4. Fare doppio clic sulla voce Disable MAPI Clients del Registro di sistema e impostare i dati del valore sul livello desiderato. L'elenco dei valori nella stringa Dati valore rappresenta le possibilità disponibili per disabilitare gli intervalli delle versioni di client MAPI. In genere, le versioni (vX) sono espresse nei formati seguenti:

    • Per Microsoft Outlook 2003 e Outlook 2007: Maj.Min.Build

    • Per Microsoft Outlook 2000: Maj.Build.Dot

    • Per versioni precedenti di Microsoft Outlook: Maj.Min.Build

    È possibile indicare tutte le versioni specifiche o gli intervalli di versioni che si desidera disattivare in questa stringa. Utilizzare Exchange System Manager per determinare la versione dei client MAPI che si connettono all'archivio delle cassette postali per Exchange Server 2003. In Exchange System Manager, individuare il contenitore Accessi dell'archivio delle cassette postali. Nella colonna Versione del client viene visualizzata la versione dei client MAPI connessi all'archivio delle cassette postali.

    In Exchange Server 2007, utilizzare il cmdlet Get-LogonStatistics di Exchange Management Shell per recuperare la versione dei client MAPI connessi al database delle cassette postali.
Importante:
La versione del client MAPI viene elencata in Exchange System Manager ed Exchange Management Shell come X.0.Y.Z e deve essere immessa come X.Y.Z nel valore del Registro di sistema. Se ad esempio Exchange System Manager elenca la versione del client MAPI come 5.0.2819.0, immettere 5.2819.0 nel valore del Registro di sistema Disable MAPI Clients.
  1. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni sul blocco della connessione a computer Exchange 2000 Server o Exchange Server 2003 per determinati client MAPI, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328240, "Come imporre restrizioni sul lato server ai client utilizzati per accedere alle cassette postali di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328240.

  • 288894, "XADM: Funzione per disabilitare l'accesso di client MAPI" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=288894.

Per ulteriori informazioni sul download di aggiornamenti della protezione per versioni precedenti di Outlook e sul blocco di altre versioni di Outlook, consultare Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sul cmdlet Get-LogonStatistics, vedere "Get-LogonStatistics" nella documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80699.


Il valore di AssertOnEvent è impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il debug è stato abilitato nell'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\AssertOnEvent

Se Exchange Server Analyzer rileva che stato impostato un valore per AssertOnEvent, verrà visualizzato un avviso.

Il valore AssertOnEvent del Registro di sistema contiene valori decimali che specificano quali eventi dell'archivio devono attivare la modalità di debug dell'Archivio informazioni di Microsoft Exchange. Il Registro di sistema AssertOnEvent si attiva solo se è in esecuzione la versione debug di store.exe. L'Archivio informazioni di Microsoft Exchange utilizza molte risorse quando viene eseguito in modalità di debug. Non è consigliabile eseguire il debug dell'archivio in un ambiente di produzione.

Se non si sta risolvendo attivamente un errore dell'Archivio informazioni di Microsoft Exchange con l'aiuto del Servizio Supporto Tecnico Clienti Microsoft, è preferibile eliminare il valore AssertOnEvent del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per eliminare la chiave del Registro di sistema AssertOnEvent

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro individuare ed eliminare il valore AssertOnEvent.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Identificato almeno un messaggio danneggiato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il numero di voci nel valore PoisonIDs:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeServerExchange> \Private- <GUIDarchivioinformazioniprivato>

Se Exchange Server Analyzer determina che il numero di voci nel valore PoisonIDs è maggiore di 0, verrà visualizzato un avviso.

Le versioni di Exchange Server successive a Exchange Server 2003 Service Pack 1 implementano un comportamento che consente di evitare che messaggi danneggiati o non validi provochino l'arresto imprevisto del servizio Archivio informazioni di Microsoft Exchange o impediscano il corretto avvio del servizio.

In Exchange Server 2003 Service Pack 1 o versioni successive viene tenuta traccia dei messaggi che causano l'arresto imprevisto del servizio Archivio informazioni di Microsoft Exchange durante la conversione dal formato MAPI al formato MIME. Quando si verifica l'arresto anomalo, l'ID del messaggio danneggiato verrà archiviato nel Registro di sistema. Se un messaggio danneggiato causa per tre volte l'arresto imprevisto dell'archivio, queste informazioni verranno utilizzate per impedire la rielaborazione del messaggio quando il servizio Archivio informazioni di Microsoft Exchange verrà riavviato per la quarta volta.

Quando il servizio Archivio informazioni di Microsoft Exchange si arresta in modo imprevisto a causa di un messaggio danneggiato, il valore del Registro di sistema PoisonIDs viene creato in:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<NomeServerExchange> \Private- <GUIDarchivioinformazioniprivato>

Inoltre, l'amministratore può creare nel Registro di sistema la voce PoisonThreshold. La chiave PoisonThreshold è in grado di controllare il numero massimo di volte in cui un messaggio riesce a passare attraverso l'Archivio informazioni di Microsoft Exchange prima di essere aggiunto alla chiave del Registro di sistema PoisonIDs. Per impostazione predefinita, questo valore limite è 2. Per generare questo comportamento, il valore limite deve essere superato. Pertanto, il servizio Archivio informazioni di Microsoft Exchange può arrestarsi 3 volte a causa di un messaggio danneggiato prima che il messaggio in questione venga bloccato. Quindi, un messaggio che determina 3 arresti anomali verrà bloccato poiché è stato superato il valore limite di 2.

Quando un evento messaggio danneggiato viene scritto nel Registro di sistema, i messaggi dell'evento di errore (ID evento 9680 e 9681) vengono visualizzati nel registro eventi applicazioni. Una volta avviato il servizio Archivio informazioni di Microsoft Exchange, il messaggio viene bloccato e viene tentato l'invio di un rapporto di mancato recapito. In alcuni casi è possibile che Exchange non sia in grado di inviare un rapporto di mancato recapito. In questi casi, è possibile che il messaggio bloccato rimanga nella coda fino alla scadenza. La chiave del Registro di sistema PoisonIDs può contenere fino a dieci valori dell'ID messaggio. Quando il limite di dieci viene superato viene aggiunto un nuovo evento messaggio. viene rimosso l'evento messaggio danneggiato la cui data di arresto anomalo è la meno recente.

Per risolvere il problema

  1. Se in un archivio cassette postali si verificano problemi con un messaggio danneggiato, sarà necessario analizzare ulteriormente il problema. Per informazioni sul ripristino di Microsoft IT da database di Exchange danneggiati, consultare http://go.microsoft.com/fwlink/?LinkId=56372.

  2. Se si verificano problemi con gli arresti di Exchange Server 2003 causati da messaggi danneggiati, abilitare la segnalazione automatica degli errori sul computer che esegue Exchange Server. I dati di un rapporto errori vengono utilizzati per individuare e risolvere i problemi nel software in uso. Per ulteriori informazioni sulla procedura di abilitazione della funzionalità di segnalazione degli errori di Exchange, vedere Segnalazione errori di Exchange è disattivata.

Per ulteriori informazioni su Exchange Server 2003 Service Pack 1 (SP1), consultare "Service Pack 1 for Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=29090 (informazioni in lingua inglese).


Background Cleanup per un archivio delle cassette postali non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare i dati correnti del valore Background Cleanup del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Se Exchange Server Analyzer rileva che i dati del valore di Background Cleanup sono impostati su un numero diverso da 60.000 (decimale) o da 0xEA60 (esadecimale), verrà visualizzato un messaggio di configurazione non predefinita. È consigliabile impostare Background Cleanup sul valore predefinito.

Se il valore Background Cleanup è impostato su un numero troppo alto, è possibile che il processo di pulitura in background non venga eseguito con la frequenza necessaria e che si verifichino numerosi problemi, inclusi i seguenti:

  • Lo spostamento delle cassette postali potrebbe non essere eseguito correttamente e potrebbe essere registrato un evento 1205 con codice di errore 0x4e3.

  • Le dimensioni delle cartelle e i conteggi degli elementi visualizzati in Gestore di sistema di Exchange o Exchange Management Console potrebbero risultare molto diversi rispetto ai valori indicati in Microsoft Outlook®. Inoltre, lo spazio di database occupato da questi elementi potrebbe non essere recuperato.

  • In alcuni casi potrebbero non essere generate le conferme di recapito non letto per elementi che sono stati eliminati senza essere letti.

  • La pulitura delle voci obsolete nella tabella DeliveredTo non verrà eseguita. La tabella DeliveredTo viene usata dall'archivio di Exchange per impedire il recapito di messaggi duplicati.

Se il valore Background Cleanup è impostato su un numero troppo basso, il processo di pulitura in background potrebbe causare un inutile sovraccarico del server.

Attenzione
L'esecuzione della procedura illustrata in questo argomento per ripristinare la configurazione predefinita da un valore troppo alto può provocare un aumento del carico sul server fino al completamento della pulitura in background per tutti gli elementi che diversamente sarebbero stati eliminati in base all'intervallo predefinito. Pertanto è consigliabile apportare queste modifiche in un momento in cui il processo influirà in misura minima sul lavoro degli utenti. Inoltre, se dei messaggi per i quali erano state richieste le conferme di lettura sono stati eliminati senza essere stati letti e, di conseguenza, non è stata eseguita la pulitura di tali messaggi, dopo aver corretto l'errore verranno generate conferme di recapito non lette per ciascun messaggio.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di conoscere le operazioni per ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Impostare il valore di Background Cleanup su 60.000 (decimale) oppure su 0xEA60 (esadecimale).

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Intervallo di Background Cleanup mancante per un archivio delle cassette postali
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la presenza del valore del Registro di sistema Background Cleanup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Background Cleanup

Se Exchange Server Analyzer rileva l'assenza del valore Background Cleanup, verrà visualizzato un avviso.

Se il valore Background Cleanup è mancante, il processo di pulitura in background non viene eseguito e si possono verificare molti problemi, inclusi i seguenti:

  • Lo spostamento delle cassette postali potrebbe non essere eseguito correttamente e potrebbe essere registrato un evento 1205 con codice di errore 0x4e3.

  • Le dimensioni delle cassette postali e i conteggi degli elementi visualizzati in Gestore di sistema di Exchange o Exchange Management Console potrebbero risultare molto diversi rispetto ai valori indicati in Microsoft Outlook®. Inoltre, lo spazio di database occupato da questi elementi potrebbe non essere recuperato.

  • In alcuni casi potrebbero non essere generate le conferme di recapito non letto per elementi che sono stati eliminati senza essere letti.

  • La pulizia della tabella DeliveredTo non verrà eseguita. La tabella DeliveredTo viene usata dall'archivio di Exchange per impedire il recapito di messaggi duplicati. Il valore di Track Duplicates controlla il tempo durante il quale verranno mantenute le voci nella tabella DeliveredTo. Se il valore Background Cleanup è presente ma manca il valore Track Duplicates, le voci presenti da più di 24 ore verranno eliminate dal processo di pulitura in background. Il valore consigliato per Track Duplicates è 1 (decimale o esadecimale).

È consigliabile impostare Background Cleanup sul valore predefinito di 60.000 (decimale) o 0xEA60 (esadecimale).

Attenzione
Se si esegue la procedura descritta di seguito per correggere l'errore, si può verificare un sovraccarico del server fino al completamento del processo di pulitura in background di tutti gli elementi che normalmente avrebbero dovuto essere eliminati con regolarità. Pertanto è consigliabile apportare queste modifiche in un momento in cui il processo influirà in misura minima sul lavoro degli utenti. Inoltre, se dei messaggi per i quali erano state richieste le conferme di lettura sono stati eliminati senza essere stati letti e, di conseguenza, non è stata eseguita la pulitura di tali messaggi, dopo aver corretto l'errore verranno generate conferme di recapito non lette per ciascun messaggio.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Creare un valore DWORD denominato Background Cleanup con il valore di 60000 (decimale) o 0xEA60 (esadecimale).

  4. Chiudere l'editor del Registro di sistema. Per rendere effettive le modifiche, eseguire una delle seguenti azioni:

    • Disinstallare e installare gli archivi informazioni interessati.

    • Riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Intervallo di Background Cleanup per un archivio cartelle pubbliche non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare i dati correnti del valore Background Cleanup del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>\Background Cleanup

Se Exchange Server Analyzer rileva che i dati del valore di Background Cleanup sono impostati su un numero diverso da 60.000 (decimale) o da 0xEA60 (esadecimale), verrà visualizzato un messaggio di configurazione non predefinita. Si consiglia di impostare Background Cleanup sul valore predefinito.

Se il valore Background Cleanup è impostato su un numero troppo alto, è possibile che il processo di pulitura in background non venga eseguito con la frequenza necessaria e che si verifichino numerosi problemi, inclusi i seguenti:

  • Le dimensioni delle cartelle e i conteggi degli elementi visualizzati in Gestore di sistema di Exchange potrebbero risultare molto diversi rispetto ai valori indicati in Microsoft Outlook®. Inoltre, lo spazio di database occupato da questi elementi potrebbe non essere recuperato.

  • In alcuni casi potrebbero non essere generate le conferme di recapito non letto per elementi che sono stati eliminati senza essere letti.

  • La pulitura delle voci obsolete nella tabella DeliveredTo non verrà eseguita. La tabella DeliveredTo viene usata dall'archivio di Exchange per impedire il recapito di messaggi duplicati.

Se il valore Background Cleanup è impostato su un numero troppo basso, il processo di pulitura in background potrebbe causare un inutile sovraccarico del server.

Attenzione
L'esecuzione della seguente procedura per ripristinare la configurazione predefinita da un valore troppo alto può provocare un aumento del carico sul server fino al completamento della pulitura in background per tutti gli elementi che diversamente sarebbero stati eliminati in base all'intervallo predefinito. Pertanto è consigliabile apportare queste modifiche in un momento in cui il processo influirà in misura minima sul lavoro degli utenti. Inoltre, se dei messaggi per i quali erano state richieste le conferme di lettura sono stati eliminati senza essere stati letti e, di conseguenza, non è stata eseguita la pulitura di tali messaggi, dopo aver corretto l'errore verranno generate conferme di recapito non lette per ciascun messaggio.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<PublicStoreGUID>

  3. Impostare il valore di Background Cleanup su 60.000 (decimale) oppure su 0xEA60 (esadecimale).

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Intervallo di Background Cleanup mancante per un archivio delle cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la presenza del valore del Registro di sistema Background Cleanup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>\Background Cleanup

Se Exchange Server Analyzer rileva l'assenza del valore Background Cleanup, verrà visualizzato un avviso.

Se il valore Background Cleanup è mancante, il processo di pulitura in background non viene eseguito e si possono verificare molti problemi, inclusi i seguenti:

  • Le dimensioni delle cartelle e i conteggi degli elementi visualizzati in Gestore di sistema di Exchange o Exchange Management Console potrebbero risultare molto diversi rispetto ai valori indicati in Microsoft Outlook®. Inoltre, lo spazio di database occupato da questi elementi potrebbe non essere recuperato.

  • In alcuni casi potrebbero non essere generate le conferme di recapito non letto per elementi che sono stati eliminati senza essere letti.

  • La pulizia della tabella DeliveredTo non verrà eseguita. La tabella DeliveredTo viene usata dall'archivio di Exchange per impedire il recapito di messaggi duplicati. Il valore di Track Duplicates controlla il tempo durante il quale verranno mantenute le voci nella tabella DeliveredTo. Se il valore Background Cleanup è presente ma manca il valore Track Duplicates, le voci presenti da più di 24 ore verranno eliminate dal processo di pulitura in background. Il valore consigliato per Track Duplicates è 1 (decimale o esadecimale).

È consigliabile impostare Background Cleanup sul valore predefinito di 60.000 (decimale) o 0xEA60 (esadecimale).

Attenzione
Se si esegue la procedura descritta di seguito per correggere l'errore, si può verificare un sovraccarico del server fino al completamento del processo di pulitura in background di tutti gli elementi che normalmente avrebbero dovuto essere eliminati con regolarità. Pertanto è consigliabile apportare queste modifiche in un momento in cui il processo influirà in misura minima sul lavoro degli utenti. Inoltre, se dei messaggi per i quali erano state richieste le conferme di lettura sono stati eliminati senza essere stati letti e, di conseguenza, non è stata eseguita la pulitura di tali messaggi, dopo aver corretto l'errore verranno generate conferme di recapito non lette per ciascun messaggio.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicStoreGUID>

  3. Creare un valore DWORD denominato Background Cleanup con il valore di 60000 (decimale) o 0xEA60 (esadecimale).

  4. Chiudere l'editor del Registro di sistema. Per rendere effettive le modifiche, eseguire una delle seguenti azioni:

    • Disinstallare e installare gli archivi informazioni interessati.

    • Riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il valore di BreakOnEvent è impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il debug è stato abilitato nell'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\BreakOnEvent

Se Exchange Server Analyzer rileva che stato impostato un valore per BreakOnEvent, verrà visualizzato un avviso.

Il valore BreakOnEvent del Registro di sistema contiene valori decimali che specificano quali eventi dell'archivio devono attivare la modalità di debug dell'Archivio informazioni di Microsoft Exchange. L'Archivio informazioni di Microsoft Exchange utilizza molte risorse quando viene eseguito in modalità di debug. Non è consigliabile eseguire il debug dell'archivio in un ambiente di produzione.

Se non si sta risolvendo attivamente un errore dell'Archivio informazioni di Microsoft Exchange con l'aiuto del Servizio Supporto Tecnico Clienti Microsoft, è preferibile eliminare il valore BreakOnEvent del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per eliminare la chiave del Registro di sistema BreakOnEvent

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro individuare ed eliminare il valore BreakOnEvent.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


La registrazione delle chiamate è disabilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la registrazione delle chiamate è abilitata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Se Exchange Server Analyzer rileva che il valore di Disable Call Tracing del Registro di sistema è presente e configurato per l'utilizzo di un valore pari a 1 e sul computer è in esecuzione Exchange Server 2003, verrà visualizzato un messaggio di configurazione non predefinita.

Se la funzione di registrazione delel chiamate è abilitata, verranno registrati i dati della chiamata della funzione per i processi Store.exe. Per impostazione predefinita, l'analisi chiamate è abilitata su computer con Exchange Server 2003 in esecuzione. Notare che la funzione è disabilitata per impostazione predefinita su Exchange 2000 Server. Tuttavia, se si esegue Exchange Server 2003, è consigliabile abilitare l'analisi chiamate a meno che non sia stata data un'istruzione diversa dal Servizio Supporto Tecnico Clienti Microsoft. Se l'analisi chiamate è abilitata, raccoglie informazioni importanti per la risoluzione dei problemi che possono crearsi durante il processo di archiviazione.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedit32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Impostare il valore Disable Call Tracing del Registro di sistema su 0.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Analisi chiamate abilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la funzione Call Trace logging è abilitata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Disable Call Tracing

Se Exchange Server Analyzer rileva che il valore Disable Call Tracing del Registro di sistema è presente e configurato con un valore 0, verrà visualizzato un messaggio di configurazione non predefinita.

Se la funzione di registrazione delel chiamate è abilitata, verranno registrati i dati della chiamata della funzione per i processi Store.exe. La funzione di registrazione delel chiamate può provocare una riduzione delle prestazioni del 4%. È consigliabile abilitare questa funzione solo quando è necessaria per la risoluzione di problemi relativi a processi Store.exe lenti o che non rispondono.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Impostare il valore Disable Call Tracing del Registro di sistema su 1. Le chiavi Flush Call Traces , RPC Requests Threshold e Call Tracing Logging Interval non vengono utilizzate quando la funzione di registrazione delel chiamate è disabilitata.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


La profondità del punto di arresto non è impostata correttamente sul cluster
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamCheckpointDepthMax in ogni gruppo di archiviazione. Se Exchange Server Analyzer rileva che il valore di msExchESEParamCheckpointDepthMax non corrisponde a 5.242.880 in un cluster di Exchange 2000 Server, verrà visualizzato un avviso.

L'attributo msExchESEParamCheckpointDepthMax viene impostato in byte e determina la profondità massima del punto di arresto. La profondità del punto di arresto rappresenta la quantità di dati in attesa di essere salvati nell'archivio di Exchange. La profondità massima del punto di arresto è la quantità massima di dati alla volta che possono essere in attesa. Pertanto, se la profondità massima del punto di arresto viene impostata su 20 MB, questa sarà la quantità massima di dati alla volta che possono essere in attesa (ossia, non salvati nell'archivio di Exchange). In un ambiente cluster, un valore più piccolo per questo parametro determina tempi di failover più rapidi. L'esecuzione di test in Exchange Server 2003 ha mostrato che un valore di 5 MB (5.242.880 byte) per questo parametro (invece di 20 MB, che era il valore predefinito in Exchange 2000 Server) determina tempi di failover molto più rapidi, senza influire seriamente sulle prestazioni I/O nel server.

Nei cluster di Exchange 2000 Server, questo valore deve essere sempre impostato su 5.242.880.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti del servizio directory di Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per impostare l'attributo msExchESEParamCheckpointDepthMax mediante ADSI Edit

  1. Eseguire ADSI Edit. ADSI Edit viene fornito con gli strumenti di supporto di Microsoft Windows® 2000 Server e Microsoft Windows Server™ 2003.

  2. Nella struttura della console fare clic con il pulsante destro del mouse su ADSIEdit, selezionare Connetti a, quindi connettersi al contesto dei nomi di configurazione.

  3. Espandere il Contenitore di configurazione, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<OrganizationName>, CN=Administrative Groups, CN=<AdminGroupName>, CN=Servers, CN=<ServerName>, CN=Information Store.

  4. Fare clic con il pulsante destro del mouse su CN=<StorageGroupName>, quindi selezionare Proprietà.

  5. Nell'elenco delle proprietà, selezionare msExchESEParamCheckpointDepthMax.

  6. Fare clic su Modifica e digitare la dimensione che si desidera impostare con incrementi di 5 MB. È necessario immettere il valore in byte. Ad esempio, una profondità del punto di arresto di 5 MB corrisponde a 5.242.880 byte, mentre una profondità del punto di arresto di 10 MB corrisponde a 10.485.760 byte. La dimensione minima che è possibile immettere è 5 MB. Se si immette un valore superiore a 20 MB, si verificherà un incremento nei tempi di failover delle risorse del servizio Archivio informazioni di Microsoft Exchange.

  7. Chiudere ADSIEdit e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sulla distribuzione dei cluster di Exchange 2000 Server, consultare "Deploying Microsoft Exchange 2000 Server Clusters" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=14578 (informazioni in lingua inglese).


Posizionamento del file del punto di arresto
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il percorso del file del punto di arresto (msExchESEParamSystemPath) per ogni gruppo di archiviazione su un server di Exchange corrisponde al percorso del registro delle transazioni (msExchESEParamLogFilePath) per quel gruppo di archiviazione. Se Exchange Server Analyzer rileva che il percorso del file del punto di arresto non corrisponde a quello del registro delle transazioni per il gruppo di archiviazione, verrà visualizzato un messaggio di configurazione ottimale.

Se la posizione del file del punto di arresto non corrisponde alla posizione dei file di registro delle transazioni, è possibile che i tempi di inattività siano estesi quando si verificano errori del disco.

Per modificare la posizione del file del punto di arresto di un gruppo di archiviazione di Exchange per Exchange 2000 Server ed Exchange Server 2003

  1. In Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sul gruppo di archiviazione, quindi selezionare Proprietà.

  2. Nella scheda Generale in Posizione percorso di sistema fare clic su Sfoglia e scegliere una posizione per il file del punto di arresto.
Per modificare la posizione dei file di registro delle transazioni del gruppo di archiviazione di Exchange per Exchange 2000 Server ed Exchange Server 2003

  1. In Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sul gruppo di archiviazione, quindi selezionare Proprietà.

  2. Nella scheda Generale in Posizione registro transazioni fare clic su Sfoglia e scegliere una posizione per i file di registro delle transazioni.
Per modificare la posizione dei file di registro delle transazioni del gruppo di archiviazione di Exchange per Exchange Server 2007

  1. Seguire le istruzioni fornite nella documentazione principale di Exchange Server 2007, "Impostazione o modifica del percorso dei file di registro del gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80702.

Per ulteriori informazioni sulla posizione dei file di registro delle transazioni, consultare l'argomento "Gestione degli archivi di cassette postali e cartelle pubbliche" del Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

Per ulteriori informazioni sul file del punto di arresto, consultare "Transaction Log File Replay: Soft Recovery and Hard Recovery" in Using Exchange Server 2003 Recovery Storage Groups all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47589 (informazioni in lingua inglese).


Registrazione circolare disabilitata su questo server front-end
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-03-27

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore configurato per l'attributo msExchESEParamLogBuffers di registrazione circolare. Se Exchange Server Analyzer rileva che l'attributo è configurato con un valore pari a 0, verrà visualizzato un avviso.

Il valore 1 per l'attributo msExchESEParamCircularLog indica che la registrazione circolare è abilitata. Il valore 0 per l'attributo msExchESEParamCircularLog indica che la registrazione circolare è disabilitata.

Nel registro delle transazioni standard utilizzato da Exchange Server, ciascuna transazione del database in un gruppo di archiviazione viene scritta in un file di registro, quindi nel database. Quando raggiunge una certa dimensione, il file di registro viene rinominato e ne viene creato uno nuovo. In questo modo, con il tempo, si otterrà un set di file di registro. Se si verifica un arresto anomalo, è possibile ripristinare le transazioni riproducendo i dati da tali file di registro nel database.

Mediante la registrazione circolare il primo file di registro viene sovrascritto e riutilizzato dopo che i dati in esso contenuti sono stati scritti nel database. In Exchange Server la registrazione circolare è disabilitata per impostazione predefinita. Abilitandola, vengono ridotti i requisiti di spazio di archiviazione dell'unità, ma senza file di registro delle transazioni completi non sarà possibile ripristinare nessun elemento recente oltre all'ultimo backup completo. Pertanto, su server di produzione che contengono dati di cassette postali o di cartelle pubbliche, non è consigliabile utilizzare la registrazione circolare. Tuttavia, su server front-end di Exchange che non dispongono di cassette postali o cartelle pubbliche, gli unici messaggi salvati sono i rapporti di mancato recapito (NDR). Pertanto, non è necessario conservare i file di transazione per questi server, né eseguire il backup di tali server. L'abilitazione della registrazione circolare su server front-end consente di sovrascrivere i file di registro delle transazioni e di non superare 20 MB di dati.

Per abilitare la registrazione circolare

  1. In Gestore di sistema di Exchange espandere la struttura Server, quindi un server Exchange.

  2. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione su cui si desidera abilitare la registrazione circolare e scegliere Proprietà. Verrà visualizzata la finestra di dialogo delle proprietà del gruppo di archiviazione.

  3. Selezionare la casella di controllo Attiva registrazione circolare e fare clic su OK per salvare le modifiche.

  4. Chiudere Gestore di sistema di Exchange e riavviare l'Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sulla registrazione circolare, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 258470, "XADM: Modifica Impostazioni registrazione circolare" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470.

  • 147524, "XADM: Influenza della registrazione circolare sull'utilizzo dei registri di transazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524.

  • 296788, "Procedure di backup e di ripristino non in linea" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788.

  • 314605, "HOW TO: Attivazione e disattivazione della registrazione circolare in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605.


La registrazione circolare è attiva
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamCircularLog di ogni gruppo di archiviazione presente nel server di Exchange. Il valore 1 indica che la registrazione circolare per il gruppo di archiviazione è attivata. Il valore 2 indica che la registrazione circolare per il gruppo di archiviazione non è attivata. Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore True indica che il computer Exchange Server è un server front-end. Il valore False indica che il computer Exchange Server non è un server front-end.

Se Exchange Server Analyzer rileva che il valore dell'attributo msExchESEParamCircularLog è impostato su 1, che il valore della chiave IsFrontEndServer è impostato su False e che il valore dell'attributo homeMDBBL è maggiore di 20, verrà visualizzato un avviso.

Questa combinazione di valori indica che la registrazione circolare è attivata su un server cassette postali che contiene più di 20 cassette postali. Nel registro delle transazioni standard utilizzato da Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007, ciascuna transazione del database in un gruppo di archiviazione viene scritta in un file di registro, quindi nel database. Quando raggiunge una certa dimensione, il file di registro viene rinominato e ne viene creato uno nuovo. In questo modo, con il tempo, si otterrà un set di file di registro. Se si verifica un arresto anomalo, è possibile ripristinare le transazioni riproducendo i dati da tali file di registro nel database.

Mediante la registrazione circolare il primo file di registro viene sovrascritto e riutilizzato dopo che i dati in esso contenuti sono stati scritti nel database. In Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007, la registrazione circolare è disabilitata per impostazione predefinita. Abilitandola, vengono ridotti i requisiti di spazio di archiviazione dell'unità, ma senza file di registro delle transazioni completi non sarà possibile ripristinare nessun elemento recente oltre all'ultimo backup completo. Pertanto, in un normale ambiente di produzione, non è cosigliabile utilizzare la registrazione circolare.

Per risolvere il problema in Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Server, quindi la struttura del server che si desidera modificare.

  3. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione che si desidera modificare e scegliere Proprietà.

  4. Nella finestra di dialogo Proprietà deselezionare la casella di controllo Attiva registrazione circolare.

  5. Fare clic su OK per salvare le modifiche.

  6. Chiudere Gestore di sistema di Exchange e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per risolvere il problema in Exchange Server 2007 utilizzando Exchange Management Console

  1. Aprire Exchange Management Console.

  2. Espandere Configurazione server e il server che si desidera modificare.

  3. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione che si desidera modificare e scegliere Proprietà.

  4. Nella finestra di dialogo Proprietà deselezionare la casella di controllo Attiva registrazione circolare.

  5. Fare clic su OK per salvare le modifiche.

  6. Chiudere Exchange Management Console e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per risolvere il problema in Exchange Server 2007 utilizzando Exchange Management Shell

  1. Di seguito è riportato del codice di esempio del comando Set-StorageGroup che disabilita la registrazione circolare per il gruppo di archiviazione "MyStorageGroup".
Copia codice
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $false
  • Per ulteriori informazioni sulla registrazione circolare, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 147254, "Effetti della registrazione circolare sull'utilizzo dei registri delle transazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524

  • 240145, "Conoscere quali file del registro delle transazioni possono essere rimossi con sicurezza", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=240145.


La registrazione circolare è disabilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-03-23

Microsoft Exchange Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore configurato per l'attributo msExchESEParamCircularLog.

Il valore 1 per l'attributo msExchESEParamCircularLog indica che la registrazione circolare è abilitata. Il valore 0 per l'attributo msExchESEParamCircularLog indica che la registrazione circolare è abilitata.

Exchange Analyzer determina inoltre se sono presenti le seguenti condizioni:

  • Il server di Exchange è configurato come server front-end.

  • Il servizio SMTP è in esecuzione e determina il numero di cassette postali configurate.

Se Exchange Analyzer rileva la presenza delle seguenti condizioni, verrà visualizzato un avviso:

  • L'attributo msExchESEParamCircularLog è configurato con il valore 0.

  • Il server non è configurato come server front-end.

  • Il numero delle cassette postali configurate è minore di 20.

Nel registro delle transazioni standard utilizzato da Exchange Server, ciascuna transazione del database in un gruppo di archiviazione viene scritta in un file di registro, quindi nel database. Quando raggiunge una certa dimensione, il file di registro viene rinominato e ne viene creato uno nuovo. In questo modo, con il tempo, verrà creato un set di file di registro. Se si verifica un errore di sistema, è possibile ripristinare le transazioni riproducendo i dati da tali file di registro nel database.

Mediante la registrazione circolare il primo file di registro viene sovrascritto e riutilizzato dopo che i dati in esso contenuti sono stati scritti nel database. In Exchange Server la registrazione circolare è disabilitata per impostazione predefinita.

Importante:
Abilitandola, vengono ridotti i requisiti di spazio di archiviazione dell'unità. Tuttavia, se non si dispone di file di registro delle transazioni completi, non sarà possibile ripristinare alcun elemento recente oltre all'ultimo backup completo. Pertanto, su server di produzione che contengono dati di cassette postali o di cartelle pubbliche, non è consigliabile utilizzare la registrazione circolare.

Nel caso di server front-end di Exchange, server di routing dei messaggi, denominati anche server dell'infrastruttura, e server testa di ponte che non dispongono di cassette postali o cartelle pubbliche degli utenti, gli unici messaggi salvati sono rapporti di mancato recapito (NDR). Pertanto, non è necessario conservare i file di transazione per questi server, né eseguirne il backup. L'abilitazione della registrazione circolare sui server che non ospitano cassette postali degli utenti consente di sovrascrivere i file di registro delle transazioni e di non superare 20 MB di dati.

Per abilitare la registrazione circolare in Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, quindi espandere un server di Exchange.

  3. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione su cui si desidera abilitare la registrazione circolare e scegliere Proprietà. Verrà visualizzata la finestra di dialogo delle proprietà del gruppo di archiviazione.

  4. Selezionare la casella di controllo Attiva registrazione circolare e fare clic su OK per salvare le modifiche.

  5. Chiudere Gestore di sistema di Exchange e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.
Per abilitare la registrazione circolare in Exchange Server 2007 utilizzando Exchange Management Console

  1. Aprire Exchange Management Console.

  2. Espandere la struttura Configurazione server, quindi la struttura del server che si desidera modificare.

  3. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione che si desidera modificare e scegliere Proprietà.

  4. Nella finestra di dialogo Proprietà selezionare la casella di controllo Attiva registrazione circolare.

  5. Fare clic su OK per salvare le modifiche.

  6. Chiudere Exchange Management Console e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.
Per abilitare la registrazione circolare in Exchange Server 2007 utilizzando Exchange Management Shell

  1. Il codice seguente è un esempio del comando Set-StorageGroup, che consente la registrazione circolare per il gruppo di archiviazione MyStorageGroup.
Copia codice
Set-StorageGroup -Identity MyStorageGroup -CircularLoggingEnabled $true

Per ulteriori informazioni sulla registrazione circolare, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 258470, "XADM: Modifica Impostazioni registrazione circolare" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=258470.

  • 147524, "XADM: Influenza della registrazione circolare sull'utilizzo dei registri di transazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=147524.

  • 296788, "Procedure di backup e di ripristino non in linea" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788.

  • 314605, "Come attivare e disattivare la registrazione circolare in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314605.


La compressione RPC del client o del server è disabilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la compressione RPC (Remote Procedure Call) è abilitata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Rpc Compression Enabled

Se Exchange Server Analyzer rileva che Rpc Compression Minimum Size è presente e configurato con un valore pari a 0, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, tutti i dati RPC spostati tra Microsoft Office Outlook® 2003 oppure Outlook 2007 ed Exchange Server 2003 o Exchange Server 2007 vengono compressi, indipendentemente dalla loro dimensione. In alcuni scenari, può essere necessario controllare la compressione RPC. Ad esempio, se si tenta di risolvere problemi di connettività visualizzando i pacchetti trasmessi attraverso la rete, la compressione RPC potrebbe rendere difficile l'analisi poiché nella traccia vengono visualizzati solo i dati compressi.

Per configurare le impostazioni della compressione RPC, è possibile aggiungere alle impostazioni di sistema tre valori della chiave del Registro di sistema:

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Il valore Rpc Compression Enabled del Registro di sistema indica se vengono utilizzati gli algoritmi di compressione RPC. Se questa chiave non è presente, verrà abilitata e utilizzata la compressione RPC.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare la chiave Rpc Compression Enabled. Se presenti, eliminare anche le chiavi Rpc Compression Minimum Size e Rpc Packing Enabled.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul controllo della compressione RPC, consultare l'articolo 825371 della Microsoft Knowledge Base "Modifica della compressione RPC (Remote Procedure Call) in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371.


Parametro ClientMonitoringReportLevel non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare le modalità di monitoraggio in Exchange Server 2003 dei dati sulle prestazioni di rete per Microsoft Office Outlook® 2003:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che il valore della chiave del Registro di sistema ClientMonitoringReportLevel non corrisponde a 1, verrà visualizzato un messaggio di configurazione non predefinita.

Exchange Server utilizza il valore della chiave ClientMonitoringReportLevel del Registro di sistema per identificare gli errori della rete e i problemi di ritardo con i client Outlook 2003. Il valore della chiave ClientMonitoringReportLevel del Registro di sistema può essere impostato su tre modalità diverse.

Valore | Funzione
0 | Non vengono raccolti i dati sulle prestazioni da nessun client Outlook 2003.
1 | Vengono raccolti i dati sulle prestazioni solo dai client Outlook 2003 che presentano una connettività di rete a elevata velocità.
2 | Vengono raccolti i dati sulle prestazioni da tutti i client Outlook 2003.

Se si abilita la chiave ClientMonitoringReportLevel del Registro di sistema impostandola sul valore 1 o 2, i client Outlook 2003 invieranno i dati al server. Tali dati inviati al server indicano lo stato della connessione di rete. I dati includono inoltre informazioni sulle richieste RPC (Remote Procedure Call) non riuscite e sulle condizioni dell'errore. Le informazioni vengono aggregate ed elencate sotto forma di voci del registro eventi.

Il programma di installazione di Exchange non consente di creare la chiave ClientMonitoringReportLevel del Registro di sistema. Tuttavia, il comportamento predefinito in Exchange Server 2003 consiste nel raccogliere i dati sulle prestazioni solo dai client Outlook 2003 che presentano una connettività di rete a elevata velocità. Questo comportamento predefinito di Exchange Server 2003 corrisponde a quello della funzione quando la chiave ClientMonitoringReportLevel del Registro di sistema è impostata su 1.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione. Tuttavia, se si desidera ripristinare il valore predefinito, è possibile modificare il valore della chiave ClientMonitoringReportLevel del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Fare doppio clic su ClientMonitoringReportLevel.

  4. Nel campo Dati valore digitare 1 e fare clic su OK.

  5. Chiudere l'editor del Registro di sistema.

Il servizio Archivio informazioni di Microsoft Exchange impiega pochi minuti per rilevare le modifiche. Non è necessario riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Implementazione di quote di archiviazione
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se sono state impostate quote per le cassette postali su ogni oggetto private message database (MDB). Se Exchange Server Analyzer rileva che un particolare database MDB privato contiene più di 20 cassette postali e che non sono state impostate quote sul database in questione, verrà visualizzato un messaggio di configurazione ottimale.

Si consiglia di applicare le quote a tutti i database su computer Exchange Server che ospitano cassette postali degli utenti. È necessario impostare tre limiti a livello di database. I limiti possono essere impostati nella scheda Limiti nella pagina delle proprietà dell'archivio delle cassette postali. Ogni limite è espresso in kilobyte (KB).

  • Avviso Il limite Issue warning definisce la dimensione delle cassette postali che genera un messaggio di posta elettronica di avviso per l'utente. Tale messaggio di avviso indica all'utente che sta per essere raggiunto il limite di dimensione delle cassette postali Prohibit send.

  • Impedisci invio Il limite Prohibit send definisce la dimensione delle cassette postali oltre la quale non è consentito l'invio dei messaggi di posta elettronica. L'utente riceverà un messaggio di posta elettronica dal server di Exchange indicante il superamento del limite di dimensione delle cassette postali.

  • Impedisci l'invio e la ricezione Il limite Prohibit send and receive definisce la dimensione delle cassette postali oltre la quale non sono consentiti l'invio e la ricezione dei messaggi di posta elettronica. Tutta la posta inviata all'utente verrà restituita al mittente con un rapporto di mancato recapito (NDR, Non-Delivery Report).

Dopo aver impostato queste regole, assicurarsi di fornire un delta sufficientemente ampio tra il limite Impedisci invio e il limite Impedisci l'invio e la ricezione. Se il delta è troppo piccolo, è possibile che i messaggi vengano rifiutati dalla cassetta postale prima che l'utente possa eseguirne la pulitura. Quindi, è consigliabile fornire come minimo un buffer del 20% tra il limite Impedisci invio e il limite Impedisci l'invio e la ricezione. Ad esempio, se agli utenti non è consentito l'invio di nuovi messaggi quando la dimensione della cassetta postale raggiunge 100 MB, il limite Impedisci l'invio e la ricezione dovrebbe essere almeno 120 MB.

Per impostare i limiti delle cassette postali in Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Individuare l'archivio delle cassette postali visualizzato in Exchange Server Analyzer in relazione a questo problema.

  3. Fare clic con il pulsante destro del mouse su MailboxStore_Name e selezionare Proprietà.

  4. Selezionare la scheda Limiti.

  5. Modificare Invia avviso a (KB), il limite Impedisci l'invio a (KB) e il limite Impedisci l'invio e la ricezione a (KB).

  6. Fare clic su Applica, quindi su OK.
Per impostare i limiti delle cassette postali in Exchange Server 2007 utilizzando Exchange Management Console

  1. Aprire Exchange Management Console.

  2. Individuare l'archivio delle cassette postali visualizzato in Exchange Server Analyzer in relazione a questo problema.

  3. Fare clic con il pulsante destro del mouse su MailboxStore_Name e selezionare Proprietà.

  4. Selezionare la scheda Limiti.

  5. Modificare Invia avviso a (KB), il limite Impedisci l'invio a (KB) e il limite Impedisci l'invio e la ricezione a (KB).

  6. Fare clic su Applica, quindi su OK.
Per impostare i limiti delle cassette postali in Exchange Server 2007 utilizzando Exchange Management Shell

  1. Nell'esempio seguente viene illustrato come impostare il limite di dimensione delle cassette postali al cui raggiungimento l'utente riceve un messaggio di avviso. Questo attributo si applica a tutte le cassette postali del database in questione per le quali non è impostato l'attributo delle quote di avviso. È necessario specificare un valore intero o "illimitato". Il valore predefinito è 1,9 gigabyte (GB).

    Copia codice
    Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680

  2. Nell'esempio seguente viene illustrato come impostare la dimensione delle cassette postali al cui raggiungimento gli utenti associati alle cassette postali nel relativo database non possono più inviare messaggi. Questo attributo si applica a tutte le cassette postali del database in questione per le quali non sono impostati gli attributi delle quote per impedire l'invio di messaggi. È necessario specificare un valore intero o "illimitato".

    Copia codice
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152

  3. Nell'esempio seguente viene illustrato come impostare la dimensione delle cassette postali al cui raggiungimento gli utenti associati alle cassette postali non possono più inviare e ricevere messaggi. Questo attributo si applica a tutte le cassette postali del database in questione per le quali non sono impostati gli attributi delle quote per impedire l'invio e la ricezione di messaggi. È necessario specificare un valore intero o "illimitato".

    Copia codice
    Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Per ulteriori informazioni sulla gestione delle cassette postali di Exchange in Exchange Server 2003, vedere Utilizzo degli archivi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.

Per ulteriori informazioni su come gestire i limiti delle cassette postali di Exchange in Exchange Server 2007, vedere "Come configurare i limiti e le proprietà del database" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80746.


Indicizzazione dei contenuti abilitata nell'archivio delle cassette postali
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo Content Indexing Rebuild Schedule (msExchCIRebuildSchedule) è stato impostato su un valore non null e se è stato impostato l'attributo Content Indexing Rebuild Style (msExchCIRebuildStyle). Questi attributi sono specifici di ciascun database di cassette postali private. Se Exchange Server Analyzer rileva che entrambi gli attributi sono configurati per l'indicizzazione, verrà visualizzato un avviso.

Non è consigliabile eseguire l'indicizzazione del contenuto, nota anche come "indicizzazione di testo completo", su un archivio delle cassette postali dal momento che l'indicizzazione del testo completo richiede un utilizzo intensivo delle risorse e i dati delle cassette postali cambiano frequentemente. Pertanto, mantenere aggiornato l'indice di un determinato database è un processo che richiede un utilizzo intensivo delle risorse. L'indicizzazione del testo completo è più adatta alle cartelle pubbliche.

Se si desidera eseguire l'indicizzazione del testo completo in un archivio delle cassette postali, è consigliabile impostare la pianificazione dell'indicizzazione in modo da eseguire frequentemente aggiornamenti e monitorare le prestazioni del computer per assicurarsi che il computer non sia sovraccarico e sia in grado di recapitare la posta e rispondere alle richieste del client durante l'indicizzazione del contenuto.

In caso contrario, è consigliabile disabilitare l'indicizzazione di testo completo eliminando l'indice di testo completo nell'archivio delle cassette postali.

Per disabilitare l'indicizzazione di testo completo in un determinato archivio delle cassette postali

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Gruppi amministrativi, il proprio gruppo amministrativo, Server, il proprio server, il proprio gruppo di archiviazione, fare clic con il pulsante destro del mouse su Archivio cassette postali, quindi su Elimina indice di testo completo.

Per ulteriori informazioni sulla configurazione e la risoluzione dei problemi di indicizzazione di testo completo in Exchange, consultare l'articolo della Microsoft Knowledge Base "HOW TO: Configurazione dell'indicizzazione di testo completo negli archivi di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=3052&kbid=822932.


Indicizzazione dei contenuti abilitata nell'archivio delle cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se gli attributi Content Indexing Rebuild Schedule (msExchCIRebuildSchedule) e Content Indexing Rebuild Style (msExchCIRebuildStyle) sono presenti e impostati su un valore diverso da 0. Questi attributi sono presenti in ogni database dell'Archivio informazioni pubblico.

Se Exchange Server Analyzer rileva che entrambi gli attributi sono presenti e impostati su un valore diverso da 0, verrà visualizzato un messaggio di configurazione non predefinita.

Se entrambi gli attributi sono impostati su 1, significa che nel database dell'archivio informazioni è stata abilitata l'indicizzazione di testo completo. Tale indicizzazione consente ricerche rapide ed efficaci in quanto ogni parola viene indicizzata in un database specifico. Con l'indicizzazione di testo completo, si seleziona anche una cartella pubblica individuale o un archivio delle cassette postali da indicizzare. Quindi è possibile eseguire ricerche di testo completo sui messaggi e sugli allegati contenuti nell'archivio delle cartelle pubbliche e nell'archivio delle cassette postali.

Per impostazione predefinita nell'indice sono contenuti l'oggetto e il corpo del messaggio, i nomi del mittente, del destinatario e tutti i nomi contenuti nei campi Cc e Ccn. L'indice comprende, inoltre, il testo dei seguenti tipi di allegati: file con estensione DOC, XLS, PPT, HTML, HTM, ASP, TXT e EML (messaggi MIME incorporati). Non sono indicizzati, invece, gli allegati binari quali immagini e audio.

L'accuratezza dei risultati delle ricerche dipende dall'ultimo aggiornamento dell'indice. Quando vengono modificati i contenuti delle cartelle pubbliche o degli archivi di cassette postali, è necessario aggiornare l'indice. È possibile aggiornare l'indice manualmente o automaticamente secondo la pianificazione impostata.

Sono disponibili quattro categorie principali di file di indicizzazione di testo completo. È possibile ottimizzare le prestazioni dell'indicizzazione di testo completo posizionando i file sul disco come indicato di seguito:

  • CataloghiI cataloghi rappresentano gli indici principali. Può essere presente un catalogo per ogni archivio di Exchange. Posizionare il catalogo su un array RAID-0+1. È possibile specificare la posizione del catalogo in Gestore di sistema di Exchange durante la creazione del catalogo.

  • Archivio proprietàDatabase contenente varie proprietà di voci indicizzate nel catalogo. È disponibile solo un archivio proprietà per server. Posizionare l'archivio proprietà su un array RAID. Per impostazione predefinita i file vengono installati nella stessa unità di Exchange Server.

  • File temporaneiQuesti file contengono informazioni temporanee utilizzate dal servizio Microsoft Search. Posizionare la directory temporanea dell'indice di testo completo su un array RAID. Per impostazione predefinita questi file vengono installati nell'unità di sistema, che normalmente non presenta il throughput dell'I/O dell'array RAID.

  • Registri GathererQuesti file contengono informazioni di registro per il servizio di indicizzazione. È presente un set di registri per ogni catalogo. È possibile lasciare i registri Gatherer nella posizione predefinita oppure spostarli.

Per abilitare o disabilitare l'indicizzazione di testo completo

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, quindi il gruppo di archiviazione contenente l'archivio delle cartelle pubbliche di lavoro in uso.

  3. Fare clic con il pulsante destro del mouse sull'archivio delle cartelle pubbliche e selezionare Proprietà.

  4. Selezionare la scheda Indicizzazione di testo completo.

  5. Modificare il campo Intervallo di aggiornamento.

  6. Fare clic su OK per salvare le modifiche e chiudere le proprietà dell'archivio della cartella pubblica.

Per ulteriori informazioni su come eseguire l'indicizzazione di testo completo nelle cartelle pubbliche, consultare l'articolo 319433 della Microsoft Knowledge Base: "HOW TO: Configurazione dell'indicizzazione di testo completo nelle cartelle pubbliche in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319433.

Per ulteriori informazioni sulla configurazione e sulla risoluzione dei problemi relativi all'indicizzazione di testo completo degli archivi di cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822932, "HOW TO: Configurazione dell'indicizzazione di testo completo negli archivi di cassette postali in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822932.

  • 319436, "HOW TO: Configurazione dell'indicizzazione di testo completo negli archivi di cassette postali in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319436.

Per informazioni sull'indicizzazione di testo completo in un ambiente multilingue, consultare l'articolo 325624 della Microsoft Knowledge Base, "XGEN: Indicizzazione di testo completo con più lingue" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325624.

Per ulteriori informazioni ssulla configurazione ottimale dell'indicizzazione di testo compelto, consultare l'articolo 326186 della Microsoft Knowledge Base, "XADM: White Paper - Raccomandazioni per la distribuzione delle indicizzazioni di testo completo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=326186.


DSN attualmente rappresentati come messaggi
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le notifiche sullo stato del recapito (DSNs) sui computer Exchange Server vengono rappresentate come messaggi standard:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\RenderDSNsAsMessages

Se Exchange Server Analyzer rileva che la voce del Registro di sistema RenderDSNsAsMessages configurata con un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Come indicato dal nome, la voce del Registro di sistema RenderDSNsAsMessages è un'opzione di configurazione che consente agli amministratori di controllare come vengono rappresentate le notifiche sullo stato del recapito (DSN) sui computer Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007:

  • Se i dati relativi al valore per RenderDSNsAsMessages sono impostati su 0, le DSN (che includono rapporti di recapito e di mancato recapito) vengono rappresentate come messaggi MAPI standard.

  • Se i dati relativi al valore per RenderDSNsAsMessages vengono impostati su un valore maggiore di 0, le DSN vengono rappresentate come messaggi MIME multiparte/misti.

Questo valore del Registro di sistema non è presente per impostazione predefinita e deve essere aggiunto manualmente per essere utilizzato. Inoltre, se si desidera che la voce abbia l'effetto desiderato su Exchange 2000 Server, il computer deve eseguire almeno la patch cumulativa successiva al Service Pack 3 per Exchange 2000 Server del settembre 2003.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Eliminare il valore RenderDSNsAsMessages del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.
  • Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, vedere l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

  • Per ulteriori informazioni su problemi relativi al formato delle notifiche sullo stato del recapito, vedere l'articolo 812806 della Microsoft Knowledge Base "Ricezione non prevista di un NDR standard invece di un NDR personalizzato" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=812806.

  • Per ulteriori informazioni sulla patch cumulativa successiva al Service Pack 3 per Exchange 2000 Server, consultare l'articolo 824282 della Microsoft Knowledge Base "Patch cumulativa successiva al Service Pack 3 per Exchange 2000 Server del settembre 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824282.


L'intervallo Aging Keep Time del database è stato modificato rispetto all'impostazione predefinita
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore di durata predefinito per gli indici del database di visualizzazione del client Exchange sono stati sostituiti:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nome server>\Private-<GUID di archivio informazioni privato>\Aging Keep Time

Se Exchange Server Analyzer rileva che la voce Aging Keep Time del Registro di sistema è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Gli indici utilizzati per visualizzazioni create nelle tabelle di database Exchange da un client Exchange inutilizzato per un dato periodo vengono eliminati. Le voci del Registo di sistema seguenti vengono utilizzate per controllare la durata dell'indice:

  • Aging Keep Time La durata minima dell'indice prima che venga eliminato. L'impostazione predefinita è 8 giorni per Exchange Server 5.5 e 40 giorni per Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007.

  • Aging Clean Interval L'intervallo di tempo minimo (in millisecondi) tra l'esecuzione di un'attività di durata dell'indice e l'altra. L'impostazione predefinita è 24 ore.

  • Reset Views Se questa impostazione esiste ed è diversa da zero impone l'eliminazione di tutti gli indici memorizzati nella cache durante l'esecuzione dell'attività di durata dell'indice successiva. Al termine della durata dell'indice, il valore Reset Views è impostato su 0.

Si consiglia di non aggiungere il valore del Registro di sistema Aging Keep Time a meno che non venga chiaramente indicato dal Servizio Supporto Tecnico Clienti Microsoft.

Importante:
Questo articolo contiene informazioni sulla modifica al Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per visualizzare o modificare il valore Aging Keep Time del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome server>\Private-<GUID di archivio informazioni privato>

  3. Esaminare ed eventualmente modificare il valore di Aging Keep Time.

  4. Chiudere l'editor del Registro di sistema. Se viene apportata una modifica, riavviare il computer sul quale è eseguito Exchange Server per renderla effettiva.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Database e file di registro si trovano sullo stesso volume disco
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se i file di database per l'archivio delle cassette postali risiedono sullo stesso disco fisico dei file del registro delle transazioni per questo gruppo di archiviazione. Nello specifico, Exchange Server Analyzer esegue una query in Active Directory per determinare quanto segue:

  • Se l'archivio delle cassette postali contiene più di 100 cassette postali. L'informazione viene determinata contando i valori dell'attributo homeMDBBL dell'oggetto archivio delle cassette postali (classe msExchPrivateMDB). Se l'archivio delle cassette postali include meno di 100 cassette postali, l'impatto della posizione dei file sulle prestazioni sarà limitato.

  • Il percorso dei file di database per l'archivio delle cassette postali. L'informazione viene determinata dalla lettura del valore di msExchEDBFile dell'oggetto archivio delle cassette postali.

  • Il percorso dei file del registro delle transazioni per il gruppo di archiviazione. L'informazione viene determinata dalla lettura del valore di msExchESEParamLogFilePath per l'oggetto gruppo di archiviazione (classe msExchStorageGroup).

  • Se il percorso indicato in msExchESEParamLogFilePath si trova sullo stesso disco del percorso indicato in msExchEDBFile.

Inoltre, Exchange Server Analyzer determina quanto segue:

  • Se le estensioni di Exchange Server per NAS basati su Windows sono in esecuzione sul server. L'informazione viene determinata tramite una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per il valore dell'attributo Started per le estensioni NAS di Exchange Server (wssexchmap). Se le estensioni di Exchange Server per NAS basati su Windows sono in esecuzione, significa che i file presi in esame possono non trovarsi su un'unità locale e le considerazioni sulle prestazioni potrebbero non essere applicabili.

  • Se i file si trovano su un volume disco con un nome più lungo di tre caratteri. L'informazione viene determinata tramite una query nella classe WMI (Strumentazione gestione Windows®) Win32_Volume. Di nuovo, questo significa che i file possono non trovarsi su un'unità locale e le considerazioni sulle prestazioni potrebbero non essere applicabili.

Per fornire la tolleranza dell'errore in caso di un errore del disco rigido, mantenere i file del registro delle transazioni e i file di database di Exchange su dischi rigidi separati. Se si mantengono i file di registro e di database su dischi rigidi separati, è possibile migliorare in modo significativo le prestazioni I/O del disco rigido.

Nota:
Per fornire la tolleranza d'errore nel caso in cui sia necessario ripristinare un database, ogni gruppo di archiviazione dispone del proprio set di file del registro delle transazioni. Nei file del registro delle transazioni è conservato il record di ogni modifica apportata a ogni database in tale gruppo di archiviazione. I file del registro delle transazioni non vengono eliminati fino a quando non viene eseguito un backup completo di tutti i database in un gruppo di archiviazione.

Negli esempi che seguono viene illustrato come eseguire il recupero dei dati anche in circostanze estreme, quali la perdita del disco rigido che contiene i file del database o i file del registro delle transazioni, se si dispone di una copia di backup e i file del registro delle transazioni si trovano su un disco separato.

  • Se si verifica un errore del disco rigido che contiene i file del database, è possibile sostituire il disco rigido con l'errore, ripristinare il backup più recente dei file di database e utilizzare i file di registro correnti archiviati su un disco rigido separato per ripristinare i dati sul server di Exchange e aggiornarlo al momento in cui si è verificato l'errore del disco rigido.

  • Se si verifica un errore del disco rigido che contiene i registri delle transazioni ma il disco rigido che contiene i file del database funziona e il file di archiviazione del database viene chiuso normalmente, è possibile riparare il disco del registro delle transazioni e reinstallare l'archivio di database. Se il file dell'archivio di database non viene chiuso normalmente, resterà in uno stato incoerente e potrà essere reinstallato solo dopo una riparazione estrema eseguita tramite eseutil.exe, che potrebbe provocare la perdita di alcuni dati. L'altra opzione prevede il ripristino del file dell'archivio di database dal backup, che non includerà nuovi dati della cassetta postale creati dopo il backup.

Importante:
Se si conservano i file di database e del registro delle transazioni di Exchange sullo stesso disco rigido fisico e si verifica un errore di tale disco, i dati creati dopo l'ultimo backup andranno persi.

Inoltre, se si salvano i file di database e i file del registro delle transazioni su dischi fisici separati, migliorano le prestazioni generali. Con Exchange ogni transazione viene prima scritta nel registro delle transazioni, quindi nel file di database. Inoltre, i file del registro delle transazioni vengono condivisi da tutti gli archivi cassette postali nel gruppo di archiviazione. Quando questi file si trovano sullo stesso disco fisico, la testina dell'unità deve spostarsi avanti e indietro tra la posizione del file del registro delle transazioni corrente e le posizioni dei file di database per completare le operazioni di scrittura. Quando i file si trovano su dischi separati, una testina dell'unità resta in posizione per scrivere nel file del registro delle transazioni, in modo che le transazioni possano essere completate più velocemente rispetto a quando i file si trovano su un unico disco. La differenza di prestazioni per una singola transazione è limitata, ma può diventare notevole quando si ha un elevato carico del sistema.

Per correggere la configurazione, è possibile spostare i file del registro delle transazioni oppure i file di database.

Per spostare i file di registro delle transazioni in una nuova unità in Exchange 2000 Server o Exchange Server 2003

  1. In Gestore di sistema di Microsoft Exchange espandere l'oggetto server di Exchange appropriato, fare clic con il pulsante destro del mouse sul gruppo di archiviazione desiderato e scegliere Proprietà.

  2. Nella scheda Generale specificare una nuova posizione per i file.

    Ad esempio, se l'unità E:\ deve contenere solo file di registro per questo gruppo di archiviazione, in Posizione registro transazioni fare clic su Sfoglia e scegliere l'unità E:\.

Per modificare la posizione dei file di registro delle transazioni di un gruppo di archiviazione di Exchange in Exchange Server 2007

  1. Seguire le istruzioni fornite nella documentazione principale di Exchange Server 2007, "Impostazione o modifica del percorso dei file di registro del gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80702.

Per spostare i file di database in una nuova unità in Exchange 2000 Server o Exchange Server 2003

  1. In Gestore di sistema di Microsoft Exchange espandere l'oggetto server di Exchange in cui si trova l'archivio, espandere il contenitore del gruppo di archiviazione appropriato, fare clic con il pulsante destro del mouse sull'oggetto archivio delle cassette postali desiderato quindi scegliere Proprietà.

  2. Specificare le nuove posizioni dei file nella scheda Database della finestra di dialogo Proprietà.
Attenzione
Per spostare un file di database, è necessario disinstallare momentaneamente il database e reinstallarlo. Questa operazione viene eseguita automaticamente dalla procedura guidata, ma durante il processo nessun utente può accedere al database.

Per spostare i file di database in una nuova unità in Exchange Server 2007 usando la procedura guidata Sposta percorso database

  1. Avviare Exchange Management Console sul server sul quale si trova il gruppo di archiviazione.

  2. Nella struttura della console espandere Configurazione server e fare clic su Cassetta postale.

  3. Nel riquadro dei risultati, espandere il contenitore del gruppo di archiviazione appropriato, fare clic con il pulsante destro del mouse sull'oggetto database delle cassette postali desiderato e scegliere Sposta percorso database. Verrà visualizzata la procedura guidata Sposta percorso database.

  4. Nella pagina di introduzione, nella casella Percorso file database viene visualizzato il percorso in cui sono attualmente archiviati i file di database. Scegliere Sfoglia per specificare il percorso in cui spostare i file.

  5. Fare clic su Sposta.

  6. Nella pagina di completamento, verificare che il percorso dei file di database sia stato modificato correttamente. Lo stato Completato indica che l'operazione è stata completata correttamente. Lo stato Non riuscito indica che l'operazione non è stata completata correttamente. Se l'operazione non riesce, ricercare una spiegazione nel riepilogo, quindi scegliere Indietro per apportare modifiche alla configurazione. Scegliere Fine per completare la procedura guidata Sposta percorso database.
Nota:
Per spostare i file di database in Exchange Server 2007 è anche possibile utilizzare Exchange Management Shell. Per ulteriori informazioni, vedere Move- DatabasePath.

Per ulteriori informazioni sui file di database di Exchange Server, consultare i seguenti argomenti:

  • "Gestione degli archivi di cassette postali e cartelle pubbliche", nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

  • "Understanding the Exchange Server 2003 Store" in Working with Exchange Server 2003 Stores all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).

Per ulteriori informazioni sulla gestione dei file di database di Exchange Server, consultare l'articolo 328794 della Microsoft Knowledge Base "Protezione dei dati di Exchange da errori del disco rigido" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328794.

Per ulteriori informazioni sulla riparazione estrema degli archivi di database di Exchange, consultare l'articolo 296788 della Microsoft Knowledge Base "Procedure di backup e di ripristino non in linea" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296788.

Per ulteriori informazioni sull'esecuzione di una riparazione estrema in un file dell'archivio di database di Exchange, consultare l'articolo 810190 della Microsoft Knowledge Base "XADM: Registrazione del messaggio di errore 'Interruzione anomala dell'archivio informazioni' e dell'ID evento 447" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810190.


Nel database sono presenti tutti i file di registro
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che tutti i file di registro necessari per eseguire il recupero del database sono presenti e archiviati nel percorso corretto. Pertanto, l'errore nella procedura di recupero non è provocato dalla mancanza o dalla mancata corrispondenza di un file di registro delle transazioni.

È probabile che i database o i file di registro delle transazioni siano danneggiati o che altri file interferiscano con il processo di recupero.

Per risolvere il problema

  • Utilizzare il Gestore di sistema di Exchange per installare uno dei database nel gruppo di archiviazione e visualizzare il registro applicazione per individuare gli errori che potrebbero indicare la causa del problema.

  • Ripristinare il database in isolamento. Al termine dell'analisi del database, verranno visualizzate le istruzioni per il recupero del database in isolamento.

  • Eseguire Eseutil.exe /ML per verificare l'integrità dei file di registro necessari. Per ulteriori informazioni sull'utilizzo di Eseutil, consultare l'articolo 248122 della Microsoft Knowledge Base "How to use Eseutil to test transaction log files for damage in Exchange 2000 Server and in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915 (informazioni in lingua inglese).


Il database è nello stato di chiusura normale
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che il database di Exchange corrente è nello stato di chiusura normale.

Se un database si trova nello stato di chiusura normale, significa che è stato chiuso correttamente e scollegato dal flusso dei file di registro. Di conseguenza, se si desidera reinstallarlo, probabilmente non sarà necessario eseguire alcuna operazione di ripristino.

Se non si riesce a installare un database che si trova nello stato di chiusura normale, il problema non è da ascrivere al fatto che il database richiede un'ulteriore esecuzione dei file di registro delle transazioni. Tuttavia, è possibile che una riesecuzione del registro delle transazioni necessaria per altri database all'interno dello stesso gruppo di archiviazione impedisca l'installazione di un database nello stato di chiusura normale. Per poter installare un database in un gruppo di archiviazione di Exchange, è necessario prima che tutti i database appartenenti allo stesso gruppo siano ripristinati e posti in uno stato che ne consenta l'installazione.

È possibile installare un database nello stato di chiusura normale con i precedenti registri delle transazioni o con una serie di registri differente. Se si installa un database che si trova nello stato di chiusura normale e non esistono registri delle transazioni, verrà generata una nuova serie di registri.

Nota:
In genere, anche se tutti i database di un gruppo di archiviazione sono nello stato di chiusura normale, è preferibile non eliminare file di registro delle transazioni esistenti. In caso contrario, non sarà possibile eseguire il roll forward di backup precedenti. Tuttavia, qualora i database di un gruppo di archiviazione siano tutti nello stato di chiusura normale, l'eventuale eliminazione di file di registro delle transazioni esistenti non interesserà i database correnti. Se si eliminano tutti i file di registro delle transazioni di un dato gruppo di archiviazione, si consiglia di creare immediatamente un backup completo di tutti i database all'interno del gruppo.


Il database è nello stato di arresto anomalo e non è necessario alcun registro
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-08-10

Microsoft® Exchange Server Analyzer Tool ha determinato che il database è nello stato di arresto anomalo.

Per definizione, un database in stato di arresto anomalo richiede la riproduzione di almeno un file di registro delle transazioni. Lo stato di arresto anomalo non è uno stato installabile e non dovrebbe verificarsi durante il funzionamento generale.

Per risolvere il problema

  • Per un'analisi avanzata del database e dei file di registro contattare il Supporto tecnico Microsoft all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=31845.


Stato del database sconosciuto
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che il database è in uno stato sconosciuto. In genere, i database devono essere nello stato di chiusura normale o di arresto anomalo. In Exchange 2000 Server e nelle versioni precedenti, questi stati vengono denominati rispettivamente coerente e incoerente.

Per risolvere il problema

  • Per un'analisi avanzata dello stato del database, ricorrere a Guida in linea e supporto tecnico all'indirizzo http://go.microsoft.com/fwlink/?LinkId=31845.


Il database manca dei file di registro necessari e facoltativi
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha determinato che i file di registro necessari per ripristinare il database non si trovano nella cartella dei file di registro. Se manca uno dei file di registro necessari, non sarà possibile ripristinare il database fino a quando il file in questione non verrà trovato.

Se un database di Exchange non è stato chiuso correttamente, ci saranno sempre file di registro da riprodurre perché il database possa essere nuovamente installato. Nella migliore delle ipotesi il file di registro da riprodurre è uno solo ma, in genere, l'operazione riguarda diversi file.

Oltre ai file di registro necessari, possono esistere file di registro aggiuntivi riproducibili nel database. Sebbene non sia necessario riprodurli per poter installare il database, questi file di registro facoltativi possono essere utilizzati per recuperare ulteriori dati. La mancata riproduzione dei file causerà la perdita di tutti i dati in essi contenuti.

Per risolvere il problema

  • Individuare i file di registro delle transazioni mancanti e aggiungerli alla cartella appropriata.

  • Se non è possibile individuare tutti i file di registro facoltativi, è possibile ripristinare il database in isolamento, con i soli file di registro necessari. Per ripristinare il database senza i file di registro facoltativi, seguire le istruzioni presenti in Exchange Server Analyzer. È importante ricordare che se si ripristina il database senza i file di registro facoltativi, i dati in essi contenuti andranno persi.

    Tuttavia, a seconda del file di registro mancante, è possibile riprodurre nel database alcuni dei file di registro facoltativi. Si prenda, ad esempio, il seguente scenario. I file di registro disponibili sono numerati da uno a dieci. Il decimo è necessario, gli altri sono facoltativi e il sesto manca. In questo caso, sarà possibile riprodurre i file di registro da sette a dieci, poiché l'ordine sequenziale fino al file necessario è costante.

  • Ripristinare il database corrente.

    Nota:
    Sebbene sia probabile, non è garantito che il ripristino del database abbia esito positivo. Anche un ripristino riuscito può causare una perdita, considerevole o minima, di dati. Per ulteriori informazioni sul ripristino dei database di Exchange, vedere l'articolo 812357 della Microsoft Knowledge Base "Manutenzione dei database di Exchange dopo il ripristino mediante lo strumento Eseutil /p di Exchange Server 5.5, Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357.

  • Implementare una strategia ibrida che includa riparazione e ripristino del database. Talvolta, può essere ripristinato anche un database su cui non è possibile eseguire il roll forward con file di registro aggiuntivi. In questi casi, è possibile ripristinare una copia precedente del database mentre si ripara la copia corrente non installabile. È possibile unire il contenuto dei database per salvare la quantità massima di dati. Si tratta di una strategia avanzata per la cui implementazione è possibile ricorrere a Guida in linea e supporto tecnico, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=31845. Per ulteriori informazioni su questa strategia, vedere Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (informazioni in lingua inglese).


Nel database mancano file di registro opzionali ma non file di registro richiesti
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft Exchange Server Analyzer Tool ha rilevato che uno dei database utilizzati non è stato chiuso correttamente.

In questi casi vi sono sempre dei file di registro che è necessario riprodurre nel database prima che quest'ultimo possa essere nuovamente installato. Come minimo vi è un solo file di registro che deve essere riprodotto. In genere, tuttavia, il file di registro da riprodurre sono numerosi.

Oltre ai file di registro richiesti, è possibile riprodurre nel database file di registro aggiuntivi. Questi file di registro opzionali non sono necessari per poter installare nuovamente il database, ma possono essere utilizzati per recuperare dati aggiuntivi. Se i file di registro opzionali non vengono riprodotti, tutti i dati contenuti in tali file andranno persi.

Per risolvere il problema

  • Individuare i file di registro opzionali mancanti e copiarli nella cartella del registro delle transazioni.

  • Se non è possibile individuare tutti i file di registro opzionali, è possibile ripristinare il database in isolamento con i soli file di registro richiesti. Per ripristinare il database senza i file di registro opzionali, seguire le istruzioni in Exchange Server Analyzer. Se si ripristina il database senza i file di registro opzionali, i dati contenuti in tali file andranno persi.

    Tuttavia, a seconda dei file di registro mancanti, è possibile riprodurre nel database alcuni dei file di registro opzionali. Si consideri, ad esempio, il seguente scenario. I file di registro sono numerati da uno a dieci. È richiesto il decimo file (i file restanti sono opzionali), il sesto file di registro è mancante. In questo caso è comunque possibile riprodurre i file di registro numerati da sette a dieci, poiché l'ordine sequenziale fino al file desiderato è costante.


Il database manca dei file di registro necessari
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha determinato che i file di registro necessari per ripristinare il database non si trovano nella cartella dei file di registro. Se manca uno dei file di registro necessari, non sarà possibile ripristinare il database fino a quando il file in questione non verrà trovato.

Per risolvere il problema

  • Individuare i file di registro delle transazioni mancanti e aggiungerli alla cartella appropriata.

  • Ripristinare il database dal backup. Eseguire quindi il roll forward del database riproducendo gli altri file di registro delle transazioni.

    Importante:
    I dati presenti nel file di registro mancante e nei successivi file di registro andranno persi. Prima di ripristinare un database dal backup, è consigliabile salvare una copia del database corrente. Se il ripristino ha esito negativo, sarà così possibile ripristinare il database corrente.

  • Ripristinare il database corrente.

    Nota:
    Sebbene sia probabile, non è garantito che il ripristino del database abbia esito positivo. Anche un ripristino riuscito può causare una perdita, considerevole o minima, di dati. Per ulteriori informazioni sul ripristino dei database di Exchange, vedere l'articolo 812357 della Microsoft Knowledge Base "Manutenzione dei database di Exchange dopo il ripristino mediante lo strumento Eseutil /p di Exchange Server 5.5, Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357.

  • Implementare una strategia ibrida che includa riparazione e ripristino del database. Talvolta, può essere ripristinato anche un database su cui non è possibile eseguire il roll forward con file di registro aggiuntivi. In questi casi, è possibile ripristinare una copia precedente del database mentre si ripara la copia corrente non installabile. È possibile unire il contenuto dei database per salvare la quantità massima di dati. Si tratta di una strategia avanzata per la cui implementazione è possibile ricorrere a Guida in linea e supporto tecnico, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=31845. Per ulteriori informazioni su questa strategia, vedere Using Recovery Storage Groups in Exchange Server 2003 (http://go.microsoft.com/fwlink/?LinkId=47589) (informazioni in lingua inglese).


I database di questo gruppo di archiviazione sono impostati su zero pagine durante il backup
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamZeroDatabaseDuringBackup di ogni gruppo di archiviazione presente nel server. Se Exchange Server Analyzer rileva che l'attributo msExchESEParamZeroDatabaseDuringBackup è stato impostato sul valore 1, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchESEParamZeroDatabaseDuringBackup rappresenta un'impostazione di configurazione che consente la sostituzione di record eliminati/valori lunghi con zero durante il backup. Questo processo è noto come azzeramento. È possibile controllare l'azzeramento delle pagine di database al livello del gruppo di archiviazione. Ciascun gruppo di archiviazione può presentare un criterio diverso per l'azzeramento delle pagine di database eliminate.

Per impostazione predefinita, l'azzeramento è disabilitato e il valore dell'attributo msExchESEParamZeroDatabaseDuringBackup è impostato su 0. Quando l'attributo è impostato su 1, le pagine di database eliminate verranno sostituite con altri caratteri al termine dei backup in linea di tutti i database del gruppo di archiviazione.

È possibile abilitare o disabilitare l'azzeramento per Exchange 2000 Server ed Exchange Server 2003 utilizzando il Gestore di sistema di Exchange, come illustrato nel presente articolo. L'articolo spiega inoltre che l'abilitazione e la disabilitazione dell'azzeramento per Exchange Server 2007 possono essere effettuate mediante Exchange Management Shell. Oltre a offrire maggiore protezione, questa opzione influisce sulle prestazioni del server.

Nota Se si abilita l'azzeramento su un computer che esegue Exchange 2000 Server, si consiglia di installare Exchange 2000 Server Service Pack 3 o una versione successiva. Il Service Pack 3 risolve un problema noto che può provocare l'interruzione di risposta da parte dell'Archivio informazioni di Exchange. Per ulteriori informazioni su questo problema, consultare l'articolo 320883 della Microsoft Knowledge Base "XADM: L'Archivio informazioni non risponde durante un backup in linea se è attivato l'azzeramento del database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320883.

Per abilitare o disabilitare l'azzeramento per Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Server, quindi la struttura del server che si desidera modificare.

  3. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione che si desidera modificare e scegliere Proprietà.

  4. Nella finestra di dialogo Proprietà selezionare o deselezionare la casella di controllo Azzera pagine database eliminate in base alle esigenze. La selezione della casella di controllo abilita l'azzeramento, mentre la deselezione lo disabilita.

  5. Fare clic su OK per salvare le modifiche.

  6. Chiudere Gestore di sistema di Exchange e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per abilitare o disabilitare l'azzeramento di pagine eliminate per Exchange Server 2007

  1. Di seguito è riportato del codice di esempio del comando Set-StorageGroup, che abilita o disabilita l'azzeramento per i database nel gruppo di archiviazione "MyStorageGroup".
Copia codice
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $false
Set-StorageGroup -Identity MyStorageGroup -ZeroDatabasePages
 $true

Per ulteriori informazioni in merito all'influenza sulle prestazioni della sostituzione delle pagine di database eliminate, consultare l'articolo 815068 della Microsoft Knowledge Base "XADM: Riduzione delle prestazioni di backup nel tempo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815068.


Debug Break At Startup impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il debug è stato abilitato nell'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Debug Break At Startup

Se Exchange Server Analyzer rileva che è stato impostato un valore per Debug Break At Startup, verrà visualizzato un avviso.

Il valore Debug Break At Startup del Registro di sistema consente di attivare la modalità di debug al successivo avvio del servizio Archivio informazioni di Microsoft Exchange. L'Archivio informazioni di Microsoft Exchange utilizza molte risorse quando viene eseguito in modalità di debug. Non è consigliabile eseguire il debug dell'archivio in un ambiente di produzione.

A meno che non si stia risolvendo attivamente un problema di archiviazione tramite il Servizio Supporto Tecnico Clienti Microsoft, è preferibile eliminare il valore Debug Break At Startup del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per eliminare la chiave Debug Break At Startup del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro individuare ed eliminare il valore Debug Break At Startup.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


I buffer di registro di ESE predefiniti sono stati modificati
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamLogBuffers di ogni gruppo di archiviazione presente nel computer Exchange Server. Se Exchange Server Analyzer rileva che il valore di msExchESEParamLogBuffers è uguale a 512, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchESEParamLogBuffers del gruppo di archiviazione definisce il numero di buffer di registro ESE (Extensible Storage Engine) utilizzati dall'archivio informazioni di Exchange. ESE utilizza una serie di buffer di registro per conservare le informazioni nella memoria RAM prima che vengano scritte nei registri delle transazioni. L'utilizzo di questi buffer consente di migliorare le prestazioni del registro delle transazioni. Per server di grandi dimensioni il valore predefinito 84 è insufficiente, dal momento che può provocare un numero eccessivo di operazioni I/O del disco nell'unità dei registri delle transazioni e, di conseguenza, una significativa riduzione delle prestazioni se il server è sovraccarico o se gli utenti inviano messaggi di grandi dimensioni. Se si aumenta il numero di buffer di registro ESE si otterrà un miglioramento delle prestazioni, tuttavia questa operazione comporta anche un maggior utilizzo di memoria virtuale.

Per impostare correttamente questo valore, utilizzare le seguenti informazioni:

  • Per Exchange 2000 Server, Exchange 2000 Server SP1 o Exchange 2000 Server SP2 impostare il valore su 9000.

  • Per Exchange 2000 Server SP3 impostare il valore su 512.

  • Per Exchange Server 2003 viene utilizzato il valore predefinito 500 e si consiglia di modificare il valore dell'attributo msExchESEParamLogBuffers impostandolo su 9000.

Nota:
Se i buffer di registro sono stati precedentemente impostati su 9000, assicurarsi di ridurre manualmente questa impostazione quando si installa Exchange 2000 Server SP3. Questa modifica non viene eseguita automaticamente quando si installa Exchange 2000 Server SP3.

In caso di blocchi del registro, è possibile che il buffer sia impostato su un livello troppo basso, per cui è possibile aumentare il valore fino a 9000. È possibile monitorare il contatore di prestazioni Database\Record di registro bloccati al secondo per determinare se si verificano blocchi del registro. Non utilizzare valori superiori a 9000 dal momento che possono danneggiare i file di registro delle transazioni.

Nota:
Record di registro bloccati al secondo indica il numero dei record di registro che non possono essere aggiunti ai buffer di registro al secondo perché i buffer sono pieni. Se questo valore non è uguale a zero per la maggior parte del tempo, la dimensione del buffer di registro potrebbe rappresentare un collo di bottiglia.

È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per ripristinare la configurazione predefinita

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, quindi CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo<e infine CN=Server.

  4. Espandere CN=<NomeServer> e CN=InformationStore, fare clic con il pulsante destro del mouse su CN=<NomeGruppoDiArchiviazione>, quindi su Proprietà.

  5. Nell'editor degli attributi fare clic sull'attributo msExchESEParamLogBuffers, quindi scegliere Modifica.

  6. Nella finestra Modifica attributo impostare il valore su 512 per Exchange 2000 Server o su 9000 per Exchange Server 2003.

  7. Fare clic su Applica, quindi su OK.

  8. Chiudere ADSI Edit e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sui buffer di registro di ESE, consultare l'articolo 328466 della Microsoft Knowledge Base "XADM: L'impostazione dei buffer di registro ESE su valori troppo bassi può causare l'interruzione di risposta da parte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


L'archivio delle cartelle pubbliche predefinito è remoto
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchHomePublicMDB di ogni archivio di cassette postali contiene il server di Exchange locale. Per impostazione predefinita, l'archivio delle cartelle pubbliche per un archivio delle cassette postali si trova sul server di Exchange locale. Se l'attributo msExchHomePublicMDB non contiene il server di Exchange locale, l'archivio delle cassette postali dispone di un archivio delle cartelle pubbliche remoto predefinito. Se Exchange Server Analyzer rileva che un archivio delle cassette postali dispone di un archivio delle cartelle pubbliche remoto predefinito, verrà visualizzato un messaggio di configurazione non predefinita.

Per modificare l'archivio delle cartelle pubbliche predefinito

  1. In Gestore di sistema di Exchange espandere Server, <il server di Exchange> e <gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali e selezionare Proprietà.

  2. Nella scheda Generale in Archivio pubblico predefinito fare clic su Sfoglia per selezionare un archivio delle cartelle pubbliche.

Per ulteriori informazioni sugli archivi di cassette postali e di cartelle pubbliche, consultare l'argomento "Gestione degli archivi di cassette postali e cartelle pubbliche" del Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


Intervallo di Deletion Thread Period per un archivio delle cassette postali non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'intervallo per la rimozione degli elementi eliminati è stato modificato rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>\Deletion Thread Period

Se Exchange Server Analyzer rileva che la chiave Deletion Thread Period è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Quando viene eliminato un messaggio, questo viene contrassegnato per l'eliminazione. Il messaggio viene contrassegnato anche come messaggio nascosto finché non verrà definitivamente eliminato dall'archivio di Exchange. Quando l'archivio di Exchange riceve una richiesta di eliminazione di un messaggio contenuto in una determinata cartella a cui viene fatto riferimento nell'ID del messaggio, l'archivio di Exchange determina se il messaggio deve essere eliminato in modo reversibile o irreversibile. Il messaggio viene eliminato definitivamente alla scadenza del periodo di mantenimento degli elementi eliminati. L'eliminazione reversibile è definita anche come eliminazione logica, mentre l'eliminazione irreversibile come eliminazione fisica.

Per impostazione predefinita, il processo di pulitura del contenitore viene eseguito ogni 24 ore e determina il momento in cui un elemento deve essere eliminato definitivamente. Il processo di pulitura del contenitore fa parte del processo di manutenzione in linea dell'archivio di Exchange. Se il periodo di mantenimento degli elementi eliminati è scaduto, l'elemento verrà eliminato definitivamente. Il valore Deletion Thread Period del Registro di sistema viene utilizzato per ignorare l'intervallo predefinito di 24 ore e specificare un intervallo personalizzato per il processo di pulitura del contenitore.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Eliminare la chiave Deletion Thread Period.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul mantenimento e il ripristino degli elementi eliminati, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 249680, "XADM: Nozioni fondamentali sul mantenimento degli elementi eliminati e sul processo di eliminazione dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=249680.

  • 287544, "XADM: Le dimensioni dell'Archivio informazioni pubblico aumentano notevolmente quando è abilitata la funzionalità di mantenimento degli elementi eliminati" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=287544.

  • 822938, "HOW TO: Utilizzo dei criteri di sistema per configurare i limiti di archiviazione delle caselle postali in Exchange Server 2003" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.


Intervallo di Deletion Thread Period per un archivio cartelle pubbliche non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'intervallo per la rimozione degli elementi eliminati è stato modificato rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\Deletion Thread Period

Se Exchange Server Analyzer rileva che la chiave Deletion Thread Period è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Quando viene eliminato un messaggio, questo viene contrassegnato per l'eliminazione. Il messaggio viene contrassegnato anche come messaggio nascosto finché non verrà definitivamente eliminato dall'archivio di Exchange. Quando l'Archivio informazioni riceve una richiesta di eliminazione di un messaggio contenuto in una determinata cartella a cui viene fatto riferimento nell'ID del messaggio, l'archivio di Exchange determina se il messaggio deve essere eliminato in modo reversibile o irreversibile. L'eliminazione reversibile è definita anche come eliminazione logica, mentre l'eliminazione irreversibile come eliminazione fisica. Il messaggio viene eliminato definitivamente alla scadenza del periodo di mantenimento degli elementi eliminati.

Per impostazione predefinita, il processo di pulitura del contenitore viene eseguito ogni 24 ore e determina il momento in cui un elemento deve essere eliminato definitivamente. Il processo di pulitura del contenitore fa parte del processo di manutenzione in linea dell'archivio di Exchange. Se il periodo di mantenimento degli elementi eliminati è scaduto, l'elemento verrà eliminato definitivamente. Il valore Deletion Thread Period del Registro di sistema viene utilizzato per ignorare l'intervallo predefinito di 24 ore e specificare un intervallo personalizzato per il processo di pulitura del contenitore.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Eliminare la chiave Deletion Thread Period.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul mantenimento e il ripristino degli elementi eliminati, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 249680, "XADM: Nozioni fondamentali sul mantenimento degli elementi eliminati e sul processo di eliminazione dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=249680.

  • 287544, "XADM: Le dimensioni dell'Archivio informazioni pubblico aumentano notevolmente quando è abilitata la funzionalità di mantenimento degli elementi eliminati" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=287544.

  • 319098, "HOW TO: Utilizzo di criteri di sistema per configurare i limiti di archiviazione delle cartelle pubbliche in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319098.


Rilevato collo di bottiglia di disco
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-11-14

Microsoft® Exchange Server Analyzer Tool ha rilevato che il sistema di dischi attualmente funzione entro il 20% della trasmissione dati massima prevista. Questo rilevamento viene eseguito mediante uno dei seguenti calcoli:

  • Misurazione delle latenze del disco. I contatori di prestazioni che indicano latenza sono Media disco logico Media letture disco/sec e Media disco logico. Media scritture disco/sec

  • Confronto di I/O massimo possibile del disco per secondo (IOPS) della configurazione corrente del disco e del numero di assi con il valore corrente di IOPS, come registrato da Performance Monitor (Perfmon).

Latenze accettabili

In base al tipo di dati a cui viene effettuato l'accesso, il server di Exchange ha una diversa tolleranza per i ritardi. Pertanto, la soglia di latenza media massima accettabile viene determinata in base al tipo di risorsa presente sul disco. In ogni caso, tranne laddove indicato nel seguente elenco, il valore massimo accettabile per latenze in lettura o scrittura è di 50 millisecondi (ms).

  • Unità registro transazioni L'unità che ospita il registro delle transazioni deve avere latenze medie in scrittura inferiori a 10 ms. I picchi nelle latenze in scrittura devono essere inferiori a 50 ms. Le scritture sul registro delle transazioni sono sincrone. Ciò significa che, prima di poter eseguire un'altra attività, un thread del processo Store.exe deve attendere che la scrittura sia stata completata. Latenze di scrittura ridotte per i registri delle transazioni sono importanti per le prestazioni del server. La latenza media in lettura per le unità registro transazioni deve essere inferiore a 20 ms. I picchi nella latenza il lettura devono essere inferiori a 50 ms. Record di registro bloccati al secondo del database devono essere inferiori a 10. I thread in attesa di registrazione del database devono essere inferiori a 10.

    In genere i server di Exchange non leggono dai registri delle transazioni. Pertanto le latenze in lettura per tali unità non sono importanti. Tuttavia poiché le latenze in scrittura del registro delle transazioni sono così importanti per le prestazioni di Exchange, sui server di grandi dimensioni si consiglia di non utilizzare per altri scopi le unità che ospitano i registri delle transazioni. In tal caso, la frequenza delle letture (secondo le misurazioni di Disco logico\Letture disco/sec) deve essere minima rispetto alla frequenza delle scritture (Disco logico\Scritture disco/sec). Exchange Server Analyzer rileverà se il rapporto di letture e scritture sull'unità registro transazioni è superiore a 0,10 (ovvero più di una lettura ogni dieci scritture).

    Se si verificano più di 0,10 letture per ogni scrittura, è necessario individuare l'applicazione che legge dall'unità del registro delle transazioni e quindi evitare che tale operazione venga eseguita.

  • Unità database La latenza accettabile per unità che contengono file di database Exchange ( file con estensione EDB e STM) è illustrata di seguito (i valori più elevati indicano un collo di bottiglia del disco):

    • Valore massimo per la media disco logico. Le letture disco/sec su un'unità database devono essere inferiori a 50 ms (0,050 secondi).

    • Valore medio per la media disco logico. Le letture disco/sec su un'unità database devono essere inferiori a 20 ms (0,020 secondi).

  • Unità TEMP e TMP La latenza in lettura e in scrittura per le unità che contengono le directory TEMP e TMP deve essere inferiore a 10 ms. Il valore massimo per la latenza in lettura o in scrittura deve essere inferiore a 50 ms.

  • Unità di paging e di sistema La latenza in lettura e in scrittura per le unità che contengono file di paging e file di sistema di Windows deve essere inferiore a 10 ms.

  • Unità SMTP La latenza in lettura e in scrittura per le unità che contengono file del server SMTP deve essere inferiore a 10 ms.

Cause della latenza

L'accesso ai dischi con una frequenza superiore a quella supportata dal sottosistema disco è una delle cause più comuni di latenza del disco. In questi casi il disco viene definito un collo di bottiglia. Ciò significa inoltre che il sottosistema disco ha raggiunto o ha superato la capacità di trasmissione.

Se la frequenza degli IOPS del disco (Disco logico\Trasferimenti disco/sec) è vicina o superiore alla capacità prevista, si dice che il disco abbia "superato la capacità di trasmissione" o semplicemente "superato la capacità". In questi casi, per migliorare le prestazioni del server, è necessario ridurre il carico sul sottosistema disco (spostando gli utenti su un altro server) o aumentare la capacità dell'unità (aggiungendo ulteriori assi o assi più veloci).

Nei casi in cui l'hardware non funziona come previsto, è possibile esaminare le latenze anche quando la frequenza di I/O è notevolmente inferiore alla capacità stimata.

Riduzione della latenza del disco

Per ridurre il carico sul sottosistema disco, è possibile ridurre alcune delle attività eseguite dal server. In particolare è necessario rimuovere tutte le applicazioni facoltative che contribuiscono al carico del disco. Il processo Store.exe è l'unica applicazione che deve accedere alle unità database e del registro delle transazioni.

In base all'attuale configurazione di sistema del disco, è possibile intraprendere alcune misure per ridurre l'effetto di questo problema.

Per ridurre la latenza del disco

  • Se una unità database o registro delle transazioni rappresenta un collo di bottiglia, è possibile ridurre il carico su tale unità spostando gli utenti in un database o gruppo di archiviazione ospitato su una unità che non sta per raggiungere la capacità massima. Se tutte le unità database o registro delle transazioni hanno quasi raggiunto la capacità massima, è necessario spostare gli utenti su un altro server. Per ulteriori informazioni, vedere Spostare le cassette postali degli utenti su un server diverso.

  • Talvolta la durata di una frequenza elevata di I/O è breve poiché è causata da operazioni MAPI costose. In tal caso, per individuare l'utente o l'operazione che provoca elevate frequenze di I/O, è possibile utilizzare Exchange Server User Monitor (ExMon) in combinazione con i contatori di prestazioni del disco logico. Se è possibile isolare l'utente, è possibile individuare l'applicazione client che genera il carico maggiore. È possibile scaricare ExMon dall'aera download Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=54983.

  • Se è in esecuzione un array di dischi RAID 5, è possibile passare a un array di dischi RAID 10 per migliorare gli IOPS disponibili supportati dal sottosistema disco.

  • Per migliorare gli IOPS disponibili supportati, valutare la possibilità di aggiungere ulteriori dischi al sistema di dischi.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare il Manuale sulla risoluzione dei problemi di prestazioni di Microsoft Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sulle procedure consigliate per la progettazione delle architetture di archiviazione, vedere Procedure consigliate comuni a più architetture all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72988.

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, vedere Spostare le cassette postali degli utenti su un server diverso.

  • Per ulteriori informazioni sulle dimensioni dei dischi, la latenza e le frequenze di I/O, consultare i seguenti blog sul sito Web del blog del team Microsoft Exchange:

    • "A few basic concepts in disk sizing" all'indirizzo http://go.microsoft.com/fwlink/?linkid=39538 (informazioni in lingua inglese)

    • "Some more thoughts on disk IO and calculations…" all'indirizzo http://go.microsoft.com/fwlink/?linkid=39539 (informazioni in lingua inglese)

    • "Come calcolare i requisiti di I/O del disco" all'indirizzo http://go.microsoft.com/fwlink/?linkid=69747.


Rilevato collo di bottiglia sul disco contenente i file di registro delle transazioni
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che nel sistema disco contenente i file di registro di Exchange Server è in esecuzione un numero eccessivo di operazioni, il che ha determinato un collo di bottiglia a livello delle prestazioni. Questo tipo di problema viene individuato mediante la verifica di uno o più dei seguenti contatori di prestazioni:

  • Il valore medio di Database\Record di registro bloccati al secondo è superiore a 10.

  • Il valore massimo di Database\Record di registro bloccati al secondo è superiore a 100.

  • Il valore medio di Database\Thread in attesa di registrazione è superiore a 10.

  • Il valore massimo di Database\Thread in attesa di registrazione è superiore a 20.

Se si raggiunge una delle soglie sopra riportate, verrà visualizzato un messaggio di errore che indica che l'unità di registro in uso rappresenta un collo di bottiglia. I file di registro richiedono una bassa latenza di scrittura. Eventuali operazioni di backup o blocchi durante la scrittura su un file di registro possono provocare problemi a livello di prestazioni del server. Blocchi del registro possono essere causati da un'impostazione bassa del buffer di registro, msExchESEParamLogBuffers, o da un numero eccessivo di utenti connessi al server.

Per ridurre la latenza del disco di registro

  • È possibile aumentare il valore del parametro relativo ai buffer ESE, msExchESEParamLogBuffers, fino a 9.000. Se si utilizza un valore superiore a tale limite, si rischia di danneggiare i file di registro delle transazioni. Per ulteriori informazioni, consultare I buffer di registro di ESE predefiniti sono stati modificati.

  • Se si verifica un collo di bottiglia a livello di unità di registro delle transazioni o di database, è possibile ridurre il carico su tale unità mediante lo spostamento di utenti in un database o in un gruppo di archiviazione ospitato su un'unità non ancora prossima alla capacità massima. Se tutte le unità di registro delle transazioni o i database sono prossimi a raggiungere la capacità massima, potrebbe rendersi necessario spostare utenti su un altro server. Per ulteriori informazioni, consultare Spostare le cassette postali degli utenti su un server diverso.


EnableChangeNotification non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se è stata abilitata la notifica della modifica dei file per il file system installabile (IFS) di Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\ EnableChangeNotification

Se Exchange Server Analyzer rileva che la chiave EnableChangeNotification è presente e configurata con un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, la notifica della modifica dei file per ExIFS è disabilitata. Quando in ExIFS vengono inviate le notifiche della modifica di un file o di una directory, non viene eliminata la versione del file o della directory memorizzata nella cache. Di conseguenza, se un'applicazione come Exchange Server o Microsoft SharePoint® Portal Server riceve una notifica di modifica e ricarica il file o la directory, verrà restituita la versione memorizzata nella cache e non il file o la directory appena modificati.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Eliminare la chiave EnableChangeNotification.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul file system installabile di Exchange (ExIFS), consultare i seguenti riferimenti:

  • Il capitolo 26, "Exchange 2000 Architecture", in Exchange 2000 Server Resource Kit all'indirizzo http://go.microsoft.com/fwlink/?LinkId=51224 (informazioni in lingua inglese).

  • Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47891.


Errore durante l'accesso alla directory dei registri
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che il percorso definito nel server di Exchange per i registri delle transazioni di questo gruppo di archiviazione è inaccessibile.

Per risolvere il problema

  • Verificare che il percorso specificato sia realmente presente nel server.

  • Assicurarsi di disporre delle autorizzazioni necessarie per la lettura dei file archiviati nel percorso dei registri delle transazioni.


Errore durante l'accesso ai file di flusso del database
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che il file di flusso del database (STM) è inaccessibile.

Ogni database in Exchange 2000 Server ed Exchange Server 2003 è costituito da due file: il file di database di Exchange EDB e il file di flusso del database STM. È necessario accedere ai due file contemporaneamente. Inoltre, i due file devono essere elaborati insieme.

Per risolvere il problema

  • Individuare il percorso del file STM. Nel Gestore di sistema di Exchange questo percorso viene definito nella pagina delle proprietà del database per ciascun oggetto del database.

  • Verificare che per questo database esista il file STM.

  • Verificare di disporre delle necessarie autorizzazioni per accedere alla cartella in cui si trova il file STM.

  • Verificare che il file non sia bloccato in maniera esclusiva da un altro processo. Un metodo per verificare che non sia bloccato è quello di rinominarlo. Se l'operazione di ridenominazione riesce, significa che il file non è bloccato in maniera esclusiva. Successivamente ricordarsi di ripristinare il nome originario del file.


Errore di controllo dei file di registro
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Impossibile leggere i file di registro delle transazioni.

Per risolvere il problema

  • Verificare se si dispongono delle autorizzazioni necessarie per accedere alla cartella del file di registro delle transazioni.

  • Verificare che il file non sia stato bloccato in modo esclusivo da un altro processo. Provare, ad esempio, a rinominare il file. Se il file viene rinominato correttamente, significa che non è bloccato in modo esclusivo (ricordarsi di rinominare il file con il nome originale).


I buffer di registro di ESE sono impostati sul livello massimo in questo gruppo di archiviazione
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamLogBuffers per ogni oggetto del gruppo di archiviazione. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchESEParamLogBuffers è uguale a 9.000, verrà visualizzato un messaggio di configurazione non predefinita.

ESE (Extensible Storage Engine) utilizza una serie di buffer di registro per conservare le informazioni nella memoria RAM prima che vengano scritte nei registri delle transazioni. L'utilizzo di questi buffer consente di migliorare le prestazioni del registro delle transazioni. Per server di grandi dimensioni il valore predefinito 84 è insufficiente, dal momento che può provocare un numero eccessivo di operazioni I/O del disco nell'unità dei registri delle transazioni e, di conseguenza, una significativa riduzione delle prestazioni se il server è sovraccarico o se gli utenti inviano messaggi di grandi dimensioni. Se si aumenta il numero di buffer di registro ESE si otterrà un miglioramento delle prestazioni, tuttavia questa operazione comporta anche un maggior utilizzo di memoria virtuale.

Per impostare correttamente questo valore, utilizzare le seguenti informazioni:

  • Per Exchange 2000 Server, Exchange 2000 Server SP1 o Exchange 2000 Server SP2 impostare il valore su 9000.

  • Per Exchange 2000 Server SP3 impostare il valore su 512.

  • Per Exchange Server 2003 viene utilizzato il valore predefinito 500 e si consiglia di modificare il valore dell'attributo msExchESEParamLogBuffers impostandolo su 9000.

Nota:
Se i buffer di registro sono stati precedentemente impostati su 9000, assicurarsi di ridurre manualmente questa impostazione quando si installa Exchange 2000 Server SP3. Questa modifica non viene eseguita automaticamente quando si installa Exchange 2000 Server SP3.

In caso di blocchi del registro, è possibile che il buffer sia impostato su un livello troppo basso, per cui è possibile aumentare il valore fino a 9000. È possibile monitorare il contatore di prestazioni Database\Record di registro bloccati al secondo per determinare se si verificano blocchi del registro. Non utilizzare valori superiori a 9000 dal momento che possono danneggiare i file di registro delle transazioni.

Nota:
Record di registro bloccati al secondo indica il numero dei record di registro che non possono essere aggiunti ai buffer di registro al secondo perché i buffer sono pieni. Se questo valore non è uguale a zero per la maggior parte del tempo, la dimensione del buffer di registro potrebbe rappresentare un collo di bottiglia.

È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per ripristinare la configurazione predefinita

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, quindi CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo<e infine CN=Servers.

  4. Espandere CN=<NomeServer> e CN=InformationStore, fare clic con il pulsante destro del mouse su CN=<NomeGruppoDiArchiviazione>, quindi su Proprietà.

  5. Nell'editor degli attributi fare clic sull'attributo msExchESEParamLogBuffers, quindi scegliere Modifica.

  6. Nella finestra Modifica attributo impostare il valore su 512 per Exchange 2000 Server o 9000 per Exchange Server 2003.

  7. Fare clic su Applica, quindi su OK.

  8. Chiudere ADSI Edit e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sull'impostazione dei buffer di registro ESE, consultare l'articolo 328466 della Microsoft Knowledge Base "XADM: L'impostazione dei buffer di registro ESE su valori troppo bassi può causare l'interruzione di risposta da parte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.


In questo gruppo di archiviazione i buffer di registro di ESE sono impostati su un livello troppo basso
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore msExchESEParamLogBuffers di ogni oggetto gruppo di archiviazione (classe msExchStorageGroup) del contenitore InformationStore. Se Exchange Server Analyzer rileva che il valore di tale attributo è minore di 500, verrà visualizzato un avviso.

ESE (Extensible Storage Engine) utilizza una serie di buffer di registro per conservare le informazioni nella memoria RAM prima che vengano scritte nei registri delle transazioni. L'utilizzo di questi buffer consente di migliorare le prestazioni del registro delle transazioni. Per server di grandi dimensioni il valore predefinito 84 è insufficiente, dal momento che può provocare un numero eccessivo di operazioni I/O del disco nell'unità dei registri delle transazioni e, di conseguenza, una significativa riduzione delle prestazioni se il server è sovraccarico o se gli utenti inviano messaggi di grandi dimensioni. Se si aumenta il numero di buffer di registro ESE si otterrà un miglioramento delle prestazioni, tuttavia questa operazione comporta anche un maggior utilizzo di memoria virtuale.

Per impostare correttamente questo valore, utilizzare le seguenti informazioni:

  • Per Exchange 2000 Server, Exchange 2000 Server SP1 o Exchange 2000 Server SP2 impostare il valore su 9000.

  • Per Exchange 2000 Server SP3 impostare il valore su 512.

  • Per Exchange Server 2003 viene utilizzato il valore predefinito 500 e si consiglia di modificare il valore dell'attributo msExchESEParamLogBuffers impostandolo su 9000.

Nota:
Se i buffer di registro sono stati precedentemente impostati su 9000, assicurarsi di ridurre manualmente questa impostazione quando si installa Exchange 2000 Server SP3. Questa modifica non viene eseguita automaticamente quando si installa Exchange 2000 Server SP3.

In caso di blocchi del registro, è possibile che il buffer sia impostato su un livello troppo basso, per cui è possibile aumentare il valore fino a 9000. È possibile monitorare il contatore di prestazioni Database\Record di registro bloccati al secondo per determinare se si verificano blocchi del registro. Non utilizzare valori superiori a 9000 dal momento che possono danneggiare i file di registro delle transazioni.

Nota:
Record di registro bloccati al secondo indica il numero dei record di registro che non possono essere aggiunti ai buffer di registro al secondo perché i buffer sono pieni. Se questo valore non è uguale a zero per la maggior parte del tempo, la dimensione del buffer di registro potrebbe rappresentare un collo di bottiglia.

È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, quindi CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo<e infine CN=Servers.

  4. Espandere CN=<NomeServer> e CN=InformationStore, fare clic con il pulsante destro del mouse su CN=<NomeGruppoDiArchiviazione>, quindi su Proprietà.

  5. Nell'editor degli attributi fare clic sull'attributo msExchESEParamLogBuffers, quindi scegliere Modifica.

  6. Nella finestra Modifica attributo impostare il valore su 512 per Exchange 2000 Server o 9000 per Exchange Server 2003.

  7. Fare clic su Applica, quindi su OK.

  8. Chiudere ADSI Edit e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sui buffer di registro ESE, consultare l'articolo 328466 della Microsoft Knowledge Base "XADM: L'impostazione dei buffer di registro ESE su valori troppo bassi può causare l'interruzione di risposta da parte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'impostazione dei buffer di registro di ESE, consultare l'articolo 328466 della Microsoft Knowledge Base "XADM: L'impostazione dei buffer di registro ESE su valori troppo bassi può causare l'interruzione di risposta da parte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


I buffer di registro di ESE sono impostati su un livello troppo alto in questo gruppo di archiviazione
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamLogBuffers per ogni gruppo di archiviazione. Se Exchange Server Analyzer determina che il valore dell'attributo msExchESEParamLogBuffers di ciascun gruppo di archiviazione è maggiore di 9.000, verrà visualizzato un messaggio di errore.

ESE (Extensible Storage Engine) utilizza una serie di buffer di registro per conservare le informazioni nella memoria RAM prima che vengano scritte nei registri delle transazioni. L'utilizzo di questi buffer consente di migliorare le prestazioni del registro delle transazioni. Per server di grandi dimensioni il valore predefinito 84 è insufficiente, dal momento che può provocare un numero eccessivo di operazioni I/O del disco nell'unità dei registri delle transazioni e, di conseguenza, una significativa riduzione delle prestazioni se il server è sovraccarico o se gli utenti inviano messaggi di grandi dimensioni. Se si aumenta il numero di buffer di registro ESE si otterrà un miglioramento delle prestazioni, tuttavia questa operazione comporta anche un maggior utilizzo di memoria virtuale.

Per impostare correttamente questo valore, utilizzare le seguenti informazioni:

  • Per Exchange 2000 Server, Exchange 2000 Server SP1 o Exchange 2000 Server SP2 impostare il valore su 9000.

  • Per Exchange 2000 Server SP3 impostare il valore su 512.

  • Per Exchange Server 2003 viene utilizzato il valore predefinito 500 ed è consigliabile modificare il valore dell'attributo msExchESEParamLogBuffers impostandolo su 9000.

Nota:
Se i buffer di registro sono stati precedentemente impostati su 9000, assicurarsi di ridurre manualmente questa impostazione quando si installa Exchange 2000 Server SP3. Questa modifica non viene eseguita automaticamente quando si installa Exchange 2000 Server SP3.

In caso di blocchi del registro, è possibile che il buffer sia impostato su un livello troppo basso, per cui è possibile aumentare il valore fino a 9000. È possibile monitorare il contatore di prestazioni Database\Record di registro bloccati al secondo per determinare se si verificano blocchi del registro. Non utilizzare valori superiori a 9000 dal momento che possono danneggiare i file di registro delle transazioni.

Nota:
Record di registro bloccati al secondo indica il numero dei record di registro che non possono essere aggiunti ai buffer di registro al secondo perché i buffer sono pieni. Se questo valore non è uguale a zero per la maggior parte del tempo, la dimensione del buffer di registro potrebbe rappresentare un collo di bottiglia.

È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, quindi CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo<e infine CN=Servers.

  4. Espandere CN=<NomeServer> e CN=InformationStore, fare clic con il pulsante destro del mouse su CN=<NomeGruppoDiArchiviazione>, quindi su Proprietà.

  5. Nell'editor degli attributi fare clic sull'attributo msExchESEParamLogBuffers, quindi scegliere Modifica.

  6. Nella finestra Modifica attributo impostare il valore su 512 per Exchange 2000 Server o su 9000 per Exchange Server 2003.

  7. Fare clic su Applica, quindi su OK.

  8. Chiudere ADSI Edit e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'impostazione dei buffer di registro ESE, consultare l'articolo 328466 della Microsoft Knowledge Base "XADM: L'impostazione dei buffer di registro ESE su valori troppo bassi può causare l'interruzione di risposta da parte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=3052&kbid=328466.


La dimensione dei file di registro di ESE è stata modificata manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamLogFileSize del contenitore InformationStore. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchESEParamLogFileSize non equivale a 5120, verrà visualizzato un messaggio di errore.

Questo valore si applica a tutti i gruppi di archiviazione nel server. Questo particolare errore si verifica se il valore dell'attributo è stato modificato rispetto al valore predefinito (5120 KB o 5 MB). Questo è l'unico valore supportato e non deve essere mai modificato.

È necessario correggere il valore mediante un'utilità quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit e individuare l'oggetto InformationStore del computer Exchange Server in Active Directory.

    L'attributo msExchESEParamLogFileSize è reperibile in:

    CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN=NomeOrganizzazione, CN=Administrative Groups, CN=NomeGruppoAmministrativo, CN=Servers, CN=NomeServer, CN=InformationStore

  2. Fare doppio clic sull'attributo msExchESEParamLogFileSize e impostare il relativo valore su 5120.

  3. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'utilizzo di LDP.exe, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


Il numero massimo di tabelle aperte di ESE è stato hardcoded
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchESEParamMaxOpenTables è presente per tutti gli oggetti del gruppo di archiviazione contenuti nell'oggetto InformationStore dell'oggetto Exchange Server. Se Exchange Server Analyzer rileva che l'attributo msExchESEParamMaxOpenTables è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, per Exchange 2000 Server e Exchange Server 2003 l'attributo è presente ma non impostato su alcun valore. Exchange Server archivia nella cache i dati relativi alle cartelle a cui non si accede attualmente. In alcuni casi, ciò può contribuire alla frammentazione della memoria virtuale. Un sistema per limitare questo effetto consiste nel ridurre il numero massimo di tabelle di database che possono essere aperte simultaneamente. Il valore effettivo suggerito per questo numero varia a seconda della versione di Exchange Server e del Service Pack di Exchange installata. Per Exchange 2000 Server Service Pack 2, l'impostazione predefinita per i server a 8 processori è di 85.000 tabelle per gruppo di archiviazione. Questo numero viene ridotto a 27.600 in Exchange 2000 Server Service Pack 3 per i server a 8 processori. Per i server a 4 processori il valore è 13.800, ma può essere abbassato per ridurre i problemi di frammentazione della memoria virtuale. Tuttavia, l'abbassamento di questo valore potrebbe anche determinare situazioni di funzionamento non corretto a causa di un numero eccessivo di tabelle aperte. L'errore si verifica in quanto, abbassando il numero massimo di tabelle che possono essere aperte simultaneamente, il valore massimo viene raggiunto più velocemente.

Exchange Server 2003 utilizza un metodo diverso per archiviare nella cache i dati relativi alle cartelle a cui non si accede attualmente. Pertanto, la diminuzione del numero massimo di tabelle aperte non è necessaria né efficace per ridurre i problemi di frammentazione della memoria virtuale. Questo attributo non deve essere impostato su un server di Exchange Server 2003.

Se non sono state fornite istruzioni dal Servizio Supporto Tecnico Clienti Microsoft sull'immissione di un valore, utilizzare lo strumento ADSI Edit (Active Directory Service Interfaces) per eliminare il valore impostato per tale attributo.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per eliminare il valore dell'attributo msExchESEParamMaxOpenTables

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=ExchangeOrganizationName.

  3. Espandere CN=Administrative Groups, CN=AdministrativeGroupNamee infine CN=Server.

  4. Espandere CN=ExchangeServerName e CN=InformationStore, fare clic con il pulsante destro del mouse su CN=StorageGroupName, quindi su Proprietà.

  5. Nella finestra Selezionare una proprietà da visualizzare fare clic su msExchESEParamMaxOpenTables.

  6. Nella finestra Modifica attributo fare clic su Cancella per modificare il valore in <non impostato>.

  7. Fare clic su OK, quindi nuovamente su OK.

  8. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni su questo attributo, consultare l'articolo 325044 della Microsoft Knowledge Base "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.


La dimensione del database Exchange supera i 100 GB
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_DataFile per determinare il valore della chiave FileSize per ogni database dell'archivio informazioni di Exchange: Se la dimensione combinata di un file con estensione EDB e di un file con estensione STM dell'archivio informazioni supera i 100 GB, verrà visualizzato un avviso.

È consigliabile evitare che la dimensione dei database dell'archivio informazioni superi i 50 GB. Se si esegue una corretta manutenzione, non si verificheranno problemi operativi con l'esecuzione di archivi di cassette postali di dimensioni superiori a 50 GB. Tuttavia, i tempi di backup e di ripristino potrebbero rendere questi archivi non adatti per alcuni contratti di servizio di alto livello (SLA).

Se si eseguono archivi di cassette postali di dimensioni superiori a 50 GB, verificare che l'hardware soddisfi le condizioni definite nel contratto di servizio di alto livello, quali, ad esempio, quelle relative al ripristino di database di grandi dimensioni. In caso contrario, è consigliabile distribuire le cassette postali in più archivi, in modo che nessun archivio delle cassette postali superi la dimensione di 50 GB.

Per risolvere il problema

  1. Provare a spostare alcune delle cassette postali dall'archivio informazioni di grandi dimensioni a un nuovo archivio informazioni sulo stesso o su un altro computer Exchange Server.

  2. Se si sono recentemente spostate cassette postali in un altro archivio informazioni, oppure se si sono recentemente eliminate cassette postali dall'archivio corrente, è possibile ridurre la dimensione dei file eseguendo una deframmentazione non in linea.

  3. Provare a impostare limiti per la dimensione delle cassette postali o dei messaggi, per impedire una crescita illimitata dell'archivio informazioni.

Per ulteriori informazioni sui file con estensione STM ed EDB, consultare l'articolo 232323 della Microsoft Knowledge Base "Archiviazione di contenuti nativi in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange 2000 Server, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Per ulteriori informazioni sull'esecuzione di una deframmentazione non in linea di un database di Exchange Server, consultare l'articolo 328804 della Microsoft Knowledge Base "Deframmentazione dei database di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Per ulteriori informazioni sull'impostazione di limiti per la dimensione dei messaggi, consultare l'articolo 322679 della Microsoft Knowledge Base "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.


Scrittura dei file di database di Exchange in una cartella compressa
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Compressed relativo alla cartella contenente i file di database dell'archivio informazioni di Exchange. Se il valore di Compressed viene impostato su True per questa cartella, verrà visualizzato un messaggio di errore.

In un computer che esegue Exchange 2000 Server o Exchange Server 2003, i database dell'archivio informazioni vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Exchsrvr\mdbdata

In un computer che esegue Exchange Server 2007, i file di database vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Microsoft\Exchange Server\Mailbox\<Nome gruppo archiviazione>

Microsoft non supporta l'archiviazione dei file di dati di Exchange in un volume NTFS compresso. Quando si esegue l'archiviazione dei file di dati di Exchange in un volume compresso, il sovraccarico aggiuntivo influisce notevolmente sulle prestazioni di Exchange. Inoltre, quando un database dell'archivio informazioni raggiunge una determinata dimensione (circa 4 GB), potrebbe presentare problemi di installazione o essere danneggiato.

I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

I file gestiti da Extensible Storage Engine (ESE) non sono progettati per l'archiviazione in un'unità compressa. L'Extensible Storage Engine dipende dall'indipendenza dei settori per il ripristino basato sui registri e la compressione dei file invalida tale indipendenza. La compressione non deve essere attivata per i volumi che ospitano database ESE o altri database che utilizzano la registrazione write-ahead.

Prima di Exchange 2000 Server Service Pack 3, era possibile installare database dell'archivio informazioni compressi. Tuttavia, i registri e i database dell'archivio informazioni di Exchange 2000 Server compressi mediante la compressione NTFS possono risultare danneggiati.

Con Exchange 2000 Server Service Pack 3, i file di database dell'archivio informazioni compressi di dimensione pari o inferiore a 128 MB vengono decompressi automaticamente. Se la dimensione dei file di database diventa maggiore di 128 MB, il database non verrà installato e nel Registro applicazione verranno generati messaggi di errore. Exchange 2000 Server Service Pack 3 impedisce l'installazione dei database compressi di dimensioni superiori a 128 MB.

Per disattivare la compressione dei file in una specifica cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

Per spostare i file di database in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Gruppi amministrativi, il proprio gruppo amministrativo, Server, il proprio server, il proprio gruppo di archiviazione, fare clic con il pulsante destro del mouse su Archivio cassette postali, quindi scegliere Proprietà.

  3. Nella scheda Database, in Database di Exchange o Database di flusso di Exchange, fare clic su Sfoglia, digitare la posizione del percorso di una cartella in cui non è abilitata la compressione, quindi scegliere OK.

  4. Fare clic su OK oppure su Applica per applicare le modifiche, quindi fare clic su Sì quando viene visualizzato l'avviso.

    Dopo aver selezionato Sì, gli archivi (database) vengono disinstallati, spostati e reinstallati. Quando queste procedure vengono completate in modo corretto, verrà visualizzato il seguente messaggio informativo:

    Spostamento dei file di database completato

Per spostare il percorso dei file del database del gruppo di archiviazione di Exchange su Exchange Server 2007

  1. Seguire le istruzioni riportate nella documentazione principale di Exchange Server 2007, "Come spostare il percorso di un gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80747.

Per ulteriori informazioni sui file con estensione STM ed EDB, consultare l'articolo 232323 della Microsoft Knowledge Base "Archiviazione di contenuti nativi in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.


Scrittura dei file di database di Exchange in una partizione non NTFS
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Windows Management Instrumentation) Win32_Directory per determinare il valore della chiave FSName per il percorso dei file di database di Exchange. Se Exchange Server Analyzer determina che il valore della chiave FSName non equivale a NTFS, verrà visualizzato un messaggio di errore.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in volumi non NTFS. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione CHK

  • File con estensione EML

Se viene riscontrato questo errore, sarà necessario spostare i file di database in una cartella dell'unità NTFS. In alternativa, se l'unità in cui sono archiviati i file del database è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertire l'unità in NTFS.

Per spostare i file di database di Exchange in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Gruppi amministrativi, il proprio gruppo amministrativo, Server, il proprio server, il proprio gruppo di archiviazione, fare clic con il pulsante destro del mouse su Archivio cassette postali, quindi scegliere Proprietà.

  3. Nella scheda Database in Database di Exchange o Database di flusso di Exchange fare clic su Sfoglia, digitare il percorso di una cartella nel volume NTFS, quindi scegliere OK.

  4. Fare clic su OK o su Applica per applicare le modifiche, oppure fare clic su Annulla se non si desidera applicare le modifiche.

  5. Se si è fatto clic su OK o su Applica, verrà visualizzato il seguente avviso:

    Nota In procinto di eseguire le seguenti operazioni

    • Modificare il percorso del database di Exchange

    • modifica della posizione del database di flusso di Exchange

    Per eseguire le operazioni richieste, è necessario disinstallare l'archivio, rendendolo in tal modo inaccessibile a qualunque utente.

    Continuare?

    Nota:
    Solo le operazioni scelte vengono elencate nell'avviso. L'avviso contiene un pulsante Sì e un pulsante No.

  6. Scegliere Sì se si desidera continuare, altrimenti scegliere No.

  7. Se si è selezionato Sì, gli archivi (database) vengono disinstallati, spostati e reinstallati. Quando queste procedure vengono completate in modo corretto, verrà visualizzato il seguente messaggio informativo:

    Spostamento dei file di database completato

Per spostare il percorso dei file di database di un gruppo di archiviazione di Exchange in Exchange Server 2007

  1. Seguire le istruzioni riportate nella documentazione principale di Exchange Server 2007, "Come spostare il percorso di un gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80747.

Come alternativa alla procedura descritta sopra, se l'unità in cui sono archiviati i file è formattata come unità FAT, è possibile utilizzare lo strumento della riga di comando convert.exe per convertirla in unità NTFS. Per ulteriori informazioni sull'utilizzo dello strumento della riga di comando convert.exe per convertire una partizione FAT in una partizione NTFS, consultare l'articolo 214579 della Microsoft Knowledge Base: "Utilizzo di Convert.exe per convertire una partizione nel file system NTFS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579.


Scrittura dei file di database di Exchange in una cartella crittografata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Encrypted relativo alla cartella contenente i file di database dell'Archivio informazioni di Exchange. Se Exchange Server Analyzer rileva che il valore di Encrypted è impostato su True, verrà visualizzato un messaggio di errore.

In un computer che esegue Exchange 2000 Server o Exchange Server 2003, i file di database vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Exchsrvr\mdbdata

In un computer che esegue Exchange Server 2007, i file di database vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Microsoft\Exchange Server\Mailbox\<Nome gruppo archiviazione>

Microsoft non supporta la memorizzazione dei file di dati di Exchange in un volume crittografato EFS (Encrypting File System). Quando si archiviano i file di dati di Exchange in un volume crittografato, l'overhead aggiuntivo influenza in modo significativo le prestazioni di Exchange. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per proteggere i file di dati di Exchange, è consigliabile impedire l'accesso non autorizzato al computer che esegue Exchange e utilizzare il formato messaggio S/MIME per crittografare i dati dei messaggi.

Per correggere questo errore è necessario disattivare la crittografia dei file nella cartella di scrittura dei file di database oppure spostare tali file di database in una cartella in cui la crittografia non è abilitata.

Per disattivare la crittografia dei file in una data cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la crittografia file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Crittografa contenuto per la protezione dei dati e scegliere OK.

Per spostare i file di database in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Gruppi amministrativi, il proprio gruppo amministrativo, Server, il proprio server, il proprio gruppo di archiviazione, fare clic con il pulsante destro del mouse su Archivio cassette postali, quindi su Proprietà.

  3. Nella scheda Database in Database di Exchange o Database di flusso di Exchange fare clic su Sfoglia, digitare la posizione del percorso di una cartella in cui non è abilitata la crittografia, quindi scegliere OK.

  4. Fare clic su OK oppure su Applica per applicare le modifiche, quindi fare clic su Sì quando viene visualizzato l'avviso.

  5. Dopo aver selezionato Sì, gli archivi (database) vengono disinstallati, spostati e reinstallati. Quando queste procedure vengono completate in modo corretto, verrà visualizzato il seguente messaggio informativo:

    Spostamento dei file di database completato

Per spostare il percorso dei file del database del gruppo di archiviazione di Exchange su Exchange Server 2007

  1. Seguire le istruzioni riportate nella documentazione principale di Exchange Server 2007, "Come spostare il percorso di un gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80747.

Per ulteriori informazioni sullo spostamento dei file di registro, consultare l'articolo 821915 della Microsoft Knowledge Base "Spostamento dei database e dei registri di Exchange in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915.

Per ulteriori informazioni sui file di dati di Exchange Server e su EFS (Encrypting File System, Crittografia file system), consultare l'articolo 834638 della Microsoft Knowledge Base "Informazioni sull'archiviazione dei file di dati in un volume crittografato in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Per informazioni sulle modalità di protezione dei messaggi in Exchange Server 2003, consultare la Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47574.


Il database di Exchange è in uno stato di arresto anomalo
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-10-30

Microsoft® Exchange Server Analyzer Tool ha determinato che uno dei database non è stato arrestato correttamente. Pertanto, i file del database sono ancora collegati ai file di registro.

Uno stato di arresto anomalo non indica che il database è danneggiato, ma semplicemente che i file del database non sono stati disconnessi correttamente dal flusso di registrazione. Pertanto, prima di poterlo riavviare, è necessario recuperare i relativi file.

Alla successiva installazione del database, il recupero viene eseguito automaticamente. Se si verifica un errore nella procedura di recupero automatico, utilizzare Microsoft Exchange Server Disaster Recovery Analyzer Tool per analizzare le cause del problema. Al termine dell'analisi verranno visualizzati alcuni suggerimenti per eseguire il ripristino manuale dei file del database.

Per risolvere il problema

  • Riportare il database nello stato di chiusura normale riproducendo i necessari file di registro delle transazioni nel database. Per riprodurre i file di registro, installare il database. In caso di errore, utilizzare Exchange Server Disaster Recovery Analyzer Tool per identificare la causa del problema.

Per ulteriori informazioni su Exchange Server Disaster Recovery Analyzer Tool, vedere l'articolo 922247 della Microsoft Knowledge Base relativo alla descrizione dello strumento Microsoft Exchange Server Disaster Recovery Analyzer per Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=922247.


La pianificazione della manutenzione in linea del database di Exchange è impostata su Mai
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo activationSchedule negli archivi di cassette postali e negli archivi pubblici. Se Exchange Server Analyzer rileva che il valore di activationSchedule è impostato su Mai, verrà visualizzato un avviso.

L'attributo activationSchedule rappresenta l'impostazione per la pianificazione della manutenzione in linea del database. La manutenzione in linea del database in Exchange Server è molto importante. Durante questo intervallo, vengono eseguite attività quali la pulitura del contenitore (l'eliminazione di messaggi che hanno superato la data di mantenimento degli elementi eliminati), la scadenza delle cartelle pubbliche (i messaggi delle cartelle pubbliche antecedenti a una data specifica sono scaduti), la pulitura delle cassette postali eliminate e la deframmentazione in linea (gli oggetti del database inutilizzati vengono rilevati e rimossi, liberando spazio nel database). Questi processi consentono al computer su cui è in esecuzione Exchange Server di funzionare correttamente e fornire prestazioni ottimali. La manutenzione in linea deve essere impostata in modo da essere eseguita almeno quattro ore al giorno. In caso contrario, il livello delle prestazioni si ridurrà nel tempo.

È consigliabile configurare la manutenzione in linea del database in modo che venga eseguita su ciascun database (archivio delle cassette postali o archivio cartelle pubblico) per quattro ore al giorno. Sfalsare gli intervalli di manutenzione in linea con le pianificazioni di backup. Se, ad esempio, il backup viene eseguito da mezzanotte alle 2:00, eseguire la manutenzione in linea dalle 3:00 alle 7:00.

Questo è importante perché, in questo modo, la manutenzione in linea non inizia se la sessione di backup è ancora in corso. Se si verifica una sovrapposizione, il backup acquista la precedenza sulla manutenzione. In questo caso, viene verificato ogni 15 minuti se il backup è stato completato. Al termine del backup, inizia la manutenzione.

Per eseguire la manutenzione vengono eseguite 18 attività. Quando si inizia un'attività, tale attività viene completata indipendentemente dall'intervallo di manutenzione. Tuttavia la nuova attività di manutenzione non viene iniziata se l'intervallo è scaduto. Pertanto, in alcuni casi, in un dato intervallo di manutenzione non vengono completate tutte le attività. Se la manutenzione viene abbreviata, verrà ripresa dal punto in cui è stata interrotta nel ciclo di manutenzione successivo.

Per abilitare la manutenzione in linea del database di Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Server, quindi la struttura del server che si desidera utilizzare.

  3. Espandere la struttura del gruppo di archiviazione che si desidera utilizzare.

  4. Nell'elenco degli archivi dei dati disponibili nel riquadro dei dettagli fare clic con il pulsante destro del mouse sull'archivio che si desidera utilizzare, quindi scegliere Proprietà.

  5. Nella finestra di dialogo Store Properties fare clic sulla scheda Database.

  6. Eseguire una delle seguenti operazioni:

    • Nell'elenco degli intervalli Manutenzione scegliere un intervallo.

    • Fare clic su Personalizza per accedere alla finestra di dialogo Pianificazione, quindi creare un intervallo personalizzato.

  7. Fare clic su OK.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Configurazione server e selezionare il server che si desidera utilizzare.

  3. Espandere la struttura del gruppo di archiviazione che si desidera utilizzare.

  4. Fare clic con il pulsante destro del mouse sull'archivio che si desidera utilizzare e scegliere Proprietà.

  5. Nella scheda Generale fare clic sull'elenco a discesa Pianificazione manutenzione e selezionare un intervallo, oppure scegliere Personalizza per creare una pianificazione personalizzata.

Per ulteriori informazioni sulle attività di manutenzione in linea del database, consultare l'articolo 159196 della Microsoft Knowledge Base "XADM: Attività controllate dalla pianificazione di manutenzione IS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196.


Il servizio Archivio informazioni di Exchange non è configurato per l'esecuzione come LocalSystem
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-02-27

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Services per determinare se l'account di avvio specificato sulla proprietà StartName del servizio Archivio informazioni di Microsoft Exchange (MSExchangeIS) sta utilizzando l'account LocalSystem. Se Exchange Server Analyzer rileva che il valore della proprietà in Exchange 2000 Server, Exchange Server 2003 o Exchange Server 2007 corrisponde a un account diverso da LocalSystem (noto anche come account SYSTEM), verrà visualizzato un avviso. L'avviso non viene generato nei computer Exchange Server 5.5, dove il servizio Archivio informazioni di Microsoft Exchange viene eseguito con un account utente.

Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007 devono essere avviati con il contesto di protezione LocalSystem anziché con un account utente specifico (e una password). In questo modo si evita che le modifiche della password e l'eliminazione dell'account utente compromettano il corretto funzionamento di Exchange. Quando un servizio di Exchange in esecuzione come LocalSystem esegue l'accesso a un server remoto, Microsoft Windows 2000 Server o Windows Server™ 2003 ne esegue l'autenticazione utilizzando le credenziali dell'account del computer.

La password sull'account del computer viene modificata ogni sette giorni mediante l'apposito meccanismo standard. Ciò contribuisce a rendere l'account del computer più sicuro rispetto a un tipico account utente in cui la password non solo viene modificata meno frequentemente, ma è anche meno casuale rispetto a una password di account del computer generata casualmente.

Alcuni amministratori esperti di Exchange Server 5.5, dove per i servizi viene utilizzato un account utente, modificano l'account di avvio dei servizi di Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007 dall'account LocalSystem predefinito a un account utente.

In Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007, non è supportata l'esecuzione del servizio Archivio informazioni di Microsoft Exchange con un account diverso da LocalSystem.

Per risolvere il problema

  1. Fare clic su Start, scegliere Programmi, Strumenti di amministrazione, quindi Servizi.

  2. Nell'elenco dei servizi fare clic con il pulsante destro del mouse su Archivio informazioni di Microsoft Exchange, quindi scegliere Proprietà.

  3. Nella scheda Connessione in Accedi come scegliere Account di sistema locale, quindi OK.

  4. Fare clic con il pulsante destro del mouse su Archivio informazioni di Microsoft Exchange e fare clic su Riavvia.

Per ulteriori informazioni sui servizi di Exchange, consultare l'articolo 239762 della Microsoft Knowledge base "Exchange Services Run Under LocalSystem", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Il servizio Archivio informazioni di Exchange non è in esecuzione
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il valore della chiave Started nel servizio Archivio informazioni di Microsoft Exchange è impostato su True o False.

Il valore False indica che il servizio Archivio informazioni di Microsoft Exchange non è attivo su questo computer che esegue Exchange Server. Il valore True indica che il servizio Archivio informazioni di Microsoft Exchange è attivo.

Exchange Server Analyzer analizza inoltre la classe WMI Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end che esegue Exchange Server 2003 o Exchange 2000 Server.

Se il valore per entrambe le chiavi valutate è False sui sistemi che eseguono Exchange 2000 Server ed Exchange Server 2003, verrà visualizzato un avviso.

Se per la chiave Win32_Service Started viene restituito il valore False e il computer Exchange Server esegue Exchange Server 2007, verrà visualizzato un avviso.

Se i tentativi di avviare il servizio Archivio informazioni di Microsoft Exchange hanno esito negativo, ciò potrebbe indicare un problema più grave nel computer che esegue Exchange Server. In questo caso, è preferibile analizzare i registri eventi per conoscere i dettagli che hanno causato l'errore. È inoltre opportuno assicurarsi di eseguire il più recente Service Pack per la versione di Exchange Server utilizzata.

È possibile ottenere il Service Pack più recente per Exchange Server 2003 dal sito "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25097 (informazioni in lingua inglese).

Per ulteriori informazioni sulle cause note degli errori relativi al servizio Archivio informazioni di Microsoft Exchange, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 827915, "Arresto imprevisto del servizio Archivio informazioni durante la conversione di un messaggio che non contiene la proprietà PR_MESSAGE_CLASS in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915.

  • 830602, "Interruzione di risposta da parte del servizio Archivio informazioni di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602.

  • 839115, "Il servizio Archivio informazioni non si avvia dopo l'aggiornamento a Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115.

  • 330197, "Arresto imprevisto del servizio Archivio informazioni durante il recapito locale di un messaggio Internet con un ID messaggio Internet null" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197.

  • 831130, "Il riquadro Cartelle non viene visualizzato o il servizio Archivio informazioni viene arrestato improvvisamente quando si utilizza OWA per accedere alla cassella postale sul computer Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130.

  • 823163, "Messaggio di errore 'l'installazione non può individuare un server di catalogo globale per qualificare' quando si tenta di avviare il servizio Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163.

  • 822579, "Dopo l'installazione di Exchange Server 2003 viene visualizzato l'ID evento 7024 e non è possibile avviare il servizio Archivio informazioni di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579.

  • 833841, "Interruzione di risposta imprevista da parte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841.

Per ulteriori informazioni sull'utilizzo di server front-end che eseguono Exchange Server 2003 ed Exchange 2000 Server, consultare i seguenti siti Web:

  • Using Microsoft Exchange 2000 Front-End Servers all'indirizzo http://go.microsoft.com/fwlink/?linkid=12055 (informazioni in lingua inglese).

  • Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology all'indirizzo http://go.microsoft.com/fwlink/?linkid=47567 (informazioni in lingua inglese).


Il servizio Archivio informazioni di Exchange non è in esecuzione su questo server front-end
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare i valori impostati per la chiave Started dei servizi Archivio informazioni di Microsoft Exchange e SMTP (Simple Message Transfer Protocol). Il valore False indica che il servizio non è in esecuzione. Il valore True indica che il servizio è in esecuzione.

Inoltre, Exchange Server Analyzer esamina la classe WMI (Strumentazione gestione Windows®) Exchange_Server nello spazio dei nomi root\MicrosoftExchangeV2 per determinare il valore della chiave IsFrontEndServer. Il valore False indica che il computer Exchange Server non è un server front-end. Il valore True indica che il computer Exchange Server è un server front-end.

Se Exchange Server Analyzer rileva che il valore di Started per il servizio SMTP è True, il valore di Started per il servizio Archivio informazioni di Microsoft Exchange è False e il valore di IsFrontEndServer è True, verrà visualizzato un avviso.

Exchange 2000 Server ed Exchange Server 2003 utilizzano server front-end per elaborare le richieste dei client POP3, IMAP4 e Microsoft Office Outlook® Web Access. Inoltre, possono essere utilizzati come server SMTP per Internet. Se questo server front-end accetta e instrada messaggi SMTP, se supporta i client IMAP (che utilizzano SMTP per l'inoltro dei messaggi) o se esegue software compatibile VSAPI (Virus Scan API), il servizio Archivio informazioni di Microsoft Exchange dovrà essere in esecuzione. In caso contrario, il server front-end non sarà in grado di elaborare i messaggi SMTP o analizzarli mediante VSAPI.

Se non viene utilizzato software antivirus compatibile VSAPI o SMTP su un server front-end, la configurazione consigliata è disconnettere ed eliminare tutti gli archivi di cartelle pubbliche situati nel server front-end, arrestare il servizio Archivio informazioni di Microsoft Exchange e impostarlo su Disabilitato. Inoltre, è necessario arrestare anche il servizio SMTP se non viene utilizzato. Nei computer Exchange Server che utilizzano software compatibile VSAPI o SMTP, è necessario che il servizio Archivio informazioni di Microsoft Exchange sia in esecuzione per poter recapitare i messaggi e rispondere ai client di messaggistica.

Per risolvere il problema

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio Archivio informazioni di Microsoft Exchange e scegliere Proprietà.

  3. Nella scheda Generale della pagina delle proprietà di Archivio informazioni di Microsoft Exchange accertarsi che l'opzione Tipo di avvio sia impostata su Automatico. Se non è impostata su Automatic, fare clic su Apply, quindi fare clic su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio Archivio informazioni di Microsoft Exchange e scegliere Avvia.

  5. Aprire lo snap-in Servizi.

Se i tentativi di avviare il servizio Archivio informazioni di Microsoft Exchange hanno esito negativo, ciò potrebbe indicare un problema più grave nel computer che esegue Exchange Server. In questo caso, è necessario esaminare i registri eventi per conoscere i dettagli che hanno causato l'errore. È inoltre opportuno assicurarsi di eseguire il più recente Service Pack per la versione di Exchange Server utilizzata. È possibile ottenere il Service Pack più recente di Exchange Server nella home page del sito Web "Microsoft Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21573.

Per ulteriori informazioni sulle cause note degli errori relativi al servizio Archivio informazioni di Microsoft Exchange, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 827915, "Arresto imprevisto del servizio Archivio informazioni durante la conversione di un messaggio che non contiene la proprietà PR_MESSAGE_CLASS in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827915.

  • 830602, "Interruzione di risposta da parte del servizio Archivio informazioni di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=830602.

  • 839115, "Il servizio Archivio informazioni non si avvia dopo l'aggiornamento a Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839115.

  • 330197, "Arresto imprevisto del servizio Archivio informazioni durante il recapito locale di un messaggio Internet con un ID messaggio Internet null" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=330197.

  • 831130, "Il riquadro Cartelle non viene visualizzato o il servizio Archivio informazioni viene arrestato improvvisamente quando si utilizza OWA per accedere alla cassetta postale sul computer Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=831130.

  • 823163, "Messaggio di errore 'Impossibile identificare il server di catalogo globale richiesto' quando si tenta di avviare il servizio Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823163.

  • 822579, "Dopo l'installazione di Exchange Server 2003 viene visualizzato l'ID evento 7024 e non è possibile avviare il servizio Archivio informazioni di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822579.

  • 833841, "Interruzione di risposta imprevista da parte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833841.

Per ulteriori informazioni sull'utilizzo dei server front-end, consultare la guida Exchange Server 2003 and Exchange 2000 Server Front-End and Back-End Topology all'indirizzo http://go.microsoft.com/fwlink/?linkid=47567 (informazioni in lingua inglese).


L'unità del file system installabile di Exchange è abilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-02-28

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il mapping della lettera unità IFS di Exchange (ExIFS o IFS) è abilitata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

Se Exchange Server Analyzer rileva che il valore del Registro di sistema DriveLetter è configurato con una lettera di unità (ad esempio, M), verrà visualizzato un messaggio di errore.

In Exchange 2000 Server è stata introdotta una funzione definita IFS. IFS è un driver a livello di kernel che replica alcuni dei dati dell'archivio informazioni di Exchange nel file system di Windows. Durante le nuove installazioni di Exchange 2000 Server e durante gli aggiornamenti a Exchange 2000 Server da Exchange Server 5.5, la funzione IFS viene installata automaticamente e una lettera di unità (per impostazione predefinita, la lettera M) viene assegnata e mappata all'archivio informazioni. L'operazione viene eseguita utilizzando lo spazio dei nomi \\.\BackOfficeStorage\.

Exchange Server 2003 supporta la funzione IFS, ma per impostazione predefinita il mapping della lettera unità è disabilitato. Il valore del Registro di sistema DriveLetter non è presente nelle nuove installazioni di Exchange Server 2003 o in un aggiornamento da Exchange 2000 Server a Exchange Server 2003, i dati relativi al valore del Registro di sistema e, di conseguenza, il mapping della lettera unità, vengono rimossi.

È consigliabile non abilitare il mapping della lettera unità IFS in Exchange Server 2003 e rimuoverlo in Exchange 2000 Server. Se si esegue l'accesso alla lettera di unità mappata all'unità IFS o se l'unità viene analizzata da applicazioni antivirus o basate su file system, possono verificarsi alcuni problemi noti. Di conseguenza, se la funzionalità IFS non viene utilizzata, è consigliabile rimuovere il mapping della lettera unità.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\EXIFS\Parameters

  3. Nel riquadro destro fare doppio clic sul valore DriveLetter.

  4. Nel campo Dati valore eliminare la lettera elencata in modo che il campo resti vuoto.

  5. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Supervisore sistema di Microsoft Exchange e il servizio Pubblicazione sul Web. Quando il servizio Supervisore sistema viene riavviato, verranno riavviati anche tutti i servizi che dipendono dal servizio Supervisore sistema, inclusi i servizi Microsoft Exchange - Stack Agente di trasferimento messaggi e Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla rimozione del mapping dell'unità M in Exchange 2000 Server, consultare l'articolo 305145 della Microsoft Knowledge Base "Rimozione della mappatura a IFS dell'unità M in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=305145.

Per ulteriori informazioni sull'aggiunta di mapping dell'unità M in Exchange 2003 Server, consultare l'articolo 821836 della Microsoft Knowledge Base "La mappatura a IFS dell'unità M non è presente per impostazione predefinita in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821836.


Configurazione e prestazioni del server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool ha rilevato che il server non è configurato per fornire prestazioni ottimali.

Durante l'esecuzione delle normali operazioni, i server di Exchange accedono a diversi file. La posizione dei file potrebbe contribuire a formare un collo di bottiglia delle prestazioni. Alcuni gruppi di file indipendenti, quali le unità dei registri di transazione, sono anche denominati risorse.

Se la distribuzione di queste risorse contribuisce alla formazione di un collo di bottiglia nel disco, è possibile che venga visualizzato un avviso o un messaggio di errore relativo alla posizione delle risorse nel server di Exchange. Per assicurarsi che risorse specifiche siano isolate da altre richieste di carico, collocare le risorse in una periferica di archiviazione dedicata. Nel seguente elenco vengono descritti l'utilizzo di ciascuna risorsa e i consigli relativi alla configurazione delle risorse.

  • Unità dei registri di transazione I file di registro delle transazioni mantengono lo stato e l'integrità dei file con estensione EDB e STM. Questo significa che i file di registro rappresentano realmente i dati. Esiste un file di registro delle transazioni per ciascun gruppo di archiviazione. Dal momento che i registri delle transazioni sono un componente fondamentale dei backup dei dati contenuti nei file di database del server di Exchange, prima di poter completare molte delle transazioni sui dati il server di Exchange deve eseguire il commit di tutti i dati nel file di registro. Qualsiasi ritardo nella scrittura sull'unità dei registri di transazione possono compromettere significativamente le prestazioni del server. È importante, pertanto, isolare le unità dei registri delle transazioni affinché ciascuna unità disponga di un sottosistema disco che non sia condiviso da nessun altro server, applicazione o risorsa. Per garantire prestazioni ottimali, assicurarsi che ciascun registro delle transazioni disponga di un'unità dedicata.

  • Posizione dell'unità TEMP Quando il sistema operativo viene installato per la prima volta, la posizione dei file temporanei viene impostata sulla stessa unità utilizzata dal sistema operativo. Di conseguenza, qualsiasi I/O verrebbe eseguito sulla stessa unità sulla quale viene eseguito l'I/O dei programmi e delle operazioni dei file di paging, compromettendo le prestazioni. L'unità TEMP viene utilizzata per il recapito della posta e per la conversione del contenuto di messaggi di grandi dimensioni. Se si forma un collo di bottiglia nell'unità TEMP, verranno compromessi il flusso di posta e alcune applicazioni client. Per evitare che l'I/O del sistema operativo e dell'unità TEMP venga eseguito suella stessa unità e per ridurre il rischio di compromettere le prestazioni del server di Exchange, si consiglia di:

    • Modificare l'impostazione globale di ambiente di TEMP in modo che faccia riferimento a un disco diverso.

    • Spostare l'unità TEMP su un disco dedicato.

  • Posizione dei file con estensione EDB e STM Il database di Exchange è costituito da due file:

    • File con estensione EDB (contenuto MAPI) In questo file vengono archiviati tutti i messaggi MAPI e le tabelle utilizzati dal processo Store.exe per individuare tutti i messaggi e i checksum del file con estensione EDB e del file con estensione STM, nonché i messaggi MAPI.

    • File con estensione STM (contenuto non MAPI) In questo file vengono archiviati i messaggi trasmessi con il relativo contenuto Internet nativo.

    Queste due estensioni di file possono essere incluse nello stesso volume disco, in quanto l'accesso è generalmente casuale per entrambe. Tuttavia, è importante non collocare i file con estensione EDB e STM sulla stessa unità in cui si trovano i registri delle transazioni. Si consiglia, inoltre, di collocare questi file su unità dedicate in base a ciascun gruppo di archiviazione per evitare un collo di bottiglia delle prestazioni sulle unità contenenti file di database.

  • Posizione della directory SMTP Nella coda SMTP vengono archiviati tutti i messaggi SMTP fino a quando non vengono scritti in un database (che può essere l'archivio delle cassette postali o l'archivio delle cartelle pubbliche) o inviati a un connettore o a un server diverso. Generalmente nelle code SMTP si verificano I/O casuali e di piccole dimensioni. In Exchange Server Analyzer verrà visualizzato un avviso se la directory SMTP si trova su un'unità condivisa da:

    • Un qualsiasi altro file di dati di Exchange

    • Le directory TEMP o TMP

    • Il file di paging

    • L'unità di sistema

    Se non si verifica alcun collo di bottiglia del disco nella directory SMTP, ignorare questo avviso. Al contrario, se il traffico indirizzato a questa unità è elevato e nell'unità si verifica un collo di bottiglia delle prestazioni, è possibile spostare la directory SMTP sulla stessa unità o aumentare la capacità dell'unità che contiene la directory SMTP.

  • Posizione del file di paging Il file di paging funge da estensione della memoria fisica. Nello specifico, il file di paging rappresenta la posizione in cui vengono archiviate le pagine non utilizzate o le pagine di cui il sistema avrà necessità in un secondo momento. Il file di paging viene sempre utilizzato, anche dai server che dispongono di una quantità sufficiente di memoria libera. L'uso costante del file di paging è dovuto al fatto che il sistema operativo tenta di archiviare soltanto le pagine necessarie e lo spazio libero sufficiente per le operazioni. Ad esempio, uno strumento di stampa utilizzato soltanto all'avvio potrebbe eseguire il paging su disco di una parte della memoria e non recuperarla più se lo strumento non viene mai utilizzato.

    Nei server in cui la memoria fisica è sottoposta a un notevole utilizzo, assicurarsi che ciascun accesso ai file di paging sia il più rapido possibile. Si consiglia di creare un secondo file di paging in un'unità dedicata al file di paging.

Ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alle prestazioni di Exchange Server, consultare Risoluzione dei problemi di prestazioni di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle procedure consigliate per la progettazione delle architetture di archiviazione, vedere Procedure consigliate comuni a più architetture all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72988.

  • Per ulteriori informazioni sulle dimensioni dei dischi, la latenza e le frequenze di I/O, vedere Calcolo dei requisiti di I/O del disco all'indirizzo http://go.microsoft.com/fwlink/?linkid=69747.


La porta TCP/IP dell'Archivio di Exchange è stata sostituita manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-03-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore della porta relativo all'interfaccia dell'archivio di Exchange è stato sostituito manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se Exchange Server Analyzer rileva che TCP/IP Port è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Il motivo più comune per cui questo valore viene configurato è quello di consentire ai client MAPI di connettersi a un server di Exchange situato sull'altro lato di un firewall. Questo scenario implica l'apertura di più porte su un firewall per consentire ai client Microsoft Office Outlook® 2003 o Outlook 2007 di connettersi mediante MAPI a un server di Exchange, in genere tramite Internet. Questa configurazione è supportata. Per ulteriori informazioni sulle modalità di configurazione dei client MAPI per la connessione a Exchange mediante firewall, consultare l'articolo 270836 della Microsoft Knowledge Base "Mapping statici delle porte in Exchange 2000 ed Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836. Tuttavia, se non si sta utilizzando questo scenario, è necessario rimuovere questa chiave del Registro di sistema.

L'implementazione consigliata per l'utilizzo di Outlook in modalità MAPI per connettersi a un server di Exchange tramite Internet consiste nell'utilizzare le funzioni RPC su HTTP reperibili in Microsoft Windows Server™ 2003, Exchange Server 2003, Outlook 2003, Exchange Server 2007, Outlook 2007 e Microsoft Windows® XP Professional. La modalità MAPI è stata precedentemente definita come modalità "Corporate" o "Workgroup".

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per rimuovere la chiave TCP/IP Port del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore del Registro di sistema denominato TCP/IP Port.

  4. Chiudere l'editor del Registro di sistema, quindi riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per implementare RPC su HTTP

  1. Esaminare "Exchange Server 2003 RPC over HTTP Deployment Scenarios" all'indirizzo http://go.microsoft.com/fwlink/?linkid=47577 (informazioni in lingua inglese).

  2. Esaminare l'articolo 833401 della Microsoft Knowledge Base "Configurazione di RPC su HTTP su un unico server in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833401.

  3. Esaminare l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi della connessione client RPC su HTTP in Office Outlook 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=827330.

  4. Esaminare "WebCast: Utilizzo di Microsoft Exchange su Internet (RPC/HTTP) con Microsoft Office Outlook 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=829134.


La porta TCP/IP dell'archivio di Exchnage ha un valore inferiore a 5000
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-01-11

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare l'impostazione di TCP/IP Port per l'archivio di Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\TCP/IP Port

Se Exchange Server Analyzer rileva che TCP/IP Port è impostato su un valore inferiore a 5000 (decimale), verrà visualizzato un avviso.

Se è necessario impostare TCP/IP Port su un valore statico, si consiglia di impostare un valore maggiore o uguale a 5000. Se si imposta un valore inferiore a 5000, il server di Exchange potrebbe interrompere l'attesa su quella porta e rimanere in questo stato fino al riavvio di un servizio. Il servizio da riavviare dipende dal componente di Exchange che è stato specificato a livello di codice.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare la chiave Porta TCP/IP del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Fare doppio clic sulla chiave TCP/IP Port e impostare il campo Dati valore su un valore intero superiore a 5000 (decimale).

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle impostazioni delle porte, vedere l'articolo 270836 della Microsoft Knowledge Base "Mapping statici delle porte in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270836.


Scrittura dei registri delle transazioni di Exchange in una partizione non NTFS
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-02-27

Messaggio di errore

Introduzione

Lo strumento Microsoft Exchange Analyzer interroga la classe di Microsoft Strumentazione gestione Windows (WMI) Win32_Directory per determinare il valore della chiave FSName per il percorso dei file registro transazioni di Exchange. Se Exchange Server Analyzer determina che il valore della chiave FSName non equivale a NTFS, verrà visualizzato un messaggio di errore.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in volumi non NTFS. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

Se viene riscontrato questo errore, sarà necessario spostare i registri delle transazioni in una cartella su un'unità NTFS. In alternativa, se l'unità in cui è archiviata la directory dei registri delle transazioni è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertire l'unità in NTFS.

Per spostare i registri delle transazioni in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, quindi il proprio gruppo amministrativo, espandere Server, fare clic con il pulsante destro del mouse sul gruppo di archiviazione e scegliere Proprietà.

  3. Nella scheda Generale, in Posizione registro transazioni, fare clic su Sfoglia.

  4. Inserire il percorso della nuova posizione dei file di registro, quindi fare clic su OK.

  5. Fare clic su OK.

Per spostare il percorso dei file registro transazioni di un gruppo di archiviazione di Exchange in Exchange Server 2007

  1. Seguire le istruzioni fornite nella documentazione principale di Exchange Server 2007, "Impostazione o modifica del percorso dei file di registro del gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80702.

Come alternativa alla procedura descritta sopra, se l'unità in cui sono archiviati i file è formattata come unità FAT, è possibile utilizzare lo strumento della riga di comando convert.exe per convertirla in unità NTFS. Per ulteriori informazioni sull'utilizzo dello strumento della riga di comando convert.exe per convertire una partizione FAT in una partizione NTFS, consultare l'articolo 214579 della Microsoft Knowledge Base: "Utilizzo di Convert.exe per convertire una partizione nel file system NTFS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579.


I registri delle transazioni vengono scritti in una cartella compressa
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Compressed relativo alla cartella contenente i registri delle transazioni dell'Archivio informazioni di Exchange. Se il valore di Compressed viene impostato su True per questa cartella, verrà visualizzato un messaggio di errore.

Quando viene recapitato un messaggio a Exchange, viene scritto nei registri delle transazioni prima di essere salvato nell'archivio e recapitato. In un computer che esegue Exchange 2000 Server o Exchange Server 2003, i registri delle transazioni vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Exchsrvr\mdbdata

In un computer che esegue Exchange Server 2007, i registri delle transazioni vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Microsoft\Exchange Server\Mailbox\<Nome gruppo archiviazione>

Microsoft non supporta l'archiviazione dei file di dati di Exchange in un volume NTFS compresso. Quando si esegue l'archiviazione dei file di dati di Exchange in un volume compresso, il sovraccarico aggiuntivo influisce notevolmente sulle prestazioni di Exchange. Inoltre, quando un database dell'archivio informazioni raggiunge una determinata dimensione (circa 4 GB), potrebbe presentare problemi di installazione o essere danneggiato.

I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

I file gestiti da Extensible Storage Engine (ESE) non sono progettati per l'archiviazione in un'unità compressa. L'Extensible Storage Engine dipende dall'indipendenza dei settori per il ripristino basato sui registri e la compressione dei file invalida tale indipendenza. La compressione non deve essere attivata per i volumi che ospitano database ESE o altri database che utilizzano la registrazione write-ahead.

Prima di Exchange 2000 Server Service Pack 3, era possibile installare database dell'archivio informazioni compressi. Tuttavia, i registri e i database dell'archivio informazioni di Exchange 2000 Server compressi mediante la compressione NTFS possono risultare danneggiati.

Con Exchange 2000 Server Service Pack 3, i file di database dell'archivio informazioni compressi di dimensione pari o inferiore a 128 MB vengono decompressi automaticamente. Se la dimensione dei file di database diventa maggiore di 128 MB, il database non verrà installato e nel registro applicazione verranno generati messaggi di errore. Exchange 2000 Server Service Pack 3 impedisce l'installazione dei database compressi di dimensioni superiori a 128 MB.

Per disattivare la compressione dei file di una specifica cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file e scegliere Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

Per spostare i registri delle transazioni in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo e Server, fare clic con il pulsante destro del mouse sul gruppo di archiviazione e scegliere Proprietà.

  3. Nella scheda Generale, in Posizione registro transazioni, fare clic su Sfoglia.

  4. Inserire il percorso della nuova posizione dei file di registro, quindi fare clic su OK.

  5. Fare clic su OK.

Per spostare il percorso dei file di registro delle transazioni di un gruppo di archiviazione di Exchange in Exchange Server 2007

  1. Seguire le istruzioni fornite nella documentazione principale di Exchange Server 2007, "Impostazione o modifica del percorso dei file di registro del gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80702.

Per ulteriori informazioni sullo spostamento dei file di registro in Exchange Server 2003, consultare l'articolo 821915 della Microsoft Knowledge Base "Spostamento dei database e dei registri di Exchange in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915.

Per ulteriori informazioni sullo spostamento dei file di registro in Exchange 2000 Server consultare l'articolo 239944 della Microsoft Knowledge Base "Spostamento dei registri di sistema o dei registri delle transazioni in una posizione diversa" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239944.


Scrittura dei registri delle transazioni di Exchange in una cartella crittografata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-02-27

Lo strumento Microsoft Exchange Server Analyzer esegue una query nella classe Microsoft Strumentazione gestione Windows (WMI) Win32_Directory per determinare il valore della chiave Encrypted relativo alla cartella contenente i registri delle transazioni dell'archivio informazioni. Se Exchange Analyzer rileva che il valore di Encrypted è impostato su True, verrà visualizzato un messaggio di errore.

Quando viene recapitato un messaggio a Exchange, viene scritto nei registri delle transazioni prima di essere salvato nell'archivio e recapitato. In un computer che esegue Exchange 2000 Server o Exchange Server 2003, i registri delle transazioni vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Exchsrvr\mdbdata

In un computer che esegue Exchange Server 2007, i registri delle transazioni vengono scritti nel seguente percorso predefinito:

<unità> :\Programmi\Microsoft\Exchange Server\Mailbox\<Nome gruppo archiviazione>

Microsoft non supporta l'archiviazione dei file di dati di Exchange in un volume crittografato EFS (Encrypting File System). Quando si archiviano i file di dati di Exchange in un volume crittografato, l'overhead aggiuntivo influenza in modo significativo le prestazioni di Exchange Server. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per proteggere i file di dati di Exchange, è consigliabile impedire l'accesso non autorizzato al computer che esegue Exchange e utilizzare il formato messaggio S/MIME per crittografare i dati dei messaggi.

Per correggere questo errore è necessario disattivare la crittografia dei file nella cartella di scrittura dei registri delle transazioni oppure spostare tali registri delle transazioni in una cartella in cui la crittografia non è abilitata.

Per disattivare la crittografia dei file in una cartella specifica

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la crittografia file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Crittografa contenuto per la protezione dei dati e scegliere OK.

Per spostare i registri delle transazioni in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Gruppi amministrativi, il proprio gruppo amministrativo e Server, fare clic con il pulsante destro del mouse sul gruppo di archiviazione e scegliere Proprietà.

  3. Nella scheda Generale, in Posizione registro transazioni, fare clic su Sfoglia.

  4. Inserire il percorso della nuova posizione dei file di registro, quindi fare clic su OK.

  5. Fare clic su OK.

Per spostare il percorso dei file di registro delle transazioni di un gruppo di archiviazione di Exchange in Exchange Server 2007

  1. Seguire le istruzioni fornite nella documentazione principale di Exchange Server 2007, "Impostazione o modifica del percorso dei file di registro del gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80702.

Per ulteriori informazioni sullo spostamento dei file di registro, consultare l'articolo 821915 della Microsoft Knowledge Base "Spostamento dei database e dei registri di Exchange in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821915.

Per ulteriori informazioni sui file di dati di Exchange Server e su EFS (Encrypting File System, Crittografia file system), consultare l'articolo 834638 della Microsoft Knowledge Base, "Information about the storage of data files on an encrypted volume in Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Per informazioni sulle modalità di protezione dei messaggi in Exchange Server 2003, consultare la Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47574.


I contatori di prestazioni ESE estesi sono abilitati
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se i contatori estesi ESE (Extensible Storage Engine) sono inclusi nella libreria dei contatori di prestazioni del server di Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ESE\Performance\Show Advanced Counters

Se Exchange Server Analyzer rileva che il valore dati della chiave Show Advanced Counters del Registro di sistema è stato impostato su 1, verrà visualizzato un messaggio di configurazione non predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per disabilitare i contatori di prestazioni ESE estesi

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Eliminare il valore Show Advanced Counters nella chiave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ESE\Performance nel Registro di sistema.

  3. Chiudere l'editor del Registro di sistema.

  4. Riavviare Performance Monitor per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


I contatori estesi di prestazioni dell'archivio sono abilitati
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se Mdbperfx.dll esiste nella libreria dei contatori di prestazioni del server di Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Performance

Se Exchange Server Analyzer rileva che il valore della libreria include la stringa "mdbperfx.dll", verrà visualizzato un messaggio di configurazione non predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Il file Mdbperf.dll della DLL contiene il set predefinito di contatori di prestazioni dell'archivio. Il file Mdbperfx.dll della DLL contiene lo stesso set di contatori di prestazioni dell'archivio e il set esteso dei contatori di prestazioni dell'archivio.

Per impostazione predefinita, i dati del valore della libreria includono il file Mdbperf.dll della DLL. Per impostazione predefinita, i dati del valore della libreria non contengono il file Mdbperfx.dll della DLL. Nella seguente tabella sono elencati i contatori estesi di prestazioni dell'archivio contenuti nel file Mdbperfx.dll della DLL.

Contatore | Destinazione
FXGetBufferRopsCalled | Numero totale delle operazioni RPC (Remote Procedure Call) di FXGetBuffer
FXGetBufferRopsCalledPerSec | Numero delle operazioni RPC di FXGetBuffer al secondo
FXGetBufferRopsAcceptedPerSec | Numero delle operazioni RPC di FXGetBuffer accettate al secondo
FXGetBufferRopsDenied | Numero totale delle operazioni RPC di FXGetBuffer negate
FXGetBufferRopsDeniedPerSec | Numero delle operazioni RPC di FXGetBuffer negate al secondo
FXGetBufferCurrentCallerCount | Numero delle operazioni RPC simultanee di FXGetBuffer
FXGetBufferCurrentUsersExecuting | Numero delle operazioni RPC simultanee di FXGetBuffer eseguite
Messaggi analizzati come MIME | Numero totale dei messaggi di livello superiore elaborati come MIME dal programma antivirus
Messaggi analizzati come MIME/sec | Frequenza con cui i messaggi di livello superiore vengono elaborati come MIME dal programma antivirus
Messaggi analizzati come MAPI | Numero totale dei messaggi di livello superiore elaborati come MIME dal programma antivirus
Messaggi analizzati come MAPI/sec | Frequenza con cui i messaggi di livello superiore vengono elaborati come MAPI dal programma antivirus
Byte letti | Numero totale dei byte letti dal programma antivirus
Byte scritti | Numero totale dei byte scritti dal programma antivirus
Lunghezza coda (priorità bassa) | Numero corrente delle richieste con priorità bassa in sospeso accodate per la ricerca virus
Thread | Numero corrente dei thread in un pool di thread utilizzato per la ricerca virus. Il totale non comprende il numero di thread utilizzati per la ricerca virus in background.
Controlli soddisfatti dall'indicatore MFT | Numero di volte in cui i controlli ricerca virus sono stati soddisfatti dall'indicatore nella tabella delle cartelle dei messaggi (MTF, Message Folder Table)
Controlli soddisfatti dall'indicatore MFT/sec | Frequenza con cui i controlli ricerca virus sono stati soddisfatti dall'indicatore nella tabella delle cartelle dei messaggi (MTF, Message Folder Table)
Controlli soddisfatti dall'indicatore di istanza | Numero di volte in cui i controlli ricerca virus sono stati soddisfatti dall'indicatore di istanza
Controlli soddisfatti dall'indicatore di istanza/sec | Numero di volte in cui i controlli ricerca virus sono stati soddisfatti dall'indicatore di istanza principale
Controlli soddisfatti dall'indicatore di istanza principale/sec | Frequenza con cui i controlli ricerca virus sono stati soddisfatti dall'indicatore di istanza principale
Controlli non soddisfatti | Numero di volte in cui i controlli ricerca virus non sono stati soddisfatti da alcun indicatore
Controlli non soddisfatti/sec | Frequenza con cui i controlli ricerca virus non sono stati soddisfatti da alcun indicatore
Controlli bloccati | Numero di volte in cui l'elaborazione è stata bloccata in attesa del completamento della ricerca
Controlli bloccati/sec | Frequenza con cui l'elaborazione è stata bloccata in attesa del completamento della ricerca
Timeout controllo | Numero di volte in cui si è verificato il timeout delle operazioni in attesa del completamento della ricerca virus
Timeout controllo/sec | Frequenza con cui si è verificato il timeout delle operazioni in attesa del completamento della ricerca virus
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per abilitare solo i contatori di prestazioni dell'archivio predefiniti

  1. Avviare un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Individuare il valore della libreria nella seguente chiave del Registro di sistema:

    HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance

  3. Scegliere Modifica dal menu Modifica.

  4. Nella casella Dati valore modificare il valore c:\Programmi\Exchsrvr\bin\mdbperfx.dll in c:\Programmi\exchsrvr\bin\mdbperf.dll.

  5. Fare clic su OK, quindi chiudere l'editor del Registro di sistema.

  6. Riavviare Performance Monitor per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla raccolta di dati relativi alle prestazioni dell'archivio di Exchange, consultare l'articolo 821912 della Microsoft Knowledge Base "Raccolta dei dati di diagnostica per la risoluzione dei problemi dell'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821912.


Parametro FXGetBuffer Backoff Constant non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la chiave del Registro di sistema indicata di seguito, per determinare se è stato creato il valore FXGetBuffer Backoff Constant:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che è stato creato il valore FXGetBuffer Backoff Constant nella chiave ParametersSystem del Registro di sistema è configurata, verrà visualizzato un messaggio di configurazione non predefinita.

È possibile utilizzare il valore FXGetBuffer Backoff Constant per controllare il numero dei client Microsoft Office Outlook® sincronizzati con un server di Exchange Server 2003 in un determinato momento. Il valore FXGetBuffer Backoff Constant viene impostato per configurare l'intervallo di tempo di attesa del client Outlook prima di eseguire un nuovo tentativo di sincronizzazione. Il valore predefinito di FXGetBuffer Backoff Constant è 500 millisecondi.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione. Tuttavia, se si desidera ripristinare la configurazione predefinita, è possibile eliminare la chiave FXGetBuffer Backoff Constant del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore FXGetBuffer Backoff Constant.

  4. Chiudere l'editor del Registro di sistema.

Il servizio Archivio informazioni di Microsoft Exchange impiega pochi minuti per rilevare le modifiche. Non è necessario riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione delle chiavi del Registro di sistema per controllare il numero di client Outlook che possono sincronizzarsi con Exchange Server 2003, consultare l'articolo 818484 della Microsoft Knowledge Base "Contatori e valori del Registro di sistema per configurare e monitorare la sincronizzazione dei client Outlook" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484.


Parametro FXGetBuffer Retry Count non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se il valore FXGetBuffer Retry Count è stato creato:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che il valore FXGetBuffer Retry Count è stato creato nella chiave del Registro di sistema ParametersSystem, verrà visualizzato un messaggio di configurazione non predefinita.

È possibile utilizzare il valore FXGetBuffer Retry Count per controllare il numero dei client Microsoft Office Outlook® 2003 sincronizzati con un server di Exchange Server 2003 in un determinato momento. Per configurare il numero di volte in cui un client Outlook può tentare di sincronizzarsi prima che gli si conceda l'accesso, occorre impostare il valore FXGetBuffer Retry Count. Il valore predefinito è 10.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione. Tuttavia, se si desidera ripristinare la configurazione predefinita, è possibile eliminare la chiave FXGetBuffer Retry Count del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore FXGetBuffer Retry Count.

  4. Chiudere l'editor del Registro di sistema.

Il servizio Archivio informazioni di Microsoft Exchange impiega pochi minuti per rilevare le modifiche. Non è necessario riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione delle chiavi del Registro di sistema per controllare il numero di client Outlook che possono sincronizzarsi con Exchange Server 2003, consultare l'articolo 818484 della Microsoft Knowledge Base "Valori del Registro di sistema e contatori che è possibile utilizzare per configurare e monitorare la sincronizzazione di client Outlook" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484.


Parametro Ignore Bad Oof Rule del Registro di sistema impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge il Registro di sistema del computer che esegue Exchange Server per verificare la presenza della voce Ignore Bad Oof Rule. Questo valore del Registro di sistema si trova in:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

Se Exchange Server Analyzer rileva che la voce Ignore Bad Oof Rule del Registro di sistema è presente e configurata con un valore pari a 1 o maggiore, verrà visualizzato un messaggio di configurazione non predefinita.

La voce Ignore Bad Oof Rule del Registro di sistema è un'impostazione di configurazione di Exchange 2000 Server, Exchange Server 2003 ed Exchange Server 2007, progettata specificamente per l'utilizzo dell'aggiornamento rapido descritto nell'articolo 828875 della Microsoft Knowledge Base, "Impossibile spostare una cassetta postale di Exchange dopo l'utilizzo di Exmerge.exe", all'indirizzohttp://go.microsoft.com/fwlink/?LinkID=3052&kbid=828875.

Quando il programma di unione delle cassette postali di Microsoft Exchange (Exmerge.exe) viene utilizzato per spostare messaggi e altri elementi da una cassetta postale di un archivio delle cassette postali a una cassetta postale di un altro archivio, un successivo tentativo di spostare la seconda cassetta potrebbe avere esito negativo. Questo problema può verificarsi a causa di una regola Fuori sede errata in tale cassetta postale. Se lo si desidera, è possibile ripristinare la configurazione predefinita mediante la procedura descritta di seguito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di conoscere le operazioni per ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Nel riquadro destro individuare ed eliminare il valore Ignore Bad Oof Rule.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il parametro Ignore Zombie Users del Registro di sistema è stato impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool verifica il Registro di sistema del computer che esegue Exchange Server per verificare la presenza della voce Ignore Zombie users del Registro di sistema. Questo valore del Registro di sistema si trova in:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che la voce Ignore Zombie users del Registro di sistema è presente e configurata con un valore pari a 1 o maggiore, verrà visualizzato un messaggio di configurazione non predefinita.

In un'organizzazione a modalità mista Exchange Server che contiene Exchange Server 5.5 e Exchange 2000 Server o in un ambiente precedentemente a modalità mista, si potrebbero verificare dei problemi se le seguenti condizioni vengono soddisfatte:

  • È stato eseguito l'aggiornamento dell'elenco di controllo di accesso (ACL) delle cassette postali e delle cartelle pubbliche da Exchange Server 5.5 a Exchange 2000 Server.

  • L'elenco di controllo di accesso (ACL) contiene account utente che non sono rappresentati nel servizio directory di Active Directory®.

Queste voci del controllo di accesso non utilizzate (ACE) vengono anche definite utenti zombie. A partire dalla patch cumulativa successiva al Service Pack 3 per Exchange 2000 Server del marzo 2003, il comportamento predefinito per l'elaborazione degli utenti non validi è stato modificato. È possibile controllare questo comportamento utilizzando la chiave Ignore Zombie users del Registro di sistema.

Il valore Ignore Zombie users del Registro di sistema può essere utilizzato sui server sui quali è installato il Server Service Pack 3 di Exchange 2000 o versioni successive. Questa voce del Registro di sistema dovrebbe essere utilizzata con cautela e solo quando è stato accertato che gli utenti non validi non risultano da problemi di replica dell'ADC, come la latenza. Questo valore del Registro di sistema consente a Exchange Server di ignorare gli utenti zombie e li rimuove dell'elenco di controllo di accesso (ACL) delle cassette postali o delle cartelle pubbliche. Se l'utente è valido ma non è presente in Active Directory al momento dell'aggiornamento dell'elenco di controllo di accesso (ACL), l'utente verrà rimosso e sarà necessario aggiungerlo manualmente a ciascun elenco di controllo di accesso (ACL) in un secondo momento.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro individuare ed eliminare il valore Ignore Zombie users.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione della chiave Ignore Zombie Users del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 812963, "Utilizzo della chiave Ignore Zombie Users del Registro di sistema" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812963.

  • 324323, "XADM: Ignorare gli account utenti non rappresentati nell'Active Directory durante la conversione dell'elenco di controllo di accesso" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=324323.


La gestione delle eccezioni IMAIL è stata disabilitata manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool esamina la voce del Registro di sistema indicata di seguito per determinare l'impostazione del valore del Registro di sistema ExceptionHandling:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se Exchange Server Analyzer rileva che il valore ExceptionHandling del Registro di sistema è configurato con un valore pari a 0, verrà visualizzato un avviso.

In Exchange Server, la gestione delle eccezioni IMAIL è attivata per impostazione predefinita e non può essere disattivata tramite l'interfaccia utente. Tuttavia, la gestione delle eccezioni IMAIL può essere disattivata utilizzando il Registro di sistema.

Microsoft consiglia di non disattivare la gestione delle eccezioni IMAIL, a meno che l'utente non stia risolvendo attivamente un problema. Ad esempio, è possibile disattivare la gestione delle eccezioni IMAIL se si dispone di applicazioni personalizzate che generano eventi basati su contenuto MIME (Multipurpose Internet Mail Extensions) o MAPI errato. Microsoft consiglia di disattivare la gestione delle eccezioni IMAIL solo su indicazione dei professionisti addetti al Servizio Supporto Tecnico Clienti Microsoft.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent.

  3. Fare doppio clic su ExceptionHandling.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore ExceptionHandling del Registro di sistema, consultare l'articolo 832174 della Microsoft Knowledge Base Non esiste alcuna opzione per disattivare la gestione delle eccezioni IMAIL in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832174.


Il servizio Archivio informazioni è configurato per interagire con il desktop
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della proprietà DesktopInteract per il servizio Archivio informazioni di Microsoft Exchange (MSExchangeIS). Se Exchange Server Analyzer rileva che il servizio Archivio informazioni è configurato per interagire con il desktop, verrà visualizzato un messaggio di errore.

Questa configurazione dovrebbe essere utilizzata solo dietro la guida del Servizio Supporto Tecnico Clienti Microsoft. Se non sono state fornite istruzioni dal Servizio Supporto Tecnico Clienti Microsoft per eseguire il servizio Archivio informazioni in questa configurazione, è consigliabile riconfigurare le proprietà del servizio Archivio informazioni in modo che non interagisca con il desktop.

Per configurare l'account del servizio Archivio informazioni di Exchange

  1. Aprire lo snap-in MMC Servizi.

  2. Individuare e arrestare il servizio Archivio informazioni di Microsoft Exchange.

  3. Fare doppio clic sul servizio Archivio informazioni di Microsoft Exchange.

  4. Nella scheda Connessione della pagina delle proprietà del servizio Archivio informazioni di Microsoft Exchange selezionare Account di sistema locale in Accedi come.

  5. Deselezionare la casella di controllo Consenti al servizio di interagire col desktop e fare clic su Applica.

  6. In Stato del servizio fare clic su Avvia e quindi su OK.

  7. Chiudere lo snap-in Servizi.

Per ulteriori informazioni sulla corretta configurazione dei servizi di Exchange, consultare l'articolo 239762 della Microsoft Knowledge Base "Esecuzione dei servizi di Exchange in LocalSystem" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Aumentare la dimensione massima del database per l'archivio delle cassette postali
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_DataFile per determinare le seguenti informazioni:

  • Percorso completo dei file di database di Exchange.

  • Dimensione corrente dell'archivio delle cassette postali.

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_OperatingSystem per determinare ulteriori informazioni:

  • Versione del sistema operativo in esecuzione sul server di Exchange.

  • Versione di Exchange Server installata.

  • Edizione di Exchange Server installata.

  • Versione del livello di Service Pack per Exchange Server.

Infine Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se il valore Database Size in Gb è stato impostato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nome del server>\Private-<MailboxStoreGUID>

Se si verificano le seguenti condizioni, in Exchange Server Best Practices Analyzer verrà visualizzato un messaggio di errore:

  • Nel server è in esecuzione Exchange Server 2003.

  • È installato il Service Pack 2 di Exchange Server 2003.

  • La dimensione del database di Exchange Server è maggiore di 16 GB.

  • Il valore del Registro di sistema Database Size in Gb non è stato impostato.

Questo errore indica che è stata quasi raggiunta la dimensione limite del database di Exchange identificato. Il Service Pack 2 di Exchange Server 2003 porta i limiti di archiviazione del database da 16 GB a 75 GB. Tuttavia, per utilizzare i nuovi limiti è necessario aggiungere manualmente il valore del Registro di sistema Database Size in Gb nel server di Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema aggiungendo il valore del Registro di sistema Database Size in Gb

  1. Nel computer che esegue Exchange Server, aprire un editor del Registro di sistema quale, ad esempio, Regedit.exe o RegEdt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome del server>\Private-<MailboxStoreGUID>

  3. Fare clic con il pulsante destro del mouse su MailboxStoreGUID, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Per il nuovo nome del valore, digitare Database Size Limit in Gb.

  5. Fare doppio clic su Database Size Limit in Gb. Nel campo Dati valore digitare un valore appropriato in GB per la dimensione massima dei database. Fare clic su OK.

  6. Fare clic con il pulsante destro del mouse su MailboxStoreGUID, scegliere Nuovo, quindi fare clic su Valore DWORD.

  7. Per il nuovo nome del valore, digitare Database Size Buffer in Percentage.

  8. Fare doppio clic su Database Size Buffer in Percentage. In Dati valore digitare un valore compreso tra 1 e 100 per specificare quando devono essere registrati gli eventi di avviso indicanti che si sta raggiungendo il limite massimo per un database. Fare clic su OK.

    Nota:
    Il valore predefinito 10 provoca la registrazione di eventi di avviso quando resta una capacità del 10% prima che venga raggiunta la dimensione massima del database.

  9. Fare clic con il pulsante destro del mouse su MailboxStoreGUID, scegliere Nuovo, quindi fare clic su Valore DWORD.

  10. Per il nuovo nome, digitare Database Size Check Start Time in Hours From Midnight.

  11. Fare doppio clic su Database Size Check Start Time in Hours From Midnight. In Dati valore digitare un valore compreso tra 0 e 23 per specificare quando si desidera che venga eseguita una verifica della dimensione dei database. Fare clic su OK.

    Nota:
    Il valore predefinito 5 provoca la verifica della dimensione dei database 5 ore dopo la mezzanotte (05:00).

  12. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle modalità di configurazione e gestione dei limiti di dimensione dei database di Exchange Server, vedere "Database Size Limit Configuration and Management" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=57029 (informazioni in lingua inglese).

Per ulteriori informazioni sulla dimensione massima del database che può essere raggiunta in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition, consultare l'articolo 828070 della Microsoft Knowledge Base "Mancata installazione dell'archivio delle cassette postali di Exchange Server quando il database dell'archivio delle cassette postali raggiunge il limite di 16 GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Per ulteriori informazioni su SP2 per Exchange Server 2003, consultare la pagina Web dedicata al Service Pack 2 di Exchange Server 2003 dal titolo "Why Try Service Pack 2 for Exchange Server 2003?" all'indirizzo (http://go.microsoft.com/fwlink/?LinkId=52073).


Aumentare la dimensione massima del database per l'archivio delle cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_DataFile per determinare le seguenti informazioni:

  • Percorso completo dei file di database di Exchange Server.

  • Dimensione corrente dell'archivio delle cartelle pubbliche.

Exchange Server Analyzer esegue inoltre una query nella classe WMI Win32_OperatingSystem per determinare ulteriori informazioni:

  • Versione del sistema operativo in esecuzione sul server di Exchange.

  • Versione di Exchange Server installata.

  • Edizione di Exchange Server installata.

  • Versione del livello di Service Pack per Exchange Server.

Infine Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se il valore Database Size in Gb è stato impostato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nome del server>\Public-<PublicStoreGUID>

Se si verificano le seguenti condizioni, in Exchange Server Best Practices Analyzer verrà visualizzato un messaggio di errore:

  • Nel server è in esecuzione Exchange Server 2003.

  • È installato il Service Pack 2 di Exchange Server 2003.

  • La dimensione del database di Exchange è maggiore di 16 GB.

  • Il valore del Registro di sistema Database Size in Gb non è stato impostato.

Questo errore indica che è stata quasi raggiunta la dimensione limite del database di Exchange Server identificato. Il Service Pack 2 di Exchange Server 2003 porta i limiti di archiviazione del database da 16 GB a 75 GB. Tuttavia, per utilizzare i nuovi limiti è necessario aggiungere manualmente il valore del Registro di sistema Database Size in Gb nel server di Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema aggiungendo il valore del Registro di sistema Database Size in Gb

  1. Nel computer che esegue Exchange Server, aprire un editor del Registro di sistema quale, ad esempio, Regedit.exe o RegEdt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome del server>\Public-<PublicStoreGUID>

  3. Fare clic con il pulsante destro del mouse su PublicStoreGUID, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Per il nuovo nome del valore, digitare Database Size Limit in Gb.

  5. Fare doppio clic su Database Size Limit in Gb. Nel campo Dati valore digitare un valore appropriato in GB per la dimensione massima dei database. Fare clic su OK.

  6. Fare clic con il pulsante destro del mouse su PublicStoreGUID, scegliere Nuovo, quindi fare clic su Valore DWORD.

  7. Per il nuovo nome del valore, digitare Database Size Buffer in Percentage.

  8. Fare doppio clic su Database Size Buffer in Percentage. In Dati valore digitare un valore compreso tra 1 e 100 per specificare quando devono essere registrati gli eventi di avviso indicanti che si sta raggiungendo il limite massimo per un database. Fare clic su OK.

    Nota:
    Il valore predefinito 10 provoca la registrazione di eventi di avviso quando resta una capacità del 10% prima che venga raggiunta la dimensione massima del database.

  9. Fare clic con il pulsante destro del mouse su PublicStoreGUID, scegliere Nuovo, quindi fare clic su Valore DWORD.

  10. Per il nuovo nome, digitare Database Size Check Start Time in Hours From Midnight.

  11. Fare doppio clic su Database Size Check Start Time in Hours From Midnight. In Dati valore digitare un valore compreso tra 0 e 23 per specificare quando si desidera che venga eseguita una verifica della dimensione dei database. Fare clic su OK.

    Nota:
    Il valore predefinito 5 provoca la verifica della dimensione dei database 5 ore dopo la mezzanotte (05:00).

  12. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle modalità di configurazione e gestione dei limiti di dimensione dei database di Exchange, vedere "Database Size Limit Configuration and Management" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=57029 (informazioni in lingua inglese).

Per ulteriori informazioni sulla dimensione massima del database che può essere raggiunta in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition, consultare l'articolo 828070 della Microsoft Knowledge Base "Mancata installazione dell'archivio delle cassette postali di Exchange Server quando il database dell'archivio delle cassette postali raggiunge il limite di 16 GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Per ulteriori informazioni su SP2 per Exchange Server 2003, consultare la pagina Web dedicata al Service Pack 2 di Exchange Server 2003 dal titolo "Why Try Service Pack 2 for Exchange Server 2003?" all'indirizzo (http://go.microsoft.com/fwlink/?LinkId=52073).


Aumentare l'impostazione dei buffer di registro per i registri delle transazioni
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha determinato che il numero di buffer di registro sul server è troppo basso. È stato infatti rilevato che il valore Database (Istanza archivio informazioni)\Record di registro bloccati al secondo del server è maggiore di 10. Un valore maggiore di 10 indica che è in corso una scrittura di backup nel registro delle transazioni. Questa situazione può verificarsi perché è stato superato il limite di velocità effettiva dell'unità dei registri delle transazioni o perché i buffer di registro sono impostati su un valore troppo basso.

Le operazioni di I/O di scrittura nel registro sono sequenziali e a thread singolo, quindi la latenza sull'I/O di registro rappresenta spesso un collo di bottiglia per il sistema. Le operazioni di I/O di registro vengono scritte nei buffer di registro, che vengono quindi cancellati con un commit non-lazy o di capacità. Con commit non-lazy il buffer di registro viene immediatamente scritto sul disco. Con commit di capacità, invece, il buffer di registro viene scritto sul disco quando il buffer si riempie.

L'incremento della dimensione dei buffer di registro riduce la frequenza degli svuotamenti per limite di capacità, aumenta la dimensione delle scritture nel registro e riduce di conseguenza la latenza globale delle scritture nel registro. La riduzione della latenza delle scritture I/O nel registro rappresenta un metodo efficace per migliorare le prestazioni e la scalabilità della distribuzione di Exchange.

È quindi sempre consigliabile aumentare la dimensione del buffer fino al limite massimo di 9.000 per Exchange Server 2003 e 512 per Exchange 2000 Server.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=ExchangeOrganizationName.

  3. Espandere CN=Administrative Groups, CN=AdministrativeGroupName e infine CN=Servers.

  4. Espandere CN=ExchangeServerName, CN=InformationStore, fare clic col pulsante destro del mouse su CN=Storage Group Name, infine su Proprietà.

  5. Nella casella Selezionare una proprietà da visualizzare fare clic su msExchESEParamLogBuffers.

  6. Nella casella Modifica attributo digitare il valore appropriato alla versione di Exchange di msExchESEParamLogBuffers, quindi fare clic su Imposta.

    Nota:
    Per i computer che eseguono Exchange 2000 Server, Exchange 2000 Server Service Pack 1 (SP1), Exchange 2000 Server SP2 o Exchange 2000 SP3, impostare il valore su 512. Per i computer che eseguono la versione originale di Exchange Server 2003 o Exchange Server 2003 SP1, impostare il valore su 9.000.

  7. Fare clic su Applica, quindi su OK.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare il documento Risoluzione dei problemi di prestazioni di Microsoft Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

  • Per ulteriori informazioni sull'utilizzo dei buffer di registro, consultare l'articolo 328466 della Microsoft Knowledge Base "Buffer di registro ESE impostati su valori troppo bassi possono causare l'interruzione delle risposte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328466.


Initial memory percentage impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se il valore Initial Memory Percentage è stato impostato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che il valore Initial Memory Percentage è presente ed è impostato su un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

L'impostazione Initial Memory Percentage del Registro di sistema è stata introdotta come meccanismo per la regolazione ottimale della quantità iniziale di memoria allocata nell'Archivio informazioni di Exchange al 10 % della memoria fisica totale nel server di Exchange. Cominciando con questa allocazione iniziale, la frammentazione della memoria virtuale non si verifica così frequentemente. Questo valore del Registro di sistema non deve essere impostato arbitrariamente e deve essere utilizzato solo su indicazione dei professionisti addetti al Servizio Supporto Tecnico Clienti Microsoft (PSS).

Le versioni di Exchange Server a partire da Exchange Server 2003 includono il supporto per speciali opzioni di avvio in Microsoft Windows® 2000 Advanced Server e Windows Server™ 2003 che consente di ridurre la frammentazione della memoria virtuale; sono state eseguite anche ulteriori modifiche per evitare la frammentazione della memoria virtuale nei cluster di Exchange Server. Pertanto, il valore Initial Memory Percentage del Registro di sistema non è più necessario nelle versioni di Exchange Server a partire da Exchange Server 2003.

Il valore Initial Memory Percentage del Registro di sistema funziona solo in computer che eseguono Exchange 2000 Server. Exchange Server 2003 ed Exchange Server 2007 ignorano questo valore, se presente, per cui il valore non ha alcun effetto. È pertanto opportuno rimuovere questa voce del Registro di sistema prima di eseguire l'aggiornamento di Exchange Server da Exchange 2000 Server a Exchange Server 2003.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per rimuovere l'impostazione Initial Memory Percentage del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro eliminare il valore Initial Memory Percentage.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.
  • Per ulteriori informazioni sui problemi che si verificano quando si utilizza questo valore del Registro di sistema, consultare l'articolo 810883 della Microsoft Knowledge Base "Il valore 'Initial Memory Percentage' del Registro di sistema non ha alcun effetto" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810883.

  • Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.


Voce Initial Reserve Size KB del Registro di sistema impostata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-04-27

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se è presente la voce Initial Reserve Size KB del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che il valore Initial Reserve Size KB è presente ed è impostato su un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Initial Reserve Size KB del Registro di sistema viene utilizzato per riservare memoria aggiuntiva per lo spazio heap. Il valore specificato è in kilobyte (KB). Il valore predefinito nella maggior parte dei server di Exchange è pari a 655360 KB, che equivalgono a 640 MB. È possibile ridurre questo valore per aumentare la quantità di memoria libera disponibile e ridurre la frammentazione della memoria virtuale. Questo valore deve essere impostato solo su suggerimento dei professionisti addetti al Servizio Supporto Tecnico Clienti Microsoft. Questo è un messaggio puramente informativo, pertanto non è necessario intraprendere alcuna azione correttiva se il valore del Registro di sistema è stato impostato su indicazione dei professionisti addetti al Servizio Supporto Tecnico Clienti Microsoft.

In caso di dubbio sull'impostazione corretta della voce del Registro di sistema, è possibile rimuoverla e ripristinare la configurazione predefinita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

  3. Eliminare il valore Initial Reserve Size KB.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla frammentazione della memoria virtuale, consultare l'articolo della Microsoft Knowledge Base "HOW TO: Risoluzione del problema della frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.


L'attributo legacyExchangeDN per il database di Exchange non corrisponde al server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo legacyExchangeDN per tutti i database dell'archivio delle cassette postali in un computer Exchange Server. Se Exchange Server Analyzer rileva che il valore dell'attributo legacyExchangeDN in qualsiasi archivio delle cassette postali non corrisponde a quello del computer Exchange Server che contiene l'archivio delle cassette postali, verrà visualizzato un messaggio di errore.

La mancanza di corrispondenza dell'attributo legacyExchangeDN potrebbe derivare da modifiche di Active Directory apportate da un amministratore per ripristinare un database in una situazione di ripristino di emergenza. Per risolvere il problema è necessario modificare l'attributo legacyExchangeDN utilizzando un editor di Active Directory come lo strumento LDP (ldp.exe) o ADSI Edit (Active Directory Service Interfaces).

Per assicurarsi che l'attributo legacyExchangeDN sia corretto, esaminare l'attributo legacyExchangeDN del server in cui si trova il database poiché, essendo un oggetto figlio del server, questo database avrà lo stesso attributo legacyExchangeDN.

È inoltre necessario esaminare gli altri database del server di Exchange che non hanno generato l'errore, perché potrebbero avere lo stesso attributo legacyExchangeDN. Esistono molti altri oggetti di sistema che presentano questo attributo. In una situazione in cui l'attributo legacyExchangeDN non corrisponde in un database, è probabile che la mancanza di corrispondenza si verifichi anche in molti altri oggetti di sistema. Pertanto, se si utilizza LDP o ADSI Edit per correggere un valore legacyExchangeDN, sarà necessario effettuare questa operazione anche per tutti gli altri oggetti di sistema.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Espandere Configuration [DomainName], quindi CN=Configuration,DC=DomainName,DC=DomainSuffix.

  3. Espandere CN=Services, quindi CN=Microsoft Exchange.

  4. Espandere CN=OrganizationName, quindi CN=Administrative Groups e infine CN=AdminGroupName.

  5. Espandere CN=Servers, quindi CN=ServerName e infine CN=InformationStore.

  6. Selezionare CN=StorageGroupName e nel riquadro destro fare clic con il pulsante destro del mouse sull'archivio delle cassette postali il cui attributo legacyExchangeDN non corrisponde, quindi scegliere Proprietà.

  7. Scorrere verso il basso fino a legacyExchangeDN, selezionarlo e fare clic su Modifica.

  8. Nel campo Valore immettere il corretto attributo legacyExchangeDN.

  9. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il computer che esegue Exchange Server.

Per ulteriori informazioni sull'utilizzo di ADSI Edit per creare un nuovo attributo legacyExchangeDN, consultare l'articolo 273863 della Microsoft Knowledge Base "Modifica dell'attributo LegacyExchangeDN in modalità nativa con ADSI Edit" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863.


Il valore legacyExchangeDN manca dal database di Exchange
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo legacyExchangeDN per tutti i database dell'archivio delle cassette postali in un computer Exchange Server. Se Exchange Server Analyzer non rileva un valore per l'attributo legacyExchangeDN su alcun archivio delle cassette postali, verrà visualizzato un messaggio di errore.

La mancanza di un attributo legacyExchangeDN potrebbe derivare da modifiche di Active Directory apportate da un amministratore per ripristinare un database in una situazione di ripristino di emergenza. Per risolvere il problema è necessario modificare l'attributo legacyExchangeDN utilizzando un editor di Active Directory come lo strumento LDP (ldp.exe) o ADSI Edit (Active Directory Service Interfaces).

Per assicurarsi che l'attributo legacyExchangeDN sia corretto, esaminare l'attributo legacyExchangeDN del server in cui si trova il database poiché, essendo un oggetto figlio del server, questo database avrà lo stesso attributo legacyExchangeDN.

È inoltre necessario esaminare gli altri database del server di Exchange che non hanno generato l'errore, perché potrebbero avere lo stesso attributo legacyExchangeDN. Esistono molti altri oggetti di sistema che presentano questo attributo. In una situazione in cui l'attributo legacyExchangeDN manca in un database, è probabile che manchi anche in molti altri oggetti di sistema. Pertanto, se si utilizza LDP o ADSI Edit per aggiungere un nuovo valore legacyExchangeDN, sarà necessario effettuare questa operazione anche per tutti gli altri oggetti di sistema.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Espandere Configurazione[NomeDominio], espandere CN=Configuration, DC=NomeDominio,DC=SuffissoDominio.

  3. Espandere CN=Services, quindi CN=Microsoft Exchange.

  4. Espandere CN=NomeOrganizzazione, quindi CN=Administrative Groups e infine CN=NomeGruppoAmministrativo.

  5. Espandere CN=Servers, quindi CN=NomeServer e infine CN=InformationStore.

  6. Selezionare CN=StorageGroupName e nel riquadro destro fare clic con il pulsante destro del mouse sull'archivio delle cassette postali il cui attributo legacyExchangeDN è mancante, quindi scegliere Proprietà.

  7. Scorrere verso il basso fino a individuare legacyExchangeDN, selezionarlo e fare clic su Modifica.

  8. Nel campo Valore immettere il corretto attributo legacyExchangeDN.

  9. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il computer che esegue Exchange Server.

Per ulteriori informazioni sull'utilizzo di ADSI Edit per creare un nuovo attributo legacyExchangeDN, consultare l'articolo 273863 della Microsoft Knowledge Base "Modifica dell'attributo LegacyExchangeDN in modalità nativa con ADSI Edit" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=273863.


Il parametro LimitBodyParts è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stato modificato il limite predefinito di allegati di un messaggio:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\LimitBodyParts

Se Exchange Server Analyzer rileva che la voce del Registro di sistema LimitBodyParts è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Strutturalmente e per motivi di protezione, il numero di allegati (definiti parti del corpo) viene limitato a 250. Se un messaggio contiene più di 250 allegati, viene generato un errore MAPI_E_TOO_BIG. Inoltre, durante l'elaborazione di messaggi con molti allegati l'Archivio informazioni di Microsoft Exchange potrebbe utilizzare troppa memoria e risorse CPU.

Esiste una possibilità di configurazione che consente agli amministratori di aggiungere il valore LimitBodyParts del Registro di sistema e configurarlo in modo da utilizzare un valore maggiore di 250. In mancanza di questa voce, viene utilizzato il valore predefinito 250.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per visualizzare o modificare il valore LimitBodyParts del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

  3. Esaminare ed eventualmente modificare il valore LimitBodyParts. Un valore del Registro di sistema valido è rappresentato da qualsiasi numero intero compreso tra 250 e 4294967295.

  4. Se viene apportata una modifica, riavviare il computer sul quale è eseguito Exchange Server per renderla effettiva.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il parametro LimitEmbeddingDepth è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-30

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se sono stati modificati i limiti predefiniti dell'intestazione MIME in Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se Exchange Server Analyzer rileva che è stato impostato un valore per LimitEmbeddingDepth, verrà visualizzato un messaggio di configurazione non predefinita.

Exchange 2000 Server Service Pack 3, Exchange Server 2003 ed Exchange Server 2007 includono una funzionalità aggiornata nel processo dell'archivio informazioni (store.exe) che definisce il modo in cui viene gestito un messaggio MIME di grandi dimensioni o non corretto. Questa funzionalità è stata aggiunta per proteggere ulteriormente Exchange Server da eventuali attacchi DoS (Denial of Service) da parte di messaggi MIME particolarmente grandi e complessi. Tra le restrizioni imposte ai messaggi MIME inoltrati all'archivio sono inclusi il limite del numero di destinatari, il limite del numero di messaggi incorporati e il limite della dimensione delle singole intestazioni MIME.

I valori predefiniti per questi diversi limiti delle intestazioni MIME vengono impostati durante il processo di archiviazione. Tuttavia, se è stata impostata una chiave del Registro di sistema per definire uno di questi limiti, questa avrà la precedenza sul valore predefinito di store.exe. Quando uno di questi limiti viene superato in un messaggio MIME, viene inviato un rapporto di mancato recapito (NDR, non-delivery report) al mittente.

Il limite alla profondità di incorporamento di MIME si riferisce al numero di messaggi MIME che possono essere incorporati l'uno nell'altro. Ad esempio, si supponga di ricevere un messaggio (m1) con un altro messaggio allegato (m2). Quando si apre il messaggio allegato (m2), si rileva che è presente un altro messaggio (m3) allegato a questo (m2). Di conseguenza, il messaggio originale (m1) contiene messaggi incorporati a una profondità di 3 livelli. Per impostazione predefinita, Exchange consentirà l'ingresso di messaggi con un livello di profondità di messaggi incorporati pari a 100. I messaggi contenenti messaggi incorporati che superano i 100 livelli di profondità potrebbero, infatti, utilizzare tutta la memoria di un server di Exchange nel tempo che questo impiega a "scorporare" il messaggio, analizzarlo e convertirlo in MAPI. È molto improbabile che un server o client di posta elettronica generi un messaggio con tale profondità di messaggi incorporati. Questo tipo di messaggio rappresenta più probabilmente il risultato del tentativo da parte di utenti malintenzionati di danneggiare con un attacco DoS il sistema di messaggistica.

Per ripristinare la configurazione predefinita

  • Non è necessario intraprendere azioni. Questa voce del Registro di sistema sarà presente solo quando verrà installato l'aggiornamento rapido cui fa riferimento l'articolo 833607 della Microsoft Knowledge Base "Il servizio Archivio informazioni di Microsoft Exchange utilizza il 100% delle risorse CPU in Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=833607. Questo aggiornamento rapido consente la creazione della voce LimitEmbeddingDepth del Registro di sistema e la relativa impostazione su un valore pari a 10.

Per ulteriori informazioni sugli aggiornamenti rapidi e i Service Pack di Exchange Server, consultare l'articolo 328839 della Microsoft Knowledge Base "Installazione dei Service Pack e degli aggiornamenti rapidi di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328839.


Il parametro LimitNestingLevels è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se sono stati modificati i limiti predefiniti dell'intestazione MIME in Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se Exchange Server Analyzer rileva che è stato impostato un valore per LimitNestingLevels, verrà visualizzato un messaggio di configurazione non predefinita.

I corpi MIME all'interno di un elemento del messaggio possono essere nidificati. Se il livello di nidificazione è elevato, il processo di conversione richiede un impiego maggiore delle risorse per decodificare l'intero messaggio. L'elaborazione di un singolo messaggio con un corpo MIME che presenta 700 livelli di nidificazione può richiedere fino a 10 minuti. Quando si ricevono messaggi da Internet con corpi MIME nidificati, il processo di conversione per i corpi MIME può provocare un rallentamento nel recapito dei messaggi. Quando i messaggi vengono recapitati, il server richiede notevoli quantità di risorse di sistema, in particolare una grande quantità di memoria. Se viene ricevuta una grande quantità di messaggi contemporaneamente, il sistema potrebbe segnalare un'insufficienza della memoria virtuale.

La limitazione dei livelli di nidificazione di MIME fa riferimento al numero di tipi di contenuto MIME (come multipart/misto o multipart/alternativo) che possono essere nidificati uno nell'altro. I messaggi che vengono generati dalla maggior parte di client di posta elettronica (inclusi Microsoft Outlook® e Outlook Express) e dai server di posta elettronica contengono un numero esiguo di tipi di contenuto MIME nidificati. Ad esempio, un messaggio standard (anche se con più risposte), verrà rappresentato solo in un messaggio MIME come singolo tipo di contenuto. I livelli di nidificazione multipli sono in genere il risultato di un processo automatico che crea messaggi MIME per usi specifici (ad esempio un'applicazione per il flusso di lavoro) oppure di un messaggio dannoso creato con lo specifico fine di utilizzare tutte le risorse sul server di posta.

Oltre a imporre i livelli di nidificazione a seconda del tipo di contenuto, Exchange Server utilizza il valore LimitNestingLevels (se definito come valore del Registro di sistema o come valore predefinito nel processo di archiviazione) per imporre un limite ai messaggi incorporati. Se il valore LimitNestingLevels del Registro di sistema non è definito, viene imposto il valore predefinito di 30 livelli di nidificazione. Il limite dei messaggi incorporati viene definito moltiplicando il valore LimitNestingLevels per 16. Pertanto, il valore predefinito per il numero di messaggi incorporati è 480. Ad esempio, se LimitNestingLevels è configurato con un valore di 5, il numero massimo di allegati consentito sarà 80.

Per ripristinare la configurazione predefinita

  • Non è necessario intraprendere azioni. Exchange Server Analyzer visualizza la configurazione non predefinita solo a scopo informativo.

Per ulteriori informazioni su un aggiornamento rapido di Exchange 2000 Server relativo al valore LimitNestingLevels del Registro di sistema, consultare l'articolo 289775 della Microsoft Knowledge Base "XADM: Perdite di memoria provocate dal numero elevato di messaggi incorporati in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=289775.


Il parametro LimitRecipients è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se sono stati modificati i limiti predefiniti dell'intestazione MIME in Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent

Se Exchange Server Analyzer rileva che è stato impostato un valore per LimitRecipients, verrà visualizzato un messaggio di configurazione non predefinita.

Exchange 2000 Server Service Pack 2 e le versioni successive di Exchange Server includono una funzionalità aggiornata nel processo dell'archivio (store.exe), che definisce il modo in cui viene gestito un messaggio MIME di grandi dimensioni o non corretto. Questa funzionalità è stata aggiunta per proteggere ulteriormente Exchange Server da eventuali attacchi di tipo DoS (Denial of Service) da parte di messaggi MIME dannosi e particolarmente grandi e complessi. Tra le restrizioni imposte ai messaggi MIME inoltrati all'archivio sono inclusi il limite del numero di destinatari, il limite del numero di messaggi incorporati e il limite della dimensione delle singole intestazioni MIME. Nelle versioni precedenti di Exchange, in cui alle intestazioni MIME non delimitate era consentito l'accesso all'archivio di Exchange per l'elaborazione, i messaggi MIME particolarmente grandi e complessi potevano utilizzare quasi tutte le risorse (principalmente la CPU) come risultato dell'analisi, indicizzazione ed elaborazione dei messaggi MIME.

I valori predefiniti per questi diversi limiti delle intestazioni MIME vengono impostati durante il processo di archiviazione. Tuttavia, se è stata impostata una chiave del Registro di sistema per definire uno di questi limiti, questa avrà la precedenza sul valore predefinito di store.exe. Quando uno di questi limiti viene superato in un messaggio MIME, viene inviato un rapporto di mancato recapito (NDR, non-delivery report) al mittente.

Se è stata impostata la chiave del Registro di sistema LimitRecipients, è molto probabile che questo sia il risultato di un suggerimento del Servizio Supporto Tecnico Clienti Microsoft, in quanto questa chiave non è stata pubblicata. Di conseguenza, Microsoft consiglia di non cambiare questa impostazione.

Il valore predefinito per LimitRecipients (se non esiste nessuna chiave del Registro di sistema) nel processo di archiviazione è 65.535 destinatari per ciascun messaggio MIME.


Buffer di registro non ottimizzati per server con spazio su disco replicato che eseguono Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se si verificano le seguenti condizioni:

  • Nel computer è in esecuzione Exchange Server 2003.

  • Il valore di msExchESEParamLogBuffers è compreso tra 0 e 8.960.

Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeIS_MSExchangeIS per determinare se si verifica la seguente condizione:

  • Il valore di VMLargestBlockSize è maggiore di 150.000.000.

Exchange Server Analyzer determina se uno dei seguenti servizi è in esecuzione:

  • GeoSpanService

  • SRDFService

Se le condizioni elencate sopra sono vere, verrà visualizzato un messaggio di errore.

ESE (Extensible Storage Engine) utilizza i buffer di registro per conservare le transazioni in memoria prima di salvarle nei registri delle transazioni. Se i buffer di registro non sono sufficienti potrebbe venire visualizzato un numero eccessivo di operazioni I/O del disco nell'unità dei registri delle transazioni, causando una riduzione delle prestazioni.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per risolvere il problema

  1. In ADSI Edit fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=ExchangeOrganizationName.

  2. Espandere CN=Administrative Groups, CN=AdministrativeGroupName e infine CN=Servers.

  3. Espandere CN=ExchangeServerName, CN=InformationStore, fare clic con il pulsante destro del mouse su CN=Storage Group Name, infine su Proprietà.

  4. Nella finestra Selezionare una proprietà da visualizzare fare clic su msExchESEParamLogBuffers.

  5. Nella casella Modifica attributo digitare 9000 per msExchESEParamLogBuffers, quindi fare clic su Imposta.

  6. Fare clic su Applica, quindi su OK.

  7. Per rendere effettive le modifiche, è necessario riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni, consultare l'articolo 328466 della Microsoft Knowledge Base, "Buffer di registro ESE impostati su valori troppo bassi possono causare l'interruzione delle risposte del servizio Archivio informazioni di Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466.


I buffer di registro potrebbero non essere sufficienti per i server che contengono un numero elevato di cassette postali ed eseguono Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-03-27

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se si verificano le seguenti condizioni:

  • Nel computer è in esecuzione Exchange Server 2003.

  • Il valore di msExchESEParamLogBuffers è compreso tra 0 e 8.960.

  • Il numero di cassette postali presenti nel gruppo di archiviazione è superiore a 500.

Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeIS_MSExchangeIS per determinare se si verificano le seguenti condizioni:

  • Il valore di VMLargestBlockSize è maggiore di 150 milioni.

Se queste condizioni sono vere, verrà visualizzato un avviso.

ESE (Extensible Storage Engine) utilizza i buffer di registro per conservare le transazioni in memoria prima di salvarle nei registri delle transazioni. Se i buffer di registro non sono sufficienti potrebbe venire visualizzato un numero eccessivo di operazioni I/O del disco nell'unità dei registri delle transazioni, causando una riduzione delle prestazioni.

Per risolvere il problema

  1. In ADSI Edit fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=ExchangeOrganizationName.

  2. Espandere CN=Administrative Groups, CN=AdministrativeGroupName e infine CN=Servers.

  3. Espandere CN=ExchangeServerName, CN=InformationStore, fare clic con il pulsante destro del mouse su CN=Storage Group Name, infine su Proprietà.

  4. Nella finestra Selezionare una proprietà da visualizzare fare clic su msExchESEParamLogBuffers.

  5. Nella casella Modifica attributo digitare 9000 per msExchESEParamLogBuffers, quindi fare clic su Imposta.

  6. Fare clic su Applica, quindi su OK.

  7. Per rendere effettive le modifiche, è necessario riavviare il servizio Archivio informazioni di Microsoft Exchange.
Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per ulteriori informazioni, consultare l'articolo 328466 della Microsoft Knowledge Base, "I buffer di registro di ESE impostati troppo bassi possono causare il blocco del servizio Archivio informazioni di Microsoft Exchange", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328466.


File di registro memorizzati nell'unità di rete
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamLogFilePath per ogni oggetto del gruppo di archiviazione. Questo attributo specifica la posizione dei file di log delle transazioni utilizzati dai database nel gruppo di archiviazione.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ogni archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero delle cassette postali presenti nell'archivio.

Se Exchange Server Analyzer rileva che l'attributo msExchESEParamLogFilePath comincia con \\ in un server di Exchange con più di 50 cassette postali, verrà visualizzato un messaggio di errore.

Questo messaggio di errore indica che i file di registro delle transazioni di un gruppo di archiviazione vengono archiviati in una condivisione di rete. Se l'attributo msExchESEParamLogFilePath inizia con \\, significa che il percorso del file di registro è un percorso UNC (Universal Naming Convention). Non è un'operazione consigliata, poiché le interruzioni nella connettività di rete possono provocare errori nel registro e nel database delle transizioni, perdite di dati o danni ai database. Si consiglia di risolvere il problema al più presto.

Per risolvere il problema

  • Spostare i registri delle transazioni sul disco locale dalla condivisione di rete. Per prestazioni ottimali, posizionare tutti i registri delle transizioni su unità separate.

Per ulteriori informazioni sullo spostamento dei registri delle transazioni, consultare l'articolo della Microsoft Knowledge Base 239944 "XADM: Spostare un registro delle transazioni o un registro di sistema in una posizione diversa" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=239944.


Discrepanza nella generazione dei registri
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha determinato che si è verificata una discrepanza nella generazione dei registri. Questo messaggio di errore indica che un file di registro delle transazioni è stato rinominato con un numero di sequenza inappropriato.

I file di registro delle transazioni di Exchange vengono rinominati in base al seguente formato: EnnXXXXX.log

  • XXXXX = Numero di sequenza esadecimale a cinque cifre. Quando viene generata una nuova serie di file di registro delle transazioni, il primo registro della sequenza sarà 000001, il successivo 00002 e così via. Poiché ogni registro delle transazioni riporta il proprio numero di sequenza nell'intestazione, è possibile determinare se il nome file del registro è stato modificato.

  • Enn = Prefisso di registro composto da una sequenza di tre caratteri condivisa da ogni registro delle transazioni del gruppo di archiviazione. In genere il prefisso è E00, E01, E02, E03 o R00 (per un gruppo di archiviazione di ripristino).

Il registro corrente in cui sono in corso le operazioni di scrittura viene denominato con il solo prefisso di registro. Questo registro non acquisirà un numero di sequenza fino a quando non verrà chiuso e non verrà generato un nuovo registro corrente. Quindi, il file di registro corrente può essere denominato E00.log. Quando questo file di registro sarà pieno, potrà essere rinominato E0012345.log. Verrà quindi generato un nuovo E00.log con un numero di sequenza interno pari a 12346.

Per risolvere il problema

  • Rinominare il file di registro con il numero di sequenza appropriato.
Per visualizzare il numero di sequenza interno

  • Eseguire il comando seguente:

    C:\Programmi\Exchsrvr\Bin\Eseutil.exe /ML [nome file del registro]

    Il valore lGeneration nell'output di questo comando riporta il numero di sequenza effettivo del file di registro.


Coppie di file di registro incoerenti
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha determinato che alcuni dei file di registro richiesti sono incoerenti. Questo errore indica che i file di registro sono stati alterati, spostati, copiati, rinominati o eliminati manualmente.

Per risolvere il problema

  • Per un'analisi avanzata dei file di registro, consultare la Guida in linea e il supporto tecnico Microsoft all'indirizzo http://go.microsoft.com/fwlink/?LinkId=31845.


Discrepanza tra le firme di registro
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato che la firma di registro in uno o più file di registro non corrisponde ad altri file di registro contenuti nella stessa cartella.

Questo problema non si verifica a meno che i file di registro siano stati spostati, eliminati o scomposti.

Nota:
Si tratta di uno scenario di recupero avanzato, e pertanto si consiglia di consultare la Guida in linea di supporto tecnico di Microsoft (http://go.microsoft.com/fwlink/?LinkId=31845) prima di procedere all'implementazione.

Ciascun file di registro delle transazioni di Exchange viene contrassegnato con una firma denominata Firma di registro. Questa firma identifica i file di registro individuali che appartengono alla stessa serie di registri. Ciascun database di Exchange registra la Firma di registro della serie di registri delle transazioni alla quale il database è stato allegato per ultimo.

I database di Exchange, inoltre, sono contraddistinti da una firma denominata Firma DB. La Firma DB è generata quando viene creato un database. Se si utilizza Eseutil per deframmentare o riparare un database, tale firma verrà modificata in quanto i processi di riparazione e deframmentazione apportano cambiamenti ai file di database senza registrare tali modifiche nei registri delle transazioni. Ai fini della registrazione, il database risultante dall'operazione di riparazione o deframmentazione sarà un database nuovo o diverso.

A differenza delle Firme DB, le Firme di registro non si modificano mai nel corso della durata di una serie di file di registro.

Al momento della creazione di un registro, i file di registro registrano le Firme DB di tutti i database allegati. I database registrano la Firma di registro della serie dei registri alla quale il database è stato allegato. Pertanto le Firme DB e quelle di registro sono utili ai fini della corrispondenza tra i database e i file di registro delle transazioni.

È possibile scollegare un database di Exchange da un set di registri e collegarlo a un altro. È possibile eseguire questa operazione spostando il database in un gruppo di archiviazione diverso o rimuovendo tutti i registri di transazione per un gruppo di archiviazione, quindi creare una nuova serie di registri.

Se il database si trova in uno stato di arresto anomalo, possono essere rieseguiti nel database soltanto i file di registro contraddistinti da firme che coincidono con la Firma di registro nell'intestazione del database. Nello stato di arresto anomalo il database è ancora collegato a un determinato flusso di registrazione e può essere recuperato solo con tale flusso di registrazione.

Se il database si trova in uno stato di arresto normale, potrebbe essere possibile eseguire i file di registro delle transazioni le cui firme non coincidono con la Firma di registro attuale nell'intestazione del database. Questa operazione potrà essere eseguita correttamente soltanto se si è verificata la seguente circostanza:

  1. Il database è stato arrestato correttamente al termine di una sequenza precedente di file di registro.

  2. Il database è stato successivamente collegato a una nuova sequenza di file di registro delle transazioni ed è possibile accedere al registro delle transazioni in cui il database è stato collegato inizialmente al nuovo set di registri.

Per risolvere il problema

  • È necessario conoscere la cronologia del database e in quali circostanze i registri di transazione sono stati generati rispettivamente al database.

  • In questo caso, prima di tentare un recupero, eseguire sempre una copia dei registri delle transazioni e dei file di database. Un errore durante il tentativo di recupero potrebbe modificare i file di registro delle transazioni o quelli di database in modo tale che un ulteriore tentativo di recupero potrebbe risultare inattuabile.

  • Riprodurre soltanto un set di registri delle transazioni alla volta con il database. Spostare gli altri registri delle transazioni fuori dalla cartella di ripristino.

  • Se il database si trova nello stato di arresto anomalo, è necessario innanzitutto rieseguire i registri delle transazioni ai quali il database è collegato e riportare quest'ultimo nello stato di arresto normale. Solo a questo punto potrebbe essere possibile eseguire il secondo set di file di registro con il database.

  • Se il database si trova nello stato di arresto normale, è possibile esaminare i registri o il database per verificare quale set di registri delle transazioni sia quello corretto da riprodurre per prima.


L'accesso è stato limitato a determinati utenti
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema nel computer che esegue Exchange Server per determinare se l'elenco di utenti cui è consentito accedere all'Archivio informazioni di Exchange è stato limitato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Logon Only As

Se Exchange Server Analyzer rileva che il valore Logon Only As del Registro di sistema è presente, verrà visualizzato un avviso.

Il valore Logon Only As del Registro di sistema rappresenta un valore multistringa (REG_MULTI_SZ) che contiene l'elenco di attributi legacyExchangeDN per gli account autorizzati ad accedere all'Archivio informazioni di Exchange. Questo valore del Registro di sistema, per impostazione predefinita non presente, viene aggiunto in genere durante periodi di risoluzione dei problemi, manutenzione e operazioni di spostamento di cassette postali.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro di destra eliminare il valore Logon Only As del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni sul valore Logon Only As del Registro di sistema, consultare l'articolo 146764 della Microsoft Knowledge Base, "Limitazione degli accessi all'Archivio informazioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=146764.

Per informazioni sulle modalità per limitare gli accessi durante le operazioni di spostamento di cassette postali, consultare l'articolo 218920 della Microsoft Knowledge Base, "XADM: Evitare gli accessi durante lo spostamento delle cassette postali" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=218920.


Valore Lookup SID Cache Expire del Registro di sistema impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare la presenza della voce Lookup Sid Cache Expire del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione non predefinita:

  • La voce Lookup Sid Cache Expire del Registro di sistema è presente.

  • La voce Lookup Sid Cache Expire del Registro di sistema presenta un valore diverso da 3.600.

Nei server di Exchange su cui è in esecuzione Exchange 2000 Server Service Pack 3 o versione successiva, l'archivio informazioni crea una cache contenente identificatori di protezione (SID, Security Identifiers) e indica se il SID è un oggetto utente o un oggetto gruppo. La cache viene creata e compilata quando si accede a una cartella pubblica per la prima volta. Dopo che la cache è stata compilata, tutte le chiamate di ricerca dei SID di account verranno prima inviate alla cache dell'archivio informazioni. Se il SID non è presente nella cache dell'archivio informazioni, la chiamata verrà eseguita al controller di dominio, quindi le informazioni relative a tale SID verranno aggiunte alla cache.

Per impostazione predefinita, la cache viene conservata per un'ora. Se la cache supera il limite predefinito di 8 KB per le voci, le voci obsolete contenute nella cache verranno rimosse per creare spazio per le nuove voci. È possibile utilizzare due chiavi del Registro di sistema per modificare sia l'intervallo di tempo predefinito (Lookup Sid Cache Expire) che la dimensione predefinita (Lookup Sid Cache Size) della cache. Si consiglia di modificare queste impostazioni predefinite solo se si è certi che in questo modo miglioreranno le prestazioni.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Nel riquadro destro individuare ed eliminare il valore Lookup Sid Cache Expire. Se è impostato anche il valore Lookup SID Cache Size, eliminarlo.

  4. Uscire dall'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore Lookup Sid Cache Expire del Registro di sistema, consultare l'articolo 328907 della Microsoft Knowledge Base "XADM: Gli aggiornamenti dell'elenco di controllo di accesso provocano il rallentamento delle prestazioni della cartella pubblica. Per risolvere il problema, è necessario Exchange 2000 SP2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907.


Valore Lookup SID Cache Size del Registro di sistema impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinarne la presenza della voce Lookup Sid Cache Size del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione non predefinita:

  • La voce Lookup Sid Cache Size del Registro di sistema è presente.

  • La voce Lookup Sid Cache Size del Registro di sistema presenta un valore diverso da 1.024.

Nei server di Exchange su cui è in esecuzione Exchange 2000 Server Service Pack 3 o versione successiva, l'archivio informazioni crea una cache contenente identificatori di protezione (SID, Security Identifiers) e indica se il SID è un oggetto utente o un oggetto gruppo. La cache viene creata e compilata quando si accede a una cartella pubblica per la prima volta. Dopo che la cache è stata compilata, tutte le chiamate di ricerca dei SID di account verranno prima inviate alla cache dell'archivio informazioni. Se il SID non è presente nella cache dell'archivio informazioni, la chiamata verrà eseguita al controller di dominio, quindi le informazioni relative a tale SID verranno aggiunte alla cache.

Per impostazione predefinita, la cache viene conservata per un'ora. Se la cache supera il limite predefinito di 8 KB per le voci, le voci obsolete contenute nella cache verranno rimosse per creare spazio per le nuove voci. È possibile utilizzare due chiavi del Registro di sistema per modificare sia l'intervallo di tempo predefinito (Lookup Sid Cache Expire) che la dimensione predefinita (Lookup Sid Cache Size) della cache. Si consiglia di modificare queste impostazioni predefinite solo se si è certi che in questo modo miglioreranno le prestazioni.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Nel riquadro destro individuare ed eliminare il valore Lookup Sid Cache Size. Se è impostato anche il valore Lookup SID Cache Expire, eliminarlo.

  4. Uscire dall'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore Lookup Sid Cache Size del Registro di sistema, consultare l'articolo 328907 della Microsoft Knowledge Base "XADM: Gli aggiornamenti dell'elenco di controllo di accesso provocano il rallentamento delle prestazioni della cartella pubblica. Per risolvere il problema, è necessario Exchange 2000 SP2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328907.


L'evento errore di memoria virtuale insufficiente è stato ignorato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la soglia per la registrazione di un evento relativo alla frammentazione della memoria virtuale (VM, virtual memory) è stata ignorata manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Error Level

Se Exchange Server Analyzer rileva che il valore VM Error Level del Registro di sistema è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Nei sistemi Microsoft Windows® a 32 bit sono disponibili due tipi di memoria: la memoria fisica (la quantità di memoria effettiva installata nel sistema) e lo spazio di indirizzi della memoria virtuale (uno spazio di memoria virtuale di 4 gigabyte). Indipendentemente dalla quantità di memoria fisica installata nel sistema, la dimensione totale dello spazio di indirizzi virtuali è sempre la stessa: 4 GB. Sebbene la situazione non sia la stessa per tutte le applicazioni a 32 bit, per quanto riguarda Exchange Server lo spazio di indirizzi virtuali equivale alla memoria virtuale, ovvero i due termini vengono utilizzati in modo interscambiabile.

Durante l'esecuzione delle normali operazioni, l'Archivio informazioni di Exchange procederà ad allocare, utilizzare e deallocare la memoria virtuale più volte. Se la memoria virtuale viene allocata, utilizzata e deallocata frequentemente è possibile che si verifichi una frammentazione della memoria stessa. La frammentazione della memoria virtuale è analoga alla frammentazione del file system che può verificarsi nel tempo. Dopo poco i segmenti di memoria virtuale allocati non sono più contigui e le prestazioni cominciano a risentirne. Nel caso del file system è disponibile un'applicazione che consente di eseguire la deframmentazione del file system e, nella maggior parte dei casi, l'operazione può essere eseguita mentre il sistema è in linea e in uso. In caso di frammentazione della memoria virtuale non è disponibile alcuno strumento di deframmentazione e per risolvere il problema è necessario arrestare e riavviare il servizio Archivio informazioni di Microsoft Exchange oppure riavviare il sistema.

Quando un computer che esegue Exchange Server dispone di meno di 16 MB di spazio per indirizzi virtuali contigui, verrà registrato il seguente messaggio di errore nel registro eventi dell'applicazione:

Origine: | MSExchangeIS
Categoria: | Prestazioni
ID: | 9582
Tipo: | Errore
Descrizione: | La memoria virtuale necessaria per eseguire il server di Exchange viene frammentata in modo tale che durante le normali operazioni potrebbero verificarsi degli errori. È consigliabile riavviare tutti i servizi di Exchange per risolvere questo problema.

Il valore del Registro di sistema VM Error Level offre una possibilità di configurazione che consente all'amministratore di ignorare l'avviso per il livello predefinito di 16 MB e di impostare un valore alternativo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro eliminare il valore VM Error Level.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla frammentazione della memoria virtuale in Exchange Server 2003 ed Exchange 2000 Server, consultare l'articolo 325044 della Microsoft Knowledge Base: "HOW TO: Risoluzione del problema della frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.


L'evento di avviso di memoria virtuale insufficiente è stato ignorato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la soglia per la registrazione di un evento relativo alla frammentazione della memoria virtuale è stata ignorata manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\VM Warning Level

Se Exchange Server Analyzer rileva che il valore VM Warning Level del Registro di sistema è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Nei sistemi Microsoft Windows® a 32 bit sono disponibili due tipi di memoria: la memoria fisica (la quantità di memoria effettiva installata nel sistema) e la memoria dello spazio di indirizzi virtuali (uno spazio di memoria virtuale di 4 gigabyte). Indipendentemente dalla quantità di memoria fisica installata nel sistema, la dimensione totale dello spazio di indirizzi virtuali è sempre la stessa: 4 GB. Sebbene la situazione non sia la stessa per tutte le applicazioni a 32 bit, in Exchange Server lo spazio di indirizzi virtuali equivale alla memoria virtuale, ovvero i due termini vengono utilizzati in modo interscambiabile.

Durante l'esecuzione delle normali operazioni, l'Archivio informazioni di Exchange procederà ad allocare, utilizzare e deallocare la memoria virtuale più volte. Se la memoria virtuale viene allocata, utilizzata e deallocata frequentemente è possibile che si verifichi una frammentazione della memoria stessa. La frammentazione della memoria virtuale è analoga alla frammentazione del file system che può verificarsi nel tempo. Dopo poco i segmenti di memoria virtuale allocati non sono più contigui e le prestazioni cominciano a risentirne. Nel caso del file system, è disponibile un'applicazione che consente di eseguire la frammentazione del file system. In genere, questa operazione può essere eseguita mentre il sistema è in linea e in uso. Nel caso della frammentazione della memoria virtuale, non è disponibile uno strumento di deframmentazione e, per risolvere il problema, è necessario eseguire l'arresto e avviare il servizio Archivio informazioni di Microsoft Exchange oppure riavviare il sistema.

Per impostazione predefinita, quando un computer Exchange Server dispone di meno di 32 MB di spazio per indirizzi virtuali contigui, verrà registrato il seguente avviso nel registro eventi dell'applicazione:

Origine: | MSExchangeIS
Categoria: | Prestazioni
ID: | 9582
Tipo: | Avviso
Descrizione: | La memoria virtuale necessaria per eseguire il server di Exchange è frammentata in modo tale che le prestazioni del server potrebbero risentirne. Si consiglia di riavviare tutti i servizi di Exchange per risolvere questo problema.

Il valore VM Warning Level del Registro di sistema costituisce una possibilità di configurazione che consente all'amministratore di ignorare l'avviso per il livello predefinito di 32 MB e di impostare un valore diverso.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro eliminare il valore VM Warning Level.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla frammentazione della memoria virtuale in Exchange Server 2003 ed Exchange 2000 Server, consultare l'articolo 325044 della Microsoft Knowledge Base: "HOW TO: Risoluzione del problema della frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.


Mailbox Cache Age Limit impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-15

Microsoft® Exchange Server Analyzer Tool verifica il Registro di sistema del computer che esegue Exchange Server per verificare la presenza della voce Mailbox Cache Age Limit del Registro di sistema. Questo valore del Registro di sistema si trova in:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che la voce Mailbox Cache Age Limit del Registro di sistema è presente e configurata con un valore pari a 1 o maggiore, verrà visualizzato un messaggio di configurazione non predefinita.

Exchange Server consente l'impostazione di limiti di dimensione (quote) per le cassette postali. Le impostazioni relative alle quote vengono archiviate nel servizio directory di Active Directory® ed Exchange Server legge periodicamente le informazioni contenute in Active Directory per determinare se sono state apportate eventuali modifiche a questi limiti. Per impostazione predefinita, Exchange Server archivia nella cache queste informazioni per un intervallo di tempo di due ore (120 minuti). Trascorso tale intervallo di tempo legge nuovamente le informazioni in Active Directory.

Il valore Mailbox Cache Age Limit del Registro di sistema, rappresentato in minuti, viene utilizzato per ignorare il periodo di tempo predefinito. ed è particolarmente utile nelle situazioni in cui l'utente non può accedere alla propria cassetta postale perché è stato raggiunto il limite della cassetta postale. Se viene attivato il limite predefinito di validità della cache, l'utente non potrà accedere alla propria cassetta postale per un massimo di due ore. Il valore consigliato è 20 minuti. Non impostare questo valore su un parametro troppo basso dal momento che ciò potrebbe provocare problemi di prestazioni.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersPrivate

  3. Nel riquadro destro individuare ed eliminare il valore Mailbox Cache Age Limit.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore Mailbox Cache Age Limit del Registro di sistema, consultare l'articolo 327378 della Microsoft Knowledge Base "XADM: I limiti per la dimensione delle cassette postali in Exchange 2000 ed Exchange Server 2003 non vengono impostati in un certo intervallo di tempo; per la correzione è necessario Exchange 2000 SP3" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378.


Mailbox Cache Idle Limit impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se esiste il valore Mailbox Cache Idle Limit:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva la presenza della voce Mailbox Cache Idle Limit del Registro di sistema, verrà visualizzato un messaggio di configurazione non predefinita.

Exchange Server consente l'impostazione di limiti di dimensione (quote) per le cassette postali. Le impostazioni relative alle quote vengono memorizzate nel servizio directory di Active Directory® e il server di Exchange legge periodicamente le informazioni contenute in Active Directory per determinare se sono state apportate eventuali modifiche a questi limiti. Exchange Server archivia nella cache queste informazioni per un certo intervallo di tempo. Trascorso tale intervallo di tempo legge nuovamente le informazioni in Active Directory.

Le impostazioni Mailbox Cache Age Limit e Mailbox Cache Idle Limit controllano l'intervallo di tempo durante il quale le voci vengono conservate nella cache della cassetta postale. Un elemento viene eliminato dalla cache se è rimasto nella cache più a lungo rispetto al tempo (in secondi) specificato nell'impostazione Mailbox Cache Age Limit. Un elemento viene eliminato dalla cache se non è stato utilizzato per il periodo di tempo (in secondi) specificato in Mailbox Cache Idle Limit. I valori predefiniti per queste impostazioni sono 7.200 secondi (120 minuti) per Mailbox Cache Age Limit e 900 secondi (15 minuti) per Mailbox Cache Idle Limit. Il valore dell'impostazione Mailbox Cache Idle Limit non deve essere superiore al valore dell'impostazione Mailbox Cache Age Limit.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem.

  3. Nel riquadro destro individuare ed eliminare il valore Mailbox Cache Idle Limit.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore del Registro di sistema per il periodo di validità della cache della cassetta postale, consultare l'articolo 327378 della Microsoft Knowledge Base, "XADM: I limiti per la dimensione delle cassette postali in Exchange 2000 non vengono impostati in un certo intervallo di tempo; per la correzione è necessario Exchange 2000 SP3" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378.


Dimensione cache cassetta postale impostata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le voci del Registro di sistema indicate di seguito, per determinare se esiste il valore Dimensione cache cassetta postale:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva la presenza della voce Dimensione cache cassetta postale nel Registro di sistema, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore Dimensione cache cassetta postale controlla la dimensione della cache della cassetta postale. Il valore predefinito è 256 MB. Exchange Server consente l'impostazione di limiti di dimensione (quote) per le cassette postali. Le impostazioni relative alle quote vengono archiviate nel servizio directory di Active Directory® ed Exchange Server legge periodicamente le informazioni contenute in Active Directory per determinare se sono state apportate eventuali modifiche a questi limiti. Per impostazione predefinita, Exchange Server archivia nella cache queste informazioni per un intervallo di tempo di due ore (7.200 secondi). Trascorso tale intervallo di tempo legge nuovamente le informazioni in Active Directory.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro individuare ed eliminare il valore Dimensione cache cassetta postale.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore del Registro di sistema per il periodo di validità della cache della cassetta postale, consultare l'articolo 327378 della Microsoft Knowledge Base, "XADM: I limiti per la dimensione delle cassette postali in Exchange 2000 non vengono impostati in un certo intervallo di tempo; per la correzione è necessario Exchange 2000 SP3" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378.


Dimensione cache cassetta postale impostata su zero
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'impostazione del valore della dimensione della cache delle cassette postali:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che il valore della dimensione della cache delle cassette postali è impostato su 0, verrà visualizzato un messaggio di errore.

Exchange Server consente l'impostazione di limiti di dimensione (quote) per le cassette postali. Le impostazioni relative alle quote vengono memorizzate nel servizio directory di Active Directory® ed Exchange Server legge periodicamente le informazioni contenute in Active Directory per determinare se sono state apportate modifiche a questi limiti. Il valore Dimensione cache cassetta postale controlla la dimensione della cache della cassetta postale. Il valore predefinito è 256 MB. Quando è impostata su 0, la cache delle cassette postali è disattivata. Non è consigliabile impostare questo valore su 0 perché questo provoca l'esecuzione di più ricerche in Active Directory da parte del componente DSAccess (Directory Service Access). Inoltre, l'impostazione del valore su 0 può provocare errori nell'archivio di Exchange e durante lo spostamento delle cassette postali.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro individuare ed eliminare il valore Dimensione cache cassetta postale.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore del Registro di sistema per il periodo di validità della cache della cassetta postale, consultare l'articolo 327378 della Microsoft Knowledge Base, "XADM: I limiti per la dimensione delle cassette postali in Exchange 2000 non vengono impostati in un certo intervallo di tempo; per la correzione è necessario Exchange 2000 SP3" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327378.


Archivio cassette postali controllato dai criteri
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-06-06

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per stabilire il valore dell'attributo msExchPolicyList di ciascun oggetto dell'archivio delle cassette postali. L'attributo msExchPolicyList determina se è stato creato un criterio per le cassette postali di Exchange Server e se è stato assegnato a un archivio delle cassette postali. Se Exchange Server Analyzer rileva che l'attributo msExchPolicyList è stato impostato, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, al momento della creazione non viene assegnato alcun criterio agli archivi cassette postali. Tuttavia, nella maggior parte dei casi, gli amministratori creano dei criteri per le cassette postali e li assegnano a più archivi cassette postali. Con questi criteri vengono applicate le impostazioni amministrative quali, ad esempio, i limiti di archiviazione, gli aggiornamenti dell'indicizzazione, gli intervalli di manutenzione, i mapping agli archivi pubblici e gli elenchi della rubrica non in linea. Se è stato creato un criterio per le cassette postali ed è stato assegnato a un archivio delle cassette postali, verrà visualizzato un messaggio che indica che attualmente tale archivio è controllato da un criterio per le cassette postali. Non sono richieste operazioni aggiuntive.

Per rimuovere un criterio per le cassette postali da un archivio delle cassette postali

  1. Aprire Gestore di sistema di Exchange ed espandere Gruppi amministrativi nella struttura della console.

  2. Espandere il primo gruppo amministrativo e selezionare System Policies.

  3. Nel riquadro dei risultati fare clic con il pulsante destro del mouse sull'archivio delle cassette postali e scegliere Remove from policy.

  4. Nella finestra Gestore di sistema di Exchange fare clic su Yes per confermare la rimozione dell'archivio delle cassette postali.
Nota:
Se il nodo System Policies non è visualizzato nella struttura delle console in Gestore di sistema di Exchange, configurare quest'ultimo in modo tale che vengano visualizzati i Gruppi amministrativi.

Per ulteriori informazioni sui criteri dell'archivio delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822938, "How To: Utilizzare criteri di sistema per la configurazione dei limiti di archiviazione delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822938.

  • 256141, "Creazione di criteri di sistema in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256141.

Per ulteriori informazioni sui file di database di Exchange Server, consultare i seguenti argomenti di Exchange Server 2003:

  • "Gestione degli archivi di cassette postali e cartelle pubbliche", nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

  • "Understanding the Exchange Server 2003 Store" in Working with Exchange Server 2003 Stores all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).


File di database dell'archivio delle cassette postali memorizzato nell'unità di rete
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchEDBFile di ciascun oggetto archivio cassette postali. L'attributo specifica la posizione dei file di database utilizzati da questo archivio delle cassette postali.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio dei valori elencati nell'attributo homeMDBBL di ogni archivio cassette postali nel server. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio. Exchange Server Analyzer è quindi in grado di calcolare il numero totale delle cassette postali gestite dal server.

Se Exchange Server Analyzer rileva che l'attributo msExchEDBFile comincia con \\ in un server di Exchange con più di 50 cassette postali, verrà visualizzato un messaggio di errore.

Questo messaggio di errore indica che i file di database di un archivio delle cassette postali vengono archiviati in una condivisione di rete. Se l'attributo msExchEDBFile inizia con \\, significa che il percorso del file di registro è un percorso UNC (Universal Naming Convention). Non è un'operazione consigliata, poiché le interruzioni nella connettività di rete possono provocare errori del database, perdite di dati o danni ai database. Si consiglia di risolvere il problema al più presto.

Per spostare i file di database in una nuova unità

  1. In Exchange System Manager, espandere l'oggetto server di Exchange in cui si trova l'archivio, espandere il contenitore del gruppo di archiviazione appropriato, fare clic con il pulsante destro del mouse sull'oggetto archivio delle cassette postali desiderato, quindi fare clic su Proprietà.

  2. Specificare le nuove posizioni dei file sulla scheda Database della finestra di dialogo Proprietà.

Per ulteriori informazioni sui file di database di Exchange Server, consultare i seguenti argomenti:

  • "Gestione degli archivi di cassette postali e cartelle pubbliche", nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

  • "Understanding the Exchange Server 2003 Store" in Working with the Exchange Server 2003 Store (http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).

Per ulteriori informazioni sull'utilizzo di unità di rete con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328879, "Utilizzo di Exchange Server con reti di archiviazione collegate e periferiche di archiviazione in rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879.

  • 839687, "Criteri di supporto Microsoft sull'utilizzo di periferiche di archiviazione in rete con Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687.

  • 317173, "Exchange Server e l'archiviazione in rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173.

  • 317172, "Exchange Server e l'archiviazione in rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172.


Il limite per la dimensione dei database dell'archivio delle cassette postali è stato impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore Database Size Limit in Gb del Registro di sistema è presente e configurato per i database dell'archivio delle cassette postali:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

Se Exchange Server Analyzer rileva che il valore Database Size Limit in Gb è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Se è installato Exchange Server 2003 Service Pack 2 (SP2) in Exchange Server 2003 Standard Edition, il limite consentito per la dimensione dei database specificato a livello di codice viene aumentato da 16 GB a 75 GB. È possibile impostare un limite di protezione per la dimensione dei database in modo tale da impedirne la crescita indesiderata. Nel Service Pack 2, il valore predefinito per il limite di dimensione è 18 GB ma può essere sostituito creando il valore Database Size Limit in Gb del Registro di sistema.

È anche possibile aumentare il limite di 50 GB per la dimensione dei database specificato a livello di codice di Exchange Server 2007 Standard Edition creando il valore del Registro di sistema Database Size Limit in Gb.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Private-<MailboxStoreGUID>

  3. Eliminare il valore Database Size Limit in Gb.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui Service Pack per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


L'archivio della cassette postali non dispone di un archivio di cartelle pubbliche associato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio di directory Active Directory® per stabilire se l'attributo msExchPrivateMDB ha un archivio di cartelle pubbliche predefinito assegnato all'archivio delle cassette postali.

L'attributo msExchPrivateMDB è una configurazione di database privato per un oggetto archivio delle cassette postali. Per impostazione predefinita l'attributo msExchHomePublicMDB è associato a un archivio delle cassette postali. L'attributo msExchPrivateMDB è il database dei messaggi pubblico (MDB) principale.

Se Exchange Server Analyzer rileva che l'attributo msExchHomePublicMDB è stato eliminato o configurato non correttamente, verrà visualizzato un messaggio di errore.

Ogni archivio delle cassette postali deve essere associato a un archivio di cartelle pubbliche predefinito, sul server locale o su un altro server. Per ogni utente abilitato alle cassette postali che sia supportato da uno specifico archivio delle cassette postali, l'archivio di cartelle pubbliche associato rappresenta l'archivio di cartelle pubbliche principale dell'utente stesso. Se possibile, utilizzare l'archivio delle cartelle pubbliche predefinito nello stesso server in cui si trova l'archivio delle cassette postali.

Nota:
In tal modo è possibile migliorare le prestazioni quando gli utenti accedono alle cartelle pubbliche e semplificare la risoluzione dei problemi di accesso a tali cartelle.
Per assegnare un archivio di cartelle pubbliche predefinito a un archivio delle cassette postali

  1. In Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sul gruppo di archiviazione in cui risiede l'archivio delle cassette postali.

  2. Fare clic con il pulsante destro del mouse sull'archivio delle cassette postali, quindi scegliere Proprietà.

  3. Nella scheda Generale fare clic su Sfoglia in Default Public folder store e selezionare l'archivio delle cartelle pubbliche da associare a questo archivio delle cassette postali.

    Nota:
    Se si crea un nuovo archivio delle cassette postali, Exchange Server seleziona automaticamente un archivio delle cartelle pubbliche predefinito associato alla struttura Cartelle pubbliche nonché una rubrica non in linea, che potrà essere scaricata dagli utenti per utilizzarla quando non sono connessi.

Per ulteriori informazioni sulla gestione degli archivi delle cassette postali e delle cartelle pubbliche, consultare il Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47617.


La dimensione dell'archivio delle cassette postali supera i 12 GB
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-02-28

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_DataFile per determinare il valore della chiave FileSize per ogni file di database dell'archivio delle cassette postali di Exchange (file con estensione EDB) e file di flusso (file con estensione STM). Exchange Server Analyzer consente anche di leggere il ramo del Registro di sistema indicato di seguito per determinare la versione di Exchange Server installata:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Exchange Product GUID>

Se Exchange Server Analyzer rileva che la dimensione complessiva di una coppia di database dell'archivio delle cassette postali e file di flusso supera i 12 GB in un computer che esegue Microsoft Exchange Server 2003 Standard Edition o Microsoft Exchange 2000 Server Standard Edition, verrà visualizzato un avviso.

I database di archiviazione di Exchange in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition non possono superare la dimensione di 16 GB. Quando viene raggiunto questo limite, l'archivio delle cassette postali non verrà più installato e sarà impossibile accedere a Exchange. Le dimensioni dei database di archiviazione di Exchange in Exchange Server 2003 Enterprise Edition ed Exchange 2000 Server Enterprise Edition non sono limitate a 16 GB. Il loro limite dipende solo dall'hardware disponibile, con una dimensione massima teorica di 16 terabyte.

Per risolvere il problema

  1. Provare a spostare alcune delle cassette postali dall'archivio delle cassette postali di grandi dimensioni a un nuovo archivio delle cassette postali in questo o un altro computer Exchange Server.

  2. Se si sono recentemente spostate cassette postali da questo archivio informazioni a un altro archivio, oppure se si sono recentemente eliminate cassette postali da questo archivio delle cassette postali, è possibile ridurre la dimensione dei file eseguendo una deframmentazione non in linea.

  3. Provare a impostare dei limiti per la dimensione delle cassette postali e dei messaggi per impedire una crescita illimitata dell'archivio delle cassette postali.
Nota:
Con la versione di Exchange Server 2003 Service Pack 2 (SP2), in Exchange Server 2003 Standard Edition, il limite consentito per la dimensione dei database specificato a livello di codice è stato aumentato da 16 GB a 75 GB. L'amministratore può impostare un limite di protezione per la dimensione dei database in modo tale da impedirne la crescita indesiderata. Nel Service Pack 2 per Standard Edition, il valore predefinito è 18 GB ma può essere sostituito modificando la chiave Database Size Limit in Gb del Registro di sistema.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il limite per la dimensione dei database con Exchange Server 2003 SP2

  1. Nel computer che esegue Exchange Server, avviare Regedit.exe.

  2. Aprire la seguente chiave del Registro di sistema: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome server\GUID dell'archivio cassette postali privato

  3. Fare clic con il pulsante destro del mouse su GUID dell'archivio privato, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Per il nuovo nome del valore, digitare Database Size Limit in Gb.

  5. Fare doppio clic su Database Size Limit in Gb. Nel campo Dati valore digitare un valore appropriato in GB per la dimensione massima dei database. Per Exchange Server 2003 Standard Edition, digitare un valore decimale compreso tra 1 e 75 (il valore predefinito è 18 GB). Per Exchange Server 2003 Enterprise Edition, digitare un valore decimale compreso tra 1 e 8000 (il valore predefinito è 8000 GB). Fare clic su OK.

  6. Fare clic con il pulsante destro del mouse su GUID dell'archivio privato, scegliere Nuovo, quindi fare clic su Valore DWORD.

  7. Per il nuovo nome del valore, digitare Database Size Buffer in Percentage.

  8. Fare doppio clic su Database Size Buffer in Percentage. In Dati valore digitare un valore decimale compreso tra 1 e 100 per specificare quando devono essere registrati gli eventi indicanti che si sta raggiungendo il limite massimo per un database. Il valore predefinito 10 implica la registrazione di eventi di avviso quando rimane una capacità del 10% prima che venga raggiunto il limite massimo per il database. Fare clic su OK.

  9. Fare clic con il pulsante destro del mouse su GUID dell'archivio privato, scegliere Nuovo, quindi fare clic su Valore DWORD.

  10. Per il nuovo nome, digitare Database Size Check Start Time in Hours From Midnight.

  11. Fare doppio clic su Database Size Check Start Time in Hours From Midnight. In Dati valore digitare un valore compreso tra 0 e 23 per specificare quando si desidera che Exchange esegua una verifica della dimensione dei database. Il valore predefinito 5 implica la verifica della dimensione dei database in Exchange Server 5 ore dopo la mezzanotte (5.00). Fare clic su OK.

  12. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui file con estensione STM ed EDB, consultare l'articolo 232323 della Microsoft Knowledge Base "Archiviazione di contenuti nativi in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange 2000 Server, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Per ulteriori informazioni sull'esecuzione di una deframmentazione non in linea di un database di Exchange Server, consultare l'articolo 328804 della Microsoft Knowledge Base "Deframmentazione dei database di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Per ulteriori informazioni sull'impostazione di limiti per la dimensione dei messaggi, consultare l'articolo 322679 della Microsoft Knowledge Base "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.

Per informazioni sulla dimensione massima del database che può essere raggiunta nelle edizioni Standard di Exchange Server, consultare l'articolo 828070 della Microsoft Knowledge Database "L'archivio delle cassette postali di Exchange Server non si installa quando il database dell'archivio delle cassette postali raggiunge il limite di 16-GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Per ulteriori informazioni sui Service Pack per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


La dimensione dell'archivio delle cassette postali supera i 15 GB
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-02-28

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_DataFile per determinare il valore della chiave FileSize per ogni file di database dell'archivio delle cassette postali di Exchange (file con estensione EDB) e file di flusso (file con estensione STM). Exchange Server Analyzer consente anche di leggere il ramo del Registro di sistema indicato di seguito per determinare la versione di Exchange Server installata:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID del prodotto Exchange>

Se Exchange Server Analyzer rileva che la dimensione combinata di una coppia di file di flusso e di database dell'archivio delle cassette postali supera 15 GB su un computer che esegue Microsoft Exchange Server 2003 Standard Edition o Microsoft Exchange 2000 Server Standard Edition, verrà visualizzato un messaggio di errore.

I database di archiviazione di Exchange in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition non possono superare la dimensione di 16 GB. Quando viene raggiunto questo limite, l'archivio delle cassette postali non verrà più installato e sarà impossibile accedere a Exchange. Le dimensioni dei database di archiviazione di Exchange in Exchange Server 2003 Enterprise Edition ed Exchange 2000 Server Enterprise Edition non sono limitate a 16 GB. Il loro limite dipende solo dall'hardware disponibile, con una dimensione massima teorica di 16 terabyte.

Per risolvere il problema

  1. Provare a spostare alcune delle cassette postali dall'archivio delle cassette postali di grandi dimensioni a un nuovo archivio delle cassette postali in questo o un altro computer Exchange Server.

  2. Se si sono recentemente spostate cassette postali da questo archivio informazioni a un altro archivio, oppure se si sono recentemente eliminate cassette postali da questo archivio delle cassette postali, è possibile ridurre la dimensione dei file eseguendo una deframmentazione non in linea.

  3. Provare a impostare dei limiti per la dimensione delle cassette postali e dei messaggi per impedire una crescita illimitata dell'archivio delle cassette postali.
Nota:
Con la versione di Exchange Server 2003 Service Pack 2 (SP2), in Exchange Server 2003 Standard Edition, il limite consentito per la dimensione dei database specificato a livello di codice è stato aumentato da 16 GB a 75 GB. L'amministratore può impostare un limite di protezione per la dimensione dei database in modo tale da impedirne la crescita indesiderata. Nel Service Pack 2 per Standard Edition, il valore predefinito è 18 GB ma può essere sostituito modificando la chiave Database Size Limit in GB del Registro di sistema.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il limite per la dimensione dei database con Exchange Server 2003 SP2

  1. Nel computer che esegue Exchange Server, avviare Regedit.exe.

  2. Aprire la seguente chiave del Registro di sistema: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome server\GUID dell'archivio cassette postali privato

  3. Fare clic con il pulsante destro del mouse su GUID dell'archivio privato, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Per il nuovo nome del valore, digitare Database Size Limit in Gb.

  5. Fare doppio clic su Database Size Limit in Gb. Nel campo Dati valore digitare un valore appropriato in GB per la dimensione massima dei database. Per Exchange Server 2003 Standard Edition, digitare un valore decimale compreso tra 1 e 75 (il valore predefinito è 18 GB). Per Exchange Server 2003 Enterprise Edition, digitare un valore decimale compreso tra 1 e 8000 (il valore predefinito è 8000 GB). Fare clic su OK.

  6. Fare clic con il pulsante destro del mouse su GUID dell'archivio privato, scegliere Nuovo, quindi fare clic su Valore DWORD.

  7. Per il nuovo nome del valore, digitare Database Size Buffer in Percentage.

  8. Fare doppio clic su Database Size Buffer in Percentage. In Dati valore digitare un valore decimale compreso tra 1 e 100 per specificare quando devono essere registrati gli eventi indicanti che si sta raggiungendo il limite massimo per un database. Il valore predefinito 10 implica la registrazione di eventi di avviso quando rimane una capacità del 10% prima che venga raggiunto il limite massimo per il database. Fare clic su OK.

  9. Fare clic con il pulsante destro del mouse su GUID dell'archivio privato, scegliere Nuovo, quindi fare clic su Valore DWORD.

  10. Per il nuovo nome, digitare Database Size Check Start Time in Hours From Midnight.

  11. Fare doppio clic su Database Size Check Start Time in Hours From Midnight. In Dati valore digitare un valore compreso tra 0 e 23 per specificare quando si desidera che Exchange esegua una verifica della dimensione dei database. Il valore predefinito 5 implica la verifica della dimensione dei database in Exchange Server 5 ore dopo la mezzanotte (5.00). Fare clic su OK.

  12. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui file con estensione STM ed EDB, consultare l'articolo 232323 della Microsoft Knowledge Base "Archiviazione di contenuti nativi in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange 2000 Server, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Per ulteriori informazioni sull'esecuzione di una deframmentazione non in linea di un database di Exchange Server, consultare l'articolo 328804 della Microsoft Knowledge Base "Deframmentazione dei database di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Per ulteriori informazioni sull'impostazione di limiti per la dimensione dei messaggi, consultare l'articolo 322679 della Microsoft Knowledge Base "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.

Per ulteriori informazioni sulla dimensione massima del database che può essere raggiunta in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition, consultare l'articolo 828070 della Microsoft Knowledge Base "Mancata installazione dell'archivio delle cassette postali di Exchange Server quando il database dell'archivio delle cassette postali raggiunge il limite di 16 GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Per ulteriori informazioni sui Service Pack per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


Il backup completo dell'archivio cassette postali non è stato eseguito da più di 8 giorni
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query in ogni archivio di cassette postali per determinare la data e l'ora dell'ultimo backup completo. Inoltre, viene eseguita una query nel servizio directory di Active Directory® per determinare il numero di utenti con cassette postali in ogni archivio di cassette postali. Se le seguenti condizioni vengono soddisfatte, verrà visualizzato un avviso:

  • Il numero di giorni dalla data di esecuzione dell'ultimo backup completo per un archivio delle cassette postali è superiore a otto.

  • Nell'archivio delle cassette postali esistono più di dieci cassette postali.

L'archivio delle cassette postali è un database per l'archiviazione di cassette postali in Microsoft Exchange Server 2003 ed Exchange Server 2007. Un archivio delle cassette postali è costituito da un file RTF (edb) e da un file di flusso di contenuto Internet nativo (stm). Sebbene esistano due file, ovvero il file con estensione EDB e quello con estensione STM, questi rappresentano le due parti di un singolo database e non due database distinti.

I dati dell'archivio delle cassette postali e dell'archivio delle cartelle pubbliche nei database di Exchange Server e nei file di registro delle transazioni sono i dati più importanti di cui eseguire il backup nell'organizzazione di Exchange Server. È possibile utilizzare un backup del database di Exchange Server per ripristinare una cassetta postale danneggiata in un server correttamente funzionante su cui è in esecuzione Exchange Server. È inoltre possibile utilizzare i backup dei database di Exchange Server per ripristinarli in un server diverso.

Si consiglia di eseguire quotidianamente un backup completo dei file di database e dei registri delle transazioni. Al termine di un backup completo di un gruppo di archiviazione, i file di registro delle transazioni salvati nei database di Exchange Server verranno eliminati dal server. In uno scenario di ripristino, un backup completo offre il vantaggio di una velocità maggiore, poiché è sufficiente un unico set di nastri per ripristinare tutti i dati.

Nota:
È consigliabile conservare i file di registro delle transazioni su un apposito disco separato dai file di database. Ciò consente la tolleranza di errore nel caso in cui un disco venga distrutto e, in alcuni casi, migliora le prestazioni del database.
Importante:
Quando si esegue il backup o il ripristino dei file e delle cartelle, è necessario disporre delle autorizzazioni o dei diritti assegnati all'account utente con cui si è eseguito l'accesso. Per creare backup di Exchange Server, è necessario disporre dei diritti di Backup Operators a livello di dominio. Per creare backup del sistema operativo Microsoft Windows Server™ 2003, è necessario disporre almeno dei diritti di Backup Operators a livello locale.

La scelta della strategia di backup per i dati di Exchange Server dipende dalla dimensione degli archivi, dalla velocità del software e dell'hardware di backup, dalla capacità dell'hardware e dai requisiti di tempo.

Per ulteriori informazioni sulle strategie di backup e sulle operazioni di ripristino di emergenza, consultare:

  • Guida al ripristino di emergenza di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47570.

  • Backup e ripristino dei database all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80766.


Il backup completo dell'archivio cassette postali non è stato eseguito da più di 60 giorni
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query in ogni archivio di cassette postali per determinare la data e l'ora dell'ultimo backup completo. Inoltre, viene eseguita una query nel servizio directory di Active Directory® per determinare il numero di utenti con cassette postali in ogni archivio di cassette postali. Se entrambe le seguenti condizioni vengono soddisfatte, verrà visualizzato un messaggio di errore:

  • Il numero di giorni trascorsi dalla data di esecuzione dell'ultimo backup completo per un archivio delle cassette postali è superiore a 60.

  • Nell'archivio delle cassette postali esistono più di 10 cassette postali.

L'archivio delle cassette postali è un database per l'archiviazione di cassette postali in Microsoft Exchange Server 2003 e Microsoft Exchange Server 2007. Un archivio delle cassette postali è costituito da un file RTF (edb) e da un file di flusso di contenuto Internet nativo (stm). Sebbene esistano due file, ovvero il file con estensione EDB e quello con estensione STM, questi rappresentano le due parti di un singolo database e non due database distinti.

I dati dell'archivio delle cassette postali e dell'archivio delle cartelle pubbliche nei database di Exchange Server e nei file di registro delle transazioni sono i dati più importanti di cui eseguire il backup nell'organizzazione di Exchange Server. È possibile utilizzare un backup del database di Exchange Server per ripristinare una cassetta postale danneggiata in un server correttamente funzionante su cui è in esecuzione Exchange Server. È inoltre possibile utilizzare i backup dei database di Exchange Server per ripristinarli in un server diverso.

Si consiglia di eseguire quotidianamente un backup completo dei file di database e dei registri delle transazioni. Al termine di un backup completo di un gruppo di archiviazione, i file di registro delle transazioni salvati nei database di Exchange Server verranno eliminati dal server. In uno scenario di ripristino, un backup completo offre il vantaggio di una velocità maggiore, poiché è sufficiente un unico set di nastri per ripristinare tutti i dati.

Nota:
È consigliabile conservare i file di registro delle transazioni su un apposito disco separato dai file di database. Ciò consente la tolleranza di errore nel caso in cui un disco venga distrutto e, in alcuni casi, migliora le prestazioni del database.
Importante:
Quando si esegue il backup o il ripristino dei file e delle cartelle, è necessario disporre delle autorizzazioni o dei diritti assegnati all'account utente con cui si è eseguito l'accesso. Per creare backup di Exchange Server, è necessario disporre dei diritti di Backup Operators a livello di dominio. Per creare backup del sistema operativo Microsoft Windows Server™ 2003, è necessario disporre almeno dei diritti di Backup Operators a livello locale.

La scelta della strategia di backup per i dati di Exchange Server dipende dalla dimensione degli archivi, dalla velocità del software e dell'hardware di backup, dalla capacità dell'hardware e dai requisiti di tempo.

Per ulteriori informazioni sulle strategie di backup e sulle operazioni di ripristino di emergenza, consultare:

  • Guida al ripristino di emergenza di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47570.

  • Backup e ripristino dei database all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80766.


Sovrapposizione delle pianificazioni di manutenzione in linea dell'archivio delle cassette postali
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se tutti gli archivi di cassette postali del gruppo di archiviazione presentano la stessa pianificazione di manutenzione. Se il contenitore del gruppo di archiviazione (classe msExchStorageGroup) dispone di due o più oggetti archivio cassette postali (classe msExchPrivMDB), Exchange Server Analyzer verificherà l'attributo activationSchedule di ciascun oggetto archivio cassette postali. Se Exchange Server Analyzer rileva che i valori in questione (archiviati come stringhe di ottetti) sono identici per ciascun archivio delle cassette postali o che si sovrappongono, verrà visualizzato un avviso.

Per impostazione predefinita, i processi di manutenzione degli archivi di cassette postali vengono eseguiti di notte dall'una alle cinque. A causa delle risorse di server richieste per tali processi, si consiglia di modificare le pianificazioni di manutenzione in modo che gli archivi delle cassette postali presentino pianificazioni che differiscono di almeno 15 minuti.

Per risolvere il problema in Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Server, quindi la struttura del server che si desidera utilizzare.

  3. Espandere la struttura del gruppo di archiviazione che si desidera utilizzare.

  4. Fare clic con il pulsante destro del mouse sull'archivio che si desidera utilizzare e scegliere Proprietà.

  5. Nella scheda Database selezionare Intervallo di manutenzione e scegliere un nuovo intervallo oppure selezionare Personalizza per creare una pianificazione personalizzata.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Configurazione server e selezionare il server che si desidera utilizzare.

  3. Espandere la struttura del gruppo di archiviazione che si desidera utilizzare.

  4. Fare clic con il pulsante destro del mouse sull'archivio che si desidera utilizzare e scegliere Proprietà.

  5. Nella scheda Generale fare clic sull'elenco a discesa Pianificazione manutenzione e selezionare un nuovo intervallo, oppure scegliere Personalizza per creare una pianificazione personalizzata.

Per ulteriori informazioni sulla manutenzione dell'archivio di Exchange Server 2003, consultare "Configurazione delle opzioni di manutenzione e backup degli archivi" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


I limiti dell'archivio delle cassette postali per impedire l'invio e la ricezione sono troppo simili
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare i limiti della dimensione impostati su una cassetta postale. Se Exchange Server Analyzer rileva che la differenza dei limiti della cassetta postale tra Prohibit send e Prohibit send and receive è inferiore al 20%, verrà visualizzato un messaggio di configurazione ottimale.

È consigliabile separare i limiti Prohibit send e Prohibit send and receive di un valore minimo del 20 per cento. Se la differenze tra i limiti è inferiore al 20 per cento, l'utente potrebbe non disporre di tempo sufficiente per liberare la cassetta postale prima che essa inizi a rifiutare i messaggi in eccesso. Ad esempio, se gli utenti non possono più inviare nuovi messaggi quando la cassetta postale raggiunge i 100 MB, il limite Prohibit send and receive dovrebbe essere di almeno 120 MB.

Nota:
È inoltre importante impostare un limite di avviso per le cassette postali. Quando la cassetta raggiunge il limite di avviso, verrà inviato all'utente un messaggio di posta elettronica, che avverte che la cassetta sta per raggiungere il limite definito in Prohibit send.

Per risolvere il problema, è consigliabile aumentare la differenza tra i limiti Prohibit send e Prohibit send and receive di un valore superiore al 20 per cento.

Per impostare i limiti delle cassette postali

  1. Aprire Gestore di sistema di Exchange.

  2. Individuare l'archivio delle cassette postali visualizzato nel messaggio di Exchange Server Analyzer.

  3. Fare clic con il pulsante destro del mouse su MailboxStore_Name e selezionare Proprietà.

  4. Selezionare la scheda Limiti.

  5. Modificare il limite Impedisci l'invio a (KB) o Impedisci l'invio e la ricezione a (KB) o entrambi.

  6. Fare clic su Applica, quindi su OK.
Per impostare i limiti delle cassette postali in Exchange Server 2007 utilizzando Exchange Management Console

  1. Aprire Exchange Management Console.

  2. Individuare l'archivio delle cassette postali visualizzato in Exchange Server Analyzer in relazione a questo problema.

  3. Fare clic con il pulsante destro del mouse su MailboxStore_Name e selezionare Proprietà.

  4. Selezionare la scheda Limiti.

  5. Modificare Invia avviso a (KB), il limite Impedisci l'invio a (KB) e il limite Impedisci l'invio e la ricezione a (KB).

  6. Fare clic su Applica, quindi su OK.
Per impostare i limiti delle cassette postali in Exchange Server 2007 utilizzando Exchange Management Shell

  1. Nell'esempio seguente viene illustrato come impostare il limite di dimensione delle cassette postali al cui raggiungimento l'utente riceve un messaggio di avviso. Questo attributo si applica a tutte le cassette postali del database per le quali non è impostato l'attributo delle quote di avviso. È necessario specificare un valore intero o "illimitato". Il valore predefinito è 1,9 gigabyte (GB).
Copia codice
Set-MailboxDatabase "Mailbox Database Name" -IssueWarningQuota 1991680
  1. Nell'esempio seguente viene illustrato come impostare la dimensione delle cassette postali al cui raggiungimento gli utenti associati alle cassette postali nel relativo database non possono più inviare messaggi. Questo attributo si applica a tutte le cassette postali del database in questione per le quali non sono impostati gli attributi delle quote per impedire l'invio di messaggi. È necessario specificare un valore intero o "illimitato".

Copia codice
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendQuota 2097152
  1. Nell'esempio seguente viene illustrato come impostare la dimensione delle cassette postali al cui raggiungimento gli utenti associati alle cassette postali non possono più inviare e ricevere messaggi. Questo attributo si applica a tutte le cassette postali del database in questione per le quali non sono impostati gli attributi delle quote per impedire l'invio e la ricezione di messaggi. È necessario specificare un valore intero o "illimitato".

Copia codice
Set-MailboxDatabase "Mailbox Database Name" -ProhibitSendReceiveQuota 2411520

Per ulteriori informazioni sulla gestione delle cassette postali in Exchange, consultare Working with Exchange Server 2003 Stores all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).

Per ulteriori informazioni su come gestire i limiti di dimensione delle cassette postali di Exchange in Exchange Server 2007, vedere "Come configurare i limiti e le proprietà del database" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80746.


L'archivio delle cassette postali non verrà installato all'avvio
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchEDBOffline di tutti gli oggetti con una classe di msExchPrivateMDB. Gli oggetti con questa classe corrispondono ad archivi di cassette postali.

Il valore True per l'attributo msExchEDBOffline indica che l'archivio delle cassette postali non verrà installato automaticamente all'avvio del servizio Archivio informazioni di Microsoft Exchange. Il valore False indica che l'archivio delle cassette postali verrà installato all'avvio. Se Exchange Server Analyzer rileva che il valore di questo attributo è True, verrà visualizzato un avviso.

Questo avviso indica che è selezionata la casella di controllo Non installare archivio all'avvio. La casella di controllo si trova nella scheda Database della finestra di dialogo Proprietà dell'archivio delle cassette postali. Se la casella di controllo è selezionata, l'archivio delle cassette postali non verrà installato automaticamente all'avvio del servizio Archivio informazioni di Microsoft Exchange. Al successivo avvio del servizio, ad esempio dopo aver riavviato il server, gli archivi delle cassette postali con questo attributo impostato su True non verranno installati. Si consiglia di impostare l'installazione automatica degli archivi delle cassette postali all'avvio del servizio Archivio informazioni di Microsoft Exchange.

Per risolvere il problema in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, quindi espandere il server che contiene l'archivio delle cassette postali che si desidera modificare.

  3. Espandere il gruppo di archiviazione che contiene l'archivio delle cassette postali da modificare.

  4. Fare clic con il pulsante destro del mouse sull'archivio delle cassette postali, quindi scegliere Proprietà.

  5. Nella scheda Database deselezionare la casella di controllo Non installare archivio all'avvio.

  6. Fare clic su OK per salvare le modifiche.

  7. Chiudere Gestore di sistema di Exchange.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Configurazione server e selezionare il server che si desidera utilizzare.

  3. Espandere il gruppo di archiviazione che si desidera utilizzare.

  4. Fare clic con il pulsante destro del mouse sul database che si desidera utilizzare e scegliere Proprietà.

  5. Nella scheda Generale deselezionare la casella di controllo Non installare database all'avvio.

  6. Fare clic su OK per salvare le modifiche.

  7. Chiudere Exchange Management Console.

Per ulteriori informazioni su questa opzione, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 314218, "HOW TO: Attivare o disattivare l'installazione automatica di archivi dati all'avvio di Exchange 2000" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=314218)

  • 285169, "XADM: Impossibile installare archivi di informazioni dopo l'utilizzo dell'opzione "/disasterrecovery"" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=285169)


Parametro Max FXGetBuffer Users non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la chiave del Registro di sistema Max FXGetBuffer Users è stata creata:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che la chiave del Registro di sistema Max FXGetBuffer Users è stata creata sotto ParametersSystem, verrà visualizzato un messaggio di configurazione non predefinita.

È possibile utilizzare la chiave Max FXGetBuffer Users del Registro di sistema per controllare il numero dei client Microsoft Office Outlook® 2003 sincronizzati con un server di Exchange Server 2003 in un determinato momento. Impostare il valore della chiave Max FXGetBuffer Users del Registro di sistema in modo da ignorare il limite durante le connessioni RPC (Remote Procedure Call) simultanee eseguite da client Outlook. Tali connessioni vengono talvolta definite ropFXSrcGetBuffers. Per calcolare il valore predefinito della chiave Max FXGetBuffer Users del Registro di sistema, moltiplicare per 2 il numero di processori presenti nel server, quindi aggiungere 3. Ad esempio, in un server di Exchange Server 2003 con due processori, il valore predefinito è 7 ([2*2] + 3=7).

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore Max FXGetBuffer Users.

  4. Chiudere l'editor del Registro di sistema.

Il servizio Archivio informazioni di Microsoft Exchange impiega pochi minuti per rilevare le modifiche. Non è necessario riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione delle chiavi del Registro di sistema per controllare il numero di client Outlook che possono sincronizzarsi con Exchange Server 2003, consultare l'articolo 818484 della Microsoft Knowledge Base "Contatori e valori del Registro di sistema che consentono di configurare e monitorare la sincronizzazione del client Outlook" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=818484.


Il numero massimo di allegati per messaggio inviato è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stato modificato il numero massimo di allegati per messaggio:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtAttachment

Se Exchange Server Analyzer rileva che il valore objtAttachment del Registro di sistema è presente e configurato con un valore non corrispondente a quello visualizzato nella tabella riportata di seguito, viene visualizzato un messaggio per indicare che la configurazione non è quella predefinita.

Voce | Valore predefinito di Exchange Server 2003 RTM | Valore predefinito di Exchange Server 2003 SP1 e versioni successive | Valore predefinito di Exchange Server 2007
objtAttachment | 100 | 500 | 500

Se aggiunto e configurato manualmente, il valore objtAttachment del Registro di sistema determina il numero massimo di allegati per messaggio inviato per client MAPI. Quando un client MAPI tenta di inviare un messaggio con un numero di allegati superiore a quello consentito, l'evento seguente viene registrato nel registro eventi dell'applicazione sul computer Exchange Server che contiene la cassetta postale del client:

Tipo di evento: | Errore
ID evento: | 9646
Origine evento: | MSExchangeIS
Categoria evento: | Generale
Descrizione: | Chiusura della sessione MAPI "/o=NomeOrganizzazione/ou=NomeGruppoAmministrativo/cn=Recipients/cn=NomeUtente" poiché superava il numero massimo di xxx oggetti di tipo "objtAttachment".

Il valore objtAttachment del Registro di sistema rappresenta una possibilità di configurazione che offre all'amministratore un livello di controllo ottimale sulle risorse di Exchange Server utilizzate dai client MAPI.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Eliminare il valore objtAttachment del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

In alternativa, se si desidera utilizzare il valore objtAttachment del Registro di sistema, invece di eliminarlo, impostarlo sul valore esistente o regolarlo, se necessario.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni, consultare l'articolo 830829 della Microsoft Knowledge Base "Interruzione di risposta da parte del computer Exchange Server 2003 dopo che il client MAPI ha aperto un numero di oggetti server maggiore di quello predefinito" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829.


Il numero massimo di visualizzazioni memorizzate nella cache è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il numero massimo di visualizzazioni memorizzato nella cache per ciascun database è stato modificato. Se Exchange Server Analyzer rileva che l'attributo msExchMaxCachedViews è stato impostato su un valore diverso da quello predefinito di 11, verrà visualizzato un messaggio di configurazione non predefinita. Il numero di visualizzazioni memorizzate nella cache che è stato configurato per ciascun database è incluso nell'output di Exchange Server Analyzer. Si consiglia di impostare un numero di visualizzazioni memorizzate nella cache compreso tra 5 e 20.

L'attributo msExchMaxCachedViews appartiene alla classe oggetto msExchangePrivateMDB. Pertanto, in Active Directory, ciascun oggetto database dell'archivio delle cassette postali presenta un valore per l'attributo msExchMaxCachedViews. Il valore dell'attributo msExchMaxCachedViews determina il numero massimo di visualizzazioni che vengono memorizzate nella cache per una cartella specifica in una cassetta postale. In questo contesto, il termine "visualizzazione" si riferisce alle cartelle che vengono visualizzate quando un utente accede alla cassetta postale Microsoft Office Outlook® 2003 di un altro utente. Quando gli utenti condividono l'accesso a una cartella di Outlook con altri utenti, viene creata una visualizzazione che consente di nascondere gli elementi privati.

Quando un utente di Outlook visualizza per la prima volta il calendario, la cartella dei contatti o i dati di un altro utente, potrebbero verificarsi dei ritardi. Dopo aver visualizzato la cartella, i successivi tentativi di accesso potrebbero essere più veloci. Tuttavia, dopo un certo intervallo di tempo, è possibile che si verifichino ulteriori ritardi. In genere, essi sono più evidenti quando la cartella contiene un numero considerevole di elementi, ovvero un numero uguale o superiore a 5.000.

L'applicazione di una visualizzazione a una cartella fa sì che vengano create, nell'archivio di Exchange, delle cartelle di ricerca per ciascun utente che accede alla cartella di Outlook. Al momento della creazione, ogni cartella di ricerca viene memorizzata nella cache per l'utilizzo futuro. Prima di creare una nuova cartella di ricerca, viene rilevato se la cartella di ricerca è già esistente. Se esiste già, in Exchange Server viene utilizzata la cartella di ricerca memorizzata nella cache per accelerare le visualizzazioni successive.

L'attributo msExchMaxCachedViews definisce il numero delle cartelle di ricerca memorizzate nella cache in una cartella specifica. Ad esempio, l'attributo msExchMaxCachedViews può definire il numero delle cartelle di ricerca memorizzate nella cache nella cartella Calendario.

Se le cartelle di Outlook vengono condivise da molti utenti, è necessario decidere come bilanciare le risorse del server con le prestazioni accettabili del client. Quando una cartella di ricerca è memorizzata nella cache, viene aggiornata ogni volta che viene modificata. Tali aggiornamenti utilizzano le risorse della CPU e del disco. La presenza di più cache della cartella di ricerca influisce ulteriormente sulle prestazioni della CPU e del disco.

D'altra parte, quando in Exchange Server viene creata una cartella di ricerca per la prima volta, l'utente che accede alla cartella di Outlook può riscontrare un ritardo al momento della creazione della cartella di ricerca.

Si consideri un esempio in cui Exchange Server sia stato configurato con 11 cartelle di ricerca. Il numero predefinito delle cartelle di ricerca sarà undici. L'utente A condivide la cartella Calendario con altri 15 utenti. L'utente B accede alla cartella e riscontra un ritardo al momento della creazione della cartella di ricerca. Dopo la creazione della cartella di ricerca per l'utente B, l'accesso alla cartella Calendario dell'utente A è più rapido. Si supponga che l'utente B non acceda alla cartella per il resto della giornata. Nel frattempo, se altri 11 utenti accedono alla cartella, verranno create altrettante cartelle di ricerca univoche. Dal momento che vengono memorizzate nella cache solo 11 cartelle di ricerca, quando l'utente B accede successivamente al Calendario dell'utente A potrebbero verificarsi nuovamente dei ritardi mentre viene creata la cartella di ricerca.

Si consiglia di limitare il numero massimo delle cartelle di ricerca memorizzate nella cache a un valore uguale o inferiore a 20. Se si supera questo numero, in particolare nel caso di cartelle che contengono più di 5.000 elementi, può verificarsi un sovraccarico del server durante il tentativo di conservare le cartelle memorizzate nella cache.

Inoltre, è consigliabile disporre di almeno cinque cache. Se gli utenti condividono le cartelle di Outlook con più utenti, la memorizzazione di solo quattro cartelle di ricerca nella cache avrà ripercussioni negative sul client e dovranno essere utilizzate maggiori risorse per la creazione più frequente di nuove cache.

L'attributo msExchMaxCachedViews, inoltre, può essere impostato nei database delle cartelle pubbliche. Anche per le cartelle pubbliche vengono create delle cartelle di ricerca. Per impostazione predefinita, le cartelle pubbliche sono risorse condivise a cui possono accedere molti utenti. Se le cartelle pubbliche ricevono molti inserimenti, è necessario ridurre le cartelle di ricerca poiché nel server di Exchange potrebbe verificarsi un utilizzo eccessivo della CPU e del disco durante l'aggiornamento delle cartelle di ricerca. Inoltre, se numerosi utenti accedono a una cartella pubblica, non è consigliabile tentare di ottimizzare le prestazioni del client fornendo numerose cache delle cartelle di ricerca. È probabile che le cache vengano eliminate quando si creano nuove cartelle di ricerca per i nuovi utenti.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per modificare l'attributo msExchMaxCachedViews

  1. Avviare lo strumento ADSI Edit dagli Strumenti di supporto di Microsoft Windows® 2000 o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Gruppi amministrativi

    • Administrative_Group_Name

    • Server

    • InformationStore

    • Storage_Group_Name

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su Database_Name e scegliere Proprietà.

  4. Nella casella Attributi fare doppio clic su msExchMaxCachedViews.

  5. Nella finestra di dialogo Integer Attribute Editor immettere un numero intero compreso tra 5 e 20 nel campo Valore, quindi fare clic su OK.

  6. Fare clic su Applica, quindi chiudere ADSI Edit.

  7. Attendere almeno 15 minuti per la replica, quindi riavviare il servizio Archivio informazioni di Microsoft Exchange nel server di Exchange in cui si è apportata la modifica.


Il numero massimo di visualizzazioni memorizzate nella cache è stato impostato su un valore troppo alto
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il numero massimo di visualizzazioni memorizzato nella cache per ciascun database è stato modificato. Se Exchange Server Analyzer rileva che l'attributo msExchMaxCachedViews è impostato su una valore maggiore di 20, verrà visualizzato un avviso. Il numero di visualizzazioni memorizzate nella cache che è stato configurato per ciascun database è incluso nell'output di Exchange Server Analyzer. Si consiglia di impostare un numero di visualizzazioni memorizzate nella cache compreso tra 5 e 20.

L'attributo msExchMaxCachedViews appartiene alla classe oggetto msExchangePrivateMDB. Pertanto, in Active Directory, ciascun oggetto database dell'archivio delle cassette postali presenta un valore per l'attributo msExchMaxCachedViews. Il valore dell'attributo msExchMaxCachedViews determina il numero massimo di visualizzazioni che vengono memorizzate nella cache per una cartella specifica in una cassetta postale. In questo contesto, il termine "visualizzazione" si riferisce alle cartelle che vengono visualizzate quando un utente accede alla cassetta postale Microsoft Office Outlook® 2003 di un altro utente. Quando gli utenti condividono l'accesso a una cartella di Outlook con altri utenti, viene creata una visualizzazione che consente di nascondere gli elementi privati.

Quando un utente di Outlook visualizza per la prima volta il calendario, la cartella dei contatti o i dati di un altro utente, potrebbero verificarsi dei ritardi. Dopo aver visualizzato la cartella, i successivi tentativi di accesso potrebbero essere più veloci. Tuttavia, dopo un certo intervallo di tempo, è possibile che si verifichino ulteriori ritardi. In genere, essi sono più evidenti quando la cartella contiene un numero considerevole di elementi, ovvero un numero uguale o superiore a 5.000.

L'applicazione di una visualizzazione a una cartella fa sì che vengano create, nell'archivio di Exchange, delle cartelle di ricerca per ciascun utente che accede alla cartella di Outlook. Al momento della creazione, ogni cartella di ricerca viene memorizzata nella cache per l'utilizzo futuro. Prima di creare una nuova cartella di ricerca, viene rilevato se la cartella di ricerca è già esistente. Se esiste già, in Exchange Server viene utilizzata la cartella di ricerca memorizzata nella cache per accelerare le visualizzazioni successive.

L'attributo msExchMaxCachedViews definisce il numero delle cartelle di ricerca memorizzate nella cache in una cartella specifica. Ad esempio, l'attributo msExchMaxCachedViews può definire il numero delle cartelle di ricerca memorizzate nella cache nella cartella Calendario.

Se le cartelle di Outlook vengono condivise da molti utenti, è necessario decidere come bilanciare le risorse del server con le prestazioni accettabili del client. Quando una cartella di ricerca è memorizzata nella cache, viene aggiornata ogni volta che viene modificata. Tali aggiornamenti utilizzano le risorse della CPU e del disco. La presenza di più cache della cartella di ricerca influisce ulteriormente sulle prestazioni della CPU e del disco.

D'altra parte, quando in Exchange Server viene creata una cartella di ricerca per la prima volta, l'utente che accede alla cartella di Outlook può riscontrare un ritardo al momento della creazione della cartella di ricerca.

Si consideri un esempio in cui Exchange Server sia stato configurato con 11 cartelle di ricerca. Il numero predefinito delle cartelle di ricerca sarà undici. L'utente A condivide la cartella Calendario con altri 15 utenti. L'utente B accede alla cartella e riscontra un ritardo al momento della creazione della cartella di ricerca. Dopo la creazione della cartella di ricerca per l'utente B, l'accesso alla cartella Calendario dell'utente A è più rapido. Si supponga che l'utente B non acceda alla cartella per il resto della giornata. Nel frattempo, se altri 11 utenti accedono alla cartella, verranno create altrettante cartelle di ricerca univoche. Dal momento che vengono memorizzate nella cache solo 11 cartelle di ricerca, quando l'utente B accede successivamente al Calendario dell'utente A potrebbero verificarsi nuovamente dei ritardi mentre viene creata la cartella di ricerca.

Si consiglia di limitare il numero massimo delle cartelle di ricerca memorizzate nella cache a un valore uguale o inferiore a 20. Se si supera questo numero, in particolare nel caso di cartelle che contengono più di 5.000 elementi, può verificarsi un sovraccarico del server durante il tentativo di conservare le cartelle memorizzate nella cache.

Inoltre, è consigliabile disporre di almeno cinque cache. Se gli utenti condividono le cartelle di Outlook con più utenti, la memorizzazione di solo quattro cartelle di ricerca nella cache avrà ripercussioni negative sul client e dovranno essere utilizzate maggiori risorse per la creazione più frequente di nuove cache.

L'attributo msExchMaxCachedViews, inoltre, può essere impostato nei database delle cartelle pubbliche. Anche per le cartelle pubbliche vengono create delle cartelle di ricerca. Per impostazione predefinita, le cartelle pubbliche sono risorse condivise a cui possono accedere molti utenti. Se le cartelle pubbliche ricevono molti inserimenti, è necessario ridurre le cartelle di ricerca poiché nel server di Exchange potrebbe verificarsi un utilizzo eccessivo della CPU e del disco durante l'aggiornamento delle cartelle di ricerca. Inoltre, se numerosi utenti accedono a una cartella pubblica, non è consigliabile tentare di ottimizzare le prestazioni del client fornendo numerose cache delle cartelle di ricerca. È probabile che le cache vengano eliminate quando si creano nuove cartelle di ricerca per i nuovi utenti.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per modificare l'attributo msExchMaxCachedViews

  1. Avviare lo strumento ADSI Edit dagli Strumenti di supporto di Microsoft Windows® 2000 o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Gruppi amministrativi

    • Administrative_Group_Name

    • Server

    • InformationStore

    • Storage_Group_Name

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su Database_Name e scegliere Proprietà.

  4. Nella casella Attributi fare doppio clic su msExchMaxCachedViews.

  5. Nella finestra di dialogo Integer Attribute Editor immettere un numero intero compreso tra 5 e 20 nel campo Valore, quindi fare clic su OK.

  6. Fare clic su Applica, quindi chiudere ADSI Edit.

  7. Attendere almeno 15 minuti per la replica, quindi riavviare il servizio Archivio informazioni di Microsoft Exchange nel server di Exchange in cui si è apportata la modifica.


Il numero massimo di visualizzazioni memorizzate nella cache è stato impostato su un valore troppo basso
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il numero massimo di visualizzazioni memorizzato nella cache per ciascun database è stato modificato. Se Exchange Server Analyzer rileva che l'attributo msExchMaxCachedViews è impostato su una valore inferiore a 5, verrà visualizzato un avviso. Il numero di visualizzazioni memorizzate nella cache che è stato configurato per ciascun database è incluso nell'output di Exchange Server Analyzer. Si consiglia di impostare un numero di visualizzazioni memorizzate nella cache compreso tra 5 e 20.

L'attributo msExchMaxCachedViews appartiene alla classe oggetto msExchangePrivateMDB. Pertanto, in Active Directory, ciascun oggetto database dell'archivio delle cassette postali presenta un valore per l'attributo msExchMaxCachedViews. Il valore dell'attributo msExchMaxCachedViews determina il numero massimo di visualizzazioni che vengono memorizzate nella cache per una cartella specifica all'interno di una cassetta postale.

In questo contesto, il termine "visualizzazione" si riferisce alle cartelle che vengono visualizzate quando un utente accede alla cassetta postale Microsoft Office Outlook® 2003 di un altro utente. Quando gli utenti condividono l'accesso a una cartella di Outlook con altri utenti, viene creata una visualizzazione che consente di nascondere gli elementi privati.

Quando un utente di Outlook visualizza per la prima volta il calendario, la cartella dei contatti o i dati di un altro utente, potrebbero verificarsi dei ritardi. Dopo aver visualizzato la cartella, i successivi tentativi di accesso potrebbero essere più veloci. Tuttavia, dopo un certo intervallo di tempo, è possibile che si verifichino ulteriori ritardi. In genere, essi sono più evidenti quando la cartella contiene un numero considerevole di elementi, ovvero un numero uguale o superiore a 5.000.

L'applicazione di una visualizzazione a una cartella fa sì che vengano create, nell'archivio di Exchange, delle cartelle di ricerca per ciascun utente che accede alla cartella di Outlook. Al momento della creazione, ogni cartella di ricerca viene memorizzata nella cache per l'utilizzo futuro. Prima di creare una nuova cartella di ricerca, viene rilevato se la cartella di ricerca è già esistente. Se esiste già, in Exchange Server viene utilizzata la cartella di ricerca memorizzata nella cache per accelerare le visualizzazioni successive.

L'attributo msExchMaxCachedViews definisce il numero delle cartelle di ricerca memorizzate nella cache in una cartella specifica. Ad esempio, l'attributo msExchMaxCachedViews può definire il numero delle cartelle di ricerca memorizzate nella cache nella cartella Calendario.

Se le cartelle di Outlook vengono condivise da molti utenti, è necessario decidere come bilanciare le risorse del server con le prestazioni accettabili del client. Quando una cartella di ricerca è memorizzata nella cache, viene aggiornata ogni volta che viene modificata. Tali aggiornamenti utilizzano le risorse della CPU e del disco. La presenza di più cache della cartella di ricerca influisce ulteriormente sulle prestazioni della CPU e del disco.

D'altra parte, quando in Exchange Server viene creata una cartella di ricerca per la prima volta, l'utente che accede alla cartella di Outlook può riscontrare un ritardo al momento della creazione della cartella di ricerca.

Si consideri un esempio in cui Exchange Server sia stato configurato con 11 cartelle di ricerca. Il numero predefinito delle cartelle di ricerca sarà undici. L'utente A condivide la cartella Calendario con altri 15 utenti. L'utente B accede alla cartella e riscontra un ritardo al momento della creazione della cartella di ricerca. Dopo la creazione della cartella di ricerca per l'utente B, l'accesso alla cartella Calendario dell'utente A è più rapido. Si supponga che l'utente B non acceda alla cartella per il resto della giornata. Nel frattempo, se altri 11 utenti accedono alla cartella, verranno create altrettante cartelle di ricerca univoche. Dal momento che vengono memorizzate nella cache solo 11 cartelle di ricerca, quando l'utente B accede successivamente al Calendario dell'utente A potrebbero verificarsi nuovamente dei ritardi mentre viene creata la cartella di ricerca.

Si consiglia di limitare il numero massimo delle cartelle di ricerca memorizzate nella cache a un valore uguale o inferiore a 20. Se si supera questo numero, in particolare nel caso di cartelle che contengono più di 5.000 elementi, può verificarsi un sovraccarico del server durante il tentativo di conservare le cartelle memorizzate nella cache.

Inoltre, è consigliabile disporre di almeno cinque cache. Se gli utenti condividono le cartelle di Outlook con più utenti, la memorizzazione di solo quattro cartelle di ricerca nella cache avrà ripercussioni negative sul client e dovranno essere utilizzate maggiori risorse per la creazione più frequente di nuove cache.

L'attributo msExchMaxCachedViews, inoltre, può essere impostato nei database delle cartelle pubbliche. Anche per le cartelle pubbliche vengono create delle cartelle di ricerca. Per impostazione predefinita, le cartelle pubbliche sono risorse condivise a cui possono accedere molti utenti. Se le cartelle pubbliche ricevono molti inserimenti, è necessario ridurre le cartelle di ricerca poiché nel server di Exchange potrebbe verificarsi un utilizzo eccessivo della CPU e del disco durante l'aggiornamento delle cartelle di ricerca. Inoltre, se numerosi utenti accedono a una cartella pubblica, non è consigliabile tentare di ottimizzare le prestazioni del client fornendo numerose cache delle cartelle di ricerca. È probabile che le cache vengano eliminate quando si creano nuove cartelle di ricerca per i nuovi utenti.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per modificare l'attributo msExchMaxCachedViews

  1. Avviare lo strumento ADSI Edit dagli Strumenti di supporto di Microsoft Windows® 2000 o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Gruppi amministrativi

    • Administrative_Group_Name

    • Server

    • InformationStore

    • Storage_Group_Name

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su Database_Name e scegliere Proprietà.

  4. Nella casella Attributi fare doppio clic su msExchMaxCachedViews.

  5. Nella finestra di dialogo Integer Attribute Editor immettere un numero intero compreso tra 5 e 20 nel campo Valore, quindi fare clic su OK.

  6. Fare clic su Applica, quindi chiudere ADSI Edit.

  7. Attendere almeno 15 minuti per la replica, quindi riavviare il servizio Archivio informazioni di Microsoft Exchange nel server di Exchange in cui si è apportata la modifica.


Dimensione massima della cache ESE modificata manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-02-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamCacheSizeMax per tutti gli oggetti archivio cassette postali. Se Exchange Server Analyzer rileva il valore dell'attributo msExchESEParamCacheSizeMax per qualsiasi archivio di cassette postali maggiore di 0 ma minore di 219727, verrà visualizzato un messaggio di configurazione non predefinita.

In Exchange 2000 Server, un'ampia area della memoria virtuale utilizzata da STORE.EXE viene allocata per il buffer ESE. Exchange 2000 Server utilizza un valore predefinito specificato a livello di codice di 858 MB per questo buffer. In Exchange Server 2003 l'allocazione del buffer ESE è basata sulla presenza dell'opzione /3GB nel file Boot.ini. Se è presente l'opzione /3GB, il buffer ESE è regolato su 896 MB. Se l'opzione /3GB non è presente, il buffer ESE è regolato su 576 MB. La regolazione automatica è sempre utile, tuttavia può essere necessario ignorare questa funzione e impostare manualmente un valore più appropriato per il proprio ambiente. È possibile impostare questo valore su qualunque multiplo di 8192, tuttavia è consigliabile utilizzare solo un valore tra quelli indicati nella seguente tabella:

Valore consigliato | Memoria allocata | Commenti
147456 | 576 MB | Questo è il valore minimo consigliato. Non impostare su un valore inferiore. Questo valore è utile su server con memoria virtuale limitata e sui computer con Exchange Server 2003 in esecuzione su Microsoft® Windows® 2000 Server, che non supporta l'opzione /3GB. Questo è il valore predefinito anche nei sistemi che non utilizzano l'opzione /3GB.
196608 | 768 MB | Questo valore è consigliato per i server con grandi quantità di memoria virtuale che generano frequentemente l'evento 9582.
219726 | 858 MB | Questo è il valore predefinito in Exchange 2000 Server ed è una buona soluzione da utilizzare nei sistemi che vengono aggiornati sul posto e che hanno grandi quantità di memoria virtuale.
229376 | 896 MB | Questo è il valore predefinito in Exchange Server 2003, ed è una buona soluzione da utilizzare nei nuovi sistemi, a meno che il registro eventi dell'applicazione indichi diversamente con la presenza di eventi 9582.
311296 | 1,2 GB | Questo è il valore massimo configurabile. Questo valore dovrebbe essere utilizzato in sistemi con almeno 2 GB di memoria fisica.

Prima di riconfigurare questo valore, è consigliabile verificare la quantità di memoria virtuale utilizzata dal processo STORE.EXE. È possibile eseguire questa operazione verificando l'oggetto Prestazione processo di Windows. Nei sistemi che utilizzano l'opzione /3GB, il valore del contatore Virtual Bytes per l'istanza STORE.EXE dell'oggetto Processo deve essere inferiore a 2,8 GB. Nei sistemi che non utilizzano l'opzione /3GB, il valore del contatore deve essere inferiore a 1,8 GB. Se i valori sono superiori a questi, può essere necessario ridurre il valore di msExchESEParamCacheSizeMax. Se i valori sono inferiori, può essere necessario aumentare il valore di msExchESEParamCacheSizeMax.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per regolare l'attributo msExchESEParamCacheSizeMax

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione.

  3. Espandere la struttura CN=Services.

  4. Espandere la struttura CN=Microsoft Exchange.

  5. Espandere la struttura CN=<Nome organizzazione di Exchange>.

  6. Espandere la struttura CN=Administrative Groups.

  7. Espandere la struttura CN=<Nome gruppo amministrativo>.

  8. Espandere la struttura CN=Servers.

  9. Espandere la struttura CN=<Nome del server Exchange>.

  10. Fare clic con il pulsante destro del mouse su CN=InformationStore, quindi scegliere Proprietà.

  11. Nel campo degli attributi scorrere e fare doppio clic su msExchESEParamCacheSizeMax.

  12. Nel campo Valore digitare il valore che si desidera impostare. Utilizzare la tabella in questo articolo per determinare il valore ottimale del sistema. Notare che il valore da utilizzare deve essere un multiplo di 8192.

  13. Fare clic su OK, quindi nuovamente su OK.

  14. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'ottimizzazione dell'utilizzo della memoria, consultare l'articolo 815372 della Microsoft Knowledge Base "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

Per ulteriori informazioni sull'attributo msExchESEParamCacheSizeMax, consultare l'articolo 266768 della Microsoft Knowledge Base "XSTR: Modifica della dimensione massima della cache nel database dell'archivio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768.


Il valore massimo della cache ESE è troppo elevato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-02-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamCacheSizeMax per tutti gli oggetti archivio cassette postali. Exchange Server Analyzer esegue una query anche nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeIS_MSExchangeIS per determinare il valore della chiave VMLargestBlockSize. La chiave VMLargestBlockSize rappresenta la dimensione (in byte) del blocco più grande di memoria virtuale disponibile.

Inoltre, Exchange Server Analyzer esegue una query in Active Directory per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer rileva che il valore di msExchESEParamCacheSizeMax è maggiore di 219726 e che il valore di VMLargestBlockSize è maggiore di 50000000 ma minore di 150000000 su un computer Exchange Server con più di 20 cassette postali, verrà visualizzato un messaggio di errore. L'errore indica che l'attributo msExchESEParamCacheSizeMax è impostato su un valore troppo elevato sul computer Exchange Server.

In Exchange 2000 Server, un'ampia area della memoria virtuale utilizzata da STORE.EXE viene allocata per il buffer ESE. Exchange 2000 Server utilizza un valore predefinito specificato a livello di codice di 858 MB per questo buffer. In Exchange Server 2003 l'allocazione del buffer ESE è basata sulla presenza dell'opzione /3GB nel file Boot.ini. Se è presente l'opzione /3GB, il buffer ESE è regolato su 896 MB. Se l'opzione /3GB non è presente, il buffer ESE è regolato su 576 MB. La regolazione automatica è sempre utile, tuttavia può essere necessario ignorare questa funzione e impostare manualmente un valore più appropriato per il proprio ambiente. È possibile impostare questo valore su qualunque multiplo di 8192, tuttavia è consigliabile utilizzare solo un valore tra quelli indicati nella seguente tabella:

Valore consigliato | Memoria allocata | Commenti
147456 | 576 MB | Questo è il valore minimo consigliato. Non impostare su un valore inferiore. Questo valore è utile su server con memoria virtuale limitata e sui computer con Exchange Server 2003 in esecuzione su Microsoft Windows 2000 Server, che non supporta l'opzione /3GB. Questo è il valore predefinito anche nei sistemi che non utilizzano l'opzione /3GB.
196608 | 768 MB | Questo valore è consigliato per i server con grandi quantità di memoria virtuale che generano frequentemente l'evento 9582.
219726 | 858 MB | Questo è il valore predefinito in Exchange 2000 Server ed è una buona soluzione da utilizzare nei sistemi che vengono aggiornati sul posto e che hanno grandi quantità di memoria virtuale.
229376 | 896 MB | Questo è il valore predefinito in Exchange Server 2003, ed è una buona soluzione da utilizzare nei nuovi sistemi, a meno che il registro eventi dell'applicazione indichi diversamente con la presenza di eventi 9582.
311296 | 1,2 GB | Questo è il valore massimo configurabile. Questo valore dovrebbe essere utilizzato in sistemi con almeno 2 GB di memoria fisica.

Prima di riconfigurare questo valore, è consigliabile verificare la quantità di memoria virtuale utilizzata dal processo STORE.EXE. È possibile eseguire questa operazione verificando l'oggetto Prestazione processo di Windows. Nei sistemi che utilizzano l'opzione /3GB, il valore del contatore Virtual Bytes per l'istanza STORE.EXE dell'oggetto Processo deve essere inferiore a 2,8 GB. Nei sistemi che non utilizzano l'opzione /3GB, il valore del contatore deve essere inferiore a 1,8 GB. Se i valori sono superiori a quelli indicati, può essere necessario ridurre il valore di msExchESEParamCacheSizeMax. Se i valori sono inferiori, può essere necessario aumentare il valore di msExchESEParamCacheSizeMax.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per regolare l'attributo msExchESEParamCacheSizeMax

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione.

  3. Espandere la struttura CN=Services.

  4. Espandere la struttura CN=Microsoft Exchange.

  5. Espandere la struttura CN=<Exchange Organization Name>.

  6. Espandere la struttura CN=Administrative Groups.

  7. Espandere la struttura CN=<Administrative Group Name>.

  8. Espandere la struttura CN=Servers.

  9. Espandere la struttura CN=<Exchange Server Name>.

  10. Fare clic con il pulsante destro del mouse su CN=InformationStore, quindi scegliere Proprietà.

  11. Nel campo degli attributi scorrere e fare doppio clic su msExchESEParamCacheSizeMax.

  12. Nel campo Valore digitare il valore che si desidera impostare. Utilizzare la tabella per determinare il valore ottimale del sistema. Notare che il valore da utilizzare deve essere un multiplo di 8192.

  13. Fare clic su OK, quindi nuovamente su OK.

  14. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'ottimizzazione dell'utilizzo della memoria, consultare l'articolo 815372 della Microsoft Knowledge Base "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

Per ulteriori informazioni sull'attributo msExchESEParamCacheSizeMax, consultare l'articolo 266768 della Knowledge Base "XSTR: Modifica della dimensione massima della cache nel database dell'archivio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768.


Dimensione massima della cache ESE aumentata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-02-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamCacheSizeMax per tutti gli oggetti archivio cassette postali.

Exchange Server Analyzer esegue una query anche nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeIS_MSExchangeIS per determinare il valore della chiave VMLargestBlockSize. La chiave VMLargestBlockSize rappresenta la dimensione (in byte) del blocco più grande di memoria virtuale disponibile.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer rileva che il valore msExchESEParamCacheSizeMax è maggiore di 219726 e che il valore di VMLargestBlockSize non rientra nei valori riportati di seguito del computer Exchange Server con più di 20 cassette postali, verrà visualizzato un avviso:

  • Maggiore di 50000000 e minore di 150000000

  • Maggiore di 0 e minore di 50000001

Questo avviso indica che l'attributo msExchESEParamCacheSizeMax è stato aumentato su questo computer Exchange Server computer e pertanto può essere causa di condizioni dovute a memoria virtuale insufficiente.

In Exchange 2000 Server, un'ampia area della memoria virtuale utilizzata da STORE.EXE viene allocata per il buffer ESE. Exchange 2000 Server utilizza un valore predefinito specificato a livello di codice di 858 MB per questo buffer. In Exchange Server 2003 l'allocazione del buffer ESE è basata sulla presenza dell'opzione /3GB nel file Boot.ini. Se è presente l'opzione /3GB, il buffer ESE è regolato su 896 MB. Se l'opzione /3GB non è presente, il buffer ESE è regolato su 576 MB. La regolazione automatica è sempre utile, tuttavia può essere necessario ignorare questa funzione e impostare manualmente un valore più appropriato per il proprio ambiente. È possibile impostare questo valore su qualunque multiplo di 8192, tuttavia è consigliabile utilizzare solo un valore tra quelli indicati nella seguente tabella:

Valore consigliato | Memoria allocata | Commenti
147456 | 576 MB | Questo è il valore minimo consigliato. Non impostare su un valore inferiore. Questo valore è utile su server con memoria virtuale limitata e sui computer con Exchange Server 2003 in esecuzione su Microsoft Windows 2000 Server, che non supporta l'opzione /3GB. Questo è il valore predefinito anche nei sistemi che non utilizzano l'opzione /3GB.
196608 | 768 MB | Questo valore è consigliato per i server con grandi quantità di memoria virtuale che generano frequentemente l'evento 9582.
219726 | 858 MB | Questo è il valore predefinito in Exchange 2000 Server ed è una buona soluzione da utilizzare nei sistemi che vengono aggiornati sul posto e che hanno grandi quantità di memoria virtuale.
229376 | 896 MB | Questo è il valore predefinito in Exchange Server 2003, ed è una buona soluzione da utilizzare nei nuovi sistemi, a meno che il registro eventi dell'applicazione indichi diversamente con la presenza di eventi 9582.
311296 | 1,2 GB | Questo è il valore massimo configurabile. Questo valore dovrebbe essere utilizzato in sistemi con almeno 2 GB di memoria fisica.

Prima di riconfigurare questo valore, è consigliabile verificare la quantità di memoria virtuale utilizzata dal processo STORE.EXE. È possibile eseguire questa operazione verificando l'oggetto Prestazione processo di Windows. Nei sistemi che utilizzano l'opzione /3GB, il valore del contatore Virtual Bytes per l'istanza STORE.EXE dell'oggetto Processo deve essere inferiore a 2,8 GB. Nei sistemi che non utilizzano l'opzione /3GB, il valore del contatore deve essere inferiore a 1,8 GB. Se i valori sono superiori a questi, può essere necessario ridurre il valore di msExchESEParamCacheSizeMax. Se i valori sono inferiori, può essere necessario aumentare il valore di msExchESEParamCacheSizeMax.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per regolare l'attributo msExchESEParamCacheSizeMax

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione.

  3. Espandere la struttura CN=Services.

  4. Espandere la struttura CN=Microsoft Exchange.

  5. Espandere la struttura CN=<Nome organizzazione di Exchange>.

  6. Espandere la struttura CN=Administrative Groups.

  7. Espandere la struttura CN=<Nome Gruppo Amministrativo>.

  8. Espandere la struttura CN=Servers.

  9. Espandere la struttura CN=<Nome server Exchange>.

  10. Fare clic con il pulsante destro del mouse su CN=InformationStore, quindi scegliere Proprietà.

  11. Nel campo degli attributi scorrere e fare doppio clic su msExchESEParamCacheSizeMax.

  12. Nel campo Valore digitare il valore che si desidera impostare. Utilizzare la tabella in questo articolo per determinare il valore ottimale del sistema. Notare che il valore da utilizzare deve essere un multiplo di 8192.

  13. Fare clic su OK, quindi nuovamente su OK.

  14. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'ottimizzazione dell'utilizzo della memoria, consultare l'articolo 815372 della Microsoft Knowledge Base "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.

Per ulteriori informazioni sull'attributo msExchESEParamCacheSizeMax, consultare l'articolo 266768 della Microsoft Knowledge Base "XSTR: Modifica della dimensione massima della cache nel database dell'archivio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266768.


MaxOpenMessagesPerLogon impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-05-14

Lo strumento Microsoft Exchange Analyzer legge la voce del Registro di sistema indicata di seguito per determinare se il valore MaxOpenMessagesPerLogon del Registro di sistema è presente e configurato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Analyzer rileva che il valore MaxOpenMessagesPerLogon è presente ed è impostato su un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Ogni volta che un client o un'applicazione MAPI apre un messaggio su un computer Exchange Server, il servizio Archivio informazioni di Microsoft Exchange (store.exe) esaurisce una piccola quantità di memoria fisica. Quando il messaggio viene chiuso dal client Microsoft Office Outlook 2003 o Outlook 2007, la memoria viene liberata. Per evitare che servizio di archivio Exchange continui a utilizzare memoria a causa di uno o più client MAPI, nel Service Pack 1 (SP1) per Exchange 2000 è stata introdotta una nuova funzione che consente all'amministratore di limitare il numero di messaggi che è possibile aprire contemporaneamente durante ciascuna sessione di accesso dei client MAPI. L'impostazione di un tale limite potrebbe essere utile nell'ambiente utilizzato se alcune applicazioni client aprissero involontariamente molti messaggi, influenzando di conseguenza le prestazioni generali del server.

Questa funzione viene implementata utilizzando il valore del Registro di sistema MaxOpenMessagesPerLogon sul computer Exchange Server. Si consiglia di non impostare un limite maggiore di 1000. Un valore di 1000 consente a ciascun client di utilizzare approssimativamente da 4 a 6 megabyte (MB) di memoria. Per alcuni ambienti, è consigliabile un valore più piccolo di 500.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di conoscere le operazioni per ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare un numero massimo di messaggi che è possibile aprire contemporaneamente.

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Aprire:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Fare clic con il pulsante destro del mouse su ParametersSystem, quindi su Nuovo | valore DWORD e denominare il nuovo valore MaxOpenMessagesPerLogon.

  4. Nel riquadro destro fare doppio clic sul valore MaxOpenMessagesPerLogon, quindi inserire il numero massimo di messaggi che è possibile aprire, in valori decimali.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore MaxOpenMessagesPerLogon del Registro di sistema, vedere l'articolo 289109 della Microsoft Knowledge Base "XADM: How to Limit the Number of Messages Opened for Each MAPI Logon" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=289109.


Il numero massimo di database per gruppo di archiviazione è stato modificato manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchMaxStoresPerGroup per ogni gruppo di archiviazione. Se Exchange Server Analyzer determina che il valore dell'attributo msExchMaxStoresPerGroup di ciascun gruppo di archiviazione non è uguale a 5, verrà visualizzato un messaggio di errore.

Questo valore si applica a tutti i gruppi di archiviazione nel server. Questo errore specifico si verifica se il valore predefinito di 5 per questo attributo è stato modificato. Questo è l'unico valore supportato e non è consigliabile modificarlo. Se tale valore viene aumentato, Exchange Server non funzionerà in modo corretto.

È necessario correggere il valore mediante uno strumento quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, quindi CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo<e infine CN=Server.

  4. Espandere CN=<NomeServer>, fare clic con il pulsante destro del mouse su CN=InformationStore, quindi scegliere Proprietà.

  5. Nell'editor degli attributi fare clic sull'attributo msExchMaxStoresPerGroup, quindi scegliere Modifica.

  6. Nella casella Modifica attributo impostare il valore su 5.

  7. Fare clic su Applica, quindi su OK.

  8. Chiudere ADSI Edit e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sul numero massimo consentito di gruppi di archiviazione, consultare l'articolo 251123 della Microsoft Knowledge Base "XADM: Numero massimo di gruppi di archiviazione in Exchange 2000 per la pianificazione della capacità del database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=251123.

Per ulteriori informazioni sull'utilizzo di ADSI Edit, consultare l'argomento "Adsiedit.msc: ADSI Edit" nella Guida in linea di Windows Server.


Il numero massimo di gruppi di archiviazione è stato modificato manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchMaxStorageGroups di ogni contenitore InformationStore. Se Exchange Server Analyzer determina che il valore di ogni attributo msExchMaxStorageGroups non corrisponde a 4, verrà visualizzato un messaggio di errore.

L'unico valore supportato per l'attributo msExchMaxStorageGroups è 4 e non dovrà essere mai modificato. Se tale valore viene modificato, Exchange non funzionerà in modo corretto.

È necessario correggere il valore mediante un editor di Active Directory quale lo snap-in ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o altri client LDAP (Lightweight Directory Access Protocol) versione 3.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Individuare, mediante ADSI Edit o uno strumento simile, l'oggetto InformationStore relativo a questo server in Active Directory.

    L'attributo msExchMaxStorageGroups è reperibile in:

    CN=Configuration,DC=Domain,CN=com, CN=Services, CN=Microsoft Exchange, CN=NomeOrganizzazione, CN=Administrative Groups, CN=NomeGruppoAmministrativo, CN=Servers, CN=NomeServer, CN=InformationStore

  2. Modificare l'attributo msExchMaxStorageGroups immettendo 4 come nuovo valore.

  3. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il computer che esegue Exchange Server.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.


Il numero massimo di oggetti cartella aperta per accesso è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Mediante Microsoft® Exchange Server Analyzer Tool viene letta la seguente voce del Registro di sistema per determinare se il numero di cartelle massimo predefinito che è possibile aprire per sessione MAPI è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolder

Se Exchange Server Analyzer rileva che il valore objtFolder del Registro di sistema è presente e configurato con un valore numerico diverso da 500, verrà visualizzato un messaggio di configurazione non predefinita.

Se aggiunto e configurato manualmente, il valore objtFolder del Registro di sistema determina il numero massimo di cartelle che è possibile aprire per client MAPI. Per impostazione predefinita, in Exchange Server 2003 e in Exchange Server 2007 il numero di cartelle aperte è limitato a 500. Quando un client MAPI tenta di aprire più di 500 cartelle, l'evento seguente viene registrato nel registro eventi dell'applicazione nel computer sul quale è in esecuzione Exchange Server, che contiene la cassetta postale del client:

Tipo di evento: | Errore
ID evento: | 9646
Origine evento: | MSExchangeIS
Categoria evento: | Generale
Descrizione: | Chiusura della sessione MAPI "/o=OrganizationName/ou=AdministrativeGroupName/cn=Recipients/cn=UserName" poiché superava il numero massimo di 500 oggetti di tipo "objtFolder".

Il valore objtFolder del Registro di sistema rappresenta una possibilità di configurazione che offre all'amministratore un livello di controllo ottimale sulle risorse di Exchange Server utilizzate dai client MAPI.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Eliminare il valore objtFolder del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

  5. In alternativa, se si desidera utilizzare il valore objtFolder del Registro di sistema, invece di eliminarlo, impostarlo sul valore esistente o regolarlo, se necessario.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni, consultare l'articolo 830829 della Microsoft Knowledge Base "Interruzione di risposta da parte del computer Exchange Server 2003 dopo che il client MAPI ha aperto un numero di oggetti server maggiore di quello predefinito" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829.


Il numero massimo di visualizzazioni cartella aperta per accesso è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il numero massimo predefinito di visualizzazioni di cartelle che è possibile aprire per sessione MAPI è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtFolderView

Se Exchange Server Analyzer rileva che il valore objtFolderView del Registro di sistema è presente e configurato con un valore numerico diverso da 500, verrà visualizzato un messaggio di configurazione non predefinita.

Quando viene aggiunto e configurato manualmente, il valore objtFolderView del Registro di sistema determina il numero massimo di cartelle che è possibile aprire per client MAPI. Per impostazione predefinita, in Exchange Server 2003 ed Exchange Server 2007 il numero di visualizzazioni di cartelle aperte è limitato a 500. Quando un client MAPI tenta di aprire più di 500 cartelle, l'evento seguente viene registrato nel registro eventi dell'applicazione nel computer sul quale è in esecuzione Exchange Server, che contiene la cassetta postale del client:

Tipo di evento: Errore

Origine evento: MSExchangeIS

Categoria evento: Generale

Descrizione: Chiusura in corso della sessione MAPI "/o= NomeOrganizzazione /ou= NomeGruppoAmministrativo /cn=Recipients/cn= NomeUtente " perché superava il numero massimo di 500 oggetti del tipo "objtFolderView".

Il valore objtFolderView del Registro di sistema rappresenta una possibilità di configurazione che consente all'amministratore un livello di controllo ottimale sulle risorse di Exchange Server utilizzate dai client MAPI.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di conoscere le operazioni per ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Eliminare il valore objtFolderView del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

  5. In alternativa, se si desidera utilizzare il valore objtFolderView del Registro di sistema, invece di eliminarlo è possibile impostarlo sul valore esistente o regolarlo in base alle esigenze.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni, consultare l'articolo 830829 della Microsoft Knowledge Base "Possibile blocco del computer che esegue Exchange Server 2003 dopo l'apertura da parte di un client MAPI di un numero di oggetti server specifici superiore al valore predefinito" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829.


Il numero massimo di oggetti messaggio aperti per accesso è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stato modificato il numero massimo predefinito di messaggi aperti per sessione MAPI:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession\objtMessage

Se Exchange Server Analyzer rileva che il valore objtMessage del Registro di sistema è presente e configurato con un valore numerico diverso da 250, verrà visualizzato un messaggio di configurazione non predefinita.

Se aggiunto e configurato manualmente, il valore objtMessage del Registro di sistema determina il numero massimo di messaggi aperti possibile per client MAPI. Per impostazione predefinita, in Exchange Server 2003 ed Exchange Server 2007 il numero di messaggi aperti è limitato a 250. Quando un client MAPI tenta di aprire più di 250 messaggi, l'evento seguente viene registrato nel registro eventi dell'applicazione nel computer sul quale è in esecuzione Exchange Server, che contiene la cassetta postale del client:

Tipo di evento: Errore

ID evento: 9646

Origine evento: MSExchangeIS

Categoria evento: Generale

Descrizione: Chiusura in corso della sessione Mapi "/o= NomeOrganizzazione /ou= NomeGruppoAmministrativo /cn=Recipients/cn= NomeUtente " perché superava il numero massimo di 250 oggetti di tipo "objtMessage".

Il valore objtMessage del Registro di sistema rappresenta una possibilità di configurazione che consente all'amministratore un livello di controllo ottimale sulle risorse di Exchange Server utilizzate dai client MAPI.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a:

    HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession.

  3. Eliminare il valore objtMessage del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

  5. In alternativa, se si desidera utilizzare il valore objtMessage del Registro di sistema, invece di eliminarlo, impostarlo sul valore esistente o regolarlo in base alle esigenze.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni, consultare l'articolo 830829 della Microsoft Knowledge Base "Interruzione di risposta da parte del computer Exchange Server 2003 dopo che il client MAPI ha aperto un numero di oggetti server maggiore di quello predefinito" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830829.


La frequenza massima di polling non è impostata su un valore predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se l'intervallo di polling per i client Microsoft Office Outlook® 2003 e Outlook 2007 che accedono a Exchange Server 2003 o Exchange Server 2007 utilizzando RPC su HTTP è stato impostato su un valore diverso da quello predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ Maximum Polling Frequency

Se Exchange Server Analyzer rileva che la chiave Maximum Polling Frequency è presente e configurata con un valore superiore a 0, verrà visualizzato un messaggio di configurazione non predefinita.

Quando viene eseguita la connessione iniziale a un server di Exchange, Outlook si registra per la notifica di nuovi messaggi. Ogni volta che si riceve un nuovo messaggio in una cassetta postale di un utente di Outlook, viene inviata una notifica a Outlook utilizzando un UDP (User Datagram Protocol). Quando Outlook riceve la notifica, il messaggio viene recuperato dal server di Exchange e viene visualizzato nella cartella appropriata. Se Outlook non riceve la notifica di nuovi messaggi di posta elettronica, viene ripristinato il polling nel server di Exchange. Sebbene il polling venga iniziato da Outlook, la frequenza di polling è determinata dal server di Exchange.

Per impostazione predefinita, in Outlook 2003 viene eseguito il polling a intervalli di 60 secondi. È possibile modificare la frequenza aggiungendo la voce Maximum Polling Frequency del Registro di sistema al server di Exchange che contiene le cassette postali dell'utente. Il valore inserito rappresenta il numero minimo in millisecondi tra gli intervalli di polling. Se il valore Maximum Polling Frequency non è presente, verrà utilizzato quello predefinito di 60 secondi (60.000 millisecondi). Questo valore predefinito non indica che il polling viene eseguito ogni 60 secondi, bensì che verrà eseguito in qualsiasi momento compreso tra l'intervallo della frequenza di polling e il doppio di tale intervallo. Ad esempio, si supponga che Maximum Polling Frequency sia impostato su 90 secondi. Il polling verrà eseguito in un momento compreso tra l'intervallo di 90 e 180 secondi dall'ultimo polling.

È consigliabile non ridurre il valore a un numero minore di 60 secondi in quanto ne risentirebbero le prestazioni di Exchange, di Outlook e della rete. Potrebbe non essere necessario modificare questo valore, poiché la presenza di nuovi messaggi verrà controllata tramite numerose operazioni interne degli utenti. Ad esempio, se un utente passa da una cartella a un'altra o apre un messaggio, sul server verranno visualizzati nuovi elementi. Ciò si verifica perché, quando Outlook invia le richieste RPC necessarie a Exchange per attivare l'operazione dell'utente, il flag del nuovo messaggio viene controllato e, se è presente, la notifica del nuovo messaggio verrà inclusa nella risposta RPC inviata a Outlook.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore Maximum Polling Frequency del Registro di sistema.

  4. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulle chiamate RPC su HTTP, consultare il manuale Scenari di distribuzione di RPC su HTTP in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47577.


Dimensione minima della cache ESE modificata manualmente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-01-16

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamCacheSizeMin per tutti gli oggetti archivio cassette postali. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchESEParamCacheSizeMin per qualsiasi archivio delle cassette postali è maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Il servizio Archivio informazioni di Microsoft Exchange utilizza la cache ESE (Extensible Storage Engine) come buffer durante la scrittura dei dati d'archivio nel disco. Exchange 2000 Server usa una dimensione massima di cache di 858 MB. Exchange Server 2003 determina in modo dinamico il valore predefinito per la proprietà msExchESEParamCacheSizeMin secondo la quantità di RAM fisica che è installata nel server.

Ad esempio, la dimensione massima della cache per un computer Exchange Server 2003 che ha l'opzione /3GB impostata nel relativo file boot.ini equivale a 896 MB. Se per il computer non è stata impostata l'opzione /3GB, la dimensione massima della cache equivale a 576 MB.

È possibile utilizzare le seguenti informazioni per ripristinare la proprietà msExchESEParamCacheSizeMin secondo il suo valore originario.

  • Se Exchange Server 2003 è in esecuzione su Microsoft® Windows Server™ 2003 e il server dispone di una RAM uguale o superiore a 2 GB, msExchESEParamCacheSizeMin sarà uguale a 131072 (512 MB).

  • Se Exchange Server 2003 è in esecuzione su Windows Server 2003 e il server dispone di una RAM superiore a 768 MB ma inferiore a 2 GB, msExchESEParamCacheSizeMin sarà uguale a "RAM/4*(4*1024)".

  • Se Exchange Server 2003 è in esecuzione su Windows Server 2003 e il server dispone di una RAM inferiore a 768 MB, msExchESEParamCacheSizeMin sarà uguale a "RAM/8*(4*1024)".

Ad esempio:

  • Windows Server 2003 con 512 MB di RAM avrà un valore predefinito di 16384 (pagine da 4 KB) per msExchESEParamCacheSizeMin.

  • Windows Server 2003 con 1 GB di RAM avrà un valore predefinito di 65536 (pagine da 4 KB) per msExchESEParamCacheSizeMin.

  • Windows Server 2003 con 4 GB di RAM avrà un valore predefinito di 131072 (pagine da 4 KB) per msExchESEParamCacheSizeMin.

  • Se Exchange Server 2003 è in esecuzione su Microsoft Windows® 2000 Server, non è impostato alcun valore predefinito per msExchESEParamCacheSizeMin.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit (Active Directory Service Interfaces), lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Windows Server 2003, Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Aprire un editor di Active Directory, ad esempio ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione.

  3. Espandere la struttura CN=Services.

  4. Espandere la struttura CN=Microsoft Exchange.

  5. Espandere la struttura CN=<Nome organizzazione di Exchange>.

  6. Espandere la struttura CN=Administrative Groups.

  7. Espandere la struttura CN=<Nome gruppo amministrativo>.

  8. Espandere la struttura CN=Servers.

  9. Espandere la struttura CN=<Nome server di Exchange>.

  10. Fare clic con il pulsante destro del mouse su CN=InformationStore, quindi scegliere Proprietà.

  11. Nel campo degli attributi scorrere e fare doppio clic su msExchESEParamCacheSizeMin.

  12. Nel campo Valore digitare il valore che si desidera impostare. È possibile utilizzare la formula predefinita e modificarla secondo necessità. Il valore da utilizzare deve essere un multiplo di 32 MB.

  13. Fare clic su OK, quindi nuovamente su OK.

  14. Per rendere effettiva la modifica, chiudere l'editor di Active Directory e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sulla regolazione dell'attributo msExchESEParamCacheSizeMin, consultare l'articolo 822894 della Microsoft Knowledge Base "Il database Jet non funziona correttamente durante un backup o un'operazione di indicizzazione del contenuto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822894.


Il numero di thread relativo al processo di archiviazione è alto
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Process per determinare il valore di ThreadCount per il processo Archivio informazioni di Exchange. Questo valore rappresenta il numero di thread di archiviazione attivi installati nel server. Se sono presenti più di 400 thread di archiviazione attivi, verrà visualizzato un avviso.

La causa più comune di questo problema è la presenza di un software antivirus non compatibile in esecuzione sullo stesso computer.

Per risolvere il problema

  1. Verificare con il rivenditore che sul computer sia in esecuzione una versione aggiornata di un software antivirus compatibile con Exchange.

  2. Eseguire l'aggiornamento del software antivirus utilizzato.

Per ulteriori informazioni sui software antivirus ed Exchange Server 2003, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.


Parametro OAB Bandwidth Threshold (KBps) del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se la chiave del Registro di sistema OAB Bandwidth Threshold (KBps) è stata creata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che la chiave del Registro di sistema OAB Bandwidth Threshold (KBps) è stata creata sotto ParametersSystem, verrà visualizzato un messaggio di configurazione non predefinita.

In Microsoft Exchange Server 2003 Service Pack 1 (SP1), l'amministratore può impostare e configurare la chiave OAB Bandwidth Threshold (KBps) del Registro di sistema in modo tale da ignorare la funzionalità predefinita e ridurre la lunghezza di banda utilizzata per un download completo di una rubrica non in linea da un archivio pubblico specifico.

Per impostazione predefinita, ogni richiesta client per un download completo di una rubrica non in linea viene eseguita immediatamente. Inoltre, l'archivio pubblico non riduce il numero di download completi simultanei delle rubriche fuori rete. In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione. Tuttavia, se si desidera ripristinare la configurazione predefinita, è possibile eliminare la chiave OAB Bandwidth Threshold (KBps) del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore OAB Bandwidth Threshold (KBps).

  4. Chiudere l'editor del Registro di sistema.

Il servizio Archivio informazioni di Microsoft Exchange impiega pochi minuti per rilevare le modifiche. Non è necessario riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla limitazione della lunghezza di banda utilizzata durante il download delle rubriche fuori rete, consultare l'articolo 867623 della Microsoft Knowledge Base "Limitazione dei download completi delle rubriche fuori rete per arginare gli effetti in una LAN in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=867623.


La rubrica fuori rete non è associata a un archivio delle cassette postali specifico
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchUseOAB nella classe msExchPrivateMDB è stato configurato per utilizzare una rubrica non in linea specifica per un determinato archivio delle cassette postali di un database. La classe msExchPrivateMDB determina la configurazione in un database privato. L'attributo msExchUseOAB determina la rubrica non in linea specifica utilizzata da un determinato archivio delle cassette postali. Se Exchange Server Analyzer rileva che la rubrica non in linea per l'archivio delle cassette postali nel database è mancante, verrà visualizzato un messaggio di errore.

In Exchange 2000 Server e versioni successive, una rubrica non in linea è associata a tutti gli utenti contenuti in un archivio informazioni. Non è possibile associare automaticamente un elenco di indirizzi non in linea a un cassetta postale specifica né ignorare le impostazioni dell'elenco di indirizzi non in linea globale per l'archivio informazioni o il gruppo di archiviazione.

Per associare un elenco di indirizzi non in linea a una cassetta postale specifica, è necessario prima crearne uno che contenga una copia filtrata dell'elenco di indirizzi globale. Quindi, è necessario associare l'elenco di indirizzi non il linea a una cassetta postale specifica utilizzando ADSI Edit oppure un altro client LDAP versione 3 per impostare l'attributo msExchUseOAB sul nome distinto completo dell'elenco di indirizzi non in linea.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per ulteriori informazioni su come associare una rubrica non in linea a una cassetta postale specifica, consultare l'articolo 275203 della Microsoft Knowledge Base "La rubrica non in linea non può essere associata a una determinata cassetta postale" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=275203.

Per ulteriori informazioni sulle rubriche fuori rete, consultare il manuale Offline Address Book Best Practices Guide all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47583 (informazioni in lingua inglese).


OLD Completion Time per un archivio delle cartelle pubbliche non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore del ritardo di avvio per la deframmentazione in linea è stato modificato e impostato su un valore diverso da quello predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Completion Time

Se Exchange Server Analyzer rileva che la chiave OLD Completion Time è presente, verrà visualizzato un messaggio di configurazione non predefinita. La chiave OLD Completion Time specifica l'intervallo di tempo, in secondi, durante il quale viene eseguita la deframmentazione in linea dopo l'intervallo di manutenzione dell'archivio informazioni. Il valore predefinito è 1 ora (3600 secondi).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Eliminare la chiave OLD Completion Time.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


OLD Minimum RunTime per un archivio delle cartelle pubbliche non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'intervallo di tempo minimo per l'esecuzione della deframmentazione in linea è stato modificato e impostato su un valore diverso da quello predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>\OLD Minimum RunTime

Se Exchange Server Analyzer rileva che la chiave OLD Minimum RunTime è presente, verrà visualizzato un messaggio di configurazione non predefinita. La chiave OLD Minimum RunTime specifica l'intervallo di tempo minimo, in secondi, durante il quale viene eseguita la deframmentazione in linea.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<PublicFolderStoreGUID>

  3. Eliminare la chiave OLD Minimum RunTime.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


La deframmentazione in linea è stata disabilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamEnableOnlineDefrag per ogni oggetto del gruppo di archiviazione. Il valore True indica che la manutenzione del database in linea si verificherà secondo la pianificazione configurata. Il valore False indica che la manutenzione in linea non si verificherà. Se Exchange Server Analyzer rileva che il valore di msExchESEParamEnableOnlineDefrag è impostato su False, verrà visualizzato un messaggio di errore.

La manutenzione in linea del database, inclusa la deframmentazione, in Exchange Server è molto importante. Durante questo intervallo, vengono eseguite attività quali l'eliminazione del contenitore (l'eliminazione di messaggi che hanno superato la data di mantenimento degli elementi eliminati), la scadenza delle cartelle pubbliche (i messaggi delle cartelle pubbliche antecedenti a una data specifica sono scaduti), la pulitura delle cassette postali eliminate e la deframmentazione in linea (gli oggetti del database inutilizzati vengono rilevati e rimossi, liberando spazio nel database) e così via. Questi processi consentono al server di Exchange di funzionare correttamente e fornire prestazioni ottimali. La manutenzione del database in linea non deve essere impostata su Never Run, poiché questo col tempo potrebbe provocare un peggioramento delle prestazioni.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema

  1. Fare clic su Start, Esegui, digitare MMC e infine fare clic su OK.

  2. In Microsoft Management Console (MMC), fare clic su File, quindi su Aggiungi/Rimuovi snap-in.

  3. Nell'elenco Snap-in autonomi disponibili, selezionare ADSI Edit, fare clic su Aggiungi, quindi su Chiudi. Fare clic su OK per chiudere la finestra Aggiungi/Rimuovi snap-in.

  4. Fare clic con il pulsante destro del mouse su ADSI Edit e scegliere Connessione a. Nella finestra di dialogo dell'elenco indirizzi Selezionare un contesto dei nomi conosciuto selezionare Configurazione, quindi fare clic su OK.

  5. Espandere il Contenitore di configurazione, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<NomeOrganizzazione>, CN=Administrative Groups, CN=<NomeGruppoAmministrativo>, CN=Servers, CN=<NomeServer>, CN=Information Store.

  6. Fare clic con il pulsante destro del mouse su CN=<NomeGruppoDiArchiviazione>, quindi selezionare Proprietà.

  7. Nella finestra di dialogo delle proprietà del gruppo di archiviazione selezionare msExchESEParamEnableOnlineDefrag dall'elenco degli attributi, quindi fare clic su Edit e modificare il valore in True.

  8. Chiudere ADSI Edit e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sulla manutenzione del database in linea, consultare le seguenti risorse di Exchange:

  • Articolo 314214 della Microsoft Knowledge Base, "Come impostare gli intervalli di manutenzione negli archivi dati in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=314214.

  • Articolo Insider di Exchange Server 2007 "Exchange Store Maintenance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80787 (informazioni in lingua inglese).


Origine di recupero informazioni preferita abilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la chiave Preferred Backfill Source è stata modificata rispetto al suo valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Preferred Backfill Source

Per impostazione predefinita Preferred Backfill Source non esiste. Se Exchange Server Analyzer rileva la presenza della chiave Preferred Backfill Source, verrà visualizzato un messaggio di configurazione non predefinita.

Il processo di recupero informazioni si verifica quando in un archivio delle cartelle pubbliche non vengono ricevuti tutti gli aggiornamenti disponibili per una cartella replicata o per la gerarchia, pertanto è necessario recuperare gli aggiornamenti mancanti da un altro archivio.

Per semplificare il processo di recupero informazioni, nella matrice di recupero vengono memorizzate informazioni relative agli aggiornamenti mancanti.

Queste informazioni vengono memorizzate nella matrice per un periodo di tempo specificato, definito timeout di recupero informazioni. Gli aggiornamenti mancanti ricevuti in messaggi di replica successivi durante il periodo di timeout specificato verranno rimossi dalla matrice di recupero informazioni. Nella tabella riportata di seguito sono elencati i valori di timeout di recupero informazioni predefiniti classificati in base al luogo in cui sono disponibili gli aggiornamenti mancanti e a se ne è stata eseguita una richiesta in precedenza.

Tipo di richiesta | Contenuto disponibile in un archivio del sito locale | Contenuto disponibile in un archivio di un sito remoto
Recupero informazioni iniziale | 6 ore | 12 ore
Primo tentativo di recupero informazioni | 12 ore | 24 ore
Tentativi successivi di recupero informazioni | 24 ore | 48 ore

Se il tempo specificato per il timeout di recupero informazioni scade e gli aggiornamenti sono ancora mancanti, verranno create una o più richieste di recupero informazioni e stabiliti i server da utilizzare come origini di recupero informazioni.

Per selezionare uno o più server da utilizzare come origine per il recupero delle informazioni, Exchange Server 2003 crea innanzitutto un elenco di tutti i server che dispongono di repliche della cartella, quindi ordina l'elenco in base alla seguente sequenza di criteri:

  • Ordinamento in base allo stato del server.I server inattivi o non disponibili vengono inseriti alla fine dell'elenco.

  • Ordinamento in base al server preferenziale di recupero informazioni. (se presenti; questa funzione è disponibile solo in Exchange Server 2003 e successivi). Nel servizio directory di Active Directory® viene verificato l'oggetto dell'archivio delle cartelle pubbliche per un server preferenziale di recupero informazioni. Questa impostazione viene utilizzata raramente. Solitamente, il processo di recupero informazioni funziona in maniera più efficiente se viene automaticamente selezionato un server di recupero informazioni. Per la maggior parte delle distribuzioni di Exchange Server 2003 non è necessario alcun server preferenziale di recupero informazioni. Se necessario, il Servizio Supporto Tecnico Clienti Microsoft può fornire uno script in grado di impostare un server preferenziale di recupero informazioni.

  • Ordinamento in base al costo di trasporto (dal più conveniente al meno conveniente). I server nello stesso sito hanno la priorità sui server in siti remoti. Il costo di trasporto di un server viene calcolato dal motore di routing di Exchange Server 2003 e viene solitamente utilizzato per stabilire il metodo più efficiente per il recapito di un messaggio. Nelle versioni di Exchange precedenti a Exchange Server 2003 il costo di trasporto ha una priorità inferiore e viene preso in considerazione soltanto dopo la versione di Exchange e il numero di modifiche disponibili.

  • Ordinamento in base alla versione di Exchange (dalla più recente alla meno recente).

  • Ordinamento in base al numero di modifiche necessarie disponibili sul server (da quelle più grandi a quelle più piccole). I server che non presentano nessuna delle modifiche mancanti vengono eliminati dall'elenco.

Se un server non presenta tutte le modifiche necessarie, verrà selezionato dall'elenco il server successivo e ad esso verrà inviata una richiesta di recupero informazioni. Questo processo viene ripetuto finché non viene effettuata la richiesta di tutte le modifiche. Questa funzionalità è disponibile soltanto in Exchange Server 2003 e versioni successive. Le versioni di Exchange inviano richieste di recupero informazioni a un server alla volta, se nessun server contiene tutti gli aggiornamenti mancanti per una cartella specifica. Dopo ogni richiesta, nelle versioni precedenti di Exchange viene attesa la scadenza del timeout dei tentativi (dalle 24 alle 48 ore) prima di inviare la richiesta successiva.

Se il server selezionato non risponde alla richiesta di recupero informazioni, nell'archivio verrà contrassegnato come server inattivo e verrà ripetuto il processo di selezione. I server contrassegnati come inattivi vengono inseriti alla fine dell'elenco.

Per la maggior parte del tempo, la topologia funzionerà correttamente se si consente a Exchange Server di selezionare automaticamente i server di recupero informazioni. Per la risoluzione dei problemi, il Servizio supporto tecnico Microsoft potrebbe consigliare l'impostazione di Origine di recupero informazioni preferita. Tuttavia, questa chiave dovrebbe essere impostata solo per la risoluzione di un problema specifico.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave del Registro di sistema Origine di recupero informazioni preferita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Origine di recupero informazioni preferita.

    Il valore per questa voce del Registro di sistema è in kilobyte (KB). Per tornare al valore predefinito, è necessario eliminare Origine di recupero informazioni preferita e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare il Capitolo 3 "Controllo della replica di cartelle pubbliche", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Origine di recupero informazioni preferita per la cartella pubblica abilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se Exchange è stato configurato con un'origine di recupero informazioni preferita per la gerarchia delle cartelle pubbliche:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nome server>\Public-<GUID di archivio informazioni pubblico>\Preferred Backfill Source

Se Exchange Server Analyzer rileva che la voce Preferred Backfill Source del Registro di sistema è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Exchange Server 2003 introduce un nuovo attributo del servizio directory di Active Directory® denominato msexchPreferredBackfillSource che può essere utilizzato per designare il server di Exchange che deve ricevere messaggi di richiesta di recupero informazioni.

In caso di replica del contenuto, la cartella pubblica invia una query all'organizzazione di Exchange per la richiesta di recupero informazioni. Il primo server delle cartelle pubbliche a rispondere verrà utilizzato per il recupero dei dati. Questa procedura presuppone che il primo server delle cartelle pubbliche a rispondere sia il più vicino, tuttavia questo non si verifica in tutti i casi. In Exchange Server 2003 è stata introdotta una possibilità di configurazione che consente all'amministratore di specificare un server preferenziale di recupero delle informazioni.

In Exchange Server 2003, è possibile impostare il server preferenziale da utilizzare per il recupero delle informazioni dal contenuto e dalla gerarchia delle cartelle pubbliche utilizzando un attributo di Active Directory o la voce Preferred Backfill Source del Registro di sistema sul server delle cartelle pubbliche. Il parametro di Active Directory viene utilizzato per primo. Se l'esito è negativo, viene verificato il parametro del Registro di sistema. Se anche tale parametro non è disponibile, viene utilizzato l'algoritmo predefinito per il recupero delle informazioni dalle cartelle pubbliche.

Per utilizzare l'attributo di Active Directory, impostare il nome distinto (DN) dell'archivio delle cartelle pubbliche richiesto per il recupero delle informazioni nell'attributo msExchPreferredBackfillSource negli oggetti dell'archivio delle cartelle pubbliche.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Se si sceglie di modificare l'attributo msExchPreferredBackfillSource in Active Directory, sarà necessario utilizzare un editor di Active Directory come ADSI Edit (Active Directory Service Interfaces) o lo strumento LDP (ldp.exe).

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per specificare un'origine di recupero informazioni preferita per le cartelle pubbliche nel Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome server>\Public-<GUID di archivio informazioni pubblico>

  3. Esaminare ed eventualmente modificare il valore Preferred Backfill Source. Il valore da immettere è il nome distinto (DN) dell'archivio delle cartelle pubbliche di Exchange che si desidera impostare come origine.

  4. Se viene apportata una modifica, disinstallare e reinstallare l'archivio informazioni pubblico, per rendere effettiva la modifica.

Per specificare un'origine di recupero informazioni preferita per le cartelle pubbliche in Active Directory

  1. Modificare il valore dell'oggetto Archivio cartelle pubbliche interessato per msExchPreferredBackfillSource, in modo che faccia riferimento all'origine di recupero informazioni desiderata. L'attributo msExchPreferredBackfillSource è reperibile in: CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Administrative Groups, CN=AdministrativeGroupName, CN=Servers, CN=ServerName, CN=InformationStore, CN=StorageGroupName, CN=Public Folder Store

  2. Il valore da immettere è il nome distinto (DN) dell'archivio delle cartelle pubbliche di Exchange che si desidera impostare come origine.

  3. Se viene apportata una modifica, disinstallare e reinstallare l'archivio informazioni pubblico, per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica di Active Directory con lo strumento LDP, consultare l'articolo 260745 della Knowledge Base "XADM: Utilizzo dell'utilità LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260745.


Aumentare lo spazio su disco
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool ha determinato che lo spazio su disco sul computer che esegue Exchange Server è inferiore ai livelli accettabili. Exchange Server Analyzer misura lo spazio su disco disponibile per verificare che rientri in un intervallo accettabile. Se rileva che è al di sotto dei livelli accettabili, verrà visualizzato un messaggio di errore. È consigliabile che in tutti i dischi dei computer Exchange Server che contengono cassette postali sia sempre disponibile almeno il 10% della capacità.

Exchange Server Analyzer verifica le seguenti unità:

  • Unità Database

  • Unità Temp

  • Unità MailRoot

  • Unità STM

  • Unità di sistema

  • Unità di registro

    Nota:
    La tabella di stato richiede che sia aumentata la dimensione dell'unità di registro e che siano archiviati i registri.
  • Unità di paging

Per risolvere il problema

  1. Per liberare spazio su disco, eliminare i file non necessari.

  2. Se il disco che presenta meno del 50% di spazio disponibile contiene dati che possono essere spostati in modo sicuro in un altro disco (quali cassette postali o il file di paging di Microsoft Windows®), eseguire i passaggi necessari per lo spostamento dei dati.

  3. Aggiungere spazio su disco al computer che esegue Exchange Server.

  4. Ridurre la dimensione delle cassette postali o spostare gli utenti in un altro server.

Ulteriori informazioni

  • Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

  • Per ulteriori informazioni sullo spostamento delle cassette postali tra Exchange 2000 Server ed Exchange 5.5 Server, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

  • Per ulteriori informazioni sull'impostazione di limiti per le cassette postali con criteri di sistema in Exchange Server 2003, consultare l'articolo 822938 della Microsoft Knowledge Base "HOW TO: Utilizzo di criteri di sistema per configurare i limiti di archiviazione delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822938.

  • Per ulteriori informazioni sull'impostazione di limiti per le cassette postali con criteri di sistema in Exchange 2000 Server, consultare l'articolo 319130 della Microsoft Knowledge Base "HOW TO: Utilizzo di criteri di sistema per configurare i limiti di archiviazione delle cassette postali in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=319130.

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sulle procedure consigliate per la progettazione delle architetture di archiviazione, vedere Procedure consigliate comuni a più architetture all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72988.

  • Per ulteriori informazioni sulle dimensioni dei dischi, la latenza e le frequenze di I/O, vedere Calcolo dei requisiti di I/O del disco all'indirizzo http://go.microsoft.com/fwlink/?linkid=69747.


File di database dell'archivio delle cartelle pubbliche memorizzato nell'unità di rete
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchEDBFile di ciascuna oggetto archivio delle cartelle pubbliche. L'attributo specifica la posizione dei file di database utilizzati da questo archivio delle cartelle pubbliche.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio dei valori elencati nell'attributo homeMDBBL di ogni archivio cassette postali nel server. Il conteggio di questo attributo rappresenta il numero delle cassette postali presenti nell'archivio. Exchange Server Analyzer è quindi in grado di calcolare il numero totale delle cassette postali gestite dal server.

Se Exchange Server Analyzer rileva che l'attributo msExchEDBFile comincia con \\ in un server di Exchange con più di 50 cassette postali, verrà visualizzato un messaggio di errore.

Questo messaggio di errore indica che i file di database di un archivio delle cartelle pubbliche vengono archiviati in una condivisione di rete. Se l'attributo msExchEDBFile inizia con \\, significa che il percorso del file di registro è un percorso UNC (Universal Naming Convention). Non è un'operazione consigliata, poiché le interruzioni nella connettività di rete possono provocare errori del database, perdite di dati o danni ai database. Si consiglia di risolvere il problema al più presto.

Per spostare i file di database in una nuova unità

  1. In Exchange System Manager, espandere l'oggetto di Exchange Server in cui si trova l'archivio, espandere il contenitore del gruppo di archiviazione appropriato, fare clic con il pulsante destro del mouse sull'oggetto archivio delle cartelle pubbliche desiderato, quindi fare clic su Proprietà.

  2. Specificare le nuove posizioni dei file nella scheda Database della finestra di dialogo Proprietà.

Per ulteriori informazioni sui file di database di Exchange Server, consultare i seguenti argomenti:

  • "Gestione degli archivi di cassette postali e cartelle pubbliche", nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

  • "Understanding the Exchange Server 2003 Store" in Working with Exchange Server 2003 Stores all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 (informazioni in lingua inglese).

Per ulteriori informazioni sull'utilizzo di unità di rete con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328879, "Utilizzo di Exchange Server con reti di archiviazione collegate e periferiche di archiviazione in rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328879.

  • 839687, "Criteri di supporto Microsoft sull'utilizzo di periferiche di archiviazione in rete con Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=839687.

  • 317173, "Exchange Server e l'archiviazione in rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317173.

  • 317172, "Exchange Server e l'archiviazione in rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=317172.


Il limite per la dimensione dei database dell'archivio delle cartelle pubbliche è stato impostato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore Database Size Limit in Gb del Registro di sistema è presente e configurato per l'archivio delle cartelle pubbliche:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Server_Name>\Public-<MailboxStoreGUID>

Se Exchange Server Analyzer rileva che il valore Database Size Limit in Gb è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Se è installato Exchange Server 2003 Service Pack 2 (SP2) in Exchange Server 2003 Standard Edition, il limite consentito per la dimensione dei database specificato a livello di codice viene aumentato da 16 GB a 75 GB. È possibile impostare un limite di protezione per la dimensione dei database in modo tale da impedirne la crescita indesiderata. Nel Service Pack 2, il valore predefinito per il limite di dimensione è 18 GB ma può essere sostituito creando il valore Database Size Limit in Gb del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<MailboxStoreGUID>

  3. Eliminare il valore Database Size Limit in Gb.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui Service Pack per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


Non è stato eseguito il backup completo dell'archivio cartelle pubbliche da più di 8 giorni
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query in ogni archivio di cartelle pubbliche per determinare la data e l'ora dell'ultimo backup completo. Se Exchange Server Analyzer rileva che il numero di giorni trascorsi dall'ultimo backup completo di un archivio delle cartelle pubbliche è superiore a otto, verrà visualizzato un avviso.

L'archivio delle cartelle pubbliche contiene informazioni associate a una specifica struttura di cartelle pubbliche, ad esempio le cartelle contenute e il modo in cui sono strutturate. Inoltre include il contenuto delle cartelle pubbliche. Un archivio delle cartelle pubbliche è costituito da un file RTF (con estensione EDB) e da un file di flusso di contenuto Internet nativo (con estensione STM).

I dati dell'archivio delle cassette postali e dell'archivio delle cartelle pubbliche nei database di Exchange Server e nei file di registro delle transazioni sono i dati più importanti di cui eseguire il backup nell'organizzazione di Exchange Server. È possibile utilizzare un backup del database di Exchange Server per ripristinare un'archivio cartelle pubbliche danneggiato in un server correttamente funzionante su cui è in esecuzione Exchange Server. È inoltre possibile utilizzare i backup dei database di Exchange Server per ripristinarli in un server diverso.

Si consiglia di eseguire quotidianamente un backup completo dei file di database e dei registri delle transazioni. Al termine di un backup completo di un gruppo di archiviazione, i file di registro delle transazioni salvati nei database di Exchange Server verranno eliminati dal server. In uno scenario di ripristino, un backup completo offre il vantaggio di una velocità maggiore, poiché è sufficiente un unico set di nastri per ripristinare tutti i dati.

Nota:
È consigliabile conservare i file di registro delle transazioni su un apposito disco separato dai file di database. Ciò consente la tolleranza di errore nel caso in cui un disco venga distrutto e, in alcuni casi, migliora le prestazioni del database.
Importante:
Quando si esegue il backup o il ripristino dei file e delle cartelle, è necessario disporre delle autorizzazioni o dei diritti assegnati all'account utente con cui si è eseguito l'accesso. Per creare backup di Exchange Server, è necessario disporre dei diritti di Backup Operators a livello di dominio. Per creare backup del sistema operativo Microsoft Windows Server™ 2003, è necessario disporre almeno dei diritti di Backup Operators a livello locale.

La scelta della strategia di backup per i dati di Exchange Server dipende dalla dimensione degli archivi, dalla velocità del software e dell'hardware di backup, dalla capacità dell'hardware e dai requisiti di tempo.

Per ulteriori informazioni sulle strategie di backup e sulle operazioni di ripristino di emergenza, consultare:

  • Guida al ripristino di emergenza di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47570.

  • Backup e ripristino dei database all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80766.


Non è stato eseguito il backup completo dell'archivio cartelle pubbliche da più di 60 giorni
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query in ogni archivio di cartelle pubbliche per determinare la data e l'ora dell'ultimo backup completo. Se Exchange Server Analyzer rileva che il numero di giorni trascorsi dall'ultimo backup completo di un archivio delle cartelle pubbliche è superiore a sessanta, verrà visualizzato un messaggio di errore.

L'archivio delle cartelle pubbliche contiene informazioni associate a una specifica struttura di cartelle pubbliche, ad esempio le cartelle contenute e il modo in cui sono strutturate. Nell'archivio cartelle pubbliche si trova anche il contenuto delle cartelle pubbliche. Un archivio delle cartelle pubbliche è costituito da un file RTF (con estensione EDB) e da un file di flusso di contenuto Internet nativo (con estensione STM).

I dati dell'archivio delle cassette postali e dell'archivio delle cartelle pubbliche nei database di Exchange Server e nei file di registro delle transazioni sono i dati più importanti di cui eseguire il backup nell'organizzazione di Exchange Server. È possibile utilizzare un backup del database di Exchange Server per ripristinare un'archivio cartelle pubbliche danneggiato in un server correttamente funzionante su cui è in esecuzione Exchange Server. È inoltre possibile utilizzare i backup dei database di Exchange Server per ripristinarli in un server diverso.

Si consiglia di eseguire quotidianamente un backup completo dei file di database e dei registri delle transazioni. Al termine di un backup completo di un gruppo di archiviazione, i file di registro delle transazioni salvati nei database di Exchange Server verranno eliminati dal server. In uno scenario di ripristino, un backup completo offre il vantaggio di una velocità maggiore, poiché è sufficiente un unico set di nastri per ripristinare tutti i dati.

Nota:
È consigliabile conservare i file di registro delle transazioni su un apposito disco separato dai file di database. Questa operazione non consente solo di migliorare le prestazioni del database, ma fornisce anche la tolleranza di errore nel caso in cui il disco del database subisca danni irreparabili.
Importante:
Quando si esegue il backup o il ripristino dei file e delle cartelle, è necessario disporre delle autorizzazioni o dei diritti assegnati all'account utente con cui si è eseguito l'accesso. Per creare backup di Exchange Server, è necessario disporre dei diritti di Backup Operators a livello di dominio. Per creare backup del sistema operativo Microsoft Windows Server™ 2003, è necessario disporre almeno dei diritti di Backup Operators a livello locale.

La scelta della strategia di backup per i dati di Exchange Server dipende dalla dimensione degli archivi, dalla velocità del software e dell'hardware di backup, dalla capacità dell'hardware e dai requisiti di tempo.

Per ulteriori informazioni sulle strategie di backup e sulle operazioni di ripristino di emergenza, consultare:

  • Guida al ripristino di emergenza di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47570.

  • Backup e ripristino dei database all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80766.


La dimensione dell'archivio delle cartelle pubbliche supera i 12 GB
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_DataFile per determinare il valore della chiave FileSize per ogni file di database dell'archivio delle cartelle pubbliche di Exchange (file con estensione EDB) e file di flusso (file con estensione STM). Exchange Server Analyzer consente anche di leggere il ramo del Registro di sistema indicato di seguito per determinare la versione di Exchange Server installata:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID del prodotto Exchange>

Se Exchange Server Analyzer rileva che la dimensione complessiva di una coppia di database dell'archivio delle cartelle pubbliche e file di flusso supera i 12 GB in un computer che esegue Microsoft Exchange Server 2003 Standard Edition o Exchange 2000 Server Standard Edition, verrà visualizzato un avviso.

I database di archiviazione di Exchange in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition non possono superare la dimensione di 16 GB. Quando viene raggiunto questo limite, l'archivio delle cassette postali non verrà più installato e sarà impossibile accedere a Exchange. Le dimensioni dei database di archiviazione di Exchange in Exchange Server 2003 Enterprise Edition ed Exchange 2000 Server Enterprise Edition non sono limitate a 16 GB. Il loro limite dipende solo dall'hardware disponibile, con una dimensione massima teorica di 16 terabyte.

Per risolvere il problema

  1. Provare a impostare i criteri di scadenza nelle cartelle pubbliche per eliminare i messaggi precedenti a una specifica data.

  2. Provare a impostare i limiti di archiviazione sia negli archivi di cartelle pubbliche che in singole cartelle pubbliche, per impedire una crescita illimitata dell'archivio delle cartelle pubbliche.

  3. Se recentemente sono state eseguite eliminazioni in blocco di messaggi o sono state rimosse repliche di cartelle pubbliche da questo archivio delle cartelle pubbliche, l'esecuzione di una deframmentazione non in linea può ridurre la dimensione dei file.
Nota:
Con la versione di Exchange Server 2003 Service Pack 2 (SP2), in Exchange Server 2003 Standard Edition, il limite consentito per la dimensione dei database specificato a livello di codice è stato aumentato da 16 GB a 75 GB. L'amministratore può impostare un limite di protezione per la dimensione dei database in modo tale da impedirne la crescita indesiderata. Nel Service Pack 2 per Standard Edition, il valore predefinito è 18 GB ma può essere sostituito modificando la chiave Database Size Limit in Gb del Registro di sistema.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il limite per la dimensione dei database con Exchange Server 2003 SP2

  1. Nel computer che esegue Exchange Server, avviare Regedit.exe.

  2. Aprire la seguente chiave del Registro di sistema: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome server\Public-GUID dell'archivio pubblico

  3. Fare clic con il pulsante destro del mouse su GUID dell'archivio pubblico, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Per il nuovo nome del valore, digitare Database Size Limit in Gb.

  5. Fare doppio clic su Database Size Limit in Gb. Nel campo Dati valore digitare un valore appropriato in GB per la dimensione massima dei database. Per Exchange Server 2003 Standard Edition, digitare un valore compreso tra 1 e 75 (il valore predefinito è 18 GB). Per Exchange Server 2003 Enterprise Edition, digitare un valore compreso tra 1 e 8000 (il valore predefinito è 8000 GB). Fare clic su OK.

  6. Fare clic con il pulsante destro del mouse su GUID dell'archivio pubblico, scegliere Nuovo, quindi fare clic su Valore DWORD.

  7. Per il nuovo nome del valore, digitare Database Size Buffer in Percentage.

  8. Fare doppio clic su Database Size Buffer in Percentage. In Dati valore digitare un valore compreso tra 1 e 100 per specificare quando devono essere registrati gli eventi indicanti che si sta raggiungendo il limite massimo per un database. Il valore predefinito 10 implica la registrazione di eventi di avviso quando rimane una capacità del 10% prima che venga raggiunto il limite massimo per il database. Fare clic su OK.

  9. Fare clic con il pulsante destro del mouse su GUID dell'archivio pubblico, scegliere Nuovo, quindi fare clic su Valore DWORD.

  10. Per il nuovo nome, digitare Database Size Check Start Time in Hours From Midnight.

  11. Fare doppio clic su Database Size Check Start Time in Hours From Midnight. In Dati valore digitare un valore compreso tra 0 e 23 per specificare quando si desidera che Exchange esegua una verifica della dimensione dei database. Il valore predefinito 5 implica la verifica della dimensione dei database in Exchange Server 5 ore dopo la mezzanotte (5.00). Fare clic su OK.

  12. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui file con estensione STM ed EDB, consultare l'articolo 232323 della Microsoft Knowledge Base "Archiviazione di contenuti nativi in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange 2000 Server, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Per ulteriori informazioni sull'esecuzione di una deframmentazione non in linea di un database di Exchange Server, consultare l'articolo 328804 della Microsoft Knowledge Base "Deframmentazione dei database di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Per ulteriori informazioni sull'impostazione dei limiti di archiviazione per le cartelle pubbliche, consultare l'articolo 823144 della Microsoft Knowledge Base "HOW TO: Configurazione dei limiti di archiviazione nelle cartelle pubbliche in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144.

Per ulteriori informazioni sulla dimensione massima del database che può essere raggiunta in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition, consultare l'articolo 828070 della Microsoft Knowledge Base "Mancata installazione della cassetta postale di Exchange Server quando il database dell'archivio delle cassette postali raggiunge il limite di 16 GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Per ulteriori informazioni sui Service Pack per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


La dimensione dell'archivio delle cartelle pubbliche supera i 15 GB
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_DataFile per determinare il valore della chiave FileSize per ogni file di database dell'archivio delle cartelle pubbliche di Exchange (file con estensione EDB) e file di flusso (file con estensione STM). Exchange Server Analyzer consente anche di leggere il ramo del Registro di sistema indicato di seguito per determinare la versione di Exchange Server installata:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<GUID del prodotto Exchange>

Se Exchange Server Analyzer rileva che la dimensione combinata di una coppia di file di flusso e di database dell'archivio delle cartelle pubbliche supera 15 GB su un computer che esegue Microsoft Exchange Server 2003 Standard Edition o Exchange 2000 Server Standard Edition, verrà visualizzato un messaggio di errore.

I database di archiviazione di Exchange in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition non possono superare la dimensione di 16 GB. Quando viene raggiunto questo limite, l'archivio delle cassette postali non verrà più installato e sarà impossibile accedere a Exchange. Le dimensioni dei database di archiviazione di Exchange in Exchange Server 2003 Enterprise Edition ed Exchange 2000 Server Enterprise Edition non sono limitate a 16 GB. Il loro limite dipende solo dall'hardware disponibile, con una dimensione massima teorica di 16 terabyte.

Per risolvere il problema

  1. Provare a impostare i criteri di scadenza nelle cartelle pubbliche per eliminare i messaggi precedenti a una specifica data.

  2. Provare a impostare i limiti di archiviazione sia negli archivi di cartelle pubbliche che in singole cartelle pubbliche, per impedire una crescita illimitata dell'archivio delle cartelle pubbliche.

  3. Se recentemente sono state eseguite eliminazioni in blocco di messaggi o sono state rimosse repliche di cartelle pubbliche da questo archivio delle cartelle pubbliche, l'esecuzione di una deframmentazione non in linea può ridurre la dimensione dei file.
Nota:
Con la versione di Exchange Server 2003 Service Pack 2 (SP2) per Exchange Server 2003 Standard Edition, il limite consentito per la dimensione dei database specificato a livello di codice è stato aumentato da 16 GB a 75 GB. L'amministratore può impostare un limite di protezione per la dimensione dei database in modo tale da impedirne la crescita indesiderata. Nel Service Pack 2 per Standard Edition, il valore predefinito è 18 GB ma può essere sostituito modificando la chiave Database Size Limit in Gb del Registro di sistema.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare il limite per la dimensione dei database con Exchange Server 2003 SP2

  1. Nel computer che esegue Exchange Server, avviare Regedit.exe.

  2. Aprire la seguente chiave del Registro di sistema: HKLM\System\CurrentControlSet\Services\MSExchangeIS\Nome server\Public-GUID dell'archivio pubblico

  3. Fare clic con il pulsante destro del mouse su GUID dell'archivio pubblico, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Per il nuovo nome del valore, digitare Database Size Limit in Gb.

  5. Fare doppio clic su Database Size Limit in Gb. Nel campo Dati valore digitare un valore appropriato in GB per la dimensione massima dei database. Per Exchange Server 2003 Standard Edition, digitare un valore compreso tra 1 e 75 (il valore predefinito è 18 GB). Per Exchange Server 2003 Enterprise Edition, digitare un valore compreso tra 1 e 8000 (il valore predefinito è 8000 GB). Fare clic su OK.

  6. Fare clic con il pulsante destro del mouse su GUID dell'archivio pubblico, scegliere Nuovo, quindi fare clic su Valore DWORD.

  7. Per il nuovo nome del valore, digitare Database Size Buffer in Percentage.

  8. Fare doppio clic su Database Size Buffer in Percentage. In Dati valore digitare un valore compreso tra 1 e 100 per specificare quando devono essere registrati gli eventi di avviso indicanti che si sta raggiungendo il limite massimo per un database. Il valore predefinito 10 implica la registrazione di eventi di avviso quando rimane una capacità del 10% prima che venga raggiunto il limite massimo per il database. Fare clic su OK.

  9. Fare clic con il pulsante destro del mouse su GUID dell'archivio pubblico, scegliere Nuovo, quindi fare clic su Valore DWORD.

  10. Per il nuovo nome, digitare Database Size Check Start Time in Hours From Midnight.

  11. Fare doppio clic su Database Size Check Start Time in Hours From Midnight. In Dati valore digitare un valore compreso tra 0 e 23 per specificare quando si desidera che Exchange esegua una verifica della dimensione dei database. Il valore predefinito 5 implica la verifica della dimensione dei database in Exchange Server 5 ore dopo la mezzanotte (5.00). Fare clic su OK.

  12. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui file con estensione STM ed EDB, consultare l'articolo 232323 della Microsoft Knowledge Base "Archiviazione di contenuti nativi in Microsoft Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=232323.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange Server 2003, consultare l'articolo 821829 della Microsoft Knowledge Base "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=821829.

Per ulteriori informazioni sullo spostamento delle cassette postali in Exchange 2000 Server, consultare l'articolo 328810 della Microsoft Knowledge Base "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328810.

Per ulteriori informazioni sull'esecuzione di una deframmentazione non in linea di un database di Exchange Server, consultare l'articolo 328804 della Microsoft Knowledge Base "Deframmentazione dei database di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328804.

Per ulteriori informazioni sull'impostazione dei limiti di archiviazione per le cartelle pubbliche, consultare l'articolo 823144 della Microsoft Knowledge Base "HOW TO: Configurazione dei limiti di archiviazione nelle cartelle pubbliche in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823144.

Per ulteriori informazioni sulla dimensione massima del database che può essere raggiunta in Exchange Server 2003 Standard Edition ed Exchange 2000 Server Standard Edition, consultare l'articolo 828070 della Microsoft Knowledge Base "Mancata installazione della cassetta postale di Exchange Server quando il database dell'archivio delle cassette postali raggiunge il limite di 16 GB" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=828070.

Per ulteriori informazioni sui Service Pack 2 per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


L'archivio delle cartelle pubbliche non dispone di un indirizzo di posta elettronica
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-03-28

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore configurato per l'attributo mail di ciascun archivio delle cartelle pubbliche. Se Exchange Server Analyzer rileva che l'attributo mail non è configurato per alcun archivio delle cartelle pubbliche, verrà visualizzato un messaggio di errore.

Se un archivio delle cartelle pubbliche non viene configurato con un indirizzo SMTP (Simple Mail Transfer Protocol), la replica della struttura delle cartelle pubbliche non funzionerà correttamente per l'archivio.

Tecnicamente, un archivio delle cartelle pubbliche è un tipo speciale di cassetta postale di Exchange. Come tutti gli oggetti abilitati alle cassette postali, un archivio delle cartelle pubbliche deve avere i seguenti attributi correttamente configurati per l'invio e la ricezione della posta:

  • legacyExchangeDN Questo è il nome distinto di tipo Exchange per l'oggetto.

  • proxyAddresses Questo attributo contiene tutti gli indirizzi di posta elettronica utilizzabili per inviare posta al destinatario indicato.

  • textEncodedORAddress Questo attributo contiene l'indirizzo primario X.400.

  • Mail Questo attributo contiene l'indirizzo SMTP primario dell'oggetto, senza un prefisso di indirizzo.

  • mailNickname Questo attributo viene utilizzato per generare l'URL di accesso alla cassetta postale.

  • displayName Questo attributo contiene il nome dell'oggetto come viene visualizzato nell'elenco indirizzi globale e negli altri elenchi di indirizzi dei quali l'oggetto è membro.

Se l'attributo mail non è impostato per un archivio delle cartelle pubbliche, spesso significa che il Servizio aggiornamento destinatari non è configurato o non funziona correttamente. Esistono due tipi di Servizi aggiornamento destinatari. Il primo è responsabile per l'elaborazione degli oggetti di sistema Exchange nel contenitore della configurazione (Servizio aggiornamento destinatari Enterprise), il secondo è responsabile per l'elaborazione dei destinatari in ciascun dominio (un dominio Servizio aggiornamento destinatari).

Esiste un unico Servizio aggiornamento destinatari aziendale nell'intero insieme di strutture Active Directory, poiché esiste un unico contenitore della configurazione. È questo Servizio aggiornamento destinatari ad essere responsabile della configurazione, tra gli altri, dell'attributo mail per gli archivi delle cartelle pubbliche. Se questo Servizio aggiornamento destinatari viene disattivato, configurato non correttamente oppure se incontra un problema, gli attributi potrebbero non venir configurati correttamente e la replica della cartella pubblica non funzionerà correttamente. È necessario risolvere questo problema verificando la configurazione del Servizio aggiornamento destinatari aziendale.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Destinatari, quindi selezionare il nodo Servizio aggiornamento destinatari.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse sul Servizio aggiornamento destinatari che presenta (Configurazione aziendale) come parte del nome, quindi fare clic su Proprietà.

  4. Verificare che il campo Dominio riporti il mode del dominio corretto.

  5. Verificare che i computer elencati nei campi Server di Exchange e Controller di dominio di Windows funzionino correttamente e siano disponibili sulla rete. Se questi sistemi sono inattivi, non disponibili o non sono i sistemi richiesti per eseguire le attività del Servizio aggiornamento destinatari, è possibile utilizzare il pulsante Sfoglia per specificare un computer alternativo.

  6. Verificare che Intervallo di aggiornamento sia impostato su Esegui sempre.

  7. Fare clic su OK per salvare le modifiche.

  8. Nel riquadro destro fare doppio clic sul Servizio aggiornamento destinatari che presenta (Configurazione aziendale) come parte del nome, quindi fare clic su Ricostruisci. Verrà visualizzato il seguente messaggio:

    "Questa operazione consentirà di ricalcolare nuovamente l'appartenenza dell'Elenco di indirizzi e le impostazioni Criteri destinatari in 'contoso.com' durante il prossimo intervallo di aggiornamento programmato. A seconda del numero dei destinatari nel dominio, questa operazione potrebbe richiedere diverse ore. Continuare?"

  9. Fare clic su Sì per ricostruire il Servizio aggiornamento destinatari.

  10. Dopo 15 minuti iniziare il monitoraggio del progresso del Servizio aggiornamento destinatari, seguendo le procedure descritte nell'articolo 246127 della Microsoft Knowledge Base "XADM: Verifica dell'esecuzione del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 296479, "XADM: Requisiti per la disabilitazione del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=296479.

  • 328738, "XADM: Applicazione dei criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.

  • 253770, "XADM: 253770, "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.

  • 288807, "Risoluzione dei problemi nel Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=288807.

  • 319065, "HOW TO: Utilizzo del Servizio aggiornamento destinatari di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319065.


L'archivio delle cartelle pubbliche non verrà installato all'avvio
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchEDBOffline per tutti gli oggetti di classe msExchPublicMDB. Gli oggetti di questa classe corrispondono ad archivi di cartelle pubbliche.

Il valore True per l'attributo msExchEDBOffline indica che l'archivio delle cartelle pubbliche non verrà installato automaticamente all'avvio del servizio Archivio informazioni di Microsoft Exchange. Il valore False indica che l'archivio delle cartelle pubbliche verrà installato all'avvio. Se Exchange Server Analyzer rileva che il valore di questo attributo è impostato su True, verrà visualizzato un avviso.

Questo avviso indica che è selezionata la casella di controllo Non installare archivio all'avvio. La casella di controllo si trova nella scheda Database della finestra di dialogo Proprietà dell'archivio delle cartelle pubbliche. Se la casella di controllo è selezionata, l'archivio delle cartelle pubbliche non verrà installato automaticamente all'avvio del servizio Archivio informazioni di Microsoft Exchange. Al successivo avvio del servizio, ad esempio dopo che viene riavviato il server, gli archivi delle cartelle pubbliche con questo attributo impostato su True non verranno installati. Si consiglia di impostare l'installazione automatica degli archivi delle cartelle pubbliche all'avvio del servizio Archivio informazioni di Microsoft Exchange.

Per risolvere il problema in Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, quindi espandere il server che contiene l'archivio delle cartelle pubbliche che si desidera modificare.

  3. Espandere il gruppo di archiviazione che contiene l'archivio delle cartelle pubbliche da modificare.

  4. Fare clic con il pulsante destro del mouse sull'archivio delle cartelle pubbliche, quindi scegliere Proprietà.

  5. Nella scheda Database deselezionare la casella di controllo Non installare archivio all'avvio.

  6. Fare clic su OK per salvare le modifiche.

  7. Chiudere Gestore di sistema di Exchange.

Per risolvere il problema in Exchange Server 2007

  1. Aprire Exchange Management Console.

  2. Espandere Configurazione server e selezionare il server che si desidera utilizzare.

  3. Espandere la struttura del gruppo di archiviazione che si desidera utilizzare.

  4. Fare clic con il pulsante destro del mouse sul database delle cartelle pubbliche che si desidera utilizzare e scegliere Proprietà.

  5. Nella scheda Generale deselezionare la casella di controllo Non installare database all'avvio.

  6. Fare clic su OK per salvare le modifiche.

  7. Chiudere Exchange Management Console.

Per ulteriori informazioni su questa opzione, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 314218, "HOW TO: Turn Off or Turn On Automatic Mounting of Data Stores at Startup in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=314218 (informazioni in lingua inglese).

  • 285169, "XADM: Information Stores Do Not Mount After You Use the "/disasterrecovery" Switch" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=285169 (informazioni in lingua inglese).


Assegnazione del database per la struttura di cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchOwningPFTreeBL di ciascuna classe oggetto msExchPFTree . L'attributo msExchOwningPFTreeBL archivia un elenco di nomi distinti di archivi delle cartelle pubbliche che contiene una replica della struttura di cartelle pubbliche. Se Exchange Server Analyzer rileva che l'attributo msExchOwningPFTreeBL di un oggetto della struttura di cartelle pubbliche è vuoto, verrà visualizzato un avviso. L'avviso indica che la struttura di cartelle pubbliche non è di proprietà di alcun archivio delle cartelle pubbliche.

Ciascuna struttura di cartelle pubbliche (denominata anche "gerarchia di cartelle pubbliche") è collegata a un archivio delle cartelle pubbliche. È necessario creare prima la struttura e dopo l'archivio. L'avviso verrà visualizzato se la struttura non è stata ancora collegata a un database. Ciascuna struttura di cartelle pubbliche può disporre di un solo archivio su un determinato server. Una struttura può, invece, disporre di più archivi quando ciascun archivio esiste su un server separato. In tale tipo di configurazione, Exchange replica le informazioni tra gli archivi per mantenere coerente la gerarchia.

Se i client Microsoft Office Outlook® Web Access tentano di connettersi a una cartella pubblica di una struttura che non dispone di archivi di cartelle pubbliche associati, si verificherà un errore del tipo "Servizio non disponibile" (HTTP 503).

Per risolvere il problema, è necessario effettuare una delle seguenti operazioni:

  • Collegare la struttura di cartelle pubbliche a un database di cartelle pubbliche. Per collegare la struttura di cartelle pubbliche a un database di cartelle pubbliche, è necessario prima creare un nuovo database di cartelle pubbliche, quindi individuare la struttura di cartelle pubbliche e collegarli; oppure

  • Eliminare la struttura di cartelle pubbliche. Se la struttura di cartelle pubbliche non è stata ancora collegata a un database di cartelle pubbliche, non si verificherà la perdita dei dati dell'utente quando si elimina la struttura.

Per collegare la struttura di cartelle pubbliche a un database di cartelle pubbliche

  1. In Gestore di sistema di Exchange, espandere il server cui si desidera aggiungere un archivio delle cartelle pubbliche.

  2. Fare clic con il pulsante destro del mouse su uno specifico gruppo di archiviazione, selezionare Nuovo, quindi scegliere Archivio pubblico.

  3. Nel campo Nome, digitare un nome per il nuovo database.

  4. Per associare la struttura di cartelle pubbliche al database, fare clic su Sfoglia, quindi selezionare la struttura visualizzata nell'avviso di Exchange Server Analyzer.

  5. Per salvare le impostazioni, fare clic su OK.

  6. Per installare il nuovo archivio, fare clic su Sì.

Per eliminare la struttura di cartelle pubbliche

  1. In Gestore di sistema di Exchange, espandere il nodo Cartelle in cui è situata la struttura di cartelle pubbliche.

  2. Fare clic con il pulsante destro del mouse sulla struttura di cartelle pubbliche che si desidera eliminare, selezionare Elimina, quindi scegliere Sì.

Per ulteriori informazioni sull'amministrazione delle cartelle pubbliche, consultare l'argomento "Gestione degli archivi di cassette postali e cartelle pubbliche" del Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47617.

Per ulteriori informazioni, consultare l'Aggiornamento della Guida di Exchange Server 2003 SP1 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=29847.


Gruppo di archiviazione di ripristino abilitato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchESEParamBaseName di tutti gli oggetti di classe msExchStorageGroup. Gli oggetti di questa classe sono oggetti del gruppo di archiviazione. Un valore di R00 per l'attributo msExchESEParamBaseName indica che l'oggetto del gruppo di archiviazione è un gruppo di archiviazione di ripristino. Se Exchange Server Analyzer rileva che il valore di tale attributo è R00, verrà visualizzato un avviso.

Tale avviso indica che è presente un gruppo di archiviazione di ripristino. Si consiglia di rimuovere il gruppo di archiviazione di ripristino dopo aver completato il processo di ripristino. In caso contrario, un amministratore che non ha dimestichezza con i gruppi di archiviazione di ripristino potrebbe riscontrare problemi nell'esecuzione delle normali operazioni di ripristino in futuro.

Per risolvere il problema in Exchange 2000 Server ed Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, quindi espandere il server che contiene il gruppo di archiviazione di ripristino che si desidera eliminare.

  3. Fare clic con il pulsante destro del mouse sul gruppo di archiviazione di ripristino, quindi scegliere Elimina.

  4. Chiudere Gestore di sistema di Exchange.

Per risolvere il problema in Exchange Server 2007

  1. Seguire le istruzioni riportate nella documentazione principale di Exchange Server 2007, "Come rimuovere un gruppo di archiviazione di ripristino", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80783.

Per ulteriori informazioni sui gruppi di archiviazione di ripristino ed Exchange Server 2003, vedere Utilizzo dei gruppi di archiviazione di ripristino in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=23233 e l'articolo 824126 della Microsoft Knowledge Base, "Utilizzo dei gruppi di archiviazione di ripristino in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=824126.

Per ulteriori informazioni sui gruppi di archiviazione di ripristino di Exchange Server 2007, vedere "Concetti relativi ai gruppi di archiviazione di ripristino" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80784.


Funzionalità Gruppo di archiviazione di ripristino disabilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchMaxRestoreStorageGroups è stato modificato. Se Exchange Server Analyzer rileva che l'attributo msExchMaxRestoreStorageGroups è stato impostato su 0, verrà visualizzato un messaggio di errore.

msExchMaxRestoreStorageGroups è un attributo binario dell'oggetto Archivio informazioni per ogni computer Exchange. Se l'attributo msExchMaxRestoreStorageGroups è impostato su 0, non sarà possibile creare gruppi di archiviazione di ripristino per il computer Exchange specifico.

Questo errore si può verificare se è stato eseguito un aggiornamento sul posto da Exchange 2000 Server SP3 a Exchange Server 2003 SP1 in un cluster Windows in cui il server virtuale di Exchange non è stato aggiornato a Exchange Server 2003. Notare che talvolta questo scenario di aggiornamento sul posto può provocare errori anche in Outlook® Mobile Access.

È necessario correggere l'errore del gruppo di archiviazione di ripristino impostando l'attributo msExchMaxRestoreStorageGroups su 1 per ogni oggetto Archivio informazioni del computer Exchange. Gli oggetti Archivio informazioni interessati verranno visualizzati nell'output di Exchange Server Analyzer. Per assistenza nella risoluzione di problemi relativi a Outlook Mobile Access, contattare il supporto Microsoft.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per correggere l'errore del gruppo di archiviazione di ripristino

  1. Avviare ADSI Edit.

  2. Fare doppio clic sul contenitore Configurazione, espandere CN=Services, CN=Microsoft Exchange e infine CN=<NomeOrganizzazioneExchange>.

  3. Espandere CN=Administrative Groups, CN=<NomeGruppoAmministrativo> e infine CN=Servers.

  4. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su CN=InformationStore e scegliere Proprietà.

  5. Nell'editor degli attributi fare clic sull'attributo msExchMaxRestoreStorageGroups, quindi scegliere Modifica.

  6. Nella finestra Modifica attributo immettere 1.

  7. Fare clic su Applica, quindi su OK.

  8. Chiudere ADSI Edit. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sull'utilizzo dello strumento LDP, consultare l'articolo 260745 della Microsoft Knowledge Base "XADM: Utilizzo dello strumento LDP per modificare gli attributi degli oggetti Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=260745.

Per ulteriori informazioni sui gruppi di archiviazione di ripristino di Exchange, consultare le seguenti risorse di Exchange:

  • Utilizzo dei gruppi di archiviazione di ripristino in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47589.

  • "Concetti relativi ai gruppi di archiviazione di ripristino" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=80784.


Scadenza replica per un server di cartelle pubbliche non predefinita
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-05-25

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stato modificato rispetto all'impostazione predefinita l'intervallo in base al quale vengono rimossi dall'archivio di Exchange gli elementi che hanno superato il periodo di mantenimento:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<NomeServer>\Public-<GUID cartella pubblica>\Replication Expiry

Se Exchange Server Analyzer rileva che il valore Replication Expiry del Registro di sistema è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

La scadenza per i messaggi è il processo di eliminazione dei messaggi nelle cartelle pubbliche dopo un determinato periodo di tempo. L'intervallo predefinito per la scadenza dei messaggi è impostato su 24 ore.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Eliminare il valore Replication Expiry del Registro di sistema.

  4. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica della cartella pubblica, vedere Utilizzo dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595 e l'articolo 273479 della Knowledge Base "Descrizione dei tipi di struttura delle cartelle pubbliche in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=273479.


Valore Replication Folder Conflict Age Limit di un archivio di cartelle pubbliche non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se la durata del conflitto della cartella è stata modificata rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>\Replication Folder Conflict Age Limit

Se Exchange Server Analyzer rileva che il valore Replication Folder Conflict Age Limit del Registro di sistema è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Quando due utenti modificano lo stesso messaggio in una cartella pubblica, i relativi messaggi salvati saranno in conflitto. Questa situazione può verificarsi se il messaggo viene salvato simultaneamente sullo stesso server di cartelle pubbliche o se viene modificato su due server che contengono repliche della cartella. Se non viene eseguita alcuna operazione da parte dei proprietari della cartella pubblica entro il periodo stabilito per la validità del conflitto, questo verrà risolto dall'archivio delle cartelle pubbliche alla scadenza del periodo di validità. Tale periodo di validità è controllato dal valore Replication Folder Conflict Age Limit del Registro di sistema. Il relativo valore rappresenta il numero di giorni in cui è consentita la presenza di elementi in conflitto.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder GUID>

  3. Eliminare il valore Replication Folder Conflict Age Limit del Registro di sistema.

  4. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica della cartella pubblica, consultare l'articolo 273479 della Microsoft Knowledge Base "Descrizione della funzionalità di riferimento di cartella pubblica in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=273479.


Valore Replication Folder Count Limit modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la chiave Replication Folder Count Limit è stata modificata rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Replication Folder Count Limit

Se Exchange Server Analyzer rileva la presenza della chiave Replication Folder Count Limit, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Folder Count Limit non esiste. Il valore Replication Folder Count Limit rappresenta il numero massimo di cartelle da comprimere in un messaggio di replica della struttura (utilizzato per replicare la gerarchia della struttura delle cartelle pubbliche nonché le proprietà di tali cartelle). Il valore deve essere compreso tra 1 e 1000; il valore predefinito è 20. Questa chiave del Registro di sistema non è valida per Exchange Server 2003 e per le versioni successive; può essere utilizzata solo nelle versioni precedenti di Exchange Server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave del Registro di sistema Replication Folder Count Limit

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Folder Count Limit.

    Il valore per questa voce del Registro di sistema è in kilobyte (KB). Per tornare al valore predefinito, è preferibile eliminare Replication Folder Count Limit e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare il Capitolo 3 "Controllo della replica di cartelle pubbliche", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Valore Replication Folder Tree RMQ Timeout modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la chiave Replication Folder Tree RMQ Timeout è stata modificata rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Replication Folder Tree RMQ Timeout

Se Exchange Server Analyzer rileva che Replication Folder Tree RMQ Timeout è presente, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Folder Tree RMQ Timeout non esiste. In Exchange vengono utilizzati i messaggi della gerarchia per eseguire la replica della gerarchia della struttura di cartelle pubbliche e delle proprietà di queste ultime. Quando un archivio delle cartelle pubbliche riceve le modifiche di cui è stata eseguita la replica, le carica nella memoria (code dei messaggi di replica) per l'elaborazione. Il valore Replication Folder Tree RMQ Timeout rappresenta il massimo periodo di tempo durante il quale le modifiche della gerarchia di cui è stata eseguita la replica restano nella memoria. Il valore, espresso in secondi, deve essere compreso tra 3.600 (un'ora) e 2.592.000 (trenta giorni). Il valore predefinito è 604.800 (sette giorni). Le modifiche elaborate correttamente vengono immediatamente eliminate dalla memoria; in caso contrario, vengono mantenute in memoria fino a quando non possano essere elaborate o non trascorra il timeout, momento in cui vengono eliminate.

Ad esempio, si supponga che venga eseguita la replica di una modifica per una cartella e la replica di un'altra modifica per una sottocartella di essa. A seconda della topologia e del tempo trascorso tra una modifica e l'altra, le modifiche possono arrivare all'archivio delle cartelle pubbliche di destinazione in un determinato ordine. Se la modifica della sottocartella arriva per prima ma non può essere elaborata correttamente fino a che non viene applicata la modifica della cartella principale, l'archivio delle cartelle pubbliche manterrà la modifica della sottocartella in memoria fino a quando non arriva e viene elaborata la modifica della cartella principale. Se il timeout trascorre prima dell'elaborazione della modifica della cartella principale, la modifica della sottocartella verrà eliminata dalla memoria. Successivamente, dopo l'elaborazione della modifica della cartella principale, l'archivio delle cartelle pubbliche può ricevere un'altra copia della modifica della sottocartella che può elaborare in modo corretto. Se l'archivio non riceve un'altra copia della modifica della sottocartella, quando controlla il proprio stato rispetto agli altri archivi delle cartelle pubbliche presenti nella topologia, rileverà che nella copia della struttura di cartelle pubbliche manca la modifica della sottocartella e inizierà il processo di recupero delle informazioni di tale modifica.

Nella maggior parte dei casi, non è consigliabile la modifica di Replication Folder Tree RMQ Timeout rispetto al valore predefinito. Se questo valore è stato modificato, è possibile che sia stato temporaneamente aumentato durante un periodo di intenso traffico di replica (ad esempio, dopo l'aggiunta di un nuovo archivio delle cartelle pubbliche).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave Replication Folder Tree RMQ Timeout del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Folder Tree RMQ Timeout.

    Il valore per questa voce del Registro di sistema è espresso in secondi. Per ripristinare il valore predefinito, è necessario eliminare Replication Folder Tree RMQ Timeout e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare "Controllo della replica di cartelle pubbliche" in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Valore Replication Folder Tombstone Age Limit di un archivio di cartelle pubbliche non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'intervallo per la rimozione delle voci eliminate della cartella pubblica sono state modificate dal valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>\Replication Folder Tombstone Age Limit

Se Exchange Server Analyzer rileva che Replication Folder Tombstone Age Limit è presente nel Registro di sistema, verrà visualizzato un messaggio di configurazione non predefinita.

Le informazioni sulla rimozione definitiva delle cartelle vengono utilizzate per la replica delle cartelle pubbliche. La durata viene richiesta per evitare la crescita illimitata dell'elenco di rimozione definitiva delle cartelle. Il valore predefinito di 180 giorni può essere sostituito con il valore Replication Folder Tombstone Age Limit del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<Public Folder Store GUID>

  3. Eliminare il valore Replication Folder Tombstone Age Limit del Registro di sistema.

  4. Per rendere effettiva la modifica, riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore Replication Folder Tombstone Age Limit del Registro di sistema, consultare l'articolo 159196 della Microsoft Knowledge Base "XADM: Attività controllate dalla pianificazione di manutenzione IS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=159196.


Valore Replication Long Backfill Request Delay modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la chiave Replication Long Backfill Request Delay è stata modificata rispetto al suo valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Replication Long Backfill Request Delay

Se Exchange Server Analyzer rileva la presenza della chiave Replication Long Backfill Request Delay, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Long Backfill Request Delay non è disponibile. Il recupero di informazioni viene eseguito quando un archivio delle cartelle pubbliche determina che non sono stati ricevuti tutti gli aggiornamenti per una cartella replicata (oppure per la gerarchia) ed è necessario recuperare gli aggiornamenti mancanti da un altro archivio.

Per semplificare il processo di recupero informazioni, nella matrice di recupero vengono memorizzate informazioni relative agli aggiornamenti mancanti. Queste informazioni vengono memorizzate nella matrice per un periodo di tempo specificato, definito timeout di recupero informazioni. Gli aggiornamenti mancanti ricevuti in messaggi di replica successivi durante il periodo di timeout specificato verranno rimossi dalla matrice di recupero informazioni. Nella tabella che segue sono elencati i valori predefiniti di timeout per il recupero delle informazioni, che dipendono dalla posizione degli aggiornamenti mancanti e dal fatto che siano stati già richiesti in precedenza o meno.

Tipo di richiesta | Contenuto disponibile in un archivio del sito locale | Contenuto disponibile in un archivio di un sito remoto
Recupero informazioni iniziale | 6 ore | 12 ore
Primo tentativo di recupero informazioni | 12 ore | 24 ore
Tentativi successivi di recupero informazioni | 24 ore | 48 ore

Se il tempo specificato per il timeout di recupero informazioni scade e gli aggiornamenti sono ancora mancanti, verranno create una o più richieste di recupero informazioni e stabiliti i server da utilizzare come origini di recupero informazioni.

Per selezionare uno o più server da utilizzare come origine per il recupero delle informazioni, Exchange Server 2003 crea innanzitutto un elenco di tutti i server che dispongono di repliche della cartella, quindi ordina l'elenco in base alla seguente sequenza di criteri:

  • Ordinamento in base allo stato del server I server inattivi o non disponibili vengono inseriti alla fine dell'elenco.

  • Ordinamento in base al server preferenziale di recupero informazioni se disponibile. Questa funzione è disponibile solo in Exchange Server 2003 e versioni successive. Nel servizio directory di Active Directory® viene verificato l'oggetto dell'archivio delle cartelle pubbliche per un server preferenziale di recupero informazioni. Questa impostazione viene utilizzata raramente. Solitamente, il processo di recupero informazioni funziona in maniera più efficiente se viene automaticamente selezionato un server di recupero informazioni. Per la maggior parte delle distribuzioni di Exchange Server 2003 non è necessario alcun server preferenziale di recupero informazioni. Se necessario, il Servizio Supporto Tecnico Clienti Microsoft può fornire uno script in grado di impostare un server preferenziale di recupero informazioni.

  • Ordinamento in base al costo di trasporto (dal più conveniente al meno conveniente) I server nello stesso sito hanno la priorità sui server in siti remoti. Il costo di trasporto di un server viene calcolato dal motore di routing di Exchange Server 2003 e viene solitamente utilizzato per stabilire il metodo più efficiente per il recapito di un messaggio. Nelle versioni di Exchange precedenti a Exchange Server 2003 il costo di trasporto ha una priorità inferiore e viene preso in considerazione soltanto dopo la versione di Exchange e il numero di modifiche disponibili.

  • Ordinamento in base alla versione di Exchange (dalla più recente alla meno recente)

  • Ordinamento in base al numero di modifiche necessarie disponibili sul server (da quelle più grandi a quelle più piccole) I server che non presentano nessuna delle modifiche mancanti vengono eliminati dall'elenco.

Se un server non presenta tutte le modifiche necessarie, verrà selezionato dall'elenco il server successivo e ad esso verrà inviata una richiesta di recupero informazioni. Questo processo viene ripetuto finché non viene effettuata la richiesta di tutte le modifiche. Questa funzionalità è disponibile soltanto in Exchange Server 2003 e versioni successive. Le versioni precedenti di Exchange inviano richieste di recupero informazioni a un server alla volta, se nessun server contiene tutti gli aggiornamenti mancanti per una cartella specifica. Dopo ogni richiesta, nelle versioni precedenti di Exchange viene attesa la scadenza del timeout dei tentativi (dalle 24 alle 48 ore) prima di inviare la richiesta successiva.

Se il server selezionato non risponde alla richiesta di recupero informazioni, nell'archivio verrà contrassegnato come server inattivo e verrà ripetuto il processo di selezione. I server contrassegnati come inattivi vengono inseriti alla fine dell'elenco.

Il valore Replication Long Backfill Request Delay rappresenta il tempo di attesa dell'archivio prima dell'invio di una richiesta di recupero dei dati non disponibili nello stesso sito di Exchange. Il valore, espresso in secondi, deve essere compreso tra 900 e 2.592.000 secondi (30 giorni). Il valore predefinito è 43200 secondi (12 ore).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave del Registro di sistema Replication Long Backfill Request Delay

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Long Backfill Request Delay.

    Il valore per questa voce del Registro di sistema è espresso in secondi. Per tornare al valore predefinito è necessario eliminare Replication Long Backfill Request Delay e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare "Controllo della replica di cartelle pubbliche" in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Valore Replication Long Backfill Request Timeout modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la chiave Replication Long Backfill Request Timeout è stata modificata rispetto al suo valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Replication Long Backfill Request Timeout

Se Exchange Server Analyzer rileva la presenza della chiave Replication Long Backfill Request Timeout, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Long Backfill Request Timeout non è disponibile. Il recupero di informazioni viene eseguito quando un archivio delle cartelle pubbliche determina che non sono stati ricevuti tutti gli aggiornamenti per una cartella replicata (oppure per la gerarchia) ed è necessario recuperare gli aggiornamenti mancanti da un altro archivio.

Per semplificare il processo di recupero informazioni, nella matrice di recupero vengono archiviate informazioni relative agli aggiornamenti mancanti. Queste informazioni vengono archiviate nella matrice per un periodo di tempo specificato, definito timeout di recupero informazioni. Gli aggiornamenti mancanti ricevuti in messaggi di replica successivi durante il periodo di timeout specificato, verranno rimossi dalla matrice di recupero informazioni. Nella tabella che segue sono elencati i valori predefiniti di timeout per il recupero delle informazioni, che dipendono dalla posizione degli aggiornamenti mancanti e dal fatto che siano stati già richiesti in precedenza o meno.

Tipo di richiesta | Contenuto disponibile in un archivio nel sito locale | Contenuto disponibile in un archivio di un sito remoto
Recupero informazioni iniziale | 6 ore | 12 ore
Primo tentativo di recupero informazioni | 12 ore | 24 ore
Successivi tentativi di recupero informazioni | 24 ore | 48 ore

Se il tempo specificato per il timeout di recupero informazioni scade e gli aggiornamenti sono ancora mancanti, verranno create una o più richieste di recupero informazioni e stabiliti i server da utilizzare come origini di recupero informazioni.

per selezionare uno o più server da utilizzare come origine per il recupero delle informazioni, Exchange Server 2003 crea innanzitutto un elenco di tutti i server che dispongono di repliche della cartella, quindi ordina l'elenco in base alla seguente sequenza di criteri:

  • Ordinamento in base allo stato del server I server inattivi o non disponibili vengono inseriti alla fine dell'elenco.

  • Ordina in base al server preferenziale di recupero informazioni se disponibile. Questa funzione è disponibile solo in Exchange Server 2003 e versioni successive. Nel servizio directory di Active Directory® viene verificato l'oggetto dell'archivio delle cartelle pubbliche per un server preferenziale di recupero informazioni. Questa impostazione viene utilizzata raramente. Solitamente, il processo di recupero informazioni funziona in maniera più efficiente se viene automaticamente selezionato un server di recupero informazioni. Per la maggior parte delle distribuzioni di Exchange Server 2003 non è necessario alcun server preferenziale di recupero informazioni. Se necessario, il servizio di supporto tecnico Microsoft può fornire uno script in grado di impostare un server preferenziale di recupero informazioni.

  • Ordinamento in base al costo di trasporto (dal più conveniente al meno conveniente) I server nello stesso sito hanno la priorità sui server in siti remoti. Il costo di trasporto di un server viene calcolato dal motore di routing di Exchange Server 2003 e viene solitamente utilizzato per stabilire la maniera più efficiente di recapitare un messaggio. Nelle versioni di Exchange precedenti a Exchange Server 2003 il costo di trasporto ha una priorità inferiore e viene preso in considerazione soltanto dopo la versione di Exchange e il numero di modifiche disponibili.

  • Ordinamento in base alla versione di Exchange (dalla più recente alla meno recente)

  • Ordinamento in base al numero di modifiche necessarie disponibili sul server (da quelle più grandi a quelle più piccole) I server che non presentano nessuna delle modifiche mancanti vengono eliminati dall'elenco.

Se un server non presenta tutte le modifiche necessarie, verrà selezionato dall'elenco il server successivo e ad esso verrà inviata una richiesta di recupero informazioni. Questo processo verrà ripetuto finché non viene effettuata la richiesta di tutte le modifiche. Questa funzionalità è disponibile soltanto in Exchange Server 2003 e versioni successive. Le versioni precedenti di Exchange inviano richieste di recupero informazioni a un server alla volta, se nessun server contiene tutti gli aggiornamenti mancanti per una cartella specifica. Dopo ogni richiesta, nelle versioni precedenti di Exchange si attende la scadenza del timeout dei tentativi (dalle 24 alle 48 ore) prima che venga inviata la richiesta successiva.

Se il server selezionato non risponde alla richiesta di recupero informazioni, nell'archivio verrà contrassegnato come server inattivo e verrà ripetuto il processo di selezione. I server contrassegnati come inattivi vengono inseriti alla fine dell'elenco.

Il valore Replication Long Backfill Request Timeout rappresenta il tempo di attesa dell'archivio delle cartelle pubbliche prima dell'invio di una richiesta di recupero dei dati non disponibili nello stesso sito di Exchange. Il valore, espresso in secondi, deve essere compreso tra 900 e 2.592.000 secondi (30 giorni). Il valore predefinito è 86400 secondi (24 ore).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave del Registro di sistema Replication Long Backfill Request Timeout

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Long Backfill Request Timeout.

    Il valore per questa voce del Registro di sistema è espresso in secondi. Per utilizzare il valore predefinito è necessario eliminare Replication Long Backfill Request Timeout e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare il Capitolo 3 "Controllo della replica di cartelle pubbliche", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Valore Replication Long Backfill Request Timeout Retry modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la chiave Replication Long Backfill Request Timeout Retry è stata modificata rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Replication Long Backfill Request Timeout Retry

Se Exchange Server Analyzer rileva la presenza della chiave Replication Long Backfill Request Timeout Retry , verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Long Backfill Request Timeout Retry non esiste. Il recupero di informazioni viene eseguito quando un archivio delle cartelle pubbliche determina che non sono stati ricevuti tutti gli aggiornamenti per una cartella replicata (oppure per la gerarchia) ed è necessario recuperare gli aggiornamenti mancanti da un altro archivio.

Per semplificare il processo di recupero informazioni, nella matrice di recupero vengono archiviate informazioni relative agli aggiornamenti mancanti. Queste informazioni vengono archiviate nella matrice per un periodo di tempo specificato, definito timeout di recupero informazioni. Gli aggiornamenti mancanti ricevuti in messaggi di replica successivi durante il periodo di timeout specificato, verranno rimossi dalla matrice di recupero informazioni. Nella tabella riportata di seguito sono elencati i valori di timeout di recupero informazioni predefiniti classificati in base al luogo in cui sono disponibili gli aggiornamenti mancanti e a se ne è stata eseguita una richiesta in precedenza.

Tipo di richiesta | Contenuto disponibile in un archivio nel sito locale | Contenuto disponibile in un archivio di un sito remoto
Recupero informazioni iniziale | 6 ore | 12 ore
Primo tentativo di recupero informazioni | 12 ore | 24 ore
Successivi tentativi di recupero informazioni | 24 ore | 48 ore

Se il tempo specificato per il timeout di recupero informazioni scade e gli aggiornamenti sono ancora mancanti, verranno create una o più richieste di recupero informazioni e stabiliti i server da utilizzare come origini di recupero informazioni.

Per selezionare uno o più server da utilizzare come origine per il recupero delle informazioni, Exchange Server 2003 crea innanzitutto un elenco di tutti i server che dispongono di repliche della cartella, quindi ordina l'elenco in base alla seguente sequenza di criteri:

  • Ordinamento in base allo stato del server I server inattivi o non disponibili vengono inseriti alla fine dell'elenco.

  • Ordinamento in base al server preferenziale di recupero informazioni se disponibile. Questa funzione è disponibile solo in Exchange Server 2003 e versioni successive. Nel servizio directory di Active Directory® viene verificato l'oggetto dell'archivio delle cartelle pubbliche per un server preferenziale di recupero informazioni. Questa impostazione viene utilizzata raramente. Solitamente, il processo di recupero informazioni funziona in maniera più efficiente se viene automaticamente selezionato un server di recupero informazioni. Per la maggior parte delle distribuzioni di Exchange Server 2003 non è necessario alcun server preferenziale di recupero informazioni. Se necessario, il servizio di supporto tecnico Microsoft può fornire uno script in grado di impostare un server preferenziale di recupero informazioni.

  • Ordinamento in base al costo di trasporto (dal più conveniente al meno conveniente) I server nello stesso sito hanno la priorità sui server in siti remoti. Il costo di trasporto di un server viene calcolato dal motore di routing di Exchange Server 2003 e viene solitamente utilizzato per stabilire la maniera più efficiente di recapitare un messaggio. Nelle versioni di Exchange precedenti a Exchange Server 2003 il costo di trasporto ha una priorità inferiore e viene preso in considerazione soltanto dopo la versione di Exchange e il numero di modifiche disponibili.

  • Ordinamento in base alla versione di Exchange (dalla più recente alla meno recente)

  • Ordinamento in base al numero di modifiche necessarie disponibili sul server (da quelle più grandi a quelle più piccole) I server che non presentano nessuna delle modifiche mancanti vengono eliminati dall'elenco.

Se un server non dispone di tutte le modifiche necessarie, Exchange Server 2003 seleziona il successivo server nell'elenco ordinato e invia una richiesta di recupero informazioni anche a tale server. Questo processo verrà ripetuto finché non viene effettuata la richiesta di tutte le modifiche. Questa funzionalità è disponibile soltanto in Exchange Server 2003 e versioni successive. Le versioni precedenti di Exchange inviano richieste di recupero informazioni a un server alla volta, se nessun server contiene tutti gli aggiornamenti mancanti per una cartella specifica. Dopo ogni richiesta, nelle versioni precedenti di Exchange si attende la scadenza del timeout dei tentativi (dalle 24 alle 48 ore) prima che venga inviata la richiesta successiva.

Se il server selezionato non risponde alla richiesta di recupero informazioni, nell'archivio verrà contrassegnato come server inattivo e verrà ripetuto il processo di selezione. I server contrassegnati come inattivi vengono inseriti alla fine dell'elenco.

Il valore Replication Long Backfill Request Timeout Retry rappresenta il valore di timeout utilizzato dall'archivio delle cartelle pubbliche durante l'invio di una richiesta di recupero informazioni per dati non disponibili nello stesso sito di Exchange e quando tale richiesta rappresenta un nuovo tentativo di una precedente richiesta di recupero informazioni. Il valore, espresso in secondi, deve essere compreso tra 900 e 2.592.000 (30 giorni). Il valore predefinito è 172800 secondi (48 ore).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave Replication Long Backfill Request Timeout Retry del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Long Backfill Request Timeout Retry.

    Il valore per questa voce del Registro di sistema è espresso in secondi. Per ripristinare il valore predefinito, è necessario eliminare Replication Long Backfill Request Timeout Retry e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare "Controllo della replica di cartelle pubbliche", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Replication Messages at Startup abilitato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se Exchange è stato configurato in modo da generare messaggi di richiesta dello stato per la gerarchia delle cartelle pubbliche:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<Nome Server>\Public-<GUID di archivio informazioni pubblico>\Enable Replication Messages At Startup

Se Exchange Server Analyzer rileva che la voce Enable Replication Messages At Startup del Registro di sistema è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

In Exchange Server 5.5, ogni computer che dispone di un archivio delle cartelle pubbliche invia un messaggio notturno di richiesta dello stato per determinare lo stato della gerarchia delle cartelle pubbliche. Exchange 2000 Server e Exchange Server 2003 non eseguono questa operazione. In genere, in Exchange 2000 Server ed Exchange Server 2003 il messaggio di richiesta dello stato viene inviato solo una volta nell'arco della durata dell'archivio delle cartelle pubbliche, ovvero quando viene creato l'archivio.

Tuttavia, in alcune circostanze è necessario generare un messaggio di richiesta dello stato. Se, ad esempio, la replica della gerarchia della cartella pubblica nel computer Exchange 2000 Server o Exchange Server 2003 non viene eseguita oppure avviene molto lentamente, la creazione di un messaggio di richiesta dello stato può consentire alla replica della gerarchia di continuare. I problemi legati alla replica della gerarchia delle cartelle pubbliche possono verificarsi se il messaggio originale di richiesta dello stato inviato al momento della creazione dell'archivio delle cartelle pubbliche è stato ignorato e mai riconosciuto oppure se il messaggio è stato inviato a un server con una gerarchia significativamente incompleta.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per visualizzare o modificare il valore Aging Keep Time del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<Nome server>\Public-<GUID di archivio informazioni pubblico>

  3. Verificare o modificare il valore Enable Replication Messages At Startup. Questo valore REG_DWORD deve essere impostato su 1 per essere efficace. Se il valore viene impostato su 0 (valore predefinito), non viene inviato alcun messaggio di richiesta dello stato quando si avvia l'archivio informazioni pubblico.

  4. Se viene apportata una modifica, chiudere l'editor del Registro di sistema, quindi disinstallare e reinstallare l'archivio informazioni pubblico, per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui messaggi relativi allo stato di replica della cartella pubblica e sul valore Enable Replication Messages At Startup del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 321082, "XADM: Invio di messaggi di richiesta dello stato di replica in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=321082.

  • 842273, "Risoluzione dei problemi di replica delle cartelle pubbliche in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273.


Valore Replication Short Backfill Request Delay modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se la chiave Replication Short Backfill Request Delay è stata modificata rispetto al suo valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<servername>\Public-<GUID dell'archivio pubblico>\Replication Short Backfill Request Delay

Se Exchange Server Analyzer rileva la presenza della chiave Replication Short Backfill Request Delay, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Short Backfill Request Delay non esiste. Il processo di recupero informazioni si verifica quando in un archivio delle cartelle pubbliche non vengono ricevuti tutti gli aggiornamenti disponibili per una cartella replicata o per la gerarchia, pertanto è necessario recuperare gli aggiornamenti mancanti da un altro archivio.

Per semplificare il processo di recupero informazioni, nella matrice di recupero vengono archiviate informazioni relative agli aggiornamenti mancanti. Queste informazioni vengono archiviate nella matrice per un periodo di tempo specificato, definito timeout di recupero informazioni. Gli aggiornamenti mancanti ricevuti in messaggi di replica successivi durante il periodo di timeout specificato, verranno rimossi dalla matrice di recupero informazioni. Nella tabella riportata di seguito sono elencati i valori di timeout di recupero informazioni predefiniti classificati in base al luogo in cui sono disponibili gli aggiornamenti mancanti e a se ne è stata eseguita una richiesta in precedenza.

Tipo di richiesta | Contenuto disponibile in un archivio nel sito locale | Contenuto disponibile in un archivio di un sito remoto
Recupero informazioni iniziale | 6 ore | 12 ore
Primo tentativo di recupero informazioni | 12 ore | 24 ore
Successivi tentativi di recupero informazioni | 24 ore | 48 ore

Se il tempo specificato per il timeout di recupero informazioni scade e gli aggiornamenti sono ancora mancanti, verranno create una o più richieste di recupero informazioni e stabiliti i server da utilizzare come origini di recupero informazioni.

Per selezionare uno o più server da utilizzare come origine per il recupero delle informazioni, Exchange Server 2003 crea innanzitutto un elenco di tutti i server che dispongono di repliche della cartella, quindi ordina l'elenco in base alla seguente sequenza di criteri:

  • Ordinamento in base allo stato del server I server inattivi o non disponibili vengono inseriti alla fine dell'elenco.

  • Ordina in base al server preferenziale di recupero informazioni se disponibile. Questa funzione è disponibile solo in Exchange Server 2003 e versioni successive. Nel servizio directory di Active Directory® viene verificato l'oggetto dell'archivio delle cartelle pubbliche per un server preferenziale di recupero informazioni. Questa impostazione viene utilizzata raramente. Solitamente, il processo di recupero informazioni funziona in maniera più efficiente se viene automaticamente selezionato un server di recupero informazioni. Per la maggior parte delle distribuzioni di Exchange Server 2003 non è necessario alcun server preferenziale di recupero informazioni. Se necessario, il servizio di supporto tecnico Microsoft può fornire uno script in grado di impostare un server preferenziale di recupero informazioni.

  • Ordinamento in base al costo di trasporto (dal più conveniente al meno conveniente) I server nello stesso sito hanno la priorità sui server in siti remoti. Il costo di trasporto di un server viene calcolato dal motore di routing di Exchange Server 2003 e viene solitamente utilizzato per stabilire la maniera più efficiente di recapitare un messaggio. Nelle versioni di Exchange precedenti a Exchange Server 2003 il costo di trasporto ha una priorità inferiore e viene preso in considerazione soltanto dopo la versione di Exchange e il numero di modifiche disponibili.

  • Ordinamento in base alla versione di Exchange (dalla più recente alla meno recente)

  • Ordinamento in base al numero di modifiche necessarie disponibili sul server (da quelle più grandi a quelle più piccole) I server che non presentano nessuna delle modifiche mancanti vengono eliminati dall'elenco.

Se un server non presenta tutte le modifiche necessarie, verrà selezionato dall'elenco il server successivo e ad esso verrà inviata una richiesta di recupero informazioni. Questo processo verrà ripetuto finché non viene effettuata la richiesta di tutte le modifiche. Questa funzionalità è disponibile soltanto in Exchange Server 2003 e versioni successive. Le versioni precedenti di Exchange inviano richieste di recupero informazioni a un server alla volta, se nessun server contiene tutti gli aggiornamenti mancanti per una cartella specifica. Dopo ogni richiesta, nelle versioni precedenti di Exchange si attende la scadenza del timeout dei tentativi (dalle 24 alle 48 ore) prima che venga inviata la richiesta successiva.

Se il server selezionato non risponde alla richiesta di recupero informazioni, nell'archivio verrà contrassegnato come server inattivo e verrà ripetuto il processo di selezione. I server contrassegnati come inattivi vengono inseriti alla fine dell'elenco.

Il valore Replication Short Backfill Request Delay rappresenta il tempo di attesa dell'archivio delle cartelle pubbliche prima dell'invio di una richiesta di recupero dei dati disponibili nello stesso sito di Exchange. Il valore, espresso in secondi, deve essere compreso tra 900 e 2.592.000 secondi (30 giorni). Il valore predefinito è 21.600 secondi (6 ore).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave del Registro di sistema Replication Short Backfill Request Delay

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Short Backfill Request Delay.

    Il valore per questa voce del Registro di sistema è espresso in secondi. Per tornare al valore predefinito è necessario eliminare Replication Short Backfill Request Delay e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare "Controllo della replica di cartelle pubbliche", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Valore Replication Short Backfill Request Timeout modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la chiave Replication Short Backfill Request Timeout è stata modificata rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Replication Short Backfill Request Timeout

Se Exchange Server Analyzer rileva che Replication Short Backfill Request Timeout è presente, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Short Backfill Request Timeout non esiste. Il recupero di informazioni viene eseguito quando un archivio delle cartelle pubbliche determina che non sono stati ricevuti tutti gli aggiornamenti per una cartella replicata (oppure per la gerarchia) ed è necessario recuperare gli aggiornamenti mancanti da un altro archivio.

Per semplificare il processo di recupero informazioni, nella matrice di recupero vengono archiviate informazioni relative agli aggiornamenti mancanti. Queste informazioni vengono archiviate nella matrice per un periodo di tempo specificato, definito timeout di recupero informazioni. Gli aggiornamenti mancanti ricevuti in messaggi di replica successivi durante il periodo di timeout specificato, verranno rimossi dalla matrice di recupero informazioni. Nella tabella che segue sono elencati i valori predefiniti di timeout per il recupero delle informazioni, che dipendono dalla posizione degli aggiornamenti mancanti e dal fatto che siano stati già richiesti in precedenza o meno.

Tipo di richiesta | Contenuto disponibile in un archivio nel sito locale | Contenuto disponibile in un archivio di un sito remoto
Recupero informazioni iniziale | 6 ore | 12 ore
Primo tentativo di recupero informazioni | 12 ore | 24 ore
Successivi tentativi di recupero informazioni | 24 ore | 48 ore

Se il tempo specificato per il timeout di recupero informazioni scade e gli aggiornamenti sono ancora mancanti, verranno create una o più richieste di recupero informazioni e stabiliti i server da utilizzare come origini di recupero informazioni.

Per selezionare uno o più server da utilizzare come origine per il recupero delle informazioni, Exchange Server 2003 crea innanzitutto un elenco di tutti i server che dispongono di repliche della cartella, quindi ordina l'elenco in base alla seguente sequenza di criteri:

  • Ordinamento in base allo stato del server I server inattivi o non disponibili vengono inseriti alla fine dell'elenco.

  • Ordinamento in base al server preferenziale di recupero informazioni se disponibile. Questa funzione è disponibile solo in Exchange Server 2003 e versioni successive. Nel servizio directory di Active Directory® viene verificato l'oggetto dell'archivio delle cartelle pubbliche per un server preferenziale di recupero informazioni. Questa impostazione viene utilizzata raramente. Solitamente, il processo di recupero informazioni funziona in maniera più efficiente se viene automaticamente selezionato un server di recupero informazioni. Per la maggior parte delle distribuzioni di Exchange Server 2003 non è necessario alcun server preferenziale di recupero informazioni. Se necessario, il Servizio Supporto Tecnico Clienti Microsoft può fornire uno script in grado di impostare un server preferenziale di recupero informazioni.

  • Ordinamento in base al costo di trasporto (dal più conveniente al meno conveniente) I server nello stesso sito hanno la priorità sui server in siti remoti. Il costo di trasporto di un server viene calcolato dal motore di routing di Exchange Server 2003 e viene solitamente utilizzato per stabilire la maniera più efficiente di recapitare un messaggio. Nelle versioni di Exchange precedenti a Exchange Server 2003 il costo di trasporto ha una priorità inferiore e viene preso in considerazione soltanto dopo la versione di Exchange e il numero di modifiche disponibili.

  • Ordinamento in base alla versione di Exchange (dalla più recente alla meno recente)

  • Ordinamento in base al numero di modifiche necessarie disponibili sul server (da quelle più grandi a quelle più piccole) I server che non presentano nessuna delle modifiche mancanti vengono eliminati dall'elenco.

Se un server non presenta tutte le modifiche necessarie, verrà selezionato dall'elenco il server successivo a cui verrà inviata una richiesta di recupero informazioni. Questo processo verrà ripetuto finché non viene effettuata la richiesta di tutte le modifiche. Questa funzionalità è disponibile soltanto in Exchange Server 2003 e versioni successive. Le versioni precedenti di Exchange inviano richieste di recupero informazioni a un server alla volta, se nessun server contiene tutti gli aggiornamenti mancanti per una cartella specifica. Dopo ogni richiesta, nelle versioni precedenti di Exchange si attende la scadenza del timeout dei tentativi (dalle 24 alle 48 ore) prima che venga inviata la richiesta successiva.

Se il server selezionato non risponde alla richiesta di recupero informazioni, nell'archivio verrà contrassegnato come server inattivo e verrà ripetuto il processo di selezione. I server contrassegnati come inattivi vengono inseriti alla fine dell'elenco.

Il valore Replication Short Backfill Request Timeout rappresenta il valore di timeout utilizzato da un archivio delle cartelle pubbliche durante il tentativo di inviare una richiesta di recupero informazioni per i dati disponibili nello stesso sito di Exchange. Il valore, espresso in secondi, deve essere compreso tra 900 e 2.592.000 (30 giorni). Il valore predefinito è 43200 secondi (12 ore).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave Replication Short Backfill Request Timeout del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Short Backfill Request Timeout.

    Il valore per questa voce del Registro di sistema è espresso in secondi. Per ripristinare il valore predefinito, è necessario eliminare Replication Short Backfill Request Timeout e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare "Controllo della replica di cartelle pubbliche", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Valore Replication Short Backfill Request Timeout modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la chiave Replication Short Backfill Request Timeout Retry è stata modificata rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>\Replication Short Backfill Request Timeout Retry

Se Exchange Server Analyzer rileva che Replication Short Backfill Request Timeout Retry è presente, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, Replication Short Backfill Request Timeout Retry non esiste. Il recupero di informazioni viene eseguito quando un archivio delle cartelle pubbliche determina che non sono stati ricevuti tutti gli aggiornamenti per una cartella replicata (oppure per la gerarchia) ed è necessario recuperare gli aggiornamenti mancanti da un altro archivio.

Per semplificare il processo di recupero informazioni, nella matrice di recupero vengono memorizzate informazioni relative agli aggiornamenti mancanti. Queste informazioni vengono memorizzate nella matrice per un periodo di tempo specificato, definito timeout di recupero informazioni. Gli aggiornamenti mancanti ricevuti in messaggi di replica successivi durante il periodo di timeout specificato verranno rimossi dalla matrice di recupero informazioni. Nella tabella che segue sono elencati i valori predefiniti di timeout per il recupero delle informazioni, che dipendono dalla posizione degli aggiornamenti mancanti e dal fatto che siano stati già richiesti in precedenza o meno.

Tipo di richiesta | Contenuto disponibile in un archivio del sito locale | Contenuto disponibile in un archivio di un sito remoto
Recupero informazioni iniziale | 6 ore | 12 ore
Primo tentativo di recupero informazioni | 12 ore | 24 ore
Tentativi successivi di recupero informazioni | 24 ore | 48 ore

Se il tempo specificato per il timeout di recupero informazioni scade e gli aggiornamenti sono ancora mancanti, verranno create una o più richieste di recupero informazioni e stabiliti i server da utilizzare come origini di recupero informazioni.

Per selezionare uno o più server da utilizzare come origine per il recupero delle informazioni, Exchange Server 2003 crea innanzitutto un elenco di tutti i server che dispongono di repliche della cartella, quindi ordina l'elenco in base alla sequenza di criteri seguente:

  • Ordinamento in base allo stato del server I server inattivi o non disponibili vengono inseriti alla fine dell'elenco.

  • Ordinamento in base al server preferenziale di recupero informazioni se disponibile. Questa funzione è disponibile solo in Exchange Server 2003 e versioni successive. Nel servizio directory di Active Directory® viene verificato l'oggetto dell'archivio delle cartelle pubbliche per un server preferenziale di recupero informazioni. Questa impostazione viene utilizzata raramente. Solitamente, il processo di recupero informazioni funziona in maniera più efficiente se viene automaticamente selezionato un server di recupero informazioni. Per la maggior parte delle distribuzioni di Exchange Server 2003 non è necessario alcun server preferenziale di recupero informazioni. Se necessario, il Servizio Supporto Tecnico Clienti Microsoft può fornire uno script in grado di impostare un server preferenziale di recupero informazioni.

  • Ordinamento in base al costo di trasporto (dal più conveniente al meno conveniente) I server nello stesso sito hanno la priorità sui server in siti remoti. Il costo di trasporto di un server viene calcolato dal motore di routing di Exchange Server 2003 e viene solitamente utilizzato per stabilire la maniera più efficiente di recapitare un messaggio. Nelle versioni di Exchange precedenti a Exchange Server 2003 il costo di trasporto ha una priorità inferiore e viene preso in considerazione soltanto dopo la versione di Exchange e il numero di modifiche disponibili.

  • Ordinamento in base alla versione di Exchange (dalla più recente alla meno recente)

  • Ordinamento in base al numero di modifiche necessarie disponibili sul server (da quelle più grandi a quelle più piccole) I server che non presentano nessuna delle modifiche mancanti vengono eliminati dall'elenco.

Se un server non dispone di tutte le modifiche necessarie, Exchange Server 2003 seleziona il successivo server nell'elenco ordinato e invia una richiesta di recupero informazioni anche a tale server. Questo processo verrà ripetuto finché non viene effettuata la richiesta di tutte le modifiche. Questa funzionalità è disponibile soltanto in Exchange Server 2003 e versioni successive. Le versioni precedenti di Exchange inviano richieste di recupero informazioni a un server alla volta, se nessun server contiene tutti gli aggiornamenti mancanti per una cartella specifica. Dopo ogni richiesta, nelle versioni precedenti di Exchange si attende la scadenza del timeout dei tentativi (dalle 24 alle 48 ore) prima che venga inviata la richiesta successiva.

Se il server selezionato non risponde alla richiesta di recupero informazioni, nell'archivio verrà contrassegnato come server inattivo e verrà ripetuto il processo di selezione. I server contrassegnati come inattivi vengono inseriti alla fine dell'elenco.

Il valore Replication Short Backfill Request Timeout Retry rappresenta il valore di timeout utilizzato dall'archivio delle cartelle pubbliche durante l'invio di una richiesta di recupero informazioni per dati disponibili nello stesso sito Web di Exchange e quando tale richiesta rappresenta un nuovo tentativo di una precedente richiesta di recupero informazioni. Il valore, espresso in secondi, deve essere compreso tra 900 e 2.592.000 secondi (30 giorni). Il valore predefinito è 86400 secondi (24 ore).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per reimpostare la chiave Replication Short Backfill Request Timeout Retry del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<nomeserver>\Public-<GUID dell'archivio pubblico>

  3. Verificare o modificare il valore di Replication Short Backfill Request Timeout Retry.

    Il valore per questa voce del Registro di sistema è espresso in secondi. Per ripristinare il valore predefinito, è necessario eliminare Replication Short Backfill Request Timeout Retry e riavviare il servizio Archivio informazioni di Microsoft Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla replica delle cartelle pubbliche, consultare "Controllo della replica di cartelle pubbliche", in Uso dell'archivio di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47595.


Dimensione Reserve increment size impostata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-30

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stato impostato un valore per Reserve Increment KB: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Microsoft Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Microsoft Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Microsoft Exchange Server 2003. Se la stringa comprende "Version 8.0", il computer esegue Microsoft Exchange Server 2007.

Se Exchange Server Analyzer rileva che il valore del Registro di sistema Reserve Increment KB è presente su un computer che esegue Exchange Server 2003, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore del Registro di sistema Reserve Increment KB sostituisce il valore heap della memoria nativa in Microsoft Windows®. Windows include una gestione heap estesa che gestisce le operazioni di memoria per tutti i processi. Quando viene creata l'istanza di un processo, viene creato anche un heap predefinito (denominato heap del processo). Se necessario, anche i programmi o i moduli caricati nel processo possono creare heap aggiuntivi. Il processo dell'Archivio informazioni di Microsoft Exchange, Store.exe, è un esempio di un processo in cui, se necessario, vengono creati heap aggiuntivi. Per impostazione predefinita, in Store.exe lo spazio della memoria iniziale destinato all'heap corrisponde al 20% della memoria RAM fisica. Il valore Reserve Increment KB modifica lo spazio della memoria iniziale destinato agli heap a un valore pari al 10% della memoria fisica.

Il valore del Registro di sistema Reserve Increment KB è utile solo in determinati casi. Questo valore dovrebbe essere impostato solo su suggerimento dei professionisti addetti al Servizio Supporto Tecnico Clienti Microsoft (PSS). L'impostazione o l'utilizzo errato di questo valore può provocare una diminuzione delle prestazioni e un aumento della frammentazione della memoria virtuale. Se il valore è stato impostato senza consultare il Servizio Supporto Tecnico Clienti Microsoft, provare a rimuoverlo utilizzando la procedura descritta di seguito.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro eliminare il valore Reserve Increment KB.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sulla regolazione corretta di Exchange Server 2003, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 815372, "Ottimizzazione dell'utilizzo della memoria in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=815372.


La compressione RPC del buffer non è abilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la compressione RPC del buffer (Remote Procedure Call) è stata disabilitata:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Packing Enabled

Se Exchange Server Analyzer rileva che il valore della chiave Rpc Packing Enabled del Registro di sistema è stato impostato su 0, verrà visualizzato un messaggio di configurazione non predefinita. La chiave Rpc Packing Enabled del Registro di sistema è disabilitata quando il relativo valore è impostato su 0.

I dati del valore per la chiave Rpc Packing Enabled del Registro di sistema rappresentano una delle tre voci del Registro di sistema che possono essere aggiunte dagli amministratori per configurare la compressione RPC tra Microsoft Office Outlook® 2003 e Exchange Server 2003.

Outlook 2003 può richiedere un buffer dati di 96 KB. Tuttavia, dopo la compressione dei dati in Exchange Server 2003, la dimensione del buffer dati può essere notevolmente inferiore rispetto a quella richiesta da Outlook 2003.

Exchange Server 2003 supporta diversi rapporti di compressione del buffer e mantiene i buffer pieni per garantirne la massima efficienza.

Quando la chiave Rpc Packing Enabled del Registro di sistema è abilitata, i dati compressi continuano a essere aggiunti al buffer finché questo non è pieno. Per ciascuna richiesta dati, Outlook 2003 consente di eseguire il download di una quantità notevolmente maggiore di dati rispetto alle versioni precedenti di Outlook. Ciò è dovuto alle seguenti ragioni:

  • Outlook 2003 richiede dimensioni di buffer maggiori.

  • Exchange Server 2003 supporta la compressione del buffer.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione. Tuttavia, se si desidera ripristinare la configurazione predefinita, è possibile eliminare la chiave Rpc Packing Enabled del Registro di sistema. È possibile, inoltre, impostare il valore della chiave Rpc Packing Enabled del Registro di sistema su 1 per abilitare la compressione del buffer RPC.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    • Per eliminare la voce, eliminare il valore Rpc Packing Enabled.

    • Per mantenere la voce e abilitare la compressione del buffer RPC, fare doppio clic su Rpc Packing Enabled, impostare il valore su 1, quindi fare clic su OK.

  3. Chiudere l'editor del Registro di sistema.

Il servizio Archivio informazioni di Microsoft Exchange impiega pochi minuti per rilevare le modifiche. Non è necessario riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione delle chiavi del Registro di sistema per configurare la compressione RPC tra i client Outlook ed Exchange Server 2003, consultare l'articolo 825371 della Microsoft Knowledge Base "Modifica della compressione RPC (Remote Procedure Call) in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371.


Valore RPC Compression Minimum Size non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la dimensione minima dei pacchetti per la compressione RPC (Remote Procedure Call):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Rpc Compression Minimum Size

Se Exchange Server Analyzer rileva che il valore di Rpc Compression Minimum Size è superiore a 0, verrà visualizzato un messaggio di configurazione non predefinita.

Per impostazione predefinita, tutti i dati RPC spostati tra Microsoft Office Outlook® 2003 oppure Outlook 2007 ed Exchange Server 2003 o Exchange Server 2007 vengono compressi, indipendentemente dalla loro dimensione. In alcuni scenari, può essere necessario controllare la compressione RPC. Ad esempio, se si tenta di risolvere problemi di connettività visualizzando i pacchetti trasmessi attraverso la rete, la compressione RPC potrebbe rendere difficile l'analisi poiché nella traccia vengono visualizzati solo i dati compressi.

Per configurare le impostazioni della compressione RPC, è possibile aggiungere alle impostazioni di sistema tre valori della chiave del Registro di sistema:

  • Rpc Compression Minimum Size

  • Rpc Compression Enabled

  • Rpc Packing Enabled

Il valore Rpc Compression Minimum Size del Registro di sistema determina il numero minimo di byte richiesti nel pacchetto RPC prima di attivare la compressione. Se questa chiave non è presente, verrà utilizzato un valore predefinito di 1.024 byte.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare la chiave Rpc Compression Minimum Size. Se presenti, eliminare anche le chiavi Rpc Compression Enabled e Rpc Packing Enabled.

  4. Chiudere l'editor del Registro di sistema e riavviare il server di Exchange per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul controllo della compressione RPC, consultare l'articolo 825371 della Microsoft Knowledge Base "Modifica della compressione RPC (Remote Procedure Call) in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=825371.


Parametro RpcEtwTracing non predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinarne i dati del valore:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\RpcEtwTracing

Se Exchange Server Analyzer rileva che i dati relativi al valore della chiave RpcEtwTracing del Registro di sistema è stato impostato su 1, verrà visualizzato un messaggio di configurazione non predefinita.

È possibile utilizzare i dati del valore per la chiave RpcEtwTracing del Registro di sistema solo per risolvere problemi di rete tra Microsoft Office Outlook® 2003 ed Exchange Server. A meno che non sia indispensabile per la risoluzione di un problema, si consiglia di disabilitare la chiave RpcEtwTracing del Registro di sistema.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione. Tuttavia, se si desidera ripristinare la configurazione predefinita, è possibile eliminare la chiave RpcEtwTracing del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore RpcEtwTracing.

  4. Chiudere l'editor del Registro di sistema.

Il servizio Archivio informazioni di Microsoft Exchange impiega pochi minuti per rilevare le modifiche. Non è necessario riavviare il computer.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Per il server sono definiti meno di quattro gruppi di archiviazione e più di quattro archivi di cassette postali
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per contare il numero di oggetti StorageGroup e MailboxGroup presenti su un server che esegue Exchange Server 2003. Se Exchange Server Analyzer determina che il numero totale di oggetti StorageGroup è minore di quattro e il numero totale di oggetti MailboxStore è maggiore di quattro, verrà visualizzato un messaggio di errore.

Se si utilizza Exchange Server 2003 Standard Edition, ogni computer che esegue Exchange Server può disporre di un gruppo di archiviazione, che supporta un archivio delle cassette postali e un archivio di cartelle pubbliche. Se si utilizza Exchange Server 2003 Enterprise Edition, ogni server può disporre di un numero massimo di quattro gruppi di archiviazione, ognuno dei quali supporta fino a cinque database (archivi di cassette postali o archivi di cartelle pubbliche).

Per la configurazione di gruppi di archiviazione per computer che eseguono Exchange Server 2003 Enterprise Edition, è consigliabile aggiungere un ulteriore gruppo di archiviazione a ogni nuovo database fino a raggiungere il numero massimo consentito. È possibile distribuire il carico delle cassette postali della topologia di archiviazione di Exchange Server nel maggior numero possibile di gruppi di archiviazione. Una topologia simile presenta i seguenti vantaggi:

  • Aumento dell'affidabilità della topologia di archiviazione.

  • Aumento della recuperabilità della topologia di archiviazione.

  • Miglioramento nella gestione dell'unità I/O.

Se si dispone di meno di quattro gruppi di archiviazione e di più di quattro archivi di cassette postali in un server che esegue Exchange Server 2003 Enterprise Edition, eseguire i seguenti passaggi per distribuire le cassette postali nel maggior numero possibile di gruppi di archiviazione.

Per risolvere il problema

  1. In Gestore di sistema di Exchange selezionare il server che ha segnalato l'errore. Annotare il numero di gruppi di archiviazione e di archivi di cassette postali sul server. Annotare il numero di gruppi di archiviazione che contengono più di un archivio delle cassette postali.

  2. Creare gruppi di archiviazione aggiuntivi fino a raggiungere il numero di quattro gruppi isu computer che eseguono Exchange Server 2003 Enterprise Edition. Per ulteriori informazioni su come creare un nuovo gruppo di archiviazione, consultare il capitolo "Aggiunta di un gruppo di archiviazione" del Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

  3. Creare un nuovo archivio delle cassette postali in ogni nuovo gruppo di archiviazione. Per ulteriori informazioni sugli elenchi di indirizzi e il Servizio aggiornamento destinatari, consultare il capitolo "Aggiunta di un gruppo di archiviazione" del Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.

  4. Spostare le cassette postali dall'archivio nel gruppo di archiviazione contenente più archivi di cassette postali all'archivio situato nel gruppo di archiviazione appena creato. Per spostare le cassette postali, utilizzare la procedura guidata Sposta cassetta postale. Per ulteriori informazioni sull'utilizzo della procedura guidata Sposta cassetta postale, consultare "Utilizzo dell'Operazione guidata di Exchange per spostare cassette postali" nel capitolo "Migrazione da Exchange Server 5.5 a Exchange 2003" del Manuale di installazione di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47569.

Per ulteriori informazioni sulla modalità di configurazione dei gruppi di archiviazione in Exchange Server 2003, consultare l'articolo 890699 della Microsoft Knowledge Base "Configurazione dei gruppi di archiviazione Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=890699.

Per informazioni sulla configurazione di gruppi di archiviazione, consultare la relativa sezione in "Pianificazione di una soluzione di archiviazione back-end affidabile" della Guida alla massima disponibilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47571.

Per consigli generali sull'ottimizzazione della disponibilità, sulla tolleranza d'errore e sulle prestazioni, consultare Ottimizzazione del sistema di archiviazione per Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=49324.


Discrepanza delle firme tra database e file di flusso
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha rilevato una discrepanza delle firme tra il file di database di Exchange (con estensione EDB) in uso e il corrispondente file di database di flusso di Exchange (con estensione STM).

Ogni database all'interno di Exchange 2000 Server e di Exchange Server 2003 è composto da due file: il file di database MAPI con estensione EDB e il file di database di flusso con estensione STM. Le coppie corrispondenti di questi file condividono una firma di database comune. Se la firma non è identica, i file non corrispondono.

Il file con estensione EDB e quello con estensione STM devono essere considerati come un singolo file. Pertanto, occorre spostarli o copiarli sempre in coppia.

Per risolvere il problema

  • Analizzare la cronologia dei file di database. Probabilmente sono stati copiati, spostati o eliminati manualmente. È necessario risolvere il problema prima di procedere al ripristino del database.

  • Se non è possibile individuare file con estensione EDB e STM corrispondenti, utilizzare Eseutil.exe per ripristinare solo il file con estensione EDB, quindi utilizzare Eseutil con l'opzione /createstm per eliminare il file con estensione STM. L'implementazione di questo metodo comporta la perdita di tutte le informazioni contenute nel database di flusso.

    Nota:
    Se tutti gli utenti del database eseguono la connessione al database mediante un client MAPI come Microsoft Office Outlook®, la quantità di informazioni archiviate nel database di flusso è molto esigua. Se invece si connettono mediante client Outlook Web Access, IMAP o POP3, nel database di flusso risulterà archiviato il contenuto parziale o totale delle cassette postali degli utenti.

Per ulteriori informazioni sulle modalità di ripristino di un database di Exchange, consultare l'articolo 812357 della Microsoft Knowledge Base "Manutenzione di un database di Exchange dopo il ripristino eseguito mediante lo strumento Eseutil /p in Exchange Server 5.5, in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812357.


Indirizzo SMTP non definito nel criterio destinatario predefinito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-12-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se è specificato l'indirizzo SMTP nell'attributo gatewayProxy del criterio destinatario predefinito nell'organizzazione di Exchange Server. Se Exchange Server Analyzer rileva che l'attributo gatewayProxy non contiene un indirizzo SMTP, verrà visualizzato un messaggio di errore.

Si tratta di un errore critico. È necessario aggiungere l'indirizzo SMTP, ad esempio SMTP:@contoso.com all'attributo gatewayProxy del criterio destinatario predefinito nell'organizzazione di Exchange Server. Il criterio destinatario predefinito deve contenere un indirizzo SMTP. In caso contrario, il servizio Archivio informazioni di Microsoft Exchange non verrà inizializzato dopo il riavvio. Questo errore si verificherà in tutti i server di Exchange nell'organizzazione di Exchange Server al successivo riavvio del servizio Archivio informazioni di Microsoft Exchange.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Exchange Server 2003 o Exchange Server 2007 oppure entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per aggiungere l'indirizzo SMTP all'attributo gatewayProxy del criterio destinatario predefinito

  1. Avviare lo strumento ADSI Edit dagli Strumenti di supporto di Microsoft Windows® 2000 o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Criteri destinatari

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su CN=Default Policy e scegliere Proprietà.

  4. Nella casella Attributi fare doppio clic su gatewayProxy.

  5. Nella finestra di dialogo Editor di stringa multivalore inserire SMTP:@domain_name.com nel campo Valore da aggiungere, quindi fare clic su Aggiungi.

    Nota:
    La sintassi che si inserisce è importante. È necessario includere SMTP:@ prima di inserire il nome di dominio dell'organizzazione di Exchange Server. La stringa non deve contenere spazi.

  6. Fare clic su OK, Applica, quindi chiudere ADSI Edit.

  7. Attendere almeno 15 minuti per la replica.


I parametri Store RPC prorate del Registro di sistema non sono impostati sui valori corretti
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge tre chiavi del Registro di sistema per determinare se i rispettivi valori sono stati modificati rispetto ai valori predefiniti. Tutte e tre le chiavi rappresentano valori DWORD reperibili nel percorso:

HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

Le chiavi presentano i seguenti nomi e valori predefiniti:

Valore DWORD Valore decimale predefinito
  • ProrateStart
  • 40
  • ProrateMax
  • 10,000
  • ProrateFactor
  • 100

Se Exchange Server Analyzer rileva che uno dei suddetti valori predefiniti è stato modificato, verrà visualizzato un messaggio di configurazione non predefinita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare i valori predefiniti

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options\STORE.EXE\RpcThreadPoolThrottle

  3. Nel riquadro destro fare doppio clic sulla voce il cui valore è stato modificato e configurarla per il valore predefinito.

  4. Se sono stati modificati più valori, ripetere il passaggio 3.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sui thread del processo di archiviazione, consultare l'articolo 267255 della Microsoft Knowledge Base "Consumo totale della memoria disponibile da parte dei thread di Store.exe" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=267255.


Directory di lavoro per l'archivio mancante o errata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-30

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per verificare la directory di lavoro per il servizio Archivio informazioni di Microsoft Exchange.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\Working Directory

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • La directory specificata come directory di lavoro non esiste.

  • Nel computer in uso è in esecuzione Exchange 2000 Server, Exchange Server 2003 o Exchange Server 2007.

In Exchange Server la directory di lavoro viene utilizzata per l'archiviazione temporanea, ad esempio durante il processo di conversione dei messaggi. Inoltre, essa viene utilizzata per archiviare un database temporaneo durante la deframmentazione. Se la directory di lavoro non viene specificata correttamente, potrebbero verificarsi i seguenti problemi:

  • I messaggi con allegati potrebbero aumentare nella coda SMTP di recapito locale.

  • I messaggi potrebbero essere ricevuti senza i relativi allegati.

  • I messaggi potrebbero non essere recapitati.

Per impostazione predefinita, in Exchange 2000 Server e in Exchange Server 2003 la directory di lavoro è denominata mdbdata e si trova nella directory di installazione di Exchange Server. Ad esempio, se si installa Exchange Server nella directory C:\Programmi\Exchsrvr directory, la directory di lavoro verrà impostata come C:\Programmi\Exchsrvr\mdbdata.

Per impostazione predefinita, in Exchange Server 2007 la directory di lavoro è la directory del database delle cassette postali e si trova nella directory di installazione di Exchange Server. Ad esempio, se si installa Exchange Server nella directory C:\Programmi\Exchange Server, in Exchange Server 2007 la directory di lavoro verrà impostata su C:\Programmi\Exchange Server\Mailbox\MDBTemp.

Per correggere questo errore, specificare la directory di lavoro come una directory esistente nel server di Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per specificare la directory di lavoro utilizzando Regedit

  1. Avviare l'editor del Registro di sistema (Regedit).

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Aggiornare il valore Working Directory del Registro di sistema con la directory di lavoro corretta per il servizio Archivio informazioni di Microsoft Exchange, quale, ad esempio, C:\Programmi\Exchsrvr\mdbdata.

    Nota:
    Questa modifica non richiede il riavvio del servizio Archivio informazioni di Microsoft Exchange.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore di Registro di sistema Working Directory, vedere l'articolo 298415 della Knowledge Base, "Mancato recapito dei messaggi con allegati e registrazione di messaggi con ID evento 12003 e 327 in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?Linkid=3052&kbid=298415.


È stato disabilitato l'invio di messaggi Fuori sede alle liste di distribuzione
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-02-27

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se i messaggi Fuori sede sono stati eliminati dalle liste di distribuzione:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\SuppressOOFsToDistributionLists

Se Exchange Server Analyzer rileva che il valore di SuppressOOFsToDistributionLists è maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Se viene inviato un messaggio a una cassetta postale sulla quale è attivato l'Assistente fuori sede, il mittente riceverà un messaggio privo di indirizzo nei campi A o Cc, ma con una lista di distribuzione nel campo Ccn. Il messaggio Fuori sede viene inviato alla lista di distribuzione che si trova nel campo Ccn.

Se un messaggio viene inviato a un destinatario e l'indirizzo del destinatario è indicato solo nel campo Ccn, ma non in una lista di distribuzione e se il destinatario ha attivato l'Assistente fuori sede, l'archivio della cassetta postale del destinatario invierà un messaggio Fuori sede anche se è stato impostato il valore del Registro di sistema SuppressOOFsToDistributionLists. Questo limite viene applicato solo se l'indirizzo del destinatario viene inserito nel campo Ccn, mentre i campi A e Cc sono vuoti. Se viene indicato almeno un utente nei campi A o Cc, il parametro del Registro di sistema sul computer Exchange Server impedirà che vengano generati messaggi Fuori sede per i destinatari elencati nel campo Ccn.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per modificare le generazione dei messaggi Fuori sede

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Fare clic con il pulsante destro del mouse su Parametri, scegliere Nuovo, quindi fare clic su Valore DWORD.

  4. Denominare il nuovo valore SuppressOOFsToDistributionLists.

  5. Fare clic con il pulsante destro del mouse su SuppressOOFsToDistributionLists, quindi scegliere Modifica.

  6. Nella casella Dati valore immettere 1, quindi fare clic su OK.

  7. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore SuppressOOFsToDistributionLists del Registro di sistema, consultare l'articolo 825370 della Microsoft Knowledge Base "I messaggi fuori sede vengono inviati alle liste di distribuzione presenti nel campo Ccn" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=825370.


Il valore di soglia che controlla il numero di volte che un messaggio danneggiato può passare nell'archivio è stato modificato
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-08

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore di PoisonThreshold:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS \<NomeServerExchange> \Private- <GUIDarchivioinformazioniprivato>

Se Exchange Server Analyzer determina che il valore di PoisonThreshold non corrisponde a 2, verrà visualizzato un messaggio di configurazione non predefinita.

Nelle versioni di Exchange Server successive a Exchange Server 2003 Service Pack 1 sono implementate opzioni che consentono di evitare che messaggi danneggiati o non validi provochino l'arresto imprevisto del servizio Archivio informazioni di Microsoft Exchange o ne impediscano il corretto avvio.

In Exchange Server 2003 Service Pack 1 o versioni successive, viene tenuta traccia dei messaggi che causano l'arresto imprevisto del servizio Archivio informazioni di Microsoft Exchange durante la conversione dal formato MAPI al formato MIME. Quando si verifica l'arresto anomalo, l'ID del messaggio danneggiato verrà archiviato nel Registro di sistema. Se un messaggio danneggiato causa per tre volte l'arresto imprevisto dell'archivio, queste informazioni verranno utilizzate per impedire la rielaborazione del messaggio quando il servizio Archivio informazioni di Microsoft Exchange verrà riavviato per la quarta volta.

Quando il servizio Archivio informazioni di Microsoft Exchange si arresta in modo imprevisto a causa di un messaggio danneggiato, il valore del Registro di sistema PoisonIDs viene creato in:

HKLM\System\CurrentControlSet\Services\MSExchangeIS \<NomeServerExchange> \Private- <GUIDarchivioinformazioniprivato>

Inoltre, l'amministratore può creare nel Registro di sistema la voce PoisonThreshold. La chiave PoisonThreshold è in grado di controllare il numero massimo di volte in cui a un messaggio è consentito passare attraverso l'Archivio informazioni di Microsoft Exchange prima di essere aggiunto alla chiave del Registro di sistema PoisonIDs. Per impostazione predefinita, questo valore limite è 2. Per generare questo comportamento, il valore limite deve essere superato. Pertanto, il servizio Archivio informazioni di Microsoft Exchange può arrestarsi 3 volte a causa di un messaggio danneggiato prima che il messaggio in questione venga bloccato. Quindi, un messaggio che determina 3 arresti anomali verrà bloccato poiché è stato superato il valore limite di 2.

Quando un evento messaggio danneggiato viene scritto nel Registro di sistema, i messaggi dell'evento di errore (ID evento 9680 e 9681) vengono visualizzati nel registro eventi applicazioni. Una volta avviato il servizio Archivio informazioni di Microsoft Exchange, il messaggio viene bloccato e viene tentato l'invio di un rapporto di mancato recapito. In alcuni casi è possibile che Exchange non sia in grado di inviare un rapporto di mancato recapito. In altri casi è possibile che il messaggio bloccato rimanga nella coda fino alla scadenza. La chiave del Registro di sistema PoisonIDs può contenere fino a dieci valori dell'ID messaggio. Quando il limite di dieci viene superato e viene aggiunto un nuovo evento messaggio, viene rimosso l'evento messaggio danneggiato con la data di arresto anomalo meno recente.

Nota:
La procedura per risolvere i problemi di singoli messaggi danneggiati non rientra nell'ambito di Exchange Server Analyzer. In alcuni casi, il Servizio Supporto Tecnico Clienti Microsoft potrebbe essere in grado di fornire assistenza risolvendo i problemi di singoli messaggi danneggiati. Se si verificano problemi con gli arresti di Exchange Server 2003 o versioni successive causati da messaggi danneggiati, può essere utile abilitare la segnalazione automatica degli errori sul computer che esegue Exchange Server. I dati di un rapporto errori vengono utilizzati per individuare e risolvere i problemi nel software in uso. Per ulteriori informazioni sulla procedura di abilitazione della funzionalità di segnalazione degli errori di Exchange, vedere Segnalazione errori di Exchange è disattivata.

Per il valore di PoisonThreshold si consiglia di ripristinare l'impostazione predefinita di 2.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\<NomeServerExchange>\Private-<GUIDarchivioinformazioniprivato>

  3. Nel riquadro destro fare doppio clic su PoisonThreshold.

  4. Nel campo Dati valore inserire 2 (decimale) e scegliere OK.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Analisi abilitata nel processo di archiviazione
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool controlla il Registro di sistema per verificare se la voce Enable Tracing è presente insieme al valore Trace User LegacyDN del Registro di sistema. Entrambe questi valori sono presenti nella seguente chiave del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva che entrambe le voci del Registro di sistema sono presenti e correttamente configurate, verrà visualizzato un avviso.

Il valore DWORD di Enable Tracing nel Registro di sistema abilita l'analisi per il servizio Archivio informazioni di Microsoft Exchange. L'analisi viene utilizzata per risolvere problemi di avvio dell'Archivio di Exchange e può influenzare in modo significativo le prestazioni. A meno che non sia indispensabile per la risoluzione di un problema, non è consigliabile utilizzare questa impostazione del Registro di sistema. L'analisi può essere abilitata per utenti specifici (analisi filtrata) aggiungendo il valore della stringa Trace User LegacyDN del Registro di sistema. Se il valore Trace User LegacyDN non è presente, l'analisi è abilitata per tutti gli utenti. Se il valore Trace User LegacyDN è presente, l'analisi viene eseguita per gli utenti specifici elencati in suddetta chiave.

Se la risoluzione del problema non viene eseguita sul computer Exchange Server, questi valori del Registro di sistema non dovrebbero essere presenti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare i valori Enable Tracing e Trace User LegacyDN del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il computer per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'analisi per utenti specifici in un server di Exchange, consultare l'articolo 296624 della Microsoft Knowledge Base "Aggiunta della funzione di analisi per utenti specifici a Exchange 2000 Server Service Pack 2 (SP2)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624.


Analisi abilitata nel servizio Archivio informazioni di Microsoft Exchange per tutti gli utenti
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge il Registro di sistema per determinare se la voce Enable Tracing è presente nella chiave:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSexchangeIS\ParametersSystem

Se Exchange Server Analyzer rileva la presenza e la corretta configurazione del valore Enable Tracing del Registro di sistema, verrà visualizzato un avviso.

Il valore DWORD di Enable Tracing nel Registro di sistema abilita l'analisi per l'Archivio informazioni di Microsoft Exchange. L'analisi viene utilizzata per risolvere problemi di avvio dell'Archivio e può influenzare in modo significativo le prestazioni. A meno che non sia indispensabile per la risoluzione di un problema, non è consigliabile utilizzare questa impostazione del Registro di sistema. L'analisi può essere abilitata per utenti specifici aggiungendo il valore della stringa Trace User LegacyDN del Registro di sistema. L'assenza del valore indica che l'analisi è abilitata per tutti gli utenti.

Se la risoluzione del problema non viene eseguita sul computer Exchange Server, questo valore non dovrebbe essere presente.

Nota:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Eliminare il valore Enable Tracing del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'analisi per utente relativa a un server di Exchange, consultare l'articolo 296624 della Microsoft Knowledge Base "Aggiunta della funzione di analisi per utenti specifici a Exchange 2000 Server Service Pack 2 (SP2)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=296624.


Nomi file dei registri delle transazioni quasi esauriti
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool verifica il corretto funzionamento dei file di registro delle transazioni in ogni gruppo di archiviazione mediante il controllo dei file di registro sul disco del server. Per individuare la posizione dei file di registro, Exchange Server Analyzer esegue una query nel servizio directory di Active Directory®. Per ciascun oggetto gruppo di archiviazione (classe msExchStorageGroup), il percorso dei file di registro è contenuto nell'attributo msExchESEParamLogFilePath.

I nomi dei file di registro delle transazioni includono numeri esadecimali sequenziali che identificano la sequenza dei file di registro. Ad esempio, il primo file di registro per il Primo gruppo di archiviazione predefinito si chiama E0000001.log, il secondo è E0000002.log e così via. La sequenza può arrivare fino a E00FFFFF.log. Exchange può creare fino a 1.030.000 file di registro univoci. Tuttavia, quando Exchange raggiunge la fine della sequenza, gli archivi del gruppo di archiviazione interessato non verranno più installati se sono disinstallati quando viene raggiunto il limite. Se rimangono installati, l'archivio non disinstallerà i database anche se non viene eseguita alcuna operazione Jet. In genere, Exchange impiega diversi anni prima di raggiungere suddetto limite.

Questo messaggio verrà visualizzato come avviso se il server specificato ha utilizzato più di 950.000 file di registro delle transazioni.

Questo messaggio verrà visualizzato come errore se il server specificato ha utilizzato più di 1.020.000 file di registro delle transazioni.

Per consentire all'archivio di disinstallare correttamente i database se viene raggiunto il limite, in Exchange Server 2003 Service Pack 1 è stata inclusa una correzione. Per Exchange 2000 Server è disponibile un aggiornamento rapido successivo al-Service Pack 3, come descritto nell'articolo 830408 della Microsoft Knowledge Base "Gli archivi di database di Exchange restano installati anche se sono stati utilizzati tutti i registri delle transazioni disponibili per un gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408.

Se Exchange non ha ancora raggiunto il limite di 1.030.000 per il registro delle transazioni, eseguire appena possibile un backup in linea completo del server. Per ulteriori informazioni sull'esecuzione del backup in linea completo degli archivi di Exchange, consultare la Guida al ripristino di emergenza di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47570.

Se Exchange ha raggiunto questo limite, è necessario spostare tutti i registri delle transazioni in un percorso diverso. Al termine verrà generata una nuova sequenza di file di registro che inizia con 0x00001. Per assicurarsi che l'archivio di Exchange disinstalli correttamente i database, è necessario applicare la correzione appropriata per la versione in uso di Exchange.

Nota:
Prima di spostare i registri delle transazioni è necessario verificare che tutti i database nel gruppo di archiviazione siano nello stato di chiusura normale.
Importante:
Dopo aver eseguito la procedura indicata di seguito, tutti i precedenti backup verranno invalidati. Ciò non significa che i backup non potranno essere ripristinati. Tuttavia, non potrà più essere eseguito il roll forward con registri delle transazioni aggiuntivi. Se è necessario ripristinare un precedente backup dopo la rimozione dei registri delle transazioni, sarà possibile ripristinare i dati solo fino al momento in cui è stata creata la nuova generazione di registri.

Per risolvere questo problema

  1. Per Exchange Server 2003, installare il Service Pack 1 disponibile nel sito Web dei download per Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=29090.

    -oppure-

    Per Exchange 2000 Server, richiedere e installare l'aggiornamento rapido menzionato nell'articolo 830408 della Microsoft Knowledge Base "Gli archivi di database di Exchange restano installati anche se sono stati utilizzati tutti i registri delle transazioni disponibili per un gruppo di archiviazione" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=830408.

  2. Nel gruppo di archiviazione privo di file di registro delle transazioni, disinstallare tutti i database. Per eseguire l'operazione, procedere come segue:

    1. Aprire Gestore di sistema di Exchange.

    2. Espandere Gruppi amministrativi, <NomeGruppoAmministrativo>, Server, <NomeServer>, quindi <NomeGruppoDiArchiviazione>.

    3. Fare clic con il pulsante destro del mouse sul primo archivio nel gruppo di archiviazione e scegliere Disinstalla archivio. Ripetere questo passaggio per ogni archivio nel gruppo di archiviazione.

  3. Verificare che ogni database nel gruppo di archiviazione sia nello stato di chiusura normale. Per eseguire l'operazione, procedere come segue:

    1. In Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sul primo archivio nel gruppo di archiviazione privo di file di registro delle transazioni e scegliere Proprietà.

    2. Selezionare la scheda Database e prendere nota dei percorsi e dei nomi dei file di database nella casella Database di Exchange e nella casella Database di flusso di Exchange. Ogni database di Exchange è composto da una coppia di file con estensione EDB e STM. Ripetere questo passaggio per ogni archivio nel gruppo di archiviazione.

    3. Al prompt dei comandi, modificare la directory impostando la cartella bin di Exchange Server. Ad esempio, impostare per la directory il percorso C:\Programmi\Exchsrvr\bin.

    4. Digitare Eseutil /mh NomeFileDatabase, quindi premere INVIO. Ripetere questo passaggio per ogni database nel gruppo di archiviazione. Questo comando consente di visualizzare l'intestazione del file di database. L'intestazione conterrà una delle due righe seguenti: Stato: Chiusura normale oppure Stato: Arresto anomalo.

  4. Se l'intestazione contiene la riga Stato: Arresto anomalo, è necessario eseguire il recupero manuale del database prima di rimuovere i file di registro. Per eseguire l'operazione, procedere come segue:

    1. In Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sul gruppo di archiviazione privo di file di registro delle transazioni e scegliere Proprietà.

    2. Fare clic sulla scheda Generale e prendere nota dei percorsi dei registri delle transazioni nella casella Posizione registro transazioni.

    3. Prendere nota del percorso del file di punto di arresto nella casella Posizione percorso di sistema.

    4. Al prompt dei comandi, modificare la directory impostando la cartella bin di Exchange Server.

    5. Digitare il comando indicato di seguito e premere INVIO: Eseutil /r Nome base a 3 caratteri del file di registro /lDirectory:\Percorso file di registro /sDirectory:\Percorso del file di punto di arresto.

      Nota:
      Non digitare spazi tra l'opzione e i percorsi di directory. Se si commette un errore nello scrivere i percorsi elencati nel comando, il ripristino non verrà eseguito correttamente. Per evitare il problema, è possibile copiare il file di punto di arresto nella cartella del file di registro delle transazioni. Al prompt dei comandi che è stato impostato sulla directory del file di registro, eseguire il comando Eseutil /r Nome base a 3 caratteri del file di registro. Poiché le opzioni /l e /s vengono impostate sulla directory corrente, non è necessario fornire i percorsi dei file di registro né i percorsi dei file di punto di arresto.
    6. Al termine del ripristino, verificare che tutti i file di database siano nello stato di chiusura normale prima di spostare i file di registro delle transazioni e il file di punto di arresto. Se i file di registro vengono spostati quando un database è nello stato di arresto anomalo, non sarà possibile riavviare il database. Se non si possono ripristinare tutti i database nello stato di chiusura normale, contattare il Servizio Supporto Tecnico Clienti Microsoft per ulteriori informazioni.

  5. In Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sul gruppo di archiviazione privo di file di registro delle transazioni e scegliere Proprietà.

  6. Fare clic sulla scheda Generale e prendere nota dei percorsi dei registri delle transazioni nella casella Posizione registro transazioni.

  7. Prendere nota del percorso del file di punto di arresto nella casella Posizione percorso di sistema.

  8. Spostare in un altro percorso i file di registro delle transazioni e il file di punto di arresto. I file di registro hanno l'estensione del nome di file LOG e i file di punto di arresto hanno l'estensione del nome di file CHK.

  9. In Gestore di sistema di Exchange fare clic con il pulsante destro del mouse sul primo archivio disinstallato nel gruppo di archiviazione, quindi scegliere Installa archivio.

  10. Ripetere questo passaggio per ogni archivio nel gruppo di archiviazione. La sequenza del file di registro adesso è stata reimpostata sul gruppo di archiviazione.

  11. Eseguire un backup completo di tutti i database nel gruppo di archiviazione.

Per ulteriori informazioni sui Service Pack per Exchange Server, consultare il sito Web di Exchange Server all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21573.


La dimensione del blocco più grande di VM è insufficiente
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeIS_MSExchangeIS per determinare il valore della chiave VMLargestBlockSize. La chiave VMLargestBlockSize rappresenta la dimensione (in byte) del blocco più grande di memoria virtuale disponibile.

Inoltre, Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer rileva che il valore di VMLargestBlockSize è superiore a 50000000 ma inferiore a 150000000 in un computer Exchange Server con più di 20 cassette postali, verrà visualizzato un avviso.

Tra l'altro, Exchange Server utilizza la memoria virtuale per archiviare messaggi quando vengono convertiti dal formato MIME a MAPI e viceversa, e come un buffer durante il salvataggio dei messaggi dal registro delle transazioni all'archivio. Spesso per il completamento veloce e affidabile di queste operazioni sono richiesti blocchi di memoria virtuale contigui e di grandi dimensioni. Se è stato visualizzato questo avviso, la memoria virtuale nel computer Exchange è stata ridotta a meno di 150 MB di spazio contiguo. Questa operazione è conosciuta come frammentazione della memoria virtuale.

Se la memoria virtuale si riduce troppo, è possibile che vengano visualizzati messaggi di errore nel registro eventi (ID evento 9582), ovvero errori della memoria virtuale. Se la memoria virtuale è sufficientemente ridotta, verrà visualizzato l'ID evento 12800, che indica i messaggi che non vengono recapitati perché non è disponibile una quantità sufficiente di memoria per l'elaborazione dei messaggi.

Per risolvere il pronblema, seguire le indicazioni che seguono nell'ordine in cui vengono presentate.

Nell'output di Exchange Server Analyzer ricercare l'errore che segnala che è stata raggiunta la dimensione massima della cache ESE.

Se l'errore che segnala che è stata raggiunta la dimensione massima della cache ESE viene restituito nello stesso computer Exchange in cui viene restituito l'avviso di frammentazione della memoria virtuale, seguire le indicazioni fornite nell'articolo Il valore massimo della cache ESE è troppo elevato.

La visualizzazione di entrambi i messaggi indica con molta probabilità che i problemi di frammentazione della memoria virtuale sono il risultato dell'aumento manuale della dimensione della cache ESE.

Riavviare il servizio Archivio informazioni di Exchange

Nella descrizione di questo messaggio di avviso fornita da Exchange Server Analyzer è specificato il numero di giorni in cui il servizio Archivio informazioni di Microsoft Exchange è stato in esecuzione. Se il numero di giorni specificato è superiore a 30, riavviare il servizio.

Per riavviare il servizio Archivio informazioni di Microsoft Exchange

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio Archivio informazioni di Microsoft Exchange e scegliere Riavvia.

Prendere in esame i limiti di dimensione del messaggio

Se molti utenti inviano messaggi di grandi dimensioni (superiori a 30 MB), la memoria virtuale si può frammentare più presto rispetto al caso in cui un numero elevato di utenti invia messaggi di dimensioni contenute. Come precedentemente detto, la memoria virtuale viene utilizzata come buffer quando durante il processo di archiviazione vengono spostati dati dai file di registro e salvati nell'archivio. Se i dati spostati sono spesso di grandi dimensioni, vengono consumati velocemente grandi blocchi contigui di memoria virtuale.

Se vengono inviati spesso e internamente dati di grandi dimensioni tramite posta elettronica, è possibile impostare directory condivise in file server dove gli utenti potranno inviare gruppi di dati di grandi dimensioni.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 30 MB. Tuttavia, qualora fosse necessario un limite più elevato per messaggi con allegati di grandi dimensioni da inviare tramite l'organizzazione di Exchange, è possibile incrementare il limite di dimensione per i messaggi in uscita oltre i 30 MB. Oltre alla frammentazione della memoria virtuale, l'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare una maggiore vulnerabilità del sistema in caso di attacchi dannosi. Non è consigliabile consentire un limite di dimensione dei messaggi superiore a 30 MB.

Per impostare il limite di dimensione dei messaggi

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e scegliere Proprietà.

  2. Nella scheda Valori predefiniti della finestra di dialogo Proprietà di Recapito messaggi selezionare l'opzione Dimensione messaggi in uscita e specificare il limite di dimensione desiderato.

Verificare che il software antivirus sia aggiornato

Talvolta il software antivirus non aggiornato eseguito in modalità VSAPI (Exchange Virus Scanning API) provocherà una frammentazione della memoria virtuale. Se il software antivirus viene eseguito in modalità VSAPI, rivolgersi al produttore del software e accertarsi di utilizzare l'ultima versione del software e dei driver.

Spostare le cassette postali in un altro server di Exchange

Se si sono eseguite tutte le procedure ma Exchange Server Analyzer visualizza ancora questo avviso, è necessario spostare le cassette postali per rimuoverle dal server interessato e ridurne in tal modo il carico. Il server contiene un numero troppo elevato di cassette postali.

Per spostare le cassette postali in Exchange 2000 Server ed Exchange Server 2003

  1. In Utenti e computer di Active Directory selezionare l'utente o gli utenti proprietari delle cassette postali che si desidera spostare.

  2. Fare clic con il pulsante destro del mouse sull'elenco utente selezionato nel passaggio precedente e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange fare clic su Sposta cassetta postale e poi su Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.

Per spostare le cassette postali in Exchange Server 2003

  1. In Gestore di sistema di Exchange espandere Server, il server dal quale si desidera sposare le cassette postali, il Gruppo di archiviazione da cui si desidera spostare le cassette postali, la struttura Archivio cassette postali contenente le cassette postali che si desidera spostare e fare clic su Cassette postali.

  2. Nel riquadro dettagli fare clic con il pulsante destro del mouse sull'utente o sugli utenti proprietari delle cassette postali che si desidera spostare e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange fare clic su Sposta cassetta postale e poi su Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.

Per ulteriori informazioni sulla risoluzione di problemi relativi alla frammentazione della memoria virtuale, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 838233, "Il computer può essere rallentato o interrompere la risposta e registrare più volte gli ID evento 9582 e 1160 in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233.

Per ulteriori informazioni sull'impostazione dei limiti di dimensione dei messaggi, consultare l'articolo 322679 della Microsoft Knowledge Base "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

Per ulteriori informazioni sullo spostamento delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328810, "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810.

  • 821829, "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829.


La dimensione del blocco più grande di VM sta raggiungendo il punto critico
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_MSExchangeIS_MSExchangeIS per determinare il valore della chiave VMLargestBlockSize. La chiave VMLargestBlockSize rappresenta la dimensione (in byte) del blocco più grande di memoria virtuale disponibile.

Inoltre, Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer rileva che il valore di VMLargestBlockSize è superiore a 0 ma inferiore a 50000001 in un computer Exchange Server con più di 20 cassette postali, verrà visualizzato un messaggio di errore.

Tra l'altro, il server di Exchange utilizza la memoria virtuale per archiviare messaggi quando vengono convertiti dal formato MIME a MAPI e viceversa, e come un buffer durante il salvataggio dei messaggi dal registro delle transazioni all'archivio. Spesso per il completamento veloce e affidabile di queste operazioni sono richiesti blocchi di memoria virtuale contigui e di grandi dimensioni. Se è stato visualizzato questo messaggio di errore, la memoria virtuale nel computer Exchange è stata ridotta a meno di 50 MB di spazio contiguo. Questa operazione è conosciuta come frammentazione della memoria virtuale. Un server cassette postali di Exchange in esecuzione con meno di 50 MB di spazio contiguo di memoria virtuale rappresenta un errore irreversibile.

Se la memoria virtuale si riduce troppo, è possibile che vengano visualizzati avvisi di errore nel registro eventi (ID evento 9582), ovvero errori della memoria virtuale. Se la memoria virtuale è sufficientemente ridotta, verrà visualizzato l'ID evento 12800, che indica i messaggi che non vengono recapitati perché non è disponibile una quantità sufficiente di memoria per l'elaborazione dei messaggi.

Per correggere questo errore, seguire le indicazioni che seguono nell'ordine in cui vengono presentate.

Nell'output di Exchange Server Analyzer ricercare l'errore che segnala che è stata raggiunta la dimensione massima della cache ESE.

Se l'errore che segnala che è stata raggiunta la dimensione massima della cache ESE viene restituito nello stesso computer Exchange in cui viene restituito l'avviso di frammentazione della memoria virtuale, seguire le indicazioni fornite nell'articolo Il valore massimo della cache ESE è troppo elevato.

La visualizzazione di entrambi gli avvisi indica con molta probabilità che i problemi di frammentazione della memoria virtuale sono il risultato dell'aumento manuale della dimensione della cache ESE.

Riavviare il servizio Archivio informazioni di Exchange

Nella descrizione di questo avviso fornita da Exchange Server Analyzer è specificato il numero di giorni in cui il servizio Archivio informazioni di Microsoft Exchange è stato in esecuzione. Se il numero di giorni specificato è superiore a 30, riavviare il servizio.

Per riavviare il servizio Archivio informazioni di Exchange

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio Archivio informazioni di Microsoft Exchange e scegliere Riavvia.

Prendere in esame i limiti di dimensione del messaggio

Se molti utenti inviano messaggi di grandi dimensioni (superiori a 30 MB), la memoria virtuale si può frammentare più presto rispetto al caso in cui un numero elevato di utenti invia messaggi di dimensioni contenute. Come precedentemente detto, la memoria virtuale viene utilizzata come buffer quando durante il processo di archiviazione vengono spostati dati dai file di registro e salvati nell'archivio. Se i dati spostati sono spesso di grandi dimensioni, vengono consumati velocemente grandi blocchi contigui di memoria virtuale.

Se vengono inviati spesso e internamente dati di grandi dimensioni tramite posta elettronica, è possibile impostare directory condivise in file server dove gli utenti potranno inviare gruppi di dati di grandi dimensioni.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 30 MB. Tuttavia, qualora fosse necessario un limite più elevato per messaggi con allegati di grandi dimensioni da inviare tramite l'organizzazione di Exchange, è possibile incrementare il limite di dimensione per i messaggi in uscita oltre i 30 MB. Oltre alla frammentazione della memoria virtuale, l'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare una maggiore vulnerabilità del sistema in caso di attacchi dannosi. Pertanto, non è consigliabile consentire un limite massimo per la dimensione dei messaggi superiore a 30 MB.

Per impostare il limite di dimensione dei messaggi

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e scegliere Proprietà.

  2. Nella scheda Valori predefiniti della finestra di dialogo Proprietà di Recapito messaggi selezionare l'opzione Dimensione messaggi in uscita e specificare il limite di dimensione desiderato.

Verificare che il software antivirus sia aggiornato

In alcuni casi il software antivirus non aggiornato eseguito in modalità VSAPI (Exchange Virus Scanning API) provocherà una frammentazione della memoria virtuale. Se il software antivirus viene eseguito in modalità VSAPI, rivolgersi al produttore del software e accertarsi di utilizzare l'ultima versione del programma e dei driver.

Spostare le cassette postali in un altro server di Exchange

Se si sono eseguite tutte le procedure indicate sopra e Exchange Server Analyzer visualizza ancora l'errore o l'avviso relativo al problema (quando sono rimasti meno di 150 MB di spazio contiguo di memoria virtuale), è necessario spostare le cassette postali rimuovendole dal server interessato per ridurne il carico. Il server contiene un numero troppo elevato di cassette postali.

Per spostare le cassette postali in Exchange 2000 Server ed Exchange Server 2003

  1. In Utenti e computer di Active Directory selezionare l'utente o gli utenti proprietari delle cassette postali che si desidera spostare.

  2. Fare clic con il pulsante destro del mouse sull'elenco utente selezionato nel passaggio precedente e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange fare clic su Sposta cassetta postale e poi su Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.

Per spostare le cassette postali in Exchange Server 2003

  1. In Gestore di sistema di Exchange espandere Server, il server dal quale si desidera sposare le cassette postali, il Gruppo di archiviazione da cui si desidera spostare le cassette postali, la struttura Archivio cassette postali contenente le cassette postali che si desidera spostare e fare clic su Cassette postali.

  2. Nel riquadro dettagli fare clic con il pulsante destro del mouse sull'utente o sugli utenti proprietari delle cassette postali che si desidera spostare e scegliere Operazioni di Exchange.

  3. Nella pagina Operazioni disponibili di Operazione guidata di Exchange fare clic su Sposta cassetta postale e poi su Avanti.

  4. Leggere attentamente e attenersi alle istruzioni per eseguire i passaggi rimanenti della procedura guidata.

Per ulteriori informazioni sulla risoluzione di problemi relativi alla frammentazione della memoria virtuale, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 325044, "HOW TO: Risoluzione dei problemi di frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325044.

  • 838233, "Il computer può essere rallentato o interrompere la risposta e registrare più volte gli ID evento 9582 e 1160 in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=838233.

Per ulteriori informazioni sull'impostazione dei limiti di dimensione dei messaggi, consultare l'articolo 322679 della Microsoft Knowledge Base "Impostazione dei limiti di dimensione dei messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

Per ulteriori informazioni sullo spostamento delle cassette postali, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328810, "Spostamento delle cassette postali tra i server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328810.

  • 821829, "Spostamento delle cassette postali in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821829.


VirtualReserveSize is non-default
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se l'allocazione di memoria iniziale relativa al componente ExIPC (Exchange Interprocess Communication) corrisponde al valore predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EXIPC\Parameters\VirtualReserveSize

Se Exchange Server Analyzer rileva che la chiave VirtualReserveSize è presente e configurata con un valore superiore a 0, verrà visualizzato un messaggio di configurazione non predefinita.

ExIPC è un componente di accodamento che consente ai servizi Inetinfo.exe (Internet Information Services) e Store.exe (Archivio informazioni di Microsoft Exchange) di spostare rapidamente i dati. In genere, l'allocazione di memoria iniziale predefinita per ExIPC è sufficiente. Per impostazione predefinita, la chiave VirtualReserveSize non è presente. Può essere aggiunta e configurata solo su indicazione dei servizi MCS (Microsoft Consulting Services) o del Servizio Supporto Tecnico Clienti Microsoft.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\EXIPC\Parameters

  3. Eliminare la chiave VirtualReserveSize.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange e il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni su ExIPC, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821879, "Definizioni dei principali componenti di trasporto in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821879.

  • 260995, "XCON: Definizioni dei principali componenti di trasporto in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=260995.


L'intervallo di eventi della memoria virtuale è stato sostituito
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la soglia per la registrazione di un evento relativo alla frammentazione della memoria virtuale è stata sostituita manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\ VM Info Update Interval

Se Exchange Server Analyzer rileva che il valore VM Info Update Interval del Registro di sistema è presente ma non uguale a 3600, verrà visualizzato un messaggio di configurazione non predefinita.

Nei sistemi Microsoft Windows® a 32 bit sono disponibili due tipi di memoria: la memoria fisica (la quantità di memoria effettiva installata nel sistema) e la memoria dello spazio di indirizzi virtuali (uno spazio di memoria virtuale di 4 gigabyte). Indipendentemente dalla quantità di memoria fisica installata nel sistema, la dimensione totale dello spazio di indirizzi virtuali è sempre la stessa: 4 GB. Sebbene la situazione non sia la stessa per tutte le applicazioni a 32 bit, in Exchange Server lo spazio di indirizzi virtuali equivale alla memoria virtuale, ovvero i due termini vengono utilizzati in modo interscambiabile.

Durante l'esecuzione delle normali operazioni, l'Archivio informazioni di Exchange procederà ad allocare, utilizzare e deallocare la memoria virtuale più volte. Se la memoria virtuale viene allocata, utilizzata e deallocata frequentemente è possibile che si verifichi una frammentazione della memoria stessa. La frammentazione della memoria virtuale è analoga alla frammentazione del file system che può verificarsi nel tempo. Dopo poco i segmenti di memoria virtuale allocati non sono più contigui e le prestazioni cominciano a risentirne. Nel caso di un file system, è disponibile un'applicazione che consente di eseguirne la deframmentazione e, nella maggior parte dei casi, questa operazione può essere eseguita mentre il sistema è in linea e in uso. Nel caso della frammentazione della memoria virtuale, non è disponibile uno strumento di deframmentazione e, per risolvere il problema, è necessario arrestare e riavviare il servizio Archivio informazioni di Microsoft Exchange oppure riavviare il sistema.

Per impostazione predefinita, il servizio Archivio informazioni di Microsoft Exchange controlla la memoria virtuale disponibile ogni ora (ad esempio, ogni 3.600 secondi). Il valore del Registro di sistema VM Info Update Interval è una configurazione che consente a un amministratore di ignorare l'intervallo predefinito di 3.600 secondi. Se il livello predefinito viene ignorato, si consiglia di non impostare un valore inferiore ai 5 minuti (300 secondi).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Nel riquadro destro eliminare il valore VM Info Update Interval.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla frammentazione della memoria virtuale in Exchange Server 2003 ed Exchange 2000 Server, consultare l'articolo 325044 della Microsoft Knowledge Base: "HOW TO: Risoluzione del problema della frammentazione della memoria virtuale in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=325044.


Cache write-back non abilitata
Articoli su Microsoft Exchange Server Analyzer > Archiviazione >

Ultima modifica: 2006-08-18

Lo strumento Microsoft® Exchange Server Analyzer ha determinato che la cache write-back per il controller di array di dischi non è stata impostata correttamente per le unità che ospitano i registri delle transazioni.

È consigliabile abilitare la cache write-back al 100% sul controller di array per tutte le unità che ospitano registri delle transazioni. È raro che vengano letti dati dai registri delle transazioni. Più è elevata la velocità di scrittura in un'unità di registro delle transazioni, migliori saranno le prestazioni di un server che esegue Exchange Server.

Per risolvere il problema

  • Abilitare la cache write-back.

Per ulteriori informazioni sulla modalità di configurazione dei dischi rigidi dei server di Exchange, consultare l'articolo 188589 della Microsoft Knowledge Base, "Database di Exchange e cache di dischi rigidi e controller" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=188589.


Software di terze parti
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente al software di terze parti. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere avvisi, messaggi di errore e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi a software di terze parti.


Le esclusioni di cartelle dalla ricerca di virus non sono state configurate
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se in Exchange Server è stato installato Symantec AntiVirus Corporate Edition (Symantec AV) e se RealTime Protection (RTP) è abilitato:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Storages\Filesystem\RealTimeScan

Se Exchange Server Analyzer rileva che il valore HaveExceptionDirs del Registro di sistema è impostato su 0, verrà visualizzato un messaggio di errore. Un valore HaveExceptionDirs del Registro di sistema impostato su 0 indica che le esclusioni di cartelle sono disabilitate.

Le esclusioni di cartelle impediscono l'analisi di cartelle specifiche durante la ricerca di virus in tempo reale. Se in Exchange Server non sono state abilitate le esclusioni di cartelle, è possibile che si verifichino i seguenti problemi:

  • Symantec AV RTP potrebbe generare rapporti con falsi positivi per determinati file puliti ai quali si accede durante le normali attività dei programmi.

  • Symantec AV RTP potrebbe fornire rapporti errati su file infetti contenuti in un software la cui esecuzione su Exchange Server è già stata autorizzata dai criteri di protezione aziendali.

  • Symantec AV RTP potrebbe eseguire l'analisi della struttura di directory di Exchange Server e provocare rilevamenti di virus non accurati, comportamenti inattesi sul server di Exchange oppure potrebbe danneggiare i database di Exchange Server.

Importante:
I programmi di analisi basati su file non devono mai essere eseguiti su database, registri, file temporanei, file di sistema di IIS (Internet Information Services) o sull'unità M del file system installabile (IFS) di Exchange Sever. Configurare i software antivirus in modo da evitare l'analisi delle cartelle che contengono questi file.

È possibile eseguire il software antivirus basato su file sul sistema operativo del computer Exchange Server e sui file di programma di Exchange Server (contenuti nella cartella Exchsrvr\Bin). Tuttavia, non eseguire il software antivirus basato su file per i seguenti file e cartelle:

  • I database di Exchange Server (file con estensione MDB e STM) e i file di registro delle transazioni (file con estensione LOG, percorso predefinito: \Exchsrvr\MDBData).

  • I file con estensione MTA di Exchange Server (percorso predefinito: \Exchsrvr\Mtadata).

  • I file di registro di verifica messaggi di Exchange Server (percorso predefinito: \Exchsrvr\Server_Name.log).

  • Le cartelle dei server virtuali (percorso predefinito: \Exchsrvr\Mailroot).

  • I file di SRS (Servizio di replica siti, percorso predefinito: \Exchsrvr\Srsdata).

  • I file di sistema di IIS (Internet Information Service, percorso predefinito: \%SystemRoot%\System32\Inetsrv).

  • File Internet Mail Connector (percorso predefinito: \Exchsrvr\IMCData).

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione dei messaggi. Per impostazione predefinita, questa cartella di lavoro si trova nel percorso \Exchsrvr\MDBData.

  • Una cartella temporanea utilizzata assieme alle utilità di manutenzione non in linea, come Eseutil.exe. Per impostazione predefinita, questa cartella è la posizione dalla quale si eseguono i file con estensione EXE, ma è possibile configurare un percorso diverso quando si esegue l'utilità.

È possibile eseguire l'analisi basata su file nelle seguenti cartelle:

  • Exchsrvr\Address.

  • Exchsrvr\Bin.

  • Exchsrvr\Exchweb.

  • Exchsrvr\Res.

  • Exchsrvr\Schema.

Per ulteriori informazioni sulla configurazione delle esclusioni dall'analisi RealTime di Symantec AntiVirus Corporate Edition, consultare il sito Web di Symantec all'indirizzo http://www.symantec.com.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sulle modalità di protezione dell'ambiente Exchange Server da virus e worm contenuti nei messaggi di posta elettronica, consultare la pagina Web Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226.


Antigen sta analizzando i messaggi di replica delle cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-03-13

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se in ciascun server Exchange è presente un archivio cartelle pubbliche. Se Exchange Server Analyzer rileva che l'oggetto InformationStore appartiene alla classe msExchPublicMDB, il server contiene un archivio delle cartelle pubbliche.

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per ANTIGENVSAPI.DLL. Un valore di 1517 o maggiore della chiave Version per ANTIGENVSAPI.DLL indica che nel server Exchange è installato Sybari Antigen per Microsoft Exchange versione 8.0 SR3 o successiva.

Infine, Exchange Server Analyzer esegue una query nel seguente ramo del Registro di sistema per determinare se la chiave DoNotScanIPMReplicationMessages è presente e non ha un valore maggiore di 0:

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\DoNotScanIPMReplicationMessages

Il valore della chiave DoNotScanIPMReplicationMessages determina se la versione di Sybari Antigen installata ricercherà e, possibilmente, rimuoverà i messaggi di replica delle cartelle pubbliche di Exchange Server. Un valore inferiore a 1 per la chiave DoNotScanIPMReplicationMessages indica che Antigen ricercherà la presenza di virus nei file winmail.dat. In Exchange Server vengono utilizzati i file Winmail.dat per vari scopi, tra i quali facilitare la replica delle cartelle pubbliche tra i server. Se uno dei file winmail.dat viene modificato, il processo di replica delle cartelle pubbliche non riesce.

Se si verificano le seguenti condizioni, verrà visualizzato un messaggio di errore:

  • Il server Exchange ospita uno o più archivi di cartelle pubbliche

  • Sybari Antigen build 1517 o successiva è installatA nel server

  • La chiave DoNotScanIPMReplicationMessages non è presente oppure è presente ma il valore non è maggiore di 0.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Sybari Software\Antigen for Exchange

  3. Se la sottochiave DoNotScanIPMReplicationMessages esiste già nel riquadro destro, fare doppio clic su di essa e impostare il valore su 1.

  4. Se la sottochiave DoNotScanIPMReplicationMessages non esiste ancora, fare clic con il pulsante destro del mouse nel riquadro destro e crearla come nuovo valore DWORD.

  5. Configurare il valore DoNotScanIPMReplicationMessages con un'impostazione di 1.

    Nota:
    Se un virus viene replicato tramite la replica delle cartelle pubbliche, anche se viene abilitata la nuova chiave del Registro di sistema il virus verrà comunque rilevato nell'analisi in tempo reale.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni sulla procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'utilizzo del software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841 "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166 "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni Antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.


eTrust di CA: i file con estensione EML/LOG/EDB/STM/DAT non sono nell'elenco di esclusione file in tempo reale
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per richiedere l'elenco delle estensioni di file che sono state escluse dalla ricerca di virus in tempo reale a livello dei file con eTrust Antivirus di Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeExtList

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeExtList

Se Exchange Server Analyzer rileva che il valore di szExcludeExtList non include le estensioni di file che corrispondono al tipo di file di dati di Exchange (eml, log, edb, stm o dat), verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello dei file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server, procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product Version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano software di analisi a livello dei file in un computer Exchange Server:

  • I software di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • È possibile che si verifichino ulteriori problemi se si esegue l'analisi dell'unità rappresentata dal file system installabile (IFS) di Exchange, in genere l'unità M, con il software di analisi a livello dei file.

Indipendentemente dal programma antivirus a livello dei file utilizzato, è sempre opportuno escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione dei messaggi. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file EXE viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello dei file.

  2. Per informazioni aggiornate sull'utilizzo di eTrust Antivirus in un computer Exchange Server, consultare il sito Web di CA eTrust Antivirus all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156 (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, pertanto potrebbe non essere possibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).

Per ulteriori informazioni su eventuali problemi nell'analisi dell'unità IFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 298924, "XADM: Problemi causati dal backup o dall'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Messaggio di errore C1041737 quando si installano i database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: l'unità di dati di Exchange non è stata esclusa dall'analisi manuale dei processi
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per ottenere l'elenco di directory escluse dalla ricerca di virus manuale a livello di file in eTrust Antivirus di Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer legge inoltre il valore dell'attributo MsExchESEParamSystemPath nel servizio directory di Active Directory® che è un attributo del gruppo di archiviazione corrispondente alla posizione dei file di dati di sistema di Exchange.

Se Exchange Server Analyzer rileva che il valore di szExcludeDirs non include il percorso corrispondente alla posizione dei file di dati di sistema di Exchange, verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello di file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano programmi di analisi a livello di file in un computer Exchange Server:

  • I software di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • È possibile che si verifichino ulteriori problemi se si esegue l'analisi dell'unità rappresentata dal file system installabile (IFS) di Exchange, in genere l'unità M, con il programma di analisi a livello di file.

Indipendentemente dal programma antivirus a livello di file utilizzato, è opportuno sempre escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione del messaggio. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file exe viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello di file.

  2. Per informazioni aggiornate sull'utilizzo di eTrust Antivirus in un computer Exchange Server, consultare il sito Web di CA eTrust Antivirus all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156 (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).

Per ulteriori informazioni sui problemi che possono verificarsi se si esegue l'analisi dell'unità IFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 298924, "XADM: Non eseguire il backup o l'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Visualizzazione del messaggio di errore C1041737 durante l'installazione dei database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: l'unità di dati di Exchange non è stata esclusa dall'analisi in tempo reale
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per richiedere l'elenco delle directory che sono state escluse dalla ricerca di virus in tempo reale a livello di file con eTrust Antivirus di Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer esegue inoltre query nel servizio directory di Active Directory® per determinare il valore dell'attributo MsExchESEParamSystemPath di ciascun gruppo di archiviazione. L'attributo rappresenta il percorso dei file di dati di Exchange.

Se Exchange Server Analyzer rileva che il valore di szExcludeDirs non include il percorso corrispondente alla posizione dei file di dati di sistema di Exchange, verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello di file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano programmi di analisi a livello di file in un computer Exchange Server:

  • I software di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • È possibile che si verifichino ulteriori problemi se si esegue l'analisi dell'unità rappresentata dal file system installabile (IFS) di Exchange, in genere l'unità M, con il programma di analisi a livello di file.

Indipendentemente dal programma antivirus a livello di file utilizzato, è opportuno sempre escludere i seguenti file e le seguenti cartelle dalla ricerca dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione del messaggio. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file exe viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello di file.

  2. Per informazioni aggiornate sull'utilizzo di eTrust Antivirus in un computer Exchange Server, consultare il sito Web di CA eTrust Antivirus all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156 (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).

Per ulteriori informazioni su eventuali problemi nell'analisi dell'unità IFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 298924, "XADM: Problemi causati dal backup o dall'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Messaggio di errore C1041737 quando si installano i database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: il percorso IFS di Exchange non è stato escluso dall'analisi manuale dei processi
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per ottenere l'elenco di directory escluse dalla ricerca di virus manuale a livello di file in eTrust Antivirus di Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer legge, inoltre, la seguente voce del Registro di sistema per ottenere la lettera che rappresenta l'unità File system installabile (IFS, Installable File System) di Exchange:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

In Exchange 2000 Server la lettera dell'unità predefinita è M. L'unità IFS viene disattivata per impostazione predefinita in Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore di szExcludeDirs non include il percorso corrispondente all'unità IFS, verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello di file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server, procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano programmi di analisi a livello di file in un computer Exchange Server:

  • I software di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • Se si esegue l'analisi dell'unità rappresentata dall'IFS, in genere l'unità M, con il programma di analisi a livello di file, potranno verificarsi altri problemi.

Indipendentemente dal programma antivirus a livello di file utilizzato, è opportuno sempre escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione del messaggio. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file exe viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello di file.

  2. Per le informazioni più recenti sull'utilizzo di eTrust Antivirus in un computer che esegue Exchange Server, visitare il sito Web relativo a eTrust Antivirus di Computer Associates all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156.

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Informazioni generali su Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226.

Per ulteriori informazioni su eventuali problemi nell'analisi dell'unità IFS, consultare i seguenti articoli della Knowledge Base:

  • 298924, "XADM: Problemi causati dal backup o dall'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Messaggio di errore C1041737 quando si installano i database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: il percorso IFS di Exchange non è stato escluso dall'analisi in tempo reale
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per richiedere l'elenco delle directory che sono state escluse dalla ricerca di virus in tempo reale a livello di file con eTrust Antivirus di Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer legge, inoltre, la seguente voce del Registro di sistema per ottenere la lettera che rappresenta l'unità File system installabile (IFS, Installable File System) di Exchange:

HKLM\System\CurrentControlSet\Services\EXIFS\Parameters\DriveLetter

In Exchange 2000 Server la lettera dell'unità predefinita è M. L'unità IFS viene disattivata per impostazione predefinita in Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore di szExcludeDirs non include il percorso corrispondente all'unità IFS, verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello di file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server, procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano programmi di analisi a livello di file in un computer Exchange Server:

  • I software di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • Se si esegue l'analisi dell'unità rappresentata dall'IFS, in genere l'unità M, con il programma di analisi a livello di file, potranno verificarsi altri problemi.

Indipendentemente dal programma antivirus a livello di file utilizzato, è opportuno sempre escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione del messaggio. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file exe viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello di file.

  2. Per informazioni aggiornate sull'utilizzo di eTrust Antivirus in un computer Exchange Server, consultare il sito Web di CA eTrust Antivirus all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156 (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226.

Per ulteriori informazioni su eventuali problemi nell'analisi dell'unità IFS, consultare i seguenti articoli della Knowledge Base:

  • 298924, "XADM: Problemi causati dal backup o dall'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Messaggio di errore C1041737 quando si installano i database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: l'analisi in tempo reale è configurata per eseguire l'analisi di tutti i file indipendentemente dall'estensione
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per richiedere l'elenco delle estensioni dei nomi di file che sono state escluse dalla ricerca di virus in tempo reale a livello dei file con eTrust Antivirus di Computer Associates:

eTrust Antivirus 6,0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\dwFileFilterType

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\dwFileFilterType

Se Exchange Server Analyzer determina che il valore di dwFileFilterType è configurato per eseguire la ricerca in tutti i file, indipendentemente dall'estensione del nome di file, verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello dei file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server, procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product Version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano software di analisi a livello dei file in un computer Exchange Server:

  • I programmi di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • È possibile che si verifichino ulteriori problemi se si esegue l'analisi dell'unità rappresentata dal file system installabile (IFS) di Exchange, in genere l'unità M, con il programma di analisi a livello di file.

Indipendentemente dal programma antivirus a livello dei file utilizzato, è sempre opportuno escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione dei messaggi. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file EXE viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file elencati sopra dalla ricerca di virus a livello dei file.

  2. Per informazioni aggiornate sull'utilizzo di eTrust Antivirus in un computer Exchange Server, consultare il sito Web di CA eTrust Antivirus all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156 (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).

Per ulteriori informazioni sui problemi che possono verificarsi se si esegue l'analisi dell'unità IFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 298924, "XADM: Non eseguire il backup o l'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Messaggio di errore C1041737 quando si installano i database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: l'unità dei gruppi di archiviazione non è stata esclusa dall'analisi manuale dei processi
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per ottenere l'elenco di directory escluse dalla ricerca di virus manuale a livello di file in eTrust Antivirus di Computer Associates:

eTrust Antivirus 6.0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Job\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Job\szExcludeDirs

Exchange Server Analyzer legge inoltre il valore dell'attributo MsExchESEParamSystemPath nel servizio directory di Active Directory® che è un attributo del gruppo di archiviazione corrispondente alla posizione dei file di regisitro di sistema di Exchange.

Se Exchange Server Analyzer rileva che il valore di szExcludeDirs non include il percorso corrispondente alla posizione dei file di registro di sistema di Exchange, verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello di file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server, procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano programmi di analisi a livello di file in un computer Exchange Server:

  • I software di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • È possibile che si verifichino ulteriori problemi se si esegue l'analisi dell'unità rappresentata dal file system installabile (IFS) di Exchange, in genere l'unità M, con il programma di analisi a livello di file.

Indipendentemente dal programma antivirus a livello di file utilizzato, è opportuno sempre escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione del messaggio. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file exe viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello di file.

  2. Per le informazioni più recenti sull'utilizzo di eTrust Antivirus in un computer che esegue Exchange Server, visitare il sito Web relativo a eTrust Antivirus di Computer Associates all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156.

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

  • Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).

Per ulteriori informazioni sui problemi che possono verificarsi se si esegue l'analisi dell'unità IFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 298924, "XADM: Non eseguire il backup o l'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Visualizzazione del messaggio di errore C1041737 durante l'installazione dei database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: l'unità del gruppo di archiviazione non è stata esclusa dall'analisi in tempo reale
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per richiedere l'elenco delle directory che sono state escluse dalla ricerca di virus in tempo reale a livello di file con eTrust Antivirus di Computer Associates:

eTrust Antivirus 6,0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\Realtime\szExcludeDirs

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeDirs

Exchange Server Analyzer esegue inoltre una query per l'attributo MsExchESEParamSystemPath nel servizio directory di Active Directory® che è un attributo del gruppo di archiviazione corrispondente alla posizione dei file di dati di sistema di Exchange.

Se Exchange Server Analyzer rileva che il valore di szExcludeDirs non include il percorso corrispondente alla posizione dei file di dati di sistema di Exchange, verrà visualizzato un avviso.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello dei file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product Version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano programmi di analisi a livello dei file in un computer Exchange Server:

  • I programmi di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • È possibile che si verifichino ulteriori problemi se si esegue l'analisi dell'unità rappresentata dal file system installabile (IFS) di Exchange, in genere l'unità M, con il software di analisi a livello dei file.

Indipendentemente dal programma antivirus a livello dei file utilizzato, è sempre opportuno escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione dei messaggi. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file EXE viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello dei file.

  2. Per informazioni aggiornate sull'utilizzo di eTrust Antivirus in un computer Exchange Server, consultare il sito Web di CA eTrust Antivirus all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156 (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).

Per ulteriori informazioni sui problemi che possono verificarsi se si esegue l'analisi dell'unità IFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 298924, "XADM: Non eseguire il backup o l'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Visualizzazione del messaggio di errore C1041737 durante l'installazione dei database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


eTrust di CA: il processo di Exchange non è stato escluso dall'analisi in tempo reale
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per richiedere l'elenco dei processi che sono stati esclusi dalla ricerca di virus in tempo reale a livello dei file con eTrust Antivirus di Computer Associates:

eTrust Antivirus 6,0

HKEY_LOCAL_MACHINE\Software\ComputerAssociates\InoculateIT\6.0\RealTime\szExcludeProcessNames

eTrust Antivirus 7.0

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\Realtime\szExcludeProcessNames

Se Exchange Server Analyzer rileva che il valore di szExcludeProcessNames non include STORE.EXE, EMSMTA.EXE e MAD.EXE, verrà visualizzato un avviso.

È consigliabile non eseguire l'analisi del processo dell'Archivio informazioni di Microsoft Exchange (Store.exe), del processo MTA di Exchange (Emsmta.exe) o del processo di Supervisore sistema (Mad.exe) con un software di analisi antivirus a livello di file mentre vengono eseguiti tali processi.

eTrust Antivirus è un programma antivirus che esegue la ricerca a livello dei file. Per stabilire la versione di eTrust Antivirus installata nel computer Exchange Server, procedere come segue:

  1. Selezionare Start | Programmi | eTrust Antivirus e fare clic su eTrust Antivirus per avviare l'applicazione.

  2. Dal menu dell'applicazione eTrust Antivirus scegliere Help, quindi About eTrust Antivirus.

  3. Esaminare il campo Product Version per determinare la versione di eTrust Antivirus.

I seguenti problemi possono verificarsi quando si utilizzano programmi di analisi a livello dei file in un computer Exchange Server:

  • I programmi di analisi a livello dei file eseguono l'analisi di un file quando esso viene utilizzato o a intervalli pianificati e possono bloccare o mettere in quarantena un file di registro o un file di database di Exchange mentre Exchange tenta di utilizzare il file. Ciò può provocare un errore irreversibile in Exchange Server o generare errori del database.

  • Se si esegue l'analisi dell'unità rappresentata dall'IFS, in genere l'unità M, con il software di analisi a livello di file, potranno verificarsi altri problemi.

Indipendentemente dal programma antivirus a livello dei file utilizzato, è sempre opportuno escludere i seguenti file e le seguenti cartelle dall'analisi dei file:

  • File con estensione EML, EDB, STM, LOG, DAT e CHK.

  • L'unità di Exchange Server rappresentata da un'unità IFS. Per impostazione predefinita, l'unità sarà contrassegnata dalla lettera M.

  • Database e file di registro di Exchange. Per impostazione predefinita, si trovano nella cartella Exchsrvr\Mdbdata.

  • File MTA di Exchange nella cartella Exchsrvr\Mtadata.

  • File di registro aggiuntivi, ad esempio il file Exchsrvr\nome_server.log.

  • La cartella Exchsrvr\Mailroot del server virtuale.

  • La cartella di lavoro utilizzata per archiviare file temporanei di flusso utilizzati per la conversione dei messaggi. Per impostazione predefinita, il percorso della cartella è \Exchsrvr\MDBData, ma è possibile configurare un percorso diverso.

  • La cartella temporanea utilizzata con strumenti di manutenzione non in linea come Eseutil.exe. Per impostazione predefinita, il file EXE viene eseguito da questa cartella, ma è possibile configurare una posizione diversa quando si esegue lo strumento.

  • File SRS (Site Replication Service) nella cartella Exchsrvr\Srsdata.

  • File di sistema di Microsoft Internet Information Service (IIS) nella cartella %SystemRoot%\System32\Inetsrv.

  • File di lavoro IIS nella cartella %SystemRoot%\IIS Temporary Compressed Files.

Per risolvere il problema

  1. Utilizzare l'interfaccia utente di eTrust Antivirus per escludere le cartelle e i file sopra elencati dalla ricerca di virus a livello dei file.

  2. Per le informazioni più recenti sull'utilizzo di eTrust Antivirus in un computer che esegue Exchange Server, visitare il sito Web relativo a eTrust Antivirus di Computer Associates all'indirizzo http://www3.ca.com/Solutions/Product.asp?ID=156.

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei programmi antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).

Per ulteriori informazioni sui problemi che possono verificarsi se si esegue l'analisi dell'unità IFS, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 298924, "XADM: Non eseguire il backup o l'analisi dell'unità M di Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298924.

  • 300608, "XADM: Visualizzazione del messaggio di errore C1041737 durante l'installazione dei database" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=300608.

  • 299046, "XADM: Scomparsa di elementi di calendario dalle cartelle dell'utente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=299046.


Aggiornamento di Client Server Messaging Security for SMB v2.0 disponibile
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema:

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Se il valore di Version è pari a 6.2100, indica che è installato Trend Micro ScanMail Client Server Messaging Security for SMB v2.0

Microsoft® Exchange Server Analyzer, inoltre, esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare la versione di Client Server Messaging Security for SMB installata. Se il numero di build principale è inferiore a 1145, verrà visualizzato un avviso.

L'avviso indica che nel server di Exchange è installato Client Server Messaging Security for SMB v2.0 e che è disponibile l'aggiornamento del software. L'aggiornamento consigliato è Client Server Messaging Security for SMB v2.0 Patch 2 for Messaging Component. Si consiglia di installare questo aggiornamento per migliorare le prestazioni e l'affidabilità generali del server.

Per risolvere il problema

  1. Visitare la sezione aggiornamenti del sito Web Trend Micro all'indirizzo http://www.trendmicro.com/download/product.asp?productid=39 (informazioni in lingua inglese).

  2. Scaricare e installare Client Server Messaging Security for SMB v2.0 Patch 2 for Messaging Component.
Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni su aggiornamenti di altri prodotti Trend Micro, consultare la sezione aggiornamenti del sito Web Trend Micro all'indirizzo http://www.trendmicro.com/download/.

Per ulteriori informazioni sull'utilizzo del software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni Antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822

Per visualizzare un elenco dei software antivirus di terze parti disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Installazione di HP Command View EVAPerf
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-09

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_SCSIController per determinare il valore della chiave Name. Se il valore della chiave Name equivale a Compaq HSV110CCL, almeno un volume disco sul server viene presentato dalla rete SAN HP EVA.

Exchange Server Analyzer esegue una query anche nella classe WMI Win32_Service per determinare il valore della chiave Started per il servizio HP StorageWorks Command View EVAPerf (EVSPDCS). Il valore False indica che il servizio non è in esecuzione. Il valore True indica che il servizio è in esecuzione.

Se entrambe le seguenti condizioni vengono soddisfatte, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • Almeno un volume disco nel server viene presentato da una rete SAN HP EVA.

  • Il servizio HP StorageWorks Command View EVAPerf (EVSPDCS) non è presente o non è in esecuzione.

HP fornisce gratuitamente un'applicazione di gestione software che pubblica contatori di prestazioni aggiuntivi per le reti SAN HP StorageWork. Gli amministratori possono utilizzare questa applicazione per monitorare le prestazioni dei singoli controller e dischi fisici della rete SAN.

Per eseguire la configurazione ottimale consigliata

  1. Visitare il sito Web HP StorageWorks Command View EVAPerf Software all'indirizzo http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=471498&locale=en_US&taskId=135&prodSeriesId=471497&prodTypeId=12169&swEnvOID=1005, per scaricare l'applicazione HP Command View EVAPerf.

    Nota:
    Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli indirizzi Web sono soggetti a modifiche senza preavviso.

  2. Avviare il file eseguibile autoestraente scaricato e seguire le istruzioni per installare l'applicazione.


EMC PowerPath Service interrotto
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio EMC PowerPath Service. Il valore True indica che il servizio EMC PowerPath Service è in esecuzione, mentre il valore False indica che il servizio EMC PowerPath Service non è in esecuzione. Se Exchange Server Analyzer rileva che il valore della chiave Started è impostato su False, verrà visualizzato un avviso.

EMC PowerPath è un software Multipath I/O (MPIO). Il multipathing offre un accesso dati ad alta disponibilità poiché consente a un host di disporre di un massimo di 32 percorsi per accedere a una periferica di archiviazione esterna, facilitando il failover e il bilanciamento del carico. Non è una funzione del sistema operativo, ma è supportata tramite il DDK (Driver Development Kit) MPIO, che offre ai rivenditori un mezzo per creare soluzioni interoperative di multipathing.

Quando il software MPIO è in esecuzione, Microsoft Windows® rileva solo un'unità mentre il software MPIO consente di gestire le diverse connessioni a numerose periferiche di archiviazione. Se il software MPIO viene arrestato, tutte le unità di archiviazione collegate vengono rilevate come unità indipendenti. In tal modo è probabile che si verifichino errori di archiviazione e funzionamenti errati.

Per avviare il servizio EMC PowerPath Service

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse su EMC PowerPath Service e scegliere Proprietà.

  3. Nella scheda Generale della pagina delle proprietà di EMC PowerPath Service accertarsi che l'opzione Tipo di avvio sia impostata su Automatico. In caso contrario, fare clic su Applica, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio EMC PowerPath Service e scegliere Start.

  5. Aprire lo snap-in Servizi.

Per informazioni generali sulla distribuzione di diverse tecnologie di archiviazione con Windows, consultare il sito Web "Pianificazione per l'utilizzo delle funzioni di archiviazione di Windows con le reti SAN " all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33626.


EMC PowerPath Version Mismatch Between Cluster Nodes
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2007-07-25

Microsoft Exchange Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di EMC PowerPath in esecuzione in ogni nodo del cluster:

HKEY_LOCAL_MACHINE\SOFTWARE\EMC\PowerPath\Version

Se Exchange Analyzer rileva che il valore di Version nel secondo nodo, o nel nodo successivo, del cluster di Exchange è diverso dal valore di Version nel primo nodo del cluster di Exchange, verrà visualizzato un messaggio di errore.

Il messaggio di errore indica che nei nodi del cluster di Exchange non è in esecuzione la stessa versione del driver EMC PowerPath. Si consiglia di eseguire su tutti i nodi del cluster di Exchange la stessa versione del driver EMC PowerPath.

EMC PowerPath è un software Multipath I/O (MPIO). Il multipathing offre un accesso dati ad alta disponibilità poiché consente a un host di disporre di un massimo di 32 percorsi per accedere a una periferica di archiviazione esterna, facilitando il failover e il bilanciamento del carico. Non è una funzione del sistema operativo, ma è supportata tramite il DDK (Driver Development Kit) MPIO, che offre ai rivenditori un mezzo per creare soluzioni interoperative di multipathing.

Quando il software MPIO è in esecuzione, Microsoft Windows rileva solo un'unità mentre il software MPIO consente di gestire le diverse connessioni a numerose periferiche di archiviazione. Se nei nodi del cluster sono in esecuzione versioni diverse del driver MPIO, potrebbero verificarsi dei problemi di failover dei cluster.

Per risolvere il problema è necessario aggiornare tutti i nodi in modo che eseguano la stessa versione del driver EMC PowerPath.

Per ulteriori informazioni

Per ulteriori informazioni sulla distribuzione di diverse tecnologie di archiviazione con Windows, consultare "Planning to Use Windows Storage Features with SANs" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33626 (in lingua inglese).


Driver della porta Emulex FC non aggiornato da più di due anni
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-04-19

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_SCSIController per determinare se è impostato un valore per la chiave DriverName e se sono presenti le seguenti condizioni:

  • Il driver della porta Emulex FC è installato nel server Exchange.

  • La versione corrente del driver della porta Emulex FC è installato nel server Exchange.

  • Il driver della porta Emulex FC è stato aggiornato negli ultimi due anni.

Se Exchange Server Analyzer rileva che il valore della chiave DriverName non è stato aggiornato per più di due anni, verrà visualizzato un avviso.

Il driver della porta Emulex FC fornisce la funzionalità solo SCSI o SCSI e IP simultanea all'interno di una singola scheda bus host (HBA) o in più HBA. Il driver della porta FC fornisce la funzionalità SCSI sulle topologie FC-AL (Fibre Channel Arbitrated Loop), point-to-point e fabric. Il driver della porta FC è stato progettato per applicazioni specializzate che richiedono il mapping di numeri di unità logiche (LUN) basati su host o il binding permanente.

Per aggiornare il driver della porta Emulex FC, consultare Downloads and Manuals for Windows all'indirizzo http://www.emulex.com/ts/docfc/winframe.htm (informazioni in lingua inglese). Se sono necessari driver OEM speciali, consultare il sito Web relativo al software e alla documentazione Emulex all'indirizzo http://www.emulex.com/ts/index.html (informazioni in lingua inglese).

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


Driver Emulex SCSIport Miniport non aggiornato da più di due anni
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-06-14

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_SCSIController per determinare se è stato impostato un valore per la chiave DriverName. Exchange Server Analyzer determina se sono presenti le seguenti condizioni:

  • Il driver Emulex SCSIport Miniport è installato nel server di Exchange.

  • La versione corrente del driver Emulex SCSIport Miniport è installata nel server di Exchange.

  • Il driver Emulex SCSIport Miniport è stato aggiornato negli ultimi due anni.

Se Exchange Server Analyzer rileva che il valore della chiave DriverName non è stato aggiornato da più di due anni, verrà visualizzato un avviso.

Il driver SCSIport Miniport fornisce la funzionalità SCSI sulle topologie FC-AL (Fibre Channel Arbitrated Loop), point-to-point e fabric.

Per aggiornare il driver Emulex SCSIport Miniport, vedere "Downloads and Manuals for Windows" all'indirizzo http://www.emulex.com/ts/docfc/winframe.htm (informazioni in lingua inglese). Se sono necessari driver OEM speciali, vedere "OEM software and documentation" all'indirizzo http://www.emulex.com/ts/index.html (informazioni in lingua inglese).

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Driver Emulex Storport Miniport non aggiornato da più di due anni
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-06-14

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_SCSIController per determinare se è impostato un valore per la chiave DriverName e se sono presenti le seguenti condizioni:

  • Il driver di Emulex Storport miniport è installato sul server di Exchange.

  • La versione corrente del driver di Emulex Storport miniport è installato sul server di Exchange.

  • Il driver di Emulex Storport miniport è stato aggiornato negli ultimi due anni.

Se Exchange Server Analyzer rileva che il valore della chiave DriverName non è stato aggiornato da più di due anni, verrà visualizzato un avviso.

Il driver di Emulex Storport miniport ottimizza le prestazioni e la gestione delle reti SAN e degli array di dischi basati su hardware. Il driver di Emulex Storport miniport supporta le topologie FC-AL, topologie punto a punto e topologie fabric.

Per aggiornare il driver di Emulex Storport miniport, consultare Downloads and Manuals for Windows all'indirizzo http://www.emulex.com/ts/docfc/winframe.htm (informazioni in lingua inglese). Se sono necessari driver OEM speciali, vedere "OEM software and documentation" all'indirizzo http://www.emulex.com/ts/index.html (informazioni in lingua inglese).

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Utilizzo CPU elevato in un processo non Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

  • Microsoft® Exchange Server Analyzer Tool ha rilevato un processo non Exchange Server che utilizza più del 20% della CPU disponibile del server. Se un processo non Exchange Server utilizza più del 20% della CPU disponibile, verrà visualizzato un messaggio di errore.

  • È consigliabile che i server che eseguono Exchange Server siano dedicati, per quanto possibile, solo a Exchange Server ed eseguano il minor numero di applicazioni e servizi al di fuori di Exchange.

Per risolvere il problema

  • Se un altro processo utilizza la maggior parte della CPU, provare a eseguire una delle seguenti operazioni:

    • Disattivare il processo e vedere se il problema si risolve.

    • Se possibile, spostare il processo in un altro server.

    • Assicurarsi che il processo sia configurato correttamente e ricercare eventuali aggiornamenti di Microsoft e del provider del processo che risolvano il problema.

    • Disinstallare il process, se non è necessario.

  • Se il processo non può essere spostato o corretto, è consigliabile scalare nuovamente il server per consentire il carico aggiunto del processo non Exchange Server. Durante quest'operazione prendere in considerazione l'ipotesi di spostare gli utenti in un altro server di Exchange.


HP/Compaq Secure Path Service interrotto
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il servizio HP/Compaq Secure Path è in esecuzione. Se Exchange Server Analyzer determina che HP/Compaq Secure Path non è in esecuzione, verrà visualizzato un avviso.

Il servizio HP/Compaq Secure Path è un programma Multipath I/O (MPIO). Il multipathing offre un accesso dati ad alta disponibilità poiché consente a un host di disporre di un massimo di 32 percorsi per accedere a una periferica di archiviazione esterna, facilitando il failover e il bilanciamento del carico. Non è una funzione del sistema operativo, ma è supportata tramite il DDK (Driver Development Kit) MPIO, che offre ai rivenditori un mezzo per creare soluzioni interoperative di multipathing.

Quando il software MPIO è in esecuzione, il sistema operativo Windows® rileva solo un'unità mentre il software MPIO consente di gestire le diverse connessioni a numerose periferiche di archiviazione. Se il software MPIO viene arrestato, tutte le unità di archiviazione collegate vengono rilevate come unità indipendenti. In tal modo è probabile che si verifichino errori di archiviazione e funzionamenti errati.

Per risolvere il problema

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio HP/Compaq Secure Path e scegliere Proprietà.

  3. Nella scheda Generale della pagina delle proprietà del servizio HP/Compaq Secure Path accertarsi che l'opzione Tipo di avvio sia impostata su Automatico. In caso contrario, fare clic su Applica, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio HP/Compaq Secure Path e scegliere Start.

  5. Aprire lo snap-in Servizi.

Per informazioni generali sulla distribuzione di diverse tecnologie di archiviazione con Windows, consultare il sito Web "Pianificazione per l'utilizzo delle funzioni di archiviazione di Windows con le reti SAN " all'indirizzo http://go.microsoft.com/fwlink/?linkid=33626.


Impatto del software di terze parti
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool ha determinato che sul server di Exchange è in esecuzione software di terze parti. Questo software di terze parti potrebbe essere la causa dei problemi di prestazioni del server. Il software di terze parti può includere quanto segue:

  • Prodotti antivirus a livello di file

  • Prodotti antivirus per la posta elettronica che riconoscono Exchange

  • Prodotti anti spam

  • Software server fax

  • Connettore di collaborazione o di posta esterna

  • Servizi di gestione file e stampa

  • Connettori di dispositivi portatili

Per risolvere il problema

  • Se si sospetta che il software di terze parti stia peggiorando le prestazioni di Exchange Server, disinstallare o disabilitare tale software e misurare la prestazioni di Exchange Server.

  • Se si determina che il software di terze parti è la causa del peggioramento delle prestazioni, ma tale software è importante per la funzionalità del server, considerare l'ipotesi di dedicare un altro server per distribuire il carico tra i due server.

Ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Disponibile aggiornamento della versione di INO_FLPY.SYS
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare la versione del driver del filtro antivirus Ino_flpy.sys di Computer Associates.

Exchange Server Analyzer esegue un query nella classe WMI CIM_Datafile per determinare il valore della chiave Version per Ino_flpy.sys e, in base al numero della della versione, può essere necessario un aggiornamento del software. Se il valore per la chiave Version indica un numero di versione inferiore a 5.00.6100.109 per il file Ino_flpy.sys, verrà visualizzato un avviso.

Un numero di versione inferiore a 5.00.6100.109 indica che nel computer Exchange Server non è installata la versione più recente del file Ino_flpy.sys e che è necessario installare una versione più recente del driver del filtro. Un aggiornamento del software antivirus per il file Ino_flpy.sys è reperibile nel sito Web di Computer Associates. Questo aggiornamento del software antivirus è consigliato e consente di migliorare le prestazioni e l'affidabilità generali del computer Exchange Server.

Al momento dell'installazione dei programmi software antivirus Inoculan Computer Associates eTrust Antivirus versione 6.x o 7.x e InoculateIT versione 6.x in un computer Exchange 2000 Server o Exchange Server 2003, i file del driver del filtro antivirus Ino_flpy.sys e Ino_fltr.sys verranno copiati nella cartella %systemroot%\system32\drivers. I file del driver dell'antivirus sono driver di Windows NT® in modalità kernel che vengono utilizzati per avviare i servizi antivirus necessari. Le versioni precedenti dei driver del filtro possono generare risultati imprevisti con il computer Exchange Server.

Per risolvere il problema

  1. Per ottenere gli aggiornamenti più recenti del software antivirus per il file ino_flpy.sys, visitare il sito Web di Computer Associates all'indirizzo http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp.

  2. Scaricare la versione aggiornata appropriata di eTrust o InoculateIT.

  3. Eseguire un backup completo del computer Exchange Server incluso un backup del file Ino_flpy.sys.

  4. Installare l'aggiornamento più recente di eTrust o InoculateIT.
Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi ai siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 240309, "Disabilitazione completa del filtraggio dei file da parte del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309.

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terze parti disponibili per Exchange Server, consultare il sito Web Exchange Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226.


Disponibile aggiornamento della versione di INO_FLTR.SYS
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare la versione del driver del filtro antivirus Computer Associates Ino_fltr.sys.

Exchange Server Analyzer esegue una query nella classe WMI CIM_Datafile per determinare il valore della chiave Version di Ino_fltr.sys e verificare, a seconda del numero di build della versione rilevato, se sia necessario un aggiornamento del software. Se il valore per la chiave Version indica un numero di versione inferiore a 5.00.6100.142 per il file Ino_fltr.sys, verrà visualizzato un avviso.

Un numero di versione inferiore a 5.00.6100.142 indica che nel computer Exchange Server non è installata la versione più recente del file Ino_fltr.sys e che è necessario installare una versione più recente del driver del filtro. Un aggiornamento del software antivirus per il file Ino_fltr.sys è reperibile nel sito Web di Computer Associates. Questo aggiornamento del software antivirus è consigliato e consente di migliorare le prestazioni e l'affidabilità generali del computer Exchange Server.

Al momento dell'installazione dei programmi software antivirus Inoculan Computer Associates eTrust Antivirus versione 6.x o 7.x e InoculateIT versione 6.x in un computer Exchange 2000 Server o Exchange Server 2003, i file del driver del filtro antivirus Ino_flpy.sys e Ino_fltr.sys verranno copiati nella cartella %systemroot%\system32\drivers. I file del filtro del driver dell'antivirus sono driver di Windows NT® in modalità kernel che vengono utilizzati per avviare i servizi antivirus necessari. Le versioni precedenti dei driver del filtro possono generare risultati imprevisti con il computer Exchange Server.

Per risolvere il problema

  1. Per richiedere gli ultimi aggiornamenti del software antivirus per il file Ino_fltr.sys, visitare il sito Web di Computer Associates. (http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/ildrvupdate.asp, informazioni in lingua inglese).

  2. Scaricare la versione aggiornata appropriata di eTrust o InoculateIT.

  3. Eseguire un backup completo del computer Exchange Server incluso un backup del file Ino_fltr.sys.

  4. Installare l'aggiornamento più recente di eTrust o InoculateIT.
Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi ai siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 240309, "Disabilitazione completa del filtraggio dei file da parte del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240309.

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226.


Disponibile aggiornamento di McAfee GroupShield 5,2 per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-04-19

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se un file di libreria VSAPI (Virus Scanning Application Programming Interface) è registrato sull'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Quando McAfee GroupShield 5.2 per Microsoft Exchange viene installato in Exchange Server 2000 o Exchange Server 2003, la voce del Registro di sistema della libreria avrà il valore GSEVS2.DLL. Questo file di libreria esegue numerose funzioni relative a VSAPI in GroupShield 5.2 per Microsoft Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per GSEVS2.DLL. Se il valore per la chiave Version indica un numero build inferiore a 682 per questo file, verrà visualizzato un avviso.

Un numero di versione inferiore a 682 per GSEVS2.DLL indica che la versione più recente di GroupShield 5.2 per Microsoft Exchange non è installata. Un aggiornamento del software di GroupShield 5.2 per Microsoft Exchange è disponibile sul sito Web McAfee. Questo aggiornamento è consigliato e consente di migliorare le prestazioni e l'affidabilità generali. Inoltre, se si esegue l'aggiornamento a GroupShield per Microsoft Exchange 5.2.682 si è certi di utilizzare le versioni più recenti di DLL importanti. L'utilizzo della versione più recente di gsevs2.dll ha determinato un notevole aumento dell'affidabilità e delle prestazioni nelle distribuzioni di messaggistica di Exchange Server.

Per risolvere il problema

  1. Per informazioni sulla versione più recente di GroupShield 5.2 per Microsoft Exchange Server, consultare la pagina Guided Knowledge Search del sito Web McAfee all'indirizzo http://knowledgemap.nai.com/ (informazioni in lingua inglese). Consultare inoltre i seguenti articoli della Knowledge Base delle soluzioni McAfee e altri articoli presenti nel sito Web:

    • ID soluzione KB40567, "Getting the latest version of GroupShield and/or SpamKiller" (informazioni in lingua inglese).

    • ID soluzione KB nai18117, "Product Version Information for GroupShield for Exchange 2000" (informazioni in lingua inglese).

  2. Visitare il sito Web McAfee all'indirizzo https://secure.nai.com/us/forms/downloads/upgrades/login.asp (informazioni in lingua inglese).

  3. Scaricare gli aggiornamenti più recenti per la versione in uso di GroupShield 5.2 per Microsoft Exchange Server.

  4. Eseguire un backup completo del computer Exchange Server.

  5. Scaricare gli aggiornamenti più recenti per GroupShield 5.2 per Microsoft Exchange Server.
Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226.


Disponibile aggiornamento di McAfee GroupShield 6,0 per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se un file di libreria VSAPI (Virus Scanning Application Programming Interface) è registrato sull'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Quando McAfee GroupShield 6.0 per Microsoft Exchange viene installato in Exchange Server 2000 o Exchange Server 2003, la voce del Registro di sistema della libreria avrà il valore VSAPISCANSOURCE.DLL. Questo file di libreria esegue numerose funzioni relative a VSAPI in GroupShield 6,0 per Microsoft Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per VSAPISCANSOURCE.DLL. Se il valore della chiave Version indica un numero di build inferiore a 6.0.1148.0 per questo file, verrà visualizzato un avviso.

Un numero di versione inferiore a 6.0.1148.0 per VSAPISCANSOURCE.DLL indica che la versione più recente di GroupShield 6.0 per Microsoft Exchange non è installata. Un aggiornamento del software di GroupShield 6,0 per Microsoft Exchange è disponibile sul sito Web McAfee. Questo aggiornamento è consigliato e consente di migliorare le prestazioni e l'affidabilità generali.

Per risolvere il problema

  1. Per informazioni sulla versione più recente di GroupShield 6.0 per Microsoft Exchange, consultare la pagina Guided Knowledge Search del sito Web McAfee all'indirizzo http://knowledgemap.nai.com/ (informazioni in lingua inglese). Consultare inoltre i seguenti articoli della delle soluzioni McAfee e altri articoli presenti nel sito Web:

    • ID soluzione nai18117, "Product Version Information for GroupShield for Exchange 2000" (informazioni in lingua inglese).

    • ID soluzione KB37636, "Version numbers for McAfee GroupShield 6.x for Microsoft Exchange" (informazioni in lingua inglese).

    • ID soluzione KB40567, "Getting the latest version of GroupShield and/or SpamKiller" (informazioni in lingua inglese).

  2. Visitare la pagina Product Downloads del sito Web McAfee all'indirizzo https://secure.nai.com/us/forms/downloads/upgrades/login.asp (informazioni in lingua inglese).

  3. Scaricare gli aggiornamenti più recenti per la versione di GroupShield 6.0 per Microsoft Exchange utilizzata.

  4. Eseguire un backup completo del computer Exchange Server.

  5. Scaricare gli aggiornamenti più recenti per GroupShield 6.0 per Microsoft Exchange.
Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui ha bisogno. Gli URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226.


McAfee GroupShield è installato nel server di Exchange ma il servizio è stato arrestato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se McAfee® GroupShield® per Microsoft® Exchange è installato e se il servizio McAfee GroupShield è in esecuzione sul computer Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il valore stabilito per la chiave Started nel servizio Archivio informazioni di Microsoft Exchange è impostato su True o False.

Il valore False indica che il servizio Archivio informazioni non è in esecuzione su questo computer Exchange Server. Il valore True indica che il servizio Archivio informazioni di Microsoft Exchange è attivo.

Se Exchange Server Analyzer rileva che il servizio Archivio informazioni di Microsoft Exchange è in esecuzione e McAfee GroupShield è installato ma il servizio McAfee GroupShield non è stato avviato, verrà visualizzato un avviso.

McAfee GroupShield offre protezione antivirus per Exchange. Di seguito sono elencati alcuni problemi (con la relativa soluzione) per i quali il servizio McAfee GroupShield potrebbe subire un'interruzione.

  • Il software eseguito nel server di Exchange può essere una versione di prova o di valutazione scaduta. In questo caso, potrebbe essere necessario reinstallare McAfee GroupShield. Per continuare a utilizzare il software, è almeno necessario attivarlo.

  • Un amministratore potrebbe aver arrestato inavvertitamente il servizio McAfee GroupShield. Verificare che il servizio sia impostato per l'esecuzione automatica, quindi avviare il servizio.

  • Un worm, un virus o un altro programma dannoso potrebbe aver arrestato il servizio. Verificare che il servizio sia impostato per l'esecuzione automatica e avviare il servizio. Se continua a verificarsi l'arresto improvviso del servizio senza eventi di errore rilevanti, verificare che il computer non sia stato infettato da un worm dannoso e, se necessario, disinfettare il sistema.

Microsoft generalmente consiglia di distribuire un software antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) oppure nei server di Exchange che ospitano cassette postali. Per una protezione massima, eseguire il software antivirus nel gateway che esegue l'analisi dei messaggi MIME in arrivo ed eseguire un'analisi del server di Exchange che utilizza VSAPI 2.5.

Per avviare il servizio McAfee GroupShield

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio McAfee GroupShield, quindi scegliere Proprietà.

  3. Nella scheda Generale della pagina delle proprietà di McAfee GroupShield accertarsi che l'opzione Tipo di avvio sia impostata su Automatico. In caso contrario, fare clic su Applica, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio McAfee GroupShield, quindi scegliere Start.

  5. Aprire lo snap-in Servizi.

Inoltre, è consigliabile eseguire un software antivirus client nel PC dell'utente. Se si esegue un software antivirus progettato per sistemi di messaggistica (in grado di analizzare ed effettuare l'analisi di contenuto MIME) nel gateway oppure nel server di Exchange, è sufficiente eseguire un'analisi del PC a livello di file.

  • Per ulteriori informazioni sui diversi tipi di programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

  • Per ulteriori informazioni sui diversi tipi di programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, consultare l'articolo 328841 della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

  • Per informazioni sulla protezione di un ambiente Exchange da virus e worm trasmessi tramite posta elettronica, consultare il documento "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=30732.


Messageware Plus Pack è installato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è installato Messageware Plus Pack nei server di Exchange:

HKEY_LOCAL_MACHINE\Software\Messageware Incorporated\Core Services\PlusPack\Load

Se Exchange Server Analyzer rileva che il valore di Load corrisponde a 1, verrà visualizzato un messaggio di configurazione non predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Messageware Plus Pack è un componente aggiuntivo di Microsoft Office Outlook® Web Access per Exchange Server 200, prodotto da Messageware Incorporated. Messageware Plus Pack estende e migliora Outlook Web Access sia per gli utenti di Outlook Web Access Basic sia per quelli di Outlook Web Access Premium.

Per ulteriori informazioni su Messageware Plus Pack, consultare il sito Web "Messageware OWA Suite" all'indirizzo http://www.messageware.com (informazioni in lingua inglese).

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Compatibilità con la Protezione esecuzione programmi di Microsoft Antigen
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2007-02-19

Lo strumento Microsoft Exchange Analyzer interroga la classe di Strumentazione gestione Windows (WMI) Win32_Service per determinare il valore della chiave Started per il servizio Microsoft Antigen. Il valore False indica che il servizio non è in esecuzione. Il valore True indica che il servizio è in esecuzione.

Exchange Analyzer legge inoltre la seguente voce del Registro di sistema per determinare se il motore di analisi Kaspersky per Microsoft Antigen è installato su Exchange Server. Tale voce del Registro di sistema sarà presente solo se il motore di analisi Kaspersky è installato su Exchange Server.

HKEY_LOCAL_MACHINE\Software\Sybari Software\Antigen for Exchange\Scan Engines\Kaspersky

Infine, se Exchange Server è in esecuzione su Microsoft Windows Server 2003 Service Pack 1 (SP1) o versione successiva, Exchange Analyzer interroga la classe di Strumentazione gestione Windows (WMI) Win32_ComputerSystem per determinare se il valore della chiave SystemStartupOptions contiene le stringhe '/NOEXECUTE=OPTOUT' o '/NOEXECUTE=ALWAYSON'. Ciò indica che sul server è attivata la Protezione esecuzione programmi (DEP). La Protezione esecuzione programmi è un gruppo di tecnologie hardware e software che eseguono verifiche aggiuntive sulla memoria per prevenire l'esecuzione di codice dannoso sul sistema.

Se Exchange Analyzer determina che le condizioni indicate di seguito sono vere, verrà visualizzato un avviso:

  • Il servizio Microsoft Antigen è attivato sul server.

  • Il motore di analisi Kaspersky per Antigen è installato.

  • Il server di Exchange è in esecuzione su Microsoft Exchange Server 2003 con Service Pack 1 (SP1) o versioni successive.

  • La Protezione esecuzione programmi è attivata sul server.

Questo avviso indica che la configurazione corrente del server può provocare problemi di prestazioni per la scansione di messaggistica e virus.

Per risolvere questo errore, seguire le istruzioni riportate nell'articolo 905952 della Microsoft Knowledge Base, "Messaging performance is slower than expected in Antigen, and the Antigen client stops responding", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=905952 per disattivare in maniera selettiva la Protezione esecuzione programmi per i singoli programmi.

Per ulteriori informazioni

Per ulteriori informazioni sulla Protezione esecuzione programmi, consultare l'articolo 875352 della Microsoft Knowledge Base, "A detailed description of the Data Execution Prevention (DEP) feature in Windows XP Service Pack 2, Windows XP Tablet PC Edition 2005, and Windows Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=875352.


Double-Take di NSI Software è installato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio Double-Take. Il valore True indica che il servizio Double-Take è in esecuzione sul server di Exchange. Se viene rilevato il servizio Double-Take su un server di Exchange, verrà visualizzato un messaggio di configurazione non predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione non predefinita solo a scopo informativo. Non è richiesta alcuna operazione.

Double-Take, di NSI Software, Inc., copia i file selezionati dall'utente o i volumi completi da uno o più server di origine a uno o più server di destinazione tramite connessioni di rete standard. Queste copie consentono alle aziende di ripristinare velocemente le attività dopo una situazione di emergenza o un'interruzione del sistema, con o senza l'intervento dell'utente.

Per ulteriori informazioni su Double-Take, consultare il sito Web "Double-Take" all'indirizzo http://www.nsisoftware.com/pro/doubletake (informazioni in lingua inglese).

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Double-Take è un software per la replica dei dati. Per ulteriori informazioni sulla replica dei dati per più siti in Exchange 2000 Server ed Exchange Server 2003, consultare l'articolo 895847 della Microsoft Knowledge Base "Supporto per la replica dei dati a più siti in Exchange 2003 ed Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895847.


Utilizzo di una percentuale di tempo processore superiore al 20% da parte di un processo non Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni %Processor Time (_Total) dell'oggetto prestazioni Processor per analizzare i dati delle prestazioni.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • È presente un collo di bottiglia del processore.

  • Uno o più processi non Exchange utilizzano una percentuale della quantità media totale di tempo di CPU del server superiore al 20%.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • È presente un collo di bottiglia del processore.

  • Uno o più processi non Exchange utilizzano una percentuale della quantità media totale di tempo di CPU del server superiore al 10%.

Il contatore di prestazioni % Processor Time (_Total) nell'oggetto prestazioni Process offre l'utilizzo complessivo dei processori. L'utilizzo medio della CPU deve essere sempre inferiore all'80%. Medie più elevate indicano la presenza di un collo di bottiglia del processore. Anche frequenti sovraccarichi nel tempo processore superiori al 90% indicano un collo di bottiglia del processore.

Rimozione dei colli di bottiglia del processore

È possibile rimuovere i colli di bottiglia del processore dal server di Exchange in più modi.

  • Innanzitutto, controllare le applicazioni o le attività che causano il carico del server. Verificare che il tempo processore utilizzato dall'applicazione sia corretto e che non rappresenti un problema.

  • Se un'applicazione non Exchange non è importante per il server, eseguire tale applicazione su un server diverso. Se possibile, spostare anche i ruoli del server su altri computer. Ad esempio, se il processo Inetinfo sta utilizzando quantità elevate di tempo di CPU, è possibile aggiungere server front-end responsabili del lavoro di protocollo eseguito da Inetinfo. È inoltre possibile spostare l'accesso a cartelle pubbliche su un server di cartelle pubbliche dedicato. Infine, se un server esegue un numero elevato di espansioni di liste di distribuzione, è possibile ridurre l'utilizzo del tempo di CPU spostando l'espansione della lista di distribuzione su un server di espansione di liste di distribuzione dedicato.

  • Se possibile, aggiungere al server ulteriori processori o sostituire quelli esistenti con processori più veloci. Attivare inoltre la tecnologia di hyper-threading, se è supportata dai processori. È possibile attivare la tecnologia di hyper-threading configurando il BIOS di sistema. Per ulteriori informazioni, vedere la Guida in linea del produttore del computer.

  • Se non è possibile aumentare la potenza di elaborazione, ridurre il carico sui processori. Per ridurre l'effetto complessivo sul server, assicurarsi che le attività con utilizzo intensivo di I/O, CPU o di memoria vengano eseguite al di fuori del normale orario di lavoro.

  • Assicurarsi che le attività che richiedono un utilizzo intensivo della CPU (ad esempio le attività di backup o di manutenzione) vengano eseguite in orari con scarso traffico e che tali attività vengano eseguite in modo gestito. Gestire un'attività significa impostare diversi tempi di avvio e, preferibilmente, di fine per ciascuna attività. Gestendo la manutenzione e il backup dei database o dei gruppi di archiviazione, inoltre, si riduce l'effetto delle attività che utilizzano una quantità elevata di risorse.

Ulteriori informazioni

  • Per ulteriori informazioni sui colli di bottiglia del processore, consultare Collo di bottiglia del processore

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione di problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server 2003 Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • Per ulteriori informazioni sullo spostamento di cassette postali utente per ridurre il carico sul server, consultare Spostare le cassette postali degli utenti su un server diverso.


Utilizzo di una percentuale di tempo processore superiore al 50% da parte di un processo non Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer con Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni %Processor Time (_Total) dell'oggetto prestazioni Processor per analizzare i dati delle prestazioni.

Il contatore di prestazioni % Processor Time (_Total) nell'oggetto prestazioni Process offre l'utilizzo complessivo dei processori. L'utilizzo medio della CPU deve essere sempre inferiore all'80%. Medie più elevate indicano la presenza di un collo di bottiglia del processore. Anche frequenti sovraccarichi nel tempo processore superiori al 90% indicano un collo di bottiglia del processore.

Se Exchange Server Analyzer determina che un processo non Exchange sta utilizzando più del 50% del tempo medio complessivo della CPU del server, verrà visualizzato un messaggio di errore anche se non viene rilevato alcun collo di bottiglia del processore.

Rimozione di potenziali colli di bottiglia del processore

È possibile rimuovere potenziali colli di bottiglia del processore dal server di Exchange in più modi.

  • Innanzitutto, controllare le applicazioni o le attività che causano il carico del server. Verificare che il tempo processore utilizzato dall'applicazione sia corretto e che non rappresenti un problema.

  • Se un'applicazione non Exchange non è importante per il server, eseguire tale applicazione su un server diverso. Se possibile, spostare anche i ruoli del server su altri computer. Ad esempio, se il processo Inetinfo sta utilizzando quantità elevate di tempo di CPU, è possibile aggiungere server front-end responsabili del lavoro di protocollo eseguito da Inetinfo. È inoltre possibile spostare l'accesso a cartelle pubbliche su un server di cartelle pubbliche dedicato. Infine, se un server esegue un numero elevato di espansioni di liste di distribuzione, è possibile ridurre l'utilizzo del tempo di CPU spostando l'espansione della lista di distribuzione su un server di espansione di liste di distribuzione dedicato.

  • Se possibile, aggiungere al server ulteriori processori o sostituire quelli esistenti con processori più veloci. Attivare inoltre la tecnologia di hyper-threading, se è supportata dai processori. È possibile attivare la tecnologia di hyper-threading configurando il BIOS di sistema. Per ulteriori informazioni, vedere la Guida in linea del produttore del computer.

  • Se non è possibile aumentare la potenza di elaborazione, ridurre il carico sui processori. Per ridurre l'effetto complessivo sul server, assicurarsi che le attività con utilizzo intensivo di I/O, CPU o di memoria vengano eseguite al di fuori del normale orario di lavoro.

  • Assicurarsi che le attività che richiedono un utilizzo intensivo della CPU (ad esempio le attività di backup o di manutenzione) vengano eseguite in orari con scarso traffico e che tali attività vengano eseguite in modo gestito. Gestire un'attività significa impostare diversi tempi di avvio e, preferibilmente, di fine per ciascuna attività. Gestendo la manutenzione e il backup dei database o dei gruppi di archiviazione, inoltre, si riduce l'effetto delle attività che utilizzano una quantità elevata di risorse.

Ulteriori informazioni

  • Per ulteriori informazioni sui colli di bottiglia del disco, consultare Collo di bottiglia del processore

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare Troubleshooting Microsoft Exchange Server Performance all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


È installata una versione obsoleta di HP/Compaq Secure Path
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-13

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare la versione software di HP/Compaq Secure Path installata nel server di Exchange. Se la versione di Secure Path non è 3.7.2.540, verrà visualizzato un avviso.

Per evitare questo avviso, aggiornare il software Secure Path. Per aggiornare il software, rivolgersi al proprio rivenditore HP/Compaq.

Per ulteriori informazioni sugli aggiornamenti software di HP/Compaq Secure Path, visitare il sito Web HP "HP StorageWorks Secure Path" all'indirizzo http://h18006.www1.hp.com/products/sanworks/softwaredrivers/securepath/index.html (informazioni in lingua inglese).

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui ha bisogno. Gli URL sono soggetti a modifiche senza preavviso.


Porta 25 bloccata
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se McAfee VirusScan per Microsoft Exchange è installato nel server in cui viene eseguito Exchange Server:

HKEY_LOCAL_MACHINE\Software\Network Associates\TVD\VirusScan Enterprise\CurrentVersion

Exchange Server Analyzer consente anche di eseguire query nel ramo del Registro di sistema indicato di seguito per determinare come il prodotto VirusScan è configurato per bloccare porte:

HKLM\Software\Network Associates\TVD\Shared Components\On Access Scanner\BehaviourBlocking

Le chiavi in questo ramo vengono utilizzate per configurare i processi e le porte da bloccare o consentire con la funzionalità On Access del prodotto VirusScan.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio McAfee VirusScan e determinare se è in esecuzione sul server di Exchange.

Il valore False indica che il servizio McAfee VirusScan non è in esecuzione su questo server di Exchange. Il valore True indica che il servizio è in esecuzione.

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • Il servizio McAfee VirusScan è installato e in esecuzione sul server di Exchange.

  • La regola di blocco "Prevent mass mailing worms from sending mail" è abilitata per la porta 25.

  • Il servizio SMTP non è escluso dalla regola di blocco.

Questo avviso indica che l'applicazione McAfee VirusScan è configurata in modo da bloccare la comunicazione legittima di Exchange Server tramite la porta 25. Potrebbero verificarsi problemi nel flusso di posta.

Per risolvere il problema:

  • Prendere in considerazione la possibilità di disabilitare la regola di blocco "Prevent mass mailing worms from sending mail".

  • Aggiungere il servizio SMTP di Exchange Server all'elenco di esclusione della regola di blocco "Prevent mass mailing worms from sending mail".

Ulteriori informazioni

  • Per ulteriori informazioni su come configurare McAfee VirusScan per Microsoft Exchange, visitare il portale dei servizi di McAfee all'indirizzo http://knowledge.mcafee.com/ (in inglese).

    Nota:
    Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli URL sono soggetti a modifiche senza preavviso.
  • Per ulteriori informazioni sui diversi tipi di programmi antivirus solitamente utilizzati con Microsoft Exchange Server 2003, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

  • Per ulteriori informazioni sui diversi tipi di programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, consultare l'articolo 328841della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

  • Per informazioni sulla protezione di un ambiente Exchange da virus e worm trasmessi tramite posta elettronica, consultare il documento "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=30732.


Red Earth Software Policy Patrol for Exchange Server Needs Update
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2007-07-24

Microsoft Exchange Analyzer Tool legge il Registro di sistema per determinare la presenza di una delle due sottochiavi riportate di seguito:

HKEY_LOCAL_MACHINE\Software\Red Earth Software\Policy Patrol\3.0

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Red Earth Software\Policy Patrol\3.0

La presenza di uno di questi due rami indica che sul computer locale è installata la versione 3.0 di Policy Patrol per Exchange Server di Red Earth Software.

Se Exchange Analyzer rileva che sul computer locale è installata la versione 3.0 di Policy Patrol per Exchange Server, verrà visualizzato un avviso.

Il messaggio di avviso indica che è disponibile un aggiornamento consigliato di Policy Patrol per Exchange Server.

Per risolvere il problema

  1. Visitare il sito di download di Policy Patrol per Exchange Server di Red Earth Software alla pagina http://www.policypatrol.com/download.htm.

  2. Scaricare e installare gli aggiornamenti necessari o consigliati di Policy Patrol per Exchange Server.
Nota:
Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli URL sono soggetti a modifiche senza preavviso.


Funzionamento simultaneo di ScanMail per Microsoft Exchange ed eTrust di CA
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare la versione di Trend Micro ScanMail per Microsoft Exchange installata nel server di Exchange:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Se i dati del valore per Version iniziano con 7, è installato ScanMail per Microsoft Exchange versione 7.

Inoltre, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se nel server di Exchange è installato anche eTrust di Computer Associates:

HKLM\Software\ComputerAssociates\eTrustAntivirus\CurrentVersion\

Se nel Registro di sistema è presente il valore CurrentVersion, nel server di Exchange è installato eTrust Antivirus versione 7 di Computer Associates.

Infine, Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio InoRT, noto anche come servizio eTrust Antivirus Realtime Server in eTrust Antivirus.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • Nel server di Exchange sono installati sia ScanMail per Microsoft Exchange che eTrust Antivirus.

  • Il servizio eTrust Antivirus Realtime Server è stato avviato.

Trend Micro consiglia di escludere le cartelle ScanMail per Microsoft Exchange dall'analisi eseguita da software antivirus basati su file come eTrust Antivirus. Per eseguire l'analisi, ScanMail per Microsoft Exchange utilizza cartelle temporanee nel proprio percorso di analisi. Se un programma antivirus basato su file analizza queste cartelle temporanee, l'analisi potrebbe interferire con le normali operazioni di ScanMail per Microsoft Exchange.

Si consiglia di escludere le cartelle ScanMail per Microsoft Exchange dall'analisi in tempo reale eseguita da software antivirus basati su file come eTrust Antivirus di Computer Associates. Per ulteriori informazioni sull'utilizzo di ScanMail per Microsoft Exchange in un computer in cui è installato un software antivirus basato su file, consultare l'articolo della Knowledge Base di Trend Micro "Installing another antivirus application with ScanMail for Exchange also installed on the same server" all'indirizzo http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=8540 (informazioni in lingua inglese).

Nota:
Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli URL sono soggetti a modifiche senza preavviso.


La directory di archivio di ScanMail per Microsoft Exchange contiene troppi file
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per stabilire se la versione 7.0 di ScanMail per Microsoft Exchange di Trend Micro è installata:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer conta quindi il numero di file presenti nella directory di archivio utilizzata da ScanMail per Microsoft Exchange. Per impostazione predefinita, il percorso della directory di archivio è il seguente:

C:\Programmi\Trend Micro\Smex\Storage\Archive

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • È installata la versione 7.0 di ScanMail per Microsoft Exchange.

  • Nella directory di archivio utilizzata da ScanMail per Microsoft Exchange sono presenti più di 1.000 file.

L'avviso indica la presenza di numerosi file nella directory di archivio utilizzata da ScanMail per Microsoft Exchange. Trend Micro consiglia di esaminare e pulire periodicamente la cartella di archiviazione utilizzata da ScanMail per Microsoft Exchange.


La directory di backup di ScanMail per Microsoft Exchange contiene un numero eccessivo di file
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la versione 7.0 di Trend Micro ScanMail per Microsoft Exchange è installata:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Quindi Exchange Server Analyzer esegue il conteggio del numero di file presenti nella directory di backup utilizzata da ScanMail per Microsoft Exchange. Per impostazione predefinita, il percorso della directory di backup è il seguente:

C:\Programmi\Trend Micro\Smex\Storage\Backup

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • La versione 7.0 di ScanMail per Microsoft Exchange è installata.

  • Nella directory di backup utilizzata da ScanMail per Microsoft Exchange sono presenti più di 1.000 file.

Questo avviso indica la presenza di un numero eccessivo di file nella directory di backup utilizzata da ScanMail per Microsoft Exchange. Trend Micro consiglia di rivedere e pulire periodicamente la cartella di backup utilizzata da ScanMail per Microsoft Exchange.


Esclusione dai backup di ScanMail per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare i file e le cartelle esclusi dai backup mediante Windows Backup:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Exchange Server Analyzer ricerca specificamente una stringa contenente "SMEX\DATA".

Se Exchange Server Analyzer rileva che la chiave FilesNotToBackup contiene un valore in cui è inclusa la stringa "SMEX\DATA", verrà visualizzato un avviso.

Se non si utilizza Windows Backup, è possibile ignorare tranquillamente questo avviso. Se invece si utilizza Windows Backup, è opportuno rimuovere l'esclusione per la directory SMEX\DATA. È consigliabile inoltre che gli utenti eseguano il backup di tutti i file con estensione MDB ubicati in questa cartella. I file di backup potranno essere utilizzati qualora i file MDB di produzione contenuti nella cartella SMEX\DATA si danneggino o vengano eliminati.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

  3. Nel riquadro sinistro selezionare FilesNotToBackup.

  4. Nel riquadro destro fare clic con il pulsante destro del mouse sul valore contenente la stringa "SMEX\DATA", quindi selezionare Elimina.

  5. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


La modalità debug di ScanMail per Microsoft Exchange è abilitata
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è abilitata la modalità debug in ScanMail per Microsoft Exchange di Trend Micro:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\DebugModule

Se i dati del valore di DebugModule contengono una o più delle seguenti stringhe, verrà visualizzato un avviso:

  • HOST:1

  • CONFIG:1

  • MASTER:1

  • WATCHER:1

  • STORE:1

  • INETINFO:1

  • TCHER:1

  • MON:1

  • MONITOR:1

L'avviso indica che la modalità debug è attualmente abilitata per uno o più moduli di ScanMail per Microsoft Exchange. Trend Micro consiglia di abilitare la modalità debug solo quando è necessario, ad esempio per la risoluzione dei problemi, e di disabilitarla per le operazioni ordinarie.

Per risolvere il problema

  1. Consultare l'articolo della Knowledge Base Trend Micro dal titolo "Enabling the ScanMail for Exchange (SMEX) 7.0 debugging through the Registry Editor" (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=25532) (informazioni in lingua inglese).

  2. Disabilitare il debug per tutti i moduli seguendo le istruzioni presenti nell'articolo della Knowledge Base Trend Micro.
Nota:
Le informazioni sui siti Web di terze parti vengono fornite per agevolare l'individuazione delle informazioni tecniche necessarie. Gli URL sono soggetti a modifica senza preavviso.


La directory di quarantena di ScanMail per Microsoft Exchange contiene un numero eccessivo di file
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la versione 7.0 di Trend Micro ScanMail per Microsoft Exchange è installata:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Quindi Exchange Server Analyzer esegue il conteggio del numero di file contenuti nella directory di quarantena utilizzata da ScanMail per Microsoft Exchange. Per impostazione predefinita, il percorso della directory di quarantena è il seguente:

C:\Programmi\Trend Micro\Smex\Storage\Quarantine

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • La versione 7.0 di ScanMail per Microsoft Exchange è installata.

  • Nella directory di quarantena utilizzata da ScanMail per Microsoft Exchange sono presenti più di 1.000 file.

Questo avviso indica la presenza di un numero eccessivo di file nella directory di quarantena utilizzata da ScanMail per Microsoft Exchange. Trend Micro consiglia di rivedere e pulire periodicamente la cartella di quarantena utilizzata da ScanMail per Microsoft Exchange.


ScanMail per la directory Microsoft Exchange SharedResPool nel percorso predefinito
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2007-06-05

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare la versione di Trend Micro ScanMail per Microsoft Exchange installata:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer legge anche la voce del Registro di sistema indicata di seguito per determinare la posizione della cartella SharedResPool:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SharedResPool

Infine, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare la posizione in cui è stato installato ScanMail per Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\HomeDir

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • ScanMail per Microsoft Exchange versione: 7 è installato.

  • La cartella SharedResPool è posizionata nel percorso della directory principale di ScanMail.

Si consiglia di trasferire la directory SharedResPool su un'unità più veloce rispetto a quella della directory principale utilizzata da ScanMail per Microsoft Exchange. Trend Micro consiglia di trasferire la cartella SharedResPool su un'unità più veloce per garantire migliori prestazioni. La directory SharedResPool contiene file di associazione di memoria per le risorse condivise tra i processi inclusi in ScanMail per Microsoft Exchange versione: 7.0. Non eliminare il contenuto di questa directory.

Per ulteriori informazioni sulla cartella SharedResPool, consultare l'articolo "What are the ScanMail for Exchange (SMEX) 7.0 SharedResPool and Engine directories?" all'indirizzo (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26898(informazioni in lingua inglese).

Per ulteriori informazioni sullo spostamento della cartella SharedResPool, vedere l'articolo "Moving the ScanMail for Exchange (SMEX) 7.0 SharedResPool directory to another location" all'indirizzo http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-127549&id=EN-127549 (in inglese).

Nota:
Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli URL sono soggetti a modifiche senza preavviso.


Analisi di ScanMail per Microsoft Exchange SMTP abilitata sul server cassette postali
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge le seguenti proprietà nella metabase di Microsoft IIS (Internet Information Services) per determinare le impostazioni delle configurazioni attuali di Trend Micro ScanMail per Microsoft Exchange:

LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes/{76719654-05A6-11d2-9dfd-00C04FA322BA}/Bindings/{6BA0CE4C-AC34-411E-B58A-EB715D04019D}/Enabled

Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare il valore per l'attributo serverRole dell'oggetto del server di Exchange. Il valore 1 dell'attributo serverRole indica che il server di Exchange è stato configurato come server front-end. Il valore 0 indica che il server di Exchange non è configurato come server front-end.

Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite per il server di Exchange. Questa query viene eseguita per determinare quale sia il sistema operativo specifico in funzione sul server di Exchange.

Exchange Server Analyzer legge anche la seguente voce del Registro di sistema per determinare la versione di ScanMail per Exchange in esecuzione sul server di Exchange:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail di Exchange\CurrentVersion\Version

Se i dati di valore per il valore Version inizia con 7, ciò indica che ScanMail per Microsoft Exchange versione 7 è installato.

Infine, Exchange Server Analyzer esegue una query nel servizio directory di Active Directory per determinare il numero degli oggetti con l'attributo homeMDBBL configurato. Gli oggetti che hanno l'attributo homeMDBBL configurato sono oggetti abilitati per le cassette postali. Pertanto, il numero di oggetti con l'attributo homeMDBBL configurato è uguale al numero di cassette postali esistenti.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • ScanMail per Microsoft Exchange versione 7 è installato.

  • ScanMail per Microsoft Exchange è configurato in modo tale da eseguire un'analisi SMTP su un server di Exchange che non è configurato come server front-end.

  • Il server di Exchange contiene più di 20 cassette postali.

  • Il server non esegue Microsoft Windows Small Business Server 2003 o Microsoft Small Business Server 2000.

Trend Micro consiglia agli utenti di ScanMail per Microsoft Exchange versione 7 di disabilitare l'analisi SMTP che utilizza la console di gestione ScanMail su server cassette postali, se sono presenti server gateway o testa di ponte dedicati separati. Per garantire prestazioni e protezione ottimali, Trend Micro consiglia di abilitare l'analisi SMTP su server testa di ponte gateway anziché su server cassette postali.


La directory TEMP di ScanMail per Microsoft Exchange contiene numerosi file
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per stabilire se è installata la versione 7.0 di Trend Micro ScanMail per Microsoft Exchange:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail di Exchange\CurrentVersion\Version

Exchange Server Analyzer Tool conta il numero di file presenti nella directory TEMP utilizzati da ScanMail per Microsoft Exchange. Per impostazione predefinita il percorso della directory TEMP utilizzata da ScanMail per Microsoft Exchange è la seguente:

C:\Programmi\Trend Micro\Smex\Temp

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • La versione 7.0 di ScanMail per Microsoft Exchange è installata.

  • Più di 100 file sono presenti nella directory TEMP utilizzata da ScanMail per Microsoft Exchange.

Questo messaggio indica la presenza di molti file nella directory TEMP utilizzata da ScanMail per Microsoft Exchange. I file presenti in questa cartella sono file temporanei utilizzati da ScanMail per Microsoft Exchange. ScanMail per Microsoft Exchange elimina questi file automaticamente.

Se sono presenti molti file con data precedente a quella corrente, Trend Micro consiglia di eliminare i file più vecchi.


La directory TEMP di ScanMail per Microsoft Exchange contiene un numero eccessivo di file
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la versione 7.0 di Trend Micro ScanMail per Microsoft Exchange è installata:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Se ScanMail per Microsoft Exchange versione 7 è installato, Exchange Server Analyzer legge la voce del Registro di sistema indicata di seguito per determinare la posizione della directory TEMP utilizzata da ScanMail per Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Quindi viene eseguito il conteggio del numero di file contenuti nella directory TEMP utilizzata da ScanMail per Microsoft Exchange.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • La versione 7.0 di ScanMail per Microsoft Exchange è installata.

  • Nella directory TEMP utilizzata da ScanMail per Microsoft Exchange sono presenti più di 100 file.

Questo avviso indica la presenza di un numero eccessivo di file nella directory TEMP utilizzata da ScanMail per Microsoft Exchange. I file in questa cartella sono file temporanei utilizzati da ScanMail per Microsoft Exchange. Si presuppone che ScanMail per Microsoft Exchange elimini automaticamente questi file.

Se è presente un numero eccessivo di file con data precedente a quella corrente, Trend Micro consiglia di eliminare i file meno recenti.


Percorso modificato della cartella temporanea di ScanMail per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la versione 7.0 di Trend Micro ScanMail per Microsoft Exchange è installata:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail di Exchange\CurrentVersion\Version

Exchange Server Analyzer legge la seguente voce per determinare la posizione della cartella temporanea utilizzata da ScanMail per Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Se il valore TempFolderPath è presente e configurato nel Registro di sistema, significa che la cartella temporanea utilizzata da ScanMail per Microsoft Exchange è stata spostata dalla sua posizione predefinita.

Infine, Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®)CIM_Datafile per determinare il valore della chiave Version per AdapterSMTP.dll. Tale modulo è compreso con ScanMail per Microsoft Exchange di Trend Micro. Un valore della chiave Version per AdapterSMTP.dll inferiore a 7.0.1366 indica che è richiesta una versione aggiornata di ScanMail per Microsoft Exchange.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • ScanMail per Microsoft Exchange versione 7 è installato.

  • La cartella temporanea utilizzata da ScanMail per Microsoft Exchange è stata spostata dalla posizione originaria.

  • La versione del file per AdapterSMTP.dlls è 7.0.1366 o precedente.

Trend Micro ha introdotto la possibilità di rilocare la cartella temporanea in build recenti di ScanMail per Microsoft Exchange. Questa funzionalità può essere eseguita soltanto su build successive alla versione 7.0.1366. Questo avviso indica che la cartella temporanea è stata rilocata, tuttavia la rilocazione non sarà effettiva poiché sul server è in esecuzione una build precedente di ScanMail per Microsoft Exchange che non supporta la rilocazione.

Per risolvere il problema

  1. Visitare il sito Web del Centro di aggiornamento di Trend Micro all'indirizzo http://www.trendmicro.com/download.

  2. Scaricare e installare tutti gli aggiornamenti necessari e consigliati di ScanMail per Microsoft Exchange.
Nota:
Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli URL sono soggetti a modifiche senza preavviso.


Ottimizzazione del percorso della cartella temporanea di ScanMail per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per stabilire se la versione 7.0 di ScanMail per Microsoft Exchange di Trend Micro è installata:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\Version

Exchange Server Analyzer legge inoltre la voce riportata di seguito per determinare la posizione della cartella temporanea utilizzata da ScanMail per Microsoft Exchange:

HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\TempFolderPath

Se il valore TempFolderPath è presente e configurato nel Registro di sistema, significa che la cartella temporanea utilizzata da ScanMail per Microsoft Exchange è stata spostata dal percorso predefinito.

Infine, Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per AdapterSMTP.dll. Tale modulo è incluso in ScanMail per Microsoft Exchange di Trend Micro.

Se le seguenti condizioni sono vere, verrà visualizzato un messaggio di configurazione ottimale:

  • La versione di ScanMail per Microsoft Exchange installata è la numero 7.

  • La cartella temporanea utilizzata da ScanMail per Microsoft Exchange si trova nella posizione predefinita originale.

  • La versione di AdapterSMTP.dll supporta il reindirizzamento della cartella temporanea utilizzata da ScanMail per Microsoft Exchange.

Nelle ultime build di ScanMail per Microsoft Exchange è stata introdotta una nuova funzione che consente di rilocare la cartella temporanea. Tale funzione è operativa solo nelle build successive alla 7.0.1366. Se si utilizza una build di ScanMail per Microsoft Exchange posteriore alla 7.0.1366, è consigliabile rilocare la cartella temporanea su un'unità più veloce.

Per rilocare la cartella temporanea

  1. Esaminare l'articolo della knowledge base Trend Micro "Can users change the location of the ScanMail for Exchange (SMEX) 7.0 temporary folder?" all'indirizzo (http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=26343 (informazioni in lingua inglese).

  2. Implementare le procedure illustrate nell'articolo in modo da riposizionare la cartella temporanea su un'unità più veloce.
Nota:
Le informazioni su siti Web di terze parti sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui ha bisogno. Gli URL sono soggetti a modifiche senza preavviso.


Disponibile aggiornamento di ScanMail per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-12-15

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per adapterSMTP.dll. Questo modulo è incluso in ScanMail per Microsoft Exchange Server da Trend Micro.

Se Exchange Server Analyzer rileva che il valore della chiave Version di adapterSMTP.dll è minore di 7.0.1366, verrà visualizzato un avviso.

L'avviso indica che ScanMail per Microsoft Exchange versione 7 è installato nel server di Exchange e che è disponibile un aggiornamento del software. Questo aggiornamento è consigliato e consente di migliorare le prestazioni e l'affidabilità complessive del server.

Per risolvere il problema

  1. Visitare la sezione aggiornamenti del sito Web Trend Micro all'indirizzo http://www.trendmicro.com/download/.

  2. Scaricare e installare gli aggiornamenti desiderati o consigliati di ScanMail per Microsoft Exchange.
Nota:
Le informazioni sui siti Web di terze parti vengono fornite per consentire di trovare le informazioni tecniche richieste. Gli URL sono soggetti a modifiche senza preavviso.


La ricerca di virus del trasporto SMTP non è abilitata
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se è impostato un valore per la chiave Started per il servizio SMSMSE (Symantec Mail Security per Microsoft Exchange) La classe Win32_Service determina se il servizio SMSMSE è installato nel computer Exchange Server 2003. Il valore True indica che il servizio SMSMSE è in esecuzione. Il valore False indica che il servizio SMSMSE non è in esecuzione. Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • Il servizio SMSMSE è installato sul computer Exchange Server 2003.

  • La ricerca di virus del trasporto SMTP non è abilitata.

In Exchange Server 2003 il motore di accodamento avanzato utilizza l'API antivirus del Trasporto di Exchange come uno dei sei eventi sink di trasporto per consegnare i messaggi a destinazione. L'evento sink API antivirus del Trasporto di Exchange è implementato in OnSubmit.dll e consente ai produttori non Microsoft, come Symantec, di implementare programmi antivirus che esaminano ogni messaggio alla ricerca di allegati nocivi e strutture di dati dannose prima che arrivino a destinazione. Questo evento è registrato per l'evento OnSubmission.

Per impostazione predefinita la ricerca di virus del trasporto non è attiva perché provoca la doppia scansione dei messaggi: una volta a livello SMTP e una volta nell'archivio di Exchange. Tuttavia, se si utilizzano server front-end per connettere un'organizzazione di Exchange a Internet, è possibile abilitare la ricerca di virus del trasporto in questi server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per abilitare la ricerca di virus del trasporto

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI.

  3. Creare un nuovo valore DWORD denominato Enabled. Assegnare il valore 1 al valore denominato Enabled.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Nota:
La funzionalità di analisi del trasporto è disponibile solo con programmi antivirus di Exchange basati sull'interfaccia VSAPI (Virus Scanning Application Programming Interface) 2.5.

Per ulteriori informazioni sull'architettura del trasporto SMTP, consultare la Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47891.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni Antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


È disponibile un aggiornamento di Simpler-Webb Exchange Resource Manager
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-04-14

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore impostato per la chiave Version di ERME2KAsyncSink.dll. Se Exchange Server Analyzer rileva che il valore di Version per ERME2KAsyncSink.dll è minore di 1015, verrà visualizzato un avviso.

Il file ERME2KAsyncSink.dll è un file binario principale per Simpler-Webb ERM (Exchange Resource Manager). Se la versione di ERME2KAsyncSink.dll è minore di 1015, significa che nel server è installato ERM 1.2 o una versione precedente. Esiste un problema conosciuto con ERM 1.2. Può succedere che la coda di recapito locale di Exchange arresti il recapito dei messaggi quando il database OLE DB di Exchange attende una chiamata di ritorno dall'evento sink ERM. Microsoft Exchange OLEDB è in attesa della restituzione del sink di evento ERME2KAsyncSink.dll dalla chiamata OnSyncSave, mentre è in corso l'arresto dell'archivio di Exchange.

Un errore nella restituzione da questa chiamata può impedire l'arresto dell'archivio di Exchange. Questo problema è stato risolto in ERM 1.35.

Per risolvere il problema

  1. Utilizzare Installazione applicazioni per rimuovere manualmente ERM 1.2.

  2. Installare ERM 1.35, disponibile sul sito Web di Simpler-Webb Web all'indirizzo http://www.swinc.com/products/ERM/upgrade/.

    Nota:
    Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


Disponibile aggiornamento di Sybari Antigen 7,5 per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se un file di libreria VSAPI (Virus Scanning Application Programming Interface) è registrato sull'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 7.5 per Microsoft Exchange è un prodotto Sybari. Quando Antigen 7.5 per Microsoft Exchange è installato su Exchange 2000 Server o Exchange Server 2003, la voce del Registro di sistema della libreria ha un valore di ANTIGENVSAPI.DLL. Questo file di libreria esegue numerose funzioni relative a VSAPI in Antigen 7.5 per Microsoft Exchange.

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per ANTIGENVSAPI.DLL. Se il valore per la chiave Version indica un numero build inferiore a 1316 per questo file, verrà visualizzato un avviso.

Un numero di versione inferiore a 1316 per ANTIGENVSAPI.DLL indica che la versione più recente di Antigen 7.5 per Microsoft Exchange non è installata. Un aggiornamento del software di Antigen 7.5 per Microsoft Exchange è disponibile sul sito Web Sybari. Questo aggiornamento è consigliato e consente di migliorare le prestazioni e l'affidabilità generali.

Per risolvere il problema

  1. Visitare il sito Web Sybari "Licensed Download Center" all'indirizzo http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi al sito Web citato in questo documento.

  2. Scaricare gli aggiornamenti più recenti per la versione in uso di Antigen 7.5 per Microsoft Exchange.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Scaricare gli aggiornamenti più recenti per Antigen 7.5 per Microsoft Exchange.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Disponibile aggiornamento di Sybari Antigen 8,0 per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-01-09

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se un file di libreria VSAPI (Virus Scanning Application Programming Interface) è registrato sull'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Antigen 8.0 per Microsoft Exchange è un prodotto Sybari. Quando Antigen 8.0 per Microsoft Exchange viene installato in Exchange 2000 Server o Exchange Server 2003, la voce del Registro di sistema della libreria avrà il valore ANTIGENVSAPIEx.DLL. Questo file di libreria esegue numerose funzioni relative a VSAPI in Antigen 8.0 per Microsoft Exchange.

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per ANTIGENVSAPI.DLL. Se il valore per la chiave Version indica un numero build inferiore a 1517 per questo file, verrà visualizzato un avviso.

Un numero di versione inferiore a 1517 per ANTIGENVSAPI.DLL indica che la versione più recente di Antigen 8.0 per Microsoft Exchange non è installata. Un aggiornamento del software di Antigen 8.0 per Microsoft Exchange è disponibile sul sito Web Sybari. Questo aggiornamento è consigliato e consente di migliorare le prestazioni e l'affidabilità generali.

Per risolvere il problema

  1. Visitare il sito Web Sybari "Licensed Download Center" all'indirizzo http://www.sybari.com/portal/alias__Rainbow/lang__en-US/tabID__3359/DesktopDefault.aspx (informazioni in lingua inglese).

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi al sito Web citato in questo documento.

  2. Scaricare gli aggiornamenti più recenti per la versione in uso di Antigen 8.0 per Microsoft Exchange.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Installare gli aggiornamenti più recenti per Antigen 8.0 per Microsoft Exchange.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Sybari Antigen è installato nel server di Exchange ma il servizio AntigenStore non è in esecuzione
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se Sybari Antigen è installato e se il servizio AntigenStore è in esecuzione sul computer che esegue Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il valore stabilito per la chiave Started nel servizio Archivio informazioni di Microsoft Exchange è impostato su True o False.

Il valore False indica che il servizio Archivio informazioni di Microsoft Exchange non è attivo su questo computer che esegue Exchange Server. Il valore True indica che il servizio Archivio informazioni di Microsoft Exchange è attivo.

Se Exchange Server Analyzer rileva che il servizio Archivio informazioni di Microsoft Exchange è in esecuzione e Sybari Antigen è installato ma il servizio AntigenStore non è stato avviato, verrà visualizzato un avviso.

Sybari Antigen offre una protezione antivirus per Exchange Server. Di seguito vengono elencati alcuni motivi per cui il servizio Sybari AntigenStore potrebbe essere stato arrestato e vengono fornite le relative soluzioni.

  • Il software eseguito nel server di Exchange può essere una versione di prova o di valutazione scaduta. In questo caso, potrebbe essere necessario reinstallare Sybari Antigen. Per continuare a utilizzare il software, è almeno necessario attivarlo.

  • Un amministratore potrebbe aver arrestato inavvertitamente il servizio Sybari Antigen. Verificare che il servizio sia impostato per l'esecuzione automatica, quindi avviare il servizio.

  • Un worm, un virus o un altro programma dannoso potrebbe aver arrestato il servizio. Verificare che il servizio sia impostato per l'esecuzione automatica e avviare il servizio. Se continua a verificarsi l'arresto improvviso del servizio senza eventi di errore rilevanti, verificare che il computer non sia stato infettato da un worm dannoso e, se necessario, disinfettare il sistema.

Generalmente si consiglia di distribuire un software antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) oppure nei server di Exchange che ospitano cassette postali. Per una protezione massima, eseguire il software antivirus nel gateway che esegue l'analisi dei messaggi MIME in arrivo ed eseguire un'analisi del server di Exchange che utilizza VSAPI 2.5. Inoltre, è consigliabile eseguire un software antivirus client nel PC dell'utente. Se si esegue un software antivirus progettato per sistemi di messaggistica (in grado di analizzare ed effettuare l'analisi di contenuto MIME) nel gateway oppure nel server di Exchange, è sufficiente eseguire un'analisi del PC a livello di file.

Per avviare il servizio AntigenStore

  1. Aprire lo snap-in Servizi MMC.

  2. Fare clic con il pulsante destro del mouse sul servizio AntigenStore e scegliere Proprietà.

  3. Nella scheda Generale della pagina delle proprietà di AntigenStore accertarsi che l'opzione Tipo di avvio sia impostata su Automatico. Nel caso non lo sia, impostarlo su Automatico, fare clic su Applica, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio AntigenStore, quindi scegliere Start.

  5. Chiudere lo snap-in Servizi MMC.

Per ulteriori informazioni su come aumentare il livello di protezione di un ambiente Exchange contro virus e worm trasmessi tramite messaggi di posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Sybari Antigen è installato nel server di Exchange ma il servizio è stato arrestato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se Sybari Antigen è installato e se il servizio AntigenService è in esecuzione sul computer che esegue Exchange Server.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il valore stabilito per la chiave Started nel servizio Archivio informazioni di Microsoft Exchange è impostato su True o False.

Il valore False indica che il servizio Archivio informazioni di Microsoft Exchange non è attivo su questo computer che esegue Exchange Server. Il valore True indica che il servizio Archivio informazioni di Microsoft Exchange è attivo.

Se Exchange Server Analyzer rileva che il servizio Archivio informazioni di Microsoft Exchange è in esecuzione e Sybari Antigen è installato ma il servizio AntigenService non è stato avviato, verrà visualizzato un avviso.

Sybari Antigen offre una protezione antivirus per Exchange Server. Di seguito vengono indicati alcuni motivi per cui il servizio Sybari Antigen potrebbe essere stato arrestato e vengono fornite le relative soluzioni:

  • Il software eseguito nel server di Exchange può essere una versione di prova o di valutazione scaduta. In questo caso, potrebbe essere necessario reinstallare Sybari Antigen. Per continuare a utilizzare il software, è almeno necessario attivarlo.

  • Un amministratore potrebbe aver arrestato inavvertitamente il servizio Sybari Antigen. Verificare che il servizio sia impostato per l'esecuzione automatica, quindi avviare il servizio.

  • Un worm, un virus o un altro programma dannoso potrebbe aver arrestato il servizio. Verificare che il servizio sia impostato per l'esecuzione automatica e avviare il servizio. Se continua a verificarsi l'arresto improvviso del servizio senza eventi di errore rilevanti, verificare che il computer non sia stato infettato da un worm dannoso e, se necessario, disinfettare il sistema.

Generalmente si consiglia di distribuire un software antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) oppure nei server di Exchange che ospitano cassette postali. Per una protezione massima, eseguire il software antivirus nel gateway che esegue l'analisi dei messaggi MIME in arrivo ed eseguire un'analisi del server di Exchange che utilizza VSAPI 2.5. Inoltre, è necessario eseguire il software antivirus sui computer client. Se si esegue un software antivirus progettato per sistemi di messaggistica (in grado di analizzare ed effettuare l'analisi di contenuto MIME) nel gateway oppure nel server di Exchange, è sufficiente eseguire un'analisi del PC a livello di file.

Per avviare il servizio AntigenService

  1. Aprire lo snap-in Servizi MMC.

  2. Fare clic con il pulsante destro del mouse sul servizio AntigenService e scegliere Proprietà.

  3. Nella scheda Generale della pagina delle proprietà di AntigenService accertarsi che l'opzione Tipo di avvio sia impostata su Automatico. Nel caso non lo sia, impostarlo su Automatico, fare clic su Applica, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio AntigenService, quindi scegliere Start.

  5. Chiudere lo snap-in Servizi MMC.
  • Per informazioni sulla protezione di un ambiente Exchange Server da virus e worm trasmessi tramite posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Le definizioni di Symantec Antivirus non sono state aggiornate da più di 30 giorni
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se le seguenti condizioni sono vere:

  • Il software antivirus Symantec è installato nel server.

  • I seguenti file delle definizioni antivirus sono aggiornati:

    HKEY_LOCAL_MACHINE\Software\Symantec\SharedDefs\MicroDefs

Se Exchange Server Analyzer rileva che il valore della chiave BinHubStamp del Registro di sistema non è stato aggiornato da più di 30 giorni, verrà visualizzato un avviso.

Il software antivirus Symantec per Microsoft Exchange Server offre una protezione antivirus per Exchange Server. È consigliabile scaricare le definizioni antivirus più recenti di Symantec non appena vengono pubblicate. Assicurarsi di distribuire l'aggiornamento delle definizioni antivirus ai seguenti livelli dell'organizzazione:

  • Server gateway messaggi

  • Server di Exchange

  • Workstation client

Per scaricare le definizioni dei virus più aggiornate, consultare il sito Web di Symantec "Symantec home page" all'indirizzo http://www.symantec.com.

Per informazioni sulla protezione di un ambiente Exchange Server da virus e worm trasmessi tramite posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Symantec Antivirus è installato nel server di Exchange ma il servizio è stato arrestato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se è stato impostato un valore per la chiave Started. La classe Win32_Service determina se Symantec Antivirus per Exchange Server è installato. Il valore True nella chiave Started indica che il servizio Symantec Antivirus è in esecuzione sul computer Exchange Server. Il valore False nella chiave Started indica che il servizio Symantec Antivirus non è in esecuzione sul computer Exchange Server.

Se Exchange Server Analyzer rileva che Symantec Antivirus è installato nel computer di Exchange Server ma che il servizio non è avviato, verrà visualizzato un avviso.

Symantec Antivirus offre una protezione antivirus per Exchange Server. Di seguito sono elencati alcuni problemi (con la relativa soluzione) che potrebbero provocare l'arresto del servizio Symantec Antivirus.

  • Il software eseguito sul server di Exchange può essere una versione di prova o di valutazione scaduta. In questo caso, potrebbe essere necessario reinstallare Symantec Antivirus. Per continuare a utilizzare il software, è almeno necessario attivarlo.

  • Un amministratore potrebbe aver arrestato inavvertitamente il servizio Symantec Antivirus. Verificare che il servizio sia impostato per l'esecuzione automatica, quindi avviare il servizio.

  • Un worm, un virus o un altro programma dannoso potrebbe aver arrestato il servizio. Verificare che il servizio sia impostato per l'esecuzione automatica e avviare il servizio. Se continua a verificarsi l'arresto improvviso del servizio senza eventi di errore rilevanti, verificare che il computer non sia stato infettato da un worm dannoso e, se necessario, disinfettare il sistema.

Si consiglia di distribuire un software antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) oppure nei server di Exchange che ospitano cassette postali. Per una protezione massima, eseguire il software antivirus nel gateway che esegue l'analisi dei messaggi MIME in arrivo ed eseguire un'analisi del server di Exchange che utilizza VSAPI 2.5.

Per avviare il servizio Symantec Antivirus

  1. Aprire lo snap-in Servizi MMC.

  2. Fare clic con il pulsante destro del mouse sul servizio Symantec Antivirus e scegliere Proprietà.

  3. Nella scheda General della pagina delle proprietà di Symantec Antivirus verificare che l'opzione Start-up type sia impostata su Automatic. In caso contrario, fare clic su Apply, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio Symantec Antivirus e scegliere Start.

  5. Chiudere lo snap-in Servizi.

Inoltre, è consigliabile eseguire un software antivirus client sul PC dell'utente. Un'analisi a livello dei file sul PC offre una protezione sufficiente se si verifica una delle seguenti condizioni:

  • Si esegue un programma antivirus progettato per i sistemi di messaggistica in grado di eseguire l'analisi e la scansione dei messaggi MIME sul gateway.

  • Si esegue un programma antivirus progettato per i sistemi di messaggistica in grado di eseguire l'analisi e la scansione dei messaggi MIME sul server di Exchange.

Per ulteriori informazioni sui diversi tipi di programmi antivirus solitamente utilizzati con Microsof Exchange Server 2003, consultare l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

Per ulteriori informazioni sui diversi tipi di programmi antivirus solitamente utilizzati con Microsoft Exchange 2000 Server, consultare l'articolo 328841della Microsoft Knowledge Base "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

Per ulteriori informazioni su come aumentare il livello di protezione di un ambiente Exchange Server contro virus e worm trasmessi tramite messaggi di posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.


Avvisi di configurazione per la scansione antivirus di Symantec Mail Security per Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore impostato per la chiave Started per il servizio SMSMSE (Symantec Mail Security per Microsoft Exchange).

Il valore True indica che Symantec Mail Security per Microsoft Exchange Server è installato in quyesto computer Exchange Server e che il servizio SMSMSE è in esecuzione. Il valore False indica che il servizio SMSMSE non è in esecuzione.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il valore stabilito per la chiave Started nel servizio Archivio informazioni di Microsoft Exchange è impostato su True o False.

Il valore False indica che il servizio Archivio informazioni di Microsoft Exchange non è attivo su questo computer che esegue Exchange Server. Il valore True indica che il servizio Archivio informazioni di Microsoft Exchange è attivo.

Se Exchange Server Analyzer rileva che il servizio Archivio informazioni di Microsoft Exchange è in esecuzione e che Symantec Mail Security per Microsoft Exchange è installato, ma il servizio SMSMSE non è stato avviato, verrà visualizzato un avviso.

Una delle principali minacce all'ambiente informatico sono i virus trasmessi tramite i messaggi di posta elettronica. I virus della posta elettronica possono attaccare lo stesso sistema informatico oppure l'ambiente di posta elettronica, inondando il sistema di messaggi fino a sovraccaricarlo. È necessario assicurarsi di disporre di una sufficiente protezione antivirus. È possibile decidere di proteggersi dagli attacchi dei virus dal firewall, al gateway SMTP o all'esterno del gateway, in ogni server di Exchange e in ogni client.

Per risolvere il problema

  1. Avviare lo snap-in Servizi di Windows sul computer in cui è installato Exchange Server.

  2. Nel riquadro destro scorrere fino a visualizzare il servizio Symantec Mail Security per Microsoft Exchange, quindi fare doppio clic su di esso.

  3. Assicurarsi che il valore nel menu a discesa Tipo di avvio sia impostato su Automatico.

  4. Scegliere Avvia per avviare il servizio Symantec Mail Security per Microsoft Exchange.

  5. Fare clic su OK per salvare le modifiche e per chiudere la finestra di dialogo Proprietà, quindi uscire dallo snap-in.

Per ulteriori informazioni su come aumentare il livello di protezione di un ambiente Exchange contro virus e worm trasmessi tramite messaggi di posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Aggiornamento di Symantec Mail Security for Microsoft Exchange 4.5 disponibile
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-02-14

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per Savfmsevsapi.dll. Se il valore per la chiave Version indica che il numero di build per questo file è 4.5, verrà visualizzato un avviso.

Un numero di versione pari a 4.5 per Savfmsevsapi.dll indica che non è in esecuzione la versione più recente di Symantec Mail Security for Microsoft Exchange 4.6x. L'aggiornamento del software di Symantec Mail Security for Microsoft Exchange 4.6x è disponibile nel sito Web di Symantec. Si consiglia di eseguire l'aggiornamento alla versione 4.63 o a versioni successive per migliorare le prestazioni e l'affidabilità generali.

Di seguito sono riportati alcuni problemi noti che possono verificarsi durante l'esecuzione della versione 4.5 di Savfmsevsapi.dll.

  • Nei processi del flusso di posta del server di Exchange può verificarsi una riduzione delle prestazioni durante le normali operazioni.

  • Viene eseguito il backup delle code SMTP, ad esempio della coda di individuazione della directory e della coda di recapito locale.

  • Non è possibile arrestare il servizio Archivio informazioni di Microsoft Exchange.

  • I client Microsoft Outlook® non sono in grado di eseguire la connessione al server di Exchange.

  • Il recapito dei messaggi inviati da client Outlook al server di Exchange richiede un periodo di tempo eccessivo. I client Outlook potrebbero non rispondere per 30 secondi.

Per risolvere il problema

  1. Visitare la pagina Supporto enterprise del sito Web di Symantec all'indirizzo http://www.symantec.com/techsupp/enterprise/.

  2. Eseguire l'aggiornamento alla versione 4.63 o a una versione successiva.
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita.
Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni sull'utilizzo del software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166

  • 306105, XGEN: Posizione di Microsoft sulle soluzioni Antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822

Per visualizzare un elenco dei software antivirus di terze parti disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Disponibile aggiornamento di Trend Micro ScanMail per Microsoft Exchange
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-01-09

Microsoft® Exchange Server Analyzer Tool legge il seguente valore del Registro di sistema per determinare se un file di libreria VSAPI (Virus Scanning Application Programming Interface) è registrato con sull'Archivio informazioni di Microsoft Exchange:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Library

Quando ScanMail per Microsoft Exchange, un prodotto Trend Micro, viene installato in Exchange 2000 Server o su Exchange Server 2003, la voce del Registro di sistema della libreria avrà il valore SMXS3DLL.DLL. Questo file di libreria esegue numerose funzioni relative a VSAPI in ScanMail per Microsoft Exchange.

Microsoft® Exchange Server Analyzer esegue anche una query nella CIM_Datafileclasse WMI (Strumentazione gestione Windows®) per determinare il valore della chiave Version per SMXS3DLL.DLL. Se il valore per la chiave Version indica un numero build inferiore a 1174 per questo file, verrà visualizzato un avviso.

Un numero di versione inferiore a 1174 per SMXS3DLL.DLL indica che la versione più recente di ScanMail per Microsoft Exchange non è installata. Un aggiornamento del software di ScanMail per Microsoft Exchange è disponibile sul sito Web Trend Micro. Questo aggiornamento è consigliato e consente di migliorare le prestazioni e l'affidabilità generali.

Per risolvere il problema

  1. Visitare il sito Web Trend Micro, alla pagina "Update Center, ScanMail for Microsoft Exchange" all'indirizzo http://www.trendmicro.com/download/product.asp?productid=8.

  2. Scaricare gli aggiornamenti più recenti per la versione di ScanMail per Microsoft Exchange utilizzata.

  3. Eseguire un backup completo del computer Exchange Server.

  4. Scaricare gli aggiornamenti più recenti per ScanMail per Microsoft Exchange.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Trend Micro ServerProtect per Microsoft Windows interrotto
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio SpntSvc. Il servizio SpntSvc è installato da ServerProtect for Microsoft Windows, che è un prodotto Trend Micro. Il valore True della chiave Started indica che il servizio è in esecuzione, mentre il valore False indica che il servizio non è in esecuzione. Se Exchange Server Analyzer rileva il mancato avvio del servizio SpntSvc, verrà visualizzato un avviso.

ServerProtect for Microsoft Windows offre una ricerca di virus per server basato su file system, che include il rilevamento e la rimozione dei virus in tempo reale.

Per avviare il servizio SpntSvc

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio ServerProtect Server e fare clic su Proprietà.

  3. Sulla scheda General della pagina delle proprietà di ServerProtect Server , verificare che l'opzione Start-up type sia impostata su Automatic. Nel caso non lo sia, impostarlo su Automatic, fare clic su Apply, quindi su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio ServerProtect Server e fare clic su Start.

  5. Aprire lo snap-in Servizi.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Configurazione di Trend ScanMail: le prestazioni possono essere migliorate
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-09-05

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del registro di sistema per determinare il valore di TempFileThreshold:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Il valore del registro di sistema TempFileThreshold si applica all'analisi del corpo del messaggio e dell'allegato. Se la dimensione del messaggio o dell'allegato è superiore al valore specificato nella chiave TempFileThreshold, il file temporaneo verrà creato sul disco. In caso contrario, verrà creato in memoria. Il valore predefinito di TempFileThreshold è 3.072 kilobyte (3 MB).

Microsoft Exchange Server Analyzer Tool esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore impostato per la chiave TotalPhysicalMemory. Questo valore rappresenta la quantità di memoria RAM (Random Access Memory) installata nel computer.

Microsoft Exchange Server Analyzer Tool esegue anche una query nel servizio directory di Active Directory® per determinare il valore relativo all'attributo delivContLength delle impostazioni globali che si trova in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= OrganizationName , CN=Global Settings, CN=Message Delivery

Questo attributo rappresenta la dimensione massima dei messaggi SMTP in arrivo.

Se Microsoft Exchange Server Analyzer Tool rileva che il valore di TempFileThreshold è inferiore al 70% della dimensione massima dei messaggi in arrivo in un computer Exchange Server con almeno 1 GB di RAM, verrà visualizzato un avviso.

Questo avviso indica che il valore del Registro di sistema TempFileThreshold potrebbe non essere stato ottimizzato per il proprio ambiente. Questo valore dovrebbe essere impostato in modo che sia almeno uguale al limite di dimensione dell'allegato impostato nei server di Exchange.

Nota:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di conoscere le operazioni per ripristinarlo qualora si verifichi un problema. Per informazioni su questa procedura, vedere l'argomento della Guida relativo al ripristino del registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del registro di sistema, quale Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. Nel riquadro destro fare doppio clic su TempFileThreshold.

  4. Immettere un valore in kilobyte pari alla dimensione media per i messaggi nell'organizzazione. Ad esempio, se la dimensione media per i messaggi è 10 MB, immettere 10240.
Nota:
Se il valore viene aumentato, potrebbe essere necessaria ulteriore memoria di sistema. Se ad esempio il valore di ScanningThreads è impostato su 8 e il valore di TempFileThreshold è impostato su 10240, la memoria minima necessaria per la ricerca di virus sarà 80 MB, ovvero ScanningThreads * TempFileThreshold.
  1. Chiudere l'editor del registro di sistema e riavviare il servizio ScanMail_RealTimeScan e il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Configurazione di Trend ScanMail: il valore QuerySender del Registro di sistema è abilitato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-04-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio ScanMail_Action di Trend Micro ScanMail per Microsoft Exchange. Il valore True indica che il servizio ScanMail_Action è in esecuzione, al contrario, il valore False indica che il servizio non è in esecuzione.

Inoltre, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se ScanMail per Microsoft Exchange è configurato per le ricerche con caratteri jolly nel servizio di directory di Active Directory®:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\QuerySender

Il valore 0 per la voce del Registro di sistema QuerySender indica che le ricerche con caratteri jolly sono disabilitate. Il valore 1 per la voce QuerySender del Registro di sistema indica che le ricerche con caratteri jolly sono abilitate.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer determina che il servizio ScanMail_Action è in esecuzione, che il server Exchange contiene più di 100 cassette postali e che la voce QuerySender del Registro di sistema non è impostata su 0, verrà visualizzato un avviso.

Trend Micro ScanMail per Microsoft Exchange offre protezione antivirus per Exchange Server. Quando ScanMail per Exchange analizza un messaggio inviato a una lista di distribuzione, per impostazione predefinita, viene eseguita una query nel catalogo globale di Active Directory per tutti i destinatari del messaggio. Se nella lista di distribuzione è presente un elevato numero di destinatari, questo comportamento può provocare problemi di esecuzione. Inoltre, i valori dei seguenti contatori di prestazioni risulteranno alti, se non vengono implementate le raccomandazioni in questo articolo:

  • MSExchangeIS/Lunghezza coda ricerca virus

  • MSExchangeIS/Richieste RPC

  • MSExchangeIS/Latenza media RPC

Se si imposta il valore QuerySender su 0 si impedisce a ScanMail per Microsoft Exchange di eseguire una query nel catalogo globale per tutti i destinatari quando si analizzano i messaggi inviati alle liste di distribuzione.

Per risolvere il problema

  1. Consultare Trend Micro per informazioni sull'utilizzo del valore QuerySender del Registro di sistema all'indirizzo http://www.trendmicro.com/en/about/overview.htm.

  2. Per ulteriori informazioni sul valore QuerySender del Registro di sistema, consultare l'ID 120393 delle soluzioni Trend Micro all'indirizzo http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-120393.

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per informazioni sulla protezione di un ambiente Exchange Server da virus e worm trasmessi tramite posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).


Configurazione di Trend ScanMail: servizio ScanMail_Monitor non dipendente dal servizio cluster
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema su ciascun server che corrisponde a un nodo cluster:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail di Exchange\CurrentVersion\Version

Un valore di Version pari a 6.2.000 indica che è installata la versione 6.2 di ScanMail for Microsoft Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster (ClusSvc). Il valore True indica che il servizio cluster è in esecuzione, mentre il valore False indica che il servizio non è in esecuzione.

Exchange Server Analyzer legge inoltre la seguente voce del Registro di sistema su ciascun server che corrisponde a un nodo cluster:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ScanMail_Monitor

Se rileva che la chiave ScanMail_Monitor non include la voce multivalore DependOnService del Registro di sistema con un valore di ClusSvc, significa che il servizio ScanMail_Monitor non dipende dal servizio cluster.

Se le seguenti condizioni sono vere, in Exchange Server Analyzer verrà visualizzato un messaggio di avviso:

  • Sul server è in esecuzione la versione 6.2 di TrendMicro ScanMail for Microsoft Exchange.

  • Sul server è in esecuzione il servizio cluster (ClusSvc).

  • Il servizio ScanMail_Monitor non è configurato per dipendere dal servizio cluster.

Dopo aver installato le build di ScanMail for Microsoft Exchange 6.2, è necessario configurare il servizio ScanMail_Monitor in modo che dipenda dal servizio cluster. Se non è configurata tale dipendenza, il servizio cluster interromperà la risposta ogni volta che il nodo viene riavviato.

Per risolvere il problema

  1. Consultare l'articolo "The Microsoft Exchange Cluster Service unexpectedly stops after applying ScanMail for Exchange (SMEX) 6.2 Patch 1" [ID soluzione: 21441] sul sito Web di Trend Micro all'indirizzo http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionId=21441&id=21441 (informazioni in lingua inglese).

    Nota:
    Questo articolo fa riferimento in particolare alla necessità di configurare questa dipendenza dopo l'installazione della patch 1. Tuttavia, può essere applicato ai server che eseguono qualsiasi build di ScanMail for Microsoft Exchange 6.2.

  2. Aggiungere il valore multistringa DependOnService al Registro di sistema come specificato nella sezione "Solutions" dell'articolo con ID soluzione 21441.
Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.

Per ulteriori informazioni su aggiornamenti di altri prodotti Trend Micro, consultare la sezione aggiornamenti del sito Web Trend Micro all'indirizzo http://www.trendmicro.com/download/.

Per ulteriori informazioni sull'utilizzo del software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, XGEN: Posizione di Microsoft sulle soluzioni Antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105

  • 245822, "Raccomandazioni per la risoluzione dei problemi su computer Exchange con software antivirus installato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822

Per visualizzare un elenco dei software antivirus di terze parti disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Configurazione di Trend ScanMail: il valore del Registro di sistema SkipWildcardSearchInGC è impostato su 0
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio ScanMail_Action di Trend Micro ScanMail per Microsoft Exchange. Il valore True indica che il servizio ScanMail_Action è in esecuzione, al contrario, il valore False indica che il servizio non è in esecuzione.

Inoltre, Exchange Server Analyzer legge la seguente voce del Registro di sistema per determinare se ScanMail per Microsoft Exchange è configurato per le ricerche con caratteri jolly nel servizio di directory di Active Directory®:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion\SkipWildcardSearchInGC

Il valore 1 per la voce del Registro di sistema SkipWildcardSearchInGC indica che le ricerche con caratteri jolly sono disabilitate. Il valore 0 per la voce del Registro di sistema SkipWildcardSearchInGC indica che le ricerche con caratteri jolly sono disabilitate.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer determina che il servizio ScanMail_Action è in esecuzione, che il server di Exchange contiene più di 100 cassette postali e che la voce del Registro di sistema SkipWildcardSearchInGC è impostata su 0, verrà visualizzato un avviso.

Trend Micro ScanMail per Microsoft Exchange offre protezione antivirus per Exchange Server. Se si imposta il valore di SkipWildcardSearchInGC su 1 si impedisce a ScanMail per Microsoft Exchange di risolvere un nome contenente un carattere jolly (*). Se si ricerca un nome con un carattere jolly è possibile rallentare notevolmente le prestazioni del computer Exchange Server poiché ScanMail per Exchange controllerà l'intera directory. Inoltre, i valori dei seguenti contatori di prestazioni risulteranno alti, se non vengono implementate le raccomandazioni in questo articolo:

  • MSExchangeIS/Lunghezza coda ricerca virus

  • MSExchangeIS/Richieste RPC

  • MSExchangeIS/Latenza media RPC

Per risolvere il problema

  1. Consultare Trend Micro per informazioni sull'utilizzo del valore SkipWildcardSearchInGC del Registro di sistema all'indirizzo http://www.trendmicro.com/en/about/overview.htm.

  2. Per ulteriori informazioni sul valore SkipWildcardSearchInGC del Registro di sistema, consultare l'ID 20393 delle soluzioni Trend Micro all'indirizzo http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=20393.

    Nota:
    Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per informazioni sulla protezione di un ambiente Exchange Server da virus e worm trasmessi tramite posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).


Configurazione di Trend ScanMail: il valore del Registro di sistema MaxMessageCount è minore di 500
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore di MaxMessageCount:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il conteggio delle voci elencate nell'attributo homeMDBBL di ciascun archivio delle cassette postali. Il conteggio di questo attributo rappresenta il numero di cassette postali presenti nell'archivio.

Se Exchange Server Analyzer determina che il server di Exchange contiene più di 100 cassette postali e che il valore di MaxMessageCount è inferiore a 500, verrà visualizzato un avviso.

Trend Micro ScanMail per Microsoft Exchange offre protezione antivirus per Exchange Server. Quando viene terminata un'attività del del thread di ricerca di ScanMail per Exchange, i risultati della ricerca vengono scritti in una coda. Se in tale coda sono presenti troppi elementi, è necessario attendere che il thread di ricerca scriva nella coda prima di rilasciarlo. La soglia per la dimensione della coda dei risultati della ricerca viene controllata da MaxMessageCount. Se si imposta il valore di MaxMessageCount su 500, si ottimizzano le prestazioni di ScanMail per Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\TrendMicro\ScanMail for Exchange\CurrentVersion

  3. Nel riquadro destro fare doppio clic su MaxMessageCount.

  4. Immettere il valore 500 (decimale).

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio ScanMail_RealTimeScan e il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'utilizzo del valore MaxMessageCount del Registro di sistema, consultare il sito Web di Trend Micro all'indirizzo http://it.trendmicro-europe.com/.

Nota:
Gli indirizzi Web possono cambiare, pertanto potrebbe non essere possibile connettersi a uno o più siti Web citati in questo documento.

Per informazioni sulla protezione di un ambiente Exchange Server da virus e worm trasmessi tramite posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).


Trend ScanMail è configurato in modo da eliminare tutti i file allegati
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge varie voci del Registro di sistema per determinare se ScanMail per Microsoft Exchange è configurato per eliminare gli allegati. Il percorso dei valori letti nel Registro di sistema è:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Valore | Descrizione
ActionType | Indica gli allegati da bloccare, se il blocco degli allegati è attivato. Il valore 0 indica che tutti gli allegati sono bloccati. Il valore 3 indica che l'amministratore ha specificato un elenco di estensioni di file, nomi file o tipi di file true. È possibile configurare questa impostazione selezionando l'opzione appropriata nella finestra di dialogo Attachment Blocking Settings in ScanMail Management Console.
EnableAlert | Indica se il blocco degli allegati è abilitato. Il valore 1 indica che il blocco degli allegati è abilitato. Il valore 0 indica che è disabilitato. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable attachment blocking nella pagina Virus Scan | Options di ScanMail Management Console.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Valore | Descrizione
EnableEManager | Indica se ScanMail eManager è abilitato. Il valore 1 indica che eManager è abilitato. Il valore 0 indica che è disabilitato. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable eManager nella ScanMail Management Console. L'impostazione è disponibile solo quando viene installato ScanMail eManager, un prodotto complementare separato.
EnableWebStoreDelMail | Indica se il filtro messaggi attivi di ScanMail è abilitato per i messaggi in ingresso. Il valore 1 indica che il filtro messaggi attivi è abilitato per i messaggi in ingresso. Il valore 0 indica che non è abilitato per i messaggi in ingresso. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Inbound Messages nella finestra di dialogo Active Message Filter in ScanMail Management Console.

Exchange Server Analyzer, inoltre, legge la seguente voce del Registro di sistema per determinare se è abilitata la ricerca dei messaggi VSAPI (Virus Scanning API):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Il valore 1 per Enabled indica che la ricerca VSAPI è abilitata. Il valore 0 indica che la ricerca VSAPI non è abilitata. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable VS API virus scanning nella pagina Virus Scan | Options di ScanMail Management Console.

Se Exchange Server Analyzer rileva che tutti i criteri seguenti sono veri, verrà visualizzato un avviso:

  • La ricerca VSAPI viene abilitata in ScanMail per Microsoft Exchange

  • EnableAlert presenta il valore 1

  • ActionType presenta il valore 0

  • EnableEManager presenta il valore 1

  • EnableWebStoreDelMail presenta il valore 1

Questo avviso indica che ScanMail è configurato per eliminare tutti gli allegati durante la successiva analisi pianificata o manuale.

Per risolvere il problema

  1. Verificare che gli allegati siano effettivamente da eliminare.

  2. Se si desidera, disabilitare il blocco degli allegati o modificare l'azione da Delete a Quarantine. Questa operazione consente a un amministratore di esaminare i file messi in quarantena relativi agli allegati che potrebbe essere necessario conservare.

Per ulteriori informazioni su ScanMail per Microsoft Exchange e ScanMail eManager, visitare il sito Web Trend Micro all'indirizzo http://www.trend.com.

Nota:
Gli indirizzi Web possono cambiare, pertanto potrebbe non essere possibile connettersi a uno o più siti Web citati in questo documento.


Trend ScanMail è configurato in modo da eliminare allegati con determinati nomi di file
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge varie voci del Registro di sistema per determinare se ScanMail per Microsoft Exchange è configurato per eliminare gli allegati. Il percorso dei valori letti nel Registro di sistema è:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Valore | Descrizione
ActionType | Indica gli allegati da bloccare, se il blocco degli allegati è attivato. Il valore 0 indica che tutti gli allegati sono bloccati. Il valore 3 indica che l'amministratore ha specificato un elenco di estensioni di file, nomi file o tipi di file true. È possibile configurare questa impostazione selezionando l'opzione desiderata nella finestra di dialogo delle impostazioni di blocco degli allegati Attachment Blocking Settings in ScanMail Management Console.
EnableAlert | Indica se il blocco degli allegati è abilitato. Il valore 1 indica che il blocco degli allegati è abilitato. Il valore 0 indica che è disabilitato. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable attachment blocking nella pagina Virus Scan | Options di ScanMail Management Console.
FileName | Una stringa delimitata da punto e virgola contenente un elenco di file da eliminare. Quando vengono bloccati i file specificati, è possibile configurare queste impostazioni immettendo i nomi di file desiderati nella finestra di dialogo Attachment Blocking Settings in ScanMail Management Console.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Valore | Descrizione
EnableEManager | Indica se ScanMail eManager è abilitato. Il valore 1 indica che eManager è abilitato. Il valore 0 indica che è disabilitato. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable eManager nella ScanMail Management Console. L'impostazione è disponibile solo quando viene installato ScanMail eManager, un prodotto complementare separato.
EnableWebStoreDelMail | Indica se il filtro messaggi attivi di ScanMail è abilitato per i messaggi in ingresso. Il valore 1 indica che il filtro messaggi attivi è abilitato per i messaggi in ingresso. Il valore 0 indica che non è abilitato per i messaggi in ingresso. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Inbound Messages nella finestra di dialogo Active Message Filter in ScanMail Management Console.

Exchange Server Analyzer, inoltre, legge la seguente voce del Registro di sistema per determinare se l'analisi dei messaggi VSAPI (Virus Scanning API) è abilitata:

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Il valore 1 per Enabled indica che la ricerca VSAPI è abilitata. Il valore 0 indica che la ricerca VSAPI non è abilitata. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable VS API virus scanning nella pagina Virus Scan | Options di ScanMail Management Console.

Se Exchange Server Analyzer rileva che tutti i criteri seguenti sono veri, verrà visualizzato un avviso:

  • La ricerca VS API viene abilitata in ScanMail per Exchange

  • EnableAlert presenta il valore 1

  • ActionType presenta il valore 3

  • EnableEManager presenta il valore 1

  • EnableWebStoreDelMail presenta il valore 1

  • FileName è null o vuoto

Questo avviso indica che ScanMail è configurato in modo da eliminare tutti gli allegati con i nomi elencati dalla chiave FileName durante la successiva analisi pianificata o manuale.

Per risolvere il problema

  1. Verificare che si desidera eliminare gli allegati con i nomi elencati nella chiave FileName.

  2. Se lo si desidera, disabilitare il blocco degli allegati o modificare l'operazione da Delete a Quarantine. Questa operazione consente a un amministratore di esaminare i file messi in quarantena relativi agli allegati che potrebbe essere necessario conservare.

Per ulteriori informazioni su ScanMail per Microsoft Exchange e ScanMail eManager, visitare il sito Web Trend Micro all'indirizzo http://www.trend.com.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Trend ScanMail è configurato in modo da eliminare allegati con determinate estensioni di file
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge varie voci del Registro di sistema per determinare se ScanMail per Microsoft Exchange Server è configurato in modo da eliminare gli allegati. I valori letti si trovano nel Registro di sistema nel percorso:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption\Advance

Valore | Descrizione
ActionType | Indica gli allegati da bloccare, se il blocco degli allegati è attivato. Il valore 0 indica che tutti gli allegati sono bloccati. Il valore 3 indica che l'amministratore ha specificato un elenco di estensioni di file, nomi file o tipi di file true. È possibile configurare questa impostazione selezionando l'opzione desiderata nella finestra di dialogo delle impostazioni di blocco degli allegati Attachment Blocking Settings in ScanMail Management Console.
EnableAlert | Indica se il blocco degli allegati è abilitato. Il valore 1 indica che il blocco degli allegati è abilitato. Il valore 0 indica che è disabilitato. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable attachment blocking nella pagina Virus Scan | Options di ScanMail Management Console.
Extension | Una stringa delimitata da punto e virgola contenente un elenco di estensioni di file degli allegati da eliminare. Quando vengono bloccati degli allegati specificati queste impostazioni possono venire configurate inserendo le estensioni desiderate nella finestra di dialogo Attachment Blocking Settings in ScanMail Management Console.

HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Valore | Descrizione
EnableEManager | Indica se ScanMail eManager è abilitato. Il valore 1 indica che eManager è abilitato. Il valore 0 indica che è disabilitato. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable eManager nella ScanMail Management Console. L'impostazione è disponibile solo quando viene installato ScanMail eManager, un prodotto complementare separato.
EnableWebStoreDelMail | Indica se Filtro messaggi attivi di ScanMail è abilitato per i messaggi in ingresso. Il valore 1 indica che il filtro messaggi attivi è abilitato per i messaggi in ingresso. Il valore 0 indica che non è abilitato per i messaggi in ingresso. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Inbound Messages nella finestra di dialogo Active Message Filter in ScanMail Management Console.

Exchange Server Analyzer, inoltre, legge la seguente voce del Registro di sistema per determinare se è abilitata la ricerca dei messaggi VSAPI (Virus Scanning API):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Il valore 1 per Enabled indica che la ricerca VSAPI è abilitata. Il valore 0 indica che la ricerca VSAPI non è abilitata. È possibile configurare questa impostazione selezionando (abilitazione) o deselezionando (disabilitazione) la casella di controllo Enable VS API virus scanning nella pagina Virus Scan | Options di ScanMail Management Console.

Se Exchange Server Analyzer rileva che tutti i criteri seguenti sono veri, verrà visualizzato un avviso:

  • La ricerca VSAPI viene abilitata in ScanMail per Microsoft Exchange

  • EnableAlert presenta il valore 1

  • ActionType presenta il valore 3

  • EnableEManager presenta il valore 1

  • EnableWebStoreDelMail presenta il valore 1

  • Extension è null o vuoto

Questo avviso indica che ScanMail è configurato in modo da eliminare tutti gli allegati con le estensioni elencate dalla chiave Extension durante la successiva analisi pianificata o manuale.

Per risolvere il problema

  1. Verificare che si desidera eliminare i file con le estensioni elencate nella chiave Extension.

  2. Se si desidera, disabilitare il blocco degli allegati o modificare l'azione da Delete a Quarantine. Questa operazione consente a un amministratore di esaminare i file messi in quarantena relativi agli allegati che potrebbe essere necessario conservare.

Per ulteriori informazioni su ScanMail per Microsoft Exchange Server e ScanMail eManager, visitare il sito Web Trend Micro all'indirizzo http://www.trend.com.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Trend ScanMail è configurato in modo da elaborare i messaggi due volte
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio ScanMail_RealTimeScan. Il valore True indica che il servizio ScanMail_RealTimeScan è in esecuzione, al contrario, il valore False indica che il servizio non è in esecuzione. Il servizio ScanMail_RealTimeScan è un componente di Trend Micro ScanMail per l'applicazione Microsoft Exchange. Trend Micro ScanMail per Microsoft Exchange offre protezione antivirus per Exchange.

Inoltre, Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'impostazione del valore Enabled:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\TransportAVAPI

Il valore 1 per Enabled indica che la ricerca di virus a livello del trasporto (talvolta definita ricerca SMTP) è abilitata, mentre il valore di 0 indica che la ricerca SMTP non è abilitata.

Se Exchange Server Analyzer rileva che Enabled è impostato su 1 e che il valore della chiave Started per il servizio ScanMail_RealTimeScan è impostato su True, verrà visualizzato un avviso.

Questo avviso indica che i messaggi che passano attraverso questo computer Exchange Server vengono analizzati due volte dalla stessa applicazione e dal motore di ricerca virus. La doppia analisi dello stesso messaggio mentre si sposta attraverso i componenti di trasporto e archiviazione di Exchange Server consuma inutilmente risorse e non fornisce alcuna protezione o vantaggio extra. È consigliabile mantenere abilitata la ricerca di virus VSAPI e disabilitare la funzione di scansione SMTP della posta utilizzando ScanMail Management Console.

Generalmente si consiglia di distribuire un software antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) oppure nei server di Exchange che ospitano cassette postali. Per una protezione massima, eseguire il software antivirus nel gateway che esegue l'analisi dei messaggi MIME in ingresso ed eseguire un programma antivirus sul computer Exchange Server che utilizza VSAPI 2.5. Inoltre, è consigliabile eseguire un software antivirus client nel PC dell'utente. Se si esegue un software antivirus progettato per sistemi di messaggistica (in grado di analizzare ed effettuare l'analisi di contenuto MIME) nel gateway oppure nel server di Exchange, è sufficiente eseguire un'analisi del PC a livello di file.

Per risolvere il problema

  1. Aprire la ScanMail Management Console e immettere le proprie credenziali di accesso.

  2. Nella pagina Virus Scan | Options assicurarsi che la casella di controllo Abilita ricerca virus VSAPI sia selezionata.

  3. Nella stessa pagina deselezionare la casella di controllo Abilita analisi posta SMTP.

  4. Fare clic su Applica per salvare le modifiche.

  5. Chiudere la ScanMail Management Console.

Per ulteriori informazioni su Trend Micro ScanMail per Microsoft Exchange visitare il sito Web di Trend Micro all'indirizzo http://kb.trendmicro.com/solutions/search.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=306105.

  • 245822, "Indicazioni per la risoluzione dei problemi in un computer Exchange in cui è installato software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=245822.


Conteggio thread di Trend ScanMail insufficiente
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore di MaxScanningThreadCount:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Il valore del Registro di sistema MaxScanningThreadCount rappresenta il numero massimo di thread che possono venire creati da ScanMail per Exchange per l'analisi. Il valore predefinito è 12.

Exchange Server Analyzer, inoltre, legge la seguente voce del Registro di sistema per determinare se è abilitata l'analisi dei messaggi VSAPI (Virus Scanning API):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Il valore 1 per Enabled indica che la ricerca VSAPI è abilitata. Il valore 0 indica che la ricerca VSAPI non è abilitata.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave NumberOfProcessors. Questo valore indica il numero di processori installati nel computer e include sia i processori fisici che quelli logici. L'utilizzo della tecnologia Hyper-Threading di Intel consente di suddividere un processore fisico in due processori logici.

Exchange Server Analyzer inoltre esegue una query nel servizio directory di Active Directory® per determinare il numero di oggetti con una classe oggetto di msExchPrivateMDB. Il conteggio di tali oggetti rappresenta il numero di archivi cassette postali nel computer Exchange Server.

Se Exchange Server Analyzer rileva che il valore di MaxScanningThreadCount è minore di (2 × NumberOfProcessors + 1) + 3 + il numero di archivi delle cassette postali) su un computer Exchange Server in cui è abilitata la ricerca VSAPI, verrà visualizzato un avviso.

Nota:
Se la tecnologia Hyper-Threading è abilitata, il valore per NumberOfProcessors sarà il doppio del numero di processori fisici. Si consiglia di utilizzare la formula indicata sopra per i sistemi che dispongono di processori fisici e per quelli che dispongono sia di processori fisici che di processori logici.

Questo avviso indica che il valore MaxScanningThreadCount del Registro di sistema potrebbe non essere stato ottimizzato per il proprio ambiente. Questo valore dovrebbe essere impostato in modo che sia almeno uguale al limite di dimensione dell'allegato impostato nei server di Exchange. Per ulteriori informazioni sul valore del Registro di sistema relativo a questa opzione, consultare Conteggio pool di thread di Trend ScanMail insufficiente.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

  3. Nel riquadro destro fare doppio clic su MaxScanningThreadCount.

  4. Immettere un valore consigliato da Exchange Server Analyzer.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio ScanMail_RealTimeScan e il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore MaxScanningThreadCount del Registro di sistema, consultare l'ID 13176 delle soluzioni Trend Micro all'indirizzo http://kb.trendmicro.com/solutions/search/main/search/solutionDetail.asp?solutionID=13176.

Per ulteriori informazioni sulla tecnologia Hyper-Threading, consultare il sito Web di Intel all'indirizzo http://www.intel.com/technology/hyperthread.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Conteggio pool di thread di Trend ScanMail insufficiente
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore di ScanningThreadPoolCount:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption

Il valore del Registro di sistema ScanningThreadPoolCount indica il numero di thread di ricerca che verranno inizializzati e che saranno utilizzabili all'avvio di ScanMail per servizi Exchange. Il valore predefinito è 12. Quando tutti i thread creati all'avvio sono stati utilizzati, in ScanMail per Exchange verranno creati thread aggiuntivi da utilizzare fino a quando non viene raggiunto il numero di thread controllati dal valore MaxScanningThreadCount del Registro di sistema descritto in Conteggio thread di Trend ScanMail insufficiente.

Exchange Server Analyzer, inoltre, legge la seguente voce del Registro di sistema per determinare se è abilitata la ricerca dei messaggi VSAPI (Virus Scanning API):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Il valore 1 per Enabled indica che la ricerca VSAPI è abilitata. Il valore 0 indica che la ricerca VSAPI non è abilitata.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_ComputerSystem per determinare il valore della chiave NumberOfProcessors. Questo valore indica il numero di processori installati nel computer e include sia i processori fisici che quelli logici. L'utilizzo della tecnologia Hyper-Threading di Intel consente di suddividere un processore fisico in due processori logici.

Exchange Server Analyzer inoltre esegue una query nel servizio directory di Active Directory® per determinare il numero di oggetti con una classe oggetto di msExchPrivateMDB. Il conteggio di tali oggetti rappresenta il numero di archivi cassette postali nel computer Exchange Server.

Se Exchange Server Analyzer rileva che il valore di ScanningThreadPoolCount è minore di (2 × NumberOfProcessors + 1) + 3 + il numero di archivi delle cassette postali) su un computer Exchange Server in cui è abilitata la ricerca VSAPI, verrà visualizzato un avviso.

Nota:
Se la tecnologia Hyper-Threading è abilitata, il valore per NumberOfProcessors sarà il doppio del numero di processori fisici. Si consiglia di utilizzare la formula indicata sopra per i sistemi che dispongono di processori fisici e per quelli che dispongono sia di processori fisici che di processori logici.

Questo avviso indica che il valore ScanningThreadPoolCount del Registro di sistema potrebbe non essere stato ottimizzato per il proprio ambiente. Questo valore dovrebbe essere impostato in modo che sia almeno uguale al limite di dimensione dell'allegato impostato nei server Exchange.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\TrendMicro\ScanMail for Exchange\RealTimeScan\ScanOption.

  3. Nel riquadro destro fare doppio clic su ScanningThreadPoolCount.

  4. Immettere un valore consigliato da Exchange Server Analyzer.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio ScanMail_RealTimeScan e il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla tecnologia Hyper-Threading, consultare il sito Web di Intel all'indirizzo http://www.intel.com/technology/hyperthread.

Nota:
Gli indirizzi Web possono cambiare, quindi potrebbe essere impossibile connettersi a uno o più siti Web citati in questo documento.


Trend ScanMail è in modalità debug
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-06-22

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare il valore di ModuleName:

HKEY_LOCAL_MACHINE\Software\TrendMicro\ScanMail for Exchange\Tools\Debug

Il valore ModuleName del Registro di sistema rappresenta il nome del file del modulo di debug in uso.

Exchange Server Analyzer, inoltre, legge la seguente voce del Registro di sistema per determinare se è abilitata la ricerca dei messaggi VSAPI (Virus Scanning API):

HKLM\System\CurrentControlSet\Services\MSExchangeIS\VirusScan\Enabled

Il valore 1 per Enabled indica che la ricerca VSAPI è abilitata. Il valore 0 indica che la ricerca VSAPI non è abilitata.

Se Exchange Server Analyzer rileva che la ricerca VSAPI è abilitata e che il valore ModuleName del Registro di sistema non è vuoto o null, verrà visualizzato un avviso.

L'esecuzione in modalità debug provoca una sostanziale riduzione del livello delle prestazioni a causa dell'analisi diagnostica in background coinvolta. Se non si sta risolvendo attivamente un problema che richiede l'esecuzione di ScanMail per Exchange in modalità debug, è necessario disattivare questa modalità.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\TrendMicro\ScanMail for Exchange\Tools\Debug.

  3. Nel riquadro destro fare doppio clic su ModuleName.

  4. Eliminare i dati di valore relativi a questa voce, lasciando vuota la stringa. Non eliminare la chiave ModuleName.

  5. Chiudere l'editor del Registro di sistema e riavviare il servizio ScanMail_RealTimeScan e il servizio Archivio informazioni di Microsoft Exchange per rendere effettive le modifiche.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, vedere l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052.

Per ulteriori informazioni sulla verifica della disabilitazione della modalità debug, vedere l'ID delle soluzioni Trend Micro 119149 all'indirizzo http://esupport.trendmicro.com/support/viewxml.do?ContentID=en-119149.

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


Il servizio Trend ScanMail Mail Action è installato nel server di Exchange ma è stato arrestato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se Trend Micro ScanMail per Exchange è installato e se il servizio ScanMail_MailAction è in esecuzione sul computer Exchange.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il valore stabilito per la chiave Started nel servizio Archivio informazioni di Microsoft Exchange è impostato su True o False.

Il valore False indica che il servizio Archivio informazioni di Microsoft Exchange non è attivo su questo computer che esegue Exchange Server. Il valore True indica che il servizio Archivio informazioni di Microsoft Exchange è attivo.

Se Exchange Server Analyzer rileva che il servizio Archivio informazioni di Microsoft Exchange è in esecuzione e che Trend Micro ScanMail per Microsoft Exchange è installato, ma il servizio ScanMail_MailAction non è stato avviato, verrà visualizzato un avviso.

Trend Micro ScanMail per Microsoft Exchange offre protezione antivirus per Exchange Server. Di seguito sono elencati alcuni problemi (con la relativa soluzione) per i quali il servizio Trend ScanMail potrebbe subire un'interruzione.

  • Il software eseguito sul server di Exchange può essere una versione di prova o di valutazione scaduta. In questo caso è necessario reinstallare Trend ScanMail. Per continuare a utilizzare il software, è almeno necessario attivarlo.

  • Un amministratore potrebbe aver arrestato inavvertitamente il servizio ScanMail_MailAction . Verificare che il servizio sia impostato per l'esecuzione automatica, quindi avviare il servizio.

  • Un worm, un virus o un altro programma dannoso potrebbe aver arrestato il servizio. Verificare che il servizio sia impostato per l'esecuzione automatica e avviare il servizio. Se continua a verificarsi l'arresto improvviso del servizio senza eventi di errore rilevanti, verificare che il computer non sia stato infettato da un worm dannoso e, se necessario, disinfettare il sistema.

Generalmente si consiglia di distribuire un software antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) oppure nei server di Exchange che ospitano cassette postali. Per una protezione massima, eseguire il software antivirus nel gateway che esegue l'analisi dei messaggi MIME in arrivo ed eseguire un'analisi del server di Exchange che utilizza VSAPI 2.5. Inoltre, è consigliabile eseguire un software antivirus client nel PC dell'utente. Se si esegue un software antivirus progettato per sistemi di messaggistica (in grado di analizzare ed effettuare l'analisi di contenuto MIME) nel gateway oppure nel server di Exchange, è sufficiente eseguire un'analisi del PC a livello di file.

Per avviare il servizio ScanMail_MailAction

  1. Aprire lo snap-in MMC Servizi.

  2. Fare clic con il pulsante destro del mouse sul servizio ScanMail_MailAction e scegliere Proprietà.

  3. Sulla scheda General della pagina delle proprietà di ScanMail_MailAction verificare che l'opzione Start-up Type sia impostata su Automatic. Se non è impostata su Automatic, fare clic su Apply, quindi fare clic su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio ScanMail_MailAction e scegliere Start.

  5. Aprire lo snap-in Servizi.
  • Per ulteriori informazioni su come aumentare il livello di protezione di un ambiente Exchange contro virus e worm trasmessi tramite messaggi di posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?linkid=16226 (informazioni in lingua inglese).


Il servizio in tempo reale Trend ScanMail è installato nel server di Exchange ma è stato arrestato
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se ScanMail per Microsoft Exchange di Trend Micro è installato e se il servizio ScanMail_RealTimeScan è in esecuzione sul computer che esegue Exchange Server. Se Exchange Server Analyzer rileva che Trend Micro ScanMail per Microsoft Exchange è installato, ma il servizio ScanMail_RealTimeScan non è avviato, verrà visualizzato un avviso.

Trend Micro ScanMail per Microsoft Exchange offre protezione antivirus per Exchange. Di seguito vengono elencati alcuni motivi per cui il servizio ScanMail_RealTimeScan può essere stato arrestato e le relative soluzioni:

  • Il software eseguito nel server di Exchange può essere una versione di prova o di valutazione scaduta. In questo caso, potrebbe essere necessario reinstallare Trend Micro ScanMail per Microsoft Exchange. Per continuare a utilizzare il software, è almeno necessario attivarlo.

  • Un amministratore potrebbe aver arrestato inavvertitamente il servizio ScanMail_RealTimeScan. Verificare che il servizio sia impostato per l'esecuzione automatica, quindi avviare il servizio.

  • Un worm, un virus o un altro programma dannoso potrebbe aver arrestato il servizio. Verificare che il servizio sia impostato per l'esecuzione automatica e avviare il servizio. Se continua a verificarsi l'arresto improvviso del servizio senza eventi di errore rilevanti, verificare che il computer non sia stato infettato da un worm dannoso e, se necessario, disinfettare il sistema.

Generalmente si consiglia di distribuire un software antivirus progettato per i sistemi di messaggistica nel gateway SMTP (Simple Mail Transfer Protocol) oppure nei server di Exchange che ospitano cassette postali. Per una protezione massima, eseguire il software antivirus nel gateway che esegue l'analisi dei messaggi MIME in ingresso ed eseguire un programma antivirus sul computer Exchange Server che utilizza VSAPI (Virus Scanning API) versione 2.5. Inoltre, è consigliabile eseguire un software antivirus client nel PC dell'utente. Se si esegue un software antivirus progettato per sistemi di messaggistica (in grado di analizzare ed effettuare l'analisi di contenuto MIME) nel gateway oppure nel server di Exchange, è sufficiente eseguire un'analisi del PC a livello di file.

Per avviare il servizio ScanMail_RealTimeScan

  1. Aprire lo snap-in Servizi MMC.

  2. Fare clic con il pulsante destro del mouse sul servizio ScanMail_RealTimeScan e scegliere Proprietà.

  3. Nella scheda General della pagina delle proprietà di ScanMail_RealTimeScan accertarsi che l'opzione Start-up type sia impostata su Automatic. Se non è impostata su Automatic, fare clic su Apply, quindi fare clic su OK.

  4. Fare clic con il pulsante destro del mouse sul servizio ScanMail_RealTimeScan, quindi scegliere Start.

  5. Chiudere lo snap-in Servizi MMC.
  • Per ulteriori informazioni su come aumentare il livello di protezione di un ambiente Exchange contro virus e worm trasmessi tramite messaggi di posta elettronica, consultare "Rallentamento e arresto della diffusione dei virus della posta elettronica in un ambiente Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47587.

Per ulteriori informazioni sull'utilizzo di software antivirus con Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 328841, "XADM: Exchange e il software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328841.

  • 823166, "Panoramica di Exchange Server 2003 e del software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • 306105, "XGEN: Posizione di Microsoft sulle soluzioni antivirus per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=306105.

  • 245822, "Consigli per la risoluzione dei problemi in un computer Exchange in cui è installato un software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=245822.

Per un elenco dei software antivirus di terzi disponibili per Exchange Server, consultare il sito Web Exchange Server Partners: Antivirus all'indirizzo http://go.microsoft.com/fwlink/?LinkId=16226 (informazioni in lingua inglese).


Disattivazione di componenti aggiuntivi di terze parti sul client
Articoli su Microsoft Exchange Server Analyzer > Software di terze parti >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool ha rilevato che è in esecuzione uno dei seguenti tipi di software di terze parti:

  • Componente aggiuntivo di terze parti per Microsoft Office Outlook®, quali un antivirus o un software di gestione fax

  • Applicazione di terze parti che accede al server Exchange

  • Software di terze parti per la sincronizzazione di dispositivi portatili

Si consiglia di analizzare i tipi di applicazioni di terze parti eseguite dagli utenti e quindi di decidere se attivare delle restrizioni su quelle applicazioni o se rimuovere completamente tali applicazioni. Tenere presente che l'esecuzione di software di terze parti è frequentemente causa di carichi eccessivi sui server.

Per disattivare componenti aggiuntivi di terze parti in Outlook

  1. In Outlook, scegliere Opzioni dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni selezionare la scheda Altro, quindi scegliere Opzioni avanzate.

  3. In Opzioni avanzate fare clic su Gestione componenti aggiuntivi.

  4. Deselezionare le caselle di controllo relative ai componenti aggiuntivi di terze parti.

  5. Fare clic su OK.

  6. Riavviare Outlook.

Per ulteriori informazioni

  • Per ulteriori informazioni sulle prestazioni di Exchange Server, consultare il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, consultare il Manuale sulla risoluzione dei problemi di prestazioni di Microsoft Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.


Trasporto
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2005-11-18

Gli articoli contenuti in questa sezione illustrano i dettagli sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente ai componenti di trasporto di Exchange. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere avvisi, messaggi di errore e configurazioni non predefinite rilevati da Exchange Server Analyzer e relativi al trasporto.


8BITMIME non registrato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-18

Microsoft® Exchange Server Analyzer Tool trasmette il comando ESMTP (Extended Simple Mail Transfer Protocol) EHLO alla porta 25 di un server remoto e analizza la risposta per determinare se il server remoto supporta il comando ESMTP 8BITMIME.

Se la risposta ricevuta dal server remoto non include la stringa "250-8BITMIME", in Exchange Server Analyzer verrà visualizzato un avviso.

In Exchange Server 2003 vengono utilizzati comandi SMTP estesi specifici di Exchange per la comunicazione con altri server che eseguono Exchange Server nell'organizzazione. La comunicazione tramite comandi SMTP estesi specifici di Exchange risulta più efficiente dell'utilizzo di comandi SMTP standard. Se il supporto del set di comandi ESMTP è disattivato, è possibile che le prestazioni di Exchange Server ne risentano.

L'errore indica che il server remoto non supporta il comando ESMTP 8BITMIME, ma non indica se il server remoto sia un server di Exchange o meno. In entrambe le istanze, i messaggi che richiedono l'estensione 8BITMIME non verranno instradati.

Per risolvere il problema, verificare il contenuto delle code SMTP per individuare i messaggi che richiedono l'estensione 8BITMIME.

Per ulteriori informazioni su come rimuovere o ripristinare il supporto predefinito per questi comandi, consultare l'articolo 257569 della Microsoft Knowledge Base "Disattivazione dei comandi ESMTP in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569.

Per ulteriori informazioni sull'utilizzo dei comandi ESMTP in Exchange Server, vedere "How to Load Exchange SMTP Properly" nella Exchange Server Transport and Routing Guide (http://go.microsoft.com/fwlink/?LinkId=71800 (informazioni in lingua inglese).


ADAM LDAP Port Identified
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-07-23

Microsoft Exchange Analyzer Tool legge la seguente voce del Registro di sistema per determinare le porte utilizzate dal servizio directory ADAM (Active Directory Application Mode) sul server Trasporto Edge:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\LdapPort

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\EdgeTransportRole\AdamSettings\MsExchangeAdam\SslPort

ADAM è un servizio directory LDAP (Lightweight Directory Access Protocol) designato specificamente per l'utilizzo con applicazioni abilitate alle directory. ADAM consente di memorizzare e replicare solo le informazioni specifiche relative all'applicazione, non richiede la distribuzione in un controller di dominio e non dipende dal servizio directory di Active Directory. ADAM non fornisce l'autenticazione o l'autorizzazione del sistema operativo della rete.

In Microsoft Exchange Server 2007, il ruolo del server Trasporto Edge utilizza ADAM per archiviare le informazioni sulla configurazione e i dati dei destinatari per il filtro dei contenuti. Se ADAM è sincronizzato con Active Directory, può essere anche utilizzato per eseguire ricerche sul destinatario per la protezione del messaggio.

L'invio dei dati ad ADAM da Active Directory viene effettuato con una connessione LDAP mediante le seguenti porte non predefinite:

  • LDAP: porta 50389/TCP

  • LDAP protetto: porta 50636/UDP

Quando Exchange Analyzer identifica le porte utilizzate da ADAM, viene visualizzato un messaggio di configurazione ottimale.

Si consiglia di bloccare tutte le porte non necessarie all'accesso esterno.

Per risolvere questo problema, verificare che le porte utilizzate da ADAM non siano aperte all'accesso esterno.

Attenzione
La porta 50636/UDP è utilizzata per il servizio Exchange EdgeSync e deve rimanere aperta se si desidera utilizzare la funzionalità EdgeSync.
Per bloccare le porte ADAM identificate all'accesso esterno utilizzando Windows Firewall

  1. Fare clic su Start, Esegui, digitare firewall.cpl, quindi fare clic su OK.

  2. Selezionare la scheda Eccezioni.

  3. Selezionare ciascun programma o servizio elencato nella casella Nome e fare clic su Modifica per rivedere le porte aperte.

  4. Verificare che le porte utilizzate da ADAM non siano presenti nell'elenco.

  5. Se le porte identificate da Exchange Analyzer sono presenti nell'elenco, assicurarsi che non vengano utilizzate per altre comunicazioni necessarie, quindi chiuderle deselezionandole nella finestra Modifica un servizio.

  6. Fare clic su OK due volte per uscire dalla configurazione di Windows Firewall.

Per ulteriori informazioni

Per ulteriori informazioni sulle porte, sull'autenticazione e sulla crittografia di tutti i percorsi di dati utilizzati da Exchange 2007, consultare "Riferimenti per la protezione dei percorsi dei dati" all'indirizzo (http://go.microsoft.com/fwlink/?LinkId=95630.


Plug-in antivirus installato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-18

Microsoft® Exchange Server Analyzer Tool esegue l'analisi di tutte le voci del Registro di sistema riportate di seguito per determinare se è stato installato il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x:

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

La presenza di questo ramo del Registro di sistema indica che il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x è installato sul server che esegue Exchange Server.

Exchange Server Analyzer legge inoltre la seguente voce del Registro di sistema per determinare se è stato attivato il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x:

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Il valore 1 di OnOff indica che il plug-in Auto Protect è attivato. Il valore 0 indica che il plug-in Auto Protect non è attivato.

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • Il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x è installato.

  • Il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x non è attivato.

Questo avviso indica che l'installazione e la configurazione del plug-in devono essere riconsiderate a fronte delle procedure ottimali consigliate dal fornitore.

Per ulteriori informazioni sulle procedure ottimali consigliate dal fornitore per questo plug-in, vedere "Best practices for Symantec AntiVirus Corporate Edition 9.x Auto-Protect on a Microsoft Exchange server" all'indirizzo http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam (informazioni in lingua inglese).

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire i dati tecnici di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


Plug-in antivirus attivato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-18

Microsoft® Exchange Server Analyzer Tool analizza le seguenti voci del Registro di sistema per determinare se il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x è installato.

HKEY_LOCAL_MACHINE\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail

La presenza di questa voce del Registro di sistema indica che il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x è installato sul server che esegue Exchange Server.

Exchange Server Analyzer legge inoltre le seguenti voci del Registro di sistema per determinare se il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x è installato.

HKLM\Software\Intel\LANDesk\VirusProtect6\CurrentVersion\Snap-In\InternetMail\RealTimeScan\OnOff

Il valore 1 di OnOff indica che il plug-in Auto Protect è attivato. Il valore 0 indica che il plug-in Auto Protect non è attivato.

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • Il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x è installato.

  • Il plug-in Internet E-Mail Auto Protect di Symantec Antivirus Corporate Edition 9.x è attivato.

L'errore indica che è consigliabile riesaminare l'installazione e la configurazione del plug-in seguendo le istruzioni aggiornate del fornitore.

Per ulteriori informazioni sulle procedure ottimali consigliate dal fornitore per questo plug-in, vedere "Best practices for Symantec AntiVirus Corporate Edition 9.x Auto-Protect on a Microsoft Exchange server" all'indirizzo http://service1.symantec.com/SUPPORT/ent-security.nsf/c9b1ac1936fbf63488256e77006521df/3d1bcbc855fce10288256e9e007e01f0?OpenDocument&src=bar_sch_nam (informazioni in lingua inglese).

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire i dati tecnici di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


La funzione di inserimento nel diario Ccn è attiva
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la funzione di inserimento nel diario copia nascosta (BCC) è abilitata:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\JournalBCC

Se Exchange Server Analyzer rileva che è stato impostato il valore 1 per JournalBCC, verrà visualizzato un messaggio di configurazione non predefinita.

La funzione di inserimento nel diario Bcc è una funzione di inserimento nel diario di soli messaggi con la capacità aggiuntiva di acquisire i destinatari Bcc. Quando la funzione di inserimento nel diario Bcc è attiva, Exchange Server acquisisce tutti i destinatari, inclusi i destinatari Bcc, che sono noti al server di origine. Se l'elenco dei destinatari include liste di distribuzione nascoste, liste di distribuzione basate su query o liste di distribuzione espanse su un altro server, i destinatari in questi elenchi non saranno inclusi nella posta inserita nel diario.

La funzione di inserimento nel diario Bcc viene attivata impostando una chiave del Registro di sistema. Per ulteriori informazioni sull'impostazione della chiave del Registro di sistema, consultare l'articolo 810999 della Microsoft Knowledge Base "XADM: Le informazioni Ccn vanno perdute nei messaggi inseriti nel diario in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=810999.

Per attivare l'inserimento Bcc nel diario su un server specifico, è innanzitutto necessario configurare la funzione di inserimento nel diario dei soli messaggi. L'impostazione di JournalBCC non è attiva quando si verificano le seguenti condizioni:

  • La chiave JournalBCC del Registro di sistema è impostata su 1.

  • La funzione di inserimento nel diario dei soli messaggi non è attiva su uno o più database nello stesso server.

La funzione di inserimento nel diario dei messaggi può richiedere molte risorse di disco, rete e CPU. Pertanto, è necessaria una pianificazione accurata della distribuzione. La funzione di inserimento nel diario dovrebbe essere abilitata solo nel contesto di una soluzione generale di inserimento nel diario.

Ignorare il messaggio di configurazione non predefinita se si verificano le seguenti condizioni:

  • L'azienda richiede l'inserimento nel diario.

  • Si è distribuita una soluzione di inserimento nel diario.

In caso contrario, è necessario disattivare la funzione di inserimento nel diario. Disattivando la funzione di inserimento nel diario nel database, si disattiva la funzione di inserimento nel diario.

Per disattivare la funzione di inserimento nel diario dei soli messaggi in un database

  1. In Gestore di sistema di Exchange espandere Server, <il server di Exchange> e <gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali.

  2. Nella scheda Generale deselezionare la casella di controllo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio.

  3. Attendere 15 minuti affinché l'archivio di Exchange possa applicare le modifiche. Non è necessario riavviare il servizio Archivio informazioni di Microsoft Exchange.

Se non si desidera che Exchange Server Analyzer visualizzi nuovamente il messaggio, è necessario eliminareJournalBCC la chiave del Registro di sistema. La disattivazione della chiave JournalBCC del Registro di sistema non è necessaria per disattivare la funzione di inserimento nel diario.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per eliminare la chiave del Registro di sistema JournalBCC

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. Nel riquadro destro individuare ed eliminare il valore JournalBCC.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel diario, consultare la guida Journaling with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


BDAT non registrato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-18

Microsoft® Exchange Server Analyzer Tool trasmette il comando ESMTP (Extended Simple Mail Transfer Protocol) EHLO alla porta 25 di un server remoto e analizza la risposta per determinare se il server remoto supporta il comando ESMTP BDAT.

Se Exchange Server Analyzer riceve una risposta con una stringa indicante un errore non recuperabile dal server remoto, verrà visualizzato un errore.

In Exchange Server 2003 vengono utilizzati comandi SMTP estesi specifici di Exchange per la comunicazione con altri server che eseguono Exchange Server nell'organizzazione. La comunicazione tramite comandi SMTP estesi specifici di Exchange risulta più efficiente dell'utilizzo di comandi SMTP standard. Se il supporto del set di comandi ESMTP è disattivato, è possibile che le prestazioni di Exchange Server ne risentano.

Questo errore indica che il server remoto non supporta il comando BDAT ESMTP ma non indica se il server remoto sia un server di Exchange o meno. In entrambi i casi i messaggi che richiedono l'estensione BDAT non vengono instradati.

Per risolvere il problema, verificare il contenuto delle code SMTP per i messaggi che richiedono l'estensione BDAT.

Per ulteriori informazioni su come rimuovere o ripristinare il supporto predefinito per questi comandi, consultare l'articolo 257569 della Microsoft Knowledge Base "Disattivazione dei comandi ESMTP in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569.

Per ulteriori informazioni sull'utilizzo dei comandi ESMTP in Exchange Server, vedere "How to Load Exchange SMTP Properly" nella Exchange Server Transport and Routing Guide http://go.microsoft.com/fwlink/?LinkID=71800 (informazioni in lingua inglese).


Server testa di ponte per verificare le restrizioni di recapito ai gruppi di distribuzione (connettore gruppo di routing)
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-18

Microsoft® Exchange Server Analyzer Tool esegue una query nei seguenti attributi per ciascun oggetto connettore del gruppo di routing (msExchRoutingGroupConnector) rilevato nel servizio directory di Active Directory® per determinare se le restrizioni relative al recapito sono impostate in base all'appartenenza al gruppo di distribuzione.

dLMemRejectPerms | Contiene i nomi di dominio (DN) di una lista di distribuzione (DL) i cui membri potrebbero non utilizzare questo connettore del gruppo di routing per l'invio di messaggi.
dLMemSubmitPerms | Contiene i DN di una lista di distribuzione (DL) i cui membri potrebbero utilizzare questo connettore del gruppo di routing per l'invio di messaggi.

Se in Exchange Server Analyzer vengono trovati connettori del gruppo di routing che presentano restrizioni basate sull'appartenenza al gruppo di distribuzione, verrà eseguita una query sull'attributo msExchSourceBridgeheadServersDN dei connettori del gruppo di distribuzione rilevati per determinare se il server analizzato è impostato come server testa di ponte per uno dei connettori.

Infine, Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se è presente e configurato il valore CheckConnectorRestrictions del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • Un connettore del gruppo di distribuzione viene utilizzato per limitare il recapito in base all'appartenenza al gruppo di distribuzione.

  • Il server di Exchange analizzato è designato come server testa di ponte per quel connettore del gruppo di routing ed esegue le attività di espansione del gruppo di distribuzione.

  • La chiave CheckConnectorRestrictions è presente, impostata su 1 e quindi attivata.

I comportamenti predefiniti del classificatore prevedono l'espansione ricorsiva dei gruppi di distribuzione e la verifica delle restrizioni per ogni messaggio che passa nel sistema.

Quando viene creato un gruppo di routing, viene designato un gruppo di server in grado di comunicare direttamente tra loro. Per fare in modo che server in gruppi di routing diversi siano in grado di comunicare tra loro, è necessario connettere i gruppi di routing.

Il metodo di connessione preferito è il connettore del gruppo di routing perché designato e concepito specificamente per la connessione di gruppi di routing.

I server in grado di inviare posta tramite un connettore del gruppo di routing sono server testa di ponte. Un server testa di ponte è una combinazione di un server virtuale SMTP (Simple Mail Transfer Protocol) e di un server di Exchange responsabile del recapito di tutti i messaggi tramite un connettore.

Quando viene creato un connettore del gruppo di routing, è possibile scegliere di mantenere tutti i server come server testa di ponte per quel connettore oppure specificare di utilizzare un solo set di server selezionati come server testa di ponte per quel connettore. Nei server testa di ponte designati vengono eseguite le attività di espansione dell'appartenenza al gruppo di distribuzione.

Quando un messaggio di posta viene inviato utilizzando i connettori del gruppo di distribuzione con restrizioni relative al recapito basate sull'appartenenza al gruppo di distribuzione, il classificatore di messaggi espande l'appartenenza del gruppo di distribuzione, ottiene l'elenco completo dei DN dei membri e confronta l'elenco dei DN con i DN dei mittenti. Quando un DN corrisponde in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

L'avviso indica che le restrizioni relative al recapito basate sull'appartenenza al gruppo di distribuzione possono causare una coda dei messaggi destinati al server testa di ponte durante la verifica delle restrizioni da parte del classificatore.

Per risolvere il problema:

  • Configurare il connettore del gruppo di routing su un gruppo di routing locale come menzionato nell'articolo 329171 della Microsoft Knowledge Base "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • Utilizzare un server di catalogo globale dedicato e più affidabile come server testa di ponte designato per il connettore.

  • Configurare cassette postali individuali e non gruppi di distribuzione per le restrizioni di recapito come menzionato nell'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

  • Implementare il filtro mittenti SMTP.

  • Per i server che eseguono Microsoft Exchange Server 2003 Service Pack 2 (SP2) o una versione successiva, implementare la verifica delle restrizioni non gerarchica. Per i server che eseguono una versione precedente a Exchange 2003 SP2, è consigliabile eseguire l'aggiornamento a Exchange 2003 SP2.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sul filtro mittenti SMTP, consultare "Configurazione del filtro mittenti" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=71832.

Per ulteriori informazioni sull'effetto della restrizione relativa al gruppo di distribuzione sul flusso di posta di Exchange Server 2003, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 329171 "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • 895407 "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949 "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.


Server testa di ponte per verificare le restrizioni di recapito ai gruppi di distribuzione (connettore SMTP)
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool esegue una query nei seguenti attributi per ciascun oggetto connettore SMTP (Simple Mail Transfer Protocol) msExchRoutingSMTPConnector rilevato nel servizio directory di Active Directory® per determinare se le restrizioni relative al recapito sono impostate in base all'appartenenza al gruppo di distribuzione.

dLMemRejectPerms | Contiene i nomi di dominio (DN) di una lista di distribuzione (DL) i cui membri potrebbero non utilizzare questo connettore SMTP per l'invio di messaggi.
dLMemSubmitPerms | Contiene i DN di una lista di distribuzione (DL) i cui membri potrebbero utilizzare questo connettore SMTP per l'invio di messaggi.

Se in Exchange Server Analyzer vengono trovati connettori SMTP che presentano restrizioni basate sull'appartenenza al gruppo di distribuzione, verrà eseguita una query nell'attributo msExchSourceBridgeheadServersDN dei connettori SMTP rilevati per determinare se il server analizzato è impostato come server testa di ponte per uno dei connettori.

Infine, Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se è presente e configurato il valore CheckConnectorRestrictions del Registro di sistema:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • Un connettore SMTP viene utilizzato per limitare il recapito in base all'appartenenza al gruppo di distribuzione.

  • Il server di Exchange analizzato è designato come server testa di ponte per quel connettore SMTP ed esegue le attività di espansione del gruppo di distribuzione.

  • La chiave CheckConnectorRestrictions è presente, impostata su 1 e quindi attivata.

I comportamenti predefiniti del classificatore prevedono l'espansione ricorsiva dei gruppi di distribuzione e la verifica delle restrizioni per ogni messaggio che passa nel sistema.

Quando un messaggio di posta viene inviato utilizzando un connettore che accetta o rifiuta i messaggi provenienti da un gruppo di distribuzione, il classificatore di messaggi espande l'appartenenza del gruppo di distribuzione, ottiene l'elenco completo dei DN dei membri e confronta l'elenco dei DN con i DN dei mittenti. Quando un DN corrisponde in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

Nel server testa di ponte designato vengono eseguite le attività di espansione dell'appartenenza al gruppo di distribuzione.

La verifica delle restrizioni viene controllata dal valore CheckConnectorRestrictions del Registro di sistema, che deve essere impostato sul server testa di ponte di Exchange che rappresenta l'origine del connettore per cui viene eseguita la verifica. Se viene specificata una restrizione ma non viene creato il valore CheckConnectorRestrictions del Registro di sistema, la restrizione non verrà verificata.

Per impostazione predefinita, la verifica delle restrizioni dei connettori è disattivata. Le prestazioni di sistema vengono influenzate in modo significativo se i gruppi di distribuzione vengono espansi e le restrizioni vengono verificate per ogni messaggio che passa nel sistema.

L'avviso indica che le restrizioni relative al recapito basate sull'appartenenza al gruppo di distribuzione possono causare una coda dei messaggi destinati al server testa di ponte durante la verifica delle restrizioni da parte del classificatore.

Per risolvere il problema:

  • Impostare un gruppo di routing dedicato per le restrizioni dei connettori e configurarlo su un gruppo di routing locale come menzionato nell'articolo 329171 della Microsoft Knowledge Base "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • Utilizzare un server di catalogo globale dedicato e più affidabile come server testa di ponte designato per il connettore.

  • Configurare cassette postali individuali e non gruppi di distribuzione per le restrizioni di recapito come menzionato nell'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

  • Implementare il filtro mittenti SMTP.

  • Per i server che eseguono Microsoft Exchange Server 2003 Service Pack 2 (SP2) o una versione successiva, implementare la verifica delle restrizioni non gerarchica. Per i server che eseguono una versione precedente a Exchange 2003 SP2, è consigliabile eseguire l'aggiornamento a Exchange 2003 SP2.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sul filtro mittenti SMTP, consultare "Configurazione del filtro mittenti" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=71832.

Per ulteriori informazioni sull'effetto della restrizione relativa al gruppo di distribuzione sul flusso di posta di Exchange Server 2003, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 329171 "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • 895407 "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949 "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.


Impossibile connettersi al server di routing principale sulla porta 25
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-24

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchRoutingMasterDN di ogni gruppo di routing presente nel gruppo amministrativo corrente. Exchange Server Analyzer tenta di aprire una connessione del socket al server di routing principale sulla porta TCP 25. Se Exchange Server Analyzer non riceve come previsto la risposta personalizzata 25 Available, verrà visualizzato un messaggio di errore.

Questo errore indica che il server di routing master non è accessibile sulla porta TCP 25 e che potrebbero verificarsi errori di routing. Per correggere questo errore, è possibile risolvere il problema di connettività con il server di routing master oppure assegnarne uno nuovo.

Per risolvere il problema di connettività con il server di routing master

  1. Verificare se è possibile eseguire una connessione telnet alla porta 25 dal server di routing master. Se non è possibile, non si tratta di un problema di rete.

  2. Assicurarsi che siano stati eseguiti i collegamenti necessari e che l'hardware funzioni correttamente.

  3. Verificare che il DNS funzioni e sia configurato correttamente.

  4. Verificare che il router funzioni correttamente.

  5. Verificare la presenza di eventuali firewall o applicazioni che impediscono la connessione.
Per assegnare un nuovo server di routing master

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic con il pulsante destro del mouse sull'icona Nome organizzazione (Exchange) nella parte superiore della struttura nel riquadro sinistro (dove Nome organizzazione è il nome selezionato per l'organizzazione di Exchange 2000), quindi scegliere Proprietà.

  3. Fare clic su Visualizza gruppi amministrativi, quindi su Visualizza gruppi di routing e infine su OK.

  4. Espandere Administrative Groups, <GruppoAmministrativo>, quindi Routing Groups.

  5. Espandere il gruppo di routing, quindi fare clic su Membri.

  6. Nel riquadro destro fare clic con il pulsante destro del mouse sul computer Exchange da configurare come master del gruppo di routing, quindi scegliere Imposta come master.

Per ulteriori informazioni sulla risoluzione dei problemi di routing, sulla configurazione delle topologie di routing e sui concetti avanzati di routing, consultare "Risoluzione dei problemi di routing" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Impossibile connettersi al server di routing principale sulla porta 691
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-24

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchRoutingMasterDN di ogni gruppo di routing presente nel gruppo amministrativo corrente. Exchange Server Analyzer tenta di aprire una connessione del socket al server di routing principale sulla porta TCP 691. Se Exchange Server Analyzer non riceve come previsto la risposta personalizzata 691 Available, verrà visualizzato un messaggio di errore.

Questo errore indica che il server di routing master non è accessibile sulla porta TCP 691 e che potrebbero verificarsi errori di routing. Per correggere questo errore, è possibile risolvere il problema di connettività con il server di routing master oppure assegnarne uno nuovo.

Per risolvere il problema di connettività con il server di routing master

  1. Verificare se è possibile eseguire una connessione telnet alla porta 691 dal server di routing master. Se non è possibile, non si tratta di un problema di rete.

  2. Assicurarsi che siano stati eseguiti i collegamenti necessari e che l'hardware funzioni correttamente.

  3. Verificare che il DNS funzioni e sia configurato correttamente.

  4. Verificare che il router funzioni correttamente.

  5. Verificare la presenza di eventuali firewall che impediscono la connessione.
Per assegnare un nuovo server di routing master

  1. Aprire il Gestore di sistema di Exchange.

  2. Fare clic con il pulsante destro del mouse sull'icona Nome organizzazione (Exchange) nella parte superiore della struttura nel riquadro sinistro (dove Nome organizzazione è il nome selezionato per l'organizzazione di Exchange 2000), quindi scegliere Proprietà.

  3. Fare clic su Visualizza gruppi amministrativi, quindi su Visualizza gruppi di routing e infine su OK.

  4. Espandere Administrative Groups, <GruppoAmministrativo>, quindi Routing Groups.

  5. Espandere il gruppo di routing, quindi fare clic su Membri.

  6. Nel riquadro destro fare clic con il pulsante destro del mouse sul computer Exchange da configurare come master del gruppo di routing, quindi scegliere Imposta come master.

Per ulteriori informazioni sulla risoluzione dei problemi di routing, sulla configurazione delle topologie di routing e sui concetti avanzati di routing, consultare "Risoluzione dei problemi di routing" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Impossibile trovare record "Host" o "MX"
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-05-10

Lo strumento Microsoft Exchange Analyzer esegue una ricerca DNS per recuperare i record MX (Mail Exchanger) per un dominio. Se Exchange Analyzer non è in grado di recuperare i record MX di un dominio dal server DNS, viene eseguita una ricerca DNS per recuperare i record Host (A) dei domini ai quali il server Exchange sta tentando di inviare messaggi.

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • Exchange Analyzer non è in grado di recuperare i record MX di un dominio.

  • L'operazione di ricerca DNS non restituisce un indirizzo IP per nessuno dei record Host (A).

Tale errore indica che i record DNS MX e Host (A) risultano mancanti nel dominio e nei server. L'errore potrebbe provocare il backup dei messaggi destinati a domini remoti nelle code Recapito remoto del server Exchange, oltre ad altri ritardi nel routing o nei servizi.

Per determinare gli host di posta, il server Exchange di invio cerca un record MX. Quindi, il server di invio risolve il record MX in un indirizzo IP cercando un record dell'indirizzo (record A).

Potrebbe verificarsi un errore nella ricerca DNS dei record MX e Host (A) per i seguenti motivi:

  • Il server DNS è inattivo o irraggiungibile a causa di un errore nella rete o per altri motivi.

  • Il record Host (A) del server remoto risulta mancante dal server DNS perché il record non è disponibile o non è corretto.

  • Il server DNS non è configurato per consentire gli aggiornamenti dinamici del record dell'host.

  • Il sistema tenta di inviare rapporti di mancato recapito (NDR, Non-Delivery Report) in risposta a messaggi di spam i cui domini di origine sono nascosti. In tal caso, eliminare tali messaggi. Vedere il collegamento allo strumento di eliminazione e archiviazione della posta scartata di Exchange Server nella sezione Per ulteriori informazioni di questo articolo.

Per verificare che il server DNS è in linea e i record MX e Host sono presenti

  1. Verificare che il server DNS sia in esecuzione eseguendo uno o più dei seguenti controlli:

    • Controllare lo stato del server DNS utilizzando il programma di amministrazione DNS nel server DNS.

    • Riavviare il server DNS. Per ulteriori informazioni, vedere "Avvio, arresto, sospensione o riavvio di un server DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=62999.

    • Verificare la capacità di risposta del server DNS utilizzando il comando nslookup. Per ulteriori informazioni, vedere le istruzioni in "Verificare la capacità di risposta del server DNS tramite il comando nslookup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63000.

  2. Utilizzare nslookup per verificare che i record MX siano configurati correttamente. Per ulteriori informazioni, consultare "Utilizzo di Nslookup per la verifica della configurazione dei record MX" nella sezione "Verifica della configurazione e della struttura del DNS" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  3. Utilizzare nslookup per verificare che il record Host (A) esiste nel server DNS. Per ulteriori informazioni, vedere "Per verificare l'esistenza di record di risorse A nel sistema DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63001.

  4. Se il record di risorse Host (A) non esiste, aggiungere manualmente o modificare il record di risorse A oppure configurare il server DNS per consentire aggiornamenti dinamici del record:

    • Aggiungere manualmente un record di risorse A. Per ulteriori informazioni, vedere "Aggiunta di un record di risorse a una zona DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63002.

    • Modificare manualmente un record di risorse A. Vedere le istruzioni in "Modifica di un record di risorsa esistente" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63014.

    • Configurare il server DNS per l'abilitazione degli aggiornamenti dinamici del record dell'host. Per ulteriori informazioni, vedere l'articolo 816592 della Microsoft Knowledge Base "Configurazione di aggiornamenti dinamici del DNS in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592.

Per ulteriori informazioni

  • Per informazioni sull'utilizzo da parte di Exchange Server 2003 del DNS per la risoluzione degli indirizzi IP esterni, vedere "Dipendenze del trasporto per Exchange Server 2003" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Per informazioni sulla risoluzione nomi DNS, vedere l'articolo 322856 della Microsoft Knowledge Base "Configurazione del DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • Per informazioni sulla risoluzione dei problemi del DNS, vedere "Risoluzione dei problemi relativi al servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63003.

  • Per informazioni sul monitoraggio del sistema di Exchange Server 2003, vedere in Exchange Server 2003 Management Pack Guide for MOM 2005 SP1 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47573 (informazioni in lingua inglese).

  • Per informazioni sui record di risorse Host (A), vedere "Gestione dei record di risorse" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63004.

  • Per ulteriori informazioni sullo strumento di eliminazione e archiviazione della posta scartata di Exchange Server, consultare "Exchange Server Badmail Deletion and Archiving" all'indirizzohttp://go.microsoft.com/fwlink/?LinkId=84239 (informazioni in lingua inglese).


Impossibile identificare il mittente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-08

Microsoft® Exchange Server Analyzer Tool esegue una query nel valore attributo proxyAddress del servizio directory di Active Directory® per tutti gli oggetti utente per determinare se esiste una corrispondenza per l'indirizzo SMTP del mittente locale specificato dall'utente.

Se Exchange Server Analyzer non riesce a rilevare una corrispondenza proxyAddress per l'indirizzo SMTP del mittente locale specificato dall'utente, verrà visualizzato un errore.

L'errore indica che è vera una delle condizioni seguenti:

  • Il mittente locale non esiste nell'organizzazione di Exchange Server locale.

  • L'indirizzo SMTP del mittente locale specificato dall'utente è stato immesso in modo errato.

Per risolvere l'errore è necessario verificare l'indirizzo SMTP del mittente locale specificato e ritentare l'operazione.

Per verificare l'indirizzo del mittente locale

  1. Avviare Gestore di sistema di Exchange.

  2. Espandere Destinatari e quindi Tutti gli elenchi indirizzi globali.

  3. Fare clic con il pulsante destro del mouse su Elenco indirizzi globale predefinito e selezionare Proprietà.

  4. Fare clic su Anteprima per visualizzare gli indirizzi SMTP dei destinatari inclusi nell'Elenco indirizzi globale predefinito.

  5. Verificare che il mittente locale specificato sia visualizzato e prendere nota dell'indirizzo SMTP.


Evento sink CatDbgSink installato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge i dati rilevati nella proprietà LM/SmtpSvc/%SMTPINSTANCE%/EventManager/EventTypes nella metabase IIS (Internet Information Services) per determinare se l'applicazione di diagnostica del flusso di posta CatDbgSink è installata in un computer che esegue Exchange 2000 Server o Exchange Server 2003.

L'applicazione CatDbgSink è un evento sink che può essere utilizzato per risolvere i problemi nel flusso di posta su computer che eseguono Exchange 2000 Server o Exchange Server 2003. Se l'applicazione CatDbgSink è installata in un server di Exchange, verrà visualizzato un avviso indicante che l'applicazione CatDbgSink è installata e che dovrebbe essere utilizzata solo per la risoluzione dei problemi nel flusso di posta.

L'applicazione CatDbgSink viene generalmente inviata ai clienti per la risoluzione dei problemi nel flusso di posta su computer Exchange 2000 Server ed Exchange Server 2003. In genere, l'applicazione CatDbgSink viene installata in base alle indicazioni del Servizio Supporto Tecnico Clienti Microsoft (PSS). Dopo che l'applicazione CatDbgSink è stata installata e registrata correttamente, i clienti potranno utilizzarla per creare file di registro per la raccolta di informazioni sulla risoluzione dei problemi nel flusso di posta in un server di Exchange.

Talvolta l'applicazione CatDbgSink non può essere rimossa dal server di Exchange di produzione dopo aver isolato e corretto i problemi. Se l'applicazione CatDbgSink non viene rimossa dal computer Exchange, si creerà un carico significativo che provocherà problemi di prestazioni indesiderati sul server di Exchange. Dopo aver diagnosticato i problemi nel flusso di posta su un server di Exchange di produzione, è necessario rimuovere l'applicazione CatDbgSink.

Per risolvere il problema

  1. Individuare la cartella d'installazione locale di CatDbgSink. La cartella contiene i seguenti file d'installazione: Setup.vbs, CatDbgSink.dll, CatDbgSink.pdb e MustReadMe.txt.

  2. Da una finestra del prompt dei comandi, modificare la directory impostandola sulla posizione dell'unità locale dei file d'installazione, ad esempio: C:\CatDbgSink.

  3. Al prompt dei comandi, digitare cscript setup.vbs uninstall 1 .
Nota:
Il numero 1 nella riga di comando indica l'istanza del server virtuale SMTP, a partire da 1.

Per ulteriori informazioni sull'applicazione CatDbgSink, contattare il Servizio Supporto Tecnico Clienti Microsoft all'indirizzo http://support.microsoft.com/default.aspx?pr=cntactms.


Classificatore disabilitato per l'istanza SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge i dati della proprietà LM/SmtpSvc/%SMTPInstance%/RoutingSources nella metabase IIS (Internet Information Services) per determinare lo stato del classificatore dei messaggi per ogni istanza del server virtuale SMTP (VSI) su computer Exchange 2000 Server o Exchange Server 2003.

Exchange Server Analyzer determina se la chiave SMTPDSUseCat è presente nel metabase IIS metabase e compila rapporti sui risultati. Se Exchange Server Analyzer rileva la presenza del valore SMTPDSUseCat, impostato su disabilitato, ovvero 0X000000, verrà visualizzato un messaggio di errore. Se il classificatore dei messaggi è disabilitato, si verificheranno gravi problemi di flusso della posta.

Per impostazione predefinita, quando il servizio SMTP è installato in un computer Microsoft Windows®°2000 Server o Microsoft Windows Server™ 2003, nella metabase IIS viene creata la chiave SMTPDSUseCat. Per impostazione predefinita, la chiave SMTPDSUseCat è disabilitata (0). Quando viene installato Exchange Server, la chiave SMTPDSUseCat della metabase IIS viene rimossa. In questo modo viene abilitato il classificatore dei messaggi. Quando il servizio SMTP o Exchange Server viene installato in un computer che esegue Windows 2000 Server o Windows Server 2003, viene creata un'istanza predefinita (1) del server virtuale SMTP (VSI). Il classificatore dei messaggi può essere disabilitato nelle situazioni in cui Exchange Server è installato e il servizio SMTP viene disinstallato e quindi reinstallato nel computer. Il classificatore dei messaggi può essere disabilitato anche quando vengono installati software di terze parti o quando si verifica un errore di configurazione amministrativa.

Nota:
Ogni istanza del server virtuale SMTP sul server di Exchange dispone di un controllo indipendente dello stato del classificatore dei messaggi.

Il classificatore dei messaggi esamina ogni messaggio ricevuto da ogni VSI SMTP e determina le opzioni. I messaggi possono essere inoltrati all'archivio locale, a un host remoto attraverso l'Agente di trasferimento messaggi (MTA) o tramite SMTP. Il classificatore dei messaggi è inoltre in grado di gestire l'espansione della lista di distribuzione. I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, che stabilisce quindi le operazioni da eseguire con i messaggi stessi. Il classificatore dei messaggi è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore dei messaggi è un insieme di eventi sink in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato.

Nota:
Lo strumento di reinstallazione SMTP (Smtpreinstall.exe) si trova nella cartella \SUPPORT\UTILS\I386 del CD di Exchange 2000 Server SP2.
Per abilitare il classificatore dei messaggi utilizzando lo strumento di reinstallazione SMTP

  1. Copiare Smtpreinstall.exe nella cartella \Exchsrvr\Bin.

  2. Fare doppio clic su Smtpreinstall.exe dalla cartella \Exchsrvr\Bin.

  3. Nella finestra di dialogo Reinstallazione SMTP di Microsoft Exchange fare clic su OK per riavviare il server di Exchange.

È possibile visualizzare le proprietà nella metabase IIS installando l'utilità Metaedit 2.2 per IIS 4.0/5.0 o l'utilità IIS Metabase Explorer su IIS 6.0.

Attenzione
Si sconsiglia di modificare direttamente la metabase.

Per ulteriori informazioni sul classificatore dei messaggi o sulle utilità della metabase IIS disponibili, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 290290, "XIMS: Impossibile inviare messaggi di posta dopo la reinstallazione del servizio SMTP IIS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=290290.

  • 319885, "XCON: I messaggi inviati nell'organizzazione di Exchange 2000 Server non vengono recapitati" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319885.

  • 231729, "XCON: La chiave DSUseCat e il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231729.

  • 232068, "How To: Scaricare, installare e rimuovere l'utilità MetaEdit 2.2 di IIS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=232068.

Per scaricare IIS 6.0 Resource Kit Tools, consultare Internet Information Services (IIS) 6.0 Resource Kit Tools all'indirizzo http://go.microsoft.com/fwlink/?LinkId=33134 (informazioni in lingua inglese).


Un evento di avviso del classificatore (ID: 6004) è stato registrato nelle ultime 24 ore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-05

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un avviso di evento 6004 di MSExchangeTransport.

Se Microsoft Exchange Server Analyzer Tool rileva che un avviso di evento 6004 di MSExchangeTransport è stato registrato nelle ultime 24 ore, verrà visualizzato un avviso.

L'avviso indica che il classificatore ha rilevato un errore quando ha tentato di elaborare un messaggio.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di sink di evento in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. Il classificatore è in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali e di generare notifiche sullo stato del recapito. Inoltre è in grado di rilevare moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Possible causes of MSExchangeTransport L'evento di avviso 6004 comprende:

  • Problemi di DSAccess.

  • Latenza o errori della replica di directory.

  • Server di catalogo globali sovraccarichi.

  • Problemi di DNS

Per risolvere il problema:

  • Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  • Analizzare tutti i messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, non-delivery report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  • Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  • Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  • Controllare i contatori di prestazioni del classificatore utilizzando Monitor di sistema.

Per ulteriori informazioni su errori ed eventi di Exchange Server 2003, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258.

Per un elenco delle notifiche sullo stato del recapito (DSN) e dei rapporti di mancato recapito (NDR) generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server e in Small Business Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzare il Centro di verifica messaggi per tenere la traccia di un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Come attivare la verifica di messaggi in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, relativo agli ID evento di verifica messaggi in Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, relativo alle funzionalità di verifica messaggi migliorate in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare l'articolo del WebCast di supporto Microsoft Exchange 2000 Server relativo alla risoluzione dei problemi del classificatore dei messaggi e dei rapporti di mancato recapito, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base relativo all'utilità Archive Sink disponibile nel Service Pack 2, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare gli articoli e le risorse della Microsoft Knowledge Base indicati di seguito:

  • 821910, relativo alla risoluzione dei problemi di trasporto in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "Risoluzione dei problemi generali di trasporto in Exchange 2000 Server e in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

  • 895853, relativo alla risoluzione dei problemi di inoltro di posta in Exchange Server 2003 e in Exchange 2000 Server, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base relativo ai contatori di Performance Monitor per il classificatore dei messaggi, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.


Un evento di avviso del classificatore (ID: 6006) è stato registrato nelle ultime 24 ore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un avviso di evento 6006 di MSExchangeTransport.

Se Microsoft Exchange Server Analyzer Tool rileva che un avviso di evento 6006 di MSExchangeTransport è stato registrato nelle ultime 24 ore, verrà visualizzato un avviso.

Tale avviso indica che i messaggi sono stati intercettati nel classificatore dei messaggi.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di sink di evento in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. Il classificatore è in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali e di generare notifiche sullo stato del recapito. Inoltre è in grado di rilevare moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Possible causes of MSExchangeTransport L'evento di avviso 6006 comprende:

  • Software antivirus obsoleto o configurato non correttamente.

  • Espansione elevata del gruppo di distribuzione.

  • Destinatari diario configurati non correttamente.

  • Autorizzazioni per oggetti di Exchange in Active Directory configurate non correttamente.

Per risolvere il problema:

  • Assicurarsi che l'applicazione antivirus sia configurata correttamente a livello di file in modo da escludere specifiche directory di Exchange Server. Per una descrizione delle cartelle da no includere quando si esegue l'analisi di server sui quali viene eseguito Microsoft Exchange Server, vedere l'articolo 823166 della Microsoft Knowledge Base "Panoramica di Exchange Server 2003 e software antivirus" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823166.

  • Assicurarsi che sia installata e in esecuzione la versione più aggiornata del software antivirus.

  • Esaminare le restrizioni relative al recapito in base al gruppo di distribuzione e rimuovere le restrizioni non necessarie.

  • Esaminare le impostazioni del diario e ricercare eventuali configurazioni non corrette.

  • Ricercare autorizzazioni per oggetti di Exchange in Active Directory configurate non correttamente.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange Server, consultare gli articoli della Microsoft Knowledge Base sugli argomenti riportati di seguito:

  • 895407, relativo al recapito dei messaggi alle cassette postali locali ed esterne più lento del previsto in Exchange Server 2003 dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949, relativo alla risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298, relativo al recapito della posta lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel diario, vedere "Journaling with Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (in inglese).

Per ulteriori informazioni sulle possibili cause dell'evento di avviso con ID 6006 del classificatore, vedere l'articolo 922256 della Microsoft Knowledge Base relativo ai messaggi di posta elettronica che restano nella coda "Messaggi in attesa dell'individuazione della directory" in un'organizzazione Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=922256.

Per ulteriori informazioni su errori ed eventi di Exchange Server 2003, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258.

Per un elenco delle notifiche sullo stato del recapito (DSN) e dei rapporti di mancato recapito (NDR) generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server e in Small Business Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare l'articolo del WebCast di supporto Microsoft Exchange 2000 Server relativo alla risoluzione dei problemi del classificatore dei messaggi e dei rapporti di mancato recapito, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare gli articoli e le risorse della Microsoft Knowledge Base indicati di seguito:

  • 821910, relativo alla risoluzione dei problemi di trasporto in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "Risoluzione dei problemi generali di trasporto in Exchange 2000 Server e in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

  • 895853, relativo alla risoluzione dei problemi di inoltro di posta in Exchange Server 2003 e in Exchange 2000 Server, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base relativo ai contatori di Performance Monitor per il classificatore dei messaggi, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.


Un evento di avviso del classificatore (ID: 6008) è stato registrato nelle ultime 24 ore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un avviso di evento 6008 di MSExchangeTransport.

Se Microsoft Exchange Server Analyzer Tool rileva che un avviso di evento 6008 di MSExchangeTransport è stato registrato nelle ultime 24 ore, verrà visualizzato un avviso.

L'avviso indica che il classificatore ha rilevato un errore quando ha tentato di elaborare un messaggio.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di sink di evento in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. Il classificatore è in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali e di generare notifiche sullo stato del recapito. Inoltre è in grado di rilevare moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Possible causes of MSExchangeTransport L'evento di avviso 6008 comprende:

  • Problemi di DSAccess.

  • Latenza o errori della replica di directory.

  • Server di catalogo globali sovraccarichi.

  • Problemi di DNS

  • Espansione eccessiva del gruppo di distribuzione.

Per risolvere il problema:

  • Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  • Analizzare tutti i messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, non-delivery report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  • Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  • Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  • Controllare i contatori di prestazioni del classificatore utilizzando Monitor di sistema.

  • Esaminare le restrizioni relative al recapito in base al gruppo di distribuzione e rimuovere le restrizioni non necessarie.

Per ulteriori informazioni su errori ed eventi di Exchange Server 2003, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258.

Per un elenco delle notifiche sullo stato del recapito (DSN) e dei rapporti di mancato recapito (NDR) generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server e in Small Business Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzare il Centro di verifica messaggi per tenere la traccia di un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Come attivare la verifica di messaggi in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, relativo agli ID evento di verifica messaggi in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, relativo alle funzionalità di verifica messaggi migliorate in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare l'articolo del WebCast di supporto Microsoft Exchange 2000 Server relativo alla risoluzione dei problemi del classificatore dei messaggi e dei rapporti di mancato recapito, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base relativo all'utilità Archive Sink disponibile nel Service Pack 2, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange Server, consultare gli articoli della Microsoft Knowledge Base sugli argomenti riportati di seguito:

  • 895407, relativo al recapito dei messaggi alle cassette postali locali ed esterne più lento del previsto in Exchange Server 2003 dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949, relativo alla risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298, relativo al recapito della posta lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare gli articoli e le risorse della Microsoft Knowledge Base indicati di seguito:

  • 821910, relativo alla risoluzione dei problemi di trasporto in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "Risoluzione dei problemi generali di trasporto in Exchange 2000 Server e in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

  • 895853, relativo alla risoluzione dei problemi di inoltro di posta in Exchange Server 2003 e in Exchange 2000 Server, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base relativo ai contatori di Performance Monitor per il classificatore dei messaggi, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.


Il filtro di connessione è abilitato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se la proprietà msExchServerBindingsFiltering di un oggetto server virtuale SMTP (Simple Mail Transfer Protocol) indica che il filtro di connessione è abilitato per un'istanza del server virtuale SMTP.

Exchange Server Analyzer Tool esegue inoltre una query in Active Directory per determinare se la proprietà msExchSmtpConnectionRulesPriority, msExchSMTPGlobalIPAcceptList o msExchSMTPGlobalIPDenyList indica che il filtro di connessione è abilitato anche al livello delle impostazioni globali.

Se le seguenti condizioni vengono soddisfatte, in Exchange Server Analyzer verrà visualizzato un avviso:

  • Il filtro di connessione è abilitato per l'istanza del server virtuale SMTP.

  • Il filtro di connessione è abilitato a livello delle impostazioni globali.

Questo avviso indica che il filtro di connessione è correttamente abilitato. Normalmente il filtro di connessione non rappresenta un problema. Tuttavia, se è in corso la risoluzione di problemi relativi al flusso di posta su questo server specifico, può essere necessario verificare la configurazione del filtro o disabilitare temporaneamente il filtro di connessione per determinare se stia bloccando in modo errato la posta inviata a destinatari validi.

Per disabilitare un filtro di connessione in un server virtuale SMTP

  1. Avviare il Gestore di sistema di Exchange: Fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nella struttura della console espandere Server, il server desiderato, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP sul quale si desidera disabilitare il filtro e scegliere Proprietà.

  4. In Proprietà <Server virtuale SMTP>, nella scheda Generale, fare clic su Avanzate.

  5. In Avanzate selezionare l'indirizzo IP per il quale si desidera disabilitare il filtro, quindi fare clic su Modifica.

  6. In Identificazione deselezionare la casella di controllo Applica filtro di connessione per disabilitare il filtro.

  7. Se si dispone di più server virtuali, ripetere i passaggi da 3 a 6 per ogni server virtuale in cui si desidera disabilitare il filtro.

Per ulteriori informazioni su come configurare i filtri di connessione, vedere l'articolo 823866 della Microsoft Knowledge Base, "Configurazione del filtro connessioni affinché utilizzi elenchi RBL (Realtime Block List) e del filtro destinatari in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866.

Per ulteriori informazioni sul Filtro messaggi intelligente, vedere il sito Web del Filtro messaggi intelligente di Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).


Sono impostate restrizioni di accettazione per il connettore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo dLMemDefault per ogni connettore SMTP nel gruppo di routing. Microsoft® Exchange Server Analyzer Tool esegue inoltre una query in Active Directory® per determinare il valore degli attributi authOrig e unauthOrig di ciascun connettore. Gli attributi unauthOrig e authOrig contengono elenchi di DN (distinguished names) di account.

Per impostazione predefinita, tutti i connettori SMTP consentono a tutti gli utenti di inviare messaggi tramite il connettore. Quando dLMemDefault è impostato sul valore predefinito 1, vengono accettati tutti i messaggi indipendentemente dal mittente, ad eccezione di quelli provenienti dagli account elencati nell'attributo unauthOrig. Quando dLMemDefault è impostato sul valore 0, vengono rifiutati tutti i messaggi indipendentemente dal mittente, ad eccezione di quelli provenienti dagli account elencati nell'attributo authOrig.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione non predefinita:

  • Il valore dell'attributo dLMemDefault è impostato su 0.

  • L'attributo authOrig contiene valori.

Il connettore specificato da Exchange Server Analyzer è configurato per accettare determinati messaggi. Solo gli account ai quali è stata concessa l'autorizzazione in modo esplicito nella scheda Restrizioni di recapito del connettore potranno inviare messaggi tramite il connettore stesso.

In Exchange Server Analyzer viene visualizzato il messaggio di configurazione non predefinita solo a scopo informativo.

Per ulteriori informazioni sui connettori, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Sono impostate restrizioni di rifiuto per il connettore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo dLMemDefault per ogni connettore SMTP nel gruppo di routing. Microsoft® Exchange Server Analyzer Tool esegue inoltre una query in Active Directory® per determinare il valore degli attributi authOrig e unauthOrig di ciascun connettore. Gli attributi unauthOrig e authOrig contengono elenchi di DN (distinguished names) di account.

Per impostazione predefinita, tutti i connettori SMTP consentono a tutti gli utenti di inviare messaggi tramite il connettore. Quando dLMemDefault è impostato sul valore predefinito 1, vengono accettati tutti i messaggi indipendentemente dal mittente, ad eccezione di quelli provenienti dagli account elencati nell'attributo unauthOrig. Quando dLMemDefault è impostato sul valore 0, vengono rifiutati tutti i messaggi indipendentemente dal mittente, ad eccezione di quelli provenienti dagli account elencati nell'attributo authOrig.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione non predefinita:

  • Il valore dell'attributo dLMemDefault è impostato su 1.

  • L'attributo unauthOrig contiene valori.

Il connettore specificato da Exchange Server Analyzer è configurato per rifiutare alcuni messaggi. Gli account ai quali è stata negata l'autorizzazione in modo esplicito nella scheda Restrizioni di recapito del connettore non potranno inviare messaggi tramite il connettore stesso.

In Exchange Server Analyzer viene visualizzato il messaggio di configurazione non predefinita solo a scopo informativo.

Per ulteriori informazioni sui connettori, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Il connettore rifiuta tutti i messaggi per impostazione predefinita
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo dLMemDefault per ogni connettore. L'attributo dLMemDefault determina se i messaggi vengono accettati o rifiutati per impostazione predefinita.

Il valore 0 per l'attributo dLMemDefault indica che i messaggi vengono rifiutati per impostazione predefinita. Il valore 1 per l'attributo dLMemDefault indica che i messaggi vengono accettati per impostazione predefinita. Se Exchange Server Analyzer rileva che il valore dell'attributo dLMemDefault è impostato su 0, verrà visualizzato un messaggio di configurazione non predefinita.

Il connettore specificato da Exchange Server Analyzer è configurato per rifiutare tutti i messaggi per impostazione predefinita. Solo gli account ai quali è stata concessa l'autorizzazione in modo esplicito nella scheda Restrizioni di recapito del connettore potranno inviare messaggi tramite il connettore stesso.

In Exchange Server Analyzer viene visualizzato il messaggio di configurazione non predefinita solo a scopo informativo.

Per ulteriori informazioni sui connettori, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Verifica delle restrizioni dei connettori abilitata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge il ramo del Registro di sistema indicato di seguito per determinare se il valore CheckConnectorRestrictions del Registro di sistema è presente e configurato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Se Exchange Server Analyzer rileva che il valore di CheckConnectorRestrictions è presente e impostato su 1, verrà visualizzato un avviso.

Se è necessario applicare a un connettore una restrizione basata su liste di distribuzione, il processo di verifica relativo a queste restrizioni dovrà essere abilitato manualmente. La verifica delle restrizioni viene controllata dal valore CheckConnectorRestrictions del Registro di sistema, che deve essere impostato sul server testa di ponte di Exchange che rappresenta l'origine del connettore per cui viene eseguita la verifica. Se viene specificata una restrizione ma non viene creato il valore CheckConnectorRestrictions del Registro di sistema, la restrizione non verrà verificata.

La verifica delle restrizioni dei connettori viene disattivata per impostazione predefinita, poiché l'espansione dei gruppi di distribuzione e la verifica delle restrizioni per ogni messaggio che passa nel sistema possono influire notevolmente sulle prestazioni. Se possibile, abilitare questa impostazione solo dove è necessario (ad esempio, sul server testa di ponte relativo al connettore sottoposto a restrizione).

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per disabilitare la verifica delle restrizioni dei connettori

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\Resvc\Parameters

  3. Nel riquadro di destra, individuare ed eliminare CheckConnectorRestrictions.

  4. Chiudere l'editor del Registro di sistema e riavviare il servizio Microsoft Exchange - Motore di routing e il servizio SMTP (Simple Mail Transfer Protocol) per rendere effettive le modifiche.

Per ulteriori informazioni sulla procedura per modificare il Registro di sistema, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore del Registro di sistema per la verifica delle restrizioni dei connettori, consultare l'articolo 277872 della Microsoft Knowledge Base "XCON: Le restrizioni di recapito del connettore potrebbero non funzionare correttamente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


L'ambito del connettore è il routing locale
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-04-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchRoutingSMTPConnector per ogni connettore SMTP. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchRoutingSMTPConnector include la stringa "Local:", verrà visualizzato un messaggio di configurazione non predefinita. La presenza della stringa "Local:" indica che l'ambito del connettore SMTP è il routing locale.

Un connettore SMTP determina una route isolata per la posta elettronica. È possibile utilizzare i connettori SMTP per determinare un gateway per la posta Internet oppure per collegarsi a un dominio o a un sistema di posta elettronica specifico. I connettori consentono di definire opzioni specifiche per la route di posta elettronica designata.

Sebbene sia possibile inviare e ricevere la posta Internet utilizzando un server virtuale SMTP, molte organizzazioni configurano un connettore SMTP dedicato a tale scopo. È consigliabile utilizzare un connettore SMTP poiché questo fornisce una route isolata per la posta elettronica destinata a Internet. Inoltre, su un connettore SMTP sono disponibili più opzioni di configurazione rispetto a quelle presenti sul server virtuale SMTP.

In Exchange Server Analyzer viene visualizzato il messaggio di configurazione non predefinita solo a scopo informativo.

Per ulteriori informazioni sui connettori SMTP, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Verifica delle restrizioni non gerarchica
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti di Exchange Server nella directory. Se Exchange Server Analyzer rileva che il valore dell'attributo serialNumber per l'oggetto server di Exchange Server 2003 contiene Service Pack 2 nel proprio valore di stringa, allora Exchange Server Analyzer legge la seguente chiave del Registro di sistema per stabilire se il valore del Registro di sistema CheckConnectorRestrictions è presente e configurato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Resvc\Parameters

Questa condizione indica che, prima di consentire l'elaborazione di un messaggio, nel server vengono verificate le restrizioni di invio e di ricezione.

Se Exchange Server Analyzer rileva che il valore per CheckConnectorRestrictions è presente, impostato su 1, e quindi attivato, Exchange Server Analyzer legge anche la chiave del Registro di sistema HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod per determinare se il valore del Registro di sistema RestrictionMethod è presente e come è configurato.

Se Exchange Server Analyzer rileva che il valore del Registro di sistema RestrictionMethod è mancante oppure è impostato su un valore diverso da 2, verrà visualizzato un messaggio di configurazione ottimale.

In sintesi, se le seguenti condizioni sono vere, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • Nel server di Exchange Server 2003 è installato il Service Pack 2.

  • Il valore CheckConnectorRestrictions del Registro di sistema in HKLM\System\CurrentControlSet\Services\Resvc\Parameters è configurato per l'utilizzo di una restrizione basata su liste di distribuzione per un connettore sul computer locale.

  • Il valore RestrictionMethod del Registro di sistema di HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod è mancante o impostato su un valore diverso da 2.

Il valore RestrictionMethod determina l'elaborazione delle restrizioni da parte del classificatore. Il comportamento predefinito del classificatore prevede l'espansione ricorsiva dei gruppi di distribuzione e la verifica delle restrizioni per ogni messaggio che passa nel sistema. Il comportamento predefinito del classificatore può influenzare in modo significativo le prestazioni e non è una configurazione ottimale.

Se si imposta il valore di RestrictionMethod su 2, i componenti di trasporto nel server di Exchange non espanderanno l'appartenenza ai gruppi di distribuzione quando nel server vengono verificate le restrizioni. Questa configurazione fornisce le migliori prestazioni per le verifiche delle restrizioni. Inoltre, per rendere effettiva la voce RestrictionMethod del Registro di sistema, è necessario che tutti i gruppi di distribuzione in cui sono inclusi utenti con restrizioni di recapito siano di tipo semplice. Ovvero, i gruppi di distribuzione con restrizioni non devono essere nidificati. In caso contrario, la logica di espansione non funzionerà.

Per i gruppi di distribuzione utilizzati nelle restrizioni per il connettore, si consiglia di impostare il valore della voce RestrictionMethod del Registro di sistema in un server testa di ponte del connettore privo di cassette postali. Per le restrizioni per gli utenti di Active Directory, se i gruppi di distribuzione con restrizioni dispongono di server di espansione, si consiglia di creare la voce RestrictionMethod del Registro di sistema in tali server.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per creare la voce RestrictionMethod del Registro di sistema e impostare il relativo valore su 2

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Nel riquadro sinistro fare clic su Parameters.

  4. Dal menu Modifica scegliere Nuovo, quindi Valore DWORD.

  5. Digitare RestrictionMethod, quindi premere INVIO per assegnare un nome alla nuova voce del Registro di sistema.

  6. Fare clic con il pulsante destro del mouse su RestrictionMethod, quindi scegliere Modifica.

  7. Digitare 2 e premere INVIO.

  8. Uscire dall'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore RestrictionMethod del ?Registro di sistema, consultare l'articolo 895407 della Microsoft Knowledge Base "In Exchange Server 2003, dopo aver configurato le limitazioni relative al recapito basate sui gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento di quanto ci si aspetti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

Per ulteriori informazioni sul valore del Registro di sistema, consultare l'articolo 277872 della Microsoft Knowledge Base "XCON: Le Restrizioni di recapito del connettore potrebbero non funzionare correttamente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


La chiave ConvertDSNInternetContent del Registro di sistema è configurata per la conversione del contenuto di tutti i messaggi
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore del Registo di sistema ConvertDSNInternetContent è stato configurato per eseguire la conversione del contenuto per tutti i messaggi ricevuti dall'Archivio informazioni di Exchange sul computer Exchange Server 2003:

HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

Se le seguenti condizioni sono vere, verrà visualizzato un messaggio di errore:

  • Il valore ConvertDSNInternetContent del Registro di sistema è stato creato manualmente.

  • La chiave ConvertDSNInternetContent del Registro di sistema è impostata su 1.

Se i dati di valore sono impostati su 0 o nessun valore nel valore ConvertDSNInternetContent del Registro di sistema, viene disabilitata la conversione del contenuto dei messaggi SMTP dall'Archivio informazioni di Exchange. Se i dati di valore sono impostati su 1, viene abilitata la conversione del contenuto di tutti i messaggi, compresi i messaggi SMTP in tutte le istanze del server virtuale SMTP (VSI) o in ognuna di esse.

Per impostazione predefinita il valore ConvertDSNInternetContent del Registro di sistema non viene creato durante l'installazione di Exchange Server 2003. Il valore ConvertDSNInternetContent del Registro di sistema piò essere creato manualmente dopo l'installazione di Exchange Server per modificare il comportamento della conversione del contenuto nel computer Exchange Server 2003. In generale, i messaggi SMTP inviati non devono essere sottoposti alla conversione del contenuto. Se viene abilitata la conversione del contenuto per tutti i messaggi inclusi i messaggi SMTP, viene aggiunto un sovraccarico di elaborazione nel server di Exchange. QUesto sovraccarico aggiuntivo può provocare problemi di prestazioni e di archiviazione dei file di registro.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. È necessario modificare il Registro di sistema per tornare nuovamente al metodo di conversione del contenuto più efficiente nel computer Exchange Server 2003.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare alla seguente chiave del Registro di sistema: HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore ConvertDSNInternetContent del Registro di sistema, su Modifica, quindi impostare i Dati valore su 80. Fare clic su OK.

    Nota:
    Per eliminare il valore ConvertDSNInternetContent del Registro di sistema, nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore ConvertDSNInternetContent, quindi su Elimina. Confermare l'eliminazione del valore facendo clic su Sì nella finestra di dialogo.

  4. Chiudere l'editor del Registro di sistema.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema di Microsoft Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Gruppo di distribuzione identificato come destinazione comune
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-04

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Queue per determinare i valori dei seguenti attributi per le code SMTP del server virtuale SMTP.

LinkId | Indica l'identificatore del collegamento che contiene la coda.
QueueId | Indica l'identificatore della coda.
QueueName | Indica il nome della coda.
VirtualMachine | Indica il nome del computer virtuale che contiene la coda.
VirtualServerName | Indica il nome del server virtuale su cui si trova la coda.
MessageCount | Indica il numero di messaggi nella coda.

In Exchange Server Analyzer vengono utilizzate le informazioni ottenute qui per eseguire una query nella classe WMI Exchange_QueuedSMTPMessage per determinare i valori dei seguenti attributi dei messaggi nella coda:

Recipients | Indica i destinatari del messaggio.
Received | Indica il time stamp del messaggio ricevuto.
MessageId | Indica l'identificatore del messaggio in coda.
StateRetry | Indica un nuovo tentativo di trasmissione di un messaggio non recapitato correttamente.

Infine, i dati ottenuti da Microsoft® Exchange Server Analyzer vengono utilizzati per eseguire una query nel servizio directory di Active Directory® per determinare il valore di distinguishedName per ciascun oggetto Recipient. Quindi viene determinato se il destinatario è un utente, un gruppo di distribuzione, una cartella pubblica o un archivio delle cartelle pubbliche.

Se Exchange Server Analyzer determina che almeno il 25% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a un gruppo di distribuzione specifico, verrà visualizzato un avviso.

Se Exchange Server Analyzer determina che almeno il 50% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a un gruppo di distribuzione specifico, verrà visualizzato un errore.

L'avviso o l'errore indica che il gruppo di distribuzione è identificato come destinazione comune per i messaggi bloccati in una coda SMTP.

Per risolvere il problema è necessario ricercare problemi di configurazione o altre anomalie del gruppo di distribuzione che possono causare un accodamento dei messaggi destinati ad esso. Per eseguire l'operazione procedere come segue:

  • Assicurarsi che gli attributi dell'oggetto gruppo di distribuzione siano impostati correttamente e contengano i valori corretti in Active Directory.

  • Esaminare che le impostazioni delle autorizzazioni di Active Directory per l'oggetto gruppo di distribuzione siano corrette.

  • Se il gruppo di distribuzione contiene un oggetto utente per uso speciale, ovvero un destinatario diario designato, esaminare che le configurazioni del servizio o dei componenti a cui è correlato l'oggetto utente siano corrette.

  • Ricercare eventuali messaggi di posta elettronica pubblicitari non richiesti, spam o attacchi virus al gruppo di distribuzione.

  • Determinare se le limitazioni di recapito per il gruppo di distribuzione sono state impostate in modo errato.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange Server, consultare gli articoli della Microsoft Knowledge Base sugli argomenti riportati di seguito:

  • 895407, relativo al recapito dei messaggi alle cassette postali locali ed esterne più lento del previsto in Exchange Server 2003 dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 329171, relativo al recapito della posta lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • 839949, relativo alla risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298, relativo al recapito della posta lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.


Categorizzazioni precedenti non riuscite con errori non irreversibili
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer che eseguono Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dai contatori di prestazioni Cat: Classificazioni in corso e Lunghezza coda classificatore dell'oggetto prestazioni SMTP Server per l'analisi dei dati sulle prestazioni.

Il contatore di prestazioni Cat: Classificazioni in corso indica il numero di classificazioni in corso mentre il contatore di prestazioni Lunghezza coda classificatore indica il numero di messaggi nella coda del classificatore.

Per questa query, Exchange Server Analyzer recupera un esempio ogni 6 secondi in un periodo di due minuti. Il valore medio del contatore di prestazioni viene restituito durante l'intervallo di raccolta.

Exchange Server Analyzer esamina il numero medio di classificazioni in corso e lo confronta con il numero di classificazioni ancora in coda.

Se nel periodo di esempio si verificano le seguenti condizioni, verrà visualizzato un errore:

  • Il numero medio di classificazioni in corso è uguale a zero.

  • La lunghezza media della coda del classificatore è superiore a zero.

Il classificatore esegue le seguenti operazioni principali:

  • Risolve e convalida tutti i destinatari.

  • Determina i limiti e le restrizioni per tutti i destinatari.

  • Espande le liste di distribuzione, se richiesto.

  • Determina se il messaggio è per il recapito locale o remoto.

L'errore indica la presenza di messaggi bloccati nella coda del classificatore, pertanto non è possibile classificare i messaggi e si è verificato un errore non irreversibile.

I messaggi si accumulano di solito nelle code perché il motore di accodamento avanzato non è in grado di classificare il messaggio. Il motore di accodamento avanzato potrebbe non essere in grado di accedere ai server di catalogo globali e alle informazioni sul destinatario oppure i server di catalogo globale non sono raggiungibili o offrono prestazioni scadenti. I messaggi possono inoltre accumularsi per i seguenti motivi:

  • Servizio directory di Active Directory® non disponibile.

    Nota:
    Il classificatore utilizza Active Directory per classificare i messaggi.
  • Active Directory potrebbe avere un carico troppo elevato se sono presenti molti messaggi nella coda di pre-classificazione.

  • Si è verificato un errore durante la conversione. Il classificatore gestisce anche la conversione del contenuto.

  • Il classificatore dei messaggi non riesce a trovare gli archivi di cassette postali.

  • Se il protocollo SMTP (Simple Mail Transfer Protocol) è stato reinstallato o rimosso, potrebbero risultare invalidate le seguenti chiavi della metabase IIS: /smtpsvc/DsUseCat e /smtpsvc/vsi#/DsUseCat.

    Nota:
    Determinare se il protocollo SMTP è stato disinstallato o rimosso.

È possibile esaminare le proprietà della coda per determinare la causa dell'errore. Ad esempio, se nelle proprietà della coda viene visualizzato un messaggio che indica "Si è verificato un errore SMTP", è necessario rivedere i registri evento del server per individuare tutti gli errori SMTP. Se non sono presenti eventi nel registro, è necessario aumentare il livello di registrazione SMTP.

Per ulteriori informazioni sulla risoluzione dei problemi di Exchange e delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.

  • "Troubleshooting Microsoft Exchange Server Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

  • "Manuale relativo alle prestazioni e alla scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.


Abilitazione dell'aggiornamento automatico del Filtro messaggi intelligente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-02-13

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti di Exchange Server nella directory. L'attributo serialNumber è un valore di stringa che include sia la versione di Exchange Server sia, se installato, la versione del Service Pack. Un valore dell'attributo serialNumber pari a Version 6.5 (Build 7638: Service Pack 2) indica che sul server è in esecuzione Exchange Server 2003, Service Pack 2.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio cluster (ClusSvc). Il valore True indica che il servizio cluster è in esecuzione, mentre il valore False indica che il servizio non è in esecuzione.

Exchange Server Analyzer legge inoltre la seguente voce del Registro di sistema per determinare se nel server è installato e abilitato il Filtro messaggi intelligente di Microsoft Exchange:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Se Exchange Server Analyzer rileva la presenza della voce ContentFilterBindings nella chiave del Registro di sistema ContentFilter ma il valore di ContentFilterBindings non è configurato, significa che il Filtro messaggi intelligente non è abilitato sul server.

Viene infine eseguita una query nella seguente voce del Registro di sistema per determinare la presenza della sottochiave ContentFilterState e se sul server è abilitato l'aggiornamento automatico del Filtro messaggi intelligente.

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\

Un valore diverso da 1 per la sottochiave ContentFilterState indica che l'aggiornamento automatico del Filtro messaggi intelligente non è abilitato.

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione ottimale:

  • Sul server è in esecuzione Exchange Server 2003, Service Pack 2

  • Il server di Exchange è un server non cluster

  • Il Filtro messaggi intelligente è abilitato

  • Gli aggiornamenti automatici per il Filtro messaggi intelligente non sono abilitati

Per impostazione predefinita, la funzionalità Filtro messaggi intelligente viene installata con Exchange Server 2003 SP2. Per usufruire dei vantaggi offerti da questa nuova tecnologia di filtraggio del contenuto, è necessario abilitare manualmente la funzionalità Filtro messaggi intelligente. Una volta abilitata questa funzionalità, sarà necessario aggiornare regolarmente i file DAT e DLL per utilizzare la versione più recente ed efficace del filtro. Nell'articolo menzionato nella seguente sezione viene descritto il processo di aggiornamento del Filtro messaggi intelligente.

Per informazioni sull'abilitazione dell'aggiornamento automatico del Filtro messaggi intelligente, consultare l'articolo 907747 della Microsoft Knowledge Base "Aggiornamento del Filtro messaggi intelligente versione 2 in Exchange Server 2003 SP2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=907747.


La funzione di inserimento nel diario protetto è attiva
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-03-30

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo heuristics è stato configurato per l'attivazione della funzione di inserimento nel diario protetto. Per impostazione predefinita, l'attributo heuristics non è configurato. Se Exchange Server Analyzer rileva che l'attributo heuristics è stato impostato sul valore 512, verrà visualizzato un messaggio di configurazione non predefinita.

La funzione di inserimento nel diario protetto consente di archiviare le intestazioni dei messaggi P1. L'intestazione del messaggio P1 contiene le informazioni relative all'indirizzo utilizzato dagli MTA (Message Transfer Agent, Agente di trasferimento messaggi) per instradare la posta. Sono incluse le informazioni relative ai destinatari che ricevono effettivamente il messaggio, i destinatari in copia nascosta (Ccn) e i destinatari dei gruppi di distribuzione. La funzione di inserimento nel diario protetto consente il recapito di messaggi contrassegnati per l'archiviazione utilizzando un messaggio protetto che contiene un rapporto diario e il messaggio originale. Il messaggio originale viene recapitato come allegato. Il corpo del rapporto diario contiene i dati di trasporto protetto del messaggio archiviato.

Per abilitare l'inserimento Ccn nel diario su un server specifico, è innanzitutto necessario configurare la funzione di inserimento nel diario dei soli messaggi a livello di database. L'attributo heuristics non è attivo quando si verificano le seguenti condizioni:

  • L'attributo heuristics è impostato su 512.

  • La funzione di inserimento nel diario dei soli messaggi non è abilitata su uno o più archivi di database.

La funzione di inserimento nel diario dei messaggi può richiedere molte risorse di disco, rete e CPU. Pertanto, è necessaria una pianificazione accurata della distribuzione. La funzione di inserimento nel diario dovrebbe essere abilitata solo nel contesto di una soluzione generale di inserimento nel diario.

Ignorare il messaggio di configurazione non predefinita se si verificano le seguenti condizioni:

  • L'azienda richiede l'inserimento nel diario.

  • Si è distribuita una soluzione di inserimento nel diario.

In caso contrario, è necessario disattivare la funzione di inserimento nel diario.

Per disattivare la funzione di inserimento nel diario dei soli messaggi in un database

  1. In Gestore di sistema di Exchange espandere Server, <il server Exchange> e <il gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali.

  2. Nella scheda Generale deselezionare la casella di controllo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio.

  3. Attendere 15 minuti affinché l'archivio di Exchange possa applicare le modifiche. Non è necessario riavviare il servizio Archivio informazioni di Microsoft Exchange.

Se non si desidera che in Exchange Server Analyzer visualizzi nuovamente il messaggio, è necessario disabilitare l'attributo heuristics. La disabilitazione dell'attributo heuristics non è necessaria per disabilitare la funzione di inserimento nel diario.

È possibile disabilitare la funzione di inserimento nel diario protetto utilizzando lo strumento E-Mail Journaling Advanced Configuration (Exejcfg.exe). È possibile eseguire lo strumento da qualunque server con accesso ad Active Directory, ma è consigliabile eseguirlo da un controller di dominio.

Per richiedere lo strumento E-Mail Journaling Advanced Configuration e la relativa documentazione, scaricare il pacchetto di strumenti dall'indirizzo http://go.microsoft.com/fwlink/?LinkId=33122. È possibile utilizzare lo strumento E-Mail Journaling Advanced Configuration in ambienti Exchange 2000 Server ed Exchange Server 2003.

Per disabilitare l'attributo heuristics

  1. Scaricare e decomprimere lo strumento E-Mail Journaling Advanced Configuration in una directory di propria scelta.

  2. Aprire un prompt dei comandi.

  3. Trovare la directory dove si è installato lo strumento E-Mail Journaling Advanced Configuration.

  4. Digitare il comando seguente per disabilitare la funzione di inserimento nel diario protetto:

    Copia codice
    exejcfg -d

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel diario, consultare la guida "Journaling with Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


Comando ESMTP non supportato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo msExchSmtpInboundCommandSupportOptions per ogni istanza di un server virtuale SMTP (Simple Mail Transfer Protocol) è configurato per supportare i comandi estesi SMTP per le connessioni in ingresso.

Questi comandi estesi SMTP sono elencati nella tabella riportata di seguito. Se Exchange Server Analyzer rileva che uno dei comandi estesi SMTP per le connessioni in ingresso elencati non è supportato, verrà visualizzato un avviso.

Exchange Server 2003 usa questi comandi estesi SMTP specifici per Exchange per comunicare con altri server Exchange nell'organizzazione in modo più efficiente con il protocollo SMTP standard. Questi comandi sono controllati nella metabase e nei sink di evento di Exchange Server. In Exchange Server 2003 il processo DS2MB è responsabile dell'aggiornamento dei valori nella metabase copiando tali valori da Active Directory. Quando si disabilitano i sink di evento, è possibile che le prestazioni di Exchange Server ne risentano.

Comando esteso SMTP Commenti

8BITMIME

Indica che il server virtuale SMTP locale supporta messaggi MIME a otto bit.

BDAT, CHUNKING

Un'alternativa al comando DATA. Utilizza due argomenti. Se un server virtuale SMTP risponde alla parola chiave EHLO con CHUNKING, il server SMTP indica che supporta il comando BDAT e accetterà i messaggi in blocchi.

  • Il primo argomento indica la lunghezza del pacchetto di dati binari. Pertanto l'host SMTP non deve eseguire continuamente la scansione per trovare la fine dei dati. Il server di ricezione conta i byte nel messaggio. Se la dimensione del messaggio è pari al valore inviato dal comando BDAT, il server presume di aver ricevuto tutti i dati del messaggio.

  • Il secondo argomento indica se il pacchetto di dati è l'ultimo pacchetto nella trasmissione corrente. Il secondo argomento è facoltativo.

BINARYMIME

Indica che il server virtuale SMTP accetta messaggi che contengono materiale binario senza codifica del trasporto utilizzando il parametro BODY con un valore di BINARYMIME assieme al comando MAIL. Quando il server SMTP accetta un comando MAIL con un parametro BODY di valore BINARYMIME, il server accetta di mantenere tutti i bit in ogni ottetto passato usando il comando BDAT. L'estensione SMTP BINARYMIME può essere utilizzata solo con CHUNKING.

DSN

Un comando ESMTP che abilita le notifiche dello stato di recapito come definito nel documento RFC (Request for Comments) 1891.

ENHANCEDSTATUSCODES

Indica che il server SMTP fornisce codici di stato di errore avanzati. La parte testuale di tutte le risposte di stato SMTP, a parte il saluto iniziale e qualunque risposta a HELO o EHLO, viene preceduta da un codice di stato come definito nel documento RFC 1893.

ETRN

Comando inviato da un server SMTP per richiedere al server virtuale locale di inviare i messaggi di posta elettronica in coda per i domini indicati nel comando ETRN.

TURN

Consente a un host remoto e all'host locale di scambiarsi i ruoli e inviare messaggi di posta nella direzione contraria, senza stabilire una nuova connessione.

Per ulteriori informazioni su come ripristinare il supporto predefinito per questi comandi, consultare l'articolo 257569 della Microsoft Knowledge Base "Disattivazione dei comandi ESMTP in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569.


Comandi estesi non annunciati dal server di Exchange
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la proprietà SmtpInboundCommandSupportOptions nella metabase IIS (Internet Information Services) per determinare se Exchange Server è stato configurato per supportare comandi estesi: Se Exchange Server Analyzer rileva che la proprietà SmtpInboundCommandSupportOptions non è impostata su 7697601, verrà visualizzato un avviso.

I comandi SMTP estesi sono richiesti sia da Exchange 2000 Server sia da Exchange Server 2003, Il valore nella metabase IIS deve corrispondere al valore impostato nel servizio directory Active Directory®. Se Exchange Server è in esecuzione in un ambiente a modalità mista, il valore deve essere impostato su 7697601.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per ripristinare il valore predefinito di SmtpInboundCommandSupportOptions

  1. Aprire ADSI Edit e connettersi a un controller di dominio.

  2. Aprire il Contenitore di configurazione.

  3. Spostarsi nella posizione seguente:

    Configuration/Services/Microsoft Exchange/<Organizzazione>/Administrative Groups/<Gruppo Amministrativo>/Servers/<Server di Exchange>/Protocols/SMTP/<Server virtuale>.

  4. Fare clic con il pulsante destro del mouse sull'oggetto server virtuale, quindi scegliere Proprietà.

  5. In Selezionare una proprietà da visualizzare, sceliere msExchSmtpInboundCommandsSupportOptions.

  6. In Modifica attributo, immettere 7697601.

  7. Fare clic su Imposta, Applica, quindi OK.

  8. Chiudere ADSI Edit.


Rilevate code bloccate
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-03

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateFrozen per le code SMTP sul server.

Se Exchange Server Analyzer rileva che il valore della chiave StateFrozen per le code SMTP su un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda risulta bloccata, le sessioni di trasporto dirette a questa coda vengono arrestate. Una coda bloccata impedisce l'invio dei messaggi in uscita, anche se è possibile aggiungere nuovi messaggi. È possibile modificare manualmente lo stato di una connessione utilizzando il menu di scelta rapida in ciascuna coda di collegamento. Se viene utilizzato il comando Imponi connessione per modificare lo stato di una coda su Attiva, viene immediatamente abilitata una connessione che invia messaggi da tale coda.

Per informazioni sulle code SMTP interessate e sulla possibile causa, consultare i seguenti articoli su Exchange Server Analyzer Tool:

  • La coda Messaggi in attesa dell'individuazione della directory è bloccata

  • La coda Messaggi in attesa di essere reindirizzati è bloccata

  • La coda Messaggi in attesa di invio è bloccata

  • La coda Recapito locale è bloccata

  • La coda Recapito remoto è bloccata

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


È disponibile l'aggiornamento per il Filtro messaggi intelligente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare se nel server di Exchange è presente MSExchange.UceContentFilter.dll nel seguente percorso:

<percorso dei file binari di Exchange server>\MSCFv2\MSExchange.UceContentFilter.dll

Nota:
In questo percorso, <percorso dei file binari di Exchange server> indica la posizione della cartella dei file binari.

Se MSExchange.UceContentFilter.dll non esiste in questa posizione, verrà visualizzato un messaggio di configurazione ottimale.

Si consiglia di installare l'aggiornamento per il Filtro messaggi intelligente di Microsoft Exchange in tutti i server di Exchange in cui è installato il Filtro messaggi intelligente. L'aggiornamento per il Filtro messaggi intelligente fornisce l'aggiornamento più recente per il Filtro messaggi intelligente Intelligent Message Filter SmartScreen™. L'aggiornamento per il filtro SmartScreen contiene delle caratteristiche anti spam aggiornate che migliorano la capacità del Filtro messaggi intelligente di bloccare i messaggi di posta elettronica pubblicitari non richiesti, anche noti come spam.

Nota:
Prima di installare l'aggiornamento, è necessario installare il Filtro messaggi intelligente. Per installare il Filtro messaggi intelligente, utilizzare un account che disponga delle autorizzazioni di amministrazione locale e un membro di un gruppo a cui sia stato assegnato il ruolo di amministratore di Exchange.

Dopo aver installato il Filtro messaggi intelligente, eseguire la seguente procedura per installare gli aggiornamenti.

Per ottenere e installare l'aggiornamento del Filtro messaggi intelligente

  1. Per ottenere l'aggiornamento più recente per il Filtro messaggi intelligente di Exchange, consultare la pagina Web http://go.microsoft.com/fwlink/?LinkId=41026 (informazioni in lingua inglese).

  2. Per ulteriori informazioni relative alle note sulla versione dell'aggiornamento per il Filtro messaggi intelligente, consultare la pagina Web http://go.microsoft.com/fwlink/?LinkId=41027 (informazioni in lingua inglese).

  3. Eseguire l'aggiornamento e seguire le istruzioni indicate nell'installazione guidata dell'aggiornamento.

Per ulteriori informazioni, consultare la pagina Web Microsoft Exchange Intelligent Message Filter all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).


Verifica delle restrizioni semplice abilitata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti di Exchange Server nella directory. Se il valore di stringa dell'attributo serialNumber di un oggetto server di Exchange Server 2003 contiene Service Pack 2, significa che nel server di Exchange è in esecuzione una versione non definitiva di Exchange Server 2003 Service Pack 2.

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è presente il valore RestrictionMethod:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione non predefinita:

  • È installato Exchange Server 2003 Service Pack 2.

  • Il valore RestrictionMethod del Registro di sistema è presente ed è configurato su 2.

Questa configurazione indica che i componenti di trasporto nel server di Exchange non espanderanno l'appartenenza ai gruppi di distribuzione quando il server verificherà le restrizioni. Questa configurazione fornisce le migliori prestazioni per le verifiche delle restrizioni.

In caso di dubbio sulla presenza e sull'impostazione corretta del valore RestrictionMethod del Registro di sistema, è possibile utilizzare la seguente procedura per ripristinare la configurazione predefinita. Tuttavia, dal momento che la presenza di questa chiave e di Exchange Server 2003 Service Pack 2 fornisce le migliori prestazioni per la verifica delle restrizioni, è consigliabile mantenere il valore RestrictionMethod del Registro di sistema con l'impostazione corrente.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\

  3. Nel riquadro di destra fare clic con il pulsante destro del mouse su RestrictionMethod e scegliere Elimina.

  4. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare i servizi Amministrazione IIS e Microsoft Exchange - Motore di routing.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore RestrictionMethod del ?Registro di sistema, consultare l'articolo 895407 della Microsoft Knowledge Base "In Exchange Server 2003, dopo aver configurato le limitazioni relative al recapito basate sui gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento di quanto ci si aspetti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.


Trovati record "Host" ma nessun record "MX"
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue query dei server DNS utilizzati per recuperare i record MX (Mail Exchanger) dei domini remoti ai quali sono diretti gli invii di Exchange. Viene quindi eseguita una ricerca DNS per recuperare i record Host (A) dei domini remoti.

Se l'operazione di ricerca DNS non restituisce record MX per i domini remoti ma è in grado di recuperare successivamente i record Host (A) per gli stessi domini remoti, verrà visualizzato un avviso.

In questa situazione, dopo il fallito tentativo di recuperare i record MX, Exchange Server potrebbe provare a inviare posta ai server ai quali i record Host (A) fanno riferimento. È molto importante che tali record Host (A) facciano riferimento ai server di posta corretti.

Alcuni domini possono configurare i propri record Host (A) affinché facciano riferimento a un ISP (Internet Service Provider, provider di servizi Internet) che, sebbene abbia server di posta validi, potrebbe non essere il server di posta autorevole per il destinatario previsto. In questo caso la posta verrà rifiutata.

È possibile che la ricerca DNS dei record MX non venga eseguita se il server DNS è inattivo o irraggiungibile in seguito a un errore di rete o per altri motivi.

Per verificare che il server DNS è in linea e i record MX sono presenti

  1. Verificare che il server DNS sia in esecuzione eseguendo uno o più dei seguenti controlli:

    • Controllare lo stato del server DNS utilizzando il programma di amministrazione DNS nel server DNS.

    • Riavviare il server DNS. Per ulteriori informazioni, vedere "Avvio, arresto, sospensione o riavvio di un server DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=62999.

    • Verificare la capacità di risposta del server DNS utilizzando il comando nslookup. Per ulteriori informazioni, vedere le istruzioni in "Verificare la capacità di risposta del server DNS tramite il comando nslookup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63000.

  2. Utilizzare nslookup per verificare che i record MX siano configurati correttamente. Per ulteriori informazioni, consultare "Utilizzo di Nslookup per la verifica della configurazione dei record MX" nella sezione "Verifica della configurazione e della struttura del DNS" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni

  • Per informazioni sull'utilizzo da parte di Exchange Server 2003 del DNS per la risoluzione degli indirizzi IP esterni, vedere "Dipendenze del trasporto per Exchange Server 2003" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Per informazioni sulla risoluzione nomi DNS, vedere l'articolo 322856 della Microsoft Knowledge Base "Configurazione del DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • Per informazioni sulla risoluzione dei problemi del DNS, vedere "Risoluzione dei problemi relativi al servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63003.


Il valore IIS PoolThreadLimit del Registro di sistema è stato aggiunto e configurato manualmente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se il numero massimo di thread del pool Internet Information Services (IIS) è stato modificato rispetto al valore predefinito:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\Inetinfo\Parameters\PoolThreadLimit

Se Exchange Server Analyzer rileva che PoolThreadLimit è presente e configurato con un valore alternativo, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore PoolThreadLimit del Registro di sistema specifica il numero massimo di thread di lavoro di input/output (I/O) che possono essere creati nel processo Inetinfo.exe, che a sua volta controlla il numero massimo di connessioni simultanee a IIS eseguibili. Ogni thread del pool controlla eventuali richieste di rete e le elabora, restituendo un file statico o passando la richiesta a una DLL di estensione ISAPI (quale ASP.DLL) o a un'applicazione CGI (Common Gateway Interface). Se l'estensione ISAPI elabora una richiesta in modo sincrono e l'elaborazione delle richieste impiega molto tempo, il thread di lavoro verrà bloccato lasciando IIS con un numero minore di thread di lavoro per l'elaborazione di altre richieste. Per tale motivo le estensioni ISAPI scritte correttamente, quali ASP, implementano pool di thread propri, inseriscono le richieste in una coda e le elaborano in modo asincrono con i propri thread, in modo da non bloccare i thread di lavoro di IIS.

Per impostazione predefinita, IIS imposta PoolThreadLimit su:

2 * numero di MB di RAM presenti nel computer

Se il valore è maggiore di 256, verrà fissato su 256. Per impostazione predefinita, questo valore del Registro di sistema non esiste. Se il valore è presente nel Registro di sistema, sostituirà il calcolo predefinito di IIS.

In genere, se si riscontra che il limite predefinito di 256 è inadeguato, probabilmente si dispone di un'estensione ISAPI scritta male che blocca i thread di lavoro di IIS. 256 thread attivi simultaneamente sono un numero elevato che comporta un notevole sovraccarico nella sincronizzazione e nel passaggio di contesto.

Il valore PoolThreadLimit del Registro di sistema rappresenta un limite rigido che include tutti i thread di lavoro di IIS, tra cui i servizi HTTP, FTP, NNTP e SMTP.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Esaminare, eliminare o modificare il valore PoolThreadLimit.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.


Restrizione di dimensione per i messaggi in arrivo e in uscita
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-12-01

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo submissionContLength per il limite di dimensione dei messaggi in uscita è diverso dall'attributo delivContLength per quello dei messaggi in arrivo. Se Exchange Server Analyzer rileva che il limite di dimensione dei messaggi in uscita è diverso da quello dei messaggi in arrivo, verrà visualizzato un messaggio di configurazione ottimale.

Per garantire coerenza nelle restrizioni dei messaggi, si consiglia di impostare il limite di dimensione dei messaggi in uscita e quello dei messaggi in arrivo sullo stesso valore.

Per impostare il limite della dimensione dei messaggi in uscita in Exchange 2000 Server ed Exchange Server 2003

  1. Avviare Gestore di sistema di Exchange.

  2. Nel riquadro sinistro espandere Impostazioni globali.

  3. Fare clic con il pulsante destro del mouse su Recapito messaggi, quindi scegliere Proprietà.

  4. Nella scheda Valori predefiniti in Dimensione messaggi in uscita fare clic su Limite massimo (KB) e digitare un numero.
Per impostare il limite della dimensione dei messaggi in uscita in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxSendSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize unlimited
 Per modificare il limite di dimensione dei messaggi in arrivo

  1. Avviare Gestore di sistema di Exchange.

  2. Nel riquadro sinistro espandere Impostazioni globali.

  3. Fare clic con il pulsante destro del mouse su Recapito messaggi, quindi scegliere Proprietà.

  4. Nella scheda Valori predefiniti in Dimensione messaggi in arrivo fare clic su Limite massimo (KB) e digitare un numero.
Per impostare il limite della dimensione dei messaggi in arrivo in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxReceiveSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere ricevuti dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere ricevuti dai destinatari nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize unlimited

Per ulteriori informazioni sull'impostazione dei limiti di dimensione per i messaggi in Exchange 2000 Server e in Exchange Server 2003, consultare l'articolo 322679 della Microsoft Knowledge Base "Impostazione dei limiti di dimensione dei messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.

Per ulteriori informazioni sul cmdlet TransportConfig in Exchange Server 2007, consultare "Set-TransportConfig" nella sezione Informazioni tecniche di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=79237.


È stata rilevata la presenza della risposta personalizzata del Filtro messaggi intelligente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se è presente il valore CustomRejectResponse del Registro di sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di configurazione non predefinita:

  • Il valore CustomRejectResponse è presente.

  • Questo valore è una stringa valida.

    Nota:
    Il valore di stringa della risposta deve iniziare con 550 5.7.1 per essere riconosciuto come valore valido.

Non è richiesta alcuna operazione di correzione.

Il filtraggio del contenuto è installato in Exchange Server 2003 Service Pack 2 (SP2) e potrà essere utilizzato quando si installa il Service Pack 2. Exchange Server 2003 SP2 consente di personalizzare la stringa di risposta del server generata e aggiunta al rapporto di mancato recapito (NDR, Non-Delivery Report) restituito al mittente. La risposta predefinita 550 5.7.1 Requested action not taken: message refused può essere modificata per fornire agli utenti autorizzati una spiegazione sul motivo per cui il messaggio è stato bloccato. Questa spiegazione può consentire di ridurre l'analisi di falsi positivi è limitare i costi di supporto associati all'elaborazione anti spam.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per modificare la stringa di risposta personalizzata

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Exchange\ContentFilter

  3. Nel riquadro attività di destra fare clic con il pulsante destro del mouse sul valore CustomRejectResponse e selezionare Modifica.

  4. Immettere il valore di stringa da utilizzare come risposta personalizzata, iniziando la stringa con 550 5.7.1. Ad esempio, è possibile immettere 550 5.7.1 Domain not an allowed sender per impostare la stringa su un valore valido che verrà aggiunto al rapporto di mancato recapito.

  5. Per rendere effettive le modifiche, salvarle, uscire dall'editor del Registro di sistema e riavviare il servizio SMTP.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul filtraggio del contenuto, consultare la pagina Web Microsoft Exchange Intelligent Message Filter all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).

Per informazioni dettagliate su come eseguire le attività di filtraggio del contenuto, consultare "Configure Intelligent Message Filtering" nella Guida in linea di Exchange Server 2003 SP2 (informazioni in lingua inglese).

Per ulteriori informazioni sui Service Pack per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


È presente l'elenco dei termini personalizzati del Filtro messaggi intelligente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per verificare la presenza di un file MSExchange.UCEContentFilter.xml sul server di Exchange. Se Exchange Server Analyzer rileva la presenza di un file MSExchange.UCEContentFilter.xml sul server di Exchange, verrà visualizzato un messaggio di configurazione non predefinita. Non è richiesta alcuna operazione di correzione.

Il file MSExchange.UCEContentFilter.xml è un componente della funzionalità di esclusione personalizzata di termini nel Filtro messaggi intelligente per Exchange Server 2003 Service Pack 2 (SP2).

La funzionalità di esclusione personalizzata di termini nel Filtro messaggi intelligente per SP2 consente agli amministratori di personalizzare il funzionamento del Filtro messaggi intelligente in base alle frasi contenute nel corpo di un messaggio di posta elettronica, nel campo dell'oggetto o in entrambi. Alla funzionalità di esclusione personalizzata di termini non è associata alcuna interfaccia utente. Tale funzionalità è resa disponibile sotto forma di un file di configurazione XML, MSExchange.UCEContentFilter.xml, che viene letto dal Filtro messaggi intelligente durante la fase di inizializzazione e ricaricato ogni volta che il file viene modificato. Se il file MSExchange.UCEContentFilter.xml non è presente all'avvio del Filtro messaggi intelligente, è necessario riavviare il servizio SMTP. Il file della funzionalità di esclusione personalizzata di termini MSExchange.UceContentFilter.xml deve trovarsi nella stessa directory del file MSExchange.UceContentFilter.dll e dei file .dat.

Per ulteriori informazioni sul file della funzionalità di esclusione personalizzata di termini, vedere le note sulla versione di Exchange Server 2003 Service Pack 2. Le note sulla versione per Exchange Server 2003 Service Pack 2 sono disponibili sia sul CD di SP2 che sul sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52072.

Per ulteriori informazioni sui Service Pack per Exchange Server 2003, consultare il sito Web di Exchange Server 2003 Service Pack 2 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=52073.


Risposta personalizzata del Filtro messaggi intelligente non valida
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente chiave del Registro di sistema per determinare se è presente il valore CustomRejectResponse del Registro di sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\ContentFilter

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • Il valore CustomRejectResponse è presente.

  • Questa stringa di valore non inizia con 550 5.7.1.

    Nota:
    Il valore di stringa della risposta deve iniziare con 550 5.7.1 per essere riconosciuto come valore valido.

Exchange Server 2003 Service Pack 2 (SP2) consente di personalizzare la stringa di risposta del server generata e aggiunta al rapporto di mancato recapito (NDR, Non-Delivery Report) restituito al mittente. La risposta predefinita 550 5.7.1 Requested action not taken: message refused può essere modificata per fornire agli utenti autorizzati una spiegazione sul motivo per cui il messaggio è stato bloccato. Questa spiegazione può consentire di ridurre l'analisi di falsi positivi è limitare i costi di supporto associati all'elaborazione anti spam.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Exchange\ContentFilter

  3. Nel riquadro attività di destra fare clic con il pulsante destro del mouse sul valore CustomRejectResponse e selezionare Modifica.

  4. Immettere il valore di stringa da utilizzare come risposta personalizzata, iniziando la stringa con 550 5.7.1. Ad esempio, è possibile immettere 550 5.7.1 Domain not an allowed sender per impostare la stringa su un valore valido che verrà aggiunto al rapporto di mancato recapito.

  5. Per rendere effettive le modifiche, salvarle, uscire dall'editor del Registro di sistema e riavviare il servizio SMTP.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul filtraggio del contenuto, consultare la pagina Web Microsoft Exchange Intelligent Message Filter all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).

Per informazioni dettagliate su come eseguire le attività di filtraggio del contenuto, consultare "Configure Intelligent Message Filtering" nella Guida in linea di Exchange Server 2003 SP2 (informazioni in lingua inglese).


Il Filtro messaggi intelligente è abilitato sul server cassette postali
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se nel server è installato e abilitato il Filtro messaggi intelligente di Microsoft Exchange:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer legge il valore ContentFilterBindings nella chiave ContentFilter del Registro di sistema per determinare se nel server è installato e abilitato il Filtro messaggi intelligente.

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchAuthenticationFlags per l'oggetto di Exchange Server. L'attributo msExchAuthenticationFlags rappresenta il tipo di autenticazione accettato dal server. Se le seguenti condizioni vengono soddisfatte, in Exchange Server Analyzer verrà visualizzato un avviso:

  • L'autenticazione sull'attributo msExchAuthenticationFlags è stata configurata per consentire l'accesso anonimo al server.

  • Il server ospita anche cassette postali.

Il Filtro messaggi intelligente consente di identificare i messaggi che potrebbero essere posta elettronica commerciale indesiderata (UCE). Per filtrare i messaggi UCE correttamente, è necessario distribuire il Filtro messaggi intelligente sui server gateway di Exchange oppure sui server testa di ponte nel caso non si utilizzino server di posta non Microsoft al gateway. Questi server gateway accettano i messaggi di posta Internet in arrivo e li inoltrano al server cassette postali appropriato. In genere, i server gateway non ospitano cassette postali.

Inoltre, è necessario abilitare il Filtro messaggi intelligente su tutti i server virtuali SMTP che accettano i messaggi di posta Internet sui server gateway di Exchange.

Importante:
Non disabilitare l'accesso anonimo sui server virtuali SMTP gateway di Internet. I server virtuali SMTP che accettano la posta da Internet devono consentire l'accesso anonimo.

Per filtrare i messaggi UCE, è possibile configurare il Filtro messaggi intelligente impostando soglie SCL (Spam Confidence Level) relative al livello di sicurezza della protezione contro la posta indesiderata assegnate ai messaggi in arrivo sia al gateway che agli archivi delle cassette postali di Exchange. Il Filtro messaggi intelligente consente di esaminare e di assegnare a ciascun messaggio in arrivo un livello di sicurezza della protezione contro la posta indesiderata basato sulla probabilità che tale messaggio sia un messaggio UCE. Nei server cassette postali di Exchange vengono utilizzate le soglie e le impostazioni SCL specificate per l'archivio delle cassette postali per determinare se recapitare un messaggio nella cartella Posta in arrivo o in quella Posta indesiderata di un utente.

Importante:
Non è necessario installare il Filtro messaggi intelligente nei server cassette postali di Exchange. Se il Filtro messaggi intelligente è installato e abilitato sui server virtuali SMTP gateway, i server cassette postali di Exchange riceveranno il livello SCL con ogni messaggio in arrivo e adotteranno le misure appropriate.

Per ulteriori informazioni, consultare la pagina Web Microsoft Exchange Intelligent Message Filter all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese). Per ulteriori informazioni sulla configurazione dell'organizzazione di Microsoft Exchange Server 2003 per l'invio e la ricezione della posta Internet, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Il Filtro messaggi intelligente non è abilitato sul server
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se nel server è installato e abilitato il Filtro messaggi intelligente di Microsoft Exchange:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Se Exchange Server Analyzer rileva che la voce ContentFilterBindings è presente nella chiave del Registro di sistema ContentFilter ma che il valore di ContentFilterBindings non è configurato, verrà visualizzato un avviso.

Nota:
La presenza del valore ContentFilterBindings nella chiave ContentFilter del Registro di sistema quando lo stesso valore ContentFilterBindings non è configurato indica che il Filtro messaggi intelligente non è abilitato sul server.
Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Il Filtro messaggi intelligente di Microsoft Exchange consente di identificare i messaggi che potrebbero essere posta elettronica commerciale indesiderata (UCE). Dopo aver distribuito il Filtro messaggi intelligente sui server gateway di Exchange oppure sui server testa di ponte che accettano posta in arrivo, è necessario abilitare il Filtro messaggi intelligente su ciascun server virtuale SMTP che accetti i messaggi di posta Internet.

Per visualizzare la chiave ContentFilter del Registro di sistema

  1. Nel riquadro dei dettagli dell'editor del Registro di sistema (regedit) fare clic con il pulsante destro del mouse su ContentFilter per visualizzare le impostazioni di ContentFilterBindings.

    Nota:
    Se non si è configurato il Filtro messaggi intelligente di Exchange sul server virtuale SMTP, il valore di ContentFilterBindings sarà null.

    Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

È consigliabile abilitare il Filtro messaggi intelligente di Exchange su tutti i server Exchange in cui è installato. Per abilitare il Filtro messaggi intelligente di Exchange sul server virtuale SMTP, procedere come indicato di seguito. Dopo aver abilitato il Filtro messaggi intelligente, è possibile verificare il valore della chiave ContentFilter del Registro di sistema.

Per abilitare il Filtro messaggi intelligente

  1. fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. In Gestore di sistema di Exchange espandere Server, Server name, Protocolli e infine SMTP, fare clic con il pulsante destro del mouse su Filtraggio del contenuto e scegliere Proprietà.

  3. Nella scheda Generale, nella sezione Applica filtraggio del contenuto per i seguenti indirizzi IP dei server virtuali selezionare la casella di controllo vicino a ogni server virtuale SMTP su cui si desidera abilitare il Filtro messaggi intelligente.

    La finestra di dialogo delle proprietà del Filtro messaggi intelligente

Per ulteriori informazioni, consultare la pagina Web Microsoft Exchange Intelligent Message Filter all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).


È stato designato un server per il Servizio aggiornamento destinatari non valido
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-07-30

Microsoft Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory per determinare il valore dell'attributo msExchAddressListServiceLink per ogni oggetto del Servizio aggiornamento destinatari della directory. L'attributo msExchAddressListServiceLink è un collegamento dal servizio elenco di indirizzi al computer Exchange Server che sta eseguendo il Servizio aggiornamento destinatari (RUS).

Exchange Analyzer esegue quindi una query nella classe Microsoft WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare il valore della chiave Version per il Servizio visualizzazione Rubrica e Gruppi dinamici (abv_dg.dll) nei computer Exchange Server identificati. La chiave WMI Version indica il numero di versione del file.

Se Exchange Analyzer rileva che il numero di versione del file abv_dg.dll in uno dei computer identificati inizia con 08, verrà visualizzato un messaggio di errore.

L'errore indica che il computer designato come server RUS esegue Microsoft Exchange Server 2007.

Il Servizio aggiornamento destinatari è un componente del servizio Supervisore sistema di Exchange disponibile in Exchange 2000 Server ed Exchange Server 2003. Il Servizio aggiornamento destinatari per Exchange 2000 ed Exchange 2003 crea e mantiene valori di attributo specifici di Exchange in Active Directory. Tale funzionalità è gestita dal processo di creazione dei destinatari in Exchange 2007 e il Servizio aggiornamento destinatari legacy non elabora gli aggiornamenti se viene eseguito su un server Exchange 2007.

Per risolvere il problema, designare Exchange 2000 Server o Exchange Server 2003 come host del Servizio aggiornamento destinatari.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. In Destinatari fare clic su Servizi aggiornamento destinatari. Nel riquadro di spostamento a destra fare clic con il pulsante destro del mouse sull'istanza appropriata del Servizio aggiornamento destinatari, quindi scegliere Proprietà.

  3. Nella scheda Generale, in Exchange Server fare clic su Sfoglia e specificare un nuovo server Exchange 2000 Server or Exchange Server 2003 per eseguire l'istanza RUS.

  4. Per rendere effettive le modifiche, fare clic su OK, quindi fare nuovamente clic su OK.


Elevato numero di classificazioni in corso
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer che eseguono Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dai contatori di prestazioni Cat: Classificazioni in corso dell'oggetto prestazioni SMTP Server per l'analisi dei dati sulle prestazioni.

Il contatore di prestazioni Cat: Classificazioni in corso indica il numero di classificazioni in corso.

Per questa query, Exchange Server Analyzer recupera un esempio ogni 6 secondi in un periodo di due minuti. Il valore medio del contatore di prestazioni viene restituito durante l'intervallo di raccolta.

Se Exchange Server Analyzer rileva che il numero medio di classificazioni in corso nel periodo di esempio supera 800, verrà visualizzato un errore.

Il classificatore esegue le seguenti operazioni principali:

  • Risolve e convalida tutti i destinatari.

  • Determina i limiti e le restrizioni per tutti i destinatari.

  • Espande le liste di distribuzione, se richiesto.

  • Determina se il messaggio è per il recapito locale o remoto.

L'errore potrebbe indicare che nel server è presente un carico straordinario oppure sono presenti problemi correlati alle prestazioni.

Per risolvere il problema:

  • Determinare se il sovraccarico del classificatore è previsto oppure è atipico. Se si tratta di un carico previsto, vedere le informazioni relative alle prestazioni di Exchange reperibili negli articoli di Microsoft TechNet riportati di seguito.

    • "Risoluzione dei problemi relativi alle prestazioni di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

    • "Manuale relativo alle prestazioni e alla scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Se il sovraccarico del classificatore è imprevisto, verificare se il carico generato dipende da eventuali attacchi di virus o da posta indesiderata.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP (Simple Mail Transfer Protocol) virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.


Numero elevato di cassette postali con restrizioni di recapito ai gruppi di distribuzione impostate
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool esegue una query nei seguenti attributi per ciascun oggetto utente in tutti i domini rilevati nel servizio directory di Active Directory® per determinare se le cassette postali nei domini presentano restrizioni relative al recapito in base all'appartenenza al gruppo di distribuzione.

dLMemDefault | Verifica se i messaggi vengono accettati o rifiutati per impostazione predefinita. L'impostazione sul valore predefinito 1 indica che vengono accettati tutti i messaggi.
dLMemRejectPerms | Contiene i DN di liste di distribuzione (DL) con membri che potrebbero non effettuare l'invio al destinatario.
dLMemSubmitPerms | Contiene i DN di liste di distribuzione (DL) con membri che potrebbero effettuare l'invio al destinatario.

Se Exchange Server Analyzer determina che nel dominio sono presenti più di 500 cassette postali con restrizioni di recapito impostate in base all'appartenenza a gruppi di distribuzione, verrà visualizzato un errore.

L'errore indica che le restrizioni di recapito basate sull'appartenenza a gruppi di distribuzione per molte cassette postali potrebbe influire sulle prestazioni del flusso di posta di Exchange.

Per impostazione predefinita, il classificatore espande in modo ricorsivo i gruppi di distribuzione e verifica le restrizioni per ciascun messaggio che passa nel sistema.

Quando il classificatore invia la posta a un utente che accetta o rifiuta i messaggi provenienti da un gruppo di distribuzione, deve espandere l'appartenenza al gruppo, ottenere l'elenco completo dei DN dei membri e quindi confrontare l'elenco di DN con i DN del mittente dell'elenco. Se viene visualizzato un DN in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

Per risolvere il problema

  • Esaminare gli utenti per i quali sono impostate le restrizioni di recapito del gruppo di distribuzione e rimuovere le restrizioni non necessarie.

  • Configurare cassette postali individuali e non gruppi di distribuzione per le restrizioni di recapito come menzionato nell'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

  • Per i server che eseguono Exchange Server 2003 Service Pack 2 (SP2) o una versione successiva, implementare la verifica delle restrizioni non gerarchica. Per i server che eseguono versioni di Exchange precedenti a Exchange Server 2003 SP2, è consigliabile eseguire l'aggiornamento a Exchange Server 2003 SP2.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange Server, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 895407, "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949, "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298, "Il recapito della posta è lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.


Il routing più breve è abilitato in un'organizzazione a modalità mista
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se è abilitato il routing più breve sul server su cui viene eseguito Exchange Server versione 5.5 in un ambiente a modalità mista. Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • Il routing più breve è abilitato.

  • L'organizzazione esegue Exchange Server 2003 in un ambiente a modalità mista con Exchange Server 5.5.

Quando è abilitato il routing con il costo più basso, ovvero con il percorso più breve, in un ambiente a modalità mista, potrebbero crearsi dei loop di messaggi. In Exchange Server 2003 viene utilizzato il routing in base allo stato dei collegamenti. Pertanto, quando Exchange Server 2003 rileva che un collegamento è inattivo, i messaggi vengono reindirizzati a un altro server. Se su un server di Exchange Server 5.5 si utilizza l'opzione Only use least cost routes nella pagina delle proprietà Message Transfer Agent, in genere la route migliore corrisponde al percorso di ritorno al server di Exchange 2003 dal punto dal quale è appena stato inviato il messaggio. Se il messaggio viene nuovamente inviato al server di Exchange Server 2003, la route diventa un loop.

Nelle organizzazioni a modalità mista che eseguono sia Exchange Server 5.5 che Exchange Server 2003, si consiglia di disabilitare l'opzione di routing più breve su tutti i server che eseguono Exchange Server 5.5.

Per disabilitare il routing più breve in Exchange Server 5.5

  1. Nel programma di amministrazione di Microsoft Exchange Server espandere i contenitori Organizzazione, Sito, Configurazione, Server, quindi fare clic sull'oggetto server.

  2. Nel riquadro destro fare clic sull'oggetto Agente di trasferimento messaggi.

  3. Dal menu File scegliere Proprietà.

  4. Nella scheda Generale della finestra di dialogo delle proprietà di Agente di trasferimento messaggi deselezionare Utilizza solo le route più brevi.

  5. Fare clic su OK.


La porta di ascolto per SMTP potrebbe essere stata impostata su un valore diverso da quello predefinito di 25
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato per l'attributo msExchServerBindings è diverso da quello predefinito di 25. Per impostazione predefinita, l'attributo msExchServerBindings è configurato per la porta TCP 25. Se Exchange Server Analyzer rileva che il valore di questo attributo non corrisponde a 25, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchServerBindings rappresenta la porta TCP su cui il server SMTP (Simple Mail Transfer Protocol) è configurato per l'ascolto di connessioni in ingresso. È possibile configurare i server virtuali SMTP per l'ascolto su una o più porte TCP. Per impostazione predefinita, tutti i server virtuali SMTP sono configurati per l'ascolto sulla porta TCP 25, la porta SMTP predefinita. Se la porta di attesa SMTP viene modificata rispetto a quella predefinita e se non include più la porta TCP 25 nell'elenco delle porte di attesa, potrebbero verificarsi dei problemi nel flusso di posta.

La porta di attesa SMTP può essere modificata a condizione che anche l'intera infrastruttura di messaggistica interna venga modificata di conseguenza. In genere, tuttavia, non è possibile utilizzare porte alternative per server virtuali SMTP che accettano messaggi direttamente da Internet, dal momento che nei server SMTP in Internet i messaggi vengono inviati tramite la porta 25.

Notare che Exchange Server Analyzer esamina il valore del server virtuale dei protocolli SMTP di Exchange. Il server virtuale dei protocolli SMTP può corrispondere o meno al server SMTP che riceve messaggi direttamente da Internet. Esistono alcuni prodotti antivirus e anti spam progettati per ricevere messaggi SMTP da Internet sulla porta 25 e per reindirizzarli a un server virtuale SMTP di Exchange su un'altra porta. In questo tipo di scenario, una configurazione accettabile è rappresentata da un server virtuale SMTP di Exchange in ascolto su una porta diversa dalla 25.

Per visualizzare o modificare la porta di attesa del server virtuale SMTP

  1. In Gestore di sistema di Exchange espandere Server, un server di Exchange, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito), quindi scegliere Proprietà.

  3. Selezionare la scheda Generale e fare clic su Avanzate.

  4. Verrà visualizzato un elenco degli indirizzi IP e delle porte

    • Per modificare la porta esistente, selezionare l'indirizzo IP quindi fare clic su Modifica. Modificare il valore nel campo Porta TCP impostandolo su 25.

    • Per aggiungere la porta 25 come porta di ascolto aggiuntiva, fare clic su Aggiungi, quindi aggiungere la nuova combinazione indirizzo IP/porta. Se si utilizzano i filtri destinatario, mittente e connessione, assicurarsi di selezionare le caselle di controllo appropriate.

  5. Fare clic su OK per salvare le modifiche, quindi fare clic su OK per uscire dalla finestra di dialogo Avanzate. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


La coda Recapito locale è bloccata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-03

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateFrozen per la coda SMTP Recapito locale.

Se Exchange Server Analyzer rileva che il valore della chiave StateFrozen per la coda Recapito locale in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda risulta bloccata, le sessioni di trasporto dirette a questa coda vengono arrestate. Una coda bloccata impedisce l'invio dei messaggi in uscita, anche se è possibile aggiungere nuovi messaggi. È possibile modificare manualmente lo stato di una connessione utilizzando il menu di scelta rapida in ciascuna coda di collegamento. Se viene utilizzato il comando Imponi connessione per modificare lo stato di una coda su Attiva, viene immediatamente abilitata una connessione che invia messaggi da quella coda.

La coda Recapito locale contiene messaggi accodati nel server Exchange per il recapito locale a una cassetta postale o archivio delle cartelle pubbliche di Exchange Server.

I messaggi possono accumularsi nella coda se il server Exchange non accetta messaggi per il recapito locale. Un recapito lento o intermittente potrebbe indicare un loop di messaggi o un problema di prestazioni.

Per correggere questo errore, aumentare la registrazione diagnostica per il servizio MSExchangeTransport per raccogliere informazioni sui componenti del classificatore.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda Recapito locale si trova in stato Riprova
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-03

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateRetry per la coda SMTP Recapito locale.

Se Exchange Server Analyzer rileva che il valore della chiave StateRetry per la coda Recapito locale in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda è nello stato Riprova, tale stato indica che si è verificato almeno un errore nei precedenti tentativi di elaborare i messaggi nella coda. È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione. In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre. Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

La coda Recapito locale contiene messaggi accodati nel server Exchange per il recapito locale a una cassetta postale o archivio delle cartelle pubbliche di Exchange Server.

I messaggi possono accumularsi nella coda se il server Exchange non accetta messaggi per il recapito locale. Un recapito lento o intermittente potrebbe indicare un loop di messaggi o un problema di prestazioni.

Per correggere questo errore, aumentare la registrazione diagnostica per il servizio MSExchangeTransport per raccogliere informazioni sui componenti del classificatore.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Errore di accettazione della posta
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool tenta di inviare un messaggio all'account Postmaster o a un account definito dall'utente per il dominio SMTP (Simple Mail Transfer Protocol) nel modo seguente:

  • Exchange Server Analyzer stabilisce una connessione socket al server SMTP. Se Exchange Server Analyzer riceve un codice di risposta pari a 220, questo passaggio è da considerarsi completato correttamente.

  • Exchange Server Analyzer trasmette il comando SMTP EHLO. Se si verificano le seguenti condizioni, questo passaggio è da considerarsi completato correttamente:

    • Exchange Server Analyzer riceve una serie di codici di risposta di 250.

    • Una di queste risposte include 250-X-LINK2STATE e 250-XEXCH50.

  • Exchange Server Analyzer trasmette il comando SMTP MAIL FROM: ExMFA-MailAcceptTest@Fabrikam.com. Se Exchange Server Analyzer riceve un codice di risposta pari a 250, questo passaggio è da considerarsi completato correttamente.

  • Exchange Server Analyzer trasmette il comando SMTP RCPT TO: Postmaster (o un account definito dall'utente)@<nome dominio>.com. Se Exchange Server Analyzer riceve un codice di risposta pari a 250, questo passaggio è da considerarsi completato correttamente.

  • Exchange Server Analyzer trasmette il comando SMTP DATA con un messaggio di esempio che termina con un punto. Se Exchange Server Analyzer riceve un codice di risposta pari a 250, questo passaggio è da considerarsi completato correttamente.

Se non è possibile eseguire tutti i passaggi, verrà visualizzato un errore. Tale messaggio indica che può essersi verificato un problema generale di flusso di posta. I collegamenti indicati di seguito vengono elencati nell'ordine in cui dovrebbero essere risolti i problemi, iniziando dal livello di server e spostandosi al livello di rete.

Per correggere questo errore

  1. Consultare "Risoluzione dei problemi di routing" nella Guida al trasporto e al routing di Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=47579.

  2. Consultare l'articolo 324867 della Microsoft Knowledge Base "WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi di flusso di posta (rivisto)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324867.

  3. Consultare l'articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=823489.

  4. Consultare l'articolo 324759 della Microsoft Knowledge Base "WebCast: Microsoft Exchange 2000 Server: Risoluzione dei problemi DNS nei trasporti" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324759.

Per ulteriori informazioni sull'account Postmaster in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 223860 "XCON: La cassetta postale SMTP Postmaster deve essere impostata manualmente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=223860.

  • 313832, "Impostazione di un account Postamaster SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=313832.


Errore nell'accettazione della posta, comando BDAT
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool trasmette il comando ESMTP (Extended Simple Mail Transfer Protocol) EHLO alla porta 25 di un server remoto e analizza la risposta per determinare se il server remoto supporta il comando ESMTP BDAT.

Se la risposta ricevuta dal server remoto in risposta al comando BDAT non indica un errore irreversibile, Exchange Server Analyzer trasmette un messaggio di prova al server remoto e analizza la risposta per determinare se il trasferimento del messaggio viene completato.

Se Microsoft Exchange Server Analyzer non riceve la stringa di risposta "250" prevista, verrà visualizzato un errore.

In Exchange Server 2003 vengono utilizzati comandi SMTP estesi specifici di Exchange per la comunicazione con altri server che eseguono Exchange Server nell'organizzazione. La comunicazione tramite comandi SMTP estesi specifici di Exchange risulta più efficiente dell'utilizzo di comandi SMTP standard. Se il supporto del set di comandi ESMTP è disattivato, è possibile che le prestazioni di Exchange Server ne risentano.

Il comando ESMTP BDAT è un'alternativa al comando DATA. Se un server virtuale SMTP risponde alla parola chiave EHLO con CHUNKING, il server SMTP indica che supporta il comando BDAT e accetterà i messaggi in blocchi. Vengono utilizzati due argomenti:

  • Il primo argomento indica la lunghezza del pacchetto di dati binari. Pertanto l'host SMTP non deve eseguire continuamente la scansione per trovare la fine dei dati. Il server di ricezione conta i byte nel messaggio. Se la dimensione del messaggio è pari al valore inviato dal comando BDAT, il server presume di aver ricevuto tutti i dati del messaggio.

  • Il secondo argomento indica se il pacchetto di dati è l'ultimo pacchetto nella trasmissione corrente. Il secondo argomento è facoltativo.

L'errore indica che sebbene il comando ESMTP BDAT sia supportato dal server remoto, il successivo test di accettazione della posta non è riuscito.

Per risolvere l'errore, verificare se nell'ambiente di messaggistica sono presenti problemi o configurazioni che potrebbero bloccare il comando BDAT, ad esempio:

  • Interruzioni di rete temporanee

  • Proxy SMTP

  • Firewall

  • Applicazioni

Per ulteriori informazioni su come rimuovere o ripristinare il supporto predefinito per questi comandi, consultare l'articolo 257569 della Microsoft Knowledge Base "Disattivazione dei comandi ESMTP in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257569.

Per ulteriori informazioni sull'utilizzo dei comandi ESMTP in Exchange Server, vedere "How to Load Exchange SMTP Properly" nella Exchange Server Transport and Routing Guide http://go.microsoft.com/fwlink/?LinkID=71800 (informazioni in lingua inglese).


Archivio cassette postali identificato come destinazione comune
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-04

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Queue per determinare i valori dei seguenti attributi per le code SMTP del server virtuale SMTP.

LinkId | Indica l'identificatore del collegamento che contiene la coda.
QueueId | Indica l'identificatore della coda.
QueueName | Indica il nome della coda.
VirtualMachine | Indica il nome del computer virtuale che contiene la coda.
VirtualServerName | Indica il nome del server virtuale su cui si trova la coda.
MessageCount | Indica il numero di messaggi nella coda.

In Exchange Server Analyzer vengono utilizzate le informazioni ottenute qui per eseguire una query nella classe WMI Exchange_QueuedSMTPMessage per determinare i valori dei seguenti attributi dei messaggi nella coda:

Recipients | Indica i destinatari del messaggio.
Received | Indica il timestamp del messaggio ricevuto.
MessageId | Indica l'identificatore del messaggio in coda.
StateRetry | Indica un nuovo tentativo di trasmissione di un messaggio non recapitato correttamente.

Infine, i dati ottenuti da Microsoft® Exchange Server Analyzer vengono utilizzati per eseguire una query nel servizio directory di Active Directory® per determinare i valori riportati di seguito per ciascun oggetto Recipient. Quindi viene determinato se il destinatario è un utente, un gruppo di distribuzione, una cartella pubblica o un archivio delle cartelle pubbliche:

distinguishedName | Indica il nome distinto dell'oggetto.
msExchHomeServerName | Indica il server in cui si trova il destinatario.
homeMDB | Indica l'archivio delle cassette postali del destinatario.

Se Exchange Server Analyzer determina che almeno il 25% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a destinatari le cui cassette postali si trovano nello stesso archivio cassette postali, verrà visualizzato un avviso.

Se Exchange Server Analyzer determina che almeno il 50% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a destinatari le cui cassette postali si trovano nello stesso archivio cassette postali, verrà visualizzato un errore.

L'avviso o l'errore indica che l'archivio cassette postali identificato è una destinazione comune per i messaggi bloccati in una coda SMTP.

Per risolvere il problema è necessario ricercare nell'archivio cassette postali problemi di configurazione o altre anomalie che possono causare un accodamento dei messaggi destinati ad esso. Per eseguire l'operazione procedere come segue:

  • Assicurarsi che gli attributi dell'oggetto archivio siano impostati correttamente e contengano i valori corretti in Active Directory.

  • Esaminare che le impostazioni delle autorizzazioni di Active Directory per l'oggetto archivio siano corrette.

  • Se l'archivio cassette postali ospita un oggetto utente per uso speciale, ovvero un destinatario diario designato, esaminare che le configurazioni del servizio o dei componenti a cui è correlato l'ogetto utente siano corrette.

  • Ricercare eventuali messaggi di posta elettronica pubblicitari non richiesti, spam o attacchi virus ai destinatari dell'archivio.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.


La coda "Messaggi con destinazione irraggiungibile" trattiene messaggi
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-04

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore delle proprietà TypeCurrentlyUnreachable, LinkName e NumberofMessages per le code SMTP sul server.

Se la proprietà TypeCurrentlyUnreachable è True, specifica che il collegamento (coda di Exchange) trattiene messaggi per destinazioni che attualmente non sono raggiungibili.

La proprietà LinkName specifica il nome del collegamento.

La proprietà NumberOfMessages specifica il numero di messaggi in attesa di essere trasmessi attraverso il collegamento.

Se Exchange Server Analyzer determina che la coda SMTP Messaggi con destinazione irraggiungibile non contiene messaggi, verrà visualizzato un messaggio di errore.

Tale errore indica che sono presenti messaggi nella coda che non possono essere recapitati al server di destinazione. Ad esempio, Exchange non è in grado di determinare una route o un connettore alla destinazione finale. In alternativa, tutte le route o i connettori sono contrassegnati come inattivi.

Per risolvere il problema, procedere come segue:

  • Determinare se i messaggi nella coda Messaggi con destinazione irraggiungibile sono legittimi.

  • Analizzare le indicazioni dell'errore e i collegamenti forniti da Exchange Server Analyzer.

  • Seguire le istruzioni fornite nella sezione "Per ulteriori informazioni" più avanti nell'argomento.

Per ulteriori informazioni

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.


La coda "Messaggi con destinazione irraggiungibile" è bloccata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateFrozen per la coda SMTP Messaggi con destinazione irraggiungibile.

Se Exchange Server Analyzer rileva che il valore della chiave StateFrozen per la coda Messaggi con destinazione irraggiungibile in un server Exchange è impostato su True, viene visualizzato un errore.

Se una coda risulta bloccata, le sessioni di trasporto dirette a questa coda vengono arrestate. Una coda bloccata impedisce l'invio dei messaggi in uscita, anche se è possibile aggiungere nuovi messaggi.

Nella coda Messaggi con destinazione irraggiungibile sono contenuti i messaggi che non possono raggiungere il server di destinazione previsto. Ad esempio, Exchange non è in grado di determinare una route o un connettore alla destinazione finale. In alternativa, tutte le route o i connettori sono contrassegnati come inattivi. I messaggi si possono accumulare in questa coda se si verifica una delle seguenti condizioni:

  • Non esiste alcuna route per il recapito dei messaggi.

  • Non è disponibile un connettore Exchange o una coda di recapito remota.

  • Nuovi messaggi vengono spostati in questa coda se un connettore Exchange o una coda di recapito remota si trova nello stato Riprova e non sono disponibili route alternative al connettore o alla destinazione remota.

Per correggere l'errore, modificare manualmente lo stato della connessione utilizzando il menu di scelta rapida in ciascuna coda di collegamento. Se viene utilizzato il comando Imponi connessione per modificare lo stato di una coda su Attiva, viene immediatamente abilitata una connessione che invia messaggi da quella coda. Se l'errore persiste, aumentare il livello di registrazione diagnostica del Motore di accodamento come descritto nella sezione "Per ulteriori informazioni" più avanti nell'argomento.

Per ulteriori informazioni

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base sulla descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Informazioni sugli stati delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda "Messaggi con destinazione irraggiungibile" è in stato Riprova
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateRetry per la coda SMTP Messaggi con destinazione irraggiungibile.

Se Exchange Server Analyzer rileva che il valore della chiave StateRetry per la coda Messaggi con destinazione irraggiungibile in un server Exchange è impostato su True, viene visualizzato un errore.

Se una coda è nello stato Riprova, tale stato indica che si è verificato almeno un errore nei precedenti tentativi di elaborare i messaggi nella coda.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

Nella coda Messaggi con destinazione irraggiungibile sono contenuti i messaggi che non possono raggiungere il server di destinazione previsto. Ad esempio, Exchange non è in grado di determinare una route o un connettore alla destinazione finale. In alternativa, tutte le route o i connettori sono contrassegnati come inattivi. I messaggi si possono accumulare in questa coda se si verifica una delle seguenti condizioni:

  • Non esiste alcuna route per il recapito dei messaggi.

  • Non è disponibile un connettore Exchange o una coda di recapito remota.

  • Nuovi messaggi vengono spostati in questa coda se un connettore Exchange o una coda di recapito remota si trova nello stato Riprova e non sono disponibili route alternative al connettore o alla destinazione remota.

Per risolvere l'errore è possibile modificare lo stato da Riprova ad Attiva mediante il comando Imponi connessione . In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi. Tuttavia, questo metodo potrebbe non funzionare sempre. Se l'errore persiste, aumentare il livello di registrazione diagnostica del Motore di accodamento come descritto nella sezione "Per ulteriori informazioni" più avanti nell'argomento.

Per ulteriori informazioni

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base sulla descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Informazioni sugli stati delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Cassette postali con restrizioni di recapito ai gruppi di distribuzione impostate
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool esegue una query nei seguenti attributi di ciascun oggetto gruppo di distribuzione in tutti i domini trovati nel servizio directory di Active Directory® per determinare l'eventuale esistenza nei domini di cassette postali con restrizioni di recapito impostate in base all'appartenenza al gruppo di distribuzione:

dLMemDefault | Controlla se i messaggi vengono accettati o rifiutati per impostazione predefinita. L'impostazione sul valore predefinito 1 indica che vengono accettati tutti i messaggi.
dLMemRejectPerms | Contiene i DN di liste di distribuzione (DL) con membri che potrebbero non effettuare l'invio al destinatario.
dLMemSubmitPerms | Contiene i DN di liste di distribuzione (DL) con membri che potrebbero effettuare l'invio al destinatario.

Se Exchange Server Analyzer determina l'esistenza di cassette postali nel dominio con restrizioni di recapito impostate in base all'appartenenza a gruppi di distribuzione, verrà visualizzato un avviso.

Tale avviso indica che le restrizioni di recapito basate sull'appartenenza a gruppi di distribuzione potrebbero influire sulle prestazioni del flusso di posta di Exchange Server.

Il classificatore per impostazione predefinita espande ricorsivamente i gruppi di distribuzione e verifica le restrizioni di ciascun messaggio che attraversa il sistema.

Quando il classificatore invia la posta a un utente che accetta o rifiuta i messaggi provenienti da un gruppo di distribuzione, deve espandere l'appartenenza al gruppo, ottenere l'elenco completo dei DN dei membri e quindi confrontare l'elenco di DN con i DN del mittente dell'elenco. Se viene visualizzato un DN in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

Per risolvere il problema

  • Esaminare gli utenti per i quali sono impostate le restrizioni di recapito del gruppo di distribuzione e rimuovere le restrizioni non necessarie.

  • Configurare cassette postali individuali e non gruppi di distribuzione per le restrizioni di recapito come menzionato nell'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

  • Per i server che eseguono Exchange Server 2003 Service Pack 2 (SP2) o una versione successiva, implementare la verifica delle restrizioni non gerarchica. Per i server che eseguono versioni di Exchange precedenti a Exchange Server 2003 SP2, è consigliabile eseguire l'aggiornamento a Exchange Server 2003 SP2.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange Server, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 895407, "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949, "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298, "Il recapito della posta è lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.


La dimensione massima del messaggio in arrivo non è stata impostata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore relativo all'attributo delivContLength delle impostazioni globali che si trova in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se Exchange Server Analyzer rileva che il valore dell'attributo delivContLength è inferiore a 1, verrà visualizzato un messaggio di errore.

Tale messaggio indica che non è stato impostato un limite per la dimensione massima del messaggio in arrivo. In base alla larghezza di banda della rete e ai requisiti dell'utente nell'ambito di un'organizzazione, può essere necessario limitare la dimensione dei messaggi. Exchange 2000 Server ed Exchange Server 2007 non prevedono alcun limite predefinito per la dimensione dei messaggi. In Exchange Server 2003 il limite di dimensione predefinito per l'invio e la ricezione dei messaggi è 10.240 KB. Questo limite predefinito per Exchange Server 2003 si applica alle nuove installazioni e agli aggiornamenti da Exchange 2000 Server in cui non è stato impostato alcun limite per la dimensione dei messaggi.

È possibile ottimizzare le risorse del sistema impostando i limiti di dimensione dei messaggi per impedire agli utenti di inviare e ricevere messaggi di posta elettronica di grandi dimensioni. In questo modo sarà possibile limitare il traffico di rete, risparmiare spazio su disco e migliorare le prestazioni complessive della rete. In Exchange 2000 Server ed Exchange Server 2003 è possibile utilizzare la scheda Valori predefiniti in Proprietà recapito messaggi delle Impostazioni globali per specificare le limitazioni relative al recapito, sia per i messaggi in entrata sia per quelli in uscita. Quindi, per impostare la dimensione massima di un singolo messaggio, selezionare Limite massimo (KB) e specificare nella casella di testo una dimensione massima in kilobyte (KB). Se non si desidera impostare un limite per la dimensione dei messaggi, selezionare Nessun limite. I mittenti all'interno di un'organizzazione ricevono un rapporto di mancato recapito (NDR) se tentano di inviare un messaggio di dimensioni superiori al limite consentito. A seconda delle impostazioni NDR configurate in Formato messaggi Internet, i mittenti esterni sono abilitati o meno a ricevere un NDR.

In Exchange Server 2007 è possibile utilizzare Exchange Management Shell per impostare il parametro TransportConfig MaxReceiveSize per l'organizzazione di Exchange.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 10 MB. Se, tuttavia, è necessario un limite maggiore per la dimensione dei messaggi con grandi allegati che devono essere inviati attraverso l'organizzazione di Exchange, sarà possibile aumentare il limite della dimensione massima dei messaggi in arrivo fino a 30 MB. L'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare un rallentamento delle prestazioni della rete e rendere il sistema più vulnerabile agli attacchi alla protezione.

Per impostare limiti della dimensione dei messaggi in Exchange 2000 Server e Exchange Server 2003

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e scegliere Proprietà.

  2. Nella scheda Valori predefiniti della finestra di dialogo Proprietà di Recapito messaggi selezionare l'opzione Dimensione messaggi in arrivo e specificare il limite di dimensione desiderato.

Per impostare limiti della dimensione dei messaggi in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxReceiveSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere ricevuti dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere ricevuti dai destinatari nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize unlimited
  • Per ulteriori informazioni sull'impostazione dei limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003, consultare l'articolo 322679 della Microsoft Knowledge Base, "Impostazione di limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

  • Per ulteriori informazioni sul cmdlet TransportConfig in Exchange Server 2007, consultare "Set-TransportConfig" nella sezione Informazioni tecniche di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=79237.

  • Per ulteriori informazioni sui formati dei messaggi Internet, consultare l'argomento "Utilizzo dei criteri SMTP per il controllo della formattazione della posta in uscita e delle risposte automatiche" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


La dimensione massima del messaggio in arrivo è impostata su un valore troppo elevato (>30MB)
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-02-27

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore relativo all'attributo delivContLength delle impostazioni globali che si trova in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se Exchange Server Analyzer rileva che il valore dell'attributo delivContLength è superiore a 30720, verrà visualizzato un messaggio di errore.

Tale messaggio indica che è stato impostato un limite massimo per la dimensione dei messaggi in arrivo su un valore superiore a 30 megabyte (MB). In Exchange 2000 Server ed Exchange Server 2007 non è previsto alcun limite predefinito per la dimensione dei messaggi. In Exchange Server 2003 il limite di dimensione predefinito per l'invio e la ricezione dei messaggi è 10.240 KB. Questo limite predefinito si applica alle nuove installazioni e agli aggiornamenti da Exchange 2000 Server in cui non è stato impostato alcun limite alla dimensione dei messaggi.

È possibile ottimizzare le risorse del sistema impostando i limiti di dimensione dei messaggi per impedire agli utenti di inviare e ricevere messaggi di posta elettronica di grandi dimensioni. In questo modo sarà possibile limitare il traffico di rete, risparmiare spazio su disco e migliorare le prestazioni complessive della rete. In Exchange 2000 Server ed Exchange Server 2003 è possibile utilizzare la scheda Valori predefiniti in Proprietà recapito messaggi delle Impostazioni globali per specificare le limitazioni relative al recapito, sia per i messaggi in entrata sia per quelli in uscita. Per impostare la dimensione massima di un singolo messaggio, selezionare Limite massimo (KB) e specificare nella casella di testo una dimensione massima in kilobyte (KB). Se non si desidera impostare un limite per la dimensione dei messaggi, selezionare Nessun limite. I mittenti all'interno di un'organizzazione ricevono un rapporto di mancato recapito (NDR) se tentano di inviare un messaggio a un utente che va oltre il limite di dimensione specificato. A seconda delle impostazioni NDR configurate in Formato messaggi Internet, i mittenti esterni potrebbero non essere abilitati a ricevere un NDR.

In Exchange Server 2007 è possibile utilizzare Exchange Management Shell per impostare il parametro TransportConfig MaxSendSize per l'organizzazione di Exchange.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 30 MB. Se, tuttavia, è necessario un limite maggiore per la dimensione dei messaggi con grandi allegati che devono essere inviati attraverso l'organizzazione di Exchange, sarà possibile aumentare il limite della dimensione massima dei messaggi in arrivo oltre i 30 MB. L'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare un rallentamento delle prestazioni della rete e rendere il sistema più vulnerabile agli attacchi alla protezione.

Importante:
Benché possano apparire simili, i risultati delle seguenti impostazioni differiscono radicalmente per gli ambienti puri di Exchange 2000 Server/Exchange Server 2003 ed Exchange Server 2007.

In un ambiente Exchange 2000 Server/Exchange Server 2003 puro, l'impostazione delle restrizioni di dimensione per i messaggi in invio e ricezione su un valore pari a 0 nelle impostazioni globali di un utente abilitato all'uso di una cassetta postale provoca la completa rimozione delle restrizioni di dimensione dei messaggi.

L'impostazione dei parametri TransportConfig -MaxSendSize e TransportConfig -MaxreceiveSize su un valore pari a 0 in un ambiente Exchange 2007 puro impedisce l'invio di messaggi di qualsiasi dimensione.

Per impostare limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e scegliere Proprietà.

  2. Nella scheda Valori predefiniti della finestra di dialogo Proprietà di Recapito messaggi selezionare l'opzione Dimensione messaggi in arrivo e specificare il limite di dimensione desiderato.

Per impostare limiti della dimensione dei messaggi in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxReceiveSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere ricevuti dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere ricevuti dai destinatari nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize unlimited
  • Per ulteriori informazioni sull'impostazione dei limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003, consultare l'articolo 322679 della Microsoft Knowledge Base, "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

Per ulteriori informazioni sul cmdlet TransportConfig in Exchange Server 2007, consultare "Set-TransportConfig" nella sezione Informazioni tecniche di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=79237.

  • Per ulteriori informazioni sui formati dei messaggi Internet, consultare l'argomento "Utilizzo dei criteri SMTP per il controllo della formattazione della posta in uscita e delle risposte automatiche" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


La dimensione massima dei messaggi in arrivo potrebbe essere impostata su un valore troppo basso (< 1MB)
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore relativo all'attributo delivContLength delle impostazioni globali che si trova in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se Exchange Server Analyzer rileva che il valore dell'attributo delivContLength è inferiore a 1024 ma superiore a 0, verrà visualizzato un messaggio di errore.

Tale messaggio indica che è stato impostato un limite massimo per la dimensione dei messaggi in arrivo su un valore inferiore a 1 megabyte (MB). Un valore così basso impedisce ad Exchange Server di accettare una parte dei messaggi inviati all'organizzazione dell'utente. In Exchange 2000 Server ed Exchange Server 2007 non è previsto alcun limite predefinito per la dimensione dei messaggi. In Exchange Server 2003 il limite di dimensione predefinito per l'invio e la ricezione dei messaggi è 10.240 KB. Questo limite predefinito si applica alle nuove installazioni e agli aggiornamenti da Exchange 2000 Server in cui non è stato impostato alcun limite per la dimensione dei messaggi.

È possibile ottimizzare le risorse del sistema impostando i limiti di dimensione dei messaggi per impedire agli utenti di inviare e ricevere messaggi di posta elettronica di grandi dimensioni. In questo modo sarà possibile limitare il traffico di rete, risparmiare spazio su disco e migliorare le prestazioni complessive della rete. In Exchange 2000 Server ed Exchange Server 2003 è possibile utilizzare la scheda Valori predefiniti in Proprietà recapito messaggi delle Impostazioni globali per specificare le limitazioni relative al recapito, sia per i messaggi in entrata sia per quelli in uscita. Per impostare la dimensione massima di un singolo messaggio, selezionare Limite massimo (KB) e specificare nella casella di testo una dimensione massima in kilobyte (KB). Se non si desidera impostare un limite per la dimensione dei messaggi, selezionare Nessun limite. I mittenti nell'organizzazione ricevono un NDR se provano a inviare a un utente un messaggio che supera il limite di dimensione specificato. A seconda delle impostazioni NDR configurate in Formato messaggi Internet, i mittenti esterni potrebbero non essere abilitati a ricevere un NDR.

In Exchange Server 2007 è possibile utilizzare Exchange Management Shell per impostare il parametro TransportConfig MaxSendSize per l'organizzazione di Exchange.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 10 MB. Se, tuttavia, è necessario un limite maggiore per la dimensione dei messaggi con grandi allegati che devono essere inviati attraverso l'organizzazione di Exchange, sarà possibile aumentare il limite della dimensione massima dei messaggi in arrivo fino a 30 MB. L'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare un rallentamento delle prestazioni della rete e rendere il sistema più vulnerabile agli attacchi alla protezione.

Per impostare limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e scegliere Proprietà.

  2. Nella scheda Valori predefiniti della finestra di dialogo Proprietà di Recapito messaggi selezionare l'opzione Dimensione messaggi in arrivo e specificare il limite di dimensione desiderato.

Per impostare limiti della dimensione dei messaggi in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxReceiveSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere ricevuti dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere ricevuti dai destinatari nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxReceiveSize unlimited
  • Per ulteriori informazioni sull'impostazione dei limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003, consultare l'articolo 322679 della Microsoft Knowledge Base, "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

Per ulteriori informazioni sul cmdlet TransportConfig in Exchange Server 2007, consultare "Set-TransportConfig" nella sezione Informazioni tecniche di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=79237.

  • Per ulteriori informazioni sui formati dei messaggi Internet, consultare l'argomento "Utilizzo dei criteri SMTP per il controllo della formattazione della posta in uscita e delle risposte automatiche" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


MaxDSNSize non impostato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la dimensione massima dei messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) è stata impostata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory® per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer. Se la stringa comprende "Version 5.5", il computer esegue Microsoft Exchange Server 5.5. Se la stringa comprende "Version 6.0", il computer esegue Microsoft Exchange 2000 Server. Se la stringa comprende "Version 6.5", il computer esegue Microsoft Exchange Server 2003.

Se Exchange Server Analyzer rileva che il valore del Registro di sistema MaxDSNSize non è presente su un computer in cui si esegue Exchange 2000 Server oppure Exchange Server 2003, verrà visualizzato un avviso.

Il valore del Registro di sistema MaxDSNSize è un valore opzionale di Exchange Server che consente di limitare la dimensione dei DSN. Questa opzione consente di configurare Exchange per la rimozione di allegati se un messaggio non può essere recapitato. Se si aggiunge questo valore del Registro di sistema, è consigliabile utilizzare un valore di 10240000 byte (10 megabyte).

Nota:
Il valore del Registro di sistema MaxDSNSize è stato introdotto con il Service Pack 2 (SP2) per Exchange 2000 Server, pertanto è necessario eseguire Exchange 2000 Server SP2 o una versione successiva. Inoltre, nel Service Pack 1 per Exchange Server 2003 e nelle versioni successive, in assenza del valore del Registro di sistema MaxDSNSize, viene utilizzato un valore di 10 megabyte. Se si desidera, per ignorare l'impostazione predefinita, è possibile aggiungere il valore del Registro di sistema MaxDSNSize.

Se si abilita questa opzione, è possibile risparmiare risorse del server e di rete. Esistono, tuttavia, alcuni svantaggi nell'implementazione della rimozione di allegati SMTP (Simple Mail Transfer Protocol). Se si abilita questa opzione per rimuovere gli allegati dal rapporto di mancato recapito (NDR), verranno rimossi anche i dettagli necessari per la visualizzazione della notifica nel riquadro di anteprima e il mittente del messaggio non potrà utilizzare l'opzione Rinvia. Se il mittente del messaggio tenta di utilizzare tale opzione dall'NDR, verrà visualizzato il seguente messaggio di errore: Impossibile rinviare il messaggio. Il rapporto di mancato recapito non contiene informazioni sufficienti sul messaggio originale. Per rinviare il messaggio, aprirlo nella cartella Posta inviata, fare clic sul menu Azioni quindi su Rinvia messaggio.

Tuttavia, il mittente del messaggio non può inviarlo nuovamente, anche utilizzando il metodo menzionato nel messaggio di errore.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc

  3. Fare clic con il pulsante destro del mouse su SMTPSvc e scegliere Nuovo | Chiave. Denominare la nuova chiave Accodamento e lasciare vuota la classe.

  4. Fare clic con il pulsante destro del mouse su Accodamento e scegliere Nuovo | Valore DWORD. Denominare il nuovo valore MaxDSNSize.

  5. Nel riquadro destro fare doppio clic sul valore del Registro di sistema MaxDSNSize e immettere il limite di dimensione (in byte) che si desidera nel campo Dati valore. I messaggi di dimensione superiore a questo valore che generano un NDR non restituiranno gli allegati o le proprietà complete del messaggio.

  6. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Simple Mail Transfer Protocol (SMTP).

Per ulteriori informazioni sull'impostazione MaxDSNSize del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 308303, "XCON: Opzione per rimuovere gli allegati che generano un NDR" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303.

  • 323484, "XCON: Descrizione del formato messaggi Internet Multipart/Report in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484.


La dimensione massima del messaggio in uscita non è stata impostata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-12-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo submissionContLength delle impostazioni globali che si trova in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se Exchange Server Analyzer rileva che il valore dell'attributo submissionContLength è minore di 1, verrà visualizzato un messaggio di errore.

Tale messaggio indica che non è stato impostato un limite per la dimensione massima dei messaggi in uscita. In base alla larghezza di banda della rete e ai requisiti dell'utente nell'ambito di un'organizzazione, può essere necessario limitare la dimensione dei messaggi. In Exchange 2000 Server ed Exchange Server 2007 non è previsto alcun limite predefinito per la dimensione dei messaggi. In Exchange Server 2003 il limite di dimensione predefinito per l'invio e la ricezione dei messaggi è 10.240 KB. Questo limite predefinito si applica alle nuove installazioni e agli aggiornamenti da Exchange 2000 Server in cui non è stato impostato alcun limite alla dimensione dei messaggi.

È possibile ottimizzare le risorse del sistema impostando i limiti di dimensione dei messaggi per impedire agli utenti di inviare e ricevere messaggi di posta elettronica di grandi dimensioni. In questo modo sarà possibile limitare il traffico di rete, risparmiare spazio su disco e migliorare le prestazioni complessive della rete. In Exchange 2000 Server ed Exchange Server 2003 è possibile utilizzare la scheda Valori predefiniti in Proprietà recapito messaggi delle Impostazioni globali per specificare le limitazioni relative al recapito, sia per i messaggi in entrata sia per quelli in uscita. Per impostare la dimensione massima di un singolo messaggio, selezionare Limite massimo (KB) e specificare nella casella di testo una dimensione massima in kilobyte (KB). Se non si desidera impostare un limite per la dimensione dei messaggi, selezionare Nessun limite. I mittenti all'interno di un'organizzazione ricevono un rapporto di mancato recapito (NDR) se tentano di inviare un messaggio di dimensioni superiori al limite consentito. A seconda delle impostazioni NDR configurate in Formato messaggi Internet, i mittenti esterni sono abilitati o meno a ricevere un NDR.

In Exchange Server 2007 è possibile utilizzare Exchange Management Shell per impostare il parametro TransportConfig MaxSendSize per l'organizzazione di Exchange.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 10 MB. Tuttavia, qualora fosse necessario un limite più elevato per messaggi con allegati di grandi dimensioni da inviare tramite l'organizzazione di Exchange, è possibile incrementare il limite di dimensione per i messaggi in uscita fino a 30 MB. L'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare un rallentamento delle prestazioni della rete e rendere il sistema più vulnerabile agli attacchi alla protezione.

Per impostare limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e scegliere Proprietà.

  2. Nella finestra Proprietà di Recapito messaggi, nella scheda Valori predefiniti, selezionare l'opzione Dimensione messaggi in uscita e specificare il limite di dimensione desiderato.

Per impostare limiti della dimensione dei messaggi in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxSendSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize unlimited
  • Per ulteriori informazioni sull'impostazione dei limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003, consultare l'articolo 322679 della Microsoft Knowledge Base, "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

  • Per ulteriori informazioni sul cmdlet TransportConfig in Exchange Server 2007, consultare "Set-TransportConfig" nella sezione Informazioni tecniche di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=79237.

  • Per ulteriori informazioni sui formati dei messaggi Internet, consultare l'argomento "Utilizzo dei criteri SMTP per il controllo della formattazione della posta in uscita e delle risposte automatiche" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


La dimensione massima dei messaggi in uscita è impostata su un valore troppo alto (>30 MB)
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-12-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo submissionContLength delle impostazioni globali che si trova in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=OrganizationName, CN=Global Settings, CN=Message Delivery

Se Exchange Server Analyzer rileva che il valore dell'attributo submissionContLength è maggiore di 30720, verrà visualizzato un messaggio di errore.

Il messaggio di errore indica che il limite massimo per la dimensione dei messaggi in uscita è stato impostato su un valore superiore a 30 megabyte (MB). In base alla larghezza di banda della rete e ai requisiti dell'utente nell'ambito di un'organizzazione, può essere necessario limitare la dimensione dei messaggi. Exchange 2000 Server ed Exchange Server 2007 non prevedono alcun limite predefinito per la dimensione dei messaggi. In Exchange Server 2003 il limite di dimensione predefinito per l'invio e la ricezione dei messaggi è 10.240 KB. Questo limite predefinito si applica alle nuove installazioni e agli aggiornamenti da Exchange 2000 Server in cui non è stato impostato alcun limite per la dimensione dei messaggi.

È possibile ottimizzare le risorse del sistema impostando i limiti di dimensione dei messaggi per impedire agli utenti di inviare e ricevere messaggi di posta elettronica di grandi dimensioni. In questo modo sarà possibile limitare il traffico di rete, risparmiare spazio su disco e migliorare le prestazioni complessive della rete. In Exchange 2000 Server ed Exchange Server 2003 è possibile utilizzare la scheda Valori predefiniti in Proprietà recapito messaggi delle Impostazioni globali per specificare le limitazioni relative al recapito, sia per i messaggi in entrata sia per quelli in uscita. Per impostare la dimensione massima di un singolo messaggio, selezionare Limite massimo (KB) e specificare nella casella di testo una dimensione massima in kilobyte (KB). Se non si desidera impostare un limite per la dimensione dei messaggi, selezionare Nessun limite. I mittenti nell'organizzazione ricevono un NDR se provano a inviare a un utente un messaggio che supera il limite di dimensione specificato. A seconda delle impostazioni NDR configurate in Formato messaggi Internet, i mittenti esterni sono abilitati o meno a ricevere un NDR.

In Exchange Server 2007 è possibile utilizzare Exchange Management Shell per impostare il parametro TransportConfig MaxSendSize per l'organizzazione di Exchange.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 10 MB. Tuttavia, qualora fosse necessario un limite più elevato per messaggi con allegati di grandi dimensioni da inviare tramite l'organizzazione di Exchange, è possibile incrementare il limite di dimensione per i messaggi in uscita fino a 30 MB. L'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare un rallentamento delle prestazioni della rete e rendere il sistema più vulnerabile agli attacchi alla protezione.

Per impostare limiti della dimensione dei messaggi in Exchange 2000 Server e Exchange Server 2003

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e scegliere Proprietà.

  2. Nella finestra Proprietà di Recapito messaggi, nella scheda Valori predefiniti selezionare l'opzione Dimensione messaggi in uscita e specificare il limite di dimensione desiderato.

Per impostare limiti della dimensione dei messaggi in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxSendSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize unlimited
  • Per ulteriori informazioni sull'impostazione dei limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003, consultare l'articolo 322679 della Microsoft Knowledge Base, "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

Per ulteriori informazioni sul cmdlet TransportConfig in Exchange Server 2007, consultare "Set-TransportConfig" nella sezione Informazioni tecniche di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=79237.

  • Per ulteriori informazioni sui formati dei messaggi Internet, consultare l'argomento "Utilizzo dei criteri SMTP per il controllo della formattazione della posta in uscita e delle risposte automatiche" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21769.


La dimensione massima dei messaggi in uscita potrebbe essere impostata su un valore troppo basso
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-12-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo submissionContLength delle impostazioni globali che si trova in:

CN=Configuration, CN=Services, CN=Microsoft Exchange, CN= NomeOrganizzazione , CN=Global Settings, CN=Message Delivery

Se Exchange Server Analyzer rileva che il valore dell'attributo submissionContLength è minore di 1.024 ma maggiore di 0, verrà visualizzato un avviso.

L'avviso indica che è stato impostato un limite massimo per la dimensione dei messaggi in uscita su un valore inferiore a 1 megabyte (MB). In base alla larghezza di banda della rete e ai requisiti dell'utente nell'ambito dell'organizzazione, è possibile aumentare la dimensione dei messaggi per consentire messaggi più grandi. In Exchange 2000 Server ed Exchange Server 2007 non è previsto alcun limite predefinito per la dimensione dei messaggi. In Exchange Server 2003 il limite di dimensione predefinito per l'invio e la ricezione dei messaggi è 10.240 KB. Questo limite predefinito si applica alle nuove installazioni e agli aggiornamenti da Exchange 2000 Server in cui non è stato impostato alcun limite alla dimensione dei messaggi.

È possibile ottimizzare le risorse del sistema impostando i limiti di dimensione dei messaggi per impedire agli utenti di inviare e ricevere messaggi di posta elettronica di grandi dimensioni. In questo modo sarà possibile limitare il traffico di rete, risparmiare spazio su disco e migliorare le prestazioni complessive della rete. In Exchange 2000 Server ed Exchange Server 2003 è possibile utilizzare la scheda Valori predefiniti in Proprietà recapito messaggi delle Impostazioni globali per specificare le limitazioni relative al recapito, sia per i messaggi in entrata sia per quelli in uscita. Per impostare la dimensione massima di un singolo messaggio, selezionare Limite massimo (KB), e in una casella di testo, specificare una dimensione massima in kilobyte (KB). Se non si desidera impostare un limite per la dimensione dei messaggi, selezionare Nessun limite. I mittenti all'interno di un'organizzazione ricevono un rapporto di mancato recapito (NDR) se tentano di inviare un messaggio a un utente che va oltre il limite di dimensione specificato. A seconda delle impostazioni di NDR configurate in Formato messaggi Internet, i mittenti esterni sono abilitati o meno a ricevere un NDR.

In Exchange Server 2007 è possibile utilizzare Exchange Management Shell per impostare il parametro TransportConfig MaxSendSize per l'organizzazione di Exchange.

È consigliabile impostare il limite massimo per la dimensione dei messaggi su un valore non superiore a 30 MB. Tuttavia, qualora fosse necessario un limite più elevato per messaggi con allegati di grandi dimensioni da inviare tramite l'organizzazione di Exchange, è possibile incrementare il limite massimo di dimensione per i messaggi in uscita a oltre 30 MB. L'aumento del limite di dimensione dei messaggi oltre i 30 MB può provocare un rallentamento delle prestazioni della rete e rendere il sistema più vulnerabile agli attacchi alla protezione.

Per impostare limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003

  1. Nel Gestore di sistema di Exchange espandere la struttura Impostazioni globali, fare clic con il pulsante destro del mouse su Recapito messaggi e fare clic su Proprietà.

  2. Nella finestra Proprietà di Recapito messaggi, sulla scheda Valori predefiniti, selezionare l'opzione Dimensione messaggi in uscita e specificare il limite di dimensione desiderato.

Per impostare limiti della dimensione dei messaggi in Exchange Server 2007

  1. In Exchange Management Shell eseguire il seguente comando, dove <size> corrisponde al valore predefinito "illimitata" oppure alla dimensione in B (byte), KB (kilobyte) o MB (megabyte) in un intervallo compreso tra 0 e 2147483647 byte:
Copia codice
Set-TransportConfig -MaxSendSize <size>

Ad esempio, per impostare su 10 megabyte la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize 10MB

Per impostare sul valore predefinito "illimitata" la dimensione massima dei messaggi che possono essere inviati dagli utenti nell'organizzazione di Exchange, immettere:

Copia codice
Set-TransportConfig -MaxSendSize unlimited
  • Per ulteriori informazioni sull'impostazione dei limiti della dimensione dei messaggi in Exchange 2000 Server ed Exchange Server 2003, consultare l'articolo 322679 della Microsoft Knowledge Base, "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=322679.

Per ulteriori informazioni sul cmdlet TransportConfig in Exchange Server 2007, consultare "Set-TransportConfig" nella sezione Informazioni tecniche di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=79237.

  • Per ulteriori informazioni sui formati dei messaggi Internet, consultare l'argomento "Utilizzo dei criteri SMTP per il controllo della formattazione della posta in uscita e delle risposte automatiche" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


La funzione di inserimento nel diario dei soli messaggi è abilitata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-10

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchMessageJournalRecipient è stato configurato per copiare la posta elettronica nella cassetta postale di un destinatario. L'attributo msExchMessageJournalRecipient è un attributo degli oggetti archivio delle cassette postali di Active Directory. Per impostazione predefinita, l'attributo msExchMessageJournalRecipient non è configurato. Se Exchange Server Analyzer rileva che l'attributo msExchMessageJournalRecipient è stato configurato, verrà visualizzato un messaggio di configurazione non predefinita. Inoltre, verrà visualizzato il nome del database e del server in cui è abilitato l'inserimento nel diario dei soli messaggi.

La funzione di inserimento nel journal dei soli messaggi di Exchange Server 2003 o la funzione di inserimento standard nel journal di Exchange Server 2007 crea una copia di tutti i messaggi ricevuti e inviati dagli utenti e dei dati dell'intestazione dei messaggi P2 corrispondenti su un database delle cassette postali e invia tale copia a una cassetta postale specificata. L'intestazione del messaggio P2 contiene solo i dati del destinatario del messaggio specificati dal mittente. Se viene ricevuto un messaggio esterno da Internet, Exchange Server inserisce nel diario le intestazioni del messaggio P1. L'intestazione del messaggio P1 contiene le informazioni relative all'indirizzo utilizzato dagli MTA (Message Transfer Agent, Agente di trasferimento messaggi) per instradare la posta. Per impostazione predefinita, se è abilitato l'inserimento nel diario dei soli messaggi, non verranno considerati i destinatari in copia nascosta (Ccn), i destinatari a cui vengono applicate regole di inoltro oppure i destinatari derivanti da espansioni dei gruppi di distribuzione. Inoltre, non vengono archiviati i messaggi di rapporto MAPI, quali, ad esempio, le conferme di lettura e le notifiche di messaggi fuori sede.

La funzione di inserimento nel diario dei messaggi può richiedere molte risorse di disco, rete e CPU. Pertanto, è necessaria una pianificazione accurata della distribuzione. La funzione di inserimento nel diario dovrebbe essere abilitata solo nel contesto di una soluzione generale di inserimento nel diario.

Ignorare il messaggio di configurazione non predefinita se si verificano le seguenti condizioni:

  • L'azienda richiede l'inserimento nel diario.

  • Si è distribuita una soluzione di inserimento nel diario.

In caso contrario, è necessario disattivare la funzione di inserimento nel diario.

Per disattivare la funzione di inserimento nel journal dei soli messaggi in un database di Exchange 2000 Server ed Exchange Server 2003

  1. In Gestore di sistema di Exchange espandere Server, <il server di Exchange> e <gruppo di archiviazione>, quindi fare clic con il pulsante destro del mouse sull'archivio delle cassette postali.

  2. Nella scheda Generale deselezionare la casella di controllo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio.

  3. Attendere 15 minuti affinché l'archivio di Exchange possa applicare le modifiche. Non è necessario riavviare il servizio Archivio informazioni di Microsoft Exchange.
Per disattivare la funzione di inserimento standard nel journal in un database di Exchange Server 2007

  1. Seguire le istruzioni contenute nella documentazione del prodotto Exchange Server 2007, Come disattivare l'inserimento nel journal del database per le cassette postali all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80889.

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel journal in Exchange Server 2003, vedere Journaling with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel journal con Exchange Server 2007, vedere Panoramica dell'inserimento nel journal all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80820.


Possibile loop di routing dei messaggi
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchAlternateServer per ogni server virtuale SMTP (Simple Mail Transfer Protocol). Exchange Server Best Practice Analyzer determina inoltre se l'attributo msExchNonAuthoritativeDomains è stato configurato in uno dei criteri destinatari nell'organizzazione. Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • È stata impostata un'istanza dell'attributo msExchAlternateServer.

  • L'attributo msExchNonAuthoritativeDomains è stato impostato in un criterio destinatario.

Exchange Server Analyzer visualizza un avviso perché le configurazioni appena citate possono provocare loop dei messaggi. I loop dei messaggi possono verificarsi quando diversi sistemi di messaggistica vengono configurati per funzionare assieme in un'unica organizzazione. In questo scenario i criteri destinatari di Exchange Server e le configurazioni SMTP vengono utilizzati per instradare e recapitare i messaggi a gruppi di utenti presenti in più sistemi di messaggistica eterogenei.

L'attributo msExchAlternateServer viene impostato quando si specifica un indirizzo nel campo Inoltra all'host tutti i messaggi con destinatari non risolti in un pagina delle proprietà del server virtuale SMTP.

L'attributo msExchNonAuthoritativeDomains viene impostato quando si deseleziona la casella di controllo Questa organizzazione di Exchange è responsabile di tutti i recapiti a questo indirizzo nella pagina delle proprietà dell'indirizzo SMTP di uno specifico criterio destinatario.

Pertanto, se si specifica un dominio SMTP come non autorevole, deselezionando la casella di controllo Questa organizzazione di Exchange è responsabile di tutti i recapiti a questo indirizzo, e si è specificato un indirizzo per i destinatari non risolti in un server virtuale SMTP, Exchange Server Analyzer visualizzerà un avviso. Tuttavia, è importante notare che l'esistenza di questo avviso non indica in modo definitivo che è presente un loop dei messaggi nell'organizzazione.

Se è presente un dominio non autorevole e almeno un server dell'organizzazione ha l'attributo msExchAlternateServer impostato, è potenzialmente possibile che si verifichino loop di routing dei messaggi. È consigliabile controllare che non si siano verificate le seguenti condizioni:

  • Esistono domini autorevoli per tutti i domini dell'organizzazione.

  • I server virtuali SMTP sono configurati in modo che i domini autorevoli gestiscano tutti i messaggi non risolti.

Nello specifico, se si condivide un nome di dominio con un'altra organizzazione, è consigliabile che sia presente un solo percorso in ingresso a tale spazio dei nomi del dominio. Per il dominio dovrebbe essere autorevole un solo server di posta o un solo sistema di posta, in modo che non si verifichi il loop. Il server autorevole dovrebbe essere l'ultimo sistema nel percorso in ingresso.

Non è importante quale sistema funga da ricevitore iniziale, se sono presenti più di due ricevitori iniziali. È importante che la destinazione finale sia rappresentata da un solo sistema.

Per modificare l'attributo msExchAlternateServer

  1. In Gestore di sistema di Exchange espandere Server, <Nome server>, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  3. Nella pagina delle proprietà del server virtuale SMTP fare clic sulla scheda Messaggi.

  4. Nella casella Inoltra all'host tutti i messaggi con destinatari non risolti digitare il nome di dominio completo del server che riceverà la posta non risolta. È inoltre possibile immettere l'indirizzo IP del server tra parentesi quadre ([ ]).

  5. Fare clic su OK.
Per modificare l'attributo msExchNonAuthoritativeDomains

  1. In Gestore di sistema di Exchange espandere Destinatari e fare doppio clic sul <Nome criterio destinatario>.

  2. Nella scheda E-Mail Addresses (Policy) fare doppio clic su un indirizzo SMTP.

  3. Selezionando Questa organizzazione di Exchange è responsabile di tutti i recapiti a questo indirizzo nella pagina delle proprietà dell'indirizzo SMTP, viene deselezionato l'attributo msExchNonAuthoritativeDomains. Se si deseleziona la casella di controllo, si imposta l'attributo msExchNonAuthoritativeDomains sull'indirizzo SMTP specificato nel campo Indirizzo.

Per ulteriori informazioni sulla condivisione degli spazi indirizzo SMTP, consultare l'articolo 321721 della Microsoft Knowledge Base, "XCON: Condivisione degli spazi di indirizzi SMTP in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721.

Per ulteriori informazioni sui connettori, consultare il Capitolo 6, "Scenari di distribuzione per la connettività Internet", della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


La coda Messaggi in attesa dell'individuazione della directory è bloccata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateFrozen per la coda SMTP Messaggi in attesa dell'individuazione della directory.

Se Exchange Server Analyzer rileva che il valore della chiave StateFrozen per la coda Messaggi in attesa dell'individuazione della directory in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda risulta bloccata, le sessioni di trasporto dirette a questa coda vengono arrestate. Una coda bloccata impedisce l'invio dei messaggi in uscita, anche se è possibile aggiungere nuovi messaggi. È possibile modificare manualmente lo stato di una connessione utilizzando il menu di scelta rapida in ciascuna coda di collegamento. Se viene utilizzato il comando Imponi connessione per modificare lo stato di una coda su Attiva, viene immediatamente abilitata una connessione che invia messaggi da quella coda.

La coda Messaggi in attesa dell'individuazione della directory contiene messaggi per destinatari che non sono stati ancora risolti nel servizio directory di Active Directory®. I messaggi vengono inoltre mantenuti nella coda durante l'espansione delle liste di distribuzione.

Generalmente, i messaggi si accumulano nella coda perché il motore di accodamento avanzato non è in grado di classificare il messaggio. Il motore di accodamento avanzato potrebbe non essere in grado di accedere ai server di catalogo globale e alle informazioni sul destinatario oppure i server di catalogo globale non sono raggiungibili od offrono prestazioni scadenti. Inoltre, i messaggi possono accumularsi per i seguenti motivi:

  • Active Directory non è disponibile.

    Nota:
    Il classificatore utilizza Active Directory per classificare i messaggi.
  • Active Directory potrebbe avere un carico troppo elevato se sono presenti molti messaggi nella coda di pre-categorizzazione.

  • Si è verificato un errore durante la conversione. Il classificatore gestisce anche la conversione del contenuto.

  • Il classificatore dei messaggi non riesce a trovare gli archivi di cassette postali.

  • Se il protocollo SMTP è stato reinstallato o rimosso, potrebbero risultare invalidate le seguenti chiavi della metabase IIS: /smtpsvc/DsUseCat e /smtpsvc/vsi#/DsUseCat.

    Nota:
    Determinare se il protocollo SMTP è stato reinstallato o rimosso.

Per correggere questo errore, aumentare la registrazione diagnostica per i servizi MSExchangeDSAccess e MSExchangeTransport per raccogliere informazioni sui componenti del classificatore.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda Messaggi in attesa dell'individuazione della directory si trova in stato Riprova
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateRetry per la coda SMTP Messaggi in attesa dell'individuazione della directory.

Se Exchange Server Analyzer rileva che il valore della chiave StateRetry per la coda Messaggi in attesa dell'individuazione della directory in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda si trova in stato Riprova, significa che si è verificato almeno un errore nei precedenti tentativi di elaborazione dei messaggi nella coda. È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione. In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

La coda Messaggi in attesa dell'individuazione della directory contiene messaggi per destinatari che non sono stati ancora risolti nel servizio directory Active Directory®. I messaggi vengono inoltre mantenuti nella coda durante l'espansione delle liste di distribuzione.

Generalmente, i messaggi si accumulano nella coda perché il motore di accodamento avanzato non è in grado di classificare il messaggio. Il motore di accodamento avanzato potrebbe non essere in grado di accedere ai server di catalogo globale e alle informazioni sul destinatario oppure i server di catalogo globale non sono raggiungibili od offrono prestazioni scadenti. Inoltre, i messaggi possono accumularsi per i seguenti motivi:

  • Active Directory non è disponibile.

    Nota:
    Il classificatore utilizza Active Directory per classificare i messaggi.
  • Active Directory potrebbe avere un carico troppo elevato se sono presenti molti messaggi nella coda di pre-categorizzazione.

  • Si è verificato un errore durante la conversione. Il classificatore gestisce anche la conversione del contenuto.

  • Il classificatore dei messaggi non riesce a trovare gli archivi di cassette postali.

  • Se il protocollo SMTP è stato reinstallato o rimosso, potrebbero risultare invalidate le seguenti chiavi della metabase IIS: /smtpsvc/DsUseCat e /smtpsvc/vsi#/DsUseCat.

    Nota:
    Determinare se il protocollo SMTP è stato disinstallato o rimosso.

Per correggere questo errore, esaminare le proprietà della coda per determinare se la coda si trova nello stato Riprova. Ad esempio, se nelle proprietà della coda viene visualizzato un messaggio che indica "Si è verificato un errore SMTP", è necessario rivedere i registri evento del server per individuare tutti gli errori SMTP. Se non sono presenti eventi nel registro, è necessario aumentare il livello di registrazione del protocollo SMTP.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda Messaggi in attesa di invio è bloccata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-16

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateFrozen per la coda SMTP Messaggi in attesa di invio.

Se Exchange Server Analyzer rileva che il valore della chiave StateFrozen per la coda Messaggi in attesa di invio in un server Exchange è impostato su True, viene visualizzato un errore.

Se una coda risulta bloccata, le sessioni di trasporto dirette a questa coda vengono arrestate. Una coda bloccata impedisce l'invio dei messaggi in uscita, anche se è possibile aggiungere nuovi messaggi. È possibile modificare manualmente lo stato di una connessione utilizzando il menu di scelta rapida in ciascuna coda di collegamento. Se viene utilizzato il comando Imponi connessione per modificare lo stato di una coda su Attiva, viene immediatamente abilitata una connessione che invia messaggi da tale coda.

La coda Messaggi in attesa di invio trattiene i messaggi riconosciuti e accettati dal servizio SMTP.

I messaggi in questa coda non sono stati elaborati. Se i messaggi si accumulano costantemente, si può essere verificato un problema di prestazioni. Picchi occasionali nelle prestazioni della CPU possono provocare una comparsa intermittente di messaggi in questa coda. Spesso i problemi con i sink di evento, ad esempio il codice di elaborazione SMTP personalizzato per lo screening antivirus e per le dichiarazioni di non responsabilità, provocano un accumulo di messaggi in questa coda.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda Messaggi in attesa di invio si trova in stato Riprova
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateRetry per la coda SMTP Messaggi in attesa di invio.

Se Exchange Server Analyzer rileva che il valore della chiave StateRetry per la coda Messaggi in attesa di invio in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda è nello stato Riprova, tale stato indica che si è verificato almeno un errore nei precedenti tentativi di elaborare i messaggi nella coda. È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione . In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

La coda Messaggi in attesa di invio trattiene i messaggi riconosciuti e accettati dal servizio SMTP.

I messaggi in questa coda non sono stati elaborati. Se i messaggi si accumulano costantemente, si può essere verificato un problema di prestazioni. Picchi occasionali nelle prestazioni della CPU possono provocare una comparsa intermittente di messaggi in questa coda. Spesso i problemi con i sink di evento, ad esempio il codice di elaborazione SMTP personalizzato per lo screening antivirus e per le dichiarazioni di non responsabilità, provocano un accumulo di messaggi in questa coda.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda Messaggi in attesa di essere reindirizzati è bloccata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateFrozen per la coda SMTP Messaggi in attesa di essere reindirizzati.

Se Exchange Server Analyzer rileva che il valore della chiave StateFrozen per la coda Messaggi in attesa dell'individuazione della directory in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda risulta bloccata, le sessioni di trasporto dirette a questa coda vengono arrestate. Una coda bloccata impedisce l'invio dei messaggi in uscita, anche se è possibile aggiungere nuovi messaggi. È possibile modificare manualmente lo stato di una connessione utilizzando il menu di scelta rapida in ciascuna coda di collegamento. Se viene utilizzato il comando Imponi connessione per modificare lo stato di una coda su Attiva, viene immediatamente abilitata una connessione che invia messaggi da quella coda.

La coda Messaggi in attesa di essere reindirizzati mantiene i messaggi finché non viene determinato il successivo server di destinazione, quindi li sposta nelle rispettive code di collegamento.

I messaggi si accumulano nella coda se si verificano problemi di routing di Exchange Server. È possibile eseguire il backup del routing dei messaggi.

Per correggere questo errore, aumentare la registrazione diagnostica per i servizi MSExchangeDSAccess e MSExchangeTransport per raccogliere informazioni sui componenti del classificatore.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda Messaggi in attesa di essere reindirizzati è in stato Riprova
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateRetry per la coda SMTP Messaggi in attesa di essere reindirizzati.

Se Exchange Server Analyzer rileva che il valore della chiave StateRetry per la coda Messaggi in attesa dell'individuazione della directory in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda è nello stato Riprova, tale stato indica che si è verificato almeno un errore nei precedenti tentativi di elaborare i messaggi nella coda. È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione . In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

La coda Messaggi in attesa di essere reindirizzati mantiene i messaggi finché non viene determinato il successivo server di destinazione, quindi li sposta nelle rispettive code di collegamento.

I messaggi si accumulano nella coda se si verificano problemi di routing di Exchange Server. È possibile eseguire il backup del routing dei messaggi.

Per correggere questo errore, aumentare la registrazione diagnostica per il servizio MSExchangeTransport per raccogliere informazioni sui componenti del classificatore. Disabilitare le restrizioni dei connettori non necessarie, poiché tali restrizioni possono causare un notevole peggioramento delle prestazioni del server. Può essere necessario attivare la chiave CheckConnectorRestrictions del Registro di sistema per alcune restrizioni.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Binding del sink di evento di trasporto mancante
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-01-11

Microsoft® Exchange Server Analyzer Tool esegue una query nella metabase IIS (Internet Information Server) per enumerare l'elenco dei binding dei sink di evento di trasporto SMTP (Simple Mail Transport Protocol). Exchange Server Analyzer tenta di individuare diversi binding di eventi standard, in base a un elenco predefinito in Exchange Server Analyzer.

  • Sink DSN di Exchange personalizzato

  • Sink per XLSA di handler di comando EHLO in ingresso

  • Sink per X-LSA di handler di risposta EHLO

  • Sink di handler del comando EOD in ingresso

  • Classificatore di Exchange

  • Bilanciatore del carico di Exchange

  • Driver di archivio NTFS di Exchange

  • Router di Exchange

  • Sink di registrazione del protocollo SMTP di Exchange

  • Sink EHLO di protezione del protocollo SMTP di Exchange

  • Sink EXPS di protezione del protocollo SMTP di Exchange

  • Sink EXPS-Aux di protezione del protocollo SMTP di Exchange

  • Sink EXPS-EOD di protezione del protocollo SMTP di Exchange

  • Sink Mail di protezione del protocollo SMTP di Exchange

  • Sink di notifica invio dati XEXCH50 del protocollo SMTP di Exchange

  • Sink di risposta EHLO XEXCH50 del protocollo SMTP di Exchange

  • Sink EOD XEXCH50 del protocollo SMTP di Exchange

  • Sink EHLO in ingresso XEXCH50 del protocollo SMTP di Exchange

  • Sink MAIL in ingresso XEXCH50 del protocollo SMTP di Exchange

  • Sink RCPT in ingresso XEXCH50 del protocollo SMTP di Exchange

  • Sink XEXCH50 in ingresso XEXCH50 del protocollo SMTP di Exchange

  • Sink di evento per destinatario XEXCH50 del protocollo SMTP di Exchange

  • Sink di risposta RCPT XEXCH50 del protocollo SMTP di Exchange

  • Sink di risposta XEXCH50 del protocollo SMTP di Exchange

  • Driver di archivio di Exchange

  • API antivirus del trasporto di Exchange

  • Sink di invio XEXCH50 del trasporto di Exchange

  • Sink per TURF di handler del comando MAIL in ingresso

  • Classificatore mobile

  • Sink EOD del filtro contenuti di MSExchange

  • Sink MsgTrackLog

  • Sink di handler del comando RCPT in ingresso

  • Sink Eventlog SMTP

  • UmConvSink

  • Sink di handler di comando X-LSA in ingresso

  • Sink di handler di risposta X-LSA

  • Sink X-LSA

Se Exchange Server Analyzer rileva la mancanza di uno o più binding di eventi standard, verrà generato un avviso.

Un evento di trasporto SMTP si verifica quando i dati dei messaggi vengono trasportati all'interno o al di fuori del servizio SMTP. Tutti i messaggi passano attraverso gli eventi. Sono inclusi i messaggi in arrivo o in uscita X.400 e RPC. Un esempio comune di evento di trasporto in ingresso è l'arrivo di un messaggio al servizio SMTP in rete o nella directory di prelievo SMTP. Quando si verifica questo evento di trasporto, un'origine dell'evento informa i sink di evento di trasporto, ciascuno dei quali può effettuare un tipo di operazione in base al contenuto dei dati del messaggio. Una volta che i dati sono stati passati al sink, non vengono eseguite altre operazioni con i dati dei messaggi fino a quando il sink completa l'operazione e restituisce il messaggio. Il sink ha il controllo esclusivo dei dati dei messaggi e dello stato nel corso dell'operazione.

La mancanza dei binding dei sink di evento di trasporto può causare problemi al flusso di posta. Se il server di Exchange presenta sintomi di problemi al flusso di posta, ad esempio l'accodamento dei messaggi, registrare nuovamente i sink di evento di trasporto.

Per registrare nuovamente i sink di evento di trasporto

  1. Dal server di Microsoft Exchange aprire una finestra del prompt dei comandi e passare alla cartella \Programmi\Exchsrvr\Bin.

  2. Digitare i seguenti comandi per registrare nuovamente i sink di evento di trasporto:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Eseguire nuovamente Exchange Server Analyzer per verificare che gli avvisi non vengano più visualizzati. Se gli avvisi continuano ad essere visualizzati e si verificano problemi nel flusso di posta, contattare il Servizio Supporto Tecnico Clienti Microsoft (PSS, Microsoft Product Support Services).

Per ulteriori informazioni sui binding dei sink di evento di trasporto, vedere le seguenti risorse di Exchange:

  • Articolo 258224 della Microsoft Knowledge Base, "XCON: Enumerazione dei sink di evento di trasporto registrati" all'indirizzo http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224.

  • "Design del servizio SMTP" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=58876.


L'attributo msExchAlternateServer è stato impostato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchAlternateServer di ogni server virtuale SMTP (Simple Mail Transfer Protocol). Per impostazione predefinita, il valore dell'attributo msExchAlternateServer non è impostato. Se Exchange Server Analyzer rileva che l'attributo msExchAlternateServer è stato impostato, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchAlternateServer dovrebbe essere impostato nelle seguenti condizioni di esempio. Si condivide uno spazio degli indirizzi SMTP, ad esempio un dominio SMTP, tra Exchange Server 2003 e un altro sistema di posta elettronica. In questo caso Exchange Server 2003 accetta la posta in arrivo da Internet. e cerca il corrispondente destinatario nell'organizzazione di Exchange Server. Se non viene rilevata una corrispondenza, Exchange Server inoltra il messaggio al sistema di posta esterno. Anche il sistema destinatario può cercare una corrispondenza. Se non viene rilevata, può inoltrare il messaggio a un terzo sistema di posta. Il sistema finale nella catena deve essere autorevole per il dominio. Il sistema finale deve cercare un destinatario corrispondente. Se non viene trovato, è necessario generare un rapporto di mancato recapito (NDR) per il messaggio. Se un sistema cerca un destinatario e quindi inoltra nuovamente il messaggio al sistema di origine quando non viene rilevata una corrispondenza, si verifica un loop dei messaggi.

Per modificare l'attributo msExchAlternateServer

  1. In Gestore di sistema di Exchange espandere Server, <Nome server>, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  3. Nella pagina delle proprietà del server virtuale SMTP fare clic sulla scheda Messaggi.

  4. Nella casella Inoltra all'host tutti i messaggi con destinatari non risolti digitare il nome di dominio completo del server che riceverà la posta non risolta. È inoltre possibile immettere l'indirizzo IP del server tra parentesi quadre ([ ]).

  5. Fare clic su OK.

Per ulteriori informazioni sulla condivisione degli spazi indirizzo SMTP, consultare l'articolo 321721 della Microsoft Knowledge Base, "XCON: Condivisione degli spazi di indirizzi SMTP in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=321721.

Per ulteriori informazioni sui connettori, consultare il Capitolo 6, "Scenari di distribuzione per la connettività Internet", della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Il valore msExchMaxIncomingConnections è stato impostato su un valore diverso da quello predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore configurato per l'attributo msExchSmtpMaxIncomingConnections per ogni server virtuale SMTP.

Per impostazione predefinita, in un computer Exchange Server che non fa parte di un'installazione Microsoft® Windows® Small Business Server 2003 l'attributo msExchSmtpMaxIncomingConnections è configurato per un numero illimitato di connessioni, come rappresentato da un valore predefinito di 2000000000 per l'attributo. In un computer Exchange Server che fa parte di un'installazione Microsoft Windows Small Business Server 2003 il numero massimo predefinito di connessioni in arrivo è 500.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave OSProductSuite. Il valore di questa chiave corrisponde a una versione specifica di un sistema operativo Windows Server.

Se Exchange Server Analyzer rileva che l'attributo msExchSmtpMaxIncomingConnections in un computer Exchange Server che non fa parte di un'installazione Microsoft Windows Small Business Server 2003 non presenta un valore di 2000000000, verrà visualizzato un messaggio di configurazione non predefinita. Il valore di 2000000000 utilizzato per questo attributo è sia un limite teorico sia il limite imposto agli elementi dell'interfaccia utente che consentono di configurare questo valore.

In alternativa, se Exchange Server Analyzer rileva che l'attributo msExchSmtpMaxIncomingConnections in un computer Exchange Server che fa parte di un'installazione Microsoft Windows Small Business Server 2003 non presenta un valore di 500, verrà visualizzato un messaggio di configurazione non predefinita.

Dal punto di vista della protezione, ha senso limitare il numero di connessioni in ingresso. La capacità di accettare un numero essenzialmente illimitato di connessioni SMTP in ingresso potrebbe portare a una situazione di rifiuto del servizio. Un numero eccessivo di connessioni simultanee al server virtuale può sovraccaricare la rete e provocare una riduzione delle prestazioni. È preferibile che ogni organizzazione determini autonomamente quale valore è più appropriato per questo attributo.

Per visualizzare o configurare il numero massimo delle connessioni in ingresso

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Server, un server di Exchange, la struttura Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  4. Fare clic su Generale:

    • Per limitare il numero di connessioni in ingresso, selezionare la casella di controllo Limita il numero di connessioni a e immettere il valore desiderato.

    • Per ripristinare l'impostazione predefinita di connessioni in ingresso illimitate, deselezionare la casella di controllo Limita il numero di connessioni a.

  5. Fare clic su OK per salvare le modifiche.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpMaxHopCount è stato modificato rispetto all'impostazione predefinita
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpMaxHopCount è stato modificato rispetto al valore predefinito.

In Exchange 2000 Server, l'attributo msExchSmtpMaxHopCount è configurato con il valore predefinito 15. In Exchange Server 2003, l'attributo ha un valore predefinito 30. Se Exchange Server Analyzer rileva che questo attributo non è più impostato sul valore predefinito, verrà visualizzato un messaggio di configurazione non predefinita.

Un messaggio può essere instradato attraverso molti server SMTP diversi (ciascuno noto come hop) prima che esso raggiunga la sua destinazione finale. Per impedire che un messaggio venga ripetutamente indirizzato in modo errato (una condizione nota come ciclo di messaggi), un amministratore può controllare il numero massimo di hop consentiti. L'attributo mxExchSmtpMaxHopCount specifica il numero di server SMTP attraverso i quali un messaggio può passare prima che ritorni al mittente come non recapitato.

È consigliabile impostare il valore 30 per i server virtuali SMTP sia in Exchange 2000 Server sia in Exchange Server 2003.

Per risolvere il problema

  1. In Exchange System Manager, espandere la struttura Server, quindi espandere un server di Exchange, espandere la struttura Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e fare clic su Proprietà.

  3. Selezionare la scheda Recapito e fare clic su Avanzate.

  4. Immettere il valore desiderato nel campo Numero massimo di passaggi (hop) e fare clic su OK per salvare le modifiche.

  5. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpMaxMessageSize è stato impostato su un valore diverso da quello predefinito di 60
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo msExchSmtpMaxMessageSize è stato modificato rispetto al valore predefinito di 0. Per impostazione predefinita, l'attributo msExchSmtpMaxMessageSize è configurato per una dimensione dei messaggi illimitata. Se Exchange Server Analyzer rileva che il valore dell'attributo non è 0 e se Exchange non è in esecuzione su Microsoft Windows® Small Business Server 2003, verrà visualizzato un avviso.

L'attributo msExchSmtpMaxMessageSize rappresenta la dimensione massima di ciascun messaggio SMTP inviato o ricevuto. Dal punto di vista della protezione è consigliabile limitare la dimensione massima dei messaggi SMTP inviati e ricevuti tramite Internet. Tuttavia, per i messaggi SMTP interni, come quelli tra server di Exchange nella stessa organizzazione, è consigliabile che l'attributo msExchSmtpMaxMessageSize rimanga impostato su 0.

Internamente, i messaggi SMTP vengono utilizzati in Exchange per gestire operazioni quali la replica della cartella pubblica. Se l'attributo msExchSmtpMaxMessageSize è configurato con un limite troppo basso, è possibile che si verifichino problemi di replica della cartella pubblica e altri problemi di recapito messaggi all'interno dell'organizzazione.

Se il server di Exchange è un server testa a ponte che trasferisce messaggi SMTP tramite Internet, è possibile ignorare questo avviso. Se il server di Exchange gestisce messaggi SMTP interni, è preferibile modificare il valore dell'attributo msExchSmtpMaxMessageSize ripristinando l'impostazione predefinita di 0.

Nota:
Se il limite della dimensione del messaggio viene impostato su un valore troppo basso, è possibile che venga impedita la replica della rubrica non in linea tra computer Exchange Server. Per ulteriori informazioni su questo problema, consultare l'articolo 326154 della Microsoft Knowledge Base "XADM: OAB non esegue la replica se viene impostata una restrizione delle dimensioni dei messaggi a livello del trasporto" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=326154.

Per visualizzare e configurare la dimensione massima dei messaggi SMTP

  1. In Gestore di sistema di Exchange, espandere la struttura Server, espandere un server di Exchange, quindi espandere Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  3. Selezionare la scheda Messaggi.

  4. Per ripristinare l'impostazione predefinita 0, deselezionare la casella di controllo Limita dimensione messaggi a (KB). In alternativa, evitare di deselezionare la casella di controllo e configurare i valori desiderati.

  5. Fare clic su OK per salvare le modifiche e chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpMaxOutboundMsgPerDomain è stato impostato su un valore diverso da quello predefinito 20
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpMaxOutboundMsgPerDomain è stato modificato rispetto al valore predefinito di 20. Per impostazione predefinita, l'attributo msExchSmtpMaxOutboundMsgPerDomain è configurato per un numero massimo di 20 messaggi SMTP in uscita per ciascuna connessione. Se Microsoft Exchange Server Analyzer Tool rileva che l'attributo non presenta un valore pari a 20, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchSmtpMaxOutboundMsgPerDomain rappresenta il numero massimo di messaggi per connessione inviabili da un server virtuale SMTP sul server di Exchange. Ad esempio, se un server SMTP contiene 35 messaggi da inviare al sito Web microsoft.com e l'attributo msExchSmtpMaxOutboundMsgPerDomain è impostato su 20, verranno eseguite due connessioni ai server di posta elettronica che ospitano i messaggi di microsoft.com. Una connessione consentirà di inviare il numero massimo di 20 messaggi, mentre l'altra verrà eseguita per inviare i restanti 15.

Normalmente, non esiste una procedura consigliata per determinare il valore corretto di questo attributo. È preferibile che ogni organizzazione determini autonomamente il valore più adeguato da impostare.

Per impostare il numero massimo di messaggi per connessione

  1. Aprire il Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito), quindi scegliere Proprietà.

  4. Fare clic su Messaggi.

  5. Il valore corrente dell'attributo msExchSmtpMaxOutboundMsgPerDomain è elencato nel campo Limita il numero di connessioni per dominio a. Modificare questo campo, se necessario, quindi fare clic su OK per salvare le modifiche. I valori accettati per questo campo includono qualsiasi numero intero compreso tra 1 e 1999999999.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpMaxOutgoingConnections è stato impostato su un valore diverso da quello predefinito di 1000
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpMaxOutgoingConnections è stato modificato rispetto al valore predefinito 1000. Per impostazione predefinita, l'attributo msExchSmtpMaxOutgoingConnections è configurato per un numero massimo di 1000 connessioni SMTP (Simple Mail Transfer Protocol) in uscita. Se Exchange Server Analyzer rileva che l'attributo non presenta un valore pari a 1000, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchSmtpMaxOutgoingConnections rappresenta il numero massimo di connessioni esterne eseguibili da un server virtuale SMTP su un server di Exchange.

Normalmente, non esiste una procedura consigliata per determinare il valore corretto di questo attributo. È preferibile che ogni organizzazione determini autonomamente il valore più adeguato da impostare. Premesso ciò, il valore predefinito può essere troppo elevato per alcune organizzazioni. È possibile monitorare e determinare il numero attuale di connessioni SMTP esterne eseguite da un server virtuale SMTP Exchange raccogliendo i seguenti contatori di prestazioni sul server di Exchange:

Oggetto | Contatore | Spiegazione
Server SMTP | Outbound Connections Current | Numero di connessioni attualmente esterne.
Server SMTP | Outbound Connections Total | Numero totale di connessioni esterne tentate.

Se l'organizzazione non utilizza in modo sostanziale SMTP in uscita in questo server di Exchange, prendere in considerazione l'ipotesi di diminuire il valore di questo attributo. Se si diminuisce il numero massimo di connessioni SMTP esterne simultanee potenzialmente eseguibili, è possibile che vengano ulteriormente rallentati eventuali sovraccarichi nell'attività del server SMTP che potrebbero essere causati da errata configurazione, errori inconsapevoli, attività dannose, un ciclo di messaggi o altri funzionamenti errati oppure ad attacchi da parte di virus o violazione della protezione.

Per visualizzare e configurare il limite di connessioni in uscita

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito), quindi scegliere Proprietà.

  4. Fare clic su Recapito e poi su Connessioni esterne.

  5. Il valore corrente dell'attributo msExchSmtpMaxOutgoingConnections è elencato nel campo Limita il numero di connessioni per dominio a. Modificare questo campo, se necessario, quindi fare clic su OK per salvare le modifiche. I valori accettati per questo campo includono qualsiasi numero intero compreso tra 1 e 1999999999.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpMaxOutgoingConnectionsPerDomain è stato modificato rispetto all'impostazione predefinita di 100
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpMaxOutgoingConnectionsPerDomain è stato modificato rispetto al valore predefinito. L'attributo msExchSmtpMaxOutgoingConnectionsPerDomain rappresenta il numero massimo di connessioni esterne per dominio eseguibili da un server virtuale SMTP in un server Microsoft Exchange. Per impostazione predefinita, in un computer Exchange Server che non fa parte di un'installazione Microsoft® Windows® Small Business Server 2003, l'attributo msExchSmtpMaxOutgoingConnectionsPerDomain è configurato con un valore predefinito di 100. In un computer Exchange Server che fa parte di un'installazione Windows Small Business Server 2003, il valore massimo predefinito di connessioni esterne per dominio è 10.

Exchange Server Analyzer esegue inoltre una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem al fine di determinare il valore della chiave OSProductSuite. Il valore di questa chiave corrisponde a una versione specifica di un sistema operativo Windows Server.

Se Exchange Server Analyzer rileva che l'attributo msExchSmtpMaxOutgoingConnectionsPerDomain in un computer Exchange Server che non fa parte di un'installazione Windows Small Business Server 2003 non presenta un valore di 500, verrà visualizzato un messaggio di configurazione non predefinita.

In alternativa, se Exchange Server Analyzer rileva che l'attributo msExchSmtpMaxOutgoingConnectionsPerDomain in un computer Exchange Server che fa parte di un'installazione Windows Small Business Server 2003 non presenta un valore di 10, verrà visualizzato un messaggio di configurazione non predefinita.

Normalmente, non esiste una procedura consigliata per determinare il valore corretto di questo attributo. Ogni organizzazione determina autonomamente il valore più adeguato da impostare. Premesso ciò, il valore predefinito può essere troppo elevato per alcune organizzazioni. È possibile monitorare e determinare il numero attuale di connessioni SMTP esterne eseguite da un server virtuale SMTP Exchange raccogliendo i seguenti contatori di prestazioni sul server di Exchange:

Oggetto | Contatore | Spiegazione
Server SMTP | Outbound Connections Current | Numero di connessioni attualmente esterne.
Server SMTP | Outbound Connections Total | Numero totale di connessioni esterne tentate.

Se l'organizzazione non utilizza in modo sostanziale SMTP in uscita in questo server di Exchange, prendere in considerazione l'ipotesi di diminuire il valore di questo attributo. Se si diminuisce il numero massimo di connessioni SMTP esterne simultanee potenzialmente eseguibili, è possibile che vengano ulteriormente rallentati eventuali sovraccarichi nell'attività del server SMTP che potrebbero essere causati da errata configurazione, errori inconsapevoli, attività dannose, un ciclo di messaggi o altri funzionamenti errati oppure ad attacchi da parte di virus o violazione della protezione.

Per visualizzare e configurare il limite di connessioni in uscita per dominio

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e fare clic su Proprietà.

  4. Fare clic su Recapito e poi su Connessioni esterne.

  5. Il valore corrente dell'attributo msExchSmtpMaxOutgoingConnectionsPerDomain è elencato nel campo Limita il numero di connessioni per dominio a. Modificare questo campo nel modo desiderato, quindi fare clic su OK per salvare le modifiche. I valori accettati per questo campo includono qualsiasi numero intero compreso tra 1 e 1999999999.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpMaxRecipients è stato impostato su un valore diverso da quello predefinito di 64000
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpMaxRecipients è stato modificato rispetto al valore predefinito di 64000. Per impostazione predefinita, l'attributo msExchSmtpMaxRecipients è configurato per 64000 destinatari. Se Exchange Server Analyzer rileva che il valore dell'attributo non è 64000, verrà visualizzato un messaggio di configurazione non predefinita.

Dal punto di vista della protezione, la restrizione del numero massimo di destinatari per ciascun messaggio è fortemente consigliata. È preferibile che ogni organizzazione determini autonomamente il valore più adeguato da impostare. A meno che non esista un motivo per configurare questo valore in altro modo, è consigliabile non modificare il valore predefinito di 64000 per l'attributo msExchSmtpMaxRecipients.

Per visualizzare e configurare il numero massimo dei destinatari

  1. In Gestore di sistema di Exchange espandere Server, un server di Exchange, quindi Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  3. Selezionare la scheda Messaggi.

  4. Per ripristinare l'impostazione predefinita di 64.000, verificare che la casella di controllo Limita numero di destinatari per messaggio a: sia selezionata e immettere il valore 64.000. In alternativa, è possibile configurare il campo con il valore desiderato oppure deselezionare la casella di controllo per consentire un numero illimitato di destinatari.

  5. Fare clic su OK per salvare le modifiche e chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpMaxSessionSize è stato modificato rispetto all'impostazione predefinita di 0
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpMaxSessionSize è stato modificato rispetto al valore predefinito 0. Per impostazione predefinita, l'attributo msExchSmtpMaxSessionSize è configurato per una dimensione dei messaggi illimitata. Se Exchange Server Analyzer rileva che l'attributo non presenta un valore pari a 0, verrà visualizzato un avviso.

L'attributo msExchSmtpMaxSessionSize rappresenta la quantità massima di dati in kilobyte (KB) che verrà accettata per ciascuna sessione SMTP. Dal punto di vista della protezione, è consigliabile limitare la dimensione delle sessioni SMTP per i messaggi inviati e ricevuti tramite Internet. Tuttavia, per le sessioni SMTP interne, come quelle tra server di Exchange nella stessa organizzazione, è consigliabile che l'attributo msExchSmtpMaxSessionSize rimanga impostato su 0.

Internamente, i messaggi SMTP vengono utilizzati in Exchange per gestire operazioni quali la replica della cartella pubblica. Se l'attributo msExchSmtpMaxSessionSize è configurato con un limite troppo basso, è possibile che si verifichino problemi di replica della cartella pubblica.

Se il server di Exchange è un server testa di ponte che trasferisce messaggi SMTP tramite Internet, è possibile ignorare questo avviso. Se il server di Exchange gestisce messaggi SMTP interni, è preferibile modificare il valore dell'attributo msExchSmtpMaxSessionSize ripristinando l'impostazione predefinita 0.

Per visualizzare e configurare la dimensione massima della sessione SMTP

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Server, un server di Exchange, quindi la struttura Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  4. Fare clic su Messaggi.

  5. Per ripristinare l'impostazione predefinita 0, deselezionare la casella di controllo Limita dimensione sessione a (KB). In alternativa, evitare di deselezionare la casella di controllo e configurare i valori desiderati.

  6. Fare clic su OK per salvare le modifiche e chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpOutgoingPort è stato modificato rispetto all'impostazione predefinita di 25
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpOutgoingPort è stato modificato rispetto al valore predefinito di 25. Per impostazione predefinita, l'attributo msExchSmtpOutgoingPort è configurato per la porta TCP 25. Se Exchange Server Analyzer rileva che questo attributo è configurato per una porta diversa dalla porta 25, verrà visualizzato un avviso.

Per impostazione predefinita, i server SMTP (Simple Mail Transfer Protocol) sono configurati per accettare connessioni in ingresso sulla porta TCP 25. Il parametro msExchSmtpOutgoingPort rappresenta la porta a cui il server di Exchange tenterà di connettersi su tutti i server SMTP remoti. Se i server SMTP remoti non sono stati configurati per l'ascolto di questa porta, la connessione non può essere eseguita.

A meno una parte o l'intera infrastruttura di messaggistica interna sia stata modificata in modo da utilizzare porte non standard, è consigliabile utilizzare la porta TCP 25 per tutte le comunicazioni SMTP.

Per visualizzare o modificare la porta SMTP in uscita predefinita

  1. In Gestore di sistema di Exchange espandere Server, un server di Exchange, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e fare clic su Proprietà.

  3. Fare clic su Recapito e poi su Connessioni esterne.

  4. Nel campo Porta TCP immettere la porta che si desidera utilizzare per le connessioni esterne. Ogni server SMTP remoto con cui si desidera comunicare deve essere configurato in modo da accettare le connessioni sulla porta specificata. Nella maggior parte dei casi, non è necessario modificare questo valore.

  5. Modificare questo campo, se necessario, quindi fare clic su OK per salvare le modifiche.

  6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Il valore msExchSmtpRelayForAuth è stato impostato su un valore diverso da quello predefinito True
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpRelayForAuth è stato modificato rispetto al valore predefinito. Per impostazione predefinita l'attributo msExchSmtpRelayForAuth viene configurato con il valore True. Se Exchange Server Analyzer rileva che l'attributo msExchSmtpRelayForAuth non presenta un valore pari a True, verrà visualizzato un messaggio di configurazione non predefinita.

Se questo valore è impostato su True, solo le connessioni autenticate SMTP possono inoltrare i messaggi SMTP tramite il server virtuale SMTP. Se l'impostazione è stata modificata impostandola su False, significa che la casella di controllo "Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sopra" delle impostazioni di inoltro nella finestra di dialogo Proprietà del server virtuale SMTP è deselezionata.

L'inoltro è l'operazione di una connessione in entrata al proprio server SMTP utilizzata per inviare messaggi di posta elettronica a domini esterni. Nel caso di messaggi di posta elettronica pubblicitari non richiesti, l'operazione viene eseguita tramite l'invio di un singolo messaggio di posta al server SMTP con più destinatari in domini esterni all'organizzazione. Poiché l'impostazione predefinita per i server SMTP prevede l'utilizzo dell'autenticazione anonima, il sistema utilizzato per propagare i messaggi pubblicitari non richiesti accetta il messaggio in arrivo come tipico.

Dopo che il messaggio è stato accettato, il server SMTP riconosce che i destinatari del messaggio appartengono a domini esterni, quindi il server SMTP recapita i messaggi. Pertanto, gli utenti non autorizzati che inviano messaggi pubblicitari non richiesti devono semplicemente inviare un messaggio in ingresso al server SMTP in modo che questo venga recapitato a migliaia di destinatari. Questa attività rallenta la reattività del computer Exchange Server, provoca congestioni nelle code e l'insoddisfazione dei destinatari quando i messaggi arrivano nelle cartelle di posta in arrivo.

Il principale sistema per controllare la funzione di inoltro consiste nel non concedere permessi di inoltro ad altri host. Tuttavia, a volte è necessario eseguire inoltri. Ad esempio, nel caso in cui si disponga di client POP3 (Post Office Protocol) e IMAP4 (Internet Message Access Protocol) che si affidano a SMTP per il recapito di messaggi e si hanno motivi legittimi per inviare messaggi di posta elettronica a domini esterni. È possibile aggirare il problema creando un secondo server virtuale SMTP dedicato alla ricezione di messaggi di posta elettronica da client POP3 e IMAP4. Questo server virtuale SMTP aggiuntivo è in grado di utilizzare l'autenticazione combinata con la crittografia basata su SSL (Secure Sockets Layer) e può essere configurato per abilitare l'inoltro per i client autenticati. Per ulteriori informazioni su questo attributo, consultare l'articolo 319267 della Microsoft Knowledge Base, "HOW TO: Protezione del recapito dei messaggi di client SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267.

Per visualizzare o modificare il valore di msExchSmtpRelayForAuth nel Gestore di sistema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere la struttura Server, un server di Exchange, la struttura Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  4. Selezionare la scheda Accesso e fare clic su Inoltro.

  5. Selezionare o deselezionare la casella di controllo Consenti l'inoltro a tutti i computer che dispongono di autenticazione, indipendentemente dall'elenco riportato sopra.

  6. Fare clic su OK per salvare le modifiche.

Se la casella di controllo è selezionata, l'attributo msExchSmtpRelayForAuth deve essere impostato su True. Se la casella di controllo è deselezionata, l'attributo msExchSmtpRelayForAuth deve essere impostato su False.

Per ulteriori informazioni sul controllo degli account che possono inoltrare messaggi, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 818778, "Gli utenti privi dell'autorizzazione all'inoltro dei messaggi possono inviare messaggi attraverso il server virtuale SMTP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=818778.

  • 310380, "HOW TO: Impedire l'utilizzo di Exchange 2000 per l'inoltro della posta in Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380.


Il valore msExchSmtpSmartHostType è stato impostato su un valore diverso da quello predefinito 0
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato per l'attributo msExchSmtpSmartHostType è diverso da quello predefinito di 0. Per impostazione predefinita, l'attributo msExchSmtpSmartHostType è impostato su 0. Se Exchange Server Analyzer rileva che il valore dell'attributo non è 0, verrà visualizzato un messaggio di configurazione non predefinita.

L'attributo msExchSmtpSmartHostType indica se il server virtuale SMTP è configurato o meno per recapitare messaggi tramite SmartHost. Invece di inviare i messaggi direttamente ai domini dei destinatari, è possibile instradare tutti i messaggi in uscita a domini remoti tramite uno SmartHost. Quando si configura Exchange per l'utilizzo di uno SmartHost, il valore dell'attributo msExchSmtpSmartHostType viene modificato come descritto nella seguente tabella.

Impostazione SmartHost | Valore dell'attributo msExchSmtpSmartHostType
Nessuno SmartHost | 0
SmartHost | 2
SmartHost con precedente tentativo di recapito diretto | 1

Su computer Exchange Server 2003 questo valore è impostato su 0 o su 2, mentre su computer Exchange 2000 Server è impostato su 0, 1 o 2. Quando è selezionata la casella di controllo Tenta recapito diretto prima di inviare a SmartHost, il valore è impostato su 1. Questa casella di controllo è disponibile solo su computer Exchange 2000 Server. L'opzione non è inclusa in Exchange Server 2003.

A meno che non esista un motivo per configurare questo valore in altro modo, è consigliabile non modificare il valore predefinito di 0 per l'attributo msExchSmtpSmartHostType.

Se l'ambiente richiede uno SmartHost e se si dispone (o si disporrà in futuro) di almeno un computer Exchange Server nel proprio ambiente, è consigliabile utilizzare un connettore SMTP per le voci dello SmartHost. In questo modo tutta la posta interna verrà instradata da Exchange Server e solo la posta esterna verrà instradata tramite lo SmartHost.

Per visualizzare e configurare le impostazioni dello SmartHost

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  4. Selezionare la scheda Recapito e fare clic su Avanzate.

  5. Immettere lo SmartHost che si desidera utilizzare. È possibile identificare lo SmartHost tramite il nome di dominio completo oppure tramite un indirizzo IP. Se si utilizza un indirizzo IP, è necessario racchiuderlo tra parentesi quadre ([ ]). In Exchange viene verificato prima il nome server, poi l'indirizzo IP. Le parentesi consentono di identificare il valore come un indirizzo IP; pertanto la ricerca DNS viene ignorata.

  6. In un computer Exchange 2000 Server, è possibile selezionare la casella di controllo Tenta recapito diretto prima di inviare a SmartHost.

  7. Fare clic su OK per salvare le modifiche, quindi selezionare di nuovo OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=268163.


Il servizio Stack Agente di trasferimento messaggi è configurato per interagire con il desktop
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della proprietà DesktopInteract per il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi (MSExchangeMTA). Se Exchange Server Analyzer rileva che il servizio MTA è configurato per interagire con il desktop, verrà visualizzato un messaggio di errore.

Questa configurazione dovrebbe essere utilizzata solo dietro la guida del Servizio Supporto Tecnico Clienti Microsoft. Se non sono state fornite istruzioni dal Servizio Supporto Tecnico Clienti Microsoft per eseguire il servizio MTA in questa configurazione, è consigliabile riconfigurare le proprietà del servizio in modo che non interagisca con il desktop.

Per configurare il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi

  1. Aprire lo snap-in MMC Servizi.

  2. Individuare e interrompere il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi.

  3. Fare doppio clic sul servizio Microsoft Exchange - Stack Agente di trasferimento messaggi .

  4. Nella scheda Connessione della pagina delle proprietà del servizio Microsoft Exchange - Stack Agente di trasferimento messaggi selezionare Account di sistema locale in Accedi come.

  5. Deselezionare la casella di controllo Consenti al servizio di interagire col desktop e fare clic su Applica.

  6. In Stato del servizio fare clic su Avvia e quindi su OK.

  7. Aprire lo snap-in Servizi.

Per ulteriori informazioni sulla corretta configurazione dei servizi di Exchange, consultare l'articolo 239762 della Microsoft Knowledge Base "Esecuzione dei servizi di Exchange in LocalSystem" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=239762.


Nessun record Host trovato per record MX
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-03

Microsoft® Exchange Server Analyzer Tool esegue una ricerca DNS per recuperare i record MX (Mail Exchanger) per un dominio. Se i record MX vengono correttamente recuperati, Exchange Server Analyzer esegue una ricerca DNS per recuperare i record Host (A) dei server ai quali i record MX fanno riferimento. Se l'operazione di ricerca DNS non restituisce un indirizzo IP per uno qualsiasi dei record Host (A), verrà visualizzato un errore.

Tale errore indica che il record DNS Host (A) risulta mancante dal server. L'errore potrebbe provocare il backup dei messaggi destinati a domini remoti nelle code Recapito remoto del server Exchange. Potrebbero inoltre verificarsi ritardi nel routing o nel servizio.

Si può verificare un errore nella ricerca DNS di un record MX nel record Host (A) per i seguenti motivi:

  • Il server DNS è inattivo o non risponde a causa di un errore nella rete o per altri motivi.

  • Il record Host (A) del server remoto manca nel server DNS perché il record non è disponibile o non è corretto.

  • Il server DNS non è configurato per l'abilitazione gli aggiornamenti dinamici del record dell'host.

Per verificare che il server DNS è in linea e che il record Host è presente

  1. Verificare che il server DNS sia in esecuzione eseguendo uno o più dei seguenti controlli:

    • Controllare lo stato del server DNS utilizzando il programma di amministrazione DNS nel server DNS.

    • Riavviare il server DNS. Per ulteriori informazioni, vedere "Avvio, arresto, sospensione o riavvio di un server DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=62999.

    • Verificare la capacità di risposta del server DNS utilizzando il comando nslookup. Per ulteriori informazioni, vedere "Verificare la capacità di risposta del server DNS tramite il comando nslookup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63000.

  2. Utilizzare nslookup per verificare che il record Host (A) esiste nel server DNS. Per ulteriori informazioni, vedere "Per verificare l'esistenza di record di risorse A nel sistema DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63001.

  3. Se il record di risorse Host (A) non esiste, aggiungere manualmente o modificare il record di risorse A oppure configurare il server DNS per consentire aggiornamenti dinamici del record:

    • Aggiungere manualmente un record di risorse A. Per ulteriori informazioni, vedere "Aggiunta di un record di risorse a una zona DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63002.

    • Modificare manualmente un record di risorse A. Per ulteriori informazioni, vedere "Modifica di un record di risorsa esistente" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63014.

    • Configurare il server DNS per l'abilitazione degli aggiornamenti dinamici del record dell'host. Per ulteriori informazioni, vedere l'articolo 816592 della Microsoft Knowledge Base "Configurazione di aggiornamenti dinamici del DNS in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592.

Per ulteriori informazioni

  • Per informazioni sull'utilizzo da parte di Exchange Server 2003 del DNS per la risoluzione degli indirizzi IP esterni, vedere "Dipendenze del trasporto per Exchange Server 2003" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Per informazioni sulla risoluzione nomi DNS, vedere l'articolo 322856 della Microsoft Knowledge Base "Configurazione del DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • Per informazioni sulla risoluzione dei problemi del DNS, vedere "Risoluzione dei problemi relativi al servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63003.

  • Per informazioni sul monitoraggio del sistema di Exchange Server 2003, vedere "Chapter 3: "System Monitoring with Exchange Server 2003 Management Pack" in Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47573 (informazioni in lingua inglese).

  • Per informazioni sui record di risorse Host (A), vedere "Gestione dei record di risorse" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63004.


Nessun record Host trovato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-04

Microsoft® Exchange Server Analyzer Tool esegue una ricerca DNS per recuperare il record Host (A) dei server remoti ai quali ai quali il server Exchange sta tentando di inviare messaggi. Se l'operazione di ricerca DNS non restituisce un indirizzo IP, verrà visualizzato un errore.

Tale errore indica che il record DNS Host (A) risulta mancante dal server remoto. Tale errore potrebbe provocaare il backup dei messaggi nelle code Recapito remoto del server Exchange.

Si può verificare un errore nella ricerca DNS del record Host (A) dal server remoto per i seguenti motivi:

  • Il server DNS è inattivo o non risponde a causa di un errore nella rete o per altri motivi.

  • Il record Host (A) per il server remoto risulta mancante dal server DNS perché il record non è disponibile o non è corretto.

  • Il server DNS non è configurato per l'abilitazione gli aggiornamenti dinamici del record dell'host.

Per verificare che il server DNS è in linea e che il record Host è presente

  1. Verificare che il server DNS sia in esecuzione eseguendo uno o più dei seguenti controlli:

    • Controllare lo stato del server DNS utilizzando il programma di amministrazione DNS nel server DNS.

    • Riavviare il server DNS. Per ulteriori informazioni, vedere "Avvio, arresto, sospensione o riavvio di un server DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=62999.

    • Verificare la capacità di risposta del server DNS utilizzando il comando nslookup. Per ulteriori informazioni, vedere "Verificare la capacità di risposta del server DNS tramite il comando nslookup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63000.

  2. Utilizzare nslookup per verificare che il record Host (A) esiste nel server DNS. Per ulteriori informazioni, vedere "Per verificare l'esistenza di record di risorse A nel sistema DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63001.

  3. Se il record di risorse Host (A) non esiste, aggiungere manualmente o modificare il record di risorse A oppure configurare il server DNS per consentire aggiornamenti dinamici del record:

    • Aggiungere manualmente un record di risorse A. Per ulteriori informazioni, vedere "Aggiunta di un record di risorse a una zona DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63002.

    • Modificare manuallmente un record di risorse A. Per ulteriori informazioni, vedere "Modifica di un record di risorsa esistente" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63014.

    • Configurare il server DNS per l'abilitazione degli aggiornamenti dinamici del record dell'host. Per ulteriori informazioni, vedere l'articolo 816592 della Microsoft Knowledge Base "Configurazione di aggiornamenti dinamici del DNS in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=816592.
  • Per informazioni sull'utilizzo da parte di Exchange Server 2003 del DNS per la risoluzione degli indirizzi IP esterni, vedere "Dipendenze del trasporto per Exchange Server 2003" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Per informazioni sulla risoluzione nomi DNS, vedere l'articolo 322856 della Microsoft Knowledge Base "Configurazione del DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • Per informazioni sulla risoluzione dei problemi del DNS, vedere "Risoluzione dei problemi relativi al servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63003.

  • Per informazioni sul monitoraggio del sistema di Exchange Server 2003, vedere "Chapter 3: "System Monitoring with Exchange Server 2003 Management Pack" in Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47573 (informazioni in lingua inglese).

  • Per informazioni sui record di risorse Host (A), vedere "Gestione dei record di risorse" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63004.


Nessun record MX trovato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue query dei server DNS utilizzati per recuperare i record MX (Mail Exchanger) dei domini remoti ai quali sono diretti gli invii di Exchange.

Se non è possibile recuperare record MX per un dominio remoto dai server DNS utilizzati, verrà visualizzato un avviso.

Tale avviso indica che nel dominio remoto non sono disponibili i record MX DNS.

Per determinare gli host della posta, il server Exchange di invio verifica la presenza di record MX. Quindi, il server di invio risolve il record MX in un indirizzo IP cercando un record dell'indirizzo (A).

Se non sono disponibili record MX per domini remoti, è possibile che i messaggi destinati ai domini remoti vengano sottoposti a backup nelle code Recapito remoto del server Exchange oltre ad altri ritardi nel routing o nei servizi.

È possibile che la ricerca DNS dei record MX non venga eseguita se il server DNS è inattivo o irraggiungibile in seguito a un errore di rete o per altre motivazioni.

Per verificare se il server DNS è in linea e i record MX sono presenti

  1. Verificare che il server DNS sia in esecuzione eseguendo uno o più dei seguenti controlli:

    • Controllare lo stato del server DNS utilizzando il programma di amministrazione DNS nel server DNS.

    • Riavviare il server DNS. Per ulteriori informazioni, vedere "Avvio, arresto, sospensione o riavvio di un server DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=62999.

    • Verificare la capacità di risposta del server DNS utilizzando il comando nslookup. Per ulteriori informazioni, vedere le istruzioni in "Verificare la capacità di risposta del server DNS tramite il comando nslookup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63000.

  2. Utilizzare nslookup per verificare che i record MX siano configurati correttamente. Per ulteriori informazioni, consultare "Utilizzo di Nslookup per la verifica della configurazione dei record MX" nella sezione "Verifica della configurazione e della struttura del DNS" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni

  • Per informazioni sull'utilizzo da parte di Exchange Server 2003 del DNS per la risoluzione degli indirizzi IP esterni, vedere "Dipendenze del trasporto per Exchange Server 2003" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Per informazioni sulla risoluzione nomi DNS, vedere l'articolo 322856 della Microsoft Knowledge Base "Configurazione del DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • Per informazioni sulla risoluzione dei problemi del DNS, vedere "Risoluzione dei problemi relativi al servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63003.

  • Per informazioni sul monitoraggio del sistema di Exchange Server 2003, vedere "Chapter 3: "System Monitoring with Exchange Server 2003 Management Pack" in Exchange Server 2003 Management Pack Guide for MOM 2000 SP1 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47573 (informazioni in lingua inglese).


Gruppo di distribuzione nidificato trovato nelle restrizioni di recapito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool esegue una query nei seguenti attributi per ciascun oggetto gruppo di distribuzione in tutti i domini rilevati nel servizio directory di Active Directory® per determinare se vi siano gruppi utilizzati per impostare le restrizioni di recapito in base all'appartenenza al gruppo:

dLMemRejectPermsBL | Contiene i nomi distinti (DN) di destinatari o connettori che non accetteranno i messaggi provenienti da questo gruppo.
dLMemSubmitPermsBL | Contiene i DN di destinatari o connettori che accetteranno i messaggi provenienti da questo gruppo.

Quando Exchange Server Analyzer rileva che esistono oggetti gruppo utilizzati per impostare le restrizioni di recapito, esamina i gruppi per determinare se contengono gruppi nidificati.

Microsoft® Exchange Server Analyzer Tool legge inoltre la seguente chiave del Registro di sistema per determinare se è presente il valore RestrictionMethod del Registro di sistema e la relativa modalità di configurazione:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • L'appartenenza a un gruppo di distribuzione viene utilizzata per impostare le restrizioni di recapito.

  • Nei gruppi di distribuzione in cui sono state impostate le restrizioni di recapito sono presenti gruppi di distribuzione nidificati.

  • Il valore del Registro di sistema RestrictionMethod è presente e non è impostato per imporre la verifica delle restrizioni lineare.

L'errore indica che le restrizioni relative al recapito impostate in base all'appartenenza al gruppo di distribuzione potrebbero influenzare in modo significativo le prestazioni del flusso di posta di Exchange.

I comportamenti predefiniti del classificatore prevedono l'espansione ricorsiva dei gruppi di distribuzione e la verifica delle restrizioni per ogni messaggio che passa nel sistema.

Quando si invia posta elettronica a un utente che accetta o rifiuta i messaggi di un gruppo di distribuzione oppure quando la posta attraversa un connettore che accetta o rifiuta un messaggio proveniente da un gruppo, il classificatore deve espandere l'appartenenza al gruppo di distribuzione, ottenere l'elenco completo dei DN dei membri e infine confrontare l'elenco di DN con i DN del mittente dell'elenco. Quando un DN corrisponde in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

il valore RestrictionMethod determina il modo in cui il classificatore elabora le restrizioni. Se il valore di RestrictionMethod viene impostato su 2, i componenti di trasporto sul server che esegue Exchange Server non espanderanno l'appartenenza ai gruppi di distribuzione quando nel server vengono verificate le restrizioni. Questa configurazione consente le prestazioni migliori per le verifiche delle restrizioni. Per rendere effettiva la voce RestrictionMethod del Registro di sistema, è inoltre necessario che tutti i gruppi di distribuzione con utenti che dispongono di limitazioni di recapito siano semplici, ovvero, i gruppi di distribuzione con restrizioni non devono essere nidificati. In caso contrario, la logica di espansione non funzionerà.

Per i gruppi di distribuzione utilizzati nelle restrizioni per il connettore, si consiglia di impostare il valore della voce RestrictionMethod del Registro di sistema in un server testa di ponte del connettore privo di cassette postali. Per le restrizioni per gli utenti di Active Directory, se i gruppi di distribuzione con restrizioni dispongono di server di espansione, si consiglia di creare la voce RestrictionMethod del Registro di sistema in tali server.

Per risolvere il problema:

  • Esaminare gli utenti per i quali sono impostate le restrizioni relative al recapito in base al gruppo di distribuzione e rimuovere le restrizioni non necessarie.

  • Configurare cassette postali individuali e non gruppi di distribuzione per le restrizioni di recapito come menzionato nell'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

  • Per i server che eseguono Microsoft Exchange Server 2003 Service Pack 2 (SP2) o una versione successiva, implementare la verifica delle restrizioni non gerarchica. Per i server che eseguono una versione precedente a Exchange 2003 SP2, è consigliabile eseguire l'aggiornamento a Exchange 2003 SP2.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di conoscere le operazioni per ripristinarlo qualora si verifichi un problema. Per informazioni su questa procedura, vedere l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per creare la voce RestrictionMethod del Registro di sistema e impostare il relativo valore su 2

  1. Aprire un editor del Registro di sistema, ad esempio Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters

  3. Nel riquadro sinistro fare clic su Parametri.

  4. Dal menu Modifica scegliere Nuovo e quindi fare clic su Valore DWORD.

  5. Digitare RestrictionMethod, quindi premere INVIO per assegnare un nome alla nuova voce del Registro di sistema.

  6. Fare clic con il pulsante destro del mouse su RestrictionMethod e quindi fare clic su Modifica.

  7. Digitare 2 e premere INVIO.

  8. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sull'effetto della restrizione relativa al gruppo di distribuzione sul flusso di posta di Exchange Server 2003, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 895407 "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949 "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298 "Il recapito della posta è lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

Per ulteriori informazioni sul valore RestrictionMethod del Registro di sistema, consultare l'articolo 895407 della Microsoft Knowledge Base "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

Per ulteriori informazioni sul valore del Registro di sistema consultare l'articolo 277872 della Microsoft Knowledge Base "XCON: Possibile errato funzionamento delle restrizioni di recapito del connettore" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


Gruppo di distribuzione nidificato trovato ma verifica restrizioni lineare abilitata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool esegue una query nei seguenti attributi per ciascun oggetto gruppo di distribuzione in tutti i domini rilevati nel servizio directory di Active Directory® per determinare se vi siano gruppi utilizzati per impostare le restrizioni di recapito in base all'appartenenza al gruppo:

dLMemRejectPermsBL | Contiene i nomi distinti (DN) di destinatari o connettori che non accetteranno i messaggi provenienti da questo gruppo.
dLMemSubmitPermsBL | Contiene i DN di destinatari o connettori che accetteranno i messaggi provenienti da questo gruppo.

Quando Exchange Server Analyzer rileva che esistono oggetti gruppo utilizzati per impostare le restrizioni di recapito, esamina i gruppi per determinare se contengono gruppi nidificati.

Exchange Server Analyzer inoltre legge la chiave seguente del Registro di sistema per determinare se il valore del Registro di sistema RestrictionMethod è presente e il modo in cui viene configurato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • L'appartenenza a un gruppo di distribuzione viene utilizzata per impostare le restrizioni di recapito.

  • Nei gruppi di distribuzione in cui sono state impostate le restrizioni di recapito sono presenti gruppi di distribuzione nidificati.

  • Il valore del Registro di sistema RestrictionMethod è presente ed è impostato per imporre la verifica delle restrizioni lineare.

Questo avviso indica che sebbene il valore del Registro di sistema RestrictionMethod sia impostato sulla verifica delle restrizioni lineare (non gerarchica), i gruppi di distribuzione per i quali sono state impostate restrizioni di recapito presentano altri gruppi di distribuzione in essi incorporati (nidificati). La verifica delle restrizioni lineare non identificherà in modo corretto i mittenti accettati o rifiutati se i gruppi di distribuzione contengono gruppi nidificati. Infatti, con tale verifica i gruppi di distribuzione nidificati non vengono espansi.

I comportamenti predefiniti del classificatore prevedono l'espansione ricorsiva dei gruppi di distribuzione e la verifica delle restrizioni per ogni messaggio che passa nel sistema.

Quando si invia posta elettronica a un utente che accetta o rifiuta i messaggi di un gruppo di distribuzione oppure quando la posta attraversa un connettore che accetta o rifiuta un messaggio proveniente da un gruppo, il classificatore deve espandere l'appartenenza al gruppo di distribuzione, ottenere l'elenco completo dei DN dei membri e infine confrontare l'elenco di DN con i DN del mittente dell'elenco. Quando un DN corrisponde in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

il valore RestrictionMethod determina il modo in cui il classificatore elabora le restrizioni. Se il valore di RestrictionMethod viene impostato su 2, i componenti di trasporto sul server che esegue Exchange Server non espanderanno l'appartenenza ai gruppi di distribuzione quando nel server vengono verificate le restrizioni. Questa configurazione consente le prestazioni migliori per le verifiche delle restrizioni. Per rendere effettiva la voce RestrictionMethod del Registro di sistema, è inoltre necessario che tutti i gruppi di distribuzione con utenti che dispongono di limitazioni di recapito siano semplici, ovvero, i gruppi di distribuzione con restrizioni non devono essere nidificati.

Per risolvere il problema, non nidificare i gruppi di distribuzione in altri gruppi utilizzati per le restrizioni di recapito se è attivata la verifica delle restrizioni lineare.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 895407 "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949 "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298 "Il recapito della posta è lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

Per ulteriori informazioni sul valore RestrictionMethod del Registro di sistema, consultare l'articolo 895407 della Microsoft Knowledge Base "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

Per ulteriori informazioni sul valore del Registro di sistema consultare l'articolo 277872 della Microsoft Knowledge Base "XCON: Possibile errato funzionamento delle restrizioni di recapito del connettore" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


Nessun messaggio dal mittente specificato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-03-07

Lo strumento Microsoft Exchange Server Analyzer esegue una query nel valore attributo proxyAddress del servizio directory di Active Directory per tutti gli oggetti utente per determinare se esiste una corrispondenza per l'indirizzo SMTP (Simple Mail Transfer Protocol) del mittente locale specificato dall'utente.

Se viene rilevata una corrispondenza proxyAddress dell'oggetto utente, Exchange Server Analyzer esegue una query nel valore attributo msExchHomeServerName di Active Directory dell'oggetto utente per determinare se il valore corrisponde al nome di Exchange Server specificato dall'utente.

Exchange Server Analyzer esegue infine una query nella proprietà SenderAddress della classe WMI (Strumentazione gestione Windows) Exchange_MessageTrackingEntry nello spazio dei nomi root\MicrosoftExchangeV2 per identificare eventuali messaggi di cui i registri di verifica hanno tenuto traccia in quanto provenienti dal mittente specificato dall'utente.

Se Exchange Server Analyzer non riesce a rilevare una voce del registro di verifica messaggi con un valore proprietà senderAddress corrispondente a legacyDN o all'indirizzo SMTP del mittente specificato dall'utente, verrà visualizzato un errore.

  • L'errore indica che si sono verificate una o più condizioni tra le seguenti:

  • Il mittente specificato dall'utente non ha inviato alcun messaggio.

  • Il periodo di mantenimento del registro di verifica messaggi è scaduto e le relative voci sono già state eliminate.

  • La verifica messaggi non è attivata per il server.

Per risolvere questo problema:

  • Il mittente specificato deve inviare un altro messaggio al destinatario specificato.

  • Attivare il Centro di verifica messaggi.

  • Aumentare il periodo di mantenimento del registro di verifica messaggi oppure verificare un messaggio più recente.

Per ulteriori informazioni sull'attivazione del Centro di verifica messaggi, vedere "Abilitazione del Centro di verifica messaggi su un server" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=71257 della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

Per ulteriori informazioni sull'utilizzo della verifica messaggi vedere l'articolo 262162 della Microsoft Knowledge Base "XADM: Utilizzo del Centro di verifica messaggi per tenere traccia di un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162.


Nessun messaggio per il destinatario specificato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-12-07

Microsoft® Exchange Server Analyzer Tool esegue una query nel valore attributo proxyAddress del servizio directory di Active Directory® per tutti gli oggetti utente per determinare se esiste una corrispondenza per l'indirizzo SMTP (Simple Mail Transfer Protocol) del mittente locale specificato dall'utente.

Se viene rilevata una corrispondenza proxyAddress dell'oggetto utente, Exchange Server Analyzer esegue una query nel valore attributo msExchHomeServerName di Active Directory dell'oggetto utente per determinare se il valore corrisponde al nome di Exchange Server specificato dall'utente.

Exchange Server Analyzer esegue quindi la query nella proprietà SenderAddress per la classe WMI (Strumentazione gestione Windows®) Exchange_MessageTrackingEntry nello spazio dei nomi root\MicrosoftExchangeV2 per identificare eventuali messaggi, di cui i registri di verifica hanno tenuto traccia, provenienti dal mittente specificato dall'utente.

Exchange Server Analyzer esegue infine la query nella proprietà RecipientAddress della classe WMI Exchange_MessageTrackingEntry per identificare eventuali messaggi, di cui i registri di verifica hanno tenuto traccia, per il destinatario specificato dall'utente.

Se Exchange Server Analyzer non riesce a rilevare alcuna voce dei registri di verifica messaggi con un valore proprietà RecipientAddress corrispondente all'indirizzo SMTP del destinatario specificato dall'utente, verrà visualizzato un errore.

L'errore indica che si sono verificate una o più condizioni tra le seguenti:

  • Il mittente specificato dall'utente non ha inviato alcun messaggio al destinatario specificato dall'utente.

  • Il periodo di mantenimento del registro di verifica messaggi è scaduto e le relative voci sono già state eliminate.

Per risolvere questo problema:

  • Verificare che l'indirizzo del destinatario specificato sia corretto.

  • Il mittente specificato deve inviare un altro messaggio al destinatario specificato.

  • Aumentare il periodo di mantenimento del registro di verifica messaggi oppure verificare un messaggio più recente.

Per ulteriori informazioni su come aumentare il periodo di mantenimento del registro del Centro di verifica messaggi, vedere "Abilitazione del Centro di verifica messaggi su un server" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=71257.

Per ulteriori informazioni sull'utilizzo della verifica messaggi vedere l'articolo 262162 della Microsoft Knowledge Base "XADM: Utilizzo del Centro di verifica messaggi per tenere traccia di un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=262162.


Nessuno stato della coda disponibile. Analisi della coda SMTP interrotta.
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-03-15

Lo strumento Microsoft Exchange Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows) ExchangeLink per verificare lo stato delle code SMTP (Simple Mail Transfer Protocol) per un server Exchange.

SMTP è il protocollo nativo per l'invio e il trasporto della posta in Exchange Server. Ciò significa che i client utilizzano il protocollo SMTP per inviare i messaggi e i server Exchange utilizzano il protocollo SMTP per recapitare i messaggi e i dati relativi ai messaggi.

Le proprietà della classe WMI ExchangeLink restituiscono informazioni sui collegamenti di gestione dei messaggi (code) tra i server di posta. Un collegamento può contenere zero o più oggetti ExchangeQueue. Il numero dipende dal traffico di messaggi corrente nel collegamento.

SMTP utilizza le code SMTP per recapitare la posta internamente ed esternamente. Durante la categorizzazione e il recapito dei messaggi, il motore di accodamento avanzato invia la posta tramite le code SMTP di un server virtuale SMTP. Se in qualsiasi punto del processo si verificano problemi di recapito del messaggio, quest'ultimo rimane nella coda in cui si è verificato il problema.

Descrizioni delle code SMTP

Coda SMTP Descrizione

[Nome dominio locale] (Recapito locale)

Contiene i messaggi accodati nel server Exchange per il recapito locale a un archivio di cassette postali o cartelle pubbliche di Exchange Server.

Messaggi in attesa dell'individuazione della directory

Contiene messaggi per destinatari che non sono stati ancora risolti nel servizio directory Microsoft Active Directory. I messaggi vengono inoltre mantenuti nella coda durante l'espansione delle liste di distribuzione.

Messaggi in attesa di essere reindirizzati

Mantiene i messaggi finché non viene determinato il server di destinazione successivo, quindi li sposta nelle rispettive code di collegamento.

Recapito remoto

[Nome connettore|

Nome server| Dominio remoto]

Contiene i messaggi destinati al recapito remoto. Il nome della coda corrisponde alla destinazione del recapito remoto, ad esempio un connettore, server o dominio.

Destinazione finale attualmente non raggiungibile

Il server di destinazione finale per questi messaggi non è raggiungibile. Ad esempio, Exchange non è in grado di determinare un percorso di rete per la destinazione finale.

Pre-invio

Contiene i messaggi riconosciuti e accettati dal servizio SMTP. L'elaborazione di questi messaggi non è iniziata.

Messaggi DSN in attesa di invio

Contiene le notifiche sullo stato del recapito, denominate anche rapporti di mancato recapito, che sono pronte per essere recapitate da Exchange.

Nota Le operazioni seguenti non sono disponibili per questa coda:

  • Eliminazione di tutti messaggi (senza rapporto di mancato recapito)

  • Eliminazione di tutti messaggi (con rapporto di mancato recapito)

Coda tentativi messaggi non riusciti

Contiene i messaggi che non sono stati inviati a causa di errori di invio della coda, spesso prima che abbia avuto luogo qualsiasi altro tipo di elaborazione. Per impostazione predefinita, i messaggi contenuti in questa coda vengono rielaborati dopo 60 minuti.

Messaggi accodati per il recapito rinviato

Contiene i messaggi accodati per essere recapitati in un momento successivo, inclusi i messaggi inviati da versioni precedenti di Outlook. Questa opzione può essere impostata nei computer client Outlook.

Le versioni precedenti di Outlook dipendono dall'agente di trasferimento messaggi (MTA, Message Transfer Agent) per il recapito dei messaggi. In questo caso, tuttavia, il recapito dei messaggi viene gestito da SMTP, non da MTA. I messaggi inviati da versioni precedenti di Outlook gestiscono quindi il recapito rinviato in modo diverso.

Questi messaggi restano nella coda fino all'ora di recapito pianificata.

Se Exchange Analyzer non è in grado di completare la query nella classe WMI ExchangeLink per un determinato server, viene visualizzato un errore.

Tale errore indica che la query WMI non è stata in grado di recuperare i dati richiesti.

I possibili motivi di questo errore sono riportati di seguito:

  • L'account che esegue Exchange Analyzer non dispone delle autorizzazioni necessarie per eseguire una query nelle classi WMI.

  • Un problema di rete impedisce a Exchange Analyzer di accedere al computer.

  • Una condizione temporanea di origine sconosciuta ha provocato il timeout della query.

Per correggere l'errore, procedere come segue:

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Utilizzare il comando PING per verificare che il computer Exchange Server sia raggiungibile.

  3. Se è attivo un firewall, verificare se le porte RPC (Remote Procedure Call) sono bloccate.

  4. Controllare le autorizzazioni dell'account su cui è in esecuzione Exchange Analyzer. Questo account deve disporre delle autorizzazioni di amministratore locale su ciascun server Exchange di cui esegue l'analisi.

    In alternativa, è possibile concedere un'autorizzazione WMI specifica all'account su cui è in esecuzione Exchange Analyzer:

    1. Sul computer Exchange aprire la struttura della console MMC (Microsoft Management Console) Gestione computer.

    2. In Servizi e applicazioni fare clic con il pulsante destro del mouse su Controllo WMI e scegliere Proprietà.

    3. Nella pagina delle proprietà Controllo WMI fare clic sulla scheda Protezione, quindi espandere Directory principale.

    4. Selezionare la cartella CIMV2, quindi fare clic su Protezione.

    5. Nella pagina Protezione per ROOT\CIMV2 aggiungere l'account sul quale è in esecuzione Exchange Analyzer.

  5. Selezionare l'account aggiunto nel Passaggio 5. In Autorizzazioni per Account selezionato, nella colonna Consenti, selezionare sia Abilita remoto sia Protezione da lettura, quindi fare clic su OK.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività della rete, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sulla risoluzione dei problemi di connettività dello strumento Exchange Best Practices Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Panoramica dei servizi e requisiti per le porte di rete per il sistema server Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017.


Nessun server o dominio remoto disponibile per i test dei record DNS
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-06

Microsoft® Exchange Server Analyzer Tool tenta di individuare e creare un elenco di nomi di dominio completi (FQDN, Fully Qualified Domain Name), indirizzi IP e nomi di dominio di server ai quali sono destinati messaggi di posta in una coda di recapito remota.

La creazione dell'elenco di FQDN, indirizzi IP e nomi di dominio di server remoti avviene come segue:

  • Viene eseguita una query nella proprietà msExchSmtpFullyQualifiedDomainName dell'oggetto del servizio directory di ActiveDirectory® del server virtuale SMTP.

    Nota:
    La proprietà msExchSmtpFullyQualifiedDomainName viene a letta a sua volta dalla proprietà msExchTargetBridgeheadServersDN di un oggetto directory del connettore del gruppo di instradamento quando in essa viene eseguita una query per rilevare la presenza dei server testa di ponte di destinazione designati.
  • Viene eseguita una query nella proprietà msExchSmtpSmartHost dell'oggetto Active Directory del connettore SMTP per rilevare la presenza di un connettore SMTP di uno SmartHost.

  • Viene eseguita una query nella proprietà LinkName della classe Microsoft WMI (Strumentazione gestione Windows®) ExchangeLink per rilevare la presenza di connessioni dirette al server remoto.

Se Microsoft Exchange Server Analyzer Tool determina che il tentativo di creare l'elenco non è riuscito, verrà visualizzato un errore.

L'errore indica che:

  • Potrebbero sussistere problemi di connessione intermittente alla rete o ad Active Directory che causano problemi di flusso di posta.

  • L'account che esegue Microsoft Exchange Server Analyzer Tool potrebbe non disporre delle autorizzazioni necessarie per eseguire una query nelle informazioni.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Verificare che si disponga della connettività di rete a un controller di dominio di Active Directory.

  3. Specificare in Microsoft Exchange Server Analyzer Tool un controller di dominio di Active Directory.

  4. Utilizzare il comando PING per verificare che il computer Exchange Server sia raggiungibile.

  5. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  6. Controllare le autorizzazioni dell'account su cui è in esecuzione Microsoft Exchange Server Analyzer Tool. Questo account deve disporre delle autorizzazioni di Administrator locale su ciascun computer di Exchange Server di cui esegue l'analisi.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sui problemi di connettività di Exchange Server Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (in inglese).

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Informazioni generali sul servizio e sui requisiti delle porte di rete del sistema Microsoft Windows Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017 (in inglese).


Nessun server disponibile per i test del comando SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-16

Microsoft® Exchange Server Analyzer Tool tenta di individuare e creare un elenco di nomi di dominio completi (FQDN, Fully Qualified Domain Name), indirizzi IP e nomi di dominio di server remoti ai quali sono destinati messaggi di posta in una coda di recapito remota.

La creazione dell'elenco di FQDN, indirizzi IP e nomi di dominio di server remoti avviene come segue:

  • Viene eseguita una query nella proprietà msExchSmtpFullyQualifiedDomainName dell'oggetto del servizio directory di ActiveDirectory® del server virtuale SMTP.

    Nota:
    La proprietà msExchSmtpFullyQualifiedDomainName viene a letta a sua volta dalla proprietà msExchTargetBridgeheadServersDN di un oggetto directory del connettore del gruppo di routing quando in essa viene eseguita una query per rilevare la presenza dei server testa di ponte di destinazione designati.
  • Viene eseguita una query nella proprietà msExchSmtpSmartHost dell'oggetto Active Directory del connettore SMTP per rilevare la presenza di un connettore SMTP di uno SmartHost.

  • Viene eseguita una query nella proprietà LinkName della classe Microsoft WMI (Strumentazione gestione Windows®) ExchangeLink per rilevare la presenza di connessioni dirette al server remoto.

Se Microsoft Exchange Server Analyzer Tool determina che il tentativo di creare l'elenco non è riuscito, verrà visualizzato un errore.

L'errore indica quanto segue:

  • Problemi di connessione intermittente alla rete o ad Active Directory potrebbero causare problemi di flusso di posta.

  • L'account che esegue Microsoft Exchange Server Analyzer Tool potrebbe non disporre delle autorizzazioni necessarie per eseguire una query nelle informazioni.

Per risolvere il problema

  1. Assicurarsi che il server che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Verificare che si disponga della connettività di rete a un controller di dominio di Active Directory.

  3. Specificare in Microsoft Exchange Server Analyzer Tool un controller di dominio di Active Directory.

  4. Utilizzare il comando PING per verificare che il server di Exchange sia raggiungibile.

  5. Se è attivo un firewall, verificare se le porte RPC (Remote Procedure Call) sono bloccate.

  6. Controllare le autorizzazioni dell'account per cui è in esecuzione Microsoft Exchange Server Analyzer Tool. Questo account deve disporre delle autorizzazioni di amministratore locale su ciascun computer di Exchange Server di cui esegue l'analisi.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo 325487 della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sui problemi di connettività di Exchange Server Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (in inglese).

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Panoramica dei servizi e requisiti per le porte di rete per il sistema server Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017.


Nessun server disponibile per i test di connettività
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool tenta di individuare e creare un elenco di nomi di dominio completi (FQDN, Fully Qualified Domain Names), indirizzi IP e nomi di dominio di server ai quali sono destinati messaggi di posta in una coda di recapito remota.

  • La creazione dell'elenco di FQDN, indirizzi IP e nomi di dominio di server remoti avviene come segue:

  • Viene eseguita una query nella proprietà msExchSmtpFullyQualifiedDomainName dell'oggetto del servizio directory di ActiveDirectory® del server virtuale SMTP.

    Nota:
    La proprietà msExchSmtpFullyQualifiedDomainName viene a letta a sua volta dalla proprietà msExchTargetBridgeheadServersDN di un oggetto directory del connettore del gruppo di instradamento quando in essa viene eseguita una query per rilevare la presenza dei server testa di ponte di destinazione designati.
  • Viene eseguita una query nella proprietà msExchSmtpSmartHost dell'oggetto Active Directory del connettore SMTP per rilevare la presenza di un connettore SMTP di uno SmartHost.

  • Viene eseguita una query nella proprietà LinkName della classe Microsoft WMI (Strumentazione gestione Windows®) ExchangeLink per rilevare la presenza di connessioni dirette al server remoto.

Se Microsoft Exchange Server Analyzer Tool determina che il tentativo di creare l'elenco non è riuscito, verrà visualizzato un errore.

L'errore indica che:

  • Potrebbero sussistere problemi di connessione intermittente alla rete o ad Active Directory che causano problemi di flusso di posta.

  • L'account che esegue Microsoft Exchange Server Analyzer Tool potrebbe non disporre delle autorizzazioni necessarie per eseguire una query nelle informazioni.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Verificare che si disponga della connettività di rete a un controller di dominio di Active Directory.

  3. Specificare in Microsoft Exchange Server Analyzer Tool un controller di dominio di Active Directory.

  4. Utilizzare il comando PING per verificare che il computer Exchange Server sia raggiungibile.

  5. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  6. Controllare le autorizzazioni dell'account su cui è in esecuzione Microsoft Exchange Server Analyzer Tool. Questo account deve disporre delle autorizzazioni di Administrator locale su ciascun computer di Exchange Server di cui esegue l'analisi.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sui problemi di connettività di Exchange Server Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (in inglese).

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Informazioni generali sul servizio e sui requisiti delle porte di rete del sistema Microsoft Windows Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017 (in inglese).


Nessun server disponibile per le verifiche dei nomi delle istanze SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool tenta di individuare e creare un elenco di nomi di dominio completi (FQDN, Fully Qualified Domain Name), indirizzi IP e nomi di dominio di server ai quali sono destinati messaggi di posta in una coda di recapito remota.

La creazione dell'elenco di FQDN, indirizzi IP e nomi di dominio di server remoti avviene come segue:

  • Viene eseguita una query nella proprietà msExchSmtpFullyQualifiedDomainName dell'oggetto del servizio directory di ActiveDirectory® del server virtuale SMTP.

    Nota:
    La proprietà msExchSmtpFullyQualifiedDomainName viene a letta a sua volta dalla proprietà msExchTargetBridgeheadServersDN di un oggetto directory del connettore del gruppo di instradamento quando in essa viene eseguita una query per rilevare la presenza dei server testa di ponte di destinazione designati.
  • Viene eseguita una query nella proprietà msExchSmtpSmartHost dell'oggetto Active Directory del connettore SMTP per rilevare la presenza di un connettore SMTP di uno SmartHost.

  • Viene eseguita una query nella proprietà LinkName della classe Microsoft WMI (Strumentazione gestione Windows®) ExchangeLink per rilevare la presenza di connessioni dirette al server remoto.

Se Microsoft Exchange Server Analyzer Tool determina che il tentativo di creare l'elenco non è riuscito, verrà visualizzato un errore.

L'errore indica che:

  • Potrebbero sussistere problemi di connessione intermittente alla rete o ad Active Directory che causano problemi di flusso di posta.

  • L'account che esegue Microsoft Exchange Server Analyzer Tool potrebbe non disporre delle autorizzazioni necessarie per eseguire una query nelle informazioni.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Verificare che si disponga della connettività di rete a un controller di dominio di Active Directory.

  3. Specificare in Microsoft Exchange Server Analyzer Tool un controller di dominio di Active Directory.

  4. Utilizzare il comando PING per verificare che il computer Exchange Server sia raggiungibile.

  5. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  6. Controllare le autorizzazioni dell'account su cui è in esecuzione Microsoft Exchange Server Analyzer Tool. Questo account deve disporre delle autorizzazioni di Administrator locale su ciascun computer di Exchange Server di cui esegue l'analisi.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sui problemi di connettività di Exchange Server Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (in inglese).

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Informazioni generali sul servizio e sui requisiti delle porte di rete del sistema Microsoft Windows Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017 (in inglese).


Impostazione della cache del servizio di routing non predefinita
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'impostazione predefinita della cache del servizio di routing è stata modificata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\

Se Exchange Server Analyzer rileva che il valore del Registro di sistema ServerCacheRefreshInterval è stato creato manualmente, modificando l'impostazione binaria predefinita di 900 secondi di Exchange Server, verrà visualizzato un avviso. Per impostazione predefinita il valore ServerCacheRefreshInterval del Registro di sistema non viene creato durante l'installazione di Exchange Server. Tuttavia, il valore ServerCacheRefreshInterval del Registro di sistema può essere creato manualmente dopo l'installazione di Exchange Server per modificare l'impostazione predefinita della cache del servizio di routing. Se il valore viene creato manualmente e l'impostazione del valore non è configurata correttamente, possono verificarsi problemi nel flusso di posta.

Si consiglia di creare o modificare il valore ServerCacheRefreshInterval del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari del server di Exchange sono stati accuratamente selezionati per garantire prestazioni ottimali per l'utilizzo nella maggior parte degli ambienti server di Exchange. Generalmente la soluzione ottimale è di affrontare la causa del problema anziché modificare il comportamento predefinito di Exchange Server configurando manualmente il Registro di sistema. Per attenersi alle indicazioni, se esiste il valore ServerCacheRefreshInterval del Registro di sistema, è possibile eliminarlo per consentire al server di Exchange di ripristinare l'impostazione binaria predefinita per la cache del servizio di routing. Tuttavia, la decisione dipende dalle impostazioni di configurazione personalizzate di Exchange Server o dall'ambiente Exchange.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia è possibile modificare il Registro di sistema per ripristinare il valore predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di apportare modifiche al Registro di sistema, accertarsi di poter eseguire il ripristino in caso di problemi. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Fare clic su Start, Esegui, digitare Regedit, quindi fare clic su OK.

  2. Nella struttura della console individuare la seguente chiave del Registro di sistema e fare clic su di essa: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\RESvc\Parameters\

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore ServerCacheRefreshInterval del Registro di sistema. Modificare il valore impostandolo su 900.

  4. In alternativa, nel riquadro dei dettagli è possibile fare clic con il pulsante destro del mouse sul valore ServerCacheRefreshInterval del Registro di sistema, quindi su Elimina. Per confermare l'eliminazione del valore del Registro di sistema, fare clic su Sì nella finestra di dialogo.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema di Microsoft Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Valore SMTP LdapRequestTimeLimit del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se LdapRequestTimeLimit predefinito è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se viene rilevato che il valore LdapRequestTimeLimit del Registro di sistema è stato creato manualmente per modificare l'impostazione binaria predefinita di 600 secondi del server di Exchange, verrà visualizzato un avviso di configurazione non predefinita. Per impostazione predefinita il valore LdapRequestTimeLimit del Registro di sistema non viene creato durante l'installazione di Exchange Server. Tuttavia è possibile creare manualmente il valore LdapRequestTimeLimit del Registro di sistema dopo l'installazione, per modificare l'intervallo di tempo massimo in secondi di attesa in coda di una richiesta LDAP. Se il valore viene creato manualmente e l'impostazione del valore del Registro di sistema non è configurata correttamente, possono verificarsi problemi nel trasporto dei messaggi.

Si consiglia di creare o modificare il valore LdapRequestTimeLimit del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari del server di Exchange sono stati accuratamente selezionati per garantire prestazioni ottimali per l'utilizzo nella maggior parte degli ambienti server di Exchange. Generalmente la soluzione ottimale è di affrontare la causa del problema anziché modificare il comportamento predefinito di Exchange Server configurando manualmente il Registro di sistema. Per attenersi alle indicazioni, se esiste il valore LdapRequestTimeLimit del Registro di sistema, è possibile eliminarlo per consentire al server di Exchange di ripristinare l'impostazione binaria predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia è possibile modificare il Registro di sistema per ripristinare il valore predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di apportare modifiche al Registro di sistema, accertarsi di poter eseguire il ripristino in caso di problemi. Per informazioni su questa procedura, consultare l'argomento "Ripristino del Registro di sistema" della Guida in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Fare clic su Start, Esegui, digitare Regedit, quindi fare clic su OK.

  2. Nella struttura della console individuare la seguente chiave del Registro di sistema fare clic su di essa: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore LdapRequestTimeLimit del Registro di sistema. Modificare il valore impostandolo su 600.

  4. Facoltativamente, è possibile fare clic con il pulsante destro del mouse nel riquadro dei dettagli sul valore LdapRequestTimeLimit del Registro di sistema, quindi fare clic su Elimina. Confermare l'eliminazione del valore facendo clic su Sì nella finestra di dialogo.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Valore SMTP LdapResultTimeout del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore LdapResultTimeout predefinito è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se viene rilevato che la chiave LdapResultTimeout del Registro di sistema è stata creata manualmente per modificare l'impostazione binaria predefinita di 121 secondi del server di Exchange, verrà visualizzato un messaggio di configurazione non predefinita. Per impostazione predefinita la chiave LdapResultTimeout del Registro di sistema non viene creata durante l'installazione di Exchange Server. Tuttavia, la chiave LdapResultTimeout del Registro di sistema può essere creata manualmente dopo l'installazione di Exchange Server per modificare il valore di timeout. LdapResultTimeout è il tempo di attesa massimo, espresso in secondi, prima che i thread di completamento LDAP eseguano l'elaborazione delle connessioni LDAP del classificatore. Se alla scadenza del timeout il server di catalogo globale non ha restituito nuovi risultati, si verificherà un errore di connessione nelle ricerche in sospeso con LDAP_SERVER_DOWN. Questo processo consente di inviare nuovamente le ricerche in sospeso su nuove connessioni. Se il valore viene creato manualmente e l'impostazione del valore del Registro di sistema non è configurata correttamente, possono verificarsi problemi nel trasporto dei messaggi.

Si consiglia di creare o modificare il valore LdapResultTimeout del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari di Exchange Server sono stati accuratamente selezionati per prestazioni ottimali per l'utilizzo nella maggior parte degli ambienti Exchange Server. Generalmente la soluzione ottimale è di affrontare la causa del problema anziché modificare il comportamento predefinito di Exchange Server configurando manualmente il Registro di sistema. Per attenersi alle indicazioni, se esiste il valore LdapResultTimeout del Registro di sistema, è possibile eliminarlo per consentire al server di Exchange di ripristinare l'impostazione binaria predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia è possibile modificare il Registro di sistema per ripristinare il valore predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di apportare modifiche al Registro di sistema, accertarsi di poter eseguire il ripristino in caso di problemi. Per informazioni su questa procedura, consultare l'argomento "Ripristino del Registro di sistema" della Guida in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Fare clic su Start, Esegui, digitare Regedit, quindi fare clic su OK.

  2. Nella struttura della console individuare la seguente chiave del Registro di sistema fare clic su di essa: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore LdapResultTimeout del Registro di sistema. Modificare il valore impostandolo su 121.

  4. Facoltativamente, è possibile fare clic con il pulsante destro del mouse nel riquadro dei dettagli sul valore LdapResultTimeout del Registro di sistema, quindi fare clic su Elimina. Confermare l'eliminazione del valore facendo clic su Sì nella finestra di dialogo.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Valore SMTP MaxConnectionRetries del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore di MaxConnectionRetries predefinito è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se Exchange Server Analyzer rileva che il valore del Registro di sistema MaxConnectionRetries è stato creato manualmente, modificando l'impostazione binaria predefinita di 20 secondi del server di Exchange, verrà visualizzato un avviso di configurazione non predefinita. Per impostazione predefinita il valore MaxConnectionRetries del Registro di sistema non viene creato durante l'installazione di Exchange Server. Tuttavia, il valore MaxConnectionRetries del Registro di sistema può essere creato manualmente dopo l'installazione di Exchange Server per modificare il valore. Il valore MaxConnectionRetries determina il numero massimo di volte in cui una singola categorizzazione può essere inviata nuovamente su una nuova connessione dopo che la relativa connessione LDAP non è riuscita. Dopo l'errore di categorizzazione sulla connessione MaxConnectionRetries, la categorizzazione viene inserita nella coda dei tentativi. Se il valore del Registro di sistema viene creato manualmente e se la relativa impostazione è configurata in modo errato, possono verificarsi problemi nel trasporto dei messaggi.

Si consiglia di creare o modificare il valore MaxConnectionRetries del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari di Exchange Server sono stati accuratamente selezionati per garantire prestazioni ottimali per l'utilizzo nella maggior parte degli ambienti Exchange Server. Generalmente la soluzione ottimale è di affrontare la causa del problema anziché modificare il comportamento predefinito di Exchange Server configurando manualmente il Registro di sistema. Per attenersi alle indicazioni, se esiste il valore MaxConnectionRetries del Registro di sistema, è possibile eliminarlo per consentire a Exchange Server di ripristinare l'impostazione binaria predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia è possibile modificare il Registro di sistema per ripristinare il valore predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di apportare modifiche al Registro di sistema, accertarsi di poter eseguire il ripristino in caso di problemi. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Fare clic su Start, Esegui, digitare Regedit, quindi fare clic su OK.

  2. Nella struttura della console individuare la seguente chiave del Registro di sistema e fare clic su di essa: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore MaxConnectionRetries del Registro di sistema. Modificare il valore impostandolo su 20.

  4. In alternativa, nel riquadro dei dettagli è possibile fare clic con il pulsante destro del mouse sul valore MaxConnectionRetries del Registro di sistema, quindi su Elimina. Per confermare l'eliminazione del valore del Registro di sistema, fare clic su Sì nella finestra di dialogo.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986)

Per ulteriori informazioni sulla modifica del Registro di sistema di Microsoft Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Valore SMTP MaxLdapConnections del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore predefinito di MaxLdapConnections è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se Exchange Server Analyzer rileva che il valore MaxLdapConnections del Registro di sistema è stato creato manualmente, modificando l'impostazione binaria predefinita di 20 del server di Exchange, verrà visualizzato un avviso di configurazione non predefinita. Per impostazione predefinita, il valore MaxLdapConnections del Registro di sistema non viene creato durante un'installazione di Exchange. Tuttavia, il valore MaxLdapConnections del Registro di sistema può essere creato manualmente dopo l'installazione di Exchange per modificare il valore. Il valore MaxLdapConnections rappresenta il numero massimo di connessioni LDAP aperto dal classificatore a un unico server di catalogo globale. Se il valore del Registro di sistema viene creato manualmente e se la relativa impostazione è configurata in modo errato, potrebbero verificarsi problemi nel trasporto dei messaggi.

Attenzione
Il valore MaxLdapConnections del Registro di sistema e l'impostazione del valore HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPoolThreads del Registro di sistema devono corrispondere in ogni momento.

Si consiglia di creare o modificare il valore MaxLdapConnections del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari del server di Exchange sono stati accuratamente selezionati per garantire prestazioni ottimali nella maggior parte degli ambienti Exchange Server. In genere, si consiglia di risolvere la causa principale del problema anziché modificare il comportamento predefinito di Exchange Server configurando manualmente il Registro di sistema. Per soddisfare le configurazioni ottimali, se è presente il valore MaxLdapConnections del Registro di sistema, è possibile eliminarlo per riconfigurare il server di Exchange in base all'impostazione binaria predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia, è possibile che si desideri reimpostare il valore del Registro di sistema sul valore predefinito modificando il Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di apportare modifiche al Registro di sistema, accertarsi di poter eseguire il ripristino in caso di problemi. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Fare clic su Start, Esegui, digitare Regedit, quindi fare clic su OK.

  2. Nella struttura della console individuare la seguente chiave del Registro di sistema e fare clic su di essa: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore MaxLdapConnections del Registro di sistema. Modificare il valore impostandolo su 8.

  4. In alternativa, nel riquadro dei dettagli è possibile fare clic con il pulsante destro del mouse sul valore MaxLdapConnections del Registro di sistema, quindi su Elimina. Per confermare l'eliminazione del valore del Registro di sistema, fare clic su Sì nella finestra di dialogo.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" (all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema di Microsoft Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Valore SMTP MaxPendingSearches del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore predefinito di MaxPendingSearches è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se Exchange Server Analyzer rileva che il valore MaxPendingSearches del Registro di sistema è stato creato manualmente, modificando l'impostazione binaria predefinita di 60 del server di Exchange, verrà visualizzato un avviso di configurazione non predefinita. Per impostazione predefinita il valore MaxPendingSearches del Registro di sistema non viene creato durante l'installazione di Exchange Server. Tuttavia, il valore MaxPendingSearches del Registro di sistema può essere creato manualmente dopo l'installazione di Exchange Server per modificare il valore. ll valore MaxPendingSearches indica il numero di ricerche LDAP in attesa che può contenere il classificatore in un particolare server di catalogo globale. Nelle versioni precedenti a Exchange 2000 Server SP3, il numero massimo delle ricerche in attesa per ciascuna connessione era 1024. Il valore predefinito in Exchange 2000 Server SP3 ed Exchange Server 2003 è impostato su 60. Ad esempio, se si modifica questo valore predefinito impostandolo su 30, verrà ridotto il numero totale di ricerche LDAP contenute nel classificatore nel server di catalogo globale.

Se il valore del Registro di sistema viene creato manualmente e se la relativa impostazione è configurata in modo errato, potrebbero verificarsi problemi nel trasporto dei messaggi.

Si consiglia di creare o modificare il valore MaxPendingSearches del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari del server di Exchange sono stati accuratamente selezionati per garantire prestazioni ottimali nella maggior parte degli ambienti Exchange Server. In genere, si consiglia di risolvere la causa principale del problema anziché modificare il comportamento predefinito di Exchange configurando manualmente il Registro di sistema. Per soddisfare le configurazioni ottimali, se è presente il valore MaxPendingSearches del Registro di sistema, è possibile eliminarlo per riconfigurare il server di Exchange in base all'impostazione binaria predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia, è possibile che si desideri reimpostare il valore del Registro di sistema sul valore predefinito modificando il Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di apportare modifiche al Registro di sistema, accertarsi di poter eseguire il ripristino in caso di problemi. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Fare clic su Start, selezionare Esegui, digitare Regedit, quindi fare clic su OK.

  2. Nella struttura della console individuare la seguente chiave del Registro di sistema e fare clic su di essa: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore MaxPendingSearches del Registro di sistema. Modificare il valore impostandolo su 60.

  4. In alternativa, nel riquadro dei dettagli è possibile fare clic con il pulsante destro del mouse sul valore MaxPendingSearches del Registro di sistema, quindi su Elimina. Per confermare l'eliminazione del valore del Registro di sistema, fare clic su Sì nella finestra di dialogo.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema di Microsoft Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

•322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

•322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP e Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Valore SMTP MaxSearchBlockSize del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il valore predefinito di MaxSearchBlockSize è stato modificato:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters

Se Exchange Server Analyzer rileva che il valore MaxSearchBlockSize del Registro di sistema è stato creato manualmente, modificando l'impostazione binaria predefinita di 20 del server di Exchange, verrà visualizzato un avviso di configurazione non predefinita. Per impostazione predefinita il valore MaxSearchBlockSize del Registro di sistema non viene creato durante l'installazione di Exchange Server. Tuttavia, il valore MaxSearchBlockSize del Registro di sistema può essere creato manualmente dopo l'installazione del server di Exchange per modificare il valore. Il valore MhelpsBlockSize consente di impostare il numero massimo di ricerche del classificatore che possono essere inviate insieme come ricerca LDAP singola. Se si imposta il numero massimo di ricerche del classificatore, è possibile semplificare i filtri di ricerca per il classificatore.

Questo processo consente di inviare nuovamente le ricerche in sospeso su nuove connessioni. Se il valore viene creato manualmente e l'impostazione del valore del Registro di sistema non è configurata correttamente, possono verificarsi problemi nel trasporto dei messaggi.

Si consiglia di creare o modificare il valore MaxSearchBlockSize del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari di Exchange Server sono stati accuratamente selezionati per garantire prestazioni ottimali per l'utilizzo nella maggior parte degli ambienti Exchange Server. Generalmente la soluzione ottimale è di affrontare la causa del problema anziché modificare il comportamento predefinito di Exchange Server configurando manualmente il Registro di sistema. Per attenersi alle indicazioni, se esiste il valore MaxSearchBlockSize del Registro di sistema, è possibile eliminarlo per consentire a Exchange Server di ripristinare l'impostazione binaria predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia è possibile modificare il Registro di sistema per ripristinare il valore predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di apportare modifiche al Registro di sistema, accertarsi di poter eseguire il ripristino in caso di problemi. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Fare clic su Start, Esegui, digitare Regedit, quindi fare clic su OK.

  2. Nella struttura della console individuare la seguente chiave del Registro di sistema e fare clic su di essa: HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore MaxSearchBlockSize del Registro di sistema. Modificare il valore impostandolo su 20.

  4. In alternativa, nel riquadro dei dettagli è possibile fare clic con il pulsante destro del mouse sul valore MaxSearchBlockSize del Registro di sistema, quindi su Elimina. Per confermare l'eliminazione del valore del Registro di sistema, fare clic su Sì nella finestra di dialogo.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema di Microsoft Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Valore SMTP TopoRecheckSecs del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se è stata modificata e impostata su un valore diverso da quello predefinito:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeDSAccess\TopoRecheckSecs.

Se Exchange Server Analyzer rileva che il valore di TopoRecheckSecs non corrisponde a quello predefinito di 900 secondi, verrà visualizzato un messaggio di configurazione non predefinita. In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione. Poiché DSAccess utilizza il valore TopoRecheckSecs del Registro di sistema per impostare l'intervallo di ricostruzione dell'elenco del catalogo globale, un'impostazione non corretta può causare un calo di prestazione. Si consiglia di utilizzare le impostazioni di configurazione predefinite per Exchange Server quando possibile. Tuttavia, se il valore è presente, può essere stato aggiunto e configurato su consiglio del Servizio Supporto Tecnico Clienti Microsoft per correggere un errore precedente. Si consiglia di rimuovere il valore a meno che non sia stato aggiunto e configurato su consiglio del Servizio Supporto Tecnico Clienti Microsoft o di altri esperti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per eliminare la chiave TopoRecheckSecs del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\MSExchangeDSAccess

  3. Nel riquadro destro individuare ed eliminare il valore TopoRecheckSecs.

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere permanente la modifica, riavviare il Supervisore sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'accesso alla directory, consultare Understanding and Troubleshooting Directory Access all'indirizzo http://go.microsoft.com/fwlink/?LinkId=39012 (informazioni in lingua inglese).


Server gateway non di Exchange non impostato come SmartHost
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-09

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per il valore attributo distingushedName della classe oggetto protocolCfgSMTPServer per elencare tutte le istanze del server virtuale SMTP (Simple Mail Transfer Protocol) sul gateway di Exchange specificato dall'utente.

Exchange Server Analyzer esegue quindi una query in Active Directory per il valore degli attributi msExchSourceBridgeheadServersDN e routingList per ciascun oggetto msExchRoutingSMTPConnector rilevato per determinare se in un connettore SMTP è stata impostata correttamente una delle istanze del server virtuale SMTP rilevate come relativo server testa di ponte su uno spazio indirizzo SMTP esterno.

Infine, Exchange Server Analyzer esegue una query in Active Directory per determinare il valore dell'attributo msExchSmtpSmartHost su tutti i connettori SMTP rilevati (oggetto msExchRoutingSMTPConnector) per determinare se un connettore è stato designato come SmartHost per il server gateway non di Exchange definito dall'utente.

Se Exchange Server Analyzer determina che il server gateway non di Exchange definito dall'utente non è impostato come SmartHost per un connettore SMTP, in Exchange Server Analyzer verrà visualizzato un avviso.

L'avviso indica che non è stato impostato alcun instradamento esplicito dal server gateway di Exchange definito dall'utente al server gateway non di Exchange definito dall'utente e che i server diversi dai gateway non di Exchange potrebbero instradare inavvertitamente i messaggi all'esterno dell'organizzazione.

Per risolvere il problema, designare il server gateway non di Exchange come SmartHost per un connettore SMTP.

Per visualizzare e configurare le impostazioni dello SmartHost

  1. Aprire il Gestore di sistema di Exchange.

  2. Espandere Server, quindi espandere un server di Exchange e Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP, ad esempio Server virtuale SMTP predefinito, e scegliere Proprietà.

  4. Selezionare la scheda Generale e fare clic su Avanzate.

  5. Immettere lo SmartHost che si desidera utilizzare. È possibile identificare lo SmartHost tramite il nome di dominio completo oppure tramite un indirizzo IP. Se si utilizza un indirizzo IP, è necessario racchiuderlo tra parentesi quadre ([ ]). In Exchange viene verificato prima il nome server, poi l'indirizzo IP. Le parentesi consentono di identificare il valore come un indirizzo IP. La ricerca DNS viene pertanto ignorata.

  6. In un server che esegue Exchange 2000 Server, è possibile selezionare la casella di controllo Tenta recapito diretto prima di inviare a SmartHost.

  7. Fare clic su OK per salvare le modifiche, quindi fare di nuovo clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulla modalità di configurazione di un connettore SmartHost consultare l'articolo 821911 della Microsoft Knowledge Base "Come configurare Exchange Server 2003 per l'utilizzo di un indirizzo IP SmartHost" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821911.

Per ulteriori informazioni sull'utilizzo dei connettori SMTP, vedere l'articolo 294736 della Microsoft Knowledge Base "Creazione dei connettori SMTP in Exchange 2000 e versioni successive" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736.

Per ulteriori informazioni sui connettori SMTP, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Possibile sovraccarico del classificatore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer che eseguono Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dai contatori di prestazioni Cat: Messaggi inoltrati/sec e Cat: Categorizzazioni completate/sec dell'oggetto prestazioni SMTP Server per analizzare i dati sulle prestazioni.

Il contatore di prestazioni Cat: Messaggi inoltrati/sec indica il numero di messaggi inoltrati al secondo al classificatore mentre Cat: Categorizzazioni completate/sec indica la percentuale di categorizzazioni completate al secondo.

Exchange Server Analyzer confronta il totale medio dei due contatori per determinare se più messaggi vengono regolarmente inoltrati piuttosto che elaborati.

Se Exchange Server Analyzer determina che il numero totale medio di messaggi inoltrati al secondo al classificatore supera regolarmente di due messaggi il numero totale medio di messaggi completati al secondo, verrà visualizzato un avviso.

Il classificatore esegue le seguenti operazioni principali:

  • Risolve e convalida tutti i destinatari.

  • Determina i limiti e le restrizioni per tutti i destinatari.

  • Espande le liste di distribuzione, se richiesto.

  • Determina se il messaggio è per il recapito locale o remoto.

Questo avviso indica che il classificatore potrebbe essere sovraccarico. È opportuno ricercare le possibili cause e trovare una soluzione al problema.

Il sovraccarico del classificatore può essere causato da una richiesta di elaborazione di un numero elevato di messaggi:

  • Messaggi di posta elettronica commerciale (UCE, Unsolicited Commercial Email) non richiesti o posta indesiderata.

  • Proliferazione di virus.

  • Problemi di prestazioni del server.

Per risolvere il problema:

  • Determinare se il sovraccarico del classificatore è previsto oppure è atipico. Se si tratta di un carico previsto, rivedere le informazioni relative alle prestazioni di Exchange reperibili negli articoli di Microsoft TechNet.

    • "Risoluzione dei problemi relativi alle prestazioni di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588.

    • "Manuale relativo alle prestazioni e alla scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Se il sovraccarico del classificatore è imprevisto, verificare se il carico generato dipende da eventuali attacchi di virus o da posta indesiderata.


Possibile problema gateway
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-09

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova a un account definito dall'utente dal server su cui è in esecuzione Exchange Server, quindi esegue l'analisi dei registri di verifica messaggi del server per determinare se sono stati rilevati problemi nel recapitare il messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query nella proprietà EntryType della classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_MessageTrackingEntry nello spazio dei nomi root\MicrosoftExchangeV2 per determinare la causa della creazione di una o più voci del registro di verifica messaggi.

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • È possibile eseguire correttamente l'analisi del registro di verifica messaggi.

  • Il messaggio di prova non è stato trasferito correttamente fuori dalla coda.

  • Non è stato generato un rapporto di mancato recapito (NDR, Non-Delivery Report).

  • Esiste un valore 1034 per la proprietà EntryType.

  • Il messaggio ha raggiunto il server gateway di Exchange in uscita locale specificato.

Questo errore potrebbe indicare che si è verificato un problema di connessione tra il server gateway di Exchange in uscita locale specificato dall'utente e il server remoto.

Per risolverlo utilizzare l'utilità NSlookup in modo da riconsiderare eventuali problemi con la risoluzione DNS (Domain Name System). Per problemi di connessione e di protocollo, ad esempio errori di tipo "Host irraggiungibile", utilizzare Telnet.exe per tentare di connettersi al computer di destinazione. Per correggere errori di protocollo, aumentare il livello di registrazione diagnostica del servizio MSExchangeTransport relativo al componente SMTP (Simple Mail Transfer Protocol) e verificare la presenza di errori nei registri. In alternativa è possibile utilizzare lo strumento Network Monitor (Netmon.exe) per ottenere informazioni sugli errori di connessione in rete.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Possibile problema Inetinfo
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool include un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatore di prestazioni in computer che eseguono Exchange 2000 Server o Exchange Server 2003. Il motore raccoglie i dati dal contatore di prestazioni Cat: Classificazioni in corso dell'oggetto prestazioni SMTP Server per l'analisi dei dati sulle prestazioni.

Il contatore di prestazioni Cat: Classificazioni in corso indica il numero di classificazioni in corso.

Per questa query, Exchange Server Analyzer recupera un esempio ogni 6 secondi in un periodo di due minuti. Il valore medio del contatore di prestazioni viene restituito durante l'intervallo di raccolta.

Se Exchange Server Analyzer rileva che il numero minimo di classificazioni in corso nel periodo di esempio non è mai uguale a zero, verrà visualizzato un avviso.

Il classificatore esegue le seguenti operazioni principali:

  • Risolve e convalida tutti i destinatari.

  • Determina i limiti e le restrizioni per tutti i destinatari.

  • Espande le liste di distribuzione, se richiesto.

  • Determina se il messaggio è per il recapito locale o remoto.

Se il carico sul server non è elevato, l'avviso potrebbe indicare che è presente un blocco critico nel processo Inetinfo.exe o nelle risorse che dipendono da tale processo.

Il servizio SMTP (Simple Mail Transfer Protocol) viene eseguito nel processo Inetinfo.exe e quando i messaggi passano nel sottosistema di trasporto, SMTP utilizza in modo intensivo le risorse ISS (Internet Information Services).

Si verifica un blocco critico quando due o più processi o thread attendono il reciproco completamento prima che il processo possa continuare. Ne risulta un'interruzione o blocco della risposta di tutti i processi o thread. In un blocco critico, l'esecuzione dei processi non viene mai completata e le risorse di sistema vengono occupate. Questa situazione impedisce l'avvio di altri processi.

Per risolvere il problema:

  • Determinare se il carico sul classificatore è di tipo previsto o tipico. Se il carico sul classificatore non è elevato, utilizzare le risorse menzionate nella sezione "Ulteriori informazioni" per identificare possibili problemi di prestazioni nel processo Inetinfo.exe o nelle risorse correlate.

  • Verificare se il processo Inetinfo.exe è avviato e in esecuzione.

  • Verificare se è presente una situazione di blocco critico del processo Inetinfo.exe seguendo le istruzioni di debug nell'articolo 919791 della Microsoft Knowledge Base "Come utilizzare lo strumento di diagnostica di debug per risolvere il problema di utilizzo elevato della CPU da parte di un processo in IIS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791.

Per ulteriori informazioni

Per ulteriori informazioni sul processo Inetinfo.exe, vedere "Internet Information Services" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72966.

Per ulteriori informazioni sulla risoluzione dei problemi di blocco critico dei processi, vedere l'articolo 919791 della Microsoft Knowledge Base "Come utilizzare lo strumento di diagnostica di debug per risolvere il problema di utilizzo elevato della CPU da parte di un processo in IIS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=919791.

Per ulteriori informazioni sulle prestazioni di Exchange Server, vedere il Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle prestazioni di Exchange Server, vedere "Troubleshooting Microsoft Exchange Server Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).


Possibile problema non gateway
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-09

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova a un indirizzo SMTP del destinatario esterno definito dall'utente dal server che esegue Exchange Server, quindi esegue l'analisi dei registri di verifica messaggi del server per determinare se sono stati rilevati problemi nel recapitare il messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query nella proprietà EntryType della classe Microsoft WMI (Strumentazione gestione Windows®) Exchange_MessageTrackingEntry nello spazio dei nomi root\MicrosoftExchangeV2 per determinare la causa della creazione di una o più voci del registro di verifica messaggi.

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • È possibile eseguire correttamente l'analisi del registro di verifica messaggi.

  • Il messaggio di prova non è stato trasferito correttamente fuori dalla coda.

  • Non è stato generato un rapporto di mancato recapito.

  • Esiste un valore 1034 per la proprietà EntryType.

  • Il messaggio non ha raggiunto il server gateway di Exchange in uscita locale specificato.

L'errore può indicare che il messaggio di prova è ancora presente in una delle code di recapito remoto SMTP del server di invio e che si è verificato un problema ad essa relativo.

Una coda di recapito remoto trattiene i messaggi destinati al recapito remoto. Il nome della coda corrisponde alla destinazione del recapito remoto. Tale destinazione può essere un connettore, un server o un dominio.

Per correggere gli errori di protocollo, aumentare il livello di registrazione diagnostica per il servizio MSExchangeTransport relativo al componente SMTP, quindi analizzare il registro alla ricerca di errori. In alternativa è possibile utilizzare lo strumento Network Monitor (Netmon.exe) per ottenere informazioni sugli errori di connessione in rete. Per riprodurre il problema, può essere necessario imporre alla coda un nuovo tentativo. Esaminare il registro eventi alla ricerca di possibili errori associati al servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Rilevato possibile proxy SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-12-06

Microsoft® Exchange Server Analyzer Tool tenta di inviare un messaggio all'account Postmaster o a un account definito dall'utente per il dominio SMTP (Simple Mail Transfer Protocol).

La risposta predefinita che segue è prevista quando Exchange Server Analyzer stabilisce una connessione socket al server SMTP:

"220 Nome computer . Nome dominio .com Microsoft ESMTP MAIL Service, Versione: Numero versione pronto il Data Ora +0000"

Se Exchange Server Analyzer riceve una risposta non predefinita contenente una stringa specifica per terze parti verrà visualizzato un errore.

L'errore indica la possibile esistenza di un server proxy SMTP di terze parti in esecuzione dietro al server remoto.

Se il banner SMTP predefinito non è stato personalizzato intenzionalmente dall'amministratore di Exchange Server, l'avviso può indicare che Exchange Server si trova dietro a un proxy SMTP che filtra i comandi estesi SMTP di Exchange Server (ESMTP; Extended Simple Mail Transfer Protocol).

Se i comandi ESMTP di Exchange Server vengono filtrati, le prestazioni di Exchange possono risentirne e si può verificare il comportamento descritto nell'articolo 320027 della Microsoft Knowledge Base "Non è possibile inviare o ricevere messaggi di posta elettronica da dietro un firewall Cisco PIX" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=320027.

Per ulteriori informazioni sui banner SMTP personalizzati consultare l'articolo seguente della Microsoft Knowledge Base:

  • 281224: XCON: How to Modify the SMTP Banner, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=281224.


Potenziale problema di prestazioni del classificatore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Microsoft Windows®) ExchangeLink per determinare il valore dell'attributo TypePendingCategorization dell'istanza SMTP (Simple Mail Transfer Protocol) ProtocolName e individuare il numero di messaggi nella coda SMTP Messaggi in attesa dell'individuazione della directory (MADL, Messages Awaiting Directory Lookup).

Le proprietà della classe WMI ExchangeLink restituiscono informazioni sui collegamenti di gestione dei messaggi o code tra i server di posta. Un collegamento può contenere zero o più oggetti ExchangeQueue. Il numero dipende dal traffico di messaggi corrente nel collegamento.

Exchange Server Analyzer include inoltre un motore di raccolta dei dati relativi alle prestazioni utilizzato per eseguire query sugli oggetti contatori di prestazioni su computer con Exchange Server 2000 o Exchange Server 2003.

Se Exchange Server Analyzer determina che sono presenti più di cinquanta messaggi nella coda MADL, il motore di raccolta dei dati relativi alle prestazioni raccoglierà i dati dai contatori di prestazioni Cat: Messaggi classificati e Cat: Classificazioni completate dell'oggetto prestazioni SMTP Server per l'analisi dei dati sulle prestazioni.

Il contatore di prestazioni Cat: Messaggi classificati indica il numero di messaggi inoltrati nella coda mentre il contatore Cat: Classificazioni completate indica il numero totale dei messaggi completati inoltrati al classificatore.

Il classificatore esegue le seguenti operazioni principali:

  • Risolve e convalida tutti i destinatari.

  • Determina i limiti e le restrizioni per tutti i destinatari.

  • Espande le liste di distribuzione, se richiesto.

  • Determina se il messaggio è per il recapito locale o remoto.

Exchange Server Analyzer esamina la media totale dei due contatori per determinare se i numeri aumentano durante il periodo di esempio.

Se si verificano le seguenti condizioni, verrà visualizzato un errore:

  • Sono presenti almeno cinquanta messaggi nella coda MADL.

  • Il contatore di prestazioni Cat: Messaggi classificati visualizza un aumento nel periodo di esempio che indica il progresso del passaggio di messaggi inoltrati al processo successivo.

  • Il contatore di prestazioni Cat: Classificazioni completate visualizza un aumento nel periodo di esempio che indica il progresso del completamento della classificazione dei messaggi inoltrati.

L'errore indica che, sebbene il classificatore elabori i messaggi correttamente, la lunghezza della coda rimane elevata e le prestazioni potrebbero risentirne.

Le prestazioni del classificatore potrebbero essere influenzate da una richiesta di elaborazione di numerosi messaggi per i motivi seguenti:

  • Messaggi di posta elettronica pubblicitari non richiesti (UCE) o spam.

  • Proliferazione di virus.

  • Problemi di prestazioni del server.

Per risolvere il problema:

  • Determinare se il sovraccarico del classificatore è previsto oppure è atipico. Se si tratta di un carico previsto, consultare le informazioni relative alle prestazioni di Exchange nelle risorse di Exchange indicate di seguito:

    • "Troubleshooting Exchange Server 2003 Performance" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47588 (informazioni in lingua inglese).

    • "Manuale sulle prestazioni e la scalabilità di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.

  • Se il sovraccarico del classificatore è imprevisto, verificare se il carico generato dipende da eventuali attacchi di virus o da posta indesiderata.


Rilevati potenziali problemi di espansione dei gruppi di distribuzione
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se sul server Exchange è in esecuzione Exchange Server 2003 Service Pack 2 (SP2) e se è configurato per espandere i gruppi di distribuzione quando verifica le limitazioni relative al recapito:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters\RestrictionMethod

  • Il valore 1 per questa voce indica che il server è configurato per espandere i gruppi di distribuzione quando verifica le limitazioni relative al recapito.

  • Il valore 2 per questa voce indica che il server è configurato per non espandere i gruppi di distribuzione quando verifica le limitazioni relative al recapito.

Se Exchange Server Analyzer rileva che il server è impostato per espandere i gruppi di distribuzione quando verifica le limitazioni relative al recapito, vengono controllati i registri eventi del server per scoprire se si sono verificati eventi di errore 6004, 6006 e 6008 nelle precedenti 24 ore.

Tali eventi indicano che i messaggi sono stati intercettati nel classificatore dei messaggi. Il classificatore dei messaggi è un componente del motore di accodamento avanzato che invia query LDAP al server di catalogo globale per l'esecuzione di ricerche nelle directory.

Infine, Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare quanto segue:

  • Se nella foresta sono presenti più di 500 cassette postali con impostate limitazioni relative al recapito, in modo che venga usato almeno un gruppo di distribuzione per consentire o impedire mittenti.

  • Se un connettore di un gruppo di routing presenta limitazioni relative al recapito in base all'appartenenza al gruppo di distribuzione e se sul server Bridgehead è abilitato il controllo delle restrizioni dei connettori.

  • Se un connettore SMTP presenta limitazioni relative al recapito in base all'appartenenza a gruppi di distribuzione e se sul server Bridgehead è abilitato il controllo delle restrizioni dei connettori.

Se si verificano le seguenti condizioni, verrà visualizzato un errore:

  • Il server Exchange Server 2003 SP2 è configurato per espandere i gruppi di distribuzione quando verifica le limitazioni relative al recapito.

  • Il server Exchange ha registrato eventi 6004, 6006 e 6008 nelle ultime 24 ore.

  • Nella foresta sono presenti più di 500 cassette postali con impostate limitazioni relative al recapito, in modo che venga usato almeno un gruppo di distribuzione per consentire o impedire mittenti, oppure è presente un connettore di un gruppo di routing con limitazioni relative al recapito in base all'appartenenza a gruppi di distribuzione e sul server testa di ponte è abilitato il controllo delle restrizioni dei connettori, oppure un connettore SMTP presenta limitazioni relative al recapito in base all'appartenenza a gruppi di distribuzione e sul server testa di ponte è abilitato il controllo delle restrizioni dei connettori.

Il valore RestrictionMethod determina l'elaborazione delle restrizioni da parte del classificatore. Il comportamento predefinito del classificatore prevede l'espansione ricorsiva dei gruppi di distribuzione e la verifica delle restrizioni per ogni messaggio che passa nel sistema. Se un messaggio di posta elettronica viene inviato a un destinatario configurato con una restrizione che rifiuta i messaggi da membri di un preciso gruppo di distribuzione o di protezione, è necessaria l'espansione di tale gruppo per assicurarsi che il mittente non sia un membro del gruppo con restrizioni. I risultati di questa espansione del gruppo non vengono memorizzati nella cache da Exchange Server, pertanto l'operazione deve essere eseguita ogni volta. In tal modo i messaggi vengono trattenuti nelle code del classificatore e l'elaborazione dei messaggi può subire ritardi.

Se si imposta il valore di RestrictionMethod su 2, i componenti di trasporto nel server di Exchange non espanderanno l'appartenenza ai gruppi di distribuzione quando nel server vengono verificate le restrizioni. Questa configurazione fornisce le migliori prestazioni per le verifiche delle restrizioni. Inoltre, per rendere effettiva la voce RestrictionMethod del Registro di sistema, è necessario che tutti i gruppi di distribuzione in cui sono inclusi utenti con restrizioni di recapito siano di tipo semplice. Ovvero, i gruppi di distribuzione con restrizioni non devono essere nidificati. In caso contrario, la logica di espansione non funzionerà.

Per i gruppi di distribuzione utilizzati nelle restrizioni per il connettore, si consiglia di impostare il valore della voce RestrictionMethod del Registro di sistema in un server testa di ponte del connettore privo di cassette postali. Per le restrizioni per gli utenti di Active Directory, se i gruppi di distribuzione con restrizioni dispongono di server di espansione, si consiglia di creare la voce RestrictionMethod del Registro di sistema in tali server.

Per ulteriori informazioni su cosa si verifica quando vengono configurate le limitazioni relative al recapito, vedere l'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

Per ulteriori informazioni sul valore RestrictionMethod del Registro di sistema, consultare l'articolo 895407 della Microsoft Knowledge Base "In Exchange Server 2003 il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto dopo la configurazione delle restrizioni di recapito in base ai gruppi di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

Per ulteriori informazioni su errori ed eventi di Exchange Server 2003, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258.

Per ulteriori informazioni sulle restrizioni dei connettori, vedere l'articolo 277872 della Microsoft Knowledge Base "XCON: Le Restrizioni di recapito del connettore potrebbero non funzionare correttamente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.

Per ulteriori informazioni sulle code SMTP, consultare l'articolo 884996 della Microsoft Knowledge Base "I messaggi restano nella coda SMTP "Messaggi in attesa dell'individuazione della directory" in Exchange Server 2003 o in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=884996.


Rilevati potenziali problemi nel destinatario diario dei messaggi
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se si sono verificate alcune delle seguenti combinazioni di avvisi del classificatore/eventi di errore nelle ultime 24 ore:

  • Eventi 9004 e 9003

  • Eventi 9035 e 6004

Tali eventi indicano che i messaggi sono stati intercettati nel classificatore dei messaggi. Il classificatore dei messaggi è un componente del motore di accodamento avanzato che invia query LDAP al server di catalogo globale per l'esecuzione di ricerche nelle directory.

  • Exchange Server Analyzer esegue inoltre una query al servizio directory Active Directory® per determinare se si verifica una della seguenti condizioni:

  • Il destinatario diario designato di un archivio fa riferimento a un oggetto eliminato.

  • Il destinatario diario designato di un archivio fa riferimento a un oggetto che non dispone di un mailNickname valido.

  • Il destinatario diario designato di un archivio fa riferimento a un account disabilitato.

Se si verificano le seguenti condizioni, verrà visualizzato un errore:

  • Si è verificata una delle combinazioni di eventi di errore/avviso elencate in precedenza.

  • Si è anche verificata una delle condizioni del destinatario diario designato.

Tale errore indica che si è verificato un potenziale problema con l'inserimento nel diario nell'ambiente Exchange, che potrebbe provocare l'accodamento dei messaggi.

Per informazioni sulla risoluzione di questo problema, vedere l'articolo specifico di Exchange Server Analyzer che fa riferimento al problema:

  • La destinazione dell'inserimento nel diario fa riferimento a un oggetto eliminato

  • Il destinatario diario non è valido

  • Il destinatario diario fa riferimento a un account disabilitato

  • Per informazioni su errori ed eventi di Exchange Server 2003, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258.


Rilevati potenziali problemi relativi al servizio di archiviazione e all'inserimento nel diario dei messaggi
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se si è verificato l'evento di avviso del classificatore 9004 nelle ultime 24 ore.

Exchange Server Analyzer esegue inoltre una query alla classe WMI Win32_Service per determinare se il servizio Archivio informazioni di Microsoft Exchange (MSExchangeIS) è stato avviato o arrestato. Un valore diverso da Started per l'istanza MSExchangeIS significa che il servizio MSExchangeIS è stato arrestato.

Se si verificano le seguenti condizioni, verrà visualizzato un errore:

  • Il server ha registrato l'evento di avviso del classificatore 9003 nelle ultime 24 ore.

  • Il servizio MSExchangeIS è stato arrestato.

Tale errore indica che si è verificato un problema con l'inserimento nel diario dei messaggi o con il servizio Archivio informazioni di Microsoft Exchange (Store.exe) che può causare l'accodamento dei messaggi.

Questo problema può presentarsi se si verifica una delle seguenti condizioni:

  • L'oggetto destinatario diario è stato eliminato dal servizio directory Active Directory®.

  • Il servizio Archivio informazioni non è in esecuzione o è stato disabilitato nel computer Exchange Server che funge da server testa di ponte SMTP.

  • Uno o più archivi di cassette postali nel server testa di ponte SMTP sono disinstallati.

Per risolvere questo problema:

  • Assicurarsi che nel server testa di ponte SMTP il servizio Archivio informazioni sia abilitato e in esecuzione. Assicurarsi che gli archivi di cassette postali presenti nel server testa di ponte SMTP siano installati.

  • Assicurarsi che l'oggetto destinatario diario degli archivi di cassette postali non sia stato eliminato da Active Directory.

Per determinare il destinatario diario di un archivio di cassette postali

  1. Avviare Gestore di sistema di Exchange.

  2. Espandere la struttura Server, espandere la struttura del <server di Exchange>, espandere la struttura <Gruppo di archiviazione>, quindi fare clic con il pulsante destro sull'archivio delle cassette postali e selezionare Proprietà.

  3. Nella scheda Generale visualizzare l'account immediatamente sotto la casella di controllo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio. Questo account verrà utilizzato come destinatario diario.

    Nota:
    Assicurarsi di verificare il destinatario diario per ciascun oggetto archivio di cassette postali.
Per nominare una nuova cassetta postale dell'utente come destinatario diario

  1. Avviare Gestore di sistema di Exchange.

  2. Espandere la struttura Server, espandere la struttura del <server di Exchange>, espandere la struttura <Gruppo di archiviazione>, quindi fare clic con il pulsante destro sull'archivio delle cassette postali e selezionare Proprietà.

  3. Nella scheda Generale fare clic su Sfoglia alla destra del testo Archivia messaggi inviati/ricevuti dalle cassette postali di questo archivio per specificare una cassetta postale di inserimento nel diario.

    Nota:
    Tutti i messaggi inseriti nel diario per i mittenti presenti in questo archivio di cassette postali verranno inviati alla cassetta postale specificata.

Per informazioni su questo argomento vedere La destinazione dell'inserimento nel diario fa riferimento a un oggetto eliminato.

Per ulteriori informazioni su errori ed eventi di Exchange Server 2003, vedere il "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258.

Per ulteriori informazioni sulla modalità di distribuzione di una soluzione di inserimento nel diario, vedere "Journaling with Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


Potenziali problemi di autorizzazione rilevati
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se si sono verificati i seguenti eventi di errore di Exchange Server nelle ultime 24 ore:

  • Evento 929.

  • Evento 9035.

  • Combinazione degli eventi 9003, 9004 e 6004.

L'evento di errore 929 di Exchange Server si può verificare a causa di autorizzazioni di accesso non corrette negli oggetti Exchange Server nel servizio directory Active Directory®.

Gli eventi di errore di Exchange Server 9003, 9004 e 6004 indicano che i messaggi sono stati intercettati nel classificatore dei messaggi. Il classificatore dei messaggi è un componente del motore di accodamento avanzato che invia query LDAP al server di catalogo globale per l'esecuzione di ricerche nelle directory.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare se gli attributi degli oggetti relativi a Exchange indicano che si sono verificati problemi di ereditarietà delle autorizzazioni in tali oggetti.

Se si verificano le seguenti condizioni, verrà visualizzato un errore:

  • Uno dei seguenti eventi o combinazione di eventi è stato connesso nelle ultime 24 ore a un server che dispone di messaggi accodati nella coda Messaggi in attesa dell'individuazione della directory:

    • Evento 929.

    • Evento 9035.

    • Combinazione degli eventi 9003, 9004 e 6004.

  • Gli oggetti correlati a Exchange hanno autorizzazioni di accesso mancanti o non corrette.

Questo errore indica che si sono verificati problemi di ereditarietà delle autorizzazioni nell'ambiente Exchange che possono causare l'accodamento della posta.

Per risolvere questo problema, seguire la procedura descritta nell'articolo 907969 della Microsoft Knowledge Base "L'ID evento 929 è connesso e la posta non viene recapitata da un server di posta a un altro in un'organizzazione di Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=907969.

Per ulteriori informazioni su errori ed eventi di Exchange Server 2003, vedere "Centro eventi e messaggi di errore" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258.


Cartella pubblica identificata come destinazione comune
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-04

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Queue per determinare i valori dei seguenti attributi per le code SMTP del server virtuale SMTP.

LinkId | Indica l'identificatore del collegamento che contiene la coda.
QueueId | Indica l'identificatore della coda.
QueueName | Indica il nome della coda.
VirtualMachine | Indica il nome del computer virtuale che contiene la coda.
VirtualServerName | Indica il nome del server virtuale su cui si trova la coda.
MessageCount | Indica il numero di messaggi nella coda.

In Exchange Server Analyzer vengono utilizzate le informazioni ottenute qui per eseguire una query nella classe WMI Exchange_QueuedSMTPMessage per determinare i valori dei seguenti attributi dei messaggi nella coda:

Recipients | Indica i destinatari del messaggio.
Received | Indica il timestamp del messaggio ricevuto.
MessageId | Indica l'identificatore del messaggio in coda.
StateRetry | Indica un nuovo tentativo di trasmissione di un messaggio non recapitato correttamente.

Infine, i dati ottenuti da Microsoft® Exchange Server Analyzer vengono utilizzati per eseguire una query nel servizio directory di Active Directory® per determinare il valore di distinguishedName per ciascun oggetto Recipient. Quindi viene determinato se il destinatario è un utente, un gruppo di distribuzione, una cartella pubblica o un archivio delle cartelle pubbliche.

Se Exchange Server Analyzer determina che almeno il 25% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a una cartella pubblica specifica, verrà visualizzato un avviso.

Se Exchange Server Analyzer determina che almeno il 50% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a una cartella pubblica specifica, verrà visualizzato un errore.

L'avviso o l'errore indica che la cartella pubblica identificata è una destinazione comune per i messaggi bloccati in una coda SMTP.

Per risolvere il problema è necessario ricercare nella cartella pubblica problemi di configurazione o altre anomalie che possono causare un accodamento dei messaggi destinati ad esso. Per eseguire l'operazione procedere come segue:

  • Assicurarsi che gli attributi dell'oggetto cartella pubblica siano impostati correttamente e contengano i valori corretti in Active Directory.

  • Esaminare che le impostazioni delle autorizzazioni di Active Directory per l'oggetto cartella pubblica siano corrette.

  • Ricercare eventuali messaggi di posta elettronica pubblicitari non richiesti, spam o attacchi virus alla cartella pubblica.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.


Archivio delle cartelle pubbliche identificato come destinazione comune
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-04

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Queue per determinare i valori dei seguenti attributi per le code SMTP del server virtuale SMTP.

LinkId | Indica l'identificatore del collegamento che contiene la coda.
QueueId | Indica l'identificatore della coda.
QueueName | Indica il nome della coda.
VirtualMachine | Indica il nome del computer virtuale che contiene la coda.
VirtualServerName | Indica il nome del server virtuale su cui si trova la coda.
MessageCount | Indica il numero di messaggi nella coda.

In Exchange Server Analyzer vengono utilizzate le informazioni ottenute qui per eseguire una query nella classe WMI Exchange_QueuedSMTPMessage per determinare i valori dei seguenti attributi dei messaggi nella coda:

Recipients | Indica i destinatari del messaggio.
Received | Indica il timestamp del messaggio ricevuto.
MessageId | Indica l'identificatore del messaggio in coda.
StateRetry | Indica un nuovo tentativo di trasmissione di un messaggio non recapitato correttamente.

Infine, i dati ottenuti da Microsoft® Exchange Server Analyzer vengono utilizzati per eseguire una query nel servizio directory di Active Directory® per determinare il valore di distinguishedName per ciascun oggetto Recipient. Quindi viene determinato se il destinatario è un utente, un gruppo di distribuzione, una cartella pubblica o un archivio delle cartelle pubbliche.

Se Exchange Server Analyzer determina che almeno il 25% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a destinatari le cui cassette postali si trovano nello stesso archivio delle cartelle pubbliche, verrà visualizzato un avviso.

Se Exchange Server Analyzer determina che almeno il 50% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a destinatari le cui cassette postali si trovano nello stesso archivio delle cartelle pubbliche, verrà visualizzato un errore.

L'avviso o l'errore indica che l'archivio delle cartelle pubbliche identificato è una destinazione comune per i messaggi bloccati in una coda SMTP.

Per risolvere il problema è necessario ricercare nell'archivio delle cartelle pubbliche problemi di configurazione o altre anomalie che possono causare un accodamento dei messaggi destinati ad esso. Per eseguire l'operazione procedere come segue:

  • Assicurarsi che gli attributi dell'oggetto archivio siano impostati correttamente e contengano i valori corretti in Active Directory.

  • Esaminare che le impostazioni delle autorizzazioni di Active Directory per l'oggetto archivio siano corrette.

  • Ricercare eventuali messaggi di posta elettronica pubblicitari non richiesti, spam o attacchi virus alla cartella pubblica.

  • Controllare eventuali modifiche della gerarchia delle cartelle pubbliche o del contenuto che potrebbero generare un gran numero di repliche tra gli archivi delle cartelle pubbliche.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 842273 della Microsoft Knowledge Base sulla risoluzione dei problemi di replica delle cartelle pubbliche in Exchange 2000 Server ed Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=842273.


Il filtro destinatari è abilitato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se la proprietà msExchServerBindingsFiltering di un oggetto server virtuale SMTP (Simple Mail Transfer Protocol) indica che il filtro destinatari è abilitato per un'istanza del server virtuale SMTP.

Exchange Server Analyzer Tool esegue inoltre una query in Active Directory per determinare se la proprietà msExchRecipTurfListNames o msExchRecipTurfListOptions indica che il filtro destinatari è abilitato anche al livello delle impostazioni globali.

Se Exchange Server Analyzer Tool rileva che il filtro destinatari è abilitato sia a livello dell'istanza del server virtuale SMTP sia al livello delle impostazioni globali, verrà visualizzato un avviso.

Questo avviso indica che il filtro destinatari è correttamente abilitato. Normalmente il filtro destinatari non rappresenta un problema. Tuttavia, se è in corso la risoluzione di problemi relativi al flusso di posta su questo server specifico, può essere necessario verificare la configurazione del filtro o disabilitare temporaneamente il filtro destinatari per determinare se stia bloccando in modo errato la posta inviata a destinatari validi.

Per disabilitare un filtro destinatari in un server virtuale SMTP

  1. Avviare il Gestore di sistema di Exchange: Fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nella struttura della console espandere Server, il server desiderato, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP sul quale si desidera disabilitare il filtro e scegliere Proprietà.

  4. Nella scheda Generale di Proprietà <SMTP Virtual Server> fare clic su Avanzate.

  5. In Avanzate selezionare l'indirizzo IP per il quale si desidera disabilitare il filtro, quindi fare clic su Modifica.

In Identificazione deselezionare la casella di controllo Applica filtro destinatario per disabilitare il filtro.

  1. Se si dispone di più server virtuali, ripetere i passaggi da 3 a 6 per ogni server virtuale in cui si desidera disabilitare il filtro.

Per ulteriori informazioni su come configurare i filtri destinatari, vedere l'articolo 823866 della Microsoft Knowledge Base, "Configurazione del filtro connessioni affinché utilizzi elenchi RBL (Realtime Block List) e del filtro destinatari in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823866.

Per ulteriori informazioni sul Filtro messaggi intelligente, vedere il sito Web del Filtro messaggi intelligente di Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).


La coda Recapito remoto è bloccata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateFrozen per la coda SMTP Recapito remoto.

Se Exchange Server Analyzer rileva che il valore della chiave StateFrozen per la coda Recapito remoto in un server Exchange è impostato su True, viene visualizzato un errore.

Se una coda risulta bloccata, le sessioni di trasporto dirette a questa coda vengono arrestate. Una coda bloccata impedisce l'invio dei messaggi in uscita, anche se è possibile aggiungere nuovi messaggi. È possibile modificare manualmente lo stato di una connessione utilizzando il menu di scelta rapida in ciascuna coda di collegamento. Se viene utilizzato il comando Imponi connessione per modificare lo stato di una coda su Attiva, viene immediatamente abilitata una connessione che invia messaggi da tale coda.

La coda Recapito remoto trattiene i messaggi destinati al recapito remoto. Il nome della coda corrisponde alla destinazione del recapito remoto. Tale destinazione può essere un connettore, un server o un dominio.

Per risolvere questo errore, utilizzare l'utilità NSlookup per rivedere possibili problemi della risoluzione DNS (Domain Name System). Per problemi di connessione e di protocollo come errori di tipo "Host irraggiungibile", usare Telnet.exe per cercare di connettersi al computer di destinazione. Per correggere errori di protocollo, aumentare il livello di registrazione diagnostica per il servizio MSExchangeTransport relativo al componente del protocollo SMTP, quindi analizzare il registro alla ricerca di errori. In alternativa è possibile utilizzare lo strumento Network Monitor (Netmon.exe) per ottenere informazioni sugli errori di connessione in rete. Per riprodurre il problema, può essere necessario imporre alla coda un nuovo tentativo. Esaminare il registro eventi alla ricerca di possibili errori associati al servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La coda Recapito remoto si trova in stato Riprova
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) ExchangeLink per determinare il valore della chiave StateRetry per la coda SMTP Recapito remoto.

Se Exchange Server Analyzer rileva che il valore della chiave StateRetry per la coda Recapito remoto in un server Exchange è impostato su True, verrà visualizzato un errore.

Se una coda è nello stato Riprova, tale stato indica che si è verificato almeno un errore nei precedenti tentativi di elaborare i messaggi nella coda. È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione . In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

La coda Recapito remoto trattiene i messaggi destinati al recapito remoto. Il nome della coda corrisponde alla destinazione del recapito remoto. Tale destinazione può essere un connettore, un server o un dominio.

Per risolvere questo errore, utilizzare l'utilità NSlookup per rivedere possibili problemi della risoluzione DNS (Domain Name System). Per problemi di connessione e di protocollo come errori di tipo "Host irraggiungibile", usare Telnet.exe per cercare di connettersi al computer di destinazione. Per correggere errori di protocollo, aumentare il livello di registrazione diagnostica per il servizio MSExchangeTransport relativo al componente del protocollo SMTP, quindi analizzare il registro alla ricerca di errori. In alternativa è possibile utilizzare lo strumento Network Monitor (Netmon.exe) per ottenere informazioni sugli errori di connessione in rete. Per riprodurre il problema, può essere necessario imporre alla coda un nuovo tentativo. Esaminare il registro eventi alla ricerca di possibili errori associati al servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Problema della coda "Recapito remoto"
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange all'account Postmaster oppure a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi relativi al recapito del messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query alla proprietà EntryType per la classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio nomi root\MicrosoftExchangeV2 per determinare cosa ha causato la creazione della voce del registro di verifica messaggi.

Se si verificano le seguenti condizioni, verrà visualizzato un errore:

  • È possibile eseguire correttamente l'analisi del registro di verifica messaggi.

  • Il messaggio di prova non è stato trasferito correttamente fuori dalla coda.

  • Non è stato generato un rapporto di mancato recapito (NDR, Non Delivery Report).

  • È rilevato un valore di 1034 per la proprietà EntryType.

Questo errore indica che il messaggio di prova è ancora in una delle code SMTP Recapito remoto per il server di invio e che si è verificato un problema con la coda.

Una coda Recapito remoto trattiene i messaggi destinati al recapito remoto. Il nome della coda corrisponde alla destinazione del recapito remoto. Tale destinazione può essere un connettore, un server o un dominio.

Per risolvere questo errore, utilizzare l'utilità NSlookup per rivedere possibili problemi della risoluzione DNS (Domain Name System). Per problemi di connessione e di protocollo come errori di tipo "Host irraggiungibile", usare Telnet.exe per cercare di connettersi al computer di destinazione. Per correggere errori di protocollo, aumentare il livello di registrazione diagnostica per il servizio MSExchangeTransport relativo al componente del protocollo SMTP, quindi analizzare il registro alla ricerca di errori. In alternativa è possibile utilizzare lo strumento Network Monitor (Netmon.exe) per ottenere informazioni sugli errori di connessione in rete. Per riprodurre il problema, può essere necessario imporre alla coda un nuovo tentativo. Esaminare il registro eventi alla ricerca di possibili errori associati al servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Ritentare la categorizzazione
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange all'account Postmaster o a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi relativi al recapito del messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query alla proprietà EntryType per la classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio nomi root\MicrosoftExchangeV2 per determinare la causa della voce del registro di verifica messaggi.

Se Exchange Server Analyzer rileva un valore di 1032 per la proprietà EntryType, viene visualizzato un avviso.

L'avviso indica che il messaggio di prova si trova in una coda pianificata per un nuovo tentativo di categorizzazione. Se una coda è nello stato Riprova, tale stato indica che si è verificato almeno un errore nei precedenti tentativi di elaborare i messaggi nella coda. È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione . In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

Generalmente, i messaggi si accumulano nella coda in attesa di un nuovo tentativo perché il motore di accodamento avanzato non è in grado di classificare il messaggio. Il motore di accodamento avanzato potrebbe non essere in grado di accedere ai server di catalogo globale e alle informazioni sul destinatario oppure i server di catalogo globale non sono raggiungibili od offrono prestazioni scadenti. Inoltre, i messaggi possono accumularsi per i seguenti motivi:

  • Active Directory non è disponibile.

    Nota:
    Il classificatore utilizza Active Directory per classificare i messaggi.
  • Active Directory potrebbe avere un carico troppo elevato se sono presenti molti messaggi nella coda di pre-categorizzazione.

  • Si è verificato un errore durante la conversione. Il classificatore gestisce anche la conversione del contenuto.

  • Il classificatore dei messaggi non riesce a trovare gli archivi di cassette postali.

  • Se il protocollo SMTP è stato reinstallato o rimosso, potrebbero risultare invalidate le seguenti chiavi della metabase IIS: /smtpsvc/DsUseCat e /smtpsvc/vsi#/DsUseCat.

    Nota:
    Determinare se il protocollo SMTP è stato reinstallato o rimosso.

Se una coda si trova in stato "Riprova", esaminare le proprietà della coda per determinare la causa. Ad esempio, se nelle proprietà della coda viene visualizzato un messaggio che indica "Si è verificato un errore SMTP", è necessario rivedere i registri evento del server per individuare tutti gli errori SMTP. Se non sono presenti eventi nel registro, è necessario aumentare il livello di registrazione del protocollo SMTP.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Ritentare il recapito locale
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-04

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange all'account Postmaster oppure a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi relativi al recapito del messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query alla proprietà EntryType per la classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio dei nomi root\MicrosoftExchangeV2 per determinare cosa ha causato la creazione della voce del registro di verifica messaggi.

Se viene rilevato un valore di 1037 per la proprietà EntryType, verrà visualizzato un avviso.

L'avviso indica che si è verificato almeno un errore nei tentativi precedenti di elaborazione del messaggio nella coda Recapito locale.

La coda Recapito locale contiene messaggi accodati nel server Exchange per il recapito locale a un archivio cassette postali o un archivio delle cartelle pubbliche di Exchange Server.

I messaggi possono accumularsi nella coda se il server Exchange non accetta messaggi per il recapito locale. Un recapito lento o intermittente potrebbe indicare un loop di messaggi o un problema di prestazioni.

È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione. In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

Per correggere questo errore, aumentare il livello di registrazione diagnostica per i componenti dell'unità di archiviazione SMTP del servizio MSExchangeIS e MSExchangeTransport.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi relativi alle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Ritentare il routing
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange all'account Postmaster o a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi relativi al recapito del messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query alla proprietà EntryType per la classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio dei nomi root\MicrosoftExchangeV2 per determinare la causa della voce del registro di verifica messaggi.

Se Exchange Server Analyzer rileva un valore di 1035 per la proprietà EntryType, verrà visualizzato un avviso.

L'avviso indica che il messaggio di prova si trova in una coda pianificata per un nuovo tentativo di routing. Se una coda è nello stato Riprova, tale stato indica che si è verificato almeno un errore nei precedenti tentativi di elaborare i messaggi nella coda. È possibile modificare lo stato delle code da Riprova o Pianificata ad Attiva mediante il comando Imponi connessione . In questo modo, la coda funzionerà come se fosse trascorso l'intervallo tra due tentativi o fosse stata raggiunta l'ora pianificata. Tuttavia, questo metodo potrebbe non funzionare sempre.

Nota:
Le proprietà di una coda possono indicare un motivo specifico per il quale una coda si trova in stato Riprova.

I messaggi si accumulano nelle code in attesa di un nuovo tentativo se si verificano problemi di routing di Exchange Server. I messaggi non sono stati instradati a causa di un errore temporaneo, ovvero il motore di routing non è stato inizializzato correttamente. I messaggi si trovano nella coda di pre-routing in attesa di un nuovo tentativo o in corso di reinstradamento.

Per correggere questo errore, aumentare la registrazione diagnostica per il servizio MSExchangeTransport per raccogliere informazioni sul componente della categoria di routing. Disabilitare le restrizioni dei connettori non necessarie, poiché tali restrizioni possono causare un notevole peggioramento delle prestazioni del server. Può essere necessario attivare la chiave CheckConnectorRestrictions del Registro di sistema per alcune restrizioni.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Le ricerche DNS inverse sono state abilitate nella metabase ma non nel server SMTP associato in Active Directory
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge la seguente proprietà nella metabase IIS (Internet Information Services) per determinare se il valore della proprietà corrisponde al valore configurato per l'attributo msExchSmtpPerformReverseDnsLookup nel servizio directory di Active Directory®:

/LM/SmtpSvc/<SMTP virtual server instance>/EnableReverseDnsLookup

Se Exchange Server Analyzer rileva una discrepanza tra i valori, verrà visualizzato un avviso.

Se il valore nella metabase IIS non corrisponde al valore in Active Directory, si può trattare di un problema della replica di Active Directory oppure di un problema del componente DS2MB (Directory-service-to-Metabase-replication) in Exchange.

La funzione del processo DS2MB è quella di trasferire le informazioni di configurazione da Active Directory alla metabase locale. Questa configurazione è archiviata nella metabase locale invece che nel Registro di sistema, per motivi di prestazioni e scalabilità. In Exchange 2000 Server ed Exchange Server 2003 tutti i protocolli Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) vengono eseguiti come componenti di IIS.

Ogni 15 minuti il processo DS2MB copia le intere sottostrutture di Active Directory senza modificare la forma della sottostruttura. È una scrittura unidirezionale da Active Directory nella metabase. La metabase non scrive mai in Active Directory.

Sia la proprietà EnableReverseDnsLookup che l'attributo msExchSmtpPerformReverseDnsLookup possono essere impostati sul valore TRUE o FALSE. Il valore impostato su TRUE indica che il server virtuale SMTP eseguirà ricerche DNS inverse su tutti i messaggi in arrivo. Il valore impostato su FALSE indica che non saranno eseguite ricerche DNS inverse. A causa della possibile riduzione delle prestazioni dovuta a record DNS non configurati correttamente o a connessioni intermittenti a Internet, la proprietà EnableReverseDnsLookup e l'attributo msExchSmtpPerformReverseDnsLookup sono impostati su FALSE per impostazione predefinita.

Se la proprietà EnableReverseDnsLookup è impostata su TRUE (abilitata) e l'attributo msExchSmtpPerformReverseDnsLookup su FALSE (disabilitato), significa che Active Directory e la metabase IIS non sono sincronizzati. Se il problema è provocato da un errore del processo DS2MB, è possibile risolverlo seguendo la procedura indicata di seguito per la versione di Exchange Server in uso. Se il problema è provocato da un errore parziale o completo della replica di Active Directory, è possibile utilizzare l'utilità Monitoraggio replica di Active Directory (ReplMon.exe) per controllare l'integrità e lo stato della replica di Active Directory. È possibile trovare ReplMon.exe in Strumenti di supporto di Windows® nel CD di Windows Server.

Per risolvere il problema in Exchange Server 2003

  1. Verificare la presenza di voci nel registro eventi applicazioni con origine MSExchangeMU. Se si verifica un errore di DS2MB, verrà registrato un evento in Exchange Server 2003.

  2. Se non si notano errori di DS2MB, utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  3. Se si sono verificati errori di DS2MB oppure dopo aver eliminato o risolto un problema della replica di Active Directory riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per risolvere il problema su Exchange 2000 Server

  1. Utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  2. Dopo aver eliminato o risolto problemi della replica di Active Directory, riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario in Exchange, consultare l'articolo 297412 della Microsoft Knowledge Base, "L'opzione 'Esegui ricerca DNS al contrario sui messaggi in arrivo' viene utilizzata per la risoluzione del nome host" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare gli articoli della Microsoft Knowledge Base 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686 e 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sulla replica di Active Directory, consultare l'articolo 232072 della Microsoft Knowledge Base "Inizializzazione della replica tra partner di replica diretta in Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072.

Per ulteriori informazioni sul processo DS2MB, consultare l'articolo 240105 della Microsoft Knowledge Base "XGEN: Informazioni generali sulla sincronizzazione della metabase e del servizio directory in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105.


Motore di routing: parametro AttachedTimeout non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la procedura di routing del connettore SMTP (Simple Mail Transfer Protocol) è stata modificata rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\AttachedTimeout

Se Exchange Server Analyzer rileva che la chiave AttachedTimeout del Registro di sistema è presente e configurata su un valore maggiore di 300, verrà visualizzato un messaggio di configurazione non predefinita.

La voce AttachedTimeout del Registro di sistema è un'impostazione di configurazione personalizzata di Exchange Server che determina la frequenza di invio del pacchetto ORG_INFO. Ogni volta che il client di routing non si connette a un server di routing, la versione utente della topologia viene incrementata e provoca la trasmissione del pacchetto ORG_INFO in tutta l'organizzazione.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Eliminare la chiave AttachedTimeout del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore AttachedTimeout del Registro di sistema, consultare l'articolo 832281 della Knowledge Base, "Stato del collegamento e routing in Exchange 2000 Server and in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832281.


Motore di routing: parametro BestAddressMatchOnly non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la procedura di routing del connettore SMTP (Simple Mail Transfer Protocol) è stata modificata rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\BestAddressMatchOnly

Se Exchange Server Analyzer rileva che la chiave BestAddressMatchOnly del Registro di sistema è presente e configurata con un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

La voce BestAddressMatchOnly del Registro di sistema è un'impostazione di configurazione personalizzata di Exchange Server che consente di imporre l'instradamento della posta inviata a un dominio specifico mediante un determinato connettore, indipendentemente dalle restrizioni esistenti.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Eliminare la chiave BestAddressMatchOnly del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Motore di routing: parametro CheckConnectorRestrictions non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la procedura di routing del connettore SMTP (Simple Mail Transfer Protocol) è stata modificata rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\CheckConnectorRestrictions

Se Exchange Server Analyzer rileva che la chiave del Registro di sistema CheckConnectorRestrictions è presente e configurata con un valore superiore a 0, verrà visualizzato un messaggio di configurazione non predefinita.

La voce CheckConnectorRestrictions del Registro di sistema è un'impostazione di configurazione personalizzata di Exchange Server che consente di abilitare la verifica delle restrizioni sul server testa di ponte di Exchange che rappresenta l'origine del connettore per cui viene eseguita la verifica. Per impostazione predefinita, la verifica delle restrizioni dei connettori viene disattivata poiché può influenzare in modo significativo le prestazioni, in particolare nelle configurazioni in cui si utilizzano molti gruppi di distribuzione. La verifica delle restrizioni verrà eseguita per ogni messaggio inviato ai membri di ciascun gruppo di distribuzione che passa attraverso il sistema. Se le restrizioni sono specificate ma la voce del Registro di sistema non esiste, la verifica delle restrizioni non verrà eseguita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Eliminare la chiave CheckConnectorRestrictions del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema.

  5. Riavviare il servizio Amministrazione IIS.

  6. Sulla scheda del connettore Restrizioni di recapito riabilitare l'opzione delle restrizioni.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore CheckConnectorRestrictions del Registro di sistema, consultare l'articolo 277872 della Microsoft Knowledge Base "XCON: Le Restrizioni di recapito del connettore potrebbero non funzionare correttamente" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=277872.


Motore di routing: il parametro di configurazione non è predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'intervallo di lettura del servizio directory di Active Directory® per la rimozione degli indici del database non utilizzati è stato modificato rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RESvc\Parameters\ReloadOsInterval

Se Exchange Server Analyzer rileva che i dati del valore di ReloadOsInterval sono impostati su un numero diverso da 3600, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore ReloadOsInterval viene utilizzato per specificare l'intervallo in base al quale le informazioni sullo stato di collegamento del routing vengono aggiornate tra i server che eseguono Exchange. Le informazioni sullo stato di collegamento del routing consentono a ciascun server di determinare la route a costo più basso per il recapito dei messaggi e di verificare il funzionamento dei connettori che costituiscono la route. Per impostazione predefinita, le informazioni sullo stato del collegamento vengono lette da Active Directory a intervalli di 3.600 secondi, ovvero ogni ora.

In alcune circostanze, le informazioni sullo stato del routing potrebbero non essere propagate correttamente tra i server all'interno di un'organizzazione di Exchange. Alcuni server dell'organizzazione, pertanto, potrebbero continuare a funzionare con informazioni errate o non aggiornate sullo stato del routing. Di conseguenza, quando si visualizza un gruppo di routing remoto utilizzando lo strumento WinRoute (Winroute.exe), è possibile che i nuovi connettori non vengano visualizzati. L'utilizzo dello strumento WinRoute consente di verificare che le informazioni sullo stato del collegamento vengano propagate correttamente. Per eseguire questa operazione, utilizzare lo strumento WinRoute per visualizzare le informazioni sullo stato del collegamento da diverse posizioni all'interno dell'organizzazione di Exchange, quindi confrontare i numeri di versione di ciascun gruppo di routing. Lo strumento WinRoute si connette alla porta dello stato del collegamento su un computer Exchange Server e ne estrae le informazioni per l'organizzazione di Exchange. Sebbene le informazioni sullo stato del collegamento siano costituite da una serie di identificatori univoci globali (GUID), i GUID dei connettori e dei server testa di ponte vengono associati a ciascun oggetto Active Directory e le informazioni vengono presentate in un formato leggibile.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SYSTEM\CurrentControlSet\Services\RESvc\Parameters

  3. Nel riquadro destro fare doppio clic su ReloadOsInterval.

  4. Nella casella Dati valore digitare 3600, quindi fare clic su OK.

  5. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul routing e sulle informazioni sullo stato del collegamento, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 842026, "Le informazioni sullo stato del routing non vengono propagate correttamente a tutti i server in Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=842026.

  • 285130, "XCON: Informazioni sullo stato dei collegamenti" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=285130.

Per scaricare WinRoute, uno strumento che consente di determinare le informazioni sullo stato del collegamento note al server di routing master, consultare "Exchange Server WinRoute" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25049.


Motore di routing: parametro PollingInterval non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la procedura di routing del connettore SMTP (Simple Mail Transfer Protocol) è stata modificata rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\PollingInterval

Se Exchange Server Analyzer rileva che la chiave del Registro di sistema PollingInterval è presente e configurata con un valore superiore a 300, verrà visualizzato un messaggio di configurazione non predefinita.

La voce del Registro di sistema PollingInterval è un'impostazione di configurazione personalizzata per Exchange Server che consente di controllare la frequenza del traffico dello stato del collegamento tra i gruppi di routing, in particolare il traffico in direzione e quello proveniente dal master del gruppo di routing all'interno di un gruppo di routing. L'aumento di questa impostazione impedisce gli errori di connessione ma può impedire di risolvere il problema ben più grave dei collegamenti lenti tra i membri di un gruppo di routing.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Eliminare la chiave PollingInterval del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Motore di routing: parametro StateChangeDelay non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la procedura di routing del connettore SMTP (Simple Mail Transfer Protocol) è stata modificata rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\StateChangeDelay

Se Exchange Server Analyzer rileva che la chiave del Registro di sistema StateChangeDelay è presente e configurata con un valore superiore a 0, verrà visualizzato un messaggio di configurazione non predefinita.

La voce StateChangeDelay del Registro di sistema è un'impostazione di configurazione personalizzata per Exchange Server che consente di controllare l'intervallo di tempo in cui i connettori vengono contrassegnati come non disponibili, nonché le notifiche generate in seguito a modifiche dello stato del server e del connettore. Se la voce StateChangeDelay è impostata su un valore maggiore di 0, un server può essere contrassegnato come disponibile o non disponibile solo una volta per ogni intervallo di tempo impostato da questo valore.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Eliminare la chiave StateChangeDelay del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema.

  5. Per rendere effettiva la modifica, riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Motore di routing: parametro SuppressStateChanges non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la procedura di routing del connettore SMTP (Simple Mail Transfer Protocol) è stata modificata rispetto all'impostazione predefinita:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters\SuppressStateChanges

Se Exchange Server Analyzer rileva che la chiave SuppressStateChanges del Registro di sistema è presente e configurata con un valore maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Exchange Server 2003 include una funzionalità che consente di rilevare automaticamente le variazioni dello stato di un collegamento. Queste informazioni possono essere utilizzate per comunicare agli altri server che eseguono Exchange Server 2003 di utilizzare una route alternativa invece della route principale con il costo più basso. Le informazioni sullo stato dei collegamenti sono suddivise in variazioni di lieve e di grande entità: una variazione di grande entità si verifica quando l'amministratore modifica la topologia di routing, ad esempio, tramite l'aggiunta di un nuovo connettore o la modifica del costo. Una variazione di lieve entità, invece, si verifica quando l'errore viene rilevato automaticamente dal sistema o quando viene ripristinato un collegamento.

Questa funzione offre ottimi risultati nelle organizzazioni di piccole o di medie dimensioni. Tuttavia, negli ambienti di grandi dimensioni con più siti, le fluttuazioni della rete possono provocare sovraccarichi di aggiornamenti dei collegamenti per la versione secondaria. Per essere davvero effettivi, i dati sullo stato dei collegamenti devono essere trasmessi a tutti i server dell'organizzazione. Inoltre, quando si modifica lo stato, l'intera tabella di stato dei collegamenti viene ritrasmessa. Questo può provocare la trasmissione di una quantità notevole di dati sulla rete. In questo tipo di scenario, potrebbe essere utile eliminare le variazioni dello stato dei collegamenti di lieve entità. La voce SuppressStateChanges del Registro di sistema è un'impostazione di configurazione personalizzata per eliminare le variazioni dello stato dei collegamenti di lieve entità. Se la voce SuppressStateChanges viene impostata su un valore maggiore di 0, tutte le variazioni dello stato dei collegamenti sul computer Exchange Server verranno eliminate.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\RESvc\Parameters

  3. Eliminare la chiave SuppressStateChanges del Registro di sistema.

  4. Chiudere l'editor del Registro di sistema.

  5. Riavviare i servizi SMTP (Simple Mail Transfer Protocol), Microsoft Exchange - Motore di routing e Microsoft Exchange - Stack Agente di trasferimento messaggi per rendere effettiva la modifica.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla chiave SuppressStateChanges del Registro di sistema, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Manuale sulle prestazioni e la scalabilità di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47576.


Connettore del gruppo di routing con restrizioni di recapito ai gruppi di distribuzione impostate
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool esegue una query nei seguenti attributi per ciascun oggetto connettore del gruppo di routing (msExchRoutingGroupConnector) rilevato nel servizio directory di Active Directory® per determinare se le restrizioni relative al recapito sono impostate in base all'appartenenza al gruppo di distribuzione.

dLMemRejectPerms | Contiene i nomi di dominio (DN) delle liste di distribuzione (DL) i cui membri potrebbero non utilizzare questo connettore del gruppo di routing per l'invio di messaggi.
dLMemSubmitPerms | Contiene i nomi di dominio (DN) delle liste di distribuzione (DL) i cui membri potrebbero utilizzare questo connettore del gruppo di routing per l'invio di messaggi.

Se Exchange Server Analyzer determina che sono presenti connettori del gruppo di routing con restrizioni relative al recapito impostate in base all'appartenenza al gruppo di distribuzione, verrà visualizzato un avviso.

Tale avviso indica che le restrizioni di recapito basate sull'appartenenza a gruppi di distribuzione potrebbero influire sulle prestazioni del flusso di posta di Exchange.

Quando un messaggio di posta viene inviato utilizzando i connettori del gruppo di distribuzione con restrizioni relative al recapito basate sull'appartenenza al gruppo di distribuzione, il classificatore di messaggi espande l'appartenenza del gruppo di distribuzione, ottiene l'elenco completo dei DN dei membri e confronta l'elenco dei DN con i DN dei mittenti. Quando un DN corrisponde in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

Per risolvere il problema:

  • Impostare un gruppo di routing dedicato per le restrizioni dei connettori e configurarlo su un gruppo di routing locale come menzionato nell'articolo 329171 della Microsoft Knowledge Base "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • Utilizzare un server di catalogo globale dedicato e più affidabile come server testa di ponte designato per il connettore.

  • Configurare cassette postali individuali e non gruppi di distribuzione per le restrizioni di recapito come menzionato nell'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

  • Implementare il filtro mittente SMTP (Simple Mail Transfer Protocol).

  • Per i server che eseguono Exchange Server 2003 Service Pack 2 (SP2) o una versione successiva, implementare la verifica delle restrizioni non gerarchica. Per i server che eseguono una versione precedente a Exchange 2003 SP2, è consigliabile eseguire l'aggiornamento a Exchange 2003 SP2.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sul filtro mittenti SMTP, consultare "Configurazione del filtro mittenti" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72967.

Per ulteriori informazioni sull'effetto della restrizione relativa al gruppo di distribuzione sul flusso di posta di Exchange Server 2003, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 329171 "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • 895407 "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949 "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.


Il server principale del gruppo di routing è stato eliminato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchRoutingMasterDN per ogni contenitore del gruppo di routing. Se Exchange Server Analyzer rileva che il valore dell'attributo msExchRoutingMasterDN contiene la stringa "DEL:", verrà visualizzato un messaggio di errore.

L'attributo msExchRoutingMasterDN è un attributo a valore singolo che consente di archiviare il nome distinto del computer Exchange Server utilizzato come master del gruppo di routing per ciascun gruppo di routing. La presenza della stringa "DEL:" può indicare che il precedente master del gruppo di routing è stato eliminato utilizzando lo strumento Utenti e computer di Active Directory. Senza il master del gruppo di routing, Exchange non sarà in grado di aggiornare correttamente o mantenere la topologia di routing.

Quando si crea un gruppo di routing, al primo server in quel gruppo viene assegnato il ruolo di master del gruppo di routing. Il master del gruppo di routing conserva le informazioni sullo stato corrente del collegamento per il proprio gruppo di routing e le propaga agli altri server all'interno del gruppo. Il master del gruppo di routing controlla la configurazione di routing scritta in Active Directory solo per il proprio gruppo di routing. I server membri possono comunicare al master del gruppo di routing qualunque informazione relativa allo stato del connettore o alla disponibilità del server. Ad esempio, se un server membro prova a contattare un altro server in un diverso gruppo di routing tramite un connettore ma il collegamento non è disponibile, il server membro informa immediatamente il master del gruppo di routing. Allo stesso modo, quando un server non master riceve informazioni sullo stato di un nuovo collegamento, trasferisce immediatamente le informazioni sullo stato del connettore al master del gruppo di routing, in modo che gli altri server possano ricevere informazioni sulla modifica del routing.

Per risolvere il problema

  1. In Gestore di sistema di Exchange, in Gruppi amministrativi, espandere Administrative_Group, quindi Gruppi di routing.

  2. Espandere il gruppo di routing, quindi fare clic su Membri.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse sul computer Exchange da configurare come master del gruppo di routing, quindi scegliere Imposta come master.

Per ulteriori informazioni sui master del gruppo di routing, consultare "Configurazione della topologia di routing" in Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47579.


Errore di appartenenza al gruppo di routing
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per ciascun valore dell'attributo msExchRoutingGroupMembersBL sugli oggetti Routing Group per determinare se il server di back-link appartiene al gruppo amministrativo Microsoft Exchange Server 2007 dedicato, Gruppo amministrativo di Exchange (FYDIBOHF23SPDLT).

Exchange Server Analyzer esegue inoltre una query nel valore dell'attributo CN per l'oggetto Routing Group per determinare se il valore equivale a quello predefinito per il gruppo di routing di Exchange 2007, Gruppo di routing di Exchange (DWBGZMFD01QNBJR).

Verrà visualizzato un errore se si verificano le condizioni riportate di seguito:

  • Il server di back-link appartiene al gruppo amministrativo Exchange 2007 dedicato, Gruppo amministrativo di Exchange (FYDIBOHF23SPDLT).

  • Il gruppo di routing non corrisponde a quello predefinito di Exchange 2007, Gruppo di routing di Exchange (DWBGZMFD01QNBJR).

Questo errore indica che il server potrebbe essere stato spostato manualmente dal gruppo di routing predefinito di Exchange 2007. È possibile che l'operazione abbia causato problemi di routing.

Microsoft Exchange Server 2003 e Microsoft Exchange 2000 Server utilizzano gruppi di routing per definire una topologia di routing specifica per Exchange. Exchange 2007 utilizza i siti Active Directory per definire la relativa topologia di routing. Exchange 2003 ed Exchange 2000 utilizzano una topologia di routing basata su connettori e gruppi di routing. In un'organizzazione Exchange 2007 pura non è più necessaria una configurazione di routing specifica per Exchange, in quanto viene utilizzata la topologia del sito Active Directory per determinare la relativa topologia di routing.

Per supportare la coesistenza tra queste due topologie di routing, tutti i server Exchange 2007 vengono aggiunti automaticamente a un singolo gruppo di routing durante l'installazione di Exchange 2007. Il gruppo di routing di Exchange 2007 viene riconosciuto nel Gestore di sistema di Exchange in Exchange 2003 o in Exchange 2000 come Gruppo di routing di Exchange (DWBGZMFD01QNBJR) all'interno del Gruppo amministrativo di Exchange (FYDIBOHF23SPDLT).

Per risolvere il problema spostare i server di Exchange 2007 nel gruppo di routing dedicato di Exchange 2007 oppure rimuovere e reinstallare il server.


Connettore di invio disabilitato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-07-30

Microsoft Exchange Analyzer Tool utilizza il seguente cmdlet di Exchange Management Shell per eseguire una query su tutti i connettori di invio nell'ambiente Exchange con valore dell'attributo Enabled impostato su False. Il valore False per l'attributo Enabled del connettore di invio indica che il connettore di invio è disabilitato.

Get-SendConnector | where { $_.Enabled -eq $False}

Exchange Server Analyzer esegue inoltre una query nel servizio directory di Active Directory per determinare il valore dell'attributo serialNumber per tutti gli oggetti con una classe oggetto di msExchExchangeServer.

Se il valore della stringa include "Version 5.5", sul computer è in esecuzione Microsoft Exchange Server 5.5. Se il valore della stringa include Version 6.0, sul computer è in esecuzione Exchange 2000 Server. Se il valore della stringa include "Version 6.5", sul computer è in esecuzione Exchange Server 2003. Se il valore della stringa include "Version 8", sul computer è in esecuzione Exchange Server 2007.

Se Exchange Analyzer determina che un connettore di invio è disabilitato in un ambiente Exchange in cui sono utilizzati anche server Exchange 2000 o Exchange 2003, verrà visualizzato un messaggio di errore.

L'errore indica che mentre il routing di Exchange 2007 ignora i connettori di invio disabilitati, Exchange 2000 ed Exchange 2003 non riconoscono il contrassegno disabilitato per il connettore ed è probabile che continuino a instradare i messaggi attraverso il connettore, con conseguenti loop di routing.

Per risolvere il problema, eliminare i connettori di invio disabilitati negli ambienti Exchange che eseguono Exchange 2000 o Exchange 2003.

Per eliminare un connettore di invio disabilitato, seguire le istruzioni per l'utilizzo del cmdlet Remove-SendConnector di Exchange Management Shell contenute nell'argomento "Remove-SendConnector" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=96007 nella documentazione del prodotto di Exchange Server 2007.


Filtro mittente abilitato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se la proprietà msExchServerBindingsTurflist di un oggetto del server virtuale SMTP indica che il filtro mittente è abilitato per un'istanza del server virtuale SMTP.

Exchange Server Analyzer Tool esegue inoltre una query in Active Directory per determinare se la proprietà msExchTurfListNames o msExchTurfListOptions indica che il filtro mittente è abilitato anche al livello delle impostazioni globali.

Se si verificano le seguenti condizioni, verrà visualizzato un avviso:

  • Il filtro mittente è abilitato per l'istanza del server virtuale SMTP.

  • Il filtro mittente è abilitato a livello delle impostazioni globali.

L'avviso indica che il filtro mittente è correttamente abilitato. Normalmente il filtro mittente non rappresenta un problema a meno che non si stia risolvendo problemi relativi al flusso di posta in questo server specifico. In questo caso, può essere necessario verificare la configurazione del filtro o disabilitare temporaneamente il filtro ID mittente per determinare se sta erroneamente bloccando la posta legittima proveniente da mittenti validi.

Per disabilitare un filtro mittente in un server virtuale SMTP

  1. Avviare il Gestore di sistema di Exchange: Fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nella struttura della console espandere Server, il server desiderato, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP sul quale si desidera disabilitare il filtro e scegliere Proprietà.

  4. Nelle Proprietà del <Server virtuale SMTP>, nella scheda Generale fare clic su Avanzate.

  5. In Avanzate selezionare l'indirizzo IP per il quale si desidera disabilitare il filtro, quindi fare clic su Modifica.

  6. In Identificazione deselezionare la casella di controllo Applica filtro mittente per disabilitare il filtro.

  7. Se si dispone di più server virtuali, ripetere i passaggi da 3 a 6 per ogni server virtuale in cui si desidera disabilitare il filtro.

Per ulteriori informazioni sul Filtro messaggi intelligente, vedere il sito Web del Filtro messaggi intelligente di Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).

Per ulteriori informazioni sulla configurazione del filtro e sul controllo della posta indesiderata, vedere "Configurazione dei filtri e controllo della posta indesiderata" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Filtro ID mittente abilitato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se la proprietà msExchServerBindingsFiltering di un oggetto del server virtuale SMTP indica che il filtro ID mittente è abilitato per un'istanza del server virtuale SMTP.

Microsoft® Exchange Server Analyzer Tool esegue una query in Active Directory® anche per determinare se l'attributo wWWHomePage dell'oggetto Filtro contenuti UCE contiene voci per l'ID mittente e il filtro connessioni.

Se si verificano le seguenti condizioni, verrà visualizzato un avviso:

  • Il filtro mittente è abilitato per l'istanza del server virtuale SMTP.

  • Il filtro mittente è abilitato a livello dell'oggetto Filtro contenuti UCE.

L'avviso indica che il filtro ID mittente è correttamente abilitato. Normalmente il filtro ID mittente non rappresenta un problema a meno che non si stia risolvendo problemi relativi al flusso di posta in questo server specifico. In questo caso, può essere necessario verificare la configurazione del filtro o disabilitare temporaneamente il filtro ID mittente per determinare se sta erroneamente bloccando la posta proveniente da mittenti validi.

Per disabilitare un filtro ID mittente in un server virtuale SMTP

  1. Avviare il Gestore di sistema di Exchange: Fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nella struttura della console espandere Server, il server desiderato, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP sul quale si desidera disabilitare il filtro e scegliere Proprietà.

  4. Nelle Proprietà del <Server virtuale SMTP>, nella scheda Generale fare clic su Avanzate.

  5. In Avanzate selezionare l'indirizzo IP per il quale si desidera disabilitare il filtro, quindi fare clic su Modifica.

  6. In Identificazione deselezionare la casella di controllo Applica filtro mittente per disabilitare il filtro.

  7. Se si dispone di più server virtuali, ripetere i passaggi da 3 a 6 per ogni server virtuale in cui si desidera disabilitare il filtro.

Per ulteriori informazioni sul Filtro messaggi intelligente, vedere il sito Web del Filtro messaggi intelligente di Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607 (informazioni in lingua inglese).


Server identificato come destinazione comune
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-04

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Queue per determinare i valori dei seguenti attributi per le code SMTP del server virtuale SMTP.

LinkId | Indica l'identificatore del collegamento che contiene la coda.
QueueId | Indica l'identificatore della coda.
QueueName | Indica il nome della coda.
VirtualMachine | Indica il nome del computer virtuale che contiene la coda.
VirtualServerName | Indica il nome del server virtuale su cui si trova la coda.
MessageCount | Indica il numero di messaggi nella coda.

In Exchange Server Analyzer vengono utilizzate le informazioni ottenute per eseguire una query nella classe WMI Exchange_QueuedSMTPMessage per determinare i valori dei seguenti attributi dei messaggi nella coda:

Recipients | Indica i destinatari del messaggio.
Received | Indica il time stamp del messaggio ricevuto.
MessageId | Indica l'identificatore del messaggio in coda.
StateRetry | Indica un nuovo tentativo di trasmissione di un messaggio non recapitato correttamente.

Infine, i dati ottenuti da Microsoft® Exchange Server Analyzer vengono utilizzati per eseguire una query nel servizio directory di Active Directory® per determinare i valori riportati di seguito per ciascun oggetto Destinatario. Quindi viene determinato se il destinatario è un utente, un gruppo di distribuzione, una cartella pubblica o un archivio delle cartelle pubbliche:

distinguishedName | Indica il nome distinto dell'oggetto.
msExchHomeServerName | Indica il server in cui si trova il destinatario.
homeMDB | Indica l'archivio delle cassette postali del destinatario.

Se Exchange Server Analyzer determina che almeno il 25% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a destinatari su un server particolare, verrà visualizzato un avviso.

Se Exchange Server Analyzer determina che almeno il 50% dei messaggi bloccati nella coda sono indirizzati, nel campo To: o Cc:, a destinatari su un server particolare, verrà visualizzato un errore.

L'avviso o l'errore indica che il server è identificato come destinazione comune per i messaggi bloccati in una coda SMTP.

Per risolvere il problema è necessario ricercare eventuali problemi di configurazione del server o altre anomalie che possono causare un accodamento dei messaggi destinati ad esso. Per eseguire l'operazione procedere come segue:

  • Assicurarsi che gli attributi dell'oggetto server siano impostati correttamente e contengano i valori corretti in Active Directory.

  • Esaminare che le impostazioni delle autorizzazioni di Active Directory per l'oggetto server siano corrette.

  • Se il server ospita un oggetto utente per uso speciale, ovvero un destinatario diario designato, esaminare che le configurazioni del servizio o dei componenti a cui è correlato l'oggetto utente siano corrette.

  • Ricercare eventuali messaggi di posta elettronica pubblicitari non richiesti, spam o attacchi virus alla cartella pubblica.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange Server, consultare gli articoli della Microsoft Knowledge Base sugli argomenti riportati di seguito:

  • 895407, relativo al recapito dei messaggi alle cassette postali locali ed esterne più lento del previsto in Exchange Server 2003 dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 329171, relativo al recapito della posta lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • 839949, relativo alla risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298, relativo al recapito della posta lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.


Registrazione sink non rilevata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-01-11

Microsoft® Exchange Server Analyzer Tool esegue una query nella metabase IIS (Internet Information Server) per enumerare l'elenco dei binding dei sink di evento di trasporto SMTP (Simple Mail Transport Protocol). Exchange Server Analyzer tenta di individuare un numero di binding sink di evento standard, in base a un elenco predefinito in Exchange Server Analyzer. Exchange Server Analyzer verifica i dettagli della registrazione COM (Component Object Model) per ciascun binding nel seguente ramo del Registro di sistema:

HKEY_CLASSES_ROOT\CLSID\

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un avviso:

  • È stato rilevato un binding di un sink di evento di trasporto nella metabase.

  • La registrazione COM corrispondente manca dal Registro di sistema.

Un evento di trasporto SMTP si verifica quando i dati dei messaggi vengono trasportati all'interno o al di fuori del servizio SMTP. Tutti i messaggi passano attraverso gli eventi. Sono inclusi i messaggi in arrivo o in uscita X.400 e RPC. Un esempio comune di evento di trasporto in ingresso è l'arrivo di un messaggio al servizio SMTP in rete o nella directory di prelievo SMTP. Quando si verifica questo evento di trasporto, un'origine dell'evento informa i sink di evento di trasporto, ciascuno dei quali può eseguire un tipo di operazione in base al contenuto dei dati del messaggio. Una volta che i dati sono stati passati al sink, non vengono eseguite altre operazioni con i dati dei messaggi fino a quando il sink completa l'operazione e restituisce il messaggio. Il sink ha il controllo esclusivo dei dati dei messaggi e dello stato nel corso dell'operazione.

La mancanza di registrazioni COM per i binding dei sink di evento di trasporto può causare problemi al flusso di posta. Se il server di Exchange presenta sintomi di problemi al flusso di posta, ad esempio l'accodamento dei messaggi, registrare nuovamente i sink di evento di trasporto.

Per registrare di nuovo i sink di evento di trasporto

  1. Dal server di Microsoft Exchange aprire una finestra del prompt dei comandi e passare alla cartella \Programmi\Exchsrvr\Bin.

  2. Digitare i seguenti comandi per registrare nuovamente i sink evento di trasporto:

    regsvr32 /i exps.dll

    regsvr32 /i miscat.dll

    regsvr32 /i onsubmit.dll

    regsvr32 /i peexch50.dll

    regsvr32 /i phatcat.dll

    regsvr32 /i protolog.dll

    regsvr32 /i reapi.dll

    regsvr32 /i regsinks.dll

    regsvr32 /i tranmsg.dll

    regsvr32 /i turflist.dll

    regsvr32 /i xlsasink.dll

    regsvr32 /i msgfilter.dll

  3. Eseguire nuovamente Exchange Server Analyzer per verificare che gli avvisi non vengano più visualizzati. Se gli avvisi continuano ad essere visualizzati e si verificano problemi nel flusso di posta, contattare il Servizio Supporto Tecnico Clienti Microsoft (PSS, Microsoft Product Support Services).

Per ulteriori informazioni sui binding dei sink di evento di trasporto, vedere le seguenti risorse di Exchange:

  • Articolo 258224 della Microsoft Knowledge Base, "XCON: Enumerazione dei sink di evento di trasporto registrati" all'indirizzo http://go.microsoft.com/fwlink/?linkID=3052&kbid=258224.

  • "Design del servizio SMTP" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=58876.


SmartHost impostato sul server virtuale SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se l'attributo msExchSmtpSmartHost è stato configurato su un server virtuale SMTP specifico. Se Exchange Server Analyzer rileva che l'attributo msExchSmtpSmartHost è stato configurato, verrà visualizzato un avviso.

Non è consigliabile configurare uno SmartHost su un server virtuale SMTP. In alternativa, è preferibile creare un connettore SMTP in cui configurare l'impostazione dello SmartHost.

In Exchange Server 2003, per configurare il recapito della posta Internet, è possibile utilizzare la Configurazione guidata posta Internet. Per ulteriori informazioni, consultare "How to Use Internet Mail Wizard" in Exchange Server Transport and Routing Guide all'indirizzo http://go.microsoft.com/fwlink/?LinkId=50099 (informazioni in lingua inglese).

Per ulteriori informazioni sulla creazione di connettori SMTP, consultare "How to Create an SMTP Connector" in Exchange Server Transport and Routing Guide all'indirizzo http://go.microsoft.com/fwlink/?LinkId=50100 (informazioni in lingua inglese).


Il valore SMTP AdditionalPoolThreadsPerProc del Registro di sistema è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se sono stati configurati manualmente thread di pool aggiuntivi:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\AdditionalPoolThreadsPerProc

Se Exchange Server Analyzer rileva la presenza e l'avvenuta configurazione di AdditionalPoolThreadsPerProc, verrà visualizzato un messaggio di configurazione non predefinita.

In SMTP sono disponibili cinque code di lavoro che utilizzano un pool di thread definiti thread ATQ. Strutturalmente, due di queste code possono utilizzare per impostazione predefinita fino al 90% dei thread disponibili. Questo pool di thread è condiviso dal processo che accetta richieste POP e IMAP. Pertanto, in uno scenario di carico da moderato a alto high, si può verificare una situazione in cui SMTP è in grado di mantenere le risorse da servizi POP e IMAP.

È possibile riservare thread adeguati per POP e IMAP limitando la percentuale di thread che possono essere utilizzati da SMTP. Per effettuare questa modifica, aumentare il numero dei thread disponibili per IIS. L'unico compromesso in questo caso è un maggiore utilizzo della memoria per i thread aggiuntivi.

Esistono due valori del Registro di sistema che consentono di controllare la percentuale SMTP dei thread e dei thread aggiuntivi per processore:

Posizione: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Valore: AdditionalPoolThreadsPerProc

Tipo: REG_DWORD

Posizione: HKLM\System\CurrentControlSet\Services\SMTPSVC\Parameters

Valore: MaxPercentPoolThreads

Tipo: REG_DWORD

È preferibile adeguare entrambi i valori del Registro di sistema in computer Exchange Server cluster, se un'elevata attività di SMTP provoca errori di POP3, IMAP4 o entrambe le risorse. È possibile utilizzare le formule indicate di seguito per calcolare il valore ottimale per il proprio cluster:

Valore del Registro di sistema | Formula
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * numero di server virtuali dei protocolli)

Ad esempio, in un cluster Exchange Server con due server virtuali dei protocolli, la formula per MaxPercentPoolThreads è 90 / (2*2) = 22. Quando si calcola il valore MaxPercentPoolThreads, se il risultato è un valore che include un punto decimale, è preferibile approssimare il risultato all'intero successivo. Quando si calcola il valore AdditionalPoolThreadsPerProc, se il risultato è un valore maggiore di 200, è necessario assegnare il valore risultante anche a un valore aggiuntivo di registro:

Posizione: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Valore: PoolThreadLimit

Tipo: REG_DWORD

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare l'impostazione ottimale nel cluster Exchange

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Creare un valore del Registro di sistema DWORD denominato AdditionalPoolThreadsPerProc e impostarne i dati di valore sul numero appropriato in base alle formule indicate sopra.

  4. Creare un valore del Registro di sistema DWORD denominato MaxPercentPoolThreads e impostarne i dati di valore sul numero appropriato in base alle formule indicate sopra.

  5. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sullo specifico problema della risorsa cluster descritto in questo articolo, consultare l'articolo 281868 della Microsoft Knowledge Base "XADM: Failover dei server virtuali POP/IMAP4 sotto carico elevato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868.


Archive Sink SMTP: archiviazione di set di intestazioni P1
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se Archive Sink SMTP è stato installato e abilitato:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Dump P1

Se Exchange Server Analyzer rileva che il valore di Dump P1 è superiore a 0, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore di 0 indica che l'archiviazione delle intestazioni P1 è disabilitata. Il valore 1 indica che l'archiviazione delle intestazioni P1 è abilitata. I valori diversi da 0 o 1 non sono supportati.

Lo strumento Archive Sink SMTP è uno script personalizzato che consente di archiviare tutti i messaggi in arrivo e in uscita da una cartella specifica di un server di Exchange. Per impostazione predefinita, Archive Sink SMTP è abilitato e tutti i messaggi, nonché i rispettivi destinatari, vengono archiviati in un file con estensione EML, ad eccezione dei destinatari Ccn.

Le intestazioni P1 sono denominate anche dati "busta". I dati busta rappresentano l'elenco dei destinatari effettivi che viene generato da Exchange durante il transito di un messaggio e che consente di recapitare tale messaggio a tutti i destinatari. Diversamente dalle intestazioni P2, che rappresentano i destinatari dichiarati dal mittente in un determinato messaggio di posta elettronica ricevuto, i dati busta vengono modificati mentre passano da una destinazione all'altra. Tali modifiche sono determinate dall'espansione delle liste di distribuzione e dal comportamento delle liste di distribuzione nascoste.

Per impostazione predefinita, le intestazioni P1 non vengono archiviate quando viene installato e abilitato Archive Sink SMTP. Generalmente, l'archiviazione delle intestazioni P1 è abilitata solo per la risoluzione dei problemi.

Per non archiviare le intestazioni P1 nel computer Exchange, è possibile impostare la chiave Dump P1 del Registro di sistema su 0 oppure disinstallare Archive Sink SMTP. Quando si disinstalla Archive Sink SMTP, tutte le chiavi del Registro di sistema utilizzate da Archive Sink SMTP vengono eliminate.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per disabilitare l'archiviazione delle intestazioni P1

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Fare doppio clic sulla chiave Dump P1 del Registro di sistema nel campo Dati valore, immettere 0, quindi fare clic su OK.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Per disinstallare Archive Sink SMTP

  1. Fare clic su Start, Esegui, digitare cmd, quindi fare clic su OK.

  2. Nella cartella C:\Program Files\Exchsrvr\bin digitare cscript archivesink_setup.vbs, quindi premere INVIO.

  3. Digitare cscript archivesink_setup.vbs uninstall Virtual Server ID, dove Virtual Server ID è il numero del server virtuale in cui è installato Archive Sink SMTP.

  4. Per rendere effettive le modifiche, chiudere la finestra del prompt dei comandi e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'installazione e la configurazione di Archive Sink SMTP in Exchange Server 2003, consultare l'articolo 871110 della Knowledge Base "Installazione e utilizzo dell'utilità Archive Sink SMTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110.

Per ulteriori informazioni sull'installazione e la configurazione di Archive Sink SMTP in Exchange 2000 Server, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798.

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel diario completa per ragioni di conformità legale, consultare Journaling with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


Archive Sink SMTP abilitato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se Archive Sink SMTP è stato installato e abilitato:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable Smtp Messages

Se Exchange Server Analyzer rileva che il valore di Enable Smtp Messages è superiore a 0, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore 0 indica che Archive Sink SMTP è disabilitato. Il valore 1 indica che Archive Sink SMTP è abilitato. I valori diversi da 0 o 1 non sono supportati.

Lo strumento Archive Sink SMTP è uno script personalizzato che consente l'archiviazione di tutti i messaggi in arrivo e in uscita da una cartella specifica di un server di Exchange. Per impostazione predefinita, Archive Sink SMTP è abilitato e tutti i messaggi, nonché i rispettivi destinatari, vengono archiviati in un file con estensione EML, ad eccezione dei destinatari Ccn.

Per impostazione predefinita, quando viene abilitata l'archiviazione SMTP con Archive Sink SMTP, tutti i messaggi inoltrati al trasporto da SMTP (Simple Mail Transfer Protocol), dall'archivio di Exchange, o da qualsiasi altro sink, generano questo evento. In teoria questo evento può essere generato un'unica volta per ciascun messaggio e può essere archiviato solo una volta. L'evento OnMessageSubmission è stato generato prima degli eventi di routing o del classificatore. Di conseguenza questi messaggi vengono denominati messaggi PreCat. Per impostazione predefinita, i messaggi vengono archiviati per questo evento quando è installato lo strumento Archive Sink SMTP. I messaggi archiviati per questo evento contengono il nome file del prefisso: ARCH_numero casuale.xml.

Per non archiviare i messaggi in questo computer Exchange, è possibile impostare la chiave Enable Smtp Messages del Registro di sistema su 0 oppure disinstallare Archive Sink SMTP. Quando si disinstalla Archive Sink SMTP, tutte le chiavi del Registro di sistema utilizzate da Archive Sink SMTP vengono eliminate.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per disabilitare Archive Sink SMTP

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Fare doppio clic sulla chiave Enable Smtp Messages del Registro di sistema nel campo Dati valore, immettere 0, quindi fare clic su OK.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Per disinstallare Archive Sink SMTP

  1. Fare clic su Start, Esegui, digitare cmd, quindi fare clic su OK.

  2. Nella cartella C:\Program Files\Exchsrvr\bin digitare cscript archivesink_setup.vbs, quindi premere INVIO.

  3. Digitare cscript archivesink_setup.vbs uninstall Virtual Server ID, dove Virtual Server ID è il numero del server virtuale in cui è installato Archive Sink SMTP.

  4. Per rendere effettive le modifiche, chiudere la finestra del prompt dei comandi e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'installazione e la configurazione di Archive Sink SMTP in Exchange Server 2003, consultare l'articolo 871110 della Knowledge Base "Installazione e utilizzo dell'utilità Archive Sink SMTP in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110.

Per ulteriori informazioni sull'installazione e la configurazione di Archive Sink SMTP in Exchange 2000 Server, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798.

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel diario completa per ragioni di conformità legale, consultare Journaling with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


Archive Sink SMTP: Impostazione della post-categorizzazione
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se Archive Sink SMTP è stato installato e abilitato:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PostCat

Se Exchange Server Analyzer rileva che il valore di Enable PostCat è maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Un valore impostato su 0 indica che l'archiviazione del messaggio di post-categorizzazione è disabilitata. Un valore impostato su 1 indica che l'archiviazione del messaggio di post-categorizzazione è abilitata. I valori diversi da 0 o 1 non sono supportati.

Lo strumento Archive Sink SMTP è uno script personalizzato che consente di archiviare tutti i messaggi in arrivo e in uscita da una cartella specifica di un server di Exchange. Per impostazione predefinita, Archive Sink SMTP è abilitato e tutti i messaggi, nonché i rispettivi destinatari, vengono archiviati in un file con estensione EML, ad eccezione dei destinatari Ccn.

Quando Enable PostCat è impostato su 1, i messaggi vengono archiviati dopo la categorizzazione di un messaggio. I messaggi possono generare questo evento più di una volta, ma solo quando un messaggio è stato categorizzato, accodato e nuovamente enumerato. I messaggi archiviati per questo evento contengono il nome del file prefisso ARCH_POSTCAT_numero casuale.xml

Se non si desidera archiviare i messaggi di post-categorizzazione nel computer Exchange, è possibile impostare la chiave Enable PostCat del Registro di sistema su 0. Se non si desidera eseguire nessuna archiviazione nel computer, è possibile disinstallare Archive Sink SMTP. Quando si disinstalla Archive Sink SMTP, tutte le chiavi del Registro di sistema utilizzate da Archive Sink SMTP vengono eliminate.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per disabilitare l'archiviazione dei messagi di post-categorizzazione

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Fare doppio clic sulla chiave Enable PostCat del Registro di sistema nel campo Dati valore, immettere 0, quindi fare clic su OK.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Per disinstallare Archive Sink SMTP

  1. Fare clic su Start, Esegui, digitare cmd, quindi fare clic su OK.

  2. Nella cartella C:\Program Files\Exchsrvr\bin digitare cscript archivesink_setup.vbs, quindi premere INVIO.

  3. Digitare cscript archivesink_setup.vbs uninstall Virtual Server ID, dove Virtual Server ID è il numero del server virtuale in cui è installato Archive Sink SMTP.

  4. Per rendere effettive le modifiche, chiudere la finestra del prompt dei comandi e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione e la configurazione di Archive Sink SMTP in Exchange Server 2003, consultare l'articolo 871110 della Knowledge Base "Installazione e utilizzo dello strumento Archive Sink in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110.

Per ulteriori informazioni sull'impostazione e la configurazione di Archive Sink SMTP, consultare l'articolo 307798 della Knowledge Base "Disponibilità dello strumento Archive Sink in Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798.

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel diario completa per ragioni di conformità legale, consultare Journaling with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


Archive Sink SMTP: Impostazione della post-categorizzazione
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se Archive Sink SMTP è installato e abilitato:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Enable PreCat

Se Exchange Server Analyzer rileva che il valore Enable PreCat è maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Un valore impostato su 0 indica che l'archiviazione dei messaggi di pre-categorizzazione è disabilitata. Un valore impostato su 1 indica che l'archiviazione dei messaggi di pre-categorizzazione è abilitata. I valori diversi da 0 o 1 non sono supportati.

Lo strumento Archive Sink SMTP è uno script personalizzato che consente di archiviare tutti i messaggi in arrivo e in uscita da una cartella specifica di un server di Exchange. Per impostazione predefinita, Archive Sink SMTP è abilitato e tutti i messaggi, nonché i rispettivi destinatari, vengono archiviati in un file con estensione EML, ad eccezione dei destinatari Ccn.

Tutti i messaggi inviati da SMTP (Simple Mail Transfer Protocol), dall'archivio di Exchange o da qualsiasi altro sink generano questo evento. In teoria questo evento può essere generato un'unica volta per ciascun messaggio e può essere archiviato solo una volta. L'evento OnMessageSubmission è stato generato prima degli eventi di routing o del classificatore. Di conseguenza questi messaggi vengono denominati messaggi PreCat. Per impostazione predefinita, i messaggi vengono archiviati per questo evento quando è installata l'utilità Archive Sink SMTP. I messaggi archiviati per questo evento contengono il nome del prefisso file ARCH_random number.xml.

Se non si desidera archiviare i messaggi di pre-categorizzazione nel computer Exchange, è possibile impostare la chiave Enable PreCat del Registro di sistema su 0. Se non si desidera eseguire nessuna archiviazione nel computer, è possibile disinstallare Archive Sink SMTP. Quando si disinstalla Archive Sink SMTP, tutte le chiavi del Registro di sistema utilizzate da Archive Sink SMTP vengono eliminate.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per disabilitare l'archiviazione dei messagi di pre-categorizzazione

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Fare doppio clic sulla chiave Enable PreCat del Registro di sistema nel campo Dati valore, immettere 0, quindi fare clic su OK.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Per disinstallare Archive Sink SMTP

  1. Fare clic su Start, Esegui, digitare cmd, quindi fare clic su OK.

  2. Nella cartella C:\Program Files\Exchsrvr\bin digitare cscript archivesink_setup.vbs, quindi premere INVIO.

  3. Digitare cscript archivesink_setup.vbs uninstall Virtual Server ID, dove Virtual Server ID è il numero del server virtuale in cui è installato Archive Sink SMTP.

  4. Per rendere effettive le modifiche, chiudere la finestra del prompt dei comandi e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione e la configurazione di Archive Sink SMTP in Exchange Server 2003, consultare l'articolo 871110 della Knowledge Base "Installazione e utilizzo dell'utilità Archive Sink in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110.

Per ulteriori informazioni sull'impostazione e la configurazione di Archive Sink SMTP in Exchange 2000 Server, consultare l'articolo 307798 della Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798.

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel diario completa per ragioni di conformità legale, consultare Journaling with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


Archive Sink SMTP: I messaggi di sistema sono in corso di archiviazione
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se lo strumento Archive Sink SMTP è stato installato e abilitato:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\ArchiveSink\1\Archive System Messages

Se Exchange Server Analyze rileva che il valore di Archive System Messages è maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Un valore di 0 indica che i messaggi di sistema non sono archiviati. Un valore di 1 indica che i messaggi di sistema sono archiviati. I valori diversi da 0 o 1 non sono supportati.

Lo strumento Archive Sink SMTP è uno script personalizzato che consente di archiviare tutti i messaggi in arrivo e in uscita da una cartella specifica di un server di Exchange. Per impostazione predefinita, Archive Sink SMTP è abilitato e tutti i messaggi, nonché i rispettivi destinatari, vengono archiviati in un file con estensione EML, ad eccezione dei destinatari Ccn.

Se non si desidera archiviare i messaggi di sistema nel computer Exchange, è possibile impostare la chiave Archive System Messages del Registro di sistema su 0. Se non si desidera eseguire nessuna archiviazione nel computer, è possibile disinstallare Archive Sink SMTP. Quando si disinstalla Archive Sink SMTP, tutte le chiavi del Registro di sistema utilizzate da Archive Sink SMTP vengono eliminate.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per disabilitare l'archiviazione dei messaggi di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\SOFTWARE\Microsoft\Exchange\ArchiveSink\1

  3. Fare doppio clic sulla chiave Archive System Messages del Registro di sistema nel campo Dati valore, immettere 0, quindi fare clic su OK.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Per disinstallare Archive Sink SMTP

  1. Fare clic su Start, Esegui, digitare cmd, quindi fare clic su OK.

  2. Nella cartella C:\Program Files\Exchsrvr\bin digitare cscript archivesink_setup.vbs, quindi premere INVIO.

  3. Digitare cscript archivesink_setup.vbs uninstall Virtual Server ID, dove Virtual Server ID è il numero del server virtuale in cui è installato Archive Sink SMTP.

  4. Per rendere effettive le modifiche, uscire dalla finestra del prompt dei comandi e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione e la configurazione di Archive Sink SMTP in Exchange Server 2003, consultare l'articolo 871110 della Knowledge Base "Installazione e utilizzo dell'utilità Archive Sink in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=871110.

Per ulteriori informazioni sull'impostazione e la configurazione di Archive Sink SMTP in Exchange 2000 Server, consultare l'articolo 307798 della Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=307798.

Per ulteriori informazioni sulla distribuzione di una soluzione di inserimento nel diario completa per ragioni di conformità legale, consultare Journaling with Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47581 (informazioni in lingua inglese).


Scrittura dei dati della posta scartata SMTP in una cartella compressa
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Compressed per la cartella di posta scartata SMTP (Simple Mail Transfer Protocol). Se Exchange Server Analyzer rileva che il valore di Compressed è impostato su True, verrà visualizzato un avviso.

Se nel computer che esegue Exchange arrivano messaggi tramite il servizio SMTP, i dati vengono scritti sul disco rigido come un file con estensione EML. Per impostazione predefinita, questi file vengono memorizzati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange. Se nella cartella in cui sono archiviati i dati della posta scartata SMTP è attivata la compressione dei file, le prestazioni di Exchange potrebbero essere significativamente compromesse. Pertanto, la compressione della cartella in cui sono archiviati i dati della posta scartata SMTP non è supportata.

Se si riceve questo avviso, è necessario disattivare la compressione della cartella in cui sono archiviati i dati della posta scartata SMTP oppure spostare questi dati in una cartella non compressa.

Microsoft non supporta l'archiviazione di file di dati di Exchange in un volume compresso. Quando si esegue l'archiviazione dei file di dati di Exchange in un volume compresso, il sovraccarico aggiuntivo influisce notevolmente sulle prestazioni di Exchange. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per disattivare la compressione dei file in una specifica cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

Per spostare la cartella Posta scartata in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic su Gruppi amministrativi ed espandere il proprio gruppo amministrativo, Server, il proprio server, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Arresta.

  4. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Nella scheda Messaggi accanto alla casella Directory della posta scartata fare clic su Sfoglia, quindi immettere il percorso della nuova posizione della cartella Coda.

  6. Fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start.

Per ulteriori informazioni sullo spostamento della cartella della directory principale di posta, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.


Scrittura dei dati della posta scartata SMTP in una partizione non NTFS
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave FSName per la directory della posta scartata SMTP di Exchange. Se Exchange Server Analyzer rileva che il valore della chiave FSName non corrisponde a NTFS, verrà visualizzato un avviso.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in volumi non NTFS. I file di dati di Exchange includono i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

Se viene visualizzato questo avviso, sarà necessario spostare la directory della posta scartata SMTP in una cartella di un'unità del file system NTFS. In alternativa, se l'unità in cui è archiviata la directory BadMail è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertire l'unità in NTFS.

Per spostare la directory della posta scartata SMTP in un'altra cartella

  1. Avviare Gestore di sistema di Exchange.

  2. Fare clic su Gruppi amministrativi ed espandere il proprio gruppo amministrativo, Server, il proprio server, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Arresta.

  4. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Nella scheda Messaggi, accanto alla casella Directory della posta scartata, fare clic su Sfoglia, quindi digitare il percorso della nuova posizione della cartella di posta scartata.

  6. Fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start.

Per ulteriori informazioni sullo spostamento della cartella della directory principale di posta, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.

In alternativa alla procedura descritta sopra, se l'unità in cui sono archiviati i file è formattata come un'unità FAT, è possibile utilizzare lo strumento della riga di comando convert.exe per convertirla in unità NTFS. Per ulteriori informazioni sull'utilizzo dello strumento della riga di comando convert.exe per convertire una partizione FAT in una partizione NTFS, consultare l'articolo 214579 della Microsoft Knowledge Base: "Utilizzo di Convert.exe per convertire una partizione nel file system NTFS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579.


Scrittura dei dati della posta scartata SMTP in una cartella crittografata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Encrypted per la cartella di posta scartata SMTP. Se Exchange Server Analyzer rileva che il valore di Encrypted è impostato su True, verrà visualizzato un avviso.

Quando nel computer che esegue Exchange arrivano messaggi tramite il servizio SMTP, i dati verranno scritti sul disco rigido come un file con estensione eml. Per impostazione predefinita, questi file vengono memorizzati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange. Se nella cartella in cui sono archiviati i dati della posta scartata SMTP è attivata la crittografia, le prestazioni di Exchange potrebbero essere significativamente compromesse. Pertanto, la crittografia della cartella in cui sono archiviati i dati della posta scartata SMTP non è supportata.

Se si riceve questo avviso, è necessario disattivare la crittografia della cartella in cui sono archiviati i dati della posta scartata SMTP oppure spostare i dati della posta scartata SMTP in una cartella non crittografata.

Microsoft non supporta la memorizzazione dei file di dati di Exchange in un volume crittografato EFS (Encrypting File System). Quando si archiviano i file di dati di Exchange in un volume crittografato, l'overhead aggiuntivo influenza in modo significativo le prestazioni di Exchange. I file di dati di Exchange includono i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per proteggere i file di dati di Exchange, è consigliabile impedire l'accesso non autorizzato al computer che esegue Exchange e utilizzare il formato messaggio S/MIME per crittografare i dati dei messaggi.

Per correggere questo errore è necessario disattivare la crittografia dei file nella cartella di posta scartata SMTP oppure spostare tale cartella in una posizione in cui la crittografia non è abilitata.

Per disattivare la crittografia dei file in una data cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la crittografia file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Crittografa contenuto per la protezione dei dati e scegliere OK.

Per spostare la cartella Posta scartata in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic su Gruppi amministrativi ed espandere il proprio gruppo amministrativo, Server, il proprio server, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Arresta.

  4. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Nella scheda Messaggi, accanto alla casella Directory della posta scartata fare clic su Sfoglia, quindi digitare il percorso della nuova posizione della cartella Coda.

  6. Fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start.

Per ulteriori informazioni sullo spostamento della cartella della directory principale di posta, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.

Per ulteriori informazioni sui file di dati di Exchange Server ed EFS (Encrypting File System, Crittografia file system), consultare l'articolo 834638 della Microsoft Knowledge Base "Informazioni sull'archiviazione dei file di dati in un volume crittografato in Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Per informazioni sulle modalità di protezione dei messaggi in Exchange Server 2003, consultare la Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47574.


Valore SMTP CatRetryMinutes del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave CatRetryMinutes è stata impostata, verrà visualizzato un messaggio di configurazione non predefinita.

Si consiglia di modificare i valori di accodamento predefiniti solo dopo un attento esame. Nella maggior parte degli ambienti le impostazioni predefinite sono state accuratamente selezionate per prestazioni ottimali. In genere, si consiglia di risolvere la causa principale del problema anziché modificare il comportamento di accodamento in Exchange Server.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


Avviso di configurazione SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-03

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore dell'attributo msExchSmtpMaxMessageSize è stato modificato rispetto al valore predefinito di 0. Per impostazione predefinita, l'attributo msExchSmtpMaxMessageSize è configurato per una dimensione dei messaggi illimitata.

Se si verificano le seguenti condizioni, verrà visualizzato un avviso:

  • L'attributo msExchSmtpMaxMessageSize non ha un valore pari a 0.

  • Exchange non è in esecuzione in Microsoft Windows® Small Business Server 2003.

L'attributo msExchSmtpMaxMessageSize rappresenta la dimensione massima di ciascun messaggio SMTP inviato o ricevuto. Dal punto di vista della protezione è consigliabile limitare la dimensione massima dei messaggi SMTP inviati e ricevuti tramite Internet. Tuttavia, per i messaggi SMTP interni, come quelli tra server Exchange nella stessa organizzazione, è consigliabile che l'attributo msExchSmtpMaxMessageSize rimanga impostato su 0.

Internamente, i messaggi SMTP vengono utilizzati in Exchange per gestire operazioni quali la replica della cartella pubblica. Se l'attributo msExchSmtpMaxMessageSize è configurato su un limite troppo basso, è possibile che si verifichino problemi di replica della cartella pubblica e altri problemi di recapito messaggi all'interno dell'organizzazione.

Se il server Exchange è un server testa di ponte che trasferisce i messaggi SMTP da e per Internet, è possibile ignorare l'avviso. Se il server Exchange gestisce i messaggi SMTP interni, è necessario modificare il valore dell'attributo msExchSmtpMaxMessageSize riportandolo al valore predefinito di 0.

Nota:
Se il limite della dimensione del messaggio viene impostato su un valore troppo basso, è possibile che venga impedita la replica della rubrica fuori rete tra computer Exchange Server. Per ulteriori informazioni, vedere l'articolo 326154 della Microsoft Knowledge Base "Impossibile scaricare la rubrica fuori rete di Microsoft Outlook in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154.
Per visualizzare e configurare la dimensione massima dei messaggi SMTP

  1. Nel Gestore di sistema di Exchange espandere Server, espandere un server Exchange, quindi Protocolli, quindi SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP, ad esempio Server virtuale SMTP predefinito, quindi selezionare Proprietà.

  3. Selezionare la scheda Messaggi.

  4. Per ripristinare l'impostazione predefinita di 0, deselezionare la casella di controllo Limita dimensione messaggi a (KB). In alternativa, lasciare la casella selezionata e configurare un valore qualsiasi.

  5. Fare clic su OK per salvare le modifiche e per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Connettore SMTP con restrizioni di recapito ai gruppi di distribuzione impostate
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool esegue una query negli attributi seguenti per ciascun oggetto connettore SMTP (Simple Mail Transfer Protocol) (msExchRoutingSMTPConnector) rilevato nel servizio directory di Active Directory® per determinare se sono state impostate restrizioni di recapito in base all'appartenenza ai gruppi di distribuzione.

dLMemRejectPerms | Contiene i nomi di dominio (DN) delle liste di distribuzione (DL) i cui membri potrebbero non utilizzare questo connettore SMTP per l'invio di messaggi
dLMemSubmitPerms | Contiene i nomi di dominio (DN) delle liste di distribuzione (DL) i cui membri potrebbero utilizzare questo connettore SMTP per l'invio di messaggi

Se Exchange Server Analyzer determina l'esistenza di connettori SMTP con restrizioni di recapito impostate in base all'appartenenza a gruppi di distribuzione, verrà visualizzato un avviso.

Tale avviso indica che le restrizioni di recapito basate sull'appartenenza a gruppi di distribuzione potrebbero influire sulle prestazioni del flusso di posta di Exchange.

Quando la posta viene inviata mediante connettori SMTP su cui sono state impostate restrizioni di recapito in base all'appartenenza a gruppi di distribuzione, il classificatore di messaggi deve espandere l'appartenenza del gruppo, ottenere l'elenco completo di DN dei membri e quindi confrontare l'elenco di DN ai DN del mittente. Quando un DN corrisponde in entrambi gli elenchi, si verifica un'operazione di accesso o di rifiuto. Se un gruppo di distribuzione è nidificato in un altro gruppo, viene espansa anche la distribuzione nidificata.

Per risolvere il problema:

  • Designare un gruppo di routing dedicato per le restrizioni dei connettori e configurarlo su un gruppo di routing locale come indicato nell'articolo 329171 della Microsoft Knowledge Base "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • Utilizzare un server di catalogo globale dedicato e più affidabile come server testa di ponte designato per il connettore.

  • Configurare cassette postali individuali e non gruppi di distribuzione per le restrizioni di recapito come menzionato nell'articolo 812298 della Microsoft Knowledge Base "Il recapito della posta è lento dopo la configurazione di restrizioni di recapito in base a una lista di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.

  • Implementare il filtro mittenti SMTP.

  • Per i server che eseguono Exchange Server 2003 Service Pack 2 (SP2) o una versione successiva, implementare la verifica delle restrizioni non gerarchica. Per i server che eseguono una versione precedente a Exchange 2003 SP2, è consigliabile eseguire l'aggiornamento a Exchange 2003 SP2.

Per ulteriori informazioni

Per ulteriori informazioni sulla verifica delle restrizioni non gerarchica, vedere Verifica delle restrizioni non gerarchica.

Per ulteriori informazioni sul filtro mittenti SMTP, consultare "Configurazione del filtro mittenti" nel Manuale dell'amministratore di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=72967.

Per ulteriori informazioni sull'effetto della restrizione relativa al gruppo di distribuzione sul flusso di posta di Exchange Server 2003, consultare gli articoli della Microsoft Knowledge Base riportati di seguito:

  • 329171 "XADM: Il recapito della posta è lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • 895407 "In Exchange Server 2003, dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, il recapito dei messaggi alle cassette postali locali ed esterne è più lento del previsto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 839949 "Risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.


Riscrittura del dominio SMTP abilitata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo heuristics sull'oggetto Server virtuale SMTP per questo server di Exchange. Se Exchange Server Analyzer rileva che l'attributo heuristics non è impostato sul valore predefinito 131072, verrà visualizzato un messaggio di errore.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sullo strumento Exchange Server Address Rewrite, visitare la pagina di Exchange Server Address Rewrite all'indirizzo http://go.microsoft.com/fwlink/?LinkId=25932.


Valore del Registro di sistema FailedMsgQRetryMinutes SMTP non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave FailedMsgQRetryMinutes è stata impostata, verrà visualizzato un messaggio di configurazione non predefinita.

Si consiglia di modificare i valori di accodamento solo dopo un attento esame. Nella maggior parte degli ambienti le impostazioni predefinite sono state attentamente selezionate per prestazioni ottimali. Generalmente il rimedio ottimale è affrontare la causa del problema anziché modificare le impostazioni di accodamento.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


Valore SMTP LocalDeliveryMaxBatch del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se l'impostazione predefinita del valore del Registro di sistema LocalDeliveryMaxBatch è stata modificata:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%.

Se Exchange Server Analyzer rileva che l'impostazione del valore del Registro di sistema LocalDeliveryMaxBatch è stata creata manualmente, modificando l'impostazione binaria predefinita di 80 del server di Exchange, verrà visualizzato un avviso di configurazione non predefinita.

Per impostazione predefinita il valore LocalDeliveryMaxBatch del Registro di sistema non viene creato durante l'installazione di Exchange Server. Il valore LocalDeliveryMaxBatch del Registro di sistema può essere creato manualmente dopo l'installazione di Exchange Server per modificare l'elaborazione interna e il recapito dei messaggi da parte dell'Archivio informazioni di Exchange. Nel server di Exchange potrebbero verificarsi problemi con il trasporto dei messaggi e le prestazioni dell'archivio se si verificano le seguenti condizioni:

  • Il valore LocalDeliveryMaxBatch del Registro di sistema è stato creato manualmente.

  • L'impostazione del valore LocalDeliveryMaxBatch del Registro di sistema non è configurata correttamente.

Si consiglia di creare o modificare il valore LocalDeliveryMaxBatch del Registro di sistema solo dopo un attento esame. I valori predefiniti per i file binari del server di Exchange sono stati accuratamente selezionati per garantire prestazioni ottimali per l'utilizzo nella maggior parte degli ambienti server di Exchange. Generalmente la soluzione ottimale è di affrontare la causa del problema anziché modificare il comportamento predefinito di Exchange Server configurando manualmente il Registro di sistema. Per attenersi alle indicazioni, se esiste il valore LocalDeliveryMaxBatch del Registro di sistema, è possibile eliminarlo per consentire al server di Exchange di ripristinare l'impostazione binaria predefinita.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Tuttavia è possibile modificare il Registro di sistema per ripristinare il valore predefinito.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare alla seguente chiave del Registro di sistema: HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\StoreDriver\Exchange\%SMTPVirtualServerInstance%

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse sul valore LocalDeliveryMaxBatch del Registro di sistema, scegliere Modifica, impostare il campo Dati valore su 80, infine fare clic su OK.

    Nota:
    Per eliminare il valore LocalDeliveryMaxBatch del Registro di sistema, nel riquadro dei dettagli fare clic su di esso con il pulsante destro del mouse e scegliere Elimina. Per confermare l'eliminazione del valore del Registro di sistema, fare clic su Sì nella finestra di dialogo.

  4. Chiudere l'editor del Registro di sistema.

  5. Riavviare il server di Exchange.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sulla modifica del Registro di sistema di Microsoft Windows, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 322755, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322755.

  • 322756, "HOW TO: Eseguire il backup, modificare e ripristinare il Registro di sistema in Windows XP" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322756.


Nome di dominio completo dell'istanza SMTP non corrispondente al nome risolto dal DNS
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore dell'attributo msExchSmtpFullyQualifiedDomainName dall'oggetto server virtuale SMTP (Simple Mail Transfer Protocol) predefinito.

Microsoft® Exchange Server Analyzer Tool tenta, inoltre, di eseguire una query Domain Name System (DNS) per ricercare nei server DNS configurati il nome di dominio completo (FQDN, Fully Qualified Domain Name) del server su cui è in esecuzione Exchange Server. Questa connessione viene effettuata mediante un elaboratore di oggetti personalizzati su cui viene eseguita una richiesta di risoluzione dei nomi e vengono analizzati i risultati.

Microsoft® Exchange Server Analyzer Tool confronta i risultati delle due query. Se il valore dell'attributo msExchSmtpFullyQualifiedDomainName dall'oggetto server virtuale SMTP predefinito non corrisponde al nome di dominio completo DNS del server Exchange, verrà visualizzato un avviso.

Tale avviso indica che i valori degli attributi possono essere stati modificati manualmente. Pertanto, tali valori modificati potrebbero contribuire a creare problemi del flusso di posta sul server.

Il valore dell'attributo msExchSmtpFullyQualifiedDomainName specifica il nome di dominio completo del server virtuale SMTP ed è necessario che sia risolto dal protocollo di rete DNS.

È necessario che per il valore dell'attributo sia presente un record DNS HOST (A) valido affinché i server di messaggistica che cercano di risolvere l'FQDN del server SMTP virtuale possano recuperare l'indirizzo IP corretto e instradare correttamente la posta.

Per risolvere il problema, determinare se i valori sono stati modificati intenzionalmente per uno scopo valido. In tal caso, eseguire una delle seguenti operazioni:

  • Modificare il valore dell'attributo msExchSmtpFullyQualifiedDomainName affinché corrisponda al nome di dominio completo del DNS.

  • Configurare il nome di dominio completo del DNS di Exchange Server affinché corrisponda al valore dell'attributo msExchSmtpFullyQualifiedDomainName.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per aggiornare il valore dell'attributo msExchSMTPFullyQualifiedDomainName

  1. Aprire Gestore di sistema di Exchange.

  2. Nel Gestore di sistema di Exchange espandere Gruppi amministrativi, Server, espandere il server di Exchange, Protocolli quindi SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP predefinito, quindi scegliere Proprietà.

  4. Selezionare la scheda Recapito e fare clic su Avanzate.

  5. In Nome di dominio completo immettere il valore dell'attributo msExchSmtpFullyQualifiedDomainName.

  6. Fare clic su OK per salvare le modifiche, quindi fare di nuovo clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.
Per configurare il nome di dominio completo DNS del server di Exchange

  1. Seguire le indicazioni fornite in Configurazione delle impostazioni sul server DNS .

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario, vedere "Add a resource record to a DNS zone" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63002 (in inglese).

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Knowledge Base:

  • 266686, sulla prima parte della configurazione di un server virtuale SMTP, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, sulla seconda parte della configurazione di un server virtuale SMTP, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sul design del servizio SMTP vedere "Design del servizio SMTP" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=58876.


Istanza SMTP senza alcun connettore SMTP in uscita impostato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-22

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per il valore attributo distingushedName della classe oggetto protocolCfgSMTPServer per elencare tutte le istanze del server virtuale SMTP (Simple Mail Transfer Protocol) sul gateway di Exchange specificato dall'utente.

Exchange Server Analyzer esegue quindi una query in Active Directory per il valore degli attributi msExchSourceBridgeheadServersDN e routingList per ciascun oggetto msExchRoutingSMTPConnector rilevato per determinare se in un connettore SMTP è stata impostata una delle istanze del server virtuale SMTP rilevate come relativo server testa di ponte su uno spazio indirizzo SMTP esterno.

Un connettore SMTP definisce una route isolata per la posta elettronica. È possibile utilizzare i connettori SMTP per stabilire un gateway per la posta Internet oppure per collegarsi a un dominio o a un sistema di posta elettronica specifico. I connettori consentono di definire opzioni specifiche per la route di posta elettronica designata.

Se Exchange Server Analyzer determina che non esiste alcun connettore SMTP con un'istanza del server virtuale SMTP proveniente dal server gateway di Exchange impostato come relativo server testa di ponte locale, verrà visualizzato un avviso.

Questo avviso indica che server diversi dal server gateway di Exchange specificato dall'utente potrebbero accidentalmente instradare i messaggi all'esterno dell'organizzazione.

Può essere necessario creare un connettore SMTP che designi un'istanza del server virtuale SMTP sul server gateway di Exchange specificato come server testa di ponte per impedire che server diversi dal server gateway di Exchange specificato dall'utente instradino accidentalmente i messaggi all'esterno dell'organizzazione.

Sebbene sia possibile inviare e ricevere la posta Internet utilizzando solo un server virtuale SMTP, è preferibile configurare un connettore SMTP dedicato a tale scopo. Si consiglia l'utilizzo di un connettore SMTP in quanto fornisce una route isolata per la posta elettronica destinata a Internet. Inoltre sono disponibili più opzioni di configurazione su un connettore SMTP che sul server virtuale SMTP.

Per ulteriori informazioni sull'utilizzo dei connettori SMTP, vedere l'articolo 294736 della Microsoft Knowledge Base "Creazione dei connettori SMTP in Exchange 2000 e versioni successive" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=294736.

Per ulteriori informazioni sui connettori SMTP vedere la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Valore SMTP LocalRetryMinutes del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave LocalRetryMinutes è stata impostata, verrà visualizzato un messaggio di configurazione non predefinita.

Si consiglia di modificare i valori di accodamento predefiniti solo dopo un attento esame. Nella maggior parte degli ambienti le impostazioni predefinite sono state accuratamente selezionate per garantire prestazioni ottimali. In genere, anziché modificare il comportamento di accodamento in Exchange, è consigliabile risolvere la causa principale del problema.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


Il valore SMTP FileCacheLifeTimeSeconds del Registro di sistema è stato aggiunto manualmente ma potrebbe non essere più necessario
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la durata predefinita per ogni handle di file IIS nella cache è stata modificata rispetto al valore predefinito 1.880 secondi (30 minuti):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheLifeTimeSeconds

Se Exchange Server Analyzer rileva che FileCacheLifeTimeSeconds è presente e configurato con un valore alternativo, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore FileCacheLifeTimeSeconds specifica la durata per gli handle di file IIS nella cache. Gli handle di file vengono memorizzati nella cache per migliorare le prestazioni, perché in tal modo impediscono al server di eseguire cicli di input/output (I/O) e cicli macchina ridondanti. Ogni volta che lo stack di trasporto SMTP in un computer Exchange Server riceve un messaggio, questo viene inviato al file system dove resta in attesa di essere instradato alla destinazione. Per scrivere nel file system, lo stack di trasporto SMTP ottiene un handle di file a cui passa il messaggio. Ogni handle di file occupa circa 2 kilobyte (KB) di memoria della riserva di paging. Il numero predefinito di handle di file della cache IIS è di 800 ogni 32 MB.

Questo valore del Registro di sistema non è presente per impostazione predefinita dal momento che Exchange 2000 Server Service Pack 2 (SP2) e versioni successive ed Exchange Server 2003 sono configurati per conservare nella cache un numero ottimale di handle di file. Con Exchange Server 2003 vengono calcolate in modo dinamico le impostazioni appropriate per gli handle dei file SMTP, in modo che tali impostazioni non siano più necessarie. Pertanto, prima di eseguire l'aggiornamento di computer Exchange 2000 Server a Exchange Server 2003 con queste impostazioni, è necessario eliminare queste voci dal Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Nel riquadro destro eliminare il valore FileCacheLifeTimeSeconds.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione di IIS.

Prima di modificare il Registro di sistema e per informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il valore SMTP FileCacheMaxHandles del Registro di sistema per stato aggiunto manualmente ma potrebbe non essere più necessario
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il numero massimo di handle di file IIS (Internet Information Services) nella cache è stato modificato rispetto al valore predefinito di 800:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters\FileCacheMaxHandles

Se Exchange Server Analyzer rileva che FileCacheMaxHandles è presente e configurato con un valore diverso da 800, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore FileCacheMaxHandles specifica il numero massimo di handle di file IIS utilizzati da Exchange per ogni 32 MB di memoria fisica. Gli handle di file vengono memorizzati nella cache per migliorare le prestazioni, perché in tal modo impediscono al server di eseguire cicli di input/output (I/O) e cicli macchina ridondanti. Ogni volta che lo stack di trasporto SMTP in un computer Exchange Server riceve un messaggio, questo viene inviato al file system dove resta in attesa di essere instradato alla destinazione. Per scrivere nel file system, lo stack di trasporto SMTP ottiene un handle di file a cui passa il messaggio. Ogni handle di file occupa circa 2 kilobyte (KB) di memoria della riserva di paging. Il numero predefinito di handle di file della cache IIS è di 800 ogni 32 MB.

Prima del Service Pack 2 (SP2) per Exchange 2000 Server, le prestazioni dei server di Exchange che supportavano grandi code di messaggi SMTP (ad esempio, una media di 1000 o più messaggi) erano limitate a causa di un'impostazione predefinita sul servizio SMTP di un massimo di 1000 handle di file. Poiché in Exchange 2000 Server è stato impostato automaticamente un valore massimo di 1.000 handle di file, il servizio SMTP è in grado di scrivere solo 1.000 messaggi simultanei nel file system.

Per migliorare le prestazioni per questi sistemi di grandi dimensioni, spesso venivano adeguate contemporaneamente tre voci del Registro di sistema, in modo da aumentare il numero massimo di handle di file che potevano essere aperti dal servizio SMTP (per poter elaborare più messaggi) e da diminuire il numero di handle di file aperti per il file system installabile, un altro componente di Exchange (per evitare di esaurire la memoria quando la coda è di grandi dimensioni). Tali valori del Registro di sistema, che non esistevano per impostazione predefinita e pertanto dovevano essere aggiunti manualmente, sono elencati di seguito:

Posizione: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Valore: MsgHandleThreshold

Tipo: REG_DWORD

Posizione: HKLM\System\CurrentControlSet\Services\SMTPSVC\Queuing

Valore: MsgHandleAsyncThreshold

Tipo: REG_DWORD

Posizione: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valore: FileCacheMaxHandles

Tipo: REG_DWORD

Le voci MsgHandleThreshold e MsgHandleAsyncThreshold vengono normalmente impostate sullo stesso valore (di solito un valore maggiore di 1.000) e il valore FileCacheMaxHandles viene normalmente ridotto da 800 a 600.

Questo valore del Registro di sistema non è presente per impostazione predefinita, poiché Exchange 2000 Server Service Pack 2 (SP2) e versioni successive determinano in modo dinamico i valori ottimali da utilizzare. Se questo server di Exchange esegue Exchange 2000 Server con Service Pack 1 o versioni precedenti, è consigliabile eseguire un aggiornamento alla versione più recente del Service Pack e degli aggiornamenti cumulativi. Dopo aver eseguito l'aggiornamento al codice più recente, è possibile eliminare queste voci del Registro di sistema.

Con Exchange Server 2003 vengono calcolate in modo dinamico le impostazioni appropriate per gli handle di file SMTP, in modo che tali impostazioni non siano più necessarie. Pertanto, prima di eseguire l'aggiornamento di computer Exchange 2000 Server a Exchange Server 2003 con queste impostazioni, è necessario eliminare queste voci dal Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

  3. Eliminare il valore FileCacheMaxHandles.

  4. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il valore SMTP GlitchRetrySeconds del Registro di sistema è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il tempo di attesa predefinito per la risoluzione del problema è stato sostituito manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\GlitchRetrySeconds

Se Exchange Server Analyzer rileva che la chiave GlitchRetrySeconds è presente e configurata, verrà visualizzato un messaggio di configurazione non predefinita.

Se Exchange 2000 Server o Exchange Server 2003 tenta di indirizzare un messaggio verso un sistema SMTP esterno molto carico, è possibile che venga visualizzato un messaggio di server occupato. In questo caso Exchange entra nello stato denominato "glitch retry". In questo stato Exchange attende 60 secondi prima di tentare di inviare nuovamente il messaggio e ripete questa operazione tre volte prima di ricorrere ad altri metodi per la risoluzione del problema. Se i server esterni sono costantemente occupati, si consiglia di ridurre il tempo di attesa del glitch retry per impedire che venga accodato un numero altissimo di messaggi.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Nel riquadro destro fare doppio clic sul valore GlitchRetrySeconds. In alternativa, è possibile ridurre il valore per GlitchRetrySeconds se si sta verificando l'accodamento di un numero molto alto di messaggi.

  4. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Simple Mail Transfer Protocol (SMTP).

Prima di modificare il Registro di sistema e per informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il valore SMTP IgnorePFTimeLimit del Registro di sistema è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge la seguente voce di registro per determinare se il numero di giorni che il motore di routing del servizio SMTP usa per ignorare il nuovo archivio delle cartelle pubbliche è stato impostato manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\IgnorePFTimeLimit

Se Exchange Server Analyzer rileva che IgnorePFTimeLimit è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Quando un nuovo archivio delle cartelle pubbliche viene portato in linea, nel visualizzatore code è possibile notare che la dimensione della coda di recapito locale è in aumento. Se la gerarchia delle cartelle pubbliche è molto ampia, i messaggi nella coda locale continuano ad aumentare e il recapito potrebbe richiedere ulteriore tempo. In alcuni casi è possibile che i messaggi non vengano recapitati.

Quando viene introdotto il nuovo server, il nome distinto del server viene aggiunto all'attributo msExchOwningPFTreeBL dell'oggetto Cartella pubblica delle gerarchie delle cartelle del gruppo amministratori nel servizio directory di Active Directory®. Quando il classificatore del server che riceve i messaggi per le cartelle pubbliche legge l'attributo msExchOwningPFTreeBL, dovrebbe selezionare il primo archivio locale per le cartelle pubbliche, se esistente. Per il bilanciamento del carico seleziona quindi gli archivi cartelle pubbliche nell'ordine in cui sono elencati. Poiché il nuovo server viene elencato per primo, i messaggi vengono indirizzati verso tale server, dove vengono aggiunti alla coda did recapito locale. Se un archivio delle cartelle pubbliche non ha ricevuto una copia della gerarchia, il server non instrada i messaggi a un archivio che possiede una copia della cartella di destinazione.

È possibile evitare questo problema aggiungendo il valore IgnorePFTimeLimit al Registro di sistema del nuovo server delle cartelle pubbliche. Questo specifica il numero di giorni in cui il motore di routing ignora il nuovo archivio delle cartelle pubbliche.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Nel riquadro destro eliminare IgnorePFTimeLimit.

  4. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Per ulteriori informazioni sul problema e sul valore IgnorePFTimeLimit del Registro di sistema descritti in questo articolo, consultare l'articolo 328870 della Microsoft Knowledge Base, "XADM: Il routing delle cartelle pubbliche viene abilitato prima della replica delle gerarchia" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328870.

Prima di modificare il Registro di sistema e per informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


L'istanza SMTP dispone di più binding della porta configurati
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato per l'attributo msExchServerBindings è diverso da quello predefinito di 25 o se sono stati impostati più valori. Per impostazione predefinita, l'attributo msExchServerBindings è configurato per la porta TCP 25. Se Exchange Server Analyzer rileva che per questo attributo è impostato più di un valore, verrà visualizzato un messaggio di configurazione non predefinita, insieme al nome del server virtuale SMTP (Simple Mail Transfer Protocol) su cui sono impostati più valori.

L'attributo msExchServerBindings rappresenta la porta TCP su cui il server SMTP è configurato per l'ascolto di connessioni in ingresso. È possibile configurare i server virtuali SMTP per l'ascolto su una o più porte TCP. Per impostazione predefinita, tutti i server virtuali SMTP sono configurati per l'ascolto sulla porta TCP 25, la porta SMTP predefinita. Se la porta di attesa SMTP è stata modificata rispetto alla configurazione predefinita e include più binding della porta, potrebbero verificarsi problemi nel flusso di posta.

La porta di attesa SMTP può essere modificata a condizione che anche l'intera infrastruttura di messaggistica interna venga modificata di conseguenza. In genere, tuttavia, non è possibile utilizzare porte alternative per server virtuali SMTP che accettano messaggi direttamente da Internet, dal momento che i server SMTP in Internet inviano i messaggi tramite la porta 25.

Exchange Server Analyzer esegue una ricerca per il valore del server virtuale dei protocolli SMTP di Exchange. Il server virtuale dei protocolli SMTP può corrispondere o meno al server SMTP che riceve messaggi direttamente da Internet. Esistono alcuni prodotti antivirus e anti spam progettati per ricevere messaggi SMTP da Internet sulla porta 25 e per reindirizzarli a un server virtuale SMTP di Exchange su un'altra porta. In questo tipo di scenario, una configurazione accettabile è rappresentata da un server virtuale SMTP di Exchange in ascolto su più porte.

Per visualizzare o modificare la porta di attesa del server virtuale SMTP

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  4. Selezionare la scheda Generale e fare clic su Avanzate.

  5. Verrà visualizzato un elenco degli indirizzi IP e delle porte.

    • Per modificare la porta esistente, selezionare l'indirizzo IP quindi fare clic su Modifica. Modificare il valore nel campo Porta TCP impostandolo su 25.

    • Per aggiungere la porta 25 come porta di attesa aggiuntiva, fare clic su Aggiungi, quindi aggiungere la nuova combinazione indirizzo IP/porta. Se si utilizzano i filtri destinatario, mittente e connessione, assicurarsi di selezionare le caselle di controllo appropriate.

  6. Fare clic su OK per salvare le modifiche, quindi fare clic su OK per uscire dalla finestra di dialogo Avanzate.

  7. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Avviso di errore nel messaggio SMTP: errore generale dei messaggi di posta scartata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave BadmailedMessagesGeneralFailure. Il valore di questa chiave rappresenta il numero di messaggi inviati alla directory della posta scartata per motivi non associati a un contatore specifico. La directory della posta scartata viene utilizzata per archiviare i messaggi non recapitati. Per ulteriori informazioni su alcuni tra gli altri contatori WMI di posta scartata, consultare i seguenti articoli su Exchange Server Analyzer:

  • Avviso di errore nel messaggio SMTP - Soglia conteggio hop per i messaggi di posta scartata

  • Avviso di errore nel messaggio SMTP: messaggi NDR di DSN in posta scartata

Alcuni contatori registrano un incremento anche quando viene inviato un messaggio nella directory della posta scartata per altri motivi, tra cui un file di prelievo errato, assenza di destinatari e messaggi generati tramite evento.

Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer determina che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di BadmailedMessagesGeneralFailure diviso per il valore di SystemUpTime è maggiore di 1000, verrà visualizzato un avviso.

Tale messaggio indica che circa 1.000 o più messaggi al giorno sono contrassegnati come non recapitati e archiviati nella cartella della posta scartata. È necessario eliminare manualmente i messaggi contenuti nella directory della posta scartata. È consigliabile eseguire controlli sistematici ed eliminare i messaggi dalla directory della posta scartata come parte della regolare manutenzione di Exchange Server. Se non vengono poste limitazioni alla dimensione della directory di posta scartata, verrà occupato l'intero spazio disponibile su disco con conseguente disinstallazione dei database di Exchange.

Per risolvere il problema

  1. Analizzare i messaggi nella directory della posta scartata per determinare se l'origine del messaggio è interna o esterna. I messaggi contenuti nella directory della posta scartata sono archiviati in formato ASCII e possono essere aperti e visualizzati con Blocco Note o con un altro editor di testo.

    • Se i messaggi sembrano generati internamente, è possibile esaminarne le intestazioni per determinarne l'origine.

    • Se i messaggi sembrano generati esternamente, può significare che il server di Exchange viene utilizzato come server per l'inoltro di posta.

Per ulteriori informazioni sul controllo e sulla configurazione delle opzioni di inoltro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 310380, "HOW TO: Impedire l'utilizzo di Exchange 2000 per l'inoltro della posta in Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380.

  • 313395, "HOW TO: Esaminare le limitazioni di inoltro per connessioni SMTP anonime e filtrare messaggi di posta elettronica non richiesti in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395.

Per ulteriori informazioni sulla disinstallazione del database a causa di spazio su disco insufficiente, consultare l'articolo 321825 della Microsoft Knowledge Base "I database vengono disinstallati per mancanza di spazio su disco" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825.


Avviso di errore nel messaggio SMTP - Soglia conteggio hop per i messaggi di posta scartata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave BadmailedMessagesHopCountExceeded. Il valore di questa chiave rappresenta il numero di messaggi inviati alla directory della posta scartata poiché avevano superato il numero massimo di hop consentiti. La directory della posta scartata viene utilizzata per memorizzare i messaggi non recapitati. Per ulteriori informazioni su alcuni tra gli altri contatori WMI di posta scartata, consultare gli articoli su Exchange Server Analyzer, Avviso di errore nel messaggio SMTP: errore generale dei messaggi di posta scartata e Avviso di errore nel messaggio SMTP: messaggi NDR di DSN in posta scartata.

Alcuni contatori registrano un incremento anche quando viene inviato un messaggio nella directory della posta scartata per altri motivi, tra cui un file di prelievo errato, assenza di destinatari e messaggi generati tramite evento.

Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer rileva che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di BadmailedMessagesHopCountExceeded diviso per il valore di SystemUpTime è maggiore di 100, verrà visualizzato un avviso.

L'avviso indica che una media di 100 o più messaggi al giorno vengono contrassegnati come non recapitati e archiviati nella directory della posta scartata poiché superano il numero massimo di hop. Il numero massimo di hop corrisponde al numero massimo di server SMTP attraverso i quali può passare un messaggio nel percorso dal mittente al destinatario. Ogni volta che un messaggio passa attraverso un server SMTP, all'intestazione del messaggio viene una aggiunta una riga di testo che rappresenta l'hop.

Il numero ottimale di hop varia in base alla topologia della rete e alle esigenze di messaggistica. Per impedire che un messaggio venga ripetutamente indirizzato in modo errato (una condizione nota come ciclo di messaggi), un amministratore può controllare il numero massimo di hop consentiti. Questa operazione può essere eseguita impostando un numero massimo di hop per il server virtuale SMTP. In Exchange 2000 Server il numero di hop predefinito è 15, mentre in Exchange Server 2003 il valore predefinito è 30. Si consiglia di impostare il valore 30 per i server virtuali SMTP sia in Exchange 2000 Server sia in Exchange Server 2003.

È necessario eliminare manualmente i messaggi contenuti nella directory della posta scartata. È consigliabile eseguire controlli sistematici ed eliminare i messaggi dalla directory della posta scartata come parte della regolare manutenzione di Exchange Server. Se si consente alla directory di posta scartata di aumentare senza alcuna limitazione, verrà occupato tutto lo spazio disponibile su disco con conseguente disinstallazione dei database di Exchange.

Per risolvere il problema

  1. Esaminare i messaggi nella directory della posta scartata per determinare se l'origine del messaggio è interna o esterna. I messaggi contenuti nella directory della posta scartata sono archiviati in formato ASCII e possono essere aperti e visualizzati con Blocco Note o con un altro editor di testo.

    • Se i messaggi sembrano generati internamente, è possibile esaminarne le intestazioni per determinarne l'origine.

    • Se i messaggi sembrano generati esternamente, può significare che il server di Exchange viene utilizzato come server per l'inoltro di posta.

  2. Impostare su 30 il valore del numero massimo di hop.

    1. Aprire Gestore di sistema di Exchange.

    2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

    3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

    4. Selezionare la scheda Recapito e fare clic su Avanzate.

    5. Immettere il valore desiderato nel campo Numero massimo di passaggi (hop) e fare clic su OK per salvare le modifiche.

    6. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sul controllo e sulla configurazione delle opzioni di inoltro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 310380, "HOW TO: Impedire l'utilizzo di Exchange 2000 per l'inoltro della posta in Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=310380.

  • 313395, "HOW TO: Esaminare le limitazioni di inoltro per connessioni SMTP anonime e filtrare messaggi di posta elettronica non richiesti in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=313395.

Per ulteriori informazioni sulla disinstallazione dei database a causa di spazio su disco insufficiente, consultare l'articolo 321825 della Microsoft Knowledge Base "Disinstallazione dei database per mancanza di spazio su disco" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=321825.


Avviso di errore nel messaggio SMTP: messaggi NDR di DSN in posta scartata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-23

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave BadmailedMessagesNDRofDSN. Il valore della chiave rappresenta il numero dei messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) inviati alla directory della posta scartata perché non recapitati. La directory della posta scartata viene utilizzata per archiviare i messaggi non recapitati. Per ulteriori informazioni su alcuni degli altri contatori WMI di posta scartata, consultare gli articoli su Exchange Server Analyzer Avviso di errore nel messaggio SMTP: errore generale dei messaggi di posta scartata e Avviso di errore nel messaggio SMTP - Soglia conteggio hop per i messaggi di posta scartata.

Alcuni contatori registrano un incremento anche quando viene inviato un messaggio nella directory della posta scartata per altri motivi quali, ad esempio, un file di prelievo errato, assenza di destinatari e messaggi generati tramite evento.

Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer rileva che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di BadmailedMessagesNDRofDSN diviso per il valore di SystemUpTime è maggiore di 1000, verrà visualizzato un avviso.

L'avviso indica che nella directory della posta scartata vengono archiviati in media 1.000 o più messaggi DSN al giorno perché non possono essere recapitati. È necessario eliminare manualmente i messaggi contenuti nella directory della posta scartata. È consigliabile eseguire controlli sistematici ed eliminare i messaggi dalla directory della posta scartata come parte della regolare manutenzione di Exchange Server. Se non vengono poste limitazioni alla dimensione della directory di posta scartata, verrà occupato l'intero spazio disponibile su disco con conseguente disinstallazione dei database di Exchange.

Per risolvere il problema

  • Analizzare i messaggi nella directory della posta scartata per determinare se i messaggi DSN sono per destinatari interni o esterni. I messaggi contenuti nella cartella di posta scartata sono archiviati in formato ASCII e possono essere aperti e visualizzati con Blocco Note o con un altro editor di testo.

    • Se i messaggi DSN sono per destinatari interni, significa che si è verificato un problema di flusso dei messaggi. La risoluzione di questo problema dipenderà dallo specifico codice numerico restituito con il DSN.

    • Se i messaggi DSN sono per destinatari esterni, può significare che il server Exchange è utilizzato come server per l'inoltro di posta. Anche la risoluzione di questo problema dipenderà dal codice numerico restituito.

Per ulteriori informazioni sui codici numerici restituiti di DSN recapitati, vedere l'articolo 284204 della Microsoft Knowledge Base Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server.

Per ulteriori informazioni sul controllo e sulla configurazione delle opzioni di inoltro, vedere l'articolo 313395 della Microsoft Knowledge Base Esaminare le limitazioni di inoltro per connessioni SMTP anonime e filtrare messaggi di posta elettronica non richiesti in Exchange 2000 Server.

Per ulteriori informazioni sulla disinstallazione dei database a causa di spazio su disco insufficiente, vedere l'articolo 321825 della Microsoft Knowledge Base Disinstallazione dei database per mancanza di spazio su disco.


Avviso di errore nel messaggio SMTP - Ricerche degli indirizzi del classificatore non riuscite
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-03-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave CatAddresslookupsnotfound. Il valore di questa chiave rappresenta il numero di ricerche degli indirizzi eseguite dai contatori di prestazioni che non hanno rilevato alcun oggetto servizio directory. Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer determina che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di CatAddresslookupsnotfound diviso per il valore di SystemUpTime è maggiore di 5000, verrà visualizzato un avviso.

I messaggi in arrivo da un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. Il classificatore è un insieme di eventi sink in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. È in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali, di generare notifiche sullo stato del recapito, di rilevare, moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Questo avviso indica che una media di 5.000 o più ricerche degli indirizzi eseguite dai contatori non riesce ogni giorno. Questa situazione può verificarsi per diverse cause, inclusi i problemi di accesso al servizio directory (DSAccess), la latenza o gli errori della replica di directory, l'attacco con dizionario alle directory, i problemi con DNS o l'utilizzo di indirizzi errati.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Esaminare i registri eventi sul computer Exchange Server per verificare la presenza di errori.

  2. Se non vengono rilevati eventi che consentono di risolvere il problema, provare a impostare su Massimo il livello di registrazione diagnostica sul classificatore di MSExchangeTransport. Dopo aver abilitato la registrazione diagnostica, controllare nuovamente i registri eventi per verificare la presenza di errori. Se impostando la registrazione diagnostica sul livello massimo non viene generata alcuna voce nel registro eventi, utilizzare il Registro di sistema per impostare la registrazione sul livello 7. Quando è impostata sul livello 7, verrà registrato l'ID evento 9000 generato dal classificatore dei messaggi. In tale ID evento sono indicati la funzione, il motivo dell'errore, il nome del destinatario per cui si è verificato l'errore e il tipo di destinatario. Per impostare la registrazione diagnostica sul livello 7:

    1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    2. Passare a:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Nel riquadro destro fare doppio clic su 2 Categorizer, impostare il valore su 7 quindi fare clic su OK.

    4. Chiudere l'editor del Registro di sistema.

      Nota:
      Al termine della risoluzione dei problemi, reimpostare su 0 il valore di 2 Categorizer.

  3. Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  4. Analizzare tutti i messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, Non-Delivery Report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  5. Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  6. Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  7. Controllare i contatori di prestazioni del classificatore utilizzando Monitor di sistema.

Per un elenco delle notifiche sullo stato del recapito (DSN, delivery status notification) e dei rapporti di mancato recapito generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzo del Centro di verifica messaggi per verificare un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Attivazione della verifica messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, "ID evento di verifica messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, "Funzionalità di verifica messaggi migliorate in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare "Support WebCast: Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (informazioni in lingua inglese).

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821910, "Risoluzione dei problemi di trasporto in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "XCON: Risoluzione dei problemi di trasporto per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.

Per ulteriori informazioni su alcuni degli altri contatori WMI del classificatore, consultare i seguenti articoli su Exchange Server Analyzer:

  • Avviso di errore nel messaggio SMTP - Errore del servizio directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore di accesso alla directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore irreversibile del classificatore

  • Avviso di errore nel messaggio SMTP - Errore di memoria insufficiente del classificatore

  • Avviso di errore nel messaggio SMTP - Errore probabilmente non irreversibile del classificatore


Avviso di errore nel messaggio SMTP - Errore di accesso alla directory del classificatore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave CatCategorizationsfailedDSlogonfailure. Il valore di questa chiave rappresenta il numero di categorizzazioni non riuscite a causa di un errore di accesso al servizio directory. Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer determina che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di CatCategorizationsfailedDSlogonfailure diviso per il valore di SystemUpTime è maggiore di 50, verrà visualizzato un avviso.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di eventi sink in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. È in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali, di generare notifiche sullo stato del recapito, di rilevare, moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Questo avviso indica che, ogni giorno, circa 50 o più tentativi di connessione del servizio directory del classificatore hanno esito negativo a causa di errori di accesso. Questo può essere determinato da una serie di cause, inclusi problemi di accesso al servizio directory (DSAccess), ritardo o errori di replica della directory, server di catalogo globali sovraccarichi e problemi di DNS.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Controllare i registri eventi sul computer su cui è in esecuzione Exchange Server per verificare la presenza di errori.

  2. Se non vengono rilevati eventi che consentono di risolvere il problema, impostare su Massimo il livello di registrazione diagnostica sul classificatore di MSExchangeTransport. Non appena è attivata la registrazione diagnostica, ricontrollare eventuali errori nel registro eventi. Se impostando la registrazione diagnostica sul livello massimo non viene generata alcuna voce del registro eventi, utilizzare il Registro di sistema per impostare la registrazione sul livello 7. Una volta impostata sul livello 7, verrà registrato l'ID evento 9000 generato dal classificatore dei messaggi. In tale ID evento sono indicati la funzione, il motivo dell'errore, il nome del destinatario per cui si è verificato l'errore e il tipo di destinatario. Per impostare la registrazione diagnostica sul livello 7:

    1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    2. Passare a:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Nel riquadro destro fare doppio clic su 2 Categorizer, impostare il valore su 7 quindi fare clic su OK.

    4. Chiudere l'editor del Registro di sistema.

      Nota:
      Al termine della risoluzione dei problemi, reimpostare su 0 il valore di 2 Categorizer.

  3. Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  4. Analizzare tutti i messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, Non-Delivery Report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  5. Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  6. Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  7. Controllare i contatori di prestazioni del classificatore utilizzando Monitor di sistema.

Per un elenco delle notifiche sullo stato del recapito (DSN) e dei rapporti di mancato recapito (NDR) generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzo del Centro di verifica messaggi per verificare un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Attivazione della verifica messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, "ID evento di verifica messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, "Funzionalità di verifica messaggi migliorate in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare il WebCast di supporto Micorsoft "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (informazioni in lingua inglese).

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821910, "Risoluzione dei problemi di trasporto in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "XCON: Risoluzione dei problemi di trasporto per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.

Per ulteriori informazioni su alcuni degli altri contatori WMI del Classificatore, consultare i seguenti articoli su Exchange Server Analyzer:

  • Avviso di errore nel messaggio SMTP - Errore del servizio directory del classificatore

  • Avviso di errore nel messaggio SMTP - Ricerche degli indirizzi del classificatore non riuscite

  • Avviso di errore nel messaggio SMTP - Errore irreversibile del classificatore

  • Avviso di errore nel messaggio SMTP - Errore di memoria insufficiente del classificatore

  • Avviso di errore nel messaggio SMTP - Errore probabilmente non irreversibile del classificatore


Avviso di errore nel messaggio SMTP - Errore del servizio directory del classificatore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-03-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Win32_PerfRawData_SMTPSVC_SMTPServer WMI (Strumentazione gestione Windows®) per determinare il valore della chiave CatCategorizationsfailedDSconnectionfailure chiave. Il valore di questa chiave rappresenta il numero di categorizzazioni non riuscite a causa di un errore di accessos al servizio directory. A sua volta, Exchange Server Analyzer esegue una query nella Win32_PerfRawData_PerfOS_System classe WMI (Strumentazione gestione Windows®) per determinare il valore di SystemUpTime.

Se Exchange Server Analyzer determina che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di CatCategorizationsfailedDSconnectionfailure diviso per il valore di SystemUpTime è maggiore di 50, verrà visualizzato un avviso.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di eventi sink in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. È in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali, di generare notifiche sullo stato del recapito, di rilevare, moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Questo avviso indica che, ogni giorno, circa 50 o più tentativi di connessione del servizio directory del classificatore hanno esito negativo. Questa situazione può verificarsi per diverse cause, inclusi i problemi con l'accesso al servizio directory (DSAccess), la latenza o gli errori della replica di directory, i server di catalogo globale in condizioni di sovraccarico e i problemi con DNS.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Esaminare i registri eventi sul computer Exchange Server per verificare la presenza di errori.

  2. Se non vengono rilevati eventi che consentono di risolvere il problema, provare a impostare su Massimo il livello di registrazione diagnostica sul classificatore di MSExchangeTransport. Non appena è attivata la registrazione diagnostica, ricontrollare eventuali errori nel registro eventi. Se impostando la registrazione diagnostica sul livello massimo non viene generata alcuna voce nel registro eventi, utilizzare il Registro di sistema per impostare la registrazione sul livello 7. Quando è impostata sul livello 7, verrà registrato l'ID evento 9000 generato dal classificatore dei messaggi. In tale ID evento sono indicati la funzione, il motivo dell'errore, il nome del destinatario per cui si è verificato l'errore e il tipo di destinatario. Per impostare la registrazione diagnostica sul livello 7:

    1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    2. Passare a:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Nel riquadro destro fare doppio clic su 2 Categorizer, impostare il valore su 7 quindi fare clic su OK.

    4. Chiudere l'editor del Registro di sistema.

      Nota:
      Al termine della risoluzione dei problemi, reimpostare su 0 il valore di 2 Categorizer.

  3. Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  4. Analizzare tutti i messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, Non-Delivery Report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  5. Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  6. Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  7. Controllare i contatori di prestazioni del classificatore utilizzando Monitor di sistema.

Per un elenco delle notifiche sullo stato del recapito (DSN) e dei rapporti di mancato recapito (NDR) generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzo del Centro di verifica messaggi per verificare un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Attivazione della verifica messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, "ID evento di verifica messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, "Funzionalità di verifica messaggi migliorate in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare il WebCast di supporto Micorsoft "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (informazioni in lingua inglese).

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821910, "Risoluzione dei problemi di trasporto in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "XCON: Risoluzione dei problemi di trasporto per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.

Per ulteriori informazioni su alcuni degli altri contatori WMI del classificatore, consultare i seguenti articoli su Exchange Server Analyzer:

  • Avviso di errore nel messaggio SMTP - Ricerche degli indirizzi del classificatore non riuscite

  • Avviso di errore nel messaggio SMTP - Errore di accesso alla directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore irreversibile del classificatore

  • Avviso di errore nel messaggio SMTP - Errore di memoria insufficiente del classificatore

  • Avviso di errore nel messaggio SMTP - Errore probabilmente non irreversibile del classificatore


Avviso di errore nel messaggio SMTP - Errore irreversibile del classificatore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave CatCategorizationsfailednonretryableerror. Il valore di questa chiave rappresenta il numero di categorizzazioni non riuscite a causa di un errore hardware. Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer determina che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di CatCategorizationsfailednonretryableerror diviso per il valore di SystemUpTime è maggiore di 50, verrà visualizzato un avviso.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di eventi sink in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. È in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali, di generare notifiche sullo stato del recapito, di rilevare, moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Questo avviso indica che ogni giorno si verifica una media di 50 o più errori hardware. Questa situazione può verificarsi per diverse cause, inclusi i problemi con l'accesso al servizio directory (DSAccess), la latenza o gli errori della replica di directory, i server di catalogo globale in condizioni di sovraccarico e i problemi con DNS.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Controllare i registri eventi sul computer su cui è in esecuzione Exchange Server per verificare la presenza di errori.

  2. Se non vengono rilevati eventi che consentono di risolvere il problema, impostare su Massimo il livello di registrazione diagnostica sul classificatore di MSExchangeTransport. Dopo aver abilitato la registrazione diagnostica, controllare nuovamente i registri eventi per verificare la presenza di errori. Se impostando la registrazione diagnostica sul livello massimo non viene generata alcuna voce del registro eventi, utilizzare il Registro di sistema per impostare la registrazione sul livello 7. Una volta impostata sul livello 7, verrà registrato l'ID evento 9000 generato dal classificatore dei messaggi. In tale ID evento sono indicati la funzione, il motivo dell'errore, il nome del destinatario per cui si è verificato l'errore e il tipo di destinatario. Per impostare la registrazione diagnostica sul livello 7:

    1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    2. Passare a:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Nel riquadro destro fare doppio clic su 2 Categorizer, impostare il valore su 7 quindi fare clic su OK.

    4. Chiudere l'editor del Registro di sistema.

      Nota:
      Al termine della risoluzione dei problemi, reimpostare su 0 il valore di 2 Categorizer.

  3. Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  4. Analizzare tutti i messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, Non-Delivery Report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  5. Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  6. Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  7. Controllare i contatori di prestazioni del classificatore utilizzando Monitor di sistema.

Per un elenco delle notifiche sullo stato del recapito (DSN, delivery status notification) e dei rapporti di mancato recapito generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzo del Centro di verifica messaggi per verificare un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Attivazione della verifica messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, "ID evento di verifica messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, "Funzionalità di verifica messaggi migliorate in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare il WebCast di supporto Micorsoft "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (informazioni in lingua inglese).

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821910, "Risoluzione dei problemi di trasporto in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "XCON: Risoluzione dei problemi di trasporto per Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.

Per ulteriori informazioni su alcuni tra gli altri contatori WMI del classificatore, consultare i seguenti articoli su Exchange Server Analyzer:

  • Avviso di errore nel messaggio SMTP - Ricerche degli indirizzi del classificatore non riuscite

  • Avviso di errore nel messaggio SMTP - Errore di accesso alla directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore del servizio directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore di memoria insufficiente del classificatore

  • Avviso di errore nel messaggio SMTP - Errore probabilmente non irreversibile del classificatore


Avviso di errore nel messaggio SMTP - Errore di memoria insufficiente del classificatore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-03-28

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave CatCategorizationsfailedOutOfMemory. Il valore di questa chiave rappresenta il numero di categorizzazioni non riuscite a causa di una mancanza di memoria disponibile. Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer determina che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di CatCategorizationsfailedOutOfMemory diviso per il valore di SystemUpTime è maggiore di 50, verrà visualizzato un avviso.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di eventi sink in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. È in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali, di generare notifiche sullo stato del recapito, di rilevare, moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Questo avviso indica che ogni giorno, in media, 50 o più categorizzazioni hanno esito negativo a causa della mancanza di memoria disponibile. Questa situazione può verificarsi per diverse cause, inclusi i problemi con l'accesso al servizio directory (DSAccess), la latenza o gli errori della replica di directory, i server di catalogo globale in condizioni di sovraccarico e i problemi con DNS.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Controllare i registri eventi sul computer su cui è in esecuzione Exchange Server per verificare la presenza di errori.

  2. Se non vengono rilevati eventi che consentono di risolvere il problema, impostare su Massimo il livello di registrazione diagnostica sul classificatore di MSExchangeTransport. Dopo aver abilitato la registrazione diagnostica, controllare nuovamente i registri eventi per verificare la presenza di errori. Se impostando la registrazione diagnostica sul livello massimo non viene generata alcuna voce del registro eventi, utilizzare il Registro di sistema per impostare la registrazione sul livello 7. Se impostata sul livello 7, verrà registrato l'ID evento 9000 generato dal classificatore dei messaggi. In tale ID evento sono indicati la funzione, il motivo dell'errore, il nome del destinatario per cui si è verificato l'errore e il tipo di destinatario. Per impostare la registrazione diagnostica sul livello 7:

    1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe

    2. Passare a:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Nel riquadro destro fare doppio clic su 2 Categorizer, impostare il valore su 7 quindi fare clic su OK.

    4. Chiudere l'editor del Registro di sistema.

      Nota:
      Al termine della risoluzione dei problemi, reimpostare su 0 il valore di 2 Categorizer.

  3. Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  4. Analizzare tutti i messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, Non-Delivery Report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  5. Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  6. Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  7. Controllare i contatori di prestazioni del classificatore utilizzando Monitor di sistema.

Per un elenco delle notifiche sullo stato del recapito (DSN) e dei rapporti di mancato recapito (NDR) generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzo del Centro di verifica messaggi per verificare un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Come attivare la verifica di messaggi in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, "ID evento di verifica messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, "Funzionalità di verifica messaggi migliorate in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare il Webcast di supporto Microsoft "Exchange 2000 Server: Risoluzione dei problemi relativi al classificatore dei messaggi e ai rapporti di mancato recapito (NDR)" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137.

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821910, "Risoluzione dei problemi di trasporto in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "Risoluzione dei problemi generali di trasporto in Exchange 2000 Server e in Exchange Server 2003", all'indirizzo http://go.microsoft.com/fwlink/?linkid=305 2&kbid=257265.

I contatori di prestazioni del classificatore dei messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore dei messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.

Per ulteriori informazioni su alcuni tra gli altri contatori WMI del classificatore, consultare i seguenti articoli su Exchange Server Analyzer:

  • Avviso di errore nel messaggio SMTP - Ricerche degli indirizzi del classificatore non riuscite

  • Avviso di errore nel messaggio SMTP - Errore di accesso alla directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore del servizio directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore irreversibile del classificatore

  • Avviso di errore nel messaggio SMTP - Errore probabilmente non irreversibile del classificatore


Avviso di errore nel messaggio SMTP - Errore probabilmente non irreversibile del classificatore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-03-20

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_PerfRawData_SMTPSVC_SMTPServer per determinare il valore della chiave CatCategorizationsfailedretryableerror. Il valore di questa chiave rappresenta il numero di categorizzazioni non riuscite a causa di un errore probabilmente non irreversibile. Tramite Exchange Server Analyzer viene anche eseguita una query nella chiave WMI (Strumentazione gestione Windows®) di Win32_PerfRawData_PerfOS_System per stabilire il valore di SystemUpTime.

Se Exchange Server Analyzer rileva che il valore della chiave SystemUpTime è maggiore di 0 e che il risultato del valore di CatCategorizationsfailedretryableerror diviso per il valore di SystemUpTime è maggiore di 500, verrà visualizzato un avviso.

I messaggi in arrivo su un server SMTP vengono esaminati dal classificatore dei messaggi, il quale quindi stabilisce le operazioni da eseguire sui messaggi stessi. I messaggi possono essere destinati all'archivio informazioni locale, a un host remoto utilizzando l'Agente di trasferimento messaggi (MTA) oppure a un host remoto utilizzando il protocollo SMTP. Il classificatore è inoltre in grado di gestire l'espansione della lista di distribuzione. Il classificatore è un plug-in del motore di accodamento avanzato in grado di eseguire query LDAP (Lightweight Directory Access Protocol) nei server di catalogo globale sulla porta TCP 3268. In sostanza, il classificatore è un insieme di eventi sink in grado di eseguire un'avanzata risoluzione degli indirizzi per ogni messaggio che passa attraverso il motore di accodamento avanzato. È in grado di risolvere gli indirizzi, di inoltrare la posta, di impostare flag di conversione del contenuto, di espandere liste di distribuzione, di applicare le impostazioni globali, di generare notifiche sullo stato del recapito, di rilevare, moltiplicare, inserire nel diario l'invio a destinatari alternativi e di eseguire molte altre funzioni.

Quando un messaggio entra nel classificatore, viene risolto il mittente della busta tramite una ricerca dell'indirizzo negli attributi dell'indirizzo proxy nel servizio directory di Active Directory®. Il classificatore dei messaggi è inoltre in grado di risolvere il destinatario della busta tramite la ricerca di ogni indirizzo nell'attributo degli indirizzi proxy in Active Directory. Ad esempio, se nell'elenco è inclusa una lista di distribuzione e nel server è consentito espandere la lista di distribuzione, l'elenco verrà espanso per includere i membri della lista di distribuzione.

Questo avviso indica che una media di 500 o più categorizzazioni non riesce ogni giorno a causa di un errore probabilmente non irreversibile. Questo può essere determinato da una serie di cause, inclusi problemi di accesso al servizio directory (DSAccess), ritardo o errori di replica della directory, server di catalogo globali sovraccarichi e problemi di DNS.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Controllare i registri eventi sul computer su cui è in esecuzione Exchange Server per verificare la presenza di errori.

  2. Se non vengono rilevati eventi che consentono di risolvere il problema, impostare su Massimo il livello di registrazione diagnostica sul classificatore di MSExchangeTransport. Dopo aver abilitato la registrazione diagnostica, controllare nuovamente i registri eventi per verificare la presenza di errori. Se impostando la registrazione diagnostica sul livello massimo non viene generata alcuna voce del registro eventi, utilizzare il Registro di sistema per impostare la registrazione sul livello 7. Se impostata sul livello 7, verrà registrato l'ID evento 9000 generato dal classificatore dei messaggi. In tale ID evento sono indicati la funzione, il motivo dell'errore, il nome del destinatario per cui si è verificato l'errore e il tipo di destinatario. Per impostare la registrazione diagnostica sul livello 7:

    1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

    2. Passare a:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeTransport\Diagnostics

    3. Nel riquadro destro fare doppio clic su 2 Categorizer, impostare il valore su 7 quindi fare clic su OK.

    4. Chiudere l'editor del Registro di sistema.

      Nota:
      Al termine della risoluzione dei problemi, reimpostare su 0 il valore di 2 Categorizer.

  3. Verificare che il server di Exchange disponga della connettività a uno o più server di catalogo globale. Lo strumento Network Monitor di Windows è molto utile a questo scopo.

  4. Analizzare tutti i messaggi DSN che vengono generati. I messaggi DSN, che possono includere rapporti di mancato recapito (NDR, Non-Delivery Report), comprendono messaggi di errore permanente e messaggi di errore temporaneo che spesso diventano errori permanenti di recapito.

  5. Utilizzare la funzione di verifica messaggi per risolvere i problemi dei messaggi bloccati nel classificatore.

  6. Utilizzare lo strumento Archive Sink per archiviare e analizzare messaggi in arrivo e in uscita da Exchange Server.

  7. Controllare i contatori di prestazioni del classificatore utilizzando System Monitor.

Per un elenco delle notifiche sullo stato del recapito (DSN, delivery status notification) e dei rapporti di mancato recapito generati da Exchange Server e Microsoft Windows Small Business Server, consultare l'articolo 284204 della Microsoft Knowledge Base "Notifiche sullo stato del recapito (DNS) in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=284204.

Per informazioni sull'utilizzo del Centro di verifica messaggi in Exchange Server, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 262162, "XADM: Utilizzo del Centro di verifica messaggi per tenere la traccia di un messaggio" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=262162.

  • 246856, "XADM: Attivazione della verifica dei messaggi in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246856.

  • 821905, "ID evento di verifica dei messaggi in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821905.

  • 823864, "Funzionalità di verifica messaggi migliorate in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823864.

Per ulteriori informazioni sulla risoluzione dei problemi relativi al classificatore dei messaggi, consultare la presentazione tecnica online (WebCast) del supporto Micorsoft "Exchange 2000 Server: Message Categorizer and NDR Troubleshooting" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329137 (informazioni in lingua inglese).

Per ulteriori informazioni sullo strumento Archive Sink, consultare l'articolo 307798 della Microsoft Knowledge Base "L'utilità Archive Sink è disponibile nel Service Pack 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=307798.

Per informazioni generali sulla risoluzione dei problemi relativi al trasporto, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 821910, "Risoluzione dei problemi di trasporto in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821910.

  • 257265, "XCON: Risoluzione generale dei problemi di trasporto in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=257265.

I contatori di prestazioni del classificatore di messaggi vengono pubblicati separatamente in base all'istanza del server SMTP virtuale. Per un elenco dei contatori di prestazioni disponibili relativi al classificatore di messaggi, consultare l'articolo 231734 della Microsoft Knowledge Base "XCON: Contatori di Performance Monitor per il classificatore dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=231734.

Per ulteriori informazioni su alcuni tra gli altri contatori WMI del classificatore, consultare i seguenti articoli su Exchange Server Analyzer Tool:

  • Avviso di errore nel messaggio SMTP - Ricerche degli indirizzi del classificatore non riuscite

  • Avviso di errore nel messaggio SMTP - Errore di accesso alla directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore del servizio directory del classificatore

  • Avviso di errore nel messaggio SMTP - Errore irreversibile del classificatore

  • Avviso di errore nel messaggio SMTP - Errore di memoria insufficiente del classificatore


Scrittura dei dati della coda di posta SMTP in una cartella compressa
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Compressed per la cartella della coda di posta SMTP. Se Exchange Server Analyzer rileva che il valore di Compressed è impostato su True, verrà visualizzato un avviso.

Se nel computer che esegue Exchange arrivano messaggi tramite il servizio SMTP, i dati vengono scritti sul disco rigido come un file con estensione EML. Per impostazione predefinita, questi file vengono memorizzati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange. Se nella cartella in cui è archiviata la coda di posta SMTP è attivata la compressione dei file, le prestazioni di Exchange potrebbero essere significativamente compromesse. Pertanto, la compressione della cartella in cui è archiviata la coda di posta SMTP non è supportata.

Microsoft non supporta l'archiviazione di file di dati di Exchange in un volume compresso. Quando si esegue l'archiviazione dei file di dati di Exchange in un volume compresso, il sovraccarico aggiuntivo influisce notevolmente sulle prestazioni di Exchange. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per disattivare la compressione dei file in una specifica cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file e scegliere Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

Per spostare la cartella Mailroot in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic su Gruppi amministrativi ed espandere il proprio gruppo amministrativo, Server, il proprio server, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Arresta.

  4. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Nella scheda Messaggi, accanto alla casella Directory della coda, fare clic su Sfoglia, quindi digitare il percorso della nuova posizione della cartella Coda.

  6. Fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start.

Per ulteriori informazioni sullo spostamento della cartella della directory principale di posta, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.


Scrittura dei dati della coda di posta SMTP in una cartella crittografata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Encrypted per la cartella della coda di posta SMTP (Simple Mail Transfer Protocol). Se Exchange Server Analyzer rileva che il valore di Encrypted è impostato su True, verrà visualizzato un avviso.

Se nel computer che esegue Exchange arrivano messaggi tramite il servizio SMTP, i dati vengono scritti sul disco rigido come un file con estensione EML. Per impostazione predefinita, questi file vengono archiviati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange. Se nella cartella in cui è archiviata la coda di posta SMTP è attivata la crittografia, le prestazioni di Exchange potrebbero essere significativamente compromesse. Pertanto, la crittografia della cartella in cui è archiviata la coda di posta SMTP non è supportata.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in un volume crittografato EFS (Encrypting File System). Quando si esegue l'archiviazione dei file di dati di Exchange in un volume crittografato, il sovraccarico aggiuntivo influisce notevolmente sulle prestazioni di Exchange. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per proteggere i file di dati di Exchange, è consigliabile impedire l'accesso non autorizzato al computer che esegue Exchange e utilizzare il formato messaggio S/MIME per crittografare i dati dei messaggi.

Per risolvere questo problema è necessario disattivare la crittografia dei file nella cartella della coda di posta SMTP oppure spostare tale cartella in una posizione in cui la crittografia non è abilitata.

Per disattivare la crittografia dei file in una data cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la crittografia dei file e scegliere Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Crittografa contenuto per la protezione dei dati e scegliere OK.

Per spostare la cartella della coda di posta SMTP in Exchange 2000 Server o Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic su Gruppi amministrativi ed espandere il proprio gruppo amministrativo, Server, il proprio server, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Arresta.

  4. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Nella scheda Messaggi, accanto alla casella Directory della posta scartata, fare clic su Sfoglia, quindi immettere il percorso della nuova posizione della cartella Coda.

  6. Fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start.

Per ulteriori informazioni sullo spostamento della cartella della directory principale di posta, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.

Per ulteriori informazioni sui file di dati di Exchange Server e su EFS (Encrypting File System, Crittografia file system), consultare l'articolo 834638 della Microsoft Knowledge Base "Informazioni sull'archiviazione dei file di dati in un volume crittografato in Exchange Server", all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Per informazioni sulle modalità di protezione dei messaggi in Microsoft Exchange Server 2003, consultare la Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47574.


Scrittura dei dati della coda di posta SMTP in una partizione non NTFS
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave FSName per la directory della coda SMTP di Exchange. Se Exchange Server Analyzer determina che il valore della chiave FSName non equivale a NTFS, verrà visualizzato un messaggio di errore.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in volumi non NTFS. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

Se viene riscontrato questo errore, sarà necessario spostare la directory della coda SMTP in una cartella di un'unità NTFS. In alternativa, se l'unità in cui è archiviata la directory della coda è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertire l'unità in NTFS.

Per spostare la coda SMTP in un'altra cartella

  1. Aprire Gestore di sistema di Exchange.

  2. Fare clic su Gruppi amministrativi ed espandere il proprio gruppo amministrativo, Server, il proprio server, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Arresta.

  4. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Nella scheda Messaggi, accanto alla casella Directory della posta scartata, fare clic su Sfoglia, quindi immettere il percorso della nuova posizione della cartella Coda.

  6. Fare clic su OK.

  7. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start.

Per ulteriori informazioni sullo spostamento della cartella della directory principale di posta, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.

Come alternativa alla procedura descritta in questo articolo, se l'unità in cui sono archiviati i file è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertirla in unità NTFS. Per ulteriori informazioni sull'utilizzo dello strumento della riga di comando convert.exe per convertire una partizione FAT in una partizione NTFS, consultare l'articolo 214579 della Microsoft Knowledge Base: "Utilizzo di Convert.exe per convertire una partizione nel file system NTFS" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=214579.


Il valore MaxDSNSize per SMTP è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge la seguente sottochiave del Registro di sistema per determinare se la dimensione massima dei messaggi di notifica sullo stato del recapito (DSN, Delivery Status Notification) è stata sostituita manualmente:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MaxDSNSize

Se Exchange Server Analyzer rileva che MaxDSNSize è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore MaxDSNSize del Registro di sistema consente a un computer che esegue Exchange 2000 Server Service Pack 2 (SP2) o versione successiva di rimuovere gli allegati in caso di impossibilità di recapito di un messaggio. Se si abilita questa opzione, è possibile risparmiare risorse del server e di rete. Esistono, tuttavia, alcuni svantaggi nell'implementazione della rimozione di allegati SMTP.

Se si abilita questa opzione per rimuovere gli allegati dal rapporto di mancato recapito (NDR), verranno rimossi anche i dettagli necessari per la visualizzazione della notifica nel riquadro di anteprima e il mittente del messaggio non potrà utilizzare l'opzione di rinvio. Se il mittente del messaggio tenta di utilizzare tale opzione dall'NDR, verrà visualizzato il seguente messaggio di errore:

"Impossibile rinviare il messaggio. Il rapporto di mancato recapito non contiene informazioni sufficienti sul messaggio originale. Per rinviare il messaggio, aprirlo nella cartella Posta inviata, fare clic sul menu Azioni quindi su Rinvia messaggio."

Tuttavia, il mittente del messaggio non può inviarlo nuovamente, anche utilizzando il metodo menzionato nel messaggio di errore. Si consiglia, pertanto, di utilizzare questa opzione con cautela.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per modificare il valore MaxDSNSize del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Creare un valore del Registro di sistema DWORD denominato MaxDSNSize e impostarne i dati di valore (in byte) sulla quantità desiderata.

  4. Per rendere effettive le modifiche, uscire dall'editor del Registro di sistema e riavviare il servizio SMTP.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sul valore MaxDSNSize del Registro di sistema, consultare i seguenti articoli della Knowledge Base:

  • 308303, "XCON: Opzione per rimuovere gli allegati di messaggi che generano un rapporto di mancato recapito (NDR)" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=308303.

  • 323484, "XCON: Descrizione del formato dei messaggi Internet Multipart/Report in Exchange 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=323484.


Valore SMTP MaxPendingCat del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave MaxPendingCat è stata impostata, verrà visualizzato un messaggio di configurazione non predefinita.

Si consiglia di modificare i valori di accodamento predefiniti solo dopo un attento esame. Nella maggior parte degli ambienti le impostazioni predefinite sono state accuratamente selezionate per prestazioni ottimali. In genere, si consiglia di risolvere la causa principale del problema anziché modificare il comportamento di accodamento in Exchange.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team di Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


Il parametro SMTP MaxMessageObjects è stato impostato su un valore troppo basso
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare il numero massimo di messaggi di posta elettronica che possono essere allocati dal sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Se Exchange Server Analyzer rileva che il valore di MaxMessageObjects è inferiore a 30001, verrà visualizzato un avviso.

Quando una coda contiene il numero massimo di messaggi, nessun ulteriore messaggio di ingresso verrà accettato da SMTP (Simple Mail Transfer Protocol). Ciascun messaggio residente nella coda SMTP utilizza come minimo 4 kilobyte (KB) di memoria, pertanto è possibile che una scarsa disponibilità di memoria provochi una coda di grandi dimensioni.

Il valore MaxMessageObjects non è presente per impostazione predefinita e il numero massimo di messaggi è impostato su 100.000. Se si imposta MaxMessageObjects su un valore inferiore si riduce il numero massimo di messaggi che può risiedere nella coda, riducendo pertanto la superficie massima di memoria per SMTP. Quando viene raggiunto questo limite, ogni connessione SMTP al server restituirà un errore di memoria esaurita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare un limite al numero di messaggi SMTP che possono essere inseriti in coda

  1. Avviare un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Exchange

  3. Fare clic con il pulsante destro del mouse sulla chiave di Exchange quindi scegliere Nuova chiave. Denominare la nuova chiave MailMsg.

  4. Fare clic con il pulsante destro del mouse sulla chiave MailMsg e scegliere New DWORD Value.

  5. Fare clic con il pulsante destro del mouse sul nuovo valore, scegliere Rinomina, quindi digitare MaxMessageObjects.

  6. Fare doppio clic sul valore MaxMessageObjects e impostarlo sul numero massimo di messaggi che si desidera avere nelle code in qualunque momento. A meno che non sia necessario elaborare un numero maggiore di messaggi, si raccomanda un valore massimo di 100.000.

  7. Per rendere effettive le modifiche, uscire dall'editor del Registro di sistema e riavviare il servizio SMTP.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione di un limite al numero dei messaggi in coda consultare l'articolo 258748 della Knowledge Base, "Impostazione di un limite al numero dei messaggi in coda" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748.


Il parametro SMTP MaxMessageObjects del Registro di sistema è stato modificato rispetto all'impostazione predefinita
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare il numero massimo di messaggi di posta elettronica che possono essere allocati dal sistema:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\MailMsg\MaxMessageObjects

Se Exchange Server Analyzer rileva che il valore di MaxMessageObjects è maggiore di 0, verrà visualizzato un messaggio di configurazione non predefinita.

Quando una coda contiene il numero massimo di messaggi, nessun ulteriore messaggio di ingresso verrà accettato da SMTP. Ciascun messaggio residente nella coda SMTP utilizza come minimo 4 kilobyte (KB) di memoria, pertanto è possibile che una scarsa disponibilità di memoria provochi una coda di grandi dimensioni.

Il valore MaxMessageObjects non è presente per impostazione predefinita e il numero massimo di messaggi è impostato su 100.000. Se si imposta MaxMessageObjects su un valore inferiore si riduce il numero massimo di messaggi che può risiedere nella coda, riducendo pertanto la superficie massima di memoria per SMTP. Quando viene raggiunto questo limite, ogni connessione SMTP al server restituirà un errore di memoria esaurita.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per impostare un limite al numero di messaggi SMTP che possono essere inseriti in coda

  1. Avviare un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\Software\Microsoft\Exchange

  3. Fare clic con il pulsante destro del mouse sulla chiave di Exchange quindi scegliere Nuova chiave. Denominare la nuova chiave MailMsg.

  4. Fare clic con il pulsante destro del mouse sulla chiave MailMsg e scegliere New DWORD Value.

  5. Fare clic con il pulsante destro del mouse sul nuovo valore, scegliere Rinomina, quindi digitare MaxMessageObjects.

  6. Fare doppio clic sul valore MaxMessageObjects e impostarlo sul numero massimo di messaggi che si desidera avere nelle code in qualunque momento. A meno che non sia necessario elaborare un numero maggiore di messaggi, è consigliabile utilizzare un valore massimo di 100.000.

  7. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Simple Mail Transfer Protocol (SMTP).

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=256986.

Per ulteriori informazioni sull'impostazione di un limite al numero dei messaggi in coda consultare l'articolo 258748 della Knowledge Base, "Impostazione di un limite al numero dei messaggi in coda" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258748.


Il SMTP valore MaxPercentPoolThreads del Registro di sistema per SMTP è stato impostato manualmente
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare se sono stati configurati manualmente thread di pool aggiuntivi:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\MaxPercentPoolThreads

Se Exchange Server Analyzer rileva che MaxPercentPoolThreads è presente e configurato, verrà visualizzato un messaggio di configurazione non predefinita.

In SMTP sono disponibili cinque code di lavoro che utilizzano un pool di thread definiti thread ATQ. Strutturalmente, due di queste code possono utilizzare per impostazione predefinita fino al 90% dei thread disponibili. Questo pool di thread è condiviso dal processo che accetta richieste POP e IMAP. Pertanto, in uno scenario di carico moderato o elevato, si può verificare una situazione in cui SMTP è in grado di mantenere le risorse da servizi POP e IMAP.

È possibile riservare thread adeguati per POP e IMAP limitando la percentuale di thread che possono essere utilizzati da SMTP. Per effettuare questa modifica, aumentare il numero dei thread disponibili per IIS. L'unico compromesso in questo caso è un maggiore utilizzo della memoria per i thread aggiuntivi.

Esistono due valori del Registro di sistema che consentono di controllare la percentuale SMTP dei thread e dei thread aggiuntivi per processore:

Posizione: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Valore: AdditionalPoolThreadsPerProc

Tipo: REG_DWORD

Posizione: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

Valore: MaxPercentPoolThreads

Tipo: REG_DWORD

È preferibile adeguare entrambi i valori del Registro di sistema in computer Exchange Server cluster, se un'elevata attività di SMTP provoca errori di POP3, IMAP4 o entrambe le risorse. È possibile utilizzare le formule indicate di seguito per calcolare il valore ottimale per il proprio cluster:

Valore del Registro di sistema | Formula
AdditionalPoolThreadsPerProc | ((9 / (MaxPercentPoolThreads/100)) - 4) / 2
MaxPercentPoolThreads | 90 / (2 * numero di server virtuali dei protocolli)

Ad esempio, in un cluster Exchange Server con due server virtuali dei protocolli, la formula per MaxPercentPoolThreads è 90 / (2*2) = 22. Quando si calcola il valore MaxPercentPoolThreads, se il risultato è un valore che include un punto decimale, è preferibile approssimare il risultato all'intero successivo. Quando si calcola il valore AdditionalPoolThreadsPerProc, se il risultato è un valore maggiore di 200, è necessario assegnare il valore risultante anche a un valore aggiuntivo di registro:

Posizione: HKLM\System\CurrentControlSet\Services\InetInfo\Parameters\

Valore: PoolThreadLimit

Tipo: REG_DWORD

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per configurare l'impostazione ottimale nel cluster Exchange

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc\Parameters

  3. Creare un valore del Registro di sistema DWORD denominato AdditionalPoolThreadsPerProc e impostarne i dati di valore sul numero appropriato in base alle formule indicate sopra.

  4. Creare un valore del Registro di sistema DWORD denominato MaxPercentPoolThreads e impostarne i dati di valore sul numero appropriato in base alle formule indicate sopra.

  5. Per rendere effettive le modifiche, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sullo specifico problema della risorsa cluster descritto in questo articolo, consultare l'articolo 281868 della Microsoft Knowledge Base "XADM: Failover dei server virtuali POP/IMAP4 sotto carico elevato" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=281868.


Il valore SMTP MsgHandleAsyncThreshold del Registro di sistema per SMTP è stato aggiunto manualmente ma potrebbe non essere più necessario
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge le seguenti voci del Registro di sistema per determinare se il numero massimo di handle di file IIS (Internet Information Services) asincroni è stato modificato rispetto al valore predefinito di 1.000:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleAsyncThreshold

Se Exchange Server Analyzer rileva che MsgHandleAsyncThreshold è presente e configurato con un valore diverso, verrà visualizzato un avviso.

Il valore MsgHandleAsyncThreshold specifica il numero massimo di handle di file asincroni che possono essere utilizzati da IIS. Gli handle di file vengono memorizzati nella cache per migliorare le prestazioni, perché in tal modo impediscono al server di eseguire cicli di input/output (I/O) e cicli macchina ridondanti. Ogni volta che lo stack di trasporto SMTP in un computer Exchange Server riceve un messaggio, questo viene inviato al file system dove resta in attesa di essere instradato alla destinazione. Per scrivere nel file system, lo stack di trasporto SMTP ottiene un handle di file a cui passa il messaggio. Ogni handle di file occupa circa 2 kilobyte (KB) di memoria della riserva di paging. Il numero predefinito di handle di file della cache IIS è di 800 ogni 32 MB.

Prima del Service Pack 2 (SP2) per Exchange 2000 Server, le prestazioni dei server di Exchange che supportavano code di messaggi SMTP di grandi dimensioni (ad esempio, una media di 1000 o più messaggi) erano limitate a causa di un'impostazione predefinita nel servizio SMTP di un massimo di 1000 handle di file. Poiché in Exchange 2000 Server è stato impostato automaticamente un valore massimo di 1.000 handle di file, il servizio SMTP è in grado di scrivere solo 1.000 messaggi simultanei nel file system.

Per migliorare le prestazioni per questi sistemi di grandi dimensioni, spesso venivano adeguate contemporaneamente tre voci del Registro di sistema, in modo da aumentare il numero massimo di handle di file che potevano essere aperti dal servizio SMTP (per poter elaborare più messaggi) e da diminuire il numero di handle di file aperti per il file system installabile, un altro componente di Exchange (per evitare di esaurire la memoria quando la coda è di grandi dimensioni). Tali valori del Registro di sistema, che non esistevano per impostazione predefinita e pertanto dovevano essere aggiunti manualmente, sono elencati di seguito:

Percorso: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valore: MsgHandleThreshold

Tipo: REG_DWORD

Percorso: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valore: MsgHandleAsyncThreshold

Tipo: REG_DWORD

Posizione: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valore: FileCacheMaxHandles

Tipo: REG_DWORD

Le voci MsgHandleThreshold e MsgHandleAsyncThreshold vengono normalmente impostate sullo stesso valore (di solito un valore maggiore di 1.000) e il valore FileCacheMaxHandles viene normalmente ridotto da 800 a 600.

Questo valore del Registro di sistema non è presente per impostazione predefinita, poiché Exchange 2000 Server SP2 e versioni successive determinano in modo dinamico i valori ottimali da utilizzare. Se questo server di Exchange esegue Exchange 2000 Server con SP1 o versioni precedenti, è consigliabile eseguire un aggiornamento al Service Pack e all'aggiornamento cumulativo più recente. Dopo aver eseguito l'aggiornamento al codice più recente, è possibile eliminare queste voci del Registro di sistema.

Con Exchange Server 2003 vengono calcolate in modo dinamico le impostazioni appropriate per gli handle di file SMTP, in modo che tali impostazioni non siano più necessarie. Pertanto, a meno che non venga indicato diversamente dal Servizio Supporto Tecnico Clienti Microsoft, prima di eseguire l'aggiornamento di computer Exchange 2000 Server a Exchange Server 2003 con queste impostazioni è necessario eliminare queste voci dal Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per ripristinare la configurazione predefinita

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Nel riquadro destro eliminare il valore MsgHandleAsyncThreshold.

  4. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Il valore MsgHandleThreshold del Registro di sistema per SMTP è stato aggiunto manualmente ma potrebbe non essere più necessario
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se il numero massimo di handle di file IIS (Internet Information Services) è stato modificato rispetto al valore predefinito di 1.000:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing\MsgHandleThreshold

Se Exchange Server Analyzer rileva che MsgHandleThreshold è presente e configurato con un valore alternativo, verrà visualizzato un messaggio di configurazione non predefinita.

Il valore MsgHandleThreshold specifica il numero massimo di handle di file che possono essere utilizzati da IIS. Gli handle di file vengono memorizzati nella cache per migliorare le prestazioni, perché in tal modo impediscono al server di eseguire cicli di input/output (I/O) e cicli macchina ridondanti. Ogni volta che lo stack di trasporto SMTP in un computer Exchange Server riceve un messaggio, questo viene inviato al file system dove resta in attesa di essere instradato alla destinazione. Per scrivere nel file system, lo stack di trasporto SMTP ottiene un handle di file a cui passa il messaggio. Ogni handle di file occupa circa 2 kilobyte (KB) di memoria del pool di paging. Il numero predefinito di handle di file della cache IIS è di 800 ogni 32 MB.

Prima del Service Pack 2 (SP2) per Exchange 2000 Server, le prestazioni dei server di Exchange che supportavano code di messaggi SMTP di grandi dimensioni (ad esempio, una media di 1.000 o più messaggi) erano limitate a causa di un'impostazione predefinita nel servizio SMTP di un massimo di 1.000 handle di file. Poiché in Exchange 2000 Server è stato impostato automaticamente un valore massimo di 1.000 handle di file, il servizio SMTP è in grado di scrivere solo 1.000 messaggi simultanei nel file system.

Per migliorare le prestazioni per questi sistemi di grandi dimensioni, spesso venivano adeguate contemporaneamente tre voci del Registro di sistema, in modo da aumentare il numero massimo di handle di file che potevano essere aperti dal servizio SMTP (per poter elaborare più messaggi) e da diminuire il numero di handle di file aperti per il file system installabile, un altro componente di Exchange (per evitare di esaurire la memoria quando la coda è di grandi dimensioni). Tali valori del Registro di sistema, che non esistevano per impostazione predefinita e pertanto dovevano essere aggiunti manualmente, sono elencati di seguito:

Percorso: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valore: MsgHandleThreshold

Tipo: REG_DWORD

Percorso: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

Valore: MsgHandleAsyncThreshold

Tipo: REG_DWORD

Posizione: HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters

Valore: FileCacheMaxHandles

Tipo: REG_DWORD

Le voci MsgHandleThreshold e MsgHandleAsyncThreshold vengono normalmente impostate sullo stesso valore (di solito un valore maggiore di 1.000) e il valore FileCacheMaxHandles viene normalmente ridotto da 800 a 600.

Se questo server di Exchange esegue Exchange 2000 Server, è consigliabile eseguire un aggiornamento alla versione più recente del Service Pack e degli aggiornamenti cumulativi. Dopo avere eseguito l'aggiornamento alla versione più recente, è consigliabile impostare MsgHandleThreshold sul valore predefinito 1000.

Il valore predefinito di MsgHandleThreshold per Exchange Server 2003 è 1000, pertanto le impostazioni di sostituzione nel Registro di sistema non sono più necessarie. Pertanto, a meno che non venga indicato diversamente dal Servizio Supporto Tecnico Clienti Microsoft, prima di eseguire l'aggiornamento di computer Exchange 2000 Server a Exchange Server 2003 con queste impostazioni è necessario eliminare queste voci dal Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.

Per risolvere il problema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKLM\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Eliminare il valore MsgHandleThreshold.

  4. Per rendere effettiva la modifica, chiudere l'editor del Registro di sistema e riavviare il servizio Amministrazione IIS.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.


Scrittura dei file di prelievo SMTP in una cartella compressa
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Compressed per la cartella di prelievo SMTP (Simple Mail Transfer Protocol). Se Exchange Server Analyzer rileva che il valore di Compressed è impostato su True, verrà visualizzato un avviso.

Se nel computer che esegue Exchange arrivano messaggi tramite il servizio SMTP, i dati vengono scritti sul disco rigido come un file con estensione EML. Per impostazione predefinita, questi file vengono memorizzati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange. Se nella cartella in cui sono archiviati i dati di prelievo SMTP è attivata la compressione dei file, le prestazioni di Exchange potrebbero essere significativamente compromesse. Pertanto, la compressione della cartella in cui sono archiviati i dati di prelievo SMTP non è supportata.

Se viene visualizzato questo avviso, è necessario disattivare la compressione della cartella in cui sono archiviati i dati di prelievo SMTP oppure spostare tali dati in una cartella non compressa.

Microsoft non supporta l'archiviazione di file di dati di Exchange in un volume compresso. Quando si archiviano i file di dati di Exchange in un volume compresso, l'overhead aggiuntivo influenza in modo significativo le prestazioni di Exchange. I file di dati di Exchange includono tutti i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per disattivare la compressione dei file in una specifica cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la compressione dei file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

Per ulteriori informazioni sullo spostamento della cartella di prelievo, consultare l'articolo della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.


Scrittura dei file di prelievo SMTP in una cartella crittografata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave Encrypted per la cartella di prelievo SMTP (Simple Mail Transfer Protocol). Se Exchange Server Analyzer rileva che il valore di Encrypted è impostato su True, verrà visualizzato un avviso.

Se nel computer che esegue Exchange arrivano messaggi tramite il servizio SMTP, i dati vengono scritti sul disco rigido come un file con estensione EML. Per impostazione predefinita, questi file vengono memorizzati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange. Se nella cartella in cui sono archiviati i dati di prelievo SMTP è attivata la crittografia, le prestazioni di Exchange potrebbero essere significativamente compromesse. Pertanto, la crittografia della cartella in cui sono archiviati i dati di prelievo SMTP non è supportata.

Se si riceve questo avviso, è necessario disattivare la crittografia della cartella in cui sono archiviati i dati di prelievo SMTP oppure spostare i dati di prelievo SMTP in una cartella non crittografata.

Microsoft non supporta la memorizzazione dei file di dati di Exchange in un volume crittografato EFS (Encrypting File System). Quando si archiviano i file di dati di Exchange in un volume crittografato, l'overhead aggiuntivo influenza in modo significativo le prestazioni di Exchange. I file di dati di Exchange includono i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

  • File con estensione CHK

Per proteggere i file di dati di Exchange, è consigliabile impedire l'accesso non autorizzato al computer che esegue Exchange e utilizzare il formato messaggio S/MIME per crittografare i dati dei messaggi.

Per correggere questo errore è necessario disattivare la crittografia dei file nella cartella di prelievo SMTP oppure spostare tale cartella in una posizione in cui la crittografia non è abilitata.

Per disattivare la crittografia dei file in una data cartella

  1. Fare clic con il pulsante destro del mouse sulla cartella in cui si desidera disattivare la crittografia file, quindi fare clic su Proprietà.

  2. Nella scheda Generale scegliere Avanzate.

  3. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Crittografa contenuto per la protezione dei dati e scegliere OK.

Per ulteriori informazioni sullo spostamento della cartella di prelievo, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.

Per ulteriori informazioni sui file di dati di Exchange Server e su EFS (Encrypting File System, Crittografia file system), consultare l'articolo 834638 della Microsoft Knowledge Base "Informazioni sull'archiviazione dei file di dati in un volume crittografato in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=834638.

Per informazioni sulle modalità di protezione dei messaggi in Exchange Server 2003, consultare la Guida alla protezione dei messaggi di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47574.


Scrittura dei file di prelievo SMTP in una partizione non NTFS
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Directory per determinare il valore della chiave FSName per la directory PickUp SMTP di Exchange. Se Exchange Server Analyzer rileva che il valore della chiave FSName non corrisponde a NTFS, verrà visualizzato un avviso.

Microsoft non supporta l'archiviazione dei file di dati di Exchange in volumi non NTFS. I file di dati di Exchange includono i file seguenti:

  • File con estensione EDB

  • File con estensione STM

  • File con estensione LOG

  • File con estensione DAT

  • File con estensione EML

Se viene visualizzato questo avviso, sarà necessario spostare la directory di prelievo SMTP in una cartella di un'unità del file system NTFS. In alternativa, se l'unità in cui è archiviata la directory di prelievo è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertire l'unità in NTFS.

Per ulteriori informazioni sullo spostamento della cartella di prelievo, consultare l'articolo 822933 della Microsoft Knowledge Base "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=822933.

In alternativa, se l'unità in cui sono archiviati i file è formattata come unità FAT, sarà possibile utilizzare lo strumento della riga di comando convert.exe per convertire l'unità in NTFS. Per ulteriori informazioni sull'utilizzo dello strumento della riga di comando convert.exe per convertire una partizione FAT in una partizione NTFS, consultare l'articolo 214579 della Microsoft Knowledge Base: "Utilizzo di Convert.exe per convertire una partizione nel file system NTFS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=214579.


Cambio porta SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-11

Microsoft® Exchange Server Analyzer Tool legge la seguente proprietà nel metabase IIS (Internet Information Services) per determinare se il relativo valore corrisponde al valore predefinito di 25:

LM/SmtpSvc/<istanza del server virtuale SMTP>/SMTPPORT

Se Exchange Server Analyzer rileva che il valore della chiave SMTPPORT non è 25, verrà visualizzato un avviso.

La proprietà SMTPPORT rappresenta la porta TCP su cui il server SMTP (Simple Mail Transfer Protocol) è configurato per l'ascolto di connessioni in ingresso. È possibile configurare i server virtuali SMTP per l'ascolto su una o più porte TCP. Per impostazione predefinita, tutti i server virtuali SMTP sono configurati per l'ascolto sulla porta TCP 25, la porta SMTP predefinita. Se la porta di attesa SMTP viene modificata rispetto a quella predefinita e se non include più la porta TCP 25 nell'elenco delle porte di attesa, potrebbero verificarsi dei problemi nel flusso di posta.

La porta di attesa SMTP può essere modificata a condizione che anche l'intera infrastruttura di messaggistica interna venga modificata di conseguenza. In genere, tuttavia, non è possibile utilizzare porte alternative per server virtuali SMTP che accettano messaggi direttamente da Internet, dal momento che nei server SMTP in Internet i messaggi vengono inviati tramite la porta 25.

Nota:
Exchange Server Analyzer esamina il valore del server virtuale dei protocolli SMTP di Exchange. Il server virtuale dei protocolli SMTP non è necessariamente il server SMTP che riceve messaggi direttamente da Internet. Esistono alcuni prodotti antivirus e anti spam progettati per ricevere messaggi SMTP da Internet sulla porta 25 e per reindirizzarli a un server virtuale SMTP di Exchange su un'altra porta. In questo tipo di scenario, una configurazione accettabile è rappresentata da un server virtuale SMTP di Exchange in ascolto su una porta diversa dalla 25.
Per visualizzare o modificare la porta di attesa del server virtuale SMTP

  1. In Gestore di sistema di Exchange espandere Server, un server di Exchange, Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  3. Selezionare la scheda Generale e fare clic su Avanzate.

  4. Verrà visualizzato un elenco degli indirizzi IP e delle porte.

    • Per modificare la porta esistente, selezionare l'indirizzo IP quindi fare clic su Modifica. Modificare il valore nel campo Porta TCP impostandolo su 25.

    • Per aggiungere la porta 25 come porta di attesa aggiuntiva, fare clic su Aggiungi, quindi aggiungere la nuova combinazione indirizzo IP/porta. Se si utilizzano i filtri destinatario, mittente e connessione, assicurarsi di selezionare le caselle di controllo appropriate.

  5. Fare clic su OK per salvare le modifiche, quindi fare clic su OK per uscire dalla finestra di dialogo Avanzate. Fare clic su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


La cartella della coda SMTP contiene un grande numero di file
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella metabase IIS (Internet Information Services) per determinare il valore dell'attributo QueueDirectory per ogni istanza di server virtuale SMTP (Simple Mail Transfer Protocol).

Quindi Exchange Server Analyzer esegue il conteggio del numero di file contenuti nella cartella della coda specificata per ogni server virtuale SMTP.

Se Exchange Server Analyzer rileva che sono presenti almeno 50.000 file nella cartella della coda di un server virtuale SMTP, verrà visualizzato un avviso.

Se Exchange Server Analyzer rileva che sono presenti almeno 90.000 file nella cartella della coda di un server virtuale SMTP, verrà visualizzato un errore.

L'avviso o l'errore indica che si sono accumulati messaggi che devono essere elaborati dall'istanza di server virtuale SMTP. Indica, inoltre, un problema grave di prestazioni o interruzioni del server, in quanto il server non è più in grado di recapitare la posta in arrivo in tempo utile. Il ritardo può essere dovuto alle seguenti condizioni:

  • Il servizio directory di Active Directory® non è stato consultato immediatamente.

  • I messaggi non vengono gestiti immediatamente per il recapito locale o SMTP.

Per risolvere il problema:

  • Esaminare i messaggi nella cartella della coda per stabilire la legittimità e verificare che il server non sia sottoposto a un carico anomalo a causa di messaggi di posta elettronica pubblicitari non richiesti, spam o l'attacco di un virus.

  • Verificare che il servizio SMTP sia abilitato e in esecuzione.

Per verificare che il servizio SMTP sia avviato

  1. Aprire lo snap-in MMC Servizi.

  2. Nel riquadro destro scorrere fino a visualizzare il servizio SMTP (Simple Mail Transfer Protocol), quindi fare doppio clic su di esso. Verrà visualizzata la finestra di dialogo Proprietà SMTP (Simple Mail Transfer Protocol).

  3. Verificare che il valore nel menu a discesa Tipo di avvio sia impostato su Automatico.

  4. Fare clic su Start per avviare il servizio Supervisore sistema.

  5. Fare clic su OK per salvare le modifiche e chiudere la finestra di dialogo Proprietà SMTP (Simple Mail Transfer Protocol).

  6. Chiudere lo snap-in Servizi.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base sulla descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Informazoni sugli stati delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


La cartella della coda SMTP corrisponde a quella di prelievo
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per verificare che la directory dalla quale vengono prelevati i messaggi non corrisponda a quella in cui i messaggi vengono accodati per un server virtuale SMTP specifico. Se Exchange Server Analyzer rileva che l'attributo msExchSmtpQueueDirectory della directory della coda corrisponde all'attributo msExchSmtpPickupDirectory della directory di prelievo, verrà visualizzato un messaggio di errore.

Si tratta di un errore critico. Se l'attributo msExchSmtpQueueDirectory e l'attributo msExchSmtpPickupDirectory sono impostati sulla stessa directory, verranno recapitati messaggi duplicati. È possibile aggiornare questi attributi utilizzando ADSI Edit.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.
Per aggiornare l'attributo msExchSmtpPickupDirectory o msExchSmtpQueueDirectory utilizzando ADSI Edit

  1. Avviare lo strumento ADSI Edit dagli Strumenti di supporto di Windows® 2000 o di Windows Server 2003.

  2. Espandere i nodi seguenti:

    • Contenitore di configurazione

    • Configurazione

    • Servizi

    • Microsoft Exchange

    • Organization_Name

    • Criteri destinatari

    • Administrative_Group_Name

    • Server

    • Server_Name

    • Protocolli

    • SMTP

  3. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su CN=1 (dove 1 rappresenta il server virtuale SMTP predefinito), quindi scegliere Proprietà.

  4. Nell'elenco Selezionare le proprietà da visualizzare fare clic su Entrambe.

  5. Aggiornare l'attributo msExchSmtpPickupDirectory in modo tale che non sia in conflitto con msExchSmtpQueueDirectory, quindi fare clic su Imposta.

  6. Fare clic su OK, Applica, quindi chiudere ADSI Edit.

  7. Attendere almeno 15 minuti per la replica.


La coda SMTP si trova sulla stessa unità su cui si trova la partizione di sistema
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il valore configurato per l'attributo msExchSmtpQueueDirectory.

Exchange Server Analyzer esegue inoltre una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio SMTP (Simple Message Transfer Protocol). Il valore False indica che il servizio non è in esecuzione. Il valore True indica che il servizio è in esecuzione. Infine, Exchange Server Analyzer esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_OperatingSystem per determinare il valore della chiave WindowsDirectory. Il valore di questa chiave indica la posizione dell'unità di sistema Windows.

Se Exchange Server Analyzer rileva che l'attributo msExchSmtpQueueDirectory è configurato con un percorso che include l'unità di sistema, che il servizio SMTP è in esecuzione e che Exchange non viene eseguito su Microsoft Windows Small Business Server, verrà visualizzato un avviso.

L'attributo msExchSmtpQueueDirectory rappresenta il percorso della cartella della coda SMTP, anche nota come cartella Directory principale della posta. Quando al server di Exchange arrivano messaggi tramite il servizio SMTP, i dati verranno scritti sul disco rigido come file con estensione EML. Per impostazione predefinita, questi file vengono archiviati nella cartella <unità>:\Programmi\Exchsrvr\Mailroot nella stessa partizione in cui è installato Exchange.

In alcuni casi, ad esempio, quando si configura un server testa di ponte, è possibile migliorare le prestazioni del server di Exchange spostando la directory principale della posta SMTP su un disco rigido o in una partizione diversa. È consigliabile non impostare la cartella della directory principale della posta SMTP sulla stessa unità del sistema Windows. Invece, per ottenere prestazioni ottimali, è consigliabile impostarla su un disco o un sottosistema disco rapido.

Nel Gestore di sistema di Exchange è possibile spostare la cartella della directory principale della posta sul server virtuale SMTP di Exchange Server 2003. Tuttavia, per spostarla su un server virtuale SMTP di Exchange 2000 Server, è necessario utilizzare un editor di Active Directory di basso livello come, ad esempio, ADSI Edit.

Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per risolvere il problema in Exchange Server 2003

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito), quindi scegliere Arresta.

  4. Fare clic di nuovo con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Proprietà.

  5. Selezionare la scheda Messaggi.

  6. Nel campo Directory della coda specificare il percorso completo della cartella appropriata Directory principale della posta. Per individuare il percorso sul computer locale, fare clic su Sfoglia.

  7. Fare clic su OK per salvare le modifiche.

  8. Fare clic con il pulsante destro del mouse sul server virtuale SMTP, quindi scegliere Start. Verrà utilizzata immediatamente la nuova posizione.

Per risolvere il problema su Exchange 2000 Server

  1. Arrestare tutti i servizi Exchange Server e IIS sul computer Exchange 2000 Server in cui si desidera modificare la cartella Directory principale della posta del server virtuale SMTP.

  2. Modificare il valore interessato del server virtuale SMTP per msExchSmtpQueueDirectory in modo tale che sia configurato con il percorso appropriato.

  3. Attendere in Active Directory la replica della modifica apportata ai server di catalogo globale utilizzati dal server di Exchange.

  4. Avviare il servizio Supervisore sistema di Microsoft Exchange.

  5. Sul computer Exchange Server, verificare nel registro eventi dell'applicazione la presenza di tre istanze dell'ID evento 1005 che presentano l'origine evento MSExchangeMU e la categoria Generale.

  6. Per rendere effettiva la modifica, riavviare il computer Exchange Server.

Per ulteriori informazioni su entrambe le procedure descritte, consultare i seguenti articoli della Microsoft Knowledge Base:

  • 822933, "Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822933.

  • 318230, "XCON: Modifica della posizione della cartella della directory principale della posta SMTP in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=318230.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Valore SMTP ResetRoutesRetryMinutes del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

Se si verificano le seguenti condizioni, in Exchange Server Analyzer verrà visualizzato un messaggio di errore:

  • La chiave ResetMessageStatus non è impostata su 0 (zero).

  • Il servizio cluster non è in esecuzione sul server di Exchange.

Quando la chiave ResetMessageStatus del Registro di sistema è impostata su 1, al riavvio di Exchange Server tutti i messaggi in coda passano nuovamente attraverso le code di elaborazione interna. Ad esempio, al riavvio di Exchange Server tutti i messaggi in coda passano nuovamente attraverso il classificatore. Pertanto, la chiave ResetMessageStatus deve essere impostata su 1 solo per la risoluzione di problemi di installazione SMTP, come documentato nell'articolo 279616 della Microsoft Knowledge Base, "XCON: Aggiunta di una chiave del Registro di sistema per la riclassificazione dei messaggi" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=279616. Se non si stanno correggendo problemi di installazione SMTP, è consigliabile eliminare questa chiave del Registro di sistema.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per eliminare la chiave ResetMessageStatus del Registro di sistema

  1. Aprire un editor del Registro di sistema, come Regedit.exe o Regedt32.exe.

  2. Passare a: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Queuing

  3. Nel riquadro destro individuare ed eliminare il valore ResetMessageStatus.

  4. Chiudere l'editor del Registro di sistema.

Prima di apportare modifiche al Registro di sistema e per ulteriori informazioni su questa procedura, consultare l'articolo 256986 della Microsoft Knowledge Base "Descrizione del Registro di sistema di Microsoft Windows" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=256986.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


The SMTP ResetRoutesRetryMinutes registry value is non-default
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave ResetRoutesRetryMinutes è stata impostata, verrà visualizzato un messaggio di configurazione non predefinita.

Si consiglia di modificare i valori di accodamento predefiniti solo dopo un attento esame. Nella maggior parte degli ambienti, le impostazioni predefinite sono state attentamente selezionate per garantire prestazioni ottimali. Generalmente il rimedio ottimale è affrontare la causa del problema anziché modificare le impostazioni di accodamento in Exchange Server.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


Valore SMTP RoutingRetryMinutes del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave RoutingRetryMinutes è stata impostata, verrà visualizzato un messaggio di configurazione non predefinita.

Si consiglia di modificare i valori di accodamento predefiniti solo dopo un attento esame. Nella maggior parte degli ambienti le impostazioni predefinite sono state accuratamente selezionate per garantire prestazioni ottimali. In genere, anziché modificare il comportamento di accodamento in Exchange Server, è consigliabile risolvere la causa principale del problema.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


Valore SMTP SecondsPerDSNPass del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la voce del Registro di sistema indicata di seguito per determinare l'impostazione del valore del Registro di sistema SecondsPerDSNPass:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave SecondsPerDSNPass è presente e non è impostata su 10, verrà visualizzato un messaggio di configurazione non predefinita.

Questa impostazione consente di ottimizzare le notifiche sullo stato del recapito (DNS, Delivery Status Notification) e specifica il numero di secondi per ogni passaggio di elaborazione di DSN. Quando viene superata questa soglia, la generazione di DSN viene arrestata e riavviata in un secondo momento. Si consiglia di modificare i valori predefiniti solo dopo un attento esame. Questa impostazione specifica dovrebbe essere modificata solo dopo aver consultato il Servizio Supporto Tecnico Clienti Microsoft. Nella maggior parte degli ambienti, le impostazioni predefinite sono state attentamente selezionate per garantire prestazioni ottimali. Generalmente il rimedio ottimale è affrontare la causa del problema anziché modificare il comportamento di accodamento sul server di Exchange.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.


L'autenticazione NTLM del server SMTP è disattivata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-11-10

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il bit del protocollo di autenticazione NTLM (noto anche come Autenticazione Windows integrata) nell'attributo msExchAuthenticationFlags è impostato. Se Exchange Server Analyzer determina che il bit non è impostato ed Exchange non è in esecuzione in Windows Small Business Server, verrà visualizzato un avviso.

L'attributo msExchAuthenticationFlags indica il tipo di autenticazione accettato da un server virtuale dei protocolli. Questo attributo utilizza una maschera a tre bit.

Bit | Metodo di autenticazione
0 | Anonimo
1 | Di base
2 | NTLM (Autenticazione Windows integrata)

Se il bit che controlla l'autenticazione NTLM non è impostato, il server virtuale SMTP non consentirà l'autenticazione NTLM. Questo può provocare problemi di autenticazione tra i computer Exchange Server.

Per risolvere il problema

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, il Nome del server, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse sul server virtuale SMTP di Exchange e scegliere Proprietà.

  4. Selezionare la scheda Accesso, scegliere Autenticazione quindi selezionare la casella di controllo Autenticazione Windows integrata.

  5. Fare clic su OK, quindi nuovamente su OK.

  6. Chiudere Gestore di sistema di Exchange.

Per ulteriori informazioni sui metodi di autenticazione SMTP, consultare Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579 e l'articolo 319267 della Knowledge Base "HOW TO: Protezione del recapito dei messaggi di client SMTP in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=319267.


Valore SMTP SubmissionRetryMinutes del Registro di sistema non predefinito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se le configurazioni di accodamento SMTP sono state modificate:

HKEY_LOCAL_MACHINE System\CurrentControlSet\Services\SMTPSvc\Queuing

Se Exchange Server Analyzer rileva che la chiave SubmissionRetryMinutes è stata impostata, Exchange Server Analyzer visualizzerà un messaggio di configurazione non predefinita.

Si consiglia di modificare i valori di accodamento predefiniti solo dopo un attento esame. Nella maggior parte degli ambienti le impostazioni predefinite sono state accuratamente selezionate per garantire prestazioni ottimali. In genere, anziché modificare il comportamento di accodamento in Exchange, è consigliabile risolvere la causa principale del problema.

In Exchange Server Analyzer viene segnalata questa configurazione solo a scopo informativo. Non è richiesta alcuna operazione.

Per ulteriori informazioni sull'accodamento SMTP di Exchange, consultare la voce del blog del team Microsoft Exchange "Explaining the Mysterious SMTP Advanced Queuing Engine" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=48585 (informazioni in lingua inglese).


Il server virtuale SMTP dispone di un limite di dimensione dei messaggi maggiore rispetto al limite di dimensione globale
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per confrontare i limiti di dimensione dei messaggi in arrivo del server virtuale SMTP con i limiti di dimensione dei messaggi globali in arrivo.

L'attributo di Active Directory che rappresenta il limite di dimensione dei messaggi del server virtuale SMTP per i messaggi in arrivo e in uscita è msExchSmtpMaxMessageSize. Questo valore è un attributo dell'oggetto server virtuale SMTP in Active Directory, reperibile in:

CN=<Numero Server Virtuale>, CN=SMTP, CN=Protocols, CN=<NomeServer>, CN=Servers, CN=<NomeGruppoAmministrativo>, CN=Administrative Groups, CN=<NomeOrganizzazione>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<NomeDominio>, DC=com

L'attributo di Active Directory che rappresenta il limite di dimensione globale dei messaggi in arrivo è delivContLength. Questo valore è un attributo dell'oggetto recapito messaggi delle impostazioni globali dell'organizzazione in Active Directory, reperibile in:

CN=Message Delivery, CN=Global Settings, CN=<NomeOrganizzazione>, CN=Microsoft Exchange, CN=Services, CN=Configuration, DC=<NomeDominio>, DC=com

Se Exchange Server Analyzer rileva che il valore di msExchSmtpMaxMessageSize è maggiore del valore di delivContLength, verrà visualizzato un avviso.

Se un server virtuale SMTP dispone di un limite di dimensione dei messaggi maggiore rispetto al limite di dimensione globale, è possibile che i messaggi superiori alla dimensione consentita vengano accettati in ingresso ma successivamente non vengano recapitati. Per risolvere il problema, configurare il server virtuale SMTP con una dimensione massima per i messaggi uguale o inferiore al limite di dimensione globale dei messaggi in arrivo.

Nota:
Se il limite della dimensione del messaggio viene impostato su un valore troppo basso, è possibile che venga impedita la replica della rubrica non in linea tra computer Exchange Server. Per ulteriori informazioni su questo problema, consultare l'articolo 326154 della Microsoft Knowledge Base "XADM: OAB non esegue la replica se viene impostata una restrizione delle dimensioni dei messaggi a livello del trasporto" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=326154.

Per risolvere il problema

  1. In Exchange System Manager, espandere la struttura Server, quindi espandere un server di Exchange, espandere la struttura Protocolli e infine SMTP.

  2. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  3. Selezionare la scheda Messaggi.

  4. Modificare il valore del campo Limita dimensione messaggi a (KB) in modo che sia uguale o inferiore al limite di dimensione dei messaggi globale.

  5. Fare clic su OK per salvare le modifiche e per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sulla visualizzazione e la modifica delle impostazioni a livello dell'intera organizzazione, consultare l'articolo 821881 della Microsoft Knowledge Base "Modifica delle impostazioni globali in Gestore di sistema di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821881.

Per ulteriori informazioni sui limiti di dimensione dei messaggi globali, consultare i seguenti articoli della Knowledge Base:

  • 298572, "I messaggi di posta elettronica che superano il limite di dimensione dei messaggi in uscita o in arrivo non vengono recapitati" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=298572.

  • 322679, "Impostazione dei limiti di dimensione per i messaggi in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322679.

  • 824111, "Modifiche e aggiornamenti delle impostazioni di protezione introdotti in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=824111.


Questo server virtuale SMTP è configurato per eseguire ricerche DNS inverse sui messaggi in arrivo
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-24

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se il valore configurato dell'attributo msExchSmtpPerformReverseDnsLookup è stato modificato rispetto al valore predefinito False. Per impostazione predefinita l'attributo msExchSmtpPerformReverseDnsLookup è configurato per non eseguire ricerche DNS al contrario per i messaggi in arrivo. Se Exchange Server Analyzer rileva che l'attributo è impostato su True, verrà visualizzato un avviso.

L'opzione Esegui ricerca DNS al contrario sui messaggi in arrivo non presenta alcuna funzionalità che impedisca la ricezione di messaggi di posta elettronica indesiderati. Quando viene utilizzata questa opzione, Exchange Server esegue una query DNS per risolvere in un nome host l'indirizzo IP (Internet Protocol) di origine dei messaggi in arrivo. Quindi il nome host viene allegato alle intestazioni dei messaggi di posta elettronica.

Con questa funzione abilitata si può osservare una riduzione delle prestazioni a causa di registrazioni DNS configurate in modo non corretto o connessioni intermittenti a Internet. Pertanto, è possibile decidere di disabilitare questa opzione quando il recapito della posta di Internet è più lento del previsto.

Per abilitare o disabilitare ricerche DNS al contrario per i messaggi SMTP in arrivo

  1. Aprire Gestore di sistema di Exchange.

  2. Espandere Server, un server di Exchange, Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio, il server virtuale SMTP predefinito) e scegliere Proprietà.

  4. Selezionare la scheda Recapito e fare clic su Avanzate.

    • Per abilitare le ricerche DNS al contrario, selezionare la casella di controllo Esegui ricerca DNS al contrario sui messaggi in arrivo.

    • Per disabilitare le ricerche DNS al contrario, deselezionare la casella di controllo Esegui ricerca DNS al contrario sui messaggi in arrivo.

  5. Fare clic su OK per salvare le modifiche, quindi fare clic su OK per uscire dalla finestra di dialogo Proprietà server virtuale SMTP.

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario in Exchange, consultare l'articolo 297412 della Microsoft Knowledge Base, "L'opzione 'Esegui ricerca DNS al contrario sui messaggi in arrivo' viene utilizzata per la risoluzione del nome host" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.


Versione SP1 del Filtro messaggi intelligente abilitata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se nel server è installato e abilitato il Filtro messaggi intelligente di Microsoft Exchange:

HKEY_LOCAL_MACHINE\ Software\Microsoft\Exchange\ContentFilter

Exchange Server Analyzer legge il valore ContentFilterBindings nella chiave ContentFilter del Registro di sistema per determinare se nel server è installato e abilitato il Filtro messaggi intelligente.

Exchange Server Analyzer esegue quindi una query nella classe WMI (Strumentazione gestione Windows®) CIM_Datafile per determinare se il file MSExchange.UceContentFilter.dll della versione Exchange Server 2003 Service Pack 1 (SP1) del Filtro messaggi intelligente si trova nel seguente percorso del server Exchange:

<percorso dei file binari di Exchange server>\MSCFv1\MSExchange.UceContentFilter.dll

Nota:
In questo percorso, <percorso dei file binari di Exchange server> indica la posizione della cartella dei file binari.

Se la versione Exchange Server 2003 SP1 del Filtro messaggi intelligente è installata e abilitata nel server, viene visualizzato un avviso.

L'avviso indica che è disponibile una versione più recente del Filtro messaggi intelligente. È consigliabile installare la versione più recente del Filtro messaggi intelligente. Per risolvere problemi nel flusso di posta relativi a un server particolare, disabilitare temporaneamente il Filtro messaggi intelligente per determinare se la posta legittima viene erroneamente bloccata.

Per disabilitare il Filtro messaggi intelligente

  1. Fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. In Gestore di sistema di Exchange espandere Server, nome server, Protocolli e infine SMTP, fare clic con il pulsante destro del mouse su Filtraggio del contenuto e scegliere Proprietà.

  3. Nella scheda Generale, nella sezione Applica filtraggio del contenuto per i seguenti indirizzi IP dei server virtuali deselezionare la casella di controllo vicino a ogni server virtuale SMTP su cui si desidera disabilitare il Filtro messaggi intelligente.

    La finestra di dialogo delle proprietà del Filtro messaggi intelligente

Per ulteriori informazioni, visitare il sito Web del Filtro messaggi intelligente di Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607.


Versione SP2 del Filtro messaggi intelligente abilitata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-04

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare se la proprietà msExchServerBindingsFiltering di un oggetto del server virtuale SMTP indica che il Filtro messaggi intelligente è abilitato per un'istanza del server virtuale SMTP.

Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare se l'attributo msExchUceEnabled è abilitato a livello delle impostazioni globali.

Se si verificano le seguenti condizioni, verrà visualizzato un avviso:

  • Il Filtro messaggi intelligente è abilitato per un'istanza del server virtuale SMTP.

  • Il Filtro messaggi intelligente è abilitato a livello delle impostazioni globali.

Tale messaggio indica che la versione di Exchange Server 2003 Service Pack 2 (SP2) del Filtro messaggi intelligente è correttamente abilitata. L'abilitazione della versione SP2 del Filtro messaggi intelligente non rappresenta un problema a meno che non sia in corso la risoluzione di problemi relativi al flusso di posta in questo server specifico. In questo caso, è consigliabile verificare la configurazione del filtro oppure disabilitare temporaneamente il Filtro messaggi intelligente per determinare se la posta legittima viene erroneamente bloccata.

Per disabilitare il Filtro messaggi intelligente

  1. Fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nel Gestore di sistema di Exchange espandere Server, quindi nome server, Protocolli, SMTP.

  3. Nelle Proprietà del Server virtuale SMTP, nella scheda Generale fare clic su Avanzate.

  4. Selezionare l'indirizzo IP per il quale si desidera disabilitare il Filtro messaggi intelligente, quindi fare clic su Modifica.

  5. In Identificazione deselezionare Applica Filtro messaggi intelligente.

  6. Se sono presenti più server virtuali, ripetere i passaggi da 3 a 6 per ciascun server virtuale sul quale disabilitare Filtro messaggi intelligente.

Per ulteriori informazioni, visitare il sito Web del Filtro messaggi intelligente di Exchange all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21607.


Server gateway specificato non utilizzato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-09

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange a un account esterno definito dall'utente e quindi esegue l'analisi dei registri di verifica messaggi del server per determinare se sono stati rilevati dei problemi con il recapito di tale messaggio.

Come parte dell'analisi, Exchange Server Analyzer verifica che il server gateway di Exchange utilizzato per instradare il messaggio al destinatario esterno corrisponda a quello specificato dall'utente nella pagina Immetti informazioni server e utente del passaggio Nomi e credenziali del server.

Se Exchange Server Analyzer determina che il messaggio è stato instradato con esito positivo all'esterno dell'organizzazione di Exchange ma il server gateway specificato non è stato utilizzato, verrà visualizzato un avviso.

L'avviso indica che potrebbe essersi verificato un problema con la topologia di routing di Exchange e che sono presenti server gateway in uscita non noti.

È possibile che i problemi di routing si verifichino se le voci SmartHost vengono impostate a livello del server virtuale anziché a livello del connettore. La procedura ottimale consigliata prevede che le voci SmartHost vengano impostate sul connettore SMTP e non sul server virtuale SMTP.

Per risolvere il problema procedere come segue:

  • Esaminare la configurazione del server virtuale SMTP (Simple Mail Transfer Protocol) per accertarsi che non vi siano voci SmartHost impostate.

  • Verificare che la configurazione dei server testa di ponte locali sia corretta per quanto riguarda gli spazi indirizzo e i costi dei connettori.

Per visualizzare e configurare le impostazioni SmartHost:

  1. Aprire il Gestore di sistema di Exchange.

  2. Espandere Server, quindi espandere un server di Exchange e Protocolli e infine SMTP.

  3. Fare clic con il pulsante destro del mouse su un server virtuale SMTP (ad esempio il server virtuale SMTP predefinito) e selezionare Proprietà.

  4. Selezionare la scheda Recapito e quindi fare clic su Avanzate.

  5. Deselezionare le voci sotto Smart host.

  6. Fare clic su OK per salvare le modifiche e quindi su OK per chiudere la finestra di dialogo Proprietà del server virtuale SMTP.

Per ulteriori informazioni sulla configurazione dei connettori SMTP, consultare l'articolo 822941 della Microsoft Knowledge Base "Utilizzo dei connettori SMTP per connettere gruppi di routing in Exchange 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=822941.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.


Mittente specificato in un server diverso
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-08-10

Microsoft® Exchange Server Analyzer Tool esegue una query nel valore attributo proxyAddress del servizio directory di Active Directory® per tutti gli oggetti utente per determinare se esiste una corrispondenza per l'indirizzo SMTP (Simple Mail Transfer Protocol) del mittente locale specificato dall'utente.

Se viene rilevata una corrispondenza proxyAddress dell'oggetto utente, Exchange Server Analyzer esegue una query in Active Directory per il valore dell'attributo msExchHomeServerName dell'oggetto utente per determinare se tale valore corrisponde al nome di Exchange Server specificato dall'utente.

Se Exchange Server Analyzer determina che il valore dell'attributo msExchHomeServerName del mittente specificato dall'utente non corrisponde al nome di Exchange Server specificato dall'utente, verrà visualizzato un avviso.

L'avviso indica che è stato fornito un nome di Exchange Server errato oppure che il problema del flusso di posta influisce su un server diverso da quello specificato dall'utente.

Per risolvere il problema verificare che sia stato immesso il nome di Exchange Server corretto.

Per visualizzare le cassette postali dell'utente in un server specificato

  1. Avviare il Gestore di sistema di Exchange:

    Fare clic su Start, scegliere Programmi , quindi Microsoft Exchange e infine fare clic su Gestore di sistema.

  2. In Gestore di sistema di Exchange, passare al contenitore seguente e fare clic su di esso:

    \Administrative Groups\ GroupName \Servers\ ServerName \ StorageGroupName \Mailbox Store\Mailboxes

  3. Verificare che la cassetta postale dell'utente specificata sia visualizzata sul server Exchange specificato.


Impossibile identificare i server di destinazione
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-06

Microsoft® Exchange Server Analyzer Tool tenta di individuare e creare un elenco di nomi di dominio completi (FQDN, Fully Qualified Domain Names), indirizzi IP e nomi di dominio di server ai quali sono destinati messaggi di posta in una coda di recapito remota.

La creazione dell'elenco di FQDN, indirizzi IP e nomi di dominio di server remoti avviene come segue:

  • Viene eseguita una query nella proprietà msExchSmtpFullyQualifiedDomainName dell'oggetto del servizio directory di ActiveDirectory® del server virtuale SMTP.

    Nota:
    La proprietà msExchSmtpFullyQualifiedDomainName viene a letta a sua volta dalla proprietà msExchTargetBridgeheadServersDN di un oggetto directory del connettore del gruppo di instradamento quando in essa viene eseguita una query per rilevare la presenza dei server testa di ponte di destinazione designati.
  • Viene eseguita una query nella proprietà msExchSmtpSmartHost dell'oggetto Active Directory del connettore SMTP per rilevare la presenza di un connettore SMTP di uno SmartHost.

  • Viene eseguita una query nella proprietà LinkName della classe Microsoft WMI (Strumentazione gestione Windows®) ExchangeLink per rilevare la presenza di connessioni dirette al server remoto.

Se Microsoft Exchange Server Analyzer Tool determina che il tentativo di creare l'elenco non è riuscito, verrà visualizzato un errore.

L'errore indica che:

  • Potrebbero sussistere problemi di connessione intermittente alla rete o ad Active Directory che causano problemi di flusso di posta.

  • L'account che esegue Microsoft Exchange Server Analyzer Tool potrebbe non disporre delle autorizzazioni necessarie per eseguire una query nelle informazioni.

Per risolvere il problema

  1. Assicurarsi che il computer che esegue Exchange Server sia stato avviato e sia connesso alla rete.

  2. Verificare che si disponga della connettività di rete a un controller di dominio di Active Directory.

  3. Specificare in Microsoft Exchange Server Analyzer Tool un controller di dominio di Active Directory.

  4. Utilizzare il comando PING per verificare che il computer che esegue Exchange Server sia raggiungibile.

  5. Se è attivo un firewall, verificare se le porte RPC sono bloccate.

  6. Controllare le autorizzazioni dell'account su cui è in esecuzione Microsoft Exchange Server Analyzer Tool. Questo account deve disporre delle autorizzazioni di Administrator locale su ciascun computer di Exchange Server di cui esegue l'analisi.

Per ulteriori informazioni sui problemi di connettività della rete, vedere l'articolo della Microsoft Knowledge Base "Risoluzione dei problemi di connettività della rete" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325487.

Per ulteriori informazioni sui problemi di connettività di Exchange Server Analyzer, vedere "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (in inglese).

Per ulteriori informazioni sui requisiti delle porte, vedere l'articolo 832017 della Microsoft Knowledge Base "Informazioni generali sul servizio e sui requisiti delle porte di rete del sistema Microsoft Windows Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=832017 (in inglese).


TarpitTime è stato implementato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-02-21

Microsoft® Exchange Server Analyzer Tool legge la seguente voce del Registro di sistema per determinare se la funzionalità tar pit di filtraggio del destinatario è stata impostata:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SMTPSvc\Parameters\TarpitTime

Se Exchange Server Analyzer rileva che il valore per TarpitTime è superiore a 0 (zero), Exchange Server Analyzer visualizzerà un messaggio di configurazione non predefinita.

La procedura di Tar pitting consiste nel provocare intenzionalmente rallentamenti o ritardi nelle connessioni non valide per ridurre la velocità con cui può essere inviata la posta indesiderata automatica o con cui può essere effettuato un attacco di tipo "dizionario".

La funzionalità tar pit disponibile con Microsoft Windows Server™ 2003 Service Pack 1 (SP1) può essere aggiunta affinché collabori con il filtraggio del destinatario, come descritto nell'articolo 842851 della Microsoft Knowledge Base "Funzionalità tar pit SMTP per Microsoft Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851. In particolare, la funzionalità tar pit consente di estendere l'utilità del filtro destinatari quando è selezionata la casella di controllo Filtra destinatari non presenti nella directory nella scheda Filtri destinatario in Impostazioni globali.

Per implementare la funzionalità tar pit, è necessario impostare la sottochiave TarpitTime del Registro di sistema. Tale sottochiave accetta valori decimali. Il valore decimale indica il numero di secondi di attesa della sessione SMTP prima di rispondere a un mittente se il destinatario non esiste nell'organizzazione di Exchange Server di destinazione.

La funzionalità tar pit rende molto più difficile l'esecuzione di attacchi di tipo "dizionario" da parte degli spammer che inviano messaggi di posta indesiderati. Un attacco di tipo "dizionario" è un tentativo di recuperare da una determinata organizzazione un elenco di indirizzi di posta elettronica validi.

Il protocollo SMTP riconosce i destinatari accettabili durante una sessione SMTP e restituisce "2.1.5 Recipient OK". Se viene inviato un messaggio a un destinatario sconosciuto, il protocollo SMTP restituisce un errore di tipo "5.x.x". Uno spammer è in grado di scrivere un programma automatico in cui vengono utilizzati nomi comuni o termini di dizionario per generare indirizzi di posta elettronica in un dominio specifico. Tale programma consente di raccogliere gli indirizzi di posta elettronica per cui viene restituito "2.1.5 Recipient OK" e di scartare quelli che provocano errori di tipo "5.x.x". Lo spammer può quindi vendere gli indirizzi "validi" oppure utilizzarli come destinatari per l'invio di messaggi indesiderati.

Se la casella di controllo Filtra destinatari non presenti nella directory è selezionata ma non è impostata la sottochiave TarpitTime del Registro di sistema e se un destinatario non esiste nel servizio directory di Active Directory® di destinazione, durante la sessione SMTP verrà restituito immediatamente un errore di tipo "5.x.x".

In alternativa, se è impostata la sottochiave TarpitTime ed è selezionata la casella di controllo Filtra destinatari non presenti nella directory, prima che venga restituito l'errore "5.x.x" dovrà trascorrere un intervallo di attesa. Il valore decimale immesso per la sottochiave TarpitTime del Registro di sistema indica il numero di secondi di attesa prima della restituzione dell'errore. Questa pausa nella sessione SMTP rende molto più difficile l'esecuzione di attacchi di tipo "dizionario" automatici.

Come indicato in precedenza, se è impostata la sottochiave TarpitTime del Registro di sistema, verrà visualizzerà un messaggio di configurazione non predefinita. Questo messaggio è puramente informativo.

Importante:
Questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema assicurarsi di comprendere come ripristinarlo, qualora si verifichi un problema. Per informazioni su questa procedura, consultare l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe o Regedt32.exe.
Per visualizzare o modificare la sottochiave TarpitTime del Registro di sistema

  1. Fare clic su Start, Esegui, digitare regedit nella casella Apri, quindi fare clic su OK.

  2. Individuare e fare clic sulle seguenti sottochiavi del Registro di sistema:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Parameters\TarpitTime

  3. La casella Dati valore contiene un numero decimale. Il valore rappresenta il numero di secondi che si desidera impostare per ritardare le risposte di verifica indirizzi SMTP per ogni indirizzo non esistente in Active Directory.

  4. Se viene modificato il valore o eliminata la sottochiave del Registro di sistema TarpitTime, sarà necessario riavviare il servizio SMTP (Simple Mail Transport Protocol).

Per ulteriori informazioni consultare l'articolo 842851 della Microsoft Knowledge Base "Funzionalità tar pit SMTP per Microsoft Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=842851.


Il messaggio di prova ha generato un rapporto di mancato recapito
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange all'account Postmaster oppure a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi relativi al recapito del messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query alla proprietà EntryType per la classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio nomi root\MicrosoftExchangeV2 per determinare cosa ha causato la creazione della voce del registro di verifica messaggi.

Se Exchange Server Analyzer rileva un valore di 1030 per la proprietà EntryType, verrà visualizzato un avviso.

L'avviso indica che il messaggio di prova ha generato un rapporto di mancato recapito (NDR, Non Delivery Report) e che potrebbe verificarsi un problema con la configurazione SMTP del server. Il rapporto di mancato recapito viene solitamente generato se il destinatario non esiste, ma rappresenta un problema se il messaggio di prova è stato inviato a un destinatario legittimo.

Per risolvere il problema, tentare l'invio di altri messaggi allo stesso destinatario e rivedere i rapporti di mancato recapito per determinare la causa.

Per ulteriori informazioni sulla risoluzione dei problemi nel flusso di posta e nel protocollo SMTP, vedere "Risoluzione di problemi nei rapporti di mancato recapito" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Messaggio di prova inviato alla directory della posta scartata
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-05-17

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange all'account Postmaster o a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi relativi al recapito del messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query alla proprietà EntryType per la classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio dei nomi root\MicrosoftExchangeV2 per determinare la causa della voce del registro di verifica messaggi.

Se Exchange Server Analyzer rileva un valore di 1021 per la proprietà EntryType, verrà visualizzato un avviso.

L'avviso indica che il messaggio di prova è stato inviato alla directory della posta scartata del server Exchange e che si è verificato un problema con la configurazione SMTP del server.

Un messaggio viene inserito nella directory della posta scartata per uno dei seguenti motivi:

  • Non può essere recapitato.

  • È stato superato il numero massimo di tentativi.

  • Non può essere restituito al mittente come non recapitato.

Per ulteriori informazioni su come verificare il flusso di posta in uscita, vedere l'articolo 297700 della Microsoft Knowledge Base "Verifica del flusso di posta in uscita con un file della cartella di prelievo" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297700.

Per ulteriori informazioni sulla risoluzione dei problemi nel flusso di posta e nel protocollo SMTP, vedere "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.


Messaggio di prova nella coda SMTP
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-06

Microsoft® Exchange Server Analyzer Tool invia un messaggio di prova dal server Exchange all'account Postmaster oppure a un account definito dall'utente per il dominio SMTP, quindi esegue l'analisi del registro di verifica messaggi del server per determinare se sono stati rilevati problemi relativi al recapito del messaggio di prova.

Come parte dell'analisi, Exchange Server Analyzer esegue una query alla proprietà EntryType per la classe WMI (Strumentazione gestione Microsoft Windows®) Exchange_MessageTrackingEntry nello spazio nomi root\MicrosoftExchangeV2 per determinare la causa della creazione delle voci del registro di verifica messaggi.

La tabella seguente elenca i possibili valori EntryType restituiti.

Nome valore | Valore
Messaggio ricevuto tramite X.400 | 0
Rapporto ricevuto | 2
Messaggio inviato | 4
Messaggio trasferito in uscita | 7
Rapporto trasferito in uscita | 8
Messaggio recapitato | 9
Rapporto recapitato | 10
Lista di distribuzione espansa | 26
Messaggio reindirizzato | 28
Messaggo reinstradato | 29
Downgrade del server da MTA | 31
Rapporto assorbito | 33
Rapporto generato | 34
Rapporto non instradabile scartato | 43
Messaggio eliminato dall'amministratore | 50
Probe eliminato dall'amministratore | 51
Rapporto eliminato dall'amministratore | 52
Messaggio recapitato localmente | 1000
Messaggio trasferito in ingresso tramite backbone | 1001
Messaggio trasferito in usciata tramite backbone | 1002
Messaggio trasferito in uscita tramite gateway | 1003
Messaggio trasferito in ingresso tramite gateway | 1004
Report trasferito in ingresso tramite gateway | 1005
Report trasferito in uscita tramite gateway | 1006
Rapporto generato | 1007
SMTP: messaggio in uscita accodato | 1010
SMTP: messaggio trasferito in uscita | 1011
SMTP: messaggio in ingresso ricevuto | 1012
SMTP: messaggio in ingresso trasferito | 1013
SMTP: messaggo reinstradato | 1014
SMTP: rapporto trasferito in ingresso | 1015
SMTP: rapporto trasferito in uscita | 1016
SMTP: rapporto generato | 1017
SMTP: rapporto assorbito | 1018
SMTP: messaggio inviato ad accodamento avanzato | 1019
SMTP: trasferimento in uscita del messaggio avviato | 1020
SMTP: messaggio inviato alla cartella posta scartata | 1021
SMTP: errore coda avanzata | 1022
SMTP: messaggio recapitato localmente | 1023
SMTP: messaggio inviato al classificatore | 1024
SMTP: invio messaggi alla coda avanzata avviato | 1025
SMTP: coda avanzata: errore recapito messaggio | 1026
Driver di archivio SMTP: messaggio inviato dall'archivio | 1027
Driver di archivio SMTP: messaggio recapitato localmente all'archivio | 1028
Driver di archivio SMTP: messaggio inviato a MTA | 1029
SMTP: generato rapporto di mancato recapito | 1030
SMTP: messaggio trasferito in uscita | 1031

Microsoft Exchange Server Analyzer Tool visualizzerà un errore se i valori EntryType restituiti indicano le seguenti condizioni:

  • È possibile eseguire correttamente l'analisi del registro di verifica messaggi.

  • l messaggio di prova non è stato trasferito correttamente fuori dalla coda.

  • Non è stato generato un rapporto di mancato recapito (NDR, Non Delivery Report) per il messaggio di prova.

  • Il messaggio di prova non è stato trasferito nella cartella della posta scartata.

  • Il messaggio di prova non viene accodato per il recapito remoto.

  • Il messaggio di prova non è stato recapitato all'archivio locale.

  • Il messaggio di prova non viene pianificato per ritentare la classificazione.

  • Il messaggio di prova non viene pianificato per ritentare l'instradamento.

  • Il messaggio di prova non viene pianificato per ritentare il recapito locale.

Questo errore indica che il messaggio di essere si trova in una delle code SMTP e che è necessaria un'ulteriore analisi per determinare la causa.

Per risolvere questo errore, utilizzare l'utilità NSlookup per rivedere possibili problemi della risoluzione DNS (Domain Name System). Per problemi di connessione e di protocollo come errori di tipo "Host irraggiungibile", usare Telnet.exe per cercare di connettersi al computer di destinazione. Per correggere errori di protocollo, aumentare il livello di registrazione diagnostica per il servizio MSExchangeTransport relativo al componente SMTP, quindi analizzare il registro alla ricerca di errori. In alternativa è possibile utilizzare lo strumento Network Monitor (Netmon.exe) per ottenere informazioni sugli errori di connessione in rete. Per riprodurre il problema, può essere necessario imporre alla coda un nuovo tentativo. Esaminare il registro eventi alla ricerca di possibili errori associati al servizio Archivio informazioni di Microsoft Exchange.

Per ulteriori informazioni sulla modifica delle impostazioni di registrazione, vedere "Modifica delle impostazioni di registrazione per MSExchangeTransport" nella sezione "Risoluzione di problemi del flusso della posta e di SMTP" della Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP, vedere le seguenti risorse di Exchange:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

  • Articolo 823489 della Microsoft Knowledge Base "Utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

  • Articolo 821877 della Microsoft Knowledge Base "Descrizione dei campi nelle schede delle proprietà delle code SMTP e X.400" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=821877.

  • Articolo 264054 della Microsoft Knowledge Base "XCON: Concetti relativi allo stato delle code in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=264054.


Sono presenti più di 900 connettori in un gruppo di routing
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di connettori presenti in un determinato gruppo di routing, inclusi connettori SMTP, connettori di un gruppo di routing, connettori X.400 e connettori EDK. Se Exchange Server Analyzer rileva più di 900 connettori totali in un unico gruppo di routing, verrà visualizzato un avviso.

Si consiglia di utilizzare un massimo di 900 istanze per i singoli tipi di oggetto di Exchange, poiché in Active Directory il valore predefinito per la dimensione massima della pagina per ogni data richiesta è 1.000. Di conseguenza, se viene inviata una richiesta LDAP per un oggetto e in Active Directory esistono più di 1000 istanze di tale oggetto, non verrà restituito alcun risultato perché è stata superata la dimensione massima della pagina.

Nel caso di Exchange Server, i diversi processi richiedono la creazione di istanze per specifici tipi di oggetto. Ad esempio, Gestore di sistema di Exchange invia una richiesta LDAP ad Active Directory per creare una visualizzazione elenco di tutti i connettori all'interno di un gruppo di routing. Nel caso in cui vi siano più di 1.000 connettori in un unico gruppo di routing, Active Directory non restituirà alcun risultato della query. Se si verifica questa eventualità, Gestore di sistema di Exchange visualizza un messaggio di errore.

Sebbene sia possibile aumentare il valore di dimensione massima della pagina per Active Directory, non è un'operazione consigliabile o supportata per Exchange Server. Sono stati rilevati errori e comportamenti anomali in ambienti Exchange, in cui è stato incrementato il valore massimo della dimensione della pagina.

Sebbene sia consigliabile non superare le 900 unità per ogni singolo tipo di oggetto in Exchange Server, sono supportati fino a 1.000 tipi di oggetto.

Per risolvere il problema

  1. Prendere in considerazione il consolidamento dei connettori o la creazione di un maggior numero di gruppi di routing e il bilanciamento del carico tra i connettori esistenti.

  2. Esaminare i connettori isolati e rimuoverli da Active Directory.

  3. Prendere in considerazione il consolidamento dei server di Exchange nella propria organizzazione.

Per ulteriori informazioni sulla struttura dei gruppi di routing e sui connettori, consultare la Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47579.

Per ulteriori informazioni sul consolidamento dei server di Exchange, consultare Server Consolidation Using Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?linkid=47586 (informazioni in lingua inglese).


Rilevata una discrepanza tra Active Directory e la metabase nell'impostazione del nome di dominio completo
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2007-01-17

Microsoft® Exchange Server Analyzer Tool legge la seguente proprietà nella metabase IIS (Internet Information Services) per determinare se il valore della proprietà corrisponde al valore configurato dell'attributo msExchSmtpFullyQualifiedDomainName nel servizio directory di Active Directory®.

/LM/SmtpSvc/<SMTP virtual server instance>/FullyQualifiedDomainName

Se Exchange Server Analyzer rileva che i valori dei due attributi non corrispondono, verrà visualizzato un avviso.

Se il valore nella metabase IIS non corrisponde al valore in Active Directory, si può trattare di un problema della replica di Active Directory oppure di un problema del componente DS2MB (Directory-service-to-Metabase-replication) in Exchange.

La funzione del processo DS2MB è quella di trasferire le informazioni di configurazione da Active Directory alla metabase locale. Questa configurazione è archiviata nella metabase locale invece che nel Registro di sistema, per motivi di prestazioni e scalabilità. In Exchange 2000 Server ed Exchange Server 2003 tutti i protocolli Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) vengono eseguiti come componenti di IIS.

Ogni 15 minuti il processo DS2MB copia le intere sottostrutture di Active Directory senza modificare la forma della sottostruttura. È una scrittura unidirezionale da Active Directory nella metabase. La metabase non scrive mai in Active Directory.

La proprietà FullyQualifiedDomainName e l'attributo msExchSmtpFullyQualifiedDomainName utilizzano un nome di server predefinito che corrisponde al nome di dominio completo del server di Exchange (ad esempio server.dominio.com). Se la proprietà FullyQualifiedDomainName e l'attributo msExchSmtpFullyQualifiedDomainName non presentano lo stesso valore, significa che Active Directory e la metabase IIS non sono sincronizzati. Se il problema è provocato da un errore del processo DS2MB, è possibile correggerlo seguendo la procedura indicata di seguito per la versione di Exchange Server in esecuzione. Se il problema è provocato da un errore parziale o completo della replica di Active Directory, è possibile utilizzare l'utilità Monitoraggio replica di Active Directory (ReplMon.exe) per controllare l'integrità e lo stato della replica di Active Directory. È possibile trovare ReplMon.exe in Strumenti di supporto di Microsoft Windows® nel CD di Windows Server™ 2003.

Per correggere questo errore su Exchange Server 2003

  1. Verificare la presenza di voci nel registro eventi applicazioni con origine MSExchangeMU. Se si verifica un errore di DS2MB, verrà registrato un evento in Exchange Server 2003.

  2. Se non si notano errori di DS2MB, utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  3. Se si sono verificati errori di DS2MB oppure dopo aver eliminato o risolto un problema della replica di Active Directory riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per correggere questo errore su Exchange 2000 Server

  1. Utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  2. Dopo aver eliminato o risolto problemi della replica di Active Directory, riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario in Exchange, consultare l'articolo 297412 della Microsoft Knowledge Base, "L'opzione 'Esegui ricerca DNS al contrario sui messaggi in arrivo' viene utilizzata per la risoluzione del nome host" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare gli articoli della Microsoft Knowledge Base 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686 e 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sulla replica di Active Directory, consultare l'articolo 232072 della Microsoft Knowledge Base "Inizializzazione della replica tra partner di replica diretta in Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072.

Per ulteriori informazioni sul processo DS2MB, consultare l'articolo 240105 della Microsoft Knowledge Base "XGEN: Informazioni generali sulla sincronizzazione della metabase e del servizio directory in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105.


Rilevata una discrepanza tra Active Directory e la metabase nell'impostazione del numero massimo di hop
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente proprietà nella metabase IIS (Internet Information Services) per determinare se il valore della proprietà corrisponde al valore configurato dell'attributo msExchSmtpMaxHopCount nel servizio directory di Active Directory®.

/LM/SmtpSvc/<SMTP virtual server instance>/HopCount

Se Exchange Server Analyzer rileva che i valori non corrispondono, verrà visualizzato un avviso.

Se il valore nella metabase IIS non corrisponde al valore in Active Directory, si può trattare di un problema della replica di Active Directory oppure di un problema del componente DS2MB (Directory-service-to-Metabase-replication) in Exchange.

La funzione del processo DS2MB è quella di trasferire le informazioni di configurazione da Active Directory alla metabase locale. Questa configurazione è archiviata nella metabase locale invece che nel Registro di sistema, per motivi di prestazioni e scalabilità. In Exchange 2000 Server ed Exchange Server 2003 tutti i protocolli Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) vengono eseguiti come componenti di IIS.

Ogni 15 minuti il processo DS2MB copia le intere sottostrutture di Active Directory senza modificare la forma della sottostruttura. È una scrittura unidirezionale da Active Directory nella metabase. La metabase non scrive mai in Active Directory.

Su un server virtuale SMTP Exchange 2000 Server il numero di hop predefinito è 15. Su un server virtuale SMTP Exchange 2003, il numero di hop predefinito è 30. Indipendentemente dal valore configurato, se la proprietà HopCount e l'attributo msExchSmtpMaxHopCount non presentano lo stesso valore, significa che Active Directory e la metabase IIS non sono sincronizzati. Se il problema è provocato da un errore del processo DS2MB, è possibile correggerlo seguendo la procedura indicata di seguito per la versione di Exchange Server in esecuzione. Se il problema è provocato da un errore parziale o completo della replica di Active Directory, è possibile utilizzare l'utilità Monitoraggio replica di Active Directory (ReplMon.exe) per controllare l'integrità e lo stato della replica di Active Directory. È possibile trovare ReplMon.exe in Strumenti di supporto di Microsoft Windows® nel CD di Windows Server™ 2003.

Per risolvere il problema in Exchange Server 2003

  1. Verificare la presenza di voci nel registro eventi applicazioni con origine MSExchangeMU. Se si verifica un errore di DS2MB, verrà registrato un evento in Exchange Server 2003.

  2. Se non si notano errori di DS2MB, utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  3. Se si sono verificati errori di DS2MB oppure dopo aver eliminato o risolto un problema della replica di Active Directory riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per risolvere il problema su Exchange 2000 Server

  1. Utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  2. Dopo aver eliminato o risolto problemi della replica di Active Directory, riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario in Exchange, consultare l'articolo 297412 della Microsoft Knowledge Base, "L'opzione 'Esegui ricerca DNS al contrario sui messaggi in arrivo' viene utilizzata per la risoluzione del nome host" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sulla replica di Active Directory, consultare l'articolo 232072 della Microsoft Knowledge Base "Inizializzazione della replica tra partner di replica diretta in Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072.

Per ulteriori informazioni sul processo DS2MB, consultare l'articolo 240105 della Microsoft Knowledge Base "XGEN: Informazioni generali sulla sincronizzazione della metabase o del servizio directory in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105.


Rilevata una discrepanza tra Active Directory e la metabase nell'impostazione della dimensione massima dei messaggi
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la seguente proprietà nella metabase IIS (Internet Information Services) per determinare se il relativo valore corrisponde al valore configurato per l'attributo msExchSmtpMaxMessageSize nel servizio directory di Active Directory®:

/LM/SmtpSvc/<Istanza del server virtuale SMTP>/MaxMessageSize

Se Exchange Server Analyzer rileva che i valori non corrispondono, verrà visualizzato un avviso.

Se il valore nella metabase IIS non corrisponde al valore in Active Directory, si può trattare di un problema della replica di Active Directory oppure di un problema del componente DS2MB (Directory-service-to-Metabase-replication) in Exchange.

La funzione del processo DS2MB è quella di trasferire le informazioni di configurazione da Active Directory alla metabase locale. Questa configurazione è archiviata nella metabase locale invece che nel Registro di sistema, per motivi di prestazioni e scalabilità. In Exchange 2000 Server ed Exchange Server 2003 tutti i protocolli Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) vengono eseguiti come componenti di IIS.

Ogni 15 minuti il processo DS2MB copia le intere sottostrutture di Active Directory senza modificare la forma della sottostruttura. È una scrittura unidirezionale da Active Directory nella metabase. La metabase non scrive mai in Active Directory.

Sia la proprietà MaxMessageSize che l'attributo msExchSmtpMaxMessageSize utilizzano il valore predefinito 0 che indica che non viene imposto alcun limite di dimensione dei messaggi. Se la proprietà MaxMessageSize e l'attributo msExchSmtpMaxMessageSize non presentano lo stesso valore, significa che Active Directory e la metabase IIS non sono sincronizzati. Se il problema è provocato da un errore del processo DS2MB, è possibile risolverlo seguendo la procedura indicata di seguito per la versione di Exchange Server in uso. Se il problema è provocato da un errore parziale o completo della replica di Active Directory, è possibile utilizzare l'utilità Monitoraggio replica di Active Directory (ReplMon.exe) per controllare l'integrità e lo stato della replica di Active Directory. È possibile trovare ReplMon.exe in Strumenti di supporto di Microsoft Windows® nel CD di Windows Server™ 2003.

Per risolvere il problema in Exchange Server 2003

  1. Verificare la presenza di voci nel registro eventi applicazioni con origine MSExchangeMU. Se si verifica un errore di DS2MB, verrà registrato un evento in Exchange Server 2003.

  2. Se non si notano errori di DS2MB, utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  3. Se si sono verificati errori di DS2MB oppure dopo aver eliminato o risolto un problema della replica di Active Directory riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per risolvere il problema su Exchange 2000 Server

  1. Utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  2. Dopo aver eliminato o risolto problemi della replica di Active Directory, riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario in Exchange, consultare l'articolo 297412 della Microsoft Knowledge Base "Utilizzo dell'opzione 'Esegui ricerca DNS al contrario sui messaggi in arrivo' per la risoluzione del nome host" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sulla replica di Active Directory, consultare l'articolo 232072 della Microsoft Knowledge Base "Inizializzazione della replica tra i partner di replica diretta di Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072.

Per ulteriori informazioni sul processo DS2MB, consultare l'articolo 240105 della Microsoft Knowledge Base "XGEN: Informazioni generali sulla sincronizzazione della metabase o del servizio directory in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105.


Rilevata una discrepanza tra Active Directory e la metabase nell'impostazione della dimensione massima della sessione
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool legge la proprietà /LM/SmtpSvc/<SMTP virtual server instance>/MaxSessionSize nella metabase Internet Information Services (IIS) per determinare se il valore della proprietà corrisponde al valore configurato per l'attributo msExchSmtpMaxSessionSize nel servizio directory di Active Directory®.

Se Exchange Server Analyzer rileva una discrepanza tra i valori, verrà visualizzato un avviso.

Se il valore nella metabase IIS non corrisponde al valore in Active Directory, si può trattare di un problema della replica di Active Directory oppure di un problema del componente DS2MB (Directory-service-to-Metabase-replication) in Exchange.

La funzione del processo DS2MB è quella di trasferire le informazioni di configurazione da Active Directory alla metabase locale. Questa configurazione è archiviata nella metabase locale invece che nel Registro di sistema, per motivi di prestazioni e scalabilità. In Exchange 2000 Server ed Exchange Server 2003 tutti i protocolli Internet (SMTP, NNTP, POP3, IMAP4 e HTTP) vengono eseguiti come componenti di IIS.

Ogni 15 minuti il processo DS2MB copia le intere sottostrutture di Active Directory senza modificare la forma della sottostruttura. È una scrittura unidirezionale da Active Directory nella metabase. La metabase non scrive mai in Active Directory.

Sia la proprietà MaxSessionSize che l'attributo msExchSmtpMaxSessionSize utilizzano il valore predefinito 0 che indica che non viene imposto alcun limite di dimensione della sessione. Se la proprietà MaxSessionSize e l'attributo msExchSmtpMaxSessionSize non presentano lo stesso valore, significa che Active Directory e la metabase IIS non sono sincronizzati. Se il problema è provocato da un errore del processo DS2MB, è possibile risolverlo seguendo la procedura indicata di seguito per la versione di Exchange Server in uso. Se il problema è provocato da un errore parziale o completo della replica di Active Directory, è possibile utilizzare l'utilità Monitoraggio replica di Active Directory (ReplMon.exe) per controllare l'integrità e lo stato della replica di Active Directory. ReplMon è reperibile in Strumenti di supporto di Microsoft Windows® nel CD di Windows Server™ 2003.

Per risolvere il problema in Exchange Server 2003

  1. Verificare la presenza di voci nel registro eventi applicazioni con origine MSExchangeMU. Se si verifica un errore di DS2MB, verrà registrato un evento in Exchange Server 2003.

  2. Se non si notano errori di DS2MB, utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  3. Se si sono verificati errori di DS2MB oppure dopo aver eliminato o risolto un problema della replica di Active Directory riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per risolvere il problema su Exchange 2000 Server

  1. Utilizzare ReplMon per diagnosticare la replica di Active Directory. Prestare particolare attenzione ai server di catalogo globali utilizzati dal server virtuale SMTP.

  2. Dopo aver eliminato o risolto problemi della replica di Active Directory, riavviare il servizio Supervisore sistema di Microsoft Exchange.

Per ulteriori informazioni sulla funzione di ricerca DNS al contrario in Exchange, consultare l'articolo 297412 della Microsoft Knowledge Base "Utilizzo dell'opzione 'Esegui ricerca DNS al contrario sui messaggi in arrivo' per la risoluzione del nome host" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=297412.

Per ulteriori informazioni sulle impostazioni del server virtuale SMTP, consultare i seguenti articoli della Knowledge Base:

  • 266686, "XCON: Configurazione di un server virtuale SMTP Parte 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=266686.

  • 268163, "XCON: Configurazione di un server virtuale SMTP Parte 2" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=268163.

Per ulteriori informazioni sulla replica di Active Directory, consultare l'articolo 232072 della Microsoft Knowledge Base "Inizializzazione della replica tra i partner di replica diretta di Active Directory" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=232072.

Per ulteriori informazioni sul processo DS2MB, consultare l'articolo 240105 della Microsoft Knowledge Base "XGEN: Informazioni generali sulla sincronizzazione della metabase o del servizio directory in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240105.


Un evento di avviso della gestione connessione di trasporto è stato registrato nelle ultime 24 ore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un avviso di evento 4006 di MSExchangeTransport.

Se Microsoft Exchange Server Analyzer Tool rileva che un avviso di evento 4006 di MSExchangeTransport è stato registrato nelle ultime 24 ore, verrà visualizzato un avviso.

L'avviso indica solitamente un tentativo non riuscito di inviare messaggi di posta elettronica a un server remoto.

Un evento 4006 di MSExchangeTransport può verificarsi nelle seguenti condizioni:

  • La connessione è stata interrotta dall'host remoto.

  • Il servizio remoto SMTP ha rifiutato la negoziazione AUTH.

  • Il server che sta tentando di recapitare il messaggio non riesce ad accedere alle informazioni di recapito contenute nel messaggio.

  • Si è verificato un errore SMTP.

  • Il server che sta tentando di recapitare il messaggio non riesce a connettersi al server remoto.

  • Per qualche ragione lo SmartHost specificato nelle proprietà del server virtuale STMP non è raggiungibile.

Per ulteriori informazioni sull'avviso di evento 4006 di MSExchangeTransport, vedere Eventi ed errori all'indirizzo http://go.microsoft.com/fwlink/?LinkId=34258 (in inglese).

Per ulteriori informazioni sui problemi di inoltro della posta in Exchange Server, vedere l'articolo 895853 della Microsoft Knowledge Base "Come risolvere l'inoltro di posta emette il server 2000 in Exchange Server 2003 ed Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

Per ulteriori informazioni sui problemi di flusso di posta e SMTP, vedere "Risoluzione di problemi del flusso della posta e di SMTP " in Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.


Un evento di avviso della gestione connessione di trasporto è stato registrato nelle ultime 24 ore
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-07-07

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe Microsoft WMI (Strumentazione gestione Windows®) Win32_NTLogEvent per determinare se nelle ultime 24 ore è stato registrato un avviso di evento 4001 di MSExchangeTransport.

Se Microsoft Exchange Server Analyzer Tool rileva che un avviso di evento 4001 di MSExchangeTransport è stato registrato nelle ultime 24 ore, verrà visualizzato un avviso.

L'avviso indica solitamente un tentativo non riuscito di inviare messaggi di posta elettronica a un server remoto.

È possibile che si verifichi un avviso di evento 4001 MSExchangeTransport se il servizio SMTP su Exchange 2000 Server o Exchange Server 2003 presenta problemi di recapito della posta. Le possibili cause dei problemi di recapito della posta includono problemi a DNS, configurazione IP o l'installazione di file DLL errati.

Per ulteriori informazioni sull'avviso di evento 4001 di consultare Eventi ed errori http://go.microsoft.com/fwlink/?LinkId=34258 (in inglese).

Per ulteriori informazioni sui problemi di inoltro della posta in Exchange Server, vedere l'articolo 895853 della Microsoft Knowledge Base "Come risolvere l'inoltro di posta emette il server 2000 in Exchange Server 2003 ed Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895853.

Per ulteriori informazioni sui problemi di flusso di posta e SMTP, vedere "Risoluzione di problemi del flusso della posta e di SMTP " in Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.


File sink di evento di trasporto non rilevato
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-01-10

Microsoft® Exchange Server Analyzer Tool esegue una query nella metabase IIS (Internet Information Server) per enumerare l'elenco dei binding degli eventi sink di trasporto SMTP (Simple Mail Transport Protocol). Exchange Server Analyzer tenta di individuare diversi binding di sink di evento standard, in base a un elenco predefinito in Exchange Server Analyzer. Exchange Server Analyzer verifica i dettagli della registrazione COM (Component Object Model) per ciascun binding nel seguente ramo del Registro di sistema:

HKEY_CLASSES_ROOT\CLSID\

I dettagli della registrazione COM contengono il percorso completo del file DLL associato. Exchange Server Analyzer utilizza Microsoft WMI (Strumentazione gestione Windows®) per individuare il file DLL e visualizzarne il numero di versione. Se Exchange Server Analyzer non riesce a individuare il file DLL, verrà visualizzato un avviso con i dettagli relativi al nome e al percorso del file DLL mancante.

Se Exchange Server Analyzer rileva la mancanza di uno o più binding di eventi standard, verrà generato un avviso.

Un evento di trasporto SMTP si verifica quando i dati dei messaggi vengono trasportati all'interno o al di fuori del servizio SMTP. Tutti i messaggi passano attraverso gli eventi. Sono inclusi i messaggi in arrivo o in uscita X.400 e RPC. Un esempio comune di evento di trasporto in ingresso è l'arrivo di un messaggio al servizio SMTP in rete o nella directory di prelievo SMTP. Quando si verifica questo evento di trasporto, un'origine dell'evento informa i sink di evento di trasporto, ciascuno dei quali può eseguire un tipo di operazione in base al contenuto dei dati del messaggio. Una volta che i dati sono stati passati al sink, non vengono eseguite altre operazioni con i dati dei messaggi fino a quando il sink completa l'operazione e restituisce il messaggio. Il sink ha il controllo esclusivo dei dati dei messaggi e dello stato nel corso dell'operazione.

La mancanza dei file DLL delle registrazioni COM dei sink di evento di trasporto può causare problemi al flusso di posta. Se il server di Exchange presenta sintomi di problemi al flusso di posta, ad esempio l'accodamento dei messaggi, verificare la presenza dei file DLL identificati e reinstallarli se necessario.

Per risolvere questo problema

  1. Utilizzare Esplora risorse per individuare manualmente il file DLL identificato. In genere il file si trova nella cartella \Programmi\Exchsrvr\Bin.

  2. È consigliabile ignorare l'avviso generato da Exchange Server Analyzer se le seguenti condizioni sono vere:

    • Il file DLL è presente nella cartella elencata.

    • Nel server non si rileva alcun segnale di problema al flusso di posta.

  3. Copiare il file DLL mancante dal supporto di installazione originale del server di Exchange se le seguenti condizioni sono vere:

    • Il file DLL non è presente nella cartella elencata da Exchange Server Analyzer.

    • Il server non presente alcun sintomo di problema al flusso di posta.

    In alternativa, applicare nuovamente il Service Pack più recente per Exchange.

  4. Eseguire nuovamente Exchange Server Analyzer per verificare che l'avviso non venga più visualizzato.


Le modifiche alla versione utente delle informazioni sullo stato del collegamento vengono eliminate
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2005-11-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare de l'attributo heuristics è stato configurato per eliminare le modifiche alla versione dell'utente delle informazioni sullo stato del collegamento. Per impostazione predefinita, l'attributo heuristics non è configurato. Se Exchange Server Analyzer rileva che l'attributo heuristics è stato impostato sul valore 2048, verrà visualizzato un messaggio di configurazione non predefinita.

Le tabelle di stato dei collegamenti vengono utilizzate per garantire un routing dei messaggi efficiente e affidabile. Contengono le informazioni sulla versione per ogni gruppo di routing suddivise in modifiche principali, secondarie e modifiche relative ai numeri della versione utente. Le modifiche alla versione principale hanno la priorità più alta, seguite dalle modifiche secondarie e dalle modifiche ai numeri della versione utente.

Le modifiche alla versione utente si verificano durante l'aggiornamento del servizio directory a livello base. Queste modifiche minime possono verificarsi quando viene modificato il master del gruppo di routing, quando i servizi vengono avviati o arrestati in un server di Exchange, quando un altro server viene aggiunto al gruppo di routing oppure quando un server membro perde la connessione al master del gruppo di routing.

Un aggiornamento del servizio directory a livello base può verificarsi quando l'amministratore di Exchange Server apporta modifiche a livello del gruppo di routing. Ad esempio, una modifica alla versione utente si verifica quando l'amministratore modifica il nome di un gruppo di routing oppure aggiunge o rimuove un server. Tuttavia, la causa principale delle modifiche alla versione utente è rappresentata dai dati di Microsoft WMI (Strumentazione gestione Windows®) presenti in ogni server. In questi dati sono indicati i servizi in esecuzione. Se viene arrestato e avviato un servizio, le modifiche alla versione utente nella tabella di stato dei collegamenti vengono replicate a tutti i computer Exchange Server dell'organizzazione.

Frequenti aggiornamenti alla versione utente possono generare una quantità indesiderata di traffico di rete. Tuttavia, è possibile eliminarli richiedendo innanzitutto un aggiornamento rapido al Servizio Supporto Tecnico Clienti Microsoft, quindi impostando l'attributo heuristics su 2048 (0x800 esadecimale).

Se gli aggiornamenti alla versione utente non generano un traffico di rete eccessivo, si consiglia di non eliminarli.

Per ripristinare la configurazione predefinita

  1. Aprire ADSI Edit (Active Directory Service Interfaces).

  2. In Adsi Edit espandere Contenitore di configurazione, CN=Configuration, DC=DomainName, DC=com, CN=Services, infine CN=Microsoft Exchange.

  3. Fare clic con il pulsante destro del mouse su CN=OrganizationName, quindi scegliere Proprietà.

  4. Nella finestra Selezionare una proprietà da visualizzare fare clic su Heuristics.

  5. Nella casella Modifica attributo cancellare il valore 0x800.

  6. Fare clic su Imposta, quindi su OK.

  7. Chiudere ADSI Edit.
Attenzione
Se si modificano in modo errato gli attributi degli oggetti Active Directory quando si utilizzano ADSI Edit, lo strumento LDP (ldp.exe) o un altro client LDAP (Lightweight Directory Access Protocol) versione 3, si possono provocare problemi gravi. Per risolvere questi problemi può essere necessario reinstallare Microsoft Windows Server™ 2003, Microsoft Exchange Server 2003 o entrambi. L'utente modifica gli attributi degli oggetti Active Directory a proprio rischio.

Per ulteriori informazioni sullo stato del collegamento e sui numeri della versione utente, consultare "Propagazione dello stato del collegamento" nella Guida di riferimento tecnico di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=49367.


Utente identificato come destinazione comune
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-09-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Exchange_Queue per determinare i valori dei seguenti attributi per le code SMTP del server virtuale SMTP.

LinkId | Indica l'identificatore del collegamento che contiene la coda.
QueueId | Indica l'identificatore della coda.
QueueName | Indica il nome della coda.
VirtualMachine | Indica il nome del computer virtuale che contiene la coda.
VirtualServerName | Indica il nome del server virtuale su cui si trova la coda.
MessageCount | Indica il numero di messaggi nella coda.

In Exchange Server Analyzer vengono utilizzate le informazioni ottenute per eseguire una query nella classe WMI Exchange_QueuedSMTPMessage per determinare i valori dei seguenti attributi dei messaggi nella coda:

Recipients | Indica i destinatari del messaggio.
Received | Indica il time stamp del messaggio ricevuto.
MessageId | Indica l'identificatore del messaggio in coda.
StateRetry | Indica un nuovo tentativo di trasmissione di un messaggio non recapitato correttamente.

Infine, utilizzando i dati ottenuti dalla precedente query, Exchange Server Analyzer esegue una query nel servizio directory di Active Directory® per determinare i valori riportati di seguito per ciascun oggetto Destinatario e determinare se questo è un utente, un gruppo di distribuzione, una cartella pubblica o un archivio delle cartelle pubbliche:

distinguishedName | Indica il nome distinto dell'oggetto.
msExchHomeServerName | Indica il server in cui si trova il destinatario.
homeMDB | Indica l'archivio delle cassette postali del destinatario.

Se Exchange Server Analyzer determina che almeno il 25% dei messaggi bloccati nella coda sono indirizzati, nel campo A: o Cc:, a un utente particolare, verrà visualizzato un avviso.

Se Exchange Server Analyzer determina che almeno il 50% dei messaggi bloccati nella coda sono indirizzati, nel campo A: o Cc:, a un utente particolare, verrà visualizzato un errore.

L'avviso o l'errore indica che l'utente è identificato come destinazione comune per i messaggi bloccati in una coda SMTP.

Per risolvere il problema è necessario ricercare problemi di configurazione dell'utente o altre anomalie che possono causare un accodamento dei messaggi destinati ad esso.

Analizzare quanto segue:

  • Assicurarsi che gli attributi dell'oggetto utente siano impostati correttamente e contengano i valori corretti in Active Directory.

  • Esaminare che le impostazioni delle autorizzazioni di Active Directory per l'oggetto utente siano corrette.

  • Ricercare eventuali messaggi di posta elettronica pubblicitari non richiesti, spam o attacchi virus all'utente.

  • Determinare se l'utente appartiene a un gruppo di distribuizione con restrizioni impostate in modo non corretto.

  • Se l'oggetto utente è per uso speciale, ovvero un destinatario diario designato, esaminare che le configurazioni del servizio o dei componenti a cui è correlato l'oggetto utente siano corrette.

Per ulteriori informazioni sulla risoluzione dei problemi delle code SMTP vedere le risorse di Exchange riportate di seguito:

  • "Risoluzione di problemi del flusso della posta e di SMTP" nella Guida al trasporto e al routing di Exchange Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=67875.

  • Articolo 823489 della Microsoft Knowledge Base relativo all'utilizzo del Visualizzatore code per risolvere i problemi relativi al flusso di posta in Exchange Server 2003, all'indirizzohttp://go.microsoft.com/fwlink/?linkid=3052&kbid=823489.

Per ulteriori informazioni sull'effetto che una restrizione del gruppo di distribuzione esercita sul flusso di posta di Exchange Server, consultare gli articoli della Microsoft Knowledge Base sugli argomenti riportati di seguito:

  • 895407, relativo al recapito dei messaggi alle cassette postali locali ed esterne più lento del previsto in Exchange Server 2003 dopo aver configurato le restrizioni di recapito in base ai gruppi di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=895407.

  • 329171, relativo al recapito della posta lento se i destinatari sono configurati con restrizioni relative al recapito basate sull'appartenenza a un gruppo di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=329171.

  • 839949, relativo alla risoluzione dei problemi di trasporto della posta e dei gruppi di distribuzione in Exchange 2000 Server e in Exchange Server 2003, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=839949.

  • 812298, relativo al recapito della posta lento dopo aver configurato le restrizioni di recapito in base a una lista di distribuzione, all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=812298.


Problema SMTP sconosciuto
Articoli su Microsoft Exchange Server Analyzer > Trasporto >

Ultima modifica: 2006-10-06

Microsoft® Exchange Server Analyzer Tool esegue una query nella classe WMI (Strumentazione gestione Windows®) Win32_Service per determinare il valore della chiave Started per il servizio SMTP. Un valore False indica che il servizio SMTP non è in esecuzione. Un valore True indica che il servizio SMTP è in esecuzione.

Microsoft® Exchange Server Analyzer Tool esegue, inoltre, una query nella metabase IIS (Internet Information Services) per determinare il valore della proprietà ServerState per l'istanza di server virtuale SMTP (Simple Mail Transfer Protocol).

La proprietà ServerState fornisce lo stato corrente dell'istanza del server. I codici di stato e gli stati corrispondenti sono i seguenti:

Codice di stato | Stato
1 | Avvio in corso
2 | Avviata
3 | Arresto in corso
4 | Arrestata
5 | Sospensione in corso
6 | Sospesa
7 | Ripresa

Se si verificano le condizioni riportate di seguito, verrà visualizzato un avviso:

  • Il servizio SMTP è in esecuzione.

  • Tutte le istanze di server virtuale SMTP sul server sono state avviate.

Tale avviso indica che, sebbene il servizio SMTP e le istanze di server virtuale SMTP sembrano essere attivi, un problema che richiede un'ulteriore analisi impedisce alle porte SMTP di rispondere correttamente.

Il problema potrebbe avere le seguenti cause:

  • Il servizio SMTP è bloccato.

  • Un firewall o un'applicazione antivirus blocca la comunicazione alle porte SMTP.

Per risolvere il problema:

  • Riavviare il servizio SMTP.

  • Analizzare la configurazione di eventuali firewall o applicazioni antivirus in relazione alle porte SMTP.

  • Analizzare le indicazioni specifiche dell'errore e i collegamenti forniti da Exchange Server Analyzer.

Per avviare, arrestare o sospendere il servizio SMTP

  1. Fare clic su Start, scegliere Strumenti di amministrazione e fare clic su Servizi componenti.

  2. Nella struttura della console fare clic su Servizi (locale).

  3. Nel riquadro dei risultati fare clic con il pulsante destro del mouse su SMTP (Simple Mail Transfer Protocol), quindi su Avvia, Arresta o Sospendi.


Preparazione di Microsoft Exchange Server 2007
Articoli su Microsoft Exchange Server Analyzer >

Ultima modifica: 2006-07-18

Gli articoli contenuti in questa sezione forniscono informazioni sugli elementi valutati da Microsoft® Exchange Server Analyzer Tool relativamente alla preparazione di Microsoft Exchange Server 2007. In questi articoli, inoltre, sono descritte le operazioni da eseguire per risolvere errori, messaggi di avviso e configurazioni non predefinite relativi ai prerequisiti e rilevati da Microsoft Exchange Server Analyzer Tool.


L'ereditarietà dell'elenco di controllo di accesso (ACL) è bloccata
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-06-19

Impossibile continuare l'installazione di Microsoft Exchange Server 2007. La propagazione delle autorizzazioni richieste non è riuscita.

È necessario che l'ereditarietà delle autorizzazioni sia abilitata sugli oggetti della struttura di cartelle pubbliche.

Per risolvere il problema, accertarsi che sia abilitata l'impostazione che consente la propagazione delle autorizzazioni in base all'oggetto e agli oggetti secondari, quindi eseguire nuovamente l'installazione di Exchange Server 2007.

Per abilitare nuovamente l'ereditarietà della struttura di cartelle pubbliche

  1. Aprire Gestore di sistema di Exchange Server 2003.

  2. Fare clic con il pulsante destro del mouse sull'archivio delle cartelle pubbliche, quindi scegliere Proprietà.

  3. Scegliere la scheda Protezione, quindi fare clic per selezionare la casella di controllo Consenti propagazione delle autorizzazioni ereditabili dall'oggetto.


Per l'estensione dello schema di Active Directory è necessario installare Ldifde.exe
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-06-19

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. È necessario un aggiornamento dello schema di Active Directory sul computer locale.

Per creare le estensioni necessarie nello schema di Active Directory, è necessario che nel computer locale sia installato Ldifde.exe.

Per risolvere il problema, installare Ldifde.exe nel computer locale ed eseguire nuovamente l'installazione di Exchange Server 2007 oppure avviare l'installazione di Exchange Server 2007 da un controller di dominio.

Nota:
Dopo aver esteso lo schema di Active Direcotry, è possibile installare i ruoli del server Exchange 2007 nel computer locale senza installare ldifde.exe.
Per installare Ldifde.exe nel computer locale

  1. Fare clic su Start, Esegui e nel campo Apri eseguire ServerManagerCmd -i RSAT-ADDS.


Il percorso di installazione ADAM è esistente
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-26

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Il tentativo di installazione di ADAM (Active Directory Application Mode) non è riuscito.

Il percorso predefinito include una precedente installazione di ADAM. Non è possibile eseguire una nuova installazione di ADAM in una struttura di directory ADAM esistente.

Per risolvere questo problema, rimuovere la cartella ADAM esistente ed eseguire nuovamente l'installazione di Exchange.


ADAM non installato nel computer locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-22

L'installazione di Microsoft Exchange Server 2007 non può continuare perché ADAM (Active Directory Application Mode) non è installato nel computer.

ADAM è un servizio directory LDAP (Lightweight Directory Access Protocol) progettato specificatamente per l'utilizzo con applicazioni abilitate alle directory. ADAM consente di memorizzare e replicare solo le informazioni specifiche dell'applicazione, non richiede la distribuzione su un controller di dominio e non dipende dal servizio directory di Active Directory. ADAM non fornisce l'autenticazione o l'autorizzazione del sistema operativo della rete.

In Exchange 2007 il ruolo del server Trasporto Edge utilizza ADAM per memorizzare le informazioni sulla configurazione. Se ADAM viene sincronizzato con Active Directory, può essere utilizzato anche per eseguire ricerche sul destinatario per la protezione del messaggio.

Per poter continuare, l'installazione di Microsoft Exchange richiede che il servizio ADAM sia installato nel computer locale.

Per risolvere il problema, installare ADAM Service Pack 1 (SP1) da "ADAM (Active Directory Application Mode)" all'indirizzo http://go.microsoft.com/fwlink/?linkid=71063, quindi eseguire nuovamente l'installazione.


ADAM non è installato nel computer locale (Longhorn)
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-08-13

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. ADAM (Active Directory Application Mode) non è installato nel computer basato su Windows Server 2008.

ADAM è un servizio directory LDAP (Lightweight Directory Access Protocol) designato specificamente per l'utilizzo con applicazioni abilitate alle directory. ADAM consente di memorizzare e replicare solo le informazioni specifiche relative all'applicazione, non richiede la distribuzione in un controller di dominio e non dipende dal servizio directory di Active Directory. ADAM non fornisce l'autenticazione o l'autorizzazione del sistema operativo della rete.

In Exchange 2007, il ruolo del server Trasporto di Exchange utilizza ADAM per archiviare le informazioni sulla configurazione. Se ADAM è sincronizzato con Active Directory, può essere utilizzato per eseguire ricerche sul destinatario per la protezione del messaggio.

Prima di proseguire con l'installazione, è necessario che il servizio ADAM sia installato sul computer locale.

Per risolvere il problema, installare ADAM sul computer locale che esegue il sistema operativo Windows Server 2008, quindi eseguire nuovamente l'installazione.

Per installare ADAM nel sistema operativo Windows Server 2008

  1. Fare clic su Start, scegliere Esegui, quindi immettere il comando seguente:

  2. cmd.exe /c start /w pkgmgr.exe /iu:"DirectoryServices-ADAM"

  3. Eseguire nuovamente l'installazione di Exchange 2007.


Avviso della ricerca di Analyzer
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-08-09

L'obiettivo di questo argomento è risolvere un problema specifico correlato a Exchange Server Analyzer Tool. È applicabile solo ai sistemi su cui è stato eseguito Exchange Server Analyzer Tool e nei quali è stato riscontrato tale problema specifico.

Exchange Server Analyzer Tool, che può essere scaricato gratuitamente, raccoglie dati di configurazione in modalità remota da ogni server della topologia e li analizza in modo automatico. Nel relativo rapporto vengono fornite informazioni dettagliate su importanti problemi di configurazione, problemi potenziali e impostazioni del prodotto non predefinite. I consigli forniti consentono di migliorare le prestazioni, la scalabilità, l'affidabilità e il tempo di attività.

Per ulteriori informazioni sullo strumento o per scaricare le versioni aggiornate, consultare "Microsoft Exchange Analyzers" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34707 (informazioni in lingua inglese).


Avviso di compatibilità a 32 bit
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-08-13

Il programma di installazione di Microsoft Exchange Server 2007 ha visualizzato questo avviso perché si sta installando la versione a 32 bit di Microsoft Exchange.

Exchange 2007 è disponibile in due versioni di piattaforma: la versione a 64 bit per gli ambienti di produzione dinamici e la versione a 32 per gli ambienti non di produzione (ad esempio ambienti di lavoro, strutture per la formazione, demo e ambienti di valutazione). È possibile acquistare solo la versione a 64 bit perché non è possibile eseguire i server Exchange 2007 a 32 bit in un ambiente di produzione.

Esistono due eccezioni riguardo all'utilizzo in ambienti di produzione e non di produzione della piattaforma a 32 bit, in quanto Microsoft supporta l'utilizzo minimo della versione a 32 bit in ambienti di produzione. In particolare:

  • È possibile utilizzare la versione a 32 bit degli Strumenti di gestione di Exchange in ambienti di produzione per amministrare i server Exchange 2007 da Windows Server 2003 o Windows XP. Attualmente non è possibile utilizzare la versione a 32 bit né la versione a 64 bit su Windows Vista o su Windows Server 2008. Si prevede che il supporto per Windows Vista e Windows Server 2008 venga fornito nel Service Pack 1 per Exchange 2007.

  • È possibile utilizzare la versione a 32 bit del programma di installazione in ambienti di produzione per estendere lo schema del servizio directory di Active Directory. Per la procedura dettagliata relativa alla preparazione di Active Directory per Exchange 2007, vedere "Come preparare Active Directory e domini".

Tutti gli altri utilizzi della versione a 32 bit di Exchange 2007 in ambienti di produzione non sono supportati.

Per scaricare la versione a 32 bit degli Strumenti di gestione di Exchange, vedere "Microsoft Exchange Server 2007 Management Tools (32-Bit)" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=82335. Per ulteriori informazioni sulle versioni delle piattaforme di Exchange 2007, vedere "Exchange Server 2007: piattaforme, edizioni e versioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=88051 nella documentazione del prodotto di Exchange 2007.


È necessario installare l'aggiornamento del fuso orario 2007 per i sistemi operativi Microsoft Windows
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-02-20

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. È necessario eseguire un aggiornamento per correggere le impostazioni relative al fuso orario del computer in uso.

È necessario installare l'aggiornamento del fuso orario per i sistemi operativi Windows menzionato nell'articolo 931836 della Microsoft Knowledge Base.

Per risolvere questo problema, installare l'aggiornamento menzionato nell'articolo 931836 della Microsoft Knowledge Base, "February 2007 cumulative time zone update for Microsoft Windows operating systems", all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=931836, quindi eseguire nuovamente l'installazione di Exchange 2007.


Active Directory non esiste o è impossibile contattarlo
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-04-18

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Non è possibile contattare un sito del servizio di directory Active Directory valido.

È necessario che il server utilizzato per l'installazione di Microsoft Exchange sia in grado di individuare il contesto dei nomi di configurazione in Active Directory.

Per risolvere questo problema, verificare che l'account utente che esegue l'installazione di Microsoft Exchange sia connesso ad Active Directory, quindi eseguire nuovamente l'installazione. Se il problema persiste, seguire le istruzioni sull'utilizzo degli strumenti di supporto NETDIAG.Exe e DCDIAG.Exe negli argomenti riportati di seguito per eseguire un'ulteriore diagnosi del problema.

Per ulteriori informazioni sulla risoluzione dei problemi in Active Directory e sulla configurazione per Microsoft Exchange, vedere le seguenti risorse:

  • "Troubleshooting Active Directory Operations" in Windows Server 2003: Operations all'indirizzo http://go.microsoft.com/fwlink/?LinkId=68099 (informazioni in lingua inglese).

  • "Tools for Troubleshooting Active Directory" in Active Directory Operations Guide all'indirizzo http://go.microsoft.com/fwlink/?LinkId=68100 (informazioni in lingua inglese).

  • "Contesto dei nomi di configurazione" in "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.

  • "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.

  • "Netdiag Overview" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=69481 (in lingua inglese).

  • "Dcdiag Overview" all'indirizzo http://go.microsoft.com/fwlink/?LinkID=68936 (in lingua inglese).


Dominio Active Directory in modalità Mista
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-10

Impossibile continuare l'installazione di Microsoft® Exchange Server 2007. Un dominio di Active Directory esistente non è impostato sulla modalità originale di Microsoft Windows®° 2000 Server o superiore.

L'installazione di Exchange 2007 creerà gruppi di protezione universali che possono esistere solo in domini in modalità originale di Windows 2000 Server o superiore.

Per risolvere il problema, attenersi alla procedura descritta di seguito per aumentare il livello di funzionalità del dominio almeno fino al livello originale di Windows 2000 Server, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per aumentare il livello di funzionalità del dominio

  1. Aprire Domini e trust di Active Directory.

  2. Nella struttura della console fare clic con il pulsante destro del mouse sul dominio di cui si desidera aumentare il livello di funzionalità e quindi fare clic su Aumento livello funzionalità dominio.

  3. In Selezionare un livello funzionalità dominio disponibile eseguire una delle operazioni seguenti:

    • Per aumentare il livello di funzionalità del dominio fino al livello originale di Windows 2000 Server, fare clic su Windows 2000 originale e quindi su Aumenta.

    • Per aumentare il livello di funzionalità del dominio fino al livello di Windows Server® 2003, fare clic su Windows Server 2003 e quindi su Aumenta.
Attenzione

Non portare il livello di funzionalità a Windows 2000 Server originale se sono presenti controller di dominio che eseguono Windows NT® 4.0 e versioni precedenti o si intende aggiungerli in futuro. Se il livello di funzionalità del dominio viene impostato su Windows 2000 Server originale, non sarà più possibile riportare il livello di funzionalità a Windows 2000 Server mista.

Non portare il livello di funzionalità a Windows Server 2003 se sono presenti controller di dominio che eseguono Windows NT 4.0 e versioni precedenti o Windows 2000 Server. Se il livello di funzionalità viene aumentato fino a Windows Server 2003, non sarà più possibile ripristinare il livello di funzionalità a Windows 2000 Server mista o a Windows 2000 Server originale.


Preparazione di Active Directory obbligatoria
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-26

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di preparazione del dominio non è riuscito.

L'installazione di Exchange richiede che il servizio directory di Active Directory venga modificato per Exchange Server 2007 prima che i domini possano essere preparati in Active Directory.

Per risolvere il problema, preparare Active Directory con il comando Setup /PrepareAD e quindi preparare i domini.

Per ulteriori informazioni sull'esecuzione del processo PrepareAD, vedere "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.


La porta ADAM è già in uso
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Durante il tentativo di installazione del ruolo Gateway Server è stato rilevato che le porte assegnate per la sincronizzazione di ADAM (Active Directory® Application Mode) sono già in uso.

ADAM è un servizio directory LDAP (Lightweight Directory Access Protocol) designato specificamente per l'utilizzo con applicazioni abilitate alle directory. ADAM consente di memorizzare e replicare solo le informazioni specifiche relative all'applicazione, non richiede la distribuzione in un controller di dominio e non dipende dal servizio Active Directory. ADAM non fornisce l'autenticazione o l'autorizzazione del sistema operativo della rete.

In Exchange 2007 il server gateway utilizza ADAM per memorizzare le informazioni sulla configurazione. Se ADAM viene sincronizzato con il servizio directory Active Directory, può essere utilizzato per eseguire ricerche sul destinatario per la protezione del messaggio.

È necessaria la disponibilità di porte specifiche non utilizzate da assegnare al processo di sincronizzazione di ADAM al momento dell'installazione del ruolo Gateway Server.

Per risolvere questo problema, identificare e arrestare il processo che sta utilizzando le porte necessarie per ADAM oppure eseguire l'installazione di Exchange 2007 con le opzioni della riga di comando per sostituire le assegnazioni predefinite della porta ADAM.

Per eseguire l'installazione con la sostituzione delle assegnazioni predefinite della porta ADAM

  1. Al prompt dei comandi digitare quanto segue:

    Setup.exe /adamport:xxxx /adamsslport:yyyy

    • /adamport:<numero di porta da assegnare ad ADAM>

    • /adamsslport:<numero di porta da assegnare ad ADAM>


Gerarchia delle cartelle pubbliche dell'applicazione presente
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

Microsoft® Exchange Server Analyzer Tool esegue la ricerca della gerarchia delle cartelle pubbliche dell'applicazione nel dominio del servizio directory di Active Directory®. Se Microsoft Exchange Server Analyzer Tool rileva alberi delle cartelle pubbliche non MAPI, verrà visualizzato un avviso. L'avviso indica che nell'organizzazione di Exchange sono presenti alberi di cartelle pubbliche non MAPI. Gli alberi dell'applicazione personalizzate non sono supportati in Microsoft Exchange Server 2007.

Gli alberi delle cartelle pubbliche non MAPI vengono utilizzati per lo sviluppo di applicazioni personalizzate. Sono presenti Microsoft Exchange 2000 Server e Microsoft Exchange Server 2003 ma non sono supportati in Microsoft Exchange Server 2007. Prima della distribuzione di Microsoft Exchange Server 2007 si cosiglia di:

  • Spostare gli alberi delle cartelle pubbliche non MAPI su SharePoint Portal Server, oppure

  • Conservare i dati sul server di Microsoft Exchange Server 2003.

Per ulteriori informazioni sui vari alberi delle cartelle pubbliche, vedere "Selezione del client adatto all'accesso alle cartelle pubbliche di Exchange" all'indirizzo http:// go.microsoft.com/fwlink/?LinkId =46439 (in inglese).


Impossibile determinare il nome del sito Active Directory
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il server non sembra appartenere a un un sito del servizio directory Active Directory® valido.

È necessario che il server utilizzato per l'installazione di Exchange 2007 appartenga a un sito Active Directory valido.

Per risolvere il problema, verificare che il server locale sia un membro di un sito Active Directory valido ed eseguire nuovamente l'installazione di Exchange Server 2007.

È possibile utilizzare l'opzione /DsGetSite dello strumento della riga di comando Nltest.exe per verificare e visualizzare l'appartenenza al sito. Per ulteriori informazioni, consultare "Nltest.exe: NLTest Overview" nella sezione "Tools and Settings Collection" di Windows Server 2003 Technical Reference all'indirizzo http://go.microsoft.com/fwlink/?LinkId=27734 (informazioni in lingua inglese).

Per ulteriori informazioni sulla risoluzione dei problemi di Active Directory, consultare "Troubleshooting Active Directory Operations" in Windows Server 2003: Operations all'indirizzo http://go.microsoft.com/fwlink/?linkid=68099 (informazioni in lingua inglese).


Impossibile trovare il Servizio aggiornamento destinatari
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-05-16

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Impossibile trovare il Servizio aggiornamento destinatari responsabile del dominio nell'organizzazione di Exchange esistente.

È necessario che ciascun dominio nell' organizzazione di Exchange esistente disponga di un'istanza del Servizio aggiornamento destinatari.

Se un'istanza del Servizio aggiornamento destinatari risulta mancante per un dominio, i nuovi oggetti utente creati nel dominio non riceveranno gli indirizzi di posta elettronica a essi destinati.

Per risolvere questo problema, verificare l'esistenza di un'istanza del Servizio aggiornamento destinatari per ciascun dominio e crearne una per i domini che non ne hanno, quindi eseguire nuovamente l'installazione di Microsoft Exchange.

Per creare un'istanza del Servizio aggiornamento destinatari per un dominio

  1. Aprire il Gestore di sistema di Exchange.

  2. Espandere Destinatari.

  3. Fare clic con il pulsante destro del mouse sul nodo Servizio aggiornamento destinatari, Nuovo, quindi su Servizio aggiornamento destinatari.

  4. Nella finestra Nuovo oggetto fare clic su Sfoglia per individuare il nome del dominio.

  5. Selezionare il nome del dominio e fare clic su OK.

  6. Nella finestra Nuovo oggetto fare clic su Avanti, quindi su Fine.

Per ulteriori informazioni sul Servizio aggiornamento destinatari, vedere i seguenti articoli della Microsoft Knowledge Base:

  • "Applicazione di criteri destinatari da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=328738.

  • "Compilazione degli elenchi di indirizzi da parte del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253828.

  • "Verifica dello stato del Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=246127.

  • "Attività eseguite dal Servizio aggiornamento destinatari" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=253770.


Impossibile rimuovere il database delle cassette postali
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-06-20

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Non è possibile rimuovere un database delle cassette postali dell'utente (archivio) dal server locale senza una potenziale perdita di dati.

Exchange 2007 verifica che tutti gli archivi delle cassette postali siano stati rimossi dal server prima della rimozione del ruolo del server Cassette postali. Tuttavia, le cassette postali dell'utente potrebbero rimanere nel server.

Per risolvere il problema, spostare o disabilitare tutte le cassette postali dell'utente nel server ed eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sull'identificazione delle cassette nel database, vedere il cmdlet "Get-Mailbox" nella documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93470 (informazioni in lingua inglese).

Per ulteriori informazioni sulla disabilitazione di una cassetta postale, consultare "How to Disable a Mailbox" nella documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93471 (informazioni in lingua inglese).

Per ulteriori informazioni sulla rimozione dei database delle cassette postali in Exchange Server 2007, vedere "How to Remove a Mailbox Database" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=93473 nella documentazione del prodotto Exchange Server 2007 (informazioni in lingua inglese).

Per ulteriori informazioni sulla gestione degli archivi o delle repliche di database di cassette postali dell'utente, vedere "Gestione degli archivi di cassette postali e cartelle pubbliche" nel "Manuale dell'amministratore di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617.


Impossibile rimuovere il database delle cartelle pubbliche
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-01-23

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Non è possibile rimuovere un database delle cassette postali dal server locale senza una potenziale perdita di dati.

È necessario che il database delle cartelle pubbliche sia rimosso dal server prima della rimozione del ruolo Mailbox Server.

Le repliche delle cartelle pubbliche potrebbero rimanere nel server oppure il database delle cartelle pubbliche potrebbe essere l'ultimo nell'organizzazione di Exchange.

Per risolvere questo problema, spostare o eliminare il database delle cartelle pubbliche dal server, quindi rieseguire l'installazione di Exchange Server 2007.

Per ulteriori informazioni sulla rimozione dei database delle cartelle pubbliche in Exchange Server 2007, vedere "Come rimuovere un database di cartelle pubbliche" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=81409 nella documentazione del prodotto Exchange Server 2007.

Per ulteriori informazioni sulla gestione degli archivi o delle repliche di database delle cartelle pubbliche, vedere "Gestione degli archivi di cassette postali e cartelle pubbliche" nel "Manuale dell'amministratore di Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47617 .


Impossibile rimuovere il ruolo del server Messaggistica unificata
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-26

Impossibile continuare l'installazione di Microsoft Exchange Server 2007. Il tentativo di disinstallazione del ruolo del server Messaggistica unificata non è riuscito.

Viene verificato che il ruolo del server Messaggistica unificata da disinstallare ospiti il punto di pubblicazione dei prompt per un dial plan e che altri server siano collegati al dial plan.

Se il ruolo del server Messaggistica unificata ospita il punto di pubblicazione dei prompt per un dial plan, il processo di disinstallazione non riesce.

Per risolvere questo problema, spostare il punto di pubblicazione dei prompt in un altro server ed eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sullo spostamento del punto di pubblicazione dei prompt per un dial plan, consultare "Come modificare il punto di pubblicazione delle istruzioni" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=82356.


Impossibile scrivere nel percorso dati CMS
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-26

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di installare il ruolo del server Cassette postali in un'unità cluster condivisa non è riuscito.

Il programma di installazione di Exchange non è stato in grado di scrivere nel percorso di installazione di destinazione specificato per il parametro /CMSDataPath. È necessario che il percorso di destinazione per i dati del server di cassette postali in cluster sia un volume scrivibile.

Per risolvere il problema, specificare un percorso di destinazione per il parametro /CMSDataPath che si trovi su un supporto di archiviazione scrivibile.

Per ulteriori informazioni sull'installazione del server di cassette postali in cluster, vedere "Installazione del ruolo server Mailbox sul nodo attivo" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86624 nella documentazione del prodotto di Exchange Server 2007.


Impossibile scrivere nel contenitore dell'organizzazione di Exchange
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-05-04

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. L'utente connesso non dispone delle autorizzazioni account necessarie per scrivere nel contenitore dell'organizzazione nel servizio directory di Active Directory.

È necessario che l'utente connesso al momento dell'installazione di Microsoft Exchange Server 2007 disponga delle credenziali di Enterprise Administrator o di amministratore dell'organizzazione di Microsoft Exchange.

Come parte del processo di installazione, potrebbe essere necessario creare oggetti nel contenitore dell'organizzazione di Microsoft Exchange.

Per risolvere questo problema, concedere all'utente connesso le autorizzazioni di Enterprise Administrator o amministratore dell'organizzazione di Microsoft Exchange, oppure accedere utilizzando un account che disponga di tali autorizzazioni, quindi eseguire nuovamente l'installazione di Microsoft Exchange Server 2007.

Importante:
Non è supportata l'installazione di Exchange 2007 in più foreste. Utilizzare l'account di un utente membro della foresta Active Directory in cui si installa Exchange 2007.

Per ulteriori informazioni sulle autorizzazioni di Active Directory necessarie per Microsoft Exchange, vedere "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.


Ruolo Client Access non rilevato nel sito locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

È stato visualizzato questo avviso perché non è stato possibile rilevare un ruolo Client Access esistente nel sito locale del servizio directory Active Directory®.

Si è scelto di installare il ruolo server Mailbox prima di installare un'istanza del ruolo Client Access nel sito di Active Directory.

Il ruolo server Client Access accetta connessioni al server Exchange 2007 da una serie di client differenti. I client software come Microsoft Outlook Express ed Eudora utilizzano connessioni POP3 o IMAP4 per comunicare con il server Exchange. I client hardware, come i dispositivi portatili, utilizzano ActiveSync, POP3 o IMAP4 per comunicare con il server Exchange.

Se gli utenti accedono alle cartelle di posta in arrivo utilizzando un client diverso da Microsoft Office Outlook®, è necessario installare il ruolo server Client Access nell'organizzazione di Exchange.

Gli utenti saranno in grado di accedere alle proprie cassette postali con Outlook, ma non potranno utilizzare Client Access o dispositivi portatili con la stessa cassetta postale se il ruolo Client Access non è presente nel sito locale di Active Directory.


Le risorse cluster gestite devono essere spostate o impostate in modalità non in linea
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-04-09

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di installare un nuovo ruolo del server Cassette postali cluster non è riuscito.

Exchange Server 2007 richiede che le risorse cluster gestite siano non attive sul nodo cluster in cui è in esecuzione il programma di installazione.

Per risolvere il problema, spostare tutte le risorse cluster gestite che appartengono a questo nodo, incluse le risorse cluster diverse da Exchange Server, su un altro nodo del cluster. In alternativa, impostarle sulla modalità non in linea ed eseguire nuovamente l'installazione.

Per ulteriori informazioni su come spostare i servizi gestiti cluster correlati a Exchange, vedere l'argomento relativo al cmdlet "Move-ClusteredMailboxServer" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86627 nella documentazione del prodotto Exchange Server 2007.

Per ulteriori informazioni su come impostare la modalità non in linea per i servizi gestiti cluster correlati a Exchange, vedere l'argomento relativo al cmdlet "Stop-ClusteredMailboxServer" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86635 nella documentazione del prodotto di Exchange Server 2007.

Per ulteriori informazioni sulla gestione delle risorse cluster diverse da Exchange, vedere "Gestire risorse" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86637 nella Guida del prodotto di Windows Server 2003.


Il servizio cluster non è avviato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-26

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Il servizio cluster di Microsoft Windows Server non è avviato.

Per installare Exchange 2007, è necessario che il servizio cluster venga avviato al momento dell'installazione nel computer locale.

Per risolvere il problema, avviare il servizio cluster sul computer locale ed eseguire nuovamente l'installazione di Exchange.

Per avviare il servizio cluster, consultare "Start the Cluster service" nella Libreria tecnica di Windows Server 2003 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86638 (informazioni in lingua inglese).


Il cluster richiede un aggiornamento (KB921181)
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-11

Impossibile continuare l'installazione di Microsoft® Exchange Server 2007. Il nodo cluster richiede un aggiornamento.

È necessario installare l'aggiornamento del nodo cluster menzionato nell'articolo 921181 della Microsoft Knowledge Base.

Per risolvere il problema, installare l'aggiornamento indicato nell'articolo 921181 della Microsoft Knowledge Base "È disponibile un aggiornamento che aggiunge funzionalità di osservazione condivisione file e heartbeat del cluster a cluster di server basati su Windows Server 2003 Service Pack 1" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69785, quindi eseguire nuovamente l'installazione di Exchange 2007.


Il percorso dati CMS deve essere il volume NTFS
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-26

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. Il tentativo di installare il ruolo del server cassette postali cluster non è riuscito.

Il percorso di installazione di destinazione inoltrato per il parametro /CMSDataPath non è un volume NTFS. Per poter installare Exchange, è necessario che il percorso di destinazione dei dati del server cassette postali cluster sia un volume NTFS.

Per risolvere il problema, selezionare un diverso percorso di destinazione per /CMSDataPath oppure convertire il volume di destinazione in NTFS, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sulla conversione di un volume in NTFS, vedere l'argomento "Convert" nella documentazione del prodotto Windows XP Professional all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86642 (informazioni in lingua inglese).


Il nodo cluster corrente è proprietario dei servizi di gestione cluster
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-04-09

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di disinstallare il nodo passivo cluster non è riuscito.

I servizi di gestione cluster di Exchange appartengono a questo nodo cluster. L'installazione di Exchange 2007 richiede che i servizi di gestione cluster di Exchange vengano spostati da questo nodo prima che i file di Exchange possano essere rimossi.

Per risolvere il problema, spostare tutte le risorse cluster gestite che appartengono al nodo, incluse le risorse cluster diverse da Exchange Server, su un altro nodo del cluster, oppure impostarle sulla modalità non in linea, quindi eseguire nuovamente l'installazione.

Per ulteriori informazioni su come spostare i servizi gestiti cluster correlati a Exchange, vedere l'argomento relativo al cmdlet "Move-ClusteredMailboxServer" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86627 nella documentazione del prodotto Exchange Server 2007.

Per ulteriori informazioni su come impostare la modalità non in linea per i servizi gestiti cluster correlati a Exchange, vedere l'argomento relativo al cmdlet "Stop-ClusteredMailboxServer" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86635 nella documentazione del prodotto di Exchange Server 2007.

Per ulteriori informazioni sulla gestione delle risorse cluster diverse da Exchange, vedere "Gestire risorse" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86637 nella Guida del prodotto di Windows Server 2003.


È necessario avviare il servizio COM+ Event System prima di continuare con l'installazione
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-16

Impossibile continuare l'installazione di Microsoft Exchange Server 2007. Il tentativo di installare i ruoli server Server Accesso client o Trasporto Edge non è riuscito. Il servizio COM+ Event System non è stato avviato sul computer di destinazione.

È necessario che il computer in cui si installa Microsoft Exchange presenti lo stato del servizio COM+ Event System impostato su Avviato.

Il servizio COM+ Event System supporta la notifica degli eventi di sistema per i componenti COM+ , i quali supportano la distribuzione automatica degli eventi ai componenti COM che vi partecipano.

I ruoli server Server Accesso client e Trasporto Edge presentano dipendenze dai componenti COM+ che partecipano al servizio COM+ Event System.

Per risolvere questo problema, verificare che lo stato del servizio COM+ Event System sia impostato su Avviato sul computer locale, quindi eseguire nuovamente l'installazione di Microsoft Exchange.

Per impostare lo stato del servizio COM+ Event System su 'Avviato'

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Gestione.

  2. Espandere il nodo Servizi e applicazioni, quindi fare clic sul nodo Servizi.

  3. Nel riquadro destro individuare Com+ Event System.

  4. Fare clic con il pulsante destro del mouse su COM+ Event System, quindi scegliere Proprietà.

  5. Verificare che il Tipo di avvio sia impostato su Automatico e lo Stato del servizio su Avviato.

  6. Fare clic su Applica, quindi su OK.


Modello organizzazione di Exchange complesso rilevato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-10

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di gruppi di routing nell'organizzazione di Exchange Server. Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il numero di siti Active Directory con server di Exchange che eseguono Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003.

Exchange Server Analyzer classifica l'organizzazione di Exchange come organizzazione complessa se si verificano le condizioni riportate di seguito:

  • Esistono più foreste di Active Directory.

  • Microsoft Identity Integration Server (MIIS) viene installato in una o più foreste.

Dei quattro modelli di organizzazione definiti per Microsoft Exchange Server 2007, l'organizzazione complessa rappresenta l'unico modello che include più foreste di Active Directory oppure prevede l'utilizzo di una tecnologia di sincronizzazione.

Per eseguire la transizione di un'organizzazione di Exchange complessa a Exchange 2007

  1. Consultare la documentazione in linea del prodotto Exchange 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69434 (informazioni in lingua inglese).

  2. Esaminare l'argomento "Planning for a Complex Exchange Organization" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70505 (informazioni in lingua inglese).


Impossibile trovare il "Sito web predefinito" nel computer locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Non è possibile accedere al sito Web predefinito nel server.

È necessario che l'installazione del ruolo Client Access acceda al sito Web predefinito creato da Microsoft IIS.

Il ruolo server Client Access fornisce la funzionalità per l'accesso client, quali Microsoft Office Outlook® (nella connessione su HTTP), Outlook Web Access, Exchange ActiveSync® e client che utilizzano i protocolli POP3 o IMAP4.

IIS funge da motore per i protocolli HTTP, POP3, IMAP4, Simple Mail Transfer Protocol (SMTP) e Network News Transfer Protocol (NNTP).

Potrebbero verificarsi situazioni in cui il sito Web predefinito di IIS non esiste più. Potrebbe essere stato eliminato o rinominato in modo differente da Sito Web predefinito.

Per risolvere questo problema, rimuovere, quindi reinstallare IIS nel server. Rieseguire l'installazione di Exchange 2007.

Importante:
Per risolvere questo problema, è necessario disinstallare e reinstallare IIS. Non è sufficiente ricreare o rinominare la directory.
Per disinstallare IIS utilizzando Installazione componenti di Windows nel Pannello di controllo

  1. Nel menu Start scegliere Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Dall'elenco Componenti selezionare la casella di controllo Server applicazioni.

  5. Fare clic su Dettagli.

  6. Fare clic su Gestione Internet Information Services.

  7. Fare clic su Avanti.

  8. Una volta terminata la disinstallazione di IIS, fare clic su Fine.
Per installare IIS tramite il Pannello di controllo

  1. Nel menu Start scegliere Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Dall'elenco Componenti selezionare la casella di controllo Server applicazioni.

  5. Fare clic su Dettagli.

  6. Fare clic sulla casella di controllo Gestione Internet Information Services.

  7. Fare clic su OK fino a quando non viene visualizzato Aggiunta guidata componenti di Windows.

  8. Fare clic su Avanti e completare l'Aggiunta guidata componenti di Windows.


Per continuare con l'installazione è necessario avviare il servizio Distributed Transaction Coordinator
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-16

Impossibile continuare l'installazione di Microsoft Exchange Server 2007. Il tentativo di installare i ruoli server Server Accesso client o Messaggistica unificata non è riuscito. Il servizio Distributed Transaction Coordinator non è stato avviato sul computer di destinazione. .

È necessario che il computer in cui si installa Microsoft Exchange presenti lo stato del servizio Distributed Transaction Coordinator impostato su Avviato.

Distributed Transaction Coordinator fornisce servizi che garantiscono la buona riuscita di transazioni complete, anche in caso di errori di sistema, di processo e di comunicazione.

Ogni computer che partecipa a una transazione distribuita si occupa della gestione delle proprie risorse e dei propri dati e, inoltre, collabora con gli altri computer coinvolti nella transazione. La transazione distribuita deve soprattutto eseguire il commit o interrompere completamente il proprio lavoro su tutti i computer che partecipano alla transazione. Il servizio Distributed Transaction Coordinator esegue il ruolo di coordinatore delle transazioni per i componenti interessati e funge da gestore delle transazioni per ogni computer che si occupa della gestione delle transazioni.

I ruoli server sia Accesso client sia Messagistica unificata presentano dipendenze dal servizio Distributed Transaction Coordinator.

Per risolvere questo problema, verificare che il servizio di Distributed Transaction Service sia impostato su Avviato sul computer locale, quindi eseguire nuovamente l'installazione di Microsoft Exchange.

Per impostare lo stato del servizio Distributed Transaction Coordinator su 'Avviato'

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Gestione.

  2. Espandere il nodo Servizi e applicazioni, quindi fare clic sul nodo Servizi.

  3. Nel riquadro destro individuare Distributed Transaction Coordinator.

  4. Fare clic con il pulsante destro del mouse su Distributed Transaction Coordinator, quindi scegliere Proprietà.

  5. Verificare che il Tipo di avvio sia impostato su Automatico e lo Stato del servizio su Avviato.

  6. Fare clic su Applica, quindi su OK.


Il suffisso DNS non è impostato sul computer locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il nome di dominio completo del computer locale non è impostato.

È necessario che il computer locale disponga di un suffisso DNS valido impostato.

Per risolvere questo problema, impostare il suffisso DNS per il computer locale, riavviare il computer, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per impostare il suffisso DNS primario del computer locale

  1. Fare clic con il pulsante destro del mouse su Risorse del computer, quindi su Proprietà. Verrà visualizzata la finestra di dialogo Proprietà del sistema.

  2. Selezionare la scheda Nome computer.

  3. Fare clic su Cambia. Viene visualizzata la finestra di dialogo Cambiamenti nome computer.

  4. Fare clic su Altro. Viene visualizzata la finestra di dialogo Suffisso DNS e nome NetBIOS del computer.

  5. Immettere il suffisso DNS appropriato per il dominio.

  6. Selezionare la casella di controllo Cambia suffisso DNS primario quando cambia l'appartenenza al dominio.

  7. Fare clic su OK per salvare le modifiche e nuovamente su OK per uscire dalla finestra di dialogo Cambiamenti nome computer.

  8. Fare clic su OK per chiudere la finestra di dialogo Proprietà del sistema e riavviare il computer per rendere effettive le modifiche.

Per ulteriori informazioni sui nomi DNS, vedere l'articolo 909264 della Microsoft Knowledge Base "Convenzioni di denominazione in Active Directory per computer, domini, siti e UO" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264.


La sostituzione del controller di dominio è impostata nel Registro di sistema
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. Il tentativo di utilizzare il controller di dominio specificato non è riuscito. Un controller di dominio è stato mappato staticamente nel Registro di sistema.

È necessario che il controller di dominio specificato nel comando di installazione corrisponda al controller di dominio mappato staticamente utilizzando una sostituzione del Registro di sistema.

Per risolvere questo problema, eseguire nuovamente l'installazione specificando il controller di dominio mappato staticamente per il parametro /DomainController: <FQDN del parametro controller di dominio mappato staticamente> .

Per ulteriori informazioni su DSAccess e sul rilevamento dei servizi directory, consultare l'articolo 250570 della Microsoft Knowledge Base, "Rilevamento del server del servizio di directory e utilizzo di DSAccess" all'indirizzo (http://go.microsoft.com/fwlink/?linkid=3052&kbid=250570.


Preparazione dominio necessaria
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. Il tentativo di installare il ruolo del server non è riuscito.

Prima di poter installare alcuni ruoli del server, è necessario che il dominio locale sia preparato per Exchange Server 2007.

La preparazione del dominio per Exchange Server 2007 consiste nelle seguenti operazioni:

  • Impostazione delle autorizzazioni nel contenitore Configurazione per i server Exchange, gli amministratori dell'organizzazione di Exchange, gli utenti autenticati e gli amministratori delle cassette postali di Exchange.

  • Creazione del contenitore Oggetti di sistema di Microsoft Exchange, se non già esistente, e impostazione nello stesso delle autorizzazioni per i server Exchange, gli amministratori dell'organizzazione di Exchange e gli utenti autenticati.

  • Creazione di un nuovo gruppo globale di dominio, all'interno del dominio corrente, denominato Exchange Install Domain Servers.

  • Aggiunta del gruppo Exchange Install Domain Servers al gruppo di protezione universale dei server Exchange nel dominio radice.

Per risolvere il problema, eseguire setup/PrepareDomain per preparare il dominio locale e riprovare a installare il ruolo del server.

Per ulteriori informazioni sul processo PrepareDomain, vedere "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.


Impossibile installare il ruolo Edge Transport nel computer locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-01-03

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Durante il tentativo di installazione del ruolo del server Edge è stato rilevato che altri ruoli Microsoft Exchange sono già installati nel server.

Non è possibile installare il ruolo del server Edge in un server in cui sono installati altri ruoli Microsoft Exchange.

Il ruolo del server Edge di Microsoft Exchange viene distribuito nella rete perimetrale dell'organizzazione e gestisce tutto il flusso di posta connesso a Internet. Fornisce la crittografia e la decrittografia dei messaggi inviati tra organizzazioni Microsoft Exchange attendibili nonché la protezione contro la posta indesiderata.

Per risolvere questo problema, installare il ruolo del server Edge in un computer in cui non sono installati altri ruoli Microsoft Exchange.


Connettore EDK nella topologia
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-04

Microsoft® Exchange Server Analyzer Tool esegue la verifica nel servizio directory di Active Directory® per rilevare la presenza di connettori EDK (Exchange Development Kit) nell'organizzazione di Microsoft Exchange. Se in Active Directory vengono rilevati connettori EDK, verrà visualizzato un avviso. L'avviso indica che i connettori EDK non sono supportati in Microsoft Exchange Server 2007.

Si consiglia di contattare il fornitore di terze parti per richiedere un connettore sostitutivo per Microsoft Exchange Server 2007, oppure è possibile tenere Microsoft Exchange Server 2003 o Microsoft Exchange 2000 per supportare il connettore EDK.

Nota:
I connettori EDK sono applicazioni di terze parti create per la connessione a sistemi di comunicazione, quali fax, SMS (Short Message Service), telex o ad altri sistemi di messaggistica, quali Lotus Notes, che utilizzano un connettore gateway. I fornitori non Microsoft utilizzano Exchange Development Kit (EDK) per sviluppare connettori proprietari.


Esm.dll è in uso da uno o più processi
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-28

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di aggiornare il server è stato ostacolato da un problema di accesso a un modulo.

L'installazione di Exchange 2007 richiede che determinati moduli non siano in esecuzione per consentire all'aggiornamento di modificare i file binari. Il file Esm.dll è uno di tali moduli.

Per risolvere il problema, scaricare i processi che utilizzano Esm.dll, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per interrompere il processo che utilizza Esm.dll

  1. Avviare Exchange Management Shell.

  2. Utilizzare il cmdlet Get-Process per trovare l'ID processo dei processi identificati da Exchange Analyzer.

  3. Get-Process < nome processo >

  4. Utilizzare il cmdlet Stop-Process per interrompere il processo.

  5. Stop-Process < ID processo >

  6. Dove <process ID> è il valore dell'ID processo restituito dal cmdlet Get-Process nel passaggio 2.

Per ulteriori informazioni sul cmdlet Get-Process, vedere Using the Get-Process Cmdlet nell'argomento "What Can I Do With Windows PowerShell?" (informazioni in lingua inglese).


"ExchHelp.chm" è aperto
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-16

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di aggiornare il server è stato ostacolato da un problema di accesso a un file.

L'installazione di Exchange 2007 richiede che determinati file siano chiusi per consentire al processo di aggiornamento di modificare tali file, o i processi che devono accedere ai file. Il file della Guida di Exchange (ExchHelp.chm) è uno di tali questi file.

Per risolvere il problema, chiudere il file ExchHelp.chm, quindi eseguire nuovamente l'installazione di Exchange 2007.


I computer Exchange 2000 Server richiedono l'aggiornamento a SP3
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. In uno o più server nell'organizzazione esistente è in esecuzione Exchange 2000 Server non aggiornato al Service Pack 3 o versioni successive.

È necessario che tutti i computer Exchange 2000 Server in uso nell'organizzazione eseguano Exchange 2000 Server Service Pack 3 (SP3).

Per risolvere il problema, eseguire l'aggiornamento dei computer Exchange 2000 Server in uso nell'organizzazione a Exchange 2000 Server SP3 o versioni successive, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sull'aggiornamento dei computer Exchange Server 2000 a Exchange 2000 Server SP3 o versioni successive, consultare "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86647 (informazioni in lingua inglese).


Organizzazione di Microsoft Exchange in modalità mista
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel contenitore dell'organizzazione di Microsoft Exchange per determinarne la modalità. Microsoft Exchange Server Analyzer Tool verifica il valore dell'attributo msExchangeMixedMode. Se il valore dell'attributo msExchangeMixedMode è True, Microsoft Exchange Server Analyzer Tool visualizzerà un errore. Il messaggio di errore indica che l'organizzazione di Microsoft Exchange è in esecuzione in modalità mista. È possibile installare Microsoft Exchange Server 2007 soltanto in un'organizzazione in esecuzione in modalità nativa. Pertanto, è necessario modificare la modalità di esecuzione di un'organizzazione dalla modalità mista alla modalità nativa per predisporre la distribuzione di Microsoft Exchange Server 2007.

Nota:
Un'organizzazione in esecuzione in modalità nativa può comprendere solo server Microsoft Exchange 2000 Server o versioni successive.

Per predisporre la distribuzione di Microsoft Exchange Server 2007, è necessario convertire l'organizzazione di Microsoft Exchange in modalità nativa procedendo come segue:

  1. Rimuovere o ritirare l'autorizzazione dei server di Exchange 5.5 ancora in uso.

  2. Nel Gestore di sistema di Exchange, aprire le proprietà dell'oggetto dell'organizzazione di Microsoft Exchange e modificare la modalità a nativa.

Per ulteriori informazioni sulla conversione dell'organizzazione di Exchange nella modalità nativa, vedere "Conversione dalla modalità mista a quella nativa in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56642 nel Manuale di installazione di Exchange Server 2003.

Per ulteriori informazioni sulla modalità mista e la modalità nativa di Microsoft Exchange, vedere i seguenti articoli della Knowledge Base:

  • 270143 "Descrizione di modalità mista e modalità nativa in Exchange 2000 Server ed Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=270143.

  • 327779 "Come convertire dalla modalità mista alla modalità nativa in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779.

  • 272314, "XADM: Preparazione di un'organizzazione in modalità mista per la conversione in modalità nativa" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=272314.


Aggiornamento alla versione SP2 necessario per i computer Exchange Server 2003
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. In uno o più server nell'organizzazione esistente che eseguono Exchange Server 2003 non è installato il Service Pack 2 o versioni successive.

Per installare Exchange 2007, è necessario che tutti i computer Exchange Server 2003 in uso nell'organizzazione eseguano Exchange Server 2003 Service Pack 2 (SP2) o versioni successive.

Per risolvere il problema, eseguire l'aggiornamento dei computer Exchange Server 2003 in uso nell'organizzazione a Exchange Server 2003 SP2 o versioni successive, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sull'aggiornamento dei computer Exchange Server 2000 a Exchange Server 2003 SP2 o versioni successive, consultare "Downloads for Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=21030 (informazioni in lingua inglese).


Impossibile utilizzare Exchange Server 2007 con questa versione di Windows
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Sul computer locale non è in esecuzione una versione del sistema operativo Microsoft Windows Server supportata da Exchange Server 2007.

È necessario che la versione di Windows Server installata nel computer locale sia supportata per l'esecuzione di Exchange Server 2007, in base ai requisiti di sistema specificati per Exchange Server 2007.

Per risolvere questo problema, installare una versione di Exchange Server 2007 supportata dal sistema operativo Windows Server disponibile sul computer locale, oppure installare Exchange Server 2007 in un computer che esegue una versione di Windows Server supportata.

Per ulteriori informazioni sui requisiti di sistema di Exchange Server 2007, consultare "Exchange Server 2007 System Requirements" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86651 (in lingua inglese).


Witness di condivisione file non configurato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-23

L'installazione di Microsoft Exchange Server 2007 non può continuare perché un witness di condivisione file non è stato configurato per il cluster di replica continua cluster (CCR, Cluster Continuous Replication).

Per sostenere l'errore in qualsiasi nodo in un cluster quorum a maggioranza dei nodi, è necessario disporre di almeno tre dispositivi che possono essere considerati disponibili. La funzionalità di witness di condivisione file consente di utilizzare una condivisione file esterna come witness. Tale witness funge da terzo dispositivo disponibile in un cluster quorum a maggioranza dei nodi a due nodi.

L'installazione di Exchange 2007 richiede che la funzionalità di witness di condivisione file sia configurata per l'installazione del ruolo del server Cassette postali cluster in un ambiente di replica continua cluster.

Per risolvere il problema, eseguire la procedura per creare e proteggere la condivisione file per il witness di condivisione file illustrata in "Come configurare il witness di condivisione file" (http://go.microsoft.com/fwlink/?LinkId=78278). Impostare quindi il valore MNSFileShare, spostare il gruppo cluster due volte e provare a installare nuovamente Microsoft Exchange.


Impossibile delegare la prima installazione del ruolo
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. L'utente connesso non dispone delle autorizzazioni di account necessarie per installare il primo ruolo del server nella topologia.

Sebbene il programma di installazione di Microsoft Exchange consenta l'uso della delega per installare i successivo ruoli del server, è necessario che l'utente connesso disponga delle credenziali di amministratore dell'organizzazione di Exchange quando viene installato il primo dei ruoli del server di Exchange 2007 nella topologia.

Come parte del processo di installazione del primo ruolo del server, potrebbe essere necessario creare oggetti nel contenitore dell'organizzazione di Exchange.

Per risolvere questo problema, concedere all'utente connesso le autorizzazioni di amministratore dell'organizzazione di Exchange oppure accedere con un account che dispone di tali autorizzazioni, quindi eseguire nuovamente l'installazione di Exchange 2007.


È necessario disabilitare Forefront Security for Exchange Server Services
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-06-20

L'aggiornamento di Microsoft Exchange Server 2007 non può continuare perché sul computer locale sono in esecuzione i servizi di Microsoft Forefront Security for Exchange Server.

Per l'installazione di Exchange è necessario disabilitare i servizi di Forefront Security per Exchange Server prima di poter proseguire l'aggiornamento di Exchange Server 2007.

Per risolvere il problema, disabilitare i servizi di Forefront Security for Exchange Server ed eseguire nuovamente l'aggiornamento di Exchange Server.

Per ulteriori informazioni sull'installazione di un Service Pack o di un aggiornamento software di Exchange Server che esegue Forefront Security, consultare l'articolo 929080 della Microsoft Knowledge Base Come installare un service pack o un aggiornamento software in un computer Exchange Server che esegue Forefront Security.


È necessario aggiornare Forefront Security per Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Si applica a: Exchange Server 2007, Exchange Server 2007 SP1
Ultima modifica: 2007-08-08

L'aggiornamento di Microsoft Exchange Server 2007 non può continuare perché sul computer locale è in esecuzione una versione di Microsoft Forefront Security per Exchange Server non supportata da Exchange Server 2007 Service Pack 1 (SP1).

Per l'installazione di Exchange è necessario aggiornare la versione di Microsoft Forefront Security per Exchange Server e disattivare i relativi servizi prima di poter proseguire l'aggiornamento di Exchange Server 2007.

Per risolvere questo problema, eseguire l'aggiornamento di Microsoft Forefront Security per Exchange Server versione 10.0 a Microsoft Forefront Security per Exchange Server SP1, quindi disattivare i servizi di Microsoft Forefront Security per Exchange Server prima di riprendere l'aggiornamento di Exchange Server.

Per ulteriori informazioni

Per ulteriori informazioni sull'installazione di un Service Pack o di un aggiornamento software di Exchange Server che esegue Forefront Security, consultare l'articolo 929080 della Microsoft Knowledge Base "Come installare un service pack o un aggiornamento software in un computer Exchange Server che esegue Forefront Security" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=929080.


Il nome di dominio completo del computer corrisponde a un criterio destinatario
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-05-16

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il nome di dominio completo del computer locale corrisponde all'indirizzo SMTO di un criterio destinatario.

È necessario che il nome di dominio completo dei server in un'organizzazione di Exchange non corrisponda ad indirizzi SMTP dei criteri destinatari nella stessa organizzazone di Exchange.

Se il nome di dominio completo di un computer corrisponde all'indirizzo SMTP di un criterio destinatario, tale corrispondenza può provocare un errore della posta in SMTP che si blocca nelle code dell'MTA.

Per risolvere il problema, rinominare il computer locale oppure rimuovere o rinominare il criterio destinatario ed eseguire nuovamente l'instalalzione di Microsoft Exchange.

Per rinominare il computer locale

  1. In Pannello di controllo aprire Sistema .

  2. Nella scheda Nome computer scegliere Cambia.

  3. In Nome computer digitare un nuovo nome per il computer, quindi scegliere OK. Verrà chiesto di fornire un nome utente e una password per rinominare il computer nel dominio.

  4. Fare clic su OK per chiudere la finestra di dialogo Proprietà sistema. Verrà chiesto di riavviare il computer per rendere effettive le modifiche.
Importante:
Se il computer da rinominare è un controller di dominio, vedere "Rinominare un controller di dominio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66828.
Per modificare l'indirizzo SMTP del criterio destinatario

  1. Avviare Gestore di sistema di Exchange.

  2. Fare clic su Organizzazione, quindi su Destinatari e infine su Criteri destinatari.

  3. Fare doppio clic sul criterio che si desidera modificare.

  4. Fare clic sulla scheda Indirizzi di posta elettronica, quindi modificare l'indirizzo SMTP appropriato.

Per ulteriori informazioni sui problemi di denominazione dei criteri destinatari, consultare l'articolo 288175 della Microsoft Knowledge Base "XCON: Il criterio destinatario non può corrispondere al nome di dominio completo di un server nell'organizzazione, NDR 5.4.8" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=288175).


Nessun server di catalogo globale nel sito locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Non è presente alcun server di catalogo globale nel sito in cui si sta tentando di installare Microsoft Exchange.

È necessario che il sito del servizio directory Active Directory® del computer che sta eseguendo l'installazione contenga un server che funge da catalogo globale.

Per risolvere questo problema, eseguire una delle seguenti procedure:

  • Denominare un controller di dominio esistente nel sito come server di catalogo globale.

  • Installare un nuovo server nel ruolo server Global Catalog.

Per denominare un controller di dominio esistente nel sito come server di catalogo globale

  1. Aprire Siti e servizi di Active Directory.

  2. Espandere Siti, il sito e infine Server.

  3. Selezionare il controller di dominio che si desidera specificare come server di catalogo globale.

  4. Nel riquadro di destra fare clic con il pulsante destro del mouse su Impostazioni NTDS e scegliere Proprietà.

  5. Nella scheda Generale selezionare la casella di controllo Catalogo globale. La modifica viene eseguita in modo dinamico senza dover riavviare il server.
  • Per ulteriori informazioni sulla creazione di server di catalogo globale, vedere l'articolo 313994 della Microsoft Knowledge Base "HOW TO: Creare o spostare un catalogo globale in Windows 2000" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=313994.

  • Per ulteriori informazioni sul posizionamento e la disponibilità di server di catalogo globale in relazione a Exchange Server, vedere l'articolo 875427 della Microsoft Knowledge Base "Posizionamento e disponibilità dei server di catalogo globale in un'organizzazione Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=875427.


Necessario aggiornamento globale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-09-19

Impossibile contiunare l'installazione di Microsoft® Exchange Server 2007. L'utente connesso non dispone delle autorizzazioni dell'account necessarie per eseguire l'aggiornamento globale al servizio directory Active Directory®.

È necessario che l'utente connesso al momento dell'installazione di Microsoft Exchange Server 2007 disponga delle credenziali di amministratore dell'organizzazione.

Come parte del processo di installazione, l'installazione di Microsoft Exchange Server 2007 potrebbe necessitare di eseguire le seguenti operazioni:

  • Creare o modificare gli oggetti dell'organizzazione di Exchange nel servizio directory di Active Directory.

  • Preparare tutti i domini nella foresta di Active Directory di Microsoft Exchange Server 2007.

  • Preparare i domini esistenti di Microsoft Exchange 2000 Server e Microsoft Exchange Server 2003 per Microsoft Exchange Server 2007.

Per risolvere questo problema, concedere all'utente connesso le autorizzazioni di Enterprise Administrator oppure accedere con un account che dispone di tali autorizzazioni, quindi eseguire nuovamente l'installazione di Microsoft Exchange Server 2007.

Per ulteriori informazioni sulle autorizzazioni di Active Directory necessarie per Microsoft Exchange, vedere "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.


Impossibile trovare il record Host per il computer locale nel database DNS
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Impossibile trovare il record Host (A) per il computer nel database DNS (Domain Name System).

È necessario che il computer locale abbia un record HOST (A) valido registrato con il database DNS autorevole per il dominio.

Microsoft Exchange dipende dai record Host DNS (A) per l'indirizzo IP del successivo server di destinazione interno o esterno.

Per risolvere questo problema:

  • Verificare che la configurazione TCP/IP locale faccia riferimento al server DNS corretto.

    Per verificare la configurazione TCP/IP locale

    1. Rivedere la configurazione TCP/IP locale. Per ulteriori informazioni, vedere "Configurare TCP/IP per l'utilizzo del servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=68094.
  • Utilizzare Nslookup.exe per verificare che il record Host (A) esista nel server DNS. Per ulteriori informazioni, vedere "Per verificare l'esistenza di record di risorse A nel sistema DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63001.

Per informazioni sulla risoluzione dei nomi DNS, la risoluzione dei problemi e i record Host (A), vedere le seguenti risorse:

  • Articolo 322856 della Microsoft Knowledge Base "Configurazione del DNS per l'utilizzo con Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=322856.

  • "Risoluzione dei problemi relativi al servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63003.

  • "Gestione dei record di risorse" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63004.


Ruolo Hub Transport non rilevato nel sito locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

Questo avviso viene visualizzato quando non è possibile rilevare un ruolo server Hub Transport esistente nel sito locale del servizio directory Active Directory®.

Si è scelto di installare il ruolo server Mailbox prima di installare un'istanza del ruolo Hub Transport nel sito di Active Directory.

I servizi Hub Transport di Exchange 2007 vengono distribuiti in Active Directory all'interno dell'organizzazione. I servizi Hub Transport gestiscono il flusso di posta all'interno dell'organizzazione, applica le regole di routing del flusso di posta dell'organizzazione e sono responsabili del recapito dei messaggi alla casella postale del destinatario.

Gli utenti potranno accedere alle proprie cassette postali, ma non sarà possibile inviare o ricevere posta da questo server cassette postali finché non viene installato un ruolo Hub Transport.


Hub Transport Server Not Present in Active Directory Site
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-07-25

Microsoft Exchange Analyzer Tool interroga il servizio directory di Active Directory per determinare il valore di qualsiasi oggetto della classe msExchAdminGroupContainer nell'organizzazione di Exchange che contenga lo specifico identificatore del gruppo amministrativo di Exchange Server 2007, ovvero FYDIBOHF23SPDLT.

Se Exchange Analyzer determina che esiste un gruppo amministrativo di Exchange Server 2007 nell'organizzazione di Exchange, interrogherà tutti i siti Active Directory nell'organizzazione per determinare il valore dell'attributo msExchCurrentServerRoles per ciascun oggetto msExchExchangeServer, allo scopo di verificare se è stato installato un ruolo del server Cassette postali su uno qualsiasi dei siti rilevati.

Infine, se Exchange Analyzer determina che è stato installato un ruolo del server Cassette postali su uno dei siti, eseguirà la query dell'attributo msExchCurrentServerRoles di ciascun oggetto msExchExchangeServer in tale sito, al fine di determinare se è stato installato anche un ruolo del server Trasporto Hub sullo stesso sito.

Se Exchange Analyzer determina che è stato installato un ruolo del server Cassette postali su un sito Active Directory su cui non è stato installato alcun ruolo del server Trasporto Hub, verrà visualizzato un errore.

Il messaggio di errore indica che, sebbene sia stato installato un ruolo del server Cassette postali sul sito Active Directory, la posta non verrà trasferita tra le cassette postali, anche se si trovano sullo stesso server, finché non viene installato almeno un ruolo del server Trasporto Hub sul sito.

Il ruolo del server Trasporto Hub viene distribuito all'interno del servizio directory di Active Directory dell'organizzazione. Gestisce tutto il flusso di posta all'interno dell'organizzazione, applica le regole dei messaggi dell'organizzazione ed è responsabile del recapito dei messaggi alla cassetta postale di un destinatario. I server Trasporto Hub forniscono le seguenti funzionalità:

Flusso di posta Il ruolo del server Trasporto Hub elabora tutti i messaggi che vengono inviati nell'organizzazione di Exchange 2007 prima del loro recapito alla cassetta postale di un destinatario all'interno dell'organizzazione o del loro instradamento agli utenti all'esterno dell'organizzazione. Questo comportamento non presenta eccezioni.

Categorizzazione Il classificatore esegue la risoluzione del destinatario, la risoluzione del routing e la conversione del contenuto per tutti i messaggi che passano attraverso la pipeline di trasporto di Exchange 2007.

Routing Il ruolo del server Trasporto Hub determina il percorso di routing per tutti i messaggi inviati e ricevuti nell'organizzazione.

Recapito I messaggi vengono recapitati alla cassetta postale di un destinatario dal driver di archivio. Il driver di archivio preleva i messaggi dalla Posta in uscita dei mittenti nell'organizzazione e li colloca nella coda di invio su un server Trasporto Hub.

Per risolvere il problema, installare il ruolo del server Trasporto Hub nei siti sui quali è installato un ruolo del server Cassette postali.

Per ulteriori informazioni

Per ulteriori informazioni sulla modalità di distribuzione del ruolo del server Trasporto Hub su un sito, vedere "Distribuzione dei ruoli server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=83282 nella documentazione del prodotto Exchange Server 2007.


I componenti di compatibilità IIS 6 non sono installati
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-08-13

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Nel tentativo di installare il ruolo server Accesso client, Cassette postali o gli Strumenti di amministrazione di Exchange 2007 nel computer di destinazione che esegue Windows Server 2008 è stato rilevato che i componenti per la compatibilità con la metabase di Internet Information Server (IIS) 6 e la console di gestione di IIS 6 non sono installati.

È necessario che nel computer Windows Server 2008 in cui si installa il ruolo del server Accesso client, Cassette postali o gli Strumenti di amministrazione di Exchange 2007 siano installati i componenti per la compatibilità con la metabase o la console di gestione IIS 6.

Per risolvere questo problema, installare il componente per la compatibilità della metabase di IIS 6 nel computer di destinazione, quindi eseguire nuovamente l'installazione di Microsoft Exchange.

Per installare i componenti di compatibilità di gestione di IIS 6.0 utilizzando Server Manager di Windows Server 2008.

  1. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Server Manager.

  2. Nel riquadro di spostamento sinistro, espandere Ruoli, fare clic con il pulsante destro del mouse su Web Server (IIS), quindi scegliere Aggiungi servizi ruolo.

  3. Nel riquadro Seleziona servizi ruolo, scorrere fino a Compatibilità gestione con IIS 6.

  4. Selezionare le caselle di controllo di Compatibilità metabase IIS 6 e Console di gestione IIS 6.

  5. Scegliere Avanti nel riquadro Seleziona ruoli servizio, quindi fare clic su Installa nel riquadro Conferma selezioni di installazione.

  6. Scegliere Chiudi per uscire dall'aggiunta guidata dei servizi del ruolo.


Componente di IIS 7 non installato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-08-09

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. L'installazione del ruolo del server Accesso client nel sistema basato su Microsoft Windows Server 2008 non è riuscita perché è stato rilevato che i componenti di Internet Information Server (IIS) 7 obbligatori non sono installati.

Per installare Exchange 2007, è necessario che nel computer basato su Windows Server 2008 in cui si installa il ruolo del server Accesso client siano installati i seguenti componenti di IIS 7 prima dell'installazione del ruolo del server Accesso client.

Componenti di IIS 7 obbligatori

Compressione dinamica dei contenuti

Compressione statica dei contenuti

Autenticazione di base

Autenticazione Windows

Per risolvere questo problema, installare i componenti di IIS 7 obbligatori nel computer di destinazione ed eseguire nuovamente l'installazione di Microsoft Exchange.

Per installare i componenti di IIS 7 utilizzando Server Manager di Windows Server 2008

  1. Fare clic su Start, scegliere Strumenti di amministrazione, quindi Server Manager.

  2. Nel riquadro di spostamento sinistro, espandere Ruoli, fare clic con il pulsante destro del mouse su Server Web (IIS), quindi scegliere Aggiungi servizi ruolo.

  3. Nel riquadro Seleziona servizi ruolo, scorrere fino a IIS.

  4. Selezionare le caselle di controllo in Protezione per Autenticazione di base e Autenticazione Windows.

  5. Selezionare le caselle di controllo in Prestazioni per Compressione statica e Compressione dinamica.

  6. Scegliere Avanti nel riquadro Seleziona servizi ruolo, quindi fare clic su Installa nel riquadro Conferma selezioni di installazione.

  7. Scegliere Chiudi per uscire dall'aggiunta guidata dei servizi del ruolo.


È necessario installare i file comuni IIS
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-14

Impossibile continuare l'installazione di Microsoft® Exchange Server 2007. I file comuni ISS (Microsoft Internet Information Services) non sono installati sul server.

Microsoft Exchange Management Shell potrebbe richiedere l'accesso remoto alla metabase IIS. La metabase è l'archivio della maggior parte dei valori di configurazione IIS. Per eseguire l'accesso remoto alla metabase è necessario installare le DLL COM+ appropriate sul computer locale.

Per risolvere il problema, installare i file comuni IIS sul server ed eseguire nuovamente l'installazione di Exchange 2007.

Per installare i file comuni IIS utilizzando il Pannello di controllo di Windows Server™ 2003

  1. Nel menu Start fare clic su Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Nell'elenco Componenti fare clic sulla casella di controllo Server applicazioni.

  5. Fare clic su Dettagli.

  6. Nell'elenco Sottocomponenti Server applicazioni fare clic sulla casella di controllo Internet Information Services (IIS).

  7. Fare clic su Dettagli.

  8. Fare clic sulla casella di controllo File comuni.

  9. Fare clic su OK fino a quando non viene visualizzato Aggiunta guidata componenti di Windows.

  10. Fare clic su Avanti e completare l'Aggiunta guidata componenti di Windows.
Per installare i file comuni IIS utilizzando il Pannello di controllo di Windows® XP

  1. Nel menu Start fare clic su Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Nell'elenco Componenti fare clic sulla casella di controllo Internet Information Services (IIS).

  5. Fare clic su Dettagli.

  6. Fare clic sulla casella di controllo File comuni.

  7. Fare clic su OK fino a quando non viene visualizzato Aggiunta guidata componenti di Windows.

  8. Fare clic su Avanti e completare l'Aggiunta guidata componenti di Windows.


IIS è in modalità di compatibilità a 32 bit
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-11

Impossibile continuare l'installazione di Microsoft® Exchange Server 2007. Microsoft Internet Information Service (IIS) è in esecuzione in modalità a 32 bit su un computer a 64 bit.

È necessario che IIS sia in modalità estesa a 64 bit quando è in esecuzione su un computer a 64 bit.

Per risolvere il problema, attivare la modalità a 64 bit per IIS ed eseguire nuovamente l'installazione di Microsoft Exchange.

Per passare alla modalità a 64 bit

  1. Aprire un prompt dei comandi.

  2. Digitare quanto segue:

    cscript c:\inetpub\adminscripts\adsutil.vbs SET /w3svc/AppPools/Enable32BitAppOnWin64 False

  3. Premere Invio


Autorizzazioni insufficienti per la preparazione di Active Directory
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-21

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Il tentativo di preparazione del dominio non è riuscito.

Per preparare i domini in Active directory, è innanzitutto necessario modificare il servizio directory di Active Directory.

L'account utilizzato per eseguire il comando setup /PrepareAD, benché sembri appartenere al gruppo Enterprise Admins, dispone di autorizzazioni insufficienti per l'esecuzione. È possibile che l'account sia scaduto.

Per risolvere il problema, verificare che l'account dell'utente che ha effettuato l'accesso sia valido e che appartenga al gruppo Enterprise Admins oppure effettuare l'accesso con un account che disponga delle autorizzazioni necessarie ed eseguire di nuovo il comando setup /PrepareAD.

Per ulteriori informazioni sull'esecuzione del processo PrepareAD, vedere "Come preparare Active Directory e domini" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78453.

Per ulteriori informazioni sulle autorizzazioni di Active Directory necessarie per Microsoft Exchange, vedere "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.


Autorizzazioni insufficienti per la rimozione di tutti i ruoli server
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare l'installazione di Microsoft Exchange Server 2007. Il tentativo di disinstallare tutti i ruoli server non è riuscito.

È necessario che l'utente connesso durante la disinstallazione di tutti i ruoli server sia membro dei gruppi Exchange Organization Administrators o del gruppo Enteprise Admins.

Per risolvere questo problema, concedere le autorizzazioni di Exchange Organization Administrator all'utente collegato, registrarle nel gruppo Enterprise Admins oppure effettuare l'accesso utilizzando un account che disponga delle autorizzazioni necessarie ed eseguire di nuovo l'installazione di Exchange 2007.

Per ulteriori informazioni sulle autorizzazioni di Active Directory necessarie per Microsoft Exchange, consultare "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.


Autorizzazioni insufficienti per l'esecuzione di /PrepareDomain
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di eseguire il processo /PrepareDomain non è riuscito. L'utente che ha effettuato l'accesso non dispone delle autorizzazioni necessarie per eseguire il processo /PrepareDomain.

L'installazione di Exchange 2007 richiede che l'utente connesso quando si esegue il processo /PrepareDomain sia un membro del gruppo Domain Admins relativo al dominio da preparare, e un membro del gruppo Exchange Organization Administrators o Enterprise Admins.

Per risolvere il problema, concedere all'utente che ha effettuato l'accesso le autorizzazioni del gruppo Domain Admins relativo al dominio in fase di preparazione e registrarlo nei gruppi Exchange Organization Administrators o Enterprise Admins, oppure effettuare l'accesso con un account che dispone di tali autorizzazioni ed eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sulle autorizzazioni di Active Directory necessarie per Microsoft Exchange, vedere "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.


Nome di dominio DNS (Domain Name System) non valido
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-04-13

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Il nome di dominio DNS (Domain Name System) impostato sul computer locale non è valido.

Per installare Exchange 2007, è necessario che il nome di dominio DNS contenga solo i caratteri 'A-Z', 'a-z','0-9', '.' e '-'.

Per risolvere questo problema, verificare che il nome del computer locale o il nome di dominio DNS non contengano caratteri non validi.

  • Se il nome del computer locale include caratteri non validi, reimpostare il nome di dominio DNS relativo al dominio sul computer locale utilizzando solo caratteri validi compresi nell'intervallo 'A-Z', 'a-z','0-9', '.' e '-', quindi riavviare il computer ed eseguire nuovamente l'installazione di Exchange 2007.

  • Se il nome di dominio DNS dell'organizzazione contiene caratteri non validi, provare a rinominare il dominio DNS oppure installare Exchange 2007 in una nuova struttura di dominio.

Attenzione
La modifica del nome di dominio DNS può influire notevolmente su tutta la rete. Prima di apportare qualsiasi modifica al nome di dominio DNS, rivolgersi all'amministratore di rete.
Per verificare il nome di dominio DNS del computer locale

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e scegliere Proprietà. Viene visualizzata la finestra di dialogo Proprietà del sistema.

  2. Selezionare la scheda Nome computer.

  3. Fare clic su Cambia. Viene visualizzata la finestra di dialogo Cambiamenti nome computer.

  4. Fare clic su Altro. Viene visualizzata la finestra di dialogo Suffisso DNS e nome NetBIOS del computer.

  5. Verificare che siano utilizzati solo i caratteri compresi nell'intervallo 'A-Z', 'a-z','0-9', '.' e '-'.

  6. Selezionare la casella di controllo Cambia suffisso DNS primario quando cambia l'appartenenza al dominio.

  7. Fare clic su OK per salvare le modifiche, quindi nuovamente su OK per uscire dalla finestra di dialogo Cambiamenti nome computer.

  8. Fare clic su OK per chiudere la finestra di dialogo Proprietà del sistema e riavviare il computer per rendere effettive le modifiche.

Per ulteriori informazioni sui nomi DNS, vedere l'articolo 909264 della Microsoft Knowledge Base "Convenzioni di denominazione in Active Directory per computer, domini, siti e UO" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=909264.


Percorso di installazione non valido
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare l'installazione di Microsoft Exchange Server 2007. Si è verificato un errore durante il tentativo di installare il ruolo del server Cassette postali o Cassette postali cluster in un'unità cluster condivisa.

È necessario installare i ruoli Exchange Server in un'unità che non sia una risorsa cluster condivisa.

Per risolvere questo problema, installare il ruolo del server Cassette postali o Cassette postali cluster in un percorso che non sia designato come unità cluster condivisa.

Per ulteriori informazioni sulle configurazioni cluster, vedere "Disponibilità elevata" nella documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?linkid=68190.


Formato del percorso di destinazione CMS non valido
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. Il tentativo di installare il ruolo del server cassette postali cluster non è riuscito.

Il parametro /CMSDataPath: <PercorsoDelDatabase> inviato presenta un formato UNC (Universal Naming Convention) non valido. Per l'installazione di Exchange è necessario che il parametro /CMSDataPath: <PercorsoDelDatabase> specificato utilizzati un'assegnazione di lettera di unità valida, ad esempio /CMSDataPath: s:\<PercorsoDelDatabase>, anziché il formato UNC.

Per risolvere questo problema, utilizzare un'assegnazione di lettera di unità valida per il parametro /CMSDataPath: <PercorsoDelDatabase> .

Per ulteriori informazioni sull'installazione del server Cassette postali in cluster, consultare "Installazione del ruolo del server Cassette postali sul nodo attivo" nella documentazione di Exchange Server 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86624.


La versione di MOUNTMGR.SYS installata non è compatibile con Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. La versione di Mountmgr.sys installata non è compatibile con Microsoft Exchange.

È necessario che nel nodo cluster sia installato l'aggiornamento al quale viene fatto riferimento all'articolo 898790 della Microsoft Knowledge Base.

La versione di Mountmgr.sys correntemente installata nel nodo cluster può causare errori dei punti di montaggio dei volumi. L'origine del problema è un errore nel driver Mountmgr.sys. Questo problema è intermittente e può verificarsi quando un volume viene installato su un punto di montaggio.

Per risolvere questo problema, installare l'aggiornamento al quale viene fatto riferimento nell'articolo 898790 della Microsoft Knowledge Base all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni su questo problema, vedere l'articolo 898790 della Microsoft Knowledge Base ""I punti di montaggio dei volumi sui dischi in un cluster di server potrebbero essere temporaneamente non disponibili, dopo l'installazione di Windows Server 2003 Service Pack 1" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=898790.


La versione di TCPIP.SYS installata non è compatibile con Exchange Server
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. La versione di Tcpip.sys installata non è compatibile con Microsoft Exchange.

È necessario che nel computer locale sia installato l'aggiornamento di cui viene fatto riferimento all'articolo 898060 della Microsoft Knowledge Base.

Su questo computer viene attualmente eseguito il driver Tcpip.sys di Windows Server™ 2003 Service Pack 1. Questo driver può provocare problemi di connettività in reti WAN.

Per risolvere questo problema, installare l'aggiornamento al quale viene fatto riferimento nell'articolo 898060 della Microsoft Knowledge Base da "Update for Windows Server x64 Edition (KB898060)" all'indirizzo http://go.microsoft.com/fwlink/?linkid=59272 (Informazioni in lingua inglese), quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni su tale avviso, seguire le indicazioni fornite nell'articolo 898060 della Microsoft Knowledge Base "L'installazione dell'aggiornamento della protezione MS05-019 o di Windows Server 2003 Service Pack 1 potrebbe causare l'interruzione della connettività di rete tra client e server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=898060.


Modello organizzazione di Exchange di grandi dimensioni rilevato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-10

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di gruppi di routing nell'organizzazione di Exchange Server. Exchange Server Analyzer esegue inoltre una query in Active Directory per determinare il numero di siti Active Directory con server di Exchange che eseguono Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003.

Exchange Server Analyzer classifica l'organizzazione di Exchange come organizzazione di grandi dimensioni se si verificano le condizioni seguenti:

  • Nell'organizzazione di Exchange sono presenti più di 5 gruppi di routing.

  • I server che eseguono Exchange 2000 o Exchange 2003 sono installati su più di 5 siti Active Directory.

Per eseguire la transizione di un'organizzazione di Exchange di grandi dimensioni a Exchange 2007

  1. Consultare la documentazione in linea del prodotto Microsoft Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69434 (informazioni in lingua inglese).

  2. Esaminare l'argomento "Planning for a Large Exchange Organization" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=70504 (informazioni in lingua inglese).


Il computer locale è un controller di dominio di un dominio figlio
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-12-29

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il computer locale è un controller di dominio di un dominio figlio.

Exchange 2007 non viene installato in un controller di dominio di un dominio figlio a meno che il controller di dominio non sia un server di catalogo globale.

Per risolvere questo problema, alzare il livello del controller di dominio a server di catalogo globale oppure installare Exchange 2007 in un non controller di dominio, un server membro nel dominio figlio, quindi rieseguire l'installazione di Microsoft Exchange.

Per risolvere questo problema rendendo il server di Exchange un server di catalogo globale

  1. Nel controller di dominio fare clic su Start, Programmi, Strumenti di amministrazione, Siti e servizi di Active Directory.

  2. Nella struttura della console fare doppio clic su Siti, fare doppio clic sul nome del sito, quindi su Server.

  3. Fare doppio clic sul controller di dominio di destinazione.

  4. Nel riquadro dei risultati fare clic con il pulsante destro del mouse su Impostazioni NTDS, quindi su Proprietà.

  5. Nella scheda Generale selezionare la casella di controllo Catalogo globale.

  6. Riavviare il controller di dominio.


Exchange Server è già in esecuzione sul computer locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-01-15

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Nel computer locale sono già installati componenti precedenti di Microsoft Exchange.

È necessario che nel computer locale non siano installati componenti di Microsoft Exchange esistenti.

Per risolvere questo problema, rimuovere i componenti di Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003, quindi rieseguire l'installazione di Microsoft Exchange.

Per rimuovere i componenti di Microsoft Exchange

  1. Fare clic su Start, Impostazioni, Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Nell'elenco Programmi attualmente installati fare clic su Microsoft Exchange, quindi su Cambia/Rimuovi.

  4. Nell'Installazione guidata di Microsoft Exchange scegliere Avanti.

  5. Nell'elenco Operazione della pagina Selezione componenti fare clic sulla freccia GIÙ accanto a ciascun componente installato, quindi fare clic su Rimuovi.

    Nota:
    I componenti installati hanno un segno di spunta nell'elenco Operazione. Facendo clic su Rimuovi, il segno di spunta viene sostituito dalla parola Rimuovi.

  6. Fare clic su Avanti due volte.

  7. Fare clic su Fine.


Il computer locale non esegue Windows Server 2003 Service Pack 1 o versioni successive
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il computer locale non esegue Windows Server™ 2003 Service Pack 1 (SP1) o versioni successive.

È necessario che il computer utilizzato per Microsoft Exchange esegua Windows Server 2003 SP1 o versioni successive.

Per risolvere questo problema:

  • Eseguire l'installazione di Exchange 2007 da un computer che esegue Windows Server 2003 SP1 o versioni successive.

  • Aggiornare il computer in cui si desidera installare Exchange 2007 a Windows Server 2003 SP1 o versioni successive.

Per ulteriori informazioni sull'aggiornamento a Windows Server 2003, vedere l'articolo 810613 della Microsoft Knowledge Base "Percorsi supportati per l'aggiornamento a Windows Server 2003 o Windows Small Business Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613.

Per ottenere il Service Pack più recente per Windows Server 2003, vedere "Windows Server TechCenter" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=45315.


Il computer locale è responsabile dell'espansione dell'appartenenza ai gruppi
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il tentativo di disinstallare il ruolo Hub Transport responsabile dell'espansione dell'appartenenza ai gruppi non è riuscito.

È necessario che l'espansione delle liste di distribuzione venga rimossa dal server testa di ponte corrente prima di poter disinstallare il ruolo Hub Transport.

L'espansione delle liste di distribuzione consente di identificare i singoli destinatari che appartengono alla lista di distribuzione da identificare oppure di identificare liste di distribuzione aggiuntive per l'espansione. Una lista di distribuzione espansa può restituire il percorso di qualsiasi notifica sullo stato del recapito (DSN, Delivery Status Notification). Le notifiche sullo stato del recapito informano l'amministratore di Microsoft Exchange o il mittente del messaggio di posta sullo stato di un messaggio di posta specifico. Inoltre, l'espansione delle liste di distribuzione consente di identificare se i messaggi fuori sede o le risposte generate automaticamente devono essere inviate al mittente del messaggio originale.

Per risolvere questo problema, spostare l'espansione dei gruppi di distribuzione su un altro server, quindi eseguire nuovamente l'installazione di Microsoft Exchange.

Per modificare il server di espansione per un gruppo di distribuzione o un gruppo di distribuzione dinamico

  1. Aprire Exchange Management Console.

  2. Nella struttura della console espandere Configurazione destinatario.

  3. Nella struttura della console fare clic su Gruppo di distribuzione.

  4. Creare un filtro per visualizzare tutti i gruppi di distribuzione e i gruppi di distribuzione dinamici che utilizzano il server testa di ponte corrente come server di espansione.

    1. Nel riquadro azioni fare clic su Crea filtro.

    2. Nell'elenco a discesa delle proprietà fare clic su Server di espansione.

    3. Nell'elenco a discesa dell'operatore fare clic su Uguale a.

    4. Nella casella del valore fare clic sul pulsante Sfoglia per selezionare il server testa di ponte che attualmente funge da server di espansione.
Nota:
Il passaggio seguente è facoltativo.
  1. Fare clic su Aggiungi espressione per specificare criteri del filtro aggiuntivi. Verranno visualizzati solo i messaggi che soddisfano tutti i criteri del filtro.

  2. Fare clic su Applica filtro. Verranno visualizzati i risultati che soddisfano i criteri del filtro.

  1. Nel riquadro dei risultati fare clic sul gruppo di distribuzione di cui modificare il server di espansione, quindi fare clic su Proprietà nel riquadro azioni.

  2. In Proprietà fare clic sulla scheda Avanzate.

  3. Nell'elenco a discesa del server di espansione selezionare un server specifico dall'elenco oppure Qualunque server nell'organizzazione.

  4. Ripetere i passaggi da 5 a 7 per tutti i gruppi di distribuzione o gruppi di distribuzione dinamici che utilizzano il server testa di ponte come server di espansione.


Il computer locale è responsabile della generazione della rubrica fuori rete
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il tentativo di disinstallare un ruolo Mailbox responsabile della generazione della rubrica fuori rete non è riuscito.

È necessario che la generazione della rubrica fuori rete venga rimossa dal server Mailbox corrente prima di disinstallare il ruolo Mailbox, a meno che il ruolo non sia l'ultimo nell'organizzazione di Exchange.

Per risolvere questo problema, spostare la generazione della rubrica fuori rete su un altro server, quindi eseguire nuovamente l'installazione di Microsoft Exchange.

Per spostare la generazione della rubrica fuori rete usando il Gestore di sistema di Exchange

  1. Aprire il Gestore di sistema di Exchange.

  2. Nella sezione Destinatari fare clic su Elenchi di indirizzi non in linea.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse su Elenco di indirizzi non in linea predefinito e fare clic su Proprietà.

    Nota:
    Seguire la stessa procedura per ogni altro elenco di indirizzi non in linea che provoca questo errore.

  4. Nella sezione Server elenco indirizzi non in linea della scheda Generale fare clic su Sfoglia, quindi selezionare il server Exchange da utilizzare.
Per spostare la generazione della rubrica fuori rete usando Exchange Management Console

  1. Aprire Exchange Management Console.

  2. Espandere Microsoft Exchange e Configurazione organizzazione, quindi selezionare Mailbox.

  3. Nel riquadro dei risultati fare clic sulla scheda Rubrica fuori rete.

  4. Nella scheda Rubrica fuori rete selezionare la rubrica fuori rete da spostare. Nel riquadro azioni fare clic su Sposta.

  5. Quando viene visualizzata la procedura guidata per spostare la rubrica fuori rete, per selezionare il nuovo server che ospiterà la generazione della rubrica fuori rete usare il pulsante Sfoglia quindi fare clic su Sposta.

  6. Per chiudere la procedura guidata, fare clic su Fine.
Per usare Exchange Management Shell per spostare la generazione della rubrica fuori rete

  • Eseguire il seguente comando:

    Copia codice
    Move-OfflineAddressBook -Identity <OfflineAddressBookIdParameter> -Server <ServerIdParameter> [-DomainController <String>]


Il computer locale esegue il ruolo Edge Transport
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Durante il tentativo di installazione di un ruolo Exchange 2007 è stato rilevato che il ruolo Gateway Server è già installato nel server.

Non è possibile installare altri ruoli server in un server in cui è installato il ruolo Microsoft Exchange Gateway Server.

Il ruolo Microsoft Exchange Gateway Server viene distribuito nella rete perimetrale dell'organizzazione, gestisce il flusso di posta connesso a Internet e fornisce la crittografia e decrittografia dei messaggi inviati tra organizzazioni attendibili di Microsoft Exchange, oltre a fornire protezione contro la posta indesiderata.

Per risolvere questo problema, installare gli altri ruoli Microsoft Exchange 2007 in un computer in cui non è installato il ruolo Gateway Server.


Il computer locale esegue Windows Server 2003 Web Edition
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il computer locale esegue Microsoft Windows Server ™ 2003 Web Edition.

È necessario installare Microsoft Exchange in un computer che esegue un sistema operativo supportato.

Per risolvere questo problema, installare Microsoft Exchange in Windows Server 2003 Service Pack 1 (SP1) o versione successiva non Web Edition.


Aggiornamento del dominio locale necessario
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. L'utente che ha effettuato l'accesso non dispone delle autorizzazioni di account necessarie per la preparazione del dominio.

È necessario che l'utente che effettua l'accesso quando è in esecuzione setup/PrepareDomain sia membro dei gruppi Domain Admins ed Exchange Organization Administrators o del gruppo Enterprise Admins.

Per risolvere il problema, concedere all'utente che ha effettuato l'accesso le autorizzazioni di Domain Admins ed Exchange Organization Administrator oppure registrarlo nel gruppo Enterprise Admins; in alternativa, è possibile effettuare l'accesso utilizzando un account che disponga delle suddette autorizzazioni, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sulle autorizzazioni di Active Directory necessarie per Microsoft Exchange, vedere "Utilizzo delle autorizzazioni di Active Directory in Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=47592.


Impossibile accedere alla metabase locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Non è possibile leggere i dati dalla metabase locale.

È necessario che l'installazione dei ruoli Mailbox Server o Client Access sia in grado di leggere i dati dalla metabase IIS.

La metabase IIS include informazioni che incidono su Microsoft Exchange, quali le impostazioni di protocollo per HTTP, le directory virtuali per l'accesso alle cassette postali e ai dispositivi portatili e le impostazioni di protezione HTTP.

Per risolvere questo problema, verificare che IIS sia correttamente installato, quindi rieseguire l'installazione di Microsoft Exchange.

Per verificare che IIS è correttamente installato, vedere le seguenti risorse:

  • Articolo 843093 della Microsoft Knowledge Base "Risoluzione dei problemi di danneggiamento della metabase IIS in un computer basato su Windows 2000 Server che esegue Exchange 2000 Server o Exchange Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=843093.

  • Articolo 240225 della Microsoft Knowledge Base "Descrizione delle utilità Adsutil e MetaEdit utilizzate per modificare la metabase" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=240225.

  • Articolo 317678 della Microsoft Knowledge Base "HOW TO: Riavvio di IIS in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=317678.

Se le indicazioni presenti in queste risorse non risolvono il problema, disinstallare e reinstallare IIS.

Per disinstallare IIS utilizzando Installazione componenti di Windows nel Pannello di controllo

  1. Nel menu Start scegliere Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Dall'elenco Componenti selezionare la casella di controllo Server applicazioni.

  5. Fare clic su Dettagli.

  6. Fare clic su Gestione Internet Information Services.

  7. Fare clic su Avanti.

  8. Una volta disinstallato IIS, fare clic su Fine.
Per installare IIS tramite il Pannello di controllo

  1. Nel menu Start scegliere Pannello di controllo.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Dall'elenco Componenti selezionare la casella di controllo Server applicazioni.

  5. Fare clic su Dettagli.

  6. Fare clic sulla casella di controllo Gestione Internet Information Services.

  7. Fare clic su OK fino a quando non viene visualizzato Aggiunta guidata componenti di Windows.

  8. Fare clic su Avanti e completare l'Aggiunta guidata componenti di Windows.


L'utente connesso non è un membro del gruppo Administrators locale
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. L'utente connesso non è un membro del gruppo di amministratori del computer locale.

È necessario che l'utente connesso che esegue l'installazione di Microsoft Exchange disponga dell'accesso completo al computer locale.

Per risolvere questo problema, accedere al computer utilizzando un account che dispone dell'accesso da amministratore locale, quindi eseguire nuovamente l'installazione di Microsoft Exchange.


L'utente connesso non è un membro del gruppo Schema Admins
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-09-06

È impossibile continuare l'installazione di Microsoft® Exchange Server 2007 poiché il processo di aggiornamento dello schema non dispone delle credenziali amministrative Schema ed Enterprise del servizio directory di Active Directory®.

L'installazione di Exchange 2007 richiede che l'utente connesso che installa Microsoft Exchange disponga delle credenziali amministrative Schema ed Enterprise per la foresta di Active Directory.

Come parte del processo di installazione, viene esteso lo schema di Active Directory per aggiungere classi e attributi specifici di Exchange 2007.

Se l'utente connesso non dispone delle autorizzazioni di amministrazione Schema Administrator ed Enterprise, il processo di aggiornamento dello schema non avrà esito positivo.

Per risolvere il problema, aggiungere l'utente connesso ai gruppi Schema Admins ed Enterprise Admins, quindi disconnettere e connettere di nuovo oppure disconnettere e riconnettere utilizzando un account che disponga già delle credenziali amministrative Schema ed Enterprise per la foresta di Active Directory.


Troppi nodi attivi
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-23

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Si è verificato un errore durante il tentativo di creare un nuovo ruolo del server Cassette postali Active Cluster.

Per supportare il recupero in caso di errore, è necessario che almeno un nodo del cluster sia passivo.

Per risolvere questo problema, installare innanzitutto un altro ruolo del server Cassette postali in cluster passivo nell'ambiente ed eseguire nuovamente l'installazione.

Per ulteriori informazioni sull'installazione di nodi attivi e passivi, vedere "Disponibilità elevata" nella documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?linkid=68190.


Specifica dell'unità del database delle cassette postali mancante
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-05-15

L'installazione di Microsoft® Exchange Server 2007 Disaster Recovery non può continuare. Non è possibile accedere alla specifica dell'unità del database delle cassette postali utilizzata nell'installazione precedente di questo server.

Sono necessarie le stesse specifiche dell'unità del database delle cassette postali utilizzate in precedenza affinché il server sia disponibile durante il ripristino.

Per risolvere questa situazione, configurare le unità affinché corrispondano alla configurazione originale dell'unità logica, quindi eseguire nuovamente l'installazione di Microsoft Exchange Disaster Recovery.

Assegnare o modificare una lettera di unità

  1. Aprire Gestione computer (locale).

  2. Nella struttura della console fare clic su Gestione computer (locale), Archiviazione, quindi Gestione disco.

  3. Fare clic con il pulsante destro del mouse su una partizione, unità logica o volume, quindi fare clic su Cambia lettera e percorso di unità.

  4. Utilizzare una delle seguenti procedure:

    • Per assegnare una lettera di unità fare clic su Aggiungi, fare clic sulla lettera di unità da utilizzare, quindi su OK.

    • Per modificare una lettera di unità, fare clic su di essa, Modifica, fare clic sulla lettera di unità da utilizzare, quindi su OK.

Per ulteriori informazioni sull'assegnazione delle lettere di unità, vedere "Assegnare, cambiare o rimuovere una lettera di unità" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66764.


Sono attualmente presenti messaggi in una o più code
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

Durante l'installazione di Microsoft® Exchange Server 2007 viene visualizzato questo avviso. Il tentativo di disinstallare il ruolo di trasporto potrebbe comportare la perdita di dati da una coda di trasporto.

L'installazione di Exchange 2007 verifica che le code di trasporto siano vuote prima di rimuovere i ruoli associati alla gestione di queste code.

Se si rimuovono i ruoli di trasporto prima che vengano recapitati i messaggi ancora nelle code di trasporto, tali messaggi possono essere trattenuti per un periodo di tempo indeterminato.

Per risolvere questo problema, verificare le code in questione per assicurarsi che non contengano messaggi prima di continuare con l'installazione.

Per visualizzare il contenuto di una coda

  1. Aprire Exchange Management Console.

  2. Nella struttura della console fare clic su Casella degli strumenti.

  3. Nel riquadro dei risultati fare clic su Visualizzatore code di Exchange.

  4. Nel riquadro azioni fare clic su Apri strumento.

  5. Nel Visualizzatore code fare clic sulla scheda Code. Viene visualizzato l'elenco delle code sul server al quale si è connessi.

  6. Fare clic con il pulsante destro del mouse sulla coda desiderata e scegliere Proprietà per visualizzare le proprietà della coda.
Per visualizzare i messaggi in una coda

  1. Seguire i passaggi da 1 a 4.

  2. Nel Visualizzatore code fare clic sulla scheda Messaggi. Viene visualizzato l'elenco dei messaggi sul server al quale si è connessi. Per impostare la visualizzazione di una singola coda, fare clic sulla scheda Code, fare doppio clic sul nome della coda, quindi fare clic sulla scheda Server\Coda visualizzata.

  3. Per visualizzare informazioni dettagliate su un messaggio, selezionare tale messaggio e fare clic su Proprietà nel riquadro azioni.


Aggiornamento di Microsoft .NET Framework richiesto
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-02-26

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. È necessario un aggiornamento del software nel computer locale.

Per l'installazione di Microsoft Exchange Server 2007 è necessario installare nel computer locale l'aggiornamento appropriato di Microsoft .NET Framework cui si fa riferimento in questo argomento.

Per risolvere il problema, uscire dall'installazione di Exchange 2007, scaricare e installare l'aggiornamento appropriato (a 32 bit o a 64 bit) tramite i collegamenti riportati di seguito, quindi eseguire nuovamente l'installazione di Exchange 2007.

Nota:
Se si fa clic sui collegamenti seguenti, verrà chiesto di scaricare i file direttamente.
  • Download a 64 bit, http://go.microsoft.com/fwlink/?linkid=74465

  • Download a 32 bit, http://go.microsoft.com/fwlink/?linkid=74469


È necessario installare Microsoft Core XML Services (MSXML) 6.0
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-21

Impossibile continuare l'installazione di Microsoft® Exchange Server 2007. Microsoft Core XML Services (MSXML) 6.0 non è installato sul server.

Per tutte le installazioni del ruolo del server di messaggistica unificata, l'installazione di Exchange 2007 richiede l'installazione di MSXML 6.0 per il supporto dei servizi di sintesi vocale Microsoft.

Per risolvere il problema, installare il software MSXML 6.0 dall'indirizzo http://go.microsoft.com/fwlink/?LinkId=70796 e rieseguire l'installazione di Microsoft Exchange Server 2007.


Percorso MNSFileShare non valido
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Il percorso MNSFileShare non è valido.

Il valore MNSFileShare deve essere impostato su un valore stringa contenente il percorso UNC (Universal Naming Convention) di una condivisione file esterna al cluster come, ad esempio, \\server\sharename.

Per risolvere il problema, specificare per la proprietà MNSFileShare un valore che corrisponda a un percorso UNC valido.

Per ulteriori informazioni sulla configurazione della proprietà MSNFileShare, vedere "Come configurare il witness di condivisione file" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=78278.


Aggiornamento di MSDAPS.DLL richiesto
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-12-05

L'installazione di Microsoft® Exchange Server 2007 non può continuare. È necessario un aggiornamento del software nel computer locale.

Per l'installazione di Microsoft® Exchange Server 2007 è necessario installare nel computer locale l'aggiornamento MSDAPS.DLL riportato di seguito.

Per risolvere il problema, scaricare e installare l'aggiornamento tramite il collegamento riportato di seguito ed eseguire nuovamente l'installazione di Exchange 2007.

  • http://go.microsoft.com/fwlink/?linkid=74467


Il servizio NNTP è attualmente installato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-01-22

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il servizio NNTP (Network News Transport Protocol) di Microsoft Windows® Server™ 2003 è installato in questo computer.

È necessario che il servizio NNTP non sia installato in server utilizzati per Exchange 2007.

Per risolvere questo problema, disinstallare il servizio NNTP ed eseguire nuovamente l'installazione di Microsoft Exchange.

Per disinstallare il servizio NNTP utilizzando Installazione componenti di Windows nel Pannello di controllo

  1. Scegliere Pannello di controllo dal menu Start.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Dall'elenco Componenti selezionare la casella di controllo Server applicazioni, quindi fare clic su Dettagli.

  5. Selezionare Gestione Internet Information Services, quindi fare clic su Dettagli.

  6. Scegliere Servizio NNTP, quindi fare clic per deselezionare la casella di controllo.

  7. Fare clic su OK due volte per tornare all'elenco Componenti, quindi fare clic su Avanti.

  8. Una volta disinstallato il servizio NMTP, fare clic su Fine.


Non è stato trovato alcun ruolo del server Accesso client
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-02-16

Microsoft Exchange Analyzer Tool interroga servizio directory di Active Directory per determinare il valore di qualsiasi oggetto della classe msExchAdminGroupContainer nell'organizzazione di Exchange che contenga lo specifico identificatore del gruppo amministrativo di Exchange Server 2007, ovvero FYDIBOHF23SPDLT.

Se Exchange Analyzer determina che esiste un gruppo amministrativo di Exchange Server 2007 nell'organizzazione di Exchange, interrogherà tutti i siti Active Directory nell'organizzazione per determinare il valore dell'attributo msExchCurrentServerRoles per ciascun oggetto msExchExchangeServer, allo scopo di verificare se è stato installato un ruolo del server Cassette postali su uno qualsiasi dei siti rilevati.

Infine, se Exchange Analyzer determina che è stato installato un ruolo del server Cassette postali su uno dei siti, eseguirà la query dell'attributo msExchCurrentServerRoles di ciascun oggetto msExchExchangeServer in tale sito, al fine di determinare se è stato installato anche un ruolo del server Accesso client sullo stesso sito.

Se Exchange Analyzer determina che è stato installato un ruolo del server Cassette postali su un sito Active Directory su cui non è stato installato alcun ruolo del server Accesso client, verrà visualizzato un avviso.

L'avviso indica che, sebbene sia stato installato un ruolo del server Cassette postali sul sito Active Directory, i client di accesso ai dispositivi portatili Microsoft Office Outlook Web Access ed Exchange ActiveSync non saranno in grado di accedere alla posta elettronica su tale server di cassette postali finché non verrà installato almeno un ruolo del server Accesso client sul sito.

Il ruolo del server Accesso client accetta connessioni al server Exchange 2007 da una serie di client differenti. I client software come Microsoft Outlook Express ed Eudora utilizzano connessioni POP3 o IMAP4 per comunicare con il server Exchange. I client hardware, come i dispositivi portatili, utilizzano ActiveSync, POP3 o IMAP4 per comunicare con il server Exchange.

Se gli utenti accedono alle cartelle di posta in arrivo utilizzando un client diverso da Microsoft Outlook, è necessario installare il ruolo del server Accesso client nell'organizzazione di Exchange.

Per risolvere questo problema, nel caso di client che hanno accesso a cassette postali diversi da quelli che utilizzano Microsoft Outlook, installare il ruolo del server Accesso client nei siti su cui è stato installato il ruolo del server Cassette postali.

Per ulteriori informazioni

Per ulteriori informazioni sulle modalità di installazione del ruolo del server Accesso client su un sito, vedere "Distribuzione dei ruoli server" all'indirizzo http://technet.microsoft.com/it-it/library/aa997610.aspx nella documentazione del prodotto Exchange Server 2007.


Spazio indirizzo non standard trovato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-21

Microsoft® Exchange Server Analyzer Tool visualizza questo avviso se determina la presenza di uno spazio indirizzo non standard in uno o più criteri destinatari.

Uno spazio indirizzo non standard o proxy è l'indirizzo tramite il quale un oggetto destinatario di Exchange Server viene riconosciuto in un sistema di messaggistica esterno.

In versioni precedenti di Exchange Server, il supporto di spazi indirizzo non standard era esclusivamente a carico del Servizio aggiornamento destinatari.

In Microsoft Exchange Server 2007, il Servizio aggiornamento destinatari non è implementato. La generazione di indirizzi proxy è esclusivamente a carico della console di amministrazione di Exchange 2007.

È necessario che nelle console di amministrazione sia caricata una DLL di generazione proxy per ogni spazio indirizzo non standard rilevato.

Importante:
Se la console di amministrazione viene eseguita in un computer a 64 bit, sarà necessario caricare una versione a 64 bit della DLL di generazione proxy.

Per risolvere il problema, contattare il fornitore che supporta lo spazio indirizzo esterno per ottenere la DDL di generazione proxy compatibile con Exchange 2007.


Sito/dominio non presente nel master schema
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-10

Impossibile continuare l'installazione di Microsoft® Exchange Server 2007. Il computer che la esegue non si trova nello stesso sito o dominio del servizio di directory di Active Directory® del server cui viene assegnato il ruolo di master schema del dominio, noto anche come ruolo FSMO (Flexible Single Master Operations).

È necessario che il controller di dominio utilizzato come master schema del dominio si trovi nello stesso sito e dominio del computer locale che esegue l'installazione di Exchange.

Il master schema del dominio controlla tutti gli aggiornamenti e le modifiche apportate allo schema di Active Directory.

Per risolvere il problema eseguire l'installazione di Exchange Server 2007 dallo stesso sito o dominio del master schema del dominio.

È possibile utilizzare lo strumento Schema Master per identificare il ruolo. È tuttavia necessario registrare Schmmgmt.dll DLL per rendere lo strumento Schema disponibile come snap-in MMC.

Per visualizzare il master schema corrente

  1. Al prompt dei comandi digitare regsvr32 schmmgmt.dll

    Nota:
    la registrazione di RegSvr32 è riuscita se viene visualizzata la seguente finestra di dialogo:

    DllRegisterServer in schmmgmt.dll eseguita.

  2. Per aprire una nuova console di gestione fare clic su Start, scegliere Esegui e quindi digitare mmc.

  3. Scegliere Aggiungi/Rimuovi snap-in dal menu Console.

  4. Fare clic su Aggiungi per aprire la finestra di dialogo Aggiungi snap-in autonomo.

  5. Selezionare Schema di Active Directory e quindi fare clic su Aggiungi.

  6. "Schema di Active Directory" viene visualizzato in Aggiungi/Rimuovi snap-in. Fare clic su Chiudi e quindi su OK per ritornare alla console.

  7. Selezionare Schema di Active Directory in modo che le sezioni Classi e Attributi vengano visualizzate sul lato destro.

  8. Fare clic con il pulsante destro del mouse su Schema di Active Directory e quindi fare clic su Master operazioni.

  9. Viene visualizzato il master schema corrente


Nessun controller di dominio di Windows Server 2003 SP1 nel dominio
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il processo setup /PrepareLegacyExchangePermissions non ha trovato un controller di dominio che esegue Microsoft Windows Server 2003 Service Pack 1 (SP1) o versione successiva nel dominio in fase di preparazione.

In ciascun dominio in cui verrà eseguito setup /PrepareLegacyExchangePermissions, il programma di installazione deve contattare un controller di dominio di Windows Server 2003 SP1. Setup /PrepareLegacyExchangePermissions non verrà completato se non viene rilevato almeno un controller di dominio di Windows Server 2003 SP1.

L'esecuzione del comando setup /PrepareLegacyExchangePermissions consente al Servizio aggiornamento destinatari legacy di funzionare correttamente. Prima di importare il nuovo schema di Exchange 2007, Exchange 2007 deve concedere nuove autorizzazioni in ciascun dominio in cui è stato eseguito Exchange Server 2003 o Exchange 2000 Server DomainPrep. L'esecuzione del comando setup /PrepareLegacyExchangePermissions consente di concedere tali autorizzazioni.

Per risolvere il problema, aggiornare almeno un controller di dominio in ciascun dominio in cui si eseguirà setup /PrepareLegacyExchangePermissions a Windows Server 2003 SP1 o versione successiva, quindi eseguire nuovamente l'installazione.

Per ulteriori informazioni su come preparare le autorizzazioni legacy di Exchange, vedere "Preparazione delle autorizzazioni legacy di Exchange" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=80699 nella documentazione del prodotto di Exchange Server 2007.


Il server della Rubrica fuori rete è stato eliminato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-21

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di installare il ruolo del server Accesso client non è riuscito. Il server di cassette postali di Exchange designato per ospitare la Rubrica fuori rete è stato eliminato.

L'installazione di Exchange 2007 richiede che esista un server di cassette postali di Exchange valido che ospiti la generazione della Rubrica fuori rete affinché l'installazione del ruolo del server Accesso client possa continuare.

Per risolvere il problema, designare un server di cassette postali di Exchange valido come host di generazione della Rubrica fuori rete, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per informazioni su come designare un server Exchange in modo da essere l'host per la generazione della Rubrica fuori rete, vedere "Come creare una Rubrica fuori rete" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86314 nella documentazione del prodotto di Exchange 2007.


Rilevati file di database precedenti
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Sono stati rilevati file di database di Microsoft Exchange esistenti nel percorso di installazione di destinazione.

È necessario che nel percorso di installazione di destinazione non siano presenti file di database di Microsoft Exchange.

Per risolvere questo problema, rimuovere i file esistenti dai percorsi di installazione di destinazione, quindi eseguire nuovamente l'installazione.

Per eliminare i file di database di Exchange Server esistenti dal percorso di installazione di destinazione

  1. In Risorse del computer o Esplora risorse individuare il percorso di installazione di destinazione.

    Nota:
    Per impostazione predefinita, i file di database si trovano in:

    <systemDrive>:\Programmi\Microsoft\Exchange Server\Mailbox\First Storage Group.

  2. Fare clic con il pulsante destro del mouse sui file da rimuovere, quindi selezionare Elimina.

  3. Nella finestra di dialogo Conferma eliminazione file fare clic su Sì.

  4. Ripetere i passaggi 2 e 3 per tutti i file presenti nei percorsi di installazione di destinazione.


Rilevata versione precedente di ADAM
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

Questo avviso viene visualizzato perché durante il tentativo di installazione del ruolo Gateway Server è stata rilevata una versione precedente di ADAM (Active Directory® Application Mode) nel server corrente.

ADAM è un servizio directory LDAP (Lightweight Directory Access Protocol) designato specificamente per l'utilizzo con applicazioni abilitate alle directory. ADAM consente di memorizzare e replicare solo le informazioni specifiche relative all'applicazione, non richiede la distribuzione in un controller di dominio e non dipende dal servizio Active Directory. ADAM non fornisce l'autenticazione o l'autorizzazione del sistema operativo della rete.

In Exchange 2007 il server gateway utilizza ADAM per memorizzare le informazioni sulla configurazione. Se ADAM viene sincronizzato con Active Directory, può essere utilizzato per eseguire ricerche sul destinatario per la protezione del messaggio.

L'installazione di ADAM verrà automaticamente aggiornata alla versione SP1 (Service Pack 1).

Non è necessario eseguire alcuna azione, a meno che non si desideri evitare l'aggiornamento di ADAM. In tal caso, non installare il ruolo Gateway Server nel computer locale.


Trovati uno o più server Active Directory Connector
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Sono stati trovati uno o più ADC (Active Directory Connector) nell'ambiente Microsoft Exchange corrente.

ADC consente di replicare oggetti da Exchange Server versione 5.5 al servizio directory Active Directory® in un ambiente Microsoft Exchange a modalità mista. ADC non è supportato da Exchange 2007.

L'installazione di Exchange 2007 richiede la rimozione di tutti i componenti di ADC.

Per risolvere questo problema, rimuovere tutti i componenti di ADC, quindi rieseguire l'installazione di Exchange 2007.

Per rimuovere i componenti di ADC

  1. Per disabilitare il servizio ADC sul server che esegue il servizio ADC, fare clic con il pulsante destro del mouse su Risorse del computer sul desktop e scegliere Gestisci.

  2. Espandere il nodo Servizi e applicazioni, quindi fare clic sul nodo Servizi.

  3. Nel riquadro destro fare clic con il pulsante destro del mouse su Microsoft Active Directory Connector e scegliere Proprietà.

  4. Modificare l'opzione Tipo di avvio in Disattivato. Al successivo riavvio del computer, il servizio ADC non verrà eseguito.

  5. Fare clic su Applica, quindi su OK.

  6. Per disinstallare il sevizio ADC, utilizzare l'Installazione guidata di Active Directory nel CD di Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003. Aprire la cartella \ADC\I386 e fare doppio clic sul programma Setup.exe. Seguire le istruzioni visualizzate per rimuovere tutti i componenti del servizio ADC.

    Importante:
    È necessario completare i passaggi e rimuovere tutti i componenti ADC per risolvere questo problema. Non è sufficiente disabilitare il servizio ADC.

Per ulteriori informazioni su ADC, vedere i seguenti articoli della Microsoft Knowledge Base:

  • 325300, "Support WebCast: Introduzione ad Active Directory Connector" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325300.

  • 325221, "Support WebCast: Microsoft Advanced Active Directory Connector" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325221.

  • 312632 "Installazione e configurazione di Active Directory Connector in Exchange 2000 Server" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=312632.


È consentito un unico server CCR
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. Il tentativo di creare un nuovo server cassette postali cluster non è riuscito.

Exchange Server 2007 richiede che nel cluster CCR (Cluster Continuos Replication) sia presente un unico server cassette postali cluster CCR. Nel cluster CCR è già presente un server cassette postali cluster.

Per risolvere il problema, non cercare di installare sul cluster un ulteriore server cassette postali cluster CCR.

Per ulteriori informazioni sull'installazione del server cassette postali cluster in un ambiente CCR, vedere "Installazione del ruolo server Mailbox sul nodo attivo" nella documentazione del prodotto Exchange Server 2007, all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86624.


In un server cluster è possibile installare solo il ruolo Mailbox
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-07

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il tentativo di installare un ruolo diverso dal ruolo server Mailbox nel server cluster non è riuscito.

Microsoft Exchange non supporta ruoli di Exchange 2007 diversi dal ruolo server Mailbox in server nei quali è installato il servizio cluster.

Per risolvere questo problema, vedere "High Availability for Exchange 2007" in "Exchange Server 2007 Operations Guide" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=68190 (informazioni in lingua inglese).


L'organizzazione è in modalità mista
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-05-15

L'installazione di Microsoft® Exchange Server 2007 non può continuare. L'organizzazione di Microsoft Exchange esistente non è in modalità nativa.

È necessario che l'organizzazione di Exchange esistente sia in modalità nativa.

Per risolvere questo problema, procedere come descritto di seguito dopo l'aggiornamento della versione 5.5 di Exchange Server o prima che l'ultimo server Exchange 5.5 non disponga più dell'autorizzazione. Quindi rieseguire l'installazione di Exchange 2007.

Nota:
Una volta eseguito il passaggio alla modalità nativa non è possibile tornare alla modalità mista.
Per passare alla modalità nativa

  1. Avviare Gestore di sistema di Exchange: Fare clic su Start, scegliere Tutti i programmi, quindi Microsoft Exchange e Gestore di sistema.

  2. Nella struttura della console fare clic con il pulsante destro del mouse sull'organizzazione che si desidera impostare sulla modalità nativa, quindi fare clic su Proprietà.

  3. In <Nome organizzazione> Proprietà, in Cambio modalità operativa, fare clic su Cambia modalità.

  4. Nella finestra di dialogo di avviso fare clic su Sì per passare definitivamente alla modalità nativa. Fare clic su Applica per accettare la nuova modalità di Exchange.

Per un utilizzo ottimale della modalità nativa di Exchange, è necessario riavviare il servizio Archivio informazioni di Microsoft Exchange su tutti i server Exchange all'interno dell'organizzazione. Non è necessario riavviare contemporaneamente tutti i servizi Archivio informazioni di Microsoft Exchange. Tuttavia, per usufruire di tutte le funzionalità della modalità nativa di Exchange, occorre riavviare il servizio su ogni server. Riavviare il servizio sui server dopo che il passaggio alla modalità nativa è stato replicato al controller di dominio di Microsoft Windows®.

Per riavviare il servizio Archivio informazioni di Microsoft Exchange

  1. Fare clic su Start, Esegui, digitare services.msc, quindi fare clic su OK.

  2. Nel riquadro Servizi (locale) individuare il servizio Archivio informazioni di Microsoft Exchange.

  3. Fare clic con il pulsante destro del mouse sul servizio, quindi scegliere Riavvia.

Per ulteriori informazioni sulla conversione dalla modalità mista a quella nativa, vedere l'articolo 32779 della Microsoft Knowledge Base "Conversione dalla modalità mista a quella nativa in Exchange" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=327779.


Impossibile contattare il server DNS primario
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Impossibile stabilire una comunicazione con il server DNS primario.

È necessario che il computer locale comunichi con il database DNS autorevole per il dominio.

Microsoft Exchange dipende dal DNS per la risoluzione dell'indirizzo IP del server di destinazione interno o esterno.

Si può verificare un errore nella comunicazione con il server DNS primario per i seguenti motivi:

  • La configurazione TCP/IP locale non fa riferimento al server DNS corretto.

  • Il server DNS è inattivo o irraggiungibile a causa di un errore nella rete o per altri motivi.

Per risolvere questo problema:

  • Verificare che la configurazione TCP/IP locale faccia riferimento al server DNS corretto.

Per verificare la configurazione TCP/IP locale

  1. Rivedere la configurazione TCP/IP locale:

    Per ulteriori informazioni, vedere "Configurare TCP/IP per l'utilizzo del servizio DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=68094.
  • Verificare che il server DNS sia in esecuzione e possa essere contattato.

Per verificare che il server DNS è in esecuzione e può essere contattato

  1. Verificare che il server DNS sia in esecuzione eseguendo uno o più dei seguenti controlli:

    • Controllare lo stato del server DNS utilizzando il programma di amministrazione DNS nel server DNS.

    • Riavviare il server DNS.

      Per ulteriori informazioni, vedere "Avvio, arresto, sospensione o riavvio di un server DNS" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=62999.

    • Verificare la capacità di risposta del server DNS utilizzando il comando nslookup.

      Per ulteriori informazioni, vedere le istruzioni in "Verificare la capacità di risposta del server DNS tramite il comando nslookup" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=63000.


Specifica dell'unità del database delle cartelle pubbliche mancante
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-05-15

L'installazione di Microsoft® Exchange Server 2007 Disaster Recovery non può continuare. Non è possibile accedere alla specifica dell'unità del database delle cassette postali utilizzata nell'installazione precedente di questo server.

Sono necessarie le stesse specifiche dell'unità del database delle cassette postali utilizzate in precedenza affinché il server sia disponibile durante il ripristino.

Per risolvere questa situazione, configurare le unità affinché corrispondano alla configurazione originale dell'unità logica, quindi eseguire nuovamente l'installazione di Microsoft Exchange Disaster Recovery.

Assegnare o modificare una lettera di unità

  1. Aprire Gestione computer (locale).

  2. Nella struttura della console fare clic su Gestione computer (locale), Archiviazione, quindi Gestione disco.

  3. Fare clic con il pulsante destro del mouse su una partizione, unità logica o volume, quindi fare clic su Cambia lettera e percorso di unità.

  4. Utilizzare una delle seguenti procedure:

    • Per assegnare una lettera di unità fare clic su Aggiungi, fare clic sulla lettera di unità da utilizzare, quindi su OK.

    • Per modificare una lettera di unità, fare clic su di essa, fare clic su Modifica, selezionare la lettera di unità da utilizzare, quindi scegliere OK.

Per ulteriori informazioni sull'assegnazione delle lettere di unità, vedere "Assegnare, cambiare o rimuovere una lettera di unità " all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66764.


Impossibile accedere in modalità remota al Registro di sistema su un nodo cluster
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-04-13

L'installazione di Microsoft Exchange Server 2007 non può continuare perché non è stato possibile accedere al Registro di sistema di un nodo cluster.

L'installazione di Exchange 2007 richiede l'accesso al Registro di sistema di tutti i nodi del cluster per recuperare impostazioni di vario tipo.

Per risolvere il problema, procedere come segue:

  • Verificare che il servizio Registro di sistema sia in esecuzione su tutti i nodi del cluster.

  • Verificare che il servizio Condivisione file e stampanti per reti Microsoft sia abilitato per la scheda di rete elencata per prima nell'ordine di binding.

  • Verificare che i valori delle chiavi del Registro di sistema riportati di seguito siano gli stessi su ciascun nodo del cluster e che siano valide per i criteri di gruppo rilevanti:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanmanworkstation\parameters\RequireSecuritySignature

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters\EnableSecuritySignature

Per ulteriori informazioni sulla risoluzione dei problemi relativi alla connettività del Registro di sistema, vedere la sezione "Troubleshooting Registry Connectivity Issues" in "Microsoft Exchange Server Best Practices Analyzer Tool Troubleshooting Connectivity Problems" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=56285 (informazioni in lingua inglese).


Rimozione della sottoscrizione di Edge prima dell'installazione del ruolo del server
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-21

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il processo di disinstallazione del ruolo del server Trasporto Edge o Hub non è riuscito a causa della presenza di una sottoscrizione di Edge nel ruolo del server.

Si sottoscrive un server Trasporto Edge a un sito di Active Directory per associare il server all'organizzazione di Exchange. Il server Trasporto Edge sottoscritto viene contrassegnato con un attributo del sito di Active Directory. Tra l'altro, questa associazione consente di configurare la sottoscrizione di Edge come server di origine per i connettori di invio che vengono creati nell'organizzazione di Exchange. I server Trasporto Hub dell'organizzazione di Exchange utilizzano un connettore di invio intraorganizzativo implicito per instradare i messaggi di posta elettronica a Internet tramite il server Trasporto Edge sottoscritto. L'associazione ad Active Directory consente ai server Trasporto Hub di individuare il server Trasporto Edge a scopo di routing.

L'installazione di Exchange 2007 richiede che vengano rimosse tutte le sottoscrizioni di Edge per il ruolo del server Trasporto Edge di destinazione, o per l'ultimo ruolo del server Trasporto Hub di un sito, prima che si possa procedere con la disinstallazione del ruolo server Trasporto Edge o Hub.

Per risolvere l'errore, utilizzare il cmdlet Get-EdgeSubscription per recuperare le informazioni sulle sottoscrizioni di Edge e il cmdlet Remove-EdgeSubscription per rimuovere la sottoscrizione di Edge dal server di destinazione, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per identificare e rimuovere la sottoscrizione di Edge

  1. Seguire le istruzioni riportate nell'argomento relativo al cmdlet Get-EdgeSubscription all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86320 per identificare le sottoscrizioni di Edge per il server di destinazione.

  2. Seguire le istruzioni riportate nell'argomento relativo al cmdlet Remove-EdgeSubscription all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86321 per rimuovere la sottoscrizione di Edge dal server di destinazione.


L'FSMO dello schema non è Windows Server 2003 SP1 o versione successiva
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

Microsoft® Exchange Server Analyzer Tool esegue la verifica nella foresta del servizio directory di Active Directory® per conoscere la versione del sistema operativo in esecuzione sul master schema del controller di dominio di Active Directory. Se Microsoft Exchange Server Analyzer Tool rileva che il controllo di dominio del master operazioni di Active Directory, noto anche come Flexible Single Master Operations o FSMO, non esegue Microsoft Windows Server™ 2003 Service Pack 1 (SP1) o una versione successiva, verrà visualizzato un errore.

L'errore indica che per installare Microsoft Exchange Server 2007 e supportare le nuove strutture di autorizzazione è necessario Windows Server 2003 SP1 o una versione successiva.

Se il controller di dominio dell'FSMO dello schema di Active Directory non esegue Windows Server 2003 SP1 o una versione successiva, l'installazione di Microsoft Exchange Server 2007 non verrà eseguita.

Il messaggio rappresenta una verifica dei prerequisiti per la distribuzione di Microsoft Exchange Server 2007. Si consiglia di eseguire Windows Server 2003 SP1 sul master schema del controller di dominio di Active Directory se si intende installare Microsoft Exchange Server 2007.


Il master schema esegue Windows 2000 Server
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-01-08

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Sul controller di dominio assegnato al ruolo del master schema del servizio directory di Active Directory®, noto anche come FSMO (Flexible Single Master Operations), è in esecuzione Microsoft Windows® 2000 Server.

È necessario che il controller di dominio utilizzato come ruolo FSMO dello schema esegua Microsoft Windows Server™ 2003 Service Pack 1 (SP1) o versione successiva.

L'FSMO controlla tutte le modifiche e gli aggiornamenti apportati allo schema di Active Directory.

Per risolvere questo problema, aggiornare o spostare il controller di dominio FSMO su Windows Server 2003 SP1 o su una versione successiva del server ed eseguire nuovamente l'installazione di Microsoft Exchange.

Per ulteriori informazioni, consultare l'articolo 325379 della Microsoft Knowledge Base "Aggiornamento dei controller di dominio Windows 2000 a Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=325379.

Per ulteriori informazioni sul trasferimento del ruolo di master infrastrutture da un controller di dominio a un altro, consultare i seguenti articoli della Microsoft Knowledge Base:

  • Per Microsoft Windows Server™ 2003, consultare l'articolo 324801, "HOW TO: Visualizzare e trasferire i ruoli FSMO in Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=324801.

  • Per Microsoft Windows 2000 Server, consultare l'articolo 255690, "HOW TO: Visualizzare e trasferire i ruoli FSMO nell'interfaccia utente grafica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=3052&kbid=255690.


Il master schema non esegue Windows Server 2003 Service Pack 1 o versioni successive
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Il controller del dominio assegnato al ruolo master schema del servizio di directory Active Directory, noto anche come FSMO (Flexible Single Master Operation), non esegue Microsoft Windows Server 2003 Service Pack 1 (SP1) o versioni successive.

È necessario che il controller di dominio utilizzato come ruolo FSMO dello schema esegua Windows Server 2003 SP1 o versione successiva.

L'FSMO controlla tutte le modifiche e gli aggiornamenti apportati allo schema di Active Directory.

Per risolvere il problema, eseguire uno o più passaggi tra i seguenti:

  • Aggiornare il controller di dominio FSMO a Windows Server 2003 SP1 o versione successiva ed eseguire nuovamente l'installazione di Microsoft Exchange.

  • Se nell'organizzazione di Exchange esiste un controller di dominio FSMO che esegue Microsoft Windows Server 2003 Service Pack 1 (SP1) o una versione successiva, eseguire l'installazione di Exchange 2007 con il parametro /domaincontroller che fa riferimento a quel controller di dominio FSO.

    [/DomainController o /dc <FQDN del controller di dominio>]

    Utilizzare il parametro /DomainController per specificare il controller di dominio da usare per la lettura e la scrittura in Active Directory durante l'installazione. È possibile utilizzare NetBIOS o il formato del nome di dominio completo (FQDN).

Per ottenere il Service Pack più recente per Windows Server 2003, vedere "Windows Server TechCenter" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=45315.

Per ulteriori informazioni sui parametri di installazione di Exchange Server 2007, consultare "Come installare Exchange 2007 in modalità automatica" nella documentazione del prodotto Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86476.


Setup Cannot Install Exchange to a Read-Only Domain Controller
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-07-23

L'installazione di Microsoft Exchange Server 2007 non può continuare. Il computer di destinazione è un controller di dominio di sola lettura (RODC, Read-Only Domain Controller).

I controller di dominio di sola lettura sono una funzionalità di Active Directory di Windows Server 2008. RODC è un tipo di opzione di installazione di controller di dominio per i siti remoti che potrebbero avere livelli inferiori di protezione fisica.

L'installazione di Exchange richiede l'accesso in scrittura al computer di installazione di destinazione.

Per risolvere questo problema, selezionare un computer di installazione di destinazione che non sia designato come controller di dominio di sola lettura ed eseguire nuovamente l'installazione.


Si è verificato un errore durante l'installazione di un ruolo del server
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-04-12

L'installazione di Microsoft Exchange Server 2007 non può continuare perché si è verificato un errore precedente durante l'installazione di un ruolo del server.

Per poter continuare con le altre attività di installazione, l'installazione di Exchange 2007 richiede che l'installazione di un ruolo del server non riuscita venga rieseguita o che venga rimossa dal processo di installazione.

Per risolvere il problema, reinstallare solo il ruolo o i ruoli del server con l'errore oppure rimuovere i ruoli.

Per reinstallare il ruolo del server con l'errore dalla riga di comando

  1. Aprire una finestra del prompt dei comandi e passare ai file di installazione.

  2. Eseguire il seguente comando:

    Copia codice
    Setup /roles:<Failed Server Role>

    Selezionare uno o più ruoli tra quelli elencati di seguito, separandoli con la virgola:

    ClientAccess (o CA, o C)

    EdgeTransport (o ET, o E)

    Nota:
    Il ruolo del server Trasporto Edge non può coesistere sullo stesso computer con altri ruoli del server.
    Nota:
    È necessario distribuire il ruolo del server Trasporto Edge nella rete perimetrale e all'esterno della foresta Active Directory.

    HubTransport (o HT, o H)

    Mailbox (o MB, o M)

    UnifiedMessaging (o UM, o U)

    ManagementTools (o MT, o T)

    Nota:
    Se si specifica ManagementTools, verranno installati Exchange Management Console, i cmdlet di Exchange per Exchange Management Shell, il file della Guida di Exchange, Exchange Best Practices Analyzer Tool e Exchange Troubleshooting Assistant. Se si installa qualsiasi altro ruolo del server, verranno installati automaticamente gli strumenti di gestione.

    Ad esempio, per aggiungere il ruolo del server Trasporto Hub a un server di cassette postali esistente, digitare quanto segue: %LocalExchangeInstallationDir%\bin\Setup.com /role:HubTransport /Mode:Install

Nota:
Se qualsiasi ruolo del server di Exchange Server 2007 è stato precedentemente installato senza errori, l'Installazione guidata verrà eseguita in modalità manutenzione. Se nessun ruolo del server di Exchange 2007 è stato precedentemente installato senza errori, l'Installazione guidata riprenderà dal punto in cui si era interrotta.
Per utilizzare l'Installazione guidata di Exchange Server 2007 in modalità manutenzione per reinstallare il ruolo del server con l'errore

  1. Accedere al server per il quale si desidera reinstallare il ruolo del server.

  2. Aprire il Pannello di controllo e fare doppio clic su Installazione applicazioni.

  3. Nella pagina Cambia/Rimuovi programmi selezionare Microsoft Exchange Server, quindi fare clic su Cambia.

  4. Nell'Installazione guidata di Exchange Server 2007, nella pagina Modalità di manutenzione di Exchange fare clic su Avanti.

  5. Nella pagina Selezione ruolo server selezionare le caselle di controllo relative ai ruoli del server che si desidera installare, quindi fare clic su Avanti.

    Nota:
    Il ruolo del server Trasporto Edge non può coesistere sullo stesso computer con altri ruoli del server.
    Nota:
    È necessario distribuire il ruolo del server Trasporto Edge nella rete perimetrale e all'esterno della foresta Active Directory.
    Nota:
    Se si seleziona Strumenti di gestione, verranno installati Exchange Management Console, i cmdlet di Exchange relativi a Exchange Management Shell e il file della Guida di Exchange. Gli strumenti di gestione verranno installati automaticamente se si installa qualsiasi altro ruolo del server.

  6. Se è stato selezionato Ruolo Trasporto Hub e se si sta installando Exchange 2007 in una foresta che contiene un'organizzazione di Exchange Server 2003 o Exchange 2000 Server esistente, nella pagina Impostazioni flusso di posta selezionare un server testa di ponte nell'organizzazione esistente che sia un membro del gruppo di routing di Exchange 2003 o Exchange 2000 per il quale si desidera creare un connettore di gruppi di routing.

  7. Nella pagina Controllo conformità visualizzare lo stato per determinare se i controlli dei prerequisiti dell'organizzazione e del ruolo del server sono stati completati correttamente. In caso affermativo, fare clic su Installa per installare Exchange 2007.

  8. Nella pagina Completamento fare clic su Fine.
Per utilizzare l'Installazione guidata di Exchange Server 2007 per reinstallare il ruolo del server con errori se non è stato precedentemente installato nessun altro ruolo

  1. Seguire le istruzioni riportate in "Come eseguire un'installazione personalizzata utilizzando il Programma di installazione di Exchange Server 2007" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86648 nella documentazione del prodotto di Exchange Server 2007.
Per rimuovere il ruolo del server con errori

  1. Seguire le istruzioni riportate in "Come rimuovere i ruoli server di Exchange 2007" (http://go.microsoft.com/fwlink/?LinkId=86649) nella documentazione del prodotto di Exchange Server 2007.

Per ulteriori informazioni

Per ulteriori informazioni sull'installazione di Exchange 2007 in modalità automatica, vedere "Come installare Exchange 2007 in modalità automatica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86476.


Questo server è l'origine di un connettore di gruppi di routing
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il tentativo di rimuovere il ruolo del server Trasporto Hub non è riuscito. Il computer locale è l'origine di uno o più connettori di gruppi di routing dell'organizzazione di Exchange.

Il connettore di gruppi di routing viene utilizzato per inviare e ricevere messaggi tra i server Trasporto Hub di Exchange 2007 e i server testa di ponte di Exchange Server 2003 o Exchange 2000 Server. Quando Exchange Server 2007 è installato in un'organizzazione Exchange Server 2003 ed Exchange 2000 Server esistente, il connettore di gruppi di routing necessario viene creato durante l'installazione.

L'installazione di Exchange 2007 richiede che tutti i connettori di gruppi di routing di un'organizzazione di Exchange vengano spostati o eliminati dal computer server Trasporto Hub prima che il ruolo del server possa essere eliminato.

Per risolvere il problema, spostare o eliminare tutti i connettori di gruppi di routing dal computer locale, quindi eseguire nuovamente l'installazione.

Per spostare il connettore di gruppi di routing mediante Exchange Management Shell

  1. Utilizzare il cmdlet Set-RoutingGroupConnector per modificare le proprietà di un connettore di gruppi di routing esistente tra un gruppo di routing di Microsoft Exchange Server 2007 e un gruppo di routing di Exchange Server 2003 o Exchange 2000 Server.

  2. In questo esempio il cmdlet Set-RoutingGroupConnector viene utilizzato per modificare l'origine di un connettore di gruppi di routing.
Copia codice
Set-RoutingGroupConnector -Identity "[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name" -SourceTransportServers [FQDN of desired Hub Transport Server]
 Per rimuovere il connettore di gruppi di routing mediante Exchange Management Shell

  1. Utilizzare il cmdlet Remove-RoutingGroupConnector per rimuovere un connettore di gruppi di routing tra un gruppo di routing di Microsoft Exchange Server 2007 e un gruppo di routing di Exchange Server 2003 o Exchange 2000 Server.

  2. L'esempio seguente illustra come utilizzare il cmdlet Remove-RoutingGroupConnector per rimuovere il connettore di gruppi di routing specificato.
Copia codice
Remove-RoutingGroupConnector -Identity"[[Administrative Group Name\]Routing Group Name]\Routing Group Connector Name"

Per ulteriori informazioni sulla modifica o sulla rimozione di connettori di gruppi di routing, vedere i seguenti argomenti nella documentazione del prodotto di Exchange Server 2007:

  • Set-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86659).

  • Remove-RoutingGroupConnector (http://go.microsoft.com/fwlink/?LinkId=86660).


Il server è l'origine di un connettore di invio
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile proseguire con l'installazione di Microsoft Exchange Server 2007. Il tentativo di rimuovere il ruolo del server Trasporto Hub non è riuscito. Il computer locale è l'origine di uno o più connettori di invio nell'organizzazione di Exchange.

Un connettore di invio rappresenta un gateway logico tramite il quale sono inviati i messaggi in uscita.

Prima di poter eliminare il ruolo del server, è necessario che tutti i connettori di invio di un'organizzazione di Exchange siano spostati o eliminati dal computer del server Trasporto Hub.

Per risolvere il problema, spostare o eliminare tutti i connettori di invio dal computer locale, quindi eseguire nuovamente l'installazione.

Per ulteriori informazioni sulla modifica o la rimozione dei connettori di invio, vedere gli argomenti seguenti nella documentazione del prodotto relativa a Exchange Server 2007:

  • "Come rimuovere un connettore di invio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86655.

  • "Modifica della configurazione di un connettore di invio" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86656.


Modello organizzazione di Exchange semplice rilevato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-18

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare il numero di cassette postali sul server. Ciascun oggetto archivio delle cassette postali (classe msExchPrivateMDB) presenta un attributo multivalore homeMDBBL che indica tutte le cassette postali dell'archivio. Exchange Server Analyzer esegue il conteggio di tali valori per ottenere il numero totale di cassette postali sul server.

Esegue inoltre una query in Active Directory per determinare il numero di siti Active Directory contenenti server di Exchange e il numero di server che eseguono Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003. Exchange Server Analyzer infine esegue una query nell'oggetto Microsoft WMI (Strumentazione gestione Windows®) Win32_Service per determinare se il servizio cluster di Windows è presente ed è in esecuzione.

Exchange Server Analyzer classifica l'organizzazione di Exchange come organizzazione semplice se si verificano le condizioni riportate di seguito:

  • Le cassette postali dell'organizzazione sono meno di 1.000.

  • I server di Exchange sono installati solo in un sito Active Directory.

  • I computer che eseguono Exchange 2000 o Exchange 2003 sono meno di 3.

  • Non sono stati distribuiti server cluster di Exchange.

Dei quattro modelli di organizzazione definiti per Microsoft Exchange Server 2007, l'organizzazione semplice rappresenta la topologia di base in cui è possibile distribuire Exchange 2007. L'organizzazione di Exchange semplice contiene:

  • Un solo server di Exchange che fornisce tutti i servizi Exchange e archivia tutti i dati Exchange dell'intera organizzazione.

  • Più server di Exchange in una topologia che include server di elenchi in linea ridondanti e un server Edge Transport in una rete perimetrale.

Per eseguire la transizione di un'organizzazione di Exchange semplice a Exchange 2007

  1. Consultare la documentazione in linea del prodotto Exchange 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69434 (informazioni in lingua inglese).

  2. Espandere "Planning and Architecture," quindi "Planning Your Deployment" e fare clic su "Planning for a Simple Exchange Organization" (informazioni in lingua inglese).


Il protocollo SMTP è attualmente installato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-01-22

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il servizio SMTP (Simple Mail Transfer Protocol) di Microsoft Windows® Server™ 2003 è installato in questo computer.

È necessario che il servizio SMTP non sia installato in server utilizzati per Exchange 2007.

Per risolvere questo problema, disinstallare il servizio SMTP ed eseguire nuovamente l'installazione di Microsoft Exchange.

Per disinstallare il servizio SMTP utilizzando Installazione componenti di Windows nel Pannello di controllo

  1. Scegliere Pannello di controllo dal menu Start.

  2. Fare doppio clic su Installazione applicazioni.

  3. Fare clic su Installazione componenti di Windows.

  4. Dall'elenco Componenti selezionare la casella di controllo Server applicazioni, quindi fare clic su Dettagli.

  5. Selezionare Gestione Internet Information Services, quindi fare clic su Dettagli.

  6. Scegliere Servizio SMTP, quindi fare clic per deselezionare la casella di controllo.

  7. Fare clic su OK due volte per tornare all'elenco Componenti, quindi fare clic su Avanti.

  8. Una volta disinstallato il servizio SMTP, fare clic su Fine.


Il sito non può supportare i server Exchange 2007
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-11

Microsoft® Exchange Server Analyzer Tool ha visualizzato questo avviso perché nella foresta del servizio directory di Active Directory sono presenti siti che non dispongono di almeno un server di catalogo globale in esecuzione su Microsoft Windows Server™ 2003 Service Pack 1 (SP1) o versione successiva.

L'installazione di Microsoft Exchange Server 2007 richiede che ciascun sito Active Directory contenente un server con Exchange 2007 disponga di almeno un server di catalogo globale in esecuzione su Windows Server 2003 SP1 o versione successiva.

Per risolvere il problema eseguire l'aggiornamento di almeno un server di catalogo globale in ciascun sito Active Directory a Windows Server 2003 SP1 o versione successiva.

Per ulteriori informazioni sull'aggiornamento a Windows Server 2003, vedere l'articolo 810613 della Microsoft Knowledge Base "Percorsi di aggiornamento per Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=810613.

Per ottenere il Service Pack più recente di Windows Server 2003, vedere "Windows Server TechCenter" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=45315 (informazioni in lingua inglese).


Modello organizzazione di Exchange standard rilevato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-08-10

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per determinare:

  • Il numero di cassette postali nell'organizzazione.

  • Il numero di gruppi di routing nell'organizzazione.

  • Il numero di siti Active Directory nell'organizzazione.

  • Il numero di foreste di Active Directory nell'organizzazione.

  • Se è stato installato Microsoft Identity Integration Server (MIIS).

La quantità di ciascun elemento determina se il modello di organizzazione di Exchange sia semplice, standard, di grandi dimensioni o complesso. Qualsiasi organizzazione che non venga classificata come semplice, di grandi dimensioni o complessa, è automaticamente un'organizzazione di Exchange standard.

Dei quattro modelli di organizzazione definiti per Microsoft Exchange Server 2007, l'organizzazione standard rappresenta la topologia più comune in cui viene distribuito Exchange 2007. Poiché necessariamente il servizio di messaggistica crescerà oltre i limiti delle risorse di un solo computer, la separazione dei servizi di Exchange 2007 in più computer diventa la divisione topologica successiva, ovvero l'organizzazione di Exchange standard. L'organizzazione standard è basata sull'organizzazione semplice con distribuzione di più computer che eseguono Exchange.

Per eseguire la transizione di un'organizzazione di Exchange standard a Exchange 2007

  1. Consultare la documentazione in linea del prodotto Exchange 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=69434 (informazioni in lingua inglese).

  2. Espandere "Planning and Architecture," quindi "Planning Your Deployment" e fare clic su "Planning for a Standard Exchange Organization" (informazioni in lingua inglese).


In un cluster sono consigliabili indirizzi IP statici
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

È stato visualizzato questo avviso perché una o più interfacce di rete sono configurate per l'utilizzo del protocollo DHCP (Dynamic Host Configuration Protocol).

È consigliabile l'utilizzo di indirizzi IP statici per le interfacce di rete che gestiscono connessioni client e collegamenti heartbeat in un cluster di server Microsoft Windows. È sconsigliato, invece, l'utilizzo della configurazione dinamica tramite DHCP, in quanto il mancato rinnovo di un lease DHCP può compromettere il corretto funzionamento del cluster.

Per risolvere il problema, configurare ciascuna interfaccia di rete che gestisce connessioni client e collegamenti heartbeat per l'utilizzo di indirizzi IP statici.

Per configurare un indirizzo IP statico per una connessione di rete

  1. Nel menu Start scegliere Impostazioni, quindi Impostazioni di rete.

  2. Fare clic con il pulsante destro del mouse sulla connessione da configurare, quindi fare clic su Proprietà.

  3. Nella scheda Generale, in La connessione utilizza gli elementi seguenti fare clic su Protocollo Internet (TCP/IP), quindi su Proprietà.

  4. Fare clic su Utilizza il seguente indirizzo IP, quindi digitare l'indirizzo IP in Indirizzo IP.

  5. Fare clic su OK due volte per terminare.

Per ulteriori informazioni sulla configurazione di rete ottimale per i cluster di server Windows, consultare il documento "Cluster di server: raccomandazioni per la configurazione della rete su Windows 2000 e Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34304.

Per ulteriori informazioni sulla corretta configurazione heartbeat del cluster, consultare l'articolo 258750 della Microsoft Knowledge Base "Configurazione consigliata per la rete "heartbeat" privata su un server cluster" all'indirizzo http://go.microsoft.com/fwlink/?linkid=3052&kbid=258750.


Il percorso di archiviazione per un cluster a copia singola deve essere un disco di cluster
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il percorso di archiviazione per un cluster a copia singola deve essere un disco di cluster.

In Exchange Server 2007, un cluster a copia singola (SCC, Single Copy Cluster) è una soluzione in cluster che utilizza una copia singola di un gruppo di archiviazione condiviso tra i nodi del cluster.

Per risolvere il problema, specificare un'unità in cluster per il percorso dati, quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sui cluster a copia singola, vedere "Installazione di un cluster a copia singola" nella documentazione del prodotto di Exchange Server 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkId=76162.


Formato indirizzo SMTP non supportato
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

L'installazione di Microsoft Exchange Server 2007 non può continuare perché il criterio destinatario specificato utilizza un formato indirizzo SMTP (Simple Mail Transfer Protocol) non supportato.

L'installazione di Exchange 2007 richiede che tutti gli indirizzi SMTP utilizzati per i criteri degli indirizzi di posta elettronica non contengano valori letterali dell'indirizzo IP, ad esempio: utente@[10.10.1.1].

Per risolvere il problema, modificare il valore dell'indirizzo SMTP nel criterio destinatario in modo che non contenga un valore letterale dell'indirizzo IP. Sostituire le parentesi quadre ([]) e i numeri (10.10.1.1) del valore letterale dell'indirizzo IP con il formato di assegnazione nomi DNS (Domain Name System), ad esempio: utente@contoso.com, quindi eseguire nuovamente l'installazione di Exchange.

Per ulteriori informazioni sulla gestione dei criteri destinatario in Exchange Server 2007, vedere "Gestione dei criteri degli indirizzi di posta elettronica" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=86653.


Collegamenti al sito SMTP trovati
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-12-07

Microsoft® Exchange Server Analyzer Tool visualizza questo avviso se rileva collegamenti al sito basati su SMTP (Simple Mail Transfer Protocol) nel servizio directory di Active Directory®.

Il routing di Microsoft Exchange Server 2007 ignorerà i siti di Active Directory connessi mediante collegamenti al sito SMTP. Se Exchange 2007 viene installato in siti connessi solo da un collegamento al sito SMTP si verificheranno degli errori di routing.

Per risolvere il problema sostituire i collegamenti al sito SMTP con quelli basati su indirizzi IP.

Per ulteriori informazioni sui collegamenti al sito IP di Active Directory, vedere "Pianificazione dell'utilizzo dei siti Active Directory per il routing della posta" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=71803.


Specifica dell'unità del gruppo di archiviazione mancante
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-05-15

L'installazione di Microsoft® Exchange Server 2007 Disaster Recovery non può continuare. Non è possibile accedere alla specifica dell'unità del database del gruppo di archiviazione utilizzata nell'installazione precedente di questo server.

Sono necessarie le stesse specifiche dell'unità del database del gruppo di archiviazione utilizzate in precedenza affinché il server sia disponibile nel corso del ripristino.

Per risolvere questa situazione, configurare le unità affinché corrispondano alla configurazione originale dell'unità logica, quindi eseguire nuovamente l'installazione di Microsoft Exchange Disaster Recovery.

Assegnare o modificare una lettera di unità

  1. Aprire Gestione computer (locale).

  2. Nella struttura della console fare clic su Gestione computer (locale), Archiviazione, quindi Gestione disco.

  3. Fare clic con il pulsante destro del mouse su una partizione, unità logica o volume, quindi fare clic su Cambia lettera e percorso di unità.

  4. Utilizzare una delle seguenti procedure:

    • Per assegnare una lettera di unità fare clic su Aggiungi, fare clic sulla lettera di unità da utilizzare, quindi su OK.

    • Per modificare una lettera di unità, fare clic su di essa, fare clic su Modifica, selezionare la lettera di unità da utilizzare, quindi scegliere OK.

Per ulteriori informazioni sull'assegnazione delle lettere di unità, vedere "Assegnare, cambiare o rimuovere una lettera di unità " all'indirizzo http://go.microsoft.com/fwlink/?LinkId=66764.


Mancata corrispondenza tra i percorsi di installazione di destinazione
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare con l'installazione di Microsoft Exchange Server 2007. Il percorso di destinazione dei file binari di Exchange non corrisponde al percorso di installazione di Exchange esistente su altri nodi cluster.

I nodi dello stesso cluster devono includere percorsi di installazione di destinazione dei file binari di Exchange coerenti.

Per risolvere il problema, utilizzare un percorso di installazione di destinazione per i file binari di Exchange coerente in tutti i nodi del cluster.

Per ulteriori informazioni sulle installazioni di Exchange Server 2007 a disponibilità elevata, consultare "Disponibilità elevata" all'indirizzo http://go.microsoft.com/fwlink/?linkid=68190 nella documentazione del prodotto Exchange Server 2007.


Il percorso di destinazione è compresso
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-06

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Il percorso della cartella di destinazione per l'installazione di Microsoft Exchange è compresso.

È necessario che la prima cartella nel percorso di destinazione dell'installazione non sia compressa. Per impostazione predefinita, la prima cartella nel percorso di destinazione dell'installazione è C:\Programmi.

Per risolvere questo problema, disabilitare la compressione per la prima cartella nel percorso di destinazione ed eseguire nuovamente l'installazione di Exchange 2007.

Per disabilitare la compressione del percorso di destinazione

  1. In Risorse del computer o Esplora risorse fare clic con il pulsante destro del mouse sulla cartella da decomprimere.

  2. Fare clic su Proprietà per visualizzare la finestra di dialogo Proprietà.

  3. Nella scheda Generale scegliere Avanzate.

  4. Nella finestra di dialogo Attributi avanzati deselezionare la casella di controllo Comprimi contenuto per risparmiare spazio su disco quindi fare clic su OK.

  5. Nella finestra di dialogo Proprietà fare clic su OK.

  6. Quando lo stato di compressione della cartella è stato modificato, nella finestra di dialogo Conferma cambiamenti attributi selezionare Applica cambiamenti a cartella, a tutte le sottocartelle e a tutti i file.

  7. Al termine fare clic su OK.


Sono consigliate due o più interfacce di rete in un cluster
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

Questo avviso viene visualizzato perché l'ambiente cluster Microsoft Windows dispone di una sola interfaccia di rete definita.

Si consiglia di implementare almeno un'interfaccia di rete per la rete pubblica (connessione client) e una per la rete privata (amministrativa/heartbeat) per evitare un singolo punto di errore.

Per risolvere il problema, implementare almeno un'interfaccia di rete aggiuntiva per il cluster Microsoft Windows.

Per ulteriori informazioni sulla configurazione di rete ottimale per i cluster dei server Windows, consultare il documento "Server Clusters: raccomandazioni per la configurazione della rete su Windows 2000 e Windows Server 2003" all'indirizzo http://go.microsoft.com/fwlink/?linkid=34304.


Impossibile connettersi al servizio Registro di sistema remoto
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-01-23

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Impossibile accedere al Registro di sistema sul computer locale.

L'installazione di Exchange 2007 richiede l'accesso al Registro di sistema locale per il recupero di varie impostazioni.

L'installazione di Exchange tenta di utilizzare Domain Name System (DNS) per ottenere il nome di dominio completo (FQDN) del computer locale per accedere al Registro di sistema.

L'installazione non è riuscita a recuperare il nome di dominio completo (FQDN) dal DNS a causa di un errore di rete oppure non è riuscita ad accedere al Registro di sistema.

Per risolvere il problema, verificare che il servizio Registro di sistema remoto sia in esecuzione sul computer locale e che la funzione di condivisione di file e stampanti sia abilitata sulla prima scheda di rete nell'ordine di binding, quindi eseguire nuovamente l'installazione di Exchange.

Per verificare che il servizio Registro di sistema remoto sia in esecuzione

  1. Fare clic su Start, scegliere Impostazioni, Pannello di controllo, Strumenti di amministrazione e fare doppio clic su Servizi.

  2. Verificare che lo stato del servizio Registro di sistema remoto sia Avviato.
Per abilitare la Condivisione file e stampanti sulla scheda di rete primaria

  1. Fare clic su Start, scegliere Impostazioni, Pannello di controllo, Connessioni di rete, quindi Connessione alla rete locale (LAN).

  2. Verificare che la funzionalità Condivisione file e stampanti per reti Microsoft sia abilitata, ovvero che la casella di controllo sia selezionata.
Nota:
Se il server è un server cluster, è necessario verificare che il servizio Registro di sistema remoto sia in esecuzione su tutti i nodi del cluster e che la funzionalità Condivisione file e stampanti per reti Microsoft sia abilitata per la scheda di rete elencata per prima nell'ordine di binding.


Necessario aggiornamento del codec audio vocale di Windows Media
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-07-13

L'installazione di Microsoft® Exchange Server 2007 non può continuare perché il codec audio vocale di Windows Media non è installato o è disponibile una versione più recente.

L'installazione di Microsoft Exchange Server 2007 necessita della versione più recente del codec audio cocale di Windows Media. Il codec audio vocale di Windows Media è necessario per supportare il ruolo del server di messaggistica unificata di Exchange Server 2007.

Per risolvere il problema, installare la versione più recente del codec audio vocale di Windows Media da http://go.microsoft.com/fwlink/?LinkId=67407 e rieseguire l'installazione di Microsoft Exchange Server 2007.


Necessario aggiornamento di Windows Media Encoder
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-07-13

L'installazione di Microsoft® Exchange Server 2007 non può continuare perché Microsoft Windows Media Encoder non è installato o è disponibile una versione più recente.

L'installazione di Microsoft Exchange Server 2007 necessita della versione più recente di Windows Media Encoder sul server. Windows Media Encoder è necessario per supportare il ruolo del server di messaggistica unificata di Microsoft Exchange Server 2007.

Per risolvere il problema, installare la versione più recente di Windows Media Encoder da http://go.microsoft.com/fwlink/?LinkId=67406 e rieseguire l'installazione di Microsoft Exchange Server 2007.


Il servizio Pubblicazione sul Web è disabilitato o mancante
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-02-14

L'installazione di Microsoft® Exchange Server 2007 non può continuare. Nel tentativo di installare il ruolo Mailbox Server o Client Access è stato rilevato che il servizio Pubblicazione sul Web è disabilitato o non installato in questo computer.

È necessario che nel computer in cui si sta installando Microsoft Exchange il servizio Pubblicazione sul Web sia installato e non disabilitato.

Per risolvere questo problema, verificare che il servizio Pubblicazione sul Web sia installato e non disabilitato nel computer locale, quindi eseguire nuovamente l'installazione di Microsoft Exchange.

Per verificare che il servizio Pubblicazione sul Web è installato e non disabilitato

  1. Fare clic con il pulsante destro del mouse su Risorse del computer nel desktop, quindi scegliere Gestione.

  2. Espandere il nodo Servizi e applicazioni, quindi fare clic sul nodo Servizi.

  3. Nel riquadro destro individuare il Servizio Pubblicazione sul Web.

    Se il servizio Pubblicazione sul Web non viene visualizzato nell'elenco dei servizi installati, procedere come segue per installarlo.

  4. Se il servizio Pubblicazione sul Web viene visualizzato con uno stato diverso da Avviato, procedere come segue per avviarlo.

  5. Fare clic con il pulsante destro del mouse su Servizio Pubblicazione sul Web, quindi su Proprietà.

  6. Verificare che il Tipo di avvio sia impostato su Automatico e lo Stato del servizio su Avviato.

  7. Fare clic su Applica, quindi su OK.
Per installare il servizio Pubblicazione sul Web

  1. Dal menu Start, selezionare Impostazioni, Pannello di controllo, quindi fare clic su Installazione applicazioni.

  2. Fare clic su Installazione componenti di Windows.

  3. Dall'elenco Componenti selezionare la casella di controllo Server applicazioni, quindi fare clic su Dettagli.

  4. Selezionare Gestione Internet Information Services, quindi fare clic su Dettagli.

  5. Scegliere Servizio Web, quindi selezionare la casella di controllo.

  6. Fare clic su OK due volte per tornare all'elenco Componenti, quindi fare clic su Avanti.

  7. Una volta installato il servizio IIS, fare clic su Fine.


Disinstallazione dei supporti per le lingue della messaggistica unificata
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-16

L'installazione di Microsoft Exchange Server 2007 non può continuare perché l'aggiornamento del ruolo del server Messaggistica unificata non è riuscito.

L'installazione di Exchange richiede che tutti i supporti per le lingue, eccetto il supporto per l'inglese (Stati Uniti), vengano disinstallati prima che l'aggiornamento del ruolo del server Messaggistica unificata possa continuare.

I supporti per le lingue della messaggistica unificata inclusi in Exchange 2007 contengono menu vocali preregistrati per il supporto della conversione della sintesi vocale per una determinata lingua.

I supporti per le lingue della messaggistica unificata di Exchange 2007 consentono ai chiamanti e agli utenti di Outlook Voice Access di interagire con il sistema di messaggistica unificata in più lingue.

I supporti per le lingue diversi dall'inglese (Stati Uniti) esistenti devono essere disinstallati in modo da poter installare nuovi supporti.

Per risolvere il problema, disinstallare tutti i supporti per le lingue del ruolo del server Messaggistica unificata, eccetto il supporto per l'inglese (Stati Uniti), quindi eseguire nuovamente l'installazione di Exchange 2007.

Per ulteriori informazioni sulla disinstallazione dei supporti per le lingue del ruolo del server Messaggistica unificata, vedere Come rimuovere il supporto lingue della messaggistica unificata da un server Unified Messaging nella documentazione del prodotto di Exchange 2007.


È necessario l'aggiornamento per il ripristino di emergenza
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2007-03-27

Impossibile continuare proseguire con il ripristino di emergenza di Microsoft Exchange Server 2007. Per installare Exchange Server in questo computer, è stata utilizzata una versione più aggiornata di Exchange Server 2007.

La versione di Exchange Server 2007 utilizzata per eseguire un ripristino di emergenza di Microsoft Exchange deve essere uguale o successiva a quella utilizzata inizialmente per installare Exchange Server.

Per risolvere questo problema, avviare il ripristino di emergenza di Exchange Server 2007 utilizzando una versione di Exchange Server 2007 uguale o successiva a quella utilizzata inizialmente per installare Exchange Server.


Connettore X.400 nella topologia
Articoli su Microsoft Exchange Server Analyzer > Preparazione di Microsoft Exchange Server 2007 >

Ultima modifica: 2006-06-05

Microsoft® Exchange Server Analyzer Tool esegue una query nel servizio directory di Active Directory® per verificare la presenza di connettori X.400. Se Microsoft Exchange Server Analyzer Tool rileva la presenza di connettori X.400 nell'organizzazione di Microsoft Exchange, verrà visualizzato un avviso. L'avviso indica che il connettore X.400, un protocollo utilizzato per trasportare i messaggi tra sistemi di messaggistica precedenti, non è supportato in Microsoft Exchange Server 2007.

In Microsoft Exchange 2000 Server e Microsoft Exchange Server 2003, il protocollo SMTP è stato impostato come protocollo di trasporto predefinito. Benché i connettori X.400 siano supportati in Microsoft Exchange 2000 Server e Microsoft Exchange Server 2003, non sono supportati in Microsoft Exchange Server 2007 perché sempre meno utilizzati nel corso degli anni. Se si necessita del supporto per connettori X.400, si consiglia di tenere un server di Microsoft Exchange 2000 Server o Microsoft Exchange Server 2003. In alternativa, è possibile sostituire il connettore X.400 con il protocollo SMTP.

Per ulteriori informazioni sull'architettura di trasporto X.400 in Exchange Server 2003, vedere "Guida al trasporto e al routing di Exchange Server" all'indirizzo http://go.microsoft.com/fwlink/?LinkId=65578.

Per ulteriori informazioni sull'implementazione del connettore X.400 in Exchange Server 2003, vedere l'articolo "Implementing the X.400 Connector - Is It Worth Using with Exchange Server 2003?" all'indirizzo http://www.msexchange.org/tutorials/X400-Connector-Exchange-Server-2003.html (in inglese)

Nota:
Le informazioni su siti Web di terze parti presenti all'interno di questo argomento sono fornite allo scopo di aiutare l'utente a reperire le informazioni tecniche di cui necessita. Gli URL sono soggetti a modifiche senza preavviso.


Informazioni legali

Ultima modifica: 2007-04-06

Le informazioni contenute nel presente documento, inclusi gli URL e gli altri riferimenti a siti Web su Internet, sono soggette a modifiche senza preavviso. Se non specificato diversamente, le aziende, le organizzazioni, i prodotti, i nomi dei domini, gli indirizzi di posta elettronica, i loghi, le persone, i luoghi e gli eventi degli esempi riportati nel documento sono fittizi e ogni riferimento a aziende, organizzazioni, prodotti, nomi di domini, indirizzi di posta elettronica, loghi, persone, luoghi o eventi reali è puramente casuale. Il rispetto di tutte le applicabili leggi in materia di copyright è esclusivamente a carico dell'utente. Fermi restando tutti i diritti coperti da copyright, nessuna parte di questo documento potrà comunque essere riprodotta o inserita in un sistema di riproduzione o trasmessa in qualsiasi forma e con qualsiasi mezzo (in formato elettronico, meccanico, su fotocopia, come registrazione o altro) per qualsiasi scopo, senza il permesso scritto di Microsoft Corporation.

Microsoft può essere titolare di brevetti, domande di brevetto, marchi, copyright o altri diritti di proprietà intellettuale relativi all'oggetto del presente. Salvo quanto espressamente previsto in un contratto scritto di licenza Microsoft, la consegna del presente documento non implica la concessione di alcuna licenza su tali brevetti, marchi, copyright o altra proprietà intellettuale.

© 2004-2006 Microsoft Corporation. Tutti i diritti riservati.

Microsoft, Active Directory, ActiveSync, ActiveX, MSDN, Outlook, SharePoint, Visual C++, Win32, Windows, Windows NT, Windows Server e Windows Server System sono marchi o marchi registrati di Microsoft Corporation negli Stati Uniti e/o negli altri paesi.

I nomi delle società e dei prodotti citati nel presente documento possono essere marchi dei rispettivi proprietari.